Getting Started

XdsObjects Help file
Getting Started

XdsObjects is a toolkit to allow developers to develop applications using the IHE XDS and XDS-I profiles, with minimal investment in time and effort, since all the hard work of complying with the profile and ebXML rules is handled by the toolkit.

It provides both client and server support for all roles, including (as of version 6.1) for acting as a registry.

The best way to get started is to use the examples on the web at: http://www.medicalconnections.co.uk/XdsObjects_Examples, but here is some general guidance about the structure of the objects:

XdsDomain

This is the key to using XdsObjects, and hold vital global information such as:

  • The registry URI
  • The list of repositories and how they may map from their OIDs
  • The audit repositories to use
  • The "global" patient root OID
  • The repository to submit newly created data to
Document Source Usage
Your main work will revolve around constructing an XdsSubmissionSet object and populating with properly completed XdsDocument objects, tthen using XdsDomain.ProvideAndRegsiterDocumentSet to submit to the chosen repository.
Document Consumer Usage
Your main work will revolve around constructing XdsQuerrequest objects and submitting them to the registry. It is important to have the OID to repository mappings completed for retrieval
Server Usage

Due to the way that Windows works, it is necessary to use 2 different classes to handle the incoming data -

  • transactions with "bulk" data such as ProvideAndRegister uses the MTOM encoding, and you use the XdsMtomServer Class
  • transactions without "bulk" data such as registry queries use the XdsSoapServer Class
Router Usage
Nauturally, this is a combination of the above
XDS-I
This is possible both as client and server, using the XdsImagingClient Class and XdsImagingServer Class respectively. See Use With DicomObjects for details of how it may be handled with or without DicomObjects.

This is only a brief outline, and the examples ar ethe best starting point, but if you have any questions, contact support@medicalconnections.co.uk

© Medical Connections Ltd 2015. All Rights Reserved.

Send Feedback


Security.6.40 Assembly

Security.6.40 Assembly
This assembly holds classes which act as bridges between the Medical Connections main products (DicomObjects and XdsObjects) and underlying security mechanisms such as the native Windows functions or the alternative BouncyCastle security mechanisms. The interfaces are fully public, allowing alternatives to be written very easily if required.
Namespaces
Namespace | Description
MedicalConnections.Security | The main namespace holds most classes that are used directly in user code. The other namespaces hold subsidiary definitions, to keep the main namespace "clean", which makes Intellisense function more intuitively.
MedicalConnections.Security.Delegates | The delegates used for the definition of events
MedicalConnections.Security.Enums | The various enumerations used by the security layer
MedicalConnections.Security.EventArguments | Specific classes passed to events


MedicalConnections.Security Namespace

MedicalConnections.Security Namespace
Inheritance Hierarchy
The main namespace holds most classes that are used directly in user code. The other namespaces hold subsidiary definitions, to keep the main namespace "clean", which makes Intellisense function more intuitively.
Classes
 | Class | Description
Class | TlsBouncyCastle | Common implmentation of BounctCastle code, shared by TlsClientBouncyCastle and TlsServerBouncyCastle
Class | TlsClientBouncyCastle | Implementation of ITlsClientSecurity based on the BouncyCastle API
Class | TlsClientNone | Impelementation of ITlsClientSecurity which does not use TLS
Class | TlsClientWindows | Impelementation of ITlsClientSecurity based on Windows interfaces
Class | TlsServerBouncyCastle | Server implementing TLS, based on the BouncyCastle implementation
Class | TlsServerWindows | The TlsServerWindows class incorporates the .NET security features needed to establish secure DICOM connection as an association Acceptor
Interfaces
 | Interface | Description
Interface | ITlsBase | Base interface, used by ITlsServerSecurity and ITlsClientSecurity
Interface | ITlsClientSecurity | Interface used to generalise access to secure communications as a client/initiator
Interface | ITlsServerSecurity | Standard interface to provide security and encryption for servers
See Also

Reference

Security.6.40 Assembly


TlsBouncyCastle Class

TlsBouncyCastle Class
Members

MedicalConnections.Security Namespace : TlsBouncyCastle Class
Common implmentation of BounctCastle code, shared by TlsClientBouncyCastle and TlsServerBouncyCastle
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class TlsBouncyCastle
   Implements ITlsBase
Dim instance As TlsBouncyCastle
public class TlsBouncyCastle : ITlsBase
public ref class TlsBouncyCastle : public ITlsBase
Inheritance Hierarchy

System.Object
MedicalConnections.Security.TlsBouncyCastle
MedicalConnections.Security.TlsClientBouncyCastle
MedicalConnections.Security.TlsServerBouncyCastle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsBouncyCastle Members
MedicalConnections.Security Namespace


TlsBouncyCastle Class Members

TlsBouncyCastle Class Members
Properties Methods

MedicalConnections.Security Namespace : TlsBouncyCastle Class

The following tables list the members exposed by TlsBouncyCastle.

Public Constructors
 | Name | Description
Public Constructor | TlsBouncyCastle Constructor | Construct a new TlsBouncyCastle object
Top
Public Properties
 | Name | Description
Public Property | CheckCRL | Controls whether or not to check certificate revokation lists
Public Property | CheckHostName | Controls whether or not to check host names against their certificates
Public Property | RemoteHostName | The remote host name
Top
Protected Properties
 | Name | Description
Protected Property | TrustedRoots | The list of trusted root certificates
Top
Public Methods
 | Name | Description
Public Method | AddTrustedRoot | Add a certificate to the list of TrustedRoots
Public Method | LoadFromPfx | Load the local certificate from a PFX/P12 file, plus a password
Public Method | SetCertificateFromByteArray | Load the local certificate from arrays containg the public and private keys, plus a password
Top
See Also

Reference

TlsBouncyCastle Class
MedicalConnections.Security Namespace


TlsBouncyCastle Constructor

TlsBouncyCastle Constructor

MedicalConnections.Security Namespace > TlsBouncyCastle Class : TlsBouncyCastle Constructor
Construct a new TlsBouncyCastle object
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New TlsBouncyCastle()
public TlsBouncyCastle()
public:
TlsBouncyCastle();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsBouncyCastle Class
TlsBouncyCastle Members


TlsBouncyCastle Class Methods

TlsBouncyCastle Class Methods

MedicalConnections.Security Namespace : TlsBouncyCastle Class

For a list of all members of this type, see TlsBouncyCastle members.

Public Methods
 | Name | Description
Public Method | AddTrustedRoot | Add a certificate to the list of TrustedRoots
Public Method | LoadFromPfx | Load the local certificate from a PFX/P12 file, plus a password
Public Method | SetCertificateFromByteArray | Load the local certificate from arrays containg the public and private keys, plus a password
Top
See Also

Reference

TlsBouncyCastle Class
MedicalConnections.Security Namespace


AddTrustedRoot Method

AddTrustedRoot Method

MedicalConnections.Security Namespace > TlsBouncyCastle Class : AddTrustedRoot Method
The certificate as a byte array
Add a certificate to the list of TrustedRoots
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub AddTrustedRoot( _
   ByVal RootCertificate() As Byte _
)
Dim instance As TlsBouncyCastle
Dim RootCertificate() As Byte

instance.AddTrustedRoot(RootCertificate)
public void AddTrustedRoot(
   byte[] RootCertificate
)
public:
void AddTrustedRoot(
   array<byte>^ RootCertificate
)

Parameters

RootCertificate
The certificate as a byte array
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsBouncyCastle Class
TlsBouncyCastle Members


LoadFromPfx Method

LoadFromPfx Method

MedicalConnections.Security Namespace > TlsBouncyCastle Class : LoadFromPfx Method
The contents of a PFX/P12 file
The password for the private key
Load the local certificate from a PFX/P12 file, plus a password
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub LoadFromPfx( _
   ByVal PfxData() As Byte, _
   ByVal Password As String _
)
Dim instance As TlsBouncyCastle
Dim PfxData() As Byte
Dim Password As String

instance.LoadFromPfx(PfxData, Password)
public void LoadFromPfx(
   byte[] PfxData,
   string Password
)
public:
void LoadFromPfx(
   array<byte>^ PfxData,
   String^ Password
)

Parameters

PfxData
The contents of a PFX/P12 file
Password
The password for the private key
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsBouncyCastle Class
TlsBouncyCastle Members


SetCertificateFromByteArray Method

SetCertificateFromByteArray Method

MedicalConnections.Security Namespace > TlsBouncyCastle Class : SetCertificateFromByteArray Method
The public key
The private key
The password for the private key
Load the local certificate from arrays containg the public and private keys, plus a password
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub SetCertificateFromByteArray( _
   ByVal ClientCertificateAsArray() As Byte, _
   ByVal ClientPrivateKeyAsArray() As Byte, _
   ByVal Password As String _
)
Dim instance As TlsBouncyCastle
Dim ClientCertificateAsArray() As Byte
Dim ClientPrivateKeyAsArray() As Byte
Dim Password As String

instance.SetCertificateFromByteArray(ClientCertificateAsArray, ClientPrivateKeyAsArray, Password)
public void SetCertificateFromByteArray(
   byte[] ClientCertificateAsArray,
   byte[] ClientPrivateKeyAsArray,
   string Password
)
public:
void SetCertificateFromByteArray(
   array<byte>^ ClientCertificateAsArray,
   array<byte>^ ClientPrivateKeyAsArray,
   String^ Password
)

Parameters

ClientCertificateAsArray
The public key
ClientPrivateKeyAsArray
The private key
Password
The password for the private key
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsBouncyCastle Class
TlsBouncyCastle Members


TlsBouncyCastle Class Properties

TlsBouncyCastle Class Properties

MedicalConnections.Security Namespace : TlsBouncyCastle Class

For a list of all members of this type, see TlsBouncyCastle members.

Public Properties
 | Name | Description
Public Property | CheckCRL | Controls whether or not to check certificate revokation lists
Public Property | CheckHostName | Controls whether or not to check host names against their certificates
Public Property | RemoteHostName | The remote host name
Top
Protected Properties
 | Name | Description
Protected Property | TrustedRoots | The list of trusted root certificates
Top
See Also

Reference

TlsBouncyCastle Class
MedicalConnections.Security Namespace


CheckCRL Property (TlsBouncyCastle)

CheckCRL Property (TlsBouncyCastle)

MedicalConnections.Security Namespace > TlsBouncyCastle Class : CheckCRL Property
Controls whether or not to check certificate revokation lists
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property CheckCRL As Boolean
Dim instance As TlsBouncyCastle
Dim value As Boolean

instance.CheckCRL = value

value = instance.CheckCRL
public bool CheckCRL {get; set;}
public:
property bool CheckCRL {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsBouncyCastle Class
TlsBouncyCastle Members


CheckHostName Property (TlsBouncyCastle)

CheckHostName Property (TlsBouncyCastle)

MedicalConnections.Security Namespace > TlsBouncyCastle Class : CheckHostName Property
Controls whether or not to check host names against their certificates
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property CheckHostName As Boolean
Dim instance As TlsBouncyCastle
Dim value As Boolean

instance.CheckHostName = value

value = instance.CheckHostName
public bool CheckHostName {get; set;}
public:
property bool CheckHostName {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsBouncyCastle Class
TlsBouncyCastle Members


RemoteHostName Property

RemoteHostName Property

MedicalConnections.Security Namespace > TlsBouncyCastle Class : RemoteHostName Property
The remote host name
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property RemoteHostName As String
Dim instance As TlsBouncyCastle
Dim value As String

instance.RemoteHostName = value

value = instance.RemoteHostName
public string RemoteHostName {get; set;}
public:
property String^ RemoteHostName {
   String^ get();
   void set (    String^ value);
}
Remarks
This is used for checking certificate against the actual host if CheckHostName is true
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsBouncyCastle Class
TlsBouncyCastle Members


TrustedRoots Property

TrustedRoots Property

MedicalConnections.Security Namespace > TlsBouncyCastle Class : TrustedRoots Property
The list of trusted root certificates
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Protected Property TrustedRoots As List(Of X509Certificate)
Dim instance As TlsBouncyCastle
Dim value As List(Of X509Certificate)

instance.TrustedRoots = value

value = instance.TrustedRoots
protected List<X509Certificate> TrustedRoots {get; set;}
protected:
property List<X509Certificate^>^ TrustedRoots {
   List<X509Certificate^>^ get();
   void set (    List<X509Certificate^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsBouncyCastle Class
TlsBouncyCastle Members


TlsClientBouncyCastle Class

TlsClientBouncyCastle Class
Members

MedicalConnections.Security Namespace : TlsClientBouncyCastle Class
Implementation of ITlsClientSecurity based on the BouncyCastle API
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class TlsClientBouncyCastle
   Inherits TlsBouncyCastle
   Implements ITlsBase, ITlsClientSecurity
Dim instance As TlsClientBouncyCastle
public class TlsClientBouncyCastle : TlsBouncyCastle, ITlsBase, ITlsClientSecurity
public ref class TlsClientBouncyCastle : public TlsBouncyCastle, ITlsBase, ITlsClientSecurity
Inheritance Hierarchy

System.Object
MedicalConnections.Security.TlsBouncyCastle
MedicalConnections.Security.TlsClientBouncyCastle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientBouncyCastle Members
MedicalConnections.Security Namespace


TlsClientBouncyCastle Class Members

TlsClientBouncyCastle Class Members
Properties Methods

MedicalConnections.Security Namespace : TlsClientBouncyCastle Class

The following tables list the members exposed by TlsClientBouncyCastle.

Public Constructors
 | Name | Description
Public Constructor | TlsClientBouncyCastle Constructor | Construct a new TlsClientBouncyCastle object
Top
Public Properties
 | Name | Description
Public Property | CheckCRL | Controls whether or not to check certificate revokation lists (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Public Property | CheckHostName | Controls whether or not to check host names against their certificates (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Public Property | HttpProvider | The mechanism used to handle HTTP requests using this security object
Public Property | RemoteHostName | The remote host name (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Public Property | TlsCipherSuite | The List of Ciphers to Propose
Top
Protected Properties
 | Name | Description
Protected Property | TrustedRoots | The list of trusted root certificates (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Top
Public Methods
 | Name | Description
Public Method | AddTrustedRoot | Add a certificate to the list of TrustedRoots (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Public Method | LoadFromPfx | Load the local certificate from a PFX/P12 file, plus a password (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Public Method | ModifyBindings | Overridable method to allow implementation of custom bindings
Public Method | ModifyCredentials | Overridable method to allow implementation of custom authentication arrangements
Public Method | OpenStream | Create an encrypted stream, based on a newly created "outer" stream
Public Method | SetCertificateFromByteArray | Load the local certificate from arrays containg the public and private keys, plus a password (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Public Method | TlsStream | Create an encrypted stream, based on the provided "outer" stream
Top
See Also

Reference

TlsClientBouncyCastle Class
MedicalConnections.Security Namespace


TlsClientBouncyCastle Constructor

TlsClientBouncyCastle Constructor

MedicalConnections.Security Namespace > TlsClientBouncyCastle Class : TlsClientBouncyCastle Constructor
Construct a new TlsClientBouncyCastle object
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New TlsClientBouncyCastle()
public TlsClientBouncyCastle()
public:
TlsClientBouncyCastle();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientBouncyCastle Class
TlsClientBouncyCastle Members


TlsClientBouncyCastle Class Methods

TlsClientBouncyCastle Class Methods

MedicalConnections.Security Namespace : TlsClientBouncyCastle Class

For a list of all members of this type, see TlsClientBouncyCastle members.

Public Methods
 | Name | Description
Public Method | AddTrustedRoot | Add a certificate to the list of TrustedRoots (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Public Method | LoadFromPfx | Load the local certificate from a PFX/P12 file, plus a password (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Public Method | ModifyBindings | Overridable method to allow implementation of custom bindings
Public Method | ModifyCredentials | Overridable method to allow implementation of custom authentication arrangements
Public Method | OpenStream | Create an encrypted stream, based on a newly created "outer" stream
Public Method | SetCertificateFromByteArray | Load the local certificate from arrays containg the public and private keys, plus a password (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Public Method | TlsStream | Create an encrypted stream, based on the provided "outer" stream
Top
See Also

Reference

TlsClientBouncyCastle Class
MedicalConnections.Security Namespace


ModifyBindings Method (TlsClientBouncyCastle)

ModifyBindings Method (TlsClientBouncyCastle)
Example

MedicalConnections.Security Namespace > TlsClientBouncyCastle Class : ModifyBindings Method
Details of the existing (modifiable) bindings and the connection being made
Overridable method to allow implementation of custom bindings
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overridable Sub ModifyBindings( _
   ByVal args As ModifyBindingsArgs _
)
Dim instance As TlsClientBouncyCastle
Dim args As ModifyBindingsArgs

instance.ModifyBindings(args)
public virtual void ModifyBindings(
   ModifyBindingsArgs args
)
public:
virtual void ModifyBindings(
   ModifyBindingsArgs^ args
)

Parameters

args
Details of the existing (modifiable) bindings and the connection being made
Remarks

This provides an extensible and flexible method to allow the bindings to be modified - e.g. (in conjunction with ModifyCredentials) the code in the example could be used to use Basic Authentication.

All the implementations of this method in the intrinsic MedicalConnections.Security classes do nothing.

Example
  • C#
class MySecurity
{
    class MySecurity : TlsClientWindows
    {
        public override void ModifyBindings(ModifyBindingsArgs args)
        {
            foreach (BindingElement b in args.Bindings)
            {
                if (b is HttpsTransportBindingElement)
                    (b as HttpsTransportBindingElement).AuthenticationScheme = System.Net.AuthenticationSchemes.Basic;
            }
        }

        public override void ModifyCredentials(ModifyCredentialArgs args)
        {
            args.Credentials.UserName.UserName = "MyUserName";
            args.Credentials.UserName.Password = "MyPassword";
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientBouncyCastle Class
TlsClientBouncyCastle Members


ModifyCredentials Method (TlsClientBouncyCastle)

ModifyCredentials Method (TlsClientBouncyCastle)
Example

MedicalConnections.Security Namespace > TlsClientBouncyCastle Class : ModifyCredentials Method
Details of the connection being made
Overridable method to allow implementation of custom authentication arrangements
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overridable Sub ModifyCredentials( _
   ByVal args As ModifyCredentialArgs _
)
Dim instance As TlsClientBouncyCastle
Dim args As ModifyCredentialArgs

instance.ModifyCredentials(args)
public virtual void ModifyCredentials(
   ModifyCredentialArgs args
)
public:
virtual void ModifyCredentials(
   ModifyCredentialArgs^ args
)

Parameters

args
Details of the connection being made
Remarks

This provides an extensible and flexible method to allow the bindings to be modified - e.g. (in conjunction with ModifyBindings) the code in the example could be used to use Basic Authentication.

All the implementations of this method in the intrinsic MedicalConnections.Security classes do nothing.

Example
  • C#
class MySecurity
{
    class MySecurity : TlsClientWindows
    {
        public override void ModifyBindings(ModifyBindingsArgs args)
        {
            foreach (BindingElement b in args.Bindings)
            {
                if (b is HttpsTransportBindingElement)
                    (b as HttpsTransportBindingElement).AuthenticationScheme = System.Net.AuthenticationSchemes.Basic;
            }
        }

        public override void ModifyCredentials(ModifyCredentialArgs args)
        {
            args.Credentials.UserName.UserName = "MyUserName";
            args.Credentials.UserName.Password = "MyPassword";
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientBouncyCastle Class
TlsClientBouncyCastle Members


OpenStream Method (TlsClientBouncyCastle)

OpenStream Method (TlsClientBouncyCastle)

MedicalConnections.Security Namespace > TlsClientBouncyCastle Class : OpenStream Method
The remote address
The port to connect to
Create an encrypted stream, based on a newly created "outer" stream
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function OpenStream( _
   ByVal Address As String, _
   ByVal Port As Integer _
) As Stream
Dim instance As TlsClientBouncyCastle
Dim Address As String
Dim Port As Integer
Dim value As Stream

value = instance.OpenStream(Address, Port)
public Stream OpenStream(
   string Address,
   int Port
)
public:
Stream^ OpenStream(
   String^ Address,
   int Port
)

Parameters

Address
The remote address
Port
The port to connect to

Return Value

A new encrypted stream
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientBouncyCastle Class
TlsClientBouncyCastle Members


TlsStream Method (TlsClientBouncyCastle)

TlsStream Method (TlsClientBouncyCastle)

MedicalConnections.Security Namespace > TlsClientBouncyCastle Class : TlsStream Method
The remote address
The outer (already connected) stream
Create an encrypted stream, based on the provided "outer" stream
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function TlsStream( _
   ByVal Address As String, _
   ByVal OuterStream As Stream _
) As Stream
Dim instance As TlsClientBouncyCastle
Dim Address As String
Dim OuterStream As Stream
Dim value As Stream

value = instance.TlsStream(Address, OuterStream)
public Stream TlsStream(
   string Address,
   Stream OuterStream
)
public:
Stream^ TlsStream(
   String^ Address,
   Stream^ OuterStream
)

Parameters

Address
The remote address
OuterStream
The outer (already connected) stream
Remarks
The address is only used for certificate validation etc.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientBouncyCastle Class
TlsClientBouncyCastle Members


TlsClientBouncyCastle Class Properties

TlsClientBouncyCastle Class Properties

MedicalConnections.Security Namespace : TlsClientBouncyCastle Class

For a list of all members of this type, see TlsClientBouncyCastle members.

Public Properties
 | Name | Description
Public Property | CheckCRL | Controls whether or not to check certificate revokation lists (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Public Property | CheckHostName | Controls whether or not to check host names against their certificates (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Public Property | HttpProvider | The mechanism used to handle HTTP requests using this security object
Public Property | RemoteHostName | The remote host name (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Public Property | TlsCipherSuite | The List of Ciphers to Propose
Top
Protected Properties
 | Name | Description
Protected Property | TrustedRoots | The list of trusted root certificates (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Top
See Also

Reference

TlsClientBouncyCastle Class
MedicalConnections.Security Namespace


HttpProvider Property (TlsClientBouncyCastle)

HttpProvider Property (TlsClientBouncyCastle)

MedicalConnections.Security Namespace > TlsClientBouncyCastle Class : HttpProvider Property
The mechanism used to handle HTTP requests using this security object
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property HttpProvider As Nullable(Of HttpProvider)
Dim instance As TlsClientBouncyCastle
Dim value As Nullable(Of HttpProvider)

value = instance.HttpProvider
public Nullable<HttpProvider> HttpProvider {get;}
public:
property Nullable<HttpProvider> HttpProvider {
   Nullable<HttpProvider> get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientBouncyCastle Class
TlsClientBouncyCastle Members


TlsCipherSuite Property

TlsCipherSuite Property

MedicalConnections.Security Namespace > TlsClientBouncyCastle Class : TlsCipherSuite Property
The List of Ciphers to Propose
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property TlsCipherSuite As List(Of TlsCipher)
Dim instance As TlsClientBouncyCastle
Dim value As List(Of TlsCipher)

instance.TlsCipherSuite = value

value = instance.TlsCipherSuite
public List<TlsCipher> TlsCipherSuite {get; set;}
public:
property List<TlsCipher>^ TlsCipherSuite {
   List<TlsCipher>^ get();
   void set (    List<TlsCipher>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientBouncyCastle Class
TlsClientBouncyCastle Members


TlsClientNone Class

TlsClientNone Class
Members

MedicalConnections.Security Namespace : TlsClientNone Class
Impelementation of ITlsClientSecurity which does not use TLS
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class TlsClientNone
   Implements ITlsBase, ITlsClientSecurity
Dim instance As TlsClientNone
public class TlsClientNone : ITlsBase, ITlsClientSecurity
public ref class TlsClientNone : public ITlsBase, ITlsClientSecurity
Remarks
This is a "dummy" class, providing all the interfaces, but using no encryption
Inheritance Hierarchy

System.Object
MedicalConnections.Security.TlsClientNone

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientNone Members
MedicalConnections.Security Namespace


TlsClientNone Class Members

TlsClientNone Class Members
Properties Methods

MedicalConnections.Security Namespace : TlsClientNone Class

The following tables list the members exposed by TlsClientNone.

Public Constructors
 | Name | Description
Public Constructor | TlsClientNone Constructor |
Top
Public Properties
 | Name | Description
Public Property | CheckCRL | Dummy implementation - does nothing
Public Property | CheckHostName | Dummy implementation - does nothing
Public Property | HttpProvider | Dummy implementation - does nothing
Top
Public Methods
 | Name | Description
Public Method | ModifyBindings | Overridable method to allow implementation of custom bindings
Public Method | ModifyCredentials | Overridable method to allow implementation of custom authentication arrangements
Public Method | OpenStream | Dummy implementation of ITlsClientSecurity.TlsStream
Public Method | TlsStream | Dummy implementation of ITlsClientSecurity.TlsStream
Top
See Also

Reference

TlsClientNone Class
MedicalConnections.Security Namespace


TlsClientNone Constructor

TlsClientNone Constructor

MedicalConnections.Security Namespace > TlsClientNone Class : TlsClientNone Constructor
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New TlsClientNone()
public TlsClientNone()
public:
TlsClientNone();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientNone Class
TlsClientNone Members


TlsClientNone Class Methods

TlsClientNone Class Methods

MedicalConnections.Security Namespace : TlsClientNone Class

For a list of all members of this type, see TlsClientNone members.

Public Methods
 | Name | Description
Public Method | ModifyBindings | Overridable method to allow implementation of custom bindings
Public Method | ModifyCredentials | Overridable method to allow implementation of custom authentication arrangements
Public Method | OpenStream | Dummy implementation of ITlsClientSecurity.TlsStream
Public Method | TlsStream | Dummy implementation of ITlsClientSecurity.TlsStream
Top
See Also

Reference

TlsClientNone Class
MedicalConnections.Security Namespace


ModifyBindings Method (TlsClientNone)

ModifyBindings Method (TlsClientNone)
Example

MedicalConnections.Security Namespace > TlsClientNone Class : ModifyBindings Method
Details of the existing (modifiable) bindings and the connection being made
Overridable method to allow implementation of custom bindings
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub ModifyBindings( _
   ByVal args As ModifyBindingsArgs _
)
Dim instance As TlsClientNone
Dim args As ModifyBindingsArgs

instance.ModifyBindings(args)
public void ModifyBindings(
   ModifyBindingsArgs args
)
public:
void ModifyBindings(
   ModifyBindingsArgs^ args
)

Parameters

args
Details of the existing (modifiable) bindings and the connection being made
Remarks

This provides an extensible and flexible method to allow the bindings to be modified - e.g. (in conjunction with ModifyCredentials) the code in the example could be used to use Basic Authentication.

All the implementations of this method in the intrinsic MedicalConnections.Security classes do nothing.

Example
  • C#
class MySecurity
{
    class MySecurity : TlsClientWindows
    {
        public override void ModifyBindings(ModifyBindingsArgs args)
        {
            foreach (BindingElement b in args.Bindings)
            {
                if (b is HttpsTransportBindingElement)
                    (b as HttpsTransportBindingElement).AuthenticationScheme = System.Net.AuthenticationSchemes.Basic;
            }
        }

        public override void ModifyCredentials(ModifyCredentialArgs args)
        {
            args.Credentials.UserName.UserName = "MyUserName";
            args.Credentials.UserName.Password = "MyPassword";
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientNone Class
TlsClientNone Members


ModifyCredentials Method (TlsClientNone)

ModifyCredentials Method (TlsClientNone)
Example

MedicalConnections.Security Namespace > TlsClientNone Class : ModifyCredentials Method
Details of the connection being made
Overridable method to allow implementation of custom authentication arrangements
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub ModifyCredentials( _
   ByVal args As ModifyCredentialArgs _
)
Dim instance As TlsClientNone
Dim args As ModifyCredentialArgs

instance.ModifyCredentials(args)
public void ModifyCredentials(
   ModifyCredentialArgs args
)
public:
void ModifyCredentials(
   ModifyCredentialArgs^ args
)

Parameters

args
Details of the connection being made
Remarks

This provides an extensible and flexible method to allow the bindings to be modified - e.g. (in conjunction with ModifyBindings) the code in the example could be used to use Basic Authentication.

All the implementations of this method in the intrinsic MedicalConnections.Security classes do nothing.

Example
  • C#
class MySecurity
{
    class MySecurity : TlsClientWindows
    {
        public override void ModifyBindings(ModifyBindingsArgs args)
        {
            foreach (BindingElement b in args.Bindings)
            {
                if (b is HttpsTransportBindingElement)
                    (b as HttpsTransportBindingElement).AuthenticationScheme = System.Net.AuthenticationSchemes.Basic;
            }
        }

        public override void ModifyCredentials(ModifyCredentialArgs args)
        {
            args.Credentials.UserName.UserName = "MyUserName";
            args.Credentials.UserName.Password = "MyPassword";
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientNone Class
TlsClientNone Members


OpenStream Method (TlsClientNone)

OpenStream Method (TlsClientNone)

MedicalConnections.Security Namespace > TlsClientNone Class : OpenStream Method
The remote address
The remote port
Dummy implementation of ITlsClientSecurity.TlsStream
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function OpenStream( _
   ByVal Address As String, _
   ByVal Port As Integer _
) As Stream
Dim instance As TlsClientNone
Dim Address As String
Dim Port As Integer
Dim value As Stream

value = instance.OpenStream(Address, Port)
public Stream OpenStream(
   string Address,
   int Port
)
public:
Stream^ OpenStream(
   String^ Address,
   int Port
)

Parameters

Address
The remote address
Port
The remote port

Return Value

A reference to the outer stream
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientNone Class
TlsClientNone Members


TlsStream Method (TlsClientNone)

TlsStream Method (TlsClientNone)

MedicalConnections.Security Namespace > TlsClientNone Class : TlsStream Method
The remote address
The "outer" stream
Dummy implementation of ITlsClientSecurity.TlsStream
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function TlsStream( _
   ByVal Address As String, _
   ByVal OuterStream As Stream _
) As Stream
Dim instance As TlsClientNone
Dim Address As String
Dim OuterStream As Stream
Dim value As Stream

value = instance.TlsStream(Address, OuterStream)
public Stream TlsStream(
   string Address,
   Stream OuterStream
)
public:
Stream^ TlsStream(
   String^ Address,
   Stream^ OuterStream
)

Parameters

Address
The remote address
OuterStream
The "outer" stream

Return Value

A reference to the outer stream
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientNone Class
TlsClientNone Members


TlsClientNone Class Properties

TlsClientNone Class Properties

MedicalConnections.Security Namespace : TlsClientNone Class

For a list of all members of this type, see TlsClientNone members.

Public Properties
 | Name | Description
Public Property | CheckCRL | Dummy implementation - does nothing
Public Property | CheckHostName | Dummy implementation - does nothing
Public Property | HttpProvider | Dummy implementation - does nothing
Top
See Also

Reference

TlsClientNone Class
MedicalConnections.Security Namespace


CheckCRL Property (TlsClientNone)

CheckCRL Property (TlsClientNone)

MedicalConnections.Security Namespace > TlsClientNone Class : CheckCRL Property
Dummy implementation - does nothing
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property CheckCRL As Boolean
Dim instance As TlsClientNone
Dim value As Boolean

instance.CheckCRL = value

value = instance.CheckCRL
public bool CheckCRL {get; set;}
public:
property bool CheckCRL {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientNone Class
TlsClientNone Members


CheckHostName Property (TlsClientNone)

CheckHostName Property (TlsClientNone)

MedicalConnections.Security Namespace > TlsClientNone Class : CheckHostName Property
Dummy implementation - does nothing
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property CheckHostName As Boolean
Dim instance As TlsClientNone
Dim value As Boolean

instance.CheckHostName = value

value = instance.CheckHostName
public bool CheckHostName {get; set;}
public:
property bool CheckHostName {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientNone Class
TlsClientNone Members


HttpProvider Property (TlsClientNone)

HttpProvider Property (TlsClientNone)

MedicalConnections.Security Namespace > TlsClientNone Class : HttpProvider Property
Dummy implementation - does nothing
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property HttpProvider As Nullable(Of HttpProvider)
Dim instance As TlsClientNone
Dim value As Nullable(Of HttpProvider)

instance.HttpProvider = value

value = instance.HttpProvider
public Nullable<HttpProvider> HttpProvider {get; set;}
public:
property Nullable<HttpProvider> HttpProvider {
   Nullable<HttpProvider> get();
   void set (    Nullable<HttpProvider> value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientNone Class
TlsClientNone Members


TlsClientWindows Class

TlsClientWindows Class
Members

MedicalConnections.Security Namespace : TlsClientWindows Class
Impelementation of ITlsClientSecurity based on Windows interfaces
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class TlsClientWindows
   Implements ITlsBase, ITlsClientSecurity
Dim instance As TlsClientWindows
public class TlsClientWindows : ITlsBase, ITlsClientSecurity
public ref class TlsClientWindows : public ITlsBase, ITlsClientSecurity
Inheritance Hierarchy

System.Object
MedicalConnections.Security.TlsClientWindows

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientWindows Members
MedicalConnections.Security Namespace


TlsClientWindows Class Members

TlsClientWindows Class Members
Properties Methods

MedicalConnections.Security Namespace : TlsClientWindows Class

The following tables list the members exposed by TlsClientWindows.

Public Constructors
 | Name | Description
Public Constructor | TlsClientWindows Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Certificate | The local certificate to use
Public Property | CheckCRL | Controls whether or not to check certificate revokation lists
Public Property | CheckHostName | Controls whether or not to check host names against their certificates
Public Property | HttpProvider |
Public Property | IgnoredSslPolicyErrors | List of SslPolicyErrors to Ignore. By default RemoteCertificateNameMismatch error will be ignored
Public Property | ValidateServerCertificate | Callback to check whether a remote certificate is valid
Top
Public Methods
 | Name | Description
Public Method | ModifyBindings | Overridable method to allow implementation of custom bindings
Public Method | ModifyCredentials | Overridable method to allow implementation of custom authentication arrangements
Public Method | OpenStream |
Public Method | TlsStream |
Top
See Also

Reference

TlsClientWindows Class
MedicalConnections.Security Namespace


TlsClientWindows Constructor

TlsClientWindows Constructor

MedicalConnections.Security Namespace > TlsClientWindows Class : TlsClientWindows Constructor
Overload List
Overload | Description
TlsClientWindows Constructor() | Create a new TlsClientWindows object
TlsClientWindows Constructor(X509Certificate2) | Create a new TlsClientWindows object with a specified local certificate
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientWindows Class
TlsClientWindows Members


TlsClientWindows Constructor()

TlsClientWindows Constructor()

MedicalConnections.Security Namespace > TlsClientWindows Class > TlsClientWindows Constructor : TlsClientWindows Constructor()
Create a new TlsClientWindows object
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New TlsClientWindows()
public TlsClientWindows()
public:
TlsClientWindows();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientWindows Class
TlsClientWindows Members
Overload List


TlsClientWindows Constructor(X509Certificate2)

TlsClientWindows Constructor(X509Certificate2)

MedicalConnections.Security Namespace > TlsClientWindows Class > TlsClientWindows Constructor : TlsClientWindows Constructor(X509Certificate2)
The certificate to use
Create a new TlsClientWindows object with a specified local certificate
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal Certificate As X509Certificate2 _
)
Dim Certificate As X509Certificate2

Dim instance As New TlsClientWindows(Certificate)
public TlsClientWindows(
   X509Certificate2 Certificate
)
public:
TlsClientWindows(
   X509Certificate2^ Certificate
)

Parameters

Certificate
The certificate to use
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientWindows Class
TlsClientWindows Members
Overload List


TlsClientWindows Class Methods

TlsClientWindows Class Methods

MedicalConnections.Security Namespace : TlsClientWindows Class

For a list of all members of this type, see TlsClientWindows members.

Public Methods
 | Name | Description
Public Method | ModifyBindings | Overridable method to allow implementation of custom bindings
Public Method | ModifyCredentials | Overridable method to allow implementation of custom authentication arrangements
Public Method | OpenStream |
Public Method | TlsStream |
Top
See Also

Reference

TlsClientWindows Class
MedicalConnections.Security Namespace


ModifyBindings Method (TlsClientWindows)

ModifyBindings Method (TlsClientWindows)
Example

MedicalConnections.Security Namespace > TlsClientWindows Class : ModifyBindings Method
Details of the existing (modifiable) bindings and the connection being made
Overridable method to allow implementation of custom bindings
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overridable Sub ModifyBindings( _
   ByVal args As ModifyBindingsArgs _
)
Dim instance As TlsClientWindows
Dim args As ModifyBindingsArgs

instance.ModifyBindings(args)
public virtual void ModifyBindings(
   ModifyBindingsArgs args
)
public:
virtual void ModifyBindings(
   ModifyBindingsArgs^ args
)

Parameters

args
Details of the existing (modifiable) bindings and the connection being made
Remarks

This provides an extensible and flexible method to allow the bindings to be modified - e.g. (in conjunction with ModifyCredentials) the code in the example could be used to use Basic Authentication.

All the implementations of this method in the intrinsic MedicalConnections.Security classes do nothing.

Example
  • C#
class MySecurity
{
    class MySecurity : TlsClientWindows
    {
        public override void ModifyBindings(ModifyBindingsArgs args)
        {
            foreach (BindingElement b in args.Bindings)
            {
                if (b is HttpsTransportBindingElement)
                    (b as HttpsTransportBindingElement).AuthenticationScheme = System.Net.AuthenticationSchemes.Basic;
            }
        }

        public override void ModifyCredentials(ModifyCredentialArgs args)
        {
            args.Credentials.UserName.UserName = "MyUserName";
            args.Credentials.UserName.Password = "MyPassword";
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientWindows Class
TlsClientWindows Members


ModifyCredentials Method (TlsClientWindows)

ModifyCredentials Method (TlsClientWindows)
Example

MedicalConnections.Security Namespace > TlsClientWindows Class : ModifyCredentials Method
Details of the connection being made
Overridable method to allow implementation of custom authentication arrangements
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overridable Sub ModifyCredentials( _
   ByVal args As ModifyCredentialArgs _
)
Dim instance As TlsClientWindows
Dim args As ModifyCredentialArgs

instance.ModifyCredentials(args)
public virtual void ModifyCredentials(
   ModifyCredentialArgs args
)
public:
virtual void ModifyCredentials(
   ModifyCredentialArgs^ args
)

Parameters

args
Details of the connection being made
Remarks

This provides an extensible and flexible method to allow the bindings to be modified - e.g. (in conjunction with ModifyBindings) the code in the example could be used to use Basic Authentication.

All the implementations of this method in the intrinsic MedicalConnections.Security classes do nothing.

Example
  • C#
class MySecurity
{
    class MySecurity : TlsClientWindows
    {
        public override void ModifyBindings(ModifyBindingsArgs args)
        {
            foreach (BindingElement b in args.Bindings)
            {
                if (b is HttpsTransportBindingElement)
                    (b as HttpsTransportBindingElement).AuthenticationScheme = System.Net.AuthenticationSchemes.Basic;
            }
        }

        public override void ModifyCredentials(ModifyCredentialArgs args)
        {
            args.Credentials.UserName.UserName = "MyUserName";
            args.Credentials.UserName.Password = "MyPassword";
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientWindows Class
TlsClientWindows Members


OpenStream Method (TlsClientWindows)

OpenStream Method (TlsClientWindows)

MedicalConnections.Security Namespace > TlsClientWindows Class : OpenStream Method
The remote address
The port to connect to
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function OpenStream( _
   ByVal Address As String, _
   ByVal Port As Integer _
) As Stream
Dim instance As TlsClientWindows
Dim Address As String
Dim Port As Integer
Dim value As Stream

value = instance.OpenStream(Address, Port)
public Stream OpenStream(
   string Address,
   int Port
)
public:
Stream^ OpenStream(
   String^ Address,
   int Port
)

Parameters

Address
The remote address
Port
The port to connect to
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientWindows Class
TlsClientWindows Members


TlsStream Method (TlsClientWindows)

TlsStream Method (TlsClientWindows)

MedicalConnections.Security Namespace > TlsClientWindows Class : TlsStream Method
The address being connected to
The cleartext stream to be encrypted
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function TlsStream( _
   ByVal Address As String, _
   ByVal OuterStream As Stream _
) As Stream
Dim instance As TlsClientWindows
Dim Address As String
Dim OuterStream As Stream
Dim value As Stream

value = instance.TlsStream(Address, OuterStream)
public Stream TlsStream(
   string Address,
   Stream OuterStream
)
public:
Stream^ TlsStream(
   String^ Address,
   Stream^ OuterStream
)

Parameters

Address
The address being connected to
OuterStream
The cleartext stream to be encrypted
Remarks
The address is only used for certificate validation etc.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientWindows Class
TlsClientWindows Members


TlsClientWindows Class Properties

TlsClientWindows Class Properties

MedicalConnections.Security Namespace : TlsClientWindows Class

For a list of all members of this type, see TlsClientWindows members.

Public Properties
 | Name | Description
Public Property | Certificate | The local certificate to use
Public Property | CheckCRL | Controls whether or not to check certificate revokation lists
Public Property | CheckHostName | Controls whether or not to check host names against their certificates
Public Property | HttpProvider |
Public Property | IgnoredSslPolicyErrors | List of SslPolicyErrors to Ignore. By default RemoteCertificateNameMismatch error will be ignored
Public Property | ValidateServerCertificate | Callback to check whether a remote certificate is valid
Top
See Also

Reference

TlsClientWindows Class
MedicalConnections.Security Namespace


Certificate Property (TlsClientWindows)

Certificate Property (TlsClientWindows)

MedicalConnections.Security Namespace > TlsClientWindows Class : Certificate Property
The local certificate to use
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Certificate As X509Certificate2
Dim instance As TlsClientWindows
Dim value As X509Certificate2

instance.Certificate = value

value = instance.Certificate
public X509Certificate2 Certificate {get; set;}
public:
property X509Certificate2^ Certificate {
   X509Certificate2^ get();
   void set (    X509Certificate2^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientWindows Class
TlsClientWindows Members


CheckCRL Property (TlsClientWindows)

CheckCRL Property (TlsClientWindows)

MedicalConnections.Security Namespace > TlsClientWindows Class : CheckCRL Property
Controls whether or not to check certificate revokation lists
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property CheckCRL As Boolean
Dim instance As TlsClientWindows
Dim value As Boolean

instance.CheckCRL = value

value = instance.CheckCRL
public bool CheckCRL {get; set;}
public:
property bool CheckCRL {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientWindows Class
TlsClientWindows Members


CheckHostName Property (TlsClientWindows)

CheckHostName Property (TlsClientWindows)

MedicalConnections.Security Namespace > TlsClientWindows Class : CheckHostName Property
Controls whether or not to check host names against their certificates
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property CheckHostName As Boolean
Dim instance As TlsClientWindows
Dim value As Boolean

instance.CheckHostName = value

value = instance.CheckHostName
public bool CheckHostName {get; set;}
public:
property bool CheckHostName {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientWindows Class
TlsClientWindows Members


HttpProvider Property (TlsClientWindows)

HttpProvider Property (TlsClientWindows)

MedicalConnections.Security Namespace > TlsClientWindows Class : HttpProvider Property
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property HttpProvider As Nullable(Of HttpProvider)
Dim instance As TlsClientWindows
Dim value As Nullable(Of HttpProvider)

instance.HttpProvider = value

value = instance.HttpProvider
public Nullable<HttpProvider> HttpProvider {get; set;}
public:
property Nullable<HttpProvider> HttpProvider {
   Nullable<HttpProvider> get();
   void set (    Nullable<HttpProvider> value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientWindows Class
TlsClientWindows Members


IgnoredSslPolicyErrors Property

IgnoredSslPolicyErrors Property

MedicalConnections.Security Namespace > TlsClientWindows Class : IgnoredSslPolicyErrors Property
List of SslPolicyErrors to Ignore. By default RemoteCertificateNameMismatch error will be ignored
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property IgnoredSslPolicyErrors As List(Of SslPolicyErrors)
Dim instance As TlsClientWindows
Dim value As List(Of SslPolicyErrors)

instance.IgnoredSslPolicyErrors = value

value = instance.IgnoredSslPolicyErrors
public List<SslPolicyErrors> IgnoredSslPolicyErrors {get; set;}
public:
property List<SslPolicyErrors>^ IgnoredSslPolicyErrors {
   List<SslPolicyErrors>^ get();
   void set (    List<SslPolicyErrors>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientWindows Class
TlsClientWindows Members


ValidateServerCertificate Property (TlsClientWindows)

ValidateServerCertificate Property (TlsClientWindows)

MedicalConnections.Security Namespace > TlsClientWindows Class : ValidateServerCertificate Property
Callback to check whether a remote certificate is valid
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ValidateServerCertificate As RemoteCertificateValidationCallback
Dim instance As TlsClientWindows
Dim value As RemoteCertificateValidationCallback

instance.ValidateServerCertificate = value

value = instance.ValidateServerCertificate
public RemoteCertificateValidationCallback ValidateServerCertificate {get; set;}
public:
property RemoteCertificateValidationCallback^ ValidateServerCertificate {
   RemoteCertificateValidationCallback^ get();
   void set (    RemoteCertificateValidationCallback^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsClientWindows Class
TlsClientWindows Members


TlsServerBouncyCastle Class

TlsServerBouncyCastle Class
Members

MedicalConnections.Security Namespace : TlsServerBouncyCastle Class
Server implementing TLS, based on the BouncyCastle implementation
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class TlsServerBouncyCastle
   Inherits TlsBouncyCastle
   Implements ITlsBase, ITlsServerSecurity
Dim instance As TlsServerBouncyCastle
public class TlsServerBouncyCastle : TlsBouncyCastle, ITlsBase, ITlsServerSecurity
public ref class TlsServerBouncyCastle : public TlsBouncyCastle, ITlsBase, ITlsServerSecurity
Inheritance Hierarchy

System.Object
MedicalConnections.Security.TlsBouncyCastle
MedicalConnections.Security.TlsServerBouncyCastle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsServerBouncyCastle Members
MedicalConnections.Security Namespace


TlsServerBouncyCastle Class Members

TlsServerBouncyCastle Class Members
Properties Methods Events

MedicalConnections.Security Namespace : TlsServerBouncyCastle Class

The following tables list the members exposed by TlsServerBouncyCastle.

Public Constructors
 | Name | Description
Public Constructor | TlsServerBouncyCastle Constructor |
Top
Public Properties
 | Name | Description
Public Property | CheckCRL | Controls whether or not to check certificate revokation lists (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Public Property | CheckHostName | Controls whether or not to check host names against their certificates (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Public Property | RemoteHostName | The remote host name (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Top
Protected Properties
 | Name | Description
Protected Property | TrustedRoots | The list of trusted root certificates (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Top
Public Methods
 | Name | Description
Public Method | AddTrustedRoot | Add a certificate to the list of TrustedRoots (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Public Method | Connect | Handle the TLS negotation
Public Method | Listen | Listen for incoming connections
Public Method | LoadFromPfx | Load the local certificate from a PFX/P12 file, plus a password (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Public Method | SetCertificateFromByteArray | Load the local certificate from arrays containg the public and private keys, plus a password (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Top
Public Events
 | Name | Description
Public Event | OnConnect | Event fires on connection to allow security checking etc.
Top
See Also

Reference

TlsServerBouncyCastle Class
MedicalConnections.Security Namespace


TlsServerBouncyCastle Constructor

TlsServerBouncyCastle Constructor

MedicalConnections.Security Namespace > TlsServerBouncyCastle Class : TlsServerBouncyCastle Constructor
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New TlsServerBouncyCastle()
public TlsServerBouncyCastle()
public:
TlsServerBouncyCastle();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsServerBouncyCastle Class
TlsServerBouncyCastle Members


TlsServerBouncyCastle Class Methods

TlsServerBouncyCastle Class Methods

MedicalConnections.Security Namespace : TlsServerBouncyCastle Class

For a list of all members of this type, see TlsServerBouncyCastle members.

Public Methods
 | Name | Description
Public Method | AddTrustedRoot | Add a certificate to the list of TrustedRoots (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Public Method | Connect | Handle the TLS negotation
Public Method | Listen | Listen for incoming connections
Public Method | LoadFromPfx | Load the local certificate from a PFX/P12 file, plus a password (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Public Method | SetCertificateFromByteArray | Load the local certificate from arrays containg the public and private keys, plus a password (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Top
See Also

Reference

TlsServerBouncyCastle Class
MedicalConnections.Security Namespace


Connect Method (TlsServerBouncyCastle)

Connect Method (TlsServerBouncyCastle)

MedicalConnections.Security Namespace > TlsServerBouncyCastle Class : Connect Method
Encrypted data stream
Handle the TLS negotation
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function Connect( _
   ByVal OuterStream As Stream _
) As Stream
Dim instance As TlsServerBouncyCastle
Dim OuterStream As Stream
Dim value As Stream

value = instance.Connect(OuterStream)
public Stream Connect(
   Stream OuterStream
)
public:
Stream^ Connect(
   Stream^ OuterStream
)

Parameters

OuterStream
Encrypted data stream

Return Value

unencrypted "inner" stream
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsServerBouncyCastle Class
TlsServerBouncyCastle Members


Listen Method (TlsServerBouncyCastle)

Listen Method (TlsServerBouncyCastle)

MedicalConnections.Security Namespace > TlsServerBouncyCastle Class : Listen Method
Address to Listen on
Port to listen on
Listen for incoming connections
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub Listen( _
   ByVal Address As IPAddress, _
   ByVal Port As Integer _
)
Dim instance As TlsServerBouncyCastle
Dim Address As IPAddress
Dim Port As Integer

instance.Listen(Address, Port)
public void Listen(
   IPAddress Address,
   int Port
)
public:
void Listen(
   IPAddress^ Address,
   int Port
)

Parameters

Address
Address to Listen on
Port
Port to listen on
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsServerBouncyCastle Class
TlsServerBouncyCastle Members


TlsServerBouncyCastle Class Events

TlsServerBouncyCastle Class Events

MedicalConnections.Security Namespace : TlsServerBouncyCastle Class

For a list of all members of this type, see TlsServerBouncyCastle members.

Public Events
 | Name | Description
Public Event | OnConnect | Event fires on connection to allow security checking etc.
Top
See Also

Reference

TlsServerBouncyCastle Class
MedicalConnections.Security Namespace


OnConnect Event (TlsServerBouncyCastle)

OnConnect Event (TlsServerBouncyCastle)

MedicalConnections.Security Namespace > TlsServerBouncyCastle Class : OnConnect Event
Event fires on connection to allow security checking etc.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Event OnConnect As OnConnectDelegate
Dim instance As TlsServerBouncyCastle
Dim handler As OnConnectDelegate

AddHandler instance.OnConnect, handler
public event OnConnectDelegate OnConnect
public:
event OnConnectDelegate^ OnConnect
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsServerBouncyCastle Class
TlsServerBouncyCastle Members


TlsServerWindows Class

TlsServerWindows Class
Members

MedicalConnections.Security Namespace : TlsServerWindows Class
The TlsServerWindows class incorporates the .NET security features needed to establish secure DICOM connection as an association Acceptor
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class TlsServerWindows
   Implements ITlsBase, ITlsServerSecurity
Dim instance As TlsServerWindows
public class TlsServerWindows : ITlsBase, ITlsServerSecurity
public ref class TlsServerWindows : public ITlsBase, ITlsServerSecurity
Inheritance Hierarchy

System.Object
MedicalConnections.Security.TlsServerWindows

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsServerWindows Members
MedicalConnections.Security Namespace


TlsServerWindows Class Members

TlsServerWindows Class Members
Properties Methods Events

MedicalConnections.Security Namespace : TlsServerWindows Class

The following tables list the members exposed by TlsServerWindows.

Public Constructors
 | Name | Description
Public Constructor | TlsServerWindows Constructor | Create a blank TlsServerWindows object
Top
Public Properties
 | Name | Description
Public Property | Certificate | The x509 Certificate used to authenticate this server to the remote party
Public Property | CertificateValidationCallback | Contains the CertificateValidationCallback delegate, which is used for verifying the remote certificate.
Public Property | CheckCRL | Controls whether or not to check certificate revokation lists
Public Property | CheckHostName | Controls whether or not to check host names against their certificates
Public Property | ClientAuthentication | Controls whether Client Authentication is required
Top
Public Methods
 | Name | Description
Public Method | Connect | Create a plaintext inner stream, based on the provided OuterStream
Public Method | Listen | Listen for incoming connections
Top
Public Events
 | Name | Description
Public Event | OnConnect | Event fires on connection to allow security checking etc.
Top
See Also

Reference

TlsServerWindows Class
MedicalConnections.Security Namespace


TlsServerWindows Constructor

TlsServerWindows Constructor

MedicalConnections.Security Namespace > TlsServerWindows Class : TlsServerWindows Constructor
Create a blank TlsServerWindows object
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New TlsServerWindows()
public TlsServerWindows()
public:
TlsServerWindows();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsServerWindows Class
TlsServerWindows Members


TlsServerWindows Class Methods

TlsServerWindows Class Methods

MedicalConnections.Security Namespace : TlsServerWindows Class

For a list of all members of this type, see TlsServerWindows members.

Public Methods
 | Name | Description
Public Method | Connect | Create a plaintext inner stream, based on the provided OuterStream
Public Method | Listen | Listen for incoming connections
Top
See Also

Reference

TlsServerWindows Class
MedicalConnections.Security Namespace


Connect Method (TlsServerWindows)

Connect Method (TlsServerWindows)

MedicalConnections.Security Namespace > TlsServerWindows Class : Connect Method
The encrypted stream
Create a plaintext inner stream, based on the provided OuterStream
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function Connect( _
   ByVal OuterStream As Stream _
) As Stream
Dim instance As TlsServerWindows
Dim OuterStream As Stream
Dim value As Stream

value = instance.Connect(OuterStream)
public Stream Connect(
   Stream OuterStream
)
public:
Stream^ Connect(
   Stream^ OuterStream
)

Parameters

OuterStream
The encrypted stream

Return Value

A new inner stream
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsServerWindows Class
TlsServerWindows Members


Listen Method (TlsServerWindows)

Listen Method (TlsServerWindows)

MedicalConnections.Security Namespace > TlsServerWindows Class : Listen Method
Address to Listen on
Port to listen on
Listen for incoming connections
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub Listen( _
   ByVal Address As IPAddress, _
   ByVal Port As Integer _
)
Dim instance As TlsServerWindows
Dim Address As IPAddress
Dim Port As Integer

instance.Listen(Address, Port)
public void Listen(
   IPAddress Address,
   int Port
)
public:
void Listen(
   IPAddress^ Address,
   int Port
)

Parameters

Address
Address to Listen on
Port
Port to listen on
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsServerWindows Class
TlsServerWindows Members


TlsServerWindows Class Properties

TlsServerWindows Class Properties

MedicalConnections.Security Namespace : TlsServerWindows Class

For a list of all members of this type, see TlsServerWindows members.

Public Properties
 | Name | Description
Public Property | Certificate | The x509 Certificate used to authenticate this server to the remote party
Public Property | CertificateValidationCallback | Contains the CertificateValidationCallback delegate, which is used for verifying the remote certificate.
Public Property | CheckCRL | Controls whether or not to check certificate revokation lists
Public Property | CheckHostName | Controls whether or not to check host names against their certificates
Public Property | ClientAuthentication | Controls whether Client Authentication is required
Top
See Also

Reference

TlsServerWindows Class
MedicalConnections.Security Namespace


Certificate Property (TlsServerWindows)

Certificate Property (TlsServerWindows)

MedicalConnections.Security Namespace > TlsServerWindows Class : Certificate Property
The x509 Certificate used to authenticate this server to the remote party
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Certificate As X509Certificate2
Dim instance As TlsServerWindows
Dim value As X509Certificate2

instance.Certificate = value

value = instance.Certificate
public X509Certificate2 Certificate {get; set;}
public:
property X509Certificate2^ Certificate {
   X509Certificate2^ get();
   void set (    X509Certificate2^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsServerWindows Class
TlsServerWindows Members


CertificateValidationCallback Property

CertificateValidationCallback Property

MedicalConnections.Security Namespace > TlsServerWindows Class : CertificateValidationCallback Property
Contains the CertificateValidationCallback delegate, which is used for verifying the remote certificate.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property CertificateValidationCallback As RemoteCertificateValidationCallback
Dim instance As TlsServerWindows
Dim value As RemoteCertificateValidationCallback

instance.CertificateValidationCallback = value

value = instance.CertificateValidationCallback
public RemoteCertificateValidationCallback CertificateValidationCallback {get; set;}
public:
property RemoteCertificateValidationCallback^ CertificateValidationCallback {
   RemoteCertificateValidationCallback^ get();
   void set (    RemoteCertificateValidationCallback^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsServerWindows Class
TlsServerWindows Members


CheckCRL Property (TlsServerWindows)

CheckCRL Property (TlsServerWindows)

MedicalConnections.Security Namespace > TlsServerWindows Class : CheckCRL Property
Controls whether or not to check certificate revokation lists
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property CheckCRL As Boolean
Dim instance As TlsServerWindows
Dim value As Boolean

instance.CheckCRL = value

value = instance.CheckCRL
public bool CheckCRL {get; set;}
public:
property bool CheckCRL {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsServerWindows Class
TlsServerWindows Members


CheckHostName Property (TlsServerWindows)

CheckHostName Property (TlsServerWindows)

MedicalConnections.Security Namespace > TlsServerWindows Class : CheckHostName Property
Controls whether or not to check host names against their certificates
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property CheckHostName As Boolean
Dim instance As TlsServerWindows
Dim value As Boolean

instance.CheckHostName = value

value = instance.CheckHostName
public bool CheckHostName {get; set;}
public:
property bool CheckHostName {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsServerWindows Class
TlsServerWindows Members


ClientAuthentication Property

ClientAuthentication Property

MedicalConnections.Security Namespace > TlsServerWindows Class : ClientAuthentication Property
Controls whether Client Authentication is required
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ClientAuthentication As Boolean
Dim instance As TlsServerWindows
Dim value As Boolean

instance.ClientAuthentication = value

value = instance.ClientAuthentication
public bool ClientAuthentication {get; set;}
public:
property bool ClientAuthentication {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsServerWindows Class
TlsServerWindows Members


TlsServerWindows Class Events

TlsServerWindows Class Events

MedicalConnections.Security Namespace : TlsServerWindows Class

For a list of all members of this type, see TlsServerWindows members.

Public Events
 | Name | Description
Public Event | OnConnect | Event fires on connection to allow security checking etc.
Top
See Also

Reference

TlsServerWindows Class
MedicalConnections.Security Namespace


OnConnect Event (TlsServerWindows)

OnConnect Event (TlsServerWindows)

MedicalConnections.Security Namespace > TlsServerWindows Class : OnConnect Event
Event fires on connection to allow security checking etc.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Event OnConnect As OnConnectDelegate
Dim instance As TlsServerWindows
Dim handler As OnConnectDelegate

AddHandler instance.OnConnect, handler
public event OnConnectDelegate OnConnect
public:
event OnConnectDelegate^ OnConnect
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TlsServerWindows Class
TlsServerWindows Members


ITlsBase Interface

ITlsBase Interface
Members

MedicalConnections.Security Namespace : ITlsBase Interface
Base interface, used by ITlsServerSecurity and ITlsClientSecurity
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Interface ITlsBase
Dim instance As ITlsBase
public interface ITlsBase
public interface class ITlsBase
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITlsBase Members
MedicalConnections.Security Namespace


ITlsBase Interface Members

ITlsBase Interface Members
Properties

MedicalConnections.Security Namespace : ITlsBase Interface

The following tables list the members exposed by ITlsBase.

Public Properties
 | Name | Description
Property | CheckCRL | Controls whether or not to check certificate revokation lists
Property | CheckHostName | Controls whether or not to check host names against their certificates
Top
See Also

Reference

ITlsBase Interface
MedicalConnections.Security Namespace


ITlsBase Interface Properties

ITlsBase Interface Properties

MedicalConnections.Security Namespace : ITlsBase Interface

For a list of all members of this type, see ITlsBase members.

Public Properties
 | Name | Description
Property | CheckCRL | Controls whether or not to check certificate revokation lists
Property | CheckHostName | Controls whether or not to check host names against their certificates
Top
See Also

Reference

ITlsBase Interface
MedicalConnections.Security Namespace


CheckCRL Property (ITlsBase)

CheckCRL Property (ITlsBase)

MedicalConnections.Security Namespace > ITlsBase Interface : CheckCRL Property
Controls whether or not to check certificate revokation lists
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Property CheckCRL As Boolean
Dim instance As ITlsBase
Dim value As Boolean

instance.CheckCRL = value

value = instance.CheckCRL
bool CheckCRL {get; set;}
property bool CheckCRL {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITlsBase Interface
ITlsBase Members


CheckHostName Property (ITlsBase)

CheckHostName Property (ITlsBase)

MedicalConnections.Security Namespace > ITlsBase Interface : CheckHostName Property
Controls whether or not to check host names against their certificates
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Property CheckHostName As Boolean
Dim instance As ITlsBase
Dim value As Boolean

instance.CheckHostName = value

value = instance.CheckHostName
bool CheckHostName {get; set;}
property bool CheckHostName {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITlsBase Interface
ITlsBase Members


ITlsClientSecurity Interface

ITlsClientSecurity Interface
Members

MedicalConnections.Security Namespace : ITlsClientSecurity Interface
Interface used to generalise access to secure communications as a client/initiator
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Interface ITlsClientSecurity
   Inherits ITlsBase
Dim instance As ITlsClientSecurity
public interface ITlsClientSecurity : ITlsBase
public interface class ITlsClientSecurity : public ITlsBase
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITlsClientSecurity Members
MedicalConnections.Security Namespace


ITlsClientSecurity Interface Members

ITlsClientSecurity Interface Members
Properties Methods

MedicalConnections.Security Namespace : ITlsClientSecurity Interface

The following tables list the members exposed by ITlsClientSecurity.

Public Properties
 | Name | Description
Property | HttpProvider | The mechanism used for handling security
Top
Public Methods
 | Name | Description
Method | ModifyBindings | Overridable method to allow implementation of custom bindings
Method | ModifyCredentials | Overridable method to allow implementation of custom authentication arrangements
Method | OpenStream | Create an encrypted stream, based on a newly created "outer" stream
Method | TlsStream | Create an encrypted stream, based on the provided "outer" stream
Top
See Also

Reference

ITlsClientSecurity Interface
MedicalConnections.Security Namespace


ITlsClientSecurity Interface Methods

ITlsClientSecurity Interface Methods

MedicalConnections.Security Namespace : ITlsClientSecurity Interface

For a list of all members of this type, see ITlsClientSecurity members.

Public Methods
 | Name | Description
Method | ModifyBindings | Overridable method to allow implementation of custom bindings
Method | ModifyCredentials | Overridable method to allow implementation of custom authentication arrangements
Method | OpenStream | Create an encrypted stream, based on a newly created "outer" stream
Method | TlsStream | Create an encrypted stream, based on the provided "outer" stream
Top
See Also

Reference

ITlsClientSecurity Interface
MedicalConnections.Security Namespace


ModifyBindings Method (ITlsClientSecurity)

ModifyBindings Method (ITlsClientSecurity)
Example

MedicalConnections.Security Namespace > ITlsClientSecurity Interface : ModifyBindings Method
Details of the existing (modifiable) bindings and the connection being made
Overridable method to allow implementation of custom bindings
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Sub ModifyBindings( _
   ByVal args As ModifyBindingsArgs _
)
Dim instance As ITlsClientSecurity
Dim args As ModifyBindingsArgs

instance.ModifyBindings(args)
void ModifyBindings(
   ModifyBindingsArgs args
)
void ModifyBindings(
   ModifyBindingsArgs^ args
)

Parameters

args
Details of the existing (modifiable) bindings and the connection being made
Remarks

This provides an extensible and flexible method to allow the bindings to be modified - e.g. (in conjunction with ModifyCredentials) the code in the example could be used to use Basic Authentication.

All the implementations of this method in the intrinsic MedicalConnections.Security classes do nothing.

Example
  • C#
class MySecurity
{
    class MySecurity : TlsClientWindows
    {
        public override void ModifyBindings(ModifyBindingsArgs args)
        {
            foreach (BindingElement b in args.Bindings)
            {
                if (b is HttpsTransportBindingElement)
                    (b as HttpsTransportBindingElement).AuthenticationScheme = System.Net.AuthenticationSchemes.Basic;
            }
        }

        public override void ModifyCredentials(ModifyCredentialArgs args)
        {
            args.Credentials.UserName.UserName = "MyUserName";
            args.Credentials.UserName.Password = "MyPassword";
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITlsClientSecurity Interface
ITlsClientSecurity Members


ModifyCredentials Method (ITlsClientSecurity)

ModifyCredentials Method (ITlsClientSecurity)
Example

MedicalConnections.Security Namespace > ITlsClientSecurity Interface : ModifyCredentials Method
Details of the connection being made
Overridable method to allow implementation of custom authentication arrangements
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Sub ModifyCredentials( _
   ByVal args As ModifyCredentialArgs _
)
Dim instance As ITlsClientSecurity
Dim args As ModifyCredentialArgs

instance.ModifyCredentials(args)
void ModifyCredentials(
   ModifyCredentialArgs args
)
void ModifyCredentials(
   ModifyCredentialArgs^ args
)

Parameters

args
Details of the connection being made
Remarks

This provides an extensible and flexible method to allow the bindings to be modified - e.g. (in conjunction with ModifyBindings) the code in the example could be used to use Basic Authentication.

All the implementations of this method in the intrinsic MedicalConnections.Security classes do nothing.

Example
  • C#
class MySecurity
{
    class MySecurity : TlsClientWindows
    {
        public override void ModifyBindings(ModifyBindingsArgs args)
        {
            foreach (BindingElement b in args.Bindings)
            {
                if (b is HttpsTransportBindingElement)
                    (b as HttpsTransportBindingElement).AuthenticationScheme = System.Net.AuthenticationSchemes.Basic;
            }
        }

        public override void ModifyCredentials(ModifyCredentialArgs args)
        {
            args.Credentials.UserName.UserName = "MyUserName";
            args.Credentials.UserName.Password = "MyPassword";
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITlsClientSecurity Interface
ITlsClientSecurity Members


OpenStream Method (ITlsClientSecurity)

OpenStream Method (ITlsClientSecurity)

MedicalConnections.Security Namespace > ITlsClientSecurity Interface : OpenStream Method
The remote address
The port to connect to
Create an encrypted stream, based on a newly created "outer" stream
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Function OpenStream( _
   ByVal Address As String, _
   ByVal Port As Integer _
) As Stream
Dim instance As ITlsClientSecurity
Dim Address As String
Dim Port As Integer
Dim value As Stream

value = instance.OpenStream(Address, Port)
Stream OpenStream(
   string Address,
   int Port
)
Stream^ OpenStream(
   String^ Address,
   int Port
)

Parameters

Address
The remote address
Port
The port to connect to

Return Value

A new encrypted stream
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITlsClientSecurity Interface
ITlsClientSecurity Members


TlsStream Method (ITlsClientSecurity)

TlsStream Method (ITlsClientSecurity)

MedicalConnections.Security Namespace > ITlsClientSecurity Interface : TlsStream Method
The remote address
The outer (already connected) stream
Create an encrypted stream, based on the provided "outer" stream
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Function TlsStream( _
   ByVal Address As String, _
   ByVal OuterStream As Stream _
) As Stream
Dim instance As ITlsClientSecurity
Dim Address As String
Dim OuterStream As Stream
Dim value As Stream

value = instance.TlsStream(Address, OuterStream)
Stream TlsStream(
   string Address,
   Stream OuterStream
)
Stream^ TlsStream(
   String^ Address,
   Stream^ OuterStream
)

Parameters

Address
The remote address
OuterStream
The outer (already connected) stream

Return Value

A new encrypted stream
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITlsClientSecurity Interface
ITlsClientSecurity Members


ITlsClientSecurity Interface Properties

ITlsClientSecurity Interface Properties

MedicalConnections.Security Namespace : ITlsClientSecurity Interface

For a list of all members of this type, see ITlsClientSecurity members.

Public Properties
 | Name | Description
Property | HttpProvider | The mechanism used for handling security
Top
See Also

Reference

ITlsClientSecurity Interface
MedicalConnections.Security Namespace


HttpProvider Property (ITlsClientSecurity)

HttpProvider Property (ITlsClientSecurity)

MedicalConnections.Security Namespace > ITlsClientSecurity Interface : HttpProvider Property
The mechanism used for handling security
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
ReadOnly Property HttpProvider As Nullable(Of HttpProvider)
Dim instance As ITlsClientSecurity
Dim value As Nullable(Of HttpProvider)

value = instance.HttpProvider
Nullable<HttpProvider> HttpProvider {get;}
property Nullable<HttpProvider> HttpProvider {
   Nullable<HttpProvider> get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITlsClientSecurity Interface
ITlsClientSecurity Members


ITlsServerSecurity Interface

ITlsServerSecurity Interface
Members

MedicalConnections.Security Namespace : ITlsServerSecurity Interface
Standard interface to provide security and encryption for servers
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Interface ITlsServerSecurity
   Inherits ITlsBase
Dim instance As ITlsServerSecurity
public interface ITlsServerSecurity : ITlsBase
public interface class ITlsServerSecurity : public ITlsBase
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITlsServerSecurity Members
MedicalConnections.Security Namespace


ITlsServerSecurity Interface Members

ITlsServerSecurity Interface Members
Methods Events

MedicalConnections.Security Namespace : ITlsServerSecurity Interface

The following tables list the members exposed by ITlsServerSecurity.

Public Methods
 | Name | Description
Method | Connect | Create a plaintext inner stream, based on the provided OuterStream
Method | Listen | Listen on the stated address and port
Top
Public Events
 | Name | Description
Event | OnConnect | Event fires on connection to allow security checking etc.
Top
See Also

Reference

ITlsServerSecurity Interface
MedicalConnections.Security Namespace


ITlsServerSecurity Interface Methods

ITlsServerSecurity Interface Methods

MedicalConnections.Security Namespace : ITlsServerSecurity Interface

For a list of all members of this type, see ITlsServerSecurity members.

Public Methods
 | Name | Description
Method | Connect | Create a plaintext inner stream, based on the provided OuterStream
Method | Listen | Listen on the stated address and port
Top
See Also

Reference

ITlsServerSecurity Interface
MedicalConnections.Security Namespace


Connect Method (ITlsServerSecurity)

Connect Method (ITlsServerSecurity)

MedicalConnections.Security Namespace > ITlsServerSecurity Interface : Connect Method
The encrypted stream
Create a plaintext inner stream, based on the provided OuterStream
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Function Connect( _
   ByVal OuterStream As Stream _
) As Stream
Dim instance As ITlsServerSecurity
Dim OuterStream As Stream
Dim value As Stream

value = instance.Connect(OuterStream)
Stream Connect(
   Stream OuterStream
)
Stream^ Connect(
   Stream^ OuterStream
)

Parameters

OuterStream
The encrypted stream

Return Value

A new inner stream
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITlsServerSecurity Interface
ITlsServerSecurity Members


Listen Method (ITlsServerSecurity)

Listen Method (ITlsServerSecurity)

MedicalConnections.Security Namespace > ITlsServerSecurity Interface : Listen Method
The Address to listen on
The port to listen on
Listen on the stated address and port
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Sub Listen( _
   ByVal Address As IPAddress, _
   ByVal Port As Integer _
)
Dim instance As ITlsServerSecurity
Dim Address As IPAddress
Dim Port As Integer

instance.Listen(Address, Port)
void Listen(
   IPAddress Address,
   int Port
)
void Listen(
   IPAddress^ Address,
   int Port
)

Parameters

Address
The Address to listen on
Port
The port to listen on
Remarks
Address my be System.Net.IPAddress.Any
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITlsServerSecurity Interface
ITlsServerSecurity Members


ITlsServerSecurity Interface Events

ITlsServerSecurity Interface Events

MedicalConnections.Security Namespace : ITlsServerSecurity Interface

For a list of all members of this type, see ITlsServerSecurity members.

Public Events
 | Name | Description
Event | OnConnect | Event fires on connection to allow security checking etc.
Top
See Also

Reference

ITlsServerSecurity Interface
MedicalConnections.Security Namespace


OnConnect Event (ITlsServerSecurity)

OnConnect Event (ITlsServerSecurity)

MedicalConnections.Security Namespace > ITlsServerSecurity Interface : OnConnect Event
Event fires on connection to allow security checking etc.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Event OnConnect As OnConnectDelegate
Dim instance As ITlsServerSecurity
Dim handler As OnConnectDelegate

AddHandler instance.OnConnect, handler
event OnConnectDelegate OnConnect
event OnConnectDelegate^ OnConnect
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITlsServerSecurity Interface
ITlsServerSecurity Members


MedicalConnections.Security.Delegates Namespace

MedicalConnections.Security.Delegates Namespace
Inheritance Hierarchy
The delegates used for the definition of events
Delegates
 | Delegate | Description
Delegate | OnConnectDelegate | Delegate for the MedicalConnections.Security.ITlsServerSecurity.OnConnect event
See Also

Reference

Security.6.40 Assembly


OnConnectDelegate Delegate

OnConnectDelegate Delegate

MedicalConnections.Security.Delegates Namespace : OnConnectDelegate Delegate
Connection arguments
Delegate for the MedicalConnections.Security.ITlsServerSecurity.OnConnect event
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Delegate Sub OnConnectDelegate( _
   ByVal e As OnConnectArgs _
)
Dim instance As New OnConnectDelegate(AddressOf HandlerMethod)
public delegate void OnConnectDelegate(
   OnConnectArgs e
)
public delegate void OnConnectDelegate(
   OnConnectArgs^ e
)

Parameters

e
Connection arguments
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OnConnectDelegate Members
MedicalConnections.Security.Delegates Namespace


MedicalConnections.Security.Enums Namespace

MedicalConnections.Security.Enums Namespace
Inheritance Hierarchy
The various enumerations used by the security layer
Enumerations
 | Enumeration | Description
Enumeration | HttpProvider | The types of security provider available
Enumeration | TlsCipher | List of TLS Ciphers
See Also

Reference

Security.6.40 Assembly


HttpProvider Enumeration

HttpProvider Enumeration

MedicalConnections.Security.Enums Namespace : HttpProvider Enumeration
The types of security provider available
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Enum HttpProvider
   Inherits System.Enum
Dim instance As HttpProvider
public enum HttpProvider : System.Enum
public enum class HttpProvider : public System.Enum
Members
Member | Description
MedConnections | Use the BouncyCastle functions
Windows | Use intrinsic Windows functions
Remarks
In previous versions of Medical Connections products, this was called "WcfType"
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
MedicalConnections.Security.Enums.HttpProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MedicalConnections.Security.Enums Namespace


TlsCipher Enumeration

TlsCipher Enumeration

MedicalConnections.Security.Enums Namespace : TlsCipher Enumeration
List of TLS Ciphers
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Enum TlsCipher
   Inherits System.Enum
Dim instance As TlsCipher
public enum TlsCipher : System.Enum
public enum class TlsCipher : public System.Enum
Members
Member | Description
TLS_DHE_DSS_WITH_3DES_EDE_CBC_SHA | TLS_DHE_DSS_WITH_3DES_EDE_CBC_SHA
TLS_DHE_DSS_WITH_AES_128_CBC_SHA | TLS_DHE_DSS_WITH_AES_128_CBC_SHA
TLS_DHE_DSS_WITH_AES_256_CBC_SHA | TLS_DHE_DSS_WITH_AES_256_CBC_SHA
TLS_DHE_RSA_WITH_3DES_EDE_CBC_SHA | TLS_DHE_RSA_WITH_3DES_EDE_CBC_SHA
TLS_DHE_RSA_WITH_AES_128_CBC_SHA | TLS_DHE_RSA_WITH_AES_128_CBC_SHA
TLS_DHE_RSA_WITH_AES_256_CBC_SHA | TLS_DHE_RSA_WITH_AES_256_CBC_SHA
TLS_RSA_WITH_3DES_EDE_CBC_SHA | TLS_RSA_WITH_3DES_EDE_CBC_SHA
TLS_RSA_WITH_AES_128_CBC_SHA | TLS_RSA_WITH_AES_128_CBC_SHA
TLS_RSA_WITH_AES_256_CBC_SHA | TLS_RSA_WITH_AES_256_CBC_SHA
TLS_SRP_SHA_DSS_WITH_3DES_EDE_CBC_SHA | TLS_SRP_SHA_DSS_WITH_3DES_EDE_CBC_SHA
TLS_SRP_SHA_DSS_WITH_AES_128_CBC_SHA | TLS_SRP_SHA_DSS_WITH_AES_128_CBC_SHA
TLS_SRP_SHA_DSS_WITH_AES_256_CBC_SHA | TLS_SRP_SHA_DSS_WITH_AES_256_CBC_SHA
TLS_SRP_SHA_RSA_WITH_3DES_EDE_CBC_SHA | TLS_SRP_SHA_RSA_WITH_3DES_EDE_CBC_SHA
TLS_SRP_SHA_RSA_WITH_AES_128_CBC_SHA | TLS_SRP_SHA_RSA_WITH_AES_128_CBC_SHA
TLS_SRP_SHA_RSA_WITH_AES_256_CBC_SHA | TLS_SRP_SHA_RSA_WITH_AES_256_CBC_SHA
TLS_SRP_SHA_WITH_3DES_EDE_CBC_SHA | TLS_SRP_SHA_WITH_3DES_EDE_CBC_SHA
TLS_SRP_SHA_WITH_AES_128_CBC_SHA | TLS_SRP_SHA_WITH_AES_128_CBC_SHA
TLS_SRP_SHA_WITH_AES_256_CBC_SHA | TLS_SRP_SHA_WITH_AES_256_CBC_SHA
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
MedicalConnections.Security.Enums.TlsCipher

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MedicalConnections.Security.Enums Namespace


MedicalConnections.Security.EventArguments Namespace

MedicalConnections.Security.EventArguments Namespace
Inheritance Hierarchy
Specific classes passed to events
Classes
 | Class | Description
Class | ModifyBindingsArgs | Class to hold data required for implementing custom transport binding arrangements
Class | ModifyCredentialArgs | Class to hold data required for implementing custom authentication arrangements
Class | OnConnectArgs | Event argument for the MedicalConnections.Security.ITlsServerSecurity.OnConnect event
See Also

Reference

Security.6.40 Assembly


ModifyBindingsArgs Class

ModifyBindingsArgs Class
Members

MedicalConnections.Security.EventArguments Namespace : ModifyBindingsArgs Class
Class to hold data required for implementing custom transport binding arrangements
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class ModifyBindingsArgs
Dim instance As ModifyBindingsArgs
public class ModifyBindingsArgs
public ref class ModifyBindingsArgs
Remarks
This is used in the ModifyBindings overridable method.
Inheritance Hierarchy

System.Object
MedicalConnections.Security.EventArguments.ModifyBindingsArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ModifyBindingsArgs Members
MedicalConnections.Security.EventArguments Namespace


ModifyBindingsArgs Class Members

ModifyBindingsArgs Class Members
Properties

MedicalConnections.Security.EventArguments Namespace : ModifyBindingsArgs Class

The following tables list the members exposed by ModifyBindingsArgs.

Public Constructors
 | Name | Description
Public Constructor | ModifyBindingsArgs Constructor |
Top
Public Properties
 | Name | Description
Public Property | Bindings | The set of bindings in existence when this method is called.
Public Property | Endpoint | The endpoint to which the connection is being made.
Top
See Also

Reference

ModifyBindingsArgs Class
MedicalConnections.Security.EventArguments Namespace


ModifyBindingsArgs Constructor

ModifyBindingsArgs Constructor

MedicalConnections.Security.EventArguments Namespace > ModifyBindingsArgs Class : ModifyBindingsArgs Constructor
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New ModifyBindingsArgs()
public ModifyBindingsArgs()
public:
ModifyBindingsArgs();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ModifyBindingsArgs Class
ModifyBindingsArgs Members


ModifyBindingsArgs Class Properties

ModifyBindingsArgs Class Properties

MedicalConnections.Security.EventArguments Namespace : ModifyBindingsArgs Class

For a list of all members of this type, see ModifyBindingsArgs members.

Public Properties
 | Name | Description
Public Property | Bindings | The set of bindings in existence when this method is called.
Public Property | Endpoint | The endpoint to which the connection is being made.
Top
See Also

Reference

ModifyBindingsArgs Class
MedicalConnections.Security.EventArguments Namespace


Bindings Property

Bindings Property

MedicalConnections.Security.EventArguments Namespace > ModifyBindingsArgs Class : Bindings Property
The set of bindings in existence when this method is called.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Bindings As BindingElement()
Dim instance As ModifyBindingsArgs
Dim value() As BindingElement

instance.Bindings = value

value = instance.Bindings
public BindingElement[] Bindings {get; set;}
public:
property array<BindingElement^>^ Bindings {
   array<BindingElement^>^ get();
   void set (    array<BindingElement^>^ value);
}
Remarks
This array may be replaced or otherwise modified if necessary
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ModifyBindingsArgs Class
ModifyBindingsArgs Members


Endpoint Property (ModifyBindingsArgs)

Endpoint Property (ModifyBindingsArgs)

MedicalConnections.Security.EventArguments Namespace > ModifyBindingsArgs Class : Endpoint Property
The endpoint to which the connection is being made.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Endpoint As EndpointAddress
Dim instance As ModifyBindingsArgs
Dim value As EndpointAddress

instance.Endpoint = value

value = instance.Endpoint
public EndpointAddress Endpoint {get; set;}
public:
property EndpointAddress^ Endpoint {
   EndpointAddress^ get();
   void set (    EndpointAddress^ value);
}
Remarks
Whilst this cannot be modified, it is provided in case the implementor wishes to use endpoint-specific behaviour
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ModifyBindingsArgs Class
ModifyBindingsArgs Members


ModifyCredentialArgs Class

ModifyCredentialArgs Class
Members

MedicalConnections.Security.EventArguments Namespace : ModifyCredentialArgs Class
Class to hold data required for implementing custom authentication arrangements
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class ModifyCredentialArgs
Dim instance As ModifyCredentialArgs
public class ModifyCredentialArgs
public ref class ModifyCredentialArgs
Remarks
This is used in the ModifyCredentials overridable method.
Inheritance Hierarchy

System.Object
MedicalConnections.Security.EventArguments.ModifyCredentialArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ModifyCredentialArgs Members
MedicalConnections.Security.EventArguments Namespace


ModifyCredentialArgs Class Members

ModifyCredentialArgs Class Members
Fields

MedicalConnections.Security.EventArguments Namespace : ModifyCredentialArgs Class

The following tables list the members exposed by ModifyCredentialArgs.

Public Constructors
 | Name | Description
Public Constructor | ModifyCredentialArgs Constructor |
Top
Public Fields
 | Name | Description
Public Field | Credentials | A standard Windows credentials object.
Top
See Also

Reference

ModifyCredentialArgs Class
MedicalConnections.Security.EventArguments Namespace


ModifyCredentialArgs Constructor

ModifyCredentialArgs Constructor

MedicalConnections.Security.EventArguments Namespace > ModifyCredentialArgs Class : ModifyCredentialArgs Constructor
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New ModifyCredentialArgs()
public ModifyCredentialArgs()
public:
ModifyCredentialArgs();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ModifyCredentialArgs Class
ModifyCredentialArgs Members


ModifyCredentialArgs Class Fields

ModifyCredentialArgs Class Fields

MedicalConnections.Security.EventArguments Namespace : ModifyCredentialArgs Class

For a list of all members of this type, see ModifyCredentialArgs members.

Public Fields
 | Name | Description
Public Field | Credentials | A standard Windows credentials object.
Top
See Also

Reference

ModifyCredentialArgs Class
MedicalConnections.Security.EventArguments Namespace


Credentials Field

Credentials Field

MedicalConnections.Security.EventArguments Namespace > ModifyCredentialArgs Class : Credentials Field
A standard Windows credentials object.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Credentials As ClientCredentials
Dim instance As ModifyCredentialArgs
Dim value As ClientCredentials

value = instance.Credentials

instance.Credentials = value
public ClientCredentials Credentials
public:
ClientCredentials^ Credentials
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ModifyCredentialArgs Class
ModifyCredentialArgs Members


OnConnectArgs Class

OnConnectArgs Class
Members

MedicalConnections.Security.EventArguments Namespace : OnConnectArgs Class
Event argument for the MedicalConnections.Security.ITlsServerSecurity.OnConnect event
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class OnConnectArgs
Dim instance As OnConnectArgs
public class OnConnectArgs
public ref class OnConnectArgs
Inheritance Hierarchy

System.Object
MedicalConnections.Security.EventArguments.OnConnectArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OnConnectArgs Members
MedicalConnections.Security.EventArguments Namespace


OnConnectArgs Class Members

OnConnectArgs Class Members
Properties

MedicalConnections.Security.EventArguments Namespace : OnConnectArgs Class

The following tables list the members exposed by OnConnectArgs.

Public Constructors
 | Name | Description
Public Constructor | OnConnectArgs Constructor |
Top
Public Properties
 | Name | Description
Public Property | Socket | The socket connected
Public Property | Stream | The stream passing through the socket
Top
See Also

Reference

OnConnectArgs Class
MedicalConnections.Security.EventArguments Namespace


OnConnectArgs Constructor

OnConnectArgs Constructor

MedicalConnections.Security.EventArguments Namespace > OnConnectArgs Class : OnConnectArgs Constructor
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New OnConnectArgs()
public OnConnectArgs()
public:
OnConnectArgs();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OnConnectArgs Class
OnConnectArgs Members


OnConnectArgs Class Properties

OnConnectArgs Class Properties

MedicalConnections.Security.EventArguments Namespace : OnConnectArgs Class

For a list of all members of this type, see OnConnectArgs members.

Public Properties
 | Name | Description
Public Property | Socket | The socket connected
Public Property | Stream | The stream passing through the socket
Top
See Also

Reference

OnConnectArgs Class
MedicalConnections.Security.EventArguments Namespace


Socket Property

Socket Property

MedicalConnections.Security.EventArguments Namespace > OnConnectArgs Class : Socket Property
The socket connected
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Socket As Socket
Dim instance As OnConnectArgs
Dim value As Socket

instance.Socket = value

value = instance.Socket
public Socket Socket {get; set;}
public:
property Socket^ Socket {
   Socket^ get();
   void set (    Socket^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OnConnectArgs Class
OnConnectArgs Members


Stream Property

Stream Property

MedicalConnections.Security.EventArguments Namespace > OnConnectArgs Class : Stream Property
The stream passing through the socket
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Stream As Stream
Dim instance As OnConnectArgs
Dim value As Stream

instance.Stream = value

value = instance.Stream
public Stream Stream {get; set;}
public:
property Stream^ Stream {
   Stream^ get();
   void set (    Stream^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OnConnectArgs Class
OnConnectArgs Members


XdsObjects.6.40 Assembly

XdsObjects.6.40 Assembly

The XdsObjects.6.40 Assembly hold XdsObjects, a toolkit for using XDS in many types of applications. For a general overview - see http://medicalconnections.co.uk/XdsObjects

Namespaces
Namespace | Description
XdsObjects | This namespace holds all the main XdsObjects
XdsObjects.Dsub |
XdsObjects.Enums | This namespace holds all the XdsObjects enumerations
XdsObjects.EventArguments | This namespace holds class which act as arguments for events and overrides


XdsObjects Namespace

XdsObjects Namespace
Inheritance Hierarchy
This namespace holds all the main XdsObjects
Classes
 | Class | Description
Class | AuditEndpoint | Class which represents an Audit Repository
Class | DicomSeries | A class which represents a single DicomSeries
Class | DicomStudy | Class which represents a single DICOM Study
Class | LicenseDialog | The customisable dialog used when a license needs to be acitvated or information about it needs to be displayed.
Class | PixQuery | Class used to handle PIX Queries
Class | WebServiceEndpoint | Defines an endpoint to which XdsObjects can make a connection.
Class | XdsAssociation | Class representing a "raw" ebXML association - as used by registries
Class | XdsAudit | Static class which encapsultates all the Auditing functionality
Class | XdsAudit.ParticipatingObject | The DICOM study details being audited
Class | XdsAuthor | Class representing the author of an XDS document or XDS SubmissionSet.
Class | XdsBaseServer | Base class used by the XdsSoapServer and XdsMtomServer classes
Class | XdsCode | An Class representing a "code" as used within the XDS/ebXML standard
Class | XdsDeleteDocumentSetRequest | Object that represents the XDS Delete Document Set Request
Class | XdsDocument | A class representing a single document as used in XDS
Class | XdsDocumentViewer | A viewer for XDS Documents
Class | XdsDomain | This class hold all the information required for an XDS domain to operate
Class | XdsError | Represents an error information as defined in the ebXML model
Class | XdsErrorItem | Class representing a single ebXML error
Class | XdsFolder | Class representing an XDS Folder
Class | XdsGlobal | A completely static class which holds various static methods and properties which relate to the application as a whole.
Class | XdsGlobal.LogEventArgs | Arguments for the XdsGlobal.LogEvent Event
Class | XdsImagingClient | Class which handles the multiple complexities involved in the XDS-I profile as a document consumer
Class | XdsImagingRetrieveRequest | Class which holds a complete request as used in the XDS RetrieveImageDocumentSet transaction (RAD-69)
Class | XdsImagingServer | Class which handles requests for images using the RetriveImageDocumentSet (RAD-69) tranaction
Class | XdsInternationalString | Represent an emXML InternationalString
Class | XdsLicense | This class handles all the new licensing scheme for XdsObjects.
Class | XdsMtomServer | A server which listens for incoming transactions for requests which include document data.
Class | XdsMultiString | Class representing one or more stings
Class | XdsObjectRef | Class representing a simple Object Reference
Class | XdsObjectRefList | Class used to hold lists of XdsObjectRef items
Class | XdsPatient | An Class representing a patient, and their IDs
Class | XdsPerson | Base class holding the attributes of a person
Class | XdsQueryRequest | Represents the data in a registry stored query
Class | XdsQueryResponse | Holds the result of an XDS RegistryStoredQuery or CrossGatewayQuery
Class | XdsRegistryResponse | Base class for all registry responses, whether generated or received by XdsObjects
Class | XdsRelationship | The relationship between one document and another
Class | XdsRequestInfo | Object representing requested information
Class | XdsRetrieveItem | Represents request for a single item within an XdsRetrieveRequest
Class | XdsRetrieveRequest | Class which holds a complete request as used in the XDS RetrieveDocumentSet transaction
Class | XdsRetrieveResponse | Class which holds the information passed from a repository to a consumer or other equivalent transactions such as CrossGatewayRetrieve. It is also used in XDS-I for holding the results of an TetrieveImagingDocumentSet transaction.
Class | XdsSlot | Class to hold Extra Slot information
Class | XdsSoapServer | A server which listens for incoming transactions for requests which do not include document data.
Class | XdsSubmissionSet | Class representing an XDS.b Submission Set
Delegates
 | Delegate | Description
Delegate | DeleteDocumentSetHandler | Delegate used for an incoming XdsSoapServer.DeleteReceived events
Delegate | ImagingRetrieveHandler | Delegate to hold the XdsImagingServer.ImageRequestReceived event
Delegate | RegisterDocumentSetHandler | Delegate used for an incoming XdsMtomServer.ProvideAndRegisterRequestReceived and XdsSoapServer.RegisterReceived events
Delegate | RetrieveHandler | Delegate used for incoming XdsMtomServer.RetrieveRequestReceived and XdsMtomServer.CrossGatewayRetrieveReceived events
Delegate | StoredQueryHandler | Delegate used by the RegistryStoredQueryReceived and XdsSoapServer.CrossGatewayQueryReceived events
Delegate | UpdateDocumentSetHandler | Delegate used for an incoming XdsSoapServer.UpdateReceived events
Delegate | XdsGlobal.LogHandler | Delegate for the XdsGlobal.LogEvent Event
Delegate | XdsLicense.RetrieveLicenseHandler | Delegate for the XdsLicense.RetrieveLicense event
Delegate | XdsLicense.StoreLicenseHandler | Delegate for XdsLicense.StoreLicense event
Delegate | XdsSoapServer.CreatePullPointRequestHandler | Event Hanlder of XDS DSUB CreatePullPoint Request
Delegate | XdsSoapServer.NotifyRequestHandler | Event Hanlder of XDS DSUB Notify Request
Delegate | XdsSoapServer.SubscriptionRequestHandler | Event Hanlder of XDS DSUB Subcription Request
Delegate | XdsSoapServer.UnsubscriptionRequestHandler | Event Hanlder of XDS DSUB Unsubcription Request
Enumerations
 | Enumeration | Description
Enumeration | XdsDomain.AuditSchemaType | Specify which Schema to use when formatting Audit message
See Also

Reference

XdsObjects.6.40 Assembly


AuditEndpoint Class

AuditEndpoint Class
Members

XdsObjects Namespace : AuditEndpoint Class
Class which represents an Audit Repository
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
<SerializableAttribute()>
Public Class AuditEndpoint
Dim instance As AuditEndpoint
[Serializable()]
public class AuditEndpoint
[Serializable()]
public ref class AuditEndpoint
Inheritance Hierarchy

System.Object
XdsObjects.AuditEndpoint

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AuditEndpoint Members
XdsObjects Namespace


AuditEndpoint Class Members

AuditEndpoint Class Members
Properties Methods

XdsObjects Namespace : AuditEndpoint Class

The following tables list the members exposed by AuditEndpoint.

Public Constructors
 | Name | Description
Public Constructor | AuditEndpoint Constructor | Construct a new, empty AuditEndpoint object
Top
Public Properties
 | Name | Description
Public Property | Host | Host name (as DNS name) or IP address of the audit endpoint
Public Property | Port | TCP or UDP port number of the audit endpoint
Public Property | Protocol | Protocol to use
Public Property | Security | The client security to use for communicating with this endpoint.
Public Property | SystemName | Human readable name of the AuditEnpoint
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

AuditEndpoint Class
XdsObjects Namespace


AuditEndpoint Constructor

AuditEndpoint Constructor

XdsObjects Namespace > AuditEndpoint Class : AuditEndpoint Constructor
Construct a new, empty AuditEndpoint object
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New AuditEndpoint()
public AuditEndpoint()
public:
AuditEndpoint();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AuditEndpoint Class
AuditEndpoint Members


AuditEndpoint Class Methods

AuditEndpoint Class Methods

XdsObjects Namespace : AuditEndpoint Class

For a list of all members of this type, see AuditEndpoint members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

AuditEndpoint Class
XdsObjects Namespace


ToString Method (AuditEndpoint)

ToString Method (AuditEndpoint)

XdsObjects Namespace > AuditEndpoint Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overrides Function ToString() As String
Dim instance As AuditEndpoint
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AuditEndpoint Class
AuditEndpoint Members
Base Implementation in ToString


AuditEndpoint Class Properties

AuditEndpoint Class Properties

XdsObjects Namespace : AuditEndpoint Class

For a list of all members of this type, see AuditEndpoint members.

Public Properties
 | Name | Description
Public Property | Host | Host name (as DNS name) or IP address of the audit endpoint
Public Property | Port | TCP or UDP port number of the audit endpoint
Public Property | Protocol | Protocol to use
Public Property | Security | The client security to use for communicating with this endpoint.
Public Property | SystemName | Human readable name of the AuditEnpoint
Top
See Also

Reference

AuditEndpoint Class
XdsObjects Namespace


Host Property

Host Property

XdsObjects Namespace > AuditEndpoint Class : Host Property
Host name (as DNS name) or IP address of the audit endpoint
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Host As String
Dim instance As AuditEndpoint
Dim value As String

instance.Host = value

value = instance.Host
public string Host {get; set;}
public:
property String^ Host {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AuditEndpoint Class
AuditEndpoint Members


Port Property

Port Property

XdsObjects Namespace > AuditEndpoint Class : Port Property
TCP or UDP port number of the audit endpoint
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Port As Integer
Dim instance As AuditEndpoint
Dim value As Integer

instance.Port = value

value = instance.Port
public int Port {get; set;}
public:
property int Port {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AuditEndpoint Class
AuditEndpoint Members


Protocol Property

Protocol Property

XdsObjects Namespace > AuditEndpoint Class : Protocol Property
Protocol to use
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Protocol As AuditProtocol
Dim instance As AuditEndpoint
Dim value As AuditProtocol

instance.Protocol = value

value = instance.Protocol
public AuditProtocol Protocol {get; set;}
public:
property AuditProtocol Protocol {
   AuditProtocol get();
   void set (    AuditProtocol value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AuditEndpoint Class
AuditEndpoint Members


Security Property (AuditEndpoint)

Security Property (AuditEndpoint)

XdsObjects Namespace > AuditEndpoint Class : Security Property
The client security to use for communicating with this endpoint.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Security As ITlsClientSecurity
Dim instance As AuditEndpoint
Dim value As ITlsClientSecurity

instance.Security = value

value = instance.Security
public ITlsClientSecurity Security {get; set;}
public:
property ITlsClientSecurity^ Security {
   ITlsClientSecurity^ get();
   void set (    ITlsClientSecurity^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AuditEndpoint Class
AuditEndpoint Members


SystemName Property

SystemName Property

XdsObjects Namespace > AuditEndpoint Class : SystemName Property
Human readable name of the AuditEnpoint
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property SystemName As String
Dim instance As AuditEndpoint
Dim value As String

instance.SystemName = value

value = instance.SystemName
public string SystemName {get; set;}
public:
property String^ SystemName {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AuditEndpoint Class
AuditEndpoint Members


DicomSeries Class

DicomSeries Class
Members

XdsObjects Namespace : DicomSeries Class
A class which represents a single DicomSeries
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class DicomSeries
Dim instance As DicomSeries
public class DicomSeries
public ref class DicomSeries
Remarks
This is a very simple class, which merely holds the information about a series, which in turn exists within a DicomStudy object in an XdsImagingRetrieveRequest object.
Inheritance Hierarchy

System.Object
XdsObjects.DicomSeries

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DicomSeries Members
XdsObjects Namespace


DicomSeries Class Members

DicomSeries Class Members
Properties

XdsObjects Namespace : DicomSeries Class

The following tables list the members exposed by DicomSeries.

Public Constructors
 | Name | Description
Public Constructor | DicomSeries Constructor | Overloaded. Create a new DicomSeries object
Top
Public Properties
 | Name | Description
Public Property | DocumentUniqueIds | The list of instance UIDs for the objects within this series which are being requested.
Public Property | SeriesInstanceUID | The UID of the series
Top
See Also

Reference

DicomSeries Class
XdsObjects Namespace


DicomSeries Constructor

DicomSeries Constructor

XdsObjects Namespace > DicomSeries Class : DicomSeries Constructor
Create a new DicomSeries object
Overload List
Overload | Description
DicomSeries Constructor() | Create a new DicomSeries object
DicomSeries Constructor(String) | Create a new DicomSeries object with a defined SeriesUID
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DicomSeries Class
DicomSeries Members


DicomSeries Constructor()

DicomSeries Constructor()

XdsObjects Namespace > DicomSeries Class > DicomSeries Constructor : DicomSeries Constructor()
Create a new DicomSeries object
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New DicomSeries()
public DicomSeries()
public:
DicomSeries();
Remarks
As every Series must have a UID, the DicomSeries Constructor(String) form is normally used in user code - this version is only really for use by the internal XML serialization.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DicomSeries Class
DicomSeries Members
Overload List


DicomSeries Constructor(String)

DicomSeries Constructor(String)

XdsObjects Namespace > DicomSeries Class > DicomSeries Constructor : DicomSeries Constructor(String)
The Series Instance UID
Create a new DicomSeries object with a defined SeriesUID
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal SeriesUID As String _
)
Dim SeriesUID As String

Dim instance As New DicomSeries(SeriesUID)
public DicomSeries(
   string SeriesUID
)
public:
DicomSeries(
   String^ SeriesUID
)

Parameters

SeriesUID
The Series Instance UID
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DicomSeries Class
DicomSeries Members
Overload List


DicomSeries Class Properties

DicomSeries Class Properties

XdsObjects Namespace : DicomSeries Class

For a list of all members of this type, see DicomSeries members.

Public Properties
 | Name | Description
Public Property | DocumentUniqueIds | The list of instance UIDs for the objects within this series which are being requested.
Public Property | SeriesInstanceUID | The UID of the series
Top
See Also

Reference

DicomSeries Class
XdsObjects Namespace


DocumentUniqueIds Property

DocumentUniqueIds Property

XdsObjects Namespace > DicomSeries Class : DocumentUniqueIds Property
The list of instance UIDs for the objects within this series which are being requested.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DocumentUniqueIds As List(Of String)
Dim instance As DicomSeries
Dim value As List(Of String)

instance.DocumentUniqueIds = value

value = instance.DocumentUniqueIds
public List<string> DocumentUniqueIds {get; set;}
public:
property List<String^>^ DocumentUniqueIds {
   List<String^>^ get();
   void set (    List<String^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DicomSeries Class
DicomSeries Members


SeriesInstanceUID Property

SeriesInstanceUID Property

XdsObjects Namespace > DicomSeries Class : SeriesInstanceUID Property
The UID of the series
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property SeriesInstanceUID As String
Dim instance As DicomSeries
Dim value As String

instance.SeriesInstanceUID = value

value = instance.SeriesInstanceUID
public string SeriesInstanceUID {get; set;}
public:
property String^ SeriesInstanceUID {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DicomSeries Class
DicomSeries Members


DicomStudy Class

DicomStudy Class
Members

XdsObjects Namespace : DicomStudy Class
Class which represents a single DICOM Study
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class DicomStudy
Dim instance As DicomStudy
public class DicomStudy
public ref class DicomStudy
Remarks
This is a very simple class, which merely holds the information about a study in an XdsImagingRetrieveRequest object. It holds details of the Series (DicomSeries) objects within it.
Inheritance Hierarchy

System.Object
XdsObjects.DicomStudy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DicomStudy Members
XdsObjects Namespace


DicomStudy Class Members

DicomStudy Class Members
Properties

XdsObjects Namespace : DicomStudy Class

The following tables list the members exposed by DicomStudy.

Public Constructors
 | Name | Description
Public Constructor | DicomStudy Constructor | Overloaded. Create a new DicomStudy object
Top
Public Properties
 | Name | Description
Public Property | Series | The list of DicomSeries objects requested from this Study
Public Property | StudyInstanceUID | The Study Instance UID
Top
See Also

Reference

DicomStudy Class
XdsObjects Namespace


DicomStudy Constructor

DicomStudy Constructor

XdsObjects Namespace > DicomStudy Class : DicomStudy Constructor
Create a new DicomStudy object
Overload List
Overload | Description
DicomStudy Constructor() | Create a new DicomStudy object
DicomStudy Constructor(String) | Create a new DicomStudy object with a defined StudyUID
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DicomStudy Class
DicomStudy Members


DicomStudy Constructor()

DicomStudy Constructor()

XdsObjects Namespace > DicomStudy Class > DicomStudy Constructor : DicomStudy Constructor()
Create a new DicomStudy object
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New DicomStudy()
public DicomStudy()
public:
DicomStudy();
Remarks
As every Study must have a UID, the DicomStudy Constructor(String) form is normally used in user code - this version is only really for use by the internal XML serialization.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DicomStudy Class
DicomStudy Members
Overload List


DicomStudy Constructor(String)

DicomStudy Constructor(String)

XdsObjects Namespace > DicomStudy Class > DicomStudy Constructor : DicomStudy Constructor(String)
The Study Instance UID
Create a new DicomStudy object with a defined StudyUID
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal StudyUID As String _
)
Dim StudyUID As String

Dim instance As New DicomStudy(StudyUID)
public DicomStudy(
   string StudyUID
)
public:
DicomStudy(
   String^ StudyUID
)

Parameters

StudyUID
The Study Instance UID
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DicomStudy Class
DicomStudy Members
Overload List


DicomStudy Class Properties

DicomStudy Class Properties

XdsObjects Namespace : DicomStudy Class

For a list of all members of this type, see DicomStudy members.

Public Properties
 | Name | Description
Public Property | Series | The list of DicomSeries objects requested from this Study
Public Property | StudyInstanceUID | The Study Instance UID
Top
See Also

Reference

DicomStudy Class
XdsObjects Namespace


Series Property

Series Property

XdsObjects Namespace > DicomStudy Class : Series Property
The list of DicomSeries objects requested from this Study
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Series As List(Of DicomSeries)
Dim instance As DicomStudy
Dim value As List(Of DicomSeries)

instance.Series = value

value = instance.Series
public List<DicomSeries> Series {get; set;}
public:
property List<DicomSeries^>^ Series {
   List<DicomSeries^>^ get();
   void set (    List<DicomSeries^>^ value);
}
Remarks
The list of series requested does not necessarily included all series which exist in the study
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DicomStudy Class
DicomStudy Members


StudyInstanceUID Property

StudyInstanceUID Property

XdsObjects Namespace > DicomStudy Class : StudyInstanceUID Property
The Study Instance UID
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property StudyInstanceUID As String
Dim instance As DicomStudy
Dim value As String

instance.StudyInstanceUID = value

value = instance.StudyInstanceUID
public string StudyInstanceUID {get; set;}
public:
property String^ StudyInstanceUID {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DicomStudy Class
DicomStudy Members


LicenseDialog Class

LicenseDialog Class
Members

XdsObjects Namespace : LicenseDialog Class
The customisable dialog used when a license needs to be acitvated or information about it needs to be displayed.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class LicenseDialog
   Inherits System.Windows.Forms.Form
Dim instance As LicenseDialog
public class LicenseDialog : System.Windows.Forms.Form
public ref class LicenseDialog : public System.Windows.Forms.Form
Remarks

This dialog uses ONLY public methods of other objects, such as XdsLicense.ActivateOnLine and hence all functionality can be replaced by develolpers if you wish, but alternatively, for a simpler implementation you can simply customise the properties of this dialog or even derive one from it.

There is always one static copy of this dialog (XdsLicense.Dialog) which will be used for most functions by XdsObjects, but note that a clean (non-customisable) copy is used for the "nag" screens on trial and developer licenses, to prevent abuse of those licenses in commercial products.

The dialog is used in 2 forms, a "full" form when a license needs to be obtained, and a shortened form when only information needs to be shown (e.g. a license about to expire).

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
XdsObjects.LicenseDialog

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Members
XdsObjects Namespace


LicenseDialog Class Members

LicenseDialog Class Members
Fields Properties Methods Events

XdsObjects Namespace : LicenseDialog Class

The following tables list the members exposed by LicenseDialog.

Public Constructors
 | Name | Description
Public Constructor | LicenseDialog Constructor | Creates a new LicenseDialog
Top
Public Fields
 | Name | Description
Public Field | ActivateOffLine | The Activate OffLine Button
Public Field | ActivateOnLine | The Activate OnLine Button
Public Field | ActivationTabs | The TabControl holding the OnLine and OffLine tabs.
Public Field | AuthorisationString | The box containging the AuthorisationString
Public Field | AuthorisationStringLabel | The AuthorisationString text label.
Public Field | Cancel | The Cancel button
Public Field | CustomerInfo1 | The Customer Information 1 text entry box
Public Field | CustomerInfo1Label | The label holding the default text "Customer Information 1"
Public Field | CustomerInfo2 | The Customer Information 2 text entry box
Public Field | CustomerInfo2Label | The label holding the default text "Customer Information 2"
Public Field | Description | The message at the top of the dialog
Public Field | LicenseInfoButton | The button which enlarges the dialog from information mode to activation mode
Public Field | LicenseToken | The LicenseToken text entry box
Public Field | LicenseTokenLabel | The label holding the default text "License Token"
Public Field | LogoPictureBox | Replaceable logo for the license dialog
Public Field | MachineID | The Machine ID text entry box
Public Field | MachineIDLabel | The label holding the default text "Machine ID"
Public Field | OffLine | The TabPage offering OffLine activation
Public Field | OffLineDescription | The text describing Off-LIne activation
Public Field | OK1 | The OK button (shown only when in "small" information mode)
Public Field | OnLine | The TabPage offering OnLine activation
Public Field | OnLineDescription | The text describing On-Line activation
Top
Public Properties
 | Name | Description
Public Property | AcceptButton | (Inherited from System.Windows.Forms.Form)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.Form)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.Form)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.Form)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.Form)
Public Property | BackColor | (Inherited from System.Windows.Forms.Form)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | CancelButton | (Inherited from System.Windows.Forms.Form)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Form)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | ControlBox | (Inherited from System.Windows.Forms.Form)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | FormBorderStyle | (Inherited from System.Windows.Forms.Form)
Public Property | HelpButton | (Inherited from System.Windows.Forms.Form)
Public Property | Icon | (Inherited from System.Windows.Forms.Form)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | IsMdiContainer | (Inherited from System.Windows.Forms.Form)
Public Property | KeyPreview | (Inherited from System.Windows.Forms.Form)
Public Property | Location | (Inherited from System.Windows.Forms.Form)
Public Property | MainMenuStrip | (Inherited from System.Windows.Forms.Form)
Public Property | MaximizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Form)
Public Property | MinimizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Form)
Public Property | Opacity | (Inherited from System.Windows.Forms.Form)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeftLayout | (Inherited from System.Windows.Forms.Form)
Public Property | ShowIcon | (Inherited from System.Windows.Forms.Form)
Public Property | ShowInTaskbar | (Inherited from System.Windows.Forms.Form)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Form)
Public Property | SizeGripStyle | (Inherited from System.Windows.Forms.Form)
Public Property | StartPosition | (Inherited from System.Windows.Forms.Form)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.Form)
Public Property | TopMost | (Inherited from System.Windows.Forms.Form)
Public Property | TransparencyKey | (Inherited from System.Windows.Forms.Form)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | WindowState | (Inherited from System.Windows.Forms.Form)
Top
Protected Properties
 | Name | Description
Protected Property | AutoScaleFactor | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.Form)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Form)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultSize | (Inherited from System.Windows.Forms.Form)
Protected Property | DoubleBuffered | (Inherited from System.Windows.Forms.Control)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | HScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | ImeModeBase | (Inherited from System.Windows.Forms.Control)
Protected Property | MaximizedBounds | (Inherited from System.Windows.Forms.Form)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from System.Windows.Forms.Control)
Protected Property | VScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Top
Public Methods
 | Name | Description
Public Method | Activate | (Inherited from System.Windows.Forms.Form)
Public Method | AddOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Close | (Inherited from System.Windows.Forms.Form)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Overridden. Dispose the LicenseDialog
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | LayoutMdi | (Inherited from System.Windows.Forms.Form)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RemoveOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetDesktopBounds | (Inherited from System.Windows.Forms.Form)
Public Method | SetDesktopLocation | (Inherited from System.Windows.Forms.Form)
Public Method | Show | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | ShowActivation | Control whether the full (activation) mode of the dialog is shown
Public Method | ShowDialog | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.Windows.Forms.Form)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.Form)
Top
Protected Methods
 | Name | Description
Protected Method | ActivateMdiChild | (Inherited from System.Windows.Forms.Form)
Protected Method | AdjustFormScrollbars | (Inherited from System.Windows.Forms.Form)
Protected Method | CenterToParent | (Inherited from System.Windows.Forms.Form)
Protected Method | CenterToScreen | (Inherited from System.Windows.Forms.Form)
Protected Method | CreateAccessibilityInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Form)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.Form)
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Form)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.Form)
Protected Method | GetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | InitLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputKey | (Inherited from System.Windows.Forms.Control)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnActivated | (Inherited from System.Windows.Forms.Form)
Protected Method | OnAutoSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoValidateChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClosed | (Inherited from System.Windows.Forms.Form)
Protected Method | OnClosing | (Inherited from System.Windows.Forms.Form)
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | (Inherited from System.Windows.Forms.Form)
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDeactivate | (Inherited from System.Windows.Forms.Form)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnabledChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Form)
Protected Method | OnFontChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFormClosed | (Inherited from System.Windows.Forms.Form)
Protected Method | OnFormClosing | (Inherited from System.Windows.Forms.Form)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.Form)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.Form)
Protected Method | OnHelpButtonClicked | (Inherited from System.Windows.Forms.Form)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInputLanguageChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnInputLanguageChanging | (Inherited from System.Windows.Forms.Form)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyPress | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLayout | (Inherited from System.Windows.Forms.Form)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLoad | (Inherited from System.Windows.Forms.Form)
Protected Method | OnLocationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMaximizedBoundsChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMaximumSizeChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMdiChildActivate | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMenuComplete | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMenuStart | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMinimumSizeChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseHover | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnPaint | (Inherited from System.Windows.Forms.Form)
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from System.Windows.Forms.Form)
Protected Method | OnResizeBegin | (Inherited from System.Windows.Forms.Form)
Protected Method | OnResizeEnd | (Inherited from System.Windows.Forms.Form)
Protected Method | OnRightToLeftChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnRightToLeftLayoutChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnShown | (Inherited from System.Windows.Forms.Form)
Protected Method | OnSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabIndexChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnValidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidating | (Inherited from System.Windows.Forms.Control)
Protected Method | OnVisibleChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessCmdKey | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessDialogKey | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessTabKey | (Inherited from System.Windows.Forms.Form)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from System.Windows.Forms.Form)
Protected Method | ScrollToControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from System.Windows.Forms.Form)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Form)
Protected Method | SetDisplayRectLocation | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Form)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateDefaultButton | (Inherited from System.Windows.Forms.Form)
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WndProc | (Inherited from System.Windows.Forms.Form)
Top
Public Events
 | Name | Description
Public Event | Activated | (Inherited from System.Windows.Forms.Form)
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.Form)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Deactivate | (Inherited from System.Windows.Forms.Form)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | FormClosed | (Inherited from System.Windows.Forms.Form)
Public Event | FormClosing | (Inherited from System.Windows.Forms.Form)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | HelpButtonClicked | (Inherited from System.Windows.Forms.Form)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | InputLanguageChanged | (Inherited from System.Windows.Forms.Form)
Public Event | InputLanguageChanging | (Inherited from System.Windows.Forms.Form)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.Form)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MaximizedBoundsChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MaximumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MdiChildActivate | (Inherited from System.Windows.Forms.Form)
Public Event | MinimumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | ResizeBegin | (Inherited from System.Windows.Forms.Form)
Public Event | ResizeEnd | (Inherited from System.Windows.Forms.Form)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftLayoutChanged | (Inherited from System.Windows.Forms.Form)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | Shown | (Inherited from System.Windows.Forms.Form)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

LicenseDialog Class
XdsObjects Namespace


LicenseDialog Constructor

LicenseDialog Constructor

XdsObjects Namespace > LicenseDialog Class : LicenseDialog Constructor
Creates a new LicenseDialog
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New LicenseDialog()
public LicenseDialog()
public:
LicenseDialog();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


LicenseDialog Class Methods

LicenseDialog Class Methods

XdsObjects Namespace : LicenseDialog Class

For a list of all members of this type, see LicenseDialog members.

Public Methods
 | Name | Description
Public Method | Activate | (Inherited from System.Windows.Forms.Form)
Public Method | AddOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Close | (Inherited from System.Windows.Forms.Form)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Overridden. Dispose the LicenseDialog
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | LayoutMdi | (Inherited from System.Windows.Forms.Form)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RemoveOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetDesktopBounds | (Inherited from System.Windows.Forms.Form)
Public Method | SetDesktopLocation | (Inherited from System.Windows.Forms.Form)
Public Method | Show | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | ShowActivation | Control whether the full (activation) mode of the dialog is shown
Public Method | ShowDialog | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.Windows.Forms.Form)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.Form)
Top
Protected Methods
 | Name | Description
Protected Method | ActivateMdiChild | (Inherited from System.Windows.Forms.Form)
Protected Method | AdjustFormScrollbars | (Inherited from System.Windows.Forms.Form)
Protected Method | CenterToParent | (Inherited from System.Windows.Forms.Form)
Protected Method | CenterToScreen | (Inherited from System.Windows.Forms.Form)
Protected Method | CreateAccessibilityInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Form)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.Form)
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Form)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.Form)
Protected Method | GetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | InitLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputKey | (Inherited from System.Windows.Forms.Control)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnActivated | (Inherited from System.Windows.Forms.Form)
Protected Method | OnAutoSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoValidateChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClosed | (Inherited from System.Windows.Forms.Form)
Protected Method | OnClosing | (Inherited from System.Windows.Forms.Form)
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | (Inherited from System.Windows.Forms.Form)
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDeactivate | (Inherited from System.Windows.Forms.Form)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnabledChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Form)
Protected Method | OnFontChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFormClosed | (Inherited from System.Windows.Forms.Form)
Protected Method | OnFormClosing | (Inherited from System.Windows.Forms.Form)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.Form)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.Form)
Protected Method | OnHelpButtonClicked | (Inherited from System.Windows.Forms.Form)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInputLanguageChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnInputLanguageChanging | (Inherited from System.Windows.Forms.Form)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyPress | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLayout | (Inherited from System.Windows.Forms.Form)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLoad | (Inherited from System.Windows.Forms.Form)
Protected Method | OnLocationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMaximizedBoundsChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMaximumSizeChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMdiChildActivate | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMenuComplete | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMenuStart | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMinimumSizeChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseHover | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnPaint | (Inherited from System.Windows.Forms.Form)
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from System.Windows.Forms.Form)
Protected Method | OnResizeBegin | (Inherited from System.Windows.Forms.Form)
Protected Method | OnResizeEnd | (Inherited from System.Windows.Forms.Form)
Protected Method | OnRightToLeftChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnRightToLeftLayoutChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnShown | (Inherited from System.Windows.Forms.Form)
Protected Method | OnSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabIndexChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnValidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidating | (Inherited from System.Windows.Forms.Control)
Protected Method | OnVisibleChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessCmdKey | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessDialogKey | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessTabKey | (Inherited from System.Windows.Forms.Form)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from System.Windows.Forms.Form)
Protected Method | ScrollToControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from System.Windows.Forms.Form)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Form)
Protected Method | SetDisplayRectLocation | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Form)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateDefaultButton | (Inherited from System.Windows.Forms.Form)
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WndProc | (Inherited from System.Windows.Forms.Form)
Top
See Also

Reference

LicenseDialog Class
XdsObjects Namespace


Dispose Method (LicenseDialog)

Dispose Method (LicenseDialog)

XdsObjects Namespace > LicenseDialog Class : Dispose Method
Dispose the LicenseDialog
Overload List
Overload | Description
Dispose(Boolean) | Clean up any resources being used.
Dispose() | (Inherited from System.ComponentModel.Component)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members
Base Implementation in Dispose


Dispose(Boolean) Method

Dispose(Boolean) Method

XdsObjects Namespace > LicenseDialog Class > Dispose Method : Dispose(Boolean) Method
true if the dialog is being explicitly disposed
Clean up any resources being used.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
Dim instance As LicenseDialog
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
true if the dialog is being explicitly disposed
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members
Overload List
Base Implementation in Dispose(Boolean)


ShowActivation Method

ShowActivation Method

XdsObjects Namespace > LicenseDialog Class : ShowActivation Method
True is the full dialog is to be shown and false if the smaller "information" mode should be used.
Control whether the full (activation) mode of the dialog is shown
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub ShowActivation( _
   ByVal Show As Boolean _
)
Dim instance As LicenseDialog
Dim Show As Boolean

instance.ShowActivation(Show)
public void ShowActivation(
   bool Show
)
public:
void ShowActivation(
   bool Show
)

Parameters

Show
True is the full dialog is to be shown and false if the smaller "information" mode should be used.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


LicenseDialog Class Fields

LicenseDialog Class Fields

XdsObjects Namespace : LicenseDialog Class

For a list of all members of this type, see LicenseDialog members.

Public Fields
 | Name | Description
Public Field | ActivateOffLine | The Activate OffLine Button
Public Field | ActivateOnLine | The Activate OnLine Button
Public Field | ActivationTabs | The TabControl holding the OnLine and OffLine tabs.
Public Field | AuthorisationString | The box containging the AuthorisationString
Public Field | AuthorisationStringLabel | The AuthorisationString text label.
Public Field | Cancel | The Cancel button
Public Field | CustomerInfo1 | The Customer Information 1 text entry box
Public Field | CustomerInfo1Label | The label holding the default text "Customer Information 1"
Public Field | CustomerInfo2 | The Customer Information 2 text entry box
Public Field | CustomerInfo2Label | The label holding the default text "Customer Information 2"
Public Field | Description | The message at the top of the dialog
Public Field | LicenseInfoButton | The button which enlarges the dialog from information mode to activation mode
Public Field | LicenseToken | The LicenseToken text entry box
Public Field | LicenseTokenLabel | The label holding the default text "License Token"
Public Field | LogoPictureBox | Replaceable logo for the license dialog
Public Field | MachineID | The Machine ID text entry box
Public Field | MachineIDLabel | The label holding the default text "Machine ID"
Public Field | OffLine | The TabPage offering OffLine activation
Public Field | OffLineDescription | The text describing Off-LIne activation
Public Field | OK1 | The OK button (shown only when in "small" information mode)
Public Field | OnLine | The TabPage offering OnLine activation
Public Field | OnLineDescription | The text describing On-Line activation
Top
See Also

Reference

LicenseDialog Class
XdsObjects Namespace


ActivateOffLine Field

ActivateOffLine Field

XdsObjects Namespace > LicenseDialog Class : ActivateOffLine Field
The Activate OffLine Button
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ActivateOffLine As Button
Dim instance As LicenseDialog
Dim value As Button

value = instance.ActivateOffLine

instance.ActivateOffLine = value
public Button ActivateOffLine
public:
Button^ ActivateOffLine
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


ActivateOnLine Field

ActivateOnLine Field

XdsObjects Namespace > LicenseDialog Class : ActivateOnLine Field
The Activate OnLine Button
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ActivateOnLine As Button
Dim instance As LicenseDialog
Dim value As Button

value = instance.ActivateOnLine

instance.ActivateOnLine = value
public Button ActivateOnLine
public:
Button^ ActivateOnLine
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


ActivationTabs Field

ActivationTabs Field

XdsObjects Namespace > LicenseDialog Class : ActivationTabs Field
The TabControl holding the OnLine and OffLine tabs.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ActivationTabs As TabControl
Dim instance As LicenseDialog
Dim value As TabControl

value = instance.ActivationTabs

instance.ActivationTabs = value
public TabControl ActivationTabs
public:
TabControl^ ActivationTabs
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


AuthorisationString Field

AuthorisationString Field

XdsObjects Namespace > LicenseDialog Class : AuthorisationString Field
The box containging the AuthorisationString
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public AuthorisationString As TextBox
Dim instance As LicenseDialog
Dim value As TextBox

value = instance.AuthorisationString

instance.AuthorisationString = value
public TextBox AuthorisationString
public:
TextBox^ AuthorisationString
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


AuthorisationStringLabel Field

AuthorisationStringLabel Field

XdsObjects Namespace > LicenseDialog Class : AuthorisationStringLabel Field
The AuthorisationString text label.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public AuthorisationStringLabel As Label
Dim instance As LicenseDialog
Dim value As Label

value = instance.AuthorisationStringLabel

instance.AuthorisationStringLabel = value
public Label AuthorisationStringLabel
public:
Label^ AuthorisationStringLabel
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


Cancel Field

Cancel Field

XdsObjects Namespace > LicenseDialog Class : Cancel Field
The Cancel button
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Cancel As Button
Dim instance As LicenseDialog
Dim value As Button

value = instance.Cancel

instance.Cancel = value
public Button Cancel
public:
Button^ Cancel
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


CustomerInfo1 Field

CustomerInfo1 Field

XdsObjects Namespace > LicenseDialog Class : CustomerInfo1 Field
The Customer Information 1 text entry box
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public CustomerInfo1 As TextBox
Dim instance As LicenseDialog
Dim value As TextBox

value = instance.CustomerInfo1

instance.CustomerInfo1 = value
public TextBox CustomerInfo1
public:
TextBox^ CustomerInfo1
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


CustomerInfo1Label Field

CustomerInfo1Label Field

XdsObjects Namespace > LicenseDialog Class : CustomerInfo1Label Field
The label holding the default text "Customer Information 1"
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public CustomerInfo1Label As Label
Dim instance As LicenseDialog
Dim value As Label

value = instance.CustomerInfo1Label

instance.CustomerInfo1Label = value
public Label CustomerInfo1Label
public:
Label^ CustomerInfo1Label
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


CustomerInfo2 Field

CustomerInfo2 Field

XdsObjects Namespace > LicenseDialog Class : CustomerInfo2 Field
The Customer Information 2 text entry box
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public CustomerInfo2 As TextBox
Dim instance As LicenseDialog
Dim value As TextBox

value = instance.CustomerInfo2

instance.CustomerInfo2 = value
public TextBox CustomerInfo2
public:
TextBox^ CustomerInfo2
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


CustomerInfo2Label Field

CustomerInfo2Label Field

XdsObjects Namespace > LicenseDialog Class : CustomerInfo2Label Field
The label holding the default text "Customer Information 2"
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public CustomerInfo2Label As Label
Dim instance As LicenseDialog
Dim value As Label

value = instance.CustomerInfo2Label

instance.CustomerInfo2Label = value
public Label CustomerInfo2Label
public:
Label^ CustomerInfo2Label
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


Description Field

Description Field

XdsObjects Namespace > LicenseDialog Class : Description Field
The message at the top of the dialog
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Description As Label
Dim instance As LicenseDialog
Dim value As Label

value = instance.Description

instance.Description = value
public Label Description
public:
Label^ Description
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


LicenseInfoButton Field

LicenseInfoButton Field

XdsObjects Namespace > LicenseDialog Class : LicenseInfoButton Field
The button which enlarges the dialog from information mode to activation mode
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public LicenseInfoButton As Button
Dim instance As LicenseDialog
Dim value As Button

value = instance.LicenseInfoButton

instance.LicenseInfoButton = value
public Button LicenseInfoButton
public:
Button^ LicenseInfoButton
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


LicenseToken Field

LicenseToken Field

XdsObjects Namespace > LicenseDialog Class : LicenseToken Field
The LicenseToken text entry box
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public LicenseToken As TextBox
Dim instance As LicenseDialog
Dim value As TextBox

value = instance.LicenseToken

instance.LicenseToken = value
public TextBox LicenseToken
public:
TextBox^ LicenseToken
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


LicenseTokenLabel Field

LicenseTokenLabel Field

XdsObjects Namespace > LicenseDialog Class : LicenseTokenLabel Field
The label holding the default text "License Token"
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public LicenseTokenLabel As Label
Dim instance As LicenseDialog
Dim value As Label

value = instance.LicenseTokenLabel

instance.LicenseTokenLabel = value
public Label LicenseTokenLabel
public:
Label^ LicenseTokenLabel
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


LogoPictureBox Field

LogoPictureBox Field

XdsObjects Namespace > LicenseDialog Class : LogoPictureBox Field
Replaceable logo for the license dialog
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public LogoPictureBox As PictureBox
Dim instance As LicenseDialog
Dim value As PictureBox

value = instance.LogoPictureBox

instance.LogoPictureBox = value
public PictureBox LogoPictureBox
public:
PictureBox^ LogoPictureBox
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


MachineID Field

MachineID Field

XdsObjects Namespace > LicenseDialog Class : MachineID Field
The Machine ID text entry box
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public MachineID As TextBox
Dim instance As LicenseDialog
Dim value As TextBox

value = instance.MachineID

instance.MachineID = value
public TextBox MachineID
public:
TextBox^ MachineID
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


MachineIDLabel Field

MachineIDLabel Field

XdsObjects Namespace > LicenseDialog Class : MachineIDLabel Field
The label holding the default text "Machine ID"
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public MachineIDLabel As Label
Dim instance As LicenseDialog
Dim value As Label

value = instance.MachineIDLabel

instance.MachineIDLabel = value
public Label MachineIDLabel
public:
Label^ MachineIDLabel
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


OffLine Field

OffLine Field

XdsObjects Namespace > LicenseDialog Class : OffLine Field
The TabPage offering OffLine activation
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public OffLine As TabPage
Dim instance As LicenseDialog
Dim value As TabPage

value = instance.OffLine

instance.OffLine = value
public TabPage OffLine
public:
TabPage^ OffLine
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


OffLineDescription Field

OffLineDescription Field

XdsObjects Namespace > LicenseDialog Class : OffLineDescription Field
The text describing Off-LIne activation
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public OffLineDescription As Label
Dim instance As LicenseDialog
Dim value As Label

value = instance.OffLineDescription

instance.OffLineDescription = value
public Label OffLineDescription
public:
Label^ OffLineDescription
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


OK1 Field

OK1 Field

XdsObjects Namespace > LicenseDialog Class : OK1 Field
The OK button (shown only when in "small" information mode)
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public OK1 As Button
Dim instance As LicenseDialog
Dim value As Button

value = instance.OK1

instance.OK1 = value
public Button OK1
public:
Button^ OK1
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


OnLine Field

OnLine Field

XdsObjects Namespace > LicenseDialog Class : OnLine Field
The TabPage offering OnLine activation
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public OnLine As TabPage
Dim instance As LicenseDialog
Dim value As TabPage

value = instance.OnLine

instance.OnLine = value
public TabPage OnLine
public:
TabPage^ OnLine
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


OnLineDescription Field

OnLineDescription Field

XdsObjects Namespace > LicenseDialog Class : OnLineDescription Field
The text describing On-Line activation
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public OnLineDescription As Label
Dim instance As LicenseDialog
Dim value As Label

value = instance.OnLineDescription

instance.OnLineDescription = value
public Label OnLineDescription
public:
Label^ OnLineDescription
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LicenseDialog Class
LicenseDialog Members


PixQuery Class

PixQuery Class
Members

XdsObjects Namespace : PixQuery Class
Class used to handle PIX Queries
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public MustInherit NotInheritable Class PixQuery
Dim instance As PixQuery
public static class PixQuery
public ref class PixQuery abstract sealed
Remarks

This is used internally for auto-PIX queries, but the functionality is also available explicitly.

it is a static class with only a few methods, as all the associated configuration information (including the details of the PIX Manager) is held within the XdsDomain object, which is passed to the methods.

Results are cached, in order to reduce the need to multiple queries

Inheritance Hierarchy

System.Object
XdsObjects.PixQuery

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PixQuery Members
XdsObjects Namespace


PixQuery Class Members

PixQuery Class Members
Properties Methods

XdsObjects Namespace : PixQuery Class

The following tables list the members exposed by PixQuery.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | FacilityName | The Name of the FAcility used in queries
static (Shared in Visual Basic) | ReceivingApplicationName | The Name of the Receiving Application used in queries
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | AddCache | Add a pair of IDs directly into the cache
static (Shared in Visual Basic) | GetID | Overloaded. Get the ID for a patient in a different domain by doing a PIX query if necessary
static (Shared in Visual Basic) | GetRawQuery | Returns Raw PIX query as byte array
Top
See Also

Reference

PixQuery Class
XdsObjects Namespace


PixQuery Class Methods

PixQuery Class Methods

XdsObjects Namespace : PixQuery Class

For a list of all members of this type, see PixQuery members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | AddCache | Add a pair of IDs directly into the cache
static (Shared in Visual Basic) | GetID | Overloaded. Get the ID for a patient in a different domain by doing a PIX query if necessary
static (Shared in Visual Basic) | GetRawQuery | Returns Raw PIX query as byte array
Top
See Also

Reference

PixQuery Class
XdsObjects Namespace


AddCache Method

AddCache Method

XdsObjects Namespace > PixQuery Class : AddCache Method
ID extension in domain 1
ID Root of domain 1
ID extension in domain 2
ID Root of domain 2
Add a pair of IDs directly into the cache
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Sub AddCache( _
   ByVal Root1 As String, _
   ByVal ID1 As String, _
   ByVal Root2 As String, _
   ByVal ID2 As String _
)
Dim Root1 As String
Dim ID1 As String
Dim Root2 As String
Dim ID2 As String

PixQuery.AddCache(Root1, ID1, Root2, ID2)
public static void AddCache(
   string Root1,
   string ID1,
   string Root2,
   string ID2
)
public:
static void AddCache(
   String^ Root1,
   String^ ID1,
   String^ Root2,
   String^ ID2
)

Parameters

Root1
ID extension in domain 1
ID1
ID Root of domain 1
Root2
ID extension in domain 2
ID2
ID Root of domain 2
Remarks
This method is intended primarily for testing
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PixQuery Class
PixQuery Members


GetID Method

GetID Method

XdsObjects Namespace > PixQuery Class : GetID Method
Get the ID for a patient in a different domain by doing a PIX query if necessary
Overload List
Overload | Description
GetID(XdsDomain,String,String) | Get the ID for a patient in a different domain by doing a PIX query if necessary
GetID(XdsDomain,String,XdsPatient) | Get the ID for a patient in a different domain by doing a PIX query if necessary
GetID(XdsDomain,IEnumerable<String>,XdsPatient) | Get the ID for a patient in a different domain by doing a PIX query if necessary
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PixQuery Class
PixQuery Members


GetID(XdsDomain,String,String) Method

GetID(XdsDomain,String,String) Method

XdsObjects Namespace > PixQuery Class > GetID Method : GetID(XdsDomain,String,String) Method
The XdsDomain object holding configuration information
The Root ID being requested
The patient's current ID in full form
Get the ID for a patient in a different domain by doing a PIX query if necessary
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overloads Shared Function GetID( _
   ByVal Domain As XdsDomain, _
   ByVal WantedRoot As String, _
   ByVal CurrentID As String _
) As String
Dim Domain As XdsDomain
Dim WantedRoot As String
Dim CurrentID As String
Dim value As String

value = PixQuery.GetID(Domain, WantedRoot, CurrentID)
public static string GetID(
   XdsDomain Domain,
   string WantedRoot,
   string CurrentID
)
public:
static String^ GetID(
   XdsDomain^ Domain,
   String^ WantedRoot,
   String^ CurrentID
)

Parameters

Domain
The XdsDomain object holding configuration information
WantedRoot
The Root ID being requested
CurrentID
The patient's current ID in full form

Return Value

The new ID (in full form)
Remarks

If the current root is the same as the Wanted root, the method returns immediately returning the current ID, withoug doing an external PIX query

If the current and wanted roots are not the same, then the cache is checked to see if the required data is already available, and if so, then the result is returned immediately from the cache

If neither of the above applies, then a PIX query is performed, the result of which is cached and returned

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PixQuery Class
PixQuery Members
Overload List


GetID(XdsDomain,String,XdsPatient) Method

GetID(XdsDomain,String,XdsPatient) Method

XdsObjects Namespace > PixQuery Class > GetID Method : GetID(XdsDomain,String,XdsPatient) Method
The XdsDomain object holding configuration information
The Root ID being requested
The "known" patient
Get the ID for a patient in a different domain by doing a PIX query if necessary
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overloads Shared Function GetID( _
   ByVal Domain As XdsDomain, _
   ByVal WantedRoot As String, _
   ByVal CurrentInfo As XdsPatient _
) As String
Dim Domain As XdsDomain
Dim WantedRoot As String
Dim CurrentInfo As XdsPatient
Dim value As String

value = PixQuery.GetID(Domain, WantedRoot, CurrentInfo)
public static string GetID(
   XdsDomain Domain,
   string WantedRoot,
   XdsPatient CurrentInfo
)
public:
static String^ GetID(
   XdsDomain^ Domain,
   String^ WantedRoot,
   XdsPatient^ CurrentInfo
)

Parameters

Domain
The XdsDomain object holding configuration information
WantedRoot
The Root ID being requested
CurrentInfo
The "known" patient

Return Value

The new ID (in full form)
Remarks

If the current root is the same as the Wanted root, the method returns immediately returning the current ID, withoug doing an external PIX query

If the current and wanted roots are not the same, then the cache is checked to see if the required data is already available, and if so, then the result is returned immediately from the cache

If neither of the above applies, then a PIX query is performed, the result of which is cached and returned

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PixQuery Class
PixQuery Members
Overload List


GetID(XdsDomain,IEnumerable<String>,XdsPatient) Method

GetID(XdsDomain,IEnumerable<String>,XdsPatient) Method

XdsObjects Namespace > PixQuery Class > GetID Method : GetID(XdsDomain,IEnumerable<String>,XdsPatient) Method
The XdsDomain object holding configuration information
The Root ID being requested
The patient's current details, including their full ID in a domain
Get the ID for a patient in a different domain by doing a PIX query if necessary
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overloads Shared Function GetID( _
   ByVal Domain As XdsDomain, _
   ByVal WantedRoot As IEnumerable(Of String), _
   ByVal CurrentInfo As XdsPatient _
) As List(Of XdsPatient)
Dim Domain As XdsDomain
Dim WantedRoot As IEnumerable(Of String)
Dim CurrentInfo As XdsPatient
Dim value As List(Of XdsPatient)

value = PixQuery.GetID(Domain, WantedRoot, CurrentInfo)
public static List<XdsPatient> GetID(
   XdsDomain Domain,
   IEnumerable<string> WantedRoot,
   XdsPatient CurrentInfo
)
public:
static List<XdsPatient^>^ GetID(
   XdsDomain^ Domain,
   IEnumerable<String^>^ WantedRoot,
   XdsPatient^ CurrentInfo
)

Parameters

Domain
The XdsDomain object holding configuration information
WantedRoot
The Root ID being requested
CurrentInfo
The patient's current details, including their full ID in a domain

Return Value

The new ID (in full form)
Remarks

If the current root is the same as the Wanted root, the method returns immediately returning the current ID, withoug doing an external PIX query

If the current and wanted roots are not the same, then the cache is checked to see if the required data is already available, and if so, then the result is returned immediately from the cache

If neither of the above applies, then a PIX query is performed, the result of which is cached and returned

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PixQuery Class
PixQuery Members
Overload List


GetRawQuery Method

GetRawQuery Method

XdsObjects Namespace > PixQuery Class : GetRawQuery Method
XdsDomain object that carries the PIX manager URI
The foreign Patient ID root
Current Patient details
Returns Raw PIX query as byte array
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Function GetRawQuery( _
   ByVal Domain As XdsDomain, _
   ByVal WantedRoot As IEnumerable(Of String), _
   ByVal CurrentInfo As XdsPatient _
) As Byte()
Dim Domain As XdsDomain
Dim WantedRoot As IEnumerable(Of String)
Dim CurrentInfo As XdsPatient
Dim value() As Byte

value = PixQuery.GetRawQuery(Domain, WantedRoot, CurrentInfo)
public static byte[] GetRawQuery(
   XdsDomain Domain,
   IEnumerable<string> WantedRoot,
   XdsPatient CurrentInfo
)
public:
static array<byte>^ GetRawQuery(
   XdsDomain^ Domain,
   IEnumerable<String^>^ WantedRoot,
   XdsPatient^ CurrentInfo
)

Parameters

Domain
XdsDomain object that carries the PIX manager URI
WantedRoot
The foreign Patient ID root
CurrentInfo
Current Patient details
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PixQuery Class
PixQuery Members


PixQuery Class Properties

PixQuery Class Properties

XdsObjects Namespace : PixQuery Class

For a list of all members of this type, see PixQuery members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | FacilityName | The Name of the FAcility used in queries
static (Shared in Visual Basic) | ReceivingApplicationName | The Name of the Receiving Application used in queries
Top
See Also

Reference

PixQuery Class
XdsObjects Namespace


FacilityName Property

FacilityName Property

XdsObjects Namespace > PixQuery Class : FacilityName Property
The Name of the FAcility used in queries
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Property FacilityName As String
Dim value As String

PixQuery.FacilityName = value

value = PixQuery.FacilityName
public static string FacilityName {get; set;}
public:
static property String^ FacilityName {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PixQuery Class
PixQuery Members


ReceivingApplicationName Property

ReceivingApplicationName Property

XdsObjects Namespace > PixQuery Class : ReceivingApplicationName Property
The Name of the Receiving Application used in queries
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Property ReceivingApplicationName As String
Dim value As String

PixQuery.ReceivingApplicationName = value

value = PixQuery.ReceivingApplicationName
public static string ReceivingApplicationName {get; set;}
public:
static property String^ ReceivingApplicationName {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PixQuery Class
PixQuery Members


WebServiceEndpoint Class

WebServiceEndpoint Class
Members

XdsObjects Namespace : WebServiceEndpoint Class
Defines an endpoint to which XdsObjects can make a connection.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class WebServiceEndpoint
   Inherits System.ServiceModel.EndpointAddress
Dim instance As WebServiceEndpoint
public class WebServiceEndpoint : System.ServiceModel.EndpointAddress
public ref class WebServiceEndpoint : public System.ServiceModel.EndpointAddress
Remarks

This class is used extensively in web services and auditing, as it encapulsates both a standard .NET System.ServiceModel.EndpointAddress and also a client certificate to allow secure communication with mutual authentication, as required by ATNA.

Inheritance Hierarchy

System.Object
System.ServiceModel.EndpointAddress
XdsObjects.WebServiceEndpoint

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebServiceEndpoint Members
XdsObjects Namespace


WebServiceEndpoint Class Members

WebServiceEndpoint Class Members
Properties Methods

XdsObjects Namespace : WebServiceEndpoint Class

The following tables list the members exposed by WebServiceEndpoint.

Public Constructors
 | Name | Description
Public Constructor | WebServiceEndpoint Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Headers | (Inherited from System.ServiceModel.EndpointAddress)
Public Property | Identity | (Inherited from System.ServiceModel.EndpointAddress)
Public Property | IsAnonymous | (Inherited from System.ServiceModel.EndpointAddress)
Public Property | IsNone | (Inherited from System.ServiceModel.EndpointAddress)
Public Property | Security | The security object used for communication through this endpoint
Public Property | Uri | (Inherited from System.ServiceModel.EndpointAddress)
Top
Public Methods
 | Name | Description
Public Method | ApplyTo | (Inherited from System.ServiceModel.EndpointAddress)
Public Method | Equals | (Inherited from System.ServiceModel.EndpointAddress)
Public Method | GetHashCode | (Inherited from System.ServiceModel.EndpointAddress)
Public Method | GetReaderAtExtensions | (Inherited from System.ServiceModel.EndpointAddress)
Public Method | GetReaderAtMetadata | (Inherited from System.ServiceModel.EndpointAddress)
Public Method | ModifyHeaders | Modify the SOAP headers being sent
Public Method | ToString | (Inherited from System.ServiceModel.EndpointAddress)
Public Method | WriteContentsTo | Overloaded. (Inherited from System.ServiceModel.EndpointAddress)
Public Method | WriteTo | Overloaded. (Inherited from System.ServiceModel.EndpointAddress)
Top
See Also

Reference

WebServiceEndpoint Class
XdsObjects Namespace


WebServiceEndpoint Constructor

WebServiceEndpoint Constructor

XdsObjects Namespace > WebServiceEndpoint Class : WebServiceEndpoint Constructor
Overload List
Overload | Description
WebServiceEndpoint Constructor(String) | Construct new WebServiceEndpoint from a URI as a string
WebServiceEndpoint Constructor(String,HttpProvider) | Construct new WebServiceEndpoint from a URI as a string
WebServiceEndpoint Constructor(String,X509Certificate2) | Construct new XdsEndPoint for secure communication from a URI as a string
WebServiceEndpoint Constructor(String,ITlsClientSecurity) | Construct new XdsEndPoint for secure communication from a URI and a Security object
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebServiceEndpoint Class
WebServiceEndpoint Members


WebServiceEndpoint Constructor(String)

WebServiceEndpoint Constructor(String)

XdsObjects Namespace > WebServiceEndpoint Class > WebServiceEndpoint Constructor : WebServiceEndpoint Constructor(String)
The URI to use
Construct new WebServiceEndpoint from a URI as a string
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal Address As String _
)
Dim Address As String

Dim instance As New WebServiceEndpoint(Address)
public WebServiceEndpoint(
   string Address
)
public:
WebServiceEndpoint(
   String^ Address
)

Parameters

Address
The URI to use
Remarks
As this overload does not include a certificate, it is normally used for non-secure (http) communication
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebServiceEndpoint Class
WebServiceEndpoint Members
Overload List


WebServiceEndpoint Constructor(String,HttpProvider)

WebServiceEndpoint Constructor(String,HttpProvider)

XdsObjects Namespace > WebServiceEndpoint Class > WebServiceEndpoint Constructor : WebServiceEndpoint Constructor(String,HttpProvider)
The URI to use
The HTTP mechanism to use
Construct new WebServiceEndpoint from a URI as a string
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal Address As String, _
   ByVal HttpProvider As HttpProvider _
)
Dim Address As String
Dim HttpProvider As HttpProvider

Dim instance As New WebServiceEndpoint(Address, HttpProvider)
public WebServiceEndpoint(
   string Address,
   HttpProvider HttpProvider
)
public:
WebServiceEndpoint(
   String^ Address,
   HttpProvider HttpProvider
)

Parameters

Address
The URI to use
HttpProvider
The HTTP mechanism to use
Remarks
As this overload does not include a certificate, it is normally used for non-secure (http) communication
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebServiceEndpoint Class
WebServiceEndpoint Members
Overload List


WebServiceEndpoint Constructor(String,X509Certificate2)

WebServiceEndpoint Constructor(String,X509Certificate2)

XdsObjects Namespace > WebServiceEndpoint Class > WebServiceEndpoint Constructor : WebServiceEndpoint Constructor(String,X509Certificate2)
The URI to use
The certificate to present as user credentials
Construct new XdsEndPoint for secure communication from a URI as a string
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal Address As String, _
   ByVal Certificate As X509Certificate2 _
)
Dim Address As String
Dim Certificate As X509Certificate2

Dim instance As New WebServiceEndpoint(Address, Certificate)
public WebServiceEndpoint(
   string Address,
   X509Certificate2 Certificate
)
public:
WebServiceEndpoint(
   String^ Address,
   X509Certificate2^ Certificate
)

Parameters

Address
The URI to use
Certificate
The certificate to present as user credentials
Remarks
As this overload includes a certificate, it is normally used for secure (https) communication
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebServiceEndpoint Class
WebServiceEndpoint Members
Overload List


WebServiceEndpoint Constructor(String,ITlsClientSecurity)

WebServiceEndpoint Constructor(String,ITlsClientSecurity)

XdsObjects Namespace > WebServiceEndpoint Class > WebServiceEndpoint Constructor : WebServiceEndpoint Constructor(String,ITlsClientSecurity)
The URI to use
The security context to use for the communication
Construct new XdsEndPoint for secure communication from a URI and a Security object
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal Address As String, _
   ByVal Security As ITlsClientSecurity _
)
Dim Address As String
Dim Security As ITlsClientSecurity

Dim instance As New WebServiceEndpoint(Address, Security)
public WebServiceEndpoint(
   string Address,
   ITlsClientSecurity Security
)
public:
WebServiceEndpoint(
   String^ Address,
   ITlsClientSecurity^ Security
)

Parameters

Address
The URI to use
Security
The security context to use for the communication
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebServiceEndpoint Class
WebServiceEndpoint Members
Overload List


WebServiceEndpoint Class Methods

WebServiceEndpoint Class Methods

XdsObjects Namespace : WebServiceEndpoint Class

For a list of all members of this type, see WebServiceEndpoint members.

Public Methods
 | Name | Description
Public Method | ApplyTo | (Inherited from System.ServiceModel.EndpointAddress)
Public Method | Equals | (Inherited from System.ServiceModel.EndpointAddress)
Public Method | GetHashCode | (Inherited from System.ServiceModel.EndpointAddress)
Public Method | GetReaderAtExtensions | (Inherited from System.ServiceModel.EndpointAddress)
Public Method | GetReaderAtMetadata | (Inherited from System.ServiceModel.EndpointAddress)
Public Method | ModifyHeaders | Modify the SOAP headers being sent
Public Method | ToString | (Inherited from System.ServiceModel.EndpointAddress)
Public Method | WriteContentsTo | Overloaded. (Inherited from System.ServiceModel.EndpointAddress)
Public Method | WriteTo | Overloaded. (Inherited from System.ServiceModel.EndpointAddress)
Top
See Also

Reference

WebServiceEndpoint Class
XdsObjects Namespace


ModifyHeaders Method

ModifyHeaders Method

XdsObjects Namespace > WebServiceEndpoint Class : ModifyHeaders Method
Details of the headers to modify
Modify the SOAP headers being sent
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overridable Sub ModifyHeaders( _
   ByVal args As ModifyHeadersArgs _
)
Dim instance As WebServiceEndpoint
Dim args As ModifyHeadersArgs

instance.ModifyHeaders(args)
public virtual void ModifyHeaders(
   ModifyHeadersArgs args
)
public:
virtual void ModifyHeaders(
   ModifyHeadersArgs^ args
)

Parameters

args
Details of the headers to modify
Remarks

This is typically only used when communicating with a non-IHE-rules compliant system, which may require non-standard SOAP headers etc.

To use this override, derive a class from WebServiceEndpoint

The default implementation does nothing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebServiceEndpoint Class
WebServiceEndpoint Members


WebServiceEndpoint Class Properties

WebServiceEndpoint Class Properties

XdsObjects Namespace : WebServiceEndpoint Class

For a list of all members of this type, see WebServiceEndpoint members.

Public Properties
 | Name | Description
Public Property | Headers | (Inherited from System.ServiceModel.EndpointAddress)
Public Property | Identity | (Inherited from System.ServiceModel.EndpointAddress)
Public Property | IsAnonymous | (Inherited from System.ServiceModel.EndpointAddress)
Public Property | IsNone | (Inherited from System.ServiceModel.EndpointAddress)
Public Property | Security | The security object used for communication through this endpoint
Public Property | Uri | (Inherited from System.ServiceModel.EndpointAddress)
Top
See Also

Reference

WebServiceEndpoint Class
XdsObjects Namespace


Security Property (WebServiceEndpoint)

Security Property (WebServiceEndpoint)

XdsObjects Namespace > WebServiceEndpoint Class : Security Property
The security object used for communication through this endpoint
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Security As ITlsClientSecurity
Dim instance As WebServiceEndpoint
Dim value As ITlsClientSecurity

instance.Security = value

value = instance.Security
public ITlsClientSecurity Security {get; set;}
public:
property ITlsClientSecurity^ Security {
   ITlsClientSecurity^ get();
   void set (    ITlsClientSecurity^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebServiceEndpoint Class
WebServiceEndpoint Members


XdsAssociation Class

XdsAssociation Class
Members

XdsObjects Namespace : XdsAssociation Class
Class representing a "raw" ebXML association - as used by registries
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsAssociation
Dim instance As XdsAssociation
public class XdsAssociation
public ref class XdsAssociation
Inheritance Hierarchy

System.Object
XdsObjects.XdsAssociation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAssociation Members
XdsObjects Namespace


XdsAssociation Class Members

XdsAssociation Class Members
Properties

XdsObjects Namespace : XdsAssociation Class

The following tables list the members exposed by XdsAssociation.

Public Properties
 | Name | Description
Public Property | ExtraSlots | The list of slots not explicitly used to populate other fields
Public Property | SourceUUID | The UUID of the source object
Public Property | SubmissionSetStatus | Indicates whether a document is being included as "new" or by reference to an existing document
Public Property | TargetUUID | The UUID of the target object
Public Property | Type | The type of the association.
Public Property | TypeAsInt | The Type of the association as an integer.
Public Property | UUID | The UUID of the association itself
Top
See Also

Reference

XdsAssociation Class
XdsObjects Namespace


XdsAssociation Class Properties

XdsAssociation Class Properties

XdsObjects Namespace : XdsAssociation Class

For a list of all members of this type, see XdsAssociation members.

Public Properties
 | Name | Description
Public Property | ExtraSlots | The list of slots not explicitly used to populate other fields
Public Property | SourceUUID | The UUID of the source object
Public Property | SubmissionSetStatus | Indicates whether a document is being included as "new" or by reference to an existing document
Public Property | TargetUUID | The UUID of the target object
Public Property | Type | The type of the association.
Public Property | TypeAsInt | The Type of the association as an integer.
Public Property | UUID | The UUID of the association itself
Top
See Also

Reference

XdsAssociation Class
XdsObjects Namespace


ExtraSlots Property (XdsAssociation)

ExtraSlots Property (XdsAssociation)

XdsObjects Namespace > XdsAssociation Class : ExtraSlots Property
The list of slots not explicitly used to populate other fields
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property ExtraSlots As List(Of XdsSlot)
Dim instance As XdsAssociation
Dim value As List(Of XdsSlot)

value = instance.ExtraSlots
public List<XdsSlot> ExtraSlots {get;}
public:
property List<XdsSlot^>^ ExtraSlots {
   List<XdsSlot^>^ get();
}
Remarks

Whilst the XDS standards specifiy the contents of some slots for some objects, "user defined" slots are allowed and should be stored by a registry. This property allows such additional slots to be created and accessed.

Note that there are no pre-defined slots for associations and therefore all slots for an association are handled via this collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAssociation Class
XdsAssociation Members


SourceUUID Property

SourceUUID Property

XdsObjects Namespace > XdsAssociation Class : SourceUUID Property
The UUID of the source object
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property SourceUUID As String
Dim instance As XdsAssociation
Dim value As String

instance.SourceUUID = value

value = instance.SourceUUID
public string SourceUUID {get; set;}
public:
property String^ SourceUUID {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAssociation Class
XdsAssociation Members


SubmissionSetStatus Property (XdsAssociation)

SubmissionSetStatus Property (XdsAssociation)

XdsObjects Namespace > XdsAssociation Class : SubmissionSetStatus Property
Indicates whether a document is being included as "new" or by reference to an existing document
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property SubmissionSetStatus As String
Dim instance As XdsAssociation
Dim value As String

instance.SubmissionSetStatus = value

value = instance.SubmissionSetStatus
public string SubmissionSetStatus {get; set;}
public:
property String^ SubmissionSetStatus {
   String^ get();
   void set (    String^ value);
}
Remarks
This is handled automatically by XdsObjects when acting as a source, but a registry will need to see and store this value. It is set to "Reference" if the document is included by reference.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAssociation Class
XdsAssociation Members


TargetUUID Property

TargetUUID Property

XdsObjects Namespace > XdsAssociation Class : TargetUUID Property
The UUID of the target object
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property TargetUUID As String
Dim instance As XdsAssociation
Dim value As String

instance.TargetUUID = value

value = instance.TargetUUID
public string TargetUUID {get; set;}
public:
property String^ TargetUUID {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAssociation Class
XdsAssociation Members


Type Property

Type Property

XdsObjects Namespace > XdsAssociation Class : Type Property
The type of the association.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Type As AssociationType
Dim instance As XdsAssociation
Dim value As AssociationType

instance.Type = value

value = instance.Type
public AssociationType Type {get; set;}
public:
property AssociationType Type {
   AssociationType get();
   void set (    AssociationType value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAssociation Class
XdsAssociation Members


TypeAsInt Property

TypeAsInt Property

XdsObjects Namespace > XdsAssociation Class : TypeAsInt Property
The Type of the association as an integer.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property TypeAsInt As Integer
Dim instance As XdsAssociation
Dim value As Integer

instance.TypeAsInt = value

value = instance.TypeAsInt
public int TypeAsInt {get; set;}
public:
property int TypeAsInt {
   int get();
   void set (    int value);
}
Remarks
This is a special property, only used as part of a registry based on the Code First Entity Framework which is used for our registry example. This is needed due to the inability of the Entity Framework to handle Enums. When used in this mode, the Type property should be excluded from the database.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAssociation Class
XdsAssociation Members


UUID Property (XdsAssociation)

UUID Property (XdsAssociation)

XdsObjects Namespace > XdsAssociation Class : UUID Property
The UUID of the association itself
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property UUID As String
Dim instance As XdsAssociation
Dim value As String

instance.UUID = value

value = instance.UUID
public string UUID {get; set;}
public:
property String^ UUID {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAssociation Class
XdsAssociation Members


XdsAudit Class

XdsAudit Class
Members

XdsObjects Namespace : XdsAudit Class
Static class which encapsultates all the Auditing functionality
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public MustInherit NotInheritable Class XdsAudit
Dim instance As XdsAudit
public static class XdsAudit
public ref class XdsAudit abstract sealed
Remarks
This uses an internal class, which could be used to add much more flexibility, but which is not documented or exposed to user code for now. It could be exposed if/when a need is identified - please contact Medical Connections if you find that this class does not provide the functionality you need.
Inheritance Hierarchy

System.Object
XdsObjects.XdsAudit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAudit Members
XdsObjects Namespace


XdsAudit Class Members

XdsAudit Class Members
Methods

XdsObjects Namespace : XdsAudit Class

The following tables list the members exposed by XdsAudit.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | ActorStart | Log that an application (actor) has started
static (Shared in Visual Basic) | ActorStop | Log that an application (actor) has stopped
static (Shared in Visual Basic) | BeginTransferringDICOMInstances | Log that a set of DICOM instances is starting to be transmitted/received
static (Shared in Visual Basic) | DICOMInstancesTransferred | Log that a set of DICOM instances has been transmitted/received
static (Shared in Visual Basic) | DICOMQuery | Log that a DICOM query has been performed
static (Shared in Visual Basic) | PHIExport | Log that an personal health information (PHI) has been exported - e.g. to media
static (Shared in Visual Basic) | PHIImport | Log that an personal health information (PHI) has been imported - e.g. from media
static (Shared in Visual Basic) | PIXQuery | Log that a Pixequery has been performed
static (Shared in Visual Basic) | ProvideAndRegister | Log that an XDS-b ProvideAndRegister transaction has been performed
static (Shared in Visual Basic) | RegistryStoredQuery | Log that an XDS-b RegistryStoredQuery transaction has been performed
static (Shared in Visual Basic) | RetrieveDocumentSet | Log that an XDS-b RetrieveDocumentSet transaction has been performed
static (Shared in Visual Basic) | SecurityAlert | Log a security alert
static (Shared in Visual Basic) | UpdateDocument | Log that an XDS Update Document Set transaction has been performed
static (Shared in Visual Basic) | UserAuthentication | Log that a user has authenticated with the application.
Top
See Also

Reference

XdsAudit Class
XdsObjects Namespace


XdsAudit Class Methods

XdsAudit Class Methods

XdsObjects Namespace : XdsAudit Class

For a list of all members of this type, see XdsAudit members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | ActorStart | Log that an application (actor) has started
static (Shared in Visual Basic) | ActorStop | Log that an application (actor) has stopped
static (Shared in Visual Basic) | BeginTransferringDICOMInstances | Log that a set of DICOM instances is starting to be transmitted/received
static (Shared in Visual Basic) | DICOMInstancesTransferred | Log that a set of DICOM instances has been transmitted/received
static (Shared in Visual Basic) | DICOMQuery | Log that a DICOM query has been performed
static (Shared in Visual Basic) | PHIExport | Log that an personal health information (PHI) has been exported - e.g. to media
static (Shared in Visual Basic) | PHIImport | Log that an personal health information (PHI) has been imported - e.g. from media
static (Shared in Visual Basic) | PIXQuery | Log that a Pixequery has been performed
static (Shared in Visual Basic) | ProvideAndRegister | Log that an XDS-b ProvideAndRegister transaction has been performed
static (Shared in Visual Basic) | RegistryStoredQuery | Log that an XDS-b RegistryStoredQuery transaction has been performed
static (Shared in Visual Basic) | RetrieveDocumentSet | Log that an XDS-b RetrieveDocumentSet transaction has been performed
static (Shared in Visual Basic) | SecurityAlert | Log a security alert
static (Shared in Visual Basic) | UpdateDocument | Log that an XDS Update Document Set transaction has been performed
static (Shared in Visual Basic) | UserAuthentication | Log that a user has authenticated with the application.
Top
See Also

Reference

XdsAudit Class
XdsObjects Namespace


ActorStart Method

ActorStart Method

XdsObjects Namespace > XdsAudit Class : ActorStart Method
The XDS domain containing details
Log that an application (actor) has started
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Function ActorStart( _
   ByVal Domain As XdsDomain _
) As Integer
Dim Domain As XdsDomain
Dim value As Integer

value = XdsAudit.ActorStart(Domain)
public static int ActorStart(
   XdsDomain Domain
)
public:
static int ActorStart(
   XdsDomain^ Domain
)

Parameters

Domain
The XDS domain containing details

Return Value

The number of audit repositories to which the message was successfully sent
Remarks

For UDP repositories, there is no confirmation that the message was successfully received

Ensure that the Domain is fully set up before making this call.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAudit Class
XdsAudit Members


ActorStop Method

ActorStop Method

XdsObjects Namespace > XdsAudit Class : ActorStop Method
The XDS domain containing details
Log that an application (actor) has stopped
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Function ActorStop( _
   ByVal Domain As XdsDomain _
) As Integer
Dim Domain As XdsDomain
Dim value As Integer

value = XdsAudit.ActorStop(Domain)
public static int ActorStop(
   XdsDomain Domain
)
public:
static int ActorStop(
   XdsDomain^ Domain
)

Parameters

Domain
The XDS domain containing details

Return Value

The number of audit repositories to which the message was successfully sent
Remarks

For UDP repositories, there is no confirmation that the message was successfully received

Ensure that the Domain is fully set up before making this call.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAudit Class
XdsAudit Members


BeginTransferringDICOMInstances Method

BeginTransferringDICOMInstances Method

XdsObjects Namespace > XdsAudit Class : BeginTransferringDICOMInstances Method
The XDS domain, including a list of the audit repositories to be used
The Name of the sender
The Name of the receiver
The Patient ID
The list of studies
Log that a set of DICOM instances is starting to be transmitted/received
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Function BeginTransferringDICOMInstances( _
   ByVal Domain As XdsDomain, _
   ByVal Sender As String, _
   ByVal Receiver As String, _
   ByVal PatientID As String, _
   ByVal Studies As IEnumerable(Of XdsAudit.ParticipatingObject) _
) As Integer
Dim Domain As XdsDomain
Dim Sender As String
Dim Receiver As String
Dim PatientID As String
Dim Studies As IEnumerable(Of XdsAudit.ParticipatingObject)
Dim value As Integer

value = XdsAudit.BeginTransferringDICOMInstances(Domain, Sender, Receiver, PatientID, Studies)
public static int BeginTransferringDICOMInstances(
   XdsDomain Domain,
   string Sender,
   string Receiver,
   string PatientID,
   IEnumerable<XdsAudit.ParticipatingObject> Studies
)
public:
static int BeginTransferringDICOMInstances(
   XdsDomain^ Domain,
   String^ Sender,
   String^ Receiver,
   String^ PatientID,
   IEnumerable<XdsAudit.ParticipatingObject^>^ Studies
)

Parameters

Domain
The XDS domain, including a list of the audit repositories to be used
Sender
The Name of the sender
Receiver
The Name of the receiver
PatientID
The Patient ID
Studies
The list of studies

Return Value

The number of audit repositories to which the message was successfully sent
Remarks

For UDP repositories, there is no confirmation that the message was successfully received

Ensure that the Domain is fully set up before making this call.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAudit Class
XdsAudit Members


DICOMInstancesTransferred Method

DICOMInstancesTransferred Method

XdsObjects Namespace > XdsAudit Class : DICOMInstancesTransferred Method
The XDS domain, including a list of the audit repositories to be used
The Name of the sender
The Name of the receiver
The Patient ID
The list of studies
Log that a set of DICOM instances has been transmitted/received
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Function DICOMInstancesTransferred( _
   ByVal Domain As XdsDomain, _
   ByVal Sender As String, _
   ByVal Receiver As String, _
   ByVal PatientID As String, _
   ByVal Studies As IEnumerable(Of XdsAudit.ParticipatingObject) _
) As Integer
Dim Domain As XdsDomain
Dim Sender As String
Dim Receiver As String
Dim PatientID As String
Dim Studies As IEnumerable(Of XdsAudit.ParticipatingObject)
Dim value As Integer

value = XdsAudit.DICOMInstancesTransferred(Domain, Sender, Receiver, PatientID, Studies)
public static int DICOMInstancesTransferred(
   XdsDomain Domain,
   string Sender,
   string Receiver,
   string PatientID,
   IEnumerable<XdsAudit.ParticipatingObject> Studies
)
public:
static int DICOMInstancesTransferred(
   XdsDomain^ Domain,
   String^ Sender,
   String^ Receiver,
   String^ PatientID,
   IEnumerable<XdsAudit.ParticipatingObject^>^ Studies
)

Parameters

Domain
The XDS domain, including a list of the audit repositories to be used
Sender
The Name of the sender
Receiver
The Name of the receiver
PatientID
The Patient ID
Studies
The list of studies

Return Value

The number of audit repositories to which the message was successfully sent
Remarks

For UDP repositories, there is no confirmation that the message was successfully received

Ensure that the Domain is fully set up before making this call.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAudit Class
XdsAudit Members


DICOMQuery Method

DICOMQuery Method

XdsObjects Namespace > XdsAudit Class : DICOMQuery Method
The XDS domain, including a list of the audit repositories to be used
The Name of the sender
The Name of the receiver
The SOP Class UID queried
The Transfer Syntax used for the query
The raw data sent as the query
Log that a DICOM query has been performed
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Function DICOMQuery( _
   ByVal Domain As XdsDomain, _
   ByVal Sender As String, _
   ByVal Receiver As String, _
   ByVal SOPClassUID As String, _
   ByVal TransferSyntax As String, _
   ByVal RawQuery() As Byte _
) As Integer
Dim Domain As XdsDomain
Dim Sender As String
Dim Receiver As String
Dim SOPClassUID As String
Dim TransferSyntax As String
Dim RawQuery() As Byte
Dim value As Integer

value = XdsAudit.DICOMQuery(Domain, Sender, Receiver, SOPClassUID, TransferSyntax, RawQuery)
public static int DICOMQuery(
   XdsDomain Domain,
   string Sender,
   string Receiver,
   string SOPClassUID,
   string TransferSyntax,
   byte[] RawQuery
)
public:
static int DICOMQuery(
   XdsDomain^ Domain,
   String^ Sender,
   String^ Receiver,
   String^ SOPClassUID,
   String^ TransferSyntax,
   array<byte>^ RawQuery
)

Parameters

Domain
The XDS domain, including a list of the audit repositories to be used
Sender
The Name of the sender
Receiver
The Name of the receiver
SOPClassUID
The SOP Class UID queried
TransferSyntax
The Transfer Syntax used for the query
RawQuery
The raw data sent as the query

Return Value

The number of audit repositories to which the message was successfully sent
Remarks

For UDP repositories, there is no confirmation that the message was successfully received

Ensure that the Domain is fully set up before making this call.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAudit Class
XdsAudit Members


PHIExport Method

PHIExport Method

XdsObjects Namespace > XdsAudit Class : PHIExport Method
The XDS domain, including a list of the audit repositories to be used
The repository address
The UIDs of the studies exported
The details of the patient
Log that an personal health information (PHI) has been exported - e.g. to media
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Function PHIExport( _
   ByVal Domain As XdsDomain, _
   ByVal DestinationURI As Uri, _
   ByVal StudyUIDList As IEnumerable(Of String), _
   ByVal Patient As XdsPatient _
) As Integer
Dim Domain As XdsDomain
Dim DestinationURI As Uri
Dim StudyUIDList As IEnumerable(Of String)
Dim Patient As XdsPatient
Dim value As Integer

value = XdsAudit.PHIExport(Domain, DestinationURI, StudyUIDList, Patient)
public static int PHIExport(
   XdsDomain Domain,
   Uri DestinationURI,
   IEnumerable<string> StudyUIDList,
   XdsPatient Patient
)
public:
static int PHIExport(
   XdsDomain^ Domain,
   Uri^ DestinationURI,
   IEnumerable<String^>^ StudyUIDList,
   XdsPatient^ Patient
)

Parameters

Domain
The XDS domain, including a list of the audit repositories to be used
DestinationURI
The repository address
StudyUIDList
The UIDs of the studies exported
Patient
The details of the patient

Return Value

The number of audit repositories to which the message was successfully sent
Remarks

The "Destination" may indicate anremovable drive etc.

For UDP repositories, there is no confirmation that the message was successfully received

Ensure that the Domain is fully set up before making this call.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAudit Class
XdsAudit Members


PHIImport Method

PHIImport Method

XdsObjects Namespace > XdsAudit Class : PHIImport Method
The XDS domain, including a list of the audit repositories to be used
The source of the images
The UIDs of the studies exported
The details of the patient
Log that an personal health information (PHI) has been imported - e.g. from media
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Function PHIImport( _
   ByVal Domain As XdsDomain, _
   ByVal Source As String, _
   ByVal StudyUIDList As IEnumerable(Of String), _
   ByVal Patient As XdsPatient _
) As Integer
Dim Domain As XdsDomain
Dim Source As String
Dim StudyUIDList As IEnumerable(Of String)
Dim Patient As XdsPatient
Dim value As Integer

value = XdsAudit.PHIImport(Domain, Source, StudyUIDList, Patient)
public static int PHIImport(
   XdsDomain Domain,
   string Source,
   IEnumerable<string> StudyUIDList,
   XdsPatient Patient
)
public:
static int PHIImport(
   XdsDomain^ Domain,
   String^ Source,
   IEnumerable<String^>^ StudyUIDList,
   XdsPatient^ Patient
)

Parameters

Domain
The XDS domain, including a list of the audit repositories to be used
Source
The source of the images
StudyUIDList
The UIDs of the studies exported
Patient
The details of the patient

Return Value

The number of audit repositories to which the message was successfully senthttp://m.ranwen.org/files/article/0/447/5184312.html
Remarks

The "Destination" may indicate anremovable drive etc.

For UDP repositories, there is no confirmation that the message was successfully received

Ensure that the Domain is fully set up before making this call.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAudit Class
XdsAudit Members


PIXQuery Method

PIXQuery Method

XdsObjects Namespace > XdsAudit Class : PIXQuery Method
The XDS domain, including a list of the audit repositories to be used
The IP address of the PIX client
The IP address of the PIX Server
The details of the patient whose other IDs are being requested
The raw data sent as the query
Log that a Pixequery has been performed
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Function PIXQuery( _
   ByVal Domain As XdsDomain, _
   ByVal SenderIP As String, _
   ByVal ReceiverIP As String, _
   ByVal Patient As XdsPatient, _
   ByVal RawQuery() As Byte _
) As Integer
Dim Domain As XdsDomain
Dim SenderIP As String
Dim ReceiverIP As String
Dim Patient As XdsPatient
Dim RawQuery() As Byte
Dim value As Integer

value = XdsAudit.PIXQuery(Domain, SenderIP, ReceiverIP, Patient, RawQuery)
public static int PIXQuery(
   XdsDomain Domain,
   string SenderIP,
   string ReceiverIP,
   XdsPatient Patient,
   byte[] RawQuery
)
public:
static int PIXQuery(
   XdsDomain^ Domain,
   String^ SenderIP,
   String^ ReceiverIP,
   XdsPatient^ Patient,
   array<byte>^ RawQuery
)

Parameters

Domain
The XDS domain, including a list of the audit repositories to be used
SenderIP
The IP address of the PIX client
ReceiverIP
The IP address of the PIX Server
Patient
The details of the patient whose other IDs are being requested
RawQuery
The raw data sent as the query

Return Value

The number of audit repositories to which the message was successfully sent
Remarks

For UDP repositories, there is no confirmation that the message was successfully received

Ensure that the Domain is fully set up before making this call.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAudit Class
XdsAudit Members


ProvideAndRegister Method

ProvideAndRegister Method

XdsObjects Namespace > XdsAudit Class : ProvideAndRegister Method
The XDS domain, including a list of the audit repositories to be used
The name of the source system
The destination address
The details of the patient
Submission set being sent
The response received from the recipient
true if this message is being sent by the document source (false if it is being logged by the recipient)
Log that an XDS-b ProvideAndRegister transaction has been performed
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Function ProvideAndRegister( _
   ByVal Domain As XdsDomain, _
   ByVal Source As String, _
   ByVal DestinationURI As Uri, _
   ByVal Patient As XdsPatient, _
   ByVal SubmissionSet As XdsSubmissionSet, _
   ByVal Response As XdsRegistryResponse, _
   ByVal SourceAudit As Boolean _
) As Integer
Dim Domain As XdsDomain
Dim Source As String
Dim DestinationURI As Uri
Dim Patient As XdsPatient
Dim SubmissionSet As XdsSubmissionSet
Dim Response As XdsRegistryResponse
Dim SourceAudit As Boolean
Dim value As Integer

value = XdsAudit.ProvideAndRegister(Domain, Source, DestinationURI, Patient, SubmissionSet, Response, SourceAudit)
public static int ProvideAndRegister(
   XdsDomain Domain,
   string Source,
   Uri DestinationURI,
   XdsPatient Patient,
   XdsSubmissionSet SubmissionSet,
   XdsRegistryResponse Response,
   bool SourceAudit
)
public:
static int ProvideAndRegister(
   XdsDomain^ Domain,
   String^ Source,
   Uri^ DestinationURI,
   XdsPatient^ Patient,
   XdsSubmissionSet^ SubmissionSet,
   XdsRegistryResponse^ Response,
   bool SourceAudit
)

Parameters

Domain
The XDS domain, including a list of the audit repositories to be used
Source
The name of the source system
DestinationURI
The destination address
Patient
The details of the patient
SubmissionSet
Submission set being sent
Response
The response received from the recipient
SourceAudit
true if this message is being sent by the document source (false if it is being logged by the recipient)

Return Value

The number of audit repositories to which the message was successfully sent
Remarks

For UDP repositories, there is no confirmation that the message was successfully received

Ensure that the Domain is fully set up before making this call.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAudit Class
XdsAudit Members


RegistryStoredQuery Method (XdsAudit)

RegistryStoredQuery Method (XdsAudit)

XdsObjects Namespace > XdsAudit Class : RegistryStoredQuery Method
The XDS domain, including a list of the audit repositories to be used
The name of the source system
The repository address
The details of the patient
The query which has been sent
The response received from the repository
Log that an XDS-b RegistryStoredQuery transaction has been performed
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Function RegistryStoredQuery( _
   ByVal Domain As XdsDomain, _
   ByVal Source As String, _
   ByVal DestinationURI As WebServiceEndpoint, _
   ByVal Patient As XdsPatient, _
   ByVal Query As XdsQueryRequest, _
   ByVal Response As XdsQueryResponse _
) As Integer
Dim Domain As XdsDomain
Dim Source As String
Dim DestinationURI As WebServiceEndpoint
Dim Patient As XdsPatient
Dim Query As XdsQueryRequest
Dim Response As XdsQueryResponse
Dim value As Integer

value = XdsAudit.RegistryStoredQuery(Domain, Source, DestinationURI, Patient, Query, Response)
public static int RegistryStoredQuery(
   XdsDomain Domain,
   string Source,
   WebServiceEndpoint DestinationURI,
   XdsPatient Patient,
   XdsQueryRequest Query,
   XdsQueryResponse Response
)
public:
static int RegistryStoredQuery(
   XdsDomain^ Domain,
   String^ Source,
   WebServiceEndpoint^ DestinationURI,
   XdsPatient^ Patient,
   XdsQueryRequest^ Query,
   XdsQueryResponse^ Response
)

Parameters

Domain
The XDS domain, including a list of the audit repositories to be used
Source
The name of the source system
DestinationURI
The repository address
Patient
The details of the patient
Query
The query which has been sent
Response
The response received from the repository

Return Value

The number of audit repositories to which the message was successfully sent
Remarks

For UDP repositories, there is no confirmation that the message was successfully received

Ensure that the Domain is fully set up before making this call.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAudit Class
XdsAudit Members


RetrieveDocumentSet Method (XdsAudit)

RetrieveDocumentSet Method (XdsAudit)

XdsObjects Namespace > XdsAudit Class : RetrieveDocumentSet Method
The XDS domain, including a list of the audit repositories to be used
The name of the source system
The repository address
The details of the patient
The response received from the repository
False if this message is being sent by the document consumer (True if it is being logged by the repository)
Log that an XDS-b RetrieveDocumentSet transaction has been performed
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Function RetrieveDocumentSet( _
   ByVal Domain As XdsDomain, _
   ByVal Source As String, _
   ByVal DestinationURI As WebServiceEndpoint, _
   ByVal Patient As XdsPatient, _
   ByVal Response As XdsRetrieveResponse, _
   ByVal SourceAudit As Boolean _
) As Integer
Dim Domain As XdsDomain
Dim Source As String
Dim DestinationURI As WebServiceEndpoint
Dim Patient As XdsPatient
Dim Response As XdsRetrieveResponse
Dim SourceAudit As Boolean
Dim value As Integer

value = XdsAudit.RetrieveDocumentSet(Domain, Source, DestinationURI, Patient, Response, SourceAudit)
public static int RetrieveDocumentSet(
   XdsDomain Domain,
   string Source,
   WebServiceEndpoint DestinationURI,
   XdsPatient Patient,
   XdsRetrieveResponse Response,
   bool SourceAudit
)
public:
static int RetrieveDocumentSet(
   XdsDomain^ Domain,
   String^ Source,
   WebServiceEndpoint^ DestinationURI,
   XdsPatient^ Patient,
   XdsRetrieveResponse^ Response,
   bool SourceAudit
)

Parameters

Domain
The XDS domain, including a list of the audit repositories to be used
Source
The name of the source system
DestinationURI
The repository address
Patient
The details of the patient
Response
The response received from the repository
SourceAudit
False if this message is being sent by the document consumer (True if it is being logged by the repository)

Return Value

The number of audit repositories to which the message was successfully sent
Remarks

For UDP repositories, there is no confirmation that the message was successfully received

Ensure that the Domain is fully set up before making this call.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAudit Class
XdsAudit Members


SecurityAlert Method

SecurityAlert Method

XdsObjects Namespace > XdsAudit Class : SecurityAlert Method
The XDS domain, including a list of the audit repositories to be used
The status of the event being logged
Human readable description of the alert
Log a security alert
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Function SecurityAlert( _
   ByVal Domain As XdsDomain, _
   ByVal outcomeIndicator As EventOutcomeIndicator, _
   ByVal alertDescription As String _
) As Integer
Dim Domain As XdsDomain
Dim outcomeIndicator As EventOutcomeIndicator
Dim alertDescription As String
Dim value As Integer

value = XdsAudit.SecurityAlert(Domain, outcomeIndicator, alertDescription)
public static int SecurityAlert(
   XdsDomain Domain,
   EventOutcomeIndicator outcomeIndicator,
   string alertDescription
)
public:
static int SecurityAlert(
   XdsDomain^ Domain,
   EventOutcomeIndicator outcomeIndicator,
   String^ alertDescription
)

Parameters

Domain
The XDS domain, including a list of the audit repositories to be used
outcomeIndicator
The status of the event being logged
alertDescription
Human readable description of the alert

Return Value

The number of audit repositories to which the message was successfully sent
Remarks

The "Destination" may indicate anremovable drive etc.

For UDP repositories, there is no confirmation that the message was successfully received

Ensure that the Domain is fully set up before making this call.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAudit Class
XdsAudit Members


UpdateDocument Method

UpdateDocument Method

XdsObjects Namespace > XdsAudit Class : UpdateDocument Method
The XDS domain, including a list of the audit repositories to be used
The name of the source system
The repository address
The details of the patient
Submission set being sent
The response received from the repository
False if this message is being sent by the document consumer (True if it is being logged by the repository)
Log that an XDS Update Document Set transaction has been performed
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Function UpdateDocument( _
   ByVal Domain As XdsDomain, _
   ByVal Source As String, _
   ByVal DestinationURI As WebServiceEndpoint, _
   ByVal Patient As XdsPatient, _
   ByVal SubmissionSet As XdsSubmissionSet, _
   ByVal Response As XdsRegistryResponse, _
   ByVal SourceAudit As Boolean _
) As Integer
Dim Domain As XdsDomain
Dim Source As String
Dim DestinationURI As WebServiceEndpoint
Dim Patient As XdsPatient
Dim SubmissionSet As XdsSubmissionSet
Dim Response As XdsRegistryResponse
Dim SourceAudit As Boolean
Dim value As Integer

value = XdsAudit.UpdateDocument(Domain, Source, DestinationURI, Patient, SubmissionSet, Response, SourceAudit)
public static int UpdateDocument(
   XdsDomain Domain,
   string Source,
   WebServiceEndpoint DestinationURI,
   XdsPatient Patient,
   XdsSubmissionSet SubmissionSet,
   XdsRegistryResponse Response,
   bool SourceAudit
)
public:
static int UpdateDocument(
   XdsDomain^ Domain,
   String^ Source,
   WebServiceEndpoint^ DestinationURI,
   XdsPatient^ Patient,
   XdsSubmissionSet^ SubmissionSet,
   XdsRegistryResponse^ Response,
   bool SourceAudit
)

Parameters

Domain
The XDS domain, including a list of the audit repositories to be used
Source
The name of the source system
DestinationURI
The repository address
Patient
The details of the patient
SubmissionSet
Submission set being sent
Response
The response received from the repository
SourceAudit
False if this message is being sent by the document consumer (True if it is being logged by the repository)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAudit Class
XdsAudit Members


UserAuthentication Method

UserAuthentication Method

XdsObjects Namespace > XdsAudit Class : UserAuthentication Method
The Domain details
Whether or not the authentication succeeded
Log that a user has authenticated with the application.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Function UserAuthentication( _
   ByVal Domain As XdsDomain, _
   ByVal Login As Boolean _
) As Integer
Dim Domain As XdsDomain
Dim Login As Boolean
Dim value As Integer

value = XdsAudit.UserAuthentication(Domain, Login)
public static int UserAuthentication(
   XdsDomain Domain,
   bool Login
)
public:
static int UserAuthentication(
   XdsDomain^ Domain,
   bool Login
)

Parameters

Domain
The Domain details
Login
Whether or not the authentication succeeded

Return Value

True if the message was successfully sent (though for UDP based logging, this is no guarantee that it was received or accepted)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAudit Class
XdsAudit Members


XdsAudit.ParticipatingObject Class

XdsAudit.ParticipatingObject Class
Members

XdsObjects Namespace : XdsAudit.ParticipatingObject Class
The DICOM study details being audited
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsAudit.ParticipatingObject
Dim instance As XdsAudit.ParticipatingObject
public class XdsAudit.ParticipatingObject
public ref class XdsAudit.ParticipatingObject
Inheritance Hierarchy

System.Object
XdsObjects.XdsAudit.ParticipatingObject

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAudit.ParticipatingObject Members
XdsObjects Namespace


XdsAudit.ParticipatingObject Class Members

XdsAudit.ParticipatingObject Class Members
Properties

XdsObjects Namespace : XdsAudit.ParticipatingObject Class

The following tables list the members exposed by XdsAudit.ParticipatingObject.

Public Constructors
 | Name | Description
Public Constructor | XdsAudit.ParticipatingObject Constructor |
Top
Public Properties
 | Name | Description
Public Property | Accession | The accession number
Public Property | NumberOfInstances | The number of objects being accessed
Public Property | SOPClassUIDs | The list of SOP class UIDs of the objects being accessed
Public Property | StudyUID | The DICOM Study UID
Top
See Also

Reference

XdsAudit.ParticipatingObject Class
XdsObjects Namespace


XdsAudit.ParticipatingObject Constructor

XdsAudit.ParticipatingObject Constructor

XdsObjects Namespace > XdsAudit.ParticipatingObject Class : XdsAudit.ParticipatingObject Constructor
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsAudit.ParticipatingObject()
public XdsAudit.ParticipatingObject()
public:
XdsAudit.ParticipatingObject();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAudit.ParticipatingObject Class
XdsAudit.ParticipatingObject Members


XdsAudit.ParticipatingObject Class Properties

XdsAudit.ParticipatingObject Class Properties

XdsObjects Namespace : XdsAudit.ParticipatingObject Class

For a list of all members of this type, see XdsAudit.ParticipatingObject members.

Public Properties
 | Name | Description
Public Property | Accession | The accession number
Public Property | NumberOfInstances | The number of objects being accessed
Public Property | SOPClassUIDs | The list of SOP class UIDs of the objects being accessed
Public Property | StudyUID | The DICOM Study UID
Top
See Also

Reference

XdsAudit.ParticipatingObject Class
XdsObjects Namespace


Accession Property

Accession Property

XdsObjects Namespace > XdsAudit.ParticipatingObject Class : Accession Property
The accession number
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Accession As String
Dim instance As XdsAudit.ParticipatingObject
Dim value As String

instance.Accession = value

value = instance.Accession
public string Accession {get; set;}
public:
property String^ Accession {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAudit.ParticipatingObject Class
XdsAudit.ParticipatingObject Members


NumberOfInstances Property

NumberOfInstances Property

XdsObjects Namespace > XdsAudit.ParticipatingObject Class : NumberOfInstances Property
The number of objects being accessed
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property NumberOfInstances As Integer
Dim instance As XdsAudit.ParticipatingObject
Dim value As Integer

instance.NumberOfInstances = value

value = instance.NumberOfInstances
public int NumberOfInstances {get; set;}
public:
property int NumberOfInstances {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAudit.ParticipatingObject Class
XdsAudit.ParticipatingObject Members


SOPClassUIDs Property

SOPClassUIDs Property

XdsObjects Namespace > XdsAudit.ParticipatingObject Class : SOPClassUIDs Property
The list of SOP class UIDs of the objects being accessed
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property SOPClassUIDs As List(Of String)
Dim instance As XdsAudit.ParticipatingObject
Dim value As List(Of String)

instance.SOPClassUIDs = value

value = instance.SOPClassUIDs
public List<string> SOPClassUIDs {get; set;}
public:
property List<String^>^ SOPClassUIDs {
   List<String^>^ get();
   void set (    List<String^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAudit.ParticipatingObject Class
XdsAudit.ParticipatingObject Members


StudyUID Property

StudyUID Property

XdsObjects Namespace > XdsAudit.ParticipatingObject Class : StudyUID Property
The DICOM Study UID
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property StudyUID As String
Dim instance As XdsAudit.ParticipatingObject
Dim value As String

instance.StudyUID = value

value = instance.StudyUID
public string StudyUID {get; set;}
public:
property String^ StudyUID {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAudit.ParticipatingObject Class
XdsAudit.ParticipatingObject Members


XdsAuthor Class

XdsAuthor Class
Members

XdsObjects Namespace : XdsAuthor Class
Class representing the author of an XDS document or XDS SubmissionSet.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsAuthor
Dim instance As XdsAuthor
public class XdsAuthor
public ref class XdsAuthor
Remarks
According to the XDS specification, an author shall have:

  • One instance of the authorPerson sub-attribute
    This is represented by the Name property

  • Zero or more instances of the authorInstitution sub-attribute
    This is represented by the Institution property

  • Zero or more instances of the authorRole sub-attribute
    This is represented by the Role property

  • Zero or more instances of the authorSpecialty sub-attribute
    This is represented by the Speciality property

Institution, Role and Speciality are XdsMultiString objects, allowing multiple values, but still allowing simple strings to be assigned to them for the (common) scenarios where only single values are used.
Inheritance Hierarchy

System.Object
XdsObjects.XdsAuthor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAuthor Members
XdsObjects Namespace


XdsAuthor Class Members

XdsAuthor Class Members
Properties Methods

XdsObjects Namespace : XdsAuthor Class

The following tables list the members exposed by XdsAuthor.

Public Constructors
 | Name | Description
Public Constructor | XdsAuthor Constructor | Overloaded. Construct a new XdsAuthor object
Top
Public Properties
 | Name | Description
Public Property | ID | GUID for database use
Public Property | Institution | The name of the institution(s) that the author is affiliated to.
Public Property | Name | The Name of the author
Public Property | Role | The name of the role(s) that the author has.
Public Property | Speciality | The name of the speciality(s) associated with the author
Top
Public Methods
 | Name | Description
Public Method | Equals | Standard Equals override
Public Method | GetHashCode | Serves as a hash function for a particular type.
Top
See Also

Reference

XdsAuthor Class
XdsObjects Namespace


XdsAuthor Constructor

XdsAuthor Constructor

XdsObjects Namespace > XdsAuthor Class : XdsAuthor Constructor
Construct a new XdsAuthor object
Overload List
Overload | Description
XdsAuthor Constructor() | Dummy Constructor for serialization use only
XdsAuthor Constructor(String,XdsMultiString,XdsMultiString,XdsMultiString) | Create a new XdsAuthor object with all required data populated.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAuthor Class
XdsAuthor Members


XdsAuthor Constructor()

XdsAuthor Constructor()

XdsObjects Namespace > XdsAuthor Class > XdsAuthor Constructor : XdsAuthor Constructor()
Dummy Constructor for serialization use only
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsAuthor()
public XdsAuthor()
public:
XdsAuthor();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAuthor Class
XdsAuthor Members
Overload List


XdsAuthor Constructor(String,XdsMultiString,XdsMultiString,XdsMultiString)

XdsAuthor Constructor(String,XdsMultiString,XdsMultiString,XdsMultiString)

XdsObjects Namespace > XdsAuthor Class > XdsAuthor Constructor : XdsAuthor Constructor(String,XdsMultiString,XdsMultiString,XdsMultiString)
The name of the author
The author's Institution
The Role of the author
The Speciality of the author
Create a new XdsAuthor object with all required data populated.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal Name As String, _
   ByVal Institution As XdsMultiString, _
   ByVal Role As XdsMultiString, _
   ByVal Speciality As XdsMultiString _
)
Dim Name As String
Dim Institution As XdsMultiString
Dim Role As XdsMultiString
Dim Speciality As XdsMultiString

Dim instance As New XdsAuthor(Name, Institution, Role, Speciality)
public XdsAuthor(
   string Name,
   XdsMultiString Institution,
   XdsMultiString Role,
   XdsMultiString Speciality
)
public:
XdsAuthor(
   String^ Name,
   XdsMultiString^ Institution,
   XdsMultiString^ Role,
   XdsMultiString^ Speciality
)

Parameters

Name
The name of the author
Institution
The author's Institution
Role
The Role of the author
Speciality
The Speciality of the author
Remarks
Due to the use of XdsMultiString objects for the Institution, Role and Speciality parameters, these may be simple strings, Arrays of Strings, Lists of Strings, or null.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAuthor Class
XdsAuthor Members
Overload List


XdsAuthor Class Methods

XdsAuthor Class Methods

XdsObjects Namespace : XdsAuthor Class

For a list of all members of this type, see XdsAuthor members.

Public Methods
 | Name | Description
Public Method | Equals | Standard Equals override
Public Method | GetHashCode | Serves as a hash function for a particular type.
Top
See Also

Reference

XdsAuthor Class
XdsObjects Namespace


Equals Method (XdsAuthor)

Equals Method (XdsAuthor)

XdsObjects Namespace > XdsAuthor Class : Equals Method
The author object to compare to
Standard Equals override
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
Dim instance As XdsAuthor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The author object to compare to

Return Value

true if the strings for Name, Institution, Institutionand Speciality match.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAuthor Class
XdsAuthor Members
Base Implementation in Equals


GetHashCode Method (XdsAuthor)

GetHashCode Method (XdsAuthor)

XdsObjects Namespace > XdsAuthor Class : GetHashCode Method
Serves as a hash function for a particular type.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overrides Function GetHashCode() As Integer
Dim instance As XdsAuthor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

A hash code for the current object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAuthor Class
XdsAuthor Members
Base Implementation in GetHashCode


XdsAuthor Class Properties

XdsAuthor Class Properties

XdsObjects Namespace : XdsAuthor Class

For a list of all members of this type, see XdsAuthor members.

Public Properties
 | Name | Description
Public Property | ID | GUID for database use
Public Property | Institution | The name of the institution(s) that the author is affiliated to.
Public Property | Name | The Name of the author
Public Property | Role | The name of the role(s) that the author has.
Public Property | Speciality | The name of the speciality(s) associated with the author
Top
See Also

Reference

XdsAuthor Class
XdsObjects Namespace


ID Property (XdsAuthor)

ID Property (XdsAuthor)

XdsObjects Namespace > XdsAuthor Class : ID Property
GUID for database use
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ID As Guid
Dim instance As XdsAuthor
Dim value As Guid

instance.ID = value

value = instance.ID
public Guid ID {get; set;}
public:
property Guid ID {
   Guid get();
   void set (    Guid value);
}
Remarks
This ID is internally generated, and is not used as part of any XDS transactions. Its only purpose is to act as a unique ID for the Entity Framework, and if not being used for that, may be ignored.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAuthor Class
XdsAuthor Members


Institution Property

Institution Property

XdsObjects Namespace > XdsAuthor Class : Institution Property
The name of the institution(s) that the author is affiliated to.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Institution As XdsMultiString
Dim instance As XdsAuthor
Dim value As XdsMultiString

instance.Institution = value

value = instance.Institution
public XdsMultiString Institution {get; set;}
public:
property XdsMultiString^ Institution {
   XdsMultiString^ get();
   void set (    XdsMultiString^ value);
}
Remarks
This is an XdsMultiString object, allowing assigment from a string, string[] or List<string>
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAuthor Class
XdsAuthor Members


Name Property (XdsAuthor)

Name Property (XdsAuthor)

XdsObjects Namespace > XdsAuthor Class : Name Property
The Name of the author
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Name As String
Dim instance As XdsAuthor
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAuthor Class
XdsAuthor Members


Role Property

Role Property

XdsObjects Namespace > XdsAuthor Class : Role Property
The name of the role(s) that the author has.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Role As XdsMultiString
Dim instance As XdsAuthor
Dim value As XdsMultiString

instance.Role = value

value = instance.Role
public XdsMultiString Role {get; set;}
public:
property XdsMultiString^ Role {
   XdsMultiString^ get();
   void set (    XdsMultiString^ value);
}
Remarks
This is an XdsMultiString object, allowing assigment from a string, string[] or List<string>
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAuthor Class
XdsAuthor Members


Speciality Property

Speciality Property

XdsObjects Namespace > XdsAuthor Class : Speciality Property
The name of the speciality(s) associated with the author
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Speciality As XdsMultiString
Dim instance As XdsAuthor
Dim value As XdsMultiString

instance.Speciality = value

value = instance.Speciality
public XdsMultiString Speciality {get; set;}
public:
property XdsMultiString^ Speciality {
   XdsMultiString^ get();
   void set (    XdsMultiString^ value);
}
Remarks
This is an XdsMultiString object, allowing assigment from a string, string[] or List<string>
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsAuthor Class
XdsAuthor Members


XdsBaseServer Class

XdsBaseServer Class
Members

XdsObjects Namespace : XdsBaseServer Class
Base class used by the XdsSoapServer and XdsMtomServer classes
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsBaseServer
Dim instance As XdsBaseServer
public class XdsBaseServer
public ref class XdsBaseServer
Inheritance Hierarchy

System.Object
XdsObjects.XdsBaseServer
XdsObjects.XdsMtomServer
XdsObjects.XdsSoapServer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsBaseServer Members
XdsObjects Namespace


XdsBaseServer Class Members

XdsBaseServer Class Members
Properties

XdsObjects Namespace : XdsBaseServer Class

The following tables list the members exposed by XdsBaseServer.

Public Constructors
 | Name | Description
Public Constructor | XdsBaseServer Constructor |
Top
Public Properties
 | Name | Description
Public Property | StructureIncomingSubmissionSet | Controls the behaviour used when incoming data is received.
Top
See Also

Reference

XdsBaseServer Class
XdsObjects Namespace


XdsBaseServer Constructor

XdsBaseServer Constructor

XdsObjects Namespace > XdsBaseServer Class : XdsBaseServer Constructor
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsBaseServer()
public XdsBaseServer()
public:
XdsBaseServer();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsBaseServer Class
XdsBaseServer Members


XdsBaseServer Class Properties

XdsBaseServer Class Properties

XdsObjects Namespace : XdsBaseServer Class

For a list of all members of this type, see XdsBaseServer members.

Public Properties
 | Name | Description
Public Property | StructureIncomingSubmissionSet | Controls the behaviour used when incoming data is received.
Top
See Also

Reference

XdsBaseServer Class
XdsObjects Namespace


StructureIncomingSubmissionSet Property (XdsBaseServer)

StructureIncomingSubmissionSet Property (XdsBaseServer)

XdsObjects Namespace > XdsBaseServer Class : StructureIncomingSubmissionSet Property
Controls the behaviour used when incoming data is received.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property StructureIncomingSubmissionSet As Boolean
Dim instance As XdsBaseServer
Dim value As Boolean

instance.StructureIncomingSubmissionSet = value

value = instance.StructureIncomingSubmissionSet
public bool StructureIncomingSubmissionSet {get; set;}
public:
property bool StructureIncomingSubmissionSet {
   bool get();
   void set (    bool value);
}
Remarks

XdsObjects can operate in 2 distinct modes - depending on the value of this property

If it is true (the default):

A folder structure is created as aprt of the receipt of data, with documents being placed in folders according the associations which link them, and the XdsSubmissionSet's Structured property is set to true

If false:

All documents will appear in the top level Document folder and the XdsSubmissionSet's Structured property is set to false. In this case, the associations may be found, unaltered, in the XdsSubmissionSet's Associations collection.

There are 2 versions of this property - one attached to XdsBaseServer which controls the behaviour when receiving data vai ProvideAndRegisterDocumentSet or RegisterDocumentSet transactions, and the other on XdsDomain which is used for data received via query and retrieve operations.

In general, this value should be true for consumers, but false for registries, servers and gateways.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsBaseServer Class
XdsBaseServer Members


XdsCode Class

XdsCode Class
Members

XdsObjects Namespace : XdsCode Class
An Class representing a "code" as used within the XDS/ebXML standard
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsCode
Dim instance As XdsCode
public class XdsCode
public ref class XdsCode
Remarks

A code has 3 components - represented as members:

  • A coding scheme
  • A code value
  • A code representation (the human readable form)

For more details on use of codes see : Use of Codes in XDS:

Inheritance Hierarchy

System.Object
XdsObjects.XdsCode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsCode Members
XdsObjects Namespace


XdsCode Class Members

XdsCode Class Members
Properties Methods

XdsObjects Namespace : XdsCode Class

The following tables list the members exposed by XdsCode.

Public Constructors
 | Name | Description
Public Constructor | XdsCode Constructor | Overloaded. Construct a new XdsCode object
Top
Public Properties
 | Name | Description
Public Property | CodeMeaning | The Human readable version of the code
Public Property | CodeValue | The value of the code - normally a guid or other obscure (not easily interpretted) code
Public Property | CodingScheme | The name of the coding scheme
Public Property | ID | GUID for database use
Top
Public Methods
 | Name | Description
Public Method | Equals | Override to give XdsCode value semantics
Public Method | GetHashCode | Serves as a hash function for a particular type.
Public Method | ToString | Standard overload - a human readable representation, based on the CodeMeaning property
Top
See Also

Reference

XdsCode Class
XdsObjects Namespace


XdsCode Constructor

XdsCode Constructor

XdsObjects Namespace > XdsCode Class : XdsCode Constructor
Construct a new XdsCode object
Overload List
Overload | Description
XdsCode Constructor() | Constructs an empty XdsCode object
XdsCode Constructor(String,String,XdsInternationalString) | Constructs a populated XdsCode object
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsCode Class
XdsCode Members


XdsCode Constructor()

XdsCode Constructor()

XdsObjects Namespace > XdsCode Class > XdsCode Constructor : XdsCode Constructor()
Constructs an empty XdsCode object
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsCode()
public XdsCode()
public:
XdsCode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsCode Class
XdsCode Members
Overload List


XdsCode Constructor(String,String,XdsInternationalString)

XdsCode Constructor(String,String,XdsInternationalString)

XdsObjects Namespace > XdsCode Class > XdsCode Constructor : XdsCode Constructor(String,String,XdsInternationalString)
The coding scheme to use - this is commonly, but not always a GUID
The coding scheme to use
The human readable code meanging.
Constructs a populated XdsCode object
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal CodingScheme As String, _
   ByVal CodeValue As String, _
   ByVal CodeMeaning As XdsInternationalString _
)
Dim CodingScheme As String
Dim CodeValue As String
Dim CodeMeaning As XdsInternationalString

Dim instance As New XdsCode(CodingScheme, CodeValue, CodeMeaning)
public XdsCode(
   string CodingScheme,
   string CodeValue,
   XdsInternationalString CodeMeaning
)
public:
XdsCode(
   String^ CodingScheme,
   String^ CodeValue,
   XdsInternationalString^ CodeMeaning
)

Parameters

CodingScheme
The coding scheme to use - this is commonly, but not always a GUID
CodeValue
The coding scheme to use
CodeMeaning
The human readable code meanging.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsCode Class
XdsCode Members
Overload List


XdsCode Class Methods

XdsCode Class Methods

XdsObjects Namespace : XdsCode Class

For a list of all members of this type, see XdsCode members.

Public Methods
 | Name | Description
Public Method | Equals | Override to give XdsCode value semantics
Public Method | GetHashCode | Serves as a hash function for a particular type.
Public Method | ToString | Standard overload - a human readable representation, based on the CodeMeaning property
Top
See Also

Reference

XdsCode Class
XdsObjects Namespace


Equals Method (XdsCode)

Equals Method (XdsCode)

XdsObjects Namespace > XdsCode Class : Equals Method
Object being compared
Override to give XdsCode value semantics
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
Dim instance As XdsCode
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object being compared

Return Value

true if CodingScheme, CodeValue and primary CodeValue are all the same
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsCode Class
XdsCode Members
Base Implementation in Equals


GetHashCode Method (XdsCode)

GetHashCode Method (XdsCode)

XdsObjects Namespace > XdsCode Class : GetHashCode Method
Serves as a hash function for a particular type.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overrides Function GetHashCode() As Integer
Dim instance As XdsCode
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

A hash code for the current object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsCode Class
XdsCode Members
Base Implementation in GetHashCode


ToString Method (XdsCode)

ToString Method (XdsCode)

XdsObjects Namespace > XdsCode Class : ToString Method
Standard overload - a human readable representation, based on the CodeMeaning property
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overrides Function ToString() As String
Dim instance As XdsCode
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsCode Class
XdsCode Members
Base Implementation in ToString


XdsCode Class Properties

XdsCode Class Properties

XdsObjects Namespace : XdsCode Class

For a list of all members of this type, see XdsCode members.

Public Properties
 | Name | Description
Public Property | CodeMeaning | The Human readable version of the code
Public Property | CodeValue | The value of the code - normally a guid or other obscure (not easily interpretted) code
Public Property | CodingScheme | The name of the coding scheme
Public Property | ID | GUID for database use
Top
See Also

Reference

XdsCode Class
XdsObjects Namespace


CodeMeaning Property

CodeMeaning Property

XdsObjects Namespace > XdsCode Class : CodeMeaning Property
The Human readable version of the code
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property CodeMeaning As XdsInternationalString
Dim instance As XdsCode
Dim value As XdsInternationalString

instance.CodeMeaning = value

value = instance.CodeMeaning
public XdsInternationalString CodeMeaning {get; set;}
public:
property XdsInternationalString^ CodeMeaning {
   XdsInternationalString^ get();
   void set (    XdsInternationalString^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsCode Class
XdsCode Members


CodeValue Property

CodeValue Property

XdsObjects Namespace > XdsCode Class : CodeValue Property
The value of the code - normally a guid or other obscure (not easily interpretted) code
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property CodeValue As String
Dim instance As XdsCode
Dim value As String

instance.CodeValue = value

value = instance.CodeValue
public string CodeValue {get; set;}
public:
property String^ CodeValue {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsCode Class
XdsCode Members


CodingScheme Property

CodingScheme Property

XdsObjects Namespace > XdsCode Class : CodingScheme Property
The name of the coding scheme
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property CodingScheme As String
Dim instance As XdsCode
Dim value As String

instance.CodingScheme = value

value = instance.CodingScheme
public string CodingScheme {get; set;}
public:
property String^ CodingScheme {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsCode Class
XdsCode Members


ID Property (XdsCode)

ID Property (XdsCode)

XdsObjects Namespace > XdsCode Class : ID Property
GUID for database use
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ID As Guid
Dim instance As XdsCode
Dim value As Guid

instance.ID = value

value = instance.ID
public Guid ID {get; set;}
public:
property Guid ID {
   Guid get();
   void set (    Guid value);
}
Remarks
This ID is internally generated, and is not used as part of any XDS transactions. Its only purpose is to act as a unique ID for the Entity Framework, and if not being used for that, may be ignored.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsCode Class
XdsCode Members


XdsDeleteDocumentSetRequest Class

XdsDeleteDocumentSetRequest Class
Members

XdsObjects Namespace : XdsDeleteDocumentSetRequest Class
Object that represents the XDS Delete Document Set Request
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsDeleteDocumentSetRequest
Dim instance As XdsDeleteDocumentSetRequest
public class XdsDeleteDocumentSetRequest
public ref class XdsDeleteDocumentSetRequest
Inheritance Hierarchy

System.Object
XdsObjects.XdsDeleteDocumentSetRequest

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDeleteDocumentSetRequest Members
XdsObjects Namespace


XdsDeleteDocumentSetRequest Class Members

XdsDeleteDocumentSetRequest Class Members

XdsObjects Namespace : XdsDeleteDocumentSetRequest Class

The following tables list the members exposed by XdsDeleteDocumentSetRequest.

Public Constructors
 | Name | Description
Public Constructor | XdsDeleteDocumentSetRequest Constructor | Construct a XDS Delete Document Set Request from a list of IDs for which objects are to be deleted
Top
See Also

Reference

XdsDeleteDocumentSetRequest Class
XdsObjects Namespace


XdsDeleteDocumentSetRequest Constructor

XdsDeleteDocumentSetRequest Constructor

XdsObjects Namespace > XdsDeleteDocumentSetRequest Class : XdsDeleteDocumentSetRequest Constructor
Construct a XDS Delete Document Set Request from a list of IDs for which objects are to be deleted
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal IDs As List(Of String) _
)
Dim IDs As List(Of String)

Dim instance As New XdsDeleteDocumentSetRequest(IDs)
public XdsDeleteDocumentSetRequest(
   List<string> IDs
)
public:
XdsDeleteDocumentSetRequest(
   List<String^>^ IDs
)

Parameters

IDs
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDeleteDocumentSetRequest Class
XdsDeleteDocumentSetRequest Members


XdsDocument Class

XdsDocument Class
Members

XdsObjects Namespace : XdsDocument Class
A class representing a single document as used in XDS
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsDocument
Dim instance As XdsDocument
public class XdsDocument
public ref class XdsDocument
Remarks

This class holds all the meta data for a document and also (optionally) the actual document itself (as a byte array in the Data property).

It is used in the following scenarios:

  • Submission
    Added to the XdsSubmissionSet.Documents collection.
  • Registry Queries
    In the resulting XdsQueryResponse.ReturnedDocuments collection
  • Retrieval
    In the resulting XdsRetrieveResponse.Documents collection

It if also used in similar ways in reverse in server applications.

Inheritance Hierarchy

System.Object
XdsObjects.XdsDocument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Members
XdsObjects Namespace


XdsDocument Class Members

XdsDocument Class Members
Properties Methods

XdsObjects Namespace : XdsDocument Class

The following tables list the members exposed by XdsDocument.

Public Constructors
 | Name | Description
Public Constructor | XdsDocument Constructor | Overloaded. Create a new XdsDocument object
Top
Public Properties
 | Name | Description
Public Property | AlreadyExists | A flag indicating whether the document already exists in the registry (as opposed to being created now)
Public Property | Authors | The humans and/or machines that authored the document
Public Property | AvailabilityStatus | The availability stats (Approved/Deprecated) of the document
Public Property | AvailabilityStatusAsInt | The AvailabilityStatus as an integer
Public Property | ClassCode | The code specifying the particular kind of document
Public Property | Comments | Comments associated with the Document
Public Property | ConfidentialityCodes | The code(s) specifying the level of confidentiality of the XDS Document
Public Property | CreationTime | The time the author created the document in the Document Source.
Public Property | Data | The contents of the document
Public Property | DocumentRelationship | The Relationship between Existing (Parent) Document and Current Document being Submitted
Public Property | EventCodeList | The code(s) representing the main clinical acts, such as a colonoscopy or an appendectomy, being documented.
Public Property | ExtraSlots | The list of slots not explicitly used to populate other fields
Public Property | FormatCode | Code globally uniquely specifying the format of the document.
Public Property | Hash | Hash key of the XDS Document itself.
Public Property | HealthCareFacilityTypeCode | This code represents the type of organizational setting of the clinical encounter during which the documented act occurred.
Public Property | HomeCommunityID | The HomeCommunityID of the Document
Public Property | LanguageCode | Specifies the human language of character data in the document.
Public Property | LegalAuthenticator | Represents a participant who has legally authenticated or attested the document within the authorInstitution.
Public Property | LogicalId | To allow a collection of registry objects to be grouped together and be identified as versions of the same object, two new attributes are introduced: the Logical ID and the VersionInfo element. While all objects must have unique value for their id attribute to maintain their identity, all objects that are versions of the same logical object have the same logical id or lid attribute
Public Property | MimeType | MIME type of the document in the Repository.
Public Property | PatientID | Shortcut to PatientInfo.XdsPerson.CompositeId
Public Property | PatientInfo | The subject of care of the document.
Public Property | PracticeSettingCode | The code specifying the clinical specialty where the act that resulted in the document was performed
Public Property | ReferenceIdList | Holds a list of additional Reference ID name/value pairs
Public Property | RepositoryUniqueId | The globally unique identifier of the repository where the document is stored
Public Property | ServiceStartTime | Represents the start time the service being documented took place
Public Property | ServiceStopTime | Represents the stop time the service being documented took place
Public Property | Size | Size of the XDS Document itself.
Public Property | SourcePatientDetails | The details of the subject of care as the Document Source knew them at the time of Submission.
Public Property | Title | Represents the title of the document
Public Property | TypeCode | The code specifying the precise kind of document
Public Property | UniqueID | The globally unique identifier assigned by the document creator to this document.
Public Property | Uri | The URI from which the document could be retrieved.
Public Property | UUID | The globally unique identifier of the document
Public Property | VersionInfo | To allow a collection of registry objects to be grouped together and be identified as versions of the same object, two new attributes are introduced: the Logical ID and the VersionInfo element. While all objects must have unique value for their id attribute to maintain their identity, all objects that are versions of the same logical object have the same logical id or lid attribute
Top
Public Methods
 | Name | Description
Public Method | CheckSizeAndHash | Check that the document in the Data property actually matches the Size and Hash values.
static (Shared in Visual Basic) | FromUUID | Creates a "dummy" XdsDocument object, in which only the UUID is populated, and the AlreadyExists property is true.
Public Method | Load | Overloaded. Methods to load a XdsDocument directly from local resources
Public Method | SetSizeAndHash | Set the Size and Hash, based on the current content
Top
See Also

Reference

XdsDocument Class
XdsObjects Namespace


XdsDocument Constructor

XdsDocument Constructor

XdsObjects Namespace > XdsDocument Class : XdsDocument Constructor
Create a new XdsDocument object
Overload List
Overload | Description
XdsDocument Constructor() | Create a new empty XdsDocument objects
XdsDocument Constructor(String) | Create a new XdsDocument objects from a file
XdsDocument Constructor(Byte[]) | Create a new XdsDocument object from a byte array
XdsDocument Constructor(Stream) | Create a new XdsDocument object from a Stream
XdsDocument Constructor(DicomDataSet,String) | Create an XdsDocument from an existing DicomObjects dataset
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


XdsDocument Constructor()

XdsDocument Constructor()

XdsObjects Namespace > XdsDocument Class > XdsDocument Constructor : XdsDocument Constructor()
Create a new empty XdsDocument objects
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsDocument()
public XdsDocument()
public:
XdsDocument();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members
Overload List


XdsDocument Constructor(String)

XdsDocument Constructor(String)

XdsObjects Namespace > XdsDocument Class > XdsDocument Constructor : XdsDocument Constructor(String)
The filename to read data from
Create a new XdsDocument objects from a file
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal path As String _
)
Dim path As String

Dim instance As New XdsDocument(path)
public XdsDocument(
   string path
)
public:
XdsDocument(
   String^ path
)

Parameters

path
The filename to read data from
Remarks
The extension of the filename is used (via standard Windows means) to determine the MimeType of the resulting object automatically.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members
Overload List


XdsDocument Constructor(Byte[])

XdsDocument Constructor(Byte[])

XdsObjects Namespace > XdsDocument Class > XdsDocument Constructor : XdsDocument Constructor(Byte[])
The byte array containing the document data
Create a new XdsDocument object from a byte array
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal data() As Byte _
)
Dim data() As Byte

Dim instance As New XdsDocument(data)
public XdsDocument(
   byte[] data
)
public:
XdsDocument(
   array<byte>^ data
)

Parameters

data
The byte array containing the document data
Remarks
Unlike the XdsDocument Constructor(String) version, this overload has no means to determine the MimeType whic must be set explicitly.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members
Overload List


XdsDocument Constructor(Stream)

XdsDocument Constructor(Stream)

XdsObjects Namespace > XdsDocument Class > XdsDocument Constructor : XdsDocument Constructor(Stream)
The stream to read from.
Create a new XdsDocument object from a Stream
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal stream As Stream _
)
Dim stream As Stream

Dim instance As New XdsDocument(stream)
public XdsDocument(
   Stream stream
)
public:
XdsDocument(
   Stream^ stream
)

Parameters

stream
The stream to read from.
Remarks
Unlike the XdsDocument Constructor(String) version, this overload has no means to determine the MimeType whic must be set explicitly.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members
Overload List


XdsDocument Constructor(DicomDataSet,String)

XdsDocument Constructor(DicomDataSet,String)

XdsObjects Namespace > XdsDocument Class > XdsDocument Constructor : XdsDocument Constructor(DicomDataSet,String)
The DicomDataSet to create the data from
The DICOM TransferSyntax to use when encoding from the DataSet to the byte array
Create an XdsDocument from an existing DicomObjects dataset
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal DataSet As DicomObjects.DicomDataSet, _
   ByVal TransferSyntax As String _
)
Dim DataSet As DicomObjects.DicomDataSet
Dim TransferSyntax As String

Dim instance As New XdsDocument(DataSet, TransferSyntax)
public XdsDocument(
   DicomObjects.DicomDataSet DataSet,
   string TransferSyntax
)
public:
XdsDocument(
   DicomObjects.DicomDataSet^ DataSet,
   String^ TransferSyntax
)

Parameters

DataSet
The DicomDataSet to create the data from
TransferSyntax
The DICOM TransferSyntax to use when encoding from the DataSet to the byte array
Remarks

This overload requires that DicomObjects be available to the application.

It is used for creating KOS objects as part of XDS-I

The MimeType is automatically set to "application/dicom"

Requirements
DicomObjects
See Also

Reference

XdsDocument Class
XdsDocument Members
Overload List


XdsDocument Class Methods

XdsDocument Class Methods

XdsObjects Namespace : XdsDocument Class

For a list of all members of this type, see XdsDocument members.

Public Methods
 | Name | Description
Public Method | CheckSizeAndHash | Check that the document in the Data property actually matches the Size and Hash values.
static (Shared in Visual Basic) | FromUUID | Creates a "dummy" XdsDocument object, in which only the UUID is populated, and the AlreadyExists property is true.
Public Method | Load | Overloaded. Methods to load a XdsDocument directly from local resources
Public Method | SetSizeAndHash | Set the Size and Hash, based on the current content
Top
See Also

Reference

XdsDocument Class
XdsObjects Namespace


CheckSizeAndHash Method

CheckSizeAndHash Method

XdsObjects Namespace > XdsDocument Class : CheckSizeAndHash Method
Check that the document in the Data property actually matches the Size and Hash values.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function CheckSizeAndHash() As Boolean
Dim instance As XdsDocument
Dim value As Boolean

value = instance.CheckSizeAndHash()
public bool CheckSizeAndHash()
public:
bool CheckSizeAndHash();

Return Value

true if the data is consistent, and false if inconsistent
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


FromUUID Method

FromUUID Method

XdsObjects Namespace > XdsDocument Class : FromUUID Method
The UUID of the reference
Creates a "dummy" XdsDocument object, in which only the UUID is populated, and the AlreadyExists property is true.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Function FromUUID( _
   ByVal UUID As String _
) As XdsDocument
Dim UUID As String
Dim value As XdsDocument

value = XdsDocument.FromUUID(UUID)
public static XdsDocument FromUUID(
   string UUID
)
public:
static XdsDocument^ FromUUID(
   String^ UUID
)

Parameters

UUID
The UUID of the reference

Return Value

A new minimal XdsDocument
Remarks
This is used when adding a reference to an "existing" document to a XdsSubmissionSet or XdsFolder, as it enables the reference to be used, without creating a duplicate of the document itself.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


Load Method

Load Method

XdsObjects Namespace > XdsDocument Class : Load Method
Methods to load a XdsDocument directly from local resources
Overload List
Overload | Description
Load(String) | Load a XdsDocument objects from a file
Load(Byte[]) | Load an XdsDocument object from a byte array
Load(Stream) | Load an XdsDocument object from a stream
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


Load(String) Method

Load(String) Method

XdsObjects Namespace > XdsDocument Class > Load Method : Load(String) Method
The filename to read data from
Load a XdsDocument objects from a file
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overloads Sub Load( _
   ByVal path As String _
)
Dim instance As XdsDocument
Dim path As String

instance.Load(path)
public void Load(
   string path
)
public:
void Load(
   String^ path
)

Parameters

path
The filename to read data from
Remarks
The extension of the filename is used (via standard Windows means) to set the MimeType of the document automatically.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members
Overload List


Load(Byte[]) Method

Load(Byte[]) Method

XdsObjects Namespace > XdsDocument Class > Load Method : Load(Byte[]) Method
The byte array containing the document data
Load an XdsDocument object from a byte array
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overloads Sub Load( _
   ByVal data() As Byte _
)
Dim instance As XdsDocument
Dim data() As Byte

instance.Load(data)
public void Load(
   byte[] data
)
public:
void Load(
   array<byte>^ data
)

Parameters

data
The byte array containing the document data
Remarks
Unlike the Load(String) version, this overload has no means to determine the MimeType which must be set explicitly.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members
Overload List


Load(Stream) Method

Load(Stream) Method

XdsObjects Namespace > XdsDocument Class > Load Method : Load(Stream) Method
The Stream containing the document data
Load an XdsDocument object from a stream
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overloads Sub Load( _
   ByVal Stream As Stream _
)
Dim instance As XdsDocument
Dim Stream As Stream

instance.Load(Stream)
public void Load(
   Stream Stream
)
public:
void Load(
   Stream^ Stream
)

Parameters

Stream
The Stream containing the document data
Remarks
Unlike the Load(String) version, this overload has no means to determine the MimeType which must be set explicitly.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members
Overload List


SetSizeAndHash Method

SetSizeAndHash Method

XdsObjects Namespace > XdsDocument Class : SetSizeAndHash Method
Set the Size and Hash, based on the current content
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub SetSizeAndHash()
Dim instance As XdsDocument

instance.SetSizeAndHash()
public void SetSizeAndHash()
public:
void SetSizeAndHash();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


XdsDocument Class Properties

XdsDocument Class Properties

XdsObjects Namespace : XdsDocument Class

For a list of all members of this type, see XdsDocument members.

Public Properties
 | Name | Description
Public Property | AlreadyExists | A flag indicating whether the document already exists in the registry (as opposed to being created now)
Public Property | Authors | The humans and/or machines that authored the document
Public Property | AvailabilityStatus | The availability stats (Approved/Deprecated) of the document
Public Property | AvailabilityStatusAsInt | The AvailabilityStatus as an integer
Public Property | ClassCode | The code specifying the particular kind of document
Public Property | Comments | Comments associated with the Document
Public Property | ConfidentialityCodes | The code(s) specifying the level of confidentiality of the XDS Document
Public Property | CreationTime | The time the author created the document in the Document Source.
Public Property | Data | The contents of the document
Public Property | DocumentRelationship | The Relationship between Existing (Parent) Document and Current Document being Submitted
Public Property | EventCodeList | The code(s) representing the main clinical acts, such as a colonoscopy or an appendectomy, being documented.
Public Property | ExtraSlots | The list of slots not explicitly used to populate other fields
Public Property | FormatCode | Code globally uniquely specifying the format of the document.
Public Property | Hash | Hash key of the XDS Document itself.
Public Property | HealthCareFacilityTypeCode | This code represents the type of organizational setting of the clinical encounter during which the documented act occurred.
Public Property | HomeCommunityID | The HomeCommunityID of the Document
Public Property | LanguageCode | Specifies the human language of character data in the document.
Public Property | LegalAuthenticator | Represents a participant who has legally authenticated or attested the document within the authorInstitution.
Public Property | LogicalId | To allow a collection of registry objects to be grouped together and be identified as versions of the same object, two new attributes are introduced: the Logical ID and the VersionInfo element. While all objects must have unique value for their id attribute to maintain their identity, all objects that are versions of the same logical object have the same logical id or lid attribute
Public Property | MimeType | MIME type of the document in the Repository.
Public Property | PatientID | Shortcut to PatientInfo.XdsPerson.CompositeId
Public Property | PatientInfo | The subject of care of the document.
Public Property | PracticeSettingCode | The code specifying the clinical specialty where the act that resulted in the document was performed
Public Property | ReferenceIdList | Holds a list of additional Reference ID name/value pairs
Public Property | RepositoryUniqueId | The globally unique identifier of the repository where the document is stored
Public Property | ServiceStartTime | Represents the start time the service being documented took place
Public Property | ServiceStopTime | Represents the stop time the service being documented took place
Public Property | Size | Size of the XDS Document itself.
Public Property | SourcePatientDetails | The details of the subject of care as the Document Source knew them at the time of Submission.
Public Property | Title | Represents the title of the document
Public Property | TypeCode | The code specifying the precise kind of document
Public Property | UniqueID | The globally unique identifier assigned by the document creator to this document.
Public Property | Uri | The URI from which the document could be retrieved.
Public Property | UUID | The globally unique identifier of the document
Public Property | VersionInfo | To allow a collection of registry objects to be grouped together and be identified as versions of the same object, two new attributes are introduced: the Logical ID and the VersionInfo element. While all objects must have unique value for their id attribute to maintain their identity, all objects that are versions of the same logical object have the same logical id or lid attribute
Top
See Also

Reference

XdsDocument Class
XdsObjects Namespace


AlreadyExists Property (XdsDocument)

AlreadyExists Property (XdsDocument)

XdsObjects Namespace > XdsDocument Class : AlreadyExists Property
A flag indicating whether the document already exists in the registry (as opposed to being created now)
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property AlreadyExists As Boolean
Dim instance As XdsDocument
Dim value As Boolean

instance.AlreadyExists = value

value = instance.AlreadyExists
public bool AlreadyExists {get; set;}
public:
property bool AlreadyExists {
   bool get();
   void set (    bool value);
}
Remarks
This flag controls whether the document is included, or is merely referenced.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


Authors Property (XdsDocument)

Authors Property (XdsDocument)

XdsObjects Namespace > XdsDocument Class : Authors Property
The humans and/or machines that authored the document
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Authors As List(Of XdsAuthor)
Dim instance As XdsDocument
Dim value As List(Of XdsAuthor)

instance.Authors = value

value = instance.Authors
public List<XdsAuthor> Authors {get; set;}
public:
property List<XdsAuthor^>^ Authors {
   List<XdsAuthor^>^ get();
   void set (    List<XdsAuthor^>^ value);
}
Remarks

This property corresponds to the XDSDocumentEntry.author Classifications

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


AvailabilityStatus Property (XdsDocument)

AvailabilityStatus Property (XdsDocument)

XdsObjects Namespace > XdsDocument Class : AvailabilityStatus Property
The availability stats (Approved/Deprecated) of the document
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property AvailabilityStatus As AvailabilityStatusCode
Dim instance As XdsDocument
Dim value As AvailabilityStatusCode

instance.AvailabilityStatus = value

value = instance.AvailabilityStatus
public AvailabilityStatusCode AvailabilityStatus {get; set;}
public:
property AvailabilityStatusCode AvailabilityStatus {
   AvailabilityStatusCode get();
   void set (    AvailabilityStatusCode value);
}
Remarks

This property corresponds to the XDSDocumentEntry.availabilityStatus attribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


AvailabilityStatusAsInt Property (XdsDocument)

AvailabilityStatusAsInt Property (XdsDocument)

XdsObjects Namespace > XdsDocument Class : AvailabilityStatusAsInt Property
The AvailabilityStatus as an integer
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property AvailabilityStatusAsInt As Integer
Dim instance As XdsDocument
Dim value As Integer

instance.AvailabilityStatusAsInt = value

value = instance.AvailabilityStatusAsInt
public int AvailabilityStatusAsInt {get; set;}
public:
property int AvailabilityStatusAsInt {
   int get();
   void set (    int value);
}
Remarks
This is a special property, only used as part of a registry based on the Code First Entity Framework which is used for our registry example. This is needed due to the inability of the Entity Framework to handle Enums. When used in this mode, the AvailabilityStatus property should be excluded from the database.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


ClassCode Property

ClassCode Property

XdsObjects Namespace > XdsDocument Class : ClassCode Property
The code specifying the particular kind of document
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ClassCode As XdsCode
Dim instance As XdsDocument
Dim value As XdsCode

instance.ClassCode = value

value = instance.ClassCode
public XdsCode ClassCode {get; set;}
public:
property XdsCode^ ClassCode {
   XdsCode^ get();
   void set (    XdsCode^ value);
}
Remarks

This property corresponds to the XDSDocumentEntry.classCode Classification

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


Comments Property (XdsDocument)

Comments Property (XdsDocument)

XdsObjects Namespace > XdsDocument Class : Comments Property
Comments associated with the Document
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Comments As XdsInternationalString
Dim instance As XdsDocument
Dim value As XdsInternationalString

instance.Comments = value

value = instance.Comments
public XdsInternationalString Comments {get; set;}
public:
property XdsInternationalString^ Comments {
   XdsInternationalString^ get();
   void set (    XdsInternationalString^ value);
}
Remarks

This property corresponds to the XDSDocumentEntry.comments Attribute, which actually uses the ebXML "Description" attribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


ConfidentialityCodes Property

ConfidentialityCodes Property

XdsObjects Namespace > XdsDocument Class : ConfidentialityCodes Property
The code(s) specifying the level of confidentiality of the XDS Document
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ConfidentialityCodes As List(Of XdsCode)
Dim instance As XdsDocument
Dim value As List(Of XdsCode)

instance.ConfidentialityCodes = value

value = instance.ConfidentialityCodes
public List<XdsCode> ConfidentialityCodes {get; set;}
public:
property List<XdsCode^>^ ConfidentialityCodes {
   List<XdsCode^>^ get();
   void set (    List<XdsCode^>^ value);
}
Remarks

This property corresponds to the XDSDocumentEntry.eventCodeList Classification

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


CreationTime Property

CreationTime Property

XdsObjects Namespace > XdsDocument Class : CreationTime Property
The time the author created the document in the Document Source.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property CreationTime As Date
Dim instance As XdsDocument
Dim value As Date

instance.CreationTime = value

value = instance.CreationTime
public DateTime CreationTime {get; set;}
public:
property DateTime CreationTime {
   DateTime get();
   void set (    DateTime value);
}
Remarks

This property corresponds to the XDSDocumentEntry.creationTime Slot

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


Data Property

Data Property

XdsObjects Namespace > XdsDocument Class : Data Property
The contents of the document
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Data As Byte()
Dim instance As XdsDocument
Dim value() As Byte

instance.Data = value

value = instance.Data
public byte[] Data {get; set;}
public:
property array<byte>^ Data {
   array<byte>^ get();
   void set (    array<byte>^ value);
}
Remarks
This property may be populated (e.g when submitting a document, or when the document is part of the XdsRetrieveResponse.Documents collection, but will atother times be null - e.g. when the document has been generated as a result of a Registry Stored Query.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


DocumentRelationship Property

DocumentRelationship Property

XdsObjects Namespace > XdsDocument Class : DocumentRelationship Property
The Relationship between Existing (Parent) Document and Current Document being Submitted
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DocumentRelationship As XdsRelationship
Dim instance As XdsDocument
Dim value As XdsRelationship

instance.DocumentRelationship = value

value = instance.DocumentRelationship
public XdsRelationship DocumentRelationship {get; set;}
public:
property XdsRelationship^ DocumentRelationship {
   XdsRelationship^ get();
   void set (    XdsRelationship^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


EventCodeList Property

EventCodeList Property

XdsObjects Namespace > XdsDocument Class : EventCodeList Property
The code(s) representing the main clinical acts, such as a colonoscopy or an appendectomy, being documented.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property EventCodeList As List(Of XdsCode)
Dim instance As XdsDocument
Dim value As List(Of XdsCode)

instance.EventCodeList = value

value = instance.EventCodeList
public List<XdsCode> EventCodeList {get; set;}
public:
property List<XdsCode^>^ EventCodeList {
   List<XdsCode^>^ get();
   void set (    List<XdsCode^>^ value);
}
Remarks

This property corresponds to the XDSDocumentEntry.confidentialityCode Classification

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


ExtraSlots Property (XdsDocument)

ExtraSlots Property (XdsDocument)

XdsObjects Namespace > XdsDocument Class : ExtraSlots Property
The list of slots not explicitly used to populate other fields
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property ExtraSlots As List(Of XdsSlot)
Dim instance As XdsDocument
Dim value As List(Of XdsSlot)

value = instance.ExtraSlots
public List<XdsSlot> ExtraSlots {get;}
public:
property List<XdsSlot^>^ ExtraSlots {
   List<XdsSlot^>^ get();
}
Remarks
Whilst the XDS standards specifiy the contents of some slots (such as ServiceStopTime and many more), other "user defined" slots are allowed and should be stored by a registry. This property allows such additional slots to be created and accessed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


FormatCode Property

FormatCode Property

XdsObjects Namespace > XdsDocument Class : FormatCode Property
Code globally uniquely specifying the format of the document.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property FormatCode As XdsCode
Dim instance As XdsDocument
Dim value As XdsCode

instance.FormatCode = value

value = instance.FormatCode
public XdsCode FormatCode {get; set;}
public:
property XdsCode^ FormatCode {
   XdsCode^ get();
   void set (    XdsCode^ value);
}
Remarks

This property corresponds to the XDSDocumentEntry.formatCode Classification

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


Hash Property

Hash Property

XdsObjects Namespace > XdsDocument Class : Hash Property
Hash key of the XDS Document itself.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Hash As String
Dim instance As XdsDocument
Dim value As String

instance.Hash = value

value = instance.Hash
public string Hash {get; set;}
public:
property String^ Hash {
   String^ get();
   void set (    String^ value);
}
Remarks

This property corresponds to the XDSDocumentEntry.hash attribute

This value needs to to be set (possibly using the SetSizeAndHash method) by a repository, before submitting the neta data to the registry, but it does not need to be set by a Document Source prior to a ProvideAndRegister transaction

Note that this attribute is specially moddifed and handled differently when Multi-Part documents are written using XdsSubmissionSet.WriteXDM, since it (and Size) have to be modified to relate only to the first part.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


HealthCareFacilityTypeCode Property

HealthCareFacilityTypeCode Property

XdsObjects Namespace > XdsDocument Class : HealthCareFacilityTypeCode Property
This code represents the type of organizational setting of the clinical encounter during which the documented act occurred.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property HealthCareFacilityTypeCode As XdsCode
Dim instance As XdsDocument
Dim value As XdsCode

instance.HealthCareFacilityTypeCode = value

value = instance.HealthCareFacilityTypeCode
public XdsCode HealthCareFacilityTypeCode {get; set;}
public:
property XdsCode^ HealthCareFacilityTypeCode {
   XdsCode^ get();
   void set (    XdsCode^ value);
}
Remarks

This property corresponds to the XDSDocumentEntry.healthcareFacilityTypeCode Classification

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


HomeCommunityID Property (XdsDocument)

HomeCommunityID Property (XdsDocument)

XdsObjects Namespace > XdsDocument Class : HomeCommunityID Property
The HomeCommunityID of the Document
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property HomeCommunityID As String
Dim instance As XdsDocument
Dim value As String

instance.HomeCommunityID = value

value = instance.HomeCommunityID
public string HomeCommunityID {get; set;}
public:
property String^ HomeCommunityID {
   String^ get();
   void set (    String^ value);
}
Remarks
This is only used in the context of XCA queries. The value will be set internally from the "home" property of incoming data. For outgoing data, it is easiest to set for all objects in the "passed through" data by using the XdsQueryResponse.SetHomeCommunityID method.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


LanguageCode Property

LanguageCode Property

XdsObjects Namespace > XdsDocument Class : LanguageCode Property
Specifies the human language of character data in the document.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property LanguageCode As String
Dim instance As XdsDocument
Dim value As String

instance.LanguageCode = value

value = instance.LanguageCode
public string LanguageCode {get; set;}
public:
property String^ LanguageCode {
   String^ get();
   void set (    String^ value);
}
Remarks

This property corresponds to the XDSDocumentEntry.languageCode Slot

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


LegalAuthenticator Property

LegalAuthenticator Property

XdsObjects Namespace > XdsDocument Class : LegalAuthenticator Property
Represents a participant who has legally authenticated or attested the document within the authorInstitution.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property LegalAuthenticator As String
Dim instance As XdsDocument
Dim value As String

instance.LegalAuthenticator = value

value = instance.LegalAuthenticator
public string LegalAuthenticator {get; set;}
public:
property String^ LegalAuthenticator {
   String^ get();
   void set (    String^ value);
}
Remarks

This property corresponds to the XDSDocumentEntry.legalAuthenticator Slot

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


LogicalId Property (XdsDocument)

LogicalId Property (XdsDocument)

XdsObjects Namespace > XdsDocument Class : LogicalId Property
To allow a collection of registry objects to be grouped together and be identified as versions of the same object, two new attributes are introduced: the Logical ID and the VersionInfo element. While all objects must have unique value for their id attribute to maintain their identity, all objects that are versions of the same logical object have the same logical id or lid attribute
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property LogicalId As String
Dim instance As XdsDocument
Dim value As String

instance.LogicalId = value

value = instance.LogicalId
public string LogicalId {get; set;}
public:
property String^ LogicalId {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


MimeType Property

MimeType Property

XdsObjects Namespace > XdsDocument Class : MimeType Property
MIME type of the document in the Repository.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property MimeType As String
Dim instance As XdsDocument
Dim value As String

instance.MimeType = value

value = instance.MimeType
public string MimeType {get; set;}
public:
property String^ MimeType {
   String^ get();
   void set (    String^ value);
}
Remarks

This property corresponds to the XDSDocumentEntry.mimeType attribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


PatientID Property (XdsDocument)

PatientID Property (XdsDocument)

XdsObjects Namespace > XdsDocument Class : PatientID Property
Shortcut to PatientInfo.XdsPerson.CompositeId
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property PatientID As String
Dim instance As XdsDocument
Dim value As String

instance.PatientID = value

value = instance.PatientID
public string PatientID {get; set;}
public:
property String^ PatientID {
   String^ get();
   void set (    String^ value);
}
Remarks
The main use for this property is to act as the primary key for applications using the CodeFirst Entity framework, but it is also available for more general use.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


PatientInfo Property (XdsDocument)

PatientInfo Property (XdsDocument)

XdsObjects Namespace > XdsDocument Class : PatientInfo Property
The subject of care of the document.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property PatientInfo As XdsPatient
Dim instance As XdsDocument
Dim value As XdsPatient

instance.PatientInfo = value

value = instance.PatientInfo
public XdsPatient PatientInfo {get; set;}
public:
property XdsPatient^ PatientInfo {
   XdsPatient^ get();
   void set (    XdsPatient^ value);
}
Remarks

This property corresponds to the XDSDocumentEntry.patientId ExternalIdentifier

Although a full XdsPatient is used, only the CompositeId is used internally. Where necessary, during submission, the ID is converted using PIX from the Source (local) domain to the domain used by the XDS affinity domain. See Automatic PIX Queries in XdsObjects for more details.

The composite ID is also accessible via the PatientID property, which is actually a shortcut to PatientInfo.XdsPerson.CompositeId

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


PracticeSettingCode Property

PracticeSettingCode Property

XdsObjects Namespace > XdsDocument Class : PracticeSettingCode Property
The code specifying the clinical specialty where the act that resulted in the document was performed
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property PracticeSettingCode As XdsCode
Dim instance As XdsDocument
Dim value As XdsCode

instance.PracticeSettingCode = value

value = instance.PracticeSettingCode
public XdsCode PracticeSettingCode {get; set;}
public:
property XdsCode^ PracticeSettingCode {
   XdsCode^ get();
   void set (    XdsCode^ value);
}
Remarks

This property corresponds to the XDSDocumentEntry.practiceSettingCode Classification

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


ReferenceIdList Property

ReferenceIdList Property

XdsObjects Namespace > XdsDocument Class : ReferenceIdList Property
Holds a list of additional Reference ID name/value pairs
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ReferenceIdList As XdsMultiString
Dim instance As XdsDocument
Dim value As XdsMultiString

instance.ReferenceIdList = value

value = instance.ReferenceIdList
public XdsMultiString ReferenceIdList {get; set;}
public:
property XdsMultiString^ ReferenceIdList {
   XdsMultiString^ get();
   void set (    XdsMultiString^ value);
}
Remarks

This property corresponds to the XDSDocumentEntry.referenceIdList Slot

The values include the value and the identification in a single string - e.g.:

2013001^^^&1.2.3.4.5.6&ISO^urn:ihe:iti:xds:2013:accession

This is a new option in XDS, and is not supported by all registries

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


RepositoryUniqueId Property (XdsDocument)

RepositoryUniqueId Property (XdsDocument)

XdsObjects Namespace > XdsDocument Class : RepositoryUniqueId Property
The globally unique identifier of the repository where the document is stored
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property RepositoryUniqueId As String
Dim instance As XdsDocument
Dim value As String

instance.RepositoryUniqueId = value

value = instance.RepositoryUniqueId
public string RepositoryUniqueId {get; set;}
public:
property String^ RepositoryUniqueId {
   String^ get();
   void set (    String^ value);
}
Remarks

This property corresponds to the XDSDocumentEntry.repositoryUniqueId Slot

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


ServiceStartTime Property

ServiceStartTime Property

XdsObjects Namespace > XdsDocument Class : ServiceStartTime Property
Represents the start time the service being documented took place
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ServiceStartTime As Date
Dim instance As XdsDocument
Dim value As Date

instance.ServiceStartTime = value

value = instance.ServiceStartTime
public DateTime ServiceStartTime {get; set;}
public:
property DateTime ServiceStartTime {
   DateTime get();
   void set (    DateTime value);
}
Remarks

This property corresponds to the XDSDocumentEntry.serviceStartTime Slot

Like all date/time fields in XDS, this is required to be specified in Universal time (GMT)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


ServiceStopTime Property

ServiceStopTime Property

XdsObjects Namespace > XdsDocument Class : ServiceStopTime Property
Represents the stop time the service being documented took place
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ServiceStopTime As Date
Dim instance As XdsDocument
Dim value As Date

instance.ServiceStopTime = value

value = instance.ServiceStopTime
public DateTime ServiceStopTime {get; set;}
public:
property DateTime ServiceStopTime {
   DateTime get();
   void set (    DateTime value);
}
Remarks

This property corresponds to the XDSDocumentEntry.serviceStopTime Slot

Like all date/time fields in XDS, this is required to be specified in Universal time (GMT)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


Size Property

Size Property

XdsObjects Namespace > XdsDocument Class : Size Property
Size of the XDS Document itself.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Size As Integer
Dim instance As XdsDocument
Dim value As Integer

instance.Size = value

value = instance.Size
public int Size {get; set;}
public:
property int Size {
   int get();
   void set (    int value);
}
Remarks

This property corresponds to the XDSDocumentEntry.size attribute

This value needs to to be set (possibly using the SetSizeAndHash method) by a repository, before submitting the neta data to the registry, but it does not need to be set by a Document Source prior to a ProvideAndRegister transaction

Note that this attribute is specially moddifed and handled differently when Multi-Part documents are written using XdsSubmissionSet.WriteXDM, since it (and Hash) have to be modified to relate only to the first part.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


SourcePatientDetails Property

SourcePatientDetails Property

XdsObjects Namespace > XdsDocument Class : SourcePatientDetails Property
The details of the subject of care as the Document Source knew them at the time of Submission.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property SourcePatientDetails As XdsPatient
Dim instance As XdsDocument
Dim value As XdsPatient

instance.SourcePatientDetails = value

value = instance.SourcePatientDetails
public XdsPatient SourcePatientDetails {get; set;}
public:
property XdsPatient^ SourcePatientDetails {
   XdsPatient^ get();
   void set (    XdsPatient^ value);
}
Remarks

This property corresponds to both the XDSDocumentEntry.sourcePatientId and sourcePatientInfo Slots

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


Title Property (XdsDocument)

Title Property (XdsDocument)

XdsObjects Namespace > XdsDocument Class : Title Property
Represents the title of the document
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Title As XdsInternationalString
Dim instance As XdsDocument
Dim value As XdsInternationalString

instance.Title = value

value = instance.Title
public XdsInternationalString Title {get; set;}
public:
property XdsInternationalString^ Title {
   XdsInternationalString^ get();
   void set (    XdsInternationalString^ value);
}
Remarks

This property corresponds to the XDSDocumentEntry.title Attribute, which actually uses the ebXML "Name" attribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


TypeCode Property

TypeCode Property

XdsObjects Namespace > XdsDocument Class : TypeCode Property
The code specifying the precise kind of document
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property TypeCode As XdsCode
Dim instance As XdsDocument
Dim value As XdsCode

instance.TypeCode = value

value = instance.TypeCode
public XdsCode TypeCode {get; set;}
public:
property XdsCode^ TypeCode {
   XdsCode^ get();
   void set (    XdsCode^ value);
}
Remarks

This property corresponds to the XDSDocumentEntry.typeCode Classification

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


UniqueID Property (XdsDocument)

UniqueID Property (XdsDocument)

XdsObjects Namespace > XdsDocument Class : UniqueID Property
The globally unique identifier assigned by the document creator to this document.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property UniqueID As String
Dim instance As XdsDocument
Dim value As String

instance.UniqueID = value

value = instance.UniqueID
public string UniqueID {get; set;}
public:
property String^ UniqueID {
   String^ get();
   void set (    String^ value);
}
Remarks

This property corresponds to the XDSDocumentEntry.uniqueId ExternalIdentifier

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


Uri Property

Uri Property

XdsObjects Namespace > XdsDocument Class : Uri Property
The URI from which the document could be retrieved.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Uri As String
Dim instance As XdsDocument
Dim value As String

instance.Uri = value

value = instance.Uri
public string Uri {get; set;}
public:
property String^ Uri {
   String^ get();
   void set (    String^ value);
}
Remarks

This property corresponds to the XDSDocumentEntry.URI slot

It is really obsolete in XDS.b, but it maintained for backwards compatibilty, and is also used in the XDM profile to hold the (relative) file path.

The string may be of any length - XdsObjcts handles the breaking up or reassembly of "short form" data if necessary.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


UUID Property (XdsDocument)

UUID Property (XdsDocument)

XdsObjects Namespace > XdsDocument Class : UUID Property
The globally unique identifier of the document
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property UUID As String
Dim instance As XdsDocument
Dim value As String

instance.UUID = value

value = instance.UUID
public string UUID {get; set;}
public:
property String^ UUID {
   String^ get();
   void set (    String^ value);
}
Remarks

This property corresponds to the XDSDocumentEntry.entryUUID attribute

This ID may be assigned by either by Source, Repository, or Registry

There is often confusion between this value and the UniqueID, and the Technical framework notes:

"The globally unique identifier (may be assigned by either by Source, Repository, or Registry) is primarily intended for use as a document registry management identifier. It is not meant to be an external reference for XDS Documents (e.g. in links within other documents). The uniqueId is meant for that purpose so that such links remain valid beyond the XDS Affinity Domain"

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


VersionInfo Property (XdsDocument)

VersionInfo Property (XdsDocument)

XdsObjects Namespace > XdsDocument Class : VersionInfo Property
To allow a collection of registry objects to be grouped together and be identified as versions of the same object, two new attributes are introduced: the Logical ID and the VersionInfo element. While all objects must have unique value for their id attribute to maintain their identity, all objects that are versions of the same logical object have the same logical id or lid attribute
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property VersionInfo As String
Dim instance As XdsDocument
Dim value As String

instance.VersionInfo = value

value = instance.VersionInfo
public string VersionInfo {get; set;}
public:
property String^ VersionInfo {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocument Class
XdsDocument Members


XdsDocumentViewer Class

XdsDocumentViewer Class
Members

XdsObjects Namespace : XdsDocumentViewer Class
A viewer for XDS Documents
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsDocumentViewer
   Inherits System.Windows.Forms.ScrollableControl
Dim instance As XdsDocumentViewer
public class XdsDocumentViewer : System.Windows.Forms.ScrollableControl
public ref class XdsDocumentViewer : public System.Windows.Forms.ScrollableControl
Remarks

This class allows documents of multiple different types to be displayed, with minimal work. The mime type of the document is used to determine how to disply it:

  • XML files are displayed using the stylesheet defined by StyleSheets
  • DICOM KOS objects are interpretted and displayed according to the configuration set up in the XdsImagingClient class
  • Other files (including plain text files) are displayed "as is" in a web browser control
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
XdsObjects.XdsDocumentViewer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocumentViewer Members
XdsObjects Namespace


XdsDocumentViewer Class Members

XdsDocumentViewer Class Members
Properties Methods Events

XdsObjects Namespace : XdsDocumentViewer Class

The following tables list the members exposed by XdsDocumentViewer.

Public Constructors
 | Name | Description
Public Constructor | XdsDocumentViewer Constructor | Constructs a new XdsDocumentViewer control
Top
Public Properties
 | Name | Description
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | ImagingClient | XdsImagingClientobject used to handle automatic retrieval of DICOM images for display when DICOM KOS objects are added to the viewer.
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | StyleSheets | A set of StyleSheets to use when displaying documents.
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Top
Protected Properties
 | Name | Description
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.Control)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DoubleBuffered | (Inherited from System.Windows.Forms.Control)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | HScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | ImeModeBase | (Inherited from System.Windows.Forms.Control)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from System.Windows.Forms.Control)
Protected Property | VScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Top
Public Methods
 | Name | Description
Public Method | AddImage | Adds a DICOM dataset (representing an image) to the viewer.
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Clear | Clear all documents from the display
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Display | Overloaded. Display an XDS Document in the viewer
Public Method | Dispose | Overloaded. Overridden. Clean up any resources being used.
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Top
Protected Methods
 | Name | Description
Protected Method | AdjustFormScrollbars | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | CreateAccessibilityInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Control)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | InitLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputKey | (Inherited from System.Windows.Forms.Control)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyPress | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLayout | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLocationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseHover | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnPaint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRightToLeftChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabIndexChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidating | (Inherited from System.Windows.Forms.Control)
Protected Method | OnVisibleChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ProcessCmdKey | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessDialogKey | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ScrollToControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetDisplayRectLocation | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WndProc | (Inherited from System.Windows.Forms.ScrollableControl)
Top
Public Events
 | Name | Description
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

XdsDocumentViewer Class
XdsObjects Namespace


XdsDocumentViewer Constructor

XdsDocumentViewer Constructor

XdsObjects Namespace > XdsDocumentViewer Class : XdsDocumentViewer Constructor
Constructs a new XdsDocumentViewer control
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsDocumentViewer()
public XdsDocumentViewer()
public:
XdsDocumentViewer();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocumentViewer Class
XdsDocumentViewer Members


XdsDocumentViewer Class Methods

XdsDocumentViewer Class Methods

XdsObjects Namespace : XdsDocumentViewer Class

For a list of all members of this type, see XdsDocumentViewer members.

Public Methods
 | Name | Description
Public Method | AddImage | Adds a DICOM dataset (representing an image) to the viewer.
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Clear | Clear all documents from the display
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Display | Overloaded. Display an XDS Document in the viewer
Public Method | Dispose | Overloaded. Overridden. Clean up any resources being used.
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Top
Protected Methods
 | Name | Description
Protected Method | AdjustFormScrollbars | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | CreateAccessibilityInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Control)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | InitLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputKey | (Inherited from System.Windows.Forms.Control)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyPress | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLayout | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLocationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseHover | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnPaint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRightToLeftChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabIndexChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidating | (Inherited from System.Windows.Forms.Control)
Protected Method | OnVisibleChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ProcessCmdKey | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessDialogKey | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ScrollToControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetDisplayRectLocation | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WndProc | (Inherited from System.Windows.Forms.ScrollableControl)
Top
See Also

Reference

XdsDocumentViewer Class
XdsObjects Namespace


AddImage Method

AddImage Method
Example

XdsObjects Namespace > XdsDocumentViewer Class : AddImage Method
The image to add
Adds a DICOM dataset (representing an image) to the viewer.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub AddImage( _
   ByVal DataSet As DicomObjects.DicomDataSet _
)
Dim instance As XdsDocumentViewer
Dim DataSet As DicomObjects.DicomDataSet

instance.AddImage(DataSet)
public void AddImage(
   DicomObjects.DicomDataSet DataSet
)
public:
void AddImage(
   DicomObjects.DicomDataSet^ DataSet
)

Parameters

DataSet
The image to add
Remarks
This method is used by client applications which are retrieving images using the DICOM C-MOVE protocl rather than WADO or Rad-69. If an image source referenced within a KOS object has been identified as using C-MOVE then the viewer will issue a C-MOVE request, but the application must then be prepared to receive the C-STORE repsonses and add them to the viewer using this method.
Example
  • C#
server.Listen(LocalPortNumber);
            server.InstanceReceived += new DicomServer.InstanceReceivedHandler(server_InstanceReceived);
            Viewer.Display(KosObject);
            void server_InstanceReceived(object sender, DicomServer.InstanceReceivedArgs e)
            {
                MessageBox.Show(e.Instance.Name);
                Viewer.AddImage(e.Instance);
                e.Status = 0;
            }
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocumentViewer Class
XdsDocumentViewer Members


Clear Method

Clear Method

XdsObjects Namespace > XdsDocumentViewer Class : Clear Method
Clear all documents from the display
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub Clear()
Dim instance As XdsDocumentViewer

instance.Clear()
public void Clear()
public:
void Clear();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocumentViewer Class
XdsDocumentViewer Members


Display Method

Display Method

XdsObjects Namespace > XdsDocumentViewer Class : Display Method
Display an XDS Document in the viewer
Overload List
Overload | Description
Display(XdsDocument) | Display an XdsDocument in the viewer
Display(Byte[],String,String) | Display a document with a defined MimeType and StyleSheet
Display(String) | Read and display a file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocumentViewer Class
XdsDocumentViewer Members


Display(XdsDocument) Method

Display(XdsDocument) Method

XdsObjects Namespace > XdsDocumentViewer Class > Display Method : Display(XdsDocument) Method
The document to display
Display an XdsDocument in the viewer
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overloads Sub Display( _
   ByVal doc As XdsDocument _
)
Dim instance As XdsDocumentViewer
Dim doc As XdsDocument

instance.Display(doc)
public void Display(
   XdsDocument doc
)
public:
void Display(
   XdsDocument^ doc
)

Parameters

doc
The document to display
Remarks
If the document is any form of Xml (if the MimeType is text/xml", then a stylesheet will be applied, from the StyleSheets collection, according to the value of the FormatType
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocumentViewer Class
XdsDocumentViewer Members
Overload List


Display(Byte[],String,String) Method

Display(Byte[],String,String) Method

XdsObjects Namespace > XdsDocumentViewer Class > Display Method : Display(Byte[],String,String) Method
The document as a byte array
The MimeType of the document
The styleSheet to use (if needed)
Display a document with a defined MimeType and StyleSheet
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overloads Sub Display( _
   ByVal Data() As Byte, _
   ByVal MimeType As String, _
   ByVal StyleSheet As String _
)
Dim instance As XdsDocumentViewer
Dim Data() As Byte
Dim MimeType As String
Dim StyleSheet As String

instance.Display(Data, MimeType, StyleSheet)
public void Display(
   byte[] Data,
   string MimeType,
   string StyleSheet
)
public:
void Display(
   array<byte>^ Data,
   String^ MimeType,
   String^ StyleSheet
)

Parameters

Data
The document as a byte array
MimeType
The MimeType of the document
StyleSheet
The styleSheet to use (if needed)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocumentViewer Class
XdsDocumentViewer Members
Overload List


Display(String) Method

Display(String) Method

XdsObjects Namespace > XdsDocumentViewer Class > Display Method : Display(String) Method
The name of the file to read
Read and display a file.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overloads Sub Display( _
   ByVal FileName As String _
)
Dim instance As XdsDocumentViewer
Dim FileName As String

instance.Display(FileName)
public void Display(
   string FileName
)
public:
void Display(
   String^ FileName
)

Parameters

FileName
The name of the file to read
Remarks
The MimeType of the content is determined automatically from the filename extension
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocumentViewer Class
XdsDocumentViewer Members
Overload List


Dispose Method (XdsDocumentViewer)

Dispose Method (XdsDocumentViewer)

XdsObjects Namespace > XdsDocumentViewer Class : Dispose Method
Clean up any resources being used.
Overload List
Overload | Description
Dispose(Boolean) | Clean up any resources being used.
Dispose() | (Inherited from System.ComponentModel.Component)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocumentViewer Class
XdsDocumentViewer Members
Base Implementation in Dispose


Dispose(Boolean) Method

Dispose(Boolean) Method

XdsObjects Namespace > XdsDocumentViewer Class > Dispose Method : Dispose(Boolean) Method
true if managed resources should be disposed; otherwise, false.
Clean up any resources being used.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
Dim instance As XdsDocumentViewer
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing
true if managed resources should be disposed; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocumentViewer Class
XdsDocumentViewer Members
Overload List
Base Implementation in Dispose(Boolean)


XdsDocumentViewer Class Properties

XdsDocumentViewer Class Properties

XdsObjects Namespace : XdsDocumentViewer Class

For a list of all members of this type, see XdsDocumentViewer members.

Public Properties
 | Name | Description
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | ImagingClient | XdsImagingClientobject used to handle automatic retrieval of DICOM images for display when DICOM KOS objects are added to the viewer.
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | StyleSheets | A set of StyleSheets to use when displaying documents.
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Top
Protected Properties
 | Name | Description
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.Control)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DoubleBuffered | (Inherited from System.Windows.Forms.Control)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | HScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | ImeModeBase | (Inherited from System.Windows.Forms.Control)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from System.Windows.Forms.Control)
Protected Property | VScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Top
See Also

Reference

XdsDocumentViewer Class
XdsObjects Namespace


ImagingClient Property

ImagingClient Property

XdsObjects Namespace > XdsDocumentViewer Class : ImagingClient Property
XdsImagingClientobject used to handle automatic retrieval of DICOM images for display when DICOM KOS objects are added to the viewer.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property ImagingClient As XdsImagingClient
Dim instance As XdsDocumentViewer
Dim value As XdsImagingClient

instance.ImagingClient = value

value = instance.ImagingClient
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public XdsImagingClient ImagingClient {get; set;}
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public:
property XdsImagingClient^ ImagingClient {
   XdsImagingClient^ get();
   void set (    XdsImagingClient^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocumentViewer Class
XdsDocumentViewer Members


StyleSheets Property

StyleSheets Property

XdsObjects Namespace > XdsDocumentViewer Class : StyleSheets Property
A set of StyleSheets to use when displaying documents.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property StyleSheets As Dictionary(Of String,String)
Dim instance As XdsDocumentViewer
Dim value As Dictionary(Of String,String)

instance.StyleSheets = value

value = instance.StyleSheets
public Dictionary<string,string> StyleSheets {get; set;}
public:
property Dictionary<String^,String^>^ StyleSheets {
   Dictionary<String^,String^>^ get();
   void set (    Dictionary<String^,String^>^ value);
}
Remarks

Many different types of document in XDS have the MimeType of "text/xml", but may be of very different form, and need different styesheets for appropriate human-readable display. This collection therefore provides a means to identify the required stylesheet filename (the value in the collection) from the FormatCode (the key for the collection)

Note that the values are filenames of the stylesheets, rather than the actual stylesheet content

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDocumentViewer Class
XdsDocumentViewer Members


XdsDomain Class

XdsDomain Class
Members

XdsObjects Namespace : XdsDomain Class
This class hold all the information required for an XDS domain to operate
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsDomain
Dim instance As XdsDomain
public class XdsDomain
public ref class XdsDomain
Remarks

This important object includes:

  • The Local Registry to use for queries as consumer
  • The Repository to submit data to as a source
  • The list of repositories (indexed by their OIDs in the RepositoryAddresses collection to retrive data from
  • The Audit Repositories to send audit messages to
  • Information needed for Patient ID lookups
    • The PIX Manager to use
    • The Domain ID Root to translate IDs to
  • The Gateway to use in an XCA environment (queries are sent to the RegistryEndpoint, just as if it were a local registry.
  • Other miscelaneous data such as the identifiers for the system to be used in audit messages

It also includes the methods needed to excute all the high level XDS transactions such as:

  • Submitting data to a repository
  • Querying a registry or gateway
  • Retrieving from a repository or gateway
Inheritance Hierarchy

System.Object
XdsObjects.XdsDomain

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Members
XdsObjects Namespace


XdsDomain Class Members

XdsDomain Class Members
Properties Methods

XdsObjects Namespace : XdsDomain Class

The following tables list the members exposed by XdsDomain.

Public Constructors
 | Name | Description
Public Constructor | XdsDomain Constructor | Creates a new XdsDomain object
Top
Public Properties
 | Name | Description
Public Property | AuditEnterpriseSiteID | The Audit Enterprise Site ID to include in audit messages
Public Property | AuditRepositories | The address of the Auditrepositories to use for logging.
Public Property | AuditSchema | The schema to use for ATNA messages.
Public Property | AuditSourceAddress | The source address reported to the audit repository
Public Property | AuditSourceID | The Audit Source ID to include in audit messages
Public Property | AuditSourceTypeCode | The Audit Source Type Code to include in audit messages
Public Property | CreatePullPointRecipientEndpoint | CreatePullPoint Receipient's Address
Public Property | DestroyPullPointRecipientEndpoint | DestroyPullPoint Receipient's Address
Public Property | NotificationRecipientEndpoint | The Notification Receipient's Address
Public Property | PixManager | The endpoint details for the PIX Manager to use for translation of patient IDs between different domains
Public Property | RegistryEndpoint | The registry used in this domain.
Public Property | RepositoryAddresses | Holds the lookup table for mapping a Repository UniqueID to an EndPoint address
Public Property | RetrieveGateway | This is used automatically when the data to be retrieved contains a HomeCommunityID value
Public Property | StructureIncomingSubmissionSet | Controls the behaviour used when incoming data is received.
Public Property | SubmissionRepositoryEndpoint | The Respository to which submissions should be sent
Public Property | SubscriptionBrokerEndpoint | The Subscription Broker's Address
Public Property | TreatErrorsAsExceptions | Controls whether error codes received via XDS protocols cause excpetions to be thrown.
Public Property | ValidateOnSending | Controls whether to validate data being sent
Public Property | ValidateServerCertificate | Callback routine used to validate remote certificates
Public Property | XdsDomainRoot | The ID Root used by the XDS Domain.
Top
Public Methods
 | Name | Description
Public Method | CreatePullPoint | Request CreatePullPoint
Public Method | CrossGatewayQuery | Send a query to a responding gateway
Public Method | CrossGatewayRetrieve | Retrieve set of documents from a responding gateway
Public Method | DeleteDocumentSet | Delete objects specified by its IDs
Public Method | Notify | Send Notification
Public Method | ProvideAndRegisterDocumentSet | Submit an XdsSubmissionSet to a repository using the ProvideAndRegisterDocumentSet-b transaction
Public Method | RegisterDocumentSet | Submit an XdsSubmissionSet to a registry using the RegisterDocumentSet-b transaction
Public Method | RegistryStoredQuery | Send a query to a registry (or equivalently to an initiating gateway)
Public Method | RetrieveDocumentSet | Retrieve set of documents from repositories
Public Method | Subscribe | Request Subscription
Public Method | UnSubscribe | Request Unsubscription
Public Method | UpdateDocumentSet | Submit metadata updates to a Registry using the Update Document Set transaction
Top
See Also

Reference

XdsDomain Class
XdsObjects Namespace


XdsDomain Constructor

XdsDomain Constructor

XdsObjects Namespace > XdsDomain Class : XdsDomain Constructor
Creates a new XdsDomain object
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsDomain()
public XdsDomain()
public:
XdsDomain();
Remarks
All values are initialised to null or to empty lists - there are no "default" values for an XdsDomain.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


XdsDomain Class Methods

XdsDomain Class Methods

XdsObjects Namespace : XdsDomain Class

For a list of all members of this type, see XdsDomain members.

Public Methods
 | Name | Description
Public Method | CreatePullPoint | Request CreatePullPoint
Public Method | CrossGatewayQuery | Send a query to a responding gateway
Public Method | CrossGatewayRetrieve | Retrieve set of documents from a responding gateway
Public Method | DeleteDocumentSet | Delete objects specified by its IDs
Public Method | Notify | Send Notification
Public Method | ProvideAndRegisterDocumentSet | Submit an XdsSubmissionSet to a repository using the ProvideAndRegisterDocumentSet-b transaction
Public Method | RegisterDocumentSet | Submit an XdsSubmissionSet to a registry using the RegisterDocumentSet-b transaction
Public Method | RegistryStoredQuery | Send a query to a registry (or equivalently to an initiating gateway)
Public Method | RetrieveDocumentSet | Retrieve set of documents from repositories
Public Method | Subscribe | Request Subscription
Public Method | UnSubscribe | Request Unsubscription
Public Method | UpdateDocumentSet | Submit metadata updates to a Registry using the Update Document Set transaction
Top
See Also

Reference

XdsDomain Class
XdsObjects Namespace


CreatePullPoint Method

CreatePullPoint Method

XdsObjects Namespace > XdsDomain Class : CreatePullPoint Method
Request CreatePullPoint
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function CreatePullPoint( _
   ByVal Request As XdsCreatePullPointRequest _
) As XdsCreatePullPointResponse
Dim instance As XdsDomain
Dim Request As XdsCreatePullPointRequest
Dim value As XdsCreatePullPointResponse

value = instance.CreatePullPoint(Request)
public XdsCreatePullPointResponse CreatePullPoint(
   XdsCreatePullPointRequest Request
)
public:
XdsCreatePullPointResponse^ CreatePullPoint(
   XdsCreatePullPointRequest^ Request
)

Parameters

Request
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


CrossGatewayQuery Method

CrossGatewayQuery Method

XdsObjects Namespace > XdsDomain Class : CrossGatewayQuery Method
the query being sent
Send a query to a responding gateway
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function CrossGatewayQuery( _
   ByVal query As XdsQueryRequest _
) As XdsQueryResponse
Dim instance As XdsDomain
Dim query As XdsQueryRequest
Dim value As XdsQueryResponse

value = instance.CrossGatewayQuery(query)
public XdsQueryResponse CrossGatewayQuery(
   XdsQueryRequest query
)
public:
XdsQueryResponse^ CrossGatewayQuery(
   XdsQueryRequest^ query
)

Parameters

query
the query being sent

Return Value

the results of the query
Remarks

This method would be used by an initiating gateway. Note that the request is sent to the defined RegistryEndpoint rather than there being an independent property to hold the responding details. The rationale for this is that many more details (domain ID root and possibly auditing) are likely to be different for the responding gateway compared to the local domain, so an initiating gateway using this method should set up a separate XdsDomain for each responding gateway it communicates with.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


CrossGatewayRetrieve Method

CrossGatewayRetrieve Method

XdsObjects Namespace > XdsDomain Class : CrossGatewayRetrieve Method
Details of the objects to retrieve
Retrieve set of documents from a responding gateway
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function CrossGatewayRetrieve( _
   ByVal Retrieve As XdsRetrieveRequest _
) As XdsRetrieveResponse
Dim instance As XdsDomain
Dim Retrieve As XdsRetrieveRequest
Dim value As XdsRetrieveResponse

value = instance.CrossGatewayRetrieve(Retrieve)
public XdsRetrieveResponse CrossGatewayRetrieve(
   XdsRetrieveRequest Retrieve
)
public:
XdsRetrieveResponse^ CrossGatewayRetrieve(
   XdsRetrieveRequest^ Retrieve
)

Parameters

Retrieve
Details of the objects to retrieve

Return Value

The requested objects and/or error information
Remarks

This method would be used by an initiating gateway. Note that the request is sent to the defined RetrieveGateway rather than there being an independent property to hold the responding details and HomeCumminityIDs. The rationale for this is that many more details (domain ID root and possibly auditing) are likely to be different for the responding gateway compared to the local domain, so an initiating gateway using this method should set up a separate XdsDomain for each responding gateway it communicates with.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


DeleteDocumentSet Method

DeleteDocumentSet Method

XdsObjects Namespace > XdsDomain Class : DeleteDocumentSet Method
which contains list of IDs of objects to be deleted
Delete objects specified by its IDs
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function DeleteDocumentSet( _
   ByVal request As XdsDeleteDocumentSetRequest _
) As XdsRegistryResponse
Dim instance As XdsDomain
Dim request As XdsDeleteDocumentSetRequest
Dim value As XdsRegistryResponse

value = instance.DeleteDocumentSet(request)
public XdsRegistryResponse DeleteDocumentSet(
   XdsDeleteDocumentSetRequest request
)
public:
XdsRegistryResponse^ DeleteDocumentSet(
   XdsDeleteDocumentSetRequest^ request
)

Parameters

request
which contains list of IDs of objects to be deleted

Return Value

Standard indicating the status of the transaction
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


Notify Method

Notify Method

XdsObjects Namespace > XdsDomain Class : Notify Method
The XdsNotifyRequest
Send Notification
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub Notify( _
   ByVal Request As XdsNotifyRequest _
)
Dim instance As XdsDomain
Dim Request As XdsNotifyRequest

instance.Notify(Request)
public void Notify(
   XdsNotifyRequest Request
)
public:
void Notify(
   XdsNotifyRequest^ Request
)

Parameters

Request
The XdsNotifyRequest
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


ProvideAndRegisterDocumentSet Method

ProvideAndRegisterDocumentSet Method

XdsObjects Namespace > XdsDomain Class : ProvideAndRegisterDocumentSet Method
The Submission Set to send
Submit an XdsSubmissionSet to a repository using the ProvideAndRegisterDocumentSet-b transaction
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function ProvideAndRegisterDocumentSet( _
   ByVal SubmissionSet As XdsSubmissionSet _
) As XdsRegistryResponse
Dim instance As XdsDomain
Dim SubmissionSet As XdsSubmissionSet
Dim value As XdsRegistryResponse

value = instance.ProvideAndRegisterDocumentSet(SubmissionSet)
public XdsRegistryResponse ProvideAndRegisterDocumentSet(
   XdsSubmissionSet SubmissionSet
)
public:
XdsRegistryResponse^ ProvideAndRegisterDocumentSet(
   XdsSubmissionSet^ SubmissionSet
)

Parameters

SubmissionSet
The Submission Set to send

Return Value

Standard response, indicating success/failure and/or any errors
Remarks

This is the primary method used by a Document Source

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


RegisterDocumentSet Method

RegisterDocumentSet Method

XdsObjects Namespace > XdsDomain Class : RegisterDocumentSet Method
The Submission Set to send
Submit an XdsSubmissionSet to a registry using the RegisterDocumentSet-b transaction
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function RegisterDocumentSet( _
   ByVal SubmissionSet As XdsSubmissionSet _
) As XdsRegistryResponse
Dim instance As XdsDomain
Dim SubmissionSet As XdsSubmissionSet
Dim value As XdsRegistryResponse

value = instance.RegisterDocumentSet(SubmissionSet)
public XdsRegistryResponse RegisterDocumentSet(
   XdsSubmissionSet SubmissionSet
)
public:
XdsRegistryResponse^ RegisterDocumentSet(
   XdsSubmissionSet^ SubmissionSet
)

Parameters

SubmissionSet
The Submission Set to send

Return Value

Standard response, indicating success/failure and/or any errors
Remarks

This is used typically by a Repository or a combined Source/Repository.

When used by a repository, the received data may be passed on after the SetHashAndSize has been called and optionally, the UUID has been set.

There is no need to remove the Documents from the SubmissionSet before calling this method, as they will not be sent even if present.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


RegistryStoredQuery Method (XdsDomain)

RegistryStoredQuery Method (XdsDomain)

XdsObjects Namespace > XdsDomain Class : RegistryStoredQuery Method
the query being sent
Send a query to a registry (or equivalently to an initiating gateway)
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function RegistryStoredQuery( _
   ByVal query As XdsQueryRequest _
) As XdsQueryResponse
Dim instance As XdsDomain
Dim query As XdsQueryRequest
Dim value As XdsQueryResponse

value = instance.RegistryStoredQuery(query)
public XdsQueryResponse RegistryStoredQuery(
   XdsQueryRequest query
)
public:
XdsQueryResponse^ RegistryStoredQuery(
   XdsQueryRequest^ query
)

Parameters

query
the query being sent

Return Value

the results of the query
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


RetrieveDocumentSet Method (XdsDomain)

RetrieveDocumentSet Method (XdsDomain)

XdsObjects Namespace > XdsDomain Class : RetrieveDocumentSet Method
Details of the objects to retrieve
The details of the patient to whom the documents are related. This is only used for auditing, as the documents themselves are reference by their unique IDs.
Retrieve set of documents from repositories
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function RetrieveDocumentSet( _
   ByVal Retrieve As XdsRetrieveRequest, _
   ByVal Patient As XdsPatient _
) As XdsRetrieveResponse
Dim instance As XdsDomain
Dim Retrieve As XdsRetrieveRequest
Dim Patient As XdsPatient
Dim value As XdsRetrieveResponse

value = instance.RetrieveDocumentSet(Retrieve, Patient)
public XdsRetrieveResponse RetrieveDocumentSet(
   XdsRetrieveRequest Retrieve,
   XdsPatient Patient
)
public:
XdsRetrieveResponse^ RetrieveDocumentSet(
   XdsRetrieveRequest^ Retrieve,
   XdsPatient^ Patient
)

Parameters

Retrieve
Details of the objects to retrieve
Patient
The details of the patient to whom the documents are related. This is only used for auditing, as the documents themselves are reference by their unique IDs.

Return Value

The requested objects and/or error information
Remarks

For now, all documents must be found in the same repository (i.e. have the same RepositoryUID), but this will change in future versions.

The identity and details (including security information) of the repository to use is looked up internally from the RepositoryAddresses

Documents which contain a HomeCommunityID are retrieved from the RetrieveGateway

collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


Subscribe Method

Subscribe Method

XdsObjects Namespace > XdsDomain Class : Subscribe Method
The Subsription request with Query Parameters
Request Subscription
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function Subscribe( _
   ByVal Request As XdsSubscriptionRequest _
) As XdsSubscriptionResponse
Dim instance As XdsDomain
Dim Request As XdsSubscriptionRequest
Dim value As XdsSubscriptionResponse

value = instance.Subscribe(Request)
public XdsSubscriptionResponse Subscribe(
   XdsSubscriptionRequest Request
)
public:
XdsSubscriptionResponse^ Subscribe(
   XdsSubscriptionRequest^ Request
)

Parameters

Request
The Subsription request with Query Parameters

Return Value

XdsSubscriptionResponse which carries a SubscriptionId
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


UnSubscribe Method

UnSubscribe Method

XdsObjects Namespace > XdsDomain Class : UnSubscribe Method
The Unsubscription Request with the SubscriptionId
Request Unsubscription
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function UnSubscribe( _
   ByVal Request As XdsUnsubscriptionRequest _
) As XdsUnsubscriptionResponse
Dim instance As XdsDomain
Dim Request As XdsUnsubscriptionRequest
Dim value As XdsUnsubscriptionResponse

value = instance.UnSubscribe(Request)
public XdsUnsubscriptionResponse UnSubscribe(
   XdsUnsubscriptionRequest Request
)
public:
XdsUnsubscriptionResponse^ UnSubscribe(
   XdsUnsubscriptionRequest^ Request
)

Parameters

Request
The Unsubscription Request with the SubscriptionId

Return Value

Returns the XdsUnsubscriptionResponse
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


UpdateDocumentSet Method

UpdateDocumentSet Method

XdsObjects Namespace > XdsDomain Class : UpdateDocumentSet Method
The XdsSubmissionSet"/>SubmissionSet object that organizes the content of the update
Submit metadata updates to a Registry using the Update Document Set transaction
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function UpdateDocumentSet( _
   ByVal SubmissionSet As XdsSubmissionSet _
) As XdsRegistryResponse
Dim instance As XdsDomain
Dim SubmissionSet As XdsSubmissionSet
Dim value As XdsRegistryResponse

value = instance.UpdateDocumentSet(SubmissionSet)
public XdsRegistryResponse UpdateDocumentSet(
   XdsSubmissionSet SubmissionSet
)
public:
XdsRegistryResponse^ UpdateDocumentSet(
   XdsSubmissionSet^ SubmissionSet
)

Parameters

SubmissionSet
The XdsSubmissionSet"/>SubmissionSet object that organizes the content of the update

Return Value

Standard response, indicating success/failure and/or any errors
Remarks

Key objects in the submission are attached to the SubmissionSet object via HasMember Associations

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


XdsDomain Class Properties

XdsDomain Class Properties

XdsObjects Namespace : XdsDomain Class

For a list of all members of this type, see XdsDomain members.

Public Properties
 | Name | Description
Public Property | AuditEnterpriseSiteID | The Audit Enterprise Site ID to include in audit messages
Public Property | AuditRepositories | The address of the Auditrepositories to use for logging.
Public Property | AuditSchema | The schema to use for ATNA messages.
Public Property | AuditSourceAddress | The source address reported to the audit repository
Public Property | AuditSourceID | The Audit Source ID to include in audit messages
Public Property | AuditSourceTypeCode | The Audit Source Type Code to include in audit messages
Public Property | CreatePullPointRecipientEndpoint | CreatePullPoint Receipient's Address
Public Property | DestroyPullPointRecipientEndpoint | DestroyPullPoint Receipient's Address
Public Property | NotificationRecipientEndpoint | The Notification Receipient's Address
Public Property | PixManager | The endpoint details for the PIX Manager to use for translation of patient IDs between different domains
Public Property | RegistryEndpoint | The registry used in this domain.
Public Property | RepositoryAddresses | Holds the lookup table for mapping a Repository UniqueID to an EndPoint address
Public Property | RetrieveGateway | This is used automatically when the data to be retrieved contains a HomeCommunityID value
Public Property | StructureIncomingSubmissionSet | Controls the behaviour used when incoming data is received.
Public Property | SubmissionRepositoryEndpoint | The Respository to which submissions should be sent
Public Property | SubscriptionBrokerEndpoint | The Subscription Broker's Address
Public Property | TreatErrorsAsExceptions | Controls whether error codes received via XDS protocols cause excpetions to be thrown.
Public Property | ValidateOnSending | Controls whether to validate data being sent
Public Property | ValidateServerCertificate | Callback routine used to validate remote certificates
Public Property | XdsDomainRoot | The ID Root used by the XDS Domain.
Top
See Also

Reference

XdsDomain Class
XdsObjects Namespace


AuditEnterpriseSiteID Property

AuditEnterpriseSiteID Property

XdsObjects Namespace > XdsDomain Class : AuditEnterpriseSiteID Property
The Audit Enterprise Site ID to include in audit messages
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property AuditEnterpriseSiteID As String
Dim instance As XdsDomain
Dim value As String

instance.AuditEnterpriseSiteID = value

value = instance.AuditEnterpriseSiteID
public string AuditEnterpriseSiteID {get; set;}
public:
property String^ AuditEnterpriseSiteID {
   String^ get();
   void set (    String^ value);
}
Remarks

RFC 3881 defines this as "Logical source location within the healthcare enterprise network, e.g., a hospital or other provider location within a multi-entity provider group."

It may be null when the audit-generating application is uniquely identified by Audit Source ID. It differentiates among the sites in a multi-site enterprise health information system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


AuditRepositories Property

AuditRepositories Property

XdsObjects Namespace > XdsDomain Class : AuditRepositories Property
The address of the Auditrepositories to use for logging.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property AuditRepositories As List(Of AuditEndpoint)
Dim instance As XdsDomain
Dim value As List(Of AuditEndpoint)

instance.AuditRepositories = value

value = instance.AuditRepositories
public List<AuditEndpoint> AuditRepositories {get; set;}
public:
property List<AuditEndpoint^>^ AuditRepositories {
   List<AuditEndpoint^>^ get();
   void set (    List<AuditEndpoint^>^ value);
}
Remarks
All audit message will be sent to each of the audit repositories in this list
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


AuditSchema Property

AuditSchema Property

XdsObjects Namespace > XdsDomain Class : AuditSchema Property
The schema to use for ATNA messages.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property AuditSchema As XdsDomain.AuditSchemaType
Dim instance As XdsDomain
Dim value As XdsDomain.AuditSchemaType

instance.AuditSchema = value

value = instance.AuditSchema
public XdsDomain.AuditSchemaType AuditSchema {get; set;}
public:
property XdsDomain.AuditSchemaType AuditSchema {
   XdsDomain.AuditSchemaType get();
   void set (    XdsDomain.AuditSchemaType value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


AuditSourceAddress Property

AuditSourceAddress Property

XdsObjects Namespace > XdsDomain Class : AuditSourceAddress Property
The source address reported to the audit repository
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property AuditSourceAddress As String
Dim instance As XdsDomain
Dim value As String

instance.AuditSourceAddress = value

value = instance.AuditSourceAddress
public string AuditSourceAddress {get; set;}
public:
property String^ AuditSourceAddress {
   String^ get();
   void set (    String^ value);
}
Remarks
This is the value used in the RFC 5424 header as the "HOSTNAME", and in most cases, this should be the fully qualified domain name of the machine sending audit messages. In some cases however (e.g. for testing when passing through NAT proxies) it may be necessary to use the externally visible address of the proxy.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


AuditSourceID Property

AuditSourceID Property

XdsObjects Namespace > XdsDomain Class : AuditSourceID Property
The Audit Source ID to include in audit messages
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property AuditSourceID As String
Dim instance As XdsDomain
Dim value As String

instance.AuditSourceID = value

value = instance.AuditSourceID
public string AuditSourceID {get; set;}
public:
property String^ AuditSourceID {
   String^ get();
   void set (    String^ value);
}
Remarks

RFC 3881 defines this as "Identifier of the source where the event originated."

It should be unique, at least within the Audit Enterprise Site ID. It ties the event to a specific source system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


AuditSourceTypeCode Property

AuditSourceTypeCode Property

XdsObjects Namespace > XdsDomain Class : AuditSourceTypeCode Property
The Audit Source Type Code to include in audit messages
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property AuditSourceTypeCode As AuditSourceTypeCode
Dim instance As XdsDomain
Dim value As AuditSourceTypeCode

instance.AuditSourceTypeCode = value

value = instance.AuditSourceTypeCode
public AuditSourceTypeCode AuditSourceTypeCode {get; set;}
public:
property AuditSourceTypeCode AuditSourceTypeCode {
   AuditSourceTypeCode get();
   void set (    AuditSourceTypeCode value);
}
Remarks

RFC 3881 defines this as "Code specifying the type of source where event originated"

It should be unique, at least within the Audit Enterprise Site ID. It ties the event to a specific source system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


CreatePullPointRecipientEndpoint Property

CreatePullPointRecipientEndpoint Property

XdsObjects Namespace > XdsDomain Class : CreatePullPointRecipientEndpoint Property
CreatePullPoint Receipient's Address
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property CreatePullPointRecipientEndpoint As WebServiceEndpoint
Dim instance As XdsDomain
Dim value As WebServiceEndpoint

instance.CreatePullPointRecipientEndpoint = value

value = instance.CreatePullPointRecipientEndpoint
public WebServiceEndpoint CreatePullPointRecipientEndpoint {get; set;}
public:
property WebServiceEndpoint^ CreatePullPointRecipientEndpoint {
   WebServiceEndpoint^ get();
   void set (    WebServiceEndpoint^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


DestroyPullPointRecipientEndpoint Property

DestroyPullPointRecipientEndpoint Property

XdsObjects Namespace > XdsDomain Class : DestroyPullPointRecipientEndpoint Property
DestroyPullPoint Receipient's Address
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DestroyPullPointRecipientEndpoint As WebServiceEndpoint
Dim instance As XdsDomain
Dim value As WebServiceEndpoint

instance.DestroyPullPointRecipientEndpoint = value

value = instance.DestroyPullPointRecipientEndpoint
public WebServiceEndpoint DestroyPullPointRecipientEndpoint {get; set;}
public:
property WebServiceEndpoint^ DestroyPullPointRecipientEndpoint {
   WebServiceEndpoint^ get();
   void set (    WebServiceEndpoint^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


NotificationRecipientEndpoint Property

NotificationRecipientEndpoint Property

XdsObjects Namespace > XdsDomain Class : NotificationRecipientEndpoint Property
The Notification Receipient's Address
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property NotificationRecipientEndpoint As WebServiceEndpoint
Dim instance As XdsDomain
Dim value As WebServiceEndpoint

instance.NotificationRecipientEndpoint = value

value = instance.NotificationRecipientEndpoint
public WebServiceEndpoint NotificationRecipientEndpoint {get; set;}
public:
property WebServiceEndpoint^ NotificationRecipientEndpoint {
   WebServiceEndpoint^ get();
   void set (    WebServiceEndpoint^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


PixManager Property

PixManager Property

XdsObjects Namespace > XdsDomain Class : PixManager Property
The endpoint details for the PIX Manager to use for translation of patient IDs between different domains
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property PixManager As WebServiceEndpoint
Dim instance As XdsDomain
Dim value As WebServiceEndpoint

instance.PixManager = value

value = instance.PixManager
public WebServiceEndpoint PixManager {get; set;}
public:
property WebServiceEndpoint^ PixManager {
   WebServiceEndpoint^ get();
   void set (    WebServiceEndpoint^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


RegistryEndpoint Property

RegistryEndpoint Property

XdsObjects Namespace > XdsDomain Class : RegistryEndpoint Property
The registry used in this domain.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property RegistryEndpoint As WebServiceEndpoint
Dim instance As XdsDomain
Dim value As WebServiceEndpoint

instance.RegistryEndpoint = value

value = instance.RegistryEndpoint
public WebServiceEndpoint RegistryEndpoint {get; set;}
public:
property WebServiceEndpoint^ RegistryEndpoint {
   WebServiceEndpoint^ get();
   void set (    WebServiceEndpoint^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


RepositoryAddresses Property

RepositoryAddresses Property
Example

XdsObjects Namespace > XdsDomain Class : RepositoryAddresses Property
Holds the lookup table for mapping a Repository UniqueID to an EndPoint address
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property RepositoryAddresses As Dictionary(Of String,WebServiceEndpoint)
Dim instance As XdsDomain
Dim value As Dictionary(Of String,WebServiceEndpoint)

instance.RepositoryAddresses = value

value = instance.RepositoryAddresses
public Dictionary<string,WebServiceEndpoint> RepositoryAddresses {get; set;}
public:
property Dictionary<String^,WebServiceEndpoint^>^ RepositoryAddresses {
   Dictionary<String^,WebServiceEndpoint^>^ get();
   void set (    Dictionary<String^,WebServiceEndpoint^>^ value);
}
Remarks

One of the more difficult and badly defined areas of XDS.b is the requirement that systems directly accessing repositories (Document Consumers and Responding Gateways) must be able to translate from a Repository Unique ID to an endpoint address. This Dictionary provides that functionality. In most applications, this dictionary is loaded just once at application startup, from a configuration file, local web service etc., and its use is then transparent, as methods such as RetrieveDocumentSet then use it internally without further user/developer interaction.

By using an WebServiceEndpoint object as the target, a domain may contain a mixture of secure and insecure endpoints, and may even use different client certificates for different connections.

Example
This example shows how to set up 2 different repositories - one to use secure and one to use insecure communications.
  • C#
XdsDomain Domain = new XdsDomain();
            X509Certificate2 Certificate = new X509Certificate2();
            //Load certificate from Store or file
            Domain.RepositoryAddresses.Add("1.2.840.99999.1.2.3", new XdsEndpoint("http://insecure/Retrieve");
            Domain.RepositoryAddresses.Add("1.2.840.99999.1.2.3.4", new XdsEndpoint("https://secure/Retrieve", Certificate));
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


RetrieveGateway Property

RetrieveGateway Property

XdsObjects Namespace > XdsDomain Class : RetrieveGateway Property
This is used automatically when the data to be retrieved contains a HomeCommunityID value
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property RetrieveGateway As WebServiceEndpoint
Dim instance As XdsDomain
Dim value As WebServiceEndpoint

instance.RetrieveGateway = value

value = instance.RetrieveGateway
public WebServiceEndpoint RetrieveGateway {get; set;}
public:
property WebServiceEndpoint^ RetrieveGateway {
   WebServiceEndpoint^ get();
   void set (    WebServiceEndpoint^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


StructureIncomingSubmissionSet Property (XdsDomain)

StructureIncomingSubmissionSet Property (XdsDomain)

XdsObjects Namespace > XdsDomain Class : StructureIncomingSubmissionSet Property
Controls the behaviour used when incoming data is received.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property StructureIncomingSubmissionSet As Boolean
Dim instance As XdsDomain
Dim value As Boolean

instance.StructureIncomingSubmissionSet = value

value = instance.StructureIncomingSubmissionSet
public bool StructureIncomingSubmissionSet {get; set;}
public:
property bool StructureIncomingSubmissionSet {
   bool get();
   void set (    bool value);
}
Remarks

XdsObjects can operate in 2 distinct modes - depending on the value of this property

If it is true (the default):

A folder structure is created as aprt of the receipt of data, with documents being placed in folders according the associations which link them, and the XdsSubmissionSet's Structured property is set to true

If false:

All documents will appear in the top level Document folder and the XdsSubmissionSet's Structured property is set to false. In this case, the associations may be found, unaltered, in the XdsSubmissionSet's Associations collection.

There are 2 versions of this property - one attached to XdsBaseServer which controls the behaviour when receiving data vai ProvideAndRegisterDocumentSet or RegisterDocumentSet transactions, and the other on XdsDomain which is used for data received via query and retrieve operations.

In general, this value should be true for consumers, but false for registries, servers and gateways.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


SubmissionRepositoryEndpoint Property

SubmissionRepositoryEndpoint Property

XdsObjects Namespace > XdsDomain Class : SubmissionRepositoryEndpoint Property
The Respository to which submissions should be sent
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property SubmissionRepositoryEndpoint As WebServiceEndpoint
Dim instance As XdsDomain
Dim value As WebServiceEndpoint

instance.SubmissionRepositoryEndpoint = value

value = instance.SubmissionRepositoryEndpoint
public WebServiceEndpoint SubmissionRepositoryEndpoint {get; set;}
public:
property WebServiceEndpoint^ SubmissionRepositoryEndpoint {
   WebServiceEndpoint^ get();
   void set (    WebServiceEndpoint^ value);
}
Remarks

This is used by the ProvideAndRegisterDocumentSet transaction.

Only a single value is used.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


SubscriptionBrokerEndpoint Property

SubscriptionBrokerEndpoint Property

XdsObjects Namespace > XdsDomain Class : SubscriptionBrokerEndpoint Property
The Subscription Broker's Address
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property SubscriptionBrokerEndpoint As WebServiceEndpoint
Dim instance As XdsDomain
Dim value As WebServiceEndpoint

instance.SubscriptionBrokerEndpoint = value

value = instance.SubscriptionBrokerEndpoint
public WebServiceEndpoint SubscriptionBrokerEndpoint {get; set;}
public:
property WebServiceEndpoint^ SubscriptionBrokerEndpoint {
   WebServiceEndpoint^ get();
   void set (    WebServiceEndpoint^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


TreatErrorsAsExceptions Property (XdsDomain)

TreatErrorsAsExceptions Property (XdsDomain)

XdsObjects Namespace > XdsDomain Class : TreatErrorsAsExceptions Property
Controls whether error codes received via XDS protocols cause excpetions to be thrown.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property TreatErrorsAsExceptions As Boolean
Dim instance As XdsDomain
Dim value As Boolean

instance.TreatErrorsAsExceptions = value

value = instance.TreatErrorsAsExceptions
public bool TreatErrorsAsExceptions {get; set;}
public:
property bool TreatErrorsAsExceptions {
   bool get();
   void set (    bool value);
}
Remarks

Low levels excepetions such as TCP errors will always be passed as exceptions, but the response to error status codes is controlled by this property. It is intialised from, and has the same meaning as XdsGlobal.TreatErrorsAsExceptions, but allows control on a "per domain" level.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


ValidateOnSending Property

ValidateOnSending Property

XdsObjects Namespace > XdsDomain Class : ValidateOnSending Property
Controls whether to validate data being sent
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ValidateOnSending As Boolean
Dim instance As XdsDomain
Dim value As Boolean

instance.ValidateOnSending = value

value = instance.ValidateOnSending
public bool ValidateOnSending {get; set;}
public:
property bool ValidateOnSending {
   bool get();
   void set (    bool value);
}
Remarks

The default value is true.

The validation performed is fairly basic (string lengths etc.) but can provide useful to avoid some known pitfalls.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


ValidateServerCertificate Property (XdsDomain)

ValidateServerCertificate Property (XdsDomain)

XdsObjects Namespace > XdsDomain Class : ValidateServerCertificate Property
Callback routine used to validate remote certificates
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ValidateServerCertificate As RemoteCertificateValidationCallback
Dim instance As XdsDomain
Dim value As RemoteCertificateValidationCallback

instance.ValidateServerCertificate = value

value = instance.ValidateServerCertificate
public RemoteCertificateValidationCallback ValidateServerCertificate {get; set;}
public:
property RemoteCertificateValidationCallback^ ValidateServerCertificate {
   RemoteCertificateValidationCallback^ get();
   void set (    RemoteCertificateValidationCallback^ value);
}
Remarks
Standard windows delegate indicating whether a particular certificate is acceptable
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


XdsDomainRoot Property

XdsDomainRoot Property

XdsObjects Namespace > XdsDomain Class : XdsDomainRoot Property
The ID Root used by the XDS Domain.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property XdsDomainRoot As String
Dim instance As XdsDomain
Dim value As String

instance.XdsDomainRoot = value

value = instance.XdsDomainRoot
public string XdsDomainRoot {get; set;}
public:
property String^ XdsDomainRoot {
   String^ get();
   void set (    String^ value);
}
Remarks
This is used for Automatic PIX queries
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDomain Class
XdsDomain Members


XdsError Class

XdsError Class
Members

XdsObjects Namespace : XdsError Class
Represents an error information as defined in the ebXML model
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsError
   Inherits System.Exception
Dim instance As XdsError
public class XdsError : System.Exception
public ref class XdsError : public System.Exception
Remarks

This type is derived from System.Exception, allowing it to be created and "thrown" in server applications, where the XdsObjects code will automatically catch it, and return the reponse to the client application.

The same object is also used to pass received errors back to a calling application, which may choose to throw the error as part of its exception handling, or may handle it as a simple object

Inheritance Hierarchy

System.Object
System.Exception
XdsObjects.XdsError

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsError Members
XdsObjects Namespace


XdsError Class Members

XdsError Class Members
Properties Methods Events

XdsObjects Namespace : XdsError Class

The following tables list the members exposed by XdsError.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorList | The list of ebXML errors in the response
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Overridden. Override to provide a human-readable version of the ebXML errors
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
Protected Events
 | Name | Description
Protected Event | SerializeObjectState | (Inherited from System.Exception)
Top
See Also

Reference

XdsError Class
XdsObjects Namespace


XdsError Class Properties

XdsError Class Properties

XdsObjects Namespace : XdsError Class

For a list of all members of this type, see XdsError members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorList | The list of ebXML errors in the response
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Overridden. Override to provide a human-readable version of the ebXML errors
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

XdsError Class
XdsObjects Namespace


ErrorList Property

ErrorList Property

XdsObjects Namespace > XdsError Class : ErrorList Property
The list of ebXML errors in the response
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ErrorList As List(Of XdsErrorItem)
Dim instance As XdsError
Dim value As List(Of XdsErrorItem)

instance.ErrorList = value

value = instance.ErrorList
public List<XdsErrorItem> ErrorList {get; set;}
public:
property List<XdsErrorItem^>^ ErrorList {
   List<XdsErrorItem^>^ get();
   void set (    List<XdsErrorItem^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsError Class
XdsError Members


Message Property (XdsError)

Message Property (XdsError)

XdsObjects Namespace > XdsError Class : Message Property
Override to provide a human-readable version of the ebXML errors
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overrides ReadOnly Property Message As String
Dim instance As XdsError
Dim value As String

value = instance.Message
public override string Message {get;}
public:
property String^ Message {
   String^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsError Class
XdsError Members
Base Implementation in Message


XdsErrorItem Class

XdsErrorItem Class
Members

XdsObjects Namespace : XdsErrorItem Class
Class representing a single ebXML error
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsErrorItem
Dim instance As XdsErrorItem
public class XdsErrorItem
public ref class XdsErrorItem
Inheritance Hierarchy

System.Object
XdsObjects.XdsErrorItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsErrorItem Members
XdsObjects Namespace


XdsErrorItem Class Members

XdsErrorItem Class Members
Properties Methods

XdsObjects Namespace : XdsErrorItem Class

The following tables list the members exposed by XdsErrorItem.

Public Constructors
 | Name | Description
Public Constructor | XdsErrorItem Constructor | Overloaded. Create a new XdsErrorItem
Top
Public Properties
 | Name | Description
Public Property | CodeContext | Supplies additional detail for the errorCode
Public Property | ErrorCode | A standardised XDS definition of the error. The names are defined in the ErrorCode enumeration, and correspond to the terms used in the IHE technical frameworks.
Public Property | Location | Supplies the location of the error
Public Property | Severity | The severity of the error - should be Warning or Error
Top
Public Methods
 | Name | Description
Public Method | ToString | Override to provide a human-readable version of the ebXML error
Top
See Also

Reference

XdsErrorItem Class
XdsObjects Namespace


XdsErrorItem Constructor

XdsErrorItem Constructor

XdsObjects Namespace > XdsErrorItem Class : XdsErrorItem Constructor
Create a new XdsErrorItem
Overload List
Overload | Description
XdsErrorItem Constructor(Exception,XdsErrorCode) | Create a new XdsErrorItem from a System.Exception object and an XdsObjects.Enums.XdsErrorCode value
XdsErrorItem Constructor(XdsErrorCode,String,String) | Create a new XdsErrorItem from a System.Exception object and explicit CodeContext and Location values
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsErrorItem Class
XdsErrorItem Members


XdsErrorItem Constructor(Exception,XdsErrorCode)

XdsErrorItem Constructor(Exception,XdsErrorCode)

XdsObjects Namespace > XdsErrorItem Class > XdsErrorItem Constructor : XdsErrorItem Constructor(Exception,XdsErrorCode)
Exception to use as source of data
XDS specific error code
Create a new XdsErrorItem from a System.Exception object and an XdsObjects.Enums.XdsErrorCode value
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal Exception As Exception, _
   ByVal ErrorCode As XdsErrorCode _
)
Dim Exception As Exception
Dim ErrorCode As XdsErrorCode

Dim instance As New XdsErrorItem(Exception, ErrorCode)
public XdsErrorItem(
   Exception Exception,
   XdsErrorCode ErrorCode
)
public:
XdsErrorItem(
   Exception^ Exception,
   XdsErrorCode ErrorCode
)

Parameters

Exception
Exception to use as source of data
ErrorCode
XDS specific error code
Remarks

The CodeContext is set to the value of System.Exception.Message

The Location is set to the value of System.Exception.StackTrace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsErrorItem Class
XdsErrorItem Members
Overload List


XdsErrorItem Constructor(XdsErrorCode,String,String)

XdsErrorItem Constructor(XdsErrorCode,String,String)

XdsObjects Namespace > XdsErrorItem Class > XdsErrorItem Constructor : XdsErrorItem Constructor(XdsErrorCode,String,String)
XDS specific error code
Further information describing the error
The locatio of the error
Create a new XdsErrorItem from a System.Exception object and explicit CodeContext and Location values
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal ErrorCode As XdsErrorCode, _
   ByVal CodeContext As String, _
   ByVal Location As String _
)
Dim ErrorCode As XdsErrorCode
Dim CodeContext As String
Dim Location As String

Dim instance As New XdsErrorItem(ErrorCode, CodeContext, Location)
public XdsErrorItem(
   XdsErrorCode ErrorCode,
   string CodeContext,
   string Location
)
public:
XdsErrorItem(
   XdsErrorCode ErrorCode,
   String^ CodeContext,
   String^ Location
)

Parameters

ErrorCode
XDS specific error code
CodeContext
Further information describing the error
Location
The locatio of the error
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsErrorItem Class
XdsErrorItem Members
Overload List


XdsErrorItem Class Methods

XdsErrorItem Class Methods

XdsObjects Namespace : XdsErrorItem Class

For a list of all members of this type, see XdsErrorItem members.

Public Methods
 | Name | Description
Public Method | ToString | Override to provide a human-readable version of the ebXML error
Top
See Also

Reference

XdsErrorItem Class
XdsObjects Namespace


ToString Method (XdsErrorItem)

ToString Method (XdsErrorItem)

XdsObjects Namespace > XdsErrorItem Class : ToString Method
Override to provide a human-readable version of the ebXML error
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overrides Function ToString() As String
Dim instance As XdsErrorItem
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsErrorItem Class
XdsErrorItem Members
Base Implementation in ToString


XdsErrorItem Class Properties

XdsErrorItem Class Properties

XdsObjects Namespace : XdsErrorItem Class

For a list of all members of this type, see XdsErrorItem members.

Public Properties
 | Name | Description
Public Property | CodeContext | Supplies additional detail for the errorCode
Public Property | ErrorCode | A standardised XDS definition of the error. The names are defined in the ErrorCode enumeration, and correspond to the terms used in the IHE technical frameworks.
Public Property | Location | Supplies the location of the error
Public Property | Severity | The severity of the error - should be Warning or Error
Top
See Also

Reference

XdsErrorItem Class
XdsObjects Namespace


CodeContext Property

CodeContext Property

XdsObjects Namespace > XdsErrorItem Class : CodeContext Property
Supplies additional detail for the errorCode
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property CodeContext As String
Dim instance As XdsErrorItem
Dim value As String

instance.CodeContext = value

value = instance.CodeContext
public string CodeContext {get; set;}
public:
property String^ CodeContext {
   String^ get();
   void set (    String^ value);
}
Remarks
This provides additional information to supplement the ErrorCode, and corresponds to the codeContext defined in the technical framework
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsErrorItem Class
XdsErrorItem Members


ErrorCode Property

ErrorCode Property

XdsObjects Namespace > XdsErrorItem Class : ErrorCode Property
A standardised XDS definition of the error. The names are defined in the ErrorCode enumeration, and correspond to the terms used in the IHE technical frameworks.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ErrorCode As XdsErrorCode
Dim instance As XdsErrorItem
Dim value As XdsErrorCode

instance.ErrorCode = value

value = instance.ErrorCode
public XdsErrorCode ErrorCode {get; set;}
public:
property XdsErrorCode ErrorCode {
   XdsErrorCode get();
   void set (    XdsErrorCode value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsErrorItem Class
XdsErrorItem Members


Location Property

Location Property

XdsObjects Namespace > XdsErrorItem Class : Location Property
Supplies the location of the error
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Location As String
Dim instance As XdsErrorItem
Dim value As String

instance.Location = value

value = instance.Location
public string Location {get; set;}
public:
property String^ Location {
   String^ get();
   void set (    String^ value);
}
Remarks
In most cases, this should provide debugging module/line number information.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsErrorItem Class
XdsErrorItem Members


Severity Property

Severity Property

XdsObjects Namespace > XdsErrorItem Class : Severity Property
The severity of the error - should be Warning or Error
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Severity As ErrorSeverityType
Dim instance As XdsErrorItem
Dim value As ErrorSeverityType

instance.Severity = value

value = instance.Severity
public ErrorSeverityType Severity {get; set;}
public:
property ErrorSeverityType Severity {
   ErrorSeverityType get();
   void set (    ErrorSeverityType value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsErrorItem Class
XdsErrorItem Members


XdsFolder Class

XdsFolder Class
Members

XdsObjects Namespace : XdsFolder Class
Class representing an XDS Folder
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsFolder
Dim instance As XdsFolder
public class XdsFolder
public ref class XdsFolder
Inheritance Hierarchy

System.Object
XdsObjects.XdsFolder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsFolder Members
XdsObjects Namespace


XdsFolder Class Members

XdsFolder Class Members
Properties

XdsObjects Namespace : XdsFolder Class

The following tables list the members exposed by XdsFolder.

Public Constructors
 | Name | Description
Public Constructor | XdsFolder Constructor | Overloaded. Create a new XdsFolder object
Top
Public Properties
 | Name | Description
Public Property | AlreadyExists | A flag indicating whether the folder already exists in the registry (as opposed to being created now)
Public Property | AvailabilityStatus | The availability stats (Approved/Deprecated) of the folder
Public Property | AvailabilityStatusAsInt | The AvailabilityStatus as an integer
Public Property | CodeList | The codes describing this folder
Public Property | Comments | Comments associated with the folder
Public Property | Documents | Collection of documents in this folder
Public Property | ExtraSlots | The list of slots not explicitly used to populate other fields
Public Property | HomeCommunityID | The HomeCommunityID of the Folder
Public Property | LastUpdateTime | Point in time at the Document Registry when an XDS Document was registered and placed in the XDS Folder
Public Property | PatientID | Shortcut to PatientInfo.XdsPerson.CompositeId
Public Property | PatientInfo | The subject of care of the folder
Public Property | Title | Represents the title of the folder
Public Property | UniqueID | The globally unique identifier assigned by the document creator to this folder
Public Property | UUID | The globally unique identifier of the folder
Top
See Also

Reference

XdsFolder Class
XdsObjects Namespace


XdsFolder Constructor

XdsFolder Constructor

XdsObjects Namespace > XdsFolder Class : XdsFolder Constructor
Create a new XdsFolder object
Overload List
Overload | Description
XdsFolder Constructor(String) | Constructor for Existing Folder - used for Adding an existing Folder to a submission set"
XdsFolder Constructor() | Create a new blank XdsFolder object
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsFolder Class
XdsFolder Members


XdsFolder Constructor(String)

XdsFolder Constructor(String)

XdsObjects Namespace > XdsFolder Class > XdsFolder Constructor : XdsFolder Constructor(String)
The UUID of the folder to create
Constructor for Existing Folder - used for Adding an existing Folder to a submission set"
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal UUID As String _
)
Dim UUID As String

Dim instance As New XdsFolder(UUID)
public XdsFolder(
   string UUID
)
public:
XdsFolder(
   String^ UUID
)

Parameters

UUID
The UUID of the folder to create
Remarks
This is used to create a "dummy" object which is a reference to an existing folder.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsFolder Class
XdsFolder Members
Overload List


XdsFolder Constructor()

XdsFolder Constructor()

XdsObjects Namespace > XdsFolder Class > XdsFolder Constructor : XdsFolder Constructor()
Create a new blank XdsFolder object
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsFolder()
public XdsFolder()
public:
XdsFolder();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsFolder Class
XdsFolder Members
Overload List


XdsFolder Class Properties

XdsFolder Class Properties

XdsObjects Namespace : XdsFolder Class

For a list of all members of this type, see XdsFolder members.

Public Properties
 | Name | Description
Public Property | AlreadyExists | A flag indicating whether the folder already exists in the registry (as opposed to being created now)
Public Property | AvailabilityStatus | The availability stats (Approved/Deprecated) of the folder
Public Property | AvailabilityStatusAsInt | The AvailabilityStatus as an integer
Public Property | CodeList | The codes describing this folder
Public Property | Comments | Comments associated with the folder
Public Property | Documents | Collection of documents in this folder
Public Property | ExtraSlots | The list of slots not explicitly used to populate other fields
Public Property | HomeCommunityID | The HomeCommunityID of the Folder
Public Property | LastUpdateTime | Point in time at the Document Registry when an XDS Document was registered and placed in the XDS Folder
Public Property | PatientID | Shortcut to PatientInfo.XdsPerson.CompositeId
Public Property | PatientInfo | The subject of care of the folder
Public Property | Title | Represents the title of the folder
Public Property | UniqueID | The globally unique identifier assigned by the document creator to this folder
Public Property | UUID | The globally unique identifier of the folder
Top
See Also

Reference

XdsFolder Class
XdsObjects Namespace


AlreadyExists Property (XdsFolder)

AlreadyExists Property (XdsFolder)

XdsObjects Namespace > XdsFolder Class : AlreadyExists Property
A flag indicating whether the folder already exists in the registry (as opposed to being created now)
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property AlreadyExists As Boolean
Dim instance As XdsFolder
Dim value As Boolean

instance.AlreadyExists = value

value = instance.AlreadyExists
public bool AlreadyExists {get; set;}
public:
property bool AlreadyExists {
   bool get();
   void set (    bool value);
}
Remarks
This flag controls whether the folder is included, or is merely referenced.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsFolder Class
XdsFolder Members


AvailabilityStatus Property (XdsFolder)

AvailabilityStatus Property (XdsFolder)

XdsObjects Namespace > XdsFolder Class : AvailabilityStatus Property
The availability stats (Approved/Deprecated) of the folder
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property AvailabilityStatus As AvailabilityStatusCode
Dim instance As XdsFolder
Dim value As AvailabilityStatusCode

instance.AvailabilityStatus = value

value = instance.AvailabilityStatus
public AvailabilityStatusCode AvailabilityStatus {get; set;}
public:
property AvailabilityStatusCode AvailabilityStatus {
   AvailabilityStatusCode get();
   void set (    AvailabilityStatusCode value);
}
Remarks

This property corresponds to the XDSFolder.availabilityStatus attribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsFolder Class
XdsFolder Members


AvailabilityStatusAsInt Property (XdsFolder)

AvailabilityStatusAsInt Property (XdsFolder)

XdsObjects Namespace > XdsFolder Class : AvailabilityStatusAsInt Property
The AvailabilityStatus as an integer
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property AvailabilityStatusAsInt As Integer
Dim instance As XdsFolder
Dim value As Integer

instance.AvailabilityStatusAsInt = value

value = instance.AvailabilityStatusAsInt
public int AvailabilityStatusAsInt {get; set;}
public:
property int AvailabilityStatusAsInt {
   int get();
   void set (    int value);
}
Remarks
This is a special property, only used as part of a registry based on the Code First Entity Framework which is used for our registry example. This is needed due to the inability of the Entity Framework to handle Enums. When used in this mode, the AvailabilityStatus property should be excluded from the database.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsFolder Class
XdsFolder Members


CodeList Property

CodeList Property

XdsObjects Namespace > XdsFolder Class : CodeList Property
The codes describing this folder
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property CodeList As List(Of XdsCode)
Dim instance As XdsFolder
Dim value As List(Of XdsCode)

instance.CodeList = value

value = instance.CodeList
public List<XdsCode> CodeList {get; set;}
public:
property List<XdsCode^>^ CodeList {
   List<XdsCode^>^ get();
   void set (    List<XdsCode^>^ value);
}
Remarks
Although the XDS rules only permit one descriptive code to be applied when a folder is created, others may be added later
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsFolder Class
XdsFolder Members


Comments Property (XdsFolder)

Comments Property (XdsFolder)

XdsObjects Namespace > XdsFolder Class : Comments Property
Comments associated with the folder
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Comments As XdsInternationalString
Dim instance As XdsFolder
Dim value As XdsInternationalString

instance.Comments = value

value = instance.Comments
public XdsInternationalString Comments {get; set;}
public:
property XdsInternationalString^ Comments {
   XdsInternationalString^ get();
   void set (    XdsInternationalString^ value);
}
Remarks

This property corresponds to the XDSFolder.comments Attribute, which actually uses the ebXML "Description" attribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsFolder Class
XdsFolder Members


Documents Property (XdsFolder)

Documents Property (XdsFolder)

XdsObjects Namespace > XdsFolder Class : Documents Property
Collection of documents in this folder
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Documents As List(Of XdsDocument)
Dim instance As XdsFolder
Dim value As List(Of XdsDocument)

instance.Documents = value

value = instance.Documents
public List<XdsDocument> Documents {get; set;}
public:
property List<XdsDocument^>^ Documents {
   List<XdsDocument^>^ get();
   void set (    List<XdsDocument^>^ value);
}
Remarks
This list is used in the API to present a simple interface for inclusion of documents in a folder, both during submission and retrieval. In reality, the list is passed to/from registry and repository actors in the form of ebXML associations, but these are created from this collection or used internally to creat this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsFolder Class
XdsFolder Members


ExtraSlots Property (XdsFolder)

ExtraSlots Property (XdsFolder)

XdsObjects Namespace > XdsFolder Class : ExtraSlots Property
The list of slots not explicitly used to populate other fields
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property ExtraSlots As List(Of XdsSlot)
Dim instance As XdsFolder
Dim value As List(Of XdsSlot)

value = instance.ExtraSlots
public List<XdsSlot> ExtraSlots {get;}
public:
property List<XdsSlot^>^ ExtraSlots {
   List<XdsSlot^>^ get();
}
Remarks
Whilst the XDS standards specifiy the contents of some slots (such as LastUpdateTime and many more), other "user defined" slots are allowed and should be stored by a registry. This property allows such additional slots to be created and accessed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsFolder Class
XdsFolder Members


HomeCommunityID Property (XdsFolder)

HomeCommunityID Property (XdsFolder)

XdsObjects Namespace > XdsFolder Class : HomeCommunityID Property
The HomeCommunityID of the Folder
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property HomeCommunityID As String
Dim instance As XdsFolder
Dim value As String

instance.HomeCommunityID = value

value = instance.HomeCommunityID
public string HomeCommunityID {get; set;}
public:
property String^ HomeCommunityID {
   String^ get();
   void set (    String^ value);
}
Remarks
This is only used in the context of XCA queries. The value will be set internally from the "home" property of incoming data. For outgoing data, it is easiest to set for all objects in the "passed through" data by using the XdsQueryResponse.SetHomeCommunityID method.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsFolder Class
XdsFolder Members


LastUpdateTime Property

LastUpdateTime Property

XdsObjects Namespace > XdsFolder Class : LastUpdateTime Property
Point in time at the Document Registry when an XDS Document was registered and placed in the XDS Folder
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property LastUpdateTime As Nullable(Of Date)
Dim instance As XdsFolder
Dim value As Nullable(Of Date)

instance.LastUpdateTime = value

value = instance.LastUpdateTime
public Nullable<DateTime> LastUpdateTime {get; set;}
public:
property Nullable<DateTime> LastUpdateTime {
   Nullable<DateTime> get();
   void set (    Nullable<DateTime> value);
}
Remarks

This property corresponds to the XDSFolder.lastUpdateTime slot

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsFolder Class
XdsFolder Members


PatientID Property (XdsFolder)

PatientID Property (XdsFolder)

XdsObjects Namespace > XdsFolder Class : PatientID Property
Shortcut to PatientInfo.XdsPerson.CompositeId
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property PatientID As String
Dim instance As XdsFolder
Dim value As String

instance.PatientID = value

value = instance.PatientID
public string PatientID {get; set;}
public:
property String^ PatientID {
   String^ get();
   void set (    String^ value);
}
Remarks
The main use for this property is to act as the primary key for applications using the CodeFirst Entity framework, but it is also available for more general use.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsFolder Class
XdsFolder Members


PatientInfo Property (XdsFolder)

PatientInfo Property (XdsFolder)

XdsObjects Namespace > XdsFolder Class : PatientInfo Property
The subject of care of the folder
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property PatientInfo As XdsPatient
Dim instance As XdsFolder
Dim value As XdsPatient

instance.PatientInfo = value

value = instance.PatientInfo
public XdsPatient PatientInfo {get; set;}
public:
property XdsPatient^ PatientInfo {
   XdsPatient^ get();
   void set (    XdsPatient^ value);
}
Remarks

This property corresponds to the XDSFolder.patientId ExternalIdentifier

Although a full XdsPatient is used, only the CompositeId is used internally. Where necessary, during submission, the ID is converted using PIX from the Source (local) domain to the domain used by the XDS affinity domain. See Automatic PIX Queries in XdsObjects for more details.

The composite ID is also accessible via the PatientID property, which is actually a shortcut to PatientInfo.XdsPerson.CompositeId

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsFolder Class
XdsFolder Members


Title Property (XdsFolder)

Title Property (XdsFolder)

XdsObjects Namespace > XdsFolder Class : Title Property
Represents the title of the folder
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Title As XdsInternationalString
Dim instance As XdsFolder
Dim value As XdsInternationalString

instance.Title = value

value = instance.Title
public XdsInternationalString Title {get; set;}
public:
property XdsInternationalString^ Title {
   XdsInternationalString^ get();
   void set (    XdsInternationalString^ value);
}
Remarks

This property corresponds to the XDSFolder.title Attribute, which actually uses the ebXML "Name" attribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsFolder Class
XdsFolder Members


UniqueID Property (XdsFolder)

UniqueID Property (XdsFolder)

XdsObjects Namespace > XdsFolder Class : UniqueID Property
The globally unique identifier assigned by the document creator to this folder
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property UniqueID As String
Dim instance As XdsFolder
Dim value As String

instance.UniqueID = value

value = instance.UniqueID
public string UniqueID {get; set;}
public:
property String^ UniqueID {
   String^ get();
   void set (    String^ value);
}
Remarks

This property corresponds to the XDSFolder.uniqueId ExternalIdentifier

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsFolder Class
XdsFolder Members


UUID Property (XdsFolder)

UUID Property (XdsFolder)

XdsObjects Namespace > XdsFolder Class : UUID Property
The globally unique identifier of the folder
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property UUID As String
Dim instance As XdsFolder
Dim value As String

instance.UUID = value

value = instance.UUID
public string UUID {get; set;}
public:
property String^ UUID {
   String^ get();
   void set (    String^ value);
}
Remarks

This property corresponds to the XDSFolder.entryUUID attribute

This ID may be assigned by either by Source, Repository, or Registry

There is often confusion between this value and the UniqueID, and the Technical framework notes:

"The globally unique identifier (may be assigned by either by Source, Repository, or Registry) is primarily intended for use as a document registry management identifier. It is not meant to be an external reference for XDS Documents (e.g. in links within other documents). The uniqueId is meant for that purpose so that such links remain valid"

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsFolder Class
XdsFolder Members


XdsGlobal Class

XdsGlobal Class
Members

XdsObjects Namespace : XdsGlobal Class
A completely static class which holds various static methods and properties which relate to the application as a whole.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public MustInherit NotInheritable Class XdsGlobal
Dim instance As XdsGlobal
public static class XdsGlobal
public ref class XdsGlobal abstract sealed
Inheritance Hierarchy

System.Object
XdsObjects.XdsGlobal

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsGlobal Members
XdsObjects Namespace


XdsGlobal Class Members

XdsGlobal Class Members
Properties Methods Events

XdsObjects Namespace : XdsGlobal Class

The following tables list the members exposed by XdsGlobal.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | DefaultLanguage | The default language to assume when not otherwise specified.
static (Shared in Visual Basic) | EventLogLevel | Controls the logging of diagnistic message to the LogEvent event.
static (Shared in Visual Basic) | FileVersion | Gets the File Version of XdsObjects
static (Shared in Visual Basic) | HttpProvider | Specify the HttpProvider type XdsObjects is going to be using. Default is Windows.
static (Shared in Visual Basic) | IncludedStyleSheet | Speficiy if a default Style Sheet is included and should be used when displaying CDA documents
static (Shared in Visual Basic) | MimeMappings | Dictionary used to convert from filenames to MIME types
static (Shared in Visual Basic) | OIDRoot | OIDRoot used by the NewOID method
static (Shared in Visual Basic) | OmitQuotesInQueries | Workaround for bad registries which do not expect/allow quotes around stored query parameters
static (Shared in Visual Basic) | ProductName | Product name to show in dialog boxes for licensing etc.
static (Shared in Visual Basic) | Timeout | Time to wait for incoming data during an operation
static (Shared in Visual Basic) | TreatErrorsAsExceptions | Controls whether errors reported in incoming data cause an exception to be thrown
static (Shared in Visual Basic) | UseQuotesForDateTimeInQueries | Workaround for bad registries which expect quotes around date time values in queries
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | Log | Log a message to the XdsObjects log.
static (Shared in Visual Basic) | LogToFile | Enables XdsObjects logging, specifies where XdsObjects log files appear, what the logging level is and the timer interval when new log file should be generated.
static (Shared in Visual Basic) | NewOID | Returns a new randomly generated OID. If the OIDRoot property has been set to a proper unique root UID/OID value, then the result is guaranteed to be unique, otherwise it is based on a default root, and though a clash is very unlikely, it is not impossible.
Top
Public Events
 | Name | Description
Public Event | LogEvent | Event fires when loggable events occur
Top
See Also

Reference

XdsGlobal Class
XdsObjects Namespace


XdsGlobal Class Methods

XdsGlobal Class Methods

XdsObjects Namespace : XdsGlobal Class

For a list of all members of this type, see XdsGlobal members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Log | Log a message to the XdsObjects log.
static (Shared in Visual Basic) | LogToFile | Enables XdsObjects logging, specifies where XdsObjects log files appear, what the logging level is and the timer interval when new log file should be generated.
static (Shared in Visual Basic) | NewOID | Returns a new randomly generated OID. If the OIDRoot property has been set to a proper unique root UID/OID value, then the result is guaranteed to be unique, otherwise it is based on a default root, and though a clash is very unlikely, it is not impossible.
Top
See Also

Reference

XdsGlobal Class
XdsObjects Namespace


Log Method

Log Method

XdsObjects Namespace > XdsGlobal Class : Log Method
The text to place into the log
Log a message to the XdsObjects log.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Sub Log( _
   ByVal text As Object _
)
Dim text As Object

XdsGlobal.Log(text)
public static void Log(
   object text
)
public:
static void Log(
   Object^ text
)

Parameters

text
The text to place into the log
Remarks
This only performs a useful function if logging is enabled. See LogToFile for more details.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsGlobal Class
XdsGlobal Members


LogToFile Method

LogToFile Method

XdsObjects Namespace > XdsGlobal Class : LogToFile Method

Path as string :

The location of the log files.

If an empty string being passed, XdsObjects will use the user's documents directory as the default location.

But still it is the caller's responsibility to ensure either that the path is valid and correct.

LogLevel as Integer:

This value controls the level of details logged to the file.

The time interval in Minutes when a new log file should be generated.
Enables XdsObjects logging, specifies where XdsObjects log files appear, what the logging level is and the timer interval when new log file should be generated.
Enables XdsObjects logging, specifies where XdsObjects log files appear, what the logging level is.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Sub LogToFile( _
   ByVal Path As String, _
   ByVal Level As LogLevel, _
   ByVal RestartInterval As Integer _
)
Dim Path As String
Dim Level As LogLevel
Dim RestartInterval As Integer

XdsGlobal.LogToFile(Path, Level, RestartInterval)
public static void LogToFile(
   string Path,
   LogLevel Level,
   int RestartInterval
)
public:
static void LogToFile(
   String^ Path,
   LogLevel Level,
   int RestartInterval
)

Parameters

Path

Path as string :

The location of the log files.

If an empty string being passed, XdsObjects will use the user's documents directory as the default location.

But still it is the caller's responsibility to ensure either that the path is valid and correct.

Level

LogLevel as Integer:

This value controls the level of details logged to the file.

RestartInterval
The time interval in Minutes when a new log file should be generated.
Remarks

The RestartInterval parameter provides a means to restart the logging on a regular time basic. This is useful to avoid log file end up being HUGE.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsGlobal Class
XdsGlobal Members


NewOID Method

NewOID Method

XdsObjects Namespace > XdsGlobal Class : NewOID Method
Returns a new randomly generated OID. If the OIDRoot property has been set to a proper unique root UID/OID value, then the result is guaranteed to be unique, otherwise it is based on a default root, and though a clash is very unlikely, it is not impossible.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Function NewOID() As String
Dim value As String

value = XdsGlobal.NewOID()
public static string NewOID()
public:
static String^ NewOID();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsGlobal Class
XdsGlobal Members


XdsGlobal Class Properties

XdsGlobal Class Properties

XdsObjects Namespace : XdsGlobal Class

For a list of all members of this type, see XdsGlobal members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | DefaultLanguage | The default language to assume when not otherwise specified.
static (Shared in Visual Basic) | EventLogLevel | Controls the logging of diagnistic message to the LogEvent event.
static (Shared in Visual Basic) | FileVersion | Gets the File Version of XdsObjects
static (Shared in Visual Basic) | HttpProvider | Specify the HttpProvider type XdsObjects is going to be using. Default is Windows.
static (Shared in Visual Basic) | IncludedStyleSheet | Speficiy if a default Style Sheet is included and should be used when displaying CDA documents
static (Shared in Visual Basic) | MimeMappings | Dictionary used to convert from filenames to MIME types
static (Shared in Visual Basic) | OIDRoot | OIDRoot used by the NewOID method
static (Shared in Visual Basic) | OmitQuotesInQueries | Workaround for bad registries which do not expect/allow quotes around stored query parameters
static (Shared in Visual Basic) | ProductName | Product name to show in dialog boxes for licensing etc.
static (Shared in Visual Basic) | Timeout | Time to wait for incoming data during an operation
static (Shared in Visual Basic) | TreatErrorsAsExceptions | Controls whether errors reported in incoming data cause an exception to be thrown
static (Shared in Visual Basic) | UseQuotesForDateTimeInQueries | Workaround for bad registries which expect quotes around date time values in queries
Top
See Also

Reference

XdsGlobal Class
XdsObjects Namespace


DefaultLanguage Property

DefaultLanguage Property

XdsObjects Namespace > XdsGlobal Class : DefaultLanguage Property
The default language to assume when not otherwise specified.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Property DefaultLanguage As String
Dim value As String

XdsGlobal.DefaultLanguage = value

value = XdsGlobal.DefaultLanguage
public static string DefaultLanguage {get; set;}
public:
static property String^ DefaultLanguage {
   String^ get();
   void set (    String^ value);
}
Remarks

This prroperty used for several different purposes:

  • When a simple string is assigned to an XdsInternationalString item, then this is the value used as the Language for the new item
  • When an XdsInternationalString is cast (implicitly or explicitly) to a simple string, then this is "first choice" for which language variant to choose.
  • It is used as the default language for newly created objects (but can be over-ridden)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsGlobal Class
XdsGlobal Members


EventLogLevel Property

EventLogLevel Property

XdsObjects Namespace > XdsGlobal Class : EventLogLevel Property
Controls the logging of diagnistic message to the LogEvent event.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Property EventLogLevel As Integer
Dim value As Integer

XdsGlobal.EventLogLevel = value

value = XdsGlobal.EventLogLevel
public static int EventLogLevel {get; set;}
public:
static property int EventLogLevel {
   int get();
   void set (    int value);
}
Remarks
Bit field indicating which levels of activity should be logged. See DicomObjects.DicomGlobal.LogToFile for more details.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsGlobal Class
XdsGlobal Members


FileVersion Property

FileVersion Property

XdsObjects Namespace > XdsGlobal Class : FileVersion Property
Gets the File Version of XdsObjects
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared ReadOnly Property FileVersion As String
Dim value As String

value = XdsGlobal.FileVersion
public static string FileVersion {get;}
public:
static property String^ FileVersion {
   String^ get();
}
Remarks
This property contains the File Version of the running XdsObjects. This information can be found in the XdsObjects log file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsGlobal Class
XdsGlobal Members


HttpProvider Property (XdsGlobal)

HttpProvider Property (XdsGlobal)

XdsObjects Namespace > XdsGlobal Class : HttpProvider Property
Specify the HttpProvider type XdsObjects is going to be using. Default is Windows.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Property HttpProvider As HttpProvider
Dim value As HttpProvider

XdsGlobal.HttpProvider = value

value = XdsGlobal.HttpProvider
public static HttpProvider HttpProvider {get; set;}
public:
static property HttpProvider HttpProvider {
   HttpProvider get();
   void set (    HttpProvider value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsGlobal Class
XdsGlobal Members


IncludedStyleSheet Property

IncludedStyleSheet Property

XdsObjects Namespace > XdsGlobal Class : IncludedStyleSheet Property
Speficiy if a default Style Sheet is included and should be used when displaying CDA documents
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Property IncludedStyleSheet As String
Dim value As String

XdsGlobal.IncludedStyleSheet = value

value = XdsGlobal.IncludedStyleSheet
public static string IncludedStyleSheet {get; set;}
public:
static property String^ IncludedStyleSheet {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsGlobal Class
XdsGlobal Members


MimeMappings Property

MimeMappings Property

XdsObjects Namespace > XdsGlobal Class : MimeMappings Property
Dictionary used to convert from filenames to MIME types
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Property MimeMappings As Dictionary(Of String,String)
Dim value As Dictionary(Of String,String)

XdsGlobal.MimeMappings = value

value = XdsGlobal.MimeMappings
public static Dictionary<string,string> MimeMappings {get; set;}
public:
static property Dictionary<String^,String^>^ MimeMappings {
   Dictionary<String^,String^>^ get();
   void set (    Dictionary<String^,String^>^ value);
}
Remarks
This list is initially populated by a fairly comprehensive list of MIME types and their corresponding extensions, but this may be modified via this property if necessary.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsGlobal Class
XdsGlobal Members


OIDRoot Property

OIDRoot Property

XdsObjects Namespace > XdsGlobal Class : OIDRoot Property
OIDRoot used by the NewOID method
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Property OIDRoot As String
Dim value As String

XdsGlobal.OIDRoot = value

value = XdsGlobal.OIDRoot
public static string OIDRoot {get; set;}
public:
static property String^ OIDRoot {
   String^ get();
   void set (    String^ value);
}
Remarks

If not set explicitly, then a "statistically unique" (i.e. not guaranteed) UID generation technique is used instead

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsGlobal Class
XdsGlobal Members


OmitQuotesInQueries Property

OmitQuotesInQueries Property

XdsObjects Namespace > XdsGlobal Class : OmitQuotesInQueries Property
Workaround for bad registries which do not expect/allow quotes around stored query parameters
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Property OmitQuotesInQueries As Boolean
Dim value As Boolean

XdsGlobal.OmitQuotesInQueries = value

value = XdsGlobal.OmitQuotesInQueries
public static bool OmitQuotesInQueries {get; set;}
public:
static property bool OmitQuotesInQueries {
   bool get();
   void set (    bool value);
}
Remarks
Set to true to omit quotes
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsGlobal Class
XdsGlobal Members


ProductName Property

ProductName Property

XdsObjects Namespace > XdsGlobal Class : ProductName Property
Product name to show in dialog boxes for licensing etc.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Property ProductName As String
Dim value As String

XdsGlobal.ProductName = value

value = XdsGlobal.ProductName
public static string ProductName {get; set;}
public:
static property String^ ProductName {
   String^ get();
   void set (    String^ value);
}
Remarks
Default is "XdsObjects"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsGlobal Class
XdsGlobal Members


Timeout Property

Timeout Property

XdsObjects Namespace > XdsGlobal Class : Timeout Property
Time to wait for incoming data during an operation
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Property Timeout As Nullable(Of TimeSpan)
Dim value As Nullable(Of TimeSpan)

XdsGlobal.Timeout = value

value = XdsGlobal.Timeout
public static Nullable<TimeSpan> Timeout {get; set;}
public:
static property Nullable<TimeSpan> Timeout {
   Nullable<TimeSpan> get();
   void set (    Nullable<TimeSpan> value);
}
Remarks
Unless explicitly set via this property, the default specified by the operating system is used.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsGlobal Class
XdsGlobal Members


TreatErrorsAsExceptions Property (XdsGlobal)

TreatErrorsAsExceptions Property (XdsGlobal)

XdsObjects Namespace > XdsGlobal Class : TreatErrorsAsExceptions Property
Controls whether errors reported in incoming data cause an exception to be thrown
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Property TreatErrorsAsExceptions As Boolean
Dim value As Boolean

XdsGlobal.TreatErrorsAsExceptions = value

value = XdsGlobal.TreatErrorsAsExceptions
public static bool TreatErrorsAsExceptions {get; set;}
public:
static property bool TreatErrorsAsExceptions {
   bool get();
   void set (    bool value);
}
Remarks
By default, this value is true, so exceptions (as XdsError objects) will be thrown if errors are encountered. If set to false, then the error objects will still be created and return in the appropriate XdsRegistryResponse property, but will not be thrown.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsGlobal Class
XdsGlobal Members


UseQuotesForDateTimeInQueries Property

UseQuotesForDateTimeInQueries Property

XdsObjects Namespace > XdsGlobal Class : UseQuotesForDateTimeInQueries Property
Workaround for bad registries which expect quotes around date time values in queries
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Property UseQuotesForDateTimeInQueries As Boolean
Dim value As Boolean

XdsGlobal.UseQuotesForDateTimeInQueries = value

value = XdsGlobal.UseQuotesForDateTimeInQueries
public static bool UseQuotesForDateTimeInQueries {get; set;}
public:
static property bool UseQuotesForDateTimeInQueries {
   bool get();
   void set (    bool value);
}
Remarks
Set to true to enable quotes
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsGlobal Class
XdsGlobal Members


XdsGlobal Class Events

XdsGlobal Class Events

XdsObjects Namespace : XdsGlobal Class

For a list of all members of this type, see XdsGlobal members.

Public Events
 | Name | Description
Public Event | LogEvent | Event fires when loggable events occur
Top
See Also

Reference

XdsGlobal Class
XdsObjects Namespace


LogEvent Event

LogEvent Event

XdsObjects Namespace > XdsGlobal Class : LogEvent Event
Event fires when loggable events occur
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Event LogEvent As XdsGlobal.LogHandler
Dim instance As XdsGlobal
Dim handler As XdsGlobal.LogHandler

AddHandler instance.LogEvent, handler
public event XdsGlobal.LogHandler LogEvent
public:
event XdsGlobal.LogHandler^ LogEvent
Remarks
The types of events are controlled by the EventLogLevel property
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsGlobal Class
XdsGlobal Members


XdsGlobal.LogEventArgs Class

XdsGlobal.LogEventArgs Class
Members

XdsObjects Namespace : XdsGlobal.LogEventArgs Class
Arguments for the LogEvent Event
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsGlobal.LogEventArgs
Dim instance As XdsGlobal.LogEventArgs
public class XdsGlobal.LogEventArgs
public ref class XdsGlobal.LogEventArgs
Inheritance Hierarchy

System.Object
XdsObjects.XdsGlobal.LogEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsGlobal.LogEventArgs Members
XdsObjects Namespace


XdsGlobal.LogEventArgs Class Members

XdsGlobal.LogEventArgs Class Members
Properties

XdsObjects Namespace : XdsGlobal.LogEventArgs Class

The following tables list the members exposed by XdsGlobal.LogEventArgs.

Public Properties
 | Name | Description
Public Property | Level | The level of the event being logged
Public Property | Text | The test of the association
Top
See Also

Reference

XdsGlobal.LogEventArgs Class
XdsObjects Namespace


XdsGlobal.LogEventArgs Class Properties

XdsGlobal.LogEventArgs Class Properties

XdsObjects Namespace : XdsGlobal.LogEventArgs Class

For a list of all members of this type, see XdsGlobal.LogEventArgs members.

Public Properties
 | Name | Description
Public Property | Level | The level of the event being logged
Public Property | Text | The test of the association
Top
See Also

Reference

XdsGlobal.LogEventArgs Class
XdsObjects Namespace


Level Property

Level Property

XdsObjects Namespace > XdsGlobal.LogEventArgs Class : Level Property
The level of the event being logged
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property Level As LogLevel
Dim instance As XdsGlobal.LogEventArgs
Dim value As LogLevel

value = instance.Level
public LogLevel Level {get;}
public:
property LogLevel Level {
   LogLevel get();
}
Remarks
See DicomObjects.DicomGlobal.LogToFile for the meaning of this level
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsGlobal.LogEventArgs Class
XdsGlobal.LogEventArgs Members


Text Property

Text Property

XdsObjects Namespace > XdsGlobal.LogEventArgs Class : Text Property
The test of the association
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property Text As String
Dim instance As XdsGlobal.LogEventArgs
Dim value As String

value = instance.Text
public string Text {get;}
public:
property String^ Text {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsGlobal.LogEventArgs Class
XdsGlobal.LogEventArgs Members


XdsImagingClient Class

XdsImagingClient Class
Members

XdsObjects Namespace : XdsImagingClient Class
Class which handles the multiple complexities involved in the XDS-I profile as a document consumer
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsImagingClient
Dim instance As XdsImagingClient
public class XdsImagingClient
public ref class XdsImagingClient
Remarks

Some of the functionality in this classdepends on DicomObjects - see Using DicomObjects with XdsObjects for more details.

Inheritance Hierarchy

System.Object
XdsObjects.XdsImagingClient

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsImagingClient Members
XdsObjects Namespace


XdsImagingClient Class Members

XdsImagingClient Class Members
Properties Methods

XdsObjects Namespace : XdsImagingClient Class

The following tables list the members exposed by XdsImagingClient.

Public Constructors
 | Name | Description
Public Constructor | XdsImagingClient Constructor | Create a new empty XdsImagingClient object
Top
Public Properties
 | Name | Description
Public Property | AcceptedTransferSyntaxes | The list of acceptable transfer syntaxes to be included in a Rad-69 request
Public Property | XdsDomain | XdsDomain objects used for specialised modifications to Rad69 bindings etc.
Top
Public Methods
 | Name | Description
Public Method | AddCMoveEndpoint | Specifies an endpoint to be used for the DICOM image retrieval method
Public Method | AddWebServiceEndpoint | Specifies an endpoint to be used for the RAD-69 or WADO image retrieval methods
Public Method | ClearAETs | Clear the list of known XDS-I endpoints.
Public Method | CreateRequestsFromKOS | Create a list of XdsImagingRetrieveRequest objects corresponding to a DICOM KOS object
Public Method | RetrieveImages | Retrieve set of images using Rad69, DICOM or WADO
Public Method | RetrieveObjects | Do a "raw" RetrieveImagingDocumentSet or WADO transaction
Top
See Also

Reference

XdsImagingClient Class
XdsObjects Namespace


XdsImagingClient Constructor

XdsImagingClient Constructor

XdsObjects Namespace > XdsImagingClient Class : XdsImagingClient Constructor
Create a new empty XdsImagingClient object
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsImagingClient()
public XdsImagingClient()
public:
XdsImagingClient();
Remarks
Default values of implicit VR little endian and JPEG lossless (1st order) are added to the AcceptedTransferSyntaxes collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsImagingClient Class
XdsImagingClient Members


XdsImagingClient Class Methods

XdsImagingClient Class Methods

XdsObjects Namespace : XdsImagingClient Class

For a list of all members of this type, see XdsImagingClient members.

Public Methods
 | Name | Description
Public Method | AddCMoveEndpoint | Specifies an endpoint to be used for the DICOM image retrieval method
Public Method | AddWebServiceEndpoint | Specifies an endpoint to be used for the RAD-69 or WADO image retrieval methods
Public Method | ClearAETs | Clear the list of known XDS-I endpoints.
Public Method | CreateRequestsFromKOS | Create a list of XdsImagingRetrieveRequest objects corresponding to a DICOM KOS object
Public Method | RetrieveImages | Retrieve set of images using Rad69, DICOM or WADO
Public Method | RetrieveObjects | Do a "raw" RetrieveImagingDocumentSet or WADO transaction
Top
See Also

Reference

XdsImagingClient Class
XdsObjects Namespace


AddCMoveEndpoint Method

AddCMoveEndpoint Method

XdsObjects Namespace > XdsImagingClient Class : AddCMoveEndpoint Method
The DICOM AET (as found in a KOS object) to be linked to this endpoint

The Repository OID (as found in a KOS object) for this endpoint.

This parameter is not required (and may be null) for DICOM retrieval when the KOS object references the source by AET, but may be necessary where the KOS contains an repository OID instead

The DICOM host to pass the C-MOVE request to
The DICOM port to pass the C-MOVE request to
The Calling AET to use when sending the C-MOVE request
The Called AET to use when sending the C-MOVE request. This will normally be the same as the AET, but may sometimes be different.
A MedicalConnections.Security.ITlsClientSecurity object to use when using DICOM over TLS
Specifies an endpoint to be used for the DICOM image retrieval method
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub AddCMoveEndpoint( _
   ByVal AET As String, _
   ByVal OID As String, _
   ByVal Host As String, _
   ByVal Port As Integer, _
   ByVal LocalAET As String, _
   ByVal RemoteAET As String, _
   ByVal Security As ITlsClientSecurity _
)
Dim instance As XdsImagingClient
Dim AET As String
Dim OID As String
Dim Host As String
Dim Port As Integer
Dim LocalAET As String
Dim RemoteAET As String
Dim Security As ITlsClientSecurity

instance.AddCMoveEndpoint(AET, OID, Host, Port, LocalAET, RemoteAET, Security)
public void AddCMoveEndpoint(
   string AET,
   string OID,
   string Host,
   int Port,
   string LocalAET,
   string RemoteAET,
   ITlsClientSecurity Security
)
public:
void AddCMoveEndpoint(
   String^ AET,
   String^ OID,
   String^ Host,
   int Port,
   String^ LocalAET,
   String^ RemoteAET,
   ITlsClientSecurity^ Security
)

Parameters

AET
The DICOM AET (as found in a KOS object) to be linked to this endpoint
OID

The Repository OID (as found in a KOS object) for this endpoint.

This parameter is not required (and may be null) for DICOM retrieval when the KOS object references the source by AET, but may be necessary where the KOS contains an repository OID instead

Host
The DICOM host to pass the C-MOVE request to
Port
The DICOM port to pass the C-MOVE request to
LocalAET
The Calling AET to use when sending the C-MOVE request
RemoteAET
The Called AET to use when sending the C-MOVE request. This will normally be the same as the AET, but may sometimes be different.
Security
A MedicalConnections.Security.ITlsClientSecurity object to use when using DICOM over TLS
Requirements
DicomObjects
See Also

Reference

XdsImagingClient Class
XdsImagingClient Members


AddWebServiceEndpoint Method

AddWebServiceEndpoint Method

XdsObjects Namespace > XdsImagingClient Class : AddWebServiceEndpoint Method
The DICOM AET (as found in a KOS object) to be linked to this endpoint

The Repository OID (as found in a KOS object, or linked via an AET) for this endpoint.

This parameter is mandatory for Rad-69 retrieval, but optional (i.e. may be null) for WADO (provided that an AET is provided), which allows direct linkage of an AET to a web endpoint address

The full web service endpoint, complete with http:// or https:// prefix
The mthod to use. This must be Rad69, Wado_Jpg or Wado_Dicom
A MedicalConnections.Security.ITlsClientSecurity object to use when using DICOM over TLS
Specifies an endpoint to be used for the RAD-69 or WADO image retrieval methods
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub AddWebServiceEndpoint( _
   ByVal AET As String, _
   ByVal OID As String, _
   ByVal Endpoint As String, _
   ByVal Method As XdsIRetrievalMethod, _
   ByVal Security As ITlsClientSecurity _
)
Dim instance As XdsImagingClient
Dim AET As String
Dim OID As String
Dim Endpoint As String
Dim Method As XdsIRetrievalMethod
Dim Security As ITlsClientSecurity

instance.AddWebServiceEndpoint(AET, OID, Endpoint, Method, Security)
public void AddWebServiceEndpoint(
   string AET,
   string OID,
   string Endpoint,
   XdsIRetrievalMethod Method,
   ITlsClientSecurity Security
)
public:
void AddWebServiceEndpoint(
   String^ AET,
   String^ OID,
   String^ Endpoint,
   XdsIRetrievalMethod Method,
   ITlsClientSecurity^ Security
)

Parameters

AET
The DICOM AET (as found in a KOS object) to be linked to this endpoint
OID

The Repository OID (as found in a KOS object, or linked via an AET) for this endpoint.

This parameter is mandatory for Rad-69 retrieval, but optional (i.e. may be null) for WADO (provided that an AET is provided), which allows direct linkage of an AET to a web endpoint address

Endpoint
The full web service endpoint, complete with http:// or https:// prefix
Method
The mthod to use. This must be Rad69, Wado_Jpg or Wado_Dicom
Security
A MedicalConnections.Security.ITlsClientSecurity object to use when using DICOM over TLS
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsImagingClient Class
XdsImagingClient Members


ClearAETs Method

ClearAETs Method

XdsObjects Namespace > XdsImagingClient Class : ClearAETs Method
Clear the list of known XDS-I endpoints.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub ClearAETs()
Dim instance As XdsImagingClient

instance.ClearAETs()
public void ClearAETs()
public:
void ClearAETs();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsImagingClient Class
XdsImagingClient Members


CreateRequestsFromKOS Method

CreateRequestsFromKOS Method

XdsObjects Namespace > XdsImagingClient Class : CreateRequestsFromKOS Method
The DICOM KOS object being used
Create a list of XdsImagingRetrieveRequest objects corresponding to a DICOM KOS object
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function CreateRequestsFromKOS( _
   ByVal KOS As DicomObjects.DicomDataSet _
) As List(Of XdsImagingRetrieveRequest)
Dim instance As XdsImagingClient
Dim KOS As DicomObjects.DicomDataSet
Dim value As List(Of XdsImagingRetrieveRequest)

value = instance.CreateRequestsFromKOS(KOS)
public List<XdsImagingRetrieveRequest> CreateRequestsFromKOS(
   DicomObjects.DicomDataSet KOS
)
public:
List<XdsImagingRetrieveRequest^>^ CreateRequestsFromKOS(
   DicomObjects.DicomDataSet^ KOS
)

Parameters

KOS
The DICOM KOS object being used

Return Value

Create a list of XdsImagingRetrieveRequest objects
Remarks

Currently, this method returns on request per series, as the KOS is permitted to include multiple series each available from a different endpoint.

Either the RepositoryUID(0040,E011) - if present or if not, the AET(0008,0054) is used to identify the endpoint to retrive the images from, using lookup information previously set up via calls to AddWebServiceEndpoint

Although the structure returned is based o that needed for a RetrieveImagingDocumentSet (Rad-69) transaction, it may equally well be used for retrieval via WADO

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsImagingClient Class
XdsImagingClient Members


RetrieveImages(DicomDataSet) Method

RetrieveImages(DicomDataSet) Method

XdsObjects Namespace > XdsImagingClient Class : RetrieveImages(DicomDataSet) Method
The DICOM KOS images listing the images together with their AET and/or Image Source OIDs
Retrieve set of images using Rad69, DICOM or WADO
Methods to retrieve images using any of the methods in the XDS-I specification
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function RetrieveImages( _
   ByVal KOS As DicomObjects.DicomDataSet _
) As DicomObjects.DicomDataSetCollection
Dim instance As XdsImagingClient
Dim KOS As DicomObjects.DicomDataSet
Dim value As DicomObjects.DicomDataSetCollection

value = instance.RetrieveImages(KOS)
public DicomObjects.DicomDataSetCollection RetrieveImages(
   DicomObjects.DicomDataSet KOS
)
public:
DicomObjects.DicomDataSetCollection^ RetrieveImages(
   DicomObjects.DicomDataSet^ KOS
)

Parameters

KOS
The DICOM KOS images listing the images together with their AET and/or Image Source OIDs

Return Value

Collection of returned objects
Remarks

The AddWebServiceEndpoint or AddCMoveEndpoint methods must have been called before using this method to "set up" the XdsImagingClient object to provide the linkage between AET/OID and retrieval endpoints

If the retrieval method is Wado_Jpg, then the images returned by this method are temporary objects, imported from the supplied JPEG image(s)

Unlike RetrieveObjects, this method Requires DicomObjects, to interpret the KOS and to provide the structure for the return results

If necessary, multiple requests will be sent to different sources, if that is how the data in the KOS object is configured.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsImagingClient Class
XdsImagingClient Members


RetrieveObjects Method

RetrieveObjects Method

XdsObjects Namespace > XdsImagingClient Class : RetrieveObjects Method
The request to send, including the OID of the image source.
The XDS Domain used as part of the retrieval
Do a "raw" RetrieveImagingDocumentSet or WADO transaction
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function RetrieveObjects( _
   ByVal Request As XdsImagingRetrieveRequest, _
   ByVal Domain As XdsDomain _
) As List(Of XdsDocument)
Dim instance As XdsImagingClient
Dim Request As XdsImagingRetrieveRequest
Dim Domain As XdsDomain
Dim value As List(Of XdsDocument)

value = instance.RetrieveObjects(Request, Domain)
public List<XdsDocument> RetrieveObjects(
   XdsImagingRetrieveRequest Request,
   XdsDomain Domain
)
public:
List<XdsDocument^>^ RetrieveObjects(
   XdsImagingRetrieveRequest^ Request,
   XdsDomain^ Domain
)

Parameters

Request
The request to send, including the OID of the image source.
Domain
The XDS Domain used as part of the retrieval

Return Value

Listof XdsDocument objects
Remarks

This sends a single transaction, and unlike RetrieveImages(DicomDataSet) does not require use of DicomObjects, since it is the responsibility of the calling application to populate the request fully.

The use of the XdsDocument type for the return values is something of an overkill, but it does enable the Data and its associated MimeType to be associated with asociated with each specific requested item, since the InstanceUIDs are placed into the UniqueID for each result.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsImagingClient Class
XdsImagingClient Members


XdsImagingClient Class Properties

XdsImagingClient Class Properties

XdsObjects Namespace : XdsImagingClient Class

For a list of all members of this type, see XdsImagingClient members.

Public Properties
 | Name | Description
Public Property | AcceptedTransferSyntaxes | The list of acceptable transfer syntaxes to be included in a Rad-69 request
Public Property | XdsDomain | XdsDomain objects used for specialised modifications to Rad69 bindings etc.
Top
See Also

Reference

XdsImagingClient Class
XdsObjects Namespace


AcceptedTransferSyntaxes Property

AcceptedTransferSyntaxes Property

XdsObjects Namespace > XdsImagingClient Class : AcceptedTransferSyntaxes Property
The list of acceptable transfer syntaxes to be included in a Rad-69 request
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property AcceptedTransferSyntaxes As List(Of String)
Dim instance As XdsImagingClient
Dim value As List(Of String)

instance.AcceptedTransferSyntaxes = value

value = instance.AcceptedTransferSyntaxes
public List<string> AcceptedTransferSyntaxes {get; set;}
public:
property List<String^>^ AcceptedTransferSyntaxes {
   List<String^>^ get();
   void set (    List<String^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsImagingClient Class
XdsImagingClient Members


XdsDomain Property

XdsDomain Property

XdsObjects Namespace > XdsImagingClient Class : XdsDomain Property
XdsDomain objects used for specialised modifications to Rad69 bindings etc.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property XdsDomain As XdsDomain
Dim instance As XdsImagingClient
Dim value As XdsDomain

instance.XdsDomain = value

value = instance.XdsDomain
public XdsDomain XdsDomain {get; set;}
public:
property XdsDomain^ XdsDomain {
   XdsDomain^ get();
   void set (    XdsDomain^ value);
}
Remarks
This is not used for most scenarios
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsImagingClient Class
XdsImagingClient Members


XdsImagingRetrieveRequest Class

XdsImagingRetrieveRequest Class
Members

XdsObjects Namespace : XdsImagingRetrieveRequest Class
Class which holds a complete request as used in the XDS RetrieveImageDocumentSet transaction (RAD-69)
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsImagingRetrieveRequest
Dim instance As XdsImagingRetrieveRequest
public class XdsImagingRetrieveRequest
public ref class XdsImagingRetrieveRequest
Remarks

Unlike the XdsRetrieveRequest item used for retieving documents, there is a structure to the data requests which are held hierarchically in DicomStudy and with those, DicomSeries objects, but the 2 processes share the same XdsRetrieveResponse to hold the results.

Inheritance Hierarchy

System.Object
XdsObjects.XdsImagingRetrieveRequest

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsImagingRetrieveRequest Members
XdsObjects Namespace


XdsImagingRetrieveRequest Class Members

XdsImagingRetrieveRequest Class Members
Properties

XdsObjects Namespace : XdsImagingRetrieveRequest Class

The following tables list the members exposed by XdsImagingRetrieveRequest.

Public Constructors
 | Name | Description
Public Constructor | XdsImagingRetrieveRequest Constructor | Create a new, empty XdsImagingRetrieveHandler
Top
Public Properties
 | Name | Description
Public Property | HomeCommunityId | Optional, corresponds to the home attribute of the Identifiable class
Public Property | RepositoryUniqueId | The OID of the Image Source to which this request should be directed
Public Property | Studies | The hierarchical list of studies (each of which contains DicomSeries objects) to be be retrieved.
Public Property | TransferSyntaxes | The list of acceptable DICOM transfer syntaxes
Top
See Also

Reference

XdsImagingRetrieveRequest Class
XdsObjects Namespace


XdsImagingRetrieveRequest Constructor

XdsImagingRetrieveRequest Constructor

XdsObjects Namespace > XdsImagingRetrieveRequest Class : XdsImagingRetrieveRequest Constructor
Create a new, empty XdsImagingRetrieveHandler
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsImagingRetrieveRequest()
public XdsImagingRetrieveRequest()
public:
XdsImagingRetrieveRequest();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsImagingRetrieveRequest Class
XdsImagingRetrieveRequest Members


XdsImagingRetrieveRequest Class Properties

XdsImagingRetrieveRequest Class Properties

XdsObjects Namespace : XdsImagingRetrieveRequest Class

For a list of all members of this type, see XdsImagingRetrieveRequest members.

Public Properties
 | Name | Description
Public Property | HomeCommunityId | Optional, corresponds to the home attribute of the Identifiable class
Public Property | RepositoryUniqueId | The OID of the Image Source to which this request should be directed
Public Property | Studies | The hierarchical list of studies (each of which contains DicomSeries objects) to be be retrieved.
Public Property | TransferSyntaxes | The list of acceptable DICOM transfer syntaxes
Top
See Also

Reference

XdsImagingRetrieveRequest Class
XdsObjects Namespace


HomeCommunityId Property (XdsImagingRetrieveRequest)

HomeCommunityId Property (XdsImagingRetrieveRequest)

XdsObjects Namespace > XdsImagingRetrieveRequest Class : HomeCommunityId Property
Optional, corresponds to the home attribute of the Identifiable class
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property HomeCommunityId As String
Dim instance As XdsImagingRetrieveRequest
Dim value As String

instance.HomeCommunityId = value

value = instance.HomeCommunityId
public string HomeCommunityId {get; set;}
public:
property String^ HomeCommunityId {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsImagingRetrieveRequest Class
XdsImagingRetrieveRequest Members


RepositoryUniqueId Property (XdsImagingRetrieveRequest)

RepositoryUniqueId Property (XdsImagingRetrieveRequest)

XdsObjects Namespace > XdsImagingRetrieveRequest Class : RepositoryUniqueId Property
The OID of the Image Source to which this request should be directed
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property RepositoryUniqueId As String
Dim instance As XdsImagingRetrieveRequest
Dim value As String

instance.RepositoryUniqueId = value

value = instance.RepositoryUniqueId
public string RepositoryUniqueId {get; set;}
public:
property String^ RepositoryUniqueId {
   String^ get();
   void set (    String^ value);
}
Remarks
The endpoint is found from previously configured entries via AddCMoveEndpoint and AddWebServiceEndpoint
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsImagingRetrieveRequest Class
XdsImagingRetrieveRequest Members


Studies Property

Studies Property

XdsObjects Namespace > XdsImagingRetrieveRequest Class : Studies Property
The hierarchical list of studies (each of which contains DicomSeries objects) to be be retrieved.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Studies As List(Of DicomStudy)
Dim instance As XdsImagingRetrieveRequest
Dim value As List(Of DicomStudy)

instance.Studies = value

value = instance.Studies
public List<DicomStudy> Studies {get; set;}
public:
property List<DicomStudy^>^ Studies {
   List<DicomStudy^>^ get();
   void set (    List<DicomStudy^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsImagingRetrieveRequest Class
XdsImagingRetrieveRequest Members


TransferSyntaxes Property

TransferSyntaxes Property

XdsObjects Namespace > XdsImagingRetrieveRequest Class : TransferSyntaxes Property
The list of acceptable DICOM transfer syntaxes
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property TransferSyntaxes As List(Of String)
Dim instance As XdsImagingRetrieveRequest
Dim value As List(Of String)

instance.TransferSyntaxes = value

value = instance.TransferSyntaxes
public List<string> TransferSyntaxes {get; set;}
public:
property List<String^>^ TransferSyntaxes {
   List<String^>^ get();
   void set (    List<String^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsImagingRetrieveRequest Class
XdsImagingRetrieveRequest Members


XdsImagingServer Class

XdsImagingServer Class
Members

XdsObjects Namespace : XdsImagingServer Class
Class which handles requests for images using the RetriveImageDocumentSet (RAD-69) tranaction
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsImagingServer
Dim instance As XdsImagingServer
public class XdsImagingServer
public ref class XdsImagingServer
Remarks

This class is closely related to the XdsMtomServer class, but is specialised to handle images.

DicomObjects is not required for use of this object, but it is useful if transfer syntax converisons are necessary.

Inheritance Hierarchy

System.Object
XdsObjects.XdsImagingServer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsImagingServer Members
XdsObjects Namespace


XdsImagingServer Class Members

XdsImagingServer Class Members
Methods Events

XdsObjects Namespace : XdsImagingServer Class

The following tables list the members exposed by XdsImagingServer.

Public Constructors
 | Name | Description
Public Constructor | XdsImagingServer Constructor | Construct a new XdsImagingServer object
Top
Public Methods
 | Name | Description
Public Method | Listen | Specify an endpoint for listening
Public Method | UnListenAll | Stops listening on all Addresses
Top
Public Events
 | Name | Description
Public Event | ImageRequestReceived | Event wchih is fired when a RetrieveImagingDocumentSet request is received
Top
See Also

Reference

XdsImagingServer Class
XdsObjects Namespace


XdsImagingServer Constructor

XdsImagingServer Constructor

XdsObjects Namespace > XdsImagingServer Class : XdsImagingServer Constructor
Construct a new XdsImagingServer object
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsImagingServer()
public XdsImagingServer()
public:
XdsImagingServer();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsImagingServer Class
XdsImagingServer Members


XdsImagingServer Class Methods

XdsImagingServer Class Methods

XdsObjects Namespace : XdsImagingServer Class

For a list of all members of this type, see XdsImagingServer members.

Public Methods
 | Name | Description
Public Method | Listen | Specify an endpoint for listening
Public Method | UnListenAll | Stops listening on all Addresses
Top
See Also

Reference

XdsImagingServer Class
XdsObjects Namespace


Listen Method (XdsImagingServer)

Listen Method (XdsImagingServer)

XdsObjects Namespace > XdsImagingServer Class : Listen Method
The address (URL) to listen on
Specify an endpoint for listening
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub Listen( _
   ByVal Address As String _
)
Dim instance As XdsImagingServer
Dim Address As String

instance.Listen(Address)
public void Listen(
   string Address
)
public:
void Listen(
   String^ Address
)

Parameters

Address
The address (URL) to listen on
Remarks

A server can listen on multiple endpoint addresses

If secure listening is required, the port and certificate must be configured using httpcfg or (for Vista/Windows 7) netsh - see Server Certificates for more details

Example
serverobject.Listen("http://myservername:8080/MyLIsteningEndpoint)serverobject.Listen("https://myservername:8080/MySecureLsteningEndpoint)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsImagingServer Class
XdsImagingServer Members


UnListenAll Method (XdsImagingServer)

UnListenAll Method (XdsImagingServer)

XdsObjects Namespace > XdsImagingServer Class : UnListenAll Method
Stops listening on all Addresses
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub UnListenAll()
Dim instance As XdsImagingServer

instance.UnListenAll()
public void UnListenAll()
public:
void UnListenAll();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsImagingServer Class
XdsImagingServer Members


XdsImagingServer Class Events

XdsImagingServer Class Events

XdsObjects Namespace : XdsImagingServer Class

For a list of all members of this type, see XdsImagingServer members.

Public Events
 | Name | Description
Public Event | ImageRequestReceived | Event wchih is fired when a RetrieveImagingDocumentSet request is received
Top
See Also

Reference

XdsImagingServer Class
XdsObjects Namespace


ImageRequestReceived Event

ImageRequestReceived Event

XdsObjects Namespace > XdsImagingServer Class : ImageRequestReceived Event
Event wchih is fired when a RetrieveImagingDocumentSet request is received
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Event ImageRequestReceived As ImagingRetrieveHandler
Dim instance As XdsImagingServer
Dim handler As ImagingRetrieveHandler

AddHandler instance.ImageRequestReceived, handler
public event ImagingRetrieveHandler ImageRequestReceived
public:
event ImagingRetrieveHandler^ ImageRequestReceived
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsImagingServer Class
XdsImagingServer Members


XdsInternationalString Class

XdsInternationalString Class
Members

XdsObjects Namespace : XdsInternationalString Class
Represent an emXML InternationalString
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsInternationalString
Dim instance As XdsInternationalString
public class XdsInternationalString
public ref class XdsInternationalString
Remarks

Many data structures in XDS allow a string to have multiple different representations for different languages. e.g. an XdsCode has unique CodingScheme and CodeValue properties (which are therefore simple strings) but CodeMeaning the human readable version is an XdsInternationalString, since different interpretations may be provided for different languages.

In most cases, this class may be used as if it were a simple string, since there are implicit conversions to and from simple strings, using the default language code, as defined by XdsGlobal.DefaultLanguage.

Inheritance Hierarchy

System.Object
XdsObjects.XdsInternationalString

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsInternationalString Members
XdsObjects Namespace


XdsInternationalString Class Members

XdsInternationalString Class Members
Properties Methods

XdsObjects Namespace : XdsInternationalString Class

The following tables list the members exposed by XdsInternationalString.

Public Constructors
 | Name | Description
Public Constructor | XdsInternationalString Constructor | Create an XdsInternationalString holding a single value
Top
Public Properties
 | Name | Description
Public Property | AllValues | Format all the contents of an XdsInternationalString for serialization.
Top
Public Methods
 | Name | Description
Public Method | AddAdditionalLanguage | Add an additional language for an XdsInternationalString
Public Method | Equals | Returns true if Strings are same
Public Method | GetHashCode | Return Hash code for Strings
Public Method | ToString | Standard override - equivelent to the implicit cast to string
Top
Public Operators
public Operator Implicit Type Conversion Overloaded. implicit operators to convert between XdsInternaitonString and String
Top
See Also

Reference

XdsInternationalString Class
XdsObjects Namespace


XdsInternationalString Constructor(String)

XdsInternationalString Constructor(String)

XdsObjects Namespace > XdsInternationalString Class > XdsInternationalString Constructor : XdsInternationalString Constructor(String)
Create an XdsInternationalString holding a single value
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal s As String _
)
Dim s As String

Dim instance As New XdsInternationalString(s)
public XdsInternationalString(
   string s
)
public:
XdsInternationalString(
   String^ s
)

Parameters

s
Remarks

The item is assigned the current default lnguage code, as defined by XdsGlobal.DefaultLanguage

This constructor is rarely used/needed, as the implicit conversion from string normally provide a simpler and more intuitive syntax.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsInternationalString Class
XdsInternationalString Members
Overload List


XdsInternationalString Class Methods

XdsInternationalString Class Methods

XdsObjects Namespace : XdsInternationalString Class

For a list of all members of this type, see XdsInternationalString members.

Public Methods
 | Name | Description
Public Method | AddAdditionalLanguage | Add an additional language for an XdsInternationalString
Public Method | Equals | Returns true if Strings are same
Public Method | GetHashCode | Return Hash code for Strings
Public Method | ToString | Standard override - equivelent to the implicit cast to string
Top
See Also

Reference

XdsInternationalString Class
XdsObjects Namespace


AddAdditionalLanguage Method

AddAdditionalLanguage Method

XdsObjects Namespace > XdsInternationalString Class : AddAdditionalLanguage Method
The code of the language to add
The value in the chosen language
Add an additional language for an XdsInternationalString
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub AddAdditionalLanguage( _
   ByVal Language As String, _
   ByVal Value As String _
)
Dim instance As XdsInternationalString
Dim Language As String
Dim Value As String

instance.AddAdditionalLanguage(Language, Value)
public void AddAdditionalLanguage(
   string Language,
   string Value
)
public:
void AddAdditionalLanguage(
   String^ Language,
   String^ Value
)

Parameters

Language
The code of the language to add
Value
The value in the chosen language
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsInternationalString Class
XdsInternationalString Members


Equals Method (XdsInternationalString)

Equals Method (XdsInternationalString)

XdsObjects Namespace > XdsInternationalString Class : Equals Method
Returns true if Strings are same
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
Dim instance As XdsInternationalString
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsInternationalString Class
XdsInternationalString Members
Base Implementation in Equals


GetHashCode Method (XdsInternationalString)

GetHashCode Method (XdsInternationalString)

XdsObjects Namespace > XdsInternationalString Class : GetHashCode Method
Return Hash code for Strings
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overrides Function GetHashCode() As Integer
Dim instance As XdsInternationalString
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsInternationalString Class
XdsInternationalString Members
Base Implementation in GetHashCode


ToString Method (XdsInternationalString)

ToString Method (XdsInternationalString)

XdsObjects Namespace > XdsInternationalString Class : ToString Method
Standard override - equivelent to the implicit cast to string
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overrides Function ToString() As String
Dim instance As XdsInternationalString
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsInternationalString Class
XdsInternationalString Members
Base Implementation in ToString


XdsInternationalString Class Properties

XdsInternationalString Class Properties

XdsObjects Namespace : XdsInternationalString Class

For a list of all members of this type, see XdsInternationalString members.

Public Properties
 | Name | Description
Public Property | AllValues | Format all the contents of an XdsInternationalString for serialization.
Top
See Also

Reference

XdsInternationalString Class
XdsObjects Namespace


AllValues Property (XdsInternationalString)

AllValues Property (XdsInternationalString)

XdsObjects Namespace > XdsInternationalString Class : AllValues Property
Format all the contents of an XdsInternationalString for serialization.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property AllValues As String
Dim instance As XdsInternationalString
Dim value As String

instance.AllValues = value

value = instance.AllValues
public string AllValues {get; set;}
public:
property String^ AllValues {
   String^ get();
   void set (    String^ value);
}
Remarks

This is a specialist property which is intended purely for serialization or with the Code First Entity Framework to allow the contents to be persisted to and restored from a simgle string.

The format is pairs of lines, the first of each being the "key" (language code), and the second being the "value" - the string in that language.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsInternationalString Class
XdsInternationalString Members


Implicit Type Conversion Operator (XdsInternationalString)

Implicit Type Conversion Operator (XdsInternationalString)

XdsObjects Namespace > XdsInternationalString Class : Implicit Type Conversion Operator
implicit operators to convert between XdsInternaitonString and String
Overload List
Overload | Description
Implicit Type Conversion(XdsInternationalString,String) | Create an XdsInternationalString holding a single value from a sting
Implicit Type Conversion(String,XdsInternationalString) | Return the most appropriate single string from those available
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsInternationalString Class
XdsInternationalString Members


XdsLicense Class

XdsLicense Class
Members

XdsObjects Namespace : XdsLicense Class
This class handles all the new licensing scheme for XdsObjects.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsLicense
Dim instance As XdsLicense
public class XdsLicense
public ref class XdsLicense
Remarks
This class both represents an individual license issued to allow use of XdsObjects on a particular machine, and also acts as a placeholder for many static (shared in VB) methods and properties which allow licenses to be listed, obtained (off-line or on-line) selected and deleted
Inheritance Hierarchy

System.Object
XdsObjects.XdsLicense

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Members
XdsObjects Namespace


XdsLicense Class Members

XdsLicense Class Members
Properties Methods Events

XdsObjects Namespace : XdsLicense Class

The following tables list the members exposed by XdsLicense.

Public Properties
 | Name | Description
Public Property | AllowedFunctions | The functions which this license allows XdsObjects to perform
Public Property | AuthorisationID | The numeric ID of the Authorisation String which was used to generate this license
static (Shared in Visual Basic) | CurrentLicense | The XdsLicense current in use
static (Shared in Visual Basic) | Dialog | Static LicenseDialog used to inform the user about license problems
Public Property | Expiry | The expiry date of the license
static (Shared in Visual Basic) | ExpiryWarningDays | Number of days before expiry to start issuing warnings
static (Shared in Visual Basic) | ExpiryWarningPeriod | Warning period to give the user of license expiry
static (Shared in Visual Basic) | InstalledLicenses | The list of currently available licenses.
Public Property | IsStrongName | Indicates whether the license is derived from the strong name of the calling program
Public Property | LicenseID | The ID for this particular license
static (Shared in Visual Basic) | LicenseServer | Specifies the server to be used to obtain on-line licenses This is an advanced property only to be used under directions from Medical Connections
static (Shared in Visual Basic) | LicenseServerCount | Specifies the how many license servers are to be tried to obtain on-line licenses This is an advanced property only to be used under directions from Medical Connections
Public Property | LicenseToken | The license token which activated this licnense.
Public Property | LicenseType | The Type (Full, Trial or Developer) of this license.
static (Shared in Visual Basic) | MachineID | A unique string for each machine.
static (Shared in Visual Basic) | ProxyDomain | Domain to be used if the machine's web proxy requires authentication.
static (Shared in Visual Basic) | ProxyPassword | Password to be used if the machine's web proxy requires authentication.
static (Shared in Visual Basic) | ProxyUsername | Username to be used if the machine's web proxy requires authentication.
Public Property | Start | The start date of the license
static (Shared in Visual Basic) | WebService | The Web Service used for on-line activation
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | ActivateOffLine | Activate using an LicenseToken obtained off-line
static (Shared in Visual Basic) | ActivateOnLine | Attempt to obtain a XdsObjects license on-line
Public Method | Delete | Delete a specific XdsObjects license on a machine.
static (Shared in Visual Basic) | DeleteAllLicenses | Delete all XdsObjects licenses on a machine.
static (Shared in Visual Basic) | GetLicense | Overloaded. Select a license
Public Method | ToString | Provides a summary of the functions, type, origin and expiry date of the license
Top
Public Events
 | Name | Description
Public Event | RetrieveLicense | Event fired when XdsObjects needs to retrieve a previously stored license
Public Event | StoreLicense | Event fires when XdsObjects needs to store a license
Top
See Also

Reference

XdsLicense Class
XdsObjects Namespace


XdsLicense Class Methods

XdsLicense Class Methods

XdsObjects Namespace : XdsLicense Class

For a list of all members of this type, see XdsLicense members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | ActivateOffLine | Activate using an LicenseToken obtained off-line
static (Shared in Visual Basic) | ActivateOnLine | Attempt to obtain a XdsObjects license on-line
Public Method | Delete | Delete a specific XdsObjects license on a machine.
static (Shared in Visual Basic) | DeleteAllLicenses | Delete all XdsObjects licenses on a machine.
static (Shared in Visual Basic) | GetLicense | Overloaded. Select a license
Public Method | ToString | Provides a summary of the functions, type, origin and expiry date of the license
Top
See Also

Reference

XdsLicense Class
XdsObjects Namespace


ActivateOffLine Method

ActivateOffLine Method

XdsObjects Namespace > XdsLicense Class : ActivateOffLine Method
The string provided by Medical Connections, allowing you to activate XdsObjects
The string obtained from the license server
An "out" parameter, into which an explantion of the result is placed.
Activate using an LicenseToken obtained off-line
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Function ActivateOffLine( _
   ByVal AuthorisationString As String, _
   ByVal LicenseToken As String, _
   ByRef Result As String _
) As XdsLicense
Dim AuthorisationString As String
Dim LicenseToken As String
Dim Result As String
Dim value As XdsLicense

value = XdsLicense.ActivateOffLine(AuthorisationString, LicenseToken, Result)
public static XdsLicense ActivateOffLine(
   string AuthorisationString,
   string LicenseToken,
   out string Result
)
public:
static XdsLicense^ ActivateOffLine(
   String^ AuthorisationString,
   String^ LicenseToken,
   [Out] String^ Result
)

Parameters

AuthorisationString
The string provided by Medical Connections, allowing you to activate XdsObjects
LicenseToken
The string obtained from the license server
Result
An "out" parameter, into which an explantion of the result is placed.

Return Value

A valid XdsLicense object if the activation succeeded or if already activated using this Authorisation string.

null if the activation failed.

Remarks

This method may be used where the machine being activated does not have a direct Internet connection. The same information as would be used by ActivateOnLine is entered into the web site http://activation.medicalconnections.co.uk using a separate machine which will return a LicenseToken, which should then be used in this method

Like the ActivateOnLine method, this method is called internally on request from the LicenseDialog form

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


ActivateOnLine Method

ActivateOnLine Method

XdsObjects Namespace > XdsLicense Class : ActivateOnLine Method
The string provided by Medical Connections, allowing you to activate XdsObjects
A string identifying the PC and or institution at which this copy is being activated
A second string with the same function
An "out" parameter, into which an explantion of the result is placed.
Attempt to obtain a XdsObjects license on-line
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Function ActivateOnLine( _
   ByVal AuthorisationString As String, _
   ByVal CustomerInfo1 As String, _
   ByVal CustomerInfo2 As String, _
   ByRef Result As String _
) As XdsLicense
Dim AuthorisationString As String
Dim CustomerInfo1 As String
Dim CustomerInfo2 As String
Dim Result As String
Dim value As XdsLicense

value = XdsLicense.ActivateOnLine(AuthorisationString, CustomerInfo1, CustomerInfo2, Result)
public static XdsLicense ActivateOnLine(
   string AuthorisationString,
   string CustomerInfo1,
   string CustomerInfo2,
   out string Result
)
public:
static XdsLicense^ ActivateOnLine(
   String^ AuthorisationString,
   String^ CustomerInfo1,
   String^ CustomerInfo2,
   [Out] String^ Result
)

Parameters

AuthorisationString
The string provided by Medical Connections, allowing you to activate XdsObjects
CustomerInfo1
A string identifying the PC and or institution at which this copy is being activated
CustomerInfo2
A second string with the same function
Result
An "out" parameter, into which an explantion of the result is placed.

Return Value

A valid XdsLicense object if the activation succeeded or if already activated using this Authorisation string.

null if the activation failed.

Remarks

This is the main method used to activate a XdsObjects license, and is used both explicitly by developers and internally by the LicenseDialog when so requested.

The result indicates whether the method succeeded, and further information (whether successful or not) is available in the Result paramaeter

If a license has previously been activated on the same machine, using the same authorisation string, then the method returns true, but the fact is noted in the Result

The license server to be contacted is specified by LicenseServer, but this should not normally be changed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


Delete Method

Delete Method

XdsObjects Namespace > XdsLicense Class : Delete Method
Delete a specific XdsObjects license on a machine.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub Delete()
Dim instance As XdsLicense

instance.Delete()
public void Delete()
public:
void Delete();
Remarks

This method may be useful to remove trial licenses etc., but should be used with care on an end-user machine just in case there are licenses installed by other vendors, which should not be deleted

Depending on the version of windows, and the permissions of the user, it is possible that the license may be removed, espeically if it was installed by an administrator, but this method is invoked by a less privileged user.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


DeleteAllLicenses Method

DeleteAllLicenses Method

XdsObjects Namespace > XdsLicense Class : DeleteAllLicenses Method
Delete all XdsObjects licenses on a machine.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Sub DeleteAllLicenses()
XdsLicense.DeleteAllLicenses()
public static void DeleteAllLicenses()
public:
static void DeleteAllLicenses();
Remarks

This method may be useful on a development machine to remove all traces of trial licenses etc., but should not normally be used on an end-user machine just in case there are licenses installed by other vendors

Depending on the version of windows, and the permissions of the user, it is possible that not all licenses will be removed, espeically if they were installed by an administrator, but this method is invoked by a less privileged user.

Note that functions previously used during an execution remain available after this call, despite CurrentLicense

being set to null. Delete
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


GetLicense Method

GetLicense Method

XdsObjects Namespace > XdsLicense Class : GetLicense Method
Select a license
Overload List
Overload | Description
GetLicense() | Allow XdsObjects to select a license
GetLicense(LicensedFunctions) | Return a XdsLicense which supports the required set of functions
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


GetLicense() Method

GetLicense() Method

XdsObjects Namespace > XdsLicense Class > GetLicense Method : GetLicense() Method
Allow XdsObjects to select a license
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overloads Shared Function GetLicense() As XdsLicense
Dim value As XdsLicense

value = XdsLicense.GetLicense()
public static XdsLicense GetLicense()
public:
static XdsLicense^ GetLicense();

Return Value

A XdsLicense object
Remarks
When this method is used (either explicitly, or implicitly via use of licensed functionality or getting the CurrentLicense property before choosing a license), the XdsObjects will select the first XdsObjects.Enums.LicenseTypes.Full license available in the InstalledLicenses collection, or failing that a XdsObjects.Enums.LicenseTypes.Developer license.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members
Overload List


GetLicense(LicensedFunctions) Method

GetLicense(LicensedFunctions) Method

XdsObjects Namespace > XdsLicense Class > GetLicense Method : GetLicense(LicensedFunctions) Method
A combination of XdsObjects.Enums.LicensedFunctions flags, indicating the required functionality
Return a XdsLicense which supports the required set of functions
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overloads Shared Function GetLicense( _
   ByVal Functions As LicensedFunctions _
) As XdsLicense
Dim Functions As LicensedFunctions
Dim value As XdsLicense

value = XdsLicense.GetLicense(Functions)
public static XdsLicense GetLicense(
   LicensedFunctions Functions
)
public:
static XdsLicense^ GetLicense(
   LicensedFunctions Functions
)

Parameters

Functions
A combination of XdsObjects.Enums.LicensedFunctions flags, indicating the required functionality

Return Value

A XdsLicense object
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members
Overload List


ToString Method (XdsLicense)

ToString Method (XdsLicense)

XdsObjects Namespace > XdsLicense Class : ToString Method
Provides a summary of the functions, type, origin and expiry date of the license
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overrides Function ToString() As String
Dim instance As XdsLicense
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A single string containing the functions, type, origin and expiry date of the license
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members
Base Implementation in ToString


XdsLicense Class Properties

XdsLicense Class Properties

XdsObjects Namespace : XdsLicense Class

For a list of all members of this type, see XdsLicense members.

Public Properties
 | Name | Description
Public Property | AllowedFunctions | The functions which this license allows XdsObjects to perform
Public Property | AuthorisationID | The numeric ID of the Authorisation String which was used to generate this license
static (Shared in Visual Basic) | CurrentLicense | The XdsLicense current in use
static (Shared in Visual Basic) | Dialog | Static LicenseDialog used to inform the user about license problems
Public Property | Expiry | The expiry date of the license
static (Shared in Visual Basic) | ExpiryWarningDays | Number of days before expiry to start issuing warnings
static (Shared in Visual Basic) | ExpiryWarningPeriod | Warning period to give the user of license expiry
static (Shared in Visual Basic) | InstalledLicenses | The list of currently available licenses.
Public Property | IsStrongName | Indicates whether the license is derived from the strong name of the calling program
Public Property | LicenseID | The ID for this particular license
static (Shared in Visual Basic) | LicenseServer | Specifies the server to be used to obtain on-line licenses This is an advanced property only to be used under directions from Medical Connections
static (Shared in Visual Basic) | LicenseServerCount | Specifies the how many license servers are to be tried to obtain on-line licenses This is an advanced property only to be used under directions from Medical Connections
Public Property | LicenseToken | The license token which activated this licnense.
Public Property | LicenseType | The Type (Full, Trial or Developer) of this license.
static (Shared in Visual Basic) | MachineID | A unique string for each machine.
static (Shared in Visual Basic) | ProxyDomain | Domain to be used if the machine's web proxy requires authentication.
static (Shared in Visual Basic) | ProxyPassword | Password to be used if the machine's web proxy requires authentication.
static (Shared in Visual Basic) | ProxyUsername | Username to be used if the machine's web proxy requires authentication.
Public Property | Start | The start date of the license
static (Shared in Visual Basic) | WebService | The Web Service used for on-line activation
Top
See Also

Reference

XdsLicense Class
XdsObjects Namespace


AllowedFunctions Property

AllowedFunctions Property

XdsObjects Namespace > XdsLicense Class : AllowedFunctions Property
The functions which this license allows XdsObjects to perform
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property AllowedFunctions As LicensedFunctions
Dim instance As XdsLicense
Dim value As LicensedFunctions

value = instance.AllowedFunctions
public LicensedFunctions AllowedFunctions {get;}
public:
property LicensedFunctions AllowedFunctions {
   LicensedFunctions get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


AuthorisationID Property

AuthorisationID Property

XdsObjects Namespace > XdsLicense Class : AuthorisationID Property
The numeric ID of the Authorisation String which was used to generate this license
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property AuthorisationID As Integer
Dim instance As XdsLicense
Dim value As Integer

value = instance.AuthorisationID
public int AuthorisationID {get;}
public:
property int AuthorisationID {
   int get();
}
Remarks
For security reasons, the Authorisation String used to generate a XdsLicense is not stored in the machine, but each such string has a unique ID in the Medical Connections database, enabling the two to be linked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


CurrentLicense Property

CurrentLicense Property

XdsObjects Namespace > XdsLicense Class : CurrentLicense Property
The XdsLicense current in use
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Property CurrentLicense As XdsLicense
Dim value As XdsLicense

XdsLicense.CurrentLicense = value

value = XdsLicense.CurrentLicense
public static XdsLicense CurrentLicense {get; set;}
public:
static property XdsLicense^ CurrentLicense {
   XdsLicense^ get();
   void set (    XdsLicense^ value);
}
Remarks

Only one license can be in use at any time, and this property allows the developer to choose which of those available (from the InstalledLicenses should be used, or to tell which is currently in use.

If no license has specifically been selected, then XdsObject will use the GetLicense method to obtain one when this method is first called or when a license is first required.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


Dialog Property

Dialog Property

XdsObjects Namespace > XdsLicense Class : Dialog Property
Static LicenseDialog used to inform the user about license problems
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Property Dialog As LicenseDialog
Dim value As LicenseDialog

XdsLicense.Dialog = value

value = XdsLicense.Dialog
public static LicenseDialog Dialog {get; set;}
public:
static property LicenseDialog^ Dialog {
   LicenseDialog^ get();
   void set (    LicenseDialog^ value);
}
Remarks
This instance of the dialog is used for most internally generated notifications, giving developers the chance to cusomise its properties before it may be used. Note that an independent non-customisable instance is used for Trial and Developer notifications, but these should only ever be seen by a developer anyway!
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


Expiry Property

Expiry Property

XdsObjects Namespace > XdsLicense Class : Expiry Property
The expiry date of the license
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property Expiry As Date
Dim instance As XdsLicense
Dim value As Date

value = instance.Expiry
public DateTime Expiry {get;}
public:
property DateTime Expiry {
   DateTime get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


ExpiryWarningDays Property

ExpiryWarningDays Property

XdsObjects Namespace > XdsLicense Class : ExpiryWarningDays Property
Number of days before expiry to start issuing warnings
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Property ExpiryWarningDays As Integer
Dim value As Integer

XdsLicense.ExpiryWarningDays = value

value = XdsLicense.ExpiryWarningDays
public static int ExpiryWarningDays {get; set;}
public:
static property int ExpiryWarningDays {
   int get();
   void set (    int value);
}
Remarks
Default value is 14. Set to 0 to disable all expiry warning from XdsObjects.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


ExpiryWarningPeriod Property

ExpiryWarningPeriod Property

XdsObjects Namespace > XdsLicense Class : ExpiryWarningPeriod Property
Warning period to give the user of license expiry
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Property ExpiryWarningPeriod As TimeSpan
Dim value As TimeSpan

XdsLicense.ExpiryWarningPeriod = value

value = XdsLicense.ExpiryWarningPeriod
public static TimeSpan ExpiryWarningPeriod {get; set;}
public:
static property TimeSpan ExpiryWarningPeriod {
   TimeSpan get();
   void set (    TimeSpan value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


InstalledLicenses Property

InstalledLicenses Property

XdsObjects Namespace > XdsLicense Class : InstalledLicenses Property
The list of currently available licenses.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared ReadOnly Property InstalledLicenses As XdsLicense()
Dim value() As XdsLicense

value = XdsLicense.InstalledLicenses
public static XdsLicense[] InstalledLicenses {get;}
public:
static property array<XdsLicense^>^ InstalledLicenses {
   array<XdsLicense^>^ get();
}
Remarks
Licenses are added to this list automatically by use of ActivateOnLine or ActivateOffLine, and removed by using Delete.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


IsStrongName Property

IsStrongName Property

XdsObjects Namespace > XdsLicense Class : IsStrongName Property
Indicates whether the license is derived from the strong name of the calling program
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property IsStrongName As Boolean
Dim instance As XdsLicense
Dim value As Boolean

value = instance.IsStrongName
public bool IsStrongName {get;}
public:
property bool IsStrongName {
   bool get();
}
Remarks
This is an advanced feature of certain specialist licenses. Most normal licenses, issued via the activation mechanism will return false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


LicenseID Property

LicenseID Property

XdsObjects Namespace > XdsLicense Class : LicenseID Property
The ID for this particular license
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property LicenseID As Integer
Dim instance As XdsLicense
Dim value As Integer

value = instance.LicenseID
public int LicenseID {get;}
public:
property int LicenseID {
   int get();
}
Remarks
When combined with the AuthorisationID, this creates a unique identifier for the license
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


LicenseServer Property

LicenseServer Property

XdsObjects Namespace > XdsLicense Class : LicenseServer Property
Specifies the server to be used to obtain on-line licenses This is an advanced property only to be used under directions from Medical Connections
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Property LicenseServer As String
Dim value As String

XdsLicense.LicenseServer = value

value = XdsLicense.LicenseServer
public static string LicenseServer {get; set;}
public:
static property String^ LicenseServer {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


LicenseServerCount Property

LicenseServerCount Property

XdsObjects Namespace > XdsLicense Class : LicenseServerCount Property
Specifies the how many license servers are to be tried to obtain on-line licenses This is an advanced property only to be used under directions from Medical Connections
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Property LicenseServerCount As Integer
Dim value As Integer

XdsLicense.LicenseServerCount = value

value = XdsLicense.LicenseServerCount
public static int LicenseServerCount {get; set;}
public:
static property int LicenseServerCount {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


LicenseToken Property

LicenseToken Property

XdsObjects Namespace > XdsLicense Class : LicenseToken Property
The license token which activated this licnense.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property LicenseToken As String
Dim instance As XdsLicense
Dim value As String

value = instance.LicenseToken
public string LicenseToken {get;}
public:
property String^ LicenseToken {
   String^ get();
}
Remarks
This token would either have been obtained automatically via ActivateOnLine or entered manually via ActivateOffLine). It is an encrypted opaque token, which will vary from machine to machine, and is only valid when used on a machine with a matching MachineID.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


LicenseType Property

LicenseType Property

XdsObjects Namespace > XdsLicense Class : LicenseType Property
The Type (Full, Trial or Developer) of this license.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property LicenseType As LicenseTypes
Dim instance As XdsLicense
Dim value As LicenseTypes

value = instance.LicenseType
public LicenseTypes LicenseType {get;}
public:
property LicenseTypes LicenseType {
   LicenseTypes get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


MachineID Property

MachineID Property

XdsObjects Namespace > XdsLicense Class : MachineID Property
A unique string for each machine.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared ReadOnly Property MachineID As String
Dim value As String

value = XdsLicense.MachineID
public static string MachineID {get;}
public:
static property String^ MachineID {
   String^ get();
}
Remarks
This string is needed to generate a license and must be entered into the web activation system when ActivateOffLine is to be used.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


ProxyDomain Property

ProxyDomain Property

XdsObjects Namespace > XdsLicense Class : ProxyDomain Property
Domain to be used if the machine's web proxy requires authentication.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Property ProxyDomain As String
Dim value As String

XdsLicense.ProxyDomain = value

value = XdsLicense.ProxyDomain
public static string ProxyDomain {get; set;}
public:
static property String^ ProxyDomain {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


ProxyPassword Property

ProxyPassword Property

XdsObjects Namespace > XdsLicense Class : ProxyPassword Property
Password to be used if the machine's web proxy requires authentication.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared WriteOnly Property ProxyPassword As String

XdsLicense.ProxyPassword = value
public static string ProxyPassword {set;}
public:
static property String^ ProxyPassword {
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


ProxyUsername Property

ProxyUsername Property

XdsObjects Namespace > XdsLicense Class : ProxyUsername Property
Username to be used if the machine's web proxy requires authentication.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Property ProxyUsername As String
Dim value As String

XdsLicense.ProxyUsername = value

value = XdsLicense.ProxyUsername
public static string ProxyUsername {get; set;}
public:
static property String^ ProxyUsername {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


Start Property

Start Property

XdsObjects Namespace > XdsLicense Class : Start Property
The start date of the license
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property Start As Date
Dim instance As XdsLicense
Dim value As Date

value = instance.Start
public DateTime Start {get;}
public:
property DateTime Start {
   DateTime get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


WebService Property

WebService Property

XdsObjects Namespace > XdsLicense Class : WebService Property
The Web Service used for on-line activation
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared ReadOnly Property WebService As SoapHttpClientProtocol
Dim value As SoapHttpClientProtocol

value = XdsLicense.WebService
public static SoapHttpClientProtocol WebService {get;}
public:
static property SoapHttpClientProtocol^ WebService {
   SoapHttpClientProtocol^ get();
}
Remarks
This static object is used when calls are made to ActivateOnLine. This object may be used to set proxy or credential information where this is necessary.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


XdsLicense Class Events

XdsLicense Class Events

XdsObjects Namespace : XdsLicense Class

For a list of all members of this type, see XdsLicense members.

Public Events
 | Name | Description
Public Event | RetrieveLicense | Event fired when XdsObjects needs to retrieve a previously stored license
Public Event | StoreLicense | Event fires when XdsObjects needs to store a license
Top
See Also

Reference

XdsLicense Class
XdsObjects Namespace


RetrieveLicense Event

RetrieveLicense Event

XdsObjects Namespace > XdsLicense Class : RetrieveLicense Event
Event fired when XdsObjects needs to retrieve a previously stored license
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Event RetrieveLicense As XdsLicense.RetrieveLicenseHandler
Dim instance As XdsLicense
Dim handler As XdsLicense.RetrieveLicenseHandler

AddHandler instance.RetrieveLicense, handler
public event XdsLicense.RetrieveLicenseHandler RetrieveLicense
public:
event XdsLicense.RetrieveLicenseHandler^ RetrieveLicense
Remarks

Normally, XdsObjects stores licenses internally, using a combination of registry locations and files, but on some machines this is not feasible due to excessive security restrictions on the account under which it is running. In these cases, a developer may choose to intercept the storage of the license via the StoreLicense event, and then to provide it on request via this event.

Note that DeleteAllLicenses does not affect this mechanism, so it is the developer's responsiblity to clear any stored key if required.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


StoreLicense Event

StoreLicense Event

XdsObjects Namespace > XdsLicense Class : StoreLicense Event
Event fires when XdsObjects needs to store a license
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Event StoreLicense As XdsLicense.StoreLicenseHandler
Dim instance As XdsLicense
Dim handler As XdsLicense.StoreLicenseHandler

AddHandler instance.StoreLicense, handler
public event XdsLicense.StoreLicenseHandler StoreLicense
public:
event XdsLicense.StoreLicenseHandler^ StoreLicense
Remarks

Normally, XdsObjects stores licenses internally, using a combination of registry locations and files, but on some machines this is not feasible due to excessive security restrictions on the account under which it is running. In these cases, a developer may choose to intercept the storage of the license via this event, and then to provide it on request via the RetrieveLicense event.

Note that DeleteAllLicenses does not affect this mechanism, so it is the developer's responsiblity to clear any stored key if required.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense Class
XdsLicense Members


XdsMtomServer Class

XdsMtomServer Class
Members

XdsObjects Namespace : XdsMtomServer Class
A server which listens for incoming transactions for requests which include document data.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsMtomServer
   Inherits XdsBaseServer
Dim instance As XdsMtomServer
public class XdsMtomServer : XdsBaseServer
public ref class XdsMtomServer : public XdsBaseServer
Inheritance Hierarchy

System.Object
XdsObjects.XdsBaseServer
XdsObjects.XdsMtomServer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsMtomServer Members
XdsObjects Namespace


XdsMtomServer Class Members

XdsMtomServer Class Members
Properties Methods Events

XdsObjects Namespace : XdsMtomServer Class

The following tables list the members exposed by XdsMtomServer.

Public Constructors
 | Name | Description
Public Constructor | XdsMtomServer Constructor | Construct new XdsMtomServer
Top
Public Properties
 | Name | Description
Public Property | StructureIncomingSubmissionSet | Controls the behaviour used when incoming data is received. (Inherited from XdsObjects.XdsBaseServer)
Top
Public Methods
 | Name | Description
Public Method | Listen | Specify an endpoint for listening
Public Method | UnListenAll | Stops listening on all Addresses
Top
Public Events
 | Name | Description
Public Event | CrossGatewayRetrieveReceived | Event fired when an incoming CrossGatewayRetrieveRetrieve transaction is received
Public Event | ProvideAndRegisterRequestReceived | Event fired when an incoming ProvideAndRegister-b transaction is received
Public Event | RetrieveRequestReceived | Event fired when an incoming RetrieveDocumentSet transaction is received
Top
See Also

Reference

XdsMtomServer Class
XdsObjects Namespace


XdsMtomServer Constructor

XdsMtomServer Constructor

XdsObjects Namespace > XdsMtomServer Class : XdsMtomServer Constructor
Construct new XdsMtomServer
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsMtomServer()
public XdsMtomServer()
public:
XdsMtomServer();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsMtomServer Class
XdsMtomServer Members


XdsMtomServer Class Methods

XdsMtomServer Class Methods

XdsObjects Namespace : XdsMtomServer Class

For a list of all members of this type, see XdsMtomServer members.

Public Methods
 | Name | Description
Public Method | Listen | Specify an endpoint for listening
Public Method | UnListenAll | Stops listening on all Addresses
Top
See Also

Reference

XdsMtomServer Class
XdsObjects Namespace


Listen Method (XdsMtomServer)

Listen Method (XdsMtomServer)

XdsObjects Namespace > XdsMtomServer Class : Listen Method
The address (URL) to listen on
Specify an endpoint for listening
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub Listen( _
   ByVal Address As String _
)
Dim instance As XdsMtomServer
Dim Address As String

instance.Listen(Address)
public void Listen(
   string Address
)
public:
void Listen(
   String^ Address
)

Parameters

Address
The address (URL) to listen on
Remarks

A server can listen on multiple endpoint addresses

If secure listening is required, the port and certificate must be configured using httpcfg or (for Vista/Windows 7) netsh - see Server Certificates for more details

Example
serverobject.Listen("http://myservername:8080/MyLIsteningEndpoint)serverobject.Listen("https://myservername:8080/MySecureLsteningEndpoint)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsMtomServer Class
XdsMtomServer Members


UnListenAll Method (XdsMtomServer)

UnListenAll Method (XdsMtomServer)

XdsObjects Namespace > XdsMtomServer Class : UnListenAll Method
Stops listening on all Addresses
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub UnListenAll()
Dim instance As XdsMtomServer

instance.UnListenAll()
public void UnListenAll()
public:
void UnListenAll();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsMtomServer Class
XdsMtomServer Members


XdsMtomServer Class Events

XdsMtomServer Class Events

XdsObjects Namespace : XdsMtomServer Class

For a list of all members of this type, see XdsMtomServer members.

Public Events
 | Name | Description
Public Event | CrossGatewayRetrieveReceived | Event fired when an incoming CrossGatewayRetrieveRetrieve transaction is received
Public Event | ProvideAndRegisterRequestReceived | Event fired when an incoming ProvideAndRegister-b transaction is received
Public Event | RetrieveRequestReceived | Event fired when an incoming RetrieveDocumentSet transaction is received
Top
See Also

Reference

XdsMtomServer Class
XdsObjects Namespace


CrossGatewayRetrieveReceived Event

CrossGatewayRetrieveReceived Event

XdsObjects Namespace > XdsMtomServer Class : CrossGatewayRetrieveReceived Event
Event fired when an incoming CrossGatewayRetrieveRetrieve transaction is received
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Event CrossGatewayRetrieveReceived As RetrieveHandler
Dim instance As XdsMtomServer
Dim handler As RetrieveHandler

AddHandler instance.CrossGatewayRetrieveReceived, handler
public event RetrieveHandler CrossGatewayRetrieveReceived
public:
event RetrieveHandler^ CrossGatewayRetrieveReceived
Requirements
A responding gateway or repository uses this event to handle incoming retrieve requests
See Also

Reference

XdsMtomServer Class
XdsMtomServer Members


ProvideAndRegisterRequestReceived Event

ProvideAndRegisterRequestReceived Event

XdsObjects Namespace > XdsMtomServer Class : ProvideAndRegisterRequestReceived Event
Event fired when an incoming ProvideAndRegister-b transaction is received
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Event ProvideAndRegisterRequestReceived As RegisterDocumentSetHandler
Dim instance As XdsMtomServer
Dim handler As RegisterDocumentSetHandler

AddHandler instance.ProvideAndRegisterRequestReceived, handler
public event RegisterDocumentSetHandler ProvideAndRegisterRequestReceived
public:
event RegisterDocumentSetHandler^ ProvideAndRegisterRequestReceived
Remarks

The repository must then:

  • Allocate a UUID to each document (at top level and in folders)
  • Store the documents and keep a record of their location linked to the UUID
  • Add hash and size values (using SetSizeAndHash
  • Pass the SubmissionSet to a registry using XdsDomain.RegisterDocumentSet
Requirements
A repository uses this event to handle incoming submissions
See Also

Reference

XdsMtomServer Class
XdsMtomServer Members


RetrieveRequestReceived Event

RetrieveRequestReceived Event

XdsObjects Namespace > XdsMtomServer Class : RetrieveRequestReceived Event
Event fired when an incoming RetrieveDocumentSet transaction is received
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Event RetrieveRequestReceived As RetrieveHandler
Dim instance As XdsMtomServer
Dim handler As RetrieveHandler

AddHandler instance.RetrieveRequestReceived, handler
public event RetrieveHandler RetrieveRequestReceived
public:
event RetrieveHandler^ RetrieveRequestReceived
Requirements
A repository or initiating gateway uses this event to handle incoming retrieve requests
See Also

Reference

XdsMtomServer Class
XdsMtomServer Members


XdsMultiString Class

XdsMultiString Class
Members Example

XdsObjects Namespace : XdsMultiString Class
Class representing one or more stings
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsMultiString
Dim instance As XdsMultiString
public class XdsMultiString
public ref class XdsMultiString
Remarks

There are many places in XDS where only a single value is commonly used, but where multiple values are permissible. This utility class has multiple implicit constructors and so is used in such circumstances in XdsObjects to allow simple assignment of strings, arrays of strings or lists of strings without needing multiple different constructors or methods.

Therefore, wherever this documentation refers to an XdsMultString object, it is equally permissible to use a string, List<String> or String[], leaving the compiler to apply an implicit conversion.

Example
Use of XdsMultiString
  • C#
XdsAuthorauthor =newXdsAuthor();
            author.Organisation ="My Hospital";// conversion from simple string
            author.Role =newString[] {"GP","Specialist"};// conversion from Array
Inheritance Hierarchy

System.Object
XdsObjects.XdsMultiString

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsMultiString Members
XdsObjects Namespace


XdsMultiString Class Members

XdsMultiString Class Members
Properties Methods

XdsObjects Namespace : XdsMultiString Class

The following tables list the members exposed by XdsMultiString.

Public Constructors
 | Name | Description
Public Constructor | XdsMultiString Constructor | Overloaded. Create a new XdsMultiString
Top
Public Properties
 | Name | Description
Public Property | AllValues | Format all the contents of an XdsInternationalString for serialization.
Public Property | NonNullValues | Return all non-null values in MultiString
Public Property | Strings | The list of strings held in this object.
Top
Public Methods
 | Name | Description
Public Method | Contains | Check whether or not a specified string exists in the MultiString
Top
Public Operators
public Operator Implicit Type Conversion Overloaded. Implicit operators to create XdsMultiString objects from string(s)
Top
See Also

Reference

XdsMultiString Class
XdsObjects Namespace


XdsMultiString Constructor

XdsMultiString Constructor

XdsObjects Namespace > XdsMultiString Class : XdsMultiString Constructor
Create a new XdsMultiString
Overload List
Overload | Description
XdsMultiString Constructor() | Dummy constructor for serialization use only
XdsMultiString Constructor(String) | Create a new XdsMultiString, initialised with a single string
XdsMultiString Constructor(IEnumerable<String>) | Create a new XdsMultiString, initialised from a list of strings
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsMultiString Class
XdsMultiString Members


XdsMultiString Constructor()

XdsMultiString Constructor()

XdsObjects Namespace > XdsMultiString Class > XdsMultiString Constructor : XdsMultiString Constructor()
Dummy constructor for serialization use only
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsMultiString()
public XdsMultiString()
public:
XdsMultiString();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsMultiString Class
XdsMultiString Members
Overload List


XdsMultiString Constructor(String)

XdsMultiString Constructor(String)

XdsObjects Namespace > XdsMultiString Class > XdsMultiString Constructor : XdsMultiString Constructor(String)
The single value to use
Create a new XdsMultiString, initialised with a single string
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal String As String _
)
Dim String As String

Dim instance As New XdsMultiString(String)
public XdsMultiString(
   string String
)
public:
XdsMultiString(
   String^ String
)

Parameters

String
The single value to use
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsMultiString Class
XdsMultiString Members
Overload List


XdsMultiString Constructor(IEnumerable<String>)

XdsMultiString Constructor(IEnumerable<String>)

XdsObjects Namespace > XdsMultiString Class > XdsMultiString Constructor : XdsMultiString Constructor(IEnumerable<String>)
The strings to copy into the XdsMultiString
Create a new XdsMultiString, initialised from a list of strings
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal StringList As IEnumerable(Of String) _
)
Dim StringList As IEnumerable(Of String)

Dim instance As New XdsMultiString(StringList)
public XdsMultiString(
   IEnumerable<string> StringList
)
public:
XdsMultiString(
   IEnumerable<String^>^ StringList
)

Parameters

StringList
The strings to copy into the XdsMultiString
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsMultiString Class
XdsMultiString Members
Overload List


XdsMultiString Class Methods

XdsMultiString Class Methods

XdsObjects Namespace : XdsMultiString Class

For a list of all members of this type, see XdsMultiString members.

Public Methods
 | Name | Description
Public Method | Contains | Check whether or not a specified string exists in the MultiString
Top
See Also

Reference

XdsMultiString Class
XdsObjects Namespace


Contains Method

Contains Method

XdsObjects Namespace > XdsMultiString Class : Contains Method
The string to search for
Check whether or not a specified string exists in the MultiString
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function Contains( _
   ByVal String As String _
) As Boolean
Dim instance As XdsMultiString
Dim String As String
Dim value As Boolean

value = instance.Contains(String)
public bool Contains(
   string String
)
public:
bool Contains(
   String^ String
)

Parameters

String
The string to search for

Return Value

true if the string is found
Remarks
This is a case-sensitive, full-string match
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsMultiString Class
XdsMultiString Members


XdsMultiString Class Properties

XdsMultiString Class Properties

XdsObjects Namespace : XdsMultiString Class

For a list of all members of this type, see XdsMultiString members.

Public Properties
 | Name | Description
Public Property | AllValues | Format all the contents of an XdsInternationalString for serialization.
Public Property | NonNullValues | Return all non-null values in MultiString
Public Property | Strings | The list of strings held in this object.
Top
See Also

Reference

XdsMultiString Class
XdsObjects Namespace


AllValues Property (XdsMultiString)

AllValues Property (XdsMultiString)

XdsObjects Namespace > XdsMultiString Class : AllValues Property
Format all the contents of an XdsInternationalString for serialization.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property AllValues As String
Dim instance As XdsMultiString
Dim value As String

instance.AllValues = value

value = instance.AllValues
public string AllValues {get; set;}
public:
property String^ AllValues {
   String^ get();
   void set (    String^ value);
}
Remarks

This is a specialist property which is intended purely for serialization or with the Code First Entity Framework to allow the contents to be persisted to and restored from a single string.

The format is set of lines, each containing a single entry.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsMultiString Class
XdsMultiString Members


NonNullValues Property

NonNullValues Property

XdsObjects Namespace > XdsMultiString Class : NonNullValues Property
Return all non-null values in MultiString
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property NonNullValues As IEnumerable(Of String)
Dim instance As XdsMultiString
Dim value As IEnumerable(Of String)

value = instance.NonNullValues
public IEnumerable<string> NonNullValues {get;}
public:
property IEnumerable<String^>^ NonNullValues {
   IEnumerable<String^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsMultiString Class
XdsMultiString Members


Strings Property

Strings Property

XdsObjects Namespace > XdsMultiString Class : Strings Property
The list of strings held in this object.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Strings As List(Of String)
Dim instance As XdsMultiString
Dim value As List(Of String)

instance.Strings = value

value = instance.Strings
public List<string> Strings {get; set;}
public:
property List<String^>^ Strings {
   List<String^>^ get();
   void set (    List<String^>^ value);
}
Remarks
Whilst systems creating data can use single strings, those consuming data must always be prepared for the possibility of multi-valued data, and so this method is deliberately the only way to access the data, to remind developers of this requirement.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsMultiString Class
XdsMultiString Members


Implicit Type Conversion Operator (XdsMultiString)

Implicit Type Conversion Operator (XdsMultiString)

XdsObjects Namespace > XdsMultiString Class : Implicit Type Conversion Operator
Implicit operators to create XdsMultiString objects from string(s)
Overload List
Overload | Description
Implicit Type Conversion(XdsMultiString,String) | Create an XdsMultiString object from a simple string
Implicit Type Conversion(XdsMultiString,List<String>) | Create an XdsMultiString object from an enumerable set of strings
Implicit Type Conversion(XdsMultiString,String[]) | Create an XdsMultiString object from an array of strings
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsMultiString Class
XdsMultiString Members


XdsObjectRef Class

XdsObjectRef Class
Members

XdsObjects Namespace : XdsObjectRef Class
Class representing a simple Object Reference
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsObjectRef
Dim instance As XdsObjectRef
public class XdsObjectRef
public ref class XdsObjectRef
Remarks

This is the type of object returned when doing a registry query with XdsQueryRequest.QueryReturnType = XdsObjects.Enums.QueryReturnType.ObjectRef. It tells you nothing about the object at all, and is purely intended to allow paging thorugh a large set of results by asking for more details on each of the returned objects in turn.

In normal XDS use only the UUID value is valid, but in an XCA environment the HomeCommunityID value is also needed

Inheritance Hierarchy

System.Object
XdsObjects.XdsObjectRef

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjectRef Members
XdsObjects Namespace


XdsObjectRef Class Members

XdsObjectRef Class Members
Properties

XdsObjects Namespace : XdsObjectRef Class

The following tables list the members exposed by XdsObjectRef.

Public Constructors
 | Name | Description
Public Constructor | XdsObjectRef Constructor | Overloaded. Create a new XdsObjectRef
Top
Public Properties
 | Name | Description
Public Property | HomeCommunityID | The HomeCommunityID of the ObjectRef
Public Property | UUID | The object UUID known to the Registry
Top
See Also

Reference

XdsObjectRef Class
XdsObjects Namespace


XdsObjectRef Constructor

XdsObjectRef Constructor

XdsObjects Namespace > XdsObjectRef Class : XdsObjectRef Constructor
Create a new XdsObjectRef
Overload List
Overload | Description
XdsObjectRef Constructor() | Create a new empty XdsObjectRef
XdsObjectRef Constructor(String,String) | Create a new XdsObjectRef, specifying the UUID and Home Community ID
XdsObjectRef Constructor(String) | Create a new XdsObjectRef, specifying the UUID
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjectRef Class
XdsObjectRef Members


XdsObjectRef Constructor()

XdsObjectRef Constructor()

XdsObjects Namespace > XdsObjectRef Class > XdsObjectRef Constructor : XdsObjectRef Constructor()
Create a new empty XdsObjectRef
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsObjectRef()
public XdsObjectRef()
public:
XdsObjectRef();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjectRef Class
XdsObjectRef Members
Overload List


XdsObjectRef Constructor(String,String)

XdsObjectRef Constructor(String,String)

XdsObjects Namespace > XdsObjectRef Class > XdsObjectRef Constructor : XdsObjectRef Constructor(String,String)
The UUID of the object
The Home Cummunity ID of the object
Create a new XdsObjectRef, specifying the UUID and Home Community ID
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal Uuid As String, _
   ByVal HomeCommunityID As String _
)
Dim Uuid As String
Dim HomeCommunityID As String

Dim instance As New XdsObjectRef(Uuid, HomeCommunityID)
public XdsObjectRef(
   string Uuid,
   string HomeCommunityID
)
public:
XdsObjectRef(
   String^ Uuid,
   String^ HomeCommunityID
)

Parameters

Uuid
The UUID of the object
HomeCommunityID
The Home Cummunity ID of the object
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjectRef Class
XdsObjectRef Members
Overload List


XdsObjectRef Constructor(String)

XdsObjectRef Constructor(String)

XdsObjects Namespace > XdsObjectRef Class > XdsObjectRef Constructor : XdsObjectRef Constructor(String)
The UUID of the object
Create a new XdsObjectRef, specifying the UUID
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal Uuid As String _
)
Dim Uuid As String

Dim instance As New XdsObjectRef(Uuid)
public XdsObjectRef(
   string Uuid
)
public:
XdsObjectRef(
   String^ Uuid
)

Parameters

Uuid
The UUID of the object
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjectRef Class
XdsObjectRef Members
Overload List


XdsObjectRef Class Properties

XdsObjectRef Class Properties

XdsObjects Namespace : XdsObjectRef Class

For a list of all members of this type, see XdsObjectRef members.

Public Properties
 | Name | Description
Public Property | HomeCommunityID | The HomeCommunityID of the ObjectRef
Public Property | UUID | The object UUID known to the Registry
Top
See Also

Reference

XdsObjectRef Class
XdsObjects Namespace


HomeCommunityID Property (XdsObjectRef)

HomeCommunityID Property (XdsObjectRef)

XdsObjects Namespace > XdsObjectRef Class : HomeCommunityID Property
The HomeCommunityID of the ObjectRef
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property HomeCommunityID As String
Dim instance As XdsObjectRef
Dim value As String

instance.HomeCommunityID = value

value = instance.HomeCommunityID
public string HomeCommunityID {get; set;}
public:
property String^ HomeCommunityID {
   String^ get();
   void set (    String^ value);
}
Remarks
This is only used in the context of XCA queries. The value will be set internally from the "home" property of incoming data. For outgoing data, it is easiest to set for all objects in the "passed through" data by using the XdsQueryResponse.SetHomeCommunityID method.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjectRef Class
XdsObjectRef Members


UUID Property (XdsObjectRef)

UUID Property (XdsObjectRef)

XdsObjects Namespace > XdsObjectRef Class : UUID Property
The object UUID known to the Registry
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property UUID As String
Dim instance As XdsObjectRef
Dim value As String

instance.UUID = value

value = instance.UUID
public string UUID {get; set;}
public:
property String^ UUID {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjectRef Class
XdsObjectRef Members


XdsObjectRefList Class

XdsObjectRefList Class
Members

XdsObjects Namespace : XdsObjectRefList Class
Class used to hold lists of XdsObjectRef items
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsObjectRefList
   Inherits System.Collections.Generic.List(Of XdsObjectRef)
Dim instance As XdsObjectRefList
public class XdsObjectRefList : System.Collections.Generic.List<XdsObjectRef>
public ref class XdsObjectRefList : public System.Collections.Generic.List<XdsObjectRef>
Remarks
This is a thin wrapper around ListXdsObjectRef>, which provides convenient methods for adding strings and lists of strings.
Inheritance Hierarchy

System.Object
System.Collections.Generic.List<T>
XdsObjects.XdsObjectRefList

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjectRefList Members
XdsObjects Namespace


XdsObjectRefList Class Members

XdsObjectRefList Class Members
Properties Methods

XdsObjects Namespace : XdsObjectRefList Class

The following tables list the members exposed by XdsObjectRefList.

Public Constructors
 | Name | Description
Public Constructor | XdsObjectRefList Constructor |
Top
Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Property | Count | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Property | Item | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Methods to add items to the list
Public Method | AddRange | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | Clear | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | Contains | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | Exists | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | Find | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | FindAll | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | FindLast | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | ForEach | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | GetRange | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | Insert | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | Remove | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | ToArray | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Top
See Also

Reference

XdsObjectRefList Class
XdsObjects Namespace


XdsObjectRefList Constructor

XdsObjectRefList Constructor

XdsObjects Namespace > XdsObjectRefList Class : XdsObjectRefList Constructor
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsObjectRefList()
public XdsObjectRefList()
public:
XdsObjectRefList();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjectRefList Class
XdsObjectRefList Members


XdsObjectRefList Class Methods

XdsObjectRefList Class Methods

XdsObjects Namespace : XdsObjectRefList Class

For a list of all members of this type, see XdsObjectRefList members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Methods to add items to the list
Public Method | AddRange | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | Clear | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | Contains | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | Exists | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | Find | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | FindAll | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | FindLast | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | ForEach | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | GetRange | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | Insert | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | Remove | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | ToArray | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Top
See Also

Reference

XdsObjectRefList Class
XdsObjects Namespace


Add Method (XdsObjectRefList)

Add Method (XdsObjectRefList)

XdsObjects Namespace > XdsObjectRefList Class : Add Method
Methods to add items to the list
Overload List
Overload | Description
Add(String) | Create a new XdsObjectRef item with the specified UUID and add it to the list
Add(IEnumerable<String>) | Create multiple new XdsObjectRef items and add them to the list
Add(XdsObjectRef) | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjectRefList Class
XdsObjectRefList Members


Add(String) Method

Add(String) Method

XdsObjects Namespace > XdsObjectRefList Class > Add Method : Add(String) Method
UUID to add
Create a new XdsObjectRef item with the specified UUID and add it to the list
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overloads Sub Add( _
   ByVal UUID As String _
)
Dim instance As XdsObjectRefList
Dim UUID As String

instance.Add(UUID)
public void Add(
   string UUID
)
public:
void Add(
   String^ UUID
)

Parameters

UUID
UUID to add
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjectRefList Class
XdsObjectRefList Members
Overload List


Add(IEnumerable<String>) Method

Add(IEnumerable<String>) Method

XdsObjects Namespace > XdsObjectRefList Class > Add Method : Add(IEnumerable<String>) Method
The list of UUIDs to add
Create multiple new XdsObjectRef items and add them to the list
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overloads Sub Add( _
   ByVal List As IEnumerable(Of String) _
)
Dim instance As XdsObjectRefList
Dim List As IEnumerable(Of String)

instance.Add(List)
public void Add(
   IEnumerable<string> List
)
public:
void Add(
   IEnumerable<String^>^ List
)

Parameters

List
The list of UUIDs to add
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjectRefList Class
XdsObjectRefList Members
Overload List


XdsPatient Class

XdsPatient Class
Members

XdsObjects Namespace : XdsPatient Class
An Class representing a patient, and their IDs
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsPatient
   Inherits XdsPerson
Dim instance As XdsPatient
public class XdsPatient : XdsPerson
public ref class XdsPatient : public XdsPerson
Remarks
This is derived from XdsPerson, but adds the abailty to hold multiple Ids for the patient in different domains as a result of PIX queries.
Inheritance Hierarchy

System.Object
XdsObjects.XdsPerson
XdsObjects.XdsPatient

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPatient Members
XdsObjects Namespace


XdsPatient Class Members

XdsPatient Class Members
Properties Methods

XdsObjects Namespace : XdsPatient Class

The following tables list the members exposed by XdsPatient.

Public Constructors
 | Name | Description
Public Constructor | XdsPatient Constructor | Overloaded. Construct a new XdsPatient object
Top
Public Properties
 | Name | Description
Public Property | Address | The address of the patient as a single string
Public Property | CompositeId | Composite ID, incorporating the root and extension (Inherited from XdsObjects.XdsPerson)
Public Property | CompositeName | A simple human readable form of the name. (Inherited from XdsObjects.XdsPerson)
Public Property | DOB | The person's date of birth (Inherited from XdsObjects.XdsPerson)
Public Property | FamilyName | The family name/surname of the person (Inherited from XdsObjects.XdsPerson)
Public Property | GivenName | The forename of the person (Inherited from XdsObjects.XdsPerson)
Public Property | ID_Domain | Use for non-standard IDs such us extension^^^ID_Domain&root&ISO^ID_Type (Inherited from XdsObjects.XdsPerson)
Public Property | ID_Extension | The ientity of the person with the domain identified by XdsPerson.ID_Root (Inherited from XdsObjects.XdsPerson)
Public Property | ID_Root | The Identifier of the domain/system issuing the person's ID - this is normally an OID (Inherited from XdsObjects.XdsPerson)
Public Property | ID_Root_Name | The "Name" of the system/organisation issuing the person's ID (Inherited from XdsObjects.XdsPerson)
Public Property | ID_Type | Use for non-standard IDs such us extension^^^ID_Domain&root&ISO^ID_Type (Inherited from XdsObjects.XdsPerson)
Public Property | MiddleName | The middle name of the person (Inherited from XdsObjects.XdsPerson)
Public Property | PhoneNumber | The person's contact number (Inherited from XdsObjects.XdsPerson)
Public Property | Prefix | The name prefix e.g. Mr, Mrs, Ms, Dr etc. (Inherited from XdsObjects.XdsPerson)
Public Property | Sex | The gender of the person (Inherited from XdsObjects.XdsPerson)
Public Property | SingleName | Simple human-readable version of the person's name (Inherited from XdsObjects.XdsPerson)
Public Property | StructuredNameDicom | Structured version of the name, as used in DICOM (Inherited from XdsObjects.XdsPerson)
Public Property | StructuredNameHl7 | Structured version of the name, as used in HL7 (Inherited from XdsObjects.XdsPerson)
Public Property | Suffix | The name suffix e.g. Jnr. or III (Inherited from XdsObjects.XdsPerson)
Top
Public Methods
 | Name | Description
Public Method | WithRoot | Uses a PIX query to lookup the identity of a patient in a different domain - i.e. with a different ID_Root
Top
See Also

Reference

XdsPatient Class
XdsObjects Namespace


XdsPatient Constructor

XdsPatient Constructor

XdsObjects Namespace > XdsPatient Class : XdsPatient Constructor
Construct a new XdsPatient object
Overload List
Overload | Description
XdsPatient Constructor() | Construct a new empty XdsPatient object
XdsPatient Constructor(String) | Constructs a new XdsPatient object with an initialised value for SingleName
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPatient Class
XdsPatient Members


XdsPatient Constructor()

XdsPatient Constructor()

XdsObjects Namespace > XdsPatient Class > XdsPatient Constructor : XdsPatient Constructor()
Construct a new empty XdsPatient object
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsPatient()
public XdsPatient()
public:
XdsPatient();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPatient Class
XdsPatient Members
Overload List


XdsPatient Constructor(String)

XdsPatient Constructor(String)

XdsObjects Namespace > XdsPatient Class > XdsPatient Constructor : XdsPatient Constructor(String)
The name of the patient
Constructs a new XdsPatient object with an initialised value for SingleName
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal Name As String _
)
Dim Name As String

Dim instance As New XdsPatient(Name)
public XdsPatient(
   string Name
)
public:
XdsPatient(
   String^ Name
)

Parameters

Name
The name of the patient
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPatient Class
XdsPatient Members
Overload List


XdsPatient Class Methods

XdsPatient Class Methods

XdsObjects Namespace : XdsPatient Class

For a list of all members of this type, see XdsPatient members.

Public Methods
 | Name | Description
Public Method | WithRoot | Uses a PIX query to lookup the identity of a patient in a different domain - i.e. with a different ID_Root
Top
See Also

Reference

XdsPatient Class
XdsObjects Namespace


WithRoot Method

WithRoot Method

XdsObjects Namespace > XdsPatient Class : WithRoot Method

The Root of the domain which is wanted - typically:

  • For a document consumer, this is the root ID of the local domain
  • For a document source, this is the root ID of the XDS domain
The XdsDomain object holding details of the Pix Manager, audit repository etc.
Uses a PIX query to lookup the identity of a patient in a different domain - i.e. with a different ID_Root
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function WithRoot( _
   ByVal WantedRoot As String, _
   ByVal xds As XdsDomain _
) As String
Dim instance As XdsPatient
Dim WantedRoot As String
Dim xds As XdsDomain
Dim value As String

value = instance.WithRoot(WantedRoot, xds)
public string WithRoot(
   string WantedRoot,
   XdsDomain xds
)
public:
String^ WithRoot(
   String^ WantedRoot,
   XdsDomain^ xds
)

Parameters

WantedRoot

The Root of the domain which is wanted - typically:

  • For a document consumer, this is the root ID of the local domain
  • For a document source, this is the root ID of the XDS domain
xds
The XdsDomain object holding details of the Pix Manager, audit repository etc.

Return Value

A full ID string in the form LocalID^^^&amp;RootID&amp;ISO
Remarks
See the article on PIX Management in XdsObjects for more details on how this method is used, both explicitly, and implicitly by other methods.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPatient Class
XdsPatient Members


XdsPatient Class Properties

XdsPatient Class Properties

XdsObjects Namespace : XdsPatient Class

For a list of all members of this type, see XdsPatient members.

Public Properties
 | Name | Description
Public Property | Address | The address of the patient as a single string
Public Property | CompositeId | Composite ID, incorporating the root and extension (Inherited from XdsObjects.XdsPerson)
Public Property | CompositeName | A simple human readable form of the name. (Inherited from XdsObjects.XdsPerson)
Public Property | DOB | The person's date of birth (Inherited from XdsObjects.XdsPerson)
Public Property | FamilyName | The family name/surname of the person (Inherited from XdsObjects.XdsPerson)
Public Property | GivenName | The forename of the person (Inherited from XdsObjects.XdsPerson)
Public Property | ID_Domain | Use for non-standard IDs such us extension^^^ID_Domain&root&ISO^ID_Type (Inherited from XdsObjects.XdsPerson)
Public Property | ID_Extension | The ientity of the person with the domain identified by XdsPerson.ID_Root (Inherited from XdsObjects.XdsPerson)
Public Property | ID_Root | The Identifier of the domain/system issuing the person's ID - this is normally an OID (Inherited from XdsObjects.XdsPerson)
Public Property | ID_Root_Name | The "Name" of the system/organisation issuing the person's ID (Inherited from XdsObjects.XdsPerson)
Public Property | ID_Type | Use for non-standard IDs such us extension^^^ID_Domain&root&ISO^ID_Type (Inherited from XdsObjects.XdsPerson)
Public Property | MiddleName | The middle name of the person (Inherited from XdsObjects.XdsPerson)
Public Property | PhoneNumber | The person's contact number (Inherited from XdsObjects.XdsPerson)
Public Property | Prefix | The name prefix e.g. Mr, Mrs, Ms, Dr etc. (Inherited from XdsObjects.XdsPerson)
Public Property | Sex | The gender of the person (Inherited from XdsObjects.XdsPerson)
Public Property | SingleName | Simple human-readable version of the person's name (Inherited from XdsObjects.XdsPerson)
Public Property | StructuredNameDicom | Structured version of the name, as used in DICOM (Inherited from XdsObjects.XdsPerson)
Public Property | StructuredNameHl7 | Structured version of the name, as used in HL7 (Inherited from XdsObjects.XdsPerson)
Public Property | Suffix | The name suffix e.g. Jnr. or III (Inherited from XdsObjects.XdsPerson)
Top
See Also

Reference

XdsPatient Class
XdsObjects Namespace


Address Property (XdsPatient)

Address Property (XdsPatient)

XdsObjects Namespace > XdsPatient Class : Address Property
The address of the patient as a single string
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Address As String
Dim instance As XdsPatient
Dim value As String

instance.Address = value

value = instance.Address
public string Address {get; set;}
public:
property String^ Address {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPatient Class
XdsPatient Members


XdsPerson Class

XdsPerson Class
Members

XdsObjects Namespace : XdsPerson Class
Base class holding the attributes of a person
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsPerson
Dim instance As XdsPerson
public class XdsPerson
public ref class XdsPerson
Remarks

At present, this is only used as base class for XdsPatient, but it is kept separate as it may be used for other purposes such as authors in the future.

Ideally, names should be set and used as individual name components, but this class also support a SingleName for when a name is only available as a single string.

The ID is kept as 2 separate components - the ID_Root and ID_Extension, with an optional ID_Root_Name

Inheritance Hierarchy

System.Object
XdsObjects.XdsPerson
XdsObjects.XdsPatient

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPerson Members
XdsObjects Namespace


XdsPerson Class Members

XdsPerson Class Members
Properties

XdsObjects Namespace : XdsPerson Class

The following tables list the members exposed by XdsPerson.

Public Constructors
 | Name | Description
Public Constructor | XdsPerson Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | CompositeId | Composite ID, incorporating the root and extension
Public Property | CompositeName | A simple human readable form of the name.
Public Property | DOB | The person's date of birth
Public Property | FamilyName | The family name/surname of the person
Public Property | GivenName | The forename of the person
Public Property | ID_Domain | Use for non-standard IDs such us extension^^^ID_Domain&root&ISO^ID_Type
Public Property | ID_Extension | The ientity of the person with the domain identified by ID_Root
Public Property | ID_Root | The Identifier of the domain/system issuing the person's ID - this is normally an OID
Public Property | ID_Root_Name | The "Name" of the system/organisation issuing the person's ID
Public Property | ID_Type | Use for non-standard IDs such us extension^^^ID_Domain&root&ISO^ID_Type
Public Property | MiddleName | The middle name of the person
Public Property | PhoneNumber | The person's contact number
Public Property | Prefix | The name prefix e.g. Mr, Mrs, Ms, Dr etc.
Public Property | Sex | The gender of the person
Public Property | SingleName | Simple human-readable version of the person's name
Public Property | StructuredNameDicom | Structured version of the name, as used in DICOM
Public Property | StructuredNameHl7 | Structured version of the name, as used in HL7
Public Property | Suffix | The name suffix e.g. Jnr. or III
Top
See Also

Reference

XdsPerson Class
XdsObjects Namespace


XdsPerson Constructor

XdsPerson Constructor

XdsObjects Namespace > XdsPerson Class : XdsPerson Constructor
Overload List
Overload | Description
XdsPerson Constructor() | Constructs a blank XdsPerson object
XdsPerson Constructor(String) | Constructs an XdsPerson object, with the SingleName initialised to to the given value
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPerson Class
XdsPerson Members


XdsPerson Constructor()

XdsPerson Constructor()

XdsObjects Namespace > XdsPerson Class > XdsPerson Constructor : XdsPerson Constructor()
Constructs a blank XdsPerson object
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsPerson()
public XdsPerson()
public:
XdsPerson();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPerson Class
XdsPerson Members
Overload List


XdsPerson Constructor(String)

XdsPerson Constructor(String)

XdsObjects Namespace > XdsPerson Class > XdsPerson Constructor : XdsPerson Constructor(String)
The name to set
Constructs an XdsPerson object, with the SingleName initialised to to the given value
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal Name As String _
)
Dim Name As String

Dim instance As New XdsPerson(Name)
public XdsPerson(
   string Name
)
public:
XdsPerson(
   String^ Name
)

Parameters

Name
The name to set
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPerson Class
XdsPerson Members
Overload List


XdsPerson Class Properties

XdsPerson Class Properties

XdsObjects Namespace : XdsPerson Class

For a list of all members of this type, see XdsPerson members.

Public Properties
 | Name | Description
Public Property | CompositeId | Composite ID, incorporating the root and extension
Public Property | CompositeName | A simple human readable form of the name.
Public Property | DOB | The person's date of birth
Public Property | FamilyName | The family name/surname of the person
Public Property | GivenName | The forename of the person
Public Property | ID_Domain | Use for non-standard IDs such us extension^^^ID_Domain&root&ISO^ID_Type
Public Property | ID_Extension | The ientity of the person with the domain identified by ID_Root
Public Property | ID_Root | The Identifier of the domain/system issuing the person's ID - this is normally an OID
Public Property | ID_Root_Name | The "Name" of the system/organisation issuing the person's ID
Public Property | ID_Type | Use for non-standard IDs such us extension^^^ID_Domain&root&ISO^ID_Type
Public Property | MiddleName | The middle name of the person
Public Property | PhoneNumber | The person's contact number
Public Property | Prefix | The name prefix e.g. Mr, Mrs, Ms, Dr etc.
Public Property | Sex | The gender of the person
Public Property | SingleName | Simple human-readable version of the person's name
Public Property | StructuredNameDicom | Structured version of the name, as used in DICOM
Public Property | StructuredNameHl7 | Structured version of the name, as used in HL7
Public Property | Suffix | The name suffix e.g. Jnr. or III
Top
See Also

Reference

XdsPerson Class
XdsObjects Namespace


CompositeId Property

CompositeId Property

XdsObjects Namespace > XdsPerson Class : CompositeId Property
Composite ID, incorporating the root and extension
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property CompositeId As String
Dim instance As XdsPerson
Dim value As String

instance.CompositeId = value

value = instance.CompositeId
public string CompositeId {get; set;}
public:
property String^ CompositeId {
   String^ get();
   void set (    String^ value);
}
Remarks

This property may be set or retrieved

When retrieved, the value is ID_Extension^^^&ID_Root&ISO"

When set, the supplied string is split into corresponding root and extension components, and stored in that form

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPerson Class
XdsPerson Members


CompositeName Property

CompositeName Property

XdsObjects Namespace > XdsPerson Class : CompositeName Property
A simple human readable form of the name.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property CompositeName As String
Dim instance As XdsPerson
Dim value As String

value = instance.CompositeName
public string CompositeName {get;}
public:
property String^ CompositeName {
   String^ get();
}
Remarks
If any of the individual components of the name are present, then this will return a space separated string - e.g. "Mr Joe Bloggs". If all the components are absent, then the SingleName property is returned.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPerson Class
XdsPerson Members


DOB Property

DOB Property

XdsObjects Namespace > XdsPerson Class : DOB Property
The person's date of birth
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DOB As Nullable(Of Date)
Dim instance As XdsPerson
Dim value As Nullable(Of Date)

instance.DOB = value

value = instance.DOB
public Nullable<DateTime> DOB {get; set;}
public:
property Nullable<DateTime> DOB {
   Nullable<DateTime> get();
   void set (    Nullable<DateTime> value);
}
Remarks
As this property is System.Nullable, it allows a null value to indicate an unknown or unavailable date.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPerson Class
XdsPerson Members


FamilyName Property

FamilyName Property

XdsObjects Namespace > XdsPerson Class : FamilyName Property
The family name/surname of the person
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property FamilyName As String
Dim instance As XdsPerson
Dim value As String

instance.FamilyName = value

value = instance.FamilyName
public string FamilyName {get; set;}
public:
property String^ FamilyName {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPerson Class
XdsPerson Members


GivenName Property

GivenName Property

XdsObjects Namespace > XdsPerson Class : GivenName Property
The forename of the person
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property GivenName As String
Dim instance As XdsPerson
Dim value As String

instance.GivenName = value

value = instance.GivenName
public string GivenName {get; set;}
public:
property String^ GivenName {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPerson Class
XdsPerson Members


ID_Domain Property

ID_Domain Property

XdsObjects Namespace > XdsPerson Class : ID_Domain Property
Use for non-standard IDs such us extension^^^ID_Domain&root&ISO^ID_Type
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ID_Domain As String
Dim instance As XdsPerson
Dim value As String

instance.ID_Domain = value

value = instance.ID_Domain
public string ID_Domain {get; set;}
public:
property String^ ID_Domain {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPerson Class
XdsPerson Members


ID_Extension Property

ID_Extension Property

XdsObjects Namespace > XdsPerson Class : ID_Extension Property
The ientity of the person with the domain identified by ID_Root
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ID_Extension As String
Dim instance As XdsPerson
Dim value As String

instance.ID_Extension = value

value = instance.ID_Extension
public string ID_Extension {get; set;}
public:
property String^ ID_Extension {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPerson Class
XdsPerson Members


ID_Root Property

ID_Root Property

XdsObjects Namespace > XdsPerson Class : ID_Root Property
The Identifier of the domain/system issuing the person's ID - this is normally an OID
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ID_Root As String
Dim instance As XdsPerson
Dim value As String

instance.ID_Root = value

value = instance.ID_Root
public string ID_Root {get; set;}
public:
property String^ ID_Root {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPerson Class
XdsPerson Members


ID_Root_Name Property

ID_Root_Name Property

XdsObjects Namespace > XdsPerson Class : ID_Root_Name Property
The "Name" of the system/organisation issuing the person's ID
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ID_Root_Name As String
Dim instance As XdsPerson
Dim value As String

instance.ID_Root_Name = value

value = instance.ID_Root_Name
public string ID_Root_Name {get; set;}
public:
property String^ ID_Root_Name {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPerson Class
XdsPerson Members


ID_Type Property

ID_Type Property

XdsObjects Namespace > XdsPerson Class : ID_Type Property
Use for non-standard IDs such us extension^^^ID_Domain&root&ISO^ID_Type
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ID_Type As String
Dim instance As XdsPerson
Dim value As String

instance.ID_Type = value

value = instance.ID_Type
public string ID_Type {get; set;}
public:
property String^ ID_Type {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPerson Class
XdsPerson Members


MiddleName Property

MiddleName Property

XdsObjects Namespace > XdsPerson Class : MiddleName Property
The middle name of the person
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property MiddleName As String
Dim instance As XdsPerson
Dim value As String

instance.MiddleName = value

value = instance.MiddleName
public string MiddleName {get; set;}
public:
property String^ MiddleName {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPerson Class
XdsPerson Members


PhoneNumber Property

PhoneNumber Property

XdsObjects Namespace > XdsPerson Class : PhoneNumber Property
The person's contact number
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property PhoneNumber As String
Dim instance As XdsPerson
Dim value As String

instance.PhoneNumber = value

value = instance.PhoneNumber
public string PhoneNumber {get; set;}
public:
property String^ PhoneNumber {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPerson Class
XdsPerson Members


Prefix Property

Prefix Property

XdsObjects Namespace > XdsPerson Class : Prefix Property
The name prefix e.g. Mr, Mrs, Ms, Dr etc.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Prefix As String
Dim instance As XdsPerson
Dim value As String

instance.Prefix = value

value = instance.Prefix
public string Prefix {get; set;}
public:
property String^ Prefix {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPerson Class
XdsPerson Members


Sex Property

Sex Property

XdsObjects Namespace > XdsPerson Class : Sex Property
The gender of the person
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Sex As String
Dim instance As XdsPerson
Dim value As String

instance.Sex = value

value = instance.Sex
public string Sex {get; set;}
public:
property String^ Sex {
   String^ get();
   void set (    String^ value);
}
Remarks
Value is normally "M" or "F"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPerson Class
XdsPerson Members


SingleName Property

SingleName Property

XdsObjects Namespace > XdsPerson Class : SingleName Property
Simple human-readable version of the person's name
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property SingleName As String
Dim instance As XdsPerson
Dim value As String

instance.SingleName = value

value = instance.SingleName
public string SingleName {get; set;}
public:
property String^ SingleName {
   String^ get();
   void set (    String^ value);
}
Remarks
This should not be used unless necessary - the individual components and CompositeName are more reliable and interoperable.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPerson Class
XdsPerson Members


StructuredNameDicom Property

StructuredNameDicom Property

XdsObjects Namespace > XdsPerson Class : StructuredNameDicom Property
Structured version of the name, as used in DICOM
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property StructuredNameDicom As String
Dim instance As XdsPerson
Dim value As String

value = instance.StructuredNameDicom
public string StructuredNameDicom {get;}
public:
property String^ StructuredNameDicom {
   String^ get();
}
Remarks
The returned value is of the form FamilyName^GivenName^MiddleName^Prefix^Suffix This is subtly different from HL7, which reverses the last 2 components
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPerson Class
XdsPerson Members


StructuredNameHl7 Property

StructuredNameHl7 Property

XdsObjects Namespace > XdsPerson Class : StructuredNameHl7 Property
Structured version of the name, as used in HL7
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property StructuredNameHl7 As String
Dim instance As XdsPerson
Dim value As String

value = instance.StructuredNameHl7
public string StructuredNameHl7 {get;}
public:
property String^ StructuredNameHl7 {
   String^ get();
}
Remarks
The returned value is of the form FamilyName^GivenName^MiddleName^Suffix^Prefix
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPerson Class
XdsPerson Members


Suffix Property

Suffix Property

XdsObjects Namespace > XdsPerson Class : Suffix Property
The name suffix e.g. Jnr. or III
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Suffix As String
Dim instance As XdsPerson
Dim value As String

instance.Suffix = value

value = instance.Suffix
public string Suffix {get; set;}
public:
property String^ Suffix {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsPerson Class
XdsPerson Members


XdsQueryRequest Class

XdsQueryRequest Class
Members

XdsObjects Namespace : XdsQueryRequest Class
Represents the data in a registry stored query
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsQueryRequest
Dim instance As XdsQueryRequest
public class XdsQueryRequest
public ref class XdsQueryRequest
Remarks

This is by far the most complex class in XdsObjects, due to the huge flexibility offered by registry stored queries.

Once a query has been created, it is passed by a document consumer implementation to the XdsDomain.RegistryStoredQuery method, which then returns the results obtained from the local registry or initiating gateway in the form of a XdsQueryResponse object.

Similarly, a registry implementation would receive such an object via the XdsSoapServer.RegistryStoredQueryReceived event, and would be expected to interpret it and respond appropriately via creation and return of an XdsQueryResponse.

Inheritance Hierarchy

System.Object
XdsObjects.XdsQueryRequest

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Members
XdsObjects Namespace


XdsQueryRequest Class Members

XdsQueryRequest Class Members
Properties

XdsObjects Namespace : XdsQueryRequest Class

The following tables list the members exposed by XdsQueryRequest.

Public Constructors
 | Name | Description
Public Constructor | XdsQueryRequest Constructor | Create a new XdsQueryRequest object
Top
Public Properties
 | Name | Description
Public Property | AssociationTypes | The types of association requested
Public Property | AssociationUUID | The UUIDs of the associations requested
Public Property | DocumentEntryAuthorPerson | Multiple values for FindDocument and FindDocumentsByReferenceId
Public Property | DocumentEntryClassCodes | Optional, Multiple Values for FindDocuments
Public Property | DocumentEntryConfidentialityCodeSet | Optional, Multiple Values for FindDocuments
Public Property | DocumentEntryCreationTimeFrom | Optional, Single Value for FindDocuments
Public Property | DocumentEntryCreationTimeTo | Optional, Single Value for FindDocuments
Public Property | DocumentEntryEntryUUID | Multiple Values for GetDocuments
Public Property | DocumentEntryEventCodeSet | Optional, Multiple Values for FindDocuments
Public Property | DocumentEntryFormatCodes | Multiple Values for GetDocuments
Public Property | DocumentEntryHealthcareFacilityTypeCodes | Optional, Multiple Values for FindDocuments
Public Property | DocumentEntryPracticeSettingCodes | Optional, Multiple Values for FindDocuments
Public Property | DocumentEntryReferenceIdList | Used for FindDocumentsByReferenceId query
Public Property | DocumentEntryServiceStartTimeFrom | Optional, Single Value for FindDocuments
Public Property | DocumentEntryServiceStartTimeTo | Optional, Single Value for FindDocuments
Public Property | DocumentEntryServiceStopTimeFrom | Optional, Single Value for FindDocuments
Public Property | DocumentEntryServiceStopTimeTo | Optional, Single Value for FindDocuments
Public Property | DocumentEntryStatus | Multiple Values. Required for FindDocument and GetAll
Public Property | DocumentEntryTypeCodes | Optional, Multiple Values for FindDocuments
Public Property | DocumentEntryUniqueId | Multiple Values for GetDocuments
Public Property | FolderCodeSet | Optional, Multiple Values for FindFolders but if included shall 1) have the same number of values as the corresponding ‘code’ attribute, 2) the ith value of the ‘code’ attribute (e.g. DocumentEntryClassCode) shall correspond to the ith value of the ‘codeScheme’ attribute (e.g. DocumentEntryClassCodeScheme).
Public Property | FolderEntryUUID | Optional, Multiple Values for GetFolders Either FolderEntryUUID or FolderUniqueId shall be specified.
Public Property | FolderLastUpdateTimeFrom | Optional, Single Value for FindFolders
Public Property | FolderLastUpdateTimeTo | Optional, Single Value for FindFolders
Public Property | FolderStatus | Required, Multiple Values for FindFolders
Public Property | FolderUniqueId | Optional, Multiple Values for GetFolders Either FolderEntryUUID or FolderUniqueId shall be specified.
Public Property | HomeCommunityID | The HomeCommunityID to which the request should be directed
Public Property | Id | GUID ID of the object for working with Entity Framework
Public Property | PatientId | Required, Single Value
Public Property | QueryReturnType | Specify the Return Type of the Query
Public Property | QueryType | Specify what Operation this Query does
Public Property | SubmissionSetAuthorPerson | Optional, Single Value for FindSubmissionSets
Public Property | SubmissionSetContentTypeCodes | Optional, Multiple Values for FindSubmissionSets
Public Property | SubmissionSetEntryUUID | Single Value for GetSubmissionSetAndContents Either SubmissionSetEntryUUID SubmissionSetUniqueId shall be specified.
Public Property | SubmissionSetSourceId | Optional, Multiple Values for FindSubmissionSets
Public Property | SubmissionSetStatus | Multiple Values. Required for FindSubmissionSets
Public Property | SubmissionSetSubmissionTimeFrom | Optional, Single Value for FindSubmissionSets
Public Property | SubmissionSetSubmissionTimeTo | Optional, Single Value for FindSubmissionSets
Public Property | SubmissionSetUniqueId | Single Value for GetSubmissionSetAndContents Either SubmissionSetEntryUUID SubmissionSetUniqueId shall be specified.
Top
See Also

Reference

XdsQueryRequest Class
XdsObjects Namespace


XdsQueryRequest Constructor

XdsQueryRequest Constructor

XdsObjects Namespace > XdsQueryRequest Class : XdsQueryRequest Constructor
Create a new XdsQueryRequest object
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsQueryRequest()
public XdsQueryRequest()
public:
XdsQueryRequest();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


XdsQueryRequest Class Properties

XdsQueryRequest Class Properties

XdsObjects Namespace : XdsQueryRequest Class

For a list of all members of this type, see XdsQueryRequest members.

Public Properties
 | Name | Description
Public Property | AssociationTypes | The types of association requested
Public Property | AssociationUUID | The UUIDs of the associations requested
Public Property | DocumentEntryAuthorPerson | Multiple values for FindDocument and FindDocumentsByReferenceId
Public Property | DocumentEntryClassCodes | Optional, Multiple Values for FindDocuments
Public Property | DocumentEntryConfidentialityCodeSet | Optional, Multiple Values for FindDocuments
Public Property | DocumentEntryCreationTimeFrom | Optional, Single Value for FindDocuments
Public Property | DocumentEntryCreationTimeTo | Optional, Single Value for FindDocuments
Public Property | DocumentEntryEntryUUID | Multiple Values for GetDocuments
Public Property | DocumentEntryEventCodeSet | Optional, Multiple Values for FindDocuments
Public Property | DocumentEntryFormatCodes | Multiple Values for GetDocuments
Public Property | DocumentEntryHealthcareFacilityTypeCodes | Optional, Multiple Values for FindDocuments
Public Property | DocumentEntryPracticeSettingCodes | Optional, Multiple Values for FindDocuments
Public Property | DocumentEntryReferenceIdList | Used for FindDocumentsByReferenceId query
Public Property | DocumentEntryServiceStartTimeFrom | Optional, Single Value for FindDocuments
Public Property | DocumentEntryServiceStartTimeTo | Optional, Single Value for FindDocuments
Public Property | DocumentEntryServiceStopTimeFrom | Optional, Single Value for FindDocuments
Public Property | DocumentEntryServiceStopTimeTo | Optional, Single Value for FindDocuments
Public Property | DocumentEntryStatus | Multiple Values. Required for FindDocument and GetAll
Public Property | DocumentEntryTypeCodes | Optional, Multiple Values for FindDocuments
Public Property | DocumentEntryUniqueId | Multiple Values for GetDocuments
Public Property | FolderCodeSet | Optional, Multiple Values for FindFolders but if included shall 1) have the same number of values as the corresponding ‘code’ attribute, 2) the ith value of the ‘code’ attribute (e.g. DocumentEntryClassCode) shall correspond to the ith value of the ‘codeScheme’ attribute (e.g. DocumentEntryClassCodeScheme).
Public Property | FolderEntryUUID | Optional, Multiple Values for GetFolders Either FolderEntryUUID or FolderUniqueId shall be specified.
Public Property | FolderLastUpdateTimeFrom | Optional, Single Value for FindFolders
Public Property | FolderLastUpdateTimeTo | Optional, Single Value for FindFolders
Public Property | FolderStatus | Required, Multiple Values for FindFolders
Public Property | FolderUniqueId | Optional, Multiple Values for GetFolders Either FolderEntryUUID or FolderUniqueId shall be specified.
Public Property | HomeCommunityID | The HomeCommunityID to which the request should be directed
Public Property | Id | GUID ID of the object for working with Entity Framework
Public Property | PatientId | Required, Single Value
Public Property | QueryReturnType | Specify the Return Type of the Query
Public Property | QueryType | Specify what Operation this Query does
Public Property | SubmissionSetAuthorPerson | Optional, Single Value for FindSubmissionSets
Public Property | SubmissionSetContentTypeCodes | Optional, Multiple Values for FindSubmissionSets
Public Property | SubmissionSetEntryUUID | Single Value for GetSubmissionSetAndContents Either SubmissionSetEntryUUID SubmissionSetUniqueId shall be specified.
Public Property | SubmissionSetSourceId | Optional, Multiple Values for FindSubmissionSets
Public Property | SubmissionSetStatus | Multiple Values. Required for FindSubmissionSets
Public Property | SubmissionSetSubmissionTimeFrom | Optional, Single Value for FindSubmissionSets
Public Property | SubmissionSetSubmissionTimeTo | Optional, Single Value for FindSubmissionSets
Public Property | SubmissionSetUniqueId | Single Value for GetSubmissionSetAndContents Either SubmissionSetEntryUUID SubmissionSetUniqueId shall be specified.
Top
See Also

Reference

XdsQueryRequest Class
XdsObjects Namespace


AssociationTypes Property

AssociationTypes Property

XdsObjects Namespace > XdsQueryRequest Class : AssociationTypes Property
The types of association requested
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property AssociationTypes As List(Of AssociationType)
Dim instance As XdsQueryRequest
Dim value As List(Of AssociationType)

instance.AssociationTypes = value

value = instance.AssociationTypes
public List<AssociationType> AssociationTypes {get; set;}
public:
property List<AssociationType>^ AssociationTypes {
   List<AssociationType>^ get();
   void set (    List<AssociationType>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


AssociationUUID Property

AssociationUUID Property

XdsObjects Namespace > XdsQueryRequest Class : AssociationUUID Property
The UUIDs of the associations requested
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property AssociationUUID As XdsObjectRefList
Dim instance As XdsQueryRequest
Dim value As XdsObjectRefList

instance.AssociationUUID = value

value = instance.AssociationUUID
public XdsObjectRefList AssociationUUID {get; set;}
public:
property XdsObjectRefList^ AssociationUUID {
   XdsObjectRefList^ get();
   void set (    XdsObjectRefList^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


DocumentEntryAuthorPerson Property

DocumentEntryAuthorPerson Property

XdsObjects Namespace > XdsQueryRequest Class : DocumentEntryAuthorPerson Property
Multiple values for FindDocument and FindDocumentsByReferenceId
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DocumentEntryAuthorPerson As XdsMultiString
Dim instance As XdsQueryRequest
Dim value As XdsMultiString

instance.DocumentEntryAuthorPerson = value

value = instance.DocumentEntryAuthorPerson
public XdsMultiString DocumentEntryAuthorPerson {get; set;}
public:
property XdsMultiString^ DocumentEntryAuthorPerson {
   XdsMultiString^ get();
   void set (    XdsMultiString^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


DocumentEntryClassCodes Property

DocumentEntryClassCodes Property

XdsObjects Namespace > XdsQueryRequest Class : DocumentEntryClassCodes Property
Optional, Multiple Values for FindDocuments
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DocumentEntryClassCodes As List(Of XdsCode)
Dim instance As XdsQueryRequest
Dim value As List(Of XdsCode)

instance.DocumentEntryClassCodes = value

value = instance.DocumentEntryClassCodes
public List<XdsCode> DocumentEntryClassCodes {get; set;}
public:
property List<XdsCode^>^ DocumentEntryClassCodes {
   List<XdsCode^>^ get();
   void set (    List<XdsCode^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


DocumentEntryConfidentialityCodeSet Property

DocumentEntryConfidentialityCodeSet Property

XdsObjects Namespace > XdsQueryRequest Class : DocumentEntryConfidentialityCodeSet Property
Optional, Multiple Values for FindDocuments
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DocumentEntryConfidentialityCodeSet As List(Of List(Of XdsCode))
Dim instance As XdsQueryRequest
Dim value As List(Of List(Of XdsCode))

instance.DocumentEntryConfidentialityCodeSet = value

value = instance.DocumentEntryConfidentialityCodeSet
public List<List<XdsCode>> DocumentEntryConfidentialityCodeSet {get; set;}
public:
property List<List<XdsCode^>^>^ DocumentEntryConfidentialityCodeSet {
   List<List<XdsCode^>^>^ get();
   void set (    List<List<XdsCode^>^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


DocumentEntryCreationTimeFrom Property

DocumentEntryCreationTimeFrom Property

XdsObjects Namespace > XdsQueryRequest Class : DocumentEntryCreationTimeFrom Property
Optional, Single Value for FindDocuments
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DocumentEntryCreationTimeFrom As Nullable(Of Date)
Dim instance As XdsQueryRequest
Dim value As Nullable(Of Date)

instance.DocumentEntryCreationTimeFrom = value

value = instance.DocumentEntryCreationTimeFrom
public Nullable<DateTime> DocumentEntryCreationTimeFrom {get; set;}
public:
property Nullable<DateTime> DocumentEntryCreationTimeFrom {
   Nullable<DateTime> get();
   void set (    Nullable<DateTime> value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


DocumentEntryCreationTimeTo Property

DocumentEntryCreationTimeTo Property

XdsObjects Namespace > XdsQueryRequest Class : DocumentEntryCreationTimeTo Property
Optional, Single Value for FindDocuments
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DocumentEntryCreationTimeTo As Nullable(Of Date)
Dim instance As XdsQueryRequest
Dim value As Nullable(Of Date)

instance.DocumentEntryCreationTimeTo = value

value = instance.DocumentEntryCreationTimeTo
public Nullable<DateTime> DocumentEntryCreationTimeTo {get; set;}
public:
property Nullable<DateTime> DocumentEntryCreationTimeTo {
   Nullable<DateTime> get();
   void set (    Nullable<DateTime> value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


DocumentEntryEntryUUID Property

DocumentEntryEntryUUID Property

XdsObjects Namespace > XdsQueryRequest Class : DocumentEntryEntryUUID Property
Multiple Values for GetDocuments
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DocumentEntryEntryUUID As XdsObjectRefList
Dim instance As XdsQueryRequest
Dim value As XdsObjectRefList

instance.DocumentEntryEntryUUID = value

value = instance.DocumentEntryEntryUUID
public XdsObjectRefList DocumentEntryEntryUUID {get; set;}
public:
property XdsObjectRefList^ DocumentEntryEntryUUID {
   XdsObjectRefList^ get();
   void set (    XdsObjectRefList^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


DocumentEntryEventCodeSet Property

DocumentEntryEventCodeSet Property

XdsObjects Namespace > XdsQueryRequest Class : DocumentEntryEventCodeSet Property
Optional, Multiple Values for FindDocuments
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DocumentEntryEventCodeSet As List(Of List(Of XdsCode))
Dim instance As XdsQueryRequest
Dim value As List(Of List(Of XdsCode))

instance.DocumentEntryEventCodeSet = value

value = instance.DocumentEntryEventCodeSet
public List<List<XdsCode>> DocumentEntryEventCodeSet {get; set;}
public:
property List<List<XdsCode^>^>^ DocumentEntryEventCodeSet {
   List<List<XdsCode^>^>^ get();
   void set (    List<List<XdsCode^>^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


DocumentEntryFormatCodes Property

DocumentEntryFormatCodes Property

XdsObjects Namespace > XdsQueryRequest Class : DocumentEntryFormatCodes Property
Multiple Values for GetDocuments
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DocumentEntryFormatCodes As List(Of XdsCode)
Dim instance As XdsQueryRequest
Dim value As List(Of XdsCode)

instance.DocumentEntryFormatCodes = value

value = instance.DocumentEntryFormatCodes
public List<XdsCode> DocumentEntryFormatCodes {get; set;}
public:
property List<XdsCode^>^ DocumentEntryFormatCodes {
   List<XdsCode^>^ get();
   void set (    List<XdsCode^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


DocumentEntryHealthcareFacilityTypeCodes Property

DocumentEntryHealthcareFacilityTypeCodes Property

XdsObjects Namespace > XdsQueryRequest Class : DocumentEntryHealthcareFacilityTypeCodes Property
Optional, Multiple Values for FindDocuments
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DocumentEntryHealthcareFacilityTypeCodes As List(Of XdsCode)
Dim instance As XdsQueryRequest
Dim value As List(Of XdsCode)

instance.DocumentEntryHealthcareFacilityTypeCodes = value

value = instance.DocumentEntryHealthcareFacilityTypeCodes
public List<XdsCode> DocumentEntryHealthcareFacilityTypeCodes {get; set;}
public:
property List<XdsCode^>^ DocumentEntryHealthcareFacilityTypeCodes {
   List<XdsCode^>^ get();
   void set (    List<XdsCode^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


DocumentEntryPracticeSettingCodes Property

DocumentEntryPracticeSettingCodes Property

XdsObjects Namespace > XdsQueryRequest Class : DocumentEntryPracticeSettingCodes Property
Optional, Multiple Values for FindDocuments
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DocumentEntryPracticeSettingCodes As List(Of XdsCode)
Dim instance As XdsQueryRequest
Dim value As List(Of XdsCode)

instance.DocumentEntryPracticeSettingCodes = value

value = instance.DocumentEntryPracticeSettingCodes
public List<XdsCode> DocumentEntryPracticeSettingCodes {get; set;}
public:
property List<XdsCode^>^ DocumentEntryPracticeSettingCodes {
   List<XdsCode^>^ get();
   void set (    List<XdsCode^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


DocumentEntryReferenceIdList Property

DocumentEntryReferenceIdList Property

XdsObjects Namespace > XdsQueryRequest Class : DocumentEntryReferenceIdList Property
Used for FindDocumentsByReferenceId query
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DocumentEntryReferenceIdList As XdsMultiString
Dim instance As XdsQueryRequest
Dim value As XdsMultiString

instance.DocumentEntryReferenceIdList = value

value = instance.DocumentEntryReferenceIdList
public XdsMultiString DocumentEntryReferenceIdList {get; set;}
public:
property XdsMultiString^ DocumentEntryReferenceIdList {
   XdsMultiString^ get();
   void set (    XdsMultiString^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


DocumentEntryServiceStartTimeFrom Property

DocumentEntryServiceStartTimeFrom Property

XdsObjects Namespace > XdsQueryRequest Class : DocumentEntryServiceStartTimeFrom Property
Optional, Single Value for FindDocuments
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DocumentEntryServiceStartTimeFrom As Nullable(Of Date)
Dim instance As XdsQueryRequest
Dim value As Nullable(Of Date)

instance.DocumentEntryServiceStartTimeFrom = value

value = instance.DocumentEntryServiceStartTimeFrom
public Nullable<DateTime> DocumentEntryServiceStartTimeFrom {get; set;}
public:
property Nullable<DateTime> DocumentEntryServiceStartTimeFrom {
   Nullable<DateTime> get();
   void set (    Nullable<DateTime> value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


DocumentEntryServiceStartTimeTo Property

DocumentEntryServiceStartTimeTo Property

XdsObjects Namespace > XdsQueryRequest Class : DocumentEntryServiceStartTimeTo Property
Optional, Single Value for FindDocuments
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DocumentEntryServiceStartTimeTo As Nullable(Of Date)
Dim instance As XdsQueryRequest
Dim value As Nullable(Of Date)

instance.DocumentEntryServiceStartTimeTo = value

value = instance.DocumentEntryServiceStartTimeTo
public Nullable<DateTime> DocumentEntryServiceStartTimeTo {get; set;}
public:
property Nullable<DateTime> DocumentEntryServiceStartTimeTo {
   Nullable<DateTime> get();
   void set (    Nullable<DateTime> value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


DocumentEntryServiceStopTimeFrom Property

DocumentEntryServiceStopTimeFrom Property

XdsObjects Namespace > XdsQueryRequest Class : DocumentEntryServiceStopTimeFrom Property
Optional, Single Value for FindDocuments
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DocumentEntryServiceStopTimeFrom As Nullable(Of Date)
Dim instance As XdsQueryRequest
Dim value As Nullable(Of Date)

instance.DocumentEntryServiceStopTimeFrom = value

value = instance.DocumentEntryServiceStopTimeFrom
public Nullable<DateTime> DocumentEntryServiceStopTimeFrom {get; set;}
public:
property Nullable<DateTime> DocumentEntryServiceStopTimeFrom {
   Nullable<DateTime> get();
   void set (    Nullable<DateTime> value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


DocumentEntryServiceStopTimeTo Property

DocumentEntryServiceStopTimeTo Property

XdsObjects Namespace > XdsQueryRequest Class : DocumentEntryServiceStopTimeTo Property
Optional, Single Value for FindDocuments
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DocumentEntryServiceStopTimeTo As Nullable(Of Date)
Dim instance As XdsQueryRequest
Dim value As Nullable(Of Date)

instance.DocumentEntryServiceStopTimeTo = value

value = instance.DocumentEntryServiceStopTimeTo
public Nullable<DateTime> DocumentEntryServiceStopTimeTo {get; set;}
public:
property Nullable<DateTime> DocumentEntryServiceStopTimeTo {
   Nullable<DateTime> get();
   void set (    Nullable<DateTime> value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


DocumentEntryStatus Property

DocumentEntryStatus Property

XdsObjects Namespace > XdsQueryRequest Class : DocumentEntryStatus Property
Multiple Values. Required for FindDocument and GetAll
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DocumentEntryStatus As AvailabilityStatusCode
Dim instance As XdsQueryRequest
Dim value As AvailabilityStatusCode

instance.DocumentEntryStatus = value

value = instance.DocumentEntryStatus
public AvailabilityStatusCode DocumentEntryStatus {get; set;}
public:
property AvailabilityStatusCode DocumentEntryStatus {
   AvailabilityStatusCode get();
   void set (    AvailabilityStatusCode value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


DocumentEntryTypeCodes Property

DocumentEntryTypeCodes Property

XdsObjects Namespace > XdsQueryRequest Class : DocumentEntryTypeCodes Property
Optional, Multiple Values for FindDocuments
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DocumentEntryTypeCodes As List(Of XdsCode)
Dim instance As XdsQueryRequest
Dim value As List(Of XdsCode)

instance.DocumentEntryTypeCodes = value

value = instance.DocumentEntryTypeCodes
public List<XdsCode> DocumentEntryTypeCodes {get; set;}
public:
property List<XdsCode^>^ DocumentEntryTypeCodes {
   List<XdsCode^>^ get();
   void set (    List<XdsCode^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


DocumentEntryUniqueId Property

DocumentEntryUniqueId Property

XdsObjects Namespace > XdsQueryRequest Class : DocumentEntryUniqueId Property
Multiple Values for GetDocuments
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DocumentEntryUniqueId As XdsObjectRefList
Dim instance As XdsQueryRequest
Dim value As XdsObjectRefList

instance.DocumentEntryUniqueId = value

value = instance.DocumentEntryUniqueId
public XdsObjectRefList DocumentEntryUniqueId {get; set;}
public:
property XdsObjectRefList^ DocumentEntryUniqueId {
   XdsObjectRefList^ get();
   void set (    XdsObjectRefList^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


FolderCodeSet Property

FolderCodeSet Property

XdsObjects Namespace > XdsQueryRequest Class : FolderCodeSet Property
Optional, Multiple Values for FindFolders but if included shall 1) have the same number of values as the corresponding ‘code’ attribute, 2) the ith value of the ‘code’ attribute (e.g. DocumentEntryClassCode) shall correspond to the ith value of the ‘codeScheme’ attribute (e.g. DocumentEntryClassCodeScheme).
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property FolderCodeSet As List(Of List(Of XdsCode))
Dim instance As XdsQueryRequest
Dim value As List(Of List(Of XdsCode))

instance.FolderCodeSet = value

value = instance.FolderCodeSet
public List<List<XdsCode>> FolderCodeSet {get; set;}
public:
property List<List<XdsCode^>^>^ FolderCodeSet {
   List<List<XdsCode^>^>^ get();
   void set (    List<List<XdsCode^>^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


FolderEntryUUID Property

FolderEntryUUID Property

XdsObjects Namespace > XdsQueryRequest Class : FolderEntryUUID Property
Optional, Multiple Values for GetFolders Either FolderEntryUUID or FolderUniqueId shall be specified.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property FolderEntryUUID As XdsObjectRefList
Dim instance As XdsQueryRequest
Dim value As XdsObjectRefList

instance.FolderEntryUUID = value

value = instance.FolderEntryUUID
public XdsObjectRefList FolderEntryUUID {get; set;}
public:
property XdsObjectRefList^ FolderEntryUUID {
   XdsObjectRefList^ get();
   void set (    XdsObjectRefList^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


FolderLastUpdateTimeFrom Property

FolderLastUpdateTimeFrom Property

XdsObjects Namespace > XdsQueryRequest Class : FolderLastUpdateTimeFrom Property
Optional, Single Value for FindFolders
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property FolderLastUpdateTimeFrom As Nullable(Of Date)
Dim instance As XdsQueryRequest
Dim value As Nullable(Of Date)

instance.FolderLastUpdateTimeFrom = value

value = instance.FolderLastUpdateTimeFrom
public Nullable<DateTime> FolderLastUpdateTimeFrom {get; set;}
public:
property Nullable<DateTime> FolderLastUpdateTimeFrom {
   Nullable<DateTime> get();
   void set (    Nullable<DateTime> value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


FolderLastUpdateTimeTo Property

FolderLastUpdateTimeTo Property

XdsObjects Namespace > XdsQueryRequest Class : FolderLastUpdateTimeTo Property
Optional, Single Value for FindFolders
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property FolderLastUpdateTimeTo As Nullable(Of Date)
Dim instance As XdsQueryRequest
Dim value As Nullable(Of Date)

instance.FolderLastUpdateTimeTo = value

value = instance.FolderLastUpdateTimeTo
public Nullable<DateTime> FolderLastUpdateTimeTo {get; set;}
public:
property Nullable<DateTime> FolderLastUpdateTimeTo {
   Nullable<DateTime> get();
   void set (    Nullable<DateTime> value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


FolderStatus Property

FolderStatus Property

XdsObjects Namespace > XdsQueryRequest Class : FolderStatus Property
Required, Multiple Values for FindFolders
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property FolderStatus As AvailabilityStatusCode
Dim instance As XdsQueryRequest
Dim value As AvailabilityStatusCode

instance.FolderStatus = value

value = instance.FolderStatus
public AvailabilityStatusCode FolderStatus {get; set;}
public:
property AvailabilityStatusCode FolderStatus {
   AvailabilityStatusCode get();
   void set (    AvailabilityStatusCode value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


FolderUniqueId Property

FolderUniqueId Property

XdsObjects Namespace > XdsQueryRequest Class : FolderUniqueId Property
Optional, Multiple Values for GetFolders Either FolderEntryUUID or FolderUniqueId shall be specified.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property FolderUniqueId As XdsObjectRefList
Dim instance As XdsQueryRequest
Dim value As XdsObjectRefList

instance.FolderUniqueId = value

value = instance.FolderUniqueId
public XdsObjectRefList FolderUniqueId {get; set;}
public:
property XdsObjectRefList^ FolderUniqueId {
   XdsObjectRefList^ get();
   void set (    XdsObjectRefList^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


HomeCommunityID Property (XdsQueryRequest)

HomeCommunityID Property (XdsQueryRequest)

XdsObjects Namespace > XdsQueryRequest Class : HomeCommunityID Property
The HomeCommunityID to which the request should be directed
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property HomeCommunityID As String
Dim instance As XdsQueryRequest
Dim value As String

instance.HomeCommunityID = value

value = instance.HomeCommunityID
public string HomeCommunityID {get; set;}
public:
property String^ HomeCommunityID {
   String^ get();
   void set (    String^ value);
}
Remarks
This is not needed in broad patient ID based (initial) queries but must be set correctly for any "follow-up" queries, if it has been returned in the responses which are being followed-up. i.e. this value must be set to the value found in XdsDocument.HomeCommunityID, XdsFolder.HomeCommunityID or HomeCommunityID
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


Id Property (XdsQueryRequest)

Id Property (XdsQueryRequest)

XdsObjects Namespace > XdsQueryRequest Class : Id Property
GUID ID of the object for working with Entity Framework
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Id As Guid
Dim instance As XdsQueryRequest
Dim value As Guid

instance.Id = value

value = instance.Id
public Guid Id {get; set;}
public:
property Guid Id {
   Guid get();
   void set (    Guid value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


PatientId Property (XdsQueryRequest)

PatientId Property (XdsQueryRequest)

XdsObjects Namespace > XdsQueryRequest Class : PatientId Property
Required, Single Value
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property PatientId As String
Dim instance As XdsQueryRequest
Dim value As String

instance.PatientId = value

value = instance.PatientId
public string PatientId {get; set;}
public:
property String^ PatientId {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


QueryReturnType Property

QueryReturnType Property

XdsObjects Namespace > XdsQueryRequest Class : QueryReturnType Property
Specify the Return Type of the Query
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property QueryReturnType As QueryReturnType
Dim instance As XdsQueryRequest
Dim value As QueryReturnType

instance.QueryReturnType = value

value = instance.QueryReturnType
public QueryReturnType QueryReturnType {get; set;}
public:
property QueryReturnType QueryReturnType {
   QueryReturnType get();
   void set (    QueryReturnType value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


QueryType Property

QueryType Property

XdsObjects Namespace > XdsQueryRequest Class : QueryType Property
Specify what Operation this Query does
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property QueryType As QueryType
Dim instance As XdsQueryRequest
Dim value As QueryType

instance.QueryType = value

value = instance.QueryType
public QueryType QueryType {get; set;}
public:
property QueryType QueryType {
   QueryType get();
   void set (    QueryType value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


SubmissionSetAuthorPerson Property

SubmissionSetAuthorPerson Property

XdsObjects Namespace > XdsQueryRequest Class : SubmissionSetAuthorPerson Property
Optional, Single Value for FindSubmissionSets
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property SubmissionSetAuthorPerson As String
Dim instance As XdsQueryRequest
Dim value As String

instance.SubmissionSetAuthorPerson = value

value = instance.SubmissionSetAuthorPerson
public string SubmissionSetAuthorPerson {get; set;}
public:
property String^ SubmissionSetAuthorPerson {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


SubmissionSetContentTypeCodes Property

SubmissionSetContentTypeCodes Property

XdsObjects Namespace > XdsQueryRequest Class : SubmissionSetContentTypeCodes Property
Optional, Multiple Values for FindSubmissionSets
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property SubmissionSetContentTypeCodes As List(Of XdsCode)
Dim instance As XdsQueryRequest
Dim value As List(Of XdsCode)

instance.SubmissionSetContentTypeCodes = value

value = instance.SubmissionSetContentTypeCodes
public List<XdsCode> SubmissionSetContentTypeCodes {get; set;}
public:
property List<XdsCode^>^ SubmissionSetContentTypeCodes {
   List<XdsCode^>^ get();
   void set (    List<XdsCode^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


SubmissionSetEntryUUID Property

SubmissionSetEntryUUID Property

XdsObjects Namespace > XdsQueryRequest Class : SubmissionSetEntryUUID Property
Single Value for GetSubmissionSetAndContents Either SubmissionSetEntryUUID SubmissionSetUniqueId shall be specified.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property SubmissionSetEntryUUID As XdsObjectRef
Dim instance As XdsQueryRequest
Dim value As XdsObjectRef

instance.SubmissionSetEntryUUID = value

value = instance.SubmissionSetEntryUUID
public XdsObjectRef SubmissionSetEntryUUID {get; set;}
public:
property XdsObjectRef^ SubmissionSetEntryUUID {
   XdsObjectRef^ get();
   void set (    XdsObjectRef^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


SubmissionSetSourceId Property

SubmissionSetSourceId Property

XdsObjects Namespace > XdsQueryRequest Class : SubmissionSetSourceId Property
Optional, Multiple Values for FindSubmissionSets
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property SubmissionSetSourceId As XdsMultiString
Dim instance As XdsQueryRequest
Dim value As XdsMultiString

instance.SubmissionSetSourceId = value

value = instance.SubmissionSetSourceId
public XdsMultiString SubmissionSetSourceId {get; set;}
public:
property XdsMultiString^ SubmissionSetSourceId {
   XdsMultiString^ get();
   void set (    XdsMultiString^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


SubmissionSetStatus Property (XdsQueryRequest)

SubmissionSetStatus Property (XdsQueryRequest)

XdsObjects Namespace > XdsQueryRequest Class : SubmissionSetStatus Property
Multiple Values. Required for FindSubmissionSets
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property SubmissionSetStatus As AvailabilityStatusCode
Dim instance As XdsQueryRequest
Dim value As AvailabilityStatusCode

instance.SubmissionSetStatus = value

value = instance.SubmissionSetStatus
public AvailabilityStatusCode SubmissionSetStatus {get; set;}
public:
property AvailabilityStatusCode SubmissionSetStatus {
   AvailabilityStatusCode get();
   void set (    AvailabilityStatusCode value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


SubmissionSetSubmissionTimeFrom Property

SubmissionSetSubmissionTimeFrom Property

XdsObjects Namespace > XdsQueryRequest Class : SubmissionSetSubmissionTimeFrom Property
Optional, Single Value for FindSubmissionSets
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property SubmissionSetSubmissionTimeFrom As Nullable(Of Date)
Dim instance As XdsQueryRequest
Dim value As Nullable(Of Date)

instance.SubmissionSetSubmissionTimeFrom = value

value = instance.SubmissionSetSubmissionTimeFrom
public Nullable<DateTime> SubmissionSetSubmissionTimeFrom {get; set;}
public:
property Nullable<DateTime> SubmissionSetSubmissionTimeFrom {
   Nullable<DateTime> get();
   void set (    Nullable<DateTime> value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


SubmissionSetSubmissionTimeTo Property

SubmissionSetSubmissionTimeTo Property

XdsObjects Namespace > XdsQueryRequest Class : SubmissionSetSubmissionTimeTo Property
Optional, Single Value for FindSubmissionSets
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property SubmissionSetSubmissionTimeTo As Nullable(Of Date)
Dim instance As XdsQueryRequest
Dim value As Nullable(Of Date)

instance.SubmissionSetSubmissionTimeTo = value

value = instance.SubmissionSetSubmissionTimeTo
public Nullable<DateTime> SubmissionSetSubmissionTimeTo {get; set;}
public:
property Nullable<DateTime> SubmissionSetSubmissionTimeTo {
   Nullable<DateTime> get();
   void set (    Nullable<DateTime> value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


SubmissionSetUniqueId Property

SubmissionSetUniqueId Property

XdsObjects Namespace > XdsQueryRequest Class : SubmissionSetUniqueId Property
Single Value for GetSubmissionSetAndContents Either SubmissionSetEntryUUID SubmissionSetUniqueId shall be specified.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property SubmissionSetUniqueId As XdsObjectRef
Dim instance As XdsQueryRequest
Dim value As XdsObjectRef

instance.SubmissionSetUniqueId = value

value = instance.SubmissionSetUniqueId
public XdsObjectRef SubmissionSetUniqueId {get; set;}
public:
property XdsObjectRef^ SubmissionSetUniqueId {
   XdsObjectRef^ get();
   void set (    XdsObjectRef^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryRequest Class
XdsQueryRequest Members


XdsQueryResponse Class

XdsQueryResponse Class
Members

XdsObjects Namespace : XdsQueryResponse Class
Holds the result of an XDS RegistryStoredQuery or CrossGatewayQuery
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsQueryResponse
   Inherits XdsRegistryResponse
Dim instance As XdsQueryResponse
public class XdsQueryResponse : XdsRegistryResponse
public ref class XdsQueryResponse : public XdsRegistryResponse
Remarks

This object can be:

  • Created by a registry to handle an expected response
  • Received and modified (e.g. combined using Combine or to add a HomeCommunityID values to the contained items by a gateway
  • Received and processed by a Document Consumer

This object holds the overall query response, including the success/error status, and errors (both inherited from XdsRegistryResponse), as well as the returned data in the following properties:

  • ReturnedDocuments
  • ReturnedFolders
  • ReturnedSubmissionSets
  • ReturnedObjectRefs
Inheritance Hierarchy

System.Object
XdsObjects.XdsRegistryResponse
XdsObjects.XdsQueryResponse

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryResponse Members
XdsObjects Namespace


XdsQueryResponse Class Members

XdsQueryResponse Class Members
Properties Methods

XdsObjects Namespace : XdsQueryResponse Class

The following tables list the members exposed by XdsQueryResponse.

Public Constructors
 | Name | Description
Public Constructor | XdsQueryResponse Constructor | Overloaded. Create a new XdsQueryResponse object
Top
Public Properties
 | Name | Description
Public Property | Errors | The errors in this response (Inherited from XdsObjects.XdsRegistryResponse)
Public Property | ReturnedAssociations | List of Associations returned by the query
Public Property | ReturnedDocuments | List of documents returned by the query
Public Property | ReturnedFolders | List of Folders returned by the query
Public Property | ReturnedObjectRefs | List of Object References returned by the query
Public Property | ReturnedSubmissionSets | List of Submission Sets returned by the query
Public Property | Status | The status send or received in this response. (Inherited from XdsObjects.XdsRegistryResponse)
Top
Public Methods
 | Name | Description
Public Method | AddError | Overloaded. Add a new XdsError to the XdsRegistryResponse.Errors collection, given the XdsObjects.Enums.XdsErrorCode, plus Location and CodeContext (Inherited from XdsObjects.XdsRegistryResponse)
Public Method | Combine | Combine query responses
Public Method | ContainsErrors | Indicates whether the response contains any error codes (Inherited from XdsObjects.XdsRegistryResponse)
Public Method | SetHomeCommunityID | Set the HomeCommunity for all items ready for sending out as part of XCA gateway use.
Top
See Also

Reference

XdsQueryResponse Class
XdsObjects Namespace


XdsQueryResponse Constructor

XdsQueryResponse Constructor

XdsObjects Namespace > XdsQueryResponse Class : XdsQueryResponse Constructor
Create a new XdsQueryResponse object
Overload List
Overload | Description
XdsQueryResponse Constructor() | Create a new empty XdsQueryResponse object
XdsQueryResponse Constructor(Exception,XdsErrorCode) | Create a query response given a System.Exception and an IHE XDS XdsObjects.Enums.XdsErrorCode
XdsQueryResponse Constructor(XdsErrorCode,String,String) | Create a query response given an IHE XDS XdsObjects.Enums.XdsErrorCode, plus Location and CodeContext
XdsQueryResponse Constructor(XdsErrorCode,String) | Create a query response given an IHE XDS XdsObjects.Enums.XdsErrorCode, plus Location and CodeContext
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryResponse Class
XdsQueryResponse Members


XdsQueryResponse Constructor()

XdsQueryResponse Constructor()

XdsObjects Namespace > XdsQueryResponse Class > XdsQueryResponse Constructor : XdsQueryResponse Constructor()
Create a new empty XdsQueryResponse object
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsQueryResponse()
public XdsQueryResponse()
public:
XdsQueryResponse();
Remarks
This version would only be used by a registry to create a new response, prior to populating it from a database.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryResponse Class
XdsQueryResponse Members
Overload List


XdsQueryResponse Constructor(Exception,XdsErrorCode)

XdsQueryResponse Constructor(Exception,XdsErrorCode)

XdsObjects Namespace > XdsQueryResponse Class > XdsQueryResponse Constructor : XdsQueryResponse Constructor(Exception,XdsErrorCode)
The exception to use to initialise a new XdsError
The XDS specific error code to use.
Create a query response given a System.Exception and an IHE XDS XdsObjects.Enums.XdsErrorCode
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal e As Exception, _
   ByVal ErrorCode As XdsErrorCode _
)
Dim e As Exception
Dim ErrorCode As XdsErrorCode

Dim instance As New XdsQueryResponse(e, ErrorCode)
public XdsQueryResponse(
   Exception e,
   XdsErrorCode ErrorCode
)
public:
XdsQueryResponse(
   Exception^ e,
   XdsErrorCode ErrorCode
)

Parameters

e
The exception to use to initialise a new XdsError
ErrorCode
The XDS specific error code to use.
Remarks
A new XdsError is created, using the provided exception and error code, and is added into the Errors collection. The Status value is set to XdsObjects.Enums.RegistryResponseStatus.Failure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryResponse Class
XdsQueryResponse Members
Overload List


XdsQueryResponse Constructor(XdsErrorCode,String,String)

XdsQueryResponse Constructor(XdsErrorCode,String,String)

XdsObjects Namespace > XdsQueryResponse Class > XdsQueryResponse Constructor : XdsQueryResponse Constructor(XdsErrorCode,String,String)
The XDS specific error code to use.
The Location for the new error
The CodeContext for the new error
Create a query response given an IHE XDS XdsObjects.Enums.XdsErrorCode, plus Location and CodeContext
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal ErrorCode As XdsErrorCode, _
   ByVal Location As String, _
   ByVal CodeContext As String _
)
Dim ErrorCode As XdsErrorCode
Dim Location As String
Dim CodeContext As String

Dim instance As New XdsQueryResponse(ErrorCode, Location, CodeContext)
public XdsQueryResponse(
   XdsErrorCode ErrorCode,
   string Location,
   string CodeContext
)
public:
XdsQueryResponse(
   XdsErrorCode ErrorCode,
   String^ Location,
   String^ CodeContext
)

Parameters

ErrorCode
The XDS specific error code to use.
Location
The Location for the new error
CodeContext
The CodeContext for the new error
Remarks
A new XdsError is created, using the provided values, and is added into the Errors collection. The Status value is set to XdsObjects.Enums.RegistryResponseStatus.Failure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryResponse Class
XdsQueryResponse Members
Overload List


XdsQueryResponse Constructor(XdsErrorCode,String)

XdsQueryResponse Constructor(XdsErrorCode,String)

XdsObjects Namespace > XdsQueryResponse Class > XdsQueryResponse Constructor : XdsQueryResponse Constructor(XdsErrorCode,String)
The XDS specific error code to use.
The CodeContext for the new error
Create a query response given an IHE XDS XdsObjects.Enums.XdsErrorCode, plus Location and CodeContext
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal ErrorCode As XdsErrorCode, _
   ByVal CodeContext As String _
)
Dim ErrorCode As XdsErrorCode
Dim CodeContext As String

Dim instance As New XdsQueryResponse(ErrorCode, CodeContext)
public XdsQueryResponse(
   XdsErrorCode ErrorCode,
   string CodeContext
)
public:
XdsQueryResponse(
   XdsErrorCode ErrorCode,
   String^ CodeContext
)

Parameters

ErrorCode
The XDS specific error code to use.
CodeContext
The CodeContext for the new error
Remarks
A new XdsError is created, using the provided values, and is added into the Errors collection. The Status value is set to XdsObjects.Enums.RegistryResponseStatus.Failure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryResponse Class
XdsQueryResponse Members
Overload List


XdsQueryResponse Class Methods

XdsQueryResponse Class Methods

XdsObjects Namespace : XdsQueryResponse Class

For a list of all members of this type, see XdsQueryResponse members.

Public Methods
 | Name | Description
Public Method | AddError | Overloaded. Add a new XdsError to the XdsRegistryResponse.Errors collection, given the XdsObjects.Enums.XdsErrorCode, plus Location and CodeContext (Inherited from XdsObjects.XdsRegistryResponse)
Public Method | Combine | Combine query responses
Public Method | ContainsErrors | Indicates whether the response contains any error codes (Inherited from XdsObjects.XdsRegistryResponse)
Public Method | SetHomeCommunityID | Set the HomeCommunity for all items ready for sending out as part of XCA gateway use.
Top
See Also

Reference

XdsQueryResponse Class
XdsObjects Namespace


Combine Method (XdsQueryResponse)

Combine Method (XdsQueryResponse)

XdsObjects Namespace > XdsQueryResponse Class : Combine Method
A second XdsQueryResponse object from which the results are copied into the primary calling object's collections
Combine query responses
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub Combine( _
   ByVal RemoteResponse As XdsQueryResponse _
)
Dim instance As XdsQueryResponse
Dim RemoteResponse As XdsQueryResponse

instance.Combine(RemoteResponse)
public void Combine(
   XdsQueryResponse RemoteResponse
)
public:
void Combine(
   XdsQueryResponse^ RemoteResponse
)

Parameters

RemoteResponse
A second XdsQueryResponse object from which the results are copied into the primary calling object's collections
Remarks
This method is used by an initiating gateway to combine the responses from multiple responding dateways, including combining the Status, which will be set to PartialSuccess if one of the results is a Success and the other a failure, or if either is PartialSuccess.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryResponse Class
XdsQueryResponse Members


SetHomeCommunityID Method

SetHomeCommunityID Method

XdsObjects Namespace > XdsQueryResponse Class : SetHomeCommunityID Method
The HomeCommunityID (an OID) to set
Set the HomeCommunity for all items ready for sending out as part of XCA gateway use.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub SetHomeCommunityID( _
   ByVal HomeCommunityID As String _
)
Dim instance As XdsQueryResponse
Dim HomeCommunityID As String

instance.SetHomeCommunityID(HomeCommunityID)
public void SetHomeCommunityID(
   string HomeCommunityID
)
public:
void SetHomeCommunityID(
   String^ HomeCommunityID
)

Parameters

HomeCommunityID
The HomeCommunityID (an OID) to set
Remarks
Responding gateways use this for all data. Initiating gateways only use it for responses from the initiating gateway
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryResponse Class
XdsQueryResponse Members


XdsQueryResponse Class Properties

XdsQueryResponse Class Properties

XdsObjects Namespace : XdsQueryResponse Class

For a list of all members of this type, see XdsQueryResponse members.

Public Properties
 | Name | Description
Public Property | Errors | The errors in this response (Inherited from XdsObjects.XdsRegistryResponse)
Public Property | ReturnedAssociations | List of Associations returned by the query
Public Property | ReturnedDocuments | List of documents returned by the query
Public Property | ReturnedFolders | List of Folders returned by the query
Public Property | ReturnedObjectRefs | List of Object References returned by the query
Public Property | ReturnedSubmissionSets | List of Submission Sets returned by the query
Public Property | Status | The status send or received in this response. (Inherited from XdsObjects.XdsRegistryResponse)
Top
See Also

Reference

XdsQueryResponse Class
XdsObjects Namespace


ReturnedAssociations Property

ReturnedAssociations Property

XdsObjects Namespace > XdsQueryResponse Class : ReturnedAssociations Property
List of Associations returned by the query
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property ReturnedAssociations As List(Of XdsAssociation)
Dim instance As XdsQueryResponse
Dim value As List(Of XdsAssociation)

value = instance.ReturnedAssociations
public List<XdsAssociation> ReturnedAssociations {get;}
public:
property List<XdsAssociation^>^ ReturnedAssociations {
   List<XdsAssociation^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryResponse Class
XdsQueryResponse Members


ReturnedDocuments Property

ReturnedDocuments Property

XdsObjects Namespace > XdsQueryResponse Class : ReturnedDocuments Property
List of documents returned by the query
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property ReturnedDocuments As List(Of XdsDocument)
Dim instance As XdsQueryResponse
Dim value As List(Of XdsDocument)

value = instance.ReturnedDocuments
public List<XdsDocument> ReturnedDocuments {get;}
public:
property List<XdsDocument^>^ ReturnedDocuments {
   List<XdsDocument^>^ get();
}
Remarks

Being the results of a query, this list only contains metadata about the documents, not their actual contents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryResponse Class
XdsQueryResponse Members


ReturnedFolders Property

ReturnedFolders Property

XdsObjects Namespace > XdsQueryResponse Class : ReturnedFolders Property
List of Folders returned by the query
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property ReturnedFolders As List(Of XdsFolder)
Dim instance As XdsQueryResponse
Dim value As List(Of XdsFolder)

value = instance.ReturnedFolders
public List<XdsFolder> ReturnedFolders {get;}
public:
property List<XdsFolder^>^ ReturnedFolders {
   List<XdsFolder^>^ get();
}
Remarks

Being the results of a query, this list only contains metadata about the folders, not their actual contents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryResponse Class
XdsQueryResponse Members


ReturnedObjectRefs Property

ReturnedObjectRefs Property

XdsObjects Namespace > XdsQueryResponse Class : ReturnedObjectRefs Property
List of Object References returned by the query
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ReturnedObjectRefs As List(Of XdsObjectRef)
Dim instance As XdsQueryResponse
Dim value As List(Of XdsObjectRef)

instance.ReturnedObjectRefs = value

value = instance.ReturnedObjectRefs
public List<XdsObjectRef> ReturnedObjectRefs {get; set;}
public:
property List<XdsObjectRef^>^ ReturnedObjectRefs {
   List<XdsObjectRef^>^ get();
   void set (    List<XdsObjectRef^>^ value);
}
Remarks

The contents of this list is justa list of GUIDs, and cannt be interpretted without fetching the full associated data

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryResponse Class
XdsQueryResponse Members


ReturnedSubmissionSets Property

ReturnedSubmissionSets Property

XdsObjects Namespace > XdsQueryResponse Class : ReturnedSubmissionSets Property
List of Submission Sets returned by the query
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property ReturnedSubmissionSets As List(Of XdsSubmissionSet)
Dim instance As XdsQueryResponse
Dim value As List(Of XdsSubmissionSet)

value = instance.ReturnedSubmissionSets
public List<XdsSubmissionSet> ReturnedSubmissionSets {get;}
public:
property List<XdsSubmissionSet^>^ ReturnedSubmissionSets {
   List<XdsSubmissionSet^>^ get();
}
Remarks

Being the results of a query, this list only contains metadata about the Submission Sets, not their actual contents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsQueryResponse Class
XdsQueryResponse Members


XdsRegistryResponse Class

XdsRegistryResponse Class
Members

XdsObjects Namespace : XdsRegistryResponse Class
Base class for all registry responses, whether generated or received by XdsObjects
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsRegistryResponse
Dim instance As XdsRegistryResponse
public class XdsRegistryResponse
public ref class XdsRegistryResponse
Inheritance Hierarchy

System.Object
XdsObjects.XdsRegistryResponse
XdsObjects.Dsub.XdsCreatePullPointResponse
XdsObjects.Dsub.XdsSubscriptionResponse
XdsObjects.Dsub.XdsUnsubscriptionResponse
XdsObjects.XdsQueryResponse
XdsObjects.XdsRetrieveResponse

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRegistryResponse Members
XdsObjects Namespace


XdsRegistryResponse Class Members

XdsRegistryResponse Class Members
Properties Methods

XdsObjects Namespace : XdsRegistryResponse Class

The following tables list the members exposed by XdsRegistryResponse.

Public Constructors
 | Name | Description
Public Constructor | XdsRegistryResponse Constructor | Overloaded. Create a new, registry response
Top
Public Properties
 | Name | Description
Public Property | Errors | The errors in this response
Public Property | Status | The status send or received in this response.
Top
Public Methods
 | Name | Description
Public Method | AddError | Overloaded. Methods to add a new XdsError to the Errors collection
Public Method | ContainsErrors | Indicates whether the response contains any error codes
Top
See Also

Reference

XdsRegistryResponse Class
XdsObjects Namespace


XdsRegistryResponse Constructor

XdsRegistryResponse Constructor

XdsObjects Namespace > XdsRegistryResponse Class : XdsRegistryResponse Constructor
Create a new, registry response
Overload List
Overload | Description
XdsRegistryResponse Constructor() | Create a new, blank, registry response
XdsRegistryResponse Constructor(Exception,XdsErrorCode) | Create a registry response given a System.Exception and an IHE XDS XdsObjects.Enums.XdsErrorCode
XdsRegistryResponse Constructor(XdsErrorCode,String,String) | Create a registry response given an IHE XDS XdsObjects.Enums.XdsErrorCode, and CodeContext
XdsRegistryResponse Constructor(XdsErrorCode,String) | Create a registry response given an IHE XDS XdsObjects.Enums.XdsErrorCode, plus Location and CodeContext
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRegistryResponse Class
XdsRegistryResponse Members


XdsRegistryResponse Constructor()

XdsRegistryResponse Constructor()

XdsObjects Namespace > XdsRegistryResponse Class > XdsRegistryResponse Constructor : XdsRegistryResponse Constructor()
Create a new, blank, registry response
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsRegistryResponse()
public XdsRegistryResponse()
public:
XdsRegistryResponse();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRegistryResponse Class
XdsRegistryResponse Members
Overload List


XdsRegistryResponse Constructor(Exception,XdsErrorCode)

XdsRegistryResponse Constructor(Exception,XdsErrorCode)

XdsObjects Namespace > XdsRegistryResponse Class > XdsRegistryResponse Constructor : XdsRegistryResponse Constructor(Exception,XdsErrorCode)
The exception to use to initialise a new XdsError
The XDS specific error code to use.
Create a registry response given a System.Exception and an IHE XDS XdsObjects.Enums.XdsErrorCode
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal e As Exception, _
   ByVal ErrorCode As XdsErrorCode _
)
Dim e As Exception
Dim ErrorCode As XdsErrorCode

Dim instance As New XdsRegistryResponse(e, ErrorCode)
public XdsRegistryResponse(
   Exception e,
   XdsErrorCode ErrorCode
)
public:
XdsRegistryResponse(
   Exception^ e,
   XdsErrorCode ErrorCode
)

Parameters

e
The exception to use to initialise a new XdsError
ErrorCode
The XDS specific error code to use.
Remarks
A new XdsError is created, using the provided exception and error code, and is added into the Errors collection. The Status value is set to XdsObjects.Enums.RegistryResponseStatus.Failure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRegistryResponse Class
XdsRegistryResponse Members
Overload List


XdsRegistryResponse Constructor(XdsErrorCode,String,String)

XdsRegistryResponse Constructor(XdsErrorCode,String,String)

XdsObjects Namespace > XdsRegistryResponse Class > XdsRegistryResponse Constructor : XdsRegistryResponse Constructor(XdsErrorCode,String,String)
The XDS specific error code to use.
The Location for the new error
The CodeContext for the new error
Create a registry response given an IHE XDS XdsObjects.Enums.XdsErrorCode, and CodeContext
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal ErrorCode As XdsErrorCode, _
   ByVal Location As String, _
   ByVal CodeContext As String _
)
Dim ErrorCode As XdsErrorCode
Dim Location As String
Dim CodeContext As String

Dim instance As New XdsRegistryResponse(ErrorCode, Location, CodeContext)
public XdsRegistryResponse(
   XdsErrorCode ErrorCode,
   string Location,
   string CodeContext
)
public:
XdsRegistryResponse(
   XdsErrorCode ErrorCode,
   String^ Location,
   String^ CodeContext
)

Parameters

ErrorCode
The XDS specific error code to use.
Location
The Location for the new error
CodeContext
The CodeContext for the new error
Remarks
A new XdsError is created, using the provided values, and is added into the Errors collection. The Status value is set to XdsObjects.Enums.RegistryResponseStatus.Failure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRegistryResponse Class
XdsRegistryResponse Members
Overload List


XdsRegistryResponse Constructor(XdsErrorCode,String)

XdsRegistryResponse Constructor(XdsErrorCode,String)

XdsObjects Namespace > XdsRegistryResponse Class > XdsRegistryResponse Constructor : XdsRegistryResponse Constructor(XdsErrorCode,String)
The XDS specific error code to use.
The CodeContext for the new error
Create a registry response given an IHE XDS XdsObjects.Enums.XdsErrorCode, plus Location and CodeContext
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal ErrorCode As XdsErrorCode, _
   ByVal CodeContext As String _
)
Dim ErrorCode As XdsErrorCode
Dim CodeContext As String

Dim instance As New XdsRegistryResponse(ErrorCode, CodeContext)
public XdsRegistryResponse(
   XdsErrorCode ErrorCode,
   string CodeContext
)
public:
XdsRegistryResponse(
   XdsErrorCode ErrorCode,
   String^ CodeContext
)

Parameters

ErrorCode
The XDS specific error code to use.
CodeContext
The CodeContext for the new error
Remarks
A new XdsError is created, using the provided values, and is added into the Errors collection. The Status value is set to XdsObjects.Enums.RegistryResponseStatus.Failure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRegistryResponse Class
XdsRegistryResponse Members
Overload List


XdsRegistryResponse Class Methods

XdsRegistryResponse Class Methods

XdsObjects Namespace : XdsRegistryResponse Class

For a list of all members of this type, see XdsRegistryResponse members.

Public Methods
 | Name | Description
Public Method | AddError | Overloaded. Methods to add a new XdsError to the Errors collection
Public Method | ContainsErrors | Indicates whether the response contains any error codes
Top
See Also

Reference

XdsRegistryResponse Class
XdsObjects Namespace


AddError Method

AddError Method

XdsObjects Namespace > XdsRegistryResponse Class : AddError Method
Methods to add a new XdsError to the Errors collection
Overload List
Overload | Description
AddError(XdsErrorCode,String,String) | Add a new XdsError to the Errors collection, given the XdsObjects.Enums.XdsErrorCode, plus Location and CodeContext
AddError(Exception,XdsErrorCode) | Add a new XdsError to the Errors collection, given a System.Exception and XdsObjects.Enums.XdsErrorCode
AddError(Exception,XdsErrorCode,String) | Add a new XdsError to the Errors collection, given a System.Exception, XdsObjects.Enums.XdsErrorCode and Location
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRegistryResponse Class
XdsRegistryResponse Members


AddError(XdsErrorCode,String,String) Method

AddError(XdsErrorCode,String,String) Method

XdsObjects Namespace > XdsRegistryResponse Class > AddError Method : AddError(XdsErrorCode,String,String) Method
The XDS specific error code to use.
The CodeContext for the new error
The Location for the new error
Add a new XdsError to the Errors collection, given the XdsObjects.Enums.XdsErrorCode, plus Location and CodeContext
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overloads Sub AddError( _
   ByVal ErrorCode As XdsErrorCode, _
   ByVal CodeContext As String, _
   ByVal Location As String _
)
Dim instance As XdsRegistryResponse
Dim ErrorCode As XdsErrorCode
Dim CodeContext As String
Dim Location As String

instance.AddError(ErrorCode, CodeContext, Location)
public void AddError(
   XdsErrorCode ErrorCode,
   string CodeContext,
   string Location
)
public:
void AddError(
   XdsErrorCode ErrorCode,
   String^ CodeContext,
   String^ Location
)

Parameters

ErrorCode
The XDS specific error code to use.
CodeContext
The CodeContext for the new error
Location
The Location for the new error
Remarks
A new XdsError is created, using the provided values, and is added into the Errors collection. The Status value is unchanged.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRegistryResponse Class
XdsRegistryResponse Members
Overload List


AddError(Exception,XdsErrorCode) Method

AddError(Exception,XdsErrorCode) Method

XdsObjects Namespace > XdsRegistryResponse Class > AddError Method : AddError(Exception,XdsErrorCode) Method
The Exception to obtain error information from
The XDS specific error code to use.
Add a new XdsError to the Errors collection, given a System.Exception and XdsObjects.Enums.XdsErrorCode
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overloads Sub AddError( _
   ByVal Exception As Exception, _
   ByVal ErrorCode As XdsErrorCode _
)
Dim instance As XdsRegistryResponse
Dim Exception As Exception
Dim ErrorCode As XdsErrorCode

instance.AddError(Exception, ErrorCode)
public void AddError(
   Exception Exception,
   XdsErrorCode ErrorCode
)
public:
void AddError(
   Exception^ Exception,
   XdsErrorCode ErrorCode
)

Parameters

Exception
The Exception to obtain error information from
ErrorCode
The XDS specific error code to use.
Remarks

A new XdsError is created, using the provided values, and is added into the Errors collection. The Status value is unchanged.

See XdsErrorItem.XdsErrorItem Constructor(Exception,XdsErrorCode) for more details of how the Exception is used to populate the XdsErrorItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRegistryResponse Class
XdsRegistryResponse Members
Overload List


AddError(Exception,XdsErrorCode,String) Method

AddError(Exception,XdsErrorCode,String) Method

XdsObjects Namespace > XdsRegistryResponse Class > AddError Method : AddError(Exception,XdsErrorCode,String) Method
The Exception to obtain error information from
The XDS specific error code to use.
The Location value - in XDS-I use, this should be the instance UID
Add a new XdsError to the Errors collection, given a System.Exception, XdsObjects.Enums.XdsErrorCode and Location
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Overloads Sub AddError( _
   ByVal Exception As Exception, _
   ByVal ErrorCode As XdsErrorCode, _
   ByVal Location As String _
)
Dim instance As XdsRegistryResponse
Dim Exception As Exception
Dim ErrorCode As XdsErrorCode
Dim Location As String

instance.AddError(Exception, ErrorCode, Location)
public void AddError(
   Exception Exception,
   XdsErrorCode ErrorCode,
   string Location
)
public:
void AddError(
   Exception^ Exception,
   XdsErrorCode ErrorCode,
   String^ Location
)

Parameters

Exception
The Exception to obtain error information from
ErrorCode
The XDS specific error code to use.
Location
The Location value - in XDS-I use, this should be the instance UID
Remarks

This override is explicitly intended for use with XDS-I, where the "Location" should be the instance UID of the affected image.

A new XdsError is created, using the provided values, and is added into the Errors collection. The Status value is unchanged.

See XdsErrorItem.XdsErrorItem Constructor(Exception,XdsErrorCode) for more details of how the Exception is used to populate the XdsErrorItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRegistryResponse Class
XdsRegistryResponse Members
Overload List


ContainsErrors Method

ContainsErrors Method

XdsObjects Namespace > XdsRegistryResponse Class : ContainsErrors Method
Indicates whether the response contains any error codes
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function ContainsErrors() As Boolean
Dim instance As XdsRegistryResponse
Dim value As Boolean

value = instance.ContainsErrors()
public bool ContainsErrors()
public:
bool ContainsErrors();
Remarks
Ideally, this should only be true if the Status is PartialSuccess or Failure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRegistryResponse Class
XdsRegistryResponse Members


XdsRegistryResponse Class Properties

XdsRegistryResponse Class Properties

XdsObjects Namespace : XdsRegistryResponse Class

For a list of all members of this type, see XdsRegistryResponse members.

Public Properties
 | Name | Description
Public Property | Errors | The errors in this response
Public Property | Status | The status send or received in this response.
Top
See Also

Reference

XdsRegistryResponse Class
XdsObjects Namespace


Errors Property

Errors Property

XdsObjects Namespace > XdsRegistryResponse Class : Errors Property
The errors in this response
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Errors As XdsError
Dim instance As XdsRegistryResponse
Dim value As XdsError

instance.Errors = value

value = instance.Errors
public XdsError Errors {get; set;}
public:
property XdsError^ Errors {
   XdsError^ get();
   void set (    XdsError^ value);
}
Remarks
For consistency, this object will always exist (it is created in the constructor), but if there are no errors, then the ErrorList will be empty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRegistryResponse Class
XdsRegistryResponse Members


Status Property

Status Property

XdsObjects Namespace > XdsRegistryResponse Class : Status Property
The status send or received in this response.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Status As RegistryResponseStatus
Dim instance As XdsRegistryResponse
Dim value As RegistryResponseStatus

instance.Status = value

value = instance.Status
public RegistryResponseStatus Status {get; set;}
public:
property RegistryResponseStatus Status {
   RegistryResponseStatus get();
   void set (    RegistryResponseStatus value);
}
Remarks
In most cases, this should be XdsObjects.Enums.RegistryResponseStatus.Success or XdsObjects.Enums.RegistryResponseStatus.Failure, but in some circumstances such as when using XCA, XdsObjects.Enums.RegistryResponseStatus.PartialSuccess is also permitted.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRegistryResponse Class
XdsRegistryResponse Members


XdsRelationship Class

XdsRelationship Class
Members

XdsObjects Namespace : XdsRelationship Class
The relationship between one document and another
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsRelationship
Dim instance As XdsRelationship
public class XdsRelationship
public ref class XdsRelationship
Inheritance Hierarchy

System.Object
XdsObjects.XdsRelationship

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRelationship Members
XdsObjects Namespace


XdsRelationship Class Members

XdsRelationship Class Members
Properties

XdsObjects Namespace : XdsRelationship Class

The following tables list the members exposed by XdsRelationship.

Public Constructors
 | Name | Description
Public Constructor | XdsRelationship Constructor | Overloaded. Create a new XdsRelationship object
Top
Public Properties
 | Name | Description
Public Property | Description | Description of the relationship
Public Property | DocumentRelation | The type of relationship
Public Property | ParentUuid | The parent document (the one that another is related to)
Public Property | Reason | The reason for replacement, appending etc.
Public Property | UUID | The UUID of the relationship itself
Top
See Also

Reference

XdsRelationship Class
XdsObjects Namespace


XdsRelationship Constructor

XdsRelationship Constructor

XdsObjects Namespace > XdsRelationship Class : XdsRelationship Constructor
Create a new XdsRelationship object
Overload List
Overload | Description
XdsRelationship Constructor() | Create a new, empty XdsRelationship object
XdsRelationship Constructor(XdsDocument,AssociationType) | Create a new XdsRelationship object, including parent and relationship
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRelationship Class
XdsRelationship Members


XdsRelationship Constructor()

XdsRelationship Constructor()

XdsObjects Namespace > XdsRelationship Class > XdsRelationship Constructor : XdsRelationship Constructor()
Create a new, empty XdsRelationship object
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsRelationship()
public XdsRelationship()
public:
XdsRelationship();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRelationship Class
XdsRelationship Members
Overload List


XdsRelationship Constructor(XdsDocument,AssociationType)

XdsRelationship Constructor(XdsDocument,AssociationType)

XdsObjects Namespace > XdsRelationship Class > XdsRelationship Constructor : XdsRelationship Constructor(XdsDocument,AssociationType)
Create a new XdsRelationship object, including parent and relationship
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal ParentDocument As XdsDocument, _
   ByVal DocumentRelation As AssociationType _
)
Dim ParentDocument As XdsDocument
Dim DocumentRelation As AssociationType

Dim instance As New XdsRelationship(ParentDocument, DocumentRelation)
public XdsRelationship(
   XdsDocument ParentDocument,
   AssociationType DocumentRelation
)
public:
XdsRelationship(
   XdsDocument^ ParentDocument,
   AssociationType DocumentRelation
)

Parameters

ParentDocument
DocumentRelation
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRelationship Class
XdsRelationship Members
Overload List


XdsRelationship Class Properties

XdsRelationship Class Properties

XdsObjects Namespace : XdsRelationship Class

For a list of all members of this type, see XdsRelationship members.

Public Properties
 | Name | Description
Public Property | Description | Description of the relationship
Public Property | DocumentRelation | The type of relationship
Public Property | ParentUuid | The parent document (the one that another is related to)
Public Property | Reason | The reason for replacement, appending etc.
Public Property | UUID | The UUID of the relationship itself
Top
See Also

Reference

XdsRelationship Class
XdsObjects Namespace


Description Property

Description Property

XdsObjects Namespace > XdsRelationship Class : Description Property
Description of the relationship
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Description As String
Dim instance As XdsRelationship
Dim value As String

instance.Description = value

value = instance.Description
public string Description {get; set;}
public:
property String^ Description {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRelationship Class
XdsRelationship Members


DocumentRelation Property

DocumentRelation Property

XdsObjects Namespace > XdsRelationship Class : DocumentRelation Property
The type of relationship
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DocumentRelation As AssociationType
Dim instance As XdsRelationship
Dim value As AssociationType

instance.DocumentRelation = value

value = instance.DocumentRelation
public AssociationType DocumentRelation {get; set;}
public:
property AssociationType DocumentRelation {
   AssociationType get();
   void set (    AssociationType value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRelationship Class
XdsRelationship Members


ParentUuid Property

ParentUuid Property

XdsObjects Namespace > XdsRelationship Class : ParentUuid Property
The parent document (the one that another is related to)
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ParentUuid As String
Dim instance As XdsRelationship
Dim value As String

instance.ParentUuid = value

value = instance.ParentUuid
public string ParentUuid {get; set;}
public:
property String^ ParentUuid {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRelationship Class
XdsRelationship Members


Reason Property

Reason Property

XdsObjects Namespace > XdsRelationship Class : Reason Property
The reason for replacement, appending etc.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Reason As XdsCode
Dim instance As XdsRelationship
Dim value As XdsCode

instance.Reason = value

value = instance.Reason
public XdsCode Reason {get; set;}
public:
property XdsCode^ Reason {
   XdsCode^ get();
   void set (    XdsCode^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRelationship Class
XdsRelationship Members


UUID Property (XdsRelationship)

UUID Property (XdsRelationship)

XdsObjects Namespace > XdsRelationship Class : UUID Property
The UUID of the relationship itself
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property UUID As String
Dim instance As XdsRelationship
Dim value As String

instance.UUID = value

value = instance.UUID
public string UUID {get; set;}
public:
property String^ UUID {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRelationship Class
XdsRelationship Members


XdsRequestInfo Class

XdsRequestInfo Class
Members

XdsObjects Namespace : XdsRequestInfo Class
Object representing requested information
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsRequestInfo
Dim instance As XdsRequestInfo
public class XdsRequestInfo
public ref class XdsRequestInfo
Inheritance Hierarchy

System.Object
XdsObjects.XdsRequestInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRequestInfo Members
XdsObjects Namespace


XdsRequestInfo Class Members

XdsRequestInfo Class Members
Properties Methods

XdsObjects Namespace : XdsRequestInfo Class

The following tables list the members exposed by XdsRequestInfo.

Public Constructors
 | Name | Description
Public Constructor | XdsRequestInfo Constructor | Initialising object with an explicitly defined message parameter
Top
Public Properties
 | Name | Description
Public Property | Context | The OperationContext which provides access to the execution context
Public Property | Message | Message content
Public Property | RemoteEndpoint | Makes available the client IP address and port number associated with the remote endpoint from which a message was sent
Top
Public Methods
 | Name | Description
Public Method | Header | Get a particular Message Header
Public Method | SecurityHeader | Returns the XUA Security Header
Top
See Also

Reference

XdsRequestInfo Class
XdsObjects Namespace


XdsRequestInfo Constructor

XdsRequestInfo Constructor

XdsObjects Namespace > XdsRequestInfo Class : XdsRequestInfo Constructor
Initialising object with an explicitly defined message parameter
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal message As Message _
)
Dim message As Message

Dim instance As New XdsRequestInfo(message)
public XdsRequestInfo(
   Message message
)
public:
XdsRequestInfo(
   Message^ message
)

Parameters

message
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRequestInfo Class
XdsRequestInfo Members


XdsRequestInfo Class Methods

XdsRequestInfo Class Methods

XdsObjects Namespace : XdsRequestInfo Class

For a list of all members of this type, see XdsRequestInfo members.

Public Methods
 | Name | Description
Public Method | Header | Get a particular Message Header
Public Method | SecurityHeader | Returns the XUA Security Header
Top
See Also

Reference

XdsRequestInfo Class
XdsObjects Namespace


Header Method

Header Method

XdsObjects Namespace > XdsRequestInfo Class : Header Method
Name of the Header
The XML namespace of the header
Get a particular Message Header
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function Header( _
   ByVal Name As String, _
   ByVal Namespace As String _
) As XmlDictionaryReader
Dim instance As XdsRequestInfo
Dim Name As String
Dim Namespace As String
Dim value As XmlDictionaryReader

value = instance.Header(Name, Namespace)
public XmlDictionaryReader Header(
   string Name,
   string Namespace
)
public:
XmlDictionaryReader^ Header(
   String^ Name,
   String^ Namespace
)

Parameters

Name
Name of the Header
Namespace
The XML namespace of the header
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRequestInfo Class
XdsRequestInfo Members


SecurityHeader Method

SecurityHeader Method

XdsObjects Namespace > XdsRequestInfo Class : SecurityHeader Method
Returns the XUA Security Header
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function SecurityHeader() As XmlDictionaryReader
Dim instance As XdsRequestInfo
Dim value As XmlDictionaryReader

value = instance.SecurityHeader()
public XmlDictionaryReader SecurityHeader()
public:
XmlDictionaryReader^ SecurityHeader();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRequestInfo Class
XdsRequestInfo Members


XdsRequestInfo Class Properties

XdsRequestInfo Class Properties

XdsObjects Namespace : XdsRequestInfo Class

For a list of all members of this type, see XdsRequestInfo members.

Public Properties
 | Name | Description
Public Property | Context | The OperationContext which provides access to the execution context
Public Property | Message | Message content
Public Property | RemoteEndpoint | Makes available the client IP address and port number associated with the remote endpoint from which a message was sent
Top
See Also

Reference

XdsRequestInfo Class
XdsObjects Namespace


Context Property

Context Property

XdsObjects Namespace > XdsRequestInfo Class : Context Property
The OperationContext which provides access to the execution context
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Context As OperationContext
Dim instance As XdsRequestInfo
Dim value As OperationContext

instance.Context = value

value = instance.Context
public OperationContext Context {get; set;}
public:
property OperationContext^ Context {
   OperationContext^ get();
   void set (    OperationContext^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRequestInfo Class
XdsRequestInfo Members


Message Property (XdsRequestInfo)

Message Property (XdsRequestInfo)

XdsObjects Namespace > XdsRequestInfo Class : Message Property
Message content
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Message As Message
Dim instance As XdsRequestInfo
Dim value As Message

instance.Message = value

value = instance.Message
public Message Message {get; set;}
public:
property Message^ Message {
   Message^ get();
   void set (    Message^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRequestInfo Class
XdsRequestInfo Members


RemoteEndpoint Property

RemoteEndpoint Property

XdsObjects Namespace > XdsRequestInfo Class : RemoteEndpoint Property
Makes available the client IP address and port number associated with the remote endpoint from which a message was sent
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property RemoteEndpoint As RemoteEndpointMessageProperty
Dim instance As XdsRequestInfo
Dim value As RemoteEndpointMessageProperty

instance.RemoteEndpoint = value

value = instance.RemoteEndpoint
public RemoteEndpointMessageProperty RemoteEndpoint {get; set;}
public:
property RemoteEndpointMessageProperty^ RemoteEndpoint {
   RemoteEndpointMessageProperty^ get();
   void set (    RemoteEndpointMessageProperty^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRequestInfo Class
XdsRequestInfo Members


XdsRetrieveItem Class

XdsRetrieveItem Class
Members

XdsObjects Namespace : XdsRetrieveItem Class
Represents request for a single item within an XdsRetrieveRequest
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsRetrieveItem
Dim instance As XdsRetrieveItem
public class XdsRetrieveItem
public ref class XdsRetrieveItem
Inheritance Hierarchy

System.Object
XdsObjects.XdsRetrieveItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRetrieveItem Members
XdsObjects Namespace


XdsRetrieveItem Class Members

XdsRetrieveItem Class Members
Properties

XdsObjects Namespace : XdsRetrieveItem Class

The following tables list the members exposed by XdsRetrieveItem.

Public Constructors
 | Name | Description
Public Constructor | XdsRetrieveItem Constructor | Overloaded. Construct a new XdsRetrieveItem
Top
Public Properties
 | Name | Description
Public Property | DocumentUniqueID | The Unique ID (see XdsDocument.UniqueID - not the UUID of the document being requested.
Public Property | HomeCommunityID | The HomeCommunityID of the item being requested.
Public Property | RepositoryUniqueID | The UniqueID of the repository holding the document. In XDS use, this must be the same for all XdsRerieveItems in the XdsRetrieveRequest, but in XCA use, it may vary, provided that that the HomeCommunityID value is the same.
Top
See Also

Reference

XdsRetrieveItem Class
XdsObjects Namespace


XdsRetrieveItem Constructor

XdsRetrieveItem Constructor

XdsObjects Namespace > XdsRetrieveItem Class : XdsRetrieveItem Constructor
Construct a new XdsRetrieveItem
Overload List
Overload | Description
XdsRetrieveItem Constructor() | Construct a new empty XdsRetrieveItem
XdsRetrieveItem Constructor(XdsDocument) | Construct a new empty XdsRetrieveItem, popuoating it from data in an XdsDocument
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRetrieveItem Class
XdsRetrieveItem Members


XdsRetrieveItem Constructor()

XdsRetrieveItem Constructor()

XdsObjects Namespace > XdsRetrieveItem Class > XdsRetrieveItem Constructor : XdsRetrieveItem Constructor()
Construct a new empty XdsRetrieveItem
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsRetrieveItem()
public XdsRetrieveItem()
public:
XdsRetrieveItem();
Remarks
When specifying objects to be retrieved following a query, it is normally easier to use the XdsRetrieveItem Constructor(XdsDocument) constructor which directly sets the required values, including the HomeCommunityID where appropriate
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRetrieveItem Class
XdsRetrieveItem Members
Overload List


XdsRetrieveItem Constructor(XdsDocument)

XdsRetrieveItem Constructor(XdsDocument)

XdsObjects Namespace > XdsRetrieveItem Class > XdsRetrieveItem Constructor : XdsRetrieveItem Constructor(XdsDocument)
A document (normally from a query) specifying what to retrieve
Construct a new empty XdsRetrieveItem, popuoating it from data in an XdsDocument
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal Document As XdsDocument _
)
Dim Document As XdsDocument

Dim instance As New XdsRetrieveItem(Document)
public XdsRetrieveItem(
   XdsDocument Document
)
public:
XdsRetrieveItem(
   XdsDocument^ Document
)

Parameters

Document
A document (normally from a query) specifying what to retrieve
Remarks
This overload sets the required DocumentUniqueID and RepositoryUniqueID, including the HomeCommunityID where appropriate
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRetrieveItem Class
XdsRetrieveItem Members
Overload List


XdsRetrieveItem Class Properties

XdsRetrieveItem Class Properties

XdsObjects Namespace : XdsRetrieveItem Class

For a list of all members of this type, see XdsRetrieveItem members.

Public Properties
 | Name | Description
Public Property | DocumentUniqueID | The Unique ID (see XdsDocument.UniqueID - not the UUID of the document being requested.
Public Property | HomeCommunityID | The HomeCommunityID of the item being requested.
Public Property | RepositoryUniqueID | The UniqueID of the repository holding the document. In XDS use, this must be the same for all XdsRerieveItems in the XdsRetrieveRequest, but in XCA use, it may vary, provided that that the HomeCommunityID value is the same.
Top
See Also

Reference

XdsRetrieveItem Class
XdsObjects Namespace


DocumentUniqueID Property

DocumentUniqueID Property

XdsObjects Namespace > XdsRetrieveItem Class : DocumentUniqueID Property
The Unique ID (see UniqueID - not the UUID of the document being requested.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DocumentUniqueID As String
Dim instance As XdsRetrieveItem
Dim value As String

instance.DocumentUniqueID = value

value = instance.DocumentUniqueID
public string DocumentUniqueID {get; set;}
public:
property String^ DocumentUniqueID {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRetrieveItem Class
XdsRetrieveItem Members


HomeCommunityID Property (XdsRetrieveItem)

HomeCommunityID Property (XdsRetrieveItem)

XdsObjects Namespace > XdsRetrieveItem Class : HomeCommunityID Property
The HomeCommunityID of the item being requested.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property HomeCommunityID As String
Dim instance As XdsRetrieveItem
Dim value As String

instance.HomeCommunityID = value

value = instance.HomeCommunityID
public string HomeCommunityID {get; set;}
public:
property String^ HomeCommunityID {
   String^ get();
   void set (    String^ value);
}
Remarks
In normal XDS use, this field is empty, but it is required to be populated in an XCA environment.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRetrieveItem Class
XdsRetrieveItem Members


RepositoryUniqueID Property (XdsRetrieveItem)

RepositoryUniqueID Property (XdsRetrieveItem)

XdsObjects Namespace > XdsRetrieveItem Class : RepositoryUniqueID Property
The UniqueID of the repository holding the document. In XDS use, this must be the same for all XdsRerieveItems in the XdsRetrieveRequest, but in XCA use, it may vary, provided that that the HomeCommunityID value is the same.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property RepositoryUniqueID As String
Dim instance As XdsRetrieveItem
Dim value As String

instance.RepositoryUniqueID = value

value = instance.RepositoryUniqueID
public string RepositoryUniqueID {get; set;}
public:
property String^ RepositoryUniqueID {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRetrieveItem Class
XdsRetrieveItem Members


XdsRetrieveRequest Class

XdsRetrieveRequest Class
Members

XdsObjects Namespace : XdsRetrieveRequest Class
Class which holds a complete request as used in the XDS RetrieveDocumentSet transaction
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsRetrieveRequest
Dim instance As XdsRetrieveRequest
public class XdsRetrieveRequest
public ref class XdsRetrieveRequest
Remarks

The individual items requested are defined by XdsRetrieveItem items in the Requests collection

The RetrieveImagingDocumentSet transaction uses a different request object which is the XdsImagingRetrieveRequest (although it shares the same XdsRetrieveResponse to hold the results)

Inheritance Hierarchy

System.Object
XdsObjects.XdsRetrieveRequest

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRetrieveRequest Members
XdsObjects Namespace


XdsRetrieveRequest Class Members

XdsRetrieveRequest Class Members
Properties Methods

XdsObjects Namespace : XdsRetrieveRequest Class

The following tables list the members exposed by XdsRetrieveRequest.

Public Constructors
 | Name | Description
Public Constructor | XdsRetrieveRequest Constructor | Create a new, blank XdsRetrieveRequest
Top
Public Properties
 | Name | Description
Public Property | Requests | The list of Documents requests
Top
Public Methods
 | Name | Description
Public Method | Add | Add one XdsDocument to the request.
Public Method | ClearHomeCommunityID | Remove the HomeCommunityID value from all XdsRequestItems in this request
Public Method | GroupByHomeCommunityID | Split a request into multiple requests, according to their HomeCommunityID value.
Top
See Also

Reference

XdsRetrieveRequest Class
XdsObjects Namespace


XdsRetrieveRequest Constructor

XdsRetrieveRequest Constructor

XdsObjects Namespace > XdsRetrieveRequest Class : XdsRetrieveRequest Constructor
Create a new, blank XdsRetrieveRequest
Create a new XdsRetrieveRequest
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsRetrieveRequest()
public XdsRetrieveRequest()
public:
XdsRetrieveRequest();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRetrieveRequest Class
XdsRetrieveRequest Members


XdsRetrieveRequest Class Methods

XdsRetrieveRequest Class Methods

XdsObjects Namespace : XdsRetrieveRequest Class

For a list of all members of this type, see XdsRetrieveRequest members.

Public Methods
 | Name | Description
Public Method | Add | Add one XdsDocument to the request.
Public Method | ClearHomeCommunityID | Remove the HomeCommunityID value from all XdsRequestItems in this request
Public Method | GroupByHomeCommunityID | Split a request into multiple requests, according to their HomeCommunityID value.
Top
See Also

Reference

XdsRetrieveRequest Class
XdsObjects Namespace


Add Method (XdsRetrieveRequest)

Add Method (XdsRetrieveRequest)

XdsObjects Namespace > XdsRetrieveRequest Class : Add Method
The document to add
Add one XdsDocument to the request.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub Add( _
   ByVal Document As XdsDocument _
)
Dim instance As XdsRetrieveRequest
Dim Document As XdsDocument

instance.Add(Document)
public void Add(
   XdsDocument Document
)
public:
void Add(
   XdsDocument^ Document
)

Parameters

Document
The document to add
Remarks
Obly the UniqueID and RepositoryUniqueId (and for XCA use, the HomeCommunityID are actually used to make the request.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRetrieveRequest Class
XdsRetrieveRequest Members


ClearHomeCommunityID Method

ClearHomeCommunityID Method

XdsObjects Namespace > XdsRetrieveRequest Class : ClearHomeCommunityID Method
Remove the HomeCommunityID value from all XdsRequestItems in this request
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub ClearHomeCommunityID()
Dim instance As XdsRetrieveRequest

instance.ClearHomeCommunityID()
public void ClearHomeCommunityID()
public:
void ClearHomeCommunityID();
Remarks
This facility is useful for an XCA Responding Gateway, which has received a retrieval request, and need to pass it on its local repositories, which do not expect th requests to contain the HomeCommunityID (home) attribute.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRetrieveRequest Class
XdsRetrieveRequest Members


GroupByHomeCommunityID Method

GroupByHomeCommunityID Method

XdsObjects Namespace > XdsRetrieveRequest Class : GroupByHomeCommunityID Method
Split a request into multiple requests, according to their HomeCommunityID value.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function GroupByHomeCommunityID() As List(Of XdsRetrieveRequest)
Dim instance As XdsRetrieveRequest
Dim value As List(Of XdsRetrieveRequest)

value = instance.GroupByHomeCommunityID()
public List<XdsRetrieveRequest> GroupByHomeCommunityID()
public:
List<XdsRetrieveRequest^>^ GroupByHomeCommunityID();

Return Value

List of XdsRetrieveRequest items, each of which only contains request items referencing the same HomeCommunityID
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRetrieveRequest Class
XdsRetrieveRequest Members


XdsRetrieveRequest Class Properties

XdsRetrieveRequest Class Properties

XdsObjects Namespace : XdsRetrieveRequest Class

For a list of all members of this type, see XdsRetrieveRequest members.

Public Properties
 | Name | Description
Public Property | Requests | The list of Documents requests
Top
See Also

Reference

XdsRetrieveRequest Class
XdsObjects Namespace


Requests Property

Requests Property

XdsObjects Namespace > XdsRetrieveRequest Class : Requests Property
The list of Documents requests
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Requests As List(Of XdsRetrieveItem)
Dim instance As XdsRetrieveRequest
Dim value As List(Of XdsRetrieveItem)

instance.Requests = value

value = instance.Requests
public List<XdsRetrieveItem> Requests {get; set;}
public:
property List<XdsRetrieveItem^>^ Requests {
   List<XdsRetrieveItem^>^ get();
   void set (    List<XdsRetrieveItem^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRetrieveRequest Class
XdsRetrieveRequest Members


XdsRetrieveResponse Class

XdsRetrieveResponse Class
Members

XdsObjects Namespace : XdsRetrieveResponse Class
Class which holds the information passed from a repository to a consumer or other equivalent transactions such as CrossGatewayRetrieve. It is also used in XDS-I for holding the results of an TetrieveImagingDocumentSet transaction.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsRetrieveResponse
   Inherits XdsRegistryResponse
Dim instance As XdsRetrieveResponse
public class XdsRetrieveResponse : XdsRegistryResponse
public ref class XdsRetrieveResponse : public XdsRegistryResponse
Remarks
This class can be used by both consumers, to which it is returned from the XdsDomain.RetrieveDocumentSet method, or respositories and gateways, who themselves return an object of this type from their document request events.
Inheritance Hierarchy

System.Object
XdsObjects.XdsRegistryResponse
XdsObjects.XdsRetrieveResponse

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRetrieveResponse Members
XdsObjects Namespace


XdsRetrieveResponse Class Members

XdsRetrieveResponse Class Members
Properties Methods

XdsObjects Namespace : XdsRetrieveResponse Class

The following tables list the members exposed by XdsRetrieveResponse.

Public Constructors
 | Name | Description
Public Constructor | XdsRetrieveResponse Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Documents | The list of documents returned.
Public Property | Errors | The errors in this response (Inherited from XdsObjects.XdsRegistryResponse)
Public Property | Status | The status send or received in this response. (Inherited from XdsObjects.XdsRegistryResponse)
Top
Public Methods
 | Name | Description
Public Method | AddError | Overloaded. Add a new XdsError to the Errors collection, given the XdsObjects.Enums.XdsErrorCode, plus Location and CodeContext (Inherited from XdsObjects.XdsRegistryResponse)
Public Method | Combine | Combine the documents and errors or two responses. This is intended for use by XCA initiating gateways, which may need to combine responses from more than one responding gateway. The values from the RemoteResponse obejct are copied into the calling object.
Public Method | ContainsErrors | Indicates whether the response contains any error codes (Inherited from XdsObjects.XdsRegistryResponse)
Top
See Also

Reference

XdsRetrieveResponse Class
XdsObjects Namespace


XdsRetrieveResponse Constructor

XdsRetrieveResponse Constructor

XdsObjects Namespace > XdsRetrieveResponse Class : XdsRetrieveResponse Constructor
Overload List
Overload | Description
XdsRetrieveResponse Constructor() | Create a new XdsRetrieveResponse object with no documents. This would be used by a repository or gateway.
XdsRetrieveResponse Constructor(Exception,XdsErrorCode) | Create a retrieve response given a System.Exception and an IHE XDS XdsObjects.Enums.XdsErrorCode
XdsRetrieveResponse Constructor(XdsErrorCode,String,String) | Create a retrieve response given an IHE XDS XdsObjects.Enums.XdsErrorCode, plus Location and CodeContext
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRetrieveResponse Class
XdsRetrieveResponse Members


XdsRetrieveResponse Constructor()

XdsRetrieveResponse Constructor()

XdsObjects Namespace > XdsRetrieveResponse Class > XdsRetrieveResponse Constructor : XdsRetrieveResponse Constructor()
Create a new XdsRetrieveResponse object with no documents. This would be used by a repository or gateway.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsRetrieveResponse()
public XdsRetrieveResponse()
public:
XdsRetrieveResponse();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRetrieveResponse Class
XdsRetrieveResponse Members
Overload List


XdsRetrieveResponse Constructor(Exception,XdsErrorCode)

XdsRetrieveResponse Constructor(Exception,XdsErrorCode)

XdsObjects Namespace > XdsRetrieveResponse Class > XdsRetrieveResponse Constructor : XdsRetrieveResponse Constructor(Exception,XdsErrorCode)
The exception to use to initialise a new XdsError
The XDS specific error code to use.
Create a retrieve response given a System.Exception and an IHE XDS XdsObjects.Enums.XdsErrorCode
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal e As Exception, _
   ByVal ErrorCode As XdsErrorCode _
)
Dim e As Exception
Dim ErrorCode As XdsErrorCode

Dim instance As New XdsRetrieveResponse(e, ErrorCode)
public XdsRetrieveResponse(
   Exception e,
   XdsErrorCode ErrorCode
)
public:
XdsRetrieveResponse(
   Exception^ e,
   XdsErrorCode ErrorCode
)

Parameters

e
The exception to use to initialise a new XdsError
ErrorCode
The XDS specific error code to use.
Remarks
A new XdsError is created, using the provided exception and error code, and is added into the Errors collection. The Status value is set to XdsObjects.Enums.RegistryResponseStatus.Failure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRetrieveResponse Class
XdsRetrieveResponse Members
Overload List


XdsRetrieveResponse Constructor(XdsErrorCode,String,String)

XdsRetrieveResponse Constructor(XdsErrorCode,String,String)

XdsObjects Namespace > XdsRetrieveResponse Class > XdsRetrieveResponse Constructor : XdsRetrieveResponse Constructor(XdsErrorCode,String,String)
The XDS specific error code to use.
The Location for the new error
The CodeContext for the new error
Create a retrieve response given an IHE XDS XdsObjects.Enums.XdsErrorCode, plus Location and CodeContext
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal ErrorCode As XdsErrorCode, _
   ByVal Location As String, _
   ByVal CodeContext As String _
)
Dim ErrorCode As XdsErrorCode
Dim Location As String
Dim CodeContext As String

Dim instance As New XdsRetrieveResponse(ErrorCode, Location, CodeContext)
public XdsRetrieveResponse(
   XdsErrorCode ErrorCode,
   string Location,
   string CodeContext
)
public:
XdsRetrieveResponse(
   XdsErrorCode ErrorCode,
   String^ Location,
   String^ CodeContext
)

Parameters

ErrorCode
The XDS specific error code to use.
Location
The Location for the new error
CodeContext
The CodeContext for the new error
Remarks
A new XdsError is created, using the provided values, and is added into the Errors collection. The Status value is set to XdsObjects.Enums.RegistryResponseStatus.Failure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRetrieveResponse Class
XdsRetrieveResponse Members
Overload List


XdsRetrieveResponse Class Methods

XdsRetrieveResponse Class Methods

XdsObjects Namespace : XdsRetrieveResponse Class

For a list of all members of this type, see XdsRetrieveResponse members.

Public Methods
 | Name | Description
Public Method | AddError | Overloaded. Add a new XdsError to the Errors collection, given the XdsObjects.Enums.XdsErrorCode, plus Location and CodeContext (Inherited from XdsObjects.XdsRegistryResponse)
Public Method | Combine | Combine the documents and errors or two responses. This is intended for use by XCA initiating gateways, which may need to combine responses from more than one responding gateway. The values from the RemoteResponse obejct are copied into the calling object.
Public Method | ContainsErrors | Indicates whether the response contains any error codes (Inherited from XdsObjects.XdsRegistryResponse)
Top
See Also

Reference

XdsRetrieveResponse Class
XdsObjects Namespace


Combine Method (XdsRetrieveResponse)

Combine Method (XdsRetrieveResponse)

XdsObjects Namespace > XdsRetrieveResponse Class : Combine Method
The source to copy from
Combine the documents and errors or two responses. This is intended for use by XCA initiating gateways, which may need to combine responses from more than one responding gateway. The values from the RemoteResponse obejct are copied into the calling object.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub Combine( _
   ByVal RemoteResponse As XdsRetrieveResponse _
)
Dim instance As XdsRetrieveResponse
Dim RemoteResponse As XdsRetrieveResponse

instance.Combine(RemoteResponse)
public void Combine(
   XdsRetrieveResponse RemoteResponse
)
public:
void Combine(
   XdsRetrieveResponse^ RemoteResponse
)

Parameters

RemoteResponse
The source to copy from
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRetrieveResponse Class
XdsRetrieveResponse Members


XdsRetrieveResponse Class Properties

XdsRetrieveResponse Class Properties

XdsObjects Namespace : XdsRetrieveResponse Class

For a list of all members of this type, see XdsRetrieveResponse members.

Public Properties
 | Name | Description
Public Property | Documents | The list of documents returned.
Public Property | Errors | The errors in this response (Inherited from XdsObjects.XdsRegistryResponse)
Public Property | Status | The status send or received in this response. (Inherited from XdsObjects.XdsRegistryResponse)
Top
See Also

Reference

XdsRetrieveResponse Class
XdsObjects Namespace


Documents Property (XdsRetrieveResponse)

Documents Property (XdsRetrieveResponse)

XdsObjects Namespace > XdsRetrieveResponse Class : Documents Property
The list of documents returned.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Documents As List(Of XdsDocument)
Dim instance As XdsRetrieveResponse
Dim value As List(Of XdsDocument)

instance.Documents = value

value = instance.Documents
public List<XdsDocument> Documents {get; set;}
public:
property List<XdsDocument^>^ Documents {
   List<XdsDocument^>^ get();
   void set (    List<XdsDocument^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRetrieveResponse Class
XdsRetrieveResponse Members


XdsSlot Class

XdsSlot Class
Members

XdsObjects Namespace : XdsSlot Class
Class to hold Extra Slot information
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsSlot
Dim instance As XdsSlot
public class XdsSlot
public ref class XdsSlot
Remarks
This is used in the ExtraSlots properties on XdsDocuments, XdsSubmissionSets and XdsFolders
Inheritance Hierarchy

System.Object
XdsObjects.XdsSlot

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSlot Members
XdsObjects Namespace


XdsSlot Class Members

XdsSlot Class Members
Properties

XdsObjects Namespace : XdsSlot Class

The following tables list the members exposed by XdsSlot.

Public Constructors
 | Name | Description
Public Constructor | XdsSlot Constructor | Create a new empty Slot
Top
Public Properties
 | Name | Description
Public Property | AllValues | Format all the contents of an XdsSlot for serialization.
Public Property | ID | GUID for database use
Public Property | Name | The Name of the slot
Public Property | Values | The list values contained in the slot
Top
See Also

Reference

XdsSlot Class
XdsObjects Namespace


XdsSlot Constructor

XdsSlot Constructor

XdsObjects Namespace > XdsSlot Class : XdsSlot Constructor
Create a new empty Slot
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsSlot()
public XdsSlot()
public:
XdsSlot();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSlot Class
XdsSlot Members


XdsSlot Class Properties

XdsSlot Class Properties

XdsObjects Namespace : XdsSlot Class

For a list of all members of this type, see XdsSlot members.

Public Properties
 | Name | Description
Public Property | AllValues | Format all the contents of an XdsSlot for serialization.
Public Property | ID | GUID for database use
Public Property | Name | The Name of the slot
Public Property | Values | The list values contained in the slot
Top
See Also

Reference

XdsSlot Class
XdsObjects Namespace


AllValues Property (XdsSlot)

AllValues Property (XdsSlot)

XdsObjects Namespace > XdsSlot Class : AllValues Property
Format all the contents of an XdsSlot for serialization.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property AllValues As String
Dim instance As XdsSlot
Dim value As String

instance.AllValues = value

value = instance.AllValues
public string AllValues {get; set;}
public:
property String^ AllValues {
   String^ get();
   void set (    String^ value);
}
Remarks

This is a specialist property which is intended purely for serialization or with the Code First Entity Framework to allow the contents to be persisted to and restored from a single string.

The format is set of lines, each containing a single entry.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSlot Class
XdsSlot Members


ID Property (XdsSlot)

ID Property (XdsSlot)

XdsObjects Namespace > XdsSlot Class : ID Property
GUID for database use
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ID As Guid
Dim instance As XdsSlot
Dim value As Guid

instance.ID = value

value = instance.ID
public Guid ID {get; set;}
public:
property Guid ID {
   Guid get();
   void set (    Guid value);
}
Remarks
This ID is internally generated, and is not used as part of any XDS transactions. Its only purpose is to act as a unique ID for the Entity Framework, and if not being used for that, may be ignored.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSlot Class
XdsSlot Members


Name Property (XdsSlot)

Name Property (XdsSlot)

XdsObjects Namespace > XdsSlot Class : Name Property
The Name of the slot
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Name As String
Dim instance As XdsSlot
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSlot Class
XdsSlot Members


Values Property

Values Property

XdsObjects Namespace > XdsSlot Class : Values Property
The list values contained in the slot
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property Values As List(Of String)
Dim instance As XdsSlot
Dim value As List(Of String)

value = instance.Values
public List<string> Values {get;}
public:
property List<String^>^ Values {
   List<String^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSlot Class
XdsSlot Members


XdsSoapServer Class

XdsSoapServer Class
Members

XdsObjects Namespace : XdsSoapServer Class

A server which listens for incoming transactions for requests which do not include document data.

Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsSoapServer
   Inherits XdsBaseServer
Dim instance As XdsSoapServer
public class XdsSoapServer : XdsBaseServer
public ref class XdsSoapServer : public XdsBaseServer
Remarks

This object is used for:

  • Stored Registry Queries
  • Cross Gateway Queries
  • Register (not Provide and Register) Transactions

The above all use SOAP encoding. Othe transaction which can include documents themselves use the XdsMtomServer class

Inheritance Hierarchy

System.Object
XdsObjects.XdsBaseServer
XdsObjects.XdsSoapServer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSoapServer Members
XdsObjects Namespace


XdsSoapServer Class Members

XdsSoapServer Class Members
Properties Methods Events

XdsObjects Namespace : XdsSoapServer Class

The following tables list the members exposed by XdsSoapServer.

Public Constructors
 | Name | Description
Public Constructor | XdsSoapServer Constructor | Construct new XdsSoapServer
Top
Public Properties
 | Name | Description
Public Property | StructureIncomingSubmissionSet | Controls the behaviour used when incoming data is received. (Inherited from XdsObjects.XdsBaseServer)
Top
Public Methods
 | Name | Description
Public Method | Listen | Specify an endpoint for listening
Public Method | UnListenAll | Stops listening on all Addresses
Top
Public Events
 | Name | Description
Public Event | CreatePullPointRequestReceived | CreatePullPointRequestReceived event
Public Event | CrossGatewayQueryReceived | Event which is fired when a CrossGatewayQuery transaction is Received
Public Event | DeleteReceived | Event which is fired when a DeleteDocumentSet transaction is Received
Public Event | NotifyRequestReceived | NotifyRequestReceived event
Public Event | RegisterReceived | Event which is fired when a RegisterDocumentSet-b transaction is Received
Public Event | RegistryStoredQueryReceived | Event which is fired when a RegistryStoredQuery transaction is Received
Public Event | SubscriptionRequestReceived | SubscriptionRequestReceived event
Public Event | UnsubscriptionRequestReceived | UnsubscriptionRequestReceived event
Public Event | UpdateReceived | Event which is fired when a UpdateDocumentSet transaction is Received
Top
See Also

Reference

XdsSoapServer Class
XdsObjects Namespace


XdsSoapServer Constructor

XdsSoapServer Constructor

XdsObjects Namespace > XdsSoapServer Class : XdsSoapServer Constructor
Construct new XdsSoapServer
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsSoapServer()
public XdsSoapServer()
public:
XdsSoapServer();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSoapServer Class
XdsSoapServer Members


XdsSoapServer Class Methods

XdsSoapServer Class Methods

XdsObjects Namespace : XdsSoapServer Class

For a list of all members of this type, see XdsSoapServer members.

Public Methods
 | Name | Description
Public Method | Listen | Specify an endpoint for listening
Public Method | UnListenAll | Stops listening on all Addresses
Top
See Also

Reference

XdsSoapServer Class
XdsObjects Namespace


Listen Method (XdsSoapServer)

Listen Method (XdsSoapServer)

XdsObjects Namespace > XdsSoapServer Class : Listen Method
Specify an endpoint for listening
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub Listen( _
   ByVal Address As String _
)
Dim instance As XdsSoapServer
Dim Address As String

instance.Listen(Address)
public void Listen(
   string Address
)
public:
void Listen(
   String^ Address
)

Parameters

Address
Remarks

A server can listen on multiple endpoint addresses

If secure listening is required, the port and certificate must be configured using httpcfg or (for Vista/Windows 7) netsh - see Server Certificates for more details

Example
serverobject.Listen("http://myservername:8080/MyLIsteningEndpoint)serverobject.Listen("https://myservername:8080/MySecureLsteningEndpoint)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSoapServer Class
XdsSoapServer Members


UnListenAll Method (XdsSoapServer)

UnListenAll Method (XdsSoapServer)

XdsObjects Namespace > XdsSoapServer Class : UnListenAll Method
Stops listening on all Addresses
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub UnListenAll()
Dim instance As XdsSoapServer

instance.UnListenAll()
public void UnListenAll()
public:
void UnListenAll();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSoapServer Class
XdsSoapServer Members


XdsSoapServer Class Events

XdsSoapServer Class Events

XdsObjects Namespace : XdsSoapServer Class

For a list of all members of this type, see XdsSoapServer members.

Public Events
 | Name | Description
Public Event | CreatePullPointRequestReceived | CreatePullPointRequestReceived event
Public Event | CrossGatewayQueryReceived | Event which is fired when a CrossGatewayQuery transaction is Received
Public Event | DeleteReceived | Event which is fired when a DeleteDocumentSet transaction is Received
Public Event | NotifyRequestReceived | NotifyRequestReceived event
Public Event | RegisterReceived | Event which is fired when a RegisterDocumentSet-b transaction is Received
Public Event | RegistryStoredQueryReceived | Event which is fired when a RegistryStoredQuery transaction is Received
Public Event | SubscriptionRequestReceived | SubscriptionRequestReceived event
Public Event | UnsubscriptionRequestReceived | UnsubscriptionRequestReceived event
Public Event | UpdateReceived | Event which is fired when a UpdateDocumentSet transaction is Received
Top
See Also

Reference

XdsSoapServer Class
XdsObjects Namespace


CreatePullPointRequestReceived Event

CreatePullPointRequestReceived Event

XdsObjects Namespace > XdsSoapServer Class : CreatePullPointRequestReceived Event
CreatePullPointRequestReceived event
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Event CreatePullPointRequestReceived As XdsSoapServer.CreatePullPointRequestHandler
Dim instance As XdsSoapServer
Dim handler As XdsSoapServer.CreatePullPointRequestHandler

AddHandler instance.CreatePullPointRequestReceived, handler
public event XdsSoapServer.CreatePullPointRequestHandler CreatePullPointRequestReceived
public:
event XdsSoapServer.CreatePullPointRequestHandler^ CreatePullPointRequestReceived
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSoapServer Class
XdsSoapServer Members


CrossGatewayQueryReceived Event

CrossGatewayQueryReceived Event

XdsObjects Namespace > XdsSoapServer Class : CrossGatewayQueryReceived Event
Event which is fired when a CrossGatewayQuery transaction is Received
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Event CrossGatewayQueryReceived As StoredQueryHandler
Dim instance As XdsSoapServer
Dim handler As StoredQueryHandler

AddHandler instance.CrossGatewayQueryReceived, handler
public event StoredQueryHandler CrossGatewayQueryReceived
public:
event StoredQueryHandler^ CrossGatewayQueryReceived
Remarks
An application which handles this transaction (an XCA responding gateway) is required to interpret the Request parameter (type XdsQueryRequest and return responses via an XdsQueryResponse result. It would normally do this by passing the request unchanged to its local registry, adding a HomeCommunityID to the results (using XdsQueryResponse.SetHomeCommunityID) and then returning that result object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSoapServer Class
XdsSoapServer Members


DeleteReceived Event

DeleteReceived Event

XdsObjects Namespace > XdsSoapServer Class : DeleteReceived Event
Event which is fired when a DeleteDocumentSet transaction is Received
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Event DeleteReceived As DeleteDocumentSetHandler
Dim instance As XdsSoapServer
Dim handler As DeleteDocumentSetHandler

AddHandler instance.DeleteReceived, handler
public event DeleteDocumentSetHandler DeleteReceived
public:
event DeleteDocumentSetHandler^ DeleteReceived
Remarks
This event would be handled only by a registry. Unlike the rest of XdsObjects, this event was not tested at the Connectathon, and is still experimental as the transaction itself still lies within the Supplement
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSoapServer Class
XdsSoapServer Members


NotifyRequestReceived Event

NotifyRequestReceived Event

XdsObjects Namespace > XdsSoapServer Class : NotifyRequestReceived Event
NotifyRequestReceived event
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Event NotifyRequestReceived As XdsSoapServer.NotifyRequestHandler
Dim instance As XdsSoapServer
Dim handler As XdsSoapServer.NotifyRequestHandler

AddHandler instance.NotifyRequestReceived, handler
public event XdsSoapServer.NotifyRequestHandler NotifyRequestReceived
public:
event XdsSoapServer.NotifyRequestHandler^ NotifyRequestReceived
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSoapServer Class
XdsSoapServer Members


RegisterReceived Event

RegisterReceived Event

XdsObjects Namespace > XdsSoapServer Class : RegisterReceived Event
Event which is fired when a RegisterDocumentSet-b transaction is Received
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Event RegisterReceived As RegisterDocumentSetHandler
Dim instance As XdsSoapServer
Dim handler As RegisterDocumentSetHandler

AddHandler instance.RegisterReceived, handler
public event RegisterDocumentSetHandler RegisterReceived
public:
event RegisterDocumentSetHandler^ RegisterReceived
Remarks
This event would be handled only by a registry
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSoapServer Class
XdsSoapServer Members


RegistryStoredQueryReceived Event

RegistryStoredQueryReceived Event

XdsObjects Namespace > XdsSoapServer Class : RegistryStoredQueryReceived Event
Event which is fired when a RegistryStoredQuery transaction is Received
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Event RegistryStoredQueryReceived As StoredQueryHandler
Dim instance As XdsSoapServer
Dim handler As StoredQueryHandler

AddHandler instance.RegistryStoredQueryReceived, handler
public event StoredQueryHandler RegistryStoredQueryReceived
public:
event StoredQueryHandler^ RegistryStoredQueryReceived
Remarks
An application which handles this transaction (either a registry or an XCA initiating gateway) is required to interpret the Request parameter (type XdsQueryRequest and return responses via an XdsQueryResponse result.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSoapServer Class
XdsSoapServer Members


SubscriptionRequestReceived Event

SubscriptionRequestReceived Event

XdsObjects Namespace > XdsSoapServer Class : SubscriptionRequestReceived Event
SubscriptionRequestReceived event
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Event SubscriptionRequestReceived As XdsSoapServer.SubscriptionRequestHandler
Dim instance As XdsSoapServer
Dim handler As XdsSoapServer.SubscriptionRequestHandler

AddHandler instance.SubscriptionRequestReceived, handler
public event XdsSoapServer.SubscriptionRequestHandler SubscriptionRequestReceived
public:
event XdsSoapServer.SubscriptionRequestHandler^ SubscriptionRequestReceived
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSoapServer Class
XdsSoapServer Members


UnsubscriptionRequestReceived Event

UnsubscriptionRequestReceived Event

XdsObjects Namespace > XdsSoapServer Class : UnsubscriptionRequestReceived Event
UnsubscriptionRequestReceived event
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Event UnsubscriptionRequestReceived As XdsSoapServer.UnsubscriptionRequestHandler
Dim instance As XdsSoapServer
Dim handler As XdsSoapServer.UnsubscriptionRequestHandler

AddHandler instance.UnsubscriptionRequestReceived, handler
public event XdsSoapServer.UnsubscriptionRequestHandler UnsubscriptionRequestReceived
public:
event XdsSoapServer.UnsubscriptionRequestHandler^ UnsubscriptionRequestReceived
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSoapServer Class
XdsSoapServer Members


UpdateReceived Event

UpdateReceived Event

XdsObjects Namespace > XdsSoapServer Class : UpdateReceived Event
Event which is fired when a UpdateDocumentSet transaction is Received
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Event UpdateReceived As UpdateDocumentSetHandler
Dim instance As XdsSoapServer
Dim handler As UpdateDocumentSetHandler

AddHandler instance.UpdateReceived, handler
public event UpdateDocumentSetHandler UpdateReceived
public:
event UpdateDocumentSetHandler^ UpdateReceived
Remarks
This event would be handled only by a registry. Unlike the rest of XdsObjects, this event was not tested at the Connectathon, and is still experimental as the transaction itself still lies within the Supplement
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSoapServer Class
XdsSoapServer Members


XdsSubmissionSet Class

XdsSubmissionSet Class
Members

XdsObjects Namespace : XdsSubmissionSet Class
Class representing an XDS.b Submission Set
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsSubmissionSet
Dim instance As XdsSubmissionSet
public class XdsSubmissionSet
public ref class XdsSubmissionSet
Remarks
This is the main object used by an XDS Source actor, or an XDS Combined Source and Repository actor, and it represents a XDS Submission Set. It may also be used:
  • by a repository or XDR source/recipient
  • when retrieving details of Submission sets from the registry

In an XCA environment the HomeCommunityID value is used for retrieval

Inheritance Hierarchy

System.Object
XdsObjects.XdsSubmissionSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Members
XdsObjects Namespace


XdsSubmissionSet Class Members

XdsSubmissionSet Class Members
Properties Methods

XdsObjects Namespace : XdsSubmissionSet Class

The following tables list the members exposed by XdsSubmissionSet.

Public Constructors
 | Name | Description
Public Constructor | XdsSubmissionSet Constructor | Creates a new Empty Submission Set
Top
Public Properties
 | Name | Description
Public Property | Associations | The set of Associations in this submission set
Public Property | Authors | The humans and/or machines that authored the Submission Set
Public Property | AvailabilityStatus | The availability status (Approved/Deprecated) of the submission set
Public Property | AvailabilityStatusAsInt | The AvailabilityStatus as an integer
Public Property | Comments | Comments associated with the Submission Set
Public Property | ContentType | The code specifying the type of clinical activity that resulted in placing these XDS Documents in this XDS-Submission Set.
Public Property | Documents | The set of documents at the "top level" in this Submission Set
Public Property | ExtraSlots | The list of slots not explicitly used to populate other fields
Public Property | Folders | The set of Folders in this Submission Set
Public Property | HomeCommunityID | The HomeCommunityID of the Submission Set
Public Property | IntendedRecipients | Represents the organization(s) or person(s) for whom the Submission set is intended.
Public Property | LogicalId | To allow a collection of registry objects to be grouped together and be identified as versions of the same object, two new attributes are introduced: the Logical ID and the VersionInfo element. While all objects must have unique value for their id attribute to maintain their identity, all objects that are versions of the same logical object have the same logical id or lid attribute
Public Property | PatientID | Shortcut to PatientInfo.XdsPerson.CompositeId
Public Property | PatientInfo | The subject of care of the Submission Set.
Public Property | SourceID | The SourceID, representing the system generating the data. All Document Sources are oblisged to complete this value, and set to a properly registered OID.
Public Property | Structured | Records wehether the associations in the submissionset were interpretted at the time of receipt
Public Property | SubmissionTime | Point in Time at the Document Source when the Submission Set was created and issued for registration to the Document Registry
Public Property | Title | Represents the title of the Submission Set
Public Property | UniqueID | The Unique ID of the submission set. This is set to a new value using NewOID in the constructor, but may be over-ridden if desired.
Public Property | UUID | The UUID of the SubmissionSet. If left blank, this field will be auto-set to a symbolic value (e.g. "SubmissionSet_01") during submission of the data. The registry will replace it by a GUID, which is the value which will be found in this property if it is subsequently retrieved from the registry.
Public Property | VersionInfo | To allow a collection of registry objects to be grouped together and be identified as versions of the same object, two new attributes are introduced: the Logical ID and the VersionInfo element. While all objects must have unique value for their id attribute to maintain their identity, all objects that are versions of the same logical object have the same logical id or lid attribute
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | ReadFromFile | Read a Submission Set serialised to a file
Public Method | ReplaceSymbolicNames | Consistentyly replace symbolic names by OIDs
Public Method | WriteXDM | Writes the SumissionSet object and all associated documents into a directory compatible with the XDM profiles.
Top
See Also

Reference

XdsSubmissionSet Class
XdsObjects Namespace


XdsSubmissionSet Constructor

XdsSubmissionSet Constructor

XdsObjects Namespace > XdsSubmissionSet Class : XdsSubmissionSet Constructor
Creates a new Empty Submission Set
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsSubmissionSet()
public XdsSubmissionSet()
public:
XdsSubmissionSet();
Remarks
All list properties are intialised to empty lists, and UniqueID is set to a new OID using NewOID.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


XdsSubmissionSet Class Methods

XdsSubmissionSet Class Methods

XdsObjects Namespace : XdsSubmissionSet Class

For a list of all members of this type, see XdsSubmissionSet members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | ReadFromFile | Read a Submission Set serialised to a file
Public Method | ReplaceSymbolicNames | Consistentyly replace symbolic names by OIDs
Public Method | WriteXDM | Writes the SumissionSet object and all associated documents into a directory compatible with the XDM profiles.
Top
See Also

Reference

XdsSubmissionSet Class
XdsObjects Namespace


ReadFromFile Method

ReadFromFile Method

XdsObjects Namespace > XdsSubmissionSet Class : ReadFromFile Method
The file to read
Read a Submission Set serialised to a file
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Shared Function ReadFromFile( _
   ByVal Filename As String _
) As XdsSubmissionSet
Dim Filename As String
Dim value As XdsSubmissionSet

value = XdsSubmissionSet.ReadFromFile(Filename)
public static XdsSubmissionSet ReadFromFile(
   string Filename
)
public:
static XdsSubmissionSet^ ReadFromFile(
   String^ Filename
)

Parameters

Filename
The file to read

Return Value

The resulting XdsSubmissionSetobject
Remarks
This is the primary method used when acting as an XDM media reader/importer for reading the METADATA.XML file within a subdirectory of the IHE_XDM directory.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


ReplaceSymbolicNames Method

ReplaceSymbolicNames Method

XdsObjects Namespace > XdsSubmissionSet Class : ReplaceSymbolicNames Method
Consistentyly replace symbolic names by OIDs
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub ReplaceSymbolicNames()
Dim instance As XdsSubmissionSet

instance.ReplaceSymbolicNames()
public void ReplaceSymbolicNames()
public:
void ReplaceSymbolicNames();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


WriteXDM Method

WriteXDM Method

XdsObjects Namespace > XdsSubmissionSet Class : WriteXDM Method
The directory to write the files into
The location of a stylesheet to use for METADATA.XML files
The location of a stylesheet to use for CDA files
Writes the SumissionSet object and all associated documents into a directory compatible with the XDM profiles.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Sub WriteXDM( _
   ByVal Directory As String, _
   ByVal MetaDataStyleSheet As String, _
   ByVal CDAStyleSheet As String _
)
Dim instance As XdsSubmissionSet
Dim Directory As String
Dim MetaDataStyleSheet As String
Dim CDAStyleSheet As String

instance.WriteXDM(Directory, MetaDataStyleSheet, CDAStyleSheet)
public void WriteXDM(
   string Directory,
   string MetaDataStyleSheet,
   string CDAStyleSheet
)
public:
void WriteXDM(
   String^ Directory,
   String^ MetaDataStyleSheet,
   String^ CDAStyleSheet
)

Parameters

Directory
The directory to write the files into
MetaDataStyleSheet
The location of a stylesheet to use for METADATA.XML files
CDAStyleSheet
The location of a stylesheet to use for CDA files
Remarks

Only the submission set folder is written - it is up to the calling application to:

  1. Create the README.TXT file
  2. Create the INDEX.HTM file
  3. Create the IHE_XDM folder into which the data is written using this call.

Most data is written "as is", but multi-part documents are handled specially:

  • The parts are placed in a directory
  • Only the first part is referenced from the METADATA.XML file
  • The size and hash in the metadata are updated accordingly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


XdsSubmissionSet Class Properties

XdsSubmissionSet Class Properties

XdsObjects Namespace : XdsSubmissionSet Class

For a list of all members of this type, see XdsSubmissionSet members.

Public Properties
 | Name | Description
Public Property | Associations | The set of Associations in this submission set
Public Property | Authors | The humans and/or machines that authored the Submission Set
Public Property | AvailabilityStatus | The availability status (Approved/Deprecated) of the submission set
Public Property | AvailabilityStatusAsInt | The AvailabilityStatus as an integer
Public Property | Comments | Comments associated with the Submission Set
Public Property | ContentType | The code specifying the type of clinical activity that resulted in placing these XDS Documents in this XDS-Submission Set.
Public Property | Documents | The set of documents at the "top level" in this Submission Set
Public Property | ExtraSlots | The list of slots not explicitly used to populate other fields
Public Property | Folders | The set of Folders in this Submission Set
Public Property | HomeCommunityID | The HomeCommunityID of the Submission Set
Public Property | IntendedRecipients | Represents the organization(s) or person(s) for whom the Submission set is intended.
Public Property | LogicalId | To allow a collection of registry objects to be grouped together and be identified as versions of the same object, two new attributes are introduced: the Logical ID and the VersionInfo element. While all objects must have unique value for their id attribute to maintain their identity, all objects that are versions of the same logical object have the same logical id or lid attribute
Public Property | PatientID | Shortcut to PatientInfo.XdsPerson.CompositeId
Public Property | PatientInfo | The subject of care of the Submission Set.
Public Property | SourceID | The SourceID, representing the system generating the data. All Document Sources are oblisged to complete this value, and set to a properly registered OID.
Public Property | Structured | Records wehether the associations in the submissionset were interpretted at the time of receipt
Public Property | SubmissionTime | Point in Time at the Document Source when the Submission Set was created and issued for registration to the Document Registry
Public Property | Title | Represents the title of the Submission Set
Public Property | UniqueID | The Unique ID of the submission set. This is set to a new value using NewOID in the constructor, but may be over-ridden if desired.
Public Property | UUID | The UUID of the SubmissionSet. If left blank, this field will be auto-set to a symbolic value (e.g. "SubmissionSet_01") during submission of the data. The registry will replace it by a GUID, which is the value which will be found in this property if it is subsequently retrieved from the registry.
Public Property | VersionInfo | To allow a collection of registry objects to be grouped together and be identified as versions of the same object, two new attributes are introduced: the Logical ID and the VersionInfo element. While all objects must have unique value for their id attribute to maintain their identity, all objects that are versions of the same logical object have the same logical id or lid attribute
Top
See Also

Reference

XdsSubmissionSet Class
XdsObjects Namespace


Associations Property

Associations Property

XdsObjects Namespace > XdsSubmissionSet Class : Associations Property
The set of Associations in this submission set
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Associations As List(Of XdsAssociation)
Dim instance As XdsSubmissionSet
Dim value As List(Of XdsAssociation)

instance.Associations = value

value = instance.Associations
public List<XdsAssociation> Associations {get; set;}
public:
property List<XdsAssociation^>^ Associations {
   List<XdsAssociation^>^ get();
   void set (    List<XdsAssociation^>^ value);
}
Remarks
If XdsBaseServer.StructureIncomingSubmissionSet is true, then any associations received in incoming data are "consumed" internally and this collection will be empty, but if XdsBaseServer.StructureIncomingSubmissionSet is false, then any associations received will be placed into this collection "as received", including those that merely link other associations to the SubmissionSet
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


Authors Property (XdsSubmissionSet)

Authors Property (XdsSubmissionSet)

XdsObjects Namespace > XdsSubmissionSet Class : Authors Property
The humans and/or machines that authored the Submission Set
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Authors As List(Of XdsAuthor)
Dim instance As XdsSubmissionSet
Dim value As List(Of XdsAuthor)

instance.Authors = value

value = instance.Authors
public List<XdsAuthor> Authors {get; set;}
public:
property List<XdsAuthor^>^ Authors {
   List<XdsAuthor^>^ get();
   void set (    List<XdsAuthor^>^ value);
}
Remarks

This property corresponds to the XDSSubmissionSet.author Classifications

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


AvailabilityStatus Property (XdsSubmissionSet)

AvailabilityStatus Property (XdsSubmissionSet)

XdsObjects Namespace > XdsSubmissionSet Class : AvailabilityStatus Property
The availability status (Approved/Deprecated) of the submission set
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property AvailabilityStatus As AvailabilityStatusCode
Dim instance As XdsSubmissionSet
Dim value As AvailabilityStatusCode

instance.AvailabilityStatus = value

value = instance.AvailabilityStatus
public AvailabilityStatusCode AvailabilityStatus {get; set;}
public:
property AvailabilityStatusCode AvailabilityStatus {
   AvailabilityStatusCode get();
   void set (    AvailabilityStatusCode value);
}
Remarks

This property corresponds to the XDSSubmissionSet.availabilityStatus attribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


AvailabilityStatusAsInt Property (XdsSubmissionSet)

AvailabilityStatusAsInt Property (XdsSubmissionSet)

XdsObjects Namespace > XdsSubmissionSet Class : AvailabilityStatusAsInt Property
The AvailabilityStatus as an integer
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property AvailabilityStatusAsInt As Integer
Dim instance As XdsSubmissionSet
Dim value As Integer

instance.AvailabilityStatusAsInt = value

value = instance.AvailabilityStatusAsInt
public int AvailabilityStatusAsInt {get; set;}
public:
property int AvailabilityStatusAsInt {
   int get();
   void set (    int value);
}
Remarks
This is a special property, only used as part of a registry based on the Code First Entity Framework which is used for our registry example. This is needed due to the inability of the Entity Framework to handle Enums. When used in this mode, the AvailabilityStatus property should be excluded from the database.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


Comments Property (XdsSubmissionSet)

Comments Property (XdsSubmissionSet)

XdsObjects Namespace > XdsSubmissionSet Class : Comments Property
Comments associated with the Submission Set
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Comments As XdsInternationalString
Dim instance As XdsSubmissionSet
Dim value As XdsInternationalString

instance.Comments = value

value = instance.Comments
public XdsInternationalString Comments {get; set;}
public:
property XdsInternationalString^ Comments {
   XdsInternationalString^ get();
   void set (    XdsInternationalString^ value);
}
Remarks

This property corresponds to the XDSSubmissionSet.comments Attribute, which actually uses the ebXML "Description" attribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


ContentType Property

ContentType Property

XdsObjects Namespace > XdsSubmissionSet Class : ContentType Property
The code specifying the type of clinical activity that resulted in placing these XDS Documents in this XDS-Submission Set.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ContentType As XdsCode
Dim instance As XdsSubmissionSet
Dim value As XdsCode

instance.ContentType = value

value = instance.ContentType
public XdsCode ContentType {get; set;}
public:
property XdsCode^ ContentType {
   XdsCode^ get();
   void set (    XdsCode^ value);
}
Remarks

This property corresponds to the XDSSubmissionSet.contentTypeCode Classification

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


Documents Property (XdsSubmissionSet)

Documents Property (XdsSubmissionSet)

XdsObjects Namespace > XdsSubmissionSet Class : Documents Property
The set of documents at the "top level" in this Submission Set
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Documents As List(Of XdsDocument)
Dim instance As XdsSubmissionSet
Dim value As List(Of XdsDocument)

instance.Documents = value

value = instance.Documents
public List<XdsDocument> Documents {get; set;}
public:
property List<XdsDocument^>^ Documents {
   List<XdsDocument^>^ get();
   void set (    List<XdsDocument^>^ value);
}
Remarks

Documents may also be present in the Folders collections.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


ExtraSlots Property (XdsSubmissionSet)

ExtraSlots Property (XdsSubmissionSet)

XdsObjects Namespace > XdsSubmissionSet Class : ExtraSlots Property
The list of slots not explicitly used to populate other fields
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property ExtraSlots As List(Of XdsSlot)
Dim instance As XdsSubmissionSet
Dim value As List(Of XdsSlot)

value = instance.ExtraSlots
public List<XdsSlot> ExtraSlots {get;}
public:
property List<XdsSlot^>^ ExtraSlots {
   List<XdsSlot^>^ get();
}
Remarks
Whilst the XDS standards specifiy the contents of some slots (such as Authors and many more), other "user defined" slots are allowed and should be stored by a registry. This property allows such additional slots to be created and accessed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


Folders Property

Folders Property

XdsObjects Namespace > XdsSubmissionSet Class : Folders Property
The set of Folders in this Submission Set
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Folders As List(Of XdsFolder)
Dim instance As XdsSubmissionSet
Dim value As List(Of XdsFolder)

instance.Folders = value

value = instance.Folders
public List<XdsFolder> Folders {get; set;}
public:
property List<XdsFolder^>^ Folders {
   List<XdsFolder^>^ get();
   void set (    List<XdsFolder^>^ value);
}
Remarks

The way that objects in this collection are created and/or used depends on several factors:

During submission:

  • If Structured is true, then
    • Any Associations in the Associations collection are passed through unchanged
    • No Associations are generated automatically
  • If Structured is false, then
    • Association objects are automatically created to link the documents to their folders (and to link those associations to the submission set!)
    • Duplicate documents (either in different folders or in both a folder and top level) are collapsed to a single document with multiple associations

During receipt:

  • If the incoming Server's StructureIncomingSubmissionSet is true, then
    • Structured is set to true
    • If association and folder objects are retrieved, then the folder structure is recreated at retrieval time
    • Otherwise the documents will appear in the top level documents
  • else
    • Structured is set to false
    • The documents will appear in the top level documents, and will not be placed into Folders.
For more details, see StructuredData
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


HomeCommunityID Property (XdsSubmissionSet)

HomeCommunityID Property (XdsSubmissionSet)

XdsObjects Namespace > XdsSubmissionSet Class : HomeCommunityID Property
The HomeCommunityID of the Submission Set
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property HomeCommunityID As String
Dim instance As XdsSubmissionSet
Dim value As String

instance.HomeCommunityID = value

value = instance.HomeCommunityID
public string HomeCommunityID {get; set;}
public:
property String^ HomeCommunityID {
   String^ get();
   void set (    String^ value);
}
Remarks
This is only used in the context of XCA queries. The value will be set internally from the "home" property of incoming data. For outgoing data, it is easiest to set for all objects in the "passed through" data by using the XdsQueryResponse.SetHomeCommunityID method.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


IntendedRecipients Property

IntendedRecipients Property

XdsObjects Namespace > XdsSubmissionSet Class : IntendedRecipients Property
Represents the organization(s) or person(s) for whom the Submission set is intended.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property IntendedRecipients As XdsMultiString
Dim instance As XdsSubmissionSet
Dim value As XdsMultiString

instance.IntendedRecipients = value

value = instance.IntendedRecipients
public XdsMultiString IntendedRecipients {get; set;}
public:
property XdsMultiString^ IntendedRecipients {
   XdsMultiString^ get();
   void set (    XdsMultiString^ value);
}
Remarks

This is only intended for use in XDM and XDR

Eaxch item in this XdsMultiString should be formatted as an HL7 XON (organisation) code followed by | and then an XCN (person) name. Whilst either code may be absent, the | is mandatory is the person details are included

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


LogicalId Property (XdsSubmissionSet)

LogicalId Property (XdsSubmissionSet)

XdsObjects Namespace > XdsSubmissionSet Class : LogicalId Property
To allow a collection of registry objects to be grouped together and be identified as versions of the same object, two new attributes are introduced: the Logical ID and the VersionInfo element. While all objects must have unique value for their id attribute to maintain their identity, all objects that are versions of the same logical object have the same logical id or lid attribute
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property LogicalId As String
Dim instance As XdsSubmissionSet
Dim value As String

instance.LogicalId = value

value = instance.LogicalId
public string LogicalId {get; set;}
public:
property String^ LogicalId {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


PatientID Property (XdsSubmissionSet)

PatientID Property (XdsSubmissionSet)

XdsObjects Namespace > XdsSubmissionSet Class : PatientID Property
Shortcut to PatientInfo.XdsPerson.CompositeId
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property PatientID As String
Dim instance As XdsSubmissionSet
Dim value As String

instance.PatientID = value

value = instance.PatientID
public string PatientID {get; set;}
public:
property String^ PatientID {
   String^ get();
   void set (    String^ value);
}
Remarks
The main use for this property is to act as the primary key for applications using the Code First Entity framework, but it is also available for more general use.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


PatientInfo Property (XdsSubmissionSet)

PatientInfo Property (XdsSubmissionSet)

XdsObjects Namespace > XdsSubmissionSet Class : PatientInfo Property
The subject of care of the Submission Set.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property PatientInfo As XdsPatient
Dim instance As XdsSubmissionSet
Dim value As XdsPatient

instance.PatientInfo = value

value = instance.PatientInfo
public XdsPatient PatientInfo {get; set;}
public:
property XdsPatient^ PatientInfo {
   XdsPatient^ get();
   void set (    XdsPatient^ value);
}
Remarks

This property corresponds to the XDSSubmissionSet.patientId ExternalIdentifier

Although a full XdsPatient is used, only the CompositeId is used internally. Where necessary, during submission, the ID is converted using PIX from the Source (local) domain to the domain used by the XDS affinity domain. See Automatic PIX Queries in XdsObjects for more details.

The composite ID is also accessible via the PatientID property, which is actually a shortcut to PatientInfo.XdsPerson.CompositeId

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


SourceID Property

SourceID Property

XdsObjects Namespace > XdsSubmissionSet Class : SourceID Property
The SourceID, representing the system generating the data. All Document Sources are oblisged to complete this value, and set to a properly registered OID.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property SourceID As String
Dim instance As XdsSubmissionSet
Dim value As String

instance.SourceID = value

value = instance.SourceID
public string SourceID {get; set;}
public:
property String^ SourceID {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


Structured Property

Structured Property

XdsObjects Namespace > XdsSubmissionSet Class : Structured Property
Records wehether the associations in the submissionset were interpretted at the time of receipt
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Structured As Boolean
Dim instance As XdsSubmissionSet
Dim value As Boolean

instance.Structured = value

value = instance.Structured
public bool Structured {get; set;}
public:
property bool Structured {
   bool get();
   void set (    bool value);
}
Remarks

This records the value of StructureIncomingSubmissionSet at the time of receipt, and therefore controls whether new associations are auto-generated if/when the submissionset is re-sent.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


SubmissionTime Property

SubmissionTime Property

XdsObjects Namespace > XdsSubmissionSet Class : SubmissionTime Property
Point in Time at the Document Source when the Submission Set was created and issued for registration to the Document Registry
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property SubmissionTime As Date
Dim instance As XdsSubmissionSet
Dim value As Date

instance.SubmissionTime = value

value = instance.SubmissionTime
public DateTime SubmissionTime {get; set;}
public:
property DateTime SubmissionTime {
   DateTime get();
   void set (    DateTime value);
}
Remarks

This property corresponds to the XDSSubmissionSet.submissionTime Classification

This is set automatically by XdsObjects during ProvideAndRegisterDocumentSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


Title Property (XdsSubmissionSet)

Title Property (XdsSubmissionSet)

XdsObjects Namespace > XdsSubmissionSet Class : Title Property
Represents the title of the Submission Set
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Title As XdsInternationalString
Dim instance As XdsSubmissionSet
Dim value As XdsInternationalString

instance.Title = value

value = instance.Title
public XdsInternationalString Title {get; set;}
public:
property XdsInternationalString^ Title {
   XdsInternationalString^ get();
   void set (    XdsInternationalString^ value);
}
Remarks

This property corresponds to the XDSSubmissionSet.title Attribute, which actually uses the ebXML "Name" attribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


UniqueID Property (XdsSubmissionSet)

UniqueID Property (XdsSubmissionSet)

XdsObjects Namespace > XdsSubmissionSet Class : UniqueID Property
The Unique ID of the submission set. This is set to a new value using NewOID in the constructor, but may be over-ridden if desired.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property UniqueID As String
Dim instance As XdsSubmissionSet
Dim value As String

instance.UniqueID = value

value = instance.UniqueID
public string UniqueID {get; set;}
public:
property String^ UniqueID {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


UUID Property (XdsSubmissionSet)

UUID Property (XdsSubmissionSet)

XdsObjects Namespace > XdsSubmissionSet Class : UUID Property
The UUID of the SubmissionSet. If left blank, this field will be auto-set to a symbolic value (e.g. "SubmissionSet_01") during submission of the data. The registry will replace it by a GUID, which is the value which will be found in this property if it is subsequently retrieved from the registry.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property UUID As String
Dim instance As XdsSubmissionSet
Dim value As String

instance.UUID = value

value = instance.UUID
public string UUID {get; set;}
public:
property String^ UUID {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


VersionInfo Property (XdsSubmissionSet)

VersionInfo Property (XdsSubmissionSet)

XdsObjects Namespace > XdsSubmissionSet Class : VersionInfo Property
To allow a collection of registry objects to be grouped together and be identified as versions of the same object, two new attributes are introduced: the Logical ID and the VersionInfo element. While all objects must have unique value for their id attribute to maintain their identity, all objects that are versions of the same logical object have the same logical id or lid attribute
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property VersionInfo As String
Dim instance As XdsSubmissionSet
Dim value As String

instance.VersionInfo = value

value = instance.VersionInfo
public string VersionInfo {get; set;}
public:
property String^ VersionInfo {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


XdsDomain.AuditSchemaType Enumeration

XdsDomain.AuditSchemaType Enumeration

XdsObjects Namespace : XdsDomain.AuditSchemaType Enumeration
Specify which Schema to use when formatting Audit message
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Enum XdsDomain.AuditSchemaType
   Inherits System.Enum
Dim instance As XdsDomain.AuditSchemaType
public enum XdsDomain.AuditSchemaType : System.Enum
public enum class XdsDomain.AuditSchemaType : public System.Enum
Members
Member | Description
DICOM | Schema developed and used by DICOM
RFC_3881 | The Orignal RFC schema used by IHE
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
XdsObjects.XdsDomain.AuditSchemaType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjects Namespace


DeleteDocumentSetHandler Delegate

DeleteDocumentSetHandler Delegate

XdsObjects Namespace : DeleteDocumentSetHandler Delegate
XdsDeleteDocumentSetRequest object that contains a list of Object IDs to be deleted
Details of the incoming request
Delegate used for an incoming XdsSoapServer.DeleteReceived events
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Delegate Function DeleteDocumentSetHandler( _
   ByVal Request As XdsDeleteDocumentSetRequest, _
   ByVal RequestInfo As XdsRequestInfo _
) As XdsRegistryResponse
Dim instance As New DeleteDocumentSetHandler(AddressOf HandlerMethod)
public delegate XdsRegistryResponse DeleteDocumentSetHandler(
   XdsDeleteDocumentSetRequest Request,
   XdsRequestInfo RequestInfo
)
public delegate XdsRegistryResponse^ DeleteDocumentSetHandler(
   XdsDeleteDocumentSetRequest^ Request,
   XdsRequestInfo^ RequestInfo
)

Parameters

Request
XdsDeleteDocumentSetRequest object that contains a list of Object IDs to be deleted
RequestInfo
Details of the incoming request

Return Value

XdsRegistryResponse Object containing the registry response
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DeleteDocumentSetHandler Members
XdsObjects Namespace


ImagingRetrieveHandler Delegate

ImagingRetrieveHandler Delegate

XdsObjects Namespace : ImagingRetrieveHandler Delegate
XdsImagingRetrieveRequest object holding details of the images and transfer syntaxes requested.
Details of the incoming request
Delegate to hold the XdsImagingServer.ImageRequestReceived event
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Delegate Function ImagingRetrieveHandler( _
   ByVal Request As XdsImagingRetrieveRequest, _
   ByVal RequestInfo As XdsRequestInfo _
) As XdsRetrieveResponse
Dim instance As New ImagingRetrieveHandler(AddressOf HandlerMethod)
public delegate XdsRetrieveResponse ImagingRetrieveHandler(
   XdsImagingRetrieveRequest Request,
   XdsRequestInfo RequestInfo
)
public delegate XdsRetrieveResponse^ ImagingRetrieveHandler(
   XdsImagingRetrieveRequest^ Request,
   XdsRequestInfo^ RequestInfo
)

Parameters

Request
XdsImagingRetrieveRequest object holding details of the images and transfer syntaxes requested.
RequestInfo
Details of the incoming request

Return Value

XdsRetrieveResponse object holding the response.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImagingRetrieveHandler Members
XdsObjects Namespace


RegisterDocumentSetHandler Delegate

RegisterDocumentSetHandler Delegate

XdsObjects Namespace : RegisterDocumentSetHandler Delegate
Object carrying the Submission Set
Details of the incoming request
Delegate used for an incoming XdsMtomServer.ProvideAndRegisterRequestReceived and XdsSoapServer.RegisterReceived events
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Delegate Function RegisterDocumentSetHandler( _
   ByVal SubmissionSet As XdsSubmissionSet, _
   ByVal RequestInfo As XdsRequestInfo _
) As XdsRegistryResponse
Dim instance As New RegisterDocumentSetHandler(AddressOf HandlerMethod)
public delegate XdsRegistryResponse RegisterDocumentSetHandler(
   XdsSubmissionSet SubmissionSet,
   XdsRequestInfo RequestInfo
)
public delegate XdsRegistryResponse^ RegisterDocumentSetHandler(
   XdsSubmissionSet^ SubmissionSet,
   XdsRequestInfo^ RequestInfo
)

Parameters

SubmissionSet
Object carrying the Submission Set
RequestInfo
Details of the incoming request

Return Value

XdsRegistryResponse object containing the registry response
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegisterDocumentSetHandler Members
XdsObjects Namespace


RetrieveHandler Delegate

RetrieveHandler Delegate

XdsObjects Namespace : RetrieveHandler Delegate
Object carrying the retrieval request
Details of the incoming request
Delegate used for incoming XdsMtomServer.RetrieveRequestReceived and XdsMtomServer.CrossGatewayRetrieveReceived events
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Delegate Function RetrieveHandler( _
   ByVal Request As XdsRetrieveRequest, _
   ByVal RequestInfo As XdsRequestInfo _
) As XdsRetrieveResponse
Dim instance As New RetrieveHandler(AddressOf HandlerMethod)
public delegate XdsRetrieveResponse RetrieveHandler(
   XdsRetrieveRequest Request,
   XdsRequestInfo RequestInfo
)
public delegate XdsRetrieveResponse^ RetrieveHandler(
   XdsRetrieveRequest^ Request,
   XdsRequestInfo^ RequestInfo
)

Parameters

Request
Object carrying the retrieval request
RequestInfo
Details of the incoming request

Return Value

XdsRetrieveResponse object containing the requested documents
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RetrieveHandler Members
XdsObjects Namespace


StoredQueryHandler Delegate

StoredQueryHandler Delegate

XdsObjects Namespace : StoredQueryHandler Delegate
The request received
Details of the incoming request
Delegate used by the RegistryStoredQueryReceived and XdsSoapServer.CrossGatewayQueryReceived events
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Delegate Function StoredQueryHandler( _
   ByVal Request As XdsQueryRequest, _
   ByVal RequestInfo As XdsRequestInfo _
) As XdsQueryResponse
Dim instance As New StoredQueryHandler(AddressOf HandlerMethod)
public delegate XdsQueryResponse StoredQueryHandler(
   XdsQueryRequest Request,
   XdsRequestInfo RequestInfo
)
public delegate XdsQueryResponse^ StoredQueryHandler(
   XdsQueryRequest^ Request,
   XdsRequestInfo^ RequestInfo
)

Parameters

Request
The request received
RequestInfo
Details of the incoming request
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StoredQueryHandler Members
XdsObjects Namespace


UpdateDocumentSetHandler Delegate

UpdateDocumentSetHandler Delegate

XdsObjects Namespace : UpdateDocumentSetHandler Delegate
SubmissionSet object that organizes the content of the update
Details of the incoming request
Delegate used for an incoming XdsSoapServer.UpdateReceived events
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Delegate Function UpdateDocumentSetHandler( _
   ByVal SubmissionSet As XdsSubmissionSet, _
   ByVal RequestInfo As XdsRequestInfo _
) As XdsRegistryResponse
Dim instance As New UpdateDocumentSetHandler(AddressOf HandlerMethod)
public delegate XdsRegistryResponse UpdateDocumentSetHandler(
   XdsSubmissionSet SubmissionSet,
   XdsRequestInfo RequestInfo
)
public delegate XdsRegistryResponse^ UpdateDocumentSetHandler(
   XdsSubmissionSet^ SubmissionSet,
   XdsRequestInfo^ RequestInfo
)

Parameters

SubmissionSet
SubmissionSet object that organizes the content of the update
RequestInfo
Details of the incoming request

Return Value

XdsRegistryResponse object containing the registry response
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UpdateDocumentSetHandler Members
XdsObjects Namespace


XdsGlobal.LogHandler Delegate

XdsGlobal.LogHandler Delegate

XdsObjects Namespace : XdsGlobal.LogHandler Delegate
Delegate for the LogEvent Event
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Delegate Sub XdsGlobal.LogHandler( _
   ByVal e As XdsGlobal.LogEventArgs _
)
Dim instance As New XdsGlobal.LogHandler(AddressOf HandlerMethod)
public delegate void XdsGlobal.LogHandler(
   XdsGlobal.LogEventArgs e
)
public delegate void XdsGlobal.LogHandler(
   XdsGlobal.LogEventArgs^ e
)

Parameters

e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsGlobal.LogHandler Members
XdsObjects Namespace


XdsLicense.RetrieveLicenseHandler Delegate

XdsLicense.RetrieveLicenseHandler Delegate

XdsObjects Namespace : XdsLicense.RetrieveLicenseHandler Delegate
Delegate for the RetrieveLicense event
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Delegate Function XdsLicense.RetrieveLicenseHandler() As String
Dim instance As New XdsLicense.RetrieveLicenseHandler(AddressOf HandlerMethod)
public delegate string XdsLicense.RetrieveLicenseHandler()
public delegate String^ XdsLicense.RetrieveLicenseHandler();

Return Value

A previously stored license string - as passed via StoreLicense
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense.RetrieveLicenseHandler Members
XdsObjects Namespace


XdsLicense.StoreLicenseHandler Delegate

XdsLicense.StoreLicenseHandler Delegate

XdsObjects Namespace : XdsLicense.StoreLicenseHandler Delegate
Token to store
Delegate for StoreLicense event
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Delegate Function XdsLicense.StoreLicenseHandler( _
   ByVal LicenseToken As String _
) As Boolean
Dim instance As New XdsLicense.StoreLicenseHandler(AddressOf HandlerMethod)
public delegate bool XdsLicense.StoreLicenseHandler(
   string LicenseToken
)
public delegate bool XdsLicense.StoreLicenseHandler(
   String^ LicenseToken
)

Parameters

LicenseToken
Token to store

Return Value

True if the routine stores the license key successfully
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsLicense.StoreLicenseHandler Members
XdsObjects Namespace


XdsSoapServer.CreatePullPointRequestHandler Delegate

XdsSoapServer.CreatePullPointRequestHandler Delegate

XdsObjects Namespace : XdsSoapServer.CreatePullPointRequestHandler Delegate
The CreatePullPoint request
Details of the request
Event Hanlder of XDS DSUB CreatePullPoint Request
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Delegate Function XdsSoapServer.CreatePullPointRequestHandler( _
   ByVal Request As XdsCreatePullPointRequest, _
   ByVal RequestInfo As XdsRequestInfo _
) As XdsCreatePullPointResponse
Dim instance As New XdsSoapServer.CreatePullPointRequestHandler(AddressOf HandlerMethod)
public delegate XdsCreatePullPointResponse XdsSoapServer.CreatePullPointRequestHandler(
   XdsCreatePullPointRequest Request,
   XdsRequestInfo RequestInfo
)
public delegate XdsCreatePullPointResponse^ XdsSoapServer.CreatePullPointRequestHandler(
   XdsCreatePullPointRequest^ Request,
   XdsRequestInfo^ RequestInfo
)

Parameters

Request
The CreatePullPoint request
RequestInfo
Details of the request
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSoapServer.CreatePullPointRequestHandler Members
XdsObjects Namespace


XdsSoapServer.NotifyRequestHandler Delegate

XdsSoapServer.NotifyRequestHandler Delegate

XdsObjects Namespace : XdsSoapServer.NotifyRequestHandler Delegate
The Notify request
Details of the request
Event Hanlder of XDS DSUB Notify Request
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Delegate Sub XdsSoapServer.NotifyRequestHandler( _
   ByVal Request As XdsNotifyRequest, _
   ByVal RequestInfo As XdsRequestInfo _
)
Dim instance As New XdsSoapServer.NotifyRequestHandler(AddressOf HandlerMethod)
public delegate void XdsSoapServer.NotifyRequestHandler(
   XdsNotifyRequest Request,
   XdsRequestInfo RequestInfo
)
public delegate void XdsSoapServer.NotifyRequestHandler(
   XdsNotifyRequest^ Request,
   XdsRequestInfo^ RequestInfo
)

Parameters

Request
The Notify request
RequestInfo
Details of the request
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSoapServer.NotifyRequestHandler Members
XdsObjects Namespace


XdsSoapServer.SubscriptionRequestHandler Delegate

XdsSoapServer.SubscriptionRequestHandler Delegate

XdsObjects Namespace : XdsSoapServer.SubscriptionRequestHandler Delegate
The Subscribe request
Details of the request
Event Hanlder of XDS DSUB Subcription Request
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Delegate Function XdsSoapServer.SubscriptionRequestHandler( _
   ByVal Request As XdsSubscriptionRequest, _
   ByVal RequestInfo As XdsRequestInfo _
) As XdsSubscriptionResponse
Dim instance As New XdsSoapServer.SubscriptionRequestHandler(AddressOf HandlerMethod)
public delegate XdsSubscriptionResponse XdsSoapServer.SubscriptionRequestHandler(
   XdsSubscriptionRequest Request,
   XdsRequestInfo RequestInfo
)
public delegate XdsSubscriptionResponse^ XdsSoapServer.SubscriptionRequestHandler(
   XdsSubscriptionRequest^ Request,
   XdsRequestInfo^ RequestInfo
)

Parameters

Request
The Subscribe request
RequestInfo
Details of the request
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSoapServer.SubscriptionRequestHandler Members
XdsObjects Namespace


XdsSoapServer.UnsubscriptionRequestHandler Delegate

XdsSoapServer.UnsubscriptionRequestHandler Delegate

XdsObjects Namespace : XdsSoapServer.UnsubscriptionRequestHandler Delegate
The Unsubscribe request
Details of the request
Event Hanlder of XDS DSUB Unsubcription Request
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Delegate Function XdsSoapServer.UnsubscriptionRequestHandler( _
   ByVal Request As XdsUnsubscriptionRequest, _
   ByVal RequestInfo As XdsRequestInfo _
) As XdsUnsubscriptionResponse
Dim instance As New XdsSoapServer.UnsubscriptionRequestHandler(AddressOf HandlerMethod)
public delegate XdsUnsubscriptionResponse XdsSoapServer.UnsubscriptionRequestHandler(
   XdsUnsubscriptionRequest Request,
   XdsRequestInfo RequestInfo
)
public delegate XdsUnsubscriptionResponse^ XdsSoapServer.UnsubscriptionRequestHandler(
   XdsUnsubscriptionRequest^ Request,
   XdsRequestInfo^ RequestInfo
)

Parameters

Request
The Unsubscribe request
RequestInfo
Details of the request
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSoapServer.UnsubscriptionRequestHandler Members
XdsObjects Namespace


XdsObjects.Dsub Namespace

XdsObjects.Dsub Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | NotificationMessage | Represents the DSUB notification message
Class | XdsCreatePullPointRequest | Object which represents a XDS DSUB Create PullPoint request
Class | XdsCreatePullPointResponse | Object represents DSUB Create PullPoint response
Class | XdsDestroyPullPointRequest | Object which represents a DSUB Destroy Pull Point Request
Class | XdsDestroyPullPointResponse | Object which represents a DSUB Destroy Pull Point Response
Class | XdsNotifyRequest | Object represents a XDS DSUB notification request
Class | XdsSubscriptionRequest | Object represents DSUB Subscribe Request
Class | XdsSubscriptionResponse | Object represents the XDS DSUB Subscribe response
Class | XdsUnsubscriptionRequest | Object represents DSUB Unsubscribe Request
Class | XdsUnsubscriptionResponse | Object represents the XDS DSUB Unsubscribe response
See Also

Reference

XdsObjects.6.40 Assembly


NotificationMessage Class

NotificationMessage Class
Members

XdsObjects.Dsub Namespace : NotificationMessage Class
Represents the DSUB notification message
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class NotificationMessage
Dim instance As NotificationMessage
public class NotificationMessage
public ref class NotificationMessage
Inheritance Hierarchy

System.Object
XdsObjects.Dsub.NotificationMessage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotificationMessage Members
XdsObjects.Dsub Namespace


NotificationMessage Class Members

NotificationMessage Class Members
Properties

XdsObjects.Dsub Namespace : NotificationMessage Class

The following tables list the members exposed by NotificationMessage.

Public Constructors
 | Name | Description
Public Constructor | NotificationMessage Constructor | Public constructor
Top
Public Properties
 | Name | Description
Public Property | DocumentsToNotify | List of XdsDocuments whose metadata matches the filter conditions of the subscription
Public Property | ForderToNotify | XdsFolder whose metadata matches the filter conditions of the subscription
Public Property | SubmissionSetToNotify | XdsSubmisstionSet whose metadata matches the filter conditions of the subscription
Top
See Also

Reference

NotificationMessage Class
XdsObjects.Dsub Namespace


NotificationMessage Constructor

NotificationMessage Constructor

XdsObjects.Dsub Namespace > NotificationMessage Class : NotificationMessage Constructor
Public constructor
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New NotificationMessage()
public NotificationMessage()
public:
NotificationMessage();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotificationMessage Class
NotificationMessage Members


NotificationMessage Class Properties

NotificationMessage Class Properties

XdsObjects.Dsub Namespace : NotificationMessage Class

For a list of all members of this type, see NotificationMessage members.

Public Properties
 | Name | Description
Public Property | DocumentsToNotify | List of XdsDocuments whose metadata matches the filter conditions of the subscription
Public Property | ForderToNotify | XdsFolder whose metadata matches the filter conditions of the subscription
Public Property | SubmissionSetToNotify | XdsSubmisstionSet whose metadata matches the filter conditions of the subscription
Top
See Also

Reference

NotificationMessage Class
XdsObjects.Dsub Namespace


DocumentsToNotify Property

DocumentsToNotify Property

XdsObjects.Dsub Namespace > NotificationMessage Class : DocumentsToNotify Property
List of XdsDocuments whose metadata matches the filter conditions of the subscription
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property DocumentsToNotify As List(Of XdsDocument)
Dim instance As NotificationMessage
Dim value As List(Of XdsDocument)

instance.DocumentsToNotify = value

value = instance.DocumentsToNotify
public List<XdsDocument> DocumentsToNotify {get; set;}
public:
property List<XdsDocument^>^ DocumentsToNotify {
   List<XdsDocument^>^ get();
   void set (    List<XdsDocument^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotificationMessage Class
NotificationMessage Members


ForderToNotify Property

ForderToNotify Property

XdsObjects.Dsub Namespace > NotificationMessage Class : ForderToNotify Property
XdsFolder whose metadata matches the filter conditions of the subscription
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ForderToNotify As XdsFolder
Dim instance As NotificationMessage
Dim value As XdsFolder

instance.ForderToNotify = value

value = instance.ForderToNotify
public XdsFolder ForderToNotify {get; set;}
public:
property XdsFolder^ ForderToNotify {
   XdsFolder^ get();
   void set (    XdsFolder^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotificationMessage Class
NotificationMessage Members


SubmissionSetToNotify Property

SubmissionSetToNotify Property

XdsObjects.Dsub Namespace > NotificationMessage Class : SubmissionSetToNotify Property
XdsSubmisstionSet whose metadata matches the filter conditions of the subscription
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property SubmissionSetToNotify As XdsSubmissionSet
Dim instance As NotificationMessage
Dim value As XdsSubmissionSet

instance.SubmissionSetToNotify = value

value = instance.SubmissionSetToNotify
public XdsSubmissionSet SubmissionSetToNotify {get; set;}
public:
property XdsSubmissionSet^ SubmissionSetToNotify {
   XdsSubmissionSet^ get();
   void set (    XdsSubmissionSet^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotificationMessage Class
NotificationMessage Members


XdsCreatePullPointRequest Class

XdsCreatePullPointRequest Class
Members

XdsObjects.Dsub Namespace : XdsCreatePullPointRequest Class
Object which represents a XDS DSUB Create PullPoint request
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsCreatePullPointRequest
Dim instance As XdsCreatePullPointRequest
public class XdsCreatePullPointRequest
public ref class XdsCreatePullPointRequest
Inheritance Hierarchy

System.Object
XdsObjects.Dsub.XdsCreatePullPointRequest

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsCreatePullPointRequest Members
XdsObjects.Dsub Namespace


XdsCreatePullPointRequest Class Members

XdsCreatePullPointRequest Class Members

XdsObjects.Dsub Namespace : XdsCreatePullPointRequest Class

The following tables list the members exposed by XdsCreatePullPointRequest.

Public Constructors
 | Name | Description
Public Constructor | XdsCreatePullPointRequest Constructor | Public construator
Top
See Also

Reference

XdsCreatePullPointRequest Class
XdsObjects.Dsub Namespace


XdsCreatePullPointRequest Constructor

XdsCreatePullPointRequest Constructor

XdsObjects.Dsub Namespace > XdsCreatePullPointRequest Class : XdsCreatePullPointRequest Constructor
Public construator
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsCreatePullPointRequest()
public XdsCreatePullPointRequest()
public:
XdsCreatePullPointRequest();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsCreatePullPointRequest Class
XdsCreatePullPointRequest Members


XdsCreatePullPointResponse Class

XdsCreatePullPointResponse Class
Members

XdsObjects.Dsub Namespace : XdsCreatePullPointResponse Class
Object represents DSUB Create PullPoint response
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsCreatePullPointResponse
   Inherits XdsObjects.XdsRegistryResponse
Dim instance As XdsCreatePullPointResponse
public class XdsCreatePullPointResponse : XdsObjects.XdsRegistryResponse
public ref class XdsCreatePullPointResponse : public XdsObjects.XdsRegistryResponse
Inheritance Hierarchy

System.Object
XdsObjects.XdsRegistryResponse
XdsObjects.Dsub.XdsCreatePullPointResponse

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsCreatePullPointResponse Members
XdsObjects.Dsub Namespace


XdsCreatePullPointResponse Class Members

XdsCreatePullPointResponse Class Members
Properties Methods

XdsObjects.Dsub Namespace : XdsCreatePullPointResponse Class

The following tables list the members exposed by XdsCreatePullPointResponse.

Public Constructors
 | Name | Description
Public Constructor | XdsCreatePullPointResponse Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Address | Address of the pullpoint
Public Property | Errors | The errors in this response (Inherited from XdsObjects.XdsRegistryResponse)
Public Property | Status | The status send or received in this response. (Inherited from XdsObjects.XdsRegistryResponse)
Top
Public Methods
 | Name | Description
Public Method | AddError | Overloaded. Add a new XdsObjects.XdsError to the Errors collection, given the XdsObjects.Enums.XdsErrorCode, plus Location and CodeContext (Inherited from XdsObjects.XdsRegistryResponse)
Public Method | ContainsErrors | Indicates whether the response contains any error codes (Inherited from XdsObjects.XdsRegistryResponse)
Top
See Also

Reference

XdsCreatePullPointResponse Class
XdsObjects.Dsub Namespace


XdsCreatePullPointResponse Constructor

XdsCreatePullPointResponse Constructor

XdsObjects.Dsub Namespace > XdsCreatePullPointResponse Class : XdsCreatePullPointResponse Constructor
Overload List
Overload | Description
XdsCreatePullPointResponse Constructor() | Public Constructor
XdsCreatePullPointResponse Constructor(Exception,XdsErrorCode) | Public Constructor
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsCreatePullPointResponse Class
XdsCreatePullPointResponse Members


XdsCreatePullPointResponse Constructor()

XdsCreatePullPointResponse Constructor()

XdsObjects.Dsub Namespace > XdsCreatePullPointResponse Class > XdsCreatePullPointResponse Constructor : XdsCreatePullPointResponse Constructor()
Public Constructor
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsCreatePullPointResponse()
public XdsCreatePullPointResponse()
public:
XdsCreatePullPointResponse();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsCreatePullPointResponse Class
XdsCreatePullPointResponse Members
Overload List


XdsCreatePullPointResponse Constructor(Exception,XdsErrorCode)

XdsCreatePullPointResponse Constructor(Exception,XdsErrorCode)

XdsObjects.Dsub Namespace > XdsCreatePullPointResponse Class > XdsCreatePullPointResponse Constructor : XdsCreatePullPointResponse Constructor(Exception,XdsErrorCode)
Exception
XdsErrorCode
Public Constructor
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal e As Exception, _
   ByVal ErrorCode As XdsErrorCode _
)
Dim e As Exception
Dim ErrorCode As XdsErrorCode

Dim instance As New XdsCreatePullPointResponse(e, ErrorCode)
public XdsCreatePullPointResponse(
   Exception e,
   XdsErrorCode ErrorCode
)
public:
XdsCreatePullPointResponse(
   Exception^ e,
   XdsErrorCode ErrorCode
)

Parameters

e
Exception
ErrorCode
XdsErrorCode
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsCreatePullPointResponse Class
XdsCreatePullPointResponse Members
Overload List


XdsCreatePullPointResponse Class Properties

XdsCreatePullPointResponse Class Properties

XdsObjects.Dsub Namespace : XdsCreatePullPointResponse Class

For a list of all members of this type, see XdsCreatePullPointResponse members.

Public Properties
 | Name | Description
Public Property | Address | Address of the pullpoint
Public Property | Errors | The errors in this response (Inherited from XdsObjects.XdsRegistryResponse)
Public Property | Status | The status send or received in this response. (Inherited from XdsObjects.XdsRegistryResponse)
Top
See Also

Reference

XdsCreatePullPointResponse Class
XdsObjects.Dsub Namespace


Address Property (XdsCreatePullPointResponse)

Address Property (XdsCreatePullPointResponse)

XdsObjects.Dsub Namespace > XdsCreatePullPointResponse Class : Address Property
Address of the pullpoint
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Address As String
Dim instance As XdsCreatePullPointResponse
Dim value As String

instance.Address = value

value = instance.Address
public string Address {get; set;}
public:
property String^ Address {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsCreatePullPointResponse Class
XdsCreatePullPointResponse Members


XdsDestroyPullPointRequest Class

XdsDestroyPullPointRequest Class
Members

XdsObjects.Dsub Namespace : XdsDestroyPullPointRequest Class
Object which represents a DSUB Destroy Pull Point Request
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsDestroyPullPointRequest
Dim instance As XdsDestroyPullPointRequest
public class XdsDestroyPullPointRequest
public ref class XdsDestroyPullPointRequest
Inheritance Hierarchy

System.Object
XdsObjects.Dsub.XdsDestroyPullPointRequest

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDestroyPullPointRequest Members
XdsObjects.Dsub Namespace


XdsDestroyPullPointRequest Class Members

XdsDestroyPullPointRequest Class Members

XdsObjects.Dsub Namespace : XdsDestroyPullPointRequest Class

The following tables list the members exposed by XdsDestroyPullPointRequest.

Public Constructors
 | Name | Description
Public Constructor | XdsDestroyPullPointRequest Constructor |
Top
See Also

Reference

XdsDestroyPullPointRequest Class
XdsObjects.Dsub Namespace


XdsDestroyPullPointRequest Constructor

XdsDestroyPullPointRequest Constructor

XdsObjects.Dsub Namespace > XdsDestroyPullPointRequest Class : XdsDestroyPullPointRequest Constructor
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsDestroyPullPointRequest()
public XdsDestroyPullPointRequest()
public:
XdsDestroyPullPointRequest();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDestroyPullPointRequest Class
XdsDestroyPullPointRequest Members


XdsDestroyPullPointResponse Class

XdsDestroyPullPointResponse Class
Members

XdsObjects.Dsub Namespace : XdsDestroyPullPointResponse Class
Object which represents a DSUB Destroy Pull Point Response
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsDestroyPullPointResponse
Dim instance As XdsDestroyPullPointResponse
public class XdsDestroyPullPointResponse
public ref class XdsDestroyPullPointResponse
Inheritance Hierarchy

System.Object
XdsObjects.Dsub.XdsDestroyPullPointResponse

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDestroyPullPointResponse Members
XdsObjects.Dsub Namespace


XdsDestroyPullPointResponse Class Members

XdsDestroyPullPointResponse Class Members

XdsObjects.Dsub Namespace : XdsDestroyPullPointResponse Class

The following tables list the members exposed by XdsDestroyPullPointResponse.

Public Constructors
 | Name | Description
Public Constructor | XdsDestroyPullPointResponse Constructor |
Top
See Also

Reference

XdsDestroyPullPointResponse Class
XdsObjects.Dsub Namespace


XdsDestroyPullPointResponse Constructor

XdsDestroyPullPointResponse Constructor

XdsObjects.Dsub Namespace > XdsDestroyPullPointResponse Class : XdsDestroyPullPointResponse Constructor
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsDestroyPullPointResponse()
public XdsDestroyPullPointResponse()
public:
XdsDestroyPullPointResponse();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsDestroyPullPointResponse Class
XdsDestroyPullPointResponse Members


XdsNotifyRequest Class

XdsNotifyRequest Class
Members

XdsObjects.Dsub Namespace : XdsNotifyRequest Class
Object represents a XDS DSUB notification request
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsNotifyRequest
Dim instance As XdsNotifyRequest
public class XdsNotifyRequest
public ref class XdsNotifyRequest
Inheritance Hierarchy

System.Object
XdsObjects.Dsub.XdsNotifyRequest

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsNotifyRequest Members
XdsObjects.Dsub Namespace


XdsNotifyRequest Class Members

XdsNotifyRequest Class Members
Properties

XdsObjects.Dsub Namespace : XdsNotifyRequest Class

The following tables list the members exposed by XdsNotifyRequest.

Public Constructors
 | Name | Description
Public Constructor | XdsNotifyRequest Constructor | Public constructor
Top
Public Properties
 | Name | Description
Public Property | Address | The DSUB notification broker server's address
Public Property | Message | The DSUB notify message
Public Property | ProducerReference | Address of the notification producer
Public Property | SubscriptionId | DSUB Subscription ID
Public Property | Topic | A set of filter expressions
Top
See Also

Reference

XdsNotifyRequest Class
XdsObjects.Dsub Namespace


XdsNotifyRequest Constructor

XdsNotifyRequest Constructor

XdsObjects.Dsub Namespace > XdsNotifyRequest Class : XdsNotifyRequest Constructor
Public constructor
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsNotifyRequest()
public XdsNotifyRequest()
public:
XdsNotifyRequest();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsNotifyRequest Class
XdsNotifyRequest Members


XdsNotifyRequest Class Properties

XdsNotifyRequest Class Properties

XdsObjects.Dsub Namespace : XdsNotifyRequest Class

For a list of all members of this type, see XdsNotifyRequest members.

Public Properties
 | Name | Description
Public Property | Address | The DSUB notification broker server's address
Public Property | Message | The DSUB notify message
Public Property | ProducerReference | Address of the notification producer
Public Property | SubscriptionId | DSUB Subscription ID
Public Property | Topic | A set of filter expressions
Top
See Also

Reference

XdsNotifyRequest Class
XdsObjects.Dsub Namespace


Address Property (XdsNotifyRequest)

Address Property (XdsNotifyRequest)

XdsObjects.Dsub Namespace > XdsNotifyRequest Class : Address Property
The DSUB notification broker server's address
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Address As String
Dim instance As XdsNotifyRequest
Dim value As String

instance.Address = value

value = instance.Address
public string Address {get; set;}
public:
property String^ Address {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsNotifyRequest Class
XdsNotifyRequest Members


Message Property (XdsNotifyRequest)

Message Property (XdsNotifyRequest)

XdsObjects.Dsub Namespace > XdsNotifyRequest Class : Message Property
The DSUB notify message
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Message As NotificationMessage
Dim instance As XdsNotifyRequest
Dim value As NotificationMessage

instance.Message = value

value = instance.Message
public NotificationMessage Message {get; set;}
public:
property NotificationMessage^ Message {
   NotificationMessage^ get();
   void set (    NotificationMessage^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsNotifyRequest Class
XdsNotifyRequest Members


ProducerReference Property

ProducerReference Property

XdsObjects.Dsub Namespace > XdsNotifyRequest Class : ProducerReference Property
Address of the notification producer
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ProducerReference As String
Dim instance As XdsNotifyRequest
Dim value As String

instance.ProducerReference = value

value = instance.ProducerReference
public string ProducerReference {get; set;}
public:
property String^ ProducerReference {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsNotifyRequest Class
XdsNotifyRequest Members


SubscriptionId Property (XdsNotifyRequest)

SubscriptionId Property (XdsNotifyRequest)

XdsObjects.Dsub Namespace > XdsNotifyRequest Class : SubscriptionId Property
DSUB Subscription ID
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property SubscriptionId As String
Dim instance As XdsNotifyRequest
Dim value As String

instance.SubscriptionId = value

value = instance.SubscriptionId
public string SubscriptionId {get; set;}
public:
property String^ SubscriptionId {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsNotifyRequest Class
XdsNotifyRequest Members


Topic Property

Topic Property

XdsObjects.Dsub Namespace > XdsNotifyRequest Class : Topic Property
A set of filter expressions
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Topic As QueryType
Dim instance As XdsNotifyRequest
Dim value As QueryType

instance.Topic = value

value = instance.Topic
public QueryType Topic {get; set;}
public:
property QueryType Topic {
   QueryType get();
   void set (    QueryType value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsNotifyRequest Class
XdsNotifyRequest Members


XdsSubscriptionRequest Class

XdsSubscriptionRequest Class
Members

XdsObjects.Dsub Namespace : XdsSubscriptionRequest Class
Object represents DSUB Subscribe Request
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsSubscriptionRequest
Dim instance As XdsSubscriptionRequest
public class XdsSubscriptionRequest
public ref class XdsSubscriptionRequest
Inheritance Hierarchy

System.Object
XdsObjects.Dsub.XdsSubscriptionRequest

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubscriptionRequest Members
XdsObjects.Dsub Namespace


XdsSubscriptionRequest Class Members

XdsSubscriptionRequest Class Members
Properties

XdsObjects.Dsub Namespace : XdsSubscriptionRequest Class

The following tables list the members exposed by XdsSubscriptionRequest.

Public Constructors
 | Name | Description
Public Constructor | XdsSubscriptionRequest Constructor | Public Constructor
Top
Public Properties
 | Name | Description
Public Property | ConsumerReferenceAddress | Web services endpoint where notifications must be sent.
Public Property | Id | GUID ID of the object for working with Entity Framework
Public Property | InitialTerminationTime | Indicates when the subsription should be terminated
Public Property | Query | Filters to narrow down for which topics the notification should be sent
Public Property | TopicDialect | WS-Topics dialect element for which a notification should be sent. Type is set from P:XdsObjects.Dsub.XdsSubscriptionRequest.Query QueryType
Top
See Also

Reference

XdsSubscriptionRequest Class
XdsObjects.Dsub Namespace


XdsSubscriptionRequest Constructor

XdsSubscriptionRequest Constructor

XdsObjects.Dsub Namespace > XdsSubscriptionRequest Class : XdsSubscriptionRequest Constructor
Public Constructor
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsSubscriptionRequest()
public XdsSubscriptionRequest()
public:
XdsSubscriptionRequest();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubscriptionRequest Class
XdsSubscriptionRequest Members


XdsSubscriptionRequest Class Properties

XdsSubscriptionRequest Class Properties

XdsObjects.Dsub Namespace : XdsSubscriptionRequest Class

For a list of all members of this type, see XdsSubscriptionRequest members.

Public Properties
 | Name | Description
Public Property | ConsumerReferenceAddress | Web services endpoint where notifications must be sent.
Public Property | Id | GUID ID of the object for working with Entity Framework
Public Property | InitialTerminationTime | Indicates when the subsription should be terminated
Public Property | Query | Filters to narrow down for which topics the notification should be sent
Public Property | TopicDialect | WS-Topics dialect element for which a notification should be sent. Type is set from P:XdsObjects.Dsub.XdsSubscriptionRequest.Query QueryType
Top
See Also

Reference

XdsSubscriptionRequest Class
XdsObjects.Dsub Namespace


ConsumerReferenceAddress Property

ConsumerReferenceAddress Property

XdsObjects.Dsub Namespace > XdsSubscriptionRequest Class : ConsumerReferenceAddress Property
Web services endpoint where notifications must be sent.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property ConsumerReferenceAddress As String
Dim instance As XdsSubscriptionRequest
Dim value As String

instance.ConsumerReferenceAddress = value

value = instance.ConsumerReferenceAddress
public string ConsumerReferenceAddress {get; set;}
public:
property String^ ConsumerReferenceAddress {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubscriptionRequest Class
XdsSubscriptionRequest Members


Id Property (XdsSubscriptionRequest)

Id Property (XdsSubscriptionRequest)

XdsObjects.Dsub Namespace > XdsSubscriptionRequest Class : Id Property
GUID ID of the object for working with Entity Framework
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Id As Guid
Dim instance As XdsSubscriptionRequest
Dim value As Guid

instance.Id = value

value = instance.Id
public Guid Id {get; set;}
public:
property Guid Id {
   Guid get();
   void set (    Guid value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubscriptionRequest Class
XdsSubscriptionRequest Members


InitialTerminationTime Property

InitialTerminationTime Property

XdsObjects.Dsub Namespace > XdsSubscriptionRequest Class : InitialTerminationTime Property
Indicates when the subsription should be terminated
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property InitialTerminationTime As Date
Dim instance As XdsSubscriptionRequest
Dim value As Date

instance.InitialTerminationTime = value

value = instance.InitialTerminationTime
public DateTime InitialTerminationTime {get; set;}
public:
property DateTime InitialTerminationTime {
   DateTime get();
   void set (    DateTime value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubscriptionRequest Class
XdsSubscriptionRequest Members


Query Property

Query Property

XdsObjects.Dsub Namespace > XdsSubscriptionRequest Class : Query Property
Filters to narrow down for which topics the notification should be sent
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Query As XdsQueryRequest
Dim instance As XdsSubscriptionRequest
Dim value As XdsQueryRequest

instance.Query = value

value = instance.Query
public XdsQueryRequest Query {get; set;}
public:
property XdsQueryRequest^ Query {
   XdsQueryRequest^ get();
   void set (    XdsQueryRequest^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubscriptionRequest Class
XdsSubscriptionRequest Members


TopicDialect Property

TopicDialect Property

XdsObjects.Dsub Namespace > XdsSubscriptionRequest Class : TopicDialect Property
WS-Topics dialect element for which a notification should be sent. Type is set from P:XdsObjects.Dsub.XdsSubscriptionRequest.Query QueryType
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property TopicDialect As String
Dim instance As XdsSubscriptionRequest
Dim value As String

instance.TopicDialect = value

value = instance.TopicDialect
public string TopicDialect {get; set;}
public:
property String^ TopicDialect {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubscriptionRequest Class
XdsSubscriptionRequest Members


XdsSubscriptionResponse Class

XdsSubscriptionResponse Class
Members

XdsObjects.Dsub Namespace : XdsSubscriptionResponse Class
Object represents the XDS DSUB Subscribe response
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsSubscriptionResponse
   Inherits XdsObjects.XdsRegistryResponse
Dim instance As XdsSubscriptionResponse
public class XdsSubscriptionResponse : XdsObjects.XdsRegistryResponse
public ref class XdsSubscriptionResponse : public XdsObjects.XdsRegistryResponse
Inheritance Hierarchy

System.Object
XdsObjects.XdsRegistryResponse
XdsObjects.Dsub.XdsSubscriptionResponse

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubscriptionResponse Members
XdsObjects.Dsub Namespace


XdsSubscriptionResponse Class Members

XdsSubscriptionResponse Class Members
Properties Methods

XdsObjects.Dsub Namespace : XdsSubscriptionResponse Class

The following tables list the members exposed by XdsSubscriptionResponse.

Public Constructors
 | Name | Description
Public Constructor | XdsSubscriptionResponse Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Address | Subscription reference address assigned by the Document Metadata Notification Broker of the current subscriptions
Public Property | Errors | The errors in this response (Inherited from XdsObjects.XdsRegistryResponse)
Public Property | Status | The status send or received in this response. (Inherited from XdsObjects.XdsRegistryResponse)
Public Property | SubscriptionId | The unique subcription ID assigned by the Document Metadata Notification Broker
Public Property | TerminationTime | When the subcription will be terminated
Top
Public Methods
 | Name | Description
Public Method | AddError | Overloaded. Add a new XdsObjects.XdsError to the Errors collection, given the XdsObjects.Enums.XdsErrorCode, plus Location and CodeContext (Inherited from XdsObjects.XdsRegistryResponse)
Public Method | ContainsErrors | Indicates whether the response contains any error codes (Inherited from XdsObjects.XdsRegistryResponse)
Top
See Also

Reference

XdsSubscriptionResponse Class
XdsObjects.Dsub Namespace


XdsSubscriptionResponse Constructor

XdsSubscriptionResponse Constructor

XdsObjects.Dsub Namespace > XdsSubscriptionResponse Class : XdsSubscriptionResponse Constructor
Overload List
Overload | Description
XdsSubscriptionResponse Constructor() | Public constructor
XdsSubscriptionResponse Constructor(Exception,XdsErrorCode) | Public constructor
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubscriptionResponse Class
XdsSubscriptionResponse Members


XdsSubscriptionResponse Constructor()

XdsSubscriptionResponse Constructor()

XdsObjects.Dsub Namespace > XdsSubscriptionResponse Class > XdsSubscriptionResponse Constructor : XdsSubscriptionResponse Constructor()
Public constructor
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsSubscriptionResponse()
public XdsSubscriptionResponse()
public:
XdsSubscriptionResponse();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubscriptionResponse Class
XdsSubscriptionResponse Members
Overload List


XdsSubscriptionResponse Constructor(Exception,XdsErrorCode)

XdsSubscriptionResponse Constructor(Exception,XdsErrorCode)

XdsObjects.Dsub Namespace > XdsSubscriptionResponse Class > XdsSubscriptionResponse Constructor : XdsSubscriptionResponse Constructor(Exception,XdsErrorCode)
The Exception
XdsErrorCode
Public constructor
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal e As Exception, _
   ByVal ErrorCode As XdsErrorCode _
)
Dim e As Exception
Dim ErrorCode As XdsErrorCode

Dim instance As New XdsSubscriptionResponse(e, ErrorCode)
public XdsSubscriptionResponse(
   Exception e,
   XdsErrorCode ErrorCode
)
public:
XdsSubscriptionResponse(
   Exception^ e,
   XdsErrorCode ErrorCode
)

Parameters

e
The Exception
ErrorCode
XdsErrorCode
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubscriptionResponse Class
XdsSubscriptionResponse Members
Overload List


XdsSubscriptionResponse Class Properties

XdsSubscriptionResponse Class Properties

XdsObjects.Dsub Namespace : XdsSubscriptionResponse Class

For a list of all members of this type, see XdsSubscriptionResponse members.

Public Properties
 | Name | Description
Public Property | Address | Subscription reference address assigned by the Document Metadata Notification Broker of the current subscriptions
Public Property | Errors | The errors in this response (Inherited from XdsObjects.XdsRegistryResponse)
Public Property | Status | The status send or received in this response. (Inherited from XdsObjects.XdsRegistryResponse)
Public Property | SubscriptionId | The unique subcription ID assigned by the Document Metadata Notification Broker
Public Property | TerminationTime | When the subcription will be terminated
Top
See Also

Reference

XdsSubscriptionResponse Class
XdsObjects.Dsub Namespace


Address Property (XdsSubscriptionResponse)

Address Property (XdsSubscriptionResponse)

XdsObjects.Dsub Namespace > XdsSubscriptionResponse Class : Address Property
Subscription reference address assigned by the Document Metadata Notification Broker of the current subscriptions
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property Address As String
Dim instance As XdsSubscriptionResponse
Dim value As String

instance.Address = value

value = instance.Address
public string Address {get; set;}
public:
property String^ Address {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubscriptionResponse Class
XdsSubscriptionResponse Members


SubscriptionId Property (XdsSubscriptionResponse)

SubscriptionId Property (XdsSubscriptionResponse)

XdsObjects.Dsub Namespace > XdsSubscriptionResponse Class : SubscriptionId Property
The unique subcription ID assigned by the Document Metadata Notification Broker
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property SubscriptionId As String
Dim instance As XdsSubscriptionResponse
Dim value As String

instance.SubscriptionId = value

value = instance.SubscriptionId
public string SubscriptionId {get; set;}
public:
property String^ SubscriptionId {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubscriptionResponse Class
XdsSubscriptionResponse Members


TerminationTime Property

TerminationTime Property

XdsObjects.Dsub Namespace > XdsSubscriptionResponse Class : TerminationTime Property
When the subcription will be terminated
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property TerminationTime As Date
Dim instance As XdsSubscriptionResponse
Dim value As Date

instance.TerminationTime = value

value = instance.TerminationTime
public DateTime TerminationTime {get; set;}
public:
property DateTime TerminationTime {
   DateTime get();
   void set (    DateTime value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubscriptionResponse Class
XdsSubscriptionResponse Members


XdsUnsubscriptionRequest Class

XdsUnsubscriptionRequest Class
Members

XdsObjects.Dsub Namespace : XdsUnsubscriptionRequest Class
Object represents DSUB Unsubscribe Request
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsUnsubscriptionRequest
Dim instance As XdsUnsubscriptionRequest
public class XdsUnsubscriptionRequest
public ref class XdsUnsubscriptionRequest
Inheritance Hierarchy

System.Object
XdsObjects.Dsub.XdsUnsubscriptionRequest

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsUnsubscriptionRequest Members
XdsObjects.Dsub Namespace


XdsUnsubscriptionRequest Class Members

XdsUnsubscriptionRequest Class Members
Properties

XdsObjects.Dsub Namespace : XdsUnsubscriptionRequest Class

The following tables list the members exposed by XdsUnsubscriptionRequest.

Public Constructors
 | Name | Description
Public Constructor | XdsUnsubscriptionRequest Constructor |
Top
Public Properties
 | Name | Description
Public Property | SubscriptionId | Id of the Subscription to terminate
Top
See Also

Reference

XdsUnsubscriptionRequest Class
XdsObjects.Dsub Namespace


XdsUnsubscriptionRequest Constructor

XdsUnsubscriptionRequest Constructor

XdsObjects.Dsub Namespace > XdsUnsubscriptionRequest Class : XdsUnsubscriptionRequest Constructor
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsUnsubscriptionRequest()
public XdsUnsubscriptionRequest()
public:
XdsUnsubscriptionRequest();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsUnsubscriptionRequest Class
XdsUnsubscriptionRequest Members


XdsUnsubscriptionRequest Class Properties

XdsUnsubscriptionRequest Class Properties

XdsObjects.Dsub Namespace : XdsUnsubscriptionRequest Class

For a list of all members of this type, see XdsUnsubscriptionRequest members.

Public Properties
 | Name | Description
Public Property | SubscriptionId | Id of the Subscription to terminate
Top
See Also

Reference

XdsUnsubscriptionRequest Class
XdsObjects.Dsub Namespace


SubscriptionId Property (XdsUnsubscriptionRequest)

SubscriptionId Property (XdsUnsubscriptionRequest)

XdsObjects.Dsub Namespace > XdsUnsubscriptionRequest Class : SubscriptionId Property
Id of the Subscription to terminate
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Property SubscriptionId As Uri
Dim instance As XdsUnsubscriptionRequest
Dim value As Uri

instance.SubscriptionId = value

value = instance.SubscriptionId
public Uri SubscriptionId {get; set;}
public:
property Uri^ SubscriptionId {
   Uri^ get();
   void set (    Uri^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsUnsubscriptionRequest Class
XdsUnsubscriptionRequest Members


XdsUnsubscriptionResponse Class

XdsUnsubscriptionResponse Class
Members

XdsObjects.Dsub Namespace : XdsUnsubscriptionResponse Class
Object represents the XDS DSUB Unsubscribe response
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class XdsUnsubscriptionResponse
   Inherits XdsObjects.XdsRegistryResponse
Dim instance As XdsUnsubscriptionResponse
public class XdsUnsubscriptionResponse : XdsObjects.XdsRegistryResponse
public ref class XdsUnsubscriptionResponse : public XdsObjects.XdsRegistryResponse
Inheritance Hierarchy

System.Object
XdsObjects.XdsRegistryResponse
XdsObjects.Dsub.XdsUnsubscriptionResponse

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsUnsubscriptionResponse Members
XdsObjects.Dsub Namespace


XdsUnsubscriptionResponse Class Members

XdsUnsubscriptionResponse Class Members
Properties Methods

XdsObjects.Dsub Namespace : XdsUnsubscriptionResponse Class

The following tables list the members exposed by XdsUnsubscriptionResponse.

Public Constructors
 | Name | Description
Public Constructor | XdsUnsubscriptionResponse Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Errors | The errors in this response (Inherited from XdsObjects.XdsRegistryResponse)
Public Property | Status | The status send or received in this response. (Inherited from XdsObjects.XdsRegistryResponse)
Top
Public Methods
 | Name | Description
Public Method | AddError | Overloaded. Add a new XdsObjects.XdsError to the Errors collection, given the XdsObjects.Enums.XdsErrorCode, plus Location and CodeContext (Inherited from XdsObjects.XdsRegistryResponse)
Public Method | ContainsErrors | Indicates whether the response contains any error codes (Inherited from XdsObjects.XdsRegistryResponse)
Top
See Also

Reference

XdsUnsubscriptionResponse Class
XdsObjects.Dsub Namespace


XdsUnsubscriptionResponse Constructor

XdsUnsubscriptionResponse Constructor

XdsObjects.Dsub Namespace > XdsUnsubscriptionResponse Class : XdsUnsubscriptionResponse Constructor
Overload List
Overload | Description
XdsUnsubscriptionResponse Constructor() | Public constructor
XdsUnsubscriptionResponse Constructor(Exception,XdsErrorCode) | Public constructor
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsUnsubscriptionResponse Class
XdsUnsubscriptionResponse Members


XdsUnsubscriptionResponse Constructor()

XdsUnsubscriptionResponse Constructor()

XdsObjects.Dsub Namespace > XdsUnsubscriptionResponse Class > XdsUnsubscriptionResponse Constructor : XdsUnsubscriptionResponse Constructor()
Public constructor
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New XdsUnsubscriptionResponse()
public XdsUnsubscriptionResponse()
public:
XdsUnsubscriptionResponse();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsUnsubscriptionResponse Class
XdsUnsubscriptionResponse Members
Overload List


XdsUnsubscriptionResponse Constructor(Exception,XdsErrorCode)

XdsUnsubscriptionResponse Constructor(Exception,XdsErrorCode)

XdsObjects.Dsub Namespace > XdsUnsubscriptionResponse Class > XdsUnsubscriptionResponse Constructor : XdsUnsubscriptionResponse Constructor(Exception,XdsErrorCode)
The Exception
XdsErrorCode
Public constructor
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New( _
   ByVal e As Exception, _
   ByVal ErrorCode As XdsErrorCode _
)
Dim e As Exception
Dim ErrorCode As XdsErrorCode

Dim instance As New XdsUnsubscriptionResponse(e, ErrorCode)
public XdsUnsubscriptionResponse(
   Exception e,
   XdsErrorCode ErrorCode
)
public:
XdsUnsubscriptionResponse(
   Exception^ e,
   XdsErrorCode ErrorCode
)

Parameters

e
The Exception
ErrorCode
XdsErrorCode
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsUnsubscriptionResponse Class
XdsUnsubscriptionResponse Members
Overload List


XdsObjects.Enums Namespace

XdsObjects.Enums Namespace
Inheritance Hierarchy

This namespace holds all the XdsObjects enumerations

Enumerations
 | Enumeration | Description
Enumeration | AssociationType | Relationships between XdsDocuments, and between XdsDocuments and XdsFolders
Enumeration | AuditProtocol | Selector for the type of Auditing used
Enumeration | AuditSourceTypeCode | Audit Source Type Codes as defined by RFC 3881
Enumeration | AvailabilityStatusCode | Document status codes for use with queries
Enumeration | ErrorSeverityType | The severity of the error returned
Enumeration | LicensedFunctions | A bitmask representing the functions that a particular license allows to be used by XdsObjects.
Enumeration | LicenseTypes | Indicates the basic type of XdsObjects license
Enumeration | LogLevel | Available logging Levels as used by XdsObjects.XdsGlobal.LogToFile
Enumeration | QueryReturnType | Controls the type of data requested in a StoredQuery or CrossGatewayQuery
Enumeration | QueryType | Identifiers for the 13 pre-defined stored queries in XDS
Enumeration | RegistryResponseStatus | Allowed values for XdsObjects.XdsRegistryResponse.Status
Enumeration | XdsErrorCode | Error codes as defined by the IHE technical framework
Enumeration | XdsIRetrievalMethod | The different mechanisms which can be used to retrieve a DICOM image for display
See Also

Reference

XdsObjects.6.40 Assembly


AssociationType Enumeration

AssociationType Enumeration

XdsObjects.Enums Namespace : AssociationType Enumeration
Relationships between XdsDocuments, and between XdsDocuments and XdsFolders
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Enum AssociationType
   Inherits System.Enum
Dim instance As AssociationType
public enum AssociationType : System.Enum
public enum class AssociationType : public System.Enum
Members
Member | Description
Append | Indicates that a document appends content to another
HasMember | This is a generic relationship, used to define the relationship between documents and folders
Replace | Indicates that a document replaces another
Signs | Indicates that a document provides a digital signature for another
Transform | Indicates that a document transforms another (leaving the original, otherwise TransformAndReplace would be more appropriate
TransformAndReplace | Indicates that a document both transforms and replaces another
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
XdsObjects.Enums.AssociationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjects.Enums Namespace


AuditProtocol Enumeration

AuditProtocol Enumeration

XdsObjects.Enums Namespace : AuditProtocol Enumeration
Selector for the type of Auditing used
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
<FlagsAttribute()>
Public Enum AuditProtocol
   Inherits System.Enum
Dim instance As AuditProtocol
[Flags()]
public enum AuditProtocol : System.Enum
[Flags()]
public enum class AuditProtocol : public System.Enum
Members
Member | Description
Bsd | Old style BSD syslog (now officialy deprecated, but supported for legacy use)
Rfc5425Tls | Using properly secured TLS as specified in RFC 5425
Rfc5426Udp | Modern RFC 5424 syntax, but sent over UDP as specified in RFC 5424
Tcp | Unofficial protocol, equivalent to Rfc5425Tls, but without TLS. Useful for testing
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
XdsObjects.Enums.AuditProtocol

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjects.Enums Namespace


AuditSourceTypeCode Enumeration

AuditSourceTypeCode Enumeration

XdsObjects.Enums Namespace : AuditSourceTypeCode Enumeration
Audit Source Type Codes as defined by RFC 3881
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Enum AuditSourceTypeCode
   Inherits System.Enum
Dim instance As AuditSourceTypeCode
public enum AuditSourceTypeCode : System.Enum
public enum class AuditSourceTypeCode : public System.Enum
Members
Member | Description
Application_Server_Process_Tier | Application Server Process Tier
Data_Acquisition_Device_Or_Instrument | Data Acquisition Device Or Instrument
Database_Server_Process_Tier | Database Server Process Tier
End_User_Interface | End User Interface
External_Source_Or_Unknown_Type | External Source Or Unknown Type
ISO_Level_1To3_Network_Component | ISO Level 1To3 Network Component
ISO_Level_4To6_Operating_Software | ISO Level 4To6 Operating Software
Security_Server | Security Server
Undefined | Special internal code meaning that the code is undefined, and will nto be included in audit messages
Web_Server_Process_Tier | Web Server Process Tier
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
XdsObjects.Enums.AuditSourceTypeCode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjects.Enums Namespace


AvailabilityStatusCode Enumeration

AvailabilityStatusCode Enumeration

XdsObjects.Enums Namespace : AvailabilityStatusCode Enumeration
Document status codes for use with queries
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
<FlagsAttribute()>
Public Enum AvailabilityStatusCode
   Inherits System.Enum
Dim instance As AvailabilityStatusCode
[Flags()]
public enum AvailabilityStatusCode : System.Enum
[Flags()]
public enum class AvailabilityStatusCode : public System.Enum
Members
Member | Description
All | All - both approved and deprecated documents
Approved | Approved - this is the normal status for "available" documents
Deprecated | Deprectaed - documents which should not be used for normal clinical purposed
None | Dummy value indicating no status set
Submitted | Document is Submitted
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
XdsObjects.Enums.AvailabilityStatusCode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjects.Enums Namespace


ErrorSeverityType Enumeration

ErrorSeverityType Enumeration

XdsObjects.Enums Namespace : ErrorSeverityType Enumeration
The severity of the error returned
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Enum ErrorSeverityType
   Inherits System.Enum
Dim instance As ErrorSeverityType
public enum ErrorSeverityType : System.Enum
public enum class ErrorSeverityType : public System.Enum
Members
Member | Description
Error | Error
Unknown | Unknown - means that the value has not been set, or that a faulty reponse was received
Warning | Warning only
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
XdsObjects.Enums.ErrorSeverityType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjects.Enums Namespace


LicensedFunctions Enumeration

LicensedFunctions Enumeration

XdsObjects.Enums Namespace : LicensedFunctions Enumeration
A bitmask representing the functions that a particular license allows to be used by XdsObjects.
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
<FlagsAttribute()>
Public Enum LicensedFunctions
   Inherits System.Enum
Dim instance As LicensedFunctions
[Flags()]
public enum LicensedFunctions : System.Enum
[Flags()]
public enum class LicensedFunctions : public System.Enum
Members
Member | Description
Consumer | Allows use as a document consumer
Gateway | Allows use as an XCA gateway
ImageConsumer | Allows use as an Imaging Consumer
ImageSource | Allows use as an Imaging Source
PixConsumer | Allows use as a PIX consumer
Reader | Allows reading and importing of documents as files (XDM)
Registry | Allows use as a registry
Repository | Allows use as a repository
Source | Allows use as a document source
Viewer | Allows use of the XdsViewer control
Writer | Allows writing and exporting of documents as files (XDM)
XDR | Allows use as an XDR recipient (XDR sender is equivalent to a document source)
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
XdsObjects.Enums.LicensedFunctions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjects.Enums Namespace


LicenseTypes Enumeration

LicenseTypes Enumeration

XdsObjects.Enums Namespace : LicenseTypes Enumeration
Indicates the basic type of XdsObjects license
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Enum LicenseTypes
   Inherits System.Enum
Dim instance As LicenseTypes
public enum LicenseTypes : System.Enum
public enum class LicenseTypes : public System.Enum
Members
Member | Description
Demo | Allows use for demonstrations
Developer | Use for development and testing only
Full | Full commercial license for production use
Trial | Allows use for evaluation only
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
XdsObjects.Enums.LicenseTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjects.Enums Namespace


LogLevel Enumeration

LogLevel Enumeration

XdsObjects.Enums Namespace : LogLevel Enumeration
Available logging Levels as used by LogToFile
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
<FlagsAttribute()>
Public Enum LogLevel
   Inherits System.Enum
Dim instance As LogLevel
[Flags()]
public enum LogLevel : System.Enum
[Flags()]
public enum class LogLevel : public System.Enum
Members
Member | Description
All | All log levels
ContentSummary | Summary of network transactions
Errors | Error messages
FullXmlIn | Full XML incoming data for all network transactions
FullXmlOut | Full XML outgoing data for all network transactions
Information | Informational messages
TlsAllBytes | Full byte levels log for TLS operations. This is not yet implemented
TlsSummary | Summary (certificates etc.) for TLS operations. This is not yet implemented
User | user log messages as generated by XdsObjects.XdsGlobal.Log
Warnings | Warning messages
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
XdsObjects.Enums.LogLevel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjects.Enums Namespace


QueryReturnType Enumeration

QueryReturnType Enumeration

XdsObjects.Enums Namespace : QueryReturnType Enumeration
Controls the type of data requested in a StoredQuery or CrossGatewayQuery
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Enum QueryReturnType
   Inherits System.Enum
Dim instance As QueryReturnType
public enum QueryReturnType : System.Enum
public enum class QueryReturnType : public System.Enum
Members
Member | Description
LeafClass | Populated metadata objects are to be returned. Note that the level of detail depends on the value of XdsObjects.XdsQueryRequest.ReturnComposedObjects
None | Value not yet set, or faulty
ObjectRef | Only Object references are to be returned
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
XdsObjects.Enums.QueryReturnType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjects.Enums Namespace


QueryType Enumeration

QueryType Enumeration

XdsObjects.Enums Namespace : QueryType Enumeration
Identifiers for the 13 pre-defined stored queries in XDS
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Enum QueryType
   Inherits System.Enum
Dim instance As QueryType
public enum QueryType : System.Enum
public enum class QueryType : public System.Enum
Members
Member | Description
FindDocuments | List documents for a specified patient
FindDocumentsByReferenceId | List documents for a specified patient with matching referenceIdList
FindFolders | List Folders for a specified patient
FindSubmissionSets | List Submission Sets for a specified patient
GetAll | Get all registry content for a patient
GetAssociations | Get collection of Associations
GetDocuments | Get a collection of XdsObjects.XdsDocument objects
GetDocumentsAndAssociations | Get a collection of XdsObjects.XdsDocument objects and their associations
GetFolderAndContents | Get a collection of XdsObjects.XdsFolder objects and their associated content
GetFolders | Get a collection of XdsObjects.XdsFolder objects
GetFoldersForDocument | Get a collection of XdsObjects.XdsFolder objects related to a particular document
GetRelatedDocuments | Get a collection of XdsObjects.XdsDocument objects related to a particular document
GetSubmissionSetAndContents | Get a collection of XdsObjects.XdsSubmissionSet objects and their associated content
GetSubmissionSets | Get a collection of XdsObjects.XdsSubmissionSet objects
None | Value not yet set, or faulty
SubscriptionMinimalDocument | A minimal DSUB notification
SubscriptionSubmissionSet | A DSUB SubmissionSet notification
SubsriptionFolder | A DSUB Folder notification
SubsriptionFullDocument | A full DSUB notification
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
XdsObjects.Enums.QueryType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjects.Enums Namespace


RegistryResponseStatus Enumeration

RegistryResponseStatus Enumeration

XdsObjects.Enums Namespace : RegistryResponseStatus Enumeration
Allowed values for Status
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Enum RegistryResponseStatus
   Inherits System.Enum
Dim instance As RegistryResponseStatus
public enum RegistryResponseStatus : System.Enum
public enum class RegistryResponseStatus : public System.Enum
Members
Member | Description
Failure | Operation failed
PartialSuccess | Operation partially succeeded
Success | Operation was successful
Unknown | Unknown - means that the value has not been set, or that a faulty reponse was received
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
XdsObjects.Enums.RegistryResponseStatus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjects.Enums Namespace


XdsErrorCode Enumeration

XdsErrorCode Enumeration

XdsObjects.Enums Namespace : XdsErrorCode Enumeration
Error codes as defined by the IHE technical framework
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Enum XdsErrorCode
   Inherits System.Enum
Dim instance As XdsErrorCode
public enum XdsErrorCode : System.Enum
public enum class XdsErrorCode : public System.Enum
Members
Member | Description
BadErrorCode | BadErrorCode is a placeholder for incorrect codes
GeneralException | This is put into the list for copmatibility with the NIST server, which can sometimes generate this error
XDSDocumentUniqueIdError | Invalid or unknown Document UniqueId
XDSDuplicateUniqueIdInRegistry | Duplicate UniqueId found in the Registry
XDSExtraMetadataNotSaved | Private slot data was present, which has not been saved.
XDSMissingDocument | Document does not exist
XDSMissingDocumentMetadata | Document metadata does not exist
XDSNonIdenticalHash | Has does not match
XDSPatientIdDoesNotMatch | Inconsistent Patient IDs
XDSRegistryBusy | Registry is Busy
XDSRegistryDeprecatedDocumentError | Attempt to perform invalid operation on a document which has a status of Deprecated
XDSRegistryDuplicateUniqueIdInMessage | Duplicate UniqueId found in the Message
XDSRegistryError | Unspecified Registry error
XDSRegistryMetadataError | Error in the Registry Metadata
XDSRegistryNotAvailable | Registry cannot be contacted
XDSRegistryOutOfResources | Registry is out of resources
XDSRepositoryError | Unspecified Repository error
XDSRepositoryMetadataError | Error in the Repository Metadata
XDSSqlError | Internal SQL Error
XDSStoredQueryMissingParam | Missing Query Parameter(s)
XDSStoredQueryParamNumber | Incorrect Number of Query Parameter(s)
XDSTooManyResults | To many results. In many cases this can be avoided by using an ObjectRef rather than a LeafClass query
XDSUnknownCommunity | Unknown HomeCommunityId value
XDSUnknownPatientId | The Patient Id is unknown to the registry
XDSUnknownRepositoryId | Repository Id is unknown
XDSUnknownStoredQuery | Unknown Query Type
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
XdsObjects.Enums.XdsErrorCode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjects.Enums Namespace


XdsIRetrievalMethod Enumeration

XdsIRetrievalMethod Enumeration

XdsObjects.Enums Namespace : XdsIRetrievalMethod Enumeration
The different mechanisms which can be used to retrieve a DICOM image for display
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Enum XdsIRetrievalMethod
   Inherits System.Enum
Dim instance As XdsIRetrievalMethod
public enum XdsIRetrievalMethod : System.Enum
public enum class XdsIRetrievalMethod : public System.Enum
Members
Member | Description
C_Move | Use DICOM C-MOVE
Rad69 | Use the IHE RetrieveImageDocumentSet transaction (RAD-69)
Wado_Dicom | Use WADO, and request a full DICOM image
Wado_Jpg | Use WADO, and request a JPEG image
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
XdsObjects.Enums.XdsIRetrievalMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsObjects.Enums Namespace


XdsObjects.EventArguments Namespace

XdsObjects.EventArguments Namespace
Inheritance Hierarchy
This namespace holds class which act as arguments for events and overrides
Classes
 | Class | Description
Class | ModifyHeadersArgs | Class to hold data to allow modification of SOAP headers
See Also

Reference

XdsObjects.6.40 Assembly


ModifyHeadersArgs Class

ModifyHeadersArgs Class
Members

XdsObjects.EventArguments Namespace : ModifyHeadersArgs Class
Class to hold data to allow modification of SOAP headers
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Class ModifyHeadersArgs
Dim instance As ModifyHeadersArgs
public class ModifyHeadersArgs
public ref class ModifyHeadersArgs
Remarks
This is typically only used when communicating with a non-IHE-rules compliant system, which may require non-standard SOAP headers etc.
Inheritance Hierarchy

System.Object
XdsObjects.EventArguments.ModifyHeadersArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ModifyHeadersArgs Members
XdsObjects.EventArguments Namespace


ModifyHeadersArgs Class Members

ModifyHeadersArgs Class Members
Properties

XdsObjects.EventArguments Namespace : ModifyHeadersArgs Class

The following tables list the members exposed by ModifyHeadersArgs.

Public Constructors
 | Name | Description
Public Constructor | ModifyHeadersArgs Constructor |
Top
Public Properties
 | Name | Description
Public Property | Action | The action being performed
Public Property | Endpoint | The endpoint to which the message is being sent
Public Property | Message | The message being sent
Top
See Also

Reference

ModifyHeadersArgs Class
XdsObjects.EventArguments Namespace


ModifyHeadersArgs Constructor

ModifyHeadersArgs Constructor

XdsObjects.EventArguments Namespace > ModifyHeadersArgs Class : ModifyHeadersArgs Constructor
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public Function New()
Dim instance As New ModifyHeadersArgs()
public ModifyHeadersArgs()
public:
ModifyHeadersArgs();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ModifyHeadersArgs Class
ModifyHeadersArgs Members


ModifyHeadersArgs Class Properties

ModifyHeadersArgs Class Properties

XdsObjects.EventArguments Namespace : ModifyHeadersArgs Class

For a list of all members of this type, see ModifyHeadersArgs members.

Public Properties
 | Name | Description
Public Property | Action | The action being performed
Public Property | Endpoint | The endpoint to which the message is being sent
Public Property | Message | The message being sent
Top
See Also

Reference

ModifyHeadersArgs Class
XdsObjects.EventArguments Namespace


Action Property

Action Property

XdsObjects.EventArguments Namespace > ModifyHeadersArgs Class : Action Property
The action being performed
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property Action As String
Dim instance As ModifyHeadersArgs
Dim value As String

value = instance.Action
public string Action {get;}
public:
property String^ Action {
   String^ get();
}
Remarks
e.g. "ProvideAndregsiterDocumentSet.b"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ModifyHeadersArgs Class
ModifyHeadersArgs Members


Endpoint Property (ModifyHeadersArgs)

Endpoint Property (ModifyHeadersArgs)

XdsObjects.EventArguments Namespace > ModifyHeadersArgs Class : Endpoint Property
The endpoint to which the message is being sent
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property Endpoint As ServiceEndpoint
Dim instance As ModifyHeadersArgs
Dim value As ServiceEndpoint

value = instance.Endpoint
public ServiceEndpoint Endpoint {get;}
public:
property ServiceEndpoint^ Endpoint {
   ServiceEndpoint^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ModifyHeadersArgs Class
ModifyHeadersArgs Members


Message Property (ModifyHeadersArgs)

Message Property (ModifyHeadersArgs)

XdsObjects.EventArguments Namespace > ModifyHeadersArgs Class : Message Property
The message being sent
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Public ReadOnly Property Message As Message
Dim instance As ModifyHeadersArgs
Dim value As Message

value = instance.Message
public Message Message {get;}
public:
property Message^ Message {
   Message^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ModifyHeadersArgs Class
ModifyHeadersArgs Members


Licensing and Activation

Licensing and Activation
General XdsObjects information > Licensing and Activation

XdsOBjects uses and on-line activation scheme for each copy installed, though alternatives are available for bulk usage. Please contact Medical Conneciton if you need license keys.


Use with the Code First Entity Framework

Use with the Code First Entity Framework
General XdsObjects information > Use with the Code First Entity Framework

Version 6.1 of XdsObjects has been designed specifically to allow all the commonly used objects to be persisted to a database directly by using the Code Forst Entity framework. This has required some careful design decisions, as below:

  • All Enum properties have been duplicated to an equivalent integer property -which can be used for getting or setting the property. They have been given the name of the property with "AsInt" appended.
  • Many other properties (including Enums) need to be excluded as they are not compatible with the Code First framework, but in order to give develoeprs the most flexibility (especially if the framework evelves, these have not been specifically excluded from using attributes. This must therefore be done in the client programs as shown in our exmplae registry.


Use With DicomObjects

Use With DicomObjects
General XdsObjects information > Use With DicomObjects

Although XdsObjects is used on its own for most XDS operations, further specific enhancements for use with XDS for Imaging (XDS-I) require the avility to dissect and use DICOM entities.

This may be done either using DicomObjects, for which very simple methods are available, but for those who have other existing toolkits, all functionality is also available without using DicomObjects. If DicomObjects cannot be found when it is actually need and used at runtime, then a "Not Found" exception will be thrown.

Normally, the two packages are licensed separately, but discounted packages are available for combined use.

Please contact sales@medicalconnections.co.uk for further details.


Use of Codes in XDS

Use of Codes in XDS
General XdsObjects information > Use of Codes in XDS

Codes are used a great deal in XDS to categorise objects, and each has 3 important components:

  • A coding scheme
  • A code value (not normally human readable)
  • A code meaning - a non-normative, but human-readable version of the value. This can have multiple language equivalents


Automatic PIX Queries in XdsObjects

Automatic PIX Queries in XdsObjects
General XdsObjects information > Automatic PIX Queries in XdsObjects

This is just a placeholder for now.

Where necessary and configured, XdsObjects will do an automatic lookup using the PIX Manager defined by XdsDomain.PixManager to translate between the local Domain and the XDS affinity domain


Server Certificates

Server Certificates
General XdsObjects information > Server Certificates

Under the Windows communication framework, applications do not themselves listen directly on ports for incoming http connections - rather they ask Windows to do this for them, and to pass on requests which "match" the requested URL pattern. Whilst this works fine for unsecured (http) traffic, it causes complications for secure (https) traffic, since the destination URL is only known after the certificates and security parameters have been negotiated, and so these must be set at a system level, rather than by any one of the applications which might happen to be listening on the chosen port.

Therefore, to listen using https, it is necessary not only to use the XdsMtomServer.Listen or XdsSoapServer.Listen methods, but also the system must be configured using httpcfg (for XP/2003 systems) or netsh (for Vista/Windows 7/Server 2008 systems).

Step by step guide (for XP using httpcfg - netsh is similar)

  • Install XP SP2 support tools for XP/2003 - get from here
    • Must select custom installation and include optional tools to get httpcfg
    • Will be netsh for Vista/Win7
  • Import into the server
    • Use mmc snap in to import to the local machine account's personal store
    • Also use snap in to add the ca cert to trusted local roots
    • MMC instructions here
    • Big picture here - towards the bottom
  • Import using httpcfg as follows, where:
    • XXX = port to listen on
    • YYYYY = thumbprint of chosen certificate
    • -f 2 means that a client certificate is requested
    • -m 1 means that the certificate will NOT be verified for revocation.
httpcfg set ssl -m 1 -i 0.0.0.0:XXX -f 2 -h YYYYY


Company and Licensing

Company and Licensing

This section contains details of commercial aspects of the use of XdsObjects, and licensing it from Medical Connections Ltd


Contact Information

Contact Information
Commercial Topics > Contact Information

Contact Information for Medical Connections Ltd:

E-mail: | support@medicalconnections.co.uk
Web: | http://www.medicalconnections.co.uk
Address: | Suite 10, Henley House Queensway Fforestfach Swansea SA5 4DJ United Kindom
Telephone: | +44 1792 390209 US toll free: (during UK business hours!): 888 342 6634
Fax: | +44 1792 390495


MedicalConnections.Security.Delegates Namespace Inheritance Hierarchy

MedicalConnections.Security.Delegates Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
See Also

Reference

Security.6.40 Assembly


MedicalConnections.Security.Enums Namespace Inheritance Hierarchy

MedicalConnections.Security.Enums Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
See Also

Reference

Security.6.40 Assembly


MedicalConnections.Security.EventArguments Namespace Inheritance Hierarchy

MedicalConnections.Security.EventArguments Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
MedicalConnections.Security.EventArguments.ModifyBindingsArgs
MedicalConnections.Security.EventArguments.ModifyCredentialArgs
MedicalConnections.Security.EventArguments.OnConnectArgs
See Also

Reference

Security.6.40 Assembly


TlsServerBouncyCastle Class Properties

TlsServerBouncyCastle Class Properties

MedicalConnections.Security Namespace : TlsServerBouncyCastle Class

For a list of all members of this type, see TlsServerBouncyCastle members.

Public Properties
 | Name | Description
Public Property | CheckCRL | Controls whether or not to check certificate revokation lists (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Public Property | CheckHostName | Controls whether or not to check host names against their certificates (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Public Property | RemoteHostName | The remote host name (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Top
Protected Properties
 | Name | Description
Protected Property | TrustedRoots | The list of trusted root certificates (Inherited from MedicalConnections.Security.TlsBouncyCastle)
Top
See Also

Reference

TlsServerBouncyCastle Class
MedicalConnections.Security Namespace


MedicalConnections.Security Namespace Inheritance Hierarchy

MedicalConnections.Security Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
MedicalConnections.Security.TlsBouncyCastle
MedicalConnections.Security.TlsClientBouncyCastle
MedicalConnections.Security.TlsServerBouncyCastle
MedicalConnections.Security.TlsClientNone
MedicalConnections.Security.TlsClientWindows
MedicalConnections.Security.TlsServerWindows
See Also

Reference

Security.6.40 Assembly


XdsCreatePullPointResponse Class Methods

XdsCreatePullPointResponse Class Methods

XdsObjects.Dsub Namespace : XdsCreatePullPointResponse Class

For a list of all members of this type, see XdsCreatePullPointResponse members.

Public Methods
 | Name | Description
Public Method | AddError | Overloaded. Add a new XdsObjects.XdsError to the Errors collection, given the XdsObjects.Enums.XdsErrorCode, plus Location and CodeContext (Inherited from XdsObjects.XdsRegistryResponse)
Public Method | ContainsErrors | Indicates whether the response contains any error codes (Inherited from XdsObjects.XdsRegistryResponse)
Top
See Also

Reference

XdsCreatePullPointResponse Class
XdsObjects.Dsub Namespace


XdsSubscriptionResponse Class Methods

XdsSubscriptionResponse Class Methods

XdsObjects.Dsub Namespace : XdsSubscriptionResponse Class

For a list of all members of this type, see XdsSubscriptionResponse members.

Public Methods
 | Name | Description
Public Method | AddError | Overloaded. Add a new XdsObjects.XdsError to the Errors collection, given the XdsObjects.Enums.XdsErrorCode, plus Location and CodeContext (Inherited from XdsObjects.XdsRegistryResponse)
Public Method | ContainsErrors | Indicates whether the response contains any error codes (Inherited from XdsObjects.XdsRegistryResponse)
Top
See Also

Reference

XdsSubscriptionResponse Class
XdsObjects.Dsub Namespace


XdsUnsubscriptionResponse Class Methods

XdsUnsubscriptionResponse Class Methods

XdsObjects.Dsub Namespace : XdsUnsubscriptionResponse Class

For a list of all members of this type, see XdsUnsubscriptionResponse members.

Public Methods
 | Name | Description
Public Method | AddError | Overloaded. Add a new XdsObjects.XdsError to the Errors collection, given the XdsObjects.Enums.XdsErrorCode, plus Location and CodeContext (Inherited from XdsObjects.XdsRegistryResponse)
Public Method | ContainsErrors | Indicates whether the response contains any error codes (Inherited from XdsObjects.XdsRegistryResponse)
Top
See Also

Reference

XdsUnsubscriptionResponse Class
XdsObjects.Dsub Namespace


XdsUnsubscriptionResponse Class Properties

XdsUnsubscriptionResponse Class Properties

XdsObjects.Dsub Namespace : XdsUnsubscriptionResponse Class

For a list of all members of this type, see XdsUnsubscriptionResponse members.

Public Properties
 | Name | Description
Public Property | Errors | The errors in this response (Inherited from XdsObjects.XdsRegistryResponse)
Public Property | Status | The status send or received in this response. (Inherited from XdsObjects.XdsRegistryResponse)
Top
See Also

Reference

XdsUnsubscriptionResponse Class
XdsObjects.Dsub Namespace


XdsObjects.Dsub Namespace Inheritance Hierarchy

XdsObjects.Dsub Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
XdsObjects.Dsub.NotificationMessage
XdsObjects.Dsub.XdsCreatePullPointRequest
XdsObjects.Dsub.XdsDestroyPullPointRequest
XdsObjects.Dsub.XdsDestroyPullPointResponse
XdsObjects.Dsub.XdsNotifyRequest
XdsObjects.Dsub.XdsSubscriptionRequest
XdsObjects.Dsub.XdsUnsubscriptionRequest
XdsObjects.XdsRegistryResponse
XdsObjects.Dsub.XdsCreatePullPointResponse
XdsObjects.Dsub.XdsSubscriptionResponse
XdsObjects.Dsub.XdsUnsubscriptionResponse
See Also

Reference

XdsObjects.6.40 Assembly


XdsObjects.Enums Namespace Inheritance Hierarchy

XdsObjects.Enums Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
See Also

Reference

XdsObjects.6.40 Assembly


XdsObjects.EventArguments Namespace Inheritance Hierarchy

XdsObjects.EventArguments Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
XdsObjects.EventArguments.ModifyHeadersArgs
See Also

Reference

XdsObjects.6.40 Assembly


LicenseDialog Class Events

LicenseDialog Class Events

XdsObjects Namespace : LicenseDialog Class

For a list of all members of this type, see LicenseDialog members.

Public Events
 | Name | Description
Public Event | Activated | (Inherited from System.Windows.Forms.Form)
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.Form)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Deactivate | (Inherited from System.Windows.Forms.Form)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | FormClosed | (Inherited from System.Windows.Forms.Form)
Public Event | FormClosing | (Inherited from System.Windows.Forms.Form)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | HelpButtonClicked | (Inherited from System.Windows.Forms.Form)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | InputLanguageChanged | (Inherited from System.Windows.Forms.Form)
Public Event | InputLanguageChanging | (Inherited from System.Windows.Forms.Form)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.Form)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MaximizedBoundsChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MaximumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MdiChildActivate | (Inherited from System.Windows.Forms.Form)
Public Event | MinimumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | ResizeBegin | (Inherited from System.Windows.Forms.Form)
Public Event | ResizeEnd | (Inherited from System.Windows.Forms.Form)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftLayoutChanged | (Inherited from System.Windows.Forms.Form)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | Shown | (Inherited from System.Windows.Forms.Form)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

LicenseDialog Class
XdsObjects Namespace


LicenseDialog Class Properties

LicenseDialog Class Properties

XdsObjects Namespace : LicenseDialog Class

For a list of all members of this type, see LicenseDialog members.

Public Properties
 | Name | Description
Public Property | AcceptButton | (Inherited from System.Windows.Forms.Form)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.Form)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.Form)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.Form)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.Form)
Public Property | BackColor | (Inherited from System.Windows.Forms.Form)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | CancelButton | (Inherited from System.Windows.Forms.Form)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Form)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | ControlBox | (Inherited from System.Windows.Forms.Form)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | FormBorderStyle | (Inherited from System.Windows.Forms.Form)
Public Property | HelpButton | (Inherited from System.Windows.Forms.Form)
Public Property | Icon | (Inherited from System.Windows.Forms.Form)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | IsMdiContainer | (Inherited from System.Windows.Forms.Form)
Public Property | KeyPreview | (Inherited from System.Windows.Forms.Form)
Public Property | Location | (Inherited from System.Windows.Forms.Form)
Public Property | MainMenuStrip | (Inherited from System.Windows.Forms.Form)
Public Property | MaximizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Form)
Public Property | MinimizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Form)
Public Property | Opacity | (Inherited from System.Windows.Forms.Form)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeftLayout | (Inherited from System.Windows.Forms.Form)
Public Property | ShowIcon | (Inherited from System.Windows.Forms.Form)
Public Property | ShowInTaskbar | (Inherited from System.Windows.Forms.Form)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Form)
Public Property | SizeGripStyle | (Inherited from System.Windows.Forms.Form)
Public Property | StartPosition | (Inherited from System.Windows.Forms.Form)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.Form)
Public Property | TopMost | (Inherited from System.Windows.Forms.Form)
Public Property | TransparencyKey | (Inherited from System.Windows.Forms.Form)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | WindowState | (Inherited from System.Windows.Forms.Form)
Top
Protected Properties
 | Name | Description
Protected Property | AutoScaleFactor | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.Form)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Form)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultSize | (Inherited from System.Windows.Forms.Form)
Protected Property | DoubleBuffered | (Inherited from System.Windows.Forms.Control)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | HScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | ImeModeBase | (Inherited from System.Windows.Forms.Control)
Protected Property | MaximizedBounds | (Inherited from System.Windows.Forms.Form)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from System.Windows.Forms.Control)
Protected Property | VScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Top
See Also

Reference

LicenseDialog Class
XdsObjects Namespace


XdsDocumentViewer Class Events

XdsDocumentViewer Class Events

XdsObjects Namespace : XdsDocumentViewer Class

For a list of all members of this type, see XdsDocumentViewer members.

Public Events
 | Name | Description
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

XdsDocumentViewer Class
XdsObjects Namespace


XdsError Class Events

XdsError Class Events

XdsObjects Namespace : XdsError Class

For a list of all members of this type, see XdsError members.

Protected Events
 | Name | Description
Protected Event | SerializeObjectState | (Inherited from System.Exception)
Top
See Also

Reference

XdsError Class
XdsObjects Namespace


XdsError Class Methods

XdsError Class Methods

XdsObjects Namespace : XdsError Class

For a list of all members of this type, see XdsError members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

XdsError Class
XdsObjects Namespace


RetrieveImages Method

RetrieveImages Method

XdsObjects Namespace > XdsImagingClient Class : RetrieveImages Method
Methods to retrieve images using any of the methods in the XDS-I specification
Overload List
Overload | Description
RetrieveImages | Retrieve set of images using Rad69, DICOM or WADO
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsImagingClient Class
XdsImagingClient Members


XdsImagingRetrieveRequest Constructor

XdsImagingRetrieveRequest Constructor

XdsObjects Namespace > XdsImagingRetrieveRequest Class : XdsImagingRetrieveRequest Constructor
Overload List
Overload | Description
XdsImagingRetrieveRequest Constructor | Create a new, empty XdsImagingRetrieveHandler
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsImagingRetrieveRequest Class
XdsImagingRetrieveRequest Members


XdsInternationalString Constructor

XdsInternationalString Constructor

XdsObjects Namespace > XdsInternationalString Class : XdsInternationalString Constructor
Overload List
Overload | Description
XdsInternationalString Constructor | Create an XdsInternationalString holding a single value
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsInternationalString Class
XdsInternationalString Members


Implicit Type Conversion(String,XdsInternationalString) Operator

Implicit Type Conversion(String,XdsInternationalString) Operator

XdsObjects Namespace > XdsInternationalString Class > Implicit Type Conversion Operator : Implicit Type Conversion(String,XdsInternationalString) Operator
The XdsInternationalString object to obtain the value from
Return the most appropriate single string from those available
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Overloads Public Operator Widening CType( _
   ByVal InternationalString As XdsInternationalString _
) As String

public string operator implicit(
   XdsInternationalString InternationalString
)

public:
operator String^ (
   XdsInternationalString^ InternationalString
)

Parameters
InternationalString

The XdsInternationalString object to obtain the value from

Return Value
the "best match" string

Remarks
The order of choice of strings is as follows:

  • Language matches XdsGlobal.DefaultLanguage

  • Item with empty language code

  • The first item in the list
If the list is empty, null is returned

As this is an implicit operator, it permits simple assigment of an XdsInternationalString object to a string

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
XdsInternationalString Class

XdsInternationalString Members

Overload List


Implicit Type Conversion(XdsInternationalString,String) Operator

Implicit Type Conversion(XdsInternationalString,String) Operator

XdsObjects Namespace > XdsInternationalString Class > Implicit Type Conversion Operator : Implicit Type Conversion(XdsInternationalString,String) Operator
The value to assign to the newly created XdsInternationalString
Create an XdsInternationalString holding a single value from a sting
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Overloads Public Operator Widening CType( _
   ByVal String As String _
) As XdsInternationalString

public XdsInternationalString operator implicit(
   string String
)

public:
operator XdsInternationalString^ (
   String^ String
)

Parameters
String

The value to assign to the newly created XdsInternationalString

Return Value
a new XdsInternationalString object

Remarks
The item is assigned the current default lnguage code, as defined by XdsGlobal.DefaultLanguage

As this is an implicit oerator, it permits simple assigment of a string to an XdsInternationalString object

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
XdsInternationalString Class

XdsInternationalString Members

Overload List


XdsMtomServer Class Properties

XdsMtomServer Class Properties

XdsObjects Namespace : XdsMtomServer Class

For a list of all members of this type, see XdsMtomServer members.

Public Properties
 | Name | Description
Public Property | StructureIncomingSubmissionSet | Controls the behaviour used when incoming data is received. (Inherited from XdsObjects.XdsBaseServer)
Top
See Also

Reference

XdsMtomServer Class
XdsObjects Namespace


Implicit Type Conversion(XdsMultiString,List<String>) Operator

Implicit Type Conversion(XdsMultiString,List<String>) Operator

XdsObjects Namespace > XdsMultiString Class > Implicit Type Conversion Operator : Implicit Type Conversion(XdsMultiString,List<String>) Operator
The list of values to assign to the new object
Create an XdsMultiString object from an enumerable set of strings
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Overloads Public Operator Widening CType( _
   ByVal List As List(Of String) _
) As XdsMultiString

public XdsMultiString operator implicit(
   List<string> List
)

public:
operator XdsMultiString^ (
   List<String^>^ List
)

Parameters
List

            The list of values to assign to the new object

Return Value

            A new XdsMultiString containing the copies of the strings in the list

Remarks
As this is an implicit oerator, it permits simple assigment of a list of strings to an XdsMultiString object

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
XdsMultiString Class

XdsMultiString Members

Overload List


Implicit Type Conversion(XdsMultiString,String) Operator

Implicit Type Conversion(XdsMultiString,String) Operator

XdsObjects Namespace > XdsMultiString Class > Implicit Type Conversion Operator : Implicit Type Conversion(XdsMultiString,String) Operator
The value to assign to the new object
Create an XdsMultiString object from a simple string
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Overloads Public Operator Widening CType( _
   ByVal String As String _
) As XdsMultiString

public XdsMultiString operator implicit(
   string String
)

public:
operator XdsMultiString^ (
   String^ String
)

Parameters
String

            The value to assign to the new object

Return Value

            A new XdsMultiString containing the single string

Remarks
As this is an implicit oerator, it permits simple assigment of a string to an XdsMultiString object

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
XdsMultiString Class

XdsMultiString Members

Overload List


Implicit Type Conversion(XdsMultiString,String[]) Operator

Implicit Type Conversion(XdsMultiString,String[]) Operator

XdsObjects Namespace > XdsMultiString Class > Implicit Type Conversion Operator : Implicit Type Conversion(XdsMultiString,String[]) Operator
The array of values to assign to the new object
Create an XdsMultiString object from an array of strings
Syntax
  • Visual Basic (Declaration)
  • Visual Basic (Usage)
  • C#
  • C++/CLI
Overloads Public Operator Widening CType( _
   ByVal Array() As String _
) As XdsMultiString

public XdsMultiString operator implicit(
   string[] Array
)

public:
operator XdsMultiString^ (
   array<String^>^ Array
)

Parameters
Array

            The array of values to assign to the new object

Return Value

            A new XdsMultiString containing the copies of the strings in the array

Remarks
As this is an implicit oerator, it permits simple assigment of an array of strings to an XdsMultiString object

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
XdsMultiString Class

XdsMultiString Members

Overload List


XdsObjectRefList Class Properties

XdsObjectRefList Class Properties

XdsObjects Namespace : XdsObjectRefList Class

For a list of all members of this type, see XdsObjectRefList members.

Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Property | Count | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Public Property | Item | (Inherited from System.Collections.Generic.List<XdsObjectRef>)
Top
See Also

Reference

XdsObjectRefList Class
XdsObjects Namespace


XdsRetrieveRequest Constructor

XdsRetrieveRequest Constructor

XdsObjects Namespace > XdsRetrieveRequest Class : XdsRetrieveRequest Constructor
Create a new XdsRetrieveRequest
Overload List
Overload | Description
XdsRetrieveRequest Constructor | Create a new, blank XdsRetrieveRequest
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsRetrieveRequest Class
XdsRetrieveRequest Members


XdsSlot Constructor

XdsSlot Constructor

XdsObjects Namespace > XdsSlot Class : XdsSlot Constructor
Overload List
Overload | Description
XdsSlot Constructor | Create a new empty Slot
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSlot Class
XdsSlot Members


XdsSoapServer Class Properties

XdsSoapServer Class Properties

XdsObjects Namespace : XdsSoapServer Class

For a list of all members of this type, see XdsSoapServer members.

Public Properties
 | Name | Description
Public Property | StructureIncomingSubmissionSet | Controls the behaviour used when incoming data is received. (Inherited from XdsObjects.XdsBaseServer)
Top
See Also

Reference

XdsSoapServer Class
XdsObjects Namespace


XdsSubmissionSet Constructor

XdsSubmissionSet Constructor

XdsObjects Namespace > XdsSubmissionSet Class : XdsSubmissionSet Constructor
Overload List
Overload | Description
XdsSubmissionSet Constructor | Creates a new Empty Submission Set
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XdsSubmissionSet Class
XdsSubmissionSet Members


XdsObjects Namespace Inheritance Hierarchy

XdsObjects Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Collections.Generic.List<T>
XdsObjects.XdsObjectRefList
System.Exception
XdsObjects.XdsError
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
XdsObjects.LicenseDialog
XdsObjects.XdsDocumentViewer
System.ServiceModel.EndpointAddress
XdsObjects.WebServiceEndpoint
XdsObjects.XdsImagingClient.WebServiceImageEndPoint
XdsObjects.AuditEndpoint
XdsObjects.DicomSeries
XdsObjects.DicomStudy
XdsObjects.PixQuery
XdsObjects.XdsAssociation
XdsObjects.XdsAudit
XdsObjects.XdsAudit.ParticipatingObject
XdsObjects.XdsAuthor
XdsObjects.XdsBaseServer
XdsObjects.XdsMtomServer
XdsObjects.XdsSoapServer
XdsObjects.XdsCode
XdsObjects.XdsDeleteDocumentSetRequest
XdsObjects.XdsDocument
XdsObjects.XdsDomain
XdsObjects.XdsErrorItem
XdsObjects.XdsFolder
XdsObjects.XdsGlobal
XdsObjects.XdsGlobal.LogEventArgs
XdsObjects.XdsImagingClient
XdsObjects.XdsImagingRetrieveRequest
XdsObjects.XdsImagingServer
XdsObjects.XdsInternationalString
XdsObjects.XdsLicense
XdsObjects.XdsMultiString
XdsObjects.XdsObjectRef
XdsObjects.XdsPerson
XdsObjects.XdsPatient
XdsObjects.XdsQueryRequest
XdsObjects.XdsRegistryResponse
XdsObjects.Dsub.XdsCreatePullPointResponse
XdsObjects.Dsub.XdsSubscriptionResponse
XdsObjects.Dsub.XdsUnsubscriptionResponse
XdsObjects.XdsQueryResponse
XdsObjects.XdsRetrieveResponse
XdsObjects.XdsRelationship
XdsObjects.XdsRequestInfo
XdsObjects.XdsRetrieveItem
XdsObjects.XdsRetrieveRequest
XdsObjects.XdsSlot
XdsObjects.XdsSubmissionSet
See Also

Reference

XdsObjects.6.40 Assembly