Introduction to DicomObjects .NET version

DicomObjects.NET.V8
Introduction to DicomObjects .NET version

Overview of DicomObjects.NET

DicomObjects.NET consists of an inter-related, but independent, set of .NET "Objects" that enable developers to quickly and easily add DICOM functionality to their products without needing to understand or program the intricacies of the DICOM standard. This help file provides full reference to those objects and also some introductory guidance.

Almost any aspect of DICOM image/data manipulation can be performed using DicomObjects, including:

  • Image display and manipulation
  • Network transmission of images and associated data, including worklists
  • Printing to DICOM and windows printers
  • Normalised operations including storage commitment
  • Image creation from scratch and import/export to/from non-DICOM formats

The main Components of DicomObjects are:

DicomViewer Control

A control that may be embedded into any .NET forms control container such as C#, Visual Basic.NET etc. It has extensive display capabilities for DICOM images, whether read from files, received over the network, or from numerous other sources, and these include a wide range of annotations, and full DICOM greyscale presentation state support.

DicomServer Class

An object that provides storage, query/retrieve and normalised facilities as a service class provider (SCP). Events are raised in response to incoming operations.

DicomQuery Class

An object that handles the query/retrieve parts of the DICOM standard as a service class user (SCU).

DicomPrint Class

An object that simplifies DICOM printing as a service class user (SCU).

DicomGlobal Class

Used for certain global operations, including logging and setting global behaviour.

DicomAssociation Class

A DicomAssociation Object represents a DICOM association, and may either be created automatically in response to an incoming query request, or explicitly by the client program. Methods of this object are used to send data, images, and verification requests.

Other classes and collections are created and used by the above, and some may also be created directly. They are:

DicomImage Class

An object that represents the DICOM image with the pixel data and all the attributes as accessible properties. It is a superset of DicomDataSet Class, which in turn is a collection of DicomAttribute Class. DicomAttribute is the basic unit to hold A DICOM element, it is represented by a keyword/tag in the format (gggg,eeee), where gggg equates to the Group Number and eeee equates to the Element Number within that Group. These values are in hexadecimal notation as specified for each named Data Element in the Standard (PS3.6 Data Dictionary)

There is also a 3D specific DicomImage3D Class that supports MPR, MIP, VR & Slab rendering of DicomVolume

DicomLabel Class

An object that represents annotations, markers on the displayed DICOM image.

DicomException Class

A DicomException Object represents the errors that occur within DicomObjects which is wrapped and thrown as a manageable exception in the user code with descriptive error messages.

Object Description | Single Item | Collection
SOP instance, containing an image | DicomImage Class | DicomImageCollection Class
Generic SOP instance, used for results of DICOM queries or as a sub-element of a Sequence | DicomDataSet Class | DicomDataSetCollection Class
Attribute (Data Element) of a DicomDataSet | DicomAttribute Class
DICOM Presentation context | DicomContext Class | DicomContextCollection Class
Image Annotation | DicomLabel Class | DicomLabelCollection Class
Licensing Information and Control | DicomLicense Class

© copyright Medical Connections Ltd 2022

Send feedback


Version 8 Release Notes

Version 8 Release Notes

This new version of DicomObjects.NET consolidates numerous incremental changes and cleans up some of the unused remnants, as well as adding significant new features, the main one being the 2D and 3D GPU rendering. The main changes are:

2D/3D GPU rendering using DirectX (HLSL)

The big advancement in this version is the GPU powered 2D and 3D rendering of images, which not only makes it a more stable option but also has a massive performance improvement with very impressive test results. Few fundamental changes to the rendering process are:

  • 3D images now have a single class, and hence it is possible to move between the types (MPR, Slab, MIP & VR) by changing the Mode property, without remaking the object.
  • A DicomVolume object can be used to make multiple 3D image objects, improving memory efficiency and saving CPU cycles.
DICOM Fusion Image
This is a totally new feature which can be utilised by using the DicomImageFusion class. It allows spatial transformations, which are passed on simultaneously to all the images in the collection.
Video support using FFmpeg

Starting with version 8 we have added video support with the help of FFmpeg, a well established video Codec, for handling all sorts of popular video formats. This allows importing of supported video formats, embedding them into DICOM and exporting them using the appropriate transfer syntax.

FFmpeg is licensed under the GNU Lesser Public license(LGPL). We comply with the rules as stated in FFmpeg's licensing terms (https://www.ffmpeg.org/legal.html) for using this open-source Codec in our product and would urge our users to be aware of the legal responsibilities of using it. For development status on this feature please check our webpage http://www.medicalconnections.co.uk/kb/Video_support_with_FFmpeg

DicomLabel update
There is a single major update in this new version as a result of our effort to have a consistent API for DicomLabel handling. We have fully documented the changes in our article.

There have been many internal code changes that are related to code normalization, efficiency and readability and some of them affect deep rooted routines like handling sequences, writing to disk, network transmission, etc. Most of these don't directly affect our API but some changes were unavoidable. If you have any problems with this version please contact us our Support Team.


DicomObjects Namespace

DicomObjects Namespace
Inheritance Hierarchy
The main namespace holding most classes that are used directly in user code. The other namespaces hold subsidiary definitions, to keep the main namespace "clean", which makes Intellisense function more intuitively.
Classes
 | Class | Description
Class | ColourPalettes | A class which holds static members providing access to ready-made Colour Palettes, including those pre-defined by DICOM
Class | DicomAssociation | Class representing a single DICOM Association
Class | DicomAssociationCollection | A collection of DicomAssociation objects
Class | DicomAttribute | Class representing a single DICOM Attribute
Class | DicomContext | A DICOM presentation context, as used in association negotiation
Class | DicomContextCollection | The list of DICOM Presentation contexts proposed or accepted during negotiation
Class | DicomDataSet | A DICOM data set
Class | DicomDataSetCollection | A collection of DicomDataSet objects
Class | DicomException | Specific Exception for DICOM errors
Class | DicomGlobal | Placeholder for various static methods and properties
Class | DicomImage | Class representing a DICOM Image
Class | DicomImage3D | Class to display 3D DICOM data in various modes
Class | DicomImageCollection | A Collection of DicomImage objects
Class | DicomImageCurvedMPR | Class to display 3D DICOM data as a curved MPR
Class | DicomImageFusion | A class which allows overlaying of multiple images
Class | DicomLabel | A label, or annotation, to be displayed over an image in a DicomViewer control, or in derived copies of the image.
Class | DicomLabel3D | Class to represent a 3D orientation label superimposed on a 3D image.
Class | DicomLabelCollection | A collection of DicomLabel objects.
Class | DicomLicense | This class handles all the new licensing scheme for DicomObjects.
Class | DicomLicense.RamLicenseInfo | Provide Basic information of a Concurrent license object
Class | DicomPrint | An object to simply printing to a DICOM printer
Class | DicomQuery | Object used for DICOM Query/retrieve SCU operations
Class | DicomServer | An object for handling advanced network communications, as both SCU & SCP
Class | DicomViewer | A visible control to display DicomImage objects
Class | DicomVolume | Class used to represent a "volume" of data, either from a set of individual 2D DICOM images, or from a 3D multi-slice object. It currently has no public properties or methods, other than constructors, and is used only in the constructor of the DicomImage3D object.
Class | FileSignature | Definition of all file signatures/magic numbers of commonly available executables and archives
Class | LicenseDialog | The customisable dialog used when a license needs to be acitvated or information about it needs to be displayed.
Class | LookupTable | Class to hold explicit lookup tables
Class | ReadBehaviours | Specific behaviour to use when reading/receiving a DICOM instance
Class | ValidationOptions | Options to validate DicomDataSet and its DicomAttributes
Class | WriteBehaviours | Specific behaviour to use when writing/sending a DICOM instance
Interfaces
 | Interface | Description
Interface | IFrameSource | A simple interface used by extension codecs for video
Structures
 | Structure | Description
Structure | Plane3D | Defines a plane in 3D space.
Delegates
 | Delegate | Description
Delegate | DicomAttribute.DelayedDataRoutine | Delegate to fetch binary data for the bid
Enumerations
 | Enumeration | Description
Enumeration | RenderMode3D | The types of 3D rendering available
See Also

Reference

DicomObjects.NET.8.40 Assembly


DicomObjects.NET.8.40 Assembly

DicomObjects.NET.8.40 Assembly
This assembly holds all the DICOM-specific functionality in DicomObjects
Namespaces
Namespace | Description
DicomObjects | The main namespace holding most classes that are used directly in user code. The other namespaces hold subsidiary definitions, to keep the main namespace "clean", which makes Intellisense function more intuitively.
DicomObjects.Delegates | The delegates used for the definition of events
DicomObjects.DicomCodecs | Namespace holding Codec specific objects - both for the extension interface, and for fine tuning of internal codecs
DicomObjects.DicomUIDs | A set of classes with static fields holding the standard well-known DICOM UIDs, grouped by function
DicomObjects.DicomWeb | A set of classes that handle DICOM web functionalities
DicomObjects.DicomWeb.Internal |
DicomObjects.Enums | The various enumerations used by DicomObjects
DicomObjects.EventArguments | Specific classes passed to events
DicomObjects.InternalCodecs.JPIP |
DicomObjects.Video | Defines classes and enums available for fine tuning video decoding/encoding


ColourPalettes Class

ColourPalettes Class
Members

DicomObjects Namespace : ColourPalettes Class
A class which holds static members providing access to ready-made Colour Palettes, including those pre-defined by DICOM
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit NotInheritable Class ColourPalettes
'Usage

Dim instance As ColourPalettes
public static class ColourPalettes
public ref class ColourPalettes abstract sealed
Inheritance Hierarchy

System.Object
DicomObjects.ColourPalettes

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ColourPalettes Members
DicomObjects Namespace


ColourPalettes Class Members

ColourPalettes Class Members
Properties Methods

DicomObjects Namespace : ColourPalettes Class

The following tables list the members exposed by ColourPalettes.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | HotIron | The Hot Iron color palette is often used in nuclear medicine applications to make differences in signal intensity (counts) more apparent to the human observer.
static (Shared in Visual Basic) | HotMetalBlue | The Hot Metal Blue color palette is often used in nuclear medicine or PET applications to make differences in signal intensity (counts) more apparent to the human observer.
static (Shared in Visual Basic) | Pet20Step | The PET 20 Step color palette is often used in PET applications to make differences in signal intensity (counts) more apparent to the human observer.
static (Shared in Visual Basic) | PetColor | The PET color palette is often used in PET applications to pseudo-color the superimposed PET images when displayed fused with underlying CT images
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | FromName | Return a well-known-instance colour palette, from its official DICOM Name
static (Shared in Visual Basic) | FromUID | Return a well-known-instance colour palette, from its official DICOM UID
Top
See Also

Reference

ColourPalettes Class
DicomObjects Namespace


ColourPalettes Class Methods

ColourPalettes Class Methods

DicomObjects Namespace : ColourPalettes Class

For a list of all members of this type, see ColourPalettes members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | FromName | Return a well-known-instance colour palette, from its official DICOM Name
static (Shared in Visual Basic) | FromUID | Return a well-known-instance colour palette, from its official DICOM UID
Top
See Also

Reference

ColourPalettes Class
DicomObjects Namespace


FromName Method

FromName Method

DicomObjects Namespace > ColourPalettes Class : FromName Method
The name which identifies the palette
Return a well-known-instance colour palette, from its official DICOM Name
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function FromName( _
   ByVal Name As String _
) As IList(Of Color)
'Usage

Dim Name As String
Dim value As IList(Of Color)

value = ColourPalettes.FromName(Name)
public static IList<Color> FromName(
   string Name
)
public:
static IList<Color>^ FromName(
   String^ Name
)

Parameters

Name
The name which identifies the palette

Return Value

A 256 colour palette
Remarks
The supported names are
  • HOT_IRON
  • PET
  • HOT_METAL_BLUE
  • PET_20_STEP
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ColourPalettes Class
ColourPalettes Members


FromUID Method

FromUID Method

DicomObjects Namespace > ColourPalettes Class : FromUID Method
The UID which identifies the palette
Return a well-known-instance colour palette, from its official DICOM UID
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function FromUID( _
   ByVal UID As String _
) As IList(Of Color)
'Usage

Dim UID As String
Dim value As IList(Of Color)

value = ColourPalettes.FromUID(UID)
public static IList<Color> FromUID(
   string UID
)
public:
static IList<Color>^ FromUID(
   String^ UID
)

Parameters

UID
The UID which identifies the palette

Return Value

A 256 colour palette
Remarks
The UIDs as of the form: 1.2.840.10008.1.5.X
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ColourPalettes Class
ColourPalettes Members


ColourPalettes Class Properties

ColourPalettes Class Properties

DicomObjects Namespace : ColourPalettes Class

For a list of all members of this type, see ColourPalettes members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | HotIron | The Hot Iron color palette is often used in nuclear medicine applications to make differences in signal intensity (counts) more apparent to the human observer.
static (Shared in Visual Basic) | HotMetalBlue | The Hot Metal Blue color palette is often used in nuclear medicine or PET applications to make differences in signal intensity (counts) more apparent to the human observer.
static (Shared in Visual Basic) | Pet20Step | The PET 20 Step color palette is often used in PET applications to make differences in signal intensity (counts) more apparent to the human observer.
static (Shared in Visual Basic) | PetColor | The PET color palette is often used in PET applications to pseudo-color the superimposed PET images when displayed fused with underlying CT images
Top
See Also

Reference

ColourPalettes Class
DicomObjects Namespace


HotIron Property

HotIron Property

DicomObjects Namespace > ColourPalettes Class : HotIron Property
The Hot Iron color palette is often used in nuclear medicine applications to make differences in signal intensity (counts) more apparent to the human observer.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property HotIron As IList(Of Color)
'Usage

Dim value As IList(Of Color)

value = ColourPalettes.HotIron
public static IList<Color> HotIron {get;}
public:
static property IList<Color>^ HotIron {
   IList<Color>^ get();
}
Remarks
This palette, and its associated description are as defined in part 6 of the DICOM Standard
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ColourPalettes Class
ColourPalettes Members


HotMetalBlue Property

HotMetalBlue Property

DicomObjects Namespace > ColourPalettes Class : HotMetalBlue Property
The Hot Metal Blue color palette is often used in nuclear medicine or PET applications to make differences in signal intensity (counts) more apparent to the human observer.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property HotMetalBlue As IList(Of Color)
'Usage

Dim value As IList(Of Color)

value = ColourPalettes.HotMetalBlue
public static IList<Color> HotMetalBlue {get;}
public:
static property IList<Color>^ HotMetalBlue {
   IList<Color>^ get();
}
Remarks
This palette, and its associated description are as defined in part 6 of the DICOM Standard
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ColourPalettes Class
ColourPalettes Members


Pet20Step Property

Pet20Step Property

DicomObjects Namespace > ColourPalettes Class : Pet20Step Property
The PET 20 Step color palette is often used in PET applications to make differences in signal intensity (counts) more apparent to the human observer.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Pet20Step As IList(Of Color)
'Usage

Dim value As IList(Of Color)

value = ColourPalettes.Pet20Step
public static IList<Color> Pet20Step {get;}
public:
static property IList<Color>^ Pet20Step {
   IList<Color>^ get();
}
Remarks
This palette, and its associated description are as defined in part 6 of the DICOM Standard
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ColourPalettes Class
ColourPalettes Members


PetColor Property

PetColor Property

DicomObjects Namespace > ColourPalettes Class : PetColor Property
The PET color palette is often used in PET applications to pseudo-color the superimposed PET images when displayed fused with underlying CT images
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PetColor As IList(Of Color)
'Usage

Dim value As IList(Of Color)

value = ColourPalettes.PetColor
public static IList<Color> PetColor {get;}
public:
static property IList<Color>^ PetColor {
   IList<Color>^ get();
}
Remarks
This palette, and its associated description are as defined in part 6 of the DICOM Standard
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ColourPalettes Class
ColourPalettes Members


DicomAssociation Class

DicomAssociation Class
Members

DicomObjects Namespace : DicomAssociation Class
Class representing a single DICOM Association
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomAssociation
'Usage

Dim instance As DicomAssociation
public class DicomAssociation
public ref class DicomAssociation
Remarks

A DicomAssociation Object represents the current state of an association, and may either be created automatically in response to an incoming query request, or explicitly by the client program. Methods of this object are used to send data, images, and verification requests. There is not a one-to-one correspondence between DicomAssociations and associations, as one incoming association may cause several DicomAssociation objects to be produced, one in response to each incoming command, and likewise, an outgoing DicomAssociation object may during its life serve more than one association, but at a given time, each association is represented by one, and only one DicomAssociation.

Inheritance Hierarchy

System.Object
DicomObjects.DicomAssociation

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Members
DicomObjects Namespace


DicomAssociation Class Members

DicomAssociation Class Members
Properties Methods Events

DicomObjects Namespace : DicomAssociation Class

The following tables list the members exposed by DicomAssociation.

Public Constructors
 | Name | Description
Public Constructor | DicomAssociation Constructor | Creates a new DicomAssociation object.
Top
Public Properties
 | Name | Description
Public Property | AgreedContexts | The Presentation Contexts associated with this DicomAssociation
Public Property | AssociationNumber | Returns the association number of current connection.
Public Property | BytesReceived | Approximate Measures of Network Input
Public Property | BytesSent | Approximate measures of Network Output
Public Property | CalledAET | Provides information about the remote application entity
Public Property | CallingAET | Provides information about the calling application entity
Public Property | Cancelled | Indicates that the remote AE has issued a C-CANCEL request.
Public Property | CheckForCancel | Control whether to check for incoming C-CANCEL asynchronous messages
Public Property | CoercionSOP | SOP Class to which images should be coerced if peer does not accept true SOP class
static (Shared in Visual Basic) | DefaultThrowStatusException | The value intially assigned for the ThrowStatusException of new DicomAssociation objects.
Public Property | Identity | The user identity to use for an association
Public Property | ImplementationName | Returns the Implementation Version Name of the Connecting AE
Public Property | ImplementationUID | Returns the Implementation Class UID of the Connecting AE
Public Property | IsOpen | Indicates whether a DicomAssociation is open
Public Property | LastCommand | Returns the last command in the current association.
Public Property | LastError | Returns the last error status from LastCommand.
Public Property | LastInstanceUID | Holds the InstanceUID created or used by the last normalised operation.
Public Property | LastOperation | Returns the last operation in the current association.
Public Property | LastStatus | Shortcut for the first element of the Status property
Public Property | LocalIP | Provide information about which local interface the remote application entity called
Public Property | LocalPort | Provide information about which local port the remote application entity called
Public Property | LogLevel | Controls the level of logging for this particular Association.
Public Property | MetaSOPClass | Determines the Abstract Syntax used for normalised operations
Public Property | MoveOriginator | The DicomAssociation object which initiated the C-MOVE resulting in the current C-STORE
Public Property | PreferredPCID | Provides guidance for the choice of presentation context
Public Property | PreferredTS | Provides guidance for the choice of presentation context
Public Property | PreferredTSList | Provides guidance for the choice of presentation context
Public Property | ReadBehaviour | Specific behaviours to use when receiving data on this association.
Public Property | RemoteIP | Provides information about the remote application entity
Public Property | Request | This contains the list of attributes to be matched, as specified in the DICOM standard
Public Property | RequestedContexts | The Presentation Contexts associated with this DicomAssociation
Public Property | RequestingQuery | Provides a linkage to the primary C-MOVE request.
Public Property | ReturnedCommands | The command datasets returned in response to the last operation
Public Property | ReturnedIdentifier | Hold data returned from outgoing operations
Public Property | ReturnedIdentifiers | Hold data returned from outgoing operations
Public Property | ReturnedInstances | Hold instances returned from outgoing C-GET operations
Public Property | SslStream | Returns the secure Stream object
Public Property | Status | Array containing the status codes returned by the last SendInstances or Echo action
Public Property | Tag | A general purpose Tag for developer use
Public Property | ThrowStatusException | Controls whether an exception is generated when a non-zero status is received.
Public Property | WriteBehaviour | Specific behaviours to use when sending data on this association.
Top
Public Methods
 | Name | Description
Public Method | Abort | Aborts an association
Public Method | Cancel | Causes a C-CANCEL request to be sent to the remote AE asking it to terminate any outstanding image transfers
Public Method | Close | Closes the association represented by a "stand-alone" DicomAssociation
Public Method | Dispose | Releases the resources used by the DicomAssociation object
Public Method | Echo | Sends a verification request (C-ECHO) over a "stand-alone" DicomAssociation and returns the result
Public Method | Find | Overloaded. Sends a C-FIND request
Public Method | Get | Overloaded. Sends a C-GET request
Public Method | Move | Overloaded. Sends a C-MOVE request
Public Method | NAction | Sends an N-ACTION request
Public Method | NCreate | Sends an N-CREATE request
Public Method | NDelete | Sends an N-DELETE request
Public Method | NEventReport | Send an N-EVENT-REPORT over an established DicomAssociation
Public Method | NGet | Sends an N-GET request
Public Method | NSet | Sends an N-SET request
Public Method | Open | Overloaded. Negotiate an association with a remote application.
Public Method | PcidFor | Indicates the presentaiton context ID which would be used to send an instance of the given SOP class
Public Method | SendInstances | Overloaded. Sends data over a DicomAssociation
Public Method | SetQuality | Set the quality factor for lossy compression
Top
Public Events
 | Name | Description
Public Event | InitiateTls | Routine to use to generate encrypted stream when TLS is to be used for outgoing associations.
Public Event | N_Event_Report | This event handler is fired when an N-EVENT-REPORT notification is received.
Public Event | ResponseReceived | Event fires when a response is received on an out-going operation
Top
See Also

Reference

DicomAssociation Class
DicomObjects Namespace


DicomAssociation Constructor

DicomAssociation Constructor

DicomObjects Namespace > DicomAssociation Class : DicomAssociation Constructor
Creates a new DicomAssociation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DicomAssociation()
public DicomAssociation()
public:
DicomAssociation();

Return Value

DicomAssociation
Remarks

Creates a new DicomAssociation object.

Such an explicitly created DicomAssociation is assumed to be for outgoing use, and requires use of open before operations can occur on it.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


DicomAssociation Class Methods

DicomAssociation Class Methods

DicomObjects Namespace : DicomAssociation Class

For a list of all members of this type, see DicomAssociation members.

Public Methods
 | Name | Description
Public Method | Abort | Aborts an association
Public Method | Cancel | Causes a C-CANCEL request to be sent to the remote AE asking it to terminate any outstanding image transfers
Public Method | Close | Closes the association represented by a "stand-alone" DicomAssociation
Public Method | Dispose | Releases the resources used by the DicomAssociation object
Public Method | Echo | Sends a verification request (C-ECHO) over a "stand-alone" DicomAssociation and returns the result
Public Method | Find | Overloaded. Sends a C-FIND request
Public Method | Get | Overloaded. Sends a C-GET request
Public Method | Move | Overloaded. Sends a C-MOVE request
Public Method | NAction | Sends an N-ACTION request
Public Method | NCreate | Sends an N-CREATE request
Public Method | NDelete | Sends an N-DELETE request
Public Method | NEventReport | Send an N-EVENT-REPORT over an established DicomAssociation
Public Method | NGet | Sends an N-GET request
Public Method | NSet | Sends an N-SET request
Public Method | Open | Overloaded. Negotiate an association with a remote application.
Public Method | PcidFor | Indicates the presentaiton context ID which would be used to send an instance of the given SOP class
Public Method | SendInstances | Overloaded. Sends data over a DicomAssociation
Public Method | SetQuality | Set the quality factor for lossy compression
Top
See Also

Reference

DicomAssociation Class
DicomObjects Namespace


Abort Method

Abort Method

DicomObjects Namespace > DicomAssociation Class : Abort Method

The "Cause" of the Abort

The "Cause" of the Abort

Aborts an association
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Abort( _
   ByVal Reason As Byte, _
   ByVal Source As Byte _
)
'Usage

Dim instance As DicomAssociation
Dim Reason As Byte
Dim Source As Byte

instance.Abort(Reason, Source)
public void Abort(
   byte Reason,
   byte Source
)
public:
void Abort(
   byte Reason,
   byte Source
)

Parameters

Reason

The "Cause" of the Abort

Source

The "Cause" of the Abort

Remarks

An A-ABORT request is sent, and the association is then terminated.

The full meanings of the parameters are defined in DICOM Standard part 8, detailed as below:

Source

0 - DICOM UL service-user (initiated abort)

1 - Reserved

2 - DICOM UL service-provider (initiated abort)

Reason

0 - reason-not-specified

1 - unrecognized-PDU

2 - unexpected-PDU

3 - reserved

4 - unrecognized-PDU parameter

5 - unexpected-PDU parameter

6 - invalid-PDU-parameter value

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


Cancel Method

Cancel Method

DicomObjects Namespace > DicomAssociation Class : Cancel Method
Causes a C-CANCEL request to be sent to the remote AE asking it to terminate any outstanding image transfers
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Cancel()
'Usage

Dim instance As DicomAssociation

instance.Cancel()
public void Cancel()
public:
void Cancel();
Remarks
The C-CANCEL request is sent between images so a single image transfer may not be affected.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


Close Method (DicomAssociation)

Close Method (DicomAssociation)

DicomObjects Namespace > DicomAssociation Class : Close Method
Closes the association represented by a "stand-alone" DicomAssociation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Close()
'Usage

Dim instance As DicomAssociation

instance.Close()
public void Close()
public:
void Close();
Remarks
After a close method, a DicomAssociation object may be re-used, using Open to establish a new association. The isOpen property is set to false after this method.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


Dispose Method (DicomAssociation)

Dispose Method (DicomAssociation)

DicomObjects Namespace > DicomAssociation Class : Dispose Method
Releases the resources used by the DicomAssociation object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Sub Dispose()
'Usage

Dim instance As DicomAssociation

instance.Dispose()
public virtual void Dispose()
public:
virtual void Dispose();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


Echo Method (DicomAssociation)

Echo Method (DicomAssociation)

DicomObjects Namespace > DicomAssociation Class : Echo Method
Sends a verification request (C-ECHO) over a "stand-alone" DicomAssociation and returns the result
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function Echo() As Integer
'Usage

Dim instance As DicomAssociation
Dim value As Integer

value = instance.Echo()
public int Echo()
public:
int Echo();

Return Value

Integer
Remarks

DicomAssociation must be open before sending out C-ECHO request.

Although in theory the remote entity may return a status other than 0 to indicate an error, in most circumstances (such as remote machine turned off), this method will fail with a trappable error, such as "Fail to connection at TCP level".

The C-ECHO status can also be found in the LastStatus property of DicomAssociation.

For more details of sending C-ECHO via TLS, see Echo method of DicomGlobal object.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


Find Method (DicomAssociation)

Find Method (DicomAssociation)

DicomObjects Namespace > DicomAssociation Class : Find Method
Sends a C-FIND request
Overload List
Overload | Description
Find(QueryRoot,DicomDataSet) | Sends a C-FIND request
Find(String,DicomDataSet) | Sends a C-FIND request for Object with Private SOP Class UID
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


Find(QueryRoot,DicomDataSet) Method

Find(QueryRoot,DicomDataSet) Method

DicomObjects Namespace > DicomAssociation Class > Find Method : Find(QueryRoot,DicomDataSet) Method

The query root

The DataSet parameter defines the C-FIND searching criteria.

Sends a C-FIND request
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Find( _
   ByVal Root As QueryRoot, _
   ByVal DataSet As DicomDataSet _
)
'Usage

Dim instance As DicomAssociation
Dim Root As QueryRoot
Dim DataSet As DicomDataSet

instance.Find(Root, DataSet)
public void Find(
   QueryRoot Root,
   DicomDataSet DataSet
)
public:
void Find(
   QueryRoot Root,
   DicomDataSet^ DataSet
)

Parameters

Root

The query root

DataSet

The DataSet parameter defines the C-FIND searching criteria.

Remarks

The query to be performed is defined by the DataSet parameter, and this method is functionally equivalent to the Find method of the DicomQuery object.

Note that the QueryLevel value (0008,0052), must be included in the data set, but the dataset parameter MUST NOT contain any group 0x0000 elements (the group 0x0000 contains elements describing operation and some of the fields like MessageID, etc.)

Once the operation has completed, the result may be found in the ReturnedIdentifiers Collection.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members
Overload List


Find(String,DicomDataSet) Method

Find(String,DicomDataSet) Method

DicomObjects Namespace > DicomAssociation Class > Find Method : Find(String,DicomDataSet) Method

The Private SOP Class UID of the DICOM object

The DataSet parameter defines the C-FIND searching criteria.

Sends a C-FIND request for Object with Private SOP Class UID
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Find( _
   ByVal SopClassUID As String, _
   ByVal DataSet As DicomDataSet _
)
'Usage

Dim instance As DicomAssociation
Dim SopClassUID As String
Dim DataSet As DicomDataSet

instance.Find(SopClassUID, DataSet)
public void Find(
   string SopClassUID,
   DicomDataSet DataSet
)
public:
void Find(
   String^ SopClassUID,
   DicomDataSet^ DataSet
)

Parameters

SopClassUID

The Private SOP Class UID of the DICOM object

DataSet

The DataSet parameter defines the C-FIND searching criteria.

Remarks

This is for use with private SOP classes and it is rarely used and only being needed for very specialist use.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members
Overload List


Get Method (DicomAssociation)

Get Method (DicomAssociation)

DicomObjects Namespace > DicomAssociation Class : Get Method
Sends a C-GET request
Overload List
Overload | Description
Get(QueryRoot,DicomDataSet) | Sends a C-GET request
Get(QueryRoot,DicomDataSet,Boolean) | Sends a C-GET request
Get(String,DicomDataSet) | Sends a C-GET request for Object with Private SOP Class UID
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


Get(QueryRoot,DicomDataSet) Method

Get(QueryRoot,DicomDataSet) Method

DicomObjects Namespace > DicomAssociation Class > Get Method : Get(QueryRoot,DicomDataSet) Method

The query root

The identifier for the request

Sends a C-GET request
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Get( _
   ByVal Root As QueryRoot, _
   ByVal DataSet As DicomDataSet _
)
'Usage

Dim instance As DicomAssociation
Dim Root As QueryRoot
Dim DataSet As DicomDataSet

instance.Get(Root, DataSet)
public void Get(
   QueryRoot Root,
   DicomDataSet DataSet
)
public:
void Get(
   QueryRoot Root,
   DicomDataSet^ DataSet
)

Parameters

Root

The query root

DataSet

The identifier for the request

Remarks

The images to be retrieved are defined by the DataSet parameter.

Note that the QueryLevel value (0008,0052), must be included in the data set, but the dataset parameter MUST NOT contain any group 0x0000 elements (the group 0x0000 contains elements describing operation and some of the fields like MessageID, etc.)

Once the operation has completed, the images retrieved may be found in the ReturnedInstances collection.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members
Overload List


Get(QueryRoot,DicomDataSet,Boolean) Method

Get(QueryRoot,DicomDataSet,Boolean) Method

DicomObjects Namespace > DicomAssociation Class > Get Method : Get(QueryRoot,DicomDataSet,Boolean) Method

The query root

The identifier for the request

Specify if bulk data is required in the response

Sends a C-GET request
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Get( _
   ByVal Root As QueryRoot, _
   ByVal DataSet As DicomDataSet, _
   ByVal NoBulkData As Boolean _
)
'Usage

Dim instance As DicomAssociation
Dim Root As QueryRoot
Dim DataSet As DicomDataSet
Dim NoBulkData As Boolean

instance.Get(Root, DataSet, NoBulkData)
public void Get(
   QueryRoot Root,
   DicomDataSet DataSet,
   bool NoBulkData
)
public:
void Get(
   QueryRoot Root,
   DicomDataSet^ DataSet,
   bool NoBulkData
)

Parameters

Root

The query root

DataSet

The identifier for the request

NoBulkData

Specify if bulk data is required in the response

Remarks

The images to be retrieved are defined by the DataSet parameter.

Note that the QueryLevel value (0008,0052), must be included in the data set, but the dataset parameter MUST NOT contain any group 0x0000 elements (the group 0x0000 contains elements describing operation and some of the fields like MessageID, etc.)

Once the operation has completed, the images retrieved may be found in the ReturnedInstances collection.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members
Overload List


Get(String,DicomDataSet) Method

Get(String,DicomDataSet) Method

DicomObjects Namespace > DicomAssociation Class > Get Method : Get(String,DicomDataSet) Method

The Private SOPClassUID of the

The identifier for the request

Sends a C-GET request for Object with Private SOP Class UID
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Get( _
   ByVal SopClassUID As String, _
   ByVal DataSet As DicomDataSet _
)
'Usage

Dim instance As DicomAssociation
Dim SopClassUID As String
Dim DataSet As DicomDataSet

instance.Get(SopClassUID, DataSet)
public void Get(
   string SopClassUID,
   DicomDataSet DataSet
)
public:
void Get(
   String^ SopClassUID,
   DicomDataSet^ DataSet
)

Parameters

SopClassUID

The Private SOPClassUID of the

DataSet

The identifier for the request

Remarks

This is for use with private SOP classes and it is rarely used and only being needed for very specialist use.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members
Overload List


Move Method (DicomAssociation)

Move Method (DicomAssociation)

DicomObjects Namespace > DicomAssociation Class : Move Method
Sends a C-MOVE request
Overload List
Overload | Description
Move(QueryRoot,String,DicomDataSet) | Sends a C-MOVE request
Move(String,DicomDataSet) | Sends a C-MOVE request for Object with Private SOP Class UID
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


Move(QueryRoot,String,DicomDataSet) Method

Move(QueryRoot,String,DicomDataSet) Method

DicomObjects Namespace > DicomAssociation Class > Move Method : Move(QueryRoot,String,DicomDataSet) Method

The query root

The destination AE Title

The identifier for the C_MOVE request

Sends a C-MOVE request
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Move( _
   ByVal Root As QueryRoot, _
   ByVal Destination As String, _
   ByVal DataSet As DicomDataSet _
)
'Usage

Dim instance As DicomAssociation
Dim Root As QueryRoot
Dim Destination As String
Dim DataSet As DicomDataSet

instance.Move(Root, Destination, DataSet)
public void Move(
   QueryRoot Root,
   string Destination,
   DicomDataSet DataSet
)
public:
void Move(
   QueryRoot Root,
   String^ Destination,
   DicomDataSet^ DataSet
)

Parameters

Root

The query root

Destination

The destination AE Title

DataSet

The identifier for the C_MOVE request

Remarks

The images to be moved are defined by the DataSet parameter.

Note that the QueryLevel value (0008,0052), must be included in the data set, but the dataset parameter MUST NOT contain any group 0x0000 elements (the group 0x0000 contains elements describing operation and some of the fields like MessageID, etc.)

Once the operation has completed, the result codes may be found in the Status property.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members
Overload List


Move(String,DicomDataSet) Method

Move(String,DicomDataSet) Method

DicomObjects Namespace > DicomAssociation Class > Move Method : Move(String,DicomDataSet) Method

The Private SOP Class UID of the DICOM object

The identifier for the C_MOVE request

Sends a C-MOVE request for Object with Private SOP Class UID
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Move( _
   ByVal SopClassUID As String, _
   ByVal DataSet As DicomDataSet _
)
'Usage

Dim instance As DicomAssociation
Dim SopClassUID As String
Dim DataSet As DicomDataSet

instance.Move(SopClassUID, DataSet)
public void Move(
   string SopClassUID,
   DicomDataSet DataSet
)
public:
void Move(
   String^ SopClassUID,
   DicomDataSet^ DataSet
)

Parameters

SopClassUID

The Private SOP Class UID of the DICOM object

DataSet

The identifier for the C_MOVE request

Remarks

This is for use with private SOP classes and it is rarely used and only being needed for very specialist use.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members
Overload List


NAction Method

NAction Method

DicomObjects Namespace > DicomAssociation Class : NAction Method

The requested SOP Class UID

The requested SOP InstanceUID

Context dependent Action code

The attributes to be set, with their values

Sends an N-ACTION request
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub NAction( _
   ByVal SOPClassUID As String, _
   ByVal InstanceUID As String, _
   ByVal ActionID As Integer, _
   ByVal DataSet As DicomDataSet _
)
'Usage

Dim instance As DicomAssociation
Dim SOPClassUID As String
Dim InstanceUID As String
Dim ActionID As Integer
Dim DataSet As DicomDataSet

instance.NAction(SOPClassUID, InstanceUID, ActionID, DataSet)
public void NAction(
   string SOPClassUID,
   string InstanceUID,
   int ActionID,
   DicomDataSet DataSet
)
public:
void NAction(
   String^ SOPClassUID,
   String^ InstanceUID,
   int ActionID,
   DicomDataSet^ DataSet
)

Parameters

SOPClassUID

The requested SOP Class UID

InstanceUID

The requested SOP InstanceUID

ActionID

Context dependent Action code

DataSet

The attributes to be set, with their values

Remarks

This method sends an N-ACTION request, using the quoted SOP Class and Instance UIDs, ActionID and DataSet.

In many cases, a dataset is not required, in which case an empty dataset should be used.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


NCreate Method

NCreate Method

DicomObjects Namespace > DicomAssociation Class : NCreate Method

The requested SOP Class UID

The requested SOP InstanceUID

The attributes to be set, with their values

Sends an N-CREATE request
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub NCreate( _
   ByVal SOPClassUID As String, _
   ByVal InstanceUID As String, _
   ByVal DataSet As DicomDataSet _
)
'Usage

Dim instance As DicomAssociation
Dim SOPClassUID As String
Dim InstanceUID As String
Dim DataSet As DicomDataSet

instance.NCreate(SOPClassUID, InstanceUID, DataSet)
public void NCreate(
   string SOPClassUID,
   string InstanceUID,
   DicomDataSet DataSet
)
public:
void NCreate(
   String^ SOPClassUID,
   String^ InstanceUID,
   DicomDataSet^ DataSet
)

Parameters

SOPClassUID

The requested SOP Class UID

InstanceUID

The requested SOP InstanceUID

DataSet

The attributes to be set, with their values

Remarks

This method sends an N-CREATE request, using the quoted SOP Class and Instance UIDs.

If appropriate, the SCP may use the values in DataSet to initialise the object.

If the operation succeeds, then the UID of the object created may be found, once the operation has completed, in the LastInstanceUID property.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


NDelete Method

NDelete Method

DicomObjects Namespace > DicomAssociation Class : NDelete Method

The requested SOP Class UID

The requested SOP InstanceUID

Sends an N-DELETE request
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub NDelete( _
   ByVal SOPClassUID As String, _
   ByVal InstanceUID As String _
)
'Usage

Dim instance As DicomAssociation
Dim SOPClassUID As String
Dim InstanceUID As String

instance.NDelete(SOPClassUID, InstanceUID)
public void NDelete(
   string SOPClassUID,
   string InstanceUID
)
public:
void NDelete(
   String^ SOPClassUID,
   String^ InstanceUID
)

Parameters

SOPClassUID

The requested SOP Class UID

InstanceUID

The requested SOP InstanceUID

Remarks

This method sends an N-DELETE request, using the quoted SOP Class and Instance UIDs.

No other information is permitted in an N-DELETE command.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


NEventReport Method

NEventReport Method

DicomObjects Namespace > DicomAssociation Class : NEventReport Method

The requested SOP Class UID

The requested SOP InstanceUID

Event ID, as defined by the Class UID

Associated Data

Send an N-EVENT-REPORT over an established DicomAssociation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub NEventReport( _
   ByVal SOPClassUID As String, _
   ByVal InstanceUID As String, _
   ByVal EventID As Integer, _
   ByVal DataSet As DicomDataSet _
)
'Usage

Dim instance As DicomAssociation
Dim SOPClassUID As String
Dim InstanceUID As String
Dim EventID As Integer
Dim DataSet As DicomDataSet

instance.NEventReport(SOPClassUID, InstanceUID, EventID, DataSet)
public void NEventReport(
   string SOPClassUID,
   string InstanceUID,
   int EventID,
   DicomDataSet DataSet
)
public:
void NEventReport(
   String^ SOPClassUID,
   String^ InstanceUID,
   int EventID,
   DicomDataSet^ DataSet
)

Parameters

SOPClassUID

The requested SOP Class UID

InstanceUID

The requested SOP InstanceUID

EventID

Event ID, as defined by the Class UID

DataSet

Associated Data

Remarks

Before using this method, it is important to ensure that the required SOP Class UID has been negotiated with the remote entity. In some cases such as when using Storage Commitment, reverse role SCU/SCP negotiation may also be necessary.

The return status can be found in the LastStatus property of DicomAssociation object.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


NGet Method

NGet Method

DicomObjects Namespace > DicomAssociation Class : NGet Method

The requested SOP Class UID

The requested SOP InstanceUID

The attributes requested

Sends an N-GET request
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub NGet( _
   ByVal SOPClassUID As String, _
   ByVal InstanceUID As String, _
   ByVal DataSet As DicomDataSet _
)
'Usage

Dim instance As DicomAssociation
Dim SOPClassUID As String
Dim InstanceUID As String
Dim DataSet As DicomDataSet

instance.NGet(SOPClassUID, InstanceUID, DataSet)
public void NGet(
   string SOPClassUID,
   string InstanceUID,
   DicomDataSet DataSet
)
public:
void NGet(
   String^ SOPClassUID,
   String^ InstanceUID,
   DicomDataSet^ DataSet
)

Parameters

SOPClassUID

The requested SOP Class UID

InstanceUID

The requested SOP InstanceUID

DataSet

The attributes requested

Return Value

This method sends an N-GET request, using the quoted SOP Class and Instance UIDs. The values of the attributes in the DataSet are irrelevant, as it is used solely as a list of attributes whose values are to be retrieved.

The returned values may be found, once the operation has completed, in the ReturnedIdentifier property.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


NSet Method

NSet Method

DicomObjects Namespace > DicomAssociation Class : NSet Method

The requested SOP Class UID

The requested SOP InstanceUID

The attributes to be set, with their values

Sends an N-SET request
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub NSet( _
   ByVal SOPClassUID As String, _
   ByVal InstanceUID As String, _
   ByVal DataSet As DicomDataSet _
)
'Usage

Dim instance As DicomAssociation
Dim SOPClassUID As String
Dim InstanceUID As String
Dim DataSet As DicomDataSet

instance.NSet(SOPClassUID, InstanceUID, DataSet)
public void NSet(
   string SOPClassUID,
   string InstanceUID,
   DicomDataSet DataSet
)
public:
void NSet(
   String^ SOPClassUID,
   String^ InstanceUID,
   DicomDataSet^ DataSet
)

Parameters

SOPClassUID

The requested SOP Class UID

InstanceUID

The requested SOP InstanceUID

DataSet

The attributes to be set, with their values

Remarks

This method sends an N-SET request, using the quoted SOP Class and Instance UIDs.

If values are returned they may be found, once the operation has completed, in the ReturnedIdentifier property.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


Open Method (DicomAssociation)

Open Method (DicomAssociation)

DicomObjects Namespace > DicomAssociation Class : Open Method
Negotiate an association with a remote application.
Overload List
Overload | Description
Open(String,Int32,String,String) | Open and negotiate a new DICOM Association
Open(Socket,Stream,String,String) | Open a DICOM association over an independently created System.Net.Sockets.NetworkStream
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


Open(String,Int32,String,String) Method

Open(String,Int32,String,String) Method

DicomObjects Namespace > DicomAssociation Class > Open Method : Open(String,Int32,String,String) Method

Network address (as dotted notation or resolvable name) to which the association is to be made

Port on which remote application is listening

Name to quote for this Application Entity

Name of remote Application Entity

Open and negotiate a new DICOM Association
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Open( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAE As String, _
   ByVal CalledAE As String _
)
'Usage

Dim instance As DicomAssociation
Dim Node As String
Dim Port As Integer
Dim CallingAE As String
Dim CalledAE As String

instance.Open(Node, Port, CallingAE, CalledAE)
public void Open(
   string Node,
   int Port,
   string CallingAE,
   string CalledAE
)
public:
void Open(
   String^ Node,
   int Port,
   String^ CallingAE,
   String^ CalledAE
)

Parameters

Node

Network address (as dotted notation or resolvable name) to which the association is to be made

Port

Port on which remote application is listening

CallingAE

Name to quote for this Application Entity

CalledAE

Name of remote Application Entity

Remarks

This method returns, after the connection has been established. If there is a protocol failure, then a trappable DicomException is thrown.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members
Overload List


Open(Socket,Stream,String,String) Method

Open(Socket,Stream,String,String) Method

DicomObjects Namespace > DicomAssociation Class > Open Method : Open(Socket,Stream,String,String) Method
Specifies the underlying Socket through which an association should be made.

The NetworkStream via which the connection is to be made

Name to quote for this Application Entity

Name of remote Application Entity

Open a DICOM association over an independently created System.Net.Sockets.NetworkStream
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Open( _
   ByVal Socket As Socket, _
   ByVal Stream As Stream, _
   ByVal CallingAE As String, _
   ByVal CalledAE As String _
)
'Usage

Dim instance As DicomAssociation
Dim Socket As Socket
Dim Stream As Stream
Dim CallingAE As String
Dim CalledAE As String

instance.Open(Socket, Stream, CallingAE, CalledAE)
public void Open(
   Socket Socket,
   Stream Stream,
   string CallingAE,
   string CalledAE
)
public:
void Open(
   Socket^ Socket,
   Stream^ Stream,
   String^ CallingAE,
   String^ CalledAE
)

Parameters

Socket
Specifies the underlying Socket through which an association should be made.
Stream

The NetworkStream via which the connection is to be made

CallingAE

Name to quote for this Application Entity

CalledAE

Name of remote Application Entity

Remarks

This version is useful in some security scenarios, as the NetworkStream may be negotiated and verified before starting DICOM negoations. Note that both the NetworkStream and underlying Socket need to be specified, as some controls (such as timeout values) are only valid when applied to the socket. This method returns, after the connection has been established. If there is a protocol failure, then a trappable DicomException is thrown.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members
Overload List


PcidFor Method

PcidFor Method

DicomObjects Namespace > DicomAssociation Class : PcidFor Method
The SOP class to test for
Indicates the presentaiton context ID which would be used to send an instance of the given SOP class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function PcidFor( _
   ByVal SOPClass As String _
) As Byte
'Usage

Dim instance As DicomAssociation
Dim SOPClass As String
Dim value As Byte

value = instance.PcidFor(SOPClass)
public byte PcidFor(
   string SOPClass
)
public:
byte PcidFor(
   String^ SOPClass
)

Parameters

SOPClass
The SOP class to test for

Return Value

Either the presentation context ID which would be used to send an instance of the stated SOP class, or 0 if so suitable, agreed presentation context exists.

Remarks

This routines uses the properties AgreedContexts, MetaSOPClass, PreferredPCID, PreferredTS and PreferredTSList

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


SendInstances Method

SendInstances Method

DicomObjects Namespace > DicomAssociation Class : SendInstances Method
Sends data over a DicomAssociation
Overload List
Overload | Description
SendInstances(IEnumerable<DicomDataSet>) | Sends images over a DicomAssociation
SendInstances(DicomDataSet) | Sends an DataSet over a DicomAssociation
SendInstances(Stream) | Sends data which is contained in a System IO Stream over a DicomAssociation
SendInstances(String) | Sends a file referenced by a string over a DicomAssociation
SendInstances(IEnumerable<String>) | Sends multiple files referenced by a collection of strings over a DicomAssociation
SendInstances(DicomDataSet,String) | Sends an DataSet over a DicomAssociation with a defined abstract syntax.
SendInstances(DicomImage) | Sends a DicomImage over a DicomAssociation
SendInstances(IEnumerable<DicomImage>) | Sends a collections of DicomImages over a DicomAssociation
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


SendInstances(IEnumerable<DicomDataSet>) Method

SendInstances(IEnumerable<DicomDataSet>) Method

DicomObjects Namespace > DicomAssociation Class > SendInstances Method : SendInstances(IEnumerable<DicomDataSet>) Method
The DicomDataSetCollection to send
Sends images over a DicomAssociation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SendInstances( _
   ByVal DataSets As IEnumerable(Of DicomDataSet) _
)
'Usage

Dim instance As DicomAssociation
Dim DataSets As IEnumerable(Of DicomDataSet)

instance.SendInstances(DataSets)
public void SendInstances(
   IEnumerable<DicomDataSet> DataSets
)
public:
void SendInstances(
   IEnumerable<DicomDataSet^>^ DataSets
)

Parameters

DataSets
The DicomDataSetCollection to send
Remarks

For automatically generated DicomAssociation objects, this method is used in response to a C-GET or C-MOVE request, but it may also be used to send any images the client chooses over a "stand-alone" DicomAssociation.

Data sent by this method are sent either to the requesting application (C-GET) or to another (C-MOVE or stand-alone) as a series of C-STORE actions.

For C-MOVE operations, if this Association has been linked internally to the request (i.e. if it is the DicomObjects.EventArguments.QueryReceivedArgs.InstanceAssociation), then:

  • "pending" responses are generated automatically by this method.
  • The number of images remaining, failed, warning, and successful associated with the request are automatically updated by the method, and the Failures property maintains a list of refused images UIDs. If all images are to be returned via a single call to SendImages, then no specific client action is required, as NumberRemaining is set automatically to the number of images in Data if previously 0. If, however, the client wishes to return images via multiple calls to this method (e.g. to enable pending status messages), then NumberRemaining must be set correctly before the first image is returned.

For C-MOVE requests, or "stand-alone" DicomAssociation objects, Open must be called before this method.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members
Overload List


SendInstances(DicomDataSet) Method

SendInstances(DicomDataSet) Method

DicomObjects Namespace > DicomAssociation Class > SendInstances Method : SendInstances(DicomDataSet) Method
The DicomDataSet to send
Sends an DataSet over a DicomAssociation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SendInstances( _
   ByVal DataSet As DicomDataSet _
)
'Usage

Dim instance As DicomAssociation
Dim DataSet As DicomDataSet

instance.SendInstances(DataSet)
public void SendInstances(
   DicomDataSet DataSet
)
public:
void SendInstances(
   DicomDataSet^ DataSet
)

Parameters

DataSet
The DicomDataSet to send
Remarks

For automatically generated DicomAssociation objects, this method is used in response to a C-GET or C-MOVE request, but it may also be used to send any images the client chooses over a "stand-alone" DicomAssociation.

Data sent by this method are sent either to the requesting application (C-GET) or to another (C-MOVE or stand-alone) as a series of C-STORE actions.

For C-MOVE operations, if this Association has been linked internally to the request (i.e. if it is the DicomObjects.EventArguments.QueryReceivedArgs.InstanceAssociation), then:

  • "pending" responses are generated automatically by this method.
  • The number of images remaining, failed, warning, and successful associated with the request are automatically updated by the method, and the Failures property maintains a list of refused images UIDs. If all images are to be returned via a single call to SendImages, then no specific client action is required, as NumberRemaining is set automatically to the number of images in Data if previously 0. If, however, the client wishes to return images via multiple calls to this method (e.g. to enable pending status messages), then NumberRemaining must be set correctly before the first image is returned.

For C-MOVE requests, or "stand-alone" DicomAssociation objects, Open must be called before this method.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members
Overload List


SendInstances(Stream) Method

SendInstances(Stream) Method

DicomObjects Namespace > DicomAssociation Class > SendInstances Method : SendInstances(Stream) Method

The Stream which contains the data to be transmitted

Sends data which is contained in a System IO Stream over a DicomAssociation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SendInstances( _
   ByVal Stream As Stream _
)
'Usage

Dim instance As DicomAssociation
Dim Stream As Stream

instance.SendInstances(Stream)
public void SendInstances(
   Stream Stream
)
public:
void SendInstances(
   Stream^ Stream
)

Parameters

Stream

The Stream which contains the data to be transmitted

Remarks

For automatically generated DicomAssociation objects, this method is used in response to a C-GET or C-MOVE request, but it may also be used to send any images the client chooses over a "stand-alone" DicomAssociation.

Data sent by this method are sent either to the requesting application (C-GET) or to another (C-MOVE or stand-alone) as a series of C-STORE actions.

For C-MOVE operations, if this Association has been linked internally to the request (i.e. if it is the DicomObjects.EventArguments.QueryReceivedArgs.InstanceAssociation), then:

  • "pending" responses are generated automatically by this method.
  • The number of images remaining, failed, warning, and successful associated with the request are automatically updated by the method, and the Failures property maintains a list of refused images UIDs. If all images are to be returned via a single call to SendImages, then no specific client action is required, as NumberRemaining is set automatically to the number of images in Data if previously 0. If, however, the client wishes to return images via multiple calls to this method (e.g. to enable pending status messages), then NumberRemaining must be set correctly before the first image is returned.

For C-MOVE requests, or "stand-alone" DicomAssociation objects, Open must be called before this method.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members
Overload List


SendInstances(String) Method

SendInstances(String) Method

DicomObjects Namespace > DicomAssociation Class > SendInstances Method : SendInstances(String) Method

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

Sends a file referenced by a string over a DicomAssociation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SendInstances( _
   ByVal Filename As String _
)
'Usage

Dim instance As DicomAssociation
Dim Filename As String

instance.SendInstances(Filename)
public void SendInstances(
   string Filename
)
public:
void SendInstances(
   String^ Filename
)

Parameters

Filename

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

Remarks

For automatically generated DicomAssociation objects, this method is used in response to a C-GET or C-MOVE request, but it may also be used to send any images the client chooses over a "stand-alone" DicomAssociation.

Data sent by this method are sent either to the requesting application (C-GET) or to another (C-MOVE or stand-alone) as a series of C-STORE actions.

For C-MOVE operations, if this Association has been linked internally to the request (i.e. if it is the DicomObjects.EventArguments.QueryReceivedArgs.InstanceAssociation), then:

  • "pending" responses are generated automatically by this method.
  • The number of images remaining, failed, warning, and successful associated with the request are automatically updated by the method, and the Failures property maintains a list of refused images UIDs. If all images are to be returned via a single call to SendImages, then no specific client action is required, as NumberRemaining is set automatically to the number of images in Data if previously 0. If, however, the client wishes to return images via multiple calls to this method (e.g. to enable pending status messages), then NumberRemaining must be set correctly before the first image is returned.

For C-MOVE requests, or "stand-alone" DicomAssociation objects, Open must be called before this method.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members
Overload List


SendInstances(IEnumerable<String>) Method

SendInstances(IEnumerable<String>) Method

DicomObjects Namespace > DicomAssociation Class > SendInstances Method : SendInstances(IEnumerable<String>) Method
The filenames of the files to send
Sends multiple files referenced by a collection of strings over a DicomAssociation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SendInstances( _
   ByVal Filenames As IEnumerable(Of String) _
)
'Usage

Dim instance As DicomAssociation
Dim Filenames As IEnumerable(Of String)

instance.SendInstances(Filenames)
public void SendInstances(
   IEnumerable<string> Filenames
)
public:
void SendInstances(
   IEnumerable<String^>^ Filenames
)

Parameters

Filenames
The filenames of the files to send
Remarks

For automatically generated DicomAssociation objects, this method is used in response to a C-GET or C-MOVE request, but it may also be used to send any images the client chooses over a "stand-alone" DicomAssociation.

Data sent by this method are sent either to the requesting application (C-GET) or to another (C-MOVE or stand-alone) as a series of C-STORE actions.

For C-MOVE operations, if this Association has been linked internally to the request (i.e. if it is the DicomObjects.EventArguments.QueryReceivedArgs.InstanceAssociation), then:

  • "pending" responses are generated automatically by this method.
  • The number of images remaining, failed, warning, and successful associated with the request are automatically updated by the method, and the Failures property maintains a list of refused images UIDs. If all images are to be returned via a single call to SendImages, then no specific client action is required, as NumberRemaining is set automatically to the number of images in Data if previously 0. If, however, the client wishes to return images via multiple calls to this method (e.g. to enable pending status messages), then NumberRemaining must be set correctly before the first image is returned.

For C-MOVE requests, or "stand-alone" DicomAssociation objects, Open must be called before this method.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members
Overload List


SendInstances(DicomDataSet,String) Method

SendInstances(DicomDataSet,String) Method

DicomObjects Namespace > DicomAssociation Class > SendInstances Method : SendInstances(DicomDataSet,String) Method
The DicomDataSet to send
The abstract syntax to use
Sends an DataSet over a DicomAssociation with a defined abstract syntax.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SendInstances( _
   ByVal DataSet As DicomDataSet, _
   ByVal AbstractSyntax As String _
)
'Usage

Dim instance As DicomAssociation
Dim DataSet As DicomDataSet
Dim AbstractSyntax As String

instance.SendInstances(DataSet, AbstractSyntax)
public void SendInstances(
   DicomDataSet DataSet,
   string AbstractSyntax
)
public:
void SendInstances(
   DicomDataSet^ DataSet,
   String^ AbstractSyntax
)

Parameters

DataSet
The DicomDataSet to send
AbstractSyntax
The abstract syntax to use
Remarks

The primary purpose of this overload is to send data where the asbtract syntax cannot be determined from the SOP class of the data being sent (e.g. when using meta-SOP classes), but it may also be useful when dealing with faulty remote entities.

For automatically generated DicomAssociation objects, this method is used in response to a C-GET or C-MOVE request, but it may also be used to send any images the client chooses over a "stand-alone" DicomAssociation.

Data sent by this method are sent either to the requesting application (C-GET) or to another (C-MOVE or stand-alone) as a series of C-STORE actions.

For C-MOVE operations, if this Association has been linked internally to the request (i.e. if it is the DicomObjects.EventArguments.QueryReceivedArgs.InstanceAssociation), then:

  • "pending" responses are generated automatically by this method.
  • The number of images remaining, failed, warning, and successful associated with the request are automatically updated by the method, and the Failures property maintains a list of refused images UIDs. If all images are to be returned via a single call to SendImages, then no specific client action is required, as NumberRemaining is set automatically to the number of images in Data if previously 0. If, however, the client wishes to return images via multiple calls to this method (e.g. to enable pending status messages), then NumberRemaining must be set correctly before the first image is returned.

For C-MOVE requests, or "stand-alone" DicomAssociation objects, Open must be called before this method.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members
Overload List


SendInstances(DicomImage) Method

SendInstances(DicomImage) Method

DicomObjects Namespace > DicomAssociation Class > SendInstances Method : SendInstances(DicomImage) Method
The Image to send
Sends a DicomImage over a DicomAssociation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SendInstances( _
   ByVal Image As DicomImage _
)
'Usage

Dim instance As DicomAssociation
Dim Image As DicomImage

instance.SendInstances(Image)
public void SendInstances(
   DicomImage Image
)
public:
void SendInstances(
   DicomImage^ Image
)

Parameters

Image
The Image to send
Remarks

For automatically generated DicomAssociation objects, this method is used in response to a C-GET or C-MOVE request, but it may also be used to send any images the client chooses over a "stand-alone" DicomAssociation.

Data sent by this method are sent either to the requesting application (C-GET) or to another (C-MOVE or stand-alone) as a series of C-STORE actions.

For C-MOVE operations, if this Association has been linked internally to the request (i.e. if it is the DicomObjects.EventArguments.QueryReceivedArgs.InstanceAssociation), then:

  • "pending" responses are generated automatically by this method.
  • The number of images remaining, failed, warning, and successful associated with the request are automatically updated by the method, and the Failures property maintains a list of refused images UIDs. If all images are to be returned via a single call to SendImages, then no specific client action is required, as NumberRemaining is set automatically to the number of images in Data if previously 0. If, however, the client wishes to return images via multiple calls to this method (e.g. to enable pending status messages), then NumberRemaining must be set correctly before the first image is returned.

For C-MOVE requests, or "stand-alone" DicomAssociation objects, Open must be called before this method.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members
Overload List


SendInstances(IEnumerable<DicomImage>) Method

SendInstances(IEnumerable<DicomImage>) Method

DicomObjects Namespace > DicomAssociation Class > SendInstances Method : SendInstances(IEnumerable<DicomImage>) Method
The Images to send
Sends a collections of DicomImages over a DicomAssociation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SendInstances( _
   ByVal Images As IEnumerable(Of DicomImage) _
)
'Usage

Dim instance As DicomAssociation
Dim Images As IEnumerable(Of DicomImage)

instance.SendInstances(Images)
public void SendInstances(
   IEnumerable<DicomImage> Images
)
public:
void SendInstances(
   IEnumerable<DicomImage^>^ Images
)

Parameters

Images
The Images to send
Remarks

For automatically generated DicomAssociation objects, this method is used in response to a C-GET or C-MOVE request, but it may also be used to send any images the client chooses over a "stand-alone" DicomAssociation.

Data sent by this method are sent either to the requesting application (C-GET) or to another (C-MOVE or stand-alone) as a series of C-STORE actions.

For C-MOVE operations, if this Association has been linked internally to the request (i.e. if it is the DicomObjects.EventArguments.QueryReceivedArgs.InstanceAssociation), then:

  • "pending" responses are generated automatically by this method.
  • The number of images remaining, failed, warning, and successful associated with the request are automatically updated by the method, and the Failures property maintains a list of refused images UIDs. If all images are to be returned via a single call to SendImages, then no specific client action is required, as NumberRemaining is set automatically to the number of images in Data if previously 0. If, however, the client wishes to return images via multiple calls to this method (e.g. to enable pending status messages), then NumberRemaining must be set correctly before the first image is returned.

For C-MOVE requests, or "stand-alone" DicomAssociation objects, Open must be called before this method.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members
Overload List


SetQuality Method

SetQuality Method

DicomObjects Namespace > DicomAssociation Class : SetQuality Method

The transfer syntax to which this quality factor applies

The quality to be set

Set the quality factor for lossy compression
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetQuality( _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object _
)
'Usage

Dim instance As DicomAssociation
Dim TransferSyntax As String
Dim Quality As Object

instance.SetQuality(TransferSyntax, Quality)
public void SetQuality(
   string TransferSyntax,
   object Quality
)
public:
void SetQuality(
   String^ TransferSyntax,
   Object^ Quality
)

Parameters

TransferSyntax

The transfer syntax to which this quality factor applies

Quality

The quality to be set

Remarks

An application does not necessarily "know" which images will be sent by which transfer syntax, as the remote AE may have accepted different transfer syntaxes for different abstract syntaxes, and a common quality factor for an association would not therefore be appropriate. Instead, this method allows quality to be set for a specific transfer syntax.

The following limitations apply:

  • This method is only meaningful when used in an application actually sending an image (normally the SCP), as there is no official means in DICOM for the SCU to send this information to the SCP.
  • Where an image is already compressed using the transfer syntax required, it is not decompressed and recompressed, so this value is ignored. If absolutely necessary, this can be over-ridden by applying the DecompressAll method to the image before sending it, but multiple compressions do have an adverse effect on image quality.

At present, the only syntaxes to which this method applies are TransferSyntaxes.JPEGBaseline (1.2.840.10008.1.2.4.50), TransferSyntaxes.JPEGExtended (1.2.840.10008.1.2.4.51), TransferSyntaxes.JPEG2000Lossy (1.2.840.10008.1.2.4.90), and TransferSyntaxes.JPEG2000Lossy (1.2.840.10008.1.2.4.91), though it is also made available to private syntaxes defined through .

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


DicomAssociation Class Properties

DicomAssociation Class Properties

DicomObjects Namespace : DicomAssociation Class

For a list of all members of this type, see DicomAssociation members.

Public Properties
 | Name | Description
Public Property | AgreedContexts | The Presentation Contexts associated with this DicomAssociation
Public Property | AssociationNumber | Returns the association number of current connection.
Public Property | BytesReceived | Approximate Measures of Network Input
Public Property | BytesSent | Approximate measures of Network Output
Public Property | CalledAET | Provides information about the remote application entity
Public Property | CallingAET | Provides information about the calling application entity
Public Property | Cancelled | Indicates that the remote AE has issued a C-CANCEL request.
Public Property | CheckForCancel | Control whether to check for incoming C-CANCEL asynchronous messages
Public Property | CoercionSOP | SOP Class to which images should be coerced if peer does not accept true SOP class
static (Shared in Visual Basic) | DefaultThrowStatusException | The value intially assigned for the ThrowStatusException of new DicomAssociation objects.
Public Property | Identity | The user identity to use for an association
Public Property | ImplementationName | Returns the Implementation Version Name of the Connecting AE
Public Property | ImplementationUID | Returns the Implementation Class UID of the Connecting AE
Public Property | IsOpen | Indicates whether a DicomAssociation is open
Public Property | LastCommand | Returns the last command in the current association.
Public Property | LastError | Returns the last error status from LastCommand.
Public Property | LastInstanceUID | Holds the InstanceUID created or used by the last normalised operation.
Public Property | LastOperation | Returns the last operation in the current association.
Public Property | LastStatus | Shortcut for the first element of the Status property
Public Property | LocalIP | Provide information about which local interface the remote application entity called
Public Property | LocalPort | Provide information about which local port the remote application entity called
Public Property | LogLevel | Controls the level of logging for this particular Association.
Public Property | MetaSOPClass | Determines the Abstract Syntax used for normalised operations
Public Property | MoveOriginator | The DicomAssociation object which initiated the C-MOVE resulting in the current C-STORE
Public Property | PreferredPCID | Provides guidance for the choice of presentation context
Public Property | PreferredTS | Provides guidance for the choice of presentation context
Public Property | PreferredTSList | Provides guidance for the choice of presentation context
Public Property | ReadBehaviour | Specific behaviours to use when receiving data on this association.
Public Property | RemoteIP | Provides information about the remote application entity
Public Property | Request | This contains the list of attributes to be matched, as specified in the DICOM standard
Public Property | RequestedContexts | The Presentation Contexts associated with this DicomAssociation
Public Property | RequestingQuery | Provides a linkage to the primary C-MOVE request.
Public Property | ReturnedCommands | The command datasets returned in response to the last operation
Public Property | ReturnedIdentifier | Hold data returned from outgoing operations
Public Property | ReturnedIdentifiers | Hold data returned from outgoing operations
Public Property | ReturnedInstances | Hold instances returned from outgoing C-GET operations
Public Property | SslStream | Returns the secure Stream object
Public Property | Status | Array containing the status codes returned by the last SendInstances or Echo action
Public Property | Tag | A general purpose Tag for developer use
Public Property | ThrowStatusException | Controls whether an exception is generated when a non-zero status is received.
Public Property | WriteBehaviour | Specific behaviours to use when sending data on this association.
Top
See Also

Reference

DicomAssociation Class
DicomObjects Namespace


AgreedContexts Property

AgreedContexts Property

DicomObjects Namespace > DicomAssociation Class : AgreedContexts Property
The Presentation Contexts associated with this DicomAssociation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property AgreedContexts As DicomContextCollection
'Usage

Dim instance As DicomAssociation
Dim value As DicomContextCollection

value = instance.AgreedContexts
public DicomContextCollection AgreedContexts {get;}
public:
property DicomContextCollection^ AgreedContexts {
   DicomContextCollection^ get();
}
Remarks

This is a powerful feature, allowing a client program as much, or as little control over presentation contexts as it wishes. the collection returned by this property may be used To check the presentation contexts available on an established association (incoming or outgoing).

IMPORTANT:

Note that operations relating to the acceptance of presentation contexts are not possible on this DicomContexts object or its contained DicomContext object. Such operations are only possible from within the AssociationRequest event.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


AssociationNumber Property

AssociationNumber Property

DicomObjects Namespace > DicomAssociation Class : AssociationNumber Property
Returns the association number of current connection.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property AssociationNumber As Integer
'Usage

Dim instance As DicomAssociation
Dim value As Integer

value = instance.AssociationNumber
public int AssociationNumber {get;}
public:
property int AssociationNumber {
   int get();
}
Remarks
This property is read only and returns 0 if current connection is null.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


BytesReceived Property

BytesReceived Property

DicomObjects Namespace > DicomAssociation Class : BytesReceived Property
Approximate Measures of Network Input
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property BytesReceived As Long
'Usage

Dim instance As DicomAssociation
Dim value As Long

value = instance.BytesReceived
public long BytesReceived {get;}
public:
property int64 BytesReceived {
   int64 get();
}
Remarks
This property report only approximate values, but are useful for updating of status bars etc.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


BytesSent Property

BytesSent Property

DicomObjects Namespace > DicomAssociation Class : BytesSent Property
Approximate measures of Network Output
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property BytesSent As Long
'Usage

Dim instance As DicomAssociation
Dim value As Long

value = instance.BytesSent
public long BytesSent {get;}
public:
property int64 BytesSent {
   int64 get();
}
Remarks
This property reports only approximate values, but is useful for updating of status bars etc.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


CalledAET Property

CalledAET Property

DicomObjects Namespace > DicomAssociation Class : CalledAET Property
Provides information about the remote application entity
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property CalledAET As String
'Usage

Dim instance As DicomAssociation
Dim value As String

value = instance.CalledAET
public string CalledAET {get;}
public:
property String^ CalledAET {
   String^ get();
}
Remarks

CallingAET, CalledAET and RemoteIP, these property relate to open associations, and can be accessed at any time after the association has been established. For �outgoing� DicomAssociation objects, they refer to the outgoing association and for �incoming� DicomAssociation objects such as those created automatically as part of incoming C-STORE (async), C-FIND of C-GET requests, they relate to the association received. For C-MOVE, they continue to refer to the incoming association even once an outgoing association to carry the images has been established.

For details of the interface and port, see LocalIP and LocalPort properties.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


CallingAET Property

CallingAET Property

DicomObjects Namespace > DicomAssociation Class : CallingAET Property
Provides information about the calling application entity
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property CallingAET As String
'Usage

Dim instance As DicomAssociation
Dim value As String

value = instance.CallingAET
public string CallingAET {get;}
public:
property String^ CallingAET {
   String^ get();
}
Remarks

CallingAET, CalledAET and RemoteIP, these property relate to open associations, and can be accessed at any time after the association has been established. For �outgoing� DicomAssociation objects, they refer to the outgoing association and for �incoming� DicomAssociation objects such as those created automatically as part of incoming C-STORE (async), C-FIND of C-GET requests, they relate to the association received. For C-MOVE, they continue to refer to the incoming association even once an outgoing association to carry the images has been established.

For details of the interface and port, see LocalIP and LocalPort properties.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


Cancelled Property

Cancelled Property

DicomObjects Namespace > DicomAssociation Class : Cancelled Property
Indicates that the remote AE has issued a C-CANCEL request.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Cancelled As Boolean
'Usage

Dim instance As DicomAssociation
Dim value As Boolean

value = instance.Cancelled
public bool Cancelled {get;}
public:
property bool Cancelled {
   bool get();
}
Remarks
C-CANCEL requests are handled internally by DicomObjects, with the result that no further images are sent on the connection, and a status of Cancelled is automatically returned to the peer. In order to prevent errors from operations on a closed association, operations such as SendInstances are still accepted but are silently ignored. This property is therefore provided solely as an optimisation, to prevent unnecessary preparatory work by the client application.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


CheckForCancel Property

CheckForCancel Property

DicomObjects Namespace > DicomAssociation Class : CheckForCancel Property
Control whether to check for incoming C-CANCEL asynchronous messages
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CheckForCancel As Boolean
'Usage

Dim instance As DicomAssociation
Dim value As Boolean

instance.CheckForCancel = value

value = instance.CheckForCancel
public bool CheckForCancel {get; set;}
public:
property bool CheckForCancel {
   bool get();
   void set (    bool value);
}
Remarks
When about to send a status response to an SCU, if this property is true (which it is bt default), then DicomObjects check whether there is any incoming data to be read off the network. If there is, then it is received, and checked to see if it is a C-CANCEL message. If it is C-CANCEL, then it is processed, but if it is any other message, then that would be illegal (without asynchronous operation), and an exception is raised.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


CoercionSOP Property

CoercionSOP Property

DicomObjects Namespace > DicomAssociation Class : CoercionSOP Property
SOP Class to which images should be coerced if peer does not accept true SOP class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CoercionSOP As String
'Usage

Dim instance As DicomAssociation
Dim value As String

instance.CoercionSOP = value

value = instance.CoercionSOP
public string CoercionSOP {get; set;}
public:
property String^ CoercionSOP {
   String^ get();
   void set (    String^ value);
}
Remarks

Some equipments can only support a limited range of SOP classes, but there may be a need to send images of other types to it. If this property is set to a non-null value, and if the remote AE does not support the SOP class of an image being sent, (but does support he CoercionSOP class), then a temporary image (with a New UID) is generated with its SOP class set to equal CoercionSOP, and this is transmitted instead.

The most common value for CoercionSOP would be SecondaryCapture (1.2.840.10008.5.1.4.1.1.7).

Although this practice is questionable, it is often useful for sending images such as ultrasounds, to display stations primarily designed for CT and MRI etc. but which also support secondary capture.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


DefaultThrowStatusException Property

DefaultThrowStatusException Property

DicomObjects Namespace > DicomAssociation Class : DefaultThrowStatusException Property
The value intially assigned for the ThrowStatusException of new DicomAssociation objects.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property DefaultThrowStatusException As Boolean
'Usage

Dim value As Boolean

DicomAssociation.DefaultThrowStatusException = value

value = DicomAssociation.DefaultThrowStatusException
public static bool DefaultThrowStatusException {get; set;}
public:
static property bool DefaultThrowStatusException {
   bool get();
   void set (    bool value);
}
Remarks

This is particularly useful for operations such as DicomImage.Send or DicomQuery.Find where implicit, temporary DicomAssociation objects are used.

See ThrowStatusException for more information.

The default value is false.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


Identity Property

Identity Property

DicomObjects Namespace > DicomAssociation Class : Identity Property
The user identity to use for an association
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Identity As DicomUserIdentity
'Usage

Dim instance As DicomAssociation
Dim value As DicomUserIdentity

instance.Identity = value

value = instance.Identity
public DicomUserIdentity Identity {get; set;}
public:
property DicomUserIdentity^ Identity {
   DicomUserIdentity^ get();
   void set (    DicomUserIdentity^ value);
}
Remarks
When used as an initiator, this should be set before the call to Open
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


ImplementationName Property (DicomAssociation)

ImplementationName Property (DicomAssociation)

DicomObjects Namespace > DicomAssociation Class : ImplementationName Property
Returns the Implementation Version Name of the Connecting AE
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ImplementationName As String
'Usage

Dim instance As DicomAssociation
Dim value As String

value = instance.ImplementationName
public string ImplementationName {get;}
public:
property String^ ImplementationName {
   String^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


ImplementationUID Property (DicomAssociation)

ImplementationUID Property (DicomAssociation)

DicomObjects Namespace > DicomAssociation Class : ImplementationUID Property
Returns the Implementation Class UID of the Connecting AE
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ImplementationUID As String
'Usage

Dim instance As DicomAssociation
Dim value As String

value = instance.ImplementationUID
public string ImplementationUID {get;}
public:
property String^ ImplementationUID {
   String^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


IsOpen Property

IsOpen Property

DicomObjects Namespace > DicomAssociation Class : IsOpen Property
Indicates whether a DicomAssociation is open
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property IsOpen As Boolean
'Usage

Dim instance As DicomAssociation
Dim value As Boolean

value = instance.IsOpen
public bool IsOpen {get;}
public:
property bool IsOpen {
   bool get();
}
Remarks
Returns true if a DicomAssociation is open, otherwise returns false. For outgoing connection, this property is true after the connection is 'opened' by Open method and before the connection is 'closed' by Close method. For incoming connection, if it is a C-GET request, the DicomAssociation object is passed as a property of the EventArguments.QueryReceivedArgs and the value is true. If it is a C-MOVE request, the value is false as the passed secondary connection has to be opened by the SCP to send requested images.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


LastCommand Property

LastCommand Property

DicomObjects Namespace > DicomAssociation Class : LastCommand Property
Returns the last command in the current association.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property LastCommand As DicomDataSet
'Usage

Dim instance As DicomAssociation
Dim value As DicomDataSet

value = instance.LastCommand
public DicomDataSet LastCommand {get;}
public:
property DicomDataSet^ LastCommand {
   DicomDataSet^ get();
}
Example

Returns the last command from the ReturnedCommands collections.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


LastError Property

LastError Property

DicomObjects Namespace > DicomAssociation Class : LastError Property

Returns the last error status from LastCommand.

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property LastError As String
'Usage

Dim instance As DicomAssociation
Dim value As String

value = instance.LastError
public string LastError {get;}
public:
property String^ LastError {
   String^ get();
}
Remarks
If the LastCommand property if not null then this property returns the error status which is contained in the (Keyword.ErrorComment) attribute of the last command, otherwise an empty string is returned.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


LastInstanceUID Property

LastInstanceUID Property

DicomObjects Namespace > DicomAssociation Class : LastInstanceUID Property
Holds the InstanceUID created or used by the last normalised operation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property LastInstanceUID As String
'Usage

Dim instance As DicomAssociation
Dim value As String

value = instance.LastInstanceUID
public string LastInstanceUID {get;}
public:
property String^ LastInstanceUID {
   String^ get();
}
Remarks

Although this property could be used for checking the UID involved in any normalised operation, its primary purpose is to allow retrieval of the UID of the object created in response to an NCreate operation.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


LastOperation Property

LastOperation Property

DicomObjects Namespace > DicomAssociation Class : LastOperation Property
Returns the last operation in the current association.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property LastOperation As DicomOperation
'Usage

Dim instance As DicomAssociation
Dim value As DicomOperation

value = instance.LastOperation
public DicomOperation LastOperation {get;}
public:
property DicomOperation LastOperation {
   DicomOperation get();
}
Remarks

If % LastCommand :LastCommand% is not null then this property returns the Enumeration value contained in the (Keyword.CommandField) attribute of that last command, otherwise it returns Enums.Operation.NONE.

Enumerated values for this property are:

0x0 - NONE

0x1 - C_STORE

0x10 - C_GET

0x20 - C_FIND

0x21 - C_MOVE

0x30 - C_ECHO

0x100 - N_EVENT_REPORT

0x110 - N_GET

0x120 - N_SET

0x130 - N_ACTION

0x140 - N_CREATE

0x150 - N_DELETE

0xFFF - C_CANCEL

0x8001 - C_STORE_RSP

0x8010 - C_GET_RSP

0x8020 - C_FIND_RSP

0x8021 - C_MOVE_RSP

0x8030 - C_ECHO_RSP

0x8100 - N_EVENT_REPORT_RSP

0x8110 - N_GET_RSP

0x8120 - N_SET_RSP

0x8130 - N_ACTION_RSP

0x8140 - N_CREATE_RSP

0x8150 - N_DELETE_RSP

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


LastStatus Property

LastStatus Property

DicomObjects Namespace > DicomAssociation Class : LastStatus Property
Shortcut for the first element of the Status property
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property LastStatus As Integer
'Usage

Dim instance As DicomAssociation
Dim value As Integer

value = instance.LastStatus
public int LastStatus {get;}
public:
property int LastStatus {
   int get();
}
Remarks
A very useful shortcut which makes it easier to access the result of the last operation performed, where only a single result is expected (e.g. after Echo).
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


LocalIP Property

LocalIP Property

DicomObjects Namespace > DicomAssociation Class : LocalIP Property
Provide information about which local interface the remote application entity called
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property LocalIP As String
'Usage

Dim instance As DicomAssociation
Dim value As String

value = instance.LocalIP
public string LocalIP {get;}
public:
property String^ LocalIP {
   String^ get();
}
Remarks
This property relates to open incoming associations only, and can be accessed at any time after the association has been made. For "outgoing" DicomAssociation objects, they are null and 0. For "incoming" DicomAssociation objects such as those created automatically as part of incoming C-STORE (Async), C-FIND of C-GET requests, they relate to the association received. For C-MOVE, they continue to refer to the incoming association even once an outgoing association to carry the images has been established.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


LocalPort Property

LocalPort Property

DicomObjects Namespace > DicomAssociation Class : LocalPort Property
Provide information about which local port the remote application entity called
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property LocalPort As Long
'Usage

Dim instance As DicomAssociation
Dim value As Long

value = instance.LocalPort
public long LocalPort {get;}
public:
property int64 LocalPort {
   int64 get();
}
Remarks
This property relates to open incoming associations only, and can be accessed at any time after the association has been made. For "outgoing" DicomAssociation objects, they are null and 0. For "incoming" DicomAssociation objects such as those created automatically as part of incoming C-STORE (Async), C-FIND of C-GET requests, they relate to the association received. For C-MOVE, they continue to refer to the incoming association even once an outgoing association to carry the images has been established.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


LogLevel Property (DicomAssociation)

LogLevel Property (DicomAssociation)

DicomObjects Namespace > DicomAssociation Class : LogLevel Property
Controls the level of logging for this particular Association.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LogLevel As LogLevel
'Usage

Dim instance As DicomAssociation
Dim value As LogLevel

instance.LogLevel = value

value = instance.LogLevel
public LogLevel LogLevel {get; set;}
public:
property LogLevel LogLevel {
   LogLevel get();
   void set (    LogLevel value);
}
Remarks
The levels are exactly the same as used by LogToFile and any level set by that function provides the default level used for any new DicomAssociation objects (whether incoming or outgoing), but this property allows that level to be changed on a per association basis.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


MetaSOPClass Property (DicomAssociation)

MetaSOPClass Property (DicomAssociation)

DicomObjects Namespace > DicomAssociation Class : MetaSOPClass Property
Determines the Abstract Syntax used for normalised operations
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MetaSOPClass As String
'Usage

Dim instance As DicomAssociation
Dim value As String

instance.MetaSOPClass = value

value = instance.MetaSOPClass
public string MetaSOPClass {get; set;}
public:
property String^ MetaSOPClass {
   String^ get();
   void set (    String^ value);
}
Remarks

Normalised operations, unlike composite operations, are not directly tied to specific abstract syntaxes, but still need to be sent within a negotiated presentation context, which generally relates to a number of related operations, and is known as a Meta SOP Class. This property defines this abstract context, and is therefore used for the selection of an appropriate presentation context, according to those negotiated and available.

If this property is a null string, then the SOP class specified in the normalised operation itself is used, which may be appropriate for some classes, which do not use meta SOP classes for negotiation.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


MoveOriginator Property

MoveOriginator Property

DicomObjects Namespace > DicomAssociation Class : MoveOriginator Property
The DicomAssociation object which initiated the C-MOVE resulting in the current C-STORE
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property MoveOriginator As DicomAssociation
'Usage

Dim instance As DicomAssociation
Dim value As DicomAssociation

value = instance.MoveOriginator
public DicomAssociation MoveOriginator {get;}
public:
property DicomAssociation^ MoveOriginator {
   DicomAssociation^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


PreferredPCID Property

PreferredPCID Property

DicomObjects Namespace > DicomAssociation Class : PreferredPCID Property
Provides guidance for the choice of presentation context
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PreferredPCID As Byte
'Usage

Dim instance As DicomAssociation
Dim value As Byte

instance.PreferredPCID = value

value = instance.PreferredPCID
public byte PreferredPCID {get; set;}
public:
property byte PreferredPCID {
   byte get();
   void set (    byte value);
}
Remarks

Under some circumstances, DicomObjects may have a choice of presentation contexts to use for a given operation, and PreferredTS and PreferredPCID, provide guidance on which of the available options to use.

DicomObjects cannot, however, guarantee that the values given will be honoured, as the requirements of the standard, and the negotiated presentation contexts available will always take priority. Note also, that they can only be effective at the application actually carrying out the operation involved, normally the SCP.

The default values for these parameters are a null string and zero respectively, and these values are taken to mean "no preference".

Presentation context will be selected according to the following procedure:

  • If the presentation context given by PreferredPCID is appropriate for the operation, it is used.
  • If not, and if any presentation context, using the transfer syntax given by PreferredTS is available, then that is used.
  • If neither of the above applies, then any suitable and negotiated presentation context is used.

These properties are particularly designed for teleradiology applications, where run-time selection of a compressed syntax may be appropriate.

For a list of the available presentation contexts, see the Contexts property.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


PreferredTS Property

PreferredTS Property

DicomObjects Namespace > DicomAssociation Class : PreferredTS Property
Provides guidance for the choice of presentation context
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PreferredTS As String
'Usage

Dim instance As DicomAssociation
Dim value As String

instance.PreferredTS = value

value = instance.PreferredTS
public string PreferredTS {get; set;}
public:
property String^ PreferredTS {
   String^ get();
   void set (    String^ value);
}
Remarks

Under some circumstances, DicomObjects may have a choice of presentation contexts to use for a given operation, and PreferredTS and PreferredPCID, provide guidance on which of the available options to use.

DicomObjects cannot, however, guarantee that the values given will be honoured, as the requirements of the standard, and the negotiated presentation contexts available will always take priority. Note also, that they can only be effective at the application actually carrying out the operation involved, normally the SCP.

The default values for these parameters are a null string and zero respectively, and these values are taken to mean "no preference".

Presentation context will be selected according to the following procedure:

  • If the presentation context given by PreferredPCID is appropriate for the operation, it is used.
  • If not, and if any presentation context, using the transfer syntax given by PreferredTS is available, then that is used.
  • If neither of the above applies, then any suitable and negotiated presentation context is used.

These properties are particularly designed for teleradiology applications, where run-time selection of a compressed syntax may be appropriate.

For a list of the available presentation contexts, see the Contexts property.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


PreferredTSList Property

PreferredTSList Property

DicomObjects Namespace > DicomAssociation Class : PreferredTSList Property
Provides guidance for the choice of presentation context
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PreferredTSList As IEnumerable(Of String)
'Usage

Dim instance As DicomAssociation
Dim value As IEnumerable(Of String)

instance.PreferredTSList = value

value = instance.PreferredTSList
public IEnumerable<string> PreferredTSList {get; set;}
public:
property IEnumerable<String^>^ PreferredTSList {
   IEnumerable<String^>^ get();
   void set (    IEnumerable<String^>^ value);
}
Remarks

Under some circumstances, DicomObjects may have a choice of presentation contexts to use for a given operation, and PreferredTSList, PreferredTS and PreferredPCID, provide guidance on which of the available options to use.

DicomObjects cannot, however, guarantee that the values given will be honoured, as the requirements of the standard, and the negotiated presentation contexts available will always take priority. Note also, that they can only be effective at the application actually carrying out the operation involved, normally the SCP.

The default values for these parameters are a null string, empty array and zero respectively, and these values are taken to mean "no preference".

Presentation context will be selected according to the following procedure:

  • If the presentation context given by PreferredPCID is appropriate for the operation, it is used.
  • If not, and if any presentation context, using the transfer syntax given by PreferredTS is available, then that is used.
  • If not, and if any presentation context, using any of the transfer syntaxes given by PreferredTSList is available, then that is used. The list is in order of decreasing priority, so the first TS in the list with a matching negotiated presentation context will be used.
  • If none of the above applies, then any suitable and negotiated presentation context is used.

These properties are particularly designed for teleradiology applications, where run-time selection of a compressed syntax may be appropriate.

For a list of the available presentation contexts, see the Contexts property.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


ReadBehaviour Property

ReadBehaviour Property

DicomObjects Namespace > DicomAssociation Class : ReadBehaviour Property
Specific behaviours to use when receiving data on this association.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ReadBehaviour As ReadBehaviours
'Usage

Dim instance As DicomAssociation
Dim value As ReadBehaviours

instance.ReadBehaviour = value

value = instance.ReadBehaviour
public ReadBehaviours ReadBehaviour {get; set;}
public:
property ReadBehaviours^ ReadBehaviour {
   ReadBehaviours^ get();
   void set (    ReadBehaviours^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


RemoteIP Property

RemoteIP Property

DicomObjects Namespace > DicomAssociation Class : RemoteIP Property
Provides information about the remote application entity
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property RemoteIP As String
'Usage

Dim instance As DicomAssociation
Dim value As String

value = instance.RemoteIP
public string RemoteIP {get;}
public:
property String^ RemoteIP {
   String^ get();
}
Remarks

CallingAET, CalledAET andRemoteIP, these property relate to open associations, and can be accessed at any time after the association has been established. For �outgoing� DicomAssociation objects, they refer to the outgoing association and for �incoming� DicomAssociation objects such as those created automatically as part of incoming C-STORE (async), C-FIND of C-GET requests, they relate to the association received. For C-MOVE, they continue to refer to the incoming association even once an outgoing association to carry the images has been established.

For details of the interface and port, see LocalIP and LocalPort properties.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


Request Property (DicomAssociation)

Request Property (DicomAssociation)

DicomObjects Namespace > DicomAssociation Class : Request Property
This contains the list of attributes to be matched, as specified in the DICOM standard
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Request As DicomDataSet
'Usage

Dim instance As DicomAssociation
Dim value As DicomDataSet

value = instance.Request
public DicomDataSet Request {get;}
public:
property DicomDataSet^ Request {
   DicomDataSet^ get();
}
Remarks

It is the client's responsibility to interpret the contents of this identifier and ensure that the data or images returned match the data sent, and in the case of C-FIND operations, to ensure that all data elements requested are included in the response.

The "level" of the query may be found in (0008, 0052) of this property.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


RequestedContexts Property

RequestedContexts Property

DicomObjects Namespace > DicomAssociation Class : RequestedContexts Property
The Presentation Contexts associated with this DicomAssociation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property RequestedContexts As DicomContextCollection
'Usage

Dim instance As DicomAssociation
Dim value As DicomContextCollection

value = instance.RequestedContexts
public DicomContextCollection RequestedContexts {get;}
public:
property DicomContextCollection^ RequestedContexts {
   DicomContextCollection^ get();
}
Remarks

This is a powerful feature, allowing a client program as much, or as little control over presentation contexts as it wishes. the collection returned by this property may be used to set up a collection of presentation contexts to offer to the peer SE prior to establishing an association

IMPORTANT:

If this property has any presentation contexts added before an association is established, then DicomObjects assumes that the client application has taken charge of this entirely, and the normal Abstract/Transfer context lists found in the registry settings (see SetRegString) are NOT used.

Note that operations relating to the acceptance of presentation contexts are not possible on this DicomContexts object or its contained DicomContext object. Such operations are only possible from within the AssociationRequest event using e.Contexts.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


RequestingQuery Property

RequestingQuery Property

DicomObjects Namespace > DicomAssociation Class : RequestingQuery Property
Provides a linkage to the primary C-MOVE request.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RequestingQuery As QueryReceivedArgs
'Usage

Dim instance As DicomAssociation
Dim value As QueryReceivedArgs

instance.RequestingQuery = value

value = instance.RequestingQuery
public QueryReceivedArgs RequestingQuery {get; set;}
public:
property QueryReceivedArgs^ RequestingQuery {
   QueryReceivedArgs^ get();
   void set (    QueryReceivedArgs^ value);
}
Remarks
This property can be used when implementing a C-MOVE SCP. This property points to the object holding the information about the current query request. in the new association (established from SCP to the move destination) to point it to the primary C-MOVE request. This will make a linkage between the outgoing association and the C-MOVE requesting association, and with every image sent out via the outgoing association DicomObjects will automatically send a notification (as part of the C-MOVE response) and once a final C-MOVE response has been sent by SCP, the outgoing association will be automatically closed.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


ReturnedCommands Property

ReturnedCommands Property

DicomObjects Namespace > DicomAssociation Class : ReturnedCommands Property
The command datasets returned in response to the last operation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ReturnedCommands As DicomDataSetCollection
'Usage

Dim instance As DicomAssociation
Dim value As DicomDataSetCollection

value = instance.ReturnedCommands
public DicomDataSetCollection ReturnedCommands {get;}
public:
property DicomDataSetCollection^ ReturnedCommands {
   DicomDataSetCollection^ get();
}
Remarks
In most cases, the useful data returned from an operation will be present once the operation is complete in properties such as Status, LastStatus, ReturnedIdentifier or ReturnedIdentifiers. However, in some cases, particularly where errors are reported, it is useful to be able to access and parse the associated command (group 0) elements. This property provides that facility, and contains one DicomDataSet for each response received.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


ReturnedIdentifier Property

ReturnedIdentifier Property

DicomObjects Namespace > DicomAssociation Class : ReturnedIdentifier Property
Hold data returned from outgoing operations
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ReturnedIdentifier As DicomDataSet
'Usage

Dim instance As DicomAssociation
Dim value As DicomDataSet

value = instance.ReturnedIdentifier
public DicomDataSet ReturnedIdentifier {get;}
public:
property DicomDataSet^ ReturnedIdentifier {
   DicomDataSet^ get();
}
Remarks
This property contain the results of outgoing Normalized Operations on the DicomAssociation. It is equivalent to ReturnedDataSets(0).
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


ReturnedIdentifiers Property

ReturnedIdentifiers Property

DicomObjects Namespace > DicomAssociation Class : ReturnedIdentifiers Property
Hold data returned from outgoing operations
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ReturnedIdentifiers As DicomDataSetCollection
'Usage

Dim instance As DicomAssociation
Dim value As DicomDataSetCollection

value = instance.ReturnedIdentifiers
public DicomDataSetCollection ReturnedIdentifiers {get;}
public:
property DicomDataSetCollection^ ReturnedIdentifiers {
   DicomDataSetCollection^ get();
}
Remarks
This property contain the results of outgoing C-FIND and C-GET Operations on the DicomAssociation.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


ReturnedInstances Property

ReturnedInstances Property

DicomObjects Namespace > DicomAssociation Class : ReturnedInstances Property
Hold instances returned from outgoing C-GET operations
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ReturnedInstances As DicomDataSetCollection
'Usage

Dim instance As DicomAssociation
Dim value As DicomDataSetCollection

value = instance.ReturnedInstances
public DicomDataSetCollection ReturnedInstances {get;}
public:
property DicomDataSetCollection^ ReturnedInstances {
   DicomDataSetCollection^ get();
}
Remarks
This property contain the results of outgoing C-GET Operations on the DicomAssociation.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


SslStream Property

SslStream Property

DicomObjects Namespace > DicomAssociation Class : SslStream Property
Returns the secure Stream object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property SslStream As Stream
'Usage

Dim instance As DicomAssociation
Dim value As Stream

value = instance.SslStream
public Stream SslStream {get;}
public:
property Stream^ SslStream {
   Stream^ get();
}
Remarks
If Windows nehotiation is used, then this will be an SslStream object
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


Status Property (DicomAssociation)

Status Property (DicomAssociation)

DicomObjects Namespace > DicomAssociation Class : Status Property
Array containing the status codes returned by the last SendInstances or Echo action
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Status As Integer()
'Usage

Dim instance As DicomAssociation
Dim value() As Integer

value = instance.Status
public int[] Status {get;}
public:
property array<int>^ Status {
   array<int>^ get();
}
Remarks

This property contains the result of an outgoing operation on the DicomAssociation. This array is cleared before each operation, and the number of elements therefore reflects the number of images sent.

After a SendVerify operation, the element will contain only one value, so LastStatus is normally more appropriate.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


Tag Property (DicomAssociation)

Tag Property (DicomAssociation)

DicomObjects Namespace > DicomAssociation Class : Tag Property
A general purpose Tag for developer use
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Tag As Object
'Usage

Dim instance As DicomAssociation
Dim value As Object

instance.Tag = value

value = instance.Tag
public object Tag {get; set;}
public:
property Object^ Tag {
   Object^ get();
   void set (    Object^ value);
}
Remarks
This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


ThrowStatusException Property

ThrowStatusException Property

DicomObjects Namespace > DicomAssociation Class : ThrowStatusException Property
Controls whether an exception is generated when a non-zero status is received.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ThrowStatusException As Boolean
'Usage

Dim instance As DicomAssociation
Dim value As Boolean

instance.ThrowStatusException = value

value = instance.ThrowStatusException
public bool ThrowStatusException {get; set;}
public:
property bool ThrowStatusException {
   bool get();
   void set (    bool value);
}
Remarks
Previous versions of DicomObjects have always simply returned the status of an operation, leaving the developer to check the value (as well as catching any exceptions which can occur due to protocol violations etc.) if however this property is set to true (directly, or by setting DefaultThrowStatusException to true before creating the DicomAssociation), then an error status will cause an exception to the thrown. Where present, the values in the 0000,0901 (offending attributes) and 0000,0902 (error comment) will be included in the exception text, to provide more useful information.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


WriteBehaviour Property (DicomAssociation)

WriteBehaviour Property (DicomAssociation)

DicomObjects Namespace > DicomAssociation Class : WriteBehaviour Property
Specific behaviours to use when sending data on this association.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property WriteBehaviour As WriteBehaviours
'Usage

Dim instance As DicomAssociation
Dim value As WriteBehaviours

instance.WriteBehaviour = value

value = instance.WriteBehaviour
public WriteBehaviours WriteBehaviour {get; set;}
public:
property WriteBehaviours^ WriteBehaviour {
   WriteBehaviours^ get();
   void set (    WriteBehaviours^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


DicomAssociation Class Events

DicomAssociation Class Events

DicomObjects Namespace : DicomAssociation Class

For a list of all members of this type, see DicomAssociation members.

Public Events
 | Name | Description
Public Event | InitiateTls | Routine to use to generate encrypted stream when TLS is to be used for outgoing associations.
Public Event | N_Event_Report | This event handler is fired when an N-EVENT-REPORT notification is received.
Public Event | ResponseReceived | Event fires when a response is received on an out-going operation
Top
See Also

Reference

DicomAssociation Class
DicomObjects Namespace


InitiateTls Event (DicomAssociation)

InitiateTls Event (DicomAssociation)

DicomObjects Namespace > DicomAssociation Class : InitiateTls Event
Routine to use to generate encrypted stream when TLS is to be used for outgoing associations.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event InitiateTls As TlsInitiator
'Usage

Dim instance As DicomAssociation
Dim handler As TlsInitiator

AddHandler instance.InitiateTls, handler
public event TlsInitiator InitiateTls
public:
event TlsInitiator^ InitiateTls
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


N_Event_Report Event (DicomAssociation)

N_Event_Report Event (DicomAssociation)

DicomObjects Namespace > DicomAssociation Class : N_Event_Report Event
This event handler is fired when an N-EVENT-REPORT notification is received.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event N_Event_Report As N_Event_ReportHandler
'Usage

Dim instance As DicomAssociation
Dim handler As N_Event_ReportHandler

AddHandler instance.N_Event_Report, handler
public event N_Event_ReportHandler N_Event_Report
public:
event N_Event_ReportHandler^ N_Event_Report
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


ResponseReceived Event (DicomAssociation)

ResponseReceived Event (DicomAssociation)

DicomObjects Namespace > DicomAssociation Class : ResponseReceived Event
Event fires when a response is received on an out-going operation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event ResponseReceived As ResponseReceivedHandler
'Usage

Dim instance As DicomAssociation
Dim handler As ResponseReceivedHandler

AddHandler instance.ResponseReceived, handler
public event ResponseReceivedHandler ResponseReceived
public:
event ResponseReceivedHandler^ ResponseReceived
Remarks

This Event will be generated when any responses are received from the remote application.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociation Class
DicomAssociation Members


DicomAssociationCollection Class

DicomAssociationCollection Class
Members

DicomObjects Namespace : DicomAssociationCollection Class
A collection of DicomAssociation objects
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomAssociationCollection
   Inherits System.Collections.ObjectModel.Collection(Of DicomAssociation)
'Usage

Dim instance As DicomAssociationCollection
public class DicomAssociationCollection : System.Collections.ObjectModel.Collection<DicomAssociation>
public ref class DicomAssociationCollection : public System.Collections.ObjectModel.Collection<DicomAssociation>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
DicomObjects.DicomAssociationCollection

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociationCollection Members
DicomObjects Namespace


DicomAssociationCollection Class Members

DicomAssociationCollection Class Members
Properties Methods

DicomObjects Namespace : DicomAssociationCollection Class

The following tables list the members exposed by DicomAssociationCollection.

Public Constructors
 | Name | Description
Public Constructor | DicomAssociationCollection Constructor |
Top
Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<DicomAssociation>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<DicomAssociation>)
Public Property | Tag | A general purpose Tag for developer use
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<DicomAssociation>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<DicomAssociation>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<DicomAssociation>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<DicomAssociation>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<DicomAssociation>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<DicomAssociation>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<DicomAssociation>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<DicomAssociation>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<DicomAssociation>)
Top
See Also

Reference

DicomAssociationCollection Class
DicomObjects Namespace


DicomAssociationCollection Constructor

DicomAssociationCollection Constructor

DicomObjects Namespace > DicomAssociationCollection Class : DicomAssociationCollection Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DicomAssociationCollection()
public DicomAssociationCollection()
public:
DicomAssociationCollection();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociationCollection Class
DicomAssociationCollection Members


DicomAssociationCollection Class Properties

DicomAssociationCollection Class Properties

DicomObjects Namespace : DicomAssociationCollection Class

For a list of all members of this type, see DicomAssociationCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<DicomAssociation>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<DicomAssociation>)
Public Property | Tag | A general purpose Tag for developer use
Top
See Also

Reference

DicomAssociationCollection Class
DicomObjects Namespace


Tag Property (DicomAssociationCollection)

Tag Property (DicomAssociationCollection)

DicomObjects Namespace > DicomAssociationCollection Class : Tag Property
A general purpose Tag for developer use
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Tag As Object
'Usage

Dim instance As DicomAssociationCollection
Dim value As Object

instance.Tag = value

value = instance.Tag
public object Tag {get; set;}
public:
property Object^ Tag {
   Object^ get();
   void set (    Object^ value);
}
Remarks
This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAssociationCollection Class
DicomAssociationCollection Members


DicomAttribute Class

DicomAttribute Class
Members

DicomObjects Namespace : DicomAttribute Class
Class representing a single DICOM Attribute
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomAttribute
'Usage

Dim instance As DicomAttribute
public class DicomAttribute
public ref class DicomAttribute
Inheritance Hierarchy

System.Object
DicomObjects.DicomAttribute

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Members
DicomObjects Namespace


DicomAttribute Class Members

DicomAttribute Class Members
Properties Methods

DicomObjects Namespace : DicomAttribute Class

The following tables list the members exposed by DicomAttribute.

Public Properties
 | Name | Description
Public Property | BulkDataUri | The URI from which the data could be retrieved
Public Property | ByteArrayData | Returns a single byte array containing the attribute's data
Public Property | DateTimeFrom | Start values for date and time ranges
Public Property | DateTimeTo | End values for date and time ranges
Public Property | DelayedData | Callback to DelayedDataRoutine specified by used for fetching binary data
Public Property | Description | The DICOM Description of the Attribute
Public Property | Element | The element indices of a data element
Public Property | Exists | Determines whether an attribute actually exists
Public Property | ExistsWithValue | Returns True if non-null data is present.
Public Property | Group | The Group indices of a data element.
Public Property | IsMultiple | Determines whether an attribute has a potential value multiplicity of greater than 1
Public Property | IsNull | Indicates whether DicomAttribute has a non-null value
Public Property | IsPrivate | Checks whether an attribute is private
Public Property | Item | The default indexer.
Public Property | Keyword | String representation of the attribute's keyword
Public Property | KeywordCode | The attribute's keyword as a Keyword
Public Property | RawData | The raw data held in DicomAttribute object
Public Property | Tag | A general purpose Tag for developer use
Public Property | Value | The value of a Data Element
Public Property | VM | The value multiplicity of an attribute
Public Property | VR | The Value Representation of an attribute
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | DefinedVM | The value multiplicity of an attribute as defined by the DICOM standard
static (Shared in Visual Basic) | DefinedVR | The value representation of an attribute as defined by the DICOM standard
Public Method | Dispose | Release all resources used by this DicomAttribute object.
Public Method | ToString | Overloaded. Converts object to String Value
Public Method | ValueInContext | Returns the value of Data Element, which may vary according to its surrounding context
Top
See Also

Reference

DicomAttribute Class
DicomObjects Namespace


DicomAttribute Class Methods

DicomAttribute Class Methods

DicomObjects Namespace : DicomAttribute Class

For a list of all members of this type, see DicomAttribute members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | DefinedVM | The value multiplicity of an attribute as defined by the DICOM standard
static (Shared in Visual Basic) | DefinedVR | The value representation of an attribute as defined by the DICOM standard
Public Method | Dispose | Release all resources used by this DicomAttribute object.
Public Method | ToString | Overloaded. Converts object to String Value
Public Method | ValueInContext | Returns the value of Data Element, which may vary according to its surrounding context
Top
See Also

Reference

DicomAttribute Class
DicomObjects Namespace


DefinedVM Method

DefinedVM Method

DicomObjects Namespace > DicomAttribute Class : DefinedVM Method
The value multiplicity of an attribute as defined by the DICOM standard
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function DefinedVM( _
   ByVal Keyword As Keyword _
) As String
'Usage

Dim Keyword As Keyword
Dim value As String

value = DicomAttribute.DefinedVM(Keyword)
public static string DefinedVM(
   Keyword Keyword
)
public:
static String^ DefinedVM(
   Keyword Keyword
)

Parameters

Keyword
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


DefinedVR Method

DefinedVR Method

DicomObjects Namespace > DicomAttribute Class : DefinedVR Method
The value representation of an attribute as defined by the DICOM standard
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function DefinedVR( _
   ByVal Keyword As Keyword _
) As String
'Usage

Dim Keyword As Keyword
Dim value As String

value = DicomAttribute.DefinedVR(Keyword)
public static string DefinedVR(
   Keyword Keyword
)
public:
static String^ DefinedVR(
   Keyword Keyword
)

Parameters

Keyword
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


Dispose Method (DicomAttribute)

Dispose Method (DicomAttribute)

DicomObjects Namespace > DicomAttribute Class : Dispose Method
Release all resources used by this DicomAttribute object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As DicomAttribute

instance.Dispose()
public void Dispose()
public:
void Dispose();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


ToString Method (DicomAttribute)

ToString Method (DicomAttribute)

DicomObjects Namespace > DicomAttribute Class : ToString Method
Converts object to String Value
Overload List
Overload | Description
ToString() | Converts object to String Value, this is the standard .NET method
ToString(String) | Converts to a string using the format parameter (where possible)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members
Base Implementation in ToString


ToString() Method

ToString() Method

DicomObjects Namespace > DicomAttribute Class > ToString Method : ToString() Method
Converts object to String Value, this is the standard .NET method
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Overrides Function ToString() As String
'Usage

Dim instance As DicomAttribute
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string representation of the attribute designed for human readability
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members
Overload List
Base Implementation in ToString


ToString(String) Method

ToString(String) Method

DicomObjects Namespace > DicomAttribute Class > ToString Method : ToString(String) Method
Stansdard format string - e.g. "{0}"
Converts to a string using the format parameter (where possible)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function ToString( _
   ByVal Format As String _
) As String
'Usage

Dim instance As DicomAttribute
Dim Format As String
Dim value As String

value = instance.ToString(Format)
public string ToString(
   string Format
)
public:
String^ ToString(
   String^ Format
)

Parameters

Format
Stansdard format string - e.g. "{0}"

Return Value

resulting string
Remarks
The format parameter is currently only used for numeric scalar values
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members
Overload List


ValueInContext Method

ValueInContext Method

DicomObjects Namespace > DicomAttribute Class : ValueInContext Method

The DicomDataSet which contains the definition/description of the current DicomAttribute

Returns the value of Data Element, which may vary according to its surrounding context
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ValueInContext( _
   ByVal ds As DicomDataSet _
) As Object
'Usage

Dim instance As DicomAttribute
Dim ds As DicomDataSet
Dim value As Object

value = instance.ValueInContext(ds)
public object ValueInContext(
   DicomDataSet ds
)
public:
Object^ ValueInContext(
   DicomDataSet^ ds
)

Parameters

ds

The DicomDataSet which contains the definition/description of the current DicomAttribute

Return Value

object
Remarks

This method is used for accessing attribute values which may vary according to its surrounding context. For example when accessing Patient Name (0010, 0010), the correct Character Set Encoding info is needed in order to return valid value. There is no problem with this when the patient name and the Character Set Encoding are within the same level. But it would be difficult to tell which Character Set to use if you have nested level of DicomDataSets, which is quite common in Sequence. To avoid this user can provide a DicomDataSet which defines/describes how the value could be interpreted.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


DicomAttribute Class Properties

DicomAttribute Class Properties

DicomObjects Namespace : DicomAttribute Class

For a list of all members of this type, see DicomAttribute members.

Public Properties
 | Name | Description
Public Property | BulkDataUri | The URI from which the data could be retrieved
Public Property | ByteArrayData | Returns a single byte array containing the attribute's data
Public Property | DateTimeFrom | Start values for date and time ranges
Public Property | DateTimeTo | End values for date and time ranges
Public Property | DelayedData | Callback to DelayedDataRoutine specified by used for fetching binary data
Public Property | Description | The DICOM Description of the Attribute
Public Property | Element | The element indices of a data element
Public Property | Exists | Determines whether an attribute actually exists
Public Property | ExistsWithValue | Returns True if non-null data is present.
Public Property | Group | The Group indices of a data element.
Public Property | IsMultiple | Determines whether an attribute has a potential value multiplicity of greater than 1
Public Property | IsNull | Indicates whether DicomAttribute has a non-null value
Public Property | IsPrivate | Checks whether an attribute is private
Public Property | Item | The default indexer.
Public Property | Keyword | String representation of the attribute's keyword
Public Property | KeywordCode | The attribute's keyword as a Keyword
Public Property | RawData | The raw data held in DicomAttribute object
Public Property | Tag | A general purpose Tag for developer use
Public Property | Value | The value of a Data Element
Public Property | VM | The value multiplicity of an attribute
Public Property | VR | The Value Representation of an attribute
Top
See Also

Reference

DicomAttribute Class
DicomObjects Namespace


BulkDataUri Property (DicomAttribute)

BulkDataUri Property (DicomAttribute)

DicomObjects Namespace > DicomAttribute Class : BulkDataUri Property
The URI from which the data could be retrieved
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BulkDataUri As String
'Usage

Dim instance As DicomAttribute
Dim value As String

instance.BulkDataUri = value

value = instance.BulkDataUri
public string BulkDataUri {get; set;}
public:
property String^ BulkDataUri {
   String^ get();
   void set (    String^ value);
}
Remarks
This is primarily used when the "metadata only" option is used in WADO-RS.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


ByteArrayData Property

ByteArrayData Property

DicomObjects Namespace > DicomAttribute Class : ByteArrayData Property
Returns a single byte array containing the attribute's data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ByteArrayData As Byte()
'Usage

Dim instance As DicomAttribute
Dim value() As Byte

value = instance.ByteArrayData
public byte[] ByteArrayData {get;}
public:
property array<byte>^ ByteArrayData {
   array<byte>^ get();
}
Remarks
For pixel data attributes, this property returns the uncompressed data for all frames as a single array.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


DateTimeFrom Property

DateTimeFrom Property

DicomObjects Namespace > DicomAttribute Class : DateTimeFrom Property
Start values for date and time ranges
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property DateTimeFrom As Date
'Usage

Dim instance As DicomAttribute
Dim value As Date

value = instance.DateTimeFrom
public DateTime DateTimeFrom {get;}
public:
property DateTime DateTimeFrom {
   DateTime get();
}
Remarks
If the attribute has an open ended range - e.g. "-20060101", then this property will return DicomGlobal.MinimumDateTime
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


DateTimeTo Property

DateTimeTo Property

DicomObjects Namespace > DicomAttribute Class : DateTimeTo Property
End values for date and time ranges
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property DateTimeTo As Date
'Usage

Dim instance As DicomAttribute
Dim value As Date

value = instance.DateTimeTo
public DateTime DateTimeTo {get;}
public:
property DateTime DateTimeTo {
   DateTime get();
}
Remarks
If the attribute has an open start range - e.g. "20060101-", then this property will return DicomGlobal.MaximumDateTime
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


DelayedData Property

DelayedData Property

DicomObjects Namespace > DicomAttribute Class : DelayedData Property
Callback to DelayedDataRoutine specified by used for fetching binary data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DelayedData As DicomAttribute.DelayedDataRoutine
'Usage

Dim instance As DicomAttribute
Dim value As DicomAttribute.DelayedDataRoutine

instance.DelayedData = value

value = instance.DelayedData
public DicomAttribute.DelayedDataRoutine DelayedData {get; set;}
public:
property DicomAttribute.DelayedDataRoutine^ DelayedData {
   DicomAttribute.DelayedDataRoutine^ get();
   void set (    DicomAttribute.DelayedDataRoutine^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


Description Property (DicomAttribute)

Description Property (DicomAttribute)

DicomObjects Namespace > DicomAttribute Class : Description Property
The DICOM Description of the Attribute
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Description As String
'Usage

Dim instance As DicomAttribute
Dim value As String

value = instance.Description
public string Description {get;}
public:
property String^ Description {
   String^ get();
}
Remarks
This is a general description of the DICOM tag itself, NOT the actual data in this instance.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


Element Property

Element Property

DicomObjects Namespace > DicomAttribute Class : Element Property
The element indices of a data element
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Element As Integer
'Usage

Dim instance As DicomAttribute
Dim value As Integer

value = instance.Element
public int Element {get;}
public:
property int Element {
   int get();
}
Remarks

Group and Element, although these properties would be redundant if accessing the elements by Group and element number, the ability to iterate through the elements using the "for each" requires these properties to be exposed, in order to identify the nature of each attribute.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


Exists Property

Exists Property

DicomObjects Namespace > DicomAttribute Class : Exists Property
Determines whether an attribute actually exists
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property Exists As Boolean
'Usage

Dim instance As DicomAttribute
Dim value As Boolean

value = instance.Exists
public virtual bool Exists {get;}
public:
virtual property bool Exists {
   bool get();
}
Remarks

This property returns True if this attribute exists within the Image/DataSet.

If an attempt is made to access a non-existent element of a DicomAttributeCollection, then no error is generated, but the element item returned is a unique "error element", which has an Exists property of False, and returns a Value of Null.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


ExistsWithValue Property

ExistsWithValue Property

DicomObjects Namespace > DicomAttribute Class : ExistsWithValue Property
Returns True if non-null data is present.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ExistsWithValue As Boolean
'Usage

Dim instance As DicomAttribute
Dim value As Boolean

value = instance.ExistsWithValue
public bool ExistsWithValue {get;}
public:
property bool ExistsWithValue {
   bool get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


Group Property

Group Property

DicomObjects Namespace > DicomAttribute Class : Group Property
The Group indices of a data element.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Group As Integer
'Usage

Dim instance As DicomAttribute
Dim value As Integer

value = instance.Group
public int Group {get;}
public:
property int Group {
   int get();
}
Remarks

Group and Element, although these properties would be redundant if accessing the elements by Group and element number, the ability to iterate through the elements using the "for each" requires these properties to be exposed, in order to identify the nature of each attribute.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


IsMultiple Property

IsMultiple Property

DicomObjects Namespace > DicomAttribute Class : IsMultiple Property
Determines whether an attribute has a potential value multiplicity of greater than 1
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property IsMultiple As Boolean
'Usage

Dim instance As DicomAttribute
Dim value As Boolean

value = instance.IsMultiple
public bool IsMultiple {get;}
public:
property bool IsMultiple {
   bool get();
}
Remarks
If true, then the element has a potential value multiplicity of > 1, and its value will be an array not a scalar.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


IsNull Property

IsNull Property

DicomObjects Namespace > DicomAttribute Class : IsNull Property
Indicates whether DicomAttribute has a non-null value
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property IsNull As Boolean
'Usage

Dim instance As DicomAttribute
Dim value As Boolean

value = instance.IsNull
public bool IsNull {get;}
public:
property bool IsNull {
   bool get();
}
Remarks
IsNull is true if the value is a Null (or "Nothing" in VB). This can be due to the actual data being zero length, OR if it consists entirely of discardable characters such as trailing blanks.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


IsPrivate Property

IsPrivate Property

DicomObjects Namespace > DicomAttribute Class : IsPrivate Property
Checks whether an attribute is private
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property IsPrivate As Boolean
'Usage

Dim instance As DicomAttribute
Dim value As Boolean

value = instance.IsPrivate
public bool IsPrivate {get;}
public:
property bool IsPrivate {
   bool get();
}
Remarks
The current implemntation simply checks if the Group number is odd.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


Item Property (DicomAttribute)

Item Property (DicomAttribute)

DicomObjects Namespace > DicomAttribute Class : Item Property
The 1-based index of the component to return
The default indexer.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Default Property Item( _
   ByVal Index As Integer _
) As Object
'Usage

Dim instance As DicomAttribute
Dim Index As Integer
Dim value As Object

value = instance.Item(Index)
public object this[
   int Index
]; {get;}
public:
property Object^ default [int] {
   Object^ get(int Index);
}

Parameters

Index
The 1-based index of the component to return
Remarks

If Item is 0, then the overall value (equivalent to the Value) is returned

If the VM is greater than 1 then individual items may be accessed by using the 1-based index.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


Keyword Property (DicomAttribute)

Keyword Property (DicomAttribute)

DicomObjects Namespace > DicomAttribute Class : Keyword Property
String representation of the attribute's keyword
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Keyword As String
'Usage

Dim instance As DicomAttribute
Dim value As String

value = instance.Keyword
public string Keyword {get;}
public:
property String^ Keyword {
   String^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


KeywordCode Property

KeywordCode Property

DicomObjects Namespace > DicomAttribute Class : KeywordCode Property
The attribute's keyword as a Keyword
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property KeywordCode As Keyword
'Usage

Dim instance As DicomAttribute
Dim value As Keyword

value = instance.KeywordCode
public Keyword KeywordCode {get;}
public:
property Keyword KeywordCode {
   Keyword get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


RawData Property

RawData Property

DicomObjects Namespace > DicomAttribute Class : RawData Property
The raw data held in DicomAttribute object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property RawData As Array
'Usage

Dim instance As DicomAttribute
Dim value As Array

value = instance.RawData
public Array RawData {get;}
public:
property Array^ RawData {
   Array^ get();
}
Remarks
This property returns an array of bytes as the raw data held in a DicomAttribute object.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


Tag Property (DicomAttribute)

Tag Property (DicomAttribute)

DicomObjects Namespace > DicomAttribute Class : Tag Property
A general purpose Tag for developer use
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Tag As Object
'Usage

Dim instance As DicomAttribute
Dim value As Object

instance.Tag = value

value = instance.Tag
public object Tag {get; set;}
public:
property Object^ Tag {
   Object^ get();
   void set (    Object^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


Value Property (DicomAttribute)

Value Property (DicomAttribute)

DicomObjects Namespace > DicomAttribute Class : Value Property
The value of a Data Element
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Value As Object
'Usage

Dim instance As DicomAttribute
Dim value As Object

value = instance.Value
public object Value {get;}
public:
property Object^ Value {
   Object^ get();
}
Remarks

The type of object returned depends on the value representation of the data element, and may be a string, date (or time, date or date-time), or a numeric type, including floating point values where appropriate.

Data elements of types not known to the program, whether private elements, or attributes recently defined by DICOM return the string " Unknown Data Type".

The pixel data attribute(7FE0,0010) is handled slightly differently and returns a flattened 1 dimensional array.

If the data dictionary lists the element as having the possibility of a value multiplicity of >1, then an single dimensional array of the appropriate type is returned, the size of the array reflecting the actual number of elements present (which may be just one).

If the element is a sequence then an Object of type DicomDataSetCollection is returned. As this is the only possible result of type Object, it can easily be identified using Visual Basic’s "Vartype" function or equivalent.

Non-existent Elements have a value of Null.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


VM Property

VM Property

DicomObjects Namespace > DicomAttribute Class : VM Property
The value multiplicity of an attribute
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property VM As Integer
'Usage

Dim instance As DicomAttribute
Dim value As Integer

value = instance.VM
public int VM {get;}
public:
property int VM {
   int get();
}
Remarks

This property returns the actual number of items which will be returned by a call to the Attribute’s Value property. If the attribute has zero length, then the value will be 0, and if it is only allowed to have a single value then it will be 1, but for other cases the value depends on the data itself. If the Value property returns an array, then the value of this property equals the upper bound of the array.

If the underlying attribute is a sequence, then this property returns the number of items in the sequence.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


VR Property (DicomAttribute)

VR Property (DicomAttribute)

DicomObjects Namespace > DicomAttribute Class : VR Property
The Value Representation of an attribute
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property VR As String
'Usage

Dim instance As DicomAttribute
Dim value As String

instance.VR = value

value = instance.VR
public string VR {get; set;}
public:
property String^ VR {
   String^ get();
   void set (    String^ value);
}
Remarks

This property is normally used as read-only and may be useful in determining the type of an element.

Changing the type of an element is not normally needed or a good idea, but may be required occasionally, such as when private data has been read through the implicit VR transfer syntax.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


DicomContext Class

DicomContext Class
Members

DicomObjects Namespace : DicomContext Class
A DICOM presentation context, as used in association negotiation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomContext
'Usage

Dim instance As DicomContext
public class DicomContext
public ref class DicomContext
Remarks
A DicomContext represents a DICOM presentation context, and is used in association negotiation, and in the selection of transmission formats (transfer syntaxes). DicomContext items only exist within a DicomContextCollection, and more information on the use of DicomContext items may be found in the DicomContextCollection entry.
Inheritance Hierarchy

System.Object
DicomObjects.DicomContext

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomContext Members
DicomObjects Namespace


DicomContext Class Members

DicomContext Class Members
Properties Methods

DicomObjects Namespace : DicomContext Class

The following tables list the members exposed by DicomContext.

Public Properties
 | Name | Description
Public Property | AbstractSyntax | The abstract syntax associated with the presentation context
Public Property | AcceptedTS | The negotiated and accepted transfer syntax to be used in a presentation context
Public Property | ContextID | Uniquely identifies a presentation context for a given association
Public Property | ExtendedNegotiationValues | Used to negotiate extended information about a SOP class
Public Property | OfferedTS | The list of transfer syntaxes offered in a presentation context
Public Property | RequestorSCPRole | Used for reverse role negotiation
Public Property | RequestorSCURole | Used for reverse role negotiation
Public Property | Tag | A general purpose Tag for developer use
Top
Public Methods
 | Name | Description
Public Method | Reject | Rejects a particular presentation context
Top
See Also

Reference

DicomContext Class
DicomObjects Namespace


DicomContext Class Methods

DicomContext Class Methods

DicomObjects Namespace : DicomContext Class

For a list of all members of this type, see DicomContext members.

Public Methods
 | Name | Description
Public Method | Reject | Rejects a particular presentation context
Top
See Also

Reference

DicomContext Class
DicomObjects Namespace


Reject Method (DicomContext)

Reject Method (DicomContext)

DicomObjects Namespace > DicomContext Class : Reject Method

Byte value, the reason for rejection

Rejects a particular presentation context
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Reject( _
   ByVal Reason As Byte _
)
'Usage

Dim instance As DicomContext
Dim Reason As Byte

instance.Reject(Reason)
public void Reject(
   byte Reason
)
public:
void Reject(
   byte Reason
)

Parameters

Reason

Byte value, the reason for rejection

Remarks

This method, and setting of the AcceptedTS property are mutually exclusive, and if both are used, the latest used takes precedence.

The defined reasons are:

  • 1: user-rejection
  • 2: no-reason (provider rejection)
  • 3: abstract-syntax-not-supported (provider rejection)
  • 4: transfer-syntax-not-supported (provider rejection)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomContext Class
DicomContext Members


DicomContext Class Properties

DicomContext Class Properties

DicomObjects Namespace : DicomContext Class

For a list of all members of this type, see DicomContext members.

Public Properties
 | Name | Description
Public Property | AbstractSyntax | The abstract syntax associated with the presentation context
Public Property | AcceptedTS | The negotiated and accepted transfer syntax to be used in a presentation context
Public Property | ContextID | Uniquely identifies a presentation context for a given association
Public Property | ExtendedNegotiationValues | Used to negotiate extended information about a SOP class
Public Property | OfferedTS | The list of transfer syntaxes offered in a presentation context
Public Property | RequestorSCPRole | Used for reverse role negotiation
Public Property | RequestorSCURole | Used for reverse role negotiation
Public Property | Tag | A general purpose Tag for developer use
Top
See Also

Reference

DicomContext Class
DicomObjects Namespace


AbstractSyntax Property

AbstractSyntax Property

DicomObjects Namespace > DicomContext Class : AbstractSyntax Property
The abstract syntax associated with the presentation context
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property AbstractSyntax As String
'Usage

Dim instance As DicomContext
Dim value As String

value = instance.AbstractSyntax
public string AbstractSyntax {get;}
public:
property String^ AbstractSyntax {
   String^ get();
}
Remarks

This value may either be a SOP class, such as CT, or a Meta SOP class such as BasicGrayscalePrint.

Whilst this property may be set to, or compared with full UID strings, use of UID Constants is advised for better readability.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomContext Class
DicomContext Members


AcceptedTS Property

AcceptedTS Property

DicomObjects Namespace > DicomContext Class : AcceptedTS Property

The negotiated and accepted transfer syntax to be used in a presentation context

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AcceptedTS As String
'Usage

Dim instance As DicomContext
Dim value As String

instance.AcceptedTS = value

value = instance.AcceptedTS
public string AcceptedTS {get; set;}
public:
property String^ AcceptedTS {
   String^ get();
   void set (    String^ value);
}
Remarks

This property allows a client program, in an AssociationRequest event, to select which transfer syntax to accept for a given presentation context, the list offered being found in the OfferedTS property. If none of the offered contexts is acceptable, then instead of setting this value, the Reject method should be called.

If no value is set, and Reject is not called, then DicomObjects will automatically select a value, based on the Transfer Syntax Negotiation settings. On an established association, whether incoming or outgoing, the client may use this property to check which transfer syntax will be used, especially if the same abstract context exists in more than one presentation context. The DicomAssociation's PreferredPCID property may then be set to the appropriate DicomContext's ContextID value.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomContext Class
DicomContext Members


ContextID Property

ContextID Property

DicomObjects Namespace > DicomContext Class : ContextID Property
Uniquely identifies a presentation context for a given association
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ContextID As Byte
'Usage

Dim instance As DicomContext
Dim value As Byte

value = instance.ContextID
public byte ContextID {get;}
public:
property byte ContextID {
   byte get();
}
Remarks

The value of this property is normally a small odd integer between 1 and 255, though some faulty public domain software incorrectly uses even values which may be seen, and need to be tolerated.

The value is set when the DicomContext item is created, either implicitly, or by the DicomContextCollection's Add method, and cannot be changed.

This value may be used to set the DicomAssociation's PreferredPCID property and is also used to index into the DicomContextCollection.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomContext Class
DicomContext Members


ExtendedNegotiationValues Property

ExtendedNegotiationValues Property

DicomObjects Namespace > DicomContext Class : ExtendedNegotiationValues Property
Used to negotiate extended information about a SOP class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ExtendedNegotiationValues As Byte()
'Usage

Dim instance As DicomContext
Dim value() As Byte

instance.ExtendedNegotiationValues = value

value = instance.ExtendedNegotiationValues
public byte[] ExtendedNegotiationValues {get; set;}
public:
property array<byte>^ ExtendedNegotiationValues {
   array<byte>^ get();
   void set (    array<byte>^ value);
}
Remarks

This property enable applications to share or negotiate extended information about themselves.

The exact meanings of the various values and byte positions used for extended negotiation vary from one service class to another, and they are all detailed in part 4 of DICOM. e.g. for C-STORE operations, byte 1 represents the "storage level", byte 3 the level of digital signature support and byte 5 controls the coercion of data elements (2,4, & 6 are reserved). However, for C-FIND operations, only 1 byte is specified, indicating whether the SCP supports relational queries. In all cases, support is optional, and default values exist if extended negotiation is not performed.

If this property is set to true, then any extended negotiation items set up before Open are proposed. When incoming associations are received, then incoming values are automatically sent out again (i.e. accepted) unless altered using the ExtendedNegotiationValues property in the AssociationRequest event.

Once an association is established, this property becomes read-only, but still reflects the arrangement negotiated.

Please note that this property is shared between all contexts with the same AbstractSyntax (SOP class), so changing one will change the value for any other matching contexts.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomContext Class
DicomContext Members


OfferedTS Property

OfferedTS Property

DicomObjects Namespace > DicomContext Class : OfferedTS Property
The list of transfer syntaxes offered in a presentation context
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OfferedTS As String()
'Usage

Dim instance As DicomContext
Dim value() As String

instance.OfferedTS = value

value = instance.OfferedTS
public string[] OfferedTS {get; set;}
public:
property array<String^>^ OfferedTS {
   array<String^>^ get();
   void set (    array<String^>^ value);
}

Property Value

The list of transfer syntaxes offered
Remarks

This property holds the list of transfer syntaxes offered as part of association negotiation. As an SCU, it may be set up by a client program prior to calling Open. As an SCP, the values may be inspected during the AssociationRequest event in order to select which on to accept (by setting AcceptedTS).

If not set explicitly by a client program, a default list is used, based on tghe current Transfer Syntax Negotiation settings.

Whilst this property may be set to, or compared with full UID strings, use of symbolic constants is advised for better readability.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomContext Class
DicomContext Members


RequestorSCPRole Property

RequestorSCPRole Property

DicomObjects Namespace > DicomContext Class : RequestorSCPRole Property
Used for reverse role negotiation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RequestorSCPRole As Boolean
'Usage

Dim instance As DicomContext
Dim value As Boolean

instance.RequestorSCPRole = value

value = instance.RequestorSCPRole
public bool RequestorSCPRole {get; set;}
public:
property bool RequestorSCPRole {
   bool get();
   void set (    bool value);
}

Property Value

True if reverse role negotiation is to be supported
Remarks

Normally in DICOM, the requester of an association becomes the SCU, and the acceptor becomes the SCP, but there are some situations (notably Storage Commitment), where this relationship needs to be reversed (or it is possible for both applications to adopt both roles). In DicomObejcts, this is achieved using these properties, and is only possible (for outgoing operations) using an association based on an explicit DicomAssociation.

To propose reverse role negotiation, DicomContext items must be created explicitly, and the contexts' RequestorSCURole should be set to false, and the RequestorSCPRole should be set to true.

When accepting associations, DicomObjects's default action is to accept whatever roles are proposed by the requester, but this may be over-ridden in the AssociationRequest event by modifying these properties of any of the proposed contexts.

Once an association is established, these properties become read-only, but still reflect the arrangement negotiated.

Please note that these properties are shared between all contexts with the same AbstractSyntax (SOP Class), so changing one will change the value for any other matching contexts.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomContext Class
DicomContext Members


RequestorSCURole Property

RequestorSCURole Property

DicomObjects Namespace > DicomContext Class : RequestorSCURole Property
Used for reverse role negotiation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RequestorSCURole As Boolean
'Usage

Dim instance As DicomContext
Dim value As Boolean

instance.RequestorSCURole = value

value = instance.RequestorSCURole
public bool RequestorSCURole {get; set;}
public:
property bool RequestorSCURole {
   bool get();
   void set (    bool value);
}

Property Value

True if reverse role negotiation is to be supported
Remarks

Normally in DICOM, the requester of an association becomes the SCU, and the acceptor becomes the SCP, but there are some situations (notably Storage Commitment), where this relationship needs to be reversed (or it is possible for both applications to adopt both roles). In DicomObejcts, this is achieved using these properties, and is only possible (for outgoing operations) using an association based on an explicit DicomAssociation.

To propose reverse role negotiation, DicomContext items must be created explicitly, and the contexts' RequestorSCURole should be set to false, and the RequestorSCPRole should be set to true.

When accepting associations, DicomObjects's default action is to accept whatever roles are proposed by the requester, but this may be over-ridden in the AssociationRequest event by modifying these properties of any of the proposed contexts.

Once an association is established, these properties become read-only, but still reflect the arrangement negotiated.

Please note that these properties are shared between all contexts with the same AbstractSyntax (SOP Class), so changing one will change the value for any other matching contexts.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomContext Class
DicomContext Members


Tag Property (DicomContext)

Tag Property (DicomContext)

DicomObjects Namespace > DicomContext Class : Tag Property
A general purpose Tag for developer use
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Tag As Object
'Usage

Dim instance As DicomContext
Dim value As Object

instance.Tag = value

value = instance.Tag
public object Tag {get; set;}
public:
property Object^ Tag {
   Object^ get();
   void set (    Object^ value);
}
Remarks
This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomContext Class
DicomContext Members


DicomContextCollection Class

DicomContextCollection Class
Members

DicomObjects Namespace : DicomContextCollection Class
The list of DICOM Presentation contexts proposed or accepted during negotiation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomContextCollection
   Inherits System.Collections.ObjectModel.KeyedCollection(Of Byte,DicomContext)
'Usage

Dim instance As DicomContextCollection
public class DicomContextCollection : System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>
public ref class DicomContextCollection : public System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
System.Collections.ObjectModel.KeyedCollection<TKey,TItem>
DicomObjects.DicomContextCollection

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomContextCollection Members
DicomObjects Namespace


DicomContextCollection Class Members

DicomContextCollection Class Members
Properties Methods

DicomObjects Namespace : DicomContextCollection Class

The following tables list the members exposed by DicomContextCollection.

Public Properties
 | Name | Description
Public Property | AnyPresent | Indicates if there is any context agreed by the remote application
Public Property | Comparer | (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Property | Item | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Property | Tag | A general purpose Tag for developer use
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a DicomContext to a DicomContextCollection
Public Method | AddDefaults | Add the default SOP Class UIDs to Presentation Contexts
Public Method | CanUse | Checks whether at least one presentation context has been negotiated for a given SOP class
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Contains | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Exists | Checks whether a particular presentation ocntext ID exists
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Remove | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Top
See Also

Reference

DicomContextCollection Class
DicomObjects Namespace


DicomContextCollection Class Methods

DicomContextCollection Class Methods

DicomObjects Namespace : DicomContextCollection Class

For a list of all members of this type, see DicomContextCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a DicomContext to a DicomContextCollection
Public Method | AddDefaults | Add the default SOP Class UIDs to Presentation Contexts
Public Method | CanUse | Checks whether at least one presentation context has been negotiated for a given SOP class
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Contains | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Exists | Checks whether a particular presentation ocntext ID exists
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Remove | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Top
See Also

Reference

DicomContextCollection Class
DicomObjects Namespace


Add Method (DicomContextCollection)

Add Method (DicomContextCollection)

DicomObjects Namespace > DicomContextCollection Class : Add Method
Adds a DicomContext to a DicomContextCollection
Overload List
Overload | Description
Add(String) | Adds a DicomContext to a DicomContextCollection
Add(String,String) | Adds a DicomContext to a DicomContextCollection, together with the proposed TransferSyntax for the Presentation Context
Add(String,IEnumerable<String>) | Adds a DicomContext to a DicomContextCollection, together with a list of proposed TransferSyntax for the Presentation Context
Add(DicomContext) | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomContextCollection Class
DicomContextCollection Members


Add(String) Method

Add(String) Method

DicomObjects Namespace > DicomContextCollection Class > Add Method : Add(String) Method

String value specifying the proposed AbstractSyntax

Adds a DicomContext to a DicomContextCollection
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Add( _
   ByVal AbstractSyntax As String _
) As DicomContext
'Usage

Dim instance As DicomContextCollection
Dim AbstractSyntax As String
Dim value As DicomContext

value = instance.Add(AbstractSyntax)
public DicomContext Add(
   string AbstractSyntax
)
public:
DicomContext^ Add(
   String^ AbstractSyntax
)

Parameters

AbstractSyntax

String value specifying the proposed AbstractSyntax

Return Value

DicomContext
Remarks
Note that in keeping with the DICOM requirement, newly added contexts have odd values, so adding two items to a DicomContexts collection using this method will create item numbers 1 and 3, not 1 and 2.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomContextCollection Class
DicomContextCollection Members
Overload List


Add(String,String) Method

Add(String,String) Method

DicomObjects Namespace > DicomContextCollection Class > Add Method : Add(String,String) Method

The string value of proposed AbstractSyntax

The string value of he proposed TransferSyntax for that Presentation Context.

Adds a DicomContext to a DicomContextCollection, together with the proposed TransferSyntax for the Presentation Context
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Add( _
   ByVal AbstractSyntax As String, _
   ByVal TransferSyntax As String _
) As DicomContext
'Usage

Dim instance As DicomContextCollection
Dim AbstractSyntax As String
Dim TransferSyntax As String
Dim value As DicomContext

value = instance.Add(AbstractSyntax, TransferSyntax)
public DicomContext Add(
   string AbstractSyntax,
   string TransferSyntax
)
public:
DicomContext^ Add(
   String^ AbstractSyntax,
   String^ TransferSyntax
)

Parameters

AbstractSyntax

The string value of proposed AbstractSyntax

TransferSyntax

The string value of he proposed TransferSyntax for that Presentation Context.

Return Value

DicomContext
Remarks

Note that in keeping with the DICOM requirement, newly added contexts have odd values, so adding two items to a DicomContexts collection using this method will create item numbers 1 and 3, not 1 and 2.

Transfer Syntax can be a space separated list as follows:

"1.2.840.10008.1.2 1.2.840.10008.1.2.1 1.2.840.10008.1.2.2"

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomContextCollection Class
DicomContextCollection Members
Overload List


Add(String,IEnumerable<String>) Method

Add(String,IEnumerable<String>) Method

DicomObjects Namespace > DicomContextCollection Class > Add Method : Add(String,IEnumerable<String>) Method

The string value of proposed AbstractSyntax

The list of proposed TransferSyntaxes for that Presentation Context.

Adds a DicomContext to a DicomContextCollection, together with a list of proposed TransferSyntax for the Presentation Context
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Add( _
   ByVal AbstractSyntax As String, _
   ByVal TransferSyntaxes As IEnumerable(Of String) _
) As DicomContext
'Usage

Dim instance As DicomContextCollection
Dim AbstractSyntax As String
Dim TransferSyntaxes As IEnumerable(Of String)
Dim value As DicomContext

value = instance.Add(AbstractSyntax, TransferSyntaxes)
public DicomContext Add(
   string AbstractSyntax,
   IEnumerable<string> TransferSyntaxes
)
public:
DicomContext^ Add(
   String^ AbstractSyntax,
   IEnumerable<String^>^ TransferSyntaxes
)

Parameters

AbstractSyntax

The string value of proposed AbstractSyntax

TransferSyntaxes

The list of proposed TransferSyntaxes for that Presentation Context.

Return Value

DicomContext
Remarks

Note that in keeping with the DICOM requirement, newly added contexts have odd values, so adding two items to a DicomContexts collection using this method will create item numbers 1 and 3, not 1 and 2.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomContextCollection Class
DicomContextCollection Members
Overload List


AddDefaults Method

AddDefaults Method

DicomObjects Namespace > DicomContextCollection Class : AddDefaults Method
TransferSyntax to add to each of the SOP Class UIDs in the default list
Add the default SOP Class UIDs to Presentation Contexts
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub AddDefaults( _
   ByVal TransferSyntax As String _
)
'Usage

Dim instance As DicomContextCollection
Dim TransferSyntax As String

instance.AddDefaults(TransferSyntax)
public void AddDefaults(
   string TransferSyntax
)
public:
void AddDefaults(
   String^ TransferSyntax
)

Parameters

TransferSyntax
TransferSyntax to add to each of the SOP Class UIDs in the default list
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomContextCollection Class
DicomContextCollection Members


CanUse Method

CanUse Method

DicomObjects Namespace > DicomContextCollection Class : CanUse Method
The SOP Class (abstract syntax) to be checked
Checks whether at least one presentation context has been negotiated for a given SOP class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function CanUse( _
   ByVal SOPClass As String _
) As Boolean
'Usage

Dim instance As DicomContextCollection
Dim SOPClass As String
Dim value As Boolean

value = instance.CanUse(SOPClass)
public bool CanUse(
   string SOPClass
)
public:
bool CanUse(
   String^ SOPClass
)

Parameters

SOPClass
The SOP Class (abstract syntax) to be checked

Return Value

True if the SOP class can be used
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomContextCollection Class
DicomContextCollection Members


Exists Method

Exists Method

DicomObjects Namespace > DicomContextCollection Class : Exists Method
the (odd numbered) presentation Context ID to check
Checks whether a particular presentation ocntext ID exists
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function Exists( _
   ByVal ContextID As Byte _
) As Boolean
'Usage

Dim instance As DicomContextCollection
Dim ContextID As Byte
Dim value As Boolean

value = instance.Exists(ContextID)
public bool Exists(
   byte ContextID
)
public:
bool Exists(
   byte ContextID
)

Parameters

ContextID
the (odd numbered) presentation Context ID to check

Return Value

True if the entry exists
Remarks
If rejected by the other entity, then this will return false
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomContextCollection Class
DicomContextCollection Members


DicomContextCollection Class Properties

DicomContextCollection Class Properties

DicomObjects Namespace : DicomContextCollection Class

For a list of all members of this type, see DicomContextCollection members.

Public Properties
 | Name | Description
Public Property | AnyPresent | Indicates if there is any context agreed by the remote application
Public Property | Comparer | (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Property | Item | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Property | Tag | A general purpose Tag for developer use
Top
See Also

Reference

DicomContextCollection Class
DicomObjects Namespace


AnyPresent Property

AnyPresent Property

DicomObjects Namespace > DicomContextCollection Class : AnyPresent Property
Indicates if there is any context agreed by the remote application
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property AnyPresent As Boolean
'Usage

Dim instance As DicomContextCollection
Dim value As Boolean

value = instance.AnyPresent
public bool AnyPresent {get;}
public:
property bool AnyPresent {
   bool get();
}
Remarks
This property returns true only if there is 1 or more presentation context which has been agreed, during the association negotiation, by the remote application.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomContextCollection Class
DicomContextCollection Members


Tag Property (DicomContextCollection)

Tag Property (DicomContextCollection)

DicomObjects Namespace > DicomContextCollection Class : Tag Property
A general purpose Tag for developer use
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Tag As Object
'Usage

Dim instance As DicomContextCollection
Dim value As Object

instance.Tag = value

value = instance.Tag
public object Tag {get; set;}
public:
property Object^ Tag {
   Object^ get();
   void set (    Object^ value);
}
Remarks
This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomContextCollection Class
DicomContextCollection Members


DicomDataSet Class

DicomDataSet Class
Members

DicomObjects Namespace : DicomDataSet Class
A DICOM data set
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomDataSet
'Usage

Dim instance As DicomDataSet
public class DicomDataSet
public ref class DicomDataSet
Remarks

A DicomDataSet object holds a set of DicomAttributes, and constitutes the main set of data within DICOM. The content may be:

  • A composite instance (image or other persitent object)
  • A Command
  • An item in a sequence (in whch case it is part of a DicomDataSetCollection)

The consituent attributes may be accessed in many different ways:

  • By Group and Element - dataset[group, element]
  • By KeyWord - dataset[Keyword]
  • Sequentially by index - dataset[index]
  • Sequentially by using the iterator - foreach(DicomAttribute in dataset)

Inheritance Hierarchy

System.Object
DicomObjects.DicomDataSet

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Members
DicomObjects Namespace


DicomDataSet Class Members

DicomDataSet Class Members
Fields Properties Methods

DicomObjects Namespace : DicomDataSet Class

The following tables list the members exposed by DicomDataSet.

Public Constructors
 | Name | Description
Public Constructor | DicomDataSet Constructor | Overloaded. Creates a new DicomDataSet
Top
Public Fields
 | Name | Description
Public Field | CompressedFrameStream | User-defined function to set output stream for compressed frame. This is suitable for writing out large compressed frames with Basic Offset Table.
Top
Public Properties
 | Name | Description
Public Property | AccessionNumber | The Accession Number
Public Property | CacheMode | Controls how the pixel data is cached
Public Property | Children | Holds the hierarchical directory structure for DICOM directory files
Public Property | Command | The full command dataset received
Public Property | Count | Number of Attributes held in the DataSet
Public Property | DateOfBirth | Date of birth of the patient
static (Shared in Visual Basic) | DefaultValidationTypes | The default DicomObjects.Enums.ValidationTypes to apply to newly created DicomDataSet objects
Public Property | Identifer | Returns the underlying DataSet which contains the list of attributes to be matched, as specified in the DICOM standard.
Public Property | InstanceUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Item | Overloaded. Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Public Property | Name | The Name of the patient
Public Property | OriginalTS | Returns the Transfer syntax with which the object was originally received or read.
Public Property | Overrides | Image-specific list of unusual behaviours (e.g. to cope with faulty images)
Public Property | OverrideTS | A means to override an incorrect transfer syntax
Public Property | PatientID | The Patient ID
Public Property | PixelsPerFrame | The number of pixels per frame
Public Property | RawPixels | Accesses the raw pixel data as an array
Public Property | SamplesPerFrame | The number of samples per frame
Public Property | SeriesDescription | Descriptions for the series
Public Property | SeriesUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Sex | Sex of the patient
Public Property | SOPClass | SOP class of the DicomDataSet.
Public Property | StudyDescription | Description for the study
Public Property | StudyUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Tag | A general purpose Tag for developer use
Public Property | UncompressedPI | Gets the Photometric Interpretation of the uncompressed Image data.
Public Property | ValidationDataSet | Assign a Validation DataSet to this property would override the DataSet's Validation scheme. This is mainly used for validation of CharacterSet.
Public Property | ValidationTypes | Gets or sets the current validation type.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Creates and adds data elements to DicomDataSet
Public Method | AddByReference | Overloaded. Add byte[] as attribute value to avoid copying large data
Public Method | AddPixelData | Adds pixel data to DicomDataSet
Public Method | AddToDirectory | Overloaded. Simplified DICOMDIR creation
Public Method | ChangeCharacterSet | Change the specific Character Set of a DICOM dataset. All applicable attributes will have its data re-encoded by the new character set
Public Method | ChangeToDecompressed | Simulate the effect of writing out as a Decompressed Image
Public Method | Clear | Clear the DicomDataSet data
Public Method | Clone | Overloaded. Returns a copy of the DicomDataSet
Public Method | DecompressAll | Causes all the frames of an image to be decompressed.
Public Method | Dispose | Release the resources used by the DicomDataSet object
Public Method | FindAttribute | Locate an attribute within either a top level dataset, or within one of the functional group macros
Public Method | ForEachAttribute | Recursively perform an action on every attribute within the dataset
Public Method | FrameSubSet | Generates a new DicomDataSet as a subset of the current instance as described in supplement 119
Public Method | FunctionalGroupDataSet | Overloaded. Locate the required functional group within a DicomDataSet
Public Method | FunctionalGroupOrRootLevelAttribute | Overloaded. Return the required DicomAttribute within a specified functional group within a DicomDataSet If DicomAttribute is not present in the specified DicomDataSet, it searches amongst the root level attributes
Public Method | GetAllBulkData | Load All Bulk data for attributes
Public Method | GetAllURIBulkData | Load Bulk data from URI, getting data from web calls
Public Method | GetMinAndMax | Overloaded. Find the maximum and minimum pixel data values in the pixel data
Public Method | GetPixelStream | Returns the raw pixel data as a Stream object for a specific frame
Public Method | ImportPixelData | Direct import of compressed pixel data
Public Method | IsPresentationStateFor | Overloaded. Indicates if the PresentationState is for the specified DicomImage
Public Method | MergeBulkData | Load Bulk data for all attributes, getting data from a method, based on the URI
Public Method | Read | Overloaded. Reads from a standard Stream, with specific reading behaviour
Public Method | ReadJson | Read DICOM data from a Json Stream
Public Method | ReadURL | Reads DataSet from Web Address
Public Method | ReadXml | Read DICOM data from an XML Stream
Public Method | Remove | Overloaded. Removes an attribute from the DataSet
Public Method | RemovePrivateAttributes | Remove private attributes
Public Method | Send | Overloaded. Sends a DicomDataSet to a remote DICOM application
Public Method | SetDicomCodec | Specify a "DICOM" codec
Public Method | SetNonDicomCodec | Specify a non-DICOM source (e.g. AVI) as a source of frame data
Public Method | SetPlanarConfiguration | Sets the planar configuration in DicomDataSet
Public Method | SimplifyOverlays | Decompress the data, and move any overlays which are encoded with the pixel data (a method deprecated in DICOM many years ago) to stand-along overlay data in 60xx,3000.
Public Method | Validate | Validate all DicomAttributes within the DicomDataset
Public Method | ValidateAll | [NEW] Validate all DicomAttributes within the DicomDataset based on the specified ValidationOptions.
Public Method | Value | Overloaded. Returns the value of the specified Data Element
Public Method | Write | Overloaded. Writes the dataset to an external DICOM file, a system IO stream or a byte array etc.
Public Method | WriteJson | Write the DICOM data into an Json Stream
Public Method | WriteXml | Write the DICOM data into an XML Stream
Top
See Also

Reference

DicomDataSet Class
DicomObjects Namespace


DicomDataSet Constructor

DicomDataSet Constructor

DicomObjects Namespace > DicomDataSet Class : DicomDataSet Constructor
Creates a new DicomDataSet
Overload List
Overload | Description
DicomDataSet Constructor() | Creates an empty DicomDataSet
DicomDataSet Constructor(DicomDataSet,Boolean) | Creates a new DicomDataSet from an existing DicomDataSet object
DicomDataSet Constructor(String,ReadBehaviours) | Creates a new DicomDataSet from an external DICOM file
DicomDataSet Constructor(Stream,ReadBehaviours) | Creates a new DicomDataSet from system IO stream
DicomDataSet Constructor(Byte[],ReadBehaviours) | Creates a new DicomDataSet from a byte array
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


DicomDataSet Constructor()

DicomDataSet Constructor()

DicomObjects Namespace > DicomDataSet Class > DicomDataSet Constructor : DicomDataSet Constructor()
Creates an empty DicomDataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DicomDataSet()
public DicomDataSet()
public:
DicomDataSet();

Return Value

DicomDataSet
Remarks
This is the constructor method.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


DicomDataSet Constructor(DicomDataSet,Boolean)

DicomDataSet Constructor(DicomDataSet,Boolean)

DicomObjects Namespace > DicomDataSet Class > DicomDataSet Constructor : DicomDataSet Constructor(DicomDataSet,Boolean)

The Origianl DicomDataSet object from which the new DicomDataSet is created.

Boolean, indicates weather a Deep/Shallow clone of the Original DicomDataSet will be performed when creating the new DicomDataSet.

Creates a new DicomDataSet from an existing DicomDataSet object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal Original As DicomDataSet, _
   ByVal Deep As Boolean _
)
'Usage

Dim Original As DicomDataSet
Dim Deep As Boolean

Dim instance As New DicomDataSet(Original, Deep)
public DicomDataSet(
   DicomDataSet Original,
   bool Deep
)
public:
DicomDataSet(
   DicomDataSet^ Original,
   bool Deep
)

Parameters

Original

The Origianl DicomDataSet object from which the new DicomDataSet is created.

Deep

Boolean, indicates weather a Deep/Shallow clone of the Original DicomDataSet will be performed when creating the new DicomDataSet.

Return Value

DicomDataSet
Remarks
A direct constructor of DicomDataSet object.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


DicomDataSet Constructor(String,ReadBehaviours)

DicomDataSet Constructor(String,ReadBehaviours)

DicomObjects Namespace > DicomDataSet Class > DicomDataSet Constructor : DicomDataSet Constructor(String,ReadBehaviours)

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

ReadBehavioursObject to control individual read operation
Creates a new DicomDataSet from an external DICOM file
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal Filename As String, _
   Optional ByVal ReadBehaviour As ReadBehaviours _
)
'Usage

Dim Filename As String
Dim ReadBehaviour As ReadBehaviours

Dim instance As New DicomDataSet(Filename, ReadBehaviour)
public DicomDataSet(
   string Filename,
   ReadBehaviours ReadBehaviour
)
public:
DicomDataSet(
   String^ Filename,
   ReadBehaviours^ ReadBehaviour
)

Parameters

Filename

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

ReadBehaviour
ReadBehavioursObject to control individual read operation

Return Value

DicomDataSet
Remarks
A direct constructor of DicomDataSet object.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


DicomDataSet Constructor(Stream,ReadBehaviours)

DicomDataSet Constructor(Stream,ReadBehaviours)

DicomObjects Namespace > DicomDataSet Class > DicomDataSet Constructor : DicomDataSet Constructor(Stream,ReadBehaviours)

The Stream from which to read.

ReadBehavioursObject to control individual read operation
Creates a new DicomDataSet from system IO stream
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal Stream As Stream, _
   Optional ByVal ReadBehaviour As ReadBehaviours _
)
'Usage

Dim Stream As Stream
Dim ReadBehaviour As ReadBehaviours

Dim instance As New DicomDataSet(Stream, ReadBehaviour)
public DicomDataSet(
   Stream Stream,
   ReadBehaviours ReadBehaviour
)
public:
DicomDataSet(
   Stream^ Stream,
   ReadBehaviours^ ReadBehaviour
)

Parameters

Stream

The Stream from which to read.

ReadBehaviour
ReadBehavioursObject to control individual read operation

Return Value

DicomDataSet
Remarks
A direct constructor of DicomDataSet object.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


DicomDataSet Constructor(Byte[],ReadBehaviours)

DicomDataSet Constructor(Byte[],ReadBehaviours)

DicomObjects Namespace > DicomDataSet Class > DicomDataSet Constructor : DicomDataSet Constructor(Byte[],ReadBehaviours)

The byte array to read

ReadBehavioursObject to control individual read operation
Creates a new DicomDataSet from a byte array
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal Array() As Byte, _
   Optional ByVal ReadBehaviour As ReadBehaviours _
)
'Usage

Dim Array() As Byte
Dim ReadBehaviour As ReadBehaviours

Dim instance As New DicomDataSet(Array, ReadBehaviour)
public DicomDataSet(
   byte[] Array,
   ReadBehaviours ReadBehaviour
)
public:
DicomDataSet(
   array<byte>^ Array,
   ReadBehaviours^ ReadBehaviour
)

Parameters

Array

The byte array to read

ReadBehaviour
ReadBehavioursObject to control individual read operation

Return Value

DicomDataSet
Remarks
A DicomDataSet constructor.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


DicomDataSet Class Methods

DicomDataSet Class Methods

DicomObjects Namespace : DicomDataSet Class

For a list of all members of this type, see DicomDataSet members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Creates and adds data elements to DicomDataSet
Public Method | AddByReference | Overloaded. Add byte[] as attribute value to avoid copying large data
Public Method | AddPixelData | Adds pixel data to DicomDataSet
Public Method | AddToDirectory | Overloaded. Simplified DICOMDIR creation
Public Method | ChangeCharacterSet | Change the specific Character Set of a DICOM dataset. All applicable attributes will have its data re-encoded by the new character set
Public Method | ChangeToDecompressed | Simulate the effect of writing out as a Decompressed Image
Public Method | Clear | Clear the DicomDataSet data
Public Method | Clone | Overloaded. Returns a copy of the DicomDataSet
Public Method | DecompressAll | Causes all the frames of an image to be decompressed.
Public Method | Dispose | Release the resources used by the DicomDataSet object
Public Method | FindAttribute | Locate an attribute within either a top level dataset, or within one of the functional group macros
Public Method | ForEachAttribute | Recursively perform an action on every attribute within the dataset
Public Method | FrameSubSet | Generates a new DicomDataSet as a subset of the current instance as described in supplement 119
Public Method | FunctionalGroupDataSet | Overloaded. Locate the required functional group within a DicomDataSet
Public Method | FunctionalGroupOrRootLevelAttribute | Overloaded. Return the required DicomAttribute within a specified functional group within a DicomDataSet If DicomAttribute is not present in the specified DicomDataSet, it searches amongst the root level attributes
Public Method | GetAllBulkData | Load All Bulk data for attributes
Public Method | GetAllURIBulkData | Load Bulk data from URI, getting data from web calls
Public Method | GetMinAndMax | Overloaded. Find the maximum and minimum pixel data values in the pixel data
Public Method | GetPixelStream | Returns the raw pixel data as a Stream object for a specific frame
Public Method | ImportPixelData | Direct import of compressed pixel data
Public Method | IsPresentationStateFor | Overloaded. Indicates if the PresentationState is for the specified DicomImage
Public Method | MergeBulkData | Load Bulk data for all attributes, getting data from a method, based on the URI
Public Method | Read | Overloaded. Reads from a standard Stream, with specific reading behaviour
Public Method | ReadJson | Read DICOM data from a Json Stream
Public Method | ReadURL | Reads DataSet from Web Address
Public Method | ReadXml | Read DICOM data from an XML Stream
Public Method | Remove | Overloaded. Removes an attribute from the DataSet
Public Method | RemovePrivateAttributes | Remove private attributes
Public Method | Send | Overloaded. Sends a DicomDataSet to a remote DICOM application
Public Method | SetDicomCodec | Specify a "DICOM" codec
Public Method | SetNonDicomCodec | Specify a non-DICOM source (e.g. AVI) as a source of frame data
Public Method | SetPlanarConfiguration | Sets the planar configuration in DicomDataSet
Public Method | SimplifyOverlays | Decompress the data, and move any overlays which are encoded with the pixel data (a method deprecated in DICOM many years ago) to stand-along overlay data in 60xx,3000.
Public Method | Validate | Validate all DicomAttributes within the DicomDataset
Public Method | ValidateAll | [NEW] Validate all DicomAttributes within the DicomDataset based on the specified ValidationOptions.
Public Method | Value | Overloaded. Returns the value of the specified Data Element
Public Method | Write | Overloaded. Writes the dataset to an external DICOM file, a system IO stream or a byte array etc.
Public Method | WriteJson | Write the DICOM data into an Json Stream
Public Method | WriteXml | Write the DICOM data into an XML Stream
Top
See Also

Reference

DicomDataSet Class
DicomObjects Namespace


Add Method (DicomDataSet)

Add Method (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : Add Method
Creates and adds data elements to DicomDataSet
Overload List
Overload | Description
Add(Int32,Int32,Object) | Creates and adds standard data elements to DicomDataSet
Add(DicomAttribute) | Add an existing attribute to the DataSet
Add(Keyword,Object) | Creates and adds standard data elements to DicomDataSet
Add(IEnumerable<DicomAttribute>) | Add a collection of DicomAttributes to the DataSet
Add(String,Object) | Creates and adds standard data elements to DicomDataSet
Add(Keyword,String,Object) | Creates and adds standard data elements to DicomDataSet
Add(Int32,Int32,String,Object) | Creates and adds standard data elements with specified VR to DicomDataSet
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


Add(Int32,Int32,Object) Method

Add(Int32,Int32,Object) Method

DicomObjects Namespace > DicomDataSet Class > Add Method : Add(Int32,Int32,Object) Method

The group index of a data element.

The element index of a data element.

The Value to be assigned

Creates and adds standard data elements to DicomDataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal Group As Integer, _
   ByVal Element As Integer, _
   ByVal Value As Object _
)
'Usage

Dim instance As DicomDataSet
Dim Group As Integer
Dim Element As Integer
Dim Value As Object

instance.Add(Group, Element, Value)
public void Add(
   int Group,
   int Element,
   object Value
)
public:
void Add(
   int Group,
   int Element,
   Object^ Value
)

Parameters

Group

The group index of a data element.

Element

The element index of a data element.

Value

The Value to be assigned

Remarks

This method is to add standard elements, VR of which will be determined by the internal dictionary. The type of value required for the "Value" parameter depends on the value representation of the data element, as defined by the values of group and element. Values of the types are always acceptable, as are values of other types that can be suitably coerced. Variants of type �null� are also accepted, resulting a zero-length data element, which can be useful in raw queries and for �type 2� elements. There are some special conditions relating to date and time types.

To create a sequence, value may be a DicomDataSetCollection.

If the data element being added has a potential value multiplicity (VM) of >1, then value may be either an array or scalar, but if the element�s VM is always 1, then an attempt to assign an array will generate an error.

Any existing data element with the same group and element will be silently replaced, even if it is an array.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Add(DicomAttribute) Method

Add(DicomAttribute) Method

DicomObjects Namespace > DicomDataSet Class > Add Method : Add(DicomAttribute) Method
An existing DicomAttribute to add
Add an existing attribute to the DataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal attribute As DicomAttribute _
)
'Usage

Dim instance As DicomDataSet
Dim attribute As DicomAttribute

instance.Add(attribute)
public void Add(
   DicomAttribute attribute
)
public:
void Add(
   DicomAttribute^ attribute
)

Parameters

attribute
An existing DicomAttribute to add
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Add(Keyword,Object) Method

Add(Keyword,Object) Method

DicomObjects Namespace > DicomDataSet Class > Add Method : Add(Keyword,Object) Method

The DICOM Keyword of the data element.

The Value to be assigned

Creates and adds standard data elements to DicomDataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal Keyword As Keyword, _
   ByVal Value As Object _
)
'Usage

Dim instance As DicomDataSet
Dim Keyword As Keyword
Dim Value As Object

instance.Add(Keyword, Value)
public void Add(
   Keyword Keyword,
   object Value
)
public:
void Add(
   Keyword Keyword,
   Object^ Value
)

Parameters

Keyword

The DICOM Keyword of the data element.

Value

The Value to be assigned

Remarks

This method is to add standard elements, VR of which will be determined by the internal dictionary. The type of value required for the "Value" parameter depends on the value representation of the data element, as defined by the values of group and element. Values of the types are always acceptable, as are values of other types that can be suitably coerced. Variants of type �null� are also accepted, resulting a zero-length data element, which can be useful in raw queries and for �type 2� elements. There are some special conditions relating to date and time types.

To create a sequence, value may be a DicomDataSetCollection.

If the data element being added has a potential value multiplicity (VM) of >1, then value may be either an array or scalar, but if the element�s VM is always 1, then an attempt to assign an array will generate an error.

Any existing data element with the same group and element will be silently replaced, even if it is an array.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Add(IEnumerable<DicomAttribute>) Method

Add(IEnumerable<DicomAttribute>) Method

DicomObjects Namespace > DicomDataSet Class > Add Method : Add(IEnumerable<DicomAttribute>) Method
A list of DicomAttribute to add
Add a collection of DicomAttributes to the DataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal attributes As IEnumerable(Of DicomAttribute) _
)
'Usage

Dim instance As DicomDataSet
Dim attributes As IEnumerable(Of DicomAttribute)

instance.Add(attributes)
public void Add(
   IEnumerable<DicomAttribute> attributes
)
public:
void Add(
   IEnumerable<DicomAttribute^>^ attributes
)

Parameters

attributes
A list of DicomAttribute to add
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Add(String,Object) Method

Add(String,Object) Method

DicomObjects Namespace > DicomDataSet Class > Add Method : Add(String,Object) Method

The DICOM Keyword of the data element.

The Value to be assigned

Creates and adds standard data elements to DicomDataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal Keyword As String, _
   ByVal Value As Object _
)
'Usage

Dim instance As DicomDataSet
Dim Keyword As String
Dim Value As Object

instance.Add(Keyword, Value)
public void Add(
   string Keyword,
   object Value
)
public:
void Add(
   String^ Keyword,
   Object^ Value
)

Parameters

Keyword

The DICOM Keyword of the data element.

Value

The Value to be assigned

Remarks

This method is to add standard elements, VR of which will be determined by the internal dictionary. The type of value required for the "Value" parameter depends on the value representation of the data element, as defined by the values of group and element. Values of the types are always acceptable, as are values of other types that can be suitably coerced. Variants of type �null� are also accepted, resulting a zero-length data element, which can be useful in raw queries and for �type 2� elements. There are some special conditions relating to date and time types.

To create a sequence, value may be a DicomDataSetCollection.

If the data element being added has a potential value multiplicity (VM) of >1, then value may be either an array or scalar, but if the element�s VM is always 1, then an attempt to assign an array will generate an error.

Any existing data element with the same group and element will be silently replaced, even if it is an array.

Although this method, taking a string as the keyword is available, where possible the aternative overload, taking an Enums.Keyword is preferable.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Add(Keyword,String,Object) Method

Add(Keyword,String,Object) Method

DicomObjects Namespace > DicomDataSet Class > Add Method : Add(Keyword,String,Object) Method

The DICOM Keyword of the data element.

The value representation (2 character string) of the data element to be added

The Value to be assigned

Creates and adds standard data elements to DicomDataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal Keyword As Keyword, _
   ByVal VR As String, _
   ByVal Value As Object _
)
'Usage

Dim instance As DicomDataSet
Dim Keyword As Keyword
Dim VR As String
Dim Value As Object

instance.Add(Keyword, VR, Value)
public void Add(
   Keyword Keyword,
   string VR,
   object Value
)
public:
void Add(
   Keyword Keyword,
   String^ VR,
   Object^ Value
)

Parameters

Keyword

The DICOM Keyword of the data element.

VR

The value representation (2 character string) of the data element to be added

Value

The Value to be assigned

Remarks

This method is to add standard elements, VR of which will be determined by the internal dictionary. The type of value required for the "Value" parameter depends on the value representation of the data element, as defined by the values of group and element. Values of the types are always acceptable, as are values of other types that can be suitably coerced. Variants of type �null� are also accepted, resulting a zero-length data element, which can be useful in raw queries and for �type 2� elements. There are some special conditions relating to date and time types.

To create a sequence, value may be a DicomDataSetCollection.

If the data element being added has a potential value multiplicity (VM) of >1, then value may be either an array or scalar, but if the element�s VM is always 1, then an attempt to assign an array will generate an error.

Any existing data element with the same group and element will be silently replaced, even if it is an array.

Although this method, taking a string as the keyword is available, where possible the aternative overload, taking an Enums.Keyword is preferable.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Add(Int32,Int32,String,Object) Method

Add(Int32,Int32,String,Object) Method

DicomObjects Namespace > DicomDataSet Class > Add Method : Add(Int32,Int32,String,Object) Method

The group index of a data element.

The element index of a data element.

The value representation (2 character string) of the data element to be added

The Value to be assigned

Creates and adds standard data elements with specified VR to DicomDataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal Group As Integer, _
   ByVal Element As Integer, _
   ByVal VR As String, _
   ByVal Value As Object _
)
'Usage

Dim instance As DicomDataSet
Dim Group As Integer
Dim Element As Integer
Dim VR As String
Dim Value As Object

instance.Add(Group, Element, VR, Value)
public void Add(
   int Group,
   int Element,
   string VR,
   object Value
)
public:
void Add(
   int Group,
   int Element,
   String^ VR,
   Object^ Value
)

Parameters

Group

The group index of a data element.

Element

The element index of a data element.

VR

The value representation (2 character string) of the data element to be added

Value

The Value to be assigned

Remarks

This method is to explicitly add elements with specified VR. The type of value required for the "Value" parameter depends on the value representation of the data element, as defined by either by the VR parameter. Values of the types are always acceptable, as are values of other types that can be suitably coerced. Variants of type "null" are also accepted, resulting a zero-length data element, which can be useful in raw queries and for �type 2� elements. There are some special conditions relating to date and time types.

To create a sequence, value may be a DicomDataSetCollection.

If the data element being added has a potential value multiplicity (VM) of >1, then value may be either an array or scalar, but if the element�s VM is always 1, then an attempt to assign an array will generate an error.

Any existing data element with the same group and element will be silently replaced, even if it is an array.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


AddByReference Method (DicomDataSet)

AddByReference Method (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : AddByReference Method
Add byte[] as attribute value to avoid copying large data
Overload List
Overload | Description
AddByReference(Keyword,Byte[]) | Add byte[] as attribute value to avoid copying large data
AddByReference(Keyword,String,Byte[]) | Add byte[] as attribute value to avoid copying large data
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


AddByReference(Keyword,Byte[]) Method

AddByReference(Keyword,Byte[]) Method

DicomObjects Namespace > DicomDataSet Class > AddByReference Method : AddByReference(Keyword,Byte[]) Method
Attribute tag to add
Attribute value as byte array
Add byte[] as attribute value to avoid copying large data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub AddByReference( _
   ByVal keyword As Keyword, _
   ByVal Value() As Byte _
)
'Usage

Dim instance As DicomDataSet
Dim keyword As Keyword
Dim Value() As Byte

instance.AddByReference(keyword, Value)
public void AddByReference(
   Keyword keyword,
   byte[] Value
)
public:
void AddByReference(
   Keyword keyword,
   array<byte>^ Value
)

Parameters

keyword
Attribute tag to add
Value
Attribute value as byte array
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


AddByReference(Keyword,String,Byte[]) Method

AddByReference(Keyword,String,Byte[]) Method

DicomObjects Namespace > DicomDataSet Class > AddByReference Method : AddByReference(Keyword,String,Byte[]) Method
Attribute tag to add
Attribute VR to add
Attribute value as byte array
Add byte[] as attribute value to avoid copying large data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub AddByReference( _
   ByVal keyword As Keyword, _
   ByVal VR As String, _
   ByVal Value() As Byte _
)
'Usage

Dim instance As DicomDataSet
Dim keyword As Keyword
Dim VR As String
Dim Value() As Byte

instance.AddByReference(keyword, VR, Value)
public void AddByReference(
   Keyword keyword,
   string VR,
   byte[] Value
)
public:
void AddByReference(
   Keyword keyword,
   String^ VR,
   array<byte>^ Value
)

Parameters

keyword
Attribute tag to add
VR
Attribute VR to add
Value
Attribute value as byte array
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


AddPixelData Method

AddPixelData Method

DicomObjects Namespace > DicomDataSet Class : AddPixelData Method

The Byte Array to be added to the Pixel Attribute (7FE0, 0010) of the DataSet

Specifies the UID of the transfer syntax in which the data is coded. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

Adds pixel data to DicomDataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub AddPixelData( _
   ByVal Data As Object, _
   ByVal TransferSyntax As String _
)
'Usage

Dim instance As DicomDataSet
Dim Data As Object
Dim TransferSyntax As String

instance.AddPixelData(Data, TransferSyntax)
public void AddPixelData(
   object Data,
   string TransferSyntax
)
public:
void AddPixelData(
   Object^ Data,
   String^ TransferSyntax
)

Parameters

Data

The Byte Array to be added to the Pixel Attribute (7FE0, 0010) of the DataSet

TransferSyntax

Specifies the UID of the transfer syntax in which the data is coded. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

Remarks
This method overwrites the pixel data (if present) in the DicomDataSet object.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


AddToDirectory Method

AddToDirectory Method

DicomObjects Namespace > DicomDataSet Class : AddToDirectory Method
Simplified DICOMDIR creation
Overload List
Overload | Description
AddToDirectory(DicomImage,String,String,Int16) | Simplified DICOMDIR creation with specified Image, Path, TransferSyntax and IconSize
AddToDirectory(DicomImage,String,String,Int16,QueryLevel) | Simplified DICOMDIR creation with specified Image, Path, TransferSyntax and IconSize
AddToDirectory(DicomDataSet,String,String) | Simplified DICOMDIR creation with specified Image, Path, TransferSyntax
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


AddToDirectory(DicomImage,String,String,Int16) Method

AddToDirectory(DicomImage,String,String,Int16) Method

DicomObjects Namespace > DicomDataSet Class > AddToDirectory Method : AddToDirectory(DicomImage,String,String,Int16) Method

Image from which to extract demographics, and (optionally) create an icon

The path is relative to where the DICOMDIR is to be written, and must conform to ISO9660/DICOM rules, and therefore be composed to up to 6 elements, each no more than 8 characters, with no extensions, separated by backslashes.

The format with which the image is to be written to disk

The size of the icon image to be included in the DICOMDIR � use 0 for no icon

Simplified DICOMDIR creation with specified Image, Path, TransferSyntax and IconSize
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function AddToDirectory( _
   ByVal Image As DicomImage, _
   ByVal Path As String, _
   ByVal TransferSyntax As String, _
   ByVal IconSize As Short _
) As DicomDataSetCollection
'Usage

Dim instance As DicomDataSet
Dim Image As DicomImage
Dim Path As String
Dim TransferSyntax As String
Dim IconSize As Short
Dim value As DicomDataSetCollection

value = instance.AddToDirectory(Image, Path, TransferSyntax, IconSize)
public DicomDataSetCollection AddToDirectory(
   DicomImage Image,
   string Path,
   string TransferSyntax,
   short IconSize
)
public:
DicomDataSetCollection^ AddToDirectory(
   DicomImage^ Image,
   String^ Path,
   String^ TransferSyntax,
   short IconSize
)

Parameters

Image

Image from which to extract demographics, and (optionally) create an icon

Path

The path is relative to where the DICOMDIR is to be written, and must conform to ISO9660/DICOM rules, and therefore be composed to up to 6 elements, each no more than 8 characters, with no extensions, separated by backslashes.

TransferSyntax

The format with which the image is to be written to disk

IconSize

The size of the icon image to be included in the DICOMDIR � use 0 for no icon

Return Value

DicomDataSetCollection
Remarks

This method makes the creation of DICOMDIR files much easier than previously. Simply create a new DicomDataSet object, then call this method for each image to be added to the file set. A full 4-level hierarchy is automatically created.

Note that this method does not write the image file to disk, it merely adds demographics from it, and possibly an icon to the DICOMDIR DicomDataSet.

The return value is a DicomDataSetCollection object containing 4 values, referencing the PATIENT, STUDY, SERIES and IMAGE Levels of the DICOMDIR, allowing optional attributes to be added if wished.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


AddToDirectory(DicomImage,String,String,Int16,QueryLevel) Method

AddToDirectory(DicomImage,String,String,Int16,QueryLevel) Method

DicomObjects Namespace > DicomDataSet Class > AddToDirectory Method : AddToDirectory(DicomImage,String,String,Int16,QueryLevel) Method

Image from which to extract demographics, and (optionally) create an icon

The path is relative to where the DICOMDIR is to be written, and must conform to ISO9660/DICOM rules, and therefore be composed to up to 6 elements, each no more than 8 characters, with no extensions, separated by backslashes.

The format with which the image is to be written to disk

The size of the icon image to be included in the DICOMDIR � use 0 for no icon

Specify which level to add the Icon to.

Simplified DICOMDIR creation with specified Image, Path, TransferSyntax and IconSize
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function AddToDirectory( _
   ByVal Image As DicomImage, _
   ByVal Path As String, _
   ByVal TransferSyntax As String, _
   ByVal IconSize As Short, _
   ByVal Level As QueryLevel _
) As DicomDataSetCollection
'Usage

Dim instance As DicomDataSet
Dim Image As DicomImage
Dim Path As String
Dim TransferSyntax As String
Dim IconSize As Short
Dim Level As QueryLevel
Dim value As DicomDataSetCollection

value = instance.AddToDirectory(Image, Path, TransferSyntax, IconSize, Level)
public DicomDataSetCollection AddToDirectory(
   DicomImage Image,
   string Path,
   string TransferSyntax,
   short IconSize,
   QueryLevel Level
)
public:
DicomDataSetCollection^ AddToDirectory(
   DicomImage^ Image,
   String^ Path,
   String^ TransferSyntax,
   short IconSize,
   QueryLevel Level
)

Parameters

Image

Image from which to extract demographics, and (optionally) create an icon

Path

The path is relative to where the DICOMDIR is to be written, and must conform to ISO9660/DICOM rules, and therefore be composed to up to 6 elements, each no more than 8 characters, with no extensions, separated by backslashes.

TransferSyntax

The format with which the image is to be written to disk

IconSize

The size of the icon image to be included in the DICOMDIR � use 0 for no icon

Level

Specify which level to add the Icon to.

Return Value

DicomDataSetCollection
Remarks

This method makes the creation of DICOMDIR files much easier than previously. Simply create a new DicomDataSet object, then call this method for each image to be added to the file set. A full 4-level hierarchy is automatically created.

Note that this method does not write the image file to disk, it merely adds demographics from it, and possibly an icon to the DICOMDIR DicomDataSet.

The return value is a DicomDataSetCollection object containing 4 values, referencing the PATIENT, STUDY, SERIES and IMAGE Levels of the DICOMDIR, allowing optional attributes to be added if wished.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


AddToDirectory(DicomDataSet,String,String) Method

AddToDirectory(DicomDataSet,String,String) Method

DicomObjects Namespace > DicomDataSet Class > AddToDirectory Method : AddToDirectory(DicomDataSet,String,String) Method

Image from which to extract demographics, and (optionally) create an icon

The path is relative to where the DICOMDIR is to be written, and must conform to ISO9660/DICOM rules, and therefore be composed to up to 8 elements, each no more than 8 characters, with no extensions, separated by backslashes.

The format with which the image is to be written to disk

Simplified DICOMDIR creation with specified Image, Path, TransferSyntax
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function AddToDirectory( _
   ByVal Image As DicomDataSet, _
   ByVal Path As String, _
   ByVal TransferSyntax As String _
) As DicomDataSetCollection
'Usage

Dim instance As DicomDataSet
Dim Image As DicomDataSet
Dim Path As String
Dim TransferSyntax As String
Dim value As DicomDataSetCollection

value = instance.AddToDirectory(Image, Path, TransferSyntax)
public DicomDataSetCollection AddToDirectory(
   DicomDataSet Image,
   string Path,
   string TransferSyntax
)
public:
DicomDataSetCollection^ AddToDirectory(
   DicomDataSet^ Image,
   String^ Path,
   String^ TransferSyntax
)

Parameters

Image

Image from which to extract demographics, and (optionally) create an icon

Path

The path is relative to where the DICOMDIR is to be written, and must conform to ISO9660/DICOM rules, and therefore be composed to up to 8 elements, each no more than 8 characters, with no extensions, separated by backslashes.

TransferSyntax

The format with which the image is to be written to disk

Return Value

DicomDataSetCollection
Remarks

This method makes the creation of DICOMDIR files much easier than previously. Simply create a new DicomDataSet object, then call this method for each image to be added to the file set. A full 4-level hierarchy is automatically created.

Note that this method does not write the image file to disk, it merely adds demographics from it, and possibly an icon to the DICOMDIR DicomDataSet.

The return value is a DicomDataSetCollection object containing 4 values, referencing the PATIENT, STUDY, SERIES and IMAGE Levels of the DICOMDIR, allowing optional attributes to be added if wished.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


ChangeCharacterSet Method

ChangeCharacterSet Method

DicomObjects Namespace > DicomDataSet Class : ChangeCharacterSet Method
The new Specific Character Set value
Change the specific Character Set of a DICOM dataset. All applicable attributes will have its data re-encoded by the new character set
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ChangeCharacterSet( _
   ByVal NewCharacterSet As String _
)
'Usage

Dim instance As DicomDataSet
Dim NewCharacterSet As String

instance.ChangeCharacterSet(NewCharacterSet)
public void ChangeCharacterSet(
   string NewCharacterSet
)
public:
void ChangeCharacterSet(
   String^ NewCharacterSet
)

Parameters

NewCharacterSet
The new Specific Character Set value
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


ChangeToDecompressed Method (DicomDataSet)

ChangeToDecompressed Method (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : ChangeToDecompressed Method
Simulate the effect of writing out as a Decompressed Image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ChangeToDecompressed()
'Usage

Dim instance As DicomDataSet

instance.ChangeToDecompressed()
public void ChangeToDecompressed()
public:
void ChangeToDecompressed();
Remarks
Unlike DecompressAll which is designed merely for performance improvement, this method permanently changes the data as if written out in an uncompressed transfer syntax and then read back. This might therefore change the Photometric interpretation etc. (e.g. from YBR_FULL_422 to RGB)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


Clear Method (DicomDataSet)

Clear Method (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : Clear Method
Clear the DicomDataSet data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Clear()
'Usage

Dim instance As DicomDataSet

instance.Clear()
public void Clear()
public:
void Clear();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


Clone Method (DicomDataSet)

Clone Method (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : Clone Method
Returns a copy of the DicomDataSet
Overload List
Overload | Description
Clone(Boolean) | Returns a copy of the DicomDataSet
Clone() | Returns a copy of the DicomDataSet
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


Clone(Boolean) Method

Clone(Boolean) Method

DicomObjects Namespace > DicomDataSet Class > Clone Method : Clone(Boolean) Method

If true then returns a Deep copy of the DicomDataSet.

If false, returns a Shallow copy.

Returns a copy of the DicomDataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Overridable Function Clone( _
   ByVal Deep As Boolean _
) As Object
'Usage

Dim instance As DicomDataSet
Dim Deep As Boolean
Dim value As Object

value = instance.Clone(Deep)
public virtual object Clone(
   bool Deep
)
public:
virtual Object^ Clone(
   bool Deep
)

Parameters

Deep

If true then returns a Deep copy of the DicomDataSet.

If false, returns a Shallow copy.

Return Value

DicomDataSet
Remarks

This method makes either a Shallow Copy or a Deep Copy of the DicomDataSet, dependants on the Deep parameter.

A shallow copy will only have the top level objects replicated, any referenced objects under the top level will be shared by the original DicomDataSet and the cloned copy.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Clone() Method

Clone() Method

DicomObjects Namespace > DicomDataSet Class > Clone Method : Clone() Method
Returns a copy of the DicomDataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Overridable Function Clone() As Object
'Usage

Dim instance As DicomDataSet
Dim value As Object

value = instance.Clone()
public virtual object Clone()
public:
virtual Object^ Clone();

Return Value

DicomDataSet
Remarks

This method makes a Shallow Copy of the DicomDataSet

A shallow copy will only have the top level objects replicated, any referenced objects under the top level will be shared by the original DicomDataSet and the cloned copy.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


DecompressAll Method (DicomDataSet)

DecompressAll Method (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : DecompressAll Method
Causes all the frames of an image to be decompressed.
Causes all the frames of an image to be decompressed into a byte array
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub DecompressAll()
'Usage

Dim instance As DicomDataSet

instance.DecompressAll()
public void DecompressAll()
public:
void DecompressAll();
Remarks

The normal policy adopted by DicomObjects for the handling of compressed images is to decompress frames only when necessary, and to keep the decompressed versions only for as long as is necessary for display or transmission, thereby minimising image load times, and memory use. This behaviour is not, however, always appropriate, especially when cine sequences are shown, or where modifications need to be made to the image. When this method is called, all frames are decompressed and held in RAM, replacing the original compressed version, thereby greatly speeding subsequent display, though needing much more memory.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


Dispose Method (DicomDataSet)

Dispose Method (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : Dispose Method
Release the resources used by the DicomDataSet object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Sub Dispose()
'Usage

Dim instance As DicomDataSet

instance.Dispose()
public virtual void Dispose()
public:
virtual void Dispose();
Remarks
This method releases all resources used by the DicomDataSet object.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


FindAttribute Method

FindAttribute Method

DicomObjects Namespace > DicomDataSet Class : FindAttribute Method
The sequence in a functional group that this attribute is part of
The item to be found
The frame number. This is only relevant if the item is found within the PerFrame functional groups sequence
Locate an attribute within either a top level dataset, or within one of the functional group macros
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function FindAttribute( _
   ByVal Macro As Keyword, _
   ByVal Item As Keyword, _
   ByVal Frame As Integer _
) As DicomAttribute
'Usage

Dim instance As DicomDataSet
Dim Macro As Keyword
Dim Item As Keyword
Dim Frame As Integer
Dim value As DicomAttribute

value = instance.FindAttribute(Macro, Item, Frame)
public DicomAttribute FindAttribute(
   Keyword Macro,
   Keyword Item,
   int Frame
)
public:
DicomAttribute^ FindAttribute(
   Keyword Macro,
   Keyword Item,
   int Frame
)

Parameters

Macro
The sequence in a functional group that this attribute is part of
Item
The item to be found
Frame
The frame number. This is only relevant if the item is found within the PerFrame functional groups sequence

Return Value

The requested DicomAttribute
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


ForEachAttribute Method

ForEachAttribute Method

DicomObjects Namespace > DicomDataSet Class : ForEachAttribute Method
Delegate, which takes as a parameter, the path to each attribute.
Recursively perform an action on every attribute within the dataset
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ForEachAttribute( _
   ByVal action As Action(Of SequencePath) _
)
'Usage

Dim instance As DicomDataSet
Dim action As Action(Of SequencePath)

instance.ForEachAttribute(action)
public void ForEachAttribute(
   Action<SequencePath> action
)
public:
void ForEachAttribute(
   Action<SequencePath^>^ action
)

Parameters

action
Delegate, which takes as a parameter, the path to each attribute.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


FrameSubSet(IEnumerable<UInt32>) Method

FrameSubSet(IEnumerable<UInt32>) Method

DicomObjects Namespace > DicomDataSet Class : FrameSubSet(IEnumerable<UInt32>) Method
Requested frame numbers
Generates a new DicomDataSet as a subset of the current instance as described in supplement 119
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function FrameSubSet( _
   ByVal Frames As IEnumerable(Of UInteger) _
) As DicomDataSet
'Usage

Dim instance As DicomDataSet
Dim Frames As IEnumerable(Of UInteger)
Dim value As DicomDataSet

value = instance.FrameSubSet(Frames)
public DicomDataSet FrameSubSet(
   IEnumerable<uint> Frames
)
public:
DicomDataSet^ FrameSubSet(
   IEnumerable<uint>^ Frames
)

Parameters

Frames
Requested frame numbers

Return Value

Subset DicomDataSet that includes the requested frames
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


FunctionalGroupDataSet Method

FunctionalGroupDataSet Method

DicomObjects Namespace > DicomDataSet Class : FunctionalGroupDataSet Method
Locate the required functional group within a DicomDataSet
Overload List
Overload | Description
FunctionalGroupDataSet(Int32,Int32,Int32) | Locate the required functional group within a DicomDataSet
FunctionalGroupDataSet(Keyword,Int32) | Locate the required functional group within a DicomDataSet
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


FunctionalGroupDataSet(Int32,Int32,Int32) Method

FunctionalGroupDataSet(Int32,Int32,Int32) Method

DicomObjects Namespace > DicomDataSet Class > FunctionalGroupDataSet Method : FunctionalGroupDataSet(Int32,Int32,Int32) Method
The Group of the requested dataset
The Element of the requested dataset
The frame number to which the dataset should apply
Locate the required functional group within a DicomDataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function FunctionalGroupDataSet( _
   ByVal FunctionalGroup As Integer, _
   ByVal FunctionalElement As Integer, _
   ByVal Frame As Integer _
) As DicomDataSet
'Usage

Dim instance As DicomDataSet
Dim FunctionalGroup As Integer
Dim FunctionalElement As Integer
Dim Frame As Integer
Dim value As DicomDataSet

value = instance.FunctionalGroupDataSet(FunctionalGroup, FunctionalElement, Frame)
public DicomDataSet FunctionalGroupDataSet(
   int FunctionalGroup,
   int FunctionalElement,
   int Frame
)
public:
DicomDataSet^ FunctionalGroupDataSet(
   int FunctionalGroup,
   int FunctionalElement,
   int Frame
)

Parameters

FunctionalGroup
The Group of the requested dataset
FunctionalElement
The Element of the requested dataset
Frame
The frame number to which the dataset should apply

Return Value

The requested dataset
Remarks
The enhanced DICOM multi-frame objects (e.g. enhanced CT and MRI) allow many attributes to be held in functional group macros, which may be either:
  • The same for all frames - in the "Shared Functional Groups Sequence" (5200,9229)
  • Different for different frames - in the "Per-frame Functional Groups Sequence" (5200,9230)
This method allows the designated dataset to be located, irrespective of which sequence it is in. Note that the Group and Element used to identify the functional group are independent of the Group and Element of individual attributes within that DataSet.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


FunctionalGroupDataSet(Keyword,Int32) Method

FunctionalGroupDataSet(Keyword,Int32) Method

DicomObjects Namespace > DicomDataSet Class > FunctionalGroupDataSet Method : FunctionalGroupDataSet(Keyword,Int32) Method
The Keyword descriptor of the requested dataset
The frame number to which the dataset should apply
Locate the required functional group within a DicomDataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function FunctionalGroupDataSet( _
   ByVal Macro As Keyword, _
   ByVal Frame As Integer _
) As DicomDataSet
'Usage

Dim instance As DicomDataSet
Dim Macro As Keyword
Dim Frame As Integer
Dim value As DicomDataSet

value = instance.FunctionalGroupDataSet(Macro, Frame)
public DicomDataSet FunctionalGroupDataSet(
   Keyword Macro,
   int Frame
)
public:
DicomDataSet^ FunctionalGroupDataSet(
   Keyword Macro,
   int Frame
)

Parameters

Macro
The Keyword descriptor of the requested dataset
Frame
The frame number to which the dataset should apply

Return Value

The requested dataset
Remarks
The enhanced DICOM multi-frame objects (e.g. enhanced CT and MRI) allow many attributes to be held in functional group macros, which may be either:
  • The same for all frames - in the "Shared Functional Groups Sequence" (5200,9229)
  • Different for different frames - in the "Per-frame Functional Groups Sequence" (5200,9230)
This method allows the designated dataset to be located, irrespective of which sequence it is in. Note that the Keyword used to identify the functional group is independent of the Keyword of individual attributes within that DataSet.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


FunctionalGroupOrRootLevelAttribute Method

FunctionalGroupOrRootLevelAttribute Method

DicomObjects Namespace > DicomDataSet Class : FunctionalGroupOrRootLevelAttribute Method
Return the required DicomAttribute within a specified functional group within a DicomDataSet If DicomAttribute is not present in the specified DicomDataSet, it searches amongst the root level attributes
Overload List
Overload | Description
FunctionalGroupOrRootLevelAttribute(Keyword,Int32,Keyword) | Return the required DicomAttribute within a specified functional group within a DicomDataSet If DicomAttribute is not present in the specified DicomDataSet, it searches amongst the root level attributes
FunctionalGroupOrRootLevelAttribute(Int32,Int32,Int32,Int32,Int32) | Return the required DicomAttribute within a specified functional group within a DicomDataSet
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


FunctionalGroupOrRootLevelAttribute(Keyword,Int32,Keyword) Method

FunctionalGroupOrRootLevelAttribute(Keyword,Int32,Keyword) Method

DicomObjects Namespace > DicomDataSet Class > FunctionalGroupOrRootLevelAttribute Method : FunctionalGroupOrRootLevelAttribute(Keyword,Int32,Keyword) Method
The keyword of the requested dataset
The frame number to which the dataset should apply
The keyword of the requested attribute within the dataset
Return the required DicomAttribute within a specified functional group within a DicomDataSet If DicomAttribute is not present in the specified DicomDataSet, it searches amongst the root level attributes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function FunctionalGroupOrRootLevelAttribute( _
   ByVal FunctionalAttribute As Keyword, _
   ByVal Frame As Integer, _
   ByVal keyword As Keyword _
) As DicomAttribute
'Usage

Dim instance As DicomDataSet
Dim FunctionalAttribute As Keyword
Dim Frame As Integer
Dim keyword As Keyword
Dim value As DicomAttribute

value = instance.FunctionalGroupOrRootLevelAttribute(FunctionalAttribute, Frame, keyword)
public DicomAttribute FunctionalGroupOrRootLevelAttribute(
   Keyword FunctionalAttribute,
   int Frame,
   Keyword keyword
)
public:
DicomAttribute^ FunctionalGroupOrRootLevelAttribute(
   Keyword FunctionalAttribute,
   int Frame,
   Keyword keyword
)

Parameters

FunctionalAttribute
The keyword of the requested dataset
Frame
The frame number to which the dataset should apply
keyword
The keyword of the requested attribute within the dataset

Return Value

The requested DicomAttribute
Remarks
The enhanced DICOM multi-frame objects (e.g. enhanced CT and MRI) allow many attributes to be held in functional group macros, which may be either:
  • The same for all frames - in the "Shared Functional Groups Sequence" (5200,9229)
  • Different for different frames - in the "Per-frame Functional Groups Sequence" (5200,9230)
This method allows an attribute to be retrieved from the chosen dataset, irrespective of which sequence it is in. Note that the DicomObjects.Enums.Keyword used to identify the functional group is independent of the DicomObjects.Enums.Keyword of individual attributes within that DataSet.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


FunctionalGroupOrRootLevelAttribute(Int32,Int32,Int32,Int32,Int32) Method

FunctionalGroupOrRootLevelAttribute(Int32,Int32,Int32,Int32,Int32) Method

DicomObjects Namespace > DicomDataSet Class > FunctionalGroupOrRootLevelAttribute Method : FunctionalGroupOrRootLevelAttribute(Int32,Int32,Int32,Int32,Int32) Method
The Group of the requested dataset
The Element of the requested dataset
The frame number to which the dataset should apply
The Group number of the requested attribute within the dataset
The Element number of the requested attribute within the dataset
Return the required DicomAttribute within a specified functional group within a DicomDataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function FunctionalGroupOrRootLevelAttribute( _
   ByVal FunctionalGroup As Integer, _
   ByVal FunctionalElement As Integer, _
   ByVal Frame As Integer, _
   ByVal Group As Integer, _
   ByVal Element As Integer _
) As DicomAttribute
'Usage

Dim instance As DicomDataSet
Dim FunctionalGroup As Integer
Dim FunctionalElement As Integer
Dim Frame As Integer
Dim Group As Integer
Dim Element As Integer
Dim value As DicomAttribute

value = instance.FunctionalGroupOrRootLevelAttribute(FunctionalGroup, FunctionalElement, Frame, Group, Element)
public DicomAttribute FunctionalGroupOrRootLevelAttribute(
   int FunctionalGroup,
   int FunctionalElement,
   int Frame,
   int Group,
   int Element
)
public:
DicomAttribute^ FunctionalGroupOrRootLevelAttribute(
   int FunctionalGroup,
   int FunctionalElement,
   int Frame,
   int Group,
   int Element
)

Parameters

FunctionalGroup
The Group of the requested dataset
FunctionalElement
The Element of the requested dataset
Frame
The frame number to which the dataset should apply
Group
The Group number of the requested attribute within the dataset
Element
The Element number of the requested attribute within the dataset

Return Value

The requested DicomAttribute
Remarks
The enhanced DICOM multi-frame objects (e.g. enhanced CT and MRI) allow many attributes to be held in functional group macros, which may be either:
  • The same for all frames - in the "Shared Functional Groups Sequence" (5200,9229)
  • Different for different frames - in the "Per-frame Functional Groups Sequence" (5200,9230)
This method allows an attribute to be retrieved from the chosen dataset, irrespective of which sequence it is in. Note that the Group and Element used to identify the functional group are independent of the Group and Element of individual attributes within that DataSet.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


GetAllBulkData Method

GetAllBulkData Method

DicomObjects Namespace > DicomDataSet Class : GetAllBulkData Method
Load All Bulk data for attributes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub GetAllBulkData()
'Usage

Dim instance As DicomDataSet

instance.GetAllBulkData()
public void GetAllBulkData()
public:
void GetAllBulkData();
Remarks
This method is used to re-assemble all bulk data from different means specified in the attribute for obtaining bulk data (e.g. BulkDataUri)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


GetAllURIBulkData Method

GetAllURIBulkData Method

DicomObjects Namespace > DicomDataSet Class : GetAllURIBulkData Method
Load Bulk data from URI, getting data from web calls
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub GetAllURIBulkData()
'Usage

Dim instance As DicomDataSet

instance.GetAllURIBulkData()
public void GetAllURIBulkData()
public:
void GetAllURIBulkData();
Remarks
This method is used to re-assemble data from WADO-RS (metadata only) etc., where some bulk data items have been removed from the data sent, but are available via a URI.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


GetMinAndMax Method (DicomDataSet)

GetMinAndMax Method (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : GetMinAndMax Method
Find the maximum and minimum pixel data values in the pixel data
Overload List
Overload | Description
GetMinAndMax(Single,Single,Single,Boolean) | Find the maximum and minimum pixel data values in the pixel data
GetMinAndMax(Single,Single,Single,Boolean,Boolean) | Find the maximum and minimum pixel data values in the pixel data
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


GetMinAndMax(Single,Single,Single,Boolean) Method

GetMinAndMax(Single,Single,Single,Boolean) Method

DicomObjects Namespace > DicomDataSet Class > GetMinAndMax Method : GetMinAndMax(Single,Single,Single,Boolean) Method
The minimum value found
The maximum value found
Proportion of extreme values to ignore
Whether to apply scaling/modality lookup table transformation
Find the maximum and minimum pixel data values in the pixel data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub GetMinAndMax( _
   ByRef Min As Single, _
   ByRef Max As Single, _
   ByVal Centile As Single, _
   ByVal Scale As Boolean _
)
'Usage

Dim instance As DicomDataSet
Dim Min As Single
Dim Max As Single
Dim Centile As Single
Dim Scale As Boolean

instance.GetMinAndMax(Min, Max, Centile, Scale)
public void GetMinAndMax(
   out float Min,
   out float Max,
   float Centile,
   bool Scale
)
public:
void GetMinAndMax(
   [Out] float Min,
   [Out] float Max,
   float Centile,
   bool Scale
)

Parameters

Min
The minimum value found
Max
The maximum value found
Centile
Proportion of extreme values to ignore
Scale
Whether to apply scaling/modality lookup table transformation
Remarks

Pixel padding values are ignored

If Scale is false, then the values returned are "raw" values before application of rescaling or modality lookup tables

If Scale is true, then the values returned are transformed using the modality slope and intercept or modality lookup tables as appropriate to the image

If it is necessray to use separate control for the 2 scaling methods, then the GetMinAndMax(Single,Single,Single,Boolean,Boolean) override may be used instead.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


GetMinAndMax(Single,Single,Single,Boolean,Boolean) Method

GetMinAndMax(Single,Single,Single,Boolean,Boolean) Method

DicomObjects Namespace > DicomDataSet Class > GetMinAndMax Method : GetMinAndMax(Single,Single,Single,Boolean,Boolean) Method
The minimum value found
The maximum value found
Centile as Float
Whether to apply modality lookup table transformation
Whether to apply modality rescale slope and offset transformations
Find the maximum and minimum pixel data values in the pixel data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub GetMinAndMax( _
   ByRef Min As Single, _
   ByRef Max As Single, _
   ByVal Centile As Single, _
   ByVal ScaleLUT As Boolean, _
   ByVal ScaleRescale As Boolean _
)
'Usage

Dim instance As DicomDataSet
Dim Min As Single
Dim Max As Single
Dim Centile As Single
Dim ScaleLUT As Boolean
Dim ScaleRescale As Boolean

instance.GetMinAndMax(Min, Max, Centile, ScaleLUT, ScaleRescale)
public void GetMinAndMax(
   out float Min,
   out float Max,
   float Centile,
   bool ScaleLUT,
   bool ScaleRescale
)
public:
void GetMinAndMax(
   [Out] float Min,
   [Out] float Max,
   float Centile,
   bool ScaleLUT,
   bool ScaleRescale
)

Parameters

Min
The minimum value found
Max
The maximum value found
Centile
Centile as Float
ScaleLUT
Whether to apply modality lookup table transformation
ScaleRescale
Whether to apply modality rescale slope and offset transformations
Remarks

Pixel padding values are ignored

If ScaleLUT is false, then the values returned are "raw" values before application of rescaling or modality lookup tables

If ScaleLUT is true, then the values returned are transformed using the modality slope and intercept or modality lookup tables as appropriate to the image

If it is necessray to use separate control for the 2 scaling methods, then the GetMinAndMax(Single,Single,Single,Boolean,Boolean) override may be used instead.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


GetPixelStream Method

GetPixelStream Method

DicomObjects Namespace > DicomDataSet Class : GetPixelStream Method
Requested pixel data for the frame
Returns the raw pixel data as a Stream object for a specific frame
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function GetPixelStream( _
   ByVal Frame As Integer _
) As Stream
'Usage

Dim instance As DicomDataSet
Dim Frame As Integer
Dim value As Stream

value = instance.GetPixelStream(Frame)
public Stream GetPixelStream(
   int Frame
)
public:
Stream^ GetPixelStream(
   int Frame
)

Parameters

Frame
Requested pixel data for the frame

Return Value

PixelData of the specified frame or null if it is uncompressed data or it encounters any failure during conversion
Remarks
Specify requested frame as 1 for MPEG data (mpeg 1,2,4) as they are defined/handled as 1 frame in DICOM
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


ImportPixelData Method

ImportPixelData Method

DicomObjects Namespace > DicomDataSet Class : ImportPixelData Method
The data fragments
The transfer synatax corresponding to the data
Direct import of compressed pixel data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ImportPixelData( _
   ByVal CompressedData As IEnumerable(Of Byte()), _
   ByVal TransferSyntax As String _
)
'Usage

Dim instance As DicomDataSet
Dim CompressedData As IEnumerable(Of Byte())
Dim TransferSyntax As String

instance.ImportPixelData(CompressedData, TransferSyntax)
public void ImportPixelData(
   IEnumerable<byte[]> CompressedData,
   string TransferSyntax
)
public:
void ImportPixelData(
   IEnumerable<array<byte>>^ CompressedData,
   String^ TransferSyntax
)

Parameters

CompressedData
The data fragments
TransferSyntax
The transfer synatax corresponding to the data
Remarks

This is an advanced technique, as no validation or data extraction is performed by DicomObjects, so those using it are responsible for setting all related attributes directly, including:

  • Rows and columns
  • Photometric Interpretation
  • Frame Count
  • The bit depth values (0028,0100-0028,0103)

For MPEG, there must only be one fragment, covering all frames. For other transfer syntaxes, there is normally one fragment per frame.

This method should not normally be used to import JPEG images, as most "normal" JPEG images have a JFIF header which is not permitted in DICOM - use the DicomImage.Import method instead.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


IsPresentationStateFor Method

IsPresentationStateFor Method

DicomObjects Namespace > DicomDataSet Class : IsPresentationStateFor Method
Indicates if the PresentationState is for the specified DicomImage
Overload List
Overload | Description
IsPresentationStateFor(DicomImage) | Indicates if the PresentationState is for the specified DicomImage
IsPresentationStateFor(DicomImage,Int32) | Indicates if the PresentationState is for the specified DicomImage
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


IsPresentationStateFor(DicomImage) Method

IsPresentationStateFor(DicomImage) Method

DicomObjects Namespace > DicomDataSet Class > IsPresentationStateFor Method : IsPresentationStateFor(DicomImage) Method

The DicomImage to check for its InstanceUID

Indicates if the PresentationState is for the specified DicomImage
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function IsPresentationStateFor( _
   ByVal Image As DicomImage _
) As Boolean
'Usage

Dim instance As DicomDataSet
Dim Image As DicomImage
Dim value As Boolean

value = instance.IsPresentationStateFor(Image)
public bool IsPresentationStateFor(
   DicomImage Image
)
public:
bool IsPresentationStateFor(
   DicomImage^ Image
)

Parameters

Image

The DicomImage to check for its InstanceUID

Return Value

true if the presentationstate matches the image
Remarks
The Image's InstanceUID is checked against the value specified in the PresentationState's referenced Image SOP Instance UID field. This method returns true if the two values match, otherwise it returns false.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


IsPresentationStateFor(DicomImage,Int32) Method

IsPresentationStateFor(DicomImage,Int32) Method

DicomObjects Namespace > DicomDataSet Class > IsPresentationStateFor Method : IsPresentationStateFor(DicomImage,Int32) Method

The DicomImage to check for its InstanceUID

Specify which frame to check

Indicates if the PresentationState is for the specified DicomImage
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function IsPresentationStateFor( _
   ByVal Image As DicomImage, _
   ByVal Frame As Integer _
) As Boolean
'Usage

Dim instance As DicomDataSet
Dim Image As DicomImage
Dim Frame As Integer
Dim value As Boolean

value = instance.IsPresentationStateFor(Image, Frame)
public bool IsPresentationStateFor(
   DicomImage Image,
   int Frame
)
public:
bool IsPresentationStateFor(
   DicomImage^ Image,
   int Frame
)

Parameters

Image

The DicomImage to check for its InstanceUID

Frame

Specify which frame to check

Return Value

true if the presentationstate matches the image
Remarks
The Image's InstanceUID is checked against the value specified in the PresentationState's referenced Image SOP Instance UID field. The frame number is also checked against the values specified in the PresentationState. This method returns true if the the values match, otherwise it returns false.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


MergeBulkData Method

MergeBulkData Method

DicomObjects Namespace > DicomDataSet Class : MergeBulkData Method
A method which, when passed a URI, returns the associated byte array
If true, then an exception is thrown if any items cannot be found
Load Bulk data for all attributes, getting data from a method, based on the URI
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub MergeBulkData( _
   ByVal GetData As Func(Of Uri,String,HttpContent), _
   ByVal RequireBulkData As Boolean _
)
'Usage

Dim instance As DicomDataSet
Dim GetData As Func(Of Uri,String,HttpContent)
Dim RequireBulkData As Boolean

instance.MergeBulkData(GetData, RequireBulkData)
public void MergeBulkData(
   Func<Uri,string,HttpContent> GetData,
   bool RequireBulkData
)
public:
void MergeBulkData(
   Func<Uri^,String^,HttpContent^>^ GetData,
   bool RequireBulkData
)

Parameters

GetData
A method which, when passed a URI, returns the associated byte array
RequireBulkData
If true, then an exception is thrown if any items cannot be found
Remarks
This method is used to re-assemble data from STOW-RS etc., where some bulk data items have been sent as parts of a multipart message, and the GetData delegate points to a routine which finds the appropriate part of the message.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


Read Method (DicomDataSet)

Read Method (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : Read Method
Reads from a standard Stream, with specific reading behaviour
Overload List
Overload | Description
Read(Stream,ReadBehaviours) | Reads from a standard Stream, with specific reading behaviour
Read(String,ReadBehaviours) | Reads from a DICOM file, using specific read behaviours
Read(Byte[],ReadBehaviours) | Reads from a byte array
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


Read(Stream,ReadBehaviours) Method

Read(Stream,ReadBehaviours) Method

DicomObjects Namespace > DicomDataSet Class > Read Method : Read(Stream,ReadBehaviours) Method

The Stream from which to read.

The behaviours to be used when reading this stream

Reads from a standard Stream, with specific reading behaviour
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Read( _
   ByVal Stream As Stream, _
   Optional ByVal ReadBehaviour As ReadBehaviours _
)
'Usage

Dim instance As DicomDataSet
Dim Stream As Stream
Dim ReadBehaviour As ReadBehaviours

instance.Read(Stream, ReadBehaviour)
public void Read(
   Stream Stream,
   ReadBehaviours ReadBehaviour
)
public:
void Read(
   Stream^ Stream,
   ReadBehaviours^ ReadBehaviour
)

Parameters

Stream

The Stream from which to read.

ReadBehaviour

The behaviours to be used when reading this stream

Remarks

This method can read streams in either official "Part10" format, with the 128 byte header, or unofficial "Part5" format, without a header. Detection of the type is automatic.

The stream may have been written by the Write method or by other DICOM software.

It is the caller's responsibility to position the stream correctly before calling this method - no rewind is done internally.

This in the only method to provide this additional Behaviour parameter, but all other Read opeations may be performed by creating a suitable stream from the file, byte[] etc., and using a null Password if necessary.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Read(String,ReadBehaviours) Method

Read(String,ReadBehaviours) Method

DicomObjects Namespace > DicomDataSet Class > Read Method : Read(String,ReadBehaviours) Method

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

The behaviours to be used when reading this stream

Reads from a DICOM file, using specific read behaviours
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Read( _
   ByVal FileName As String, _
   Optional ByVal ReadBehaviour As ReadBehaviours _
)
'Usage

Dim instance As DicomDataSet
Dim FileName As String
Dim ReadBehaviour As ReadBehaviours

instance.Read(FileName, ReadBehaviour)
public void Read(
   string FileName,
   ReadBehaviours ReadBehaviour
)
public:
void Read(
   String^ FileName,
   ReadBehaviours^ ReadBehaviour
)

Parameters

FileName

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

ReadBehaviour

The behaviours to be used when reading this stream

Remarks

This method can read files in either official "Part10" format, with the 128 byte header, or unofficial "Part5" format, without a header. Detection of the type is automatic.

The file may have been written by the Write method or by other DICOM software.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Read(Byte[],ReadBehaviours) Method

Read(Byte[],ReadBehaviours) Method

DicomObjects Namespace > DicomDataSet Class > Read Method : Read(Byte[],ReadBehaviours) Method

The byte array to read

The behaviours to be used when reading this stream

Reads from a byte array
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Read( _
   ByVal Array() As Byte, _
   Optional ByVal Behaviour As ReadBehaviours _
)
'Usage

Dim instance As DicomDataSet
Dim Array() As Byte
Dim Behaviour As ReadBehaviours

instance.Read(Array, Behaviour)
public void Read(
   byte[] Array,
   ReadBehaviours Behaviour
)
public:
void Read(
   array<byte>^ Array,
   ReadBehaviours^ Behaviour
)

Parameters

Array

The byte array to read

Behaviour

The behaviours to be used when reading this stream

Remarks
Reads an array of bytes, which may have been written by the Write method.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


ReadJson Method (DicomDataSet)

ReadJson Method (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : ReadJson Method
The Stream to read from
Read DICOM data from a Json Stream
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ReadJson( _
   ByVal Stream As Stream _
)
'Usage

Dim instance As DicomDataSet
Dim Stream As Stream

instance.ReadJson(Stream)
public void ReadJson(
   Stream Stream
)
public:
void ReadJson(
   Stream^ Stream
)

Parameters

Stream
The Stream to read from
Remarks
The Json data must be compliant with the Native DICOM Model outlined in the DICOM Part 19 (Application Hosting), with modifications as defined in supplement 163 to allow bulk data
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


ReadURL Method (DicomDataSet)

ReadURL Method (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : ReadURL Method

The web address of the DataSet to read.

Reads DataSet from Web Address
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ReadURL( _
   ByVal URL As String _
)
'Usage

Dim instance As DicomDataSet
Dim URL As String

instance.ReadURL(URL)
public void ReadURL(
   string URL
)
public:
void ReadURL(
   String^ URL
)

Parameters

URL

The web address of the DataSet to read.

Remarks

A valid web address should be provided by the user. This method does not support progressive downloading (JPIP support is to be implemented).

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


ReadXml Method

ReadXml Method

DicomObjects Namespace > DicomDataSet Class : ReadXml Method
The Stream to read from
The transfer syntax to assign to the resulting instances - see remarks
Read DICOM data from an XML Stream
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ReadXml( _
   ByVal Stream As Stream, _
   Optional ByVal TransferSyntax As String _
)
'Usage

Dim instance As DicomDataSet
Dim Stream As Stream
Dim TransferSyntax As String

instance.ReadXml(Stream, TransferSyntax)
public void ReadXml(
   Stream Stream,
   string TransferSyntax
)
public:
void ReadXml(
   Stream^ Stream,
   String^ TransferSyntax
)

Parameters

Stream
The Stream to read from
TransferSyntax
The transfer syntax to assign to the resulting instances - see remarks
Remarks

The XML data must be compliant with the Native DICOM Model outlined in the DICOM Part 19 (Application Hosting), with modifications as defined in supplement 163 to allow bulk data

The TransferSyntaxvalue does not directly affect the data itself, which is independent of transfer syntax, but the assigned value may be used internally to control the form in which are missing bulk data (e.g. pixel data) is requested fromn an origin server if replaced by a BulkDataUri property.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


Remove Method (DicomDataSet)

Remove Method (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : Remove Method
Removes an attribute from the DataSet
Overload List
Overload | Description
Remove(Int32,Int32) | Removes an attribute from the DataSet
Remove(Keyword) | Removes an attribute from the DataSet
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


Remove(Int32,Int32) Method

Remove(Int32,Int32) Method

DicomObjects Namespace > DicomDataSet Class > Remove Method : Remove(Int32,Int32) Method

The group index of a data element

The element index of a data element

Removes an attribute from the DataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Remove( _
   ByVal Group As Integer, _
   ByVal Element As Integer _
)
'Usage

Dim instance As DicomDataSet
Dim Group As Integer
Dim Element As Integer

instance.Remove(Group, Element)
public void Remove(
   int Group,
   int Element
)
public:
void Remove(
   int Group,
   int Element
)

Parameters

Group

The group index of a data element

Element

The element index of a data element

Remarks

If the appropriate data element exists in the DicomDataSet, it is removed.

No error is generated if the requested item is not present in the DataSet.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Remove(Keyword) Method

Remove(Keyword) Method

DicomObjects Namespace > DicomDataSet Class > Remove Method : Remove(Keyword) Method
The attribute to be removed, specified as a Keyword
Removes an attribute from the DataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Remove( _
   ByVal Keyword As Keyword _
)
'Usage

Dim instance As DicomDataSet
Dim Keyword As Keyword

instance.Remove(Keyword)
public void Remove(
   Keyword Keyword
)
public:
void Remove(
   Keyword Keyword
)

Parameters

Keyword
The attribute to be removed, specified as a Keyword
Remarks

If the appropriate data element exists in the DicomDataSet, it is removed.

No error is generated if the requested item is not present in the DataSet.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


RemovePrivateAttributes Method

RemovePrivateAttributes Method

DicomObjects Namespace > DicomDataSet Class : RemovePrivateAttributes Method
Remove top level private attributes only by default. When set to true, all private attributes within sequence and sub-sequences will be removed
Remove private attributes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub RemovePrivateAttributes( _
   Optional ByVal deep As Boolean _
)
'Usage

Dim instance As DicomDataSet
Dim deep As Boolean

instance.RemovePrivateAttributes(deep)
public void RemovePrivateAttributes(
   bool deep
)
public:
void RemovePrivateAttributes(
   bool deep
)

Parameters

deep
Remove top level private attributes only by default. When set to true, all private attributes within sequence and sub-sequences will be removed
Remarks
This method removes all attributes with an odd group number
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


Send Method (DicomDataSet)

Send Method (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : Send Method
Sends a DicomDataSet to a remote DICOM application
Overload List
Overload | Description
Send(String,Int32,String,String) | Sends a DicomDataSet to a remote DICOM application
Send(String,Int32,String,String,IEnumerable<String>) | Sends a DicomDataSet to a remote DICOM application, with control over the set of transfer synatxes offered.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


Send(String,Int32,String,String) Method

Send(String,Int32,String,String) Method

DicomObjects Namespace > DicomDataSet Class > Send Method : Send(String,Int32,String,String) Method

Network address (as dotted notation or resolvable name) to which the image is to be sent.

Port on which remote application is listening.

Name of remote Application Entity.

Name to quote for this Application Entity

Sends a DicomDataSet to a remote DICOM application
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Send( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAE As String, _
   ByVal CalledAE As String _
) As Integer
'Usage

Dim instance As DicomDataSet
Dim Node As String
Dim Port As Integer
Dim CallingAE As String
Dim CalledAE As String
Dim value As Integer

value = instance.Send(Node, Port, CallingAE, CalledAE)
public int Send(
   string Node,
   int Port,
   string CallingAE,
   string CalledAE
)
public:
int Send(
   String^ Node,
   int Port,
   String^ CallingAE,
   String^ CalledAE
)

Parameters

Node

Network address (as dotted notation or resolvable name) to which the image is to be sent.

Port

Port on which remote application is listening.

CallingAE

Name of remote Application Entity.

CalledAE

Name to quote for this Application Entity

Return Value

The status as returned by the remote application. Zero indicates success.

Remarks
This method negotiates an association, sends one dataset over it, and then closes it. DICOM does not allow SCPs to draw any conclusion about the relationships between images based on the opening and closing of associations, so this should never be a problem (apart from slight network inefficiency). However, there are several badly written applications in the world, which incorrectly assume that the end of an association indicates the end of a series or a study etc., and if interfacing to such a faulty implementation, it is possible to send multiple images on one association by using DicomAssociation object, and its SendInstances methods.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Send(String,Int32,String,String,IEnumerable<String>) Method

Send(String,Int32,String,String,IEnumerable<String>) Method

DicomObjects Namespace > DicomDataSet Class > Send Method : Send(String,Int32,String,String,IEnumerable<String>) Method

Network address (as dotted notation or resolvable name) to which the image is to be sent.

Port on which remote application is listening.

Name of remote Application Entity.

Name to quote for this Application Entity

A list of offered Transfer Syntaxes

Sends a DicomDataSet to a remote DICOM application, with control over the set of transfer synatxes offered.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Send( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAE As String, _
   ByVal CalledAE As String, _
   ByVal OfferedTS As IEnumerable(Of String) _
) As Integer
'Usage

Dim instance As DicomDataSet
Dim Node As String
Dim Port As Integer
Dim CallingAE As String
Dim CalledAE As String
Dim OfferedTS As IEnumerable(Of String)
Dim value As Integer

value = instance.Send(Node, Port, CallingAE, CalledAE, OfferedTS)
public int Send(
   string Node,
   int Port,
   string CallingAE,
   string CalledAE,
   IEnumerable<string> OfferedTS
)
public:
int Send(
   String^ Node,
   int Port,
   String^ CallingAE,
   String^ CalledAE,
   IEnumerable<String^>^ OfferedTS
)

Parameters

Node

Network address (as dotted notation or resolvable name) to which the image is to be sent.

Port

Port on which remote application is listening.

CallingAE

Name of remote Application Entity.

CalledAE

Name to quote for this Application Entity

OfferedTS

A list of offered Transfer Syntaxes

Return Value

The status as returned by the remote application. Zero indicates success.

Remarks
This method negotiates an association, sends one dataset over it, and then closes it. DICOM does not allow SCPs to draw any conclusion about the relationships between images based on the opening and closing of associations, so this should never be a problem (apart from slight network inefficiency). However, there are several badly written applications in the world, which incorrectly assume that the end of an association indicates the end of a series or a study etc., and if interfacing to such a faulty implementation, it is possible to send multiple images on one association by using DicomAssociation object, and its SendInstances methods.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


SetDicomCodec Method

SetDicomCodec Method

DicomObjects Namespace > DicomDataSet Class : SetDicomCodec Method
The transfer syntax of the data
The decompressor to use to access the frames etc.
The tream containing the data
Specify a "DICOM" codec
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetDicomCodec( _
   ByVal TS As UID, _
   ByVal dec As IDecompressor, _
   ByVal Stream As Stream _
)
'Usage

Dim instance As DicomDataSet
Dim TS As UID
Dim dec As IDecompressor
Dim Stream As Stream

instance.SetDicomCodec(TS, dec, Stream)
public void SetDicomCodec(
   UID TS,
   IDecompressor dec,
   Stream Stream
)
public:
void SetDicomCodec(
   UID^ TS,
   IDecompressor^ dec,
   Stream^ Stream
)

Parameters

TS
The transfer syntax of the data
dec
The decompressor to use to access the frames etc.
Stream
The tream containing the data
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


SetNonDicomCodec Method

SetNonDicomCodec Method

DicomObjects Namespace > DicomDataSet Class : SetNonDicomCodec Method
An objects to provide the frames
Specify a non-DICOM source (e.g. AVI) as a source of frame data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetNonDicomCodec( _
   ByVal source As IFrameSource _
)
'Usage

Dim instance As DicomDataSet
Dim source As IFrameSource

instance.SetNonDicomCodec(source)
public void SetNonDicomCodec(
   IFrameSource source
)
public:
void SetNonDicomCodec(
   IFrameSource^ source
)

Parameters

source
An objects to provide the frames
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


SetPlanarConfiguration Method

SetPlanarConfiguration Method

DicomObjects Namespace > DicomDataSet Class : SetPlanarConfiguration Method

The enumerated value to be set for planar configuration attribute (0028, 0006)

Sets the planar configuration in DicomDataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetPlanarConfiguration( _
   ByVal Value As Integer _
)
'Usage

Dim instance As DicomDataSet
Dim Value As Integer

instance.SetPlanarConfiguration(Value)
public void SetPlanarConfiguration(
   int Value
)
public:
void SetPlanarConfiguration(
   int Value
)

Parameters

Value

The enumerated value to be set for planar configuration attribute (0028, 0006)

Remarks

Planar Configuration indicates whether the color pixel data are sent color-by-color or color-by-pixel. This element shall be present if Samples per Pixel (0028, 0002) has a value greater than 1. It shall not be present otherwise.

This method removes Planar Configuration (0028, 0006) from dataset if it has only 1 plane, otherwise it sets Planar Configuration to the value provided.

Enumerated Values for Planar Configuration are:

  • 0 = The sample values for the first pixel are followed by the sample values for the second pixel, etc. For RGB images, this means the order of the pixel values sent shall be R1, G1, B1, R2, G2, B2, ..., etc.
  • 1 = Each color place shall be sent contiguously. For RGB images, this means the order of the pixel values sent is R1, R2, R3, ..., G1, G2, G3, ..., B1, B2, B3, etc.

Planar Configuration is not meaningful when a compression transfer syntax is used that involves reorganization of sample components in the compressed bit stream. In such cases, since the data element is required to be sent, then an appropriate value to use may be specified, though in all likelihood the value will be ignored by the receiving implementation.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


SimplifyOverlays Method

SimplifyOverlays Method

DicomObjects Namespace > DicomDataSet Class : SimplifyOverlays Method
Decompress the data, and move any overlays which are encoded with the pixel data (a method deprecated in DICOM many years ago) to stand-along overlay data in 60xx,3000.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SimplifyOverlays()
'Usage

Dim instance As DicomDataSet

instance.SimplifyOverlays()
public void SimplifyOverlays()
public:
void SimplifyOverlays();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


Validate Method

Validate Method

DicomObjects Namespace > DicomDataSet Class : Validate Method
Validate all DicomAttributes within the DicomDataset
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Validate()
'Usage

Dim instance As DicomDataSet

instance.Validate()
public void Validate()
public:
void Validate();
Remarks
Throws a DicomValidationException on the first invalid DicomAttribute
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


ValidateAll(ValidationOptions) Method

ValidateAll(ValidationOptions) Method

DicomObjects Namespace > DicomDataSet Class > ValidateAll Method : ValidateAll(ValidationOptions) Method
[NEW] Validate all DicomAttributes within the DicomDataset based on the specified ValidationOptions.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function ValidateAll( _
   ByVal validationOptions As ValidationOptions _
) As List(Of DicomValidationException)
'Usage

Dim instance As DicomDataSet
Dim validationOptions As ValidationOptions
Dim value As List(Of DicomValidationException)

value = instance.ValidateAll(validationOptions)
public List<DicomValidationException> ValidateAll(
   ValidationOptions validationOptions
)
public:
List<DicomValidationException^>^ ValidateAll(
   ValidationOptions^ validationOptions
)

Parameters

validationOptions

Return Value

A list of validation errors as DicomValidationException objects
Remarks
If there are no errors, then an Empty list is returned
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Value Method

Value Method

DicomObjects Namespace > DicomDataSet Class : Value Method
Returns the value of the specified Data Element
Overload List
Overload | Description
Value(Int32,Int32) | Returns the value of the specified Data Element
Value(Keyword) | Returns the value of the specified Data Element
Value(String) | Returns the value of the specified Data Element
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


Value(Int32,Int32) Method

Value(Int32,Int32) Method

DicomObjects Namespace > DicomDataSet Class > Value Method : Value(Int32,Int32) Method

The group index of the specified Data Element

The element index of the specified Data Element

Returns the value of the specified Data Element
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Value( _
   ByVal group As Integer, _
   ByVal element As Integer _
) As Object
'Usage

Dim instance As DicomDataSet
Dim group As Integer
Dim element As Integer
Dim value As Object

value = instance.Value(group, element)
public object Value(
   int group,
   int element
)
public:
Object^ Value(
   int group,
   int element
)

Parameters

group

The group index of the specified Data Element

element

The element index of the specified Data Element

Return Value

object
Remarks

The type of variant returned depends on the value representation of the data element, and may be a string, date (for time, date or date-time), or a numeric type, including floating point values where appropriate.

Data elements of types not known to the program, whether private elements, or attributes recently defined by DICOM return the string " Unknown Data Type".

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Value(Keyword) Method

Value(Keyword) Method

DicomObjects Namespace > DicomDataSet Class > Value Method : Value(Keyword) Method

The keyword of the DicomAttribute

Returns the value of the specified Data Element
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Value( _
   ByVal Keyword As Keyword _
) As Object
'Usage

Dim instance As DicomDataSet
Dim Keyword As Keyword
Dim value As Object

value = instance.Value(Keyword)
public object Value(
   Keyword Keyword
)
public:
Object^ Value(
   Keyword Keyword
)

Parameters

Keyword

The keyword of the DicomAttribute

Return Value

object
Remarks

The type of variant returned depends on the value representation of the data element, and may be a string, date (for time, date or date-time), or a numeric type, including floating point values where appropriate.

Data elements of types not known to the program, whether private elements, or attributes recently defined by DICOM return the string " Unknown Data Type".

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Value(String) Method

Value(String) Method

DicomObjects Namespace > DicomDataSet Class > Value Method : Value(String) Method

The String Keyword of the DicomAttribute

Returns the value of the specified Data Element
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Value( _
   ByVal Keyword As String _
) As Object
'Usage

Dim instance As DicomDataSet
Dim Keyword As String
Dim value As Object

value = instance.Value(Keyword)
public object Value(
   string Keyword
)
public:
Object^ Value(
   String^ Keyword
)

Parameters

Keyword

The String Keyword of the DicomAttribute

Return Value

object
Remarks

The type of variant returned depends on the value representation of the data element, and may be a string, date (for time, date or date-time), or a numeric type, including floating point values where appropriate.

Data elements of types not known to the program, whether private elements, or attributes recently defined by DICOM return the string " Unknown Data Type".

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Write Method (DicomDataSet)

Write Method (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : Write Method
Writes the dataset to an external DICOM file, a system IO stream or a byte array etc.
Overload List
Overload | Description
Write(String,String,Object) | Writes dataset to an external DICOM file with specified transfer syntax and quality factor
Write(String,String,Object,DicomDataSet) | Writes dataset to an external DICOM file with specified transfer syntax, quality factor and meta header
Write(String,String,Object,DicomDataSet,WriteBehaviours) | Writes dataset to an external DICOM file with specified transfer syntax, quality factor, meta header and behaviour overrides
Write(Stream,String,Object,DicomDataSet,WriteBehaviours) | Writes dataset to a stream with specified transfer syntax, quality factor, meta header and behaviour overrides
Write(String,Boolean) | Writes dataset to an external DICOM file
Write(String,String,DicomDataSet) | Writes dataset to an external DICOM file with specified transfer syntax and meta header
Write(String,String) | Writes dataset to an external DICOM file with specified transfer syntax
Write(String) | Writes dataset to an external DICOM file
Write(String,DicomDataSet) | Writes dataset to an external DICOM file with specified meta header
Write(Stream,String,Object) | Writes dataset to a system IO stream object with specified transfer syntax
Write(Stream,Boolean) | Writes dataset to a system IO stream object
Write(Stream,String) | Writes dataset to a system IO stream object with specified transfer syntax
Write(Stream,String,DicomDataSet) | Writes dataset to a system IO stream object with specified transfer syntax and meta header
Write(Stream) | Writes dataset to a system IO stream object
Write(Byte[],String,Object) | Writes dataset to a byte array with specified transfer syntax and quality factor
Write(Byte[],Boolean) | Writes dataset to a byte array
Write(Byte[],String) | Writes dataset to a byte array with specified transfer syntax
Write(Byte[]) | Writes the dataset to a byte array
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


Write(String,String,Object) Method

Write(String,String,Object) Method

DicomObjects Namespace > DicomDataSet Class > Write Method : Write(String,String,Object) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The quality factor to be used.

Writes dataset to an external DICOM file with specified transfer syntax and quality factor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object _
)
'Usage

Dim instance As DicomDataSet
Dim FileName As String
Dim TransferSyntax As String
Dim Quality As Object

instance.Write(FileName, TransferSyntax, Quality)
public void Write(
   string FileName,
   string TransferSyntax,
   object Quality
)
public:
void Write(
   String^ FileName,
   String^ TransferSyntax,
   Object^ Quality
)

Parameters

FileName

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

TransferSyntax

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

Quality

The quality factor to be used.

Remarks

The file may subsequently be read by the Read method or by other DICOM software.

Quality is specific to the compression method being used, and is ignored for non-compressed or lossless JPEG transfer syntaxes. For Lossy JPEG, it is an integer in the range 1-100, the higher the number, the better the quality (and the larger the file), and for JPEG 2000 lossy, it is a compression ratio. Other compression methods may use this for other purposes in the future.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Write(String,String,Object,DicomDataSet) Method

Write(String,String,Object,DicomDataSet) Method

DicomObjects Namespace > DicomDataSet Class > Write Method : Write(String,String,Object,DicomDataSet) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The quality factor to be used.

The customized MetaHeader (only Group 2 Elements)

Writes dataset to an external DICOM file with specified transfer syntax, quality factor and meta header
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object, _
   ByVal MetaHeader As DicomDataSet _
)
'Usage

Dim instance As DicomDataSet
Dim FileName As String
Dim TransferSyntax As String
Dim Quality As Object
Dim MetaHeader As DicomDataSet

instance.Write(FileName, TransferSyntax, Quality, MetaHeader)
public void Write(
   string FileName,
   string TransferSyntax,
   object Quality,
   DicomDataSet MetaHeader
)
public:
void Write(
   String^ FileName,
   String^ TransferSyntax,
   Object^ Quality,
   DicomDataSet^ MetaHeader
)

Parameters

FileName

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

TransferSyntax

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

Quality

The quality factor to be used.

MetaHeader

The customized MetaHeader (only Group 2 Elements)

Remarks

The file may subsequently be read by the Read method or by other DICOM software.

Quality is specific to the compression method being used, and is ignored for non-compressed or lossless JPEG transfer syntaxes. For Lossy JPEG, it is an integer in the range 1-100, the higher the number, the better the quality (and the larger the file), and for JPEG 2000 lossy, it is a compression ratio. Other compression methods may use this for other purposes in the future.

The provided MetaHeader should only contain group 2 elements.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Write(String,String,Object,DicomDataSet,WriteBehaviours) Method

Write(String,String,Object,DicomDataSet,WriteBehaviours) Method

DicomObjects Namespace > DicomDataSet Class > Write Method : Write(String,String,Object,DicomDataSet,WriteBehaviours) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The quality factor to be used.

The customized MetaHeader (only Group 2 Elements)

Specific options to use when writing the data

Writes dataset to an external DICOM file with specified transfer syntax, quality factor, meta header and behaviour overrides
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object, _
   ByVal MetaHeader As DicomDataSet, _
   ByVal Behaviour As WriteBehaviours _
)
'Usage

Dim instance As DicomDataSet
Dim FileName As String
Dim TransferSyntax As String
Dim Quality As Object
Dim MetaHeader As DicomDataSet
Dim Behaviour As WriteBehaviours

instance.Write(FileName, TransferSyntax, Quality, MetaHeader, Behaviour)
public void Write(
   string FileName,
   string TransferSyntax,
   object Quality,
   DicomDataSet MetaHeader,
   WriteBehaviours Behaviour
)
public:
void Write(
   String^ FileName,
   String^ TransferSyntax,
   Object^ Quality,
   DicomDataSet^ MetaHeader,
   WriteBehaviours^ Behaviour
)

Parameters

FileName

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

TransferSyntax

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

Quality

The quality factor to be used.

MetaHeader

The customized MetaHeader (only Group 2 Elements)

Behaviour

Specific options to use when writing the data

Remarks

The file may subsequently be read by the Read method or by other DICOM software.

Quality is specific to the compression method being used, and is ignored for non-compressed or lossless JPEG transfer syntaxes. For Lossy JPEG, it is an integer in the range 1-100, the higher the number, the better the quality (and the larger the file), and for JPEG 2000 lossy, it is a compression ratio. Other compression methods may use this for other purposes in the future.

The provided MetaHeader should only contain group 2 elements.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Write(Stream,String,Object,DicomDataSet,WriteBehaviours) Method

Write(Stream,String,Object,DicomDataSet,WriteBehaviours) Method

DicomObjects Namespace > DicomDataSet Class > Write Method : Write(Stream,String,Object,DicomDataSet,WriteBehaviours) Method

The Stream to which to write.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The quality factor to be used.

The customized MetaHeader (only Group 2 Elements)

Specific options to use when writing the data

Writes dataset to a stream with specified transfer syntax, quality factor, meta header and behaviour overrides
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal Stream As Stream, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object, _
   ByVal MetaHeader As DicomDataSet, _
   ByVal Behaviour As WriteBehaviours _
)
'Usage

Dim instance As DicomDataSet
Dim Stream As Stream
Dim TransferSyntax As String
Dim Quality As Object
Dim MetaHeader As DicomDataSet
Dim Behaviour As WriteBehaviours

instance.Write(Stream, TransferSyntax, Quality, MetaHeader, Behaviour)
public void Write(
   Stream Stream,
   string TransferSyntax,
   object Quality,
   DicomDataSet MetaHeader,
   WriteBehaviours Behaviour
)
public:
void Write(
   Stream^ Stream,
   String^ TransferSyntax,
   Object^ Quality,
   DicomDataSet^ MetaHeader,
   WriteBehaviours^ Behaviour
)

Parameters

Stream

The Stream to which to write.

TransferSyntax

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

Quality

The quality factor to be used.

MetaHeader

The customized MetaHeader (only Group 2 Elements)

Behaviour

Specific options to use when writing the data

Remarks

The file may subsequently be read by the Read method or by other DICOM software.

Quality is specific to the compression method being used, and is ignored for non-compressed or lossless JPEG transfer syntaxes. For Lossy JPEG, it is an integer in the range 1-100, the higher the number, the better the quality (and the larger the file), and for JPEG 2000 lossy, it is a compression ratio. Other compression methods may use this for other purposes in the future.

The provided MetaHeader should only contain group 2 elements.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Write(String,Boolean) Method

Write(String,Boolean) Method

DicomObjects Namespace > DicomDataSet Class > Write Method : Write(String,Boolean) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the file, and an appropriate transfer syntax is used, as below.

If FALSE, the file is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

Writes dataset to an external DICOM file
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal isPart10 As Boolean _
)
'Usage

Dim instance As DicomDataSet
Dim FileName As String
Dim isPart10 As Boolean

instance.Write(FileName, isPart10)
public void Write(
   string FileName,
   bool isPart10
)
public:
void Write(
   String^ FileName,
   bool isPart10
)

Parameters

FileName

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

isPart10

If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the file, and an appropriate transfer syntax is used, as below.

If FALSE, the file is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

Remarks

The file may subsequently be read by the Read method or by other DICOM software.

Quality is specific to the compression method being used, and is ignored for non-compressed or lossless JPEG transfer syntaxes. For Lossy JPEG, it is an integer in the range 1-100, the higher the number, the better the quality (and the larger the file), and for JPEG 2000 lossy, it is a compression ratio. Other compression methods may use this for other purposes in the future.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Write(String,String,DicomDataSet) Method

Write(String,String,DicomDataSet) Method

DicomObjects Namespace > DicomDataSet Class > Write Method : Write(String,String,DicomDataSet) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The customized MetaHeader (only Group 2 Elements)

Writes dataset to an external DICOM file with specified transfer syntax and meta header
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal TransferSyntax As String, _
   ByVal MetaHeader As DicomDataSet _
)
'Usage

Dim instance As DicomDataSet
Dim FileName As String
Dim TransferSyntax As String
Dim MetaHeader As DicomDataSet

instance.Write(FileName, TransferSyntax, MetaHeader)
public void Write(
   string FileName,
   string TransferSyntax,
   DicomDataSet MetaHeader
)
public:
void Write(
   String^ FileName,
   String^ TransferSyntax,
   DicomDataSet^ MetaHeader
)

Parameters

FileName

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

TransferSyntax

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

MetaHeader

The customized MetaHeader (only Group 2 Elements)

Remarks

The file may subsequently be read by the Read method or by other DICOM software.

The provided meta header should only contain group 2 elements.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Write(String,String) Method

Write(String,String) Method

DicomObjects Namespace > DicomDataSet Class > Write Method : Write(String,String) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

Writes dataset to an external DICOM file with specified transfer syntax
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal TransferSyntax As String _
)
'Usage

Dim instance As DicomDataSet
Dim FileName As String
Dim TransferSyntax As String

instance.Write(FileName, TransferSyntax)
public void Write(
   string FileName,
   string TransferSyntax
)
public:
void Write(
   String^ FileName,
   String^ TransferSyntax
)

Parameters

FileName

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

TransferSyntax

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

Remarks

The file may subsequently be read by the Read method or by other DICOM software.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Write(String) Method

Write(String) Method

DicomObjects Namespace > DicomDataSet Class > Write Method : Write(String) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Writes dataset to an external DICOM file
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal FileName As String _
)
'Usage

Dim instance As DicomDataSet
Dim FileName As String

instance.Write(FileName)
public void Write(
   string FileName
)
public:
void Write(
   String^ FileName
)

Parameters

FileName

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Remarks

The file may subsequently be read by the Read method or by other DICOM software.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Write(String,DicomDataSet) Method

Write(String,DicomDataSet) Method

DicomObjects Namespace > DicomDataSet Class > Write Method : Write(String,DicomDataSet) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

The customized MetaHeader (only Group 2 Elements)

Writes dataset to an external DICOM file with specified meta header
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal MetaHeader As DicomDataSet _
)
'Usage

Dim instance As DicomDataSet
Dim FileName As String
Dim MetaHeader As DicomDataSet

instance.Write(FileName, MetaHeader)
public void Write(
   string FileName,
   DicomDataSet MetaHeader
)
public:
void Write(
   String^ FileName,
   DicomDataSet^ MetaHeader
)

Parameters

FileName

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

MetaHeader

The customized MetaHeader (only Group 2 Elements)

Remarks

The file may subsequently be read by the Read method or by other DICOM software.

The provided meta header should only contain group 2 elements.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Write(Stream,String,Object) Method

Write(Stream,String,Object) Method

DicomObjects Namespace > DicomDataSet Class > Write Method : Write(Stream,String,Object) Method

The Stream from which to read.

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The quality factor to be used.

Writes dataset to a system IO stream object with specified transfer syntax
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal Stream As Stream, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object _
)
'Usage

Dim instance As DicomDataSet
Dim Stream As Stream
Dim TransferSyntax As String
Dim Quality As Object

instance.Write(Stream, TransferSyntax, Quality)
public void Write(
   Stream Stream,
   string TransferSyntax,
   object Quality
)
public:
void Write(
   Stream^ Stream,
   String^ TransferSyntax,
   Object^ Quality
)

Parameters

Stream

The Stream from which to read.

TransferSyntax

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

Quality

The quality factor to be used.

Remarks

The stream may subsequently be read by the Read method or by other DICOM software.

Quality is specific to the compression method being used, and is ignored for non-compressed or lossless JPEG transfer syntaxes. For Lossy JPEG, it is an integer in the range 1-100, the higher the number, the better the quality (and the larger the file) , and for JPEG 2000 lossy, it is a compression ratio. Other compression methods may use this for other purposes in the future.

This method is particularly suitable for use with Delphi, which provides access to streams via classes such as TStreamAdapter.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Write(Stream,Boolean) Method

Write(Stream,Boolean) Method

DicomObjects Namespace > DicomDataSet Class > Write Method : Write(Stream,Boolean) Method

The Stream from which to read.

If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the stream, and an appropriate transfer syntax is used, as below.

If FALSE, the stream is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

Writes dataset to a system IO stream object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal Stream As Stream, _
   ByVal isPart10 As Boolean _
)
'Usage

Dim instance As DicomDataSet
Dim Stream As Stream
Dim isPart10 As Boolean

instance.Write(Stream, isPart10)
public void Write(
   Stream Stream,
   bool isPart10
)
public:
void Write(
   Stream^ Stream,
   bool isPart10
)

Parameters

Stream

The Stream from which to read.

isPart10

If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the stream, and an appropriate transfer syntax is used, as below.

If FALSE, the stream is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

Remarks

The stream may subsequently be read by the Read method or by other DICOM software.

This method is particularly suitable for use with Delphi, which provides access to streams via classes such as TStreamAdapter.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Write(Stream,String) Method

Write(Stream,String) Method

DicomObjects Namespace > DicomDataSet Class > Write Method : Write(Stream,String) Method

The Stream to which to write.

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

Writes dataset to a system IO stream object with specified transfer syntax
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal Stream As Stream, _
   ByVal TransferSyntax As String _
)
'Usage

Dim instance As DicomDataSet
Dim Stream As Stream
Dim TransferSyntax As String

instance.Write(Stream, TransferSyntax)
public void Write(
   Stream Stream,
   string TransferSyntax
)
public:
void Write(
   Stream^ Stream,
   String^ TransferSyntax
)

Parameters

Stream

The Stream to which to write.

TransferSyntax

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

Remarks

The stream may subsequently be read by the Read method or by other DICOM software.

This method is particularly suitable for use with Delphi, which provides access to streams via classes such as TStreamAdapter.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Write(Stream,String,DicomDataSet) Method

Write(Stream,String,DicomDataSet) Method

DicomObjects Namespace > DicomDataSet Class > Write Method : Write(Stream,String,DicomDataSet) Method

The Stream to which to write.

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The customized MetaHeader (only Group 2 Elements)

Writes dataset to a system IO stream object with specified transfer syntax and meta header
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal Stream As Stream, _
   ByVal TransferSyntax As String, _
   ByVal MetaHeader As DicomDataSet _
)
'Usage

Dim instance As DicomDataSet
Dim Stream As Stream
Dim TransferSyntax As String
Dim MetaHeader As DicomDataSet

instance.Write(Stream, TransferSyntax, MetaHeader)
public void Write(
   Stream Stream,
   string TransferSyntax,
   DicomDataSet MetaHeader
)
public:
void Write(
   Stream^ Stream,
   String^ TransferSyntax,
   DicomDataSet^ MetaHeader
)

Parameters

Stream

The Stream to which to write.

TransferSyntax

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

MetaHeader

The customized MetaHeader (only Group 2 Elements)

Remarks

The file may subsequently be read by the Read method or by other DICOM software.

The provided meta header should only contain group 2 elements.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Write(Stream) Method

Write(Stream) Method

DicomObjects Namespace > DicomDataSet Class > Write Method : Write(Stream) Method

The Stream to which to write.

Writes dataset to a system IO stream object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal Stream As Stream _
)
'Usage

Dim instance As DicomDataSet
Dim Stream As Stream

instance.Write(Stream)
public void Write(
   Stream Stream
)
public:
void Write(
   Stream^ Stream
)

Parameters

Stream

The Stream to which to write.

Remarks

The stream may subsequently be read by the Read method or by other DICOM software.

This method is particularly suitable for use with Delphi, which provides access to streams via classes such as TStreamAdapter.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Write(Byte[],String,Object) Method

Write(Byte[],String,Object) Method

DicomObjects Namespace > DicomDataSet Class > Write Method : Write(Byte[],String,Object) Method

The byte array to write dataset to

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The quality factor to be used

Writes dataset to a byte array with specified transfer syntax and quality factor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByRef Array() As Byte, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object _
)
'Usage

Dim instance As DicomDataSet
Dim Array() As Byte
Dim TransferSyntax As String
Dim Quality As Object

instance.Write(Array, TransferSyntax, Quality)
public void Write(
   out byte[] Array,
   string TransferSyntax,
   object Quality
)
public:
void Write(
   [Out] array<byte>^ Array,
   String^ TransferSyntax,
   Object^ Quality
)

Parameters

Array

The byte array to write dataset to

TransferSyntax

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

Quality

The quality factor to be used

Remarks

Quality is specific to the compression method being used, and is ignored for non-compressed or lossless JPEG transfer syntaxes. For Lossy JPEG, it is an integer in the range 1-100, the higher the number, the better the quality (and the larger the file) , and for JPEG 2000 lossy, it is a compression ratio. Other compression methods may use this for other purposes in the future.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Write(Byte[],Boolean) Method

Write(Byte[],Boolean) Method

DicomObjects Namespace > DicomDataSet Class > Write Method : Write(Byte[],Boolean) Method

The byte array to write dataset to

If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the file, and an appropriate transfer syntax is used, as below.

If FALSE, the file is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

Writes dataset to a byte array
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByRef Array() As Byte, _
   ByVal isPart10 As Boolean _
)
'Usage

Dim instance As DicomDataSet
Dim Array() As Byte
Dim isPart10 As Boolean

instance.Write(Array, isPart10)
public void Write(
   out byte[] Array,
   bool isPart10
)
public:
void Write(
   [Out] array<byte>^ Array,
   bool isPart10
)

Parameters

Array

The byte array to write dataset to

isPart10

If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the file, and an appropriate transfer syntax is used, as below.

If FALSE, the file is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

Remarks

Data may subsequently be read by the Read methods or by other DICOM software.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Write(Byte[],String) Method

Write(Byte[],String) Method

DicomObjects Namespace > DicomDataSet Class > Write Method : Write(Byte[],String) Method

The byte array to write dataset to

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

Writes dataset to a byte array with specified transfer syntax
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByRef Array() As Byte, _
   ByVal TransferSyntax As String _
)
'Usage

Dim instance As DicomDataSet
Dim Array() As Byte
Dim TransferSyntax As String

instance.Write(Array, TransferSyntax)
public void Write(
   out byte[] Array,
   string TransferSyntax
)
public:
void Write(
   [Out] array<byte>^ Array,
   String^ TransferSyntax
)

Parameters

Array

The byte array to write dataset to

TransferSyntax

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

Remarks

Data may subsequently be read by the Read method or by other DICOM software.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Write(Byte[]) Method

Write(Byte[]) Method

DicomObjects Namespace > DicomDataSet Class > Write Method : Write(Byte[]) Method

The byte array to write dataset to

Writes the dataset to a byte array
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByRef Array() As Byte _
)
'Usage

Dim instance As DicomDataSet
Dim Array() As Byte

instance.Write(Array)
public void Write(
   out byte[] Array
)
public:
void Write(
   [Out] array<byte>^ Array
)

Parameters

Array

The byte array to write dataset to

Remarks

Data may subsequently be read by the Read method or by other DICOM software.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


WriteJson Method (DicomDataSet)

WriteJson Method (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : WriteJson Method
The Stream to write to
Write the DICOM data into an Json Stream
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub WriteJson( _
   ByVal Stream As Stream _
)
'Usage

Dim instance As DicomDataSet
Dim Stream As Stream

instance.WriteJson(Stream)
public void WriteJson(
   Stream Stream
)
public:
void WriteJson(
   Stream^ Stream
)

Parameters

Stream
The Stream to write to
Remarks
The result Json data is compliant with the Native DICOM Model outlined in the DICOM Part 19 (Application Hosting), with modifications as defined in supplement 163 to allow bulk data, which is used for attributes of appropriate types with more than 16 values
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


WriteXml Method

WriteXml Method

DicomObjects Namespace > DicomDataSet Class : WriteXml Method
The Stream to write to
Write the DICOM data into an XML Stream
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub WriteXml( _
   ByVal Stream As Stream _
)
'Usage

Dim instance As DicomDataSet
Dim Stream As Stream

instance.WriteXml(Stream)
public void WriteXml(
   Stream Stream
)
public:
void WriteXml(
   Stream^ Stream
)

Parameters

Stream
The Stream to write to
Remarks
The result XML data is compliant with the Native DICOM Model outlined in the DICOM Part 19 (Application Hosting), with modifications as defined in supplement 163 to allow bulk data, which is used for attributes of appropriate types with more than 16 values
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


DicomDataSet Class Properties

DicomDataSet Class Properties

DicomObjects Namespace : DicomDataSet Class

For a list of all members of this type, see DicomDataSet members.

Public Properties
 | Name | Description
Public Property | AccessionNumber | The Accession Number
Public Property | CacheMode | Controls how the pixel data is cached
Public Property | Children | Holds the hierarchical directory structure for DICOM directory files
Public Property | Command | The full command dataset received
Public Property | Count | Number of Attributes held in the DataSet
Public Property | DateOfBirth | Date of birth of the patient
static (Shared in Visual Basic) | DefaultValidationTypes | The default DicomObjects.Enums.ValidationTypes to apply to newly created DicomDataSet objects
Public Property | Identifer | Returns the underlying DataSet which contains the list of attributes to be matched, as specified in the DICOM standard.
Public Property | InstanceUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Item | Overloaded. Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Public Property | Name | The Name of the patient
Public Property | OriginalTS | Returns the Transfer syntax with which the object was originally received or read.
Public Property | Overrides | Image-specific list of unusual behaviours (e.g. to cope with faulty images)
Public Property | OverrideTS | A means to override an incorrect transfer syntax
Public Property | PatientID | The Patient ID
Public Property | PixelsPerFrame | The number of pixels per frame
Public Property | RawPixels | Accesses the raw pixel data as an array
Public Property | SamplesPerFrame | The number of samples per frame
Public Property | SeriesDescription | Descriptions for the series
Public Property | SeriesUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Sex | Sex of the patient
Public Property | SOPClass | SOP class of the DicomDataSet.
Public Property | StudyDescription | Description for the study
Public Property | StudyUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Tag | A general purpose Tag for developer use
Public Property | UncompressedPI | Gets the Photometric Interpretation of the uncompressed Image data.
Public Property | ValidationDataSet | Assign a Validation DataSet to this property would override the DataSet's Validation scheme. This is mainly used for validation of CharacterSet.
Public Property | ValidationTypes | Gets or sets the current validation type.
Top
See Also

Reference

DicomDataSet Class
DicomObjects Namespace


AccessionNumber Property (DicomDataSet)

AccessionNumber Property (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : AccessionNumber Property
The Accession Number
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AccessionNumber As String
'Usage

Dim instance As DicomDataSet
Dim value As String

instance.AccessionNumber = value

value = instance.AccessionNumber
public string AccessionNumber {get; set;}
public:
property String^ AccessionNumber {
   String^ get();
   void set (    String^ value);
}

Property Value

The Accession Number
Remarks
Shortcut for Attribute 0008,0050
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


CacheMode Property (DicomDataSet)

CacheMode Property (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : CacheMode Property
Controls how the pixel data is cached
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CacheMode As CacheTypes
'Usage

Dim instance As DicomDataSet
Dim value As CacheTypes

instance.CacheMode = value

value = instance.CacheMode
public CacheTypes CacheMode {get; set;}
public:
property CacheTypes CacheMode {
   CacheTypes get();
   void set (    CacheTypes value);
}
Remarks
See DicomObjects.Enums.CacheTypes for details of the values
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


Children Property

Children Property

DicomObjects Namespace > DicomDataSet Class : Children Property
Holds the hierarchical directory structure for DICOM directory files
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Children As DicomDataSetCollection
'Usage

Dim instance As DicomDataSet
Dim value As DicomDataSetCollection

value = instance.Children
public DicomDataSetCollection Children {get;}
public:
property DicomDataSetCollection^ Children {
   DicomDataSetCollection^ get();
}
Remarks
Recursive use of this property and the datasets contained within it allows representation and manipulation of the hierarchical structure of a DICOMDIR file. The Children property exists for all DicomDataSet objects, but is only created by AddToDirectory and is used by Write method. There are normally five levels, the objects representing the DICOMDIR file itself, and the four hierarchical levels PATIENT, STUDY, SERIES and IMAGE.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


Command Property (DicomDataSet)

Command Property (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : Command Property
The full command dataset received
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Command As DicomDataSet
'Usage

Dim instance As DicomDataSet
Dim value As DicomDataSet

value = instance.Command
public DicomDataSet Command {get;}
public:
property DicomDataSet^ Command {
   DicomDataSet^ get();
}
Remarks
Returns the DataSet which contains elements in the 0000 and 0002 Group.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


Count Property (DicomDataSet)

Count Property (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : Count Property
Number of Attributes held in the DataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As DicomDataSet
Dim value As Integer

value = instance.Count
public int Count {get;}
public:
property int Count {
   int get();
}
Remarks
Returns the number of attributes in the dataset, irrespective of their values being null or none-null.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


DateOfBirth Property (DicomDataSet)

DateOfBirth Property (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : DateOfBirth Property
Date of birth of the patient
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DateOfBirth As Date
'Usage

Dim instance As DicomDataSet
Dim value As Date

instance.DateOfBirth = value

value = instance.DateOfBirth
public DateTime DateOfBirth {get; set;}
public:
property DateTime DateOfBirth {
   DateTime get();
   void set (    DateTime value);
}

Property Value

Date of birth of the patient
Remarks
A shortcut for attribute (0010, 0030)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


DefaultValidationTypes Property

DefaultValidationTypes Property

DicomObjects Namespace > DicomDataSet Class : DefaultValidationTypes Property
The default DicomObjects.Enums.ValidationTypes to apply to newly created DicomDataSet objects
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property DefaultValidationTypes As ValidationTypes
'Usage

Dim value As ValidationTypes

DicomDataSet.DefaultValidationTypes = value

value = DicomDataSet.DefaultValidationTypes
public static ValidationTypes DefaultValidationTypes {get; set;}
public:
static property ValidationTypes DefaultValidationTypes {
   ValidationTypes get();
   void set (    ValidationTypes value);
}
Remarks
The default value for this default is DicomObjects.Enums.ValidationTypes.Basic combined with DicomObjects.Enums.ValidationTypes.CharacterSet
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


Identifer Property

Identifer Property

DicomObjects Namespace > DicomDataSet Class : Identifer Property
Returns the underlying DataSet which contains the list of attributes to be matched, as specified in the DICOM standard.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Identifer As DicomDataSet
'Usage

Dim instance As DicomDataSet
Dim value As DicomDataSet

value = instance.Identifer
public DicomDataSet Identifer {get;}
public:
property DicomDataSet^ Identifer {
   DicomDataSet^ get();
}

Property Value

DicomDataSet
Remarks

It is the client's responsibility to interpret the contents of this identifier and ensure that the data or images returned match the data sent, and in the case of C-FIND operations, to ensure that all data elements requested are included in the response.

The "level" of the query may be found in Attribute (Keyword.QueryRetrieveLevel) of this property.

The handling of Query/Retrieve requests as an SCP is an advanced technique, and the rules to be obeyed are beyond the scope of this help file. See the Access SCP example for a demonstration of a possible implementation.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


InstanceUID Property (DicomDataSet)

InstanceUID Property (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : InstanceUID Property
Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property InstanceUID As String
'Usage

Dim instance As DicomDataSet
Dim value As String

instance.InstanceUID = value

value = instance.InstanceUID
public string InstanceUID {get; set;}
public:
property String^ InstanceUID {
   String^ get();
   void set (    String^ value);
}

Property Value

The Instance UID
Remarks
A shortcut for attribute (0008, 0018)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


Item Property (DicomDataSet)

Item Property (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : Item Property
Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Overload List
Overload | Description
Item(Int32,Int32) | Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Item(Int32) | Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Item(Keyword) | Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Item(String) | Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Remarks
There are several possible indexers for a dataset, allowing both specific and sequential access.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


Item(Int32,Int32) Property

Item(Int32,Int32) Property

DicomObjects Namespace > DicomDataSet Class > Item Property : Item(Int32,Int32) Property

The group index of a data element.

The element index of a data element.

Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Overridable ReadOnly Property Item( _
   ByVal group As Integer, _
   ByVal element As Integer _
) As DicomAttribute
'Usage

Dim instance As DicomDataSet
Dim group As Integer
Dim element As Integer
Dim value As DicomAttribute

value = instance.Item(group, element)
public virtual DicomAttribute Item(
   int group,
   int element
) {get;}
public:
virtual property DicomAttribute^ Item {
   DicomAttribute^ get(int group, int element);
}

Parameters

group

The group index of a data element.

element

The element index of a data element.

Remarks
There are several possible indexers for a dataset, allowing both specific and sequential access.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Item(Int32) Property

Item(Int32) Property

DicomObjects Namespace > DicomDataSet Class > Item Property : Item(Int32) Property
The Index of the DicomAttribute
Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As DicomAttribute
'Usage

Dim instance As DicomDataSet
Dim index As Integer
Dim value As DicomAttribute

value = instance.Item(index)
public DicomAttribute Item(
   int index
) {get;}
public:
property DicomAttribute^ Item {
   DicomAttribute^ get(int index);
}

Parameters

index
The Index of the DicomAttribute
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Item(Keyword) Property

Item(Keyword) Property

DicomObjects Namespace > DicomDataSet Class > Item Property : Item(Keyword) Property
The Keyword of the DicomAttribute
Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal Keyword As Keyword _
) As DicomAttribute
'Usage

Dim instance As DicomDataSet
Dim Keyword As Keyword
Dim value As DicomAttribute

value = instance.Item(Keyword)
public DicomAttribute Item(
   Keyword Keyword
) {get;}
public:
property DicomAttribute^ Item {
   DicomAttribute^ get(Keyword Keyword);
}

Parameters

Keyword
The Keyword of the DicomAttribute
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Item(String) Property

Item(String) Property

DicomObjects Namespace > DicomDataSet Class > Item Property : Item(String) Property
A String containing the DicomObjects.Enums.Keyword of the DicomAttribute
Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal Keyword As String _
) As DicomAttribute
'Usage

Dim instance As DicomDataSet
Dim Keyword As String
Dim value As DicomAttribute

value = instance.Item(Keyword)
public DicomAttribute Item(
   string Keyword
) {get;}
public:
property DicomAttribute^ Item {
   DicomAttribute^ get(String^ Keyword);
}

Parameters

Keyword
A String containing the DicomObjects.Enums.Keyword of the DicomAttribute
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members
Overload List


Name Property (DicomDataSet)

Name Property (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : Name Property
The Name of the patient
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As DicomDataSet
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

The Name of the patient
Remarks

A shortcut for attribute (0010,0010).

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


OriginalTS Property (DicomDataSet)

OriginalTS Property (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : OriginalTS Property
Returns the Transfer syntax with which the object was originally received or read.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property OriginalTS As String
'Usage

Dim instance As DicomDataSet
Dim value As String

value = instance.OriginalTS
public string OriginalTS {get;}
public:
property String^ OriginalTS {
   String^ get();
}
Remarks

The value returned is the UID, in dotted numerical form, or the transfer syntax used.

This property may be useful to programs to handle compressed images, that wish to avoid re-compression of images, e.g. when using the Write method.

If an image/dataset has been created locally, then then explicit VT little endian (1.2.840.10008.1.2.1") is returned.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


Overrides Property

Overrides Property

DicomObjects Namespace > DicomDataSet Class : Overrides Property
Image-specific list of unusual behaviours (e.g. to cope with faulty images)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Overrides As Dictionary(Of String,Object)
'Usage

Dim instance As DicomDataSet
Dim value As Dictionary(Of String,Object)

instance.Overrides = value

value = instance.Overrides
public Dictionary<string,object> Overrides {get; set;}
public:
property Dictionary<String^,Object^>^ Overrides {
   Dictionary<String^,Object^>^ get();
   void set (    Dictionary<String^,Object^>^ value);
}
Remarks
Use only if requested by Medical Connections.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


OverrideTS Property

OverrideTS Property

DicomObjects Namespace > DicomDataSet Class : OverrideTS Property
A means to override an incorrect transfer syntax
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OverrideTS As String
'Usage

Dim instance As DicomDataSet
Dim value As String

instance.OverrideTS = value

value = instance.OverrideTS
public string OverrideTS {get; set;}
public:
property String^ OverrideTS {
   String^ get();
   void set (    String^ value);
}
Remarks
If set to a non-empty value, then this is used in place of the value in 0002,0010 in the meta-header of any dataset read into this object (e.g. using one of the Read methods.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


PatientID Property (DicomDataSet)

PatientID Property (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : PatientID Property
The Patient ID
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PatientID As String
'Usage

Dim instance As DicomDataSet
Dim value As String

instance.PatientID = value

value = instance.PatientID
public string PatientID {get; set;}
public:
property String^ PatientID {
   String^ get();
   void set (    String^ value);
}

Property Value

The Patient ID
Remarks
A shortcut for attribute (0010, 0020)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


PixelsPerFrame Property

PixelsPerFrame Property

DicomObjects Namespace > DicomDataSet Class : PixelsPerFrame Property
The number of pixels per frame
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property PixelsPerFrame As Integer
'Usage

Dim instance As DicomDataSet
Dim value As Integer

value = instance.PixelsPerFrame
public int PixelsPerFrame {get;}
public:
property int PixelsPerFrame {
   int get();
}
Remarks
This returns Size.Height * Size.Width
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


RawPixels Property (DicomDataSet)

RawPixels Property (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : RawPixels Property
Accesses the raw pixel data as an array
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RawPixels As Array
'Usage

Dim instance As DicomDataSet
Dim value As Array

instance.RawPixels = value

value = instance.RawPixels
public Array RawPixels {get; set;}
public:
property Array^ RawPixels {
   Array^ get();
   void set (    Array^ value);
}
Remarks

This returns an array containing one element per frame. The data returned is unaffected by the display parameters.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


SamplesPerFrame Property

SamplesPerFrame Property

DicomObjects Namespace > DicomDataSet Class : SamplesPerFrame Property
The number of samples per frame
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property SamplesPerFrame As Integer
'Usage

Dim instance As DicomDataSet
Dim value As Integer

value = instance.SamplesPerFrame
public int SamplesPerFrame {get;}
public:
property int SamplesPerFrame {
   int get();
}
Remarks
For monochrome images, this is the same as PixelsPerFrame but for multi-component images such as RGB it will be PixelsPerFrame * Samples per Pixel.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


SeriesDescription Property (DicomDataSet)

SeriesDescription Property (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : SeriesDescription Property
Descriptions for the series
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SeriesDescription As String
'Usage

Dim instance As DicomDataSet
Dim value As String

instance.SeriesDescription = value

value = instance.SeriesDescription
public string SeriesDescription {get; set;}
public:
property String^ SeriesDescription {
   String^ get();
   void set (    String^ value);
}

Property Value

The Series Description
Remarks

Provides human readable descriptions of the Study returned by a query, or relating to an image. They correspond to attribute (0008, 103E).

The usefulness is limited by the fact that not all equipment provides descriptions in its SOP instances, and even if it does, they may not be available through Query/Retrieve. For instance the RSNA CTN (up to and including version 2.8) supports the study description, but fails to index and provide the series description.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


SeriesUID Property (DicomDataSet)

SeriesUID Property (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : SeriesUID Property
Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SeriesUID As String
'Usage

Dim instance As DicomDataSet
Dim value As String

instance.SeriesUID = value

value = instance.SeriesUID
public string SeriesUID {get; set;}
public:
property String^ SeriesUID {
   String^ get();
   void set (    String^ value);
}

Property Value

The Series UID
Remarks
A shortcut for the attribute (0020, 000E).
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


Sex Property (DicomDataSet)

Sex Property (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : Sex Property
Sex of the patient
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Sex As String
'Usage

Dim instance As DicomDataSet
Dim value As String

instance.Sex = value

value = instance.Sex
public string Sex {get; set;}
public:
property String^ Sex {
   String^ get();
   void set (    String^ value);
}

Property Value

Sex of the patient
Remarks
A shortcut for attribute (0010, 0040)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


SOPClass Property (DicomDataSet)

SOPClass Property (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : SOPClass Property
SOP class of the DicomDataSet.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SOPClass As String
'Usage

Dim instance As DicomDataSet
Dim value As String

instance.SOPClass = value

value = instance.SOPClass
public string SOPClass {get; set;}
public:
property String^ SOPClass {
   String^ get();
   void set (    String^ value);
}

Property Value

The SOP class UID
Remarks
Shortcut for attribute (0008, 0016).
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


StudyDescription Property (DicomDataSet)

StudyDescription Property (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : StudyDescription Property
Description for the study
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property StudyDescription As String
'Usage

Dim instance As DicomDataSet
Dim value As String

instance.StudyDescription = value

value = instance.StudyDescription
public string StudyDescription {get; set;}
public:
property String^ StudyDescription {
   String^ get();
   void set (    String^ value);
}

Property Value

Study Description
Remarks

This property provides human readable descriptions of the Study returned by a query, or relating to an image. It corresponds to attribute (0008, 1030).

The usefulness is limited by the fact that not all equipment provides these descriptions in its SOP instances, and even if it does, they may not be available through Query/Retrieve. For instance the RSNA CTN (up to and including version 2.8) supports the study description, but fails to index and provide the series description.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


StudyUID Property (DicomDataSet)

StudyUID Property (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : StudyUID Property
Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property StudyUID As String
'Usage

Dim instance As DicomDataSet
Dim value As String

instance.StudyUID = value

value = instance.StudyUID
public string StudyUID {get; set;}
public:
property String^ StudyUID {
   String^ get();
   void set (    String^ value);
}

Property Value

The Study UID
Remarks
A shortcut for attribute (0020, 000D).
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


Tag Property (DicomDataSet)

Tag Property (DicomDataSet)

DicomObjects Namespace > DicomDataSet Class : Tag Property
A general purpose Tag for developer use
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Tag As Object
'Usage

Dim instance As DicomDataSet
Dim value As Object

instance.Tag = value

value = instance.Tag
public object Tag {get; set;}
public:
property Object^ Tag {
   Object^ get();
   void set (    Object^ value);
}
Remarks
This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


UncompressedPI Property

UncompressedPI Property

DicomObjects Namespace > DicomDataSet Class : UncompressedPI Property
Gets the Photometric Interpretation of the uncompressed Image data.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property UncompressedPI As String
'Usage

Dim instance As DicomDataSet
Dim value As String

value = instance.UncompressedPI
public string UncompressedPI {get;}
public:
property String^ UncompressedPI {
   String^ get();
}

Property Value

The Photometric Interpretation
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


ValidationDataSet Property

ValidationDataSet Property

DicomObjects Namespace > DicomDataSet Class : ValidationDataSet Property
Assign a Validation DataSet to this property would override the DataSet's Validation scheme. This is mainly used for validation of CharacterSet.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ValidationDataSet As DicomDataSet
'Usage

Dim instance As DicomDataSet
Dim value As DicomDataSet

instance.ValidationDataSet = value

value = instance.ValidationDataSet
public DicomDataSet ValidationDataSet {get; set;}
public:
property DicomDataSet^ ValidationDataSet {
   DicomDataSet^ get();
   void set (    DicomDataSet^ value);
}
Remarks

This property provides a means to override the CharacterSet validation of the DataSet within a sequence, which is added onto another DataSet, value of which should be passed to this property.

Example

Dim sequence As New DicomObjects.DicomDataSetCollection

Dim sequenceItem As New DicomObjects.DicomDataSet

Dim d As New DicomObjects.DicomDataSet

d.ValidationTypes = ValidationTypes.CharacterSet

d.Add(&H8, &H5, "ISO_IR 100")

sequenceItem.ValidationTypes = ValidationTypes.CharacterSet

sequenceItem.ValidationDataSet = d

sequenceItem.Name = "C�nan"

d.Add(&H88, &H200, sequence)

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


ValidationTypes Property

ValidationTypes Property

DicomObjects Namespace > DicomDataSet Class : ValidationTypes Property
Gets or sets the current validation type.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ValidationTypes As ValidationTypes
'Usage

Dim instance As DicomDataSet
Dim value As ValidationTypes

instance.ValidationTypes = value

value = instance.ValidationTypes
public ValidationTypes ValidationTypes {get; set;}
public:
property ValidationTypes ValidationTypes {
   ValidationTypes get();
   void set (    ValidationTypes value);
}
Remarks

Enumerated values for valid Enums.ValidationTypes are:

None=0,

Basic=1,

ForQuery=2,

CharacterSet=4

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


DicomDataSet Class Fields

DicomDataSet Class Fields

DicomObjects Namespace : DicomDataSet Class

For a list of all members of this type, see DicomDataSet members.

Public Fields
 | Name | Description
Public Field | CompressedFrameStream | User-defined function to set output stream for compressed frame. This is suitable for writing out large compressed frames with Basic Offset Table.
Top
See Also

Reference

DicomDataSet Class
DicomObjects Namespace


CompressedFrameStream Field

CompressedFrameStream Field

DicomObjects Namespace > DicomDataSet Class : CompressedFrameStream Field
User-defined function to set output stream for compressed frame. This is suitable for writing out large compressed frames with Basic Offset Table.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public CompressedFrameStream As Func(Of Integer,Stream)
'Usage

Dim instance As DicomDataSet
Dim value As Func(Of Integer,Stream)

value = instance.CompressedFrameStream

instance.CompressedFrameStream = value
public Func<int,Stream> CompressedFrameStream
public:
Func<int,Stream^>^ CompressedFrameStream
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


DicomDataSetCollection Class

DicomDataSetCollection Class
Members

DicomObjects Namespace : DicomDataSetCollection Class
A collection of DicomDataSet objects
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomDataSetCollection
   Inherits System.Collections.ObjectModel.Collection(Of DicomDataSet)
'Usage

Dim instance As DicomDataSetCollection
public class DicomDataSetCollection : System.Collections.ObjectModel.Collection<DicomDataSet>
public ref class DicomDataSetCollection : public System.Collections.ObjectModel.Collection<DicomDataSet>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
DicomObjects.DicomDataSetCollection

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Members
DicomObjects Namespace


DicomDataSetCollection Class Members

DicomDataSetCollection Class Members
Properties Methods

DicomObjects Namespace : DicomDataSetCollection Class

The following tables list the members exposed by DicomDataSetCollection.

Public Constructors
 | Name | Description
Public Constructor | DicomDataSetCollection Constructor | Overloaded. Creates a DicomDataSetCollection object
Top
Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Property | Item | Overloaded. Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Public Property | SopUIDList | Contains a list of SOP Class UIDs for all DataSet items contained in this Collection
Public Property | Tag | A general purpose Tag for developer use
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a DicomDataSet to a DicomDataSetCollection
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Clone | Overloaded. Returns a copy of the DicomDataSetCollection
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Dispose | Release all resources used by DicomDataSetCollection
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | MakeKOS | Make DICOM Key Object Note object from a collection of DicomDataSets. The first DicomDataSet object in the collection will be used as the primary data for KOS content. If multiple Studies are present in the collection, each Study will be added as a new Current Requested Procedure Evidence Sequence item. All Referenced Instance(s) will be added to the Content Sequence.
Public Method | Read | Overloaded. Creates and adds a DicomDataSet from an external DICOM File, a byte array, or a file stream. Or Creates and adds a collection of DicomDataSet objects from an array of external DICOM files
Public Method | ReadJson | Read DICOM data from a JSON Stream
Public Method | ReadMint | Overloaded. Read MINT Stream to reconstruct DICOM data from MINT data
Public Method | Remove | Overloaded. Removes DicomDataSet from a DicomDataSetCollectionby matching its InstanceUID
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Send | Sends all DataSets within the collection in one association
Public Method | WriteJson | Write DICOM data to a JSON Stream
Public Method | WriteMint | Write DICOM data to a MINT Stream and returns the list of bid's
Top
See Also

Reference

DicomDataSetCollection Class
DicomObjects Namespace


DicomDataSetCollection Constructor

DicomDataSetCollection Constructor

DicomObjects Namespace > DicomDataSetCollection Class : DicomDataSetCollection Constructor
Creates a DicomDataSetCollection object
Overload List
Overload | Description
DicomDataSetCollection Constructor() | Creates a DicomDataSetCollection object
DicomDataSetCollection Constructor(IEnumerable<DicomImage>) | Creates a DicomDataSetCollection from a DicomImageCollection
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members


DicomDataSetCollection Constructor()

DicomDataSetCollection Constructor()

DicomObjects Namespace > DicomDataSetCollection Class > DicomDataSetCollection Constructor : DicomDataSetCollection Constructor()
Creates a DicomDataSetCollection object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DicomDataSetCollection()
public DicomDataSetCollection()
public:
DicomDataSetCollection();

Return Value

DicomDataSetCollection
Remarks
This is the constructor method.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members
Overload List


DicomDataSetCollection Constructor(IEnumerable<DicomImage>)

DicomDataSetCollection Constructor(IEnumerable<DicomImage>)

DicomObjects Namespace > DicomDataSetCollection Class > DicomDataSetCollection Constructor : DicomDataSetCollection Constructor(IEnumerable<DicomImage>)
images as DicomImageCollection, the DicomImageCollection from which the new DicomDataSetCollection is created.
Creates a DicomDataSetCollection from a DicomImageCollection
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal images As IEnumerable(Of DicomImage) _
)
'Usage

Dim images As IEnumerable(Of DicomImage)

Dim instance As New DicomDataSetCollection(images)
public DicomDataSetCollection(
   IEnumerable<DicomImage> images
)
public:
DicomDataSetCollection(
   IEnumerable<DicomImage^>^ images
)

Parameters

images
images as DicomImageCollection, the DicomImageCollection from which the new DicomDataSetCollection is created.

Return Value

DicomDataSetCollection
Remarks
This is a "down-grading" approach to extract a DicomDataSetCollection from a DicomImageCollection.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members
Overload List


DicomDataSetCollection Class Methods

DicomDataSetCollection Class Methods

DicomObjects Namespace : DicomDataSetCollection Class

For a list of all members of this type, see DicomDataSetCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a DicomDataSet to a DicomDataSetCollection
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Clone | Overloaded. Returns a copy of the DicomDataSetCollection
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Dispose | Release all resources used by DicomDataSetCollection
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | MakeKOS | Make DICOM Key Object Note object from a collection of DicomDataSets. The first DicomDataSet object in the collection will be used as the primary data for KOS content. If multiple Studies are present in the collection, each Study will be added as a new Current Requested Procedure Evidence Sequence item. All Referenced Instance(s) will be added to the Content Sequence.
Public Method | Read | Overloaded. Creates and adds a DicomDataSet from an external DICOM File, a byte array, or a file stream. Or Creates and adds a collection of DicomDataSet objects from an array of external DICOM files
Public Method | ReadJson | Read DICOM data from a JSON Stream
Public Method | ReadMint | Overloaded. Read MINT Stream to reconstruct DICOM data from MINT data
Public Method | Remove | Overloaded. Removes DicomDataSet from a DicomDataSetCollectionby matching its InstanceUID
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Send | Sends all DataSets within the collection in one association
Public Method | WriteJson | Write DICOM data to a JSON Stream
Public Method | WriteMint | Write DICOM data to a MINT Stream and returns the list of bid's
Top
See Also

Reference

DicomDataSetCollection Class
DicomObjects Namespace


Add Method (DicomDataSetCollection)

Add Method (DicomDataSetCollection)

DicomObjects Namespace > DicomDataSetCollection Class : Add Method
Adds a DicomDataSet to a DicomDataSetCollection
Overload List
Overload | Description
Add(IEnumerable<DicomDataSet>) | Adds a DicomDataSetCollection to a DicomDataSetCollection
Add(DicomDataSet) | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members


Add(IEnumerable<DicomDataSet>) Method

Add(IEnumerable<DicomDataSet>) Method

DicomObjects Namespace > DicomDataSetCollection Class > Add Method : Add(IEnumerable<DicomDataSet>) Method

Collection of DicomDataSets to be added

Adds a DicomDataSetCollection to a DicomDataSetCollection
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal value As IEnumerable(Of DicomDataSet) _
)
'Usage

Dim instance As DicomDataSetCollection
Dim value As IEnumerable(Of DicomDataSet)

instance.Add(value)
public void Add(
   IEnumerable<DicomDataSet> value
)
public:
void Add(
   IEnumerable<DicomDataSet^>^ value
)

Parameters

value

Collection of DicomDataSets to be added

Remarks
Adds a Collection of DicomDataSets to the end of a DicomDataSetCollection.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members
Overload List


Clone Method (DicomDataSetCollection)

Clone Method (DicomDataSetCollection)

DicomObjects Namespace > DicomDataSetCollection Class : Clone Method
Returns a copy of the DicomDataSetCollection
Overload List
Overload | Description
Clone(Boolean) | Returns a copy of the DicomDataSetCollection
Clone() | Returns a copy of the DicomDataSetCollection
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members


Clone(Boolean) Method

Clone(Boolean) Method

DicomObjects Namespace > DicomDataSetCollection Class > Clone Method : Clone(Boolean) Method

Boolean value, if true then returns a Deep copy of the DicomDataSetCollection.

If false, returns a Shallow copy.

Returns a copy of the DicomDataSetCollection
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Overridable Function Clone( _
   ByVal Deep As Boolean _
) As Object
'Usage

Dim instance As DicomDataSetCollection
Dim Deep As Boolean
Dim value As Object

value = instance.Clone(Deep)
public virtual object Clone(
   bool Deep
)
public:
virtual Object^ Clone(
   bool Deep
)

Parameters

Deep

Boolean value, if true then returns a Deep copy of the DicomDataSetCollection.

If false, returns a Shallow copy.

Return Value

DicomDataSetCollection
Remarks

This method makes either a Shallow Copy or a Deep Copy of the DicomDataSetCollection, dependants on the Deep parameter.

A shallow copy will only have the top level objects replicated, any referenced objects under the top level will be shared by the original DicomDataSetCollection and the cloned copy.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members
Overload List


Clone() Method

Clone() Method

DicomObjects Namespace > DicomDataSetCollection Class > Clone Method : Clone() Method
Returns a copy of the DicomDataSetCollection
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Overridable Function Clone() As Object
'Usage

Dim instance As DicomDataSetCollection
Dim value As Object

value = instance.Clone()
public virtual object Clone()
public:
virtual Object^ Clone();

Return Value

DicomDataSetCollection
Remarks
This method makes a Shallow Copy of the DicomDataSetCollection. A shallow copy will only have the top level objects replicated, any referenced objects under the top level will be shared by the original DicomDataSetCollection and the cloned copy.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members
Overload List


Dispose Method (DicomDataSetCollection)

Dispose Method (DicomDataSetCollection)

DicomObjects Namespace > DicomDataSetCollection Class : Dispose Method
Release all resources used by DicomDataSetCollection
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As DicomDataSetCollection

instance.Dispose()
public void Dispose()
public:
void Dispose();
Remarks
Standard Dispose method.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members


MakeKOS Method

MakeKOS Method

DicomObjects Namespace > DicomDataSetCollection Class : MakeKOS Method
The location UID of each referenced Series where Instances can be retreived
Name of the Application Entity Title of where the referenced Instances can be retrieved
Make DICOM Key Object Note object from a collection of DicomDataSets. The first DicomDataSet object in the collection will be used as the primary data for KOS content. If multiple Studies are present in the collection, each Study will be added as a new Current Requested Procedure Evidence Sequence item. All Referenced Instance(s) will be added to the Content Sequence.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function MakeKOS( _
   ByVal RetrieveLocationUID As String, _
   ByVal RetrieveAET As String _
) As DicomDataSet
'Usage

Dim instance As DicomDataSetCollection
Dim RetrieveLocationUID As String
Dim RetrieveAET As String
Dim value As DicomDataSet

value = instance.MakeKOS(RetrieveLocationUID, RetrieveAET)
public DicomDataSet MakeKOS(
   string RetrieveLocationUID,
   string RetrieveAET
)
public:
DicomDataSet^ MakeKOS(
   String^ RetrieveLocationUID,
   String^ RetrieveAET
)

Parameters

RetrieveLocationUID
The location UID of each referenced Series where Instances can be retreived
RetrieveAET
Name of the Application Entity Title of where the referenced Instances can be retrieved
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members


Read Method (DicomDataSetCollection)

Read Method (DicomDataSetCollection)

DicomObjects Namespace > DicomDataSetCollection Class : Read Method
Creates and adds a DicomDataSet from an external DICOM File, a byte array, or a file stream. Or Creates and adds a collection of DicomDataSet objects from an array of external DICOM files
Overload List
Overload | Description
Read(String,ReadBehaviours) | Creates and adds a DicomDataSet from an external DICOM file
Read(Byte[]) | Creates and adds a DicomDataSet from a byte array
Read(IEnumerable<String>,ReadBehaviours) | Creates and adds a collection of DicomDataSet objects from a collection of external DICOM files
Read(Stream,ReadBehaviours) | Reads a DICOM file from a Stream
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members


Read(String,ReadBehaviours) Method

Read(String,ReadBehaviours) Method

DicomObjects Namespace > DicomDataSetCollection Class > Read Method : Read(String,ReadBehaviours) Method

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container’s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

The behaviours to be used when reading this stream

Creates and adds a DicomDataSet from an external DICOM file
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Read( _
   ByVal FileName As String, _
   Optional ByVal ReadBehaviour As ReadBehaviours _
) As DicomDataSet
'Usage

Dim instance As DicomDataSetCollection
Dim FileName As String
Dim ReadBehaviour As ReadBehaviours
Dim value As DicomDataSet

value = instance.Read(FileName, ReadBehaviour)
public DicomDataSet Read(
   string FileName,
   ReadBehaviours ReadBehaviour
)
public:
DicomDataSet^ Read(
   String^ FileName,
   ReadBehaviours^ ReadBehaviour
)

Parameters

FileName

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container’s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

ReadBehaviour

The behaviours to be used when reading this stream

Return Value

If successful, a DicomDataSet Object is returned, and is added to the appropriate collection. If unsuccessful, an appropriate error is thrown.
Remarks

This method can read either official "Part10" format files with the 128 byte header, or unofficial "Part5" format files without a header. Detection of the type is automatic.

The file may have been written by the Write method or by other DICOM software.

By default, pixel data is read only when it is required, greatly speeding the display of multi-frame images, and reducing memory requirements. However, a side effect of this is that any elements after the pixel data (7FE0,0010) will not be read. This should not affect most applications, but if necessary, this behavior may be over-ridden using the DicomGlobal.CloseFilesAfterReading property.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members
Overload List


Read(Byte[]) Method

Read(Byte[]) Method

DicomObjects Namespace > DicomDataSetCollection Class > Read Method : Read(Byte[]) Method

Array as Byte Array:

The Byte Array to read

Creates and adds a DicomDataSet from a byte array
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Read( _
   ByVal Array() As Byte _
) As DicomDataSet
'Usage

Dim instance As DicomDataSetCollection
Dim Array() As Byte
Dim value As DicomDataSet

value = instance.Read(Array)
public DicomDataSet Read(
   byte[] Array
)
public:
DicomDataSet^ Read(
   array<byte>^ Array
)

Parameters

Array

Array as Byte Array:

The Byte Array to read

Return Value

DicomDataSet
Remarks
This method uses memory stream to read a byte array and creates a new DicomDataSet and adds it to the DicomDataSetCollection.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members
Overload List


Read(IEnumerable<String>,ReadBehaviours) Method

Read(IEnumerable<String>,ReadBehaviours) Method

DicomObjects Namespace > DicomDataSetCollection Class > Read Method : Read(IEnumerable<String>,ReadBehaviours) Method

A set of Filenames to read.

The behaviours to be used when reading this stream

Creates and adds a collection of DicomDataSet objects from a collection of external DICOM files
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Read( _
   ByVal FileNames As IEnumerable(Of String), _
   Optional ByVal ReadBehaviour As ReadBehaviours _
) As DicomDataSetCollection
'Usage

Dim instance As DicomDataSetCollection
Dim FileNames As IEnumerable(Of String)
Dim ReadBehaviour As ReadBehaviours
Dim value As DicomDataSetCollection

value = instance.Read(FileNames, ReadBehaviour)
public DicomDataSetCollection Read(
   IEnumerable<string> FileNames,
   ReadBehaviours ReadBehaviour
)
public:
DicomDataSetCollection^ Read(
   IEnumerable<String^>^ FileNames,
   ReadBehaviours^ ReadBehaviour
)

Parameters

FileNames

A set of Filenames to read.

ReadBehaviour

The behaviours to be used when reading this stream

Return Value

If successful, a DicomDataSetCollection is returned, and is added to the appropriate collection. If unsuccessful, an appropriate error is thrown.
Remarks
Like reading from a single DICOM file, this method loops through the list of files and read them one by one and if successful returns a DicomDataSetCollectionwhich contains all the newly created DicomDataSets.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members
Overload List


Read(Stream,ReadBehaviours) Method

Read(Stream,ReadBehaviours) Method

DicomObjects Namespace > DicomDataSetCollection Class > Read Method : Read(Stream,ReadBehaviours) Method

The stream from which to read.

The behaviours to be used when reading this stream

Reads a DICOM file from a Stream
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Read( _
   ByVal Stream As Stream, _
   Optional ByVal ReadBehaviour As ReadBehaviours _
) As DicomDataSet
'Usage

Dim instance As DicomDataSetCollection
Dim Stream As Stream
Dim ReadBehaviour As ReadBehaviours
Dim value As DicomDataSet

value = instance.Read(Stream, ReadBehaviour)
public DicomDataSet Read(
   Stream Stream,
   ReadBehaviours ReadBehaviour
)
public:
DicomDataSet^ Read(
   Stream^ Stream,
   ReadBehaviours^ ReadBehaviour
)

Parameters

Stream

The stream from which to read.

ReadBehaviour

The behaviours to be used when reading this stream

Return Value

If successful, a DicomDataSet Object is returned, and is added to the appropriate collection. If unsuccessful, an appropriate error is thrown.
Remarks

This method can read streams in either official "Part10" format, with the 128 byte header, or unofficial "Part5" format, without a header. Detection of the type is automatic.

The stream may have been written by the Write method or by other DICOM software.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members
Overload List


ReadJson Method (DicomDataSetCollection)

ReadJson Method (DicomDataSetCollection)

DicomObjects Namespace > DicomDataSetCollection Class : ReadJson Method
The Stream to read from
The transfer syntax to assign to the resulting instances - see remarks
Read DICOM data from a JSON Stream
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ReadJson( _
   ByVal Stream As Stream, _
   Optional ByVal TransferSyntax As String _
)
'Usage

Dim instance As DicomDataSetCollection
Dim Stream As Stream
Dim TransferSyntax As String

instance.ReadJson(Stream, TransferSyntax)
public void ReadJson(
   Stream Stream,
   string TransferSyntax
)
public:
void ReadJson(
   Stream^ Stream,
   String^ TransferSyntax
)

Parameters

Stream
The Stream to read from
TransferSyntax
The transfer syntax to assign to the resulting instances - see remarks
Remarks

The JSON data must be compliant with the Native DICOM Model outlined in the DICOM Part 18, with modifications as defined in supplement 163 to allow bulk data

The TransferSyntaxvalue does not directly affect the data itself, which is independent of transfer syntax, but the assigned value may be used internally to control the form in which are missing bulk data (e.g. pixel data) is requested fromn an origin server if replaced by a BulkDataUri property.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members


ReadMint Method

ReadMint Method

DicomObjects Namespace > DicomDataSetCollection Class : ReadMint Method
Read MINT Stream to reconstruct DICOM data from MINT data
Overload List
Overload | Description
ReadMint(Stream) | Read MINT Stream to reconstruct DICOM data from MINT data
ReadMint(Stream,Func<String,Int32,Byte[]>) | Read MINT Stream to reconstruct DICOM data from MINT data
ReadMint(StringReader,Func<String,Int32,Byte[]>) | Read MINT Stream to reconstruct DICOM data from MINT data
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members


ReadMint(Stream) Method

ReadMint(Stream) Method

DicomObjects Namespace > DicomDataSetCollection Class > ReadMint Method : ReadMint(Stream) Method
MINT input Stream
Read MINT Stream to reconstruct DICOM data from MINT data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub ReadMint( _
   ByVal MintInputStream As Stream _
)
'Usage

Dim instance As DicomDataSetCollection
Dim MintInputStream As Stream

instance.ReadMint(MintInputStream)
public void ReadMint(
   Stream MintInputStream
)
public:
void ReadMint(
   Stream^ MintInputStream
)

Parameters

MintInputStream
MINT input Stream
Remarks
This method returns just the metadata and skips bid handling
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members
Overload List


ReadMint(Stream,Func<String,Int32,Byte[]>) Method

ReadMint(Stream,Func<String,Int32,Byte[]>) Method

DicomObjects Namespace > DicomDataSetCollection Class > ReadMint Method : ReadMint(Stream,Func<String,Int32,Byte[]>) Method
MINT input Stream
User defined Func to obtain binary data for a specific bid
Read MINT Stream to reconstruct DICOM data from MINT data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub ReadMint( _
   ByVal MintInputStream As Stream, _
   ByVal GetBinaryDataAsStream As Func(Of String,Integer,Byte()) _
)
'Usage

Dim instance As DicomDataSetCollection
Dim MintInputStream As Stream
Dim GetBinaryDataAsStream As Func(Of String,Integer,Byte())

instance.ReadMint(MintInputStream, GetBinaryDataAsStream)
public void ReadMint(
   Stream MintInputStream,
   Func<string,int,byte[]> GetBinaryDataAsStream
)
public:
void ReadMint(
   Stream^ MintInputStream,
   Func<String^,int,array<byte>>^ GetBinaryDataAsStream
)

Parameters

MintInputStream
MINT input Stream
GetBinaryDataAsStream
User defined Func to obtain binary data for a specific bid
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members
Overload List


ReadMint(StringReader,Func<String,Int32,Byte[]>) Method

ReadMint(StringReader,Func<String,Int32,Byte[]>) Method

DicomObjects Namespace > DicomDataSetCollection Class > ReadMint Method : ReadMint(StringReader,Func<String,Int32,Byte[]>) Method
MINT text input
User defined Func to obtain binary data for a specific bid
Read MINT Stream to reconstruct DICOM data from MINT data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub ReadMint( _
   ByVal Reader As StringReader, _
   ByVal GetBinaryDataAsStream As Func(Of String,Integer,Byte()) _
)
'Usage

Dim instance As DicomDataSetCollection
Dim Reader As StringReader
Dim GetBinaryDataAsStream As Func(Of String,Integer,Byte())

instance.ReadMint(Reader, GetBinaryDataAsStream)
public void ReadMint(
   StringReader Reader,
   Func<string,int,byte[]> GetBinaryDataAsStream
)
public:
void ReadMint(
   StringReader^ Reader,
   Func<String^,int,array<byte>>^ GetBinaryDataAsStream
)

Parameters

Reader
MINT text input
GetBinaryDataAsStream
User defined Func to obtain binary data for a specific bid
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members
Overload List


Remove Method (DicomDataSetCollection)

Remove Method (DicomDataSetCollection)

DicomObjects Namespace > DicomDataSetCollection Class : Remove Method
Removes DicomDataSet from a DicomDataSetCollectionby matching its InstanceUID
Overload List
Overload | Description
Remove(String) | Removes DicomDataSet from a DicomDataSetCollectionby matching its InstanceUID
Remove(DicomDataSet) | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members


Remove(String) Method

Remove(String) Method

DicomObjects Namespace > DicomDataSetCollection Class > Remove Method : Remove(String) Method

The InstanceUID of the DicomDataSet to be removed from the DicomDataSetCollection

Removes DicomDataSet from a DicomDataSetCollectionby matching its InstanceUID
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Remove( _
   ByVal InstanceUID As String _
)
'Usage

Dim instance As DicomDataSetCollection
Dim InstanceUID As String

instance.Remove(InstanceUID)
public void Remove(
   string InstanceUID
)
public:
void Remove(
   String^ InstanceUID
)

Parameters

InstanceUID

The InstanceUID of the DicomDataSet to be removed from the DicomDataSetCollection

Remarks
The first DicomDataSet objects with the same InstanceUID will be removed from the Collection.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members
Overload List


Send Method (DicomDataSetCollection)

Send Method (DicomDataSetCollection)

DicomObjects Namespace > DicomDataSetCollection Class : Send Method
String value, the IP address
Integer value, the port number
String value, the calling application entity title
String value, the called application entity title
Sends all DataSets within the collection in one association
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function Send( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAE As String, _
   ByVal CalledAE As String _
) As Integer()
'Usage

Dim instance As DicomDataSetCollection
Dim Node As String
Dim Port As Integer
Dim CallingAE As String
Dim CalledAE As String
Dim value() As Integer

value = instance.Send(Node, Port, CallingAE, CalledAE)
public int[] Send(
   string Node,
   int Port,
   string CallingAE,
   string CalledAE
)
public:
array<int>^ Send(
   String^ Node,
   int Port,
   String^ CallingAE,
   String^ CalledAE
)

Parameters

Node
String value, the IP address
Port
Integer value, the port number
CallingAE
String value, the calling application entity title
CalledAE
String value, the called application entity title

Return Value

int Array, as status of each image transfer
Remarks
This does the send in ONE association and returns an array of integers as the status of each transfer. Association is closed automatically once sending has completed.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members


WriteJson Method (DicomDataSetCollection)

WriteJson Method (DicomDataSetCollection)

DicomObjects Namespace > DicomDataSetCollection Class : WriteJson Method
The Stream to write to
Write DICOM data to a JSON Stream
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub WriteJson( _
   ByVal Stream As Stream _
)
'Usage

Dim instance As DicomDataSetCollection
Dim Stream As Stream

instance.WriteJson(Stream)
public void WriteJson(
   Stream Stream
)
public:
void WriteJson(
   Stream^ Stream
)

Parameters

Stream
The Stream to write to
Remarks
The JSON data will be compliant with the Native DICOM Model outlined in the DICOM Part 18, with modifications as defined in supplement 163 to allow bulk data
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members


WriteMint Method

WriteMint Method

DicomObjects Namespace > DicomDataSetCollection Class : WriteMint Method
Output Stream for MINT
Write DICOM data to a MINT Stream and returns the list of bid's
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function WriteMint( _
   ByVal MintOutputStream As Stream _
) As IEnumerable(Of BidMap)
'Usage

Dim instance As DicomDataSetCollection
Dim MintOutputStream As Stream
Dim value As IEnumerable(Of BidMap)

value = instance.WriteMint(MintOutputStream)
public IEnumerable<BidMap> WriteMint(
   Stream MintOutputStream
)
public:
IEnumerable<BidMap^>^ WriteMint(
   Stream^ MintOutputStream
)

Parameters

MintOutputStream
Output Stream for MINT

Return Value

List of bid maps for the MINT output
Remarks
The MINT data will be compliant with the MINT Study Metadata Format
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members


DicomDataSetCollection Class Properties

DicomDataSetCollection Class Properties

DicomObjects Namespace : DicomDataSetCollection Class

For a list of all members of this type, see DicomDataSetCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Property | Item | Overloaded. Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Public Property | SopUIDList | Contains a list of SOP Class UIDs for all DataSet items contained in this Collection
Public Property | Tag | A general purpose Tag for developer use
Top
See Also

Reference

DicomDataSetCollection Class
DicomObjects Namespace


Item Property (DicomDataSetCollection)

Item Property (DicomDataSetCollection)

DicomObjects Namespace > DicomDataSetCollection Class : Item Property
Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Overload List
Overload | Description
Item(String) | Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Item(Int32) | Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file. (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Remarks
This is the default indexer. Individual DicomDataSet item can be accessed via DicomDataSetCollection[InstanceUID].
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members


Item(String) Property

Item(String) Property

DicomObjects Namespace > DicomDataSetCollection Class > Item Property : Item(String) Property

String, the Instance UID of the DicomDataSet

Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal InstanceUID As String _
) As DicomDataSet
'Usage

Dim instance As DicomDataSetCollection
Dim InstanceUID As String
Dim value As DicomDataSet

value = instance.Item(InstanceUID)
public DicomDataSet Item(
   string InstanceUID
) {get;}
public:
property DicomDataSet^ Item {
   DicomDataSet^ get(String^ InstanceUID);
}

Parameters

InstanceUID

String, the Instance UID of the DicomDataSet

Remarks
This is the default indexer. Individual DicomDataSet item can be accessed via DicomDataSetCollection[InstanceUID].
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members
Overload List


SopUIDList Property

SopUIDList Property

DicomObjects Namespace > DicomDataSetCollection Class : SopUIDList Property
Contains a list of SOP Class UIDs for all DataSet items contained in this Collection
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property SopUIDList As String()
'Usage

Dim instance As DicomDataSetCollection
Dim value() As String

value = instance.SopUIDList
public string[] SopUIDList {get;}
public:
property array<String^>^ SopUIDList {
   array<String^>^ get();
}
Remarks
Returns an empty Array if the DicomDataSetCollection is empty, otherwise it returns a list of SOP Class UIDs of all DataSet items.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members


Tag Property (DicomDataSetCollection)

Tag Property (DicomDataSetCollection)

DicomObjects Namespace > DicomDataSetCollection Class : Tag Property
A general purpose Tag for developer use
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Tag As Object
'Usage

Dim instance As DicomDataSetCollection
Dim value As Object

instance.Tag = value

value = instance.Tag
public object Tag {get; set;}
public:
property Object^ Tag {
   Object^ get();
   void set (    Object^ value);
}
Remarks
This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSetCollection Class
DicomDataSetCollection Members


DicomException Class

DicomException Class
Members

DicomObjects Namespace : DicomException Class
Specific Exception for DICOM errors
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomException
   Inherits System.Exception
'Usage

Dim instance As DicomException
public class DicomException : System.Exception
public ref class DicomException : public System.Exception
Remarks
Where possible, "standard" exceptions are thrown (file not found etc.) but this exception class exists to handle more specialized DICOM exceptions

Where possible, "standard" exceptions are thrown (file not found etc.) but this exception class exists to handle more specialized DICOM exceptions

For validation errors, the more specific derived class, DicomValidationException is used instead

Inheritance Hierarchy

System.Object
System.Exception
DicomObjects.DicomException

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomException Members
DicomObjects Namespace


DicomException Class Members

DicomException Class Members
Properties Methods

DicomObjects Namespace : DicomException Class

The following tables list the members exposed by DicomException.

Public Constructors
 | Name | Description
Public Constructor | DicomException Constructor | Overloaded. Create a new DicomException
Top
Public Properties
 | Name | Description
Public Property | CausedAbort | True if this exception caused the related to association to issue an Abort (thereby no longer requiring to be closed)
Public Property | Code | The Error code
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | Tag | A general purpose Tag for developer use
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

DicomException Class
DicomObjects Namespace


DicomException Constructor

DicomException Constructor

DicomObjects Namespace > DicomException Class : DicomException Constructor
Create a new DicomException
Overload List
Overload | Description
DicomException Constructor(Int32) | Create a new DicomException
DicomException Constructor(Int32,String) | Create a new DicomException
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomException Class
DicomException Members


DicomException Constructor(Int32)

DicomException Constructor(Int32)

DicomObjects Namespace > DicomException Class > DicomException Constructor : DicomException Constructor(Int32)
The DicomObjects error code
Create a new DicomException
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal code As Integer _
)
'Usage

Dim code As Integer

Dim instance As New DicomException(code)
public DicomException(
   int code
)
public:
DicomException(
   int code
)

Parameters

code
The DicomObjects error code
Remarks
This is only intended for internal use, but is made public for use by external codecs
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomException Class
DicomException Members
Overload List


DicomException Constructor(Int32,String)

DicomException Constructor(Int32,String)

DicomObjects Namespace > DicomException Class > DicomException Constructor : DicomException Constructor(Int32,String)
Error code
Associated string to be inserted
Create a new DicomException
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal code As Integer, _
   ByVal val As String _
)
'Usage

Dim code As Integer
Dim val As String

Dim instance As New DicomException(code, val)
public DicomException(
   int code,
   string val
)
public:
DicomException(
   int code,
   String^ val
)

Parameters

code
Error code
val
Associated string to be inserted
Remarks
This is only intended for internal use, but is made public for use by external codecs
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomException Class
DicomException Members
Overload List


DicomException Class Properties

DicomException Class Properties

DicomObjects Namespace : DicomException Class

For a list of all members of this type, see DicomException members.

Public Properties
 | Name | Description
Public Property | CausedAbort | True if this exception caused the related to association to issue an Abort (thereby no longer requiring to be closed)
Public Property | Code | The Error code
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | Tag | A general purpose Tag for developer use
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

DicomException Class
DicomObjects Namespace


CausedAbort Property

CausedAbort Property

DicomObjects Namespace > DicomException Class : CausedAbort Property
True if this exception caused the related to association to issue an Abort (thereby no longer requiring to be closed)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property CausedAbort As Boolean
'Usage

Dim instance As DicomException
Dim value As Boolean

value = instance.CausedAbort
public bool CausedAbort {get;}
public:
property bool CausedAbort {
   bool get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomException Class
DicomException Members


Code Property

Code Property

DicomObjects Namespace > DicomException Class : Code Property
The Error code
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Code As Integer
'Usage

Dim instance As DicomException
Dim value As Integer

value = instance.Code
public int Code {get;}
public:
property int Code {
   int get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomException Class
DicomException Members


Tag Property (DicomException)

Tag Property (DicomException)

DicomObjects Namespace > DicomException Class : Tag Property
A general purpose Tag for developer use
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Tag As Object
'Usage

Dim instance As DicomException
Dim value As Object

instance.Tag = value

value = instance.Tag
public object Tag {get; set;}
public:
property Object^ Tag {
   Object^ get();
   void set (    Object^ value);
}
Remarks
This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomException Class
DicomException Members


DicomGlobal Class

DicomGlobal Class
Members

DicomObjects Namespace : DicomGlobal Class
Placeholder for various static methods and properties
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit NotInheritable Class DicomGlobal
'Usage

Dim instance As DicomGlobal
public static class DicomGlobal
public ref class DicomGlobal abstract sealed
Remarks
Properties may be set and methods called from a config file if necessary - see Config File for more information.
Inheritance Hierarchy

System.Object
DicomObjects.DicomGlobal

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Members
DicomObjects Namespace


DicomGlobal Class Members

DicomGlobal Class Members
Properties Methods Events

DicomObjects Namespace : DicomGlobal Class

The following tables list the members exposed by DicomGlobal.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | AssemblyDirectory | Returns the Assembly Directory information
static (Shared in Visual Basic) | AssemblyVersion | Gets the Assembly Version of DicomObjects.NET
static (Shared in Visual Basic) | Assume2022Escapes | Controls whether DicomObjects attempts to locate unannounced 2022 escape sequences
static (Shared in Visual Basic) | ChangeLossyUIDs | Controls whether DicomObjects changes the UID when doing lossy compression
static (Shared in Visual Basic) | CloseFilesAfterReading | Controls how pixel data is read from disk
static (Shared in Visual Basic) | ColourConverter | Interface to allow override of the default CIELab <=> RGB conversion
static (Shared in Visual Basic) | CombinePDVs | Controls whether to combine outgoing command and data PDVs into a single PDU
static (Shared in Visual Basic) | CurrentLogFileName | Returns the Current DicomObjects Log File Name in full.
static (Shared in Visual Basic) | DefaultCacheMode | Default Cache Mode value used to initialize "CacheMode" property for DicomImage and DicomDataSet. This will be applied to all new instances.
static (Shared in Visual Basic) | DefaultCharacterSet | Default Character to set to use if 0008,0005 is absent
static (Shared in Visual Basic) | DefaultFFmpegFilter | Description of the Default filter to apply for FFmpeg processing
static (Shared in Visual Basic) | DefaultIpAddressFamily | The IP Address family to be used where not otherwise specified
static (Shared in Visual Basic) | DefaultReadBehaviour | Default behaviour when reading or receiving files
static (Shared in Visual Basic) | DefaultSOPClasses | Default list of SOP class UID's (Abstract syntaxes) to be used until specifically overridden by user settings
static (Shared in Visual Basic) | DefaultWriteBehaviour | Default behaviour when writing or sending files
static (Shared in Visual Basic) | DeidentifyInLog | A list of keywords fo attributes which should not be included in any standard log file.
static (Shared in Visual Basic) | DescriptionAsSerializationTag | To use attribute string description as tag for Json/XML serialization
static (Shared in Visual Basic) | DirectionStrings | Language specific indicators for anatomic labelling
static (Shared in Visual Basic) | DisplayCacheTime | Controls how long display cache copies of images are retained.
static (Shared in Visual Basic) | Enable10BitDisplay | To allows support for 10bit data.
static (Shared in Visual Basic) | EventLogLevel | Controls the logging of diagnostic message to the LogEvent event.
static (Shared in Visual Basic) | FailOnSuspiciousPreamble | Detect any non-zero data in the preamble (the first 128 bytes) leading to 'DICM', and alert if any unwanted bytes or malicious code is present. A pre-defined list of file formats PreambleFileSignatures is used for checking against the non-zero preamble This mainly affects data with such preamble when reading it in. Writing to disk or sending using DICOM protocol would remove existing preamble (effectively cleaning any malicious preamble) and recreate it when written to disk on the receiving side
static (Shared in Visual Basic) | FileVersion | Gets the File Version of DicomObjects.NET
static (Shared in Visual Basic) | FlushLevel | A level to cause the log to be flushed to disk
static (Shared in Visual Basic) | FontScaling | The factor by which to increase the font size when using DirectX display mode. The default is 1.5, which gives appearance similar to those in GDI mode.
static (Shared in Visual Basic) | HologicCompressedDataAttributeElements | List of attribute elements known to be used by Hologic for their compressed frames used to detect any compressed data in private sequence
static (Shared in Visual Basic) | IgnoreShortPixelData | Try to ignore Short pixel data error to suppress read exception. This does not fix any faulty attributes or guarantee the read pixels are correct and complete
static (Shared in Visual Basic) | ImplementationName | The Implementation Name of this application
static (Shared in Visual Basic) | ImplementationUID | The Implementation UID of this application
static (Shared in Visual Basic) | IndentJson | Controls whether JSON generated is indented and formatted for easy human interpretation
static (Shared in Visual Basic) | LockGdiOperations | Controls whether to use an explicit lock to prevent recurrent GDI operations from happening
static (Shared in Visual Basic) | MaximumDateTime | Control the global MaximumDateTime value used by DicomObjects. Default value is DateTime.MaxValue
static (Shared in Visual Basic) | MaximumNesting | Controls to what level deep are nested Sequences parsed
static (Shared in Visual Basic) | MaximumPDUSize | The Maximum PDU size accepted and used by DicomObjects
static (Shared in Visual Basic) | MinFontSize | Contains the Minimum Font Size used when drawing Text Label.
static (Shared in Visual Basic) | MinimumDateTime | Control the global MinimumDateTime value used by DicomObjects. Default value is DateTime.MinValue
static (Shared in Visual Basic) | MoveTimesOut | Controls whether DicomObjects will time out during a C-MOVE operation
static (Shared in Visual Basic) | PreambleFileSignatures | A pre-defined modifiable list of file signatures to match against the preamble if FailOnSuspiciousPreamble is enabled
static (Shared in Visual Basic) | PreferredBitmapMode | Controls method of rendering used by "Bitmap"
static (Shared in Visual Basic) | PresentationStateFont | The font to be used for internally generated DicomLabel objects derived from Presentation States
static (Shared in Visual Basic) | PreserveDoublePrecision | Retain precision for double numbers
static (Shared in Visual Basic) | ProductName | The product name to be shown in licensing Dialogs etc. Default value is "DicomObjects".
static (Shared in Visual Basic) | QuadrupedDirectionStrings | The quadruped equivalent of DirectionStrings allowing localisation of these abbreviations
static (Shared in Visual Basic) | RenderException | Controls whether non-image objects throw an exception during rendering
static (Shared in Visual Basic) | ReUseArrays | Controls whether DicomObjcts re-uses arrays to hold pixel data
static (Shared in Visual Basic) | ReuseOnlyExactArraySize | Controls whether "Over-sized" arrays are used
static (Shared in Visual Basic) | ShowTextBoxForPresentationStates | Controls whether bounding boxes are drawn around internally generated DicomLabel objects derived from text entries in Presentation States
static (Shared in Visual Basic) | SigningLicensePrefix | Set to tell DicomObjects to check the exe.{Prefix}.lic, instead of default exe.lic file
static (Shared in Visual Basic) | ThreadCount | Controls how many threads may be used by DicomObjects when rendering etc.
static (Shared in Visual Basic) | Timeout | The period of time that a network operation will wait if there is no response from the peer
static (Shared in Visual Basic) | UIDRoot | UIDRoot used by the NewUID method
static (Shared in Visual Basic) | UsePerformanceCounters | Controls use of specific performance counters for DicomObjects
static (Shared in Visual Basic) | UsePixelCache | Controls whether to use an area of memory as a pixel cache to reduce demands on the memory allocator
static (Shared in Visual Basic) | ValidDateMax | Maximum allowed DateTime for validation purposes Default value is DateTime.MaxValue
static (Shared in Visual Basic) | ValidDateMin | Minimum allowed DateTime for validation purposes Default value is DateTime.MinValue
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | AcceptedTransferSyntaxes | List of Transfer Syntaxes accepted by default for a group of SOP classes
static (Shared in Visual Basic) | AddDictionaryElement | Adds Data Element to the Dictionary.
static (Shared in Visual Basic) | AddPrivateDictionaryElement | Adds Private Data Element to the Dictionary.
static (Shared in Visual Basic) | AddToAcceptedTransferSyntaxes | Add an accepted Transfer Syntax into a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | AddToOfferedTransferSyntaxes | Add an offered Transfer Syntax into a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | AddToSOPClassGroup | Add a SOP class into a group used to help control use of associated transfer syntaxes
static (Shared in Visual Basic) | ClearAcceptedTransferSyntaxes | Clear all accepted Transfer Syntaxes from a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | ClearOfferedTransferSyntaxes | Clear all offered Transfer Syntaxes from a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | ClearSOPClassGroup | Clear all SOP classes from a group used to help control use of associated transfer syntaxes
static (Shared in Visual Basic) | Echo | Sends a DICOM verify (C-ECHO), with IP address, port number, callingAET, calledAET to another application entity, and returns the result
static (Shared in Visual Basic) | FindGroup | Find to which group a particular SOP class is currently assigned
static (Shared in Visual Basic) | GetRegString | Overloaded. Returns the key values from internal look up table
static (Shared in Visual Basic) | GetRegWord | Overloaded. Returns the key values from internal look up table
static (Shared in Visual Basic) | GetStatusCodeType | Checks if status code is a defined error code
static (Shared in Visual Basic) | GuidToUID | Construct a DICOM UID from Universally Unique Identifier (GUID) based on the method defined in ISO/IEC 9834-8 / ITU-T X.667
static (Shared in Visual Basic) | IgnoreAttribute | Instruct DicomObjects to ignore particular attributes
static (Shared in Visual Basic) | IsDICOM | Overloaded. Methods to check for DICOM content
static (Shared in Visual Basic) | IsEncrypted | Tests whether a DICOM file is encrypted according the CMS encoding defined in DICOM supplement 895
static (Shared in Visual Basic) | Keyword | Construct a keyword from arbitrary group and element values
static (Shared in Visual Basic) | LoadConfigFile | Forces loading of the XML configuration file
static (Shared in Visual Basic) | Log | Add text to the log file.
static (Shared in Visual Basic) | LogToFile | Overloaded. Enables DicomObjects logging
static (Shared in Visual Basic) | LogToFileStop | Stop logging to the currently active file
static (Shared in Visual Basic) | LogToStream | Enables DicomObjects logging to a user provided stream
static (Shared in Visual Basic) | MakeDictionary | Create a Dataset containing a null copy of all 'known' possible attributes
static (Shared in Visual Basic) | NewUID | Generates a guaranteed unique valid DICOM UID
static (Shared in Visual Basic) | OfferedTransferSyntaxes | List of Transfer Syntaxes offered by default for a group of SOP classes
static (Shared in Visual Basic) | RegisterPerformanceCounters | Specialised use for purely diagnostics purposes. Contact support@medicalconnections.co.uk for more information.
static (Shared in Visual Basic) | RemoveFromAcceptedTransferSyntaxes | Remove an accepted Transfer Syntax from a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | RemoveFromOfferedTransferSyntaxes | Remove an offered Transfer Syntax from a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | RemoveFromSOPClassGroup | Remove a SOP class from a group used to help control use of associated transfer syntaxes
static (Shared in Visual Basic) | ResetPixelCache | Clear any existing pixel cache
static (Shared in Visual Basic) | SetRegString | Insert or replace values in the internal virtual registry
static (Shared in Visual Basic) | SetRegWord | Sets key values in the internal look up table
static (Shared in Visual Basic) | SOPClassGroup | Groups of SOP classes that use the same default Transfer Syntaxes
static (Shared in Visual Basic) | Zoom | The Zoom factor corresponding to a given System.Drawing.Drawing2D.Matrix object
Top
Public Events
 | Name | Description
Public Event | LogEvent | Event fires when loggable events occur
Public Event | OnChangeUid | Event fired when DicomObjects should change a UID for an object
Public Event | ValidateFragments | Routine to allow validation (and if necessary, correction) of fragments of compressed pixel data
Top
See Also

Reference

DicomGlobal Class
DicomObjects Namespace


DicomGlobal Class Methods

DicomGlobal Class Methods

DicomObjects Namespace : DicomGlobal Class

For a list of all members of this type, see DicomGlobal members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | AcceptedTransferSyntaxes | List of Transfer Syntaxes accepted by default for a group of SOP classes
static (Shared in Visual Basic) | AddDictionaryElement | Adds Data Element to the Dictionary.
static (Shared in Visual Basic) | AddPrivateDictionaryElement | Adds Private Data Element to the Dictionary.
static (Shared in Visual Basic) | AddToAcceptedTransferSyntaxes | Add an accepted Transfer Syntax into a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | AddToOfferedTransferSyntaxes | Add an offered Transfer Syntax into a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | AddToSOPClassGroup | Add a SOP class into a group used to help control use of associated transfer syntaxes
static (Shared in Visual Basic) | ClearAcceptedTransferSyntaxes | Clear all accepted Transfer Syntaxes from a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | ClearOfferedTransferSyntaxes | Clear all offered Transfer Syntaxes from a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | ClearSOPClassGroup | Clear all SOP classes from a group used to help control use of associated transfer syntaxes
static (Shared in Visual Basic) | Echo | Sends a DICOM verify (C-ECHO), with IP address, port number, callingAET, calledAET to another application entity, and returns the result
static (Shared in Visual Basic) | FindGroup | Find to which group a particular SOP class is currently assigned
static (Shared in Visual Basic) | GetRegString | Overloaded. Returns the key values from internal look up table
static (Shared in Visual Basic) | GetRegWord | Overloaded. Returns the key values from internal look up table
static (Shared in Visual Basic) | GetStatusCodeType | Checks if status code is a defined error code
static (Shared in Visual Basic) | GuidToUID | Construct a DICOM UID from Universally Unique Identifier (GUID) based on the method defined in ISO/IEC 9834-8 / ITU-T X.667
static (Shared in Visual Basic) | IgnoreAttribute | Instruct DicomObjects to ignore particular attributes
static (Shared in Visual Basic) | IsDICOM | Overloaded. Methods to check for DICOM content
static (Shared in Visual Basic) | IsEncrypted | Tests whether a DICOM file is encrypted according the CMS encoding defined in DICOM supplement 895
static (Shared in Visual Basic) | Keyword | Construct a keyword from arbitrary group and element values
static (Shared in Visual Basic) | LoadConfigFile | Forces loading of the XML configuration file
static (Shared in Visual Basic) | Log | Add text to the log file.
static (Shared in Visual Basic) | LogToFile | Overloaded. Enables DicomObjects logging
static (Shared in Visual Basic) | LogToFileStop | Stop logging to the currently active file
static (Shared in Visual Basic) | LogToStream | Enables DicomObjects logging to a user provided stream
static (Shared in Visual Basic) | MakeDictionary | Create a Dataset containing a null copy of all 'known' possible attributes
static (Shared in Visual Basic) | NewUID | Generates a guaranteed unique valid DICOM UID
static (Shared in Visual Basic) | OfferedTransferSyntaxes | List of Transfer Syntaxes offered by default for a group of SOP classes
static (Shared in Visual Basic) | RegisterPerformanceCounters | Specialised use for purely diagnostics purposes. Contact support@medicalconnections.co.uk for more information.
static (Shared in Visual Basic) | RemoveFromAcceptedTransferSyntaxes | Remove an accepted Transfer Syntax from a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | RemoveFromOfferedTransferSyntaxes | Remove an offered Transfer Syntax from a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | RemoveFromSOPClassGroup | Remove a SOP class from a group used to help control use of associated transfer syntaxes
static (Shared in Visual Basic) | ResetPixelCache | Clear any existing pixel cache
static (Shared in Visual Basic) | SetRegString | Insert or replace values in the internal virtual registry
static (Shared in Visual Basic) | SetRegWord | Sets key values in the internal look up table
static (Shared in Visual Basic) | SOPClassGroup | Groups of SOP classes that use the same default Transfer Syntaxes
static (Shared in Visual Basic) | Zoom | The Zoom factor corresponding to a given System.Drawing.Drawing2D.Matrix object
Top
See Also

Reference

DicomGlobal Class
DicomObjects Namespace


AcceptedTransferSyntaxes Method

AcceptedTransferSyntaxes Method

DicomObjects Namespace > DicomGlobal Class : AcceptedTransferSyntaxes Method
The SOPClassGroups
List of Transfer Syntaxes accepted by default for a group of SOP classes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function AcceptedTransferSyntaxes( _
   ByVal Group As SOPClassGroups _
) As List(Of String)
'Usage

Dim Group As SOPClassGroups
Dim value As List(Of String)

value = DicomGlobal.AcceptedTransferSyntaxes(Group)
public static List<string> AcceptedTransferSyntaxes(
   SOPClassGroups Group
)
public:
static List<String^>^ AcceptedTransferSyntaxes(
   SOPClassGroups Group
)

Parameters

Group
The SOPClassGroups

Return Value

A list of Transfer Syntaxes to be accepted
Remarks

The list is pre-populated at initialization, but may be modified by the user

This method is intended for advanced usage - for simpler methods see:

  • AddToAcceptedTransferSyntaxes
  • RemoveFromAcceptedTransferSyntaxes
  • ClearAcceptedTransferSyntaxes

To control the related SOP classes and accepted transfer syntaxes associated with the group see:

  • AddToSOPClassGroup
  • RemoveFromSOPClassGroup
  • ClearSOPClassGroup
  • AddToOfferedTransferSyntaxes
  • RemoveFromOfferedTransferSyntaxes
  • ClearOfferedTransferSyntaxes
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


AddDictionaryElement Method

AddDictionaryElement Method

DicomObjects Namespace > DicomGlobal Class : AddDictionaryElement Method
Integer value, the group index of the data element.
Integer value, the element index of the data element.
String value, the value representation of the new data element.
String value, the value multiplicity of the data element.
String value, the description of the data element.
Adds Data Element to the Dictionary.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub AddDictionaryElement( _
   ByVal Group As Integer, _
   ByVal Element As Integer, _
   ByVal VR As String, _
   ByVal VM As String, _
   ByVal Description As String _
)
'Usage

Dim Group As Integer
Dim Element As Integer
Dim VR As String
Dim VM As String
Dim Description As String

DicomGlobal.AddDictionaryElement(Group, Element, VR, VM, Description)
public static void AddDictionaryElement(
   int Group,
   int Element,
   string VR,
   string VM,
   string Description
)
public:
static void AddDictionaryElement(
   int Group,
   int Element,
   String^ VR,
   String^ VM,
   String^ Description
)

Parameters

Group
Integer value, the group index of the data element.
Element
Integer value, the element index of the data element.
VR
String value, the value representation of the new data element.
VM
String value, the value multiplicity of the data element.
Description
String value, the description of the data element.
Remarks

If the specified Group and Element locate an existing data element in the dictionary, that data element will be removed from the dictionary and the new data element will be added to the dictionary. Otherwise, a new dictionary entry for the specified data element will be created.

Following the link to see more information about Group, Element, VR, VM and Description.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


AddPrivateDictionaryElement Method

AddPrivateDictionaryElement Method

DicomObjects Namespace > DicomGlobal Class : AddPrivateDictionaryElement Method
Integer value, the group index of the data element.
Byte value, the lower byte element index of the data element.
The name of the private creator
String value, the value representation of the new data element.
String value, the value multiplicity of the data element.
String value, the description of the data element.
Adds Private Data Element to the Dictionary.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub AddPrivateDictionaryElement( _
   ByVal Group As Integer, _
   ByVal Element As Byte, _
   ByVal Creator As String, _
   ByVal VR As String, _
   ByVal VM As String, _
   ByVal Description As String _
)
'Usage

Dim Group As Integer
Dim Element As Byte
Dim Creator As String
Dim VR As String
Dim VM As String
Dim Description As String

DicomGlobal.AddPrivateDictionaryElement(Group, Element, Creator, VR, VM, Description)
public static void AddPrivateDictionaryElement(
   int Group,
   byte Element,
   string Creator,
   string VR,
   string VM,
   string Description
)
public:
static void AddPrivateDictionaryElement(
   int Group,
   byte Element,
   String^ Creator,
   String^ VR,
   String^ VM,
   String^ Description
)

Parameters

Group
Integer value, the group index of the data element.
Element
Byte value, the lower byte element index of the data element.
Creator
The name of the private creator
VR
String value, the value representation of the new data element.
VM
String value, the value multiplicity of the data element.
Description
String value, the description of the data element.
Remarks

If the specified Group and Element locate an existing data element in the private element dictionary, that data element will be removed from the dictionary and the new data element will be added to the dictionary. Otherwise, a new dictionary entry for the specified data element will be created.

The Creator is a string which will be found in the element GGGG,00EE and identifies the creator of this private element

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


AddToAcceptedTransferSyntaxes Method

AddToAcceptedTransferSyntaxes Method

DicomObjects Namespace > DicomGlobal Class : AddToAcceptedTransferSyntaxes Method
The group to add the accepted Transfer Syntax to
The accepted Transfer Syntax to add
Add an accepted Transfer Syntax into a group used to help control automatic acceptance of transfer syntaxes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub AddToAcceptedTransferSyntaxes( _
   ByVal Group As SOPClassGroups, _
   ByVal TransferSyntax As UID _
)
'Usage

Dim Group As SOPClassGroups
Dim TransferSyntax As UID

DicomGlobal.AddToAcceptedTransferSyntaxes(Group, TransferSyntax)
public static void AddToAcceptedTransferSyntaxes(
   SOPClassGroups Group,
   UID TransferSyntax
)
public:
static void AddToAcceptedTransferSyntaxes(
   SOPClassGroups Group,
   UID^ TransferSyntax
)

Parameters

Group
The group to add the accepted Transfer Syntax to
TransferSyntax
The accepted Transfer Syntax to add
Remarks

The groups are pre-populated at initialization, but may be modified by the user

For direct access to the underlying List of Strings to allow advanced usage see AcceptedTransferSyntaxes

See Also:

  • AddToSOPClassGroup
  • RemoveFromSOPClassGroup
  • ClearSOPClassGroup
  • RemoveFromAcceptedTransferSyntaxes
  • ClearAcceptedTransferSyntaxes
  • AddToOfferedTransferSyntaxes
  • RemoveFromOfferedTransferSyntaxes
  • ClearOfferedTransferSyntaxes
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


AddToOfferedTransferSyntaxes Method

AddToOfferedTransferSyntaxes Method

DicomObjects Namespace > DicomGlobal Class : AddToOfferedTransferSyntaxes Method
The group to add the offered Transfer Syntax to
The offered Transfer Syntax to add
Add an offered Transfer Syntax into a group used to help control automatic acceptance of transfer syntaxes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub AddToOfferedTransferSyntaxes( _
   ByVal Group As SOPClassGroups, _
   ByVal TransferSyntax As UID _
)
'Usage

Dim Group As SOPClassGroups
Dim TransferSyntax As UID

DicomGlobal.AddToOfferedTransferSyntaxes(Group, TransferSyntax)
public static void AddToOfferedTransferSyntaxes(
   SOPClassGroups Group,
   UID TransferSyntax
)
public:
static void AddToOfferedTransferSyntaxes(
   SOPClassGroups Group,
   UID^ TransferSyntax
)

Parameters

Group
The group to add the offered Transfer Syntax to
TransferSyntax
The offered Transfer Syntax to add
Remarks

The groups are pre-populated at initialization, but may be modified by the user

For direct access to the underlying List of Strings to allow advanced usage see OfferedTransferSyntaxes

See Also:

  • AddToSOPClassGroup
  • RemoveFromSOPClassGroup
  • ClearSOPClassGroup
  • AddToAcceptedTransferSyntaxes
  • RemoveFromAcceptedTransferSyntaxes
  • ClearAcceptedTransferSyntaxes
  • RemoveFromOfferedTransferSyntaxes
  • ClearOfferedTransferSyntaxes
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


AddToSOPClassGroup Method

AddToSOPClassGroup Method

DicomObjects Namespace > DicomGlobal Class : AddToSOPClassGroup Method
The group to add the SOP class to
The SOP class to add
Add a SOP class into a group used to help control use of associated transfer syntaxes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub AddToSOPClassGroup( _
   ByVal Group As SOPClassGroups, _
   ByVal SOPClass As UID _
)
'Usage

Dim Group As SOPClassGroups
Dim SOPClass As UID

DicomGlobal.AddToSOPClassGroup(Group, SOPClass)
public static void AddToSOPClassGroup(
   SOPClassGroups Group,
   UID SOPClass
)
public:
static void AddToSOPClassGroup(
   SOPClassGroups Group,
   UID^ SOPClass
)

Parameters

Group
The group to add the SOP class to
SOPClass
The SOP class to add
Remarks

The groups are pre-populated at initialization, but may be modified by the user

For direct access to the underlying List of Strings to allow advanced usage see SOPClassGroup

See Also:

  • RemoveFromSOPClassGroup
  • ClearSOPClassGroup
  • AddToAcceptedTransferSyntaxes
  • RemoveFromAcceptedTransferSyntaxes
  • ClearAcceptedTransferSyntaxes
  • AddToOfferedTransferSyntaxes
  • RemoveFromOfferedTransferSyntaxes
  • ClearOfferedTransferSyntaxes
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


ClearAcceptedTransferSyntaxes Method

ClearAcceptedTransferSyntaxes Method

DicomObjects Namespace > DicomGlobal Class : ClearAcceptedTransferSyntaxes Method
The list of accepted Transfer Syntaxes to clear
Clear all accepted Transfer Syntaxes from a group used to help control automatic acceptance of transfer syntaxes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub ClearAcceptedTransferSyntaxes( _
   ByVal Group As SOPClassGroups _
)
'Usage

Dim Group As SOPClassGroups

DicomGlobal.ClearAcceptedTransferSyntaxes(Group)
public static void ClearAcceptedTransferSyntaxes(
   SOPClassGroups Group
)
public:
static void ClearAcceptedTransferSyntaxes(
   SOPClassGroups Group
)

Parameters

Group
The list of accepted Transfer Syntaxes to clear
Remarks

The groups are pre-populated at initialization, but may be modified by the user

For direct access to the underlying List of Strings to allow advanced usage see AcceptedTransferSyntaxes

See Also:

  • AddToSOPClassGroup
  • RemoveFromSOPClassGroup
  • ClearSOPClassGroup
  • AddToAcceptedTransferSyntaxes
  • RemoveFromAcceptedTransferSyntaxes
  • AddToOfferedTransferSyntaxes
  • RemoveFromOfferedTransferSyntaxes
  • ClearOfferedTransferSyntaxes
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


ClearOfferedTransferSyntaxes Method

ClearOfferedTransferSyntaxes Method

DicomObjects Namespace > DicomGlobal Class : ClearOfferedTransferSyntaxes Method
The list of offered Transfer Syntaxes to clear
Clear all offered Transfer Syntaxes from a group used to help control automatic acceptance of transfer syntaxes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub ClearOfferedTransferSyntaxes( _
   ByVal Group As SOPClassGroups _
)
'Usage

Dim Group As SOPClassGroups

DicomGlobal.ClearOfferedTransferSyntaxes(Group)
public static void ClearOfferedTransferSyntaxes(
   SOPClassGroups Group
)
public:
static void ClearOfferedTransferSyntaxes(
   SOPClassGroups Group
)

Parameters

Group
The list of offered Transfer Syntaxes to clear
Remarks

The groups are pre-populated at initialization, but may be modified by the user

For direct access to the underlying List of Strings to allow advanced usage see OfferedTransferSyntaxes

See Also:

  • AddToSOPClassGroup
  • RemoveFromSOPClassGroup
  • ClearSOPClassGroup
  • AddToAcceptedTransferSyntaxes
  • RemoveFromAcceptedTransferSyntaxes
  • ClearAcceptedTransferSyntaxes
  • AddToOfferedTransferSyntaxes
  • RemoveFromOfferedTransferSyntaxes
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


ClearSOPClassGroup Method

ClearSOPClassGroup Method

DicomObjects Namespace > DicomGlobal Class : ClearSOPClassGroup Method
The group to clear
Clear all SOP classes from a group used to help control use of associated transfer syntaxes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub ClearSOPClassGroup( _
   ByVal Group As SOPClassGroups _
)
'Usage

Dim Group As SOPClassGroups

DicomGlobal.ClearSOPClassGroup(Group)
public static void ClearSOPClassGroup(
   SOPClassGroups Group
)
public:
static void ClearSOPClassGroup(
   SOPClassGroups Group
)

Parameters

Group
The group to clear
Remarks

The groups are pre-populated at initialization, but may be modified by the user

For direct access to the underlying List of Strings to allow advanced usage see SOPClassGroup

See Also:

  • AddToSOPClassGroup
  • RemoveFromSOPClassGroup
  • AddToAcceptedTransferSyntaxes
  • RemoveFromAcceptedTransferSyntaxes
  • ClearAcceptedTransferSyntaxes
  • AddToOfferedTransferSyntaxes
  • RemoveFromOfferedTransferSyntaxes
  • ClearOfferedTransferSyntaxes
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


Echo Method (DicomGlobal)

Echo Method (DicomGlobal)

DicomObjects Namespace > DicomGlobal Class : Echo Method

Remote entity name as IP address or resolvable name

Port to connect to

Calling Application Entity Titles (AETs)

Called Application Entity Titles (AETs)

Sends a DICOM verify (C-ECHO), with IP address, port number, callingAET, calledAET to another application entity, and returns the result
Sends a DICOM verify (C-ECHO) and returns the result
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function Echo( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAET As String, _
   ByVal CalledAET As String _
) As Integer
'Usage

Dim Node As String
Dim Port As Integer
Dim CallingAET As String
Dim CalledAET As String
Dim value As Integer

value = DicomGlobal.Echo(Node, Port, CallingAET, CalledAET)
public static int Echo(
   string Node,
   int Port,
   string CallingAET,
   string CalledAET
)
public:
static int Echo(
   String^ Node,
   int Port,
   String^ CallingAET,
   String^ CalledAET
)

Parameters

Node

Remote entity name as IP address or resolvable name

Port

Port to connect to

CallingAET

Calling Application Entity Titles (AETs)

CalledAET

Called Application Entity Titles (AETs)

Return Value

The status provided by the SCP. This should always be 0
Remarks

Although in theory the remote entity may return a status other than 0 to indicate an error, in most circumstances (such as remote machine turned off), this method will fail with a trappable error, such as "Fail to connection at TCP level"

When certificate is used, a secure association will be attempted using TLS. If certificate is a valid x509 certificate, then user authentication will be used, but if it is null, then an anonymous client association will be attempted, which may or may not be accepted by the SCP.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


FindGroup Method

FindGroup Method

DicomObjects Namespace > DicomGlobal Class : FindGroup Method
The SOP class to be queried
Find to which group a particular SOP class is currently assigned
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function FindGroup( _
   ByVal UID As String _
) As SOPClassGroups
'Usage

Dim UID As String
Dim value As SOPClassGroups

value = DicomGlobal.FindGroup(UID)
public static SOPClassGroups FindGroup(
   string UID
)
public:
static SOPClassGroups FindGroup(
   String^ UID
)

Parameters

UID
The SOP class to be queried

Return Value

The associated group
Remarks
If no group is found, then SOPClassGroups.Services is returned
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


GetRegString Method

GetRegString Method

DicomObjects Namespace > DicomGlobal Class : GetRegString Method
Returns the key values from internal look up table
Overload List
Overload | Description
GetRegString(String,String) | Returns the value of a cached key with default value
GetRegString(String) | Returns the value of a cached key
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


GetRegString(String,String) Method

GetRegString(String,String) Method

DicomObjects Namespace > DicomGlobal Class > GetRegString Method : GetRegString(String,String) Method

The name of the registry key.

The default return value.

Returns the value of a cached key with default value
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Shared Function GetRegString( _
   ByVal Name As String, _
   ByVal Default As String _
) As String
'Usage

Dim Name As String
Dim Default As String
Dim value As String

value = DicomGlobal.GetRegString(Name, Default)
public static string GetRegString(
   string Name,
   string Default
)
public:
static String^ GetRegString(
   String^ Name,
   String^ Default
)

Parameters

Name

The name of the registry key.

Default

The default return value.

Return Value

string
Remarks

This method returns the registry key values from a internal look up table. If Name does not exist in that table, the default value will be returned.

As DicomGlobal does not look in to registry any more (as did in COM version) for key values, instead, an internal look up table is used to provide all those options used by DicomObjects, like logging, Importing/Exporting external files, Compression/Decompression, Supported SOP Class, Supported Transfer Syntax.

For a current list of values, se the wiki: http://www.medicalconnections.co.uk/kb/Registry_Values

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members
Overload List


GetRegString(String) Method

GetRegString(String) Method

DicomObjects Namespace > DicomGlobal Class > GetRegString Method : GetRegString(String) Method

The name of the registry key.

Returns the value of a cached key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Shared Function GetRegString( _
   ByVal Name As String _
) As String
'Usage

Dim Name As String
Dim value As String

value = DicomGlobal.GetRegString(Name)
public static string GetRegString(
   string Name
)
public:
static String^ GetRegString(
   String^ Name
)

Parameters

Name

The name of the registry key.

Return Value

string
Remarks
This method returns the registry key values from a internal look up table. If Name does not exist in that table, it will return an empty string "".

As DicomGlobal does not look in to registry any more (as did in COM version) for key values, instead, an internal look up table is used to provide all those options used by DicomObjects, like logging, Importing/Exporting external files, Compression/Decompression, Supported SOP Class, Supported Transfer Syntax.

For a current list of values, se the wiki: http://www.medicalconnections.co.uk/kb/Registry_Values

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members
Overload List


GetRegWord Method

GetRegWord Method

DicomObjects Namespace > DicomGlobal Class : GetRegWord Method
Returns the key values from internal look up table
Overload List
Overload | Description
GetRegWord(String,Int32) | Returns the value of a cached key with default value
GetRegWord(String) | Returns the value of a cached key
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


GetRegWord(String,Int32) Method

GetRegWord(String,Int32) Method

DicomObjects Namespace > DicomGlobal Class > GetRegWord Method : GetRegWord(String,Int32) Method

The name of the registry key.

The default return value.

Returns the value of a cached key with default value
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Shared Function GetRegWord( _
   ByVal Name As String, _
   ByVal Default As Integer _
) As Integer
'Usage

Dim Name As String
Dim Default As Integer
Dim value As Integer

value = DicomGlobal.GetRegWord(Name, Default)
public static int GetRegWord(
   string Name,
   int Default
)
public:
static int GetRegWord(
   String^ Name,
   int Default
)

Parameters

Name

The name of the registry key.

Default

The default return value.

Return Value

int
Remarks
This method returns the registry key values from a internal look up table. If Name does not exist in that table, the default value will be returned.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members
Overload List


GetRegWord(String) Method

GetRegWord(String) Method

DicomObjects Namespace > DicomGlobal Class > GetRegWord Method : GetRegWord(String) Method

The name of the registry key.

Returns the value of a cached key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Shared Function GetRegWord( _
   ByVal Name As String _
) As Integer
'Usage

Dim Name As String
Dim value As Integer

value = DicomGlobal.GetRegWord(Name)
public static int GetRegWord(
   string Name
)
public:
static int GetRegWord(
   String^ Name
)

Parameters

Name

The name of the registry key.

Return Value

int
Remarks
This method returns the registry key values from a internal look up table. If Name does not exist in that table, it will return 0.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members
Overload List


GetStatusCodeType Method

GetStatusCodeType Method

DicomObjects Namespace > DicomGlobal Class : GetStatusCodeType Method
Status code to check
Checks if status code is a defined error code
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function GetStatusCodeType( _
   ByVal statusCode As StatusCode _
) As StatusType
'Usage

Dim statusCode As StatusCode
Dim value As StatusType

value = DicomGlobal.GetStatusCodeType(statusCode)
public static StatusType GetStatusCodeType(
   StatusCode statusCode
)
public:
static StatusType GetStatusCodeType(
   StatusCode statusCode
)

Parameters

statusCode
Status code to check

Return Value

Type of the status code
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


GuidToUID Method

GuidToUID Method

DicomObjects Namespace > DicomGlobal Class : GuidToUID Method
A System.Guid object to construct the DICOM UID from
Construct a DICOM UID from Universally Unique Identifier (GUID) based on the method defined in ISO/IEC 9834-8 / ITU-T X.667
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function GuidToUID( _
   ByVal guid As Guid _
) As String
'Usage

Dim guid As Guid
Dim value As String

value = DicomGlobal.GuidToUID(guid)
public static string GuidToUID(
   Guid guid
)
public:
static String^ GuidToUID(
   Guid guid
)

Parameters

guid
A System.Guid object to construct the DICOM UID from

Return Value

A DICOM UID based on the Guid object
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


IgnoreAttribute Method

IgnoreAttribute Method

DicomObjects Namespace > DicomGlobal Class : IgnoreAttribute Method
The Group to ignore
The Element to ignore
Instruct DicomObjects to ignore particular attributes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub IgnoreAttribute( _
   ByVal Group As Integer, _
   ByVal Element As Integer _
)
'Usage

Dim Group As Integer
Dim Element As Integer

DicomGlobal.IgnoreAttribute(Group, Element)
public static void IgnoreAttribute(
   int Group,
   int Element
)
public:
static void IgnoreAttribute(
   int Group,
   int Element
)

Parameters

Group
The Group to ignore
Element
The Element to ignore
Remarks
This is a very specialist feature, intended only to be used when receiving or reading data from systems so bad that the data cannot be fixed after reading. It is most commonly used when receiving badly formatted sequences, but in that context can only be used when they use explicit length for the sequence as a whole, as it would otherwise not be possible to determine the location of the end of the sequence.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


IsDICOM Method

IsDICOM Method

DicomObjects Namespace > DicomGlobal Class : IsDICOM Method
Methods to check for DICOM content
Overload List
Overload | Description
IsDICOM(Stream) | A very simple method to test whether a stream contains valid DICOM
IsDICOM(String) | A very simple method to decide if a File is DICOM
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


IsDICOM(Stream) Method

IsDICOM(Stream) Method

DicomObjects Namespace > DicomGlobal Class > IsDICOM Method : IsDICOM(Stream) Method
The Stream which carries the data
A very simple method to test whether a stream contains valid DICOM
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Shared Function IsDICOM( _
   ByVal stream As Stream _
) As Boolean
'Usage

Dim stream As Stream
Dim value As Boolean

value = DicomGlobal.IsDICOM(stream)
public static bool IsDICOM(
   Stream stream
)
public:
static bool IsDICOM(
   Stream^ stream
)

Parameters

stream
The Stream which carries the data

Return Value

True if the byte 129 - 132 is DICM and the next 8 bytes contains the group 0 header data 02 00 00 00 55 4C 04 00
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members
Overload List


IsDICOM(String) Method

IsDICOM(String) Method

DicomObjects Namespace > DicomGlobal Class > IsDICOM Method : IsDICOM(String) Method
The full file path
A very simple method to decide if a File is DICOM
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Shared Function IsDICOM( _
   ByVal Filename As String _
) As Boolean
'Usage

Dim Filename As String
Dim value As Boolean

value = DicomGlobal.IsDICOM(Filename)
public static bool IsDICOM(
   string Filename
)
public:
static bool IsDICOM(
   String^ Filename
)

Parameters

Filename
The full file path

Return Value

True if bytes 129 - 132 are "DICM" and the next 8 bytes contains the group 0 header data 02 00 00 00 55 4C 04 00
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members
Overload List


IsEncrypted Method

IsEncrypted Method

DicomObjects Namespace > DicomGlobal Class : IsEncrypted Method
File to test
Tests whether a DICOM file is encrypted according the CMS encoding defined in DICOM supplement 895
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function IsEncrypted( _
   ByVal Filename As String _
) As Boolean
'Usage

Dim Filename As String
Dim value As Boolean

value = DicomGlobal.IsEncrypted(Filename)
public static bool IsEncrypted(
   string Filename
)
public:
static bool IsEncrypted(
   String^ Filename
)

Parameters

Filename
File to test

Return Value

True if file is encrypted
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


Keyword Method

Keyword Method

DicomObjects Namespace > DicomGlobal Class : Keyword Method
The Group value
The Element value
Construct a keyword from arbitrary group and element values
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function Keyword( _
   ByVal Group As UShort, _
   ByVal Element As UShort _
) As Keyword
'Usage

Dim Group As UShort
Dim Element As UShort
Dim value As Keyword

value = DicomGlobal.Keyword(Group, Element)
public static Keyword Keyword(
   ushort Group,
   ushort Element
)
public:
static Keyword Keyword(
   ushort Group,
   ushort Element
)

Parameters

Group
The Group value
Element
The Element value

Return Value

A keyword
Remarks
Note that the keyword generated does not need to exist within the pre-defined values of the Keyword enumeration, so this method may be used to generate keyword for private elements etc.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


LoadConfigFile Method

LoadConfigFile Method

DicomObjects Namespace > DicomGlobal Class : LoadConfigFile Method
Forces loading of the XML configuration file
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub LoadConfigFile()
'Usage

DicomGlobal.LoadConfigFile()
public static void LoadConfigFile()
public:
static void LoadConfigFile();
Remarks
Normally, this is loaded automatically, but this method exists for unusual situations where this need to be done before it would otherwise happen.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


Log Method

Log Method

DicomObjects Namespace > DicomGlobal Class : Log Method
Text as string, which is to be added to the log file.
Add text to the log file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub Log( _
   ByVal Text As String _
)
'Usage

Dim Text As String

DicomGlobal.Log(Text)
public static void Log(
   string Text
)
public:
static void Log(
   String^ Text
)

Parameters

Text
Text as string, which is to be added to the log file.
Remarks
Adds user specified text to the log file. Only works when the log file is enabled. For information about how to enable logging, see LogToFile.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


LogToFile Method

LogToFile Method

DicomObjects Namespace > DicomGlobal Class : LogToFile Method
Enables DicomObjects logging
Overload List
Overload | Description
LogToFile(String,Int32) | Enables DicomObjects logging, specifies where DicomObjects log files appear, what the logging level is and the timer interval when new log file should be generated.
LogToFile(String,Int32,Int32) | Enables DicomObjects logging, specifies where DicomObjects log files appear, what the logging level is and the timer interval when new log file should be generated.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


LogToFile(String,Int32) Method

LogToFile(String,Int32) Method

DicomObjects Namespace > DicomGlobal Class > LogToFile Method : LogToFile(String,Int32) Method

The location of the log files.

If an empty string being passed, DicomObjects will use "C:\" as the default location.

But still it is the container's responsibility to ensure either that the path is valid and correct.

This value controls the level of details logged either to the display, or to a file.

The allowable values for log level are:

Decimal | Hex |
1 | 1 | Errors
2 | 2 | Warnings
4 | 4 | Informational Messages
8 | 8 | Detailed Logging
16 | 10 | All DICOM attributes received or read
32 | 20 | All DICOM attributes send or written
64 | 40 | Byte-Level data received, except contents of data PDUs
128 | 80 | Byte-level data sent, except contents of data PDUs
256 | 100 | All bytes received
512 | 200 | All bytes sent

Enables DicomObjects logging, specifies where DicomObjects log files appear, what the logging level is and the timer interval when new log file should be generated.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Shared Sub LogToFile( _
   ByVal Path As String, _
   ByVal LogLevel As Integer _
)
'Usage

Dim Path As String
Dim LogLevel As Integer

DicomGlobal.LogToFile(Path, LogLevel)
public static void LogToFile(
   string Path,
   int LogLevel
)
public:
static void LogToFile(
   String^ Path,
   int LogLevel
)

Parameters

Path

The location of the log files.

If an empty string being passed, DicomObjects will use "C:\" as the default location.

But still it is the container's responsibility to ensure either that the path is valid and correct.

LogLevel

This value controls the level of details logged either to the display, or to a file.

The allowable values for log level are:

Decimal | Hex
1 | 1 | Errors
2 | 2 | Warnings
4 | 4 | Informational Messages
8 | 8 | Detailed Logging
16 | 10 | All DICOM attributes received or read
32 | 20 | All DICOM attributes send or written
64 | 40 | Byte-Level data received, except contents of data PDUs
128 | 80 | Byte-level data sent, except contents of data PDUs
256 | 100 | All bytes received
512 | 200 | All bytes sent

Remarks

The last two levels should NOT be used routinely when images are being sent or received, as the quality of log data becomes unmanageable, and the system will probably run so slowly that connecting equipment will time-out.

Other bits in the higher word are reserved for Medical Connections' use or future expansion.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members
Overload List


LogToFile(String,Int32,Int32) Method

LogToFile(String,Int32,Int32) Method

DicomObjects Namespace > DicomGlobal Class > LogToFile Method : LogToFile(String,Int32,Int32) Method

The location of the log files.

If an empty string being passed, DicomObjects will use "C:\" as the default location.

But still it is the container's responsibility to ensure either that the path is valid and correct.

This value controls the level of details logged either to the display, or to a file.

The allowable values for log level are:

Decimal | Hex |
1 | 1 | Errors
2 | 2 | Warnings
4 | 4 | Informational Messages
8 | 8 | Detailed Logging
16 | 10 | All DICOM attributes received or read
32 | 20 | All DICOM attributes send or written
64 | 40 | Byte-Level data received, except contents of data PDUs
128 | 80 | Byte-level data sent, except contents of data PDUs
256 | 100 | All bytes received
512 | 200 | All bytes sent

RestartMinutes as int, the time interval when a new log file should be generated.

Enables DicomObjects logging, specifies where DicomObjects log files appear, what the logging level is and the timer interval when new log file should be generated.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Shared Sub LogToFile( _
   ByVal Path As String, _
   ByVal LogLevel As Integer, _
   ByVal RestartMinutes As Integer _
)
'Usage

Dim Path As String
Dim LogLevel As Integer
Dim RestartMinutes As Integer

DicomGlobal.LogToFile(Path, LogLevel, RestartMinutes)
public static void LogToFile(
   string Path,
   int LogLevel,
   int RestartMinutes
)
public:
static void LogToFile(
   String^ Path,
   int LogLevel,
   int RestartMinutes
)

Parameters

Path

The location of the log files.

If an empty string being passed, DicomObjects will use "C:\" as the default location.

But still it is the container's responsibility to ensure either that the path is valid and correct.

LogLevel

This value controls the level of details logged either to the display, or to a file.

The allowable values for log level are:

Decimal | Hex
1 | 1 | Errors
2 | 2 | Warnings
4 | 4 | Informational Messages
8 | 8 | Detailed Logging
16 | 10 | All DICOM attributes received or read
32 | 20 | All DICOM attributes send or written
64 | 40 | Byte-Level data received, except contents of data PDUs
128 | 80 | Byte-level data sent, except contents of data PDUs
256 | 100 | All bytes received
512 | 200 | All bytes sent
RestartMinutes

RestartMinutes as int, the time interval when a new log file should be generated.

Remarks

The last two levels should NOT be used routinely when images are being sent or received, as the quality of log data becomes unmanageable, and the system will probably run so slowly that connecting equipment will time-out.

Other bits in the higher word are reserved for Medical Connections' use or future expansion.

This overload is to provide users a means to restart the logging on a regular time basic. This method is useful to avoid log file end up being HUGE.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members
Overload List


LogToFileStop Method

LogToFileStop Method

DicomObjects Namespace > DicomGlobal Class : LogToFileStop Method
Stop logging to the currently active file
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub LogToFileStop()
'Usage

DicomGlobal.LogToFileStop()
public static void LogToFileStop()
public:
static void LogToFileStop();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


LogToStream Method

LogToStream Method

DicomObjects Namespace > DicomGlobal Class : LogToStream Method

The stream to send log data to

This value controls the level of details logged either to the display, or to a file.

The allowable values for log level are:

Decimal | Hex |
1 | 1 | Errors
2 | 2 | Warnings
4 | 4 | Informational Messages
8 | 8 | Detailed Logging
16 | 10 | All DICOM attributes received or read
32 | 20 | All DICOM attributes send or written
64 | 40 | Byte-Level data received, except contents of data PDUs
128 | 80 | Byte-level data sent, except contents of data PDUs
256 | 100 | All bytes received
512 | 200 | All bytes sent
Enables DicomObjects logging to a user provided stream
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub LogToStream( _
   ByVal Stream As Stream, _
   ByVal LogLevel As Integer _
)
'Usage

Dim Stream As Stream
Dim LogLevel As Integer

DicomGlobal.LogToStream(Stream, LogLevel)
public static void LogToStream(
   Stream Stream,
   int LogLevel
)
public:
static void LogToStream(
   Stream^ Stream,
   int LogLevel
)

Parameters

Stream

The stream to send log data to

LogLevel

This value controls the level of details logged either to the display, or to a file.

The allowable values for log level are:

Decimal | Hex
1 | 1 | Errors
2 | 2 | Warnings
4 | 4 | Informational Messages
8 | 8 | Detailed Logging
16 | 10 | All DICOM attributes received or read
32 | 20 | All DICOM attributes send or written
64 | 40 | Byte-Level data received, except contents of data PDUs
128 | 80 | Byte-level data sent, except contents of data PDUs
256 | 100 | All bytes received
512 | 200 | All bytes sent
Remarks

The last two levels should NOT be used routinely when images are being sent or received, as the quality of log data becomes unmanageable, and the system will probably run so slowly that connecting equipment will time-out.

Other bits in the higher word are reserved for Medical Connections' use or future expansion.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


MakeDictionary Method

MakeDictionary Method

DicomObjects Namespace > DicomGlobal Class : MakeDictionary Method
Create a Dataset containing a null copy of all 'known' possible attributes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function MakeDictionary() As DicomDataSet
'Usage

Dim value As DicomDataSet

value = DicomGlobal.MakeDictionary()
public static DicomDataSet MakeDictionary()
public:
static DicomDataSet^ MakeDictionary();

Return Value

DicomDataSet
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


NewUID Method

NewUID Method

DicomObjects Namespace > DicomGlobal Class : NewUID Method
Generates a guaranteed unique valid DICOM UID
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function NewUID() As String
'Usage

Dim value As String

value = DicomGlobal.NewUID()
public static string NewUID()
public:
static String^ NewUID();

Return Value

String
Remarks
The UIDRoot property is used, followed by a unique combination of thread ID, date/time and an incrementing counter
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


OfferedTransferSyntaxes Method

OfferedTransferSyntaxes Method

DicomObjects Namespace > DicomGlobal Class : OfferedTransferSyntaxes Method

The SOPClassGroups

List of Transfer Syntaxes offered by default for a group of SOP classes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function OfferedTransferSyntaxes( _
   ByVal Group As SOPClassGroups _
) As List(Of String)
'Usage

Dim Group As SOPClassGroups
Dim value As List(Of String)

value = DicomGlobal.OfferedTransferSyntaxes(Group)
public static List<string> OfferedTransferSyntaxes(
   SOPClassGroups Group
)
public:
static List<String^>^ OfferedTransferSyntaxes(
   SOPClassGroups Group
)

Parameters

Group

The SOPClassGroups

Return Value

The list of Transfer Syntaxes to be offered
Remarks

The list is pre-populated at initialization, but may be modified by the user

This method is intended for advanced usage - for simpler methods see:

  • AddToOfferedTransferSyntaxes
  • RemoveFromOfferedTransferSyntaxes
  • ClearOfferedTransferSyntaxes

To control the related SOP classes and accepted transfer syntaxes associated with the group see:

  • AddToSOPClassGroup
  • RemoveFromSOPClassGroup
  • ClearSOPClassGroup
  • AddToAcceptedTransferSyntaxes
  • RemoveFromAcceptedTransferSyntaxes
  • ClearAcceptedTransferSyntaxes
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


RegisterPerformanceCounters Method

RegisterPerformanceCounters Method

DicomObjects Namespace > DicomGlobal Class : RegisterPerformanceCounters Method

If true, Performance Counters are registered

If true, Performance Counters are removed and re-registered

Specialised use for purely diagnostics purposes. Contact support@medicalconnections.co.uk for more information.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub RegisterPerformanceCounters( _
   ByVal register As Boolean, _
   ByVal reregister As Boolean _
)
'Usage

Dim register As Boolean
Dim reregister As Boolean

DicomGlobal.RegisterPerformanceCounters(register, reregister)
public static void RegisterPerformanceCounters(
   bool register,
   bool reregister
)
public:
static void RegisterPerformanceCounters(
   bool register,
   bool reregister
)

Parameters

register

If true, Performance Counters are registered

reregister

If true, Performance Counters are removed and re-registered

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


RemoveFromAcceptedTransferSyntaxes Method

RemoveFromAcceptedTransferSyntaxes Method

DicomObjects Namespace > DicomGlobal Class : RemoveFromAcceptedTransferSyntaxes Method
The group to remove the accepted Transfer Syntax from
The accepted Transfer Syntax to remove
Remove an accepted Transfer Syntax from a group used to help control automatic acceptance of transfer syntaxes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub RemoveFromAcceptedTransferSyntaxes( _
   ByVal Group As SOPClassGroups, _
   ByVal TransferSyntax As UID _
)
'Usage

Dim Group As SOPClassGroups
Dim TransferSyntax As UID

DicomGlobal.RemoveFromAcceptedTransferSyntaxes(Group, TransferSyntax)
public static void RemoveFromAcceptedTransferSyntaxes(
   SOPClassGroups Group,
   UID TransferSyntax
)
public:
static void RemoveFromAcceptedTransferSyntaxes(
   SOPClassGroups Group,
   UID^ TransferSyntax
)

Parameters

Group
The group to remove the accepted Transfer Syntax from
TransferSyntax
The accepted Transfer Syntax to remove
Remarks

The groups are pre-populated at initialization, but may be modified by the user

For direct access to the underlying List<String> to allow advanced usage see AcceptedTransferSyntaxes

See Also:

  • AddToSOPClassGroup
  • RemoveFromSOPClassGroup
  • ClearSOPClassGroup
  • AddToAcceptedTransferSyntaxes
  • ClearAcceptedTransferSyntaxes
  • AddToOfferedTransferSyntaxes
  • RemoveFromOfferedTransferSyntaxes
  • ClearOfferedTransferSyntaxes
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


RemoveFromOfferedTransferSyntaxes Method

RemoveFromOfferedTransferSyntaxes Method

DicomObjects Namespace > DicomGlobal Class : RemoveFromOfferedTransferSyntaxes Method
The group to remove the offered Transfer Syntax from
The offered Transfer Syntax to remove
Remove an offered Transfer Syntax from a group used to help control automatic acceptance of transfer syntaxes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub RemoveFromOfferedTransferSyntaxes( _
   ByVal Group As SOPClassGroups, _
   ByVal TransferSyntax As UID _
)
'Usage

Dim Group As SOPClassGroups
Dim TransferSyntax As UID

DicomGlobal.RemoveFromOfferedTransferSyntaxes(Group, TransferSyntax)
public static void RemoveFromOfferedTransferSyntaxes(
   SOPClassGroups Group,
   UID TransferSyntax
)
public:
static void RemoveFromOfferedTransferSyntaxes(
   SOPClassGroups Group,
   UID^ TransferSyntax
)

Parameters

Group
The group to remove the offered Transfer Syntax from
TransferSyntax
The offered Transfer Syntax to remove
Remarks

The groups are pre-populated at initialization, but may be modified by the user

For direct access to the underlying List of Strings to allow advanced usage see OfferedTransferSyntaxes

See Also:

  • AddToSOPClassGroup
  • RemoveFromSOPClassGroup
  • ClearSOPClassGroup
  • AddToAcceptedTransferSyntaxes
  • RemoveFromAcceptedTransferSyntaxes
  • ClearAcceptedTransferSyntaxes
  • AddToOfferedTransferSyntaxes
  • ClearOfferedTransferSyntaxes
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


RemoveFromSOPClassGroup Method

RemoveFromSOPClassGroup Method

DicomObjects Namespace > DicomGlobal Class : RemoveFromSOPClassGroup Method
The group to remove the SOP class from
The SOP class to remove
Remove a SOP class from a group used to help control use of associated transfer syntaxes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub RemoveFromSOPClassGroup( _
   ByVal Group As SOPClassGroups, _
   ByVal SOPClass As UID _
)
'Usage

Dim Group As SOPClassGroups
Dim SOPClass As UID

DicomGlobal.RemoveFromSOPClassGroup(Group, SOPClass)
public static void RemoveFromSOPClassGroup(
   SOPClassGroups Group,
   UID SOPClass
)
public:
static void RemoveFromSOPClassGroup(
   SOPClassGroups Group,
   UID^ SOPClass
)

Parameters

Group
The group to remove the SOP class from
SOPClass
The SOP class to remove
Remarks

The groups are pre-populated at initialization, but may be modified by the user

For direct access to the underlying Listof Strings to allow advanced usage see SOPClassGroup

See Also:

  • AddToSOPClassGroup
  • ClearSOPClassGroup
  • AddToAcceptedTransferSyntaxes
  • RemoveFromAcceptedTransferSyntaxes
  • ClearAcceptedTransferSyntaxes
  • AddToOfferedTransferSyntaxes
  • RemoveFromOfferedTransferSyntaxes
  • ClearOfferedTransferSyntaxes
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


ResetPixelCache Method

ResetPixelCache Method

DicomObjects Namespace > DicomGlobal Class : ResetPixelCache Method
Clear any existing pixel cache
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub ResetPixelCache()
'Usage

DicomGlobal.ResetPixelCache()
public static void ResetPixelCache()
public:
static void ResetPixelCache();
Remarks
See UsePixelCache for more details.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


SetRegString Method

SetRegString Method

DicomObjects Namespace > DicomGlobal Class : SetRegString Method

The name of the registry key.

The value to set.

Insert or replace values in the internal virtual registry
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub SetRegString( _
   ByVal Name As String, _
   ByVal Value As String _
)
'Usage

Dim Name As String
Dim Value As String

DicomGlobal.SetRegString(Name, Value)
public static void SetRegString(
   string Name,
   string Value
)
public:
static void SetRegString(
   String^ Name,
   String^ Value
)

Parameters

Name

The name of the registry key.

Value

The value to set.

Remarks

This method creates or replaces string values in the internal virtual registry. The internal look up table can be updated by calling this method to provide a pair of 'Name' and 'Value' e.g. 'UIDRoot' - '1.2.826.3.4.5.6'

As DicomGlobal does not look in to registry any more (as did in COM version) for key values, instead, an internal look up table is used to provide all those options used by DicomObjects, like logging, Importing/Exporting external files, Compression/Decompression, Supported SOP Class, Supported Transfer Syntax.

For a current list of values, se the wiki: http://www.medicalconnections.co.uk/kb/Registry_Values

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


SetRegWord Method

SetRegWord Method

DicomObjects Namespace > DicomGlobal Class : SetRegWord Method

The name of the registry key.

The value to set.

Sets key values in the internal look up table
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub SetRegWord( _
   ByVal Name As String, _
   ByVal Value As Integer _
)
'Usage

Dim Name As String
Dim Value As Integer

DicomGlobal.SetRegWord(Name, Value)
public static void SetRegWord(
   string Name,
   int Value
)
public:
static void SetRegWord(
   String^ Name,
   int Value
)

Parameters

Name

The name of the registry key.

Value

The value to set.

Remarks

This method creates, if the specified key does not exist, and puts the word value in. The internal look up table can be made by calling this method to provide a pair of 'Name' and 'Value' e.g. 'LogLevel' - '1', 'LogLocation' - '"c:\"'.

As DicomGlobal does not look in to registry any more (as did in COM version) for key values, instead, an internal look up table is used to provide all those options used by DicomObjects, like logging, Importing/Exporting external files, Compression/Decompression, Supported SOP Class, Supported Transfer Syntax.

For a current list of values, se the wiki: http://www.medicalconnections.co.uk/kb/Registry_Values

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


SOPClassGroup Method

SOPClassGroup Method

DicomObjects Namespace > DicomGlobal Class : SOPClassGroup Method
The group requested
Groups of SOP classes that use the same default Transfer Syntaxes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function SOPClassGroup( _
   ByVal Group As SOPClassGroups _
) As List(Of String)
'Usage

Dim Group As SOPClassGroups
Dim value As List(Of String)

value = DicomGlobal.SOPClassGroup(Group)
public static List<string> SOPClassGroup(
   SOPClassGroups Group
)
public:
static List<String^>^ SOPClassGroup(
   SOPClassGroups Group
)

Parameters

Group
The group requested

Return Value

The list of SOP classes to which the selected group applies
Remarks

These groups pre-populated at initialization, but may be modified by the user

This method is intended for advanced usage - for simpler methods see:

  • AddToSOPClassGroup
  • RemoveFromSOPClassGroup
  • ClearSOPClassGroup

To control the offered and accepted transfer syntaxes associated with the group see:

  • AddToAcceptedTransferSyntaxes
  • RemoveFromAcceptedTransferSyntaxes
  • ClearAcceptedTransferSyntaxes
  • AddToOfferedTransferSyntaxes
  • RemoveFromOfferedTransferSyntaxes
  • ClearOfferedTransferSyntaxes
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


Zoom Method

Zoom Method

DicomObjects Namespace > DicomGlobal Class : Zoom Method
The Matrix to use
The Zoom factor corresponding to a given System.Drawing.Drawing2D.Matrix object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function Zoom( _
   ByVal m As Matrix _
) As Single
'Usage

Dim m As Matrix
Dim value As Single

value = DicomGlobal.Zoom(m)
public static float Zoom(
   Matrix m
)
public:
static float Zoom(
   Matrix^ m
)

Parameters

m
The Matrix to use

Return Value

float/single
Remarks
If the Matrix is anisometropic (different zooms in different directions), then the lower of the two is used, corresponding to the behaviour of the Zoom property, which uses the specified zoom as the lower figure, and inflates the other as necessary to correct for non-square pixels.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


DicomGlobal Class Properties

DicomGlobal Class Properties

DicomObjects Namespace : DicomGlobal Class

For a list of all members of this type, see DicomGlobal members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | AssemblyDirectory | Returns the Assembly Directory information
static (Shared in Visual Basic) | AssemblyVersion | Gets the Assembly Version of DicomObjects.NET
static (Shared in Visual Basic) | Assume2022Escapes | Controls whether DicomObjects attempts to locate unannounced 2022 escape sequences
static (Shared in Visual Basic) | ChangeLossyUIDs | Controls whether DicomObjects changes the UID when doing lossy compression
static (Shared in Visual Basic) | CloseFilesAfterReading | Controls how pixel data is read from disk
static (Shared in Visual Basic) | ColourConverter | Interface to allow override of the default CIELab <=> RGB conversion
static (Shared in Visual Basic) | CombinePDVs | Controls whether to combine outgoing command and data PDVs into a single PDU
static (Shared in Visual Basic) | CurrentLogFileName | Returns the Current DicomObjects Log File Name in full.
static (Shared in Visual Basic) | DefaultCacheMode | Default Cache Mode value used to initialize "CacheMode" property for DicomImage and DicomDataSet. This will be applied to all new instances.
static (Shared in Visual Basic) | DefaultCharacterSet | Default Character to set to use if 0008,0005 is absent
static (Shared in Visual Basic) | DefaultFFmpegFilter | Description of the Default filter to apply for FFmpeg processing
static (Shared in Visual Basic) | DefaultIpAddressFamily | The IP Address family to be used where not otherwise specified
static (Shared in Visual Basic) | DefaultReadBehaviour | Default behaviour when reading or receiving files
static (Shared in Visual Basic) | DefaultSOPClasses | Default list of SOP class UID's (Abstract syntaxes) to be used until specifically overridden by user settings
static (Shared in Visual Basic) | DefaultWriteBehaviour | Default behaviour when writing or sending files
static (Shared in Visual Basic) | DeidentifyInLog | A list of keywords fo attributes which should not be included in any standard log file.
static (Shared in Visual Basic) | DescriptionAsSerializationTag | To use attribute string description as tag for Json/XML serialization
static (Shared in Visual Basic) | DirectionStrings | Language specific indicators for anatomic labelling
static (Shared in Visual Basic) | DisplayCacheTime | Controls how long display cache copies of images are retained.
static (Shared in Visual Basic) | Enable10BitDisplay | To allows support for 10bit data.
static (Shared in Visual Basic) | EventLogLevel | Controls the logging of diagnostic message to the LogEvent event.
static (Shared in Visual Basic) | FailOnSuspiciousPreamble | Detect any non-zero data in the preamble (the first 128 bytes) leading to 'DICM', and alert if any unwanted bytes or malicious code is present. A pre-defined list of file formats PreambleFileSignatures is used for checking against the non-zero preamble This mainly affects data with such preamble when reading it in. Writing to disk or sending using DICOM protocol would remove existing preamble (effectively cleaning any malicious preamble) and recreate it when written to disk on the receiving side
static (Shared in Visual Basic) | FileVersion | Gets the File Version of DicomObjects.NET
static (Shared in Visual Basic) | FlushLevel | A level to cause the log to be flushed to disk
static (Shared in Visual Basic) | FontScaling | The factor by which to increase the font size when using DirectX display mode. The default is 1.5, which gives appearance similar to those in GDI mode.
static (Shared in Visual Basic) | HologicCompressedDataAttributeElements | List of attribute elements known to be used by Hologic for their compressed frames used to detect any compressed data in private sequence
static (Shared in Visual Basic) | IgnoreShortPixelData | Try to ignore Short pixel data error to suppress read exception. This does not fix any faulty attributes or guarantee the read pixels are correct and complete
static (Shared in Visual Basic) | ImplementationName | The Implementation Name of this application
static (Shared in Visual Basic) | ImplementationUID | The Implementation UID of this application
static (Shared in Visual Basic) | IndentJson | Controls whether JSON generated is indented and formatted for easy human interpretation
static (Shared in Visual Basic) | LockGdiOperations | Controls whether to use an explicit lock to prevent recurrent GDI operations from happening
static (Shared in Visual Basic) | MaximumDateTime | Control the global MaximumDateTime value used by DicomObjects. Default value is DateTime.MaxValue
static (Shared in Visual Basic) | MaximumNesting | Controls to what level deep are nested Sequences parsed
static (Shared in Visual Basic) | MaximumPDUSize | The Maximum PDU size accepted and used by DicomObjects
static (Shared in Visual Basic) | MinFontSize | Contains the Minimum Font Size used when drawing Text Label.
static (Shared in Visual Basic) | MinimumDateTime | Control the global MinimumDateTime value used by DicomObjects. Default value is DateTime.MinValue
static (Shared in Visual Basic) | MoveTimesOut | Controls whether DicomObjects will time out during a C-MOVE operation
static (Shared in Visual Basic) | PreambleFileSignatures | A pre-defined modifiable list of file signatures to match against the preamble if FailOnSuspiciousPreamble is enabled
static (Shared in Visual Basic) | PreferredBitmapMode | Controls method of rendering used by "Bitmap"
static (Shared in Visual Basic) | PresentationStateFont | The font to be used for internally generated DicomLabel objects derived from Presentation States
static (Shared in Visual Basic) | PreserveDoublePrecision | Retain precision for double numbers
static (Shared in Visual Basic) | ProductName | The product name to be shown in licensing Dialogs etc. Default value is "DicomObjects".
static (Shared in Visual Basic) | QuadrupedDirectionStrings | The quadruped equivalent of DirectionStrings allowing localisation of these abbreviations
static (Shared in Visual Basic) | RenderException | Controls whether non-image objects throw an exception during rendering
static (Shared in Visual Basic) | ReUseArrays | Controls whether DicomObjcts re-uses arrays to hold pixel data
static (Shared in Visual Basic) | ReuseOnlyExactArraySize | Controls whether "Over-sized" arrays are used
static (Shared in Visual Basic) | ShowTextBoxForPresentationStates | Controls whether bounding boxes are drawn around internally generated DicomLabel objects derived from text entries in Presentation States
static (Shared in Visual Basic) | SigningLicensePrefix | Set to tell DicomObjects to check the exe.{Prefix}.lic, instead of default exe.lic file
static (Shared in Visual Basic) | ThreadCount | Controls how many threads may be used by DicomObjects when rendering etc.
static (Shared in Visual Basic) | Timeout | The period of time that a network operation will wait if there is no response from the peer
static (Shared in Visual Basic) | UIDRoot | UIDRoot used by the NewUID method
static (Shared in Visual Basic) | UsePerformanceCounters | Controls use of specific performance counters for DicomObjects
static (Shared in Visual Basic) | UsePixelCache | Controls whether to use an area of memory as a pixel cache to reduce demands on the memory allocator
static (Shared in Visual Basic) | ValidDateMax | Maximum allowed DateTime for validation purposes Default value is DateTime.MaxValue
static (Shared in Visual Basic) | ValidDateMin | Minimum allowed DateTime for validation purposes Default value is DateTime.MinValue
Top
See Also

Reference

DicomGlobal Class
DicomObjects Namespace


AssemblyDirectory Property

AssemblyDirectory Property

DicomObjects Namespace > DicomGlobal Class : AssemblyDirectory Property
Returns the Assembly Directory information
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property AssemblyDirectory As String
'Usage

Dim value As String

value = DicomGlobal.AssemblyDirectory
public static string AssemblyDirectory {get;}
public:
static property String^ AssemblyDirectory {
   String^ get();
}
Remarks
This property contains the directory information of the running DicomObjects.NET.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


AssemblyVersion Property

AssemblyVersion Property

DicomObjects Namespace > DicomGlobal Class : AssemblyVersion Property
Gets the Assembly Version of DicomObjects.NET
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property AssemblyVersion As String
'Usage

Dim value As String

value = DicomGlobal.AssemblyVersion
public static string AssemblyVersion {get;}
public:
static property String^ AssemblyVersion {
   String^ get();
}
Remarks
This property contains the Assembly Version of the running DicomObjects.NET. This information can be found in the DicomObjects.NET log file.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


Assume2022Escapes Property

Assume2022Escapes Property

DicomObjects Namespace > DicomGlobal Class : Assume2022Escapes Property
Controls whether DicomObjects attempts to locate unannounced 2022 escape sequences
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property Assume2022Escapes As Boolean
'Usage

Dim value As Boolean

DicomGlobal.Assume2022Escapes = value

value = DicomGlobal.Assume2022Escapes
public static bool Assume2022Escapes {get; set;}
public:
static property bool Assume2022Escapes {
   bool get();
   void set (    bool value);
}
Remarks
Officiallly in DICOM, ISO 2022 character escape may ONLY be used if the the specific character set (0008,0005) lists both the initial character set in its 2022 form (e.g. "ISO 2022 IR 100" in place of "ISO_IR 100" and also contains a list of all character sets that could be used. In practice however, some modality equipment suppliers don't bother to include 0008,0005 in their data at all, or fail to use the 2022-specific variant. This property, if true (the default value) allows DicomObjects to check whether a string contains any escape (0x1B) characters, and if it does, to assume 2022 mode (thereby enabling chages of character set) even in the absence of a marker in (0008,0005).
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members
DefaultCharacterSet Property


ChangeLossyUIDs Property (DicomGlobal)

ChangeLossyUIDs Property (DicomGlobal)

DicomObjects Namespace > DicomGlobal Class : ChangeLossyUIDs Property
Controls whether DicomObjects changes the UID when doing lossy compression
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property ChangeLossyUIDs As Boolean
'Usage

Dim value As Boolean

DicomGlobal.ChangeLossyUIDs = value

value = DicomGlobal.ChangeLossyUIDs
public static bool ChangeLossyUIDs {get; set;}
public:
static property bool ChangeLossyUIDs {
   bool get();
   void set (    bool value);
}
Remarks

There are times when the negotiated transfer syntaxes for a DicomAssociation require a previously uncompressed (or losslessly compressed) image to be transmmited in a lossy form. Although the DICOM standard is not entirely clear, most people believe that a new instance UID should be generated whenever this happens. This is the normal DicomObjects behaviour, and a reference to the original UID is included in the referenced image sequence. However, some query SCUs having requested a specific image by it's UID fail to look in the referenced image sequence and reject images with UIDs other than those they had requested.

This property provides a default value for new DicomAssociation objects, and also controls the behaviour for DicomImage.Write and DicomDataSet.Write. The default value of this property is true, causing new UIDs to be generated.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


CloseFilesAfterReading Property (DicomGlobal)

CloseFilesAfterReading Property (DicomGlobal)

DicomObjects Namespace > DicomGlobal Class : CloseFilesAfterReading Property
Controls how pixel data is read from disk
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property CloseFilesAfterReading As Boolean
'Usage

Dim value As Boolean

DicomGlobal.CloseFilesAfterReading = value

value = DicomGlobal.CloseFilesAfterReading
public static bool CloseFilesAfterReading {get; set;}
public:
static property bool CloseFilesAfterReading {
   bool get();
   void set (    bool value);
}
Remarks

If true, then all the pixel data is read from the disk at the time of reading the file, and the file is then closed. if false, then the file is kept open and pixel data is only read as and when required.

The default setting is true which improves memory usage, but has the downside that the file is locked. If you wish to over-write files which have been opened, then set this value to true before reading the files.

The default value is false

This corresponds to the old "DisableMemoryMapping" registry setting.

If required, this behaviour can be controlled on a file by file basis by using the CloseFilesAfterReading property of the ReadBehaviours class, combined with the appropriate override of DicomDataSet.Read

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


ColourConverter Property

ColourConverter Property

DicomObjects Namespace > DicomGlobal Class : ColourConverter Property
Interface to allow override of the default CIELab <=> RGB conversion
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property ColourConverter As IColourConverter
'Usage

Dim value As IColourConverter

DicomGlobal.ColourConverter = value

value = DicomGlobal.ColourConverter
public static IColourConverter ColourConverter {get; set;}
public:
static property IColourConverter^ ColourConverter {
   IColourConverter^ get();
   void set (    IColourConverter^ value);
}
Remarks
A default implementation is provided, but an application which implements an object with the IColourConverter interface can then assign it to this property which allows appropriate calibration where required.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


CombinePDVs Property

CombinePDVs Property

DicomObjects Namespace > DicomGlobal Class : CombinePDVs Property
Controls whether to combine outgoing command and data PDVs into a single PDU
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property CombinePDVs As Boolean
'Usage

Dim value As Boolean

DicomGlobal.CombinePDVs = value

value = DicomGlobal.CombinePDVs
public static bool CombinePDVs {get; set;}
public:
static property bool CombinePDVs {
   bool get();
   void set (    bool value);
}
Remarks

DicomObjects accepts PDVs in any combination in incoming PDUs, but as some implementations fall over when sent such data, by default (when this property is false), DicomObjects send command and data PDVs in separate PDUs

Setting this to true provides a small performance improvement

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


CurrentLogFileName Property

CurrentLogFileName Property

DicomObjects Namespace > DicomGlobal Class : CurrentLogFileName Property
Returns the Current DicomObjects Log File Name in full.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CurrentLogFileName As String
'Usage

Dim value As String

value = DicomGlobal.CurrentLogFileName
public static string CurrentLogFileName {get;}
public:
static property String^ CurrentLogFileName {
   String^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


DefaultCacheMode Property

DefaultCacheMode Property

DicomObjects Namespace > DicomGlobal Class : DefaultCacheMode Property
Default Cache Mode value used to initialize "CacheMode" property for DicomImage and DicomDataSet. This will be applied to all new instances.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property DefaultCacheMode As CacheTypes
'Usage

Dim value As CacheTypes

DicomGlobal.DefaultCacheMode = value

value = DicomGlobal.DefaultCacheMode
public static CacheTypes DefaultCacheMode {get; set;}
public:
static property CacheTypes DefaultCacheMode {
   CacheTypes get();
   void set (    CacheTypes value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


DefaultCharacterSet Property

DefaultCharacterSet Property

DicomObjects Namespace > DicomGlobal Class : DefaultCharacterSet Property
Default Character to set to use if 0008,0005 is absent
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property DefaultCharacterSet As String
'Usage

Dim value As String

DicomGlobal.DefaultCharacterSet = value

value = DicomGlobal.DefaultCharacterSet
public static string DefaultCharacterSet {get; set;}
public:
static property String^ DefaultCharacterSet {
   String^ get();
   void set (    String^ value);
}
Remarks
The official DICOM rule, if the specific character set (0008,0005) is absent is to use ISO_IR 6 - i.e. just 7 bit US ASCII. This however commonly causes problems since many modality equipment suppliers (especially in Europe & Japan) use extension characters in the range 128-255 but don't bother to include 0008,0005 in their data. This property allows the default to be changed, and the initial value is "ISO_IR 100", which permits and assumes use of European accented characters in the upper range. Fortunately, the lower raneg (0-127) of this character set is identical to US ASCII (ISO_IR 6), so this value does not break compatibility for valid ASCII-only data.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members
Assume2022Escapes Property


DefaultFFmpegFilter Property

DefaultFFmpegFilter Property

DicomObjects Namespace > DicomGlobal Class : DefaultFFmpegFilter Property
Description of the Default filter to apply for FFmpeg processing
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property DefaultFFmpegFilter As String
'Usage

Dim value As String

DicomGlobal.DefaultFFmpegFilter = value

value = DicomGlobal.DefaultFFmpegFilter
public static string DefaultFFmpegFilter {get; set;}
public:
static property String^ DefaultFFmpegFilter {
   String^ get();
   void set (    String^ value);
}
Remarks
For more details please refer to this page "https://ffmpeg.org/ffmpeg-filters.html"
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


DefaultIpAddressFamily Property

DefaultIpAddressFamily Property

DicomObjects Namespace > DicomGlobal Class : DefaultIpAddressFamily Property
The IP Address family to be used where not otherwise specified
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property DefaultIpAddressFamily As AddressFamily
'Usage

Dim value As AddressFamily

DicomGlobal.DefaultIpAddressFamily = value

value = DicomGlobal.DefaultIpAddressFamily
public static AddressFamily DefaultIpAddressFamily {get; set;}
public:
static property AddressFamily DefaultIpAddressFamily {
   AddressFamily get();
   void set (    AddressFamily value);
}
Remarks
The default is System.Net.Sockets.AddressFamily.InterNetwork (IPv4)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


DefaultReadBehaviour Property

DefaultReadBehaviour Property

DicomObjects Namespace > DicomGlobal Class : DefaultReadBehaviour Property
Default behaviour when reading or receiving files
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property DefaultReadBehaviour As ReadBehaviours
'Usage

Dim value As ReadBehaviours

DicomGlobal.DefaultReadBehaviour = value

value = DicomGlobal.DefaultReadBehaviour
public static ReadBehaviours DefaultReadBehaviour {get; set;}
public:
static property ReadBehaviours^ DefaultReadBehaviour {
   ReadBehaviours^ get();
   void set (    ReadBehaviours^ value);
}
Remarks

A new ReadBehaviours object is created for each file operation or association. If this property is non-null, then the new object is a clone of this property, but if this property is null, then a new ReadBehaviours object is created which will, when created, reflect the values of the internal registry at that time

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


DefaultSOPClasses Property

DefaultSOPClasses Property

DicomObjects Namespace > DicomGlobal Class : DefaultSOPClasses Property
Default list of SOP class UID's (Abstract syntaxes) to be used until specifically overridden by user settings
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property DefaultSOPClasses As ReadOnlyCollection(Of String)
'Usage

Dim value As ReadOnlyCollection(Of String)

value = DicomGlobal.DefaultSOPClasses
public static ReadOnlyCollection<string> DefaultSOPClasses {get;}
public:
static property ReadOnlyCollection<String^>^ DefaultSOPClasses {
   ReadOnlyCollection<String^>^ get();
}
Remarks
Returns a copy of the default SOP classes. This may not match the effective SOP classes used if overridden in user code.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


DefaultWriteBehaviour Property

DefaultWriteBehaviour Property

DicomObjects Namespace > DicomGlobal Class : DefaultWriteBehaviour Property
Default behaviour when writing or sending files
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property DefaultWriteBehaviour As WriteBehaviours
'Usage

Dim value As WriteBehaviours

DicomGlobal.DefaultWriteBehaviour = value

value = DicomGlobal.DefaultWriteBehaviour
public static WriteBehaviours DefaultWriteBehaviour {get; set;}
public:
static property WriteBehaviours^ DefaultWriteBehaviour {
   WriteBehaviours^ get();
   void set (    WriteBehaviours^ value);
}
Remarks

A new WriteBehaviours object is created for each file operation or association. If this property is non-null, then the new object is a clone of this property, but if this property is null, then a new WriteBehaviours object is created which will, when created, reflect the values of the internal registry at that time

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


DeidentifyInLog Property

DeidentifyInLog Property

DicomObjects Namespace > DicomGlobal Class : DeidentifyInLog Property
A list of keywords fo attributes which should not be included in any standard log file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property DeidentifyInLog As List(Of Keyword)
'Usage

Dim value As List(Of Keyword)

value = DicomGlobal.DeidentifyInLog
public static List<Keyword> DeidentifyInLog {get;}
public:
static property List<Keyword>^ DeidentifyInLog {
   List<Keyword>^ get();
}
Remarks

Any such attributes will be replaced by either {De-identified} or by the value of DicomGlobal.GetRegString("DeIdentifyText") if that has been set.

It is important to note that this not applies to the individual attributes (as listed in a 3F level log), as a full byte level log will still contain the binary versions of such data

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


DescriptionAsSerializationTag Property

DescriptionAsSerializationTag Property

DicomObjects Namespace > DicomGlobal Class : DescriptionAsSerializationTag Property
To use attribute string description as tag for Json/XML serialization
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property DescriptionAsSerializationTag As Boolean
'Usage

Dim value As Boolean

DicomGlobal.DescriptionAsSerializationTag = value

value = DicomGlobal.DescriptionAsSerializationTag
public static bool DescriptionAsSerializationTag {get; set;}
public:
static property bool DescriptionAsSerializationTag {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


DirectionStrings Property

DirectionStrings Property

DicomObjects Namespace > DicomGlobal Class : DirectionStrings Property
Language specific indicators for anatomic labelling
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property DirectionStrings As String()
'Usage

Dim value() As String

DicomGlobal.DirectionStrings = value

value = DicomGlobal.DirectionStrings
public static string[] DirectionStrings {get; set;}
public:
static property array<String^>^ DirectionStrings {
   array<String^>^ get();
   void set (    array<String^>^ value);
}
Remarks

This property supplies the strings used by all DicomLabels of type Special. The default value is{"R","L","A","P","I","S"} corresponding to the English abbreviations for RIGHT, LEFT, ANTERIOR, POSTERIOR, INFERIOR and SUPERIOR respectively. If you wish to to change this value, please note the following:

  • Exactly 6 values are required (otherwise you will get error message), in the order indicated above.
  • Unicode is fully supported allowing Chinese or other non-western direction indicators.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


DisplayCacheTime Property

DisplayCacheTime Property

DicomObjects Namespace > DicomGlobal Class : DisplayCacheTime Property
Controls how long display cache copies of images are retained.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property DisplayCacheTime As TimeSpan
'Usage

Dim value As TimeSpan

DicomGlobal.DisplayCacheTime = value

value = DicomGlobal.DisplayCacheTime
public static TimeSpan DisplayCacheTime {get; set;}
public:
static property TimeSpan DisplayCacheTime {
   TimeSpan get();
   void set (    TimeSpan value);
}
Remarks
Cached copies of displayed images are discarded after this interval if the memory has not been needed earlier. The default value is 25 seconds.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


Enable10BitDisplay Property

Enable10BitDisplay Property

DicomObjects Namespace > DicomGlobal Class : Enable10BitDisplay Property
To allows support for 10bit data.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property Enable10BitDisplay As Boolean
'Usage

Dim value As Boolean

DicomGlobal.Enable10BitDisplay = value

value = DicomGlobal.Enable10BitDisplay
public static bool Enable10BitDisplay {get; set;}
public:
static property bool Enable10BitDisplay {
   bool get();
   void set (    bool value);
}
Remarks
This is an experimental feature to handle data as 10bit
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


EventLogLevel Property

EventLogLevel Property

DicomObjects Namespace > DicomGlobal Class : EventLogLevel Property
Controls the logging of diagnostic message to the LogEvent event.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property EventLogLevel As LogLevel
'Usage

Dim value As LogLevel

DicomGlobal.EventLogLevel = value

value = DicomGlobal.EventLogLevel
public static LogLevel EventLogLevel {get; set;}
public:
static property LogLevel EventLogLevel {
   LogLevel get();
   void set (    LogLevel value);
}
Remarks
Bit field indicating which levels of activity should be logged. See DicomGlobal.LogToFile for more details.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


FailOnSuspiciousPreamble Property

FailOnSuspiciousPreamble Property

DicomObjects Namespace > DicomGlobal Class : FailOnSuspiciousPreamble Property
Detect any non-zero data in the preamble (the first 128 bytes) leading to 'DICM', and alert if any unwanted bytes or malicious code is present. A pre-defined list of file formats PreambleFileSignatures is used for checking against the non-zero preamble This mainly affects data with such preamble when reading it in. Writing to disk or sending using DICOM protocol would remove existing preamble (effectively cleaning any malicious preamble) and recreate it when written to disk on the receiving side
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property FailOnSuspiciousPreamble As Boolean
'Usage

Dim value As Boolean

DicomGlobal.FailOnSuspiciousPreamble = value

value = DicomGlobal.FailOnSuspiciousPreamble
public static bool FailOnSuspiciousPreamble {get; set;}
public:
static property bool FailOnSuspiciousPreamble {
   bool get();
   void set (    bool value);
}
Remarks
This mainly affects data with such preamble when reading it in. Writing to disk or sending using DICOM protocol would remove existing preamble (effectively cleaning any malicious preamble) and recreate it when written to disk on the receiving side
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


FileVersion Property

FileVersion Property

DicomObjects Namespace > DicomGlobal Class : FileVersion Property
Gets the File Version of DicomObjects.NET
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property FileVersion As String
'Usage

Dim value As String

value = DicomGlobal.FileVersion
public static string FileVersion {get;}
public:
static property String^ FileVersion {
   String^ get();
}
Remarks
This property contains the File Version of the running DicomObjects.NET. This information can be found in the DicomObjects.NET log file.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


FlushLevel Property

FlushLevel Property

DicomObjects Namespace > DicomGlobal Class : FlushLevel Property
A level to cause the log to be flushed to disk
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property FlushLevel As LogLevel
'Usage

Dim value As LogLevel

DicomGlobal.FlushLevel = value

value = DicomGlobal.FlushLevel
public static LogLevel FlushLevel {get; set;}
public:
static property LogLevel FlushLevel {
   LogLevel get();
   void set (    LogLevel value);
}
Remarks
Any log event which has bits which match this property causes the log to be flushed This is useful to ensure that exceptions are flsuhed to disk without slowing normal operations.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


FontScaling Property

FontScaling Property

DicomObjects Namespace > DicomGlobal Class : FontScaling Property
The factor by which to increase the font size when using DirectX display mode. The default is 1.5, which gives appearance similar to those in GDI mode.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property FontScaling As Single
'Usage

Dim value As Single

DicomGlobal.FontScaling = value

value = DicomGlobal.FontScaling
public static float FontScaling {get; set;}
public:
static property float FontScaling {
   float get();
   void set (    float value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


HologicCompressedDataAttributeElements Property

HologicCompressedDataAttributeElements Property

DicomObjects Namespace > DicomGlobal Class : HologicCompressedDataAttributeElements Property
List of attribute elements known to be used by Hologic for their compressed frames used to detect any compressed data in private sequence
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property HologicCompressedDataAttributeElements As List(Of UShort)
'Usage

Dim value As List(Of UShort)

DicomGlobal.HologicCompressedDataAttributeElements = value

value = DicomGlobal.HologicCompressedDataAttributeElements
public static List<ushort> HologicCompressedDataAttributeElements {get; set;}
public:
static property List<ushort>^ HologicCompressedDataAttributeElements {
   List<ushort>^ get();
   void set (    List<ushort>^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


IgnoreShortPixelData Property

IgnoreShortPixelData Property

DicomObjects Namespace > DicomGlobal Class : IgnoreShortPixelData Property
Try to ignore Short pixel data error to suppress read exception. This does not fix any faulty attributes or guarantee the read pixels are correct and complete
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property IgnoreShortPixelData As Boolean
'Usage

Dim value As Boolean

DicomGlobal.IgnoreShortPixelData = value

value = DicomGlobal.IgnoreShortPixelData
public static bool IgnoreShortPixelData {get; set;}
public:
static property bool IgnoreShortPixelData {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


ImplementationName Property (DicomGlobal)

ImplementationName Property (DicomGlobal)

DicomObjects Namespace > DicomGlobal Class : ImplementationName Property
The Implementation Name of this application
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property ImplementationName As String
'Usage

Dim value As String

DicomGlobal.ImplementationName = value

value = DicomGlobal.ImplementationName
public static string ImplementationName {get; set;}
public:
static property String^ ImplementationName {
   String^ get();
   void set (    String^ value);
}
Remarks
This value is used in association negotiation and is put into Part 10 files
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


ImplementationUID Property (DicomGlobal)

ImplementationUID Property (DicomGlobal)

DicomObjects Namespace > DicomGlobal Class : ImplementationUID Property
The Implementation UID of this application
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property ImplementationUID As String
'Usage

Dim value As String

DicomGlobal.ImplementationUID = value

value = DicomGlobal.ImplementationUID
public static string ImplementationUID {get; set;}
public:
static property String^ ImplementationUID {
   String^ get();
   void set (    String^ value);
}
Remarks
This value is used in association negotiation and is put into Part 10 files
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


IndentJson Property

IndentJson Property

DicomObjects Namespace > DicomGlobal Class : IndentJson Property
Controls whether JSON generated is indented and formatted for easy human interpretation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property IndentJson As Boolean
'Usage

Dim value As Boolean

DicomGlobal.IndentJson = value

value = DicomGlobal.IndentJson
public static bool IndentJson {get; set;}
public:
static property bool IndentJson {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


LockGdiOperations Property

LockGdiOperations Property

DicomObjects Namespace > DicomGlobal Class : LockGdiOperations Property
Controls whether to use an explicit lock to prevent recurrent GDI operations from happening
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property LockGdiOperations As Boolean
'Usage

Dim value As Boolean

DicomGlobal.LockGdiOperations = value

value = DicomGlobal.LockGdiOperations
public static bool LockGdiOperations {get; set;}
public:
static property bool LockGdiOperations {
   bool get();
   void set (    bool value);
}
Remarks
This is false by default, as t is believed that these problems have been eliminated, but is left as an option to prevent rare but difficult to reproduce errors when different threads happen to use the GDI sub-system at the same time - e.g. when rendering labels through use of DicomImage.PrinterImage
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


MaximumDateTime Property

MaximumDateTime Property

DicomObjects Namespace > DicomGlobal Class : MaximumDateTime Property
Control the global MaximumDateTime value used by DicomObjects. Default value is DateTime.MaxValue
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property MaximumDateTime As Date
'Usage

Dim value As Date

DicomGlobal.MaximumDateTime = value

value = DicomGlobal.MaximumDateTime
public static DateTime MaximumDateTime {get; set;}
public:
static property DateTime MaximumDateTime {
   DateTime get();
   void set (    DateTime value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


MaximumNesting Property

MaximumNesting Property

DicomObjects Namespace > DicomGlobal Class : MaximumNesting Property
Controls to what level deep are nested Sequences parsed
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property MaximumNesting As Integer
'Usage

Dim value As Integer

DicomGlobal.MaximumNesting = value

value = DicomGlobal.MaximumNesting
public static int MaximumNesting {get; set;}
public:
static property int MaximumNesting {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


MaximumPDUSize Property

MaximumPDUSize Property

DicomObjects Namespace > DicomGlobal Class : MaximumPDUSize Property
The Maximum PDU size accepted and used by DicomObjects
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property MaximumPDUSize As Integer
'Usage

Dim value As Integer

DicomGlobal.MaximumPDUSize = value

value = DicomGlobal.MaximumPDUSize
public static int MaximumPDUSize {get; set;}
public:
static property int MaximumPDUSize {
   int get();
   void set (    int value);
}
Remarks

This corresponds to the old "MaxPDU" registry setting.

The default value is 65536 (64k)

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


MinFontSize Property

MinFontSize Property

DicomObjects Namespace > DicomGlobal Class : MinFontSize Property
Contains the Minimum Font Size used when drawing Text Label.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property MinFontSize As Single
'Usage

Dim value As Single

DicomGlobal.MinFontSize = value

value = DicomGlobal.MinFontSize
public static float MinFontSize {get; set;}
public:
static property float MinFontSize {
   float get();
   void set (    float value);
}
Remarks
Default value is 8.0F.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


MinimumDateTime Property

MinimumDateTime Property

DicomObjects Namespace > DicomGlobal Class : MinimumDateTime Property
Control the global MinimumDateTime value used by DicomObjects. Default value is DateTime.MinValue
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property MinimumDateTime As Date
'Usage

Dim value As Date

DicomGlobal.MinimumDateTime = value

value = DicomGlobal.MinimumDateTime
public static DateTime MinimumDateTime {get; set;}
public:
static property DateTime MinimumDateTime {
   DateTime get();
   void set (    DateTime value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


MoveTimesOut Property

MoveTimesOut Property

DicomObjects Namespace > DicomGlobal Class : MoveTimesOut Property
Controls whether DicomObjects will time out during a C-MOVE operation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property MoveTimesOut As Boolean
'Usage

Dim value As Boolean

DicomGlobal.MoveTimesOut = value

value = DicomGlobal.MoveTimesOut
public static bool MoveTimesOut {get; set;}
public:
static property bool MoveTimesOut {
   bool get();
   void set (    bool value);
}
Remarks

This is unlikely to be needed with "good" SCPs which return regular status updates to the C-MOVE SCU, but is needed when getting many images (particularly over slow connections) from SCPs which do not send such notifications

This corresponds to the old "MoveTimesOut" registry setting.

The default value is true

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


PreambleFileSignatures Property

PreambleFileSignatures Property

DicomObjects Namespace > DicomGlobal Class : PreambleFileSignatures Property
A pre-defined modifiable list of file signatures to match against the preamble if FailOnSuspiciousPreamble is enabled
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property PreambleFileSignatures As List(Of FileSignature)
'Usage

Dim value As List(Of FileSignature)

DicomGlobal.PreambleFileSignatures = value

value = DicomGlobal.PreambleFileSignatures
public static List<FileSignature> PreambleFileSignatures {get; set;}
public:
static property List<FileSignature^>^ PreambleFileSignatures {
   List<FileSignature^>^ get();
   void set (    List<FileSignature^>^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


PreferredBitmapMode Property

PreferredBitmapMode Property

DicomObjects Namespace > DicomGlobal Class : PreferredBitmapMode Property
Controls method of rendering used by "Bitmap"
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property PreferredBitmapMode As ViewerMode
'Usage

Dim value As ViewerMode

DicomGlobal.PreferredBitmapMode = value

value = DicomGlobal.PreferredBitmapMode
public static ViewerMode PreferredBitmapMode {get; set;}
public:
static property ViewerMode PreferredBitmapMode {
   ViewerMode get();
   void set (    ViewerMode value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


PresentationStateFont Property

PresentationStateFont Property

DicomObjects Namespace > DicomGlobal Class : PresentationStateFont Property
The font to be used for internally generated DicomLabel objects derived from Presentation States
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property PresentationStateFont As Font
'Usage

Dim value As Font

DicomGlobal.PresentationStateFont = value

value = DicomGlobal.PresentationStateFont
public static Font PresentationStateFont {get; set;}
public:
static property Font^ PresentationStateFont {
   Font^ get();
   void set (    Font^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


PreserveDoublePrecision Property

PreserveDoublePrecision Property

DicomObjects Namespace > DicomGlobal Class : PreserveDoublePrecision Property
Retain precision for double numbers
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property PreserveDoublePrecision As Boolean
'Usage

Dim value As Boolean

DicomGlobal.PreserveDoublePrecision = value

value = DicomGlobal.PreserveDoublePrecision
public static bool PreserveDoublePrecision {get; set;}
public:
static property bool PreserveDoublePrecision {
   bool get();
   void set (    bool value);
}
Remarks
To control floating value precision when adding attributes with double values
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


ProductName Property

ProductName Property

DicomObjects Namespace > DicomGlobal Class : ProductName Property
The product name to be shown in licensing Dialogs etc. Default value is "DicomObjects".
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property ProductName As String
'Usage

Dim value As String

DicomGlobal.ProductName = value

value = DicomGlobal.ProductName
public static string ProductName {get; set;}
public:
static property String^ ProductName {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


QuadrupedDirectionStrings Property

QuadrupedDirectionStrings Property

DicomObjects Namespace > DicomGlobal Class : QuadrupedDirectionStrings Property
The quadruped equivalent of DirectionStrings allowing localisation of these abbreviations
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property QuadrupedDirectionStrings As String()
'Usage

Dim value() As String

DicomGlobal.QuadrupedDirectionStrings = value

value = DicomGlobal.QuadrupedDirectionStrings
public static string[] QuadrupedDirectionStrings {get; set;}
public:
static property array<String^>^ QuadrupedDirectionStrings {
   array<String^>^ get();
   void set (    array<String^>^ value);
}
Remarks

Exactly 14 values are required (otherwise you will get error message), in the order indicated below.

Unicode is fully supported allowing Chinese or other non-western direction indicators.

  • Le: Left
  • Rt: Right
  • Pr: Proximal
  • Di: Distal
  • Pa:
  • Pl:
  • Cr: Cranial
  • Cd: Caudal (opposite of cranial)
  • D : Dorsal
  • V : Ventral
  • R : Rostral
  • Cd: Caudal (opposite of rostral)
  • M : Medial
  • L : Laeral
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


RenderException Property

RenderException Property

DicomObjects Namespace > DicomGlobal Class : RenderException Property
Controls whether non-image objects throw an exception during rendering
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property RenderException As Boolean
'Usage

Dim value As Boolean

DicomGlobal.RenderException = value

value = DicomGlobal.RenderException
public static bool RenderException {get; set;}
public:
static property bool RenderException {
   bool get();
   void set (    bool value);
}
Remarks
If true, then attempts to display or otherwise render images without the required attributes (e.g. structured reports) will throw an exception. If false (default value), then such attempts merely result in a blank output.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


ReUseArrays Property

ReUseArrays Property

DicomObjects Namespace > DicomGlobal Class : ReUseArrays Property
Controls whether DicomObjcts re-uses arrays to hold pixel data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property ReUseArrays As Boolean
'Usage

Dim value As Boolean

DicomGlobal.ReUseArrays = value

value = DicomGlobal.ReUseArrays
public static bool ReUseArrays {get; set;}
public:
static property bool ReUseArrays {
   bool get();
   void set (    bool value);
}
Remarks

Whilst the approach to array allocation pushed by Microsoft is "don't worry about it, just leave all memory management to the garbage collector", the reality is very different, and in practice, especially for "large" objects (>85kbytes - small by pixel standards)fragmentation can occur after prolonged use, leading to performance issues and even, on some systems, memory allocation failure, even when sufficient total memory should be available.

As of V8 therefore, DicomObjects attempts to "re-use" pixel arrays where possible, which it does by intercepting their release, and then adding them to a cache list, from which new allocations can be made if an array of sufficient (including possibly larger) size is available. The use of over-sized arrays can be prvented by use of the ReuseOnlyExactArraySize property.

If this property is set to false, then arrays are not re-used at all.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


ReuseOnlyExactArraySize Property

ReuseOnlyExactArraySize Property

DicomObjects Namespace > DicomGlobal Class : ReuseOnlyExactArraySize Property
Controls whether "Over-sized" arrays are used
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property ReuseOnlyExactArraySize As Boolean
'Usage

Dim value As Boolean

DicomGlobal.ReuseOnlyExactArraySize = value

value = DicomGlobal.ReuseOnlyExactArraySize
public static bool ReuseOnlyExactArraySize {get; set;}
public:
static property bool ReuseOnlyExactArraySize {
   bool get();
   void set (    bool value);
}
Remarks

DicomObjects attempts where possible to re-user arrays to hold pixel data, as this reduces fragmentation of the Large Object Heap. (see ReUseArrays for more details).

If this property is false (the default) then the smallest array available for re-use which is either the right size or larger than the required size is used, but if this is false, then only an exactly sized array is accepted (and a new array is allocated if an exactly sized array is not available).
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


ShowTextBoxForPresentationStates Property

ShowTextBoxForPresentationStates Property

DicomObjects Namespace > DicomGlobal Class : ShowTextBoxForPresentationStates Property
Controls whether bounding boxes are drawn around internally generated DicomLabel objects derived from text entries in Presentation States
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property ShowTextBoxForPresentationStates As Boolean
'Usage

Dim value As Boolean

DicomGlobal.ShowTextBoxForPresentationStates = value

value = DicomGlobal.ShowTextBoxForPresentationStates
public static bool ShowTextBoxForPresentationStates {get; set;}
public:
static property bool ShowTextBoxForPresentationStates {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


SigningLicensePrefix Property

SigningLicensePrefix Property

DicomObjects Namespace > DicomGlobal Class : SigningLicensePrefix Property
Set to tell DicomObjects to check the exe.{Prefix}.lic, instead of default exe.lic file
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property SigningLicensePrefix As String
'Usage

Dim value As String

DicomGlobal.SigningLicensePrefix = value

value = DicomGlobal.SigningLicensePrefix
public static string SigningLicensePrefix {get; set;}
public:
static property String^ SigningLicensePrefix {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


ThreadCount Property

ThreadCount Property

DicomObjects Namespace > DicomGlobal Class : ThreadCount Property
Controls how many threads may be used by DicomObjects when rendering etc.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property ThreadCount As Integer
'Usage

Dim value As Integer

DicomGlobal.ThreadCount = value

value = DicomGlobal.ThreadCount
public static int ThreadCount {get; set;}
public:
static property int ThreadCount {
   int get();
   void set (    int value);
}
Remarks
The default value is the number of procesors on the system. Setting to 1 disables the multi-threading rendering support.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


Timeout Property

Timeout Property

DicomObjects Namespace > DicomGlobal Class : Timeout Property
The period of time that a network operation will wait if there is no response from the peer
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property Timeout As Integer
'Usage

Dim value As Integer

DicomGlobal.Timeout = value

value = DicomGlobal.Timeout
public static int Timeout {get; set;}
public:
static property int Timeout {
   int get();
   void set (    int value);
}
Remarks

The default value is 60 (seconds)

This corresponds to the old "Timeout" registry setting.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


UIDRoot Property

UIDRoot Property

DicomObjects Namespace > DicomGlobal Class : UIDRoot Property
UIDRoot used by the NewUID method
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property UIDRoot As String
'Usage

Dim value As String

DicomGlobal.UIDRoot = value

value = DicomGlobal.UIDRoot
public static string UIDRoot {get; set;}
public:
static property String^ UIDRoot {
   String^ get();
   void set (    String^ value);
}
Remarks

If not set explicitly, then a "statistically unique" (i.e. not guaranteed) UID generation technique is used instead

This corresponds to the old "UIDRoot" registry setting.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


UsePerformanceCounters Property

UsePerformanceCounters Property

DicomObjects Namespace > DicomGlobal Class : UsePerformanceCounters Property
Controls use of specific performance counters for DicomObjects
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property UsePerformanceCounters As Boolean
'Usage

Dim value As Boolean

DicomGlobal.UsePerformanceCounters = value

value = DicomGlobal.UsePerformanceCounters
public static bool UsePerformanceCounters {get; set;}
public:
static property bool UsePerformanceCounters {
   bool get();
   void set (    bool value);
}
Remarks
These are only designed for specialist diagnostic use, and this should only be set to true on request from Medical Connections support.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


UsePixelCache Property

UsePixelCache Property

DicomObjects Namespace > DicomGlobal Class : UsePixelCache Property
Controls whether to use an area of memory as a pixel cache to reduce demands on the memory allocator
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property UsePixelCache As Boolean
'Usage

Dim value As Boolean

DicomGlobal.UsePixelCache = value

value = DicomGlobal.UsePixelCache
public static bool UsePixelCache {get; set;}
public:
static property bool UsePixelCache {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


ValidDateMax Property

ValidDateMax Property

DicomObjects Namespace > DicomGlobal Class : ValidDateMax Property
Maximum allowed DateTime for validation purposes Default value is DateTime.MaxValue
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property ValidDateMax As Date
'Usage

Dim value As Date

DicomGlobal.ValidDateMax = value

value = DicomGlobal.ValidDateMax
public static DateTime ValidDateMax {get; set;}
public:
static property DateTime ValidDateMax {
   DateTime get();
   void set (    DateTime value);
}
Remarks
Default value is DateTime.MaxValue
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


ValidDateMin Property

ValidDateMin Property

DicomObjects Namespace > DicomGlobal Class : ValidDateMin Property
Minimum allowed DateTime for validation purposes Default value is DateTime.MinValue
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property ValidDateMin As Date
'Usage

Dim value As Date

DicomGlobal.ValidDateMin = value

value = DicomGlobal.ValidDateMin
public static DateTime ValidDateMin {get; set;}
public:
static property DateTime ValidDateMin {
   DateTime get();
   void set (    DateTime value);
}
Remarks
Default value is DateTime.MinValue
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


DicomGlobal Class Events

DicomGlobal Class Events

DicomObjects Namespace : DicomGlobal Class

For a list of all members of this type, see DicomGlobal members.

Public Events
 | Name | Description
Public Event | LogEvent | Event fires when loggable events occur
Public Event | OnChangeUid | Event fired when DicomObjects should change a UID for an object
Public Event | ValidateFragments | Routine to allow validation (and if necessary, correction) of fragments of compressed pixel data
Top
See Also

Reference

DicomGlobal Class
DicomObjects Namespace


LogEvent Event

LogEvent Event

DicomObjects Namespace > DicomGlobal Class : LogEvent Event
Event fires when loggable events occur
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event LogEvent As LogHandler
'Usage

Dim instance As DicomGlobal
Dim handler As LogHandler

AddHandler instance.LogEvent, handler
public event LogHandler LogEvent
public:
event LogHandler^ LogEvent
Remarks
The types of events are controlled by the EventLogLevel property
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


OnChangeUid Event

OnChangeUid Event

DicomObjects Namespace > DicomGlobal Class : OnChangeUid Event
Event fired when DicomObjects should change a UID for an object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event OnChangeUid As ChangeUidHandler
'Usage

Dim instance As DicomGlobal
Dim handler As ChangeUidHandler

AddHandler instance.OnChangeUid, handler
public event ChangeUidHandler OnChangeUid
public:
event ChangeUidHandler^ OnChangeUid
Remarks
This event allows developers to see the old and new UIDs in circumstances where UIDs should be changed, allowing the default bahaviour and new UID to be overridden
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


ValidateFragments Event

ValidateFragments Event

DicomObjects Namespace > DicomGlobal Class : ValidateFragments Event
Routine to allow validation (and if necessary, correction) of fragments of compressed pixel data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event ValidateFragments As Action(Of ValidateFragmentsArgs)
'Usage

Dim instance As DicomGlobal
Dim handler As Action(Of ValidateFragmentsArgs)

AddHandler instance.ValidateFragments, handler
public event Action<ValidateFragmentsArgs> ValidateFragments
public:
event Action<ValidateFragmentsArgs^>^ ValidateFragments
Remarks

This is called whenever compressed pixel data read/received, including compressedpixel data within a sequence.

CloseFilesAfterReading must be set to true if hooking this event.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomGlobal Class
DicomGlobal Members


DicomImage Class

DicomImage Class
Members

DicomObjects Namespace : DicomImage Class
Class representing a DICOM Image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomImage
'Usage

Dim instance As DicomImage
public class DicomImage
public ref class DicomImage
Remarks

Each DicomImage object corresponds to one SOP instance, and for display, DicomImages are commonly held within a DicomImages collection.

In general, a DicomImage is a utility wrapper around a DicomDataSet to help accomplish the Image viewing-related tasks, like zooming, scrolling, flipping, rotating, windowing etc.

A DicomImage references a DicomDataSet ( DataSet property ), which also contains the attributes, the distinction being that a DicomImage contains pixel data, and is therefore displayable within a DicomViewer control, whereas a DicomDataSet may or may not contain pixel data, and is not displayable. The different properties and methods reflect this difference.

A DicomImage object can be constructed directly from a file, stream or byte array

Inheritance Hierarchy

System.Object
DicomObjects.DicomImage
DicomObjects.DicomImage3D
DicomObjects.DicomImageCurvedMPR
DicomObjects.DicomImageFusion

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Members
DicomObjects Namespace


DicomImage Class Members

DicomImage Class Members
Properties Methods Events

DicomObjects Namespace : DicomImage Class

The following tables list the members exposed by DicomImage.

Public Constructors
 | Name | Description
Public Constructor | DicomImage Constructor | Overloaded. Creates a blank DicomImage object
Top
Public Properties
 | Name | Description
Public Property | AccessionNumber | The Accession Number
Public Property | Angle | Controls the rotation of an image
Public Property | Area | The display area of DicomImage
Public Property | BorderPen | The Pen object for Image border
Public Property | CacheMode | Controls how the pixel data is cached
Public Property | CaptureBackColour | User defined background colour for image output of PrinterImage, Bitmap and SubImage methods Default is Black background
Public Property | CDAStyleSheet | Style sheet used for displaying encapsulated CDA
Public Property | CineFramesToDisplay | The set of frames to display for cine modes
Public Property | CineIndex | The index of the currently displayed frame when using CineMode
Public Property | CineMode | Enumerated running modes for multi-frame image
Public Property | CineRate | Controls the speed of autonomous cine runs
Public Property | CineSmoothing | Boolean property indicating whether Smoothing is applied when Cine is being displayed.
Public Property | ColourTable | The colour lookup table of DicomImage
Public Property | CubicSplineAlpha | Parameter to control the degree of smoothing. The default value is �0.75, and normal values range from �0.5 to �1.25, though higher negative values may be used to produce deliberate edge enhancement.
Public Property | DataSet | The underlying DICOM Dataset containing persistent data for the image
Public Property | DateOfBirth | Date of birth of the patient
static (Shared in Visual Basic) | DefaultModalityLUT | Default value for the ModalityLUT property
static (Shared in Visual Basic) | DefaultPresentationLUT | Default value for the PresentationLUT property
static (Shared in Visual Basic) | DefaultRealTimeCine | Controls the default for how cine images are displayed
static (Shared in Visual Basic) | DefaultVoiLUT | Default value for the VoiLUT property
Public Property | DisplayMode | Controls how the image is rendered internal before transfer to the screen
Public Property | DrawCacheMode | Specify the DrawCacheMode to control how image is drawn/cached
Public Property | ExplicitModalityLUT | An explicit modality Lookup Table to be used in place of one specified in the image or presentaiton state.
Public Property | ExplicitPresentationLUT | An explicit presentation Lookup Table to be used in place of one specified in the image or presentaiton state.
Public Property | ExplicitVOILUT | An explicit Values of Interest (VOI) Lookup Table to be used in place of one specified in the image or presentaiton state.
Public Property | FilterLength | Contains the length of the smoothing filter
Public Property | FlipState | The flip state of the image, allowing the orientation of the image, as displayed, to be altered
Public Property | Frame | Controls which frame of a multi-frame image is displayed
Public Property | FrameCount | The number of frames contained in a multi-frame image
Public Property | Gamma | A number that specifies a power
Public Property | InstanceUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Invert | Controls whether the Image will be inverted.
Public Property | Item | Overloaded. Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
static (Shared in Visual Basic) | JpipInitialSize | The size of the first request (in bytes) to make to a JPIP server.
Public Property | JpipRequestSize | The size of the requests other than the first (in bytes) to make to a JPIP server.
Public Property | Labels | Provides access to the DicomLabelCollection, items of which are to be displayed over an image.
Public Property | Level | The Window Level (also known as the centre) - which controls the greyscale mapping of a displayed image
Public Property | LevelShift | Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping
Public Property | MagnificationMode | Controls how pixels are interpolated when the image is magnified
Public Property | MaskRanges | Contains an array of DicomMaskRange objects to be applied to this image. See the DicomMaskRange object for more information on how this is used.
Public Property | MinificationMode | Controls how pixels are interpolated when the image is minified
Public Property | ModalityLUT | Enables or disables the Modality Lookup Table to be used in the DicomImage
Public Property | Name | The Name of the patient
Public Property | OriginalTs | Original Transfer syntax of the underlying DataSet
Public Property | OverlayColour | Controls how overlays embedded in the image are displayed
Public Property | OverlayVisible | Controls whether overlays embedded in the image are displayed
Public Property | PatientID | The Patient ID
Public Property | Pixels | Accesses the raw pixel data as a typed array
Public Property | PresentationLUT | Enables or disables the Presentation Lookup Table to be used in the DicomImage
Public Property | PresentationState | Support for DICOM greyscale presentation state
Public Property | PresentationStateFeaturesUsed | The presentation state features to use
Public Property | PresentationStates | Support for a list of DICOM greyscale presentation state
Public Property | RawPixels | Accesses the raw pixel data as an array
Public Property | RealTimeCine | Controls how cine images are displayed
Public Property | RenderedSize | Returns the Image display size in output (normally screen) coordinates
Public Property | RotateState | The rotation state of the image, allowing the orientation of the image, as displayed, to be altered
Public Property | RotationBehaviour | Controls the baseline positioning of an image which is not stretched to fit and is rotated
Public Property | Scroll | Controls the positioning of an image display
Public Property | SeriesDescription | Descriptions for the series
Public Property | SeriesUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Sex | Sex of the patient
Public Property | ShowLabels | Controls whether the image�s labels (annotations) are shown on screen
Public Property | ShowShutter | Controls whether image shutters (if specified in the image) are used.
Public Property | ShowUpdates | Controls whether the images is updated when image display parameters change
Public Property | Size | The dimensions of the image
Public Property | SOPClass | SOP class of the DicomDataSet.
Public Property | StretchMode | Controls the automatic zooming of an image.
Public Property | StudyDescription | Description for the study
Public Property | StudyUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Tag | A general purpose Tag for developer use
Public Property | UnsharpEnhancement | UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement
Public Property | UnsharpLength | UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement
Public Property | UserMatrix | Means to override the matrix used to display 2D images
Public Property | VoiLUT | The VOI Lookup Table to be used to display the DicomImage
Public Property | VOILUTFunction | Controls which VOILUT function to be used, default value is Linear
Public Property | VoiLUTInUse | Indicates whether a Values of Interest Lookup Table is in use
Public Property | Width | The Window "Width" - which controls the greyscale mapping of a displayed image
Public Property | WidthMultiplier | Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping
Public Property | Zoom | Controls the magnification of an image display
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Creates and adds standard data elements to the underlying DicomDataSet
Public Method | AddByReference | Overloaded. Add byte[] as attribute value to avoid copying large data
Public Method | Bitmap | Overloaded. Creates a Bitmap object from DicomImage
Public Method | BitmapImage | Image rendered as a System.Windows.Media.Imaging.BitmapImage object
Public Method | Blt | Combine pixel data of source image into this image as a base image
Public Method | BurnAnnotations | Burn all image Labels in Pixel data. This method modifies the underlying pixel data!
Public Method | CanConvertTo | Useful method to check if the image can be converted using a different compression specified by the TransferSyntax
Public Method | CellLocation | The location of the top-left corner of the cell within which this image would be displayed in a particular viewer
Public Method | CellSize | The size of the cell within which this image would be displayed in a particular viewer
Public Method | ChangeToDecompressed | Simulate the effect of writing out as a Decompressed Image
Public Method | ClearCaches | Overloaded. Clears the internal cache for compressed and uncompressed pixel data, lookup data and DirectX textures
Public Method | Clone | Overloaded. Returns a cloned copy of the DicomImage
Public Method | Copy | Copies the image to the Windows clipboard
Public Method | CurrentToNoStretch | This method modifies the StretchMode, Zoom and Scroll properties such that the display output stays very similar while the display parameters have changed to suit the DicomObjects.Enums.StretchModes.NoStretch mode.
Public Method | CurrentToPresentationState | Overloaded. Encapsulate current display properties into a DICOM GreyScale Presentation State object
Public Method | DecompressAll | Causes all the frames of an image to be decompressed.
Public Method | DisplaySize | Overloaded. Methods to determine the size at which am image would be shown
Public Method | Dispose | Releases the resources used by the DicomImage object This does not dispose the underlying DicomDataSet object which is DataSet, an explicit Dispose call will be needed to have that effect
Public Method | DistanceFromPoint | Perpendicular distance from a Point to the plane of this image
Public Method | DownloadStatus | Overloaded. Methods to determine the degree to which part of an image has already been downloaded
Public Method | ExplicitJpipRequest | Overloaded. Explicitly request that some of the pixel information for this image should be retrieved via JPIP
Public Method | Export | Overloaded. Export image to non-DICOM format
Public Method | GetCacheSize | Get cache size used by DicomObjects for the image - useful to help decide when to call ClearCaches method
Public Method | GetMinAndMax | Overloaded. Find the maximum and minimum pixel data values in the pixel data
Public Method | GetRawFrame | Extract individual frame from the pixel data
Public Method | Histogram | Returns an array containing the distribution of raw pixel values.
Public Method | ImagePlane | The currently displayed plane of this image.
Public Method | ImageToScreen | Calculate where in screen (X,Y) space, a given image point lies
Public Method | ImageToWorld | Calculate the real-world 3D coordinates of a point of the image currently displayed
Public Method | Import | Overloaded. Copies the image data from an external image format
Public Method | Matrix | Overloaded. Matrix specifying how the image is displayed
Public Method | MatrixBase | Matrix specifying how the image would be displayed with a Zoom of 1:1
Public Method | OrientationText | Return the Text of DicomLabel of LabelType = special.
Public Method | Paste | Copies the Image Data from Windows Clipboard
Public Method | PixelValuesByFrame | Returns an array of pixel values for a frame, optionally transformed via the modality transformation
Public Method | PresentationStateToCurrent | Overloaded. Modifies current display properties to match the DICOM presentation state.
Public Method | PrinterImage | Overloaded. Creates a copy of the image for printing or other purposes
Public Method | RawPixelValuesByFrame | Returns an array of raw pixel values for a frame
Public Method | Read | Overloaded. Read from a file, a system IO stream or a byte array
Public Method | ReadURL | Reads from Web Address
Public Method | ReferenceLine | This method returns a new DicomLabel object which represents the position of one DicomImage relative to another.
Public Method | RenderToArray | Overloaded. Render the DicomImage to array.
Public Method | ScreenToImage | Calculate where in image (X,Y) space, a given screen point lies
Public Method | ScreenToWorld | Calculate where in real world (X,Y,Z) space, a given screen point lies
Public Method | Send | Overloaded. Sends an image to a remote Storage SCP
Public Method | SetDefaultWindows | Recalculates the default windows used by DicomObjects as if the image had just been loaded
Public Method | SetExternalShader | An external DirectX pixel shader to be used for custom filtering
Public Method | SetPixelData | Method to set pixel data directly from a stream
Public Method | SetPixelDataAndImport | Method to import pixel data directly from a non-DICOM data
Public Method | SetPixelFile | Maps an external file as the pixel data
Public Method | SetScrollAndZoom | Sets the Scroll and Zoom values to values reflecting the current display
Public Method | SetSimpleMasking | Overloaded. Sets the frame number of the mask frame for subtraction.
Public Method | Spacing | Overloaded. Get the pixel spacing of the DicomImage
Public Method | SpacingInViewer | This method returns the Pixel Spacing within the region specified by Area, in a particular viewer
Public Method | SubImage | Overloaded. Creates a copy of part or all of the image
Public Method | Update | Causes the image to be updated
Public Method | WorldToImage | Calculate the nearest image coordinates for a point in real world (X,Y,Z) space,
Public Method | WorldToScreen | Calculate where in real world (X,Y,Z) space, a given screen point lies
Public Method | Write | Overloaded. Write the data to a file, Stream or Byte Array
Top
Public Events
 | Name | Description
Public Event | PositionChanged | An event which fires when the plane displayed by this image changes.
Public Event | UserSmoothing | Setting this event enables a developer to specify his own smoothing algorithm.
Top
Public Operators
public Operator Implicit Type Conversion Implicit DicomImage to DicomDataSet cast
Top
See Also

Reference

DicomImage Class
DicomObjects Namespace


DicomImage Constructor

DicomImage Constructor

DicomObjects Namespace > DicomImage Class : DicomImage Constructor
Creates a blank DicomImage object
Overload List
Overload | Description
DicomImage Constructor() | Creates a new DicomImage with an empty Dataset
DicomImage Constructor(Bitmap) | Creates a new DicomImage from a Windows Bitmap
DicomImage Constructor(DicomImage) | Creates a new DicomImage from an existing DicomImage
DicomImage Constructor(String,ReadBehaviours) | Creates a new DicomImage from an external DICOM file
DicomImage Constructor(Stream,ReadBehaviours) | Reads a stream into a new DicomImage
DicomImage Constructor(Byte[],ReadBehaviours) | Reads an array of bytes into a new DicomImage
DicomImage Constructor(DicomDataSet) | Creates a new DicomImage from an existing DicomDataSet
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


DicomImage Constructor()

DicomImage Constructor()

DicomObjects Namespace > DicomImage Class > DicomImage Constructor : DicomImage Constructor()
Creates a new DicomImage with an empty Dataset
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DicomImage()
public DicomImage()
public:
DicomImage();

Return Value

DicomImage
Remarks
A direct constructor of DicomImage object.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


DicomImage Constructor(Bitmap)

DicomImage Constructor(Bitmap)

DicomObjects Namespace > DicomImage Class > DicomImage Constructor : DicomImage Constructor(Bitmap)

The Bitmap Image from which the new DicomImage is created

Creates a new DicomImage from a Windows Bitmap
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal Bitmap As Bitmap _
)
'Usage

Dim Bitmap As Bitmap

Dim instance As New DicomImage(Bitmap)
public DicomImage(
   Bitmap Bitmap
)
public:
DicomImage(
   Bitmap^ Bitmap
)

Parameters

Bitmap

The Bitmap Image from which the new DicomImage is created

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


DicomImage Constructor(DicomImage)

DicomImage Constructor(DicomImage)

DicomObjects Namespace > DicomImage Class > DicomImage Constructor : DicomImage Constructor(DicomImage)

The existing Image to create the new image from

Creates a new DicomImage from an existing DicomImage
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal img As DicomImage _
)
'Usage

Dim img As DicomImage

Dim instance As New DicomImage(img)
public DicomImage(
   DicomImage img
)
public:
DicomImage(
   DicomImage^ img
)

Parameters

img

The existing Image to create the new image from

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


DicomImage Constructor(String,ReadBehaviours)

DicomImage Constructor(String,ReadBehaviours)

DicomObjects Namespace > DicomImage Class > DicomImage Constructor : DicomImage Constructor(String,ReadBehaviours)

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container's responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

The behaviours to be used when reading this stream

Creates a new DicomImage from an external DICOM file
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal FileName As String, _
   Optional ByVal ReadBehaviour As ReadBehaviours _
)
'Usage

Dim FileName As String
Dim ReadBehaviour As ReadBehaviours

Dim instance As New DicomImage(FileName, ReadBehaviour)
public DicomImage(
   string FileName,
   ReadBehaviours ReadBehaviour
)
public:
DicomImage(
   String^ FileName,
   ReadBehaviours^ ReadBehaviour
)

Parameters

FileName

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container's responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

ReadBehaviour

The behaviours to be used when reading this stream

Return Value

DicomImage
Remarks
A direct constructor of DicomImage. Reads an external DICOM file to create a new DicomImage object.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


DicomImage Constructor(Stream,ReadBehaviours)

DicomImage Constructor(Stream,ReadBehaviours)

DicomObjects Namespace > DicomImage Class > DicomImage Constructor : DicomImage Constructor(Stream,ReadBehaviours)

The Stream from which to read.

The behaviours to be used when reading this stream

Reads a stream into a new DicomImage
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal Stream As Stream, _
   Optional ByVal ReadBehaviour As ReadBehaviours _
)
'Usage

Dim Stream As Stream
Dim ReadBehaviour As ReadBehaviours

Dim instance As New DicomImage(Stream, ReadBehaviour)
public DicomImage(
   Stream Stream,
   ReadBehaviours ReadBehaviour
)
public:
DicomImage(
   Stream^ Stream,
   ReadBehaviours^ ReadBehaviour
)

Parameters

Stream

The Stream from which to read.

ReadBehaviour

The behaviours to be used when reading this stream

Return Value

DicomImage
Remarks

A direct constructor of DicomImage. This method can read streams in either official "Part10" format, with the 128 byte header, or unofficial "Part5" format, without a header. Detection of the type is automatic.

The stream may have been written by the Write method or by other DICOM software.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


DicomImage Constructor(Byte[],ReadBehaviours)

DicomImage Constructor(Byte[],ReadBehaviours)

DicomObjects Namespace > DicomImage Class > DicomImage Constructor : DicomImage Constructor(Byte[],ReadBehaviours)

Array of bytes to read

The behaviours to be used when reading this stream

Reads an array of bytes into a new DicomImage
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal Array() As Byte, _
   Optional ByVal ReadBehaviour As ReadBehaviours _
)
'Usage

Dim Array() As Byte
Dim ReadBehaviour As ReadBehaviours

Dim instance As New DicomImage(Array, ReadBehaviour)
public DicomImage(
   byte[] Array,
   ReadBehaviours ReadBehaviour
)
public:
DicomImage(
   array<byte>^ Array,
   ReadBehaviours^ ReadBehaviour
)

Parameters

Array

Array of bytes to read

ReadBehaviour

The behaviours to be used when reading this stream

Return Value

DicomImage
Remarks
A direct constructor of DicomImage. Reads a byte array to create a new DicomImage object.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


DicomImage Constructor(DicomDataSet)

DicomImage Constructor(DicomDataSet)

DicomObjects Namespace > DicomImage Class > DicomImage Constructor : DicomImage Constructor(DicomDataSet)

The DataSet to read

Creates a new DicomImage from an existing DicomDataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal Data As DicomDataSet _
)
'Usage

Dim Data As DicomDataSet

Dim instance As New DicomImage(Data)
public DicomImage(
   DicomDataSet Data
)
public:
DicomImage(
   DicomDataSet^ Data
)

Parameters

Data

The DataSet to read

Return Value

DicomImage
Remarks
A direct constructor of DicomImage. Reads a DicomDataSet to create a new DicomImage object.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


DicomImage Class Methods

DicomImage Class Methods

DicomObjects Namespace : DicomImage Class

For a list of all members of this type, see DicomImage members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Creates and adds standard data elements to the underlying DicomDataSet
Public Method | AddByReference | Overloaded. Add byte[] as attribute value to avoid copying large data
Public Method | Bitmap | Overloaded. Creates a Bitmap object from DicomImage
Public Method | BitmapImage | Image rendered as a System.Windows.Media.Imaging.BitmapImage object
Public Method | Blt | Combine pixel data of source image into this image as a base image
Public Method | BurnAnnotations | Burn all image Labels in Pixel data. This method modifies the underlying pixel data!
Public Method | CanConvertTo | Useful method to check if the image can be converted using a different compression specified by the TransferSyntax
Public Method | CellLocation | The location of the top-left corner of the cell within which this image would be displayed in a particular viewer
Public Method | CellSize | The size of the cell within which this image would be displayed in a particular viewer
Public Method | ChangeToDecompressed | Simulate the effect of writing out as a Decompressed Image
Public Method | ClearCaches | Overloaded. Clears the internal cache for compressed and uncompressed pixel data, lookup data and DirectX textures
Public Method | Clone | Overloaded. Returns a cloned copy of the DicomImage
Public Method | Copy | Copies the image to the Windows clipboard
Public Method | CurrentToNoStretch | This method modifies the StretchMode, Zoom and Scroll properties such that the display output stays very similar while the display parameters have changed to suit the DicomObjects.Enums.StretchModes.NoStretch mode.
Public Method | CurrentToPresentationState | Overloaded. Encapsulate current display properties into a DICOM GreyScale Presentation State object
Public Method | DecompressAll | Causes all the frames of an image to be decompressed.
Public Method | DisplaySize | Overloaded. Methods to determine the size at which am image would be shown
Public Method | Dispose | Releases the resources used by the DicomImage object This does not dispose the underlying DicomDataSet object which is DataSet, an explicit Dispose call will be needed to have that effect
Public Method | DistanceFromPoint | Perpendicular distance from a Point to the plane of this image
Public Method | DownloadStatus | Overloaded. Methods to determine the degree to which part of an image has already been downloaded
Public Method | ExplicitJpipRequest | Overloaded. Explicitly request that some of the pixel information for this image should be retrieved via JPIP
Public Method | Export | Overloaded. Export image to non-DICOM format
Public Method | GetCacheSize | Get cache size used by DicomObjects for the image - useful to help decide when to call ClearCaches method
Public Method | GetMinAndMax | Overloaded. Find the maximum and minimum pixel data values in the pixel data
Public Method | GetRawFrame | Extract individual frame from the pixel data
Public Method | Histogram | Returns an array containing the distribution of raw pixel values.
Public Method | ImagePlane | The currently displayed plane of this image.
Public Method | ImageToScreen | Calculate where in screen (X,Y) space, a given image point lies
Public Method | ImageToWorld | Calculate the real-world 3D coordinates of a point of the image currently displayed
Public Method | Import | Overloaded. Copies the image data from an external image format
Public Method | Matrix | Overloaded. Matrix specifying how the image is displayed
Public Method | MatrixBase | Matrix specifying how the image would be displayed with a Zoom of 1:1
Public Method | OrientationText | Return the Text of DicomLabel of LabelType = special.
Public Method | Paste | Copies the Image Data from Windows Clipboard
Public Method | PixelValuesByFrame | Returns an array of pixel values for a frame, optionally transformed via the modality transformation
Public Method | PresentationStateToCurrent | Overloaded. Modifies current display properties to match the DICOM presentation state.
Public Method | PrinterImage | Overloaded. Creates a copy of the image for printing or other purposes
Public Method | RawPixelValuesByFrame | Returns an array of raw pixel values for a frame
Public Method | Read | Overloaded. Read from a file, a system IO stream or a byte array
Public Method | ReadURL | Reads from Web Address
Public Method | ReferenceLine | This method returns a new DicomLabel object which represents the position of one DicomImage relative to another.
Public Method | RenderToArray | Overloaded. Render the DicomImage to array.
Public Method | ScreenToImage | Calculate where in image (X,Y) space, a given screen point lies
Public Method | ScreenToWorld | Calculate where in real world (X,Y,Z) space, a given screen point lies
Public Method | Send | Overloaded. Sends an image to a remote Storage SCP
Public Method | SetDefaultWindows | Recalculates the default windows used by DicomObjects as if the image had just been loaded
Public Method | SetExternalShader | An external DirectX pixel shader to be used for custom filtering
Public Method | SetPixelData | Method to set pixel data directly from a stream
Public Method | SetPixelDataAndImport | Method to import pixel data directly from a non-DICOM data
Public Method | SetPixelFile | Maps an external file as the pixel data
Public Method | SetScrollAndZoom | Sets the Scroll and Zoom values to values reflecting the current display
Public Method | SetSimpleMasking | Overloaded. Sets the frame number of the mask frame for subtraction.
Public Method | Spacing | Overloaded. Get the pixel spacing of the DicomImage
Public Method | SpacingInViewer | This method returns the Pixel Spacing within the region specified by Area, in a particular viewer
Public Method | SubImage | Overloaded. Creates a copy of part or all of the image
Public Method | Update | Causes the image to be updated
Public Method | WorldToImage | Calculate the nearest image coordinates for a point in real world (X,Y,Z) space,
Public Method | WorldToScreen | Calculate where in real world (X,Y,Z) space, a given screen point lies
Public Method | Write | Overloaded. Write the data to a file, Stream or Byte Array
Top
See Also

Reference

DicomImage Class
DicomObjects Namespace


Add Method (DicomImage)

Add Method (DicomImage)

DicomObjects Namespace > DicomImage Class : Add Method
Creates and adds standard data elements to the underlying DicomDataSet
Overload List
Overload | Description
Add(Int32,Int32,Object) | Creates and adds standard data elements to the underlying DicomDataSet
Add(DicomAttribute) | Add an existing attribute to the underlying DicomDataSet
Add(Keyword,Object) | Creates and adds standard data elements to the underlying DicomDataSet
Add(IEnumerable<DicomAttribute>) | Add a collection of DicomAttributes to the DataSet the underlying DicomDataSet
Add(String,Object) | Creates and adds standard data elements to the underlying DicomDataSet
Add(Keyword,String,Object) | Creates and adds standard data elements to the underlying DicomDataSet
Add(Int32,Int32,String,Object) | Creates and adds standard data elements with specified VR to the underlying DicomDataSet
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Add(Int32,Int32,Object) Method

Add(Int32,Int32,Object) Method

DicomObjects Namespace > DicomImage Class > Add Method : Add(Int32,Int32,Object) Method

The group index of a data element.

The element index of a data element.

The Value to be assigned

Creates and adds standard data elements to the underlying DicomDataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal Group As Integer, _
   ByVal Element As Integer, _
   ByVal Value As Object _
)
'Usage

Dim instance As DicomImage
Dim Group As Integer
Dim Element As Integer
Dim Value As Object

instance.Add(Group, Element, Value)
public void Add(
   int Group,
   int Element,
   object Value
)
public:
void Add(
   int Group,
   int Element,
   Object^ Value
)

Parameters

Group

The group index of a data element.

Element

The element index of a data element.

Value

The Value to be assigned

Remarks

This method is to add standard elements, VR of which will be determined by the internal dictionary. The type of value required for the "Value" parameter depends on the value representation of the data element, as defined by the values of group and element. Values of the types are always acceptable, as are values of other types that can be suitably coerced. Variants of type �null� are also accepted, resulting a zero-length data element, which can be useful in raw queries and for �type 2� elements. There are some special conditions relating to date and time types.

To create a sequence, value may be a DicomDataSetCollection.

If the data element being added has a potential value multiplicity (VM) of >1, then value may be either an array or scalar, but if the element�s VM is always 1, then an attempt to assign an array will generate an error.

Any existing data element with the same group and element will be silently replaced, even if it is an array.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Add(DicomAttribute) Method

Add(DicomAttribute) Method

DicomObjects Namespace > DicomImage Class > Add Method : Add(DicomAttribute) Method
An existing DicomAttribute to add
Add an existing attribute to the underlying DicomDataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal attribute As DicomAttribute _
)
'Usage

Dim instance As DicomImage
Dim attribute As DicomAttribute

instance.Add(attribute)
public void Add(
   DicomAttribute attribute
)
public:
void Add(
   DicomAttribute^ attribute
)

Parameters

attribute
An existing DicomAttribute to add
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Add(Keyword,Object) Method

Add(Keyword,Object) Method

DicomObjects Namespace > DicomImage Class > Add Method : Add(Keyword,Object) Method

The DICOM Keyword of the data element.

The Value to be assigned

Creates and adds standard data elements to the underlying DicomDataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal Keyword As Keyword, _
   ByVal Value As Object _
)
'Usage

Dim instance As DicomImage
Dim Keyword As Keyword
Dim Value As Object

instance.Add(Keyword, Value)
public void Add(
   Keyword Keyword,
   object Value
)
public:
void Add(
   Keyword Keyword,
   Object^ Value
)

Parameters

Keyword

The DICOM Keyword of the data element.

Value

The Value to be assigned

Remarks

This method is to add standard elements, VR of which will be determined by the internal dictionary. The type of value required for the "Value" parameter depends on the value representation of the data element, as defined by the values of group and element. Values of the types are always acceptable, as are values of other types that can be suitably coerced. Variants of type �null� are also accepted, resulting a zero-length data element, which can be useful in raw queries and for �type 2� elements. There are some special conditions relating to date and time types.

To create a sequence, value may be a DicomDataSetCollection.

If the data element being added has a potential value multiplicity (VM) of >1, then value may be either an array or scalar, but if the element�s VM is always 1, then an attempt to assign an array will generate an error.

Any existing data element with the same group and element will be silently replaced, even if it is an array.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Add(IEnumerable<DicomAttribute>) Method

Add(IEnumerable<DicomAttribute>) Method

DicomObjects Namespace > DicomImage Class > Add Method : Add(IEnumerable<DicomAttribute>) Method
A list of DicomAttribute to add
Add a collection of DicomAttributes to the DataSet the underlying DicomDataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal attributes As IEnumerable(Of DicomAttribute) _
)
'Usage

Dim instance As DicomImage
Dim attributes As IEnumerable(Of DicomAttribute)

instance.Add(attributes)
public void Add(
   IEnumerable<DicomAttribute> attributes
)
public:
void Add(
   IEnumerable<DicomAttribute^>^ attributes
)

Parameters

attributes
A list of DicomAttribute to add
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Add(String,Object) Method

Add(String,Object) Method

DicomObjects Namespace > DicomImage Class > Add Method : Add(String,Object) Method

The DICOM Keyword of the data element.

The Value to be assigned

Creates and adds standard data elements to the underlying DicomDataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal Keyword As String, _
   ByVal Value As Object _
)
'Usage

Dim instance As DicomImage
Dim Keyword As String
Dim Value As Object

instance.Add(Keyword, Value)
public void Add(
   string Keyword,
   object Value
)
public:
void Add(
   String^ Keyword,
   Object^ Value
)

Parameters

Keyword

The DICOM Keyword of the data element.

Value

The Value to be assigned

Remarks

This method is to add standard elements, VR of which will be determined by the internal dictionary. The type of value required for the "Value" parameter depends on the value representation of the data element, as defined by the values of group and element. Values of the types are always acceptable, as are values of other types that can be suitably coerced. Variants of type �null� are also accepted, resulting a zero-length data element, which can be useful in raw queries and for �type 2� elements. There are some special conditions relating to date and time types.

To create a sequence, value may be a DicomDataSetCollection.

If the data element being added has a potential value multiplicity (VM) of >1, then value may be either an array or scalar, but if the element�s VM is always 1, then an attempt to assign an array will generate an error.

Any existing data element with the same group and element will be silently replaced, even if it is an array.

Although this method, taking a string as the keyword is available, where possible the aternative overload, taking an Enums.Keyword is preferable.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Add(Keyword,String,Object) Method

Add(Keyword,String,Object) Method

DicomObjects Namespace > DicomImage Class > Add Method : Add(Keyword,String,Object) Method

The DICOM Keyword of the data element.

The value representation (2 character string) of the data element to be added

The Value to be assigned

Creates and adds standard data elements to the underlying DicomDataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal Keyword As Keyword, _
   ByVal VR As String, _
   ByVal Value As Object _
)
'Usage

Dim instance As DicomImage
Dim Keyword As Keyword
Dim VR As String
Dim Value As Object

instance.Add(Keyword, VR, Value)
public void Add(
   Keyword Keyword,
   string VR,
   object Value
)
public:
void Add(
   Keyword Keyword,
   String^ VR,
   Object^ Value
)

Parameters

Keyword

The DICOM Keyword of the data element.

VR

The value representation (2 character string) of the data element to be added

Value

The Value to be assigned

Remarks

This method is to add standard elements, VR of which will be determined by the internal dictionary. The type of value required for the "Value" parameter depends on the value representation of the data element, as defined by the values of group and element. Values of the types are always acceptable, as are values of other types that can be suitably coerced. Variants of type �null� are also accepted, resulting a zero-length data element, which can be useful in raw queries and for �type 2� elements. There are some special conditions relating to date and time types.

To create a sequence, value may be a DicomDataSetCollection.

If the data element being added has a potential value multiplicity (VM) of >1, then value may be either an array or scalar, but if the element�s VM is always 1, then an attempt to assign an array will generate an error.

Any existing data element with the same group and element will be silently replaced, even if it is an array.

Although this method, taking a string as the keyword is available, where possible the aternative overload, taking an Enums.Keyword is preferable.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Add(Int32,Int32,String,Object) Method

Add(Int32,Int32,String,Object) Method

DicomObjects Namespace > DicomImage Class > Add Method : Add(Int32,Int32,String,Object) Method

The group index of a data element.

The element index of a data element.

The value representation (2 character string) of the data element to be added

The Value to be assigned

Creates and adds standard data elements with specified VR to the underlying DicomDataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal Group As Integer, _
   ByVal Element As Integer, _
   ByVal VR As String, _
   ByVal Value As Object _
)
'Usage

Dim instance As DicomImage
Dim Group As Integer
Dim Element As Integer
Dim VR As String
Dim Value As Object

instance.Add(Group, Element, VR, Value)
public void Add(
   int Group,
   int Element,
   string VR,
   object Value
)
public:
void Add(
   int Group,
   int Element,
   String^ VR,
   Object^ Value
)

Parameters

Group

The group index of a data element.

Element

The element index of a data element.

VR

The value representation (2 character string) of the data element to be added

Value

The Value to be assigned

Remarks

This method is to explicitly add elements with specified VR. The type of value required for the "Value" parameter depends on the value representation of the data element, as defined by either by the VR parameter. Values of the types are always acceptable, as are values of other types that can be suitably coerced. Variants of type "null" are also accepted, resulting a zero-length data element, which can be useful in raw queries and for �type 2� elements. There are some special conditions relating to date and time types.

To create a sequence, value may be a DicomDataSetCollection.

If the data element being added has a potential value multiplicity (VM) of >1, then value may be either an array or scalar, but if the element�s VM is always 1, then an attempt to assign an array will generate an error.

Any existing data element with the same group and element will be silently replaced, even if it is an array.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


AddByReference Method (DicomImage)

AddByReference Method (DicomImage)

DicomObjects Namespace > DicomImage Class : AddByReference Method
Add byte[] as attribute value to avoid copying large data
Overload List
Overload | Description
AddByReference(Keyword,Byte[]) | Add byte[] as attribute value to avoid copying large data
AddByReference(Keyword,String,Byte[]) | Add byte[] as attribute value to avoid copying large data
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


AddByReference(Keyword,Byte[]) Method

AddByReference(Keyword,Byte[]) Method

DicomObjects Namespace > DicomImage Class > AddByReference Method : AddByReference(Keyword,Byte[]) Method
Attribute tag to add
Attribute value as byte array
Add byte[] as attribute value to avoid copying large data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub AddByReference( _
   ByVal keyword As Keyword, _
   ByVal Value() As Byte _
)
'Usage

Dim instance As DicomImage
Dim keyword As Keyword
Dim Value() As Byte

instance.AddByReference(keyword, Value)
public void AddByReference(
   Keyword keyword,
   byte[] Value
)
public:
void AddByReference(
   Keyword keyword,
   array<byte>^ Value
)

Parameters

keyword
Attribute tag to add
Value
Attribute value as byte array
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


AddByReference(Keyword,String,Byte[]) Method

AddByReference(Keyword,String,Byte[]) Method

DicomObjects Namespace > DicomImage Class > AddByReference Method : AddByReference(Keyword,String,Byte[]) Method
Attribute tag to add
Attribute VR to add
Attribute value as byte array
Add byte[] as attribute value to avoid copying large data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub AddByReference( _
   ByVal keyword As Keyword, _
   ByVal VR As String, _
   ByVal Value() As Byte _
)
'Usage

Dim instance As DicomImage
Dim keyword As Keyword
Dim VR As String
Dim Value() As Byte

instance.AddByReference(keyword, VR, Value)
public void AddByReference(
   Keyword keyword,
   string VR,
   byte[] Value
)
public:
void AddByReference(
   Keyword keyword,
   String^ VR,
   array<byte>^ Value
)

Parameters

keyword
Attribute tag to add
VR
Attribute VR to add
Value
Attribute value as byte array
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Bitmap Method

Bitmap Method

DicomObjects Namespace > DicomImage Class : Bitmap Method
Creates a Bitmap object from DicomImage
Overload List
Overload | Description
Bitmap() | Creates a Bitmap Image from DicomImage
Bitmap(Int32) | Creates a Bitmap Image from DicomImage
Bitmap(Size,PixelFormat,Matrix) | Creates a new Bitmap object, in the chosen format representing the appearance of a DicomImage
Bitmap(Size,PixelFormat,Matrix,Int32) | Creates a new Bitmap object, in the chosen format representing the appearance of a DicomImage
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Bitmap() Method

Bitmap() Method

DicomObjects Namespace > DicomImage Class > Bitmap Method : Bitmap() Method
Creates a Bitmap Image from DicomImage
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Bitmap() As Bitmap
'Usage

Dim instance As DicomImage
Dim value As Bitmap

value = instance.Bitmap()
public Bitmap Bitmap()
public:
Bitmap^ Bitmap();

Return Value

Bitmap
Remarks
Returnes a Bitmap image of the full size of the DicomImage
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Bitmap(Int32) Method

Bitmap(Int32) Method

DicomObjects Namespace > DicomImage Class > Bitmap Method : Bitmap(Int32) Method

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

Creates a Bitmap Image from DicomImage
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Bitmap( _
   ByVal frame As Integer _
) As Bitmap
'Usage

Dim instance As DicomImage
Dim frame As Integer
Dim value As Bitmap

value = instance.Bitmap(frame)
public Bitmap Bitmap(
   int frame
)
public:
Bitmap^ Bitmap(
   int frame
)

Parameters

frame

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

Return Value

Bitmap
Remarks
Returns a Bitmap image of the full size of the current Frame of the DicomImage
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Bitmap(Size,PixelFormat,Matrix) Method

Bitmap(Size,PixelFormat,Matrix) Method

DicomObjects Namespace > DicomImage Class > Bitmap Method : Bitmap(Size,PixelFormat,Matrix) Method
The size of the image to generate
The requested format
The Matrix to apply to convert from DICOM coordinates to Bitmap coordinates
Creates a new Bitmap object, in the chosen format representing the appearance of a DicomImage
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Bitmap( _
   ByVal Size As Size, _
   ByVal Format As PixelFormat, _
   ByVal Matrix As Matrix _
) As Bitmap
'Usage

Dim instance As DicomImage
Dim Size As Size
Dim Format As PixelFormat
Dim Matrix As Matrix
Dim value As Bitmap

value = instance.Bitmap(Size, Format, Matrix)
public Bitmap Bitmap(
   Size Size,
   PixelFormat Format,
   Matrix Matrix
)
public:
Bitmap^ Bitmap(
   Size Size,
   PixelFormat Format,
   Matrix^ Matrix
)

Parameters

Size
The size of the image to generate
Format
The requested format
Matrix
The Matrix to apply to convert from DICOM coordinates to Bitmap coordinates

Return Value

A Bitmap object
Remarks
Only some formats are allowed by Windows - only those supported by System.Drawing.Graphics.FromImage(System.Drawing.Image)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Bitmap(Size,PixelFormat,Matrix,Int32) Method

Bitmap(Size,PixelFormat,Matrix,Int32) Method

DicomObjects Namespace > DicomImage Class > Bitmap Method : Bitmap(Size,PixelFormat,Matrix,Int32) Method
The size of the image to generate
The requested format
The Matrix to apply to convert from DICOM coordinates to Bitmap coordinates

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

Creates a new Bitmap object, in the chosen format representing the appearance of a DicomImage
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Bitmap( _
   ByVal Size As Size, _
   ByVal Format As PixelFormat, _
   ByVal Matrix As Matrix, _
   ByVal frame As Integer _
) As Bitmap
'Usage

Dim instance As DicomImage
Dim Size As Size
Dim Format As PixelFormat
Dim Matrix As Matrix
Dim frame As Integer
Dim value As Bitmap

value = instance.Bitmap(Size, Format, Matrix, frame)
public Bitmap Bitmap(
   Size Size,
   PixelFormat Format,
   Matrix Matrix,
   int frame
)
public:
Bitmap^ Bitmap(
   Size Size,
   PixelFormat Format,
   Matrix^ Matrix,
   int frame
)

Parameters

Size
The size of the image to generate
Format
The requested format
Matrix
The Matrix to apply to convert from DICOM coordinates to Bitmap coordinates
frame

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

Return Value

A Bitmap object
Remarks
Only some formats are allowed by Windows - only those supported by System.Drawing.Graphics.FromImage(System.Drawing.Image)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


BitmapImage Method

BitmapImage Method

DicomObjects Namespace > DicomImage Class : BitmapImage Method
Forces a re-render of the BitmapImage, discarding any cached data
Image rendered as a System.Windows.Media.Imaging.BitmapImage object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function BitmapImage( _
   ByVal ForceRender As Boolean _
) As BitmapImage
'Usage

Dim instance As DicomImage
Dim ForceRender As Boolean
Dim value As BitmapImage

value = instance.BitmapImage(ForceRender)
public BitmapImage BitmapImage(
   bool ForceRender
)
public:
BitmapImage^ BitmapImage(
   bool ForceRender
)

Parameters

ForceRender
Forces a re-render of the BitmapImage, discarding any cached data

Return Value

Returns a WPF control compatible BitmapImage object
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Blt Method

Blt Method

DicomObjects Namespace > DicomImage Class : Blt Method
Image to copy pixel data from
Offset of this(base) image
Offset of the source image
Size of the pixel data in destination image
Alpha value for the source image when combined with this image. Valid values are ranging from 0 - 1, by default full opacity (1) is set
Combine pixel data of source image into this image as a base image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function Blt( _
   ByVal sourceImage As DicomImage, _
   ByVal baseAreaOffset As Point, _
   ByVal bltAreaOffset As Point, _
   ByVal outputSize As Size, _
   Optional ByVal opacity As Single _
) As DicomImage
'Usage

Dim instance As DicomImage
Dim sourceImage As DicomImage
Dim baseAreaOffset As Point
Dim bltAreaOffset As Point
Dim outputSize As Size
Dim opacity As Single
Dim value As DicomImage

value = instance.Blt(sourceImage, baseAreaOffset, bltAreaOffset, outputSize, opacity)
public DicomImage Blt(
   DicomImage sourceImage,
   Point baseAreaOffset,
   Point bltAreaOffset,
   Size outputSize,
   float opacity
)
public:
DicomImage^ Blt(
   DicomImage^ sourceImage,
   Point baseAreaOffset,
   Point bltAreaOffset,
   Size outputSize,
   float opacity
)

Parameters

sourceImage
Image to copy pixel data from
baseAreaOffset
Offset of this(base) image
bltAreaOffset
Offset of the source image
outputSize
Size of the pixel data in destination image
opacity
Alpha value for the source image when combined with this image. Valid values are ranging from 0 - 1, by default full opacity (1) is set

Return Value

A copy of this image combined with the source image in user defined outputSize
Exceptions
Exception | Description
DicomException | Specific Exception for DICOM errors
Remarks
Source and base images' Frame and Zoom can be used to select the frames and zoom level when the images are combined
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


BurnAnnotations Method

BurnAnnotations Method

DicomObjects Namespace > DicomImage Class : BurnAnnotations Method
Frames to burn labels into
Burn all image Labels in Pixel data.

This method modifies the underlying pixel data!

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub BurnAnnotations( _
   ByVal ParamArray FrameNumbers() As Integer _
)
'Usage

Dim instance As DicomImage
Dim FrameNumbers() As Integer

instance.BurnAnnotations(FrameNumbers)
public void BurnAnnotations(
   params int[] FrameNumbers
)
public:
void BurnAnnotations(
   ... array<int>^ FrameNumbers
)

Parameters

FrameNumbers
Frames to burn labels into
Remarks
If no frame number is specified, all frames are selected by default
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


CanConvertTo Method

CanConvertTo Method

DicomObjects Namespace > DicomImage Class : CanConvertTo Method
The transfer syntax to test
Useful method to check if the image can be converted using a different compression specified by the TransferSyntax
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function CanConvertTo( _
   ByVal TransferSyntax As String _
) As Boolean
'Usage

Dim instance As DicomImage
Dim TransferSyntax As String
Dim value As Boolean

value = instance.CanConvertTo(TransferSyntax)
public bool CanConvertTo(
   string TransferSyntax
)
public:
bool CanConvertTo(
   String^ TransferSyntax
)

Parameters

TransferSyntax
The transfer syntax to test

Return Value

True is the conversion is possible
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


CellLocation Method

CellLocation Method

DicomObjects Namespace > DicomImage Class : CellLocation Method
The viewer to use for sizing etc.
The location of the top-left corner of the cell within which this image would be displayed in a particular viewer
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function CellLocation( _
   ByVal Viewer As DicomViewer _
) As Point
'Usage

Dim instance As DicomImage
Dim Viewer As DicomViewer
Dim value As Point

value = instance.CellLocation(Viewer)
public Point CellLocation(
   DicomViewer Viewer
)
public:
Point CellLocation(
   DicomViewer^ Viewer
)

Parameters

Viewer
The viewer to use for sizing etc.

Return Value

The location, in pixels, relative to the viewer
Remarks
If the Area property of the image is empty, then this will return the values bases on the position of the image within the viewer's Images collection, (using the Viewer's rows and columms), but if an explicit area is specified, then that is used instead.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


CellSize Method

CellSize Method

DicomObjects Namespace > DicomImage Class : CellSize Method
The viewer to use for sizing etc.
The size of the cell within which this image would be displayed in a particular viewer
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function CellSize( _
   ByVal Viewer As DicomViewer _
) As Size
'Usage

Dim instance As DicomImage
Dim Viewer As DicomViewer
Dim value As Size

value = instance.CellSize(Viewer)
public Size CellSize(
   DicomViewer Viewer
)
public:
Size CellSize(
   DicomViewer^ Viewer
)

Parameters

Viewer
The viewer to use for sizing etc.

Return Value

The size, in pixels
Remarks
If the Area property of the image is empty, then this will always return the same size (area of the viewer divided by rows and columms), but if an explicit area is specified, then that is used instead.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


ChangeToDecompressed Method (DicomImage)

ChangeToDecompressed Method (DicomImage)

DicomObjects Namespace > DicomImage Class : ChangeToDecompressed Method
Simulate the effect of writing out as a Decompressed Image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ChangeToDecompressed()
'Usage

Dim instance As DicomImage

instance.ChangeToDecompressed()
public void ChangeToDecompressed()
public:
void ChangeToDecompressed();
Remarks
Unlike DecompressAll which is designed merely for performance improvement, this method permanently changes the data as if written out in an uncompressed transfer syntax and then read back. This might therefore change the Photometric interpretation etc. (e.Graphics. from YBR_FULL_422 to RGB)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


ClearCaches Method

ClearCaches Method

DicomObjects Namespace > DicomImage Class : ClearCaches Method
Clears the internal cache for compressed and uncompressed pixel data, lookup data and DirectX textures
Overload List
Overload | Description
ClearCaches() | Clears the entire internal cache
ClearCaches(CacheTypes) | Clears the caches of the specified types
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


ClearCaches() Method

ClearCaches() Method

DicomObjects Namespace > DicomImage Class > ClearCaches Method : ClearCaches() Method
Clears the entire internal cache
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub ClearCaches()
'Usage

Dim instance As DicomImage

instance.ClearCaches()
public void ClearCaches()
public:
void ClearCaches();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


ClearCaches(CacheTypes) Method

ClearCaches(CacheTypes) Method

DicomObjects Namespace > DicomImage Class > ClearCaches Method : ClearCaches(CacheTypes) Method
The types of cached information to be cleared
Clears the caches of the specified types
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub ClearCaches( _
   ByVal Types As CacheTypes _
)
'Usage

Dim instance As DicomImage
Dim Types As CacheTypes

instance.ClearCaches(Types)
public void ClearCaches(
   CacheTypes Types
)
public:
void ClearCaches(
   CacheTypes Types
)

Parameters

Types
The types of cached information to be cleared
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Clone Method (DicomImage)

Clone Method (DicomImage)

DicomObjects Namespace > DicomImage Class : Clone Method
Returns a cloned copy of the DicomImage
Overload List
Overload | Description
Clone(Boolean) | Returns a cloned copy of the DicomImage
Clone() | Returns a Shallow copy of the DicomImage
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Clone(Boolean) Method

Clone(Boolean) Method

DicomObjects Namespace > DicomImage Class > Clone Method : Clone(Boolean) Method

If true then returns a Deep copy of the DicomImage, otherwise returns a Shallow copy.

Returns a cloned copy of the DicomImage
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Overridable Function Clone( _
   ByVal Deep As Boolean _
) As Object
'Usage

Dim instance As DicomImage
Dim Deep As Boolean
Dim value As Object

value = instance.Clone(Deep)
public virtual object Clone(
   bool Deep
)
public:
virtual Object^ Clone(
   bool Deep
)

Parameters

Deep

If true then returns a Deep copy of the DicomImage, otherwise returns a Shallow copy.

Return Value

DicomImage
Remarks

This method makes either a Shallow Copy or a Deep Copy of the DicomImage, dependants on the Deep parameter.

A shallow copy will only have the top level objects replicated, any referenced objects under the top level will be shared by the original DicomImage and the cloned copy.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Clone() Method

Clone() Method

DicomObjects Namespace > DicomImage Class > Clone Method : Clone() Method
Returns a Shallow copy of the DicomImage
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Overridable Function Clone() As Object
'Usage

Dim instance As DicomImage
Dim value As Object

value = instance.Clone()
public virtual object Clone()
public:
virtual Object^ Clone();

Return Value

DicomImage
Remarks
Equivalent to Clone(False)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Copy Method

Copy Method

DicomObjects Namespace > DicomImage Class : Copy Method
Copies the image to the Windows clipboard
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Copy()
'Usage

Dim instance As DicomImage

instance.Copy()
public void Copy()
public:
void Copy();
Remarks
The image is copied as a device independent bitmap (DIB), which can be imported into most graphical applications. The image generated is partially based on that that would be displayed, in that Width, Level and Frame are used to locate and pre-process the image, but Zoom, ScrollX and ScrollY are not.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


CurrentToNoStretch Method

CurrentToNoStretch Method

DicomObjects Namespace > DicomImage Class : CurrentToNoStretch Method
The viewer to associate the changes to.
This method modifies the StretchMode, Zoom and Scroll properties such that the display output stays very similar while the display parameters have changed to suit the DicomObjects.Enums.StretchModes.NoStretch mode.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub CurrentToNoStretch( _
   ByVal Viewer As DicomViewer _
)
'Usage

Dim instance As DicomImage
Dim Viewer As DicomViewer

instance.CurrentToNoStretch(Viewer)
public void CurrentToNoStretch(
   DicomViewer Viewer
)
public:
void CurrentToNoStretch(
   DicomViewer^ Viewer
)

Parameters

Viewer
The viewer to associate the changes to.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


CurrentToPresentationState Method

CurrentToPresentationState Method

DicomObjects Namespace > DicomImage Class : CurrentToPresentationState Method
Encapsulate current display properties into a DICOM GreyScale Presentation State object
Overload List
Overload | Description
CurrentToPresentationState(Size,Boolean) | Encapsulate current display properties into a DICOM GreyScale Presentation State object
CurrentToPresentationState(DicomViewer,Boolean) | Encapsulate current display properties into a DICOM GreyScale Presentation State object
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


CurrentToPresentationState(Size,Boolean) Method

CurrentToPresentationState(Size,Boolean) Method

DicomObjects Namespace > DicomImage Class > CurrentToPresentationState Method : CurrentToPresentationState(Size,Boolean) Method

The image size in pixel which is to be rendered

Controls whether additional private elements are included.

Encapsulate current display properties into a DICOM GreyScale Presentation State object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub CurrentToPresentationState( _
   ByVal DisplaySize As Size, _
   ByVal usePrivate As Boolean _
)
'Usage

Dim instance As DicomImage
Dim DisplaySize As Size
Dim usePrivate As Boolean

instance.CurrentToPresentationState(DisplaySize, usePrivate)
public void CurrentToPresentationState(
   Size DisplaySize,
   bool usePrivate
)
public:
void CurrentToPresentationState(
   Size DisplaySize,
   bool usePrivate
)

Parameters

DisplaySize

The image size in pixel which is to be rendered

usePrivate

Controls whether additional private elements are included.

Remarks

The presentation state created is immediately used as the image�s PresentationState property, so after this call, the display should not be visibly altered, though small changes may be seen due to the reduced flexibility of colours etc. in DICOM presentation states compared with DicomObjects' DicomLabel objects.

The properties encapsulated into the presentation state include:

  • Window Width & Level
  • StretchMode
  • Zoom
  • FlipState & RotateState
  • ScrollX& ScrollY
  • ModalityLUT, VOILUT & PresentationLUT
  • OverlayVisible & OverlayColour
  • All DicomLabels except "special" and "ruler" types

There are several properties of DicomLabel objects which do not have official DICOM equivalents, such as font details,RotationMode and AutoSizeMode. If usePrivate is true, then private attribute in the range 6E15,7Axx are added to the presentation state to store them, but if usePrivate is false, then these properties must be discarded.

This method does have some limitations, and the following objects/properties are not currently converted:

  • Some label types � arrows, rulers, arcs and "special" labels
  • MaskRanges subtraction information
  • ModalityLUT, VOILUT & PresentationLUT properties
These issues will be addressed in a future version of DicomObjects
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


CurrentToPresentationState(DicomViewer,Boolean) Method

CurrentToPresentationState(DicomViewer,Boolean) Method

DicomObjects Namespace > DicomImage Class > CurrentToPresentationState Method : CurrentToPresentationState(DicomViewer,Boolean) Method
The viewer the image is displayed in
Controls whether additional private elements are included.
Encapsulate current display properties into a DICOM GreyScale Presentation State object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub CurrentToPresentationState( _
   ByVal Viewer As DicomViewer, _
   ByVal UsePrivate As Boolean _
)
'Usage

Dim instance As DicomImage
Dim Viewer As DicomViewer
Dim UsePrivate As Boolean

instance.CurrentToPresentationState(Viewer, UsePrivate)
public void CurrentToPresentationState(
   DicomViewer Viewer,
   bool UsePrivate
)
public:
void CurrentToPresentationState(
   DicomViewer^ Viewer,
   bool UsePrivate
)

Parameters

Viewer
The viewer the image is displayed in
UsePrivate
Controls whether additional private elements are included.
Remarks

The presentation state created is immediately used as the image�s PresentationState property, so after this call, the display should not be visibly altered, though small changes may be seen due to the reduced flexibility of colours etc. in DICOM presentation states compared with DicomObjects' DicomLabel objects.

The properties encapsulated into the presentation state include:

  • Window Width & Level
  • StretchMode
  • Zoom
  • FlipState & RotateState
  • ScrollX& ScrollY
  • ModalityLUT, VOILUT & PresentationLUT
  • OverlayVisible & OverlayColour
  • All DicomLabels except "special" and "ruler" types

There are several properties of DicomLabel objects which do not have official DICOM equivalents, such as font details,RotationMode and AutoSizeMode. If usePrivate is true, then private attribute in the range 6E15,7Axx are added to the presentation state to store them, but if usePrivate is false, then these properties must be discarded.

This method does have some limitations, and the following objects/properties are not currently converted:

  • Some label types � arrows, rulers, arcs and "special" labels
  • MaskRanges subtraction information
  • ModalityLUT, VOILUT & PresentationLUT properties
These issues will be addressed in a future version of DicomObjects
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


DecompressAll Method (DicomImage)

DecompressAll Method (DicomImage)

DicomObjects Namespace > DicomImage Class : DecompressAll Method
Causes all the frames of an image to be decompressed.
Causes all the frames of an image to be decompressed into a byte array
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub DecompressAll()
'Usage

Dim instance As DicomImage

instance.DecompressAll()
public void DecompressAll()
public:
void DecompressAll();
Remarks

The normal policy adopted by DicomObjects for the handling of compressed images is to decompress frames only when necessary, and to keep the decompressed versions only for as long as is necessary for display or transmission, thereby minimising image load times, and memory use. This behaviour is not, however, always appropriate, especially when cine sequences are shown, or where modifications need to be made to the image. When this method is called, all frames are decompressed and held in RAM, replacing the original compressed version, thereby greatly speeding subsequent display, though needing much more memory.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


DisplaySize Method

DisplaySize Method

DicomObjects Namespace > DicomImage Class : DisplaySize Method
Methods to determine the size at which am image would be shown
Overload List
Overload | Description
DisplaySize(DicomViewer) | The size at which this image, using current values for StretchMode etc. will display in this viewer.
DisplaySize(Matrix) | The display size in output coordinates
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


DisplaySize(DicomViewer) Method

DisplaySize(DicomViewer) Method

DicomObjects Namespace > DicomImage Class > DisplaySize Method : DisplaySize(DicomViewer) Method
The Viewer being used to provide spacing etc.
The size at which this image, using current values for StretchMode etc. will display in this viewer.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function DisplaySize( _
   ByVal Viewer As DicomViewer _
) As Size
'Usage

Dim instance As DicomImage
Dim Viewer As DicomViewer
Dim value As Size

value = instance.DisplaySize(Viewer)
public Size DisplaySize(
   DicomViewer Viewer
)
public:
Size DisplaySize(
   DicomViewer^ Viewer
)

Parameters

Viewer
The Viewer being used to provide spacing etc.

Return Value

The size of the displayed image, in pixels
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


DisplaySize(Matrix) Method

DisplaySize(Matrix) Method

DicomObjects Namespace > DicomImage Class > DisplaySize Method : DisplaySize(Matrix) Method
The transformation to apply to the original image size.
The display size in output coordinates
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function DisplaySize( _
   ByVal Matrix As Matrix _
) As Size
'Usage

Dim instance As DicomImage
Dim Matrix As Matrix
Dim value As Size

value = instance.DisplaySize(Matrix)
public Size DisplaySize(
   Matrix Matrix
)
public:
Size DisplaySize(
   Matrix^ Matrix
)

Parameters

Matrix
The transformation to apply to the original image size.

Return Value

The transformed Size
Remarks
This method takes the user provided Matrix, perform Transformation on the Image and returns the Image display size in output (normally screen) coordinates.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Dispose() Method

Dispose() Method

DicomObjects Namespace > DicomImage Class : Dispose() Method
Releases the resources used by the DicomImage object This does not dispose the underlying DicomDataSet object which is DataSet, an explicit Dispose call will be needed to have that effect
Standard Dispose methods
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As DicomImage

instance.Dispose()
public void Dispose()
public:
void Dispose();
Remarks
This does not dispose the underlying DicomDataSet object which is DataSet, an explicit Dispose call will be needed to have that effect
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


DistanceFromPoint Method

DistanceFromPoint Method

DicomObjects Namespace > DicomImage Class : DistanceFromPoint Method
The reference point
Frame within the image being used for calculation
Perpendicular distance from a Point to the plane of this image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function DistanceFromPoint( _
   ByVal Point As Point3D, _
   ByVal Frame As Integer _
) As Nullable(Of Single)
'Usage

Dim instance As DicomImage
Dim Point As Point3D
Dim Frame As Integer
Dim value As Nullable(Of Single)

value = instance.DistanceFromPoint(Point, Frame)
public virtual Nullable<float> DistanceFromPoint(
   Point3D Point,
   int Frame
)
public:
virtual Nullable<float> DistanceFromPoint(
   Point3D Point,
   int Frame
)

Parameters

Point
The reference point
Frame
Frame within the image being used for calculation

Return Value

Distance in mm
Remarks
The distance may be positive/negative
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


DownloadStatus Method (DicomImage)

DownloadStatus Method (DicomImage)

DicomObjects Namespace > DicomImage Class : DownloadStatus Method
Methods to determine the degree to which part of an image has already been downloaded
Overload List
Overload | Description
DownloadStatus(Rectangle,Single,Int32) | The download status of an image compared to specific attributes of the image
DownloadStatus(RectangleF,Single,Int32) | The download status of an image compared to specific attributes of the image
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


DownloadStatus(Rectangle,Single,Int32) Method

DownloadStatus(Rectangle,Single,Int32) Method

DicomObjects Namespace > DicomImage Class > DownloadStatus Method : DownloadStatus(Rectangle,Single,Int32) Method
The Area of the image needed
The required zoom for the image
The requested frame number
The download status of an image compared to specific attributes of the image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function DownloadStatus( _
   ByVal Area As Rectangle, _
   ByVal Zoom As Single, _
   ByVal Frame As Integer _
) As ProgressiveStatus
'Usage

Dim instance As DicomImage
Dim Area As Rectangle
Dim Zoom As Single
Dim Frame As Integer
Dim value As ProgressiveStatus

value = instance.DownloadStatus(Area, Zoom, Frame)
public ProgressiveStatus DownloadStatus(
   Rectangle Area,
   float Zoom,
   int Frame
)
public:
ProgressiveStatus DownloadStatus(
   Rectangle Area,
   float Zoom,
   int Frame
)

Parameters

Area
The Area of the image needed
Zoom
The required zoom for the image
Frame
The requested frame number

Return Value

The status relative to the parameters
Remarks
For this overload, the Area is specified in pixels
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


DownloadStatus(RectangleF,Single,Int32) Method

DownloadStatus(RectangleF,Single,Int32) Method

DicomObjects Namespace > DicomImage Class > DownloadStatus Method : DownloadStatus(RectangleF,Single,Int32) Method
The Area of the image needed
The required zoom for the image
The requested frame number
The download status of an image compared to specific attributes of the image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function DownloadStatus( _
   ByVal Area As RectangleF, _
   ByVal Zoom As Single, _
   ByVal Frame As Integer _
) As ProgressiveStatus
'Usage

Dim instance As DicomImage
Dim Area As RectangleF
Dim Zoom As Single
Dim Frame As Integer
Dim value As ProgressiveStatus

value = instance.DownloadStatus(Area, Zoom, Frame)
public ProgressiveStatus DownloadStatus(
   RectangleF Area,
   float Zoom,
   int Frame
)
public:
ProgressiveStatus DownloadStatus(
   RectangleF Area,
   float Zoom,
   int Frame
)

Parameters

Area
The Area of the image needed
Zoom
The required zoom for the image
Frame
The requested frame number

Return Value

The status relative to the parameters
Remarks
For this overload, the Area is specified in image fractions (0.0-1.0)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


ExplicitJpipRequest Method

ExplicitJpipRequest Method

DicomObjects Namespace > DicomImage Class : ExplicitJpipRequest Method
Explicitly request that some of the pixel information for this image should be retrieved via JPIP
Overload List
Overload | Description
ExplicitJpipRequest(Rectangle,Single,Int32,Int32) | Explicitly request that some of the pixel information for this image should be retrieved via JPIP
ExplicitJpipRequest(RectangleF,Single,Int32,Int32) | Explicitly request that some of the pixel information for this image should be retrieved via JPIP
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


ExplicitJpipRequest(Rectangle,Single,Int32,Int32) Method

ExplicitJpipRequest(Rectangle,Single,Int32,Int32) Method

DicomObjects Namespace > DicomImage Class > ExplicitJpipRequest Method : ExplicitJpipRequest(Rectangle,Single,Int32,Int32) Method
The area of the image requested (pixel units)
The zoom factor required
The requested frame number (first = 1)
The priority of the request (higher values mean higher priority)
Explicitly request that some of the pixel information for this image should be retrieved via JPIP
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub ExplicitJpipRequest( _
   ByVal Area As Rectangle, _
   ByVal Zoom As Single, _
   ByVal Frame As Integer, _
   ByVal Priority As Integer _
)
'Usage

Dim instance As DicomImage
Dim Area As Rectangle
Dim Zoom As Single
Dim Frame As Integer
Dim Priority As Integer

instance.ExplicitJpipRequest(Area, Zoom, Frame, Priority)
public void ExplicitJpipRequest(
   Rectangle Area,
   float Zoom,
   int Frame,
   int Priority
)
public:
void ExplicitJpipRequest(
   Rectangle Area,
   float Zoom,
   int Frame,
   int Priority
)

Parameters

Area
The area of the image requested (pixel units)
Zoom
The zoom factor required
Frame
The requested frame number (first = 1)
Priority
The priority of the request (higher values mean higher priority)
Remarks
implicit requests (e.g. if the image is being displayed in a viewer) have priority values between 1000 and 10000 depending on how long since they were last updated.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


ExplicitJpipRequest(RectangleF,Single,Int32,Int32) Method

ExplicitJpipRequest(RectangleF,Single,Int32,Int32) Method

DicomObjects Namespace > DicomImage Class > ExplicitJpipRequest Method : ExplicitJpipRequest(RectangleF,Single,Int32,Int32) Method
The area of the image requested (image fractional units - 0.0-1.0)
The zoom factor required
The requested frame number (first = 1)
The priority of the request (higher values mean higher priority)
Explicitly request that some of the pixel information for this image should be retrieved via JPIP
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub ExplicitJpipRequest( _
   ByVal Area As RectangleF, _
   ByVal Zoom As Single, _
   ByVal Frame As Integer, _
   ByVal Priority As Integer _
)
'Usage

Dim instance As DicomImage
Dim Area As RectangleF
Dim Zoom As Single
Dim Frame As Integer
Dim Priority As Integer

instance.ExplicitJpipRequest(Area, Zoom, Frame, Priority)
public void ExplicitJpipRequest(
   RectangleF Area,
   float Zoom,
   int Frame,
   int Priority
)
public:
void ExplicitJpipRequest(
   RectangleF Area,
   float Zoom,
   int Frame,
   int Priority
)

Parameters

Area
The area of the image requested (image fractional units - 0.0-1.0)
Zoom
The zoom factor required
Frame
The requested frame number (first = 1)
Priority
The priority of the request (higher values mean higher priority)
Remarks
implicit requests (e.g. if the image is being displayed in a viewer) have priority values between 1000 and 10000 depending on how long since they were last updated.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Export Method (DicomImage)

Export Method (DicomImage)

DicomObjects Namespace > DicomImage Class : Export Method
Export image to non-DICOM format
Overload List
Overload | Description
Export(String,Object) | Copy the image data for external access, controlled by Format and Quality
Export(Stream,String,Object) | Export DicomImage to supported Image Format
Export(String,ImageFormat,Int32) | Export DicomImage to supported Image Format
Export(Stream,ImageFormat,Int32) | Export DicomImage to supported Image Format
Export(String,String,Object) | Copy the image data to an external file format, with control of FileName, Format and Quality
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Export(String,Object) Method

Export(String,Object) Method

DicomObjects Namespace > DicomImage Class > Export Method : Export(String,Object) Method

The type of export operation to perform

The quality factor to be used

Copy the image data for external access, controlled by Format and Quality
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Export( _
   ByVal Format As String, _
   ByVal Quality As Object _
) As Byte()
'Usage

Dim instance As DicomImage
Dim Format As String
Dim Quality As Object
Dim value() As Byte

value = instance.Export(Format, Quality)
public byte[] Export(
   string Format,
   object Quality
)
public:
array<byte>^ Export(
   String^ Format,
   Object^ Quality
)

Parameters

Format

The type of export operation to perform

Quality

The quality factor to be used

Return Value

byte array containing the exported version
Remarks

Only JPEG and BMP/DIB formats are supported directly, but other formats such as TIF may be supported via deveoloper supplied codecs.

The following applies to JPEG file import:

The Format parameter must be JPEG or JPG

The following applies to DIB/BMP file export:

Data will be uncompressed.
If format is BMP, then a BMP file header is included at the start of the data. If type is DIB, then no header is included.
The Format parameter must be DIB or BMP

See for details of how to write and configure your own codecs.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Export(Stream,String,Object) Method

Export(Stream,String,Object) Method

DicomObjects Namespace > DicomImage Class > Export Method : Export(Stream,String,Object) Method

The stream into which the image is written

The file format you would like to export image to

The quality factor to be used

Export DicomImage to supported Image Format
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Export( _
   ByVal Stream As Stream, _
   ByVal Format As String, _
   ByVal Quality As Object _
)
'Usage

Dim instance As DicomImage
Dim Stream As Stream
Dim Format As String
Dim Quality As Object

instance.Export(Stream, Format, Quality)
public void Export(
   Stream Stream,
   string Format,
   object Quality
)
public:
void Export(
   Stream^ Stream,
   String^ Format,
   Object^ Quality
)

Parameters

Stream

The stream into which the image is written

Format

The file format you would like to export image to

Quality

The quality factor to be used

Remarks
This method uses the internal DicomObjects export methods, including the ability to export multi-frame GIF etc.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Export(String,ImageFormat,Int32) Method

Export(String,ImageFormat,Int32) Method

DicomObjects Namespace > DicomImage Class > Export Method : Export(String,ImageFormat,Int32) Method

The filename where you would like to save the exported image

The file format you would like to export image to

The quality factor to be used

Export DicomImage to supported Image Format
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Export( _
   ByVal Filename As String, _
   ByVal Format As ImageFormat, _
   ByVal Quality As Integer _
)
'Usage

Dim instance As DicomImage
Dim Filename As String
Dim Format As ImageFormat
Dim Quality As Integer

instance.Export(Filename, Format, Quality)
public void Export(
   string Filename,
   ImageFormat Format,
   int Quality
)
public:
void Export(
   String^ Filename,
   ImageFormat^ Format,
   int Quality
)

Parameters

Filename

The filename where you would like to save the exported image

Format

The file format you would like to export image to

Quality

The quality factor to be used

Remarks
This method provides a native .NET approach to export images. An internal BMP image is created and the .NET bmp.Save method is used. For more flexibity, it is possible to build your own export routine, by using DicomImage.Bitmap method to get a bitmap image out of the DicomImage then using the native .NET approaches to convert it to any format you like.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Export(Stream,ImageFormat,Int32) Method

Export(Stream,ImageFormat,Int32) Method

DicomObjects Namespace > DicomImage Class > Export Method : Export(Stream,ImageFormat,Int32) Method

The stream into which the image is written

The file format you would like to export image to

The quality factor to be used

Export DicomImage to supported Image Format
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Export( _
   ByVal Stream As Stream, _
   ByVal Format As ImageFormat, _
   ByVal Quality As Integer _
)
'Usage

Dim instance As DicomImage
Dim Stream As Stream
Dim Format As ImageFormat
Dim Quality As Integer

instance.Export(Stream, Format, Quality)
public void Export(
   Stream Stream,
   ImageFormat Format,
   int Quality
)
public:
void Export(
   Stream^ Stream,
   ImageFormat^ Format,
   int Quality
)

Parameters

Stream

The stream into which the image is written

Format

The file format you would like to export image to

Quality

The quality factor to be used

Remarks
This method provides a native .NET approach to export images. An internal BMP image is created and the .NET bmp.Save method is used. For more flexibity, it is possible to build your own export routine, by using DicomImage.Bitmap method to get a bitmap image out of the DicomImage then using the native .NET approaches to convert it to any format you like.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Export(String,String,Object) Method

Export(String,String,Object) Method

DicomObjects Namespace > DicomImage Class > Export Method : Export(String,String,Object) Method

The name of the file to export

The type of export operation to perform

The quality factor to be used

Copy the image data to an external file format, with control of FileName, Format and Quality
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Export( _
   ByVal FileName As String, _
   Optional ByVal Format As String, _
   Optional ByVal Quality As Object _
)
'Usage

Dim instance As DicomImage
Dim FileName As String
Dim Format As String
Dim Quality As Object

instance.Export(FileName, Format, Quality)
public void Export(
   string FileName,
   string Format,
   object Quality
)
public:
void Export(
   String^ FileName,
   String^ Format,
   Object^ Quality
)

Parameters

FileName

The name of the file to export

Format

The type of export operation to perform

Quality

The quality factor to be used

Remarks

Any of the formats supported via Image.Save(...) or via internal codecs are supported

See for details of how to write and configure your own codecs.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


GetCacheSize Method

GetCacheSize Method

DicomObjects Namespace > DicomImage Class : GetCacheSize Method
Type of Cache of interest, default value is DicomObjects.Enums.CacheTypes.All
Get cache size used by DicomObjects for the image - useful to help decide when to call ClearCaches method
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function GetCacheSize( _
   ByVal cacheType As CacheTypes _
) As Long
'Usage

Dim instance As DicomImage
Dim cacheType As CacheTypes
Dim value As Long

value = instance.GetCacheSize(cacheType)
public long GetCacheSize(
   CacheTypes cacheType
)
public:
int64 GetCacheSize(
   CacheTypes cacheType
)

Parameters

cacheType
Type of Cache of interest, default value is DicomObjects.Enums.CacheTypes.All

Return Value

number of bytes cached by DicomObjects
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


GetMinAndMax Method (DicomImage)

GetMinAndMax Method (DicomImage)

DicomObjects Namespace > DicomImage Class : GetMinAndMax Method
Find the maximum and minimum pixel data values in the pixel data
Overload List
Overload | Description
GetMinAndMax(Single,Single,Single,Boolean) | Find the maximum and minimum pixel data values in the pixel data
GetMinAndMax(Single,Single,Single,Boolean,Boolean) | Find the maximum and minimum pixel data values in the pixel data
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


GetMinAndMax(Single,Single,Single,Boolean) Method

GetMinAndMax(Single,Single,Single,Boolean) Method

DicomObjects Namespace > DicomImage Class > GetMinAndMax Method : GetMinAndMax(Single,Single,Single,Boolean) Method
The minimum value found
The maximum value found
Proportion of extreme values to ignore (in range 0.0 to 1.0)
Whether to apply scaling/modality lookup table transformation
Find the maximum and minimum pixel data values in the pixel data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub GetMinAndMax( _
   ByRef Min As Single, _
   ByRef Max As Single, _
   ByVal Centile As Single, _
   ByVal Scale As Boolean _
)
'Usage

Dim instance As DicomImage
Dim Min As Single
Dim Max As Single
Dim Centile As Single
Dim Scale As Boolean

instance.GetMinAndMax(Min, Max, Centile, Scale)
public void GetMinAndMax(
   out float Min,
   out float Max,
   float Centile,
   bool Scale
)
public:
void GetMinAndMax(
   [Out] float Min,
   [Out] float Max,
   float Centile,
   bool Scale
)

Parameters

Min
The minimum value found
Max
The maximum value found
Centile
Proportion of extreme values to ignore (in range 0.0 to 1.0)
Scale
Whether to apply scaling/modality lookup table transformation
Remarks

Pixel padding values are ignored

If Scale is false, then the values returned are "raw" values before application of rescaling or modality lookup tables

If Scale is true, then the values returned are transformed using the modality slope and intercept or modality lookup tables as appropriate to the image

If it is necessray to use separate control for the 2 scaling methods, then the GetMinAndMax(Single,Single,Single,Boolean,Boolean) override may be used instead.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


GetMinAndMax(Single,Single,Single,Boolean,Boolean) Method

GetMinAndMax(Single,Single,Single,Boolean,Boolean) Method

DicomObjects Namespace > DicomImage Class > GetMinAndMax Method : GetMinAndMax(Single,Single,Single,Boolean,Boolean) Method
The minimum value found
The maximum value found
Centile as Float
Whether to apply modality lookup table transformation
Whether to apply modality rescale slope and offset transformations
Find the maximum and minimum pixel data values in the pixel data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub GetMinAndMax( _
   ByRef Min As Single, _
   ByRef Max As Single, _
   ByVal Centile As Single, _
   ByVal ScaleLUT As Boolean, _
   ByVal ScaleRescale As Boolean _
)
'Usage

Dim instance As DicomImage
Dim Min As Single
Dim Max As Single
Dim Centile As Single
Dim ScaleLUT As Boolean
Dim ScaleRescale As Boolean

instance.GetMinAndMax(Min, Max, Centile, ScaleLUT, ScaleRescale)
public void GetMinAndMax(
   out float Min,
   out float Max,
   float Centile,
   bool ScaleLUT,
   bool ScaleRescale
)
public:
void GetMinAndMax(
   [Out] float Min,
   [Out] float Max,
   float Centile,
   bool ScaleLUT,
   bool ScaleRescale
)

Parameters

Min
The minimum value found
Max
The maximum value found
Centile
Centile as Float
ScaleLUT
Whether to apply modality lookup table transformation
ScaleRescale
Whether to apply modality rescale slope and offset transformations
Remarks

Pixel padding values are ignored

If ScaleLUT is false, then the values returned are "raw" values before application of rescaling or modality lookup tables

If ScaleLUT is true, then the values returned are transformed using the modality slope and intercept or modality lookup tables as appropriate to the image

If it is necessray to use separate control for the 2 scaling methods, then the GetMinAndMax(Single,Single,Single,Boolean,Boolean) override may be used instead.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


GetRawFrame Method

GetRawFrame Method

DicomObjects Namespace > DicomImage Class : GetRawFrame Method
Frame number to extract
Cache result for the extracted frame
Extract individual frame from the pixel data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function GetRawFrame( _
   ByVal Frame As Integer, _
   ByVal cache As Boolean _
) As Byte()
'Usage

Dim instance As DicomImage
Dim Frame As Integer
Dim cache As Boolean
Dim value() As Byte

value = instance.GetRawFrame(Frame, cache)
public byte[] GetRawFrame(
   int Frame,
   bool cache
)
public:
array<byte>^ GetRawFrame(
   int Frame,
   bool cache
)

Parameters

Frame
Frame number to extract
cache
Cache result for the extracted frame

Return Value

Raw pixel data of the request frame
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Histogram Method

Histogram Method

DicomObjects Namespace > DicomImage Class : Histogram Method
The lowest pixel value to be included
The highest pixel value to be included
The number of adjacent pixel values to be grouped into each bin
Returns an array containing the distribution of raw pixel values.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function Histogram( _
   ByVal MinValue As Integer, _
   ByVal MaxValue As Integer, _
   ByVal BinSize As Integer _
) As Integer()
'Usage

Dim instance As DicomImage
Dim MinValue As Integer
Dim MaxValue As Integer
Dim BinSize As Integer
Dim value() As Integer

value = instance.Histogram(MinValue, MaxValue, BinSize)
public int[] Histogram(
   int MinValue,
   int MaxValue,
   int BinSize
)
public:
array<int>^ Histogram(
   int MinValue,
   int MaxValue,
   int BinSize
)

Parameters

MinValue
The lowest pixel value to be included
MaxValue
The highest pixel value to be included
BinSize
The number of adjacent pixel values to be grouped into each bin

Return Value

An integer array containing the distribution.
Remarks
The format of the returned data is suitable for creating DICOM Image Histogram modules, though to use this a few other attributes must be added. In keeping with the image histogram module, the values used are raw pixel values before application of a modality lookup table or rescaling � apply Lookup Tables if such translation is required. For multi-frame images, only the first frame is used for this method.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


ImagePlane Method (DicomImage)

ImagePlane Method (DicomImage)

DicomObjects Namespace > DicomImage Class : ImagePlane Method
The currently displayed plane of this image.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function ImagePlane( _
   ByVal Frame1 As Integer _
) As Nullable(Of Plane3D)
'Usage

Dim instance As DicomImage
Dim Frame1 As Integer
Dim value As Nullable(Of Plane3D)

value = instance.ImagePlane(Frame1)
public virtual Nullable<Plane3D> ImagePlane(
   int Frame1
)
public:
virtual Nullable<Plane3D> ImagePlane(
   int Frame1
)

Parameters

Frame1

Return Value

The plane of the image in 3D space, or null if not applicable to this image.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


ImageToScreen Method (DicomImage)

ImageToScreen Method (DicomImage)

DicomObjects Namespace > DicomImage Class : ImageToScreen Method
The image coordinates
The Viewer being used for display
Calculate where in screen (X,Y) space, a given image point lies
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function ImageToScreen( _
   ByVal ImageCoordinates As PointF, _
   ByVal Viewer As DicomViewer _
) As Nullable(Of PointF)
'Usage

Dim instance As DicomImage
Dim ImageCoordinates As PointF
Dim Viewer As DicomViewer
Dim value As Nullable(Of PointF)

value = instance.ImageToScreen(ImageCoordinates, Viewer)
public virtual Nullable<PointF> ImageToScreen(
   PointF ImageCoordinates,
   DicomViewer Viewer
)
public:
virtual Nullable<PointF> ImageToScreen(
   PointF ImageCoordinates,
   DicomViewer^ Viewer
)

Parameters

ImageCoordinates
The image coordinates
Viewer
The Viewer being used for display

Return Value

Point in 2D image space if appropriate, or null, for 3D images
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


ImageToWorld(PointF,DicomViewer) Method

ImageToWorld(PointF,DicomViewer) Method

DicomObjects Namespace > DicomImage Class : ImageToWorld(PointF,DicomViewer) Method
location being calculated in image pixel coordinates
The Viewer being used for display
Calculate the real-world 3D coordinates of a point of the image currently displayed
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function ImageToWorld( _
   ByVal ImageLocation As PointF, _
   Optional ByVal Viewer As DicomViewer _
) As Nullable(Of Point3D)
'Usage

Dim instance As DicomImage
Dim ImageLocation As PointF
Dim Viewer As DicomViewer
Dim value As Nullable(Of Point3D)

value = instance.ImageToWorld(ImageLocation, Viewer)
public virtual Nullable<Point3D> ImageToWorld(
   PointF ImageLocation,
   DicomViewer Viewer
)
public:
virtual Nullable<Point3D> ImageToWorld(
   PointF ImageLocation,
   DicomViewer^ Viewer
)

Parameters

ImageLocation
location being calculated in image pixel coordinates
Viewer
The Viewer being used for display

Return Value

Note the use of image pixel coordinates, so you may wish to use DicomViewer.ImagePosition first.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Import Method (DicomImage)

Import Method (DicomImage)

DicomObjects Namespace > DicomImage Class : Import Method
Copies the image data from an external image format
Overload List
Overload | Description
Import(Image) | Copies the image data from an external generic image object
Import(String) | Copies the image data from an external image
Import(Stream,String) | Copies the image data from a System IO Stream
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Import(Image) Method

Import(Image) Method

DicomObjects Namespace > DicomImage Class > Import Method : Import(Image) Method
The image to import
Copies the image data from an external generic image object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Import( _
   ByVal Image As Image _
)
'Usage

Dim instance As DicomImage
Dim Image As Image

instance.Import(Image)
public void Import(
   Image Image
)
public:
void Import(
   Image^ Image
)

Parameters

Image
The image to import
Remarks

Like the Paste method, this method modifies only the minimum number of attributes necessary to ensure consistency of the image. In order to produce a valid DICOM SOP instance, many other attributes (depending on the SOP class) must be added.

A multiframe image is created if the input data is a multipage Image

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Import(String) Method

Import(String) Method

DicomObjects Namespace > DicomImage Class > Import Method : Import(String) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Copies the image data from an external image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Import( _
   ByVal FileName As String _
)
'Usage

Dim instance As DicomImage
Dim FileName As String

instance.Import(FileName)
public void Import(
   string FileName
)
public:
void Import(
   String^ FileName
)

Parameters

FileName

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Remarks

Like the Paste method, this method modifies only the minimum number of attributes necessary to ensure consistency of the image. In order to produce a valid DICOM SOP instance, many other attributes (depending on the SOP class) must be added.

The import file format is detected automatically, if DicomObjects cannot detect the file type then it will use the file extension as the format.

All formats which can be supported by Windows via new Bitmap(Stream) or explicitly via (including JPEG 2000) are supported.

File extensions for supported formats are:

  • JPEG: "JPEG" or "JPG"
  • Bitmap: "BMP"
  • DIB: "DIB"
  • AVI: "AVI"

A multiframe image is created if the input data is a multipage Image

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Import(Stream,String) Method

Import(Stream,String) Method

DicomObjects Namespace > DicomImage Class > Import Method : Import(Stream,String) Method

The System IO Stream to read

The type of import operation to perform

Copies the image data from a System IO Stream
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Import( _
   ByVal Stream As Stream, _
   ByVal Format As String _
)
'Usage

Dim instance As DicomImage
Dim Stream As Stream
Dim Format As String

instance.Import(Stream, Format)
public void Import(
   Stream Stream,
   string Format
)
public:
void Import(
   Stream^ Stream,
   String^ Format
)

Parameters

Stream

The System IO Stream to read

Format

The type of import operation to perform

Remarks

Like the Paste method, this method modifies only the minimum number of attributes necessary to ensure consistency of the image. In order to produce a valid DICOM SOP instance, many other attributes (depending on the SOP class) must be added.

All formats which can be supported by Windows via new Bitmap(Stream) or explicitly via (including JPEG 2000) are supported.

The following applies to JPEG file import:

  • The JPEG data is imported directly, and may either be stored or transmitted unchanged as a JPEG encapsulated SOP instance (1.2.840.10008.1.2.4.50), or automatically decompressed if necessary.
  • The Type parameter must be JPEG or JPG

The following applies to JPEG 2000 file import:

  • The import format must be "J2K", "JPC" or "JP2"
  • The JPEG 2000 data is imported directly, and may either be stored or transmitted unchanged as a JPEG 2000 encapsulated SOP instance (1.2.840.10008.1.2.4.90 or .91), or automatically decompressed if necessary.
  • The Type parameter must be J2K, JPC or JP2.
  • For JP2, the header is stripped

The following applies to AVI file import:

  • The Type parameter must be AVI.
  • A multi-frame DICOM image is generated.

See for details of how to write and configure your own codecs.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Matrix Method (DicomImage)

Matrix Method (DicomImage)

DicomObjects Namespace > DicomImage Class : Matrix Method
Matrix specifying how the image is displayed
Overload List
Overload | Description
Matrix(SizeF) | Matrix specifying how the image is displayed onto display of the stated size
Matrix(DicomViewer) | Matrix specifying how the image is displayed onto the specified DicomViewer
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Matrix(SizeF) Method

Matrix(SizeF) Method

DicomObjects Namespace > DicomImage Class > Matrix Method : Matrix(SizeF) Method
The size used for calculations
Matrix specifying how the image is displayed onto display of the stated size
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Matrix( _
   ByVal OutputSize As SizeF _
) As Matrix
'Usage

Dim instance As DicomImage
Dim OutputSize As SizeF
Dim value As Matrix

value = instance.Matrix(OutputSize)
public Matrix Matrix(
   SizeF OutputSize
)
public:
Matrix^ Matrix(
   SizeF OutputSize
)

Parameters

OutputSize
The size used for calculations

Return Value

Matrix
Remarks
A .NET object containing the image display information, like rotation, scale etc. The Size is important if the DicomObjects.Enums.ScaleMode of the image indicates stetching to fit the available space.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Matrix(DicomViewer) Method

Matrix(DicomViewer) Method

DicomObjects Namespace > DicomImage Class > Matrix Method : Matrix(DicomViewer) Method
DicomViewer
Matrix specifying how the image is displayed onto the specified DicomViewer
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Matrix( _
   ByVal Viewer As DicomViewer _
) As Matrix
'Usage

Dim instance As DicomImage
Dim Viewer As DicomViewer
Dim value As Matrix

value = instance.Matrix(Viewer)
public Matrix Matrix(
   DicomViewer Viewer
)
public:
Matrix^ Matrix(
   DicomViewer^ Viewer
)

Parameters

Viewer
DicomViewer

Return Value

Matrix
Remarks
A .NET object containing the image display information, like rotation, scale etc.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


MatrixBase Method

MatrixBase Method

DicomObjects Namespace > DicomImage Class : MatrixBase Method
If true, then the aspect ratio of the image is respected, so the zoom in one of the directions may be >1 if necessary to give a correctly shaped image
Matrix specifying how the image would be displayed with a Zoom of 1:1
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function MatrixBase( _
   ByVal UseAspect As Boolean _
) As Matrix
'Usage

Dim instance As DicomImage
Dim UseAspect As Boolean
Dim value As Matrix

value = instance.MatrixBase(UseAspect)
public Matrix MatrixBase(
   bool UseAspect
)
public:
Matrix^ MatrixBase(
   bool UseAspect
)

Parameters

UseAspect
If true, then the aspect ratio of the image is respected, so the zoom in one of the directions may be >1 if necessary to give a correctly shaped image

Return Value

Matrix
Remarks
The RotateState, FlipState and Angle are all used in this method.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


OrientationText Method

OrientationText Method

DicomObjects Namespace > DicomImage Class : OrientationText Method
Specify the format of the returned string

if format = "FRAME", then frame number will be returned.

if format = "ZOOM", then image zoom value will be returned.

if format = "LEFT", or "RIGHT", or "TOP" or "BOTTOM" then conresponding Direction Strings will be returned.

Return the Text of DicomLabel of LabelType = special.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function OrientationText( _
   ByVal format As String _
) As String
'Usage

Dim instance As DicomImage
Dim format As String
Dim value As String

value = instance.OrientationText(format)
public string OrientationText(
   string format
)
public:
String^ OrientationText(
   String^ format
)

Parameters

format
Specify the format of the returned string

if format = "FRAME", then frame number will be returned.

if format = "ZOOM", then image zoom value will be returned.

if format = "LEFT", or "RIGHT", or "TOP" or "BOTTOM" then conresponding Direction Strings will be returned.

Return Value

String
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Paste Method

Paste Method

DicomObjects Namespace > DicomImage Class : Paste Method
Copies the Image Data from Windows Clipboard
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Paste()
'Usage

Dim instance As DicomImage

instance.Paste()
public void Paste()
public:
void Paste();
Remarks

In order for this method to succeed, the clipboard must contain data which is, or can automatically be converted to, a device independent bitmap (DIB).

Like the Import methods, this method modifies only the minimum number of attributes necessary to ensure consistency of the image. In order to produce a valid DICOM SOP instance, many other attributes (depending on the SOP class) must be added.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


PixelValuesByFrame Method

PixelValuesByFrame Method

DicomObjects Namespace > DicomImage Class : PixelValuesByFrame Method
The 1-based frame number to retrieve
Controls whether to apply the scale/offset or Modality LUT if present
Returns an array of pixel values for a frame, optionally transformed via the modality transformation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function PixelValuesByFrame( _
   ByVal Frame As Integer, _
   ByVal ModalityTransform As Boolean _
) As Single()
'Usage

Dim instance As DicomImage
Dim Frame As Integer
Dim ModalityTransform As Boolean
Dim value() As Single

value = instance.PixelValuesByFrame(Frame, ModalityTransform)
public float[] PixelValuesByFrame(
   int Frame,
   bool ModalityTransform
)
public:
array<float>^ PixelValuesByFrame(
   int Frame,
   bool ModalityTransform
)

Parameters

Frame
The 1-based frame number to retrieve
ModalityTransform
Controls whether to apply the scale/offset or Modality LUT if present

Return Value

Array of float values representing the (possibly transformed) pixel values
Remarks
Even if ModalityTransform is false, the values are still masked to the relevent bit length and interpretted as sign/unsigned. This differs from RawPixelValuesByFrame.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


PresentationStateToCurrent Method

PresentationStateToCurrent Method

DicomObjects Namespace > DicomImage Class : PresentationStateToCurrent Method
Modifies current display properties to match the DICOM presentation state.
Overload List
Overload | Description
PresentationStateToCurrent(DicomViewer) | Modifies current display properties to match the DICOM presentation state.
PresentationStateToCurrent(DicomViewer,PresentationStateFeatures) | Modifies current display properties to match the DICOM presentation state.
PresentationStateToCurrent(Matrix,PresentationStateFeatures) | Modifies current display properties to match the DICOM presentation state.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


PresentationStateToCurrent(DicomViewer) Method

PresentationStateToCurrent(DicomViewer) Method

DicomObjects Namespace > DicomImage Class > PresentationStateToCurrent Method : PresentationStateToCurrent(DicomViewer) Method
The viewer the image is displayed in
Modifies current display properties to match the DICOM presentation state.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub PresentationStateToCurrent( _
   ByVal Viewer As DicomViewer _
)
'Usage

Dim instance As DicomImage
Dim Viewer As DicomViewer

instance.PresentationStateToCurrent(Viewer)
public void PresentationStateToCurrent(
   DicomViewer Viewer
)
public:
void PresentationStateToCurrent(
   DicomViewer^ Viewer
)

Parameters

Viewer
The viewer the image is displayed in
Remarks
This is essentially the reverse of CurrentToPresentationState. DicomObjects properties such as Scroll, Zoom and Labels are set to reflect as accurately as possible the data in the current PresentationState property. If private attributes have been added by CurrentToPresentationState, then they are utilized in this method. The viewer is used to determine the scroll values. For finer control of which properties are modified, consider one of the overrides which take a DicomObjects.Enums.PresentationStateFeatures parameter.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


PresentationStateToCurrent(DicomViewer,PresentationStateFeatures) Method

PresentationStateToCurrent(DicomViewer,PresentationStateFeatures) Method

DicomObjects Namespace > DicomImage Class > PresentationStateToCurrent Method : PresentationStateToCurrent(DicomViewer,PresentationStateFeatures) Method
The viewer ths image is displayed in
Controls which properties are updated from the presentation state.
Modifies current display properties to match the DICOM presentation state.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub PresentationStateToCurrent( _
   ByVal Viewer As DicomViewer, _
   ByVal Features As PresentationStateFeatures _
)
'Usage

Dim instance As DicomImage
Dim Viewer As DicomViewer
Dim Features As PresentationStateFeatures

instance.PresentationStateToCurrent(Viewer, Features)
public void PresentationStateToCurrent(
   DicomViewer Viewer,
   PresentationStateFeatures Features
)
public:
void PresentationStateToCurrent(
   DicomViewer^ Viewer,
   PresentationStateFeatures Features
)

Parameters

Viewer
The viewer ths image is displayed in
Features
Controls which properties are updated from the presentation state.
Remarks

This is essentially the reverse of CurrentToPresentationState. DicomObjects properties such as Scroll, Zoom and Labels are set to reflect as accurately as possible the data in the current PresentationState property. If private attributes have been added by CurrentToPresentationState, then they are utilized in this method.

The viewer is used to determine the scroll values.

Properties which are not updated from the presentation state continue to use the presentation state itself, as the PresentationStateFeaturesUsed property is updated to unset only the bits in the Features parameter

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


PresentationStateToCurrent(Matrix,PresentationStateFeatures) Method

PresentationStateToCurrent(Matrix,PresentationStateFeatures) Method

DicomObjects Namespace > DicomImage Class > PresentationStateToCurrent Method : PresentationStateToCurrent(Matrix,PresentationStateFeatures) Method
A matrix defining how the image is to be displayed.
Controls which properties are updated from the presentation state.
Modifies current display properties to match the DICOM presentation state.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub PresentationStateToCurrent( _
   ByVal Matrix As Matrix, _
   ByVal Features As PresentationStateFeatures _
)
'Usage

Dim instance As DicomImage
Dim Matrix As Matrix
Dim Features As PresentationStateFeatures

instance.PresentationStateToCurrent(Matrix, Features)
public void PresentationStateToCurrent(
   Matrix Matrix,
   PresentationStateFeatures Features
)
public:
void PresentationStateToCurrent(
   Matrix^ Matrix,
   PresentationStateFeatures Features
)

Parameters

Matrix
A matrix defining how the image is to be displayed.
Features
Controls which properties are updated from the presentation state.
Remarks

This is essentially the reverse of CurrentToPresentationState. DicomObjects. properties such as Scroll, Zoom and Labels are set to reflect as accurately as possible the data in the current PresentationState property. If private attributes have been added by CurrentToPresentationState, then they are utilized in this method.

The Matrix is used to determine the scroll values.

Properties which are not updated from the presentation state continue to use the presentation state itself, as the PresentationStateFeaturesUsed property is updated to unset only the bits in the Features parameter

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


PrinterImage Method

PrinterImage Method

DicomObjects Namespace > DicomImage Class : PrinterImage Method
Creates a copy of the image for printing or other purposes
Overload List
Overload | Description
PrinterImage(Int32,Int32,Boolean,Single,Rectangle,Boolean) | Creates a copy of the image for printing or other purposes
PrinterImage(Int32,Int32,Boolean,Single,Rectangle,Boolean,Int32) | Creates a copy of the image for printing or other purposes
PrinterImage(Int32,Int32,Boolean,Single,Rectangle,Boolean,Int32,Int32) | Creates a copy of the image for printing or other purposes
PrinterImage(Int32,Int32,Boolean,Matrix,Rectangle,Int32,Int32) | Creates a copy of the image for printing or other purposes
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


PrinterImage(Int32,Int32,Boolean,Single,Rectangle,Boolean) Method

PrinterImage(Int32,Int32,Boolean,Single,Rectangle,Boolean) Method

DicomObjects Namespace > DicomImage Class > PrinterImage Method : PrinterImage(Int32,Int32,Boolean,Single,Rectangle,Boolean) Method

Bit depth of final image (must be 8-16, but always 8 when Planes=3)

1 for monochrome and 3 for colour

Controls whether annotations are "burnt-in" to the new image

Zoom to apply to new image

The area of the original image to use

Controls whether Image Aspect Ratio is used - if true, then output pixels are square, but if false, then they retain their original aspect ratio

If ShowAnnotations is true, then this parameter is ignored and treated as true.

Creates a copy of the image for printing or other purposes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function PrinterImage( _
   ByVal Bits As Integer, _
   ByVal Planes As Integer, _
   ByVal ShowAnnotations As Boolean, _
   ByVal Zoom As Single, _
   ByVal Area As Rectangle, _
   ByVal SquarePixels As Boolean _
) As DicomImage
'Usage

Dim instance As DicomImage
Dim Bits As Integer
Dim Planes As Integer
Dim ShowAnnotations As Boolean
Dim Zoom As Single
Dim Area As Rectangle
Dim SquarePixels As Boolean
Dim value As DicomImage

value = instance.PrinterImage(Bits, Planes, ShowAnnotations, Zoom, Area, SquarePixels)
public DicomImage PrinterImage(
   int Bits,
   int Planes,
   bool ShowAnnotations,
   float Zoom,
   Rectangle Area,
   bool SquarePixels
)
public:
DicomImage^ PrinterImage(
   int Bits,
   int Planes,
   bool ShowAnnotations,
   float Zoom,
   Rectangle Area,
   bool SquarePixels
)

Parameters

Bits

Bit depth of final image (must be 8-16, but always 8 when Planes=3)

Planes

1 for monochrome and 3 for colour

ShowAnnotations

Controls whether annotations are "burnt-in" to the new image

Zoom

Zoom to apply to new image

Area

The area of the original image to use

SquarePixels

Controls whether Image Aspect Ratio is used - if true, then output pixels are square, but if false, then they retain their original aspect ratio

If ShowAnnotations is true, then this parameter is ignored and treated as true.

Return Value

DicomImage
Remarks
The copy is fully rendered and scaled to the chosen bit depth, so no further windowing is required. Only 8 bits are allowed when Planes=3 (RGB). Area refers to the original image � the size of the final image is the product of the cropped size and the chosen zoom. If the edges are given as 0, the full image is used.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


PrinterImage(Int32,Int32,Boolean,Single,Rectangle,Boolean,Int32) Method

PrinterImage(Int32,Int32,Boolean,Single,Rectangle,Boolean,Int32) Method

DicomObjects Namespace > DicomImage Class > PrinterImage Method : PrinterImage(Int32,Int32,Boolean,Single,Rectangle,Boolean,Int32) Method

Bit depth of final image (must be 8-16, but always 8 when Planes=3)

1 for monochrome and 3 for colour

Controls whether annotations are "burnt-in" to the new image

Zoom to apply to new image

The area of the original image to use

Controls whether Image Aspect Ratio is used - if true, then output pixels are square, but if false, then they retain their original aspect ratio

If ShowAnnotations is true, then this parameter is ignored and treated as true.

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

Creates a copy of the image for printing or other purposes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function PrinterImage( _
   ByVal Bits As Integer, _
   ByVal Planes As Integer, _
   ByVal ShowAnnotations As Boolean, _
   ByVal Zoom As Single, _
   ByVal Area As Rectangle, _
   ByVal SquarePixels As Boolean, _
   ByVal Frame As Integer _
) As DicomImage
'Usage

Dim instance As DicomImage
Dim Bits As Integer
Dim Planes As Integer
Dim ShowAnnotations As Boolean
Dim Zoom As Single
Dim Area As Rectangle
Dim SquarePixels As Boolean
Dim Frame As Integer
Dim value As DicomImage

value = instance.PrinterImage(Bits, Planes, ShowAnnotations, Zoom, Area, SquarePixels, Frame)
public DicomImage PrinterImage(
   int Bits,
   int Planes,
   bool ShowAnnotations,
   float Zoom,
   Rectangle Area,
   bool SquarePixels,
   int Frame
)
public:
DicomImage^ PrinterImage(
   int Bits,
   int Planes,
   bool ShowAnnotations,
   float Zoom,
   Rectangle Area,
   bool SquarePixels,
   int Frame
)

Parameters

Bits

Bit depth of final image (must be 8-16, but always 8 when Planes=3)

Planes

1 for monochrome and 3 for colour

ShowAnnotations

Controls whether annotations are "burnt-in" to the new image

Zoom

Zoom to apply to new image

Area

The area of the original image to use

SquarePixels

Controls whether Image Aspect Ratio is used - if true, then output pixels are square, but if false, then they retain their original aspect ratio

If ShowAnnotations is true, then this parameter is ignored and treated as true.

Frame

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

Return Value

DicomImage
Remarks
The copy is fully rendered and scaled to the chosen bit depth, so no further windowing is required. Only 8 bits are allowed when Planes=3 (RGB). Area refers to the original image � the size of the final image is the product of the cropped size and the chosen zoom. If the edges are given as 0, the full image is used.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


PrinterImage(Int32,Int32,Boolean,Single,Rectangle,Boolean,Int32,Int32) Method

PrinterImage(Int32,Int32,Boolean,Single,Rectangle,Boolean,Int32,Int32) Method

DicomObjects Namespace > DicomImage Class > PrinterImage Method : PrinterImage(Int32,Int32,Boolean,Single,Rectangle,Boolean,Int32,Int32) Method

Bit depth of final image (must be 8-16, but always 8 when Planes=3)

1 for monochrome and 3 for colour

Controls whether annotations are "burnt-in" to the new image

Zoom to apply to new image

The area of the original image to use

Controls whether Image Aspect Ratio is used - if true, then output pixels are square, but if false, then they retain their original aspect ratio

If ShowAnnotations is true, then this parameter is ignored and treated as true.

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

The planar configuration value of the resulting image. For use in Printing, this should be 1 as defined by DICOM rules, but if this function is used for other purposes, then 0 may be required.

Creates a copy of the image for printing or other purposes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function PrinterImage( _
   ByVal Bits As Integer, _
   ByVal Planes As Integer, _
   ByVal ShowAnnotations As Boolean, _
   ByVal Zoom As Single, _
   ByVal Area As Rectangle, _
   ByVal SquarePixels As Boolean, _
   ByVal Frame As Integer, _
   ByVal PlanarConfig As Integer _
) As DicomImage
'Usage

Dim instance As DicomImage
Dim Bits As Integer
Dim Planes As Integer
Dim ShowAnnotations As Boolean
Dim Zoom As Single
Dim Area As Rectangle
Dim SquarePixels As Boolean
Dim Frame As Integer
Dim PlanarConfig As Integer
Dim value As DicomImage

value = instance.PrinterImage(Bits, Planes, ShowAnnotations, Zoom, Area, SquarePixels, Frame, PlanarConfig)
public DicomImage PrinterImage(
   int Bits,
   int Planes,
   bool ShowAnnotations,
   float Zoom,
   Rectangle Area,
   bool SquarePixels,
   int Frame,
   int PlanarConfig
)
public:
DicomImage^ PrinterImage(
   int Bits,
   int Planes,
   bool ShowAnnotations,
   float Zoom,
   Rectangle Area,
   bool SquarePixels,
   int Frame,
   int PlanarConfig
)

Parameters

Bits

Bit depth of final image (must be 8-16, but always 8 when Planes=3)

Planes

1 for monochrome and 3 for colour

ShowAnnotations

Controls whether annotations are "burnt-in" to the new image

Zoom

Zoom to apply to new image

Area

The area of the original image to use

SquarePixels

Controls whether Image Aspect Ratio is used - if true, then output pixels are square, but if false, then they retain their original aspect ratio

If ShowAnnotations is true, then this parameter is ignored and treated as true.

Frame

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

PlanarConfig

The planar configuration value of the resulting image. For use in Printing, this should be 1 as defined by DICOM rules, but if this function is used for other purposes, then 0 may be required.

Return Value

DicomImage
Remarks
The copy is fully rendered and scaled to the chosen bit depth, so no further windowing is required. Only 8 bits are allowed when Planes=3 (RGB). Area refers to the original image � the size of the final image is the product of the cropped size and the chosen zoom. If the edges are given as 0, the full image is used.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


PrinterImage(Int32,Int32,Boolean,Matrix,Rectangle,Int32,Int32) Method

PrinterImage(Int32,Int32,Boolean,Matrix,Rectangle,Int32,Int32) Method

DicomObjects Namespace > DicomImage Class > PrinterImage Method : PrinterImage(Int32,Int32,Boolean,Matrix,Rectangle,Int32,Int32) Method

Bit depth of final image (must be 8-16, but always 8 when Planes=3)

1 for monochrome and 3 for colour

Controls whether annotations are "burnt-in" to the new image

The transform to apply to the pixels - this includes zoom etc.

The output area to be filled

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

The planar configuration value of the resulting image. For use in Printing, this should be 1 as defined by DICOM rules, but if this function is used for other purposes, then 0 may be required.

Creates a copy of the image for printing or other purposes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function PrinterImage( _
   ByVal Bits As Integer, _
   ByVal Planes As Integer, _
   ByVal ShowAnnotations As Boolean, _
   ByVal Matrix As Matrix, _
   ByVal FinalArea As Rectangle, _
   ByVal Frame As Integer, _
   ByVal PlanarConfig As Integer _
) As DicomImage
'Usage

Dim instance As DicomImage
Dim Bits As Integer
Dim Planes As Integer
Dim ShowAnnotations As Boolean
Dim Matrix As Matrix
Dim FinalArea As Rectangle
Dim Frame As Integer
Dim PlanarConfig As Integer
Dim value As DicomImage

value = instance.PrinterImage(Bits, Planes, ShowAnnotations, Matrix, FinalArea, Frame, PlanarConfig)
public DicomImage PrinterImage(
   int Bits,
   int Planes,
   bool ShowAnnotations,
   Matrix Matrix,
   Rectangle FinalArea,
   int Frame,
   int PlanarConfig
)
public:
DicomImage^ PrinterImage(
   int Bits,
   int Planes,
   bool ShowAnnotations,
   Matrix^ Matrix,
   Rectangle FinalArea,
   int Frame,
   int PlanarConfig
)

Parameters

Bits

Bit depth of final image (must be 8-16, but always 8 when Planes=3)

Planes

1 for monochrome and 3 for colour

ShowAnnotations

Controls whether annotations are "burnt-in" to the new image

Matrix

The transform to apply to the pixels - this includes zoom etc.

FinalArea

The output area to be filled

Frame

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

PlanarConfig

The planar configuration value of the resulting image. For use in Printing, this should be 1 as defined by DICOM rules, but if this function is used for other purposes, then 0 may be required.

Return Value

DicomImage
Remarks
The copy is fully rendered and scaled to the chosen bit depth, so no further windowing is required. Only 8 bits are allowed when Planes=3 (RGB). Area refers to the original image � the size of the final image is the product of the cropped size and the chosen zoom. If the edges are given as 0, the full image is used.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


RawPixelValuesByFrame Method

RawPixelValuesByFrame Method

DicomObjects Namespace > DicomImage Class : RawPixelValuesByFrame Method
The 1-based frame number to retrieve
Returns an array of raw pixel values for a frame
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function RawPixelValuesByFrame( _
   ByVal Frame As Integer _
) As Array
'Usage

Dim instance As DicomImage
Dim Frame As Integer
Dim value As Array

value = instance.RawPixelValuesByFrame(Frame)
public Array RawPixelValuesByFrame(
   int Frame
)
public:
Array^ RawPixelValuesByFrame(
   int Frame
)

Parameters

Frame
The 1-based frame number to retrieve

Return Value

Array of values representing the raw pixel values before masking, signing interpretation, or modality transformations
Remarks
For interpretted values (with or with use of the modality transformation, see PixelValuesByFrame.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Read Method (DicomImage)

Read Method (DicomImage)

DicomObjects Namespace > DicomImage Class : Read Method
Read from a file, a system IO stream or a byte array
Overload List
Overload | Description
Read(String,ReadBehaviours) | Reads from an external DICOM file
Read(Stream,ReadBehaviours) | Reads from a system IO stream
Read(Byte[],ReadBehaviours) | Reads from a Byte Array
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Read(String,ReadBehaviours) Method

Read(String,ReadBehaviours) Method

DicomObjects Namespace > DicomImage Class > Read Method : Read(String,ReadBehaviours) Method
The name of the file to read

This is passed unmodified to the operating system, and it is therefore the container's responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

The behaviours to be used when reading this stream
Reads from an external DICOM file
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Read( _
   ByVal FileName As String, _
   Optional ByVal readBehaviours As ReadBehaviours _
)
'Usage

Dim instance As DicomImage
Dim FileName As String
Dim readBehaviours As ReadBehaviours

instance.Read(FileName, readBehaviours)
public void Read(
   string FileName,
   ReadBehaviours readBehaviours
)
public:
void Read(
   String^ FileName,
   ReadBehaviours^ readBehaviours
)

Parameters

FileName
The name of the file to read

This is passed unmodified to the operating system, and it is therefore the container's responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

readBehaviours
The behaviours to be used when reading this stream
Remarks

This method can read either official "Part10" format files with the 128 byte header, or unofficial "Part5" format files without a header. Detection of the type is automatic.

The file may have been written by the Write method or by other DICOM software.

By default, pixel data is read only when it is required, greatly speeding the display of multi-frame images, and reducing memory requirements. However, a side effect of this is that any elements after the pixel data (7FE0,0010) will not be read. This should not affect most applications, but if necessary, this behavior may be over-ridden using the CloseFilesAfterReading property.

Another effect of file mapping is that files read using this method cannot be deleted until the image object is released. This method creates two references to the newly created DicomImage object (one in the collection, and one as the return value), and both must be released before the file can be deleted.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Read(Stream,ReadBehaviours) Method

Read(Stream,ReadBehaviours) Method

DicomObjects Namespace > DicomImage Class > Read Method : Read(Stream,ReadBehaviours) Method

The Stream from which to read.

ReadBehavioursObject to control individual read operation
Reads from a system IO stream
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Read( _
   ByVal Stream As Stream, _
   Optional ByVal readBehaviours As ReadBehaviours _
)
'Usage

Dim instance As DicomImage
Dim Stream As Stream
Dim readBehaviours As ReadBehaviours

instance.Read(Stream, readBehaviours)
public void Read(
   Stream Stream,
   ReadBehaviours readBehaviours
)
public:
void Read(
   Stream^ Stream,
   ReadBehaviours^ readBehaviours
)

Parameters

Stream

The Stream from which to read.

readBehaviours
ReadBehavioursObject to control individual read operation
Remarks

This method can read streams in either official "Part10" format, with the 128 byte header, or unofficial "Part5" format, without a header. Detection of the type is automatic.

The stream may have been written by the Write method or by other DICOM software.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Read(Byte[],ReadBehaviours) Method

Read(Byte[],ReadBehaviours) Method

DicomObjects Namespace > DicomImage Class > Read Method : Read(Byte[],ReadBehaviours) Method

Byte Array to read

The behaviours to be used when reading this stream

Reads from a Byte Array
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Read( _
   ByVal Array() As Byte, _
   Optional ByVal readBehaviours As ReadBehaviours _
)
'Usage

Dim instance As DicomImage
Dim Array() As Byte
Dim readBehaviours As ReadBehaviours

instance.Read(Array, readBehaviours)
public void Read(
   byte[] Array,
   ReadBehaviours readBehaviours
)
public:
void Read(
   array<byte>^ Array,
   ReadBehaviours^ readBehaviours
)

Parameters

Array

Byte Array to read

readBehaviours

The behaviours to be used when reading this stream

Remarks
Reads an array of byte, which may have been written by Write method.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


ReadURL Method (DicomImage)

ReadURL Method (DicomImage)

DicomObjects Namespace > DicomImage Class : ReadURL Method

The web address of the image to read.

Reads from Web Address
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ReadURL( _
   ByVal URL As String _
)
'Usage

Dim instance As DicomImage
Dim URL As String

instance.ReadURL(URL)
public void ReadURL(
   string URL
)
public:
void ReadURL(
   String^ URL
)

Parameters

URL

The web address of the image to read.

Remarks

A valid web address should be provided by the user. This method does not support progressive downloading (JPIP support is to be implemented).

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


ReferenceLine Method

ReferenceLine Method

DicomObjects Namespace > DicomImage Class : ReferenceLine Method

The main Image, who's position is to be shown.

Whether the intersection should be used - see remarks for details

This method returns a new DicomLabel object which represents the position of one DicomImage relative to another.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ReferenceLine( _
   ByVal Image As DicomImage, _
   ByVal Intersection As Boolean _
) As DicomLabel
'Usage

Dim instance As DicomImage
Dim Image As DicomImage
Dim Intersection As Boolean
Dim value As DicomLabel

value = instance.ReferenceLine(Image, Intersection)
public DicomLabel ReferenceLine(
   DicomImage Image,
   bool Intersection
)
public:
DicomLabel^ ReferenceLine(
   DicomImage^ Image,
   bool Intersection
)

Parameters

Image

The main Image, who's position is to be shown.

Intersection

Whether the intersection should be used - see remarks for details

Return Value

DicomLabe
Remarks

This method is used which you wish to show the relative positions of one image on another. It is typically used in CT and MRI to indicate the position of main imaging sections relative to a previously obtained localizer or �scout� image.

The method is called on the �localizer� image, and the first parameter is the main section who�s position is to be shown. The result is a new DicomLabel object which is designed to be added to the localizer image�s Labels collection. e.Graphics. if �localizer� and �main_image� are defined as DicomObjects, then the following code will add an appropriate reference line to the localizer image:

NewLabel = localizer.ReferenceLine(main_image, false)
Localizer.Labels.Add(NewLabel)

If the images are orthogonal, then the �Intersection� parameter is not used, and the DicomLabel returned will always be of type LabelType.Line, but if they are not, then it controls how this is handled:

  • If true, then the DicomLabel will still be of type LabelType.Line, representing the intersection of the two image planes.
  • If false, then the DicomLabel returned will be of type LabelType.Polygon with 4 vertices, each representing the projection of a corner of the main image onto the plane of the localizer.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


RenderToArray Method

RenderToArray Method

DicomObjects Namespace > DicomImage Class : RenderToArray Method
Render the DicomImage to array.
Overload List
Overload | Description
RenderToArray(Array,Boolean,Int32) | Render the DicomImage to array. The data returned will be exactly the same as the "presentation data" if the Image gets displayed on screen.
RenderToArray(Array,Boolean,Int32,Int32) | Render the DicomImage to array. The data returned will be exactly the same as the "presentation data" if the Image gets displayed on screen.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


RenderToArray(Array,Boolean,Int32) Method

RenderToArray(Array,Boolean,Int32) Method

DicomObjects Namespace > DicomImage Class > RenderToArray Method : RenderToArray(Array,Boolean,Int32) Method

Array to write the image presentation data to

Set Colour to True if you want the color output.

Bit depth of final data.

Render the DicomImage to array. The data returned will be exactly the same as the "presentation data" if the Image gets displayed on screen.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub RenderToArray( _
   ByVal destination As Array, _
   ByVal Colour As Boolean, _
   ByVal BitsPerSample As Integer _
)
'Usage

Dim instance As DicomImage
Dim destination As Array
Dim Colour As Boolean
Dim BitsPerSample As Integer

instance.RenderToArray(destination, Colour, BitsPerSample)
public void RenderToArray(
   Array destination,
   bool Colour,
   int BitsPerSample
)
public:
void RenderToArray(
   Array^ destination,
   bool Colour,
   int BitsPerSample
)

Parameters

destination

Array to write the image presentation data to

Colour

Set Colour to True if you want the color output.

BitsPerSample

Bit depth of final data.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


RenderToArray(Array,Boolean,Int32,Int32) Method

RenderToArray(Array,Boolean,Int32,Int32) Method

DicomObjects Namespace > DicomImage Class > RenderToArray Method : RenderToArray(Array,Boolean,Int32,Int32) Method

Array to write the image presentation data to

Set Colour to True if you want the color output.

Bit depth of final data.

Choose which frame of a Multi-Frame Image you want to render.

Render the DicomImage to array. The data returned will be exactly the same as the "presentation data" if the Image gets displayed on screen.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub RenderToArray( _
   ByVal destination As Array, _
   ByVal Colour As Boolean, _
   ByVal BitsPerSample As Integer, _
   ByVal frame As Integer _
)
'Usage

Dim instance As DicomImage
Dim destination As Array
Dim Colour As Boolean
Dim BitsPerSample As Integer
Dim frame As Integer

instance.RenderToArray(destination, Colour, BitsPerSample, frame)
public void RenderToArray(
   Array destination,
   bool Colour,
   int BitsPerSample,
   int frame
)
public:
void RenderToArray(
   Array^ destination,
   bool Colour,
   int BitsPerSample,
   int frame
)

Parameters

destination

Array to write the image presentation data to

Colour

Set Colour to True if you want the color output.

BitsPerSample

Bit depth of final data.

frame

Choose which frame of a Multi-Frame Image you want to render.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


ScreenToImage Method (DicomImage)

ScreenToImage Method (DicomImage)

DicomObjects Namespace > DicomImage Class : ScreenToImage Method
The point on the output space
The Viewer being used for display
Calculate where in image (X,Y) space, a given screen point lies
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function ScreenToImage( _
   ByVal ScreenLocation As PointF, _
   ByVal Viewer As DicomViewer _
) As Nullable(Of PointF)
'Usage

Dim instance As DicomImage
Dim ScreenLocation As PointF
Dim Viewer As DicomViewer
Dim value As Nullable(Of PointF)

value = instance.ScreenToImage(ScreenLocation, Viewer)
public virtual Nullable<PointF> ScreenToImage(
   PointF ScreenLocation,
   DicomViewer Viewer
)
public:
virtual Nullable<PointF> ScreenToImage(
   PointF ScreenLocation,
   DicomViewer^ Viewer
)

Parameters

ScreenLocation
The point on the output space
Viewer
The Viewer being used for display

Return Value

Point in 2D space if appropriate, or null, for 3D images
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


ScreenToWorld(PointF,DicomViewer) Method

ScreenToWorld(PointF,DicomViewer) Method

DicomObjects Namespace > DicomImage Class : ScreenToWorld(PointF,DicomViewer) Method
The point on the output space
The Viewer being used for display
Calculate where in real world (X,Y,Z) space, a given screen point lies
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ScreenToWorld( _
   ByVal ScreenLocation As PointF, _
   ByVal Viewer As DicomViewer _
) As Nullable(Of Point3D)
'Usage

Dim instance As DicomImage
Dim ScreenLocation As PointF
Dim Viewer As DicomViewer
Dim value As Nullable(Of Point3D)

value = instance.ScreenToWorld(ScreenLocation, Viewer)
public Nullable<Point3D> ScreenToWorld(
   PointF ScreenLocation,
   DicomViewer Viewer
)
public:
Nullable<Point3D> ScreenToWorld(
   PointF ScreenLocation,
   DicomViewer^ Viewer
)

Parameters

ScreenLocation
The point on the output space
Viewer
The Viewer being used for display

Return Value

Point in 3D space if appropriate, or null, if the necessary coordinate information is not available
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Send Method (DicomImage)

Send Method (DicomImage)

DicomObjects Namespace > DicomImage Class : Send Method
Sends an image to a remote Storage SCP
Overload List
Overload | Description
Send(String,Int32,String,String) | Sends an image to a remote Storage SCP
Send(String,Int32,String,String,IEnumerable<String>) | Sends an image to a remote Storage SCP
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Send(String,Int32,String,String) Method

Send(String,Int32,String,String) Method

DicomObjects Namespace > DicomImage Class > Send Method : Send(String,Int32,String,String) Method

Network address (as dotted notation or resolvable name) to which the image is to be sent

Port on which remote application is listening

Name of remote Application Entity

Name to quote for this Application Entity

Sends an image to a remote Storage SCP
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Send( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAE As String, _
   ByVal CalledAE As String _
) As Integer
'Usage

Dim instance As DicomImage
Dim Node As String
Dim Port As Integer
Dim CallingAE As String
Dim CalledAE As String
Dim value As Integer

value = instance.Send(Node, Port, CallingAE, CalledAE)
public int Send(
   string Node,
   int Port,
   string CallingAE,
   string CalledAE
)
public:
int Send(
   String^ Node,
   int Port,
   String^ CallingAE,
   String^ CalledAE
)

Parameters

Node

Network address (as dotted notation or resolvable name) to which the image is to be sent

Port

Port on which remote application is listening

CallingAE

Name of remote Application Entity

CalledAE

Name to quote for this Application Entity

Return Value

The status as returned by the remote application. Zero indicates success.

Remarks
This method negotiates an association, sends one image over it, and then closes it. DICOM does not allow SCPs to draw any conclusions about the relationships between images based on the opening and closing of associations, so this should never be a problem (apart from slight network inefficiency). However, there are several badly written applications in the world, which incorrectly assume that the end of an association indicates the end of a series or a study etc., and if interfacing to such a faulty implementation, it is possible to send multiple images on one association by using a DicomAssociation object, and its SendInstances methods.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Send(String,Int32,String,String,IEnumerable<String>) Method

Send(String,Int32,String,String,IEnumerable<String>) Method

DicomObjects Namespace > DicomImage Class > Send Method : Send(String,Int32,String,String,IEnumerable<String>) Method

Network address (as dotted notation or resolvable name) to which the image is to be sent

Port on which remote application is listening

Name of remote Application Entity

Name to quote for this Application Entity

A list of offered Transfer Syntaxes

Sends an image to a remote Storage SCP
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Send( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAE As String, _
   ByVal CalledAE As String, _
   ByVal OfferedTS As IEnumerable(Of String) _
) As Integer
'Usage

Dim instance As DicomImage
Dim Node As String
Dim Port As Integer
Dim CallingAE As String
Dim CalledAE As String
Dim OfferedTS As IEnumerable(Of String)
Dim value As Integer

value = instance.Send(Node, Port, CallingAE, CalledAE, OfferedTS)
public int Send(
   string Node,
   int Port,
   string CallingAE,
   string CalledAE,
   IEnumerable<string> OfferedTS
)
public:
int Send(
   String^ Node,
   int Port,
   String^ CallingAE,
   String^ CalledAE,
   IEnumerable<String^>^ OfferedTS
)

Parameters

Node

Network address (as dotted notation or resolvable name) to which the image is to be sent

Port

Port on which remote application is listening

CallingAE

Name of remote Application Entity

CalledAE

Name to quote for this Application Entity

OfferedTS

A list of offered Transfer Syntaxes

Return Value

The status as returned by the remote application. Zero indicates success.

Remarks
This method negotiates an association, sends one image over it, and then closes it. DICOM does not allow SCPs to draw any conclusions about the relationships between images based on the opening and closing of associations, so this should never be a problem (apart from slight network inefficiency). However, there are several badly written applications in the world, which incorrectly assume that the end of an association indicates the end of a series or a study etc., and if interfacing to such a faulty implementation, it is possible to send multiple images on one association by using a DicomAssociation object, and its SendInstances methods.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


SetDefaultWindows() Method

SetDefaultWindows() Method

DicomObjects Namespace > DicomImage Class : SetDefaultWindows() Method
Recalculates the default windows used by DicomObjects as if the image had just been loaded
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetDefaultWindows()
'Usage

Dim instance As DicomImage

instance.SetDefaultWindows()
public void SetDefaultWindows()
public:
void SetDefaultWindows();
Remarks
Where possible, DicomObjects sets the initial values of Width and Level using attributes (0028,1050) & (0028,1051) in the file itself, but where these are not present, it calculates the values by measuring the range of pixel values. The values may of course be subsequently changed, and this method is therefore useful either to reset to initial values, or to calculate suitable "guess" values when new images are created, or when the pixel data itself is changed.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


SetExternalShader Method

SetExternalShader Method
Example

DicomObjects Namespace > DicomImage Class : SetExternalShader Method
A precompiled pixel shader, or null to remove the existing shader
An external DirectX pixel shader to be used for custom filtering
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetExternalShader( _
   ByVal code() As Byte _
)
'Usage

Dim instance As DicomImage
Dim code() As Byte

instance.SetExternalShader(code)
public void SetExternalShader(
   byte[] code
)
public:
void SetExternalShader(
   array<byte>^ code
)

Parameters

code
A precompiled pixel shader, or null to remove the existing shader
Remarks
This is an advanced technique, and those intending to use it should contact us for guidance

To remove the shader, use this method again, with a null parameter

Example
A sample (in this case a simple Sobel) filter would be like this:
  • HLSL
// The 3D data
MyTexture2D<float> ShaderTextureFloat: register(t0);

// A simple Sampler
SamplerState Sampler : register(s0);

struct VertexShaderOutput
{
    // The calculated position in the texture (0..1) space
    float4 Position : SV_Position;

    //The position of the pixel in X,Y integers
    float2 TextureUV : TEXCOORD0;
};

float main(VertexShaderOutput input) : SV_Target
{
    float2 pos = input.TextureUV;

    // simplified Sobel filter

    float x0 = ShaderTextureFloat.SampleLevel(Sampler, pos - ddx(pos), 0);
    float x1 = ShaderTextureFloat.SampleLevel(Sampler, pos + ddx(pos), 0);
    float y0 = ShaderTextureFloat.SampleLevel(Sampler, pos - ddy(pos), 0);
    float y1 = ShaderTextureFloat.SampleLevel(Sampler, pos + ddy(pos), 0);
    return sqrt((x1 - x0) * (x1 - x0) + (y1 - y0) * (y1 - y0));
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


SetPixelData Method

SetPixelData Method

DicomObjects Namespace > DicomImage Class : SetPixelData Method
The transfer syntax of the data provided via the GetData function
User defined function to return the correct pixel data stream for the requested frame number
Method to set pixel data directly from a stream
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetPixelData( _
   ByVal TransferSyntax As String, _
   ByVal GetData As Func(Of Integer,Stream) _
)
'Usage

Dim instance As DicomImage
Dim TransferSyntax As String
Dim GetData As Func(Of Integer,Stream)

instance.SetPixelData(TransferSyntax, GetData)
public void SetPixelData(
   string TransferSyntax,
   Func<int,Stream> GetData
)
public:
void SetPixelData(
   String^ TransferSyntax,
   Func<int,Stream^>^ GetData
)

Parameters

TransferSyntax
The transfer syntax of the data provided via the GetData function
GetData
User defined function to return the correct pixel data stream for the requested frame number
Remarks
Experimental method, please contact support@medicalconnections.co.uk for more info
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


SetPixelDataAndImport Method

SetPixelDataAndImport Method

DicomObjects Namespace > DicomImage Class : SetPixelDataAndImport Method
The transfer syntax of the data provided via the GetData function
Number of frames that would get imported
User defined function to return the correct data stream to be imported
Method to import pixel data directly from a non-DICOM data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetPixelDataAndImport( _
   ByVal TransferSyntax As String, _
   ByVal FrameCount As Integer, _
   ByVal GetData As Func(Of Integer,Stream) _
)
'Usage

Dim instance As DicomImage
Dim TransferSyntax As String
Dim FrameCount As Integer
Dim GetData As Func(Of Integer,Stream)

instance.SetPixelDataAndImport(TransferSyntax, FrameCount, GetData)
public void SetPixelDataAndImport(
   string TransferSyntax,
   int FrameCount,
   Func<int,Stream> GetData
)
public:
void SetPixelDataAndImport(
   String^ TransferSyntax,
   int FrameCount,
   Func<int,Stream^>^ GetData
)

Parameters

TransferSyntax
The transfer syntax of the data provided via the GetData function
FrameCount
Number of frames that would get imported
GetData
User defined function to return the correct data stream to be imported
Remarks
Experimental method, please contact support@medicalconnections.co.uk for more info
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


SetPixelFile Method

SetPixelFile Method

DicomObjects Namespace > DicomImage Class : SetPixelFile Method

The name of the external file

Transfer Syntax of the Pixel Data

The offset in the file of the start of the first frame

The offset in the file between the start of one frame, and the start of the next

Maps an external file as the pixel data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetPixelFile( _
   ByVal FileName As String, _
   ByVal TransferSyntax As String, _
   ByVal InitialOffset As Long, _
   ByVal FrameOffset As Long _
)
'Usage

Dim instance As DicomImage
Dim FileName As String
Dim TransferSyntax As String
Dim InitialOffset As Long
Dim FrameOffset As Long

instance.SetPixelFile(FileName, TransferSyntax, InitialOffset, FrameOffset)
public void SetPixelFile(
   string FileName,
   string TransferSyntax,
   long InitialOffset,
   long FrameOffset
)
public:
void SetPixelFile(
   String^ FileName,
   String^ TransferSyntax,
   int64 InitialOffset,
   int64 FrameOffset
)

Parameters

FileName

The name of the external file

TransferSyntax

Transfer Syntax of the Pixel Data

InitialOffset

The offset in the file of the start of the first frame

FrameOffset

The offset in the file between the start of one frame, and the start of the next

Remarks
The PixelData attribute (7FE0, 0010) is set after calling this method and Pixel data is read from the specified external file only when image rendering is about to happen.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


SetScrollAndZoom Method

SetScrollAndZoom Method

DicomObjects Namespace > DicomImage Class : SetScrollAndZoom Method
The viewer that the image is displayed in
Sets the Scroll and Zoom values to values reflecting the current display
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetScrollAndZoom( _
   ByVal Viewer As DicomViewer _
)
'Usage

Dim instance As DicomImage
Dim Viewer As DicomViewer

instance.SetScrollAndZoom(Viewer)
public void SetScrollAndZoom(
   DicomViewer Viewer
)
public:
void SetScrollAndZoom(
   DicomViewer^ Viewer
)

Parameters

Viewer
The viewer that the image is displayed in
Remarks
The viewer used as a reference, and the current zoom and scroll values as used in that viewer are calculated. This is useful when the existing StretchMode is a dynamic mode such as DicomObjects.Enums.StretchModes.StretchCentred. After the calulations have been performed, the StretchMode is set to DicomObjects.Enums.StretchModes.NoStretch
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


SetSimpleMasking Method

SetSimpleMasking Method

DicomObjects Namespace > DicomImage Class : SetSimpleMasking Method
Sets the frame number of the mask frame for subtraction.
Overload List
Overload | Description
SetSimpleMasking(Int32[],MaskMode) | Sets an int array as frame numbers of the mask frames for subtraction
SetSimpleMasking(Int32,MaskMode) | Sets the frame number of the mask frame for subtraction.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


SetSimpleMasking(Int32[],MaskMode) Method

SetSimpleMasking(Int32[],MaskMode) Method

DicomObjects Namespace > DicomImage Class > SetSimpleMasking Method : SetSimpleMasking(Int32[],MaskMode) Method

Frame numbers of the frames for subtraction

The subtraction mode to use
Sets an int array as frame numbers of the mask frames for subtraction
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SetSimpleMasking( _
   ByVal Frames() As Integer, _
   ByVal mode As MaskMode _
)
'Usage

Dim instance As DicomImage
Dim Frames() As Integer
Dim mode As MaskMode

instance.SetSimpleMasking(Frames, mode)
public void SetSimpleMasking(
   int[] Frames,
   MaskMode mode
)
public:
void SetSimpleMasking(
   array<int>^ Frames,
   MaskMode mode
)

Parameters

Frames

Frame numbers of the frames for subtraction

mode
The subtraction mode to use
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


SetSimpleMasking(Int32,MaskMode) Method

SetSimpleMasking(Int32,MaskMode) Method

DicomObjects Namespace > DicomImage Class > SetSimpleMasking Method : SetSimpleMasking(Int32,MaskMode) Method

Frame number of the frame for subtraction

The subtraction mode to use
Sets the frame number of the mask frame for subtraction.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SetSimpleMasking( _
   ByVal Frame As Integer, _
   ByVal mode As MaskMode _
)
'Usage

Dim instance As DicomImage
Dim Frame As Integer
Dim mode As MaskMode

instance.SetSimpleMasking(Frame, mode)
public void SetSimpleMasking(
   int Frame,
   MaskMode mode
)
public:
void SetSimpleMasking(
   int Frame,
   MaskMode mode
)

Parameters

Frame

Frame number of the frame for subtraction

mode
The subtraction mode to use
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Spacing Method

Spacing Method

DicomObjects Namespace > DicomImage Class : Spacing Method
Get the pixel spacing of the DicomImage
Overload List
Overload | Description
Spacing() | The pixel spacing of the DicomImage
Spacing(Rectangle) | This method returns the Pixel Spacing within the region specified by Area
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Spacing() Method

Spacing() Method

DicomObjects Namespace > DicomImage Class > Spacing Method : Spacing() Method
The pixel spacing of the DicomImage
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Spacing() As SizeF
'Usage

Dim instance As DicomImage
Dim value As SizeF

value = instance.Spacing()
public SizeF Spacing()
public:
SizeF Spacing();

Return Value

The pixel spacing of the image
Remarks
The pixel size in mm.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Spacing(Rectangle) Method

Spacing(Rectangle) Method

DicomObjects Namespace > DicomImage Class > Spacing Method : Spacing(Rectangle) Method
The Area for which the spacing should be calculated
This method returns the Pixel Spacing within the region specified by Area
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Spacing( _
   ByVal Area As Rectangle _
) As SizeF
'Usage

Dim instance As DicomImage
Dim Area As Rectangle
Dim value As SizeF

value = instance.Spacing(Area)
public SizeF Spacing(
   Rectangle Area
)
public:
SizeF Spacing(
   Rectangle Area
)

Parameters

Area
The Area for which the spacing should be calculated

Return Value

The pixel spacing of the requested area
Remarks
This method returns the Pixel Spacing within a Region of the DicomImage. Note, one Image may have multiple regions with different pixel spacing values, so this method may return different values for different inputs.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


SpacingInViewer Method

SpacingInViewer Method

DicomObjects Namespace > DicomImage Class : SpacingInViewer Method
The Area for which the spacing should be calculated
The viewer for which the spacing applies
This method returns the Pixel Spacing within the region specified by Area, in a particular viewer
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function SpacingInViewer( _
   ByVal Area As Rectangle, _
   ByVal Viewer As DicomViewer _
) As SizeF
'Usage

Dim instance As DicomImage
Dim Area As Rectangle
Dim Viewer As DicomViewer
Dim value As SizeF

value = instance.SpacingInViewer(Area, Viewer)
public virtual SizeF SpacingInViewer(
   Rectangle Area,
   DicomViewer Viewer
)
public:
virtual SizeF SpacingInViewer(
   Rectangle Area,
   DicomViewer^ Viewer
)

Parameters

Area
The Area for which the spacing should be calculated
Viewer
The viewer for which the spacing applies

Return Value

The pixel spacing of the requested area
Remarks

This method returns the Pixel Spacing within a Region of the DicomImage. Note, one Image may have multiple regions with different pixel spacing values, so this method may return different values for different inputs.

Note that for non-3D images, this returns exactly the same value as Spacing(Rectangle), but that 3D images have scaling dependent on the viewer size, as autoscaling is used for such images.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


SubImage Method (DicomImage)

SubImage Method (DicomImage)

DicomObjects Namespace > DicomImage Class : SubImage Method
Creates a copy of part or all of the image
Overload List
Overload | Description
SubImage(Point,Size,Single,Int32) | Creates a copy of part or all of the image with controlled size
SubImage(Point,Size,Single,Int32,ScaleMode) | Creates a copy of part or all of the image with controlled size
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


SubImage(Point,Size,Single,Int32) Method

SubImage(Point,Size,Single,Int32) Method

DicomObjects Namespace > DicomImage Class > SubImage Method : SubImage(Point,Size,Single,Int32) Method

The left top corner point of the sub Image

The total size of the original image to capture

The zooming factor which determines the output size

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

Creates a copy of part or all of the image with controlled size
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function SubImage( _
   ByVal Offset As Point, _
   ByVal Size As Size, _
   ByVal Magnification As Single, _
   ByVal Frame As Integer _
) As DicomImage
'Usage

Dim instance As DicomImage
Dim Offset As Point
Dim Size As Size
Dim Magnification As Single
Dim Frame As Integer
Dim value As DicomImage

value = instance.SubImage(Offset, Size, Magnification, Frame)
public DicomImage SubImage(
   Point Offset,
   Size Size,
   float Magnification,
   int Frame
)
public:
DicomImage^ SubImage(
   Point Offset,
   Size Size,
   float Magnification,
   int Frame
)

Parameters

Offset

The left top corner point of the sub Image

Size

The total size of the original image to capture

Magnification

The zooming factor which determines the output size

Frame

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

Return Value

A new DicomImage
Remarks
Makes a derived image (of same basic DICOM type as the original) scaled and cropped as required. Unlike PrinterImage, the pixel data is not modified or scaled, and XSize and YSize refer to the final image size, not the input (useful for making fixed size thumbnails etc.) If the original image is flipped and/or rotated, then the SubImage will be similarly modified, and the coordinates used for the offsets and sizes apply in the rotated/flipped coordinate space. This makes it simple to select sub-images using a GUI, as the coordinates used for SubImage are compatible with those used for an "ImageTied" DicomLabel.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


SubImage(Point,Size,Single,Int32,ScaleMode) Method

SubImage(Point,Size,Single,Int32,ScaleMode) Method

DicomObjects Namespace > DicomImage Class > SubImage Method : SubImage(Point,Size,Single,Int32,ScaleMode) Method

The left top corner point of the sub Image

The total size of the original image to capture

The zooming factor which determines the output size

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

The scaling mode to use

Creates a copy of part or all of the image with controlled size
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Overridable Function SubImage( _
   ByVal Offset As Point, _
   ByVal Size As Size, _
   ByVal Magnification As Single, _
   ByVal Frame As Integer, _
   ByVal Scaling As ScaleMode _
) As DicomImage
'Usage

Dim instance As DicomImage
Dim Offset As Point
Dim Size As Size
Dim Magnification As Single
Dim Frame As Integer
Dim Scaling As ScaleMode
Dim value As DicomImage

value = instance.SubImage(Offset, Size, Magnification, Frame, Scaling)
public virtual DicomImage SubImage(
   Point Offset,
   Size Size,
   float Magnification,
   int Frame,
   ScaleMode Scaling
)
public:
virtual DicomImage^ SubImage(
   Point Offset,
   Size Size,
   float Magnification,
   int Frame,
   ScaleMode Scaling
)

Parameters

Offset

The left top corner point of the sub Image

Size

The total size of the original image to capture

Magnification

The zooming factor which determines the output size

Frame

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

Scaling

The scaling mode to use

Return Value

A new DicomImage
Remarks

Makes a derived image (of same basic DICOM type as the original) scaled and cropped as required. Size refers to the final image size, whether or not it is transformed as below.

The coordinate system used depends on the value of scaling. If ScaleMode.Image then the original image is used without rotation etc, but if ScaleMode.Output then the image is conceptually flipped, rotated etc. before applying the bounds.

This overload is now recommended in place of the earlier version without the scaling mode which is retained for backwards compatibility only.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Update() Method

Update() Method

DicomObjects Namespace > DicomImage Class : Update() Method
Causes the image to be updated
Causes the image to be updated
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Update()
'Usage

Dim instance As DicomImage

instance.Update()
public void Update()
public:
void Update();
Remarks
Forces a refresh to re-draw the image onto screen.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


WorldToImage(Point3D,DicomViewer,Int32) Method

WorldToImage(Point3D,DicomViewer,Int32) Method

DicomObjects Namespace > DicomImage Class : WorldToImage(Point3D,DicomViewer,Int32) Method
The point in real world coordinates
The Viewer being used for display
The frame to apply this calculation to
Calculate the nearest image coordinates for a point in real world (X,Y,Z) space,
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function WorldToImage( _
   ByVal WorldLocation As Point3D, _
   ByVal Viewer As DicomViewer, _
   ByVal Frame As Integer _
) As PointF
'Usage

Dim instance As DicomImage
Dim WorldLocation As Point3D
Dim Viewer As DicomViewer
Dim Frame As Integer
Dim value As PointF

value = instance.WorldToImage(WorldLocation, Viewer, Frame)
public PointF WorldToImage(
   Point3D WorldLocation,
   DicomViewer Viewer,
   int Frame
)
public:
PointF WorldToImage(
   Point3D WorldLocation,
   DicomViewer^ Viewer,
   int Frame
)

Parameters

WorldLocation
The point in real world coordinates
Viewer
The Viewer being used for display
Frame
The frame to apply this calculation to

Return Value

Image coordinates of the closest point of the image plane
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


WorldToScreen(Point3D,DicomViewer) Method

WorldToScreen(Point3D,DicomViewer) Method

DicomObjects Namespace > DicomImage Class : WorldToScreen(Point3D,DicomViewer) Method
The point on the output space
The Viewer being used to display the image
Calculate where in real world (X,Y,Z) space, a given screen point lies
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function WorldToScreen( _
   ByVal WorldLocation As Point3D, _
   ByVal Viewer As DicomViewer _
) As PointF
'Usage

Dim instance As DicomImage
Dim WorldLocation As Point3D
Dim Viewer As DicomViewer
Dim value As PointF

value = instance.WorldToScreen(WorldLocation, Viewer)
public PointF WorldToScreen(
   Point3D WorldLocation,
   DicomViewer Viewer
)
public:
PointF WorldToScreen(
   Point3D WorldLocation,
   DicomViewer^ Viewer
)

Parameters

WorldLocation
The point on the output space
Viewer
The Viewer being used to display the image

Return Value

POint in 3D space if appropriate, or null, if the necessary coordinate information is not available
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Write Method (DicomImage)

Write Method (DicomImage)

DicomObjects Namespace > DicomImage Class : Write Method
Write the data to a file, Stream or Byte Array
Overload List
Overload | Description
Write(String,String,Object) | Write the data to a file with specified transfer syntax and quality
Write(String,Boolean) | Write the image data to a file
Write(String,String) | Write the image data to a file with specified transfer syntax
Write(String) | Write the image data to a file
Write(Stream,String,Object) | Write the image data to a stream with specified transfer syntax and quality
Write(Stream,Boolean) | Write the image data to a stream
Write(Stream,String) | Write the data to a stream with specified transfer syntax
Write(Stream) | Write the data to a stream
Write(Byte[],String,Object) | Write the data to a Byte Array with specified transfer syntax and quality
Write(Byte[],Boolean) | Write the data to a Byte Array
Write(Byte[],String) | Write the image data to a Byte Array with specified transfer syntax
Write(Byte[]) | Write the image data to a Byte Array
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Write(String,String,Object) Method

Write(String,String,Object) Method

DicomObjects Namespace > DicomImage Class > Write Method : Write(String,String,Object) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The quality factor to be used.

Write the data to a file with specified transfer syntax and quality
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object _
)
'Usage

Dim instance As DicomImage
Dim FileName As String
Dim TransferSyntax As String
Dim Quality As Object

instance.Write(FileName, TransferSyntax, Quality)
public void Write(
   string FileName,
   string TransferSyntax,
   object Quality
)
public:
void Write(
   String^ FileName,
   String^ TransferSyntax,
   Object^ Quality
)

Parameters

FileName

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

TransferSyntax

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

Quality

The quality factor to be used.

Remarks

The file may subsequently be read by the Read method or by other DICOM software.

Quality is specific to the compression method being used, and is ignored for non-compressed or lossless JPEG transfer syntaxes. For Lossy JPEG, it is an integer in the range 1-100, the higher the number, the better the quality (and the larger the file), and for JPEG 2000 lossy, it is a compression ratio. Other compression methods may use this for other purposes in the future.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Write(String,Boolean) Method

Write(String,Boolean) Method

DicomObjects Namespace > DicomImage Class > Write Method : Write(String,Boolean) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the file, and an appropriate transfer syntax is used, as below.

If FALSE, the file is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

Write the image data to a file
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal isPart10 As Boolean _
)
'Usage

Dim instance As DicomImage
Dim FileName As String
Dim isPart10 As Boolean

instance.Write(FileName, isPart10)
public void Write(
   string FileName,
   bool isPart10
)
public:
void Write(
   String^ FileName,
   bool isPart10
)

Parameters

FileName

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

isPart10

If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the file, and an appropriate transfer syntax is used, as below.

If FALSE, the file is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

Remarks

The file may subsequently be read by the Read method or by other DICOM software.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Write(String,String) Method

Write(String,String) Method

DicomObjects Namespace > DicomImage Class > Write Method : Write(String,String) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

Write the image data to a file with specified transfer syntax
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal TransferSyntax As String _
)
'Usage

Dim instance As DicomImage
Dim FileName As String
Dim TransferSyntax As String

instance.Write(FileName, TransferSyntax)
public void Write(
   string FileName,
   string TransferSyntax
)
public:
void Write(
   String^ FileName,
   String^ TransferSyntax
)

Parameters

FileName

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

TransferSyntax

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

Remarks

The file may subsequently be read by the Read method or by other DICOM software.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Write(String) Method

Write(String) Method

DicomObjects Namespace > DicomImage Class > Write Method : Write(String) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Write the image data to a file
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal FileName As String _
)
'Usage

Dim instance As DicomImage
Dim FileName As String

instance.Write(FileName)
public void Write(
   string FileName
)
public:
void Write(
   String^ FileName
)

Parameters

FileName

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Remarks

The file may subsequently be read by the Read method or by other DICOM software.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Write(Stream,String,Object) Method

Write(Stream,String,Object) Method

DicomObjects Namespace > DicomImage Class > Write Method : Write(Stream,String,Object) Method

The Stream from which to read.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The quality factor to be used.

Write the image data to a stream with specified transfer syntax and quality
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal Stream As Stream, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object _
)
'Usage

Dim instance As DicomImage
Dim Stream As Stream
Dim TransferSyntax As String
Dim Quality As Object

instance.Write(Stream, TransferSyntax, Quality)
public void Write(
   Stream Stream,
   string TransferSyntax,
   object Quality
)
public:
void Write(
   Stream^ Stream,
   String^ TransferSyntax,
   Object^ Quality
)

Parameters

Stream

The Stream from which to read.

TransferSyntax

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

Quality

The quality factor to be used.

Remarks

The stream object may subsequently be read by the Read method or by other DICOM software.

Quality is specific to the compression method being used, and is ignored for non-compressed or lossless JPEG transfer syntaxes. For Lossy JPEG, it is an integer in the range 1-100, the higher the number, the better the quality (and the larger the file) , and for JPEG 2000 lossy, it is a compression ratio. Other compression methods may use this for other purposes in the future.

This method is particularly suitable for use with Delphi, which provides access to streams via classes such as TStreamAdapter.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Write(Stream,Boolean) Method

Write(Stream,Boolean) Method

DicomObjects Namespace > DicomImage Class > Write Method : Write(Stream,Boolean) Method

The Stream from which to read.

If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the stream, and an appropriate transfer syntax is used, as below.

If FALSE, the stream is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

Write the image data to a stream
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal Stream As Stream, _
   ByVal isPart10 As Boolean _
)
'Usage

Dim instance As DicomImage
Dim Stream As Stream
Dim isPart10 As Boolean

instance.Write(Stream, isPart10)
public void Write(
   Stream Stream,
   bool isPart10
)
public:
void Write(
   Stream^ Stream,
   bool isPart10
)

Parameters

Stream

The Stream from which to read.

isPart10

If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the stream, and an appropriate transfer syntax is used, as below.

If FALSE, the stream is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

Remarks
The stream object may subsequently be read by the Read method or by other DICOM software
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Write(Stream,String) Method

Write(Stream,String) Method

DicomObjects Namespace > DicomImage Class > Write Method : Write(Stream,String) Method

The Stream from which to read.

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see .

Write the data to a stream with specified transfer syntax
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal Stream As Stream, _
   ByVal TransferSyntax As String _
)
'Usage

Dim instance As DicomImage
Dim Stream As Stream
Dim TransferSyntax As String

instance.Write(Stream, TransferSyntax)
public void Write(
   Stream Stream,
   string TransferSyntax
)
public:
void Write(
   Stream^ Stream,
   String^ TransferSyntax
)

Parameters

Stream

The Stream from which to read.

TransferSyntax

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see .

Remarks
The stream object may subsequently be read by the Read method or by other DICOM software
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Write(Stream) Method

Write(Stream) Method

DicomObjects Namespace > DicomImage Class > Write Method : Write(Stream) Method

The Stream from which to read.

Write the data to a stream
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByVal Stream As Stream _
)
'Usage

Dim instance As DicomImage
Dim Stream As Stream

instance.Write(Stream)
public void Write(
   Stream Stream
)
public:
void Write(
   Stream^ Stream
)

Parameters

Stream

The Stream from which to read.

Remarks
The stream object may subsequently be read by the Read method or by other DICOM software
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Write(Byte[],String,Object) Method

Write(Byte[],String,Object) Method

DicomObjects Namespace > DicomImage Class > Write Method : Write(Byte[],String,Object) Method

Byte Array to write image data to

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see .

The quality factor to be used.

Write the data to a Byte Array with specified transfer syntax and quality
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByRef Array() As Byte, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object _
)
'Usage

Dim instance As DicomImage
Dim Array() As Byte
Dim TransferSyntax As String
Dim Quality As Object

instance.Write(Array, TransferSyntax, Quality)
public void Write(
   out byte[] Array,
   string TransferSyntax,
   object Quality
)
public:
void Write(
   [Out] array<byte>^ Array,
   String^ TransferSyntax,
   Object^ Quality
)

Parameters

Array

Byte Array to write image data to

TransferSyntax

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see .

Quality

The quality factor to be used.

Remarks

Quality is specific to the compression method being used, and is ignored for non-compressed or lossless JPEG transfer syntaxes. For Lossy JPEG, it is an integer in the range 1-100, the higher the number, the better the quality (and the larger the file) , and for JPEG 2000 lossy, it is a compression ratio. Other compression methods may use this for other purposes in the future.

Data may be read back by the corresponding Read method.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Write(Byte[],Boolean) Method

Write(Byte[],Boolean) Method

DicomObjects Namespace > DicomImage Class > Write Method : Write(Byte[],Boolean) Method

Byte Array to write image data to

If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the file, and an appropriate transfer syntax is used, as below.

If FALSE, the file is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

Write the data to a Byte Array
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByRef Array() As Byte, _
   ByVal isPart10 As Boolean _
)
'Usage

Dim instance As DicomImage
Dim Array() As Byte
Dim isPart10 As Boolean

instance.Write(Array, isPart10)
public void Write(
   out byte[] Array,
   bool isPart10
)
public:
void Write(
   [Out] array<byte>^ Array,
   bool isPart10
)

Parameters

Array

Byte Array to write image data to

isPart10

If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the file, and an appropriate transfer syntax is used, as below.

If FALSE, the file is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

Remarks
Data may be read back by the corresponding Read method.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Write(Byte[],String) Method

Write(Byte[],String) Method

DicomObjects Namespace > DicomImage Class > Write Method : Write(Byte[],String) Method

Byte Array to write image data to

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the page

Write the image data to a Byte Array with specified transfer syntax
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByRef Array() As Byte, _
   ByVal TransferSyntax As String _
)
'Usage

Dim instance As DicomImage
Dim Array() As Byte
Dim TransferSyntax As String

instance.Write(Array, TransferSyntax)
public void Write(
   out byte[] Array,
   string TransferSyntax
)
public:
void Write(
   [Out] array<byte>^ Array,
   String^ TransferSyntax
)

Parameters

Array

Byte Array to write image data to

TransferSyntax

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the page

Remarks
Data may be read back by the corresponding Read method.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Write(Byte[]) Method

Write(Byte[]) Method

DicomObjects Namespace > DicomImage Class > Write Method : Write(Byte[]) Method

Byte Array to write image data to

Write the image data to a Byte Array
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Write( _
   ByRef Array() As Byte _
)
'Usage

Dim instance As DicomImage
Dim Array() As Byte

instance.Write(Array)
public void Write(
   out byte[] Array
)
public:
void Write(
   [Out] array<byte>^ Array
)

Parameters

Array

Byte Array to write image data to

Remarks
Data may be read back by the corresponding Read method.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


DicomImage Class Properties

DicomImage Class Properties

DicomObjects Namespace : DicomImage Class

For a list of all members of this type, see DicomImage members.

Public Properties
 | Name | Description
Public Property | AccessionNumber | The Accession Number
Public Property | Angle | Controls the rotation of an image
Public Property | Area | The display area of DicomImage
Public Property | BorderPen | The Pen object for Image border
Public Property | CacheMode | Controls how the pixel data is cached
Public Property | CaptureBackColour | User defined background colour for image output of PrinterImage, Bitmap and SubImage methods Default is Black background
Public Property | CDAStyleSheet | Style sheet used for displaying encapsulated CDA
Public Property | CineFramesToDisplay | The set of frames to display for cine modes
Public Property | CineIndex | The index of the currently displayed frame when using CineMode
Public Property | CineMode | Enumerated running modes for multi-frame image
Public Property | CineRate | Controls the speed of autonomous cine runs
Public Property | CineSmoothing | Boolean property indicating whether Smoothing is applied when Cine is being displayed.
Public Property | ColourTable | The colour lookup table of DicomImage
Public Property | CubicSplineAlpha | Parameter to control the degree of smoothing. The default value is �0.75, and normal values range from �0.5 to �1.25, though higher negative values may be used to produce deliberate edge enhancement.
Public Property | DataSet | The underlying DICOM Dataset containing persistent data for the image
Public Property | DateOfBirth | Date of birth of the patient
static (Shared in Visual Basic) | DefaultModalityLUT | Default value for the ModalityLUT property
static (Shared in Visual Basic) | DefaultPresentationLUT | Default value for the PresentationLUT property
static (Shared in Visual Basic) | DefaultRealTimeCine | Controls the default for how cine images are displayed
static (Shared in Visual Basic) | DefaultVoiLUT | Default value for the VoiLUT property
Public Property | DisplayMode | Controls how the image is rendered internal before transfer to the screen
Public Property | DrawCacheMode | Specify the DrawCacheMode to control how image is drawn/cached
Public Property | ExplicitModalityLUT | An explicit modality Lookup Table to be used in place of one specified in the image or presentaiton state.
Public Property | ExplicitPresentationLUT | An explicit presentation Lookup Table to be used in place of one specified in the image or presentaiton state.
Public Property | ExplicitVOILUT | An explicit Values of Interest (VOI) Lookup Table to be used in place of one specified in the image or presentaiton state.
Public Property | FilterLength | Contains the length of the smoothing filter
Public Property | FlipState | The flip state of the image, allowing the orientation of the image, as displayed, to be altered
Public Property | Frame | Controls which frame of a multi-frame image is displayed
Public Property | FrameCount | The number of frames contained in a multi-frame image
Public Property | Gamma | A number that specifies a power
Public Property | InstanceUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Invert | Controls whether the Image will be inverted.
Public Property | Item | Overloaded. Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
static (Shared in Visual Basic) | JpipInitialSize | The size of the first request (in bytes) to make to a JPIP server.
Public Property | JpipRequestSize | The size of the requests other than the first (in bytes) to make to a JPIP server.
Public Property | Labels | Provides access to the DicomLabelCollection, items of which are to be displayed over an image.
Public Property | Level | The Window Level (also known as the centre) - which controls the greyscale mapping of a displayed image
Public Property | LevelShift | Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping
Public Property | MagnificationMode | Controls how pixels are interpolated when the image is magnified
Public Property | MaskRanges | Contains an array of DicomMaskRange objects to be applied to this image. See the DicomMaskRange object for more information on how this is used.
Public Property | MinificationMode | Controls how pixels are interpolated when the image is minified
Public Property | ModalityLUT | Enables or disables the Modality Lookup Table to be used in the DicomImage
Public Property | Name | The Name of the patient
Public Property | OriginalTs | Original Transfer syntax of the underlying DataSet
Public Property | OverlayColour | Controls how overlays embedded in the image are displayed
Public Property | OverlayVisible | Controls whether overlays embedded in the image are displayed
Public Property | PatientID | The Patient ID
Public Property | Pixels | Accesses the raw pixel data as a typed array
Public Property | PresentationLUT | Enables or disables the Presentation Lookup Table to be used in the DicomImage
Public Property | PresentationState | Support for DICOM greyscale presentation state
Public Property | PresentationStateFeaturesUsed | The presentation state features to use
Public Property | PresentationStates | Support for a list of DICOM greyscale presentation state
Public Property | RawPixels | Accesses the raw pixel data as an array
Public Property | RealTimeCine | Controls how cine images are displayed
Public Property | RenderedSize | Returns the Image display size in output (normally screen) coordinates
Public Property | RotateState | The rotation state of the image, allowing the orientation of the image, as displayed, to be altered
Public Property | RotationBehaviour | Controls the baseline positioning of an image which is not stretched to fit and is rotated
Public Property | Scroll | Controls the positioning of an image display
Public Property | SeriesDescription | Descriptions for the series
Public Property | SeriesUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Sex | Sex of the patient
Public Property | ShowLabels | Controls whether the image�s labels (annotations) are shown on screen
Public Property | ShowShutter | Controls whether image shutters (if specified in the image) are used.
Public Property | ShowUpdates | Controls whether the images is updated when image display parameters change
Public Property | Size | The dimensions of the image
Public Property | SOPClass | SOP class of the DicomDataSet.
Public Property | StretchMode | Controls the automatic zooming of an image.
Public Property | StudyDescription | Description for the study
Public Property | StudyUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Tag | A general purpose Tag for developer use
Public Property | UnsharpEnhancement | UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement
Public Property | UnsharpLength | UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement
Public Property | UserMatrix | Means to override the matrix used to display 2D images
Public Property | VoiLUT | The VOI Lookup Table to be used to display the DicomImage
Public Property | VOILUTFunction | Controls which VOILUT function to be used, default value is Linear
Public Property | VoiLUTInUse | Indicates whether a Values of Interest Lookup Table is in use
Public Property | Width | The Window "Width" - which controls the greyscale mapping of a displayed image
Public Property | WidthMultiplier | Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping
Public Property | Zoom | Controls the magnification of an image display
Top
See Also

Reference

DicomImage Class
DicomObjects Namespace


AccessionNumber Property (DicomImage)

AccessionNumber Property (DicomImage)

DicomObjects Namespace > DicomImage Class : AccessionNumber Property
The Accession Number
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AccessionNumber As String
'Usage

Dim instance As DicomImage
Dim value As String

instance.AccessionNumber = value

value = instance.AccessionNumber
public string AccessionNumber {get; set;}
public:
property String^ AccessionNumber {
   String^ get();
   void set (    String^ value);
}

Property Value

The Accession Number
Remarks
Shortcut for Attribute 0008,0050
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Angle Property (DicomImage)

Angle Property (DicomImage)

DicomObjects Namespace > DicomImage Class : Angle Property
Controls the rotation of an image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Angle As Single
'Usage

Dim instance As DicomImage
Dim value As Single

instance.Angle = value

value = instance.Angle
public float Angle {get; set;}
public:
property float Angle {
   float get();
   void set (    float value);
}
Remarks

If set to anything other than 0, then (MagnificationMode and MinificationMode, are handled internally as if they were set to DicomObjects.Enums.FilterMode.Gpu

The centre of rotation is the centre of the original image

The angle is measured in degrees, and clockwise

As for all other display features, the Scroll values continue to work in screen units and relative to the screen axes, and hence are applied after rotation

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Area Property (DicomImage)

Area Property (DicomImage)

DicomObjects Namespace > DicomImage Class : Area Property
The display area of DicomImage
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Property Area As RectangleF
'Usage

Dim instance As DicomImage
Dim value As RectangleF

instance.Area = value

value = instance.Area
public virtual RectangleF Area {get; set;}
public:
virtual property RectangleF Area {
   RectangleF get();
   void set (    RectangleF value);
}
Remarks
If set to a non-empty value, this property overrides the normal placement of images in the Rows x Columns grid in the DicomViewer by specifying the abolute position and size of the image in the viewer.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


BorderPen Property

BorderPen Property

DicomObjects Namespace > DicomImage Class : BorderPen Property
The Pen object for Image border
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BorderPen As Pen
'Usage

Dim instance As DicomImage
Dim value As Pen

instance.BorderPen = value

value = instance.BorderPen
public Pen BorderPen {get; set;}
public:
property Pen^ BorderPen {
   Pen^ get();
   void set (    Pen^ value);
}
Remarks
User defined pen object for drawing the Image border. The default color is transparent and width is zero. If set to null, this property will be reset to transparent.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


CacheMode Property (DicomImage)

CacheMode Property (DicomImage)

DicomObjects Namespace > DicomImage Class : CacheMode Property
Controls how the pixel data is cached
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CacheMode As CacheTypes
'Usage

Dim instance As DicomImage
Dim value As CacheTypes

instance.CacheMode = value

value = instance.CacheMode
public CacheTypes CacheMode {get; set;}
public:
property CacheTypes CacheMode {
   CacheTypes get();
   void set (    CacheTypes value);
}
Remarks
See DicomObjects.Enums.CacheTypes for details of the values
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


CaptureBackColour Property

CaptureBackColour Property

DicomObjects Namespace > DicomImage Class : CaptureBackColour Property
User defined background colour for image output of PrinterImage, Bitmap and SubImage methods Default is Black background
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CaptureBackColour As Color
'Usage

Dim instance As DicomImage
Dim value As Color

instance.CaptureBackColour = value

value = instance.CaptureBackColour
public Color CaptureBackColour {get; set;}
public:
property Color CaptureBackColour {
   Color get();
   void set (    Color value);
}
Remarks
Default is Black background
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


CDAStyleSheet Property

CDAStyleSheet Property

DicomObjects Namespace > DicomImage Class : CDAStyleSheet Property
Style sheet used for displaying encapsulated CDA
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CDAStyleSheet As String
'Usage

Dim instance As DicomImage
Dim value As String

instance.CDAStyleSheet = value

value = instance.CDAStyleSheet
public string CDAStyleSheet {get; set;}
public:
property String^ CDAStyleSheet {
   String^ get();
   void set (    String^ value);
}
Remarks
This is a string giving the full path to the Schema File
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


CineFramesToDisplay Property

CineFramesToDisplay Property

DicomObjects Namespace > DicomImage Class : CineFramesToDisplay Property
The set of frames to display for cine modes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CineFramesToDisplay As Integer()
'Usage

Dim instance As DicomImage
Dim value() As Integer

instance.CineFramesToDisplay = value

value = instance.CineFramesToDisplay
public int[] CineFramesToDisplay {get; set;}
public:
property array<int>^ CineFramesToDisplay {
   array<int>^ get();
   void set (    array<int>^ value);
}
Remarks
If non-null, then the contents are used in place of native frame numbers to control which frames are displayed when CineMode is not Static.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


CineIndex Property

CineIndex Property

DicomObjects Namespace > DicomImage Class : CineIndex Property
The index of the currently displayed frame when using CineMode
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CineIndex As Integer
'Usage

Dim instance As DicomImage
Dim value As Integer

instance.CineIndex = value

value = instance.CineIndex
public int CineIndex {get; set;}
public:
property int CineIndex {
   int get();
   void set (    int value);
}
Remarks

This acts as an index into CineFramesToDisplay and is therefore 0-based

If CineFramesToDisplay is null, then this property will be equal to Frame -1

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


CineMode Property

CineMode Property

DicomObjects Namespace > DicomImage Class : CineMode Property
Enumerated running modes for multi-frame image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CineMode As CineMode
'Usage

Dim instance As DicomImage
Dim value As CineMode

instance.CineMode = value

value = instance.CineMode
public CineMode CineMode {get; set;}
public:
property CineMode CineMode {
   CineMode get();
   void set (    CineMode value);
}
Remarks
All possible values are:
  • 0 - Static: The default mode. The displayed frame is selected by the Frame property, and does not change
  • 1 - Forward: A single run is made through the frames, and at the end, the value of this property reverts to Static
  • 2 - Reverse: A single run is made through the frames in reverse, and at the end (frame 0), the value of this property reverts to Static
  • 3 - Repeat: The sequence of frames runs continuously from the first, to the last, and the sequence then restarts
  • 4 - Oscillate: The sequence runs from the first frame to the last, and then back through the frames to the first, and the process then restarts
  • 5 - RepeatReverse: The sequence of frames runs continuously from the last, to the first, and the sequence then restarts
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


CineRate Property

CineRate Property

DicomObjects Namespace > DicomImage Class : CineRate Property
Controls the speed of autonomous cine runs
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CineRate As Single
'Usage

Dim instance As DicomImage
Dim value As Single

instance.CineRate = value

value = instance.CineRate
public float CineRate {get; set;}
public:
property float CineRate {
   float get();
   void set (    float value);
}
Remarks
The "true" rate as determined from the attributes of the image is multiplied by this value to give the rate at which frames are to be displayed. It is not used when CineMode has the default value of Static. The default value is 1.0
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


CineSmoothing Property

CineSmoothing Property

DicomObjects Namespace > DicomImage Class : CineSmoothing Property
Boolean property indicating whether Smoothing is applied when Cine is being displayed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CineSmoothing As Boolean
'Usage

Dim instance As DicomImage
Dim value As Boolean

instance.CineSmoothing = value

value = instance.CineSmoothing
public bool CineSmoothing {get; set;}
public:
property bool CineSmoothing {
   bool get();
   void set (    bool value);
}
Remarks
Default value is false, which speeds up the cine display with out applying smoothing. Once the cine stops, smoothing will be back on to give the user a better view of the Image.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


ColourTable Property

ColourTable Property

DicomObjects Namespace > DicomImage Class : ColourTable Property
The colour lookup table of DicomImage
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ColourTable As IList(Of Color)
'Usage

Dim instance As DicomImage
Dim value As IList(Of Color)

instance.ColourTable = value

value = instance.ColourTable
public IList<Color> ColourTable {get; set;}
public:
property IList<Color>^ ColourTable {
   IList<Color>^ get();
   void set (    IList<Color>^ value);
}

Property Value

List of System.Drawing.Color values
Remarks
This property enables developers to define and apply their own color table to Images.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


CubicSplineAlpha Property

CubicSplineAlpha Property

DicomObjects Namespace > DicomImage Class : CubicSplineAlpha Property
Parameter to control the degree of smoothing. The default value is �0.75, and normal values range from �0.5 to �1.25, though higher negative values may be used to produce deliberate edge enhancement.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CubicSplineAlpha As Single
'Usage

Dim instance As DicomImage
Dim value As Single

instance.CubicSplineAlpha = value

value = instance.CubicSplineAlpha
public float CubicSplineAlpha {get; set;}
public:
property float CubicSplineAlpha {
   float get();
   void set (    float value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


DataSet Property (DicomImage)

DataSet Property (DicomImage)

DicomObjects Namespace > DicomImage Class : DataSet Property
The underlying DICOM Dataset containing persistent data for the image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DataSet As DicomDataSet
'Usage

Dim instance As DicomImage
Dim value As DicomDataSet

instance.DataSet = value

value = instance.DataSet
public DicomDataSet DataSet {get; set;}
public:
property DicomDataSet^ DataSet {
   DicomDataSet^ get();
   void set (    DicomDataSet^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


DateOfBirth Property (DicomImage)

DateOfBirth Property (DicomImage)

DicomObjects Namespace > DicomImage Class : DateOfBirth Property
Date of birth of the patient
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DateOfBirth As Date
'Usage

Dim instance As DicomImage
Dim value As Date

instance.DateOfBirth = value

value = instance.DateOfBirth
public DateTime DateOfBirth {get; set;}
public:
property DateTime DateOfBirth {
   DateTime get();
   void set (    DateTime value);
}

Property Value

Date of birth of the patient
Remarks
A shortcut for attribute (0010, 0030)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


DefaultModalityLUT Property

DefaultModalityLUT Property

DicomObjects Namespace > DicomImage Class : DefaultModalityLUT Property
Default value for the ModalityLUT property
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property DefaultModalityLUT As Short
'Usage

Dim value As Short

DicomImage.DefaultModalityLUT = value

value = DicomImage.DefaultModalityLUT
public static short DefaultModalityLUT {get; set;}
public:
static property short DefaultModalityLUT {
   short get();
   void set (    short value);
}
Remarks
All new DicomImage objects will have this as their ModalityLUT property
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


DefaultPresentationLUT Property

DefaultPresentationLUT Property

DicomObjects Namespace > DicomImage Class : DefaultPresentationLUT Property
Default value for the PresentationLUT property
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property DefaultPresentationLUT As Short
'Usage

Dim value As Short

DicomImage.DefaultPresentationLUT = value

value = DicomImage.DefaultPresentationLUT
public static short DefaultPresentationLUT {get; set;}
public:
static property short DefaultPresentationLUT {
   short get();
   void set (    short value);
}
Remarks
All new DicomImage objects will have this as their PresentationLUT property
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


DefaultRealTimeCine Property

DefaultRealTimeCine Property

DicomObjects Namespace > DicomImage Class : DefaultRealTimeCine Property
Controls the default for how cine images are displayed
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property DefaultRealTimeCine As Boolean
'Usage

Dim value As Boolean

DicomImage.DefaultRealTimeCine = value

value = DicomImage.DefaultRealTimeCine
public static bool DefaultRealTimeCine {get; set;}
public:
static property bool DefaultRealTimeCine {
   bool get();
   void set (    bool value);
}
Remarks

If true, then frames are skipped as necessary to ensure that the required display speed is maintained. If false, then every frame is displayed in turn, even if this slows the display

This is equivalent to the "RealTimeCine" registry value

New images acquire this value for their RealTimeCine property

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


DefaultVoiLUT Property

DefaultVoiLUT Property

DicomObjects Namespace > DicomImage Class : DefaultVoiLUT Property
Default value for the VoiLUT property
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property DefaultVoiLUT As Short
'Usage

Dim value As Short

DicomImage.DefaultVoiLUT = value

value = DicomImage.DefaultVoiLUT
public static short DefaultVoiLUT {get; set;}
public:
static property short DefaultVoiLUT {
   short get();
   void set (    short value);
}
Remarks
All new DicomImage objects will have this as their VoiLUT property
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


DisplayMode Property

DisplayMode Property

DicomObjects Namespace > DicomImage Class : DisplayMode Property
Controls how the image is rendered internal before transfer to the screen
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DisplayMode As DisplayMode
'Usage

Dim instance As DicomImage
Dim value As DisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
public DisplayMode DisplayMode {get; set;}
public:
property DisplayMode DisplayMode {
   DisplayMode get();
   void set (    DisplayMode value);
}
Remarks
Although public, this is an experimental property intended for performance tuning experiments and may not be supported in future versions of DicomObjects
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


DrawCacheMode Property

DrawCacheMode Property

DicomObjects Namespace > DicomImage Class : DrawCacheMode Property
Specify the DrawCacheMode to control how image is drawn/cached
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DrawCacheMode As DrawCacheMode
'Usage

Dim instance As DicomImage
Dim value As DrawCacheMode

instance.DrawCacheMode = value

value = instance.DrawCacheMode
public DrawCacheMode DrawCacheMode {get; set;}
public:
property DrawCacheMode DrawCacheMode {
   DrawCacheMode get();
   void set (    DrawCacheMode value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


ExplicitModalityLUT Property

ExplicitModalityLUT Property

DicomObjects Namespace > DicomImage Class : ExplicitModalityLUT Property
An explicit modality Lookup Table to be used in place of one specified in the image or presentaiton state.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ExplicitModalityLUT As LookupTable
'Usage

Dim instance As DicomImage
Dim value As LookupTable

instance.ExplicitModalityLUT = value

value = instance.ExplicitModalityLUT
public LookupTable ExplicitModalityLUT {get; set;}
public:
property LookupTable^ ExplicitModalityLUT {
   LookupTable^ get();
   void set (    LookupTable^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


ExplicitPresentationLUT Property

ExplicitPresentationLUT Property

DicomObjects Namespace > DicomImage Class : ExplicitPresentationLUT Property
An explicit presentation Lookup Table to be used in place of one specified in the image or presentaiton state.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ExplicitPresentationLUT As LookupTable
'Usage

Dim instance As DicomImage
Dim value As LookupTable

instance.ExplicitPresentationLUT = value

value = instance.ExplicitPresentationLUT
public LookupTable ExplicitPresentationLUT {get; set;}
public:
property LookupTable^ ExplicitPresentationLUT {
   LookupTable^ get();
   void set (    LookupTable^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


ExplicitVOILUT Property

ExplicitVOILUT Property

DicomObjects Namespace > DicomImage Class : ExplicitVOILUT Property
An explicit Values of Interest (VOI) Lookup Table to be used in place of one specified in the image or presentaiton state.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ExplicitVOILUT As LookupTable
'Usage

Dim instance As DicomImage
Dim value As LookupTable

instance.ExplicitVOILUT = value

value = instance.ExplicitVOILUT
public LookupTable ExplicitVOILUT {get; set;}
public:
property LookupTable^ ExplicitVOILUT {
   LookupTable^ get();
   void set (    LookupTable^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


FilterLength Property

FilterLength Property

DicomObjects Namespace > DicomImage Class : FilterLength Property
Contains the length of the smoothing filter
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FilterLength As Integer
'Usage

Dim instance As DicomImage
Dim value As Integer

instance.FilterLength = value

value = instance.FilterLength
public int FilterLength {get; set;}
public:
property int FilterLength {
   int get();
   void set (    int value);
}
Remarks
This property is used when DicomImage's FilterMode is set to MovingAverage and it controls the number of pixel values used in the smoothing calculation. If length is zero then a suitable value is determined internally based on the zoom, but if FileterLenght is non-zero then 2 * FilterLength number of pixel values will be used in MovingAverage smoothing calculation.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


FlipState Property

FlipState Property

DicomObjects Namespace > DicomImage Class : FlipState Property
The flip state of the image, allowing the orientation of the image, as displayed, to be altered
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FlipState As FlipState
'Usage

Dim instance As DicomImage
Dim value As FlipState

instance.FlipState = value

value = instance.FlipState
public FlipState FlipState {get; set;}
public:
property FlipState FlipState {
   FlipState get();
   void set (    FlipState value);
}
Remarks

Check DicomImage.FlipState for all possible values.

Default values is Normal.

Only display within a DicomViewer is altered by these properties. Storage and transmission are NOT affected.

RotateState and FlipState properties interact, as for example, RotateState=180 has the same effect as FlipState=Both. Conceptually, the flip is performed first, followed by any rotation.

These properties are over-ridden if a PresentationState is applied.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Frame Property (DicomImage)

Frame Property (DicomImage)

DicomObjects Namespace > DicomImage Class : Frame Property
Controls which frame of a multi-frame image is displayed
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Frame As Integer
'Usage

Dim instance As DicomImage
Dim value As Integer

instance.Frame = value

value = instance.Frame
public int Frame {get; set;}
public:
property int Frame {
   int get();
   void set (    int value);
}

Property Value

The number of the frame to display
Remarks

Unlike other indices in DicomObjects, this is 1-based, as that is the DICOM convention - i.e. the range is from 1 to FrameCount.

If set to a value higher than FrameCount, this property is reduced modulo FrameCount, to bring it within range. Cine sequences may therefore be run repeatedly simply by incrementing Frame continuously. Alternatively, to allow multi-frame images to "play" autonomously, the CineMode property may be used.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


FrameCount Property (DicomImage)

FrameCount Property (DicomImage)

DicomObjects Namespace > DicomImage Class : FrameCount Property
The number of frames contained in a multi-frame image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property FrameCount As Integer
'Usage

Dim instance As DicomImage
Dim value As Integer

value = instance.FrameCount
public int FrameCount {get;}
public:
property int FrameCount {
   int get();
}

Property Value

The number of frames
Remarks

The actual frame displayed is controlled by the image's Frame property.

If the image does not contain a frame count, a value of 1 is returned.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Gamma Property

Gamma Property

DicomObjects Namespace > DicomImage Class : Gamma Property
A number that specifies a power
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Gamma As Single
'Usage

Dim instance As DicomImage
Dim value As Single

instance.Gamma = value

value = instance.Gamma
public float Gamma {get; set;}
public:
property float Gamma {
   float get();
   void set (    float value);
}
Remarks
Default value is 1.0F. If value of this property is not 1 then transformation is applied after rewindowing to calculate the value for output pixel data.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


InstanceUID Property (DicomImage)

InstanceUID Property (DicomImage)

DicomObjects Namespace > DicomImage Class : InstanceUID Property
Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property InstanceUID As String
'Usage

Dim instance As DicomImage
Dim value As String

instance.InstanceUID = value

value = instance.InstanceUID
public string InstanceUID {get; set;}
public:
property String^ InstanceUID {
   String^ get();
   void set (    String^ value);
}

Property Value

The Instance UID
Remarks
A shortcut for attribute (0008, 0018)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Invert Property

Invert Property

DicomObjects Namespace > DicomImage Class : Invert Property
Controls whether the Image will be inverted.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Invert As Boolean
'Usage

Dim instance As DicomImage
Dim value As Boolean

instance.Invert = value

value = instance.Invert
public bool Invert {get; set;}
public:
property bool Invert {
   bool get();
   void set (    bool value);
}
Remarks
If set to true then Image will be inverted, which means black becomes white and write becomes black. Setting this property to true has the same effect of setting Image's Width property to some negative value.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Item Property (DicomImage)

Item Property (DicomImage)

DicomObjects Namespace > DicomImage Class : Item Property
Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Overload List
Overload | Description
Item(Int32,Int32) | Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Item(Keyword) | Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Remarks
This is the default indexer to provide access to all attributes of the image. Attribute element can be accessed by "Image[Group, Element]".
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Item(Int32,Int32) Property

Item(Int32,Int32) Property

DicomObjects Namespace > DicomImage Class > Item Property : Item(Int32,Int32) Property

The group index of a data element.

The element index of a data element.

Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal Group As Integer, _
   ByVal Element As Integer _
) As DicomAttribute
'Usage

Dim instance As DicomImage
Dim Group As Integer
Dim Element As Integer
Dim value As DicomAttribute

value = instance.Item(Group, Element)
public DicomAttribute Item(
   int Group,
   int Element
) {get;}
public:
property DicomAttribute^ Item {
   DicomAttribute^ get(int Group, int Element);
}

Parameters

Group

The group index of a data element.

Element

The element index of a data element.

Remarks
This is the default indexer to provide access to all attributes of the image. Attribute element can be accessed by "Image[Group, Element]".
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


Item(Keyword) Property

Item(Keyword) Property

DicomObjects Namespace > DicomImage Class > Item Property : Item(Keyword) Property
The Keyword of the DicomAttribute
Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal Keyword As Keyword _
) As DicomAttribute
'Usage

Dim instance As DicomImage
Dim Keyword As Keyword
Dim value As DicomAttribute

value = instance.Item(Keyword)
public DicomAttribute Item(
   Keyword Keyword
) {get;}
public:
property DicomAttribute^ Item {
   DicomAttribute^ get(Keyword Keyword);
}

Parameters

Keyword
The Keyword of the DicomAttribute
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members
Overload List


JpipInitialSize Property

JpipInitialSize Property

DicomObjects Namespace > DicomImage Class : JpipInitialSize Property
The size of the first request (in bytes) to make to a JPIP server.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property JpipInitialSize As Integer
'Usage

Dim value As Integer

DicomImage.JpipInitialSize = value

value = DicomImage.JpipInitialSize
public static int JpipInitialSize {get; set;}
public:
static property int JpipInitialSize {
   int get();
   void set (    int value);
}
Remarks
Lower values give a lower latency, but higher values are more efficient.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


JpipRequestSize Property

JpipRequestSize Property

DicomObjects Namespace > DicomImage Class : JpipRequestSize Property
The size of the requests other than the first (in bytes) to make to a JPIP server.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property JpipRequestSize As Integer
'Usage

Dim instance As DicomImage
Dim value As Integer

instance.JpipRequestSize = value

value = instance.JpipRequestSize
public int JpipRequestSize {get; set;}
public:
property int JpipRequestSize {
   int get();
   void set (    int value);
}
Remarks

Lower values give a lower latency, but higher values are more efficient. The value actually used is increased by 25% each request, so that later requests are larger.

The value is actually held at the dataset level, and so is shared between images which share a DataSet

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Labels Property

Labels Property

DicomObjects Namespace > DicomImage Class : Labels Property
Provides access to the DicomLabelCollection, items of which are to be displayed over an image.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Labels As DicomLabelCollection
'Usage

Dim instance As DicomImage
Dim value As DicomLabelCollection

instance.Labels = value

value = instance.Labels
public DicomLabelCollection Labels {get; set;}
public:
property DicomLabelCollection^ Labels {
   DicomLabelCollection^ get();
   void set (    DicomLabelCollection^ value);
}
Remarks
If ShowLabels is true, then the labels in this collection are displayed over the image. The labels are also used if the image is captured to a secondary capture image.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Level Property (DicomImage)

Level Property (DicomImage)

DicomObjects Namespace > DicomImage Class : Level Property
The Window Level (also known as the centre) - which controls the greyscale mapping of a displayed image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Level As Single
'Usage

Dim instance As DicomImage
Dim value As Single

instance.Level = value

value = instance.Level
public float Level {get; set;}
public:
property float Level {
   float get();
   void set (    float value);
}

Property Value

The Window Level (also known as the centre)
Remarks

Width and Level are the parameters that control the grey-scale mapping from the original pixel data to the screen. Following the normal convention, the grey scale ranges from level-width/2 to level+width/2. Note that re-scale values present in some SOP classes are used for the purposes of this mapping, but the native data are not altered, and other operations such as obtaining the Pixels are unaffected.

Windowing using these values applies now also to colour (RGB, YBR & COLOR PALETTE images, which by default have Width=255 and Level=128)

These values are initialised from the suggested values in the DICOM data, if present, but if not present, then reasonable initial values are calculated from the pixel data itself.

These values are regarded as transitory, and therefore, when an image is written, they are not written back into the DICOM data. If this behaviour is required, then code similar to this should be included prior to the write:

Image.Attributes.Add(&h0028,&h1050), Image.Level Image.Attributes.Add(&h0028,&h1051), Image.Width

Width and Level are ignored under the following circumstances:

  • When a PresentationState is applied to the image
  • When the image contains a "Values of Interest Lookup Table" (VOILUT), as this takes the place of windowing

In the later case, the VOI LUT can be ignored (and width and level used), by setting the image�s VOILUT property to 0.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


LevelShift Property

LevelShift Property

DicomObjects Namespace > DicomImage Class : LevelShift Property
Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LevelShift As Single
'Usage

Dim instance As DicomImage
Dim value As Single

instance.LevelShift = value

value = instance.LevelShift
public float LevelShift {get; set;}
public:
property float LevelShift {
   float get();
   void set (    float value);
}
Remarks

Width and Level are ignored when a VOI LUT is in use (VoiLUTInUse is true), but this property, together with WidthMultiplier provides an alternative means to allow users to have some control over the display without having to disable the VOILUT completely

The mechanism used is that the entire lookup table is shifted (in original image units) by LevelShift units, then widended or narrowed around its mid-point (where it crosses the mid-point of the output space) by a factor of WidthMultiplier.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


MagnificationMode Property

MagnificationMode Property

DicomObjects Namespace > DicomImage Class : MagnificationMode Property
Controls how pixels are interpolated when the image is magnified
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MagnificationMode As FilterMode
'Usage

Dim instance As DicomImage
Dim value As FilterMode

instance.MagnificationMode = value

value = instance.MagnificationMode
public FilterMode MagnificationMode {get; set;}
public:
property FilterMode MagnificationMode {
   FilterMode get();
   void set (    FilterMode value);
}
Remarks
This property controls how DicomObjects handles magnification of images, either for display or other uses such as PrinterImage. The FilterMode enumerations (used for MagnificationMode and MinificationMode) are:
  • Default: For MagnificationMode, this acts identically to Replicate. This behaviour is the default, and is designed to minimise regulatory issues by doing the minimum necessary to display all pixel data, without adding extra "image processing".
  • Replicate: If zooming up is necessary, then pixels are simply replicated, giving a possibly "blocky" but honest representation of the pixel data. For minification, rows and columns are simply omitted as necessary.
  • BSpline: This smoothing procedure interpolates using a Cubic B-Spline, which has the advantage of guaranteeing continuity in both the first and second differentials of the image, in both directions. No other parameters are used in this smoothing method, which produces good visual results, though some users find them a little too "smoothed".
  • CubicSpline: This is similar to the B-Spline described above, but uses an additional parameter (CubicSplineAlpha) to control the degree of smoothing or edge enhancement. The default value is "�0.75", and normal values range from "�0.5" to "�1.25", though higher negative values may be used to produce deliberate edge enhancement, though generally, UnsharpLength and UnsharpEnhancement should be used for this purpose, as they are independent of the smoothing method.
  • MovingAverage: This mode is most applicable when zoom is less than 1, and calculates pixels values as a weighted average of the surrounding values. The number of values used for this calculation depends on the value of FilterLength. If FilterLength is 0 (the default), then a suitable value is determined internally, based on the zoom (approximately 2/ActualZoom), but if FilterLength is non-zero then 2*FilterLength values are used.
  • GDI (Graphical Device Intergace): This mode uses the interinsic capabilities of modern display hardware and software to leave the interpolation of the image to such systems. In practice, it is generally similar on most systems to a DicomObjects.Enums.FilterMode.BSpline, and should, particularly for large format display be the most efficient. However, experience shows that some graphic cards perform quite badly in this mode, especially in 64 bit mode, so practical testing is advised.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


MaskRanges Property

MaskRanges Property

DicomObjects Namespace > DicomImage Class : MaskRanges Property

Contains an array of DicomMaskRange objects to be applied to this image.

See the DicomMaskRange object for more information on how this is used.

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MaskRanges As DicomMaskRange()
'Usage

Dim instance As DicomImage
Dim value() As DicomMaskRange

instance.MaskRanges = value

value = instance.MaskRanges
public DicomMaskRange[] MaskRanges {get; set;}
public:
property array<DicomMaskRange^>^ MaskRanges {
   array<DicomMaskRange^>^ get();
   void set (    array<DicomMaskRange^>^ value);
}
Remarks
If this property is changed, then the internal caches are cleared automatically, but if you change individual elements of the array without chaning the array itself, then it is necessary to call ClearCaches explicitly.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


MinificationMode Property

MinificationMode Property

DicomObjects Namespace > DicomImage Class : MinificationMode Property
Controls how pixels are interpolated when the image is minified
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MinificationMode As FilterMode
'Usage

Dim instance As DicomImage
Dim value As FilterMode

instance.MinificationMode = value

value = instance.MinificationMode
public FilterMode MinificationMode {get; set;}
public:
property FilterMode MinificationMode {
   FilterMode get();
   void set (    FilterMode value);
}
Remarks
This property controls how DicomObjects handles minification of images, either for display or other uses such as PrinterImage. The FilterMode enumerations (used for MagnificationMode and MinificationMode) are:
  • Default: For MinificationMode, this acts identically to MovingAverage. This behaviour is the default, and is deigned to minimise regulatory issues by doing the minimum necessary to display all pixel data, without adding extra "image processing".
  • Replicate: If zooming up is necessary, then pixels are simply replicated, giving a possibly "blocky" but honest representation of the pixel data. For minification, rows and columns are simply omitted as necessary.
  • BSpline: This smoothing procedure interpolates using a Cubic B-Spline, which has the advantage of guaranteeing continuity in both the first and second differentials of the image, in both directions. No other parameters are used in this smoothing method, which produces good visual results, though some users find them a little too "smoothed".
  • CubicSpline: This is similar to the B-Spline described above, but uses an additional parameter (CubicSplineAlpha) to control the degree of smoothing or edge enhancement. The default value is "�0.75", and normal values range from "�0.5" to "�1.25", though higher negative values may be used to produce deliberate edge enhancement, though generally, UnsharpLength and UnsharpEnhancement should be used for this purpose, as they are independent of the smoothing method.
  • MovingAverage: This mode is most applicable when zoom is less than 1, and calculates pixels values as a weighted average of the surrounding values. The number of values used for this calculation depends on the value of FilterLength. If FilterLength is 0 (the default), then a suitable value is determined internally, based on the zoom (approximately 2/ActualZoom), but if FilterLength is non-zero then 2*FilterLength values are used.
  • GDI (Graphical Device Intergace): This mode uses the interinsic capabilities of modern display hardware and software to leave the interpolation of the image to such systems. In practice, it is generally similar on most systems to a DicomObjects.Enums.FilterMode.BSpline, and should, particularly for large format display be the most efficient. However, experience shows that some graphic cards perform quite badly in this mode, especially in 64 bit mode, so practical testing is advised.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


ModalityLUT Property

ModalityLUT Property

DicomObjects Namespace > DicomImage Class : ModalityLUT Property
Enables or disables the Modality Lookup Table to be used in the DicomImage
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ModalityLUT As Short
'Usage

Dim instance As DicomImage
Dim value As Short

instance.ModalityLUT = value

value = instance.ModalityLUT
public short ModalityLUT {get; set;}
public:
property short ModalityLUT {
   short get();
   void set (    short value);
}

Property Value

The index of the modality lookup table to use
Remarks

DICOM allows multiple VOI and presentation Lookup Tables (LUTs) in images, and the user may select whichever they require. These properties provide that choice, and the value 0 may be used to disable a particular type of LUT.

Only one Modality LUT is allowed, so the only meaningful values for ModalityLUT are 0 and 1, but the other two may range from 0 to the number of such LUTs in the image. Value beyond the available range are treated as 0.

For Modality LUT, the default value is all 1, indicating that the Lookup Table, if present, should be used.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Name Property (DicomImage)

Name Property (DicomImage)

DicomObjects Namespace > DicomImage Class : Name Property
The Name of the patient
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As DicomImage
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

The Name of the patient
Remarks

A shortcut for attribute (0010,0010).

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


OriginalTs Property (DicomImage)

OriginalTs Property (DicomImage)

DicomObjects Namespace > DicomImage Class : OriginalTs Property
Original Transfer syntax of the underlying DataSet
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property OriginalTs As String
'Usage

Dim instance As DicomImage
Dim value As String

value = instance.OriginalTs
public string OriginalTs {get;}
public:
property String^ OriginalTs {
   String^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


OverlayColour Property

OverlayColour Property

DicomObjects Namespace > DicomImage Class : OverlayColour Property
Controls how overlays embedded in the image are displayed
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property OverlayColour As Color()
'Usage

Dim instance As DicomImage
Dim value() As Color

value = instance.OverlayColour
public Color[] OverlayColour {get;}
public:
property array<Color>^ OverlayColour {
   array<Color>^ get();
}

Property Value

Array of 16 System.Drawing.Colorelements, one for each possible overlay plane
Remarks

DICOM defines up to 16 overlay planes embedded in an image, using group number 6000, 6002, 6004�601E, and these properties allow the developer to choose which to display. Each is a simple single bit mask, and is displayed if the appropriate OverlayVisible property is true, using the associated OverlayColour.

The source of the data for such overlays can be either unused bits in the pixel data, or separate elements, but this is handled internally by DicomObjects, and all such overlays are handled identically.

The OverlayIDs are numbered from 0 to 15, and so are related to the group numbers as follows:

OverlayID=(group number � 0x6000) / 2

Or put another way

Group number=OverlayID * 2 + 0x6000

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


OverlayVisible Property

OverlayVisible Property

DicomObjects Namespace > DicomImage Class : OverlayVisible Property
Controls whether overlays embedded in the image are displayed
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property OverlayVisible As Boolean()
'Usage

Dim instance As DicomImage
Dim value() As Boolean

value = instance.OverlayVisible
public bool[] OverlayVisible {get;}
public:
property array<bool>^ OverlayVisible {
   array<bool>^ get();
}

Property Value

Array of 16 elements, one for each possible overlay plane
Remarks

DICOM defines up to 16 overlay planes embedded in an image, using group number 6000, 6002, 6004�601E, and these properties allow the developer to choose which to display. Each is a simple single bit mask, and is displayed if the appropriate OverlayVisible property is true, using the associated OverlayColour.

The source of the data for such overlays can be either unused bits in the pixel data, or separate elements, but this is handled internally by DicomObjects, and all such overlays are handled identically.

The OverlayIDs are numbered from 1 to 15, and so are related to the group numbers as follows:

OverlayID=(group number � 0x6000) / 2

Or put another way

Group number=OverlayID * 2 + 0x6000

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


PatientID Property (DicomImage)

PatientID Property (DicomImage)

DicomObjects Namespace > DicomImage Class : PatientID Property
The Patient ID
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PatientID As String
'Usage

Dim instance As DicomImage
Dim value As String

instance.PatientID = value

value = instance.PatientID
public string PatientID {get; set;}
public:
property String^ PatientID {
   String^ get();
   void set (    String^ value);
}

Property Value

The Patient ID
Remarks
A shortcut for attribute (0010, 0020)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Pixels Property

Pixels Property

DicomObjects Namespace > DicomImage Class : Pixels Property
Accesses the raw pixel data as a typed array
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Pixels As Object
'Usage

Dim instance As DicomImage
Dim value As Object

instance.Pixels = value

value = instance.Pixels
public object Pixels {get; set;}
public:
property Object^ Pixels {
   Object^ get();
   void set (    Object^ value);
}
Remarks

This returns an array of either bytes or short or long integers, depending on the size of the native data. The data returned is unaffected by the display parameters.

The first two dimensions of the array returned are those of the image itself, the third being the number of frames (as returned by FrameCount).

If the data has more than one sample per pixel (e.Graphics. RGB images), then the format of the array returned depends on the planar configuration (0028,0006). If this is 0 (colour-by-pixel), then the 1st (horizontal) dimension of the array is multiplied by the number of samples, whereas if the planar configuration is 1 (colour-by-plane), then it is the 2nd (vertical) dimension that is increased. This ensures that each �row� of pixels remains intact.

When writing to this property, either a 1, 2 or 3 dimensional array will be accepted, and will be interpreted as a byte or word stream, varying the first dimension fastest, then the others in order.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


PresentationLUT Property

PresentationLUT Property

DicomObjects Namespace > DicomImage Class : PresentationLUT Property
Enables or disables the Presentation Lookup Table to be used in the DicomImage
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PresentationLUT As Short
'Usage

Dim instance As DicomImage
Dim value As Short

instance.PresentationLUT = value

value = instance.PresentationLUT
public short PresentationLUT {get; set;}
public:
property short PresentationLUT {
   short get();
   void set (    short value);
}

Property Value

The index of the Presentation LUT to use
Remarks

DICOM allows multiple VOI and presentation Lookup Tables (LUTs) in images, and the user may select whichever they require. These properties provide that choice, and the value 0 may be used to disable a particular type of LUT. Only one Modality LUT is allowed, so the only meaningful values for ModalityLUT are 0 and 1, but the other two may range from 0 to the number of such LUTs in the image. Value beyond the available range are treated as 0.

The default values are all 1, indicating that the first VOI Lookup Table, if present, should be used.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


PresentationState Property (DicomImage)

PresentationState Property (DicomImage)

DicomObjects Namespace > DicomImage Class : PresentationState Property
Support for DICOM greyscale presentation state
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PresentationState As DicomDataSet
'Usage

Dim instance As DicomImage
Dim value As DicomDataSet

instance.PresentationState = value

value = instance.PresentationState
public DicomDataSet PresentationState {get; set;}
public:
property DicomDataSet^ PresentationState {
   DicomDataSet^ get();
   void set (    DicomDataSet^ value);
}
Remarks
When this property is set to an existing DicomDataSet containing a valid DICOM greyscale presentation state, all the normal display parameters (Zoom, Scroll, Width & Level etc.) are over-ridden, and the display is determines solely by the presentation state as defined in DICOM supplement 33.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


PresentationStateFeaturesUsed Property

PresentationStateFeaturesUsed Property

DicomObjects Namespace > DicomImage Class : PresentationStateFeaturesUsed Property
The presentation state features to use
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PresentationStateFeaturesUsed As PresentationStateFeatures
'Usage

Dim instance As DicomImage
Dim value As PresentationStateFeatures

instance.PresentationStateFeaturesUsed = value

value = instance.PresentationStateFeaturesUsed
public PresentationStateFeatures PresentationStateFeaturesUsed {get; set;}
public:
property PresentationStateFeatures PresentationStateFeaturesUsed {
   PresentationStateFeatures get();
   void set (    PresentationStateFeatures value);
}
Remarks

Features not included will be controlled by standard DicomImage properties

The default value is DicomObjects.Enums.PresentationStateFeatures.All

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


PresentationStates Property

PresentationStates Property

DicomObjects Namespace > DicomImage Class : PresentationStates Property
Support for a list of DICOM greyscale presentation state
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PresentationStates As DicomDataSetCollection
'Usage

Dim instance As DicomImage
Dim value As DicomDataSetCollection

instance.PresentationStates = value

value = instance.PresentationStates
public DicomDataSetCollection PresentationStates {get; set;}
public:
property DicomDataSetCollection^ PresentationStates {
   DicomDataSetCollection^ get();
   void set (    DicomDataSetCollection^ value);
}
Remarks
This property is for user to provide a list of PresentationStates for matching. If the Image's PresentationState property is null then the first matching item from this list will get used.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


RawPixels Property (DicomImage)

RawPixels Property (DicomImage)

DicomObjects Namespace > DicomImage Class : RawPixels Property
Accesses the raw pixel data as an array
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RawPixels As Array
'Usage

Dim instance As DicomImage
Dim value As Array

instance.RawPixels = value

value = instance.RawPixels
public Array RawPixels {get; set;}
public:
property Array^ RawPixels {
   Array^ get();
   void set (    Array^ value);
}
Remarks

This returns an array containing one element per frame. The data returned is unaffected by the display parameters.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


RealTimeCine Property

RealTimeCine Property

DicomObjects Namespace > DicomImage Class : RealTimeCine Property
Controls how cine images are displayed
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RealTimeCine As Boolean
'Usage

Dim instance As DicomImage
Dim value As Boolean

instance.RealTimeCine = value

value = instance.RealTimeCine
public bool RealTimeCine {get; set;}
public:
property bool RealTimeCine {
   bool get();
   void set (    bool value);
}
Remarks

If true, then frames are skipped as necessary to ensure that the required display speed is maintained. If false, then every frame is displayed in turn, even if this slows the display

This is equivalent to the "RealTimeCine" registry value

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


RenderedSize Property (DicomImage)

RenderedSize Property (DicomImage)

DicomObjects Namespace > DicomImage Class : RenderedSize Property
Returns the Image display size in output (normally screen) coordinates
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property RenderedSize As Size
'Usage

Dim instance As DicomImage
Dim value As Size

value = instance.RenderedSize
public virtual Size RenderedSize {get;}
public:
virtual property Size RenderedSize {
   Size get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


RotateState Property

RotateState Property

DicomObjects Namespace > DicomImage Class : RotateState Property
The rotation state of the image, allowing the orientation of the image, as displayed, to be altered
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RotateState As RotateState
'Usage

Dim instance As DicomImage
Dim value As RotateState

instance.RotateState = value

value = instance.RotateState
public RotateState RotateState {get; set;}
public:
property RotateState RotateState {
   RotateState get();
   void set (    RotateState value);
}
Remarks

Check RotateState for all possible values.

Default values is Normal.

Only display within a DicomViewer is altered by these properties. Storage and transmission are NOT affected.

RotateState and FlipState properties interact, as for example, RotateState=180 has the same effect as FlipState=Both. Conceptually, the flip is performed first, followed by any rotation.

These properties are over-ridden if a PresentationState is applied.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


RotationBehaviour Property

RotationBehaviour Property

DicomObjects Namespace > DicomImage Class : RotationBehaviour Property
Controls the baseline positioning of an image which is not stretched to fit and is rotated
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RotationBehaviour As RotationBehaviour
'Usage

Dim instance As DicomImage
Dim value As RotationBehaviour

instance.RotationBehaviour = value

value = instance.RotationBehaviour
public RotationBehaviour RotationBehaviour {get; set;}
public:
property RotationBehaviour RotationBehaviour {
   RotationBehaviour get();
   void set (    RotationBehaviour value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Scroll Property

Scroll Property

DicomObjects Namespace > DicomImage Class : Scroll Property
Controls the positioning of an image display
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Scroll As PointF
'Usage

Dim instance As DicomImage
Dim value As PointF

instance.Scroll = value

value = instance.Scroll
public PointF Scroll {get; set;}
public:
property PointF Scroll {
   PointF get();
   void set (    PointF value);
}

Property Value

The offset to use for display
Remarks

Together with Zoom, this determines the display of an image, which is magnified by 'Zoom' and then displaced Scroll.X pixels to the left and Scroll.Y pixels up. Zoom and Scroll are ignored if the containing control's StretchMode property is true.

In order to find the values used at any given time, even if StretchToFit is true, use the Matrix method to get the ActualScrollX, ActualScrollY and ActualZoom which are used in the COM version.

This property is over-ridden if a PresentationState is applied.

If the viewer in which the image is held has
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


SeriesDescription Property (DicomImage)

SeriesDescription Property (DicomImage)

DicomObjects Namespace > DicomImage Class : SeriesDescription Property
Descriptions for the series
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SeriesDescription As String
'Usage

Dim instance As DicomImage
Dim value As String

instance.SeriesDescription = value

value = instance.SeriesDescription
public string SeriesDescription {get; set;}
public:
property String^ SeriesDescription {
   String^ get();
   void set (    String^ value);
}

Property Value

The Series Description
Remarks

Provides human readable descriptions of the Study returned by a query, or relating to an image. They correspond to attribute (0008, 103E).

The usefulness is limited by the fact that not all equipment provides descriptions in its SOP instances, and even if it does, they may not be available through Query/Retrieve. For instance the RSNA CTN (up to and including version 2.8) supports the study description, but fails to index and provide the series description.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


SeriesUID Property (DicomImage)

SeriesUID Property (DicomImage)

DicomObjects Namespace > DicomImage Class : SeriesUID Property
Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SeriesUID As String
'Usage

Dim instance As DicomImage
Dim value As String

instance.SeriesUID = value

value = instance.SeriesUID
public string SeriesUID {get; set;}
public:
property String^ SeriesUID {
   String^ get();
   void set (    String^ value);
}

Property Value

The Series UID
Remarks
A shortcut for the attribute (0020, 000E).
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Sex Property (DicomImage)

Sex Property (DicomImage)

DicomObjects Namespace > DicomImage Class : Sex Property
Sex of the patient
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Sex As String
'Usage

Dim instance As DicomImage
Dim value As String

instance.Sex = value

value = instance.Sex
public string Sex {get; set;}
public:
property String^ Sex {
   String^ get();
   void set (    String^ value);
}

Property Value

Sex of the patient
Remarks
A shortcut for attribute (0010, 0040)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


ShowLabels Property (DicomImage)

ShowLabels Property (DicomImage)

DicomObjects Namespace > DicomImage Class : ShowLabels Property
Controls whether the image�s labels (annotations) are shown on screen
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ShowLabels As Boolean
'Usage

Dim instance As DicomImage
Dim value As Boolean

instance.ShowLabels = value

value = instance.ShowLabels
public bool ShowLabels {get; set;}
public:
property bool ShowLabels {
   bool get();
   void set (    bool value);
}
Remarks

If set false, then the DicomLabel objects in the image�s Labels collection are not displayed, and are not incorporated into any captured versions, but they remain present, and may be redisplayed by setting this property to true.

Unlike other label manipulations, altering this property does cause the display to be updated to include or exclude the annotations as appropriate.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


ShowShutter Property

ShowShutter Property

DicomObjects Namespace > DicomImage Class : ShowShutter Property
Controls whether image shutters (if specified in the image) are used.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ShowShutter As Boolean
'Usage

Dim instance As DicomImage
Dim value As Boolean

instance.ShowShutter = value

value = instance.ShowShutter
public bool ShowShutter {get; set;}
public:
property bool ShowShutter {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


ShowUpdates Property

ShowUpdates Property

DicomObjects Namespace > DicomImage Class : ShowUpdates Property
Controls whether the images is updated when image display parameters change
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ShowUpdates As Boolean
'Usage

Dim instance As DicomImage
Dim value As Boolean

instance.ShowUpdates = value

value = instance.ShowUpdates
public bool ShowUpdates {get; set;}
public:
property bool ShowUpdates {
   bool get();
   void set (    bool value);
}
Remarks
Set this property false before making multiple changes to an image, e.Graphics. Zoom, Scroll and Windowing, then set true once changes are complete. This will ensure that only a single screen update occurs.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Size Property (DicomImage)

Size Property (DicomImage)

DicomObjects Namespace > DicomImage Class : Size Property
The dimensions of the image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Size As Size
'Usage

Dim instance As DicomImage
Dim value As Size

value = instance.Size
public Size Size {get;}
public:
property Size Size {
   Size get();
}
Remarks
This property provides access to the horizontal (Size.Width) and vertical dimensions (Size.Height) of the image. Dimensions are 32-bit Integers.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


SOPClass Property (DicomImage)

SOPClass Property (DicomImage)

DicomObjects Namespace > DicomImage Class : SOPClass Property
SOP class of the DicomDataSet.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SOPClass As String
'Usage

Dim instance As DicomImage
Dim value As String

instance.SOPClass = value

value = instance.SOPClass
public string SOPClass {get; set;}
public:
property String^ SOPClass {
   String^ get();
   void set (    String^ value);
}

Property Value

The SOP class UID
Remarks
Shortcut for attribute (0008, 0016).
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


StretchMode Property

StretchMode Property

DicomObjects Namespace > DicomImage Class : StretchMode Property
Controls the automatic zooming of an image.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property StretchMode As StretchModes
'Usage

Dim instance As DicomImage
Dim value As StretchModes

instance.StretchMode = value

value = instance.StretchMode
public StretchModes StretchMode {get; set;}
public:
property StretchModes StretchMode {
   StretchModes get();
   void set (    StretchModes value);
}
Remarks
If not None, the image is sized to fit the display area available to it, whilst retaining its aspect ratio. If None, the image is displayed according to the Zoom and Scroll properties.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


StudyDescription Property (DicomImage)

StudyDescription Property (DicomImage)

DicomObjects Namespace > DicomImage Class : StudyDescription Property
Description for the study
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property StudyDescription As String
'Usage

Dim instance As DicomImage
Dim value As String

instance.StudyDescription = value

value = instance.StudyDescription
public string StudyDescription {get; set;}
public:
property String^ StudyDescription {
   String^ get();
   void set (    String^ value);
}

Property Value

Study Description
Remarks

This property provides human readable descriptions of the Study returned by a query, or relating to an image. It corresponds to attribute (0008, 1030).

The usefulness is limited by the fact that not all equipment provides these descriptions in its SOP instances, and even if it does, they may not be available through Query/Retrieve. For instance the RSNA CTN (up to and including version 2.8) supports the study description, but fails to index and provide the series description.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


StudyUID Property (DicomImage)

StudyUID Property (DicomImage)

DicomObjects Namespace > DicomImage Class : StudyUID Property
Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property StudyUID As String
'Usage

Dim instance As DicomImage
Dim value As String

instance.StudyUID = value

value = instance.StudyUID
public string StudyUID {get; set;}
public:
property String^ StudyUID {
   String^ get();
   void set (    String^ value);
}

Property Value

The Study UID
Remarks
A shortcut for attribute (0020, 000D).
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Tag Property (DicomImage)

Tag Property (DicomImage)

DicomObjects Namespace > DicomImage Class : Tag Property
A general purpose Tag for developer use
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Tag As Object
'Usage

Dim instance As DicomImage
Dim value As Object

instance.Tag = value

value = instance.Tag
public object Tag {get; set;}
public:
property Object^ Tag {
   Object^ get();
   void set (    Object^ value);
}
Remarks
This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


UnsharpEnhancement Property

UnsharpEnhancement Property

DicomObjects Namespace > DicomImage Class : UnsharpEnhancement Property
UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property UnsharpEnhancement As Single
'Usage

Dim instance As DicomImage
Dim value As Single

instance.UnsharpEnhancement = value

value = instance.UnsharpEnhancement
public float UnsharpEnhancement {get; set;}
public:
property float UnsharpEnhancement {
   float get();
   void set (    float value);
}
Remarks
Effectively, a moving average image is created with a filter length of UnsharpLength, and then subtracted from the original image to leave an enhanced image. The relative contributions of the original and averaged images are controlled by UnsharpEnhancement, higher values giving a greater degree of enhancement, but the factors are adjusted so that the pixel values remain unchanged where there are no edges.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


UnsharpLength Property

UnsharpLength Property

DicomObjects Namespace > DicomImage Class : UnsharpLength Property
UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property UnsharpLength As Integer
'Usage

Dim instance As DicomImage
Dim value As Integer

instance.UnsharpLength = value

value = instance.UnsharpLength
public int UnsharpLength {get; set;}
public:
property int UnsharpLength {
   int get();
   void set (    int value);
}
Remarks
Effectively, a moving average image is created with a filter length of UnsharpLength, and then subtracted from the original image to leave an enhanced image. The relative contributions of the original and averaged images are controlled by UnsharpEnhancement, higher values giving a greater degree of enhancement, but the factors are adjusted so that the pixel values remain unchanged where there are no edges.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


UserMatrix Property

UserMatrix Property

DicomObjects Namespace > DicomImage Class : UserMatrix Property
Means to override the matrix used to display 2D images
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property UserMatrix As Matrix
'Usage

Dim instance As DicomImage
Dim value As Matrix

instance.UserMatrix = value

value = instance.UserMatrix
public Matrix UserMatrix {get; set;}
public:
property Matrix^ UserMatrix {
   Matrix^ get();
   void set (    Matrix^ value);
}
Remarks
There are multiple uses for the display matrix, with numerous matrix overrides, which all ultimately call the CoreMatrix protected function, but there could be special circumstanes where the uses wished to override the normal zoom/scroll/rotate bahaviour, and if so, then it can be done by setting this property to a non-null value.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


VoiLUT Property

VoiLUT Property

DicomObjects Namespace > DicomImage Class : VoiLUT Property
The VOI Lookup Table to be used to display the DicomImage
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property VoiLUT As Short
'Usage

Dim instance As DicomImage
Dim value As Short

instance.VoiLUT = value

value = instance.VoiLUT
public short VoiLUT {get; set;}
public:
property short VoiLUT {
   short get();
   void set (    short value);
}

Property Value

The index of the VOI LUT to use for display
Remarks

DICOM allows multiple VOI and presentation Lookup Tables (LUTs) in images, and the user may select whichever they require. These properties provide that choice, and the value 0 may be used to disable the LUT. The value may range from 0 (disabling the LUT) to the number of VOI LUTs in the image. Values beyond the available range are treated as 0.

The value is initially set to the DefaultVoiLUT property, which if itself having the default value of 1, indicates that the first VOI Lookup Table, if present, should be used.

See VoiLUTInUse for a mean to tell which VOILUT is actually being used

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


VOILUTFunction Property

VOILUTFunction Property

DicomObjects Namespace > DicomImage Class : VOILUTFunction Property
Controls which VOILUT function to be used, default value is Linear
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property VOILUTFunction As VoiLUTFunction
'Usage

Dim instance As DicomImage
Dim value As VoiLUTFunction

instance.VOILUTFunction = value

value = instance.VOILUTFunction
public VoiLUTFunction VOILUTFunction {get; set;}
public:
property VoiLUTFunction VOILUTFunction {
   VoiLUTFunction get();
   void set (    VoiLUTFunction value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


VoiLUTInUse Property

VoiLUTInUse Property

DicomObjects Namespace > DicomImage Class : VoiLUTInUse Property
Indicates whether a Values of Interest Lookup Table is in use
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property VoiLUTInUse As Short
'Usage

Dim instance As DicomImage
Dim value As Short

value = instance.VoiLUTInUse
public short VoiLUTInUse {get;}
public:
property short VoiLUTInUse {
   short get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Width Property (DicomImage)

Width Property (DicomImage)

DicomObjects Namespace > DicomImage Class : Width Property
The Window "Width" - which controls the greyscale mapping of a displayed image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Width As Single
'Usage

Dim instance As DicomImage
Dim value As Single

instance.Width = value

value = instance.Width
public float Width {get; set;}
public:
property float Width {
   float get();
   void set (    float value);
}
Remarks

Width and Levels are the parameters that control the grey-scale mapping from the original pixel data to the screen. Following the normal convention, the grey scale ranges from level-width/2 to level+width/2. Note that re-scale values present in some SOP classes are used for the purposes of this mapping, but the native data are not altered, and other operations such as obtaining the Pixels are unaffected.

Windowing using these values applies now also to colour (RGB, YBR & COLOR PALETTE images, which by default have Width=255 and Level=128)

These values are initialised from the suggested values in the DICOM data, if present, but if not present, then reasonable initial values are calculated from the pixel data itself.

These values are regarded as transitory, and therefore, when an image is written, they are not written back into the DICOM data. If this behaviour is required, then code similar to this should be included prior to the write:

Image.Attributes.Add(&h0028,&h1050), Image.Level Image.Attributes.Add(&h0028,&h1051), Image.Width

Width and Level are ignored under the following circumstances:

  • When a PresentationState is applied to the image
  • When the image contains a "Values of Interest Lookup Table" (VOILUT), as this takes the place of windowing

In the later case, the VOI LUT can be ignored (and width and level used), by setting the image�s VOILUT property to 0.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


WidthMultiplier Property

WidthMultiplier Property

DicomObjects Namespace > DicomImage Class : WidthMultiplier Property
Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property WidthMultiplier As Single
'Usage

Dim instance As DicomImage
Dim value As Single

instance.WidthMultiplier = value

value = instance.WidthMultiplier
public float WidthMultiplier {get; set;}
public:
property float WidthMultiplier {
   float get();
   void set (    float value);
}
Remarks

Width and Level are ignored when a VOI LUT is in use (VoiLUTInUse is true), but this property, together with LevelShift provides an alternative means to allow users to have some control over the display without having to disable the VOILUT completely

The mechanism used is that the entire lookup table is shifted (in original image units) by LevelShift units, then widended or narrowed around its mid-point (where it crosses the mid-point of the output space) by a factor of WidthMultiplier.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Zoom Property

Zoom Property

DicomObjects Namespace > DicomImage Class : Zoom Property
Controls the magnification of an image display
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Zoom As Single
'Usage

Dim instance As DicomImage
Dim value As Single

instance.Zoom = value

value = instance.Zoom
public float Zoom {get; set;}
public:
property float Zoom {
   float get();
   void set (    float value);
}
Remarks

Together with Scroll, this property determines the display of an image, which is magnified by 'Zoom' relative to an original size which is defined as 1 pixel = 1 screen pixel. This property is ignored if the image's StretchMode property is True.

In order to find the values used at any given time, even if StretchToFit is true, use the Matrix method to get the ActualZoom which is used in the COM version.

This property is over-ridden if a PresentationState is applied.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


DicomImage Class Events

DicomImage Class Events

DicomObjects Namespace : DicomImage Class

For a list of all members of this type, see DicomImage members.

Public Events
 | Name | Description
Public Event | PositionChanged | An event which fires when the plane displayed by this image changes.
Public Event | UserSmoothing | Setting this event enables a developer to specify his own smoothing algorithm.
Top
See Also

Reference

DicomImage Class
DicomObjects Namespace


PositionChanged Event

PositionChanged Event

DicomObjects Namespace > DicomImage Class : PositionChanged Event
An event which fires when the plane displayed by this image changes.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event PositionChanged As PositionChangedHandler
'Usage

Dim instance As DicomImage
Dim handler As PositionChangedHandler

AddHandler instance.PositionChanged, handler
public event PositionChangedHandler PositionChanged
public:
event PositionChangedHandler^ PositionChanged
Remarks
This is used by the DicomLabel objects with type = DicomObjects.Enums.LabelType.ReferenceLine to cause them to update automatically, but is also available for user use - e.g. for updating displayed axes.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


UserSmoothing Event

UserSmoothing Event

DicomObjects Namespace > DicomImage Class : UserSmoothing Event
Setting this event enables a developer to specify his own smoothing algorithm.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event UserSmoothing As UserSmoothingHandler
'Usage

Dim instance As DicomImage
Dim handler As UserSmoothingHandler

AddHandler instance.UserSmoothing, handler
public event UserSmoothingHandler UserSmoothing
public:
event UserSmoothingHandler^ UserSmoothing
Remarks
This is an advanced and rarely used technique - please ask Medical Connections for help if you wish to use this event.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Implicit Type Conversion Operator (DicomImage)

Implicit Type Conversion Operator (DicomImage)

DicomObjects Namespace > DicomImage Class : Implicit Type Conversion Operator

DicomImage

Implicit DicomImage to DicomDataSet cast
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Operator Widening CType( _
   ByVal im As DicomImage _
) As DicomDataSet
'Usage

public DicomDataSet operator implicit(
   DicomImage im
)
public:
operator DicomDataSet^ (
   DicomImage^ im
)

Parameters

im

DicomImage

Return Value

DicomDataSet
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


DicomImage3D Class

DicomImage3D Class
Members

DicomObjects Namespace : DicomImage3D Class
Class to display 3D DICOM data in various modes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomImage3D
   Inherits DicomImage
'Usage

Dim instance As DicomImage3D
public class DicomImage3D : DicomImage
public ref class DicomImage3D : public DicomImage
Remarks

Unlike in earlier versions of DicomObjects, MPR, MIP, VR & Slab are all handled by the same class, allowing the view to be changed at will simply by changing the RenderMode property.

The members of the IProjection interface allow the view to be roated, zoomed etc., and these transformations are retained when changing views.

Multiple DicomImage3D objects may share the same Volume, greatly reducing memory requirements.

In version 8, display of 3D images is only suported in a DicomViewer with ViewerMode = DirectX.

A DicomImage3D references a "primary" Image which is used for accessing the DataSet and related demographics etc, which is normally the first image in the pixel volume

Inheritance Hierarchy

System.Object
DicomObjects.DicomImage
DicomObjects.DicomImage3D

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Members
DicomObjects Namespace


DicomImage3D Class Members

DicomImage3D Class Members
Properties Methods Events

DicomObjects Namespace : DicomImage3D Class

The following tables list the members exposed by DicomImage3D.

Public Constructors
 | Name | Description
Public Constructor | DicomImage3D Constructor | Create a 3D image from a DicomVolume and with a defined rendering mode
Top
Public Properties
 | Name | Description
Public Property | AccessionNumber | The Accession Number (Inherited from DicomObjects.DicomImage)
Public Property | Angle | Controls the rotation of an image (Inherited from DicomObjects.DicomImage)
Public Property | Area | The display area of DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | BorderPen | The Pen object for Image border (Inherited from DicomObjects.DicomImage)
Public Property | CacheMode | Controls how the pixel data is cached (Inherited from DicomObjects.DicomImage)
Public Property | CaptureBackColour | User defined background colour for image output of PrinterImage, Bitmap and SubImage methods Default is Black background (Inherited from DicomObjects.DicomImage)
Public Property | CDAStyleSheet | Style sheet used for displaying encapsulated CDA (Inherited from DicomObjects.DicomImage)
Public Property | CineFramesToDisplay | The set of frames to display for cine modes (Inherited from DicomObjects.DicomImage)
Public Property | CineIndex | The index of the currently displayed frame when using CineMode (Inherited from DicomObjects.DicomImage)
Public Property | CineMode | Enumerated running modes for multi-frame image (Inherited from DicomObjects.DicomImage)
Public Property | CineRate | Controls the speed of autonomous cine runs (Inherited from DicomObjects.DicomImage)
Public Property | CineSmoothing | Boolean property indicating whether Smoothing is applied when Cine is being displayed. (Inherited from DicomObjects.DicomImage)
Public Property | ColourTable | The colour lookup table of DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | CubicSplineAlpha | Parameter to control the degree of smoothing. The default value is �0.75, and normal values range from �0.5 to �1.25, though higher negative values may be used to produce deliberate edge enhancement. (Inherited from DicomObjects.DicomImage)
Public Property | CutPlanes | The list of cutplanes applied to the view of the object
Public Property | DataSet | The underlying DICOM Dataset containing persistent data for the image (Inherited from DicomObjects.DicomImage)
Public Property | DateOfBirth | Date of birth of the patient (Inherited from DicomObjects.DicomImage)
Public Property | DiffuseReflection | Switches on and off diffuse reflection (shading)
Public Property | DisplayMode | Controls how the image is rendered internal before transfer to the screen (Inherited from DicomObjects.DicomImage)
Public Property | DownSample | A means to reduce the time time to render images, at the expense of reduced quality
Public Property | DrawCacheMode | Specify the DrawCacheMode to control how image is drawn/cached (Inherited from DicomObjects.DicomImage)
Public Property | EarlyRayTermination | The opacity at which to stop Ray Tracing (VR only)
Public Property | ExplicitModalityLUT | An explicit modality Lookup Table to be used in place of one specified in the image or presentaiton state. (Inherited from DicomObjects.DicomImage)
Public Property | ExplicitPresentationLUT | An explicit presentation Lookup Table to be used in place of one specified in the image or presentaiton state. (Inherited from DicomObjects.DicomImage)
Public Property | ExplicitVOILUT | An explicit Values of Interest (VOI) Lookup Table to be used in place of one specified in the image or presentaiton state. (Inherited from DicomObjects.DicomImage)
Public Property | FilterLength | Contains the length of the smoothing filter (Inherited from DicomObjects.DicomImage)
Public Property | FlipState | The flip state of the image, allowing the orientation of the image, as displayed, to be altered (Inherited from DicomObjects.DicomImage)
Public Property | Frame | Controls which frame of a multi-frame image is displayed (Inherited from DicomObjects.DicomImage)
Public Property | FrameCount | The number of frames contained in a multi-frame image (Inherited from DicomObjects.DicomImage)
Public Property | Gamma | A number that specifies a power (Inherited from DicomObjects.DicomImage)
Public Property | InstanceUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy (Inherited from DicomObjects.DicomImage)
Public Property | Invert | Controls whether the Image will be inverted. (Inherited from DicomObjects.DicomImage)
Public Property | Item | Overloaded. Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file. (Inherited from DicomObjects.DicomImage)
Public Property | JpipRequestSize | The size of the requests other than the first (in bytes) to make to a JPIP server. (Inherited from DicomObjects.DicomImage)
Public Property | Labels | Provides access to the DicomLabelCollection, items of which are to be displayed over an image. (Inherited from DicomObjects.DicomImage)
Public Property | Labels3D | Collection to hold DicomLabel3D objects for display over 3D images.
Public Property | Level | The Window Level (also known as the centre) - which controls the greyscale mapping of a displayed image (Inherited from DicomObjects.DicomImage)
Public Property | LevelShift | Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping (Inherited from DicomObjects.DicomImage)
Public Property | LightDirection | The direction of the ambient light, relative to the eye position
Public Property | LightIntensity | The intensity of the directional (as opposed to ambient) lighting.
Public Property | MagnificationMode | Controls how pixels are interpolated when the image is magnified (Inherited from DicomObjects.DicomImage)
Public Property | MaskRanges | Contains an array of DicomMaskRange objects to be applied to this image. See the DicomMaskRange object for more information on how this is used. (Inherited from DicomObjects.DicomImage)
Public Property | Matrix3D | The Matrix relating real world coordinates (in mm) to the display space (with units -1 to +1 in each dimension)
Public Property | MinificationMode | Controls how pixels are interpolated when the image is minified (Inherited from DicomObjects.DicomImage)
Public Property | ModalityLUT | Enables or disables the Modality Lookup Table to be used in the DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | Name | The Name of the patient (Inherited from DicomObjects.DicomImage)
Public Property | OriginalTs | Original Transfer syntax of the underlying DataSet (Inherited from DicomObjects.DicomImage)
Public Property | OverlayColour | Controls how overlays embedded in the image are displayed (Inherited from DicomObjects.DicomImage)
Public Property | OverlayVisible | Controls whether overlays embedded in the image are displayed (Inherited from DicomObjects.DicomImage)
Public Property | PatientID | The Patient ID (Inherited from DicomObjects.DicomImage)
Public Property | Pixels | Accesses the raw pixel data as a typed array (Inherited from DicomObjects.DicomImage)
Public Property | PresentationLUT | Enables or disables the Presentation Lookup Table to be used in the DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | PresentationState | Support for DICOM greyscale presentation state (Inherited from DicomObjects.DicomImage)
Public Property | PresentationStateFeaturesUsed | The presentation state features to use (Inherited from DicomObjects.DicomImage)
Public Property | PresentationStates | Support for a list of DICOM greyscale presentation state (Inherited from DicomObjects.DicomImage)
Public Property | RawPixels | Accesses the raw pixel data as an array (Inherited from DicomObjects.DicomImage)
Public Property | RealTimeCine | Controls how cine images are displayed (Inherited from DicomObjects.DicomImage)
Public Property | RenderedSize | Overridden. Returns the Image display size in output (normally screen) coordinates
Public Property | RenderMode | The mode used to display an image
Public Property | RotateState | The rotation state of the image, allowing the orientation of the image, as displayed, to be altered (Inherited from DicomObjects.DicomImage)
Public Property | RotationBehaviour | Controls the baseline positioning of an image which is not stretched to fit and is rotated (Inherited from DicomObjects.DicomImage)
Public Property | Scroll | Controls the positioning of an image display (Inherited from DicomObjects.DicomImage)
Public Property | SeriesDescription | Descriptions for the series (Inherited from DicomObjects.DicomImage)
Public Property | SeriesUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy (Inherited from DicomObjects.DicomImage)
Public Property | Sex | Sex of the patient (Inherited from DicomObjects.DicomImage)
Public Property | ShowLabels | Controls whether the image�s labels (annotations) are shown on screen (Inherited from DicomObjects.DicomImage)
Public Property | ShowShutter | Controls whether image shutters (if specified in the image) are used. (Inherited from DicomObjects.DicomImage)
Public Property | ShowUpdates | Controls whether the images is updated when image display parameters change (Inherited from DicomObjects.DicomImage)
Public Property | Size | The dimensions of the image (Inherited from DicomObjects.DicomImage)
Public Property | SlabThickness | Thickness for rendering Minimum, Maximum and Average (slab)
Public Property | SOPClass | SOP class of the DicomDataSet. (Inherited from DicomObjects.DicomImage)
Public Property | SpecularExponent | Controls broadness of specular reflection component (VR only)
Public Property | SpecularIntensity | Controls the intensity of specular reflection (VR only)
Public Property | Step | Step to use when RayCasting (MIP & VR only)
Public Property | StretchMode | Controls the automatic zooming of an image. (Inherited from DicomObjects.DicomImage)
Public Property | StudyDescription | Description for the study (Inherited from DicomObjects.DicomImage)
Public Property | StudyUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy (Inherited from DicomObjects.DicomImage)
Public Property | Tag | A general purpose Tag for developer use (Inherited from DicomObjects.DicomImage)
Public Property | UnsharpEnhancement | UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement (Inherited from DicomObjects.DicomImage)
Public Property | UnsharpLength | UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement (Inherited from DicomObjects.DicomImage)
Public Property | UserMatrix | Means to override the matrix used to display 2D images (Inherited from DicomObjects.DicomImage)
Public Property | VoiLUT | The VOI Lookup Table to be used to display the DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | VOILUTFunction | Controls which VOILUT function to be used, default value is Linear (Inherited from DicomObjects.DicomImage)
Public Property | VoiLUTInUse | Indicates whether a Values of Interest Lookup Table is in use (Inherited from DicomObjects.DicomImage)
Public Property | Volume | The DicomVolume on which this DicomImage3D is based.
Public Property | Width | The Window "Width" - which controls the greyscale mapping of a displayed image (Inherited from DicomObjects.DicomImage)
Public Property | WidthMultiplier | Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping (Inherited from DicomObjects.DicomImage)
Public Property | Zoom | Controls the magnification of an image display (Inherited from DicomObjects.DicomImage)
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Creates and adds standard data elements to the underlying DicomDataSet (Inherited from DicomObjects.DicomImage)
Public Method | AddByReference | Overloaded. Add byte[] as attribute value to avoid copying large data (Inherited from DicomObjects.DicomImage)
Public Method | Bitmap | Overloaded. Creates a Bitmap Image from DicomImage (Inherited from DicomObjects.DicomImage)
Public Method | BitmapImage | Image rendered as a System.Windows.Media.Imaging.BitmapImage object (Inherited from DicomObjects.DicomImage)
Public Method | Blt | Combine pixel data of source image into this image as a base image (Inherited from DicomObjects.DicomImage)
Public Method | BurnAnnotations | Burn all image Labels in Pixel data. This method modifies the underlying pixel data! (Inherited from DicomObjects.DicomImage)
Public Method | CanConvertTo | Useful method to check if the image can be converted using a different compression specified by the TransferSyntax (Inherited from DicomObjects.DicomImage)
Public Method | CellLocation | The location of the top-left corner of the cell within which this image would be displayed in a particular viewer (Inherited from DicomObjects.DicomImage)
Public Method | CellSize | The size of the cell within which this image would be displayed in a particular viewer (Inherited from DicomObjects.DicomImage)
Public Method | ChangeToDecompressed | Simulate the effect of writing out as a Decompressed Image (Inherited from DicomObjects.DicomImage)
Public Method | ClearCaches | Overloaded. Clears the entire internal cache (Inherited from DicomObjects.DicomImage)
Public Method | Clip | Apply clip planes to the display volume
Public Method | Clone | Overloaded. Returns a cloned copy of the DicomImage (Inherited from DicomObjects.DicomImage)
Public Method | Copy | Copies the image to the Windows clipboard (Inherited from DicomObjects.DicomImage)
Public Method | CurrentPixelScale | Current Pixel Size
Public Method | CurrentToNoStretch | This method modifies the StretchMode, Zoom and Scroll properties such that the display output stays very similar while the display parameters have changed to suit the DicomObjects.Enums.StretchModes.NoStretch mode. (Inherited from DicomObjects.DicomImage)
Public Method | CurrentToPresentationState | Overloaded. Encapsulate current display properties into a DICOM GreyScale Presentation State object (Inherited from DicomObjects.DicomImage)
Public Method | DecompressAll | Causes all the frames of an image to be decompressed. (Inherited from DicomObjects.DicomImage)
Public Method | DisplaySize | Overloaded. The size at which this image, using current values for StretchMode etc. will display in this viewer. (Inherited from DicomObjects.DicomImage)
Public Method | Dispose | Standard Dispose methods (Inherited from DicomObjects.DicomImage)
Public Method | DistanceFromPoint | Perpendicular distance from a Point to the plane of this image (Inherited from DicomObjects.DicomImage)
Public Method | DistanceToFarVertex | Find distance to the furthest vertex of the volume
Public Method | DownloadStatus | Overloaded. The download status of an image compared to specific attributes of the image (Inherited from DicomObjects.DicomImage)
Public Method | ExplicitJpipRequest | Overloaded. Explicitly request that some of the pixel information for this image should be retrieved via JPIP (Inherited from DicomObjects.DicomImage)
Public Method | Export | Overloaded. Copy the image data for external access, controlled by Format and Quality (Inherited from DicomObjects.DicomImage)
Public Method | GetCacheSize | Get cache size used by DicomObjects for the image - useful to help decide when to call ClearCaches method (Inherited from DicomObjects.DicomImage)
Public Method | GetMinAndMax | Overloaded. Find the maximum and minimum pixel data values in the pixel data (Inherited from DicomObjects.DicomImage)
Public Method | GetRawFrame | Extract individual frame from the pixel data (Inherited from DicomObjects.DicomImage)
Public Method | Histogram | Returns an array containing the distribution of raw pixel values. (Inherited from DicomObjects.DicomImage)
Public Method | ImagePlane | Overridden. The currently displayed plane of this image.
Public Method | ImageToScreen | Overridden. Calculate where in screen (X,Y) space, a given image point lies
Public Method | ImageToWorld | Calculate the real-world 3D coordinates of a point of the image currently displayed (Inherited from DicomObjects.DicomImage)
Public Method | Import | Overloaded. Copies the image data from an external generic image object (Inherited from DicomObjects.DicomImage)
Public Method | Matrix | Overloaded. Matrix specifying how the image is displayed, applying correction if needed if pizels are not square (Inherited from DicomObjects.DicomImage)
Public Method | MatrixBase | Matrix specifying how the image would be displayed with a Zoom of 1:1 (Inherited from DicomObjects.DicomImage)
Public Method | OrientationText | Return the Text of DicomLabel of LabelType = special. (Inherited from DicomObjects.DicomImage)
Public Method | Paste | Copies the Image Data from Windows Clipboard (Inherited from DicomObjects.DicomImage)
Public Method | PixelToWorld | Calculate the real world location of a point displayed on a 3D image
Public Method | PixelValuesByFrame | Returns an array of pixel values for a frame, optionally transformed via the modality transformation (Inherited from DicomObjects.DicomImage)
Public Method | PresentationStateToCurrent | Overloaded. Modifies current display properties to match the DICOM presentation state. (Inherited from DicomObjects.DicomImage)
Public Method | PrinterImage | Overloaded. Creates a copy of the image for printing or other purposes (Inherited from DicomObjects.DicomImage)
Public Method | RawPixelValuesByFrame | Returns an array of raw pixel values for a frame (Inherited from DicomObjects.DicomImage)
Public Method | Read | Overloaded. Reads from an external DICOM file (Inherited from DicomObjects.DicomImage)
Public Method | ReadURL | Reads from Web Address (Inherited from DicomObjects.DicomImage)
Public Method | ReferenceLine | This method returns a new DicomLabel object which represents the position of one DicomImage relative to another. (Inherited from DicomObjects.DicomImage)
Public Method | RenderToArray | Overloaded. Render the DicomImage to array. The data returned will be exactly the same as the "presentation data" if the Image gets displayed on screen. (Inherited from DicomObjects.DicomImage)
Public Method | Rotate | Rotate view around a defined axis and based on a DicomViewer if available
Public Method | RotateWorld | Rotate the view by an angle around a vector in world orientation
Public Method | Scale | Scale/Zoom the view
Public Method | ScreenNormal | Screen normal in World units
Public Method | ScreenToImage | Overridden. Calculate where in image (X,Y) space, a given screen point lies
Public Method | ScreenToWorld(PointF,DicomViewer) | Calculate where in real world (X,Y,Z) space, a given screen point lies (Inherited from DicomObjects.DicomImage)
Public Method | Send | Overloaded. Sends an image to a remote Storage SCP (Inherited from DicomObjects.DicomImage)
Public Method | SetDefaultWindows | Recalculates the default windows used by DicomObjects as if the image had just been loaded (Inherited from DicomObjects.DicomImage)
Public Method | SetExternalShader | An external DirectX pixel shader to be used for custom filtering (Inherited from DicomObjects.DicomImage)
Public Method | SetPixelData | Method to set pixel data directly from a stream (Inherited from DicomObjects.DicomImage)
Public Method | SetPixelDataAndImport | Method to import pixel data directly from a non-DICOM data (Inherited from DicomObjects.DicomImage)
Public Method | SetPixelFile | Maps an external file as the pixel data (Inherited from DicomObjects.DicomImage)
Public Method | SetScrollAndZoom | Sets the Scroll and Zoom values to values reflecting the current display (Inherited from DicomObjects.DicomImage)
Public Method | SetSimpleMasking | Overloaded. Sets an int array as frame numbers of the mask frames for subtraction (Inherited from DicomObjects.DicomImage)
Public Method | SetTransferFunction | Overloaded. Set the transfer function (Colour Map) for use in Volume Rendering
Public Method | SetViewPlane | Overloaded. Set the view plane for the image, to one of 3 pre-defined views, with optional reset of centre and zoom
Public Method | Spacing | Overloaded. The pixel spacing of the DicomImage (Inherited from DicomObjects.DicomImage)
Public Method | SpacingInViewer | This method returns the Pixel Spacing within the region specified by Area, in a particular viewer (Inherited from DicomObjects.DicomImage)
Public Method | SubImage | Overloaded. Overridden. Creates a copy of part or all of the image with controlled size
Public Method | TranslateMm | Move the centre point of the view by the specified offset
Public Method | TranslateNormal | Move the centre point of the view by the specified distance, normal to the current view plane
Public Method | TranslatePixels | Move the display Offset pixels based on output size
Public Method | Update | Causes the image to be updated (Inherited from DicomObjects.DicomImage)
Public Method | WorldToImage(Point3D,DicomViewer,Int32) | Calculate the nearest image coordinates for a point in real world (X,Y,Z) space, (Inherited from DicomObjects.DicomImage)
Public Method | WorldToScreen(Point3D,DicomViewer) | Calculate where in real world (X,Y,Z) space, a given screen point lies (Inherited from DicomObjects.DicomImage)
Public Method | Write | Overloaded. Write the data to a file with specified transfer syntax and quality (Inherited from DicomObjects.DicomImage)
Top
Public Events
 | Name | Description
Public Event | PositionChanged | An event which fires when the plane displayed by this image changes. (Inherited from DicomObjects.DicomImage)
Public Event | UserSmoothing | Setting this event enables a developer to specify his own smoothing algorithm. (Inherited from DicomObjects.DicomImage)
Top
See Also

Reference

DicomImage3D Class
DicomObjects Namespace


DicomImage3D Constructor

DicomImage3D Constructor

DicomObjects Namespace > DicomImage3D Class : DicomImage3D Constructor
The volume from which to create the image
The intial rendering mode
Create a 3D image from a DicomVolume and with a defined rendering mode
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal volume As DicomVolume, _
   ByVal Type As RenderMode3D _
)
'Usage

Dim volume As DicomVolume
Dim Type As RenderMode3D

Dim instance As New DicomImage3D(volume, Type)
public DicomImage3D(
   DicomVolume volume,
   RenderMode3D Type
)
public:
DicomImage3D(
   DicomVolume^ volume,
   RenderMode3D Type
)

Parameters

volume
The volume from which to create the image
Type
The intial rendering mode
Remarks

Multiple images may share the same volume, and this should be used where possible to save both general and video RAM.

The rendering mode may subsequently be changed without creating a new image object.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


DicomImage3D Class Methods

DicomImage3D Class Methods

DicomObjects Namespace : DicomImage3D Class

For a list of all members of this type, see DicomImage3D members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Creates and adds standard data elements to the underlying DicomDataSet (Inherited from DicomObjects.DicomImage)
Public Method | AddByReference | Overloaded. Add byte[] as attribute value to avoid copying large data (Inherited from DicomObjects.DicomImage)
Public Method | Bitmap | Overloaded. Creates a Bitmap Image from DicomImage (Inherited from DicomObjects.DicomImage)
Public Method | BitmapImage | Image rendered as a System.Windows.Media.Imaging.BitmapImage object (Inherited from DicomObjects.DicomImage)
Public Method | Blt | Combine pixel data of source image into this image as a base image (Inherited from DicomObjects.DicomImage)
Public Method | BurnAnnotations | Burn all image Labels in Pixel data. This method modifies the underlying pixel data! (Inherited from DicomObjects.DicomImage)
Public Method | CanConvertTo | Useful method to check if the image can be converted using a different compression specified by the TransferSyntax (Inherited from DicomObjects.DicomImage)
Public Method | CellLocation | The location of the top-left corner of the cell within which this image would be displayed in a particular viewer (Inherited from DicomObjects.DicomImage)
Public Method | CellSize | The size of the cell within which this image would be displayed in a particular viewer (Inherited from DicomObjects.DicomImage)
Public Method | ChangeToDecompressed | Simulate the effect of writing out as a Decompressed Image (Inherited from DicomObjects.DicomImage)
Public Method | ClearCaches | Overloaded. Clears the entire internal cache (Inherited from DicomObjects.DicomImage)
Public Method | Clip | Apply clip planes to the display volume
Public Method | Clone | Overloaded. Returns a cloned copy of the DicomImage (Inherited from DicomObjects.DicomImage)
Public Method | Copy | Copies the image to the Windows clipboard (Inherited from DicomObjects.DicomImage)
Public Method | CurrentPixelScale | Current Pixel Size
Public Method | CurrentToNoStretch | This method modifies the StretchMode, Zoom and Scroll properties such that the display output stays very similar while the display parameters have changed to suit the DicomObjects.Enums.StretchModes.NoStretch mode. (Inherited from DicomObjects.DicomImage)
Public Method | CurrentToPresentationState | Overloaded. Encapsulate current display properties into a DICOM GreyScale Presentation State object (Inherited from DicomObjects.DicomImage)
Public Method | DecompressAll | Causes all the frames of an image to be decompressed. (Inherited from DicomObjects.DicomImage)
Public Method | DisplaySize | Overloaded. The size at which this image, using current values for StretchMode etc. will display in this viewer. (Inherited from DicomObjects.DicomImage)
Public Method | Dispose | Standard Dispose methods (Inherited from DicomObjects.DicomImage)
Public Method | DistanceFromPoint | Perpendicular distance from a Point to the plane of this image (Inherited from DicomObjects.DicomImage)
Public Method | DistanceToFarVertex | Find distance to the furthest vertex of the volume
Public Method | DownloadStatus | Overloaded. The download status of an image compared to specific attributes of the image (Inherited from DicomObjects.DicomImage)
Public Method | ExplicitJpipRequest | Overloaded. Explicitly request that some of the pixel information for this image should be retrieved via JPIP (Inherited from DicomObjects.DicomImage)
Public Method | Export | Overloaded. Copy the image data for external access, controlled by Format and Quality (Inherited from DicomObjects.DicomImage)
Public Method | GetCacheSize | Get cache size used by DicomObjects for the image - useful to help decide when to call ClearCaches method (Inherited from DicomObjects.DicomImage)
Public Method | GetMinAndMax | Overloaded. Find the maximum and minimum pixel data values in the pixel data (Inherited from DicomObjects.DicomImage)
Public Method | GetRawFrame | Extract individual frame from the pixel data (Inherited from DicomObjects.DicomImage)
Public Method | Histogram | Returns an array containing the distribution of raw pixel values. (Inherited from DicomObjects.DicomImage)
Public Method | ImagePlane | Overridden. The currently displayed plane of this image.
Public Method | ImageToScreen | Overridden. Calculate where in screen (X,Y) space, a given image point lies
Public Method | ImageToWorld | Calculate the real-world 3D coordinates of a point of the image currently displayed (Inherited from DicomObjects.DicomImage)
Public Method | Import | Overloaded. Copies the image data from an external generic image object (Inherited from DicomObjects.DicomImage)
Public Method | Matrix | Overloaded. Matrix specifying how the image is displayed, applying correction if needed if pizels are not square (Inherited from DicomObjects.DicomImage)
Public Method | MatrixBase | Matrix specifying how the image would be displayed with a Zoom of 1:1 (Inherited from DicomObjects.DicomImage)
Public Method | OrientationText | Return the Text of DicomLabel of LabelType = special. (Inherited from DicomObjects.DicomImage)
Public Method | Paste | Copies the Image Data from Windows Clipboard (Inherited from DicomObjects.DicomImage)
Public Method | PixelToWorld | Calculate the real world location of a point displayed on a 3D image
Public Method | PixelValuesByFrame | Returns an array of pixel values for a frame, optionally transformed via the modality transformation (Inherited from DicomObjects.DicomImage)
Public Method | PresentationStateToCurrent | Overloaded. Modifies current display properties to match the DICOM presentation state. (Inherited from DicomObjects.DicomImage)
Public Method | PrinterImage | Overloaded. Creates a copy of the image for printing or other purposes (Inherited from DicomObjects.DicomImage)
Public Method | RawPixelValuesByFrame | Returns an array of raw pixel values for a frame (Inherited from DicomObjects.DicomImage)
Public Method | Read | Overloaded. Reads from an external DICOM file (Inherited from DicomObjects.DicomImage)
Public Method | ReadURL | Reads from Web Address (Inherited from DicomObjects.DicomImage)
Public Method | ReferenceLine | This method returns a new DicomLabel object which represents the position of one DicomImage relative to another. (Inherited from DicomObjects.DicomImage)
Public Method | RenderToArray | Overloaded. Render the DicomImage to array. The data returned will be exactly the same as the "presentation data" if the Image gets displayed on screen. (Inherited from DicomObjects.DicomImage)
Public Method | Rotate | Rotate view around a defined axis and based on a DicomViewer if available
Public Method | RotateWorld | Rotate the view by an angle around a vector in world orientation
Public Method | Scale | Scale/Zoom the view
Public Method | ScreenNormal | Screen normal in World units
Public Method | ScreenToImage | Overridden. Calculate where in image (X,Y) space, a given screen point lies
Public Method | ScreenToWorld(PointF,DicomViewer) | Calculate where in real world (X,Y,Z) space, a given screen point lies (Inherited from DicomObjects.DicomImage)
Public Method | Send | Overloaded. Sends an image to a remote Storage SCP (Inherited from DicomObjects.DicomImage)
Public Method | SetDefaultWindows | Recalculates the default windows used by DicomObjects as if the image had just been loaded (Inherited from DicomObjects.DicomImage)
Public Method | SetExternalShader | An external DirectX pixel shader to be used for custom filtering (Inherited from DicomObjects.DicomImage)
Public Method | SetPixelData | Method to set pixel data directly from a stream (Inherited from DicomObjects.DicomImage)
Public Method | SetPixelDataAndImport | Method to import pixel data directly from a non-DICOM data (Inherited from DicomObjects.DicomImage)
Public Method | SetPixelFile | Maps an external file as the pixel data (Inherited from DicomObjects.DicomImage)
Public Method | SetScrollAndZoom | Sets the Scroll and Zoom values to values reflecting the current display (Inherited from DicomObjects.DicomImage)
Public Method | SetSimpleMasking | Overloaded. Sets an int array as frame numbers of the mask frames for subtraction (Inherited from DicomObjects.DicomImage)
Public Method | SetTransferFunction | Overloaded. Set the transfer function (Colour Map) for use in Volume Rendering
Public Method | SetViewPlane | Overloaded. Set the view plane for the image, to one of 3 pre-defined views, with optional reset of centre and zoom
Public Method | Spacing | Overloaded. The pixel spacing of the DicomImage (Inherited from DicomObjects.DicomImage)
Public Method | SpacingInViewer | This method returns the Pixel Spacing within the region specified by Area, in a particular viewer (Inherited from DicomObjects.DicomImage)
Public Method | SubImage | Overloaded. Overridden. Creates a copy of part or all of the image with controlled size
Public Method | TranslateMm | Move the centre point of the view by the specified offset
Public Method | TranslateNormal | Move the centre point of the view by the specified distance, normal to the current view plane
Public Method | TranslatePixels | Move the display Offset pixels based on output size
Public Method | Update | Causes the image to be updated (Inherited from DicomObjects.DicomImage)
Public Method | WorldToImage(Point3D,DicomViewer,Int32) | Calculate the nearest image coordinates for a point in real world (X,Y,Z) space, (Inherited from DicomObjects.DicomImage)
Public Method | WorldToScreen(Point3D,DicomViewer) | Calculate where in real world (X,Y,Z) space, a given screen point lies (Inherited from DicomObjects.DicomImage)
Public Method | Write | Overloaded. Write the data to a file with specified transfer syntax and quality (Inherited from DicomObjects.DicomImage)
Top
See Also

Reference

DicomImage3D Class
DicomObjects Namespace


Clip Method

Clip Method

DicomObjects Namespace > DicomImage3D Class : Clip Method
The label containing a rectangle or line used to define the cut planes
The size of the area in which the image is displayed
Apply clip planes to the display volume
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Clip( _
   ByVal Label As DicomLabel, _
   ByVal DisplayArea As Size _
)
'Usage

Dim instance As DicomImage3D
Dim Label As DicomLabel
Dim DisplayArea As Size

instance.Clip(Label, DisplayArea)
public void Clip(
   DicomLabel Label,
   Size DisplayArea
)
public:
void Clip(
   DicomLabel^ Label,
   Size DisplayArea
)

Parameters

Label
The label containing a rectangle or line used to define the cut planes
DisplayArea
The size of the area in which the image is displayed
Remarks

1 plane (for a line) or 4 planes (for a rectangle) are generated, each of which is orthogonal to the current display plane, and each includes, at that plane, the line(s) of the label. These are added to the CutPlanes collection, and may therefore subsequently be removed form that collection if necessary. The overall effect then when this method is used is to leave the image displayed only on one side of the line, or within the rectangle.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


CurrentPixelScale Method (DicomImage3D)

CurrentPixelScale Method (DicomImage3D)

DicomObjects Namespace > DicomImage3D Class : CurrentPixelScale Method
Size of current display area
Current Pixel Size
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function CurrentPixelScale( _
   ByVal DisplaySize As Size _
) As SizeF
'Usage

Dim instance As DicomImage3D
Dim DisplaySize As Size
Dim value As SizeF

value = instance.CurrentPixelScale(DisplaySize)
public SizeF CurrentPixelScale(
   Size DisplaySize
)
public:
SizeF CurrentPixelScale(
   Size DisplaySize
)

Parameters

DisplaySize
Size of current display area

Return Value

Size per pixel in mm (X and Y may differ)
Remarks
The DicomImage.DisplaySize method may be used to obtain the correct value of DisplaySize
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


DistanceToFarVertex Method

DistanceToFarVertex Method

DicomObjects Namespace > DicomImage3D Class : DistanceToFarVertex Method
Selects which direction to look.
Find distance to the furthest vertex of the volume
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function DistanceToFarVertex( _
   ByVal Forward As Boolean _
) As Single
'Usage

Dim instance As DicomImage3D
Dim Forward As Boolean
Dim value As Single

value = instance.DistanceToFarVertex(Forward)
public float DistanceToFarVertex(
   bool Forward
)
public:
float DistanceToFarVertex(
   bool Forward
)

Parameters

Forward
Selects which direction to look.

Return Value

distance to the verex in mm
Remarks

The measurement is from the current view plane.

If Forward is true, then the distance is that from the current plane to the vertex furthest "into the screen" (reached by calling TranslateNormal with a positive value)

If Forward is false, then the distance is that from the current plane to the vertex furthest "out of the screen" (reached by calling TranslateNormal with a negative value)

If the current plane intersects the volume, then both the forward and backward values will be positive.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


ImagePlane Method (DicomImage3D)

ImagePlane Method (DicomImage3D)

DicomObjects Namespace > DicomImage3D Class : ImagePlane Method
The currently displayed plane of this image.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ImagePlane( _
   ByVal Frame1 As Integer _
) As Nullable(Of Plane3D)
'Usage

Dim instance As DicomImage3D
Dim Frame1 As Integer
Dim value As Nullable(Of Plane3D)

value = instance.ImagePlane(Frame1)
public override Nullable<Plane3D> ImagePlane(
   int Frame1
)
public:
Nullable<Plane3D> ImagePlane(
   int Frame1
) override

Parameters

Frame1

Return Value

The plane of the image in 3D space, or null if not applicable to this image.
Remarks
For 3D images, this method returns the currently viewed plane. For MPR &Slab images, this is the actual data displayed, but for VR & MIP images, it is a hypothetical plane through the image and normal to the view direction.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members
Base Implementation in ImagePlane


ImageToScreen Method (DicomImage3D)

ImageToScreen Method (DicomImage3D)

DicomObjects Namespace > DicomImage3D Class : ImageToScreen Method
The image coordinates
The Viewer being used for display
Calculate where in screen (X,Y) space, a given image point lies
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ImageToScreen( _
   ByVal ImageCoordinates As PointF, _
   ByVal Viewer As DicomViewer _
) As Nullable(Of PointF)
'Usage

Dim instance As DicomImage3D
Dim ImageCoordinates As PointF
Dim Viewer As DicomViewer
Dim value As Nullable(Of PointF)

value = instance.ImageToScreen(ImageCoordinates, Viewer)
public override Nullable<PointF> ImageToScreen(
   PointF ImageCoordinates,
   DicomViewer Viewer
)
public:
Nullable<PointF> ImageToScreen(
   PointF ImageCoordinates,
   DicomViewer^ Viewer
) override

Parameters

ImageCoordinates
The image coordinates
Viewer
The Viewer being used for display

Return Value

Point in 2D image space if appropriate, or null, for 3D images
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members
Base Implementation in ImageToScreen


PixelToWorld Method (DicomImage3D)

PixelToWorld Method (DicomImage3D)

DicomObjects Namespace > DicomImage3D Class : PixelToWorld Method
Calculate the real world location of a point displayed on a 3D image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function PixelToWorld( _
   ByVal Point As PointF, _
   ByVal DisplaySize As Size _
) As Point3D
'Usage

Dim instance As DicomImage3D
Dim Point As PointF
Dim DisplaySize As Size
Dim value As Point3D

value = instance.PixelToWorld(Point, DisplaySize)
public Point3D PixelToWorld(
   PointF Point,
   Size DisplaySize
)
public:
Point3D PixelToWorld(
   PointF Point,
   Size DisplaySize
)

Parameters

Point
DisplaySize
Remarks

This method is suitable for MPR and Slab images, and whilst it will provide a value for "projectional" MIP and VR images the point will be on the "central plane" of that view, and is not really localised to a single point in space.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


Rotate Method (DicomImage3D)

Rotate Method (DicomImage3D)

DicomObjects Namespace > DicomImage3D Class : Rotate Method
The angle to rotate, measured clockwise in degrees
The axis around which to rotate the view
Display parameters of this viewer instance to use for applying rotation
Rotate view around a defined axis and based on a DicomViewer if available
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Rotate( _
   ByVal Angle As Single, _
   ByVal Axis As Vector3D, _
   Optional ByVal Viewer As DicomViewer _
)
'Usage

Dim instance As DicomImage3D
Dim Angle As Single
Dim Axis As Vector3D
Dim Viewer As DicomViewer

instance.Rotate(Angle, Axis, Viewer)
public void Rotate(
   float Angle,
   Vector3D Axis,
   DicomViewer Viewer
)
public:
void Rotate(
   float Angle,
   Vector3D Axis,
   DicomViewer^ Viewer
)

Parameters

Angle
The angle to rotate, measured clockwise in degrees
Axis
The axis around which to rotate the view
Viewer
Display parameters of this viewer instance to use for applying rotation
Remarks
Viewer instance is used mainly for ImageFusion with 2D images, never used in 3D.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


RotateWorld Method

RotateWorld Method

DicomObjects Namespace > DicomImage3D Class : RotateWorld Method
Angle to rotate by
Normalised axis of rotation in world orientation
Centre of rotation in world space
Rotate the view by an angle around a vector in world orientation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub RotateWorld( _
   ByVal Angle As Single, _
   ByVal Axis As Vector3D, _
   ByVal Centre As Vector3D _
)
'Usage

Dim instance As DicomImage3D
Dim Angle As Single
Dim Axis As Vector3D
Dim Centre As Vector3D

instance.RotateWorld(Angle, Axis, Centre)
public void RotateWorld(
   float Angle,
   Vector3D Axis,
   Vector3D Centre
)
public:
void RotateWorld(
   float Angle,
   Vector3D Axis,
   Vector3D Centre
)

Parameters

Angle
Angle to rotate by
Axis
Normalised axis of rotation in world orientation
Centre
Centre of rotation in world space
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


Scale Method (DicomImage3D)

Scale Method (DicomImage3D)

DicomObjects Namespace > DicomImage3D Class : Scale Method
The factor to scale the image view by
Scale/Zoom the view
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Scale( _
   ByVal Scale As Single _
)
'Usage

Dim instance As DicomImage3D
Dim Scale As Single

instance.Scale(Scale)
public void Scale(
   float Scale
)
public:
void Scale(
   float Scale
)

Parameters

Scale
The factor to scale the image view by
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


ScreenNormal Method

ScreenNormal Method

DicomObjects Namespace > DicomImage3D Class : ScreenNormal Method
Screen normal in World units
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ScreenNormal() As SharpDX.Vector3
'Usage

Dim instance As DicomImage3D
Dim value As SharpDX.Vector3

value = instance.ScreenNormal()
public SharpDX.Vector3 ScreenNormal()
public:
SharpDX.Vector3 ScreenNormal();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


ScreenToImage Method (DicomImage3D)

ScreenToImage Method (DicomImage3D)

DicomObjects Namespace > DicomImage3D Class : ScreenToImage Method
The point on the output space
The Viewer being used for display
Calculate where in image (X,Y) space, a given screen point lies
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ScreenToImage( _
   ByVal ScreenLocation As PointF, _
   ByVal Viewer As DicomViewer _
) As Nullable(Of PointF)
'Usage

Dim instance As DicomImage3D
Dim ScreenLocation As PointF
Dim Viewer As DicomViewer
Dim value As Nullable(Of PointF)

value = instance.ScreenToImage(ScreenLocation, Viewer)
public override Nullable<PointF> ScreenToImage(
   PointF ScreenLocation,
   DicomViewer Viewer
)
public:
Nullable<PointF> ScreenToImage(
   PointF ScreenLocation,
   DicomViewer^ Viewer
) override

Parameters

ScreenLocation
The point on the output space
Viewer
The Viewer being used for display

Return Value

Point in 2D space if appropriate, or null, for 3D images
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members
Base Implementation in ScreenToImage


SetTransferFunction Method

SetTransferFunction Method

DicomObjects Namespace > DicomImage3D Class : SetTransferFunction Method
Set the transfer function (Colour Map) for use in Volume Rendering
Overload List
Overload | Description
SetTransferFunction(Single,Single,Color[]) | Set the transfer function (Colour Map) for use in Volume Rendering
SetTransferFunction(IEnumerable<KeyValuePair<Int32,Color>>) | Set the transfer function for VR from a dictionary of pixel value to Colour lookups
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


SetTransferFunction(Single,Single,Color[]) Method

SetTransferFunction(Single,Single,Color[]) Method

DicomObjects Namespace > DicomImage3D Class > SetTransferFunction Method : SetTransferFunction(Single,Single,Color[]) Method
The pixel value to be mapped to the first element of the Colours array
The pixel value to be mapped to the last element of the Colours array
An array of Color values
Set the transfer function (Colour Map) for use in Volume Rendering
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SetTransferFunction( _
   ByVal Min As Single, _
   ByVal Max As Single, _
   ByVal Colours() As Color _
)
'Usage

Dim instance As DicomImage3D
Dim Min As Single
Dim Max As Single
Dim Colours() As Color

instance.SetTransferFunction(Min, Max, Colours)
public void SetTransferFunction(
   float Min,
   float Max,
   Color[] Colours
)
public:
void SetTransferFunction(
   float Min,
   float Max,
   array<Color>^ Colours
)

Parameters

Min
The pixel value to be mapped to the first element of the Colours array
Max
The pixel value to be mapped to the last element of the Colours array
Colours
An array of Color values
Remarks

The alpha values are central to Volume rendering, and it is important that "transparent" pixel ranges should be to colours with an alpha value < 1.

Pixel values less than the Min value are mapped to the first colour in the array and those greater than the Max value are mapped to the last value.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members
Overload List


SetTransferFunction(IEnumerable<KeyValuePair<Int32,Color>>) Method

SetTransferFunction(IEnumerable<KeyValuePair<Int32,Color>>) Method

DicomObjects Namespace > DicomImage3D Class > SetTransferFunction Method : SetTransferFunction(IEnumerable<KeyValuePair<Int32,Color>>) Method
The list of pixel values and associated colours
Set the transfer function for VR from a dictionary of pixel value to Colour lookups
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SetTransferFunction( _
   ByVal ColourList As IEnumerable(Of KeyValuePair(Of Integer,Color)) _
)
'Usage

Dim instance As DicomImage3D
Dim ColourList As IEnumerable(Of KeyValuePair(Of Integer,Color))

instance.SetTransferFunction(ColourList)
public void SetTransferFunction(
   IEnumerable<KeyValuePair<int,Color>> ColourList
)
public:
void SetTransferFunction(
   IEnumerable<KeyValuePair<int,Color>>^ ColourList
)

Parameters

ColourList
The list of pixel values and associated colours
Remarks

DicomObjects will interpolate between adjacent values, and create a linearised lookup table, which is then passed (alongside the minimum and maximum pixel values to the other override of SetTransferFunction. This method is therefore a "convenience" method to simplify such updates.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members
Overload List


SetViewPlane Method (DicomImage3D)

SetViewPlane Method (DicomImage3D)

DicomObjects Namespace > DicomImage3D Class : SetViewPlane Method
Set the view plane for the image, to one of 3 pre-defined views, with optional reset of centre and zoom
Overload List
Overload | Description
SetViewPlane(Plane,Boolean,Single) | Set the view plane for the image, to one of 3 pre-defined views, with optional reset of centre and zoom
SetViewPlane(Point3D,Vector3D,Vector3D,Single) | Set the view plane for the image, based on centre of the plane, the direction of view, and the "Up" direction.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


SetViewPlane(Plane,Boolean,Single) Method

SetViewPlane(Plane,Boolean,Single) Method

DicomObjects Namespace > DicomImage3D Class > SetViewPlane Method : SetViewPlane(Plane,Boolean,Single) Method
Controls whether the view is set to axial, sagital, coronal, or left unchanged
Controls whether to recentre the view to point to the centre of the image volume
The zoom factor to use - see notes in remarks
Set the view plane for the image, to one of 3 pre-defined views, with optional reset of centre and zoom
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SetViewPlane( _
   ByVal Plane As Plane, _
   ByVal Recentre As Boolean, _
   ByVal Zoom As Single _
)
'Usage

Dim instance As DicomImage3D
Dim Plane As Plane
Dim Recentre As Boolean
Dim Zoom As Single

instance.SetViewPlane(Plane, Recentre, Zoom)
public void SetViewPlane(
   Plane Plane,
   bool Recentre,
   float Zoom
)
public:
void SetViewPlane(
   Plane Plane,
   bool Recentre,
   float Zoom
)

Parameters

Plane
Controls whether the view is set to axial, sagital, coronal, or left unchanged
Recentre
Controls whether to recentre the view to point to the centre of the image volume
Zoom
The zoom factor to use - see notes in remarks
Remarks

Zoom is relative to a "standard" zoom which is internally calculated to include the whole image within the visible display area. If Zoom is 0, then the Zoom of the image is unchanged.

For simple usage to reset the view to be based on the centre point of the image volume, with a conventional anatomical viewpoint, use Recentre = true, and zoom = 1

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members
Overload List


SetViewPlane(Point3D,Vector3D,Vector3D,Single) Method

SetViewPlane(Point3D,Vector3D,Vector3D,Single) Method

DicomObjects Namespace > DicomImage3D Class > SetViewPlane Method : SetViewPlane(Point3D,Vector3D,Vector3D,Single) Method
The coordinates of the centre of the plane
A vector defining the direction of view
The direction to be "up" in the resulting view.
The zoom factor to use - see notes in remarks
Set the view plane for the image, based on centre of the plane, the direction of view, and the "Up" direction.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SetViewPlane( _
   ByVal Centre As Point3D, _
   ByVal Normal As Vector3D, _
   ByVal Up As Vector3D, _
   ByVal Zoom As Single _
)
'Usage

Dim instance As DicomImage3D
Dim Centre As Point3D
Dim Normal As Vector3D
Dim Up As Vector3D
Dim Zoom As Single

instance.SetViewPlane(Centre, Normal, Up, Zoom)
public void SetViewPlane(
   Point3D Centre,
   Vector3D Normal,
   Vector3D Up,
   float Zoom
)
public:
void SetViewPlane(
   Point3D Centre,
   Vector3D Normal,
   Vector3D Up,
   float Zoom
)

Parameters

Centre
The coordinates of the centre of the plane
Normal
A vector defining the direction of view
Up
The direction to be "up" in the resulting view.
Zoom
The zoom factor to use - see notes in remarks
Remarks

All coordinates are in "real world" coordinates, measured in mm.

Zoom is relative to a "standard" zoom which is internally calculated to include the whole image within the visible display area.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members
Overload List


SubImage Method (DicomImage3D)

SubImage Method (DicomImage3D)

DicomObjects Namespace > DicomImage3D Class : SubImage Method
Creates a copy of part or all of the image with controlled size
Overload List
Overload | Description
SubImage(Point,Size,Single,Int32,ScaleMode) | Creates a copy of part or all of the image with controlled size
SubImage(Point,Size,Single,Int32) | Creates a copy of part or all of the image with controlled size (Inherited from DicomObjects.DicomImage)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members
Base Implementation in SubImage


SubImage(Point,Size,Single,Int32,ScaleMode) Method

SubImage(Point,Size,Single,Int32,ScaleMode) Method

DicomObjects Namespace > DicomImage3D Class > SubImage Method : SubImage(Point,Size,Single,Int32,ScaleMode) Method

The left top corner point of the sub Image

The zooming factor which determines the output size

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

The scaling mode to use

Creates a copy of part or all of the image with controlled size
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Overrides Function SubImage( _
   ByVal offset As Point, _
   ByVal imgSize As Size, _
   ByVal Magnification As Single, _
   ByVal frame As Integer, _
   ByVal Scaling As ScaleMode _
) As DicomImage
'Usage

Dim instance As DicomImage3D
Dim offset As Point
Dim imgSize As Size
Dim Magnification As Single
Dim frame As Integer
Dim Scaling As ScaleMode
Dim value As DicomImage

value = instance.SubImage(offset, imgSize, Magnification, frame, Scaling)
public override DicomImage SubImage(
   Point offset,
   Size imgSize,
   float Magnification,
   int frame,
   ScaleMode Scaling
)
public:
DicomImage^ SubImage(
   Point offset,
   Size imgSize,
   float Magnification,
   int frame,
   ScaleMode Scaling
) override

Parameters

offset

The left top corner point of the sub Image

imgSize
Magnification

The zooming factor which determines the output size

frame

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

Scaling

The scaling mode to use

Return Value

A new DicomImage
Remarks

Makes a derived image (of same basic DICOM type as the original) scaled and cropped as required. Size refers to the final image size, whether or not it is transformed as below.

The coordinate system used depends on the value of scaling. If ScaleMode.Image then the original image is used without rotation etc, but if ScaleMode.Output then the image is conceptually flipped, rotated etc. before applying the bounds.

This overload is now recommended in place of the earlier version without the scaling mode which is retained for backwards compatibility only.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members
Overload List
Base Implementation in SubImage(Point,Size,Single,Int32,ScaleMode)


TranslateMm Method (DicomImage3D)

TranslateMm Method (DicomImage3D)

DicomObjects Namespace > DicomImage3D Class : TranslateMm Method
The offset, measured in absolute real world mm
Move the centre point of the view by the specified offset
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub TranslateMm( _
   ByVal Offset As Vector3D _
)
'Usage

Dim instance As DicomImage3D
Dim Offset As Vector3D

instance.TranslateMm(Offset)
public void TranslateMm(
   Vector3D Offset
)
public:
void TranslateMm(
   Vector3D Offset
)

Parameters

Offset
The offset, measured in absolute real world mm
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


TranslateNormal Method (DicomImage3D)

TranslateNormal Method (DicomImage3D)

DicomObjects Namespace > DicomImage3D Class : TranslateNormal Method
The distance, measured in real world mm
Move the centre point of the view by the specified distance, normal to the current view plane
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub TranslateNormal( _
   ByVal Offset As Single _
)
'Usage

Dim instance As DicomImage3D
Dim Offset As Single

instance.TranslateNormal(Offset)
public void TranslateNormal(
   float Offset
)
public:
void TranslateNormal(
   float Offset
)

Parameters

Offset
The distance, measured in real world mm
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


TranslatePixels Method (DicomImage3D)

TranslatePixels Method (DicomImage3D)

DicomObjects Namespace > DicomImage3D Class : TranslatePixels Method
The movement to apply, measured in output pixels
The displaysize of the whole image as currently displayed
Move the display Offset pixels based on output size
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub TranslatePixels( _
   ByVal Offset As SizeF, _
   ByVal Size As Size _
)
'Usage

Dim instance As DicomImage3D
Dim Offset As SizeF
Dim Size As Size

instance.TranslatePixels(Offset, Size)
public void TranslatePixels(
   SizeF Offset,
   Size Size
)
public:
void TranslatePixels(
   SizeF Offset,
   Size Size
)

Parameters

Offset
The movement to apply, measured in output pixels
Size
The displaysize of the whole image as currently displayed
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


DicomImage3D Class Properties

DicomImage3D Class Properties

DicomObjects Namespace : DicomImage3D Class

For a list of all members of this type, see DicomImage3D members.

Public Properties
 | Name | Description
Public Property | AccessionNumber | The Accession Number (Inherited from DicomObjects.DicomImage)
Public Property | Angle | Controls the rotation of an image (Inherited from DicomObjects.DicomImage)
Public Property | Area | The display area of DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | BorderPen | The Pen object for Image border (Inherited from DicomObjects.DicomImage)
Public Property | CacheMode | Controls how the pixel data is cached (Inherited from DicomObjects.DicomImage)
Public Property | CaptureBackColour | User defined background colour for image output of PrinterImage, Bitmap and SubImage methods Default is Black background (Inherited from DicomObjects.DicomImage)
Public Property | CDAStyleSheet | Style sheet used for displaying encapsulated CDA (Inherited from DicomObjects.DicomImage)
Public Property | CineFramesToDisplay | The set of frames to display for cine modes (Inherited from DicomObjects.DicomImage)
Public Property | CineIndex | The index of the currently displayed frame when using CineMode (Inherited from DicomObjects.DicomImage)
Public Property | CineMode | Enumerated running modes for multi-frame image (Inherited from DicomObjects.DicomImage)
Public Property | CineRate | Controls the speed of autonomous cine runs (Inherited from DicomObjects.DicomImage)
Public Property | CineSmoothing | Boolean property indicating whether Smoothing is applied when Cine is being displayed. (Inherited from DicomObjects.DicomImage)
Public Property | ColourTable | The colour lookup table of DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | CubicSplineAlpha | Parameter to control the degree of smoothing. The default value is �0.75, and normal values range from �0.5 to �1.25, though higher negative values may be used to produce deliberate edge enhancement. (Inherited from DicomObjects.DicomImage)
Public Property | CutPlanes | The list of cutplanes applied to the view of the object
Public Property | DataSet | The underlying DICOM Dataset containing persistent data for the image (Inherited from DicomObjects.DicomImage)
Public Property | DateOfBirth | Date of birth of the patient (Inherited from DicomObjects.DicomImage)
Public Property | DiffuseReflection | Switches on and off diffuse reflection (shading)
Public Property | DisplayMode | Controls how the image is rendered internal before transfer to the screen (Inherited from DicomObjects.DicomImage)
Public Property | DownSample | A means to reduce the time time to render images, at the expense of reduced quality
Public Property | DrawCacheMode | Specify the DrawCacheMode to control how image is drawn/cached (Inherited from DicomObjects.DicomImage)
Public Property | EarlyRayTermination | The opacity at which to stop Ray Tracing (VR only)
Public Property | ExplicitModalityLUT | An explicit modality Lookup Table to be used in place of one specified in the image or presentaiton state. (Inherited from DicomObjects.DicomImage)
Public Property | ExplicitPresentationLUT | An explicit presentation Lookup Table to be used in place of one specified in the image or presentaiton state. (Inherited from DicomObjects.DicomImage)
Public Property | ExplicitVOILUT | An explicit Values of Interest (VOI) Lookup Table to be used in place of one specified in the image or presentaiton state. (Inherited from DicomObjects.DicomImage)
Public Property | FilterLength | Contains the length of the smoothing filter (Inherited from DicomObjects.DicomImage)
Public Property | FlipState | The flip state of the image, allowing the orientation of the image, as displayed, to be altered (Inherited from DicomObjects.DicomImage)
Public Property | Frame | Controls which frame of a multi-frame image is displayed (Inherited from DicomObjects.DicomImage)
Public Property | FrameCount | The number of frames contained in a multi-frame image (Inherited from DicomObjects.DicomImage)
Public Property | Gamma | A number that specifies a power (Inherited from DicomObjects.DicomImage)
Public Property | InstanceUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy (Inherited from DicomObjects.DicomImage)
Public Property | Invert | Controls whether the Image will be inverted. (Inherited from DicomObjects.DicomImage)
Public Property | Item | Overloaded. Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file. (Inherited from DicomObjects.DicomImage)
Public Property | JpipRequestSize | The size of the requests other than the first (in bytes) to make to a JPIP server. (Inherited from DicomObjects.DicomImage)
Public Property | Labels | Provides access to the DicomLabelCollection, items of which are to be displayed over an image. (Inherited from DicomObjects.DicomImage)
Public Property | Labels3D | Collection to hold DicomLabel3D objects for display over 3D images.
Public Property | Level | The Window Level (also known as the centre) - which controls the greyscale mapping of a displayed image (Inherited from DicomObjects.DicomImage)
Public Property | LevelShift | Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping (Inherited from DicomObjects.DicomImage)
Public Property | LightDirection | The direction of the ambient light, relative to the eye position
Public Property | LightIntensity | The intensity of the directional (as opposed to ambient) lighting.
Public Property | MagnificationMode | Controls how pixels are interpolated when the image is magnified (Inherited from DicomObjects.DicomImage)
Public Property | MaskRanges | Contains an array of DicomMaskRange objects to be applied to this image. See the DicomMaskRange object for more information on how this is used. (Inherited from DicomObjects.DicomImage)
Public Property | Matrix3D | The Matrix relating real world coordinates (in mm) to the display space (with units -1 to +1 in each dimension)
Public Property | MinificationMode | Controls how pixels are interpolated when the image is minified (Inherited from DicomObjects.DicomImage)
Public Property | ModalityLUT | Enables or disables the Modality Lookup Table to be used in the DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | Name | The Name of the patient (Inherited from DicomObjects.DicomImage)
Public Property | OriginalTs | Original Transfer syntax of the underlying DataSet (Inherited from DicomObjects.DicomImage)
Public Property | OverlayColour | Controls how overlays embedded in the image are displayed (Inherited from DicomObjects.DicomImage)
Public Property | OverlayVisible | Controls whether overlays embedded in the image are displayed (Inherited from DicomObjects.DicomImage)
Public Property | PatientID | The Patient ID (Inherited from DicomObjects.DicomImage)
Public Property | Pixels | Accesses the raw pixel data as a typed array (Inherited from DicomObjects.DicomImage)
Public Property | PresentationLUT | Enables or disables the Presentation Lookup Table to be used in the DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | PresentationState | Support for DICOM greyscale presentation state (Inherited from DicomObjects.DicomImage)
Public Property | PresentationStateFeaturesUsed | The presentation state features to use (Inherited from DicomObjects.DicomImage)
Public Property | PresentationStates | Support for a list of DICOM greyscale presentation state (Inherited from DicomObjects.DicomImage)
Public Property | RawPixels | Accesses the raw pixel data as an array (Inherited from DicomObjects.DicomImage)
Public Property | RealTimeCine | Controls how cine images are displayed (Inherited from DicomObjects.DicomImage)
Public Property | RenderedSize | Overridden. Returns the Image display size in output (normally screen) coordinates
Public Property | RenderMode | The mode used to display an image
Public Property | RotateState | The rotation state of the image, allowing the orientation of the image, as displayed, to be altered (Inherited from DicomObjects.DicomImage)
Public Property | RotationBehaviour | Controls the baseline positioning of an image which is not stretched to fit and is rotated (Inherited from DicomObjects.DicomImage)
Public Property | Scroll | Controls the positioning of an image display (Inherited from DicomObjects.DicomImage)
Public Property | SeriesDescription | Descriptions for the series (Inherited from DicomObjects.DicomImage)
Public Property | SeriesUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy (Inherited from DicomObjects.DicomImage)
Public Property | Sex | Sex of the patient (Inherited from DicomObjects.DicomImage)
Public Property | ShowLabels | Controls whether the image�s labels (annotations) are shown on screen (Inherited from DicomObjects.DicomImage)
Public Property | ShowShutter | Controls whether image shutters (if specified in the image) are used. (Inherited from DicomObjects.DicomImage)
Public Property | ShowUpdates | Controls whether the images is updated when image display parameters change (Inherited from DicomObjects.DicomImage)
Public Property | Size | The dimensions of the image (Inherited from DicomObjects.DicomImage)
Public Property | SlabThickness | Thickness for rendering Minimum, Maximum and Average (slab)
Public Property | SOPClass | SOP class of the DicomDataSet. (Inherited from DicomObjects.DicomImage)
Public Property | SpecularExponent | Controls broadness of specular reflection component (VR only)
Public Property | SpecularIntensity | Controls the intensity of specular reflection (VR only)
Public Property | Step | Step to use when RayCasting (MIP & VR only)
Public Property | StretchMode | Controls the automatic zooming of an image. (Inherited from DicomObjects.DicomImage)
Public Property | StudyDescription | Description for the study (Inherited from DicomObjects.DicomImage)
Public Property | StudyUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy (Inherited from DicomObjects.DicomImage)
Public Property | Tag | A general purpose Tag for developer use (Inherited from DicomObjects.DicomImage)
Public Property | UnsharpEnhancement | UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement (Inherited from DicomObjects.DicomImage)
Public Property | UnsharpLength | UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement (Inherited from DicomObjects.DicomImage)
Public Property | UserMatrix | Means to override the matrix used to display 2D images (Inherited from DicomObjects.DicomImage)
Public Property | VoiLUT | The VOI Lookup Table to be used to display the DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | VOILUTFunction | Controls which VOILUT function to be used, default value is Linear (Inherited from DicomObjects.DicomImage)
Public Property | VoiLUTInUse | Indicates whether a Values of Interest Lookup Table is in use (Inherited from DicomObjects.DicomImage)
Public Property | Volume | The DicomVolume on which this DicomImage3D is based.
Public Property | Width | The Window "Width" - which controls the greyscale mapping of a displayed image (Inherited from DicomObjects.DicomImage)
Public Property | WidthMultiplier | Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping (Inherited from DicomObjects.DicomImage)
Public Property | Zoom | Controls the magnification of an image display (Inherited from DicomObjects.DicomImage)
Top
See Also

Reference

DicomImage3D Class
DicomObjects Namespace


CutPlanes Property

CutPlanes Property

DicomObjects Namespace > DicomImage3D Class : CutPlanes Property
The list of cutplanes applied to the view of the object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property CutPlanes As List(Of Vector4)
'Usage

Dim instance As DicomImage3D
Dim value As List(Of Vector4)

value = instance.CutPlanes
public List<Vector4> CutPlanes {get;}
public:
property List<Vector4>^ CutPlanes {
   List<Vector4>^ get();
}
Remarks
The cutplanes are in real-world units, and limit display to an area where point A,B,C is displayed only if AX + BY + CZ + W > 0 where X,Y,Z & W are the components of the cutplane vector.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


DiffuseReflection Property

DiffuseReflection Property

DicomObjects Namespace > DicomImage3D Class : DiffuseReflection Property
Switches on and off diffuse reflection (shading)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DiffuseReflection As Single
'Usage

Dim instance As DicomImage3D
Dim value As Single

instance.DiffuseReflection = value

value = instance.DiffuseReflection
public float DiffuseReflection {get; set;}
public:
property float DiffuseReflection {
   float get();
   void set (    float value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


DownSample Property

DownSample Property

DicomObjects Namespace > DicomImage3D Class : DownSample Property
A means to reduce the time time to render images, at the expense of reduced quality
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DownSample As Single
'Usage

Dim instance As DicomImage3D
Dim value As Single

instance.DownSample = value

value = instance.DownSample
public float DownSample {get; set;}
public:
property float DownSample {
   float get();
   void set (    float value);
}
Remarks

The normal and default value of this property is 1.0, meaning that 3D images are rendered internally at full resolution before being copied to the screen. If this property is set to a higher value, then the internally generated copy of the image is reduced by this factor (in both dimensions) which can be significantly faster, and the resulting copy is then magnified by the same factor when copied to the screen

In practice, this is only likely to be useful on old hardware/very large 3D data, and would normally be set to a value such as 2.0 at the start of dynamic image manipulation (such as during the MouseDown event), and then reverted to 1.0 at the end (such as during the MouseUp event).

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


EarlyRayTermination Property

EarlyRayTermination Property

DicomObjects Namespace > DicomImage3D Class : EarlyRayTermination Property
The opacity at which to stop Ray Tracing (VR only)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EarlyRayTermination As Single
'Usage

Dim instance As DicomImage3D
Dim value As Single

instance.EarlyRayTermination = value

value = instance.EarlyRayTermination
public float EarlyRayTermination {get; set;}
public:
property float EarlyRayTermination {
   float get();
   void set (    float value);
}
Remarks
This is used to speed up ray tracing. Once the cumulative alpha value along a ray is greater than alpha, rendering that ray stops. The value should be 0 to 1.0. Setting to 1.0 will render all data (no early ray termination).
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


Labels3D Property

Labels3D Property

DicomObjects Namespace > DicomImage3D Class : Labels3D Property
Collection to hold DicomLabel3D objects for display over 3D images.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Labels3D As Collection(Of DicomLabel3D)
'Usage

Dim instance As DicomImage3D
Dim value As Collection(Of DicomLabel3D)

value = instance.Labels3D
public Collection<DicomLabel3D> Labels3D {get;}
public:
property Collection<DicomLabel3D^>^ Labels3D {
   Collection<DicomLabel3D^>^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


LightDirection Property

LightDirection Property

DicomObjects Namespace > DicomImage3D Class : LightDirection Property
The direction of the ambient light, relative to the eye position
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LightDirection As SharpDX.Vector3
'Usage

Dim instance As DicomImage3D
Dim value As SharpDX.Vector3

instance.LightDirection = value

value = instance.LightDirection
public SharpDX.Vector3 LightDirection {get; set;}
public:
property SharpDX.Vector3 LightDirection {
   SharpDX.Vector3 get();
   void set (    SharpDX.Vector3 value);
}
Remarks
The default value is (0,1,1), corresponding to a light source directly above the eye position, shining downwards at 45 degrees.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


LightIntensity Property

LightIntensity Property

DicomObjects Namespace > DicomImage3D Class : LightIntensity Property
The intensity of the directional (as opposed to ambient) lighting.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LightIntensity As Single
'Usage

Dim instance As DicomImage3D
Dim value As Single

instance.LightIntensity = value

value = instance.LightIntensity
public float LightIntensity {get; set;}
public:
property float LightIntensity {
   float get();
   void set (    float value);
}
Remarks

The direction of the light is defined by the LightDirection property, and the default value is 0.6.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


Matrix3D Property (DicomImage3D)

Matrix3D Property (DicomImage3D)

DicomObjects Namespace > DicomImage3D Class : Matrix3D Property
The Matrix relating real world coordinates (in mm) to the display space (with units -1 to +1 in each dimension)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Matrix3D As SharpDX.Matrix
'Usage

Dim instance As DicomImage3D
Dim value As SharpDX.Matrix

instance.Matrix3D = value

value = instance.Matrix3D
public SharpDX.Matrix Matrix3D {get; set;}
public:
property SharpDX.Matrix Matrix3D {
   SharpDX.Matrix get();
   void set (    SharpDX.Matrix value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


RenderedSize Property (DicomImage3D)

RenderedSize Property (DicomImage3D)

DicomObjects Namespace > DicomImage3D Class : RenderedSize Property
Returns the Image display size in output (normally screen) coordinates
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property RenderedSize As Size
'Usage

Dim instance As DicomImage3D
Dim value As Size

value = instance.RenderedSize
public override Size RenderedSize {get;}
public:
property Size RenderedSize {
   Size get() override;
}
Remarks
For 3D images, the size is the maximum of the 3 dimensions of the volume, squared.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members
Base Implementation in RenderedSize


RenderMode Property

RenderMode Property

DicomObjects Namespace > DicomImage3D Class : RenderMode Property
The mode used to display an image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RenderMode As RenderMode3D
'Usage

Dim instance As DicomImage3D
Dim value As RenderMode3D

instance.RenderMode = value

value = instance.RenderMode
public RenderMode3D RenderMode {get; set;}
public:
property RenderMode3D RenderMode {
   RenderMode3D get();
   void set (    RenderMode3D value);
}
Remarks
Although this property must be specified in the constructor, it may be changed without generating a new image
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


SlabThickness Property

SlabThickness Property

DicomObjects Namespace > DicomImage3D Class : SlabThickness Property
Thickness for rendering Minimum, Maximum and Average (slab)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SlabThickness As Single
'Usage

Dim instance As DicomImage3D
Dim value As Single

instance.SlabThickness = value

value = instance.SlabThickness
public float SlabThickness {get; set;}
public:
property float SlabThickness {
   float get();
   void set (    float value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


SpecularExponent Property

SpecularExponent Property

DicomObjects Namespace > DicomImage3D Class : SpecularExponent Property
Controls broadness of specular reflection component (VR only)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SpecularExponent As Single
'Usage

Dim instance As DicomImage3D
Dim value As Single

instance.SpecularExponent = value

value = instance.SpecularExponent
public float SpecularExponent {get; set;}
public:
property float SpecularExponent {
   float get();
   void set (    float value);
}
Remarks

If value is large specular reflection approaches perfect mirror

If value is small will be very diffuse

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


SpecularIntensity Property

SpecularIntensity Property

DicomObjects Namespace > DicomImage3D Class : SpecularIntensity Property
Controls the intensity of specular reflection (VR only)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SpecularIntensity As Single
'Usage

Dim instance As DicomImage3D
Dim value As Single

instance.SpecularIntensity = value

value = instance.SpecularIntensity
public float SpecularIntensity {get; set;}
public:
property float SpecularIntensity {
   float get();
   void set (    float value);
}
Remarks
Typically a value between 0 and 1.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


Step Property

Step Property

DicomObjects Namespace > DicomImage3D Class : Step Property
Step to use when RayCasting (MIP & VR only)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Step As Single
'Usage

Dim instance As DicomImage3D
Dim value As Single

instance.Step = value

value = instance.Step
public float Step {get; set;}
public:
property float Step {
   float get();
   void set (    float value);
}
Remarks
Size of the step used, as a multiplier of the minimum voxel dimension. Default is 0.5
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


Volume Property (DicomImage3D)

Volume Property (DicomImage3D)

DicomObjects Namespace > DicomImage3D Class : Volume Property
The DicomVolume on which this DicomImage3D is based.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Volume As DicomVolume
'Usage

Dim instance As DicomImage3D
Dim value As DicomVolume

value = instance.Volume
public DicomVolume Volume {get;}
public:
property DicomVolume^ Volume {
   DicomVolume^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members


DicomImageCollection Class

DicomImageCollection Class
Members

DicomObjects Namespace : DicomImageCollection Class
A Collection of DicomImage objects
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomImageCollection
   Inherits System.Collections.ObjectModel.Collection(Of DicomImage)
'Usage

Dim instance As DicomImageCollection
public class DicomImageCollection : System.Collections.ObjectModel.Collection<DicomImage>
public ref class DicomImageCollection : public System.Collections.ObjectModel.Collection<DicomImage>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
DicomObjects.DicomImageCollection

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCollection Members
DicomObjects Namespace


DicomImageCollection Class Members

DicomImageCollection Class Members
Properties Methods

DicomObjects Namespace : DicomImageCollection Class

The following tables list the members exposed by DicomImageCollection.

Public Constructors
 | Name | Description
Public Constructor | DicomImageCollection Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Property | Item | Overloaded. Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Public Property | Tag | A general purpose Tag for developer use
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a DicomImageCollection to a DicomImageCollection
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | Clone | Returns a Shallow copy of the DicomImageCollection
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | Dispose | Release all resources used by DicomImageCollection
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | MakeEnhancedMultiFrame | Creates a single enhanced multi-frame object from a collection of individual images.
Public Method | MakeMultiFrame | Creates a single multi-frame object from a collection of individual images.
Public Method | Move | Moves a DicomImage within a DicomDicomImageCollection.
Public Method | Read | Overloaded. Creates and adds one or more DicomImage objects from an external DICOM file, a byte array, a system IO stream or a collection of external DICOM files.
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | Send | Sends all images within the collection in one association
Top
See Also

Reference

DicomImageCollection Class
DicomObjects Namespace


DicomImageCollection Constructor

DicomImageCollection Constructor

DicomObjects Namespace > DicomImageCollection Class : DicomImageCollection Constructor
Overload List
Overload | Description
DicomImageCollection Constructor() | Create a blank DicomImageCollection object
DicomImageCollection Constructor(IEnumerable<DicomImage>) | Create a DicomImageCollection from an enumeration
DicomImageCollection Constructor(IEnumerable<DicomDataSet>) | Create a DicomImageCollection from an enumeration
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCollection Class
DicomImageCollection Members


DicomImageCollection Constructor()

DicomImageCollection Constructor()

DicomObjects Namespace > DicomImageCollection Class > DicomImageCollection Constructor : DicomImageCollection Constructor()
Create a blank DicomImageCollection object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DicomImageCollection()
public DicomImageCollection()
public:
DicomImageCollection();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCollection Class
DicomImageCollection Members
Overload List


DicomImageCollection Constructor(IEnumerable<DicomImage>)

DicomImageCollection Constructor(IEnumerable<DicomImage>)

DicomObjects Namespace > DicomImageCollection Class > DicomImageCollection Constructor : DicomImageCollection Constructor(IEnumerable<DicomImage>)
Create a DicomImageCollection from an enumeration
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal Images As IEnumerable(Of DicomImage) _
)
'Usage

Dim Images As IEnumerable(Of DicomImage)

Dim instance As New DicomImageCollection(Images)
public DicomImageCollection(
   IEnumerable<DicomImage> Images
)
public:
DicomImageCollection(
   IEnumerable<DicomImage^>^ Images
)

Parameters

Images
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCollection Class
DicomImageCollection Members
Overload List


DicomImageCollection Constructor(IEnumerable<DicomDataSet>)

DicomImageCollection Constructor(IEnumerable<DicomDataSet>)

DicomObjects Namespace > DicomImageCollection Class > DicomImageCollection Constructor : DicomImageCollection Constructor(IEnumerable<DicomDataSet>)
Create a DicomImageCollection from an enumeration
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal DataSets As IEnumerable(Of DicomDataSet) _
)
'Usage

Dim DataSets As IEnumerable(Of DicomDataSet)

Dim instance As New DicomImageCollection(DataSets)
public DicomImageCollection(
   IEnumerable<DicomDataSet> DataSets
)
public:
DicomImageCollection(
   IEnumerable<DicomDataSet^>^ DataSets
)

Parameters

DataSets
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCollection Class
DicomImageCollection Members
Overload List


DicomImageCollection Class Methods

DicomImageCollection Class Methods

DicomObjects Namespace : DicomImageCollection Class

For a list of all members of this type, see DicomImageCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a DicomImageCollection to a DicomImageCollection
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | Clone | Returns a Shallow copy of the DicomImageCollection
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | Dispose | Release all resources used by DicomImageCollection
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | MakeEnhancedMultiFrame | Creates a single enhanced multi-frame object from a collection of individual images.
Public Method | MakeMultiFrame | Creates a single multi-frame object from a collection of individual images.
Public Method | Move | Moves a DicomImage within a DicomDicomImageCollection.
Public Method | Read | Overloaded. Creates and adds one or more DicomImage objects from an external DICOM file, a byte array, a system IO stream or a collection of external DICOM files.
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | Send | Sends all images within the collection in one association
Top
See Also

Reference

DicomImageCollection Class
DicomObjects Namespace


Add Method (DicomImageCollection)

Add Method (DicomImageCollection)

DicomObjects Namespace > DicomImageCollection Class : Add Method
Adds a DicomImageCollection to a DicomImageCollection
Overload List
Overload | Description
Add(IEnumerable<DicomImage>) | Adds a DicomImageCollection to a DicomImageCollection
Add(IEnumerable<DicomDataSet>) | Adds a DicomDataSetCollection to a DicomImageCollection
Add(DicomImage) | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCollection Class
DicomImageCollection Members


Add(IEnumerable<DicomImage>) Method

Add(IEnumerable<DicomImage>) Method

DicomObjects Namespace > DicomImageCollection Class > Add Method : Add(IEnumerable<DicomImage>) Method

The DicomImageCollection to be added to the collection

Adds a DicomImageCollection to a DicomImageCollection
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal value As IEnumerable(Of DicomImage) _
)
'Usage

Dim instance As DicomImageCollection
Dim value As IEnumerable(Of DicomImage)

instance.Add(value)
public void Add(
   IEnumerable<DicomImage> value
)
public:
void Add(
   IEnumerable<DicomImage^>^ value
)

Parameters

value

The DicomImageCollection to be added to the collection

Remarks
Adds a DicomImageCollection to the end of another DicomImageCollection
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCollection Class
DicomImageCollection Members
Overload List


Add(IEnumerable<DicomDataSet>) Method

Add(IEnumerable<DicomDataSet>) Method

DicomObjects Namespace > DicomImageCollection Class > Add Method : Add(IEnumerable<DicomDataSet>) Method

The DicomDataSetCollection to be added to the collection

Adds a DicomDataSetCollection to a DicomImageCollection
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal value As IEnumerable(Of DicomDataSet) _
)
'Usage

Dim instance As DicomImageCollection
Dim value As IEnumerable(Of DicomDataSet)

instance.Add(value)
public void Add(
   IEnumerable<DicomDataSet> value
)
public:
void Add(
   IEnumerable<DicomDataSet^>^ value
)

Parameters

value

The DicomDataSetCollection to be added to the collection

Remarks
Similar to adding a DicomImage to DicomImageCollection, this method adds a collection of DicomDataSets to the end of a DicomImageCollection.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCollection Class
DicomImageCollection Members
Overload List


Clone Method (DicomImageCollection)

Clone Method (DicomImageCollection)

DicomObjects Namespace > DicomImageCollection Class : Clone Method
Returns a Shallow copy of the DicomImageCollection
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function Clone() As Object
'Usage

Dim instance As DicomImageCollection
Dim value As Object

value = instance.Clone()
public virtual object Clone()
public:
virtual Object^ Clone();

Return Value

DicomImageCollection
Remarks

This method makes a Shallow Copy of the DicomImageCollection.

A shallow copy will only have the top level objects replicated, any referenced objects under top level will be shared by the original DicomImageCollection and the cloned copy.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCollection Class
DicomImageCollection Members


Dispose Method (DicomImageCollection)

Dispose Method (DicomImageCollection)

DicomObjects Namespace > DicomImageCollection Class : Dispose Method
Release all resources used by DicomImageCollection
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As DicomImageCollection

instance.Dispose()
public void Dispose()
public:
void Dispose();
Remarks
Standard Dispose method.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCollection Class
DicomImageCollection Members


MakeEnhancedMultiFrame Method

MakeEnhancedMultiFrame Method

DicomObjects Namespace > DicomImageCollection Class : MakeEnhancedMultiFrame Method
True if the images should be removed from the collection after this function call.
Creates a single enhanced multi-frame object from a collection of individual images.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function MakeEnhancedMultiFrame( _
   ByVal Remove As Boolean _
) As DicomImage
'Usage

Dim instance As DicomImageCollection
Dim Remove As Boolean
Dim value As DicomImage

value = instance.MakeEnhancedMultiFrame(Remove)
public DicomImage MakeEnhancedMultiFrame(
   bool Remove
)
public:
DicomImage^ MakeEnhancedMultiFrame(
   bool Remove
)

Parameters

Remove
True if the images should be removed from the collection after this function call.

Return Value

The new DicomImage
Remarks

Constructs a single enhanced multi-frame image from a series of identically-sized single frame images, which have been collected into a DicomImageCollection. If the argument is true, the images are removed from the collection as they are added to the new object. Unlike MakeMultiFrame, data is taken from all frames, and incorporated into the Common or PerFrame functional groups, not from the first image only.

Note that the newly created multi-frame image may need some modifications, as DicomObjects has no knowledge of many attributes which only exist in enhanced images but it does do much of the hard work

If you find any attributes which you feel should be moved to functional groups but which are not, then please contact support@medicalconnections.co.uk

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCollection Class
DicomImageCollection Members


MakeMultiFrame Method

MakeMultiFrame Method

DicomObjects Namespace > DicomImageCollection Class : MakeMultiFrame Method
True if the images should be removed from the collection after this function call.
Creates a single multi-frame object from a collection of individual images.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function MakeMultiFrame( _
   ByVal remove As Boolean _
) As DicomImage
'Usage

Dim instance As DicomImageCollection
Dim remove As Boolean
Dim value As DicomImage

value = instance.MakeMultiFrame(remove)
public DicomImage MakeMultiFrame(
   bool remove
)
public:
DicomImage^ MakeMultiFrame(
   bool remove
)

Parameters

remove
True if the images should be removed from the collection after this function call.

Return Value

The new DicomImage
Remarks

Constructs a single multi-frame image from a series of identically-sized single frame images, which have been collected into a DicomImageCollection. If the argument is true, the images are removed from the collection as they are added to the new object. Apart from the pixel data, all information is copied from the first image only.

Note that the newly created multi-frame image may need some modifications, as DicomObjects has no knowledge of the relationship between frames. By default, attributes 0028,0009 & 0018,1063 are set to give a constant 10 frames per second. These may need to be removed/changed.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCollection Class
DicomImageCollection Members


Move Method (DicomImageCollection)

Move Method (DicomImageCollection)

DicomObjects Namespace > DicomImageCollection Class : Move Method

The current index in the collection

The destination index for the image within the collection

Moves a DicomImage within a DicomDicomImageCollection.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Move( _
   ByVal From As Integer, _
   ByVal To As Integer _
)
'Usage

Dim instance As DicomImageCollection
Dim From As Integer
Dim To As Integer

instance.Move(From, To)
public void Move(
   int From,
   int To
)
public:
void Move(
   int From,
   int To
)

Parameters

From

The current index in the collection

To

The destination index for the image within the collection

Remarks
By using Move, Images may be re-ordered within the collection. The Image referred to by the index is placed at the position given by To, other Images are kept in sequence but moved as necessary to accommodate the moved item.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCollection Class
DicomImageCollection Members


Read Method (DicomImageCollection)

Read Method (DicomImageCollection)

DicomObjects Namespace > DicomImageCollection Class : Read Method
Creates and adds one or more DicomImage objects from an external DICOM file, a byte array, a system IO stream or a collection of external DICOM files.
Overload List
Overload | Description
Read(String,ReadBehaviours) | Creates and adds a DicomImage from an external DICOM file
Read(Byte[],ReadBehaviours) | Creates and adds a DicomImage from a byte array
Read(IEnumerable<String>,ReadBehaviours) | Creates and adds DicomImage objects from a collection of external DICOM files
Read(Stream,ReadBehaviours) | Reads a DICOM file from a Stream
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCollection Class
DicomImageCollection Members


Read(String,ReadBehaviours) Method

Read(String,ReadBehaviours) Method

DicomObjects Namespace > DicomImageCollection Class > Read Method : Read(String,ReadBehaviours) Method

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container’s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

The behaviours to be used when reading this stream

Creates and adds a DicomImage from an external DICOM file
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Read( _
   ByVal FileName As String, _
   Optional ByVal ReadBehaviour As ReadBehaviours _
) As DicomImage
'Usage

Dim instance As DicomImageCollection
Dim FileName As String
Dim ReadBehaviour As ReadBehaviours
Dim value As DicomImage

value = instance.Read(FileName, ReadBehaviour)
public DicomImage Read(
   string FileName,
   ReadBehaviours ReadBehaviour
)
public:
DicomImage^ Read(
   String^ FileName,
   ReadBehaviours^ ReadBehaviour
)

Parameters

FileName

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container’s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

ReadBehaviour

The behaviours to be used when reading this stream

Return Value

If successful, a DicomImage Object is returned, and is added to the appropriate collection. If unsuccessful, an appropriate error is thrown.
Remarks

This method can read either official "Part10" format files with the 128 byte header, or unofficial "Part5" format files without a header. Detection of the type is automatic.

The file may have been written by the Write method or by other DICOM software.

By default, pixel data is read only when it is required, greatly speeding the display of multi-frame images, and reducing memory requirements. However, a side effect of this is that any elements after the pixel data (7FE0,0010) will not be read. This should not affect most applications, but if necessary, this behavior may be over-ridden using the CloseFilesAfterReading property.

Another effect of file mapping is that files read using this method cannot be deleted until the image object is released. This method creates two references to the newly created DicomImage object (one in the collection, and one as the return value), and both must be released before the file can be deleted.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCollection Class
DicomImageCollection Members
Overload List


Read(Byte[],ReadBehaviours) Method

Read(Byte[],ReadBehaviours) Method

DicomObjects Namespace > DicomImageCollection Class > Read Method : Read(Byte[],ReadBehaviours) Method
Array of Bytes to read

The behaviours to be used when reading this stream

Creates and adds a DicomImage from a byte array
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Read( _
   ByVal Array() As Byte, _
   Optional ByVal ReadBehaviour As ReadBehaviours _
) As DicomImage
'Usage

Dim instance As DicomImageCollection
Dim Array() As Byte
Dim ReadBehaviour As ReadBehaviours
Dim value As DicomImage

value = instance.Read(Array, ReadBehaviour)
public DicomImage Read(
   byte[] Array,
   ReadBehaviours ReadBehaviour
)
public:
DicomImage^ Read(
   array<byte>^ Array,
   ReadBehaviours^ ReadBehaviour
)

Parameters

Array
Array of Bytes to read
ReadBehaviour

The behaviours to be used when reading this stream

Return Value

If successful, a DicomImage Object is returned, and is added to the appropriate collection. If unsuccessful, an appropriate error is thrown.
Remarks
This method uses memory stream to read a byte array and creates a new DicomImage and adds it to the DicomImageCollection.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCollection Class
DicomImageCollection Members
Overload List


Read(IEnumerable<String>,ReadBehaviours) Method

Read(IEnumerable<String>,ReadBehaviours) Method

DicomObjects Namespace > DicomImageCollection Class > Read Method : Read(IEnumerable<String>,ReadBehaviours) Method
A set of filenames as strings

The behaviours to be used when reading this stream

Creates and adds DicomImage objects from a collection of external DICOM files
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Read( _
   ByVal FileNames As IEnumerable(Of String), _
   Optional ByVal ReadBehaviour As ReadBehaviours _
)
'Usage

Dim instance As DicomImageCollection
Dim FileNames As IEnumerable(Of String)
Dim ReadBehaviour As ReadBehaviours

instance.Read(FileNames, ReadBehaviour)
public void Read(
   IEnumerable<string> FileNames,
   ReadBehaviours ReadBehaviour
)
public:
void Read(
   IEnumerable<String^>^ FileNames,
   ReadBehaviours^ ReadBehaviour
)

Parameters

FileNames
A set of filenames as strings
ReadBehaviour

The behaviours to be used when reading this stream

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCollection Class
DicomImageCollection Members
Overload List


Read(Stream,ReadBehaviours) Method

Read(Stream,ReadBehaviours) Method

DicomObjects Namespace > DicomImageCollection Class > Read Method : Read(Stream,ReadBehaviours) Method

The Stream from which to read.

The behaviours to be used when reading this stream

Reads a DICOM file from a Stream
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Read( _
   ByVal Stream As Stream, _
   Optional ByVal ReadBehaviour As ReadBehaviours _
) As DicomImage
'Usage

Dim instance As DicomImageCollection
Dim Stream As Stream
Dim ReadBehaviour As ReadBehaviours
Dim value As DicomImage

value = instance.Read(Stream, ReadBehaviour)
public DicomImage Read(
   Stream Stream,
   ReadBehaviours ReadBehaviour
)
public:
DicomImage^ Read(
   Stream^ Stream,
   ReadBehaviours^ ReadBehaviour
)

Parameters

Stream

The Stream from which to read.

ReadBehaviour

The behaviours to be used when reading this stream

Return Value

If successful, a DicomImage Object is returned, and is added to the appropriate collection. If unsuccessful, an appropriate error is thrown.
Remarks

This method can read streams in either official "Part10" format, with the 128 byte header, or unofficial "Part5" format, without a header. Detection of the type is automatic.

The stream may have been written by the Write method or by other DICOM software.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCollection Class
DicomImageCollection Members
Overload List


Send Method (DicomImageCollection)

Send Method (DicomImageCollection)

DicomObjects Namespace > DicomImageCollection Class : Send Method
The IP address
The port number
The calling application entity title
The called application entity title
Sends all images within the collection in one association
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function Send( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAE As String, _
   ByVal CalledAE As String _
) As Integer()
'Usage

Dim instance As DicomImageCollection
Dim Node As String
Dim Port As Integer
Dim CallingAE As String
Dim CalledAE As String
Dim value() As Integer

value = instance.Send(Node, Port, CallingAE, CalledAE)
public int[] Send(
   string Node,
   int Port,
   string CallingAE,
   string CalledAE
)
public:
array<int>^ Send(
   String^ Node,
   int Port,
   String^ CallingAE,
   String^ CalledAE
)

Parameters

Node
The IP address
Port
The port number
CallingAE
The calling application entity title
CalledAE
The called application entity title

Return Value

int Array, as status of each image transfer
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCollection Class
DicomImageCollection Members


DicomImageCollection Class Properties

DicomImageCollection Class Properties

DicomObjects Namespace : DicomImageCollection Class

For a list of all members of this type, see DicomImageCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Property | Item | Overloaded. Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Public Property | Tag | A general purpose Tag for developer use
Top
See Also

Reference

DicomImageCollection Class
DicomObjects Namespace


Item Property (DicomImageCollection)

Item Property (DicomImageCollection)

DicomObjects Namespace > DicomImageCollection Class : Item Property
Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
The default indexer of collection object
Overload List
Overload | Description
Item(String) | Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Item(Int32) | Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file. (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCollection Class
DicomImageCollection Members


Item(String) Property

Item(String) Property

DicomObjects Namespace > DicomImageCollection Class > Item Property : Item(String) Property
Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal InstanceUID As String _
) As DicomImage
'Usage

Dim instance As DicomImageCollection
Dim InstanceUID As String
Dim value As DicomImage

value = instance.Item(InstanceUID)
public DicomImage Item(
   string InstanceUID
) {get;}
public:
property DicomImage^ Item {
   DicomImage^ get(String^ InstanceUID);
}

Parameters

InstanceUID
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCollection Class
DicomImageCollection Members
Overload List


Tag Property (DicomImageCollection)

Tag Property (DicomImageCollection)

DicomObjects Namespace > DicomImageCollection Class : Tag Property
A general purpose Tag for developer use
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Tag As Object
'Usage

Dim instance As DicomImageCollection
Dim value As Object

instance.Tag = value

value = instance.Tag
public object Tag {get; set;}
public:
property Object^ Tag {
   Object^ get();
   void set (    Object^ value);
}
Remarks
This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCollection Class
DicomImageCollection Members


DicomImageCurvedMPR Class

DicomImageCurvedMPR Class
Members

DicomObjects Namespace : DicomImageCurvedMPR Class
Class to display 3D DICOM data as a curved MPR
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomImageCurvedMPR
   Inherits DicomImage
'Usage

Dim instance As DicomImageCurvedMPR
public class DicomImageCurvedMPR : DicomImage
public ref class DicomImageCurvedMPR : public DicomImage
Remarks

This object allows the display of an arbitrary plane through a 3D volume, as defined by the data passed to the SetCurve method. In most cases this is likely to represent a simple curved plane (curved in one dimension and straight in the other), but arbitrary data points are possible. DicomObjects will interpolate between the cooridinates provided.

Inheritance Hierarchy

System.Object
DicomObjects.DicomImage
DicomObjects.DicomImageCurvedMPR

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCurvedMPR Members
DicomObjects Namespace


DicomImageCurvedMPR Class Members

DicomImageCurvedMPR Class Members
Properties Methods Events

DicomObjects Namespace : DicomImageCurvedMPR Class

The following tables list the members exposed by DicomImageCurvedMPR.

Public Constructors
 | Name | Description
Public Constructor | DicomImageCurvedMPR Constructor | Create a curved MPR image from a DicomVolume
Top
Public Properties
 | Name | Description
Public Property | AccessionNumber | The Accession Number (Inherited from DicomObjects.DicomImage)
Public Property | Angle | Controls the rotation of an image (Inherited from DicomObjects.DicomImage)
Public Property | Area | The display area of DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | BorderPen | The Pen object for Image border (Inherited from DicomObjects.DicomImage)
Public Property | CacheMode | Controls how the pixel data is cached (Inherited from DicomObjects.DicomImage)
Public Property | CaptureBackColour | User defined background colour for image output of PrinterImage, Bitmap and SubImage methods Default is Black background (Inherited from DicomObjects.DicomImage)
Public Property | CDAStyleSheet | Style sheet used for displaying encapsulated CDA (Inherited from DicomObjects.DicomImage)
Public Property | CineFramesToDisplay | The set of frames to display for cine modes (Inherited from DicomObjects.DicomImage)
Public Property | CineIndex | The index of the currently displayed frame when using CineMode (Inherited from DicomObjects.DicomImage)
Public Property | CineMode | Enumerated running modes for multi-frame image (Inherited from DicomObjects.DicomImage)
Public Property | CineRate | Controls the speed of autonomous cine runs (Inherited from DicomObjects.DicomImage)
Public Property | CineSmoothing | Boolean property indicating whether Smoothing is applied when Cine is being displayed. (Inherited from DicomObjects.DicomImage)
Public Property | ColourTable | The colour lookup table of DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | CubicSplineAlpha | Parameter to control the degree of smoothing. The default value is �0.75, and normal values range from �0.5 to �1.25, though higher negative values may be used to produce deliberate edge enhancement. (Inherited from DicomObjects.DicomImage)
Public Property | DataSet | The underlying DICOM Dataset containing persistent data for the image (Inherited from DicomObjects.DicomImage)
Public Property | DateOfBirth | Date of birth of the patient (Inherited from DicomObjects.DicomImage)
Public Property | DisplayMode | Controls how the image is rendered internal before transfer to the screen (Inherited from DicomObjects.DicomImage)
Public Property | DrawCacheMode | Specify the DrawCacheMode to control how image is drawn/cached (Inherited from DicomObjects.DicomImage)
Public Property | ExplicitModalityLUT | An explicit modality Lookup Table to be used in place of one specified in the image or presentaiton state. (Inherited from DicomObjects.DicomImage)
Public Property | ExplicitPresentationLUT | An explicit presentation Lookup Table to be used in place of one specified in the image or presentaiton state. (Inherited from DicomObjects.DicomImage)
Public Property | ExplicitVOILUT | An explicit Values of Interest (VOI) Lookup Table to be used in place of one specified in the image or presentaiton state. (Inherited from DicomObjects.DicomImage)
Public Property | FilterLength | Contains the length of the smoothing filter (Inherited from DicomObjects.DicomImage)
Public Property | FlipState | The flip state of the image, allowing the orientation of the image, as displayed, to be altered (Inherited from DicomObjects.DicomImage)
Public Property | Frame | Controls which frame of a multi-frame image is displayed (Inherited from DicomObjects.DicomImage)
Public Property | FrameCount | The number of frames contained in a multi-frame image (Inherited from DicomObjects.DicomImage)
Public Property | Gamma | A number that specifies a power (Inherited from DicomObjects.DicomImage)
Public Property | InstanceUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy (Inherited from DicomObjects.DicomImage)
Public Property | Invert | Controls whether the Image will be inverted. (Inherited from DicomObjects.DicomImage)
Public Property | Item | Overloaded. Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file. (Inherited from DicomObjects.DicomImage)
Public Property | JpipRequestSize | The size of the requests other than the first (in bytes) to make to a JPIP server. (Inherited from DicomObjects.DicomImage)
Public Property | Labels | Provides access to the DicomLabelCollection, items of which are to be displayed over an image. (Inherited from DicomObjects.DicomImage)
Public Property | Level | The Window Level (also known as the centre) - which controls the greyscale mapping of a displayed image (Inherited from DicomObjects.DicomImage)
Public Property | LevelShift | Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping (Inherited from DicomObjects.DicomImage)
Public Property | MagnificationMode | Controls how pixels are interpolated when the image is magnified (Inherited from DicomObjects.DicomImage)
Public Property | MaskRanges | Contains an array of DicomMaskRange objects to be applied to this image. See the DicomMaskRange object for more information on how this is used. (Inherited from DicomObjects.DicomImage)
Public Property | MinificationMode | Controls how pixels are interpolated when the image is minified (Inherited from DicomObjects.DicomImage)
Public Property | ModalityLUT | Enables or disables the Modality Lookup Table to be used in the DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | Name | The Name of the patient (Inherited from DicomObjects.DicomImage)
Public Property | OriginalTs | Original Transfer syntax of the underlying DataSet (Inherited from DicomObjects.DicomImage)
Public Property | OverlayColour | Controls how overlays embedded in the image are displayed (Inherited from DicomObjects.DicomImage)
Public Property | OverlayVisible | Controls whether overlays embedded in the image are displayed (Inherited from DicomObjects.DicomImage)
Public Property | PatientID | The Patient ID (Inherited from DicomObjects.DicomImage)
Public Property | Pixels | Accesses the raw pixel data as a typed array (Inherited from DicomObjects.DicomImage)
Public Property | PresentationLUT | Enables or disables the Presentation Lookup Table to be used in the DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | PresentationState | Support for DICOM greyscale presentation state (Inherited from DicomObjects.DicomImage)
Public Property | PresentationStateFeaturesUsed | The presentation state features to use (Inherited from DicomObjects.DicomImage)
Public Property | PresentationStates | Support for a list of DICOM greyscale presentation state (Inherited from DicomObjects.DicomImage)
Public Property | RawPixels | Accesses the raw pixel data as an array (Inherited from DicomObjects.DicomImage)
Public Property | RealTimeCine | Controls how cine images are displayed (Inherited from DicomObjects.DicomImage)
Public Property | RenderedSize | Overridden. Returns the Image display size in output (normally screen) coordinates
Public Property | RotateState | The rotation state of the image, allowing the orientation of the image, as displayed, to be altered (Inherited from DicomObjects.DicomImage)
Public Property | RotationBehaviour | Controls the baseline positioning of an image which is not stretched to fit and is rotated (Inherited from DicomObjects.DicomImage)
Public Property | Scroll | Controls the positioning of an image display (Inherited from DicomObjects.DicomImage)
Public Property | SeriesDescription | Descriptions for the series (Inherited from DicomObjects.DicomImage)
Public Property | SeriesUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy (Inherited from DicomObjects.DicomImage)
Public Property | Sex | Sex of the patient (Inherited from DicomObjects.DicomImage)
Public Property | ShowLabels | Controls whether the image�s labels (annotations) are shown on screen (Inherited from DicomObjects.DicomImage)
Public Property | ShowShutter | Controls whether image shutters (if specified in the image) are used. (Inherited from DicomObjects.DicomImage)
Public Property | ShowUpdates | Controls whether the images is updated when image display parameters change (Inherited from DicomObjects.DicomImage)
Public Property | Size | The dimensions of the image (Inherited from DicomObjects.DicomImage)
Public Property | SOPClass | SOP class of the DicomDataSet. (Inherited from DicomObjects.DicomImage)
Public Property | StretchMode | Controls the automatic zooming of an image. (Inherited from DicomObjects.DicomImage)
Public Property | StudyDescription | Description for the study (Inherited from DicomObjects.DicomImage)
Public Property | StudyUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy (Inherited from DicomObjects.DicomImage)
Public Property | Tag | A general purpose Tag for developer use (Inherited from DicomObjects.DicomImage)
Public Property | UnsharpEnhancement | UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement (Inherited from DicomObjects.DicomImage)
Public Property | UnsharpLength | UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement (Inherited from DicomObjects.DicomImage)
Public Property | UserMatrix | Means to override the matrix used to display 2D images (Inherited from DicomObjects.DicomImage)
Public Property | VoiLUT | The VOI Lookup Table to be used to display the DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | VOILUTFunction | Controls which VOILUT function to be used, default value is Linear (Inherited from DicomObjects.DicomImage)
Public Property | VoiLUTInUse | Indicates whether a Values of Interest Lookup Table is in use (Inherited from DicomObjects.DicomImage)
Public Property | Volume | The DicomVolume on which this DicomImageCurvedMPR is based.
Public Property | Width | The Window "Width" - which controls the greyscale mapping of a displayed image (Inherited from DicomObjects.DicomImage)
Public Property | WidthMultiplier | Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping (Inherited from DicomObjects.DicomImage)
Public Property | Zoom | Controls the magnification of an image display (Inherited from DicomObjects.DicomImage)
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Creates and adds standard data elements to the underlying DicomDataSet (Inherited from DicomObjects.DicomImage)
Public Method | AddByReference | Overloaded. Add byte[] as attribute value to avoid copying large data (Inherited from DicomObjects.DicomImage)
Public Method | Bitmap | Overloaded. Creates a Bitmap Image from DicomImage (Inherited from DicomObjects.DicomImage)
Public Method | BitmapImage | Image rendered as a System.Windows.Media.Imaging.BitmapImage object (Inherited from DicomObjects.DicomImage)
Public Method | Blt | Combine pixel data of source image into this image as a base image (Inherited from DicomObjects.DicomImage)
Public Method | BurnAnnotations | Burn all image Labels in Pixel data. This method modifies the underlying pixel data! (Inherited from DicomObjects.DicomImage)
Public Method | CanConvertTo | Useful method to check if the image can be converted using a different compression specified by the TransferSyntax (Inherited from DicomObjects.DicomImage)
Public Method | CellLocation | The location of the top-left corner of the cell within which this image would be displayed in a particular viewer (Inherited from DicomObjects.DicomImage)
Public Method | CellSize | The size of the cell within which this image would be displayed in a particular viewer (Inherited from DicomObjects.DicomImage)
Public Method | ChangeToDecompressed | Simulate the effect of writing out as a Decompressed Image (Inherited from DicomObjects.DicomImage)
Public Method | ClearCaches | Overloaded. Clears the entire internal cache (Inherited from DicomObjects.DicomImage)
Public Method | Clone | Overloaded. Returns a cloned copy of the DicomImage (Inherited from DicomObjects.DicomImage)
Public Method | Copy | Copies the image to the Windows clipboard (Inherited from DicomObjects.DicomImage)
Public Method | CurrentPixelScale | Current Pixel Size
Public Method | CurrentToNoStretch | This method modifies the StretchMode, Zoom and Scroll properties such that the display output stays very similar while the display parameters have changed to suit the DicomObjects.Enums.StretchModes.NoStretch mode. (Inherited from DicomObjects.DicomImage)
Public Method | CurrentToPresentationState | Overloaded. Encapsulate current display properties into a DICOM GreyScale Presentation State object (Inherited from DicomObjects.DicomImage)
Public Method | DecompressAll | Causes all the frames of an image to be decompressed. (Inherited from DicomObjects.DicomImage)
Public Method | DisplaySize | Overloaded. The size at which this image, using current values for StretchMode etc. will display in this viewer. (Inherited from DicomObjects.DicomImage)
Public Method | Dispose | Standard Dispose methods (Inherited from DicomObjects.DicomImage)
Public Method | DistanceFromPoint | Perpendicular distance from a Point to the plane of this image (Inherited from DicomObjects.DicomImage)
Public Method | DownloadStatus | Overloaded. The download status of an image compared to specific attributes of the image (Inherited from DicomObjects.DicomImage)
Public Method | ExplicitJpipRequest | Overloaded. Explicitly request that some of the pixel information for this image should be retrieved via JPIP (Inherited from DicomObjects.DicomImage)
Public Method | Export | Overloaded. Copy the image data for external access, controlled by Format and Quality (Inherited from DicomObjects.DicomImage)
Public Method | GetCacheSize | Get cache size used by DicomObjects for the image - useful to help decide when to call ClearCaches method (Inherited from DicomObjects.DicomImage)
Public Method | GetMinAndMax | Overloaded. Find the maximum and minimum pixel data values in the pixel data (Inherited from DicomObjects.DicomImage)
Public Method | GetRawFrame | Extract individual frame from the pixel data (Inherited from DicomObjects.DicomImage)
Public Method | Histogram | Returns an array containing the distribution of raw pixel values. (Inherited from DicomObjects.DicomImage)
Public Method | ImagePlane | Overridden. The currently displayed plane of this image.
Public Method | ImageToScreen | Calculate where in screen (X,Y) space, a given image point lies (Inherited from DicomObjects.DicomImage)
Public Method | ImageToWorld | Calculate the real-world 3D coordinates of a point of the image currently displayed (Inherited from DicomObjects.DicomImage)
Public Method | Import | Overloaded. Copies the image data from an external generic image object (Inherited from DicomObjects.DicomImage)
Public Method | Matrix | Overloaded. Matrix specifying how the image is displayed, applying correction if needed if pizels are not square (Inherited from DicomObjects.DicomImage)
Public Method | MatrixBase | Matrix specifying how the image would be displayed with a Zoom of 1:1 (Inherited from DicomObjects.DicomImage)
Public Method | OrientationText | Return the Text of DicomLabel of LabelType = special. (Inherited from DicomObjects.DicomImage)
Public Method | Paste | Copies the Image Data from Windows Clipboard (Inherited from DicomObjects.DicomImage)
Public Method | PixelToWorld | Calculate the real world location of a point displayed on a 3D image
Public Method | PixelValuesByFrame | Returns an array of pixel values for a frame, optionally transformed via the modality transformation (Inherited from DicomObjects.DicomImage)
Public Method | PresentationStateToCurrent | Overloaded. Modifies current display properties to match the DICOM presentation state. (Inherited from DicomObjects.DicomImage)
Public Method | PrinterImage | Overloaded. Creates a copy of the image for printing or other purposes (Inherited from DicomObjects.DicomImage)
Public Method | RawPixelValuesByFrame | Returns an array of raw pixel values for a frame (Inherited from DicomObjects.DicomImage)
Public Method | Read | Overloaded. Reads from an external DICOM file (Inherited from DicomObjects.DicomImage)
Public Method | ReadURL | Reads from Web Address (Inherited from DicomObjects.DicomImage)
Public Method | ReferenceLine | This method returns a new DicomLabel object which represents the position of one DicomImage relative to another. (Inherited from DicomObjects.DicomImage)
Public Method | RenderToArray | Overloaded. Render the DicomImage to array. The data returned will be exactly the same as the "presentation data" if the Image gets displayed on screen. (Inherited from DicomObjects.DicomImage)
Public Method | ScreenToImage | Calculate where in image (X,Y) space, a given screen point lies (Inherited from DicomObjects.DicomImage)
Public Method | ScreenToWorld(PointF,DicomViewer) | Calculate where in real world (X,Y,Z) space, a given screen point lies (Inherited from DicomObjects.DicomImage)
Public Method | Send | Overloaded. Sends an image to a remote Storage SCP (Inherited from DicomObjects.DicomImage)
Public Method | SetCurve | Defines the coordinates of the curve to represent the curved MPR
Public Method | SetDefaultWindows | Recalculates the default windows used by DicomObjects as if the image had just been loaded (Inherited from DicomObjects.DicomImage)
Public Method | SetExternalShader | An external DirectX pixel shader to be used for custom filtering (Inherited from DicomObjects.DicomImage)
Public Method | SetPixelData | Method to set pixel data directly from a stream (Inherited from DicomObjects.DicomImage)
Public Method | SetPixelDataAndImport | Method to import pixel data directly from a non-DICOM data (Inherited from DicomObjects.DicomImage)
Public Method | SetPixelFile | Maps an external file as the pixel data (Inherited from DicomObjects.DicomImage)
Public Method | SetScrollAndZoom | Sets the Scroll and Zoom values to values reflecting the current display (Inherited from DicomObjects.DicomImage)
Public Method | SetSimpleMasking | Overloaded. Sets an int array as frame numbers of the mask frames for subtraction (Inherited from DicomObjects.DicomImage)
Public Method | Spacing | Overloaded. The pixel spacing of the DicomImage (Inherited from DicomObjects.DicomImage)
Public Method | SpacingInViewer | This method returns the Pixel Spacing within the region specified by Area, in a particular viewer (Inherited from DicomObjects.DicomImage)
Public Method | SubImage | Overloaded. Overridden. Creates a copy of part or all of the image with controlled size
Public Method | Update | Causes the image to be updated (Inherited from DicomObjects.DicomImage)
Public Method | WorldToImage(Point3D,DicomViewer,Int32) | Calculate the nearest image coordinates for a point in real world (X,Y,Z) space, (Inherited from DicomObjects.DicomImage)
Public Method | WorldToScreen(Point3D,DicomViewer) | Calculate where in real world (X,Y,Z) space, a given screen point lies (Inherited from DicomObjects.DicomImage)
Public Method | Write | Overloaded. Write the data to a file with specified transfer syntax and quality (Inherited from DicomObjects.DicomImage)
Top
Public Events
 | Name | Description
Public Event | PositionChanged | An event which fires when the plane displayed by this image changes. (Inherited from DicomObjects.DicomImage)
Public Event | UserSmoothing | Setting this event enables a developer to specify his own smoothing algorithm. (Inherited from DicomObjects.DicomImage)
Top
See Also

Reference

DicomImageCurvedMPR Class
DicomObjects Namespace


DicomImageCurvedMPR Constructor

DicomImageCurvedMPR Constructor

DicomObjects Namespace > DicomImageCurvedMPR Class : DicomImageCurvedMPR Constructor
The volume from which to create the image
Create a curved MPR image from a DicomVolume
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal volume As DicomVolume _
)
'Usage

Dim volume As DicomVolume

Dim instance As New DicomImageCurvedMPR(volume)
public DicomImageCurvedMPR(
   DicomVolume volume
)
public:
DicomImageCurvedMPR(
   DicomVolume^ volume
)

Parameters

volume
The volume from which to create the image
Remarks

Multiple images may share the same volume, and this should be used where possible to save both general and video RAM.

The rendering mode may subsequently be changed without creating a new image object.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCurvedMPR Class
DicomImageCurvedMPR Members


DicomImageCurvedMPR Class Methods

DicomImageCurvedMPR Class Methods

DicomObjects Namespace : DicomImageCurvedMPR Class

For a list of all members of this type, see DicomImageCurvedMPR members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Creates and adds standard data elements to the underlying DicomDataSet (Inherited from DicomObjects.DicomImage)
Public Method | AddByReference | Overloaded. Add byte[] as attribute value to avoid copying large data (Inherited from DicomObjects.DicomImage)
Public Method | Bitmap | Overloaded. Creates a Bitmap Image from DicomImage (Inherited from DicomObjects.DicomImage)
Public Method | BitmapImage | Image rendered as a System.Windows.Media.Imaging.BitmapImage object (Inherited from DicomObjects.DicomImage)
Public Method | Blt | Combine pixel data of source image into this image as a base image (Inherited from DicomObjects.DicomImage)
Public Method | BurnAnnotations | Burn all image Labels in Pixel data. This method modifies the underlying pixel data! (Inherited from DicomObjects.DicomImage)
Public Method | CanConvertTo | Useful method to check if the image can be converted using a different compression specified by the TransferSyntax (Inherited from DicomObjects.DicomImage)
Public Method | CellLocation | The location of the top-left corner of the cell within which this image would be displayed in a particular viewer (Inherited from DicomObjects.DicomImage)
Public Method | CellSize | The size of the cell within which this image would be displayed in a particular viewer (Inherited from DicomObjects.DicomImage)
Public Method | ChangeToDecompressed | Simulate the effect of writing out as a Decompressed Image (Inherited from DicomObjects.DicomImage)
Public Method | ClearCaches | Overloaded. Clears the entire internal cache (Inherited from DicomObjects.DicomImage)
Public Method | Clone | Overloaded. Returns a cloned copy of the DicomImage (Inherited from DicomObjects.DicomImage)
Public Method | Copy | Copies the image to the Windows clipboard (Inherited from DicomObjects.DicomImage)
Public Method | CurrentPixelScale | Current Pixel Size
Public Method | CurrentToNoStretch | This method modifies the StretchMode, Zoom and Scroll properties such that the display output stays very similar while the display parameters have changed to suit the DicomObjects.Enums.StretchModes.NoStretch mode. (Inherited from DicomObjects.DicomImage)
Public Method | CurrentToPresentationState | Overloaded. Encapsulate current display properties into a DICOM GreyScale Presentation State object (Inherited from DicomObjects.DicomImage)
Public Method | DecompressAll | Causes all the frames of an image to be decompressed. (Inherited from DicomObjects.DicomImage)
Public Method | DisplaySize | Overloaded. The size at which this image, using current values for StretchMode etc. will display in this viewer. (Inherited from DicomObjects.DicomImage)
Public Method | Dispose | Standard Dispose methods (Inherited from DicomObjects.DicomImage)
Public Method | DistanceFromPoint | Perpendicular distance from a Point to the plane of this image (Inherited from DicomObjects.DicomImage)
Public Method | DownloadStatus | Overloaded. The download status of an image compared to specific attributes of the image (Inherited from DicomObjects.DicomImage)
Public Method | ExplicitJpipRequest | Overloaded. Explicitly request that some of the pixel information for this image should be retrieved via JPIP (Inherited from DicomObjects.DicomImage)
Public Method | Export | Overloaded. Copy the image data for external access, controlled by Format and Quality (Inherited from DicomObjects.DicomImage)
Public Method | GetCacheSize | Get cache size used by DicomObjects for the image - useful to help decide when to call ClearCaches method (Inherited from DicomObjects.DicomImage)
Public Method | GetMinAndMax | Overloaded. Find the maximum and minimum pixel data values in the pixel data (Inherited from DicomObjects.DicomImage)
Public Method | GetRawFrame | Extract individual frame from the pixel data (Inherited from DicomObjects.DicomImage)
Public Method | Histogram | Returns an array containing the distribution of raw pixel values. (Inherited from DicomObjects.DicomImage)
Public Method | ImagePlane | Overridden. The currently displayed plane of this image.
Public Method | ImageToScreen | Calculate where in screen (X,Y) space, a given image point lies (Inherited from DicomObjects.DicomImage)
Public Method | ImageToWorld | Calculate the real-world 3D coordinates of a point of the image currently displayed (Inherited from DicomObjects.DicomImage)
Public Method | Import | Overloaded. Copies the image data from an external generic image object (Inherited from DicomObjects.DicomImage)
Public Method | Matrix | Overloaded. Matrix specifying how the image is displayed, applying correction if needed if pizels are not square (Inherited from DicomObjects.DicomImage)
Public Method | MatrixBase | Matrix specifying how the image would be displayed with a Zoom of 1:1 (Inherited from DicomObjects.DicomImage)
Public Method | OrientationText | Return the Text of DicomLabel of LabelType = special. (Inherited from DicomObjects.DicomImage)
Public Method | Paste | Copies the Image Data from Windows Clipboard (Inherited from DicomObjects.DicomImage)
Public Method | PixelToWorld | Calculate the real world location of a point displayed on a 3D image
Public Method | PixelValuesByFrame | Returns an array of pixel values for a frame, optionally transformed via the modality transformation (Inherited from DicomObjects.DicomImage)
Public Method | PresentationStateToCurrent | Overloaded. Modifies current display properties to match the DICOM presentation state. (Inherited from DicomObjects.DicomImage)
Public Method | PrinterImage | Overloaded. Creates a copy of the image for printing or other purposes (Inherited from DicomObjects.DicomImage)
Public Method | RawPixelValuesByFrame | Returns an array of raw pixel values for a frame (Inherited from DicomObjects.DicomImage)
Public Method | Read | Overloaded. Reads from an external DICOM file (Inherited from DicomObjects.DicomImage)
Public Method | ReadURL | Reads from Web Address (Inherited from DicomObjects.DicomImage)
Public Method | ReferenceLine | This method returns a new DicomLabel object which represents the position of one DicomImage relative to another. (Inherited from DicomObjects.DicomImage)
Public Method | RenderToArray | Overloaded. Render the DicomImage to array. The data returned will be exactly the same as the "presentation data" if the Image gets displayed on screen. (Inherited from DicomObjects.DicomImage)
Public Method | ScreenToImage | Calculate where in image (X,Y) space, a given screen point lies (Inherited from DicomObjects.DicomImage)
Public Method | ScreenToWorld(PointF,DicomViewer) | Calculate where in real world (X,Y,Z) space, a given screen point lies (Inherited from DicomObjects.DicomImage)
Public Method | Send | Overloaded. Sends an image to a remote Storage SCP (Inherited from DicomObjects.DicomImage)
Public Method | SetCurve | Defines the coordinates of the curve to represent the curved MPR
Public Method | SetDefaultWindows | Recalculates the default windows used by DicomObjects as if the image had just been loaded (Inherited from DicomObjects.DicomImage)
Public Method | SetExternalShader | An external DirectX pixel shader to be used for custom filtering (Inherited from DicomObjects.DicomImage)
Public Method | SetPixelData | Method to set pixel data directly from a stream (Inherited from DicomObjects.DicomImage)
Public Method | SetPixelDataAndImport | Method to import pixel data directly from a non-DICOM data (Inherited from DicomObjects.DicomImage)
Public Method | SetPixelFile | Maps an external file as the pixel data (Inherited from DicomObjects.DicomImage)
Public Method | SetScrollAndZoom | Sets the Scroll and Zoom values to values reflecting the current display (Inherited from DicomObjects.DicomImage)
Public Method | SetSimpleMasking | Overloaded. Sets an int array as frame numbers of the mask frames for subtraction (Inherited from DicomObjects.DicomImage)
Public Method | Spacing | Overloaded. The pixel spacing of the DicomImage (Inherited from DicomObjects.DicomImage)
Public Method | SpacingInViewer | This method returns the Pixel Spacing within the region specified by Area, in a particular viewer (Inherited from DicomObjects.DicomImage)
Public Method | SubImage | Overloaded. Overridden. Creates a copy of part or all of the image with controlled size
Public Method | Update | Causes the image to be updated (Inherited from DicomObjects.DicomImage)
Public Method | WorldToImage(Point3D,DicomViewer,Int32) | Calculate the nearest image coordinates for a point in real world (X,Y,Z) space, (Inherited from DicomObjects.DicomImage)
Public Method | WorldToScreen(Point3D,DicomViewer) | Calculate where in real world (X,Y,Z) space, a given screen point lies (Inherited from DicomObjects.DicomImage)
Public Method | Write | Overloaded. Write the data to a file with specified transfer syntax and quality (Inherited from DicomObjects.DicomImage)
Top
See Also

Reference

DicomImageCurvedMPR Class
DicomObjects Namespace


CurrentPixelScale Method (DicomImageCurvedMPR)

CurrentPixelScale Method (DicomImageCurvedMPR)

DicomObjects Namespace > DicomImageCurvedMPR Class : CurrentPixelScale Method
Size of current display area
Current Pixel Size
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function CurrentPixelScale( _
   ByVal DisplaySize As Size _
) As SizeF
'Usage

Dim instance As DicomImageCurvedMPR
Dim DisplaySize As Size
Dim value As SizeF

value = instance.CurrentPixelScale(DisplaySize)
public SizeF CurrentPixelScale(
   Size DisplaySize
)
public:
SizeF CurrentPixelScale(
   Size DisplaySize
)

Parameters

DisplaySize
Size of current display area

Return Value

Size per pixel in mm (X and Y may differ)
Remarks
The DicomImage.DisplaySize method may be used to obtain the correct value of DisplaySize
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCurvedMPR Class
DicomImageCurvedMPR Members


ImagePlane Method (DicomImageCurvedMPR)

ImagePlane Method (DicomImageCurvedMPR)

DicomObjects Namespace > DicomImageCurvedMPR Class : ImagePlane Method
The currently displayed plane of this image.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ImagePlane( _
   ByVal Frame1 As Integer _
) As Nullable(Of Plane3D)
'Usage

Dim instance As DicomImageCurvedMPR
Dim Frame1 As Integer
Dim value As Nullable(Of Plane3D)

value = instance.ImagePlane(Frame1)
public override Nullable<Plane3D> ImagePlane(
   int Frame1
)
public:
Nullable<Plane3D> ImagePlane(
   int Frame1
) override

Parameters

Frame1

Return Value

The plane of the image in 3D space, or null if not applicable to this image.
Remarks
For 3D images, this method returns the currently viewed plane. For MPR & Slab images, this is the actual data displayed, but for VR & MIP images, it is a hypothetical plane through the image and normal to the view direction.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCurvedMPR Class
DicomImageCurvedMPR Members
Base Implementation in ImagePlane


PixelToWorld Method (DicomImageCurvedMPR)

PixelToWorld Method (DicomImageCurvedMPR)

DicomObjects Namespace > DicomImageCurvedMPR Class : PixelToWorld Method
Calculate the real world location of a point displayed on a 3D image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function PixelToWorld( _
   ByVal Point As PointF, _
   ByVal DisplaySize As Size _
) As Point3D
'Usage

Dim instance As DicomImageCurvedMPR
Dim Point As PointF
Dim DisplaySize As Size
Dim value As Point3D

value = instance.PixelToWorld(Point, DisplaySize)
public Point3D PixelToWorld(
   PointF Point,
   Size DisplaySize
)
public:
Point3D PixelToWorld(
   PointF Point,
   Size DisplaySize
)

Parameters

Point
DisplaySize
Remarks
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCurvedMPR Class
DicomImageCurvedMPR Members


SetCurve Method

SetCurve Method

DicomObjects Namespace > DicomImageCurvedMPR Class : SetCurve Method
User defined points in 3D real world space that are used to define the curved MPR projection
Size of the reconstructed output image in mm
Defines the coordinates of the curve to represent the curved MPR
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetCurve( _
   ByVal Points(,) As Point3D, _
   ByVal Size As SizeF _
)
'Usage

Dim instance As DicomImageCurvedMPR
Dim Points() As Point3D
Dim Size As SizeF

instance.SetCurve(Points, Size)
public void SetCurve(
   Point3D[,] Points,
   SizeF Size
)
public:
void SetCurve(
   array<Point3D>^ Points,
   SizeF Size
)

Parameters

Points
User defined points in 3D real world space that are used to define the curved MPR projection
Size
Size of the reconstructed output image in mm
Remarks
The array of points can have any dimension, and DicomObjects will interpolate between the points as required. The size (mm in real world units) needs to be provided explicitly rather than calculated from the points, as the points are not necessarily required to lie on a simple curved plane.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCurvedMPR Class
DicomImageCurvedMPR Members


SubImage Method (DicomImageCurvedMPR)

SubImage Method (DicomImageCurvedMPR)

DicomObjects Namespace > DicomImageCurvedMPR Class : SubImage Method
Creates a copy of part or all of the image with controlled size
Overload List
Overload | Description
SubImage(Point,Size,Single,Int32,ScaleMode) | Creates a copy of part or all of the image with controlled size
SubImage(Point,Size,Single,Int32) | Creates a copy of part or all of the image with controlled size (Inherited from DicomObjects.DicomImage)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCurvedMPR Class
DicomImageCurvedMPR Members
Base Implementation in SubImage


SubImage(Point,Size,Single,Int32,ScaleMode) Method

SubImage(Point,Size,Single,Int32,ScaleMode) Method

DicomObjects Namespace > DicomImageCurvedMPR Class > SubImage Method : SubImage(Point,Size,Single,Int32,ScaleMode) Method

The left top corner point of the sub Image

The total size of the original image to capture

The zooming factor which determines the output size

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

The scaling mode to use

Creates a copy of part or all of the image with controlled size
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Overrides Function SubImage( _
   ByVal Offset As Point, _
   ByVal Size As Size, _
   ByVal Magnification As Single, _
   ByVal Frame As Integer, _
   ByVal Scaling As ScaleMode _
) As DicomImage
'Usage

Dim instance As DicomImageCurvedMPR
Dim Offset As Point
Dim Size As Size
Dim Magnification As Single
Dim Frame As Integer
Dim Scaling As ScaleMode
Dim value As DicomImage

value = instance.SubImage(Offset, Size, Magnification, Frame, Scaling)
public override DicomImage SubImage(
   Point Offset,
   Size Size,
   float Magnification,
   int Frame,
   ScaleMode Scaling
)
public:
DicomImage^ SubImage(
   Point Offset,
   Size Size,
   float Magnification,
   int Frame,
   ScaleMode Scaling
) override

Parameters

Offset

The left top corner point of the sub Image

Size

The total size of the original image to capture

Magnification

The zooming factor which determines the output size

Frame

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

Scaling

The scaling mode to use

Return Value

A new DicomImage
Remarks

Makes a derived image (of same basic DICOM type as the original) scaled and cropped as required. Size refers to the final image size, whether or not it is transformed as below.

The coordinate system used depends on the value of scaling. If ScaleMode.Image then the original image is used without rotation etc, but if ScaleMode.Output then the image is conceptually flipped, rotated etc. before applying the bounds.

This overload is now recommended in place of the earlier version without the scaling mode which is retained for backwards compatibility only.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCurvedMPR Class
DicomImageCurvedMPR Members
Overload List
Base Implementation in SubImage(Point,Size,Single,Int32,ScaleMode)


DicomImageCurvedMPR Class Properties

DicomImageCurvedMPR Class Properties

DicomObjects Namespace : DicomImageCurvedMPR Class

For a list of all members of this type, see DicomImageCurvedMPR members.

Public Properties
 | Name | Description
Public Property | AccessionNumber | The Accession Number (Inherited from DicomObjects.DicomImage)
Public Property | Angle | Controls the rotation of an image (Inherited from DicomObjects.DicomImage)
Public Property | Area | The display area of DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | BorderPen | The Pen object for Image border (Inherited from DicomObjects.DicomImage)
Public Property | CacheMode | Controls how the pixel data is cached (Inherited from DicomObjects.DicomImage)
Public Property | CaptureBackColour | User defined background colour for image output of PrinterImage, Bitmap and SubImage methods Default is Black background (Inherited from DicomObjects.DicomImage)
Public Property | CDAStyleSheet | Style sheet used for displaying encapsulated CDA (Inherited from DicomObjects.DicomImage)
Public Property | CineFramesToDisplay | The set of frames to display for cine modes (Inherited from DicomObjects.DicomImage)
Public Property | CineIndex | The index of the currently displayed frame when using CineMode (Inherited from DicomObjects.DicomImage)
Public Property | CineMode | Enumerated running modes for multi-frame image (Inherited from DicomObjects.DicomImage)
Public Property | CineRate | Controls the speed of autonomous cine runs (Inherited from DicomObjects.DicomImage)
Public Property | CineSmoothing | Boolean property indicating whether Smoothing is applied when Cine is being displayed. (Inherited from DicomObjects.DicomImage)
Public Property | ColourTable | The colour lookup table of DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | CubicSplineAlpha | Parameter to control the degree of smoothing. The default value is �0.75, and normal values range from �0.5 to �1.25, though higher negative values may be used to produce deliberate edge enhancement. (Inherited from DicomObjects.DicomImage)
Public Property | DataSet | The underlying DICOM Dataset containing persistent data for the image (Inherited from DicomObjects.DicomImage)
Public Property | DateOfBirth | Date of birth of the patient (Inherited from DicomObjects.DicomImage)
Public Property | DisplayMode | Controls how the image is rendered internal before transfer to the screen (Inherited from DicomObjects.DicomImage)
Public Property | DrawCacheMode | Specify the DrawCacheMode to control how image is drawn/cached (Inherited from DicomObjects.DicomImage)
Public Property | ExplicitModalityLUT | An explicit modality Lookup Table to be used in place of one specified in the image or presentaiton state. (Inherited from DicomObjects.DicomImage)
Public Property | ExplicitPresentationLUT | An explicit presentation Lookup Table to be used in place of one specified in the image or presentaiton state. (Inherited from DicomObjects.DicomImage)
Public Property | ExplicitVOILUT | An explicit Values of Interest (VOI) Lookup Table to be used in place of one specified in the image or presentaiton state. (Inherited from DicomObjects.DicomImage)
Public Property | FilterLength | Contains the length of the smoothing filter (Inherited from DicomObjects.DicomImage)
Public Property | FlipState | The flip state of the image, allowing the orientation of the image, as displayed, to be altered (Inherited from DicomObjects.DicomImage)
Public Property | Frame | Controls which frame of a multi-frame image is displayed (Inherited from DicomObjects.DicomImage)
Public Property | FrameCount | The number of frames contained in a multi-frame image (Inherited from DicomObjects.DicomImage)
Public Property | Gamma | A number that specifies a power (Inherited from DicomObjects.DicomImage)
Public Property | InstanceUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy (Inherited from DicomObjects.DicomImage)
Public Property | Invert | Controls whether the Image will be inverted. (Inherited from DicomObjects.DicomImage)
Public Property | Item | Overloaded. Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file. (Inherited from DicomObjects.DicomImage)
Public Property | JpipRequestSize | The size of the requests other than the first (in bytes) to make to a JPIP server. (Inherited from DicomObjects.DicomImage)
Public Property | Labels | Provides access to the DicomLabelCollection, items of which are to be displayed over an image. (Inherited from DicomObjects.DicomImage)
Public Property | Level | The Window Level (also known as the centre) - which controls the greyscale mapping of a displayed image (Inherited from DicomObjects.DicomImage)
Public Property | LevelShift | Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping (Inherited from DicomObjects.DicomImage)
Public Property | MagnificationMode | Controls how pixels are interpolated when the image is magnified (Inherited from DicomObjects.DicomImage)
Public Property | MaskRanges | Contains an array of DicomMaskRange objects to be applied to this image. See the DicomMaskRange object for more information on how this is used. (Inherited from DicomObjects.DicomImage)
Public Property | MinificationMode | Controls how pixels are interpolated when the image is minified (Inherited from DicomObjects.DicomImage)
Public Property | ModalityLUT | Enables or disables the Modality Lookup Table to be used in the DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | Name | The Name of the patient (Inherited from DicomObjects.DicomImage)
Public Property | OriginalTs | Original Transfer syntax of the underlying DataSet (Inherited from DicomObjects.DicomImage)
Public Property | OverlayColour | Controls how overlays embedded in the image are displayed (Inherited from DicomObjects.DicomImage)
Public Property | OverlayVisible | Controls whether overlays embedded in the image are displayed (Inherited from DicomObjects.DicomImage)
Public Property | PatientID | The Patient ID (Inherited from DicomObjects.DicomImage)
Public Property | Pixels | Accesses the raw pixel data as a typed array (Inherited from DicomObjects.DicomImage)
Public Property | PresentationLUT | Enables or disables the Presentation Lookup Table to be used in the DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | PresentationState | Support for DICOM greyscale presentation state (Inherited from DicomObjects.DicomImage)
Public Property | PresentationStateFeaturesUsed | The presentation state features to use (Inherited from DicomObjects.DicomImage)
Public Property | PresentationStates | Support for a list of DICOM greyscale presentation state (Inherited from DicomObjects.DicomImage)
Public Property | RawPixels | Accesses the raw pixel data as an array (Inherited from DicomObjects.DicomImage)
Public Property | RealTimeCine | Controls how cine images are displayed (Inherited from DicomObjects.DicomImage)
Public Property | RenderedSize | Overridden. Returns the Image display size in output (normally screen) coordinates
Public Property | RotateState | The rotation state of the image, allowing the orientation of the image, as displayed, to be altered (Inherited from DicomObjects.DicomImage)
Public Property | RotationBehaviour | Controls the baseline positioning of an image which is not stretched to fit and is rotated (Inherited from DicomObjects.DicomImage)
Public Property | Scroll | Controls the positioning of an image display (Inherited from DicomObjects.DicomImage)
Public Property | SeriesDescription | Descriptions for the series (Inherited from DicomObjects.DicomImage)
Public Property | SeriesUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy (Inherited from DicomObjects.DicomImage)
Public Property | Sex | Sex of the patient (Inherited from DicomObjects.DicomImage)
Public Property | ShowLabels | Controls whether the image�s labels (annotations) are shown on screen (Inherited from DicomObjects.DicomImage)
Public Property | ShowShutter | Controls whether image shutters (if specified in the image) are used. (Inherited from DicomObjects.DicomImage)
Public Property | ShowUpdates | Controls whether the images is updated when image display parameters change (Inherited from DicomObjects.DicomImage)
Public Property | Size | The dimensions of the image (Inherited from DicomObjects.DicomImage)
Public Property | SOPClass | SOP class of the DicomDataSet. (Inherited from DicomObjects.DicomImage)
Public Property | StretchMode | Controls the automatic zooming of an image. (Inherited from DicomObjects.DicomImage)
Public Property | StudyDescription | Description for the study (Inherited from DicomObjects.DicomImage)
Public Property | StudyUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy (Inherited from DicomObjects.DicomImage)
Public Property | Tag | A general purpose Tag for developer use (Inherited from DicomObjects.DicomImage)
Public Property | UnsharpEnhancement | UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement (Inherited from DicomObjects.DicomImage)
Public Property | UnsharpLength | UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement (Inherited from DicomObjects.DicomImage)
Public Property | UserMatrix | Means to override the matrix used to display 2D images (Inherited from DicomObjects.DicomImage)
Public Property | VoiLUT | The VOI Lookup Table to be used to display the DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | VOILUTFunction | Controls which VOILUT function to be used, default value is Linear (Inherited from DicomObjects.DicomImage)
Public Property | VoiLUTInUse | Indicates whether a Values of Interest Lookup Table is in use (Inherited from DicomObjects.DicomImage)
Public Property | Volume | The DicomVolume on which this DicomImageCurvedMPR is based.
Public Property | Width | The Window "Width" - which controls the greyscale mapping of a displayed image (Inherited from DicomObjects.DicomImage)
Public Property | WidthMultiplier | Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping (Inherited from DicomObjects.DicomImage)
Public Property | Zoom | Controls the magnification of an image display (Inherited from DicomObjects.DicomImage)
Top
See Also

Reference

DicomImageCurvedMPR Class
DicomObjects Namespace


RenderedSize Property (DicomImageCurvedMPR)

RenderedSize Property (DicomImageCurvedMPR)

DicomObjects Namespace > DicomImageCurvedMPR Class : RenderedSize Property
Returns the Image display size in output (normally screen) coordinates
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property RenderedSize As Size
'Usage

Dim instance As DicomImageCurvedMPR
Dim value As Size

value = instance.RenderedSize
public override Size RenderedSize {get;}
public:
property Size RenderedSize {
   Size get() override;
}
Remarks
For 3D images, the size is the maximum of the 3 dimensions of the volume, squared.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCurvedMPR Class
DicomImageCurvedMPR Members
Base Implementation in RenderedSize


Volume Property (DicomImageCurvedMPR)

Volume Property (DicomImageCurvedMPR)

DicomObjects Namespace > DicomImageCurvedMPR Class : Volume Property
The DicomVolume on which this DicomImageCurvedMPR is based.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Volume As DicomVolume
'Usage

Dim instance As DicomImageCurvedMPR
Dim value As DicomVolume

value = instance.Volume
public DicomVolume Volume {get;}
public:
property DicomVolume^ Volume {
   DicomVolume^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCurvedMPR Class
DicomImageCurvedMPR Members


DicomImageFusion Class

DicomImageFusion Class
Members

DicomObjects Namespace : DicomImageFusion Class
A class which allows overlaying of multiple images
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomImageFusion
   Inherits DicomImage
'Usage

Dim instance As DicomImageFusion
public class DicomImageFusion : DicomImage
public ref class DicomImageFusion : public DicomImage
Remarks

The set of images is held in the ImageCollection property, and their respective opacities (0-1) are in the OpacityValues collection which should contain the same number of items.

If created from using the constructor which takes a DicomImageCollection parameter, then all the images that support the IProjectioninterface (i.e. 3D images) will have their Matrix3D properties set to the same value as the first image in the collection, but they may subsequently altered independently

Use of any of the methods on this object's IProjection interface cause the same transformation to be applied to any images in the collection which themselves support IProjection

Inheritance Hierarchy

System.Object
DicomObjects.DicomImage
DicomObjects.DicomImageFusion

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageFusion Members
DicomObjects Namespace


DicomImageFusion Class Members

DicomImageFusion Class Members
Properties Methods Events

DicomObjects Namespace : DicomImageFusion Class

The following tables list the members exposed by DicomImageFusion.

Public Constructors
 | Name | Description
Public Constructor | DicomImageFusion Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AccessionNumber | The Accession Number (Inherited from DicomObjects.DicomImage)
Public Property | Angle | Controls the rotation of an image (Inherited from DicomObjects.DicomImage)
Public Property | Area | The display area of DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | BorderPen | The Pen object for Image border (Inherited from DicomObjects.DicomImage)
Public Property | CacheMode | Controls how the pixel data is cached (Inherited from DicomObjects.DicomImage)
Public Property | CaptureBackColour | User defined background colour for image output of PrinterImage, Bitmap and SubImage methods Default is Black background (Inherited from DicomObjects.DicomImage)
Public Property | CDAStyleSheet | Style sheet used for displaying encapsulated CDA (Inherited from DicomObjects.DicomImage)
Public Property | CineFramesToDisplay | The set of frames to display for cine modes (Inherited from DicomObjects.DicomImage)
Public Property | CineIndex | The index of the currently displayed frame when using CineMode (Inherited from DicomObjects.DicomImage)
Public Property | CineMode | Enumerated running modes for multi-frame image (Inherited from DicomObjects.DicomImage)
Public Property | CineRate | Controls the speed of autonomous cine runs (Inherited from DicomObjects.DicomImage)
Public Property | CineSmoothing | Boolean property indicating whether Smoothing is applied when Cine is being displayed. (Inherited from DicomObjects.DicomImage)
Public Property | ColourTable | The colour lookup table of DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | CubicSplineAlpha | Parameter to control the degree of smoothing. The default value is �0.75, and normal values range from �0.5 to �1.25, though higher negative values may be used to produce deliberate edge enhancement. (Inherited from DicomObjects.DicomImage)
Public Property | DataSet | The underlying DICOM Dataset containing persistent data for the image (Inherited from DicomObjects.DicomImage)
Public Property | DateOfBirth | Date of birth of the patient (Inherited from DicomObjects.DicomImage)
Public Property | DisplayMode | Controls how the image is rendered internal before transfer to the screen (Inherited from DicomObjects.DicomImage)
Public Property | DrawCacheMode | Specify the DrawCacheMode to control how image is drawn/cached (Inherited from DicomObjects.DicomImage)
Public Property | ExplicitModalityLUT | An explicit modality Lookup Table to be used in place of one specified in the image or presentaiton state. (Inherited from DicomObjects.DicomImage)
Public Property | ExplicitPresentationLUT | An explicit presentation Lookup Table to be used in place of one specified in the image or presentaiton state. (Inherited from DicomObjects.DicomImage)
Public Property | ExplicitVOILUT | An explicit Values of Interest (VOI) Lookup Table to be used in place of one specified in the image or presentaiton state. (Inherited from DicomObjects.DicomImage)
Public Property | FilterLength | Contains the length of the smoothing filter (Inherited from DicomObjects.DicomImage)
Public Property | FlipState | The flip state of the image, allowing the orientation of the image, as displayed, to be altered (Inherited from DicomObjects.DicomImage)
Public Property | Frame | Controls which frame of a multi-frame image is displayed (Inherited from DicomObjects.DicomImage)
Public Property | FrameCount | The number of frames contained in a multi-frame image (Inherited from DicomObjects.DicomImage)
Public Property | Gamma | A number that specifies a power (Inherited from DicomObjects.DicomImage)
Public Property | ImageCollection | Image collection for fusion
Public Property | InstanceUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy (Inherited from DicomObjects.DicomImage)
Public Property | Invert | Controls whether the Image will be inverted. (Inherited from DicomObjects.DicomImage)
Public Property | Item | Overloaded. Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file. (Inherited from DicomObjects.DicomImage)
Public Property | JpipRequestSize | The size of the requests other than the first (in bytes) to make to a JPIP server. (Inherited from DicomObjects.DicomImage)
Public Property | Labels | Provides access to the DicomLabelCollection, items of which are to be displayed over an image. (Inherited from DicomObjects.DicomImage)
Public Property | Level | The Window Level (also known as the centre) - which controls the greyscale mapping of a displayed image (Inherited from DicomObjects.DicomImage)
Public Property | LevelShift | Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping (Inherited from DicomObjects.DicomImage)
Public Property | MagnificationMode | Controls how pixels are interpolated when the image is magnified (Inherited from DicomObjects.DicomImage)
Public Property | MaskRanges | Contains an array of DicomMaskRange objects to be applied to this image. See the DicomMaskRange object for more information on how this is used. (Inherited from DicomObjects.DicomImage)
Public Property | Matrix3D | The Matrix relating real world coordinates (in mm) to the display space (with units -1 to +1 in each dimension)
Public Property | MinificationMode | Controls how pixels are interpolated when the image is minified (Inherited from DicomObjects.DicomImage)
Public Property | ModalityLUT | Enables or disables the Modality Lookup Table to be used in the DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | Name | The Name of the patient (Inherited from DicomObjects.DicomImage)
Public Property | OpacityValues | Opacity values for individual images
Public Property | OriginalTs | Original Transfer syntax of the underlying DataSet (Inherited from DicomObjects.DicomImage)
Public Property | OverlayColour | Controls how overlays embedded in the image are displayed (Inherited from DicomObjects.DicomImage)
Public Property | OverlayVisible | Controls whether overlays embedded in the image are displayed (Inherited from DicomObjects.DicomImage)
Public Property | PatientID | The Patient ID (Inherited from DicomObjects.DicomImage)
Public Property | Pixels | Accesses the raw pixel data as a typed array (Inherited from DicomObjects.DicomImage)
Public Property | PresentationLUT | Enables or disables the Presentation Lookup Table to be used in the DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | PresentationState | Support for DICOM greyscale presentation state (Inherited from DicomObjects.DicomImage)
Public Property | PresentationStateFeaturesUsed | The presentation state features to use (Inherited from DicomObjects.DicomImage)
Public Property | PresentationStates | Support for a list of DICOM greyscale presentation state (Inherited from DicomObjects.DicomImage)
Public Property | RawPixels | Accesses the raw pixel data as an array (Inherited from DicomObjects.DicomImage)
Public Property | RealTimeCine | Controls how cine images are displayed (Inherited from DicomObjects.DicomImage)
Public Property | RenderedSize | Returns the Image display size in output (normally screen) coordinates (Inherited from DicomObjects.DicomImage)
Public Property | RotateState | The rotation state of the image, allowing the orientation of the image, as displayed, to be altered (Inherited from DicomObjects.DicomImage)
Public Property | RotationBehaviour | Controls the baseline positioning of an image which is not stretched to fit and is rotated (Inherited from DicomObjects.DicomImage)
Public Property | Scroll | Controls the positioning of an image display (Inherited from DicomObjects.DicomImage)
Public Property | SeriesDescription | Descriptions for the series (Inherited from DicomObjects.DicomImage)
Public Property | SeriesUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy (Inherited from DicomObjects.DicomImage)
Public Property | Sex | Sex of the patient (Inherited from DicomObjects.DicomImage)
Public Property | ShowLabels | Controls whether the image�s labels (annotations) are shown on screen (Inherited from DicomObjects.DicomImage)
Public Property | ShowShutter | Controls whether image shutters (if specified in the image) are used. (Inherited from DicomObjects.DicomImage)
Public Property | ShowUpdates | Controls whether the images is updated when image display parameters change (Inherited from DicomObjects.DicomImage)
Public Property | Size | The dimensions of the image (Inherited from DicomObjects.DicomImage)
Public Property | SOPClass | SOP class of the DicomDataSet. (Inherited from DicomObjects.DicomImage)
Public Property | StretchMode | Controls the automatic zooming of an image. (Inherited from DicomObjects.DicomImage)
Public Property | StudyDescription | Description for the study (Inherited from DicomObjects.DicomImage)
Public Property | StudyUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy (Inherited from DicomObjects.DicomImage)
Public Property | SynchonisePlanes | If true, then the images in ImageCollection are automatically adjusted to match the first of the collection at display time.
Public Property | Tag | A general purpose Tag for developer use (Inherited from DicomObjects.DicomImage)
Public Property | UnsharpEnhancement | UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement (Inherited from DicomObjects.DicomImage)
Public Property | UnsharpLength | UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement (Inherited from DicomObjects.DicomImage)
Public Property | UserMatrix | Means to override the matrix used to display 2D images (Inherited from DicomObjects.DicomImage)
Public Property | VoiLUT | The VOI Lookup Table to be used to display the DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | VOILUTFunction | Controls which VOILUT function to be used, default value is Linear (Inherited from DicomObjects.DicomImage)
Public Property | VoiLUTInUse | Indicates whether a Values of Interest Lookup Table is in use (Inherited from DicomObjects.DicomImage)
Public Property | Width | The Window "Width" - which controls the greyscale mapping of a displayed image (Inherited from DicomObjects.DicomImage)
Public Property | WidthMultiplier | Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping (Inherited from DicomObjects.DicomImage)
Public Property | Zoom | Controls the magnification of an image display (Inherited from DicomObjects.DicomImage)
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Creates and adds standard data elements to the underlying DicomDataSet (Inherited from DicomObjects.DicomImage)
Public Method | AddByReference | Overloaded. Add byte[] as attribute value to avoid copying large data (Inherited from DicomObjects.DicomImage)
Public Method | Bitmap | Overloaded. Creates a Bitmap Image from DicomImage (Inherited from DicomObjects.DicomImage)
Public Method | BitmapImage | Image rendered as a System.Windows.Media.Imaging.BitmapImage object (Inherited from DicomObjects.DicomImage)
Public Method | Blt | Combine pixel data of source image into this image as a base image (Inherited from DicomObjects.DicomImage)
Public Method | BurnAnnotations | Burn all image Labels in Pixel data. This method modifies the underlying pixel data! (Inherited from DicomObjects.DicomImage)
Public Method | CanConvertTo | Useful method to check if the image can be converted using a different compression specified by the TransferSyntax (Inherited from DicomObjects.DicomImage)
Public Method | CellLocation | The location of the top-left corner of the cell within which this image would be displayed in a particular viewer (Inherited from DicomObjects.DicomImage)
Public Method | CellSize | The size of the cell within which this image would be displayed in a particular viewer (Inherited from DicomObjects.DicomImage)
Public Method | ChangeToDecompressed | Simulate the effect of writing out as a Decompressed Image (Inherited from DicomObjects.DicomImage)
Public Method | ClearCaches | Overloaded. Clears the entire internal cache (Inherited from DicomObjects.DicomImage)
Public Method | Clone | Overloaded. Returns a cloned copy of the DicomImage (Inherited from DicomObjects.DicomImage)
Public Method | Copy | Copies the image to the Windows clipboard (Inherited from DicomObjects.DicomImage)
Public Method | CurrentToNoStretch | This method modifies the StretchMode, Zoom and Scroll properties such that the display output stays very similar while the display parameters have changed to suit the DicomObjects.Enums.StretchModes.NoStretch mode. (Inherited from DicomObjects.DicomImage)
Public Method | CurrentToPresentationState | Overloaded. Encapsulate current display properties into a DICOM GreyScale Presentation State object (Inherited from DicomObjects.DicomImage)
Public Method | DecompressAll | Causes all the frames of an image to be decompressed. (Inherited from DicomObjects.DicomImage)
Public Method | DisplaySize | Overloaded. The size at which this image, using current values for StretchMode etc. will display in this viewer. (Inherited from DicomObjects.DicomImage)
Public Method | Dispose | Standard Dispose methods (Inherited from DicomObjects.DicomImage)
Public Method | DistanceFromPoint | Perpendicular distance from a Point to the plane of this image (Inherited from DicomObjects.DicomImage)
Public Method | DownloadStatus | Overloaded. The download status of an image compared to specific attributes of the image (Inherited from DicomObjects.DicomImage)
Public Method | ExplicitJpipRequest | Overloaded. Explicitly request that some of the pixel information for this image should be retrieved via JPIP (Inherited from DicomObjects.DicomImage)
Public Method | Export | Overloaded. Copy the image data for external access, controlled by Format and Quality (Inherited from DicomObjects.DicomImage)
Public Method | GetCacheSize | Get cache size used by DicomObjects for the image - useful to help decide when to call ClearCaches method (Inherited from DicomObjects.DicomImage)
Public Method | GetMinAndMax | Overloaded. Find the maximum and minimum pixel data values in the pixel data (Inherited from DicomObjects.DicomImage)
Public Method | GetRawFrame | Extract individual frame from the pixel data (Inherited from DicomObjects.DicomImage)
Public Method | Histogram | Returns an array containing the distribution of raw pixel values. (Inherited from DicomObjects.DicomImage)
Public Method | ImagePlane | Overridden. The currently displayed plane of this image.
Public Method | ImageToScreen | Calculate where in screen (X,Y) space, a given image point lies (Inherited from DicomObjects.DicomImage)
Public Method | ImageToWorld | Calculate the real-world 3D coordinates of a point of the image currently displayed (Inherited from DicomObjects.DicomImage)
Public Method | Import | Overloaded. Copies the image data from an external generic image object (Inherited from DicomObjects.DicomImage)
Public Method | Matrix | Overloaded. Matrix specifying how the image is displayed, applying correction if needed if pizels are not square (Inherited from DicomObjects.DicomImage)
Public Method | MatrixBase | Matrix specifying how the image would be displayed with a Zoom of 1:1 (Inherited from DicomObjects.DicomImage)
Public Method | OrientationText | Return the Text of DicomLabel of LabelType = special. (Inherited from DicomObjects.DicomImage)
Public Method | Paste | Copies the Image Data from Windows Clipboard (Inherited from DicomObjects.DicomImage)
Public Method | PixelValuesByFrame | Returns an array of pixel values for a frame, optionally transformed via the modality transformation (Inherited from DicomObjects.DicomImage)
Public Method | PresentationStateToCurrent | Overloaded. Modifies current display properties to match the DICOM presentation state. (Inherited from DicomObjects.DicomImage)
Public Method | PrinterImage | Overloaded. Creates a copy of the image for printing or other purposes (Inherited from DicomObjects.DicomImage)
Public Method | RawPixelValuesByFrame | Returns an array of raw pixel values for a frame (Inherited from DicomObjects.DicomImage)
Public Method | Read | Overloaded. Reads from an external DICOM file (Inherited from DicomObjects.DicomImage)
Public Method | ReadURL | Reads from Web Address (Inherited from DicomObjects.DicomImage)
Public Method | ReferenceLine | This method returns a new DicomLabel object which represents the position of one DicomImage relative to another. (Inherited from DicomObjects.DicomImage)
Public Method | RenderToArray | Overloaded. Render the DicomImage to array. The data returned will be exactly the same as the "presentation data" if the Image gets displayed on screen. (Inherited from DicomObjects.DicomImage)
Public Method | Rotate | Rotate view around a defined axis and based on a DicomViewer if available
Public Method | Scale | Scale/Zoom the view
Public Method | ScreenToImage | Calculate where in image (X,Y) space, a given screen point lies (Inherited from DicomObjects.DicomImage)
Public Method | ScreenToWorld(PointF,DicomViewer) | Calculate where in real world (X,Y,Z) space, a given screen point lies (Inherited from DicomObjects.DicomImage)
Public Method | Send | Overloaded. Sends an image to a remote Storage SCP (Inherited from DicomObjects.DicomImage)
Public Method | SetDefaultWindows | Recalculates the default windows used by DicomObjects as if the image had just been loaded (Inherited from DicomObjects.DicomImage)
Public Method | SetExternalShader | An external DirectX pixel shader to be used for custom filtering (Inherited from DicomObjects.DicomImage)
Public Method | SetPixelData | Method to set pixel data directly from a stream (Inherited from DicomObjects.DicomImage)
Public Method | SetPixelDataAndImport | Method to import pixel data directly from a non-DICOM data (Inherited from DicomObjects.DicomImage)
Public Method | SetPixelFile | Maps an external file as the pixel data (Inherited from DicomObjects.DicomImage)
Public Method | SetScrollAndZoom | Sets the Scroll and Zoom values to values reflecting the current display (Inherited from DicomObjects.DicomImage)
Public Method | SetSimpleMasking | Overloaded. Sets an int array as frame numbers of the mask frames for subtraction (Inherited from DicomObjects.DicomImage)
Public Method | SetViewPlane | Overloaded. Set the view plane for the image, based on centre of the plane, the direction of view, and the "Up" direction.
Public Method | Spacing | Overloaded. The pixel spacing of the DicomImage (Inherited from DicomObjects.DicomImage)
Public Method | SpacingInViewer | This method returns the Pixel Spacing within the region specified by Area, in a particular viewer (Inherited from DicomObjects.DicomImage)
Public Method | SubImage | Overloaded. Creates a copy of part or all of the image with controlled size (Inherited from DicomObjects.DicomImage)
Public Method | TranslateMm | Move the centre point of the view by the specified offset
Public Method | TranslateNormal | Move the centre point of the view by the specified distance, normal to the current view plane
Public Method | TranslatePixels | Move the display Offset pixels based on output size
Public Method | Update | Causes the image to be updated (Inherited from DicomObjects.DicomImage)
Public Method | WorldToImage | Calculate the nearest image coordinates for a point in real world (X,Y,Z) space, (Inherited from DicomObjects.DicomImage)
Public Method | WorldToScreen(Point3D,DicomViewer) | Calculate where in real world (X,Y,Z) space, a given screen point lies (Inherited from DicomObjects.DicomImage)
Public Method | Write | Overloaded. Write the data to a file with specified transfer syntax and quality (Inherited from DicomObjects.DicomImage)
Top
Public Events
 | Name | Description
Public Event | PositionChanged | An event which fires when the plane displayed by this image changes. (Inherited from DicomObjects.DicomImage)
Public Event | UserSmoothing | Setting this event enables a developer to specify his own smoothing algorithm. (Inherited from DicomObjects.DicomImage)
Top
See Also

Reference

DicomImageFusion Class
DicomObjects Namespace


DicomImageFusion Constructor

DicomImageFusion Constructor

DicomObjects Namespace > DicomImageFusion Class : DicomImageFusion Constructor
Overload List
Overload | Description
DicomImageFusion Constructor(DicomDataSet) | Create a new DicomImageFusion object, with an empty image collection
DicomImageFusion Constructor(DicomImageCollection) | Create a new DIcomImageFusion object, with an initial collection of images.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageFusion Class
DicomImageFusion Members


DicomImageFusion Constructor(DicomDataSet)

DicomImageFusion Constructor(DicomDataSet)

DicomObjects Namespace > DicomImageFusion Class > DicomImageFusion Constructor : DicomImageFusion Constructor(DicomDataSet)
The image to use for general non-display purposes such as DataSet and demographics
Create a new DicomImageFusion object, with an empty image collection
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal DataSet As DicomDataSet _
)
'Usage

Dim DataSet As DicomDataSet

Dim instance As New DicomImageFusion(DataSet)
public DicomImageFusion(
   DicomDataSet DataSet
)
public:
DicomImageFusion(
   DicomDataSet^ DataSet
)

Parameters

DataSet
The image to use for general non-display purposes such as DataSet and demographics
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageFusion Class
DicomImageFusion Members
Overload List


DicomImageFusion Constructor(DicomImageCollection)

DicomImageFusion Constructor(DicomImageCollection)

DicomObjects Namespace > DicomImageFusion Class > DicomImageFusion Constructor : DicomImageFusion Constructor(DicomImageCollection)
The collection to use
Create a new DIcomImageFusion object, with an initial collection of images.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal ImageCollection As DicomImageCollection _
)
'Usage

Dim ImageCollection As DicomImageCollection

Dim instance As New DicomImageFusion(ImageCollection)
public DicomImageFusion(
   DicomImageCollection ImageCollection
)
public:
DicomImageFusion(
   DicomImageCollection^ ImageCollection
)

Parameters

ImageCollection
The collection to use
Remarks
The first image in the collection is used for general non-display purposes such as DataSet and demographics
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageFusion Class
DicomImageFusion Members
Overload List


DicomImageFusion Class Methods

DicomImageFusion Class Methods

DicomObjects Namespace : DicomImageFusion Class

For a list of all members of this type, see DicomImageFusion members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Creates and adds standard data elements to the underlying DicomDataSet (Inherited from DicomObjects.DicomImage)
Public Method | AddByReference | Overloaded. Add byte[] as attribute value to avoid copying large data (Inherited from DicomObjects.DicomImage)
Public Method | Bitmap | Overloaded. Creates a Bitmap Image from DicomImage (Inherited from DicomObjects.DicomImage)
Public Method | BitmapImage | Image rendered as a System.Windows.Media.Imaging.BitmapImage object (Inherited from DicomObjects.DicomImage)
Public Method | Blt | Combine pixel data of source image into this image as a base image (Inherited from DicomObjects.DicomImage)
Public Method | BurnAnnotations | Burn all image Labels in Pixel data. This method modifies the underlying pixel data! (Inherited from DicomObjects.DicomImage)
Public Method | CanConvertTo | Useful method to check if the image can be converted using a different compression specified by the TransferSyntax (Inherited from DicomObjects.DicomImage)
Public Method | CellLocation | The location of the top-left corner of the cell within which this image would be displayed in a particular viewer (Inherited from DicomObjects.DicomImage)
Public Method | CellSize | The size of the cell within which this image would be displayed in a particular viewer (Inherited from DicomObjects.DicomImage)
Public Method | ChangeToDecompressed | Simulate the effect of writing out as a Decompressed Image (Inherited from DicomObjects.DicomImage)
Public Method | ClearCaches | Overloaded. Clears the entire internal cache (Inherited from DicomObjects.DicomImage)
Public Method | Clone | Overloaded. Returns a cloned copy of the DicomImage (Inherited from DicomObjects.DicomImage)
Public Method | Copy | Copies the image to the Windows clipboard (Inherited from DicomObjects.DicomImage)
Public Method | CurrentToNoStretch | This method modifies the StretchMode, Zoom and Scroll properties such that the display output stays very similar while the display parameters have changed to suit the DicomObjects.Enums.StretchModes.NoStretch mode. (Inherited from DicomObjects.DicomImage)
Public Method | CurrentToPresentationState | Overloaded. Encapsulate current display properties into a DICOM GreyScale Presentation State object (Inherited from DicomObjects.DicomImage)
Public Method | DecompressAll | Causes all the frames of an image to be decompressed. (Inherited from DicomObjects.DicomImage)
Public Method | DisplaySize | Overloaded. The size at which this image, using current values for StretchMode etc. will display in this viewer. (Inherited from DicomObjects.DicomImage)
Public Method | Dispose | Standard Dispose methods (Inherited from DicomObjects.DicomImage)
Public Method | DistanceFromPoint | Perpendicular distance from a Point to the plane of this image (Inherited from DicomObjects.DicomImage)
Public Method | DownloadStatus | Overloaded. The download status of an image compared to specific attributes of the image (Inherited from DicomObjects.DicomImage)
Public Method | ExplicitJpipRequest | Overloaded. Explicitly request that some of the pixel information for this image should be retrieved via JPIP (Inherited from DicomObjects.DicomImage)
Public Method | Export | Overloaded. Copy the image data for external access, controlled by Format and Quality (Inherited from DicomObjects.DicomImage)
Public Method | GetCacheSize | Get cache size used by DicomObjects for the image - useful to help decide when to call ClearCaches method (Inherited from DicomObjects.DicomImage)
Public Method | GetMinAndMax | Overloaded. Find the maximum and minimum pixel data values in the pixel data (Inherited from DicomObjects.DicomImage)
Public Method | GetRawFrame | Extract individual frame from the pixel data (Inherited from DicomObjects.DicomImage)
Public Method | Histogram | Returns an array containing the distribution of raw pixel values. (Inherited from DicomObjects.DicomImage)
Public Method | ImagePlane | Overridden. The currently displayed plane of this image.
Public Method | ImageToScreen | Calculate where in screen (X,Y) space, a given image point lies (Inherited from DicomObjects.DicomImage)
Public Method | ImageToWorld | Calculate the real-world 3D coordinates of a point of the image currently displayed (Inherited from DicomObjects.DicomImage)
Public Method | Import | Overloaded. Copies the image data from an external generic image object (Inherited from DicomObjects.DicomImage)
Public Method | Matrix | Overloaded. Matrix specifying how the image is displayed, applying correction if needed if pizels are not square (Inherited from DicomObjects.DicomImage)
Public Method | MatrixBase | Matrix specifying how the image would be displayed with a Zoom of 1:1 (Inherited from DicomObjects.DicomImage)
Public Method | OrientationText | Return the Text of DicomLabel of LabelType = special. (Inherited from DicomObjects.DicomImage)
Public Method | Paste | Copies the Image Data from Windows Clipboard (Inherited from DicomObjects.DicomImage)
Public Method | PixelValuesByFrame | Returns an array of pixel values for a frame, optionally transformed via the modality transformation (Inherited from DicomObjects.DicomImage)
Public Method | PresentationStateToCurrent | Overloaded. Modifies current display properties to match the DICOM presentation state. (Inherited from DicomObjects.DicomImage)
Public Method | PrinterImage | Overloaded. Creates a copy of the image for printing or other purposes (Inherited from DicomObjects.DicomImage)
Public Method | RawPixelValuesByFrame | Returns an array of raw pixel values for a frame (Inherited from DicomObjects.DicomImage)
Public Method | Read | Overloaded. Reads from an external DICOM file (Inherited from DicomObjects.DicomImage)
Public Method | ReadURL | Reads from Web Address (Inherited from DicomObjects.DicomImage)
Public Method | ReferenceLine | This method returns a new DicomLabel object which represents the position of one DicomImage relative to another. (Inherited from DicomObjects.DicomImage)
Public Method | RenderToArray | Overloaded. Render the DicomImage to array. The data returned will be exactly the same as the "presentation data" if the Image gets displayed on screen. (Inherited from DicomObjects.DicomImage)
Public Method | Rotate | Rotate view around a defined axis and based on a DicomViewer if available
Public Method | Scale | Scale/Zoom the view
Public Method | ScreenToImage | Calculate where in image (X,Y) space, a given screen point lies (Inherited from DicomObjects.DicomImage)
Public Method | ScreenToWorld(PointF,DicomViewer) | Calculate where in real world (X,Y,Z) space, a given screen point lies (Inherited from DicomObjects.DicomImage)
Public Method | Send | Overloaded. Sends an image to a remote Storage SCP (Inherited from DicomObjects.DicomImage)
Public Method | SetDefaultWindows | Recalculates the default windows used by DicomObjects as if the image had just been loaded (Inherited from DicomObjects.DicomImage)
Public Method | SetExternalShader | An external DirectX pixel shader to be used for custom filtering (Inherited from DicomObjects.DicomImage)
Public Method | SetPixelData | Method to set pixel data directly from a stream (Inherited from DicomObjects.DicomImage)
Public Method | SetPixelDataAndImport | Method to import pixel data directly from a non-DICOM data (Inherited from DicomObjects.DicomImage)
Public Method | SetPixelFile | Maps an external file as the pixel data (Inherited from DicomObjects.DicomImage)
Public Method | SetScrollAndZoom | Sets the Scroll and Zoom values to values reflecting the current display (Inherited from DicomObjects.DicomImage)
Public Method | SetSimpleMasking | Overloaded. Sets an int array as frame numbers of the mask frames for subtraction (Inherited from DicomObjects.DicomImage)
Public Method | SetViewPlane | Overloaded. Set the view plane for the image, based on centre of the plane, the direction of view, and the "Up" direction.
Public Method | Spacing | Overloaded. The pixel spacing of the DicomImage (Inherited from DicomObjects.DicomImage)
Public Method | SpacingInViewer | This method returns the Pixel Spacing within the region specified by Area, in a particular viewer (Inherited from DicomObjects.DicomImage)
Public Method | SubImage | Overloaded. Creates a copy of part or all of the image with controlled size (Inherited from DicomObjects.DicomImage)
Public Method | TranslateMm | Move the centre point of the view by the specified offset
Public Method | TranslateNormal | Move the centre point of the view by the specified distance, normal to the current view plane
Public Method | TranslatePixels | Move the display Offset pixels based on output size
Public Method | Update | Causes the image to be updated (Inherited from DicomObjects.DicomImage)
Public Method | WorldToImage | Calculate the nearest image coordinates for a point in real world (X,Y,Z) space, (Inherited from DicomObjects.DicomImage)
Public Method | WorldToScreen(Point3D,DicomViewer) | Calculate where in real world (X,Y,Z) space, a given screen point lies (Inherited from DicomObjects.DicomImage)
Public Method | Write | Overloaded. Write the data to a file with specified transfer syntax and quality (Inherited from DicomObjects.DicomImage)
Top
See Also

Reference

DicomImageFusion Class
DicomObjects Namespace


ImagePlane Method (DicomImageFusion)

ImagePlane Method (DicomImageFusion)

DicomObjects Namespace > DicomImageFusion Class : ImagePlane Method
The currently displayed plane of this image.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ImagePlane( _
   ByVal Frame1 As Integer _
) As Nullable(Of Plane3D)
'Usage

Dim instance As DicomImageFusion
Dim Frame1 As Integer
Dim value As Nullable(Of Plane3D)

value = instance.ImagePlane(Frame1)
public override Nullable<Plane3D> ImagePlane(
   int Frame1
)
public:
Nullable<Plane3D> ImagePlane(
   int Frame1
) override

Parameters

Frame1

Return Value

The plane of the image in 3D space, or null if not applicable to this image. For fusion images, this is the plane of the first image in the collection.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageFusion Class
DicomImageFusion Members
Base Implementation in ImagePlane


Rotate Method (DicomImageFusion)

Rotate Method (DicomImageFusion)

DicomObjects Namespace > DicomImageFusion Class : Rotate Method
The angle to rotate, measured clockwise in degrees
The axis around which to rotate the view
Display parameters of this viewer instance to use for applying rotation
Rotate view around a defined axis and based on a DicomViewer if available
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Rotate( _
   ByVal Angle As Single, _
   ByVal Axis As Vector3D, _
   Optional ByVal Viewer As DicomViewer _
)
'Usage

Dim instance As DicomImageFusion
Dim Angle As Single
Dim Axis As Vector3D
Dim Viewer As DicomViewer

instance.Rotate(Angle, Axis, Viewer)
public void Rotate(
   float Angle,
   Vector3D Axis,
   DicomViewer Viewer
)
public:
void Rotate(
   float Angle,
   Vector3D Axis,
   DicomViewer^ Viewer
)

Parameters

Angle
The angle to rotate, measured clockwise in degrees
Axis
The axis around which to rotate the view
Viewer
Display parameters of this viewer instance to use for applying rotation
Remarks
Viewer instance is used mainly for ImageFusion with 2D images, never used in 3D.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageFusion Class
DicomImageFusion Members


Scale Method (DicomImageFusion)

Scale Method (DicomImageFusion)

DicomObjects Namespace > DicomImageFusion Class : Scale Method
The factor to scale the image view by
Scale/Zoom the view
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Scale( _
   ByVal Scale As Single _
)
'Usage

Dim instance As DicomImageFusion
Dim Scale As Single

instance.Scale(Scale)
public void Scale(
   float Scale
)
public:
void Scale(
   float Scale
)

Parameters

Scale
The factor to scale the image view by
Remarks
For a DicomImageFusion object, this passes the transformation on to all images in the collection which support IProjection
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageFusion Class
DicomImageFusion Members


SetViewPlane Method (DicomImageFusion)

SetViewPlane Method (DicomImageFusion)

DicomObjects Namespace > DicomImageFusion Class : SetViewPlane Method
Set the view plane for the image, based on centre of the plane, the direction of view, and the "Up" direction.
Overload List
Overload | Description
SetViewPlane(Point3D,Vector3D,Vector3D,Single) | Set the view plane for the image, based on centre of the plane, the direction of view, and the "Up" direction.
SetViewPlane(Plane,Boolean,Single) | Set the view plane for the image, to one of 3 pre-defined views, with optional reset of centre and zoom
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageFusion Class
DicomImageFusion Members


SetViewPlane(Point3D,Vector3D,Vector3D,Single) Method

SetViewPlane(Point3D,Vector3D,Vector3D,Single) Method

DicomObjects Namespace > DicomImageFusion Class > SetViewPlane Method : SetViewPlane(Point3D,Vector3D,Vector3D,Single) Method
The coordinates of the centre of the plane
A vector defining the direction of view
The direction to be "up" in the resulting view.
The zoom factor to use - see notes in remarks
Set the view plane for the image, based on centre of the plane, the direction of view, and the "Up" direction.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SetViewPlane( _
   ByVal Centre As Point3D, _
   ByVal Normal As Vector3D, _
   ByVal Up As Vector3D, _
   ByVal Zoom As Single _
)
'Usage

Dim instance As DicomImageFusion
Dim Centre As Point3D
Dim Normal As Vector3D
Dim Up As Vector3D
Dim Zoom As Single

instance.SetViewPlane(Centre, Normal, Up, Zoom)
public void SetViewPlane(
   Point3D Centre,
   Vector3D Normal,
   Vector3D Up,
   float Zoom
)
public:
void SetViewPlane(
   Point3D Centre,
   Vector3D Normal,
   Vector3D Up,
   float Zoom
)

Parameters

Centre
The coordinates of the centre of the plane
Normal
A vector defining the direction of view
Up
The direction to be "up" in the resulting view.
Zoom
The zoom factor to use - see notes in remarks
Remarks

All coordinates are in "real world" coordinates, measured in mm.

Zoom is relative to a "standard" zoom which is internally calculated to include the whole image within the visible display area.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageFusion Class
DicomImageFusion Members
Overload List


SetViewPlane(Plane,Boolean,Single) Method

SetViewPlane(Plane,Boolean,Single) Method

DicomObjects Namespace > DicomImageFusion Class > SetViewPlane Method : SetViewPlane(Plane,Boolean,Single) Method
Controls whether the view is set to axial, sagital, coronal, or left unchanged
Controls whether to recentre the view to point to the centre of the image volume
The zoom factor to use - see notes in remarks
Set the view plane for the image, to one of 3 pre-defined views, with optional reset of centre and zoom
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SetViewPlane( _
   ByVal Plane As Plane, _
   ByVal Recentre As Boolean, _
   ByVal Zoom As Single _
)
'Usage

Dim instance As DicomImageFusion
Dim Plane As Plane
Dim Recentre As Boolean
Dim Zoom As Single

instance.SetViewPlane(Plane, Recentre, Zoom)
public void SetViewPlane(
   Plane Plane,
   bool Recentre,
   float Zoom
)
public:
void SetViewPlane(
   Plane Plane,
   bool Recentre,
   float Zoom
)

Parameters

Plane
Controls whether the view is set to axial, sagital, coronal, or left unchanged
Recentre
Controls whether to recentre the view to point to the centre of the image volume
Zoom
The zoom factor to use - see notes in remarks
Remarks

Zoom is relative to a "standard" zoom which is internally calculated to include the whole image within the visible display area. If Zoom is 0, then the Zoom of the image is unchanged.

For simple usage to reset the view to be based on the centre point of the image volume, with a conventional anatomical viewpoint, use Recentre = true, and zoom = 1

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageFusion Class
DicomImageFusion Members
Overload List


TranslateMm Method (DicomImageFusion)

TranslateMm Method (DicomImageFusion)

DicomObjects Namespace > DicomImageFusion Class : TranslateMm Method
The offset, measured in absolute real world mm
Move the centre point of the view by the specified offset
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub TranslateMm( _
   ByVal Offset As Vector3D _
)
'Usage

Dim instance As DicomImageFusion
Dim Offset As Vector3D

instance.TranslateMm(Offset)
public void TranslateMm(
   Vector3D Offset
)
public:
void TranslateMm(
   Vector3D Offset
)

Parameters

Offset
The offset, measured in absolute real world mm
Remarks
For a DicomImageFusion object, this passes the transformation on to all images in the collection which support IProjection
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageFusion Class
DicomImageFusion Members


TranslateNormal Method (DicomImageFusion)

TranslateNormal Method (DicomImageFusion)

DicomObjects Namespace > DicomImageFusion Class : TranslateNormal Method
The distance, measured in real world mm
Move the centre point of the view by the specified distance, normal to the current view plane
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub TranslateNormal( _
   ByVal Offset As Single _
)
'Usage

Dim instance As DicomImageFusion
Dim Offset As Single

instance.TranslateNormal(Offset)
public void TranslateNormal(
   float Offset
)
public:
void TranslateNormal(
   float Offset
)

Parameters

Offset
The distance, measured in real world mm
Remarks
For a DicomImageFusion object, this passes the transformation on to all images in the collection which support IProjection
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageFusion Class
DicomImageFusion Members


TranslatePixels Method (DicomImageFusion)

TranslatePixels Method (DicomImageFusion)

DicomObjects Namespace > DicomImageFusion Class : TranslatePixels Method
The movement to apply, measured in output pixels
The displaysize of the whole image as currently displayed
Move the display Offset pixels based on output size
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub TranslatePixels( _
   ByVal Offset As SizeF, _
   ByVal Size As Size _
)
'Usage

Dim instance As DicomImageFusion
Dim Offset As SizeF
Dim Size As Size

instance.TranslatePixels(Offset, Size)
public void TranslatePixels(
   SizeF Offset,
   Size Size
)
public:
void TranslatePixels(
   SizeF Offset,
   Size Size
)

Parameters

Offset
The movement to apply, measured in output pixels
Size
The displaysize of the whole image as currently displayed
Remarks
For a DicomImageFusion object, this passes the transformation on to all images in the collection which support IProjection
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageFusion Class
DicomImageFusion Members


DicomImageFusion Class Properties

DicomImageFusion Class Properties

DicomObjects Namespace : DicomImageFusion Class

For a list of all members of this type, see DicomImageFusion members.

Public Properties
 | Name | Description
Public Property | AccessionNumber | The Accession Number (Inherited from DicomObjects.DicomImage)
Public Property | Angle | Controls the rotation of an image (Inherited from DicomObjects.DicomImage)
Public Property | Area | The display area of DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | BorderPen | The Pen object for Image border (Inherited from DicomObjects.DicomImage)
Public Property | CacheMode | Controls how the pixel data is cached (Inherited from DicomObjects.DicomImage)
Public Property | CaptureBackColour | User defined background colour for image output of PrinterImage, Bitmap and SubImage methods Default is Black background (Inherited from DicomObjects.DicomImage)
Public Property | CDAStyleSheet | Style sheet used for displaying encapsulated CDA (Inherited from DicomObjects.DicomImage)
Public Property | CineFramesToDisplay | The set of frames to display for cine modes (Inherited from DicomObjects.DicomImage)
Public Property | CineIndex | The index of the currently displayed frame when using CineMode (Inherited from DicomObjects.DicomImage)
Public Property | CineMode | Enumerated running modes for multi-frame image (Inherited from DicomObjects.DicomImage)
Public Property | CineRate | Controls the speed of autonomous cine runs (Inherited from DicomObjects.DicomImage)
Public Property | CineSmoothing | Boolean property indicating whether Smoothing is applied when Cine is being displayed. (Inherited from DicomObjects.DicomImage)
Public Property | ColourTable | The colour lookup table of DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | CubicSplineAlpha | Parameter to control the degree of smoothing. The default value is �0.75, and normal values range from �0.5 to �1.25, though higher negative values may be used to produce deliberate edge enhancement. (Inherited from DicomObjects.DicomImage)
Public Property | DataSet | The underlying DICOM Dataset containing persistent data for the image (Inherited from DicomObjects.DicomImage)
Public Property | DateOfBirth | Date of birth of the patient (Inherited from DicomObjects.DicomImage)
Public Property | DisplayMode | Controls how the image is rendered internal before transfer to the screen (Inherited from DicomObjects.DicomImage)
Public Property | DrawCacheMode | Specify the DrawCacheMode to control how image is drawn/cached (Inherited from DicomObjects.DicomImage)
Public Property | ExplicitModalityLUT | An explicit modality Lookup Table to be used in place of one specified in the image or presentaiton state. (Inherited from DicomObjects.DicomImage)
Public Property | ExplicitPresentationLUT | An explicit presentation Lookup Table to be used in place of one specified in the image or presentaiton state. (Inherited from DicomObjects.DicomImage)
Public Property | ExplicitVOILUT | An explicit Values of Interest (VOI) Lookup Table to be used in place of one specified in the image or presentaiton state. (Inherited from DicomObjects.DicomImage)
Public Property | FilterLength | Contains the length of the smoothing filter (Inherited from DicomObjects.DicomImage)
Public Property | FlipState | The flip state of the image, allowing the orientation of the image, as displayed, to be altered (Inherited from DicomObjects.DicomImage)
Public Property | Frame | Controls which frame of a multi-frame image is displayed (Inherited from DicomObjects.DicomImage)
Public Property | FrameCount | The number of frames contained in a multi-frame image (Inherited from DicomObjects.DicomImage)
Public Property | Gamma | A number that specifies a power (Inherited from DicomObjects.DicomImage)
Public Property | ImageCollection | Image collection for fusion
Public Property | InstanceUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy (Inherited from DicomObjects.DicomImage)
Public Property | Invert | Controls whether the Image will be inverted. (Inherited from DicomObjects.DicomImage)
Public Property | Item | Overloaded. Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file. (Inherited from DicomObjects.DicomImage)
Public Property | JpipRequestSize | The size of the requests other than the first (in bytes) to make to a JPIP server. (Inherited from DicomObjects.DicomImage)
Public Property | Labels | Provides access to the DicomLabelCollection, items of which are to be displayed over an image. (Inherited from DicomObjects.DicomImage)
Public Property | Level | The Window Level (also known as the centre) - which controls the greyscale mapping of a displayed image (Inherited from DicomObjects.DicomImage)
Public Property | LevelShift | Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping (Inherited from DicomObjects.DicomImage)
Public Property | MagnificationMode | Controls how pixels are interpolated when the image is magnified (Inherited from DicomObjects.DicomImage)
Public Property | MaskRanges | Contains an array of DicomMaskRange objects to be applied to this image. See the DicomMaskRange object for more information on how this is used. (Inherited from DicomObjects.DicomImage)
Public Property | Matrix3D | The Matrix relating real world coordinates (in mm) to the display space (with units -1 to +1 in each dimension)
Public Property | MinificationMode | Controls how pixels are interpolated when the image is minified (Inherited from DicomObjects.DicomImage)
Public Property | ModalityLUT | Enables or disables the Modality Lookup Table to be used in the DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | Name | The Name of the patient (Inherited from DicomObjects.DicomImage)
Public Property | OpacityValues | Opacity values for individual images
Public Property | OriginalTs | Original Transfer syntax of the underlying DataSet (Inherited from DicomObjects.DicomImage)
Public Property | OverlayColour | Controls how overlays embedded in the image are displayed (Inherited from DicomObjects.DicomImage)
Public Property | OverlayVisible | Controls whether overlays embedded in the image are displayed (Inherited from DicomObjects.DicomImage)
Public Property | PatientID | The Patient ID (Inherited from DicomObjects.DicomImage)
Public Property | Pixels | Accesses the raw pixel data as a typed array (Inherited from DicomObjects.DicomImage)
Public Property | PresentationLUT | Enables or disables the Presentation Lookup Table to be used in the DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | PresentationState | Support for DICOM greyscale presentation state (Inherited from DicomObjects.DicomImage)
Public Property | PresentationStateFeaturesUsed | The presentation state features to use (Inherited from DicomObjects.DicomImage)
Public Property | PresentationStates | Support for a list of DICOM greyscale presentation state (Inherited from DicomObjects.DicomImage)
Public Property | RawPixels | Accesses the raw pixel data as an array (Inherited from DicomObjects.DicomImage)
Public Property | RealTimeCine | Controls how cine images are displayed (Inherited from DicomObjects.DicomImage)
Public Property | RenderedSize | Returns the Image display size in output (normally screen) coordinates (Inherited from DicomObjects.DicomImage)
Public Property | RotateState | The rotation state of the image, allowing the orientation of the image, as displayed, to be altered (Inherited from DicomObjects.DicomImage)
Public Property | RotationBehaviour | Controls the baseline positioning of an image which is not stretched to fit and is rotated (Inherited from DicomObjects.DicomImage)
Public Property | Scroll | Controls the positioning of an image display (Inherited from DicomObjects.DicomImage)
Public Property | SeriesDescription | Descriptions for the series (Inherited from DicomObjects.DicomImage)
Public Property | SeriesUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy (Inherited from DicomObjects.DicomImage)
Public Property | Sex | Sex of the patient (Inherited from DicomObjects.DicomImage)
Public Property | ShowLabels | Controls whether the image�s labels (annotations) are shown on screen (Inherited from DicomObjects.DicomImage)
Public Property | ShowShutter | Controls whether image shutters (if specified in the image) are used. (Inherited from DicomObjects.DicomImage)
Public Property | ShowUpdates | Controls whether the images is updated when image display parameters change (Inherited from DicomObjects.DicomImage)
Public Property | Size | The dimensions of the image (Inherited from DicomObjects.DicomImage)
Public Property | SOPClass | SOP class of the DicomDataSet. (Inherited from DicomObjects.DicomImage)
Public Property | StretchMode | Controls the automatic zooming of an image. (Inherited from DicomObjects.DicomImage)
Public Property | StudyDescription | Description for the study (Inherited from DicomObjects.DicomImage)
Public Property | StudyUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy (Inherited from DicomObjects.DicomImage)
Public Property | SynchonisePlanes | If true, then the images in ImageCollection are automatically adjusted to match the first of the collection at display time.
Public Property | Tag | A general purpose Tag for developer use (Inherited from DicomObjects.DicomImage)
Public Property | UnsharpEnhancement | UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement (Inherited from DicomObjects.DicomImage)
Public Property | UnsharpLength | UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement (Inherited from DicomObjects.DicomImage)
Public Property | UserMatrix | Means to override the matrix used to display 2D images (Inherited from DicomObjects.DicomImage)
Public Property | VoiLUT | The VOI Lookup Table to be used to display the DicomImage (Inherited from DicomObjects.DicomImage)
Public Property | VOILUTFunction | Controls which VOILUT function to be used, default value is Linear (Inherited from DicomObjects.DicomImage)
Public Property | VoiLUTInUse | Indicates whether a Values of Interest Lookup Table is in use (Inherited from DicomObjects.DicomImage)
Public Property | Width | The Window "Width" - which controls the greyscale mapping of a displayed image (Inherited from DicomObjects.DicomImage)
Public Property | WidthMultiplier | Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping (Inherited from DicomObjects.DicomImage)
Public Property | Zoom | Controls the magnification of an image display (Inherited from DicomObjects.DicomImage)
Top
See Also

Reference

DicomImageFusion Class
DicomObjects Namespace


ImageCollection Property

ImageCollection Property

DicomObjects Namespace > DicomImageFusion Class : ImageCollection Property
Image collection for fusion
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ImageCollection As DicomImageCollection
'Usage

Dim instance As DicomImageFusion
Dim value As DicomImageCollection

instance.ImageCollection = value

value = instance.ImageCollection
public DicomImageCollection ImageCollection {get; set;}
public:
property DicomImageCollection^ ImageCollection {
   DicomImageCollection^ get();
   void set (    DicomImageCollection^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageFusion Class
DicomImageFusion Members


Matrix3D Property (DicomImageFusion)

Matrix3D Property (DicomImageFusion)

DicomObjects Namespace > DicomImageFusion Class : Matrix3D Property
The Matrix relating real world coordinates (in mm) to the display space (with units -1 to +1 in each dimension)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Matrix3D As SharpDX.Matrix
'Usage

Dim instance As DicomImageFusion
Dim value As SharpDX.Matrix

instance.Matrix3D = value

value = instance.Matrix3D
public SharpDX.Matrix Matrix3D {get; set;}
public:
property SharpDX.Matrix Matrix3D {
   SharpDX.Matrix get();
   void set (    SharpDX.Matrix value);
}
Remarks
For a DicomImageFusion object, this returns the Matrix of the first image in the collection, but the setter changes all values
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageFusion Class
DicomImageFusion Members


OpacityValues Property

OpacityValues Property

DicomObjects Namespace > DicomImageFusion Class : OpacityValues Property
Opacity values for individual images
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OpacityValues As IEnumerable(Of Single)
'Usage

Dim instance As DicomImageFusion
Dim value As IEnumerable(Of Single)

instance.OpacityValues = value

value = instance.OpacityValues
public IEnumerable<float> OpacityValues {get; set;}
public:
property IEnumerable<float>^ OpacityValues {
   IEnumerable<float>^ get();
   void set (    IEnumerable<float>^ value);
}
Remarks
Value should be in the range of 0 - 1
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageFusion Class
DicomImageFusion Members


SynchonisePlanes Property

SynchonisePlanes Property

DicomObjects Namespace > DicomImageFusion Class : SynchonisePlanes Property
If true, then the images in ImageCollection are automatically adjusted to match the first of the collection at display time.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SynchonisePlanes As Boolean
'Usage

Dim instance As DicomImageFusion
Dim value As Boolean

instance.SynchonisePlanes = value

value = instance.SynchonisePlanes
public bool SynchonisePlanes {get; set;}
public:
property bool SynchonisePlanes {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageFusion Class
DicomImageFusion Members


DicomLabel Class

DicomLabel Class
Members

DicomObjects Namespace : DicomLabel Class
A label, or annotation, to be displayed over an image in a DicomViewer control, or in derived copies of the image.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomLabel
'Usage

Dim instance As DicomLabel
public class DicomLabel
public ref class DicomLabel
Remarks

Labels may be ellipses (or circles), rectangles (or squares), lines, text or bitmaps, or other shapes (see LabelType for a full list), and the properties control not only the type and size of the object, but many other properties such as colour and line thickness.

Labels may be tied to the viewer control, to the display area in which an image is displayed, or to the image itself, this latter distinction being controlled by the ScaleMode property.

All properties have default values, which are suitable for many uses, and each is documented with the appropriate property. The same label may be added into several DicomLabelCollections if necessary, but where this is done, subsequent labels will be “cloned” when added, so that they may later be manipulated independently. Also, unambiguous association of each DicomLabel with one image is necessary for the ROI functions.

An arc is defined as if it were an ellipse using top, left, height and width, but the first two items of the Points collection are used to define the start and end (working anti-clockwise)

For Special Labels check this kb article

Inheritance Hierarchy

System.Object
DicomObjects.DicomLabel

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Members
DicomObjects Namespace


DicomLabel Class Members

DicomLabel Class Members
Properties Methods Events

DicomObjects Namespace : DicomLabel Class

The following tables list the members exposed by DicomLabel.

Public Constructors
 | Name | Description
Public Constructor | DicomLabel Constructor | Creates a new blank DicomLabel object
Top
Public Properties
 | Name | Description
Public Property | Anchor | A pair of coordinates (x, y) of an visible anchor point for a text label
Public Property | AnchorScaleMode | Defines how anchor point is transformed with the image
Public Property | Angle | Angle to rotate Label (Clockwise)
Public Property | Area | The 4 edges of the rectangle area of the DicomLabel
Public Property | AutoSizeMode | Controls the size of a text label.
Public Property | BoundingBox | Area that encloses the label as displayed
Public Property | Brush | Objects used to fill the interiors of graphical shapes such as rectangles, ellipses, pies, polygons, and paths
Public Property | ChildAlignment | Specify the locations of the child labels
Public Property | ChildLabels | A DicomLabel collection linked with the primary DicomLabel. Useful for grouping labels together so you can do one operation for all of them, i.e movement.
Public Property | CircleWithPerpendicularBiSector | Draw a circle using Perpendicular Bisector from the first three user defined Points. For this to work you need to select the DicomObjects.Enums.LabelType.Ellipse and set at least three Points Default is false, which means the label will use Area property instead of user defined points
Public Property | Font | The Font to be used for text labels
Public Property | FontIndex | Specify which Font in the Fonts Collection to apply to the Current DicomLabel object.
static (Shared in Visual Basic) | Fonts | A Static Font collection. Users can define and add their list of fonts and choose which to apply to each DicomLabel object using DicomLabel's FontIndex property.
Public Property | FrameList | List of Frames you want to display the DicomLabel on. Empty FrameList is default value and it means display on all frames.
Public Property | Height | Define the height of a DicomLabel (annotation) on an image
Public Property | Image | The Image to be displayed by an Image type DicomLabel
Public Property | ImageOpacity | Controls the opacity of the Image label. Only applicable to DicomObjects.Enums.LabelType.Image. Value ranges from 0-1 (None to Full opacity)
static (Shared in Visual Basic) | ImportedLabelType | The type of label created by DicomObjects from Presentation states
Public Property | IncludeInPresentationState | This property controls whether the DicomLabel goes into the PresentationState or not when one of the CurrentToPresentationState methods is used.
Public Property | IsInterpolated | Specify if the DicomLabel is Interpolated
Public Property | IsShutter | This property decides whether or not the DicomLabel will be acting as a Shutter.
Public Property | LabelType | Determines the basic type of a label
Public Property | Left | Define the left of a DicomLabel (annotation) on an image
Public Property | Margin | Defines a margin between text and it’s bounding box
Public Property | MinArrowSize | Specify the minimum Arrow size when the labeltype is set to LabelArrow
Public Property | Pen | Object used to draw lines and curves
Public Property | Plane | The plane on which this label will be displayed when used on a 3D image
Public Property | Points | The points of a DicomLabel (of type PolyLine or Polygon)
Public Property | RefImage | The image whose plane is used to control the placement of this image, as a line.
Public Property | Reversible | Controls whether the label is drawn in reversible mode
Public Property | RotationCentre | Controls the centre of rotation of a text label.
Public Property | RotationMode | Controls the rotation behaviour of a label.
Public Property | RotationPoint | Defines the centre point used for label rotation (whether due to Angle or as a result of RotationMode) if the RotationCentre is set to SpecifiedPoint
Public Property | RulerOptions | Ruler options used if LabelType is set to Ruler
Public Property | RulerSpacing | Controls the approximate spacing of the minor ticks for a ruler label
Public Property | ScaleFontSize | Determines whether the font size scales with the image
Public Property | ScaleMode | Defines a basic scale mode of DicomLabel
Public Property | ScalePenWidth | Control whether the width of a line scales with the label being drawn
Public Property | SelectMode | Controls whether a label is highlighted using a box and/or “handles”
Public Property | SelectPen | Select Pen from Pen
Public Property | Shadow | Controls whether a label is displayed with a contrasting shadow, to make it more visible over image areas with the same colour.
Public Property | ShadowColor | Contains the colour of the Shadow applied to the DicomLabel
Public Property | ShowAnchor | Determines whether the anchor point is shown
Public Property | ShowTextBox | Controls whether text boxes have a visible border
Public Property | StringFormat | Handles text alignment using the .NET StringFormat Member
Public Property | Tag | A general purpose Tag for developer use
Public Property | Text | The text to be displayed by a text type DicomLabel
Public Property | TextBrush | The brush object only for labels of type "doLabelText"
Public Property | TextLabelRendering | Control text label anti-aliasing behaviour
Public Property | Top | Define the top of a DicomLabel (annotation) on an image
Public Property | Visible | Controls whether a DicomLabel object is displayed
Public Property | Width | Define the width of a DicomLabel (annotation) on an image
Top
Public Methods
 | Name | Description
Public Method | AddPoint | Overloaded. Adds to point to the path used for a polyline or polygon type of DicomLabel
Public Method | Adjust | Move or resize a label defined offset where the offset is defined in screen pixel units
Public Method | ClipTo | Limits a line to the section within a given rectangle
Public Method | Clone | Clones the DicomLabel
static (Shared in Visual Basic) | Create3DLabel | Create 3D label
Public Method | GetTickSpacing | Returns the size of the spacing used in a DicomLabel of type Ruler
Public Method | Matrix | Provides the Matrix object used to display the DicomLabel
Public Method | OnExport | Allows control of Export of objects derived from a DicomLabel
Public Method | OnImport | Allows control of Import of objects derived from a DicomLabel
Public Method | Rescale | Overloaded. Transform a label from viewer coordinates to the chosen image scaling type
Public Method | ROIArea | Overloaded. Returns the area of the ROI
Public Method | ROIDistanceUnits | Overloaded. Distance units for the values returned by ROILength and ROIArea of a None-Image-Tied label
Public Method | ROILength | Overloaded. Length of the boundary of a DicomLabel, interpreted as a region of interest. The overload method applies to None-Image-Tied labels
Public Method | ROIMax | Returns the maximum values of the pixels in the ROI
Public Method | ROIMean | Returns the mean value of the pixels in the ROI
Public Method | ROIMin | Returns the minimum values of the pixels in the ROI
Public Method | ROIPoints | The list of points within the label
Public Method | ROIStandardDeviation | Returns the standard deviation of the values of the pixels in the ROI
Public Method | ROIValues | The values within a DicomLabel, interpreted as a region of interest
Public Method | ScaledAngle | Returns the line angle of the DicomLabel. Image Pixel Aspect Ratio is automatically taken into account.
Public Method | Threshold | Makes a bitmap label by thresholding an existing label
Public Method | Transform | Adjusts the position, size etc. of the label
Public Method | Update | Force display update for this label
Top
Public Events
 | Name | Description
Public Event | LabelChanged | Event fired when the properties of a label are changed.
Public Event | PSLabelCreated | Event fires when a new DicomLabel is created when a Presentation State is applied to an image. This event gives users a chance to customise the label before display
Top
See Also

Reference

DicomLabel Class
DicomObjects Namespace


DicomLabel Constructor

DicomLabel Constructor

DicomObjects Namespace > DicomLabel Class : DicomLabel Constructor
Creates a new blank DicomLabel object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DicomLabel()
public DicomLabel()
public:
DicomLabel();
Remarks
The default LabelType value is LabelType.Text
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


DicomLabel Class Methods

DicomLabel Class Methods

DicomObjects Namespace : DicomLabel Class

For a list of all members of this type, see DicomLabel members.

Public Methods
 | Name | Description
Public Method | AddPoint | Overloaded. Adds to point to the path used for a polyline or polygon type of DicomLabel
Public Method | Adjust | Move or resize a label defined offset where the offset is defined in screen pixel units
Public Method | ClipTo | Limits a line to the section within a given rectangle
Public Method | Clone | Clones the DicomLabel
static (Shared in Visual Basic) | Create3DLabel | Create 3D label
Public Method | GetTickSpacing | Returns the size of the spacing used in a DicomLabel of type Ruler
Public Method | Matrix | Provides the Matrix object used to display the DicomLabel
Public Method | OnExport | Allows control of Export of objects derived from a DicomLabel
Public Method | OnImport | Allows control of Import of objects derived from a DicomLabel
Public Method | Rescale | Overloaded. Transform a label from viewer coordinates to the chosen image scaling type
Public Method | ROIArea | Overloaded. Returns the area of the ROI
Public Method | ROIDistanceUnits | Overloaded. Distance units for the values returned by ROILength and ROIArea of a None-Image-Tied label
Public Method | ROILength | Overloaded. Length of the boundary of a DicomLabel, interpreted as a region of interest. The overload method applies to None-Image-Tied labels
Public Method | ROIMax | Returns the maximum values of the pixels in the ROI
Public Method | ROIMean | Returns the mean value of the pixels in the ROI
Public Method | ROIMin | Returns the minimum values of the pixels in the ROI
Public Method | ROIPoints | The list of points within the label
Public Method | ROIStandardDeviation | Returns the standard deviation of the values of the pixels in the ROI
Public Method | ROIValues | The values within a DicomLabel, interpreted as a region of interest
Public Method | ScaledAngle | Returns the line angle of the DicomLabel. Image Pixel Aspect Ratio is automatically taken into account.
Public Method | Threshold | Makes a bitmap label by thresholding an existing label
Public Method | Transform | Adjusts the position, size etc. of the label
Public Method | Update | Force display update for this label
Top
See Also

Reference

DicomLabel Class
DicomObjects Namespace


AddPoint Method

AddPoint Method

DicomObjects Namespace > DicomLabel Class : AddPoint Method
Adds to point to the path used for a polyline or polygon type of DicomLabel
Overload List
Overload | Description
AddPoint(Single,Single) | Adds to point to the path used for a polyline or polygon type of DicomLabel.
AddPoint(PointF) | Adds to point to the path used for a polyline or polygon type of DicomLabel.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


AddPoint(Single,Single) Method

AddPoint(Single,Single) Method

DicomObjects Namespace > DicomLabel Class > AddPoint Method : AddPoint(Single,Single) Method
The X co-ordinates of the point to add.
The Y co-ordinates of the point to add.
Adds to point to the path used for a polyline or polygon type of DicomLabel.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub AddPoint( _
   ByVal X As Single, _
   ByVal Y As Single _
)
'Usage

Dim instance As DicomLabel
Dim X As Single
Dim Y As Single

instance.AddPoint(X, Y)
public void AddPoint(
   float X,
   float Y
)
public:
void AddPoint(
   float X,
   float Y
)

Parameters

X
The X co-ordinates of the point to add.
Y
The Y co-ordinates of the point to add.
Remarks

This method only affects Label objects where the LabelType is Polygon or PolyLine.

The points are scaled and moved exactly as are Top, Left, Width & Height, i.e. if used a part of a DicomViewer’s Labels collection or if ImageTied is false, then they are display pixels, but ImageTied is true, and used as part of a DicomImage’s Labels collection, then they are scaled and scrolled with the image pixels, ensuring that the shape produced maintains an exact relationship to the underlying image.

After points have been added, they may be accessed through the Points property, which may also be used to set the whole array in a single operation.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members
Overload List


AddPoint(PointF) Method

AddPoint(PointF) Method

DicomObjects Namespace > DicomLabel Class > AddPoint Method : AddPoint(PointF) Method
The point to add
Adds to point to the path used for a polyline or polygon type of DicomLabel.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub AddPoint( _
   ByVal point As PointF _
)
'Usage

Dim instance As DicomLabel
Dim point As PointF

instance.AddPoint(point)
public void AddPoint(
   PointF point
)
public:
void AddPoint(
   PointF point
)

Parameters

point
The point to add
Remarks

This method only affects Label objects where the LabelType is Polygon or PolyLine.

The points are scaled and moved exactly as are Top, Left, Width & Height, i.e. if used a part of a DicomViewer’s Labels collection or if ImageTied is false, then they are display pixels, but ImageTied is true, and used as part of a DicomImage’s Labels collection, then they are scaled and scrolled with the image pixels, ensuring that the shape produced maintains an exact relationship to the underlying image.

After points have been added, they may be accessed through the Points property, which may also be used to set the whole array in a single operation.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members
Overload List


Adjust Method

Adjust Method

DicomObjects Namespace > DicomLabel Class : Adjust Method
Which corner of the label to adjust
The distance to move that corner
The viewer in which the image is displayed
The index of the image, on which the label is displayed, within the viewer
Move or resize a label defined offset where the offset is defined in screen pixel units
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Adjust( _
   ByVal Where As ContentAlignment, _
   ByVal Offset As SizeF, _
   ByVal Viewer As DicomViewer, _
   ByVal Index As Integer _
)
'Usage

Dim instance As DicomLabel
Dim Where As ContentAlignment
Dim Offset As SizeF
Dim Viewer As DicomViewer
Dim Index As Integer

instance.Adjust(Where, Offset, Viewer, Index)
public void Adjust(
   ContentAlignment Where,
   SizeF Offset,
   DicomViewer Viewer,
   int Index
)
public:
void Adjust(
   ContentAlignment Where,
   SizeF Offset,
   DicomViewer^ Viewer,
   int Index
)

Parameters

Where
Which corner of the label to adjust
Offset
The distance to move that corner
Viewer
The viewer in which the image is displayed
Index
The index of the image, on which the label is displayed, within the viewer
Remarks
This method is typically used to provide a means to "edit" labels by adjusting their corners. If Where is System.Drawing.ContentAlignment.MiddleCenter then the label is moved with no re-sizing.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


ClipTo Method

ClipTo Method

DicomObjects Namespace > DicomLabel Class : ClipTo Method
The area to clip to
Limits a line to the section within a given rectangle
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ClipTo( _
   ByVal Rectangle As RectangleF _
)
'Usage

Dim instance As DicomLabel
Dim Rectangle As RectangleF

instance.ClipTo(Rectangle)
public void ClipTo(
   RectangleF Rectangle
)
public:
void ClipTo(
   RectangleF Rectangle
)

Parameters

Rectangle
The area to clip to
Remarks
Although the type of the label is not explicitly checked (as the mehod merely changes the Area property, in practice it only makes sense to use this method for labels of type Line
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Clone Method (DicomLabel)

Clone Method (DicomLabel)

DicomObjects Namespace > DicomLabel Class : Clone Method
Clones the DicomLabel
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function Clone() As DicomLabel
'Usage

Dim instance As DicomLabel
Dim value As DicomLabel

value = instance.Clone()
public virtual DicomLabel Clone()
public:
virtual DicomLabel^ Clone();

Return Value

A cloned copy
Remarks
A complete cloned copy is created.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Create3DLabel Method

Create3DLabel Method

DicomObjects Namespace > DicomLabel Class : Create3DLabel Method
The area of the image from a previous label's Area property
The Plane of the image to display the label on
Create 3D label
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function Create3DLabel( _
   ByVal Area As RectangleF, _
   ByVal Plane As Plane3D _
) As DicomLabel
'Usage

Dim Area As RectangleF
Dim Plane As Plane3D
Dim value As DicomLabel

value = DicomLabel.Create3DLabel(Area, Plane)
public static DicomLabel Create3DLabel(
   RectangleF Area,
   Plane3D Plane
)
public:
static DicomLabel^ Create3DLabel(
   RectangleF Area,
   Plane3D Plane
)

Parameters

Area
The area of the image from a previous label's Area property
Plane
The Plane of the image to display the label on

Return Value

a new DicomLabel of mode Image3D
Remarks
This is a specialised method for reconstructing previously created and saved labels
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


GetTickSpacing(Boolean,DicomImage,DicomViewer) Method

GetTickSpacing(Boolean,DicomImage,DicomViewer) Method

DicomObjects Namespace > DicomLabel Class : GetTickSpacing(Boolean,DicomImage,DicomViewer) Method
If MajorTicks is true, then the value is the spacing between large marks, and if false, it will be the small mark spacing. The large mark spacing is always exactly 2, 5 or 10 time the small mark spacing.
The image from which the pixel data is taken for the calculations
The Viewer in which the image is displayed
Returns the size of the spacing used in a DicomLabel of type Ruler
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function GetTickSpacing( _
   ByVal MajorTicks As Boolean, _
   ByVal Image As DicomImage, _
   ByVal Viewer As DicomViewer _
) As Single
'Usage

Dim instance As DicomLabel
Dim MajorTicks As Boolean
Dim Image As DicomImage
Dim Viewer As DicomViewer
Dim value As Single

value = instance.GetTickSpacing(MajorTicks, Image, Viewer)
public float GetTickSpacing(
   bool MajorTicks,
   DicomImage Image,
   DicomViewer Viewer
)
public:
float GetTickSpacing(
   bool MajorTicks,
   DicomImage^ Image,
   DicomViewer^ Viewer
)

Parameters

MajorTicks
If MajorTicks is true, then the value is the spacing between large marks, and if false, it will be the small mark spacing. The large mark spacing is always exactly 2, 5 or 10 time the small mark spacing.
Image
The image from which the pixel data is taken for the calculations
Viewer
The Viewer in which the image is displayed

Return Value

A float number as the spacing between tick marks on the ruler displayed
Remarks

The value returned is the spacing in nominal mm between tick marks on the ruler displayed. Note that depending on the type of image, these may not be true patient measurements, and the ROIDistanceUnits property should be checked to see whether these are “mm at imager” etc.

If MajorTicks is true, then the value is the spacing between large marks, and if false, it will be the small mark spacing. The large mark spacing is always exactly 2, 5 or 10 time the small mark spacing.

The values returned by this property are highly labile, and will change if the zoom, StretchMode or any other display parameters of the associated image are altered, so if used for display purposes, it may be advisable to update in the “DrawStart” event.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Matrix Method (DicomLabel)

Matrix Method (DicomLabel)

DicomObjects Namespace > DicomLabel Class : Matrix Method
The DicomViewer control in which the DicomLabel is being displayed

If the label is shown as part of the Labels collection of a DicomImage, then this should be the Index of the DicomImage in the viewer's Images collection.

If the label is part of a the viewer's Labels collection, then this should be -1

Provides the Matrix object used to display the DicomLabel
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function Matrix( _
   ByVal viewer As DicomViewer, _
   ByVal index As Integer _
) As Matrix
'Usage

Dim instance As DicomLabel
Dim viewer As DicomViewer
Dim index As Integer
Dim value As Matrix

value = instance.Matrix(viewer, index)
public Matrix Matrix(
   DicomViewer viewer,
   int index
)
public:
Matrix^ Matrix(
   DicomViewer^ viewer,
   int index
)

Parameters

viewer
The DicomViewer control in which the DicomLabel is being displayed
index

If the label is shown as part of the Labels collection of a DicomImage, then this should be the Index of the DicomImage in the viewer's Images collection.

If the label is part of a the viewer's Labels collection, then this should be -1

Return Value

The requested matrix
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


OnExport Method

OnExport Method

DicomObjects Namespace > DicomLabel Class : OnExport Method
The DicomDataset within the presentation state representing this particular label
The UsePrivate parameter from CurrentToPresentationState .
Allows control of Export of objects derived from a DicomLabel
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Sub OnExport( _
   ByVal LabelDataSet As DicomDataSet, _
   ByVal UsePrivate As Boolean _
)
'Usage

Dim instance As DicomLabel
Dim LabelDataSet As DicomDataSet
Dim UsePrivate As Boolean

instance.OnExport(LabelDataSet, UsePrivate)
public virtual void OnExport(
   DicomDataSet LabelDataSet,
   bool UsePrivate
)
public:
virtual void OnExport(
   DicomDataSet^ LabelDataSet,
   bool UsePrivate
)

Parameters

LabelDataSet
The DicomDataset within the presentation state representing this particular label
UsePrivate
The UsePrivate parameter from CurrentToPresentationState .
Remarks
This routine is called afterDicomObjects has added its own private attributes
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


OnImport Method

OnImport Method

DicomObjects Namespace > DicomLabel Class : OnImport Method
The DicomDataset within the presentation state representing this particular label
Allows control of Import of objects derived from a DicomLabel
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Sub OnImport( _
   ByVal LabelDataSet As DicomDataSet _
)
'Usage

Dim instance As DicomLabel
Dim LabelDataSet As DicomDataSet

instance.OnImport(LabelDataSet)
public virtual void OnImport(
   DicomDataSet LabelDataSet
)
public:
virtual void OnImport(
   DicomDataSet^ LabelDataSet
)

Parameters

LabelDataSet
The DicomDataset within the presentation state representing this particular label
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Rescale Method

Rescale Method

DicomObjects Namespace > DicomLabel Class : Rescale Method
Transform a label from viewer coordinates to the chosen image scaling type
Overload List
Overload | Description
Rescale(DicomViewer,Int32,ScaleMode) | Transform a label from viewer coordinates to the chosen image scaling type
Rescale(DicomImage,Size,ScaleMode) | Transform a label from viewer coordinates to the chosen image scaling type
Rescale(DicomViewer,Int32,Boolean,ScaleMode) | Transform a label from viewer coordinates to the chosen image scaling type
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Rescale(DicomViewer,Int32,ScaleMode) Method

Rescale(DicomViewer,Int32,ScaleMode) Method

DicomObjects Namespace > DicomLabel Class > Rescale Method : Rescale(DicomViewer,Int32,ScaleMode) Method
The viewer the label is currently being shown on
The index of the image within that viewer to which the label is intended to be applied
The new ScaleMode property for the label
Transform a label from viewer coordinates to the chosen image scaling type
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Rescale( _
   ByVal Viewer As DicomViewer, _
   ByVal Index As Integer, _
   ByVal NewScaleMode As ScaleMode _
)
'Usage

Dim instance As DicomLabel
Dim Viewer As DicomViewer
Dim Index As Integer
Dim NewScaleMode As ScaleMode

instance.Rescale(Viewer, Index, NewScaleMode)
public void Rescale(
   DicomViewer Viewer,
   int Index,
   ScaleMode NewScaleMode
)
public:
void Rescale(
   DicomViewer^ Viewer,
   int Index,
   ScaleMode NewScaleMode
)

Parameters

Viewer
The viewer the label is currently being shown on
Index
The index of the image within that viewer to which the label is intended to be applied
NewScaleMode
The new ScaleMode property for the label
Remarks

This method does not actually remove the label from the viewer's ccollection (if it were even a member), and does not actually add it to the image's Labels collection, though that is what a developer would normally do immediately after this method.

The label's coordinates are manipulated, so that after such a change, it should appear completely unchanged in size and position, but with a different "base"

This overload checks whether the labels is part of the image's Labels collection and if so, handles as an image-related label, but if it is not a member of that collection, then it is treated as viewer-related.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members
Overload List


Rescale(DicomImage,Size,ScaleMode) Method

Rescale(DicomImage,Size,ScaleMode) Method

DicomObjects Namespace > DicomLabel Class > Rescale Method : Rescale(DicomImage,Size,ScaleMode) Method
The image to which the label is attached
The size of the displayed version of the image (the cell area, or size of the output on which the label has been drawn
The new ScaleMode property for the label
Transform a label from viewer coordinates to the chosen image scaling type
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Rescale( _
   ByVal Image As DicomImage, _
   ByVal Size As Size, _
   ByVal NewScaleMode As ScaleMode _
)
'Usage

Dim instance As DicomLabel
Dim Image As DicomImage
Dim Size As Size
Dim NewScaleMode As ScaleMode

instance.Rescale(Image, Size, NewScaleMode)
public void Rescale(
   DicomImage Image,
   Size Size,
   ScaleMode NewScaleMode
)
public:
void Rescale(
   DicomImage^ Image,
   Size Size,
   ScaleMode NewScaleMode
)

Parameters

Image
The image to which the label is attached
Size
The size of the displayed version of the image (the cell area, or size of the output on which the label has been drawn
NewScaleMode
The new ScaleMode property for the label
Remarks

This overload is intended for cases where no viewer is being used - e.g. in a web server rendering images to JPG, PNG etc.

The label's coordinates are manipulated, so that after such a change, it should appear completely unchanged in size and position, but with a different "base"

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members
Overload List


Rescale(DicomViewer,Int32,Boolean,ScaleMode) Method

Rescale(DicomViewer,Int32,Boolean,ScaleMode) Method

DicomObjects Namespace > DicomLabel Class > Rescale Method : Rescale(DicomViewer,Int32,Boolean,ScaleMode) Method
The viewer the label is currently being shown on
The index of the image within that viewer to which the label is intended to be applied
If true, the the current position is assumed to be as if the label is displayed using Viewer.DrawLabel or in the viewer's collection, and if false it is assumed to be in the Image's Labels collection.
The new ScaleMode property for the label
Transform a label from viewer coordinates to the chosen image scaling type
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Rescale( _
   ByVal Viewer As DicomViewer, _
   ByVal Index As Integer, _
   ByVal IsInViewer As Boolean, _
   ByVal NewScaleMode As ScaleMode _
)
'Usage

Dim instance As DicomLabel
Dim Viewer As DicomViewer
Dim Index As Integer
Dim IsInViewer As Boolean
Dim NewScaleMode As ScaleMode

instance.Rescale(Viewer, Index, IsInViewer, NewScaleMode)
public void Rescale(
   DicomViewer Viewer,
   int Index,
   bool IsInViewer,
   ScaleMode NewScaleMode
)
public:
void Rescale(
   DicomViewer^ Viewer,
   int Index,
   bool IsInViewer,
   ScaleMode NewScaleMode
)

Parameters

Viewer
The viewer the label is currently being shown on
Index
The index of the image within that viewer to which the label is intended to be applied
IsInViewer
If true, the the current position is assumed to be as if the label is displayed using Viewer.DrawLabel or in the viewer's collection, and if false it is assumed to be in the Image's Labels collection.
NewScaleMode
The new ScaleMode property for the label
Remarks

This method does not actually remove the label from the viewer's ccollection (if it were even a member), and does not actually add it to the image's Labels collection, though that is what a developer would normally do immediately after this method.

The label's coordinates are manipulated, so that after such a change, it should appear completely unchanged in size and position, but with a different "base"

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members
Overload List


ROIArea Method

ROIArea Method

DicomObjects Namespace > DicomLabel Class : ROIArea Method
Returns the area of the ROI
Overload List
Overload | Description
ROIArea(DicomViewer,Int32) | Returns the area of the ROI
ROIArea(DicomImage) | Returns the area of the ROI
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


ROIArea(DicomViewer,Int32) Method

ROIArea(DicomViewer,Int32) Method

DicomObjects Namespace > DicomLabel Class > ROIArea Method : ROIArea(DicomViewer,Int32) Method
The DicomViewer object which holds the Image that measurement is being taken on
The Image index of the image that measurement is being taken on
Returns the area of the ROI
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function ROIArea( _
   ByVal Viewer As DicomViewer, _
   ByVal Index As Integer _
) As Single
'Usage

Dim instance As DicomLabel
Dim Viewer As DicomViewer
Dim Index As Integer
Dim value As Single

value = instance.ROIArea(Viewer, Index)
public float ROIArea(
   DicomViewer Viewer,
   int Index
)
public:
float ROIArea(
   DicomViewer^ Viewer,
   int Index
)

Parameters

Viewer
The DicomViewer object which holds the Image that measurement is being taken on
Index
The Image index of the image that measurement is being taken on

Return Value

A single precision float number
Remarks

Where pixel dimensions for the whole image are present within the image data, these are used to scale the area appropriately, and multiple region calibration areas (e.g. in U/S images) are supported. The units used (which for uncalibrated data may simply be pixels) is returned by ROIDistanceUnits (for this property, they should be interpreted as square units of course)

This method may only be used for DicomLabels of type Rectangle, Ellipse, Polygon or Bitmap.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members
Overload List


ROIArea(DicomImage) Method

ROIArea(DicomImage) Method

DicomObjects Namespace > DicomLabel Class > ROIArea Method : ROIArea(DicomImage) Method
The Image that measurement is being taken on
Returns the area of the ROI
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function ROIArea( _
   ByVal Image As DicomImage _
) As Single
'Usage

Dim instance As DicomLabel
Dim Image As DicomImage
Dim value As Single

value = instance.ROIArea(Image)
public float ROIArea(
   DicomImage Image
)
public:
float ROIArea(
   DicomImage^ Image
)

Parameters

Image
The Image that measurement is being taken on

Return Value

A single precision float number
Remarks

Where pixel dimensions for the whole image are present within the image data, these are used to scale the area appropriately, and multiple region calibration areas (e.g. in U/S images) are supported. The units used (which for uncalibrated data may simply be pixels) is returned by ROIDistanceUnits (for this property, they should be interpreted as square units of course)

This method may only be used for DicomLabels of type Rectangle, Ellipse, Polygon or Bitmap.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members
Overload List


ROIDistanceUnits Method

ROIDistanceUnits Method

DicomObjects Namespace > DicomLabel Class : ROIDistanceUnits Method
Distance units for the values returned by ROILength and ROIArea of a None-Image-Tied label
Overload List
Overload | Description
ROIDistanceUnits(DicomImage) | Distance units for the values returned by ROILength and ROIArea of a Image-Tied label
ROIDistanceUnits(DicomViewer,Int32) | Distance units for the values returned by ROILength and ROIArea of a None-Image-Tied label
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


ROIDistanceUnits(DicomImage) Method

ROIDistanceUnits(DicomImage) Method

DicomObjects Namespace > DicomLabel Class > ROIDistanceUnits Method : ROIDistanceUnits(DicomImage) Method
The image from which the pixel data is taken for the calculations
Distance units for the values returned by ROILength and ROIArea of a Image-Tied label
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function ROIDistanceUnits( _
   ByVal Image As DicomImage _
) As String
'Usage

Dim instance As DicomLabel
Dim Image As DicomImage
Dim value As String

value = instance.ROIDistanceUnits(Image)
public string ROIDistanceUnits(
   DicomImage Image
)
public:
String^ ROIDistanceUnits(
   DicomImage^ Image
)

Parameters

Image
The image from which the pixel data is taken for the calculations

Return Value

A String Value of the Distance Units
Remarks

The value returned depends on whether distance calibration is present in the image data. The possible values are:

  • "mm"
  • "mm at Imager"
  • "mm at Imaging Plane"
  • "Pixels"
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members
Overload List


ROIDistanceUnits(DicomViewer,Int32) Method

ROIDistanceUnits(DicomViewer,Int32) Method

DicomObjects Namespace > DicomLabel Class > ROIDistanceUnits Method : ROIDistanceUnits(DicomViewer,Int32) Method
The Viewer which holds the Image where measurement units is taken from
The Index of the Image in the Viewer's Images Collection
Distance units for the values returned by ROILength and ROIArea of a None-Image-Tied label
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function ROIDistanceUnits( _
   ByVal Viewer As DicomViewer, _
   ByVal Index As Integer _
) As String
'Usage

Dim instance As DicomLabel
Dim Viewer As DicomViewer
Dim Index As Integer
Dim value As String

value = instance.ROIDistanceUnits(Viewer, Index)
public string ROIDistanceUnits(
   DicomViewer Viewer,
   int Index
)
public:
String^ ROIDistanceUnits(
   DicomViewer^ Viewer,
   int Index
)

Parameters

Viewer
The Viewer which holds the Image where measurement units is taken from
Index
The Index of the Image in the Viewer's Images Collection

Return Value

A String Value of the Distance Units
Remarks

The value returned depends on whether distance calibration is present in the image data. The possible values are:

  • "mm"
  • "mm at Imager"
  • "mm at Imaging Plane"
  • "Pixels"
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members
Overload List


ROILength Method

ROILength Method

DicomObjects Namespace > DicomLabel Class : ROILength Method
Length of the boundary of a DicomLabel, interpreted as a region of interest. The overload method applies to None-Image-Tied labels
Overload List
Overload | Description
ROILength(DicomImage) | Length of the boundary of a DicomLabel, interpreted as a region of interest. This method applies to Image-Tied labels
ROILength(DicomViewer,Int32) | Length of the boundary of a Non-Image-Tied DicomLabel, interpreted as a region of interest.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


ROILength(DicomImage) Method

ROILength(DicomImage) Method

DicomObjects Namespace > DicomLabel Class > ROILength Method : ROILength(DicomImage) Method
The image from which the pixel data is taken for the calculations
Length of the boundary of a DicomLabel, interpreted as a region of interest. This method applies to Image-Tied labels
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function ROILength( _
   ByVal Image As DicomImage _
) As Single
'Usage

Dim instance As DicomLabel
Dim Image As DicomImage
Dim value As Single

value = instance.ROILength(Image)
public float ROILength(
   DicomImage Image
)
public:
float ROILength(
   DicomImage^ Image
)

Parameters

Image
The image from which the pixel data is taken for the calculations

Return Value

The length of the boundary of a DicomLabel
Remarks

This property may not be used for DicomLabels of type Bitmap.

The length is the length of the entire circumference of the label.

Where pixel dimensions for the whole image are present within the image data, these are used to scale the length appropriately. Multiple region calibration areas (e.g. in U/S images) are fully supported.

The units used (which for uncalibrated data may simply be pixels) is returned by ROIDistanceUnits.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members
Overload List


ROILength(DicomViewer,Int32) Method

ROILength(DicomViewer,Int32) Method

DicomObjects Namespace > DicomLabel Class > ROILength Method : ROILength(DicomViewer,Int32) Method
The Viewer from which the Image is drawn
The specific Index of the Image in the Viewer's Images Collection
Length of the boundary of a Non-Image-Tied DicomLabel, interpreted as a region of interest.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function ROILength( _
   ByVal Viewer As DicomViewer, _
   ByVal Index As Integer _
) As Single
'Usage

Dim instance As DicomLabel
Dim Viewer As DicomViewer
Dim Index As Integer
Dim value As Single

value = instance.ROILength(Viewer, Index)
public float ROILength(
   DicomViewer Viewer,
   int Index
)
public:
float ROILength(
   DicomViewer^ Viewer,
   int Index
)

Parameters

Viewer
The Viewer from which the Image is drawn
Index
The specific Index of the Image in the Viewer's Images Collection

Return Value

This property may not be used for DicomLabels of type Bitmap.

The length is the length of the entire circumference of the label.

Where pixel dimensions for the whole image are present within the image data, these are used to scale the length appropriately. Multiple region calibration areas (e.g. in U/S images) are fully supported.

The units used (which for uncalibrated data may simply be pixels) is returned by ROIDistanceUnits.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members
Overload List


ROIMax Method

ROIMax Method

DicomObjects Namespace > DicomLabel Class : ROIMax Method
The image from which the pixel data is taken for the calculations
If true, then the rescale slope and offset are applied to the data values
Returns the maximum values of the pixels in the ROI
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ROIMax( _
   ByVal Image As DicomImage, _
   ByVal Scale As Boolean _
) As Double
'Usage

Dim instance As DicomLabel
Dim Image As DicomImage
Dim Scale As Boolean
Dim value As Double

value = instance.ROIMax(Image, Scale)
public double ROIMax(
   DicomImage Image,
   bool Scale
)
public:
double ROIMax(
   DicomImage^ Image,
   bool Scale
)

Parameters

Image
The image from which the pixel data is taken for the calculations
Scale
If true, then the rescale slope and offset are applied to the data values

Return Value

The maximum value
Remarks
This property, where rescale parameters are used (e.g. for CT) it is applied to the pixel values automatically before the statistical values are calculated.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


ROIMean Method

ROIMean Method

DicomObjects Namespace > DicomLabel Class : ROIMean Method
The image from which the pixel data is taken for the calculations
If true, then the rescale slope and offset are applied to the data values
Returns the mean value of the pixels in the ROI
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ROIMean( _
   ByVal Image As DicomImage, _
   ByVal Scale As Boolean _
) As Double
'Usage

Dim instance As DicomLabel
Dim Image As DicomImage
Dim Scale As Boolean
Dim value As Double

value = instance.ROIMean(Image, Scale)
public double ROIMean(
   DicomImage Image,
   bool Scale
)
public:
double ROIMean(
   DicomImage^ Image,
   bool Scale
)

Parameters

Image
The image from which the pixel data is taken for the calculations
Scale
If true, then the rescale slope and offset are applied to the data values

Return Value

The mean value of the pixels in the ROI
Remarks
This method may only be used for DicomLabels of type Rectangle, Ellipse, Polygon or Bitmap.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


ROIMin Method

ROIMin Method

DicomObjects Namespace > DicomLabel Class : ROIMin Method
The image from which the pixel data is taken for the calculations
If true, then the rescale slope and offset are applied to the data values
Returns the minimum values of the pixels in the ROI
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ROIMin( _
   ByVal Image As DicomImage, _
   ByVal Scale As Boolean _
) As Double
'Usage

Dim instance As DicomLabel
Dim Image As DicomImage
Dim Scale As Boolean
Dim value As Double

value = instance.ROIMin(Image, Scale)
public double ROIMin(
   DicomImage Image,
   bool Scale
)
public:
double ROIMin(
   DicomImage^ Image,
   bool Scale
)

Parameters

Image
The image from which the pixel data is taken for the calculations
Scale
If true, then the rescale slope and offset are applied to the data values

Return Value

The minimum value
Remarks
This property, where rescale parameters are used (e.g. for CT) it is applied to the pixel values automatically before the statistical values are calculated.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


ROIPoints Method

ROIPoints Method

DicomObjects Namespace > DicomLabel Class : ROIPoints Method
The image to which to which the label is being applied.
The list of points within the label
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ROIPoints( _
   ByVal Image As DicomImage _
) As PointF()
'Usage

Dim instance As DicomLabel
Dim Image As DicomImage
Dim value() As PointF

value = instance.ROIPoints(Image)
public PointF[] ROIPoints(
   DicomImage Image
)
public:
array<PointF>^ ROIPoints(
   DicomImage^ Image
)

Parameters

Image
The image to which to which the label is being applied.

Return Value

Array of PointF values
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


ROIStandardDeviation Method

ROIStandardDeviation Method

DicomObjects Namespace > DicomLabel Class : ROIStandardDeviation Method
The image from which the pixel data is taken for the calculations
If true, then the rescale slope and offset are applied to the data values
Returns the standard deviation of the values of the pixels in the ROI
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ROIStandardDeviation( _
   ByVal Image As DicomImage, _
   ByVal Scale As Boolean _
) As Double
'Usage

Dim instance As DicomLabel
Dim Image As DicomImage
Dim Scale As Boolean
Dim value As Double

value = instance.ROIStandardDeviation(Image, Scale)
public double ROIStandardDeviation(
   DicomImage Image,
   bool Scale
)
public:
double ROIStandardDeviation(
   DicomImage^ Image,
   bool Scale
)

Parameters

Image
The image from which the pixel data is taken for the calculations
Scale
If true, then the rescale slope and offset are applied to the data values

Return Value

The standard deviation
Remarks
ROIStandardDeviation returns the standard deviation of the values of the pixels in the ROI
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


ROIValues Method

ROIValues Method

DicomObjects Namespace > DicomLabel Class : ROIValues Method
The image from which the pixel data is taken for the calculations
If true, then the rescale slope and offset are applied to the data values
The values within a DicomLabel, interpreted as a region of interest
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ROIValues( _
   ByVal Image As DicomImage, _
   ByVal Scale As Boolean _
) As Single()
'Usage

Dim instance As DicomLabel
Dim Image As DicomImage
Dim Scale As Boolean
Dim value() As Single

value = instance.ROIValues(Image, Scale)
public float[] ROIValues(
   DicomImage Image,
   bool Scale
)
public:
array<float>^ ROIValues(
   DicomImage^ Image,
   bool Scale
)

Parameters

Image
The image from which the pixel data is taken for the calculations
Scale
If true, then the rescale slope and offset are applied to the data values

Return Value

Array of floats
Remarks

This property may only be used for DicomLabels of type Rectangle, Ellipse, Polygon or Bitmap.

Where rescale parameters are used (e.g. for CT) they are applied to the pixel values automatically before returning these values.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


ScaledAngle Method

ScaledAngle Method

DicomObjects Namespace > DicomLabel Class : ScaledAngle Method
The Image where the Label is drawn on
Returns the line angle of the DicomLabel. Image Pixel Aspect Ratio is automatically taken into account.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ScaledAngle( _
   ByVal img As DicomImage _
) As Single
'Usage

Dim instance As DicomLabel
Dim img As DicomImage
Dim value As Single

value = instance.ScaledAngle(img)
public float ScaledAngle(
   DicomImage img
)
public:
float ScaledAngle(
   DicomImage^ img
)

Parameters

img
The Image where the Label is drawn on

Return Value

The angle of the line
Remarks
The angle returned is measued counterclockwise from a line pointing to the right, and uses the range -π to +π (equivalent to -180º to +180º)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Threshold Method

Threshold Method

DicomObjects Namespace > DicomLabel Class : Threshold Method
The minimum value to include in the new DicomLabel
The maximum value to include in the new DicomLabel
The image from which the pixel data is taken for the calculations
If true, then the rescale slope and offset are applied to the data values
Makes a bitmap label by thresholding an existing label
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function Threshold( _
   ByVal Min As Single, _
   ByVal Max As Single, _
   ByVal Image As DicomImage, _
   ByVal Scale As Boolean _
) As DicomLabel
'Usage

Dim instance As DicomLabel
Dim Min As Single
Dim Max As Single
Dim Image As DicomImage
Dim Scale As Boolean
Dim value As DicomLabel

value = instance.Threshold(Min, Max, Image, Scale)
public DicomLabel Threshold(
   float Min,
   float Max,
   DicomImage Image,
   bool Scale
)
public:
DicomLabel^ Threshold(
   float Min,
   float Max,
   DicomImage^ Image,
   bool Scale
)

Parameters

Min
The minimum value to include in the new DicomLabel
Max
The maximum value to include in the new DicomLabel
Image
The image from which the pixel data is taken for the calculations
Scale
If true, then the rescale slope and offset are applied to the data values

Return Value

A new DicomLabel
Remarks

The DicomLabel to which this method is applied must be of a type which defines an area, i.e. Rectangle, Ellipse, Polygon, or Bitmap.

The result is a new label (unattached to any collection) of type Bitmap, which consists of all those points in the original label whose values (after applying scaling if necessary) fall with the range Min to Max inclusive.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Transform(Matrix) Method

Transform(Matrix) Method

DicomObjects Namespace > DicomLabel Class : Transform(Matrix) Method
The Matrix object to use to transform the label
Adjusts the position, size etc. of the label
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Transform( _
   ByVal Matrix As Matrix _
)
'Usage

Dim instance As DicomLabel
Dim Matrix As Matrix

instance.Transform(Matrix)
public void Transform(
   Matrix Matrix
)
public:
void Transform(
   Matrix^ Matrix
)

Parameters

Matrix
The Matrix object to use to transform the label

Return Value

void
Remarks
The Area and Points properties are both transformed acccording the values in the Matrix
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Update Method (DicomLabel)

Update Method (DicomLabel)

DicomObjects Namespace > DicomLabel Class : Update Method
Force display update for this label
Force display update for this label
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Update()
'Usage

Dim instance As DicomLabel

instance.Update()
public void Update()
public:
void Update();
Remarks
This method is useful when elements or properties of a DicomLabel have been altered, (e.g. the items in the Points array, as the label receives no other notification that these have changed, preventing the normal update mechanism from occurring.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


DicomLabel Class Properties

DicomLabel Class Properties

DicomObjects Namespace : DicomLabel Class

For a list of all members of this type, see DicomLabel members.

Public Properties
 | Name | Description
Public Property | Anchor | A pair of coordinates (x, y) of an visible anchor point for a text label
Public Property | AnchorScaleMode | Defines how anchor point is transformed with the image
Public Property | Angle | Angle to rotate Label (Clockwise)
Public Property | Area | The 4 edges of the rectangle area of the DicomLabel
Public Property | AutoSizeMode | Controls the size of a text label.
Public Property | BoundingBox | Area that encloses the label as displayed
Public Property | Brush | Objects used to fill the interiors of graphical shapes such as rectangles, ellipses, pies, polygons, and paths
Public Property | ChildAlignment | Specify the locations of the child labels
Public Property | ChildLabels | A DicomLabel collection linked with the primary DicomLabel. Useful for grouping labels together so you can do one operation for all of them, i.e movement.
Public Property | CircleWithPerpendicularBiSector | Draw a circle using Perpendicular Bisector from the first three user defined Points. For this to work you need to select the DicomObjects.Enums.LabelType.Ellipse and set at least three Points Default is false, which means the label will use Area property instead of user defined points
Public Property | Font | The Font to be used for text labels
Public Property | FontIndex | Specify which Font in the Fonts Collection to apply to the Current DicomLabel object.
static (Shared in Visual Basic) | Fonts | A Static Font collection. Users can define and add their list of fonts and choose which to apply to each DicomLabel object using DicomLabel's FontIndex property.
Public Property | FrameList | List of Frames you want to display the DicomLabel on. Empty FrameList is default value and it means display on all frames.
Public Property | Height | Define the height of a DicomLabel (annotation) on an image
Public Property | Image | The Image to be displayed by an Image type DicomLabel
Public Property | ImageOpacity | Controls the opacity of the Image label. Only applicable to DicomObjects.Enums.LabelType.Image. Value ranges from 0-1 (None to Full opacity)
static (Shared in Visual Basic) | ImportedLabelType | The type of label created by DicomObjects from Presentation states
Public Property | IncludeInPresentationState | This property controls whether the DicomLabel goes into the PresentationState or not when one of the CurrentToPresentationState methods is used.
Public Property | IsInterpolated | Specify if the DicomLabel is Interpolated
Public Property | IsShutter | This property decides whether or not the DicomLabel will be acting as a Shutter.
Public Property | LabelType | Determines the basic type of a label
Public Property | Left | Define the left of a DicomLabel (annotation) on an image
Public Property | Margin | Defines a margin between text and it’s bounding box
Public Property | MinArrowSize | Specify the minimum Arrow size when the labeltype is set to LabelArrow
Public Property | Pen | Object used to draw lines and curves
Public Property | Plane | The plane on which this label will be displayed when used on a 3D image
Public Property | Points | The points of a DicomLabel (of type PolyLine or Polygon)
Public Property | RefImage | The image whose plane is used to control the placement of this image, as a line.
Public Property | Reversible | Controls whether the label is drawn in reversible mode
Public Property | RotationCentre | Controls the centre of rotation of a text label.
Public Property | RotationMode | Controls the rotation behaviour of a label.
Public Property | RotationPoint | Defines the centre point used for label rotation (whether due to Angle or as a result of RotationMode) if the RotationCentre is set to SpecifiedPoint
Public Property | RulerOptions | Ruler options used if LabelType is set to Ruler
Public Property | RulerSpacing | Controls the approximate spacing of the minor ticks for a ruler label
Public Property | ScaleFontSize | Determines whether the font size scales with the image
Public Property | ScaleMode | Defines a basic scale mode of DicomLabel
Public Property | ScalePenWidth | Control whether the width of a line scales with the label being drawn
Public Property | SelectMode | Controls whether a label is highlighted using a box and/or “handles”
Public Property | SelectPen | Select Pen from Pen
Public Property | Shadow | Controls whether a label is displayed with a contrasting shadow, to make it more visible over image areas with the same colour.
Public Property | ShadowColor | Contains the colour of the Shadow applied to the DicomLabel
Public Property | ShowAnchor | Determines whether the anchor point is shown
Public Property | ShowTextBox | Controls whether text boxes have a visible border
Public Property | StringFormat | Handles text alignment using the .NET StringFormat Member
Public Property | Tag | A general purpose Tag for developer use
Public Property | Text | The text to be displayed by a text type DicomLabel
Public Property | TextBrush | The brush object only for labels of type "doLabelText"
Public Property | TextLabelRendering | Control text label anti-aliasing behaviour
Public Property | Top | Define the top of a DicomLabel (annotation) on an image
Public Property | Visible | Controls whether a DicomLabel object is displayed
Public Property | Width | Define the width of a DicomLabel (annotation) on an image
Top
See Also

Reference

DicomLabel Class
DicomObjects Namespace


Anchor Property

Anchor Property

DicomObjects Namespace > DicomLabel Class : Anchor Property
A pair of coordinates (x, y) of an visible anchor point for a text label
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Anchor As PointF
'Usage

Dim instance As DicomLabel
Dim value As PointF

instance.Anchor = value

value = instance.Anchor
public PointF Anchor {get; set;}
public:
property PointF Anchor {
   PointF get();
   void set (    PointF value);
}
Remarks

Anchor comprises the x and y coordinates, which are now floating numbers in .NET version, and only applies to text labels.

If ShowAnchor is true, then a line is drawn from the border of the text label to a point in the image indicated by these coordinates.

If AnchorScaleMode is set to Image, then the anchor point is transformed with the image exactly the same way that the label itself is if ScaleMode is set to Image.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


AnchorScaleMode Property

AnchorScaleMode Property

DicomObjects Namespace > DicomLabel Class : AnchorScaleMode Property
Defines how anchor point is transformed with the image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AnchorScaleMode As ScaleMode
'Usage

Dim instance As DicomLabel
Dim value As ScaleMode

instance.AnchorScaleMode = value

value = instance.AnchorScaleMode
public ScaleMode AnchorScaleMode {get; set;}
public:
property ScaleMode AnchorScaleMode {
   ScaleMode get();
   void set (    ScaleMode value);
}
Remarks

Check LabelScaleMode for possible values of AnchorScaleMode.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Angle Property (DicomLabel)

Angle Property (DicomLabel)

DicomObjects Namespace > DicomLabel Class : Angle Property
Angle to rotate Label (Clockwise)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Angle As Single
'Usage

Dim instance As DicomLabel
Dim value As Single

instance.Angle = value

value = instance.Angle
public float Angle {get; set;}
public:
property float Angle {
   float get();
   void set (    float value);
}
Remarks

The label is rotated around its centre after any transformations due to ImageTied have been applied.

This property only applies to labels of type rectangle, ellipse and text

If RotateTextWithImage is true, and the label is of type text, then:

  • For display, this angle is added to the rotation of the image.
  • This angle is modified when Rescale is called, so as to preserve the relationship between the text and the image
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Area Property (DicomLabel)

Area Property (DicomLabel)

DicomObjects Namespace > DicomLabel Class : Area Property
The 4 edges of the rectangle area of the DicomLabel
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Area As RectangleF
'Usage

Dim instance As DicomLabel
Dim value As RectangleF

instance.Area = value

value = instance.Area
public RectangleF Area {get; set;}
public:
property RectangleF Area {
   RectangleF get();
   void set (    RectangleF value);
}
Remarks
Coordinates of the corner points are returned as Floating numbers.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


AutoSizeMode Property

AutoSizeMode Property

DicomObjects Namespace > DicomLabel Class : AutoSizeMode Property
Controls the size of a text label.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AutoSizeMode As AutoSizeMode
'Usage

Dim instance As DicomLabel
Dim value As AutoSizeMode

instance.AutoSizeMode = value

value = instance.AutoSizeMode
public AutoSizeMode AutoSizeMode {get; set;}
public:
property AutoSizeMode AutoSizeMode {
   AutoSizeMode get();
   void set (    AutoSizeMode value);
}
Remarks
This is used to control both the drawing of a visible box around the text if ShowTextBox is true, and also used to control the positioning of child labels. It is also used for rotation if RotationCentre is AutoSizeCentre
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


BoundingBox Property

BoundingBox Property

DicomObjects Namespace > DicomLabel Class : BoundingBox Property
Area that encloses the label as displayed
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property BoundingBox As RectangleF
'Usage

Dim instance As DicomLabel
Dim value As RectangleF

value = instance.BoundingBox
public RectangleF BoundingBox {get;}
public:
property RectangleF BoundingBox {
   RectangleF get();
}
Remarks
For labels of type Polygon and PolyLine this return the bounding box of the Points collection, but for other labels, it returns the same as Area
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Brush Property

Brush Property

DicomObjects Namespace > DicomLabel Class : Brush Property
Objects used to fill the interiors of graphical shapes such as rectangles, ellipses, pies, polygons, and paths
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Brush As Brush
'Usage

Dim instance As DicomLabel
Dim value As Brush

instance.Brush = value

value = instance.Brush
public Brush Brush {get; set;}
public:
property Brush^ Brush {
   Brush^ get();
   void set (    Brush^ value);
}
Remarks
The default brush is SolidBrush(Transparent).
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


ChildAlignment Property

ChildAlignment Property

DicomObjects Namespace > DicomLabel Class : ChildAlignment Property
Specify the locations of the child labels
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ChildAlignment As ContentAlignment
'Usage

Dim instance As DicomLabel
Dim value As ContentAlignment

instance.ChildAlignment = value

value = instance.ChildAlignment
public ContentAlignment ChildAlignment {get; set;}
public:
property ContentAlignment ChildAlignment {
   ContentAlignment get();
   void set (    ContentAlignment value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


ChildLabels Property

ChildLabels Property

DicomObjects Namespace > DicomLabel Class : ChildLabels Property
A DicomLabel collection linked with the primary DicomLabel. Useful for grouping labels together so you can do one operation for all of them, i.e movement.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ChildLabels As DicomLabelCollection
'Usage

Dim instance As DicomLabel
Dim value As DicomLabelCollection

instance.ChildLabels = value

value = instance.ChildLabels
public DicomLabelCollection ChildLabels {get; set;}
public:
property DicomLabelCollection^ ChildLabels {
   DicomLabelCollection^ get();
   void set (    DicomLabelCollection^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


CircleWithPerpendicularBiSector Property

CircleWithPerpendicularBiSector Property

DicomObjects Namespace > DicomLabel Class : CircleWithPerpendicularBiSector Property
Draw a circle using Perpendicular Bisector from the first three user defined Points. For this to work you need to select the DicomObjects.Enums.LabelType.Ellipse and set at least three Points Default is false, which means the label will use Area property instead of user defined points
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CircleWithPerpendicularBiSector As Boolean
'Usage

Dim instance As DicomLabel
Dim value As Boolean

instance.CircleWithPerpendicularBiSector = value

value = instance.CircleWithPerpendicularBiSector
public bool CircleWithPerpendicularBiSector {get; set;}
public:
property bool CircleWithPerpendicularBiSector {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Font Property

Font Property

DicomObjects Namespace > DicomLabel Class : Font Property
The Font to be used for text labels
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Font As Font
'Usage

Dim instance As DicomLabel
Dim value As Font

instance.Font = value

value = instance.Font
public Font Font {get; set;}
public:
property Font^ Font {
   Font^ get();
   void set (    Font^ value);
}
Remarks

This property is only relevant where LabelType is doLabelText or doLabelSpecial.

Use Font.Name and Font.Size to change the font properties.

The default font name is System.Font and default size is 12.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


FontIndex Property

FontIndex Property

DicomObjects Namespace > DicomLabel Class : FontIndex Property
Specify which Font in the Fonts Collection to apply to the Current DicomLabel object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FontIndex As Integer
'Usage

Dim instance As DicomLabel
Dim value As Integer

instance.FontIndex = value

value = instance.FontIndex
public int FontIndex {get; set;}
public:
property int FontIndex {
   int get();
   void set (    int value);
}
Remarks
The default value for this property is -1, which means none of the fonts in Fonts will be applied to the current DicomLabel, and instead the font in the Font property will be used. If is set a value between 0 and Fonts.Count - 1, the indexed Font from the Fonts collection will be used instead.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Fonts Property

Fonts Property

DicomObjects Namespace > DicomLabel Class : Fonts Property
A Static Font collection. Users can define and add their list of fonts and choose which to apply to each DicomLabel object using DicomLabel's FontIndex property.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property Fonts As List(Of Font)
'Usage

Dim value As List(Of Font)

DicomLabel.Fonts = value

value = DicomLabel.Fonts
public static List<Font> Fonts {get; set;}
public:
static property List<Font^>^ Fonts {
   List<Font^>^ get();
   void set (    List<Font^>^ value);
}
Remarks
No Font is in this collection by default. User have to add the font(s) to it before its item can be later indexed by FontIndex property. This collection provides a method for the fonts of many labels to be changed at once.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


FrameList Property

FrameList Property

DicomObjects Namespace > DicomLabel Class : FrameList Property
List of Frames you want to display the DicomLabel on. Empty FrameList is default value and it means display on all frames.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property FrameList As List(Of Integer)
'Usage

Dim instance As DicomLabel
Dim value As List(Of Integer)

value = instance.FrameList
public List<int> FrameList {get;}
public:
property List<int>^ FrameList {
   List<int>^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Height Property

Height Property

DicomObjects Namespace > DicomLabel Class : Height Property
Define the height of a DicomLabel (annotation) on an image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Height As Single
'Usage

Dim instance As DicomLabel
Dim value As Single

instance.Height = value

value = instance.Height
public float Height {get; set;}
public:
property float Height {
   float get();
   void set (    float value);
}
Remarks
Equivalent to Area.Height. Remained in .NET version for backward compatibility.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Image Property (DicomLabel)

Image Property (DicomLabel)

DicomObjects Namespace > DicomLabel Class : Image Property
The Image to be displayed by an Image type DicomLabel
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Image As Image
'Usage

Dim instance As DicomLabel
Dim value As Image

instance.Image = value

value = instance.Image
public Image Image {get; set;}
public:
property Image^ Image {
   Image^ get();
   void set (    Image^ value);
}
Remarks

This property is only relevant where LabelType is Image

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


ImageOpacity Property

ImageOpacity Property

DicomObjects Namespace > DicomLabel Class : ImageOpacity Property
Controls the opacity of the Image label. Only applicable to DicomObjects.Enums.LabelType.Image.

Value ranges from 0-1 (None to Full opacity)

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ImageOpacity As Single
'Usage

Dim instance As DicomLabel
Dim value As Single

instance.ImageOpacity = value

value = instance.ImageOpacity
public float ImageOpacity {get; set;}
public:
property float ImageOpacity {
   float get();
   void set (    float value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


ImportedLabelType Property

ImportedLabelType Property

DicomObjects Namespace > DicomLabel Class : ImportedLabelType Property
The type of label created by DicomObjects from Presentation states
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property ImportedLabelType As Type
'Usage

Dim value As Type

DicomLabel.ImportedLabelType = value

value = DicomLabel.ImportedLabelType
public static Type ImportedLabelType {get; set;}
public:
static property Type^ ImportedLabelType {
   Type^ get();
   void set (    Type^ value);
}
Remarks
DicomObjects converts the graphic and text objects in a presentation state to DicomLabel or derived objects either temporarily (when displaying) or permanently when calling PresentationStateToCurrent. In order to allow custom values, under user control, the OnImport
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


IncludeInPresentationState Property

IncludeInPresentationState Property

DicomObjects Namespace > DicomLabel Class : IncludeInPresentationState Property
This property controls whether the DicomLabel goes into the PresentationState or not when one of the CurrentToPresentationState methods is used.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property IncludeInPresentationState As Boolean
'Usage

Dim instance As DicomLabel
Dim value As Boolean

instance.IncludeInPresentationState = value

value = instance.IncludeInPresentationState
public bool IncludeInPresentationState {get; set;}
public:
property bool IncludeInPresentationState {
   bool get();
   void set (    bool value);
}
Remarks
Default value is True. Set the value to false to stop the DicomLabel from being included in the PresentationState.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


IsInterpolated Property

IsInterpolated Property

DicomObjects Namespace > DicomLabel Class : IsInterpolated Property
Specify if the DicomLabel is Interpolated
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property IsInterpolated As Boolean
'Usage

Dim instance As DicomLabel
Dim value As Boolean

instance.IsInterpolated = value

value = instance.IsInterpolated
public bool IsInterpolated {get; set;}
public:
property bool IsInterpolated {
   bool get();
   void set (    bool value);
}
Remarks
Curving/Smoothing will be appleid if this property is set to true. This only applies to Label of type Polyline and Polygon.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


IsShutter Property

IsShutter Property

DicomObjects Namespace > DicomLabel Class : IsShutter Property
This property decides whether or not the DicomLabel will be acting as a Shutter.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property IsShutter As Boolean
'Usage

Dim instance As DicomLabel
Dim value As Boolean

instance.IsShutter = value

value = instance.IsShutter
public bool IsShutter {get; set;}
public:
property bool IsShutter {
   bool get();
   void set (    bool value);
}
Remarks
Label must be polygonal to be a shutter. Brush property must be assigned in order to make the shutter effect visible. If set to true, the outside area will be filled with the color specified by Brush property.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


LabelType Property

LabelType Property

DicomObjects Namespace > DicomLabel Class : LabelType Property
Determines the basic type of a label
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LabelType As LabelType
'Usage

Dim instance As DicomLabel
Dim value As LabelType

instance.LabelType = value

value = instance.LabelType
public LabelType LabelType {get; set;}
public:
property LabelType LabelType {
   LabelType get();
   void set (    LabelType value);
}
Remarks

Possible values for LabelType

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Left Property

Left Property

DicomObjects Namespace > DicomLabel Class : Left Property
Define the left of a DicomLabel (annotation) on an image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Left As Single
'Usage

Dim instance As DicomLabel
Dim value As Single

instance.Left = value

value = instance.Left
public float Left {get; set;}
public:
property float Left {
   float get();
   void set (    float value);
}
Remarks
Equivalent to Area.Left. Remains in .NET version for backward compatibility.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Margin Property

Margin Property

DicomObjects Namespace > DicomLabel Class : Margin Property
Defines a margin between text and it’s bounding box
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Margin As Integer
'Usage

Dim instance As DicomLabel
Dim value As Integer

instance.Margin = value

value = instance.Margin
public int Margin {get; set;}
public:
property int Margin {
   int get();
   void set (    int value);
}
Remarks
The bounding rectangle defined by Height and Width is reduced by this size on all four sides before text is drawn, leaving a clear margin around the text. If the AutoSizeMode property causes the size to be reduced, then the calculated box is automatically expanded to accommodate this margin.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


MinArrowSize Property

MinArrowSize Property

DicomObjects Namespace > DicomLabel Class : MinArrowSize Property
Specify the minimum Arrow size when the labeltype is set to LabelArrow
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MinArrowSize As Integer
'Usage

Dim instance As DicomLabel
Dim value As Integer

instance.MinArrowSize = value

value = instance.MinArrowSize
public int MinArrowSize {get; set;}
public:
property int MinArrowSize {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Pen Property

Pen Property

DicomObjects Namespace > DicomLabel Class : Pen Property
Object used to draw lines and curves
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Pen As Pen
'Usage

Dim instance As DicomLabel
Dim value As Pen

instance.Pen = value

value = instance.Pen
public Pen Pen {get; set;}
public:
property Pen^ Pen {
   Pen^ get();
   void set (    Pen^ value);
}
Remarks
Default pen is Pen(White).
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Plane Property

Plane Property

DicomObjects Namespace > DicomLabel Class : Plane Property
The plane on which this label will be displayed when used on a 3D image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Plane As Plane3D
'Usage

Dim instance As DicomLabel
Dim value As Plane3D

instance.Plane = value

value = instance.Plane
public Plane3D Plane {get; set;}
public:
property Plane3D Plane {
   Plane3D get();
   void set (    Plane3D value);
}
Remarks
To ensure that labels are only shown where appropriate, use of Rescale on a label o a 3D image records the plane displayed when the rescale was performed, and the label is only displayed when the image is displayed in the same plane (though it could be rotated and scaled without preventing display - in this case the label will be rotated and scaled by the same amount).
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Points Property

Points Property

DicomObjects Namespace > DicomLabel Class : Points Property
The points of a DicomLabel (of type PolyLine or Polygon)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Points As PointF()
'Usage

Dim instance As DicomLabel
Dim value() As PointF

instance.Points = value

value = instance.Points
public PointF[] Points {get; set;}
public:
property array<PointF>^ Points {
   array<PointF>^ get();
   void set (    array<PointF>^ value);
}
Remarks

This is a single-dimension array, but interpreted as pairs of values (x and y).

The values may be updated either by direct assignment to this property, or as in earlier versions of DicomObjects, the AddPoint:o method may be used to add a point to the end of the array.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


RefImage Property

RefImage Property

DicomObjects Namespace > DicomLabel Class : RefImage Property
The image whose plane is used to control the placement of this image, as a line.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RefImage As DicomImage
'Usage

Dim instance As DicomLabel
Dim value As DicomImage

instance.RefImage = value

value = instance.RefImage
public DicomImage RefImage {get; set;}
public:
property DicomImage^ RefImage {
   DicomImage^ get();
   void set (    DicomImage^ value);
}
Remarks
Unlike lines generated using the DicomImage.ReferenceLine method, this line is fully dynamic, and updates automatically if the plane displayed by the referenced image is changed.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Reversible Property

Reversible Property

DicomObjects Namespace > DicomLabel Class : Reversible Property
Controls whether the label is drawn in reversible mode
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Reversible As Boolean
'Usage

Dim instance As DicomLabel
Dim value As Boolean

instance.Reversible = value

value = instance.Reversible
public bool Reversible {get; set;}
public:
property bool Reversible {
   bool get();
   void set (    bool value);
}
Remarks
This is roughly equivalent to XOR in the COM version but is limited, as the .NET GDI+ API lacks the previous standard WIndows API functionality to do XOR drawing. Only lines, rectangles, ploygons, polylines and ellipses are currently supported
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


RotationCentre Property

RotationCentre Property

DicomObjects Namespace > DicomLabel Class : RotationCentre Property
Controls the centre of rotation of a text label.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RotationCentre As RotationCentre
'Usage

Dim instance As DicomLabel
Dim value As RotationCentre

instance.RotationCentre = value

value = instance.RotationCentre
public RotationCentre RotationCentre {get; set;}
public:
property RotationCentre RotationCentre {
   RotationCentre get();
   void set (    RotationCentre value);
}
Remarks
This properrty is used for 2 purposes:
  • When an explicit rotation is applied to a label
  • When an image is rotated, but the label is not rotated due to the setting of the RotationMode which therefore requires that the label be rotated relative to the image.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


RotationMode Property

RotationMode Property

DicomObjects Namespace > DicomLabel Class : RotationMode Property
Controls the rotation behaviour of a label.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RotationMode As RotationMode
'Usage

Dim instance As DicomLabel
Dim value As RotationMode

instance.RotationMode = value

value = instance.RotationMode
public RotationMode RotationMode {get; set;}
public:
property RotationMode RotationMode {
   RotationMode get();
   void set (    RotationMode value);
}
Remarks

If a DicomImage is rotated (either by use of an explicit Angle, or by use of RotateState, and if the ScaleMode is Image then this property controls whether the label rotates with the underlying image, or whether its base rotation remains upright.

In either case, the label may still be rotated, relative to that base rotation using the label's Angle property

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


RotationPoint Property

RotationPoint Property

DicomObjects Namespace > DicomLabel Class : RotationPoint Property
Defines the centre point used for label rotation (whether due to Angle or as a result of RotationMode) if the RotationCentre is set to SpecifiedPoint
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RotationPoint As PointF
'Usage

Dim instance As DicomLabel
Dim value As PointF

instance.RotationPoint = value

value = instance.RotationPoint
public PointF RotationPoint {get; set;}
public:
property PointF RotationPoint {
   PointF get();
   void set (    PointF value);
}
Remarks
The point is defined using the same coordinates as Area or Points, which depend on the value of ScaleMode
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


RulerOptions Property

RulerOptions Property

DicomObjects Namespace > DicomLabel Class : RulerOptions Property
Ruler options used if LabelType is set to Ruler
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RulerOptions As RulerOptions
'Usage

Dim instance As DicomLabel
Dim value As RulerOptions

instance.RulerOptions = value

value = instance.RulerOptions
public RulerOptions RulerOptions {get; set;}
public:
property RulerOptions RulerOptions {
   RulerOptions get();
   void set (    RulerOptions value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


RulerSpacing Property

RulerSpacing Property

DicomObjects Namespace > DicomLabel Class : RulerSpacing Property
Controls the approximate spacing of the minor ticks for a ruler label
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RulerSpacing As Integer
'Usage

Dim instance As DicomLabel
Dim value As Integer

instance.RulerSpacing = value

value = instance.RulerSpacing
public int RulerSpacing {get; set;}
public:
property int RulerSpacing {
   int get();
   void set (    int value);
}
Remarks

This value is measured in screen/output pixels. When drawing a ruler, DicomObjects first calculates the distance (in mm) corresponding to this number of output pixels. It then rounds it up to the next significant figure (1, 2 or 5 times a power of 10) and uses that as the minor tick spacing.

The default value is 20

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


ScaleFontSize Property

ScaleFontSize Property

DicomObjects Namespace > DicomLabel Class : ScaleFontSize Property
Determines whether the font size scales with the image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ScaleFontSize As Boolean
'Usage

Dim instance As DicomLabel
Dim value As Boolean

instance.ScaleFontSize = value

value = instance.ScaleFontSize
public bool ScaleFontSize {get; set;}
public:
property bool ScaleFontSize {
   bool get();
   void set (    bool value);
}
Remarks
When this property is true (the default case, as used in previous versions of DicomObjects), then when ScaleMode is set to Image, the font size of a text label scales with the zoom of the image. Otherwise, the font size remains constant.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


ScaleMode Property

ScaleMode Property

DicomObjects Namespace > DicomLabel Class : ScaleMode Property
Defines a basic scale mode of DicomLabel
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ScaleMode As ScaleMode
'Usage

Dim instance As DicomLabel
Dim value As ScaleMode

instance.ScaleMode = value

value = instance.ScaleMode
public ScaleMode ScaleMode {get; set;}
public:
property ScaleMode ScaleMode {
   ScaleMode get();
   void set (    ScaleMode value);
}
Remarks

Check the ScaleMode for the possible values.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


ScalePenWidth Property

ScalePenWidth Property

DicomObjects Namespace > DicomLabel Class : ScalePenWidth Property
Control whether the width of a line scales with the label being drawn
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ScalePenWidth As Boolean
'Usage

Dim instance As DicomLabel
Dim value As Boolean

instance.ScalePenWidth = value

value = instance.ScalePenWidth
public bool ScalePenWidth {get; set;}
public:
property bool ScalePenWidth {
   bool get();
   void set (    bool value);
}
Remarks
Default value is false
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


SelectMode Property

SelectMode Property

DicomObjects Namespace > DicomLabel Class : SelectMode Property
Controls whether a label is highlighted using a box and/or “handles”
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SelectMode As SelectMode
'Usage

Dim instance As DicomLabel
Dim value As SelectMode

instance.SelectMode = value

value = instance.SelectMode
public SelectMode SelectMode {get; set;}
public:
property SelectMode SelectMode {
   SelectMode get();
   void set (    SelectMode value);
}
Remarks

The allowable values are:

  • None 0 No Highlighting
  • Box 1 A bounding box is drawn around the label
  • BoxHangles 2 Handles are drawn at the corners of the above box
  • AllHandles 4 Handles are drawn at all relevant 'points' (This only applies to labels of type dolabelPolygon, doLabelPolyline & doLabelArc)

Although defined as enumerated types, the values above can be (and normally are) used as bit fields, so the value doSelectBox + doSelectBoxHandles gives a bounding box with visible corners.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


SelectPen Property

SelectPen Property

DicomObjects Namespace > DicomLabel Class : SelectPen Property
Select Pen from Pen
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SelectPen As Pen
'Usage

Dim instance As DicomLabel
Dim value As Pen

instance.SelectPen = value

value = instance.SelectPen
public Pen SelectPen {get; set;}
public:
property Pen^ SelectPen {
   Pen^ get();
   void set (    Pen^ value);
}
Remarks
Default SelectPen is Pen(Red).
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Shadow Property

Shadow Property

DicomObjects Namespace > DicomLabel Class : Shadow Property
Controls whether a label is displayed with a contrasting shadow, to make it more visible over image areas with the same colour.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Shadow As Short
'Usage

Dim instance As DicomLabel
Dim value As Short

instance.Shadow = value

value = instance.Shadow
public short Shadow {get; set;}
public:
property short Shadow {
   short get();
   void set (    short value);
}
Remarks

The allowable values are:

  • doShadowNone =0
  • doShadowTopLeft =1
  • doShadowTop =2
  • doShadowTopRight =4
  • doShadowRight =8
  • doShadowBottomRight =16
  • doShadowBottom =32
  • doShadowBottomLeft =64
  • doShadowLeft =128
  • doShadowAll =255

Although defined as enumerated types, the values above can be (and normally are) combined and used as bit fields

The shadow is drawn in the direction(s) indicated above displaced by one pixel from the main label, and it is drawn using the label’s BackColour colour.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


ShadowColor Property

ShadowColor Property

DicomObjects Namespace > DicomLabel Class : ShadowColor Property
Contains the colour of the Shadow applied to the DicomLabel
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ShadowColor As Color
'Usage

Dim instance As DicomLabel
Dim value As Color

instance.ShadowColor = value

value = instance.ShadowColor
public Color ShadowColor {get; set;}
public:
property Color ShadowColor {
   Color get();
   void set (    Color value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


ShowAnchor Property

ShowAnchor Property

DicomObjects Namespace > DicomLabel Class : ShowAnchor Property
Determines whether the anchor point is shown
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ShowAnchor As Boolean
'Usage

Dim instance As DicomLabel
Dim value As Boolean

instance.ShowAnchor = value

value = instance.ShowAnchor
public bool ShowAnchor {get; set;}
public:
property bool ShowAnchor {
   bool get();
   void set (    bool value);
}
Remarks

If the label is a text label, and this property is true, then a line is drawn from the border of the text label to a point in the image indicated by the X and Y co-ordinates of the anchor.

If AnchorScaleMode is set to Image, then the anchor point is transformed with the image exactly the same way that the label itself is if ScaleMode is set to Image.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


ShowTextBox Property

ShowTextBox Property

DicomObjects Namespace > DicomLabel Class : ShowTextBox Property
Controls whether text boxes have a visible border
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ShowTextBox As Boolean
'Usage

Dim instance As DicomLabel
Dim value As Boolean

instance.ShowTextBox = value

value = instance.ShowTextBox
public bool ShowTextBox {get; set;}
public:
property bool ShowTextBox {
   bool get();
   void set (    bool value);
}
Remarks
If true, then the area occupied by a text label is outlined.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


StringFormat Property

StringFormat Property

DicomObjects Namespace > DicomLabel Class : StringFormat Property
Handles text alignment using the .NET StringFormat Member
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property StringFormat As StringFormat
'Usage

Dim instance As DicomLabel
Dim value As StringFormat

instance.StringFormat = value

value = instance.StringFormat
public StringFormat StringFormat {get; set;}
public:
property StringFormat^ StringFormat {
   StringFormat^ get();
   void set (    StringFormat^ value);
}
Remarks
NEW - Handles text alignment using the .NET StringFormat class
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Tag Property (DicomLabel)

Tag Property (DicomLabel)

DicomObjects Namespace > DicomLabel Class : Tag Property
A general purpose Tag for developer use
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Tag As Object
'Usage

Dim instance As DicomLabel
Dim value As Object

instance.Tag = value

value = instance.Tag
public object Tag {get; set;}
public:
property Object^ Tag {
   Object^ get();
   void set (    Object^ value);
}
Remarks
This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Text Property (DicomLabel)

Text Property (DicomLabel)

DicomObjects Namespace > DicomLabel Class : Text Property
The text to be displayed by a text type DicomLabel
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Text As String
'Usage

Dim instance As DicomLabel
Dim value As String

instance.Text = value

value = instance.Text
public string Text {get; set;}
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}
Remarks

This property is only relevant where LabelType is Text, Special or Formatted.

The StringFormat, ScaleFontSize, ShowAnchor and Anchor properties are important also for this case.

If ShowTextBox is true, then the text is surrounded by a rectangular box, drawn in the foreground colour.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


TextBrush Property

TextBrush Property

DicomObjects Namespace > DicomLabel Class : TextBrush Property
The brush object only for labels of type "doLabelText"
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TextBrush As Brush
'Usage

Dim instance As DicomLabel
Dim value As Brush

instance.TextBrush = value

value = instance.TextBrush
public Brush TextBrush {get; set;}
public:
property Brush^ TextBrush {
   Brush^ get();
   void set (    Brush^ value);
}
Remarks
The default color for TextBrush is White, if ShowUpdate is set true, changes made to TextBrush, as to any other properties of the label object will cause an immediate image update.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


TextLabelRendering Property

TextLabelRendering Property

DicomObjects Namespace > DicomLabel Class : TextLabelRendering Property
Control text label anti-aliasing behaviour
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TextLabelRendering As TextRenderingHint
'Usage

Dim instance As DicomLabel
Dim value As TextRenderingHint

instance.TextLabelRendering = value

value = instance.TextLabelRendering
public TextRenderingHint TextLabelRendering {get; set;}
public:
property TextRenderingHint TextLabelRendering {
   TextRenderingHint get();
   void set (    TextRenderingHint value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Top Property

Top Property

DicomObjects Namespace > DicomLabel Class : Top Property
Define the top of a DicomLabel (annotation) on an image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Top As Single
'Usage

Dim instance As DicomLabel
Dim value As Single

instance.Top = value

value = instance.Top
public float Top {get; set;}
public:
property float Top {
   float get();
   void set (    float value);
}
Remarks
Equivalent to Area.Top. Remains in .NET version for backward compatibility.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Visible Property

Visible Property

DicomObjects Namespace > DicomLabel Class : Visible Property
Controls whether a DicomLabel object is displayed
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Visible As Boolean
'Usage

Dim instance As DicomLabel
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public bool Visible {get; set;}
public:
property bool Visible {
   bool get();
   void set (    bool value);
}
Remarks
A label is only displayed if this property is true, and if the ShowLabels property of the associated image is also true.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Width Property (DicomLabel)

Width Property (DicomLabel)

DicomObjects Namespace > DicomLabel Class : Width Property
Define the width of a DicomLabel (annotation) on an image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Width As Single
'Usage

Dim instance As DicomLabel
Dim value As Single

instance.Width = value

value = instance.Width
public float Width {get; set;}
public:
property float Width {
   float get();
   void set (    float value);
}
Remarks
Equivalent to Area.Width. Remains in .NET version for backward compatibility.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


DicomLabel Class Events

DicomLabel Class Events

DicomObjects Namespace : DicomLabel Class

For a list of all members of this type, see DicomLabel members.

Public Events
 | Name | Description
Public Event | LabelChanged | Event fired when the properties of a label are changed.
Public Event | PSLabelCreated | Event fires when a new DicomLabel is created when a Presentation State is applied to an image. This event gives users a chance to customise the label before display
Top
See Also

Reference

DicomLabel Class
DicomObjects Namespace


LabelChanged Event

LabelChanged Event

DicomObjects Namespace > DicomLabel Class : LabelChanged Event
Event fired when the properties of a label are changed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event LabelChanged As LabelChangedHandler
'Usage

Dim instance As DicomLabel
Dim handler As LabelChangedHandler

AddHandler instance.LabelChanged, handler
public event LabelChangedHandler LabelChanged
public:
event LabelChangedHandler^ LabelChanged
Remarks

Note that this Event is only fired when a complete property changes e.g.

label.Area = new RectangleF(0,0,10,20);

It is not fired when a property of a property changes - e.g.

label.Area.Left = 20;
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


PSLabelCreated Event

PSLabelCreated Event

DicomObjects Namespace > DicomLabel Class : PSLabelCreated Event
Event fires when a new DicomLabel is created when a Presentation State is applied to an image. This event gives users a chance to customise the label before display
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event PSLabelCreated As PSLabelCreatedHandler
'Usage

Dim instance As DicomLabel
Dim handler As PSLabelCreatedHandler

AddHandler instance.PSLabelCreated, handler
public event PSLabelCreatedHandler PSLabelCreated
public:
event PSLabelCreatedHandler^ PSLabelCreated
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


DicomLabel3D Class

DicomLabel3D Class
Members

DicomObjects Namespace : DicomLabel3D Class
Class to represent a 3D orientation label superimposed on a 3D image.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomLabel3D
'Usage

Dim instance As DicomLabel3D
public class DicomLabel3D
public ref class DicomLabel3D
Remarks
To use this label, add to a DicomImage3D's Labels3D collection.
Inheritance Hierarchy

System.Object
DicomObjects.DicomLabel3D

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel3D Members
DicomObjects Namespace


DicomLabel3D Class Members

DicomLabel3D Class Members
Properties Methods

DicomObjects Namespace : DicomLabel3D Class

The following tables list the members exposed by DicomLabel3D.

Public Constructors
 | Name | Description
Public Constructor | DicomLabel3D Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Position | The Position of the label in the output space (0 to 1) - default is 0.9, 0.9 - lower right corner.
Public Property | Size | The size of the label relative the smaller of the image's displayed dimensions - default = 0.1
Top
Public Methods
 | Name | Description
Public Method | Dispose | Standard Dispose
Top
See Also

Reference

DicomLabel3D Class
DicomObjects Namespace


DicomLabel3D Constructor

DicomLabel3D Constructor

DicomObjects Namespace > DicomLabel3D Class : DicomLabel3D Constructor
Overload List
Overload | Description
DicomLabel3D Constructor(DicomImageCollection) | Create a "cube" with user provided images on the 6 sides.
DicomLabel3D Constructor(String) | Create a DicomLabel from a Wavefront "obj" file, using a default orientation for OBJ files
DicomLabel3D Constructor(String,Matrix) | Create a DicomLabel from a Wavefront "obj" file with explicit orientation
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel3D Class
DicomLabel3D Members


DicomLabel3D Constructor(DicomImageCollection)

DicomLabel3D Constructor(DicomImageCollection)

DicomObjects Namespace > DicomLabel3D Class > DicomLabel3D Constructor : DicomLabel3D Constructor(DicomImageCollection)
A set of 6 images
Create a "cube" with user provided images on the 6 sides.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal Images As DicomImageCollection _
)
'Usage

Dim Images As DicomImageCollection

Dim instance As New DicomLabel3D(Images)
public DicomLabel3D(
   DicomImageCollection Images
)
public:
DicomLabel3D(
   DicomImageCollection^ Images
)

Parameters

Images
A set of 6 images
Remarks

The collection shows one image per side and is conventionally presented according to normally expected anatomical orientations.

The 6 images must be in the following order:

  • Left
  • Right
  • Posterior (back)
  • Anterior (front)
  • Superior (head)
  • Inferior (feet)

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel3D Class
DicomLabel3D Members
Overload List


DicomLabel3D Constructor(String)

DicomLabel3D Constructor(String)

DicomObjects Namespace > DicomLabel3D Class > DicomLabel3D Constructor : DicomLabel3D Constructor(String)
Create a DicomLabel from a Wavefront "obj" file, using a default orientation for OBJ files
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal ObjFileName As String _
)
'Usage

Dim ObjFileName As String

Dim instance As New DicomLabel3D(ObjFileName)
public DicomLabel3D(
   string ObjFileName
)
public:
DicomLabel3D(
   String^ ObjFileName
)

Parameters

ObjFileName
Remarks

Although this constructor points to an individual file, the associated material and texture files must also be present in the same directory, and they will be accessed automatically.

DICOM uses a strict convention for the axes: +X=Left, +Y=Back and +Z=Head. Whilst the convention for OBJ files is not well defined, most models assume +X=Left, +Y=Head and +Z=front, so this method supplies a default 90 dgree rotation about the X axis to bring them into alignment.

The OBJ file implmentation uses vertices, normals and colour or textures to render the images but a few advanced aspects such as specular maps or transparency are not supported.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel3D Class
DicomLabel3D Members
Overload List


DicomLabel3D Constructor(String,Matrix)

DicomLabel3D Constructor(String,Matrix)

DicomObjects Namespace > DicomLabel3D Class > DicomLabel3D Constructor : DicomLabel3D Constructor(String,Matrix)
Create a DicomLabel from a Wavefront "obj" file with explicit orientation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal ObjFileName As String, _
   ByVal Rotation As SharpDX.Matrix _
)
'Usage

Dim ObjFileName As String
Dim Rotation As SharpDX.Matrix

Dim instance As New DicomLabel3D(ObjFileName, Rotation)
public DicomLabel3D(
   string ObjFileName,
   SharpDX.Matrix Rotation
)
public:
DicomLabel3D(
   String^ ObjFileName,
   SharpDX.Matrix Rotation
)

Parameters

ObjFileName
Rotation
Remarks

Although this constructor points to an individual file, the associated material and texture files must also be present in the same directory, and they will be accessed automatically.

DICOM uses a strict convention for the axes: +X=Left, +Y=Back and +Z=Head. Whilst the convention for OBJ files is not well defined, most models assume +X=Left, +Y=Head and +Z=front, but this is not universal, so this method allows the user to provide a custom rotation matrix to bring them into alignment.

The OBJ file implmentation uses vertices, normals and colour or textures to render the images but a few advanced aspects such as specular maps or transparency are not supported.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel3D Class
DicomLabel3D Members
Overload List


DicomLabel3D Class Methods

DicomLabel3D Class Methods

DicomObjects Namespace : DicomLabel3D Class

For a list of all members of this type, see DicomLabel3D members.

Public Methods
 | Name | Description
Public Method | Dispose | Standard Dispose
Top
See Also

Reference

DicomLabel3D Class
DicomObjects Namespace


Dispose() Method

Dispose() Method

DicomObjects Namespace > DicomLabel3D Class : Dispose() Method
Standard Dispose
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As DicomLabel3D

instance.Dispose()
public void Dispose()
public:
void Dispose();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel3D Class
DicomLabel3D Members


DicomLabel3D Class Properties

DicomLabel3D Class Properties

DicomObjects Namespace : DicomLabel3D Class

For a list of all members of this type, see DicomLabel3D members.

Public Properties
 | Name | Description
Public Property | Position | The Position of the label in the output space (0 to 1) - default is 0.9, 0.9 - lower right corner.
Public Property | Size | The size of the label relative the smaller of the image's displayed dimensions - default = 0.1
Top
See Also

Reference

DicomLabel3D Class
DicomObjects Namespace


Position Property

Position Property

DicomObjects Namespace > DicomLabel3D Class : Position Property
The Position of the label in the output space (0 to 1) - default is 0.9, 0.9 - lower right corner.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Position As PointF
'Usage

Dim instance As DicomLabel3D
Dim value As PointF

instance.Position = value

value = instance.Position
public PointF Position {get; set;}
public:
property PointF Position {
   PointF get();
   void set (    PointF value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel3D Class
DicomLabel3D Members


Size Property (DicomLabel3D)

Size Property (DicomLabel3D)

DicomObjects Namespace > DicomLabel3D Class : Size Property
The size of the label relative the smaller of the image's displayed dimensions - default = 0.1
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Size As Single
'Usage

Dim instance As DicomLabel3D
Dim value As Single

instance.Size = value

value = instance.Size
public float Size {get; set;}
public:
property float Size {
   float get();
   void set (    float value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel3D Class
DicomLabel3D Members


DicomLabelCollection Class

DicomLabelCollection Class
Members

DicomObjects Namespace : DicomLabelCollection Class
A collection of DicomLabel objects.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomLabelCollection
   Inherits System.Collections.ObjectModel.Collection(Of DicomLabel)
'Usage

Dim instance As DicomLabelCollection
public class DicomLabelCollection : System.Collections.ObjectModel.Collection<DicomLabel>
public ref class DicomLabelCollection : public System.Collections.ObjectModel.Collection<DicomLabel>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
DicomObjects.DicomLabelCollection

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabelCollection Members
DicomObjects Namespace


DicomLabelCollection Class Members

DicomLabelCollection Class Members
Properties Methods

DicomObjects Namespace : DicomLabelCollection Class

The following tables list the members exposed by DicomLabelCollection.

Public Constructors
 | Name | Description
Public Constructor | DicomLabelCollection Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Property | Tag | A general purpose Tag for developer use
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Add a list of DicomLabel objects
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | Clone | Overloaded. Returns a copy of the DicomLabelCollection
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | Remove | Overloaded. Remove a list of DicomLabel objects
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Top
See Also

Reference

DicomLabelCollection Class
DicomObjects Namespace


DicomLabelCollection Constructor

DicomLabelCollection Constructor

DicomObjects Namespace > DicomLabelCollection Class : DicomLabelCollection Constructor
Overload List
Overload | Description
DicomLabelCollection Constructor() | Create a blank DicomLabelCollection object
DicomLabelCollection Constructor(IEnumerable<DicomLabel>) | Create a DicomLabelCollection object fro ma list
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabelCollection Class
DicomLabelCollection Members


DicomLabelCollection Constructor()

DicomLabelCollection Constructor()

DicomObjects Namespace > DicomLabelCollection Class > DicomLabelCollection Constructor : DicomLabelCollection Constructor()
Create a blank DicomLabelCollection object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DicomLabelCollection()
public DicomLabelCollection()
public:
DicomLabelCollection();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabelCollection Class
DicomLabelCollection Members
Overload List


DicomLabelCollection Constructor(IEnumerable<DicomLabel>)

DicomLabelCollection Constructor(IEnumerable<DicomLabel>)

DicomObjects Namespace > DicomLabelCollection Class > DicomLabelCollection Constructor : DicomLabelCollection Constructor(IEnumerable<DicomLabel>)
Create a DicomLabelCollection object fro ma list
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal Items As IEnumerable(Of DicomLabel) _
)
'Usage

Dim Items As IEnumerable(Of DicomLabel)

Dim instance As New DicomLabelCollection(Items)
public DicomLabelCollection(
   IEnumerable<DicomLabel> Items
)
public:
DicomLabelCollection(
   IEnumerable<DicomLabel^>^ Items
)

Parameters

Items
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabelCollection Class
DicomLabelCollection Members
Overload List


DicomLabelCollection Class Methods

DicomLabelCollection Class Methods

DicomObjects Namespace : DicomLabelCollection Class

For a list of all members of this type, see DicomLabelCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Add a list of DicomLabel objects
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | Clone | Overloaded. Returns a copy of the DicomLabelCollection
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | Remove | Overloaded. Remove a list of DicomLabel objects
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Top
See Also

Reference

DicomLabelCollection Class
DicomObjects Namespace


Add Method (DicomLabelCollection)

Add Method (DicomLabelCollection)

DicomObjects Namespace > DicomLabelCollection Class : Add Method
Add a list of DicomLabel objects
Overload List
Overload | Description
Add(IEnumerable<DicomLabel>) | Add a list of DicomLabel objects
Add(DicomLabel) | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabelCollection Class
DicomLabelCollection Members


Add(IEnumerable<DicomLabel>) Method

Add(IEnumerable<DicomLabel>) Method

DicomObjects Namespace > DicomLabelCollection Class > Add Method : Add(IEnumerable<DicomLabel>) Method
Items to add
Add a list of DicomLabel objects
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal Items As IEnumerable(Of DicomLabel) _
)
'Usage

Dim instance As DicomLabelCollection
Dim Items As IEnumerable(Of DicomLabel)

instance.Add(Items)
public void Add(
   IEnumerable<DicomLabel> Items
)
public:
void Add(
   IEnumerable<DicomLabel^>^ Items
)

Parameters

Items
Items to add
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabelCollection Class
DicomLabelCollection Members
Overload List


Clone Method (DicomLabelCollection)

Clone Method (DicomLabelCollection)

DicomObjects Namespace > DicomLabelCollection Class : Clone Method
Returns a copy of the DicomLabelCollection
Overload List
Overload | Description
Clone() | Returns a copy of the DicomLabelCollection
Clone(Boolean) | Returns a copy of the DicomLabelCollection
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabelCollection Class
DicomLabelCollection Members


Clone() Method

Clone() Method

DicomObjects Namespace > DicomLabelCollection Class > Clone Method : Clone() Method
Returns a copy of the DicomLabelCollection
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Overridable Function Clone() As Object
'Usage

Dim instance As DicomLabelCollection
Dim value As Object

value = instance.Clone()
public virtual object Clone()
public:
virtual Object^ Clone();

Return Value

DicomLabelCollection
Remarks
This method makes a Shallow Copy of the DicomLabelCollection. A shallow copy will only have the top level objects replicated, any referenced objects under the top level will be shared by the original DicomLabelCollection and the cloned copy.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabelCollection Class
DicomLabelCollection Members
Overload List


Clone(Boolean) Method

Clone(Boolean) Method

DicomObjects Namespace > DicomLabelCollection Class > Clone Method : Clone(Boolean) Method

Controls whether a Shallow copy or a Deep copy is to be returned

Returns a copy of the DicomLabelCollection
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Overridable Function Clone( _
   ByVal Deep As Boolean _
) As Object
'Usage

Dim instance As DicomLabelCollection
Dim Deep As Boolean
Dim value As Object

value = instance.Clone(Deep)
public virtual object Clone(
   bool Deep
)
public:
virtual Object^ Clone(
   bool Deep
)

Parameters

Deep

Controls whether a Shallow copy or a Deep copy is to be returned

Return Value

DicomLabelCollection
Remarks

If Deep is true, then returns a Deep copy of the DicomLabelCollection, otherwise returns a Shallow copy.

A Deep copy will have all referenced objects of all levels cloned, where a Shallow copy will only have the top level referenced objects cloned.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabelCollection Class
DicomLabelCollection Members
Overload List


Remove Method (DicomLabelCollection)

Remove Method (DicomLabelCollection)

DicomObjects Namespace > DicomLabelCollection Class : Remove Method
Remove a list of DicomLabel objects
Overload List
Overload | Description
Remove(IEnumerable<DicomLabel>) | Remove a list of DicomLabel objects
Remove(DicomLabel) | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabelCollection Class
DicomLabelCollection Members


Remove(IEnumerable<DicomLabel>) Method

Remove(IEnumerable<DicomLabel>) Method

DicomObjects Namespace > DicomLabelCollection Class > Remove Method : Remove(IEnumerable<DicomLabel>) Method
Items to remove
Remove a list of DicomLabel objects
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Remove( _
   ByVal Items As IEnumerable(Of DicomLabel) _
)
'Usage

Dim instance As DicomLabelCollection
Dim Items As IEnumerable(Of DicomLabel)

instance.Remove(Items)
public void Remove(
   IEnumerable<DicomLabel> Items
)
public:
void Remove(
   IEnumerable<DicomLabel^>^ Items
)

Parameters

Items
Items to remove
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabelCollection Class
DicomLabelCollection Members
Overload List


DicomLabelCollection Class Properties

DicomLabelCollection Class Properties

DicomObjects Namespace : DicomLabelCollection Class

For a list of all members of this type, see DicomLabelCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Property | Tag | A general purpose Tag for developer use
Top
See Also

Reference

DicomLabelCollection Class
DicomObjects Namespace


Tag Property (DicomLabelCollection)

Tag Property (DicomLabelCollection)

DicomObjects Namespace > DicomLabelCollection Class : Tag Property
A general purpose Tag for developer use
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Tag As Object
'Usage

Dim instance As DicomLabelCollection
Dim value As Object

instance.Tag = value

value = instance.Tag
public object Tag {get; set;}
public:
property Object^ Tag {
   Object^ get();
   void set (    Object^ value);
}
Remarks
This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabelCollection Class
DicomLabelCollection Members


DicomLicense Class

DicomLicense Class
Members

DicomObjects Namespace : DicomLicense Class
This class handles all the new licensing scheme for DicomObjects.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomLicense
'Usage

Dim instance As DicomLicense
public class DicomLicense
public ref class DicomLicense
Remarks
This class both represents an individual license issued to allow use of DicomObjects on a particular machine, and also acts as a placeholder for many static (shared in VB) methods and properties which allow licenses to be listed, obtained (off-line or on-line) selected and deleted. For licence activation to be controlled via an external file at startup, DicomObjects offers a mechanism for using an Activation File
Inheritance Hierarchy

System.Object
DicomObjects.DicomLicense

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Members
DicomObjects Namespace


DicomLicense Class Members

DicomLicense Class Members
Properties Methods Events

DicomObjects Namespace : DicomLicense Class

The following tables list the members exposed by DicomLicense.

Public Properties
 | Name | Description
Public Property | AllowedFunctions | The functions which this license allows DicomObjects to perform
Public Property | AuthorisationID | The numeric ID of the Authorisation String which was used to generate this license
static (Shared in Visual Basic) | CurrentLicense | The DicomLicense current in use
static (Shared in Visual Basic) | Dialog | Static LicenseDialog used to inform the user about license problems
Public Property | Expiry | The expiry date of the license
static (Shared in Visual Basic) | ExpiryWarningDays | Number of days before expiry to start issuing warnings
static (Shared in Visual Basic) | ExpiryWarningPeriod | Warning period to give the user of license expiry
static (Shared in Visual Basic) | InstalledLicenses | The list of currently available licenses
Public Property | IsRamLicense | Check whether the currently active license is a temporary (RAM) license
Public Property | LicenseID | The ID for this particular license
static (Shared in Visual Basic) | LicenseServer | Specifies the server to be used to obtain on-line licenses This is an advanced property only to be used under directions from Medical Connections
static (Shared in Visual Basic) | LicenseServerCount | Specifies the how many license servers are to be tried to obtain on-line licenses This is an advanced property only to be used under directions from Medical Connections
Public Property | LicenseToken | The license token which activated this licnense.
Public Property | LicenseType | The Type (Full, Trial or Developer) of this license.
static (Shared in Visual Basic) | MachineID | A unique string for each machine.
static (Shared in Visual Basic) | ProxyDomain | Domain to be used if the machine's web proxy requires authentication.
static (Shared in Visual Basic) | ProxyPassword | Password to be used if the machine's web proxy requires authentication.
static (Shared in Visual Basic) | ProxyUsername | Username to be used if the machine's web proxy requires authentication.
Public Property | Start | The start date of the license
static (Shared in Visual Basic) | WebService | The Web Service used for on-line activation
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | ActivateOffLine | Activate using an LicenseToken obtained off-line
static (Shared in Visual Basic) | ActivateOnLine | Attempt to obtain a DicomObjects license on-line
static (Shared in Visual Basic) | AddRamLicense | Add a RAM License contained in the byte array
static (Shared in Visual Basic) | DeactivateOnline | Attempt to Delete all installed Licenses on-line
Public Method | Delete | Delete a specific DicomObjects license on a machine.
static (Shared in Visual Basic) | DeleteAllLicenses | Delete all DicomObjects licenses on a machine.
static (Shared in Visual Basic) | GetActiveLicenses | Method to obtain a list of active concurrent licenses
static (Shared in Visual Basic) | GetLicense | Overloaded. Return a DicomLicense
static (Shared in Visual Basic) | GetRamLicense | Get a concurrent temporary license
static (Shared in Visual Basic) | ReactivateOnLine | Attempt to obtain a DicomObjects license on-line.
static (Shared in Visual Basic) | RemoveRamLicense | Deactivate a RAM License
Public Method | Revoke | Revokes all temporary and permanent licenses
Public Method | ToString | Standard override
Top
Public Events
 | Name | Description
Public Event | LicenseExpirationEvent | Event to alert application that the current temporary license is about to expire
Public Event | RetrieveLicense | Event fired when DicomObjects needs to retrieve a previously stored license
Public Event | StoreLicense | Event fires when DicomObjects needs to store a license
Top
See Also

Reference

DicomLicense Class
DicomObjects Namespace


DicomLicense Class Methods

DicomLicense Class Methods

DicomObjects Namespace : DicomLicense Class

For a list of all members of this type, see DicomLicense members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | ActivateOffLine | Activate using an LicenseToken obtained off-line
static (Shared in Visual Basic) | ActivateOnLine | Attempt to obtain a DicomObjects license on-line
static (Shared in Visual Basic) | AddRamLicense | Add a RAM License contained in the byte array
static (Shared in Visual Basic) | DeactivateOnline | Attempt to Delete all installed Licenses on-line
Public Method | Delete | Delete a specific DicomObjects license on a machine.
static (Shared in Visual Basic) | DeleteAllLicenses | Delete all DicomObjects licenses on a machine.
static (Shared in Visual Basic) | GetActiveLicenses | Method to obtain a list of active concurrent licenses
static (Shared in Visual Basic) | GetLicense | Overloaded. Return a DicomLicense
static (Shared in Visual Basic) | GetRamLicense | Get a concurrent temporary license
static (Shared in Visual Basic) | ReactivateOnLine | Attempt to obtain a DicomObjects license on-line.
static (Shared in Visual Basic) | RemoveRamLicense | Deactivate a RAM License
Public Method | Revoke | Revokes all temporary and permanent licenses
Public Method | ToString | Standard override
Top
See Also

Reference

DicomLicense Class
DicomObjects Namespace


ActivateOffLine Method

ActivateOffLine Method

DicomObjects Namespace > DicomLicense Class : ActivateOffLine Method
The string provided by Medical Connections, allowing you to activate DicomObjects
The string obtained from the license server
An "out" parameter, into which an explantion of the result is placed.
Activate using an LicenseToken obtained off-line
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function ActivateOffLine( _
   ByVal AuthorisationString As String, _
   ByVal LicenseToken As String, _
   ByRef Result As String _
) As DicomLicense
'Usage

Dim AuthorisationString As String
Dim LicenseToken As String
Dim Result As String
Dim value As DicomLicense

value = DicomLicense.ActivateOffLine(AuthorisationString, LicenseToken, Result)
public static DicomLicense ActivateOffLine(
   string AuthorisationString,
   string LicenseToken,
   out string Result
)
public:
static DicomLicense^ ActivateOffLine(
   String^ AuthorisationString,
   String^ LicenseToken,
   [Out] String^ Result
)

Parameters

AuthorisationString
The string provided by Medical Connections, allowing you to activate DicomObjects
LicenseToken
The string obtained from the license server
Result
An "out" parameter, into which an explantion of the result is placed.

Return Value

A valid DicomLicense object if the activation succeeded or if already activated using this Authorisation string.

null if the activation failed.

Remarks

This method may be used where the machine being activated does not have a direct Internet connection. The same information as would be used by ActivateOnLine is entered into the web site http://activation.medicalconnections.co.uk using a separate machine which will return a LicenseToken, which should then be used in this method

Like the ActivateOnLine method, this method is called internally on request from the LicenseDialog form

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


ActivateOnLine Method

ActivateOnLine Method

DicomObjects Namespace > DicomLicense Class : ActivateOnLine Method
The string provided by Medical Connections, allowing you to activate DicomObjects
A string identifying the PC and or institution at which this copy is being activated
A second string with the same function
An "out" parameter, into which an explantion of the result is placed.
Attempt to obtain a DicomObjects license on-line
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function ActivateOnLine( _
   ByVal AuthorisationString As String, _
   ByVal CustomerInfo1 As String, _
   ByVal CustomerInfo2 As String, _
   ByRef Result As String _
) As DicomLicense
'Usage

Dim AuthorisationString As String
Dim CustomerInfo1 As String
Dim CustomerInfo2 As String
Dim Result As String
Dim value As DicomLicense

value = DicomLicense.ActivateOnLine(AuthorisationString, CustomerInfo1, CustomerInfo2, Result)
public static DicomLicense ActivateOnLine(
   string AuthorisationString,
   string CustomerInfo1,
   string CustomerInfo2,
   out string Result
)
public:
static DicomLicense^ ActivateOnLine(
   String^ AuthorisationString,
   String^ CustomerInfo1,
   String^ CustomerInfo2,
   [Out] String^ Result
)

Parameters

AuthorisationString
The string provided by Medical Connections, allowing you to activate DicomObjects
CustomerInfo1
A string identifying the PC and or institution at which this copy is being activated
CustomerInfo2
A second string with the same function
Result
An "out" parameter, into which an explantion of the result is placed.

Return Value

A valid DicomLicense object if the activation succeeded or if already activated using this Authorisation string.

null if the activation failed.

Remarks

This is the main method used to activate a DicomObjects license, and is used both explicitly by developers and internally by the LicenseDialog when so requested.

The result indicates whether the method succeeded, and further information (whether successful or not) is available in the Result paramaeter

If a license has previously been activated on the same machine, using the same authorisation string, then the method returns true, but the fact is noted in the Result

The license server to be contacted is specified by LicenseServer, but this should not normally be changed.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


AddRamLicense Method

AddRamLicense Method

DicomObjects Namespace > DicomLicense Class : AddRamLicense Method
The license to add
Add a RAM License contained in the byte array
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function AddRamLicense( _
   ByVal token() As Byte _
) As DicomLicense
'Usage

Dim token() As Byte
Dim value As DicomLicense

value = DicomLicense.AddRamLicense(token)
public static DicomLicense AddRamLicense(
   byte[] token
)
public:
static DicomLicense^ AddRamLicense(
   array<byte>^ token
)

Parameters

token
The license to add

Return Value

The resulting DicomLicense object
Remarks

This method is only available in special builds of DicomObjects which include the temporary licensing facility

The type and valid date/time range of the license are defined within the encoded byte array

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


DeactivateOnline Method

DeactivateOnline Method

DicomObjects Namespace > DicomLicense Class : DeactivateOnline Method
An optional string identifying the PC and or institution at which this copy is being deactivated
A second string with the same function
Attempt to Delete all installed Licenses on-line
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function DeactivateOnline( _
   ByVal CustomerInfo1 As String, _
   ByVal CustomerInfo2 As String _
) As String
'Usage

Dim CustomerInfo1 As String
Dim CustomerInfo2 As String
Dim value As String

value = DicomLicense.DeactivateOnline(CustomerInfo1, CustomerInfo2)
public static string DeactivateOnline(
   string CustomerInfo1,
   string CustomerInfo2
)
public:
static String^ DeactivateOnline(
   String^ CustomerInfo1,
   String^ CustomerInfo2
)

Parameters

CustomerInfo1
An optional string identifying the PC and or institution at which this copy is being deactivated
CustomerInfo2
A second string with the same function
Remarks
This method tries to delete all installed licenses on your machine and notify our license server of the deletion.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


Delete Method

Delete Method

DicomObjects Namespace > DicomLicense Class : Delete Method
Delete a specific DicomObjects license on a machine.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Delete()
'Usage

Dim instance As DicomLicense

instance.Delete()
public void Delete()
public:
void Delete();
Remarks

This method may be useful to remove trial licenses etc., but should be used with care on an end-user machine just in case there are licenses installed by other vendors, which should not be deleted

Depending on the version of windows, and the permissions of the user, it is possible that the license may be removed, espeically if it was installed by an administrator, but this method is invoked by a less privileged user.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


DeleteAllLicenses Method

DeleteAllLicenses Method

DicomObjects Namespace > DicomLicense Class : DeleteAllLicenses Method
Delete all DicomObjects licenses on a machine.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub DeleteAllLicenses()
'Usage

DicomLicense.DeleteAllLicenses()
public static void DeleteAllLicenses()
public:
static void DeleteAllLicenses();
Remarks

This method may be useful on a development machine to remove all traces of trial licenses etc., but should not normally be used on an end-user machine just in case there are licenses installed by other vendors

Depending on the version of windows, and the permissions of the user, it is possible that not all licenses will be removed, espeically if they were installed by an administrator, but this method is invoked by a less privileged user.

Note that functions previously used during an execution remain available after this call, despite CurrentLicense

being set to null. Delete
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


GetActiveLicenses Method

GetActiveLicenses Method

DicomObjects Namespace > DicomLicense Class : GetActiveLicenses Method
The key used to activate the concurrent license
Method to obtain a list of active concurrent licenses
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function GetActiveLicenses( _
   ByVal LicenseKey As String _
) As List(Of DicomLicense.RamLicenseInfo)
'Usage

Dim LicenseKey As String
Dim value As List(Of DicomLicense.RamLicenseInfo)

value = DicomLicense.GetActiveLicenses(LicenseKey)
public static List<DicomLicense.RamLicenseInfo> GetActiveLicenses(
   string LicenseKey
)
public:
static List<DicomLicense.RamLicenseInfo^>^ GetActiveLicenses(
   String^ LicenseKey
)

Parameters

LicenseKey
The key used to activate the concurrent license
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


GetLicense Method

GetLicense Method

DicomObjects Namespace > DicomLicense Class : GetLicense Method
Return a DicomLicense
Overload List
Overload | Description
GetLicense() | Allow DicomObjects to select a license
GetLicense(LicensedFunctions) | Return a DicomLicense which supports the required set of functions
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


GetLicense() Method

GetLicense() Method

DicomObjects Namespace > DicomLicense Class > GetLicense Method : GetLicense() Method
Allow DicomObjects to select a license
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Shared Function GetLicense() As DicomLicense
'Usage

Dim value As DicomLicense

value = DicomLicense.GetLicense()
public static DicomLicense GetLicense()
public:
static DicomLicense^ GetLicense();

Return Value

A DicomLicense object
Remarks
When this method is used (either explicitly, or implicitly via use of licensed functionality or getting the CurrentLicense property before choosing a license), the DicomObjects will select the first DicomObjects.Enums.LicenseTypes.Full license available in the InstalledLicenses collection, or failing that a DicomObjects.Enums.LicenseTypes.Developer license.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members
Overload List


GetLicense(LicensedFunctions) Method

GetLicense(LicensedFunctions) Method

DicomObjects Namespace > DicomLicense Class > GetLicense Method : GetLicense(LicensedFunctions) Method
A combination of DicomObjects.Enums.LicensedFunctions flags, indicating the required functionality
Return a DicomLicense which supports the required set of functions
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Shared Function GetLicense( _
   ByVal Functions As LicensedFunctions _
) As DicomLicense
'Usage

Dim Functions As LicensedFunctions
Dim value As DicomLicense

value = DicomLicense.GetLicense(Functions)
public static DicomLicense GetLicense(
   LicensedFunctions Functions
)
public:
static DicomLicense^ GetLicense(
   LicensedFunctions Functions
)

Parameters

Functions
A combination of DicomObjects.Enums.LicensedFunctions flags, indicating the required functionality

Return Value

A DicomLicense object
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members
Overload List


GetRamLicense Method

GetRamLicense Method

DicomObjects Namespace > DicomLicense Class : GetRamLicense Method
The RAM License Key
Any useful information about the current user
String result to indicate success or failure
Get a concurrent temporary license
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function GetRamLicense( _
   ByVal AuthorisationString As String, _
   ByVal CustomerInfo As String, _
   ByRef Result As String _
) As DicomLicense
'Usage

Dim AuthorisationString As String
Dim CustomerInfo As String
Dim Result As String
Dim value As DicomLicense

value = DicomLicense.GetRamLicense(AuthorisationString, CustomerInfo, Result)
public static DicomLicense GetRamLicense(
   string AuthorisationString,
   string CustomerInfo,
   out string Result
)
public:
static DicomLicense^ GetRamLicense(
   String^ AuthorisationString,
   String^ CustomerInfo,
   [Out] String^ Result
)

Parameters

AuthorisationString
The RAM License Key
CustomerInfo
Any useful information about the current user
Result
String result to indicate success or failure
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


ReactivateOnLine Method

ReactivateOnLine Method

DicomObjects Namespace > DicomLicense Class : ReactivateOnLine Method
The string provided by Medical Connections, allowing you to activate DicomObjects
Provide as much information as possible for the Original License, including original MachineID and license token
A string identifying the PC and or institution at which this copy is being activated
A second string with the same function
An "out" parameter, into which an explantion of the result is placed.
Attempt to obtain a DicomObjects license on-line.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function ReactivateOnLine( _
   ByVal AuthorisationString As String, _
   ByVal OriginalLicense As String, _
   ByVal CustomerInfo1 As String, _
   ByVal CustomerInfo2 As String, _
   ByRef Result As String _
) As DicomLicense
'Usage

Dim AuthorisationString As String
Dim OriginalLicense As String
Dim CustomerInfo1 As String
Dim CustomerInfo2 As String
Dim Result As String
Dim value As DicomLicense

value = DicomLicense.ReactivateOnLine(AuthorisationString, OriginalLicense, CustomerInfo1, CustomerInfo2, Result)
public static DicomLicense ReactivateOnLine(
   string AuthorisationString,
   string OriginalLicense,
   string CustomerInfo1,
   string CustomerInfo2,
   out string Result
)
public:
static DicomLicense^ ReactivateOnLine(
   String^ AuthorisationString,
   String^ OriginalLicense,
   String^ CustomerInfo1,
   String^ CustomerInfo2,
   [Out] String^ Result
)

Parameters

AuthorisationString
The string provided by Medical Connections, allowing you to activate DicomObjects
OriginalLicense
Provide as much information as possible for the Original License, including original MachineID and license token
CustomerInfo1
A string identifying the PC and or institution at which this copy is being activated
CustomerInfo2
A second string with the same function
Result
An "out" parameter, into which an explantion of the result is placed.

Return Value

A valid DicomLicense object if the activation succeeded or if already activated using this Authorisation string.

null if the activation failed.

Remarks
This is the method for re-installing a DicomObjects licenses on existing PC that had some hardware changes, and as a result generates a new MachineID. You can also use this method for installing a DicomLicense on a replacement PC.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


RemoveRamLicense Method

RemoveRamLicense Method

DicomObjects Namespace > DicomLicense Class : RemoveRamLicense Method
string result to indicate success or failure
Deactivate a RAM License
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub RemoveRamLicense( _
   ByRef result As String _
)
'Usage

Dim result As String

DicomLicense.RemoveRamLicense(result)
public static void RemoveRamLicense(
   out string result
)
public:
static void RemoveRamLicense(
   [Out] String^ result
)

Parameters

result
string result to indicate success or failure
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


Revoke Method

Revoke Method

DicomObjects Namespace > DicomLicense Class : Revoke Method
Revokes all temporary and permanent licenses
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function Revoke() As Byte()
'Usage

Dim instance As DicomLicense
Dim value() As Byte

value = instance.Revoke()
public byte[] Revoke()
public:
array<byte>^ Revoke();

Return Value

A byte array containing a token which may be used to "prove" that revokation has occured
Remarks

This method is only available in special builds of DicomObjects which include the temporary licensing facility

This method can only be called when a valid temporary license is active.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


ToString Method (DicomLicense)

ToString Method (DicomLicense)

DicomObjects Namespace > DicomLicense Class : ToString Method
Standard override
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As DicomLicense
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A human readable representation of the type, functions, IDs and expiry of the license
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members
Base Implementation in ToString


DicomLicense Class Properties

DicomLicense Class Properties

DicomObjects Namespace : DicomLicense Class

For a list of all members of this type, see DicomLicense members.

Public Properties
 | Name | Description
Public Property | AllowedFunctions | The functions which this license allows DicomObjects to perform
Public Property | AuthorisationID | The numeric ID of the Authorisation String which was used to generate this license
static (Shared in Visual Basic) | CurrentLicense | The DicomLicense current in use
static (Shared in Visual Basic) | Dialog | Static LicenseDialog used to inform the user about license problems
Public Property | Expiry | The expiry date of the license
static (Shared in Visual Basic) | ExpiryWarningDays | Number of days before expiry to start issuing warnings
static (Shared in Visual Basic) | ExpiryWarningPeriod | Warning period to give the user of license expiry
static (Shared in Visual Basic) | InstalledLicenses | The list of currently available licenses
Public Property | IsRamLicense | Check whether the currently active license is a temporary (RAM) license
Public Property | LicenseID | The ID for this particular license
static (Shared in Visual Basic) | LicenseServer | Specifies the server to be used to obtain on-line licenses This is an advanced property only to be used under directions from Medical Connections
static (Shared in Visual Basic) | LicenseServerCount | Specifies the how many license servers are to be tried to obtain on-line licenses This is an advanced property only to be used under directions from Medical Connections
Public Property | LicenseToken | The license token which activated this licnense.
Public Property | LicenseType | The Type (Full, Trial or Developer) of this license.
static (Shared in Visual Basic) | MachineID | A unique string for each machine.
static (Shared in Visual Basic) | ProxyDomain | Domain to be used if the machine's web proxy requires authentication.
static (Shared in Visual Basic) | ProxyPassword | Password to be used if the machine's web proxy requires authentication.
static (Shared in Visual Basic) | ProxyUsername | Username to be used if the machine's web proxy requires authentication.
Public Property | Start | The start date of the license
static (Shared in Visual Basic) | WebService | The Web Service used for on-line activation
Top
See Also

Reference

DicomLicense Class
DicomObjects Namespace


AllowedFunctions Property

AllowedFunctions Property

DicomObjects Namespace > DicomLicense Class : AllowedFunctions Property
The functions which this license allows DicomObjects to perform
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property AllowedFunctions As LicensedFunctions
'Usage

Dim instance As DicomLicense
Dim value As LicensedFunctions

value = instance.AllowedFunctions
public LicensedFunctions AllowedFunctions {get;}
public:
property LicensedFunctions AllowedFunctions {
   LicensedFunctions get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


AuthorisationID Property

AuthorisationID Property

DicomObjects Namespace > DicomLicense Class : AuthorisationID Property
The numeric ID of the Authorisation String which was used to generate this license
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property AuthorisationID As Integer
'Usage

Dim instance As DicomLicense
Dim value As Integer

value = instance.AuthorisationID
public int AuthorisationID {get;}
public:
property int AuthorisationID {
   int get();
}
Remarks
For security reasons, the Authorisation String used to generate a DicomLicense is not stored in the machine, but each such string has a unique ID in the Medical Connections database, enabling the two to be linked.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


CurrentLicense Property

CurrentLicense Property

DicomObjects Namespace > DicomLicense Class : CurrentLicense Property
The DicomLicense current in use
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property CurrentLicense As DicomLicense
'Usage

Dim value As DicomLicense

DicomLicense.CurrentLicense = value

value = DicomLicense.CurrentLicense
public static DicomLicense CurrentLicense {get; set;}
public:
static property DicomLicense^ CurrentLicense {
   DicomLicense^ get();
   void set (    DicomLicense^ value);
}
Remarks

Only one license can be in use at any time, and this property allows the developer to choose which of those available (from the InstalledLicenses should be used, or to tell which is currently in use.

If no license has specifically been selected, then DicomObject will use the GetLicense method to obtain one when this method is first called or when a license is first required.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


Dialog Property

Dialog Property

DicomObjects Namespace > DicomLicense Class : Dialog Property
Static LicenseDialog used to inform the user about license problems
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property Dialog As LicenseDialog
'Usage

Dim value As LicenseDialog

DicomLicense.Dialog = value

value = DicomLicense.Dialog
public static LicenseDialog Dialog {get; set;}
public:
static property LicenseDialog^ Dialog {
   LicenseDialog^ get();
   void set (    LicenseDialog^ value);
}
Remarks
This instance of the dialog is used for most internally generated notifications, giving developers the chance to cusomise its properties before it may be used. Note that an independent non-customisable instance is used for Trial and Developer notifications, but these should only ever be seen by a developer anyway!
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


Expiry Property

Expiry Property

DicomObjects Namespace > DicomLicense Class : Expiry Property
The expiry date of the license
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Expiry As Date
'Usage

Dim instance As DicomLicense
Dim value As Date

value = instance.Expiry
public DateTime Expiry {get;}
public:
property DateTime Expiry {
   DateTime get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


ExpiryWarningDays Property

ExpiryWarningDays Property

DicomObjects Namespace > DicomLicense Class : ExpiryWarningDays Property
Number of days before expiry to start issuing warnings
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property ExpiryWarningDays As Integer
'Usage

Dim value As Integer

DicomLicense.ExpiryWarningDays = value

value = DicomLicense.ExpiryWarningDays
public static int ExpiryWarningDays {get; set;}
public:
static property int ExpiryWarningDays {
   int get();
   void set (    int value);
}
Remarks
Default value is 14. Set to 0 to disable all expiry warning from DicomObjects.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


ExpiryWarningPeriod Property

ExpiryWarningPeriod Property

DicomObjects Namespace > DicomLicense Class : ExpiryWarningPeriod Property
Warning period to give the user of license expiry
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property ExpiryWarningPeriod As TimeSpan
'Usage

Dim value As TimeSpan

DicomLicense.ExpiryWarningPeriod = value

value = DicomLicense.ExpiryWarningPeriod
public static TimeSpan ExpiryWarningPeriod {get; set;}
public:
static property TimeSpan ExpiryWarningPeriod {
   TimeSpan get();
   void set (    TimeSpan value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


InstalledLicenses Property

InstalledLicenses Property

DicomObjects Namespace > DicomLicense Class : InstalledLicenses Property
The list of currently available licenses
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property InstalledLicenses As DicomLicense()
'Usage

Dim value() As DicomLicense

value = DicomLicense.InstalledLicenses
public static DicomLicense[] InstalledLicenses {get;}
public:
static property array<DicomLicense^>^ InstalledLicenses {
   array<DicomLicense^>^ get();
}
Remarks
Licenses are added to this list automatically by invoking ActivateOnLine or ActivateOffLine, and removed by invoking Delete
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


IsRamLicense Property

IsRamLicense Property

DicomObjects Namespace > DicomLicense Class : IsRamLicense Property
Check whether the currently active license is a temporary (RAM) license
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property IsRamLicense As Boolean
'Usage

Dim instance As DicomLicense
Dim value As Boolean

value = instance.IsRamLicense
public bool IsRamLicense {get;}
public:
property bool IsRamLicense {
   bool get();
}
Remarks

This method is only available in special builds of DicomObjects which include the temporary licensing facility

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


LicenseID Property

LicenseID Property

DicomObjects Namespace > DicomLicense Class : LicenseID Property
The ID for this particular license
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property LicenseID As Integer
'Usage

Dim instance As DicomLicense
Dim value As Integer

value = instance.LicenseID
public int LicenseID {get;}
public:
property int LicenseID {
   int get();
}
Remarks
When combined with the AuthorisationID, this creates a unique identifier for the license
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


LicenseServer Property

LicenseServer Property

DicomObjects Namespace > DicomLicense Class : LicenseServer Property
Specifies the server to be used to obtain on-line licenses This is an advanced property only to be used under directions from Medical Connections
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property LicenseServer As String
'Usage

Dim value As String

DicomLicense.LicenseServer = value

value = DicomLicense.LicenseServer
public static string LicenseServer {get; set;}
public:
static property String^ LicenseServer {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


LicenseServerCount Property

LicenseServerCount Property

DicomObjects Namespace > DicomLicense Class : LicenseServerCount Property
Specifies the how many license servers are to be tried to obtain on-line licenses This is an advanced property only to be used under directions from Medical Connections
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property LicenseServerCount As Integer
'Usage

Dim value As Integer

DicomLicense.LicenseServerCount = value

value = DicomLicense.LicenseServerCount
public static int LicenseServerCount {get; set;}
public:
static property int LicenseServerCount {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


LicenseToken Property

LicenseToken Property

DicomObjects Namespace > DicomLicense Class : LicenseToken Property
The license token which activated this licnense.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property LicenseToken As String
'Usage

Dim instance As DicomLicense
Dim value As String

value = instance.LicenseToken
public string LicenseToken {get;}
public:
property String^ LicenseToken {
   String^ get();
}
Remarks
This token would either have been obtained automatically via ActivateOnLine or entered manually via ActivateOffLine). It is an encrypted opaque token, which will vary from machine to machine, and is only valid when used on a machine with a matching MachineID.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


LicenseType Property

LicenseType Property

DicomObjects Namespace > DicomLicense Class : LicenseType Property
The Type (Full, Trial or Developer) of this license.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property LicenseType As LicenseTypes
'Usage

Dim instance As DicomLicense
Dim value As LicenseTypes

value = instance.LicenseType
public LicenseTypes LicenseType {get;}
public:
property LicenseTypes LicenseType {
   LicenseTypes get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


MachineID Property (DicomLicense)

MachineID Property (DicomLicense)

DicomObjects Namespace > DicomLicense Class : MachineID Property
A unique string for each machine.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property MachineID As String
'Usage

Dim value As String

value = DicomLicense.MachineID
public static string MachineID {get;}
public:
static property String^ MachineID {
   String^ get();
}
Remarks
This string is needed to generate a license and must be entered into the web activation system when ActivateOffLine is to be used.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


ProxyDomain Property

ProxyDomain Property

DicomObjects Namespace > DicomLicense Class : ProxyDomain Property
Domain to be used if the machine's web proxy requires authentication.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property ProxyDomain As String
'Usage

Dim value As String

DicomLicense.ProxyDomain = value

value = DicomLicense.ProxyDomain
public static string ProxyDomain {get; set;}
public:
static property String^ ProxyDomain {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


ProxyPassword Property

ProxyPassword Property

DicomObjects Namespace > DicomLicense Class : ProxyPassword Property
Password to be used if the machine's web proxy requires authentication.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property ProxyPassword As String
'Usage

Dim value As String

DicomLicense.ProxyPassword = value

value = DicomLicense.ProxyPassword
public static string ProxyPassword {get; set;}
public:
static property String^ ProxyPassword {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


ProxyUsername Property

ProxyUsername Property

DicomObjects Namespace > DicomLicense Class : ProxyUsername Property
Username to be used if the machine's web proxy requires authentication.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property ProxyUsername As String
'Usage

Dim value As String

DicomLicense.ProxyUsername = value

value = DicomLicense.ProxyUsername
public static string ProxyUsername {get; set;}
public:
static property String^ ProxyUsername {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


Start Property

Start Property

DicomObjects Namespace > DicomLicense Class : Start Property
The start date of the license
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Start As Date
'Usage

Dim instance As DicomLicense
Dim value As Date

value = instance.Start
public DateTime Start {get;}
public:
property DateTime Start {
   DateTime get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


WebService Property

WebService Property

DicomObjects Namespace > DicomLicense Class : WebService Property
The Web Service used for on-line activation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WebService As SoapHttpClientProtocol
'Usage

Dim value As SoapHttpClientProtocol

value = DicomLicense.WebService
public static SoapHttpClientProtocol WebService {get;}
public:
static property SoapHttpClientProtocol^ WebService {
   SoapHttpClientProtocol^ get();
}
Remarks
This static object is used when calls are made to ActivateOnLine. This object may be used to set proxy or credential information where this is necessary.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


DicomLicense Class Events

DicomLicense Class Events

DicomObjects Namespace : DicomLicense Class

For a list of all members of this type, see DicomLicense members.

Public Events
 | Name | Description
Public Event | LicenseExpirationEvent | Event to alert application that the current temporary license is about to expire
Public Event | RetrieveLicense | Event fired when DicomObjects needs to retrieve a previously stored license
Public Event | StoreLicense | Event fires when DicomObjects needs to store a license
Top
See Also

Reference

DicomLicense Class
DicomObjects Namespace


LicenseExpirationEvent Event

LicenseExpirationEvent Event

DicomObjects Namespace > DicomLicense Class : LicenseExpirationEvent Event
Event to alert application that the current temporary license is about to expire
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event LicenseExpirationEvent As LicenseExpirationHandler
'Usage

Dim instance As DicomLicense
Dim handler As LicenseExpirationHandler

AddHandler instance.LicenseExpirationEvent, handler
public event LicenseExpirationHandler LicenseExpirationEvent
public:
event LicenseExpirationHandler^ LicenseExpirationEvent
Remarks

This method is only available in special builds of DicomObjects which include the temporary licensing facility

The event is fired 30s before license expiry

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


RetrieveLicense Event

RetrieveLicense Event

DicomObjects Namespace > DicomLicense Class : RetrieveLicense Event
Event fired when DicomObjects needs to retrieve a previously stored license
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event RetrieveLicense As RetrieveLicenseHandler
'Usage

Dim instance As DicomLicense
Dim handler As RetrieveLicenseHandler

AddHandler instance.RetrieveLicense, handler
public event RetrieveLicenseHandler RetrieveLicense
public:
event RetrieveLicenseHandler^ RetrieveLicense
Remarks

Normally, DicomObjects stores licenses internally, using a combination of registry locations and files, but on some machines this is not feasible due to excessive security restrictions on the account under which it is running. In these cases, a developer may choose to intercept the storage of the license via the StoreLicense event, and then to provide it on request via this event.

Note that DeleteAllLicenses does not affect this mechanism, so it is the developer's responsiblity to clear any stored key if required.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


StoreLicense Event

StoreLicense Event

DicomObjects Namespace > DicomLicense Class : StoreLicense Event
Event fires when DicomObjects needs to store a license
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event StoreLicense As StoreLicenseHandler
'Usage

Dim instance As DicomLicense
Dim handler As StoreLicenseHandler

AddHandler instance.StoreLicense, handler
public event StoreLicenseHandler StoreLicense
public:
event StoreLicenseHandler^ StoreLicense
Remarks

Normally, DicomObjects stores licenses internally, using a combination of registry locations and files, but on some machines this is not feasible due to excessive security restrictions on the account under which it is running. In these cases, a developer may choose to intercept the storage of the license via this event, and then to provide it on request via the RetrieveLicense event.

Note that DeleteAllLicenses does not affect this mechanism, so it is the developer's responsiblity to clear any stored key if required.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense Class
DicomLicense Members


DicomLicense.RamLicenseInfo Class

DicomLicense.RamLicenseInfo Class
Members

DicomObjects Namespace : DicomLicense.RamLicenseInfo Class
Provide Basic information of a Concurrent license object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomLicense.RamLicenseInfo
'Usage

Dim instance As DicomLicense.RamLicenseInfo
public class DicomLicense.RamLicenseInfo
public ref class DicomLicense.RamLicenseInfo
Inheritance Hierarchy

System.Object
DicomObjects.DicomLicense.RamLicenseInfo

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense.RamLicenseInfo Members
DicomObjects Namespace


DicomLicense.RamLicenseInfo Class Members

DicomLicense.RamLicenseInfo Class Members
Properties

DicomObjects Namespace : DicomLicense.RamLicenseInfo Class

The following tables list the members exposed by DicomLicense.RamLicenseInfo.

Public Constructors
 | Name | Description
Public Constructor | DicomLicense.RamLicenseInfo Constructor |
Top
Public Properties
 | Name | Description
Public Property | EndTime | End Date and Time of the license
Public Property | MachineID | The machine's ID
Public Property | StartTime | Start Date and Time of the license
Top
See Also

Reference

DicomLicense.RamLicenseInfo Class
DicomObjects Namespace


DicomLicense.RamLicenseInfo Constructor

DicomLicense.RamLicenseInfo Constructor

DicomObjects Namespace > DicomLicense.RamLicenseInfo Class : DicomLicense.RamLicenseInfo Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DicomLicense.RamLicenseInfo()
public DicomLicense.RamLicenseInfo()
public:
DicomLicense.RamLicenseInfo();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense.RamLicenseInfo Class
DicomLicense.RamLicenseInfo Members


DicomLicense.RamLicenseInfo Class Properties

DicomLicense.RamLicenseInfo Class Properties

DicomObjects Namespace : DicomLicense.RamLicenseInfo Class

For a list of all members of this type, see DicomLicense.RamLicenseInfo members.

Public Properties
 | Name | Description
Public Property | EndTime | End Date and Time of the license
Public Property | MachineID | The machine's ID
Public Property | StartTime | Start Date and Time of the license
Top
See Also

Reference

DicomLicense.RamLicenseInfo Class
DicomObjects Namespace


EndTime Property

EndTime Property

DicomObjects Namespace > DicomLicense.RamLicenseInfo Class : EndTime Property
End Date and Time of the license
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EndTime As Date
'Usage

Dim instance As DicomLicense.RamLicenseInfo
Dim value As Date

instance.EndTime = value

value = instance.EndTime
public DateTime EndTime {get; set;}
public:
property DateTime EndTime {
   DateTime get();
   void set (    DateTime value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense.RamLicenseInfo Class
DicomLicense.RamLicenseInfo Members


MachineID Property (DicomLicense.RamLicenseInfo)

MachineID Property (DicomLicense.RamLicenseInfo)

DicomObjects Namespace > DicomLicense.RamLicenseInfo Class : MachineID Property
The machine's ID
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MachineID As String
'Usage

Dim instance As DicomLicense.RamLicenseInfo
Dim value As String

instance.MachineID = value

value = instance.MachineID
public string MachineID {get; set;}
public:
property String^ MachineID {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense.RamLicenseInfo Class
DicomLicense.RamLicenseInfo Members


StartTime Property

StartTime Property

DicomObjects Namespace > DicomLicense.RamLicenseInfo Class : StartTime Property
Start Date and Time of the license
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property StartTime As Date
'Usage

Dim instance As DicomLicense.RamLicenseInfo
Dim value As Date

instance.StartTime = value

value = instance.StartTime
public DateTime StartTime {get; set;}
public:
property DateTime StartTime {
   DateTime get();
   void set (    DateTime value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLicense.RamLicenseInfo Class
DicomLicense.RamLicenseInfo Members


DicomPrint Class

DicomPrint Class
Members

DicomObjects Namespace : DicomPrint Class
An object to simply printing to a DICOM printer
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomPrint
'Usage

Dim instance As DicomPrint
public class DicomPrint
public ref class DicomPrint
Inheritance Hierarchy

System.Object
DicomObjects.DicomPrint

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Members
DicomObjects Namespace


DicomPrint Class Members

DicomPrint Class Members
Properties Methods

DicomObjects Namespace : DicomPrint Class

The following tables list the members exposed by DicomPrint.

Public Constructors
 | Name | Description
Public Constructor | DicomPrint Constructor | Creates a DicomPrint object
Top
Public Properties
 | Name | Description
Public Property | AnnotationFormat | Common printing variable, the annotation format
Public Property | Annotations | DataSets containing annotations to add to a film
Public Property | BitDepth | The bit depth to send to the printer
Public Property | Colour | Controls whether monochrome of colour printing is attempted
Public Property | Connection | Reference to the underlying DicomAssociation object used by a DicomPrint object
Public Property | Copies | Common printing variable, number of copies to print
Public Property | FilmBox | Over-rides of default values for Film Box Object
Public Property | FilmSize | Common printing variable, the size of the film
Public Property | Format | Common printing variable, the printing format
Public Property | ImageBox | Over-rides of default values for Image Box Object
Public Property | MetaSOPClass | Returns the Meta SOP Class used during the printing session
Public Property | NextPosition | Indicates/Controls the next image box to be used by PrintImage
Public Property | Orientation | Common printing variable, the printing orientation
Public Property | Printer | The well known Printer Instance (as a DicomDataSet)
Public Property | Session | Over-rides of default values for Film Session Object
Public Property | Tag | A general purpose Tag for developer use
Top
Public Methods
 | Name | Description
Public Method | AddAnnotation | Adds an Annotation to the Annotations collection
Public Method | CheckStatus | Check Print Status and return success or error message
Public Method | Close | Closes an association to a DICOM printer, completing any pending print operations
Public Method | Open | Opens an association to a DICOM printer for printing
Public Method | PrintFilm | Print current film
Public Method | PrintImage | Sends an image to the printer
Top
See Also

Reference

DicomPrint Class
DicomObjects Namespace


DicomPrint Constructor

DicomPrint Constructor

DicomObjects Namespace > DicomPrint Class : DicomPrint Constructor
Creates a DicomPrint object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DicomPrint()
public DicomPrint()
public:
DicomPrint();

Return Value

DicomPrint
Remarks

The default constructor. The following properties are initialized during object creation:

Property | Default Value
Session | Empty
Printer | Empty
ImageBox | Empty
FilmBox | Empty
Annotations | Empty
NextPosition | 0
BitDepth | 12
Color | False
Orientation | "PORTRAIT"
FilmSize | ""
AnnotationFormat | ""
Format | "STANDARD\1,1"
Copies | 1

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Class
DicomPrint Members


DicomPrint Class Methods

DicomPrint Class Methods

DicomObjects Namespace : DicomPrint Class

For a list of all members of this type, see DicomPrint members.

Public Methods
 | Name | Description
Public Method | AddAnnotation | Adds an Annotation to the Annotations collection
Public Method | CheckStatus | Check Print Status and return success or error message
Public Method | Close | Closes an association to a DICOM printer, completing any pending print operations
Public Method | Open | Opens an association to a DICOM printer for printing
Public Method | PrintFilm | Print current film
Public Method | PrintImage | Sends an image to the printer
Top
See Also

Reference

DicomPrint Class
DicomObjects Namespace


AddAnnotation Method

AddAnnotation Method

DicomObjects Namespace > DicomPrint Class : AddAnnotation Method

ID of Annotation to be added

Text value of the annotation to be added

Adds an Annotation to the Annotations collection
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub AddAnnotation( _
   ByVal AnnotationID As Integer, _
   ByVal AnnotationString As String _
)
'Usage

Dim instance As DicomPrint
Dim AnnotationID As Integer
Dim AnnotationString As String

instance.AddAnnotation(AnnotationID, AnnotationString)
public void AddAnnotation(
   int AnnotationID,
   string AnnotationString
)
public:
void AddAnnotation(
   int AnnotationID,
   String^ AnnotationString
)

Parameters

AnnotationID

ID of Annotation to be added

AnnotationString

Text value of the annotation to be added

Remarks
This is simply a shortcut way of adding items to the Annotations collection. See that property for more details of how annotations work in DicomObjects printing.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Class
DicomPrint Members


CheckStatus Method

CheckStatus Method

DicomObjects Namespace > DicomPrint Class : CheckStatus Method
String
Check Print Status and return success or error message
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub CheckStatus( _
   ByVal Message As String _
)
'Usage

Dim instance As DicomPrint
Dim Message As String

instance.CheckStatus(Message)
public void CheckStatus(
   string Message
)
public:
void CheckStatus(
   String^ Message
)

Parameters

Message
String
Remarks
This method checks the LastStatus property of the underlying DicomAssociation object, and returns 0 if it is a success status. If false, the default error message together with error code is logged.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Class
DicomPrint Members


Close Method (DicomPrint)

Close Method (DicomPrint)

DicomObjects Namespace > DicomPrint Class : Close Method
Closes an association to a DICOM printer, completing any pending print operations
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Close()
'Usage

Dim instance As DicomPrint

instance.Close()
public void Close()
public:
void Close();
Remarks

It is often not necessary to call this method explicitly, as it is called automatically then the DicomPrint object goes out of scope.

Any pending film boxes are printed (using an implicit PrintFilm method) before the association is closed.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Class
DicomPrint Members


Open Method (DicomPrint)

Open Method (DicomPrint)

DicomObjects Namespace > DicomPrint Class : Open Method

Network address (as dotted notation or resolvable name) to which the association is to be made

Port on which remote application is listening

Name to quote for this Application Entity

Name of remote Application Entity

Opens an association to a DICOM printer for printing
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Open( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAE As String, _
   ByVal CalledAE As String _
)
'Usage

Dim instance As DicomPrint
Dim Node As String
Dim Port As Integer
Dim CallingAE As String
Dim CalledAE As String

instance.Open(Node, Port, CallingAE, CalledAE)
public void Open(
   string Node,
   int Port,
   string CallingAE,
   string CalledAE
)
public:
void Open(
   String^ Node,
   int Port,
   String^ CallingAE,
   String^ CalledAE
)

Parameters

Node

Network address (as dotted notation or resolvable name) to which the association is to be made

Port

Port on which remote application is listening

CallingAE

Name to quote for this Application Entity

CalledAE

Name of remote Application Entity

Remarks

This method opens a new connection to the destination specified by the Node and Port property.

Although no result is returned, success at subsequent statements can always be assumed, as failure will produce a trappable error (error like "Fail to connection at TCP level" etc.).

As part of this method the well-known printer object is retrieved, so after this call, the Printer property becomes valid.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Class
DicomPrint Members


PrintFilm Method

PrintFilm Method

DicomObjects Namespace > DicomPrint Class : PrintFilm Method
Print current film
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub PrintFilm()
'Usage

Dim instance As DicomPrint

instance.PrintFilm()
public void PrintFilm()
public:
void PrintFilm();
Remarks
This method is implicitly called once a film becomes "full" as a result of PrintImage calls, or when Close is called but this method is provided for those wishing to flush a film to start subsequent images on a new sheet.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Class
DicomPrint Members


PrintImage Method

PrintImage Method

DicomObjects Namespace > DicomPrint Class : PrintImage Method

The image to print

If true, the image is presumed to be pre-formatted (e.g. from a PrinterImage method), and is sent without modification, but if false (the norm), then an internal PrinterImage method is called first, thereby "fixing" the windowing, and (if UseLabels is true) adding any annotations.

If Raw is false, and this parameter is true, then any DicomLabels or DICOM annotations are "burnt-in" to the pixel data before the image is sent to the printer.

Sends an image to the printer
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub PrintImage( _
   ByVal Image As DicomImage, _
   ByVal Raw As Boolean, _
   ByVal UseLabels As Boolean _
)
'Usage

Dim instance As DicomPrint
Dim Image As DicomImage
Dim Raw As Boolean
Dim UseLabels As Boolean

instance.PrintImage(Image, Raw, UseLabels)
public void PrintImage(
   DicomImage Image,
   bool Raw,
   bool UseLabels
)
public:
void PrintImage(
   DicomImage^ Image,
   bool Raw,
   bool UseLabels
)

Parameters

Image

The image to print

Raw

If true, the image is presumed to be pre-formatted (e.g. from a PrinterImage method), and is sent without modification, but if false (the norm), then an internal PrinterImage method is called first, thereby "fixing" the windowing, and (if UseLabels is true) adding any annotations.

UseLabels

If Raw is false, and this parameter is true, then any DicomLabels or DICOM annotations are "burnt-in" to the pixel data before the image is sent to the printer.

Remarks
Unless the order is altered explicitly using NextPosition or PrintFilm, images are put into each of the image boxes on the film in the default order, and each film is printed once full.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Class
DicomPrint Members


DicomPrint Class Properties

DicomPrint Class Properties

DicomObjects Namespace : DicomPrint Class

For a list of all members of this type, see DicomPrint members.

Public Properties
 | Name | Description
Public Property | AnnotationFormat | Common printing variable, the annotation format
Public Property | Annotations | DataSets containing annotations to add to a film
Public Property | BitDepth | The bit depth to send to the printer
Public Property | Colour | Controls whether monochrome of colour printing is attempted
Public Property | Connection | Reference to the underlying DicomAssociation object used by a DicomPrint object
Public Property | Copies | Common printing variable, number of copies to print
Public Property | FilmBox | Over-rides of default values for Film Box Object
Public Property | FilmSize | Common printing variable, the size of the film
Public Property | Format | Common printing variable, the printing format
Public Property | ImageBox | Over-rides of default values for Image Box Object
Public Property | MetaSOPClass | Returns the Meta SOP Class used during the printing session
Public Property | NextPosition | Indicates/Controls the next image box to be used by PrintImage
Public Property | Orientation | Common printing variable, the printing orientation
Public Property | Printer | The well known Printer Instance (as a DicomDataSet)
Public Property | Session | Over-rides of default values for Film Session Object
Public Property | Tag | A general purpose Tag for developer use
Top
See Also

Reference

DicomPrint Class
DicomObjects Namespace


AnnotationFormat Property

AnnotationFormat Property

DicomObjects Namespace > DicomPrint Class : AnnotationFormat Property
Common printing variable, the annotation format
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AnnotationFormat As String
'Usage

Dim instance As DicomPrint
Dim value As String

instance.AnnotationFormat = value

value = instance.AnnotationFormat
public string AnnotationFormat {get; set;}
public:
property String^ AnnotationFormat {
   String^ get();
   void set (    String^ value);
}
Remarks

FilmSize, Orientation, Format, AnnotationFormat and Copies, these are the most commonly used variables when printing so they are given names, so that users do not need to remember the attribute tags for each, and which of the DataSets they apply to. These properties are simply shortcuts to values in Session or FilmBox. The equivalences and default values are as below:

Property | DataSet | Tags | Default Value
FilmSize | FilmBox | 2010, 0050 | blank (printer default)
Orientation | FilmBox | 2010, 0040 | "PORTRAIT"
Format | FilmBox | 2010, 0010 | "STANDARD\1,1"
AnnotationFormat | FilmBox | 2010, 0030 | blank
Copies | Session | 2000, 0010 | 1

Note that the "X" in the FilmSize value must be a capital letter !

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Class
DicomPrint Members


Annotations Property

Annotations Property

DicomObjects Namespace > DicomPrint Class : Annotations Property
DataSets containing annotations to add to a film
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Annotations As DicomDataSetCollection
'Usage

Dim instance As DicomPrint
Dim value As DicomDataSetCollection

value = instance.Annotations
public DicomDataSetCollection Annotations {get;}
public:
property DicomDataSetCollection^ Annotations {
   DicomDataSetCollection^ get();
}
Remarks
Annotations allow one or more items of text to be added to each film printed (not each image). They are very printer-dependent, and many printers do not support them at all. The number and placement depend on the annotation format ID, which in DicomObjects should be placed, before the FilmBox is created in the AnnotationFormat property. Each DicomDataSet in this collection corresponds to one annotation, and they must be added with appropriate tags (2030,0010 for the ID and 2030,0020 for the text). Alternatively, the AddAnnotation method may be used.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Class
DicomPrint Members


BitDepth Property

BitDepth Property

DicomObjects Namespace > DicomPrint Class : BitDepth Property
The bit depth to send to the printer
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BitDepth As Integer
'Usage

Dim instance As DicomPrint
Dim value As Integer

instance.BitDepth = value

value = instance.BitDepth
public int BitDepth {get; set;}
public:
property int BitDepth {
   int get();
   void set (    int value);
}
Remarks

Not all printers support the same bit depths, and PrintImage uses this property to ensure that images are rendered to the appropriate number of bits before being sent to the printer (though if the Raw parameter is true, this becomes the user’s responsibility).

Default value is 12. See DicomPrint for more details of initial values.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Class
DicomPrint Members


Colour Property

Colour Property

DicomObjects Namespace > DicomPrint Class : Colour Property
Controls whether monochrome of colour printing is attempted
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Colour As Boolean
'Usage

Dim instance As DicomPrint
Dim value As Boolean

instance.Colour = value

value = instance.Colour
public bool Colour {get; set;}
public:
property bool Colour {
   bool get();
   void set (    bool value);
}
Remarks
If true, then the DicomPrint object attempts to use the Basic Colour Print Meta SOP Class, but if false, then he Basic GreyScale Print Meta SOP Class is used. The film box classes are also changed to suit, and PrintImage uses this property to ensure that images are rendered appropriately (though if the Raw parameter is true, this becomes the user's responsibility).
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Class
DicomPrint Members


Connection Property

Connection Property

DicomObjects Namespace > DicomPrint Class : Connection Property
Reference to the underlying DicomAssociation object used by a DicomPrint object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Connection As DicomAssociation
'Usage

Dim instance As DicomPrint
Dim value As DicomAssociation

value = instance.Connection
public DicomAssociation Connection {get;}
public:
property DicomAssociation^ Connection {
   DicomAssociation^ get();
}

Property Value

The underlying DicomAssociation
Remarks
This property is useful when extra operations are required over a print association, and enables the user to use the simplified interface provided by DicomPrint object, yet still have flexibility to make arbitrary requests. In particular, it can be used to N-GET the well-known printer instance during an association to check for the printer's status.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Class
DicomPrint Members


Copies Property

Copies Property

DicomObjects Namespace > DicomPrint Class : Copies Property
Common printing variable, number of copies to print
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Copies As Short
'Usage

Dim instance As DicomPrint
Dim value As Short

instance.Copies = value

value = instance.Copies
public short Copies {get; set;}
public:
property short Copies {
   short get();
   void set (    short value);
}
Remarks

FilmSize, Orientation, Format, AnnotationFormat and Copies, these are the most commonly used variables when printing so they are given names, so that users do not need to remember the attribute tags for each, and which of the DataSets they apply to. These properties are simply shortcuts to values in Session or FilmBox. The equivalences and default values are as below:

Property | DataSet | Tags | Default Value
FilmSize | FilmBox | 2010, 0050 | blank (printer default)
Orientation | FilmBox | 2010, 0040 | "PORTRAIT"
Format | FilmBox | 2010, 0010 | "STANDARD\1,1"
AnnotationFormat | FilmBox | 2010, 0030 | blank
Copies | Session | 2000, 0010 | 1

Note that the "X" in the FilmSize value must be a capital letter, for example, 512X512.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Class
DicomPrint Members


FilmBox Property

FilmBox Property

DicomObjects Namespace > DicomPrint Class : FilmBox Property
Over-rides of default values for Film Box Object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property FilmBox As DicomDataSet
'Usage

Dim instance As DicomPrint
Dim value As DicomDataSet

value = instance.FilmBox
public DicomDataSet FilmBox {get;}
public:
property DicomDataSet^ FilmBox {
   DicomDataSet^ get();
}
Remarks

When this object is created during printing, values can be passed in the N-CREATE message, and the resulting dataset is retrieved. This property allows the initial values to be set to any non-default values needed.

Some of the more commonly used properties have been given their own properties of the DicomPrint objects. These are FilmSize, Orientation, Format & AnnotationFormat. Values placed in the FilmBox object immediately update the corresponding values elements in the FilmBox property.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Class
DicomPrint Members


FilmSize Property

FilmSize Property

DicomObjects Namespace > DicomPrint Class : FilmSize Property
Common printing variable, the size of the film
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FilmSize As String
'Usage

Dim instance As DicomPrint
Dim value As String

instance.FilmSize = value

value = instance.FilmSize
public string FilmSize {get; set;}
public:
property String^ FilmSize {
   String^ get();
   void set (    String^ value);
}
Remarks

FilmSize, Orientation, Format, AnnotationFormat and Copies, these are the most commonly used variables when printing so they are given names, so that users do not need to remember the attribute tags for each, and which of the DataSets they apply to. These properties are simply shortcuts to values in Session or FilmBox. The equivalences and default values are as below:

Property | DataSet | Tags | Default Value
FilmSize | FilmBox | 2010, 0050 | blank (printer default)
Orientation | FilmBox | 2010, 0040 | "PORTRAIT"
Format | FilmBox | 2010, 0010 | "STANDARD\1,1"
AnnotationFormat | FilmBox | 2010, 0030 | blank
Copies | Session | 2000, 0010 | 1

Note that the "X" in the FilmSize value must be a capital letter !

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Class
DicomPrint Members


Format Property

Format Property

DicomObjects Namespace > DicomPrint Class : Format Property
Common printing variable, the printing format
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Format As String
'Usage

Dim instance As DicomPrint
Dim value As String

instance.Format = value

value = instance.Format
public string Format {get; set;}
public:
property String^ Format {
   String^ get();
   void set (    String^ value);
}
Remarks

FilmSize, Orientation, Format, AnnotationFormat and Copies, these are the most commonly used variables when printing so they are given names, so that users do not need to remember the attribute tags for each, and which of the DataSets they apply to. These properties are simply shortcuts to values in Session or FilmBox. The equivalences and default values are as below:

Property | DataSet | Tags | Default Value
FilmSize | FilmBox | 2010, 0050 | blank (printer default)
Orientation | FilmBox | 2010, 0040 | "PORTRAIT"
Format | FilmBox | 2010, 0010 | "STANDARD\1,1"
AnnotationFormat | FilmBox | 2010, 0030 | blank
Copies | Session | 2000, 0010 | 1

Note that the "X" in the FilmSize value must be a capital letter !

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Class
DicomPrint Members


ImageBox Property

ImageBox Property

DicomObjects Namespace > DicomPrint Class : ImageBox Property
Over-rides of default values for Image Box Object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ImageBox As DicomDataSet
'Usage

Dim instance As DicomPrint
Dim value As DicomDataSet

value = instance.ImageBox
public DicomDataSet ImageBox {get;}
public:
property DicomDataSet^ ImageBox {
   DicomDataSet^ get();
}
Remarks
When this object is created during printing, values can be passed in the N-CREATE message, and the resulting dataset is retrieved. This property allows the initial values to be set to any non-default values needed.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Class
DicomPrint Members


MetaSOPClass Property (DicomPrint)

MetaSOPClass Property (DicomPrint)

DicomObjects Namespace > DicomPrint Class : MetaSOPClass Property
Returns the Meta SOP Class used during the printing session
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property MetaSOPClass As String
'Usage

Dim instance As DicomPrint
Dim value As String

value = instance.MetaSOPClass
public string MetaSOPClass {get;}
public:
property String^ MetaSOPClass {
   String^ get();
}
Remarks
Returns Meta_BasicColorPrintSOP Class UID "1.2.840.10008.5.1.1.18" if printing in color, otherwise returns BasicGrayscalePrint SOP Class UID "1.2.840.10008.5.1.1.9".
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Class
DicomPrint Members


NextPosition Property

NextPosition Property

DicomObjects Namespace > DicomPrint Class : NextPosition Property
Indicates/Controls the next image box to be used by PrintImage
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NextPosition As Integer
'Usage

Dim instance As DicomPrint
Dim value As Integer

instance.NextPosition = value

value = instance.NextPosition
public int NextPosition {get; set;}
public:
property int NextPosition {
   int get();
   void set (    int value);
}
Remarks
The value ranges from 1 to n where n is the number of image boxes in the current film box, which in turn depends on the value of Format. If this property is not altered, then images are printed sequentially.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Class
DicomPrint Members


Orientation Property

Orientation Property

DicomObjects Namespace > DicomPrint Class : Orientation Property
Common printing variable, the printing orientation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Orientation As String
'Usage

Dim instance As DicomPrint
Dim value As String

instance.Orientation = value

value = instance.Orientation
public string Orientation {get; set;}
public:
property String^ Orientation {
   String^ get();
   void set (    String^ value);
}
Remarks

FilmSize, Orientation, Format, AnnotationFormat and Copies, these are the most commonly used variables when printing so they are given names, so that users do not need to remember the attribute tags for each, and which of the DataSets they apply to. These properties are simply shortcuts to values in Session or FilmBox. The equivalences and default values are as below:

Property | DataSet | Tags | Default Value
FilmSize | FilmBox | 2010, 0050 | blank (printer default)
Orientation | FilmBox | 2010, 0040 | "PORTRAIT"
Format | FilmBox | 2010, 0010 | "STANDARD\1,1"
AnnotationFormat | FilmBox | 2010, 0030 | blank
Copies | Session | 2000, 0010 | 1

Note that the "X" in the FilmSize value must be a capital letter !

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Class
DicomPrint Members


Printer Property

Printer Property

DicomObjects Namespace > DicomPrint Class : Printer Property
The well known Printer Instance (as a DicomDataSet)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Printer As DicomDataSet
'Usage

Dim instance As DicomPrint
Dim value As DicomDataSet

value = instance.Printer
public DicomDataSet Printer {get;}
public:
property DicomDataSet^ Printer {
   DicomDataSet^ get();
}
Remarks

When the DicomPrint's Open method is called, the well-known SOP instance representing the printer is retrieved, and placed into this property, which may allow some useful information about the printer and it’s current state to be determined before attempting to print any images.

Please check the printer’s conformance statement for more details of what information may be available.

To get updated information after the initial connection, use an NGet operation on the DicomAssociation object.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Class
DicomPrint Members


Session Property

Session Property

DicomObjects Namespace > DicomPrint Class : Session Property
Over-rides of default values for Film Session Object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Session As DicomDataSet
'Usage

Dim instance As DicomPrint
Dim value As DicomDataSet

value = instance.Session
public DicomDataSet Session {get;}
public:
property DicomDataSet^ Session {
   DicomDataSet^ get();
}
Remarks

When this object is created during printing, values can be passed in the N-CREATE message, and the resulting dataset is retrieved. This property allows the initial values to be set to any non-default values needed.

Values placed in the Copies property of DicomPrint object will immediately update the corresponding value element in the Session property.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Class
DicomPrint Members


Tag Property (DicomPrint)

Tag Property (DicomPrint)

DicomObjects Namespace > DicomPrint Class : Tag Property
A general purpose Tag for developer use
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Tag As Object
'Usage

Dim instance As DicomPrint
Dim value As Object

instance.Tag = value

value = instance.Tag
public object Tag {get; set;}
public:
property Object^ Tag {
   Object^ get();
   void set (    Object^ value);
}
Remarks
This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomPrint Class
DicomPrint Members


DicomQuery Class

DicomQuery Class
Members

DicomObjects Namespace : DicomQuery Class
Object used for DICOM Query/retrieve SCU operations
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomQuery
'Usage

Dim instance As DicomQuery
public class DicomQuery
public ref class DicomQuery
Remarks

A DicomQuery Object that facilitates the querying of information and retrieval of images from DICOM servers that support the Query/Retrieve protocols as a Service Class Provider (SCP)

A useful feature of this object is that is re-usable, so as the user descends though a hierarchical search, new constraints may be added, and the search repeated, with having to re-set those already used.

The query object can be used either to retrieve images to itself for data extraction, conversion to JPEG etc., or it may initiate DICOM C-MOVE requests to send the images to another entity, commonly a DicomServer control.

Inheritance Hierarchy

System.Object
DicomObjects.DicomQuery

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Members
DicomObjects Namespace


DicomQuery Class Members

DicomQuery Class Members
Properties Methods Events

DicomObjects Namespace : DicomQuery Class

The following tables list the members exposed by DicomQuery.

Public Constructors
 | Name | Description
Public Constructor | DicomQuery Constructor | Create a new DicomQuery Object
Top
Public Properties
 | Name | Description
Public Property | CalculatedFrameList | Specify the list of frames (by triplets with the starting frame, ending frame and frame step) for Frame Level Retrival
Public Property | CalledAE | The Application Entity Title of the server providing the Query/Retrieve service to which the DicomQuery object is requesting a connection
Public Property | CallingAE | The Application Entity Title by which the DicomQuery object is to be known during its connection to the server providing the Query/Retrieve service
Public Property | DateOfBirth | Demographic details of the patient
Public Property | Destination | The Application Entity Name to which images should be sent by a C-MOVE request
Public Property | FrameTimes | Specify the range of frames by frame time, used for Frame Level Retrival
Public Property | InstanceUID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Level | Define the level of query or retrieve request within the DICOM search hierarchies.
Public Property | Name | Demographic details of the patient
Public Property | NoBulkData | Specify if bulk data is required in the FrameLevelRetrieve C-GET response
Public Property | Node | The IP address at which the Query/Retrieve service to which the DicomQuery object is requesting a connection may be found
Public Property | PatientID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Port | The TCP port at which the Query/Retrieve service to which the DicomQuery object is requesting a connection is listening
Public Property | Root | Define the type of query requested within the DICOM search hierarchies.
Public Property | SeriesUID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Sex | Demographic details of the patient
Public Property | SimpleFrameList | Specify the list of single frames (by frame number) for Frame Level Retrival
Public Property | StudyDate | The date or date range to be searched for suitable studies
Public Property | StudyUID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Tag | A general purpose Tag for developer use
Public Property | TransferSyntaxes | Controls the allowed transfer syntaxes for outgoing operations (C-FIND, C-MOVE & C-GET)
Top
Public Methods
 | Name | Description
Public Method | Find | Overloaded. Perform a C-FIND as SCU
Public Method | Get | Overloaded. Perform a C-GET as SCU
Public Method | Move | Overloaded. Perform a C-MOVE as SCU
Public Method | QueryDataSet | Returns the dataset which would have been used by Find method.
Public Method | RetrieveDataSet | Returns the DataSet which would have been used by Get or Move method
Top
Public Events
 | Name | Description
Public Event | InitiateTls | Routine to use to generate encrypted stream when TLS is to be used for outgoing associations.
Public Event | ResponseReceived | Event fires when a response is received on an out-going operation
Top
See Also

Reference

DicomQuery Class
DicomObjects Namespace


DicomQuery Constructor

DicomQuery Constructor

DicomObjects Namespace > DicomQuery Class : DicomQuery Constructor
Create a new DicomQuery Object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DicomQuery()
public DicomQuery()
public:
DicomQuery();

Return Value

DicomQuery
Remarks
This is the Constructor method.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


DicomQuery Class Methods

DicomQuery Class Methods

DicomObjects Namespace : DicomQuery Class

For a list of all members of this type, see DicomQuery members.

Public Methods
 | Name | Description
Public Method | Find | Overloaded. Perform a C-FIND as SCU
Public Method | Get | Overloaded. Perform a C-GET as SCU
Public Method | Move | Overloaded. Perform a C-MOVE as SCU
Public Method | QueryDataSet | Returns the dataset which would have been used by Find method.
Public Method | RetrieveDataSet | Returns the DataSet which would have been used by Get or Move method
Top
See Also

Reference

DicomQuery Class
DicomObjects Namespace


Find Method (DicomQuery)

Find Method (DicomQuery)

DicomObjects Namespace > DicomQuery Class : Find Method
Perform a C-FIND as SCU
Overload List
Overload | Description
Find(DicomDataSet) | Perform a C-FIND as SCU with search criteria.
Find() | Perform a C-FIND as SCU without any search criteria.
Find(DicomAssociation,DicomDataSet) | Perform a C-FIND as SCU with search criteria.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


Find(DicomDataSet) Method

Find(DicomDataSet) Method

DicomObjects Namespace > DicomQuery Class > Find Method : Find(DicomDataSet) Method

DicomDataSet containing the search criteria

Perform a C-FIND as SCU with search criteria.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Find( _
   ByVal Request As DicomDataSet _
) As DicomDataSetCollection
'Usage

Dim instance As DicomQuery
Dim Request As DicomDataSet
Dim value As DicomDataSetCollection

value = instance.Find(Request)
public DicomDataSetCollection Find(
   DicomDataSet Request
)
public:
DicomDataSetCollection^ Find(
   DicomDataSet^ Request
)

Parameters

Request

DicomDataSet containing the search criteria

Return Value

DicomDataSetCollection
Remarks
This method is intended for advanced users, requiring more control over the query than can be achieved using the Query object's standard properties, and methods. Note that the Level value (Attribute 0008, 0052) where relevant must be included in the DataSet parameter. (For e.g. Level is not required for MWL query but it is required when quering for Patients, Studies, Series or Instances directly)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members
Overload List


Find() Method

Find() Method

DicomObjects Namespace > DicomQuery Class > Find Method : Find() Method
Perform a C-FIND as SCU without any search criteria.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Find() As DicomDataSetCollection
'Usage

Dim instance As DicomQuery
Dim value As DicomDataSetCollection

value = instance.Find()
public DicomDataSetCollection Find()
public:
DicomDataSetCollection^ Find();

Return Value

DicomDataSetCollection
Remarks

This method takes no parameters, as all values are set as properties of the DicomQuery Object.

The returned value is an object of type DicomDataSetCollection, containing one or more DicomDataSet for each single successful match. An unsuccessful search produces no error, but the Count property of the returned DicomDataSetCollection object will be Zero.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members
Overload List


Find(DicomAssociation,DicomDataSet) Method

Find(DicomAssociation,DicomDataSet) Method

DicomObjects Namespace > DicomQuery Class > Find Method : Find(DicomAssociation,DicomDataSet) Method

DicomAssociation Exposes the underlying DICOM association object

DicomDataSet containing the search criteria

Perform a C-FIND as SCU with search criteria.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Find( _
   ByVal Association As DicomAssociation, _
   ByVal Request As DicomDataSet _
) As DicomDataSetCollection
'Usage

Dim instance As DicomQuery
Dim Association As DicomAssociation
Dim Request As DicomDataSet
Dim value As DicomDataSetCollection

value = instance.Find(Association, Request)
public DicomDataSetCollection Find(
   DicomAssociation Association,
   DicomDataSet Request
)
public:
DicomDataSetCollection^ Find(
   DicomAssociation^ Association,
   DicomDataSet^ Request
)

Parameters

Association

DicomAssociation Exposes the underlying DICOM association object

Request

DicomDataSet containing the search criteria

Return Value

DicomDataSetCollection
Remarks
This method is based on the Find(DicomDataSet) method, but user can create their own DicomAssociation object so that access to other data, for example lastStatus, error message, can be available
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members
Overload List


Get Method (DicomQuery)

Get Method (DicomQuery)

DicomObjects Namespace > DicomQuery Class : Get Method
Perform a C-GET as SCU
Overload List
Overload | Description
Get() | Perform a C-GET as SCU without any search criteria
Get(DicomDataSet) | Perform a C-GET as SCU with matching criteria
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


Get() Method

Get() Method

DicomObjects Namespace > DicomQuery Class > Get Method : Get() Method
Perform a C-GET as SCU without any search criteria
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Get() As DicomDataSetCollection
'Usage

Dim instance As DicomQuery
Dim value As DicomDataSetCollection

value = instance.Get()
public DicomDataSetCollection Get()
public:
DicomDataSetCollection^ Get();

Return Value

DicomDataSetCollection
Remarks

This method takes no parameters, as all values are set as properties of the DicomQuery object.

The returned value is an object of type DicomDataSetCollection, containing one DicomImage for each successful match. An unsuccessful retrieval produces no error, but the Count property of the returned DicomImages objects will be zero.

Note that many servers do not support the C-GET protocol required for this method, requiring instead C-MOVE. In this case, use the Move method instead.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members
Overload List


Get(DicomDataSet) Method

Get(DicomDataSet) Method

DicomObjects Namespace > DicomQuery Class > Get Method : Get(DicomDataSet) Method

DicomDataSet containing the search criteria

Perform a C-GET as SCU with matching criteria
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Get( _
   ByVal Request As DicomDataSet _
) As DicomDataSetCollection
'Usage

Dim instance As DicomQuery
Dim Request As DicomDataSet
Dim value As DicomDataSetCollection

value = instance.Get(Request)
public DicomDataSetCollection Get(
   DicomDataSet Request
)
public:
DicomDataSetCollection^ Get(
   DicomDataSet^ Request
)

Parameters

Request

DicomDataSet containing the search criteria

Return Value

DicomDataSetCollection

Remarks

This method is intended for advanced users, requiring more control over the query DataSet than can be achieved using the Query object's standard properties, and methods. Note that the Level value (Attribute 0008, 0052), must be included in the DataSet.

The returned value is an object of type DicomDataSetCollection, containing one DicomImage for each successful match. An unsuccessful retrieval produces no error, but the Count property of the returned DicomImages objects will be zero.

Note that many servers do not support the C-GET protocol required for this method, requiring instead C-MOVE. In this case, use the Move method instead.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members
Overload List


Move Method (DicomQuery)

Move Method (DicomQuery)

DicomObjects Namespace > DicomQuery Class : Move Method
Perform a C-MOVE as SCU
Overload List
Overload | Description
Move() | Perform a C-MOVE as SCU without any search criteria
Move(DicomDataSet) | Perform a C-MOVE as SCU with matching criteria
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


Move() Method

Move() Method

DicomObjects Namespace > DicomQuery Class > Move Method : Move() Method
Perform a C-MOVE as SCU without any search criteria
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Move() As DicomDataSet
'Usage

Dim instance As DicomQuery
Dim value As DicomDataSet

value = instance.Move()
public DicomDataSet Move()
public:
DicomDataSet^ Move();

Return Value

DicomDataSet, which contains the final response from SCP.
Remarks

This method takes no parameters, as all values are set as properties of the DicomQuery Object.

Images are requested to be transferred to the application entity specified by the DicomQuery object's Destination property.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members
Overload List


Move(DicomDataSet) Method

Move(DicomDataSet) Method

DicomObjects Namespace > DicomQuery Class > Move Method : Move(DicomDataSet) Method

DicomDataSet containing the search criteria

Perform a C-MOVE as SCU with matching criteria
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Move( _
   ByVal Request As DicomDataSet _
) As DicomDataSet
'Usage

Dim instance As DicomQuery
Dim Request As DicomDataSet
Dim value As DicomDataSet

value = instance.Move(Request)
public DicomDataSet Move(
   DicomDataSet Request
)
public:
DicomDataSet^ Move(
   DicomDataSet^ Request
)

Parameters

Request

DicomDataSet containing the search criteria

Return Value

DicomDataSet, which contains the final response from SCP.
Remarks

This method is intended for advanced users, requiring more control over the query DataSet than can be achieved using the Query object's standard properties, and methods. Note that the Level value (Attribute 0008, 0052), must be included in the DataSet.

Images are requested to be transferred to the application entity specified by the DicomQuery object's Destination property.

Final status of the MOVE operation can be obtained in Attribute [0x0000, 0x0900] of the returned DataSet.

Responses during the entire C-MOVE operation can be obtained in the DicomQuery's ResponseReceived Event.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members
Overload List


QueryDataSet Method

QueryDataSet Method

DicomObjects Namespace > DicomQuery Class : QueryDataSet Method
Returns the dataset which would have been used by Find method.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function QueryDataSet() As DicomDataSet
'Usage

Dim instance As DicomQuery
Dim value As DicomDataSet

value = instance.QueryDataSet()
public DicomDataSet QueryDataSet()
public:
DicomDataSet^ QueryDataSet();

Return Value

DicomDataSet
Remarks
This method returns exactly the same dataset that would have been used for a Find method, which depends on most of the other DicomQuery parameters such as Root, Level etc. The result is suitable for passing to Find, normally after some modification/addition and this method is particularly useful where a slight variation on the “standard” queries generated by Find is required, but the user does not wish to generate a whole new dataset from scratch.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


RetrieveDataSet Method

RetrieveDataSet Method

DicomObjects Namespace > DicomQuery Class : RetrieveDataSet Method
Returns the DataSet which would have been used by Get or Move method
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function RetrieveDataSet() As DicomDataSet
'Usage

Dim instance As DicomQuery
Dim value As DicomDataSet

value = instance.RetrieveDataSet()
public DicomDataSet RetrieveDataSet()
public:
DicomDataSet^ RetrieveDataSet();

Return Value

DicomDataSet
Remarks
This method returns the DataSet which would have been used for a Get or Move method. Request level is set and UIDs are set according to the value of the level. If Patient Level then PatientID is set; if Study Level then PatientID and StudyUID are set; if Series Level then then PatientID, StudyUID and SeriesUID are set; if Image Level then PatientID, StudyUID, SeriesUID and InstanceUID are set.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


DicomQuery Class Properties

DicomQuery Class Properties

DicomObjects Namespace : DicomQuery Class

For a list of all members of this type, see DicomQuery members.

Public Properties
 | Name | Description
Public Property | CalculatedFrameList | Specify the list of frames (by triplets with the starting frame, ending frame and frame step) for Frame Level Retrival
Public Property | CalledAE | The Application Entity Title of the server providing the Query/Retrieve service to which the DicomQuery object is requesting a connection
Public Property | CallingAE | The Application Entity Title by which the DicomQuery object is to be known during its connection to the server providing the Query/Retrieve service
Public Property | DateOfBirth | Demographic details of the patient
Public Property | Destination | The Application Entity Name to which images should be sent by a C-MOVE request
Public Property | FrameTimes | Specify the range of frames by frame time, used for Frame Level Retrival
Public Property | InstanceUID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Level | Define the level of query or retrieve request within the DICOM search hierarchies.
Public Property | Name | Demographic details of the patient
Public Property | NoBulkData | Specify if bulk data is required in the FrameLevelRetrieve C-GET response
Public Property | Node | The IP address at which the Query/Retrieve service to which the DicomQuery object is requesting a connection may be found
Public Property | PatientID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Port | The TCP port at which the Query/Retrieve service to which the DicomQuery object is requesting a connection is listening
Public Property | Root | Define the type of query requested within the DICOM search hierarchies.
Public Property | SeriesUID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Sex | Demographic details of the patient
Public Property | SimpleFrameList | Specify the list of single frames (by frame number) for Frame Level Retrival
Public Property | StudyDate | The date or date range to be searched for suitable studies
Public Property | StudyUID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Tag | A general purpose Tag for developer use
Public Property | TransferSyntaxes | Controls the allowed transfer syntaxes for outgoing operations (C-FIND, C-MOVE & C-GET)
Top
See Also

Reference

DicomQuery Class
DicomObjects Namespace


CalculatedFrameList Property

CalculatedFrameList Property

DicomObjects Namespace > DicomQuery Class : CalculatedFrameList Property
Specify the list of frames (by triplets with the starting frame, ending frame and frame step) for Frame Level Retrival
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CalculatedFrameList As Integer()
'Usage

Dim instance As DicomQuery
Dim value() As Integer

instance.CalculatedFrameList = value

value = instance.CalculatedFrameList
public int[] CalculatedFrameList {get; set;}
public:
property array<int>^ CalculatedFrameList {
   array<int>^ get();
   void set (    array<int>^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


CalledAE Property

CalledAE Property

DicomObjects Namespace > DicomQuery Class : CalledAE Property
The Application Entity Title of the server providing the Query/Retrieve service to which the DicomQuery object is requesting a connection
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CalledAE As String
'Usage

Dim instance As DicomQuery
Dim value As String

instance.CalledAE = value

value = instance.CalledAE
public string CalledAE {get; set;}
public:
property String^ CalledAE {
   String^ get();
   void set (    String^ value);
}
Remarks
Some servers allow access from any application entity, whilst others must be configured to include a list of "allowable" clients. Whilst this software allows an arbitrary choice of AE name, it would be prudent to keep to a limited, unique list for each machine.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


CallingAE Property

CallingAE Property

DicomObjects Namespace > DicomQuery Class : CallingAE Property
The Application Entity Title by which the DicomQuery object is to be known during its connection to the server providing the Query/Retrieve service
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CallingAE As String
'Usage

Dim instance As DicomQuery
Dim value As String

instance.CallingAE = value

value = instance.CallingAE
public string CallingAE {get; set;}
public:
property String^ CallingAE {
   String^ get();
   void set (    String^ value);
}
Remarks
For most servers this value must be looked up in the server’s documentation, and must be exactly correct for an association to be accepted.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


DateOfBirth Property (DicomQuery)

DateOfBirth Property (DicomQuery)

DicomObjects Namespace > DicomQuery Class : DateOfBirth Property
Demographic details of the patient
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DateOfBirth As String
'Usage

Dim instance As DicomQuery
Dim value As String

instance.DateOfBirth = value

value = instance.DateOfBirth
public string DateOfBirth {get; set;}
public:
property String^ DateOfBirth {
   String^ get();
   void set (    String^ value);
}
Remarks
This property is used as search criteria only when QueryLevel is set to "PATIENT" and this property may be set to a string representing a range of values, but it is the user's responsibility to ensure that this is formatted exactly according to the DICOM standard format i.e. YYYYMMDD-YYYYMMDD.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


Destination Property (DicomQuery)

Destination Property (DicomQuery)

DicomObjects Namespace > DicomQuery Class : Destination Property
The Application Entity Name to which images should be sent by a C-MOVE request
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Destination As String
'Usage

Dim instance As DicomQuery
Dim value As String

instance.Destination = value

value = instance.Destination
public string Destination {get; set;}
public:
property String^ Destination {
   String^ get();
   void set (    String^ value);
}
Remarks
A Query/Retrieve SCP should use this property to find the values of the IP address, port number and possibly calling AET to use before calling the Open method to respond any C-MOVE request.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


FrameTimes Property

FrameTimes Property

DicomObjects Namespace > DicomQuery Class : FrameTimes Property
Specify the range of frames by frame time, used for Frame Level Retrival
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FrameTimes As Date()
'Usage

Dim instance As DicomQuery
Dim value() As Date

instance.FrameTimes = value

value = instance.FrameTimes
public DateTime[] FrameTimes {get; set;}
public:
property array<DateTime>^ FrameTimes {
   array<DateTime>^ get();
   void set (    array<DateTime>^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


InstanceUID Property (DicomQuery)

InstanceUID Property (DicomQuery)

DicomObjects Namespace > DicomQuery Class : InstanceUID Property
Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property InstanceUID As String
'Usage

Dim instance As DicomQuery
Dim value As String

instance.InstanceUID = value

value = instance.InstanceUID
public string InstanceUID {get; set;}
public:
property String^ InstanceUID {
   String^ get();
   void set (    String^ value);
}
Remarks
InstanceUID value is used to uniquely identify each single DICOM instance.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


Level Property (DicomQuery)

Level Property (DicomQuery)

DicomObjects Namespace > DicomQuery Class : Level Property
Define the level of query or retrieve request within the DICOM search hierarchies.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Level As QueryLevel
'Usage

Dim instance As DicomQuery
Dim value As QueryLevel

instance.Level = value

value = instance.Level
public QueryLevel Level {get; set;}
public:
property QueryLevel Level {
   QueryLevel get();
   void set (    QueryLevel value);
}
Remarks

DICOM defines three different hierarchies for image-related Query/Retrieve operations, each of which has different semantics and allowable search levels. The allowable combinations of QueryRoot and QueryLevel are:

Root | PATIENT | STUDY | PATIENTSTUDY
Permitted Levels | PATIENT STUDY SERIES IMAGE | STUDY SERIES IMAGE | PATIENT STUDY

In addition, to the above values, Root may be set to “WORKLIST” to indicate a Modality Worklist query, or “GP-WORKLIST” to indicate a General Purpose Worklist query, but if this is done, then a Find must be performed with a DicomDataSet parameter, as the parameters for the query DataSet are very different to those used for the other queries.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


Name Property (DicomQuery)

Name Property (DicomQuery)

DicomObjects Namespace > DicomQuery Class : Name Property
Demographic details of the patient
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As DicomQuery
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}
Remarks
This property is used as search criteria only when QueryLevel is set to "PATIENT".
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


NoBulkData Property

NoBulkData Property

DicomObjects Namespace > DicomQuery Class : NoBulkData Property
Specify if bulk data is required in the FrameLevelRetrieve C-GET response
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NoBulkData As Boolean
'Usage

Dim instance As DicomQuery
Dim value As Boolean

instance.NoBulkData = value

value = instance.NoBulkData
public bool NoBulkData {get; set;}
public:
property bool NoBulkData {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


Node Property

Node Property

DicomObjects Namespace > DicomQuery Class : Node Property
The IP address at which the Query/Retrieve service to which the DicomQuery object is requesting a connection may be found
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Node As String
'Usage

Dim instance As DicomQuery
Dim value As String

instance.Node = value

value = instance.Node
public string Node {get; set;}
public:
property String^ Node {
   String^ get();
   void set (    String^ value);
}
Remarks
This may be any form of IP address, either dotted numerical or text name, understandable by the machines IP implementation.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


PatientID Property (DicomQuery)

PatientID Property (DicomQuery)

DicomObjects Namespace > DicomQuery Class : PatientID Property
Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PatientID As String
'Usage

Dim instance As DicomQuery
Dim value As String

instance.PatientID = value

value = instance.PatientID
public string PatientID {get; set;}
public:
property String^ PatientID {
   String^ get();
   void set (    String^ value);
}
Remarks

For DicomQuery object, this property must be set for all levels of the hierarchy above the current Level.

e.g. if Root is "PATIENT", and Level is "STUDY" then PatientID must be set to appropriate values.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


Port Property

Port Property

DicomObjects Namespace > DicomQuery Class : Port Property
The TCP port at which the Query/Retrieve service to which the DicomQuery object is requesting a connection is listening
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Port As Integer
'Usage

Dim instance As DicomQuery
Dim value As Integer

instance.Port = value

value = instance.Port
public int Port {get; set;}
public:
property int Port {
   int get();
   void set (    int value);
}
Remarks
The "official" value for DICOM should be 104, but many manufacturers use other values such as 4006. Please check with the documentation of the service provider.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


Root Property (DicomQuery)

Root Property (DicomQuery)

DicomObjects Namespace > DicomQuery Class : Root Property
Define the type of query requested within the DICOM search hierarchies.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Root As QueryRoot
'Usage

Dim instance As DicomQuery
Dim value As QueryRoot

instance.Root = value

value = instance.Root
public QueryRoot Root {get; set;}
public:
property QueryRoot Root {
   QueryRoot get();
   void set (    QueryRoot value);
}
Remarks

DICOM defines three different hierarchies for image-related Query/Retrieve operations, each of which has different semantics and allowable search levels. The allowable combinations of QueryRoot and QueryLevel are:

Root | PATIENT | STUDY | PATIENTSTUDY
Permitted Levels | PATIENT STUDY SERIES IMAGE | STUDY SERIES IMAGE | PATIENT STUDY

In addition, to the above values, Root may be set to “WORKLIST” to indicate a Modality Worklist query, or “GP-WORKLIST” to indicate a General Purpose Worklist query, but if this is done, then a Find must be performed with a DicomDataSet parameter, as the parameters for the query DataSet are very different to those used for the other queries.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


SeriesUID Property (DicomQuery)

SeriesUID Property (DicomQuery)

DicomObjects Namespace > DicomQuery Class : SeriesUID Property
Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SeriesUID As String
'Usage

Dim instance As DicomQuery
Dim value As String

instance.SeriesUID = value

value = instance.SeriesUID
public string SeriesUID {get; set;}
public:
property String^ SeriesUID {
   String^ get();
   void set (    String^ value);
}
Remarks

SeriesUID must be set to appropriate value if Level is "IMAGE".

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


Sex Property (DicomQuery)

Sex Property (DicomQuery)

DicomObjects Namespace > DicomQuery Class : Sex Property
Demographic details of the patient
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Sex As String
'Usage

Dim instance As DicomQuery
Dim value As String

instance.Sex = value

value = instance.Sex
public string Sex {get; set;}
public:
property String^ Sex {
   String^ get();
   void set (    String^ value);
}
Remarks
This property is used as search criteria only when QueryLevel is set to "PATIENT".
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


SimpleFrameList Property

SimpleFrameList Property

DicomObjects Namespace > DicomQuery Class : SimpleFrameList Property
Specify the list of single frames (by frame number) for Frame Level Retrival
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SimpleFrameList As Integer()
'Usage

Dim instance As DicomQuery
Dim value() As Integer

instance.SimpleFrameList = value

value = instance.SimpleFrameList
public int[] SimpleFrameList {get; set;}
public:
property array<int>^ SimpleFrameList {
   array<int>^ get();
   void set (    array<int>^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


StudyDate Property

StudyDate Property

DicomObjects Namespace > DicomQuery Class : StudyDate Property
The date or date range to be searched for suitable studies
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property StudyDate As String
'Usage

Dim instance As DicomQuery
Dim value As String

instance.StudyDate = value

value = instance.StudyDate
public string StudyDate {get; set;}
public:
property String^ StudyDate {
   String^ get();
   void set (    String^ value);
}
Remarks
Like DateOfBirth, this property may either contain a single value, in any form intelligible as a date, or if a range is required, then it must comply exactly with the DICOM format for date ranges, namely YYYYMMDD-YYYYMMDD.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


StudyUID Property (DicomQuery)

StudyUID Property (DicomQuery)

DicomObjects Namespace > DicomQuery Class : StudyUID Property
Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property StudyUID As String
'Usage

Dim instance As DicomQuery
Dim value As String

instance.StudyUID = value

value = instance.StudyUID
public string StudyUID {get; set;}
public:
property String^ StudyUID {
   String^ get();
   void set (    String^ value);
}
Remarks
For DicomQuery object, StudyUID must be set to appropriate value if Level is "SERIES" or "IMAGE".
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


Tag Property (DicomQuery)

Tag Property (DicomQuery)

DicomObjects Namespace > DicomQuery Class : Tag Property
A general purpose Tag for developer use
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Tag As Object
'Usage

Dim instance As DicomQuery
Dim value As Object

instance.Tag = value

value = instance.Tag
public object Tag {get; set;}
public:
property Object^ Tag {
   Object^ get();
   void set (    Object^ value);
}
Remarks
This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


TransferSyntaxes Property

TransferSyntaxes Property

DicomObjects Namespace > DicomQuery Class : TransferSyntaxes Property
Controls the allowed transfer syntaxes for outgoing operations (C-FIND, C-MOVE & C-GET)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TransferSyntaxes As String
'Usage

Dim instance As DicomQuery
Dim value As String

instance.TransferSyntaxes = value

value = instance.TransferSyntaxes
public string TransferSyntaxes {get; set;}
public:
property String^ TransferSyntaxes {
   String^ get();
   void set (    String^ value);
}
Remarks

If blank (the default) the default transfer syntax list specified by the Transfer Syntax Negotiation settings is used.

The list is space separated – e.g. "1.2.840.10008.1.2 1.2.40.10008.1.2.1"

Any syntaxes immediately preceded by an asterisk are sent in their own separate presentation context.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


DicomQuery Class Events

DicomQuery Class Events

DicomObjects Namespace : DicomQuery Class

For a list of all members of this type, see DicomQuery members.

Public Events
 | Name | Description
Public Event | InitiateTls | Routine to use to generate encrypted stream when TLS is to be used for outgoing associations.
Public Event | ResponseReceived | Event fires when a response is received on an out-going operation
Top
See Also

Reference

DicomQuery Class
DicomObjects Namespace


InitiateTls Event (DicomQuery)

InitiateTls Event (DicomQuery)

DicomObjects Namespace > DicomQuery Class : InitiateTls Event
Routine to use to generate encrypted stream when TLS is to be used for outgoing associations.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event InitiateTls As TlsInitiator
'Usage

Dim instance As DicomQuery
Dim handler As TlsInitiator

AddHandler instance.InitiateTls, handler
public event TlsInitiator InitiateTls
public:
event TlsInitiator^ InitiateTls
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


ResponseReceived Event (DicomQuery)

ResponseReceived Event (DicomQuery)

DicomObjects Namespace > DicomQuery Class : ResponseReceived Event
Event fires when a response is received on an out-going operation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event ResponseReceived As ResponseReceivedHandler
'Usage

Dim instance As DicomQuery
Dim handler As ResponseReceivedHandler

AddHandler instance.ResponseReceived, handler
public event ResponseReceivedHandler ResponseReceived
public:
event ResponseReceivedHandler^ ResponseReceived
Remarks

This Event will be generated when any responses are received from the remote application.

This is a direct equivalent of the ResponseReceived event.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomQuery Class
DicomQuery Members


DicomServer Class

DicomServer Class
Members

DicomObjects Namespace : DicomServer Class
An object for handling advanced network communications, as both SCU & SCP
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomServer
'Usage

Dim instance As DicomServer
public class DicomServer
public ref class DicomServer
Example
In general, as much functionality as possible is devolved to the container. For instance, the control does not have its own application entity name, and acceptance or rejection of associations is controlled via an event. This event is given the remote IP address and the calling and called application entity titles, allowing the container to make its own accept/reject decision.
Inheritance Hierarchy

System.Object
DicomObjects.DicomServer

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Members
DicomObjects Namespace


DicomServer Class Members

DicomServer Class Members
Properties Methods Events

DicomObjects Namespace : DicomServer Class

The following tables list the members exposed by DicomServer.

Public Constructors
 | Name | Description
Public Constructor | DicomServer Constructor | Creates a DicomServer object
Top
Public Properties
 | Name | Description
Public Property | AllowExtendedNegotiation | Controls whether extended negotation should be supported (as initiator or acceptor)
Public Property | AssociationCount | The number of associations currently open on this server
Public Property | DefaultStatus | The default status code to be returned in response to incoming requests
Public Property | NewAssociationType | This property is for user derived DicomAssociation
Public Property | Tag | A general purpose Tag for developer use
Top
Public Methods
 | Name | Description
Public Method | AbortAssociations | Aborts all related associations
Public Method | Accept | Means to allow DICOM negotiation on an existing socket
Public Method | Dispose | Release all system resources used by DicomServer object
Public Method | Listen | Overloaded. Open a TCP port to listen for incoming DICOM Connections
Public Method | Unlisten | Overloaded. Close a "Listening" TCP port for incoming DICOM Connections
Public Method | UnlistenAll | Close all "Listening" TCP ports for incoming DICOM Connections
Top
Public Events
 | Name | Description
Public Event | AssociationClosed | Event fired when an incoming DICOM association is closed
Public Event | AssociationRequest | Event fired when the object receives a DICOM connection request
Public Event | ErrorReceived | This event fires when an error is detected in received data
Public Event | InfoMessage | Passes information back to the container for error messages and notifications originating from the DICOM interface.
Public Event | InstanceReceived | This event is fired whenever a C-STORE operation completes, passing details of the instance received
Public Event | N_Event_Report | This event handler is fired on SCU when an N-EVENT-REPORT notification is received from the SCP.
Public Event | NormalisedReceived | This event fires when an incoming normalised request is received
Public Event | QueryReceived | Event fired when the object receives a DICOM C-FIND,C-GET or C-MOVE request
Public Event | ReceivingPixelData | Event called when pixel data is being received
Public Event | VerifyReceived | This event fires when a C-ECHO command (verification request) is received
Top
See Also

Reference

DicomServer Class
DicomObjects Namespace


DicomServer Constructor

DicomServer Constructor

DicomObjects Namespace > DicomServer Class : DicomServer Constructor
Creates a DicomServer object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DicomServer()
public DicomServer()
public:
DicomServer();

Return Value

DicomServer
Remarks
This is the Constructor method.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members


DicomServer Class Methods

DicomServer Class Methods

DicomObjects Namespace : DicomServer Class

For a list of all members of this type, see DicomServer members.

Public Methods
 | Name | Description
Public Method | AbortAssociations | Aborts all related associations
Public Method | Accept | Means to allow DICOM negotiation on an existing socket
Public Method | Dispose | Release all system resources used by DicomServer object
Public Method | Listen | Overloaded. Open a TCP port to listen for incoming DICOM Connections
Public Method | Unlisten | Overloaded. Close a "Listening" TCP port for incoming DICOM Connections
Public Method | UnlistenAll | Close all "Listening" TCP ports for incoming DICOM Connections
Top
See Also

Reference

DicomServer Class
DicomObjects Namespace


AbortAssociations Method

AbortAssociations Method

DicomObjects Namespace > DicomServer Class : AbortAssociations Method
Aborts all related associations
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub AbortAssociations()
'Usage

Dim instance As DicomServer

instance.AbortAssociations()
public void AbortAssociations()
public:
void AbortAssociations();
Remarks
This method aborts all associations (incoming and outgoing) related to the DicomServer object.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members


Accept Method

Accept Method

DicomObjects Namespace > DicomServer Class : Accept Method
The underlying socket
A stream based on that socket
Means to allow DICOM negotiation on an existing socket
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Accept( _
   ByVal Socket As Socket, _
   ByVal Stream As Stream _
)
'Usage

Dim instance As DicomServer
Dim Socket As Socket
Dim Stream As Stream

instance.Accept(Socket, Stream)
public void Accept(
   Socket Socket,
   Stream Stream
)
public:
void Accept(
   Socket^ Socket,
   Stream^ Stream
)

Parameters

Socket
The underlying socket
Stream
A stream based on that socket
Remarks

Normally this is all handled internally by DicomObjects, but this method is provided for developers who may wish to use their own listening and authorisation mechanisms

Note that only one association is allowed per TCP connection, so this does require a "new" TCP connection, though TLS negotiation etc. may of course have been performed.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members


Dispose Method (DicomServer)

Dispose Method (DicomServer)

DicomObjects Namespace > DicomServer Class : Dispose Method
Release all system resources used by DicomServer object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Sub Dispose()
'Usage

Dim instance As DicomServer

instance.Dispose()
public virtual void Dispose()
public:
virtual void Dispose();
Remarks
This is the Destructor method.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members


Listen Method

Listen Method

DicomObjects Namespace > DicomServer Class : Listen Method
Open a TCP port to listen for incoming DICOM Connections
Overload List
Overload | Description
Listen(Int32) | Open a TCP port to listen for incoming DICOM Connections
Listen(Int32,TlsAcceptor) | Open a TCP port to listen for secure incoming DICOM Connections
Listen(Int32,AddressFamily,TlsAcceptor) | Open a TCP port to listen for secure incoming DICOM Connections
Listen(Int32,String) | Open a TCP port to listen for incoming DICOM Connections, specified by port number and IP address
Listen(Int32,String,AddressFamily,TlsAcceptor) | Open a TCP port to listen for secure incoming DICOM Connections on a specific IP address
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members


Listen(Int32) Method

Listen(Int32) Method

DicomObjects Namespace > DicomServer Class > Listen Method : Listen(Int32) Method

The TCP port on which to receive connections

Open a TCP port to listen for incoming DICOM Connections
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Listen( _
   ByVal Port As Integer _
)
'Usage

Dim instance As DicomServer
Dim Port As Integer

instance.Listen(Port)
public void Listen(
   int Port
)
public:
void Listen(
   int Port
)

Parameters

Port

The TCP port on which to receive connections

Remarks

More than one port may be active simultaneously. The listening sockets are all closed when the control is de-activated.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members
Overload List


Listen(Int32,TlsAcceptor) Method

Listen(Int32,TlsAcceptor) Method

DicomObjects Namespace > DicomServer Class > Listen Method : Listen(Int32,TlsAcceptor) Method

The TCP port on which to receive connections

The DicomObjects.Delegates.TlsAcceptor object used to accept secure connections

Open a TCP port to listen for secure incoming DICOM Connections
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Listen( _
   ByVal Port As Integer, _
   ByVal AcceptTls As TlsAcceptor _
)
'Usage

Dim instance As DicomServer
Dim Port As Integer
Dim AcceptTls As TlsAcceptor

instance.Listen(Port, AcceptTls)
public void Listen(
   int Port,
   TlsAcceptor AcceptTls
)
public:
void Listen(
   int Port,
   TlsAcceptor^ AcceptTls
)

Parameters

Port

The TCP port on which to receive connections

AcceptTls

The DicomObjects.Delegates.TlsAcceptor object used to accept secure connections

Remarks

This is the secure equivalent of the Listen method.

Different ports must be used for secure and non-secure associations, as the security negotiation occurs before DICOM negotiation.

More than one port may be active simultaneously. The listening sockets are all closed when the control is de-activated.

Closing a “listening” socket has no effect on currently active associations that connected via that socket.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members
Overload List


Listen(Int32,AddressFamily,TlsAcceptor) Method

Listen(Int32,AddressFamily,TlsAcceptor) Method

DicomObjects Namespace > DicomServer Class > Listen Method : Listen(Int32,AddressFamily,TlsAcceptor) Method

The TCP port on which to receive connections

The address family to use (IPv4 or IPv6)

The DicomObjects.Delegates.TlsAcceptor object used to accept secure connections

Open a TCP port to listen for secure incoming DICOM Connections
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Listen( _
   ByVal Port As Integer, _
   ByVal IpAddressFamily As AddressFamily, _
   ByVal AcceptTls As TlsAcceptor _
)
'Usage

Dim instance As DicomServer
Dim Port As Integer
Dim IpAddressFamily As AddressFamily
Dim AcceptTls As TlsAcceptor

instance.Listen(Port, IpAddressFamily, AcceptTls)
public void Listen(
   int Port,
   AddressFamily IpAddressFamily,
   TlsAcceptor AcceptTls
)
public:
void Listen(
   int Port,
   AddressFamily IpAddressFamily,
   TlsAcceptor^ AcceptTls
)

Parameters

Port

The TCP port on which to receive connections

IpAddressFamily

The address family to use (IPv4 or IPv6)

AcceptTls

The DicomObjects.Delegates.TlsAcceptor object used to accept secure connections

Remarks

This is the secure equivalent of the Listen method.

Different ports must be used for secure and non-secure associations, as the security negotiation occurs before DICOM negotiation.

More than one port may be active simultaneously. The listening sockets are all closed when the control is de-activated.

Closing a “listening” socket has no effect on currently active associations that connected via that socket.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members
Overload List


Listen(Int32,String) Method

Listen(Int32,String) Method

DicomObjects Namespace > DicomServer Class > Listen Method : Listen(Int32,String) Method

The TCP port on which to receive connections

IP address to listen on

Open a TCP port to listen for incoming DICOM Connections, specified by port number and IP address
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Listen( _
   ByVal Port As Integer, _
   ByVal Address As String _
)
'Usage

Dim instance As DicomServer
Dim Port As Integer
Dim Address As String

instance.Listen(Port, Address)
public void Listen(
   int Port,
   string Address
)
public:
void Listen(
   int Port,
   String^ Address
)

Parameters

Port

The TCP port on which to receive connections

Address

IP address to listen on

Remarks

This is the secure equivalent of the Listen method.

Different ports must be used for secure and non-secure associations, as the security negotiation occurs before DICOM negotiation.

More than one port may be active simultaneously. The listening sockets are all closed when the control is de-activated.

Closing a “listening” socket has no effect on currently active associations that connected via that socket.

If the IP address is used, then Address must be either in dotted form, or a resolvable name.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members
Overload List


Listen(Int32,String,AddressFamily,TlsAcceptor) Method

Listen(Int32,String,AddressFamily,TlsAcceptor) Method

DicomObjects Namespace > DicomServer Class > Listen Method : Listen(Int32,String,AddressFamily,TlsAcceptor) Method

The TCP port on which to receive connections

The address to listen on

The address family to use (IPv4 or IPv6)

The DicomObjects.Delegates.TlsAcceptor object used to accept secure connections

Open a TCP port to listen for secure incoming DICOM Connections on a specific IP address
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Listen( _
   ByVal Port As Integer, _
   ByVal Address As String, _
   ByVal IpAddressFamily As AddressFamily, _
   ByVal AcceptTls As TlsAcceptor _
)
'Usage

Dim instance As DicomServer
Dim Port As Integer
Dim Address As String
Dim IpAddressFamily As AddressFamily
Dim AcceptTls As TlsAcceptor

instance.Listen(Port, Address, IpAddressFamily, AcceptTls)
public void Listen(
   int Port,
   string Address,
   AddressFamily IpAddressFamily,
   TlsAcceptor AcceptTls
)
public:
void Listen(
   int Port,
   String^ Address,
   AddressFamily IpAddressFamily,
   TlsAcceptor^ AcceptTls
)

Parameters

Port

The TCP port on which to receive connections

Address

The address to listen on

IpAddressFamily

The address family to use (IPv4 or IPv6)

AcceptTls

The DicomObjects.Delegates.TlsAcceptor object used to accept secure connections

Remarks

This is the secure equivalent of the Listen method.

Different ports must be used for secure and non-secure associations, as the security negotiation occurs before DICOM negotiation.

More than one port may be active simultaneously. The listening sockets are all closed when the control is de-activated.

Closing a “listening” socket has no effect on currently active associations that connected via that socket.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members
Overload List


Unlisten Method

Unlisten Method

DicomObjects Namespace > DicomServer Class : Unlisten Method
Close a "Listening" TCP port for incoming DICOM Connections
Overload List
Overload | Description
Unlisten(Int32) | Close a "Listening" TCP port, specified by the port number, for incoming DICOM Connections
Unlisten(Int32,String) | Close a "Listening" TCP port, specified by the port number and IP address, for incoming DICOM Connections
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members


Unlisten(Int32) Method

Unlisten(Int32) Method

DicomObjects Namespace > DicomServer Class > Unlisten Method : Unlisten(Int32) Method

The port number which is to be closed for incoming connection.

Close a "Listening" TCP port, specified by the port number, for incoming DICOM Connections
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Unlisten( _
   ByVal Port As Integer _
)
'Usage

Dim instance As DicomServer
Dim Port As Integer

instance.Unlisten(Port)
public void Unlisten(
   int Port
)
public:
void Unlisten(
   int Port
)

Parameters

Port

The port number which is to be closed for incoming connection.

Remarks

Closing a “listening” socket has no effect on currently active associations that connected via that socket.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members
Overload List


Unlisten(Int32,String) Method

Unlisten(Int32,String) Method

DicomObjects Namespace > DicomServer Class > Unlisten Method : Unlisten(Int32,String) Method

The port number which is to be closed for incoming connection

IP address to listen on

Close a "Listening" TCP port, specified by the port number and IP address, for incoming DICOM Connections
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Unlisten( _
   ByVal Port As Integer, _
   ByVal Address As String _
)
'Usage

Dim instance As DicomServer
Dim Port As Integer
Dim Address As String

instance.Unlisten(Port, Address)
public void Unlisten(
   int Port,
   string Address
)
public:
void Unlisten(
   int Port,
   String^ Address
)

Parameters

Port

The port number which is to be closed for incoming connection

Address

IP address to listen on

Remarks

Closing a “listening” socket has no effect on currently active associations that connected via that socket.

If the address option is used, then address must be either in dotted form, or a resolvable name.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members
Overload List


UnlistenAll Method

UnlistenAll Method

DicomObjects Namespace > DicomServer Class : UnlistenAll Method
Close all "Listening" TCP ports for incoming DICOM Connections
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub UnlistenAll()
'Usage

Dim instance As DicomServer

instance.UnlistenAll()
public void UnlistenAll()
public:
void UnlistenAll();
Remarks

Since more than one port may be active simultaneously, this method is designed to close all "Listening" socket.

For more information see Unlisten.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members


DicomServer Class Properties

DicomServer Class Properties

DicomObjects Namespace : DicomServer Class

For a list of all members of this type, see DicomServer members.

Public Properties
 | Name | Description
Public Property | AllowExtendedNegotiation | Controls whether extended negotation should be supported (as initiator or acceptor)
Public Property | AssociationCount | The number of associations currently open on this server
Public Property | DefaultStatus | The default status code to be returned in response to incoming requests
Public Property | NewAssociationType | This property is for user derived DicomAssociation
Public Property | Tag | A general purpose Tag for developer use
Top
See Also

Reference

DicomServer Class
DicomObjects Namespace


AllowExtendedNegotiation Property

AllowExtendedNegotiation Property

DicomObjects Namespace > DicomServer Class : AllowExtendedNegotiation Property
Controls whether extended negotation should be supported (as initiator or acceptor)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AllowExtendedNegotiation As Boolean
'Usage

Dim instance As DicomServer
Dim value As Boolean

instance.AllowExtendedNegotiation = value

value = instance.AllowExtendedNegotiation
public bool AllowExtendedNegotiation {get; set;}
public:
property bool AllowExtendedNegotiation {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members


AssociationCount Property

AssociationCount Property

DicomObjects Namespace > DicomServer Class : AssociationCount Property
The number of associations currently open on this server
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property AssociationCount As Integer
'Usage

Dim instance As DicomServer
Dim value As Integer

value = instance.AssociationCount
public int AssociationCount {get;}
public:
property int AssociationCount {
   int get();
}
Remarks
This is a volatile property which can change at any time
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members


DefaultStatus Property

DefaultStatus Property

DicomObjects Namespace > DicomServer Class : DefaultStatus Property
The default status code to be returned in response to incoming requests
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DefaultStatus As Integer
'Usage

Dim instance As DicomServer
Dim value As Integer

instance.DefaultStatus = value

value = instance.DefaultStatus
public int DefaultStatus {get; set;}
public:
property int DefaultStatus {
   int get();
   void set (    int value);
}
Remarks

When incoming requests such as C-STORE, C-ECHO or normalised operations are received, a status code must be returned to the Sender. Normally, this is supplied either by the final value of the "Status" parameter to the VerifyReceived or InstanceReceived event. Under some circumstances, however (such as when a message box is displayed in Visual Basic), events my not be fired, so this property provides a default value. It is used in the following circumstances:

  • It provides the initial value for the Status parameter for an InstanceReceived or VerifyReceved event
  • It provides the definitive value if the appropriate event is not fired or not captured

Servers should normally set this value to a suitable error code, so that sending applications are alerted when an image cannot be handled due to server errors erc.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members


NewAssociationType Property

NewAssociationType Property

DicomObjects Namespace > DicomServer Class : NewAssociationType Property
This property is for user derived DicomAssociation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NewAssociationType As Type
'Usage

Dim instance As DicomServer
Dim value As Type

instance.NewAssociationType = value

value = instance.NewAssociationType
public Type NewAssociationType {get; set;}
public:
property Type^ NewAssociationType {
   Type^ get();
   void set (    Type^ value);
}
Remarks
When deriving a new class from the DicomAssociation class, users can specify in this property the type of the derived Association class so that instances of the derived association used by DicomServer will be created for incoming associations.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members


Tag Property (DicomServer)

Tag Property (DicomServer)

DicomObjects Namespace > DicomServer Class : Tag Property
A general purpose Tag for developer use
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Tag As Object
'Usage

Dim instance As DicomServer
Dim value As Object

instance.Tag = value

value = instance.Tag
public object Tag {get; set;}
public:
property Object^ Tag {
   Object^ get();
   void set (    Object^ value);
}
Remarks
This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members


DicomServer Class Events

DicomServer Class Events

DicomObjects Namespace : DicomServer Class

For a list of all members of this type, see DicomServer members.

Public Events
 | Name | Description
Public Event | AssociationClosed | Event fired when an incoming DICOM association is closed
Public Event | AssociationRequest | Event fired when the object receives a DICOM connection request
Public Event | ErrorReceived | This event fires when an error is detected in received data
Public Event | InfoMessage | Passes information back to the container for error messages and notifications originating from the DICOM interface.
Public Event | InstanceReceived | This event is fired whenever a C-STORE operation completes, passing details of the instance received
Public Event | N_Event_Report | This event handler is fired on SCU when an N-EVENT-REPORT notification is received from the SCP.
Public Event | NormalisedReceived | This event fires when an incoming normalised request is received
Public Event | QueryReceived | Event fired when the object receives a DICOM C-FIND,C-GET or C-MOVE request
Public Event | ReceivingPixelData | Event called when pixel data is being received
Public Event | VerifyReceived | This event fires when a C-ECHO command (verification request) is received
Top
See Also

Reference

DicomServer Class
DicomObjects Namespace


AssociationClosed Event

AssociationClosed Event

DicomObjects Namespace > DicomServer Class : AssociationClosed Event
Event fired when an incoming DICOM association is closed
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event AssociationClosed As AssociationClosedHandler
'Usage

Dim instance As DicomServer
Dim handler As AssociationClosedHandler

AddHandler instance.AssociationClosed, handler
public event AssociationClosedHandler AssociationClosed
public:
event AssociationClosedHandler^ AssociationClosed
Remarks

At the time this event fires, the association has closed, but the associated DicomAssociation object still exists, so it's properties are all still available.

When acting as a print SCP, this event is useful, as the DICOM standard allows all associated objects created during the association to be deleted once the association closes.

Important Note:

With the sole exception of applications acting as a print service SCP, DICOM specifically bars any application from making any assumptions about the organisation of incoming data based on he association on which it arrives - to quote part 4 (section B.4):

"…an SCP of the Storage SOP Classes may not attach any significance to the particular association or associations over which C-STORE operations are requested, nor the order in which C-STORE operations occur within an association. No constraints are placed on the operations an SCU may perform during any particular association, other than those defined during association negotiation. An SCP may not expect an SCU to perform C-STORE operations in a particular order.

Similarly, no semantics are attached to the closing of an Association, such as the end of Study or Performed Procedure."

Therefore, if this event is used for any purpose other than a print SCP, any actions taken within it are most likely to be violations of the DICOM Standard.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members


AssociationRequest Event

AssociationRequest Event

DicomObjects Namespace > DicomServer Class : AssociationRequest Event
Event fired when the object receives a DICOM connection request
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event AssociationRequest As AssociationRequestHandler
'Usage

Dim instance As DicomServer
Dim handler As AssociationRequestHandler

AddHandler instance.AssociationRequest, handler
public event AssociationRequestHandler AssociationRequest
public:
event AssociationRequestHandler^ AssociationRequest
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members


ErrorReceived Event

ErrorReceived Event

DicomObjects Namespace > DicomServer Class : ErrorReceived Event
This event fires when an error is detected in received data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event ErrorReceived As ErrorReceivedHandler
'Usage

Dim instance As DicomServer
Dim handler As ErrorReceivedHandler

AddHandler instance.ErrorReceived, handler
public event ErrorReceivedHandler ErrorReceived
public:
event ErrorReceivedHandler^ ErrorReceived
Remarks

This may be a DicomException or any other form of Exception. If a DicomException, then more detailed error information may be available through it's properties.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members


InfoMessage Event

InfoMessage Event

DicomObjects Namespace > DicomServer Class : InfoMessage Event
Passes information back to the container for error messages and notifications originating from the DICOM interface.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event InfoMessage As InfoMessageHandler
'Usage

Dim instance As DicomServer
Dim handler As InfoMessageHandler

AddHandler instance.InfoMessage, handler
public event InfoMessageHandler InfoMessage
public:
event InfoMessageHandler^ InfoMessage
Remarks

Where possible, objects pass error information back to the container standard exceptions, but this is not possible for errors originating from the DICOM interface, as there is no call from the container to the object in progress. This event is therefore used for that purpose.

Debugging information may include all or part of the byte stream exchanged between DicomObjects and other entities, and is useful when communication failures occur.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members


InstanceReceived Event

InstanceReceived Event

DicomObjects Namespace > DicomServer Class : InstanceReceived Event
This event is fired whenever a C-STORE operation completes, passing details of the instance received
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event InstanceReceived As InstanceReceivedHandler
'Usage

Dim instance As DicomServer
Dim handler As InstanceReceivedHandler

AddHandler instance.InstanceReceived, handler
public event InstanceReceivedHandler InstanceReceived
public:
event InstanceReceivedHandler^ InstanceReceived
Remarks

This is a more generic event as compared with the ImageReceived method in COM version, which fires only when a DicomImage has been successfully transferred.

A status of 0 would be sent back indicating a successful instance transfer.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members


N_Event_Report Event (DicomServer)

N_Event_Report Event (DicomServer)

DicomObjects Namespace > DicomServer Class : N_Event_Report Event
This event handler is fired on SCU when an N-EVENT-REPORT notification is received from the SCP.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event N_Event_Report As N_Event_ReportHandler
'Usage

Dim instance As DicomServer
Dim handler As N_Event_ReportHandler

AddHandler instance.N_Event_Report, handler
public event N_Event_ReportHandler N_Event_Report
public:
event N_Event_ReportHandler^ N_Event_Report
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members


NormalisedReceived Event

NormalisedReceived Event

DicomObjects Namespace > DicomServer Class : NormalisedReceived Event
This event fires when an incoming normalised request is received
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event NormalisedReceived As NormalisedReceivedHandler
'Usage

Dim instance As DicomServer
Dim handler As NormalisedReceivedHandler

AddHandler instance.NormalisedReceived, handler
public event NormalisedReceivedHandler NormalisedReceived
public:
event NormalisedReceivedHandler^ NormalisedReceived
Remarks

All information required for processing this event may be found within the various properties of the Connection. In particular, the Command property contains the main request (group 0000), including the CommandID (element 0000,0100), while the Request property contains the associated identifier. Calling one of the overloads of SendResponse method call on the Association should be used to reply to this request, if an identifier needs to be returned.

You are expected to set the appropriate Status as a response for the request. This is accessible using the second parameter.

The handling of Normalised requests as an SCP is a very advanced technique, and close attention to the appropriate sections of the DICOM standard is necessary.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members


QueryReceived Event

QueryReceived Event

DicomObjects Namespace > DicomServer Class : QueryReceived Event
Event fired when the object receives a DICOM C-FIND,C-GET or C-MOVE request
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event QueryReceived As QueryReceivedHandler
'Usage

Dim instance As DicomServer
Dim handler As QueryReceivedHandler

AddHandler instance.QueryReceived, handler
public event QueryReceivedHandler QueryReceived
public:
event QueryReceivedHandler^ QueryReceived
Remarks

All information required for processing this event may be found within the various properties of the Connection. In particular, the Command property contains the main request (group 0000), including the CommandID (element 0000,0100), while the Request property contains the associated identifier. Calling one of the overloads of SendResponse method call on the Association should be used to reply to this request, if an identifier needs to be returned.

You are expected to set the appropriate Status as a response for the request. This is accessible using the second parameter.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members


ReceivingPixelData Event

ReceivingPixelData Event

DicomObjects Namespace > DicomServer Class : ReceivingPixelData Event
Event called when pixel data is being received
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event ReceivingPixelData As ReceivingPixelDataHandler
'Usage

Dim instance As DicomServer
Dim handler As ReceivingPixelDataHandler

AddHandler instance.ReceivingPixelData, handler
public event ReceivingPixelDataHandler ReceivingPixelData
public:
event ReceivingPixelDataHandler^ ReceivingPixelData
Remarks
This event could be used to redirect incoming data
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members


VerifyReceived Event

VerifyReceived Event

DicomObjects Namespace > DicomServer Class : VerifyReceived Event
This event fires when a C-ECHO command (verification request) is received
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event VerifyReceived As VerifyReceivedHandler
'Usage

Dim instance As DicomServer
Dim handler As VerifyReceivedHandler

AddHandler instance.VerifyReceived, handler
public event VerifyReceivedHandler VerifyReceived
public:
event VerifyReceivedHandler^ VerifyReceived
Remarks

The initial value of Status is the originating object's DefaultStatus value, and applications should replace this by zero in this event.

In all release applications, DefaultStatus should be non-zero, so that if the receiver application stalls or fails to respond then probing applications will receive a non-zero response to their C-ECHO request.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomServer Class
DicomServer Members


DicomViewer Class

DicomViewer Class
Members

DicomObjects Namespace : DicomViewer Class
A visible control to display DicomImage objects
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomViewer
   Inherits System.Windows.Forms.Control
'Usage

Dim instance As DicomViewer
public class DicomViewer : System.Windows.Forms.Control
public ref class DicomViewer : public System.Windows.Forms.Control
Remarks

The primary purpose of this control is the display of DICOM images, and extensive facilities are available to allow images to be obtained from a variety of sources, including files and network operations. There is extensive control over how the images are displayed, including not only the normal width/level controls, but also use of DICOM greyscale presentation states, a wide range of annotations, flipping, zooming etc.

Images received via C-STORE operations are, by default, stored in memory and displayed. Any number of images can be received (subject to memory limitations), and may be displayed either singly or in combination. Images may be "windowed", and their various attributes, (including the pixel data), are available to the container application. Images may be selectively deleted, duplicated or re-ordered.

A major design feature is that this control has no intrinsic user interface other than the display itself, all functionality being exposed and implemented via programmatic interfaces.

Thread safety: All explicit methods are believed to be thread safe, and may be called from any thread, but many of the methods inherited from System.Windows.Forms.Control are not, and will throw exceptions if called from a thread other than the one which ceated the control. If any similar issues are found with non-inherited methods, please inform Medical Connections.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
DicomObjects.DicomViewer

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Members
DicomObjects Namespace


DicomViewer Class Members

DicomViewer Class Members
Properties Methods Events

DicomObjects Namespace : DicomViewer Class

The following tables list the members exposed by DicomViewer.

Public Constructors
 | Name | Description
Public Constructor | DicomViewer Constructor | Creates a new DicomViewer control
Top
Public Properties
 | Name | Description
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActualViewerMode | The actual rendering mode used for the DicomViewer control
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoDisplay | Determines whether images newly added to the viewer control are automatically displayed. This is achieved, if necessary, by modification of the control�s CurrentIndex property.
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackColour | Background Colour for the control.
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | Border | Sets the gap between images
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | CellSpacing | Sets the gap between images
Public Property | CineUpdateTime | Specify how often the viewer updates cine mode for multiframe images. Directly correlates to the 'uDelay' parameter of the Windows timeSetEvent function For detailed documentation please check: https://docs.microsoft.com/en-us/previous-versions/dd757634(v%3dvs.85)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentIndex | Determines the images to be displayed by the DicomViewer control.
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
static (Shared in Visual Basic) | DefaultHitMargin | The default margin of error used for the LabelHits method
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | HitMargin | The margin of error used for the LabelHits method
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MultiColumns | MultiRows and MultiColumns control the layout of images within the control.
Public Property | MultiRows | MultiRows and MultiColumns control the layout of images within the control.
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | PixelSize | The actual size of pixels on the display device (in mm)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | ShowLabels | Controls whether the viewer�s labels (annotations) are shown on screen
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | ViewerMode | The rendering mode to use for this viewer
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | VSync | Controls whether updates to the the display are synchronised to the refresh rate when using DirectX mode.
Top
Public Methods
 | Name | Description
Public Method | AdjustMultiRowsColumns | Overloaded. Evenly adjust MultiRows and MultiColumns to display all images on the Viewer
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | CellArea | Returns a rectangle representing the specified cell.
Public Method | Clear | This removes all Images and Labels from this Viewer
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawLabel | Draws a DicomLabel onto the DicomViewer
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | ImageIndex | Identifies the image and pixel positions within it displayed at a particular location in the control
Public Method | ImageIndices | Identifies the image and pixel positions within it displayed at a particular location in the control
Public Method | ImagePosition | Returns the Image coordinates conversion of the user provided Point
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | IsImageDisplayed | Overloaded. Specifies wether a particular Image is being displayed.
Public Method | LabelHits | Identify labels occupying a give screen point in a DicomViewer
Public Method | LogicalToDeviceUnits | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Matrix | The Matrix used to define the given image in a viewer
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Overloaded. Overridden. Override of standard Control.Refresh() method
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SafeUpdate | Threadsafe version of standard Control.Update() method
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | (Inherited from System.Windows.Forms.Control)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Top
Public Events
 | Name | Description
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DataChanged | This event is fired whenever the underlying data in the control's Images collection changes
Public Event | DisplayChanged | This event is fired whenever the display properties of any of the images in the control�s Images collection change.
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | DrawEnd | Fires at the end of a redraw of any part of the viewer
Public Event | DrawException | This event is generated when an exception is thrown during the drawing of images onto a DicomViewer
Public Event | DrawStart | Fires at the start of a redraw of any part of the viewer
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MakeControl | Event called to create a Control to display an Image.
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

DicomViewer Class
DicomObjects Namespace


DicomViewer Constructor

DicomViewer Constructor

DicomObjects Namespace > DicomViewer Class : DicomViewer Constructor
Creates a new DicomViewer control
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DicomViewer()
public DicomViewer()
public:
DicomViewer();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


DicomViewer Class Methods

DicomViewer Class Methods

DicomObjects Namespace : DicomViewer Class

For a list of all members of this type, see DicomViewer members.

Public Methods
 | Name | Description
Public Method | AdjustMultiRowsColumns | Overloaded. Evenly adjust MultiRows and MultiColumns to display all images on the Viewer
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | CellArea | Returns a rectangle representing the specified cell.
Public Method | Clear | This removes all Images and Labels from this Viewer
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawLabel | Draws a DicomLabel onto the DicomViewer
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | ImageIndex | Identifies the image and pixel positions within it displayed at a particular location in the control
Public Method | ImageIndices | Identifies the image and pixel positions within it displayed at a particular location in the control
Public Method | ImagePosition | Returns the Image coordinates conversion of the user provided Point
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | IsImageDisplayed | Overloaded. Specifies wether a particular Image is being displayed.
Public Method | LabelHits | Identify labels occupying a give screen point in a DicomViewer
Public Method | LogicalToDeviceUnits | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Matrix | The Matrix used to define the given image in a viewer
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Overloaded. Overridden. Override of standard Control.Refresh() method
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SafeUpdate | Threadsafe version of standard Control.Update() method
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | (Inherited from System.Windows.Forms.Control)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

DicomViewer Class
DicomObjects Namespace


AdjustMultiRowsColumns Method

AdjustMultiRowsColumns Method

DicomObjects Namespace > DicomViewer Class : AdjustMultiRowsColumns Method
Evenly adjust MultiRows and MultiColumns to display all images on the Viewer
Overload List
Overload | Description
AdjustMultiRowsColumns() | Evenly adjust MultiRows and MultiColumns to display all images on the Viewer
AdjustMultiRowsColumns(Int32) | Evenly adjust MultiRows and MultiColumns to display specified number of images on the Viewer
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


AdjustMultiRowsColumns() Method

AdjustMultiRowsColumns() Method

DicomObjects Namespace > DicomViewer Class > AdjustMultiRowsColumns Method : AdjustMultiRowsColumns() Method
Evenly adjust MultiRows and MultiColumns to display all images on the Viewer
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub AdjustMultiRowsColumns()
'Usage

Dim instance As DicomViewer

instance.AdjustMultiRowsColumns()
public void AdjustMultiRowsColumns()
public:
void AdjustMultiRowsColumns();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members
Overload List


AdjustMultiRowsColumns(Int32) Method

AdjustMultiRowsColumns(Int32) Method

DicomObjects Namespace > DicomViewer Class > AdjustMultiRowsColumns Method : AdjustMultiRowsColumns(Int32) Method
Number of images that will be displayed in Multi Rows and Columns. This is the user specified count or the total images count, whichever is the least.
Evenly adjust MultiRows and MultiColumns to display specified number of images on the Viewer
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub AdjustMultiRowsColumns( _
   ByVal NumberOfImagesToDisplay As Integer _
)
'Usage

Dim instance As DicomViewer
Dim NumberOfImagesToDisplay As Integer

instance.AdjustMultiRowsColumns(NumberOfImagesToDisplay)
public void AdjustMultiRowsColumns(
   int NumberOfImagesToDisplay
)
public:
void AdjustMultiRowsColumns(
   int NumberOfImagesToDisplay
)

Parameters

NumberOfImagesToDisplay
Number of images that will be displayed in Multi Rows and Columns. This is the user specified count or the total images count, whichever is the least.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members
Overload List


CellArea(Int32) Method

CellArea(Int32) Method

DicomObjects Namespace > DicomViewer Class : CellArea(Int32) Method

The zero based cell index within the Viewer.

Returns a rectangle representing the specified cell.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function CellArea( _
   ByVal index As Integer _
) As Rectangle
'Usage

Dim instance As DicomViewer
Dim index As Integer
Dim value As Rectangle

value = instance.CellArea(index)
public Rectangle CellArea(
   int index
)
public:
Rectangle CellArea(
   int index
)

Parameters

index

The zero based cell index within the Viewer.

Return Value

Rectangle
Remarks
If invalid cell index provided, then an empty Rectangle will be returned, otherwise a rectangle with the same size of the specified cell will be returned.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


Clear Method (DicomViewer)

Clear Method (DicomViewer)

DicomObjects Namespace > DicomViewer Class : Clear Method
This removes all Images and Labels from this Viewer
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Clear()
'Usage

Dim instance As DicomViewer

instance.Clear()
public void Clear()
public:
void Clear();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


DrawLabel Method

DrawLabel Method

DicomObjects Namespace > DicomViewer Class : DrawLabel Method
The label to be drawn on DicomViewer
Draws a DicomLabel onto the DicomViewer
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub DrawLabel( _
   ByVal Label As DicomLabel _
)
'Usage

Dim instance As DicomViewer
Dim Label As DicomLabel

instance.DrawLabel(Label)
public void DrawLabel(
   DicomLabel Label
)
public:
void DrawLabel(
   DicomLabel^ Label
)

Parameters

Label
The label to be drawn on DicomViewer
Remarks
This method draws the user defined DicomLabel onto the DicomViewer, irrespective of it's multiRows and multiColumns property, in other worlds it's drawing on the DicomViewer not on its image cell.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


ImageIndex Method

ImageIndex Method

DicomObjects Namespace > DicomViewer Class : ImageIndex Method

The point location of interest in the control.

Identifies the image and pixel positions within it displayed at a particular location in the control
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function ImageIndex( _
   ByVal p As Point _
) As Integer
'Usage

Dim instance As DicomViewer
Dim p As Point
Dim value As Integer

value = instance.ImageIndex(p)
public virtual int ImageIndex(
   Point p
)
public:
virtual int ImageIndex(
   Point p
)

Parameters

p

The point location of interest in the control.

Return Value

Index of the Image within the Viewer's Images collection

Remarks

If the point identified corresponds with an image cell, ImageIndex returns the index to that image within the viewer's images collection.

If the point is not within an image cell, all methods return -1.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


ImageIndices Method

ImageIndices Method

DicomObjects Namespace > DicomViewer Class : ImageIndices Method

The point location of interest in the control.

Identifies the image and pixel positions within it displayed at a particular location in the control
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function ImageIndices( _
   ByVal p As Point _
) As Integer()
'Usage

Dim instance As DicomViewer
Dim p As Point
Dim value() As Integer

value = instance.ImageIndices(p)
public virtual int[] ImageIndices(
   Point p
)
public:
virtual array<int>^ ImageIndices(
   Point p
)

Parameters

p

The point location of interest in the control.

Return Value

Indices of the Images within the Viewer's Images collection

Remarks

If the point identified corresponds with an image cell, ImageIndicies returns an array of the index to each image within the viewer's images collection.

If the point is not within an image cell, all methods return an empty array.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


ImagePosition Method

ImagePosition Method

DicomObjects Namespace > DicomViewer Class : ImagePosition Method
Point as Point
Returns the Image coordinates conversion of the user provided Point
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ImagePosition( _
   ByVal Point As Point _
) As PointF
'Usage

Dim instance As DicomViewer
Dim Point As Point
Dim value As PointF

value = instance.ImagePosition(Point)
public PointF ImagePosition(
   Point Point
)
public:
PointF ImagePosition(
   Point Point
)

Parameters

Point
Point as Point

Return Value

PointF
Remarks
This method takes a Point (normally a mouse click on the DicomViewer) and returns it's Image Cell coordinate conversion in PointF format, if no image selected then it returns (0.0, 0.0).
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


IsImageDisplayed Method

IsImageDisplayed Method

DicomObjects Namespace > DicomViewer Class : IsImageDisplayed Method
Specifies wether a particular Image is being displayed.
Overload List
Overload | Description
IsImageDisplayed(Int32,Rectangle) | Specifies wether a particular Image, or part of the image is being displayed.
IsImageDisplayed(Int32) | Specifies wether a particular Image is being displayed.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


IsImageDisplayed(Int32,Rectangle) Method

IsImageDisplayed(Int32,Rectangle) Method

DicomObjects Namespace > DicomViewer Class > IsImageDisplayed Method : IsImageDisplayed(Int32,Rectangle) Method

The index of the Image within the Viewer's Images Collections.

The particular Area of the Image.

Specifies wether a particular Image, or part of the image is being displayed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function IsImageDisplayed( _
   ByVal Index As Integer, _
   ByVal Area As Rectangle _
) As Boolean
'Usage

Dim instance As DicomViewer
Dim Index As Integer
Dim Area As Rectangle
Dim value As Boolean

value = instance.IsImageDisplayed(Index, Area)
public bool IsImageDisplayed(
   int Index,
   Rectangle Area
)
public:
bool IsImageDisplayed(
   int Index,
   Rectangle Area
)

Parameters

Index

The index of the Image within the Viewer's Images Collections.

Area

The particular Area of the Image.

Return Value

bool
Remarks
This methods returns true, if the specified area of the indexed image from the Viewer's Images collection is being display. If an empty area is provided, then this method will return true if any part of the image, or the entire image, is being displayed on the Viewer.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members
Overload List


IsImageDisplayed(Int32) Method

IsImageDisplayed(Int32) Method

DicomObjects Namespace > DicomViewer Class > IsImageDisplayed Method : IsImageDisplayed(Int32) Method

The index of the Image within the Viewer's Images Collections.

Specifies wether a particular Image is being displayed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function IsImageDisplayed( _
   ByVal Index As Integer _
) As Boolean
'Usage

Dim instance As DicomViewer
Dim Index As Integer
Dim value As Boolean

value = instance.IsImageDisplayed(Index)
public bool IsImageDisplayed(
   int Index
)
public:
bool IsImageDisplayed(
   int Index
)

Parameters

Index

The index of the Image within the Viewer's Images Collections.

Return Value

bool
Remarks
The method returns true if the Image (indexed from the Viewer's Images collection) is being displayed on the Viewer, otherwise it returns false.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members
Overload List


LabelHits Method

LabelHits Method

DicomObjects Namespace > DicomViewer Class : LabelHits Method
The Point in scrren coordinates to be investigated
Indication of whether Viewer-Tied Labels will be investigated
Indication of whether Image-Tied Labels will be investigated
Identify labels occupying a give screen point in a DicomViewer
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function LabelHits( _
   ByVal p As Point, _
   ByVal ViewerLabels As Boolean, _
   ByVal ImageLabels As Boolean _
) As DicomLabelCollection
'Usage

Dim instance As DicomViewer
Dim p As Point
Dim ViewerLabels As Boolean
Dim ImageLabels As Boolean
Dim value As DicomLabelCollection

value = instance.LabelHits(p, ViewerLabels, ImageLabels)
public DicomLabelCollection LabelHits(
   Point p,
   bool ViewerLabels,
   bool ImageLabels
)
public:
DicomLabelCollection^ LabelHits(
   Point p,
   bool ViewerLabels,
   bool ImageLabels
)

Parameters

p
The Point in scrren coordinates to be investigated
ViewerLabels
Indication of whether Viewer-Tied Labels will be investigated
ImageLabels
Indication of whether Image-Tied Labels will be investigated

Return Value

DicomLabelCollection
Remarks

The Point p parameter is normally created directly from the MouseDown event where e.X and e.Y represent the screen coordinates of the mouse-clicked point.

The area allowed for a "hit" is defined by the label's region and for LabelLine, you can customize the "hit margin" by using the HitMargin value. The default value for HitMargin is 3.

When writting user interface facilities with this method, it is often useful to be able to highlight selected labels - the SelectMode property is surtable for this purpose.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


Matrix(Int32) Method

Matrix(Int32) Method

DicomObjects Namespace > DicomViewer Class : Matrix(Int32) Method
The 0-based index into the Images collection
The Matrix used to define the given image in a viewer
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function Matrix( _
   ByVal Index As Integer _
) As Matrix
'Usage

Dim instance As DicomViewer
Dim Index As Integer
Dim value As Matrix

value = instance.Matrix(Index)
public Matrix Matrix(
   int Index
)
public:
Matrix^ Matrix(
   int Index
)

Parameters

Index
The 0-based index into the Images collection

Return Value

Matrix
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


Refresh Method

Refresh Method

DicomObjects Namespace > DicomViewer Class : Refresh Method
Override of standard Control.Refresh() method
Overload List
Overload | Description
Refresh() | Override of standard Control.Refresh() method
Refresh(Boolean) | Refresh the control with optional wait for return
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members
Base Implementation in Refresh


Refresh() Method

Refresh() Method

DicomObjects Namespace > DicomViewer Class > Refresh Method : Refresh() Method
Override of standard Control.Refresh() method
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Overrides Sub Refresh()
'Usage

Dim instance As DicomViewer

instance.Refresh()
public override void Refresh()
public:
void Refresh(); override
Remarks
The only reason for this override is to handle cases where it is called from a thread other than the one which created the control. This override handles that situation nicely by causing the update to be deferred to the main thread, and is equivalent to Refresh(true)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members
Overload List
Base Implementation in Refresh


Refresh(Boolean) Method

Refresh(Boolean) Method

DicomObjects Namespace > DicomViewer Class > Refresh Method : Refresh(Boolean) Method
if true, then the method issues a sychronous Invoke to the main thread and therefore does not return until the redraw has completed.
Refresh the control with optional wait for return
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Refresh( _
   ByVal Synchronous As Boolean _
)
'Usage

Dim instance As DicomViewer
Dim Synchronous As Boolean

instance.Refresh(Synchronous)
public void Refresh(
   bool Synchronous
)
public:
void Refresh(
   bool Synchronous
)

Parameters

Synchronous
if true, then the method issues a sychronous Invoke to the main thread and therefore does not return until the redraw has completed.
Remarks

If called from the main thread, then this is equiavalent to base.Refresh()

If called synchronously fom another thread, then it waits for the redraw to complete, so be careful to avoid deadlocks

If called asynchronously fom another thread, then it simply issues a redraw request

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members
Overload List


SafeUpdate Method

SafeUpdate Method

DicomObjects Namespace > DicomViewer Class : SafeUpdate Method
Threadsafe version of standard Control.Update() method
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SafeUpdate()
'Usage

Dim instance As DicomViewer

instance.SafeUpdate()
public void SafeUpdate()
public:
void SafeUpdate();
Remarks
The only reason for this method is to handle Update() where it is called from a thread other than the one which created the control. This override handles that situation nicely by causing the update to be deferred to the main thread.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


DicomViewer Class Properties

DicomViewer Class Properties

DicomObjects Namespace : DicomViewer Class

For a list of all members of this type, see DicomViewer members.

Public Properties
 | Name | Description
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActualViewerMode | The actual rendering mode used for the DicomViewer control
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoDisplay | Determines whether images newly added to the viewer control are automatically displayed. This is achieved, if necessary, by modification of the control�s CurrentIndex property.
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackColour | Background Colour for the control.
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | Border | Sets the gap between images
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | CellSpacing | Sets the gap between images
Public Property | CineUpdateTime | Specify how often the viewer updates cine mode for multiframe images. Directly correlates to the 'uDelay' parameter of the Windows timeSetEvent function For detailed documentation please check: https://docs.microsoft.com/en-us/previous-versions/dd757634(v%3dvs.85)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentIndex | Determines the images to be displayed by the DicomViewer control.
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
static (Shared in Visual Basic) | DefaultHitMargin | The default margin of error used for the LabelHits method
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | HitMargin | The margin of error used for the LabelHits method
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MultiColumns | MultiRows and MultiColumns control the layout of images within the control.
Public Property | MultiRows | MultiRows and MultiColumns control the layout of images within the control.
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | PixelSize | The actual size of pixels on the display device (in mm)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | ShowLabels | Controls whether the viewer�s labels (annotations) are shown on screen
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | ViewerMode | The rendering mode to use for this viewer
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | VSync | Controls whether updates to the the display are synchronised to the refresh rate when using DirectX mode.
Top
See Also

Reference

DicomViewer Class
DicomObjects Namespace


ActualViewerMode Property

ActualViewerMode Property

DicomObjects Namespace > DicomViewer Class : ActualViewerMode Property
The actual rendering mode used for the DicomViewer control
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ActualViewerMode As ViewerMode
'Usage

Dim instance As DicomViewer
Dim value As ViewerMode

value = instance.ActualViewerMode
public ViewerMode ActualViewerMode {get;}
public:
property ViewerMode ActualViewerMode {
   ViewerMode get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


AutoDisplay Property

AutoDisplay Property

DicomObjects Namespace > DicomViewer Class : AutoDisplay Property

Determines whether images newly added to the viewer control are automatically displayed. This is achieved, if necessary, by modification of the control�s CurrentIndex property.

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AutoDisplay As Boolean
'Usage

Dim instance As DicomViewer
Dim value As Boolean

instance.AutoDisplay = value

value = instance.AutoDisplay
public bool AutoDisplay {get; set;}
public:
property bool AutoDisplay {
   bool get();
   void set (    bool value);
}
Remarks

If the number of the latest image to be added to the control is new then the formula used is:

CurrentIndex = max(0, new - MultiRows * MultiColumns)

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


BackColour Property

BackColour Property

DicomObjects Namespace > DicomViewer Class : BackColour Property
Background Colour for the control.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Property BackColour As Color
'Usage

Dim instance As DicomViewer
Dim value As Color

instance.BackColour = value

value = instance.BackColour
public virtual Color BackColour {get; set;}
public:
virtual property Color BackColour {
   Color get();
   void set (    Color value);
}
Remarks
Equivalent to the standardized BackColor method, but with English spelling!
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


Border Property

Border Property

DicomObjects Namespace > DicomViewer Class : Border Property
Sets the gap between images
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Border As Short
'Usage

Dim instance As DicomViewer
Dim value As Short

instance.Border = value

value = instance.Border
public short Border {get; set;}
public:
property short Border {
   short get();
   void set (    short value);
}
Remarks

The area available for display in a DicomViewer is divided into a number of image �cells� according to the values of MultiRows and MultiColumns and the number of pixels specified by this property is effectively �removed� from the display area before rendering the image, giving a gap between images. This is useful if the image�s BorderWidth property is used, as it can prevent the visible highlight overlying the image itself.

The default value is 0.

See also CellSpacing for another variation.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


CellSpacing Property

CellSpacing Property

DicomObjects Namespace > DicomViewer Class : CellSpacing Property
Sets the gap between images
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CellSpacing As Short
'Usage

Dim instance As DicomViewer
Dim value As Short

instance.CellSpacing = value

value = instance.CellSpacing
public short CellSpacing {get; set;}
public:
property short CellSpacing {
   short get();
   void set (    short value);
}
Remarks

The area available for display in a DicomViewer is divided into a number of image �cells� according to the values of MultiRows and MultiColumns and the number of pixels specified by this property is effectively �removed� from the display area before rendering the image, giving a gap between images. This property, unlike EdgeBorder does not apply at the edges of the viewer

The default value is 0.

See also Border for another variation.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


CineUpdateTime Property

CineUpdateTime Property

DicomObjects Namespace > DicomViewer Class : CineUpdateTime Property
Specify how often the viewer updates cine mode for multiframe images. Directly correlates to the 'uDelay' parameter of the Windows timeSetEvent function

For detailed documentation please check: https://docs.microsoft.com/en-us/previous-versions/dd757634(v%3dvs.85)

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CineUpdateTime As Integer
'Usage

Dim instance As DicomViewer
Dim value As Integer

instance.CineUpdateTime = value

value = instance.CineUpdateTime
public int CineUpdateTime {get; set;}
public:
property int CineUpdateTime {
   int get();
   void set (    int value);
}
Remarks
Directly correlates to the 'uDelay' parameter of the Windows timeSetEvent function

For detailed documentation please check: https://docs.microsoft.com/en-us/previous-versions/dd757634(v%3dvs.85)

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


CurrentIndex Property

CurrentIndex Property

DicomObjects Namespace > DicomViewer Class : CurrentIndex Property
Determines the images to be displayed by the DicomViewer control.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CurrentIndex As Integer
'Usage

Dim instance As DicomViewer
Dim value As Integer

instance.CurrentIndex = value

value = instance.CurrentIndex
public int CurrentIndex {get; set;}
public:
property int CurrentIndex {
   int get();
   void set (    int value);
}
Remarks
This defines the index (0-based) of the image displayed in the top left corner of the display matrix (or the only image if MultiRows and MultiColumns are 1). If MultiRows or MultiColumns are greater than 1, then other images are displayed sequentially along and then down.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


DefaultHitMargin Property

DefaultHitMargin Property

DicomObjects Namespace > DicomViewer Class : DefaultHitMargin Property
The default margin of error used for the LabelHits method
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property DefaultHitMargin As Integer
'Usage

Dim value As Integer

DicomViewer.DefaultHitMargin = value

value = DicomViewer.DefaultHitMargin
public static int DefaultHitMargin {get; set;}
public:
static property int DefaultHitMargin {
   int get();
   void set (    int value);
}
Remarks
This property is used as the default value for HitMargin
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


HitMargin Property

HitMargin Property

DicomObjects Namespace > DicomViewer Class : HitMargin Property
The margin of error used for the LabelHits method
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property HitMargin As Integer
'Usage

Dim instance As DicomViewer
Dim value As Integer

instance.HitMargin = value

value = instance.HitMargin
public int HitMargin {get; set;}
public:
property int HitMargin {
   int get();
   void set (    int value);
}
Remarks
This is measured in screen pixels
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


MultiColumns Property

MultiColumns Property

DicomObjects Namespace > DicomViewer Class : MultiColumns Property
MultiRows and MultiColumns control the layout of images within the control.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MultiColumns As Short
'Usage

Dim instance As DicomViewer
Dim value As Short

instance.MultiColumns = value

value = instance.MultiColumns
public short MultiColumns {get; set;}
public:
property short MultiColumns {
   short get();
   void set (    short value);
}
Remarks

If MultiRows or %MultiColumns:MultiColumns" is greater than 1, then the display area is sub-divided into a matrix of equally sized cells, each displaying an image.

Positioning of the individual images is the responsibility of the container, by use of the image�s Scroll property.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


MultiRows Property

MultiRows Property

DicomObjects Namespace > DicomViewer Class : MultiRows Property
MultiRows and MultiColumns control the layout of images within the control.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MultiRows As Short
'Usage

Dim instance As DicomViewer
Dim value As Short

instance.MultiRows = value

value = instance.MultiRows
public short MultiRows {get; set;}
public:
property short MultiRows {
   short get();
   void set (    short value);
}
Remarks

If MultiRows or %MultiColumns:MultiColumns" is greater than 1, then the display area is sub-divided into a matrix of equally sized cells, each displaying an image.

Positioning of the individual images is the responsibility of the container, by use of the image�s Scroll property.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


PixelSize Property

PixelSize Property

DicomObjects Namespace > DicomViewer Class : PixelSize Property
The actual size of pixels on the display device (in mm)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PixelSize As SizeF
'Usage

Dim instance As DicomViewer
Dim value As SizeF

instance.PixelSize = value

value = instance.PixelSize
public SizeF PixelSize {get; set;}
public:
property SizeF PixelSize {
   SizeF get();
   void set (    SizeF value);
}
Remarks

The absolute values of this property is only used when the image has an attached DICOM greyscale presentation state, which specifies �ACTUAL SIZE� for the scaling mode, but their ratio is used in all display modes to allow anisotropic pixels to be corrected.

The default value is (0.3, 0.3) mm.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


ShowLabels Property (DicomViewer)

ShowLabels Property (DicomViewer)

DicomObjects Namespace > DicomViewer Class : ShowLabels Property
Controls whether the viewer�s labels (annotations) are shown on screen
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ShowLabels As Boolean
'Usage

Dim instance As DicomViewer
Dim value As Boolean

instance.ShowLabels = value

value = instance.ShowLabels
public bool ShowLabels {get; set;}
public:
property bool ShowLabels {
   bool get();
   void set (    bool value);
}
Remarks

If set false, then the DicomLabel objects in the viewer�s Labels collection are not displayed, but they remain present, and may be redisplayed by setting this property to true.

Unlike other label manipulations, altering this property does cause the display to be updated to include or exclude the annotations as appropriate.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


ViewerMode Property

ViewerMode Property

DicomObjects Namespace > DicomViewer Class : ViewerMode Property
The rendering mode to use for this viewer
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ViewerMode As ViewerMode
'Usage

Dim instance As DicomViewer
Dim value As ViewerMode

instance.ViewerMode = value

value = instance.ViewerMode
public ViewerMode ViewerMode {get; set;}
public:
property ViewerMode ViewerMode {
   ViewerMode get();
   void set (    ViewerMode value);
}
Remarks

Version 8 of DicomObjects uses DirectX rendering by default (version 11.1), which is massively faster and more flexible than GDI+ rendering, but it is possible that some very old hardware might not support DirectX, so GDI mode is maintained as a fallback.

For testing and debugging purposes, this value can be over-ridden at run-time by the "ForceDirectX or ForceGdi "registry" Word values by setting the required value to 1.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


VSync Property

VSync Property

DicomObjects Namespace > DicomViewer Class : VSync Property
Controls whether updates to the the display are synchronised to the refresh rate when using DirectX mode.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property VSync As Boolean
'Usage

Dim instance As DicomViewer
Dim value As Boolean

instance.VSync = value

value = instance.VSync
public bool VSync {get; set;}
public:
property bool VSync {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


DicomViewer Class Events

DicomViewer Class Events

DicomObjects Namespace : DicomViewer Class

For a list of all members of this type, see DicomViewer members.

Public Events
 | Name | Description
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DataChanged | This event is fired whenever the underlying data in the control's Images collection changes
Public Event | DisplayChanged | This event is fired whenever the display properties of any of the images in the control�s Images collection change.
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | DrawEnd | Fires at the end of a redraw of any part of the viewer
Public Event | DrawException | This event is generated when an exception is thrown during the drawing of images onto a DicomViewer
Public Event | DrawStart | Fires at the start of a redraw of any part of the viewer
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MakeControl | Event called to create a Control to display an Image.
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

DicomViewer Class
DicomObjects Namespace


DataChanged Event

DataChanged Event

DicomObjects Namespace > DicomViewer Class : DataChanged Event
This event is fired whenever the underlying data in the control's Images collection changes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event DataChanged As DataChangedHandler
'Usage

Dim instance As DicomViewer
Dim handler As DataChangedHandler

AddHandler instance.DataChanged, handler
public event DataChangedHandler DataChanged
public:
event DataChangedHandler^ DataChanged
Remarks

This event is useful for updating any display elements which relate to the images displayed, such as the patient�s name etc. It only fires when complete images are added, removed, moved etc., not when attributes of those images are changed.

See also the DisplayChanged event.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


DisplayChanged Event

DisplayChanged Event

DicomObjects Namespace > DicomViewer Class : DisplayChanged Event
This event is fired whenever the display properties of any of the images in the control�s Images collection change.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event DisplayChanged As DisplayChangedHandler
'Usage

Dim instance As DicomViewer
Dim handler As DisplayChangedHandler

AddHandler instance.DisplayChanged, handler
public event DisplayChangedHandler DisplayChanged
public:
event DisplayChangedHandler^ DisplayChanged
Remarks

This event is useful for updating appropriate display elements relating to the images displayed, such as Width and Level sliders etc.

Note that DataChanged is always followed by DisplayChanged, so there is no need to duplicate functionality in the DataChanged routine.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


DrawEnd Event

DrawEnd Event

DicomObjects Namespace > DicomViewer Class : DrawEnd Event
Fires at the end of a redraw of any part of the viewer
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event DrawEnd As PaintEventHandler
'Usage

Dim instance As DicomViewer
Dim handler As PaintEventHandler

AddHandler instance.DrawEnd, handler
public event PaintEventHandler DrawEnd
public:
event PaintEventHandler^ DrawEnd
Event Data

The event handler receives an argument of type PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.
Remarks
The DrawStart & DrawEnd events are always called as a pair, and surround any drawing of pixel data to the DicomViewer�s display.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


DrawException Event

DrawException Event

DicomObjects Namespace > DicomViewer Class : DrawException Event
This event is generated when an exception is thrown during the drawing of images onto a DicomViewer
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event DrawException As DrawExceptionHandler
'Usage

Dim instance As DicomViewer
Dim handler As DrawExceptionHandler

AddHandler instance.DrawException, handler
public event DrawExceptionHandler DrawException
public:
event DrawExceptionHandler^ DrawException
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


DrawStart Event

DrawStart Event

DicomObjects Namespace > DicomViewer Class : DrawStart Event
Fires at the start of a redraw of any part of the viewer
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event DrawStart As DrawStartHandler
'Usage

Dim instance As DicomViewer
Dim handler As DrawStartHandler

AddHandler instance.DrawStart, handler
public event DrawStartHandler DrawStart
public:
event DrawStartHandler^ DrawStart
Remarks
The DrawStart2 & DrawEnd events are always called as a pair, and surround any drawing of pixel data to the DicomViewer�s display. DrawStart2 is an improved extension to DrawStart.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


MakeControl Event

MakeControl Event

DicomObjects Namespace > DicomViewer Class : MakeControl Event
Event called to create a Control to display an Image.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event MakeControl As MakeControlHandler
'Usage

Dim instance As DicomViewer
Dim handler As MakeControlHandler

AddHandler instance.MakeControl, handler
public event MakeControlHandler MakeControl
public:
event MakeControlHandler^ MakeControl
Remarks

This is used internally to generate controls for displaying objects such as PDF or CDA, but can also be used for other content types - e.g. to create a custom control to display an ECG.

The return value should be either null (to indicate that this event is not generating a custom control, or any object derived from System.Windows.Forms.Control

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


DicomVolume Class

DicomVolume Class
Members

DicomObjects Namespace : DicomVolume Class
Class used to represent a "volume" of data, either from a set of individual 2D DICOM images, or from a 3D multi-slice object. It currently has no public properties or methods, other than constructors, and is used only in the constructor of the DicomImage3D object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomVolume
   Inherits SharpDX.DisposeCollector
'Usage

Dim instance As DicomVolume
public class DicomVolume : SharpDX.DisposeCollector
public ref class DicomVolume : public SharpDX.DisposeCollector
Inheritance Hierarchy

System.Object
SharpDX.DisposeBase
SharpDX.DisposeCollector
DicomObjects.DicomVolume

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomVolume Members
DicomObjects Namespace


DicomVolume Class Members

DicomVolume Class Members
Properties Methods Events

DicomObjects Namespace : DicomVolume Class

The following tables list the members exposed by DicomVolume.

Public Constructors
 | Name | Description
Public Constructor | DicomVolume Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Centre | The centre point of the 3D volume, in real world coordinates
Public Property | Count | (Inherited from SharpDX.DisposeCollector)
Public Property | Extent | The size of the 3D volume.
Public Property | IsDisposed | (Inherited from SharpDX.DisposeBase)
Top
Public Methods
 | Name | Description
Public Method | Collect<T> | (Inherited from SharpDX.DisposeCollector)
Public Method | Dispose | (Inherited from SharpDX.DisposeBase)
Public Method | DisposeAndClear | (Inherited from SharpDX.DisposeCollector)
Public Method | Remove<T> | (Inherited from SharpDX.DisposeCollector)
Public Method | RemoveAndDispose<T> | (Inherited from SharpDX.DisposeCollector)
Public Method | SetBorderColour | Set volume's border colour. If not set, uses DicomViewer.BackColour
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from SharpDX.DisposeBase)
Public Event | Disposing | (Inherited from SharpDX.DisposeBase)
Top
See Also

Reference

DicomVolume Class
DicomObjects Namespace


DicomVolume Constructor

DicomVolume Constructor

DicomObjects Namespace > DicomVolume Class : DicomVolume Constructor
Overload List
Overload | Description
DicomVolume Constructor(DicomImage) | Constructs a DicomVolume from a set of slices within a multi-frame image.
DicomVolume Constructor(IEnumerable<DicomImage>,Boolean,Single) | Create a DicomVolume with even spacing, from data which may not be evenly spaced.
DicomVolume Constructor(IEnumerable<DicomImage>) | Constructs a DicomVolume from a set of individual slices
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomVolume Class
DicomVolume Members


DicomVolume Constructor(DicomImage)

DicomVolume Constructor(DicomImage)

DicomObjects Namespace > DicomVolume Class > DicomVolume Constructor : DicomVolume Constructor(DicomImage)
The Multi-frame image to derive the DicomVolume from
Constructs a DicomVolume from a set of slices within a multi-frame image.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal Image As DicomImage _
)
'Usage

Dim Image As DicomImage

Dim instance As New DicomVolume(Image)
public DicomVolume(
   DicomImage Image
)
public:
DicomVolume(
   DicomImage^ Image
)

Parameters

Image
The Multi-frame image to derive the DicomVolume from
Remarks

The slices ini the multi-frame image must be the same size, orientation, bit depth etc. and must be evenly spaced (though not necessarily in order, as they will be sorted internally).

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomVolume Class
DicomVolume Members
Overload List


DicomVolume Constructor(IEnumerable<DicomImage>,Boolean,Single)

DicomVolume Constructor(IEnumerable<DicomImage>,Boolean,Single)

DicomObjects Namespace > DicomVolume Class > DicomVolume Constructor : DicomVolume Constructor(IEnumerable<DicomImage>,Boolean,Single)
The set of images to derive the DicomVolume from
True if even spacing is to be used
The desired spacing
Create a DicomVolume with even spacing, from data which may not be evenly spaced.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal Images As IEnumerable(Of DicomImage), _
   ByVal EvenSpacing As Boolean, _
   ByVal Spacing As Single _
)
'Usage

Dim Images As IEnumerable(Of DicomImage)
Dim EvenSpacing As Boolean
Dim Spacing As Single

Dim instance As New DicomVolume(Images, EvenSpacing, Spacing)
public DicomVolume(
   IEnumerable<DicomImage> Images,
   bool EvenSpacing,
   float Spacing
)
public:
DicomVolume(
   IEnumerable<DicomImage^>^ Images,
   bool EvenSpacing,
   float Spacing
)

Parameters

Images
The set of images to derive the DicomVolume from
EvenSpacing
True if even spacing is to be used
Spacing
The desired spacing
Remarks

If EvenSpacing is false, then this is equivalent to the simple constructor with only one parameter

If Spacing is 0, then the spacing between the first 2 images in the collection is used.

The spacing is measured normal to the plane of the slices.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomVolume Class
DicomVolume Members
Overload List


DicomVolume Constructor(IEnumerable<DicomImage>)

DicomVolume Constructor(IEnumerable<DicomImage>)

DicomObjects Namespace > DicomVolume Class > DicomVolume Constructor : DicomVolume Constructor(IEnumerable<DicomImage>)
The set of images to derive the DicomVolume from
Constructs a DicomVolume from a set of individual slices
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal Images As IEnumerable(Of DicomImage) _
)
'Usage

Dim Images As IEnumerable(Of DicomImage)

Dim instance As New DicomVolume(Images)
public DicomVolume(
   IEnumerable<DicomImage> Images
)
public:
DicomVolume(
   IEnumerable<DicomImage^>^ Images
)

Parameters

Images
The set of images to derive the DicomVolume from
Remarks

The individual slices, which must be the same size, orientation, bit depth etc. and must be evenly spaced (though not necessarily in order, as they will be sorted internally).

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomVolume Class
DicomVolume Members
Overload List


DicomVolume Class Methods

DicomVolume Class Methods

DicomObjects Namespace : DicomVolume Class

For a list of all members of this type, see DicomVolume members.

Public Methods
 | Name | Description
Public Method | Collect<T> | (Inherited from SharpDX.DisposeCollector)
Public Method | Dispose | (Inherited from SharpDX.DisposeBase)
Public Method | DisposeAndClear | (Inherited from SharpDX.DisposeCollector)
Public Method | Remove<T> | (Inherited from SharpDX.DisposeCollector)
Public Method | RemoveAndDispose<T> | (Inherited from SharpDX.DisposeCollector)
Public Method | SetBorderColour | Set volume's border colour. If not set, uses DicomViewer.BackColour
Top
See Also

Reference

DicomVolume Class
DicomObjects Namespace


SetBorderColour Method

SetBorderColour Method

DicomObjects Namespace > DicomVolume Class : SetBorderColour Method
Top border colour
Bottom border colour
Left border colour
Right border colour
Set volume's border colour. If not set, uses DicomViewer.BackColour
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetBorderColour( _
   ByVal Top As Color, _
   ByVal Bottom As Color, _
   ByVal Left As Color, _
   ByVal Right As Color _
)
'Usage

Dim instance As DicomVolume
Dim Top As Color
Dim Bottom As Color
Dim Left As Color
Dim Right As Color

instance.SetBorderColour(Top, Bottom, Left, Right)
public void SetBorderColour(
   Color Top,
   Color Bottom,
   Color Left,
   Color Right
)
public:
void SetBorderColour(
   Color Top,
   Color Bottom,
   Color Left,
   Color Right
)

Parameters

Top
Top border colour
Bottom
Bottom border colour
Left
Left border colour
Right
Right border colour
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomVolume Class
DicomVolume Members


DicomVolume Class Properties

DicomVolume Class Properties

DicomObjects Namespace : DicomVolume Class

For a list of all members of this type, see DicomVolume members.

Public Properties
 | Name | Description
Public Property | Centre | The centre point of the 3D volume, in real world coordinates
Public Property | Count | (Inherited from SharpDX.DisposeCollector)
Public Property | Extent | The size of the 3D volume.
Public Property | IsDisposed | (Inherited from SharpDX.DisposeBase)
Top
See Also

Reference

DicomVolume Class
DicomObjects Namespace


Centre Property

Centre Property

DicomObjects Namespace > DicomVolume Class : Centre Property
The centre point of the 3D volume, in real world coordinates
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Centre As Point3D
'Usage

Dim instance As DicomVolume
Dim value As Point3D

instance.Centre = value

value = instance.Centre
public Point3D Centre {get; set;}
public:
property Point3D Centre {
   Point3D get();
   void set (    Point3D value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomVolume Class
DicomVolume Members


Extent Property

Extent Property

DicomObjects Namespace > DicomVolume Class : Extent Property
The size of the 3D volume.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Extent As Point3D
'Usage

Dim instance As DicomVolume
Dim value As Point3D

instance.Extent = value

value = instance.Extent
public Point3D Extent {get; set;}
public:
property Point3D Extent {
   Point3D get();
   void set (    Point3D value);
}
Remarks

This is the size of the regular cuboid (in mm, real world units), centred on Centre, which contains the entire 3D volume.

If the data is skewed, or angled relative to the primary axes, then the volume defined by this property may be considerably larger than the actual volume of the data.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomVolume Class
DicomVolume Members


FileSignature Class

FileSignature Class
Members

DicomObjects Namespace : FileSignature Class
Definition of all file signatures/magic numbers of commonly available executables and archives
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class FileSignature
'Usage

Dim instance As FileSignature
public class FileSignature
public ref class FileSignature
Inheritance Hierarchy

System.Object
DicomObjects.FileSignature

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Members
DicomObjects Namespace


FileSignature Class Members

FileSignature Class Members
Fields Properties

DicomObjects Namespace : FileSignature Class

The following tables list the members exposed by FileSignature.

Public Constructors
 | Name | Description
Public Constructor | FileSignature Constructor | Initialize file signature from the signatures bytes of the format
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | Bz2 | bz2 archive
static (Shared in Visual Basic) | Deb | linux deb file
static (Shared in Visual Basic) | ELF | ELF Executable
static (Shared in Visual Basic) | Hunk | Amiga Hunk
static (Shared in Visual Basic) | JavaClass | Java class file /Mach-O Fat Binary
static (Shared in Visual Basic) | Lua | Lua bytecode
static (Shared in Visual Basic) | MachO_32 | Mach-O binary (32-bit)
static (Shared in Visual Basic) | MachO_64 | Mach-O binary (64-bit)
static (Shared in Visual Basic) | MachOReverse_32 | MMach-O binary (reverse byte ordering scheme, 32-bit)
static (Shared in Visual Basic) | MachOReverse_64 | Mach-O binary (reverse byte ordering scheme, 64-bit)
static (Shared in Visual Basic) | MSCabinet | Microsoft Cabinet file
static (Shared in Visual Basic) | MZ | DOS Executable (exe/dll)
static (Shared in Visual Basic) | PE | PE32 Executable
static (Shared in Visual Basic) | Rar | Rar archive
static (Shared in Visual Basic) | Tar | Tar archive
static (Shared in Visual Basic) | Xar | eXtensible ARchive format
static (Shared in Visual Basic) | Xz | xz / tar.xz compressed format
static (Shared in Visual Basic) | Zip | Zip archive
static (Shared in Visual Basic) | Zip_7z | 7-Zip File format
static (Shared in Visual Basic) | ZM | DOS Executable (exe/dll)
static (Shared in Visual Basic) | Zst | Zstandard compressed file
Top
Public Properties
 | Name | Description
Public Property | MagicNumber | Underlying byte array that is the signature of the file format
Top
See Also

Reference

FileSignature Class
DicomObjects Namespace


FileSignature Constructor

FileSignature Constructor

DicomObjects Namespace > FileSignature Class : FileSignature Constructor
Magic number for the file format
Initialize file signature from the signatures bytes of the format
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal ParamArray ByteFormat() As Byte _
)
'Usage

Dim ByteFormat() As Byte

Dim instance As New FileSignature(ByteFormat)
public FileSignature(
   params byte[] ByteFormat
)
public:
FileSignature(
   ... array<byte>^ ByteFormat
)

Parameters

ByteFormat
Magic number for the file format
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Class
FileSignature Members


FileSignature Class Properties

FileSignature Class Properties

DicomObjects Namespace : FileSignature Class

For a list of all members of this type, see FileSignature members.

Public Properties
 | Name | Description
Public Property | MagicNumber | Underlying byte array that is the signature of the file format
Top
See Also

Reference

FileSignature Class
DicomObjects Namespace


MagicNumber Property

MagicNumber Property

DicomObjects Namespace > FileSignature Class : MagicNumber Property
Underlying byte array that is the signature of the file format
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property MagicNumber As Byte()
'Usage

Dim instance As FileSignature
Dim value() As Byte

value = instance.MagicNumber
public byte[] MagicNumber {get;}
public:
property array<byte>^ MagicNumber {
   array<byte>^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Class
FileSignature Members


FileSignature Class Fields

FileSignature Class Fields

DicomObjects Namespace : FileSignature Class

For a list of all members of this type, see FileSignature members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Bz2 | bz2 archive
static (Shared in Visual Basic) | Deb | linux deb file
static (Shared in Visual Basic) | ELF | ELF Executable
static (Shared in Visual Basic) | Hunk | Amiga Hunk
static (Shared in Visual Basic) | JavaClass | Java class file /Mach-O Fat Binary
static (Shared in Visual Basic) | Lua | Lua bytecode
static (Shared in Visual Basic) | MachO_32 | Mach-O binary (32-bit)
static (Shared in Visual Basic) | MachO_64 | Mach-O binary (64-bit)
static (Shared in Visual Basic) | MachOReverse_32 | MMach-O binary (reverse byte ordering scheme, 32-bit)
static (Shared in Visual Basic) | MachOReverse_64 | Mach-O binary (reverse byte ordering scheme, 64-bit)
static (Shared in Visual Basic) | MSCabinet | Microsoft Cabinet file
static (Shared in Visual Basic) | MZ | DOS Executable (exe/dll)
static (Shared in Visual Basic) | PE | PE32 Executable
static (Shared in Visual Basic) | Rar | Rar archive
static (Shared in Visual Basic) | Tar | Tar archive
static (Shared in Visual Basic) | Xar | eXtensible ARchive format
static (Shared in Visual Basic) | Xz | xz / tar.xz compressed format
static (Shared in Visual Basic) | Zip | Zip archive
static (Shared in Visual Basic) | Zip_7z | 7-Zip File format
static (Shared in Visual Basic) | ZM | DOS Executable (exe/dll)
static (Shared in Visual Basic) | Zst | Zstandard compressed file
Top
See Also

Reference

FileSignature Class
DicomObjects Namespace


Bz2 Field

Bz2 Field

DicomObjects Namespace > FileSignature Class : Bz2 Field
bz2 archive
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Bz2 As FileSignature
'Usage

Dim value As FileSignature

value = FileSignature.Bz2
public static readonly FileSignature Bz2
public:
static readonly FileSignature^ Bz2
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Class
FileSignature Members


Deb Field

Deb Field

DicomObjects Namespace > FileSignature Class : Deb Field
linux deb file
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Deb As FileSignature
'Usage

Dim value As FileSignature

value = FileSignature.Deb
public static readonly FileSignature Deb
public:
static readonly FileSignature^ Deb
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Class
FileSignature Members


ELF Field

ELF Field

DicomObjects Namespace > FileSignature Class : ELF Field
ELF Executable
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ELF As FileSignature
'Usage

Dim value As FileSignature

value = FileSignature.ELF
public static readonly FileSignature ELF
public:
static readonly FileSignature^ ELF
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Class
FileSignature Members


Hunk Field

Hunk Field

DicomObjects Namespace > FileSignature Class : Hunk Field
Amiga Hunk
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Hunk As FileSignature
'Usage

Dim value As FileSignature

value = FileSignature.Hunk
public static readonly FileSignature Hunk
public:
static readonly FileSignature^ Hunk
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Class
FileSignature Members


JavaClass Field

JavaClass Field

DicomObjects Namespace > FileSignature Class : JavaClass Field
Java class file /Mach-O Fat Binary
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly JavaClass As FileSignature
'Usage

Dim value As FileSignature

value = FileSignature.JavaClass
public static readonly FileSignature JavaClass
public:
static readonly FileSignature^ JavaClass
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Class
FileSignature Members


Lua Field

Lua Field

DicomObjects Namespace > FileSignature Class : Lua Field
Lua bytecode
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Lua As FileSignature
'Usage

Dim value As FileSignature

value = FileSignature.Lua
public static readonly FileSignature Lua
public:
static readonly FileSignature^ Lua
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Class
FileSignature Members


MachO_32 Field

MachO_32 Field

DicomObjects Namespace > FileSignature Class : MachO_32 Field
Mach-O binary (32-bit)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly MachO_32 As FileSignature
'Usage

Dim value As FileSignature

value = FileSignature.MachO_32
public static readonly FileSignature MachO_32
public:
static readonly FileSignature^ MachO_32
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Class
FileSignature Members


MachO_64 Field

MachO_64 Field

DicomObjects Namespace > FileSignature Class : MachO_64 Field
Mach-O binary (64-bit)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly MachO_64 As FileSignature
'Usage

Dim value As FileSignature

value = FileSignature.MachO_64
public static readonly FileSignature MachO_64
public:
static readonly FileSignature^ MachO_64
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Class
FileSignature Members


MachOReverse_32 Field

MachOReverse_32 Field

DicomObjects Namespace > FileSignature Class : MachOReverse_32 Field
MMach-O binary (reverse byte ordering scheme, 32-bit)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly MachOReverse_32 As FileSignature
'Usage

Dim value As FileSignature

value = FileSignature.MachOReverse_32
public static readonly FileSignature MachOReverse_32
public:
static readonly FileSignature^ MachOReverse_32
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Class
FileSignature Members


MachOReverse_64 Field

MachOReverse_64 Field

DicomObjects Namespace > FileSignature Class : MachOReverse_64 Field
Mach-O binary (reverse byte ordering scheme, 64-bit)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly MachOReverse_64 As FileSignature
'Usage

Dim value As FileSignature

value = FileSignature.MachOReverse_64
public static readonly FileSignature MachOReverse_64
public:
static readonly FileSignature^ MachOReverse_64
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Class
FileSignature Members


MSCabinet Field

MSCabinet Field

DicomObjects Namespace > FileSignature Class : MSCabinet Field
Microsoft Cabinet file
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly MSCabinet As FileSignature
'Usage

Dim value As FileSignature

value = FileSignature.MSCabinet
public static readonly FileSignature MSCabinet
public:
static readonly FileSignature^ MSCabinet
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Class
FileSignature Members


MZ Field

MZ Field

DicomObjects Namespace > FileSignature Class : MZ Field
DOS Executable (exe/dll)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly MZ As FileSignature
'Usage

Dim value As FileSignature

value = FileSignature.MZ
public static readonly FileSignature MZ
public:
static readonly FileSignature^ MZ
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Class
FileSignature Members


PE Field

PE Field

DicomObjects Namespace > FileSignature Class : PE Field
PE32 Executable
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly PE As FileSignature
'Usage

Dim value As FileSignature

value = FileSignature.PE
public static readonly FileSignature PE
public:
static readonly FileSignature^ PE
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Class
FileSignature Members


Rar Field

Rar Field

DicomObjects Namespace > FileSignature Class : Rar Field
Rar archive
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Rar As FileSignature
'Usage

Dim value As FileSignature

value = FileSignature.Rar
public static readonly FileSignature Rar
public:
static readonly FileSignature^ Rar
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Class
FileSignature Members


Tar Field

Tar Field

DicomObjects Namespace > FileSignature Class : Tar Field
Tar archive
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Tar As FileSignature
'Usage

Dim value As FileSignature

value = FileSignature.Tar
public static readonly FileSignature Tar
public:
static readonly FileSignature^ Tar
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Class
FileSignature Members


Xar Field

Xar Field

DicomObjects Namespace > FileSignature Class : Xar Field
eXtensible ARchive format
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Xar As FileSignature
'Usage

Dim value As FileSignature

value = FileSignature.Xar
public static readonly FileSignature Xar
public:
static readonly FileSignature^ Xar
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Class
FileSignature Members


Xz Field

Xz Field

DicomObjects Namespace > FileSignature Class : Xz Field
xz / tar.xz compressed format
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Xz As FileSignature
'Usage

Dim value As FileSignature

value = FileSignature.Xz
public static readonly FileSignature Xz
public:
static readonly FileSignature^ Xz
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Class
FileSignature Members


Zip Field

Zip Field

DicomObjects Namespace > FileSignature Class : Zip Field
Zip archive
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Zip As FileSignature
'Usage

Dim value As FileSignature

value = FileSignature.Zip
public static readonly FileSignature Zip
public:
static readonly FileSignature^ Zip
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Class
FileSignature Members


Zip_7z Field

Zip_7z Field

DicomObjects Namespace > FileSignature Class : Zip_7z Field
7-Zip File format
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Zip_7z As FileSignature
'Usage

Dim value As FileSignature

value = FileSignature.Zip_7z
public static readonly FileSignature Zip_7z
public:
static readonly FileSignature^ Zip_7z
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Class
FileSignature Members


ZM Field

ZM Field

DicomObjects Namespace > FileSignature Class : ZM Field
DOS Executable (exe/dll)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ZM As FileSignature
'Usage

Dim value As FileSignature

value = FileSignature.ZM
public static readonly FileSignature ZM
public:
static readonly FileSignature^ ZM
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Class
FileSignature Members


Zst Field

Zst Field

DicomObjects Namespace > FileSignature Class : Zst Field
Zstandard compressed file
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Zst As FileSignature
'Usage

Dim value As FileSignature

value = FileSignature.Zst
public static readonly FileSignature Zst
public:
static readonly FileSignature^ Zst
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FileSignature Class
FileSignature Members


LicenseDialog Class

LicenseDialog Class
Members

DicomObjects Namespace : LicenseDialog Class
The customisable dialog used when a license needs to be acitvated or information about it needs to be displayed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class LicenseDialog
   Inherits System.Windows.Forms.Form
'Usage

Dim instance As LicenseDialog
public class LicenseDialog : System.Windows.Forms.Form
public ref class LicenseDialog : public System.Windows.Forms.Form
Remarks

This dialog uses ONLY public methods of other objects, such as DicomLicense.ActivateOnLine and hence all functionality can be replaced by develolpers if you wish, but alternatively, for a simpler implementation you can simply customise the properties of this dialog or even derive one from it.

There is always one static copy of this dialog (DicomLicense.Dialog) which will be used for most functions by DicomObjects, but note that a clean (non-customisable) copy is used for the "nag" screens on trial and developer licenses, to prevent abuse of those licenses in commercial products.

The dialog is used in 2 forms, a "full" form when a license needs to be obtained, and a shortened form when only information needs to be shown (e.g. a license about to expire).

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
DicomObjects.LicenseDialog

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Members
DicomObjects Namespace


LicenseDialog Class Members

LicenseDialog Class Members
Fields Properties Methods Events

DicomObjects Namespace : LicenseDialog Class

The following tables list the members exposed by LicenseDialog.

Public Constructors
 | Name | Description
Public Constructor | LicenseDialog Constructor | Creates a new LicenseDialog
Top
Public Fields
 | Name | Description
Public Field | ActivateOffLine | The Activate OffLine Button
Public Field | ActivateOnLine | The Activate OnLine Button
Public Field | ActivationTabs | The TabControl holding the OnLine and OffLine tabs.
Public Field | AuthorisationString | The box containging the AuthorisationString
Public Field | AuthorisationStringLabel | The AuthorisationString text label.
Public Field | Cancel | The Cancel button
Public Field | CustomerInfo1 | The Customer Information 1 text entry box
Public Field | CustomerInfo1Label | The label holding the default text "Customer Information 1"
Public Field | CustomerInfo2 | The Customer Information 2 text entry box
Public Field | CustomerInfo2Label | The label holding the default text "Customer Information 2"
Public Field | Description | The message at the top of the dialog
Public Field | DomainLabel | The label for the domain text box
Public Field | LicenseInfoButton | The button which enlarges the dialog from information mode to activation mode
Public Field | LicenseToken | The LicenseToken text entry box
Public Field | LicenseTokenLabel | The label holding the default text "License Token"
Public Field | LogoPictureBox | Replaceable logo for the license dialog
Public Field | MachineID | The Machine ID text entry box
Public Field | MachineIDLabel | The label holding the default text "Machine ID"
Public Field | OffLine | The TabPage offering OffLine activation
Public Field | OffLineDescription | The text describing Off-LIne activation
Public Field | OK1 | The OK button (shown only when in "small" information mode)
Public Field | OnLine | The TabPage offering OnLine activation
Public Field | OnLineDescription | The text describing On-Line activation
Public Field | PasswordLabel | The label for the password text box
Public Field | ProxyDomainText | The proxy domain
Public Field | ProxyPasswordText | The password
Public Field | ProxyUserNameText | The username
Public Field | UsernameLabel | The label for the username text box
Top
Public Properties
 | Name | Description
Public Property | AcceptButton | (Inherited from System.Windows.Forms.Form)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.Form)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.Form)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.Form)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.Form)
Public Property | BackColor | (Inherited from System.Windows.Forms.Form)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | CancelButton | (Inherited from System.Windows.Forms.Form)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Form)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | ControlBox | (Inherited from System.Windows.Forms.Form)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | FormBorderStyle | (Inherited from System.Windows.Forms.Form)
Public Property | HelpButton | (Inherited from System.Windows.Forms.Form)
Public Property | Icon | (Inherited from System.Windows.Forms.Form)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | IsMdiContainer | (Inherited from System.Windows.Forms.Form)
Public Property | KeyPreview | (Inherited from System.Windows.Forms.Form)
Public Property | Location | (Inherited from System.Windows.Forms.Form)
Public Property | MainMenuStrip | (Inherited from System.Windows.Forms.Form)
Public Property | MaximizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Form)
Public Property | MinimizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Form)
Public Property | Opacity | (Inherited from System.Windows.Forms.Form)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeftLayout | (Inherited from System.Windows.Forms.Form)
Public Property | ShowIcon | (Inherited from System.Windows.Forms.Form)
Public Property | ShowInTaskbar | (Inherited from System.Windows.Forms.Form)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Form)
Public Property | SizeGripStyle | (Inherited from System.Windows.Forms.Form)
Public Property | StartPosition | (Inherited from System.Windows.Forms.Form)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.Form)
Public Property | TopMost | (Inherited from System.Windows.Forms.Form)
Public Property | TransparencyKey | (Inherited from System.Windows.Forms.Form)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | WindowState | (Inherited from System.Windows.Forms.Form)
Top
Public Methods
 | Name | Description
Public Method | Activate | (Inherited from System.Windows.Forms.Form)
Public Method | AddOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Close | (Inherited from System.Windows.Forms.Form)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | LayoutMdi | (Inherited from System.Windows.Forms.Form)
Public Method | LogicalToDeviceUnits | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RemoveOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetDesktopBounds | (Inherited from System.Windows.Forms.Form)
Public Method | SetDesktopLocation | (Inherited from System.Windows.Forms.Form)
Public Method | Show | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | ShowActivation | Control whether the full (activation) mode of the dialog is shown
Public Method | ShowDialog | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.Windows.Forms.Form)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.Form)
Top
Public Events
 | Name | Description
Public Event | Activated | (Inherited from System.Windows.Forms.Form)
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.Form)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Deactivate | (Inherited from System.Windows.Forms.Form)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DpiChanged | (Inherited from System.Windows.Forms.Form)
Public Event | DpiChangedAfterParent | (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | FormClosed | (Inherited from System.Windows.Forms.Form)
Public Event | FormClosing | (Inherited from System.Windows.Forms.Form)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | HelpButtonClicked | (Inherited from System.Windows.Forms.Form)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | InputLanguageChanged | (Inherited from System.Windows.Forms.Form)
Public Event | InputLanguageChanging | (Inherited from System.Windows.Forms.Form)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.Form)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MaximizedBoundsChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MaximumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MdiChildActivate | (Inherited from System.Windows.Forms.Form)
Public Event | MinimumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | ResizeBegin | (Inherited from System.Windows.Forms.Form)
Public Event | ResizeEnd | (Inherited from System.Windows.Forms.Form)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftLayoutChanged | (Inherited from System.Windows.Forms.Form)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | Shown | (Inherited from System.Windows.Forms.Form)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

LicenseDialog Class
DicomObjects Namespace


LicenseDialog Constructor

LicenseDialog Constructor

DicomObjects Namespace > LicenseDialog Class : LicenseDialog Constructor
Creates a new LicenseDialog
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New LicenseDialog()
public LicenseDialog()
public:
LicenseDialog();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


LicenseDialog Class Methods

LicenseDialog Class Methods

DicomObjects Namespace : LicenseDialog Class

For a list of all members of this type, see LicenseDialog members.

Public Methods
 | Name | Description
Public Method | Activate | (Inherited from System.Windows.Forms.Form)
Public Method | AddOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Close | (Inherited from System.Windows.Forms.Form)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | LayoutMdi | (Inherited from System.Windows.Forms.Form)
Public Method | LogicalToDeviceUnits | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RemoveOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetDesktopBounds | (Inherited from System.Windows.Forms.Form)
Public Method | SetDesktopLocation | (Inherited from System.Windows.Forms.Form)
Public Method | Show | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | ShowActivation | Control whether the full (activation) mode of the dialog is shown
Public Method | ShowDialog | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.Windows.Forms.Form)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.Form)
Top
See Also

Reference

LicenseDialog Class
DicomObjects Namespace


ShowActivation Method

ShowActivation Method

DicomObjects Namespace > LicenseDialog Class : ShowActivation Method
True is the full dialog is to be shown and false if the smaller "information" mode should be used.
Control whether the full (activation) mode of the dialog is shown
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ShowActivation( _
   ByVal Show As Boolean _
)
'Usage

Dim instance As LicenseDialog
Dim Show As Boolean

instance.ShowActivation(Show)
public void ShowActivation(
   bool Show
)
public:
void ShowActivation(
   bool Show
)

Parameters

Show
True is the full dialog is to be shown and false if the smaller "information" mode should be used.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


LicenseDialog Class Fields

LicenseDialog Class Fields

DicomObjects Namespace : LicenseDialog Class

For a list of all members of this type, see LicenseDialog members.

Public Fields
 | Name | Description
Public Field | ActivateOffLine | The Activate OffLine Button
Public Field | ActivateOnLine | The Activate OnLine Button
Public Field | ActivationTabs | The TabControl holding the OnLine and OffLine tabs.
Public Field | AuthorisationString | The box containging the AuthorisationString
Public Field | AuthorisationStringLabel | The AuthorisationString text label.
Public Field | Cancel | The Cancel button
Public Field | CustomerInfo1 | The Customer Information 1 text entry box
Public Field | CustomerInfo1Label | The label holding the default text "Customer Information 1"
Public Field | CustomerInfo2 | The Customer Information 2 text entry box
Public Field | CustomerInfo2Label | The label holding the default text "Customer Information 2"
Public Field | Description | The message at the top of the dialog
Public Field | DomainLabel | The label for the domain text box
Public Field | LicenseInfoButton | The button which enlarges the dialog from information mode to activation mode
Public Field | LicenseToken | The LicenseToken text entry box
Public Field | LicenseTokenLabel | The label holding the default text "License Token"
Public Field | LogoPictureBox | Replaceable logo for the license dialog
Public Field | MachineID | The Machine ID text entry box
Public Field | MachineIDLabel | The label holding the default text "Machine ID"
Public Field | OffLine | The TabPage offering OffLine activation
Public Field | OffLineDescription | The text describing Off-LIne activation
Public Field | OK1 | The OK button (shown only when in "small" information mode)
Public Field | OnLine | The TabPage offering OnLine activation
Public Field | OnLineDescription | The text describing On-Line activation
Public Field | PasswordLabel | The label for the password text box
Public Field | ProxyDomainText | The proxy domain
Public Field | ProxyPasswordText | The password
Public Field | ProxyUserNameText | The username
Public Field | UsernameLabel | The label for the username text box
Top
See Also

Reference

LicenseDialog Class
DicomObjects Namespace


ActivateOffLine Field

ActivateOffLine Field

DicomObjects Namespace > LicenseDialog Class : ActivateOffLine Field
The Activate OffLine Button
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ActivateOffLine As Button
'Usage

Dim instance As LicenseDialog
Dim value As Button

value = instance.ActivateOffLine

instance.ActivateOffLine = value
public Button ActivateOffLine
public:
Button^ ActivateOffLine
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


ActivateOnLine Field

ActivateOnLine Field

DicomObjects Namespace > LicenseDialog Class : ActivateOnLine Field
The Activate OnLine Button
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ActivateOnLine As Button
'Usage

Dim instance As LicenseDialog
Dim value As Button

value = instance.ActivateOnLine

instance.ActivateOnLine = value
public Button ActivateOnLine
public:
Button^ ActivateOnLine
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


ActivationTabs Field

ActivationTabs Field

DicomObjects Namespace > LicenseDialog Class : ActivationTabs Field
The TabControl holding the OnLine and OffLine tabs.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ActivationTabs As TabControl
'Usage

Dim instance As LicenseDialog
Dim value As TabControl

value = instance.ActivationTabs

instance.ActivationTabs = value
public TabControl ActivationTabs
public:
TabControl^ ActivationTabs
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


AuthorisationString Field

AuthorisationString Field

DicomObjects Namespace > LicenseDialog Class : AuthorisationString Field
The box containging the AuthorisationString
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public AuthorisationString As TextBox
'Usage

Dim instance As LicenseDialog
Dim value As TextBox

value = instance.AuthorisationString

instance.AuthorisationString = value
public TextBox AuthorisationString
public:
TextBox^ AuthorisationString
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


AuthorisationStringLabel Field

AuthorisationStringLabel Field

DicomObjects Namespace > LicenseDialog Class : AuthorisationStringLabel Field
The AuthorisationString text label.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public AuthorisationStringLabel As Label
'Usage

Dim instance As LicenseDialog
Dim value As Label

value = instance.AuthorisationStringLabel

instance.AuthorisationStringLabel = value
public Label AuthorisationStringLabel
public:
Label^ AuthorisationStringLabel
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


Cancel Field

Cancel Field

DicomObjects Namespace > LicenseDialog Class : Cancel Field
The Cancel button
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Cancel As Button
'Usage

Dim instance As LicenseDialog
Dim value As Button

value = instance.Cancel

instance.Cancel = value
public Button Cancel
public:
Button^ Cancel
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


CustomerInfo1 Field

CustomerInfo1 Field

DicomObjects Namespace > LicenseDialog Class : CustomerInfo1 Field
The Customer Information 1 text entry box
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public CustomerInfo1 As TextBox
'Usage

Dim instance As LicenseDialog
Dim value As TextBox

value = instance.CustomerInfo1

instance.CustomerInfo1 = value
public TextBox CustomerInfo1
public:
TextBox^ CustomerInfo1
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


CustomerInfo1Label Field

CustomerInfo1Label Field

DicomObjects Namespace > LicenseDialog Class : CustomerInfo1Label Field
The label holding the default text "Customer Information 1"
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public CustomerInfo1Label As Label
'Usage

Dim instance As LicenseDialog
Dim value As Label

value = instance.CustomerInfo1Label

instance.CustomerInfo1Label = value
public Label CustomerInfo1Label
public:
Label^ CustomerInfo1Label
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


CustomerInfo2 Field

CustomerInfo2 Field

DicomObjects Namespace > LicenseDialog Class : CustomerInfo2 Field
The Customer Information 2 text entry box
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public CustomerInfo2 As TextBox
'Usage

Dim instance As LicenseDialog
Dim value As TextBox

value = instance.CustomerInfo2

instance.CustomerInfo2 = value
public TextBox CustomerInfo2
public:
TextBox^ CustomerInfo2
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


CustomerInfo2Label Field

CustomerInfo2Label Field

DicomObjects Namespace > LicenseDialog Class : CustomerInfo2Label Field
The label holding the default text "Customer Information 2"
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public CustomerInfo2Label As Label
'Usage

Dim instance As LicenseDialog
Dim value As Label

value = instance.CustomerInfo2Label

instance.CustomerInfo2Label = value
public Label CustomerInfo2Label
public:
Label^ CustomerInfo2Label
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


Description Field

Description Field

DicomObjects Namespace > LicenseDialog Class : Description Field
The message at the top of the dialog
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Description As Label
'Usage

Dim instance As LicenseDialog
Dim value As Label

value = instance.Description

instance.Description = value
public Label Description
public:
Label^ Description
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


DomainLabel Field

DomainLabel Field

DicomObjects Namespace > LicenseDialog Class : DomainLabel Field
The label for the domain text box
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public DomainLabel As Label
'Usage

Dim instance As LicenseDialog
Dim value As Label

value = instance.DomainLabel

instance.DomainLabel = value
public Label DomainLabel
public:
Label^ DomainLabel
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


LicenseInfoButton Field

LicenseInfoButton Field

DicomObjects Namespace > LicenseDialog Class : LicenseInfoButton Field
The button which enlarges the dialog from information mode to activation mode
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public LicenseInfoButton As Button
'Usage

Dim instance As LicenseDialog
Dim value As Button

value = instance.LicenseInfoButton

instance.LicenseInfoButton = value
public Button LicenseInfoButton
public:
Button^ LicenseInfoButton
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


LicenseToken Field

LicenseToken Field

DicomObjects Namespace > LicenseDialog Class : LicenseToken Field
The LicenseToken text entry box
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public LicenseToken As TextBox
'Usage

Dim instance As LicenseDialog
Dim value As TextBox

value = instance.LicenseToken

instance.LicenseToken = value
public TextBox LicenseToken
public:
TextBox^ LicenseToken
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


LicenseTokenLabel Field

LicenseTokenLabel Field

DicomObjects Namespace > LicenseDialog Class : LicenseTokenLabel Field
The label holding the default text "License Token"
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public LicenseTokenLabel As Label
'Usage

Dim instance As LicenseDialog
Dim value As Label

value = instance.LicenseTokenLabel

instance.LicenseTokenLabel = value
public Label LicenseTokenLabel
public:
Label^ LicenseTokenLabel
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


LogoPictureBox Field

LogoPictureBox Field

DicomObjects Namespace > LicenseDialog Class : LogoPictureBox Field
Replaceable logo for the license dialog
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public LogoPictureBox As PictureBox
'Usage

Dim instance As LicenseDialog
Dim value As PictureBox

value = instance.LogoPictureBox

instance.LogoPictureBox = value
public PictureBox LogoPictureBox
public:
PictureBox^ LogoPictureBox
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


MachineID Field

MachineID Field

DicomObjects Namespace > LicenseDialog Class : MachineID Field
The Machine ID text entry box
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MachineID As TextBox
'Usage

Dim instance As LicenseDialog
Dim value As TextBox

value = instance.MachineID

instance.MachineID = value
public TextBox MachineID
public:
TextBox^ MachineID
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


MachineIDLabel Field

MachineIDLabel Field

DicomObjects Namespace > LicenseDialog Class : MachineIDLabel Field
The label holding the default text "Machine ID"
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MachineIDLabel As Label
'Usage

Dim instance As LicenseDialog
Dim value As Label

value = instance.MachineIDLabel

instance.MachineIDLabel = value
public Label MachineIDLabel
public:
Label^ MachineIDLabel
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


OffLine Field

OffLine Field

DicomObjects Namespace > LicenseDialog Class : OffLine Field
The TabPage offering OffLine activation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public OffLine As TabPage
'Usage

Dim instance As LicenseDialog
Dim value As TabPage

value = instance.OffLine

instance.OffLine = value
public TabPage OffLine
public:
TabPage^ OffLine
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


OffLineDescription Field

OffLineDescription Field

DicomObjects Namespace > LicenseDialog Class : OffLineDescription Field
The text describing Off-LIne activation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public OffLineDescription As Label
'Usage

Dim instance As LicenseDialog
Dim value As Label

value = instance.OffLineDescription

instance.OffLineDescription = value
public Label OffLineDescription
public:
Label^ OffLineDescription
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


OK1 Field

OK1 Field

DicomObjects Namespace > LicenseDialog Class : OK1 Field
The OK button (shown only when in "small" information mode)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public OK1 As Button
'Usage

Dim instance As LicenseDialog
Dim value As Button

value = instance.OK1

instance.OK1 = value
public Button OK1
public:
Button^ OK1
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


OnLine Field

OnLine Field

DicomObjects Namespace > LicenseDialog Class : OnLine Field
The TabPage offering OnLine activation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public OnLine As TabPage
'Usage

Dim instance As LicenseDialog
Dim value As TabPage

value = instance.OnLine

instance.OnLine = value
public TabPage OnLine
public:
TabPage^ OnLine
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


OnLineDescription Field

OnLineDescription Field

DicomObjects Namespace > LicenseDialog Class : OnLineDescription Field
The text describing On-Line activation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public OnLineDescription As Label
'Usage

Dim instance As LicenseDialog
Dim value As Label

value = instance.OnLineDescription

instance.OnLineDescription = value
public Label OnLineDescription
public:
Label^ OnLineDescription
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


PasswordLabel Field

PasswordLabel Field

DicomObjects Namespace > LicenseDialog Class : PasswordLabel Field
The label for the password text box
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public PasswordLabel As Label
'Usage

Dim instance As LicenseDialog
Dim value As Label

value = instance.PasswordLabel

instance.PasswordLabel = value
public Label PasswordLabel
public:
Label^ PasswordLabel
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


ProxyDomainText Field

ProxyDomainText Field

DicomObjects Namespace > LicenseDialog Class : ProxyDomainText Field
The proxy domain
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ProxyDomainText As TextBox
'Usage

Dim instance As LicenseDialog
Dim value As TextBox

value = instance.ProxyDomainText

instance.ProxyDomainText = value
public TextBox ProxyDomainText
public:
TextBox^ ProxyDomainText
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


ProxyPasswordText Field

ProxyPasswordText Field

DicomObjects Namespace > LicenseDialog Class : ProxyPasswordText Field
The password
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ProxyPasswordText As TextBox
'Usage

Dim instance As LicenseDialog
Dim value As TextBox

value = instance.ProxyPasswordText

instance.ProxyPasswordText = value
public TextBox ProxyPasswordText
public:
TextBox^ ProxyPasswordText
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


ProxyUserNameText Field

ProxyUserNameText Field

DicomObjects Namespace > LicenseDialog Class : ProxyUserNameText Field
The username
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ProxyUserNameText As TextBox
'Usage

Dim instance As LicenseDialog
Dim value As TextBox

value = instance.ProxyUserNameText

instance.ProxyUserNameText = value
public TextBox ProxyUserNameText
public:
TextBox^ ProxyUserNameText
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


UsernameLabel Field

UsernameLabel Field

DicomObjects Namespace > LicenseDialog Class : UsernameLabel Field
The label for the username text box
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public UsernameLabel As Label
'Usage

Dim instance As LicenseDialog
Dim value As Label

value = instance.UsernameLabel

instance.UsernameLabel = value
public Label UsernameLabel
public:
Label^ UsernameLabel
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members


LookupTable Class

LookupTable Class
Members

DicomObjects Namespace : LookupTable Class
Class to hold explicit lookup tables
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class LookupTable
'Usage

Dim instance As LookupTable
public class LookupTable
public ref class LookupTable
Inheritance Hierarchy

System.Object
DicomObjects.LookupTable

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LookupTable Members
DicomObjects Namespace


LookupTable Class Members

LookupTable Class Members
Properties

DicomObjects Namespace : LookupTable Class

The following tables list the members exposed by LookupTable.

Public Constructors
 | Name | Description
Public Constructor | LookupTable Constructor | Create a LUT from components
Top
Public Properties
 | Name | Description
Public Property | Bits | The number of bits in the LUT data
Public Property | Data | The LUT data
Public Property | MinValue | The source value mapped to the first value in the LUT
Public Property | SignedInput | True if the LUT is supposed to apply to signed data
Top
See Also

Reference

LookupTable Class
DicomObjects Namespace


LookupTable Constructor

LookupTable Constructor

DicomObjects Namespace > LookupTable Class : LookupTable Constructor
The source value mapped to the first value in the LUT
The number of bits in the LUT data
True if the LUT is supposed to apply to signed data
The LUT data
Create a LUT from components
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal MinValue As Integer, _
   ByVal Bits As Integer, _
   ByVal SignedInput As Boolean, _
   ByVal Data As Array _
)
'Usage

Dim MinValue As Integer
Dim Bits As Integer
Dim SignedInput As Boolean
Dim Data As Array

Dim instance As New LookupTable(MinValue, Bits, SignedInput, Data)
public LookupTable(
   int MinValue,
   int Bits,
   bool SignedInput,
   Array Data
)
public:
LookupTable(
   int MinValue,
   int Bits,
   bool SignedInput,
   Array^ Data
)

Parameters

MinValue
The source value mapped to the first value in the LUT
Bits
The number of bits in the LUT data
SignedInput
True if the LUT is supposed to apply to signed data
Data
The LUT data
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LookupTable Class
LookupTable Members


LookupTable Class Properties

LookupTable Class Properties

DicomObjects Namespace : LookupTable Class

For a list of all members of this type, see LookupTable members.

Public Properties
 | Name | Description
Public Property | Bits | The number of bits in the LUT data
Public Property | Data | The LUT data
Public Property | MinValue | The source value mapped to the first value in the LUT
Public Property | SignedInput | True if the LUT is supposed to apply to signed data
Top
See Also

Reference

LookupTable Class
DicomObjects Namespace


Bits Property

Bits Property

DicomObjects Namespace > LookupTable Class : Bits Property
The number of bits in the LUT data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Bits As Integer
'Usage

Dim instance As LookupTable
Dim value As Integer

value = instance.Bits
public int Bits {get;}
public:
property int Bits {
   int get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LookupTable Class
LookupTable Members


Data Property

Data Property

DicomObjects Namespace > LookupTable Class : Data Property
The LUT data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Data As Array
'Usage

Dim instance As LookupTable
Dim value As Array

value = instance.Data
public Array Data {get;}
public:
property Array^ Data {
   Array^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LookupTable Class
LookupTable Members


MinValue Property

MinValue Property

DicomObjects Namespace > LookupTable Class : MinValue Property
The source value mapped to the first value in the LUT
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property MinValue As Integer
'Usage

Dim instance As LookupTable
Dim value As Integer

value = instance.MinValue
public int MinValue {get;}
public:
property int MinValue {
   int get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LookupTable Class
LookupTable Members


SignedInput Property

SignedInput Property

DicomObjects Namespace > LookupTable Class : SignedInput Property
True if the LUT is supposed to apply to signed data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property SignedInput As Boolean
'Usage

Dim instance As LookupTable
Dim value As Boolean

value = instance.SignedInput
public bool SignedInput {get;}
public:
property bool SignedInput {
   bool get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LookupTable Class
LookupTable Members


ReadBehaviours Class

ReadBehaviours Class
Members

DicomObjects Namespace : ReadBehaviours Class
Specific behaviour to use when reading/receiving a DICOM instance
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ReadBehaviours
'Usage

Dim instance As ReadBehaviours
public class ReadBehaviours
public ref class ReadBehaviours
Remarks

An object of this class may be used in 4 ways:

  • As a parameter to one of the overrides of DicomDataSet.Read
  • By assigning to DicomGlobal.DefaultReadBehaviour
  • By setting the ReadBehaviour property of an explicitly created DicomAssociation
  • By setting the ReadBehaviour property of an internally generated DicomAssociation object during the DicomServer.AssociationRequest event

Most of the behaviours controlled by the properties of this object may also be set globally using the internal registry, but this object allows more granular control.

Inheritance Hierarchy

System.Object
DicomObjects.ReadBehaviours

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ReadBehaviours Members
DicomObjects Namespace


ReadBehaviours Class Members

ReadBehaviours Class Members
Properties

DicomObjects Namespace : ReadBehaviours Class

The following tables list the members exposed by ReadBehaviours.

Public Constructors
 | Name | Description
Public Constructor | ReadBehaviours Constructor | Create a new ReadBehaviours object
Top
Public Properties
 | Name | Description
Public Property | AttemptToFixHologicCompressedFrames | Try to detect and attempt to fix Hologic compressed frames. This will replace their private sequence containing the pixels with correctly formatted pixel data. Note this doesn't not replace the original pixel data, you have to explicitly overwrite the image by Write to disk
Public Property | BlankTransferSyntax | A default transfer syntax value for DicomObjects when reading DICOM image with missing transfer syntax value.
Public Property | CloseFilesAfterReading | Controls how pixel data is read from disk
Public Property | DelayedSequenceLoad | Controls whether to perform on-demand loading of all sequences only when needed
Public Property | DiscardBadIcons | Controls how "bad icons" are handled.
Public Property | DontReadPixels | Can disable reading of pixel values
Public Property | IgnoreAfterPixels | Controls whether all data after the pixel data is to be ignored.
Public Property | IgnoreAfterTag | Controls whether all data after a specifc tag is to be ignored. Value shall be in ggggeeee hex format, such as 0x00100010 for patient name.
Public Property | IgnoreBOT | Ignore any Basic Offset Table which may be present in the received data
Public Property | IgnoreExceptions | Ignores a list of DicomObjects error codes accessible from DicomException.Code during reading from disk/network and puts together what has been successfully read. This is particularly useful to skip exceptions and keep the association open to continue reading.
Public Property | IgnoreIconLengths | Ignore the lengths of the pixel data in icon sequences
Public Property | IgnorePrivateSequences | If set, private sequence items are skipped.
Public Property | SilentEndOfFileReached | Set to true to tell DicomObjects to not throw End Of File Reached exception and stop reading from file when an attribute with bad length is encountered. Default value is false
Public Property | ThrowNotDICOMDIRError | Controls whether to throw an exception if a file which is apparently a DICOM does not contain the expected DICOMDIR offset attributes.
Public Property | TolerateBadOffsets | Ignore bad "offset" data when reading a DICOMDIR
Public Property | ZeissBug | A workaround for old bad Zeiss Data, some of which had UT attributes with 2 Bytes length
Top
See Also

Reference

ReadBehaviours Class
DicomObjects Namespace


ReadBehaviours Constructor

ReadBehaviours Constructor

DicomObjects Namespace > ReadBehaviours Class : ReadBehaviours Constructor
Create a new ReadBehaviours object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ReadBehaviours()
public ReadBehaviours()
public:
ReadBehaviours();
Remarks
The properties are all initialised from global or "registry" values, as described in each individual property
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ReadBehaviours Class
ReadBehaviours Members


ReadBehaviours Class Properties

ReadBehaviours Class Properties

DicomObjects Namespace : ReadBehaviours Class

For a list of all members of this type, see ReadBehaviours members.

Public Properties
 | Name | Description
Public Property | AttemptToFixHologicCompressedFrames | Try to detect and attempt to fix Hologic compressed frames. This will replace their private sequence containing the pixels with correctly formatted pixel data. Note this doesn't not replace the original pixel data, you have to explicitly overwrite the image by Write to disk
Public Property | BlankTransferSyntax | A default transfer syntax value for DicomObjects when reading DICOM image with missing transfer syntax value.
Public Property | CloseFilesAfterReading | Controls how pixel data is read from disk
Public Property | DelayedSequenceLoad | Controls whether to perform on-demand loading of all sequences only when needed
Public Property | DiscardBadIcons | Controls how "bad icons" are handled.
Public Property | DontReadPixels | Can disable reading of pixel values
Public Property | IgnoreAfterPixels | Controls whether all data after the pixel data is to be ignored.
Public Property | IgnoreAfterTag | Controls whether all data after a specifc tag is to be ignored. Value shall be in ggggeeee hex format, such as 0x00100010 for patient name.
Public Property | IgnoreBOT | Ignore any Basic Offset Table which may be present in the received data
Public Property | IgnoreExceptions | Ignores a list of DicomObjects error codes accessible from DicomException.Code during reading from disk/network and puts together what has been successfully read. This is particularly useful to skip exceptions and keep the association open to continue reading.
Public Property | IgnoreIconLengths | Ignore the lengths of the pixel data in icon sequences
Public Property | IgnorePrivateSequences | If set, private sequence items are skipped.
Public Property | SilentEndOfFileReached | Set to true to tell DicomObjects to not throw End Of File Reached exception and stop reading from file when an attribute with bad length is encountered. Default value is false
Public Property | ThrowNotDICOMDIRError | Controls whether to throw an exception if a file which is apparently a DICOM does not contain the expected DICOMDIR offset attributes.
Public Property | TolerateBadOffsets | Ignore bad "offset" data when reading a DICOMDIR
Public Property | ZeissBug | A workaround for old bad Zeiss Data, some of which had UT attributes with 2 Bytes length
Top
See Also

Reference

ReadBehaviours Class
DicomObjects Namespace


AttemptToFixHologicCompressedFrames Property

AttemptToFixHologicCompressedFrames Property

DicomObjects Namespace > ReadBehaviours Class : AttemptToFixHologicCompressedFrames Property
Try to detect and attempt to fix Hologic compressed frames. This will replace their private sequence containing the pixels with correctly formatted pixel data.

Note this doesn't not replace the original pixel data, you have to explicitly overwrite the image by Write to disk

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AttemptToFixHologicCompressedFrames As Boolean
'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.AttemptToFixHologicCompressedFrames = value

value = instance.AttemptToFixHologicCompressedFrames
public bool AttemptToFixHologicCompressedFrames {get; set;}
public:
property bool AttemptToFixHologicCompressedFrames {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ReadBehaviours Class
ReadBehaviours Members


BlankTransferSyntax Property

BlankTransferSyntax Property

DicomObjects Namespace > ReadBehaviours Class : BlankTransferSyntax Property
A default transfer syntax value for DicomObjects when reading DICOM image with missing transfer syntax value.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BlankTransferSyntax As String
'Usage

Dim instance As ReadBehaviours
Dim value As String

instance.BlankTransferSyntax = value

value = instance.BlankTransferSyntax
public string BlankTransferSyntax {get; set;}
public:
property String^ BlankTransferSyntax {
   String^ get();
   void set (    String^ value);
}
Remarks

The default value of this property is copied from the BlankTransferSyntax value of the internal registry, which in turn has a default value of 1.2.840.10008.1.2.1

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ReadBehaviours Class
ReadBehaviours Members


CloseFilesAfterReading Property (ReadBehaviours)

CloseFilesAfterReading Property (ReadBehaviours)

DicomObjects Namespace > ReadBehaviours Class : CloseFilesAfterReading Property
Controls how pixel data is read from disk
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CloseFilesAfterReading As Boolean
'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.CloseFilesAfterReading = value

value = instance.CloseFilesAfterReading
public bool CloseFilesAfterReading {get; set;}
public:
property bool CloseFilesAfterReading {
   bool get();
   void set (    bool value);
}
Remarks

This is initialised from CloseFilesAfterReading - see that property for more details of the effects of this property.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ReadBehaviours Class
ReadBehaviours Members


DelayedSequenceLoad Property

DelayedSequenceLoad Property

DicomObjects Namespace > ReadBehaviours Class : DelayedSequenceLoad Property
Controls whether to perform on-demand loading of all sequences only when needed
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DelayedSequenceLoad As Boolean
'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.DelayedSequenceLoad = value

value = instance.DelayedSequenceLoad
public bool DelayedSequenceLoad {get; set;}
public:
property bool DelayedSequenceLoad {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ReadBehaviours Class
ReadBehaviours Members


DiscardBadIcons Property

DiscardBadIcons Property

DicomObjects Namespace > ReadBehaviours Class : DiscardBadIcons Property
Controls how "bad icons" are handled.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DiscardBadIcons As Boolean
'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.DiscardBadIcons = value

value = instance.DiscardBadIcons
public bool DiscardBadIcons {get; set;}
public:
property bool DiscardBadIcons {
   bool get();
   void set (    bool value);
}
Remarks

Unfortunately, many DICOM files from a certan large manufacturer, commonly contain "thumbnail" sequences, which break the DICOM rules, as they have explicit length, indicating that they are uncompressed, when in fact they are compressed (and even then, they don't follow th encapsulation rules for compressed pixel data!)

If set to true, then such defective icons (which where not in the original images and can be seen as "damage" by the PACS) are silently removed from the data at the time it is read - leaving only a warning in the log file.

The default value of this property is derived from the DiscardBadIcons value of the internal registry, which in turn has a default value of 0, causing this property to be false.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ReadBehaviours Class
ReadBehaviours Members


DontReadPixels Property

DontReadPixels Property

DicomObjects Namespace > ReadBehaviours Class : DontReadPixels Property
Can disable reading of pixel values
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DontReadPixels As Boolean
'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.DontReadPixels = value

value = instance.DontReadPixels
public bool DontReadPixels {get; set;}
public:
property bool DontReadPixels {
   bool get();
   void set (    bool value);
}
Remarks

The default value of this property is derived from the DontReadPixels value of the internal registry, which in turn has a default value of 0, causing this property to be false.

This property can sometimes be useful when scanning a large set of images soley for indexing

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ReadBehaviours Class
ReadBehaviours Members


IgnoreAfterPixels Property

IgnoreAfterPixels Property

DicomObjects Namespace > ReadBehaviours Class : IgnoreAfterPixels Property
Controls whether all data after the pixel data is to be ignored.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property IgnoreAfterPixels As Boolean
'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.IgnoreAfterPixels = value

value = instance.IgnoreAfterPixels
public bool IgnoreAfterPixels {get; set;}
public:
property bool IgnoreAfterPixels {
   bool get();
   void set (    bool value);
}
Remarks

It may give the following advantages in some situations:

  • When there is rubbish at the end of the file
  • When reading very large compressed files, as it avoids the need to scan to the end of the pixel data.

The default value of this property is derived from the IgnoreAfterPixels value of the internal registry, which in turn has a default value of 0, causing this property to be false.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ReadBehaviours Class
ReadBehaviours Members


IgnoreAfterTag Property

IgnoreAfterTag Property

DicomObjects Namespace > ReadBehaviours Class : IgnoreAfterTag Property
Controls whether all data after a specifc tag is to be ignored. Value shall be in ggggeeee hex format, such as 0x00100010 for patient name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property IgnoreAfterTag As UInteger
'Usage

Dim instance As ReadBehaviours
Dim value As UInteger

instance.IgnoreAfterTag = value

value = instance.IgnoreAfterTag
public uint IgnoreAfterTag {get; set;}
public:
property uint IgnoreAfterTag {
   uint get();
   void set (    uint value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ReadBehaviours Class
ReadBehaviours Members


IgnoreBOT Property

IgnoreBOT Property

DicomObjects Namespace > ReadBehaviours Class : IgnoreBOT Property
Ignore any Basic Offset Table which may be present in the received data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property IgnoreBOT As Boolean
'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.IgnoreBOT = value

value = instance.IgnoreBOT
public bool IgnoreBOT {get; set;}
public:
property bool IgnoreBOT {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ReadBehaviours Class
ReadBehaviours Members


IgnoreExceptions Property

IgnoreExceptions Property

DicomObjects Namespace > ReadBehaviours Class : IgnoreExceptions Property
Ignores a list of DicomObjects error codes accessible from DicomException.Code during reading from disk/network and puts together what has been successfully read. This is particularly useful to skip exceptions and keep the association open to continue reading.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property IgnoreExceptions As Integer()
'Usage

Dim instance As ReadBehaviours
Dim value() As Integer

instance.IgnoreExceptions = value

value = instance.IgnoreExceptions
public int[] IgnoreExceptions {get; set;}
public:
property array<int>^ IgnoreExceptions {
   array<int>^ get();
   void set (    array<int>^ value);
}
Remarks
Similar to IgnoreAfterPixels, in which it excludes only error in while reading after Pixel data. This is more expansive as it ignores all listed exceptions while reading
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ReadBehaviours Class
ReadBehaviours Members


IgnoreIconLengths Property

IgnoreIconLengths Property

DicomObjects Namespace > ReadBehaviours Class : IgnoreIconLengths Property
Ignore the lengths of the pixel data in icon sequences
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property IgnoreIconLengths As Boolean
'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.IgnoreIconLengths = value

value = instance.IgnoreIconLengths
public bool IgnoreIconLengths {get; set;}
public:
property bool IgnoreIconLengths {
   bool get();
   void set (    bool value);
}
Remarks

The default value of this property is derived from the IgnoreIconLengths value of the internal registry, which in turn has a default value of 0, causing this property to be false.

Many manufacturers (including the largest!) still create images containing ICON images (either in the official DICOM icon sequence - 0088,0200 or in private sequences) which are badly formatted with innappropriate length (commonly being compressed, when the DICOM rules require them to be compressed). If set, this property causes such pixel data to be treated simply as a byte array, ignoring the length (but disabling transfer syntax conversion of it)

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ReadBehaviours Class
ReadBehaviours Members


IgnorePrivateSequences Property

IgnorePrivateSequences Property

DicomObjects Namespace > ReadBehaviours Class : IgnorePrivateSequences Property
If set, private sequence items are skipped.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property IgnorePrivateSequences As Boolean
'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.IgnorePrivateSequences = value

value = instance.IgnorePrivateSequences
public bool IgnorePrivateSequences {get; set;}
public:
property bool IgnorePrivateSequences {
   bool get();
   void set (    bool value);
}
Remarks

The default value of this property is derived from the IgnorePrivateSequences value of the internal registry, which in turn has a default value of 0, causing this property to be false.

Badly formed data in private sequences is unfortunately very common, and setting this property can allow some such data (if it has an explicit length) to be ignored, allowing the remainder of a dataset to be read.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ReadBehaviours Class
ReadBehaviours Members


SilentEndOfFileReached Property

SilentEndOfFileReached Property

DicomObjects Namespace > ReadBehaviours Class : SilentEndOfFileReached Property
Set to true to tell DicomObjects to not throw End Of File Reached exception and stop reading from file when an attribute with bad length is encountered. Default value is false
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SilentEndOfFileReached As Boolean
'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.SilentEndOfFileReached = value

value = instance.SilentEndOfFileReached
public bool SilentEndOfFileReached {get; set;}
public:
property bool SilentEndOfFileReached {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ReadBehaviours Class
ReadBehaviours Members


ThrowNotDICOMDIRError Property

ThrowNotDICOMDIRError Property

DicomObjects Namespace > ReadBehaviours Class : ThrowNotDICOMDIRError Property
Controls whether to throw an exception if a file which is apparently a DICOM does not contain the expected DICOMDIR offset attributes.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ThrowNotDICOMDIRError As Boolean
'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.ThrowNotDICOMDIRError = value

value = instance.ThrowNotDICOMDIRError
public bool ThrowNotDICOMDIRError {get; set;}
public:
property bool ThrowNotDICOMDIRError {
   bool get();
   void set (    bool value);
}
Remarks

The default value of this property is derived from the ThrowNotDICOMDIRError value of the internal registry, which in turn has a default value of 1, causing this property to be true.

This error can sometimes be triggered by files which are not DICOMDIRs but which for some reason do not contain a SOP class UID.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ReadBehaviours Class
ReadBehaviours Members


TolerateBadOffsets Property

TolerateBadOffsets Property

DicomObjects Namespace > ReadBehaviours Class : TolerateBadOffsets Property
Ignore bad "offset" data when reading a DICOMDIR
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TolerateBadOffsets As Boolean
'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.TolerateBadOffsets = value

value = instance.TolerateBadOffsets
public bool TolerateBadOffsets {get; set;}
public:
property bool TolerateBadOffsets {
   bool get();
   void set (    bool value);
}
Remarks

The default value of this property is derived from the TolerateBadOffsets value of the internal registry, which in turn has a default value of 0, causing this property to be false.

Setting this to true may enable some otherwise unreadable DICOMDIR files to the read, but as the bizarre mechanism used to organise DICOMDIR files is based on using offsets, the resulting DicomDataSet may not be a complete representation of the file.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ReadBehaviours Class
ReadBehaviours Members


ZeissBug Property

ZeissBug Property

DicomObjects Namespace > ReadBehaviours Class : ZeissBug Property
A workaround for old bad Zeiss Data, some of which had UT attributes with 2 Bytes length
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ZeissBug As Boolean
'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.ZeissBug = value

value = instance.ZeissBug
public bool ZeissBug {get; set;}
public:
property bool ZeissBug {
   bool get();
   void set (    bool value);
}
Remarks
The default value of this property is derived from the ZeissBug value of the internal registry, which in turn has a default value of 0, causing this property to be false.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ReadBehaviours Class
ReadBehaviours Members


ValidationOptions Class

ValidationOptions Class
Members

DicomObjects Namespace : ValidationOptions Class
Options to validate DicomDataSet and its DicomAttributes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ValidationOptions
'Usage

Dim instance As ValidationOptions
public class ValidationOptions
public ref class ValidationOptions
Inheritance Hierarchy

System.Object
DicomObjects.ValidationOptions

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ValidationOptions Members
DicomObjects Namespace


ValidationOptions Class Members

ValidationOptions Class Members
Properties Methods

DicomObjects Namespace : ValidationOptions Class

The following tables list the members exposed by ValidationOptions.

Public Constructors
 | Name | Description
Public Constructor | ValidationOptions Constructor |
Top
Public Properties
 | Name | Description
static (Shared in Visual Basic) | All | Generate a Full ValidationOptions object
Public Property | CharacterSet | Validation for Character Set if Non-ASCII characters are present Specifically checking for (0008,0005) Specific Character Set. Refer to the Standard for more details
Public Property | DataLength | Include data length compatibility check for VR as specified in the Standard (Length of Value)
Public Property | Detailed | Include data length compatibility check for VR (Character Repertoire) and allowed VM for associated attribute as specified in the Standard
Public Property | ForQuery | Validation for attributes in the context of a Query with range matching Refer to the Standard for more details
static (Shared in Visual Basic) | None | Generate a No ValidationOptions object
Public Property | PrivateAttributes | Validation of Private Attributes if present Non-standard, DicomObjects only option. Default is to skip validation for these types
Public Property | PrivateSequences | Validation of Private Sequences if present Non-standard, DicomObjects only option. Default is to skip validation for these types
static (Shared in Visual Basic) | Query | Generate a ValidationOptions object with ForQuery enabled
Top
Public Methods
 | Name | Description
Public Method | Equals | Member comparison
Public Method | GetHashCode | Generate member hash
Top
See Also

Reference

ValidationOptions Class
DicomObjects Namespace


ValidationOptions Constructor

ValidationOptions Constructor

DicomObjects Namespace > ValidationOptions Class : ValidationOptions Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ValidationOptions()
public ValidationOptions()
public:
ValidationOptions();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ValidationOptions Class
ValidationOptions Members


ValidationOptions Class Methods

ValidationOptions Class Methods

DicomObjects Namespace : ValidationOptions Class

For a list of all members of this type, see ValidationOptions members.

Public Methods
 | Name | Description
Public Method | Equals | Member comparison
Public Method | GetHashCode | Generate member hash
Top
See Also

Reference

ValidationOptions Class
DicomObjects Namespace


Equals Method (ValidationOptions)

Equals Method (ValidationOptions)

DicomObjects Namespace > ValidationOptions Class : Equals Method
ValidationOptions to compare
Member comparison
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As ValidationOptions
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
ValidationOptions to compare

Return Value

Comparison result
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ValidationOptions Class
ValidationOptions Members
Base Implementation in Equals


GetHashCode Method (ValidationOptions)

GetHashCode Method (ValidationOptions)

DicomObjects Namespace > ValidationOptions Class : GetHashCode Method
Generate member hash
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As ValidationOptions
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

Combined hash code
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ValidationOptions Class
ValidationOptions Members
Base Implementation in GetHashCode


ValidationOptions Class Properties

ValidationOptions Class Properties

DicomObjects Namespace : ValidationOptions Class

For a list of all members of this type, see ValidationOptions members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | All | Generate a Full ValidationOptions object
Public Property | CharacterSet | Validation for Character Set if Non-ASCII characters are present Specifically checking for (0008,0005) Specific Character Set. Refer to the Standard for more details
Public Property | DataLength | Include data length compatibility check for VR as specified in the Standard (Length of Value)
Public Property | Detailed | Include data length compatibility check for VR (Character Repertoire) and allowed VM for associated attribute as specified in the Standard
Public Property | ForQuery | Validation for attributes in the context of a Query with range matching Refer to the Standard for more details
static (Shared in Visual Basic) | None | Generate a No ValidationOptions object
Public Property | PrivateAttributes | Validation of Private Attributes if present Non-standard, DicomObjects only option. Default is to skip validation for these types
Public Property | PrivateSequences | Validation of Private Sequences if present Non-standard, DicomObjects only option. Default is to skip validation for these types
static (Shared in Visual Basic) | Query | Generate a ValidationOptions object with ForQuery enabled
Top
See Also

Reference

ValidationOptions Class
DicomObjects Namespace


All Property

All Property

DicomObjects Namespace > ValidationOptions Class : All Property
Generate a Full ValidationOptions object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property All As ValidationOptions
'Usage

Dim value As ValidationOptions

value = ValidationOptions.All
public static ValidationOptions All {get;}
public:
static property ValidationOptions^ All {
   ValidationOptions^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ValidationOptions Class
ValidationOptions Members


CharacterSet Property

CharacterSet Property

DicomObjects Namespace > ValidationOptions Class : CharacterSet Property
Validation for Character Set if Non-ASCII characters are present

Specifically checking for (0008,0005) Specific Character Set. Refer to the Standard for more details

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CharacterSet As Boolean
'Usage

Dim instance As ValidationOptions
Dim value As Boolean

instance.CharacterSet = value

value = instance.CharacterSet
public bool CharacterSet {get; set;}
public:
property bool CharacterSet {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ValidationOptions Class
ValidationOptions Members


DataLength Property

DataLength Property

DicomObjects Namespace > ValidationOptions Class : DataLength Property
Include data length compatibility check for VR as specified in the Standard (Length of Value)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DataLength As Boolean
'Usage

Dim instance As ValidationOptions
Dim value As Boolean

instance.DataLength = value

value = instance.DataLength
public bool DataLength {get; set;}
public:
property bool DataLength {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ValidationOptions Class
ValidationOptions Members


Detailed Property

Detailed Property

DicomObjects Namespace > ValidationOptions Class : Detailed Property
Include data length compatibility check for VR (Character Repertoire) and allowed VM for associated attribute as specified in the Standard
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Detailed As Boolean
'Usage

Dim instance As ValidationOptions
Dim value As Boolean

instance.Detailed = value

value = instance.Detailed
public bool Detailed {get; set;}
public:
property bool Detailed {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ValidationOptions Class
ValidationOptions Members


ForQuery Property

ForQuery Property

DicomObjects Namespace > ValidationOptions Class : ForQuery Property
Validation for attributes in the context of a Query with range matching

Refer to the Standard for more details

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ForQuery As Boolean
'Usage

Dim instance As ValidationOptions
Dim value As Boolean

instance.ForQuery = value

value = instance.ForQuery
public bool ForQuery {get; set;}
public:
property bool ForQuery {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ValidationOptions Class
ValidationOptions Members


None Property

None Property

DicomObjects Namespace > ValidationOptions Class : None Property
Generate a No ValidationOptions object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property None As ValidationOptions
'Usage

Dim value As ValidationOptions

value = ValidationOptions.None
public static ValidationOptions None {get;}
public:
static property ValidationOptions^ None {
   ValidationOptions^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ValidationOptions Class
ValidationOptions Members


PrivateAttributes Property

PrivateAttributes Property

DicomObjects Namespace > ValidationOptions Class : PrivateAttributes Property
Validation of Private Attributes if present

Non-standard, DicomObjects only option. Default is to skip validation for these types

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PrivateAttributes As Boolean
'Usage

Dim instance As ValidationOptions
Dim value As Boolean

instance.PrivateAttributes = value

value = instance.PrivateAttributes
public bool PrivateAttributes {get; set;}
public:
property bool PrivateAttributes {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ValidationOptions Class
ValidationOptions Members


PrivateSequences Property

PrivateSequences Property

DicomObjects Namespace > ValidationOptions Class : PrivateSequences Property
Validation of Private Sequences if present

Non-standard, DicomObjects only option. Default is to skip validation for these types

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PrivateSequences As Boolean
'Usage

Dim instance As ValidationOptions
Dim value As Boolean

instance.PrivateSequences = value

value = instance.PrivateSequences
public bool PrivateSequences {get; set;}
public:
property bool PrivateSequences {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ValidationOptions Class
ValidationOptions Members


Query Property

Query Property

DicomObjects Namespace > ValidationOptions Class : Query Property
Generate a ValidationOptions object with ForQuery enabled
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Query As ValidationOptions
'Usage

Dim value As ValidationOptions

value = ValidationOptions.Query
public static ValidationOptions Query {get;}
public:
static property ValidationOptions^ Query {
   ValidationOptions^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ValidationOptions Class
ValidationOptions Members


WriteBehaviours Class

WriteBehaviours Class
Members

DicomObjects Namespace : WriteBehaviours Class
Specific behaviour to use when writing/sending a DICOM instance
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class WriteBehaviours
'Usage

Dim instance As WriteBehaviours
public class WriteBehaviours
public ref class WriteBehaviours
Remarks

An object of this class may be used in 4 ways:

  • As a parameter to one of the overrides of DicomDataSet.Write
  • By assiging to DicomGlobal.DefaultWriteBehaviour
  • By setting the WriteBehaviour property of an explicitly created DicomAssociation
  • By setting the WriteBehaviour property of an internally generated DicomAssociation object during the DicomServer.AssociationRequest event

Most of the behaviours controlled by the properties of this object may also be set globally using the internal registry, but this object allows more granular control.

Inheritance Hierarchy

System.Object
DicomObjects.WriteBehaviours

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WriteBehaviours Members
DicomObjects Namespace


WriteBehaviours Class Members

WriteBehaviours Class Members
Properties

DicomObjects Namespace : WriteBehaviours Class

The following tables list the members exposed by WriteBehaviours.

Public Constructors
 | Name | Description
Public Constructor | WriteBehaviours Constructor | Create a new WriteBehaviours object
Top
Public Properties
 | Name | Description
Public Property | AllowOddLengths | Allows data to do be written with odd lengths
Public Property | ChangeLossyAttributes | Controls whether DicomObjects alters Lossy compression related attributes (for e.g. Instance UID, Source Image Sequence and Image Type) to reflect the change in data due to lossy compression. ChangeLossyUIDs is a subset of this property where that only controls the UID changes but the other attributes are updated appropriately
Public Property | ChangeLossyUIDs | Controls whether DicomObjects changes the UID when doing lossy compression
Public Property | DontCompressIcons | Controls whether to compress icon pixcel data if using an encapsulated (compressed) transfer syntax.
Public Property | ImplicitSequenceItemLength | Controls whether sequence itemss are written out using Implicit or Explicit lengths for the sequence
Public Property | ImplicitSequenceLength | Controls whether sequences are written out using Implicit or Explicit lengths for the sequence
Public Property | NonSeekableBotHandling | Controls the creation of the Basic Offset Table (BOT) when writing data to non-seekable streams such as the network.
Public Property | OmitJpegComments | Controls whether to include JPEG comments during compression
Public Property | OverwriteWithCorrectVR | Controls the correction of mismatching VR. If this settings is enabled correction of wrong VR for all attributes will be attempted when writing out or sending, this won't affect the original dataset
Public Property | RescaleCTs | Controls whether to make changes to the rescale slope and offset if compressing to a smaller range.
Public Property | SeekableBotHandling | Controls the creation of the Basic Offset Table (BOT) when writing data to seekable streams such as files.
Top
See Also

Reference

WriteBehaviours Class
DicomObjects Namespace


WriteBehaviours Constructor

WriteBehaviours Constructor

DicomObjects Namespace > WriteBehaviours Class : WriteBehaviours Constructor
Create a new WriteBehaviours object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New WriteBehaviours()
public WriteBehaviours()
public:
WriteBehaviours();
Remarks
The properties are all initialised from global or "registry" values, as described in each individual property
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WriteBehaviours Class
WriteBehaviours Members


WriteBehaviours Class Properties

WriteBehaviours Class Properties

DicomObjects Namespace : WriteBehaviours Class

For a list of all members of this type, see WriteBehaviours members.

Public Properties
 | Name | Description
Public Property | AllowOddLengths | Allows data to do be written with odd lengths
Public Property | ChangeLossyAttributes | Controls whether DicomObjects alters Lossy compression related attributes (for e.g. Instance UID, Source Image Sequence and Image Type) to reflect the change in data due to lossy compression. ChangeLossyUIDs is a subset of this property where that only controls the UID changes but the other attributes are updated appropriately
Public Property | ChangeLossyUIDs | Controls whether DicomObjects changes the UID when doing lossy compression
Public Property | DontCompressIcons | Controls whether to compress icon pixcel data if using an encapsulated (compressed) transfer syntax.
Public Property | ImplicitSequenceItemLength | Controls whether sequence itemss are written out using Implicit or Explicit lengths for the sequence
Public Property | ImplicitSequenceLength | Controls whether sequences are written out using Implicit or Explicit lengths for the sequence
Public Property | NonSeekableBotHandling | Controls the creation of the Basic Offset Table (BOT) when writing data to non-seekable streams such as the network.
Public Property | OmitJpegComments | Controls whether to include JPEG comments during compression
Public Property | OverwriteWithCorrectVR | Controls the correction of mismatching VR. If this settings is enabled correction of wrong VR for all attributes will be attempted when writing out or sending, this won't affect the original dataset
Public Property | RescaleCTs | Controls whether to make changes to the rescale slope and offset if compressing to a smaller range.
Public Property | SeekableBotHandling | Controls the creation of the Basic Offset Table (BOT) when writing data to seekable streams such as files.
Top
See Also

Reference

WriteBehaviours Class
DicomObjects Namespace


AllowOddLengths Property

AllowOddLengths Property

DicomObjects Namespace > WriteBehaviours Class : AllowOddLengths Property
Allows data to do be written with odd lengths
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AllowOddLengths As Boolean
'Usage

Dim instance As WriteBehaviours
Dim value As Boolean

instance.AllowOddLengths = value

value = instance.AllowOddLengths
public bool AllowOddLengths {get; set;}
public:
property bool AllowOddLengths {
   bool get();
   void set (    bool value);
}
Remarks

The default value of this property is derived from the AllowOddLengths value of the internal registry, which in turn has a default value of 0, causing this property to be false.

Data written with this property set does not conform to the DICOM standard, and this property should only be used either for testing, or when re-writing faulty files in an environment where bit-preservation is expected.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WriteBehaviours Class
WriteBehaviours Members


ChangeLossyAttributes Property

ChangeLossyAttributes Property

DicomObjects Namespace > WriteBehaviours Class : ChangeLossyAttributes Property
Controls whether DicomObjects alters Lossy compression related attributes (for e.g. Instance UID, Source Image Sequence and Image Type) to reflect the change in data due to lossy compression. ChangeLossyUIDs is a subset of this property where that only controls the UID changes but the other attributes are updated appropriately
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ChangeLossyAttributes As Boolean
'Usage

Dim instance As WriteBehaviours
Dim value As Boolean

instance.ChangeLossyAttributes = value

value = instance.ChangeLossyAttributes
public bool ChangeLossyAttributes {get; set;}
public:
property bool ChangeLossyAttributes {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WriteBehaviours Class
WriteBehaviours Members


ChangeLossyUIDs Property (WriteBehaviours)

ChangeLossyUIDs Property (WriteBehaviours)

DicomObjects Namespace > WriteBehaviours Class : ChangeLossyUIDs Property
Controls whether DicomObjects changes the UID when doing lossy compression
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ChangeLossyUIDs As Boolean
'Usage

Dim instance As WriteBehaviours
Dim value As Boolean

instance.ChangeLossyUIDs = value

value = instance.ChangeLossyUIDs
public bool ChangeLossyUIDs {get; set;}
public:
property bool ChangeLossyUIDs {
   bool get();
   void set (    bool value);
}
Remarks

This is initialised from DicomGlobal.ChangeLossyUIDs - see that property for more details of the effects of this property.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WriteBehaviours Class
WriteBehaviours Members


DontCompressIcons Property

DontCompressIcons Property

DicomObjects Namespace > WriteBehaviours Class : DontCompressIcons Property
Controls whether to compress icon pixcel data if using an encapsulated (compressed) transfer syntax.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DontCompressIcons As Boolean
'Usage

Dim instance As WriteBehaviours
Dim value As Boolean

instance.DontCompressIcons = value

value = instance.DontCompressIcons
public bool DontCompressIcons {get; set;}
public:
property bool DontCompressIcons {
   bool get();
   void set (    bool value);
}
Remarks

DICOM allows icon images to be either compressed (with an implicit length) or uncompressed (with an explicit length), and this property allows develoeprs to choose which to use.

The default value of this property is derived from the DontCompressIcons value of the internal registry, which in turn has a default value of 0, causing this property to be false, causing icons to be compressed as per the transfer syntax of the surrounding dataset

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WriteBehaviours Class
WriteBehaviours Members


ImplicitSequenceItemLength Property

ImplicitSequenceItemLength Property

DicomObjects Namespace > WriteBehaviours Class : ImplicitSequenceItemLength Property
Controls whether sequence itemss are written out using Implicit or Explicit lengths for the sequence
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ImplicitSequenceItemLength As Boolean
'Usage

Dim instance As WriteBehaviours
Dim value As Boolean

instance.ImplicitSequenceItemLength = value

value = instance.ImplicitSequenceItemLength
public bool ImplicitSequenceItemLength {get; set;}
public:
property bool ImplicitSequenceItemLength {
   bool get();
   void set (    bool value);
}
Remarks

For sequences, DICOM allows either explicit or implicit length to be used for the individual sequence itmes, and when reading/receiving, both are accepted. This is separate from the choice made for the sequence itself, which is controlled by the ImplicitSequenceLength property.

The default value of this property is derived from the the bit 1 of the ImplicitSequence value the internal registry, which in turn has a default value of 0, causing this property to be false, resulting in explicit sequence item lengths being used.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WriteBehaviours Class
WriteBehaviours Members


ImplicitSequenceLength Property

ImplicitSequenceLength Property

DicomObjects Namespace > WriteBehaviours Class : ImplicitSequenceLength Property
Controls whether sequences are written out using Implicit or Explicit lengths for the sequence
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ImplicitSequenceLength As Boolean
'Usage

Dim instance As WriteBehaviours
Dim value As Boolean

instance.ImplicitSequenceLength = value

value = instance.ImplicitSequenceLength
public bool ImplicitSequenceLength {get; set;}
public:
property bool ImplicitSequenceLength {
   bool get();
   void set (    bool value);
}
Remarks

For sequences, DICOM allows either explicit or implicit length to be used for the sequence itself, and when reading/receiving, both are accepted. This is separate from the choice made for individual sequence items, which are controlled by the ImplicitSequenceItemLength property.

The default value of this property is derived from the the bit 0 of the ImplicitSequence value the internal registry, which in turn has a default value of 0, causing this property to be false, resulting in explicit sequence lengths being used.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WriteBehaviours Class
WriteBehaviours Members


NonSeekableBotHandling Property

NonSeekableBotHandling Property

DicomObjects Namespace > WriteBehaviours Class : NonSeekableBotHandling Property
Controls the creation of the Basic Offset Table (BOT) when writing data to non-seekable streams such as the network.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NonSeekableBotHandling As BasicOffsetTableHandling
'Usage

Dim instance As WriteBehaviours
Dim value As BasicOffsetTableHandling

instance.NonSeekableBotHandling = value

value = instance.NonSeekableBotHandling
public BasicOffsetTableHandling NonSeekableBotHandling {get; set;}
public:
property BasicOffsetTableHandling NonSeekableBotHandling {
   BasicOffsetTableHandling get();
   void set (    BasicOffsetTableHandling value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WriteBehaviours Class
WriteBehaviours Members


OmitJpegComments Property

OmitJpegComments Property

DicomObjects Namespace > WriteBehaviours Class : OmitJpegComments Property
Controls whether to include JPEG comments during compression
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OmitJpegComments As Boolean
'Usage

Dim instance As WriteBehaviours
Dim value As Boolean

instance.OmitJpegComments = value

value = instance.OmitJpegComments
public bool OmitJpegComments {get; set;}
public:
property bool OmitJpegComments {
   bool get();
   void set (    bool value);
}
Remarks
This parameter is set to false by default (i.e. include JPEG comments in the output)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WriteBehaviours Class
WriteBehaviours Members


OverwriteWithCorrectVR Property

OverwriteWithCorrectVR Property

DicomObjects Namespace > WriteBehaviours Class : OverwriteWithCorrectVR Property
Controls the correction of mismatching VR. If this settings is enabled correction of wrong VR for all attributes will be attempted when writing out or sending, this won't affect the original dataset
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OverwriteWithCorrectVR As Boolean
'Usage

Dim instance As WriteBehaviours
Dim value As Boolean

instance.OverwriteWithCorrectVR = value

value = instance.OverwriteWithCorrectVR
public bool OverwriteWithCorrectVR {get; set;}
public:
property bool OverwriteWithCorrectVR {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WriteBehaviours Class
WriteBehaviours Members


RescaleCTs Property

RescaleCTs Property

DicomObjects Namespace > WriteBehaviours Class : RescaleCTs Property
Controls whether to make changes to the rescale slope and offset if compressing to a smaller range.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RescaleCTs As Boolean
'Usage

Dim instance As WriteBehaviours
Dim value As Boolean

instance.RescaleCTs = value

value = instance.RescaleCTs
public bool RescaleCTs {get; set;}
public:
property bool RescaleCTs {
   bool get();
   void set (    bool value);
}
Remarks

The changes are needed to maintain proper Hounsfield units for CT, so this value should only be set to false for very specific test circumastances.

The default value of this property is derived from the RescaleCTs value of the internal registry, which in turn has a default value of 1, causing this property to be true.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WriteBehaviours Class
WriteBehaviours Members


SeekableBotHandling Property

SeekableBotHandling Property

DicomObjects Namespace > WriteBehaviours Class : SeekableBotHandling Property
Controls the creation of the Basic Offset Table (BOT) when writing data to seekable streams such as files.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SeekableBotHandling As BasicOffsetTableHandling
'Usage

Dim instance As WriteBehaviours
Dim value As BasicOffsetTableHandling

instance.SeekableBotHandling = value

value = instance.SeekableBotHandling
public BasicOffsetTableHandling SeekableBotHandling {get; set;}
public:
property BasicOffsetTableHandling SeekableBotHandling {
   BasicOffsetTableHandling get();
   void set (    BasicOffsetTableHandling value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WriteBehaviours Class
WriteBehaviours Members


RenderMode3D Enumeration

RenderMode3D Enumeration

DicomObjects Namespace : RenderMode3D Enumeration
The types of 3D rendering available
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum RenderMode3D
   Inherits System.Enum
'Usage

Dim instance As RenderMode3D
public enum RenderMode3D : System.Enum
public enum class RenderMode3D : public System.Enum
Members
Member | Description
Average | Average - this is like MPR, but with a finite thickness
Maximum | Maximum Intensity Projection
Minimum | Minimum Intensity Projection
MPR | Multi-planar reformatting
VR | Volume Rendering
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.RenderMode3D

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects Namespace


Plane3D Structure

Plane3D Structure
Members

DicomObjects Namespace : Plane3D Structure
Defines a plane in 3D space.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Structure Plane3D
   Inherits System.ValueType
'Usage

Dim instance As Plane3D
public struct Plane3D : System.ValueType
public value class Plane3D : public System.ValueType
Remarks
A plane is defined in 3D space by the equation Ax + By + Cz + D = 0 This equates to a vector (the normal of the plane, whose x, y and z components equate to the coefficients A, B and C respectively), and a constant (D) which is the distance along the normal you have to go to move the plane back to the origin.
Inheritance Hierarchy

System.Object
System.ValueType
DicomObjects.Plane3D

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Plane3D Members
DicomObjects Namespace


Plane3D Structure Members

Plane3D Structure Members
Fields Properties Methods

DicomObjects Namespace : Plane3D Structure

The following tables list the members exposed by Plane3D.

Public Constructors
 | Name | Description
Public Constructor | Plane3D Constructor | Overloaded. Construct a plane
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | Vector3DZero | Static constructor - merely sets up Vector3DZero
Top
Public Properties
 | Name | Description
Public Property | D | Distance from the origin.
Public Property | Normal | Direction the plane is facing.
Top
Public Methods
 | Name | Description
Public Method | Equals | Object method for testing equality.
Public Method | GetDistance | Distance of a point from the plane
Public Method | GetHashCode | Returns the hash code for this instance.
Public Method | Horizontal2D | The arbitrary "X" axis for this plane
static (Shared in Visual Basic) | PlaneIntersection | Overloaded. Calculate the line of intersection between 2 planes
Public Method | To2D | Convert from real world coordinates to the arbitrary frame of reference for this plane
Public Method | To3D | Convert from the arbitrary frame of reference for this plane to real world coordinates
Public Method | ToString | Returns a string representation of this Plane.
Public Method | Vertical2D | The arbitrary "Y" axis for this plane
Top
Public Operators
public Operator Equality | Compares 2 Planes for equality.
public Operator Inequality | Compares 2 Planes for inequality.
Top
See Also

Reference

Plane3D Structure
DicomObjects Namespace


Plane3D Constructor

Plane3D Constructor

DicomObjects Namespace > Plane3D Structure : Plane3D Constructor
Construct a plane
Overload List
Overload | Description
Plane3D Constructor(Vector3D,Double) | Construct a plane with a defined normal, and a distance to move the plane along the normal.
Plane3D Constructor(Vector3D,Point3D) | Construct a plane with a defined normal, pasing through a defined point
Plane3D Constructor(Vector3D,Vector3D,Vector3D) | Construct a plane from 3 coplanar points.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Plane3D Structure
Plane3D Members


Plane3D Constructor(Vector3D,Double)

Plane3D Constructor(Vector3D,Double)

DicomObjects Namespace > Plane3D Structure > Plane3D Constructor : Plane3D Constructor(Vector3D,Double)
The normal to the plane
The distance to move
Construct a plane with a defined normal, and a distance to move the plane along the normal.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal Normal As Vector3D, _
   ByVal Constant As Double _
)
'Usage

Dim Normal As Vector3D
Dim Constant As Double

Dim instance As New Plane3D(Normal, Constant)
public Plane3D(
   Vector3D Normal,
   double Constant
)
public:
Plane3D(
   Vector3D Normal,
   double Constant
)

Parameters

Normal
The normal to the plane
Constant
The distance to move
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Plane3D Structure
Plane3D Members
Overload List


Plane3D Constructor(Vector3D,Point3D)

Plane3D Constructor(Vector3D,Point3D)

DicomObjects Namespace > Plane3D Structure > Plane3D Constructor : Plane3D Constructor(Vector3D,Point3D)
The normal to the plane
The point to pass through
Construct a plane with a defined normal, pasing through a defined point
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal Normal As Vector3D, _
   ByVal Point As Point3D _
)
'Usage

Dim Normal As Vector3D
Dim Point As Point3D

Dim instance As New Plane3D(Normal, Point)
public Plane3D(
   Vector3D Normal,
   Point3D Point
)
public:
Plane3D(
   Vector3D Normal,
   Point3D Point
)

Parameters

Normal
The normal to the plane
Point
The point to pass through
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Plane3D Structure
Plane3D Members
Overload List


Plane3D Constructor(Vector3D,Vector3D,Vector3D)

Plane3D Constructor(Vector3D,Vector3D,Vector3D)

DicomObjects Namespace > Plane3D Structure > Plane3D Constructor : Plane3D Constructor(Vector3D,Vector3D,Vector3D)
First point.
Second point.
Third point.
Construct a plane from 3 coplanar points.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal point0 As Vector3D, _
   ByVal point1 As Vector3D, _
   ByVal point2 As Vector3D _
)
'Usage

Dim point0 As Vector3D
Dim point1 As Vector3D
Dim point2 As Vector3D

Dim instance As New Plane3D(point0, point1, point2)
public Plane3D(
   Vector3D point0,
   Vector3D point1,
   Vector3D point2
)
public:
Plane3D(
   Vector3D point0,
   Vector3D point1,
   Vector3D point2
)

Parameters

point0
First point.
point1
Second point.
point2
Third point.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Plane3D Structure
Plane3D Members
Overload List


Plane3D Structure Methods

Plane3D Structure Methods

DicomObjects Namespace : Plane3D Structure

For a list of all members of this type, see Plane3D members.

Public Methods
 | Name | Description
Public Method | Equals | Object method for testing equality.
Public Method | GetDistance | Distance of a point from the plane
Public Method | GetHashCode | Returns the hash code for this instance.
Public Method | Horizontal2D | The arbitrary "X" axis for this plane
static (Shared in Visual Basic) | PlaneIntersection | Overloaded. Calculate the line of intersection between 2 planes
Public Method | To2D | Convert from real world coordinates to the arbitrary frame of reference for this plane
Public Method | To3D | Convert from the arbitrary frame of reference for this plane to real world coordinates
Public Method | ToString | Returns a string representation of this Plane.
Public Method | Vertical2D | The arbitrary "Y" axis for this plane
Top
See Also

Reference

Plane3D Structure
DicomObjects Namespace


Equals Method (Plane3D)

Equals Method (Plane3D)

DicomObjects Namespace > Plane3D Structure : Equals Method
Object to test.
Object method for testing equality.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As Plane3D
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to test.

Return Value

True if the 2 planes are logically equal, false otherwise.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Plane3D Structure
Plane3D Members
Base Implementation in Equals


GetDistance Method

GetDistance Method

DicomObjects Namespace > Plane3D Structure : GetDistance Method
The point being measured from
Distance of a point from the plane
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function GetDistance( _
   ByVal Point As Point3D _
) As Double
'Usage

Dim instance As Plane3D
Dim Point As Point3D
Dim value As Double

value = instance.GetDistance(Point)
public double GetDistance(
   Point3D Point
)
public:
double GetDistance(
   Point3D Point
)

Parameters

Point
The point being measured from

Return Value

The distance
Remarks
This is a psuedo-distance. The sign of the return value is positive if the point is on the positive side of the plane, negative if the point is on the negative side, and zero if the point is on the plane. The absolute value of the return value is the true distance only when the plane normal is a unit length vector.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Plane3D Structure
Plane3D Members


GetHashCode Method (Plane3D)

GetHashCode Method (Plane3D)

DicomObjects Namespace > Plane3D Structure : GetHashCode Method
Returns the hash code for this instance.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As Plane3D
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

A 32-bit signed integer that is the hash code for this instance.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Plane3D Structure
Plane3D Members
Base Implementation in GetHashCode


Horizontal2D Method

Horizontal2D Method

DicomObjects Namespace > Plane3D Structure : Horizontal2D Method
The arbitrary "X" axis for this plane
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function Horizontal2D() As Vector3D
'Usage

Dim instance As Plane3D
Dim value As Vector3D

value = instance.Horizontal2D()
public Vector3D Horizontal2D()
public:
Vector3D Horizontal2D();

Return Value

The direction, in real world coordinates, of the X-axis of that frame of reference.
Remarks
In order to provide consistent display of 2D labels on 3D images, despite rotation of the 3D image, coordinates for 3D labels are treated as being relative to an arbitrary coordinate system, which is based on the direction of the normal to the plane.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Plane3D Structure
Plane3D Members


PlaneIntersection Method

PlaneIntersection Method

DicomObjects Namespace > Plane3D Structure : PlaneIntersection Method
Calculate the line of intersection between 2 planes
Overload List
Overload | Description
PlaneIntersection(Plane3D,Plane3D) | Calculate the line of intersection between 2 planes
PlaneIntersection(Plane3D,Plane3D,Plane3D) | Calculate the point of intersection between 3 planes
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Plane3D Structure
Plane3D Members


PlaneIntersection(Plane3D,Plane3D) Method

PlaneIntersection(Plane3D,Plane3D) Method

DicomObjects Namespace > Plane3D Structure > PlaneIntersection Method : PlaneIntersection(Plane3D,Plane3D) Method
The first plane
The second plane
Calculate the line of intersection between 2 planes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Shared Function PlaneIntersection( _
   ByVal Plane1 As Plane3D, _
   ByVal Plane2 As Plane3D _
) As Nullable(Of Line3D)
'Usage

Dim Plane1 As Plane3D
Dim Plane2 As Plane3D
Dim value As Nullable(Of Line3D)

value = Plane3D.PlaneIntersection(Plane1, Plane2)
public static Nullable<Line3D> PlaneIntersection(
   Plane3D Plane1,
   Plane3D Plane2
)
public:
static Nullable<Line3D> PlaneIntersection(
   Plane3D Plane1,
   Plane3D Plane2
)

Parameters

Plane1
The first plane
Plane2
The second plane

Return Value

The line of intersection, or null if the planes are parallel
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Plane3D Structure
Plane3D Members
Overload List


PlaneIntersection(Plane3D,Plane3D,Plane3D) Method

PlaneIntersection(Plane3D,Plane3D,Plane3D) Method

DicomObjects Namespace > Plane3D Structure > PlaneIntersection Method : PlaneIntersection(Plane3D,Plane3D,Plane3D) Method
The first plane
The second plane
The third plane
Calculate the point of intersection between 3 planes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Shared Function PlaneIntersection( _
   ByVal Plane1 As Plane3D, _
   ByVal Plane2 As Plane3D, _
   ByVal Plane3 As Plane3D _
) As Nullable(Of Vector3D)
'Usage

Dim Plane1 As Plane3D
Dim Plane2 As Plane3D
Dim Plane3 As Plane3D
Dim value As Nullable(Of Vector3D)

value = Plane3D.PlaneIntersection(Plane1, Plane2, Plane3)
public static Nullable<Vector3D> PlaneIntersection(
   Plane3D Plane1,
   Plane3D Plane2,
   Plane3D Plane3
)
public:
static Nullable<Vector3D> PlaneIntersection(
   Plane3D Plane1,
   Plane3D Plane2,
   Plane3D Plane3
)

Parameters

Plane1
The first plane
Plane2
The second plane
Plane3
The third plane

Return Value

The line of intersection, or zero if the planes do not ALL intersect
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Plane3D Structure
Plane3D Members
Overload List


To2D(Point3D) Method

To2D(Point3D) Method

DicomObjects Namespace > Plane3D Structure : To2D(Point3D) Method
Convert from real world coordinates to the arbitrary frame of reference for this plane
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function To2D( _
   ByVal p1 As Point3D _
) As PointF
'Usage

Dim instance As Plane3D
Dim p1 As Point3D
Dim value As PointF

value = instance.To2D(p1)
public PointF To2D(
   Point3D p1
)
public:
PointF To2D(
   Point3D p1
)

Parameters

p1

Return Value

The 2D coordinates, in the arbitrary frame of reference, of the point on the plane closest to the given real world coordinates
Remarks
In order to provide consistent display of 2D labels on 3D images, despite rotation of the 3D image, coordinates for 3D labels are treated as being relative to an arbitrary coordinate system, which is based on the direction of the normal to the plane.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Plane3D Structure
Plane3D Members


To3D Method

To3D Method

DicomObjects Namespace > Plane3D Structure : To3D Method
Convert from the arbitrary frame of reference for this plane to real world coordinates
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function To3D( _
   ByVal p1 As PointF _
) As Point3D
'Usage

Dim instance As Plane3D
Dim p1 As PointF
Dim value As Point3D

value = instance.To3D(p1)
public Point3D To3D(
   PointF p1
)
public:
Point3D To3D(
   PointF p1
)

Parameters

p1

Return Value

The real world coordinates of the point on the plane specified by the 2D coordinates, in the arbitrary frame of reference
Remarks
In order to provide consistent display of 2D labels on 3D images, despite rotation of the 3D image, coordinates for 3D labels are treated as being relative to an arbitrary coordinate system, which is based on the direction of the normal to the plane.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Plane3D Structure
Plane3D Members


ToString Method (Plane3D)

ToString Method (Plane3D)

DicomObjects Namespace > Plane3D Structure : ToString Method
Returns a string representation of this Plane.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As Plane3D
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A human readable version of the plane
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Plane3D Structure
Plane3D Members
Base Implementation in ToString


Vertical2D Method

Vertical2D Method

DicomObjects Namespace > Plane3D Structure : Vertical2D Method
The arbitrary "Y" axis for this plane
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function Vertical2D() As Vector3D
'Usage

Dim instance As Plane3D
Dim value As Vector3D

value = instance.Vertical2D()
public Vector3D Vertical2D()
public:
Vector3D Vertical2D();

Return Value

The direction, in real world coordinates, of the Y-axis of that frame of reference.
Remarks
In order to provide consistent display of 2D labels on 3D images, despite rotation of the 3D image, coordinates for 3D labels are treated as being relative to an arbitrary coordinate system, which is based on the direction of the normal to the plane.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Plane3D Structure
Plane3D Members


Plane3D Structure Properties

Plane3D Structure Properties

DicomObjects Namespace : Plane3D Structure

For a list of all members of this type, see Plane3D members.

Public Properties
 | Name | Description
Public Property | D | Distance from the origin.
Public Property | Normal | Direction the plane is facing.
Top
See Also

Reference

Plane3D Structure
DicomObjects Namespace


D Property

D Property

DicomObjects Namespace > Plane3D Structure : D Property
Distance from the origin.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property D As Double
'Usage

Dim instance As Plane3D
Dim value As Double

instance.D = value

value = instance.D
public double D {get; set;}
public:
property double D {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Plane3D Structure
Plane3D Members


Normal Property

Normal Property

DicomObjects Namespace > Plane3D Structure : Normal Property
Direction the plane is facing.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Normal As Vector3D
'Usage

Dim instance As Plane3D
Dim value As Vector3D

instance.Normal = value

value = instance.Normal
public Vector3D Normal {get; set;}
public:
property Vector3D Normal {
   Vector3D get();
   void set (    Vector3D value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Plane3D Structure
Plane3D Members


Plane3D Structure Fields

Plane3D Structure Fields

DicomObjects Namespace : Plane3D Structure

For a list of all members of this type, see Plane3D members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Vector3DZero | Static constructor - merely sets up Vector3DZero
Top
See Also

Reference

Plane3D Structure
DicomObjects Namespace


Vector3DZero Field

Vector3DZero Field

DicomObjects Namespace > Plane3D Structure : Vector3DZero Field
Static constructor - merely sets up Vector3DZero
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Vector3DZero As Vector3D
'Usage

Dim value As Vector3D

value = Plane3D.Vector3DZero
public static readonly Vector3D Vector3DZero
public:
static readonly Vector3D Vector3DZero
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Plane3D Structure
Plane3D Members


Equality Operator

Equality Operator

DicomObjects Namespace > Plane3D Structure : Equality Operator
First plane.
Second plane.
Compares 2 Planes for equality.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Operator =( _
   ByVal left As Plane3D, _
   ByVal right As Plane3D _
) As Boolean
'Usage

public bool operator ==(
   Plane3D left,
   Plane3D right
)
public:
bool operator ==(
   Plane3D left,
   Plane3D right
)

Parameters

left
First plane.
right
Second plane.

Return Value

true if equal, false if not equal.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Plane3D Structure
Plane3D Members


Inequality Operator

Inequality Operator

DicomObjects Namespace > Plane3D Structure : Inequality Operator
First plane.
Second plane.
Compares 2 Planes for inequality.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Operator <>( _
   ByVal left As Plane3D, _
   ByVal right As Plane3D _
) As Boolean
'Usage

public bool operator !=(
   Plane3D left,
   Plane3D right
)
public:
bool operator !=(
   Plane3D left,
   Plane3D right
)

Parameters

left
First plane.
right
Second plane.

Return Value

true if not equal, false if equal.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Plane3D Structure
Plane3D Members


IFrameSource Interface

IFrameSource Interface
Members

DicomObjects Namespace : IFrameSource Interface
A simple interface used by extension codecs for video
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IFrameSource
'Usage

Dim instance As IFrameSource
public interface IFrameSource
public interface class IFrameSource
Remarks
Whilst officialy public, this is primarily intended for use by internal MPEG codecs
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

IFrameSource Members
DicomObjects Namespace


IFrameSource Interface Members

IFrameSource Interface Members
Methods

DicomObjects Namespace : IFrameSource Interface

The following tables list the members exposed by IFrameSource.

Public Methods
 | Name | Description
Method | CalculatedNumberOfFrames | The number of frames, cacluated from the data itself
Method | Clone | Clone the frame source
Method | ReadFrame | Read one frame
Top
See Also

Reference

IFrameSource Interface
DicomObjects Namespace


IFrameSource Interface Methods

IFrameSource Interface Methods

DicomObjects Namespace : IFrameSource Interface

For a list of all members of this type, see IFrameSource members.

Public Methods
 | Name | Description
Method | CalculatedNumberOfFrames | The number of frames, cacluated from the data itself
Method | Clone | Clone the frame source
Method | ReadFrame | Read one frame
Top
See Also

Reference

IFrameSource Interface
DicomObjects Namespace


CalculatedNumberOfFrames Method

CalculatedNumberOfFrames Method

DicomObjects Namespace > IFrameSource Interface : CalculatedNumberOfFrames Method
The number of frames, cacluated from the data itself
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function CalculatedNumberOfFrames() As Integer
'Usage

Dim instance As IFrameSource
Dim value As Integer

value = instance.CalculatedNumberOfFrames()
int CalculatedNumberOfFrames()
int CalculatedNumberOfFrames();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

IFrameSource Interface
IFrameSource Members


Clone Method (IFrameSource)

Clone Method (IFrameSource)

DicomObjects Namespace > IFrameSource Interface : Clone Method
Clone the frame source
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function Clone() As IFrameSource
'Usage

Dim instance As IFrameSource
Dim value As IFrameSource

value = instance.Clone()
IFrameSource Clone()
IFrameSource^ Clone();

Return Value

An independent IFrameSource based on the original underlying data
Remarks
Cloning a frame source allows efficient use of filtergraphs, and this is called internally by DicomObjects
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

IFrameSource Interface
IFrameSource Members


ReadFrame Method

ReadFrame Method

DicomObjects Namespace > IFrameSource Interface : ReadFrame Method
The zero-based frame number to read
The array to put the data into
Total number of frames expected to be present
Read one frame
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub ReadFrame( _
   ByVal frame0 As Integer, _
   ByVal result As Array, _
   ByVal frameCount As Integer _
)
'Usage

Dim instance As IFrameSource
Dim frame0 As Integer
Dim result As Array
Dim frameCount As Integer

instance.ReadFrame(frame0, result, frameCount)
void ReadFrame(
   int frame0,
   Array result,
   int frameCount
)
void ReadFrame(
   int frame0,
   Array^ result,
   int frameCount
)

Parameters

frame0
The zero-based frame number to read
result
The array to put the data into
frameCount
Total number of frames expected to be present
Remarks
It is expected that result will contain a byte array in most cases
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

IFrameSource Interface
IFrameSource Members


DicomAttribute.DelayedDataRoutine Delegate

DicomAttribute.DelayedDataRoutine Delegate

DicomObjects Namespace : DicomAttribute.DelayedDataRoutine Delegate
The dataset the bid is realted to
Delegate to fetch binary data for the bid
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Function DicomAttribute.DelayedDataRoutine( _
   ByVal ds As DicomDataSet _
) As Byte()
'Usage

Dim instance As New DicomAttribute.DelayedDataRoutine(AddressOf HandlerMethod)
public delegate byte[] DicomAttribute.DelayedDataRoutine(
   DicomDataSet ds
)
public delegate array<byte>^ DicomAttribute.DelayedDataRoutine(
   DicomDataSet^ ds
)

Parameters

ds
The dataset the bid is realted to

Return Value

Binary data as byte[]
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute.DelayedDataRoutine Members
DicomObjects Namespace


DicomObjects.Delegates Namespace

DicomObjects.Delegates Namespace
Inheritance Hierarchy
The delegates used for the definition of events
Delegates
 | Delegate | Description
Delegate | AssociationClosedHandler | Delegate for the DicomObjects.DicomServer.AssociationClosed event
Delegate | AssociationRequestHandler | Delegate for the DicomObjects.DicomServer.AssociationRequest event
Delegate | ChangeUidHandler | Delegate for the DicomObjects.DicomGlobal.OnChangeUid event
Delegate | DataChangedHandler | Delegate for the DicomObjects.DicomViewer.DataChanged event
Delegate | DisplayChangedHandler | Delegate for the DicomObjects.DicomViewer.DisplayChanged event
Delegate | DrawExceptionHandler | delegate for the DicomObjects.DicomViewer.DrawException event
Delegate | DrawStartHandler | Delegate used by the DicomObjects.DicomViewer.DrawStart event
Delegate | ErrorReceivedHandler | Delegate for the DicomObjects.DicomServer.ErrorReceived event
Delegate | GetUrlHandler | Delegate for the DicomObjects.DicomCodecs.Jpip.GetUri event
Delegate | InfoMessageHandler | Delegate for the DicomObjects.DicomServer.InfoMessage event
Delegate | InstanceReceivedHandler | Delegate for the DicomObjects.DicomServer.InstanceReceived Event
Delegate | LabelChangedHandler | Delegate for the DicomObjects.DicomLabel.LabelChanged event
Delegate | LicenseExpirationHandler | Delegate used by the LicenseExpirationEvent
Delegate | LogHandler | Delegate for the DicomObjects.DicomGlobal.LogEvent Event
Delegate | MakeControlHandler | Delegate for the "MakeControl" event of a DicomObjects.DicomViewer
Delegate | N_Event_ReportHandler | Delegate for the "N_Event_Report" events of a DicomObjects.DicomAssociation and DicomObjects.DicomServer
Delegate | NormalisedReceivedHandler | Delegate for the DicomObjects.DicomServer.NormalisedReceived event
Delegate | PositionChangedHandler | Delegate for the DicomObjects.DicomImage.PositionChanged event
Delegate | PSLabelCreatedHandler | Delegate for the DicomObjects.DicomLabel.PSLabelCreated event
Delegate | QueryReceivedHandler | Delegate for the DicomObjects.DicomServer.QueryReceived event
Delegate | ReceivingPixelDataHandler | Delegate used by the DicomObjects.DicomServer.ReceivingPixelData event
Delegate | ResponseReceivedHandler | Delegate for the DicomObjects.DicomAssociation.ResponseReceived and DicomObjects.DicomQuery.ResponseReceived events
Delegate | RetrieveLicenseHandler | Delegate for the DicomObjects.DicomLicense.RetrieveLicense event
Delegate | StatusUpdateHandler | Delegate for the DicomObjects.DicomCodecs.Jpip.StatusUpdate event
Delegate | StoreLicenseHandler | Delegate for DicomObjects.DicomLicense.StoreLicense event
Delegate | TlsAcceptor | Delegate used to accept TLS communications
Delegate | TlsInitiator | Delegate used to initiate TLS communications
Delegate | UserSmoothingHandler | Delegate for the DicomObjects.DicomImage.UserSmoothing event
Delegate | VerifyReceivedHandler | Delegate for the DicomObjects.DicomServer.VerifyReceived event
See Also

Reference

DicomObjects.NET.8.40 Assembly


AssociationClosedHandler Delegate

AssociationClosedHandler Delegate

DicomObjects.Delegates Namespace : AssociationClosedHandler Delegate
Sender as Object
e as AssocaitionClosedArgs
Delegate for the DicomObjects.DicomServer.AssociationClosed event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Sub AssociationClosedHandler( _
   ByVal Sender As Object, _
   ByVal e As AssociationClosedArgs _
)
'Usage

Dim instance As New AssociationClosedHandler(AddressOf HandlerMethod)
public delegate void AssociationClosedHandler(
   object Sender,
   AssociationClosedArgs e
)
public delegate void AssociationClosedHandler(
   Object^ Sender,
   AssociationClosedArgs^ e
)

Parameters

Sender
Sender as Object
e
e as AssocaitionClosedArgs
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

AssociationClosedHandler Members
DicomObjects.Delegates Namespace


AssociationRequestHandler Delegate

AssociationRequestHandler Delegate

DicomObjects.Delegates Namespace : AssociationRequestHandler Delegate
Sender as Object
e as AssociationRequestArgs
Delegate for the DicomObjects.DicomServer.AssociationRequest event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Sub AssociationRequestHandler( _
   ByVal Sender As Object, _
   ByVal e As AssociationRequestArgs _
)
'Usage

Dim instance As New AssociationRequestHandler(AddressOf HandlerMethod)
public delegate void AssociationRequestHandler(
   object Sender,
   AssociationRequestArgs e
)
public delegate void AssociationRequestHandler(
   Object^ Sender,
   AssociationRequestArgs^ e
)

Parameters

Sender
Sender as Object
e
e as AssociationRequestArgs
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

AssociationRequestHandler Members
DicomObjects.Delegates Namespace


ChangeUidHandler Delegate

ChangeUidHandler Delegate

DicomObjects.Delegates Namespace : ChangeUidHandler Delegate
Delegate for the DicomObjects.DicomGlobal.OnChangeUid event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Sub ChangeUidHandler( _
   ByVal e As ChangeUidArgs _
)
'Usage

Dim instance As New ChangeUidHandler(AddressOf HandlerMethod)
public delegate void ChangeUidHandler(
   ChangeUidArgs e
)
public delegate void ChangeUidHandler(
   ChangeUidArgs^ e
)

Parameters

e
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ChangeUidHandler Members
DicomObjects.Delegates Namespace


DataChangedHandler Delegate

DataChangedHandler Delegate

DicomObjects.Delegates Namespace : DataChangedHandler Delegate
Sender as Object
Delegate for the DataChanged event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Sub DataChangedHandler( _
   ByVal Sender As Object _
)
'Usage

Dim instance As New DataChangedHandler(AddressOf HandlerMethod)
public delegate void DataChangedHandler(
   object Sender
)
public delegate void DataChangedHandler(
   Object^ Sender
)

Parameters

Sender
Sender as Object
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DataChangedHandler Members
DicomObjects.Delegates Namespace


DisplayChangedHandler Delegate

DisplayChangedHandler Delegate

DicomObjects.Delegates Namespace : DisplayChangedHandler Delegate
Sender as Object
Area as Region
Delegate for the DicomObjects.DicomViewer.DisplayChanged event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Sub DisplayChangedHandler( _
   ByVal Sender As Object, _
   ByVal Area As Region _
)
'Usage

Dim instance As New DisplayChangedHandler(AddressOf HandlerMethod)
public delegate void DisplayChangedHandler(
   object Sender,
   Region Area
)
public delegate void DisplayChangedHandler(
   Object^ Sender,
   Region^ Area
)

Parameters

Sender
Sender as Object
Area
Area as Region
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DisplayChangedHandler Members
DicomObjects.Delegates Namespace


DrawExceptionHandler Delegate

DrawExceptionHandler Delegate

DicomObjects.Delegates Namespace : DrawExceptionHandler Delegate
Sender as object
event arguments
delegate for the DicomObjects.DicomViewer.DrawException event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Sub DrawExceptionHandler( _
   ByVal Sender As Object, _
   ByVal e As DrawExceptionArgs _
)
'Usage

Dim instance As New DrawExceptionHandler(AddressOf HandlerMethod)
public delegate void DrawExceptionHandler(
   object Sender,
   DrawExceptionArgs e
)
public delegate void DrawExceptionHandler(
   Object^ Sender,
   DrawExceptionArgs^ e
)

Parameters

Sender
Sender as object
e
event arguments
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DrawExceptionHandler Members
DicomObjects.Delegates Namespace


DrawStartHandler Delegate

DrawStartHandler Delegate

DicomObjects.Delegates Namespace : DrawStartHandler Delegate
Control raising the event
Standard system PaintEventArgs parameter
Additional DicomObjects specific argument
Delegate used by the DicomObjects.DicomViewer.DrawStart event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Sub DrawStartHandler( _
   ByVal Sender As Object, _
   ByVal e As PaintEventArgs, _
   ByVal DrawStartArgs As DrawStartEventArgs _
)
'Usage

Dim instance As New DrawStartHandler(AddressOf HandlerMethod)
public delegate void DrawStartHandler(
   object Sender,
   PaintEventArgs e,
   DrawStartEventArgs DrawStartArgs
)
public delegate void DrawStartHandler(
   Object^ Sender,
   PaintEventArgs^ e,
   DrawStartEventArgs^ DrawStartArgs
)

Parameters

Sender
Control raising the event
e
Standard system PaintEventArgs parameter
DrawStartArgs
Additional DicomObjects specific argument
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DrawStartHandler Members
DicomObjects.Delegates Namespace


ErrorReceivedHandler Delegate

ErrorReceivedHandler Delegate

DicomObjects.Delegates Namespace : ErrorReceivedHandler Delegate
As Object
As ErrorReceivedArgs
Delegate for the DicomObjects.DicomServer.ErrorReceived event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Sub ErrorReceivedHandler( _
   ByVal Sender As Object, _
   ByVal e As ErrorReceivedArgs _
)
'Usage

Dim instance As New ErrorReceivedHandler(AddressOf HandlerMethod)
public delegate void ErrorReceivedHandler(
   object Sender,
   ErrorReceivedArgs e
)
public delegate void ErrorReceivedHandler(
   Object^ Sender,
   ErrorReceivedArgs^ e
)

Parameters

Sender
As Object
e
As ErrorReceivedArgs
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ErrorReceivedHandler Members
DicomObjects.Delegates Namespace


GetUrlHandler Delegate

GetUrlHandler Delegate

DicomObjects.Delegates Namespace : GetUrlHandler Delegate
The DataSet to generate the URI for
Delegate for the DicomObjects.DicomCodecs.Jpip.GetUri event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Function GetUrlHandler( _
   ByVal DataSet As DicomDataSet _
) As String
'Usage

Dim instance As New GetUrlHandler(AddressOf HandlerMethod)
public delegate string GetUrlHandler(
   DicomDataSet DataSet
)
public delegate String^ GetUrlHandler(
   DicomDataSet^ DataSet
)

Parameters

DataSet
The DataSet to generate the URI for

Return Value

The required Uri
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

GetUrlHandler Members
DicomObjects.Delegates Namespace


InfoMessageHandler Delegate

InfoMessageHandler Delegate

DicomObjects.Delegates Namespace : InfoMessageHandler Delegate
Sender as Object
e as InfoMessageArgs
Delegate for the DicomObjects.DicomServer.InfoMessage event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Sub InfoMessageHandler( _
   ByVal Sender As Object, _
   ByVal e As InfoMessageArgs _
)
'Usage

Dim instance As New InfoMessageHandler(AddressOf HandlerMethod)
public delegate void InfoMessageHandler(
   object Sender,
   InfoMessageArgs e
)
public delegate void InfoMessageHandler(
   Object^ Sender,
   InfoMessageArgs^ e
)

Parameters

Sender
Sender as Object
e
e as InfoMessageArgs
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

InfoMessageHandler Members
DicomObjects.Delegates Namespace


InstanceReceivedHandler Delegate

InstanceReceivedHandler Delegate

DicomObjects.Delegates Namespace : InstanceReceivedHandler Delegate
Sender as Object
e as InstanceReceivedArgs
Delegate for the DicomObjects.DicomServer.InstanceReceived Event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Sub InstanceReceivedHandler( _
   ByVal Sender As Object, _
   ByVal e As InstanceReceivedArgs _
)
'Usage

Dim instance As New InstanceReceivedHandler(AddressOf HandlerMethod)
public delegate void InstanceReceivedHandler(
   object Sender,
   InstanceReceivedArgs e
)
public delegate void InstanceReceivedHandler(
   Object^ Sender,
   InstanceReceivedArgs^ e
)

Parameters

Sender
Sender as Object
e
e as InstanceReceivedArgs
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

InstanceReceivedHandler Members
DicomObjects.Delegates Namespace


LabelChangedHandler Delegate

LabelChangedHandler Delegate

DicomObjects.Delegates Namespace : LabelChangedHandler Delegate
Standard event Sender argument
The label which has changed
Delegate for the DicomObjects.DicomLabel.LabelChanged event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Sub LabelChangedHandler( _
   ByVal Sender As Object, _
   ByVal label As DicomLabel _
)
'Usage

Dim instance As New LabelChangedHandler(AddressOf HandlerMethod)
public delegate void LabelChangedHandler(
   object Sender,
   DicomLabel label
)
public delegate void LabelChangedHandler(
   Object^ Sender,
   DicomLabel^ label
)

Parameters

Sender
Standard event Sender argument
label
The label which has changed
Remarks
If the Area property changes, then the rectangle passed as a parameter is the union of the old and new Areas.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LabelChangedHandler Members
DicomObjects.Delegates Namespace


LicenseExpirationHandler Delegate

LicenseExpirationHandler Delegate

DicomObjects.Delegates Namespace : LicenseExpirationHandler Delegate
The time remaining until the current license expires
Delegate used by the LicenseExpirationEvent
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Sub LicenseExpirationHandler( _
   ByVal remaining As TimeSpan _
)
'Usage

Dim instance As New LicenseExpirationHandler(AddressOf HandlerMethod)
public delegate void LicenseExpirationHandler(
   TimeSpan remaining
)
public delegate void LicenseExpirationHandler(
   TimeSpan remaining
)

Parameters

remaining
The time remaining until the current license expires
Remarks

This method is only available in special builds of DicomObjects which include the temporary licensing facility

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseExpirationHandler Members
DicomObjects.Delegates Namespace


LogHandler Delegate

LogHandler Delegate

DicomObjects.Delegates Namespace : LogHandler Delegate
The event details
Delegate for the LogEvent Event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Sub LogHandler( _
   ByVal e As LogEventArgs _
)
'Usage

Dim instance As New LogHandler(AddressOf HandlerMethod)
public delegate void LogHandler(
   LogEventArgs e
)
public delegate void LogHandler(
   LogEventArgs^ e
)

Parameters

e
The event details
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LogHandler Members
DicomObjects.Delegates Namespace


MakeControlHandler Delegate

MakeControlHandler Delegate

DicomObjects.Delegates Namespace : MakeControlHandler Delegate
The MakeControlArgs class
Delegate for the "MakeControl" event of a DicomObjects.DicomViewer
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Function MakeControlHandler( _
   ByVal e As MakeControlArgs _
) As Control
'Usage

Dim instance As New MakeControlHandler(AddressOf HandlerMethod)
public delegate Control MakeControlHandler(
   MakeControlArgs e
)
public delegate Control^ MakeControlHandler(
   MakeControlArgs^ e
)

Parameters

e
The MakeControlArgs class
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

MakeControlHandler Members
DicomObjects.Delegates Namespace


N_Event_ReportHandler Delegate

N_Event_ReportHandler Delegate

DicomObjects.Delegates Namespace : N_Event_ReportHandler Delegate
The object triggering the event - in fact the DicomAssociation
The N_Event_ReportArgs class
Delegate for the "N_Event_Report" events of a DicomObjects.DicomAssociation and DicomObjects.DicomServer
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Sub N_Event_ReportHandler( _
   ByVal Sender As Object, _
   ByVal e As N_Event_ReportArgs _
)
'Usage

Dim instance As New N_Event_ReportHandler(AddressOf HandlerMethod)
public delegate void N_Event_ReportHandler(
   object Sender,
   N_Event_ReportArgs e
)
public delegate void N_Event_ReportHandler(
   Object^ Sender,
   N_Event_ReportArgs^ e
)

Parameters

Sender
The object triggering the event - in fact the DicomAssociation
e
The N_Event_ReportArgs class
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

N_Event_ReportHandler Members
DicomObjects.Delegates Namespace
N_Event_Report Event
N_Event_Report Event


NormalisedReceivedHandler Delegate

NormalisedReceivedHandler Delegate

DicomObjects.Delegates Namespace : NormalisedReceivedHandler Delegate
Sender as Object
e as NormalisedReceivedArgs
Delegate for the DicomObjects.DicomServer.NormalisedReceived event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Sub NormalisedReceivedHandler( _
   ByVal Sender As Object, _
   ByVal e As NormalisedReceivedArgs _
)
'Usage

Dim instance As New NormalisedReceivedHandler(AddressOf HandlerMethod)
public delegate void NormalisedReceivedHandler(
   object Sender,
   NormalisedReceivedArgs e
)
public delegate void NormalisedReceivedHandler(
   Object^ Sender,
   NormalisedReceivedArgs^ e
)

Parameters

Sender
Sender as Object
e
e as NormalisedReceivedArgs
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

NormalisedReceivedHandler Members
DicomObjects.Delegates Namespace


PositionChangedHandler Delegate

PositionChangedHandler Delegate

DicomObjects.Delegates Namespace : PositionChangedHandler Delegate
The object causing the change to happen
The Image which has changed
Delegate for the DicomObjects.DicomImage.PositionChanged event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Sub PositionChangedHandler( _
   ByVal Sender As Object, _
   ByVal Image As DicomImage _
)
'Usage

Dim instance As New PositionChangedHandler(AddressOf HandlerMethod)
public delegate void PositionChangedHandler(
   object Sender,
   DicomImage Image
)
public delegate void PositionChangedHandler(
   Object^ Sender,
   DicomImage^ Image
)

Parameters

Sender
The object causing the change to happen
Image
The Image which has changed
Remarks
In practice, currently, Sender and Image are the same object.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

PositionChangedHandler Members
DicomObjects.Delegates Namespace


PSLabelCreatedHandler Delegate

PSLabelCreatedHandler Delegate

DicomObjects.Delegates Namespace : PSLabelCreatedHandler Delegate
Event args that contains the label which has been created from Presentation State, the DICOM presentation state instance from which the label is created and the specific Presentation State Item for the label created
Delegate for the DicomObjects.DicomLabel.PSLabelCreated event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Sub PSLabelCreatedHandler( _
   ByVal args As PSLabelCreatedArgs _
)
'Usage

Dim instance As New PSLabelCreatedHandler(AddressOf HandlerMethod)
public delegate void PSLabelCreatedHandler(
   PSLabelCreatedArgs args
)
public delegate void PSLabelCreatedHandler(
   PSLabelCreatedArgs^ args
)

Parameters

args
Event args that contains the label which has been created from Presentation State, the DICOM presentation state instance from which the label is created and the specific Presentation State Item for the label created
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

PSLabelCreatedHandler Members
DicomObjects.Delegates Namespace


QueryReceivedHandler Delegate

QueryReceivedHandler Delegate

DicomObjects.Delegates Namespace : QueryReceivedHandler Delegate
Sender as Object
e as QueryReceivedArgs
Delegate for the DicomObjects.DicomServer.QueryReceived event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Sub QueryReceivedHandler( _
   ByVal Sender As Object, _
   ByVal e As QueryReceivedArgs _
)
'Usage

Dim instance As New QueryReceivedHandler(AddressOf HandlerMethod)
public delegate void QueryReceivedHandler(
   object Sender,
   QueryReceivedArgs e
)
public delegate void QueryReceivedHandler(
   Object^ Sender,
   QueryReceivedArgs^ e
)

Parameters

Sender
Sender as Object
e
e as QueryReceivedArgs
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

QueryReceivedHandler Members
DicomObjects.Delegates Namespace


ReceivingPixelDataHandler Delegate

ReceivingPixelDataHandler Delegate

DicomObjects.Delegates Namespace : ReceivingPixelDataHandler Delegate
Delegate used by the DicomObjects.DicomServer.ReceivingPixelData event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Sub ReceivingPixelDataHandler( _
   ByVal Sender As Object, _
   ByVal e As ReceivingPixelDataArgs _
)
'Usage

Dim instance As New ReceivingPixelDataHandler(AddressOf HandlerMethod)
public delegate void ReceivingPixelDataHandler(
   object Sender,
   ReceivingPixelDataArgs e
)
public delegate void ReceivingPixelDataHandler(
   Object^ Sender,
   ReceivingPixelDataArgs^ e
)

Parameters

Sender
e
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ReceivingPixelDataHandler Members
DicomObjects.Delegates Namespace


ResponseReceivedHandler Delegate

ResponseReceivedHandler Delegate

DicomObjects.Delegates Namespace : ResponseReceivedHandler Delegate
The object (DicomObjects.DicomAssociation or DicomObjects.DicomQuery generating the event
The event details
Delegate for the DicomObjects.DicomAssociation.ResponseReceived and ResponseReceived events
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Sub ResponseReceivedHandler( _
   ByVal Sender As Object, _
   ByVal e As ResponseReceivedArgs _
)
'Usage

Dim instance As New ResponseReceivedHandler(AddressOf HandlerMethod)
public delegate void ResponseReceivedHandler(
   object Sender,
   ResponseReceivedArgs e
)
public delegate void ResponseReceivedHandler(
   Object^ Sender,
   ResponseReceivedArgs^ e
)

Parameters

Sender
The object (DicomObjects.DicomAssociation or DicomObjects.DicomQuery generating the event
e
The event details
Remarks
This is used by the DicomObjects.DicomAssociation and DicomObjects.DicomQuery objects
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ResponseReceivedHandler Members
DicomObjects.Delegates Namespace


RetrieveLicenseHandler Delegate

RetrieveLicenseHandler Delegate

DicomObjects.Delegates Namespace : RetrieveLicenseHandler Delegate
Delegate for the RetrieveLicense event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Function RetrieveLicenseHandler() As String
'Usage

Dim instance As New RetrieveLicenseHandler(AddressOf HandlerMethod)
public delegate string RetrieveLicenseHandler()
public delegate String^ RetrieveLicenseHandler();

Return Value

A previously stored license string - as passed via StoreLicense
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

RetrieveLicenseHandler Members
DicomObjects.Delegates Namespace


StatusUpdateHandler Delegate

StatusUpdateHandler Delegate

DicomObjects.Delegates Namespace : StatusUpdateHandler Delegate
The DicomDataSet which has been updated
The PixelRequest which has caused the update to occur
The new status
Delegate for the DicomObjects.DicomCodecs.Jpip.StatusUpdate event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Sub StatusUpdateHandler( _
   ByVal DataSet As DicomDataSet, _
   ByVal Request As PixelRequest, _
   ByVal Status As ProgressiveStatus _
)
'Usage

Dim instance As New StatusUpdateHandler(AddressOf HandlerMethod)
public delegate void StatusUpdateHandler(
   DicomDataSet DataSet,
   PixelRequest Request,
   ProgressiveStatus Status
)
public delegate void StatusUpdateHandler(
   DicomDataSet^ DataSet,
   PixelRequest^ Request,
   ProgressiveStatus Status
)

Parameters

DataSet
The DicomDataSet which has been updated
Request
The PixelRequest which has caused the update to occur
Status
The new status
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

StatusUpdateHandler Members
DicomObjects.Delegates Namespace


StoreLicenseHandler Delegate

StoreLicenseHandler Delegate

DicomObjects.Delegates Namespace : StoreLicenseHandler Delegate
Token to store
Delegate for StoreLicense event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Function StoreLicenseHandler( _
   ByVal LicenseToken As String _
) As Boolean
'Usage

Dim instance As New StoreLicenseHandler(AddressOf HandlerMethod)
public delegate bool StoreLicenseHandler(
   string LicenseToken
)
public delegate bool StoreLicenseHandler(
   String^ LicenseToken
)

Parameters

LicenseToken
Token to store

Return Value

True if the routine stores the license key successfully
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

StoreLicenseHandler Members
DicomObjects.Delegates Namespace


TlsAcceptor Delegate

TlsAcceptor Delegate

DicomObjects.Delegates Namespace : TlsAcceptor Delegate
The encrypted stream over which unencrypted data will be sent and received
Remote IP address
The local port to which the remote entity has connected
Delegate used to accept TLS communications
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Function TlsAcceptor( _
   ByVal EncryptedStream As Stream, _
   ByVal RemoteAddress As String, _
   ByVal LocalPort As Integer _
) As Stream
'Usage

Dim instance As New TlsAcceptor(AddressOf HandlerMethod)
public delegate Stream TlsAcceptor(
   Stream EncryptedStream,
   string RemoteAddress,
   int LocalPort
)
public delegate Stream^ TlsAcceptor(
   Stream^ EncryptedStream,
   String^ RemoteAddress,
   int LocalPort
)

Parameters

EncryptedStream
The encrypted stream over which unencrypted data will be sent and received
RemoteAddress
Remote IP address
LocalPort
The local port to which the remote entity has connected
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TlsAcceptor Members
DicomObjects.Delegates Namespace


TlsInitiator Delegate

TlsInitiator Delegate

DicomObjects.Delegates Namespace : TlsInitiator Delegate
The cleartext stream over which unencrypted data will be sent and received
Remote IP address
remote Port
Delegate used to initiate TLS communications
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Function TlsInitiator( _
   ByVal ClearTextStream As Stream, _
   ByVal RemoteAddress As String, _
   ByVal RemotePort As Integer _
) As Stream
'Usage

Dim instance As New TlsInitiator(AddressOf HandlerMethod)
public delegate Stream TlsInitiator(
   Stream ClearTextStream,
   string RemoteAddress,
   int RemotePort
)
public delegate Stream^ TlsInitiator(
   Stream^ ClearTextStream,
   String^ RemoteAddress,
   int RemotePort
)

Parameters

ClearTextStream
The cleartext stream over which unencrypted data will be sent and received
RemoteAddress
Remote IP address
RemotePort
remote Port

Return Value

An encrypted stream following TLS negotiation
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TlsInitiator Members
DicomObjects.Delegates Namespace


UserSmoothingHandler Delegate

UserSmoothingHandler Delegate

DicomObjects.Delegates Namespace : UserSmoothingHandler Delegate
The event arguments, specifying the smoothing requested
Delegate for the DicomObjects.DicomImage.UserSmoothing event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Function UserSmoothingHandler( _
   ByVal e As UserSmoothingArgs _
) As Boolean
'Usage

Dim instance As New UserSmoothingHandler(AddressOf HandlerMethod)
public delegate bool UserSmoothingHandler(
   UserSmoothingArgs e
)
public delegate bool UserSmoothingHandler(
   UserSmoothingArgs^ e
)

Parameters

e
The event arguments, specifying the smoothing requested

Return Value

True, if the event handler has succeeded. If false, then DicomObjects continues with its own rendering.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

UserSmoothingHandler Members
DicomObjects.Delegates Namespace


VerifyReceivedHandler Delegate

VerifyReceivedHandler Delegate

DicomObjects.Delegates Namespace : VerifyReceivedHandler Delegate
Sender as Object
e as VerifyReceivedArgs
Delegate for the DicomObjects.DicomServer.VerifyReceived event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Delegate Sub VerifyReceivedHandler( _
   ByVal Sender As Object, _
   ByVal e As VerifyReceivedArgs _
)
'Usage

Dim instance As New VerifyReceivedHandler(AddressOf HandlerMethod)
public delegate void VerifyReceivedHandler(
   object Sender,
   VerifyReceivedArgs e
)
public delegate void VerifyReceivedHandler(
   Object^ Sender,
   VerifyReceivedArgs^ e
)

Parameters

Sender
Sender as Object
e
e as VerifyReceivedArgs
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VerifyReceivedHandler Members
DicomObjects.Delegates Namespace


DicomObjects.DicomCodecs Namespace

DicomObjects.DicomCodecs Namespace
Inheritance Hierarchy
Namespace holding Codec specific objects - both for the extension interface, and for fine tuning of internal codecs
Classes
 | Class | Description
Class | CodecFactory | "Factory" class which creates and controls the instantiation of codecs
Class | CodecGlobal | Placeholder for methods affecting all codecs
Class | CompressionArguments | class used to pass arguments to a compression codec
Class | DecompressionArguments | Class used to hold arguments passed to a decompression codec
Class | DicomCodecBaseArguments | The base class for arguments passed to codecs
Class | ImportArguments | Class used to hold arguments passed to an import codec
Class | Jpeg2000CompressionOptions | Class which allows control of the details of JPEG 2000 compression
Class | JpegLossless | The class which implements the internal JPEG Lossless codec
Class | JpegLossy | Static class to hold global options for the JPEG lossy codec
Class | JpegLSCompressionOptions | Class which allows control of the details of JpegLS compression
Class | Jpip | Static class to hold global options for JPIP usage
Class | ModificationArguments | Defines changes which need to be applied to a compressed image
Class | SimpleCodec | A class which provides a simple implementation of most of the required members of ICompressor and IDecompressor, simplifying implementation for transfer syntaxes which do not need partial decompression.
Class | VideoCodec | A class derived from SimpleCodec to be used by video codecs
Interfaces
 | Interface | Description
Interface | ICodecBase | Common features for all codecs
Interface | ICompressor | Interface implemented by all compression codecs
Interface | IDecompressor | Interface implemented by for all DICOM decompression codecs
Interface | IExporter | Interface implemented by all export codecs
Interface | IImporter | Interface implemented by all import codecs
See Also

Reference

DicomObjects.NET.8.40 Assembly


CodecFactory Class

CodecFactory Class
Members

DicomObjects.DicomCodecs Namespace : CodecFactory Class
"Factory" class which creates and controls the instantiation of codecs
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class CodecFactory
'Usage

Dim instance As CodecFactory
public abstract class CodecFactory
public ref class CodecFactory abstract
Remarks

This is the main class which would need to be implemented by anyone missing to write their own codecs, to specify what transfer synatxes or external formats are supported.

See for more details on the new codec interface used from verion 5.6.3.x onwards

Inheritance Hierarchy

System.Object
DicomObjects.DicomCodecs.CodecFactory

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

CodecFactory Members
DicomObjects.DicomCodecs Namespace


CodecFactory Class Members

CodecFactory Class Members
Methods

DicomObjects.DicomCodecs Namespace : CodecFactory Class

The following tables list the members exposed by CodecFactory.

Public Methods
 | Name | Description
Public Method | CheckStart | Check whether a stream contains data which could be the start of a frame of compressed data
Public Method | Compressor | Create a Compressor object
Public Method | Decompressor | Create a Decompressor object
Public Method | Exporter | Create the Exporter object
Public Method | Importer | Create an Importer object
Public Method | SupportedTransferSyntaxes | The list of transfer syntaxes supported by this factory. This also includes file extensions for import and export
Top
See Also

Reference

CodecFactory Class
DicomObjects.DicomCodecs Namespace


CodecFactory Class Methods

CodecFactory Class Methods

DicomObjects.DicomCodecs Namespace : CodecFactory Class

For a list of all members of this type, see CodecFactory members.

Public Methods
 | Name | Description
Public Method | CheckStart | Check whether a stream contains data which could be the start of a frame of compressed data
Public Method | Compressor | Create a Compressor object
Public Method | Decompressor | Create a Decompressor object
Public Method | Exporter | Create the Exporter object
Public Method | Importer | Create an Importer object
Public Method | SupportedTransferSyntaxes | The list of transfer syntaxes supported by this factory. This also includes file extensions for import and export
Top
See Also

Reference

CodecFactory Class
DicomObjects.DicomCodecs Namespace


CheckStart Method

CheckStart Method

DicomObjects.DicomCodecs Namespace > CodecFactory Class : CheckStart Method
The fragment data to test
The transfer syntax to check against
Check whether a stream contains data which could be the start of a frame of compressed data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustOverride Function CheckStart( _
   ByVal stream As Stream, _
   ByVal TransferSyntax As String _
) As Boolean
'Usage

Dim instance As CodecFactory
Dim stream As Stream
Dim TransferSyntax As String
Dim value As Boolean

value = instance.CheckStart(stream, TransferSyntax)
public abstract bool CheckStart(
   Stream stream,
   string TransferSyntax
)
public:
abstract bool CheckStart(
   Stream^ stream,
   String^ TransferSyntax
)

Parameters

stream
The fragment data to test
TransferSyntax
The transfer syntax to check against

Return Value

true if the data could be the start of a new frame for this transfer syntax
Remarks
This routine is used in the difficult cases where the basic offset table is empty, and where there is no obvious 1:1 relationship between fragments and frames, to determine which fragment is the start of which frame.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

CodecFactory Class
CodecFactory Members


Compressor Method

Compressor Method

DicomObjects.DicomCodecs Namespace > CodecFactory Class : Compressor Method
The transfer syntax to be used for the compression
Create a Compressor object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustOverride Function Compressor( _
   ByVal TransferSyntax As String _
) As ICompressor
'Usage

Dim instance As CodecFactory
Dim TransferSyntax As String
Dim value As ICompressor

value = instance.Compressor(TransferSyntax)
public abstract ICompressor Compressor(
   string TransferSyntax
)
public:
abstract ICompressor^ Compressor(
   String^ TransferSyntax
)

Parameters

TransferSyntax
The transfer syntax to be used for the compression

Return Value

The new Compressor object
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

CodecFactory Class
CodecFactory Members


Decompressor Method

Decompressor Method

DicomObjects.DicomCodecs Namespace > CodecFactory Class : Decompressor Method
The transfer syntax of the data to be decompressed
The data to be decompressed
The DicomDataSet containing the data to be decompressed
The Frame number (as per DICOM rules, numbered from 1)
Create a Decompressor object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustOverride Function Decompressor( _
   ByVal TransferSyntax As String, _
   ByVal Data As Stream, _
   ByVal DataSet As DicomDataSet, _
   ByVal Frame As Integer _
) As IDecompressor
'Usage

Dim instance As CodecFactory
Dim TransferSyntax As String
Dim Data As Stream
Dim DataSet As DicomDataSet
Dim Frame As Integer
Dim value As IDecompressor

value = instance.Decompressor(TransferSyntax, Data, DataSet, Frame)
public abstract IDecompressor Decompressor(
   string TransferSyntax,
   Stream Data,
   DicomDataSet DataSet,
   int Frame
)
public:
abstract IDecompressor^ Decompressor(
   String^ TransferSyntax,
   Stream^ Data,
   DicomDataSet^ DataSet,
   int Frame
)

Parameters

TransferSyntax
The transfer syntax of the data to be decompressed
Data
The data to be decompressed
DataSet
The DicomDataSet containing the data to be decompressed
Frame
The Frame number (as per DICOM rules, numbered from 1)

Return Value

The new Decompressor object
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

CodecFactory Class
CodecFactory Members


Exporter Method

Exporter Method

DicomObjects.DicomCodecs Namespace > CodecFactory Class : Exporter Method
The format to be used for the compression/export
Create the Exporter object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustOverride Function Exporter( _
   ByVal Format As String _
) As IExporter
'Usage

Dim instance As CodecFactory
Dim Format As String
Dim value As IExporter

value = instance.Exporter(Format)
public abstract IExporter Exporter(
   string Format
)
public:
abstract IExporter^ Exporter(
   String^ Format
)

Parameters

Format
The format to be used for the compression/export

Return Value

The new Exported object
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

CodecFactory Class
CodecFactory Members


Importer Method

Importer Method

DicomObjects.DicomCodecs Namespace > CodecFactory Class : Importer Method
The format of the data being decompressed/imported
Create an Importer object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustOverride Function Importer( _
   ByVal Format As String _
) As IImporter
'Usage

Dim instance As CodecFactory
Dim Format As String
Dim value As IImporter

value = instance.Importer(Format)
public abstract IImporter Importer(
   string Format
)
public:
abstract IImporter^ Importer(
   String^ Format
)

Parameters

Format
The format of the data being decompressed/imported

Return Value

The new Importer object
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

CodecFactory Class
CodecFactory Members


SupportedTransferSyntaxes Method

SupportedTransferSyntaxes Method

DicomObjects.DicomCodecs Namespace > CodecFactory Class : SupportedTransferSyntaxes Method
The type of operation that the transfer syntaxes/file extensions are valid for
The list of transfer syntaxes supported by this factory. This also includes file extensions for import and export
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustOverride Function SupportedTransferSyntaxes( _
   ByVal Operation As CodecOperation _
) As String()
'Usage

Dim instance As CodecFactory
Dim Operation As CodecOperation
Dim value() As String

value = instance.SupportedTransferSyntaxes(Operation)
public abstract string[] SupportedTransferSyntaxes(
   CodecOperation Operation
)
public:
abstract array<String^>^ SupportedTransferSyntaxes(
   CodecOperation Operation
)

Parameters

Operation
The type of operation that the transfer syntaxes/file extensions are valid for

Return Value

he list of transfer syntaxes
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

CodecFactory Class
CodecFactory Members


CodecGlobal Class

CodecGlobal Class
Members

DicomObjects.DicomCodecs Namespace : CodecGlobal Class
Placeholder for methods affecting all codecs
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit NotInheritable Class CodecGlobal
'Usage

Dim instance As CodecGlobal
public static class CodecGlobal
public ref class CodecGlobal abstract sealed
Remarks
Many of these functions were attached to the DicomObjects.DicomGlobal in previous versions of DicomObjects
Inheritance Hierarchy

System.Object
DicomObjects.DicomCodecs.CodecGlobal

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

CodecGlobal Members
DicomObjects.DicomCodecs Namespace


CodecGlobal Class Members

CodecGlobal Class Members
Methods

DicomObjects.DicomCodecs Namespace : CodecGlobal Class

The following tables list the members exposed by CodecGlobal.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | AddCodec | Overloaded. Adds codec into DicomObjects
static (Shared in Visual Basic) | AvailableTransferSyntaxes | Contains a list of transfer syntaxes supported by DicomObjects.NET
static (Shared in Visual Basic) | Decompress | Experimental independent decompression method
static (Shared in Visual Basic) | RegisterCodec | Registry a CodecFactory-derived class to be used for future codec operations
Top
See Also

Reference

CodecGlobal Class
DicomObjects.DicomCodecs Namespace


CodecGlobal Class Methods

CodecGlobal Class Methods

DicomObjects.DicomCodecs Namespace : CodecGlobal Class

For a list of all members of this type, see CodecGlobal members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | AddCodec | Overloaded. Adds codec into DicomObjects
static (Shared in Visual Basic) | AvailableTransferSyntaxes | Contains a list of transfer syntaxes supported by DicomObjects.NET
static (Shared in Visual Basic) | Decompress | Experimental independent decompression method
static (Shared in Visual Basic) | RegisterCodec | Registry a CodecFactory-derived class to be used for future codec operations
Top
See Also

Reference

CodecGlobal Class
DicomObjects.DicomCodecs Namespace


AddCodec Method

AddCodec Method

DicomObjects.DicomCodecs Namespace > CodecGlobal Class : AddCodec Method
Adds codec into DicomObjects
Overload List
Overload Description
AddCodec(Assembly)

Finds all codec factories in the assembly by finding classes which are derived from the CodecFactory abstract class.

Once the factories have been identified, their supported combinations of formats/transfer syntaxes and operations are indexed for future use

AddCodec(String)

Finds all codec factories in the assembly by finding classes which are derived from the CodecFactory abstract class.

Once the factories have been identified, their supported combinations of formats/transfer syntaxes and operations are indexed for future use

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

CodecGlobal Class
CodecGlobal Members


AddCodec(Assembly) Method

AddCodec(Assembly) Method

DicomObjects.DicomCodecs Namespace > CodecGlobal Class > AddCodec Method : AddCodec(Assembly) Method
The Assembly to search

Finds all codec factories in the assembly by finding classes which are derived from the CodecFactory abstract class.

Once the factories have been identified, their supported combinations of formats/transfer syntaxes and operations are indexed for future use

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Shared Sub AddCodec( _
   ByVal Assembly As Assembly _
)
'Usage

Dim Assembly As Assembly

CodecGlobal.AddCodec(Assembly)
public static void AddCodec(
   Assembly Assembly
)
public:
static void AddCodec(
   Assembly^ Assembly
)

Parameters

Assembly
The Assembly to search
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

CodecGlobal Class
CodecGlobal Members
Overload List


AddCodec(String) Method

AddCodec(String) Method

DicomObjects.DicomCodecs Namespace > CodecGlobal Class > AddCodec Method : AddCodec(String) Method
Filename as string, the full path of the codec file to load.

Finds all codec factories in the assembly by finding classes which are derived from the CodecFactory abstract class.

Once the factories have been identified, their supported combinations of formats/transfer syntaxes and operations are indexed for future use

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Shared Sub AddCodec( _
   ByVal AsemblyFilename As String _
)
'Usage

Dim AsemblyFilename As String

CodecGlobal.AddCodec(AsemblyFilename)
public static void AddCodec(
   string AsemblyFilename
)
public:
static void AddCodec(
   String^ AsemblyFilename
)

Parameters

AsemblyFilename
Filename as string, the full path of the codec file to load.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

CodecGlobal Class
CodecGlobal Members
Overload List


AvailableTransferSyntaxes Method

AvailableTransferSyntaxes Method

DicomObjects.DicomCodecs Namespace > CodecGlobal Class : AvailableTransferSyntaxes Method
Include only those TrannsferSyntax UIDs into which data can be compressed
Include only those TrannsferSyntax UIDs from which data can be decompressed
Contains a list of transfer syntaxes supported by DicomObjects.NET
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function AvailableTransferSyntaxes( _
   ByVal IncludeOnlyCompress As Boolean, _
   ByVal IncludeOnlyDecompress As Boolean _
) As String()
'Usage

Dim IncludeOnlyCompress As Boolean
Dim IncludeOnlyDecompress As Boolean
Dim value() As String

value = CodecGlobal.AvailableTransferSyntaxes(IncludeOnlyCompress, IncludeOnlyDecompress)
public static string[] AvailableTransferSyntaxes(
   bool IncludeOnlyCompress,
   bool IncludeOnlyDecompress
)
public:
static array<String^>^ AvailableTransferSyntaxes(
   bool IncludeOnlyCompress,
   bool IncludeOnlyDecompress
)

Parameters

IncludeOnlyCompress
Include only those TrannsferSyntax UIDs into which data can be compressed
IncludeOnlyDecompress
Include only those TrannsferSyntax UIDs from which data can be decompressed

Return Value

An array containing all the matching transfer syntax UIDs
Remarks
This property contains a list of Compression Transfer Syntaxes supported by DicomObjects.NET as currently being run. If both parameters are true, then only those codecs which can both compress and decompress are returned.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

CodecGlobal Class
CodecGlobal Members


Decompress Method (CodecGlobal)

Decompress Method (CodecGlobal)

DicomObjects.DicomCodecs Namespace > CodecGlobal Class : Decompress Method
The data to be decompressed
The destination to put the decompressed data into.
Size of the image
Bit depth
1 for monochrome, or 3 for colour
This indicates the decopmression metho to use
Experimental independent decompression method
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub Decompress( _
   ByVal CompressedData As Stream, _
   ByVal DestinationData As Array, _
   ByVal Size As Size, _
   ByVal Bits As Integer, _
   ByVal Planes As Integer, _
   ByVal TransferSyntax As String _
)
'Usage

Dim CompressedData As Stream
Dim DestinationData As Array
Dim Size As Size
Dim Bits As Integer
Dim Planes As Integer
Dim TransferSyntax As String

CodecGlobal.Decompress(CompressedData, DestinationData, Size, Bits, Planes, TransferSyntax)
public static void Decompress(
   Stream CompressedData,
   Array DestinationData,
   Size Size,
   int Bits,
   int Planes,
   string TransferSyntax
)
public:
static void Decompress(
   Stream^ CompressedData,
   Array^ DestinationData,
   Size Size,
   int Bits,
   int Planes,
   String^ TransferSyntax
)

Parameters

CompressedData
The data to be decompressed
DestinationData
The destination to put the decompressed data into.
Size
Size of the image
Bits
Bit depth
Planes
1 for monochrome, or 3 for colour
TransferSyntax
This indicates the decopmression metho to use
Remarks

This method uses the same internal codecs to decompress data as would be used by DicomObjects. Although most formats contain internal information about the size, format, bit depth of the data etc., other such as RLE do not, and so for consistency with the existing internal patterns, these must be supplied as parameters to the method.

The DestinationDataarray must be an array of byte or ushort (to match the bit depth of the data) and must be preallocated to the correct size before this call.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

CodecGlobal Class
CodecGlobal Members


RegisterCodec Method

RegisterCodec Method

DicomObjects.DicomCodecs Namespace > CodecGlobal Class : RegisterCodec Method
Instance of the CodecFactory-derived class to register
Registry a CodecFactory-derived class to be used for future codec operations
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub RegisterCodec( _
   ByVal codec As CodecFactory _
)
'Usage

Dim codec As CodecFactory

CodecGlobal.RegisterCodec(codec)
public static void RegisterCodec(
   CodecFactory codec
)
public:
static void RegisterCodec(
   CodecFactory^ codec
)

Parameters

codec
Instance of the CodecFactory-derived class to register
Remarks

See for more details on the new codec interface used from verion 5.6.3.x onwards

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

CodecGlobal Class
CodecGlobal Members


CompressionArguments Class

CompressionArguments Class
Members

DicomObjects.DicomCodecs Namespace : CompressionArguments Class
class used to pass arguments to a compression codec
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class CompressionArguments
   Inherits DicomCodecBaseArguments
'Usage

Dim instance As CompressionArguments
public class CompressionArguments : DicomCodecBaseArguments
public ref class CompressionArguments : public DicomCodecBaseArguments
Inheritance Hierarchy

System.Object
DicomObjects.DicomCodecs.DicomCodecBaseArguments
DicomObjects.DicomCodecs.CompressionArguments

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

CompressionArguments Members
DicomObjects.DicomCodecs Namespace


CompressionArguments Class Members

CompressionArguments Class Members
Properties

DicomObjects.DicomCodecs Namespace : CompressionArguments Class

The following tables list the members exposed by CompressionArguments.

Public Properties
 | Name | Description
Public Property | BitsAllocated | Number of bits per sample allocated (always 8 or 16) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | BitsStored | Number of bits per sample used (always between 8 and 16) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | DataSet | The full associated dataset (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | DestinationStream | The stream into which compressed pixel data is placed
Public Property | Image | The DICOM image being compressed
Public Property | ImplementationUID | The implementation UID of the original image (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | isSigned | Sign of the data (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | OutputDataset | Reference of the actual output Dataset made available in the codec
Public Property | OutputTransferSyntax | The transfer syntax into which the image should be compressed
Public Property | PhotometricInterpretation | The photometric interpretation of the data (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | Planarconfig | How the colour pixel data is arranged (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | Planes | The number of images planes. (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | Quality | A data to describe compression quality
Public Property | Size | The size of the image (pixels x pixels) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | SourceArray | The array from which the original decompressed pixel data is obtained. This could be a byte or short or ushort array depending on the pixel data bits stored.
Public Property | WriteBehaviour | Specific behaviours to use for compression
Top
See Also

Reference

CompressionArguments Class
DicomObjects.DicomCodecs Namespace


CompressionArguments Class Properties

CompressionArguments Class Properties

DicomObjects.DicomCodecs Namespace : CompressionArguments Class

For a list of all members of this type, see CompressionArguments members.

Public Properties
 | Name | Description
Public Property | BitsAllocated | Number of bits per sample allocated (always 8 or 16) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | BitsStored | Number of bits per sample used (always between 8 and 16) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | DataSet | The full associated dataset (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | DestinationStream | The stream into which compressed pixel data is placed
Public Property | Image | The DICOM image being compressed
Public Property | ImplementationUID | The implementation UID of the original image (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | isSigned | Sign of the data (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | OutputDataset | Reference of the actual output Dataset made available in the codec
Public Property | OutputTransferSyntax | The transfer syntax into which the image should be compressed
Public Property | PhotometricInterpretation | The photometric interpretation of the data (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | Planarconfig | How the colour pixel data is arranged (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | Planes | The number of images planes. (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | Quality | A data to describe compression quality
Public Property | Size | The size of the image (pixels x pixels) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | SourceArray | The array from which the original decompressed pixel data is obtained. This could be a byte or short or ushort array depending on the pixel data bits stored.
Public Property | WriteBehaviour | Specific behaviours to use for compression
Top
See Also

Reference

CompressionArguments Class
DicomObjects.DicomCodecs Namespace


DestinationStream Property

DestinationStream Property

DicomObjects.DicomCodecs Namespace > CompressionArguments Class : DestinationStream Property
The stream into which compressed pixel data is placed
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property DestinationStream As Stream
'Usage

Dim instance As CompressionArguments
Dim value As Stream

value = instance.DestinationStream
public Stream DestinationStream {get;}
public:
property Stream^ DestinationStream {
   Stream^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

CompressionArguments Class
CompressionArguments Members


Image Property (CompressionArguments)

Image Property (CompressionArguments)

DicomObjects.DicomCodecs Namespace > CompressionArguments Class : Image Property
The DICOM image being compressed
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Image As DicomImage
'Usage

Dim instance As CompressionArguments
Dim value As DicomImage

instance.Image = value

value = instance.Image
public DicomImage Image {get; set;}
public:
property DicomImage^ Image {
   DicomImage^ get();
   void set (    DicomImage^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

CompressionArguments Class
CompressionArguments Members


OutputDataset Property

OutputDataset Property

DicomObjects.DicomCodecs Namespace > CompressionArguments Class : OutputDataset Property
Reference of the actual output Dataset made available in the codec
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OutputDataset As DicomDataSet
'Usage

Dim instance As CompressionArguments
Dim value As DicomDataSet

instance.OutputDataset = value

value = instance.OutputDataset
public DicomDataSet OutputDataset {get; set;}
public:
property DicomDataSet^ OutputDataset {
   DicomDataSet^ get();
   void set (    DicomDataSet^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

CompressionArguments Class
CompressionArguments Members


OutputTransferSyntax Property (CompressionArguments)

OutputTransferSyntax Property (CompressionArguments)

DicomObjects.DicomCodecs Namespace > CompressionArguments Class : OutputTransferSyntax Property
The transfer syntax into which the image should be compressed
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property OutputTransferSyntax As String
'Usage

Dim instance As CompressionArguments
Dim value As String

value = instance.OutputTransferSyntax
public string OutputTransferSyntax {get;}
public:
property String^ OutputTransferSyntax {
   String^ get();
}
Remarks
Most codecs will only handle one transfer syntax, but this is provided, as some can handle many - e.g. the JPEG 2000 codec which handles the lossless and lossy modes.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

CompressionArguments Class
CompressionArguments Members


Quality Property (CompressionArguments)

Quality Property (CompressionArguments)

DicomObjects.DicomCodecs Namespace > CompressionArguments Class : Quality Property
A data to describe compression quality
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Quality As Object
'Usage

Dim instance As CompressionArguments
Dim value As Object

instance.Quality = value

value = instance.Quality
public object Quality {get; set;}
public:
property Object^ Quality {
   Object^ get();
   void set (    Object^ value);
}
Remarks
The meaning of this property is codec dependent.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

CompressionArguments Class
CompressionArguments Members


SourceArray Property

SourceArray Property

DicomObjects.DicomCodecs Namespace > CompressionArguments Class : SourceArray Property
The array from which the original decompressed pixel data is obtained. This could be a byte or short or ushort array depending on the pixel data bits stored.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property SourceArray As Array
'Usage

Dim instance As CompressionArguments
Dim value As Array

value = instance.SourceArray
public Array SourceArray {get;}
public:
property Array^ SourceArray {
   Array^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

CompressionArguments Class
CompressionArguments Members


WriteBehaviour Property (CompressionArguments)

WriteBehaviour Property (CompressionArguments)

DicomObjects.DicomCodecs Namespace > CompressionArguments Class : WriteBehaviour Property
Specific behaviours to use for compression
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property WriteBehaviour As WriteBehaviours
'Usage

Dim instance As CompressionArguments
Dim value As WriteBehaviours

value = instance.WriteBehaviour
public WriteBehaviours WriteBehaviour {get;}
public:
property WriteBehaviours^ WriteBehaviour {
   WriteBehaviours^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

CompressionArguments Class
CompressionArguments Members


DecompressionArguments Class

DecompressionArguments Class
Members

DicomObjects.DicomCodecs Namespace : DecompressionArguments Class
Class used to hold arguments passed to a decompression codec
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DecompressionArguments
   Inherits DicomCodecBaseArguments
'Usage

Dim instance As DecompressionArguments
public class DecompressionArguments : DicomCodecBaseArguments
public ref class DecompressionArguments : public DicomCodecBaseArguments
Inheritance Hierarchy

System.Object
DicomObjects.DicomCodecs.DicomCodecBaseArguments
DicomObjects.DicomCodecs.DecompressionArguments

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DecompressionArguments Members
DicomObjects.DicomCodecs Namespace


DecompressionArguments Class Members

DecompressionArguments Class Members
Fields Properties

DicomObjects.DicomCodecs Namespace : DecompressionArguments Class

The following tables list the members exposed by DecompressionArguments.

Public Fields
 | Name | Description
Public Field | ReadBehaviour | Specific behaviours to use for decompression
Top
Public Properties
 | Name | Description
Public Property | BitsAllocated | Number of bits per sample allocated (always 8 or 16) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | BitsStored | Number of bits per sample used (always between 8 and 16) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | DataSet | The full associated dataset (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | DestinationArray | The array into which the original decompressed pixel data is placed. This could be a byte or short or ushort array depending on the pixel data bits stored.
Public Property | Frame | The requested Frame number (first frame is 1, not 0)
Public Property | FrameCount | Total number of frames in the input stream. Useful for some codec (e.g. FFmpeg) if it needs to seek and run cope with out of sync and missing frames
Public Property | ImplementationUID | The implementation UID of the original image (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | InputTransferSyntax | The transfer syntax of the input data
Public Property | isSigned | Sign of the data (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | PhotometricInterpretation | The photometric interpretation of the data (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | PixelRequest | The requested resolution to decompress the image to
Public Property | Planarconfig | How the colour pixel data is arranged (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | Planes | The number of images planes. (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | Size | The size of the image (pixels x pixels) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | SourceStream | The stream from which compressed pixel data is obtained
Top
See Also

Reference

DecompressionArguments Class
DicomObjects.DicomCodecs Namespace


DecompressionArguments Class Properties

DecompressionArguments Class Properties

DicomObjects.DicomCodecs Namespace : DecompressionArguments Class

For a list of all members of this type, see DecompressionArguments members.

Public Properties
 | Name | Description
Public Property | BitsAllocated | Number of bits per sample allocated (always 8 or 16) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | BitsStored | Number of bits per sample used (always between 8 and 16) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | DataSet | The full associated dataset (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | DestinationArray | The array into which the original decompressed pixel data is placed. This could be a byte or short or ushort array depending on the pixel data bits stored.
Public Property | Frame | The requested Frame number (first frame is 1, not 0)
Public Property | FrameCount | Total number of frames in the input stream. Useful for some codec (e.g. FFmpeg) if it needs to seek and run cope with out of sync and missing frames
Public Property | ImplementationUID | The implementation UID of the original image (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | InputTransferSyntax | The transfer syntax of the input data
Public Property | isSigned | Sign of the data (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | PhotometricInterpretation | The photometric interpretation of the data (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | PixelRequest | The requested resolution to decompress the image to
Public Property | Planarconfig | How the colour pixel data is arranged (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | Planes | The number of images planes. (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | Size | The size of the image (pixels x pixels) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | SourceStream | The stream from which compressed pixel data is obtained
Top
See Also

Reference

DecompressionArguments Class
DicomObjects.DicomCodecs Namespace


DestinationArray Property

DestinationArray Property

DicomObjects.DicomCodecs Namespace > DecompressionArguments Class : DestinationArray Property
The array into which the original decompressed pixel data is placed. This could be a byte or short or ushort array depending on the pixel data bits stored.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property DestinationArray As Array
'Usage

Dim instance As DecompressionArguments
Dim value As Array

value = instance.DestinationArray
public Array DestinationArray {get;}
public:
property Array^ DestinationArray {
   Array^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DecompressionArguments Class
DecompressionArguments Members


Frame Property (DecompressionArguments)

Frame Property (DecompressionArguments)

DicomObjects.DicomCodecs Namespace > DecompressionArguments Class : Frame Property
The requested Frame number (first frame is 1, not 0)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Frame As Integer
'Usage

Dim instance As DecompressionArguments
Dim value As Integer

instance.Frame = value

value = instance.Frame
public int Frame {get; set;}
public:
property int Frame {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DecompressionArguments Class
DecompressionArguments Members


FrameCount Property (DecompressionArguments)

FrameCount Property (DecompressionArguments)

DicomObjects.DicomCodecs Namespace > DecompressionArguments Class : FrameCount Property
Total number of frames in the input stream. Useful for some codec (e.g. FFmpeg) if it needs to seek and run cope with out of sync and missing frames
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FrameCount As Integer
'Usage

Dim instance As DecompressionArguments
Dim value As Integer

instance.FrameCount = value

value = instance.FrameCount
public int FrameCount {get; set;}
public:
property int FrameCount {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DecompressionArguments Class
DecompressionArguments Members


InputTransferSyntax Property (DecompressionArguments)

InputTransferSyntax Property (DecompressionArguments)

DicomObjects.DicomCodecs Namespace > DecompressionArguments Class : InputTransferSyntax Property
The transfer syntax of the input data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property InputTransferSyntax As String
'Usage

Dim instance As DecompressionArguments
Dim value As String

value = instance.InputTransferSyntax
public string InputTransferSyntax {get;}
public:
property String^ InputTransferSyntax {
   String^ get();
}
Remarks
Most codecs will only handle one transfer syntax, but this is provided, as some can handle many - e.g. the JPEG 2000 codec which handles the lossless and lossy modes.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DecompressionArguments Class
DecompressionArguments Members


PixelRequest Property

PixelRequest Property

DicomObjects.DicomCodecs Namespace > DecompressionArguments Class : PixelRequest Property
The requested resolution to decompress the image to
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PixelRequest As PixelRequest
'Usage

Dim instance As DecompressionArguments
Dim value As PixelRequest

instance.PixelRequest = value

value = instance.PixelRequest
public PixelRequest PixelRequest {get; set;}
public:
property PixelRequest^ PixelRequest {
   PixelRequest^ get();
   void set (    PixelRequest^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DecompressionArguments Class
DecompressionArguments Members


SourceStream Property (DecompressionArguments)

SourceStream Property (DecompressionArguments)

DicomObjects.DicomCodecs Namespace > DecompressionArguments Class : SourceStream Property
The stream from which compressed pixel data is obtained
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property SourceStream As Stream
'Usage

Dim instance As DecompressionArguments
Dim value As Stream

value = instance.SourceStream
public Stream SourceStream {get;}
public:
property Stream^ SourceStream {
   Stream^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DecompressionArguments Class
DecompressionArguments Members


DecompressionArguments Class Fields

DecompressionArguments Class Fields

DicomObjects.DicomCodecs Namespace : DecompressionArguments Class

For a list of all members of this type, see DecompressionArguments members.

Public Fields
 | Name | Description
Public Field | ReadBehaviour | Specific behaviours to use for decompression
Top
See Also

Reference

DecompressionArguments Class
DicomObjects.DicomCodecs Namespace


ReadBehaviour Field

ReadBehaviour Field

DicomObjects.DicomCodecs Namespace > DecompressionArguments Class : ReadBehaviour Field
Specific behaviours to use for decompression
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadBehaviour As ReadBehaviours
'Usage

Dim instance As DecompressionArguments
Dim value As ReadBehaviours

value = instance.ReadBehaviour

instance.ReadBehaviour = value
public ReadBehaviours ReadBehaviour
public:
ReadBehaviours^ ReadBehaviour
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DecompressionArguments Class
DecompressionArguments Members


DicomCodecBaseArguments Class

DicomCodecBaseArguments Class
Members

DicomObjects.DicomCodecs Namespace : DicomCodecBaseArguments Class
The base class for arguments passed to codecs
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomCodecBaseArguments
'Usage

Dim instance As DicomCodecBaseArguments
public class DicomCodecBaseArguments
public ref class DicomCodecBaseArguments
Remarks

Different derived classes are defined for:

  • Compression & Export (CompressionArguments)
  • Decompression (DecompressionArguments)
  • Import (ImportArguments)
Inheritance Hierarchy

System.Object
DicomObjects.DicomCodecs.DicomCodecBaseArguments
DicomObjects.DicomCodecs.CompressionArguments
DicomObjects.DicomCodecs.DecompressionArguments
DicomObjects.DicomCodecs.ImportArguments
DicomObjects.DicomCodecs.ModificationArguments

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomCodecBaseArguments Members
DicomObjects.DicomCodecs Namespace


DicomCodecBaseArguments Class Members

DicomCodecBaseArguments Class Members
Properties

DicomObjects.DicomCodecs Namespace : DicomCodecBaseArguments Class

The following tables list the members exposed by DicomCodecBaseArguments.

Public Properties
 | Name | Description
Public Property | BitsAllocated | Number of bits per sample allocated (always 8 or 16)
Public Property | BitsStored | Number of bits per sample used (always between 8 and 16)
Public Property | DataSet | The full associated dataset
Public Property | ImplementationUID | The implementation UID of the original image
Public Property | isSigned | Sign of the data
Public Property | PhotometricInterpretation | The photometric interpretation of the data
Public Property | Planarconfig | How the colour pixel data is arranged
Public Property | Planes | The number of images planes.
Public Property | Size | The size of the image (pixels x pixels)
Top
See Also

Reference

DicomCodecBaseArguments Class
DicomObjects.DicomCodecs Namespace


DicomCodecBaseArguments Class Properties

DicomCodecBaseArguments Class Properties

DicomObjects.DicomCodecs Namespace : DicomCodecBaseArguments Class

For a list of all members of this type, see DicomCodecBaseArguments members.

Public Properties
 | Name | Description
Public Property | BitsAllocated | Number of bits per sample allocated (always 8 or 16)
Public Property | BitsStored | Number of bits per sample used (always between 8 and 16)
Public Property | DataSet | The full associated dataset
Public Property | ImplementationUID | The implementation UID of the original image
Public Property | isSigned | Sign of the data
Public Property | PhotometricInterpretation | The photometric interpretation of the data
Public Property | Planarconfig | How the colour pixel data is arranged
Public Property | Planes | The number of images planes.
Public Property | Size | The size of the image (pixels x pixels)
Top
See Also

Reference

DicomCodecBaseArguments Class
DicomObjects.DicomCodecs Namespace


BitsAllocated Property

BitsAllocated Property

DicomObjects.DicomCodecs Namespace > DicomCodecBaseArguments Class : BitsAllocated Property
Number of bits per sample allocated (always 8 or 16)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property BitsAllocated As Integer
'Usage

Dim instance As DicomCodecBaseArguments
Dim value As Integer

value = instance.BitsAllocated
public int BitsAllocated {get;}
public:
property int BitsAllocated {
   int get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomCodecBaseArguments Class
DicomCodecBaseArguments Members


BitsStored Property

BitsStored Property

DicomObjects.DicomCodecs Namespace > DicomCodecBaseArguments Class : BitsStored Property
Number of bits per sample used (always between 8 and 16)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property BitsStored As Integer
'Usage

Dim instance As DicomCodecBaseArguments
Dim value As Integer

value = instance.BitsStored
public int BitsStored {get;}
public:
property int BitsStored {
   int get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomCodecBaseArguments Class
DicomCodecBaseArguments Members


DataSet Property (DicomCodecBaseArguments)

DataSet Property (DicomCodecBaseArguments)

DicomObjects.DicomCodecs Namespace > DicomCodecBaseArguments Class : DataSet Property
The full associated dataset
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property DataSet As DicomDataSet
'Usage

Dim instance As DicomCodecBaseArguments
Dim value As DicomDataSet

value = instance.DataSet
public DicomDataSet DataSet {get;}
public:
property DicomDataSet^ DataSet {
   DicomDataSet^ get();
}
Remarks
This should NOT be changed during (de)compression, only during a prepare function
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomCodecBaseArguments Class
DicomCodecBaseArguments Members


ImplementationUID Property (DicomCodecBaseArguments)

ImplementationUID Property (DicomCodecBaseArguments)

DicomObjects.DicomCodecs Namespace > DicomCodecBaseArguments Class : ImplementationUID Property
The implementation UID of the original image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ImplementationUID As String
'Usage

Dim instance As DicomCodecBaseArguments
Dim value As String

value = instance.ImplementationUID
public string ImplementationUID {get;}
public:
property String^ ImplementationUID {
   String^ get();
}
Remarks
This is very occasionally useful, where there are known bugs in implementations, and which need different handling according to the implementation UID. This is derived either from the association negotiation, or the 0002 meta header
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomCodecBaseArguments Class
DicomCodecBaseArguments Members


isSigned Property

isSigned Property

DicomObjects.DicomCodecs Namespace > DicomCodecBaseArguments Class : isSigned Property
Sign of the data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property isSigned As Boolean
'Usage

Dim instance As DicomCodecBaseArguments
Dim value As Boolean

value = instance.isSigned
public bool isSigned {get;}
public:
property bool isSigned {
   bool get();
}
Remarks

0 = unsigned

1 = signed

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomCodecBaseArguments Class
DicomCodecBaseArguments Members


PhotometricInterpretation Property

PhotometricInterpretation Property

DicomObjects.DicomCodecs Namespace > DicomCodecBaseArguments Class : PhotometricInterpretation Property
The photometric interpretation of the data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property PhotometricInterpretation As String
'Usage

Dim instance As DicomCodecBaseArguments
Dim value As String

value = instance.PhotometricInterpretation
public string PhotometricInterpretation {get;}
public:
property String^ PhotometricInterpretation {
   String^ get();
}
Remarks
This should not change during the (de)compression phase. if this needs to be modified (e.g. changing to or from YBR_FULL_422 for JPEG images), then such changes should occur during the PrepareCompressFunction (for compression) or signaled via the GetDecompressedPhotometricInterpretationFunction (for decompression).
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomCodecBaseArguments Class
DicomCodecBaseArguments Members


Planarconfig Property

Planarconfig Property

DicomObjects.DicomCodecs Namespace > DicomCodecBaseArguments Class : Planarconfig Property
How the colour pixel data is arranged
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Planarconfig As Integer
'Usage

Dim instance As DicomCodecBaseArguments
Dim value As Integer

value = instance.Planarconfig
public int Planarconfig {get;}
public:
property int Planarconfig {
   int get();
}
Remarks

Only relevant for colour images

If 0 then pixel ordering is RGBRGBRGB....

If 1, then there is a whole frame of Red, followed by a whole frame of Green etc.

(could equally be Y, then B, then R in place of R, G & B)

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomCodecBaseArguments Class
DicomCodecBaseArguments Members


Planes Property

Planes Property

DicomObjects.DicomCodecs Namespace > DicomCodecBaseArguments Class : Planes Property
The number of images planes.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Planes As Integer
'Usage

Dim instance As DicomCodecBaseArguments
Dim value As Integer

value = instance.Planes
public int Planes {get;}
public:
property int Planes {
   int get();
}
Remarks
Always 1 for monochrome images or 3 for colour
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomCodecBaseArguments Class
DicomCodecBaseArguments Members


Size Property (DicomCodecBaseArguments)

Size Property (DicomCodecBaseArguments)

DicomObjects.DicomCodecs Namespace > DicomCodecBaseArguments Class : Size Property
The size of the image (pixels x pixels)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Size As Size
'Usage

Dim instance As DicomCodecBaseArguments
Dim value As Size

value = instance.Size
public Size Size {get;}
public:
property Size Size {
   Size get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomCodecBaseArguments Class
DicomCodecBaseArguments Members


ImportArguments Class

ImportArguments Class
Members

DicomObjects.DicomCodecs Namespace : ImportArguments Class
Class used to hold arguments passed to an import codec
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ImportArguments
   Inherits DicomCodecBaseArguments
'Usage

Dim instance As ImportArguments
public class ImportArguments : DicomCodecBaseArguments
public ref class ImportArguments : public DicomCodecBaseArguments
Inheritance Hierarchy

System.Object
DicomObjects.DicomCodecs.DicomCodecBaseArguments
DicomObjects.DicomCodecs.ImportArguments

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ImportArguments Members
DicomObjects.DicomCodecs Namespace


ImportArguments Class Members

ImportArguments Class Members
Properties

DicomObjects.DicomCodecs Namespace : ImportArguments Class

The following tables list the members exposed by ImportArguments.

Public Properties
 | Name | Description
Public Property | BitsAllocated | Number of bits per sample allocated (always 8 or 16) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | BitsStored | Number of bits per sample used (always between 8 and 16) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | DataSet | The full associated dataset (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | ImplementationUID | The implementation UID of the original image (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | ImportPixelData | Controls whether data should be actually read and put into the PixelData attribute at import time
Public Property | InputTransferSyntax | The transfer syntax of the input data
Public Property | isSigned | Sign of the data (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | LossyType | Value to place into DICOM attribute (0028,2114) when an image is compressed
Public Property | PhotometricInterpretation | The photometric interpretation of the data (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | Planarconfig | How the colour pixel data is arranged (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | Planes | The number of images planes. (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | Size | The size of the image (pixels x pixels) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | SourceStream | The stream from which compressed pixel data is obtained
Top
See Also

Reference

ImportArguments Class
DicomObjects.DicomCodecs Namespace


ImportArguments Class Properties

ImportArguments Class Properties

DicomObjects.DicomCodecs Namespace : ImportArguments Class

For a list of all members of this type, see ImportArguments members.

Public Properties
 | Name | Description
Public Property | BitsAllocated | Number of bits per sample allocated (always 8 or 16) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | BitsStored | Number of bits per sample used (always between 8 and 16) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | DataSet | The full associated dataset (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | ImplementationUID | The implementation UID of the original image (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | ImportPixelData | Controls whether data should be actually read and put into the PixelData attribute at import time
Public Property | InputTransferSyntax | The transfer syntax of the input data
Public Property | isSigned | Sign of the data (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | LossyType | Value to place into DICOM attribute (0028,2114) when an image is compressed
Public Property | PhotometricInterpretation | The photometric interpretation of the data (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | Planarconfig | How the colour pixel data is arranged (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | Planes | The number of images planes. (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | Size | The size of the image (pixels x pixels) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | SourceStream | The stream from which compressed pixel data is obtained
Top
See Also

Reference

ImportArguments Class
DicomObjects.DicomCodecs Namespace


ImportPixelData Property

ImportPixelData Property

DicomObjects.DicomCodecs Namespace > ImportArguments Class : ImportPixelData Property
Controls whether data should be actually read and put into the PixelData attribute at import time
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ImportPixelData As Boolean
'Usage

Dim instance As ImportArguments
Dim value As Boolean

instance.ImportPixelData = value

value = instance.ImportPixelData
public bool ImportPixelData {get; set;}
public:
property bool ImportPixelData {
   bool get();
   void set (    bool value);
}
Remarks
If false, then it is assumed that the SourceStream remains available for delayed pixel data reading
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ImportArguments Class
ImportArguments Members


InputTransferSyntax Property (ImportArguments)

InputTransferSyntax Property (ImportArguments)

DicomObjects.DicomCodecs Namespace > ImportArguments Class : InputTransferSyntax Property
The transfer syntax of the input data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property InputTransferSyntax As String
'Usage

Dim instance As ImportArguments
Dim value As String

value = instance.InputTransferSyntax
public string InputTransferSyntax {get;}
public:
property String^ InputTransferSyntax {
   String^ get();
}
Remarks
Most codecs will only handle one transfer syntax, but this is provided, as some can handle many - e.g. the JPEG 2000 codec which handles the lossless and lossy modes.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ImportArguments Class
ImportArguments Members


LossyType Property

LossyType Property

DicomObjects.DicomCodecs Namespace > ImportArguments Class : LossyType Property
Value to place into DICOM attribute (0028,2114) when an image is compressed
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LossyType As String
'Usage

Dim instance As ImportArguments
Dim value As String

instance.LossyType = value

value = instance.LossyType
public string LossyType {get; set;}
public:
property String^ LossyType {
   String^ get();
   void set (    String^ value);
}
Remarks
Leave blank for lossless compression.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ImportArguments Class
ImportArguments Members


SourceStream Property (ImportArguments)

SourceStream Property (ImportArguments)

DicomObjects.DicomCodecs Namespace > ImportArguments Class : SourceStream Property
The stream from which compressed pixel data is obtained
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property SourceStream As Stream
'Usage

Dim instance As ImportArguments
Dim value As Stream

value = instance.SourceStream
public Stream SourceStream {get;}
public:
property Stream^ SourceStream {
   Stream^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ImportArguments Class
ImportArguments Members


Jpeg2000CompressionOptions Class

Jpeg2000CompressionOptions Class
Members

DicomObjects.DicomCodecs Namespace : Jpeg2000CompressionOptions Class
Class which allows control of the details of JPEG 2000 compression
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class Jpeg2000CompressionOptions
'Usage

Dim instance As Jpeg2000CompressionOptions
public class Jpeg2000CompressionOptions
public ref class Jpeg2000CompressionOptions
Inheritance Hierarchy

System.Object
DicomObjects.DicomCodecs.Jpeg2000CompressionOptions

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Jpeg2000CompressionOptions Members
DicomObjects.DicomCodecs Namespace


Jpeg2000CompressionOptions Class Members

Jpeg2000CompressionOptions Class Members
Properties Methods

DicomObjects.DicomCodecs Namespace : Jpeg2000CompressionOptions Class

The following tables list the members exposed by Jpeg2000CompressionOptions.

Public Constructors
 | Name | Description
Public Constructor | Jpeg2000CompressionOptions Constructor | Create a blank Jpeg2000CompressionOptions object
Top
Public Properties
 | Name | Description
Public Property | ActualLevels | The number of decomposition levels actually used. If Levels is -1, then a default value (currently 5 but subject to change) is used.
Public Property | ForJpip | Specify useful values for subsequent JPIP usage
Public Property | Layers | The number of quality layers to use.
Public Property | Levels | The number of decomposition levels to use
Public Property | Lossy | Whether lossy compression is to be used.
Public Property | PrecinctSize | JPEG 2000 precinct size
Public Property | Progression | The order in which to output the packets
Public Property | Rate | The inverse of the compresion rate
Top
Public Methods
 | Name | Description
Public Method | Clone |
static (Shared in Visual Basic) | OptionsFromImage | Discover information about a JPEG 2000 encoded image
Top
See Also

Reference

Jpeg2000CompressionOptions Class
DicomObjects.DicomCodecs Namespace


Jpeg2000CompressionOptions Constructor

Jpeg2000CompressionOptions Constructor

DicomObjects.DicomCodecs Namespace > Jpeg2000CompressionOptions Class : Jpeg2000CompressionOptions Constructor
Create a blank Jpeg2000CompressionOptions object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Jpeg2000CompressionOptions()
public Jpeg2000CompressionOptions()
public:
Jpeg2000CompressionOptions();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Jpeg2000CompressionOptions Class
Jpeg2000CompressionOptions Members


Jpeg2000CompressionOptions Class Methods

Jpeg2000CompressionOptions Class Methods

DicomObjects.DicomCodecs Namespace : Jpeg2000CompressionOptions Class

For a list of all members of this type, see Jpeg2000CompressionOptions members.

Public Methods
 | Name | Description
Public Method | Clone |
static (Shared in Visual Basic) | OptionsFromImage | Discover information about a JPEG 2000 encoded image
Top
See Also

Reference

Jpeg2000CompressionOptions Class
DicomObjects.DicomCodecs Namespace


Clone Method (Jpeg2000CompressionOptions)

Clone Method (Jpeg2000CompressionOptions)

DicomObjects.DicomCodecs Namespace > Jpeg2000CompressionOptions Class : Clone Method
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function Clone() As Object
'Usage

Dim instance As Jpeg2000CompressionOptions
Dim value As Object

value = instance.Clone()
public object Clone()
public:
Object^ Clone();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Jpeg2000CompressionOptions Class
Jpeg2000CompressionOptions Members


OptionsFromImage Method

OptionsFromImage Method

DicomObjects.DicomCodecs Namespace > Jpeg2000CompressionOptions Class : OptionsFromImage Method
The image/dataset to analyse
The frame number to analyse
Discover information about a JPEG 2000 encoded image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function OptionsFromImage( _
   ByVal DataSet As DicomDataSet, _
   ByVal Frame As Integer _
) As Jpeg2000CompressionOptions
'Usage

Dim DataSet As DicomDataSet
Dim Frame As Integer
Dim value As Jpeg2000CompressionOptions

value = Jpeg2000CompressionOptions.OptionsFromImage(DataSet, Frame)
public static Jpeg2000CompressionOptions OptionsFromImage(
   DicomDataSet DataSet,
   int Frame
)
public:
static Jpeg2000CompressionOptions^ OptionsFromImage(
   DicomDataSet^ DataSet,
   int Frame
)

Parameters

DataSet
The image/dataset to analyse
Frame
The frame number to analyse

Return Value

An object representing the compressionoptions used, or null if no JPEG 2000 data exists
Remarks

This is a little simplistic, as the JPEG 2000 standard allows huge flexibility, including even the ability to have different options for different tiles of an image, but only data from the "top level" is included here. Similarly, whilst JPEG 2000 allows different precinct sizes for different resolution levels, only the highest level is returned from this method (and -1 is returned if MaxPrecinct size is specified)

At present, the data filled in by this method includes only:

  • Progression
  • Layers
  • Levels
  • PrecinctSize

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Jpeg2000CompressionOptions Class
Jpeg2000CompressionOptions Members


Jpeg2000CompressionOptions Class Properties

Jpeg2000CompressionOptions Class Properties

DicomObjects.DicomCodecs Namespace : Jpeg2000CompressionOptions Class

For a list of all members of this type, see Jpeg2000CompressionOptions members.

Public Properties
 | Name | Description
Public Property | ActualLevels | The number of decomposition levels actually used. If Levels is -1, then a default value (currently 5 but subject to change) is used.
Public Property | ForJpip | Specify useful values for subsequent JPIP usage
Public Property | Layers | The number of quality layers to use.
Public Property | Levels | The number of decomposition levels to use
Public Property | Lossy | Whether lossy compression is to be used.
Public Property | PrecinctSize | JPEG 2000 precinct size
Public Property | Progression | The order in which to output the packets
Public Property | Rate | The inverse of the compresion rate
Top
See Also

Reference

Jpeg2000CompressionOptions Class
DicomObjects.DicomCodecs Namespace


ActualLevels Property

ActualLevels Property

DicomObjects.DicomCodecs Namespace > Jpeg2000CompressionOptions Class : ActualLevels Property
The number of decomposition levels actually used. If Levels is -1, then a default value (currently 5 but subject to change) is used.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ActualLevels As Integer
'Usage

Dim instance As Jpeg2000CompressionOptions
Dim value As Integer

value = instance.ActualLevels
public int ActualLevels {get;}
public:
property int ActualLevels {
   int get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Jpeg2000CompressionOptions Class
Jpeg2000CompressionOptions Members


ForJpip Property

ForJpip Property

DicomObjects.DicomCodecs Namespace > Jpeg2000CompressionOptions Class : ForJpip Property
Specify useful values for subsequent JPIP usage
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ForJpip As Boolean
'Usage

Dim instance As Jpeg2000CompressionOptions
Dim value As Boolean

instance.ForJpip = value

value = instance.ForJpip
public bool ForJpip {get; set;}
public:
property bool ForJpip {
   bool get();
   void set (    bool value);
}
Remarks
JPEG images to be used for JPIP have certain unusual requirements such as being lossless, but with multiple quality layers. Setting this to true when generating a JPEG 2000 image helps to improve the quality of subsequent JPIP transfers based on the resulting image.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Jpeg2000CompressionOptions Class
Jpeg2000CompressionOptions Members


Layers Property

Layers Property

DicomObjects.DicomCodecs Namespace > Jpeg2000CompressionOptions Class : Layers Property
The number of quality layers to use.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Layers As Integer
'Usage

Dim instance As Jpeg2000CompressionOptions
Dim value As Integer

instance.Layers = value

value = instance.Layers
public int Layers {get; set;}
public:
property int Layers {
   int get();
   void set (    int value);
}
Remarks

Default value is 1, which is appropriate for whole image use, but for JPIP a larger number would be more appropriate.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Jpeg2000CompressionOptions Class
Jpeg2000CompressionOptions Members


Levels Property

Levels Property

DicomObjects.DicomCodecs Namespace > Jpeg2000CompressionOptions Class : Levels Property
The number of decomposition levels to use
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Levels As Integer
'Usage

Dim instance As Jpeg2000CompressionOptions
Dim value As Integer

instance.Levels = value

value = instance.Levels
public int Levels {get; set;}
public:
property int Levels {
   int get();
   void set (    int value);
}
Remarks
By default this is -1, which allows DicomObjects to choose a suitable default value, which might depend on the size or other characteristics of the image. The actuall value used is available via the ActualLevels property.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Jpeg2000CompressionOptions Class
Jpeg2000CompressionOptions Members


Lossy Property

Lossy Property

DicomObjects.DicomCodecs Namespace > Jpeg2000CompressionOptions Class : Lossy Property
Whether lossy compression is to be used.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Lossy As Boolean
'Usage

Dim instance As Jpeg2000CompressionOptions
Dim value As Boolean

instance.Lossy = value

value = instance.Lossy
public bool Lossy {get; set;}
public:
property bool Lossy {
   bool get();
   void set (    bool value);
}
Remarks
This is overridden and set to false when a lossless JPEG 2000 transfer syntax is used.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Jpeg2000CompressionOptions Class
Jpeg2000CompressionOptions Members


PrecinctSize Property

PrecinctSize Property

DicomObjects.DicomCodecs Namespace > Jpeg2000CompressionOptions Class : PrecinctSize Property
JPEG 2000 precinct size
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PrecinctSize As Integer
'Usage

Dim instance As Jpeg2000CompressionOptions
Dim value As Integer

instance.PrecinctSize = value

value = instance.PrecinctSize
public int PrecinctSize {get; set;}
public:
property int PrecinctSize {
   int get();
   void set (    int value);
}
Remarks

Default value is 0, which means to use the "MaxPrecincts" option meaning just a single precinct per band. This is appropriate for whole image use, but for JPIP a smaller precinct size is more appropriate.

The value must be a power of 2

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Jpeg2000CompressionOptions Class
Jpeg2000CompressionOptions Members


Progression Property

Progression Property

DicomObjects.DicomCodecs Namespace > Jpeg2000CompressionOptions Class : Progression Property
The order in which to output the packets
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Progression As Progression
'Usage

Dim instance As Jpeg2000CompressionOptions
Dim value As Progression

instance.Progression = value

value = instance.Progression
public Progression Progression {get; set;}
public:
property Progression Progression {
   Progression get();
   void set (    Progression value);
}
Remarks

Default is LRCP (Layer Resolution Component Position)

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Jpeg2000CompressionOptions Class
Jpeg2000CompressionOptions Members


Rate Property

Rate Property

DicomObjects.DicomCodecs Namespace > Jpeg2000CompressionOptions Class : Rate Property
The inverse of the compresion rate
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Rate As Double
'Usage

Dim instance As Jpeg2000CompressionOptions
Dim value As Double

instance.Rate = value

value = instance.Rate
public double Rate {get; set;}
public:
property double Rate {
   double get();
   void set (    double value);
}
Remarks
This value holds the ratio of the final compressed length to the original uncompressed length expressed as a fraction. e.g. Rate = 0.1 gives a compresison ratio of 10:1. It is only valid when Lossy=true;
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Jpeg2000CompressionOptions Class
Jpeg2000CompressionOptions Members


JpegLossless Class

JpegLossless Class
Members

DicomObjects.DicomCodecs Namespace : JpegLossless Class
The class which implements the internal JPEG Lossless codec
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class JpegLossless
   Inherits SimpleCodec
   Implements ICodecBase, ICompressor, IDecompressor
'Usage

Dim instance As JpegLossless
public class JpegLossless : SimpleCodec, ICodecBase, ICompressor, IDecompressor
public ref class JpegLossless : public SimpleCodec, ICodecBase, ICompressor, IDecompressor
Remarks
This members of this class contains only static data. Some may in the future be used to fine-tune the behaviour of the codec.
Inheritance Hierarchy

System.Object
DicomObjects.DicomCodecs.SimpleCodec
DicomObjects.DicomCodecs.JpegLossless

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JpegLossless Members
DicomObjects.DicomCodecs Namespace


JpegLossless Class Members

JpegLossless Class Members
Properties Methods

DicomObjects.DicomCodecs Namespace : JpegLossless Class

The following tables list the members exposed by JpegLossless.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | CheckForBadCompression | Controls whether or not to check for images badly compressed using very old versions of the COM version.
Public Property | MaximumBits | The maximum number of bits supported by this codec. (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Property | NeedsPlanarConfigTransform | Lets a caller to SimpleCodec.Decompress tell whether data needs to be transformed following decompression. It is only relevant if the image has a Planar Configuration value (0028,0006) of 1. For the simple codec, the value comes from the constructor (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Top
Public Methods
 | Name | Description
Public Method | BestRequest | The most appropriate DicomObjects.Internal.PixelRequest, given the requested zoom and image/codec type (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | CalculatedFrameCount | Limiting number of frames. Only used by MPEG etc. - default values used by other classes is int.MaxValue (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | Compress | Overridden. The internal compressor codec method for JPEG Lossless
Public Method | Decompress | Overridden. The internal decompressor codec method for JPEG Lossless
Public Method | DecompressedPhotometricInterpretation | The effective photometric Interpretation of the decompressed data (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | DecompressState | The status of the decompression (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | DownloadStatus | The status of the download (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | LockObject | Standard LockObject implementation for thread-safety (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | PrepareFunction | Prepares the data for Compression (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | Quality | (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Top
See Also

Reference

JpegLossless Class
DicomObjects.DicomCodecs Namespace


JpegLossless Class Methods

JpegLossless Class Methods

DicomObjects.DicomCodecs Namespace : JpegLossless Class

For a list of all members of this type, see JpegLossless members.

Public Methods
 | Name | Description
Public Method | BestRequest | The most appropriate DicomObjects.Internal.PixelRequest, given the requested zoom and image/codec type (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | CalculatedFrameCount | Limiting number of frames. Only used by MPEG etc. - default values used by other classes is int.MaxValue (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | Compress | Overridden. The internal compressor codec method for JPEG Lossless
Public Method | Decompress | Overridden. The internal decompressor codec method for JPEG Lossless
Public Method | DecompressedPhotometricInterpretation | The effective photometric Interpretation of the decompressed data (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | DecompressState | The status of the decompression (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | DownloadStatus | The status of the download (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | LockObject | Standard LockObject implementation for thread-safety (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | PrepareFunction | Prepares the data for Compression (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | Quality | (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Top
See Also

Reference

JpegLossless Class
DicomObjects.DicomCodecs Namespace


Compress Method (JpegLossless)

Compress Method (JpegLossless)

DicomObjects.DicomCodecs Namespace > JpegLossless Class : Compress Method
Standard arguments for a codec
The internal compressor codec method for JPEG Lossless
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Sub Compress( _
   ByVal args As CompressionArguments _
)
'Usage

Dim instance As JpegLossless
Dim args As CompressionArguments

instance.Compress(args)
public override void Compress(
   CompressionArguments args
)
public:
void Compress(
   CompressionArguments^ args
) override

Parameters

args
Standard arguments for a codec

Return Value

The compressed data
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JpegLossless Class
JpegLossless Members
Base Implementation in Compress


Decompress Method (JpegLossless)

Decompress Method (JpegLossless)

DicomObjects.DicomCodecs Namespace > JpegLossless Class : Decompress Method
Standard arguments for a codec
The internal decompressor codec method for JPEG Lossless
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Sub Decompress( _
   ByVal args As DecompressionArguments _
)
'Usage

Dim instance As JpegLossless
Dim args As DecompressionArguments

instance.Decompress(args)
public override void Decompress(
   DecompressionArguments args
)
public:
void Decompress(
   DecompressionArguments^ args
) override

Parameters

args
Standard arguments for a codec

Return Value

True if successful
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JpegLossless Class
JpegLossless Members
Base Implementation in Decompress


JpegLossless Class Properties

JpegLossless Class Properties

DicomObjects.DicomCodecs Namespace : JpegLossless Class

For a list of all members of this type, see JpegLossless members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | CheckForBadCompression | Controls whether or not to check for images badly compressed using very old versions of the COM version.
Public Property | MaximumBits | The maximum number of bits supported by this codec. (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Property | NeedsPlanarConfigTransform | Lets a caller to SimpleCodec.Decompress tell whether data needs to be transformed following decompression. It is only relevant if the image has a Planar Configuration value (0028,0006) of 1. For the simple codec, the value comes from the constructor (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Top
See Also

Reference

JpegLossless Class
DicomObjects.DicomCodecs Namespace


CheckForBadCompression Property

CheckForBadCompression Property

DicomObjects.DicomCodecs Namespace > JpegLossless Class : CheckForBadCompression Property
Controls whether or not to check for images badly compressed using very old versions of the COM version.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property CheckForBadCompression As Boolean
'Usage

Dim value As Boolean

JpegLossless.CheckForBadCompression = value

value = JpegLossless.CheckForBadCompression
public static bool CheckForBadCompression {get; set;}
public:
static property bool CheckForBadCompression {
   bool get();
   void set (    bool value);
}
Remarks

Setting this to true does impact decompression performance, as each possibly affected image (a sub-set of JPEG lossless types) is decompressed twice, to try to determine which version is more likely to be "correct"

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JpegLossless Class
JpegLossless Members


JpegLossy Class

JpegLossy Class
Members

DicomObjects.DicomCodecs Namespace : JpegLossy Class
Static class to hold global options for the JPEG lossy codec
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit NotInheritable Class JpegLossy
'Usage

Dim instance As JpegLossy
public static class JpegLossy
public ref class JpegLossy abstract sealed
Inheritance Hierarchy

System.Object
DicomObjects.DicomCodecs.JpegLossy

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JpegLossy Members
DicomObjects.DicomCodecs Namespace


JpegLossy Class Members

JpegLossy Class Members
Properties

DicomObjects.DicomCodecs Namespace : JpegLossy Class

The following tables list the members exposed by JpegLossy.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | DecompressionType | Controls which method is used for JPEG decompression
Top
See Also

Reference

JpegLossy Class
DicomObjects.DicomCodecs Namespace


JpegLossy Class Properties

JpegLossy Class Properties

DicomObjects.DicomCodecs Namespace : JpegLossy Class

For a list of all members of this type, see JpegLossy members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | DecompressionType | Controls which method is used for JPEG decompression
Top
See Also

Reference

JpegLossy Class
DicomObjects.DicomCodecs Namespace


DecompressionType Property

DecompressionType Property

DicomObjects.DicomCodecs Namespace > JpegLossy Class : DecompressionType Property
Controls which method is used for JPEG decompression
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property DecompressionType As CodecUsage
'Usage

Dim value As CodecUsage

JpegLossy.DecompressionType = value

value = JpegLossy.DecompressionType
public static CodecUsage DecompressionType {get; set;}
public:
static property CodecUsage DecompressionType {
   CodecUsage get();
   void set (    CodecUsage value);
}
Remarks
The internal codec is used for 12 bit images or when the value of this property is DicomObjects.Enums.CodecUsage.DicomObjects but the Windows intrinsic codec is used for 8 bit images when the value is DicomObjects.Enums.CodecUsage.Windows
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JpegLossy Class
JpegLossy Members


JpegLSCompressionOptions Class

JpegLSCompressionOptions Class
Members

DicomObjects.DicomCodecs Namespace : JpegLSCompressionOptions Class
Class which allows control of the details of JpegLS compression
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class JpegLSCompressionOptions
'Usage

Dim instance As JpegLSCompressionOptions
public class JpegLSCompressionOptions
public ref class JpegLSCompressionOptions
Inheritance Hierarchy

System.Object
DicomObjects.DicomCodecs.JpegLSCompressionOptions

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JpegLSCompressionOptions Members
DicomObjects.DicomCodecs Namespace


JpegLSCompressionOptions Class Members

JpegLSCompressionOptions Class Members
Properties Methods

DicomObjects.DicomCodecs Namespace : JpegLSCompressionOptions Class

The following tables list the members exposed by JpegLSCompressionOptions.

Public Constructors
 | Name | Description
Public Constructor | JpegLSCompressionOptions Constructor |
Top
Public Properties
 | Name | Description
Public Property | Near | This value is the maximum permissible difference between the original and encoded pixel values
Public Property | T1 | T1 threshold value for JpegLS compression
Public Property | T2 | T2 threshold value for JpegLS compression
Public Property | T3 | T3 threshold value for JpegLS compression
Top
Public Methods
 | Name | Description
Public Method | Clone |
Top
See Also

Reference

JpegLSCompressionOptions Class
DicomObjects.DicomCodecs Namespace


JpegLSCompressionOptions Constructor

JpegLSCompressionOptions Constructor

DicomObjects.DicomCodecs Namespace > JpegLSCompressionOptions Class : JpegLSCompressionOptions Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JpegLSCompressionOptions()
public JpegLSCompressionOptions()
public:
JpegLSCompressionOptions();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JpegLSCompressionOptions Class
JpegLSCompressionOptions Members


JpegLSCompressionOptions Class Methods

JpegLSCompressionOptions Class Methods

DicomObjects.DicomCodecs Namespace : JpegLSCompressionOptions Class

For a list of all members of this type, see JpegLSCompressionOptions members.

Public Methods
 | Name | Description
Public Method | Clone |
Top
See Also

Reference

JpegLSCompressionOptions Class
DicomObjects.DicomCodecs Namespace


Clone Method (JpegLSCompressionOptions)

Clone Method (JpegLSCompressionOptions)

DicomObjects.DicomCodecs Namespace > JpegLSCompressionOptions Class : Clone Method
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function Clone() As Object
'Usage

Dim instance As JpegLSCompressionOptions
Dim value As Object

value = instance.Clone()
public object Clone()
public:
Object^ Clone();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JpegLSCompressionOptions Class
JpegLSCompressionOptions Members


JpegLSCompressionOptions Class Properties

JpegLSCompressionOptions Class Properties

DicomObjects.DicomCodecs Namespace : JpegLSCompressionOptions Class

For a list of all members of this type, see JpegLSCompressionOptions members.

Public Properties
 | Name | Description
Public Property | Near | This value is the maximum permissible difference between the original and encoded pixel values
Public Property | T1 | T1 threshold value for JpegLS compression
Public Property | T2 | T2 threshold value for JpegLS compression
Public Property | T3 | T3 threshold value for JpegLS compression
Top
See Also

Reference

JpegLSCompressionOptions Class
DicomObjects.DicomCodecs Namespace


Near Property

Near Property

DicomObjects.DicomCodecs Namespace > JpegLSCompressionOptions Class : Near Property
This value is the maximum permissible difference between the original and encoded pixel values
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Near As Byte
'Usage

Dim instance As JpegLSCompressionOptions
Dim value As Byte

instance.Near = value

value = instance.Near
public byte Near {get; set;}
public:
property byte Near {
   byte get();
   void set (    byte value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JpegLSCompressionOptions Class
JpegLSCompressionOptions Members


T1 Property

T1 Property

DicomObjects.DicomCodecs Namespace > JpegLSCompressionOptions Class : T1 Property
T1 threshold value for JpegLS compression
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property T1 As Integer
'Usage

Dim instance As JpegLSCompressionOptions
Dim value As Integer

instance.T1 = value

value = instance.T1
public int T1 {get; set;}
public:
property int T1 {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JpegLSCompressionOptions Class
JpegLSCompressionOptions Members


T2 Property

T2 Property

DicomObjects.DicomCodecs Namespace > JpegLSCompressionOptions Class : T2 Property
T2 threshold value for JpegLS compression
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property T2 As Integer
'Usage

Dim instance As JpegLSCompressionOptions
Dim value As Integer

instance.T2 = value

value = instance.T2
public int T2 {get; set;}
public:
property int T2 {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JpegLSCompressionOptions Class
JpegLSCompressionOptions Members


T3 Property

T3 Property

DicomObjects.DicomCodecs Namespace > JpegLSCompressionOptions Class : T3 Property
T3 threshold value for JpegLS compression
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property T3 As Integer
'Usage

Dim instance As JpegLSCompressionOptions
Dim value As Integer

instance.T3 = value

value = instance.T3
public int T3 {get; set;}
public:
property int T3 {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JpegLSCompressionOptions Class
JpegLSCompressionOptions Members


Jpip Class

Jpip Class
Members

DicomObjects.DicomCodecs Namespace : Jpip Class
Static class to hold global options for JPIP usage
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit NotInheritable Class Jpip
'Usage

Dim instance As Jpip
public static class Jpip
public ref class Jpip abstract sealed
Inheritance Hierarchy

System.Object
DicomObjects.DicomCodecs.Jpip

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Jpip Members
DicomObjects.DicomCodecs Namespace


Jpip Class Members

Jpip Class Members
Properties Events

DicomObjects.DicomCodecs Namespace : Jpip Class

The following tables list the members exposed by Jpip.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | ClientCertificate | The client certificate to use when performing JPIP retrieval requests over https
static (Shared in Visual Basic) | JpipThreads | The number of concurrent threads to use to handle JPIP pixel data requests
static (Shared in Visual Basic) | JpipUriBase | Base Uri used to construct a Jpip Uri
static (Shared in Visual Basic) | LogLevel | The LogLevel to use to record JPIP activity
Top
Public Events
 | Name | Description
Public Event | GetUri | Event used to give finer control over the generation of Uris for JPIP transfer syntaxes
Public Event | StatusUpdate | Event fires when a JPIP image's status changes
Top
See Also

Reference

Jpip Class
DicomObjects.DicomCodecs Namespace


Jpip Class Properties

Jpip Class Properties

DicomObjects.DicomCodecs Namespace : Jpip Class

For a list of all members of this type, see Jpip members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | ClientCertificate | The client certificate to use when performing JPIP retrieval requests over https
static (Shared in Visual Basic) | JpipThreads | The number of concurrent threads to use to handle JPIP pixel data requests
static (Shared in Visual Basic) | JpipUriBase | Base Uri used to construct a Jpip Uri
static (Shared in Visual Basic) | LogLevel | The LogLevel to use to record JPIP activity
Top
See Also

Reference

Jpip Class
DicomObjects.DicomCodecs Namespace


ClientCertificate Property

ClientCertificate Property

DicomObjects.DicomCodecs Namespace > Jpip Class : ClientCertificate Property
The client certificate to use when performing JPIP retrieval requests over https
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property ClientCertificate As X509Certificate2
'Usage

Dim value As X509Certificate2

Jpip.ClientCertificate = value

value = Jpip.ClientCertificate
public static X509Certificate2 ClientCertificate {get; set;}
public:
static property X509Certificate2^ ClientCertificate {
   X509Certificate2^ get();
   void set (    X509Certificate2^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Jpip Class
Jpip Members


JpipThreads Property

JpipThreads Property

DicomObjects.DicomCodecs Namespace > Jpip Class : JpipThreads Property
The number of concurrent threads to use to handle JPIP pixel data requests
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property JpipThreads As Integer
'Usage

Dim value As Integer

Jpip.JpipThreads = value

value = Jpip.JpipThreads
public static int JpipThreads {get; set;}
public:
static property int JpipThreads {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Jpip Class
Jpip Members


JpipUriBase Property

JpipUriBase Property

DicomObjects.DicomCodecs Namespace > Jpip Class : JpipUriBase Property
Base Uri used to construct a Jpip Uri
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property JpipUriBase As String
'Usage

Dim value As String

Jpip.JpipUriBase = value

value = Jpip.JpipUriBase
public static string JpipUriBase {get; set;}
public:
static property String^ JpipUriBase {
   String^ get();
   void set (    String^ value);
}
Remarks

This property is only used if the GetUri event is not set

If used, then the Uri is set to the value of the property followed by the InstancerUID of the image

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Jpip Class
Jpip Members


LogLevel Property (Jpip)

LogLevel Property (Jpip)

DicomObjects.DicomCodecs Namespace > Jpip Class : LogLevel Property
The LogLevel to use to record JPIP activity
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Property LogLevel As LogLevel
'Usage

Dim value As LogLevel

Jpip.LogLevel = value

value = Jpip.LogLevel
public static LogLevel LogLevel {get; set;}
public:
static property LogLevel LogLevel {
   LogLevel get();
   void set (    LogLevel value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Jpip Class
Jpip Members


Jpip Class Events

Jpip Class Events

DicomObjects.DicomCodecs Namespace : Jpip Class

For a list of all members of this type, see Jpip members.

Public Events
 | Name | Description
Public Event | GetUri | Event used to give finer control over the generation of Uris for JPIP transfer syntaxes
Public Event | StatusUpdate | Event fires when a JPIP image's status changes
Top
See Also

Reference

Jpip Class
DicomObjects.DicomCodecs Namespace


GetUri Event

GetUri Event

DicomObjects.DicomCodecs Namespace > Jpip Class : GetUri Event
Event used to give finer control over the generation of Uris for JPIP transfer syntaxes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event GetUri As GetUrlHandler
'Usage

Dim instance As Jpip
Dim handler As GetUrlHandler

AddHandler instance.GetUri, handler
public event GetUrlHandler GetUri
public:
event GetUrlHandler^ GetUri
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Jpip Class
Jpip Members


StatusUpdate Event

StatusUpdate Event

DicomObjects.DicomCodecs Namespace > Jpip Class : StatusUpdate Event
Event fires when a JPIP image's status changes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event StatusUpdate As StatusUpdateHandler
'Usage

Dim instance As Jpip
Dim handler As StatusUpdateHandler

AddHandler instance.StatusUpdate, handler
public event StatusUpdateHandler StatusUpdate
public:
event StatusUpdateHandler^ StatusUpdate
Remarks
This can indicate that data has been downloaded and/or decompressed
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Jpip Class
Jpip Members


ModificationArguments Class

ModificationArguments Class
Members

DicomObjects.DicomCodecs Namespace : ModificationArguments Class
Defines changes which need to be applied to a compressed image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ModificationArguments
   Inherits DicomCodecBaseArguments
'Usage

Dim instance As ModificationArguments
public class ModificationArguments : DicomCodecBaseArguments
public ref class ModificationArguments : public DicomCodecBaseArguments
Remarks
This class is only passed to the prepare function, and enables the codec to notify DicomObjects of changes that the code will be making during compression.
Inheritance Hierarchy

System.Object
DicomObjects.DicomCodecs.DicomCodecBaseArguments
DicomObjects.DicomCodecs.ModificationArguments

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ModificationArguments Members
DicomObjects.DicomCodecs Namespace


ModificationArguments Class Members

ModificationArguments Class Members
Properties

DicomObjects.DicomCodecs Namespace : ModificationArguments Class

The following tables list the members exposed by ModificationArguments.

Public Properties
 | Name | Description
Public Property | BitsAllocated | Number of bits per sample allocated (always 8 or 16) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | BitsStored | Number of bits per sample used (always between 8 and 16) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | DataSet | The full associated dataset (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | ImplementationUID | The implementation UID of the original image (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | isSigned | Sign of the data (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | LossyDescription | The description of the image to put into the newly compressed object
Public Property | LossyMethod | The definition of the image to put into the newly compressed object
Public Property | Offset | The rescale offset to be applied to the new object
Public Property | OutputTransferSyntax | The transfer syntax into which the image should be compressed
Public Property | PhotometricInterpretation | The photometric interpretation of the data (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | Planarconfig | How the colour pixel data is arranged (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | Planes | The number of images planes. (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | Quality | A data to describe compression quality
Public Property | RequestedColourSpace | The colour space into which the codec will be converting the image
Public Property | Scale | The scale factor to be applied to the new image
Public Property | Size | The size of the image (pixels x pixels) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Top
See Also

Reference

ModificationArguments Class
DicomObjects.DicomCodecs Namespace


ModificationArguments Class Properties

ModificationArguments Class Properties

DicomObjects.DicomCodecs Namespace : ModificationArguments Class

For a list of all members of this type, see ModificationArguments members.

Public Properties
 | Name | Description
Public Property | BitsAllocated | Number of bits per sample allocated (always 8 or 16) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | BitsStored | Number of bits per sample used (always between 8 and 16) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | DataSet | The full associated dataset (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | ImplementationUID | The implementation UID of the original image (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | isSigned | Sign of the data (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | LossyDescription | The description of the image to put into the newly compressed object
Public Property | LossyMethod | The definition of the image to put into the newly compressed object
Public Property | Offset | The rescale offset to be applied to the new object
Public Property | OutputTransferSyntax | The transfer syntax into which the image should be compressed
Public Property | PhotometricInterpretation | The photometric interpretation of the data (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | Planarconfig | How the colour pixel data is arranged (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | Planes | The number of images planes. (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Public Property | Quality | A data to describe compression quality
Public Property | RequestedColourSpace | The colour space into which the codec will be converting the image
Public Property | Scale | The scale factor to be applied to the new image
Public Property | Size | The size of the image (pixels x pixels) (Inherited from DicomObjects.DicomCodecs.DicomCodecBaseArguments)
Top
See Also

Reference

ModificationArguments Class
DicomObjects.DicomCodecs Namespace


LossyDescription Property

LossyDescription Property

DicomObjects.DicomCodecs Namespace > ModificationArguments Class : LossyDescription Property
The description of the image to put into the newly compressed object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LossyDescription As String
'Usage

Dim instance As ModificationArguments
Dim value As String

instance.LossyDescription = value

value = instance.LossyDescription
public string LossyDescription {get; set;}
public:
property String^ LossyDescription {
   String^ get();
   void set (    String^ value);
}
Remarks
This information will be placed into attribute (0008,2111)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ModificationArguments Class
ModificationArguments Members


LossyMethod Property

LossyMethod Property

DicomObjects.DicomCodecs Namespace > ModificationArguments Class : LossyMethod Property
The definition of the image to put into the newly compressed object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LossyMethod As String
'Usage

Dim instance As ModificationArguments
Dim value As String

instance.LossyMethod = value

value = instance.LossyMethod
public string LossyMethod {get; set;}
public:
property String^ LossyMethod {
   String^ get();
   void set (    String^ value);
}
Remarks
This information will be placed into attribute (0008,2114). Allowed values are:
  • ISO_10918_1 = JPEG Lossy Compression
  • ISO_14495_1 = JPEG-LS Near-lossless Compression
  • ISO_15444_1 = JPEG 2000 Irreversible Compression
  • ISO_13818_2 = MPEG2 Compression
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ModificationArguments Class
ModificationArguments Members


Offset Property

Offset Property

DicomObjects.DicomCodecs Namespace > ModificationArguments Class : Offset Property
The rescale offset to be applied to the new object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Offset As Single
'Usage

Dim instance As ModificationArguments
Dim value As Single

instance.Offset = value

value = instance.Offset
public float Offset {get; set;}
public:
property float Offset {
   float get();
   void set (    float value);
}
Remarks
This is important for codecs compressing CT, so that the Hounsfield values remain valid
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ModificationArguments Class
ModificationArguments Members


OutputTransferSyntax Property (ModificationArguments)

OutputTransferSyntax Property (ModificationArguments)

DicomObjects.DicomCodecs Namespace > ModificationArguments Class : OutputTransferSyntax Property
The transfer syntax into which the image should be compressed
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property OutputTransferSyntax As String
'Usage

Dim instance As ModificationArguments
Dim value As String

value = instance.OutputTransferSyntax
public string OutputTransferSyntax {get;}
public:
property String^ OutputTransferSyntax {
   String^ get();
}
Remarks
Most codecs will only handle one transfer syntax, but this is provided, as some can handle many - e.g. the JPEG 2000 codec which handles the lossless and lossy modes.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ModificationArguments Class
ModificationArguments Members


Quality Property (ModificationArguments)

Quality Property (ModificationArguments)

DicomObjects.DicomCodecs Namespace > ModificationArguments Class : Quality Property
A data to describe compression quality
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Quality As Object
'Usage

Dim instance As ModificationArguments
Dim value As Object

value = instance.Quality
public object Quality {get;}
public:
property Object^ Quality {
   Object^ get();
}
Remarks
The meaning of this property is codec dependent.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ModificationArguments Class
ModificationArguments Members


RequestedColourSpace Property

RequestedColourSpace Property

DicomObjects.DicomCodecs Namespace > ModificationArguments Class : RequestedColourSpace Property
The colour space into which the codec will be converting the image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RequestedColourSpace As String
'Usage

Dim instance As ModificationArguments
Dim value As String

instance.RequestedColourSpace = value

value = instance.RequestedColourSpace
public string RequestedColourSpace {get; set;}
public:
property String^ RequestedColourSpace {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ModificationArguments Class
ModificationArguments Members


Scale Property (ModificationArguments)

Scale Property (ModificationArguments)

DicomObjects.DicomCodecs Namespace > ModificationArguments Class : Scale Property
The scale factor to be applied to the new image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Scale As Single
'Usage

Dim instance As ModificationArguments
Dim value As Single

instance.Scale = value

value = instance.Scale
public float Scale {get; set;}
public:
property float Scale {
   float get();
   void set (    float value);
}
Remarks
This is important for codecs compressing CT, so that the Hounsfield values remain valid
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ModificationArguments Class
ModificationArguments Members


SimpleCodec Class

SimpleCodec Class
Members

DicomObjects.DicomCodecs Namespace : SimpleCodec Class
A class which provides a simple implementation of most of the required members of ICompressor and IDecompressor, simplifying implementation for transfer syntaxes which do not need partial decompression.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class SimpleCodec
   Implements ICodecBase, ICompressor, IDecompressor
'Usage

Dim instance As SimpleCodec
public abstract class SimpleCodec : ICodecBase, ICompressor, IDecompressor
public ref class SimpleCodec abstract : public ICodecBase, ICompressor, IDecompressor
Inheritance Hierarchy

System.Object
DicomObjects.DicomCodecs.SimpleCodec
DicomObjects.DicomCodecs.JpegLossless
DicomObjects.DicomCodecs.VideoCodec

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SimpleCodec Members
DicomObjects.DicomCodecs Namespace


SimpleCodec Class Members

SimpleCodec Class Members
Properties Methods

DicomObjects.DicomCodecs Namespace : SimpleCodec Class

The following tables list the members exposed by SimpleCodec.

Public Properties
 | Name | Description
Public Property | MaximumBits | The maximum number of bits supported by this codec.
Public Property | NeedsPlanarConfigTransform | Lets a caller to Decompress tell whether data needs to be transformed following decompression. It is only relevant if the image has a Planar Configuration value (0028,0006) of 1. For the simple codec, the value comes from the constructor
Top
Public Methods
 | Name | Description
Public Method | BestRequest | The most appropriate DicomObjects.Internal.PixelRequest, given the requested zoom and image/codec type
Public Method | CalculatedFrameCount | Limiting number of frames. Only used by MPEG etc. - default values used by other classes is int.MaxValue
Public Method | Compress | Abstract Placeholder for the compression routine
Public Method | Decompress | Abstract Placeholder for the decompression routine
Public Method | DecompressedPhotometricInterpretation | The effective photometric Interpretation of the decompressed data
Public Method | DecompressState | The status of the decompression
Public Method | DownloadStatus | The status of the download
Public Method | LockObject | Standard LockObject implementation for thread-safety
Public Method | PrepareFunction | Prepares the data for Compression
Public Method | Quality |
Top
See Also

Reference

SimpleCodec Class
DicomObjects.DicomCodecs Namespace


SimpleCodec Class Methods

SimpleCodec Class Methods

DicomObjects.DicomCodecs Namespace : SimpleCodec Class

For a list of all members of this type, see SimpleCodec members.

Public Methods
 | Name | Description
Public Method | BestRequest | The most appropriate DicomObjects.Internal.PixelRequest, given the requested zoom and image/codec type
Public Method | CalculatedFrameCount | Limiting number of frames. Only used by MPEG etc. - default values used by other classes is int.MaxValue
Public Method | Compress | Abstract Placeholder for the compression routine
Public Method | Decompress | Abstract Placeholder for the decompression routine
Public Method | DecompressedPhotometricInterpretation | The effective photometric Interpretation of the decompressed data
Public Method | DecompressState | The status of the decompression
Public Method | DownloadStatus | The status of the download
Public Method | LockObject | Standard LockObject implementation for thread-safety
Public Method | PrepareFunction | Prepares the data for Compression
Public Method | Quality |
Top
See Also

Reference

SimpleCodec Class
DicomObjects.DicomCodecs Namespace


BestRequest Method (SimpleCodec)

BestRequest Method (SimpleCodec)

DicomObjects.DicomCodecs Namespace > SimpleCodec Class : BestRequest Method
The requested Zoom
The requested usage of the pixel data
The surrounding dataset
The requested Frame
The most appropriate DicomObjects.Internal.PixelRequest, given the requested zoom and image/codec type
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function BestRequest( _
   ByVal Zoom As Single, _
   ByVal Sync As RequestType, _
   ByVal parent As DicomDataSet, _
   ByVal Frame As Integer _
) As PixelRequest
'Usage

Dim instance As SimpleCodec
Dim Zoom As Single
Dim Sync As RequestType
Dim parent As DicomDataSet
Dim Frame As Integer
Dim value As PixelRequest

value = instance.BestRequest(Zoom, Sync, parent, Frame)
public PixelRequest BestRequest(
   float Zoom,
   RequestType Sync,
   DicomDataSet parent,
   int Frame
)
public:
PixelRequest^ BestRequest(
   float Zoom,
   RequestType Sync,
   DicomDataSet^ parent,
   int Frame
)

Parameters

Zoom
The requested Zoom
Sync
The requested usage of the pixel data
parent
The surrounding dataset
Frame
The requested Frame

Return Value

The best fit
Remarks
For this codec, the return object always references the full area, as this compression method does not support partial decompression
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SimpleCodec Class
SimpleCodec Members


CalculatedFrameCount Method (SimpleCodec)

CalculatedFrameCount Method (SimpleCodec)

DicomObjects.DicomCodecs Namespace > SimpleCodec Class : CalculatedFrameCount Method
Limiting number of frames. Only used by MPEG etc. - default values used by other classes is int.MaxValue
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function CalculatedFrameCount() As Integer
'Usage

Dim instance As SimpleCodec
Dim value As Integer

value = instance.CalculatedFrameCount()
public virtual int CalculatedFrameCount()
public:
virtual int CalculatedFrameCount();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SimpleCodec Class
SimpleCodec Members


Compress Method (SimpleCodec)

Compress Method (SimpleCodec)

DicomObjects.DicomCodecs Namespace > SimpleCodec Class : Compress Method
Standard Decompression arguments
Abstract Placeholder for the compression routine
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustOverride Sub Compress( _
   ByVal args As CompressionArguments _
)
'Usage

Dim instance As SimpleCodec
Dim args As CompressionArguments

instance.Compress(args)
public abstract void Compress(
   CompressionArguments args
)
public:
abstract void Compress(
   CompressionArguments^ args
)

Parameters

args
Standard Decompression arguments
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SimpleCodec Class
SimpleCodec Members


Decompress Method (SimpleCodec)

Decompress Method (SimpleCodec)

DicomObjects.DicomCodecs Namespace > SimpleCodec Class : Decompress Method
Standard Decompression arguments
Abstract Placeholder for the decompression routine
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustOverride Sub Decompress( _
   ByVal args As DecompressionArguments _
)
'Usage

Dim instance As SimpleCodec
Dim args As DecompressionArguments

instance.Decompress(args)
public abstract void Decompress(
   DecompressionArguments args
)
public:
abstract void Decompress(
   DecompressionArguments^ args
)

Parameters

args
Standard Decompression arguments
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SimpleCodec Class
SimpleCodec Members


DecompressedPhotometricInterpretation Method (SimpleCodec)

DecompressedPhotometricInterpretation Method (SimpleCodec)

DicomObjects.DicomCodecs Namespace > SimpleCodec Class : DecompressedPhotometricInterpretation Method
The surrounding dataset
The effective photometric Interpretation of the decompressed data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function DecompressedPhotometricInterpretation( _
   ByVal parent As DicomDataSet _
) As String
'Usage

Dim instance As SimpleCodec
Dim parent As DicomDataSet
Dim value As String

value = instance.DecompressedPhotometricInterpretation(parent)
public virtual string DecompressedPhotometricInterpretation(
   DicomDataSet parent
)
public:
virtual String^ DecompressedPhotometricInterpretation(
   DicomDataSet^ parent
)

Parameters

parent
The surrounding dataset

Return Value

Photometric Interpretation as a string
Remarks
For RLE, this will always be the native value of the parent dataset (0028,0004)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SimpleCodec Class
SimpleCodec Members


DecompressState Method (SimpleCodec)

DecompressState Method (SimpleCodec)

DicomObjects.DicomCodecs Namespace > SimpleCodec Class : DecompressState Method
The request against which to compare the current status
The status of the decompression
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function DecompressState( _
   ByVal Request As PixelRequest _
) As DecompressStatus
'Usage

Dim instance As SimpleCodec
Dim Request As PixelRequest
Dim value As DecompressStatus

value = instance.DecompressState(Request)
public DecompressStatus DecompressState(
   PixelRequest Request
)
public:
DecompressStatus DecompressState(
   PixelRequest^ Request
)

Parameters

Request
The request against which to compare the current status

Return Value

DicomObjects.Enums.DecompressStatus.None
Remarks
For this codec, this method always returns DicomObjects.Enums.DecompressStatus.None
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SimpleCodec Class
SimpleCodec Members


DownloadStatus Method (SimpleCodec)

DownloadStatus Method (SimpleCodec)

DicomObjects.DicomCodecs Namespace > SimpleCodec Class : DownloadStatus Method
The request against which to compare the current status
The status of the download
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function DownloadStatus( _
   ByVal Request As PixelRequest _
) As ProgressiveStatus
'Usage

Dim instance As SimpleCodec
Dim Request As PixelRequest
Dim value As ProgressiveStatus

value = instance.DownloadStatus(Request)
public ProgressiveStatus DownloadStatus(
   PixelRequest Request
)
public:
ProgressiveStatus DownloadStatus(
   PixelRequest^ Request
)

Parameters

Request
The request against which to compare the current status

Return Value

DicomObjects.Enums.ProgressiveStatus.WholeImage
Remarks
For this codec, this method always returns DicomObjects.Enums.ProgressiveStatus.WholeImage
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SimpleCodec Class
SimpleCodec Members


LockObject Method (SimpleCodec)

LockObject Method (SimpleCodec)

DicomObjects.DicomCodecs Namespace > SimpleCodec Class : LockObject Method
Standard LockObject implementation for thread-safety
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function LockObject() As Object
'Usage

Dim instance As SimpleCodec
Dim value As Object

value = instance.LockObject()
public object LockObject()
public:
Object^ LockObject();

Return Value

The Instance object
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SimpleCodec Class
SimpleCodec Members


PrepareFunction Method (SimpleCodec)

PrepareFunction Method (SimpleCodec)

DicomObjects.DicomCodecs Namespace > SimpleCodec Class : PrepareFunction Method
Details of the compression to take place
Prepares the data for Compression
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Sub PrepareFunction( _
   ByVal args As ModificationArguments _
)
'Usage

Dim instance As SimpleCodec
Dim args As ModificationArguments

instance.PrepareFunction(args)
public virtual void PrepareFunction(
   ModificationArguments args
)
public:
virtual void PrepareFunction(
   ModificationArguments^ args
)

Parameters

args
Details of the compression to take place
Remarks
For this codec, this function does nothing
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SimpleCodec Class
SimpleCodec Members


Quality Method (SimpleCodec)

Quality Method (SimpleCodec)

DicomObjects.DicomCodecs Namespace > SimpleCodec Class : Quality Method
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function Quality( _
   ByVal TransferSyntax As String, _
   ByVal qmap As Dictionary(Of String,Object), _
   ByVal dataset As DicomDataSet _
) As Object
'Usage

Dim instance As SimpleCodec
Dim TransferSyntax As String
Dim qmap As Dictionary(Of String,Object)
Dim dataset As DicomDataSet
Dim value As Object

value = instance.Quality(TransferSyntax, qmap, dataset)
public object Quality(
   string TransferSyntax,
   Dictionary<string,object> qmap,
   DicomDataSet dataset
)
public:
Object^ Quality(
   String^ TransferSyntax,
   Dictionary<String^,Object^>^ qmap,
   DicomDataSet^ dataset
)

Parameters

TransferSyntax
qmap
dataset
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SimpleCodec Class
SimpleCodec Members


SimpleCodec Class Properties

SimpleCodec Class Properties

DicomObjects.DicomCodecs Namespace : SimpleCodec Class

For a list of all members of this type, see SimpleCodec members.

Public Properties
 | Name | Description
Public Property | MaximumBits | The maximum number of bits supported by this codec.
Public Property | NeedsPlanarConfigTransform | Lets a caller to Decompress tell whether data needs to be transformed following decompression. It is only relevant if the image has a Planar Configuration value (0028,0006) of 1. For the simple codec, the value comes from the constructor
Top
See Also

Reference

SimpleCodec Class
DicomObjects.DicomCodecs Namespace


MaximumBits Property (SimpleCodec)

MaximumBits Property (SimpleCodec)

DicomObjects.DicomCodecs Namespace > SimpleCodec Class : MaximumBits Property
The maximum number of bits supported by this codec.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property MaximumBits As Integer
'Usage

Dim instance As SimpleCodec
Dim value As Integer

value = instance.MaximumBits
public virtual int MaximumBits {get;}
public:
virtual property int MaximumBits {
   int get();
}
Remarks

For the simple codec, the maximum is as provided in the constructor

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SimpleCodec Class
SimpleCodec Members


NeedsPlanarConfigTransform Property (SimpleCodec)

NeedsPlanarConfigTransform Property (SimpleCodec)

DicomObjects.DicomCodecs Namespace > SimpleCodec Class : NeedsPlanarConfigTransform Property

Lets a caller to Decompress tell whether data needs to be transformed following decompression. It is only relevant if the image has a Planar Configuration value (0028,0006) of 1.

For the simple codec, the value comes from the constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property NeedsPlanarConfigTransform As Boolean
'Usage

Dim instance As SimpleCodec
Dim value As Boolean

value = instance.NeedsPlanarConfigTransform
public virtual bool NeedsPlanarConfigTransform {get;}
public:
virtual property bool NeedsPlanarConfigTransform {
   bool get();
}
Remarks
For the simple codec, the value comes from the constructor
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SimpleCodec Class
SimpleCodec Members


VideoCodec Class

VideoCodec Class
Members

DicomObjects.DicomCodecs Namespace : VideoCodec Class
A class derived from SimpleCodec to be used by video codecs
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class VideoCodec
   Inherits SimpleCodec
   Implements ICodecBase, ICompressor, IDecompressor
'Usage

Dim instance As VideoCodec
public class VideoCodec : SimpleCodec, ICodecBase, ICompressor, IDecompressor
public ref class VideoCodec : public SimpleCodec, ICodecBase, ICompressor, IDecompressor
Inheritance Hierarchy

System.Object
DicomObjects.DicomCodecs.SimpleCodec
DicomObjects.DicomCodecs.VideoCodec

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VideoCodec Members
DicomObjects.DicomCodecs Namespace


VideoCodec Class Members

VideoCodec Class Members
Properties Methods

DicomObjects.DicomCodecs Namespace : VideoCodec Class

The following tables list the members exposed by VideoCodec.

Public Constructors
 | Name | Description
Public Constructor | VideoCodec Constructor | Simple constructor
Top
Public Properties
 | Name | Description
Public Property | MaximumBits | The maximum number of bits supported by this codec. (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Property | NeedsPlanarConfigTransform | Lets a caller to Decompress tell whether data needs to be transformed following decompression. It is only relevant if the image has a Planar Configuration value (0028,0006) of 1. For the simple codec, the value comes from the constructor (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Top
Public Methods
 | Name | Description
Public Method | BestRequest | The most appropriate DicomObjects.Internal.PixelRequest, given the requested zoom and image/codec type (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | CalculatedFrameCount | Overridden. Limiting number of frames. Only used by MPEG etc. - default values used by other classes is int.MaxValue
Public Method | Compress | Overridden. Not currently implemented
Public Method | Decompress | Overridden. Abstract Placeholder for the decompression routine
Public Method | DecompressedPhotometricInterpretation | Overridden. The effective photometric Interpretation of the decompressed data
Public Method | DecompressState | The status of the decompression (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | DownloadStatus | The status of the download (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | LockObject | Standard LockObject implementation for thread-safety (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | PrepareFunction | Prepares the data for Compression (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | Quality | (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Top
See Also

Reference

VideoCodec Class
DicomObjects.DicomCodecs Namespace


VideoCodec Constructor

VideoCodec Constructor

DicomObjects.DicomCodecs Namespace > VideoCodec Class : VideoCodec Constructor
Simple constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal d As IFrameSource _
)
'Usage

Dim d As IFrameSource

Dim instance As New VideoCodec(d)
public VideoCodec(
   IFrameSource d
)
public:
VideoCodec(
   IFrameSource^ d
)

Parameters

d
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VideoCodec Class
VideoCodec Members


VideoCodec Class Methods

VideoCodec Class Methods

DicomObjects.DicomCodecs Namespace : VideoCodec Class

For a list of all members of this type, see VideoCodec members.

Public Methods
 | Name | Description
Public Method | BestRequest | The most appropriate DicomObjects.Internal.PixelRequest, given the requested zoom and image/codec type (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | CalculatedFrameCount | Overridden. Limiting number of frames. Only used by MPEG etc. - default values used by other classes is int.MaxValue
Public Method | Compress | Overridden. Not currently implemented
Public Method | Decompress | Overridden. Abstract Placeholder for the decompression routine
Public Method | DecompressedPhotometricInterpretation | Overridden. The effective photometric Interpretation of the decompressed data
Public Method | DecompressState | The status of the decompression (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | DownloadStatus | The status of the download (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | LockObject | Standard LockObject implementation for thread-safety (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | PrepareFunction | Prepares the data for Compression (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Method | Quality | (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Top
See Also

Reference

VideoCodec Class
DicomObjects.DicomCodecs Namespace


CalculatedFrameCount Method (VideoCodec)

CalculatedFrameCount Method (VideoCodec)

DicomObjects.DicomCodecs Namespace > VideoCodec Class : CalculatedFrameCount Method
Limiting number of frames. Only used by MPEG etc. - default values used by other classes is int.MaxValue
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function CalculatedFrameCount() As Integer
'Usage

Dim instance As VideoCodec
Dim value As Integer

value = instance.CalculatedFrameCount()
public override int CalculatedFrameCount()
public:
int CalculatedFrameCount(); override
Remarks
This is calculated from the codec - e.g. the length of an MPEG data stream in frames.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VideoCodec Class
VideoCodec Members
Base Implementation in CalculatedFrameCount


Compress Method (VideoCodec)

Compress Method (VideoCodec)

DicomObjects.DicomCodecs Namespace > VideoCodec Class : Compress Method
Not currently implemented
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Sub Compress( _
   ByVal args As CompressionArguments _
)
'Usage

Dim instance As VideoCodec
Dim args As CompressionArguments

instance.Compress(args)
public override void Compress(
   CompressionArguments args
)
public:
void Compress(
   CompressionArguments^ args
) override

Parameters

args
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VideoCodec Class
VideoCodec Members
Base Implementation in Compress


Decompress Method (VideoCodec)

Decompress Method (VideoCodec)

DicomObjects.DicomCodecs Namespace > VideoCodec Class : Decompress Method
Standard Decompression arguments
Abstract Placeholder for the decompression routine
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Sub Decompress( _
   ByVal args As DecompressionArguments _
)
'Usage

Dim instance As VideoCodec
Dim args As DecompressionArguments

instance.Decompress(args)
public override void Decompress(
   DecompressionArguments args
)
public:
void Decompress(
   DecompressionArguments^ args
) override

Parameters

args
Standard Decompression arguments
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VideoCodec Class
VideoCodec Members
Base Implementation in Decompress


DecompressedPhotometricInterpretation Method (VideoCodec)

DecompressedPhotometricInterpretation Method (VideoCodec)

DicomObjects.DicomCodecs Namespace > VideoCodec Class : DecompressedPhotometricInterpretation Method
The surrounding dataset
The effective photometric Interpretation of the decompressed data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function DecompressedPhotometricInterpretation( _
   ByVal parent As DicomDataSet _
) As String
'Usage

Dim instance As VideoCodec
Dim parent As DicomDataSet
Dim value As String

value = instance.DecompressedPhotometricInterpretation(parent)
public override string DecompressedPhotometricInterpretation(
   DicomDataSet parent
)
public:
String^ DecompressedPhotometricInterpretation(
   DicomDataSet^ parent
) override

Parameters

parent
The surrounding dataset

Return Value

Photometric Interpretation as a string
Remarks
For RLE, this will always be the native value of the parent dataset (0028,0004)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VideoCodec Class
VideoCodec Members
Base Implementation in DecompressedPhotometricInterpretation


ICodecBase Interface

ICodecBase Interface
Members

DicomObjects.DicomCodecs Namespace : ICodecBase Interface
Common features for all codecs
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ICodecBase
'Usage

Dim instance As ICodecBase
public interface ICodecBase
public interface class ICodecBase
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ICodecBase Members
DicomObjects.DicomCodecs Namespace


ICodecBase Interface Members

ICodecBase Interface Members
Methods

DicomObjects.DicomCodecs Namespace : ICodecBase Interface

The following tables list the members exposed by ICodecBase.

Public Methods
 | Name | Description
Method | LockObject | A simple object to provide synchronisation if a codec is accessed via multiple threads
Top
See Also

Reference

ICodecBase Interface
DicomObjects.DicomCodecs Namespace


ICodecBase Interface Methods

ICodecBase Interface Methods

DicomObjects.DicomCodecs Namespace : ICodecBase Interface

For a list of all members of this type, see ICodecBase members.

Public Methods
 | Name | Description
Method | LockObject | A simple object to provide synchronisation if a codec is accessed via multiple threads
Top
See Also

Reference

ICodecBase Interface
DicomObjects.DicomCodecs Namespace


LockObject Method (ICodecBase)

LockObject Method (ICodecBase)

DicomObjects.DicomCodecs Namespace > ICodecBase Interface : LockObject Method
A simple object to provide synchronisation if a codec is accessed via multiple threads
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function LockObject() As Object
'Usage

Dim instance As ICodecBase
Dim value As Object

value = instance.LockObject()
object LockObject()
Object^ LockObject();

Return Value

An object which should only be used for locking
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ICodecBase Interface
ICodecBase Members


ICompressor Interface

ICompressor Interface
Members

DicomObjects.DicomCodecs Namespace : ICompressor Interface
Interface implemented by all compression codecs
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ICompressor
   Inherits ICodecBase
'Usage

Dim instance As ICompressor
public interface ICompressor : ICodecBase
public interface class ICompressor : public ICodecBase
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ICompressor Members
DicomObjects.DicomCodecs Namespace


ICompressor Interface Members

ICompressor Interface Members
Properties Methods

DicomObjects.DicomCodecs Namespace : ICompressor Interface

The following tables list the members exposed by ICompressor.

Public Properties
Name | Description
Property | MaximumBits | The maximum number of bits supported by this codec.
Property NeedsPlanarConfigTransform

Lets a caller to Compress tell whether data needs to be transformed before compression. It is only relevent if the image has a Planar Configuration value (0028,0006) of 1.

If this property is true, then the compressor expects data in "by pixel" mode, irrespective of the stated Planar Configuration, so DicomObjects will apply a suitable transformation pre-compression.

If this property is false, then the compressor can use data in the original form as stated by the Planar Configuration, so pre-compression transformation is not necessary.

Top
Public Methods
 | Name | Description
Method | Compress | Compress a frame of pixel data
Method | LockObject | A simple object to provide synchronisation if a codec is accessed via multiple threads (Inherited from DicomObjects.DicomCodecs.ICodecBase)
Method | PrepareFunction | Make any changes to the main dataset, before doing the frame-by-frame compression, and inform DicomObjects of any preprocessing required.
Method | Quality |
Top
See Also

Reference

ICompressor Interface
DicomObjects.DicomCodecs Namespace


ICompressor Interface Methods

ICompressor Interface Methods

DicomObjects.DicomCodecs Namespace : ICompressor Interface

For a list of all members of this type, see ICompressor members.

Public Methods
 | Name | Description
Method | Compress | Compress a frame of pixel data
Method | LockObject | A simple object to provide synchronisation if a codec is accessed via multiple threads (Inherited from DicomObjects.DicomCodecs.ICodecBase)
Method | PrepareFunction | Make any changes to the main dataset, before doing the frame-by-frame compression, and inform DicomObjects of any preprocessing required.
Method | Quality |
Top
See Also

Reference

ICompressor Interface
DicomObjects.DicomCodecs Namespace


Compress Method (ICompressor)

Compress Method (ICompressor)

DicomObjects.DicomCodecs Namespace > ICompressor Interface : Compress Method
Standard compression arguments as defined by the CompressionArguments class
Compress a frame of pixel data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub Compress( _
   ByVal args As CompressionArguments _
)
'Usage

Dim instance As ICompressor
Dim args As CompressionArguments

instance.Compress(args)
void Compress(
   CompressionArguments args
)
void Compress(
   CompressionArguments^ args
)

Parameters

args
Standard compression arguments as defined by the CompressionArguments class
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ICompressor Interface
ICompressor Members


PrepareFunction Method (ICompressor)

PrepareFunction Method (ICompressor)

DicomObjects.DicomCodecs Namespace > ICompressor Interface : PrepareFunction Method
Standard argument for PrepareCompress
Make any changes to the main dataset, before doing the frame-by-frame compression, and inform DicomObjects of any preprocessing required.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub PrepareFunction( _
   ByVal args As ModificationArguments _
)
'Usage

Dim instance As ICompressor
Dim args As ModificationArguments

instance.PrepareFunction(args)
void PrepareFunction(
   ModificationArguments args
)
void PrepareFunction(
   ModificationArguments^ args
)

Parameters

args
Standard argument for PrepareCompress
Remarks
Details vary according to the compression method, but examples include:
  • For some compression methods, a transform is needed to bring the data into the 12 bit unsigned range (e.g. JPEG lossy extended)
  • For colour images, the photometric interpretation of the dataset may need to be changed to (e.g. to YBR_FULL_422 for JPEG lossy)

By changing the values in ModificationArguments, a compressor can control how the pixel data is passed to it by DicomObjects, or how some other values are later changed:

Setting ModificationArgs.LossyDescription to a human description and and ModificationArgs.LossyMethod to a codec values (e.g. "ISO_10918_1" for JPEG)

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ICompressor Interface
ICompressor Members


Quality Method (ICompressor)

Quality Method (ICompressor)

DicomObjects.DicomCodecs Namespace > ICompressor Interface : Quality Method
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function Quality( _
   ByVal TransferSyntax As String, _
   ByVal qmap As Dictionary(Of String,Object), _
   ByVal dataset As DicomDataSet _
) As Object
'Usage

Dim instance As ICompressor
Dim TransferSyntax As String
Dim qmap As Dictionary(Of String,Object)
Dim dataset As DicomDataSet
Dim value As Object

value = instance.Quality(TransferSyntax, qmap, dataset)
object Quality(
   string TransferSyntax,
   Dictionary<string,object> qmap,
   DicomDataSet dataset
)
Object^ Quality(
   String^ TransferSyntax,
   Dictionary<String^,Object^>^ qmap,
   DicomDataSet^ dataset
)

Parameters

TransferSyntax
qmap
dataset
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ICompressor Interface
ICompressor Members


ICompressor Interface Properties

ICompressor Interface Properties

DicomObjects.DicomCodecs Namespace : ICompressor Interface

For a list of all members of this type, see ICompressor members.

Public Properties
Name | Description
Property | MaximumBits | The maximum number of bits supported by this codec.
Property NeedsPlanarConfigTransform

Lets a caller to Compress tell whether data needs to be transformed before compression. It is only relevent if the image has a Planar Configuration value (0028,0006) of 1.

If this property is true, then the compressor expects data in "by pixel" mode, irrespective of the stated Planar Configuration, so DicomObjects will apply a suitable transformation pre-compression.

If this property is false, then the compressor can use data in the original form as stated by the Planar Configuration, so pre-compression transformation is not necessary.

Top
See Also

Reference

ICompressor Interface
DicomObjects.DicomCodecs Namespace


MaximumBits Property (ICompressor)

MaximumBits Property (ICompressor)

DicomObjects.DicomCodecs Namespace > ICompressor Interface : MaximumBits Property
The maximum number of bits supported by this codec.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property MaximumBits As Integer
'Usage

Dim instance As ICompressor
Dim value As Integer

value = instance.MaximumBits
int MaximumBits {get;}
property int MaximumBits {
   int get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ICompressor Interface
ICompressor Members


NeedsPlanarConfigTransform Property (ICompressor)

NeedsPlanarConfigTransform Property (ICompressor)

DicomObjects.DicomCodecs Namespace > ICompressor Interface : NeedsPlanarConfigTransform Property

Lets a caller to Compress tell whether data needs to be transformed before compression. It is only relevent if the image has a Planar Configuration value (0028,0006) of 1.

If this property is true, then the compressor expects data in "by pixel" mode, irrespective of the stated Planar Configuration, so DicomObjects will apply a suitable transformation pre-compression.

If this property is false, then the compressor can use data in the original form as stated by the Planar Configuration, so pre-compression transformation is not necessary.

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property NeedsPlanarConfigTransform As Boolean
'Usage

Dim instance As ICompressor
Dim value As Boolean

value = instance.NeedsPlanarConfigTransform
bool NeedsPlanarConfigTransform {get;}
property bool NeedsPlanarConfigTransform {
   bool get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ICompressor Interface
ICompressor Members


IDecompressor Interface

IDecompressor Interface
Members

DicomObjects.DicomCodecs Namespace : IDecompressor Interface
Interface implemented by for all DICOM decompression codecs
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IDecompressor
   Inherits ICodecBase
'Usage

Dim instance As IDecompressor
public interface IDecompressor : ICodecBase
public interface class IDecompressor : public ICodecBase
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

IDecompressor Members
DicomObjects.DicomCodecs Namespace


IDecompressor Interface Members

IDecompressor Interface Members
Properties Methods

DicomObjects.DicomCodecs Namespace : IDecompressor Interface

The following tables list the members exposed by IDecompressor.

Public Properties
Name Description
Property NeedsPlanarConfigTransform

Lets a caller to Decompress tell whether data needs to be transformed following decompression. It is only relevant if the image has a Planar Configuration value (0028,0006) of 1.

If this property is true, then the decompressor will return data in "by pixel" mode, irrespective of the stated Planar Configuration, so post-decompression transformation may be necessary.

If this property is false, then the decompressor will return data in the form requested by the stated Planar Configuration, so post-decompression transformation is not necessary.

Top
Public Methods
 | Name | Description
Method | BestRequest | The most appropriate DicomObjects.Internal.PixelRequest, given the requested zoom and image/codec type
Method | CalculatedFrameCount | The number of frames calculated by decompressor
Method | Decompress | Decompress a frame as defined by the DecompressionArguments argument
Method | DecompressedPhotometricInterpretation | The effective Photometric Interpretation of the decompressed data
Method | DecompressState | The status of the decompression
Method | DownloadStatus | The status of the download
Method | LockObject | A simple object to provide synchronisation if a codec is accessed via multiple threads (Inherited from DicomObjects.DicomCodecs.ICodecBase)
Top
See Also

Reference

IDecompressor Interface
DicomObjects.DicomCodecs Namespace


IDecompressor Interface Methods

IDecompressor Interface Methods

DicomObjects.DicomCodecs Namespace : IDecompressor Interface

For a list of all members of this type, see IDecompressor members.

Public Methods
 | Name | Description
Method | BestRequest | The most appropriate DicomObjects.Internal.PixelRequest, given the requested zoom and image/codec type
Method | CalculatedFrameCount | The number of frames calculated by decompressor
Method | Decompress | Decompress a frame as defined by the DecompressionArguments argument
Method | DecompressedPhotometricInterpretation | The effective Photometric Interpretation of the decompressed data
Method | DecompressState | The status of the decompression
Method | DownloadStatus | The status of the download
Method | LockObject | A simple object to provide synchronisation if a codec is accessed via multiple threads (Inherited from DicomObjects.DicomCodecs.ICodecBase)
Top
See Also

Reference

IDecompressor Interface
DicomObjects.DicomCodecs Namespace


BestRequest Method (IDecompressor)

BestRequest Method (IDecompressor)

DicomObjects.DicomCodecs Namespace > IDecompressor Interface : BestRequest Method
The requested Zoom
The requested usage of the pixel data
The surrounding dataset
The requested Frame
The most appropriate DicomObjects.Internal.PixelRequest, given the requested zoom and image/codec type
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function BestRequest( _
   ByVal Zoom As Single, _
   ByVal Sync As RequestType, _
   ByVal parent As DicomDataSet, _
   ByVal Frame As Integer _
) As PixelRequest
'Usage

Dim instance As IDecompressor
Dim Zoom As Single
Dim Sync As RequestType
Dim parent As DicomDataSet
Dim Frame As Integer
Dim value As PixelRequest

value = instance.BestRequest(Zoom, Sync, parent, Frame)
PixelRequest BestRequest(
   float Zoom,
   RequestType Sync,
   DicomDataSet parent,
   int Frame
)
PixelRequest^ BestRequest(
   float Zoom,
   RequestType Sync,
   DicomDataSet^ parent,
   int Frame
)

Parameters

Zoom
The requested Zoom
Sync
The requested usage of the pixel data
parent
The surrounding dataset
Frame
The requested Frame

Return Value

The best fit
Remarks
This is only really used for codecs with partial decompression options, such as JPEG 2000 and JPIP
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

IDecompressor Interface
IDecompressor Members


CalculatedFrameCount Method (IDecompressor)

CalculatedFrameCount Method (IDecompressor)

DicomObjects.DicomCodecs Namespace > IDecompressor Interface : CalculatedFrameCount Method
The number of frames calculated by decompressor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function CalculatedFrameCount() As Integer
'Usage

Dim instance As IDecompressor
Dim value As Integer

value = instance.CalculatedFrameCount()
int CalculatedFrameCount()
int CalculatedFrameCount();

Return Value

Number of frames as calculated by the codec
Remarks
This value may not match the NumberOfFrames in the DICOM data
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

IDecompressor Interface
IDecompressor Members


Decompress Method (IDecompressor)

Decompress Method (IDecompressor)

DicomObjects.DicomCodecs Namespace > IDecompressor Interface : Decompress Method
The decompression arguments
Decompress a frame as defined by the DecompressionArguments argument
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub Decompress( _
   ByVal args As DecompressionArguments _
)
'Usage

Dim instance As IDecompressor
Dim args As DecompressionArguments

instance.Decompress(args)
void Decompress(
   DecompressionArguments args
)
void Decompress(
   DecompressionArguments^ args
)

Parameters

args
The decompression arguments
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

IDecompressor Interface
IDecompressor Members


DecompressedPhotometricInterpretation Method (IDecompressor)

DecompressedPhotometricInterpretation Method (IDecompressor)

DicomObjects.DicomCodecs Namespace > IDecompressor Interface : DecompressedPhotometricInterpretation Method
The surrounding dataset
The effective Photometric Interpretation of the decompressed data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function DecompressedPhotometricInterpretation( _
   ByVal parent As DicomDataSet _
) As String
'Usage

Dim instance As IDecompressor
Dim parent As DicomDataSet
Dim value As String

value = instance.DecompressedPhotometricInterpretation(parent)
string DecompressedPhotometricInterpretation(
   DicomDataSet parent
)
String^ DecompressedPhotometricInterpretation(
   DicomDataSet^ parent
)

Parameters

parent
The surrounding dataset

Return Value

Photometric Interpretation as a string
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

IDecompressor Interface
IDecompressor Members


DecompressState Method (IDecompressor)

DecompressState Method (IDecompressor)

DicomObjects.DicomCodecs Namespace > IDecompressor Interface : DecompressState Method
The request against which to compare the current status
The status of the decompression
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function DecompressState( _
   ByVal Request As PixelRequest _
) As DecompressStatus
'Usage

Dim instance As IDecompressor
Dim Request As PixelRequest
Dim value As DecompressStatus

value = instance.DecompressState(Request)
DecompressStatus DecompressState(
   PixelRequest Request
)
DecompressStatus DecompressState(
   PixelRequest^ Request
)

Parameters

Request
The request against which to compare the current status

Return Value

The state of the decompression
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

IDecompressor Interface
IDecompressor Members


DownloadStatus Method (IDecompressor)

DownloadStatus Method (IDecompressor)

DicomObjects.DicomCodecs Namespace > IDecompressor Interface : DownloadStatus Method
The request against which to compare the current status
The status of the download
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function DownloadStatus( _
   ByVal Request As PixelRequest _
) As ProgressiveStatus
'Usage

Dim instance As IDecompressor
Dim Request As PixelRequest
Dim value As ProgressiveStatus

value = instance.DownloadStatus(Request)
ProgressiveStatus DownloadStatus(
   PixelRequest Request
)
ProgressiveStatus DownloadStatus(
   PixelRequest^ Request
)

Parameters

Request
The request against which to compare the current status

Return Value

The state of the download
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

IDecompressor Interface
IDecompressor Members


IDecompressor Interface Properties

IDecompressor Interface Properties

DicomObjects.DicomCodecs Namespace : IDecompressor Interface

For a list of all members of this type, see IDecompressor members.

Public Properties
Name Description
Property NeedsPlanarConfigTransform

Lets a caller to Decompress tell whether data needs to be transformed following decompression. It is only relevant if the image has a Planar Configuration value (0028,0006) of 1.

If this property is true, then the decompressor will return data in "by pixel" mode, irrespective of the stated Planar Configuration, so post-decompression transformation may be necessary.

If this property is false, then the decompressor will return data in the form requested by the stated Planar Configuration, so post-decompression transformation is not necessary.

Top
See Also

Reference

IDecompressor Interface
DicomObjects.DicomCodecs Namespace


NeedsPlanarConfigTransform Property (IDecompressor)

NeedsPlanarConfigTransform Property (IDecompressor)

DicomObjects.DicomCodecs Namespace > IDecompressor Interface : NeedsPlanarConfigTransform Property

Lets a caller to Decompress tell whether data needs to be transformed following decompression. It is only relevant if the image has a Planar Configuration value (0028,0006) of 1.

If this property is true, then the decompressor will return data in "by pixel" mode, irrespective of the stated Planar Configuration, so post-decompression transformation may be necessary.

If this property is false, then the decompressor will return data in the form requested by the stated Planar Configuration, so post-decompression transformation is not necessary.

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property NeedsPlanarConfigTransform As Boolean
'Usage

Dim instance As IDecompressor
Dim value As Boolean

value = instance.NeedsPlanarConfigTransform
bool NeedsPlanarConfigTransform {get;}
property bool NeedsPlanarConfigTransform {
   bool get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

IDecompressor Interface
IDecompressor Members


IExporter Interface

IExporter Interface
Members

DicomObjects.DicomCodecs Namespace : IExporter Interface
Interface implemented by all export codecs
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IExporter
   Inherits ICodecBase
'Usage

Dim instance As IExporter
public interface IExporter : ICodecBase
public interface class IExporter : public ICodecBase
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

IExporter Members
DicomObjects.DicomCodecs Namespace


IExporter Interface Members

IExporter Interface Members
Methods

DicomObjects.DicomCodecs Namespace : IExporter Interface

The following tables list the members exposed by IExporter.

Public Methods
 | Name | Description
Method | Export | Export to an external format image
Method | LockObject | A simple object to provide synchronisation if a codec is accessed via multiple threads (Inherited from DicomObjects.DicomCodecs.ICodecBase)
Top
See Also

Reference

IExporter Interface
DicomObjects.DicomCodecs Namespace


IExporter Interface Methods

IExporter Interface Methods

DicomObjects.DicomCodecs Namespace : IExporter Interface

For a list of all members of this type, see IExporter members.

Public Methods
 | Name | Description
Method | Export | Export to an external format image
Method | LockObject | A simple object to provide synchronisation if a codec is accessed via multiple threads (Inherited from DicomObjects.DicomCodecs.ICodecBase)
Top
See Also

Reference

IExporter Interface
DicomObjects.DicomCodecs Namespace


Export Method (IExporter)

Export Method (IExporter)

DicomObjects.DicomCodecs Namespace > IExporter Interface : Export Method
Standard export arguments as defined by the CompressionArguments class
Export to an external format image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub Export( _
   ByVal args As CompressionArguments _
)
'Usage

Dim instance As IExporter
Dim args As CompressionArguments

instance.Export(args)
void Export(
   CompressionArguments args
)
void Export(
   CompressionArguments^ args
)

Parameters

args
Standard export arguments as defined by the CompressionArguments class
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

IExporter Interface
IExporter Members


IImporter Interface

IImporter Interface
Members

DicomObjects.DicomCodecs Namespace : IImporter Interface
Interface implemented by all import codecs
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IImporter
   Inherits ICodecBase
'Usage

Dim instance As IImporter
public interface IImporter : ICodecBase
public interface class IImporter : public ICodecBase
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

IImporter Members
DicomObjects.DicomCodecs Namespace


IImporter Interface Members

IImporter Interface Members
Methods

DicomObjects.DicomCodecs Namespace : IImporter Interface

The following tables list the members exposed by IImporter.

Public Methods
 | Name | Description
Method | Import | Import from an external format image
Method | LockObject | A simple object to provide synchronisation if a codec is accessed via multiple threads (Inherited from DicomObjects.DicomCodecs.ICodecBase)
Top
See Also

Reference

IImporter Interface
DicomObjects.DicomCodecs Namespace


IImporter Interface Methods

IImporter Interface Methods

DicomObjects.DicomCodecs Namespace : IImporter Interface

For a list of all members of this type, see IImporter members.

Public Methods
 | Name | Description
Method | Import | Import from an external format image
Method | LockObject | A simple object to provide synchronisation if a codec is accessed via multiple threads (Inherited from DicomObjects.DicomCodecs.ICodecBase)
Top
See Also

Reference

IImporter Interface
DicomObjects.DicomCodecs Namespace


Import Method (IImporter)

Import Method (IImporter)

DicomObjects.DicomCodecs Namespace > IImporter Interface : Import Method
Standard import arguments as defined by the ImportArguments class
Import from an external format image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function Import( _
   ByVal args As ImportArguments _
) As Boolean
'Usage

Dim instance As IImporter
Dim args As ImportArguments
Dim value As Boolean

value = instance.Import(args)
bool Import(
   ImportArguments args
)
bool Import(
   ImportArguments^ args
)

Parameters

args
Standard import arguments as defined by the ImportArguments class

Return Value

true if successful
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

IImporter Interface
IImporter Members


DicomObjects.DicomUIDs Namespace

DicomObjects.DicomUIDs Namespace
Inheritance Hierarchy
A set of classes with static fields holding the standard well-known DICOM UIDs, grouped by function
Classes
 | Class | Description
Class | ApplicationContexts | Contains UIDs for Application Context
Class | FramesOfReference | Well known frames of reference
Class | MetaSOPClasses | Contains UIDs for Meta SOP Class
Class | SOPClasses | Contains UIDs for SOP Class
Class | TransferSyntaxes | Contains UIDs for Transfer Syntax
Class | UID | A class to represent the constant UIDs present as readonly fields in the objects within the DicomObjects.DicomUIDs namespace.
Class | WellKnownInstances | Contains UIDs for Well Known Instance
See Also

Reference

DicomObjects.NET.8.40 Assembly


ApplicationContexts Class

ApplicationContexts Class
Members

DicomObjects.DicomUIDs Namespace : ApplicationContexts Class
Contains UIDs for Application Context
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit NotInheritable Class ApplicationContexts
'Usage

Dim instance As ApplicationContexts
public static class ApplicationContexts
public ref class ApplicationContexts abstract sealed
Remarks

Contains constant UID ApplicationContext "1.2.840.10008.3.1.1.1"

Inheritance Hierarchy

System.Object
DicomObjects.DicomUIDs.ApplicationContexts

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ApplicationContexts Members
DicomObjects.DicomUIDs Namespace


ApplicationContexts Class Members

ApplicationContexts Class Members
Fields

DicomObjects.DicomUIDs Namespace : ApplicationContexts Class

The following tables list the members exposed by ApplicationContexts.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | DICOM30 | DICOM Application Context Name (1.2.840.10008.3.1.1.1)
Top
See Also

Reference

ApplicationContexts Class
DicomObjects.DicomUIDs Namespace


ApplicationContexts Class Fields

ApplicationContexts Class Fields

DicomObjects.DicomUIDs Namespace : ApplicationContexts Class

For a list of all members of this type, see ApplicationContexts members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | DICOM30 | DICOM Application Context Name (1.2.840.10008.3.1.1.1)
Top
See Also

Reference

ApplicationContexts Class
DicomObjects.DicomUIDs Namespace


DICOM30 Field

DICOM30 Field

DicomObjects.DicomUIDs Namespace > ApplicationContexts Class : DICOM30 Field
DICOM Application Context Name (1.2.840.10008.3.1.1.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly DICOM30 As UID
'Usage

Dim value As UID

value = ApplicationContexts.DICOM30
public static readonly UID DICOM30
public:
static readonly UID^ DICOM30
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ApplicationContexts Class
ApplicationContexts Members


FramesOfReference Class

FramesOfReference Class
Members

DicomObjects.DicomUIDs Namespace : FramesOfReference Class
Well known frames of reference
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit NotInheritable Class FramesOfReference
'Usage

Dim instance As FramesOfReference
public static class FramesOfReference
public ref class FramesOfReference abstract sealed
Remarks
The constants in this class are well-known instances, representing externally defined frames of reference
Inheritance Hierarchy

System.Object
DicomObjects.DicomUIDs.FramesOfReference

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FramesOfReference Members
DicomObjects.DicomUIDs Namespace


FramesOfReference Class Members

FramesOfReference Class Members
Fields

DicomObjects.DicomUIDs Namespace : FramesOfReference Class

The following tables list the members exposed by FramesOfReference.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | ICBM452T1FrameofReference | ICBM 452 T1 Frame of Reference (1.2.840.10008.1.4.2.1)
static (Shared in Visual Basic) | ICBMSingleSubjectMRIFrameofReference | ICBM Single Subject MRI Frame of Reference (1.2.840.10008.1.4.2.2)
static (Shared in Visual Basic) | SPM2AVG152PDFrameofReference | SPM2 AVG152PD Frame of Reference (1.2.840.10008.1.4.1.17)
static (Shared in Visual Basic) | SPM2AVG152T1FrameofReference | SPM2 AVG152T1 Frame of Reference (1.2.840.10008.1.4.1.15)
static (Shared in Visual Basic) | SPM2AVG152T2FrameofReference | SPM2 AVG152T2 Frame of Reference (1.2.840.10008.1.4.1.16)
static (Shared in Visual Basic) | SPM2AVG305T1FrameofReference | SPM2 AVG305T1 Frame of Reference (1.2.840.10008.1.4.1.14)
static (Shared in Visual Basic) | SPM2BRAINMASKFrameofReference | SPM2 BRAINMASK Frame of Reference (1.2.840.10008.1.4.1.13)
static (Shared in Visual Basic) | SPM2CSFFrameofReference | SPM2 CSF Frame of Reference (1.2.840.10008.1.4.1.12)
static (Shared in Visual Basic) | SPM2EPIFrameofReference | SPM2 EPI Frame of Reference (1.2.840.10008.1.4.1.5)
static (Shared in Visual Basic) | SPM2FILT1FrameofReference | SPM2 FIL T1 Frame of Reference (1.2.840.10008.1.4.1.6)
static (Shared in Visual Basic) | SPM2GRAYFrameofReference | SPM2 GRAY Frame of Reference (1.2.840.10008.1.4.1.10)
static (Shared in Visual Basic) | SPM2PDFrameofReference | SPM2 PD Frame of Reference (1.2.840.10008.1.4.1.4)
static (Shared in Visual Basic) | SPM2PETFrameofReference | SPM2 PET Frame of Reference (1.2.840.10008.1.4.1.7)
static (Shared in Visual Basic) | SPM2SINGLESUBJT1FrameofReference | SPM2 SINGLESUBJT1 Frame of Reference (1.2.840.10008.1.4.1.18)
static (Shared in Visual Basic) | SPM2SPECTFrameofReference | SPM2 SPECT Frame of Reference (1.2.840.10008.1.4.1.9)
static (Shared in Visual Basic) | SPM2T1FrameofReference | SPM2 T1 Frame of Reference (1.2.840.10008.1.4.1.2)
static (Shared in Visual Basic) | SPM2T2FrameofReference | SPM2 T2 Frame of Reference (1.2.840.10008.1.4.1.3)
static (Shared in Visual Basic) | SPM2TRANSMFrameofReference | SPM2 TRANSM Frame of Reference (1.2.840.10008.1.4.1.8)
static (Shared in Visual Basic) | SPM2WHITEFrameofReference | SPM2 WHITE Frame of Reference (1.2.840.10008.1.4.1.11)
static (Shared in Visual Basic) | TalairachBrainAtlasFrameofReference | Talairach Brain Atlas Frame of Reference (1.2.840.10008.1.4.1.1)
Top
See Also

Reference

FramesOfReference Class
DicomObjects.DicomUIDs Namespace


FramesOfReference Class Fields

FramesOfReference Class Fields

DicomObjects.DicomUIDs Namespace : FramesOfReference Class

For a list of all members of this type, see FramesOfReference members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | ICBM452T1FrameofReference | ICBM 452 T1 Frame of Reference (1.2.840.10008.1.4.2.1)
static (Shared in Visual Basic) | ICBMSingleSubjectMRIFrameofReference | ICBM Single Subject MRI Frame of Reference (1.2.840.10008.1.4.2.2)
static (Shared in Visual Basic) | SPM2AVG152PDFrameofReference | SPM2 AVG152PD Frame of Reference (1.2.840.10008.1.4.1.17)
static (Shared in Visual Basic) | SPM2AVG152T1FrameofReference | SPM2 AVG152T1 Frame of Reference (1.2.840.10008.1.4.1.15)
static (Shared in Visual Basic) | SPM2AVG152T2FrameofReference | SPM2 AVG152T2 Frame of Reference (1.2.840.10008.1.4.1.16)
static (Shared in Visual Basic) | SPM2AVG305T1FrameofReference | SPM2 AVG305T1 Frame of Reference (1.2.840.10008.1.4.1.14)
static (Shared in Visual Basic) | SPM2BRAINMASKFrameofReference | SPM2 BRAINMASK Frame of Reference (1.2.840.10008.1.4.1.13)
static (Shared in Visual Basic) | SPM2CSFFrameofReference | SPM2 CSF Frame of Reference (1.2.840.10008.1.4.1.12)
static (Shared in Visual Basic) | SPM2EPIFrameofReference | SPM2 EPI Frame of Reference (1.2.840.10008.1.4.1.5)
static (Shared in Visual Basic) | SPM2FILT1FrameofReference | SPM2 FIL T1 Frame of Reference (1.2.840.10008.1.4.1.6)
static (Shared in Visual Basic) | SPM2GRAYFrameofReference | SPM2 GRAY Frame of Reference (1.2.840.10008.1.4.1.10)
static (Shared in Visual Basic) | SPM2PDFrameofReference | SPM2 PD Frame of Reference (1.2.840.10008.1.4.1.4)
static (Shared in Visual Basic) | SPM2PETFrameofReference | SPM2 PET Frame of Reference (1.2.840.10008.1.4.1.7)
static (Shared in Visual Basic) | SPM2SINGLESUBJT1FrameofReference | SPM2 SINGLESUBJT1 Frame of Reference (1.2.840.10008.1.4.1.18)
static (Shared in Visual Basic) | SPM2SPECTFrameofReference | SPM2 SPECT Frame of Reference (1.2.840.10008.1.4.1.9)
static (Shared in Visual Basic) | SPM2T1FrameofReference | SPM2 T1 Frame of Reference (1.2.840.10008.1.4.1.2)
static (Shared in Visual Basic) | SPM2T2FrameofReference | SPM2 T2 Frame of Reference (1.2.840.10008.1.4.1.3)
static (Shared in Visual Basic) | SPM2TRANSMFrameofReference | SPM2 TRANSM Frame of Reference (1.2.840.10008.1.4.1.8)
static (Shared in Visual Basic) | SPM2WHITEFrameofReference | SPM2 WHITE Frame of Reference (1.2.840.10008.1.4.1.11)
static (Shared in Visual Basic) | TalairachBrainAtlasFrameofReference | Talairach Brain Atlas Frame of Reference (1.2.840.10008.1.4.1.1)
Top
See Also

Reference

FramesOfReference Class
DicomObjects.DicomUIDs Namespace


ICBM452T1FrameofReference Field

ICBM452T1FrameofReference Field

DicomObjects.DicomUIDs Namespace > FramesOfReference Class : ICBM452T1FrameofReference Field
ICBM 452 T1 Frame of Reference (1.2.840.10008.1.4.2.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ICBM452T1FrameofReference As UID
'Usage

Dim value As UID

value = FramesOfReference.ICBM452T1FrameofReference
public static readonly UID ICBM452T1FrameofReference
public:
static readonly UID^ ICBM452T1FrameofReference
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FramesOfReference Class
FramesOfReference Members


ICBMSingleSubjectMRIFrameofReference Field

ICBMSingleSubjectMRIFrameofReference Field

DicomObjects.DicomUIDs Namespace > FramesOfReference Class : ICBMSingleSubjectMRIFrameofReference Field
ICBM Single Subject MRI Frame of Reference (1.2.840.10008.1.4.2.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ICBMSingleSubjectMRIFrameofReference As UID
'Usage

Dim value As UID

value = FramesOfReference.ICBMSingleSubjectMRIFrameofReference
public static readonly UID ICBMSingleSubjectMRIFrameofReference
public:
static readonly UID^ ICBMSingleSubjectMRIFrameofReference
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FramesOfReference Class
FramesOfReference Members


SPM2AVG152PDFrameofReference Field

SPM2AVG152PDFrameofReference Field

DicomObjects.DicomUIDs Namespace > FramesOfReference Class : SPM2AVG152PDFrameofReference Field
SPM2 AVG152PD Frame of Reference (1.2.840.10008.1.4.1.17)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SPM2AVG152PDFrameofReference As UID
'Usage

Dim value As UID

value = FramesOfReference.SPM2AVG152PDFrameofReference
public static readonly UID SPM2AVG152PDFrameofReference
public:
static readonly UID^ SPM2AVG152PDFrameofReference
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FramesOfReference Class
FramesOfReference Members


SPM2AVG152T1FrameofReference Field

SPM2AVG152T1FrameofReference Field

DicomObjects.DicomUIDs Namespace > FramesOfReference Class : SPM2AVG152T1FrameofReference Field
SPM2 AVG152T1 Frame of Reference (1.2.840.10008.1.4.1.15)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SPM2AVG152T1FrameofReference As UID
'Usage

Dim value As UID

value = FramesOfReference.SPM2AVG152T1FrameofReference
public static readonly UID SPM2AVG152T1FrameofReference
public:
static readonly UID^ SPM2AVG152T1FrameofReference
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FramesOfReference Class
FramesOfReference Members


SPM2AVG152T2FrameofReference Field

SPM2AVG152T2FrameofReference Field

DicomObjects.DicomUIDs Namespace > FramesOfReference Class : SPM2AVG152T2FrameofReference Field
SPM2 AVG152T2 Frame of Reference (1.2.840.10008.1.4.1.16)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SPM2AVG152T2FrameofReference As UID
'Usage

Dim value As UID

value = FramesOfReference.SPM2AVG152T2FrameofReference
public static readonly UID SPM2AVG152T2FrameofReference
public:
static readonly UID^ SPM2AVG152T2FrameofReference
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FramesOfReference Class
FramesOfReference Members


SPM2AVG305T1FrameofReference Field

SPM2AVG305T1FrameofReference Field

DicomObjects.DicomUIDs Namespace > FramesOfReference Class : SPM2AVG305T1FrameofReference Field
SPM2 AVG305T1 Frame of Reference (1.2.840.10008.1.4.1.14)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SPM2AVG305T1FrameofReference As UID
'Usage

Dim value As UID

value = FramesOfReference.SPM2AVG305T1FrameofReference
public static readonly UID SPM2AVG305T1FrameofReference
public:
static readonly UID^ SPM2AVG305T1FrameofReference
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FramesOfReference Class
FramesOfReference Members


SPM2BRAINMASKFrameofReference Field

SPM2BRAINMASKFrameofReference Field

DicomObjects.DicomUIDs Namespace > FramesOfReference Class : SPM2BRAINMASKFrameofReference Field
SPM2 BRAINMASK Frame of Reference (1.2.840.10008.1.4.1.13)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SPM2BRAINMASKFrameofReference As UID
'Usage

Dim value As UID

value = FramesOfReference.SPM2BRAINMASKFrameofReference
public static readonly UID SPM2BRAINMASKFrameofReference
public:
static readonly UID^ SPM2BRAINMASKFrameofReference
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FramesOfReference Class
FramesOfReference Members


SPM2CSFFrameofReference Field

SPM2CSFFrameofReference Field

DicomObjects.DicomUIDs Namespace > FramesOfReference Class : SPM2CSFFrameofReference Field
SPM2 CSF Frame of Reference (1.2.840.10008.1.4.1.12)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SPM2CSFFrameofReference As UID
'Usage

Dim value As UID

value = FramesOfReference.SPM2CSFFrameofReference
public static readonly UID SPM2CSFFrameofReference
public:
static readonly UID^ SPM2CSFFrameofReference
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FramesOfReference Class
FramesOfReference Members


SPM2EPIFrameofReference Field

SPM2EPIFrameofReference Field

DicomObjects.DicomUIDs Namespace > FramesOfReference Class : SPM2EPIFrameofReference Field
SPM2 EPI Frame of Reference (1.2.840.10008.1.4.1.5)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SPM2EPIFrameofReference As UID
'Usage

Dim value As UID

value = FramesOfReference.SPM2EPIFrameofReference
public static readonly UID SPM2EPIFrameofReference
public:
static readonly UID^ SPM2EPIFrameofReference
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FramesOfReference Class
FramesOfReference Members


SPM2FILT1FrameofReference Field

SPM2FILT1FrameofReference Field

DicomObjects.DicomUIDs Namespace > FramesOfReference Class : SPM2FILT1FrameofReference Field
SPM2 FIL T1 Frame of Reference (1.2.840.10008.1.4.1.6)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SPM2FILT1FrameofReference As UID
'Usage

Dim value As UID

value = FramesOfReference.SPM2FILT1FrameofReference
public static readonly UID SPM2FILT1FrameofReference
public:
static readonly UID^ SPM2FILT1FrameofReference
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FramesOfReference Class
FramesOfReference Members


SPM2GRAYFrameofReference Field

SPM2GRAYFrameofReference Field

DicomObjects.DicomUIDs Namespace > FramesOfReference Class : SPM2GRAYFrameofReference Field
SPM2 GRAY Frame of Reference (1.2.840.10008.1.4.1.10)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SPM2GRAYFrameofReference As UID
'Usage

Dim value As UID

value = FramesOfReference.SPM2GRAYFrameofReference
public static readonly UID SPM2GRAYFrameofReference
public:
static readonly UID^ SPM2GRAYFrameofReference
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FramesOfReference Class
FramesOfReference Members


SPM2PDFrameofReference Field

SPM2PDFrameofReference Field

DicomObjects.DicomUIDs Namespace > FramesOfReference Class : SPM2PDFrameofReference Field
SPM2 PD Frame of Reference (1.2.840.10008.1.4.1.4)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SPM2PDFrameofReference As UID
'Usage

Dim value As UID

value = FramesOfReference.SPM2PDFrameofReference
public static readonly UID SPM2PDFrameofReference
public:
static readonly UID^ SPM2PDFrameofReference
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FramesOfReference Class
FramesOfReference Members


SPM2PETFrameofReference Field

SPM2PETFrameofReference Field

DicomObjects.DicomUIDs Namespace > FramesOfReference Class : SPM2PETFrameofReference Field
SPM2 PET Frame of Reference (1.2.840.10008.1.4.1.7)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SPM2PETFrameofReference As UID
'Usage

Dim value As UID

value = FramesOfReference.SPM2PETFrameofReference
public static readonly UID SPM2PETFrameofReference
public:
static readonly UID^ SPM2PETFrameofReference
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FramesOfReference Class
FramesOfReference Members


SPM2SINGLESUBJT1FrameofReference Field

SPM2SINGLESUBJT1FrameofReference Field

DicomObjects.DicomUIDs Namespace > FramesOfReference Class : SPM2SINGLESUBJT1FrameofReference Field
SPM2 SINGLESUBJT1 Frame of Reference (1.2.840.10008.1.4.1.18)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SPM2SINGLESUBJT1FrameofReference As UID
'Usage

Dim value As UID

value = FramesOfReference.SPM2SINGLESUBJT1FrameofReference
public static readonly UID SPM2SINGLESUBJT1FrameofReference
public:
static readonly UID^ SPM2SINGLESUBJT1FrameofReference
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FramesOfReference Class
FramesOfReference Members


SPM2SPECTFrameofReference Field

SPM2SPECTFrameofReference Field

DicomObjects.DicomUIDs Namespace > FramesOfReference Class : SPM2SPECTFrameofReference Field
SPM2 SPECT Frame of Reference (1.2.840.10008.1.4.1.9)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SPM2SPECTFrameofReference As UID
'Usage

Dim value As UID

value = FramesOfReference.SPM2SPECTFrameofReference
public static readonly UID SPM2SPECTFrameofReference
public:
static readonly UID^ SPM2SPECTFrameofReference
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FramesOfReference Class
FramesOfReference Members


SPM2T1FrameofReference Field

SPM2T1FrameofReference Field

DicomObjects.DicomUIDs Namespace > FramesOfReference Class : SPM2T1FrameofReference Field
SPM2 T1 Frame of Reference (1.2.840.10008.1.4.1.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SPM2T1FrameofReference As UID
'Usage

Dim value As UID

value = FramesOfReference.SPM2T1FrameofReference
public static readonly UID SPM2T1FrameofReference
public:
static readonly UID^ SPM2T1FrameofReference
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FramesOfReference Class
FramesOfReference Members


SPM2T2FrameofReference Field

SPM2T2FrameofReference Field

DicomObjects.DicomUIDs Namespace > FramesOfReference Class : SPM2T2FrameofReference Field
SPM2 T2 Frame of Reference (1.2.840.10008.1.4.1.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SPM2T2FrameofReference As UID
'Usage

Dim value As UID

value = FramesOfReference.SPM2T2FrameofReference
public static readonly UID SPM2T2FrameofReference
public:
static readonly UID^ SPM2T2FrameofReference
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FramesOfReference Class
FramesOfReference Members


SPM2TRANSMFrameofReference Field

SPM2TRANSMFrameofReference Field

DicomObjects.DicomUIDs Namespace > FramesOfReference Class : SPM2TRANSMFrameofReference Field
SPM2 TRANSM Frame of Reference (1.2.840.10008.1.4.1.8)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SPM2TRANSMFrameofReference As UID
'Usage

Dim value As UID

value = FramesOfReference.SPM2TRANSMFrameofReference
public static readonly UID SPM2TRANSMFrameofReference
public:
static readonly UID^ SPM2TRANSMFrameofReference
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FramesOfReference Class
FramesOfReference Members


SPM2WHITEFrameofReference Field

SPM2WHITEFrameofReference Field

DicomObjects.DicomUIDs Namespace > FramesOfReference Class : SPM2WHITEFrameofReference Field
SPM2 WHITE Frame of Reference (1.2.840.10008.1.4.1.11)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SPM2WHITEFrameofReference As UID
'Usage

Dim value As UID

value = FramesOfReference.SPM2WHITEFrameofReference
public static readonly UID SPM2WHITEFrameofReference
public:
static readonly UID^ SPM2WHITEFrameofReference
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FramesOfReference Class
FramesOfReference Members


TalairachBrainAtlasFrameofReference Field

TalairachBrainAtlasFrameofReference Field

DicomObjects.DicomUIDs Namespace > FramesOfReference Class : TalairachBrainAtlasFrameofReference Field
Talairach Brain Atlas Frame of Reference (1.2.840.10008.1.4.1.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly TalairachBrainAtlasFrameofReference As UID
'Usage

Dim value As UID

value = FramesOfReference.TalairachBrainAtlasFrameofReference
public static readonly UID TalairachBrainAtlasFrameofReference
public:
static readonly UID^ TalairachBrainAtlasFrameofReference
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

FramesOfReference Class
FramesOfReference Members


MetaSOPClasses Class

MetaSOPClasses Class
Members

DicomObjects.DicomUIDs Namespace : MetaSOPClasses Class
Contains UIDs for Meta SOP Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit NotInheritable Class MetaSOPClasses
'Usage

Dim instance As MetaSOPClasses
public static class MetaSOPClasses
public ref class MetaSOPClasses abstract sealed
Inheritance Hierarchy

System.Object
DicomObjects.DicomUIDs.MetaSOPClasses

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

MetaSOPClasses Members
DicomObjects.DicomUIDs Namespace


MetaSOPClasses Class Members

MetaSOPClasses Class Members
Fields

DicomObjects.DicomUIDs Namespace : MetaSOPClasses Class

The following tables list the members exposed by MetaSOPClasses.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | BasicColorPrint | Basic Color Print Management Meta SOP Class (1.2.840.10008.5.1.1.18)
static (Shared in Visual Basic) | BasicGrayscalePrint | Basic Grayscale Print Management Meta SOP Class (1.2.840.10008.5.1.1.9)
static (Shared in Visual Basic) | GeneralPurposeWorklist | General Purpose Worklist Management Meta SOP Class (1.2.840.10008.5.1.4.32)
Top
See Also

Reference

MetaSOPClasses Class
DicomObjects.DicomUIDs Namespace


MetaSOPClasses Class Fields

MetaSOPClasses Class Fields

DicomObjects.DicomUIDs Namespace : MetaSOPClasses Class

For a list of all members of this type, see MetaSOPClasses members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | BasicColorPrint | Basic Color Print Management Meta SOP Class (1.2.840.10008.5.1.1.18)
static (Shared in Visual Basic) | BasicGrayscalePrint | Basic Grayscale Print Management Meta SOP Class (1.2.840.10008.5.1.1.9)
static (Shared in Visual Basic) | GeneralPurposeWorklist | General Purpose Worklist Management Meta SOP Class (1.2.840.10008.5.1.4.32)
Top
See Also

Reference

MetaSOPClasses Class
DicomObjects.DicomUIDs Namespace


BasicColorPrint Field

BasicColorPrint Field

DicomObjects.DicomUIDs Namespace > MetaSOPClasses Class : BasicColorPrint Field
Basic Color Print Management Meta SOP Class (1.2.840.10008.5.1.1.18)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly BasicColorPrint As UID
'Usage

Dim value As UID

value = MetaSOPClasses.BasicColorPrint
public static readonly UID BasicColorPrint
public:
static readonly UID^ BasicColorPrint
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

MetaSOPClasses Class
MetaSOPClasses Members


BasicGrayscalePrint Field

BasicGrayscalePrint Field

DicomObjects.DicomUIDs Namespace > MetaSOPClasses Class : BasicGrayscalePrint Field
Basic Grayscale Print Management Meta SOP Class (1.2.840.10008.5.1.1.9)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly BasicGrayscalePrint As UID
'Usage

Dim value As UID

value = MetaSOPClasses.BasicGrayscalePrint
public static readonly UID BasicGrayscalePrint
public:
static readonly UID^ BasicGrayscalePrint
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

MetaSOPClasses Class
MetaSOPClasses Members


GeneralPurposeWorklist Field

GeneralPurposeWorklist Field

DicomObjects.DicomUIDs Namespace > MetaSOPClasses Class : GeneralPurposeWorklist Field
General Purpose Worklist Management Meta SOP Class (1.2.840.10008.5.1.4.32)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly GeneralPurposeWorklist As UID
'Usage

Dim value As UID

value = MetaSOPClasses.GeneralPurposeWorklist
public static readonly UID GeneralPurposeWorklist
public:
static readonly UID^ GeneralPurposeWorklist
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

MetaSOPClasses Class
MetaSOPClasses Members


SOPClasses Class

SOPClasses Class
Members

DicomObjects.DicomUIDs Namespace : SOPClasses Class
Contains UIDs for SOP Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit NotInheritable Class SOPClasses
'Usage

Dim instance As SOPClasses
public static class SOPClasses
public ref class SOPClasses abstract sealed
Remarks
Contains a full list of all DICOM SOP Class UIDs.
Inheritance Hierarchy

System.Object
DicomObjects.DicomUIDs.SOPClasses

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Members
DicomObjects.DicomUIDs Namespace


SOPClasses Class Members

SOPClasses Class Members
Fields

DicomObjects.DicomUIDs Namespace : SOPClasses Class

The following tables list the members exposed by SOPClasses.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | AmbulatoryECGWaveform | Ambulatory ECG Waveform Storage (1.2.840.10008.5.1.4.1.1.9.1.3)
static (Shared in Visual Basic) | ArterialPulseWaveform | Arterial Pulse Waveform Storage (1.2.840.10008.5.1.4.1.1.9.5.1)
static (Shared in Visual Basic) | AutorefractionMeasurements | Autorefraction Measurements Storage (1.2.840.10008.5.1.4.1.1.78.2)
static (Shared in Visual Basic) | BasicAnnotationBox | Basic Annotation Box SOP Class (1.2.840.10008.5.1.1.15)
static (Shared in Visual Basic) | BasicColorImageBox | Basic Color Image Box SOP Class (1.2.840.10008.5.1.1.4.1)
static (Shared in Visual Basic) | BasicFilmBox | Basic Film Box SOP Class (1.2.840.10008.5.1.1.2)
static (Shared in Visual Basic) | BasicFilmSession | Basic Film Session SOP Class (1.2.840.10008.5.1.1.1)
static (Shared in Visual Basic) | BasicGrayscaleImageBox | Basic Grayscale Image Box SOP Class (1.2.840.10008.5.1.1.4)
static (Shared in Visual Basic) | BasicStructuredDisplay | Basic Structured Display Storage (1.2.840.10008.5.1.4.1.1.131)
static (Shared in Visual Basic) | BasicTextSR | Basic Text SR Storage (1.2.840.10008.5.1.4.1.1.88.11)
static (Shared in Visual Basic) | BasicVoiceAudioWaveform | Basic Voice Audio Waveform Storage (1.2.840.10008.5.1.4.1.1.9.4.1)
static (Shared in Visual Basic) | BlendingSoftcopyPresentationState | Blending Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.4)
static (Shared in Visual Basic) | BreastImagingRelevantPatientInformationQuery | Breast Imaging Relevant Patient Information Query (1.2.840.10008.5.1.4.37.2)
static (Shared in Visual Basic) | BreastTomosynthesisImage | Breast Tomosynthesis Image Storage (1.2.840.10008.5.1.4.1.1.13.1.3)
static (Shared in Visual Basic) | CardiacElectrophysiologyWaveform | Cardiac Electrophysiology Waveform Storage (1.2.840.10008.5.1.4.1.1.9.3.1)
static (Shared in Visual Basic) | CardiacRelevantPatientInformationQuery | Cardiac Relevant Patient Information Query (1.2.840.10008.5.1.4.37.3)
static (Shared in Visual Basic) | ChestCADSR | Chest CAD SR Storage (1.2.840.10008.5.1.4.1.1.88.65)
static (Shared in Visual Basic) | ColonCADSR | Colon CAD SR Storage (1.2.840.10008.5.1.4.1.1.88.69)
static (Shared in Visual Basic) | ColorPalette | Color Palette Storage (1.2.840.10008.5.1.4.39.1)
static (Shared in Visual Basic) | ColorPaletteQRFIND | Color Palette Information Model - FIND (1.2.840.10008.5.1.4.39.2)
static (Shared in Visual Basic) | ColorPaletteQRGET | Color Palette Information Model - GET (1.2.840.10008.5.1.4.39.4)
static (Shared in Visual Basic) | ColorPaletteQRMOVE | Color Palette Information Model - MOVE (1.2.840.10008.5.1.4.39.3)
static (Shared in Visual Basic) | ColorSoftcopyPresentationState | Color Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.2)
static (Shared in Visual Basic) | CompositeInstanceRootRetrieve_GET | Composite Instance Root Retrieve - GET (1.2.840.10008.5.1.4.1.2.4.3)
static (Shared in Visual Basic) | CompositeInstanceRootRetrieve_MOVE | Composite Instance Root Retrieve - MOVE (1.2.840.10008.5.1.4.1.2.4.2)
static (Shared in Visual Basic) | CompositeInstanceRootRetrieveWithoutBulkData_GET | Composite Instance Retrieve Without Bulk Data - GET (1.2.840.10008.5.1.4.1.2.5.3)
static (Shared in Visual Basic) | ComprehensiveSR | Comprehensive SR Storage (1.2.840.10008.5.1.4.1.1.88.33)
static (Shared in Visual Basic) | ComputedRadiography | Computed Radiography Image Storage (1.2.840.10008.5.1.4.1.1.1)
static (Shared in Visual Basic) | CornealTopographyMap | Corneal Topography Map Storage (1.2.840.10008.5.1.4.1.1.82.1)
static (Shared in Visual Basic) | CT | CT Image Storage (1.2.840.10008.5.1.4.1.1.2)
static (Shared in Visual Basic) | DeformableSpatialRegistration | Deformable Spatial Registration Storage (1.2.840.10008.5.1.4.1.1.66.3)
static (Shared in Visual Basic) | DICOSCTImage | DICOS CT Image Storage (1.2.840.10008.5.1.4.1.1.501.1)
static (Shared in Visual Basic) | DICOSDigitalXRayImageForPresentation | DICOS Digital X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.501.2.1)
static (Shared in Visual Basic) | DICOSDigitalXRayImageForProcessing | DICOS Digital X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.501.2.2)
static (Shared in Visual Basic) | DICOSThreatDetectionReport | DICOS Threat Detection Report Storage (1.2.840.10008.5.1.4.1.1.501.3)
static (Shared in Visual Basic) | DigitalIntraoralXRay_Presentation | Digital Intra-oral X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.1.3)
static (Shared in Visual Basic) | DigitalIntraoralXRay_Processing | Digital Intra-oral X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.1.3.1)
static (Shared in Visual Basic) | DigitalMammographyXRay_Presentation | Digital Mammography X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.1.2)
static (Shared in Visual Basic) | DigitalMammographyXRay_Processing | Digital Mammography X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.1.2.1)
static (Shared in Visual Basic) | DigitalXRay_Presentation | Digital X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.1.1)
static (Shared in Visual Basic) | DigitalXRay_Processing | Digital X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.1.1.1)
static (Shared in Visual Basic) | EddyCurrentImage | Eddy Current Image Storage (1.2.840.10008.5.1.4.1.1.601.1)
static (Shared in Visual Basic) | EddyCurrentMultiframeImage | Eddy Current Multi-frame Image Storage (1.2.840.10008.5.1.4.1.1.601.2)
static (Shared in Visual Basic) | EncapsulatedCDA | Encapsulated CDA Storage (1.2.840.10008.5.1.4.1.1.104.2)
static (Shared in Visual Basic) | EncapsulatedPDF | Encapsulated PDF Storage (1.2.840.10008.5.1.4.1.1.104.1)
static (Shared in Visual Basic) | EncapsulatedSTL | Encapsulated STL Storage (1.2.840.10008.5.1.4.1.1.104.3)
static (Shared in Visual Basic) | EnhancedCT | Enhanced CT Image Storage (1.2.840.10008.5.1.4.1.1.2.1)
static (Shared in Visual Basic) | EnhancedMR | Enhanced MR Image Storage (1.2.840.10008.5.1.4.1.1.4.1)
static (Shared in Visual Basic) | EnhancedMRColorImage | Enhanced MR Color Image Storage (1.2.840.10008.5.1.4.1.1.4.3)
static (Shared in Visual Basic) | EnhancedPETImage | Enhanced PET Image Storage (1.2.840.10008.5.1.4.1.1.130)
static (Shared in Visual Basic) | EnhancedSR | Enhanced SR Storage (1.2.840.10008.5.1.4.1.1.88.22)
static (Shared in Visual Basic) | EnhancedUSVolume | Enhanced US Volume Storage (1.2.840.10008.5.1.4.1.1.6.2)
static (Shared in Visual Basic) | EnhancedXAImage | Enhanced XA Image Storage (1.2.840.10008.5.1.4.1.1.12.1.1)
static (Shared in Visual Basic) | EnhancedXRFImage | Enhanced XRF Image Storage (1.2.840.10008.5.1.4.1.1.12.2.1)
static (Shared in Visual Basic) | GeneralAudioWaveform | General Audio Waveform Storage (1.2.840.10008.5.1.4.1.1.9.4.2)
static (Shared in Visual Basic) | GeneralECGWaveform | General ECG Waveform Storage (1.2.840.10008.5.1.4.1.1.9.1.2)
static (Shared in Visual Basic) | GeneralPurposePerformedProcedureStep | General Purpose Performed Procedure Step SOP Class (1.2.840.10008.5.1.4.32.3)
static (Shared in Visual Basic) | GeneralPurposeScheduledProcedureStep | General Purpose Scheduled Procedure Step SOP Class (1.2.840.10008.5.1.4.32.2)
static (Shared in Visual Basic) | GeneralPurposeWorklistQRFIND | General Purpose Worklist Information Model - FIND (1.2.840.10008.5.1.4.32.1)
static (Shared in Visual Basic) | GeneralRelevantPatientInformationQuery | General Relevant Patient Information Query (1.2.840.10008.5.1.4.37.1)
static (Shared in Visual Basic) | GenericImplantTemplate | Generic Implant Template Storage (1.2.840.10008.5.1.4.43.1)
static (Shared in Visual Basic) | GenericImplantTemplateQRFIND | Generic Implant Template Information Model - FIND (1.2.840.10008.5.1.4.43.2)
static (Shared in Visual Basic) | GenericImplantTemplateQRGET | Generic Implant Template Information Model - GET (1.2.840.10008.5.1.4.43.4)
static (Shared in Visual Basic) | GenericImplantTemplateQRMOVE | Generic Implant Template Information Model - MOVE (1.2.840.10008.5.1.4.43.3)
static (Shared in Visual Basic) | GrayscaleSoftcopyPresentationState | Grayscale Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.1)
static (Shared in Visual Basic) | HangingProtocol | Hanging Protocol Storage (1.2.840.10008.5.1.4.38.1)
static (Shared in Visual Basic) | HangingProtocolQRFIND | Hanging Protocol Information Model - FIND (1.2.840.10008.5.1.4.38.2)
static (Shared in Visual Basic) | HangingProtocolQRGET | Hanging Protocol Information Model - GET (1.2.840.10008.5.1.4.38.4)
static (Shared in Visual Basic) | HangingProtocolQRMOVE | Hanging Protocol Information Model - MOVE (1.2.840.10008.5.1.4.38.3)
static (Shared in Visual Basic) | HemodynamicWaveform | Hemodynamic Waveform Storage (1.2.840.10008.5.1.4.1.1.9.2.1)
static (Shared in Visual Basic) | ImplantAssemblyTemplate | Implant Assembly Template Storage (1.2.840.10008.5.1.4.44.1)
static (Shared in Visual Basic) | ImplantAssemblyTemplateQRFIND | Implant Assembly Template Information Model - FIND (1.2.840.10008.5.1.4.44.2)
static (Shared in Visual Basic) | ImplantAssemblyTemplateQRGET | Implant Assembly Template Information Model - GET (1.2.840.10008.5.1.4.44.4)
static (Shared in Visual Basic) | ImplantAssemblyTemplateQRMOVE | Implant Assembly Template Information Model - MOVE (1.2.840.10008.5.1.4.44.3)
static (Shared in Visual Basic) | ImplantationPlanSR | Implantation Plan SR Storage (1.2.840.10008.5.1.4.1.1.88.70)
static (Shared in Visual Basic) | ImplantTemplateGroup | Implant Template Group Storage (1.2.840.10008.5.1.4.45.1)
static (Shared in Visual Basic) | ImplantTemplateGroupQRFIND | Implant Template Group Information Model - FIND (1.2.840.10008.5.1.4.45.2)
static (Shared in Visual Basic) | ImplantTemplateGroupQRGET | Implant Template Group Information Model - GET (1.2.840.10008.5.1.4.45.4)
static (Shared in Visual Basic) | ImplantTemplateGroupQRMOVE | Implant Template Group Information Model - MOVE (1.2.840.10008.5.1.4.45.3)
static (Shared in Visual Basic) | InstanceAvailabilityNotification | Instance Availability Notification SOP Class (1.2.840.10008.5.1.4.33)
static (Shared in Visual Basic) | IntraocularLensCalculations | Intraocular Lens Calculations Storage (1.2.840.10008.5.1.4.1.1.78.8)
static (Shared in Visual Basic) | IntravascularOpticalCoherenceTomographyImageForPresentation | Intravascular Optical Coherence Tomography Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.14.1)
static (Shared in Visual Basic) | IntravascularOpticalCoherenceTomographyImageForProcessing | Intravascular Optical Coherence Tomography Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.14.2)
static (Shared in Visual Basic) | KeratometryMeasurements | Keratometry Measurements Storage (1.2.840.10008.5.1.4.1.1.78.3)
static (Shared in Visual Basic) | KeyObjectSelectionDocument | Key Object Selection Document Storage (1.2.840.10008.5.1.4.1.1.88.59)
static (Shared in Visual Basic) | LegacyConvertedEnhancedCT | Legacy Converted Enhanced CT Image Storage (1.2.840.10008.5.1.4.1.1.2.2)
static (Shared in Visual Basic) | LegacyConvertedEnhancedMRColorImage | Legacy Converted Enhanced MR Image Storage (1.2.840.10008.5.1.4.1.1.4.4)
static (Shared in Visual Basic) | LegacyConvertedEnhancedPETImage | Legacy Converted Enhanced PET Image Storage (1.2.840.10008.5.1.4.1.1.128.1)
static (Shared in Visual Basic) | LensometryMeasurements | Lensometry Measurements Storage (1.2.840.10008.5.1.4.1.1.78.1)
static (Shared in Visual Basic) | MacularGridThicknessandVolumeReport | Macular Grid Thickness and Volume Report Storage (1.2.840.10008.5.1.4.1.1.79.1)
static (Shared in Visual Basic) | MammographyCADSR | Mammography CAD SR Storage (1.2.840.10008.5.1.4.1.1.88.50)
static (Shared in Visual Basic) | MediaCreationManagementUID | Media Creation Management SOP Class UID (1.2.840.10008.5.1.1.33)
static (Shared in Visual Basic) | MediaStorageDirectory | Media Storage Directory Storage (1.2.840.10008.1.3.10)
static (Shared in Visual Basic) | ModalityPerformedProcedureStep | Modality Performed Procedure Step SOP Class (1.2.840.10008.3.1.2.3.3)
static (Shared in Visual Basic) | ModalityPerformedProcedureStepNotification | Modality Performed Procedure Step Notification SOP Class (1.2.840.10008.3.1.2.3.5)
static (Shared in Visual Basic) | ModalityPerformedProcedureStepRetrieve | Modality Performed Procedure Step Retrieve SOP Class (1.2.840.10008.3.1.2.3.4)
static (Shared in Visual Basic) | ModalityWorklistQRFIND | Modality Worklist Information Model - FIND (1.2.840.10008.5.1.4.31)
static (Shared in Visual Basic) | MR | MR Image Storage (1.2.840.10008.5.1.4.1.1.4)
static (Shared in Visual Basic) | MRSpectroscopy | MR Spectroscopy Storage (1.2.840.10008.5.1.4.1.1.4.2)
static (Shared in Visual Basic) | MultiFrameGrayscaleByteSC | Multi-frame Grayscale Byte Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.2)
static (Shared in Visual Basic) | MultiFrameGrayscaleWordSC | Multi-frame Grayscale Word Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.3)
static (Shared in Visual Basic) | MultiFrameSingleBitSC | Multi-frame Single Bit Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.1)
static (Shared in Visual Basic) | MultiFrameTrueColorSC | Multi-frame True Color Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.4)
static (Shared in Visual Basic) | NuclearMedicine | Nuclear Medicine Image Storage (1.2.840.10008.5.1.4.1.1.20)
static (Shared in Visual Basic) | OphthalmicAxialMeasurements | Ophthalmic Axial Measurements Storage (1.2.840.10008.5.1.4.1.1.78.7)
static (Shared in Visual Basic) | OphthalmicPhotography16Bit | Ophthalmic Photography 16 Bit Image Storage (1.2.840.10008.5.1.4.1.1.77.1.5.2)
static (Shared in Visual Basic) | OphthalmicPhotography8Bit | Ophthalmic Photography 8 Bit Image Storage (1.2.840.10008.5.1.4.1.1.77.1.5.1)
static (Shared in Visual Basic) | OphthalmicThicknessMap | Ophthalmic Thickness Map Storage (1.2.840.10008.5.1.4.1.1.81.1)
static (Shared in Visual Basic) | OphthalmicTomographyImage | Ophthalmic Tomography Image Storage (1.2.840.10008.5.1.4.1.1.77.1.5.4)
static (Shared in Visual Basic) | OphthalmicVisualFieldStaticPerimetryMeasurements | Ophthalmic Visual Field Static Perimetry Measurements Storage (1.2.840.10008.5.1.4.1.1.80.1)
static (Shared in Visual Basic) | PatientRootQR_FIND | Patient Root Query/Retrieve Information Model - FIND (1.2.840.10008.5.1.4.1.2.1.1)
static (Shared in Visual Basic) | PatientRootQR_GET | Patient Root Query/Retrieve Information Model - GET (1.2.840.10008.5.1.4.1.2.1.3)
static (Shared in Visual Basic) | PatientRootQR_MOVE | Patient Root Query/Retrieve Information Model - MOVE (1.2.840.10008.5.1.4.1.2.1.2)
static (Shared in Visual Basic) | PositronEmissionTomography | Positron Emission Tomography Image Storage (1.2.840.10008.5.1.4.1.1.128)
static (Shared in Visual Basic) | PresentationLUT | Presentation LUT SOP Class (1.2.840.10008.5.1.1.23)
static (Shared in Visual Basic) | Printer | Printer SOP Class (1.2.840.10008.5.1.1.16)
static (Shared in Visual Basic) | PrinterConfigurationRetrieval | Printer Configuration Retrieval SOP Class (1.2.840.10008.5.1.1.16.376)
static (Shared in Visual Basic) | PrintJob | Print Job SOP Class (1.2.840.10008.5.1.1.14)
static (Shared in Visual Basic) | ProceduralEventLogging | Procedural Event Logging SOP Class (1.2.840.10008.1.40)
static (Shared in Visual Basic) | ProcedureLog | Procedure Log Storage (1.2.840.10008.5.1.4.1.1.88.40)
static (Shared in Visual Basic) | ProductCharacteristicsQuery | Product Characteristics Query SOP Class (1.2.840.10008.5.1.4.41)
static (Shared in Visual Basic) | PseudoColorSoftcopyPresentationState | Pseudo-Color Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.3)
static (Shared in Visual Basic) | RawData | Raw Data Storage (1.2.840.10008.5.1.4.1.1.66)
static (Shared in Visual Basic) | RealWorldValueMapping | Real World Value Mapping Storage (1.2.840.10008.5.1.4.1.1.67)
static (Shared in Visual Basic) | RespiratoryWaveform | Respiratory Waveform Storage (1.2.840.10008.5.1.4.1.1.9.6.1)
static (Shared in Visual Basic) | RT | RT Image Storage (1.2.840.10008.5.1.4.1.1.481.1)
static (Shared in Visual Basic) | RTBeamsDeliveryInstruction | RT Beams Delivery Instruction Storage (1.2.840.10008.5.1.4.34.7)
static (Shared in Visual Basic) | RTBeamsTreatmentRecord | RT Beams Treatment Record Storage (1.2.840.10008.5.1.4.1.1.481.4)
static (Shared in Visual Basic) | RTBrachyTreatmentRecord | RT Brachy Treatment Record Storage (1.2.840.10008.5.1.4.1.1.481.6)
static (Shared in Visual Basic) | RTConventionalMachineVerification | RT Conventional Machine Verification (1.2.840.10008.5.1.4.34.8)
static (Shared in Visual Basic) | RTDose | RT Dose Storage (1.2.840.10008.5.1.4.1.1.481.2)
static (Shared in Visual Basic) | RTIonBeamsTreatmentRecord | RT Ion Beams Treatment Record Storage (1.2.840.10008.5.1.4.1.1.481.9)
static (Shared in Visual Basic) | RTIonMachineVerification | RT Ion Machine Verification (1.2.840.10008.5.1.4.34.9)
static (Shared in Visual Basic) | RTIonPlan | RT Ion Plan Storage (1.2.840.10008.5.1.4.1.1.481.8)
static (Shared in Visual Basic) | RTPlan | RT Plan Storage (1.2.840.10008.5.1.4.1.1.481.5)
static (Shared in Visual Basic) | RTStructureSet | RT Structure Set Storage (1.2.840.10008.5.1.4.1.1.481.3)
static (Shared in Visual Basic) | RTTreatmentSummaryRecord | RT Treatment Summary Record Storage (1.2.840.10008.5.1.4.1.1.481.7)
static (Shared in Visual Basic) | SecondaryCapture | Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7)
static (Shared in Visual Basic) | Segmentation | Segmentation Storage (1.2.840.10008.5.1.4.1.1.66.4)
static (Shared in Visual Basic) | SpatialFiducials | Spatial Fiducials Storage (1.2.840.10008.5.1.4.1.1.66.2)
static (Shared in Visual Basic) | SpatialRegistration | Spatial Registration Storage (1.2.840.10008.5.1.4.1.1.66.1)
static (Shared in Visual Basic) | SpectaclePrescriptionReport | Spectacle Prescription Report Storage (1.2.840.10008.5.1.4.1.1.78.6)
static (Shared in Visual Basic) | StereometricRelationship | Stereometric Relationship Storage (1.2.840.10008.5.1.4.1.1.77.1.5.3)
static (Shared in Visual Basic) | StorageCommitmentPush | Storage Commitment Push Model SOP Class (1.2.840.10008.1.20.1)
static (Shared in Visual Basic) | StorageServiceClass | Storage Service Class (1.2.840.10008.4.2)
static (Shared in Visual Basic) | StudyRootQR_FIND | Study Root Query/Retrieve Information Model - FIND (1.2.840.10008.5.1.4.1.2.2.1)
static (Shared in Visual Basic) | StudyRootQR_GET | Study Root Query/Retrieve Information Model - GET (1.2.840.10008.5.1.4.1.2.2.3)
static (Shared in Visual Basic) | StudyRootQR_MOVE | Study Root Query/Retrieve Information Model - MOVE (1.2.840.10008.5.1.4.1.2.2.2)
static (Shared in Visual Basic) | SubjectiveRefractionMeasurements | Subjective Refraction Measurements Storage (1.2.840.10008.5.1.4.1.1.78.4)
static (Shared in Visual Basic) | SubstanceAdministrationLogging | Substance Administration Logging SOP Class (1.2.840.10008.1.42)
static (Shared in Visual Basic) | SubstanceApprovalQuery | Substance Approval Query SOP Class (1.2.840.10008.5.1.4.42)
static (Shared in Visual Basic) | SurfaceSegmentation | Surface Segmentation Storage (1.2.840.10008.5.1.4.1.1.66.5)
static (Shared in Visual Basic) | TwelveLeadECGWaveform | 12-lead ECG Waveform Storage (1.2.840.10008.5.1.4.1.1.9.1.1)
static (Shared in Visual Basic) | Ultrasound | Ultrasound Image Storage (1.2.840.10008.5.1.4.1.1.6.1)
static (Shared in Visual Basic) | UltrasoundMultiframe | Ultrasound Multi-frame Image Storage (1.2.840.10008.5.1.4.1.1.3.1)
static (Shared in Visual Basic) | UnifiedProcedureStepEvent | Unified Procedure Step - Event SOP Class (1.2.840.10008.5.1.4.34.6.4)
static (Shared in Visual Basic) | UnifiedProcedureStepPull | Unified Procedure Step - Pull SOP Class (1.2.840.10008.5.1.4.34.6.3)
static (Shared in Visual Basic) | UnifiedProcedureStepPush | Unified Procedure Step - Push SOP Class (1.2.840.10008.5.1.4.34.6.1)
static (Shared in Visual Basic) | UnifiedProcedureStepWatch | Unified Procedure Step - Watch SOP Class (1.2.840.10008.5.1.4.34.6.2)
static (Shared in Visual Basic) | UnifiedWorklistandProcedureStepServiceClass | Unified Worklist and Procedure Step Service Class (1.2.840.10008.5.1.4.34.6)
static (Shared in Visual Basic) | Verification | Verification SOP Class (1.2.840.10008.1.1)
static (Shared in Visual Basic) | VideoEndoscopic | Video Endoscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.1.1)
static (Shared in Visual Basic) | VideoMicroscopic | Video Microscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.2.1)
static (Shared in Visual Basic) | VideoPhotographic | Video Photographic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.4.1)
static (Shared in Visual Basic) | VisualAcuityMeasurements | Visual Acuity Measurements Storage (1.2.840.10008.5.1.4.1.1.78.5)
static (Shared in Visual Basic) | VLEndoscopic | VL Endoscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.1)
static (Shared in Visual Basic) | VLMicroscopic | VL Microscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.2)
static (Shared in Visual Basic) | VLPhotographic | VL Photographic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.4)
static (Shared in Visual Basic) | VLSlideCoordinatesMicroscopic | VL Slide-Coordinates Microscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.3)
static (Shared in Visual Basic) | VLWholeSlideMicroscopyImage | VL Whole Slide Microscopy Image Storage (1.2.840.10008.5.1.4.1.1.77.1.6)
static (Shared in Visual Basic) | VOILUTBox | VOI LUT Box SOP Class (1.2.840.10008.5.1.1.22)
static (Shared in Visual Basic) | XA_XRFGrayscaleSoftcopyPresentationState | XA/XRF Grayscale Softcopy Presentation State Storage (1.2.840.10008.5.1.4.1.1.11.5)
static (Shared in Visual Basic) | XRay3DAngiographicImage | X-Ray 3D Angiographic Image Storage (1.2.840.10008.5.1.4.1.1.13.1.1)
static (Shared in Visual Basic) | XRay3DCraniofacialImage | X-Ray 3D Craniofacial Image Storage (1.2.840.10008.5.1.4.1.1.13.1.2)
static (Shared in Visual Basic) | XRayAngiographic | X-Ray Angiographic Image Storage (1.2.840.10008.5.1.4.1.1.12.1)
static (Shared in Visual Basic) | XRayRadiationDoseSR | X-Ray Radiation Dose SR Storage (1.2.840.10008.5.1.4.1.1.88.67)
static (Shared in Visual Basic) | XRayRadiofluoroscopic | X-Ray Radiofluoroscopic Image Storage (1.2.840.10008.5.1.4.1.1.12.2)
Top
See Also

Reference

SOPClasses Class
DicomObjects.DicomUIDs Namespace


SOPClasses Class Fields

SOPClasses Class Fields

DicomObjects.DicomUIDs Namespace : SOPClasses Class

For a list of all members of this type, see SOPClasses members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | AmbulatoryECGWaveform | Ambulatory ECG Waveform Storage (1.2.840.10008.5.1.4.1.1.9.1.3)
static (Shared in Visual Basic) | ArterialPulseWaveform | Arterial Pulse Waveform Storage (1.2.840.10008.5.1.4.1.1.9.5.1)
static (Shared in Visual Basic) | AutorefractionMeasurements | Autorefraction Measurements Storage (1.2.840.10008.5.1.4.1.1.78.2)
static (Shared in Visual Basic) | BasicAnnotationBox | Basic Annotation Box SOP Class (1.2.840.10008.5.1.1.15)
static (Shared in Visual Basic) | BasicColorImageBox | Basic Color Image Box SOP Class (1.2.840.10008.5.1.1.4.1)
static (Shared in Visual Basic) | BasicFilmBox | Basic Film Box SOP Class (1.2.840.10008.5.1.1.2)
static (Shared in Visual Basic) | BasicFilmSession | Basic Film Session SOP Class (1.2.840.10008.5.1.1.1)
static (Shared in Visual Basic) | BasicGrayscaleImageBox | Basic Grayscale Image Box SOP Class (1.2.840.10008.5.1.1.4)
static (Shared in Visual Basic) | BasicStructuredDisplay | Basic Structured Display Storage (1.2.840.10008.5.1.4.1.1.131)
static (Shared in Visual Basic) | BasicTextSR | Basic Text SR Storage (1.2.840.10008.5.1.4.1.1.88.11)
static (Shared in Visual Basic) | BasicVoiceAudioWaveform | Basic Voice Audio Waveform Storage (1.2.840.10008.5.1.4.1.1.9.4.1)
static (Shared in Visual Basic) | BlendingSoftcopyPresentationState | Blending Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.4)
static (Shared in Visual Basic) | BreastImagingRelevantPatientInformationQuery | Breast Imaging Relevant Patient Information Query (1.2.840.10008.5.1.4.37.2)
static (Shared in Visual Basic) | BreastTomosynthesisImage | Breast Tomosynthesis Image Storage (1.2.840.10008.5.1.4.1.1.13.1.3)
static (Shared in Visual Basic) | CardiacElectrophysiologyWaveform | Cardiac Electrophysiology Waveform Storage (1.2.840.10008.5.1.4.1.1.9.3.1)
static (Shared in Visual Basic) | CardiacRelevantPatientInformationQuery | Cardiac Relevant Patient Information Query (1.2.840.10008.5.1.4.37.3)
static (Shared in Visual Basic) | ChestCADSR | Chest CAD SR Storage (1.2.840.10008.5.1.4.1.1.88.65)
static (Shared in Visual Basic) | ColonCADSR | Colon CAD SR Storage (1.2.840.10008.5.1.4.1.1.88.69)
static (Shared in Visual Basic) | ColorPalette | Color Palette Storage (1.2.840.10008.5.1.4.39.1)
static (Shared in Visual Basic) | ColorPaletteQRFIND | Color Palette Information Model - FIND (1.2.840.10008.5.1.4.39.2)
static (Shared in Visual Basic) | ColorPaletteQRGET | Color Palette Information Model - GET (1.2.840.10008.5.1.4.39.4)
static (Shared in Visual Basic) | ColorPaletteQRMOVE | Color Palette Information Model - MOVE (1.2.840.10008.5.1.4.39.3)
static (Shared in Visual Basic) | ColorSoftcopyPresentationState | Color Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.2)
static (Shared in Visual Basic) | CompositeInstanceRootRetrieve_GET | Composite Instance Root Retrieve - GET (1.2.840.10008.5.1.4.1.2.4.3)
static (Shared in Visual Basic) | CompositeInstanceRootRetrieve_MOVE | Composite Instance Root Retrieve - MOVE (1.2.840.10008.5.1.4.1.2.4.2)
static (Shared in Visual Basic) | CompositeInstanceRootRetrieveWithoutBulkData_GET | Composite Instance Retrieve Without Bulk Data - GET (1.2.840.10008.5.1.4.1.2.5.3)
static (Shared in Visual Basic) | ComprehensiveSR | Comprehensive SR Storage (1.2.840.10008.5.1.4.1.1.88.33)
static (Shared in Visual Basic) | ComputedRadiography | Computed Radiography Image Storage (1.2.840.10008.5.1.4.1.1.1)
static (Shared in Visual Basic) | CornealTopographyMap | Corneal Topography Map Storage (1.2.840.10008.5.1.4.1.1.82.1)
static (Shared in Visual Basic) | CT | CT Image Storage (1.2.840.10008.5.1.4.1.1.2)
static (Shared in Visual Basic) | DeformableSpatialRegistration | Deformable Spatial Registration Storage (1.2.840.10008.5.1.4.1.1.66.3)
static (Shared in Visual Basic) | DICOSCTImage | DICOS CT Image Storage (1.2.840.10008.5.1.4.1.1.501.1)
static (Shared in Visual Basic) | DICOSDigitalXRayImageForPresentation | DICOS Digital X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.501.2.1)
static (Shared in Visual Basic) | DICOSDigitalXRayImageForProcessing | DICOS Digital X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.501.2.2)
static (Shared in Visual Basic) | DICOSThreatDetectionReport | DICOS Threat Detection Report Storage (1.2.840.10008.5.1.4.1.1.501.3)
static (Shared in Visual Basic) | DigitalIntraoralXRay_Presentation | Digital Intra-oral X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.1.3)
static (Shared in Visual Basic) | DigitalIntraoralXRay_Processing | Digital Intra-oral X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.1.3.1)
static (Shared in Visual Basic) | DigitalMammographyXRay_Presentation | Digital Mammography X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.1.2)
static (Shared in Visual Basic) | DigitalMammographyXRay_Processing | Digital Mammography X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.1.2.1)
static (Shared in Visual Basic) | DigitalXRay_Presentation | Digital X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.1.1)
static (Shared in Visual Basic) | DigitalXRay_Processing | Digital X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.1.1.1)
static (Shared in Visual Basic) | EddyCurrentImage | Eddy Current Image Storage (1.2.840.10008.5.1.4.1.1.601.1)
static (Shared in Visual Basic) | EddyCurrentMultiframeImage | Eddy Current Multi-frame Image Storage (1.2.840.10008.5.1.4.1.1.601.2)
static (Shared in Visual Basic) | EncapsulatedCDA | Encapsulated CDA Storage (1.2.840.10008.5.1.4.1.1.104.2)
static (Shared in Visual Basic) | EncapsulatedPDF | Encapsulated PDF Storage (1.2.840.10008.5.1.4.1.1.104.1)
static (Shared in Visual Basic) | EncapsulatedSTL | Encapsulated STL Storage (1.2.840.10008.5.1.4.1.1.104.3)
static (Shared in Visual Basic) | EnhancedCT | Enhanced CT Image Storage (1.2.840.10008.5.1.4.1.1.2.1)
static (Shared in Visual Basic) | EnhancedMR | Enhanced MR Image Storage (1.2.840.10008.5.1.4.1.1.4.1)
static (Shared in Visual Basic) | EnhancedMRColorImage | Enhanced MR Color Image Storage (1.2.840.10008.5.1.4.1.1.4.3)
static (Shared in Visual Basic) | EnhancedPETImage | Enhanced PET Image Storage (1.2.840.10008.5.1.4.1.1.130)
static (Shared in Visual Basic) | EnhancedSR | Enhanced SR Storage (1.2.840.10008.5.1.4.1.1.88.22)
static (Shared in Visual Basic) | EnhancedUSVolume | Enhanced US Volume Storage (1.2.840.10008.5.1.4.1.1.6.2)
static (Shared in Visual Basic) | EnhancedXAImage | Enhanced XA Image Storage (1.2.840.10008.5.1.4.1.1.12.1.1)
static (Shared in Visual Basic) | EnhancedXRFImage | Enhanced XRF Image Storage (1.2.840.10008.5.1.4.1.1.12.2.1)
static (Shared in Visual Basic) | GeneralAudioWaveform | General Audio Waveform Storage (1.2.840.10008.5.1.4.1.1.9.4.2)
static (Shared in Visual Basic) | GeneralECGWaveform | General ECG Waveform Storage (1.2.840.10008.5.1.4.1.1.9.1.2)
static (Shared in Visual Basic) | GeneralPurposePerformedProcedureStep | General Purpose Performed Procedure Step SOP Class (1.2.840.10008.5.1.4.32.3)
static (Shared in Visual Basic) | GeneralPurposeScheduledProcedureStep | General Purpose Scheduled Procedure Step SOP Class (1.2.840.10008.5.1.4.32.2)
static (Shared in Visual Basic) | GeneralPurposeWorklistQRFIND | General Purpose Worklist Information Model - FIND (1.2.840.10008.5.1.4.32.1)
static (Shared in Visual Basic) | GeneralRelevantPatientInformationQuery | General Relevant Patient Information Query (1.2.840.10008.5.1.4.37.1)
static (Shared in Visual Basic) | GenericImplantTemplate | Generic Implant Template Storage (1.2.840.10008.5.1.4.43.1)
static (Shared in Visual Basic) | GenericImplantTemplateQRFIND | Generic Implant Template Information Model - FIND (1.2.840.10008.5.1.4.43.2)
static (Shared in Visual Basic) | GenericImplantTemplateQRGET | Generic Implant Template Information Model - GET (1.2.840.10008.5.1.4.43.4)
static (Shared in Visual Basic) | GenericImplantTemplateQRMOVE | Generic Implant Template Information Model - MOVE (1.2.840.10008.5.1.4.43.3)
static (Shared in Visual Basic) | GrayscaleSoftcopyPresentationState | Grayscale Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.1)
static (Shared in Visual Basic) | HangingProtocol | Hanging Protocol Storage (1.2.840.10008.5.1.4.38.1)
static (Shared in Visual Basic) | HangingProtocolQRFIND | Hanging Protocol Information Model - FIND (1.2.840.10008.5.1.4.38.2)
static (Shared in Visual Basic) | HangingProtocolQRGET | Hanging Protocol Information Model - GET (1.2.840.10008.5.1.4.38.4)
static (Shared in Visual Basic) | HangingProtocolQRMOVE | Hanging Protocol Information Model - MOVE (1.2.840.10008.5.1.4.38.3)
static (Shared in Visual Basic) | HemodynamicWaveform | Hemodynamic Waveform Storage (1.2.840.10008.5.1.4.1.1.9.2.1)
static (Shared in Visual Basic) | ImplantAssemblyTemplate | Implant Assembly Template Storage (1.2.840.10008.5.1.4.44.1)
static (Shared in Visual Basic) | ImplantAssemblyTemplateQRFIND | Implant Assembly Template Information Model - FIND (1.2.840.10008.5.1.4.44.2)
static (Shared in Visual Basic) | ImplantAssemblyTemplateQRGET | Implant Assembly Template Information Model - GET (1.2.840.10008.5.1.4.44.4)
static (Shared in Visual Basic) | ImplantAssemblyTemplateQRMOVE | Implant Assembly Template Information Model - MOVE (1.2.840.10008.5.1.4.44.3)
static (Shared in Visual Basic) | ImplantationPlanSR | Implantation Plan SR Storage (1.2.840.10008.5.1.4.1.1.88.70)
static (Shared in Visual Basic) | ImplantTemplateGroup | Implant Template Group Storage (1.2.840.10008.5.1.4.45.1)
static (Shared in Visual Basic) | ImplantTemplateGroupQRFIND | Implant Template Group Information Model - FIND (1.2.840.10008.5.1.4.45.2)
static (Shared in Visual Basic) | ImplantTemplateGroupQRGET | Implant Template Group Information Model - GET (1.2.840.10008.5.1.4.45.4)
static (Shared in Visual Basic) | ImplantTemplateGroupQRMOVE | Implant Template Group Information Model - MOVE (1.2.840.10008.5.1.4.45.3)
static (Shared in Visual Basic) | InstanceAvailabilityNotification | Instance Availability Notification SOP Class (1.2.840.10008.5.1.4.33)
static (Shared in Visual Basic) | IntraocularLensCalculations | Intraocular Lens Calculations Storage (1.2.840.10008.5.1.4.1.1.78.8)
static (Shared in Visual Basic) | IntravascularOpticalCoherenceTomographyImageForPresentation | Intravascular Optical Coherence Tomography Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.14.1)
static (Shared in Visual Basic) | IntravascularOpticalCoherenceTomographyImageForProcessing | Intravascular Optical Coherence Tomography Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.14.2)
static (Shared in Visual Basic) | KeratometryMeasurements | Keratometry Measurements Storage (1.2.840.10008.5.1.4.1.1.78.3)
static (Shared in Visual Basic) | KeyObjectSelectionDocument | Key Object Selection Document Storage (1.2.840.10008.5.1.4.1.1.88.59)
static (Shared in Visual Basic) | LegacyConvertedEnhancedCT | Legacy Converted Enhanced CT Image Storage (1.2.840.10008.5.1.4.1.1.2.2)
static (Shared in Visual Basic) | LegacyConvertedEnhancedMRColorImage | Legacy Converted Enhanced MR Image Storage (1.2.840.10008.5.1.4.1.1.4.4)
static (Shared in Visual Basic) | LegacyConvertedEnhancedPETImage | Legacy Converted Enhanced PET Image Storage (1.2.840.10008.5.1.4.1.1.128.1)
static (Shared in Visual Basic) | LensometryMeasurements | Lensometry Measurements Storage (1.2.840.10008.5.1.4.1.1.78.1)
static (Shared in Visual Basic) | MacularGridThicknessandVolumeReport | Macular Grid Thickness and Volume Report Storage (1.2.840.10008.5.1.4.1.1.79.1)
static (Shared in Visual Basic) | MammographyCADSR | Mammography CAD SR Storage (1.2.840.10008.5.1.4.1.1.88.50)
static (Shared in Visual Basic) | MediaCreationManagementUID | Media Creation Management SOP Class UID (1.2.840.10008.5.1.1.33)
static (Shared in Visual Basic) | MediaStorageDirectory | Media Storage Directory Storage (1.2.840.10008.1.3.10)
static (Shared in Visual Basic) | ModalityPerformedProcedureStep | Modality Performed Procedure Step SOP Class (1.2.840.10008.3.1.2.3.3)
static (Shared in Visual Basic) | ModalityPerformedProcedureStepNotification | Modality Performed Procedure Step Notification SOP Class (1.2.840.10008.3.1.2.3.5)
static (Shared in Visual Basic) | ModalityPerformedProcedureStepRetrieve | Modality Performed Procedure Step Retrieve SOP Class (1.2.840.10008.3.1.2.3.4)
static (Shared in Visual Basic) | ModalityWorklistQRFIND | Modality Worklist Information Model - FIND (1.2.840.10008.5.1.4.31)
static (Shared in Visual Basic) | MR | MR Image Storage (1.2.840.10008.5.1.4.1.1.4)
static (Shared in Visual Basic) | MRSpectroscopy | MR Spectroscopy Storage (1.2.840.10008.5.1.4.1.1.4.2)
static (Shared in Visual Basic) | MultiFrameGrayscaleByteSC | Multi-frame Grayscale Byte Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.2)
static (Shared in Visual Basic) | MultiFrameGrayscaleWordSC | Multi-frame Grayscale Word Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.3)
static (Shared in Visual Basic) | MultiFrameSingleBitSC | Multi-frame Single Bit Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.1)
static (Shared in Visual Basic) | MultiFrameTrueColorSC | Multi-frame True Color Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.4)
static (Shared in Visual Basic) | NuclearMedicine | Nuclear Medicine Image Storage (1.2.840.10008.5.1.4.1.1.20)
static (Shared in Visual Basic) | OphthalmicAxialMeasurements | Ophthalmic Axial Measurements Storage (1.2.840.10008.5.1.4.1.1.78.7)
static (Shared in Visual Basic) | OphthalmicPhotography16Bit | Ophthalmic Photography 16 Bit Image Storage (1.2.840.10008.5.1.4.1.1.77.1.5.2)
static (Shared in Visual Basic) | OphthalmicPhotography8Bit | Ophthalmic Photography 8 Bit Image Storage (1.2.840.10008.5.1.4.1.1.77.1.5.1)
static (Shared in Visual Basic) | OphthalmicThicknessMap | Ophthalmic Thickness Map Storage (1.2.840.10008.5.1.4.1.1.81.1)
static (Shared in Visual Basic) | OphthalmicTomographyImage | Ophthalmic Tomography Image Storage (1.2.840.10008.5.1.4.1.1.77.1.5.4)
static (Shared in Visual Basic) | OphthalmicVisualFieldStaticPerimetryMeasurements | Ophthalmic Visual Field Static Perimetry Measurements Storage (1.2.840.10008.5.1.4.1.1.80.1)
static (Shared in Visual Basic) | PatientRootQR_FIND | Patient Root Query/Retrieve Information Model - FIND (1.2.840.10008.5.1.4.1.2.1.1)
static (Shared in Visual Basic) | PatientRootQR_GET | Patient Root Query/Retrieve Information Model - GET (1.2.840.10008.5.1.4.1.2.1.3)
static (Shared in Visual Basic) | PatientRootQR_MOVE | Patient Root Query/Retrieve Information Model - MOVE (1.2.840.10008.5.1.4.1.2.1.2)
static (Shared in Visual Basic) | PositronEmissionTomography | Positron Emission Tomography Image Storage (1.2.840.10008.5.1.4.1.1.128)
static (Shared in Visual Basic) | PresentationLUT | Presentation LUT SOP Class (1.2.840.10008.5.1.1.23)
static (Shared in Visual Basic) | Printer | Printer SOP Class (1.2.840.10008.5.1.1.16)
static (Shared in Visual Basic) | PrinterConfigurationRetrieval | Printer Configuration Retrieval SOP Class (1.2.840.10008.5.1.1.16.376)
static (Shared in Visual Basic) | PrintJob | Print Job SOP Class (1.2.840.10008.5.1.1.14)
static (Shared in Visual Basic) | ProceduralEventLogging | Procedural Event Logging SOP Class (1.2.840.10008.1.40)
static (Shared in Visual Basic) | ProcedureLog | Procedure Log Storage (1.2.840.10008.5.1.4.1.1.88.40)
static (Shared in Visual Basic) | ProductCharacteristicsQuery | Product Characteristics Query SOP Class (1.2.840.10008.5.1.4.41)
static (Shared in Visual Basic) | PseudoColorSoftcopyPresentationState | Pseudo-Color Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.3)
static (Shared in Visual Basic) | RawData | Raw Data Storage (1.2.840.10008.5.1.4.1.1.66)
static (Shared in Visual Basic) | RealWorldValueMapping | Real World Value Mapping Storage (1.2.840.10008.5.1.4.1.1.67)
static (Shared in Visual Basic) | RespiratoryWaveform | Respiratory Waveform Storage (1.2.840.10008.5.1.4.1.1.9.6.1)
static (Shared in Visual Basic) | RT | RT Image Storage (1.2.840.10008.5.1.4.1.1.481.1)
static (Shared in Visual Basic) | RTBeamsDeliveryInstruction | RT Beams Delivery Instruction Storage (1.2.840.10008.5.1.4.34.7)
static (Shared in Visual Basic) | RTBeamsTreatmentRecord | RT Beams Treatment Record Storage (1.2.840.10008.5.1.4.1.1.481.4)
static (Shared in Visual Basic) | RTBrachyTreatmentRecord | RT Brachy Treatment Record Storage (1.2.840.10008.5.1.4.1.1.481.6)
static (Shared in Visual Basic) | RTConventionalMachineVerification | RT Conventional Machine Verification (1.2.840.10008.5.1.4.34.8)
static (Shared in Visual Basic) | RTDose | RT Dose Storage (1.2.840.10008.5.1.4.1.1.481.2)
static (Shared in Visual Basic) | RTIonBeamsTreatmentRecord | RT Ion Beams Treatment Record Storage (1.2.840.10008.5.1.4.1.1.481.9)
static (Shared in Visual Basic) | RTIonMachineVerification | RT Ion Machine Verification (1.2.840.10008.5.1.4.34.9)
static (Shared in Visual Basic) | RTIonPlan | RT Ion Plan Storage (1.2.840.10008.5.1.4.1.1.481.8)
static (Shared in Visual Basic) | RTPlan | RT Plan Storage (1.2.840.10008.5.1.4.1.1.481.5)
static (Shared in Visual Basic) | RTStructureSet | RT Structure Set Storage (1.2.840.10008.5.1.4.1.1.481.3)
static (Shared in Visual Basic) | RTTreatmentSummaryRecord | RT Treatment Summary Record Storage (1.2.840.10008.5.1.4.1.1.481.7)
static (Shared in Visual Basic) | SecondaryCapture | Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7)
static (Shared in Visual Basic) | Segmentation | Segmentation Storage (1.2.840.10008.5.1.4.1.1.66.4)
static (Shared in Visual Basic) | SpatialFiducials | Spatial Fiducials Storage (1.2.840.10008.5.1.4.1.1.66.2)
static (Shared in Visual Basic) | SpatialRegistration | Spatial Registration Storage (1.2.840.10008.5.1.4.1.1.66.1)
static (Shared in Visual Basic) | SpectaclePrescriptionReport | Spectacle Prescription Report Storage (1.2.840.10008.5.1.4.1.1.78.6)
static (Shared in Visual Basic) | StereometricRelationship | Stereometric Relationship Storage (1.2.840.10008.5.1.4.1.1.77.1.5.3)
static (Shared in Visual Basic) | StorageCommitmentPush | Storage Commitment Push Model SOP Class (1.2.840.10008.1.20.1)
static (Shared in Visual Basic) | StorageServiceClass | Storage Service Class (1.2.840.10008.4.2)
static (Shared in Visual Basic) | StudyRootQR_FIND | Study Root Query/Retrieve Information Model - FIND (1.2.840.10008.5.1.4.1.2.2.1)
static (Shared in Visual Basic) | StudyRootQR_GET | Study Root Query/Retrieve Information Model - GET (1.2.840.10008.5.1.4.1.2.2.3)
static (Shared in Visual Basic) | StudyRootQR_MOVE | Study Root Query/Retrieve Information Model - MOVE (1.2.840.10008.5.1.4.1.2.2.2)
static (Shared in Visual Basic) | SubjectiveRefractionMeasurements | Subjective Refraction Measurements Storage (1.2.840.10008.5.1.4.1.1.78.4)
static (Shared in Visual Basic) | SubstanceAdministrationLogging | Substance Administration Logging SOP Class (1.2.840.10008.1.42)
static (Shared in Visual Basic) | SubstanceApprovalQuery | Substance Approval Query SOP Class (1.2.840.10008.5.1.4.42)
static (Shared in Visual Basic) | SurfaceSegmentation | Surface Segmentation Storage (1.2.840.10008.5.1.4.1.1.66.5)
static (Shared in Visual Basic) | TwelveLeadECGWaveform | 12-lead ECG Waveform Storage (1.2.840.10008.5.1.4.1.1.9.1.1)
static (Shared in Visual Basic) | Ultrasound | Ultrasound Image Storage (1.2.840.10008.5.1.4.1.1.6.1)
static (Shared in Visual Basic) | UltrasoundMultiframe | Ultrasound Multi-frame Image Storage (1.2.840.10008.5.1.4.1.1.3.1)
static (Shared in Visual Basic) | UnifiedProcedureStepEvent | Unified Procedure Step - Event SOP Class (1.2.840.10008.5.1.4.34.6.4)
static (Shared in Visual Basic) | UnifiedProcedureStepPull | Unified Procedure Step - Pull SOP Class (1.2.840.10008.5.1.4.34.6.3)
static (Shared in Visual Basic) | UnifiedProcedureStepPush | Unified Procedure Step - Push SOP Class (1.2.840.10008.5.1.4.34.6.1)
static (Shared in Visual Basic) | UnifiedProcedureStepWatch | Unified Procedure Step - Watch SOP Class (1.2.840.10008.5.1.4.34.6.2)
static (Shared in Visual Basic) | UnifiedWorklistandProcedureStepServiceClass | Unified Worklist and Procedure Step Service Class (1.2.840.10008.5.1.4.34.6)
static (Shared in Visual Basic) | Verification | Verification SOP Class (1.2.840.10008.1.1)
static (Shared in Visual Basic) | VideoEndoscopic | Video Endoscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.1.1)
static (Shared in Visual Basic) | VideoMicroscopic | Video Microscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.2.1)
static (Shared in Visual Basic) | VideoPhotographic | Video Photographic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.4.1)
static (Shared in Visual Basic) | VisualAcuityMeasurements | Visual Acuity Measurements Storage (1.2.840.10008.5.1.4.1.1.78.5)
static (Shared in Visual Basic) | VLEndoscopic | VL Endoscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.1)
static (Shared in Visual Basic) | VLMicroscopic | VL Microscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.2)
static (Shared in Visual Basic) | VLPhotographic | VL Photographic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.4)
static (Shared in Visual Basic) | VLSlideCoordinatesMicroscopic | VL Slide-Coordinates Microscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.3)
static (Shared in Visual Basic) | VLWholeSlideMicroscopyImage | VL Whole Slide Microscopy Image Storage (1.2.840.10008.5.1.4.1.1.77.1.6)
static (Shared in Visual Basic) | VOILUTBox | VOI LUT Box SOP Class (1.2.840.10008.5.1.1.22)
static (Shared in Visual Basic) | XA_XRFGrayscaleSoftcopyPresentationState | XA/XRF Grayscale Softcopy Presentation State Storage (1.2.840.10008.5.1.4.1.1.11.5)
static (Shared in Visual Basic) | XRay3DAngiographicImage | X-Ray 3D Angiographic Image Storage (1.2.840.10008.5.1.4.1.1.13.1.1)
static (Shared in Visual Basic) | XRay3DCraniofacialImage | X-Ray 3D Craniofacial Image Storage (1.2.840.10008.5.1.4.1.1.13.1.2)
static (Shared in Visual Basic) | XRayAngiographic | X-Ray Angiographic Image Storage (1.2.840.10008.5.1.4.1.1.12.1)
static (Shared in Visual Basic) | XRayRadiationDoseSR | X-Ray Radiation Dose SR Storage (1.2.840.10008.5.1.4.1.1.88.67)
static (Shared in Visual Basic) | XRayRadiofluoroscopic | X-Ray Radiofluoroscopic Image Storage (1.2.840.10008.5.1.4.1.1.12.2)
Top
See Also

Reference

SOPClasses Class
DicomObjects.DicomUIDs Namespace


AmbulatoryECGWaveform Field

AmbulatoryECGWaveform Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : AmbulatoryECGWaveform Field
Ambulatory ECG Waveform Storage (1.2.840.10008.5.1.4.1.1.9.1.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly AmbulatoryECGWaveform As UID
'Usage

Dim value As UID

value = SOPClasses.AmbulatoryECGWaveform
public static readonly UID AmbulatoryECGWaveform
public:
static readonly UID^ AmbulatoryECGWaveform
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ArterialPulseWaveform Field

ArterialPulseWaveform Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ArterialPulseWaveform Field
Arterial Pulse Waveform Storage (1.2.840.10008.5.1.4.1.1.9.5.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ArterialPulseWaveform As UID
'Usage

Dim value As UID

value = SOPClasses.ArterialPulseWaveform
public static readonly UID ArterialPulseWaveform
public:
static readonly UID^ ArterialPulseWaveform
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


AutorefractionMeasurements Field

AutorefractionMeasurements Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : AutorefractionMeasurements Field
Autorefraction Measurements Storage (1.2.840.10008.5.1.4.1.1.78.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly AutorefractionMeasurements As UID
'Usage

Dim value As UID

value = SOPClasses.AutorefractionMeasurements
public static readonly UID AutorefractionMeasurements
public:
static readonly UID^ AutorefractionMeasurements
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


BasicAnnotationBox Field

BasicAnnotationBox Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : BasicAnnotationBox Field
Basic Annotation Box SOP Class (1.2.840.10008.5.1.1.15)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly BasicAnnotationBox As UID
'Usage

Dim value As UID

value = SOPClasses.BasicAnnotationBox
public static readonly UID BasicAnnotationBox
public:
static readonly UID^ BasicAnnotationBox
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


BasicColorImageBox Field

BasicColorImageBox Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : BasicColorImageBox Field
Basic Color Image Box SOP Class (1.2.840.10008.5.1.1.4.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly BasicColorImageBox As UID
'Usage

Dim value As UID

value = SOPClasses.BasicColorImageBox
public static readonly UID BasicColorImageBox
public:
static readonly UID^ BasicColorImageBox
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


BasicFilmBox Field

BasicFilmBox Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : BasicFilmBox Field
Basic Film Box SOP Class (1.2.840.10008.5.1.1.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly BasicFilmBox As UID
'Usage

Dim value As UID

value = SOPClasses.BasicFilmBox
public static readonly UID BasicFilmBox
public:
static readonly UID^ BasicFilmBox
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


BasicFilmSession Field

BasicFilmSession Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : BasicFilmSession Field
Basic Film Session SOP Class (1.2.840.10008.5.1.1.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly BasicFilmSession As UID
'Usage

Dim value As UID

value = SOPClasses.BasicFilmSession
public static readonly UID BasicFilmSession
public:
static readonly UID^ BasicFilmSession
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


BasicGrayscaleImageBox Field

BasicGrayscaleImageBox Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : BasicGrayscaleImageBox Field
Basic Grayscale Image Box SOP Class (1.2.840.10008.5.1.1.4)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly BasicGrayscaleImageBox As UID
'Usage

Dim value As UID

value = SOPClasses.BasicGrayscaleImageBox
public static readonly UID BasicGrayscaleImageBox
public:
static readonly UID^ BasicGrayscaleImageBox
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


BasicStructuredDisplay Field

BasicStructuredDisplay Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : BasicStructuredDisplay Field
Basic Structured Display Storage (1.2.840.10008.5.1.4.1.1.131)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly BasicStructuredDisplay As UID
'Usage

Dim value As UID

value = SOPClasses.BasicStructuredDisplay
public static readonly UID BasicStructuredDisplay
public:
static readonly UID^ BasicStructuredDisplay
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


BasicTextSR Field

BasicTextSR Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : BasicTextSR Field
Basic Text SR Storage (1.2.840.10008.5.1.4.1.1.88.11)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly BasicTextSR As UID
'Usage

Dim value As UID

value = SOPClasses.BasicTextSR
public static readonly UID BasicTextSR
public:
static readonly UID^ BasicTextSR
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


BasicVoiceAudioWaveform Field

BasicVoiceAudioWaveform Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : BasicVoiceAudioWaveform Field
Basic Voice Audio Waveform Storage (1.2.840.10008.5.1.4.1.1.9.4.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly BasicVoiceAudioWaveform As UID
'Usage

Dim value As UID

value = SOPClasses.BasicVoiceAudioWaveform
public static readonly UID BasicVoiceAudioWaveform
public:
static readonly UID^ BasicVoiceAudioWaveform
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


BlendingSoftcopyPresentationState Field

BlendingSoftcopyPresentationState Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : BlendingSoftcopyPresentationState Field
Blending Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.4)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly BlendingSoftcopyPresentationState As UID
'Usage

Dim value As UID

value = SOPClasses.BlendingSoftcopyPresentationState
public static readonly UID BlendingSoftcopyPresentationState
public:
static readonly UID^ BlendingSoftcopyPresentationState
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


BreastImagingRelevantPatientInformationQuery Field

BreastImagingRelevantPatientInformationQuery Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : BreastImagingRelevantPatientInformationQuery Field
Breast Imaging Relevant Patient Information Query (1.2.840.10008.5.1.4.37.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly BreastImagingRelevantPatientInformationQuery As UID
'Usage

Dim value As UID

value = SOPClasses.BreastImagingRelevantPatientInformationQuery
public static readonly UID BreastImagingRelevantPatientInformationQuery
public:
static readonly UID^ BreastImagingRelevantPatientInformationQuery
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


BreastTomosynthesisImage Field

BreastTomosynthesisImage Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : BreastTomosynthesisImage Field
Breast Tomosynthesis Image Storage (1.2.840.10008.5.1.4.1.1.13.1.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly BreastTomosynthesisImage As UID
'Usage

Dim value As UID

value = SOPClasses.BreastTomosynthesisImage
public static readonly UID BreastTomosynthesisImage
public:
static readonly UID^ BreastTomosynthesisImage
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


CardiacElectrophysiologyWaveform Field

CardiacElectrophysiologyWaveform Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : CardiacElectrophysiologyWaveform Field
Cardiac Electrophysiology Waveform Storage (1.2.840.10008.5.1.4.1.1.9.3.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly CardiacElectrophysiologyWaveform As UID
'Usage

Dim value As UID

value = SOPClasses.CardiacElectrophysiologyWaveform
public static readonly UID CardiacElectrophysiologyWaveform
public:
static readonly UID^ CardiacElectrophysiologyWaveform
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


CardiacRelevantPatientInformationQuery Field

CardiacRelevantPatientInformationQuery Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : CardiacRelevantPatientInformationQuery Field
Cardiac Relevant Patient Information Query (1.2.840.10008.5.1.4.37.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly CardiacRelevantPatientInformationQuery As UID
'Usage

Dim value As UID

value = SOPClasses.CardiacRelevantPatientInformationQuery
public static readonly UID CardiacRelevantPatientInformationQuery
public:
static readonly UID^ CardiacRelevantPatientInformationQuery
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ChestCADSR Field

ChestCADSR Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ChestCADSR Field
Chest CAD SR Storage (1.2.840.10008.5.1.4.1.1.88.65)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ChestCADSR As UID
'Usage

Dim value As UID

value = SOPClasses.ChestCADSR
public static readonly UID ChestCADSR
public:
static readonly UID^ ChestCADSR
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ColonCADSR Field

ColonCADSR Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ColonCADSR Field
Colon CAD SR Storage (1.2.840.10008.5.1.4.1.1.88.69)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ColonCADSR As UID
'Usage

Dim value As UID

value = SOPClasses.ColonCADSR
public static readonly UID ColonCADSR
public:
static readonly UID^ ColonCADSR
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ColorPalette Field

ColorPalette Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ColorPalette Field
Color Palette Storage (1.2.840.10008.5.1.4.39.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ColorPalette As UID
'Usage

Dim value As UID

value = SOPClasses.ColorPalette
public static readonly UID ColorPalette
public:
static readonly UID^ ColorPalette
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ColorPaletteQRFIND Field

ColorPaletteQRFIND Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ColorPaletteQRFIND Field
Color Palette Information Model - FIND (1.2.840.10008.5.1.4.39.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ColorPaletteQRFIND As UID
'Usage

Dim value As UID

value = SOPClasses.ColorPaletteQRFIND
public static readonly UID ColorPaletteQRFIND
public:
static readonly UID^ ColorPaletteQRFIND
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ColorPaletteQRGET Field

ColorPaletteQRGET Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ColorPaletteQRGET Field
Color Palette Information Model - GET (1.2.840.10008.5.1.4.39.4)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ColorPaletteQRGET As UID
'Usage

Dim value As UID

value = SOPClasses.ColorPaletteQRGET
public static readonly UID ColorPaletteQRGET
public:
static readonly UID^ ColorPaletteQRGET
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ColorPaletteQRMOVE Field

ColorPaletteQRMOVE Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ColorPaletteQRMOVE Field
Color Palette Information Model - MOVE (1.2.840.10008.5.1.4.39.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ColorPaletteQRMOVE As UID
'Usage

Dim value As UID

value = SOPClasses.ColorPaletteQRMOVE
public static readonly UID ColorPaletteQRMOVE
public:
static readonly UID^ ColorPaletteQRMOVE
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ColorSoftcopyPresentationState Field

ColorSoftcopyPresentationState Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ColorSoftcopyPresentationState Field
Color Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ColorSoftcopyPresentationState As UID
'Usage

Dim value As UID

value = SOPClasses.ColorSoftcopyPresentationState
public static readonly UID ColorSoftcopyPresentationState
public:
static readonly UID^ ColorSoftcopyPresentationState
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


CompositeInstanceRootRetrieve_GET Field

CompositeInstanceRootRetrieve_GET Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : CompositeInstanceRootRetrieve_GET Field
Composite Instance Root Retrieve - GET (1.2.840.10008.5.1.4.1.2.4.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly CompositeInstanceRootRetrieve_GET As UID
'Usage

Dim value As UID

value = SOPClasses.CompositeInstanceRootRetrieve_GET
public static readonly UID CompositeInstanceRootRetrieve_GET
public:
static readonly UID^ CompositeInstanceRootRetrieve_GET
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


CompositeInstanceRootRetrieve_MOVE Field

CompositeInstanceRootRetrieve_MOVE Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : CompositeInstanceRootRetrieve_MOVE Field
Composite Instance Root Retrieve - MOVE (1.2.840.10008.5.1.4.1.2.4.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly CompositeInstanceRootRetrieve_MOVE As UID
'Usage

Dim value As UID

value = SOPClasses.CompositeInstanceRootRetrieve_MOVE
public static readonly UID CompositeInstanceRootRetrieve_MOVE
public:
static readonly UID^ CompositeInstanceRootRetrieve_MOVE
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


CompositeInstanceRootRetrieveWithoutBulkData_GET Field

CompositeInstanceRootRetrieveWithoutBulkData_GET Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : CompositeInstanceRootRetrieveWithoutBulkData_GET Field
Composite Instance Retrieve Without Bulk Data - GET (1.2.840.10008.5.1.4.1.2.5.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly CompositeInstanceRootRetrieveWithoutBulkData_GET As UID
'Usage

Dim value As UID

value = SOPClasses.CompositeInstanceRootRetrieveWithoutBulkData_GET
public static readonly UID CompositeInstanceRootRetrieveWithoutBulkData_GET
public:
static readonly UID^ CompositeInstanceRootRetrieveWithoutBulkData_GET
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ComprehensiveSR Field

ComprehensiveSR Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ComprehensiveSR Field
Comprehensive SR Storage (1.2.840.10008.5.1.4.1.1.88.33)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ComprehensiveSR As UID
'Usage

Dim value As UID

value = SOPClasses.ComprehensiveSR
public static readonly UID ComprehensiveSR
public:
static readonly UID^ ComprehensiveSR
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ComputedRadiography Field

ComputedRadiography Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ComputedRadiography Field
Computed Radiography Image Storage (1.2.840.10008.5.1.4.1.1.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ComputedRadiography As UID
'Usage

Dim value As UID

value = SOPClasses.ComputedRadiography
public static readonly UID ComputedRadiography
public:
static readonly UID^ ComputedRadiography
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


CornealTopographyMap Field

CornealTopographyMap Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : CornealTopographyMap Field
Corneal Topography Map Storage (1.2.840.10008.5.1.4.1.1.82.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly CornealTopographyMap As UID
'Usage

Dim value As UID

value = SOPClasses.CornealTopographyMap
public static readonly UID CornealTopographyMap
public:
static readonly UID^ CornealTopographyMap
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


CT Field

CT Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : CT Field
CT Image Storage (1.2.840.10008.5.1.4.1.1.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly CT As UID
'Usage

Dim value As UID

value = SOPClasses.CT
public static readonly UID CT
public:
static readonly UID^ CT
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


DeformableSpatialRegistration Field

DeformableSpatialRegistration Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : DeformableSpatialRegistration Field
Deformable Spatial Registration Storage (1.2.840.10008.5.1.4.1.1.66.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly DeformableSpatialRegistration As UID
'Usage

Dim value As UID

value = SOPClasses.DeformableSpatialRegistration
public static readonly UID DeformableSpatialRegistration
public:
static readonly UID^ DeformableSpatialRegistration
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


DICOSCTImage Field

DICOSCTImage Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : DICOSCTImage Field
DICOS CT Image Storage (1.2.840.10008.5.1.4.1.1.501.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly DICOSCTImage As UID
'Usage

Dim value As UID

value = SOPClasses.DICOSCTImage
public static readonly UID DICOSCTImage
public:
static readonly UID^ DICOSCTImage
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


DICOSDigitalXRayImageForPresentation Field

DICOSDigitalXRayImageForPresentation Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : DICOSDigitalXRayImageForPresentation Field
DICOS Digital X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.501.2.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly DICOSDigitalXRayImageForPresentation As UID
'Usage

Dim value As UID

value = SOPClasses.DICOSDigitalXRayImageForPresentation
public static readonly UID DICOSDigitalXRayImageForPresentation
public:
static readonly UID^ DICOSDigitalXRayImageForPresentation
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


DICOSDigitalXRayImageForProcessing Field

DICOSDigitalXRayImageForProcessing Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : DICOSDigitalXRayImageForProcessing Field
DICOS Digital X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.501.2.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly DICOSDigitalXRayImageForProcessing As UID
'Usage

Dim value As UID

value = SOPClasses.DICOSDigitalXRayImageForProcessing
public static readonly UID DICOSDigitalXRayImageForProcessing
public:
static readonly UID^ DICOSDigitalXRayImageForProcessing
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


DICOSThreatDetectionReport Field

DICOSThreatDetectionReport Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : DICOSThreatDetectionReport Field
DICOS Threat Detection Report Storage (1.2.840.10008.5.1.4.1.1.501.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly DICOSThreatDetectionReport As UID
'Usage

Dim value As UID

value = SOPClasses.DICOSThreatDetectionReport
public static readonly UID DICOSThreatDetectionReport
public:
static readonly UID^ DICOSThreatDetectionReport
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


DigitalIntraoralXRay_Presentation Field

DigitalIntraoralXRay_Presentation Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : DigitalIntraoralXRay_Presentation Field
Digital Intra-oral X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.1.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly DigitalIntraoralXRay_Presentation As UID
'Usage

Dim value As UID

value = SOPClasses.DigitalIntraoralXRay_Presentation
public static readonly UID DigitalIntraoralXRay_Presentation
public:
static readonly UID^ DigitalIntraoralXRay_Presentation
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


DigitalIntraoralXRay_Processing Field

DigitalIntraoralXRay_Processing Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : DigitalIntraoralXRay_Processing Field
Digital Intra-oral X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.1.3.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly DigitalIntraoralXRay_Processing As UID
'Usage

Dim value As UID

value = SOPClasses.DigitalIntraoralXRay_Processing
public static readonly UID DigitalIntraoralXRay_Processing
public:
static readonly UID^ DigitalIntraoralXRay_Processing
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


DigitalMammographyXRay_Presentation Field

DigitalMammographyXRay_Presentation Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : DigitalMammographyXRay_Presentation Field
Digital Mammography X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.1.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly DigitalMammographyXRay_Presentation As UID
'Usage

Dim value As UID

value = SOPClasses.DigitalMammographyXRay_Presentation
public static readonly UID DigitalMammographyXRay_Presentation
public:
static readonly UID^ DigitalMammographyXRay_Presentation
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


DigitalMammographyXRay_Processing Field

DigitalMammographyXRay_Processing Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : DigitalMammographyXRay_Processing Field
Digital Mammography X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.1.2.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly DigitalMammographyXRay_Processing As UID
'Usage

Dim value As UID

value = SOPClasses.DigitalMammographyXRay_Processing
public static readonly UID DigitalMammographyXRay_Processing
public:
static readonly UID^ DigitalMammographyXRay_Processing
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


DigitalXRay_Presentation Field

DigitalXRay_Presentation Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : DigitalXRay_Presentation Field
Digital X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.1.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly DigitalXRay_Presentation As UID
'Usage

Dim value As UID

value = SOPClasses.DigitalXRay_Presentation
public static readonly UID DigitalXRay_Presentation
public:
static readonly UID^ DigitalXRay_Presentation
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


DigitalXRay_Processing Field

DigitalXRay_Processing Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : DigitalXRay_Processing Field
Digital X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.1.1.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly DigitalXRay_Processing As UID
'Usage

Dim value As UID

value = SOPClasses.DigitalXRay_Processing
public static readonly UID DigitalXRay_Processing
public:
static readonly UID^ DigitalXRay_Processing
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


EddyCurrentImage Field

EddyCurrentImage Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : EddyCurrentImage Field
Eddy Current Image Storage (1.2.840.10008.5.1.4.1.1.601.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly EddyCurrentImage As UID
'Usage

Dim value As UID

value = SOPClasses.EddyCurrentImage
public static readonly UID EddyCurrentImage
public:
static readonly UID^ EddyCurrentImage
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


EddyCurrentMultiframeImage Field

EddyCurrentMultiframeImage Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : EddyCurrentMultiframeImage Field
Eddy Current Multi-frame Image Storage (1.2.840.10008.5.1.4.1.1.601.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly EddyCurrentMultiframeImage As UID
'Usage

Dim value As UID

value = SOPClasses.EddyCurrentMultiframeImage
public static readonly UID EddyCurrentMultiframeImage
public:
static readonly UID^ EddyCurrentMultiframeImage
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


EncapsulatedCDA Field

EncapsulatedCDA Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : EncapsulatedCDA Field
Encapsulated CDA Storage (1.2.840.10008.5.1.4.1.1.104.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly EncapsulatedCDA As UID
'Usage

Dim value As UID

value = SOPClasses.EncapsulatedCDA
public static readonly UID EncapsulatedCDA
public:
static readonly UID^ EncapsulatedCDA
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


EncapsulatedPDF Field

EncapsulatedPDF Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : EncapsulatedPDF Field
Encapsulated PDF Storage (1.2.840.10008.5.1.4.1.1.104.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly EncapsulatedPDF As UID
'Usage

Dim value As UID

value = SOPClasses.EncapsulatedPDF
public static readonly UID EncapsulatedPDF
public:
static readonly UID^ EncapsulatedPDF
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


EncapsulatedSTL Field

EncapsulatedSTL Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : EncapsulatedSTL Field
Encapsulated STL Storage (1.2.840.10008.5.1.4.1.1.104.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly EncapsulatedSTL As UID
'Usage

Dim value As UID

value = SOPClasses.EncapsulatedSTL
public static readonly UID EncapsulatedSTL
public:
static readonly UID^ EncapsulatedSTL
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


EnhancedCT Field

EnhancedCT Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : EnhancedCT Field
Enhanced CT Image Storage (1.2.840.10008.5.1.4.1.1.2.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly EnhancedCT As UID
'Usage

Dim value As UID

value = SOPClasses.EnhancedCT
public static readonly UID EnhancedCT
public:
static readonly UID^ EnhancedCT
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


EnhancedMR Field

EnhancedMR Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : EnhancedMR Field
Enhanced MR Image Storage (1.2.840.10008.5.1.4.1.1.4.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly EnhancedMR As UID
'Usage

Dim value As UID

value = SOPClasses.EnhancedMR
public static readonly UID EnhancedMR
public:
static readonly UID^ EnhancedMR
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


EnhancedMRColorImage Field

EnhancedMRColorImage Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : EnhancedMRColorImage Field
Enhanced MR Color Image Storage (1.2.840.10008.5.1.4.1.1.4.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly EnhancedMRColorImage As UID
'Usage

Dim value As UID

value = SOPClasses.EnhancedMRColorImage
public static readonly UID EnhancedMRColorImage
public:
static readonly UID^ EnhancedMRColorImage
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


EnhancedPETImage Field

EnhancedPETImage Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : EnhancedPETImage Field
Enhanced PET Image Storage (1.2.840.10008.5.1.4.1.1.130)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly EnhancedPETImage As UID
'Usage

Dim value As UID

value = SOPClasses.EnhancedPETImage
public static readonly UID EnhancedPETImage
public:
static readonly UID^ EnhancedPETImage
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


EnhancedSR Field

EnhancedSR Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : EnhancedSR Field
Enhanced SR Storage (1.2.840.10008.5.1.4.1.1.88.22)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly EnhancedSR As UID
'Usage

Dim value As UID

value = SOPClasses.EnhancedSR
public static readonly UID EnhancedSR
public:
static readonly UID^ EnhancedSR
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


EnhancedUSVolume Field

EnhancedUSVolume Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : EnhancedUSVolume Field
Enhanced US Volume Storage (1.2.840.10008.5.1.4.1.1.6.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly EnhancedUSVolume As UID
'Usage

Dim value As UID

value = SOPClasses.EnhancedUSVolume
public static readonly UID EnhancedUSVolume
public:
static readonly UID^ EnhancedUSVolume
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


EnhancedXAImage Field

EnhancedXAImage Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : EnhancedXAImage Field
Enhanced XA Image Storage (1.2.840.10008.5.1.4.1.1.12.1.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly EnhancedXAImage As UID
'Usage

Dim value As UID

value = SOPClasses.EnhancedXAImage
public static readonly UID EnhancedXAImage
public:
static readonly UID^ EnhancedXAImage
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


EnhancedXRFImage Field

EnhancedXRFImage Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : EnhancedXRFImage Field
Enhanced XRF Image Storage (1.2.840.10008.5.1.4.1.1.12.2.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly EnhancedXRFImage As UID
'Usage

Dim value As UID

value = SOPClasses.EnhancedXRFImage
public static readonly UID EnhancedXRFImage
public:
static readonly UID^ EnhancedXRFImage
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


GeneralAudioWaveform Field

GeneralAudioWaveform Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : GeneralAudioWaveform Field
General Audio Waveform Storage (1.2.840.10008.5.1.4.1.1.9.4.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly GeneralAudioWaveform As UID
'Usage

Dim value As UID

value = SOPClasses.GeneralAudioWaveform
public static readonly UID GeneralAudioWaveform
public:
static readonly UID^ GeneralAudioWaveform
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


GeneralECGWaveform Field

GeneralECGWaveform Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : GeneralECGWaveform Field
General ECG Waveform Storage (1.2.840.10008.5.1.4.1.1.9.1.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly GeneralECGWaveform As UID
'Usage

Dim value As UID

value = SOPClasses.GeneralECGWaveform
public static readonly UID GeneralECGWaveform
public:
static readonly UID^ GeneralECGWaveform
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


GeneralPurposePerformedProcedureStep Field

GeneralPurposePerformedProcedureStep Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : GeneralPurposePerformedProcedureStep Field
General Purpose Performed Procedure Step SOP Class (1.2.840.10008.5.1.4.32.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly GeneralPurposePerformedProcedureStep As UID
'Usage

Dim value As UID

value = SOPClasses.GeneralPurposePerformedProcedureStep
public static readonly UID GeneralPurposePerformedProcedureStep
public:
static readonly UID^ GeneralPurposePerformedProcedureStep
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


GeneralPurposeScheduledProcedureStep Field

GeneralPurposeScheduledProcedureStep Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : GeneralPurposeScheduledProcedureStep Field
General Purpose Scheduled Procedure Step SOP Class (1.2.840.10008.5.1.4.32.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly GeneralPurposeScheduledProcedureStep As UID
'Usage

Dim value As UID

value = SOPClasses.GeneralPurposeScheduledProcedureStep
public static readonly UID GeneralPurposeScheduledProcedureStep
public:
static readonly UID^ GeneralPurposeScheduledProcedureStep
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


GeneralPurposeWorklistQRFIND Field

GeneralPurposeWorklistQRFIND Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : GeneralPurposeWorklistQRFIND Field
General Purpose Worklist Information Model - FIND (1.2.840.10008.5.1.4.32.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly GeneralPurposeWorklistQRFIND As UID
'Usage

Dim value As UID

value = SOPClasses.GeneralPurposeWorklistQRFIND
public static readonly UID GeneralPurposeWorklistQRFIND
public:
static readonly UID^ GeneralPurposeWorklistQRFIND
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


GeneralRelevantPatientInformationQuery Field

GeneralRelevantPatientInformationQuery Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : GeneralRelevantPatientInformationQuery Field
General Relevant Patient Information Query (1.2.840.10008.5.1.4.37.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly GeneralRelevantPatientInformationQuery As UID
'Usage

Dim value As UID

value = SOPClasses.GeneralRelevantPatientInformationQuery
public static readonly UID GeneralRelevantPatientInformationQuery
public:
static readonly UID^ GeneralRelevantPatientInformationQuery
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


GenericImplantTemplate Field

GenericImplantTemplate Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : GenericImplantTemplate Field
Generic Implant Template Storage (1.2.840.10008.5.1.4.43.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly GenericImplantTemplate As UID
'Usage

Dim value As UID

value = SOPClasses.GenericImplantTemplate
public static readonly UID GenericImplantTemplate
public:
static readonly UID^ GenericImplantTemplate
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


GenericImplantTemplateQRFIND Field

GenericImplantTemplateQRFIND Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : GenericImplantTemplateQRFIND Field
Generic Implant Template Information Model - FIND (1.2.840.10008.5.1.4.43.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly GenericImplantTemplateQRFIND As UID
'Usage

Dim value As UID

value = SOPClasses.GenericImplantTemplateQRFIND
public static readonly UID GenericImplantTemplateQRFIND
public:
static readonly UID^ GenericImplantTemplateQRFIND
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


GenericImplantTemplateQRGET Field

GenericImplantTemplateQRGET Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : GenericImplantTemplateQRGET Field
Generic Implant Template Information Model - GET (1.2.840.10008.5.1.4.43.4)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly GenericImplantTemplateQRGET As UID
'Usage

Dim value As UID

value = SOPClasses.GenericImplantTemplateQRGET
public static readonly UID GenericImplantTemplateQRGET
public:
static readonly UID^ GenericImplantTemplateQRGET
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


GenericImplantTemplateQRMOVE Field

GenericImplantTemplateQRMOVE Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : GenericImplantTemplateQRMOVE Field
Generic Implant Template Information Model - MOVE (1.2.840.10008.5.1.4.43.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly GenericImplantTemplateQRMOVE As UID
'Usage

Dim value As UID

value = SOPClasses.GenericImplantTemplateQRMOVE
public static readonly UID GenericImplantTemplateQRMOVE
public:
static readonly UID^ GenericImplantTemplateQRMOVE
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


GrayscaleSoftcopyPresentationState Field

GrayscaleSoftcopyPresentationState Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : GrayscaleSoftcopyPresentationState Field
Grayscale Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly GrayscaleSoftcopyPresentationState As UID
'Usage

Dim value As UID

value = SOPClasses.GrayscaleSoftcopyPresentationState
public static readonly UID GrayscaleSoftcopyPresentationState
public:
static readonly UID^ GrayscaleSoftcopyPresentationState
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


HangingProtocol Field

HangingProtocol Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : HangingProtocol Field
Hanging Protocol Storage (1.2.840.10008.5.1.4.38.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly HangingProtocol As UID
'Usage

Dim value As UID

value = SOPClasses.HangingProtocol
public static readonly UID HangingProtocol
public:
static readonly UID^ HangingProtocol
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


HangingProtocolQRFIND Field

HangingProtocolQRFIND Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : HangingProtocolQRFIND Field
Hanging Protocol Information Model - FIND (1.2.840.10008.5.1.4.38.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly HangingProtocolQRFIND As UID
'Usage

Dim value As UID

value = SOPClasses.HangingProtocolQRFIND
public static readonly UID HangingProtocolQRFIND
public:
static readonly UID^ HangingProtocolQRFIND
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


HangingProtocolQRGET Field

HangingProtocolQRGET Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : HangingProtocolQRGET Field
Hanging Protocol Information Model - GET (1.2.840.10008.5.1.4.38.4)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly HangingProtocolQRGET As UID
'Usage

Dim value As UID

value = SOPClasses.HangingProtocolQRGET
public static readonly UID HangingProtocolQRGET
public:
static readonly UID^ HangingProtocolQRGET
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


HangingProtocolQRMOVE Field

HangingProtocolQRMOVE Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : HangingProtocolQRMOVE Field
Hanging Protocol Information Model - MOVE (1.2.840.10008.5.1.4.38.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly HangingProtocolQRMOVE As UID
'Usage

Dim value As UID

value = SOPClasses.HangingProtocolQRMOVE
public static readonly UID HangingProtocolQRMOVE
public:
static readonly UID^ HangingProtocolQRMOVE
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


HemodynamicWaveform Field

HemodynamicWaveform Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : HemodynamicWaveform Field
Hemodynamic Waveform Storage (1.2.840.10008.5.1.4.1.1.9.2.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly HemodynamicWaveform As UID
'Usage

Dim value As UID

value = SOPClasses.HemodynamicWaveform
public static readonly UID HemodynamicWaveform
public:
static readonly UID^ HemodynamicWaveform
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ImplantAssemblyTemplate Field

ImplantAssemblyTemplate Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ImplantAssemblyTemplate Field
Implant Assembly Template Storage (1.2.840.10008.5.1.4.44.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ImplantAssemblyTemplate As UID
'Usage

Dim value As UID

value = SOPClasses.ImplantAssemblyTemplate
public static readonly UID ImplantAssemblyTemplate
public:
static readonly UID^ ImplantAssemblyTemplate
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ImplantAssemblyTemplateQRFIND Field

ImplantAssemblyTemplateQRFIND Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ImplantAssemblyTemplateQRFIND Field
Implant Assembly Template Information Model - FIND (1.2.840.10008.5.1.4.44.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ImplantAssemblyTemplateQRFIND As UID
'Usage

Dim value As UID

value = SOPClasses.ImplantAssemblyTemplateQRFIND
public static readonly UID ImplantAssemblyTemplateQRFIND
public:
static readonly UID^ ImplantAssemblyTemplateQRFIND
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ImplantAssemblyTemplateQRGET Field

ImplantAssemblyTemplateQRGET Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ImplantAssemblyTemplateQRGET Field
Implant Assembly Template Information Model - GET (1.2.840.10008.5.1.4.44.4)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ImplantAssemblyTemplateQRGET As UID
'Usage

Dim value As UID

value = SOPClasses.ImplantAssemblyTemplateQRGET
public static readonly UID ImplantAssemblyTemplateQRGET
public:
static readonly UID^ ImplantAssemblyTemplateQRGET
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ImplantAssemblyTemplateQRMOVE Field

ImplantAssemblyTemplateQRMOVE Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ImplantAssemblyTemplateQRMOVE Field
Implant Assembly Template Information Model - MOVE (1.2.840.10008.5.1.4.44.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ImplantAssemblyTemplateQRMOVE As UID
'Usage

Dim value As UID

value = SOPClasses.ImplantAssemblyTemplateQRMOVE
public static readonly UID ImplantAssemblyTemplateQRMOVE
public:
static readonly UID^ ImplantAssemblyTemplateQRMOVE
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ImplantationPlanSR Field

ImplantationPlanSR Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ImplantationPlanSR Field
Implantation Plan SR Storage (1.2.840.10008.5.1.4.1.1.88.70)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ImplantationPlanSR As UID
'Usage

Dim value As UID

value = SOPClasses.ImplantationPlanSR
public static readonly UID ImplantationPlanSR
public:
static readonly UID^ ImplantationPlanSR
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ImplantTemplateGroup Field

ImplantTemplateGroup Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ImplantTemplateGroup Field
Implant Template Group Storage (1.2.840.10008.5.1.4.45.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ImplantTemplateGroup As UID
'Usage

Dim value As UID

value = SOPClasses.ImplantTemplateGroup
public static readonly UID ImplantTemplateGroup
public:
static readonly UID^ ImplantTemplateGroup
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ImplantTemplateGroupQRFIND Field

ImplantTemplateGroupQRFIND Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ImplantTemplateGroupQRFIND Field
Implant Template Group Information Model - FIND (1.2.840.10008.5.1.4.45.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ImplantTemplateGroupQRFIND As UID
'Usage

Dim value As UID

value = SOPClasses.ImplantTemplateGroupQRFIND
public static readonly UID ImplantTemplateGroupQRFIND
public:
static readonly UID^ ImplantTemplateGroupQRFIND
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ImplantTemplateGroupQRGET Field

ImplantTemplateGroupQRGET Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ImplantTemplateGroupQRGET Field
Implant Template Group Information Model - GET (1.2.840.10008.5.1.4.45.4)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ImplantTemplateGroupQRGET As UID
'Usage

Dim value As UID

value = SOPClasses.ImplantTemplateGroupQRGET
public static readonly UID ImplantTemplateGroupQRGET
public:
static readonly UID^ ImplantTemplateGroupQRGET
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ImplantTemplateGroupQRMOVE Field

ImplantTemplateGroupQRMOVE Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ImplantTemplateGroupQRMOVE Field
Implant Template Group Information Model - MOVE (1.2.840.10008.5.1.4.45.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ImplantTemplateGroupQRMOVE As UID
'Usage

Dim value As UID

value = SOPClasses.ImplantTemplateGroupQRMOVE
public static readonly UID ImplantTemplateGroupQRMOVE
public:
static readonly UID^ ImplantTemplateGroupQRMOVE
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


InstanceAvailabilityNotification Field

InstanceAvailabilityNotification Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : InstanceAvailabilityNotification Field
Instance Availability Notification SOP Class (1.2.840.10008.5.1.4.33)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly InstanceAvailabilityNotification As UID
'Usage

Dim value As UID

value = SOPClasses.InstanceAvailabilityNotification
public static readonly UID InstanceAvailabilityNotification
public:
static readonly UID^ InstanceAvailabilityNotification
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


IntraocularLensCalculations Field

IntraocularLensCalculations Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : IntraocularLensCalculations Field
Intraocular Lens Calculations Storage (1.2.840.10008.5.1.4.1.1.78.8)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly IntraocularLensCalculations As UID
'Usage

Dim value As UID

value = SOPClasses.IntraocularLensCalculations
public static readonly UID IntraocularLensCalculations
public:
static readonly UID^ IntraocularLensCalculations
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


IntravascularOpticalCoherenceTomographyImageForPresentation Field

IntravascularOpticalCoherenceTomographyImageForPresentation Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : IntravascularOpticalCoherenceTomographyImageForPresentation Field
Intravascular Optical Coherence Tomography Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.14.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly IntravascularOpticalCoherenceTomographyImageForPresentation As UID
'Usage

Dim value As UID

value = SOPClasses.IntravascularOpticalCoherenceTomographyImageForPresentation
public static readonly UID IntravascularOpticalCoherenceTomographyImageForPresentation
public:
static readonly UID^ IntravascularOpticalCoherenceTomographyImageForPresentation
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


IntravascularOpticalCoherenceTomographyImageForProcessing Field

IntravascularOpticalCoherenceTomographyImageForProcessing Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : IntravascularOpticalCoherenceTomographyImageForProcessing Field
Intravascular Optical Coherence Tomography Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.14.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly IntravascularOpticalCoherenceTomographyImageForProcessing As UID
'Usage

Dim value As UID

value = SOPClasses.IntravascularOpticalCoherenceTomographyImageForProcessing
public static readonly UID IntravascularOpticalCoherenceTomographyImageForProcessing
public:
static readonly UID^ IntravascularOpticalCoherenceTomographyImageForProcessing
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


KeratometryMeasurements Field

KeratometryMeasurements Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : KeratometryMeasurements Field
Keratometry Measurements Storage (1.2.840.10008.5.1.4.1.1.78.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly KeratometryMeasurements As UID
'Usage

Dim value As UID

value = SOPClasses.KeratometryMeasurements
public static readonly UID KeratometryMeasurements
public:
static readonly UID^ KeratometryMeasurements
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


KeyObjectSelectionDocument Field

KeyObjectSelectionDocument Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : KeyObjectSelectionDocument Field
Key Object Selection Document Storage (1.2.840.10008.5.1.4.1.1.88.59)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly KeyObjectSelectionDocument As UID
'Usage

Dim value As UID

value = SOPClasses.KeyObjectSelectionDocument
public static readonly UID KeyObjectSelectionDocument
public:
static readonly UID^ KeyObjectSelectionDocument
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


LegacyConvertedEnhancedCT Field

LegacyConvertedEnhancedCT Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : LegacyConvertedEnhancedCT Field
Legacy Converted Enhanced CT Image Storage (1.2.840.10008.5.1.4.1.1.2.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly LegacyConvertedEnhancedCT As UID
'Usage

Dim value As UID

value = SOPClasses.LegacyConvertedEnhancedCT
public static readonly UID LegacyConvertedEnhancedCT
public:
static readonly UID^ LegacyConvertedEnhancedCT
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


LegacyConvertedEnhancedMRColorImage Field

LegacyConvertedEnhancedMRColorImage Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : LegacyConvertedEnhancedMRColorImage Field
Legacy Converted Enhanced MR Image Storage (1.2.840.10008.5.1.4.1.1.4.4)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly LegacyConvertedEnhancedMRColorImage As UID
'Usage

Dim value As UID

value = SOPClasses.LegacyConvertedEnhancedMRColorImage
public static readonly UID LegacyConvertedEnhancedMRColorImage
public:
static readonly UID^ LegacyConvertedEnhancedMRColorImage
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


LegacyConvertedEnhancedPETImage Field

LegacyConvertedEnhancedPETImage Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : LegacyConvertedEnhancedPETImage Field
Legacy Converted Enhanced PET Image Storage (1.2.840.10008.5.1.4.1.1.128.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly LegacyConvertedEnhancedPETImage As UID
'Usage

Dim value As UID

value = SOPClasses.LegacyConvertedEnhancedPETImage
public static readonly UID LegacyConvertedEnhancedPETImage
public:
static readonly UID^ LegacyConvertedEnhancedPETImage
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


LensometryMeasurements Field

LensometryMeasurements Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : LensometryMeasurements Field
Lensometry Measurements Storage (1.2.840.10008.5.1.4.1.1.78.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly LensometryMeasurements As UID
'Usage

Dim value As UID

value = SOPClasses.LensometryMeasurements
public static readonly UID LensometryMeasurements
public:
static readonly UID^ LensometryMeasurements
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


MacularGridThicknessandVolumeReport Field

MacularGridThicknessandVolumeReport Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : MacularGridThicknessandVolumeReport Field
Macular Grid Thickness and Volume Report Storage (1.2.840.10008.5.1.4.1.1.79.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly MacularGridThicknessandVolumeReport As UID
'Usage

Dim value As UID

value = SOPClasses.MacularGridThicknessandVolumeReport
public static readonly UID MacularGridThicknessandVolumeReport
public:
static readonly UID^ MacularGridThicknessandVolumeReport
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


MammographyCADSR Field

MammographyCADSR Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : MammographyCADSR Field
Mammography CAD SR Storage (1.2.840.10008.5.1.4.1.1.88.50)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly MammographyCADSR As UID
'Usage

Dim value As UID

value = SOPClasses.MammographyCADSR
public static readonly UID MammographyCADSR
public:
static readonly UID^ MammographyCADSR
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


MediaCreationManagementUID Field

MediaCreationManagementUID Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : MediaCreationManagementUID Field
Media Creation Management SOP Class UID (1.2.840.10008.5.1.1.33)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly MediaCreationManagementUID As UID
'Usage

Dim value As UID

value = SOPClasses.MediaCreationManagementUID
public static readonly UID MediaCreationManagementUID
public:
static readonly UID^ MediaCreationManagementUID
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


MediaStorageDirectory Field

MediaStorageDirectory Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : MediaStorageDirectory Field
Media Storage Directory Storage (1.2.840.10008.1.3.10)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly MediaStorageDirectory As UID
'Usage

Dim value As UID

value = SOPClasses.MediaStorageDirectory
public static readonly UID MediaStorageDirectory
public:
static readonly UID^ MediaStorageDirectory
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ModalityPerformedProcedureStep Field

ModalityPerformedProcedureStep Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ModalityPerformedProcedureStep Field
Modality Performed Procedure Step SOP Class (1.2.840.10008.3.1.2.3.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ModalityPerformedProcedureStep As UID
'Usage

Dim value As UID

value = SOPClasses.ModalityPerformedProcedureStep
public static readonly UID ModalityPerformedProcedureStep
public:
static readonly UID^ ModalityPerformedProcedureStep
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ModalityPerformedProcedureStepNotification Field

ModalityPerformedProcedureStepNotification Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ModalityPerformedProcedureStepNotification Field
Modality Performed Procedure Step Notification SOP Class (1.2.840.10008.3.1.2.3.5)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ModalityPerformedProcedureStepNotification As UID
'Usage

Dim value As UID

value = SOPClasses.ModalityPerformedProcedureStepNotification
public static readonly UID ModalityPerformedProcedureStepNotification
public:
static readonly UID^ ModalityPerformedProcedureStepNotification
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ModalityPerformedProcedureStepRetrieve Field

ModalityPerformedProcedureStepRetrieve Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ModalityPerformedProcedureStepRetrieve Field
Modality Performed Procedure Step Retrieve SOP Class (1.2.840.10008.3.1.2.3.4)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ModalityPerformedProcedureStepRetrieve As UID
'Usage

Dim value As UID

value = SOPClasses.ModalityPerformedProcedureStepRetrieve
public static readonly UID ModalityPerformedProcedureStepRetrieve
public:
static readonly UID^ ModalityPerformedProcedureStepRetrieve
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ModalityWorklistQRFIND Field

ModalityWorklistQRFIND Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ModalityWorklistQRFIND Field
Modality Worklist Information Model - FIND (1.2.840.10008.5.1.4.31)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ModalityWorklistQRFIND As UID
'Usage

Dim value As UID

value = SOPClasses.ModalityWorklistQRFIND
public static readonly UID ModalityWorklistQRFIND
public:
static readonly UID^ ModalityWorklistQRFIND
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


MR Field

MR Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : MR Field
MR Image Storage (1.2.840.10008.5.1.4.1.1.4)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly MR As UID
'Usage

Dim value As UID

value = SOPClasses.MR
public static readonly UID MR
public:
static readonly UID^ MR
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


MRSpectroscopy Field

MRSpectroscopy Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : MRSpectroscopy Field
MR Spectroscopy Storage (1.2.840.10008.5.1.4.1.1.4.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly MRSpectroscopy As UID
'Usage

Dim value As UID

value = SOPClasses.MRSpectroscopy
public static readonly UID MRSpectroscopy
public:
static readonly UID^ MRSpectroscopy
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


MultiFrameGrayscaleByteSC Field

MultiFrameGrayscaleByteSC Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : MultiFrameGrayscaleByteSC Field
Multi-frame Grayscale Byte Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly MultiFrameGrayscaleByteSC As UID
'Usage

Dim value As UID

value = SOPClasses.MultiFrameGrayscaleByteSC
public static readonly UID MultiFrameGrayscaleByteSC
public:
static readonly UID^ MultiFrameGrayscaleByteSC
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


MultiFrameGrayscaleWordSC Field

MultiFrameGrayscaleWordSC Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : MultiFrameGrayscaleWordSC Field
Multi-frame Grayscale Word Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly MultiFrameGrayscaleWordSC As UID
'Usage

Dim value As UID

value = SOPClasses.MultiFrameGrayscaleWordSC
public static readonly UID MultiFrameGrayscaleWordSC
public:
static readonly UID^ MultiFrameGrayscaleWordSC
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


MultiFrameSingleBitSC Field

MultiFrameSingleBitSC Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : MultiFrameSingleBitSC Field
Multi-frame Single Bit Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly MultiFrameSingleBitSC As UID
'Usage

Dim value As UID

value = SOPClasses.MultiFrameSingleBitSC
public static readonly UID MultiFrameSingleBitSC
public:
static readonly UID^ MultiFrameSingleBitSC
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


MultiFrameTrueColorSC Field

MultiFrameTrueColorSC Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : MultiFrameTrueColorSC Field
Multi-frame True Color Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.4)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly MultiFrameTrueColorSC As UID
'Usage

Dim value As UID

value = SOPClasses.MultiFrameTrueColorSC
public static readonly UID MultiFrameTrueColorSC
public:
static readonly UID^ MultiFrameTrueColorSC
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


NuclearMedicine Field

NuclearMedicine Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : NuclearMedicine Field
Nuclear Medicine Image Storage (1.2.840.10008.5.1.4.1.1.20)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly NuclearMedicine As UID
'Usage

Dim value As UID

value = SOPClasses.NuclearMedicine
public static readonly UID NuclearMedicine
public:
static readonly UID^ NuclearMedicine
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


OphthalmicAxialMeasurements Field

OphthalmicAxialMeasurements Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : OphthalmicAxialMeasurements Field
Ophthalmic Axial Measurements Storage (1.2.840.10008.5.1.4.1.1.78.7)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly OphthalmicAxialMeasurements As UID
'Usage

Dim value As UID

value = SOPClasses.OphthalmicAxialMeasurements
public static readonly UID OphthalmicAxialMeasurements
public:
static readonly UID^ OphthalmicAxialMeasurements
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


OphthalmicPhotography16Bit Field

OphthalmicPhotography16Bit Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : OphthalmicPhotography16Bit Field
Ophthalmic Photography 16 Bit Image Storage (1.2.840.10008.5.1.4.1.1.77.1.5.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly OphthalmicPhotography16Bit As UID
'Usage

Dim value As UID

value = SOPClasses.OphthalmicPhotography16Bit
public static readonly UID OphthalmicPhotography16Bit
public:
static readonly UID^ OphthalmicPhotography16Bit
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


OphthalmicPhotography8Bit Field

OphthalmicPhotography8Bit Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : OphthalmicPhotography8Bit Field
Ophthalmic Photography 8 Bit Image Storage (1.2.840.10008.5.1.4.1.1.77.1.5.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly OphthalmicPhotography8Bit As UID
'Usage

Dim value As UID

value = SOPClasses.OphthalmicPhotography8Bit
public static readonly UID OphthalmicPhotography8Bit
public:
static readonly UID^ OphthalmicPhotography8Bit
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


OphthalmicThicknessMap Field

OphthalmicThicknessMap Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : OphthalmicThicknessMap Field
Ophthalmic Thickness Map Storage (1.2.840.10008.5.1.4.1.1.81.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly OphthalmicThicknessMap As UID
'Usage

Dim value As UID

value = SOPClasses.OphthalmicThicknessMap
public static readonly UID OphthalmicThicknessMap
public:
static readonly UID^ OphthalmicThicknessMap
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


OphthalmicTomographyImage Field

OphthalmicTomographyImage Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : OphthalmicTomographyImage Field
Ophthalmic Tomography Image Storage (1.2.840.10008.5.1.4.1.1.77.1.5.4)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly OphthalmicTomographyImage As UID
'Usage

Dim value As UID

value = SOPClasses.OphthalmicTomographyImage
public static readonly UID OphthalmicTomographyImage
public:
static readonly UID^ OphthalmicTomographyImage
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


OphthalmicVisualFieldStaticPerimetryMeasurements Field

OphthalmicVisualFieldStaticPerimetryMeasurements Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : OphthalmicVisualFieldStaticPerimetryMeasurements Field
Ophthalmic Visual Field Static Perimetry Measurements Storage (1.2.840.10008.5.1.4.1.1.80.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly OphthalmicVisualFieldStaticPerimetryMeasurements As UID
'Usage

Dim value As UID

value = SOPClasses.OphthalmicVisualFieldStaticPerimetryMeasurements
public static readonly UID OphthalmicVisualFieldStaticPerimetryMeasurements
public:
static readonly UID^ OphthalmicVisualFieldStaticPerimetryMeasurements
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


PatientRootQR_FIND Field

PatientRootQR_FIND Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : PatientRootQR_FIND Field
Patient Root Query/Retrieve Information Model - FIND (1.2.840.10008.5.1.4.1.2.1.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly PatientRootQR_FIND As UID
'Usage

Dim value As UID

value = SOPClasses.PatientRootQR_FIND
public static readonly UID PatientRootQR_FIND
public:
static readonly UID^ PatientRootQR_FIND
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


PatientRootQR_GET Field

PatientRootQR_GET Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : PatientRootQR_GET Field
Patient Root Query/Retrieve Information Model - GET (1.2.840.10008.5.1.4.1.2.1.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly PatientRootQR_GET As UID
'Usage

Dim value As UID

value = SOPClasses.PatientRootQR_GET
public static readonly UID PatientRootQR_GET
public:
static readonly UID^ PatientRootQR_GET
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


PatientRootQR_MOVE Field

PatientRootQR_MOVE Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : PatientRootQR_MOVE Field
Patient Root Query/Retrieve Information Model - MOVE (1.2.840.10008.5.1.4.1.2.1.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly PatientRootQR_MOVE As UID
'Usage

Dim value As UID

value = SOPClasses.PatientRootQR_MOVE
public static readonly UID PatientRootQR_MOVE
public:
static readonly UID^ PatientRootQR_MOVE
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


PositronEmissionTomography Field

PositronEmissionTomography Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : PositronEmissionTomography Field
Positron Emission Tomography Image Storage (1.2.840.10008.5.1.4.1.1.128)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly PositronEmissionTomography As UID
'Usage

Dim value As UID

value = SOPClasses.PositronEmissionTomography
public static readonly UID PositronEmissionTomography
public:
static readonly UID^ PositronEmissionTomography
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


PresentationLUT Field

PresentationLUT Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : PresentationLUT Field
Presentation LUT SOP Class (1.2.840.10008.5.1.1.23)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly PresentationLUT As UID
'Usage

Dim value As UID

value = SOPClasses.PresentationLUT
public static readonly UID PresentationLUT
public:
static readonly UID^ PresentationLUT
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


Printer Field (SOPClasses)

Printer Field (SOPClasses)

DicomObjects.DicomUIDs Namespace > SOPClasses Class : Printer Field
Printer SOP Class (1.2.840.10008.5.1.1.16)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Printer As UID
'Usage

Dim value As UID

value = SOPClasses.Printer
public static readonly UID Printer
public:
static readonly UID^ Printer
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


PrinterConfigurationRetrieval Field (SOPClasses)

PrinterConfigurationRetrieval Field (SOPClasses)

DicomObjects.DicomUIDs Namespace > SOPClasses Class : PrinterConfigurationRetrieval Field
Printer Configuration Retrieval SOP Class (1.2.840.10008.5.1.1.16.376)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly PrinterConfigurationRetrieval As UID
'Usage

Dim value As UID

value = SOPClasses.PrinterConfigurationRetrieval
public static readonly UID PrinterConfigurationRetrieval
public:
static readonly UID^ PrinterConfigurationRetrieval
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


PrintJob Field

PrintJob Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : PrintJob Field
Print Job SOP Class (1.2.840.10008.5.1.1.14)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly PrintJob As UID
'Usage

Dim value As UID

value = SOPClasses.PrintJob
public static readonly UID PrintJob
public:
static readonly UID^ PrintJob
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ProceduralEventLogging Field

ProceduralEventLogging Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ProceduralEventLogging Field
Procedural Event Logging SOP Class (1.2.840.10008.1.40)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ProceduralEventLogging As UID
'Usage

Dim value As UID

value = SOPClasses.ProceduralEventLogging
public static readonly UID ProceduralEventLogging
public:
static readonly UID^ ProceduralEventLogging
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ProcedureLog Field

ProcedureLog Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ProcedureLog Field
Procedure Log Storage (1.2.840.10008.5.1.4.1.1.88.40)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ProcedureLog As UID
'Usage

Dim value As UID

value = SOPClasses.ProcedureLog
public static readonly UID ProcedureLog
public:
static readonly UID^ ProcedureLog
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


ProductCharacteristicsQuery Field

ProductCharacteristicsQuery Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : ProductCharacteristicsQuery Field
Product Characteristics Query SOP Class (1.2.840.10008.5.1.4.41)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ProductCharacteristicsQuery As UID
'Usage

Dim value As UID

value = SOPClasses.ProductCharacteristicsQuery
public static readonly UID ProductCharacteristicsQuery
public:
static readonly UID^ ProductCharacteristicsQuery
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


PseudoColorSoftcopyPresentationState Field

PseudoColorSoftcopyPresentationState Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : PseudoColorSoftcopyPresentationState Field
Pseudo-Color Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly PseudoColorSoftcopyPresentationState As UID
'Usage

Dim value As UID

value = SOPClasses.PseudoColorSoftcopyPresentationState
public static readonly UID PseudoColorSoftcopyPresentationState
public:
static readonly UID^ PseudoColorSoftcopyPresentationState
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


RawData Field

RawData Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : RawData Field
Raw Data Storage (1.2.840.10008.5.1.4.1.1.66)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly RawData As UID
'Usage

Dim value As UID

value = SOPClasses.RawData
public static readonly UID RawData
public:
static readonly UID^ RawData
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


RealWorldValueMapping Field

RealWorldValueMapping Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : RealWorldValueMapping Field
Real World Value Mapping Storage (1.2.840.10008.5.1.4.1.1.67)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly RealWorldValueMapping As UID
'Usage

Dim value As UID

value = SOPClasses.RealWorldValueMapping
public static readonly UID RealWorldValueMapping
public:
static readonly UID^ RealWorldValueMapping
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


RespiratoryWaveform Field

RespiratoryWaveform Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : RespiratoryWaveform Field
Respiratory Waveform Storage (1.2.840.10008.5.1.4.1.1.9.6.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly RespiratoryWaveform As UID
'Usage

Dim value As UID

value = SOPClasses.RespiratoryWaveform
public static readonly UID RespiratoryWaveform
public:
static readonly UID^ RespiratoryWaveform
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


RT Field

RT Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : RT Field
RT Image Storage (1.2.840.10008.5.1.4.1.1.481.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly RT As UID
'Usage

Dim value As UID

value = SOPClasses.RT
public static readonly UID RT
public:
static readonly UID^ RT
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


RTBeamsDeliveryInstruction Field

RTBeamsDeliveryInstruction Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : RTBeamsDeliveryInstruction Field
RT Beams Delivery Instruction Storage (1.2.840.10008.5.1.4.34.7)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly RTBeamsDeliveryInstruction As UID
'Usage

Dim value As UID

value = SOPClasses.RTBeamsDeliveryInstruction
public static readonly UID RTBeamsDeliveryInstruction
public:
static readonly UID^ RTBeamsDeliveryInstruction
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


RTBeamsTreatmentRecord Field

RTBeamsTreatmentRecord Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : RTBeamsTreatmentRecord Field
RT Beams Treatment Record Storage (1.2.840.10008.5.1.4.1.1.481.4)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly RTBeamsTreatmentRecord As UID
'Usage

Dim value As UID

value = SOPClasses.RTBeamsTreatmentRecord
public static readonly UID RTBeamsTreatmentRecord
public:
static readonly UID^ RTBeamsTreatmentRecord
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


RTBrachyTreatmentRecord Field

RTBrachyTreatmentRecord Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : RTBrachyTreatmentRecord Field
RT Brachy Treatment Record Storage (1.2.840.10008.5.1.4.1.1.481.6)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly RTBrachyTreatmentRecord As UID
'Usage

Dim value As UID

value = SOPClasses.RTBrachyTreatmentRecord
public static readonly UID RTBrachyTreatmentRecord
public:
static readonly UID^ RTBrachyTreatmentRecord
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


RTConventionalMachineVerification Field

RTConventionalMachineVerification Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : RTConventionalMachineVerification Field
RT Conventional Machine Verification (1.2.840.10008.5.1.4.34.8)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly RTConventionalMachineVerification As UID
'Usage

Dim value As UID

value = SOPClasses.RTConventionalMachineVerification
public static readonly UID RTConventionalMachineVerification
public:
static readonly UID^ RTConventionalMachineVerification
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


RTDose Field

RTDose Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : RTDose Field
RT Dose Storage (1.2.840.10008.5.1.4.1.1.481.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly RTDose As UID
'Usage

Dim value As UID

value = SOPClasses.RTDose
public static readonly UID RTDose
public:
static readonly UID^ RTDose
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


RTIonBeamsTreatmentRecord Field

RTIonBeamsTreatmentRecord Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : RTIonBeamsTreatmentRecord Field
RT Ion Beams Treatment Record Storage (1.2.840.10008.5.1.4.1.1.481.9)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly RTIonBeamsTreatmentRecord As UID
'Usage

Dim value As UID

value = SOPClasses.RTIonBeamsTreatmentRecord
public static readonly UID RTIonBeamsTreatmentRecord
public:
static readonly UID^ RTIonBeamsTreatmentRecord
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


RTIonMachineVerification Field

RTIonMachineVerification Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : RTIonMachineVerification Field
RT Ion Machine Verification (1.2.840.10008.5.1.4.34.9)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly RTIonMachineVerification As UID
'Usage

Dim value As UID

value = SOPClasses.RTIonMachineVerification
public static readonly UID RTIonMachineVerification
public:
static readonly UID^ RTIonMachineVerification
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


RTIonPlan Field

RTIonPlan Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : RTIonPlan Field
RT Ion Plan Storage (1.2.840.10008.5.1.4.1.1.481.8)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly RTIonPlan As UID
'Usage

Dim value As UID

value = SOPClasses.RTIonPlan
public static readonly UID RTIonPlan
public:
static readonly UID^ RTIonPlan
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


RTPlan Field

RTPlan Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : RTPlan Field
RT Plan Storage (1.2.840.10008.5.1.4.1.1.481.5)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly RTPlan As UID
'Usage

Dim value As UID

value = SOPClasses.RTPlan
public static readonly UID RTPlan
public:
static readonly UID^ RTPlan
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


RTStructureSet Field

RTStructureSet Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : RTStructureSet Field
RT Structure Set Storage (1.2.840.10008.5.1.4.1.1.481.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly RTStructureSet As UID
'Usage

Dim value As UID

value = SOPClasses.RTStructureSet
public static readonly UID RTStructureSet
public:
static readonly UID^ RTStructureSet
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


RTTreatmentSummaryRecord Field

RTTreatmentSummaryRecord Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : RTTreatmentSummaryRecord Field
RT Treatment Summary Record Storage (1.2.840.10008.5.1.4.1.1.481.7)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly RTTreatmentSummaryRecord As UID
'Usage

Dim value As UID

value = SOPClasses.RTTreatmentSummaryRecord
public static readonly UID RTTreatmentSummaryRecord
public:
static readonly UID^ RTTreatmentSummaryRecord
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


SecondaryCapture Field

SecondaryCapture Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : SecondaryCapture Field
Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SecondaryCapture As UID
'Usage

Dim value As UID

value = SOPClasses.SecondaryCapture
public static readonly UID SecondaryCapture
public:
static readonly UID^ SecondaryCapture
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


Segmentation Field

Segmentation Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : Segmentation Field
Segmentation Storage (1.2.840.10008.5.1.4.1.1.66.4)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Segmentation As UID
'Usage

Dim value As UID

value = SOPClasses.Segmentation
public static readonly UID Segmentation
public:
static readonly UID^ Segmentation
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


SpatialFiducials Field

SpatialFiducials Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : SpatialFiducials Field
Spatial Fiducials Storage (1.2.840.10008.5.1.4.1.1.66.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SpatialFiducials As UID
'Usage

Dim value As UID

value = SOPClasses.SpatialFiducials
public static readonly UID SpatialFiducials
public:
static readonly UID^ SpatialFiducials
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


SpatialRegistration Field

SpatialRegistration Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : SpatialRegistration Field
Spatial Registration Storage (1.2.840.10008.5.1.4.1.1.66.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SpatialRegistration As UID
'Usage

Dim value As UID

value = SOPClasses.SpatialRegistration
public static readonly UID SpatialRegistration
public:
static readonly UID^ SpatialRegistration
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


SpectaclePrescriptionReport Field

SpectaclePrescriptionReport Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : SpectaclePrescriptionReport Field
Spectacle Prescription Report Storage (1.2.840.10008.5.1.4.1.1.78.6)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SpectaclePrescriptionReport As UID
'Usage

Dim value As UID

value = SOPClasses.SpectaclePrescriptionReport
public static readonly UID SpectaclePrescriptionReport
public:
static readonly UID^ SpectaclePrescriptionReport
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


StereometricRelationship Field

StereometricRelationship Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : StereometricRelationship Field
Stereometric Relationship Storage (1.2.840.10008.5.1.4.1.1.77.1.5.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly StereometricRelationship As UID
'Usage

Dim value As UID

value = SOPClasses.StereometricRelationship
public static readonly UID StereometricRelationship
public:
static readonly UID^ StereometricRelationship
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


StorageCommitmentPush Field (SOPClasses)

StorageCommitmentPush Field (SOPClasses)

DicomObjects.DicomUIDs Namespace > SOPClasses Class : StorageCommitmentPush Field
Storage Commitment Push Model SOP Class (1.2.840.10008.1.20.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly StorageCommitmentPush As UID
'Usage

Dim value As UID

value = SOPClasses.StorageCommitmentPush
public static readonly UID StorageCommitmentPush
public:
static readonly UID^ StorageCommitmentPush
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


StorageServiceClass Field

StorageServiceClass Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : StorageServiceClass Field
Storage Service Class (1.2.840.10008.4.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly StorageServiceClass As UID
'Usage

Dim value As UID

value = SOPClasses.StorageServiceClass
public static readonly UID StorageServiceClass
public:
static readonly UID^ StorageServiceClass
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


StudyRootQR_FIND Field

StudyRootQR_FIND Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : StudyRootQR_FIND Field
Study Root Query/Retrieve Information Model - FIND (1.2.840.10008.5.1.4.1.2.2.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly StudyRootQR_FIND As UID
'Usage

Dim value As UID

value = SOPClasses.StudyRootQR_FIND
public static readonly UID StudyRootQR_FIND
public:
static readonly UID^ StudyRootQR_FIND
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


StudyRootQR_GET Field

StudyRootQR_GET Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : StudyRootQR_GET Field
Study Root Query/Retrieve Information Model - GET (1.2.840.10008.5.1.4.1.2.2.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly StudyRootQR_GET As UID
'Usage

Dim value As UID

value = SOPClasses.StudyRootQR_GET
public static readonly UID StudyRootQR_GET
public:
static readonly UID^ StudyRootQR_GET
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


StudyRootQR_MOVE Field

StudyRootQR_MOVE Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : StudyRootQR_MOVE Field
Study Root Query/Retrieve Information Model - MOVE (1.2.840.10008.5.1.4.1.2.2.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly StudyRootQR_MOVE As UID
'Usage

Dim value As UID

value = SOPClasses.StudyRootQR_MOVE
public static readonly UID StudyRootQR_MOVE
public:
static readonly UID^ StudyRootQR_MOVE
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


SubjectiveRefractionMeasurements Field

SubjectiveRefractionMeasurements Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : SubjectiveRefractionMeasurements Field
Subjective Refraction Measurements Storage (1.2.840.10008.5.1.4.1.1.78.4)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SubjectiveRefractionMeasurements As UID
'Usage

Dim value As UID

value = SOPClasses.SubjectiveRefractionMeasurements
public static readonly UID SubjectiveRefractionMeasurements
public:
static readonly UID^ SubjectiveRefractionMeasurements
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


SubstanceAdministrationLogging Field

SubstanceAdministrationLogging Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : SubstanceAdministrationLogging Field
Substance Administration Logging SOP Class (1.2.840.10008.1.42)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SubstanceAdministrationLogging As UID
'Usage

Dim value As UID

value = SOPClasses.SubstanceAdministrationLogging
public static readonly UID SubstanceAdministrationLogging
public:
static readonly UID^ SubstanceAdministrationLogging
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


SubstanceApprovalQuery Field

SubstanceApprovalQuery Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : SubstanceApprovalQuery Field
Substance Approval Query SOP Class (1.2.840.10008.5.1.4.42)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SubstanceApprovalQuery As UID
'Usage

Dim value As UID

value = SOPClasses.SubstanceApprovalQuery
public static readonly UID SubstanceApprovalQuery
public:
static readonly UID^ SubstanceApprovalQuery
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


SurfaceSegmentation Field

SurfaceSegmentation Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : SurfaceSegmentation Field
Surface Segmentation Storage (1.2.840.10008.5.1.4.1.1.66.5)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SurfaceSegmentation As UID
'Usage

Dim value As UID

value = SOPClasses.SurfaceSegmentation
public static readonly UID SurfaceSegmentation
public:
static readonly UID^ SurfaceSegmentation
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


TwelveLeadECGWaveform Field

TwelveLeadECGWaveform Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : TwelveLeadECGWaveform Field
12-lead ECG Waveform Storage (1.2.840.10008.5.1.4.1.1.9.1.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly TwelveLeadECGWaveform As UID
'Usage

Dim value As UID

value = SOPClasses.TwelveLeadECGWaveform
public static readonly UID TwelveLeadECGWaveform
public:
static readonly UID^ TwelveLeadECGWaveform
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


Ultrasound Field

Ultrasound Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : Ultrasound Field
Ultrasound Image Storage (1.2.840.10008.5.1.4.1.1.6.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Ultrasound As UID
'Usage

Dim value As UID

value = SOPClasses.Ultrasound
public static readonly UID Ultrasound
public:
static readonly UID^ Ultrasound
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


UltrasoundMultiframe Field

UltrasoundMultiframe Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : UltrasoundMultiframe Field
Ultrasound Multi-frame Image Storage (1.2.840.10008.5.1.4.1.1.3.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly UltrasoundMultiframe As UID
'Usage

Dim value As UID

value = SOPClasses.UltrasoundMultiframe
public static readonly UID UltrasoundMultiframe
public:
static readonly UID^ UltrasoundMultiframe
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


UnifiedProcedureStepEvent Field

UnifiedProcedureStepEvent Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : UnifiedProcedureStepEvent Field
Unified Procedure Step - Event SOP Class (1.2.840.10008.5.1.4.34.6.4)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly UnifiedProcedureStepEvent As UID
'Usage

Dim value As UID

value = SOPClasses.UnifiedProcedureStepEvent
public static readonly UID UnifiedProcedureStepEvent
public:
static readonly UID^ UnifiedProcedureStepEvent
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


UnifiedProcedureStepPull Field

UnifiedProcedureStepPull Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : UnifiedProcedureStepPull Field
Unified Procedure Step - Pull SOP Class (1.2.840.10008.5.1.4.34.6.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly UnifiedProcedureStepPull As UID
'Usage

Dim value As UID

value = SOPClasses.UnifiedProcedureStepPull
public static readonly UID UnifiedProcedureStepPull
public:
static readonly UID^ UnifiedProcedureStepPull
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


UnifiedProcedureStepPush Field

UnifiedProcedureStepPush Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : UnifiedProcedureStepPush Field
Unified Procedure Step - Push SOP Class (1.2.840.10008.5.1.4.34.6.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly UnifiedProcedureStepPush As UID
'Usage

Dim value As UID

value = SOPClasses.UnifiedProcedureStepPush
public static readonly UID UnifiedProcedureStepPush
public:
static readonly UID^ UnifiedProcedureStepPush
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


UnifiedProcedureStepWatch Field

UnifiedProcedureStepWatch Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : UnifiedProcedureStepWatch Field
Unified Procedure Step - Watch SOP Class (1.2.840.10008.5.1.4.34.6.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly UnifiedProcedureStepWatch As UID
'Usage

Dim value As UID

value = SOPClasses.UnifiedProcedureStepWatch
public static readonly UID UnifiedProcedureStepWatch
public:
static readonly UID^ UnifiedProcedureStepWatch
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


UnifiedWorklistandProcedureStepServiceClass Field

UnifiedWorklistandProcedureStepServiceClass Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : UnifiedWorklistandProcedureStepServiceClass Field
Unified Worklist and Procedure Step Service Class (1.2.840.10008.5.1.4.34.6)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly UnifiedWorklistandProcedureStepServiceClass As UID
'Usage

Dim value As UID

value = SOPClasses.UnifiedWorklistandProcedureStepServiceClass
public static readonly UID UnifiedWorklistandProcedureStepServiceClass
public:
static readonly UID^ UnifiedWorklistandProcedureStepServiceClass
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


Verification Field

Verification Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : Verification Field
Verification SOP Class (1.2.840.10008.1.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Verification As UID
'Usage

Dim value As UID

value = SOPClasses.Verification
public static readonly UID Verification
public:
static readonly UID^ Verification
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


VideoEndoscopic Field

VideoEndoscopic Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : VideoEndoscopic Field
Video Endoscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.1.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly VideoEndoscopic As UID
'Usage

Dim value As UID

value = SOPClasses.VideoEndoscopic
public static readonly UID VideoEndoscopic
public:
static readonly UID^ VideoEndoscopic
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


VideoMicroscopic Field

VideoMicroscopic Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : VideoMicroscopic Field
Video Microscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.2.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly VideoMicroscopic As UID
'Usage

Dim value As UID

value = SOPClasses.VideoMicroscopic
public static readonly UID VideoMicroscopic
public:
static readonly UID^ VideoMicroscopic
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


VideoPhotographic Field

VideoPhotographic Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : VideoPhotographic Field
Video Photographic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.4.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly VideoPhotographic As UID
'Usage

Dim value As UID

value = SOPClasses.VideoPhotographic
public static readonly UID VideoPhotographic
public:
static readonly UID^ VideoPhotographic
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


VisualAcuityMeasurements Field

VisualAcuityMeasurements Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : VisualAcuityMeasurements Field
Visual Acuity Measurements Storage (1.2.840.10008.5.1.4.1.1.78.5)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly VisualAcuityMeasurements As UID
'Usage

Dim value As UID

value = SOPClasses.VisualAcuityMeasurements
public static readonly UID VisualAcuityMeasurements
public:
static readonly UID^ VisualAcuityMeasurements
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


VLEndoscopic Field

VLEndoscopic Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : VLEndoscopic Field
VL Endoscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly VLEndoscopic As UID
'Usage

Dim value As UID

value = SOPClasses.VLEndoscopic
public static readonly UID VLEndoscopic
public:
static readonly UID^ VLEndoscopic
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


VLMicroscopic Field

VLMicroscopic Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : VLMicroscopic Field
VL Microscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly VLMicroscopic As UID
'Usage

Dim value As UID

value = SOPClasses.VLMicroscopic
public static readonly UID VLMicroscopic
public:
static readonly UID^ VLMicroscopic
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


VLPhotographic Field

VLPhotographic Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : VLPhotographic Field
VL Photographic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.4)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly VLPhotographic As UID
'Usage

Dim value As UID

value = SOPClasses.VLPhotographic
public static readonly UID VLPhotographic
public:
static readonly UID^ VLPhotographic
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


VLSlideCoordinatesMicroscopic Field

VLSlideCoordinatesMicroscopic Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : VLSlideCoordinatesMicroscopic Field
VL Slide-Coordinates Microscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly VLSlideCoordinatesMicroscopic As UID
'Usage

Dim value As UID

value = SOPClasses.VLSlideCoordinatesMicroscopic
public static readonly UID VLSlideCoordinatesMicroscopic
public:
static readonly UID^ VLSlideCoordinatesMicroscopic
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


VLWholeSlideMicroscopyImage Field

VLWholeSlideMicroscopyImage Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : VLWholeSlideMicroscopyImage Field
VL Whole Slide Microscopy Image Storage (1.2.840.10008.5.1.4.1.1.77.1.6)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly VLWholeSlideMicroscopyImage As UID
'Usage

Dim value As UID

value = SOPClasses.VLWholeSlideMicroscopyImage
public static readonly UID VLWholeSlideMicroscopyImage
public:
static readonly UID^ VLWholeSlideMicroscopyImage
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


VOILUTBox Field

VOILUTBox Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : VOILUTBox Field
VOI LUT Box SOP Class (1.2.840.10008.5.1.1.22)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly VOILUTBox As UID
'Usage

Dim value As UID

value = SOPClasses.VOILUTBox
public static readonly UID VOILUTBox
public:
static readonly UID^ VOILUTBox
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


XA_XRFGrayscaleSoftcopyPresentationState Field

XA_XRFGrayscaleSoftcopyPresentationState Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : XA_XRFGrayscaleSoftcopyPresentationState Field
XA/XRF Grayscale Softcopy Presentation State Storage (1.2.840.10008.5.1.4.1.1.11.5)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly XA_XRFGrayscaleSoftcopyPresentationState As UID
'Usage

Dim value As UID

value = SOPClasses.XA_XRFGrayscaleSoftcopyPresentationState
public static readonly UID XA_XRFGrayscaleSoftcopyPresentationState
public:
static readonly UID^ XA_XRFGrayscaleSoftcopyPresentationState
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


XRay3DAngiographicImage Field

XRay3DAngiographicImage Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : XRay3DAngiographicImage Field
X-Ray 3D Angiographic Image Storage (1.2.840.10008.5.1.4.1.1.13.1.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly XRay3DAngiographicImage As UID
'Usage

Dim value As UID

value = SOPClasses.XRay3DAngiographicImage
public static readonly UID XRay3DAngiographicImage
public:
static readonly UID^ XRay3DAngiographicImage
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


XRay3DCraniofacialImage Field

XRay3DCraniofacialImage Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : XRay3DCraniofacialImage Field
X-Ray 3D Craniofacial Image Storage (1.2.840.10008.5.1.4.1.1.13.1.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly XRay3DCraniofacialImage As UID
'Usage

Dim value As UID

value = SOPClasses.XRay3DCraniofacialImage
public static readonly UID XRay3DCraniofacialImage
public:
static readonly UID^ XRay3DCraniofacialImage
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


XRayAngiographic Field

XRayAngiographic Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : XRayAngiographic Field
X-Ray Angiographic Image Storage (1.2.840.10008.5.1.4.1.1.12.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly XRayAngiographic As UID
'Usage

Dim value As UID

value = SOPClasses.XRayAngiographic
public static readonly UID XRayAngiographic
public:
static readonly UID^ XRayAngiographic
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


XRayRadiationDoseSR Field

XRayRadiationDoseSR Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : XRayRadiationDoseSR Field
X-Ray Radiation Dose SR Storage (1.2.840.10008.5.1.4.1.1.88.67)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly XRayRadiationDoseSR As UID
'Usage

Dim value As UID

value = SOPClasses.XRayRadiationDoseSR
public static readonly UID XRayRadiationDoseSR
public:
static readonly UID^ XRayRadiationDoseSR
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


XRayRadiofluoroscopic Field

XRayRadiofluoroscopic Field

DicomObjects.DicomUIDs Namespace > SOPClasses Class : XRayRadiofluoroscopic Field
X-Ray Radiofluoroscopic Image Storage (1.2.840.10008.5.1.4.1.1.12.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly XRayRadiofluoroscopic As UID
'Usage

Dim value As UID

value = SOPClasses.XRayRadiofluoroscopic
public static readonly UID XRayRadiofluoroscopic
public:
static readonly UID^ XRayRadiofluoroscopic
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

SOPClasses Class
SOPClasses Members


TransferSyntaxes Class

TransferSyntaxes Class
Members

DicomObjects.DicomUIDs Namespace : TransferSyntaxes Class
Contains UIDs for Transfer Syntax
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit NotInheritable Class TransferSyntaxes
'Usage

Dim instance As TransferSyntaxes
public static class TransferSyntaxes
public ref class TransferSyntaxes abstract sealed
Inheritance Hierarchy

System.Object
DicomObjects.DicomUIDs.TransferSyntaxes

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Members
DicomObjects.DicomUIDs Namespace


TransferSyntaxes Class Members

TransferSyntaxes Class Members
Fields

DicomObjects.DicomUIDs Namespace : TransferSyntaxes Class

The following tables list the members exposed by TransferSyntaxes.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | DeflatedExplicitVRLittleEndian | Deflated Explicit VR Little Endian (1.2.840.10008.1.2.1.99)
static (Shared in Visual Basic) | ExplicitVRBigEndian | Explicit VR Big Endian (1.2.840.10008.1.2.2)
static (Shared in Visual Basic) | ExplicitVRLittleEndian | Explicit VR Little Endian (1.2.840.10008.1.2.1)
static (Shared in Visual Basic) | ImplicitVRLittleEndian | Implicit VR Little Endian (1.2.840.10008.1.2)
static (Shared in Visual Basic) | JPEG2000Lossless | JPEG 2000 Image Compression (Lossless Only) (1.2.840.10008.1.2.4.90)
static (Shared in Visual Basic) | JPEG2000Lossy | JPEG 2000 Image Compression (1.2.840.10008.1.2.4.91)
static (Shared in Visual Basic) | JPEG2000Part2MulticomponentImageCompression | JPEG 2000 Part 2 Multi-component Image Compression (1.2.840.10008.1.2.4.93)
static (Shared in Visual Basic) | JPEG2000Part2MulticomponentImageCompressionLosslessOnly | JPEG 2000 Part 2 Multi-component Image Compression (Lossless Only) (1.2.840.10008.1.2.4.92)
static (Shared in Visual Basic) | JPEGBaseline | JPEG Baseline (Process 1) (1.2.840.10008.1.2.4.50)
static (Shared in Visual Basic) | JPEGExtended | JPEG Extended (Process 2 & 4) (1.2.840.10008.1.2.4.51)
static (Shared in Visual Basic) | JPEGLossless | JPEG Lossless, Non-Hierarchical (Process 14) (1.2.840.10008.1.2.4.57)
static (Shared in Visual Basic) | JPEGLosslessFirstOrder | JPEG Lossless, Non-Hierarchical, First-Order Prediction (Process 14 [Selection Value 1]) (1.2.840.10008.1.2.4.70)
static (Shared in Visual Basic) | JPEGLSLossless | JPEG-LS Lossless Image Compression (1.2.840.10008.1.2.4.80)
static (Shared in Visual Basic) | JPEGLSLossy | JPEG-LS Lossy (Near-Lossless) Image Compression (1.2.840.10008.1.2.4.81)
static (Shared in Visual Basic) | JPIPReferenced | JPIP Referenced (1.2.840.10008.1.2.4.94)
static (Shared in Visual Basic) | JPIPReferencedDeflate | JPIP Referenced Deflate (1.2.840.10008.1.2.4.95)
static (Shared in Visual Basic) | MPEG2 | MPEG2 Main Profile @ Main Level (1.2.840.10008.1.2.4.100)
static (Shared in Visual Basic) | MPEG2_HL | MPEG2 Main Profile @ High Level (1.2.840.10008.1.2.4.101)
static (Shared in Visual Basic) | MPEG4 | MPEG-4 AVC/H.264 High Profile / Level 4.1 (1.2.840.10008.1.2.4.102)
static (Shared in Visual Basic) | MPEG4_BD | MPEG-4 AVC/H.264 BD-compatible High Profile / Level 4.1 (1.2.840.10008.1.2.4.103)
static (Shared in Visual Basic) | RFC2557MIMEencapsulation | RFC 2557 MIME encapsulation (1.2.840.10008.1.2.6.1)
static (Shared in Visual Basic) | RLELossless | RLE Lossless (1.2.840.10008.1.2.5)
static (Shared in Visual Basic) | XMLEncoding | XML Encoding (1.2.840.10008.1.2.6.2)
Top
See Also

Reference

TransferSyntaxes Class
DicomObjects.DicomUIDs Namespace


TransferSyntaxes Class Fields

TransferSyntaxes Class Fields

DicomObjects.DicomUIDs Namespace : TransferSyntaxes Class

For a list of all members of this type, see TransferSyntaxes members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | DeflatedExplicitVRLittleEndian | Deflated Explicit VR Little Endian (1.2.840.10008.1.2.1.99)
static (Shared in Visual Basic) | ExplicitVRBigEndian | Explicit VR Big Endian (1.2.840.10008.1.2.2)
static (Shared in Visual Basic) | ExplicitVRLittleEndian | Explicit VR Little Endian (1.2.840.10008.1.2.1)
static (Shared in Visual Basic) | ImplicitVRLittleEndian | Implicit VR Little Endian (1.2.840.10008.1.2)
static (Shared in Visual Basic) | JPEG2000Lossless | JPEG 2000 Image Compression (Lossless Only) (1.2.840.10008.1.2.4.90)
static (Shared in Visual Basic) | JPEG2000Lossy | JPEG 2000 Image Compression (1.2.840.10008.1.2.4.91)
static (Shared in Visual Basic) | JPEG2000Part2MulticomponentImageCompression | JPEG 2000 Part 2 Multi-component Image Compression (1.2.840.10008.1.2.4.93)
static (Shared in Visual Basic) | JPEG2000Part2MulticomponentImageCompressionLosslessOnly | JPEG 2000 Part 2 Multi-component Image Compression (Lossless Only) (1.2.840.10008.1.2.4.92)
static (Shared in Visual Basic) | JPEGBaseline | JPEG Baseline (Process 1) (1.2.840.10008.1.2.4.50)
static (Shared in Visual Basic) | JPEGExtended | JPEG Extended (Process 2 & 4) (1.2.840.10008.1.2.4.51)
static (Shared in Visual Basic) | JPEGLossless | JPEG Lossless, Non-Hierarchical (Process 14) (1.2.840.10008.1.2.4.57)
static (Shared in Visual Basic) | JPEGLosslessFirstOrder | JPEG Lossless, Non-Hierarchical, First-Order Prediction (Process 14 [Selection Value 1]) (1.2.840.10008.1.2.4.70)
static (Shared in Visual Basic) | JPEGLSLossless | JPEG-LS Lossless Image Compression (1.2.840.10008.1.2.4.80)
static (Shared in Visual Basic) | JPEGLSLossy | JPEG-LS Lossy (Near-Lossless) Image Compression (1.2.840.10008.1.2.4.81)
static (Shared in Visual Basic) | JPIPReferenced | JPIP Referenced (1.2.840.10008.1.2.4.94)
static (Shared in Visual Basic) | JPIPReferencedDeflate | JPIP Referenced Deflate (1.2.840.10008.1.2.4.95)
static (Shared in Visual Basic) | MPEG2 | MPEG2 Main Profile @ Main Level (1.2.840.10008.1.2.4.100)
static (Shared in Visual Basic) | MPEG2_HL | MPEG2 Main Profile @ High Level (1.2.840.10008.1.2.4.101)
static (Shared in Visual Basic) | MPEG4 | MPEG-4 AVC/H.264 High Profile / Level 4.1 (1.2.840.10008.1.2.4.102)
static (Shared in Visual Basic) | MPEG4_BD | MPEG-4 AVC/H.264 BD-compatible High Profile / Level 4.1 (1.2.840.10008.1.2.4.103)
static (Shared in Visual Basic) | RFC2557MIMEencapsulation | RFC 2557 MIME encapsulation (1.2.840.10008.1.2.6.1)
static (Shared in Visual Basic) | RLELossless | RLE Lossless (1.2.840.10008.1.2.5)
static (Shared in Visual Basic) | XMLEncoding | XML Encoding (1.2.840.10008.1.2.6.2)
Top
See Also

Reference

TransferSyntaxes Class
DicomObjects.DicomUIDs Namespace


DeflatedExplicitVRLittleEndian Field

DeflatedExplicitVRLittleEndian Field

DicomObjects.DicomUIDs Namespace > TransferSyntaxes Class : DeflatedExplicitVRLittleEndian Field
Deflated Explicit VR Little Endian (1.2.840.10008.1.2.1.99)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly DeflatedExplicitVRLittleEndian As UID
'Usage

Dim value As UID

value = TransferSyntaxes.DeflatedExplicitVRLittleEndian
public static readonly UID DeflatedExplicitVRLittleEndian
public:
static readonly UID^ DeflatedExplicitVRLittleEndian
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Class
TransferSyntaxes Members


ExplicitVRBigEndian Field

ExplicitVRBigEndian Field

DicomObjects.DicomUIDs Namespace > TransferSyntaxes Class : ExplicitVRBigEndian Field
Explicit VR Big Endian (1.2.840.10008.1.2.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ExplicitVRBigEndian As UID
'Usage

Dim value As UID

value = TransferSyntaxes.ExplicitVRBigEndian
public static readonly UID ExplicitVRBigEndian
public:
static readonly UID^ ExplicitVRBigEndian
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Class
TransferSyntaxes Members


ExplicitVRLittleEndian Field

ExplicitVRLittleEndian Field

DicomObjects.DicomUIDs Namespace > TransferSyntaxes Class : ExplicitVRLittleEndian Field
Explicit VR Little Endian (1.2.840.10008.1.2.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ExplicitVRLittleEndian As UID
'Usage

Dim value As UID

value = TransferSyntaxes.ExplicitVRLittleEndian
public static readonly UID ExplicitVRLittleEndian
public:
static readonly UID^ ExplicitVRLittleEndian
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Class
TransferSyntaxes Members


ImplicitVRLittleEndian Field

ImplicitVRLittleEndian Field

DicomObjects.DicomUIDs Namespace > TransferSyntaxes Class : ImplicitVRLittleEndian Field
Implicit VR Little Endian (1.2.840.10008.1.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ImplicitVRLittleEndian As UID
'Usage

Dim value As UID

value = TransferSyntaxes.ImplicitVRLittleEndian
public static readonly UID ImplicitVRLittleEndian
public:
static readonly UID^ ImplicitVRLittleEndian
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Class
TransferSyntaxes Members


JPEG2000Lossless Field

JPEG2000Lossless Field

DicomObjects.DicomUIDs Namespace > TransferSyntaxes Class : JPEG2000Lossless Field
JPEG 2000 Image Compression (Lossless Only) (1.2.840.10008.1.2.4.90)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly JPEG2000Lossless As UID
'Usage

Dim value As UID

value = TransferSyntaxes.JPEG2000Lossless
public static readonly UID JPEG2000Lossless
public:
static readonly UID^ JPEG2000Lossless
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Class
TransferSyntaxes Members


JPEG2000Lossy Field

JPEG2000Lossy Field

DicomObjects.DicomUIDs Namespace > TransferSyntaxes Class : JPEG2000Lossy Field
JPEG 2000 Image Compression (1.2.840.10008.1.2.4.91)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly JPEG2000Lossy As UID
'Usage

Dim value As UID

value = TransferSyntaxes.JPEG2000Lossy
public static readonly UID JPEG2000Lossy
public:
static readonly UID^ JPEG2000Lossy
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Class
TransferSyntaxes Members


JPEG2000Part2MulticomponentImageCompression Field

JPEG2000Part2MulticomponentImageCompression Field

DicomObjects.DicomUIDs Namespace > TransferSyntaxes Class : JPEG2000Part2MulticomponentImageCompression Field
JPEG 2000 Part 2 Multi-component Image Compression (1.2.840.10008.1.2.4.93)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly JPEG2000Part2MulticomponentImageCompression As UID
'Usage

Dim value As UID

value = TransferSyntaxes.JPEG2000Part2MulticomponentImageCompression
public static readonly UID JPEG2000Part2MulticomponentImageCompression
public:
static readonly UID^ JPEG2000Part2MulticomponentImageCompression
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Class
TransferSyntaxes Members


JPEG2000Part2MulticomponentImageCompressionLosslessOnly Field

JPEG2000Part2MulticomponentImageCompressionLosslessOnly Field

DicomObjects.DicomUIDs Namespace > TransferSyntaxes Class : JPEG2000Part2MulticomponentImageCompressionLosslessOnly Field
JPEG 2000 Part 2 Multi-component Image Compression (Lossless Only) (1.2.840.10008.1.2.4.92)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly JPEG2000Part2MulticomponentImageCompressionLosslessOnly As UID
'Usage

Dim value As UID

value = TransferSyntaxes.JPEG2000Part2MulticomponentImageCompressionLosslessOnly
public static readonly UID JPEG2000Part2MulticomponentImageCompressionLosslessOnly
public:
static readonly UID^ JPEG2000Part2MulticomponentImageCompressionLosslessOnly
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Class
TransferSyntaxes Members


JPEGBaseline Field

JPEGBaseline Field

DicomObjects.DicomUIDs Namespace > TransferSyntaxes Class : JPEGBaseline Field
JPEG Baseline (Process 1) (1.2.840.10008.1.2.4.50)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly JPEGBaseline As UID
'Usage

Dim value As UID

value = TransferSyntaxes.JPEGBaseline
public static readonly UID JPEGBaseline
public:
static readonly UID^ JPEGBaseline
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Class
TransferSyntaxes Members


JPEGExtended Field

JPEGExtended Field

DicomObjects.DicomUIDs Namespace > TransferSyntaxes Class : JPEGExtended Field
JPEG Extended (Process 2 & 4) (1.2.840.10008.1.2.4.51)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly JPEGExtended As UID
'Usage

Dim value As UID

value = TransferSyntaxes.JPEGExtended
public static readonly UID JPEGExtended
public:
static readonly UID^ JPEGExtended
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Class
TransferSyntaxes Members


JPEGLossless Field

JPEGLossless Field

DicomObjects.DicomUIDs Namespace > TransferSyntaxes Class : JPEGLossless Field
JPEG Lossless, Non-Hierarchical (Process 14) (1.2.840.10008.1.2.4.57)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly JPEGLossless As UID
'Usage

Dim value As UID

value = TransferSyntaxes.JPEGLossless
public static readonly UID JPEGLossless
public:
static readonly UID^ JPEGLossless
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Class
TransferSyntaxes Members


JPEGLosslessFirstOrder Field

JPEGLosslessFirstOrder Field

DicomObjects.DicomUIDs Namespace > TransferSyntaxes Class : JPEGLosslessFirstOrder Field
JPEG Lossless, Non-Hierarchical, First-Order Prediction (Process 14 [Selection Value 1]) (1.2.840.10008.1.2.4.70)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly JPEGLosslessFirstOrder As UID
'Usage

Dim value As UID

value = TransferSyntaxes.JPEGLosslessFirstOrder
public static readonly UID JPEGLosslessFirstOrder
public:
static readonly UID^ JPEGLosslessFirstOrder
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Class
TransferSyntaxes Members


JPEGLSLossless Field

JPEGLSLossless Field

DicomObjects.DicomUIDs Namespace > TransferSyntaxes Class : JPEGLSLossless Field
JPEG-LS Lossless Image Compression (1.2.840.10008.1.2.4.80)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly JPEGLSLossless As UID
'Usage

Dim value As UID

value = TransferSyntaxes.JPEGLSLossless
public static readonly UID JPEGLSLossless
public:
static readonly UID^ JPEGLSLossless
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Class
TransferSyntaxes Members


JPEGLSLossy Field

JPEGLSLossy Field

DicomObjects.DicomUIDs Namespace > TransferSyntaxes Class : JPEGLSLossy Field
JPEG-LS Lossy (Near-Lossless) Image Compression (1.2.840.10008.1.2.4.81)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly JPEGLSLossy As UID
'Usage

Dim value As UID

value = TransferSyntaxes.JPEGLSLossy
public static readonly UID JPEGLSLossy
public:
static readonly UID^ JPEGLSLossy
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Class
TransferSyntaxes Members


JPIPReferenced Field

JPIPReferenced Field

DicomObjects.DicomUIDs Namespace > TransferSyntaxes Class : JPIPReferenced Field
JPIP Referenced (1.2.840.10008.1.2.4.94)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly JPIPReferenced As UID
'Usage

Dim value As UID

value = TransferSyntaxes.JPIPReferenced
public static readonly UID JPIPReferenced
public:
static readonly UID^ JPIPReferenced
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Class
TransferSyntaxes Members


JPIPReferencedDeflate Field

JPIPReferencedDeflate Field

DicomObjects.DicomUIDs Namespace > TransferSyntaxes Class : JPIPReferencedDeflate Field
JPIP Referenced Deflate (1.2.840.10008.1.2.4.95)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly JPIPReferencedDeflate As UID
'Usage

Dim value As UID

value = TransferSyntaxes.JPIPReferencedDeflate
public static readonly UID JPIPReferencedDeflate
public:
static readonly UID^ JPIPReferencedDeflate
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Class
TransferSyntaxes Members


MPEG2 Field

MPEG2 Field

DicomObjects.DicomUIDs Namespace > TransferSyntaxes Class : MPEG2 Field
MPEG2 Main Profile @ Main Level (1.2.840.10008.1.2.4.100)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly MPEG2 As UID
'Usage

Dim value As UID

value = TransferSyntaxes.MPEG2
public static readonly UID MPEG2
public:
static readonly UID^ MPEG2
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Class
TransferSyntaxes Members


MPEG2_HL Field

MPEG2_HL Field

DicomObjects.DicomUIDs Namespace > TransferSyntaxes Class : MPEG2_HL Field
MPEG2 Main Profile @ High Level (1.2.840.10008.1.2.4.101)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly MPEG2_HL As UID
'Usage

Dim value As UID

value = TransferSyntaxes.MPEG2_HL
public static readonly UID MPEG2_HL
public:
static readonly UID^ MPEG2_HL
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Class
TransferSyntaxes Members


MPEG4 Field

MPEG4 Field

DicomObjects.DicomUIDs Namespace > TransferSyntaxes Class : MPEG4 Field
MPEG-4 AVC/H.264 High Profile / Level 4.1 (1.2.840.10008.1.2.4.102)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly MPEG4 As UID
'Usage

Dim value As UID

value = TransferSyntaxes.MPEG4
public static readonly UID MPEG4
public:
static readonly UID^ MPEG4
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Class
TransferSyntaxes Members


MPEG4_BD Field

MPEG4_BD Field

DicomObjects.DicomUIDs Namespace > TransferSyntaxes Class : MPEG4_BD Field
MPEG-4 AVC/H.264 BD-compatible High Profile / Level 4.1 (1.2.840.10008.1.2.4.103)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly MPEG4_BD As UID
'Usage

Dim value As UID

value = TransferSyntaxes.MPEG4_BD
public static readonly UID MPEG4_BD
public:
static readonly UID^ MPEG4_BD
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Class
TransferSyntaxes Members


RFC2557MIMEencapsulation Field

RFC2557MIMEencapsulation Field

DicomObjects.DicomUIDs Namespace > TransferSyntaxes Class : RFC2557MIMEencapsulation Field
RFC 2557 MIME encapsulation (1.2.840.10008.1.2.6.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly RFC2557MIMEencapsulation As UID
'Usage

Dim value As UID

value = TransferSyntaxes.RFC2557MIMEencapsulation
public static readonly UID RFC2557MIMEencapsulation
public:
static readonly UID^ RFC2557MIMEencapsulation
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Class
TransferSyntaxes Members


RLELossless Field

RLELossless Field

DicomObjects.DicomUIDs Namespace > TransferSyntaxes Class : RLELossless Field
RLE Lossless (1.2.840.10008.1.2.5)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly RLELossless As UID
'Usage

Dim value As UID

value = TransferSyntaxes.RLELossless
public static readonly UID RLELossless
public:
static readonly UID^ RLELossless
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Class
TransferSyntaxes Members


XMLEncoding Field

XMLEncoding Field

DicomObjects.DicomUIDs Namespace > TransferSyntaxes Class : XMLEncoding Field
XML Encoding (1.2.840.10008.1.2.6.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly XMLEncoding As UID
'Usage

Dim value As UID

value = TransferSyntaxes.XMLEncoding
public static readonly UID XMLEncoding
public:
static readonly UID^ XMLEncoding
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

TransferSyntaxes Class
TransferSyntaxes Members


UID Class

UID Class
Members

DicomObjects.DicomUIDs Namespace : UID Class
A class to represent the constant UIDs present as readonly fields in the objects within the DicomObjects.DicomUIDs namespace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class UID
'Usage

Dim instance As UID
public class UID
public ref class UID
Inheritance Hierarchy

System.Object
DicomObjects.DicomUIDs.UID

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

UID Members
DicomObjects.DicomUIDs Namespace


UID Class Members

UID Class Members
Properties Methods

DicomObjects.DicomUIDs Namespace : UID Class

The following tables list the members exposed by UID.

Public Properties
 | Name | Description
Public Property | Description | Description of the attribute, as defined in DICOM Part 6
Public Property | Name | The Name of the UID
Public Property | Retired | True if the attribute is official retired
Public Property | Type | The "type" of the UID
Public Property | Value | The dotted form UID string
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | Parse | Standard parsing routine, which returns a reference to the existing UID object (from any of the classes in DicomObjects.DicomUIDs corresponding to the value passed.
Public Method | ToString | An explicit conversion to a string, returning the same string as Value
Top
Public Operators
public Operator Implicit Type Conversion Overloaded. Create a UID from a string
Top
See Also

Reference

UID Class
DicomObjects.DicomUIDs Namespace


UID Class Methods

UID Class Methods

DicomObjects.DicomUIDs Namespace : UID Class

For a list of all members of this type, see UID members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Parse | Standard parsing routine, which returns a reference to the existing UID object (from any of the classes in DicomObjects.DicomUIDs corresponding to the value passed.
Public Method | ToString | An explicit conversion to a string, returning the same string as Value
Top
See Also

Reference

UID Class
DicomObjects.DicomUIDs Namespace


Parse Method

Parse Method

DicomObjects.DicomUIDs Namespace > UID Class : Parse Method
The String to be parsed - this may be either in name form e.g. "EnhancedCT" or numberic - e.g. "1.2.840.10008.5.1.4.1.1.2.1"
An out parameter which returns the "name" of the returned UID object. If Value is a name, then this will be set to the same string, so its main use is when Value is in numeric form.
Standard parsing routine, which returns a reference to the existing UID object (from any of the classes in DicomObjects.DicomUIDs corresponding to the value passed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function Parse( _
   ByVal Value As String, _
   ByRef Name As String _
) As UID
'Usage

Dim Value As String
Dim Name As String
Dim value As UID

value = UID.Parse(Value, Name)
public static UID Parse(
   string Value,
   out string Name
)
public:
static UID^ Parse(
   String^ Value,
   [Out] String^ Name
)

Parameters

Value
The String to be parsed - this may be either in name form e.g. "EnhancedCT" or numberic - e.g. "1.2.840.10008.5.1.4.1.1.2.1"
Name
An out parameter which returns the "name" of the returned UID object. If Value is a name, then this will be set to the same string, so its main use is when Value is in numeric form.

Return Value

the matching UID value or null if there is no match
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

UID Class
UID Members


ToString Method (UID)

ToString Method (UID)

DicomObjects.DicomUIDs Namespace > UID Class : ToString Method
An explicit conversion to a string, returning the same string as Value
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As UID
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

The dotted form of the UID as a string
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

UID Class
UID Members
Base Implementation in ToString


UID Class Properties

UID Class Properties

DicomObjects.DicomUIDs Namespace : UID Class

For a list of all members of this type, see UID members.

Public Properties
 | Name | Description
Public Property | Description | Description of the attribute, as defined in DICOM Part 6
Public Property | Name | The Name of the UID
Public Property | Retired | True if the attribute is official retired
Public Property | Type | The "type" of the UID
Public Property | Value | The dotted form UID string
Top
See Also

Reference

UID Class
DicomObjects.DicomUIDs Namespace


Description Property (UID)

Description Property (UID)

DicomObjects.DicomUIDs Namespace > UID Class : Description Property
Description of the attribute, as defined in DICOM Part 6
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Description As String
'Usage

Dim instance As UID
Dim value As String

value = instance.Description
public string Description {get;}
public:
property String^ Description {
   String^ get();
}
Remarks
This should not be confused with the Keyword enumeration, which is a single word with no spaces and used in code in place of Group and Element
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

UID Class
UID Members


Name Property (UID)

Name Property (UID)

DicomObjects.DicomUIDs Namespace > UID Class : Name Property
The Name of the UID
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Name As String
'Usage

Dim instance As UID
Dim value As String

value = instance.Name
public string Name {get;}
public:
property String^ Name {
   String^ get();
}
Remarks
This name is the name of the field within one of the classes in the DicomObjects.DicomUIDs namespace which holds this UID object
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

UID Class
UID Members


Retired Property

Retired Property

DicomObjects.DicomUIDs Namespace > UID Class : Retired Property
True if the attribute is official retired
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Retired As Boolean
'Usage

Dim instance As UID
Dim value As Boolean

value = instance.Retired
public bool Retired {get;}
public:
property bool Retired {
   bool get();
}
Remarks
Retired attributes may legally be used in DICOM, but their use is discouraged in new implementations
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

UID Class
UID Members


Type Property

Type Property

DicomObjects.DicomUIDs Namespace > UID Class : Type Property
The "type" of the UID
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Type As UIDType
'Usage

Dim instance As UID
Dim value As UIDType

value = instance.Type
public UIDType Type {get;}
public:
property UIDType Type {
   UIDType get();
}
Remarks
See DicomObjects.Enums.UIDType for the list of types
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

UID Class
UID Members


Value Property (UID)

Value Property (UID)

DicomObjects.DicomUIDs Namespace > UID Class : Value Property
The dotted form UID string
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Value As String
'Usage

Dim instance As UID
Dim value As String

value = instance.Value
public string Value {get;}
public:
property String^ Value {
   String^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

UID Class
UID Members


Implicit Type Conversion Operator (UID)

Implicit Type Conversion Operator (UID)

DicomObjects.DicomUIDs Namespace > UID Class : Implicit Type Conversion Operator
Create a UID from a string
Overload List
Overload | Description
Implicit Type Conversion(UID,String) | Create a UID from a string
Implicit Type Conversion(String,UID) | An implicit conversion to a string, returning the same string as Value
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

UID Class
UID Members


WellKnownInstances Class

WellKnownInstances Class
Members

DicomObjects.DicomUIDs Namespace : WellKnownInstances Class
Contains UIDs for Well Known Instance
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit NotInheritable Class WellKnownInstances
'Usage

Dim instance As WellKnownInstances
public static class WellKnownInstances
public ref class WellKnownInstances abstract sealed
Inheritance Hierarchy

System.Object
DicomObjects.DicomUIDs.WellKnownInstances

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WellKnownInstances Members
DicomObjects.DicomUIDs Namespace


WellKnownInstances Class Members

WellKnownInstances Class Members
Fields

DicomObjects.DicomUIDs Namespace : WellKnownInstances Class

The following tables list the members exposed by WellKnownInstances.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | HotIronColorPaletteSOPInstance | Hot Iron Color Palette SOP Instance (1.2.840.10008.1.5.1)
static (Shared in Visual Basic) | HotMetalBlueColorPaletteSOPInstance | Hot Metal Blue Color Palette SOP Instance (1.2.840.10008.1.5.3)
static (Shared in Visual Basic) | PET20StepColorPaletteSOPInstance | PET 20 Step Color Palette SOP Instance (1.2.840.10008.1.5.4)
static (Shared in Visual Basic) | PETColorPaletteSOPInstance | PET Color Palette SOP Instance (1.2.840.10008.1.5.2)
static (Shared in Visual Basic) | Printer | Printer SOP Instance (1.2.840.10008.5.1.1.17)
static (Shared in Visual Basic) | PrinterConfigurationRetrieval | Printer Configuration Retrieval SOP Instance (1.2.840.10008.5.1.1.17.376)
static (Shared in Visual Basic) | ProceduralEventLoggingSOPInstance | Procedural Event Logging SOP Instance (1.2.840.10008.1.40.1)
static (Shared in Visual Basic) | StorageCommitmentPush | Storage Commitment Push Model SOP Instance (1.2.840.10008.1.20.1.1)
static (Shared in Visual Basic) | SubstanceAdministrationLoggingSOPInstance | Substance Administration Logging SOP Instance (1.2.840.10008.1.42.1)
static (Shared in Visual Basic) | UnifiedWorklistandProcedureStepSOPInstance | Unified Worklist and Procedure Step SOP Instance (1.2.840.10008.5.1.4.34.5)
Top
See Also

Reference

WellKnownInstances Class
DicomObjects.DicomUIDs Namespace


WellKnownInstances Class Fields

WellKnownInstances Class Fields

DicomObjects.DicomUIDs Namespace : WellKnownInstances Class

For a list of all members of this type, see WellKnownInstances members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | HotIronColorPaletteSOPInstance | Hot Iron Color Palette SOP Instance (1.2.840.10008.1.5.1)
static (Shared in Visual Basic) | HotMetalBlueColorPaletteSOPInstance | Hot Metal Blue Color Palette SOP Instance (1.2.840.10008.1.5.3)
static (Shared in Visual Basic) | PET20StepColorPaletteSOPInstance | PET 20 Step Color Palette SOP Instance (1.2.840.10008.1.5.4)
static (Shared in Visual Basic) | PETColorPaletteSOPInstance | PET Color Palette SOP Instance (1.2.840.10008.1.5.2)
static (Shared in Visual Basic) | Printer | Printer SOP Instance (1.2.840.10008.5.1.1.17)
static (Shared in Visual Basic) | PrinterConfigurationRetrieval | Printer Configuration Retrieval SOP Instance (1.2.840.10008.5.1.1.17.376)
static (Shared in Visual Basic) | ProceduralEventLoggingSOPInstance | Procedural Event Logging SOP Instance (1.2.840.10008.1.40.1)
static (Shared in Visual Basic) | StorageCommitmentPush | Storage Commitment Push Model SOP Instance (1.2.840.10008.1.20.1.1)
static (Shared in Visual Basic) | SubstanceAdministrationLoggingSOPInstance | Substance Administration Logging SOP Instance (1.2.840.10008.1.42.1)
static (Shared in Visual Basic) | UnifiedWorklistandProcedureStepSOPInstance | Unified Worklist and Procedure Step SOP Instance (1.2.840.10008.5.1.4.34.5)
Top
See Also

Reference

WellKnownInstances Class
DicomObjects.DicomUIDs Namespace


HotIronColorPaletteSOPInstance Field

HotIronColorPaletteSOPInstance Field

DicomObjects.DicomUIDs Namespace > WellKnownInstances Class : HotIronColorPaletteSOPInstance Field
Hot Iron Color Palette SOP Instance (1.2.840.10008.1.5.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly HotIronColorPaletteSOPInstance As UID
'Usage

Dim value As UID

value = WellKnownInstances.HotIronColorPaletteSOPInstance
public static readonly UID HotIronColorPaletteSOPInstance
public:
static readonly UID^ HotIronColorPaletteSOPInstance
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WellKnownInstances Class
WellKnownInstances Members


HotMetalBlueColorPaletteSOPInstance Field

HotMetalBlueColorPaletteSOPInstance Field

DicomObjects.DicomUIDs Namespace > WellKnownInstances Class : HotMetalBlueColorPaletteSOPInstance Field
Hot Metal Blue Color Palette SOP Instance (1.2.840.10008.1.5.3)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly HotMetalBlueColorPaletteSOPInstance As UID
'Usage

Dim value As UID

value = WellKnownInstances.HotMetalBlueColorPaletteSOPInstance
public static readonly UID HotMetalBlueColorPaletteSOPInstance
public:
static readonly UID^ HotMetalBlueColorPaletteSOPInstance
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WellKnownInstances Class
WellKnownInstances Members


PET20StepColorPaletteSOPInstance Field

PET20StepColorPaletteSOPInstance Field

DicomObjects.DicomUIDs Namespace > WellKnownInstances Class : PET20StepColorPaletteSOPInstance Field
PET 20 Step Color Palette SOP Instance (1.2.840.10008.1.5.4)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly PET20StepColorPaletteSOPInstance As UID
'Usage

Dim value As UID

value = WellKnownInstances.PET20StepColorPaletteSOPInstance
public static readonly UID PET20StepColorPaletteSOPInstance
public:
static readonly UID^ PET20StepColorPaletteSOPInstance
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WellKnownInstances Class
WellKnownInstances Members


PETColorPaletteSOPInstance Field

PETColorPaletteSOPInstance Field

DicomObjects.DicomUIDs Namespace > WellKnownInstances Class : PETColorPaletteSOPInstance Field
PET Color Palette SOP Instance (1.2.840.10008.1.5.2)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly PETColorPaletteSOPInstance As UID
'Usage

Dim value As UID

value = WellKnownInstances.PETColorPaletteSOPInstance
public static readonly UID PETColorPaletteSOPInstance
public:
static readonly UID^ PETColorPaletteSOPInstance
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WellKnownInstances Class
WellKnownInstances Members


Printer Field (WellKnownInstances)

Printer Field (WellKnownInstances)

DicomObjects.DicomUIDs Namespace > WellKnownInstances Class : Printer Field
Printer SOP Instance (1.2.840.10008.5.1.1.17)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Printer As UID
'Usage

Dim value As UID

value = WellKnownInstances.Printer
public static readonly UID Printer
public:
static readonly UID^ Printer
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WellKnownInstances Class
WellKnownInstances Members


PrinterConfigurationRetrieval Field (WellKnownInstances)

PrinterConfigurationRetrieval Field (WellKnownInstances)

DicomObjects.DicomUIDs Namespace > WellKnownInstances Class : PrinterConfigurationRetrieval Field
Printer Configuration Retrieval SOP Instance (1.2.840.10008.5.1.1.17.376)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly PrinterConfigurationRetrieval As UID
'Usage

Dim value As UID

value = WellKnownInstances.PrinterConfigurationRetrieval
public static readonly UID PrinterConfigurationRetrieval
public:
static readonly UID^ PrinterConfigurationRetrieval
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WellKnownInstances Class
WellKnownInstances Members


ProceduralEventLoggingSOPInstance Field

ProceduralEventLoggingSOPInstance Field

DicomObjects.DicomUIDs Namespace > WellKnownInstances Class : ProceduralEventLoggingSOPInstance Field
Procedural Event Logging SOP Instance (1.2.840.10008.1.40.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly ProceduralEventLoggingSOPInstance As UID
'Usage

Dim value As UID

value = WellKnownInstances.ProceduralEventLoggingSOPInstance
public static readonly UID ProceduralEventLoggingSOPInstance
public:
static readonly UID^ ProceduralEventLoggingSOPInstance
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WellKnownInstances Class
WellKnownInstances Members


StorageCommitmentPush Field (WellKnownInstances)

StorageCommitmentPush Field (WellKnownInstances)

DicomObjects.DicomUIDs Namespace > WellKnownInstances Class : StorageCommitmentPush Field
Storage Commitment Push Model SOP Instance (1.2.840.10008.1.20.1.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly StorageCommitmentPush As UID
'Usage

Dim value As UID

value = WellKnownInstances.StorageCommitmentPush
public static readonly UID StorageCommitmentPush
public:
static readonly UID^ StorageCommitmentPush
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WellKnownInstances Class
WellKnownInstances Members


SubstanceAdministrationLoggingSOPInstance Field

SubstanceAdministrationLoggingSOPInstance Field

DicomObjects.DicomUIDs Namespace > WellKnownInstances Class : SubstanceAdministrationLoggingSOPInstance Field
Substance Administration Logging SOP Instance (1.2.840.10008.1.42.1)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly SubstanceAdministrationLoggingSOPInstance As UID
'Usage

Dim value As UID

value = WellKnownInstances.SubstanceAdministrationLoggingSOPInstance
public static readonly UID SubstanceAdministrationLoggingSOPInstance
public:
static readonly UID^ SubstanceAdministrationLoggingSOPInstance
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WellKnownInstances Class
WellKnownInstances Members


UnifiedWorklistandProcedureStepSOPInstance Field

UnifiedWorklistandProcedureStepSOPInstance Field

DicomObjects.DicomUIDs Namespace > WellKnownInstances Class : UnifiedWorklistandProcedureStepSOPInstance Field
Unified Worklist and Procedure Step SOP Instance (1.2.840.10008.5.1.4.34.5)
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly UnifiedWorklistandProcedureStepSOPInstance As UID
'Usage

Dim value As UID

value = WellKnownInstances.UnifiedWorklistandProcedureStepSOPInstance
public static readonly UID UnifiedWorklistandProcedureStepSOPInstance
public:
static readonly UID^ UnifiedWorklistandProcedureStepSOPInstance
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

WellKnownInstances Class
WellKnownInstances Members


DicomObjects.DicomWeb Namespace

DicomObjects.DicomWeb Namespace
Inheritance Hierarchy
A set of classes that handle DICOM web functionalities
Enumerations
 | Enumeration | Description
Enumeration | DicomDataEncoding | The ways that DICOM data can be encoded in DicomWeb
See Also

Reference

DicomObjects.NET.8.40 Assembly


DicomDataEncoding Enumeration

DicomDataEncoding Enumeration

DicomObjects.DicomWeb Namespace : DicomDataEncoding Enumeration
The ways that DICOM data can be encoded in DicomWeb
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum DicomDataEncoding
   Inherits System.Enum
'Usage

Dim instance As DicomDataEncoding
public enum DicomDataEncoding : System.Enum
public enum class DicomDataEncoding : public System.Enum
Members
Member | Description
Json | JSON encoding
NativeDicom | Native DICOM as "part 10" files
Xml | XML encoding
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.DicomWeb.DicomDataEncoding

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb.Internal Namespace

DicomObjects.DicomWeb.Internal Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | BulkData | Internal Use Only
Class | DicomAttribute | Internal Use Only
Class | Item | Internal Use Only
Class | JsonAttribute | Internal Use Only
Class | JsonPersonName | Internal Use Only
Class | NamePart | Internal Use Only
Class | NativeDicomModel | Internal Use Only
Class | PersonName | Internal Use Only
Class | Value | Internal Use Only
See Also

Reference

DicomObjects.NET.8.40 Assembly


BulkData Class

BulkData Class
Members

DicomObjects.DicomWeb.Internal Namespace : BulkData Class
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class BulkData
'Usage

Dim instance As BulkData
public class BulkData
public ref class BulkData
Inheritance Hierarchy

System.Object
DicomObjects.DicomWeb.Internal.BulkData

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

BulkData Members
DicomObjects.DicomWeb.Internal Namespace


BulkData Class Members

BulkData Class Members
Properties

DicomObjects.DicomWeb.Internal Namespace : BulkData Class

The following tables list the members exposed by BulkData.

Public Constructors
 | Name | Description
Public Constructor | BulkData Constructor |
Top
Public Properties
 | Name | Description
Public Property | uri | Internal Use Only
Public Property | uuid | Internal Use Only
Top
See Also

Reference

BulkData Class
DicomObjects.DicomWeb.Internal Namespace


BulkData Constructor

BulkData Constructor

DicomObjects.DicomWeb.Internal Namespace > BulkData Class : BulkData Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New BulkData()
public BulkData()
public:
BulkData();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

BulkData Class
BulkData Members


BulkData Class Properties

BulkData Class Properties

DicomObjects.DicomWeb.Internal Namespace : BulkData Class

For a list of all members of this type, see BulkData members.

Public Properties
 | Name | Description
Public Property | uri | Internal Use Only
Public Property | uuid | Internal Use Only
Top
See Also

Reference

BulkData Class
DicomObjects.DicomWeb.Internal Namespace


uri Property

uri Property

DicomObjects.DicomWeb.Internal Namespace > BulkData Class : uri Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property uri As String
'Usage

Dim instance As BulkData
Dim value As String

instance.uri = value

value = instance.uri
public string uri {get; set;}
public:
property String^ uri {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

BulkData Class
BulkData Members


uuid Property

uuid Property

DicomObjects.DicomWeb.Internal Namespace > BulkData Class : uuid Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property uuid As String
'Usage

Dim instance As BulkData
Dim value As String

instance.uuid = value

value = instance.uuid
public string uuid {get; set;}
public:
property String^ uuid {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

BulkData Class
BulkData Members


DicomAttribute Class

DicomAttribute Class
Members

DicomObjects.DicomWeb.Internal Namespace : DicomAttribute Class
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DicomAttribute
'Usage

Dim instance As DicomAttribute
public class DicomAttribute
public ref class DicomAttribute
Inheritance Hierarchy

System.Object
DicomObjects.DicomWeb.Internal.DicomAttribute

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Members
DicomObjects.DicomWeb.Internal Namespace


DicomAttribute Class Members

DicomAttribute Class Members
Properties

DicomObjects.DicomWeb.Internal Namespace : DicomAttribute Class

The following tables list the members exposed by DicomAttribute.

Public Constructors
 | Name | Description
Public Constructor | DicomAttribute Constructor | Default Constructor
Top
Public Properties
 | Name | Description
Public Property | BulkData | Internal Use Only
Public Property | InlineBinary | Internal Use Only
Public Property | Items | Internal Use Only
Public Property | Keyword | Internal Use Only
Public Property | PersonNames | Internal Use Only
Public Property | PrivateCreator | Internal Use Only
Public Property | Tag | Internal Use Only
Public Property | Values | Internal Use Only
Public Property | VR | Internal Use Only
Top
See Also

Reference

DicomAttribute Class
DicomObjects.DicomWeb.Internal Namespace


DicomAttribute Constructor

DicomAttribute Constructor

DicomObjects.DicomWeb.Internal Namespace > DicomAttribute Class : DicomAttribute Constructor
Default Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DicomAttribute()
public DicomAttribute()
public:
DicomAttribute();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


DicomAttribute Class Properties

DicomAttribute Class Properties

DicomObjects.DicomWeb.Internal Namespace : DicomAttribute Class

For a list of all members of this type, see DicomAttribute members.

Public Properties
 | Name | Description
Public Property | BulkData | Internal Use Only
Public Property | InlineBinary | Internal Use Only
Public Property | Items | Internal Use Only
Public Property | Keyword | Internal Use Only
Public Property | PersonNames | Internal Use Only
Public Property | PrivateCreator | Internal Use Only
Public Property | Tag | Internal Use Only
Public Property | Values | Internal Use Only
Public Property | VR | Internal Use Only
Top
See Also

Reference

DicomAttribute Class
DicomObjects.DicomWeb.Internal Namespace


BulkData Property

BulkData Property

DicomObjects.DicomWeb.Internal Namespace > DicomAttribute Class : BulkData Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BulkData As BulkData
'Usage

Dim instance As DicomAttribute
Dim value As BulkData

instance.BulkData = value

value = instance.BulkData
public BulkData BulkData {get; set;}
public:
property BulkData^ BulkData {
   BulkData^ get();
   void set (    BulkData^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


InlineBinary Property (DicomAttribute)

InlineBinary Property (DicomAttribute)

DicomObjects.DicomWeb.Internal Namespace > DicomAttribute Class : InlineBinary Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property InlineBinary As Byte()
'Usage

Dim instance As DicomAttribute
Dim value() As Byte

instance.InlineBinary = value

value = instance.InlineBinary
public byte[] InlineBinary {get; set;}
public:
property array<byte>^ InlineBinary {
   array<byte>^ get();
   void set (    array<byte>^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


Items Property

Items Property

DicomObjects.DicomWeb.Internal Namespace > DicomAttribute Class : Items Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Items As List(Of Item)
'Usage

Dim instance As DicomAttribute
Dim value As List(Of Item)

instance.Items = value

value = instance.Items
public List<Item> Items {get; set;}
public:
property List<Item^>^ Items {
   List<Item^>^ get();
   void set (    List<Item^>^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


Keyword Property (DicomAttribute)

Keyword Property (DicomAttribute)

DicomObjects.DicomWeb.Internal Namespace > DicomAttribute Class : Keyword Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Keyword As String
'Usage

Dim instance As DicomAttribute
Dim value As String

instance.Keyword = value

value = instance.Keyword
public string Keyword {get; set;}
public:
property String^ Keyword {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


PersonNames Property

PersonNames Property

DicomObjects.DicomWeb.Internal Namespace > DicomAttribute Class : PersonNames Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PersonNames As List(Of PersonName)
'Usage

Dim instance As DicomAttribute
Dim value As List(Of PersonName)

instance.PersonNames = value

value = instance.PersonNames
public List<PersonName> PersonNames {get; set;}
public:
property List<PersonName^>^ PersonNames {
   List<PersonName^>^ get();
   void set (    List<PersonName^>^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


PrivateCreator Property

PrivateCreator Property

DicomObjects.DicomWeb.Internal Namespace > DicomAttribute Class : PrivateCreator Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PrivateCreator As String
'Usage

Dim instance As DicomAttribute
Dim value As String

instance.PrivateCreator = value

value = instance.PrivateCreator
public string PrivateCreator {get; set;}
public:
property String^ PrivateCreator {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


Tag Property (DicomAttribute)

Tag Property (DicomAttribute)

DicomObjects.DicomWeb.Internal Namespace > DicomAttribute Class : Tag Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Tag As String
'Usage

Dim instance As DicomAttribute
Dim value As String

instance.Tag = value

value = instance.Tag
public string Tag {get; set;}
public:
property String^ Tag {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


Values Property

Values Property

DicomObjects.DicomWeb.Internal Namespace > DicomAttribute Class : Values Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Values As List(Of Value)
'Usage

Dim instance As DicomAttribute
Dim value As List(Of Value)

instance.Values = value

value = instance.Values
public List<Value> Values {get; set;}
public:
property List<Value^>^ Values {
   List<Value^>^ get();
   void set (    List<Value^>^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


VR Property (DicomAttribute)

VR Property (DicomAttribute)

DicomObjects.DicomWeb.Internal Namespace > DicomAttribute Class : VR Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property VR As String
'Usage

Dim instance As DicomAttribute
Dim value As String

instance.VR = value

value = instance.VR
public string VR {get; set;}
public:
property String^ VR {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomAttribute Class
DicomAttribute Members


Item Class

Item Class
Members

DicomObjects.DicomWeb.Internal Namespace : Item Class
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class Item
'Usage

Dim instance As Item
public class Item
public ref class Item
Inheritance Hierarchy

System.Object
DicomObjects.DicomWeb.Internal.Item

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Item Members
DicomObjects.DicomWeb.Internal Namespace


Item Class Members

Item Class Members
Properties

DicomObjects.DicomWeb.Internal Namespace : Item Class

The following tables list the members exposed by Item.

Public Constructors
 | Name | Description
Public Constructor | Item Constructor | Default constructor
Top
Public Properties
 | Name | Description
Public Property | Attributes | Internal Use Only
Public Property | Number | Internal Use Only
Top
See Also

Reference

Item Class
DicomObjects.DicomWeb.Internal Namespace


Item Constructor

Item Constructor

DicomObjects.DicomWeb.Internal Namespace > Item Class : Item Constructor
Default constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Item()
public Item()
public:
Item();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Item Class
Item Members


Item Class Properties

Item Class Properties

DicomObjects.DicomWeb.Internal Namespace : Item Class

For a list of all members of this type, see Item members.

Public Properties
 | Name | Description
Public Property | Attributes | Internal Use Only
Public Property | Number | Internal Use Only
Top
See Also

Reference

Item Class
DicomObjects.DicomWeb.Internal Namespace


Attributes Property (Item)

Attributes Property (Item)

DicomObjects.DicomWeb.Internal Namespace > Item Class : Attributes Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Attributes As List(Of DicomAttribute)
'Usage

Dim instance As Item
Dim value As List(Of DicomAttribute)

instance.Attributes = value

value = instance.Attributes
public List<DicomAttribute> Attributes {get; set;}
public:
property List<DicomAttribute^>^ Attributes {
   List<DicomAttribute^>^ get();
   void set (    List<DicomAttribute^>^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Item Class
Item Members


Number Property (Item)

Number Property (Item)

DicomObjects.DicomWeb.Internal Namespace > Item Class : Number Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Number As Integer
'Usage

Dim instance As Item
Dim value As Integer

instance.Number = value

value = instance.Number
public int Number {get; set;}
public:
property int Number {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Item Class
Item Members


JsonAttribute Class

JsonAttribute Class
Members

DicomObjects.DicomWeb.Internal Namespace : JsonAttribute Class
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class JsonAttribute
'Usage

Dim instance As JsonAttribute
public class JsonAttribute
public ref class JsonAttribute
Inheritance Hierarchy

System.Object
DicomObjects.DicomWeb.Internal.JsonAttribute

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JsonAttribute Members
DicomObjects.DicomWeb.Internal Namespace


JsonAttribute Class Members

JsonAttribute Class Members
Properties

DicomObjects.DicomWeb.Internal Namespace : JsonAttribute Class

The following tables list the members exposed by JsonAttribute.

Public Constructors
 | Name | Description
Public Constructor | JsonAttribute Constructor |
Top
Public Properties
 | Name | Description
Public Property | BulkDataURI | Internal Use Only
Public Property | InlineBinary | Internal Use Only
Public Property | Value | Internal Use Only
Public Property | VR | Internal Use Only
Top
See Also

Reference

JsonAttribute Class
DicomObjects.DicomWeb.Internal Namespace


JsonAttribute Constructor

JsonAttribute Constructor

DicomObjects.DicomWeb.Internal Namespace > JsonAttribute Class : JsonAttribute Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JsonAttribute()
public JsonAttribute()
public:
JsonAttribute();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JsonAttribute Class
JsonAttribute Members


JsonAttribute Class Properties

JsonAttribute Class Properties

DicomObjects.DicomWeb.Internal Namespace : JsonAttribute Class

For a list of all members of this type, see JsonAttribute members.

Public Properties
 | Name | Description
Public Property | BulkDataURI | Internal Use Only
Public Property | InlineBinary | Internal Use Only
Public Property | Value | Internal Use Only
Public Property | VR | Internal Use Only
Top
See Also

Reference

JsonAttribute Class
DicomObjects.DicomWeb.Internal Namespace


BulkDataURI Property (JsonAttribute)

BulkDataURI Property (JsonAttribute)

DicomObjects.DicomWeb.Internal Namespace > JsonAttribute Class : BulkDataURI Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BulkDataURI As String
'Usage

Dim instance As JsonAttribute
Dim value As String

instance.BulkDataURI = value

value = instance.BulkDataURI
public string BulkDataURI {get; set;}
public:
property String^ BulkDataURI {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JsonAttribute Class
JsonAttribute Members


InlineBinary Property (JsonAttribute)

InlineBinary Property (JsonAttribute)

DicomObjects.DicomWeb.Internal Namespace > JsonAttribute Class : InlineBinary Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property InlineBinary As Byte()
'Usage

Dim instance As JsonAttribute
Dim value() As Byte

instance.InlineBinary = value

value = instance.InlineBinary
public byte[] InlineBinary {get; set;}
public:
property array<byte>^ InlineBinary {
   array<byte>^ get();
   void set (    array<byte>^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JsonAttribute Class
JsonAttribute Members


Value Property (JsonAttribute)

Value Property (JsonAttribute)

DicomObjects.DicomWeb.Internal Namespace > JsonAttribute Class : Value Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Value As IEnumerable(Of Object)
'Usage

Dim instance As JsonAttribute
Dim value As IEnumerable(Of Object)

instance.Value = value

value = instance.Value
public IEnumerable<object> Value {get; set;}
public:
property IEnumerable<Object^>^ Value {
   IEnumerable<Object^>^ get();
   void set (    IEnumerable<Object^>^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JsonAttribute Class
JsonAttribute Members


VR Property (JsonAttribute)

VR Property (JsonAttribute)

DicomObjects.DicomWeb.Internal Namespace > JsonAttribute Class : VR Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property VR As String
'Usage

Dim instance As JsonAttribute
Dim value As String

instance.VR = value

value = instance.VR
public string VR {get; set;}
public:
property String^ VR {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JsonAttribute Class
JsonAttribute Members


JsonPersonName Class

JsonPersonName Class
Members

DicomObjects.DicomWeb.Internal Namespace : JsonPersonName Class
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class JsonPersonName
'Usage

Dim instance As JsonPersonName
public class JsonPersonName
public ref class JsonPersonName
Inheritance Hierarchy

System.Object
DicomObjects.DicomWeb.Internal.JsonPersonName

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JsonPersonName Members
DicomObjects.DicomWeb.Internal Namespace


JsonPersonName Class Members

JsonPersonName Class Members
Properties

DicomObjects.DicomWeb.Internal Namespace : JsonPersonName Class

The following tables list the members exposed by JsonPersonName.

Public Constructors
 | Name | Description
Public Constructor | JsonPersonName Constructor |
Top
Public Properties
 | Name | Description
Public Property | Alphabetic | Internal Use Only
Public Property | Ideographic | Internal Use Only
Public Property | Phonetic | Internal Use Only
Top
See Also

Reference

JsonPersonName Class
DicomObjects.DicomWeb.Internal Namespace


JsonPersonName Constructor

JsonPersonName Constructor

DicomObjects.DicomWeb.Internal Namespace > JsonPersonName Class : JsonPersonName Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JsonPersonName()
public JsonPersonName()
public:
JsonPersonName();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JsonPersonName Class
JsonPersonName Members


JsonPersonName Class Properties

JsonPersonName Class Properties

DicomObjects.DicomWeb.Internal Namespace : JsonPersonName Class

For a list of all members of this type, see JsonPersonName members.

Public Properties
 | Name | Description
Public Property | Alphabetic | Internal Use Only
Public Property | Ideographic | Internal Use Only
Public Property | Phonetic | Internal Use Only
Top
See Also

Reference

JsonPersonName Class
DicomObjects.DicomWeb.Internal Namespace


Alphabetic Property (JsonPersonName)

Alphabetic Property (JsonPersonName)

DicomObjects.DicomWeb.Internal Namespace > JsonPersonName Class : Alphabetic Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Alphabetic As String
'Usage

Dim instance As JsonPersonName
Dim value As String

instance.Alphabetic = value

value = instance.Alphabetic
public string Alphabetic {get; set;}
public:
property String^ Alphabetic {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JsonPersonName Class
JsonPersonName Members


Ideographic Property (JsonPersonName)

Ideographic Property (JsonPersonName)

DicomObjects.DicomWeb.Internal Namespace > JsonPersonName Class : Ideographic Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Ideographic As String
'Usage

Dim instance As JsonPersonName
Dim value As String

instance.Ideographic = value

value = instance.Ideographic
public string Ideographic {get; set;}
public:
property String^ Ideographic {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JsonPersonName Class
JsonPersonName Members


Phonetic Property (JsonPersonName)

Phonetic Property (JsonPersonName)

DicomObjects.DicomWeb.Internal Namespace > JsonPersonName Class : Phonetic Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Phonetic As String
'Usage

Dim instance As JsonPersonName
Dim value As String

instance.Phonetic = value

value = instance.Phonetic
public string Phonetic {get; set;}
public:
property String^ Phonetic {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

JsonPersonName Class
JsonPersonName Members


NamePart Class

NamePart Class
Members

DicomObjects.DicomWeb.Internal Namespace : NamePart Class
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class NamePart
'Usage

Dim instance As NamePart
public class NamePart
public ref class NamePart
Inheritance Hierarchy

System.Object
DicomObjects.DicomWeb.Internal.NamePart

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

NamePart Members
DicomObjects.DicomWeb.Internal Namespace


NamePart Class Members

NamePart Class Members
Properties

DicomObjects.DicomWeb.Internal Namespace : NamePart Class

The following tables list the members exposed by NamePart.

Public Constructors
 | Name | Description
Public Constructor | NamePart Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | FamilyName | Internal Use Only
Public Property | GivenName | Internal Use Only
Public Property | MiddleName | Internal Use Only
Public Property | NamePrefix | Internal Use Only
Public Property | NameSuffix | Internal Use Only
Top
See Also

Reference

NamePart Class
DicomObjects.DicomWeb.Internal Namespace


NamePart Constructor

NamePart Constructor

DicomObjects.DicomWeb.Internal Namespace > NamePart Class : NamePart Constructor
Overload List
Overload | Description
NamePart Constructor() | Internal Use Only
NamePart Constructor(String) | Internal Use Only
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

NamePart Class
NamePart Members


NamePart Constructor()

NamePart Constructor()

DicomObjects.DicomWeb.Internal Namespace > NamePart Class > NamePart Constructor : NamePart Constructor()
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New NamePart()
public NamePart()
public:
NamePart();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

NamePart Class
NamePart Members
Overload List


NamePart Constructor(String)

NamePart Constructor(String)

DicomObjects.DicomWeb.Internal Namespace > NamePart Class > NamePart Constructor : NamePart Constructor(String)
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal p As String _
)
'Usage

Dim p As String

Dim instance As New NamePart(p)
public NamePart(
   string p
)
public:
NamePart(
   String^ p
)

Parameters

p
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

NamePart Class
NamePart Members
Overload List


NamePart Class Properties

NamePart Class Properties

DicomObjects.DicomWeb.Internal Namespace : NamePart Class

For a list of all members of this type, see NamePart members.

Public Properties
 | Name | Description
Public Property | FamilyName | Internal Use Only
Public Property | GivenName | Internal Use Only
Public Property | MiddleName | Internal Use Only
Public Property | NamePrefix | Internal Use Only
Public Property | NameSuffix | Internal Use Only
Top
See Also

Reference

NamePart Class
DicomObjects.DicomWeb.Internal Namespace


FamilyName Property

FamilyName Property

DicomObjects.DicomWeb.Internal Namespace > NamePart Class : FamilyName Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FamilyName As String
'Usage

Dim instance As NamePart
Dim value As String

instance.FamilyName = value

value = instance.FamilyName
public string FamilyName {get; set;}
public:
property String^ FamilyName {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

NamePart Class
NamePart Members


GivenName Property

GivenName Property

DicomObjects.DicomWeb.Internal Namespace > NamePart Class : GivenName Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property GivenName As String
'Usage

Dim instance As NamePart
Dim value As String

instance.GivenName = value

value = instance.GivenName
public string GivenName {get; set;}
public:
property String^ GivenName {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

NamePart Class
NamePart Members


MiddleName Property

MiddleName Property

DicomObjects.DicomWeb.Internal Namespace > NamePart Class : MiddleName Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MiddleName As String
'Usage

Dim instance As NamePart
Dim value As String

instance.MiddleName = value

value = instance.MiddleName
public string MiddleName {get; set;}
public:
property String^ MiddleName {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

NamePart Class
NamePart Members


NamePrefix Property

NamePrefix Property

DicomObjects.DicomWeb.Internal Namespace > NamePart Class : NamePrefix Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NamePrefix As String
'Usage

Dim instance As NamePart
Dim value As String

instance.NamePrefix = value

value = instance.NamePrefix
public string NamePrefix {get; set;}
public:
property String^ NamePrefix {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

NamePart Class
NamePart Members


NameSuffix Property

NameSuffix Property

DicomObjects.DicomWeb.Internal Namespace > NamePart Class : NameSuffix Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NameSuffix As String
'Usage

Dim instance As NamePart
Dim value As String

instance.NameSuffix = value

value = instance.NameSuffix
public string NameSuffix {get; set;}
public:
property String^ NameSuffix {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

NamePart Class
NamePart Members


NativeDicomModel Class

NativeDicomModel Class
Members

DicomObjects.DicomWeb.Internal Namespace : NativeDicomModel Class
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class NativeDicomModel
'Usage

Dim instance As NativeDicomModel
public class NativeDicomModel
public ref class NativeDicomModel
Inheritance Hierarchy

System.Object
DicomObjects.DicomWeb.Internal.NativeDicomModel

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

NativeDicomModel Members
DicomObjects.DicomWeb.Internal Namespace


NativeDicomModel Class Members

NativeDicomModel Class Members
Fields Properties

DicomObjects.DicomWeb.Internal Namespace : NativeDicomModel Class

The following tables list the members exposed by NativeDicomModel.

Public Constructors
 | Name | Description
Public Constructor | NativeDicomModel Constructor | Default Constructor
Top
Public Fields
 | Name | Description
Public Field | Space | Internal Use Only
Top
Public Properties
 | Name | Description
Public Property | Attributes | Internal Use Only
Top
See Also

Reference

NativeDicomModel Class
DicomObjects.DicomWeb.Internal Namespace


NativeDicomModel Constructor

NativeDicomModel Constructor

DicomObjects.DicomWeb.Internal Namespace > NativeDicomModel Class : NativeDicomModel Constructor
Default Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New NativeDicomModel()
public NativeDicomModel()
public:
NativeDicomModel();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

NativeDicomModel Class
NativeDicomModel Members


NativeDicomModel Class Properties

NativeDicomModel Class Properties

DicomObjects.DicomWeb.Internal Namespace : NativeDicomModel Class

For a list of all members of this type, see NativeDicomModel members.

Public Properties
 | Name | Description
Public Property | Attributes | Internal Use Only
Top
See Also

Reference

NativeDicomModel Class
DicomObjects.DicomWeb.Internal Namespace


Attributes Property (NativeDicomModel)

Attributes Property (NativeDicomModel)

DicomObjects.DicomWeb.Internal Namespace > NativeDicomModel Class : Attributes Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Attributes As List(Of DicomAttribute)
'Usage

Dim instance As NativeDicomModel
Dim value As List(Of DicomAttribute)

instance.Attributes = value

value = instance.Attributes
public List<DicomAttribute> Attributes {get; set;}
public:
property List<DicomAttribute^>^ Attributes {
   List<DicomAttribute^>^ get();
   void set (    List<DicomAttribute^>^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

NativeDicomModel Class
NativeDicomModel Members


NativeDicomModel Class Fields

NativeDicomModel Class Fields

DicomObjects.DicomWeb.Internal Namespace : NativeDicomModel Class

For a list of all members of this type, see NativeDicomModel members.

Public Fields
 | Name | Description
Public Field | Space | Internal Use Only
Top
See Also

Reference

NativeDicomModel Class
DicomObjects.DicomWeb.Internal Namespace


Space Field

Space Field

DicomObjects.DicomWeb.Internal Namespace > NativeDicomModel Class : Space Field
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Space As String
'Usage

Dim value As String

value = NativeDicomModel.Space
public const string Space
public:
const String^ Space
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

NativeDicomModel Class
NativeDicomModel Members


PersonName Class

PersonName Class
Members

DicomObjects.DicomWeb.Internal Namespace : PersonName Class
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PersonName
'Usage

Dim instance As PersonName
public class PersonName
public ref class PersonName
Inheritance Hierarchy

System.Object
DicomObjects.DicomWeb.Internal.PersonName

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

PersonName Members
DicomObjects.DicomWeb.Internal Namespace


PersonName Class Members

PersonName Class Members
Properties

DicomObjects.DicomWeb.Internal Namespace : PersonName Class

The following tables list the members exposed by PersonName.

Public Constructors
 | Name | Description
Public Constructor | PersonName Constructor |
Top
Public Properties
 | Name | Description
Public Property | Alphabetic | Internal Use Only
Public Property | Ideographic | Internal Use Only
Public Property | number | Internal Use Only
Public Property | Phonetic | Internal Use Only
Top
See Also

Reference

PersonName Class
DicomObjects.DicomWeb.Internal Namespace


PersonName Constructor

PersonName Constructor

DicomObjects.DicomWeb.Internal Namespace > PersonName Class : PersonName Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PersonName()
public PersonName()
public:
PersonName();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

PersonName Class
PersonName Members


PersonName Class Properties

PersonName Class Properties

DicomObjects.DicomWeb.Internal Namespace : PersonName Class

For a list of all members of this type, see PersonName members.

Public Properties
 | Name | Description
Public Property | Alphabetic | Internal Use Only
Public Property | Ideographic | Internal Use Only
Public Property | number | Internal Use Only
Public Property | Phonetic | Internal Use Only
Top
See Also

Reference

PersonName Class
DicomObjects.DicomWeb.Internal Namespace


Alphabetic Property (PersonName)

Alphabetic Property (PersonName)

DicomObjects.DicomWeb.Internal Namespace > PersonName Class : Alphabetic Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Alphabetic As NamePart
'Usage

Dim instance As PersonName
Dim value As NamePart

instance.Alphabetic = value

value = instance.Alphabetic
public NamePart Alphabetic {get; set;}
public:
property NamePart^ Alphabetic {
   NamePart^ get();
   void set (    NamePart^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

PersonName Class
PersonName Members


Ideographic Property (PersonName)

Ideographic Property (PersonName)

DicomObjects.DicomWeb.Internal Namespace > PersonName Class : Ideographic Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Ideographic As NamePart
'Usage

Dim instance As PersonName
Dim value As NamePart

instance.Ideographic = value

value = instance.Ideographic
public NamePart Ideographic {get; set;}
public:
property NamePart^ Ideographic {
   NamePart^ get();
   void set (    NamePart^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

PersonName Class
PersonName Members


number Property (PersonName)

number Property (PersonName)

DicomObjects.DicomWeb.Internal Namespace > PersonName Class : number Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property number As Integer
'Usage

Dim instance As PersonName
Dim value As Integer

instance.number = value

value = instance.number
public int number {get; set;}
public:
property int number {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

PersonName Class
PersonName Members


Phonetic Property (PersonName)

Phonetic Property (PersonName)

DicomObjects.DicomWeb.Internal Namespace > PersonName Class : Phonetic Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Phonetic As NamePart
'Usage

Dim instance As PersonName
Dim value As NamePart

instance.Phonetic = value

value = instance.Phonetic
public NamePart Phonetic {get; set;}
public:
property NamePart^ Phonetic {
   NamePart^ get();
   void set (    NamePart^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

PersonName Class
PersonName Members


Value Class

Value Class
Members

DicomObjects.DicomWeb.Internal Namespace : Value Class
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class Value
'Usage

Dim instance As Value
public class Value
public ref class Value
Inheritance Hierarchy

System.Object
DicomObjects.DicomWeb.Internal.Value

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Value Members
DicomObjects.DicomWeb.Internal Namespace


Value Class Members

Value Class Members
Properties

DicomObjects.DicomWeb.Internal Namespace : Value Class

The following tables list the members exposed by Value.

Public Constructors
 | Name | Description
Public Constructor | Value Constructor |
Top
Public Properties
 | Name | Description
Public Property | Content | Internal Use Only
Public Property | Number | Internal Use Only
Top
See Also

Reference

Value Class
DicomObjects.DicomWeb.Internal Namespace


Value Constructor

Value Constructor

DicomObjects.DicomWeb.Internal Namespace > Value Class : Value Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Value()
public Value()
public:
Value();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Value Class
Value Members


Value Class Properties

Value Class Properties

DicomObjects.DicomWeb.Internal Namespace : Value Class

For a list of all members of this type, see Value members.

Public Properties
 | Name | Description
Public Property | Content | Internal Use Only
Public Property | Number | Internal Use Only
Top
See Also

Reference

Value Class
DicomObjects.DicomWeb.Internal Namespace


Content Property

Content Property

DicomObjects.DicomWeb.Internal Namespace > Value Class : Content Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Content As String
'Usage

Dim instance As Value
Dim value As String

instance.Content = value

value = instance.Content
public string Content {get; set;}
public:
property String^ Content {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Value Class
Value Members


Number Property (Value)

Number Property (Value)

DicomObjects.DicomWeb.Internal Namespace > Value Class : Number Property
Internal Use Only
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Number As Integer
'Usage

Dim instance As Value
Dim value As Integer

instance.Number = value

value = instance.Number
public int Number {get; set;}
public:
property int Number {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Value Class
Value Members


DicomObjects.Enums Namespace

DicomObjects.Enums Namespace
Inheritance Hierarchy
The various enumerations used by DicomObjects
Enumerations
 | Enumeration | Description
Enumeration | AutoSizeMode | Possible values for controlling the size of a text label.
Enumeration | BasicOffsetTableHandling | Allows control of Basic Offset Table (BOT) Handling when writing data
Enumeration | CacheTypes | Flags which are used to control caching.
Enumeration | ChangeUidReason | reason why a UID should be changed
Enumeration | CineMode | Enumerated values for cine mode
Enumeration | CodecOperation | The basic types of codec operation requested by DicomObjects
Enumeration | CodecUsage | Enum to control whether a codec should use the Windows codec when available.
Enumeration | DecompressStatus | The state of decompression of an image
Enumeration | DicomOperation | The Full List of DICOM Primitive operations
Enumeration | DisplayMode | Controls how images are rendered
Enumeration | DrawCacheMode | Controls how images are drawn internally
Enumeration | FilterMode | Enumerated values for filter mode
Enumeration | FlipState | Enumerated values for flip mode
Enumeration | Keyword | The complete enumerated list of all DICOM data element. Enum representation can be used for adding and indexing data element in DicomDataSet object
Enumeration | LabelType | The possible types of DicomObjects.DicomLabel
Enumeration | LicensedFunctions | A bitmask representing the functions that a particular license allows to be used by DicomObjects.
Enumeration | LicenseTypes | Indicates the basic type of DicomObjects license
Enumeration | LogLevel | Log levels
Enumeration | MaskMode | Enumerated values for mask operations
Enumeration | Plane | Common planes used to display 3D images
Enumeration | PresentationStateFeatures | Flags to control which features of presentation states are used and/or converted
Enumeration | Progression | Ordering of packet used in JPEG 2000 & JPIP
Enumeration | ProgressiveStatus | The status of an image being viewed in a progressive manner
Enumeration | QueryLevel | Enumerated values for Query Level
Enumeration | QueryRoot | Enumerated values for Query Root
Enumeration | RequestType | Enum used in the DicomObjects.Internal.PixelRequest class to pecify the required usage of the data requested
Enumeration | RetrieveType | The type of retrieval requested
Enumeration | RotateState | Enumerated values for rotate mode
Enumeration | RotationBehaviour | Rotation behaviour of the Image
Enumeration | RotationCentre | Possible values for controlling the centre of rotation of a text label.
Enumeration | RotationMode | Possible values for controlling the rotation behaviour of a label.
Enumeration | RulerOptions | Ruler options to for alignment and spacing
Enumeration | ScaleMode | How DicomLabel objects' dimensions should be interpreted - i.e. how they should be scaled
Enumeration | SelectMode | Enumerated values for DicomLabel select mode
Enumeration | ShadowTypes | Controls whether a labels is displayed with a specified shadow, to make it more visible over image areas with similar color.
Enumeration | SOPClassGroups | The categories of SOP class used for negotiation
Enumeration | StatusCode | Common DICOM status codes
Enumeration | StatusType | DICOM status code type
Enumeration | StretchModes | Controls how an image is displayed
Enumeration | UIDType | Classification of DICOM UID types
Enumeration | UserIdentityResponseType | User Identity Response Type for User Identity Negotiation
Enumeration | UserIdentityType | User Identity Type for User Identity Negotiation
Enumeration | ViewerMode | The modes which can be used for displaying DICOM images in a DicomObjects.DicomViewer
Enumeration | VoiLUTFunction | Controls which VOILUT function to be used
Enumeration | WaveletTransform | The types of wavelet transform used in JPEG 2000 & JPIP
See Also

Reference

DicomObjects.NET.8.40 Assembly


AutoSizeMode Enumeration

AutoSizeMode Enumeration

DicomObjects.Enums Namespace : AutoSizeMode Enumeration
Possible values for controlling the size of a text label.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum AutoSizeMode
   Inherits System.Enum
'Usage

Dim instance As AutoSizeMode
public enum AutoSizeMode : System.Enum
public enum class AutoSizeMode : public System.Enum
Members
Member | Description
Auto | Both the height and width are reduced to fit the size of the text displayed. The original width is still used to control the wrapping of the text
AutoSizeHeight | The original width, as defined by the label's Area is used, but the height is reduced to fit the size of the actual text displayed
AutoSizeWidth | The original height, as defined by the label's Area is used, but the width is reduced to fit the size of the actual text displayed
NoAutoSize | The original size, as defined by the label's Area is used.
Remarks
This is used by the DicomLabel's AutoSizeMode property. It is used to control both the drawing of a visible box around the text, and also used for the positioning of child labels and for rotation.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.AutoSizeMode

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


BasicOffsetTableHandling Enumeration

BasicOffsetTableHandling Enumeration

DicomObjects.Enums Namespace : BasicOffsetTableHandling Enumeration
Allows control of Basic Offset Table (BOT) Handling when writing data
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum BasicOffsetTableHandling
   Inherits System.Enum
'Usage

Dim instance As BasicOffsetTableHandling
public enum BasicOffsetTableHandling : System.Enum
public enum class BasicOffsetTableHandling : public System.Enum
Members
Member | Description
CompressAndCache | Each frame is compressed and cached in memory, allowing the lengths to be calculated. The BOT is then written using those lengths, followed by the cached fragments themselves.
CompressTwice | Each frame is compressed allowing the lengths to be calculated, but the frames are discarded. The BOT is then written using those lengths, followed by the fragments themselves, which are generated by compressing the data a second time.
Omit | An empty (zero-length) BOT is written
Seek | The individual fragments are written, and the stream position is then moved back to the BOT to write the locations. This is the most efficient solution to producing a BOT, but is only applicable to seekable media and therefore cannot be used when performing C-STORE etc.
Remarks
This is used by the DicomObjects.WriteBehaviours.NonSeekableBotHandling and DicomObjects.WriteBehaviours.SeekableBotHandling properties.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.BasicOffsetTableHandling

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


CacheTypes Enumeration

CacheTypes Enumeration

DicomObjects.Enums Namespace : CacheTypes Enumeration
Flags which are used to control caching.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum CacheTypes
   Inherits System.Enum
'Usage

Dim instance As CacheTypes
public enum CacheTypes : System.Enum
public enum class CacheTypes : public System.Enum
Members
Member | Description
All | All caches
CompressedData | Specifies the raw compressed pixel data (where it needs to be read from disk)
Display | Specifies the cached copy of the pixel display data
LookupTables | Specifies the lookup tables generated as a result of windowing etc.
None | No caching at all
PixelData | Specifies the raw uncompressed pixel data (where it needs to be decompressed or read from disk)
Texture | Specifies the GPU texture for the basic image data (before indowing etc.) in DirectX mode.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.CacheTypes

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


ChangeUidReason Enumeration

ChangeUidReason Enumeration

DicomObjects.Enums Namespace : ChangeUidReason Enumeration
reason why a UID should be changed
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum ChangeUidReason
   Inherits System.Enum
'Usage

Dim instance As ChangeUidReason
public enum ChangeUidReason : System.Enum
public enum class ChangeUidReason : public System.Enum
Members
Member | Description
LossyCompression | Lossy image compression is being applied
SopClassCoersion | The SOP class is being coerced
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.ChangeUidReason

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


CineMode Enumeration

CineMode Enumeration

DicomObjects.Enums Namespace : CineMode Enumeration
Enumerated values for cine mode
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum CineMode
   Inherits System.Enum
'Usage

Dim instance As CineMode
public enum CineMode : System.Enum
public enum class CineMode : public System.Enum
Members
Member | Description
Forward | A single run is made through the frames, and at the end, the value of this property reverts to doCineStatic.
Oscillate | The sequence runs from the first frame to the last, and then back through the frames to the first, and the process then restarts.
Repeat | The sequence of frames is run continuously from the first, to the last, and the sequence then restarts.
RepeatReverse | The sequence of frames is run continuously from the last, to the first, and the sequence then restarts.
Reverse | A single run is made through the frames in reverse, and at the end (frame 1), the value of this property reverts to doCineStatic.
Static | The default mode. The displayed frame is selected by the Frame property, and does not change.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.CineMode

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


CodecOperation Enumeration

CodecOperation Enumeration

DicomObjects.Enums Namespace : CodecOperation Enumeration
The basic types of codec operation requested by DicomObjects
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum CodecOperation
   Inherits System.Enum
'Usage

Dim instance As CodecOperation
public enum CodecOperation : System.Enum
public enum class CodecOperation : public System.Enum
Members
Member | Description
Compress | Compression of DICOM images
Decompress | Decompression of DICOM compressed images
Export | Export of images to external files
Import | Import of images from external files
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.CodecOperation

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


CodecUsage Enumeration

CodecUsage Enumeration

DicomObjects.Enums Namespace : CodecUsage Enumeration
Enum to control whether a codec should use the Windows codec when available.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum CodecUsage
   Inherits System.Enum
'Usage

Dim instance As CodecUsage
public enum CodecUsage : System.Enum
public enum class CodecUsage : public System.Enum
Members
Member | Description
DicomObjects | Use the DicomObjects codec
Windows | Use the Windows codec
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.CodecUsage

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


DecompressStatus Enumeration

DecompressStatus Enumeration

DicomObjects.Enums Namespace : DecompressStatus Enumeration
The state of decompression of an image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum DecompressStatus
   Inherits System.Enum
'Usage

Dim instance As DecompressStatus
public enum DecompressStatus : System.Enum
public enum class DecompressStatus : public System.Enum
Members
Member | Description
AllDownloaded | All data downloaded has been decompressed
Complete | The image has been fully decompressed at full resolution
InProgress | Data is waiting to be decompressed
None | Nothing decompressed yet
Remarks
This status is normally relative to a particular DicomObjects.Internal.PixelRequest
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.DecompressStatus

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


DicomOperation Enumeration

DicomOperation Enumeration

DicomObjects.Enums Namespace : DicomOperation Enumeration
The Full List of DICOM Primitive operations
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum DicomOperation
   Inherits System.Enum
'Usage

Dim instance As DicomOperation
public enum DicomOperation : System.Enum
public enum class DicomOperation : public System.Enum
Members
Member | Description
C_CANCEL | C-CANCEL : 0FFFH
C_ECHO | C-ECHO : 0030H
C_ECHO_RSP | C-ECHO Response : 8030H
C_FIND | C-FIND : 0020H
C_FIND_RSP | C-FIND Response : 8020H
C_GET | C-GET : 0010H
C_GET_RSP | C-GET Response : 8010H
C_MOVE | C-MOVE : 0021H
C_MOVE_RSP | C-MOVE Response : 8021H
C_STORE | C-STORE : 0001H
C_STORE_RSP | C-STORE Response : 8001H
N_ACTION | N-ACTION : 0130H
N_ACTION_RSP | N-ACTION Response : 8130H
N_CREATE | N-CREATE : 0140H
N_CREATE_RSP | N-CREATE Response : 8140H
N_DELETE | N-DELETE : 0150H
N_DELETE_RSP | N-DELETE Response : 8150H
N_EVENT_REPORT | N-EVENT_REPORT : 0100H
N_EVENT_REPORT_RSP | N-EVENT_REPORT Response : 8100H
N_GET | N-GET : 0110H
N_GET_RSP | N-GET Response : 8110H
N_SET | N-SET : 0120H
N_SET_RSP | N-SET Response : 8120H
NONE | No Operation
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.DicomOperation

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


DisplayMode Enumeration

DisplayMode Enumeration

DicomObjects.Enums Namespace : DisplayMode Enumeration
Controls how images are rendered
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum DisplayMode
   Inherits System.Enum
'Usage

Dim instance As DisplayMode
public enum DisplayMode : System.Enum
public enum class DisplayMode : public System.Enum
Members
Member | Description
Auto | Use Monochome if the image is monochrom and RGB is the image is colour
Monochrome | Force use of monochrome mode
RGB | Force use of RGB mode
Remarks
Although public, this is an experimental enum intended for performance tuning experiments and may not be supported in future versions of DicomObjects
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.DisplayMode

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


DrawCacheMode Enumeration

DrawCacheMode Enumeration

DicomObjects.Enums Namespace : DrawCacheMode Enumeration
Controls how images are drawn internally
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum DrawCacheMode
   Inherits System.Enum
'Usage

Dim instance As DrawCacheMode
public enum DrawCacheMode : System.Enum
public enum class DrawCacheMode : public System.Enum
Members
Member | Description
AfterLabels | Rendered copy has labelled added and is then cached. If this mode is used, then the cache is cleared when labels change. This mode is incompatible with DisplayMode.Monochrome as .NET des not permit use of a monochrome bitmap as a Graphics object. The mode will silently revert to BeforeLabels if DisplayMode is monochrome, or if it is Auto on a monochrome image.
BeforeLabels | Rendered copy is cached, and then drawn to the screen. Labels are drawn separately to the screen.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.DrawCacheMode

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


FilterMode Enumeration

FilterMode Enumeration

DicomObjects.Enums Namespace : FilterMode Enumeration
Enumerated values for filter mode
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum FilterMode
   Inherits System.Enum
'Usage

Dim instance As FilterMode
public enum FilterMode : System.Enum
public enum class FilterMode : public System.Enum
Members
Member | Description
BiLinear | This mode is most applicable when zoom is >1, and uses bilinear interpolation. This is a simple and relatively fast means of magnification.
BSpline | This smoothing procedure interpolates using a Cubic B-Spline, which has the advantage of guaranteeing continuity in both the first and second differentials of the image, in both directions. No other parameters are used in this smoothing method, which produces good visual results, though some users find them a little too "smoothed"
BSpline2 | Custom format
CubicSpline | This is similar to the B-Spline described above, but uses an additional parameter (CubicSplineAlpha) to control the degree of smoothing or edge enhancement. The default value is –0.75, and normal values range fro –0.5 to –1.25, though higher negative values may be used to produce deliberate edge enhancement, though generally, UnsharpLength and UnsharpEnhancement should be used for this purpose, as they are independent of the smoothing method.
Default | For MagnificationMode, this acts identically to doFilterReplicate and for MinificationMode it acts as doFilterMovingAverage. This behaviour is the default, and is designed to minimise regulatory issues by doing the minimum necessary to display all pixel data, without adding extra "Image processing".
Gpu | This mode uses interpolation in the GPU to apply magnification or minification. It does not give as much flexibility as the other modes, but may be significant faster, whilst still avoiding a "blocky" effect for magnification and avoiding aliasing on grid-lines for minification.
MovingAverage | This mode is most applicable when zoom is <1, and calculates pixel values as a weighted average of the surrounding values. The number of values used for this calculation depends on the value of FilterLength. If this is 0 (the default), then a suitable values is determined internally, based on the zoom (approximately 2/ActualZoom), but if FilterLength is non-zero then 2*FilterLength values are used.
Replicate | If zooming up is necessary, then pixels are simply replicated, giving a possibly "blocky" but honest representation of the pixel data. For minification, rows and columns are simply omitted as necessary.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.FilterMode

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


FlipState Enumeration

FlipState Enumeration

DicomObjects.Enums Namespace : FlipState Enumeration
Enumerated values for flip mode
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum FlipState
   Inherits System.Enum
'Usage

Dim instance As FlipState
public enum FlipState : System.Enum
public enum class FlipState : public System.Enum
Members
Member | Description
Both | Image is mirrored vertically and horizontally
Horizontal | Image is mirrored horizontally
Normal | No flipping specified
Vertical | Image is mirrored vertically
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.FlipState

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


Keyword Enumeration

Keyword Enumeration

DicomObjects.Enums Namespace : Keyword Enumeration
The complete enumerated list of all DICOM data element. Enum representation can be used for adding and indexing data element in DicomDataSet object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum Keyword
   Inherits System.Enum
'Usage

Dim instance As Keyword
public enum Keyword : System.Enum
public enum class Keyword : public System.Enum
Members
Member | Description
AbortFlag | (4010,1024): Abort Flag
AbortReason | (4010,1021): Abort Reason
AbsoluteChannelDisplayScale | (003A,0248): Absolute Channel Display Scale
AbsoluteDosimetricObjectiveFlag | (3010,0073): Absolute Dosimetric Objective Flag
AbsorbedDoseToMetersetRatio | (300C,0121): Absorbed Dose to Meterset Ratio
AbstractPriorCodeSequence | (0072,003E): Abstract Prior Code Sequence
AbstractPriorValue | (0072,003C): Abstract Prior Value
Acceleration | (0016,0034): Acceleration
AccessionNumber | (0008,0050): Accession Number
AccessoryCode | (300A,00F9): Accessory Code
AcquiredImageAreaDoseProduct | (0018,9473): Acquired Image Area Dose Product
AcquiredSoundpathLength | (0014,4031): Acquired Soundpath Length
AcquiredSubtractionMaskFlag | (0018,11B2): Acquired Subtraction Mask Flag
AcquisitionComments | (0018,4000): Acquisition Comments(Retired)
AcquisitionCompressionType | (0014,4032): Acquisition Compression Type
AcquisitionContextDescription | (0040,0556): Acquisition Context Description
AcquisitionContextSequence | (0040,0555): Acquisition Context Sequence
AcquisitionContrast | (0008,9209): Acquisition Contrast
AcquisitionDate | (0008,0022): Acquisition Date
AcquisitionDateTime | (0008,002A): Acquisition DateTime
AcquisitionDeviceProcessingCode | (0018,1401): Acquisition Device Processing Code
AcquisitionDeviceProcessingDescription | (0018,1400): Acquisition Device Processing Description
AcquisitionDeviceTypeCodeSequence | (0022,0015): Acquisition Device Type Code Sequence
AcquisitionDuration | (0018,9073): Acquisition Duration
AcquisitionEndLocationSequence | (0018,9932): Acquisition End Location Sequence
AcquisitionFieldOfViewLabel | (0018,11BB): Acquisition Field of View Label
AcquisitionIndex | (0020,9518): Acquisition Index
AcquisitionMatrix | (0018,1310): Acquisition Matrix
AcquisitionMethodAlgorithmSequence | (0022,1423): Acquisition Method Algorithm Sequence
AcquisitionMethodCodeSequence | (0022,1420): Acquisition Method Code Sequence
AcquisitionMode | (0018,11B0): Acquisition Mode
AcquisitionMotion | (0018,9930): Acquisition Motion
AcquisitionNumber | (0020,0012): Acquisition Number
AcquisitionProtocolDescription | (0018,9424): Acquisition Protocol Description
AcquisitionProtocolElementSequence | (0018,9920): Acquisition Protocol Element Sequence
AcquisitionProtocolElementSpecificationSequence | (0018,991F): Acquisition Protocol Element Specification Sequence
AcquisitionProtocolName | (0018,9423): Acquisition Protocol Name
AcquisitionSampleSize | (0014,4033): Acquisition Sample Size
AcquisitionsInSeries | (0020,1001): Acquisitions in Series(Retired)
AcquisitionsInStudy | (0020,1004): Acquisitions in Study
AcquisitionStartCondition | (0018,0073): Acquisition Start Condition
AcquisitionStartConditionData | (0018,0074): Acquisition Start Condition Data
AcquisitionStartLocationSequence | (0018,9931): Acquisition Start Location Sequence
AcquisitionStatus | (4010,1044): Acquisition Status
AcquisitionTerminationCondition | (0018,0071): Acquisition Termination Condition
AcquisitionTerminationConditionData | (0018,0075): Acquisition Termination Condition Data
AcquisitionTime | (0008,0032): Acquisition Time
AcquisitionTimeSynchronized | (0018,1800): Acquisition Time Synchronized
AcquisitionType | (0018,9302): Acquisition Type
AcrossScanSpatialResolution | (0022,0048): Across-scan Spatial Resolution
ActionTypeID | (0000,1008): Action Type ID
ActiveAperture | (0014,5100): Active Aperture
ActiveImageAreaOverlayGroup | (0018,6070): Active Image Area Overlay Group
ActiveSourceDiameter | (300A,0218): Active Source Diameter
ActiveSourceLength | (300A,021A): Active Source Length
ActualCardiacTriggerDelayTime | (0020,9252): Actual Cardiac Trigger Delay Time
ActualCardiacTriggerTimePriorToRPeak | (0020,9155): Actual Cardiac Trigger Time Prior To R-Peak
ActualEnvironmentalConditions | (0014,1010): Actual Environmental Conditions
ActualFrameDuration | (0018,1242): Actual Frame Duration
ActualHumanPerformersSequence | (0040,4035): Actual Human Performers Sequence
ActualRespiratoryTriggerDelayTime | (0020,9257): Actual Respiratory Trigger Delay Time
AdaptiveMapFormat | (0028,0730): Adaptive Map Format
AddGrayScale | (0000,5150): Add Gray Scale(Retired)
AddIntermediateSequence | (0046,0101): Add Intermediate Sequence
AdditionalDrugSequence | (0018,002A): Additional Drug Sequence
AdditionalInspectionMethodSequence | (4010,106F): Additional Inspection Method Sequence
AdditionalInspectionSelectionCriteria | (4010,106E): Additional Inspection Selection Criteria
AdditionalParameterRecordingInstanceSequence | (300A,0780): Additional Parameter Recording Instance Sequence
AdditionalPatientHistory | (0010,21B0): Additional Patient History
AdditionalRTROIIdentificationCodeSequence | (3006,00B9): Additional RT ROI Identification Code Sequence
AdditionalScreeningPerformed | (4010,106D): Additional Screening Performed
AddNearSequence | (0046,0100): Add Near Sequence
AddOtherSequence | (0046,0102): Add Other Sequence
AddPower | (0046,0104): Add Power
AddressTrial | (0040,A353): Address (Trial)
AdministrationRouteCodeSequence | (0054,0302): Administration Route Code Sequence
AdmissionID | (0038,0010): Admission ID
AdmittingDate | (0038,0020): Admitting Date
AdmittingDiagnosesCodeSequence | (0008,1084): Admitting Diagnoses Code Sequence
AdmittingDiagnosesDescription | (0008,1080): Admitting Diagnoses Description
AdmittingTime | (0038,0021): Admitting Time
AdvancedBlendingSequence | (0070,1B01): Advanced Blending Sequence
AffectedSOPClassUID | (0000,0002): Affected SOP Class UID
AffectedSOPInstanceUID | (0000,1000): Affected SOP Instance UID
AfterloaderChannelID | (300A,0273): Afterloader Channel ID
AgeCorrectedSensitivityDeviationAlgorithmSequence | (0024,0065): Age Corrected Sensitivity Deviation Algorithm Sequence
AgeCorrectedSensitivityDeviationProbabilityValue | (0024,0100): Age Corrected Sensitivity Deviation Probability Value
AgeCorrectedSensitivityDeviationValue | (0024,0092): Age Corrected Sensitivity Deviation Value
AirCounts | (0014,3070): Air Counts
AITDeviceType | (4010,1070): AIT Device Type
AlarmDecision | (4010,1031): Alarm Decision
AlarmDecisionTime | (4010,102B): Alarm Decision Time
AlgorithmCodeSequenceTrial | (0040,A296): Algorithm Code Sequence (Trial)
AlgorithmDescription | (0018,9528): Algorithm Description
AlgorithmDescriptionTrial | (0040,A297): Algorithm Description (Trial)
AlgorithmFamilyCodeSequence | (0066,002F): Algorithm Family Code Sequence
AlgorithmName | (0066,0036): Algorithm Name
AlgorithmNameCodeSequence | (0066,0030): Algorithm Name Code Sequence
AlgorithmParameters | (0066,0032): Algorithm Parameters
AlgorithmRoutingCodeSequence | (4010,1064): Algorithm Routing Code Sequence
AlgorithmSource | (0024,0202): Algorithm Source
AlgorithmType | (0018,9527): Algorithm Type
AlgorithmVersion | (0066,0031): Algorithm Version
AliasedDataType | (0018,980B): Aliased Data Type
ALinePixelSpacing | (0052,0014): A-line Pixel Spacing
ALineRate | (0052,0011): A-line Rate
ALinesPerFrame | (0052,0012): A-lines Per Frame
Allergies | (0010,2110): Allergies
AllowLossyCompression | (2200,000F): Allow Lossy Compression
AllowMediaSplitting | (2200,0007): Allow Media Splitting
AlongScanSpatialResolution | (0022,0037): Along-scan Spatial Resolution
AlphaLUTTransferFunction | (0028,1410): Alpha LUT Transfer Function
AlphaPaletteColorLookupTableData | (0028,1204): Alpha Palette Color Lookup Table Data
AlphaPaletteColorLookupTableDescriptor | (0028,1104): Alpha Palette Color Lookup Table Descriptor
AlternateBeamDose | (300A,0091): Alternate Beam Dose
AlternateBeamDoseType | (300A,0092): Alternate Beam Dose Type
AlternateContainerIdentifierSequence | (0040,0515): Alternate Container Identifier Sequence
AlternateContentDescriptionSequence | (0070,0087): Alternate Content Description Sequence
AlternateRepresentationSequence | (0008,3001): Alternate Representation Sequence
AlternateValueSequence | (300A,073E): Alternate Value Sequence
AmbientLightValueSource | (0028,7025): Ambient Light Value Source
AmbientReflectionIntensity | (0070,1702): Ambient Reflection Intensity
AmplifierType | (0014,400A): Amplifier Type
AnalyzedArea | (0046,0227): Analyzed Area
AnatomicalOrientationType | (0010,2210): Anatomical Orientation Type
AnatomicApproachDirectionCodeSequenceTrial | (0008,2255): Anatomic Approach Direction Code Sequence (Trial)
AnatomicLocationOfExaminingInstrumentCodeSequenceTrial | (0008,2259): Anatomic Location Of Examining Instrument Code Sequence (Trial)
AnatomicLocationOfExaminingInstrumentDescriptionTrial | (0008,2258): Anatomic Location Of Examining Instrument Description (Trial)
AnatomicPerspectiveCodeSequenceTrial | (0008,2257): Anatomic Perspective Code Sequence (Trial)
AnatomicPerspectiveDescriptionTrial | (0008,2256): Anatomic Perspective Description (Trial)
AnatomicPortalOfEntranceCodeSequenceTrial | (0008,2253): Anatomic Portal Of Entrance Code Sequence (Trial)
AnatomicRegionModifierSequence | (0008,2220): Anatomic Region Modifier Sequence
AnatomicRegionSequence | (0008,2218): Anatomic Region Sequence
AnatomicRegionsInStudyCodeSequence | (0008,0063): Anatomic Regions in Study Code Sequence
AnatomicStructure | (0008,2208): Anatomic Structure
AnatomicStructureReferencePoint | (0022,1463): Anatomic Structure Reference Point
AnatomicStructureSpaceOrRegionCodeSequenceTrial | (0008,2251): Anatomic Structure Space Or Region Code Sequence (Trial)
AnatomicStructureSpaceOrRegionModifierCodeSequenceTrial | (0008,225A): Anatomic Structure Space Or Region Modifier Code Sequence (Trial)
AnatomicStructureSpaceOrRegionSequence | (0008,2229): Anatomic Structure, Space or Region Sequence
AnchorPoint | (0070,0014): Anchor Point
AnchorPointAnnotationUnits | (0070,0004): Anchor Point Annotation Units
AnchorPointVisibility | (0070,0015): Anchor Point Visibility
AngioFlag | (0018,0025): Angio Flag
AngleNumber | (0020,0018): Angle Number
AngularPosition | (0018,1141): Angular Position
AngularStep | (0018,1144): Angular Step
AngularViewVector | (0054,0090): Angular View Vector
AnimationCurveSequence | (0070,1A04): Animation Curve Sequence
AnimationStepSize | (0070,1A05): Animation Step Size
AnnotationAppliesToAllOpticalPaths | (006A,000D): Annotation Applies to All Optical Paths
AnnotationAppliesToAllZPlanes | (006A,000F): Annotation Applies to All Z Planes
AnnotationClipping | (0070,1907): Annotation Clipping
AnnotationContentSequence | (2130,0050): Annotation Content Sequence
AnnotationCoordinateType | (006A,0001): Annotation Coordinate Type
AnnotationDisplayFormatID | (2010,0030): Annotation Display Format ID
AnnotationFlag | (2000,0065): Annotation Flag
AnnotationGroupAlgorithmIdentificationSequence | (006A,0008): Annotation Group Algorithm Identification Sequence
AnnotationGroupDescription | (006A,0006): Annotation Group Description
AnnotationGroupGenerationType | (006A,0007): Annotation Group Generation Type
AnnotationGroupLabel | (006A,0005): Annotation Group Label
AnnotationGroupNumber | (0040,A180): Annotation Group Number
AnnotationGroupSequence | (006A,0002): Annotation Group Sequence
AnnotationGroupUID | (006A,0003): Annotation Group UID
AnnotationIndexList | (006A,0011): Annotation Index List
AnnotationPosition | (2030,0010): Annotation Position
AnnotationPropertyCategoryCodeSequence | (006A,0009): Annotation Property Category Code Sequence
AnnotationPropertyTypeCodeSequence | (006A,000A): Annotation Property Type Code Sequence
AnnotationPropertyTypeModifierCodeSequence | (006A,000B): Annotation Property Type Modifier Code Sequence
AnodeTargetMaterial | (0018,1191): Anode Target Material
AnomalyLocatorIndicator | (4010,107A): Anomaly Locator Indicator
AnomalyLocatorIndicatorSequence | (4010,1079): Anomaly Locator Indicator Sequence
AnteriorChamberDepth | (0022,1131): Anterior Chamber Depth
AnteriorChamberDepthDefinitionCodeSequence | (0022,1125): Anterior Chamber Depth Definition Code Sequence
AnteriorChamberDepthSequence | (0022,1128): Anterior Chamber Depth Sequence
ApertureElevation | (0014,5102): Aperture Elevation
ApertureValue | (0016,0022): Aperture Value
ApexPosition | (0020,9308): Apex Position
ApplicableFrameRange | (0028,6102): Applicable Frame Range
ApplicableSafetyStandardAgency | (0018,9174): Applicable Safety Standard Agency
ApplicableSafetyStandardDescription | (0018,9175): Applicable Safety Standard Description
ApplicationManufacturer | (0018,9526): Application Manufacturer
ApplicationMaximumRepaintTime | (0072,010E): Application Maximum Repaint Time
ApplicationName | (0018,9524): Application Name
ApplicationSetupCheck | (3008,0116): Application Setup Check
ApplicationSetupManufacturer | (300A,0238): Application Setup Manufacturer
ApplicationSetupName | (300A,0236): Application Setup Name
ApplicationSetupNumber | (300A,0234): Application Setup Number
ApplicationSetupSequence | (300A,0230): Application Setup Sequence
ApplicationSetupType | (300A,0232): Application Setup Type
ApplicationVersion | (0018,9525): Application Version
ApplicatorApertureShape | (300A,0432): Applicator Aperture Shape
ApplicatorDescription | (300A,010A): Applicator Description
ApplicatorGeometrySequence | (300A,0431): Applicator Geometry Sequence
ApplicatorID | (300A,0108): Applicator ID
ApplicatorOpening | (300A,0433): Applicator Opening
ApplicatorOpeningX | (300A,0434): Applicator Opening X
ApplicatorOpeningY | (300A,0435): Applicator Opening Y
ApplicatorSequence | (300A,0107): Applicator Sequence
ApplicatorShapeReferencedROINumber | (300A,02A1): Applicator Shape Referenced ROI Number
ApplicatorType | (300A,0109): Applicator Type
AppliedMaskSubtractionFlag | (0018,11C0): Applied Mask Subtraction Flag
ApprovalSequence | (0044,0100): Approval Sequence
ApprovalStatus | (300E,0002): Approval Status
ApprovalStatusDateTime | (0044,0004): Approval Status DateTime
ApprovalStatusFurtherDescription | (0044,0003): Approval Status Further Description
ApprovalSubjectSequence | (0044,0109): Approval Subject Sequence
Arbitrary | (4000,0010): Arbitrary(Retired)
ArchiveRequested | (0040,A494): Archive Requested
ArterialSpinLabelingContrast | (0018,9250): Arterial Spin Labeling Contrast
AscanRate | (0022,1649): A-scan Rate
ASLBolusCutoffDelayTime | (0018,925F): ASL Bolus Cut-off Delay Time
ASLBolusCutoffFlag | (0018,925C): ASL Bolus Cut-off Flag
ASLBolusCutoffTechnique | (0018,925E): ASL Bolus Cut-off Technique
ASLBolusCutoffTimingSequence | (0018,925D): ASL Bolus Cut-off Timing Sequence
ASLContext | (0018,9257): ASL Context
ASLCrusherDescription | (0018,925B): ASL Crusher Description
ASLCrusherFlag | (0018,9259): ASL Crusher Flag
ASLCrusherFlowLimit | (0018,925A): ASL Crusher Flow Limit
ASLMidSlabPosition | (0018,9256): ASL Mid Slab Position
ASLPulseTrainDuration | (0018,9258): ASL Pulse Train Duration
ASLSlabNumber | (0018,9253): ASL Slab Number
ASLSlabOrientation | (0018,9255): ASL Slab Orientation
ASLSlabSequence | (0018,9260): ASL Slab Sequence
ASLSlabThickness | (0018,9254): ASL Slab Thickness
ASLTechniqueDescription | (0018,9252): ASL Technique Description
AsserterIdentificationSequence | (0044,0103): Asserter Identification Sequence
AssertionCodeSequence | (0044,0101): Assertion Code Sequence
AssertionComments | (0044,0106): Assertion Comments
AssertionDateTime | (0044,0104): Assertion DateTime
AssertionExpirationDateTime | (0044,0105): Assertion Expiration DateTime
AssertionUID | (0044,0102): Assertion UID
AssessedAttributeValueSequence | (0082,0010): Assessed Attribute Value Sequence
AssessedSOPInstanceSequence | (0082,0004): Assessed SOP Instance Sequence
AssessmentLabel | (0082,0023): Assessment Label
AssessmentObservationsSequence | (0082,0007): Assessment Observations Sequence
AssessmentRequesterSequence | (0082,0017): Assessment Requester Sequence
AssessmentSetID | (0082,0016): Assessment Set ID
AssessmentSummary | (0082,0001): Assessment Summary
AssessmentSummaryDescription | (0082,0003): Assessment Summary Description
AssessmentTypeCodeSequence | (0082,0021): Assessment Type Code Sequence
AssignedLocation | (4010,102A): Assigned Location
AssigningAgencyOrDepartmentCodeSequence | (0040,003A): Assigning Agency or Department Code Sequence
AssigningFacilitySequence | (0040,0036): Assigning Facility Sequence
AssigningJurisdictionCodeSequence | (0040,0039): Assigning Jurisdiction Code Sequence
ATDAbilityAssessment | (4010,1014): ATD Ability Assessment
ATDAssessmentFlag | (4010,1015): ATD Assessment Flag
ATDAssessmentProbability | (4010,1016): ATD Assessment Probability
ATDAssessmentSequence | (4010,1038): ATD Assessment Sequence
AttachedContours | (3006,0049): Attached Contours
AttenuationCorrected | (0018,9759): Attenuation Corrected
AttenuationCorrectionMethod | (0054,1101): Attenuation Correction Method
AttenuationCorrectionSource | (0018,9738): Attenuation Correction Source
AttenuationCorrectionTemporalRelationship | (0018,9770): Attenuation Correction Temporal Relationship
AttributeIdentifierList | (0000,1005): Attribute Identifier List
AttributeItemSelector | (0074,1054): Attribute Item Selector
AttributeModificationDateTime | (0400,0562): Attribute Modification DateTime
AttributeOccurrencePointer | (0074,1052): Attribute Occurrence Pointer
AttributeOccurrencePrivateCreator | (0074,1056): Attribute Occurrence Private Creator
AttributeOccurrenceSequence | (0074,1050): Attribute Occurrence Sequence
AttributeToleranceValuesSequence | (300A,062B): Attribute Tolerance Values Sequence
AudioComments | (50xx,200E): Audio Comments
AudioSampleData | (50xx,200C): Audio Sample Data
AudioSampleFormat | (50xx,2002): Audio Sample Format
AudioType | (50xx,2000): Audio Type
AuthorIdentificationSequence | (3010,0019): Author Identification Sequence
AuthorizationEquipmentCertificationNumber | (0100,0426): Authorization Equipment Certification Number
AuthorObserverSequence | (0040,A078): Author Observer Sequence
AutoKVPLowerBound | (0018,9946): Auto KVP Lower Bound
AutoKVPSelectionType | (0018,9944): Auto KVP Selection Type
AutoKVPUpperBound | (0018,9945): Auto KVP Upper Bound
AutorefractionLeftEyeSequence | (0046,0052): Autorefraction Left Eye Sequence
AutorefractionRightEyeSequence | (0046,0050): Autorefraction Right Eye Sequence
AutosequenceFlag | (0074,1025): Autosequence Flag
AvailableTransferSyntaxUID | (0008,3002): Available Transfer Syntax UID
AverageBeamDosePointDepth | (300A,008D): Average Beam Dose Point Depth
AverageBeamDosePointEquivalentDepth | (300A,008E): Average Beam Dose Point Equivalent Depth
AverageBeamDosePointSourceToExternalContourDistance | (300A,0131): Average Beam Dose Point Source to External Contour Distance
AverageBeamDosePointSSD | (300A,008F): Average Beam Dose Point SSD
AverageCornealPower | (0046,0220): Average Corneal Power
AveragePulseWidth | (0018,1154): Average Pulse Width
AxialAcceptance | (0054,1200): Axial Acceptance
AxialDetectorDimension | (0018,9727): Axial Detector Dimension
AxialLengthOfTheEye | (0022,0030): Axial Length of the Eye
AxialMash | (0054,1201): Axial Mash
AxialPower | (0046,0249): Axial Power
AxialResolution | (0052,0008): Axial Resolution
AxisLabels | (50xx,0040): Axis Labels
AxisOfRotation | (0066,001B): Axis of Rotation
AxisUnits | (50xx,0030): Axis Units
B1rms | (0018,1320): B1rms
BackgroundColor | (0046,0092): Background Color
BackgroundIlluminationColorCodeSequence | (0024,0024): Background Illumination Color Code Sequence
BackgroundLuminance | (0024,0020): Background Luminance
BadPixelImage | (0014,3080): Bad Pixel Image
BarcodeSymbology | (2200,0006): Barcode Symbology
BarcodeValue | (2200,0005): Barcode Value
BaselineCorrection | (0018,9067): Baseline Correction
BasicColorImageSequence | (2020,0111): Basic Color Image Sequence
BasicGrayscaleImageSequence | (2020,0110): Basic Grayscale Image Sequence
BasisMaterialsCodeSequence | (4010,1045): Basis Materials Code Sequence
BasisRTTreatmentPhaseIndex | (3010,003E): Basis RT Treatment Phase Index
BatteryLevel | (0016,0003): Battery Level
BeamAngle | (0018,9449): Beam Angle
BeamAreaLimitSequence | (300A,0689): Beam Area Limit Sequence
BeamCurrentModulationID | (300A,034C): Beam Current Modulation ID
BeamDeliveryDurationLimit | (300A,00C5): Beam Delivery Duration Limit
BeamDescription | (300A,00C3): Beam Description
BeamDose | (300A,0084): Beam Dose
BeamDoseMeaning | (300A,008B): Beam Dose Meaning
BeamDosePointDepth | (300A,0088): Beam Dose Point Depth
BeamDosePointEquivalentDepth | (300A,0089): Beam Dose Point Equivalent Depth
BeamDosePointSourceToExternalContourDistance | (300A,0094): Beam Dose Point Source to External Contour Distance
BeamDosePointSSD | (300A,008A): Beam Dose Point SSD
BeamDoseSpecificationPoint | (300A,0082): Beam Dose Specification Point
BeamDoseType | (300A,0090): Beam Dose Type
BeamDoseVerificationControlPointSequence | (300A,008C): Beam Dose Verification Control Point Sequence
BeamHardeningCorrectionTechnique | (0014,3101): Beam Hardening Correction Technique
BeamHoldOriginatingDeviceSequence | (300C,0128): Beam Hold Originating Device Sequence
BeamHoldTransition | (300C,0126): Beam Hold Transition
BeamHoldTransitionDateTime | (300C,0127): Beam Hold Transition DateTime
BeamLimitingDeviceAngle | (300A,0120): Beam Limiting Device Angle
BeamLimitingDeviceAngleTolerance | (300A,0046): Beam Limiting Device Angle Tolerance
BeamLimitingDeviceLeafPairsSequence | (3008,00A0): Beam Limiting Device Leaf Pairs Sequence
BeamLimitingDevicePositionSequence | (300A,011A): Beam Limiting Device Position Sequence
BeamLimitingDevicePositionTolerance | (300A,004A): Beam Limiting Device Position Tolerance
BeamLimitingDeviceRotationDirection | (300A,0121): Beam Limiting Device Rotation Direction
BeamLimitingDeviceSequence | (300A,00B6): Beam Limiting Device Sequence
BeamLimitingDeviceToleranceSequence | (300A,0048): Beam Limiting Device Tolerance Sequence
BeamMeterset | (300A,0086): Beam Meterset
BeamModifierOrientationAngle | (300A,0645): Beam Modifier Orientation Angle
BeamName | (300A,00C2): Beam Name
BeamNumber | (300A,00C0): Beam Number
BeamOrderIndex | (0074,1324): Beam Order Index
BeamOrderIndexTrial | (0074,1024): Beam Order Index (Trial)
BeamSequence | (300A,00B0): Beam Sequence
BeamSpotSize | (0052,0003): Beam Spot Size
BeamStopperPosition | (3008,0230): Beam Stopper Position
BeamTaskSequence | (0074,1020): Beam Task Sequence
BeamTaskType | (0074,1022): Beam Task Type
BeamType | (300A,00C4): Beam Type
BeatRejectionFlag | (0018,1080): Beat Rejection Flag
BeltHeight | (4010,1062): Belt Height
BibliographicCitationTrial | (0040,A16A): Bibliographic Citation (Trial)
BillingItemSequence | (0040,0296): Billing Item Sequence
BillingProcedureStepSequence | (0040,0320): Billing Procedure Step Sequence
BillingSuppliesAndDevicesSequence | (0040,0324): Billing Supplies and Devices Sequence
BiopsyTargetSequence | (0018,2041): Biopsy Target Sequence
BiPlaneAcquisitionSequence | (0028,5000): Bi-Plane Acquisition Sequence
BitsAllocated | (0028,0100): Bits Allocated
BitsForCodeWord | (0028,08x4): Bits For Code Word
BitsGrouped | (0028,0069): Bits Grouped
BitsMappedToColorLookupTable | (0028,1403): Bits Mapped to Color Lookup Table
BitsStored | (0028,0101): Bits Stored
BlendingDisplayInputSequence | (0070,1B03): Blending Display Input Sequence
BlendingDisplaySequence | (0070,1B04): Blending Display Sequence
BlendingInputNumber | (0070,1B02): Blending Input Number
BlendingLookupTableData | (0028,1408): Blending Lookup Table Data
BlendingLookupTableDescriptor | (0028,1407): Blending Lookup Table Descriptor
BlendingLUT1Sequence | (0028,1404): Blending LUT 1 Sequence
BlendingLUT1TransferFunction | (0028,1405): Blending LUT 1 Transfer Function
BlendingLUT2Sequence | (0028,140C): Blending LUT 2 Sequence
BlendingLUT2TransferFunction | (0028,140D): Blending LUT 2 Transfer Function
BlendingMode | (0070,1B06): Blending Mode
BlendingOperationType | (0072,0500): Blending Operation Type
BlendingPosition | (0070,0405): Blending Position
BlendingSequence | (0070,0402): Blending Sequence
BlendingWeightConstant | (0028,1406): Blending Weight Constant
BlindSpotLocalized | (0024,0106): Blind Spot Localized
BlindSpotXCoordinate | (0024,0107): Blind Spot X-Coordinate
BlindSpotYCoordinate | (0024,0108): Blind Spot Y-Coordinate
BlockColumns | (0028,0092): Block Columns
BlockData | (300A,0106): Block Data
BlockDefinitionSequence | (300A,066A): Block Definition Sequence
BlockDivergence | (300A,00FA): Block Divergence
BlockEdgeData | (300A,066B): Block Edge Data
BlockEdgeDataSequence | (300A,066F): Block Edge Data Sequence
BlockedPixels | (0028,0090): Blocked Pixels
BlockIdentifyingInformationStatus | (0008,0303): Block Identifying Information Status
BlockMountingPosition | (300A,00FB): Block Mounting Position
BlockName | (300A,00FE): Block Name
BlockNumber | (300A,00FC): Block Number
BlockNumberOfPoints | (300A,0104): Block Number of Points
BlockOrientation | (300A,066C): Block Orientation
BlockRows | (0028,0091): Block Rows
BlockSequence | (300A,00F4): Block Sequence
BlockSlabNumber | (300A,0443): Block Slab Number
BlockSlabSequence | (300A,0441): Block Slab Sequence
BlockSlabThickness | (300A,0442): Block Slab Thickness
BlockThickness | (300A,0100): Block Thickness
BlockTransmission | (300A,0102): Block Transmission
BlockTrayID | (300A,00F5): Block Tray ID
BlockType | (300A,00F8): Block Type
BloodSignalNulling | (0018,9022): Blood Signal Nulling
BluePaletteColorLookupTableData | (0028,1203): Blue Palette Color Lookup Table Data
BluePaletteColorLookupTableDescriptor | (0028,1103): Blue Palette Color Lookup Table Descriptor
BoardingPassID | (4010,101A): Boarding Pass ID
BodyPartExamined | (0018,0015): Body Part Examined
BodyPartThickness | (0018,11A0): Body Part Thickness
Bold | (0070,0249): Bold
BolusDefinitionSequence | (300A,0673): Bolus Definition Sequence
BolusDescription | (300A,00DD): Bolus Description
BolusID | (300A,00DC): Bolus ID
BoneThermalIndex | (0018,5024): Bone Thermal Index
BorderDensity | (2010,0100): Border Density
Borders | (0000,5160): Borders(Retired)
BottomRightHandCornerOfLocalizerArea | (0048,0202): Bottom Right Hand Corner of Localizer Area
BoundingBoxAnnotationUnits | (0070,0003): Bounding Box Annotation Units
BoundingBoxBottomRightHandCorner | (0070,0011): Bounding Box Bottom Right Hand Corner
BoundingBoxCrop | (0070,1303): Bounding Box Crop
BoundingBoxTextHorizontalJustification | (0070,0012): Bounding Box Text Horizontal Justification
BoundingBoxTopLeftHandCorner | (0070,0010): Bounding Box Top Left Hand Corner
BoundingPolygon | (4010,101D): Bounding Polygon
BoundingRectangle | (0068,6347): Bounding Rectangle
BrachyAccessoryDeviceID | (300A,0263): Brachy Accessory Device ID
BrachyAccessoryDeviceName | (300A,0266): Brachy Accessory Device Name
BrachyAccessoryDeviceNominalThickness | (300A,026A): Brachy Accessory Device Nominal Thickness
BrachyAccessoryDeviceNominalTransmission | (300A,026C): Brachy Accessory Device Nominal Transmission
BrachyAccessoryDeviceNumber | (300A,0262): Brachy Accessory Device Number
BrachyAccessoryDeviceSequence | (300A,0260): Brachy Accessory Device Sequence
BrachyAccessoryDeviceType | (300A,0264): Brachy Accessory Device Type
BrachyApplicationSetupDose | (300A,00A4): Brachy Application Setup Dose
BrachyApplicationSetupDoseSpecificationPoint | (300A,00A2): Brachy Application Setup Dose Specification Point
BrachyControlPointDeliveredSequence | (3008,0160): Brachy Control Point Delivered Sequence
BrachyControlPointSequence | (300A,02D0): Brachy Control Point Sequence
BrachyPulseControlPointDeliveredSequence | (3008,0173): Brachy Pulse Control Point Delivered Sequence
BrachyReferencedDoseReferenceSequence | (300C,0055): Brachy Referenced Dose Reference Sequence
BrachyTaskSequence | (0074,1401): Brachy Task Sequence
BrachytherapySourceType | (3010,0048): Brachytherapy Source Type
BrachyTreatmentTechnique | (300A,0200): Brachy Treatment Technique
BrachyTreatmentType | (300A,0202): Brachy Treatment Type
BranchOfService | (0010,1081): Branch of Service
BreastImplantPresent | (0028,1300): Breast Implant Present
BreastSupportIsocenterPrimaryAngle | (0018,9545): Breast Support Isocenter Primary Angle
BreastSupportIsocenterSecondaryAngle | (0018,9546): Breast Support Isocenter Secondary Angle
BreastSupportXPositionToIsocenter | (0018,9547): Breast Support X Position to Isocenter
BreastSupportYPositionToIsocenter | (0018,9548): Breast Support Y Position to Isocenter
BreastSupportZPositionToIsocenter | (0018,9549): Breast Support Z Position to Isocenter
BreedRegistrationNumber | (0010,2295): Breed Registration Number
BreedRegistrationSequence | (0010,2294): Breed Registration Sequence
BreedRegistryCodeSequence | (0010,2296): Breed Registry Code Sequence
BridgeResistors | (0014,4088): Bridge Resistors
BrightnessValue | (0016,0023): Brightness Value
BscanCycleTime | (0022,1645): B-scan Cycle Time
BscanCycleTimeVector | (0022,1646): B-scan Cycle Time Vector
BscanRate | (0022,1650): B-scan Rate
BscanSlabThickness | (0022,1643): B-scan Slab Thickness
BulkMotionCompensationTechnique | (0018,9172): Bulk Motion Compensation Technique
BulkMotionSignalSource | (0018,9173): Bulk Motion Signal Source
BulkMotionStatus | (0018,9166): Bulk Motion Status
BurnedInAnnotation | (0028,0301): Burned In Annotation
CADFileFormat | (0014,0023): CAD File Format
CalciumScoringMassFactorDevice | (0018,9352): Calcium Scoring Mass Factor Device
CalciumScoringMassFactorPatient | (0018,9351): Calcium Scoring Mass Factor Patient
CalculatedAnatomyThickness | (0018,9452): Calculated Anatomy Thickness
CalculatedDoseReferenceDescription | (3008,0074): Calculated Dose Reference Description
CalculatedDoseReferenceDoseValue | (3008,0076): Calculated Dose Reference Dose Value
CalculatedDoseReferenceNumber | (3008,0072): Calculated Dose Reference Number
CalculatedDoseReferenceSequence | (3008,0070): Calculated Dose Reference Sequence
CalculatedFrameList | (0008,1162): Calculated Frame List
CalculatedTargetPosition | (0018,2044): Calculated Target Position
CalculationComment | (0022,112C): Calculation Comment
CalculationCommentSequence | (0022,112A): Calculation Comment Sequence
CalculationCommentType | (0022,112B): Calculation Comment Type
CalibrationDataSequence | (0054,0306): Calibration Data Sequence
CalibrationDate | (0014,407E): Calibration Date
CalibrationDateTime | (0018,1203): Calibration DateTime
CalibrationImage | (0050,0004): Calibration Image
CalibrationNotes | (0014,3099): Calibration Notes
CalibrationProcedure | (0014,4072): Calibration Procedure
CalibrationReferencePointDepth | (300C,0124): Calibration Reference Point Depth
CalibrationSequence | (0018,9455): Calibration Sequence
CalibrationSettingsSequence | (0014,4070): Calibration Settings Sequence
CalibrationTime | (0014,407C): Calibration Time
CameraAngleOfView | (0022,001E): Camera Angle of View
CameraElevationAngle | (0016,0035): Camera Elevation Angle
CameraOwnerName | (0016,004D): Camera Owner Name
CameraPositionGroupSequence | (0034,000B): Camera Position Group Sequence
CardiacBeatRejectionTechnique | (0018,9169): Cardiac Beat Rejection Technique
CardiacCyclePosition | (0018,9236): Cardiac Cycle Position
CardiacFramingType | (0018,1064): Cardiac Framing Type
CardiacNumberOfImages | (0018,1090): Cardiac Number of Images
CardiacRRIntervalSpecified | (0018,9070): Cardiac R-R Interval Specified
CardiacSignalSource | (0018,9085): Cardiac Signal Source
CardiacSynchronizationSequence | (0018,9118): Cardiac Synchronization Sequence
CardiacSynchronizationTechnique | (0018,9037): Cardiac Synchronization Technique
CArmPhotonElectronControlPointSequence | (300A,062F): C-Arm Photon-Electron Control Point Sequence
CArmPositionerTabletopRelationship | (0018,9474): C-arm Positioner Tabletop Relationship
CarrierID | (4010,1058): Carrier ID
CarrierIDAssigningAuthority | (4010,1059): Carrier ID Assigning Authority
CassetteID | (0018,1007): Cassette ID
CassetteOrientation | (0018,1402): Cassette Orientation
CassetteSize | (0018,1403): Cassette Size
CatchTrialsDataFlag | (0024,0055): Catch Trials Data Flag
CatheterDirectionOfRotation | (0052,0031): Catheter Direction of Rotation
CatheterRotationalRate | (0052,0013): Catheter Rotational Rate
CellValuesSequence | (0040,A808): Cell Values Sequence
CenterOfCircularCollimator | (0018,1710): Center of Circular Collimator
CenterOfCircularExposureControlSensingRegion | (0018,9440): Center of Circular Exposure Control Sensing Region
CenterOfCircularOutline | (0018,1635): Center of Circular Outline
CenterOfCircularShutter | (0018,1610): Center of Circular Shutter
CenterOfMass | (4010,101B): Center of Mass
CenterOfPTO | (4010,101C): Center of PTO
CenterOfRotation | (0066,001C): Center of Rotation
CenterOfRotationOffset | (0018,1145): Center of Rotation Offset
CertificateOfSigner | (0400,0115): Certificate of Signer
CertificateType | (0400,0110): Certificate Type
CertifiedTimestamp | (0400,0310): Certified Timestamp
CertifiedTimestampType | (0400,0305): Certified Timestamp Type
ChairHeadFramePosition | (300A,0151): Chair Head Frame Position
ChairHeadFramePositionTolerance | (300A,0153): Chair Head Frame Position Tolerance
ChannelBaseline | (003A,0213): Channel Baseline
ChannelDefinitionSequence | (003A,0200): Channel Definition Sequence
ChannelDeliveryContinuationSequence | (0074,140D): Channel Delivery Continuation Sequence
ChannelDeliveryOrderIndex | (0074,140C): Channel Delivery Order Index
ChannelDeliveryOrderSequence | (0074,1405): Channel Delivery Order Sequence
ChannelDerivationDescription | (003A,020C): Channel Derivation Description
ChannelDescriptionCodeSequence | (0022,001A): Channel Description Code Sequence
ChannelDisplaySequence | (003A,0242): Channel Display Sequence
ChannelEffectiveLength | (300A,0271): Channel Effective Length
ChannelIdentificationCode | (003A,0301): Channel Identification Code
ChannelImpedanceSequence | (003A,0312): Channel Impedance Sequence
ChannelInnerLength | (300A,0272): Channel Inner Length
ChannelLabel | (003A,0203): Channel Label
ChannelLength | (300A,0284): Channel Length
ChannelMaximumValue | (5400,0112): Channel Maximum Value
ChannelMinimumValue | (5400,0110): Channel Minimum Value
ChannelMode | (003A,0302): Channel Mode
ChannelNumber | (300A,0282): Channel Number
ChannelOffset | (003A,0218): Channel Offset
ChannelOverlap | (0014,409F): Channel Overlap
ChannelPosition | (003A,0245): Channel Position
ChannelRecommendedDisplayCIELabValue | (003A,0244): Channel Recommended Display CIELab Value
ChannelSampleSkew | (003A,0215): Channel Sample Skew
ChannelSensitivity | (003A,0210): Channel Sensitivity
ChannelSensitivityCorrectionFactor | (003A,0212): Channel Sensitivity Correction Factor
ChannelSensitivityUnitsSequence | (003A,0211): Channel Sensitivity Units Sequence
ChannelSequence | (300A,0280): Channel Sequence
ChannelSettingsSequence | (0014,4091): Channel Settings Sequence
ChannelShieldID | (300A,02B3): Channel Shield ID
ChannelShieldName | (300A,02B4): Channel Shield Name
ChannelShieldNominalThickness | (300A,02B8): Channel Shield Nominal Thickness
ChannelShieldNominalTransmission | (300A,02BA): Channel Shield Nominal Transmission
ChannelShieldNumber | (300A,02B2): Channel Shield Number
ChannelShieldSequence | (300A,02B0): Channel Shield Sequence
ChannelSourceModifiersSequence | (003A,0209): Channel Source Modifiers Sequence
ChannelSourceSequence | (003A,0208): Channel Source Sequence
ChannelStatus | (003A,0205): Channel Status
ChannelThreshold | (0014,4092): Channel Threshold
ChannelTimeSkew | (003A,0214): Channel Time Skew
ChannelTotalTime | (300A,0286): Channel Total Time
ChannelWidth | (0046,0042): Channel Width
ChemicalShiftMaximumIntegrationLimitInHz | (0018,9196): Chemical Shift Maximum Integration Limit in Hz
ChemicalShiftMaximumIntegrationLimitInppm | (0018,9296): Chemical Shift Maximum Integration Limit in ppm
ChemicalShiftMinimumIntegrationLimitInHz | (0018,9195): Chemical Shift Minimum Integration Limit in Hz
ChemicalShiftMinimumIntegrationLimitInppm | (0018,9295): Chemical Shift Minimum Integration Limit in ppm
ChemicalShiftReference | (0018,9053): Chemical Shift Reference
ChemicalShiftSequence | (0018,9084): Chemical Shift Sequence
CIExyWhitePoint | (0028,7018): CIExy White Point
CineRate | (0018,0040): Cine Rate
CineRelativeToRealTime | (0072,0330): Cine Relative to Real-Time
ClinicalFractionNumber | (300A,0705): Clinical Fraction Number
ClinicalTrialCoordinatingCenterName | (0012,0060): Clinical Trial Coordinating Center Name
ClinicalTrialProtocolEthicsCommitteeApprovalNumber | (0012,0082): Clinical Trial Protocol Ethics Committee Approval Number
ClinicalTrialProtocolEthicsCommitteeName | (0012,0081): Clinical Trial Protocol Ethics Committee Name
ClinicalTrialProtocolID | (0012,0020): Clinical Trial Protocol ID
ClinicalTrialProtocolName | (0012,0021): Clinical Trial Protocol Name
ClinicalTrialSeriesDescription | (0012,0072): Clinical Trial Series Description
ClinicalTrialSeriesID | (0012,0071): Clinical Trial Series ID
ClinicalTrialSiteID | (0012,0030): Clinical Trial Site ID
ClinicalTrialSiteName | (0012,0031): Clinical Trial Site Name
ClinicalTrialSponsorName | (0012,0010): Clinical Trial Sponsor Name
ClinicalTrialSubjectID | (0012,0040): Clinical Trial Subject ID
ClinicalTrialSubjectReadingID | (0012,0042): Clinical Trial Subject Reading ID
ClinicalTrialTimePointDescription | (0012,0051): Clinical Trial Time Point Description
ClinicalTrialTimePointID | (0012,0050): Clinical Trial Time Point ID
CoatingMaterialsCodeSequence | (0068,63A4): Coating Materials Code Sequence
CodeLabel | (0028,08x0): Code Label
CodeMeaning | (0008,0104): Code Meaning
CodeNumberFormat | (0028,0740): Code Number Format
CodeTableLocation | (0028,08x3): Code Table Location
CodeValue | (0008,0100): Code Value
CodingSchemeDesignator | (0008,0102): Coding Scheme Designator
CodingSchemeExternalID | (0008,0114): Coding Scheme External ID
CodingSchemeIdentificationSequence | (0008,0110): Coding Scheme Identification Sequence
CodingSchemeName | (0008,0115): Coding Scheme Name
CodingSchemeRegistry | (0008,0112): Coding Scheme Registry
CodingSchemeResourcesSequence | (0008,0109): Coding Scheme Resources Sequence
CodingSchemeResponsibleOrganization | (0008,0116): Coding Scheme Responsible Organization
CodingSchemeUID | (0008,010C): Coding Scheme UID
CodingSchemeURL | (0008,010E): Coding Scheme URL
CodingSchemeURLType | (0008,010A): Coding Scheme URL Type
CodingSchemeVersion | (0008,0103): Coding Scheme Version
CoefficientsSDDN | (7FE0,0040): Coefficients SDDN
CoefficientsSDHN | (7FE0,0030): Coefficients SDHN
CoefficientsSDVN | (7FE0,0020): Coefficients SDVN
CoincidenceWindowWidth | (0054,1210): Coincidence Window Width
CollationFlag | (2000,0063): Collation Flag
CollimatorGridName | (0018,1180): Collimator/grid Name
CollimatorLeftVerticalEdge | (0018,1702): Collimator Left Vertical Edge
CollimatorLowerHorizontalEdge | (0018,1708): Collimator Lower Horizontal Edge
CollimatorRightVerticalEdge | (0018,1704): Collimator Right Vertical Edge
CollimatorShape | (0018,1700): Collimator Shape
CollimatorShapeSequence | (0018,9407): Collimator Shape Sequence
CollimatorType | (0018,1181): Collimator Type
CollimatorUpperHorizontalEdge | (0018,1706): Collimator Upper Horizontal Edge
ColorFilterArrayPatternColumns | (0016,000F): Color Filter Array Pattern Columns
ColorFilterArrayPatternRows | (0016,000E): Color Filter Array Pattern Rows
ColorFilterArrayPatternValues | (0016,0010): Color Filter Array Pattern Values
ColorImagePrintingFlag | (2000,0062): Color Image Printing Flag
ColorSpace | (0028,2002): Color Space
ColumnAngulation | (0018,1450): Column Angulation
ColumnAngulationPatient | (0018,9447): Column Angulation (Patient)
ColumnOverlap | (0028,0094): Column Overlap
ColumnPositionInTotalImagePixelMatrix | (0048,021E): Column Position In Total Image Pixel Matrix
Columns | (0028,0011): Columns
CombinationSegmentReferenceSequence | (3010,0024): Combination Segment Reference Sequence
CommandDataSetType | (0000,0800): Command Data Set Type
CommandField | (0000,0100): Command Field
CommandGroupLength | (0000,0000): Command Group Length
CommandLengthToEnd | (0000,0001): Command Length to End(Retired)
CommandMagnificationType | (0000,5180): Command Magnification Type(Retired)
CommandRecognitionCode | (0000,0010): Command Recognition Code(Retired)
CommentsOnPatientPerformanceOfVisualField | (0024,0044): Comments on Patient's Performance of Visual Field
CommentsOnRadiationDose | (0040,0310): Comments on Radiation Dose
CommentsOnThePerformedProcedureStep | (0040,0280): Comments on the Performed Procedure Step
CommentsOnTheScheduledProcedureStep | (0040,0400): Comments on the Scheduled Procedure Step
CommonZCoordinateValue | (006A,0010): Common Z Coordinate Value
CompensatorBasePlaneOffset | (300A,0666): Compensator Base Plane Offset
CompensatorColumnOffset | (300A,02E5): Compensator Column Offset
CompensatorColumns | (300A,00E8): Compensator Columns
CompensatorDefinitionSequence | (300A,0662): Compensator Definition Sequence
CompensatorDescription | (300A,02EB): Compensator Description
CompensatorDistalThicknessMap | (300A,0665): Compensator Distal Thickness Map
CompensatorDivergence | (300A,02E0): Compensator Divergence
CompensatorID | (300A,00E5): Compensator ID
CompensatorMapOrientation | (300A,0663): Compensator Map Orientation
CompensatorMillingToolDiameter | (300A,02E8): Compensator Milling Tool Diameter
CompensatorMountingPosition | (300A,02E1): Compensator Mounting Position
CompensatorNumber | (300A,00E4): Compensator Number
CompensatorPixelSpacing | (300A,00E9): Compensator Pixel Spacing
CompensatorPosition | (300A,00EA): Compensator Position
CompensatorProximalThicknessMap | (300A,0664): Compensator Proximal Thickness Map
CompensatorRelativeStoppingPowerRatio | (300A,02E7): Compensator Relative Stopping Power Ratio
CompensatorRows | (300A,00E7): Compensator Rows
CompensatorSequence | (300A,00E3): Compensator Sequence
CompensatorShapeFabricationCodeSequence | (300A,0667): Compensator Shape Fabrication Code Sequence
CompensatorShapeSequence | (300A,0668): Compensator Shape Sequence
CompensatorThicknessData | (300A,00EC): Compensator Thickness Data
CompensatorTransmissionData | (300A,00EB): Compensator Transmission Data
CompensatorTrayID | (300A,00EF): Compensator Tray ID
CompensatorType | (300A,00EE): Compensator Type
CompletionFlag | (0040,A491): Completion Flag
CompletionFlagDescription | (0040,A492): Completion Flag Description
ComplexImageComponent | (0008,9208): Complex Image Component
Component1ReferencedID | (0076,0070): Component 1 Referenced ID
Component1ReferencedMatingFeatureID | (0076,0090): Component 1 Referenced Mating Feature ID
Component1ReferencedMatingFeatureSetID | (0076,0080): Component 1 Referenced Mating Feature Set ID
Component2ReferencedID | (0076,00A0): Component 2 Referenced ID
Component2ReferencedMatingFeatureID | (0076,00C0): Component 2 Referenced Mating Feature ID
Component2ReferencedMatingFeatureSetID | (0076,00B0): Component 2 Referenced Mating Feature Set ID
ComponentAssemblySequence | (0076,0060): Component Assembly Sequence
ComponentID | (0076,0055): Component ID
ComponentInputSequence | (0070,1803): Component Input Sequence
ComponentManufacturer | (0014,0028): Component Manufacturer
ComponentManufacturingProcedure | (0014,0025): Component Manufacturing Procedure
ComponentReferenceSystem | (0014,0024): Component Reference System
ComponentSequence | (0076,0040): Component Sequence
ComponentShape | (0014,0050): Component Shape
ComponentType | (0070,1802): Component Type
ComponentTypeCodeSequence | (0076,0034): Component Type Code Sequence
ComponentTypesSequence | (0076,0032): Component Types Sequence
ComponentWelderIDs | (0014,0100): Component Welder IDs
CompositingMethod | (0070,1206): Compositing Method
CompoundGraphicInstanceID | (0070,0226): Compound Graphic Instance ID
CompoundGraphicSequence | (0070,0209): Compound Graphic Sequence
CompoundGraphicType | (0070,0294): Compound Graphic Type
CompoundGraphicUnits | (0070,0282): Compound Graphic Units
CompressionCode | (0028,0060): Compression Code(Retired)
CompressionContactArea | (0018,11A5): Compression Contact Area
CompressionDescription | (0028,0063): Compression Description
CompressionForce | (0018,11A2): Compression Force
CompressionLabel | (0028,0062): Compression Label
CompressionOriginator | (0028,0061): Compression Originator
CompressionPressure | (0018,11A3): Compression Pressure
CompressionRecognitionCode | (0028,005F): Compression Recognition Code
CompressionSequence | (0028,0065): Compression Sequence
CompressionStepPointers | (0028,0066): Compression Step Pointers
ConcatenationFrameOffsetNumber | (0020,9228): Concatenation Frame Offset Number
ConcatenationUID | (0020,9161): Concatenation UID
ConceptCodeSequence | (0040,A168): Concept Code Sequence
ConceptNameCodeSequence | (0040,A043): Concept Name Code Sequence
ConceptualVolumeBlockingConstraint | (3010,0068): Conceptual Volume Blocking Constraint
ConceptualVolumeCategoryCodeSequence | (3010,0067): Conceptual Volume Category Code Sequence
ConceptualVolumeCombinationDescription | (3010,000F): Conceptual Volume Combination Description
ConceptualVolumeCombinationExpression | (3010,000C): Conceptual Volume Combination Expression
ConceptualVolumeCombinationFlag | (3010,000E): Conceptual Volume Combination Flag
ConceptualVolumeConstituentIndex | (3010,000D): Conceptual Volume Constituent Index
ConceptualVolumeConstituentSegmentationReferenceSequence | (3010,0012): Conceptual Volume Constituent Segmentation Reference Sequence
ConceptualVolumeConstituentSequence | (3010,0008): Conceptual Volume Constituent Sequence
ConceptualVolumeDerivationAlgorithmSequence | (3010,0016): Conceptual Volume Derivation Algorithm Sequence
ConceptualVolumeDescription | (3010,0017): Conceptual Volume Description
ConceptualVolumeOptimizationPrecedence | (3010,0066): Conceptual Volume Optimization Precedence
ConceptualVolumeSegmentationDefinedFlag | (3010,0010): Conceptual Volume Segmentation Defined Flag
ConceptualVolumeSegmentationReferenceSequence | (3010,0011): Conceptual Volume Segmentation Reference Sequence
ConceptualVolumeSequence | (3010,0025): Conceptual Volume Sequence
ConceptualVolumeTypeCodeSequence | (3010,0069): Conceptual Volume Type Code Sequence
ConceptualVolumeTypeModifierCodeSequence | (3010,006A): Conceptual Volume Type Modifier Code Sequence
ConceptualVolumeUID | (3010,0006): Conceptual Volume UID
CondenserLensPower | (0048,0111): Condenser Lens Power
ConfidentialityCode | (0040,1008): Confidentiality Code
ConfidentialityConstraintOnPatientDataDescription | (0040,3001): Confidentiality Constraint on Patient Data Description
ConfigurationDescription | (0028,700D): Configuration Description
ConfigurationID | (0028,700B): Configuration ID
ConfigurationInformation | (2010,0150): Configuration Information
ConfigurationInformationDescription | (2010,0152): Configuration Information Description
ConfigurationName | (0028,700C): Configuration Name
ConfigurationQAResultsSequence | (0028,7011): Configuration QA Results Sequence
ConfirmationSequence | (300A,073F): Confirmation Sequence
ConnectorType | (0014,5105): Connector Type
ConsentForClinicalTrialUseSequence | (0012,0083): Consent for Clinical Trial Use Sequence
ConsentForDistributionFlag | (0012,0085): Consent for Distribution Flag
ConstantVolumeFlag | (0018,9333): Constant Volume Flag
ConstituentConceptualVolumeUID | (3010,0013): Constituent Conceptual Volume UID
ConstraintType | (0082,0032): Constraint Type
ConstraintValueSequence | (0082,0034): Constraint Value Sequence
ConstraintViolationCondition | (0082,0037): Constraint Violation Condition
ConstraintViolationSignificance | (0082,0036): Constraint Violation Significance
ConstraintWeight | (300A,0021): Constraint Weight
ConsultingPhysicianIdentificationSequence | (0008,009D): Consulting Physician Identification Sequence
ConsultingPhysicianName | (0008,009C): Consulting Physician's Name
ContactDisplayName | (0074,100C): Contact Display Name
ContactMethod | (0016,1003): Contact Method
ContactURI | (0074,100A): Contact URI
ContainerComponentDescription | (0050,001E): Container Component Description
ContainerComponentDiameter | (0050,001D): Container Component Diameter
ContainerComponentID | (0050,001B): Container Component ID
ContainerComponentLength | (0050,001C): Container Component Length
ContainerComponentMaterial | (0050,001A): Container Component Material
ContainerComponentSequence | (0040,0520): Container Component Sequence
ContainerComponentThickness | (0050,0013): Container Component Thickness
ContainerComponentTypeCodeSequence | (0050,0012): Container Component Type Code Sequence
ContainerComponentWidth | (0050,0015): Container Component Width
ContainerDescription | (0040,051A): Container Description
ContainerIdentifier | (0040,0512): Container Identifier
ContainerTypeCodeSequence | (0040,0518): Container Type Code Sequence
ContentCreatorIdentificationCodeSequence | (0070,0086): Content Creator's Identification Code Sequence
ContentCreatorName | (0070,0084): Content Creator's Name
ContentDate | (0008,0023): Content Date
ContentDescription | (0070,0081): Content Description
ContentItemModifierSequence | (0040,0441): Content Item Modifier Sequence
ContentLabel | (0070,0080): Content Label
ContentQualification | (0018,9004): Content Qualification
ContentSequence | (0040,A730): Content Sequence
ContentTemplateSequence | (0040,A504): Content Template Sequence
ContentTime | (0008,0033): Content Time
ContextGroupExtensionCreatorUID | (0008,010D): Context Group Extension Creator UID
ContextGroupExtensionFlag | (0008,010B): Context Group Extension Flag
ContextGroupIdentificationSequence | (0008,0123): Context Group Identification Sequence
ContextGroupLocalVersion | (0008,0107): Context Group Local Version
ContextGroupVersion | (0008,0106): Context Group Version
ContextIdentifier | (0008,010F): Context Identifier
ContextUID | (0008,0117): Context UID
ContinuationEndMeterset | (0074,0121): Continuation End Meterset
ContinuationEndTotalReferenceAirKerma | (0074,1403): Continuation End Total Reference Air Kerma
ContinuationPulseNumber | (0074,1404): Continuation Pulse Number
ContinuationStartMeterset | (0074,0120): Continuation Start Meterset
ContinuationStartTotalReferenceAirKerma | (0074,1402): Continuation Start Total Reference Air Kerma
ContinuityOfContent | (0040,A050): Continuity Of Content
ContourData | (3006,0050): Contour Data
ContourGeometricType | (3006,0042): Contour Geometric Type
ContourImageSequence | (3006,0016): Contour Image Sequence
ContourNumber | (3006,0048): Contour Number
ContourOffsetVector | (3006,0045): Contour Offset Vector
ContourSequence | (3006,0040): Contour Sequence
ContourSlabThickness | (3006,0044): Contour Slab Thickness
ContourUncertaintyRadius | (0070,0312): Contour Uncertainty Radius
ContraindicationsCodeSequence | (0018,990B): Contraindications Code Sequence
Contrast | (0016,0048): Contrast
ContrastAdministrationProfileSequence | (0018,9340): Contrast Administration Profile Sequence
ContrastBolusAdministrationRouteSequence | (0018,0014): Contrast/Bolus Administration Route Sequence
ContrastBolusAgent | (0018,0010): Contrast/Bolus Agent
ContrastBolusAgentAdministered | (0018,9342): Contrast/Bolus Agent Administered
ContrastBolusAgentDetected | (0018,9343): Contrast/Bolus Agent Detected
ContrastBolusAgentNumber | (0018,9337): Contrast/Bolus Agent Number
ContrastBolusAgentPhase | (0018,9344): Contrast/Bolus Agent Phase
ContrastBolusAgentSequence | (0018,0012): Contrast/Bolus Agent Sequence
ContrastBolusAutoInjectionTriggerFlag | (0018,11B6): Contrast/Bolus Auto Injection Trigger Flag
ContrastBolusIngredient | (0018,1048): Contrast/Bolus Ingredient
ContrastBolusIngredientCodeSequence | (0018,9338): Contrast/Bolus Ingredient Code Sequence
ContrastBolusIngredientConcentration | (0018,1049): Contrast/Bolus Ingredient Concentration
ContrastBolusIngredientOpaque | (0018,9425): Contrast/Bolus Ingredient Opaque
ContrastBolusIngredientPercentByVolume | (0052,0001): Contrast/Bolus Ingredient Percent by Volume
ContrastBolusInjectionDelay | (0018,11B7): Contrast/Bolus Injection Delay
ContrastBolusRoute | (0018,1040): Contrast/Bolus Route
ContrastBolusStartTime | (0018,1042): Contrast/Bolus Start Time
ContrastBolusStopTime | (0018,1043): Contrast/Bolus Stop Time
ContrastBolusT1Relaxivity | (0018,0013): Contrast/Bolus T1 Relaxivity
ContrastBolusTotalDose | (0018,1044): Contrast/Bolus Total Dose
ContrastBolusUsageSequence | (0018,9341): Contrast/Bolus Usage Sequence
ContrastBolusVolume | (0018,1041): Contrast/Bolus Volume
ContrastFlowDuration | (0018,1047): Contrast Flow Duration
ContrastFlowRate | (0018,1046): Contrast Flow Rate
ContrastFrameAveraging | (0028,6112): Contrast Frame Averaging
ContributingEquipmentSequence | (0018,A001): Contributing Equipment Sequence
ContributingSOPInstancesReferenceSequence | (0020,9529): Contributing SOP Instances Reference Sequence
ContributingSourcesSequence | (0018,9506): Contributing Sources Sequence
ContributionDateTime | (0018,A002): Contribution DateTime
ContributionDescription | (0018,A003): Contribution Description
ControlPoint3DPosition | (300A,02D4): Control Point 3D Position
ControlPointDeliverySequence | (3008,0040): Control Point Delivery Sequence
ControlPointIndex | (300A,0112): Control Point Index
ControlPointOrientation | (300A,0412): Control Point Orientation
ControlPointRelativePosition | (300A,02D2): Control Point Relative Position
ControlPointSequence | (300A,0111): Control Point Sequence
ConventionalControlPointVerificationSequence | (0074,104C): Conventional Control Point Verification Sequence
ConventionalMachineVerificationSequence | (0074,1044): Conventional Machine Verification Sequence
ConversionSourceAttributesSequence | (0020,9172): Conversion Source Attributes Sequence
ConversionType | (0008,0064): Conversion Type
ConvolutionKernel | (0018,1210): Convolution Kernel
ConvolutionKernelGroup | (0018,9316): Convolution Kernel Group
CoordinatesSetGeometricTypeTrial | (0040,A290): Coordinates Set Geometric Type (Trial)
CoordinateStartValue | (50xx,0112): Coordinate Start Value
CoordinateStepValue | (50xx,0114): Coordinate Step Value
CoordinateSystemAxesSequence | (0014,2204): Coordinate System Axes Sequence
CoordinateSystemAxisCodeSequence | (0040,08DA): Coordinate System Axis Code Sequence
CoordinateSystemAxisDescription | (0014,2206): Coordinate System Axis Description
CoordinateSystemAxisNumber | (0014,220A): Coordinate System Axis Number
CoordinateSystemAxisType | (0014,220C): Coordinate System Axis Type
CoordinateSystemAxisUnits | (0014,220E): Coordinate System Axis Units
CoordinateSystemAxisValues | (0014,2210): Coordinate System Axis Values
CoordinateSystemDataSetMapping | (0014,2208): Coordinate System Data Set Mapping
CoordinateSystemNumberOfAxes | (0014,2202): Coordinate System Number of Axes
CoordinateSystemTransformRotationAndScaleMatrix | (0014,222A): Coordinate System Transform Rotation and Scale Matrix
CoordinateSystemTransformSequence | (0014,2220): Coordinate System Transform Sequence
CoordinateSystemTransformTranslationMatrix | (0014,222C): Coordinate System Transform Translation Matrix
Copies | (0000,5170): Copies(Retired)
CornealAxis | (0046,0115): Corneal Axis
CornealEccentricityIndex | (0046,0234): Corneal Eccentricity Index
CornealISValue | (0046,0224): Corneal I-S Value
CornealPointEstimated | (0046,0248): Corneal Point Estimated
CornealPointLocation | (0046,0247): Corneal Point Location
CornealPower | (0046,0114): Corneal Power
CornealSize | (0046,0046): Corneal Size
CornealSizeSequence | (0046,0047): Corneal Size Sequence
CornealTopographyMappingNormalsSequence | (0046,0210): Corneal Topography Mapping Normals Sequence
CornealTopographyMapQualityEvaluation | (0046,0242): Corneal Topography Map Quality Evaluation
CornealTopographyMapTypeCodeSequence | (0046,0207): Corneal Topography Map Type Code Sequence
CornealTopographySurface | (0046,0201): Corneal Topography Surface
CornealVertexLocation | (0046,0202): Corneal Vertex Location
CornealWavefront | (0046,0253): Corneal Wavefront
CorneaMeasurementMethodCodeSequence | (0046,0116): Cornea Measurement Method Code Sequence
CorneaMeasurementsSequence | (0046,0110): Cornea Measurements Sequence
CorrectedImage | (0028,0051): Corrected Image
CorrectedLocalizedDeviationFromNormal | (0024,0079): Corrected Localized Deviation From Normal
CorrectedLocalizedDeviationFromNormalCalculated | (0024,0078): Corrected Localized Deviation From Normal Calculated
CorrectedLocalizedDeviationFromNormalProbability | (0024,0081): Corrected Localized Deviation From Normal Probability
CorrectedLocalizedDeviationFromNormalProbabilityCalculated | (0024,0080): Corrected Localized Deviation From Normal Probability Calculated
CorrectedParameterSequence | (3008,0068): Corrected Parameter Sequence
CorrectionValue | (3008,006A): Correction Value
CountLossNormalizationCorrected | (0018,9764): Count Loss Normalization Corrected
CountRate | (0018,1243): Count Rate
CountryOfResidence | (0010,2150): Country of Residence
CountsAccumulated | (0018,0070): Counts Accumulated
CountsIncluded | (0054,1400): Counts Included
CountsSource | (0054,1002): Counts Source
CouplingMedium | (0014,4056): Coupling Medium
CouplingTechnique | (0014,4054): Coupling Technique
CouplingVelocity | (0014,4057): Coupling Velocity
CoverageOfKSpace | (0018,9094): Coverage of k-Space
CranialThermalIndex | (0018,5026): Cranial Thermal Index
CreationDate | (2100,0040): Creation Date
CreationTime | (2100,0050): Creation Time
CreatorVersionUID | (0008,9123): Creator-Version UID
Crop | (0070,1204): Crop
CroppingSpecificationIndex | (0070,1205): Cropping Specification Index
CroppingSpecificationNumber | (0070,1309): Cropping Specification Number
CSSFontName | (0070,0229): CSS Font Name
CTAcquisitionDetailsSequence | (0018,9304): CT Acquisition Details Sequence
CTAcquisitionTypeSequence | (0018,9301): CT Acquisition Type Sequence
CTAdditionalXRaySourceSequence | (0018,9360): CT Additional X-Ray Source Sequence
CTDIPhantomTypeCodeSequence | (0018,9346): CTDI Phantom Type Code Sequence
CTDIvol | (0018,9345): CTDIvol
CTDIvolNotificationTrigger | (0018,9942): CTDIvol Notification Trigger
CTExposureSequence | (0018,9321): CT Exposure Sequence
CTGeometrySequence | (0018,9312): CT Geometry Sequence
CTImageFrameTypeSequence | (0018,9329): CT Image Frame Type Sequence
CTPositionSequence | (0018,9326): CT Position Sequence
CTReconstructionSequence | (0018,9314): CT Reconstruction Sequence
CTTableDynamicsSequence | (0018,9308): CT Table Dynamics Sequence
CTXRayDetailsSequence | (0018,9325): CT X-Ray Details Sequence
CumulativeDoseReferenceCoefficient | (300A,010C): Cumulative Dose Reference Coefficient
CumulativeDoseToDoseReference | (3008,0052): Cumulative Dose to Dose Reference
CumulativeMeterset | (300A,063C): Cumulative Meterset
CumulativeMetersetWeight | (300A,0134): Cumulative Meterset Weight
CumulativeTimeWeight | (300A,02D6): Cumulative Time Weight
CurrentConfigurationID | (0028,7002): Current Configuration ID
CurrentFractionNumber | (3008,0022): Current Fraction Number
CurrentObserverTrial | (0040,A307): Current Observer (Trial)
CurrentPatientLocation | (0038,0300): Current Patient Location
CurrentRequestedProcedureEvidenceSequence | (0040,A375): Current Requested Procedure Evidence Sequence
CurrentTreatmentStatus | (3008,0200): Current Treatment Status
CurvatureType | (0014,0052): Curvature Type
CurveActivationLayer | (50xx,1001): Curve Activation Layer
CurveData | (50xx,3000): Curve Data
CurveDataDescriptor | (50xx,0110): Curve Data Descriptor
CurveDate | (0008,0025): Curve Date
CurveDescription | (50xx,0022): Curve Description
CurveDimensions | (50xx,0005): Curve Dimensions
CurveLabel | (50xx,2500): Curve Label
CurveNumber | (0020,0024): Curve Number
CurveRange | (50xx,0106): Curve Range
CurveReferencedOverlayGroup | (50xx,2610): Curve Referenced Overlay Group
CurveReferencedOverlaySequence | (50xx,2600): Curve Referenced Overlay Sequence
CurveTime | (0008,0035): Curve Time(Retired)
CustodialOrganizationSequence | (0040,A07C): Custodial Organization Sequence
CustomRendered | (0016,0041): Custom Rendered
CylinderAxis | (0022,0009): Cylinder Axis
CylinderLensPower | (0022,0008): Cylinder Lens Power
CylinderPower | (0046,0147): Cylinder Power
CylinderSequence | (0046,0018): Cylinder Sequence
DACAmplitude | (0014,403C): DAC Amplitude
DACGainPoints | (0014,4038): DAC Gain Points
DACSequence | (0014,4035): DAC Sequence
DACTimePoints | (0014,403A): DAC Time Points
DACType | (0014,4036): DAC Type
Damping | (0014,4028): Damping
DarkCurrentCounts | (0014,3050): Dark Current Counts
DarkCurrentSequence | (0014,3040): Dark Current Sequence
DataBlock | (0028,0702): Data Block
DataBlockDescription | (0028,0701): Data Block Description
DataCollectionCenterPatient | (0018,9313): Data Collection Center (Patient)
DataCollectionDiameter | (0018,0090): Data Collection Diameter
DataElementsSigned | (0400,0020): Data Elements Signed
DataFrameAssignmentSequence | (0028,1401): Data Frame Assignment Sequence
DataInformationSequence | (0054,0063): Data Information Sequence
DataObservationSequence | (0024,0325): Data Observation Sequence
DataPathAssignment | (0028,1402): Data Path Assignment
DataPathID | (0028,140E): Data Path ID
DataPointColumns | (0028,9002): Data Point Columns
DataPointRows | (0028,9001): Data Point Rows
DataRepresentation | (0028,9108): Data Representation
DataSetDescription | (0024,0309): Data Set Description
DataSetName | (0024,0306): Data Set Name
DataSetSource | (0024,0308): Data Set Source
DataSetSubtype | (0008,0041): Data Set Subtype
DataSetTrailingPadding | (FFFC,FFFC): Data Set Trailing Padding
DataSetType | (0008,0040): Data Set Type
DataSetVersion | (0024,0307): Data Set Version
DataType | (0018,9808): Data Type
DataValueRepresentation | (50xx,0103): Data Value Representation
Date | (0040,A121): Date
DateOfDocumentOrVerbalTransactionTrial | (0040,A110): Date of Document or Verbal Transaction (Trial)
DateOfGainCalibration | (0014,3076): Date of Gain Calibration
DateOfLastCalibration | (0018,1200): Date of Last Calibration
DateOfLastDetectorCalibration | (0018,700C): Date of Last Detector Calibration
DateOfSecondaryCapture | (0018,1012): Date of Secondary Capture
DateTime | (0040,A120): DateTime
DateTimeOfLastCalibration | (0018,1202): DateTime of Last Calibration
dBdt | (0018,1318): dB/dt
DCTLabel | (0028,0700): DCT Label
DDLValue | (0028,7017): DDL Value
DeadTimeCorrected | (0018,9761): Dead Time Corrected
DeadTimeCorrectionFlag | (0054,1401): Dead Time Correction Flag
DeadTimeFactor | (0054,1324): Dead Time Factor
DecayCorrected | (0018,9758): Decay Corrected
DecayCorrection | (0054,1102): Decay Correction
DecayCorrectionDateTime | (0018,9701): Decay Correction DateTime
DecayFactor | (0054,1321): Decay Factor
DecimalPotentialVisualAcuity | (0046,0238): Decimal Potential Visual Acuity
DecimalVisualAcuity | (0046,0137): Decimal Visual Acuity
DecimateCropResult | (2020,00A2): Decimate/Crop Result
DecompositionAlgorithmIdentificationSequence | (0018,9380): Decomposition Algorithm Identification Sequence
DecompositionDescription | (0018,937F): Decomposition Description
DecompositionMaterialSequence | (0018,9381): Decomposition Material Sequence
DecompositionMethod | (0018,937E): Decomposition Method
DecoupledNucleus | (0018,9060): De-coupled Nucleus
Decoupling | (0018,9059): De-coupling
DecouplingChemicalShiftReference | (0018,9063): De-coupling Chemical Shift Reference
DecouplingFrequency | (0018,9061): De-coupling Frequency
DecouplingMethod | (0018,9062): De-coupling Method
DefaultMagnificationType | (2010,00A6): Default Magnification Type
DefaultPrinterResolutionID | (2010,0054): Default Printer Resolution ID
DefaultSmoothingType | (2010,00A8): Default Smoothing Type
DefinitionSourceSequence | (0008,1156): Definition Source Sequence
DeformableRegistrationGridSequence | (0064,0005): Deformable Registration Grid Sequence
DeformableRegistrationSequence | (0064,0002): Deformable Registration Sequence
DegreeOfDilation | (0022,000E): Degree of Dilation
DegreeOfFreedomID | (0068,6410): Degree of Freedom ID
DegreeOfFreedomType | (0068,6420): Degree of Freedom Type
DeidentificationAction | (0008,0307): Deidentification Action
DeidentificationActionSequence | (0008,0305): Deidentification Action Sequence
DeidentificationMethod | (0012,0063): De-identification Method
DeidentificationMethodCodeSequence | (0012,0064): De-identification Method Code Sequence
DelayLawIdentifier | (0014,405C): Delay Law Identifier
DeletionLock | (0074,1230): Deletion Lock
DelineatedRadiationFieldSize | (300C,0122): Delineated Radiation Field Size
DeliveredChannelTotalTime | (3008,0134): Delivered Channel Total Time
DeliveredDepthDoseParametersSequence | (300A,0506): Delivered Depth Dose Parameters Sequence
DeliveredDistalDepth | (300A,0508): Delivered Distal Depth
DeliveredDistalDepthFraction | (300A,0507): Delivered Distal Depth Fraction
DeliveredMeterset | (3008,0044): Delivered Meterset
DeliveredNominalRangeModulatedRegionDepths | (300A,0510): Delivered Nominal Range Modulated Region Depths
DeliveredNominalRangeModulationFractions | (300A,0509): Delivered Nominal Range Modulation Fractions
DeliveredNumberOfPulses | (3008,0138): Delivered Number of Pulses
DeliveredPrimaryMeterset | (3008,0036): Delivered Primary Meterset
DeliveredPulseRepetitionInterval | (3008,013C): Delivered Pulse Repetition Interval
DeliveredReferenceDoseDefinition | (300A,0511): Delivered Reference Dose Definition
DeliveredSecondaryMeterset | (3008,0037): Delivered Secondary Meterset
DeliveredTreatmentTime | (3008,003B): Delivered Treatment Time
DeliveryMaximumDose | (300A,0023): Delivery Maximum Dose
DeliveryRate | (300A,063D): Delivery Rate
DeliveryRateUnitSequence | (300A,063E): Delivery Rate Unit Sequence
DeliveryTimeStructureCodeSequence | (3010,0088): Delivery Time Structure Code Sequence
DeliveryVerificationImageSequence | (0074,1030): Delivery Verification Image Sequence
DeliveryWarningDose | (300A,0022): Delivery Warning Dose
Density | (4010,1018): Density
DepthDoseParametersSequence | (300A,0505): Depth Dose Parameters Sequence
DepthOfScanField | (0018,5050): Depth of Scan Field
DepthOfTransverseImage | (0022,0041): Depth of Transverse Image
DepthsOfFocus | (0018,9801): Depth(s) of Focus
DepthSpatialResolution | (0022,0035): Depth Spatial Resolution
DepthValueAveragingFlag | (300A,0093): Depth Value Averaging Flag
DerivationAlgorithmSequence | (0022,1612): Derivation Algorithm Sequence
DerivationCodeSequence | (0008,9215): Derivation Code Sequence
DerivationConceptualVolumeSequence | (3010,0014): Derivation Conceptual Volume Sequence
DerivationDescription | (0008,2111): Derivation Description
DerivationImageSequence | (0008,9124): Derivation Image Sequence
DerivationImplantAssemblyTemplateSequence | (0076,000E): Derivation Implant Assembly Template Sequence
DerivationImplantTemplateSequence | (0068,6224): Derivation Implant Template Sequence
DestinationAE | (2100,0140): Destination AE
DetailsOfCoefficients | (0028,0404): Details of Coefficients
DetectorActivationOffsetFromExposure | (0018,7016): Detector Activation Offset From Exposure
DetectorActiveAreaOrientation | (0018,9558): Detector Active Area Orientation
DetectorActiveAreaTLHCPosition | (0018,9557): Detector Active Area TLHC Position
DetectorActiveDimensions | (0018,7026): Detector Active Dimension(s)
DetectorActiveOrigin | (0018,7028): Detector Active Origin
DetectorActiveShape | (0018,7024): Detector Active Shape
DetectorActiveTime | (0018,7014): Detector Active Time
DetectorBinning | (0018,701A): Detector Binning
DetectorCalibrationData | (4010,106C): Detector Calibration Data
DetectorConditionsNominalFlag | (0018,7000): Detector Conditions Nominal Flag
DetectorConfiguration | (0018,7005): Detector Configuration
DetectorDescription | (0018,7006): Detector Description
DetectorElementPhysicalSize | (0018,7020): Detector Element Physical Size
DetectorElementSize | (0054,1203): Detector Element Size
DetectorElementSpacing | (0018,7022): Detector Element Spacing
DetectorGeometry | (0018,9725): Detector Geometry
DetectorGeometrySequence | (4010,0004): Detector Geometry Sequence
DetectorID | (0018,700A): Detector ID
DetectorInformationSequence | (0054,0022): Detector Information Sequence
DetectorIsocenterPrimaryAngle | (0018,9550): Detector Isocenter Primary Angle
DetectorIsocenterSecondaryAngle | (0018,9551): Detector Isocenter Secondary Angle
DetectorLinesOfResponseUsed | (0054,1104): Detector Lines of Response Used
DetectorManufacturerModelName | (0018,702B): Detector Manufacturer's Model Name
DetectorManufacturerName | (0018,702A): Detector Manufacturer Name
DetectorMode | (0018,7008): Detector Mode
DetectorNormalizationCorrection | (0018,9768): Detector Normalization Correction
DetectorPositionSequence | (0018,9541): Detector Position Sequence
DetectorPrimaryAngle | (0018,1530): Detector Primary Angle
DetectorSecondaryAngle | (0018,1531): Detector Secondary Angle
DetectorTemperature | (0018,7001): Detector Temperature
DetectorTemperatureSequence | (0014,3020): Detector Temperature Sequence
DetectorTimeSinceLastExposure | (0018,7012): Detector Time Since Last Exposure
DetectorType | (0018,7004): Detector Type
DetectorVector | (0054,0020): Detector Vector
DetectorXPositionToIsocenter | (0018,9552): Detector X Position to Isocenter
DetectorYPositionToIsocenter | (0018,9553): Detector Y Position to Isocenter
DetectorZPositionToIsocenter | (0018,9554): Detector Z Position to Isocenter
DeviationIndex | (0018,1413): Deviation Index
DeviceAlternateIdentifier | (3010,001B): Device Alternate Identifier
DeviceAlternateIdentifierFormat | (3010,001D): Device Alternate Identifier Format
DeviceAlternateIdentifierType | (3010,001C): Device Alternate Identifier Type
DeviceDescription | (0050,0020): Device Description
DeviceDiameter | (0050,0016): Device Diameter
DeviceDiameterUnits | (0050,0017): Device Diameter Units
DeviceID | (0018,1003): Device ID
DeviceIndex | (3010,0039): Device Index
DeviceLabel | (3010,002D): Device Label
DeviceLength | (0050,0014): Device Length
DeviceMotionControlSequence | (300A,0450): Device Motion Control Sequence
DeviceMotionExecutionMode | (300A,0451): Device Motion Execution Mode
DeviceMotionObservationMode | (300A,0452): Device Motion Observation Mode
DeviceMotionParameterCodeSequence | (300A,0453): Device Motion Parameter Code Sequence
DeviceOrderIndex | (300A,065E): Device Order Index
DeviceSequence | (0050,0010): Device Sequence
DeviceSerialNumber | (0018,1000): Device Serial Number
DeviceSettingDescription | (0016,004B): Device Setting Description
DeviceTypeCodeSequence | (3010,002E): Device Type Code Sequence
DeviceUID | (0018,1002): Device UID
DeviceVolume | (0050,0018): Device Volume
DialogReceiver | (0000,4000): Dialog Receiver(Retired)
DiameterOfCircularOutline | (0018,1636): Diameter of Circular Outline
DiameterOfVisibility | (0070,0262): Diameter of Visibility
DiaphragmPosition | (3002,0034): Diaphragm Position
DICOMMediaRetrievalSequence | (0040,E022): DICOM Media Retrieval Sequence
DICOMRetrievalSequence | (0040,E021): DICOM Retrieval Sequence
DICOMStorageSequence | (0040,4071): DICOM Storage Sequence
DICOSVersion | (4010,103A): DICOS Version
DiffuseReflectionIntensity | (0070,1704): Diffuse Reflection Intensity
DiffusionAcquisitionCodeSequence | (0066,0133): Diffusion Acquisition Code Sequence
DiffusionAnisotropyType | (0018,9147): Diffusion Anisotropy Type
DiffusionBMatrixSequence | (0018,9601): Diffusion b-matrix Sequence
DiffusionBValue | (0018,9087): Diffusion b-value
DiffusionBValueXX | (0018,9602): Diffusion b-value XX
DiffusionBValueXY | (0018,9603): Diffusion b-value XY
DiffusionBValueXZ | (0018,9604): Diffusion b-value XZ
DiffusionBValueYY | (0018,9605): Diffusion b-value YY
DiffusionBValueYZ | (0018,9606): Diffusion b-value YZ
DiffusionBValueZZ | (0018,9607): Diffusion b-value ZZ
DiffusionDirectionality | (0018,9075): Diffusion Directionality
DiffusionGradientDirectionSequence | (0018,9076): Diffusion Gradient Direction Sequence
DiffusionGradientOrientation | (0018,9089): Diffusion Gradient Orientation
DiffusionModelCodeSequence | (0066,0134): Diffusion Model Code Sequence
DigitalImageFormatAcquired | (0018,1023): Digital Image Format Acquired
DigitalSignatureDateTime | (0400,0105): Digital Signature DateTime
DigitalSignaturePurposeCodeSequence | (0400,0401): Digital Signature Purpose Code Sequence
DigitalSignaturesSequence | (FFFA,FFFA): Digital Signatures Sequence
DigitalSignatureUID | (0400,0100): Digital Signature UID
DigitalZoomRatio | (0016,0044): Digital Zoom Ratio
DigitizingDeviceTransportDirection | (0018,2020): Digitizing Device Transport Direction
DimensionDescriptionLabel | (0020,9421): Dimension Description Label
DimensionIndexPointer | (0020,9165): Dimension Index Pointer
DimensionIndexPrivateCreator | (0020,9213): Dimension Index Private Creator
DimensionIndexSequence | (0020,9222): Dimension Index Sequence
DimensionIndexValues | (0020,9157): Dimension Index Values
DimensionOrganizationSequence | (0020,9221): Dimension Organization Sequence
DimensionOrganizationType | (0020,9311): Dimension Organization Type
DimensionOrganizationUID | (0020,9164): Dimension Organization UID
DirectoryRecordSequence | (0004,1220): Directory Record Sequence
DirectoryRecordType | (0004,1430): Directory Record Type
DirectSegmentReferenceSequence | (3010,0023): Direct Segment Reference Sequence
DischargeDate | (0038,0030): Discharge Date
DischargeDiagnosisCodeSequence | (0038,0044): Discharge Diagnosis Code Sequence
DischargeDiagnosisDescription | (0038,0040): Discharge Diagnosis Description
DischargeTime | (0038,0032): Discharge Time
DisplacementMatrix | (300A,079B): Displacement Matrix
DisplacementReferenceLabel | (300A,079A): Displacement Reference Label
DisplacementReferenceLocationCodeSequence | (300A,079D): Displacement Reference Location Code Sequence
DisplayCalibrationResultSequence | (0028,7016): Display Calibration Result Sequence
DisplayDeviceTypeCodeSequence | (0028,7022): Display Device Type Code Sequence
DisplayedAreaBottomRightHandCorner | (0070,0053): Displayed Area Bottom Right Hand Corner
DisplayedAreaBottomRightHandCornerTrial | (0070,0051): Displayed Area Bottom Right Hand Corner (Trial)
DisplayedAreaSelectionSequence | (0070,005A): Displayed Area Selection Sequence
DisplayedAreaTopLeftHandCorner | (0070,0052): Displayed Area Top Left Hand Corner
DisplayedAreaTopLeftHandCornerTrial | (0070,0050): Displayed Area Top Left Hand Corner (Trial)
DisplayedZValue | (0018,2046): Displayed Z Value
DisplayEnvironmentSpatialPosition | (0072,0108): Display Environment Spatial Position
DisplayFilterPercentage | (0028,9411): Display Filter Percentage
DisplayFormat | (0000,5110): Display Format(Retired)
DisplayFunctionType | (0028,7019): Display Function Type
DisplaySetHorizontalJustification | (0072,0717): Display Set Horizontal Justification
DisplaySetLabel | (0072,0203): Display Set Label
DisplaySetNumber | (0072,0202): Display Set Number
DisplaySetPatientOrientation | (0072,0700): Display Set Patient Orientation
DisplaySetPresentationGroup | (0072,0204): Display Set Presentation Group
DisplaySetPresentationGroupDescription | (0072,0206): Display Set Presentation Group Description
DisplaySetScrollingGroup | (0072,0212): Display Set Scrolling Group
DisplaySetsSequence | (0072,0200): Display Sets Sequence
DisplaySetVerticalJustification | (0072,0718): Display Set Vertical Justification
DisplayShadingFlag | (003A,0246): Display Shading Flag
DisplaySubsystemConfigurationSequence | (0028,700A): Display Subsystem Configuration Sequence
DisplaySubsystemDescription | (0028,7005): Display Subsystem Description
DisplaySubsystemID | (0028,7003): Display Subsystem ID
DisplaySubsystemName | (0028,7004): Display Subsystem Name
DisplaySubsystemQAResultsSequence | (0028,7010): Display Subsystem QA Results Sequence
DisplaySubsystemSequence | (0028,7023): Display Subsystem Sequence
DisplayWindowLabelVector | (0018,2006): Display Window Label Vector
DistalDepth | (300A,0502): Distal Depth
DistalDepthFraction | (300A,0501): Distal Depth Fraction
DistanceBetweenBscanSlabs | (0022,1644): Distance Between B-scan Slabs
DistanceBetweenFocalPlanes | (0048,0014): Distance Between Focal Planes
DistanceObjectToTableTop | (0018,9403): Distance Object to Table Top
DistancePupillaryDistance | (0046,0060): Distance Pupillary Distance
DistanceReceptorPlaneToDetectorHousing | (0018,9426): Distance Receptor Plane to Detector Housing
DistanceSourceToDataCollectionCenter | (0018,9335): Distance Source to Data Collection Center
DistanceSourceToDetector | (0018,1110): Distance Source to Detector
DistanceSourceToEntrance | (0040,0306): Distance Source to Entrance
DistanceSourceToIsocenter | (0018,9402): Distance Source to Isocenter
DistanceSourceToPatient | (0018,1111): Distance Source to Patient
DistanceSourceToSupport | (0040,0307): Distance Source to Support
DistributionAddress | (4008,011A): Distribution Address
DistributionName | (4008,0119): Distribution Name
DistributionType | (0012,0084): Distribution Type
DLPNotificationTrigger | (0018,9943): DLP Notification Trigger
DocumentAuthorIdentifierCodeSequenceTrial | (0040,A068): Document Author Identifier Code Sequence (Trial)
DocumentAuthorTrial | (0040,A067): Document Author (Trial)
DocumentClassCodeSequence | (0040,E008): Document Class Code Sequence
DocumentIdentifierCodeSequenceTrial | (0040,A066): Document Identifier Code Sequence (Trial)
DocumentingObserverIdentifierCodeSequenceTrial | (0040,A076): Documenting Observer Identifier Code Sequence (Trial)
DocumentingOrganizationIdentifierCodeSequenceTrial | (0040,A028): Documenting Organization Identifier Code Sequence (Trial)
DocumentTitle | (0042,0010): Document Title
DopplerCorrectionAngle | (0018,6034): Doppler Correction Angle
DopplerSampleVolumeXPosition | (0018,6039): Doppler Sample Volume X Position
DopplerSampleVolumeXPositionRetired | (0018,6038): Doppler Sample Volume X Position (Retired)
DopplerSampleVolumeYPosition | (0018,603B): Doppler Sample Volume Y Position
DopplerSampleVolumeYPositionRetired | (0018,603A): Doppler Sample Volume Y Position (Retired)
DoseCalibrationConditionsSequence | (300C,0120): Dose Calibration Conditions Sequence
DoseCalibrationConditionsVerifiedFlag | (300C,0123): Dose Calibration Conditions Verified Flag
DoseCalibrationFactor | (0054,1322): Dose Calibration Factor
DoseComment | (3004,0006): Dose Comment
DoseGridScaling | (3004,000E): Dose Grid Scaling
DoseMeasurementDeviceCodeSequence | (300A,0774): Dose Measurement Device Code Sequence
DoseModeName | (0018,11B1): Dose Mode Name
DoseRateDelivered | (3008,0048): Dose Rate Delivered
DoseRateSet | (300A,0115): Dose Rate Set
DoseReferenceDescription | (300A,0016): Dose Reference Description
DoseReferenceNumber | (300A,0012): Dose Reference Number
DoseReferencePointCoordinates | (300A,0018): Dose Reference Point Coordinates
DoseReferenceSequence | (300A,0010): Dose Reference Sequence
DoseReferenceStructureType | (300A,0014): Dose Reference Structure Type
DoseReferenceType | (300A,0020): Dose Reference Type
DoseReferenceUID | (300A,0013): Dose Reference UID
DoseSummationType | (3004,000A): Dose Summation Type
DoseType | (3004,0004): Dose Type
DoseUnits | (3004,0002): Dose Units
DoseValue | (3004,0012): Dose Value
DoseValuePurpose | (300A,061D): Dose Value Purpose
DoseValuesSequence | (300A,061C): Dose Values Sequence
DosimetricObjectiveEvaluationScope | (3010,0063): Dosimetric Objective Evaluation Scope
DosimetricObjectiveParameterSequence | (3010,0070): Dosimetric Objective Parameter Sequence
DosimetricObjectivePurpose | (3010,0075): Dosimetric Objective Purpose
DosimetricObjectiveSequence | (3010,006C): Dosimetric Objective Sequence
DosimetricObjectiveTypeCodeSequence | (3010,006D): Dosimetric Objective Type Code Sequence
DosimetricObjectiveUID | (3010,006E): Dosimetric Objective UID
DosimetricObjectiveWeight | (3010,0074): Dosimetric Objective Weight
DoubleExposureFieldDelta | (0074,133A): Double Exposure Field Delta
DoubleExposureFieldDeltaTrial | (0074,103A): Double Exposure Field Delta (Trial)
DoubleExposureFlag | (0074,1034): Double Exposure Flag
DoubleExposureMeterset | (0074,1338): Double Exposure Meterset
DoubleExposureMetersetTrial | (0074,1038): Double Exposure Meterset (Trial)
DoubleExposureOrdering | (0074,1036): Double Exposure Ordering
DoubleFloatPixelData | (7FE0,0009): Double Float Pixel Data
DoubleFloatPixelPaddingRangeLimit | (0028,0125): Double Float Pixel Padding Range Limit
DoubleFloatPixelPaddingValue | (0028,0123): Double Float Pixel Padding Value
DoubleFloatRealWorldValueFirstValueMapped | (0040,9214): Double Float Real World Value First Value Mapped
DoubleFloatRealWorldValueLastValueMapped | (0040,9213): Double Float Real World Value Last Value Mapped
DoublePointCoordinatesData | (0066,0022): Double Point Coordinates Data
DriveProbeSequence | (0014,4083): Drive Probe Sequence
DriveType | (0014,4081): Drive Type
DVHData | (3004,0058): DVH Data
DVHDoseScaling | (3004,0052): DVH Dose Scaling
DVHMaximumDose | (3004,0072): DVH Maximum Dose
DVHMeanDose | (3004,0074): DVH Mean Dose
DVHMinimumDose | (3004,0070): DVH Minimum Dose
DVHNormalizationDoseValue | (3004,0042): DVH Normalization Dose Value
DVHNormalizationPoint | (3004,0040): DVH Normalization Point
DVHNumberOfBins | (3004,0056): DVH Number of Bins
DVHReferencedROISequence | (3004,0060): DVH Referenced ROI Sequence
DVHROIContributionType | (3004,0062): DVH ROI Contribution Type
DVHSequence | (3004,0050): DVH Sequence
DVHType | (3004,0001): DVH Type
DVHVolumeUnits | (3004,0054): DVH Volume Units
DynamicRange | (0018,5030): Dynamic Range(Retired)
EchoNumbers | (0018,0086): Echo Number(s)
EchoPeakPosition | (0018,9298): Echo Peak Position
EchoPlanarPulseSequence | (0018,9018): Echo Planar Pulse Sequence
EchoPulseSequence | (0018,9008): Echo Pulse Sequence
EchoTime | (0018,0081): Echo Time
EchoTrainLength | (0018,0091): Echo Train Length
EdgePointIndexList | (0066,0024): Edge Point Index List
EffectiveBinEnergy | (0018,936E): Effective Bin Energy
EffectiveDateTime | (0068,6226): Effective DateTime
EffectiveDoseCalculationMethodCategoryCodeSequence | (3010,0003): Effective Dose Calculation Method Category Code Sequence
EffectiveDoseCalculationMethodCodeSequence | (3010,0004): Effective Dose Calculation Method Code Sequence
EffectiveDoseCalculationMethodDescription | (3010,0005): Effective Dose Calculation Method Description
EffectiveDuration | (0018,0072): Effective Duration
EffectiveEchoTime | (0018,9082): Effective Echo Time
EffectiveRefractiveIndex | (0052,0004): Effective Refractive Index
EffectiveWedgeAngle | (300A,00DE): Effective Wedge Angle
ElementDimensionA | (0014,4014): Element Dimension A
ElementDimensionB | (0014,4015): Element Dimension B
ElementPitchA | (0014,4016): Element Pitch A
ElementPitchB | (0014,401D): Element Pitch B
ElementShape | (0014,4013): Element Shape
EmitterColorTemperature | (0016,1002): Emitter Color Temperature
EmmetropicMagnification | (0022,000A): Emmetropic Magnification
EmptyImageBoxCIELabValue | (0072,0421): Empty Image Box CIELab Value
EmptyImageDensity | (2010,0110): Empty Image Density
EncapsulatedDocument | (0042,0011): Encapsulated Document
EncapsulatedDocumentLength | (0042,0015): Encapsulated Document Length
EncryptedAttributesSequence | (0400,0500): Encrypted Attributes Sequence
EncryptedContent | (0400,0520): Encrypted Content
EncryptedContentTransferSyntaxUID | (0400,0510): Encrypted Content Transfer Syntax UID
EndAcquisitionDateTime | (0018,9517): End Acquisition DateTime
EndCumulativeMetersetWeight | (300C,0009): End Cumulative Meterset Weight
EndCumulativeTimeWeight | (0074,1408): End Cumulative Time Weight
EndingRespiratoryAmplitude | (0020,9248): Ending Respiratory Amplitude
EndingRespiratoryPhase | (0020,9249): Ending Respiratory Phase
EndMessageID | (0000,5020): End Message ID(Retired)
EndMeterset | (3008,007A): End Meterset
EnergyUnitCodeSequence | (300A,0684): Energy Unit Code Sequence
EnergyWeightingFactor | (0018,9353): Energy Weighting Factor
EnergyWindowCenterline | (0018,0032): Energy Window Centerline
EnergyWindowInformationSequence | (0054,0012): Energy Window Information Sequence
EnergyWindowLowerLimit | (0054,0014): Energy Window Lower Limit
EnergyWindowName | (0054,0018): Energy Window Name
EnergyWindowNumber | (0054,0308): Energy Window Number
EnergyWindowRangeSequence | (0054,0013): Energy Window Range Sequence
EnergyWindowTotalWidth | (0018,0033): Energy Window Total Width
EnergyWindowUpperLimit | (0054,0015): Energy Window Upper Limit
EnergyWindowVector | (0054,0010): Energy Window Vector
EnhancedPaletteColorLookupTableSequence | (0028,140B): Enhanced Palette Color Lookup Table Sequence
EntityDescription | (3010,0037): Entity Description
EntityLabel | (3010,0035): Entity Label
EntityLongLabel | (3010,0038): Entity Long Label
EntityName | (3010,0036): Entity Name
EntranceDose | (0040,0302): Entrance Dose
EntranceDoseDerivation | (0040,8303): Entrance Dose Derivation
EntranceDoseInmGy | (0040,8302): Entrance Dose in mGy
EnvironmentalConditions | (0014,1040): Environmental Conditions
EquipmentAdministratorSequence | (0028,7000): Equipment Administrator Sequence
EquipmentCoordinateSystemIdentification | (0028,9537): Equipment Coordinate System Identification
EquipmentFrameOfReferenceDescription | (300A,0676): Equipment Frame of Reference Description
EquipmentFrameOfReferenceUID | (300A,0675): Equipment Frame of Reference UID
EquipmentModality | (0008,0221): Equipment Modality
EquipmentReferencePointCodeSequence | (300A,0678): Equipment Reference Point Code Sequence
EquipmentReferencePointCoordinatesSequence | (300A,0677): Equipment Reference Point Coordinates Sequence
EquivalentCDADocumentSequence | (0040,A090): Equivalent CDA Document Sequence
EquivalentCodeSequence | (0008,0121): Equivalent Code Sequence
EquivalentConceptualVolumeInstanceReferenceSequence | (3010,0009): Equivalent Conceptual Volume Instance Reference Sequence
EquivalentConceptualVolumesSequence | (3010,000A): Equivalent Conceptual Volumes Sequence
EquivalentPupilRadius | (0046,0205): Equivalent Pupil Radius
Erase | (0000,5190): Erase(Retired)
ErrorComment | (0000,0902): Error Comment
ErrorID | (0000,0903): Error ID
EscapeTriplet | (1000,xxx0): Escape Triplet
EstimatedDoseSaving | (0018,9324): Estimated Dose Saving
EstimatedRadiographicMagnificationFactor | (0018,1114): Estimated Radiographic Magnification Factor
EthicsCommitteeApprovalEffectivenessEndDate | (0012,0087): Ethics Committee Approval Effectiveness End Date
EthicsCommitteeApprovalEffectivenessStartDate | (0012,0086): Ethics Committee Approval Effectiveness Start Date
EthnicGroup | (0010,2160): Ethnic Group
EvaluationAttempt | (0014,2008): Evaluation Attempt
EvaluatorName | (0014,2006): Evaluator Name
EvaluatorNumber | (0014,2004): Evaluator Number
EvaluatorSequence | (0014,2002): Evaluator Sequence
EventCodeSequence | (0008,2135): Event Code Sequence
EventElapsedTimes | (0008,2130): Event Elapsed Time(s)
EventTimeOffset | (0008,2134): Event Time Offset
EventTimerNames | (0008,2132): Event Timer Name(s)
EventTimerSequence | (0008,2133): Event Timer Sequence
EventTypeID | (0000,1002): Event Type ID
ExaminedBodyThickness | (0010,9431): Examined Body Thickness
ExcessiveFalseNegatives | (0024,0052): Excessive False Negatives
ExcessiveFalseNegativesDataFlag | (0024,0051): Excessive False Negatives Data Flag
ExcessiveFalsePositives | (0024,0062): Excessive False Positives
ExcessiveFalsePositivesDataFlag | (0024,0061): Excessive False Positives Data Flag
ExcessiveFixationLosses | (0024,0040): Excessive Fixation Losses
ExcessiveFixationLossesDataFlag | (0024,0039): Excessive Fixation Losses Data Flag
ExcitationFrequency | (0014,4024): Excitation Frequency
ExcludedIntervalsSequence | (0018,9803): Excluded Intervals Sequence
ExclusionDuration | (0018,9805): Exclusion Duration
ExclusionStartDateTime | (0018,9804): Exclusion Start DateTime
ExclusiveComponentType | (0076,0036): Exclusive Component Type
ExecutionStatus | (2100,0020): Execution Status
ExecutionStatusInfo | (2100,0030): Execution Status Info
EXIFVersion | (0016,0020): EXIF Version
ExpectedCompletionDateTime | (0040,4011): Expected Completion DateTime
ExpectedInVivoMeasurementValueIndex | (300A,0622): Expected In-Vivo Measurement Value Index
ExpectedInVivoMeasurementValuesSequence | (300A,0621): Expected In-Vivo Measurement Values Sequence
ExpiryDate | (0014,1020): Expiry Date
ExposedArea | (0040,0303): Exposed Area
Exposure | (0018,1152): Exposure
ExposureBiasValue | (0016,0024): Exposure Bias Value
ExposureControlMode | (0018,7060): Exposure Control Mode
ExposureControlModeDescription | (0018,7062): Exposure Control Mode Description
ExposureControlSensingRegionLeftVerticalEdge | (0018,9436): Exposure Control Sensing Region Left Vertical Edge
ExposureControlSensingRegionLowerHorizontalEdge | (0018,9439): Exposure Control Sensing Region Lower Horizontal Edge
ExposureControlSensingRegionRightVerticalEdge | (0018,9437): Exposure Control Sensing Region Right Vertical Edge
ExposureControlSensingRegionShape | (0018,9435): Exposure Control Sensing Region Shape
ExposureControlSensingRegionsSequence | (0018,9434): Exposure Control Sensing Regions Sequence
ExposureControlSensingRegionUpperHorizontalEdge | (0018,9438): Exposure Control Sensing Region Upper Horizontal Edge
ExposureDoseSequence | (0040,030E): Exposure Dose Sequence
ExposureIndex | (0018,1411): Exposure Index
ExposureInmAs | (0018,9332): Exposure in mAs
ExposureInuAs | (0018,1153): Exposure in µAs
ExposureMode | (0016,0042): Exposure Mode
ExposureModulationType | (0018,9323): Exposure Modulation Type
ExposureProgram | (0016,0016): Exposure Program
ExposureSequence | (3002,0030): Exposure Sequence
ExposuresOnDetectorSinceLastCalibration | (0018,7010): Exposures on Detector Since Last Calibration
ExposuresOnDetectorSinceManufactured | (0018,7011): Exposures on Detector Since Manufactured
ExposuresOnPlate | (0018,1404): Exposures on Plate
ExposureStatus | (0018,7064): Exposure Status
ExposureTime | (0018,1150): Exposure Time
ExposureTimeInms | (0018,9328): Exposure Time in ms
ExposureTimeInSeconds | (0016,0004): Exposure Time in Seconds
ExposureTimeInuS | (0018,8150): Exposure Time in µS
ExtendedCodeMeaning | (0008,0108): Extended Code Meaning
ExtendedCodeValue | (0008,0101): Extended Code Value
ExtendedDepthOfField | (0048,0012): Extended Depth of Field
ExtendedOffsetTable | (7FE0,0001): Extended Offset Table
ExtendedOffsetTableLengths | (7FE0,0002): Extended Offset Table Lengths
ExternalContourEntryPoint | (300A,0133): External Contour Entry Point
FacetSequence | (0066,0034): Facet Sequence
FailedAttributesSequence | (0074,1048): Failed Attributes Sequence
FailedSOPInstanceUIDList | (0008,0058): Failed SOP Instance UID List
FailedSOPSequence | (0008,1198): Failed SOP Sequence
FailureAttributes | (2200,000E): Failure Attributes
FailureReason | (0008,1197): Failure Reason
FalseNegativesEstimate | (0024,0046): False Negatives Estimate
FalseNegativesEstimateFlag | (0024,0045): False Negatives Estimate Flag
FalseNegativesQuantity | (0024,0050): False Negatives Quantity
FalsePositivesEstimate | (0024,0054): False Positives Estimate
FalsePositivesEstimateFlag | (0024,0053): False Positives Estimate Flag
FalsePositivesQuantity | (0024,0060): False Positives Quantity
FiducialDescription | (0070,030F): Fiducial Description
FiducialIdentifier | (0070,0310): Fiducial Identifier
FiducialIdentifierCodeSequence | (0070,0311): Fiducial Identifier Code Sequence
FiducialSequence | (0070,031E): Fiducial Sequence
FiducialSetSequence | (0070,031C): Fiducial Set Sequence
FiducialsPropertyCategoryCodeSequence | (0070,031F): Fiducials Property Category Code Sequence
FiducialUID | (0070,031A): Fiducial UID
FieldOfViewDescription | (0018,9433): Field of View Description
FieldOfViewDimensions | (0018,1149): Field of View Dimension(s)
FieldOfViewDimensionsInFloat | (0018,9461): Field of View Dimension(s) in Float
FieldOfViewHorizontalFlip | (0018,7034): Field of View Horizontal Flip
FieldOfViewOrigin | (0018,7030): Field of View Origin
FieldOfViewRotation | (0018,7032): Field of View Rotation
FieldOfViewSequence | (0018,9432): Field of View Sequence
FieldOfViewShape | (0018,1147): Field of View Shape
FileMetaInformationGroupLength | (0002,0000): File Meta Information Group Length
FileMetaInformationVersion | (0002,0001): File Meta Information Version
FileSetConsistencyFlag | (0004,1212): File-set Consistency Flag
FileSetDescriptorFileID | (0004,1141): File-set Descriptor File ID
FileSetID | (0004,1130): File-set ID
FileSource | (0016,003A): File Source
FillerOrderNumberImagingServiceRequest | (0040,2017): Filler Order Number / Imaging Service Request
FillerOrderNumberImagingServiceRequestRetired | (0040,2007): Filler Order Number / Imaging Service Request (Retired)
FillerOrderNumberProcedure | (0040,1007): Filler Order Number / Procedure
FillMode | (0070,0257): Fill Mode
FillPattern | (0070,0256): Fill Pattern
FillStyleSequence | (0070,0233): Fill Style Sequence
FilmBoxContentSequence | (2130,0030): Film Box Content Sequence
FilmConsumptionSequence | (0040,0321): Film Consumption Sequence
FilmDestination | (2000,0040): Film Destination
FilmOrientation | (2010,0040): Film Orientation
FilmSessionLabel | (2000,0050): Film Session Label
FilmSizeID | (2010,0050): Film Size ID
FilterBeamPathLengthMaximum | (0018,7058): Filter Beam Path Length Maximum
FilterBeamPathLengthMinimum | (0018,7056): Filter Beam Path Length Minimum
FilterByAttributePresence | (0072,0404): Filter-by Attribute Presence
FilterByCategory | (0072,0402): Filter-by Category
FilterByOperator | (0072,0406): Filter-by Operator
FilterHighFrequency | (003A,0221): Filter High Frequency
FilterLowFrequency | (003A,0220): Filter Low Frequency
FilterMaterial | (0018,7050): Filter Material
FilterMaterialUsedInGainCalibration | (0014,3074): Filter Material Used in Gain Calibration
FilterOperationsSequence | (0072,0400): Filter Operations Sequence
FilterThicknessMaximum | (0018,7054): Filter Thickness Maximum
FilterThicknessMinimum | (0018,7052): Filter Thickness Minimum
FilterThicknessUsedInGainCalibration | (0014,3075): Filter Thickness Used in Gain Calibration
FilterType | (0018,1160): Filter Type
FinalCumulativeMetersetWeight | (300A,010E): Final Cumulative Meterset Weight
FinalCumulativeTimeWeight | (300A,02C8): Final Cumulative Time Weight
FindingsFlagTrial | (0040,A007): Findings Flag (Trial)
FindingsGroupRecordingDateTrial | (0040,A023): Findings Group Recording Date (Trial)
FindingsGroupRecordingTimeTrial | (0040,A024): Findings Group Recording Time (Trial)
FindingsGroupUIDTrial | (0040,A021): Findings Group UID (Trial)
FindingsSequenceTrial | (0040,A020): Findings Sequence (Trial)
FindingsSourceCategoryCodeSequenceTrial | (0040,A026): Findings Source Category Code Sequence (Trial)
FindLocation | (0000,0400): Find Location(Retired)
FiniteVolume | (0066,000E): Finite Volume
FirstALineLocation | (0052,0034): First A-line Location
FirstOrderPhaseCorrection | (0018,9198): First Order Phase Correction
FirstOrderPhaseCorrectionAngle | (5600,0010): First Order Phase Correction Angle
FirstTreatmentDate | (3008,0054): First Treatment Date
FixationCheckedQuantity | (0024,0035): Fixation Checked Quantity
FixationDeviceDescription | (300A,0196): Fixation Device Description
FixationDeviceLabel | (300A,0194): Fixation Device Label
FixationDevicePitchAngle | (300A,0199): Fixation Device Pitch Angle
FixationDevicePosition | (300A,0198): Fixation Device Position
FixationDeviceRollAngle | (300A,019A): Fixation Device Roll Angle
FixationDeviceSequence | (300A,0190): Fixation Device Sequence
FixationDeviceType | (300A,0192): Fixation Device Type
FixationEye | (300A,0150): Fixation Eye
FixationLightAzimuthalAngle | (300A,0356): Fixation Light Azimuthal Angle
FixationLightAzimuthalAngleTolerance | (300A,0154): Fixation Light Azimuthal Angle Tolerance
FixationLightPolarAngle | (300A,0358): Fixation Light Polar Angle
FixationLightPolarAngleTolerance | (300A,0155): Fixation Light Polar Angle Tolerance
FixationMethodCodeSequence | (0068,63AC): Fixation Method Code Sequence
FixationMonitoringCodeSequence | (0024,0033): Fixation Monitoring Code Sequence
FixationSequence | (0024,0032): Fixation Sequence
FixedRTBeamDelimiterDeviceSequence | (300A,0646): Fixed RT Beam Delimiter Device Sequence
FlashEnergy | (0016,0036): Flash Energy
FlashFiringStatus | (0016,0011): Flash Firing Status
FlashFunctionPresent | (0016,0014): Flash Function Present
FlashMode | (0016,0013): Flash Mode
FlashRedEyeMode | (0016,0015): Flash Red Eye Mode
FlashReturnStatus | (0016,0012): Flash Return Status
FlatCornealAxisSequence | (0046,0113): Flat Corneal Axis Sequence
FlatKeratometricAxisSequence | (0046,0080): Flat Keratometric Axis Sequence
FlipAngle | (0018,1314): Flip Angle
FloatingPointValue | (0040,A161): Floating Point Value
FloatingPointValues | (0066,0125): Floating Point Values
FloatPixelData | (7FE0,0008): Float Pixel Data
FloatPixelPaddingRangeLimit | (0028,0124): Float Pixel Padding Range Limit
FloatPixelPaddingValue | (0028,0122): Float Pixel Padding Value
FlowCompensation | (0018,9010): Flow Compensation
FlowCompensationDirection | (0018,9183): Flow Compensation Direction
FlowIdentifier | (0034,0002): Flow Identifier
FlowIdentifierSequence | (0034,0001): Flow Identifier Sequence
FlowRTPSamplingRate | (0034,0004): Flow RTP Sampling Rate
FlowTransferSyntaxUID | (0034,0003): Flow Transfer Syntax UID
FluenceDataScale | (3002,0042): Fluence Data Scale
FluenceDataSource | (3002,0041): Fluence Data Source
FluenceMapSequence | (3002,0040): Fluence Map Sequence
FluenceMode | (3002,0051): Fluence Mode
FluenceModeID | (3002,0052): Fluence Mode ID
FluoroscopyFlag | (0018,9334): Fluoroscopy Flag
FluoroscopyLastImageHoldPersistenceFlag | (0018,11B4): Fluoroscopy Last Image Hold Persistence Flag
FluoroscopyPersistenceFlag | (0018,11B3): Fluoroscopy Persistence Flag
FNumber | (0016,0005): F-Number
FocalDistance | (0018,1182): Focal Distance
FocalLength | (0016,0029): Focal Length
FocalLengthIn35mmFilm | (0016,0045): Focal Length In 35mm Film
FocalSpots | (0018,1190): Focal Spot(s)
FocusDepth | (0018,5012): Focus Depth
FocusMethod | (0048,0011): Focus Method
FontName | (0070,0227): Font Name
FontNameType | (0070,0228): Font Name Type
FovealPointNormativeDataFlag | (0024,0117): Foveal Point Normative Data Flag
FovealPointProbabilityValue | (0024,0118): Foveal Point Probability Value
FovealSensitivity | (0024,0087): Foveal Sensitivity
FovealSensitivityMeasured | (0024,0086): Foveal Sensitivity Measured
FractionalChannelDisplayScale | (003A,0247): Fractional Channel Display Scale
FractionationNotes | (3010,007F): Fractionation Notes
FractionBasedRelationshipIntervalAnchor | (3010,0083): Fraction-Based Relationship Interval Anchor
FractionBasedRelationshipSequence | (3010,0082): Fraction-Based Relationship Sequence
FractionGroupDescription | (300A,0072): Fraction Group Description
FractionGroupNumber | (300A,0071): Fraction Group Number
FractionGroupSequence | (300A,0070): Fraction Group Sequence
FractionGroupSummarySequence | (3008,0220): Fraction Group Summary Sequence
FractionGroupType | (3008,0224): Fraction Group Type
FractionNumber | (3002,0029): Fraction Number
FractionPattern | (300A,007B): Fraction Pattern
FractionPatternSequence | (3010,0079): Fraction Pattern Sequence
FractionStatusSummarySequence | (3008,0240): Fraction Status Summary Sequence
FrameAcquisitionDateTime | (0018,9074): Frame Acquisition DateTime
FrameAcquisitionDuration | (0018,9220): Frame Acquisition Duration
FrameAcquisitionNumber | (0020,9156): Frame Acquisition Number
FrameAcquisitionSequence | (0018,9417): Frame Acquisition Sequence
FrameAnatomySequence | (0020,9071): Frame Anatomy Sequence
FrameComments | (0020,9158): Frame Comments
FrameContentSequence | (0020,9111): Frame Content Sequence
FrameDelay | (0018,1066): Frame Delay
FrameDetectorParametersSequence | (0018,9451): Frame Detector Parameters Sequence
FrameDimensionPointer | (0028,000A): Frame Dimension Pointer
FrameDisplaySequence | (0008,9458): Frame Display Sequence
FrameDisplayShutterSequence | (0018,9472): Frame Display Shutter Sequence
FrameExtractionSequence | (0008,1164): Frame Extraction Sequence
FrameIncrementPointer | (0028,0009): Frame Increment Pointer
FrameLabel | (0020,9453): Frame Label
FrameLabelVector | (0018,2002): Frame Label Vector
FrameLaterality | (0020,9072): Frame Laterality
FrameNumbersOfInterest | (0028,6020): Frame Numbers of Interest (FOI)
FrameOfInterestDescription | (0028,6022): Frame of Interest Description
FrameOfInterestType | (0028,6023): Frame of Interest Type
FrameOfReferenceRelationshipSequence | (3006,00C0): Frame of Reference Relationship Sequence
FrameOfReferenceToDisplayedCoordinateSystemTransformationMatrix | (0070,030B): Frame of Reference to Displayed Coordinate System Transformation Matrix
FrameOfReferenceTransformationComment | (3006,00C8): Frame of Reference Transformation Comment
FrameOfReferenceTransformationMatrix | (3006,00C6): Frame of Reference Transformation Matrix
FrameOfReferenceTransformationMatrixType | (0070,030C): Frame of Reference Transformation Matrix Type
FrameOfReferenceTransformationType | (3006,00C4): Frame of Reference Transformation Type
FrameOfReferenceUID | (0020,0052): Frame of Reference UID
FrameOriginTimestamp | (0034,0007): Frame Origin Timestamp
FramePixelDataPropertiesSequence | (0028,9443): Frame Pixel Data Properties Sequence
FramePixelShiftSequence | (0028,9415): Frame Pixel Shift Sequence
FramePrimaryAngleVector | (0018,2003): Frame Primary Angle Vector
FrameReferenceDateTime | (0018,9151): Frame Reference DateTime
FrameReferenceTime | (0054,1300): Frame Reference Time
FrameSecondaryAngleVector | (0018,2004): Frame Secondary Angle Vector
FrameTime | (0018,1063): Frame Time
FrameTimeVector | (0018,1065): Frame Time Vector
FrameType | (0008,9007): Frame Type
FrameUsefulnessGroupSequence | (0034,0009): Frame Usefulness Group Sequence
FrameVOILUTSequence | (0028,9132): Frame VOI LUT Sequence
FrequencyCorrection | (0018,9101): Frequency Correction
FunctionalGroupPointer | (0020,9167): Functional Group Pointer
FunctionalGroupPrivateCreator | (0020,9238): Functional Group Private Creator
FunctionalMRSequence | (0018,9621): Functional MR Sequence
FunctionalSettlingPhaseFramesPresent | (0018,9622): Functional Settling Phase Frames Present
FunctionalSyncPulse | (0018,9623): Functional Sync Pulse
GainControl | (0016,0047): Gain Control
GainCorrectionReferenceSequence | (0014,3060): Gain Correction Reference Sequence
GammaValue | (0028,701A): Gamma Value
GantryAngle | (300A,011E): Gantry Angle
GantryAngleTolerance | (300A,0044): Gantry Angle Tolerance
GantryDetectorSlew | (0018,1121): Gantry/Detector Slew
GantryDetectorTilt | (0018,1120): Gantry/Detector Tilt
GantryID | (0018,1008): Gantry ID
GantryMotionCorrected | (0018,9762): Gantry Motion Corrected
GantryPitchAngle | (300A,014A): Gantry Pitch Angle
GantryPitchAngleTolerance | (300A,014E): Gantry Pitch Angle Tolerance
GantryPitchRotationDirection | (300A,014C): Gantry Pitch Rotation Direction
GantryRotationDirection | (300A,011F): Gantry Rotation Direction
GantryType | (4010,1008): Gantry Type
GapLength | (0070,0261): Gap Length
GatedInformationSequence | (0054,0062): Gated Information Sequence
GateSettingsSequence | (0014,4060): Gate Settings Sequence
GateThreshold | (0014,4062): Gate Threshold
GatingBeamHoldTransitionSequence | (300C,0125): Gating Beam Hold Transition Sequence
GeneralAccessoryDefinitionSequence | (300A,0671): General Accessory Definition Sequence
GeneralAccessoryDescription | (300A,0422): General Accessory Description
GeneralAccessoryID | (300A,0421): General Accessory ID
GeneralAccessoryNumber | (300A,0424): General Accessory Number
GeneralAccessorySequence | (300A,0420): General Accessory Sequence
GeneralAccessoryType | (300A,0423): General Accessory Type
GeneralizedDefectCorrectedSensitivityDeviationFlag | (0024,0102): Generalized Defect Corrected Sensitivity Deviation Flag
GeneralizedDefectCorrectedSensitivityDeviationProbabilityValue | (0024,0104): Generalized Defect Corrected Sensitivity Deviation Probability Value
GeneralizedDefectCorrectedSensitivityDeviationValue | (0024,0103): Generalized Defect Corrected Sensitivity Deviation Value
GeneralizedDefectSensitivityDeviationAlgorithmSequence | (0024,0067): Generalized Defect Sensitivity Deviation Algorithm Sequence
GeneralMachineVerificationSequence | (0074,1042): General Machine Verification Sequence
GeneralPurposePerformedProcedureStepStatus | (0040,4002): General Purpose Performed Procedure Step Status
GeneralPurposeScheduledProcedureStepPriority | (0040,4003): General Purpose Scheduled Procedure Step Priority
GeneralPurposeScheduledProcedureStepStatus | (0040,4001): General Purpose Scheduled Procedure Step Status
GeneratorID | (0018,1005): Generator ID
GeneratorPower | (0018,1170): Generator Power
GeneticModificationsCodeSequence | (0010,0229): Genetic Modifications Code Sequence
GeneticModificationsDescription | (0010,0222): Genetic Modifications Description
GeneticModificationsNomenclature | (0010,0223): Genetic Modifications Nomenclature
GeneticModificationsSequence | (0010,0221): Genetic Modifications Sequence
GeometricalProperties | (0028,9444): Geometrical Properties
GeometricMaximumDistortion | (0028,9445): Geometric Maximum Distortion
GeometryForDisplay | (0070,1B08): Geometry for Display
GeometryOfKSpaceTraversal | (0018,9032): Geometry of k-Space Traversal
GlobalCrop | (0070,120B): Global Crop
GlobalCroppingSpecificationIndex | (0070,120C): Global Cropping Specification Index
GlobalDeviationFromNormal | (0024,0066): Global Deviation From Normal
GlobalDeviationProbability | (0024,0071): Global Deviation Probability
GlobalDeviationProbabilityNormalsFlag | (0024,0059): Global Deviation Probability Normals Flag
GlobalDeviationProbabilitySequence | (0024,0083): Global Deviation Probability Sequence
GPSAltitude | (0016,0076): GPS Altitude
GPSAltitudeRef | (0016,0075): GPS Altitude Ref
GPSAreaInformation | (0016,008C): GPS Area Information
GPSDateStamp | (0016,008D): GPS Date Stamp
GPSDestBearing | (0016,0088): GPS Dest Bearing
GPSDestBearingRef | (0016,0087): GPS Dest Bearing Ref
GPSDestDistance | (0016,008A): GPS Dest Distance
GPSDestDistanceRef | (0016,0089): GPS Dest Distance Ref
GPSDestLatitude | (0016,0084): GPS Dest Latitude
GPSDestLatitudeRef | (0016,0083): GPS Dest Latitude Ref
GPSDestLongitude | (0016,0086): GPS Dest Longitude
GPSDestLongitudeRef | (0016,0085): GPS Dest Longitude Ref
GPSDifferential | (0016,008E): GPS Differential
GPSDOP | (0016,007B): GPS DOP
GPSImgDirection | (0016,0081): GPS Img Direction
GPSImgDirectionRef | (0016,0080): GPS Img Direction Ref
GPSLatitude | (0016,0072): GPS Latitude
GPSLatitudeRef | (0016,0071): GPS Latitude Ref
GPSLongitude | (0016,0074): GPS Longitude
GPSLongitudeRef | (0016,0073): GPS Longitude Ref
GPSMapDatum | (0016,0082): GPS Map Datum
GPSMeasureMode | (0016,007A): GPS Measure Mode
GPSProcessingMethod | (0016,008B): GPS Processing Method
GPSSatellites | (0016,0078): GPS Satellites
GPSSpeed | (0016,007D): GPS Speed
GPSSpeedRef | (0016,007C): GPS Speed Ref
GPSStatus | (0016,0079): GPS Status
GPSTimeStamp | (0016,0077): GPS Time Stamp
GPSTrack | (0016,007F): GPS Track
GPSTrackRef | (0016,007E): GPS Track Ref
GPSVersionID | (0016,0070): GPS Version ID
GradientEchoTrainLength | (0018,9241): Gradient Echo Train Length
GradientOutput | (0018,9182): Gradient Output
GradientOutputType | (0018,9180): Gradient Output Type
GraphicAnnotationSequence | (0070,0001): Graphic Annotation Sequence
GraphicAnnotationUnits | (0070,0005): Graphic Annotation Units
GraphicCoordinatesDataSequence | (0070,0318): Graphic Coordinates Data Sequence
GraphicData | (0070,0022): Graphic Data
GraphicDimensions | (0070,0020): Graphic Dimensions
GraphicFilled | (0070,0024): Graphic Filled
GraphicGroupDescription | (0070,0208): Graphic Group Description
GraphicGroupID | (0070,0295): Graphic Group ID
GraphicGroupLabel | (0070,0207): Graphic Group Label
GraphicGroupSequence | (0070,0234): Graphic Group Sequence
GraphicLayer | (0070,0002): Graphic Layer
GraphicLayerDescription | (0070,0068): Graphic Layer Description
GraphicLayerOrder | (0070,0062): Graphic Layer Order
GraphicLayerRecommendedDisplayCIELabValue | (0070,0401): Graphic Layer Recommended Display CIELab Value
GraphicLayerRecommendedDisplayGrayscaleValue | (0070,0066): Graphic Layer Recommended Display Grayscale Value
GraphicLayerRecommendedDisplayRGBValue | (0070,0067): Graphic Layer Recommended Display RGB Value
GraphicLayerSequence | (0070,0060): Graphic Layer Sequence
GraphicObjectSequence | (0070,0009): Graphic Object Sequence
GraphicType | (0070,0023): Graphic Type
GrayLookupTableData | (0028,1200): Gray Lookup Table Data(Retired)
GrayLookupTableDescriptor | (0028,1100): Gray Lookup Table Descriptor(Retired)
GrayScale | (0028,1080): Gray Scale(Retired)
GreenPaletteColorLookupTableData | (0028,1202): Green Palette Color Lookup Table Data
GreenPaletteColorLookupTableDescriptor | (0028,1102): Green Palette Color Lookup Table Descriptor
Grid | (0018,1166): Grid
GridAbsorbingMaterial | (0018,7040): Grid Absorbing Material
GridAspectRatio | (0018,7046): Grid Aspect Ratio
GridDimensions | (0064,0007): Grid Dimensions
GridFocalDistance | (0018,704C): Grid Focal Distance
GridFrameOffsetVector | (3004,000C): Grid Frame Offset Vector
GridID | (0018,1006): Grid ID
GridPeriod | (0018,7048): Grid Period
GridPitch | (0018,7044): Grid Pitch
GridResolution | (0064,0008): Grid Resolution
GridSpacingMaterial | (0018,7041): Grid Spacing Material
GridThickness | (0018,7042): Grid Thickness
GroupOfPatientsIdentificationSequence | (0010,0027): Group of Patients Identification Sequence
HalfValueLayer | (0040,0314): Half Value Layer
HangingProtocolCreationDateTime | (0072,000A): Hanging Protocol Creation DateTime
HangingProtocolCreator | (0072,0008): Hanging Protocol Creator
HangingProtocolDefinitionSequence | (0072,000C): Hanging Protocol Definition Sequence
HangingProtocolDescription | (0072,0004): Hanging Protocol Description
HangingProtocolLevel | (0072,0006): Hanging Protocol Level
HangingProtocolName | (0072,0002): Hanging Protocol Name
HangingProtocolUserGroupName | (0072,0010): Hanging Protocol User Group Name
HangingProtocolUserIdentificationCodeSequence | (0072,000E): Hanging Protocol User Identification Code Sequence
HardcopyCreationDeviceID | (0018,1011): Hardcopy Creation Device ID
HardcopyDeviceManufacturer | (0018,1017): Hardcopy Device Manufacturer
HardcopyDeviceManufacturerModelName | (0018,101B): Hardcopy Device Manufacturer's Model Name
HardcopyDeviceSoftwareVersion | (0018,101A): Hardcopy Device Software Version
HeadFixationAngle | (300A,0148): Head Fixation Angle
HeadFixationAngleTolerance | (300A,0152): Head Fixation Angle Tolerance
HeartRate | (0018,1088): Heart Rate
HighBit | (0028,0102): High Bit
HighDoseTechniqueType | (300A,00C7): High-Dose Technique Type
HighEnergyDetectors | (4010,0002): High Energy Detectors
HighRRValue | (0018,1082): High R-R Value
HistogramBinWidth | (0060,3008): Histogram Bin Width
HistogramData | (0060,3020): Histogram Data
HistogramExplanation | (0060,3010): Histogram Explanation
HistogramFirstBinValue | (0060,3004): Histogram First Bin Value
HistogramLastBinValue | (0060,3006): Histogram Last Bin Value
HistogramNumberOfBins | (0060,3002): Histogram Number of Bins
HistogramSequence | (0060,3000): Histogram Sequence
HL7DocumentEffectiveTime | (0040,E004): HL7 Document Effective Time
HL7DocumentTypeCodeSequence | (0040,E006): HL7 Document Type Code Sequence
HL7InstanceIdentifier | (0040,E001): HL7 Instance Identifier
HL7StructuredDocumentReferenceSequence | (0040,A390): HL7 Structured Document Reference Sequence
HomeCommunityID | (0040,E031): Home Community ID
HorizontalAlignment | (0070,0242): Horizontal Alignment
HorizontalFieldOfView | (0022,000C): Horizontal Field of View
HorizontalOffsetOfSensor | (0014,3024): Horizontal Offset of Sensor
HorizontalPrismBase | (0046,0032): Horizontal Prism Base
HorizontalPrismPower | (0046,0030): Horizontal Prism Power
HPGLContourPenNumber | (0068,6310): HPGL Contour Pen Number
HPGLDocument | (0068,6300): HPGL Document
HPGLDocumentID | (0068,62D0): HPGL Document ID
HPGLDocumentLabel | (0068,62D5): HPGL Document Label
HPGLDocumentScaling | (0068,62F2): HPGL Document Scaling
HPGLDocumentSequence | (0068,62C0): HPGL Document Sequence
HPGLPenDescription | (0068,6345): HPGL Pen Description
HPGLPenLabel | (0068,6340): HPGL Pen Label
HPGLPenNumber | (0068,6330): HPGL Pen Number
HPGLPenSequence | (0068,6320): HPGL Pen Sequence
HuffmanTableSize | (1000,xxx2): Huffman Table Size
HuffmanTableTriplet | (1000,xxx3): Huffman Table Triplet
HumanPerformerCodeSequence | (0040,4009): Human Performer Code Sequence
HumanPerformerName | (0040,4037): Human Performer's Name
HumanPerformerOrganization | (0040,4036): Human Performer's Organization
Humidity | (0016,0031): Humidity
ICCProfile | (0028,2000): ICC Profile
IconImageSequence | (0088,0200): Icon Image Sequence
IdenticalDocumentsSequence | (0040,A525): Identical Documents Sequence
IdentificationDescriptionTrial | (0040,A224): Identification Description (Trial)
IdentifierCodeSequenceTrial | (0040,A070): Identifier Code Sequence (Trial)
IdentifierTypeCode | (0040,0035): Identifier Type Code
IdentifyingComments | (0008,4000): Identifying Comments(Retired)
IdentifyingPrivateElements | (0008,0306): Identifying Private Elements
Illumination | (2010,015E): Illumination
IlluminationBandwidth | (0022,0057): Illumination Bandwidth
IlluminationColorCodeSequence | (0048,0108): Illumination Color Code Sequence
IlluminationPower | (0022,0056): Illumination Power
IlluminationTypeCodeSequence | (0022,0016): Illumination Type Code Sequence
IlluminationWaveLength | (0022,0055): Illumination Wave Length
IlluminatorTypeCodeSequence | (0048,0100): Illuminator Type Code Sequence
ImageAndFluoroscopyAreaDoseProduct | (0018,115E): Image and Fluoroscopy Area Dose Product
ImageBoxContentSequence | (2130,0040): Image Box Content Sequence
ImageBoxesSequence | (0072,0300): Image Boxes Sequence
ImageBoxLargeScrollAmount | (0072,0318): Image Box Large Scroll Amount
ImageBoxLargeScrollType | (0072,0316): Image Box Large Scroll Type
ImageBoxLayoutType | (0072,0304): Image Box Layout Type
ImageBoxNumber | (0072,0302): Image Box Number
ImageBoxOverlapPriority | (0072,0320): Image Box Overlap Priority
ImageBoxPosition | (2020,0010): Image Box Position
ImageBoxPresentationLUTFlag | (2000,006A): Image Box Presentation LUT Flag
ImageBoxScrollDirection | (0072,0310): Image Box Scroll Direction
ImageBoxSmallScrollAmount | (0072,0314): Image Box Small Scroll Amount
ImageBoxSmallScrollType | (0072,0312): Image Box Small Scroll Type
ImageBoxSynchronizationSequence | (0072,0430): Image Box Synchronization Sequence
ImageBoxTileHorizontalDimension | (0072,0306): Image Box Tile Horizontal Dimension
ImageBoxTileVerticalDimension | (0072,0308): Image Box Tile Vertical Dimension
ImageCenterPointCoordinatesSequence | (0040,071A): Image Center Point Coordinates Sequence
ImageComments | (0020,4000): Image Comments
ImageDataLocation | (0028,08x8): Image Data Location
ImageDataTypeSequence | (0018,9807): Image Data Type Sequence
ImageDimensions | (0028,0005): Image Dimensions(Retired)
ImageDisplayFormat | (2010,0010): Image Display Format
ImagedNucleus | (0018,0085): Imaged Nucleus
ImagedVolumeDepth | (0048,0003): Imaged Volume Depth
ImagedVolumeHeight | (0048,0002): Imaged Volume Height
ImagedVolumeWidth | (0048,0001): Imaged Volume Width
ImageFilter | (0018,9320): Image Filter
ImageFilterDescription | (0018,9941): Image Filter Description
ImageFilterDetailsSequence | (0018,11BF): Image Filter Details Sequence
ImageFormat | (0028,0040): Image Format(Retired)
ImageFrameOrigin | (60xx,0051): Image Frame Origin
ImageGeometryType | (0020,0070): Image Geometry Type(Retired)
ImageHorizontalFlip | (0070,0041): Image Horizontal Flip
ImageID | (0054,0400): Image ID
ImageIndex | (0054,1330): Image Index
ImageLaterality | (0020,0062): Image Laterality
ImageLocation | (0028,0200): Image Location(Retired)
ImageOrientation | (0020,0035): Image Orientation(Retired)
ImageOrientationPatient | (0020,0037): Image Orientation (Patient)
ImageOrientationSlide | (0048,0102): Image Orientation (Slide)
ImageOrientationVolume | (0020,9302): Image Orientation (Volume)
ImageOverlayBoxContentSequence | (2130,0060): Image Overlay Box Content Sequence
ImageOverlayFlag | (2000,0067): Image Overlay Flag
ImagePathFilterPassBand | (0022,0004): Image Path Filter Pass Band
ImagePathFilterPassThroughWavelength | (0022,0003): Image Path Filter Pass-Through Wavelength
ImagePathFilterTypeStackCodeSequence | (0022,0018): Image Path Filter Type Stack Code Sequence
ImagePlanePixelSpacing | (3002,0011): Image Plane Pixel Spacing
ImagePosition | (0020,0030): Image Position(Retired)
ImagePositionPatient | (0020,0032): Image Position (Patient)
ImagePositionVolume | (0020,9301): Image Position (Volume)
ImagePresentationComments | (0028,4000): Image Presentation Comments(Retired)
ImageProcessingApplied | (0028,9446): Image Processing Applied
ImageQualityIndicatorMaterial | (0014,40A1): Image Quality Indicator Material
ImageQualityIndicatorSize | (0014,40A2): Image Quality Indicator Size
ImageQualityIndicatorType | (0014,40A0): Image Quality Indicator Type
ImageRotation | (0070,0042): Image Rotation
ImageRotationRetired | (0070,0040): Image Rotation (Retired)
ImagerPixelSpacing | (0018,1164): Imager Pixel Spacing
ImageScaleRepresentation | (4010,1075): Image Scale Representation
ImageSetLabel | (0072,0040): Image Set Label
ImageSetNumber | (0072,0032): Image Set Number
ImageSetSelectorCategory | (0072,0034): Image Set Selector Category
ImageSetSelectorSequence | (0072,0022): Image Set Selector Sequence
ImageSetSelectorUsageFlag | (0072,0024): Image Set Selector Usage Flag
ImageSetsSequence | (0072,0020): Image Sets Sequence
ImagesInAcquisition | (0020,1002): Images in Acquisition
ImagesInSeries | (0020,1003): Images in Series
ImagesInStudy | (0020,1005): Images in Study
ImageToEquipmentMappingMatrix | (0028,9520): Image to Equipment Mapping Matrix
ImageTransformationMatrix | (0018,5210): Image Transformation Matrix
ImageTranslationVector | (0018,5212): Image Translation Vector
ImageTriggerDelay | (0018,1067): Image Trigger Delay
ImageType | (0008,0008): Image Type
ImageVolumeGeometry | (0070,1208): Image Volume Geometry
ImagingDeviceSpecificAcquisitionParameters | (300A,00CC): Imaging Device-Specific Acquisition Parameters
ImagingFrequency | (0018,0084): Imaging Frequency
ImagingServiceRequestComments | (0040,2400): Imaging Service Request Comments
ImmersionMedia | (0016,1004): Immersion Media
ImpedanceMeasurementCurrentType | (003A,0316): Impedance Measurement Current Type
ImpedanceMeasurementDateTime | (003A,0314): Impedance Measurement DateTime
ImpedanceMeasurementFrequency | (003A,0315): Impedance Measurement Frequency
ImpedanceValue | (003A,0313): Impedance Value
ImplantAssemblyTemplateIssuer | (0076,0003): Implant Assembly Template Issuer
ImplantAssemblyTemplateName | (0076,0001): Implant Assembly Template Name
ImplantAssemblyTemplateTargetAnatomySequence | (0076,0010): Implant Assembly Template Target Anatomy Sequence
ImplantAssemblyTemplateType | (0076,000A): Implant Assembly Template Type
ImplantAssemblyTemplateVersion | (0076,0006): Implant Assembly Template Version
ImplantName | (0022,1095): Implant Name
ImplantPartNumber | (0022,1097): Implant Part Number
ImplantRegulatoryDisapprovalCodeSequence | (0068,62A0): Implant Regulatory Disapproval Code Sequence
ImplantSize | (0068,6210): Implant Size
ImplantTargetAnatomySequence | (0068,6230): Implant Target Anatomy Sequence
ImplantTemplate3DModelSurfaceNumber | (0068,6350): Implant Template 3D Model Surface Number
ImplantTemplateGroupDescription | (0078,0010): Implant Template Group Description
ImplantTemplateGroupIssuer | (0078,0020): Implant Template Group Issuer
ImplantTemplateGroupMemberID | (0078,002E): Implant Template Group Member ID
ImplantTemplateGroupMemberMatching2DCoordinatesSequence | (0078,0070): Implant Template Group Member Matching 2D Coordinates Sequence
ImplantTemplateGroupMembersSequence | (0078,002A): Implant Template Group Members Sequence
ImplantTemplateGroupName | (0078,0001): Implant Template Group Name
ImplantTemplateGroupTargetAnatomySequence | (0078,0028): Implant Template Group Target Anatomy Sequence
ImplantTemplateGroupVariationDimensionName | (0078,00B2): Implant Template Group Variation Dimension Name
ImplantTemplateGroupVariationDimensionRank | (0078,00B8): Implant Template Group Variation Dimension Rank
ImplantTemplateGroupVariationDimensionRankSequence | (0078,00B4): Implant Template Group Variation Dimension Rank Sequence
ImplantTemplateGroupVariationDimensionSequence | (0078,00B0): Implant Template Group Variation Dimension Sequence
ImplantTemplateGroupVersion | (0078,0024): Implant Template Group Version
ImplantTemplateVersion | (0068,6221): Implant Template Version
ImplantType | (0068,6223): Implant Type
ImplantTypeCodeSequence | (0068,63A8): Implant Type Code Sequence
ImplementationClassUID | (0002,0012): Implementation Class UID
ImplementationVersionName | (0002,0013): Implementation Version Name
Impressions | (4008,0300): Impressions
InboundArrivalType | (4010,1056): Inbound Arrival Type
IncidentAngle | (0014,4052): Incident Angle
IncludeDisplayApplication | (2200,0009): Include Display Application
IncludeNonDICOMObjects | (2200,0008): Include Non-DICOM Objects
IncludesImagingSubject | (0034,0008): Includes Imaging Subject
IncludesInformation | (0034,000C): Includes Information
InConcatenationNumber | (0020,9162): In-concatenation Number
InConcatenationTotalNumber | (0020,9163): In-concatenation Total Number
IndexNormalsFlag | (0024,0338): Index Normals Flag
IndexProbability | (0024,0341): Index Probability
IndexProbabilitySequence | (0024,0344): Index Probability Sequence
IndicationDescription | (0014,2018): Indication Description
IndicationDisposition | (0014,201C): Indication Disposition
IndicationLabel | (0014,2016): Indication Label
IndicationNumber | (0014,2014): Indication Number
IndicationPhysicalPropertySequence | (0014,2030): Indication Physical Property Sequence
IndicationROISequence | (0014,201E): Indication ROI Sequence
IndicationSequence | (0014,2012): Indication Sequence
IndicationType | (0014,201A): Indication Type
InformationFromManufacturerSequence | (0068,6260): Information From Manufacturer Sequence
InformationIssueDateTime | (0068,6270): Information Issue DateTime
InformationSummary | (0068,6280): Information Summary
InitialCineRunState | (0018,0042): Initial Cine Run State
Initiator | (0000,0200): Initiator(Retired)
InnerDiameter | (0014,0056): Inner Diameter
InPlanePhaseEncodingDirection | (0018,1312): In-plane Phase Encoding Direction
InputAvailabilityFlag | (0040,4020): Input Availability Flag
InputInformationSequence | (0040,4021): Input Information Sequence
InputReadinessState | (0040,4041): Input Readiness State
InputSequencePositionIndex | (0070,1203): Input Sequence Position Index
InspectionSelectionCriteria | (4010,107C): Inspection Selection Criteria
InStackPositionNumber | (0020,9057): In-Stack Position Number
InstanceAvailability | (0008,0056): Instance Availability
InstanceCoercionDateTime | (0008,0015): Instance Coercion DateTime
InstanceCreationDate | (0008,0012): Instance Creation Date
InstanceCreationTime | (0008,0013): Instance Creation Time
InstanceCreatorUID | (0008,0014): Instance Creator UID
InstanceLevelReferencedPerformedProcedureStepSequence | (3010,0044): Instance-Level Referenced Performed Procedure Step Sequence
InstanceNumber | (0020,0013): Instance Number
InstanceOriginStatus | (0400,0600): Instance Origin Status
InstitutionAddress | (0008,0081): Institution Address
InstitutionalDepartmentName | (0008,1040): Institutional Department Name
InstitutionalDepartmentTypeCodeSequence | (0008,1041): Institutional Department Type Code Sequence
InstitutionCodeSequence | (0008,0082): Institution Code Sequence
InstitutionName | (0008,0080): Institution Name
InstructionDescription | (0018,9917): Instruction Description
InstructionIndex | (0018,9915): Instruction Index
InstructionPerformanceComment | (0018,991A): Instruction Performance Comment
InstructionPerformedDateTime | (0018,9919): Instruction Performed DateTime
InstructionPerformedFlag | (0018,9918): Instruction Performed Flag
InstructionSequence | (0018,9914): Instruction Sequence
InstructionText | (0018,9916): Instruction Text
InsurancePlanIdentification | (0010,1050): Insurance Plan Identification(Retired)
IntendedDeliveryDuration | (3010,007E): Intended Delivery Duration
IntendedFractionStartTime | (3010,0085): Intended Fraction Start Time
IntendedNumberOfFractions | (300A,0636): Intended Number of Fractions
IntendedPhaseEndDate | (3010,004D): Intended Phase End Date
IntendedPhaseStartDate | (3010,004C): Intended Phase Start Date
IntendedRecipientsOfResultsIdentificationSequence | (0040,1011): Intended Recipients of Results Identification Sequence
IntendedRTTreatmentPhaseSequence | (3010,004B): Intended RT Treatment Phase Sequence
IntendedStartDayOfWeek | (3010,0086): Intended Start Day of Week
IntensifierActiveDimensions | (0018,9428): Intensifier Active Dimension(s)
IntensifierActiveShape | (0018,9427): Intensifier Active Shape
IntensifierSize | (0018,1162): Intensifier Size
InterlockCodeSequence | (300A,0744): Interlock Code Sequence
InterlockDateTime | (300A,0741): Interlock DateTime
InterlockDescription | (300A,0742): Interlock Description
InterlockOriginatingDeviceSequence | (300A,0743): Interlock Originating Device Sequence
InterlockOriginDescription | (300A,0783): Interlock Origin Description
InterlockResolutionCodeSequence | (300A,0745): Interlock Resolution Code Sequence
InterlockResolutionUserSequence | (300A,0746): Interlock Resolution User Sequence
InterlockSequence | (300A,0740): Interlock Sequence
InterMarkerDistance | (0050,0019): Inter-Marker Distance
IntermediatePupillaryDistance | (0046,0063): Intermediate Pupillary Distance
InternalDetectorFrameTime | (0014,3011): Internal Detector Frame Time
InternationalRouteSegment | (4010,1028): International Route Segment
InteroperabilityIndex | (0016,0061): Interoperability Index
InteroperabilityVersion | (0016,0062): Interoperability Version
InterpolationType | (0052,0039): Interpolation Type
InterpretationApprovalDate | (4008,0112): Interpretation Approval Date
InterpretationApprovalTime | (4008,0113): Interpretation Approval Time
InterpretationApproverSequence | (4008,0111): Interpretation Approver Sequence
InterpretationAuthor | (4008,010C): Interpretation Author
InterpretationDiagnosisCodeSequence | (4008,0117): Interpretation Diagnosis Code Sequence
InterpretationDiagnosisDescription | (4008,0115): Interpretation Diagnosis Description
InterpretationID | (4008,0200): Interpretation ID
InterpretationIDIssuer | (4008,0202): Interpretation ID Issuer
InterpretationRecordedDate | (4008,0100): Interpretation Recorded Date
InterpretationRecordedTime | (4008,0101): Interpretation Recorded Time
InterpretationRecorder | (4008,0102): Interpretation Recorder
InterpretationStatusID | (4008,0212): Interpretation Status ID
InterpretationText | (4008,010B): Interpretation Text
InterpretationTranscriber | (4008,010A): Interpretation Transcriber
InterpretationTranscriptionDate | (4008,0108): Interpretation Transcription Date
InterpretationTranscriptionTime | (4008,0109): Interpretation Transcription Time
InterpretationTypeID | (4008,0210): Interpretation Type ID
IntervalNumber | (0020,0016): Interval Number
IntervalsAcquired | (0018,1083): Intervals Acquired
IntervalsRejected | (0018,1084): Intervals Rejected
InterventionDescription | (0018,003A): Intervention Description
InterventionDrugCodeSequence | (0018,0029): Intervention Drug Code Sequence
InterventionDrugDose | (0018,0028): Intervention Drug Dose
InterventionDrugInformationSequence | (0018,0026): Intervention Drug Information Sequence
InterventionDrugName | (0018,0034): Intervention Drug Name
InterventionDrugStartTime | (0018,0035): Intervention Drug Start Time
InterventionDrugStopTime | (0018,0027): Intervention Drug Stop Time
InterventionSequence | (0018,0036): Intervention Sequence
InterventionStatus | (0018,0038): Intervention Status
IntraocularLensCalculationsLeftEyeSequence | (0022,1310): Intraocular Lens Calculations Left Eye Sequence
IntraocularLensCalculationsRightEyeSequence | (0022,1300): Intraocular Lens Calculations Right Eye Sequence
IntraOcularPressure | (0022,000B): Intra Ocular Pressure
IntravascularFrameContentSequence | (0052,0027): Intravascular Frame Content Sequence
IntravascularLongitudinalDistance | (0052,0028): Intravascular Longitudinal Distance
IntravascularOCTFrameContentSequence | (0052,0029): Intravascular OCT Frame Content Sequence
IntravascularOCTFrameTypeSequence | (0052,0025): Intravascular OCT Frame Type Sequence
InversionRecovery | (0018,9009): Inversion Recovery
InversionTime | (0018,0082): Inversion Time
InversionTimes | (0018,9079): Inversion Times
IOLFormulaCodeSequence | (0022,1028): IOL Formula Code Sequence
IOLFormulaDetail | (0022,1029): IOL Formula Detail
IOLManufacturer | (0022,1093): IOL Manufacturer
IOLPower | (0022,1053): IOL Power
IOLPowerForExactEmmetropia | (0022,1121): IOL Power For Exact Emmetropia
IOLPowerForExactTargetRefraction | (0022,1122): IOL Power For Exact Target Refraction
IOLPowerSequence | (0022,1090): IOL Power Sequence
IonBeamLimitingDeviceSequence | (300A,03A4): Ion Beam Limiting Device Sequence
IonBeamSequence | (300A,03A2): Ion Beam Sequence
IonBlockSequence | (300A,03A6): Ion Block Sequence
IonControlPointDeliverySequence | (3008,0041): Ion Control Point Delivery Sequence
IonControlPointSequence | (300A,03A8): Ion Control Point Sequence
IonControlPointVerificationSequence | (0074,104E): Ion Control Point Verification Sequence
IonMachineVerificationSequence | (0074,1046): Ion Machine Verification Sequence
IonRangeCompensatorSequence | (300A,02EA): Ion Range Compensator Sequence
IonToleranceTableSequence | (300A,03A0): Ion Tolerance Table Sequence
IonWedgePositionSequence | (300A,03AC): Ion Wedge Position Sequence
IonWedgeSequence | (300A,03AA): Ion Wedge Sequence
IrradiationEventIdentificationSequence | (0018,9477): Irradiation Event Identification Sequence
IrradiationEventUID | (0008,3010): Irradiation Event UID
IsocenterPosition | (300A,012C): Isocenter Position
IsocenterReferenceSystemSequence | (0018,9462): Isocenter Reference System Sequence
IsocenterToBeamLimitingDeviceDistance | (300A,00BB): Isocenter to Beam Limiting Device Distance
IsocenterToBlockTrayDistance | (300A,00F7): Isocenter to Block Tray Distance
IsocenterToCompensatorDistances | (300A,02E6): Isocenter to Compensator Distances
IsocenterToCompensatorTrayDistance | (300A,02E4): Isocenter to Compensator Tray Distance
IsocenterToGeneralAccessoryDistance | (300A,0426): Isocenter to General Accessory Distance
IsocenterToLateralSpreadingDeviceDistance | (300A,0374): Isocenter to Lateral Spreading Device Distance
IsocenterToRangeModulatorDistance | (300A,038A): Isocenter to Range Modulator Distance
IsocenterToRangeShifterDistance | (300A,0364): Isocenter to Range Shifter Distance
IsocenterToWedgeTrayDistance | (300A,00D9): Isocenter to Wedge Tray Distance
ISOSpeed | (0016,001D): ISO Speed
ISOSpeedLatitudeyyy | (0016,001E): ISO Speed Latitude yyy
ISOSpeedLatitudezzz | (0016,001F): ISO Speed Latitude zzz
IsotopeNumber | (0020,0014): Isotope Number
IssueDateOfImagingServiceRequest | (0040,2004): Issue Date of Imaging Service Request
IssuerOfAccessionNumberSequence | (0008,0051): Issuer of Accession Number Sequence
IssuerOfAdmissionID | (0038,0011): Issuer of Admission ID
IssuerOfAdmissionIDSequence | (0038,0014): Issuer of Admission ID Sequence
IssuerOfPatientID | (0010,0021): Issuer of Patient ID
IssuerOfPatientIDQualifiersSequence | (0010,0024): Issuer of Patient ID Qualifiers Sequence
IssuerOfServiceEpisodeID | (0038,0061): Issuer of Service Episode ID
IssuerOfServiceEpisodeIDSequence | (0038,0064): Issuer of Service Episode ID Sequence
IssuerOfTheContainerIdentifierSequence | (0040,0513): Issuer of the Container Identifier Sequence
IssuerOfTheSpecimenIdentifierSequence | (0040,0562): Issuer of the Specimen Identifier Sequence
IssueTimeOfImagingServiceRequest | (0040,2005): Issue Time of Imaging Service Request
Italic | (0070,0250): Italic
Item | (FFFE,E000): Item
ItemDelimitationItem | (FFFE,E00D): Item Delimitation Item
ItemNumber | (0020,0019): Item Number
IterativeReconstructionMethod | (0018,9769): Iterative Reconstruction Method
ItineraryID | (4010,1051): Itinerary ID
ItineraryIDAssigningAuthority | (4010,1053): Itinerary ID Assigning Authority
ItineraryIDType | (4010,1052): Itinerary ID Type
IVUSAcquisition | (0018,3100): IVUS Acquisition
IVUSGatedRate | (0018,3102): IVUS Gated Rate
IVUSPullbackRate | (0018,3101): IVUS Pullback Rate
IVUSPullbackStartFrameNumber | (0018,3103): IVUS Pullback Start Frame Number
IVUSPullbackStopFrameNumber | (0018,3104): IVUS Pullback Stop Frame Number
KeratoconusPredictionIndex | (0046,0236): Keratoconus Prediction Index
KeratometerIndex | (0022,1033): Keratometer Index
KeratometricAxis | (0046,0077): Keratometric Axis
KeratometricPower | (0046,0076): Keratometric Power
KeratometryLeftEyeSequence | (0046,0071): Keratometry Left Eye Sequence
KeratometryMeasurementTypeCodeSequence | (0022,1096): Keratometry Measurement Type Code Sequence
KeratometryRightEyeSequence | (0046,0070): Keratometry Right Eye Sequence
KSpaceFiltering | (0018,9064): k-space Filtering
KVP | (0018,0060): KVP
KVUsedInGainCalibration | (0014,3071): KV Used in Gain Calibration
LabelStyleSelection | (2200,0003): Label Style Selection
LabelText | (2200,0002): Label Text
LabelUsingInformationExtractedFromInstances | (2200,0001): Label Using Information Extracted From Instances
LanguageCodeSequence | (0008,0006): Language Code Sequence
LanguageCodeSequenceTrial | (0040,A744): Language Code Sequence (Trial)
LargeBluePaletteColorLookupTableData | (0028,1213): Large Blue Palette Color Lookup Table Data
LargeBluePaletteColorLookupTableDescriptor | (0028,1113): Large Blue Palette Color Lookup Table Descriptor
LargeGreenPaletteColorLookupTableData | (0028,1212): Large Green Palette Color Lookup Table Data
LargeGreenPaletteColorLookupTableDescriptor | (0028,1112): Large Green Palette Color Lookup Table Descriptor
LargePaletteColorLookupTableUID | (0028,1214): Large Palette Color Lookup Table UID
LargeRedPaletteColorLookupTableData | (0028,1211): Large Red Palette Color Lookup Table Data
LargeRedPaletteColorLookupTableDescriptor | (0028,1111): Large Red Palette Color Lookup Table Descriptor
LargestImagePixelValue | (0028,0107): Largest Image Pixel Value
LargestImagePixelValueInPlane | (0028,0111): Largest Image Pixel Value in Plane
LargestMonochromePixelValue | (0028,9099): Largest Monochrome Pixel Value
LargestPixelValueInSeries | (0028,0109): Largest Pixel Value in Series
LargestValidPixelValue | (0028,0105): Largest Valid Pixel Value(Retired)
LastMenstrualDate | (0010,21D0): Last Menstrual Date
Laterality | (0020,0060): Laterality
LateralSpreadingDeviceDescription | (300A,033A): Lateral Spreading Device Description
LateralSpreadingDeviceID | (300A,0336): Lateral Spreading Device ID
LateralSpreadingDeviceNumber | (300A,0334): Lateral Spreading Device Number
LateralSpreadingDeviceSequence | (300A,0332): Lateral Spreading Device Sequence
LateralSpreadingDeviceSetting | (300A,0372): Lateral Spreading Device Setting
LateralSpreadingDeviceSettingsSequence | (300A,0370): Lateral Spreading Device Settings Sequence
LateralSpreadingDeviceType | (300A,0338): Lateral Spreading Device Type
LateralSpreadingDeviceWaterEquivalentThickness | (300A,033C): Lateral Spreading Device Water Equivalent Thickness
LeafJawPositions | (300A,011C): Leaf/Jaw Positions
LeafPositionBoundaries | (300A,00BE): Leaf Position Boundaries
LeftImageSequence | (0022,0021): Left Image Sequence
LeftLensSequence | (0046,0015): Left Lens Sequence
LengthToEnd | (0008,0001): Length to End(Retired)
LensConstantDescription | (0022,1094): Lens Constant Description
LensConstantSequence | (0022,1092): Lens Constant Sequence
LensDescription | (0046,0012): Lens Description
LensesCodeSequence | (0022,0019): Lenses Code Sequence
LensMake | (0016,004F): Lens Make
LensModel | (0016,0050): Lens Model
LensSegmentType | (0046,0038): Lens Segment Type
LensSerialNumber | (0016,0051): Lens Serial Number
LensSpecification | (0016,004E): Lens Specification
LensStatusCodeSequence | (0022,1024): Lens Status Code Sequence
LensStatusDescription | (0022,1065): Lens Status Description
LensThickness | (0022,1130): Lens Thickness
LensThicknessSequence | (0022,1127): Lens Thickness Sequence
LesionNumber | (0018,3105): Lesion Number
LightDirection | (0070,1703): Light Direction
LightPathFilterPassBand | (0022,0002): Light Path Filter Pass Band
LightPathFilterPassThroughWavelength | (0022,0001): Light Path Filter Pass-Through Wavelength
LightPathFilterTypeStackCodeSequence | (0022,0017): Light Path Filter Type Stack Code Sequence
LightSource | (0016,0028): Light Source
LightSourcePolarization | (0016,1001): Light Source Polarization
LINACEnergy | (0014,5002): LINAC Energy
LINACOutput | (0014,5004): LINAC Output
LinearityCorrectionTechnique | (0014,3100): Linearity Correction Technique
LineDashingStyle | (0070,0254): Line Dashing Style
LinePattern | (0070,0255): Line Pattern
LineSequence | (0066,0028): Line Sequence
LineStyleSequence | (0070,0232): Line Style Sequence
LineThickness | (0070,0253): Line Thickness
ListOfMIMETypes | (0042,0014): List of MIME Types
LocalDeviationProbabilityNormalsFlag | (0024,0072): Local Deviation Probability Normals Flag
LocalizedDeviationFromNormal | (0024,0068): Localized Deviation From Normal
LocalizedDeviationProbability | (0024,0073): Localized Deviation Probability
LocalizedDeviationProbabilitySequence | (0024,0085): Localized Deviation Probability Sequence
LocalizingCursorPosition | (0018,2043): Localizing Cursor Position
LocalNamespaceEntityID | (0040,0031): Local Namespace Entity ID
Location | (0020,0050): Location(Retired)
LocationOfMeasuredBeamDiameter | (0014,4019): Location of Measured Beam Diameter
LongCodeValue | (0008,0119): Long Code Value
LongDeviceDescription | (0050,0021): Long Device Description
LongEdgePointIndexList | (0066,0042): Long Edge Point Index List
LongitudinalTemporalEventType | (0012,0053): Longitudinal Temporal Event Type
LongitudinalTemporalInformationModified | (0028,0303): Longitudinal Temporal Information Modified
LongitudinalTemporalOffsetFromEvent | (0012,0052): Longitudinal Temporal Offset from Event
LongPrimitivePointIndexList | (0066,0040): Long Primitive Point Index List
LongTrianglePointIndexList | (0066,0041): Long Triangle Point Index List
LongVertexPointIndexList | (0066,0043): Long Vertex Point Index List
LossyImageCompression | (0028,2110): Lossy Image Compression
LossyImageCompressionMethod | (0028,2114): Lossy Image Compression Method
LossyImageCompressionRatio | (0028,2112): Lossy Image Compression Ratio
LossyImageCompressionRetired | (0008,2110): Lossy Image Compression (Retired)
LowEnergyDetectors | (4010,0001): Low Energy Detectors
LowRRValue | (0018,1081): Low R-R Value
LuminanceCharacteristicsID | (0028,7009): Luminance Characteristics ID
LuminanceResponseDescription | (0028,7020): Luminance Response Description
LuminanceResponseSequence | (0028,701C): Luminance Response Sequence
LuminanceResultSequence | (0028,7024): Luminance Result Sequence
LuminanceUniformityResultSequence | (0028,7027): Luminance Uniformity Result Sequence
LuminanceValue | (0028,701F): Luminance Value
LUTData | (0028,3006): LUT Data
LUTDescriptor | (0028,3002): LUT Descriptor
LUTExplanation | (0028,3003): LUT Explanation
LUTFrameRange | (0028,9507): LUT Frame Range
LUTFunction | (0028,9474): LUT Function
LUTLabel | (0040,9210): LUT Label
LUTNumber | (0020,0026): LUT Number
MAC | (0400,0404): MAC
MACAlgorithm | (0400,0015): MAC Algorithm
MACCalculationTransferSyntaxUID | (0400,0010): MAC Calculation Transfer Syntax UID
MachineSpecificTreatmentTerminationCodeSequence | (300A,0716): Machine-Specific Treatment Termination Code Sequence
MACIDNumber | (0400,0005): MAC ID Number
MACParametersSequence | (4FFE,0001): MAC Parameters Sequence
MagneticFieldStrength | (0018,0087): Magnetic Field Strength
MagnetizationTransfer | (0018,9020): Magnetization Transfer
MagnificationType | (2010,0060): Magnification Type
MagnifyToNumberOfColumns | (2040,0074): Magnify to Number of Columns
MainLobeAngle | (0014,5103): Main Lobe Angle
MainRoofAngle | (0014,5104): Main Roof Angle
MajorTicksSequence | (0070,0287): Major Ticks Sequence
MakerNote | (0016,002B): Maker Note
MandatoryComponentType | (0076,0038): Mandatory Component Type
Manifold | (0066,0010): Manifold
ManipulatedImage | (0028,0050): Manipulated Image(Retired)
Manufacturer | (0008,0070): Manufacturer
ManufacturerDeviceClassUID | (0018,100B): Manufacturer's Device Class UID
ManufacturerDeviceIdentifier | (3010,0043): Manufacturer's Device Identifier
ManufacturerModelName | (0008,1090): Manufacturer's Model Name
ManufacturerModelVersion | (3010,001A): Manufacturer's Model Version
ManufacturerRelatedModelGroup | (0008,0222): Manufacturer's Related Model Group
MappedPixelValue | (0022,1452): Mapped Pixel Value
MappingResource | (0008,0105): Mapping Resource
MappingResourceIdentificationSequence | (0008,0124): Mapping Resource Identification Sequence
MappingResourceName | (0008,0122): Mapping Resource Name
MappingResourceUID | (0008,0118): Mapping Resource UID
MaskFrameNumbers | (0028,6110): Mask Frame Numbers
MaskingImage | (0020,0080): Masking Image(Retired)
MaskOperation | (0028,6101): Mask Operation
MaskOperationExplanation | (0028,6190): Mask Operation Explanation
MaskPointers | (0028,6030): Mask Pointer(s)
MaskSelectionMode | (0028,9454): Mask Selection Mode
MaskSubPixelShift | (0028,6114): Mask Sub-pixel Shift
MaskSubtractionSequence | (0028,6100): Mask Subtraction Sequence
MaskVisibilityPercentage | (0028,9478): Mask Visibility Percentage
Mass | (4010,1017): Mass
MaterialAttenuationSequence | (0018,9382): Material Attenuation Sequence
MaterialCodeSequence | (0018,937D): Material Code Sequence
MaterialGrade | (0014,0042): Material Grade
MaterialID | (300A,00E1): Material ID
MaterialIsolationDiameter | (0014,0034): Material Isolation Diameter
MaterialNotes | (0014,0046): Material Notes
MaterialPipeDiameter | (0014,0032): Material Pipe Diameter
MaterialPropertiesDescription | (0014,0044): Material Properties Description
MaterialPropertiesFileFormatRetired | (0014,0045): Material Properties File Format (Retired)
MaterialsCodeSequence | (0068,63A0): Materials Code Sequence
MaterialThickness | (0014,0030): Material Thickness
MatingFeatureDegreeOfFreedomSequence | (0068,6400): Mating Feature Degree of Freedom Sequence
MatingFeatureID | (0068,63F0): Mating Feature ID
MatingFeatureSequence | (0068,63E0): Mating Feature Sequence
MatingFeatureSetID | (0068,63C0): Mating Feature Set ID
MatingFeatureSetLabel | (0068,63D0): Mating Feature Set Label
MatingFeatureSetsSequence | (0068,63B0): Mating Feature Sets Sequence
MatrixRegistrationSequence | (0070,0309): Matrix Registration Sequence
MatrixSequence | (0070,030A): Matrix Sequence
MAUsedInGainCalibration | (0014,3072): MA Used in Gain Calibration
MaxApertureValue | (0016,0025): Max Aperture Value
MaxDensity | (2010,0130): Max Density
MaximumAcrossScanDistortion | (0022,0049): Maximum Across-scan Distortion
MaximumAlongScanDistortion | (0022,0038): Maximum Along-scan Distortion
MaximumCollatedFilms | (2010,0154): Maximum Collated Films
MaximumCoordinateValue | (50xx,0105): Maximum Coordinate Value
MaximumCornealCurvature | (0046,0212): Maximum Corneal Curvature
MaximumCornealCurvatureLocation | (0046,0213): Maximum Corneal Curvature Location
MaximumCornealCurvatureSequence | (0046,0211): Maximum Corneal Curvature Sequence
MaximumDepthDistortion | (0022,0036): Maximum Depth Distortion
MaximumFractionalValue | (0062,000E): Maximum Fractional Value
MaximumMemoryAllocation | (2000,0061): Maximum Memory Allocation
MaximumNominalEnergy | (300A,0682): Maximum Nominal Energy
MaximumNumberOfIntervalDays | (3010,0051): Maximum Number of Interval Days
MaximumPointDistance | (0066,0019): Maximum Point Distance
MaximumStimulusLuminance | (0024,0018): Maximum Stimulus Luminance
MaximumStoredValueMapped | (0028,1232): Maximum Stored Value Mapped
MeanPointDistance | (0066,0018): Mean Point Distance
MeasuredAPDimension | (0010,1023): Measured AP Dimension
MeasuredBandwidth | (0014,401C): Measured Bandwidth
MeasuredBeamDimensionA | (0014,4017): Measured Beam Dimension A
MeasuredBeamDimensionB | (0014,4018): Measured Beam Dimension B
MeasuredCenterFrequency | (0014,401B): Measured Center Frequency
MeasuredCharacteristics | (0028,7026): Measured Characteristics
MeasuredDoseDescription | (3008,0012): Measured Dose Description
MeasuredDoseReferenceNumber | (3008,0064): Measured Dose Reference Number
MeasuredDoseReferenceSequence | (3008,0010): Measured Dose Reference Sequence
MeasuredDoseType | (3008,0014): Measured Dose Type
MeasuredDoseValue | (3008,0016): Measured Dose Value
MeasuredLateralDimension | (0010,1024): Measured Lateral Dimension
MeasuredMetersetToDoseMappingSequence | (300A,0772): Measured Meterset to Dose Mapping Sequence
MeasuredValueSequence | (0040,A300): Measured Value Sequence
MeasurementAutomationTrial | (0040,A194): Measurement Automation (Trial)
MeasurementEquipmentSequence | (0028,7012): Measurement Equipment Sequence
MeasurementEquipmentType | (0028,7014): Measurement Equipment Type
MeasurementFunctions | (0028,7013): Measurement Functions
MeasurementLaterality | (0024,0113): Measurement Laterality
MeasurementPatternCodeSequence | (0028,702D): Measurement Pattern Code Sequence
MeasurementPrecisionDescriptionTrial | (0040,A047): Measurement Precision Description (Trial)
MeasurementsSequence | (0066,0121): Measurements Sequence
MeasurementUnitsCodeSequence | (0040,08EA): Measurement Units Code Sequence
MeasurementValuesSequence | (0066,0132): Measurement Values Sequence
MeasuringUnitsSequence | (0040,0295): Measuring Units Sequence
MechanicalIndex | (0018,5022): Mechanical Index
MediaDisposition | (2200,0004): Media Disposition
MediaInstalledSequence | (2000,00A2): Media Installed Sequence
MediaStorageSOPClassUID | (0002,0002): Media Storage SOP Class UID
MediaStorageSOPInstanceUID | (0002,0003): Media Storage SOP Instance UID
MedicalAlerts | (0010,2000): Medical Alerts
MedicalRecordLocator | (0010,1090): Medical Record Locator
MediumType | (2000,0030): Medium Type
MemoryAllocation | (2000,0060): Memory Allocation
MemoryBitDepth | (2000,00A0): Memory Bit Depth
MessageID | (0000,0110): Message ID
MessageIDBeingRespondedTo | (0000,0120): Message ID Being Responded To
MessageSetID | (0000,5010): Message Set ID(Retired)
MetaboliteMapCodeSequence | (0018,9083): Metabolite Map Code Sequence
MetaboliteMapDescription | (0018,9080): Metabolite Map Description
MeteringMode | (0016,0027): Metering Mode
MetersetExposure | (3002,0032): Meterset Exposure
MetersetRate | (300A,035A): Meterset Rate
MetersetRateDelivered | (3008,0046): Meterset Rate Delivered
MetersetRateSet | (3008,0045): Meterset Rate Set
MetersetToDoseMappingSequence | (300A,0620): Meterset to Dose Mapping Sequence
MidSlabPosition | (0018,9106): Mid Slab Position
MilitaryRank | (0010,1080): Military Rank
MIMETypeOfEncapsulatedDocument | (0042,0012): MIME Type of Encapsulated Document
MinDensity | (2010,0120): Min Density
MinimumCoordinateValue | (50xx,0104): Minimum Coordinate Value
MinimumHoursBetweenFractions | (3010,0084): Minimum Hours between Fractions
MinimumKeratometricSequence | (0046,0215): Minimum Keratometric Sequence
MinimumNominalEnergy | (300A,0681): Minimum Nominal Energy
MinimumNumberOfIntervalDays | (3010,0050): Minimum Number of Interval Days
MinimumSensitivityValue | (0024,0105): Minimum Sensitivity Value
MinimumStoredValueMapped | (0028,1231): Minimum Stored Value Mapped
ModalitiesInStudy | (0008,0061): Modalities in Study
Modality | (0008,0060): Modality
ModalityLUTSequence | (0028,3000): Modality LUT Sequence
ModalityLUTType | (0028,3004): Modality LUT Type
ModelGroupUID | (0068,7004): Model Group UID
ModelMirroring | (0068,7002): Model Mirroring
ModelModification | (0068,7001): Model Modification
ModelSpecificationSequence | (0018,9912): Model Specification Sequence
ModelUsageCodeSequence | (0068,7003): Model Usage Code Sequence
ModeOfPercutaneousAccessSequence | (0052,0016): Mode of Percutaneous Access Sequence
ModifiableConstraintFlag | (0082,0038): Modifiable Constraint Flag
ModifiedAttributesSequence | (0400,0550): Modified Attributes Sequence
ModifiedImageDate | (0020,3403): Modified Image Date(Retired)
ModifiedImageDescription | (0020,3406): Modified Image Description(Retired)
ModifiedImageID | (0020,3402): Modified Image ID(Retired)
ModifiedImageTime | (0020,3405): Modified Image Time(Retired)
ModifierCodeSequence | (0040,A195): Modifier Code Sequence
ModifyingDeviceID | (0020,3401): Modifying Device ID(Retired)
ModifyingDeviceManufacturer | (0020,3404): Modifying Device Manufacturer(Retired)
ModifyingSystem | (0400,0563): Modifying System
ModulatedScanModeType | (300A,0309): Modulated Scan Mode Type
ModulationType | (0014,4026): Modulation Type
MonoenergeticEnergyEquivalent | (0018,937C): Monoenergetic Energy Equivalent
MostRecentTreatmentDate | (3008,0056): Most Recent Treatment Date
MotionSynchronizationSequence | (300A,0410): Motion Synchronization Sequence
MoveDestination | (0000,0600): Move Destination
MoveOriginatorApplicationEntityTitle | (0000,1030): Move Originator Application Entity Title
MoveOriginatorMessageID | (0000,1031): Move Originator Message ID
MPRSlabThickness | (0070,1503): MPR Slab Thickness
MPRThicknessType | (0070,1502): MPR Thickness Type
MPRTopLeftHandCorner | (0070,1505): MPR Top Left Hand Corner
MPRViewHeight | (0070,1512): MPR View Height
MPRViewHeightDirection | (0070,1511): MPR View Height Direction
MPRViewWidth | (0070,1508): MPR View Width
MPRViewWidthDirection | (0070,1507): MPR View Width Direction
MRAcquisitionFrequencyEncodingSteps | (0018,9058): MR Acquisition Frequency Encoding Steps
MRAcquisitionPhaseEncodingStepsInPlane | (0018,9231): MR Acquisition Phase Encoding Steps in-plane
MRAcquisitionPhaseEncodingStepsOutOfPlane | (0018,9232): MR Acquisition Phase Encoding Steps out-of-plane
MRAcquisitionType | (0018,0023): MR Acquisition Type
MRArterialSpinLabelingSequence | (0018,9251): MR Arterial Spin Labeling Sequence
MRAveragesSequence | (0018,9119): MR Averages Sequence
MRDiffusionSequence | (0018,9117): MR Diffusion Sequence
MRDRDirectoryRecordOffset | (0004,1504): MRDR Directory Record Offset
MREchoSequence | (0018,9114): MR Echo Sequence
MRFOVGeometrySequence | (0018,9125): MR FOV/Geometry Sequence
MRImageFrameTypeSequence | (0018,9226): MR Image Frame Type Sequence
MRImagingModifierSequence | (0018,9006): MR Imaging Modifier Sequence
MRMetaboliteMapSequence | (0018,9152): MR Metabolite Map Sequence
MRModifierSequence | (0018,9115): MR Modifier Sequence
MRReceiveCoilSequence | (0018,9042): MR Receive Coil Sequence
MRSpatialSaturationSequence | (0018,9107): MR Spatial Saturation Sequence
MRSpectroscopyAcquisitionType | (0018,9200): MR Spectroscopy Acquisition Type
MRSpectroscopyFOVGeometrySequence | (0018,9103): MR Spectroscopy FOV/Geometry Sequence
MRSpectroscopyFrameTypeSequence | (0018,9227): MR Spectroscopy Frame Type Sequence
MRTimingAndRelatedParametersSequence | (0018,9112): MR Timing and Related Parameters Sequence
MRTransmitCoilSequence | (0018,9049): MR Transmit Coil Sequence
MRVelocityEncodingSequence | (0018,9197): MR Velocity Encoding Sequence
MultiCoilConfiguration | (0018,9046): Multi-Coil Configuration
MultiCoilDefinitionSequence | (0018,9045): Multi-Coil Definition Sequence
MultiCoilElementName | (0018,9047): Multi-Coil Element Name
MultiCoilElementUsed | (0018,9048): Multi-Coil Element Used
MultienergyAcquisitionDescription | (0018,937B): Multi-energy Acquisition Description
MultienergyCTAcquisition | (0018,9361): Multi-energy CT Acquisition
MultienergyCTAcquisitionSequence | (0018,9362): Multi-energy CT Acquisition Sequence
MultienergyCTCharacteristicsSequence | (0018,9364): Multi-energy CT Characteristics Sequence
MultienergyCTPathIndex | (0018,937A): Multi-energy CT Path Index
MultienergyCTPathSequence | (0018,9379): Multi-energy CT Path Sequence
MultienergyCTProcessingSequence | (0018,9363): Multi-energy CT Processing Sequence
MultienergyCTXRayDetectorSequence | (0018,936F): Multi-energy CT X-Ray Detector Sequence
MultienergyCTXRaySourceSequence | (0018,9365): Multi-energy CT X-Ray Source Sequence
MultienergyDetectorType | (0018,9372): Multi-energy Detector Type
MultienergySourceTechnique | (0018,9368): Multi-energy Source Technique
MultiFramePresentationSequence | (0028,9505): Multi-frame Presentation Sequence
MultiFrameSourceSOPInstanceUID | (0008,1167): Multi-frame Source SOP Instance UID
MultiPlanarExcitation | (0018,9012): Multi-planar Excitation
MultiPlanarReconstructionStyle | (0070,1501): Multi-Planar Reconstruction Style
MultipleComponentApprovalSequence | (0014,0106): Multiple Component Approval Sequence
MultipleCopiesFlag | (0040,4006): Multiple Copies Flag
MultipleSpinEcho | (0018,9011): Multiple Spin Echo
MultiplexedAudioChannelsDescriptionCodeSequence | (003A,0300): Multiplexed Audio Channels Description Code Sequence
MultiplexGroupLabel | (003A,0020): Multiplex Group Label
MultiplexGroupTimeOffset | (0018,1068): Multiplex Group Time Offset
MultiplexGroupUID | (003A,0310): Multiplex Group UID
MydriaticAgentCodeSequence | (0022,001C): Mydriatic Agent Code Sequence
MydriaticAgentConcentration | (0022,004E): Mydriatic Agent Concentration
MydriaticAgentConcentrationUnitsSequence | (0022,0042): Mydriatic Agent Concentration Units Sequence
MydriaticAgentSequence | (0022,0058): Mydriatic Agent Sequence
NameOfPhysiciansReadingStudy | (0008,1060): Name of Physician(s) Reading Study
NamesOfIntendedRecipientsOfResults | (0040,1010): Names of Intended Recipients of Results
NavigationDisplaySet | (0072,0216): Navigation Display Set
NavigationIndicatorSequence | (0072,0214): Navigation Indicator Sequence
NearPupillaryDistance | (0046,0062): Near Pupillary Distance
NegativeCatchTrialsQuantity | (0024,0048): Negative Catch Trials Quantity
NetworkID | (0008,1000): Network ID(Retired)
NominalBeamAngle | (0014,5112): Nominal Beam Angle
NominalBeamEnergy | (300A,0114): Nominal Beam Energy
NominalBeamEnergyUnit | (300A,0015): Nominal Beam Energy Unit
NominalCardiacTriggerDelayTime | (0020,9153): Nominal Cardiac Trigger Delay Time
NominalCardiacTriggerTimePriorToRPeak | (0020,9154): Nominal Cardiac Trigger Time Prior To R-Peak
NominalEnergy | (300A,0680): Nominal Energy
NominalFrequency | (0014,401A): Nominal Frequency
NominalInterval | (0018,1062): Nominal Interval
NominalMaxEnergy | (0018,9374): Nominal Max Energy
NominalMinEnergy | (0018,9375): Nominal Min Energy
NominalPercentageOfCardiacPhase | (0020,9241): Nominal Percentage of Cardiac Phase
NominalPercentageOfRespiratoryPhase | (0020,9245): Nominal Percentage of Respiratory Phase
NominalPriorDose | (300A,001A): Nominal Prior Dose
NominalRangeModulatedRegionDepths | (300A,0504): Nominal Range Modulated Region Depths
NominalRangeModulationFractions | (300A,0503): Nominal Range Modulation Fractions
NominalRespiratoryTriggerDelayTime | (0020,9255): Nominal Respiratory Trigger Delay Time
NominalScannedPixelSpacing | (0018,2010): Nominal Scanned Pixel Spacing
NominalScreenDefinitionSequence | (0072,0102): Nominal Screen Definition Sequence
NonconformingDataElementValue | (0400,0552): Nonconforming Data Element Value
NonconformingModifiedAttributesSequence | (0400,0551): Nonconforming Modified Attributes Sequence
NonDICOMOutputCodeSequence | (0040,4032): Non-DICOM Output Code Sequence
NonidentifyingPrivateElements | (0008,0304): Nonidentifying Private Elements
NonUniformRadialSamplingCorrected | (0018,9766): Non-uniform Radial Sampling Corrected
NormalizationFactorFormat | (0028,0710): Normalization Factor Format
NormalizationPoint | (3004,0008): Normalization Point
NormalReverse | (0000,5140): Normal/Reverse(Retired)
NotchFilterBandwidth | (003A,0223): Notch Filter Bandwidth
NotchFilterFrequency | (003A,0222): Notch Filter Frequency
NotificationFromManufacturerSequence | (0068,6265): Notification From Manufacturer Sequence
NTPSourceAddress | (0018,1803): NTP Source Address
NuclearMedicineSeriesType | (0008,0042): Nuclear Medicine Series Type
NumberOfAlarmObjects | (4010,1034): Number of Alarm Objects
NumberOfAnnotations | (006A,000C): Number of Annotations
NumberOfAssessmentObservations | (0082,0006): Number of Assessment Observations
NumberOfAverages | (0018,0083): Number of Averages
NumberOfBeams | (300A,0080): Number of Beams
NumberOfBlocks | (300A,00F0): Number of Blocks
NumberOfBlockSlabItems | (300A,0440): Number of Block Slab Items
NumberOfBoli | (300A,00ED): Number of Boli
NumberOfBoluses | (300A,0674): Number of Boluses
NumberOfBrachyApplicationSetups | (300A,00A0): Number of Brachy Application Setups
NumberOfBscansPerFrame | (0022,1642): Number of B-scans Per Frame
NumberOfChannels | (50xx,2004): Number of Channels
NumberOfCompensators | (300A,00E0): Number of Compensators
NumberOfCompletedSuboperations | (0000,1021): Number of Completed Sub-operations
NumberOfContourPoints | (3006,0046): Number of Contour Points
NumberOfControlPoints | (300A,0110): Number of Control Points
NumberOfCopies | (2000,0010): Number of Copies
NumberOfDetectors | (0054,0021): Number of Detectors
NumberOfDisplaySubsystems | (0028,7001): Number of Display Subsystems
NumberOfElements | (0014,4012): Number of Elements
NumberOfEnergyWindows | (0054,0011): Number of Energy Windows
NumberOfEventTimers | (0008,2129): Number of Event Timers
NumberOfFailedSuboperations | (0000,1022): Number of Failed Sub-operations
NumberOfFilms | (2100,0170): Number of Films
NumberOfFocalPlanes | (0048,0013): Number of Focal Planes
NumberOfFractionPatternDigitsPerDay | (300A,0079): Number of Fraction Pattern Digits Per Day
NumberOfFractions | (3010,007D): Number of Fractions
NumberOfFractionsDelivered | (3008,005A): Number of Fractions Delivered
NumberOfFractionsIncluded | (300C,0119): Number of Fractions Included
NumberOfFractionsPlanned | (300A,0078): Number of Fractions Planned
NumberOfFrames | (0028,0008): Number of Frames
NumberOfFramesInOverlay | (60xx,0015): Number of Frames in Overlay
NumberOfFramesInPhase | (0054,0033): Number of Frames in Phase
NumberOfFramesInRotation | (0054,0053): Number of Frames in Rotation
NumberOfFramesIntegrated | (0014,3012): Number of Frames Integrated
NumberOfFramesUsedForIntegration | (0014,3073): Number of Frames Used for Integration
NumberOfGeneralAccessories | (300A,0672): Number of General Accessories
NumberOfGraphicPoints | (0070,0021): Number of Graphic Points
NumberOfHorizontalPixels | (0072,0106): Number of Horizontal Pixels
NumberOfIntervalFractions | (3010,007C): Number of Interval Fractions
NumberOfIterations | (0018,9739): Number of Iterations
NumberOfKSpaceTrajectories | (0018,9093): Number of k-Space Trajectories
NumberOfLateralSpreadingDevices | (300A,0330): Number of Lateral Spreading Devices
NumberOfLeafJawPairs | (300A,00BC): Number of Leaf/Jaw Pairs
NumberOfLuminancePoints | (0028,701B): Number of Luminance Points
NumberOfMapPoints | (0022,1530): Number of Map Points
NumberOfMatches | (0000,0850): Number of Matches(Retired)
NumberOfOpticalPaths | (0048,0302): Number of Optical Paths
NumberOfPaddedALines | (0052,0038): Number of Padded A-lines
NumberOfPaintings | (300A,039A): Number of Paintings
NumberOfParallelRTBeamDelimiters | (300A,0648): Number of Parallel RT Beam Delimiters
NumberOfPatientRelatedInstances | (0020,1204): Number of Patient Related Instances
NumberOfPatientRelatedSeries | (0020,1202): Number of Patient Related Series
NumberOfPatientRelatedStudies | (0020,1200): Number of Patient Related Studies
NumberOfPatientSupportDevices | (300A,0687): Number of Patient Support Devices
NumberOfPhaseEncodingSteps | (0018,0089): Number of Phase Encoding Steps
NumberOfPhases | (0054,0031): Number of Phases
NumberOfPoints | (50xx,0010): Number of Points
NumberOfPolygonalVertices | (0018,1637): Number of Polygonal Vertices
NumberOfPriorsReferenced | (0072,0014): Number of Priors Referenced
NumberOfPulses | (300A,028A): Number of Pulses
NumberOfRadiationGenerationModes | (300A,0685): Number of Radiation GenerationModes
NumberOfRangeModulators | (300A,0340): Number of Range Modulators
NumberOfRangeShifters | (300A,0312): Number of Range Shifters
NumberOfReferences | (0004,1600): Number of References
NumberOfRemainingSuboperations | (0000,1020): Number of Remaining Sub-operations
NumberOfRotations | (0054,0051): Number of Rotations
NumberOfRRIntervals | (0054,0061): Number of R-R Intervals
NumberOfRTAccessoryHolders | (300A,0670): Number of RT Accessory Holders
NumberOfRTBeamLimitingDeviceOpenings | (300A,0657): Number of RT Beam Limiting Device Openings
NumberOfRTBeamLimitingDevices | (300A,0641): Number of RT Beam Limiting Devices
NumberOfRTControlPoints | (300A,0604): Number of RT Control Points
NumberOfSamples | (50xx,2006): Number of Samples
NumberOfScanSpotPositions | (300A,0392): Number of Scan Spot Positions
NumberOfScreens | (0072,0100): Number of Screens
NumberOfSeriesRelatedInstances | (0020,1209): Number of Series Related Instances
NumberOfSlices | (0054,0081): Number of Slices
NumberOfStages | (0008,2124): Number of Stages
NumberOfStudyRelatedInstances | (0020,1208): Number of Study Related Instances
NumberOfStudyRelatedSeries | (0020,1206): Number of Study Related Series
NumberOfSubsets | (0018,9740): Number of Subsets
NumberOfSurfacePoints | (0066,0015): Number of Surface Points
NumberOfSurfaces | (0066,0001): Number of Surfaces
NumberOfTableBreakPoints | (0018,6050): Number of Table Break Points
NumberOfTableColumns | (0040,A803): Number of Table Columns
NumberOfTableEntries | (0018,6056): Number of Table Entries
NumberOfTableRows | (0040,A802): Number of Table Rows
NumberOfTables | (0028,08x2): Number of Tables
NumberOfTemporalPositions | (0020,0105): Number of Temporal Positions
NumberOfTimeSlices | (0054,0101): Number of Time Slices
NumberOfTimeSlots | (0054,0071): Number of Time Slots
NumberOfTomosynthesisSourceImages | (0018,1495): Number of Tomosynthesis Source Images
NumberOfTotalObjects | (4010,1033): Number of Total Objects
NumberOfTransformSteps | (0028,0402): Number of Transform Steps
NumberOfTriggersInPhase | (0054,0211): Number of Triggers in Phase
NumberOfVectors | (0066,001E): Number of Vectors
NumberOfVerticalPixels | (0072,0104): Number of Vertical Pixels
NumberOfViewsInStage | (0008,212A): Number of Views in Stage
NumberOfVisualStimuli | (0024,0038): Number of Visual Stimuli
NumberOfVolumetricCurvePoints | (0070,150C): Number of Volumetric Curve Points
NumberOfWarningSuboperations | (0000,1023): Number of Warning Sub-operations
NumberOfWaveformChannels | (003A,0005): Number of Waveform Channels
NumberOfWaveformSamples | (003A,0010): Number of Waveform Samples
NumberOfWedgePositions | (300A,0655): Number of Wedge Positions
NumberOfWedges | (300A,00D0): Number of Wedges
NumberOfZeroFills | (0018,9066): Number of Zero Fills
NumericValue | (0040,A30A): Numeric Value
NumericValueQualifierCodeSequence | (0040,A301): Numeric Value Qualifier Code Sequence
ObjectBinaryIdentifierTrial | (0040,A074): Object Binary Identifier (Trial)
ObjectDirectoryBinaryIdentifierTrial | (0040,A089): Object Directory Binary Identifier (Trial)
ObjectiveLensNumericalAperture | (0048,0113): Objective Lens Numerical Aperture
ObjectiveLensPower | (0048,0112): Objective Lens Power
ObjectPixelSpacingInCenterOfBeam | (0018,9404): Object Pixel Spacing in Center of Beam
ObjectThicknessSequence | (0018,9456): Object Thickness Sequence
ObliqueCroppingPlaneSequence | (0070,1304): Oblique Cropping Plane Sequence
ObservationBasisCodeSequence | (0082,0022): Observation Basis Code Sequence
ObservationCategoryCodeSequenceTrial | (0040,A167): Observation Category Code Sequence (Trial)
ObservationDateTime | (0040,A032): Observation DateTime
ObservationDateTrial | (0040,A192): Observation Date (Trial)
ObservationDescription | (0082,000A): Observation Description
ObservationNumber | (3006,0082): Observation Number
ObservationSignificance | (0082,0008): Observation Significance
ObservationStartDateTime | (0040,A033): Observation Start DateTime
ObservationSubjectClassTrial | (0040,A403): Observation Subject Class (Trial)
ObservationSubjectContextFlagTrial | (0040,A600): Observation Subject Context Flag (Trial)
ObservationSubjectTypeCodeSequenceTrial | (0040,A404): Observation Subject Type Code Sequence (Trial)
ObservationSubjectUIDTrial | (0040,A402): Observation Subject UID (Trial)
ObservationTimeTrial | (0040,A193): Observation Time (Trial)
ObservationUID | (0040,A171): Observation UID
ObserverContextFlagTrial | (0040,A601): Observer Context Flag (Trial)
ObserverType | (0040,A084): Observer Type
Occupation | (0010,2180): Occupation
OCTAcquisitionDomain | (0052,0006): OCT Acquisition Domain
OCTBscanAnalysisAcquisitionParametersSequence | (0022,1640): OCT B-scan Analysis Acquisition Parameters Sequence
OCTFocalDistance | (0052,0002): OCT Focal Distance
OCTOpticalCenterWavelength | (0052,0007): OCT Optical Center Wavelength
OCTZOffsetApplied | (0052,0026): OCT Z Offset Applied
OCTZOffsetCorrection | (0052,0030): OCT Z Offset Correction
OECFColumnNames | (0016,0008): OECF Column Names
OECFColumns | (0016,0007): OECF Columns
OECFRows | (0016,0006): OECF Rows
OECFValues | (0016,0009): OECF Values
OffendingElement | (0000,0901): Offending Element
OffsetDirection | (0018,9905): Offset Direction
OffsetDistance | (0018,9904): Offset Distance
OffsetOfReferencedLowerLevelDirectoryEntity | (0004,1420): Offset of Referenced Lower-Level Directory Entity
OffsetOfTheFirstDirectoryRecordOfTheRootDirectoryEntity | (0004,1200): Offset of the First Directory Record of the Root Directory Entity
OffsetOfTheLastDirectoryRecordOfTheRootDirectoryEntity | (0004,1202): Offset of the Last Directory Record of the Root Directory Entity
OffsetOfTheNextDirectoryRecord | (0004,1400): Offset of the Next Directory Record
OmittedApplicationSetupSequence | (0074,140E): Omitted Application Setup Sequence
OmittedBeamTaskSequence | (300C,0111): Omitted Beam Task Sequence
OmittedChannelSequence | (0074,1409): Omitted Channel Sequence
OmittedRadiationSequence | (300A,0787): Omitted Radiation Sequence
OnAxisBackgroundAnatomicStructureCodeSequenceTrial | (0008,225C): On Axis Background Anatomic Structure Code Sequence (Trial)
OOIOwnerCreationTime | (4010,1041): OOI Owner Creation Time
OOIOwnerSequence | (4010,1047): OOI Owner Sequence
OOIOwnerType | (4010,1009): OOI Owner Type
OOISize | (4010,1043): OOI Size
OOIType | (4010,1042): OOI Type
OOITypeDescriptor | (4010,1068): OOI Type Descriptor
OperatingMode | (0018,9178): Operating Mode
OperatingModeSequence | (0018,9176): Operating Mode Sequence
OperatingModeType | (0018,9177): Operating Mode Type
OperatorIdentificationSequence | (0008,1072): Operator Identification Sequence
OperatorsName | (0008,1070): Operators' Name
OphthalmicAnatomicReferencePointXCoordinate | (0022,1624): Ophthalmic Anatomic Reference Point X-Coordinate
OphthalmicAnatomicReferencePointYCoordinate | (0022,1626): Ophthalmic Anatomic Reference Point Y-Coordinate
OphthalmicAxialLength | (0022,1019): Ophthalmic Axial Length
OphthalmicAxialLengthAcquisitionMethodCodeSequence | (0022,1153): Ophthalmic Axial Length Acquisition Method Code Sequence
OphthalmicAxialLengthDataSourceCodeSequence | (0022,1150): Ophthalmic Axial Length Data Source Code Sequence
OphthalmicAxialLengthDataSourceDescription | (0022,1159): Ophthalmic Axial Length Data Source Description
OphthalmicAxialLengthMeasurementModified | (0022,1140): Ophthalmic Axial Length Measurement Modified
OphthalmicAxialLengthMeasurementsLengthSummationSequence | (0022,1212): Ophthalmic Axial Length Measurements Length Summation Sequence
OphthalmicAxialLengthMeasurementsSegmentalLengthSequence | (0022,1211): Ophthalmic Axial Length Measurements Segmental Length Sequence
OphthalmicAxialLengthMeasurementsSegmentNameCodeSequence | (0022,1101): Ophthalmic Axial Length Measurements Segment Name Code Sequence
OphthalmicAxialLengthMeasurementsSequence | (0022,1050): Ophthalmic Axial Length Measurements Sequence
OphthalmicAxialLengthMeasurementsTotalLengthSequence | (0022,1210): Ophthalmic Axial Length Measurements Total Length Sequence
OphthalmicAxialLengthMeasurementsType | (0022,1010): Ophthalmic Axial Length Measurements Type
OphthalmicAxialLengthMethod | (0022,1515): Ophthalmic Axial Length Method
OphthalmicAxialLengthQualityMetricSequence | (0022,1262): Ophthalmic Axial Length Quality Metric Sequence
OphthalmicAxialLengthQualityMetricTypeCodeSequence | (0022,1265): Ophthalmic Axial Length Quality Metric Type Code Sequence(Retired)
OphthalmicAxialLengthQualityMetricTypeDescription | (0022,1273): Ophthalmic Axial Length Quality Metric Type Description
OphthalmicAxialLengthSelectionMethodCodeSequence | (0022,1250): Ophthalmic Axial Length Selection Method Code Sequence
OphthalmicAxialLengthSequence | (0022,1012): Ophthalmic Axial Length Sequence
OphthalmicAxialLengthVelocity | (0022,1059): Ophthalmic Axial Length Velocity
OphthalmicAxialMeasurementsDeviceType | (0022,1009): Ophthalmic Axial Measurements Device Type
OphthalmicAxialMeasurementsLeftEyeSequence | (0022,1008): Ophthalmic Axial Measurements Left Eye Sequence
OphthalmicAxialMeasurementsRightEyeSequence | (0022,1007): Ophthalmic Axial Measurements Right Eye Sequence
OphthalmicEnFaceImageQualityRatingSequence | (0022,1628): Ophthalmic En Face Image Quality Rating Sequence
OphthalmicFOV | (0022,1517): Ophthalmic FOV
OphthalmicFrameLocationSequence | (0022,0031): Ophthalmic Frame Location Sequence
OphthalmicImageOrientation | (0022,0039): Ophthalmic Image Orientation
OphthalmicImageTypeCodeSequence | (0022,1615): Ophthalmic Image Type Code Sequence
OphthalmicImageTypeDescription | (0022,1616): Ophthalmic Image Type Description
OphthalmicMappingDeviceType | (0022,1415): Ophthalmic Mapping Device Type
OphthalmicPatientClinicalInformationLeftEyeSequence | (0024,0114): Ophthalmic Patient Clinical Information Left Eye Sequence
OphthalmicPatientClinicalInformationRightEyeSequence | (0024,0115): Ophthalmic Patient Clinical Information Right Eye Sequence
OphthalmicThicknessMappingNormalsSequence | (0022,1443): Ophthalmic Thickness Mapping Normals Sequence
OphthalmicThicknessMapQualityRatingSequence | (0022,1470): Ophthalmic Thickness Map Quality Rating Sequence
OphthalmicThicknessMapQualityThresholdSequence | (0022,1458): Ophthalmic Thickness Map Quality Threshold Sequence
OphthalmicThicknessMapThresholdQualityRating | (0022,1460): Ophthalmic Thickness Map Threshold Quality Rating
OphthalmicThicknessMapTypeCodeSequence | (0022,1436): Ophthalmic Thickness Map Type Code Sequence
OphthalmicUltrasoundMethodCodeSequence | (0022,1044): Ophthalmic Ultrasound Method Code Sequence
OphthalmicVolumetricPropertiesFlag | (0022,1622): Ophthalmic Volumetric Properties Flag
OpticalMagnificationFactor | (0016,1005): Optical Magnification Factor
OpticalOphthalmicAxialLengthMeasurementsSequence | (0022,1225): Optical Ophthalmic Axial Length Measurements Sequence
OpticalPathDescription | (0048,0107): Optical Path Description
OpticalPathIdentificationSequence | (0048,0207): Optical Path Identification Sequence
OpticalPathIdentifier | (0048,0106): Optical Path Identifier
OpticalPathSequence | (0048,0105): Optical Path Sequence
OpticalSelectedOphthalmicAxialLengthSequence | (0022,1255): Optical Selected Ophthalmic Axial Length Sequence
OpticalTransmittance | (0046,0040): Optical Transmittance
Optotype | (0046,0094): Optotype
OptotypeDetailedDefinition | (0046,0139): Optotype Detailed Definition
OptotypePresentation | (0046,0095): Optotype Presentation
OrderCallbackPhoneNumber | (0040,2010): Order Callback Phone Number
OrderCallbackTelecomInformation | (0040,2011): Order Callback Telecom Information
OrderEnteredBy | (0040,2008): Order Entered By
OrderEntererLocation | (0040,2009): Order Enterer's Location
OrderFillerIdentifierSequence | (0040,0027): Order Filler Identifier Sequence
OrderPlacerIdentifierSequence | (0040,0026): Order Placer Identifier Sequence
OrganAtRiskFullVolumeDose | (300A,002A): Organ at Risk Full-volume Dose
OrganAtRiskLimitDose | (300A,002B): Organ at Risk Limit Dose
OrganAtRiskMaximumDose | (300A,002C): Organ at Risk Maximum Dose
OrganAtRiskOverdoseVolumeFraction | (300A,002D): Organ at Risk Overdose Volume Fraction
OrganDose | (0040,0316): Organ Dose
OrganExposed | (0040,0318): Organ Exposed
OrganizationalRoleCodeSequence | (0044,010A): Organizational Role Code Sequence
OriginalAttributesSequence | (0400,0561): Original Attributes Sequence
OriginalImageIdentification | (0020,5000): Original Image Identification(Retired)
OriginalImageIdentificationNomenclature | (0020,5002): Original Image Identification Nomenclature(Retired)
OriginalImageSequence | (2130,00C0): Original Image Sequence
OriginalImplantAssemblyTemplateSequence | (0076,000C): Original Implant Assembly Template Sequence
OriginalImplantTemplateSequence | (0068,6225): Original Implant Template Sequence
OriginalSpecializedSOPClassUID | (0008,001B): Original Specialized SOP Class UID
OriginatingSOPInstanceReferenceSequence | (3010,0007): Originating SOP Instance Reference Sequence
Originator | (2100,0070): Originator
OtherApprovalStatus | (0014,0107): Other Approval Status
OtherFailuresSequence | (0008,119A): Other Failures Sequence
OtherMagnificationTypesAvailable | (2010,00A7): Other Magnification Types Available
OtherMediaAvailableSequence | (2000,00A4): Other Media Available Sequence
OtherPatientIDs | (0010,1000): Other Patient IDs
OtherPatientIDsSequence | (0010,1002): Other Patient IDs Sequence
OtherPatientNames | (0010,1001): Other Patient Names
OtherPupillaryDistance | (0046,0064): Other Pupillary Distance
OtherSecondaryApprovalStatus | (0014,0108): Other Secondary Approval Status
OtherSmoothingTypesAvailable | (2010,00A9): Other Smoothing Types Available
OtherStudyNumbers | (0020,1070): Other Study Numbers
OuterDiameter | (0014,0054): Outer Diameter
OutlineLeftVerticalEdge | (0018,1631): Outline Left Vertical Edge
OutlineLowerHorizontalEdge | (0018,1634): Outline Lower Horizontal Edge
OutlineRightVerticalEdge | (0018,1632): Outline Right Vertical Edge
OutlineShapeType | (0018,1630): Outline Shape Type
OutlineUpperHorizontalEdge | (0018,1633): Outline Upper Horizontal Edge
OutputDestinationSequence | (0040,4070): Output Destination Sequence
OutputInformationSequence | (0040,4033): Output Information Sequence
OutputPower | (0018,5000): Output Power
OverallTemplateSpatialTolerance | (0068,62A5): Overall Template Spatial Tolerance
OverlayActivationLayer | (60xx,1001): Overlay Activation Layer
OverlayBackgroundDensity | (2040,0082): Overlay Background Density
OverlayBitPosition | (60xx,0102): Overlay Bit Position
OverlayBitsAllocated | (60xx,0100): Overlay Bits Allocated
OverlayBitsForCodeWord | (60xx,0804): Overlay Bits For Code Word
OverlayBitsGrouped | (60xx,0069): Overlay Bits Grouped
OverlayCodeLabel | (60xx,0800): Overlay Code Label
OverlayCodeTableLocation | (60xx,0803): Overlay Code Table Location
OverlayColumns | (60xx,0011): Overlay Columns
OverlayComments | (60xx,4000): Overlay Comments(Retired)
OverlayCompressionCode | (60xx,0060): Overlay Compression Code(Retired)
OverlayCompressionDescription | (60xx,0063): Overlay Compression Description
OverlayCompressionLabel | (60xx,0062): Overlay Compression Label
OverlayCompressionOriginator | (60xx,0061): Overlay Compression Originator
OverlayCompressionStepPointers | (60xx,0066): Overlay Compression Step Pointers
OverlayData | (60xx,3000): Overlay Data
OverlayDate | (0008,0024): Overlay Date
OverlayDescription | (60xx,0022): Overlay Description
OverlayDescriptorBlue | (60xx,1103): Overlay Descriptor - Blue
OverlayDescriptorGray | (60xx,1100): Overlay Descriptor - Gray
OverlayDescriptorGreen | (60xx,1102): Overlay Descriptor - Green
OverlayDescriptorRed | (60xx,1101): Overlay Descriptor - Red
OverlayForegroundDensity | (2040,0080): Overlay Foreground Density
OverlayFormat | (60xx,0110): Overlay Format(Retired)
OverlayLabel | (60xx,1500): Overlay Label
OverlayLocation | (60xx,0200): Overlay Location(Retired)
OverlayMagnificationType | (2040,0060): Overlay Magnification Type
OverlayMode | (2040,0090): Overlay Mode
OverlayNumber | (0020,0022): Overlay Number
OverlayNumberOfTables | (60xx,0802): Overlay Number of Tables
OverlayOrigin | (60xx,0050): Overlay Origin
OverlayOrImageMagnification | (2040,0072): Overlay or Image Magnification
OverlayPixelDataSequence | (2040,0020): Overlay Pixel Data Sequence
OverlayPlaneOrigin | (60xx,0052): Overlay Plane Origin
OverlayPlanes | (60xx,0012): Overlay Planes
OverlayRepeatInterval | (60xx,0068): Overlay Repeat Interval
OverlayRows | (60xx,0010): Overlay Rows
Overlays | (0000,51B0): Overlays(Retired)
OverlaysBlue | (60xx,1203): Overlays - Blue
OverlaysGray | (60xx,1200): Overlays - Gray
OverlaysGreen | (60xx,1202): Overlays - Green
OverlaySmoothingType | (2040,0070): Overlay Smoothing Type
OverlaysRed | (60xx,1201): Overlays - Red
OverlaySubtype | (60xx,0045): Overlay Subtype
OverlayTime | (0008,0034): Overlay Time
OverlayType | (60xx,0040): Overlay Type
OverriddenAttributesSequence | (0074,104A): Overridden Attributes Sequence
OverrideDateTime | (300A,0760): Override DateTime
OverrideParameterPointer | (3008,0062): Override Parameter Pointer
OverrideReason | (3008,0066): Override Reason
OverrideSequence | (3008,0060): Override Sequence
OversamplingPhase | (0018,9029): Oversampling Phase
OwnerID | (2100,0160): Owner ID
PaddleDescription | (0018,11A4): Paddle Description
PageNumberVector | (0018,2001): Page Number Vector
PagePositionID | (0000,5120): Page Position ID(Retired)
PaletteColorLookupTableSequence | (0048,0120): Palette Color Lookup Table Sequence
PaletteColorLookupTableUID | (0028,1199): Palette Color Lookup Table UID
ParallelAcquisition | (0018,9077): Parallel Acquisition
ParallelAcquisitionTechnique | (0018,9078): Parallel Acquisition Technique
ParallelReductionFactorInPlane | (0018,9069): Parallel Reduction Factor In-plane
ParallelReductionFactorInPlaneRetired | (0018,9096): Parallel Reduction Factor In-plane (Retired)
ParallelReductionFactorOutOfPlane | (0018,9155): Parallel Reduction Factor out-of-plane
ParallelReductionFactorSecondInPlane | (0018,9168): Parallel Reduction Factor Second In-plane
ParallelRTBeamDelimiterBoundaries | (300A,0649): Parallel RT Beam Delimiter Boundaries
ParallelRTBeamDelimiterDeviceOrientationLabelCodeSequence | (300A,0644): Parallel RT Beam Delimiter Device Orientation Label Code Sequence
ParallelRTBeamDelimiterDeviceSequence | (300A,0647): Parallel RT Beam Delimiter Device Sequence
ParallelRTBeamDelimiterLeafMountingSide | (300A,064F): Parallel RT Beam Delimiter Leaf Mounting Side
ParallelRTBeamDelimiterOpeningMode | (300A,064E): Parallel RT Beam Delimiter Opening Mode
ParallelRTBeamDelimiterPositions | (300A,064A): Parallel RT Beam Delimiter Positions
ParameterItemIndex | (3008,0063): Parameter Item Index
ParameterPointer | (3008,0065): Parameter Pointer
ParameterSequencePointer | (3008,0061): Parameter Sequence Pointer
ParametersSpecificationSequence | (0018,9913): Parameters Specification Sequence
ParameterValueNumber | (3008,0067): Parameter Value Number
ParametricMapFrameTypeSequence | (0040,9092): Parametric Map Frame Type Sequence
PartialDataDisplayHandling | (0072,0208): Partial Data Display Handling
PartialFourier | (0018,9081): Partial Fourier
PartialFourierDirection | (0018,9036): Partial Fourier Direction
PartialView | (0028,1350): Partial View
PartialViewCodeSequence | (0028,1352): Partial View Code Sequence
PartialViewDescription | (0028,1351): Partial View Description
ParticipantSequence | (0040,A07A): Participant Sequence
ParticipationDateTime | (0040,A082): Participation DateTime
ParticipationType | (0040,A080): Participation Type
PatientAdditionalPosition | (300A,0184): Patient Additional Position
PatientAddress | (0010,1040): Patient's Address
PatientAge | (0010,1010): Patient's Age
PatientAlternativeCalendar | (0010,0035): Patient's Alternative Calendar
PatientBirthDate | (0010,0030): Patient's Birth Date
PatientBirthDateInAlternativeCalendar | (0010,0033): Patient's Birth Date in Alternative Calendar
PatientBirthName | (0010,1005): Patient's Birth Name
PatientBirthTime | (0010,0032): Patient's Birth Time
PatientBodyMassIndex | (0010,1022): Patient's Body Mass Index
PatientBreedCodeSequence | (0010,2293): Patient Breed Code Sequence
PatientBreedDescription | (0010,2292): Patient Breed Description
PatientClinicalTrialParticipationSequence | (0038,0502): Patient Clinical Trial Participation Sequence
PatientComments | (0010,4000): Patient Comments
PatientDeathDateInAlternativeCalendar | (0010,0034): Patient's Death Date in Alternative Calendar
PatientEquipmentRelationshipCodeSequence | (3010,0030): Patient Equipment Relationship Code Sequence
PatientEyeMovementCommandCodeSequence | (0022,0006): Patient Eye Movement Command Code Sequence
PatientEyeMovementCommanded | (0022,0005): Patient Eye Movement Commanded
PatientFrameOfReferenceSource | (0020,930C): Patient Frame of Reference Source
PatientGantryRelationshipCodeSequence | (0054,0414): Patient Gantry Relationship Code Sequence
PatientID | (0010,0020): Patient ID
PatientIdentityRemoved | (0012,0062): Patient Identity Removed
PatientInstitutionResidence | (0038,0400): Patient's Institution Residence
PatientInsurancePlanCodeSequence | (0010,0050): Patient's Insurance Plan Code Sequence
PatientLocationCoordinatesCodeSequence | (3006,00CA): Patient Location Coordinates Code Sequence
PatientLocationCoordinatesSequence | (3006,00C9): Patient Location Coordinates Sequence
PatientMotherBirthName | (0010,1060): Patient's Mother's Birth Name
PatientMotionCorrected | (0018,9763): Patient Motion Corrected
PatientName | (0010,0010): Patient's Name
PatientNotProperlyFixatedQuantity | (0024,0036): Patient Not Properly Fixated Quantity
PatientOrientation | (0020,0020): Patient Orientation
PatientOrientationCodeSequence | (0054,0410): Patient Orientation Code Sequence
PatientOrientationInFrameSequence | (0020,9450): Patient Orientation in Frame Sequence
PatientOrientationModifierCodeSequence | (0054,0412): Patient Orientation Modifier Code Sequence
PatientPhysiologicalStateCodeSequence | (0018,9772): Patient Physiological State Code Sequence
PatientPhysiologicalStateSequence | (0018,9771): Patient Physiological State Sequence
PatientPosition | (0018,5100): Patient Position
PatientPositioningInstructionSequence | (0018,991B): Patient Positioning Instruction Sequence
PatientPrimaryLanguageCodeSequence | (0010,0101): Patient's Primary Language Code Sequence
PatientPrimaryLanguageModifierCodeSequence | (0010,0102): Patient's Primary Language Modifier Code Sequence
PatientReliabilityIndicator | (0024,0069): Patient Reliability Indicator
PatientReligiousPreference | (0010,21F0): Patient's Religious Preference
PatientSetupLabel | (300A,0183): Patient Setup Label
PatientSetupNumber | (300A,0182): Patient Setup Number
PatientSetupPhotoDescription | (300A,0794): Patient Setup Photo Description
PatientSetupSequence | (300A,0180): Patient Setup Sequence
PatientSetupUID | (300A,0650): Patient Setup UID
PatientSex | (0010,0040): Patient's Sex
PatientSexNeutered | (0010,2203): Patient's Sex Neutered
PatientSize | (0010,1020): Patient's Size
PatientSizeCodeSequence | (0010,1021): Patient's Size Code Sequence
PatientSpeciesCodeSequence | (0010,2202): Patient Species Code Sequence
PatientSpeciesDescription | (0010,2201): Patient Species Description
PatientSpecificationSequence | (0018,9911): Patient Specification Sequence
PatientState | (0038,0500): Patient State
PatientSupportAccessoryCode | (300A,0354): Patient Support Accessory Code
PatientSupportAdjustedAngle | (0074,102A): Patient Support Adjusted Angle
PatientSupportAngle | (300A,0122): Patient Support Angle
PatientSupportAngleTolerance | (300A,004C): Patient Support Angle Tolerance
PatientSupportDevicesSequence | (300A,0686): Patient Support Devices Sequence
PatientSupportDisplacementSequence | (300A,079C): Patient Support Displacement Sequence
PatientSupportID | (300A,0352): Patient Support ID
PatientSupportPositionDeviceParameterSequence | (300A,065D): Patient Support Position Device Parameter Sequence
PatientSupportPositionDeviceToleranceSequence | (300A,0660): Patient Support Position Device Tolerance Sequence
PatientSupportPositionParameterOrderIndex | (300A,065F): Patient Support Position Parameter Order Index
PatientSupportPositionParameterSequence | (300A,065B): Patient Support Position Parameter Sequence
PatientSupportPositionSequence | (3006,00CB): Patient Support Position Sequence
PatientSupportPositionSpecificationMethod | (300A,065C): Patient Support Position Specification Method
PatientSupportPositionToleranceOrderIndex | (300A,0661): Patient Support Position Tolerance Order Index
PatientSupportPositionToleranceSequence | (300A,062D): Patient Support Position Tolerance Sequence
PatientSupportRotationDirection | (300A,0123): Patient Support Rotation Direction
PatientSupportType | (300A,0350): Patient Support Type
PatientTelecomInformation | (0010,2155): Patient's Telecom Information
PatientTelephoneNumbers | (0010,2154): Patient's Telephone Numbers
PatientTransportArrangements | (0040,1004): Patient Transport Arrangements
PatientTreatmentOrientationSequence | (3010,0032): Patient Treatment Orientation Sequence
PatientTreatmentPreparationDeviceSequence | (300A,078F): Patient Treatment Preparation Device Sequence
PatientTreatmentPreparationMethodCodeSequence | (300A,078D): Patient Treatment Preparation Method Code Sequence
PatientTreatmentPreparationMethodDescription | (300A,0792): Patient Treatment Preparation Method Description
PatientTreatmentPreparationProcedureCodeSequence | (300A,0791): Patient Treatment Preparation Procedure Code Sequence
PatientTreatmentPreparationProcedureIndex | (300A,0795): Patient Treatment Preparation Procedure Index
PatientTreatmentPreparationProcedureParameterDescription | (300A,078E): Patient Treatment Preparation Procedure Parameter Description
PatientTreatmentPreparationProcedureParameterSequence | (300A,0793): Patient Treatment Preparation Procedure Parameter Sequence
PatientTreatmentPreparationProcedureSequence | (300A,0790): Patient Treatment Preparation Procedure Sequence
PatientWeight | (0010,1030): Patient's Weight
PatternOffColorCIELabValue | (0070,0252): Pattern Off Color CIELab Value
PatternOffOpacity | (0070,0285): Pattern Off Opacity
PatternOnColorCIELabValue | (0070,0251): Pattern On Color CIELab Value
PatternOnOpacity | (0070,0284): Pattern On Opacity
PauseBetweenFrames | (0054,0038): Pause Between Frames
PercentPhaseFieldOfView | (0018,0094): Percent Phase Field of View
PercentSampling | (0018,0093): Percent Sampling
PerformedLocation | (0040,0243): Performed Location
PerformedProcedureCodeSequence | (0040,A372): Performed Procedure Code Sequence
PerformedProcedureStepDescription | (0040,0254): Performed Procedure Step Description
PerformedProcedureStepDiscontinuationReasonCodeSequence | (0040,0281): Performed Procedure Step Discontinuation Reason Code Sequence
PerformedProcedureStepEndDate | (0040,0250): Performed Procedure Step End Date
PerformedProcedureStepEndDateTime | (0040,4051): Performed Procedure Step End DateTime
PerformedProcedureStepEndTime | (0040,0251): Performed Procedure Step End Time
PerformedProcedureStepID | (0040,0253): Performed Procedure Step ID
PerformedProcedureStepStartDate | (0040,0244): Performed Procedure Step Start Date
PerformedProcedureStepStartDateTime | (0040,4050): Performed Procedure Step Start DateTime
PerformedProcedureStepStartTime | (0040,0245): Performed Procedure Step Start Time
PerformedProcedureStepStatus | (0040,0252): Performed Procedure Step Status
PerformedProcedureTypeDescription | (0040,0255): Performed Procedure Type Description
PerformedProcessingApplicationsCodeSequence | (0040,4007): Performed Processing Applications Code Sequence
PerformedProcessingParametersSequence | (0074,1212): Performed Processing Parameters Sequence
PerformedProtocolCodeSequence | (0040,0260): Performed Protocol Code Sequence
PerformedProtocolType | (0040,0261): Performed Protocol Type
PerformedSeriesSequence | (0040,0340): Performed Series Sequence
PerformedStationAETitle | (0040,0241): Performed Station AE Title
PerformedStationClassCodeSequence | (0040,4029): Performed Station Class Code Sequence
PerformedStationGeographicLocationCodeSequence | (0040,4030): Performed Station Geographic Location Code Sequence
PerformedStationName | (0040,0242): Performed Station Name
PerformedStationNameCodeSequence | (0040,4028): Performed Station Name Code Sequence
PerformedWorkitemCodeSequence | (0040,4019): Performed Workitem Code Sequence
PerformingPhysicianIdentificationSequence | (0008,1052): Performing Physician Identification Sequence
PerformingPhysicianName | (0008,1050): Performing Physician's Name
PerFrameFunctionalGroupsSequence | (5200,9230): Per-frame Functional Groups Sequence
PerimeterTable | (0028,0070): Perimeter Table
PerimeterValue | (0028,0071): Perimeter Value
PerProjectionAcquisitionSequence | (0018,9538): Per Projection Acquisition Sequence
PersonAddress | (0040,1102): Person's Address
PersonIdentificationCodeSequence | (0040,1101): Person Identification Code Sequence
PersonName | (0040,A123): Person Name
PersonTelecomInformation | (0040,1104): Person's Telecom Information
PersonTelephoneNumbers | (0040,1103): Person's Telephone Numbers
PertinentDocumentsSequence | (0038,0100): Pertinent Documents Sequence
PertinentOtherEvidenceSequence | (0040,A385): Pertinent Other Evidence Sequence
PertinentResourcesSequence | (0038,0101): Pertinent Resources Sequence
PertinentSOPClassesInSeries | (3010,0053): Pertinent SOP Classes in Series
PertinentSOPClassesInStudy | (3010,0052): Pertinent SOP Classes in Study
PETDetectorMotionDetailsSequence | (0018,9733): PET Detector Motion Details Sequence
PETFrameAcquisitionSequence | (0018,9732): PET Frame Acquisition Sequence
PETFrameCorrectionFactorsSequence | (0018,9736): PET Frame Correction Factors Sequence
PETFrameTypeSequence | (0018,9751): PET Frame Type Sequence
PETPositionSequence | (0018,9735): PET Position Sequence
PETReconstructionSequence | (0018,9749): PET Reconstruction Sequence
PETTableDynamicsSequence | (0018,9734): PET Table Dynamics Sequence
PhantomType | (4010,1046): Phantom Type
PhaseContrast | (0018,9014): Phase Contrast
PhaseDelay | (0054,0036): Phase Delay
PhaseDescription | (0054,0039): Phase Description
PhaseInformationSequence | (0054,0032): Phase Information Sequence
PhaseNumber | (0020,0015): Phase Number
PhaseVector | (0054,0030): Phase Vector
PhosphorType | (0018,1261): Phosphor Type
PhotographicExposureIndex | (0016,0038): Photographic Exposure Index
PhotographicSensitivity | (0016,0018): Photographic Sensitivity
PhotometricInterpretation | (0028,0004): Photometric Interpretation
PhotonEnergy | (0018,9383): Photon Energy
PhototimerSetting | (0018,7065): Phototimer Setting
PhysicalDeltaX | (0018,602C): Physical Delta X
PhysicalDeltaY | (0018,602E): Physical Delta Y
PhysicalDetectorSize | (0018,9429): Physical Detector Size
PhysicalUnitsXDirection | (0018,6024): Physical Units X Direction
PhysicalUnitsYDirection | (0018,6026): Physical Units Y Direction
PhysicianApprovingInterpretation | (4008,0114): Physician Approving Interpretation
PhysiciansOfRecord | (0008,1048): Physician(s) of Record
PhysiciansOfRecordIdentificationSequence | (0008,1049): Physician(s) of Record Identification Sequence
PhysiciansReadingStudyIdentificationSequence | (0008,1062): Physician(s) Reading Study Identification Sequence
PixelAspectRatio | (0028,0034): Pixel Aspect Ratio
PixelBandwidth | (0018,0095): Pixel Bandwidth
PixelComponentDataType | (0018,604E): Pixel Component Data Type
PixelComponentMask | (0018,6046): Pixel Component Mask
PixelComponentOrganization | (0018,6044): Pixel Component Organization
PixelComponentPhysicalUnits | (0018,604C): Pixel Component Physical Units
PixelComponentRangeStart | (0018,6048): Pixel Component Range Start
PixelComponentRangeStop | (0018,604A): Pixel Component Range Stop
PixelCoordinatesSetTrial | (0040,A29A): Pixel Coordinates Set (Trial)
PixelData | (7FE0,0010): Pixel Data
PixelDataAreaOriginRelativeToFOV | (0018,7036): Pixel Data Area Origin Relative To FOV
PixelDataAreaRotationAngleRelativeToFOV | (0018,7038): Pixel Data Area Rotation Angle Relative To FOV
PixelDataProviderURL | (0028,7FE0): Pixel Data Provider URL
PixelIntensityRelationship | (0028,1040): Pixel Intensity Relationship
PixelIntensityRelationshipLUTSequence | (0028,9422): Pixel Intensity Relationship LUT Sequence
PixelIntensityRelationshipSign | (0028,1041): Pixel Intensity Relationship Sign
PixelMeasuresSequence | (0028,9110): Pixel Measures Sequence
PixelOriginInterpretation | (0048,0301): Pixel Origin Interpretation
PixelPaddingRangeLimit | (0028,0121): Pixel Padding Range Limit
PixelPaddingValue | (0028,0120): Pixel Padding Value
PixelPresentation | (0008,9205): Pixel Presentation
PixelRepresentation | (0028,0103): Pixel Representation
PixelShiftFrameRange | (0028,9506): Pixel Shift Frame Range
PixelShiftSequence | (0028,9501): Pixel Shift Sequence
PixelSpacing | (0028,0030): Pixel Spacing
PixelSpacingCalibrationDescription | (0028,0A04): Pixel Spacing Calibration Description
PixelSpacingCalibrationType | (0028,0A02): Pixel Spacing Calibration Type
PixelSpacingSequence | (0040,08D8): Pixel Spacing Sequence
PixelValueMappingCodeSequence | (0040,9098): Pixel Value Mapping Code Sequence
PixelValueMappingExplanation | (0022,1454): Pixel Value Mapping Explanation
PixelValueMappingToCodedConceptSequence | (0022,1450): Pixel Value Mapping to Coded Concept Sequence
PixelValueTransformationSequence | (0028,9145): Pixel Value Transformation Sequence
PlacerOrderNumberImagingServiceRequest | (0040,2016): Placer Order Number / Imaging Service Request
PlacerOrderNumberImagingServiceRequestRetired | (0040,2006): Placer Order Number / Imaging Service Request (Retired)
PlacerOrderNumberProcedure | (0040,1006): Placer Order Number / Procedure
PlanarConfiguration | (0028,0006): Planar Configuration
Plane | (0070,1305): Plane
PlaneIdentification | (0018,9457): Plane Identification
PlaneNormal | (0070,1306): Plane Normal
PlaneOrientationSequence | (0020,9116): Plane Orientation Sequence
PlaneOrientationVolumeSequence | (0020,930F): Plane Orientation (Volume) Sequence
PlanePositionSequence | (0020,9113): Plane Position Sequence
PlanePositionSlideSequence | (0048,021A): Plane Position (Slide) Sequence
PlanePositionVolumeSequence | (0020,930E): Plane Position (Volume) Sequence
Planes | (0028,0012): Planes
PlanesInAcquisition | (0018,9410): Planes in Acquisition
PlanIntent | (300A,000A): Plan Intent
PlannedVerificationImageSequence | (300A,00CA): Planned Verification Image Sequence
PlanningInputInformationSequence | (3010,0076): Planning Input Information Sequence
PlanningLandmarkDescription | (0068,6540): Planning Landmark Description
PlanningLandmarkID | (0068,6530): Planning Landmark ID
PlanningLandmarkIdentificationCodeSequence | (0068,6545): Planning Landmark Identification Code Sequence
PlanningLandmarkLineSequence | (0068,6510): Planning Landmark Line Sequence
PlanningLandmarkPlaneSequence | (0068,6520): Planning Landmark Plane Sequence
PlanningLandmarkPointSequence | (0068,6500): Planning Landmark Point Sequence
PlanOverviewIndex | (300C,0117): Plan Overview Index
PlanOverviewSequence | (300C,0116): Plan Overview Sequence
PlateID | (0018,1004): Plate ID
PlateType | (0018,1260): Plate Type
PointCoordinatesData | (0066,0016): Point Coordinates Data
PointPositionAccuracy | (0066,0017): Point Position Accuracy
PointsBoundingBoxCoordinates | (0066,001A): Points Bounding Box Coordinates
Polarity | (2020,0020): Polarity
PositionerIsocenterDetectorRotationAngle | (0018,9465): Positioner Isocenter Detector Rotation Angle
PositionerIsocenterPrimaryAngle | (0018,9463): Positioner Isocenter Primary Angle
PositionerIsocenterSecondaryAngle | (0018,9464): Positioner Isocenter Secondary Angle
PositionerMotion | (0018,1500): Positioner Motion
PositionerPositionSequence | (0018,9405): Positioner Position Sequence
PositionerPrimaryAngle | (0018,1510): Positioner Primary Angle
PositionerPrimaryAngleDirection | (0018,9559): Positioner Primary Angle Direction
PositionerPrimaryAngleIncrement | (0018,1520): Positioner Primary Angle Increment
PositionerSecondaryAngle | (0018,1511): Positioner Secondary Angle
PositionerSecondaryAngleIncrement | (0018,1521): Positioner Secondary Angle Increment
PositionerType | (0018,1508): Positioner Type
PositioningLandmarkSequence | (0018,991D): Positioning Landmark Sequence
PositioningMethodCodeSequence | (0018,991C): Positioning Method Code Sequence
PositionMeasuringDeviceUsed | (0018,980C): Position Measuring Device Used
PositionOfIsocenterProjection | (0018,9430): Position of Isocenter Projection
PositionReferenceIndicator | (0020,1040): Position Reference Indicator
PositiveCatchTrialsQuantity | (0024,0056): Positive Catch Trials Quantity
PostDeformationMatrixRegistrationSequence | (0064,0010): Post Deformation Matrix Registration Sequence
PostprocessingFunction | (0018,5021): Postprocessing Function
PotentialDiagnosticTasks | (0018,990A): Potential Diagnostic Tasks
PotentialReasonsForProcedure | (0018,9908): Potential Reasons for Procedure
PotentialReasonsForProcedureCodeSequence | (0018,9909): Potential Reasons for Procedure Code Sequence
PotentialRequestedProcedureCodeSequence | (0018,9907): Potential Requested Procedure Code Sequence
PotentialScheduledProtocolCodeSequence | (0018,9906): Potential Scheduled Protocol Code Sequence
PotentialThreatObjectID | (4010,1010): Potential Threat Object ID
PowerlineFrequency | (003A,0311): Powerline Frequency
PRCSToRCSOrientation | (4010,107E): PRCS to RCS Orientation
PreAmplifierEquipmentSequence | (0014,400E): Pre-Amplifier Equipment Sequence
PreAmplifierNotes | (0014,400F): Pre-Amplifier Notes
PreAmplifierSettingsSequence | (0014,4040): Pre-Amplifier Settings Sequence
PredecessorDocumentsSequence | (0040,A360): Predecessor Documents Sequence
PredecessorProtocolSequence | (0018,990E): Predecessor Protocol Sequence
PredecessorStructureSetSequence | (3006,0018): Predecessor Structure Set Sequence
PreDeformationMatrixRegistrationSequence | (0064,000F): Pre Deformation Matrix Registration Sequence
PredictedRefractiveError | (0022,1054): Predicted Refractive Error
PredictedToricErrorSequence | (0022,1048): Predicted Toric Error Sequence
PredictorColumns | (0028,0081): Predictor Columns
PredictorConstants | (0028,0082): Predictor Constants
PredictorRows | (0028,0080): Predictor Rows
PreferredPlaybackSequencing | (0018,1244): Preferred Playback Sequencing
PregnancyStatus | (0010,21C0): Pregnancy Status
PreliminaryFlag | (0040,A496): Preliminary Flag
PreMedication | (0040,0012): Pre-Medication
PrescriptionDescription | (300A,000E): Prescription Description
PrescriptionNotes | (3010,007B): Prescription Notes
PrescriptionNotesSequence | (3010,0081): Prescription Notes Sequence
PrescriptionOverviewSequence | (300C,0114): Prescription Overview Sequence
PreSelectedForImplantation | (0022,1049): Pre-Selected for Implantation
PresentationAnimationStyle | (0070,1A01): Presentation Animation Style
PresentationCreationDate | (0070,0082): Presentation Creation Date
PresentationCreationTime | (0070,0083): Presentation Creation Time
PresentationDisplayCollectionUID | (0070,1101): Presentation Display Collection UID
PresentationGroupNumber | (003A,0241): Presentation Group Number
PresentationInputType | (0070,1202): Presentation Input Type
PresentationIntentType | (0008,0068): Presentation Intent Type
PresentationLUTContentSequence | (2130,0080): Presentation LUT Content Sequence
PresentationLUTFlag | (2000,0069): Presentation LUT Flag
PresentationLUTSequence | (2050,0010): Presentation LUT Sequence
PresentationLUTShape | (2050,0020): Presentation LUT Shape
PresentationPixelAspectRatio | (0070,0102): Presentation Pixel Aspect Ratio
PresentationPixelMagnificationRatio | (0070,0103): Presentation Pixel Magnification Ratio
PresentationPixelSpacing | (0070,0101): Presentation Pixel Spacing
PresentationSequenceCollectionUID | (0070,1102): Presentation Sequence Collection UID
PresentationSequencePositionIndex | (0070,1103): Presentation Sequence Position Index
PresentationSizeMode | (0070,0100): Presentation Size Mode
PresentationStateClassificationComponentSequence | (0070,1801): Presentation State Classification Component Sequence
PresentationStateCompositorComponentSequence | (0070,1805): Presentation State Compositor Component Sequence
PresentedVisualStimuliDataFlag | (0024,0037): Presented Visual Stimuli Data Flag
PreserveCompositeInstancesAfterMediaCreation | (2200,000A): Preserve Composite Instances After Media Creation
Pressure | (0016,0032): Pressure
PrimaryAnatomicStructureModifierSequence | (0008,2230): Primary Anatomic Structure Modifier Sequence
PrimaryAnatomicStructureSequence | (0008,2228): Primary Anatomic Structure Sequence
PrimaryChromaticities | (0016,0002): Primary Chromaticities
PrimaryDoseValueIndicator | (300A,061B): Primary Dose Value Indicator
PrimaryDosimeterUnit | (300A,00B3): Primary Dosimeter Unit
PrimaryFluenceModeSequence | (3002,0050): Primary Fluence Mode Sequence
PrimaryPositionerIncrement | (0018,9514): Primary Positioner Increment
PrimaryPositionerIncrementSign | (0018,9518): Primary Positioner Increment Sign
PrimaryPositionerScanArc | (0018,9508): Primary Positioner Scan Arc
PrimaryPositionerScanStartAngle | (0018,9510): Primary Positioner Scan Start Angle
PrimaryPromptsCountsAccumulated | (0054,1310): Primary (Prompts) Counts Accumulated
PrimitivePointIndexList | (0066,0029): Primitive Point Index List
Print | (0000,51A0): Print(Retired)
PrinterCharacteristicsSequence | (2130,0015): Printer Characteristics Sequence
PrinterConfigurationSequence | (2000,001E): Printer Configuration Sequence
PrinterName | (2110,0030): Printer Name
PrinterPixelSpacing | (2010,0376): Printer Pixel Spacing
PrinterResolutionID | (2010,0052): Printer Resolution ID
PrinterStatus | (2110,0010): Printer Status
PrinterStatusInfo | (2110,0020): Printer Status Info
PrintingBitDepth | (2000,00A1): Printing Bit Depth
PrintJobDescriptionSequence | (2120,0050): Print Job Description Sequence
PrintJobID | (2100,0010): Print Job ID
PrintManagementCapabilitiesSequence | (2130,0010): Print Management Capabilities Sequence
PrintPriority | (2000,0020): Print Priority
PrintQueueID | (2110,0099): Print Queue ID
Priority | (0000,0700): Priority
PriorTreatmentDoseDescription | (3010,0061): Prior Treatment Dose Description
PriorTreatmentReferenceSequence | (3010,0062): Prior Treatment Reference Sequence
PrismSequence | (0046,0028): Prism Sequence
PrivateCreatorReference | (0008,0302): Private Creator Reference
PrivateDataElement | (0008,0308): Private Data Element
PrivateDataElementCharacteristicsSequence | (0008,0300): Private Data Element Characteristics Sequence
PrivateDataElementDefinitionSequence | (0008,0310): Private Data Element Definition Sequence
PrivateDataElementDescription | (0008,030E): Private Data Element Description
PrivateDataElementEncoding | (0008,030F): Private Data Element Encoding
PrivateDataElementKeyword | (0008,030D): Private Data Element Keyword
PrivateDataElementName | (0008,030C): Private Data Element Name
PrivateDataElementNumberOfItems | (0008,030B): Private Data Element Number of Items
PrivateDataElementValueMultiplicity | (0008,0309): Private Data Element Value Multiplicity
PrivateDataElementValueRepresentation | (0008,030A): Private Data Element Value Representation
PrivateGroupReference | (0008,0301): Private Group Reference
PrivateInformation | (0002,0102): Private Information
PrivateInformationCreatorUID | (0002,0100): Private Information Creator UID
PrivateRecordUID | (0004,1432): Private Record UID
ProbeCenterLocationX | (0014,4058): Probe Center Location X
ProbeCenterLocationZ | (0014,4059): Probe Center Location Z
ProbeDriveEquipmentSequence | (0014,4080): Probe Drive Equipment Sequence
ProbeDriveNotes | (0014,4082): Probe Drive Notes
ProbeDriveSettingsSequence | (0014,4087): Probe Drive Settings Sequence
ProbeInductance | (0014,4084): Probe Inductance
ProbeOrientationAngle | (0014,4089): Probe Orientation Angle
ProbeResistance | (0014,4085): Probe Resistance
ProcedureCodeSequence | (0008,1032): Procedure Code Sequence
ProcedureContextFlagTrial | (0040,A603): Procedure Context Flag (Trial)
ProcedureContextSequenceTrial | (0040,A340): Procedure Context Sequence (Trial)
ProcedureCreationDate | (0014,4076): Procedure Creation Date
ProcedureExpirationDate | (0014,4078): Procedure Expiration Date
ProcedureIdentifierCodeSequenceTrial | (0040,A085): Procedure Identifier Code Sequence (Trial)
ProcedureLastModifiedDate | (0014,407A): Procedure Last Modified Date
ProcedureStepCancellationDateTime | (0040,4052): Procedure Step Cancellation DateTime
ProcedureStepCommunicationsURISequence | (0074,1008): Procedure Step Communications URI Sequence
ProcedureStepDiscontinuationReasonCodeSequence | (0074,100E): Procedure Step Discontinuation Reason Code Sequence
ProcedureStepLabel | (0074,1204): Procedure Step Label
ProcedureStepProgress | (0074,1004): Procedure Step Progress
ProcedureStepProgressDescription | (0074,1006): Procedure Step Progress Description
ProcedureStepProgressInformationSequence | (0074,1002): Procedure Step Progress Information Sequence
ProcedureStepProgressParametersSequence | (0074,1007): Procedure Step Progress Parameters Sequence
ProcedureStepRelationshipType | (0074,1222): Procedure Step Relationship Type
ProcedureStepState | (0074,1000): Procedure Step State
ProcedureTypeCodeSequence | (0076,0020): Procedure Type Code Sequence
ProcedureVersion | (0014,4074): Procedure Version
ProcessingFunction | (0018,5020): Processing Function
ProductDescription | (0044,0009): Product Description
ProductExpirationDateTime | (0044,000B): Product Expiration DateTime
ProductLotIdentifier | (0044,000A): Product Lot Identifier
ProductName | (0044,0008): Product Name
ProductPackageIdentifier | (0044,0001): Product Package Identifier
ProductParameterSequence | (0044,0013): Product Parameter Sequence
ProductTypeCodeSequence | (0044,0007): Product Type Code Sequence
ProjectionEponymousNameCodeSequence | (0018,5104): Projection Eponymous Name Code Sequence
ProjectionPixelCalibrationSequence | (0018,9401): Projection Pixel Calibration Sequence
PropertyLabel | (0014,2032): Property Label
ProposedStudySequence | (2130,00A0): Proposed Study Sequence
ProtocolContextSequence | (0040,0440): Protocol Context Sequence
ProtocolDefinedPatientPosition | (0018,9947): Protocol Defined Patient Position
ProtocolDesignRationale | (0018,9910): Protocol Design Rationale
ProtocolElementCharacteristicsSummary | (0018,9923): Protocol Element Characteristics Summary
ProtocolElementName | (0018,9922): Protocol Element Name
ProtocolElementNumber | (0018,9921): Protocol Element Number
ProtocolElementPurpose | (0018,9924): Protocol Element Purpose
ProtocolName | (0018,1030): Protocol Name
ProtocolPlanningInformation | (0018,990F): Protocol Planning Information
PseudoColorPaletteInstanceReferenceSequence | (0072,0705): Pseudo-Color Palette Instance Reference Sequence
PseudoColorType | (0072,0704): Pseudo-Color Type
PTOLocationDescription | (4010,1078): PTO Location Description
PTORegionSequence | (4010,107B): PTO Region Sequence
PTORepresentationSequence | (4010,1037): PTO Representation Sequence
PulseNumber | (3008,0172): Pulse Number
PulseRepetitionFrequency | (0018,6032): Pulse Repetition Frequency
PulseRepetitionInterval | (300A,028C): Pulse Repetition Interval
PulserEquipmentSequence | (0014,4002): Pulser Equipment Sequence
PulserNotes | (0014,4006): Pulser Notes
PulserSettingsSequence | (0014,4020): Pulser Settings Sequence
PulserType | (0014,4004): Pulser Type
PulseSequenceName | (0018,9005): Pulse Sequence Name
PulseSpecificBrachyControlPointDeliveredSequence | (3008,0171): Pulse Specific Brachy Control Point Delivered Sequence
PulseWidth | (0014,4022): Pulse Width
PupilCentroidXCoordinate | (0046,0203): Pupil Centroid X-Coordinate
PupilCentroidYCoordinate | (0046,0204): Pupil Centroid Y-Coordinate
PupilDilated | (0022,000D): Pupil Dilated
PupilSize | (0046,0044): Pupil Size
PurposeOfReferenceCodeSequence | (0040,A170): Purpose of Reference Code Sequence
PVCRejection | (0018,1085): PVC Rejection
QAResultsSequence | (0028,700F): QA Results Sequence
QRMeasurementsSequence | (4010,1071): QR Measurements Sequence
QuadratureReceiveCoil | (0018,9044): Quadrature Receive Coil
QualityControlImage | (0028,0300): Quality Control Image
QualityControlSubject | (0010,0200): Quality Control Subject
QualityControlSubjectTypeCodeSequence | (0010,0201): Quality Control Subject Type Code Sequence
QualityThreshold | (0022,1630): Quality Threshold
QuantifiedDefect | (0024,0098): Quantified Defect
Quantity | (0040,0294): Quantity
QuantityDefinitionSequence | (0040,9220): Quantity Definition Sequence
QuantitySequence | (0040,0293): Quantity Sequence
QueryRetrieveLevel | (0008,0052): Query/Retrieve Level
QueryRetrieveView | (0008,0053): Query/Retrieve View
QueueStatus | (2120,0010): Queue Status
RadialPosition | (0018,1142): Radial Position
RadiationAtomicNumber | (300A,0304): Radiation Atomic Number
RadiationBeamBlockSlabThickness | (300A,066E): Radiation Beam Block Slab Thickness
RadiationBeamBlockThickness | (300A,066D): Radiation Beam Block Thickness
RadiationBeamCompensatorMillingToolDiameter | (300A,0669): Radiation Beam Compensator Milling Tool Diameter
RadiationBeamEffectiveWedgeAngle | (300A,0654): Radiation Beam Effective Wedge Angle
RadiationBeamWedgeAngle | (300A,0652): Radiation Beam Wedge Angle
RadiationBeamWedgeThinEdgeDistance | (300A,0653): Radiation Beam Wedge Thin Edge Distance
RadiationChargeState | (300A,0306): Radiation Charge State
RadiationDeviceConfigurationAndCommissioningKeySequence | (300A,065A): Radiation Device Configuration and Commissioning Key Sequence
RadiationDoseCentralAxisDisplacement | (300A,0624): Radiation Dose Central Axis Displacement
RadiationDoseIdentificationIndex | (300A,0603): Radiation Dose Identification Index
RadiationDoseIdentificationLabel | (300A,0619): Radiation Dose Identification Label
RadiationDoseIdentificationSequence | (300A,0618): Radiation Dose Identification Sequence
RadiationDoseInVivoMeasurementLabel | (300A,0623): Radiation Dose In-Vivo Measurement Label
RadiationDoseMeasurementPointCoordinates | (300A,0627): Radiation Dose Measurement Point Coordinates
RadiationDoseSequence | (300A,0617): Radiation Dose Sequence
RadiationDoseSourceToExternalContourDistance | (300A,0628): Radiation Dose Source to External Contour Distance
RadiationDoseSourceToSkinDistance | (300A,0626): Radiation Dose Source to Skin Distance
RadiationDoseValue | (300A,0625): Radiation Dose Value
RadiationDoseValuesParametersSequence | (300A,061F): Radiation Dose Values Parameters Sequence
RadiationDosimeterUnitSequence | (300A,0658): Radiation Dosimeter Unit Sequence
RadiationFluenceModifierCodeSequence | (300A,0683): Radiation Fluence Modifier Code Sequence
RadiationGenerationModeDescription | (300A,067D): Radiation GenerationMode Description
RadiationGenerationModeIndex | (300A,0601): Radiation Generation Mode Index
RadiationGenerationModeLabel | (300A,067C): Radiation GenerationMode Label
RadiationGenerationModeMachineCodeSequence | (300A,067E): Radiation GenerationMode Machine Code Sequence
RadiationGenerationModeSequence | (300A,067B): Radiation GenerationMode Sequence
RadiationMachineName | (3002,0020): Radiation Machine Name
RadiationMachineSAD | (3002,0022): Radiation Machine SAD
RadiationMachineSSD | (3002,0024): Radiation Machine SSD
RadiationMassNumber | (300A,0302): Radiation Mass Number
RadiationMode | (0018,115A): Radiation Mode
RadiationOrderIndex | (300A,0786): Radiation Order Index
RadiationSetting | (0018,1155): Radiation Setting
RadiationSourceAxisDistance | (300A,0640): Radiation Source-Axis Distance
RadiationSourceCoordinateSystemPitchAngle | (3010,0096): Radiation Source Coordinate System Pitch Angle
RadiationSourceCoordinateSystemRollAngle | (3010,0095): Radiation Source Coordinate SystemRoll Angle
RadiationSourceCoordinateSystemYawAngle | (3010,0094): Radiation Source Coordinate SystemYaw Angle
RadiationType | (300A,00C6): Radiation Type
RadiationTypeCodeSequence | (300A,067F): Radiation Type Code Sequence
RadiobiologicalDoseEffectFlag | (3010,0002): Radiobiological Dose Effect Flag
RadiobiologicalDoseEffectSequence | (3010,0001): Radiobiological Dose Effect Sequence
Radionuclide | (0018,0030): Radionuclide
RadionuclideCodeSequence | (0054,0300): Radionuclide Code Sequence
RadionuclideHalfLife | (0018,1075): Radionuclide Half Life
RadionuclidePositronFraction | (0018,1076): Radionuclide Positron Fraction
RadionuclideTotalDose | (0018,1074): Radionuclide Total Dose
Radiopharmaceutical | (0018,0031): Radiopharmaceutical
RadiopharmaceuticalAdministrationEventUID | (0008,3012): Radiopharmaceutical Administration Event UID
RadiopharmaceuticalAgentNumber | (0018,9729): Radiopharmaceutical Agent Number
RadiopharmaceuticalCodeSequence | (0054,0304): Radiopharmaceutical Code Sequence
RadiopharmaceuticalInformationSequence | (0054,0016): Radiopharmaceutical Information Sequence
RadiopharmaceuticalRoute | (0018,1070): Radiopharmaceutical Route
RadiopharmaceuticalSpecificActivity | (0018,1077): Radiopharmaceutical Specific Activity
RadiopharmaceuticalStartDateTime | (0018,1078): Radiopharmaceutical Start DateTime
RadiopharmaceuticalStartTime | (0018,1072): Radiopharmaceutical Start Time
RadiopharmaceuticalStopDateTime | (0018,1079): Radiopharmaceutical Stop DateTime
RadiopharmaceuticalStopTime | (0018,1073): Radiopharmaceutical Stop Time
RadiopharmaceuticalUsageSequence | (0018,9737): Radiopharmaceutical Usage Sequence
RadiopharmaceuticalVolume | (0018,1071): Radiopharmaceutical Volume
RadiotherapyTreatmentType | (3010,0046): Radiotherapy Treatment Type
RadiusAlongWedge | (0014,511F): Radius Along the Wedge
RadiusOfCircularCollimator | (0018,1712): Radius of Circular Collimator
RadiusOfCircularExposureControlSensingRegion | (0018,9441): Radius of Circular Exposure Control Sensing Region
RadiusOfCircularShutter | (0018,1612): Radius of Circular Shutter
RadiusOfCurvature | (0046,0075): Radius of Curvature
RandomsCorrected | (0018,9765): Randoms Corrected
RandomsCorrectionMethod | (0054,1100): Randoms Correction Method
RangeModulatorDescription | (300A,034A): Range Modulator Description
RangeModulatorGatingStartValue | (300A,0382): Range Modulator Gating Start Value
RangeModulatorGatingStartWaterEquivalentThickness | (300A,0386): Range Modulator Gating Start Water Equivalent Thickness
RangeModulatorGatingStopValue | (300A,0384): Range Modulator Gating Stop Value
RangeModulatorGatingStopWaterEquivalentThickness | (300A,0388): Range Modulator Gating Stop Water Equivalent Thickness
RangeModulatorID | (300A,0346): Range Modulator ID
RangeModulatorNumber | (300A,0344): Range Modulator Number
RangeModulatorSequence | (300A,0342): Range Modulator Sequence
RangeModulatorSettingsSequence | (300A,0380): Range Modulator Settings Sequence
RangeModulatorType | (300A,0348): Range Modulator Type
RangeOfFreedom | (0068,64A0): Range of Freedom
RangeShifterDescription | (300A,0322): Range Shifter Description
RangeShifterID | (300A,0318): Range Shifter ID
RangeShifterNumber | (300A,0316): Range Shifter Number
RangeShifterSequence | (300A,0314): Range Shifter Sequence
RangeShifterSetting | (300A,0362): Range Shifter Setting
RangeShifterSettingsSequence | (300A,0360): Range Shifter Settings Sequence
RangeShifterType | (300A,0320): Range Shifter Type
RangeShifterWaterEquivalentThickness | (300A,0366): Range Shifter Water Equivalent Thickness
RangingDepth | (0052,0009): Ranging Depth
RationalDenominatorValue | (0040,A163): Rational Denominator Value
RationalNumeratorValue | (0040,A162): Rational Numerator Value
RawDataHandling | (0040,4040): Raw Data Handling
RealTimeBulkDataFlowSequence | (0034,000A): Real-Time Bulk Data Flow Sequence
RealWorldValueFirstValueMapped | (0040,9216): Real World Value First Value Mapped
RealWorldValueIntercept | (0040,9224): Real World Value Intercept
RealWorldValueLastValueMapped | (0040,9211): Real World Value Last Value Mapped
RealWorldValueLUTData | (0040,9212): Real World Value LUT Data
RealWorldValueMappingSequence | (0040,9096): Real World Value Mapping Sequence
RealWorldValueSlope | (0040,9225): Real World Value Slope
ReasonForCancellation | (0074,1238): Reason for Cancellation
ReasonForChannelOmission | (0074,140A): Reason for Channel Omission
ReasonForChannelOmissionDescription | (0074,140B): Reason for Channel Omission Description
ReasonForOmission | (300C,0112): Reason for Omission
ReasonForOmissionCodeSequence | (300A,0788): Reason for Omission Code Sequence
ReasonForOmissionDescription | (300C,0113): Reason for Omission Description
ReasonForPerformedProcedureCodeSequence | (0040,1012): Reason For Performed Procedure Code Sequence
ReasonForRequestedProcedureCodeSequence | (0040,100A): Reason for Requested Procedure Code Sequence
ReasonForStudy | (0032,1030): Reason for Study
ReasonForSuperseding | (3010,005C): Reason for Superseding
ReasonForTheAttributeModification | (0400,0565): Reason for the Attribute Modification
ReasonForTheImagingServiceRequest | (0040,2001): Reason for the Imaging Service Request
ReasonForTheRequestedProcedure | (0040,1002): Reason for the Requested Procedure
ReasonForVisit | (0032,1066): Reason for Visit
ReasonForVisitCodeSequence | (0032,1067): Reason for Visit Code Sequence
ReceiveCoilManufacturerName | (0018,9041): Receive Coil Manufacturer Name
ReceiveCoilName | (0018,1250): Receive Coil Name
ReceiveCoilType | (0018,9043): Receive Coil Type
ReceiveProbeSequence | (0014,4086): Receive Probe Sequence
Receiver | (0000,0300): Receiver(Retired)
ReceiverEquipmentSequence | (0014,4008): Receiver Equipment Sequence
ReceiverNotes | (0014,400C): Receiver Notes
ReceiverSettingsSequence | (0014,4030): Receiver Settings Sequence
ReceiveTransducerSequence | (0014,4011): Receive Transducer Sequence
ReceiveTransducerSettingsSequence | (0014,4051): Receive Transducer Settings Sequence
ReceivingAE | (0074,1234): Receiving AE
ReceivingApplicationEntityTitle | (0002,0018): Receiving Application Entity Title
ReceivingPresentationAddress | (0002,0028): Receiving Presentation Address
RecognitionCode | (0008,0010): Recognition Code(Retired)
RecognizableVisualFeatures | (0028,0302): Recognizable Visual Features
RecommendedAbsentPixelCIELabValue | (0048,0015): Recommended Absent Pixel CIELab Value
RecommendedAnimationRate | (0070,1A03): Recommended Animation Rate
RecommendedDefaultValueSequence | (0082,0035): Recommended Default Value Sequence
RecommendedDisplayCIELabValue | (0062,000D): Recommended Display CIELab Value
RecommendedDisplayCIELabValueList | (0066,0103): Recommended Display CIELab Value List
RecommendedDisplayFrameRate | (0008,2144): Recommended Display Frame Rate
RecommendedDisplayFrameRateInFloat | (0008,9459): Recommended Display Frame Rate in Float
RecommendedDisplayGrayscaleValue | (0062,000C): Recommended Display Grayscale Value
RecommendedExposureIndex | (0016,001C): Recommended Exposure Index
RecommendedLineThickness | (0066,0038): Recommended Line Thickness
RecommendedPointRadius | (0066,0037): Recommended Point Radius
RecommendedPresentationOpacity | (0066,000C): Recommended Presentation Opacity
RecommendedPresentationType | (0066,000D): Recommended Presentation Type
RecommendedRotationPoint | (0068,6346): Recommended Rotation Point
RecommendedViewingMode | (0028,1090): Recommended Viewing Mode
ReconstructionAlgorithm | (0018,9315): Reconstruction Algorithm
ReconstructionAlgorithmSequence | (0018,993D): Reconstruction Algorithm Sequence
ReconstructionAngle | (0018,9319): Reconstruction Angle
ReconstructionDescription | (0018,9531): Reconstruction Description
ReconstructionDiameter | (0018,1100): Reconstruction Diameter
ReconstructionEndLocationSequence | (0018,993C): Reconstruction End Location Sequence
ReconstructionFieldOfView | (0018,9317): Reconstruction Field of View
ReconstructionIndex | (0020,9536): Reconstruction Index
ReconstructionMethod | (0054,1103): Reconstruction Method
ReconstructionPipelineType | (0018,11BE): Reconstruction Pipeline Type
ReconstructionPixelSpacing | (0018,9322): Reconstruction Pixel Spacing
ReconstructionProtocolElementSequence | (0018,9934): Reconstruction Protocol Element Sequence
ReconstructionProtocolElementSpecificationSequence | (0018,9933): Reconstruction Protocol Element Specification Sequence
ReconstructionStartLocationSequence | (0018,993B): Reconstruction Start Location Sequence
ReconstructionTargetCenterLocationSequence | (0018,993E): Reconstruction Target Center Location Sequence
ReconstructionTargetCenterPatient | (0018,9318): Reconstruction Target Center (Patient)
ReconstructionType | (0018,9756): Reconstruction Type
RecordedBlockSequence | (3008,00D0): Recorded Block Sequence
RecordedBlockSlabSequence | (3008,00D1): Recorded Block Slab Sequence
RecordedBrachyAccessoryDeviceSequence | (3008,0120): Recorded Brachy Accessory Device Sequence
RecordedChannelSequence | (3008,0130): Recorded Channel Sequence
RecordedChannelShieldSequence | (3008,0150): Recorded Channel Shield Sequence
RecordedCompensatorSequence | (3008,00C0): Recorded Compensator Sequence
RecordedLateralSpreadingDeviceSequence | (3008,00F4): Recorded Lateral Spreading Device Sequence
RecordedRangeModulatorSequence | (3008,00F6): Recorded Range Modulator Sequence
RecordedRangeShifterSequence | (3008,00F2): Recorded Range Shifter Sequence
RecordedRTControlPointDateTime | (300A,073A): Recorded RT Control Point DateTime
RecordedSnoutSequence | (3008,00F0): Recorded Snout Sequence
RecordedSourceApplicatorSequence | (3008,0140): Recorded Source Applicator Sequence
RecordedSourceSequence | (3008,0100): Recorded Source Sequence
RecordedWedgeSequence | (3008,00B0): Recorded Wedge Sequence
RecordInUseFlag | (0004,1410): Record In-use Flag
RectificationType | (0018,1156): Rectification Type
RectifierSmoothing | (0014,4034): Rectifier Smoothing
RectilinearPhaseEncodeReordering | (0018,9034): Rectilinear Phase Encode Reordering
RedPaletteColorLookupTableData | (0028,1201): Red Palette Color Lookup Table Data
RedPaletteColorLookupTableDescriptor | (0028,1101): Red Palette Color Lookup Table Descriptor
Reference | (0020,1020): Reference(Retired)
ReferenceAirKermaRate | (300A,022A): Reference Air Kerma Rate
ReferenceBasisCodeSequence | (0018,9902): Reference Basis Code Sequence
ReferenceCoordinates | (0022,0032): Reference Coordinates
ReferencedAccessionSequenceTrial | (0040,A313): Referenced Accession Sequence (Trial)
ReferencedAssertionUID | (0044,0108): Referenced Assertion UID
ReferencedBasicAnnotationBoxSequence | (2010,0520): Referenced Basic Annotation Box Sequence
ReferencedBeamNumber | (300C,0006): Referenced Beam Number
ReferencedBeamSequence | (300C,0004): Referenced Beam Sequence
ReferencedBlockNumber | (300C,00E0): Referenced Block Number
ReferencedBolusSequence | (300C,00B0): Referenced Bolus Sequence
ReferencedBrachyAccessoryDeviceNumber | (3008,0122): Referenced Brachy Accessory Device Number
ReferencedBrachyApplicationSetupNumber | (300C,000C): Referenced Brachy Application Setup Number
ReferencedBrachyApplicationSetupSequence | (300C,000A): Referenced Brachy Application Setup Sequence
ReferencedCalculatedDoseReferenceNumber | (3008,0092): Referenced Calculated Dose Reference Number
ReferencedCalculatedDoseReferenceSequence | (3008,0090): Referenced Calculated Dose Reference Sequence
ReferencedChannelNumber | (0074,1406): Referenced Channel Number
ReferencedChannelShieldNumber | (3008,0152): Referenced Channel Shield Number
ReferencedColorPaletteInstanceUID | (0028,0304): Referenced Color Palette Instance UID
ReferencedComparisonSOPInstanceSequence | (0082,0005): Referenced Comparison SOP Instance Sequence
ReferencedCompensatorNumber | (300C,00D0): Referenced Compensator Number
ReferencedConceptualVolumeUID | (3010,000B): Referenced Conceptual Volume UID
ReferencedContentItem | (0070,1904): Referenced Content Item
ReferencedContentItemIdentifier | (0040,DB73): Referenced Content Item Identifier
ReferencedControlPointIndex | (300C,00F0): Referenced Control Point Index
ReferencedControlPointSequence | (300C,00F2): Referenced Control Point Sequence
ReferencedCurveSequence | (0008,1145): Referenced Curve Sequence
ReferencedDateTime | (0040,A13A): Referenced DateTime
ReferencedDefinedDeviceIndex | (300A,0602): Referenced Defined Device Index
ReferencedDefinedProtocolSequence | (0018,990C): Referenced Defined Protocol Sequence
ReferencedDeviceIndex | (300A,0607): Referenced Device Index
ReferencedDigitalSignatureSequence | (0400,0402): Referenced Digital Signature Sequence
ReferencedDirectSegmentInstanceSequence | (3010,004A): Referenced Direct Segment Instance Sequence
ReferencedDoseReferenceNumber | (300C,0051): Referenced Dose Reference Number
ReferencedDoseReferenceSequence | (300C,0050): Referenced Dose Reference Sequence
ReferencedDoseReferenceUID | (300A,0083): Referenced Dose Reference UID
ReferencedDoseSequence | (300C,0080): Referenced Dose Sequence
ReferencedDosimetricObjectivesSequence | (3010,0071): Referenced Dosimetric Objectives Sequence
ReferencedDosimetricObjectiveUID | (3010,006F): Referenced Dosimetric Objective UID
ReferencedExpectedInVivoMeasurementValueIndex | (300A,0773): Referenced Expected In-Vivo Measurement Value Index
ReferencedFiducialsUID | (3010,0031): Referenced Fiducials UID
ReferencedFiducialUID | (0070,031B): Referenced Fiducial UID
ReferencedFileID | (0004,1500): Referenced File ID
ReferencedFilmBoxSequence | (2000,0500): Referenced Film Box Sequence
ReferencedFilmSessionSequence | (2010,0500): Referenced Film Session Sequence
ReferencedFindingsGroupUIDTrial | (0040,A022): Referenced Findings Group UID (Trial)
ReferencedFirstFrameSequence | (0072,0427): Referenced First Frame Sequence
ReferencedFractionGroupNumber | (300C,0022): Referenced Fraction Group Number
ReferencedFractionGroupSequence | (300C,0020): Referenced Fraction Group Sequence
ReferencedFractionNumber | (3008,0223): Referenced Fraction Number
ReferencedFrameNumber | (0008,1160): Referenced Frame Number
ReferencedFrameNumbers | (0040,A136): Referenced Frame Numbers
ReferencedFrameOfReferenceSequence | (3006,0010): Referenced Frame of Reference Sequence
ReferencedFrameOfReferenceUID | (3006,0024): Referenced Frame of Reference UID
ReferencedGeneralPurposeScheduledProcedureStepSequence | (0040,4016): Referenced General Purpose Scheduled Procedure Step Sequence
ReferencedGeneralPurposeScheduledProcedureStepTransactionUID | (0040,4023): Referenced General Purpose Scheduled Procedure Step Transaction UID
ReferencedHPGLDocumentID | (0068,6440): Referenced HPGL Document ID
ReferencedImageBoxSequence | (2010,0510): Referenced Image Box Sequence
ReferencedImageBoxSequenceRetired | (2040,0500): Referenced Image Box Sequence (Retired)
ReferencedImageEvidenceSequence | (0008,9092): Referenced Image Evidence Sequence
ReferencedImageNavigationSequence | (0048,0200): Referenced Image Navigation Sequence
ReferencedImageOverlayBoxSequence | (2020,0130): Referenced Image Overlay Box Sequence
ReferencedImageRealWorldValueMappingSequence | (0040,9094): Referenced Image Real World Value Mapping Sequence
ReferencedImageSequence | (0008,1140): Referenced Image Sequence
ReferencedImplantTemplateGroupMemberID | (0078,00B6): Referenced Implant Template Group Member ID
ReferencedInstanceSequence | (0008,114A): Referenced Instance Sequence
ReferencedInterpretationSequence | (4008,0050): Referenced Interpretation Sequence
ReferenceDisplaySets | (0072,0218): Reference Display Sets
ReferencedLateralSpreadingDeviceNumber | (300C,0102): Referenced Lateral Spreading Device Number
ReferencedMeasuredDoseReferenceNumber | (3008,0082): Referenced Measured Dose Reference Number
ReferencedMeasuredDoseReferenceSequence | (3008,0080): Referenced Measured Dose Reference Sequence
ReferencedNonImageCompositeSOPInstanceSequence | (0040,0220): Referenced Non-Image Composite SOP Instance Sequence
ReferencedObjectObservationClassTrial | (0040,A174): Referenced Object Observation Class (Trial)
ReferencedObservationClassTrial | (0040,A173): Referenced Observation Class (Trial)
ReferencedObservationUIDTrial | (0040,A172): Referenced Observation UID (Trial)
ReferencedOphthalmicAxialLengthMeasurementQCImageSequence | (0022,1330): Referenced Ophthalmic Axial Length Measurement QC Image Sequence
ReferencedOphthalmicAxialMeasurementsSequence | (0022,1100): Referenced Ophthalmic Axial Measurements Sequence
ReferencedOpticalPathIdentifier | (006A,000E): Referenced Optical Path Identifier
ReferenceDoseDefinition | (300A,0512): Reference Dose Definition
ReferenceDosePointCoordinates | (300A,061E): Reference Dose Point Coordinates
ReferenceDoseType | (300A,061A): Reference Dose Type
ReferencedOtherPlaneSequence | (0008,9410): Referenced Other Plane Sequence
ReferencedOverlayPlaneGroups | (2040,0011): Referenced Overlay Plane Groups
ReferencedOverlayPlaneSequence | (2040,0010): Referenced Overlay Plane Sequence
ReferencedOverlaySequence | (0008,1130): Referenced Overlay Sequence
ReferencedParentRTPrescriptionIndex | (3010,0042): Referenced Parent RT Prescription Index
ReferencedPathIndex | (0018,9378): Referenced Path Index
ReferencedPatientAliasSequence | (0038,0004): Referenced Patient Alias Sequence
ReferencedPatientPhotoSequence | (0010,1100): Referenced Patient Photo Sequence
ReferencedPatientSequence | (0008,1120): Referenced Patient Sequence
ReferencedPatientSetupNumber | (300C,006A): Referenced Patient Setup Number
ReferencedPatientSetupPhotoSequence | (300A,078C): Referenced Patient Setup Photo Sequence
ReferencedPatientSetupProcedureIndex | (300A,0796): Referenced Patient Setup Procedure Index
ReferencedPerformedProcedureStepSequence | (0008,1111): Referenced Performed Procedure Step Sequence
ReferencedPerformedProtocolSequence | (0018,990D): Referenced Performed Protocol Sequence
ReferencedPlanOverviewIndex | (300C,0118): Referenced Plan Overview Index
ReferencedPresentationLUTSequence | (2050,0500): Referenced Presentation LUT Sequence
ReferencedPresentationStateSequence | (0008,9237): Referenced Presentation State Sequence
ReferencedPrintJobSequence | (2120,0070): Referenced Print Job Sequence
ReferencedPrintJobSequencePullStoredPrint | (2100,0500): Referenced Print Job Sequence (Pull Stored Print)
ReferencedProcedureStepSequence | (0040,0330): Referenced Procedure Step Sequence
ReferencedPTOSequence | (4010,1076): Referenced PTO Sequence
ReferencedRadiationDoseIdentificationIndex | (300A,060C): Referenced Radiation Dose Identification Index
ReferencedRadiationGenerationModeIndex | (300A,0605): Referenced Radiation Generation Mode Index
ReferencedRadiationRTControlPointIndex | (300A,073B): Referenced Radiation RT Control Point Index
ReferencedRangeModulatorNumber | (300C,0104): Referenced Range Modulator Number
ReferencedRangeShifterNumber | (300C,0100): Referenced Range Shifter Number
ReferencedRawDataSequence | (0008,9121): Referenced Raw Data Sequence
ReferencedRealWorldValueMappingInstanceSequence | (0008,114B): Referenced Real World Value Mapping Instance Sequence
ReferencedReferenceImageNumber | (300C,0007): Referenced Reference Image Number
ReferencedReferenceImageSequence | (300C,0042): Referenced Reference Image Sequence
ReferencedRefractiveMeasurementsSequence | (0046,0145): Referenced Refractive Measurements Sequence
ReferencedRelatedGeneralSOPClassUIDInFile | (0004,151A): Referenced Related General SOP Class UID in File
ReferencedRequestSequence | (0040,A370): Referenced Request Sequence
ReferencedResultsSequence | (0008,1100): Referenced Results Sequence
ReferencedROINumber | (3006,0084): Referenced ROI Number
ReferencedRTAccessoryHolderDeviceIndex | (300A,060E): Referenced RT Accessory Holder Device Index
ReferencedRTInstanceSequence | (300A,0631): Referenced RT Instance Sequence
ReferencedRTPatientSetupSequence | (300A,0632): Referenced RT Patient Setup Sequence
ReferencedRTPhysicianIntentIndex | (3010,005E): Referenced RT Physician Intent Index
ReferencedRTPhysicianIntentSequence | (300A,063B): Referenced RT Physician Intent Sequence
ReferencedRTPlanSequence | (300C,0002): Referenced RT Plan Sequence
ReferencedRTPrescriptionIndex | (3010,0041): Referenced RT Prescription Index
ReferencedRTPrescriptionSequence | (300A,068A): Referenced RT Prescription Sequence
ReferencedRTRadiationRecordSequence | (300A,0703): Referenced RT Radiation Record Sequence
ReferencedRTRadiationSequence | (300A,0630): Referenced RT Radiation Sequence
ReferencedRTRadiationSetSequence | (300A,0702): Referenced RT Radiation Set Sequence
ReferencedRTTreatmentPhaseIndex | (3010,0040): Referenced RT Treatment Phase Index
ReferencedRTTreatmentPhaseSequence | (3010,0049): Referenced RT Treatment Phase Sequence
ReferencedRTTreatmentPreparationSequence | (300A,078B): Referenced RT Treatment Preparation Sequence
ReferencedSamplePositions | (0040,A132): Referenced Sample Positions
ReferencedSegmentNumber | (0062,000B): Referenced Segment Number
ReferencedSegmentReferenceIndex | (3010,0020): Referenced Segment Reference Index
ReferencedSeriesSequence | (0008,1115): Referenced Series Sequence
ReferencedSetupImageSequence | (300A,0401): Referenced Setup Image Sequence
ReferencedSOPClassUID | (0008,1150): Referenced SOP Class UID
ReferencedSOPClassUIDInFile | (0004,1510): Referenced SOP Class UID in File
ReferencedSOPInstanceMACSequence | (0400,0403): Referenced SOP Instance MAC Sequence
ReferencedSOPInstanceUID | (0008,1155): Referenced SOP Instance UID
ReferencedSOPInstanceUIDInFile | (0004,1511): Referenced SOP Instance UID in File
ReferencedSOPSequence | (0008,1199): Referenced SOP Sequence
ReferencedSourceApplicatorNumber | (3008,0142): Referenced Source Applicator Number
ReferencedSourceNumber | (300C,000E): Referenced Source Number
ReferencedSpatialRegistrationSequence | (0070,0404): Referenced Spatial Registration Sequence
ReferencedStartControlPointIndex | (300C,00F4): Referenced Start Control Point Index
ReferencedStereometricInstanceSequence | (0008,1134): Referenced Stereometric Instance Sequence
ReferencedStopControlPointIndex | (300C,00F6): Referenced Stop Control Point Index
ReferencedStorageMediaSequence | (2200,000D): Referenced Storage Media Sequence
ReferencedStoredPrintSequence | (2000,0510): Referenced Stored Print Sequence
ReferencedStructuredContextSequence | (0070,1903): Referenced Structured Context Sequence
ReferencedStructureSetSequence | (300C,0060): Referenced Structure Set Sequence
ReferencedStudySequence | (0008,1110): Referenced Study Sequence
ReferencedSurfaceDataSequence | (0080,0013): Referenced Surface Data Sequence
ReferencedSurfaceMeshIdentificationSequence | (0022,1620): Referenced Surface Mesh Identification Sequence
ReferencedSurfaceNumber | (0066,002C): Referenced Surface Number
ReferencedSurfaceSequence | (0066,002B): Referenced Surface Sequence
ReferencedTargetLuminanceCharacteristicsID | (0028,700E): Referenced Target Luminance Characteristics ID
ReferencedTDRInstanceSequence | (4010,1077): Referenced TDR Instance Sequence
ReferencedTextureSequence | (0080,0012): Referenced Texture Sequence
ReferencedTimeOffsets | (0040,A138): Referenced Time Offsets
ReferencedToleranceTableNumber | (300C,00A0): Referenced Tolerance Table Number
ReferencedTransferSyntaxUIDInFile | (0004,1512): Referenced Transfer Syntax UID in File
ReferencedTreatmentPositionGroupUID | (300A,0785): Referenced Treatment Position Group UID
ReferencedTreatmentPositionIndex | (300A,060B): Referenced Treatment Position Index
ReferencedTreatmentRecordSequence | (3008,0030): Referenced Treatment Record Sequence
ReferencedVerificationImageSequence | (300C,0040): Referenced Verification Image Sequence
ReferencedVisitSequence | (0008,1125): Referenced Visit Sequence
ReferencedVOILUTBoxSequence | (2020,0140): Referenced VOI LUT Box Sequence
ReferencedWaveformChannels | (0040,A0B0): Referenced Waveform Channels
ReferencedWaveformSequence | (0008,113A): Referenced Waveform Sequence
ReferencedWedgeNumber | (300C,00C0): Referenced Wedge Number
ReferencedXRayDetectorIndex | (0018,9376): Referenced X-Ray Detector Index
ReferencedXRaySourceIndex | (0018,9377): Referenced X-Ray Source Index
ReferenceGeometryCodeSequence | (0018,9903): Reference Geometry Code Sequence
ReferenceImageNumber | (300A,00C8): Reference Image Number
ReferenceLocationDescription | (0018,9901): Reference Location Description
ReferenceLocationLabel | (0018,9900): Reference Location Label
ReferencePixelPhysicalValueX | (0018,6028): Reference Pixel Physical Value X
ReferencePixelPhysicalValueY | (0018,602A): Reference Pixel Physical Value Y
ReferencePixelX0 | (0018,6020): Reference Pixel X0
ReferencePixelY0 | (0018,6022): Reference Pixel Y0
ReferenceToRecordedSound | (4008,0103): Reference to Recorded Sound
ReferringPhysicianAddress | (0008,0092): Referring Physician's Address
ReferringPhysicianIdentificationSequence | (0008,0096): Referring Physician Identification Sequence
ReferringPhysicianName | (0008,0090): Referring Physician's Name
ReferringPhysicianTelephoneNumbers | (0008,0094): Referring Physician's Telephone Numbers
ReflectedAmbientLight | (2010,0160): Reflected Ambient Light
ReformattingInterval | (0072,0514): Reformatting Interval
ReformattingOperationInitialViewDirection | (0072,0516): Reformatting Operation Initial View Direction
ReformattingOperationType | (0072,0510): Reformatting Operation Type
ReformattingThickness | (0072,0512): Reformatting Thickness
RefractiveErrorBeforeRefractiveSurgeryCodeSequence | (0022,1103): Refractive Error Before Refractive Surgery Code Sequence
RefractiveIndexApplied | (0052,003A): Refractive Index Applied
RefractiveIndexOfAqueousHumor | (0046,0118): Refractive Index of Aqueous Humor
RefractiveIndexOfCornea | (0046,0117): Refractive Index of Cornea
RefractiveParametersUsedOnPatientSequence | (0024,0112): Refractive Parameters Used on Patient Sequence
RefractivePower | (0046,0251): Refractive Power
RefractiveProcedureOccurred | (0022,1039): Refractive Procedure Occurred
RefractiveStateSequence | (0022,001B): Refractive State Sequence
RefractiveSurgeryTypeCodeSequence | (0022,1040): Refractive Surgery Type Code Sequence
RegionDataType | (0018,6014): Region Data Type
RegionFlags | (0018,6016): Region Flags
RegionLocationMaxX1 | (0018,601C): Region Location Max X1
RegionLocationMaxY1 | (0018,601E): Region Location Max Y1
RegionLocationMinX0 | (0018,6018): Region Location Min X0
RegionLocationMinY0 | (0018,601A): Region Location Min Y0
RegionOfResidence | (0010,2152): Region of Residence
RegionPixelShiftSequence | (0028,9502): Region Pixel Shift Sequence
RegionSpatialFormat | (0018,6012): Region Spatial Format
RegisteredLocalizerBottomRightHandCorner | (0022,1468): Registered Localizer Bottom Right Hand Corner
RegisteredLocalizerTopLeftHandCorner | (0022,1467): Registered Localizer Top Left Hand Corner
RegisteredLocalizerUnits | (0022,1466): Registered Localizer Units
RegistrationMethodCodeSequence | (0080,0003): Registration Method Code Sequence
RegistrationSequence | (0070,0308): Registration Sequence
RegistrationToLocalizerSequence | (0022,1465): Registration to Localizer Sequence
RegistrationTypeCodeSequence | (0070,030D): Registration Type Code Sequence
RelatedAssertionSequence | (0044,0107): Related Assertion Sequence
RelatedFrameOfReferenceUID | (3006,00C2): Related Frame of Reference UID
RelatedGeneralSOPClassUID | (0008,001A): Related General SOP Class UID
RelatedProcedureStepSequence | (0074,1220): Related Procedure Step Sequence
RelatedReferenceRTImageSequence | (0074,1040): Related Reference RT Image Sequence
RelatedRTROIObservationsSequence | (3006,00A0): Related RT ROI Observations Sequence
RelatedRTTreatmentPhaseIndex | (3010,003F): Related RT Treatment Phase Index
RelatedSegmentCharacteristicsSequence | (3010,0028): Related Segment Characteristics Sequence
RelatedSeriesSequence | (0008,1250): Related Series Sequence
RelationshipSequenceTrial | (0040,A731): Relationship Sequence (Trial)
RelationshipType | (0040,A010): Relationship Type
RelationshipTypeCodeSequenceTrial | (0040,A732): Relationship Type Code Sequence (Trial)
RelativeElevation | (0046,0252): Relative Elevation
RelativeImagePositionCodeSequence | (0022,001D): Relative Image Position Code Sequence
RelativeOpacity | (0070,0403): Relative Opacity
RelativeTime | (0072,0038): Relative Time
RelativeTimeUnits | (0072,003A): Relative Time Units
RelativeURIReferenceWithinEncapsulatedDocument | (0068,7005): Relative URI Reference Within Encapsulated Document
RelativeXRayExposure | (0018,1405): Relative X-Ray Exposure
RelevantInformationSequence | (0040,4022): Relevant Information Sequence
RelevantOPTAttributesSequence | (0022,1472): Relevant OPT Attributes Sequence
RenderedImageReferenceSequence | (0070,1104): Rendered Image Reference Sequence
RenderFieldOfView | (0070,1606): Render Field of View
RenderingMethod | (0070,120D): Rendering Method
RenderProjection | (0070,1602): Render Projection
RepairID | (0014,0105): Repair ID
RepeatFractionCycleLength | (300A,007A): Repeat Fraction Cycle Length
RepeatInterval | (0028,0068): Repeat Interval
RepetitionTime | (0018,0080): Repetition Time
ReplacedImplantAssemblyTemplateSequence | (0076,0008): Replaced Implant Assembly Template Sequence
ReplacedImplantTemplateGroupSequence | (0078,0026): Replaced Implant Template Group Sequence
ReplacedImplantTemplateSequence | (0068,6222): Replaced Implant Template Sequence
ReplacedProcedureStepSequence | (0074,1224): Replaced Procedure Step Sequence
ReportDetailSequenceTrial | (0040,A380): Report Detail Sequence (Trial)
ReportedValuesOrigin | (3002,000A): Reported Values Origin
ReportingPriority | (0040,1009): Reporting Priority
ReportNumber | (0020,00AA): Report Number
ReportProductionStatusTrial | (4008,00FF): Report Production Status (Trial)
ReportStatusCommentTrial | (0040,A33A): Report Status Comment (Trial)
ReportStatusIDTrial | (0040,A125): Report Status ID (Trial)
RepositoryUniqueID | (0040,E030): Repository Unique ID
RepresentativeFrameNumber | (0028,6010): Representative Frame Number
ReprojectionMethod | (0054,1004): Reprojection Method
RequestAttributesSequence | (0040,0275): Request Attributes Sequence
RequestedContrastAgent | (0032,1070): Requested Contrast Agent
RequestedDecimateCropBehavior | (2020,0040): Requested Decimate/Crop Behavior
RequestedImageSize | (2020,0030): Requested Image Size
RequestedImageSizeFlag | (2020,00A0): Requested Image Size Flag
RequestedLateralityCodeSequence | (0032,1065): Requested Laterality Code Sequence
RequestedMediaApplicationProfile | (2200,000C): Requested Media Application Profile
RequestedProcedureCodeSequence | (0032,1064): Requested Procedure Code Sequence
RequestedProcedureComments | (0040,1400): Requested Procedure Comments
RequestedProcedureDescription | (0032,1060): Requested Procedure Description
RequestedProcedureDescriptionTrial | (0040,1060): Requested Procedure Description (Trial)
RequestedProcedureID | (0040,1001): Requested Procedure ID
RequestedProcedureLocation | (0040,1005): Requested Procedure Location
RequestedProcedurePriority | (0040,1003): Requested Procedure Priority
RequestedResolutionID | (2020,0050): Requested Resolution ID
RequestedSeriesDescription | (0018,9937): Requested Series Description
RequestedSeriesDescriptionCodeSequence | (0018,11C1): Requested Series Description Code Sequence
RequestedSOPClassUID | (0000,0003): Requested SOP Class UID
RequestedSOPInstanceUID | (0000,1001): Requested SOP Instance UID
RequestedSubsequentWorkitemCodeSequence | (0040,4031): Requested Subsequent Workitem Code Sequence
RequestingAE | (0074,1236): Requesting AE
RequestingPhysician | (0032,1032): Requesting Physician
RequestingPhysicianIdentificationSequence | (0032,1031): Requesting Physician Identification Sequence
RequestingService | (0032,1033): Requesting Service
RequestingServiceCodeSequence | (0032,1034): Requesting Service Code Sequence
RequestPriority | (2200,0020): Request Priority
RescaleIntercept | (0028,1052): Rescale Intercept
RescaleSlope | (0028,1053): Rescale Slope
RescaleType | (0028,1054): Rescale Type
ResidualSyringeCounts | (0054,0017): Residual Syringe Counts
ResonantNucleus | (0018,9100): Resonant Nucleus
ResourceDescription | (0038,0102): Resource Description
RespiratoryCyclePosition | (0018,9214): Respiratory Cycle Position
RespiratoryIntervalTime | (0020,9254): Respiratory Interval Time
RespiratoryMotionCompensationTechnique | (0018,9170): Respiratory Motion Compensation Technique
RespiratoryMotionCompensationTechniqueDescription | (0018,9185): Respiratory Motion Compensation Technique Description
RespiratorySignalSource | (0018,9171): Respiratory Signal Source
RespiratorySignalSourceID | (0018,9186): Respiratory Signal Source ID
RespiratorySynchronizationSequence | (0020,9253): Respiratory Synchronization Sequence
RespiratoryTriggerDelayThreshold | (0020,9256): Respiratory Trigger Delay Threshold
RespiratoryTriggerType | (0020,9250): Respiratory Trigger Type
ResponseSequenceNumber | (0000,0860): Response Sequence Number(Retired)
ResponsibleGroupCodeSequence | (0008,0220): Responsible Group Code Sequence
ResponsibleOrganization | (0010,2299): Responsible Organization
ResponsiblePerson | (0010,2297): Responsible Person
ResponsiblePersonRole | (0010,2298): Responsible Person Role
ResultingGeneralPurposePerformedProcedureStepsSequence | (0040,4015): Resulting General Purpose Performed Procedure Steps Sequence
ResultsComments | (4008,4000): Results Comments
ResultsDistributionListSequence | (4008,0118): Results Distribution List Sequence
ResultsID | (4008,0040): Results ID
ResultsIDIssuer | (4008,0042): Results ID Issuer
ResultsNormalsSequence | (0024,0064): Results Normals Sequence
RetestSensitivityValue | (0024,0096): Retest Sensitivity Value
RetestStimulusSeen | (0024,0095): Retest Stimulus Seen
RetinalThicknessDefinitionCodeSequence | (0022,1445): Retinal Thickness Definition Code Sequence
RetrieveAETitle | (0008,0054): Retrieve AE Title
RetrieveLocationUID | (0040,E011): Retrieve Location UID
RetrieveURI | (0040,E010): Retrieve URI
RetrieveURL | (0008,1190): Retrieve URL
ReviewDate | (300E,0004): Review Date
ReviewerName | (300E,0008): Reviewer Name
ReviewTime | (300E,0005): Review Time
RevolutionTime | (0018,9305): Revolution Time
RFEchoTrainLength | (0018,9240): RF Echo Train Length
RGBATransferFunctionDescription | (0070,1A09): RGBA Transfer Function Description
RGBLUTTransferFunction | (0028,140F): RGB LUT Transfer Function
RightImageSequence | (0022,0022): Right Image Sequence
RightLensSequence | (0046,0014): Right Lens Sequence
RoboticBaseLocationIndicator | (3010,0090): Robotic Base Location Indicator
RoboticNodeIdentifier | (3010,0092): Robotic Node Identifier
RoboticPathControlPointSequence | (3010,0097): Robotic Path Control Point Sequence
RoboticPathNodeSetCodeSequence | (3010,0091): Robotic Path Node Set Code Sequence
ROIArea | (60xx,1301): ROI Area
ROIContourSequence | (3006,0039): ROI Contour Sequence
ROIDerivationAlgorithmIdentificationSequence | (3006,0037): ROI Derivation Algorithm Identification Sequence
ROIDescription | (3006,0028): ROI Description
ROIDisplayColor | (3006,002A): ROI Display Color
ROIElementalCompositionAtomicMassFraction | (3006,00B8): ROI Elemental Composition Atomic Mass Fraction
ROIElementalCompositionAtomicNumber | (3006,00B7): ROI Elemental Composition Atomic Number
ROIElementalCompositionSequence | (3006,00B6): ROI Elemental Composition Sequence
ROIGenerationAlgorithm | (3006,0036): ROI Generation Algorithm
ROIGenerationDescription | (3006,0038): ROI Generation Description
ROIInterpreter | (3006,00A6): ROI Interpreter
ROIMean | (60xx,1302): ROI Mean
ROIName | (3006,0026): ROI Name
ROINumber | (3006,0022): ROI Number
ROIObservationDescription | (3006,0088): ROI Observation Description
ROIObservationLabel | (3006,0085): ROI Observation Label
ROIPhysicalPropertiesSequence | (3006,00B0): ROI Physical Properties Sequence
ROIPhysicalProperty | (3006,00B2): ROI Physical Property
ROIPhysicalPropertyValue | (3006,00B4): ROI Physical Property Value
ROIStandardDeviation | (60xx,1303): ROI Standard Deviation
ROIVolume | (3006,002C): ROI Volume
RotationAngle | (0070,0230): Rotation Angle
RotationDirection | (0018,1140): Rotation Direction
RotationInformationSequence | (0054,0052): Rotation Information Sequence
RotationOffset | (0018,1146): Rotation Offset
RotationOfScannedFilm | (0018,2030): Rotation of Scanned Film
RotationPoint | (0070,0273): Rotation Point
RotationVector | (0054,0050): Rotation Vector
RouteID | (4010,1054): Route ID
RouteIDAssigningAuthority | (4010,1055): Route ID Assigning Authority
RouteOfAdmissions | (0038,0016): Route of Admissions
RouteSegmentEndLocationID | (4010,101F): Route Segment End Location ID
RouteSegmentEndTime | (4010,1026): Route Segment End Time
RouteSegmentID | (4010,1007): Route Segment ID
RouteSegmentLocationIDType | (4010,1020): Route Segment Location ID Type
RouteSegmentSequence | (4010,100A): Route Segment Sequence
RouteSegmentStartLocationID | (4010,101E): Route Segment Start Location ID
RouteSegmentStartTime | (4010,1025): Route Segment Start Time
RowOverlap | (0028,0093): Row Overlap
RowPositionInTotalImagePixelMatrix | (0048,021F): Row Position In Total Image Pixel Matrix
Rows | (0028,0010): Rows
RRIntervalTimeNominal | (0020,9251): R-R Interval Time Nominal
RRIntervalVector | (0054,0060): R-R Interval Vector
RTAccessoryDeviceSlotID | (300A,0615): RT Accessory Device Slot ID
RTAccessoryHolderDefinitionSequence | (300A,0614): RT Accessory Holder Definition Sequence
RTAccessoryHolderSlotDistance | (300A,0612): RT Accessory Holder Slot Distance
RTAccessoryHolderSlotExistenceFlag | (300A,060F): RT Accessory Holder Slot Existence Flag
RTAccessoryHolderSlotID | (300A,0611): RT Accessory Holder Slot ID
RTAccessoryHolderSlotSequence | (300A,0610): RT Accessory Holder Slot Sequence
RTAccessoryHolderWaterEquivalentThickness | (300A,060D): RT Accessory Holder Water-Equivalent Thickness
RTAccessorySlotDistance | (300A,0613): RT Accessory Slot Distance
RTAnatomicPrescriptionSequence | (3010,0060): RT Anatomic Prescription Sequence
RTBeamDelimiterGeometrySequence | (300A,064C): RT Beam Delimiter Geometry Sequence
RTBeamLimitingDeviceAngle | (300A,0679): RT Beam Limiting Device Angle
RTBeamLimitingDeviceDefinitionSequence | (300A,064D): RT Beam Limiting Device Definition Sequence
RTBeamLimitingDeviceDistalDistance | (300A,0643): RT Beam Limiting Device Distal Distance
RTBeamLimitingDeviceOffset | (300A,064B): RT Beam Limiting Device Offset
RTBeamLimitingDeviceOpeningSequence | (300A,0656): RT Beam Limiting Device Opening Sequence
RTBeamLimitingDeviceProximalDistance | (300A,0642): RT Beam Limiting Device Proximal Distance
RTBeamLimitingDeviceType | (300A,00B8): RT Beam Limiting Device Type
RTBeamModifierDefinitionDistance | (300A,0688): RT Beam Modifier Definition Distance
RTControlPointIndex | (300A,0600): RT Control Point Index
RTDeliveryStartPatientPositionSequence | (300A,0789): RT Delivery Start Patient Position Sequence
RTDeviceDistanceReferenceLocationCodeSequence | (300A,0659): RT Device Distance Reference Location Code Sequence
RTDiagnosisCodeSequence | (3010,005D): RT Diagnosis Code Sequence
RTDoseROISequence | (3004,0010): RT Dose ROI Sequence
RTImageDescription | (3002,0004): RT Image Description
RTImageLabel | (3002,0002): RT Image Label
RTImageName | (3002,0003): RT Image Name
RTImageOrientation | (3002,0010): RT Image Orientation
RTImagePlane | (3002,000C): RT Image Plane
RTImagePosition | (3002,0012): RT Image Position
RTImageSID | (3002,0026): RT Image SID
RTPatientPositionDisplacementSequence | (300A,0798): RT Patient Position Displacement Sequence
RTPatientPositionScopeSequence | (300A,0784): RT Patient Position Scope Sequence
RTPatientPositionSequence | (300A,0799): RT Patient Position Sequence
RTPhysicianIntentIndex | (3010,0058): RT Physician Intent Index
RTPhysicianIntentInputInstanceSequence | (3010,005F): RT Physician Intent Input Instance Sequence
RTPhysicianIntentNarrative | (3010,005A): RT Physician Intent Narrative
RTPhysicianIntentPredecessorSequence | (3010,0055): RT Physician Intent Predecessor Sequence
RTPhysicianIntentSequence | (3010,0057): RT Physician Intent Sequence
RTPlanDate | (300A,0006): RT Plan Date
RTPlanDescription | (300A,0004): RT Plan Description
RTPlanGeometry | (300A,000C): RT Plan Geometry
RTPlanLabel | (300A,0002): RT Plan Label
RTPlanName | (300A,0003): RT Plan Name
RTPlanRelationship | (300A,0055): RT Plan Relationship
RTPlanTime | (300A,0007): RT Plan Time
RTPrescriptionIndex | (3010,003C): RT Prescription Index
RTPrescriptionLabel | (3010,0054): RT Prescription Label
RTPrescriptionSequence | (3010,006B): RT Prescription Sequence
RTProtocolCodeSequence | (3010,005B): RT Protocol Code Sequence
RTRadiationPhysicalAndGeometricContentDetailFlag | (300A,0638): RT Radiation Physical and Geometric Content Detail Flag
RTRadiationSalvageRecordControlPointSequence | (300A,0722): RT Radiation Salvage Record Control Point Sequence
RTRadiationSequence | (300A,0616): RT Radiation Sequence
RTRadiationSetDeliveryNumber | (300A,0704): RT Radiation Set Delivery Number
RTRadiationSetDeliveryUsage | (300A,079E): RT Radiation Set Delivery Usage
RTRadiationSetIntent | (300A,0637): RT Radiation Set Intent
RTRadiationSetUsage | (300A,0707): RT Radiation Set Usage
RTRadiationTaskSequence | (300A,0797): RT Radiation Task Sequence
RTRadiationUsage | (300A,0701): RT Radiation Usage
RTRecordFlag | (300A,0639): RT Record Flag
RTReferencedSeriesSequence | (3006,0014): RT Referenced Series Sequence
RTReferencedStudySequence | (3006,0012): RT Referenced Study Sequence
RTRelatedROISequence | (3006,0030): RT Related ROI Sequence
RTROIIdentificationCodeSequence | (3006,0086): RT ROI Identification Code Sequence
RTROIInterpretedType | (3006,00A4): RT ROI Interpreted Type
RTROIObservationsSequence | (3006,0080): RT ROI Observations Sequence
RTROIRelationship | (3006,0033): RT ROI Relationship
RTSegmentAnnotationIndex | (3010,003D): RT Segment Annotation Index
RTSegmentAnnotationSequence | (3010,002A): RT Segment Annotation Sequence
RTToleranceSetLabel | (300A,062A): RT Tolerance Set Label
RTToleranceSetSequence | (300A,0629): RT Tolerance Set Sequence
RTTreatmentApproachLabel | (3010,0056): RT Treatment Approach Label
RTTreatmentFractionCompletionStatus | (300A,0706): RT Treatment Fraction Completion Status
RTTreatmentIntentType | (3010,0059): RT Treatment Intent Type
RTTreatmentPhaseIndex | (3010,003A): RT Treatment Phase Index
RTTreatmentPhaseIntentPresenceFlag | (3010,0045): RT Treatment Phase Intent Presence Flag
RTTreatmentPhaseIntervalSequence | (3010,004E): RT Treatment Phase Interval Sequence
RTTreatmentPhaseUID | (3010,003B): RT Treatment Phase UID
RTTreatmentPreparationPatientPositionSequence | (300A,078A): RT Treatment Preparation Patient Position Sequence
RTTreatmentSourceCoordinates | (3010,0093): RT Treatment Source Coordinates
RTTreatmentTechniqueCodeSequence | (3010,0080): RT Treatment Technique Code Sequence
RTTreatmentTerminationReasonCodeSequence | (300A,0715): RT Treatment Termination Reason Code Sequence
RTTreatmentTerminationStatus | (300A,0714): RT Treatment Termination Status
RTVCommunicationSOPClassUID | (0002,0032): RTV Communication SOP Class UID
RTVCommunicationSOPInstanceUID | (0002,0033): RTV Communication SOP Instance UID
RTVFlowActualFrameDuration | (0002,0038): RTV Flow Actual Frame Duration
RTVFlowIdentifier | (0002,0036): RTV Flow Identifier
RTVFlowRTPSamplingRate | (0002,0037): RTV Flow RTP Sampling Rate
RTVMetaInformationVersion | (0002,0031): RTV Meta Information Version
RTVSourceIdentifier | (0002,0035): RTV Source Identifier
RunLengthTriplet | (1000,xxx1): Run Length Triplet
RWavePointer | (0028,6040): R Wave Pointer
RWaveTimeVector | (0018,6060): R Wave Time Vector
SafePositionExitDate | (3008,0162): Safe Position Exit Date
SafePositionExitTime | (3008,0164): Safe Position Exit Time
SafePositionReturnDate | (3008,0166): Safe Position Return Date
SafePositionReturnTime | (3008,0168): Safe Position Return Time
SampleRate | (50xx,2008): Sample Rate
SamplesPerPixel | (0028,0002): Samples per Pixel
SamplesPerPixelUsed | (0028,0003): Samples per Pixel Used
SamplingFrequency | (003A,001A): Sampling Frequency
SamplingStepSize | (0070,1607): Sampling Step Size
SAR | (0018,1316): SAR
Saturation | (0016,0049): Saturation
SaturationRecovery | (0018,9024): Saturation Recovery
ScanArc | (0018,1143): Scan Arc
ScanLength | (0018,1302): Scan Length
ScanMode | (300A,0308): Scan Mode
ScannerSettingsSequence | (0014,409A): Scanner Settings Sequence
ScanningSequence | (0018,0020): Scanning Sequence
ScanningSpotSize | (300A,0398): Scanning Spot Size
ScanOptions | (0018,0022): Scan Options
ScanPatternTypeCodeSequence | (0022,1618): Scan Pattern Type Code Sequence
ScanProcedure | (0014,409B): Scan Procedure
ScanProgressionDirection | (0054,0501): Scan Progression Direction
ScanSpotMetersetsDelivered | (3008,0047): Scan Spot Metersets Delivered
ScanSpotMetersetWeights | (300A,0396): Scan Spot Meterset Weights
ScanSpotPositionMap | (300A,0394): Scan Spot Position Map
ScanSpotPrescribedIndices | (300A,0391): Scan Spot Prescribed Indices
ScanSpotReordered | (300A,0393): Scan Spot Reordered
ScanSpotReorderingAllowed | (300A,0395): Scan Spot Reordering Allowed
ScanSpotSizesDelivered | (300A,0399): Scan Spot Sizes Delivered
ScanSpotTimeOffset | (300A,038F): Scan Spot Time Offset
ScanSpotTuneID | (300A,0390): Scan Spot Tune ID
ScanType | (4010,1048): Scan Type
ScanVelocity | (0018,1300): Scan Velocity
ScatterCorrected | (0018,9760): Scatter Corrected
ScatterCorrectionMethod | (0054,1105): Scatter Correction Method
ScatterFractionFactor | (0054,1323): Scatter Fraction Factor
SceneCaptureType | (0016,0046): Scene Capture Type
SceneType | (0016,003B): Scene Type
ScheduledAdmissionDate | (0038,001A): Scheduled Admission Date
ScheduledAdmissionTime | (0038,001B): Scheduled Admission Time
ScheduledDischargeDate | (0038,001C): Scheduled Discharge Date
ScheduledDischargeTime | (0038,001D): Scheduled Discharge Time
ScheduledHumanPerformersSequence | (0040,4034): Scheduled Human Performers Sequence
ScheduledPatientInstitutionResidence | (0038,001E): Scheduled Patient Institution Residence
ScheduledPerformingPhysicianIdentificationSequence | (0040,000B): Scheduled Performing Physician Identification Sequence
ScheduledPerformingPhysicianName | (0040,0006): Scheduled Performing Physician's Name
ScheduledProcedureStepDescription | (0040,0007): Scheduled Procedure Step Description
ScheduledProcedureStepEndDate | (0040,0004): Scheduled Procedure Step End Date
ScheduledProcedureStepEndTime | (0040,0005): Scheduled Procedure Step End Time
ScheduledProcedureStepExpirationDateTime | (0040,4008): Scheduled Procedure Step Expiration DateTime
ScheduledProcedureStepID | (0040,0009): Scheduled Procedure Step ID
ScheduledProcedureStepLocation | (0040,0011): Scheduled Procedure Step Location
ScheduledProcedureStepModificationDateTime | (0040,4010): Scheduled Procedure Step Modification DateTime
ScheduledProcedureStepPriority | (0074,1200): Scheduled Procedure Step Priority
ScheduledProcedureStepSequence | (0040,0100): Scheduled Procedure Step Sequence
ScheduledProcedureStepStartDate | (0040,0002): Scheduled Procedure Step Start Date
ScheduledProcedureStepStartDateTime | (0040,4005): Scheduled Procedure Step Start DateTime
ScheduledProcedureStepStartTime | (0040,0003): Scheduled Procedure Step Start Time
ScheduledProcedureStepStatus | (0040,0020): Scheduled Procedure Step Status
ScheduledProcessingApplicationsCodeSequence | (0040,4004): Scheduled Processing Applications Code Sequence
ScheduledProcessingParametersSequence | (0074,1210): Scheduled Processing Parameters Sequence
ScheduledProtocolCodeSequence | (0040,0008): Scheduled Protocol Code Sequence
ScheduledSpecimenSequence | (0040,0500): Scheduled Specimen Sequence
ScheduledStationAETitle | (0040,0001): Scheduled Station AE Title
ScheduledStationClassCodeSequence | (0040,4026): Scheduled Station Class Code Sequence
ScheduledStationGeographicLocationCodeSequence | (0040,4027): Scheduled Station Geographic Location Code Sequence
ScheduledStationName | (0040,0010): Scheduled Station Name
ScheduledStationNameCodeSequence | (0040,4025): Scheduled Station Name Code Sequence
ScheduledStepAttributesSequence | (0040,0270): Scheduled Step Attributes Sequence
ScheduledStudyLocation | (0032,1020): Scheduled Study Location
ScheduledStudyLocationAETitle | (0032,1021): Scheduled Study Location AE Title
ScheduledStudyStartDate | (0032,1000): Scheduled Study Start Date
ScheduledStudyStartTime | (0032,1001): Scheduled Study Start Time
ScheduledStudyStopDate | (0032,1010): Scheduled Study Stop Date
ScheduledStudyStopTime | (0032,1011): Scheduled Study Stop Time
ScheduledWorkitemCodeSequence | (0040,4018): Scheduled Workitem Code Sequence
SCPStatus | (0074,1242): SCP Status
ScreeningBaselineMeasured | (0024,0120): Screening Baseline Measured
ScreeningBaselineMeasuredSequence | (0024,0122): Screening Baseline Measured Sequence
ScreeningBaselineType | (0024,0124): Screening Baseline Type
ScreeningBaselineValue | (0024,0126): Screening Baseline Value
ScreeningTestModeCodeSequence | (0024,0016): Screening Test Mode Code Sequence
ScreenMinimumColorBitDepth | (0072,010C): Screen Minimum Color Bit Depth
ScreenMinimumGrayscaleBitDepth | (0072,010A): Screen Minimum Grayscale Bit Depth
SeamLineIndex | (0052,0036): Seam Line Index
SeamLineLocation | (0052,0033): Seam Line Location
SecondaryApprovalStatus | (0014,0101): Secondary Approval Status
SecondaryCaptureDeviceID | (0018,1010): Secondary Capture Device ID
SecondaryCaptureDeviceManufacturer | (0018,1016): Secondary Capture Device Manufacturer
SecondaryCaptureDeviceManufacturerModelName | (0018,1018): Secondary Capture Device Manufacturer's Model Name
SecondaryCaptureDeviceSoftwareVersions | (0018,1019): Secondary Capture Device Software Versions
SecondaryCountsAccumulated | (0054,1311): Secondary Counts Accumulated
SecondaryCountsType | (0054,1220): Secondary Counts Type
SecondaryInspectionMethodSequence | (4010,107D): Secondary Inspection Method Sequence
SecondaryPositionerIncrement | (0018,9515): Secondary Positioner Increment
SecondaryPositionerIncrementSign | (0018,9519): Secondary Positioner Increment Sign
SecondaryPositionerScanArc | (0018,9509): Secondary Positioner Scan Arc
SecondaryPositionerScanStartAngle | (0018,9511): Secondary Positioner Scan Start Angle
SecondaryReviewDate | (0014,0102): Secondary Review Date
SecondaryReviewerName | (0014,0104): Secondary Reviewer Name
SecondaryReviewTime | (0014,0103): Secondary Review Time
SegmentAlgorithmName | (0062,0009): Segment Algorithm Name
SegmentAlgorithmType | (0062,0008): Segment Algorithm Type
SegmentAnnotationCategoryCodeSequence | (3010,002B): Segment Annotation Category Code Sequence
SegmentAnnotationTypeCodeSequence | (3010,002C): Segment Annotation Type Code Sequence
SegmentAnnotationTypeModifierCodeSequence | (3010,002F): Segment Annotation Type Modifier Code Sequence
SegmentationAlgorithmIdentificationSequence | (0062,0007): Segmentation Algorithm Identification Sequence
SegmentationCreationTemplateLabel | (3010,001E): Segmentation Creation Template Label
SegmentationFractionalType | (0062,0010): Segmentation Fractional Type
SegmentationTemplateUID | (3010,001F): Segmentation Template UID
SegmentationType | (0062,0001): Segmentation Type
SegmentCharacteristicsPrecedence | (3010,0029): Segment Characteristics Precedence
SegmentCharacteristicsSequence | (3010,0027): Segment Characteristics Sequence
SegmentDescription | (0062,0006): Segment Description
SegmentedAlphaPaletteColorLookupTableData | (0028,1224): Segmented Alpha Palette Color Lookup Table Data
SegmentedBluePaletteColorLookupTableData | (0028,1223): Segmented Blue Palette Color Lookup Table Data
SegmentedGreenPaletteColorLookupTableData | (0028,1222): Segmented Green Palette Color Lookup Table Data
SegmentedKSpaceTraversal | (0018,9033): Segmented k-Space Traversal
SegmentedPropertyCategoryCodeSequence | (0062,0003): Segmented Property Category Code Sequence
SegmentedPropertyTypeCodeSequence | (0062,000F): Segmented Property Type Code Sequence
SegmentedPropertyTypeModifierCodeSequence | (0062,0011): Segmented Property Type Modifier Code Sequence
SegmentedRedPaletteColorLookupTableData | (0028,1221): Segmented Red Palette Color Lookup Table Data
SegmentedRTAccessoryDeviceSequence | (3010,0026): Segmented RT Accessory Device Sequence
SegmentIdentificationSequence | (0062,000A): Segment Identification Sequence
SegmentLabel | (0062,0005): Segment Label
SegmentNumber | (0062,0004): Segment Number
SegmentReferenceIndex | (3010,0022): Segment Reference Index
SegmentReferenceSequence | (3010,0021): Segment Reference Sequence
SegmentSequence | (0062,0002): Segment Sequence
SegmentsOverlap | (0062,0013): Segments Overlap
SegmentSurfaceGenerationAlgorithmIdentificationSequence | (0066,002D): Segment Surface Generation Algorithm Identification Sequence
SegmentSurfaceSourceInstanceSequence | (0066,002E): Segment Surface Source Instance Sequence
SelectedSegmentalOphthalmicAxialLengthSequence | (0022,1257): Selected Segmental Ophthalmic Axial Length Sequence
SelectedTotalOphthalmicAxialLengthSequence | (0022,1260): Selected Total Ophthalmic Axial Length Sequence
SelectorAEValue | (0072,005E): Selector AE Value
SelectorASValue | (0072,005F): Selector AS Value
SelectorAttribute | (0072,0026): Selector Attribute
SelectorAttributeKeyword | (0082,0019): Selector Attribute Keyword
SelectorAttributeName | (0082,0018): Selector Attribute Name
SelectorAttributePrivateCreator | (0072,0056): Selector Attribute Private Creator
SelectorAttributeVR | (0072,0050): Selector Attribute VR
SelectorATValue | (0072,0060): Selector AT Value
SelectorCodeSequenceValue | (0072,0080): Selector Code Sequence Value
SelectorCSValue | (0072,0062): Selector CS Value
SelectorDAValue | (0072,0061): Selector DA Value
SelectorDSValue | (0072,0072): Selector DS Value
SelectorDTValue | (0072,0063): Selector DT Value
SelectorFDValue | (0072,0074): Selector FD Value
SelectorFLValue | (0072,0076): Selector FL Value
SelectorISValue | (0072,0064): Selector IS Value
SelectorLOValue | (0072,0066): Selector LO Value
SelectorLTValue | (0072,0068): Selector LT Value
SelectorOBValue | (0072,0065): Selector OB Value
SelectorODValue | (0072,0073): Selector OD Value
SelectorOFValue | (0072,0067): Selector OF Value
SelectorOLValue | (0072,0075): Selector OL Value
SelectorOVValue | (0072,0081): Selector OV Value
SelectorOWValue | (0072,0069): Selector OW Value
SelectorPNValue | (0072,006A): Selector PN Value
SelectorSequencePointer | (0072,0052): Selector Sequence Pointer
SelectorSequencePointerItems | (0074,1057): Selector Sequence Pointer Items
SelectorSequencePointerPrivateCreator | (0072,0054): Selector Sequence Pointer Private Creator
SelectorSHValue | (0072,006C): Selector SH Value
SelectorSLValue | (0072,007C): Selector SL Value
SelectorSSValue | (0072,007E): Selector SS Value
SelectorSTValue | (0072,006E): Selector ST Value
SelectorSVValue | (0072,0082): Selector SV Value
SelectorTMValue | (0072,006B): Selector TM Value
SelectorUCValue | (0072,006F): Selector UC Value
SelectorUIValue | (0072,007F): Selector UI Value
SelectorULValue | (0072,0078): Selector UL Value
SelectorUNValue | (0072,006D): Selector UN Value
SelectorURValue | (0072,0071): Selector UR Value
SelectorUSValue | (0072,007A): Selector US Value
SelectorUTValue | (0072,0070): Selector UT Value
SelectorUVValue | (0072,0083): Selector UV Value
SelectorValueNumber | (0072,0028): Selector Value Number
SelfTimerMode | (0016,0019): Self Timer Mode
SendingApplicationEntityTitle | (0002,0017): Sending Application Entity Title
SendingPresentationAddress | (0002,0027): Sending Presentation Address
SensingMethod | (0016,0039): Sensing Method
Sensitivity | (0018,6000): Sensitivity
SensitivityCalibrated | (0018,9767): Sensitivity Calibrated
SensitivityType | (0016,001A): Sensitivity Type
SensitivityValue | (0024,0094): Sensitivity Value
SensorName | (0014,3022): Sensor Name
SensorTemperature | (0014,3028): Sensor Temperature
SequenceDelimitationItem | (FFFE,E0DD): Sequence Delimitation Item
SequenceName | (0018,0024): Sequence Name
SequenceOfCompressedData | (0028,0403): Sequence of Compressed Data
SequenceOfUltrasoundRegions | (0018,6011): Sequence of Ultrasound Regions
SequenceVariant | (0018,0021): Sequence Variant
SequencingIndicatorTrial | (0040,A060): Sequencing Indicator (Trial)
SeriesDate | (0008,0021): Series Date
SeriesDescription | (0008,103E): Series Description
SeriesDescriptionCodeSequence | (0008,103F): Series Description Code Sequence
SeriesInstanceUID | (0020,000E): Series Instance UID
SeriesInStudy | (0020,1000): Series in Study
SeriesNumber | (0020,0011): Series Number
SeriesTime | (0008,0031): Series Time
SeriesType | (0054,1000): Series Type
ServiceEpisodeDescription | (0038,0062): Service Episode Description
ServiceEpisodeID | (0038,0060): Service Episode ID
SettlingPhaseFrame | (0018,9624): Settling Phase Frame
SetupDeviceDescription | (300A,01BA): Setup Device Description
SetupDeviceLabel | (300A,01B8): Setup Device Label
SetupDeviceParameter | (300A,01BC): Setup Device Parameter
SetupDeviceSequence | (300A,01B4): Setup Device Sequence
SetupDeviceType | (300A,01B6): Setup Device Type
SetupImageComment | (300A,0402): Setup Image Comment
SetupReferenceDescription | (300A,01D0): Setup Reference Description
SetupTechnique | (300A,01B0): Setup Technique
SetupTechniqueDescription | (300A,01B2): Setup Technique Description
ShadingStyle | (0070,1701): Shading Style
ShadowColorCIELabValue | (0070,0247): Shadow Color CIELab Value
ShadowOffsetX | (0070,0245): Shadow Offset X
ShadowOffsetY | (0070,0246): Shadow Offset Y
ShadowOpacity | (0070,0258): Shadow Opacity
ShadowStyle | (0070,0244): Shadow Style
ShapeType | (0070,0306): Shape Type
SharedFunctionalGroupsSequence | (5200,9229): Shared Functional Groups Sequence
Sharpness | (0016,004A): Sharpness
ShieldingDeviceDescription | (300A,01A6): Shielding Device Description
ShieldingDeviceLabel | (300A,01A4): Shielding Device Label
ShieldingDevicePosition | (300A,01A8): Shielding Device Position
ShieldingDeviceSequence | (300A,01A0): Shielding Device Sequence
ShieldingDeviceType | (300A,01A2): Shielding Device Type
ShiftTableSize | (1000,xxx4): Shift Table Size
ShiftTableTriplet | (1000,xxx5): Shift Table Triplet
Shininess | (0070,1706): Shininess
ShortTermFluctuation | (0024,0075): Short Term Fluctuation
ShortTermFluctuationCalculated | (0024,0074): Short Term Fluctuation Calculated
ShortTermFluctuationProbability | (0024,0077): Short Term Fluctuation Probability
ShortTermFluctuationProbabilityCalculated | (0024,0076): Short Term Fluctuation Probability Calculated
ShotDurationTime | (0080,0004): Shot Duration Time
ShotOffsetTime | (0080,0005): Shot Offset Time
ShowAcquisitionTechniquesFlag | (0072,0716): Show Acquisition Techniques Flag
ShowGraphicAnnotationFlag | (0072,0712): Show Graphic Annotation Flag
ShowGrayscaleInverted | (0072,0706): Show Grayscale Inverted
ShowImageTrueSizeFlag | (0072,0710): Show Image True Size Flag
ShowPatientDemographicsFlag | (0072,0714): Show Patient Demographics Flag
ShowTickLabel | (0070,0278): Show Tick Label
ShutterLeftVerticalEdge | (0018,1602): Shutter Left Vertical Edge
ShutterLowerHorizontalEdge | (0018,1608): Shutter Lower Horizontal Edge
ShutterOverlayGroup | (0018,1623): Shutter Overlay Group
ShutterPresentationColorCIELabValue | (0018,1624): Shutter Presentation Color CIELab Value
ShutterPresentationValue | (0018,1622): Shutter Presentation Value
ShutterRightVerticalEdge | (0018,1604): Shutter Right Vertical Edge
ShutterShape | (0018,1600): Shutter Shape
ShutterSpeedValue | (0016,0021): Shutter Speed Value
ShutterUpperHorizontalEdge | (0018,1606): Shutter Upper Horizontal Edge
SignalDomainColumns | (0028,9003): Signal Domain Columns
SignalDomainRows | (0028,9235): Signal Domain Rows
SignalToNoiseRatio | (0022,1155): Signal to Noise Ratio
Signature | (0400,0120): Signature
SimpleFrameList | (0008,1161): Simple Frame List
SimulatedKeratometricCylinderSequence | (0046,0218): Simulated Keratometric Cylinder Sequence
SingleCollimationWidth | (0018,9306): Single Collimation Width
SkipBeats | (0018,1086): Skip Beats
SkipFrameRangeFlag | (0008,9460): Skip Frame Range Flag
SlabOrientation | (0018,9105): Slab Orientation
SlabThickness | (0018,9104): Slab Thickness
SliceLocation | (0020,1041): Slice Location
SliceLocationVector | (0018,2005): Slice Location Vector
SliceProgressionDirection | (0054,0500): Slice Progression Direction
SliceSensitivityFactor | (0054,1320): Slice Sensitivity Factor
SliceThickness | (0018,0050): Slice Thickness
SliceVector | (0054,0080): Slice Vector
SlideIdentifier | (0040,06FA): Slide Identifier
SmallestImagePixelValue | (0028,0106): Smallest Image Pixel Value
SmallestImagePixelValueInPlane | (0028,0110): Smallest Image Pixel Value in Plane
SmallestPixelValueInSeries | (0028,0108): Smallest Pixel Value in Series
SmallestValidPixelValue | (0028,0104): Smallest Valid Pixel Value(Retired)
SmokingStatus | (0010,21A0): Smoking Status
SmoothingType | (2010,0080): Smoothing Type
SnoutID | (300A,030F): Snout ID
SnoutPosition | (300A,030D): Snout Position
SnoutPositionTolerance | (300A,004B): Snout Position Tolerance
SnoutSequence | (300A,030C): Snout Sequence
SNRThreshold | (4010,1073): SNR Threshold
SoftcopyVOILUTSequence | (0028,3110): Softcopy VOI LUT Sequence
SoftTissueFocusThermalIndex | (0018,5028): Soft Tissue-focus Thermal Index
SoftTissueSurfaceThermalIndex | (0018,5029): Soft Tissue-surface Thermal Index
SoftTissueThermalIndex | (0018,5027): Soft Tissue Thermal Index
SoftwareVersions | (0018,1020): Software Versions
SOPAuthorizationComment | (0100,0424): SOP Authorization Comment
SOPAuthorizationDateTime | (0100,0420): SOP Authorization DateTime
SOPClassesInStudy | (0008,0062): SOP Classes in Study
SOPClassesSupported | (0008,115A): SOP Classes Supported
SOPClassUID | (0008,0016): SOP Class UID
SOPInstanceStatus | (0100,0410): SOP Instance Status
SOPInstanceUID | (0008,0018): SOP Instance UID
SOPInstanceUIDOfConcatenationSource | (0020,0242): SOP Instance UID of Concatenation Source
SortByCategory | (0072,0602): Sort-by Category
SortingDirection | (0072,0604): Sorting Direction
SortingOperationsSequence | (0072,0600): Sorting Operations Sequence
SoundPathLength | (0014,405A): Sound Path Length
SourceAcquisitionBeamNumber | (0018,9939): Source Acquisition Beam Number
SourceAcquisitionProtocolElementNumber | (0018,9938): Source Acquisition Protocol Element Number
SourceApplicationEntityTitle | (0002,0016): Source Application Entity Title
SourceApplicatorID | (300A,0291): Source Applicator ID
SourceApplicatorLength | (300A,0296): Source Applicator Length
SourceApplicatorManufacturer | (300A,0298): Source Applicator Manufacturer
SourceApplicatorName | (300A,0294): Source Applicator Name
SourceApplicatorNumber | (300A,0290): Source Applicator Number
SourceApplicatorStepSize | (300A,02A0): Source Applicator Step Size
SourceApplicatorTipLength | (300A,0274): Source Applicator Tip Length
SourceApplicatorType | (300A,0292): Source Applicator Type
SourceApplicatorWallNominalThickness | (300A,029C): Source Applicator Wall Nominal Thickness
SourceApplicatorWallNominalTransmission | (300A,029E): Source Applicator Wall Nominal Transmission
SourceAxisDistance | (300A,00B4): Source-Axis Distance
SourceConceptualVolumeSequence | (3010,0018): Source Conceptual Volume Sequence
SourceConceptualVolumeUID | (3010,0015): Source Conceptual Volume UID
SourceDescription | (300A,021C): Source Description
SourceEncapsulationNominalThickness | (300A,0222): Source Encapsulation Nominal Thickness
SourceEncapsulationNominalTransmission | (300A,0224): Source Encapsulation Nominal Transmission
SourceEndDateTime | (0018,936A): Source End DateTime
SourceFrameOfReferenceUID | (0064,0003): Source Frame of Reference UID
SourceHangingProtocolSequence | (0072,0012): Source Hanging Protocol Sequence
SourceIdentifier | (0034,0005): Source Identifier
SourceImageCornealProcessedDataSequence | (0046,0244): Source Image Corneal Processed Data Sequence
SourceImageEvidenceSequence | (0008,9154): Source Image Evidence Sequence
SourceImageIDs | (0020,31xx): Source Image IDs(Retired)
SourceImageSequence | (0008,2112): Source Image Sequence
SourceInstanceSequence | (0042,0013): Source Instance Sequence
SourceIrradiationEventSequence | (0008,3011): Source Irradiation Event Sequence
SourceIsotopeHalfLife | (300A,0228): Source Isotope Half Life
SourceIsotopeName | (300A,0226): Source Isotope Name
SourceManufacturer | (300A,0216): Source Manufacturer
SourceModelID | (300A,021B): Source Model ID
SourceMovementType | (300A,0288): Source Movement Type
SourceNumber | (300A,0212): Source Number
SourceOfAnteriorChamberDepthDataCodeSequence | (0022,1133): Source of Anterior Chamber Depth Data Code Sequence
SourceOfCornealSizeDataCodeSequence | (0022,1036): Source of Corneal Size Data Code Sequence
SourceOfCorneaMeasurementDataCodeSequence | (0046,0111): Source of Cornea Measurement Data Code Sequence
SourceOfLensThicknessDataCodeSequence | (0022,1132): Source of Lens Thickness Data Code Sequence
SourceOfOphthalmicAxialLengthCodeSequence | (0022,1035): Source of Ophthalmic Axial Length Code Sequence
SourceOfPreviousValues | (0400,0564): Source of Previous Values
SourceOfRefractiveMeasurementsCodeSequence | (0022,1135): Source of Refractive Measurements Code Sequence
SourceOfRefractiveMeasurementsSequence | (0022,1134): Source of Refractive Measurements Sequence
SourceOrientation | (4010,1060): Source Orientation
SourcePatientGroupIdentificationSequence | (0010,0026): Source Patient Group Identification Sequence
SourcePixelPlanesCharacteristicsSequence | (3006,004A): Source Pixel Planes Characteristics Sequence
SourcePosition | (4010,1061): Source Position
SourcePresentationAddress | (0002,0026): Source Presentation Address
SourceReconstructionProtocolElementNumber | (0018,993A): Source Reconstruction Protocol Element Number
SourceRollAngle | (300A,067A): Source Roll Angle
SourceSequence | (300A,0210): Source Sequence
SourceSerialNumber | (3008,0105): Source Serial Number
SourceStartDateTime | (0018,9369): Source Start DateTime
SourceStrength | (300A,022B): Source Strength
SourceStrengthReferenceDate | (300A,022C): Source Strength Reference Date
SourceStrengthReferenceTime | (300A,022E): Source Strength Reference Time
SourceStrengthUnits | (300A,0229): Source Strength Units
SourceToApplicatorMountingPositionDistance | (300A,0436): Source to Applicator Mounting Position Distance
SourceToBeamLimitingDeviceDistance | (300A,00BA): Source to Beam Limiting Device Distance
SourceToBlockTrayDistance | (300A,00F6): Source to Block Tray Distance
SourceToCompensatorDistance | (300A,02E2): Source to Compensator Distance
SourceToCompensatorTrayDistance | (300A,00E6): Source to Compensator Tray Distance
SourceToExternalContourDistance | (300A,0132): Source to External Contour Distance
SourceToGeneralAccessoryDistance | (300A,0425): Source to General Accessory Distance
SourceToPatientSurfaceDistance | (300A,0634): Source to Patient Surface Distance
SourceToReferenceObjectDistance | (3002,0028): Source to Reference Object Distance
SourceToSurfaceDistance | (300A,0130): Source to Surface Distance
SourceToWedgeTrayDistance | (300A,00DA): Source to Wedge Tray Distance
SourceType | (300A,0214): Source Type
SourceWaveformSequence | (003A,020A): Source Waveform Sequence
SpacingBetweenSlices | (0018,0088): Spacing Between Slices
SpatialFrequencyResponseColumnNames | (0016,000C): Spatial Frequency Response Column Names
SpatialFrequencyResponseColumns | (0016,000B): Spatial Frequency Response Columns
SpatialFrequencyResponseRows | (0016,000A): Spatial Frequency Response Rows
SpatialFrequencyResponseValues | (0016,000D): Spatial Frequency Response Values
SpatialLocationsPreserved | (0028,135A): Spatial Locations Preserved
SpatialPresaturation | (0018,9027): Spatial Pre-saturation
SpatialResolution | (0018,1050): Spatial Resolution
SpatialTransformOfDose | (3004,0005): Spatial Transform of Dose
SpecialNeeds | (0038,0050): Special Needs
SpecificAbsorptionRateDefinition | (0018,9179): Specific Absorption Rate Definition
SpecificAbsorptionRateSequence | (0018,9239): Specific Absorption Rate Sequence
SpecificAbsorptionRateValue | (0018,9181): Specific Absorption Rate Value
SpecificationSelectionGuidance | (0082,0033): Specification Selection Guidance
SpecificCharacterSet | (0008,0005): Specific Character Set
SpecificCharacterSetOfFileSetDescriptorFile | (0004,1142): Specific Character Set of File-set Descriptor File
SpecifiedChannelTotalTime | (3008,0132): Specified Channel Total Time
SpecifiedMeterset | (3008,0042): Specified Meterset
SpecifiedNumberOfPulses | (3008,0136): Specified Number of Pulses
SpecifiedPrimaryMeterset | (3008,0032): Specified Primary Meterset
SpecifiedPulseRepetitionInterval | (3008,013A): Specified Pulse Repetition Interval
SpecifiedSecondaryMeterset | (3008,0033): Specified Secondary Meterset
SpecifiedTreatmentTime | (3008,003A): Specified Treatment Time
SpecimenAccessionNumber | (0040,050A): Specimen Accession Number
SpecimenDescriptionSequence | (0040,0560): Specimen Description Sequence
SpecimenDescriptionSequenceTrial | (0040,0552): Specimen Description Sequence (Trial)
SpecimenDescriptionTrial | (0040,0553): Specimen Description (Trial)
SpecimenDetailedDescription | (0040,0602): Specimen Detailed Description
SpecimenIdentifier | (0040,0551): Specimen Identifier
SpecimenLabelInImage | (0048,0010): Specimen Label in Image
SpecimenLocalizationContentItemSequence | (0040,0620): Specimen Localization Content Item Sequence
SpecimenPreparationSequence | (0040,0610): Specimen Preparation Sequence
SpecimenPreparationStepContentItemSequence | (0040,0612): Specimen Preparation Step Content Item Sequence
SpecimenReferenceSequence | (0048,0110): Specimen Reference Sequence
SpecimenSequence | (0040,0550): Specimen Sequence
SpecimenShortDescription | (0040,0600): Specimen Short Description
SpecimenTypeCodeSequence | (0040,059A): Specimen Type Code Sequence
SpecimenUID | (0040,0554): Specimen UID
SpectrallySelectedExcitation | (0018,9026): Spectrally Selected Excitation
SpectrallySelectedSuppression | (0018,9025): Spectrally Selected Suppression
SpectralSensitivity | (0016,0017): Spectral Sensitivity
SpectralWidth | (0018,9052): Spectral Width
SpectroscopyAcquisitionDataColumns | (0018,9127): Spectroscopy Acquisition Data Columns
SpectroscopyAcquisitionOutOfPlanePhaseSteps | (0018,9159): Spectroscopy Acquisition Out-of-plane Phase Steps
SpectroscopyAcquisitionPhaseColumns | (0018,9234): Spectroscopy Acquisition Phase Columns
SpectroscopyAcquisitionPhaseRows | (0018,9095): Spectroscopy Acquisition Phase Rows
SpectroscopyData | (5600,0020): Spectroscopy Data
SpecularReflectionIntensity | (0070,1705): Specular Reflection Intensity
SpherePower | (0046,0146): Sphere Power
SphericalLensPower | (0022,0007): Spherical Lens Power
SpiralPitchFactor | (0018,9311): Spiral Pitch Factor
Spoiling | (0018,9016): Spoiling
StackID | (0020,9056): Stack ID
StageCodeSequence | (0040,000A): Stage Code Sequence
StageName | (0008,2120): Stage Name
StageNumber | (0008,2122): Stage Number
StandardOutputSensitivity | (0016,001B): Standard Output Sensitivity
StartAcquisitionDateTime | (0018,9516): Start Acquisition DateTime
StartAngle | (0054,0200): Start Angle
StartCardiacTriggerCountThreshold | (0018,9717): Start Cardiac Trigger Count Threshold
StartCumulativeMetersetWeight | (300C,0008): Start Cumulative Meterset Weight
StartCumulativeTimeWeight | (0074,1407): Start Cumulative Time Weight
StartDensityThreshold | (0018,9715): Start Density Threshold
StartingMetersetValueKnownFlag | (300A,0723): Starting Meterset Value Known Flag
StartingRespiratoryAmplitude | (0020,9246): Starting Respiratory Amplitude
StartingRespiratoryPhase | (0020,9247): Starting Respiratory Phase
StartMeterset | (3008,0078): Start Meterset
StartRelativeDensityDifferenceThreshold | (0018,9716): Start Relative Density Difference Threshold
StartRespiratoryTriggerCountThreshold | (0018,9718): Start Respiratory Trigger Count Threshold
StartTrim | (0008,2142): Start Trim
StationAETitle | (0008,0055): Station AE Title
StationName | (0008,1010): Station Name
Status | (0000,0900): Status
SteadyStatePulseSequence | (0018,9017): Steady State Pulse Sequence
SteepCornealAxisSequence | (0046,0112): Steep Corneal Axis Sequence
SteepKeratometricAxisSequence | (0046,0074): Steep Keratometric Axis Sequence
SteeringAngle | (0018,6036): Steering Angle
StereoBaselineAngle | (0022,0010): Stereo Baseline Angle
StereoBaselineDisplacement | (0022,0011): Stereo Baseline Displacement
StereoHorizontalPixelOffset | (0022,0012): Stereo Horizontal Pixel Offset
StereoPairsPresent | (0022,0028): Stereo Pairs Present
StereoPairsSequence | (0022,0020): Stereo Pairs Sequence
StereoRotation | (0022,0014): Stereo Rotation
StereoVerticalPixelOffset | (0022,0013): Stereo Vertical Pixel Offset
StimuliRetestingQuantity | (0024,0042): Stimuli Retesting Quantity
StimulusArea | (0024,0025): Stimulus Area
StimulusColorCodeSequence | (0024,0021): Stimulus Color Code Sequence
StimulusPresentationTime | (0024,0028): Stimulus Presentation Time
StimulusResults | (0024,0093): Stimulus Results
StopTrim | (0008,2143): Stop Trim
StorageMediaFileSetID | (0088,0130): Storage Media File-set ID
StorageMediaFileSetUID | (0088,0140): Storage Media File-set UID
StorageProtocolElementSequence | (0018,9936): Storage Protocol Element Sequence
StorageProtocolElementSpecificationSequence | (0018,9935): Storage Protocol Element Specification Sequence
StorageURL | (0040,4073): Storage URL
StoredValueColorRangeSequence | (0028,1230): Stored Value Color Range Sequence
STOWRSStorageSequence | (0040,4072): STOW-RS Storage Sequence
StrainAdditionalInformation | (0010,0218): Strain Additional Information
StrainCodeSequence | (0010,0219): Strain Code Sequence
StrainDescription | (0010,0212): Strain Description
StrainNomenclature | (0010,0213): Strain Nomenclature
StrainSource | (0010,0217): Strain Source
StrainSourceRegistryCodeSequence | (0010,0215): Strain Source Registry Code Sequence
StrainStockNumber | (0010,0214): Strain Stock Number
StrainStockSequence | (0010,0216): Strain Stock Sequence
StructuredConstraintObservationSequence | (0082,000C): Structured Constraint Observation Sequence
StructuredDisplayBackgroundCIELabValue | (0072,0420): Structured Display Background CIELab Value
StructuredDisplayImageBoxSequence | (0072,0422): Structured Display Image Box Sequence
StructuredDisplayTextBoxSequence | (0072,0424): Structured Display Text Box Sequence
StructureSetDate | (3006,0008): Structure Set Date
StructureSetDescription | (3006,0006): Structure Set Description
StructureSetLabel | (3006,0002): Structure Set Label
StructureSetName | (3006,0004): Structure Set Name
StructureSetROISequence | (3006,0020): Structure Set ROI Sequence
StructureSetTime | (3006,0009): Structure Set Time
StudiesContainingOtherReferencedInstancesSequence | (0008,1200): Studies Containing Other Referenced Instances Sequence
StudyArrivalDate | (0032,1040): Study Arrival Date
StudyArrivalTime | (0032,1041): Study Arrival Time
StudyComments | (0032,4000): Study Comments
StudyCompletionDate | (0032,1050): Study Completion Date
StudyCompletionTime | (0032,1051): Study Completion Time
StudyComponentStatusID | (0032,1055): Study Component Status ID
StudyDate | (0008,0020): Study Date
StudyDescription | (0008,1030): Study Description
StudyID | (0020,0010): Study ID
StudyIDIssuer | (0032,0012): Study ID Issuer
StudyInstanceUID | (0020,000D): Study Instance UID
StudyPriorityID | (0032,000C): Study Priority ID
StudyReadDate | (0032,0034): Study Read Date
StudyReadTime | (0032,0035): Study Read Time
StudyStatusID | (0032,000A): Study Status ID
StudyTime | (0008,0030): Study Time
StudyVerifiedDate | (0032,0032): Study Verified Date
StudyVerifiedTime | (0032,0033): Study Verified Time
SubjectArea | (0016,002A): Subject Area
SubjectDistance | (0016,0026): Subject Distance
SubjectDistanceRange | (0016,004C): Subject Distance Range
SubjectiveRefractionLeftEyeSequence | (0046,0098): Subjective Refraction Left Eye Sequence
SubjectiveRefractionRightEyeSequence | (0046,0097): Subjective Refraction Right Eye Sequence
SubjectLocation | (0016,0037): Subject Location
SubjectRelativePositionInImage | (0010,0028): Subject Relative Position in Image
SubscriptionListStatus | (0074,1244): Subscription List Status
SubstanceAdministrationApproval | (0044,0002): Substance Administration Approval
SubstanceAdministrationDateTime | (0044,0010): Substance Administration DateTime
SubstanceAdministrationDeviceID | (0044,0012): Substance Administration Device ID
SubstanceAdministrationNotes | (0044,0011): Substance Administration Notes
SubstanceAdministrationParameterSequence | (0044,0019): Substance Administration Parameter Sequence
SubtractionItemID | (0028,9416): Subtraction Item ID
SupportedImageDisplayFormatsSequence | (2000,00A8): Supported Image Display Formats Sequence
SurfaceAsymmetryIndex | (0046,0232): Surface Asymmetry Index
SurfaceComments | (0066,0004): Surface Comments
SurfaceCount | (0066,002A): Surface Count
SurfaceEntryPoint | (300A,012E): Surface Entry Point
SurfaceMeshPrimitivesSequence | (0066,0013): Surface Mesh Primitives Sequence
SurfaceMeshZPixelOffset | (0022,1658): Surface Mesh Z-Pixel Offset
SurfaceModelDescriptionSequence | (0068,6360): Surface Model Description Sequence
SurfaceModelLabel | (0068,6380): Surface Model Label
SurfaceModelScalingFactor | (0068,6390): Surface Model Scaling Factor
SurfaceNumber | (0066,0003): Surface Number
SurfacePointColorCIELabValueData | (0080,0007): Surface Point Color CIELab Value Data
SurfacePointPresentationValueData | (0080,0006): Surface Point Presentation Value Data
SurfacePointsNormalsSequence | (0066,0012): Surface Points Normals Sequence
SurfacePointsSequence | (0066,0011): Surface Points Sequence
SurfaceProcessing | (0066,0009): Surface Processing
SurfaceProcessingAlgorithmIdentificationSequence | (0066,0035): Surface Processing Algorithm Identification Sequence
SurfaceProcessingDescription | (0066,000B): Surface Processing Description
SurfaceProcessingRatio | (0066,000A): Surface Processing Ratio
SurfaceRegularityIndex | (0046,0230): Surface Regularity Index
SurfaceScanAcquisitionTypeCodeSequence | (0080,0001): Surface Scan Acquisition Type Code Sequence
SurfaceScanModeCodeSequence | (0080,0002): Surface Scan Mode Code Sequence
SurfaceSequence | (0066,0002): Surface Sequence
SurgicallyInducedAstigmatismSequence | (0022,1045): Surgically Induced Astigmatism Sequence
SurgicalTechnique | (0076,0030): Surgical Technique
SUVType | (0054,1006): SUV Type
SwitchingPhaseNominalDuration | (0018,936C): Switching Phase Nominal Duration
SwitchingPhaseNumber | (0018,936B): Switching Phase Number
SwitchingPhaseTransitionDuration | (0018,936D): Switching Phase Transition Duration
SwivelRange | (0070,1A06): Swivel Range
SynchronizationChannel | (0018,106C): Synchronization Channel
SynchronizationFrameOfReferenceUID | (0020,0200): Synchronization Frame of Reference UID
SynchronizationTrigger | (0018,106A): Synchronization Trigger
SynchronizedImageBoxList | (0072,0432): Synchronized Image Box List
SynchronizedScrollingSequence | (0072,0210): Synchronized Scrolling Sequence
SyringeCounts | (0018,1045): Syringe Counts
SystemStatus | (0028,7006): System Status
SystemStatusComment | (0028,7007): System Status Comment
T2Preparation | (0018,9021): T2 Preparation
TableAngle | (0018,1138): Table Angle
TableColumnDefinitionSequence | (0040,A807): Table Column Definition Sequence
TableColumnNumber | (0040,A805): Table Column Number
TableCradleTiltAngle | (0018,9471): Table Cradle Tilt Angle
TableFeedPerRotation | (0018,9310): Table Feed per Rotation
TableFrameOfReferenceUID | (0020,9313): Table Frame of Reference UID
TableHeadTiltAngle | (0018,9470): Table Head Tilt Angle
TableHeight | (0018,1130): Table Height
TableHorizontalRotationAngle | (0018,9469): Table Horizontal Rotation Angle
TableLateralIncrement | (0018,1136): Table Lateral Increment
TableLongitudinalIncrement | (0018,1137): Table Longitudinal Increment
TableMotion | (0018,1134): Table Motion
TableOfParameterValues | (0018,605A): Table of Parameter Values
TableOfPixelValues | (0018,6058): Table of Pixel Values
TableOfXBreakPoints | (0018,6052): Table of X Break Points
TableOfYBreakPoints | (0018,6054): Table of Y Break Points
TablePosition | (0018,9327): Table Position
TablePositionSequence | (0018,9406): Table Position Sequence
TableRowDefinitionSequence | (0040,A806): Table Row Definition Sequence
TableRowNumber | (0040,A804): Table Row Number
TableSpeed | (0018,9309): Table Speed
TableTopEccentricAdjustedAngle | (0074,102B): Table Top Eccentric Adjusted Angle
TableTopEccentricAngle | (300A,0125): Table Top Eccentric Angle
TableTopEccentricAngleTolerance | (300A,004E): Table Top Eccentric Angle Tolerance
TableTopEccentricAxisDistance | (300A,0124): Table Top Eccentric Axis Distance
TableTopEccentricRotationDirection | (300A,0126): Table Top Eccentric Rotation Direction
TableTopLateralAdjustedPosition | (0074,1028): Table Top Lateral Adjusted Position
TableTopLateralPosition | (300A,012A): Table Top Lateral Position
TableTopLateralPositionTolerance | (300A,0053): Table Top Lateral Position Tolerance
TableTopLateralSetupDisplacement | (300A,01D6): Table Top Lateral Setup Displacement
TableTopLongitudinalAdjustedPosition | (0074,1027): Table Top Longitudinal Adjusted Position
TableTopLongitudinalPosition | (300A,0129): Table Top Longitudinal Position
TableTopLongitudinalPositionTolerance | (300A,0052): Table Top Longitudinal Position Tolerance
TableTopLongitudinalSetupDisplacement | (300A,01D4): Table Top Longitudinal Setup Displacement
TableTopPitchAdjustedAngle | (0074,102C): Table Top Pitch Adjusted Angle
TableTopPitchAngle | (300A,0140): Table Top Pitch Angle
TableTopPitchAngleTolerance | (300A,004F): Table Top Pitch Angle Tolerance
TableTopPitchRotationDirection | (300A,0142): Table Top Pitch Rotation Direction
TableTopRollAdjustedAngle | (0074,102D): Table Top Roll Adjusted Angle
TableTopRollAngle | (300A,0144): Table Top Roll Angle
TableTopRollAngleTolerance | (300A,0050): Table Top Roll Angle Tolerance
TableTopRollRotationDirection | (300A,0146): Table Top Roll Rotation Direction
TableTopVerticalAdjustedPosition | (0074,1026): Table Top Vertical Adjusted Position
TableTopVerticalPosition | (300A,0128): Table Top Vertical Position
TableTopVerticalPositionTolerance | (300A,0051): Table Top Vertical Position Tolerance
TableTopVerticalSetupDisplacement | (300A,01D2): Table Top Vertical Setup Displacement
TableTraverse | (0018,1131): Table Traverse
TableType | (0018,113A): Table Type
TableVerticalIncrement | (0018,1135): Table Vertical Increment
TableXPositionToIsocenter | (0018,9466): Table X Position to Isocenter
TableYPositionToIsocenter | (0018,9467): Table Y Position to Isocenter
TableZPositionToIsocenter | (0018,9468): Table Z Position to Isocenter
TabulatedValuesSequence | (0040,A801): Tabulated Values Sequence
TagAngleFirstAxis | (0018,9019): Tag Angle First Axis
TagAngleSecondAxis | (0018,9219): Tag Angle Second Axis
Tagging | (0018,9028): Tagging
TaggingDelay | (0018,9184): Tagging Delay
TagSpacingFirstDimension | (0018,9030): Tag Spacing First Dimension
TagSpacingSecondDimension | (0018,9218): Tag Spacing Second Dimension
TagThickness | (0018,9035): Tag Thickness
TangentialPower | (0046,0250): Tangential Power
TargetExposureIndex | (0018,1412): Target Exposure Index
TargetFrameOfReferenceUID | (0018,991E): Target Frame of Reference UID
TargetLabel | (0018,2045): Target Label
TargetLuminanceCharacteristicsSequence | (0028,7008): Target Luminance Characteristics Sequence
TargetMaterialSequence | (4010,1072): Target Material Sequence
TargetMaximumDose | (300A,0027): Target Maximum Dose
TargetMaximumLuminance | (0028,701E): Target Maximum Luminance
TargetMinimumDose | (300A,0025): Target Minimum Dose
TargetMinimumLuminance | (0028,701D): Target Minimum Luminance
TargetPositionReferenceIndicator | (0020,103F): Target Position Reference Indicator
TargetPrescriptionDose | (300A,0026): Target Prescription Dose
TargetRefraction | (0022,1037): Target Refraction
TargetUID | (0018,2042): Target UID
TargetUnderdoseVolumeFraction | (300A,0028): Target Underdose Volume Fraction
TDRType | (4010,1027): TDR Type
TelephoneNumberTrial | (0040,A354): Telephone Number (Trial)
TeletherapyRadiationType | (3010,0047): Teletherapy Radiation Type
Temperature | (0016,0030): Temperature
TemplateExtensionCreatorUID | (0040,DB0D): Template Extension Creator UID
TemplateExtensionFlag | (0040,DB0B): Template Extension Flag
TemplateExtensionOrganizationUID | (0040,DB0C): Template Extension Organization UID
TemplateIdentifier | (0040,DB00): Template Identifier
TemplateLocalVersion | (0040,DB07): Template Local Version
TemplateName | (300A,0244): Template Name
TemplateNumber | (300A,0240): Template Number
TemplateType | (300A,0242): Template Type
TemplateVersion | (0040,DB06): Template Version
TemporalPositionIdentifier | (0020,0100): Temporal Position Identifier
TemporalPositionIndex | (0020,9128): Temporal Position Index
TemporalPositionSequence | (0020,9310): Temporal Position Sequence
TemporalPositionTimeOffset | (0020,930D): Temporal Position Time Offset
TemporalRangeType | (0040,A130): Temporal Range Type
TemporalRelationshipIntervalAnchor | (3010,004F): Temporal Relationship Interval Anchor
TemporalResolution | (0020,0110): Temporal Resolution
TerminalType | (0000,4010): Terminal Type(Retired)
TerminationCardiacTriggerCountThreshold | (0018,9723): Termination Cardiac Trigger Count Threshold
TerminationCountsThreshold | (0018,9719): Termination Counts Threshold
TerminationDensityThreshold | (0018,9720): Termination Density Threshold
TerminationRelativeDensityThreshold | (0018,9721): Termination Relative Density Threshold
TerminationRespiratoryTriggerCountThreshold | (0018,9724): Termination Respiratory Trigger Count Threshold
TerminationTimeThreshold | (0018,9722): Termination Time Threshold
TestImageValidation | (0028,702B): Test Image Validation
TestPatternCodeSequence | (0028,702C): Test Pattern Code Sequence
TestPointNormalsDataFlag | (0024,0057): Test Point Normals Data Flag
TestPointNormalsSequence | (0024,0058): Test Point Normals Sequence
TestResult | (0028,7029): Test Result
TestResultComment | (0028,702A): Test Result Comment
TextColorCIELabValue | (0070,0241): Text Color CIELab Value
TextComments | (4000,4000): Text Comments(Retired)
TextFormatID | (0000,5130): Text Format ID(Retired)
TextObjectSequence | (0070,0008): Text Object Sequence
TextString | (2030,0020): Text String
TextStyleSequence | (0070,0231): Text Style Sequence
TextureLabel | (0080,0009): Texture Label
TextValue | (0040,A160): Text Value
TherapeuticRoleCategoryCodeSequence | (3010,0064): Therapeutic Role Category Code Sequence
TherapeuticRoleTypeCodeSequence | (3010,0065): Therapeutic Role Type Code Sequence
TherapyDescription | (0018,0039): Therapy Description
TherapyType | (0018,0037): Therapy Type
ThreatCategory | (4010,1012): Threat Category
ThreatCategoryDescription | (4010,1013): Threat Category Description
ThreatDetectionAlgorithmAndVersion | (4010,1029): Threat Detection Algorithm and Version
ThreatROIBase | (4010,1004): Threat ROI Base
ThreatROIBitmap | (4010,1006): Threat ROI Bitmap
ThreatROIExtents | (4010,1005): Threat ROI Extents
ThreatROIVoxelSequence | (4010,1001): Threat ROI Voxel Sequence
ThreatSequence | (4010,1011): Threat Sequence
ThreeDDegreeOfFreedomAxis | (0068,6490): 3D Degree of Freedom Axis
ThreeDImplantTemplateGroupMemberMatchingAxes | (0078,0060): 3D Implant Template Group Member Matching Axes
ThreeDImplantTemplateGroupMemberMatchingPoint | (0078,0050): 3D Implant Template Group Member Matching Point
ThreeDLineCoordinates | (0068,65D0): 3D Line Coordinates
ThreeDMatingAxes | (0068,64D0): 3D Mating Axes
ThreeDMatingPoint | (0068,64C0): 3D Mating Point
ThreeDPlaneNormal | (0068,6620): 3D Plane Normal
ThreeDPlaneOrigin | (0068,6610): 3D Plane Origin
ThreeDPointCoordinates | (0068,6590): 3D Point Coordinates
ThreeDRenderingType | (0072,0520): 3D Rendering Type
ThresholdDensity | (2040,0100): Threshold Density
ThresholdSequence | (0070,1B11): Threshold Sequence
ThresholdType | (0070,1B13): Threshold Type
ThresholdValue | (0070,1B14): Threshold Value
ThresholdValueSequence | (0070,1B12): Threshold Value Sequence
TickAlignment | (0070,0274): Tick Alignment
TickLabel | (0070,0289): Tick Label
TickLabelAlignment | (0070,0279): Tick Label Alignment
TickPosition | (0070,0288): Tick Position
TIDOffset | (0028,6120): TID Offset
Time | (0040,A122): Time
TimeBasedImageSetsSequence | (0072,0030): Time Based Image Sets Sequence
TimeDistributionProtocol | (0018,1802): Time Distribution Protocol
TimeDomainFiltering | (0018,9065): Time Domain Filtering
TimeOfDocumentCreationOrVerbalTransactionTrial | (0040,A112): Time of Document Creation or Verbal Transaction (Trial)
TimeOfFlightContrast | (0018,9015): Time of Flight Contrast
TimeOfFlightInformationUsed | (0018,9755): Time of Flight Information Used
TimeOfFrameGroupSequence | (0034,000D): Time of Frame Group Sequence
TimeOfGainCalibration | (0014,3077): Time of Gain Calibration
TimeOfLastCalibration | (0018,1201): Time of Last Calibration
TimeOfLastDetectorCalibration | (0018,700E): Time of Last Detector Calibration
TimeOfSecondaryCapture | (0018,1014): Time of Secondary Capture
TimeRange | (0008,1163): Time Range
TimeSeriesBlending | (0070,1B07): Time Series Blending
TimeSliceVector | (0054,0100): Time Slice Vector
TimeSlotInformationSequence | (0054,0072): Time Slot Information Sequence
TimeSlotNumber | (0020,0017): Time Slot Number
TimeSlotTime | (0054,0073): Time Slot Time
TimeSlotVector | (0054,0070): Time Slot Vector
TimeSource | (0018,1801): Time Source
TimezoneOffsetFromUTC | (0008,0201): Timezone Offset From UTC
TIPType | (4010,1039): TIP Type
TissueHeterogeneityCorrection | (3004,0014): Tissue Heterogeneity Correction
TMLinePositionX0 | (0018,603D): TM-Line Position X0
TMLinePositionX0Retired | (0018,603C): TM-Line Position X0 (Retired)
TMLinePositionX1 | (0018,6041): TM-Line Position X1
TMLinePositionX1Retired | (0018,6040): TM-Line Position X1 (Retired)
TMLinePositionY0 | (0018,603F): TM-Line Position Y0
TMLinePositionY0Retired | (0018,603E): TM-Line Position Y0 (Retired)
TMLinePositionY1 | (0018,6043): TM-Line Position Y1
TMLinePositionY1Retired | (0018,6042): TM-Line Position Y1 (Retired)
ToleranceTableLabel | (300A,0043): Tolerance Table Label
ToleranceTableNumber | (300A,0042): Tolerance Table Number
ToleranceTableSequence | (300A,0040): Tolerance Table Sequence
ToleranceValue | (300A,062C): Tolerance Value
TomoAngle | (0018,1470): Tomo Angle
TomoClass | (0018,1491): Tomo Class
TomoLayerHeight | (0018,1460): Tomo Layer Height
TomotherapeuticControlPointSequence | (3010,0098): Tomotherapeutic Control Point Sequence
TomotherapeuticLeafInitialClosedDurations | (3010,009A): Tomotherapeutic Leaf Initial Closed Durations
TomotherapeuticLeafOpenDurations | (3010,0099): Tomotherapeutic Leaf Open Durations
TomoTime | (0018,1480): Tomo Time
TomoType | (0018,1490): Tomo Type
TopicAuthor | (0088,0910): Topic Author
TopicKeywords | (0088,0912): Topic Keywords
TopicSubject | (0088,0906): Topic Subject
TopicTitle | (0088,0904): Topic Title
TopLeftHandCornerOfLocalizerArea | (0048,0201): Top Left Hand Corner of Localizer Area
ToricIOLPowerForExactEmmetropiaSequence | (0022,104A): Toric IOL Power for Exact Emmetropia Sequence
ToricIOLPowerForExactTargetRefractionSequence | (0022,104B): Toric IOL Power for Exact Target Refraction Sequence
ToricIOLPowerSequence | (0022,1047): Toric IOL Power Sequence
TotalAperture | (0014,5101): Total Aperture
TotalBlockTrayFactor | (300A,00F2): Total Block Tray Factor
TotalBlockTrayWaterEquivalentThickness | (300A,00F3): Total Block Tray Water-Equivalent Thickness
TotalCollimationWidth | (0018,9307): Total Collimation Width
TotalCompensatorTrayFactor | (300A,00E2): Total Compensator Tray Factor
TotalCompensatorTrayWaterEquivalentThickness | (300A,02E3): Total Compensator Tray Water-Equivalent Thickness
TotalGain | (0018,5040): Total Gain(Retired)
TotalNumberOfExposures | (0040,0301): Total Number of Exposures
TotalNumberOfPiecesOfMediaCreated | (2200,000B): Total Number of Pieces of Media Created
TotalPixelMatrixColumns | (0048,0006): Total Pixel Matrix Columns
TotalPixelMatrixFocalPlanes | (0048,0303): Total Pixel Matrix Focal Planes
TotalPixelMatrixOriginSequence | (0048,0008): Total Pixel Matrix Origin Sequence
TotalPixelMatrixRows | (0048,0007): Total Pixel Matrix Rows
TotalPrescriptionDose | (300C,0115): Total Prescription Dose
TotalProcessingTime | (4010,1069): Total Processing Time
TotalReferenceAirKerma | (300A,0250): Total Reference Air Kerma
TotalTime | (50xx,200A): Total Time
TotalTimeOfFluoroscopy | (0040,0300): Total Time of Fluoroscopy
TotalWedgeTrayWaterEquivalentThickness | (300A,00D7): Total Wedge Tray Water-Equivalent Thickness
TrackingAlgorithmIdentificationSequence | (0066,0104): Tracking Algorithm Identification Sequence
TrackingID | (0062,0020): Tracking ID
TrackingUID | (0062,0021): Tracking UID
TrackPointIndexList | (0066,0129): Track Point Index List
TrackSequence | (0066,0102): Track Sequence
TrackSetAnatomicalTypeCodeSequence | (0066,0108): Track Set Anatomical Type Code Sequence
TrackSetDescription | (0066,0107): Track Set Description
TrackSetLabel | (0066,0106): Track Set Label
TrackSetNumber | (0066,0105): Track Set Number
TrackSetSequence | (0066,0101): Track Set Sequence
TrackSetStatisticsSequence | (0066,0124): Track Set Statistics Sequence
TrackStatisticsSequence | (0066,0130): Track Statistics Sequence
TransactionUID | (0008,1195): Transaction UID
TransducerApplicationCodeSequence | (0018,980F): Transducer Application Code Sequence
TransducerBeamSteeringCodeSequence | (0018,980E): Transducer Beam Steering Code Sequence
TransducerData | (0018,5010): Transducer Data
TransducerFrequency | (0018,6030): Transducer Frequency
TransducerGeometryCodeSequence | (0018,980D): Transducer Geometry Code Sequence
TransducerIdentificationSequence | (0018,5011): Transducer Identification Sequence
TransducerOrientation | (0008,2204): Transducer Orientation
TransducerOrientationModifierSequence | (0008,2246): Transducer Orientation Modifier Sequence
TransducerOrientationSequence | (0008,2244): Transducer Orientation Sequence
TransducerPosition | (0008,2200): Transducer Position
TransducerPositionModifierSequence | (0008,2242): Transducer Position Modifier Sequence
TransducerPositionSequence | (0008,2240): Transducer Position Sequence
TransducerScanPatternCodeSequence | (0018,9809): Transducer Scan Pattern Code Sequence
TransducerType | (0018,6031): Transducer Type
TransferSyntaxUID | (0002,0010): Transfer Syntax UID
TransferTubeLength | (300A,02A4): Transfer Tube Length
TransferTubeNumber | (300A,02A2): Transfer Tube Number
TransformationAlgorithmSequence | (0022,1513): Transformation Algorithm Sequence
TransformationMethodCodeSequence | (0022,1512): Transformation Method Code Sequence
TransformDescription | (0014,2222): Transform Description
TransformedAxisUnits | (0014,2228): Transformed Axis Units
TransformLabel | (0028,0400): Transform Label
TransformNumberOfAxes | (0014,2224): Transform Number of Axes
TransformOrderOfAxes | (0014,2226): Transform Order of Axes
TransformVersionNumber | (0028,0401): Transform Version Number
TranslationRateX | (0014,409C): Translation Rate X
TranslationRateY | (0014,409D): Translation Rate Y
TransmitCoilManufacturerName | (0018,9050): Transmit Coil Manufacturer Name
TransmitCoilName | (0018,1251): Transmit Coil Name
TransmitCoilType | (0018,9051): Transmit Coil Type
TransmitterFrequency | (0018,9098): Transmitter Frequency
TransmitTransducerSequence | (0014,4010): Transmit Transducer Sequence
TransmitTransducerSettingsSequence | (0014,4050): Transmit Transducer Settings Sequence
TransportClassification | (4010,1067): Transport Classification
TransverseDetectorSeparation | (0018,9726): Transverse Detector Separation
TransverseMash | (0054,1202): Transverse Mash
TrayAccessoryCode | (300A,0355): Tray Accessory Code
TreatmentControlPointDate | (3008,0024): Treatment Control Point Date
TreatmentControlPointTime | (3008,0025): Treatment Control Point Time
TreatmentDate | (3008,0250): Treatment Date
TreatmentDeliveryContinuationFlag | (300A,0708): Treatment Delivery Continuation Flag
TreatmentDeliveryType | (300A,00CE): Treatment Delivery Type
TreatmentDeviceIdentificationSequence | (300A,063A): Treatment Device Identification Sequence
TreatmentMachineName | (300A,00B2): Treatment Machine Name
TreatmentMachineSequence | (300A,0206): Treatment Machine Sequence
TreatmentMachineSpecialModeCodeSequence | (300A,0635): Treatment Machine Special Mode Code Sequence
TreatmentPositionGroupLabel | (300A,0608): Treatment Position Group Label
TreatmentPositionGroupSequence | (300A,060A): Treatment Position Group Sequence
TreatmentPositionGroupUID | (300A,0609): Treatment Position Group UID
TreatmentPositionIndex | (300A,0606): Treatment Position Index
TreatmentPositionSequence | (300A,063F): Treatment Position Sequence
TreatmentProtocols | (300A,0009): Treatment Protocols
TreatmentRecordContentOrigin | (300A,0709): Treatment Record Content Origin
TreatmentSessionApplicationSetupSequence | (3008,0110): Treatment Session Application Setup Sequence
TreatmentSessionBeamSequence | (3008,0020): Treatment Session Beam Sequence
TreatmentSessionIonBeamSequence | (3008,0021): Treatment Session Ion Beam Sequence
TreatmentSessionUID | (300A,0700): Treatment Session UID
TreatmentSite | (3010,0077): Treatment Site
TreatmentSiteCodeSequence | (3010,0078): Treatment Site Code Sequence
TreatmentSiteModifierCodeSequence | (3010,0089): Treatment Site Modifier Code Sequence
TreatmentSites | (300A,000B): Treatment Sites
TreatmentStatusComment | (3008,0202): Treatment Status Comment
TreatmentSummaryCalculatedDoseReferenceSequence | (3008,0050): Treatment Summary Calculated Dose Reference Sequence
TreatmentSummaryMeasuredDoseReferenceSequence | (3008,00E0): Treatment Summary Measured Dose Reference Sequence
TreatmentTechniqueNotes | (3010,007A): Treatment Technique Notes
TreatmentTerminationCode | (3008,002B): Treatment Termination Code
TreatmentTerminationDescription | (300A,0730): Treatment Termination Description
TreatmentTerminationStatus | (3008,002A): Treatment Termination Status
TreatmentTime | (3008,0251): Treatment Time
TreatmentTimeLimit | (300A,062E): Treatment Time Limit
TreatmentToleranceViolationAttributeSequence | (300A,0733): Treatment Tolerance Violation Attribute Sequence
TreatmentToleranceViolationCategory | (300A,0732): Treatment Tolerance Violation Category
TreatmentToleranceViolationCauseCodeSequence | (300A,0762): Treatment Tolerance Violation Cause Code Sequence
TreatmentToleranceViolationDateTime | (300A,0736): Treatment Tolerance Violation DateTime
TreatmentToleranceViolationDescription | (300A,0734): Treatment Tolerance Violation Description
TreatmentToleranceViolationIdentification | (300A,0735): Treatment Tolerance Violation Identification
TreatmentToleranceViolationSequence | (300A,0731): Treatment Tolerance Violation Sequence
TreatmentToleranceViolationTypeCodeSequence | (300A,0761): Treatment Tolerance Violation Type Code Sequence
TreatmentVerificationStatus | (3008,002C): Treatment Verification Status
TriangleFanSequence | (0066,0027): Triangle Fan Sequence
TrianglePointIndexList | (0066,0023): Triangle Point Index List
TriangleStripSequence | (0066,0026): Triangle Strip Sequence
TriggerSamplePosition | (0018,106E): Trigger Sample Position
TriggerSourceOrType | (0018,1061): Trigger Source or Type
TriggerTime | (0018,1060): Trigger Time
TriggerTimeOffset | (0018,1069): Trigger Time Offset
TriggerVector | (0054,0210): Trigger Vector
TriggerWindow | (0018,1094): Trigger Window
Trim | (2010,0140): Trim
TubeAngle | (0018,9303): Tube Angle
TwoDDegreeOfFreedomAxis | (0068,64F0): 2D Degree of Freedom Axis
TwoDDegreeOfFreedomSequence | (0068,6470): 2D Degree of Freedom Sequence
TwoDimensionalToThreeDimensionalMapData | (0022,1531): Two Dimensional to Three Dimensional Map Data
TwoDimensionalToThreeDimensionalMapSequence | (0022,1518): Two Dimensional to Three Dimensional Map Sequence
TwoDImplantTemplateGroupMemberMatchingAxes | (0078,00A0): 2D Implant Template Group Member Matching Axes
TwoDImplantTemplateGroupMemberMatchingPoint | (0078,0090): 2D Implant Template Group Member Matching Point
TwoDLineCoordinates | (0068,65B0): 2D Line Coordinates
TwoDLineCoordinatesSequence | (0068,65A0): 2D Line Coordinates Sequence
TwoDMatingAxes | (0068,6460): 2D Mating Axes
TwoDMatingFeatureCoordinatesSequence | (0068,6430): 2D Mating Feature Coordinates Sequence
TwoDMatingPoint | (0068,6450): 2D Mating Point
TwoDPlaneCoordinatesSequence | (0068,65E0): 2D Plane Coordinates Sequence
TwoDPlaneIntersection | (0068,65F0): 2D Plane Intersection
TwoDPointCoordinates | (0068,6560): 2D Point Coordinates
TwoDPointCoordinatesSequence | (0068,6550): 2D Point Coordinates Sequence
TypeOfData | (50xx,0020): Type of Data
TypeOfDetectorMotion | (0054,0202): Type of Detector Motion
TypeOfFilters | (0018,1161): Type of Filters
TypeOfInstances | (0040,E020): Type of Instances
TypeOfOpticalCorrection | (0022,1046): Type of Optical Correction
TypeOfPatientID | (0010,0022): Type of Patient ID
TypeOfSynchronization | (0072,0434): Type of Synchronization
UDISequence | (0018,100A): UDI Sequence
UID | (0040,A124): UID
UltrasoundAcquisitionGeometry | (0020,9307): Ultrasound Acquisition Geometry
UltrasoundColorDataPresent | (0028,0014): Ultrasound Color Data Present
UltrasoundOphthalmicAxialLengthMeasurementsSequence | (0022,1220): Ultrasound Ophthalmic Axial Length Measurements Sequence
UltrasoundSelectedOphthalmicAxialLengthSequence | (0022,1230): Ultrasound Selected Ophthalmic Axial Length Sequence
UnassignedPerFrameConvertedAttributesSequence | (0020,9171): Unassigned Per-Frame Converted Attributes Sequence
UnassignedSharedConvertedAttributesSequence | (0020,9170): Unassigned Shared Converted Attributes Sequence
Underlined | (0070,0248): Underlined
UnformattedTextValue | (0070,0006): Unformatted Text Value
UnifiedProcedureStepListStatus | (0074,1246): Unified Procedure Step List Status
UnifiedProcedureStepPerformedProcedureSequence | (0074,1216): Unified Procedure Step Performed Procedure Sequence
UniformResourceLocatorTrial | (0040,A992): Uniform Resource Locator (Trial)
UniqueDeviceIdentifier | (0018,1009): Unique Device Identifier
Units | (0054,1001): Units
UniversalEntityID | (0040,0032): Universal Entity ID
UniversalEntityIDType | (0040,0033): Universal Entity ID Type
UnspecifiedLateralityLensSequence | (0046,0016): Unspecified Laterality Lens Sequence
UpperLimitNumberOfPersistentFluoroscopyFrames | (0018,11B5): Upper Limit Number Of Persistent Fluoroscopy Frames
UpperLowerPixelValues | (0018,1240): Upper/Lower Pixel Values(Retired)
UrgencyOrPriorityAlertsTrial | (0040,A057): Urgency or Priority Alerts (Trial)
URNCodeValue | (0008,0120): URN Code Value
UsedFiducialsSequence | (0070,0314): Used Fiducials Sequence
UsedSegmentsSequence | (0062,0012): Used Segments Sequence
UserContentLabel | (3010,0033): User Content Label
UserContentLongLabel | (3010,0034): User Content Long Label
UserSelectedGainY | (0014,408B): User Selected Gain Y
UserSelectedOffsetX | (0014,408D): User Selected Offset X
UserSelectedOffsetY | (0014,408E): User Selected Offset Y
UserSelectedPhase | (0014,408C): User Selected Phase
USImageDescriptionSequence | (0018,9806): US Image Description Sequence
UValueData | (0080,0010): U Value Data
UVMappingSequence | (0080,0008): UV Mapping Sequence
ValueType | (0040,A040): Value Type
VariableCoefficientsSDDN | (7Fxx,0040): Variable Coefficients SDDN
VariableCoefficientsSDHN | (7Fxx,0030): Variable Coefficients SDHN
VariableCoefficientsSDVN | (7Fxx,0020): Variable Coefficients SDVN
VariableFlipAngleFlag | (0018,1315): Variable Flip Angle Flag
VariableNextDataGroup | (7Fxx,0011): Variable Next Data Group
VariablePixelData | (7Fxx,0010): Variable Pixel Data
VectorAccuracy | (0066,0020): Vector Accuracy
VectorCoordinateData | (0066,0021): Vector Coordinate Data
VectorDimensionality | (0066,001F): Vector Dimensionality
VectorGridData | (0064,0009): Vector Grid Data
VelocityEncodingAcquisitionSequence | (0018,9092): Velocity Encoding Acquisition Sequence
VelocityEncodingDirection | (0018,9090): Velocity Encoding Direction
VelocityEncodingMaximumValue | (0018,9217): Velocity Encoding Maximum Value
VelocityEncodingMinimumValue | (0018,9091): Velocity Encoding Minimum Value
VelocityOfSound | (0014,4064): Velocity of Sound
VerbalSourceIdentifierCodeSequenceTrial | (0040,A358): Verbal Source Identifier Code Sequence (Trial)
VerbalSourceTrial | (0040,A352): Verbal Source (Trial)
VerificationDateTime | (0040,A030): Verification DateTime
VerificationFlag | (0040,A493): Verification Flag
VerificationImageTiming | (0074,1032): Verification Image Timing
VerifyingObserverIdentificationCodeSequence | (0040,A088): Verifying Observer Identification Code Sequence
VerifyingObserverName | (0040,A075): Verifying Observer Name
VerifyingObserverSequence | (0040,A073): Verifying Observer Sequence
VerifyingOrganization | (0040,A027): Verifying Organization
VertexPointIndexList | (0066,0025): Vertex Point Index List
VerticalAlignment | (0070,0243): Vertical Alignment
VerticalOffsetOfSensor | (0014,3026): Vertical Offset of Sensor
VerticalPrismBase | (0046,0036): Vertical Prism Base
VerticalPrismPower | (0046,0034): Vertical Prism Power
VerticesOfTheOutlineOfPupil | (0046,0208): Vertices of the Outline of Pupil
VerticesOfThePolygonalCollimator | (0018,1720): Vertices of the Polygonal Collimator
VerticesOfThePolygonalExposureControlSensingRegion | (0018,9442): Vertices of the Polygonal Exposure Control Sensing Region
VerticesOfThePolygonalOutline | (0018,1638): Vertices of the Polygonal Outline
VerticesOfThePolygonalShutter | (0018,1620): Vertices of the Polygonal Shutter
VerticesOfTheRegion | (0028,9503): Vertices of the Region
VideoImageFormatAcquired | (0018,1022): Video Image Format Acquired
ViewCodeSequence | (0054,0220): View Code Sequence
ViewingDistance | (0046,0106): Viewing Distance
ViewingDistanceType | (0046,0125): Viewing Distance Type
ViewModifierCodeSequence | (0054,0222): View Modifier Code Sequence
ViewName | (0008,2127): View Name
ViewNumber | (0008,2128): View Number
ViewOrientationCodeSequence | (0068,62E0): View Orientation Code Sequence
ViewOrientationModifierCodeSequence | (0068,62F0): View Orientation Modifier Code Sequence
ViewpointLookAtPoint | (0070,1604): Viewpoint LookAt Point
ViewpointPosition | (0070,1603): Viewpoint Position
ViewpointUpDirection | (0070,1605): Viewpoint Up Direction
ViewPosition | (0018,5101): View Position
VirtualSourceAxisDistances | (300A,030A): Virtual Source-Axis Distances
VisitComments | (0038,4000): Visit Comments
VisitStatusID | (0038,0008): Visit Status ID
VisualAcuityBothEyesOpenSequence | (0046,0124): Visual Acuity Both Eyes Open Sequence
VisualAcuityLeftEyeSequence | (0046,0123): Visual Acuity Left Eye Sequence
VisualAcuityMeasurementSequence | (0024,0110): Visual Acuity Measurement Sequence
VisualAcuityModifiers | (0046,0135): Visual Acuity Modifiers
VisualAcuityRightEyeSequence | (0046,0122): Visual Acuity Right Eye Sequence
VisualAcuityTypeCodeSequence | (0046,0121): Visual Acuity Type Code Sequence
VisualEvaluationMethodCodeSequence | (0028,702E): Visual Evaluation Method Code Sequence
VisualEvaluationResultSequence | (0028,7015): Visual Evaluation Result Sequence
VisualEvaluationTestSequence | (0028,7028): Visual Evaluation Test Sequence
VisualFieldCatchTrialSequence | (0024,0034): Visual Field Catch Trial Sequence
VisualFieldGlobalResultsIndexSequence | (0024,0320): Visual Field Global Results Index Sequence
VisualFieldHorizontalExtent | (0024,0010): Visual Field Horizontal Extent
VisualFieldMeanSensitivity | (0024,0070): Visual Field Mean Sensitivity
VisualFieldShape | (0024,0012): Visual Field Shape
VisualFieldTestDuration | (0024,0088): Visual Field Test Duration
VisualFieldTestNormalsFlag | (0024,0063): Visual Field Test Normals Flag
VisualFieldTestPointNormalsSequence | (0024,0097): Visual Field Test Point Normals Sequence
VisualFieldTestPointSequence | (0024,0089): Visual Field Test Point Sequence
VisualFieldTestPointXCoordinate | (0024,0090): Visual Field Test Point X-Coordinate
VisualFieldTestPointYCoordinate | (0024,0091): Visual Field Test Point Y-Coordinate
VisualFieldTestReliabilityGlobalIndexSequence | (0024,0317): Visual Field Test Reliability Global Index Sequence
VisualFieldVerticalExtent | (0024,0011): Visual Field Vertical Extent
VitalStainCodeSequenceTrial | (0040,09F8): Vital Stain Code Sequence (Trial)
VitreousStatusCodeSequence | (0022,1025): Vitreous Status Code Sequence
VitreousStatusDescription | (0022,1066): Vitreous Status Description
VOILUTFunction | (0028,1056): VOI LUT Function
VOILUTSequence | (0028,3010): VOI LUT Sequence
VOIType | (0072,0702): VOI Type
VolumeBasedCalculationTechnique | (0008,9207): Volume Based Calculation Technique
VolumeCroppingMethod | (0070,1302): Volume Cropping Method
VolumeCroppingSequence | (0070,1301): Volume Cropping Sequence
VolumeFrameOfReferenceUID | (0020,9312): Volume Frame of Reference UID
VolumeLocalizationSequence | (0018,9126): Volume Localization Sequence
VolumeLocalizationTechnique | (0018,9054): Volume Localization Technique
VolumeOfPTO | (4010,1023): Volume of PTO
VolumeStreamSequence | (0070,1A08): Volume Stream Sequence
VolumeToTableMappingMatrix | (0020,930A): Volume to Table Mapping Matrix
VolumeToTransducerMappingMatrix | (0020,9309): Volume to Transducer Mapping Matrix
VolumeToTransducerRelationship | (0020,930B): Volume to Transducer Relationship
VolumetricAnnotationSequence | (0070,1901): Volumetric Annotation Sequence
VolumetricCurvePoints | (0070,150D): Volumetric Curve Points
VolumetricCurveUpDirections | (0070,1A07): Volumetric Curve Up Directions
VolumetricPresentationInputAnnotationSequence | (0070,1905): Volumetric Presentation Input Annotation Sequence
VolumetricPresentationInputIndex | (0070,1804): Volumetric Presentation Input Index
VolumetricPresentationInputNumber | (0070,1207): Volumetric Presentation Input Number
VolumetricPresentationInputSetSequence | (0070,120A): Volumetric Presentation Input Set Sequence
VolumetricPresentationInputSetUID | (0070,1209): Volumetric Presentation Input Set UID
VolumetricPresentationStateInputSequence | (0070,1201): Volumetric Presentation State Input Sequence
VolumetricProperties | (0008,9206): Volumetric Properties
VValueData | (0080,0011): V Value Data
WADORetrievalSequence | (0040,E023): WADO Retrieval Sequence
WADORSRetrievalSequence | (0040,E025): WADO-RS Retrieval Sequence
WarningReason | (0008,1196): Warning Reason
WaterDepth | (0016,0033): Water Depth
WaterEquivalentDiameter | (0018,1271): Water Equivalent Diameter
WaterEquivalentDiameterCalculationMethodCodeSequence | (0018,1272): Water Equivalent Diameter Calculation Method Code Sequence
WaterReferenceAcquisition | (0018,9297): Water Reference Acquisition
WaterReferencedPhaseCorrection | (0018,9199): Water Referenced Phase Correction
WaveformAnnotationSequence | (0040,B020): Waveform Annotation Sequence
WaveformBitsAllocated | (5400,1004): Waveform Bits Allocated
WaveformBitsStored | (003A,021A): Waveform Bits Stored
WaveformChannelNumber | (003A,0202): Waveform Channel Number
WaveformData | (5400,1010): Waveform Data
WaveformDataDisplayScale | (003A,0230): Waveform Data Display Scale
WaveformDisplayBackgroundCIELabValue | (003A,0231): Waveform Display Background CIELab Value
WaveformOriginality | (003A,0004): Waveform Originality
WaveformPaddingValue | (5400,100A): Waveform Padding Value
WaveformPresentationGroupSequence | (003A,0240): Waveform Presentation Group Sequence
WaveformSampleInterpretation | (5400,1006): Waveform Sample Interpretation
WaveformSequence | (5400,0100): Waveform Sequence
WedgeAngle | (300A,00D5): Wedge Angle
WedgeAngleFloat | (0014,5107): Wedge Angle Float
WedgeChamferHeight | (0014,511D): Wedge Chamfer Height
WedgeCurve | (0014,511E): Wedge Curve
WedgeDefinitionSequence | (300A,0651): Wedge Definition Sequence
WedgeDescription | (0014,5111): Wedge Description
WedgeElement1Position | (0014,5109): Wedge Element 1 Position
WedgeFactor | (300A,00D6): Wedge Factor
WedgeFrontGap | (0014,5117): Wedge Front Gap
WedgeFrontHeight | (0014,5119): Wedge Front Height
WedgeID | (300A,00D4): Wedge ID
WedgeInContactLength | (0014,5116): Wedge In Contact Length
WedgeInContactWidth | (0014,511C): Wedge In Contact Width
WedgeManufacturerName | (0014,5110): Wedge Manufacturer Name
WedgeMaterial | (0014,510B): Wedge Material
WedgeMaterialVelocity | (0014,510A): Wedge Material Velocity
WedgeModelNumber | (0014,5106): Wedge Model Number
WedgeName | (0014,510F): Wedge Name
WedgeNumber | (300A,00D2): Wedge Number
WedgeOffsetX | (0014,5113): Wedge Offset X
WedgeOffsetY | (0014,5114): Wedge Offset Y
WedgeOffsetZ | (0014,510C): Wedge Offset Z
WedgeOrientation | (300A,00D8): Wedge Orientation
WedgeOriginOffsetX | (0014,510D): Wedge Origin Offset X
WedgePosition | (300A,0118): Wedge Position
WedgePositionSequence | (300A,0116): Wedge Position Sequence
WedgeRearHeight | (0014,511A): Wedge Rear Height
WedgeRoofAngle | (0014,5108): Wedge Roof Angle
WedgeSequence | (300A,00D1): Wedge Sequence
WedgeThinEdgePosition | (300A,00DB): Wedge Thin Edge Position
WedgeTimeDelay | (0014,510E): Wedge Time Delay
WedgeTotalHeight | (0014,5118): Wedge Total Height
WedgeTotalLength | (0014,5115): Wedge Total Length
WedgeTotalWidth | (0014,511B): Wedge Total Width
WedgeType | (300A,00D3): Wedge Type
WeekdayFractionPatternSequence | (3010,0087): Weekday Fraction Pattern Sequence
WeightingLookupTableData | (0070,1808): Weighting Lookup Table Data
WeightingLookupTableDescriptor | (0070,1807): Weighting Lookup Table Descriptor
WeightingTransferFunctionSequence | (0070,1806): Weighting Transfer Function Sequence
WhiteBalance | (0016,0043): White Balance
WhitePoint | (0016,0001): White Point
WhitePointFlag | (0028,7021): White Point Flag
WholeBodyTechnique | (0018,1301): Whole Body Technique
WholeSlideMicroscopyImageFrameTypeSequence | (0040,0710): Whole Slide Microscopy Image Frame Type Sequence
WideFieldOphthalmicPhotographyQualityRatingSequence | (0022,1525): Wide Field Ophthalmic Photography Quality Rating Sequence
WideFieldOphthalmicPhotographyQualityThresholdSequence | (0022,1526): Wide Field Ophthalmic Photography Quality Threshold Sequence
WideFieldOphthalmicPhotographyThresholdQualityRating | (0022,1527): Wide Field Ophthalmic Photography Threshold Quality Rating
WindowCenter | (0028,1050): Window Center
WindowCenterWidthExplanation | (0028,1055): Window Center & Width Explanation
WindowWidth | (0028,1051): Window Width
WorklistLabel | (0074,1202): Worklist Label
XAAcquisitionDuration | (0018,11BD): XA Acquisition Duration
XAAcquisitionFrameRate | (0018,11B9): XA Acquisition Frame Rate
XAAcquisitionPhaseDetailsSequence | (0018,11B8): XA Acquisition Phase Details Sequence
XAPlaneDetailsSequence | (0018,11BA): XA Plane Details Sequence
XAXRFFrameCharacteristicsSequence | (0018,9412): XA/XRF Frame Characteristics Sequence
XCoordinatesCenterPixelViewAngle | (0022,1528): X Coordinates Center Pixel View Angle
XDSRetrievalSequence | (0040,E024): XDS Retrieval Sequence
XDSStorageSequence | (0040,4074): XDS Storage Sequence
XFocusCenter | (0018,1183): X Focus Center
XOffsetInSlideCoordinateSystem | (0040,072A): X Offset in Slide Coordinate System
XRay3DAcquisitionSequence | (0018,9507): X-Ray 3D Acquisition Sequence
XRay3DFrameTypeSequence | (0018,9504): X-Ray 3D Frame Type Sequence
XRay3DReconstructionSequence | (0018,9530): X-Ray 3D Reconstruction Sequence
XRayAcquisitionDoseSequence | (0018,9542): X-Ray Acquisition Dose Sequence
XRayDetectorID | (0018,9371): X-Ray Detector ID
XRayDetectorIndex | (0018,9370): X-Ray Detector Index
XRayDetectorLabel | (0018,9373): X-Ray Detector Label
XRayFilterDetailsSequence | (0018,11BC): X-Ray Filter Details Sequence
XRayFilterSequence | (0018,9556): X-Ray Filter Sequence
XRayGeometrySequence | (0018,9476): X-Ray Geometry Sequence
XRayGridSequence | (0018,9555): X-Ray Grid Sequence
XRayImageReceptorAngle | (3002,000E): X-Ray Image Receptor Angle
XRayImageReceptorTranslation | (3002,000D): X-Ray Image Receptor Translation
XRayMassAttenuationCoefficient | (0018,9384): X-Ray Mass Attenuation Coefficient
XRayOutput | (0040,0312): X-Ray Output
XRayReceptorType | (0018,9420): X-Ray Receptor Type
XRaySourceID | (0018,9367): X-Ray Source ID
XRaySourceIndex | (0018,9366): X-Ray Source Index
XRaySourceIsocenterPrimaryAngle | (0018,9543): X-Ray Source Isocenter Primary Angle
XRaySourceIsocenterSecondaryAngle | (0018,9544): X-Ray Source Isocenter Secondary Angle
XRayTubeCurrent | (0018,1151): X-Ray Tube Current
XRayTubeCurrentInmA | (0018,9330): X-Ray Tube Current in mA
XRayTubeCurrentInuA | (0018,8151): X-Ray Tube Current in µA
YCoordinatesCenterPixelViewAngle | (0022,1529): Y Coordinates Center Pixel View Angle
YFocusCenter | (0018,1184): Y Focus Center
YOffsetInSlideCoordinateSystem | (0040,073A): Y Offset in Slide Coordinate System
ZEffective | (4010,1019): Z Effective
ZeroVelocityPixelValue | (0018,9810): Zero Velocity Pixel Value
ZOffsetInSlideCoordinateSystem | (0040,074A): Z Offset in Slide Coordinate System
ZonalMap | (1010,xxxx): Zonal Map
ZonalMapFormat | (0028,0722): Zonal Map Format
ZonalMapLocation | (0028,0721): Zonal Map Location
ZonalMapNumberFormat | (0028,0720): Zonal Map Number Format
ZoomCenter | (0028,0032): Zoom Center
ZoomFactor | (0028,0031): Zoom Factor
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.Keyword

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


LabelType Enumeration

LabelType Enumeration

DicomObjects.Enums Namespace : LabelType Enumeration
The possible types of DicomObjects.DicomLabel
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum LabelType
   Inherits System.Enum
'Usage

Dim instance As LabelType
public enum LabelType : System.Enum
public enum class LabelType : public System.Enum
Members
Member | Description
Arc | Arc
Arrow | Arrow
Bitmap | Bitmap - i.e. a set of points - see Image for a picture
Ellipse | Ellipse or Circle
Formatted | Formatted with Macros
Image | An arbitrary Image .NET object
Line | Line
Polygon | Polygon
PolyLine | PolyLine
Rectangle | Rectangle or Square
ReferenceLine | Dynamic Reference Line
Ruler | Ruler (Scale)
Special | Anatomic Side Markers
Text | Text
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.LabelType

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


LicensedFunctions Enumeration

LicensedFunctions Enumeration

DicomObjects.Enums Namespace : LicensedFunctions Enumeration
A bitmask representing the functions that a particular license allows to be used by DicomObjects.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum LicensedFunctions
   Inherits System.Enum
'Usage

Dim instance As LicensedFunctions
public enum LicensedFunctions : System.Enum
public enum class LicensedFunctions : public System.Enum
Members
Member | Description
Acceptor | Allows listening for and accepting new associations
Initiator | Allows associations to be intiated
NormalisedSCP | Allows use as an SCP for normalised services
QuerySCP | Allows use as a Query/Retrieve SCP
Read | Allows reading and importing of images
Viewer | Allows use of the DicomViewer control
Write | Allows writing and exporting of images
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.LicensedFunctions

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


LicenseTypes Enumeration

LicenseTypes Enumeration

DicomObjects.Enums Namespace : LicenseTypes Enumeration
Indicates the basic type of DicomObjects license
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum LicenseTypes
   Inherits System.Enum
'Usage

Dim instance As LicenseTypes
public enum LicenseTypes : System.Enum
public enum class LicenseTypes : public System.Enum
Members
Member | Description
Demo | Allows use for demonstrations
Developer | Use for development and testing only
Full | Full commercial license for production use
Trial | Allows use for evaluation only
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.LicenseTypes

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


LogLevel Enumeration

LogLevel Enumeration

DicomObjects.Enums Namespace : LogLevel Enumeration
Log levels
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum LogLevel
   Inherits System.Enum
'Usage

Dim instance As LogLevel
public enum LogLevel : System.Enum
public enum class LogLevel : public System.Enum
Members
Member | Description
L_ALLBYTESIN | Full incoming network traffic
L_ALLBYTESOUT | Full outgoing network traffic
L_CACHE | Detailed cache usage data (only on specific test builds)
L_CODEC | Detailed codec logging (e.g. loading of codecs)
L_DEBUG | Specialist debug data (only on specific test builds)
L_DETAILED | Detailed informational messages
L_ELEMENTSIN | Interpetted version of incoming attributes (file and network)
L_ELEMENTSOUT | Interpetted version of outgoing attributes (file and network)
L_ERROR | Errors
L_JPIP | Detailed JPIP logging
L_LIMITEDBYTESIN | PDU and PDV headers for incoming network traffic
L_LIMITEDBYTESOUT | PDU and PDV headers for outgong network traffic
L_LOG | Miscelaneous informational messages
L_PROFILE | Profiling data (only on specific test builds)
L_WARN | Warnings
Remarks
These are a bit filed and may be combined as required, though common values are:
  • 7: errors, warning and information
  • 63 (3F): Basic attributes in and out
  • Full byte level for network operations
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.LogLevel

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


MaskMode Enumeration

MaskMode Enumeration

DicomObjects.Enums Namespace : MaskMode Enumeration
Enumerated values for mask operations
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum MaskMode
   Inherits System.Enum
'Usage

Dim instance As MaskMode
public enum MaskMode : System.Enum
public enum class MaskMode : public System.Enum
Members
Member | Description
AverageSubtraction | The frames specified by the MaskFrames property are averaged together, shifted by the amount specified in the MaskShift property, then subtracted from the contrast frames in the range specified in the ApplicableFrames property.
Maximum | In this mode, value of the frames specified by the MaskFrames property are compaired against the contrast frames specified in the ApplicableFrames property, the maximum value is then used for Rendering.
Minimum | In this mode, value of the frames specified by the MaskFrames property are compaired against the contrast frames specified in the ApplicableFrames property, the minimum value is then used for Rendering.
None | No mask subtraction operation is specified
ReverseTimeDifference | This is the reversed Time Interval Differencing mode, in which the number of the mask frame for each contrast frame is calculated by subtracting TID Offset from the first frame within the Applicable Frame Range, TID Offset+2 from the second frame within the Applicable Frame Range, TID Offset+4 from the third frame and so on.
TimeDifference | The mask for each frame within the Applicable Frames range, specified by the ApplicableFrames property, is selected by subtracting the value (specified by TIDOffset property) from the respective frame number.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.MaskMode

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


Plane Enumeration

Plane Enumeration

DicomObjects.Enums Namespace : Plane Enumeration
Common planes used to display 3D images
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum Plane
   Inherits System.Enum
'Usage

Dim instance As Plane
public enum Plane : System.Enum
public enum class Plane : public System.Enum
Members
Member | Description
Axial | Typical a cross-section of a patient
Coronal | A slice as if viewed from the front/back
Sagittal | A slice as if viewed from the side
Unchanged | As special Plane, which when used in DicomImage3D.SetViewPlane indicates the view plane should be left unaltered.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.Plane

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


PresentationStateFeatures Enumeration

PresentationStateFeatures Enumeration

DicomObjects.Enums Namespace : PresentationStateFeatures Enumeration
Flags to control which features of presentation states are used and/or converted
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PresentationStateFeatures
   Inherits System.Enum
'Usage

Dim instance As PresentationStateFeatures
public enum PresentationStateFeatures : System.Enum
public enum class PresentationStateFeatures : public System.Enum
Members
Member | Description
All | All features
DisplayArea | Selection of part of image for display
Gamma | Use of the Gamma property. Note that gamma is not part of the presentation state definition, but by default (if this bit is set), DicomObjects disables Gamma when a PS is applied to maintain consistency.
GraphicAnnotations | Graphical Annotations
Masking | Masking / Subtraction
ModalityTransform | Modality Transform - i.e. rescale slope and intercept or Modality LUT
Overlays | overlays activated or help by the presentation state
PresentationTransform | Presentation Transform - i.e. inversion or Presentation LUT
Shutters | Shutters defined
SpatialTransform | Rotate/flip etc.
TextAnnotations | Text Annotations
VoiTransform | VOI Transform - i.e. windowing or VOI LUT
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.PresentationStateFeatures

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


Progression Enumeration

Progression Enumeration

DicomObjects.Enums Namespace : Progression Enumeration
Ordering of packet used in JPEG 2000 & JPIP
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum Progression
   Inherits System.Enum
'Usage

Dim instance As Progression
public enum Progression : System.Enum
public enum class Progression : public System.Enum
Members
Member | Description
CPRL | Component Position Resolution Layer
LRCP | Layer Resolution Component Position
PCRL | Position Component Resolution Layer
RLCP | Resolution Layer Component Position
RPCL | Resolution Position Component Layer
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.Progression

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


ProgressiveStatus Enumeration

ProgressiveStatus Enumeration

DicomObjects.Enums Namespace : ProgressiveStatus Enumeration
The status of an image being viewed in a progressive manner
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum ProgressiveStatus
   Inherits System.Enum
'Usage

Dim instance As ProgressiveStatus
public enum ProgressiveStatus : System.Enum
public enum class ProgressiveStatus : public System.Enum
Members
Member | Description
Incomplete | The image is currently being retrieved, and will update asynchronously
NotStarted | The meta data and JPEG 2000 Header have not yet been retrieved/
RequiredResolution | All data available and needed for the current display area and resolution has been received, but more may be available if the area or magnification change.
WholeImage | All available data for the image has been retrieved.
Remarks

This enumeration is currently only used for JPIP, but is generic, and could be used for other similar transports in the future.

Note that the values are strictly ordered allowing greater and lesser comparisons to be used.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.ProgressiveStatus

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


QueryLevel Enumeration

QueryLevel Enumeration

DicomObjects.Enums Namespace : QueryLevel Enumeration
Enumerated values for Query Level
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum QueryLevel
   Inherits System.Enum
'Usage

Dim instance As QueryLevel
public enum QueryLevel : System.Enum
public enum class QueryLevel : public System.Enum
Members
Member | Description
FRAME | Frame level as per supplment 119
IMAGE | IMAGE level for query
INSTANCE | Equivalent to IMAGE level
NONE | No level specified
PATIENT | PATIENT level for query
SERIES | SERIES level for query
STUDY | STUDY level for query
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.QueryLevel

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


QueryRoot Enumeration

QueryRoot Enumeration

DicomObjects.Enums Namespace : QueryRoot Enumeration
Enumerated values for Query Root
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum QueryRoot
   Inherits System.Enum
'Usage

Dim instance As QueryRoot
public enum QueryRoot : System.Enum
public enum class QueryRoot : public System.Enum
Members
Member | Description
CompositeInstance | Composite Instance Root
GeneralPurposeWorklist | Root for General Purpose Worklist query
ModalityWorklist | Root for Modality Worklist query
None | No root specified
Patient | Patient Root
PatientStudyOnly | A combined root of Patient and Study
Study | Study Root
UnifiedProcedureStep | Root for DICOM Unified Procedure Step
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.QueryRoot

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


RequestType Enumeration

RequestType Enumeration

DicomObjects.Enums Namespace : RequestType Enumeration
Enum used in the DicomObjects.Internal.PixelRequest class to pecify the required usage of the data requested
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum RequestType
   Inherits System.Enum
'Usage

Dim instance As RequestType
public enum RequestType : System.Enum
public enum class RequestType : public System.Enum
Members
Member | Description
Background | Low priority background request to satisfy a possible future requirement
Display | Data is for display - i.e. it will may be acquired asynchronously
Synchronous | Data must be acquired synchronously (e.g. for Writing out, or generating a bitmap etc.)
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.RequestType

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


RetrieveType Enumeration

RetrieveType Enumeration

DicomObjects.Enums Namespace : RetrieveType Enumeration
The type of retrieval requested
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum RetrieveType
   Inherits System.Enum
'Usage

Dim instance As RetrieveType
public enum RetrieveType : System.Enum
public enum class RetrieveType : public System.Enum
Members
Member | Description
Full | Full Data
NoBulkData | Remove all bulk data before sending
Remarks
Until 2009, all DICOM retrievals were "Full", but supplement 119 introduced the concept of "No Bulk data" retrieval which is indicated in the EventArguments.QueryReceivedArgs by a property of this type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.RetrieveType

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


RotateState Enumeration

RotateState Enumeration

DicomObjects.Enums Namespace : RotateState Enumeration
Enumerated values for rotate mode
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum RotateState
   Inherits System.Enum
'Usage

Dim instance As RotateState
public enum RotateState : System.Enum
public enum class RotateState : public System.Enum
Members
Member | Description
Full | Image is rotated 180°
Left | Image is rotated 90° counter-clockwise
Normal | No Rotate mode is specified
Right | Image is rotated 90° clockwise
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.RotateState

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


RotationBehaviour Enumeration

RotationBehaviour Enumeration

DicomObjects.Enums Namespace : RotationBehaviour Enumeration
Rotation behaviour of the Image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum RotationBehaviour
   Inherits System.Enum
'Usage

Dim instance As RotationBehaviour
public enum RotationBehaviour : System.Enum
public enum class RotationBehaviour : public System.Enum
Members
Member | Description
BoundingBox | The top left position is defined as the top left corner of the bounding box which surrounds the rotated image.
FixedCentrePoint | The top left position is defined as being where the top left corner of the image would be if it were not rotated. If the image is rotated, it will rotate around the centre point of that non rotated position
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.RotationBehaviour

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


RotationCentre Enumeration

RotationCentre Enumeration

DicomObjects.Enums Namespace : RotationCentre Enumeration
Possible values for controlling the centre of rotation of a text label.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum RotationCentre
   Inherits System.Enum
'Usage

Dim instance As RotationCentre
public enum RotationCentre : System.Enum
public enum class RotationCentre : public System.Enum
Members
Member | Description
AutoSizeCentre | The rotation point is the centre of the chosen text area, as defined by the AutoSizeMode property
LabelCentre | The rotation point is the centre of the originally defined label, as defined by it's Area property
SpecifiedPoint | The rotation point is the point specified by the RotationPoint property
TextCentre | The rotation point is the centre of the calculated text area - irrespective of the value of AutoSizeMode property
Remarks
These values are used for 2 purposes:
  • When an explicit rotation is applied to a label
  • When an image is rotated, but the label is not rotated due to the setting of the RotationMode which therefore requires that the label be rotated relative to the image.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.RotationCentre

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


RotationMode Enumeration

RotationMode Enumeration

DicomObjects.Enums Namespace : RotationMode Enumeration
Possible values for controlling the rotation behaviour of a label.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum RotationMode
   Inherits System.Enum
'Usage

Dim instance As RotationMode
public enum RotationMode : System.Enum
public enum class RotationMode : public System.Enum
Members
Member | Description
CentreToRotationPoint | Move label position so that it remains centred on the rotation point as defined by RotationCentre
Default | Non-text labels rotate, but text labels do not.
NoRotate | The label does not rotate if the image is rotated
WithImage | The label rotates with the image (provided that the label's ScaleMode property is ScaleMode.Image)
Remarks
This is used by the DicomLabel's RotationMode property.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.RotationMode

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


RulerOptions Enumeration

RulerOptions Enumeration

DicomObjects.Enums Namespace : RulerOptions Enumeration
Ruler options to for alignment and spacing
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum RulerOptions
   Inherits System.Enum
'Usage

Dim instance As RulerOptions
public enum RulerOptions : System.Enum
public enum class RulerOptions : public System.Enum
Members
Member | Description
AlignCentre | Centered within the cell area for all changes
AlignFar | If truncated, Ruler label will be placed at the far-side of the cell area (opposite of AlignNear)
AlignNear | This is the default behaviour. Ruler label will be placed within the defined cell area and if shortened it will remain attached to top of the defined area
RoundToLarge | If set any small division beyond the large division will be ignored. In other words, only the large divisions will be displayed/updated as the length of the ruler
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.RulerOptions

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


ScaleMode Enumeration

ScaleMode Enumeration

DicomObjects.Enums Namespace : ScaleMode Enumeration
How DicomLabel objects' dimensions should be interpreted - i.e. how they should be scaled
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum ScaleMode
   Inherits System.Enum
'Usage

Dim instance As ScaleMode
public enum ScaleMode : System.Enum
public enum class ScaleMode : public System.Enum
Members
Member | Description
Cell | Dimensions are in the coordinate system used by DICOM in presentation states, where (0.0,0.0) represents the top left corner of the display area, and (1.0,1.0) represents the bottom right
Cell1000 | Like Cell, but the corners are (0,0) and (1000,1000)
Image | Dimensions are in image pixels
Image3D | Used to specify points in 3D space using images' frame of reference
Output | Dimensions are in screen or other output device pixels and are unaffected by the zooming of the image
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.ScaleMode

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


SelectMode Enumeration

SelectMode Enumeration

DicomObjects.Enums Namespace : SelectMode Enumeration
Enumerated values for DicomLabel select mode
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum SelectMode
   Inherits System.Enum
'Usage

Dim instance As SelectMode
public enum SelectMode : System.Enum
public enum class SelectMode : public System.Enum
Members
Member | Description
AllHandles | Handles are drawn at all relevant "Points" (This only applies to labels of type doLabelPolygon, doLabelPolyline & doLabelArc)
Box | A bounding box is drawn around the label
BoxHandles | Handles are drawn at the corners of the above box
None | No highlighting
Remarks
Although defined as enumerated types, the values above can be (and normally are) used as bit fields, so the value doSelectBox + doSelectBoxHandles gives a bounding box with visible corners.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.SelectMode

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


ShadowTypes Enumeration

ShadowTypes Enumeration

DicomObjects.Enums Namespace : ShadowTypes Enumeration
Controls whether a labels is displayed with a specified shadow, to make it more visible over image areas with similar color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum ShadowTypes
   Inherits System.Enum
'Usage

Dim instance As ShadowTypes
public enum ShadowTypes : System.Enum
public enum class ShadowTypes : public System.Enum
Members
Member | Description
All | 256
Bottom | 32
BottomLeft | 64
BottomRight | 16
Left | 128
None | 0
Right | 8
Top | 2
TopLeft | 1
TopRight | 4
Remarks

Although defined as enumerated types, the values above can be (and normally are) combined and used as bit fields.

The shadow is drawn in the direction(s) indicated above displaced by one pixel from the main label, and it is drawn using the label’s ShadowColor property.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.ShadowTypes

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


SOPClassGroups Enumeration

SOPClassGroups Enumeration

DicomObjects.Enums Namespace : SOPClassGroups Enumeration
The categories of SOP class used for negotiation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum SOPClassGroups
   Inherits System.Enum
'Usage

Dim instance As SOPClassGroups
public enum SOPClassGroups : System.Enum
public enum class SOPClassGroups : public System.Enum
Members
Member | Description
Images16Bit | DICOM Images expected to contain up to 16 bit pixel data
Images1Bit | DICOM Images expected to contain only 1 bit pixel data
Images32Bit | DICOM Images expected to contain up to 32 bit pixel data
Images8Bit | DICOM Images expected to contain only 8 bit pixel data
ImplicitVrOnly | Special group for objects at risk of exceeding 64k for attributes with 2 byte lengths
NonImageObjects | Persistent DICOM objects without pixel data
Services | DICOM Services such as verification and C-GET etc.
User1 | User group for custom SOP class/transfer syntax definitions
User2 | User group for custom SOP class/transfer syntax definitions
User3 | User group for custom SOP class/transfer syntax definitions
Remarks
These groups are used as indices for the DicomGlobal.SOPClassGroup, DicomGlobal.OfferedTransferSyntaxes and DicomGlobal.AcceptedTransferSyntaxes indexed properties
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.SOPClassGroups

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


StatusCode Enumeration

StatusCode Enumeration

DicomObjects.Enums Namespace : StatusCode Enumeration
Common DICOM status codes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum StatusCode
   Inherits System.Enum
'Usage

Dim instance As StatusCode
public enum StatusCode : System.Enum
public enum class StatusCode : public System.Enum
Members
Member | Description
AttributeListError | Attribute List Error
AttributeValueOutOfRange | Attribute Value Out of Range
Cancel | Operation cancelled
ClassInstanceConflict | Class-instance conflict
DuplicateInvocation | Duplicate invocation
DuplicateSOPInstance | Duplicate SOP instance
InvalidArgumentValue | Invalid argument value
InvalidAttributeValue | Invalid attribute value
InvalidObjectInstance | Invalid object instance
MissingAttribute | Missing attribute
MissingAttributeValue | Missing attribute value
MistypedArgument | Mistyped argument
NoSuchActionType | No such action type
NoSuchArgument | No such argument
NoSuchAttribute | No such attribute
NoSuchEventType | No such event type
NoSuchObjectInstance | No such object instance
NoSuchSOPClass | No such SOP class
ProcessingFailure | Processing failure
ResourceLimitation | Resource limitation
SOPClassNotSupported | SOP class not supported
Success | Operation successful
UnrecognizedOperation | Unrecognized operation
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.StatusCode

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


StatusType Enumeration

StatusType Enumeration

DicomObjects.Enums Namespace : StatusType Enumeration
DICOM status code type
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum StatusType
   Inherits System.Enum
'Usage

Dim instance As StatusType
public enum StatusType : System.Enum
public enum class StatusType : public System.Enum
Members
Member | Description
Cancel | Cancel status code
Failure | Failure status code
Pending | Pending status code
Success | Success status code
Unknown | Not a DICOM defined status code
Warning | Warning status code
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.StatusType

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


StretchModes Enumeration

StretchModes Enumeration

DicomObjects.Enums Namespace : StretchModes Enumeration
Controls how an image is displayed
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum StretchModes
   Inherits System.Enum
'Usage

Dim instance As StretchModes
public enum StretchModes : System.Enum
public enum class StretchModes : public System.Enum
Members
Member | Description
NoStretch | Not stretched at all - display depends on Zoom and Scroll properties. If rotated, image position will be calculated as if non-rotated, the moved by Scroll and then finally rotated around its centre point.
StretchCentred | Fitted to the available size, and centered within that
StretchTopLeft | Fitted to the available size, but placed in the top left corner
TrueSize | Similar to NoStretch, but image will be zoomed and rotated and the top-left of its bounding box calculated to provide a reference position before the Scroll is applied.
Remarks
The replaces the previous StrecthToFit property, but has additional flexibility
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.StretchModes

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


UIDType Enumeration

UIDType Enumeration

DicomObjects.Enums Namespace : UIDType Enumeration
Classification of DICOM UID types
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum UIDType
   Inherits System.Enum
'Usage

Dim instance As UIDType
public enum UIDType : System.Enum
public enum class UIDType : public System.Enum
Members
Member | Description
ApplicationContext | The single DICOM Application Context
FrameOfReference | Well-known frames of reference
Image16Bit | DICOM Images expected to contain up to 16 bit pixel data
Image1Bit | DICOM Images containing only 1 bit pixel data
Image32Bit | DICOM Images expected to contain up to 32 bit pixel data
Image8Bit | DICOM Images expected to contain only 8 bit pixel data
MetaSOPClass | A DICOM Meta SOP class
NonImageObject | Persistent DICOM objects without pixel data
Service | DICOM Services such as verification and C-GET etc.
TransferSyntax | A DICOM Transfer Syntax
WellKnownInstance | Well-known fixed DICOM Instances
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.UIDType

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


UserIdentityResponseType Enumeration

UserIdentityResponseType Enumeration

DicomObjects.Enums Namespace : UserIdentityResponseType Enumeration
User Identity Response Type for User Identity Negotiation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum UserIdentityResponseType
   Inherits System.Enum
'Usage

Dim instance As UserIdentityResponseType
public enum UserIdentityResponseType : System.Enum
public enum class UserIdentityResponseType : public System.Enum
Members
Member | Description
NoResponseRequested | No response requested
PositiveResponseRequested | Positive response requested
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.UserIdentityResponseType

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


UserIdentityType Enumeration

UserIdentityType Enumeration

DicomObjects.Enums Namespace : UserIdentityType Enumeration
User Identity Type for User Identity Negotiation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum UserIdentityType
   Inherits System.Enum
'Usage

Dim instance As UserIdentityType
public enum UserIdentityType : System.Enum
public enum class UserIdentityType : public System.Enum
Members
Member | Description
JsonWebToken | JSON Web Token (JWT)
Kerberos | Kerberos Service ticket
SamlAssertion | SAML Assertion
UserName | Username as a string in UTF-8
UserNameAndPassword | Username as a string in UTF-8 and passcode
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.UserIdentityType

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


ViewerMode Enumeration

ViewerMode Enumeration

DicomObjects.Enums Namespace : ViewerMode Enumeration
The modes which can be used for displaying DICOM images in a DicomObjects.DicomViewer
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum ViewerMode
   Inherits System.Enum
'Usage

Dim instance As ViewerMode
public enum ViewerMode : System.Enum
public enum class ViewerMode : public System.Enum
Members
Member | Description
DirectX | DirectX (currently DirectX 11)
Gdi | Graphics Display Interface (GDI+)
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.ViewerMode

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


VoiLUTFunction Enumeration

VoiLUTFunction Enumeration

DicomObjects.Enums Namespace : VoiLUTFunction Enumeration
Controls which VOILUT function to be used
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum VoiLUTFunction
   Inherits System.Enum
'Usage

Dim instance As VoiLUTFunction
public enum VoiLUTFunction : System.Enum
public enum class VoiLUTFunction : public System.Enum
Members
Member | Description
Linear | Linear Windowing
Sigmoid | Sigmoide Window function
Remarks

Used to control whether simple width level has sharp corners (linear) or rounded ends (sigmoid)

This graph shows the difference between linear and sigmoid forms.

This enumeration is used by the VoiLUTFunction Property.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.VoiLUTFunction

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


WaveletTransform Enumeration

WaveletTransform Enumeration

DicomObjects.Enums Namespace : WaveletTransform Enumeration
The types of wavelet transform used in JPEG 2000 & JPIP
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum WaveletTransform
   Inherits System.Enum
'Usage

Dim instance As WaveletTransform
public enum WaveletTransform : System.Enum
public enum class WaveletTransform : public System.Enum
Members
Member | Description
Irreversible | Irreversible 9/7
None | No transform
Reversible | Reversible 5/3
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Enums.WaveletTransform

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Enums Namespace


DicomObjects.EventArguments Namespace

DicomObjects.EventArguments Namespace
Inheritance Hierarchy
Specific classes passed to events
Classes
 | Class | Description
Class | AssociationClosedArgs | Argument passed in the AssociationClosed event
Class | AssociationRequestArgs | Argument passed in the DicomObjects.DicomServer.AssociationRequest event
Class | ChangeUidArgs | Argument for the DicomObjects.DicomGlobal.OnChangeUid event, allowing visibility and control of UID changes
Class | DrawExceptionArgs | Arguments for the DicomObjects.DicomViewer.DrawException event
Class | DrawStartEventArgs | Arguments for the DrawStart2 event
Class | ErrorReceivedArgs | Argument passed in the ErrorReceived event
Class | InfoMessageArgs | Argument passed in the InfoMessage event
Class | InstanceReceivedArgs | Argument passed in the InstanceReceived event
Class | LogEventArgs | Arguments for the DicomObjects.DicomGlobal.LogEvent Event
Class | MakeControlArgs | Arguments for the DicomObjects.DicomViewer.MakeControl Event
Class | N_Event_ReportArgs | Event argument passed in the DicomObjects.DicomServer.N_Event_Report and DicomObjects.DicomAssociation.N_Event_Report events
Class | NormalisedReceivedArgs | Argument passed in the NormalisedReceived evetn
Class | OperationBaseArgs | A base class for other Arguments classes used for incoming operations It is not used directly on its own.
Class | PSLabelCreatedArgs | Argument for the event, allowing customisation of the DicomLabel as a PS is applied to an Image
Class | QueryReceivedArgs | Argument passed in the QueryReceived event
Class | ReceivingPixelDataArgs | Class used by the DicomObjects.DicomServer.ReceivingPixelData event
Class | ResponseReceivedArgs | Event argument passed in the ResponseReceived
Class | UserSmoothingArgs | Class which provides support for the DicomObjects.DicomImage.UserSmoothing event
Class | ValidateFragmentsArgs | Argument for the DicomObjects.DicomGlobal.ValidateFragments event.
Class | VerifyReceivedArgs | Argument passed in the VerifyReceived Event
See Also

Reference

DicomObjects.NET.8.40 Assembly


AssociationClosedArgs Class

AssociationClosedArgs Class
Members

DicomObjects.EventArguments Namespace : AssociationClosedArgs Class
Argument passed in the AssociationClosed event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class AssociationClosedArgs
'Usage

Dim instance As AssociationClosedArgs
public class AssociationClosedArgs
public ref class AssociationClosedArgs
Inheritance Hierarchy

System.Object
DicomObjects.EventArguments.AssociationClosedArgs

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

AssociationClosedArgs Members
DicomObjects.EventArguments Namespace


AssociationClosedArgs Class Members

AssociationClosedArgs Class Members
Properties

DicomObjects.EventArguments Namespace : AssociationClosedArgs Class

The following tables list the members exposed by AssociationClosedArgs.

Public Properties
 | Name | Description
Public Property | Association | The association that is to be closed
Top
See Also

Reference

AssociationClosedArgs Class
DicomObjects.EventArguments Namespace


AssociationClosedArgs Class Properties

AssociationClosedArgs Class Properties

DicomObjects.EventArguments Namespace : AssociationClosedArgs Class

For a list of all members of this type, see AssociationClosedArgs members.

Public Properties
 | Name | Description
Public Property | Association | The association that is to be closed
Top
See Also

Reference

AssociationClosedArgs Class
DicomObjects.EventArguments Namespace


Association Property (AssociationClosedArgs)

Association Property (AssociationClosedArgs)

DicomObjects.EventArguments Namespace > AssociationClosedArgs Class : Association Property
The association that is to be closed
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Association As DicomAssociation
'Usage

Dim instance As AssociationClosedArgs
Dim value As DicomAssociation

value = instance.Association
public DicomAssociation Association {get;}
public:
property DicomAssociation^ Association {
   DicomAssociation^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

AssociationClosedArgs Class
AssociationClosedArgs Members


AssociationRequestArgs Class

AssociationRequestArgs Class
Members

DicomObjects.EventArguments Namespace : AssociationRequestArgs Class
Argument passed in the DicomObjects.DicomServer.AssociationRequest event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class AssociationRequestArgs
   Inherits System.EventArgs
'Usage

Dim instance As AssociationRequestArgs
public class AssociationRequestArgs : System.EventArgs
public ref class AssociationRequestArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
DicomObjects.EventArguments.AssociationRequestArgs

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

AssociationRequestArgs Members
DicomObjects.EventArguments Namespace


AssociationRequestArgs Class Members

AssociationRequestArgs Class Members
Properties Methods

DicomObjects.EventArguments Namespace : AssociationRequestArgs Class

The following tables list the members exposed by AssociationRequestArgs.

Public Properties
 | Name | Description
Public Property | Association | The association that contains the incoming request
Public Property | Contexts | The Contexts proposed by the remote application
Top
Public Methods
 | Name | Description
Public Method | Reject | Reject a whole association request
Top
See Also

Reference

AssociationRequestArgs Class
DicomObjects.EventArguments Namespace


AssociationRequestArgs Class Methods

AssociationRequestArgs Class Methods

DicomObjects.EventArguments Namespace : AssociationRequestArgs Class

For a list of all members of this type, see AssociationRequestArgs members.

Public Methods
 | Name | Description
Public Method | Reject | Reject a whole association request
Top
See Also

Reference

AssociationRequestArgs Class
DicomObjects.EventArguments Namespace


Reject(Byte,Byte,Byte) Method

Reject(Byte,Byte,Byte) Method

DicomObjects.EventArguments Namespace > AssociationRequestArgs Class > Reject Method : Reject(Byte,Byte,Byte) Method
Result as byte, indicating whether it's a permanent or transient rejection
Source as byte, indicating the source of the rejection
Reason as byte, indicating the reason of the rejection
Reject a whole association request
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Reject( _
   ByVal Result As Byte, _
   ByVal Source As Byte, _
   ByVal Reason As Byte _
)
'Usage

Dim instance As AssociationRequestArgs
Dim Result As Byte
Dim Source As Byte
Dim Reason As Byte

instance.Reject(Result, Source, Reason)
public void Reject(
   byte Result,
   byte Source,
   byte Reason
)
public:
void Reject(
   byte Result,
   byte Source,
   byte Reason
)

Parameters

Result
Result as byte, indicating whether it's a permanent or transient rejection
Source
Source as byte, indicating the source of the rejection
Reason
Reason as byte, indicating the reason of the rejection
Remarks

Values for Result, Source and Reason are as follow:

Result:

  • 1 - rejected-permanent
  • 2 - rejected-transient

Source

  • 1 - DICOM UL service-user
  • 2 - DICOM UL service-provider (ACSE related function)
  • 3 - DICOM UL service-provider (Presentation related function)

Reason:

For Source field value of 1 (DICOM UL service-user)

  • 1 - no-reason-given
  • 2 - application-context-name-not-supported
  • 3 - calling-AE-title-not-recognized
  • 4-6 - reserved
  • 7 - called-AE-title-not-recognized
  • 8-10 - reserved

For Source field value of 2 (DICOM UL service-provider (ACSE related function))

  • 1 - no-reason-given
  • 2 - protocol-version-not-supported

For Source field value of 3 (DICOM UL service-provider (Presentation related function))

  • 0 - reserved
  • 1 - temporary-congestion
  • 2 - local-limit-exceeded
  • 3-7 - reserved
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

AssociationRequestArgs Class
AssociationRequestArgs Members
Overload List


AssociationRequestArgs Class Properties

AssociationRequestArgs Class Properties

DicomObjects.EventArguments Namespace : AssociationRequestArgs Class

For a list of all members of this type, see AssociationRequestArgs members.

Public Properties
 | Name | Description
Public Property | Association | The association that contains the incoming request
Public Property | Contexts | The Contexts proposed by the remote application
Top
See Also

Reference

AssociationRequestArgs Class
DicomObjects.EventArguments Namespace


Association Property (AssociationRequestArgs)

Association Property (AssociationRequestArgs)

DicomObjects.EventArguments Namespace > AssociationRequestArgs Class : Association Property
The association that contains the incoming request
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Association As DicomAssociation
'Usage

Dim instance As AssociationRequestArgs
Dim value As DicomAssociation

value = instance.Association
public DicomAssociation Association {get;}
public:
property DicomAssociation^ Association {
   DicomAssociation^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

AssociationRequestArgs Class
AssociationRequestArgs Members


Contexts Property

Contexts Property

DicomObjects.EventArguments Namespace > AssociationRequestArgs Class : Contexts Property
The Contexts proposed by the remote application
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Contexts As DicomContextCollection
'Usage

Dim instance As AssociationRequestArgs
Dim value As DicomContextCollection

value = instance.Contexts
public DicomContextCollection Contexts {get;}
public:
property DicomContextCollection^ Contexts {
   DicomContextCollection^ get();
}
Remarks
Select using reject and/or setting AcceptedTS of each
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

AssociationRequestArgs Class
AssociationRequestArgs Members


ChangeUidArgs Class

ChangeUidArgs Class
Members

DicomObjects.EventArguments Namespace : ChangeUidArgs Class
Argument for the DicomObjects.DicomGlobal.OnChangeUid event, allowing visibility and control of UID changes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ChangeUidArgs
'Usage

Dim instance As ChangeUidArgs
public class ChangeUidArgs
public ref class ChangeUidArgs
Inheritance Hierarchy

System.Object
DicomObjects.EventArguments.ChangeUidArgs

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ChangeUidArgs Members
DicomObjects.EventArguments Namespace


ChangeUidArgs Class Members

ChangeUidArgs Class Members
Properties

DicomObjects.EventArguments Namespace : ChangeUidArgs Class

The following tables list the members exposed by ChangeUidArgs.

Public Properties
 | Name | Description
Public Property | AllowChange | Controls whether to actually make the UID change
Public Property | DataSet | The dataset whose UID should be changed
Public Property | NewUID | The UID being proposed by DicomObjects.
Public Property | Quality | The quality being used for the image compression
Public Property | Reason | The reason that the UID should be changed
Public Property | TransferSyntax | The new transfer syntax being used
Top
See Also

Reference

ChangeUidArgs Class
DicomObjects.EventArguments Namespace


ChangeUidArgs Class Properties

ChangeUidArgs Class Properties

DicomObjects.EventArguments Namespace : ChangeUidArgs Class

For a list of all members of this type, see ChangeUidArgs members.

Public Properties
 | Name | Description
Public Property | AllowChange | Controls whether to actually make the UID change
Public Property | DataSet | The dataset whose UID should be changed
Public Property | NewUID | The UID being proposed by DicomObjects.
Public Property | Quality | The quality being used for the image compression
Public Property | Reason | The reason that the UID should be changed
Public Property | TransferSyntax | The new transfer syntax being used
Top
See Also

Reference

ChangeUidArgs Class
DicomObjects.EventArguments Namespace


AllowChange Property

AllowChange Property

DicomObjects.EventArguments Namespace > ChangeUidArgs Class : AllowChange Property
Controls whether to actually make the UID change
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AllowChange As Boolean
'Usage

Dim instance As ChangeUidArgs
Dim value As Boolean

instance.AllowChange = value

value = instance.AllowChange
public bool AllowChange {get; set;}
public:
property bool AllowChange {
   bool get();
   void set (    bool value);
}
Remarks
This property is initially true, but if required may be set to false in the DicomObjects.DicomGlobal.OnChangeUid event to prevent the UID update from occuring.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ChangeUidArgs Class
ChangeUidArgs Members


DataSet Property (ChangeUidArgs)

DataSet Property (ChangeUidArgs)

DicomObjects.EventArguments Namespace > ChangeUidArgs Class : DataSet Property
The dataset whose UID should be changed
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DataSet As DicomDataSet
'Usage

Dim instance As ChangeUidArgs
Dim value As DicomDataSet

instance.DataSet = value

value = instance.DataSet
public DicomDataSet DataSet {get; set;}
public:
property DicomDataSet^ DataSet {
   DicomDataSet^ get();
   void set (    DicomDataSet^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ChangeUidArgs Class
ChangeUidArgs Members


NewUID Property

NewUID Property

DicomObjects.EventArguments Namespace > ChangeUidArgs Class : NewUID Property
The UID being proposed by DicomObjects.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NewUID As String
'Usage

Dim instance As ChangeUidArgs
Dim value As String

instance.NewUID = value

value = instance.NewUID
public string NewUID {get; set;}
public:
property String^ NewUID {
   String^ get();
   void set (    String^ value);
}
Remarks
This may be replaced if required in the DicomObjects.DicomGlobal.OnChangeUid event
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ChangeUidArgs Class
ChangeUidArgs Members


Quality Property (ChangeUidArgs)

Quality Property (ChangeUidArgs)

DicomObjects.EventArguments Namespace > ChangeUidArgs Class : Quality Property
The quality being used for the image compression
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Quality As Object
'Usage

Dim instance As ChangeUidArgs
Dim value As Object

instance.Quality = value

value = instance.Quality
public object Quality {get; set;}
public:
property Object^ Quality {
   Object^ get();
   void set (    Object^ value);
}
Remarks
This is only applicable when DicomObjects.Enums.ChangeUidReason is DicomObjects.Enums.ChangeUidReason.LossyCompression
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ChangeUidArgs Class
ChangeUidArgs Members


Reason Property

Reason Property

DicomObjects.EventArguments Namespace > ChangeUidArgs Class : Reason Property
The reason that the UID should be changed
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Reason As ChangeUidReason
'Usage

Dim instance As ChangeUidArgs
Dim value As ChangeUidReason

instance.Reason = value

value = instance.Reason
public ChangeUidReason Reason {get; set;}
public:
property ChangeUidReason Reason {
   ChangeUidReason get();
   void set (    ChangeUidReason value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ChangeUidArgs Class
ChangeUidArgs Members


TransferSyntax Property

TransferSyntax Property

DicomObjects.EventArguments Namespace > ChangeUidArgs Class : TransferSyntax Property
The new transfer syntax being used
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TransferSyntax As String
'Usage

Dim instance As ChangeUidArgs
Dim value As String

instance.TransferSyntax = value

value = instance.TransferSyntax
public string TransferSyntax {get; set;}
public:
property String^ TransferSyntax {
   String^ get();
   void set (    String^ value);
}
Remarks
This is only applicable when DicomObjects.Enums.ChangeUidReason is DicomObjects.Enums.ChangeUidReason.LossyCompression
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ChangeUidArgs Class
ChangeUidArgs Members


DrawExceptionArgs Class

DrawExceptionArgs Class
Members

DicomObjects.EventArguments Namespace : DrawExceptionArgs Class
Arguments for the DicomObjects.DicomViewer.DrawException event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DrawExceptionArgs
'Usage

Dim instance As DrawExceptionArgs
public class DrawExceptionArgs
public ref class DrawExceptionArgs
Inheritance Hierarchy

System.Object
DicomObjects.EventArguments.DrawExceptionArgs

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DrawExceptionArgs Members
DicomObjects.EventArguments Namespace


DrawExceptionArgs Class Members

DrawExceptionArgs Class Members
Properties

DicomObjects.EventArguments Namespace : DrawExceptionArgs Class

The following tables list the members exposed by DrawExceptionArgs.

Public Properties
 | Name | Description
Public Property | DrawExceptionOnViewer | A read/write property to control whether the default message detailing the exception is to be drawn onto the viewer's surface.
Public Property | Exception | The Exception which was thrown
Public Property | Index | The Index of the image within the Images collection which was being drawn when the exception was thrown
Public Property | Viewer | The viewer which threw the exception during drawing
Top
See Also

Reference

DrawExceptionArgs Class
DicomObjects.EventArguments Namespace


DrawExceptionArgs Class Properties

DrawExceptionArgs Class Properties

DicomObjects.EventArguments Namespace : DrawExceptionArgs Class

For a list of all members of this type, see DrawExceptionArgs members.

Public Properties
 | Name | Description
Public Property | DrawExceptionOnViewer | A read/write property to control whether the default message detailing the exception is to be drawn onto the viewer's surface.
Public Property | Exception | The Exception which was thrown
Public Property | Index | The Index of the image within the Images collection which was being drawn when the exception was thrown
Public Property | Viewer | The viewer which threw the exception during drawing
Top
See Also

Reference

DrawExceptionArgs Class
DicomObjects.EventArguments Namespace


DrawExceptionOnViewer Property

DrawExceptionOnViewer Property

DicomObjects.EventArguments Namespace > DrawExceptionArgs Class : DrawExceptionOnViewer Property
A read/write property to control whether the default message detailing the exception is to be drawn onto the viewer's surface.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DrawExceptionOnViewer As Boolean
'Usage

Dim instance As DrawExceptionArgs
Dim value As Boolean

instance.DrawExceptionOnViewer = value

value = instance.DrawExceptionOnViewer
public bool DrawExceptionOnViewer {get; set;}
public:
property bool DrawExceptionOnViewer {
   bool get();
   void set (    bool value);
}
Remarks
By default this is true, but may be set to false to disable the writing of the text description.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DrawExceptionArgs Class
DrawExceptionArgs Members


Exception Property

Exception Property

DicomObjects.EventArguments Namespace > DrawExceptionArgs Class : Exception Property
The Exception which was thrown
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Exception As Exception
'Usage

Dim instance As DrawExceptionArgs
Dim value As Exception

value = instance.Exception
public Exception Exception {get;}
public:
property Exception^ Exception {
   Exception^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DrawExceptionArgs Class
DrawExceptionArgs Members


Index Property

Index Property

DicomObjects.EventArguments Namespace > DrawExceptionArgs Class : Index Property
The Index of the image within the Images collection which was being drawn when the exception was thrown
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Index As Integer
'Usage

Dim instance As DrawExceptionArgs
Dim value As Integer

value = instance.Index
public int Index {get;}
public:
property int Index {
   int get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DrawExceptionArgs Class
DrawExceptionArgs Members


Viewer Property

Viewer Property

DicomObjects.EventArguments Namespace > DrawExceptionArgs Class : Viewer Property
The viewer which threw the exception during drawing
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Viewer As DicomViewer
'Usage

Dim instance As DrawExceptionArgs
Dim value As DicomViewer

value = instance.Viewer
public DicomViewer Viewer {get;}
public:
property DicomViewer^ Viewer {
   DicomViewer^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DrawExceptionArgs Class
DrawExceptionArgs Members


DrawStartEventArgs Class

DrawStartEventArgs Class
Members

DicomObjects.EventArguments Namespace : DrawStartEventArgs Class
Arguments for the DrawStart2 event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DrawStartEventArgs
'Usage

Dim instance As DrawStartEventArgs
public class DrawStartEventArgs
public ref class DrawStartEventArgs
Inheritance Hierarchy

System.Object
DicomObjects.EventArguments.DrawStartEventArgs

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DrawStartEventArgs Members
DicomObjects.EventArguments Namespace


DrawStartEventArgs Class Members

DrawStartEventArgs Class Members
Properties

DicomObjects.EventArguments Namespace : DrawStartEventArgs Class

The following tables list the members exposed by DrawStartEventArgs.

Public Constructors
 | Name | Description
Public Constructor | DrawStartEventArgs Constructor | Create a blank DrawStartEventArgs object
Top
Public Properties
 | Name | Description
Public Property | CancelPaint | Causes a paint operation to be cancelled.
Top
See Also

Reference

DrawStartEventArgs Class
DicomObjects.EventArguments Namespace


DrawStartEventArgs Constructor

DrawStartEventArgs Constructor

DicomObjects.EventArguments Namespace > DrawStartEventArgs Class : DrawStartEventArgs Constructor
Create a blank DrawStartEventArgs object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DrawStartEventArgs()
public DrawStartEventArgs()
public:
DrawStartEventArgs();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DrawStartEventArgs Class
DrawStartEventArgs Members


DrawStartEventArgs Class Properties

DrawStartEventArgs Class Properties

DicomObjects.EventArguments Namespace : DrawStartEventArgs Class

For a list of all members of this type, see DrawStartEventArgs members.

Public Properties
 | Name | Description
Public Property | CancelPaint | Causes a paint operation to be cancelled.
Top
See Also

Reference

DrawStartEventArgs Class
DicomObjects.EventArguments Namespace


CancelPaint Property

CancelPaint Property

DicomObjects.EventArguments Namespace > DrawStartEventArgs Class : CancelPaint Property
Causes a paint operation to be cancelled.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CancelPaint As Boolean
'Usage

Dim instance As DrawStartEventArgs
Dim value As Boolean

instance.CancelPaint = value

value = instance.CancelPaint
public bool CancelPaint {get; set;}
public:
property bool CancelPaint {
   bool get();
   void set (    bool value);
}
Remarks
This is intially false, but if set to true during DicomViewer.DrawStart2 then the subsequent drawing of the DicomViewer does not occur.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DrawStartEventArgs Class
DrawStartEventArgs Members


ErrorReceivedArgs Class

ErrorReceivedArgs Class
Members

DicomObjects.EventArguments Namespace : ErrorReceivedArgs Class
Argument passed in the ErrorReceived event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ErrorReceivedArgs
'Usage

Dim instance As ErrorReceivedArgs
public class ErrorReceivedArgs
public ref class ErrorReceivedArgs
Inheritance Hierarchy

System.Object
DicomObjects.EventArguments.ErrorReceivedArgs

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ErrorReceivedArgs Members
DicomObjects.EventArguments Namespace


ErrorReceivedArgs Class Members

ErrorReceivedArgs Class Members
Properties

DicomObjects.EventArguments Namespace : ErrorReceivedArgs Class

The following tables list the members exposed by ErrorReceivedArgs.

Public Properties
 | Name | Description
Public Property | Association | The association which contains the detected error
Public Property | Error | The Exception received
Top
See Also

Reference

ErrorReceivedArgs Class
DicomObjects.EventArguments Namespace


ErrorReceivedArgs Class Properties

ErrorReceivedArgs Class Properties

DicomObjects.EventArguments Namespace : ErrorReceivedArgs Class

For a list of all members of this type, see ErrorReceivedArgs members.

Public Properties
 | Name | Description
Public Property | Association | The association which contains the detected error
Public Property | Error | The Exception received
Top
See Also

Reference

ErrorReceivedArgs Class
DicomObjects.EventArguments Namespace


Association Property (ErrorReceivedArgs)

Association Property (ErrorReceivedArgs)

DicomObjects.EventArguments Namespace > ErrorReceivedArgs Class : Association Property
The association which contains the detected error
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Association As DicomAssociation
'Usage

Dim instance As ErrorReceivedArgs
Dim value As DicomAssociation

value = instance.Association
public DicomAssociation Association {get;}
public:
property DicomAssociation^ Association {
   DicomAssociation^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ErrorReceivedArgs Class
ErrorReceivedArgs Members


Error Property

Error Property

DicomObjects.EventArguments Namespace > ErrorReceivedArgs Class : Error Property
The Exception received
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Error As Exception
'Usage

Dim instance As ErrorReceivedArgs
Dim value As Exception

value = instance.Error
public Exception Error {get;}
public:
property Exception^ Error {
   Exception^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ErrorReceivedArgs Class
ErrorReceivedArgs Members


InfoMessageArgs Class

InfoMessageArgs Class
Members

DicomObjects.EventArguments Namespace : InfoMessageArgs Class
Argument passed in the InfoMessage event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class InfoMessageArgs
'Usage

Dim instance As InfoMessageArgs
public class InfoMessageArgs
public ref class InfoMessageArgs
Inheritance Hierarchy

System.Object
DicomObjects.EventArguments.InfoMessageArgs

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

InfoMessageArgs Members
DicomObjects.EventArguments Namespace


InfoMessageArgs Class Members

InfoMessageArgs Class Members
Properties

DicomObjects.EventArguments Namespace : InfoMessageArgs Class

The following tables list the members exposed by InfoMessageArgs.

Public Properties
 | Name | Description
Public Property | Association | The current association
Public Property | Level | Level indicating the importance of the message
Public Property | Message | The message to be passed back
Top
See Also

Reference

InfoMessageArgs Class
DicomObjects.EventArguments Namespace


InfoMessageArgs Class Properties

InfoMessageArgs Class Properties

DicomObjects.EventArguments Namespace : InfoMessageArgs Class

For a list of all members of this type, see InfoMessageArgs members.

Public Properties
 | Name | Description
Public Property | Association | The current association
Public Property | Level | Level indicating the importance of the message
Public Property | Message | The message to be passed back
Top
See Also

Reference

InfoMessageArgs Class
DicomObjects.EventArguments Namespace


Association Property (InfoMessageArgs)

Association Property (InfoMessageArgs)

DicomObjects.EventArguments Namespace > InfoMessageArgs Class : Association Property
The current association
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Association As DicomAssociation
'Usage

Dim instance As InfoMessageArgs
Dim value As DicomAssociation

value = instance.Association
public DicomAssociation Association {get;}
public:
property DicomAssociation^ Association {
   DicomAssociation^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

InfoMessageArgs Class
InfoMessageArgs Members


Level Property (InfoMessageArgs)

Level Property (InfoMessageArgs)

DicomObjects.EventArguments Namespace > InfoMessageArgs Class : Level Property
Level indicating the importance of the message
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Level As Integer
'Usage

Dim instance As InfoMessageArgs
Dim value As Integer

value = instance.Level
public int Level {get;}
public:
property int Level {
   int get();
}
Remarks

Enumerated values as follows:

0 - Fatal Error

1 - Protocol Error

2 - Warning

3 - Information

4 - Debugging trace

Will be put into DicomObjects.Enums in the near future.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

InfoMessageArgs Class
InfoMessageArgs Members


Message Property

Message Property

DicomObjects.EventArguments Namespace > InfoMessageArgs Class : Message Property
The message to be passed back
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Message As String
'Usage

Dim instance As InfoMessageArgs
Dim value As String

value = instance.Message
public string Message {get;}
public:
property String^ Message {
   String^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

InfoMessageArgs Class
InfoMessageArgs Members


InstanceReceivedArgs Class

InstanceReceivedArgs Class
Members

DicomObjects.EventArguments Namespace : InstanceReceivedArgs Class
Argument passed in the InstanceReceived event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class InstanceReceivedArgs
   Inherits OperationBaseArgs
'Usage

Dim instance As InstanceReceivedArgs
public class InstanceReceivedArgs : OperationBaseArgs
public ref class InstanceReceivedArgs : public OperationBaseArgs
Inheritance Hierarchy

System.Object
System.EventArgs
DicomObjects.EventArguments.OperationBaseArgs
DicomObjects.EventArguments.InstanceReceivedArgs

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

InstanceReceivedArgs Members
DicomObjects.EventArguments Namespace


InstanceReceivedArgs Class Members

InstanceReceivedArgs Class Members
Properties

DicomObjects.EventArguments Namespace : InstanceReceivedArgs Class

The following tables list the members exposed by InstanceReceivedArgs.

Public Properties
 | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Instance | The received composite DICOM instance
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ReceivedFilename | Filename to which the instance has already been saved
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Top
See Also

Reference

InstanceReceivedArgs Class
DicomObjects.EventArguments Namespace


InstanceReceivedArgs Class Properties

InstanceReceivedArgs Class Properties

DicomObjects.EventArguments Namespace : InstanceReceivedArgs Class

For a list of all members of this type, see InstanceReceivedArgs members.

Public Properties
 | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Instance | The received composite DICOM instance
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ReceivedFilename | Filename to which the instance has already been saved
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Top
See Also

Reference

InstanceReceivedArgs Class
DicomObjects.EventArguments Namespace


Instance Property

Instance Property

DicomObjects.EventArguments Namespace > InstanceReceivedArgs Class : Instance Property
The received composite DICOM instance
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Instance As DicomDataSet
'Usage

Dim instance As InstanceReceivedArgs
Dim value As DicomDataSet

value = instance.Instance
public DicomDataSet Instance {get;}
public:
property DicomDataSet^ Instance {
   DicomDataSet^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

InstanceReceivedArgs Class
InstanceReceivedArgs Members


ReceivedFilename Property

ReceivedFilename Property

DicomObjects.EventArguments Namespace > InstanceReceivedArgs Class : ReceivedFilename Property
Filename to which the instance has already been saved
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ReceivedFilename As String
'Usage

Dim instance As InstanceReceivedArgs
Dim value As String

value = instance.ReceivedFilename
public string ReceivedFilename {get;}
public:
property String^ ReceivedFilename {
   String^ get();
}
Remarks
This is only valid for images saved as a result of ReceivingPixelDataArgs.ReceiveToDisk -
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

InstanceReceivedArgs Class
InstanceReceivedArgs Members


LogEventArgs Class

LogEventArgs Class
Members

DicomObjects.EventArguments Namespace : LogEventArgs Class
Arguments for the LogEvent Event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class LogEventArgs
'Usage

Dim instance As LogEventArgs
public class LogEventArgs
public ref class LogEventArgs
Inheritance Hierarchy

System.Object
DicomObjects.EventArguments.LogEventArgs

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LogEventArgs Members
DicomObjects.EventArguments Namespace


LogEventArgs Class Members

LogEventArgs Class Members
Properties

DicomObjects.EventArguments Namespace : LogEventArgs Class

The following tables list the members exposed by LogEventArgs.

Public Properties
 | Name | Description
Public Property | Level | The level of the event being logged
Public Property | Source | The Log Event Source
Public Property | Text | The test of the association
Top
See Also

Reference

LogEventArgs Class
DicomObjects.EventArguments Namespace


LogEventArgs Class Properties

LogEventArgs Class Properties

DicomObjects.EventArguments Namespace : LogEventArgs Class

For a list of all members of this type, see LogEventArgs members.

Public Properties
 | Name | Description
Public Property | Level | The level of the event being logged
Public Property | Source | The Log Event Source
Public Property | Text | The test of the association
Top
See Also

Reference

LogEventArgs Class
DicomObjects.EventArguments Namespace


Level Property (LogEventArgs)

Level Property (LogEventArgs)

DicomObjects.EventArguments Namespace > LogEventArgs Class : Level Property
The level of the event being logged
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Level As Integer
'Usage

Dim instance As LogEventArgs
Dim value As Integer

value = instance.Level
public int Level {get;}
public:
property int Level {
   int get();
}
Remarks
See DicomGlobal.LogToFile for the meaning of this level
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LogEventArgs Class
LogEventArgs Members


Source Property

Source Property

DicomObjects.EventArguments Namespace > LogEventArgs Class : Source Property
The Log Event Source
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Source As String
'Usage

Dim instance As LogEventArgs
Dim value As String

value = instance.Source
public string Source {get;}
public:
property String^ Source {
   String^ get();
}
Remarks

For associations, this is a sequentially increment number, unique for each association.

Files read or written are also allocated a "pseudo-association" number for identification

May be zero for non-association related log events

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LogEventArgs Class
LogEventArgs Members


Text Property (LogEventArgs)

Text Property (LogEventArgs)

DicomObjects.EventArguments Namespace > LogEventArgs Class : Text Property
The test of the association
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Text As String
'Usage

Dim instance As LogEventArgs
Dim value As String

value = instance.Text
public string Text {get;}
public:
property String^ Text {
   String^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LogEventArgs Class
LogEventArgs Members


MakeControlArgs Class

MakeControlArgs Class
Members

DicomObjects.EventArguments Namespace : MakeControlArgs Class
Arguments for the DicomObjects.DicomViewer.MakeControl Event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class MakeControlArgs
'Usage

Dim instance As MakeControlArgs
public class MakeControlArgs
public ref class MakeControlArgs
Inheritance Hierarchy

System.Object
DicomObjects.EventArguments.MakeControlArgs

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

MakeControlArgs Members
DicomObjects.EventArguments Namespace


MakeControlArgs Class Members

MakeControlArgs Class Members
Properties

DicomObjects.EventArguments Namespace : MakeControlArgs Class

The following tables list the members exposed by MakeControlArgs.

Public Constructors
 | Name | Description
Public Constructor | MakeControlArgs Constructor |
Top
Public Properties
 | Name | Description
Public Property | Image | The image that the control is used to display
Top
See Also

Reference

MakeControlArgs Class
DicomObjects.EventArguments Namespace


MakeControlArgs Constructor

MakeControlArgs Constructor

DicomObjects.EventArguments Namespace > MakeControlArgs Class : MakeControlArgs Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New MakeControlArgs()
public MakeControlArgs()
public:
MakeControlArgs();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

MakeControlArgs Class
MakeControlArgs Members


MakeControlArgs Class Properties

MakeControlArgs Class Properties

DicomObjects.EventArguments Namespace : MakeControlArgs Class

For a list of all members of this type, see MakeControlArgs members.

Public Properties
 | Name | Description
Public Property | Image | The image that the control is used to display
Top
See Also

Reference

MakeControlArgs Class
DicomObjects.EventArguments Namespace


Image Property (MakeControlArgs)

Image Property (MakeControlArgs)

DicomObjects.EventArguments Namespace > MakeControlArgs Class : Image Property
The image that the control is used to display
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Image As DicomImage
'Usage

Dim instance As MakeControlArgs
Dim value As DicomImage

instance.Image = value

value = instance.Image
public DicomImage Image {get; set;}
public:
property DicomImage^ Image {
   DicomImage^ get();
   void set (    DicomImage^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

MakeControlArgs Class
MakeControlArgs Members


N_Event_ReportArgs Class

N_Event_ReportArgs Class
Members

DicomObjects.EventArguments Namespace : N_Event_ReportArgs Class
Event argument passed in the DicomObjects.DicomServer.N_Event_Report and DicomObjects.DicomAssociation.N_Event_Report events
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class N_Event_ReportArgs
   Inherits OperationBaseArgs
'Usage

Dim instance As N_Event_ReportArgs
public class N_Event_ReportArgs : OperationBaseArgs
public ref class N_Event_ReportArgs : public OperationBaseArgs
Inheritance Hierarchy

System.Object
System.EventArgs
DicomObjects.EventArguments.OperationBaseArgs
DicomObjects.EventArguments.N_Event_ReportArgs

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

N_Event_ReportArgs Members
DicomObjects.EventArguments Namespace


N_Event_ReportArgs Class Members

N_Event_ReportArgs Class Members
Properties

DicomObjects.EventArguments Namespace : N_Event_ReportArgs Class

The following tables list the members exposed by N_Event_ReportArgs.

Public Properties
 | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | EventID | The ID of the notification
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Top
See Also

Reference

N_Event_ReportArgs Class
DicomObjects.EventArguments Namespace


N_Event_ReportArgs Class Properties

N_Event_ReportArgs Class Properties

DicomObjects.EventArguments Namespace : N_Event_ReportArgs Class

For a list of all members of this type, see N_Event_ReportArgs members.

Public Properties
 | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | EventID | The ID of the notification
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Top
See Also

Reference

N_Event_ReportArgs Class
DicomObjects.EventArguments Namespace


EventID Property

EventID Property

DicomObjects.EventArguments Namespace > N_Event_ReportArgs Class : EventID Property
The ID of the notification
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property EventID As Integer
'Usage

Dim instance As N_Event_ReportArgs
Dim value As Integer

value = instance.EventID
public int EventID {get;}
public:
property int EventID {
   int get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

N_Event_ReportArgs Class
N_Event_ReportArgs Members


NormalisedReceivedArgs Class

NormalisedReceivedArgs Class
Members

DicomObjects.EventArguments Namespace : NormalisedReceivedArgs Class
Argument passed in the NormalisedReceived evetn
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class NormalisedReceivedArgs
   Inherits OperationBaseArgs
'Usage

Dim instance As NormalisedReceivedArgs
public class NormalisedReceivedArgs : OperationBaseArgs
public ref class NormalisedReceivedArgs : public OperationBaseArgs
Inheritance Hierarchy

System.Object
System.EventArgs
DicomObjects.EventArguments.OperationBaseArgs
DicomObjects.EventArguments.NormalisedReceivedArgs

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

NormalisedReceivedArgs Members
DicomObjects.EventArguments Namespace


NormalisedReceivedArgs Class Members

NormalisedReceivedArgs Class Members
Properties

DicomObjects.EventArguments Namespace : NormalisedReceivedArgs Class

The following tables list the members exposed by NormalisedReceivedArgs.

Public Properties
 | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Top
See Also

Reference

NormalisedReceivedArgs Class
DicomObjects.EventArguments Namespace


OperationBaseArgs Class

OperationBaseArgs Class
Members

DicomObjects.EventArguments Namespace : OperationBaseArgs Class
A base class for other Arguments classes used for incoming operations It is not used directly on its own.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class OperationBaseArgs
   Inherits System.EventArgs
'Usage

Dim instance As OperationBaseArgs
public class OperationBaseArgs : System.EventArgs
public ref class OperationBaseArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
DicomObjects.EventArguments.OperationBaseArgs
DicomObjects.EventArguments.InstanceReceivedArgs
DicomObjects.EventArguments.N_Event_ReportArgs
DicomObjects.EventArguments.NormalisedReceivedArgs
DicomObjects.EventArguments.QueryReceivedArgs
DicomObjects.EventArguments.VerifyReceivedArgs

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

OperationBaseArgs Members
DicomObjects.EventArguments Namespace


OperationBaseArgs Class Members

OperationBaseArgs Class Members
Properties

DicomObjects.EventArguments Namespace : OperationBaseArgs Class

The following tables list the members exposed by OperationBaseArgs.

Public Properties
 | Name | Description
Public Property | Command | The incoming command
Public Property | Errors | List of errors found in an incoming request
Public Property | Operation | The normalised operation currently requested
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation
Public Property | Request | The incoming request
Public Property | RequestAssociation | The Association which contains the Query
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations
Public Property | Status | The status to be sent back as a C-Echo response
Top
See Also

Reference

OperationBaseArgs Class
DicomObjects.EventArguments Namespace


OperationBaseArgs Class Properties

OperationBaseArgs Class Properties

DicomObjects.EventArguments Namespace : OperationBaseArgs Class

For a list of all members of this type, see OperationBaseArgs members.

Public Properties
 | Name | Description
Public Property | Command | The incoming command
Public Property | Errors | List of errors found in an incoming request
Public Property | Operation | The normalised operation currently requested
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation
Public Property | Request | The incoming request
Public Property | RequestAssociation | The Association which contains the Query
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations
Public Property | Status | The status to be sent back as a C-Echo response
Top
See Also

Reference

OperationBaseArgs Class
DicomObjects.EventArguments Namespace


Command Property (OperationBaseArgs)

Command Property (OperationBaseArgs)

DicomObjects.EventArguments Namespace > OperationBaseArgs Class : Command Property
The incoming command
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Command As DicomDataSet
'Usage

Dim instance As OperationBaseArgs
Dim value As DicomDataSet

value = instance.Command
public DicomDataSet Command {get;}
public:
property DicomDataSet^ Command {
   DicomDataSet^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

OperationBaseArgs Class
OperationBaseArgs Members


Errors Property

Errors Property

DicomObjects.EventArguments Namespace > OperationBaseArgs Class : Errors Property
List of errors found in an incoming request
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Errors As DicomDataSet
'Usage

Dim instance As OperationBaseArgs
Dim value As DicomDataSet

value = instance.Errors
public DicomDataSet Errors {get;}
public:
property DicomDataSet^ Errors {
   DicomDataSet^ get();
}
Remarks

If a client identifies errors in a DicomAssociation, it should place appropriate values into this property before setting the Status to an appropriate error code.

The appropriate elements to be inserted into this dataset are:

  • (0000, 0901) : Offending Element
  • (0000, 0902) : Error Comment

Only the appropriate elements, as defined by the returned status will be transmitted.

SCP uses this property to check if there is any errors reported by the connected clients.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

OperationBaseArgs Class
OperationBaseArgs Members


Operation Property

Operation Property

DicomObjects.EventArguments Namespace > OperationBaseArgs Class : Operation Property
The normalised operation currently requested
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Operation As DicomOperation
'Usage

Dim instance As OperationBaseArgs
Dim value As DicomOperation

value = instance.Operation
public DicomOperation Operation {get;}
public:
property DicomOperation Operation {
   DicomOperation get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

OperationBaseArgs Class
OperationBaseArgs Members


PresentationContextId Property

PresentationContextId Property

DicomObjects.EventArguments Namespace > OperationBaseArgs Class : PresentationContextId Property
The Presentation Context ID used to transmit this operation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property PresentationContextId As Byte
'Usage

Dim instance As OperationBaseArgs
Dim value As Byte

value = instance.PresentationContextId
public byte PresentationContextId {get;}
public:
property byte PresentationContextId {
   byte get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

OperationBaseArgs Class
OperationBaseArgs Members


Request Property (OperationBaseArgs)

Request Property (OperationBaseArgs)

DicomObjects.EventArguments Namespace > OperationBaseArgs Class : Request Property
The incoming request
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Request As DicomDataSet
'Usage

Dim instance As OperationBaseArgs
Dim value As DicomDataSet

value = instance.Request
public DicomDataSet Request {get;}
public:
property DicomDataSet^ Request {
   DicomDataSet^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

OperationBaseArgs Class
OperationBaseArgs Members


RequestAssociation Property

RequestAssociation Property

DicomObjects.EventArguments Namespace > OperationBaseArgs Class : RequestAssociation Property
The Association which contains the Query
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property RequestAssociation As DicomAssociation
'Usage

Dim instance As OperationBaseArgs
Dim value As DicomAssociation

value = instance.RequestAssociation
public DicomAssociation RequestAssociation {get;}
public:
property DicomAssociation^ RequestAssociation {
   DicomAssociation^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

OperationBaseArgs Class
OperationBaseArgs Members


ResultDataSet Property

ResultDataSet Property

DicomObjects.EventArguments Namespace > OperationBaseArgs Class : ResultDataSet Property
Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ResultDataSet As DicomDataSet
'Usage

Dim instance As OperationBaseArgs
Dim value As DicomDataSet

instance.ResultDataSet = value

value = instance.ResultDataSet
public DicomDataSet ResultDataSet {get; set;}
public:
property DicomDataSet^ ResultDataSet {
   DicomDataSet^ get();
   void set (    DicomDataSet^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

OperationBaseArgs Class
OperationBaseArgs Members


Status Property (OperationBaseArgs)

Status Property (OperationBaseArgs)

DicomObjects.EventArguments Namespace > OperationBaseArgs Class : Status Property
The status to be sent back as a C-Echo response
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Status As Integer
'Usage

Dim instance As OperationBaseArgs
Dim value As Integer

instance.Status = value

value = instance.Status
public int Status {get; set;}
public:
property int Status {
   int get();
   void set (    int value);
}
Remarks
Set Status to Zero as a successful C-Echo response, none-zero status indicates C-Echo failure.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

OperationBaseArgs Class
OperationBaseArgs Members


PSLabelCreatedArgs Class

PSLabelCreatedArgs Class
Members

DicomObjects.EventArguments Namespace : PSLabelCreatedArgs Class
Argument for the event, allowing customisation of the DicomLabel as a PS is applied to an Image
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PSLabelCreatedArgs
'Usage

Dim instance As PSLabelCreatedArgs
public class PSLabelCreatedArgs
public ref class PSLabelCreatedArgs
Inheritance Hierarchy

System.Object
DicomObjects.EventArguments.PSLabelCreatedArgs

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

PSLabelCreatedArgs Members
DicomObjects.EventArguments Namespace


PSLabelCreatedArgs Class Members

PSLabelCreatedArgs Class Members
Properties

DicomObjects.EventArguments Namespace : PSLabelCreatedArgs Class

The following tables list the members exposed by PSLabelCreatedArgs.

Public Constructors
 | Name | Description
Public Constructor | PSLabelCreatedArgs Constructor |
Top
Public Properties
 | Name | Description
Public Property | Label | Label created form the PresentationStateItem
Public Property | PresentationState | The general DICOM Presentation State Instance
Public Property | PresentationStateItem | The specific DICOM Presentation State Item from which the label is created
Top
See Also

Reference

PSLabelCreatedArgs Class
DicomObjects.EventArguments Namespace


PSLabelCreatedArgs Constructor

PSLabelCreatedArgs Constructor

DicomObjects.EventArguments Namespace > PSLabelCreatedArgs Class : PSLabelCreatedArgs Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PSLabelCreatedArgs()
public PSLabelCreatedArgs()
public:
PSLabelCreatedArgs();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

PSLabelCreatedArgs Class
PSLabelCreatedArgs Members


PSLabelCreatedArgs Class Properties

PSLabelCreatedArgs Class Properties

DicomObjects.EventArguments Namespace : PSLabelCreatedArgs Class

For a list of all members of this type, see PSLabelCreatedArgs members.

Public Properties
 | Name | Description
Public Property | Label | Label created form the PresentationStateItem
Public Property | PresentationState | The general DICOM Presentation State Instance
Public Property | PresentationStateItem | The specific DICOM Presentation State Item from which the label is created
Top
See Also

Reference

PSLabelCreatedArgs Class
DicomObjects.EventArguments Namespace


Label Property

Label Property

DicomObjects.EventArguments Namespace > PSLabelCreatedArgs Class : Label Property
Label created form the PresentationStateItem
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Label As DicomLabel
'Usage

Dim instance As PSLabelCreatedArgs
Dim value As DicomLabel

instance.Label = value

value = instance.Label
public DicomLabel Label {get; set;}
public:
property DicomLabel^ Label {
   DicomLabel^ get();
   void set (    DicomLabel^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

PSLabelCreatedArgs Class
PSLabelCreatedArgs Members


PresentationState Property (PSLabelCreatedArgs)

PresentationState Property (PSLabelCreatedArgs)

DicomObjects.EventArguments Namespace > PSLabelCreatedArgs Class : PresentationState Property
The general DICOM Presentation State Instance
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PresentationState As DicomDataSet
'Usage

Dim instance As PSLabelCreatedArgs
Dim value As DicomDataSet

instance.PresentationState = value

value = instance.PresentationState
public DicomDataSet PresentationState {get; set;}
public:
property DicomDataSet^ PresentationState {
   DicomDataSet^ get();
   void set (    DicomDataSet^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

PSLabelCreatedArgs Class
PSLabelCreatedArgs Members


PresentationStateItem Property

PresentationStateItem Property

DicomObjects.EventArguments Namespace > PSLabelCreatedArgs Class : PresentationStateItem Property
The specific DICOM Presentation State Item from which the label is created
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PresentationStateItem As DicomDataSet
'Usage

Dim instance As PSLabelCreatedArgs
Dim value As DicomDataSet

instance.PresentationStateItem = value

value = instance.PresentationStateItem
public DicomDataSet PresentationStateItem {get; set;}
public:
property DicomDataSet^ PresentationStateItem {
   DicomDataSet^ get();
   void set (    DicomDataSet^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

PSLabelCreatedArgs Class
PSLabelCreatedArgs Members


QueryReceivedArgs Class

QueryReceivedArgs Class
Members

DicomObjects.EventArguments Namespace : QueryReceivedArgs Class
Argument passed in the QueryReceived event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class QueryReceivedArgs
   Inherits OperationBaseArgs
'Usage

Dim instance As QueryReceivedArgs
public class QueryReceivedArgs : OperationBaseArgs
public ref class QueryReceivedArgs : public OperationBaseArgs
Inheritance Hierarchy

System.Object
System.EventArgs
DicomObjects.EventArguments.OperationBaseArgs
DicomObjects.EventArguments.QueryReceivedArgs

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

QueryReceivedArgs Members
DicomObjects.EventArguments Namespace


QueryReceivedArgs Class Members

QueryReceivedArgs Class Members
Properties Methods

DicomObjects.EventArguments Namespace : QueryReceivedArgs Class

The following tables list the members exposed by QueryReceivedArgs.

Public Properties
 | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Destination | The Application Entity Name to which images should be sent by a C-MOVE request
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | InstanceAssociation | The Association to which to send instances using SendInstances
Public Property | Level | The Query Level
Public Property | ModificationsDone | Property to inform DicomObjects whether frame extraction (as per Supplement 119) has been performed
Public Property | NumberCompleted | Numbers of completed C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | NumberFailed | Numbers of failed C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | NumberRemaining | Numbers of remaining C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | NumberWarning | Numbers of warning C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RetrieveType | The type of retrieval requested
Public Property | Root | The Query Root
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Top
Public Methods
 | Name | Description
Public Method | SendPending | Return a pending response
Public Method | SendResponse | Overloaded. Send response back as DicomDataSetCollection to the request association
Top
See Also

Reference

QueryReceivedArgs Class
DicomObjects.EventArguments Namespace


QueryReceivedArgs Class Methods

QueryReceivedArgs Class Methods

DicomObjects.EventArguments Namespace : QueryReceivedArgs Class

For a list of all members of this type, see QueryReceivedArgs members.

Public Methods
 | Name | Description
Public Method | SendPending | Return a pending response
Public Method | SendResponse | Overloaded. Send response back as DicomDataSetCollection to the request association
Top
See Also

Reference

QueryReceivedArgs Class
DicomObjects.EventArguments Namespace


SendPending Method

SendPending Method

DicomObjects.EventArguments Namespace > QueryReceivedArgs Class : SendPending Method
Return a pending response
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SendPending()
'Usage

Dim instance As QueryReceivedArgs

instance.SendPending()
public void SendPending()
public:
void SendPending();
Remarks

The status response is FF00. This method may be useful to keep an association "alive"

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

QueryReceivedArgs Class
QueryReceivedArgs Members


SendResponse Method

SendResponse Method

DicomObjects.EventArguments Namespace > QueryReceivedArgs Class : SendResponse Method
Send response back as DicomDataSetCollection to the request association
Overload List
Overload | Description
SendResponse(IEnumerable<DicomDataSet>,Int32) | Send response back as DicomDataSetCollection to the request association
SendResponse(DicomDataSet,Int32) | Send response back as DicomDataSet to the request association
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

QueryReceivedArgs Class
QueryReceivedArgs Members


SendResponse(IEnumerable<DicomDataSet>,Int32) Method

SendResponse(IEnumerable<DicomDataSet>,Int32) Method

DicomObjects.EventArguments Namespace > QueryReceivedArgs Class > SendResponse Method : SendResponse(IEnumerable<DicomDataSet>,Int32) Method
Send response back as DicomDataSetCollection to the request association
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SendResponse( _
   ByVal Data As IEnumerable(Of DicomDataSet), _
   ByVal Status As Integer _
)
'Usage

Dim instance As QueryReceivedArgs
Dim Data As IEnumerable(Of DicomDataSet)
Dim Status As Integer

instance.SendResponse(Data, Status)
public void SendResponse(
   IEnumerable<DicomDataSet> Data,
   int Status
)
public:
void SendResponse(
   IEnumerable<DicomDataSet^>^ Data,
   int Status
)

Parameters

Data
Status
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

QueryReceivedArgs Class
QueryReceivedArgs Members
Overload List


SendResponse(DicomDataSet,Int32) Method

SendResponse(DicomDataSet,Int32) Method

DicomObjects.EventArguments Namespace > QueryReceivedArgs Class > SendResponse Method : SendResponse(DicomDataSet,Int32) Method
Send response back as DicomDataSet to the request association
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SendResponse( _
   ByVal Data As DicomDataSet, _
   ByVal Status As Integer _
)
'Usage

Dim instance As QueryReceivedArgs
Dim Data As DicomDataSet
Dim Status As Integer

instance.SendResponse(Data, Status)
public void SendResponse(
   DicomDataSet Data,
   int Status
)
public:
void SendResponse(
   DicomDataSet^ Data,
   int Status
)

Parameters

Data
Status
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

QueryReceivedArgs Class
QueryReceivedArgs Members
Overload List


QueryReceivedArgs Class Properties

QueryReceivedArgs Class Properties

DicomObjects.EventArguments Namespace : QueryReceivedArgs Class

For a list of all members of this type, see QueryReceivedArgs members.

Public Properties
 | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Destination | The Application Entity Name to which images should be sent by a C-MOVE request
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | InstanceAssociation | The Association to which to send instances using SendInstances
Public Property | Level | The Query Level
Public Property | ModificationsDone | Property to inform DicomObjects whether frame extraction (as per Supplement 119) has been performed
Public Property | NumberCompleted | Numbers of completed C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | NumberFailed | Numbers of failed C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | NumberRemaining | Numbers of remaining C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | NumberWarning | Numbers of warning C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RetrieveType | The type of retrieval requested
Public Property | Root | The Query Root
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Top
See Also

Reference

QueryReceivedArgs Class
DicomObjects.EventArguments Namespace


Destination Property (QueryReceivedArgs)

Destination Property (QueryReceivedArgs)

DicomObjects.EventArguments Namespace > QueryReceivedArgs Class : Destination Property
The Application Entity Name to which images should be sent by a C-MOVE request
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Destination As String
'Usage

Dim instance As QueryReceivedArgs
Dim value As String

value = instance.Destination
public string Destination {get;}
public:
property String^ Destination {
   String^ get();
}
Remarks

A Query/Retrieve SCP must use this property to find the values of the IP address, port number and possibly Calling AET to use before calling Open on the InstanceAssociation.

This Application Entity Name must be known by the C-MOVE SCP, as the standard allows no other means of specifying the destination. In particular, it is not possible to direct images to an arbitrary IP address and port using Move.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

QueryReceivedArgs Class
QueryReceivedArgs Members


InstanceAssociation Property

InstanceAssociation Property

DicomObjects.EventArguments Namespace > QueryReceivedArgs Class : InstanceAssociation Property
The Association to which to send instances using SendInstances
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property InstanceAssociation As DicomAssociation
'Usage

Dim instance As QueryReceivedArgs
Dim value As DicomAssociation

instance.InstanceAssociation = value

value = instance.InstanceAssociation
public DicomAssociation InstanceAssociation {get; set;}
public:
property DicomAssociation^ InstanceAssociation {
   DicomAssociation^ get();
   void set (    DicomAssociation^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

QueryReceivedArgs Class
QueryReceivedArgs Members


Level Property (QueryReceivedArgs)

Level Property (QueryReceivedArgs)

DicomObjects.EventArguments Namespace > QueryReceivedArgs Class : Level Property
The Query Level
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Level As QueryLevel
'Usage

Dim instance As QueryReceivedArgs
Dim value As QueryLevel

value = instance.Level
public QueryLevel Level {get;}
public:
property QueryLevel Level {
   QueryLevel get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

QueryReceivedArgs Class
QueryReceivedArgs Members


ModificationsDone Property

ModificationsDone Property

DicomObjects.EventArguments Namespace > QueryReceivedArgs Class : ModificationsDone Property
Property to inform DicomObjects whether frame extraction (as per Supplement 119) has been performed
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ModificationsDone As Boolean
'Usage

Dim instance As QueryReceivedArgs
Dim value As Boolean

instance.ModificationsDone = value

value = instance.ModificationsDone
public bool ModificationsDone {get; set;}
public:
property bool ModificationsDone {
   bool get();
   void set (    bool value);
}
Remarks
If a FRAME level retrieve is requested, then the SCP is required to create a new instance consisting of the requested frames from the original image. There are 2 options for doing this in in DicomObjects:
  • Simply send the original instance using DicomObjects.DicomAssociation.SendInstances and allow DicomObjects to create the new image
  • Make the new object yourself and send using DicomObjects.DicomAssociation.SendInstances. If this option is chosen then ModificationsDone must be set to true to inform DicomObjects not to do an internal extraction as well.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

QueryReceivedArgs Class
QueryReceivedArgs Members


NumberCompleted Property

NumberCompleted Property

DicomObjects.EventArguments Namespace > QueryReceivedArgs Class : NumberCompleted Property
Numbers of completed C-STORE sub-operations in a C-GET or C_MOVE operation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NumberCompleted As Integer
'Usage

Dim instance As QueryReceivedArgs
Dim value As Integer

instance.NumberCompleted = value

value = instance.NumberCompleted
public int NumberCompleted {get; set;}
public:
property int NumberCompleted {
   int get();
   void set (    int value);
}
Remarks
NumberComleted, NumberWarning, NumberFailed and NumberRemaining, these values are returned to the requester as part of pending or final status notifications.

Values are updated automatically as part of SendImages, each operation decrementing NumberRemaining, and incrementing NumberCompleted, NumberWarning or NumberFailed according to the status returned.

If NumberRemaining is less than the number of images sent by a SendImages call, then NumberRemaining is set to the number of images to be returned by that call. Therefore, if an application intends to return all the images for a request in one operation, then it need not manipulate these values at all, as the DicomAssociation object will handle then automatically. If however the application wishes to call SendImages more than once, then NumberRemaining must be set correctly before the first call.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

QueryReceivedArgs Class
QueryReceivedArgs Members


NumberFailed Property

NumberFailed Property

DicomObjects.EventArguments Namespace > QueryReceivedArgs Class : NumberFailed Property
Numbers of failed C-STORE sub-operations in a C-GET or C_MOVE operation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NumberFailed As Integer
'Usage

Dim instance As QueryReceivedArgs
Dim value As Integer

instance.NumberFailed = value

value = instance.NumberFailed
public int NumberFailed {get; set;}
public:
property int NumberFailed {
   int get();
   void set (    int value);
}
Remarks
NumberComleted, NumberWarning, NumberFailed and NumberRemaining, these values are returned to the requester as part of pending or final status notifications.

Values are updated automatically as part of SendImages, each operation decrementing NumberRemaining, and incrementing NumberCompleted, NumberWarning or NumberFailed according to the status returned.

If NumberRemaining is less than the number of images sent by a SendImages call, then NumberRemaining is set to the number of images to be returned by that call. Therefore, if an application intends to return all the images for a request in one operation, then it need not manipulate these values at all, as the DicomAssociation object will handle then automatically. If however the application wishes to call SendImages more than once, then NumberRemaining must be set correctly before the first call.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

QueryReceivedArgs Class
QueryReceivedArgs Members


NumberRemaining Property

NumberRemaining Property

DicomObjects.EventArguments Namespace > QueryReceivedArgs Class : NumberRemaining Property
Numbers of remaining C-STORE sub-operations in a C-GET or C_MOVE operation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NumberRemaining As Integer
'Usage

Dim instance As QueryReceivedArgs
Dim value As Integer

instance.NumberRemaining = value

value = instance.NumberRemaining
public int NumberRemaining {get; set;}
public:
property int NumberRemaining {
   int get();
   void set (    int value);
}
Remarks

NumberComleted, NumberWarning, NumberFailed and NumberRemaining, these values are returned to the requester as part of pending or final status notifications.

Values are updated automatically as part of SendImages, each operation decrementing NumberRemaining, and incrementing NumberCompleted, NumberWarning or NumberFailed according to the status returned.

If NumberRemaining is less than the number of images sent by a SendImages call, then NumberRemaining is set to the number of images to be returned by that call. Therefore, if an application intends to return all the images for a request in one operation, then it need not manipulate these values at all, as the DicomAssociation object will handle then automatically. If however the application wishes to call SendImages more than once, then NumberRemaining must be set correctly before the first call.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

QueryReceivedArgs Class
QueryReceivedArgs Members


NumberWarning Property

NumberWarning Property

DicomObjects.EventArguments Namespace > QueryReceivedArgs Class : NumberWarning Property
Numbers of warning C-STORE sub-operations in a C-GET or C_MOVE operation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NumberWarning As Integer
'Usage

Dim instance As QueryReceivedArgs
Dim value As Integer

instance.NumberWarning = value

value = instance.NumberWarning
public int NumberWarning {get; set;}
public:
property int NumberWarning {
   int get();
   void set (    int value);
}
Remarks
NumberComleted, NumberWarning, NumberFailed and NumberRemaining, these values are returned to the requester as part of pending or final status notifications.

Values are updated automatically as part of SendImages, each operation decrementing NumberRemaining, and incrementing NumberCompleted, NumberWarning or NumberFailed according to the status returned.

If NumberRemaining is less than the number of images sent by a SendImages call, then NumberRemaining is set to the number of images to be returned by that call. Therefore, if an application intends to return all the images for a request in one operation, then it need not manipulate these values at all, as the DicomAssociation object will handle then automatically. If however the application wishes to call SendImages more than once, then NumberRemaining must be set correctly before the first call.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

QueryReceivedArgs Class
QueryReceivedArgs Members


RetrieveType Property

RetrieveType Property

DicomObjects.EventArguments Namespace > QueryReceivedArgs Class : RetrieveType Property
The type of retrieval requested
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RetrieveType As RetrieveType
'Usage

Dim instance As QueryReceivedArgs
Dim value As RetrieveType

instance.RetrieveType = value

value = instance.RetrieveType
public RetrieveType RetrieveType {get; set;}
public:
property RetrieveType RetrieveType {
   RetrieveType get();
   void set (    RetrieveType value);
}
Remarks
Until 2009, all DICOM retrievals were "Full", but supplement 119 introduced the concept of "No Bulk data" retrieval, which can be indicated by this property.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

QueryReceivedArgs Class
QueryReceivedArgs Members


Root Property (QueryReceivedArgs)

Root Property (QueryReceivedArgs)

DicomObjects.EventArguments Namespace > QueryReceivedArgs Class : Root Property
The Query Root
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Root As QueryRoot
'Usage

Dim instance As QueryReceivedArgs
Dim value As QueryRoot

value = instance.Root
public QueryRoot Root {get;}
public:
property QueryRoot Root {
   QueryRoot get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

QueryReceivedArgs Class
QueryReceivedArgs Members


ReceivingPixelDataArgs Class

ReceivingPixelDataArgs Class
Members

DicomObjects.EventArguments Namespace : ReceivingPixelDataArgs Class
Class used by the DicomObjects.DicomServer.ReceivingPixelData event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ReceivingPixelDataArgs
'Usage

Dim instance As ReceivingPixelDataArgs
public class ReceivingPixelDataArgs
public ref class ReceivingPixelDataArgs
Inheritance Hierarchy

System.Object
DicomObjects.EventArguments.ReceivingPixelDataArgs

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ReceivingPixelDataArgs Members
DicomObjects.EventArguments Namespace


ReceivingPixelDataArgs Class Members

ReceivingPixelDataArgs Class Members
Properties Methods

DicomObjects.EventArguments Namespace : ReceivingPixelDataArgs Class

The following tables list the members exposed by ReceivingPixelDataArgs.

Public Properties
 | Name | Description
Public Property | Association | The association on which data is arriving
Public Property | Dataset | The dataset so far
Top
Public Methods
 | Name | Description
Public Method | ReceiveToDisk | Write the data received so far to the names file, and then pass received pixel data direct to that file, without holding it all in memory
Top
See Also

Reference

ReceivingPixelDataArgs Class
DicomObjects.EventArguments Namespace


ReceivingPixelDataArgs Class Methods

ReceivingPixelDataArgs Class Methods

DicomObjects.EventArguments Namespace : ReceivingPixelDataArgs Class

For a list of all members of this type, see ReceivingPixelDataArgs members.

Public Methods
 | Name | Description
Public Method | ReceiveToDisk | Write the data received so far to the names file, and then pass received pixel data direct to that file, without holding it all in memory
Top
See Also

Reference

ReceivingPixelDataArgs Class
DicomObjects.EventArguments Namespace


ReceiveToDisk Method

ReceiveToDisk Method

DicomObjects.EventArguments Namespace > ReceivingPixelDataArgs Class : ReceiveToDisk Method
Write the data received so far to the names file, and then pass received pixel data direct to that file, without holding it all in memory
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ReceiveToDisk( _
   ByVal FileName As String _
)
'Usage

Dim instance As ReceivingPixelDataArgs
Dim FileName As String

instance.ReceiveToDisk(FileName)
public void ReceiveToDisk(
   string FileName
)
public:
void ReceiveToDisk(
   String^ FileName
)

Parameters

FileName
Remarks

The transfer syntax used for the file is always the same as that received over the network

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ReceivingPixelDataArgs Class
ReceivingPixelDataArgs Members


ReceivingPixelDataArgs Class Properties

ReceivingPixelDataArgs Class Properties

DicomObjects.EventArguments Namespace : ReceivingPixelDataArgs Class

For a list of all members of this type, see ReceivingPixelDataArgs members.

Public Properties
 | Name | Description
Public Property | Association | The association on which data is arriving
Public Property | Dataset | The dataset so far
Top
See Also

Reference

ReceivingPixelDataArgs Class
DicomObjects.EventArguments Namespace


Association Property (ReceivingPixelDataArgs)

Association Property (ReceivingPixelDataArgs)

DicomObjects.EventArguments Namespace > ReceivingPixelDataArgs Class : Association Property
The association on which data is arriving
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Association As DicomAssociation
'Usage

Dim instance As ReceivingPixelDataArgs
Dim value As DicomAssociation

value = instance.Association
public DicomAssociation Association {get;}
public:
property DicomAssociation^ Association {
   DicomAssociation^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ReceivingPixelDataArgs Class
ReceivingPixelDataArgs Members


Dataset Property (ReceivingPixelDataArgs)

Dataset Property (ReceivingPixelDataArgs)

DicomObjects.EventArguments Namespace > ReceivingPixelDataArgs Class : Dataset Property
The dataset so far
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Dataset As DicomDataSet
'Usage

Dim instance As ReceivingPixelDataArgs
Dim value As DicomDataSet

value = instance.Dataset
public DicomDataSet Dataset {get;}
public:
property DicomDataSet^ Dataset {
   DicomDataSet^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ReceivingPixelDataArgs Class
ReceivingPixelDataArgs Members


ResponseReceivedArgs Class

ResponseReceivedArgs Class
Members

DicomObjects.EventArguments Namespace : ResponseReceivedArgs Class
Event argument passed in the ResponseReceived
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ResponseReceivedArgs
   Inherits System.EventArgs
'Usage

Dim instance As ResponseReceivedArgs
public class ResponseReceivedArgs : System.EventArgs
public ref class ResponseReceivedArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
DicomObjects.EventArguments.ResponseReceivedArgs

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ResponseReceivedArgs Members
DicomObjects.EventArguments Namespace


ResponseReceivedArgs Class Members

ResponseReceivedArgs Class Members
Properties

DicomObjects.EventArguments Namespace : ResponseReceivedArgs Class

The following tables list the members exposed by ResponseReceivedArgs.

Public Properties
 | Name | Description
Public Property | Association | The incoming association that contains the received responses
Public Property | ReturnStatus | The Status to be returned for Instance received via C-GET
Top
See Also

Reference

ResponseReceivedArgs Class
DicomObjects.EventArguments Namespace


ResponseReceivedArgs Class Properties

ResponseReceivedArgs Class Properties

DicomObjects.EventArguments Namespace : ResponseReceivedArgs Class

For a list of all members of this type, see ResponseReceivedArgs members.

Public Properties
 | Name | Description
Public Property | Association | The incoming association that contains the received responses
Public Property | ReturnStatus | The Status to be returned for Instance received via C-GET
Top
See Also

Reference

ResponseReceivedArgs Class
DicomObjects.EventArguments Namespace


Association Property (ResponseReceivedArgs)

Association Property (ResponseReceivedArgs)

DicomObjects.EventArguments Namespace > ResponseReceivedArgs Class : Association Property
The incoming association that contains the received responses
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Association As DicomAssociation
'Usage

Dim instance As ResponseReceivedArgs
Dim value As DicomAssociation

value = instance.Association
public DicomAssociation Association {get;}
public:
property DicomAssociation^ Association {
   DicomAssociation^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ResponseReceivedArgs Class
ResponseReceivedArgs Members


ReturnStatus Property

ReturnStatus Property

DicomObjects.EventArguments Namespace > ResponseReceivedArgs Class : ReturnStatus Property
The Status to be returned for Instance received via C-GET
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ReturnStatus As Integer
'Usage

Dim instance As ResponseReceivedArgs
Dim value As Integer

instance.ReturnStatus = value

value = instance.ReturnStatus
public int ReturnStatus {get; set;}
public:
property int ReturnStatus {
   int get();
   void set (    int value);
}
Remarks

C-GET request causes internal C-STORE operations to happen and this property provides means to send status back after each single instance received via C-STORE. The default value is zero and if you need to send non-zero status back to indicate an unsuccessful C-Store operation, set this property to any non-zero value (normally 1).

The COM version hasn't got such a property to send non-zero C-Store (caused by C-GET) status back.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ResponseReceivedArgs Class
ResponseReceivedArgs Members


UserSmoothingArgs Class

UserSmoothingArgs Class
Members

DicomObjects.EventArguments Namespace : UserSmoothingArgs Class
Class which provides support for the DicomObjects.DicomImage.UserSmoothing event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class UserSmoothingArgs
'Usage

Dim instance As UserSmoothingArgs
public class UserSmoothingArgs
public ref class UserSmoothingArgs
Inheritance Hierarchy

System.Object
DicomObjects.EventArguments.UserSmoothingArgs

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

UserSmoothingArgs Members
DicomObjects.EventArguments Namespace


UserSmoothingArgs Class Members

UserSmoothingArgs Class Members
Fields

DicomObjects.EventArguments Namespace : UserSmoothingArgs Class

The following tables list the members exposed by UserSmoothingArgs.

Public Constructors
 | Name | Description
Public Constructor | UserSmoothingArgs Constructor |
Top
Public Fields
 | Name | Description
Public Field | AreaToDraw | The area which is needed to be drawn
Public Field | Destination | The array to put the destination smoothed data into
Public Field | DestinationSize | The size of the Destination array
Public Field | MapArea | The coordinates of the area corresponding to the Destination
Public Field | Matrix | The transformation being applied to the pixel data for rendering
Public Field | Source | The source data to be smoothed
Public Field | SourceArea | The part of the original image represented by the data in the Source array
Top
See Also

Reference

UserSmoothingArgs Class
DicomObjects.EventArguments Namespace


UserSmoothingArgs Constructor

UserSmoothingArgs Constructor

DicomObjects.EventArguments Namespace > UserSmoothingArgs Class : UserSmoothingArgs Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New UserSmoothingArgs()
public UserSmoothingArgs()
public:
UserSmoothingArgs();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

UserSmoothingArgs Class
UserSmoothingArgs Members


UserSmoothingArgs Class Fields

UserSmoothingArgs Class Fields

DicomObjects.EventArguments Namespace : UserSmoothingArgs Class

For a list of all members of this type, see UserSmoothingArgs members.

Public Fields
 | Name | Description
Public Field | AreaToDraw | The area which is needed to be drawn
Public Field | Destination | The array to put the destination smoothed data into
Public Field | DestinationSize | The size of the Destination array
Public Field | MapArea | The coordinates of the area corresponding to the Destination
Public Field | Matrix | The transformation being applied to the pixel data for rendering
Public Field | Source | The source data to be smoothed
Public Field | SourceArea | The part of the original image represented by the data in the Source array
Top
See Also

Reference

UserSmoothingArgs Class
DicomObjects.EventArguments Namespace


AreaToDraw Field

AreaToDraw Field

DicomObjects.EventArguments Namespace > UserSmoothingArgs Class : AreaToDraw Field
The area which is needed to be drawn
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public AreaToDraw As Rectangle
'Usage

Dim instance As UserSmoothingArgs
Dim value As Rectangle

value = instance.AreaToDraw

instance.AreaToDraw = value
public Rectangle AreaToDraw
public:
Rectangle AreaToDraw
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

UserSmoothingArgs Class
UserSmoothingArgs Members


Destination Field

Destination Field

DicomObjects.EventArguments Namespace > UserSmoothingArgs Class : Destination Field
The array to put the destination smoothed data into
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Destination As Array
'Usage

Dim instance As UserSmoothingArgs
Dim value As Array

value = instance.Destination

instance.Destination = value
public Array Destination
public:
Array^ Destination
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

UserSmoothingArgs Class
UserSmoothingArgs Members


DestinationSize Field

DestinationSize Field

DicomObjects.EventArguments Namespace > UserSmoothingArgs Class : DestinationSize Field
The size of the Destination array
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public DestinationSize As Size
'Usage

Dim instance As UserSmoothingArgs
Dim value As Size

value = instance.DestinationSize

instance.DestinationSize = value
public Size DestinationSize
public:
Size DestinationSize
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

UserSmoothingArgs Class
UserSmoothingArgs Members


MapArea Field

MapArea Field

DicomObjects.EventArguments Namespace > UserSmoothingArgs Class : MapArea Field
The coordinates of the area corresponding to the Destination
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MapArea As Rectangle
'Usage

Dim instance As UserSmoothingArgs
Dim value As Rectangle

value = instance.MapArea

instance.MapArea = value
public Rectangle MapArea
public:
Rectangle MapArea
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

UserSmoothingArgs Class
UserSmoothingArgs Members


Matrix Field

Matrix Field

DicomObjects.EventArguments Namespace > UserSmoothingArgs Class : Matrix Field
The transformation being applied to the pixel data for rendering
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Matrix As Matrix
'Usage

Dim instance As UserSmoothingArgs
Dim value As Matrix

value = instance.Matrix

instance.Matrix = value
public Matrix Matrix
public:
Matrix^ Matrix
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

UserSmoothingArgs Class
UserSmoothingArgs Members


Source Field

Source Field

DicomObjects.EventArguments Namespace > UserSmoothingArgs Class : Source Field
The source data to be smoothed
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Source As Array
'Usage

Dim instance As UserSmoothingArgs
Dim value As Array

value = instance.Source

instance.Source = value
public Array Source
public:
Array^ Source
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

UserSmoothingArgs Class
UserSmoothingArgs Members


SourceArea Field

SourceArea Field

DicomObjects.EventArguments Namespace > UserSmoothingArgs Class : SourceArea Field
The part of the original image represented by the data in the Source array
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public SourceArea As Rectangle
'Usage

Dim instance As UserSmoothingArgs
Dim value As Rectangle

value = instance.SourceArea

instance.SourceArea = value
public Rectangle SourceArea
public:
Rectangle SourceArea
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

UserSmoothingArgs Class
UserSmoothingArgs Members


ValidateFragmentsArgs Class

ValidateFragmentsArgs Class
Members

DicomObjects.EventArguments Namespace : ValidateFragmentsArgs Class
Argument for the DicomObjects.DicomGlobal.ValidateFragments event.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ValidateFragmentsArgs
'Usage

Dim instance As ValidateFragmentsArgs
public class ValidateFragmentsArgs
public ref class ValidateFragmentsArgs
Inheritance Hierarchy

System.Object
DicomObjects.EventArguments.ValidateFragmentsArgs

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ValidateFragmentsArgs Members
DicomObjects.EventArguments Namespace


ValidateFragmentsArgs Class Members

ValidateFragmentsArgs Class Members
Properties

DicomObjects.EventArguments Namespace : ValidateFragmentsArgs Class

The following tables list the members exposed by ValidateFragmentsArgs.

Public Constructors
 | Name | Description
Public Constructor | ValidateFragmentsArgs Constructor |
Top
Public Properties
 | Name | Description
Public Property | BasicOffsetTable | The basic offset table as read from the received data.
Public Property | DataSet | The dataset to which this pixel data belongs
Public Property | Fragments | The fragments exactly as received. These may be replaced, but if you do (whether by replacing individual Stream, or even by replacing the whole list of Streams, you must set Modified to true to force DicomObjects to use your modified data.
Public Property | Modified | Indication that data has been modified. Unless this is set to true, the return values in Fragments and BasicOffsetTable will be ignored.
Top
See Also

Reference

ValidateFragmentsArgs Class
DicomObjects.EventArguments Namespace


ValidateFragmentsArgs Constructor

ValidateFragmentsArgs Constructor

DicomObjects.EventArguments Namespace > ValidateFragmentsArgs Class : ValidateFragmentsArgs Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ValidateFragmentsArgs()
public ValidateFragmentsArgs()
public:
ValidateFragmentsArgs();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ValidateFragmentsArgs Class
ValidateFragmentsArgs Members


ValidateFragmentsArgs Class Properties

ValidateFragmentsArgs Class Properties

DicomObjects.EventArguments Namespace : ValidateFragmentsArgs Class

For a list of all members of this type, see ValidateFragmentsArgs members.

Public Properties
 | Name | Description
Public Property | BasicOffsetTable | The basic offset table as read from the received data.
Public Property | DataSet | The dataset to which this pixel data belongs
Public Property | Fragments | The fragments exactly as received. These may be replaced, but if you do (whether by replacing individual Stream, or even by replacing the whole list of Streams, you must set Modified to true to force DicomObjects to use your modified data.
Public Property | Modified | Indication that data has been modified. Unless this is set to true, the return values in Fragments and BasicOffsetTable will be ignored.
Top
See Also

Reference

ValidateFragmentsArgs Class
DicomObjects.EventArguments Namespace


BasicOffsetTable Property

BasicOffsetTable Property

DicomObjects.EventArguments Namespace > ValidateFragmentsArgs Class : BasicOffsetTable Property
The basic offset table as read from the received data.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BasicOffsetTable As UInteger()
'Usage

Dim instance As ValidateFragmentsArgs
Dim value() As UInteger

instance.BasicOffsetTable = value

value = instance.BasicOffsetTable
public uint[] BasicOffsetTable {get; set;}
public:
property array<uint>^ BasicOffsetTable {
   array<uint>^ get();
   void set (    array<uint>^ value);
}
Remarks

You may set this to null if modifying the data, and DicomObjects will attempt to recalculate it, checking whether the fragements start with the appropriate markers.

Alternatively, you may set it explicitly

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ValidateFragmentsArgs Class
ValidateFragmentsArgs Members


DataSet Property (ValidateFragmentsArgs)

DataSet Property (ValidateFragmentsArgs)

DicomObjects.EventArguments Namespace > ValidateFragmentsArgs Class : DataSet Property
The dataset to which this pixel data belongs
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property DataSet As DicomDataSet
'Usage

Dim instance As ValidateFragmentsArgs
Dim value As DicomDataSet

value = instance.DataSet
public DicomDataSet DataSet {get;}
public:
property DicomDataSet^ DataSet {
   DicomDataSet^ get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ValidateFragmentsArgs Class
ValidateFragmentsArgs Members


Fragments Property

Fragments Property

DicomObjects.EventArguments Namespace > ValidateFragmentsArgs Class : Fragments Property
The fragments exactly as received. These may be replaced, but if you do (whether by replacing individual Stream, or even by replacing the whole list of Streams, you must set Modified to true to force DicomObjects to use your modified data.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Fragments As List(Of List(Of Stream))
'Usage

Dim instance As ValidateFragmentsArgs
Dim value As List(Of List(Of Stream))

instance.Fragments = value

value = instance.Fragments
public List<List<Stream>> Fragments {get; set;}
public:
property List<List<Stream^>^>^ Fragments {
   List<List<Stream^>^>^ get();
   void set (    List<List<Stream^>^>^ value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ValidateFragmentsArgs Class
ValidateFragmentsArgs Members


Modified Property

Modified Property

DicomObjects.EventArguments Namespace > ValidateFragmentsArgs Class : Modified Property
Indication that data has been modified. Unless this is set to true, the return values in Fragments and BasicOffsetTable will be ignored.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Modified As Boolean
'Usage

Dim instance As ValidateFragmentsArgs
Dim value As Boolean

instance.Modified = value

value = instance.Modified
public bool Modified {get; set;}
public:
property bool Modified {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

ValidateFragmentsArgs Class
ValidateFragmentsArgs Members


VerifyReceivedArgs Class

VerifyReceivedArgs Class
Members

DicomObjects.EventArguments Namespace : VerifyReceivedArgs Class
Argument passed in the VerifyReceived Event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class VerifyReceivedArgs
   Inherits OperationBaseArgs
'Usage

Dim instance As VerifyReceivedArgs
public class VerifyReceivedArgs : OperationBaseArgs
public ref class VerifyReceivedArgs : public OperationBaseArgs
Inheritance Hierarchy

System.Object
System.EventArgs
DicomObjects.EventArguments.OperationBaseArgs
DicomObjects.EventArguments.VerifyReceivedArgs

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VerifyReceivedArgs Members
DicomObjects.EventArguments Namespace


VerifyReceivedArgs Class Members

VerifyReceivedArgs Class Members
Properties

DicomObjects.EventArguments Namespace : VerifyReceivedArgs Class

The following tables list the members exposed by VerifyReceivedArgs.

Public Properties
 | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Top
See Also

Reference

VerifyReceivedArgs Class
DicomObjects.EventArguments Namespace


DicomObjects.InternalCodecs.JPIP Namespace

DicomObjects.InternalCodecs.JPIP Namespace
Inheritance Hierarchy
See Also

Reference

DicomObjects.NET.8.40 Assembly


DicomObjects.Video Namespace

DicomObjects.Video Namespace
Inheritance Hierarchy
Defines classes and enums available for fine tuning video decoding/encoding
Classes
 | Class | Description
Class | VideoCompressionOptions | Control the encoding of video for either export, or for encoding into one of the DICOM video transfer syntaxes
Enumerations
 | Enumeration | Description
Enumeration | Level | Video level enumerations
Enumeration | Profile | Video profile enumerations
See Also

Reference

DicomObjects.NET.8.40 Assembly


VideoCompressionOptions Class

VideoCompressionOptions Class
Members

DicomObjects.Video Namespace : VideoCompressionOptions Class
Control the encoding of video for either export, or for encoding into one of the DICOM video transfer syntaxes
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class VideoCompressionOptions
'Usage

Dim instance As VideoCompressionOptions
public class VideoCompressionOptions
public ref class VideoCompressionOptions
Remarks

The only public constructor for this class takes a DicomImage and a "format" - which is generally the extension of the file to be used for export, which therefore sets the Container, which in turn normally sets a default codec. The Codec can however subsequently be changed.

For internal DICOM transfer syntax conversion, default VideoCompressionOptions objects are created to match the requirements of the output transfer syntax, but they may be

Inheritance Hierarchy

System.Object
DicomObjects.Video.VideoCompressionOptions

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VideoCompressionOptions Members
DicomObjects.Video Namespace


VideoCompressionOptions Class Members

VideoCompressionOptions Class Members
Properties

DicomObjects.Video Namespace : VideoCompressionOptions Class

The following tables list the members exposed by VideoCompressionOptions.

Public Constructors
 | Name | Description
Public Constructor | VideoCompressionOptions Constructor | Construct a default set of compression options for a given image and output format
Top
Public Properties
 | Name | Description
Public Property | BitsPerSecond | The defined output rate in Bits per second
Public Property | Container | The name of the container ("format") to use when encoding.
Public Property | ExplicitCodec | The name of the video compression codec to use
Public Property | FirstFrame | The first frame of the video to export
Public Property | InputFilter | Filter to apply to raw frames before scaling etc.
Public Property | InputFrameRate | The rate at which the source frames are to be used.
Public Property | LastFrame | The last frame of the video to export
Public Property | Level | Video level to use
Public Property | OutputFilter | Filter to apply to scaled frames before passing to the codec
Public Property | OutputFrameRate | The rate at which frame are fed to the codec
Public Property | OutputSize | The size of the output frames to be encoded
Public Property | PaddingColour | Colour to use for any padding required if OutputSize is not the same as the original DICOM image size
Public Property | Profile | The Video profile to use
Public Property | Scale | Controls whether to scale video if OutputSize is not the same as the original DICOM image size
Public Property | UseWindowing | Controls whether data is put into the MPEG "raw" or via the presentaiton chain, including windowing
Top
See Also

Reference

VideoCompressionOptions Class
DicomObjects.Video Namespace


VideoCompressionOptions Constructor

VideoCompressionOptions Constructor

DicomObjects.Video Namespace > VideoCompressionOptions Class : VideoCompressionOptions Constructor
The Image to be compressed to video
The output format - see remarks
If specified (may be null), then the specific codec is used - otherwise this can be selected internally based on the container
If set to a value convertable to an integer, then this is used to initialise the BitsPerSecond property
Construct a default set of compression options for a given image and output format
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal Image As DicomDataSet, _
   ByVal Format As String, _
   ByVal Codec As String, _
   ByVal Quality As Object _
)
'Usage

Dim Image As DicomDataSet
Dim Format As String
Dim Codec As String
Dim Quality As Object

Dim instance As New VideoCompressionOptions(Image, Format, Codec, Quality)
public VideoCompressionOptions(
   DicomDataSet Image,
   string Format,
   string Codec,
   object Quality
)
public:
VideoCompressionOptions(
   DicomDataSet^ Image,
   String^ Format,
   String^ Codec,
   Object^ Quality
)

Parameters

Image
The Image to be compressed to video
Format
The output format - see remarks
Codec
If specified (may be null), then the specific codec is used - otherwise this can be selected internally based on the container
Quality
If set to a value convertable to an integer, then this is used to initialise the BitsPerSecond property
Remarks

This constructor sets very many default options, depending on the characteristics of the image and the output format. Only change them if you know what you are doing!

The format parameter has 2 quite different forms:

  • If it is a UID, then it is interpretted as a DICOM Transfer Syntax, and options are set according to the DICOM rules for that transfer syntax
  • Otherwise, it is treated as an container format (such as "avi" or "mp4")

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VideoCompressionOptions Class
VideoCompressionOptions Members


VideoCompressionOptions Class Properties

VideoCompressionOptions Class Properties

DicomObjects.Video Namespace : VideoCompressionOptions Class

For a list of all members of this type, see VideoCompressionOptions members.

Public Properties
 | Name | Description
Public Property | BitsPerSecond | The defined output rate in Bits per second
Public Property | Container | The name of the container ("format") to use when encoding.
Public Property | ExplicitCodec | The name of the video compression codec to use
Public Property | FirstFrame | The first frame of the video to export
Public Property | InputFilter | Filter to apply to raw frames before scaling etc.
Public Property | InputFrameRate | The rate at which the source frames are to be used.
Public Property | LastFrame | The last frame of the video to export
Public Property | Level | Video level to use
Public Property | OutputFilter | Filter to apply to scaled frames before passing to the codec
Public Property | OutputFrameRate | The rate at which frame are fed to the codec
Public Property | OutputSize | The size of the output frames to be encoded
Public Property | PaddingColour | Colour to use for any padding required if OutputSize is not the same as the original DICOM image size
Public Property | Profile | The Video profile to use
Public Property | Scale | Controls whether to scale video if OutputSize is not the same as the original DICOM image size
Public Property | UseWindowing | Controls whether data is put into the MPEG "raw" or via the presentaiton chain, including windowing
Top
See Also

Reference

VideoCompressionOptions Class
DicomObjects.Video Namespace


BitsPerSecond Property

BitsPerSecond Property

DicomObjects.Video Namespace > VideoCompressionOptions Class : BitsPerSecond Property
The defined output rate in Bits per second
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BitsPerSecond As Integer
'Usage

Dim instance As VideoCompressionOptions
Dim value As Integer

instance.BitsPerSecond = value

value = instance.BitsPerSecond
public int BitsPerSecond {get; set;}
public:
property int BitsPerSecond {
   int get();
   void set (    int value);
}
Remarks
If the "Quality" parameter for video copmression is set to a number rather than a VideoCompressionOptions object, then a default VideoCompressionOptions object will be created, based on the format, and the rate will then be set to that quality value.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VideoCompressionOptions Class
VideoCompressionOptions Members


Container Property

Container Property

DicomObjects.Video Namespace > VideoCompressionOptions Class : Container Property
The name of the container ("format") to use when encoding.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Container As String
'Usage

Dim instance As VideoCompressionOptions
Dim value As String

instance.Container = value

value = instance.Container
public string Container {get; set;}
public:
property String^ Container {
   String^ get();
   void set (    String^ value);
}
Remarks

For encapsulating into DICOM, this must always be "mp4" (MPEG-4 Part 14) or "mpeg" (MPEG program stream) - irrespective of the ExplicitCodec used.

For export, this may be other formats such as "avi"

As "gif" is used for standard static gif export, the special value "v-gif" may be used which will force video export, and which will be passed to ffmpeg as "gif"

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VideoCompressionOptions Class
VideoCompressionOptions Members


ExplicitCodec Property

ExplicitCodec Property

DicomObjects.Video Namespace > VideoCompressionOptions Class : ExplicitCodec Property
The name of the video compression codec to use
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ExplicitCodec As String
'Usage

Dim instance As VideoCompressionOptions
Dim value As String

instance.ExplicitCodec = value

value = instance.ExplicitCodec
public string ExplicitCodec {get; set;}
public:
property String^ ExplicitCodec {
   String^ get();
   void set (    String^ value);
}
Remarks

This is semi-independent of the Container, but not all combinations are valid.

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VideoCompressionOptions Class
VideoCompressionOptions Members


FirstFrame Property

FirstFrame Property

DicomObjects.Video Namespace > VideoCompressionOptions Class : FirstFrame Property
The first frame of the video to export
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FirstFrame As Integer
'Usage

Dim instance As VideoCompressionOptions
Dim value As Integer

instance.FirstFrame = value

value = instance.FirstFrame
public int FirstFrame {get; set;}
public:
property int FirstFrame {
   int get();
   void set (    int value);
}
Remarks
Default is 1
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VideoCompressionOptions Class
VideoCompressionOptions Members


InputFilter Property

InputFilter Property

DicomObjects.Video Namespace > VideoCompressionOptions Class : InputFilter Property
Filter to apply to raw frames before scaling etc.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property InputFilter As String
'Usage

Dim instance As VideoCompressionOptions
Dim value As String

instance.InputFilter = value

value = instance.InputFilter
public string InputFilter {get; set;}
public:
property String^ InputFilter {
   String^ get();
   void set (    String^ value);
}
Remarks
The whole of the filter set defined by ffmpeg is available, and this filter allows options to be set as one would at the ffmpeg command line
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VideoCompressionOptions Class
VideoCompressionOptions Members


InputFrameRate Property

InputFrameRate Property

DicomObjects.Video Namespace > VideoCompressionOptions Class : InputFrameRate Property
The rate at which the source frames are to be used.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property InputFrameRate As Integer
'Usage

Dim instance As VideoCompressionOptions
Dim value As Integer

instance.InputFrameRate = value

value = instance.InputFrameRate
public int InputFrameRate {get; set;}
public:
property int InputFrameRate {
   int get();
   void set (    int value);
}
Remarks
By default, this is calculated the same way as is used for cine display, based on the FrameTime etc. in the DICOM data
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VideoCompressionOptions Class
VideoCompressionOptions Members


LastFrame Property

LastFrame Property

DicomObjects.Video Namespace > VideoCompressionOptions Class : LastFrame Property
The last frame of the video to export
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LastFrame As Integer
'Usage

Dim instance As VideoCompressionOptions
Dim value As Integer

instance.LastFrame = value

value = instance.LastFrame
public int LastFrame {get; set;}
public:
property int LastFrame {
   int get();
   void set (    int value);
}
Remarks
Default is the image's FrameCount
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VideoCompressionOptions Class
VideoCompressionOptions Members


Level Property (VideoCompressionOptions)

Level Property (VideoCompressionOptions)

DicomObjects.Video Namespace > VideoCompressionOptions Class : Level Property
Video level to use
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Level As Level
'Usage

Dim instance As VideoCompressionOptions
Dim value As Level

instance.Level = value

value = instance.Level
public Level Level {get; set;}
public:
property Level Level {
   Level get();
   void set (    Level value);
}
Remarks

It is the user's responsibility to ensure that the Level chosen is suitable for the chosen Codec, as different codecs use differnet numbering schemes.

If a particular value is not available in this list, please let us know for future releases, but a suitable integer value may simply be cast to a Level

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VideoCompressionOptions Class
VideoCompressionOptions Members


OutputFilter Property

OutputFilter Property

DicomObjects.Video Namespace > VideoCompressionOptions Class : OutputFilter Property
Filter to apply to scaled frames before passing to the codec
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OutputFilter As String
'Usage

Dim instance As VideoCompressionOptions
Dim value As String

instance.OutputFilter = value

value = instance.OutputFilter
public string OutputFilter {get; set;}
public:
property String^ OutputFilter {
   String^ get();
   void set (    String^ value);
}
Remarks
The whole of the filter set defined by ffmpeg is available, and this filter allows options to be set as one would at the ffmpeg command line
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VideoCompressionOptions Class
VideoCompressionOptions Members


OutputFrameRate Property

OutputFrameRate Property

DicomObjects.Video Namespace > VideoCompressionOptions Class : OutputFrameRate Property
The rate at which frame are fed to the codec
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OutputFrameRate As Integer
'Usage

Dim instance As VideoCompressionOptions
Dim value As Integer

instance.OutputFrameRate = value

value = instance.OutputFrameRate
public int OutputFrameRate {get; set;}
public:
property int OutputFrameRate {
   int get();
   void set (    int value);
}
Remarks
By default, this is the same as InputFrameRate, but some codecs (especially when combined with DICOM rules) have specific requirements, so this can be set independently. If the input and output rates differ, then the ffmpeg "fps" filter is applied to duplicate/drop as required.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VideoCompressionOptions Class
VideoCompressionOptions Members


OutputSize Property

OutputSize Property

DicomObjects.Video Namespace > VideoCompressionOptions Class : OutputSize Property
The size of the output frames to be encoded
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OutputSize As Size
'Usage

Dim instance As VideoCompressionOptions
Dim value As Size

instance.OutputSize = value

value = instance.OutputSize
public Size OutputSize {get; set;}
public:
property Size OutputSize {
   Size get();
   void set (    Size value);
}
Remarks
By default, this is the same as the size of the DICOm frames, but some codecs (especially when combined with DICOM rules) have specific requirements, so this can be set independently. If the input and output rates differ, then the ffmpeg "pad" and/or "scale" filters are change the size as required.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VideoCompressionOptions Class
VideoCompressionOptions Members
Scale Property
PaddingColour Property


PaddingColour Property

PaddingColour Property

DicomObjects.Video Namespace > VideoCompressionOptions Class : PaddingColour Property
Colour to use for any padding required if OutputSize is not the same as the original DICOM image size
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PaddingColour As Color
'Usage

Dim instance As VideoCompressionOptions
Dim value As Color

instance.PaddingColour = value

value = instance.PaddingColour
public Color PaddingColour {get; set;}
public:
property Color PaddingColour {
   Color get();
   void set (    Color value);
}
Remarks
Default is Black
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VideoCompressionOptions Class
VideoCompressionOptions Members


Profile Property

Profile Property

DicomObjects.Video Namespace > VideoCompressionOptions Class : Profile Property
The Video profile to use
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Profile As Profile
'Usage

Dim instance As VideoCompressionOptions
Dim value As Profile

instance.Profile = value

value = instance.Profile
public Profile Profile {get; set;}
public:
property Profile Profile {
   Profile get();
   void set (    Profile value);
}
Remarks

It is the user's responsibility to ensure that the Profile chosen is suitable for the chosen Codec, as different codecs use differnet numbering schemes.

If a particular value is not available in this list, please let us know for future releases, but a suitable integer value may simply be cast to a Profile

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VideoCompressionOptions Class
VideoCompressionOptions Members


Scale Property (VideoCompressionOptions)

Scale Property (VideoCompressionOptions)

DicomObjects.Video Namespace > VideoCompressionOptions Class : Scale Property
Controls whether to scale video if OutputSize is not the same as the original DICOM image size
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Scale As Boolean
'Usage

Dim instance As VideoCompressionOptions
Dim value As Boolean

instance.Scale = value

value = instance.Scale
public bool Scale {get; set;}
public:
property bool Scale {
   bool get();
   void set (    bool value);
}
Remarks

If true or if the original DICOM image size is larger than the OutputSize, then the images are scaled to fit on the most restrictive dimension

If false, and if the original DICOM image size is smaller than the OutputSize, then the original size is retained, and padding is placed around it

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VideoCompressionOptions Class
VideoCompressionOptions Members
OutputSize Property
PaddingColour Property


UseWindowing Property

UseWindowing Property

DicomObjects.Video Namespace > VideoCompressionOptions Class : UseWindowing Property
Controls whether data is put into the MPEG "raw" or via the presentaiton chain, including windowing
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property UseWindowing As Boolean
'Usage

Dim instance As VideoCompressionOptions
Dim value As Boolean

instance.UseWindowing = value

value = instance.UseWindowing
public bool UseWindowing {get; set;}
public:
property bool UseWindowing {
   bool get();
   void set (    bool value);
}
Remarks
The default for colour images is false, and for monochrome images it is true. It should not be set to false for images with more than 8 bits per sample.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

VideoCompressionOptions Class
VideoCompressionOptions Members


Level Enumeration

Level Enumeration

DicomObjects.Video Namespace : Level Enumeration
Video level enumerations
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum Level
   Inherits System.Enum
'Usage

Dim instance As Level
public enum Level : System.Enum
public enum class Level : public System.Enum
Members
Member | Description
MPEG2_High | MPEG 2 High level - as used in the MPEG-2 DICOM MP@HLtransfer syntax
MPEG2_High1440 | MPEG 2 High 1440 level (not generally used in DICOM)
MPEG2_Low | MPEG 2 Simple level (not generally used in DICOM)
MPEG2_Main | MPEG 2 Main level - as used in the MPEG-2 DICOM MP@MLtransfer syntax
MPEG4_41 | MPEG-4 AVC/H.264 Level 4.1 as used in the MPEG-4 AVC/H.264 HiP@Level4.1 transfer syntaxes
MPEG4_42 | MPEG-4 AVC/H.264 Level 4.2 as used in the MPEG-4 AVC/H.264 HiP@Level4.1 transfer syntaxes
Remarks

It is the user's responsibility to ensure that the Level chosen is suitable for the chosen Codec, as different codecs use differnet numbering schemes.

If a particular value is not available in this list, please let us know for future releases, but a suitable integer value may simply be cast to a Level

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Video.Level

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Video Namespace


Profile Enumeration

Profile Enumeration

DicomObjects.Video Namespace : Profile Enumeration
Video profile enumerations
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum Profile
   Inherits System.Enum
'Usage

Dim instance As Profile
public enum Profile : System.Enum
public enum class Profile : public System.Enum
Members
Member | Description
MPEG2_High | MPEG 2 High profile. This is not generally used in DICOM. Not to be confused with the High Level (Level.MPEG2_High which is used in the DICOM MPEG2 MP@HL transfer syntax)
MPEG2_Main | MPEG 2 Main profile - as used in the MPEG-2 DICOM transfer syntaxes
MPEG2_Simple | MPEG 2 Simple profile. This is not generally used in DICOM.
MPEG4_High | MPEG-4 AVC/H.264 High profile as used in the MPEG-4 AVC/H.264 HiP@Level4.1 transfer syntaxes
Remarks

It is the user's responsibility to ensure that the Profile chosen is suitable for the chosen Codec, as different codecs use different numbering schemes.

If a particular value is not available in this list, please let us know for future releases, but a suitable integer value may simply be cast to a Profile

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DicomObjects.Video.Profile

Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomObjects.Video Namespace


3D Functionality

3D Functionality
Reference Material > 3D Functionality

This is a major new feature in DicomObjects version 8, and this page provides notes on how to use it.

Concepts and Objects

The main things you need to know are:

  1. 3D reconstructions are still generated by DicomImage objects. This enables them to be viewed on DicomViewer controls via insertion to DicomImageCollection.
  2. These 3D images are represented by DicomImage3D class.
  3. A DicomVolume Object is created from either:
    1. A single multi-frame DicomImage Object
      OR
    2. A set of related single frame images in a DicomImages Collection
  4. You then control the viewing of the reconstruction by using the methods and properties accessible within the DicomImage3D class, which lists all 3D specific operations of that image.


API changes for DicomLabel

API changes for DicomLabel
Reference Material > API changes for DicomLabel

Introduction

Since labels on images were introduced in the very early days of DicomObjects, the facilities and flexibility for their display have been extended considerably, both for "specific" display and also to ensure full support for DICOM presentation states, as well as providing some rather specific requirements at some users' requests. The complexity is now rather excessive, and this has been compounded in V7 by the addition of the ability to rotate images by angles other than multiples of 90° leading to some anomalous effects when the image is rotated but the text is not.

We have therefore stepped right back and considered what is needed, bearing in mind the possible angular rotation, but always subject to the requirements for legibility. These requirements mean that text annotations cannot simply be treated the same as other graphics - to take an extreme example, flipping an image horizontally with a fully "image tied" label should fully flip an arrow etc., but clearly "mirror-image" text would be useless and possibly dangerous. Therefore the following options are planned for the new versions (.NET & COM). Whilst the primary design was based on text labels only, some users have expressed a wish to allow the same behaviour for non-text labels such as rectangles or ellipses and this has been incorporated, but the default for the 2 classes is different, being non-rotation for image tied text labels, but image tied rotation for non-text labels.

General

Text may be rotated and resized, but never mirrored

There is a (controllable) minimum font size

The specified size of the label will be used for wrapping and alignment, but will NOT cause text to be "clipped" - it will extend "downwards" (relative to its rendering angle) to ensure that whole string is rendered (but this might not all still be visible if obscured by other labels, images, or by the edge of the image area)

Auto-Sizing and Alignment

Auto-sizing is most useful when combined with showing a box around the text, or adding a line from the text to an "anchor point", as well as when adding "child labels" to the corners (.NET only). Previous versions have supported autosize as a simple Boolean, but with an obscure (user requested) means to specify that only the height should be shrunk, with the width remaining unchanged. These are being combined, with the addition (for consistency if nothing else) of a new option to preserve height but not width. As in all cases below, the dotted line indicates the defined "Area" of the label, and red indicates what is actually displayed:

This behaviour is controlled by a new AutoSizeMode property, which replaces the previous AutoSize (Boolean) property – the possibilities are:

NoAutoSize
AutoSizeWidth
AutoSizeHeight
Auto

This behaviour is of course modified by the chosen alignment, so for instance if the text is right & bottom aligned, then the appearance would be:

Similarly, if rotated, then the height/width remain relative to the rotated image's "text" frame of reference, giving for a 90° rotation (see below for when this would occur) this would be:

Explicit Rotation

This type of rotation is controlled by the Angle property of the label, and can be used on images of all scale modes (see following section for interaction with image pixel scale mode and rotated images). Whilst the DicomObjects API allows any degree of rotation, it should be noted that the DICOM Presentation State specification only allows exact multiples of 90° (via designation of one of the 4 corners as being "top left"). Whilst the angle is easy to specify as a single floating point value, there is an additional level of complexity due to the need to define the "centre of rotation", as not all users would necessarily wish this to be the centre of the label (especially if the area is defined as having a very large/unlimited right margin to avoid wrapping, as is often the case). Furthermore, if the centre were used by default, would that be the centre of the "whole" Area, or the centre of the reduced effective area actually occupied by the text (as used in AutoSized labels). A new enumeration and property have therefore been defined to control this behaviour:

RotationCentre:

RotateAtLabelCentre - default - centre of whole Area
RotateAtTextCentre - centre of actual text area (whether or not AutoSize is actually used)
RotateAtAutoSizeCentre - centre of whatever AutoSize is chosen
RotateAtPoint - defined by RotationPoint(.NET) or RotationPointX/Y (COM)

Transformation with the image

a) Rotation and Flipping

This is where the major complications arise, compounded by the different wishes of different developers. Before looking at the new model, I review the issues with the existing one. In the existing model, all works well if the text is allowed to rotate with the image (RotateTextWithImage = true), as all aspects of the label rotate in unison - e.g.

In the above scenarios, there is no need for any other adjustments to the text position, alignment nor angulation, and indeed it is important to prevent such accidental changes which were possible in the previous API - hence the decision as detailed below to move the top level control to a single enumeration, of which "RotatationMode.WithImage" is a complete definition. The only situation in which the overall effect is not the same as a simple transformation of the combined image & label is when the image is "flipped", either horizontally or vertically. In this case, the text is not mirrored, and the top left of the above set when flipped vertically would look like this:

or

With RotateAtLabelCentre With RotateAtLabelCentre
However, if the rectangle defining the area is allowed to rotate without rotation of the text, then the text and its container are mis-matched shapes, and some ambiguity arises. In these images, the green rectangle is the largest "straight" rectangle fitting within the rotated rectangle:

The above is the default behaviour of versions until now, inherited from V6, and whilst it makes some sense for the multiples of 90°, it makes no sense for other angles, and will therefore be dropped from now on. In its place will be a new "NoRotation" mode, which acts in an analogous but reversed manner to the simple rotation of an image without being image tied - i.e. the text will retain the same size and shape as if the image were NOT rotated. Like the simple rotation, this requires definition and use of a "rotation point", and the same RotationPoint and RotationCentre(X/Y) properties but in this case the definition will be in image pixel coordinates.

Equivalents to the above (moved slightly to separate centres of image and label) with NoRotate mode would now be:

With RotateAtLabelCentre

With RotateAtTextCentre

Similarly, the rotation point (the dot in the above) could be positioned elsewhere for RotateAtPoint mode.

2) Alignment

Previous versions have included a Boolean to specify whether the "Alignment" of a non-rotated text label within its overall Area should or should not be modified to match the rotation and flipping of the underlying image. This allowed text to stay at the "same corner" of the box as the box rotated

e.g.

Non-rotated

RotateAlignment = false

RotateAlignment = true

This however is not well defined when the angle can be a non multiple of 90°, and is superfluous when there is instead the ability to define the "rotation point" as being the centre of the actual text, thereby maintaining the equivalent effect of keeping the text in approximately the same place, irrespective of the "far" edges of the Area. This property is therefore being removed.

Combination of Image and Explicit Text Rotation angles

There can be independent angles for the image and the label. Logically, the point of rotation is selected, and an angle is calculated as the sum of the image rotation (if RotateWithImage mode, else 0) and the explicit rotation of the label itself. The text is then rotated about that combined angle.

Summary

The new API uses 5 properties to define the positioning and angle of the image relative to its Area and the image.

The following are new properties:

AutoSizeMode: enum

  1. AutoSize
  2. AutoSizeHeight
  3. AutoSizeWidth
  4. NoAutoSize

RotationMode: enum

  1. RotateWithImage
  2. NoRotate
  3. Default (RotateWithImage for non-text and NoRotate for text labels)

RotationCentre: enum

  1. RotateAtLabelCentre
  2. RotateAtTextCentre
  3. RotateAtAutoSizeCentre

RotateAtPoint

RotationPoint (PointF X&Y floats in COM)

These completely replace the following properties and registry values:

RotateTextWithImage : bool
RotateAlignmentWithImage: bool
AutoSize: bool
RegistryWord "FixedAutoWidth"


Third party license compliance

Third party license compliance
Reference Material > Third party license compliance

Below is a list of third party tools included in this product and their usage policy as defined. This is to make you (our users) aware of the usage of third party tools, their policies and adherence to the legal aspects of using them in your product. Here is the complete list of external code included in our product and how you are entitled to use them, if you wish to.

  1. FFmpeg is a Codec to support variety of video formats and their usage policy can be viewed on their website which also has a compliance checklist for using FFmpeg in your project https://www.ffmpeg.org/legal.html. You can also find their reference in our website license http://www.medicalconnections.co.uk/kb/Video_support_with_FFmpeg
  2. SharpDx, a .NET wrapper for Microsoft's DirectX, is used for GPU efficient processing. Its licensing terms can be found here http://sharpdx.org/License.txt
  3. Newtonsoft library has been used to parse Json data to DICOM and vice versa. Its licensing terms can be found here https://github.com/JamesNK/Newtonsoft.Json/blob/master/LICENSE.md


Useful Links

Useful Links
Reference Material > Useful Links

For FAQ please check our website articles, where you can find discussions and solutions for most common errors and questions regarding DICOM and our toolkit KB articles.

Latest DICOM standard can be found here DICOM standard.

For the latest list of DICOM attributes please follow this link DICOM standard Part 6.

Some values that relate to DicomObjects as a whole are controlled through registry values, which can be set using the RegWord and RegString methods of DicomGlobal. For latest list please click here.


Contents of this version

Contents of this version
Reference Material > Contents of this version

Main library files (All DICOM operations)

  • DicomObjects.NET.8.40.dll
  • DicomObjects.NET.8.40.xml (Documentation, intellisense tooltip)
  • DicomObjects.NET.8.40.XmlSerializers.dll (Serialization/Deserialization of classes)

Optional

Support for DirectX mode for rendering and displaying images (An alternative to GDI rendering)

  • SharpDX.Direct2D1.dll
  • SharpDX.Direct3D11.dll
  • SharpDX.dll
  • SharpDX.DXGI.dll

Video support using FFmpeg

32 bit

64 bit

  • FFmpeg.Adapter.x86.40.dll
  • avcodec.x86-57.dll
  • avdevice.x86-57.dll
  • avfilter.x86-6.dll
  • avformat.x86-57.dll
  • avutil.x86-55.dll
  • swresample.x86-2.dll
  • swscale.x86-4.dll
  • FFmpeg.Adapter.x64.40.dll
  • avcodec.x64-57.dll
  • avdevice.x64-57.dll
  • avfilter.x64-6.dll
  • avformat.x64-57.dll
  • avutil.x64-55.dll
  • swresample.x64-2.dll
  • swscale.x64-4.dll
* Please include appropriate DLLs depending on your project platform. You may include both sets of DLLs if your application supports both platforms.

PDF support (Importing PDF, writing encapsulated PDF in DICOM format and reading them)

32 bit

64 bit

  • ceTe.DynamicPDF.Viewer.40.x86.dll
  • ceTe.DynamicPDF.Viewer.40.x64.dll
* Please include appropriate DLLs depending on your project platform. You may include both sets of DLLs if your application supports both platforms.

JSON parser (mainly used in DICOM Web)

  • Newtonsoft.Json.dll

Web API client libraries (part of MVC installation, mainly used in DICOM Web)

  • System.Net.Http.dll
  • System.Net.Http.Formatting.dll
  • System.Net.Http.WebRequest.dll
  • System.Web.Http.dll

Release Notes (build log of all versions)

  • BuildHistory_NET.v8.txt


Contact Information

Contact Information
Reference Material > Contact Information

Contact Information for Medical Connections Ltd:

E-mail: | support@medicalconnections.co.uk
Web: | www.medicalconnections.co.uk
Address: | Suite 10, Henley House Queensway Fforestfach Swansea SA5 4DJ United Kingdom
Telephone: | +44 1792 390209 US toll free: (during UK business hours): 888 342 6634


Activation File

Activation File

This file is available to allow license activation to be controlled via an external file. This is useful for services etc. where a GUI is not available, but must not be confused with Signature Based Licensing, which is machine independent.

This activation file is a simple text file called DicomObjects.Activation in the same directory as the copy of DicomObjects DLL being used (which is normally the same as the application using it). It is similar in concept to the Config File

Each line is independent, and should conform to one of the following formats

  • A Comment

This is any line starting with # ; ' or // e.g. :

# This is a comment

  • ActivateOnLine

This has the form:

ActivateOnLine AuthorisationString, "Customer Info 1", "Customer Info 2"

It is exactly equivalent to the DicomLicense.ActivateOnLine method, and the result is recorded in the log file.

  • ActivateOffLine

This has the form:

ActivateOffLine AuthorisationString, LicenseToken

It is exactly equivalent to the DicomLicense.ActivateOffLine method, and the result is recorded in the log file. The LicenseToken should be obtained from http://activation.medicalconnections.co.uk, using the MachineID, which you need to obtain from either the log, or a separate program with a GUI etc.

  • DeleteAllLicenses

This has the form:

DeleteAllLicenses
It has no parameters, and deletes all locally stored licenses.

It is exactly equivalent to the DicomLicense.DeleteAllLicenses method.

  • StopIfValidLicense

This has the form:

StopIfValidLicense
It has no parameters, and causes all subsequent lines in the activation file to be ignored if a valid license already exists on this machine.

  • DeleteActivationFile

This has the form:

DeleteActivationFile
It causes the activation file itself to be deleted immediately - this should be considered for security reasons.


The Codec Model

The Codec Model

From version 5.6.3.x onwards DicomObjects, including this version, has used a new model for Codec interfacing. This is only used by those implementing their own custom codecs, and so does not affect the majority of customers, but for the benefit of those wishing to write/interface their own codecs, it is documented here.

The main difference is that a Codec "factory" is now created and used for each transfer syntax, allowing an instance of an appropriate Codec object (supporting ICompressor or IDecompressor) to be created and used when necessary. This object is held alongside the associated pixel data, and allows "state" to be maintained between calls, which is important for progressive decompression.

To use this interface:

  1. Implement a class derived from CodecFactory Class. This must:
    1. Return a list of strings (DICOM UIDs or file extensions) when the TransferSyntaxes method is called.
    2. Return as suitable Codec (as below) when its Compressor, Decompressor, Importer or Exporter methods are called. Only those methods for which a non-empty set of strings is returned from TransferSyntaxes need to function - the other may return NotImplemented exceptions.
  2. Implement suitable classes providing ICompressor, IDecompressor, IImporter, or IExporter interfaces to be returned from the above
  3. Call RegisterCodec Method in a startup method to register the factory class.

The addition of progressive decoding has added some complexity to the IDecompressor interface, but this has been avoided for most users by addition of the SimpleCodec Class, which includes implementations of most of the members of both ICompressor and IDecompressor, leaving only the unavoidable Compress and Decompress methods. It is still necessary to implement and register an associated CodecFactory to reference the new Codec, which should return and instance of the SimpleCodec derived class for one or both of the Compressor and Decompressor methods.


Config File

Config File

This file is available to allow some aspects of DicomObjects behaviour to be modified without the need to recompile your program. This is broadly equivalent to the registry as used in the COM version, but has the advantage of being application-specific, avoiding any side-effects for other applications.

This Config file is a simple text file called DicomObjects.Config in the same directory as the copy of DicomObjects dll being used (which is normally the same as the application using it). A similar facility exists for licensing override - see Activation File for more details.

Each line is independent, and should conform to one of the following formats:

  • A comment

This is any line starting with # ; ' or // e.g. :

# This is a comment

  • A "registry" value

This has the form:

Name = NumericValue

or

Name = "Stringvalue"

The form with quotes is equivalent to DicomGlobal.SetRegString(Name, Stringvalue) and the form without is equivalent to DicomGlobal.SetRegWord(Name, NumericValue)

  • A Static Property

This has the form:

Class.Property = Value

The type of Value is determined internally by reflection to match the type of the property, and it may be a number (decimal or hex - preceded by 0x or &H), a string, a boolean or an Enum (in which case multiple value may be separated by commas) - e.g.

DicomDataSet.DefaultValidationTypes = Basic, CharacterSet
DicomGlobal.Timeout = 300
DicomGlobal.MoveTimesOut = False

  • A DicomGlobal method call

This has the form:

MethodName parameter, parameter, parameter etc.
As for the static property, the types of the parameters are determined by reflection and may be a wide variety of types

This is primarily used to initiate or override logging behaviour, e.g.

LogToFile "C:\Logs", 0x3F

A special internal mechanism is used to "freeze" any logging enabled via the Configuration file, such that it cannot subsequently be changed by internal program calls - allowing definitive control from the Config file.


Conformance

Conformance

Please see the knowledge base article:

http://www.medicalconnections.co.uk/kb/Conformance_Statement_for_DicomObjects


Conversion

Conversion
This section will be expanded in the future, but for now please see the knowledge base article on COM conversion


DicomObjects.Delegates Namespace Inheritance Hierarchy

DicomObjects.Delegates Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
See Also

Reference

DicomObjects.NET.8.40 Assembly


DicomAssociationCollection Class Methods

DicomAssociationCollection Class Methods

DicomObjects Namespace : DicomAssociationCollection Class

For a list of all members of this type, see DicomAssociationCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<DicomAssociation>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<DicomAssociation>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<DicomAssociation>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<DicomAssociation>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<DicomAssociation>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<DicomAssociation>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<DicomAssociation>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<DicomAssociation>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<DicomAssociation>)
Top
See Also

Reference

DicomAssociationCollection Class
DicomObjects Namespace


VideoCodec Class Properties

VideoCodec Class Properties

DicomObjects.DicomCodecs Namespace : VideoCodec Class

For a list of all members of this type, see VideoCodec members.

Public Properties
 | Name | Description
Public Property | MaximumBits | The maximum number of bits supported by this codec. (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Public Property | NeedsPlanarConfigTransform | Lets a caller to Decompress tell whether data needs to be transformed following decompression. It is only relevant if the image has a Planar Configuration value (0028,0006) of 1. For the simple codec, the value comes from the constructor (Inherited from DicomObjects.DicomCodecs.SimpleCodec)
Top
See Also

Reference

VideoCodec Class
DicomObjects.DicomCodecs Namespace


DicomObjects.DicomCodecs Namespace Inheritance Hierarchy

DicomObjects.DicomCodecs Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
DicomObjects.DicomCodecs.CodecFactory
DicomObjects.DicomCodecs.CodecGlobal
DicomObjects.DicomCodecs.DicomCodecBaseArguments
DicomObjects.DicomCodecs.CompressionArguments
DicomObjects.DicomCodecs.DecompressionArguments
DicomObjects.DicomCodecs.ImportArguments
DicomObjects.DicomCodecs.ModificationArguments
DicomObjects.DicomCodecs.Jpeg2000CompressionOptions
DicomObjects.DicomCodecs.JpegLossy
DicomObjects.DicomCodecs.JpegLSCompressionOptions
DicomObjects.DicomCodecs.Jpip
DicomObjects.DicomCodecs.SimpleCodec
DicomObjects.DicomCodecs.JpegLossless
DicomObjects.DicomCodecs.VideoCodec
See Also

Reference

DicomObjects.NET.8.40 Assembly


FrameSubSet Method

FrameSubSet Method

DicomObjects Namespace > DicomDataSet Class : FrameSubSet Method
Generates a new DicomDataSet as a subset of the current instance as described in supplement 119
Overload List
Overload | Description
FrameSubSet | Generates a new DicomDataSet as a subset of the current instance as described in supplement 119
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


ValidateAll Method

ValidateAll Method

DicomObjects Namespace > DicomDataSet Class : ValidateAll Method
Validate all DicomAttributes within the DicomDataset
Overload List
Overload | Description
ValidateAll | [NEW] Validate all DicomAttributes within the DicomDataset based on the specified ValidationOptions.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomDataSet Class
DicomDataSet Members


DicomException Class Methods

DicomException Class Methods

DicomObjects Namespace : DicomException Class

For a list of all members of this type, see DicomException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

DicomException Class
DicomObjects Namespace


DicomImage3D Class Events

DicomImage3D Class Events

DicomObjects Namespace : DicomImage3D Class

For a list of all members of this type, see DicomImage3D members.

Public Events
 | Name | Description
Public Event | PositionChanged | An event which fires when the plane displayed by this image changes. (Inherited from DicomObjects.DicomImage)
Public Event | UserSmoothing | Setting this event enables a developer to specify his own smoothing algorithm. (Inherited from DicomObjects.DicomImage)
Top
See Also

Reference

DicomImage3D Class
DicomObjects Namespace


ScreenToWorld Method (DicomImage3D)

ScreenToWorld Method (DicomImage3D)

DicomObjects Namespace > DicomImage3D Class : ScreenToWorld Method
Calculate where in real world (X,Y,Z) space, a given screen point lies
Overload List
Overload | Description
ScreenToWorld(PointF,DicomViewer) | Calculate where in real world (X,Y,Z) space, a given screen point lies (Inherited from DicomObjects.DicomImage)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members
Base Implementation in ScreenToWorld


WorldToImage Method (DicomImage3D)

WorldToImage Method (DicomImage3D)

DicomObjects Namespace > DicomImage3D Class : WorldToImage Method
Calculate where in the image a real world point would lie
Overload List
Overload | Description
WorldToImage(Point3D,DicomViewer,Int32) | Calculate the nearest image coordinates for a point in real world (X,Y,Z) space, (Inherited from DicomObjects.DicomImage)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members
Base Implementation in WorldToImage


WorldToScreen Method (DicomImage3D)

WorldToScreen Method (DicomImage3D)

DicomObjects Namespace > DicomImage3D Class : WorldToScreen Method
Calculate where in the output pixel space a real world point would lie
Overload List
Overload | Description
WorldToScreen(Point3D,DicomViewer) | Calculate where in real world (X,Y,Z) space, a given screen point lies (Inherited from DicomObjects.DicomImage)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage3D Class
DicomImage3D Members
Base Implementation in WorldToScreen


DicomImageCurvedMPR Class Events

DicomImageCurvedMPR Class Events

DicomObjects Namespace : DicomImageCurvedMPR Class

For a list of all members of this type, see DicomImageCurvedMPR members.

Public Events
 | Name | Description
Public Event | PositionChanged | An event which fires when the plane displayed by this image changes. (Inherited from DicomObjects.DicomImage)
Public Event | UserSmoothing | Setting this event enables a developer to specify his own smoothing algorithm. (Inherited from DicomObjects.DicomImage)
Top
See Also

Reference

DicomImageCurvedMPR Class
DicomObjects Namespace


ScreenToWorld Method (DicomImageCurvedMPR)

ScreenToWorld Method (DicomImageCurvedMPR)

DicomObjects Namespace > DicomImageCurvedMPR Class : ScreenToWorld Method
Calculate where in real world (X,Y,Z) space, a given screen point lies
Overload List
Overload | Description
ScreenToWorld(PointF,DicomViewer) | Calculate where in real world (X,Y,Z) space, a given screen point lies (Inherited from DicomObjects.DicomImage)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCurvedMPR Class
DicomImageCurvedMPR Members
Base Implementation in ScreenToWorld


WorldToImage Method (DicomImageCurvedMPR)

WorldToImage Method (DicomImageCurvedMPR)

DicomObjects Namespace > DicomImageCurvedMPR Class : WorldToImage Method
Calculate where in the image a real world point would lie
Overload List
Overload | Description
WorldToImage(Point3D,DicomViewer,Int32) | Calculate the nearest image coordinates for a point in real world (X,Y,Z) space, (Inherited from DicomObjects.DicomImage)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCurvedMPR Class
DicomImageCurvedMPR Members
Base Implementation in WorldToImage


WorldToScreen Method (DicomImageCurvedMPR)

WorldToScreen Method (DicomImageCurvedMPR)

DicomObjects Namespace > DicomImageCurvedMPR Class : WorldToScreen Method
Calculate where in the output pixel space a real world point would lie
Overload List
Overload | Description
WorldToScreen(Point3D,DicomViewer) | Calculate where in real world (X,Y,Z) space, a given screen point lies (Inherited from DicomObjects.DicomImage)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageCurvedMPR Class
DicomImageCurvedMPR Members
Base Implementation in WorldToScreen


DicomImageFusion Class Events

DicomImageFusion Class Events

DicomObjects Namespace : DicomImageFusion Class

For a list of all members of this type, see DicomImageFusion members.

Public Events
 | Name | Description
Public Event | PositionChanged | An event which fires when the plane displayed by this image changes. (Inherited from DicomObjects.DicomImage)
Public Event | UserSmoothing | Setting this event enables a developer to specify his own smoothing algorithm. (Inherited from DicomObjects.DicomImage)
Top
See Also

Reference

DicomImageFusion Class
DicomObjects Namespace


ScreenToWorld Method (DicomImageFusion)

ScreenToWorld Method (DicomImageFusion)

DicomObjects Namespace > DicomImageFusion Class : ScreenToWorld Method
Calculate where in real world (X,Y,Z) space, a given screen point lies
Overload List
Overload | Description
ScreenToWorld(PointF,DicomViewer) | Calculate where in real world (X,Y,Z) space, a given screen point lies (Inherited from DicomObjects.DicomImage)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageFusion Class
DicomImageFusion Members
Base Implementation in ScreenToWorld


WorldToScreen Method (DicomImageFusion)

WorldToScreen Method (DicomImageFusion)

DicomObjects Namespace > DicomImageFusion Class : WorldToScreen Method
Calculate where in real world (X,Y,Z) space, a given screen point lies
Overload List
Overload | Description
WorldToScreen(Point3D,DicomViewer) | Calculate where in real world (X,Y,Z) space, a given screen point lies (Inherited from DicomObjects.DicomImage)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImageFusion Class
DicomImageFusion Members
Base Implementation in WorldToScreen


Dispose Method (DicomImage)

Dispose Method (DicomImage)

DicomObjects Namespace > DicomImage Class : Dispose Method
Standard Dispose methods
Overload List
Overload | Description
Dispose | Releases the resources used by the DicomImage object This does not dispose the underlying DicomDataSet object which is DataSet, an explicit Dispose call will be needed to have that effect
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


ImageToWorld Method

ImageToWorld Method

DicomObjects Namespace > DicomImage Class : ImageToWorld Method
Calculate the real-world 3D coordinates of a point of the image currently displayed
Overload List
Overload | Description
ImageToWorld | Calculate the real-world 3D coordinates of a point of the image currently displayed
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


ScreenToWorld Method (DicomImage)

ScreenToWorld Method (DicomImage)

DicomObjects Namespace > DicomImage Class : ScreenToWorld Method
Calculate where in real world (X,Y,Z) space, a given screen point lies
Overload List
Overload | Description
ScreenToWorld | Calculate where in real world (X,Y,Z) space, a given screen point lies
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


SetDefaultWindows Method

SetDefaultWindows Method

DicomObjects Namespace > DicomImage Class : SetDefaultWindows Method
Recalculates the default windows used by DicomObjects as if the image had just been loaded
Overload List
Overload | Description
SetDefaultWindows | Recalculates the default windows used by DicomObjects as if the image had just been loaded
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Update Method (DicomImage)

Update Method (DicomImage)

DicomObjects Namespace > DicomImage Class : Update Method
Causes the image to be updated
Overload List
Overload | Description
Update | Causes the image to be updated
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


WorldToImage Method (DicomImage)

WorldToImage Method (DicomImage)

DicomObjects Namespace > DicomImage Class : WorldToImage Method
Calculate the nearest image coordinates for a point in real world (X,Y,Z) space,
Overload List
Overload | Description
WorldToImage | Calculate the nearest image coordinates for a point in real world (X,Y,Z) space,
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


WorldToScreen Method (DicomImage)

WorldToScreen Method (DicomImage)

DicomObjects Namespace > DicomImage Class : WorldToScreen Method
Calculate where in real world (X,Y,Z) space, a given screen point lies
Overload List
Overload | Description
WorldToScreen | Calculate where in real world (X,Y,Z) space, a given screen point lies
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomImage Class
DicomImage Members


Dispose Method (DicomLabel3D)

Dispose Method (DicomLabel3D)

DicomObjects Namespace > DicomLabel3D Class : Dispose Method
Overload List
Overload | Description
Dispose | Standard Dispose
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel3D Class
DicomLabel3D Members


GetTickSpacing Method

GetTickSpacing Method

DicomObjects Namespace > DicomLabel Class : GetTickSpacing Method
Returns the size of the spacing used in a DicomLabel of type Ruler
Overload List
Overload | Description
GetTickSpacing | Returns the size of the spacing used in a DicomLabel of type Ruler
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Transform Method

Transform Method

DicomObjects Namespace > DicomLabel Class : Transform Method
Adjusts the position, size etc. of the label
Overload List
Overload | Description
Transform | Adjusts the position, size etc. of the label
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomLabel Class
DicomLabel Members


Implicit Type Conversion(String,UID) Operator

Implicit Type Conversion(String,UID) Operator

DicomObjects.DicomUIDs Namespace > UID Class > Implicit Type Conversion Operator : Implicit Type Conversion(String,UID) Operator
The UID object from which to obtain the Value
An implicit conversion to a string, returning the same string as Value
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal uid As UID _
) As String
'Usage

public string operator implicit(
   UID uid
)
public:
operator String^ (
   UID^ uid
)

Parameters

uid
The UID object from which to obtain the Value

Return Value

The dotted form of the UID as a string
Remarks
This conversion is provided to assists migration from earlier versions of DicomObjects.NET in which the UID objects were strings
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

UID Class
UID Members
Overload List


Implicit Type Conversion(UID,String) Operator

Implicit Type Conversion(UID,String) Operator

DicomObjects.DicomUIDs Namespace > UID Class > Implicit Type Conversion Operator : Implicit Type Conversion(UID,String) Operator
The UID as a string
Create a UID from a string
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As String _
) As UID
'Usage

public UID operator implicit(
   string value
)
public:
operator UID^ (
   String^ value
)

Parameters

value
The UID as a string

Return Value

The UID object
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

UID Class
UID Members
Overload List


DicomObjects.DicomUIDs Namespace Inheritance Hierarchy

DicomObjects.DicomUIDs Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
DicomObjects.DicomUIDs.ApplicationContexts
DicomObjects.DicomUIDs.FramesOfReference
DicomObjects.DicomUIDs.MetaSOPClasses
DicomObjects.DicomUIDs.SOPClasses
DicomObjects.DicomUIDs.TransferSyntaxes
DicomObjects.DicomUIDs.UID
DicomObjects.DicomUIDs.WellKnownInstances
See Also

Reference

DicomObjects.NET.8.40 Assembly


CellArea Method

CellArea Method

DicomObjects Namespace > DicomViewer Class : CellArea Method
Returns a rectangle representing the specified cell.
Overload List
Overload | Description
CellArea | Returns a rectangle representing the specified cell.
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


Dispose Method (DicomViewer)

Dispose Method (DicomViewer)

DicomObjects Namespace > DicomViewer Class : Dispose Method
Dispose the DicomViewer object
Overload List
Overload | Description
Dispose() | (Inherited from System.ComponentModel.Component)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members
Base Implementation in Dispose


Matrix Method (DicomViewer)

Matrix Method (DicomViewer)

DicomObjects Namespace > DicomViewer Class : Matrix Method
The Matrix used to define the given image in a viewer
Overload List
Overload | Description
Matrix | The Matrix used to define the given image in a viewer
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomViewer Class
DicomViewer Members


DicomVolume Class Events

DicomVolume Class Events

DicomObjects Namespace : DicomVolume Class

For a list of all members of this type, see DicomVolume members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from SharpDX.DisposeBase)
Public Event | Disposing | (Inherited from SharpDX.DisposeBase)
Top
See Also

Reference

DicomVolume Class
DicomObjects Namespace


Collect<T> Method

Collect<T> Method

DicomObjects Namespace > DicomVolume Class : Collect<T> Method
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function Collect(Of T)( _
   ByVal toDispose As T _
) As T
'Usage

Dim instance As DicomVolume
Dim toDispose As T
Dim value As T

value = instance.Collect(Of T)(toDispose)
public T Collect<T>(
   T toDispose
)
public:
T^ Collectgeneric<typename T>
(
   T^ toDispose
)

Parameters

toDispose

Type Parameters

T
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomVolume Class
DicomVolume Members


Count Property (DicomVolume)

Count Property (DicomVolume)

DicomObjects Namespace > DicomVolume Class : Count Property
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As DicomVolume
Dim value As Integer

value = instance.Count
public int Count {get;}
public:
property int Count {
   int get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomVolume Class
DicomVolume Members


Dispose Method (DicomVolume)

Dispose Method (DicomVolume)

DicomObjects Namespace > DicomVolume Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from SharpDX.DisposeBase)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomVolume Class
DicomVolume Members
Base Implementation in Dispose


Dispose() Method

Dispose() Method

DicomObjects Namespace > DicomVolume Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As DicomVolume

instance.Dispose()
public void Dispose()
public:
void Dispose();
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomVolume Class
DicomVolume Members


DisposeAndClear Method

DisposeAndClear Method

DicomObjects Namespace > DicomVolume Class : DisposeAndClear Method
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub DisposeAndClear( _
   Optional ByVal disposeManagedResources As Boolean _
)
'Usage

Dim instance As DicomVolume
Dim disposeManagedResources As Boolean

instance.DisposeAndClear(disposeManagedResources)
public void DisposeAndClear(
   bool disposeManagedResources
)
public:
void DisposeAndClear(
   bool disposeManagedResources
)

Parameters

disposeManagedResources
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomVolume Class
DicomVolume Members


Disposed Event

Disposed Event

DicomObjects Namespace > DicomVolume Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event Disposed As EventHandler(Of EventArgs)
'Usage

Dim instance As DicomVolume
Dim handler As EventHandler(Of EventArgs)

AddHandler instance.Disposed, handler
public event EventHandler<EventArgs> Disposed
public:
event EventHandler<EventArgs^>^ Disposed
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomVolume Class
DicomVolume Members


Disposing Event

Disposing Event

DicomObjects Namespace > DicomVolume Class : Disposing Event
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event Disposing As EventHandler(Of EventArgs)
'Usage

Dim instance As DicomVolume
Dim handler As EventHandler(Of EventArgs)

AddHandler instance.Disposing, handler
public event EventHandler<EventArgs> Disposing
public:
event EventHandler<EventArgs^>^ Disposing
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomVolume Class
DicomVolume Members


IsDisposed Property

IsDisposed Property

DicomObjects Namespace > DicomVolume Class : IsDisposed Property
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property IsDisposed As Boolean
'Usage

Dim instance As DicomVolume
Dim value As Boolean

value = instance.IsDisposed
public bool IsDisposed {get;}
public:
property bool IsDisposed {
   bool get();
}
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomVolume Class
DicomVolume Members


Remove<T> Method (DicomVolume)

Remove<T> Method (DicomVolume)

DicomObjects Namespace > DicomVolume Class : Remove<T> Method
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Remove(Of T)( _
   ByVal toDisposeArg As T _
)
'Usage

Dim instance As DicomVolume
Dim toDisposeArg As T

instance.Remove(Of T)(toDisposeArg)
public void Remove<T>(
   T toDisposeArg
)
public:
void Removegeneric<typename T>
(
   T^ toDisposeArg
)

Parameters

toDisposeArg

Type Parameters

T
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomVolume Class
DicomVolume Members


RemoveAndDispose<T> Method

RemoveAndDispose<T> Method

DicomObjects Namespace > DicomVolume Class : RemoveAndDispose<T> Method
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub RemoveAndDispose(Of T)( _
   ByRef objectToDispose As T _
)
'Usage

Dim instance As DicomVolume
Dim objectToDispose As T

instance.RemoveAndDispose(Of T)(objectToDispose)
public void RemoveAndDispose<T>(
   ref T objectToDispose
)
public:
void RemoveAndDisposegeneric<typename T>
(
   T^% objectToDispose
)

Parameters

objectToDispose

Type Parameters

T
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

DicomVolume Class
DicomVolume Members


DicomObjects.DicomWeb.Internal Namespace Inheritance Hierarchy

DicomObjects.DicomWeb.Internal Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
DicomObjects.DicomWeb.Internal.BulkData
DicomObjects.DicomWeb.Internal.DicomAttribute
DicomObjects.DicomWeb.Internal.Item
DicomObjects.DicomWeb.Internal.JsonAttribute
DicomObjects.DicomWeb.Internal.JsonPersonName
DicomObjects.DicomWeb.Internal.NamePart
DicomObjects.DicomWeb.Internal.NativeDicomModel
DicomObjects.DicomWeb.Internal.PersonName
DicomObjects.DicomWeb.Internal.Value
See Also

Reference

DicomObjects.NET.8.40 Assembly


DicomObjects.DicomWeb Namespace Inheritance Hierarchy

DicomObjects.DicomWeb Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
See Also

Reference

DicomObjects.NET.8.40 Assembly


DicomObjects.Enums Namespace Inheritance Hierarchy

DicomObjects.Enums Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
See Also

Reference

DicomObjects.NET.8.40 Assembly


Reject Method (AssociationRequestArgs)

Reject Method (AssociationRequestArgs)

DicomObjects.EventArguments Namespace > AssociationRequestArgs Class : Reject Method
Reject the assocation.
Overload List
Overload | Description
Reject | Reject a whole association request
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

AssociationRequestArgs Class
AssociationRequestArgs Members


NormalisedReceivedArgs Class Properties

NormalisedReceivedArgs Class Properties

DicomObjects.EventArguments Namespace : NormalisedReceivedArgs Class

For a list of all members of this type, see NormalisedReceivedArgs members.

Public Properties
 | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Top
See Also

Reference

NormalisedReceivedArgs Class
DicomObjects.EventArguments Namespace


VerifyReceivedArgs Class Properties

VerifyReceivedArgs Class Properties

DicomObjects.EventArguments Namespace : VerifyReceivedArgs Class

For a list of all members of this type, see VerifyReceivedArgs members.

Public Properties
 | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Top
See Also

Reference

VerifyReceivedArgs Class
DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace Inheritance Hierarchy

DicomObjects.EventArguments Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
DicomObjects.EventArguments.AssociationClosedArgs
DicomObjects.EventArguments.ChangeUidArgs
DicomObjects.EventArguments.DrawExceptionArgs
DicomObjects.EventArguments.DrawStartEventArgs
DicomObjects.EventArguments.ErrorReceivedArgs
DicomObjects.EventArguments.InfoMessageArgs
DicomObjects.EventArguments.LogEventArgs
DicomObjects.EventArguments.MakeControlArgs
DicomObjects.EventArguments.PSLabelCreatedArgs
DicomObjects.EventArguments.ReceivingPixelDataArgs
DicomObjects.EventArguments.UserSmoothingArgs
DicomObjects.EventArguments.ValidateFragmentsArgs
System.EventArgs
DicomObjects.EventArguments.AssociationRequestArgs
DicomObjects.EventArguments.OperationBaseArgs
DicomObjects.EventArguments.InstanceReceivedArgs
DicomObjects.EventArguments.N_Event_ReportArgs
DicomObjects.EventArguments.NormalisedReceivedArgs
DicomObjects.EventArguments.QueryReceivedArgs
DicomObjects.EventArguments.VerifyReceivedArgs
DicomObjects.EventArguments.ResponseReceivedArgs
See Also

Reference

DicomObjects.NET.8.40 Assembly


DicomObjects.InternalCodecs.JPIP Namespace Inheritance Hierarchy

DicomObjects.InternalCodecs.JPIP Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
See Also

Reference

DicomObjects.NET.8.40 Assembly


LicenseDialog Class Events

LicenseDialog Class Events

DicomObjects Namespace : LicenseDialog Class

For a list of all members of this type, see LicenseDialog members.

Public Events
 | Name | Description
Public Event | Activated | (Inherited from System.Windows.Forms.Form)
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.Form)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Deactivate | (Inherited from System.Windows.Forms.Form)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DpiChanged | (Inherited from System.Windows.Forms.Form)
Public Event | DpiChangedAfterParent | (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | FormClosed | (Inherited from System.Windows.Forms.Form)
Public Event | FormClosing | (Inherited from System.Windows.Forms.Form)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | HelpButtonClicked | (Inherited from System.Windows.Forms.Form)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | InputLanguageChanged | (Inherited from System.Windows.Forms.Form)
Public Event | InputLanguageChanging | (Inherited from System.Windows.Forms.Form)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.Form)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MaximizedBoundsChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MaximumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MdiChildActivate | (Inherited from System.Windows.Forms.Form)
Public Event | MinimumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | ResizeBegin | (Inherited from System.Windows.Forms.Form)
Public Event | ResizeEnd | (Inherited from System.Windows.Forms.Form)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftLayoutChanged | (Inherited from System.Windows.Forms.Form)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | Shown | (Inherited from System.Windows.Forms.Form)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

LicenseDialog Class
DicomObjects Namespace


LicenseDialog Class Properties

LicenseDialog Class Properties

DicomObjects Namespace : LicenseDialog Class

For a list of all members of this type, see LicenseDialog members.

Public Properties
 | Name | Description
Public Property | AcceptButton | (Inherited from System.Windows.Forms.Form)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.Form)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.Form)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.Form)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.Form)
Public Property | BackColor | (Inherited from System.Windows.Forms.Form)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | CancelButton | (Inherited from System.Windows.Forms.Form)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Form)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | ControlBox | (Inherited from System.Windows.Forms.Form)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | FormBorderStyle | (Inherited from System.Windows.Forms.Form)
Public Property | HelpButton | (Inherited from System.Windows.Forms.Form)
Public Property | Icon | (Inherited from System.Windows.Forms.Form)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | IsMdiContainer | (Inherited from System.Windows.Forms.Form)
Public Property | KeyPreview | (Inherited from System.Windows.Forms.Form)
Public Property | Location | (Inherited from System.Windows.Forms.Form)
Public Property | MainMenuStrip | (Inherited from System.Windows.Forms.Form)
Public Property | MaximizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Form)
Public Property | MinimizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Form)
Public Property | Opacity | (Inherited from System.Windows.Forms.Form)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeftLayout | (Inherited from System.Windows.Forms.Form)
Public Property | ShowIcon | (Inherited from System.Windows.Forms.Form)
Public Property | ShowInTaskbar | (Inherited from System.Windows.Forms.Form)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Form)
Public Property | SizeGripStyle | (Inherited from System.Windows.Forms.Form)
Public Property | StartPosition | (Inherited from System.Windows.Forms.Form)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.Form)
Public Property | TopMost | (Inherited from System.Windows.Forms.Form)
Public Property | TransparencyKey | (Inherited from System.Windows.Forms.Form)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | WindowState | (Inherited from System.Windows.Forms.Form)
Top
See Also

Reference

LicenseDialog Class
DicomObjects Namespace


Dispose Method (LicenseDialog)

Dispose Method (LicenseDialog)

DicomObjects Namespace > LicenseDialog Class : Dispose Method
Dispose the LicenseDialog
Overload List
Overload | Description
Dispose() | (Inherited from System.ComponentModel.Component)
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LicenseDialog Class
LicenseDialog Members
Base Implementation in Dispose


LookupTable Constructor

LookupTable Constructor

DicomObjects Namespace > LookupTable Class : LookupTable Constructor
Overload List
Overload | Description
LookupTable Constructor | Create a LUT from components
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

LookupTable Class
LookupTable Members


To2D Method

To2D Method

DicomObjects Namespace > Plane3D Structure : To2D Method
Convert from real world coordinates to the arbitrary frame of reference for this plane
Overload List
Overload | Description
To2D | Convert from real world coordinates to the arbitrary frame of reference for this plane
Requirements

Target Platforms: .NET CLR 4.0 or higher

See Also

Reference

Plane3D Structure
Plane3D Members


DicomObjects.Video Namespace Inheritance Hierarchy

DicomObjects.Video Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
DicomObjects.Video.VideoCompressionOptions
See Also

Reference

DicomObjects.NET.8.40 Assembly


DicomObjects Namespace Inheritance Hierarchy

DicomObjects Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
DicomObjects.ColourPalettes
DicomObjects.DicomAssociation
DicomObjects.DicomAttribute
DicomObjects.DicomContext
DicomObjects.DicomDataSet
DicomObjects.DicomGlobal
DicomObjects.DicomImage
DicomObjects.DicomImage3D
DicomObjects.DicomImageCurvedMPR
DicomObjects.DicomImageFusion
DicomObjects.DicomLabel
DicomObjects.DicomLabel3D
DicomObjects.DicomLicense
DicomObjects.DicomLicense.RamLicenseInfo
DicomObjects.DicomPrint
DicomObjects.DicomQuery
DicomObjects.DicomServer
DicomObjects.FileSignature
DicomObjects.LookupTable
DicomObjects.ReadBehaviours
DicomObjects.ValidationOptions
DicomObjects.WriteBehaviours
SharpDX.DisposeBase
SharpDX.DisposeCollector
DicomObjects.DicomVolume
System.Collections.ObjectModel.Collection<T>
DicomObjects.DicomAssociationCollection
DicomObjects.DicomDataSetCollection
DicomObjects.DicomImageCollection
DicomObjects.DicomLabelCollection
System.Collections.ObjectModel.KeyedCollection<TKey,TItem>
DicomObjects.DicomContextCollection
System.Exception
DicomObjects.DicomException
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
DicomObjects.DicomViewer
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
DicomObjects.LicenseDialog
System.ValueType
DicomObjects.Plane3D
See Also

Reference

DicomObjects.NET.8.40 Assembly


New Topic 2

New Topic 2


Transfer Syntax Negotiation

Transfer Syntax Negotiation

Please see the following article on the knowledge base:

http://www.medicalconnections.co.uk/kb/Transfer_Syntax_Control_on_the_Network