%%ItemTitle%%

DicomObjects.NET Core Documentation
In This Topic
    Introduction to DicomObjects.NET Core version

    DicomObjects.Core consists of an inter-related, but independent, set of .Core compatible "Objects" that enable developers to quickly and easily add DICOM functionality to their products without needing to understand or program the intricacies of the DICOM standard. This help file provides full reference to those objects and also some introductory guidance.

    Almost any aspect of DICOM image/data manipulation can be performed using DicomObjects, including:

    • Image read/write and parsing
    • Network transmission of images and associated data, including worklists
    • Printing to DICOM and windows printers
    • Normalised operations including storage commitment
    • Image creation from scratch and import/export to/from non-DICOM formats
    • DICOM Web client and server

    The main Components of DicomObjects are:

    DicomWeb Namespace

    All classes for RESTful DICOM Web Client and Server implmentations.

    DicomServer Class

    An object that provides storage, query/retrieve and normalised facilities as a service class provider (SCP). Events are raised in response to incoming operations.

    DicomQuery Class

    An object that handles the query/retrieve parts of the DICOM standard as a service class user (SCU).

    DicomDataSet Class

    Used for reading, writting, parsing, imporint and exportring DICOM objects

    DicomPrint Class

    Used for sending DICOM print requests to DICOM Printer SCP

    DicomGlobal Class

    Used for certain global operations, including logging and setting global behaviour.

    DicomAssociation Class

    A DicomAssociation Object represents a DICOM association, and may either be created automatically in response to an incoming query request, or explicitly by the client program. Methods of this object are used to send data, images, and verification requests.

    DicomException Class

    A DicomException Object represents the errors that occur within DicomObjects which is wrapped and thrown as a manageable exception in the user code with descriptive error messages.

    Other classes and collections are created and used by the above, and some may also be created directly. They are:

    Object Description | Single Item | Collection
Generic SOP instance, used for results of DICOM queries or as a sub-element of a Sequence | DicomDataSet Class | DicomDataSetCollection Class
Attribute (Data Element) of a DicomDataSet | DicomAttribute Class |
DICOM Presentation context | DicomContext Class | DicomContextCollection Class
Licencing Information and Control | DicomLicence Class |

    © 2022 Medical Connections Ltd

    Send feedback


    Release Notes

    This new version of DicomObjects.Core is based mainly on DicomObjects.NET v8 version with the only exception of the DicomViewer control missing due to lack of platform support in .NET core. Key features included in DicomObjects.Core version include:

    RESTful DICOM support
    This RESTful DICOM features can be found under DicomWeb namespace. It allows users to easily create their own DICOM Web client as well as self-hosted server applications.
    Video support using Latest FFmpeg

    Starting with version 8 we have added video support with the help of FFmpeg, a well established video Codec, for handling all sorts of popular video formats. This allows importing of supported video formats, embedding them into DICOM and exporting them using the appropriate transfer syntax.

    FFmpeg is licensed under the GNU Lesser Public license(LGPL). We comply with the rules as stated in FFmpeg's licensing terms (https://www.ffmpeg.org/legal.html) for using this open-source Codec in our product and would urge our users to be aware of the legal responsibilities of using it. For development status on this feature please check our webpage http://www.medicalconnections.co.uk/kb/Video_support_with_FFmpeg

    After recent discover of several vulnerabilities found in older versions of FFMPEG, DicomObjects.Core and DicomObjects.NET version have been upgraded to the latest Windows build of FFMPEG for better security.

    DicomLicencere API remain consistent with .NET version of DicomObjects
    Licensing is another topic that we have tried to be consistent with. All licensing models are supported and are identical to our .NET and COM versions, and easily accessible from DicomLicence.ActivateOnline/Offline() methods.

    There have been many internal code changes that are related to code normalization, efficiency and readability and some of them affect deep rooted routines like handling sequences, writing to disk, network transmission, etc. Most of these don't directly affect our API but some changes were unavoidable. If you have any problems with this version please contact us our Support Team.


    DicomObjects.Core Assembly
    Namespaces
    Namespace | Description
DicomObjects |
DicomObjects.Codecs |
DicomObjects.Delegates |
DicomObjects.DicomWeb |
DicomObjects.DicomWeb.Delegates |
DicomObjects.Enums |
DicomObjects.EventArguments |
DicomObjects.UIDs |
DicomObjects.Validation |
DicomObjects.Video |


Inheritance Hierarchy
    DicomObjects Namespace
    Classes
     | Class | Description
Class | DicomAssociation | Class representing a single DICOM Association
Class | DicomAttribute | Class representing a single DICOM Attribute
Class | DicomContext | A DICOM presentation context, as used in association negotiation
Class | DicomContextCollection | The list of DICOM Presentation contexts proposed or accepted during negotiation
Class | DicomDataSet | A DICOM data set
Class | DicomDataSetCollection | A collection of DicomDataSet objects
Class | DicomException | Specific Exception for DICOM errors
Class | DicomGlobal | Placeholder for various static methods and properties
Class | DicomLicence |
Class | DicomMaskRange |
Class | DicomQuery | Object used for DICOM Query/retrieve SCU operations
Class | DicomServer | An object for handling advanced network communications, as both SCU & SCP
Class | ReadBehaviours | Specific behaviour to use when reading/receiving a DICOM instance
Class | SequencePath |
Class | WriteBehaviours | Specific behaviour to use when writing/sending a DICOM instance
    Delegates
     | Delegate | Description
Delegate | DicomAttribute.DelayedDataRoutine | Delegate to fetch binary data for the bid
    See Also

    Reference

    DicomObjects.Core Assembly


%%PageItemTitle%%

DicomObjects Namespace / DicomAssociation Class
Members

In This Topic
    DicomAssociation Class
    In This Topic
    Class representing a single DICOM Association
    Object Model
    DicomAssociation ClassDicomContextCollection ClassDicomContext ClassDicomDataSet ClassDicomAttribute ClassDicomDataSet ClassDicomAttribute ClassDicomAssociation ClassReadBehaviours ClassDicomDataSet ClassDicomAttribute ClassDicomContextCollection ClassDicomContext ClassQueryReceivedArgs ClassDicomDataSetCollection ClassDicomDataSet ClassDicomDataSet ClassDicomAttribute ClassDicomDataSetCollection ClassDicomDataSet ClassDicomDataSetCollection ClassDicomDataSet ClassWriteBehaviours Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class DicomAssociation
    'Usage

Dim instance As DicomAssociation
    public class DicomAssociation
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomAssociation

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomAssociation Class
Properties Methods Events

In This Topic
    DicomAssociation Class Members
    In This Topic

    The following tables list the members exposed by DicomAssociation.

    Public Constructors
     | Name | Description
Public Constructor | DicomAssociation Constructor | Creates a new DicomAssociation object.
    Top
    Public Properties
     | Name | Description
Public Property | AgreedContexts | The Presentation Contexts associated with this DicomAssociation
Public Property | AssociationNumber | Returns the association number of current connection.
Public Property | BytesReceived | Approximate Measures of Network Input
Public Property | BytesSent | Approximate measures of Network Output
Public Property | CalledAET | Provides information about the remote application entity
Public Property | CallingAET | Provides information about the calling application entity
Public Property | Cancelled | Indicates that the remote AE has issued a C-CANCEL request.
Public Property | ChangeLossyUIDs |
Public Property | CheckForCancel | Control whether to check for incoming C-CANCEL asynchronous messages
Public Property | CoercionSOP | SOP Class to which images should be coerced if peer does not accept true SOP class
Public Property | Command |
static (Shared in Visual Basic) | DefaultThrowStatusException | The value intially assigned for the of new DicomAssociation objects.
Public Property | Destination |
Public Property | Identity | The user identity to use for an association
Public Property | ImplementationName | Returns the Implementation Version Name of the Connecting AE
Public Property | ImplementationUID | Returns the Implementation Class UID of the Connecting AE
Public Property | isOpen |
Public Property | LastCommand | Returns the last command in the current association.
Public Property | LastError | Returns the last error status from LastCommand.
Public Property | LastInstanceUID | Holds the InstanceUID created or used by the last normalised operation.
Public Property | LastOperation | Returns the last operation in the current association.
Public Property | LastStatus | Shortcut for the first element of the Status property
Public Property | LocalIP | Provide information about which local interface the remote application entity called
Public Property | LocalPort | Provide information about which local port the remote application entity called
Public Property | LogLevel | Controls the level of logging for this particular Association.
Public Property | MetaSOPClass | Determines the Abstract Syntax used for normalised operations
Public Property | MoveOriginator | The DicomAssociation object which initiated the C-MOVE resulting in the current C-STORE
Public Property | PreferredPCID | Provides guidance for the choice of presentation context
Public Property | PreferredTS | Provides guidance for the choice of presentation context
Public Property | PreferredTSList | Provides guidance for the choice of presentation context
Public Property | ReadBehaviour | Specific behaviours to use when receiving data on this association.
Public Property | RemoteIP | Provides information about the remote application entity
Public Property | Request | This contains the list of attributes to be matched, as specified in the DICOM standard
Public Property | RequestedContexts | The Presentation Contexts associated with this DicomAssociation
Public Property | RequestingQuery | Provides a linkage to the primary C-MOVE request.
Public Property | ReturnedCommands | The command datasets returned in response to the last operation
Public Property | ReturnedIdentifier | Hold data returned from outgoing operations
Public Property | ReturnedIdentifiers | Hold data returned from outgoing operations
Public Property | ReturnedInstances | Hold instances returned from outgoing C-GET operations
Public Property | SslStream | Returns the secure Stream object
Public Property | Status | Array containing the status codes returned by the last SendInstances or Echo action
Public Property | Tag | A general purpose Tag for developer use
Public Property | ThrowStatusException | Controls whether an exception is generated when a non-zero status is received.
Public Property | WriteBehaviour | Specific behaviours to use when sending data on this association.
    Top
    Public Methods
     | Name | Description
Public Method | Abort | Aborts an association
Public Method | Cancel | Causes a C-CANCEL request to be sent to the remote AE asking it to terminate any outstanding image transfers
Public Method | CheckForNEventReports |
Public Method | Close | Closes the association represented by a "stand-alone" DicomAssociation
Public Method | Dispose | Releases the resources used by the DicomAssociation object
Public Method | Echo | Sends a verification request (C-ECHO) over a "stand-alone" DicomAssociation and returns the result
Public Method | Find | Overloaded. Sends a C-FIND request
Public Method | Get | Overloaded. Sends a C-GET request
Public Method | Move | Overloaded. Sends a C-MOVE request
Public Method | NAction | Sends an N-ACTION request
Public Method | NCreate | Sends an N-CREATE request
Public Method | NDelete | Sends an N-DELETE request
Public Method | NEventReport | Send an N-EVENT-REPORT over an established DicomAssociation
Public Method | NGet | Sends an N-GET request
Public Method | NSet | Sends an N-SET request
Public Method | Open | Overloaded. Open and negotiate a new DICOM Association
Public Method | PcidFor | Indicates the presentaiton context ID which would be used to send an instance of the given SOP class
Public Method | SendInstances | Overloaded. Sends images over a DicomAssociation
Public Method | SendPending |
Public Method | SendResponse | Overloaded.
Public Method | SetQuality | Set the quality factor for lossy compression
    Top
    Public Events
     | Name | Description
Public Event | InitiateTls | Routine to use to generate encrypted stream when TLS is to be used for outgoing associations.
Public Event | N_Event_Report | This event handler is fired when an N-EVENT-REPORT notification is received.
Public Event | ResponseReceived | Event fires when a response is received on an out-going operation
    Top
    See Also

    Reference

    DicomAssociation Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / DicomAssociation Class / DicomAssociation Constructor

In This Topic
    DicomAssociation Constructor
    In This Topic
    Creates a new DicomAssociation object.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New()
    'Usage

Dim instance As New DicomAssociation()
    public DicomAssociation()

    Return Value

    DicomAssociation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomAssociation Class

    DicomAssociation Class Methods
    In This Topic

    For a list of all members of this type, see DicomAssociation members.

    Public Methods
     | Name | Description
Public Method | Abort | Aborts an association
Public Method | Cancel | Causes a C-CANCEL request to be sent to the remote AE asking it to terminate any outstanding image transfers
Public Method | CheckForNEventReports |
Public Method | Close | Closes the association represented by a "stand-alone" DicomAssociation
Public Method | Dispose | Releases the resources used by the DicomAssociation object
Public Method | Echo | Sends a verification request (C-ECHO) over a "stand-alone" DicomAssociation and returns the result
Public Method | Find | Overloaded. Sends a C-FIND request
Public Method | Get | Overloaded. Sends a C-GET request
Public Method | Move | Overloaded. Sends a C-MOVE request
Public Method | NAction | Sends an N-ACTION request
Public Method | NCreate | Sends an N-CREATE request
Public Method | NDelete | Sends an N-DELETE request
Public Method | NEventReport | Send an N-EVENT-REPORT over an established DicomAssociation
Public Method | NGet | Sends an N-GET request
Public Method | NSet | Sends an N-SET request
Public Method | Open | Overloaded. Open and negotiate a new DICOM Association
Public Method | PcidFor | Indicates the presentaiton context ID which would be used to send an instance of the given SOP class
Public Method | SendInstances | Overloaded. Sends images over a DicomAssociation
Public Method | SendPending |
Public Method | SendResponse | Overloaded.
Public Method | SetQuality | Set the quality factor for lossy compression
    Top
    See Also

    Reference

    DicomAssociation Class
    DicomObjects Namespace


DicomObjects Namespace / DicomAssociation Class / Abort Method

The "Cause" of the Abort

The "Cause" of the Abort

In This Topic
    Abort Method
    In This Topic
    Aborts an association
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub Abort( _
   ByVal Reason As Byte, _
   ByVal Source As Byte _
)
    'Usage

Dim instance As DicomAssociation
Dim Reason As Byte
Dim Source As Byte

instance.Abort(Reason, Source)
    public void Abort(
   byte Reason,
   byte Source
)

    Parameters

    Reason

    The "Cause" of the Abort

    Source

    The "Cause" of the Abort

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Cancel Method

    Cancel Method
    Causes a C-CANCEL request to be sent to the remote AE asking it to terminate any outstanding image transfers
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub Cancel()
    'Usage

Dim instance As DicomAssociation

instance.Cancel()
    public void Cancel()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / CheckForNEventReports Method

    CheckForNEventReports Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("This method is no longer needed, and does nothing")>
Public Sub CheckForNEventReports()
    'Usage

Dim instance As DicomAssociation

instance.CheckForNEventReports()
    [Obsolete("This method is no longer needed, and does nothing")]
public void CheckForNEventReports()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Close Method

    Close Method
    Closes the association represented by a "stand-alone" DicomAssociation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub Close()
    'Usage

Dim instance As DicomAssociation

instance.Close()
    public void Close()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Dispose Method

    Dispose Method (DicomAssociation)
    In This Topic
    Releases the resources used by the DicomAssociation object
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overridable Sub Dispose()
    'Usage

Dim instance As DicomAssociation

instance.Dispose()
    public virtual void Dispose()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Echo Method

    Echo Method (DicomAssociation)
    In This Topic
    Sends a verification request (C-ECHO) over a "stand-alone" DicomAssociation and returns the result
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function Echo() As Integer
    'Usage

Dim instance As DicomAssociation
Dim value As Integer

value = instance.Echo()
    public int Echo()

    Return Value

    Integer
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Find Method

    Find Method (DicomAssociation)
    In This Topic
    Sends a C-FIND request
    Overload List
    Overload | Description
Find(QueryRoot,DicomDataSet) | Sends a C-FIND request
Find(String,DicomDataSet) | Sends a C-FIND request for Object with Private SOP Class UID
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Find Method / Find(QueryRoot,DicomDataSet) Method

The query root

The DataSet parameter defines the C-FIND searching criteria.

In This Topic
    Find(QueryRoot,DicomDataSet) Method
    In This Topic
    Sends a C-FIND request
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Find( _
   ByVal Root As QueryRoot, _
   ByVal DataSet As DicomDataSet _
)
    'Usage

Dim instance As DicomAssociation
Dim Root As QueryRoot
Dim DataSet As DicomDataSet

instance.Find(Root, DataSet)
    public void Find(
   QueryRoot Root,
   DicomDataSet DataSet
)

    Parameters

    Root

    The query root

    DataSet

    The DataSet parameter defines the C-FIND searching criteria.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / Find Method / Find(String,DicomDataSet) Method

The Private SOP Class UID of the DICOM object

The DataSet parameter defines the C-FIND searching criteria.

In This Topic
    Find(String,DicomDataSet) Method
    In This Topic
    Sends a C-FIND request for Object with Private SOP Class UID
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Find( _
   ByVal SopClassUID As String, _
   ByVal DataSet As DicomDataSet _
)
    'Usage

Dim instance As DicomAssociation
Dim SopClassUID As String
Dim DataSet As DicomDataSet

instance.Find(SopClassUID, DataSet)
    public void Find(
   string SopClassUID,
   DicomDataSet DataSet
)

    Parameters

    SopClassUID

    The Private SOP Class UID of the DICOM object

    DataSet

    The DataSet parameter defines the C-FIND searching criteria.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / Get Method

    Get Method (DicomAssociation)
    In This Topic
    Sends a C-GET request
    Overload List
    Overload | Description
Get(QueryRoot,DicomDataSet) | Sends a C-GET request
Get(QueryRoot,DicomDataSet,Boolean) | Sends a C-GET request
Get(String,DicomDataSet) | Sends a C-GET request for Object with Private SOP Class UID
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Get Method / Get(QueryRoot,DicomDataSet) Method

The query root

The identifier for the request

In This Topic
    Get(QueryRoot,DicomDataSet) Method
    In This Topic
    Sends a C-GET request
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Get( _
   ByVal Root As QueryRoot, _
   ByVal DataSet As DicomDataSet _
)
    'Usage

Dim instance As DicomAssociation
Dim Root As QueryRoot
Dim DataSet As DicomDataSet

instance.Get(Root, DataSet)
    public void Get(
   QueryRoot Root,
   DicomDataSet DataSet
)

    Parameters

    Root

    The query root

    DataSet

    The identifier for the request

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / Get Method / Get(QueryRoot,DicomDataSet,Boolean) Method

The query root

The identifier for the request

Specify if bulk data is required in the response

In This Topic
    Get(QueryRoot,DicomDataSet,Boolean) Method
    In This Topic
    Sends a C-GET request
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Get( _
   ByVal Root As QueryRoot, _
   ByVal DataSet As DicomDataSet, _
   ByVal NoBulkData As Boolean _
)
    'Usage

Dim instance As DicomAssociation
Dim Root As QueryRoot
Dim DataSet As DicomDataSet
Dim NoBulkData As Boolean

instance.Get(Root, DataSet, NoBulkData)
    public void Get(
   QueryRoot Root,
   DicomDataSet DataSet,
   bool NoBulkData
)

    Parameters

    Root

    The query root

    DataSet

    The identifier for the request

    NoBulkData

    Specify if bulk data is required in the response

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / Get Method / Get(String,DicomDataSet) Method

The Private SOPClassUID of the

The identifier for the request

In This Topic
    Get(String,DicomDataSet) Method
    In This Topic
    Sends a C-GET request for Object with Private SOP Class UID
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Get( _
   ByVal SopClassUID As String, _
   ByVal DataSet As DicomDataSet _
)
    'Usage

Dim instance As DicomAssociation
Dim SopClassUID As String
Dim DataSet As DicomDataSet

instance.Get(SopClassUID, DataSet)
    public void Get(
   string SopClassUID,
   DicomDataSet DataSet
)

    Parameters

    SopClassUID

    The Private SOPClassUID of the

    DataSet

    The identifier for the request

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / Move Method

    Move Method (DicomAssociation)
    In This Topic
    Sends a C-MOVE request
    Overload List
    Overload | Description
Move(QueryRoot,String,DicomDataSet) | Sends a C-MOVE request
Move(String,DicomDataSet) | Sends a C-MOVE request for Object with Private SOP Class UID
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Move Method / Move(QueryRoot,String,DicomDataSet) Method

The query root

The destination AE Title

The identifier for the C_MOVE request

In This Topic
    Move(QueryRoot,String,DicomDataSet) Method
    In This Topic
    Sends a C-MOVE request
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Move( _
   ByVal Root As QueryRoot, _
   ByVal Destination As String, _
   ByVal DataSet As DicomDataSet _
)
    'Usage

Dim instance As DicomAssociation
Dim Root As QueryRoot
Dim Destination As String
Dim DataSet As DicomDataSet

instance.Move(Root, Destination, DataSet)
    public void Move(
   QueryRoot Root,
   string Destination,
   DicomDataSet DataSet
)

    Parameters

    Root

    The query root

    Destination

    The destination AE Title

    DataSet

    The identifier for the C_MOVE request

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / Move Method / Move(String,DicomDataSet) Method

The Private SOP Class UID of the DICOM object

The identifier for the C_MOVE request

In This Topic
    Move(String,DicomDataSet) Method
    In This Topic
    Sends a C-MOVE request for Object with Private SOP Class UID
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Move( _
   ByVal SopClassUID As String, _
   ByVal DataSet As DicomDataSet _
)
    'Usage

Dim instance As DicomAssociation
Dim SopClassUID As String
Dim DataSet As DicomDataSet

instance.Move(SopClassUID, DataSet)
    public void Move(
   string SopClassUID,
   DicomDataSet DataSet
)

    Parameters

    SopClassUID

    The Private SOP Class UID of the DICOM object

    DataSet

    The identifier for the C_MOVE request

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / NAction Method

The requested SOP Class UID

The requested SOP InstanceUID

Context dependent Action code

The attributes to be set, with their values

In This Topic
    NAction Method
    In This Topic
    Sends an N-ACTION request
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub NAction( _
   ByVal SOPClassUID As String, _
   ByVal InstanceUID As String, _
   ByVal ActionID As Integer, _
   ByVal DataSet As DicomDataSet _
)
    'Usage

Dim instance As DicomAssociation
Dim SOPClassUID As String
Dim InstanceUID As String
Dim ActionID As Integer
Dim DataSet As DicomDataSet

instance.NAction(SOPClassUID, InstanceUID, ActionID, DataSet)
    public void NAction(
   string SOPClassUID,
   string InstanceUID,
   int ActionID,
   DicomDataSet DataSet
)

    Parameters

    SOPClassUID

    The requested SOP Class UID

    InstanceUID

    The requested SOP InstanceUID

    ActionID

    Context dependent Action code

    DataSet

    The attributes to be set, with their values

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / NCreate Method

The requested SOP Class UID

The requested SOP InstanceUID

The attributes to be set, with their values

In This Topic
    NCreate Method
    In This Topic
    Sends an N-CREATE request
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub NCreate( _
   ByVal SOPClassUID As String, _
   ByVal InstanceUID As String, _
   ByVal DataSet As DicomDataSet _
)
    'Usage

Dim instance As DicomAssociation
Dim SOPClassUID As String
Dim InstanceUID As String
Dim DataSet As DicomDataSet

instance.NCreate(SOPClassUID, InstanceUID, DataSet)
    public void NCreate(
   string SOPClassUID,
   string InstanceUID,
   DicomDataSet DataSet
)

    Parameters

    SOPClassUID

    The requested SOP Class UID

    InstanceUID

    The requested SOP InstanceUID

    DataSet

    The attributes to be set, with their values

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / NDelete Method

The requested SOP Class UID

The requested SOP InstanceUID

In This Topic
    NDelete Method
    In This Topic
    Sends an N-DELETE request
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub NDelete( _
   ByVal SOPClassUID As String, _
   ByVal InstanceUID As String _
)
    'Usage

Dim instance As DicomAssociation
Dim SOPClassUID As String
Dim InstanceUID As String

instance.NDelete(SOPClassUID, InstanceUID)
    public void NDelete(
   string SOPClassUID,
   string InstanceUID
)

    Parameters

    SOPClassUID

    The requested SOP Class UID

    InstanceUID

    The requested SOP InstanceUID

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / NEventReport Method

The requested SOP Class UID

The requested SOP InstanceUID

Event ID, as defined by the Class UID

Associated Data

In This Topic
    NEventReport Method
    In This Topic
    Send an N-EVENT-REPORT over an established DicomAssociation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub NEventReport( _
   ByVal SOPClassUID As String, _
   ByVal InstanceUID As String, _
   ByVal EventID As Integer, _
   ByVal DataSet As DicomDataSet _
)
    'Usage

Dim instance As DicomAssociation
Dim SOPClassUID As String
Dim InstanceUID As String
Dim EventID As Integer
Dim DataSet As DicomDataSet

instance.NEventReport(SOPClassUID, InstanceUID, EventID, DataSet)
    public void NEventReport(
   string SOPClassUID,
   string InstanceUID,
   int EventID,
   DicomDataSet DataSet
)

    Parameters

    SOPClassUID

    The requested SOP Class UID

    InstanceUID

    The requested SOP InstanceUID

    EventID

    Event ID, as defined by the Class UID

    DataSet

    Associated Data

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / NGet Method

The requested SOP Class UID

The requested SOP InstanceUID

The attributes requested

In This Topic
    NGet Method
    In This Topic
    Sends an N-GET request
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub NGet( _
   ByVal SOPClassUID As String, _
   ByVal InstanceUID As String, _
   ByVal DataSet As DicomDataSet _
)
    'Usage

Dim instance As DicomAssociation
Dim SOPClassUID As String
Dim InstanceUID As String
Dim DataSet As DicomDataSet

instance.NGet(SOPClassUID, InstanceUID, DataSet)
    public void NGet(
   string SOPClassUID,
   string InstanceUID,
   DicomDataSet DataSet
)

    Parameters

    SOPClassUID

    The requested SOP Class UID

    InstanceUID

    The requested SOP InstanceUID

    DataSet

    The attributes requested

    Return Value

    This method sends an N-GET request, using the quoted SOP Class and Instance UIDs. The values of the attributes in the DataSet are irrelevant, as it is used solely as a list of attributes whose values are to be retrieved.

    The returned values may be found, once the operation has completed, in the ReturnedIdentifier property.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / NSet Method

The requested SOP Class UID

The requested SOP InstanceUID

The attributes to be set, with their values

In This Topic
    NSet Method
    In This Topic
    Sends an N-SET request
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub NSet( _
   ByVal SOPClassUID As String, _
   ByVal InstanceUID As String, _
   ByVal DataSet As DicomDataSet _
)
    'Usage

Dim instance As DicomAssociation
Dim SOPClassUID As String
Dim InstanceUID As String
Dim DataSet As DicomDataSet

instance.NSet(SOPClassUID, InstanceUID, DataSet)
    public void NSet(
   string SOPClassUID,
   string InstanceUID,
   DicomDataSet DataSet
)

    Parameters

    SOPClassUID

    The requested SOP Class UID

    InstanceUID

    The requested SOP InstanceUID

    DataSet

    The attributes to be set, with their values

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Open Method

    Open Method
    Open and negotiate a new DICOM Association
    Overload List
    Overload | Description
Open(String,Int32,String,String) | Open and negotiate a new DICOM Association
Open(Socket,Stream,String,String) | Open a DICOM association over an independently created
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Open Method / Open(String,Int32,String,String) Method

Network address (as dotted notation or resolvable name) to which the association is to be made

Port on which remote application is listening

In This Topic
    Open(String,Int32,String,String) Method
    In This Topic
    Open and negotiate a new DICOM Association
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Open( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAET As String, _
   ByVal CalledAET As String _
)
    'Usage

Dim instance As DicomAssociation
Dim Node As String
Dim Port As Integer
Dim CallingAET As String
Dim CalledAET As String

instance.Open(Node, Port, CallingAET, CalledAET)
    public void Open(
   string Node,
   int Port,
   string CallingAET,
   string CalledAET
)

    Parameters

    Node

    Network address (as dotted notation or resolvable name) to which the association is to be made

    Port

    Port on which remote application is listening

    CallingAET
    CalledAET
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / Open Method / Open(Socket,Stream,String,String) Method
Specifies the underlying Socket through which an association should be made.

The NetworkStream via which the connection is to be made

In This Topic
    Open(Socket,Stream,String,String) Method
    In This Topic
    Open a DICOM association over an independently created
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Open( _
   ByVal Socket As Socket, _
   ByVal Stream As Stream, _
   ByVal CallingAET As String, _
   ByVal CalledAET As String _
)
    'Usage

Dim instance As DicomAssociation
Dim Socket As Socket
Dim Stream As Stream
Dim CallingAET As String
Dim CalledAET As String

instance.Open(Socket, Stream, CallingAET, CalledAET)
    public void Open(
   Socket Socket,
   Stream Stream,
   string CallingAET,
   string CalledAET
)

    Parameters

    Socket
    Specifies the underlying Socket through which an association should be made.
    Stream

    The NetworkStream via which the connection is to be made

    CallingAET
    CalledAET
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / PcidFor Method
The SOP class to test for

    PcidFor Method
    In This Topic
    Indicates the presentaiton context ID which would be used to send an instance of the given SOP class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function PcidFor( _
   ByVal SOPClass As String _
) As Byte
    'Usage

Dim instance As DicomAssociation
Dim SOPClass As String
Dim value As Byte

value = instance.PcidFor(SOPClass)
    public byte PcidFor(
   string SOPClass
)

    Parameters

    SOPClass
    The SOP class to test for

    Return Value

    Either the presentation context ID which would be used to send an instance of the stated SOP class, or 0 if so suitable, agreed presentation context exists.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / SendInstances Method

    SendInstances Method
    Sends images over a DicomAssociation
    Overload List
    Overload | Description
SendInstances(IEnumerable<DicomDataSet>) | Sends images over a DicomAssociation
SendInstances(DicomDataSet) | Sends an DataSet over a DicomAssociation
SendInstances(Stream) | Sends data which is contained in a System IO Stream over a DicomAssociation
SendInstances(String) | Sends a file referenced by a string over a DicomAssociation
SendInstances(IEnumerable<String>) | Sends multiple files referenced by a collection of strings over a DicomAssociation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / SendInstances Method / SendInstances(IEnumerable<DicomDataSet>) Method
The DicomDataSetCollection to send

    SendInstances(IEnumerable<DicomDataSet>) Method
    In This Topic
    Sends images over a DicomAssociation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub SendInstances( _
   ByVal DataSets As IEnumerable(Of DicomDataSet) _
)
    'Usage

Dim instance As DicomAssociation
Dim DataSets As IEnumerable(Of DicomDataSet)

instance.SendInstances(DataSets)
    public void SendInstances(
   IEnumerable<DicomDataSet> DataSets
)

    Parameters

    DataSets
    The DicomDataSetCollection to send
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / SendInstances Method / SendInstances(DicomDataSet) Method
The DicomDataSet to send

    SendInstances(DicomDataSet) Method
    In This Topic
    Sends an DataSet over a DicomAssociation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub SendInstances( _
   ByVal DataSet As DicomDataSet _
)
    'Usage

Dim instance As DicomAssociation
Dim DataSet As DicomDataSet

instance.SendInstances(DataSet)
    public void SendInstances(
   DicomDataSet DataSet
)

    Parameters

    DataSet
    The DicomDataSet to send
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / SendInstances Method / SendInstances(Stream) Method

The Stream which contains the data to be transmitted

    SendInstances(Stream) Method
    In This Topic
    Sends data which is contained in a System IO Stream over a DicomAssociation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub SendInstances( _
   ByVal Stream As Stream _
)
    'Usage

Dim instance As DicomAssociation
Dim Stream As Stream

instance.SendInstances(Stream)
    public void SendInstances(
   Stream Stream
)

    Parameters

    Stream

    The Stream which contains the data to be transmitted

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / SendInstances Method / SendInstances(String) Method

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

In This Topic
    SendInstances(String) Method
    In This Topic
    Sends a file referenced by a string over a DicomAssociation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub SendInstances( _
   ByVal Filename As String _
)
    'Usage

Dim instance As DicomAssociation
Dim Filename As String

instance.SendInstances(Filename)
    public void SendInstances(
   string Filename
)

    Parameters

    Filename

    The name of the file to read.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / SendInstances Method / SendInstances(IEnumerable<String>) Method
The filenames of the files to send

    SendInstances(IEnumerable<String>) Method
    In This Topic
    Sends multiple files referenced by a collection of strings over a DicomAssociation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub SendInstances( _
   ByVal Filenames As IEnumerable(Of String) _
)
    'Usage

Dim instance As DicomAssociation
Dim Filenames As IEnumerable(Of String)

instance.SendInstances(Filenames)
    public void SendInstances(
   IEnumerable<string> Filenames
)

    Parameters

    Filenames
    The filenames of the files to send
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / SendPending Method

    SendPending Method (DicomAssociation)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("This method should be replaced by QueryReceivedArgs.SendPending (e.SendPending) which also handles DICOM Asynchronous operations")>
Public Sub SendPending()
    'Usage

Dim instance As DicomAssociation

instance.SendPending()
    [Obsolete("This method should be replaced by QueryReceivedArgs.SendPending (e.SendPending) which also handles DICOM Asynchronous operations")]
public void SendPending()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / SendResponse Method

    SendResponse Method (DicomAssociation)
    In This Topic
    Overload List
    Overload | Description
SendResponse(IEnumerable<DicomDataSet>,Int32) |
SendResponse(DicomDataSet,Int32) |
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / SendResponse Method / SendResponse(IEnumerable<DicomDataSet>,Int32) Method

    SendResponse(IEnumerable<DicomDataSet>,Int32) Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("This method should be replaced by QueryReceivedArgs.SendResponse (e.SendResponse) which also handles DICOM Asynchronous operations")>
Public Overloads Sub SendResponse( _
   ByVal Data As IEnumerable(Of DicomDataSet), _
   ByVal Status As Integer _
)
    'Usage

Dim instance As DicomAssociation
Dim Data As IEnumerable(Of DicomDataSet)
Dim Status As Integer

instance.SendResponse(Data, Status)
    [Obsolete("This method should be replaced by QueryReceivedArgs.SendResponse (e.SendResponse) which also handles DICOM Asynchronous operations")]
public void SendResponse(
   IEnumerable<DicomDataSet> Data,
   int Status
)

    Parameters

    Data
    Status
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / SendResponse Method / SendResponse(DicomDataSet,Int32) Method

    SendResponse(DicomDataSet,Int32) Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("This method should be replaced by QueryReceivedArgs.SendResponse (e.SendResponse) which also handles DICOM Asynchronous operations")>
Public Overloads Sub SendResponse( _
   ByVal Data As DicomDataSet, _
   ByVal Status As Integer _
)
    'Usage

Dim instance As DicomAssociation
Dim Data As DicomDataSet
Dim Status As Integer

instance.SendResponse(Data, Status)
    [Obsolete("This method should be replaced by QueryReceivedArgs.SendResponse (e.SendResponse) which also handles DICOM Asynchronous operations")]
public void SendResponse(
   DicomDataSet Data,
   int Status
)

    Parameters

    Data
    Status
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / SetQuality Method

The transfer syntax to which this quality factor applies

The quality to be set

In This Topic
    SetQuality Method
    In This Topic
    Set the quality factor for lossy compression
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub SetQuality( _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object _
)
    'Usage

Dim instance As DicomAssociation
Dim TransferSyntax As String
Dim Quality As Object

instance.SetQuality(TransferSyntax, Quality)
    public void SetQuality(
   string TransferSyntax,
   object Quality
)

    Parameters

    TransferSyntax

    The transfer syntax to which this quality factor applies

    Quality

    The quality to be set

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomAssociation Class

    DicomAssociation Class Properties
    In This Topic

    For a list of all members of this type, see DicomAssociation members.

    Public Properties
     | Name | Description
Public Property | AgreedContexts | The Presentation Contexts associated with this DicomAssociation
Public Property | AssociationNumber | Returns the association number of current connection.
Public Property | BytesReceived | Approximate Measures of Network Input
Public Property | BytesSent | Approximate measures of Network Output
Public Property | CalledAET | Provides information about the remote application entity
Public Property | CallingAET | Provides information about the calling application entity
Public Property | Cancelled | Indicates that the remote AE has issued a C-CANCEL request.
Public Property | ChangeLossyUIDs |
Public Property | CheckForCancel | Control whether to check for incoming C-CANCEL asynchronous messages
Public Property | CoercionSOP | SOP Class to which images should be coerced if peer does not accept true SOP class
Public Property | Command |
static (Shared in Visual Basic) | DefaultThrowStatusException | The value intially assigned for the of new DicomAssociation objects.
Public Property | Destination |
Public Property | Identity | The user identity to use for an association
Public Property | ImplementationName | Returns the Implementation Version Name of the Connecting AE
Public Property | ImplementationUID | Returns the Implementation Class UID of the Connecting AE
Public Property | isOpen |
Public Property | LastCommand | Returns the last command in the current association.
Public Property | LastError | Returns the last error status from LastCommand.
Public Property | LastInstanceUID | Holds the InstanceUID created or used by the last normalised operation.
Public Property | LastOperation | Returns the last operation in the current association.
Public Property | LastStatus | Shortcut for the first element of the Status property
Public Property | LocalIP | Provide information about which local interface the remote application entity called
Public Property | LocalPort | Provide information about which local port the remote application entity called
Public Property | LogLevel | Controls the level of logging for this particular Association.
Public Property | MetaSOPClass | Determines the Abstract Syntax used for normalised operations
Public Property | MoveOriginator | The DicomAssociation object which initiated the C-MOVE resulting in the current C-STORE
Public Property | PreferredPCID | Provides guidance for the choice of presentation context
Public Property | PreferredTS | Provides guidance for the choice of presentation context
Public Property | PreferredTSList | Provides guidance for the choice of presentation context
Public Property | ReadBehaviour | Specific behaviours to use when receiving data on this association.
Public Property | RemoteIP | Provides information about the remote application entity
Public Property | Request | This contains the list of attributes to be matched, as specified in the DICOM standard
Public Property | RequestedContexts | The Presentation Contexts associated with this DicomAssociation
Public Property | RequestingQuery | Provides a linkage to the primary C-MOVE request.
Public Property | ReturnedCommands | The command datasets returned in response to the last operation
Public Property | ReturnedIdentifier | Hold data returned from outgoing operations
Public Property | ReturnedIdentifiers | Hold data returned from outgoing operations
Public Property | ReturnedInstances | Hold instances returned from outgoing C-GET operations
Public Property | SslStream | Returns the secure Stream object
Public Property | Status | Array containing the status codes returned by the last SendInstances or Echo action
Public Property | Tag | A general purpose Tag for developer use
Public Property | ThrowStatusException | Controls whether an exception is generated when a non-zero status is received.
Public Property | WriteBehaviour | Specific behaviours to use when sending data on this association.
    Top
    See Also

    Reference

    DicomAssociation Class
    DicomObjects Namespace


DicomObjects Namespace / DicomAssociation Class / AgreedContexts Property

    AgreedContexts Property
    The Presentation Contexts associated with this DicomAssociation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property AgreedContexts As DicomContextCollection
    'Usage

Dim instance As DicomAssociation
Dim value As DicomContextCollection

value = instance.AgreedContexts
    public DicomContextCollection AgreedContexts {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / AssociationNumber Property

    AssociationNumber Property
    Returns the association number of current connection.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property AssociationNumber As Integer
    'Usage

Dim instance As DicomAssociation
Dim value As Integer

value = instance.AssociationNumber
    public int AssociationNumber {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / BytesReceived Property

    BytesReceived Property
    Approximate Measures of Network Input
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property BytesReceived As Long
    'Usage

Dim instance As DicomAssociation
Dim value As Long

value = instance.BytesReceived
    public long BytesReceived {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / BytesSent Property

    BytesSent Property
    Approximate measures of Network Output
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property BytesSent As Long
    'Usage

Dim instance As DicomAssociation
Dim value As Long

value = instance.BytesSent
    public long BytesSent {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / CalledAET Property

    CalledAET Property
    Provides information about the remote application entity
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property CalledAET As String
    'Usage

Dim instance As DicomAssociation
Dim value As String

value = instance.CalledAET
    public string CalledAET {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / CallingAET Property

    CallingAET Property
    Provides information about the calling application entity
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property CallingAET As String
    'Usage

Dim instance As DicomAssociation
Dim value As String

value = instance.CallingAET
    public string CallingAET {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Cancelled Property

    Cancelled Property
    Indicates that the remote AE has issued a C-CANCEL request.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Cancelled As Boolean
    'Usage

Dim instance As DicomAssociation
Dim value As Boolean

value = instance.Cancelled
    public bool Cancelled {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / ChangeLossyUIDs Property

    ChangeLossyUIDs Property (DicomAssociation)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("This property has been superceded by WriteBehaviours.ChangeLossyUIDs, which is more flexible, including use when writing files")>
Public Property ChangeLossyUIDs As Boolean
    'Usage

Dim instance As DicomAssociation
Dim value As Boolean

instance.ChangeLossyUIDs = value

value = instance.ChangeLossyUIDs
    [Obsolete("This property has been superceded by WriteBehaviours.ChangeLossyUIDs, which is more flexible, including use when writing files")]
public bool ChangeLossyUIDs {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / CheckForCancel Property

    CheckForCancel Property
    Control whether to check for incoming C-CANCEL asynchronous messages
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property CheckForCancel As Boolean
    'Usage

Dim instance As DicomAssociation
Dim value As Boolean

instance.CheckForCancel = value

value = instance.CheckForCancel
    public bool CheckForCancel {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / CoercionSOP Property

    CoercionSOP Property
    SOP Class to which images should be coerced if peer does not accept true SOP class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property CoercionSOP As String
    'Usage

Dim instance As DicomAssociation
Dim value As String

instance.CoercionSOP = value

value = instance.CoercionSOP
    public string CoercionSOP {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Command Property

    Command Property (DicomAssociation)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("This property should be replaced by OperationBaseArgs.Command (e.Command) which also handles DICOM Asynchronous operations")>
Public ReadOnly Property Command As DicomDataSet
    'Usage

Dim instance As DicomAssociation
Dim value As DicomDataSet

value = instance.Command
    [Obsolete("This property should be replaced by OperationBaseArgs.Command (e.Command) which also handles DICOM Asynchronous operations")]
public DicomDataSet Command {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / DefaultThrowStatusException Property

    DefaultThrowStatusException Property
    The value intially assigned for the of new DicomAssociation objects.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property DefaultThrowStatusException As Boolean
    'Usage

Dim value As Boolean

DicomAssociation.DefaultThrowStatusException = value

value = DicomAssociation.DefaultThrowStatusException
    public static bool DefaultThrowStatusException {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Destination Property

    Destination Property (DicomAssociation)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("This method should be replaced by QueryReceivedArgs.Destination (e.Destination) which also handles DICOM Asynchronous operations")>
Public ReadOnly Property Destination As String
    'Usage

Dim instance As DicomAssociation
Dim value As String

value = instance.Destination
    [Obsolete("This method should be replaced by QueryReceivedArgs.Destination (e.Destination) which also handles DICOM Asynchronous operations")]
public string Destination {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Identity Property

    Identity Property
    The user identity to use for an association
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Identity As DicomUserIdentity
    'Usage

Dim instance As DicomAssociation
Dim value As DicomUserIdentity

instance.Identity = value

value = instance.Identity
    public DicomUserIdentity Identity {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / ImplementationName Property

    ImplementationName Property (DicomAssociation)
    In This Topic
    Returns the Implementation Version Name of the Connecting AE
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property ImplementationName As String
    'Usage

Dim instance As DicomAssociation
Dim value As String

value = instance.ImplementationName
    public string ImplementationName {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / ImplementationUID Property

    ImplementationUID Property (DicomAssociation)
    In This Topic
    Returns the Implementation Class UID of the Connecting AE
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property ImplementationUID As String
    'Usage

Dim instance As DicomAssociation
Dim value As String

value = instance.ImplementationUID
    public string ImplementationUID {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / isOpen Property

    isOpen Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property isOpen As Boolean
    'Usage

Dim instance As DicomAssociation
Dim value As Boolean

value = instance.isOpen
    public bool isOpen {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / LastCommand Property

    LastCommand Property
    Returns the last command in the current association.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property LastCommand As DicomDataSet
    'Usage

Dim instance As DicomAssociation
Dim value As DicomDataSet

value = instance.LastCommand
    public DicomDataSet LastCommand {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / LastError Property

    LastError Property

    Returns the last error status from LastCommand.

    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property LastError As String
    'Usage

Dim instance As DicomAssociation
Dim value As String

value = instance.LastError
    public string LastError {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / LastInstanceUID Property

    LastInstanceUID Property
    Holds the InstanceUID created or used by the last normalised operation.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property LastInstanceUID As String
    'Usage

Dim instance As DicomAssociation
Dim value As String

value = instance.LastInstanceUID
    public string LastInstanceUID {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / LastOperation Property

    LastOperation Property
    Returns the last operation in the current association.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property LastOperation As DicomOperation
    'Usage

Dim instance As DicomAssociation
Dim value As DicomOperation

value = instance.LastOperation
    public DicomOperation LastOperation {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / LastStatus Property

    LastStatus Property
    Shortcut for the first element of the Status property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property LastStatus As Integer
    'Usage

Dim instance As DicomAssociation
Dim value As Integer

value = instance.LastStatus
    public int LastStatus {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / LocalIP Property

    LocalIP Property
    Provide information about which local interface the remote application entity called
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property LocalIP As String
    'Usage

Dim instance As DicomAssociation
Dim value As String

value = instance.LocalIP
    public string LocalIP {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / LocalPort Property

    LocalPort Property
    Provide information about which local port the remote application entity called
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property LocalPort As Long
    'Usage

Dim instance As DicomAssociation
Dim value As Long

value = instance.LocalPort
    public long LocalPort {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / LogLevel Property

    LogLevel Property (DicomAssociation)
    In This Topic
    Controls the level of logging for this particular Association.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property LogLevel As LogLevel
    'Usage

Dim instance As DicomAssociation
Dim value As LogLevel

instance.LogLevel = value

value = instance.LogLevel
    public LogLevel LogLevel {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / MetaSOPClass Property

    MetaSOPClass Property
    Determines the Abstract Syntax used for normalised operations
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property MetaSOPClass As String
    'Usage

Dim instance As DicomAssociation
Dim value As String

instance.MetaSOPClass = value

value = instance.MetaSOPClass
    public string MetaSOPClass {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / MoveOriginator Property

    MoveOriginator Property
    The DicomAssociation object which initiated the C-MOVE resulting in the current C-STORE
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property MoveOriginator As DicomAssociation
    'Usage

Dim instance As DicomAssociation
Dim value As DicomAssociation

value = instance.MoveOriginator
    public DicomAssociation MoveOriginator {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / PreferredPCID Property

    PreferredPCID Property
    Provides guidance for the choice of presentation context
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property PreferredPCID As Byte
    'Usage

Dim instance As DicomAssociation
Dim value As Byte

instance.PreferredPCID = value

value = instance.PreferredPCID
    public byte PreferredPCID {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / PreferredTS Property

    PreferredTS Property
    Provides guidance for the choice of presentation context
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property PreferredTS As String
    'Usage

Dim instance As DicomAssociation
Dim value As String

instance.PreferredTS = value

value = instance.PreferredTS
    public string PreferredTS {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / PreferredTSList Property

    PreferredTSList Property
    Provides guidance for the choice of presentation context
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property PreferredTSList As IEnumerable(Of String)
    'Usage

Dim instance As DicomAssociation
Dim value As IEnumerable(Of String)

instance.PreferredTSList = value

value = instance.PreferredTSList
    public IEnumerable<string> PreferredTSList {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / ReadBehaviour Property

    ReadBehaviour Property
    Specific behaviours to use when receiving data on this association.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property ReadBehaviour As ReadBehaviours
    'Usage

Dim instance As DicomAssociation
Dim value As ReadBehaviours

instance.ReadBehaviour = value

value = instance.ReadBehaviour
    public ReadBehaviours ReadBehaviour {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / RemoteIP Property

    RemoteIP Property
    Provides information about the remote application entity
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property RemoteIP As String
    'Usage

Dim instance As DicomAssociation
Dim value As String

value = instance.RemoteIP
    public string RemoteIP {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Request Property

    Request Property (DicomAssociation)
    In This Topic
    This contains the list of attributes to be matched, as specified in the DICOM standard
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Request As DicomDataSet
    'Usage

Dim instance As DicomAssociation
Dim value As DicomDataSet

value = instance.Request
    public DicomDataSet Request {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / RequestedContexts Property

    RequestedContexts Property
    The Presentation Contexts associated with this DicomAssociation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property RequestedContexts As DicomContextCollection
    'Usage

Dim instance As DicomAssociation
Dim value As DicomContextCollection

value = instance.RequestedContexts
    public DicomContextCollection RequestedContexts {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / RequestingQuery Property

    RequestingQuery Property
    Provides a linkage to the primary C-MOVE request.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property RequestingQuery As QueryReceivedArgs
    'Usage

Dim instance As DicomAssociation
Dim value As QueryReceivedArgs

instance.RequestingQuery = value

value = instance.RequestingQuery
    public QueryReceivedArgs RequestingQuery {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / ReturnedCommands Property

    ReturnedCommands Property
    The command datasets returned in response to the last operation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property ReturnedCommands As DicomDataSetCollection
    'Usage

Dim instance As DicomAssociation
Dim value As DicomDataSetCollection

value = instance.ReturnedCommands
    public DicomDataSetCollection ReturnedCommands {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / ReturnedIdentifier Property

    ReturnedIdentifier Property
    Hold data returned from outgoing operations
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property ReturnedIdentifier As DicomDataSet
    'Usage

Dim instance As DicomAssociation
Dim value As DicomDataSet

value = instance.ReturnedIdentifier
    public DicomDataSet ReturnedIdentifier {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / ReturnedIdentifiers Property

    ReturnedIdentifiers Property
    Hold data returned from outgoing operations
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property ReturnedIdentifiers As DicomDataSetCollection
    'Usage

Dim instance As DicomAssociation
Dim value As DicomDataSetCollection

value = instance.ReturnedIdentifiers
    public DicomDataSetCollection ReturnedIdentifiers {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / ReturnedInstances Property

    ReturnedInstances Property
    Hold instances returned from outgoing C-GET operations
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property ReturnedInstances As DicomDataSetCollection
    'Usage

Dim instance As DicomAssociation
Dim value As DicomDataSetCollection

value = instance.ReturnedInstances
    public DicomDataSetCollection ReturnedInstances {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / SslStream Property

    SslStream Property
    Returns the secure Stream object
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property SslStream As Stream
    'Usage

Dim instance As DicomAssociation
Dim value As Stream

value = instance.SslStream
    public Stream SslStream {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Status Property

    Status Property (DicomAssociation)
    In This Topic
    Array containing the status codes returned by the last SendInstances or Echo action
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Status As Integer()
    'Usage

Dim instance As DicomAssociation
Dim value() As Integer

value = instance.Status
    public int[] Status {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Tag Property

    Tag Property (DicomAssociation)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Tag As Object
    'Usage

Dim instance As DicomAssociation
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / ThrowStatusException Property

    ThrowStatusException Property
    Controls whether an exception is generated when a non-zero status is received.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property ThrowStatusException As Boolean
    'Usage

Dim instance As DicomAssociation
Dim value As Boolean

instance.ThrowStatusException = value

value = instance.ThrowStatusException
    public bool ThrowStatusException {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / WriteBehaviour Property

    WriteBehaviour Property (DicomAssociation)
    In This Topic
    Specific behaviours to use when sending data on this association.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property WriteBehaviour As WriteBehaviours
    'Usage

Dim instance As DicomAssociation
Dim value As WriteBehaviours

instance.WriteBehaviour = value

value = instance.WriteBehaviour
    public WriteBehaviours WriteBehaviour {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


%%PageItemTitle%% $$Events$$

DicomObjects Namespace / DicomAssociation Class

    DicomAssociation Class Events
    In This Topic

    For a list of all members of this type, see DicomAssociation members.

    Public Events
     | Name | Description
Public Event | InitiateTls | Routine to use to generate encrypted stream when TLS is to be used for outgoing associations.
Public Event | N_Event_Report | This event handler is fired when an N-EVENT-REPORT notification is received.
Public Event | ResponseReceived | Event fires when a response is received on an out-going operation
    Top
    See Also

    Reference

    DicomAssociation Class
    DicomObjects Namespace


DicomObjects Namespace / DicomAssociation Class / InitiateTls Event

    InitiateTls Event (DicomAssociation)
    In This Topic
    Routine to use to generate encrypted stream when TLS is to be used for outgoing associations.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event InitiateTls As TlsInitiator
    'Usage

Dim instance As DicomAssociation
Dim handler As TlsInitiator

AddHandler instance.InitiateTls, handler
    public event TlsInitiator InitiateTls
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / N_Event_Report Event

    N_Event_Report Event (DicomAssociation)
    In This Topic
    This event handler is fired when an N-EVENT-REPORT notification is received.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event N_Event_Report As N_Event_ReportHandler
    'Usage

Dim instance As DicomAssociation
Dim handler As N_Event_ReportHandler

AddHandler instance.N_Event_Report, handler
    public event N_Event_ReportHandler N_Event_Report
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / ResponseReceived Event

    ResponseReceived Event (DicomAssociation)
    In This Topic
    Event fires when a response is received on an out-going operation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event ResponseReceived As ResponseReceivedHandler
    'Usage

Dim instance As DicomAssociation
Dim handler As ResponseReceivedHandler

AddHandler instance.ResponseReceived, handler
    public event ResponseReceivedHandler ResponseReceived
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


%%PageItemTitle%%

DicomObjects Namespace / DicomAttribute Class
Members

In This Topic
    DicomAttribute Class
    In This Topic
    Class representing a single DICOM Attribute
    Syntax
    • Visual Basic
    • C#
    'Declaration

<DefaultMemberAttribute("Item")>
Public Class DicomAttribute
    'Usage

Dim instance As DicomAttribute
    [DefaultMember("Item")]
public class DicomAttribute
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomAttribute

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomAttribute Class
Fields Properties Methods

In This Topic
    DicomAttribute Class Members
    In This Topic

    The following tables list the members exposed by DicomAttribute.

    Public Fields
     | Name | Description
Public Field | DelayedData |
    Top
    Public Properties
     | Name | Description
Public Property | BulkDataUri | The URI from which the data could be retrieved
Public Property | ByteArrayData | Returns a single byte array containing the attribute's data
Public Property | DateTimeFrom | Start values for date and time ranges
Public Property | DateTimeTo | End values for date and time ranges
Public Property | Description | The DICOM Description of the Attribute
Public Property | Element | The element indices of a data element
Public Property | Exists | Determines whether an attribute actually exists
Public Property | ExistsWithValue | Returns True if non-null data is present.
Public Property | Group | The Group indices of a data element.
Public Property | IsMultiple | Determines whether an attribute has a potential value multiplicity of greater than 1
Public Property | IsNull | Indicates whether DicomAttribute has a non-null value
Public Property | IsPrivate | Checks whether an attribute is private
Public Property | Item | The default indexer.
Public Property | Keyword | String representation of the attribute's keyword
Public Property | KeywordCode | The attribute's keyword as a Keyword
Public Property | RawData | The raw data held in DicomAttribute object
Public Property | Tag | A general purpose Tag for developer use
Public Property | Value | The value of a Data Element
Public Property | VM | The value multiplicity of an attribute
Public Property | VR | The Value Representation of an attribute
    Top
    Public Methods
     | Name | Description
static (Shared in Visual Basic) | DefinedVM | The value multiplicity of an attribute as defined by the DICOM standard
static (Shared in Visual Basic) | DefinedVR | The value representation of an attribute as defined by the DICOM standard
Public Method | Dispose | Release all resources used by this DicomAttribute object.
Public Method | ToString | Overloaded. Converts object to String Value
Public Method | ValueInContext | Returns the value of Data Element, which may vary according to its surrounding context
    Top
    See Also

    Reference

    DicomAttribute Class
    DicomObjects Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomAttribute Class

    DicomAttribute Class Methods
    In This Topic

    For a list of all members of this type, see DicomAttribute members.

    Public Methods
     | Name | Description
static (Shared in Visual Basic) | DefinedVM | The value multiplicity of an attribute as defined by the DICOM standard
static (Shared in Visual Basic) | DefinedVR | The value representation of an attribute as defined by the DICOM standard
Public Method | Dispose | Release all resources used by this DicomAttribute object.
Public Method | ToString | Overloaded. Converts object to String Value
Public Method | ValueInContext | Returns the value of Data Element, which may vary according to its surrounding context
    Top
    See Also

    Reference

    DicomAttribute Class
    DicomObjects Namespace


DicomObjects Namespace / DicomAttribute Class / DefinedVM Method

    DefinedVM Method
    The value multiplicity of an attribute as defined by the DICOM standard
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function DefinedVM( _
   ByVal Keyword As Keyword _
) As String
    'Usage

Dim Keyword As Keyword
Dim value As String

value = DicomAttribute.DefinedVM(Keyword)
    public static string DefinedVM(
   Keyword Keyword
)

    Parameters

    Keyword
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / DefinedVR Method

    DefinedVR Method
    The value representation of an attribute as defined by the DICOM standard
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function DefinedVR( _
   ByVal Keyword As Keyword _
) As String
    'Usage

Dim Keyword As Keyword
Dim value As String

value = DicomAttribute.DefinedVR(Keyword)
    public static string DefinedVR(
   Keyword Keyword
)

    Parameters

    Keyword
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / Dispose Method

    Dispose Method (DicomAttribute)
    In This Topic
    Release all resources used by this DicomAttribute object.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub Dispose()
    'Usage

Dim instance As DicomAttribute

instance.Dispose()
    public void Dispose()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / ToString Method

    ToString Method (DicomAttribute)
    In This Topic
    Converts object to String Value
    Overload List
    Overload | Description
ToString() | Converts object to String Value
ToString(String) | Converts to a string using the format parameter (where possible)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members
    Base Implementation in ToString


DicomObjects Namespace / DicomAttribute Class / ToString Method / ToString() Method

    ToString() Method
    Converts object to String Value
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Overrides Function ToString() As String
    'Usage

Dim instance As DicomAttribute
Dim value As String

value = instance.ToString()
    public override string ToString()

    Return Value

    A string representation of the attribute designed for human readability
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members
    Overload List
    Base Implementation in ToString


DicomObjects Namespace / DicomAttribute Class / ToString Method / ToString(String) Method
Stansdard format string - e.g. "{0}"

    ToString(String) Method
    In This Topic
    Converts to a string using the format parameter (where possible)
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function ToString( _
   ByVal Format As String _
) As String
    'Usage

Dim instance As DicomAttribute
Dim Format As String
Dim value As String

value = instance.ToString(Format)
    public string ToString(
   string Format
)

    Parameters

    Format
    Stansdard format string - e.g. "{0}"

    Return Value

    resulting string
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members
    Overload List


DicomObjects Namespace / DicomAttribute Class / ValueInContext Method

The DicomDataSet which contains the definition/description of the current DicomAttribute

In This Topic
    ValueInContext Method
    In This Topic
    Returns the value of Data Element, which may vary according to its surrounding context
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function ValueInContext( _
   ByVal ds As DicomDataSet _
) As Object
    'Usage

Dim instance As DicomAttribute
Dim ds As DicomDataSet
Dim value As Object

value = instance.ValueInContext(ds)
    public object ValueInContext(
   DicomDataSet ds
)

    Parameters

    ds

    The DicomDataSet which contains the definition/description of the current DicomAttribute

    Return Value

    object
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomAttribute Class

    DicomAttribute Class Properties
    In This Topic

    For a list of all members of this type, see DicomAttribute members.

    Public Properties
     | Name | Description
Public Property | BulkDataUri | The URI from which the data could be retrieved
Public Property | ByteArrayData | Returns a single byte array containing the attribute's data
Public Property | DateTimeFrom | Start values for date and time ranges
Public Property | DateTimeTo | End values for date and time ranges
Public Property | Description | The DICOM Description of the Attribute
Public Property | Element | The element indices of a data element
Public Property | Exists | Determines whether an attribute actually exists
Public Property | ExistsWithValue | Returns True if non-null data is present.
Public Property | Group | The Group indices of a data element.
Public Property | IsMultiple | Determines whether an attribute has a potential value multiplicity of greater than 1
Public Property | IsNull | Indicates whether DicomAttribute has a non-null value
Public Property | IsPrivate | Checks whether an attribute is private
Public Property | Item | The default indexer.
Public Property | Keyword | String representation of the attribute's keyword
Public Property | KeywordCode | The attribute's keyword as a Keyword
Public Property | RawData | The raw data held in DicomAttribute object
Public Property | Tag | A general purpose Tag for developer use
Public Property | Value | The value of a Data Element
Public Property | VM | The value multiplicity of an attribute
Public Property | VR | The Value Representation of an attribute
    Top
    See Also

    Reference

    DicomAttribute Class
    DicomObjects Namespace


DicomObjects Namespace / DicomAttribute Class / BulkDataUri Property

    BulkDataUri Property
    The URI from which the data could be retrieved
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property BulkDataUri As String
    'Usage

Dim instance As DicomAttribute
Dim value As String

instance.BulkDataUri = value

value = instance.BulkDataUri
    public string BulkDataUri {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / ByteArrayData Property

    ByteArrayData Property
    Returns a single byte array containing the attribute's data
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property ByteArrayData As Byte()
    'Usage

Dim instance As DicomAttribute
Dim value() As Byte

value = instance.ByteArrayData
    public byte[] ByteArrayData {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / DateTimeFrom Property

    DateTimeFrom Property
    Start values for date and time ranges
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property DateTimeFrom As Date
    'Usage

Dim instance As DicomAttribute
Dim value As Date

value = instance.DateTimeFrom
    public DateTime DateTimeFrom {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / DateTimeTo Property

    DateTimeTo Property
    End values for date and time ranges
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property DateTimeTo As Date
    'Usage

Dim instance As DicomAttribute
Dim value As Date

value = instance.DateTimeTo
    public DateTime DateTimeTo {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / Description Property

    Description Property (DicomAttribute)
    In This Topic
    The DICOM Description of the Attribute
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Description As String
    'Usage

Dim instance As DicomAttribute
Dim value As String

value = instance.Description
    public string Description {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / Element Property

    Element Property (DicomAttribute)
    In This Topic
    The element indices of a data element
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Element As Integer
    'Usage

Dim instance As DicomAttribute
Dim value As Integer

value = instance.Element
    public int Element {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / Exists Property

    Exists Property
    Determines whether an attribute actually exists
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overridable ReadOnly Property Exists As Boolean
    'Usage

Dim instance As DicomAttribute
Dim value As Boolean

value = instance.Exists
    public virtual bool Exists {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / ExistsWithValue Property

    ExistsWithValue Property
    Returns True if non-null data is present.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property ExistsWithValue As Boolean
    'Usage

Dim instance As DicomAttribute
Dim value As Boolean

value = instance.ExistsWithValue
    public bool ExistsWithValue {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / Group Property

    Group Property (DicomAttribute)
    In This Topic
    The Group indices of a data element.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Group As Integer
    'Usage

Dim instance As DicomAttribute
Dim value As Integer

value = instance.Group
    public int Group {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / IsMultiple Property

    IsMultiple Property
    Determines whether an attribute has a potential value multiplicity of greater than 1
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property IsMultiple As Boolean
    'Usage

Dim instance As DicomAttribute
Dim value As Boolean

value = instance.IsMultiple
    public bool IsMultiple {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / IsNull Property

    IsNull Property
    Indicates whether DicomAttribute has a non-null value
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property IsNull As Boolean
    'Usage

Dim instance As DicomAttribute
Dim value As Boolean

value = instance.IsNull
    public bool IsNull {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / IsPrivate Property

    IsPrivate Property
    Checks whether an attribute is private
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property IsPrivate As Boolean
    'Usage

Dim instance As DicomAttribute
Dim value As Boolean

value = instance.IsPrivate
    public bool IsPrivate {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / Item Property
The 1-based index of the component to return

    Item Property (DicomAttribute)
    In This Topic
    The default indexer.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Default Property Item( _
   ByVal Index As Integer _
) As Object
    'Usage

Dim instance As DicomAttribute
Dim Index As Integer
Dim value As Object

value = instance.Item(Index)
    public object this[
   int Index
]; {get;}

    Parameters

    Index
    The 1-based index of the component to return
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / Keyword Property

    Keyword Property
    String representation of the attribute's keyword
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Keyword As String
    'Usage

Dim instance As DicomAttribute
Dim value As String

value = instance.Keyword
    public string Keyword {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / KeywordCode Property

    KeywordCode Property
    The attribute's keyword as a Keyword
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property KeywordCode As Keyword
    'Usage

Dim instance As DicomAttribute
Dim value As Keyword

value = instance.KeywordCode
    public Keyword KeywordCode {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / RawData Property

    RawData Property
    The raw data held in DicomAttribute object
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property RawData As Array
    'Usage

Dim instance As DicomAttribute
Dim value As Array

value = instance.RawData
    public Array RawData {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / Tag Property

    Tag Property (DicomAttribute)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Tag As Object
    'Usage

Dim instance As DicomAttribute
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / Value Property

    Value Property (DicomAttribute)
    In This Topic
    The value of a Data Element
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Value As Object
    'Usage

Dim instance As DicomAttribute
Dim value As Object

value = instance.Value
    public object Value {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / VM Property

    VM Property
    The value multiplicity of an attribute
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property VM As Integer
    'Usage

Dim instance As DicomAttribute
Dim value As Integer

value = instance.VM
    public int VM {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / VR Property

    VR Property
    The Value Representation of an attribute
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property VR As String
    'Usage

Dim instance As DicomAttribute
Dim value As String

instance.VR = value

value = instance.VR
    public string VR {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


%%PageItemTitle%% $$Fields$$

DicomObjects Namespace / DicomAttribute Class

    DicomAttribute Class Fields
    In This Topic

    For a list of all members of this type, see DicomAttribute members.

    Public Fields
     | Name | Description
Public Field | DelayedData |
    Top
    See Also

    Reference

    DicomAttribute Class
    DicomObjects Namespace


DicomObjects Namespace / DicomAttribute Class / DelayedData Field

    DelayedData Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public DelayedData As DicomAttribute.DelayedDataRoutine
    'Usage

Dim instance As DicomAttribute
Dim value As DicomAttribute.DelayedDataRoutine

value = instance.DelayedData

instance.DelayedData = value
    public DicomAttribute.DelayedDataRoutine DelayedData
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


%%PageItemTitle%%

DicomObjects Namespace / DicomContext Class
Members

In This Topic
    DicomContext Class
    In This Topic
    A DICOM presentation context, as used in association negotiation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class DicomContext
    'Usage

Dim instance As DicomContext
    public class DicomContext
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomContext

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContext Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomContext Class
Properties Methods

In This Topic
    DicomContext Class Members
    In This Topic

    The following tables list the members exposed by DicomContext.

    Public Properties
     | Name | Description
Public Property | AbstractSyntax | The abstract syntax associated with the presentation context
Public Property | AcceptedTS | The negotiated and accepted transfer syntax to be used in a presentation context
Public Property | ContextID | Uniquely identifies a presentation context for a given association
Public Property | ExtendedNegotiationValues | Used to negotiate extended information about a SOP class
Public Property | OfferedTS | The list of transfer syntaxes offered in a presentation context
Public Property | RequestorSCPRole | Used for reverse role negotiation
Public Property | RequestorSCURole | Used for reverse role negotiation
Public Property | Tag | A general purpose Tag for developer use
    Top
    Public Methods
     | Name | Description
Public Method | Reject | Rejects a particular presentation context
    Top
    See Also

    Reference

    DicomContext Class
    DicomObjects Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomContext Class

    DicomContext Class Methods
    In This Topic

    For a list of all members of this type, see DicomContext members.

    Public Methods
     | Name | Description
Public Method | Reject | Rejects a particular presentation context
    Top
    See Also

    Reference

    DicomContext Class
    DicomObjects Namespace


DicomObjects Namespace / DicomContext Class / Reject Method

Byte value, the reason for rejection

    Reject Method (DicomContext)
    In This Topic
    Rejects a particular presentation context
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub Reject( _
   ByVal Reason As Byte _
)
    'Usage

Dim instance As DicomContext
Dim Reason As Byte

instance.Reject(Reason)
    public void Reject(
   byte Reason
)

    Parameters

    Reason

    Byte value, the reason for rejection

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContext Class
    DicomContext Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomContext Class

    DicomContext Class Properties
    In This Topic

    For a list of all members of this type, see DicomContext members.

    Public Properties
     | Name | Description
Public Property | AbstractSyntax | The abstract syntax associated with the presentation context
Public Property | AcceptedTS | The negotiated and accepted transfer syntax to be used in a presentation context
Public Property | ContextID | Uniquely identifies a presentation context for a given association
Public Property | ExtendedNegotiationValues | Used to negotiate extended information about a SOP class
Public Property | OfferedTS | The list of transfer syntaxes offered in a presentation context
Public Property | RequestorSCPRole | Used for reverse role negotiation
Public Property | RequestorSCURole | Used for reverse role negotiation
Public Property | Tag | A general purpose Tag for developer use
    Top
    See Also

    Reference

    DicomContext Class
    DicomObjects Namespace


DicomObjects Namespace / DicomContext Class / AbstractSyntax Property

    AbstractSyntax Property
    The abstract syntax associated with the presentation context
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property AbstractSyntax As String
    'Usage

Dim instance As DicomContext
Dim value As String

value = instance.AbstractSyntax
    public string AbstractSyntax {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContext Class
    DicomContext Members


DicomObjects Namespace / DicomContext Class / AcceptedTS Property

    AcceptedTS Property

    The negotiated and accepted transfer syntax to be used in a presentation context

    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property AcceptedTS As String
    'Usage

Dim instance As DicomContext
Dim value As String

instance.AcceptedTS = value

value = instance.AcceptedTS
    public string AcceptedTS {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContext Class
    DicomContext Members


DicomObjects Namespace / DicomContext Class / ContextID Property

    ContextID Property
    Uniquely identifies a presentation context for a given association
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property ContextID As Byte
    'Usage

Dim instance As DicomContext
Dim value As Byte

value = instance.ContextID
    public byte ContextID {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContext Class
    DicomContext Members


DicomObjects Namespace / DicomContext Class / ExtendedNegotiationValues Property

    ExtendedNegotiationValues Property
    Used to negotiate extended information about a SOP class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property ExtendedNegotiationValues As Byte()
    'Usage

Dim instance As DicomContext
Dim value() As Byte

instance.ExtendedNegotiationValues = value

value = instance.ExtendedNegotiationValues
    public byte[] ExtendedNegotiationValues {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContext Class
    DicomContext Members


DicomObjects Namespace / DicomContext Class / OfferedTS Property

    OfferedTS Property
    The list of transfer syntaxes offered in a presentation context
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property OfferedTS As String()
    'Usage

Dim instance As DicomContext
Dim value() As String

instance.OfferedTS = value

value = instance.OfferedTS
    public string[] OfferedTS {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContext Class
    DicomContext Members


DicomObjects Namespace / DicomContext Class / RequestorSCPRole Property

    RequestorSCPRole Property
    Used for reverse role negotiation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property RequestorSCPRole As Boolean
    'Usage

Dim instance As DicomContext
Dim value As Boolean

instance.RequestorSCPRole = value

value = instance.RequestorSCPRole
    public bool RequestorSCPRole {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContext Class
    DicomContext Members


DicomObjects Namespace / DicomContext Class / RequestorSCURole Property

    RequestorSCURole Property
    Used for reverse role negotiation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property RequestorSCURole As Boolean
    'Usage

Dim instance As DicomContext
Dim value As Boolean

instance.RequestorSCURole = value

value = instance.RequestorSCURole
    public bool RequestorSCURole {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContext Class
    DicomContext Members


DicomObjects Namespace / DicomContext Class / Tag Property

    Tag Property (DicomContext)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Tag As Object
    'Usage

Dim instance As DicomContext
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContext Class
    DicomContext Members


%%PageItemTitle%%

DicomObjects Namespace / DicomContextCollection Class
Members

In This Topic
    DicomContextCollection Class
    In This Topic
    The list of DICOM Presentation contexts proposed or accepted during negotiation
    Object Model
    DicomContextCollection ClassDicomContext Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

<DefaultMemberAttribute("Item")>
<DebuggerTypeProxyAttribute(System.Collections.Generic.CollectionDebugView`1)>
<DebuggerDisplayAttribute("Count = {Count}")>
Public Class DicomContextCollection
   Inherits System.Collections.ObjectModel.KeyedCollection(Of Byte,DicomContext)
    'Usage

Dim instance As DicomContextCollection
    [DefaultMember("Item")]
[DebuggerTypeProxy(System.Collections.Generic.CollectionDebugView`1)]
[DebuggerDisplay("Count = {Count}")]
public class DicomContextCollection : System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>
    Inheritance Hierarchy

    System.Object
    System.Collections.ObjectModel.Collection<T>
    System.Collections.ObjectModel.KeyedCollection<TKey,TItem>
    DicomObjects.DicomContextCollection

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContextCollection Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomContextCollection Class
Properties Methods

In This Topic
    DicomContextCollection Class Members
    In This Topic

    The following tables list the members exposed by DicomContextCollection.

    Public Properties
     | Name | Description
Public Property | AnyPresent | Indicates if there is any context agreed by the remote application
Public Property | Comparer | (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Property | Item | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Property | Tag | A general purpose Tag for developer use
    Top
    Public Methods
     | Name | Description
Public Method | Add | Overloaded. Adds a DicomContext to a DicomContextCollection
Public Method | AddDefaults | Add the default SOP Class UIDs to Presentation Contexts
Public Method | CanUse | Checks whether at least one presentation context has been negotiated for a given SOP class
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Contains | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Exists | Checks whether a particular presentation ocntext ID exists
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Remove | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | TryGetValue | (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
    Top
    See Also

    Reference

    DicomContextCollection Class
    DicomObjects Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomContextCollection Class

    DicomContextCollection Class Methods
    In This Topic

    For a list of all members of this type, see DicomContextCollection members.

    Public Methods
     | Name | Description
Public Method | Add | Overloaded. Adds a DicomContext to a DicomContextCollection
Public Method | AddDefaults | Add the default SOP Class UIDs to Presentation Contexts
Public Method | CanUse | Checks whether at least one presentation context has been negotiated for a given SOP class
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Contains | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Exists | Checks whether a particular presentation ocntext ID exists
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Remove | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | TryGetValue | (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
    Top
    See Also

    Reference

    DicomContextCollection Class
    DicomObjects Namespace


DicomObjects Namespace / DicomContextCollection Class / Add Method

    Add Method (DicomContextCollection)
    In This Topic
    Adds a DicomContext to a DicomContextCollection
    Overload List
    Overload | Description
Add(String) | Adds a DicomContext to a DicomContextCollection
Add(String,String) | Adds a DicomContext to a DicomContextCollection, together with the proposed TransferSyntax for the Presentation Context
Add(String,IEnumerable<String>) | Adds a DicomContext to a DicomContextCollection, together with a list of proposed TransferSyntax for the Presentation Context
Add(DicomContext) | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContextCollection Class
    DicomContextCollection Members


DicomObjects Namespace / DicomContextCollection Class / Add Method / Add(String) Method

String value specifying the proposed AbstractSyntax

    Add(String) Method
    In This Topic
    Adds a DicomContext to a DicomContextCollection
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function Add( _
   ByVal AbstractSyntax As String _
) As DicomContext
    'Usage

Dim instance As DicomContextCollection
Dim AbstractSyntax As String
Dim value As DicomContext

value = instance.Add(AbstractSyntax)
    public DicomContext Add(
   string AbstractSyntax
)

    Parameters

    AbstractSyntax

    String value specifying the proposed AbstractSyntax

    Return Value

    DicomContext
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContextCollection Class
    DicomContextCollection Members
    Overload List


DicomObjects Namespace / DicomContextCollection Class / Add Method / Add(String,String) Method

The string value of proposed AbstractSyntax

The string value of he proposed TransferSyntax for that Presentation Context.

In This Topic
    Add(String,String) Method
    In This Topic
    Adds a DicomContext to a DicomContextCollection, together with the proposed TransferSyntax for the Presentation Context
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function Add( _
   ByVal AbstractSyntax As String, _
   ByVal TransferSyntax As String _
) As DicomContext
    'Usage

Dim instance As DicomContextCollection
Dim AbstractSyntax As String
Dim TransferSyntax As String
Dim value As DicomContext

value = instance.Add(AbstractSyntax, TransferSyntax)
    public DicomContext Add(
   string AbstractSyntax,
   string TransferSyntax
)

    Parameters

    AbstractSyntax

    The string value of proposed AbstractSyntax

    TransferSyntax

    The string value of he proposed TransferSyntax for that Presentation Context.

    Return Value

    DicomContext
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContextCollection Class
    DicomContextCollection Members
    Overload List


DicomObjects Namespace / DicomContextCollection Class / Add Method / Add(String,IEnumerable<String>) Method

The string value of proposed AbstractSyntax

The list of proposed TransferSyntaxes for that Presentation Context.

In This Topic
    Add(String,IEnumerable<String>) Method
    In This Topic
    Adds a DicomContext to a DicomContextCollection, together with a list of proposed TransferSyntax for the Presentation Context
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function Add( _
   ByVal AbstractSyntax As String, _
   ByVal TransferSyntaxes As IEnumerable(Of String) _
) As DicomContext
    'Usage

Dim instance As DicomContextCollection
Dim AbstractSyntax As String
Dim TransferSyntaxes As IEnumerable(Of String)
Dim value As DicomContext

value = instance.Add(AbstractSyntax, TransferSyntaxes)
    public DicomContext Add(
   string AbstractSyntax,
   IEnumerable<string> TransferSyntaxes
)

    Parameters

    AbstractSyntax

    The string value of proposed AbstractSyntax

    TransferSyntaxes

    The list of proposed TransferSyntaxes for that Presentation Context.

    Return Value

    DicomContext
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContextCollection Class
    DicomContextCollection Members
    Overload List


DicomObjects Namespace / DicomContextCollection Class / AddDefaults Method
TransferSyntax to add to each of the SOP Class UIDs in the default list

In This Topic
    AddDefaults Method
    In This Topic
    Add the default SOP Class UIDs to Presentation Contexts
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub AddDefaults( _
   ByVal TransferSyntax As String _
)
    'Usage

Dim instance As DicomContextCollection
Dim TransferSyntax As String

instance.AddDefaults(TransferSyntax)
    public void AddDefaults(
   string TransferSyntax
)

    Parameters

    TransferSyntax
    TransferSyntax to add to each of the SOP Class UIDs in the default list
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContextCollection Class
    DicomContextCollection Members


DicomObjects Namespace / DicomContextCollection Class / CanUse Method
The SOP Class (abstract syntax) to be checked

    CanUse Method
    In This Topic
    Checks whether at least one presentation context has been negotiated for a given SOP class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function CanUse( _
   ByVal SOPClass As String _
) As Boolean
    'Usage

Dim instance As DicomContextCollection
Dim SOPClass As String
Dim value As Boolean

value = instance.CanUse(SOPClass)
    public bool CanUse(
   string SOPClass
)

    Parameters

    SOPClass
    The SOP Class (abstract syntax) to be checked

    Return Value

    True if the SOP class can be used
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContextCollection Class
    DicomContextCollection Members


DicomObjects Namespace / DicomContextCollection Class / Exists Method
the (odd numbered) presentation Context ID to check

    Exists Method
    In This Topic
    Checks whether a particular presentation ocntext ID exists
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function Exists( _
   ByVal ContextID As Byte _
) As Boolean
    'Usage

Dim instance As DicomContextCollection
Dim ContextID As Byte
Dim value As Boolean

value = instance.Exists(ContextID)
    public bool Exists(
   byte ContextID
)

    Parameters

    ContextID
    the (odd numbered) presentation Context ID to check

    Return Value

    True if the entry exists
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContextCollection Class
    DicomContextCollection Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomContextCollection Class

    DicomContextCollection Class Properties
    In This Topic

    For a list of all members of this type, see DicomContextCollection members.

    Public Properties
     | Name | Description
Public Property | AnyPresent | Indicates if there is any context agreed by the remote application
Public Property | Comparer | (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Property | Item | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Property | Tag | A general purpose Tag for developer use
    Top
    See Also

    Reference

    DicomContextCollection Class
    DicomObjects Namespace


DicomObjects Namespace / DicomContextCollection Class / AnyPresent Property

    AnyPresent Property
    Indicates if there is any context agreed by the remote application
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property AnyPresent As Boolean
    'Usage

Dim instance As DicomContextCollection
Dim value As Boolean

value = instance.AnyPresent
    public bool AnyPresent {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContextCollection Class
    DicomContextCollection Members


DicomObjects Namespace / DicomContextCollection Class / Tag Property

    Tag Property (DicomContextCollection)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Tag As Object
    'Usage

Dim instance As DicomContextCollection
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContextCollection Class
    DicomContextCollection Members


%%PageItemTitle%%

DicomObjects Namespace / DicomDataSet Class
Members

In This Topic
    DicomDataSet Class
    In This Topic
    A DICOM data set
    Object Model
    DicomDataSet ClassDicomAttribute Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

<DefaultMemberAttribute("Item")>
Public Class DicomDataSet
    'Usage

Dim instance As DicomDataSet
    [DefaultMember("Item")]
public class DicomDataSet
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomDataSet

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomDataSet Class
Fields Properties Methods

In This Topic
    DicomDataSet Class Members
    In This Topic

    The following tables list the members exposed by DicomDataSet.

    Public Constructors
     | Name | Description
Public Constructor | DicomDataSet Constructor | Overloaded.
    Top
    Public Fields
     | Name | Description
Public Field | CompressedFrameStream | User-defined function to set output stream for compressed frame. This is suitable for writing out large compressed frames with Basic Offset Table.
    Top
    Public Properties
     | Name | Description
Public Property | AccessionNumber | The Accession Number
Public Property | CacheMode | Controls how the pixel data is cached
Public Property | Children | Holds the hierarchical directory structure for DICOM directory files
Public Property | Command | The full command dataset received
Public Property | Count | Number of Attributes held in the DataSet
Public Property | DateOfBirth | Date of birth of the patient
Public Property | Identifer | Returns the underlying DataSet which contains the list of attributes to be matched, as specified in the DICOM standard.
Public Property | InstanceUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Item | Overloaded. Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Public Property | Name | The Name of the patient
Public Property | OriginalTS | Returns the Transfer syntax with which the object was originally received or read.
Public Property | Overrides | Image-specific list of unusual behaviours (e.g. to cope with faulty images)
Public Property | OverrideTS | A means to override an incorrect transfer syntax
Public Property | PatientID | The Patient ID
Public Property | PixelsPerFrame | The number of pixels per frame
Public Property | RawPixels | Accesses the raw pixel data as an array
Public Property | SamplesPerFrame | The number of samples per frame
Public Property | SeriesDescription | Descriptions for the series
Public Property | SeriesUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Sex | Sex of the patient
Public Property | Size |
Public Property | SOPClass | SOP class of the DicomDataSet.
Public Property | StudyDescription | Description for the study
Public Property | StudyUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Tag | A general purpose Tag for developer use
Public Property | UncompressedPI | Gets the Photometric Interpretation of the uncompressed Image data.
Public Property | ValidationDataSet | Assign a Validation DataSet to this property would override the DataSet's Validation scheme. This is mainly used for validation of CharacterSet.
Public Property | ValidationOptions |
    Top
    Public Methods
     | Name | Description
Public Method | Add | Overloaded. Creates and adds standard data elements to DicomDataSet
Public Method | AddByReference | Overloaded. Add byte[] as attribute value to avoid copying large data
Public Method | AddPixelData | Adds pixel data to DicomDataSet
Public Method | AddToDirectory | Simplified DICOMDIR creation with specified Image, Path, TransferSyntax
Public Method | Bitmap | Overloaded.
Public Method | ChangeCharacterSet | Change the specific Character Set of a DICOM dataset. All applicable attributes will have its data re-encoded by the new character set
Public Method | ChangeToDecompressed | Simulate the effect of writing out as a Decompressed Image
Public Method | Clear | Clear the DicomDataSet data
Public Method | Clone | Overloaded. Returns a copy of the DicomDataSet
Public Method | DecompressAll | Causes all the frames of an image to be decompressed.
Public Method | Dispose | Release the resources used by the DicomDataSet object
Public Method | FindAttribute | Locate an attribute within either a top level dataset, or within one of the functional group macros
Public Method | ForEachAttribute | Recursively perform an action on every attribute within the dataset
Public Method | FrameSubSet | Generates a new DicomDataSet as a subset of the current instance as described in supplement 119
Public Method | FunctionalGroupDataSet | Overloaded. Locate the required functional group within a
Public Method | FunctionalGroupOrRootLevelAttribute | Overloaded. Return the required within a specified functional group within a If DicomAttribute is not present in the specified DicomDataSet, it searches amongst the root level attributes
Public Method | GetAllBulkData | Load All Bulk data for attributes
Public Method | GetAllURIBulkData | Load Bulk data from URI, getting data from web calls
Public Method | GetMinAndMax | Overloaded. Find the maximum and minimum pixel data values in the pixel data
Public Method | GetPixelStream | Returns the raw pixel data as a Stream object for a specific frame
Public Method | Import |
Public Method | ImportPixelData | Direct import of compressed pixel data
Public Method | MergeBulkData | Load Bulk data for all attributes, getting data from a method, based on the URI
Public Method | OriginalPixelData |
Public Method | PixelValuesByFrameGeneric |
Public Method | Read | Overloaded. Reads from a standard Stream, with specific reading behaviour
Public Method | ReadJson | Read DICOM data from a Json Stream
Public Method | ReadURL | Reads DataSet from Web Address
Public Method | ReadXml | Read DICOM data from an XML Stream
Public Method | Remove | Overloaded. Removes an attribute from the DataSet
Public Method | RemovePrivateAttributes |
Public Method | Send | Overloaded. Sends a DicomDataSet to a remote DICOM application
Public Method | SetDicomCodec |
Public Method | SetNonDicomCodec |
Public Method | SetPlanarConfiguration | Sets the planar configuration in DicomDataSet
Public Method | SimplifyOverlays | Decompress the data, and move any overlays which are encoded with the pixel data (a method deprecated in DICOM many years ago) to stand-along overlay data in 60xx,3000.
Public Method | SKBitmap |
Public Method | Validate | Validate all DicomAttributes within the DicomDataset
Public Method | ValidateAll |
Public Method | Value | Overloaded. Returns the value of the specified Data Element
Public Method | Write | Overloaded. Writes dataset to an external DICOM file with specified transfer syntax and quality factor
Public Method | WriteJson | Write the DICOM data into an Json Stream
Public Method | WriteXml | Write the DICOM data into an XML Stream
    Top
    See Also

    Reference

    DicomDataSet Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / DicomDataSet Class / DicomDataSet Constructor

In This Topic
    DicomDataSet Constructor
    In This Topic
    Overload List
    Overload | Description
DicomDataSet Constructor() | Creates a new DicomDataSet
DicomDataSet Constructor(Stream,ReadBehaviours) | Creates a new DicomDataSet from system IO stream
DicomDataSet Constructor(Byte[],ReadBehaviours) | Creates a new DicomDataSet from a byte array
DicomDataSet Constructor(Bitmap) | Creates a new DicomDataSet
DicomDataSet Constructor(DicomDataSet,Boolean) | Creates a new DicomDataSet from an existing DicomDataSet object
DicomDataSet Constructor(String,ReadBehaviours) | Creates a new DicomDataSet from an external DICOM file
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


%%PageItemTitle%%

DicomObjects Namespace / DicomDataSet Class / DicomDataSet Constructor / DicomDataSet Constructor()

In This Topic
    DicomDataSet Constructor()
    In This Topic
    Creates a new DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New()
    'Usage

Dim instance As New DicomDataSet()
    public DicomDataSet()

    Return Value

    DicomDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


%%PageItemTitle%%

DicomObjects Namespace / DicomDataSet Class / DicomDataSet Constructor / DicomDataSet Constructor(Stream,ReadBehaviours)

The Stream from which to read.

Object to control individual read operation

In This Topic
    DicomDataSet Constructor(Stream,ReadBehaviours)
    In This Topic
    Creates a new DicomDataSet from system IO stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New( _
   ByVal Stream As Stream, _
   Optional ByVal ReadBehaviour As ReadBehaviours _
)
    'Usage

Dim Stream As Stream
Dim ReadBehaviour As ReadBehaviours

Dim instance As New DicomDataSet(Stream, ReadBehaviour)
    public DicomDataSet(
   Stream Stream,
   ReadBehaviours ReadBehaviour
)

    Parameters

    Stream

    The Stream from which to read.

    ReadBehaviour
    Object to control individual read operation

    Return Value

    DicomDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


%%PageItemTitle%%

DicomObjects Namespace / DicomDataSet Class / DicomDataSet Constructor / DicomDataSet Constructor(Byte[],ReadBehaviours)

The byte array to read

Object to control individual read operation

In This Topic
    DicomDataSet Constructor(Byte[],ReadBehaviours)
    In This Topic
    Creates a new DicomDataSet from a byte array
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New( _
   ByVal Array() As Byte, _
   Optional ByVal ReadBehaviour As ReadBehaviours _
)
    'Usage

Dim Array() As Byte
Dim ReadBehaviour As ReadBehaviours

Dim instance As New DicomDataSet(Array, ReadBehaviour)
    public DicomDataSet(
   byte[] Array,
   ReadBehaviours ReadBehaviour
)

    Parameters

    Array

    The byte array to read

    ReadBehaviour
    Object to control individual read operation

    Return Value

    DicomDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


%%PageItemTitle%%

DicomObjects Namespace / DicomDataSet Class / DicomDataSet Constructor / DicomDataSet Constructor(Bitmap)

In This Topic
    DicomDataSet Constructor(Bitmap)
    In This Topic
    Creates a new DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New( _
   ByVal bmp As Bitmap _
)
    'Usage

Dim bmp As Bitmap

Dim instance As New DicomDataSet(bmp)
    public DicomDataSet(
   Bitmap bmp
)

    Parameters

    bmp

    Return Value

    DicomDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


%%PageItemTitle%%

DicomObjects Namespace / DicomDataSet Class / DicomDataSet Constructor / DicomDataSet Constructor(DicomDataSet,Boolean)

The Origianl DicomDataSet object from which the new DicomDataSet is created.

Boolean, indicates weather a Deep/Shallow clone of the Original DicomDataSet will be performed when creating the new DicomDataSet.

In This Topic
    DicomDataSet Constructor(DicomDataSet,Boolean)
    In This Topic
    Creates a new DicomDataSet from an existing DicomDataSet object
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New( _
   ByVal Original As DicomDataSet, _
   ByVal Deep As Boolean _
)
    'Usage

Dim Original As DicomDataSet
Dim Deep As Boolean

Dim instance As New DicomDataSet(Original, Deep)
    public DicomDataSet(
   DicomDataSet Original,
   bool Deep
)

    Parameters

    Original

    The Origianl DicomDataSet object from which the new DicomDataSet is created.

    Deep

    Boolean, indicates weather a Deep/Shallow clone of the Original DicomDataSet will be performed when creating the new DicomDataSet.

    Return Value

    DicomDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


%%PageItemTitle%%

DicomObjects Namespace / DicomDataSet Class / DicomDataSet Constructor / DicomDataSet Constructor(String,ReadBehaviours)

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

Object to control individual read operation

In This Topic
    DicomDataSet Constructor(String,ReadBehaviours)
    In This Topic
    Creates a new DicomDataSet from an external DICOM file
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New( _
   ByVal Filename As String, _
   Optional ByVal ReadBehaviour As ReadBehaviours _
)
    'Usage

Dim Filename As String
Dim ReadBehaviour As ReadBehaviours

Dim instance As New DicomDataSet(Filename, ReadBehaviour)
    public DicomDataSet(
   string Filename,
   ReadBehaviours ReadBehaviour
)

    Parameters

    Filename

    The name of the file to read.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

    ReadBehaviour
    Object to control individual read operation

    Return Value

    DicomDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomDataSet Class

    DicomDataSet Class Methods
    In This Topic

    For a list of all members of this type, see DicomDataSet members.

    Public Methods
     | Name | Description
Public Method | Add | Overloaded. Creates and adds standard data elements to DicomDataSet
Public Method | AddByReference | Overloaded. Add byte[] as attribute value to avoid copying large data
Public Method | AddPixelData | Adds pixel data to DicomDataSet
Public Method | AddToDirectory | Simplified DICOMDIR creation with specified Image, Path, TransferSyntax
Public Method | Bitmap | Overloaded.
Public Method | ChangeCharacterSet | Change the specific Character Set of a DICOM dataset. All applicable attributes will have its data re-encoded by the new character set
Public Method | ChangeToDecompressed | Simulate the effect of writing out as a Decompressed Image
Public Method | Clear | Clear the DicomDataSet data
Public Method | Clone | Overloaded. Returns a copy of the DicomDataSet
Public Method | DecompressAll | Causes all the frames of an image to be decompressed.
Public Method | Dispose | Release the resources used by the DicomDataSet object
Public Method | FindAttribute | Locate an attribute within either a top level dataset, or within one of the functional group macros
Public Method | ForEachAttribute | Recursively perform an action on every attribute within the dataset
Public Method | FrameSubSet | Generates a new DicomDataSet as a subset of the current instance as described in supplement 119
Public Method | FunctionalGroupDataSet | Overloaded. Locate the required functional group within a
Public Method | FunctionalGroupOrRootLevelAttribute | Overloaded. Return the required within a specified functional group within a If DicomAttribute is not present in the specified DicomDataSet, it searches amongst the root level attributes
Public Method | GetAllBulkData | Load All Bulk data for attributes
Public Method | GetAllURIBulkData | Load Bulk data from URI, getting data from web calls
Public Method | GetMinAndMax | Overloaded. Find the maximum and minimum pixel data values in the pixel data
Public Method | GetPixelStream | Returns the raw pixel data as a Stream object for a specific frame
Public Method | Import |
Public Method | ImportPixelData | Direct import of compressed pixel data
Public Method | MergeBulkData | Load Bulk data for all attributes, getting data from a method, based on the URI
Public Method | OriginalPixelData |
Public Method | PixelValuesByFrameGeneric |
Public Method | Read | Overloaded. Reads from a standard Stream, with specific reading behaviour
Public Method | ReadJson | Read DICOM data from a Json Stream
Public Method | ReadURL | Reads DataSet from Web Address
Public Method | ReadXml | Read DICOM data from an XML Stream
Public Method | Remove | Overloaded. Removes an attribute from the DataSet
Public Method | RemovePrivateAttributes |
Public Method | Send | Overloaded. Sends a DicomDataSet to a remote DICOM application
Public Method | SetDicomCodec |
Public Method | SetNonDicomCodec |
Public Method | SetPlanarConfiguration | Sets the planar configuration in DicomDataSet
Public Method | SimplifyOverlays | Decompress the data, and move any overlays which are encoded with the pixel data (a method deprecated in DICOM many years ago) to stand-along overlay data in 60xx,3000.
Public Method | SKBitmap |
Public Method | Validate | Validate all DicomAttributes within the DicomDataset
Public Method | ValidateAll |
Public Method | Value | Overloaded. Returns the value of the specified Data Element
Public Method | Write | Overloaded. Writes dataset to an external DICOM file with specified transfer syntax and quality factor
Public Method | WriteJson | Write the DICOM data into an Json Stream
Public Method | WriteXml | Write the DICOM data into an XML Stream
    Top
    See Also

    Reference

    DicomDataSet Class
    DicomObjects Namespace


DicomObjects Namespace / DicomDataSet Class / Add Method

    Add Method (DicomDataSet)
    In This Topic
    Creates and adds standard data elements to DicomDataSet
    Overload List
    Overload | Description
Add(Int32,Int32,Object) | Creates and adds standard data elements to DicomDataSet
Add(Keyword,Object) | Creates and adds standard data elements to DicomDataSet
Add(IEnumerable<DicomAttribute>) | Add a collection of DicomAttributes to the DataSet
Add(DicomAttribute) | Add an existing attribute to the DataSet
Add(String,Object) | Creates and adds standard data elements to DicomDataSet
Add(Keyword,String,Object) | Creates and adds standard data elements to DicomDataSet
Add(Int32,Int32,String,Object) | Creates and adds standard data elements with specified VR to DicomDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Add Method / Add(Int32,Int32,Object) Method

The group index of a data element.

The element index of a data element.

The Value to be assigned

In This Topic
    Add(Int32,Int32,Object) Method
    In This Topic
    Creates and adds standard data elements to DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Add( _
   ByVal Group As Integer, _
   ByVal Element As Integer, _
   ByVal Value As Object _
)
    'Usage

Dim instance As DicomDataSet
Dim Group As Integer
Dim Element As Integer
Dim Value As Object

instance.Add(Group, Element, Value)
    public void Add(
   int Group,
   int Element,
   object Value
)

    Parameters

    Group

    The group index of a data element.

    Element

    The element index of a data element.

    Value

    The Value to be assigned

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Add Method / Add(Keyword,Object) Method

The DICOM Keyword of the data element.

The Value to be assigned

In This Topic
    Add(Keyword,Object) Method
    In This Topic
    Creates and adds standard data elements to DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Add( _
   ByVal Keyword As Keyword, _
   ByVal Value As Object _
)
    'Usage

Dim instance As DicomDataSet
Dim Keyword As Keyword
Dim Value As Object

instance.Add(Keyword, Value)
    public void Add(
   Keyword Keyword,
   object Value
)

    Parameters

    Keyword

    The DICOM Keyword of the data element.

    Value

    The Value to be assigned

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Add Method / Add(IEnumerable<DicomAttribute>) Method
A list of DicomAttribute to add

    Add(IEnumerable<DicomAttribute>) Method
    In This Topic
    Add a collection of DicomAttributes to the DataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Add( _
   ByVal attributes As IEnumerable(Of DicomAttribute) _
)
    'Usage

Dim instance As DicomDataSet
Dim attributes As IEnumerable(Of DicomAttribute)

instance.Add(attributes)
    public void Add(
   IEnumerable<DicomAttribute> attributes
)

    Parameters

    attributes
    A list of DicomAttribute to add
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Add Method / Add(DicomAttribute) Method
An existing DicomAttribute to add

    Add(DicomAttribute) Method
    In This Topic
    Add an existing attribute to the DataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Add( _
   ByVal attribute As DicomAttribute _
)
    'Usage

Dim instance As DicomDataSet
Dim attribute As DicomAttribute

instance.Add(attribute)
    public void Add(
   DicomAttribute attribute
)

    Parameters

    attribute
    An existing DicomAttribute to add
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Add Method / Add(String,Object) Method

The DICOM Keyword of the data element.

The Value to be assigned

In This Topic
    Add(String,Object) Method
    In This Topic
    Creates and adds standard data elements to DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Add( _
   ByVal Keyword As String, _
   ByVal Value As Object _
)
    'Usage

Dim instance As DicomDataSet
Dim Keyword As String
Dim Value As Object

instance.Add(Keyword, Value)
    public void Add(
   string Keyword,
   object Value
)

    Parameters

    Keyword

    The DICOM Keyword of the data element.

    Value

    The Value to be assigned

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Add Method / Add(Keyword,String,Object) Method

The DICOM Keyword of the data element.

The value representation (2 character string) of the data element to be added

The Value to be assigned

In This Topic
    Add(Keyword,String,Object) Method
    In This Topic
    Creates and adds standard data elements to DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Add( _
   ByVal Keyword As Keyword, _
   ByVal VR As String, _
   ByVal Value As Object _
)
    'Usage

Dim instance As DicomDataSet
Dim Keyword As Keyword
Dim VR As String
Dim Value As Object

instance.Add(Keyword, VR, Value)
    public void Add(
   Keyword Keyword,
   string VR,
   object Value
)

    Parameters

    Keyword

    The DICOM Keyword of the data element.

    VR

    The value representation (2 character string) of the data element to be added

    Value

    The Value to be assigned

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Add Method / Add(Int32,Int32,String,Object) Method

The group index of a data element.

The element index of a data element.

The value representation (2 character string) of the data element to be added

The Value to be assigned

In This Topic
    Add(Int32,Int32,String,Object) Method
    In This Topic
    Creates and adds standard data elements with specified VR to DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Add( _
   ByVal Group As Integer, _
   ByVal Element As Integer, _
   ByVal VR As String, _
   ByVal Value As Object _
)
    'Usage

Dim instance As DicomDataSet
Dim Group As Integer
Dim Element As Integer
Dim VR As String
Dim Value As Object

instance.Add(Group, Element, VR, Value)
    public void Add(
   int Group,
   int Element,
   string VR,
   object Value
)

    Parameters

    Group

    The group index of a data element.

    Element

    The element index of a data element.

    VR

    The value representation (2 character string) of the data element to be added

    Value

    The Value to be assigned

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / AddByReference Method

    AddByReference Method
    Add byte[] as attribute value to avoid copying large data
    Overload List
    Overload | Description
AddByReference(Keyword,Byte[]) | Add byte[] as attribute value to avoid copying large data
AddByReference(Keyword,String,Byte[]) | Add byte[] as attribute value to avoid copying large data
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / AddByReference Method / AddByReference(Keyword,Byte[]) Method
Attribute tag to add
Attribute value as byte array

In This Topic
    AddByReference(Keyword,Byte[]) Method
    In This Topic
    Add byte[] as attribute value to avoid copying large data
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub AddByReference( _
   ByVal keyword As Keyword, _
   ByVal Value() As Byte _
)
    'Usage

Dim instance As DicomDataSet
Dim keyword As Keyword
Dim Value() As Byte

instance.AddByReference(keyword, Value)
    public void AddByReference(
   Keyword keyword,
   byte[] Value
)

    Parameters

    keyword
    Attribute tag to add
    Value
    Attribute value as byte array
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / AddByReference Method / AddByReference(Keyword,String,Byte[]) Method
Attribute tag to add
Attribute VR to add
Attribute value as byte array

In This Topic
    AddByReference(Keyword,String,Byte[]) Method
    In This Topic
    Add byte[] as attribute value to avoid copying large data
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub AddByReference( _
   ByVal keyword As Keyword, _
   ByVal VR As String, _
   ByVal Value() As Byte _
)
    'Usage

Dim instance As DicomDataSet
Dim keyword As Keyword
Dim VR As String
Dim Value() As Byte

instance.AddByReference(keyword, VR, Value)
    public void AddByReference(
   Keyword keyword,
   string VR,
   byte[] Value
)

    Parameters

    keyword
    Attribute tag to add
    VR
    Attribute VR to add
    Value
    Attribute value as byte array
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / AddPixelData Method

The Byte Array to be added to the Pixel Attribute (7FE0, 0010) of the DataSet

Specifies the UID of the transfer syntax in which the data is coded. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

In This Topic
    AddPixelData Method
    In This Topic
    Adds pixel data to DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub AddPixelData( _
   ByVal Data As Object, _
   ByVal TransferSyntax As String _
)
    'Usage

Dim instance As DicomDataSet
Dim Data As Object
Dim TransferSyntax As String

instance.AddPixelData(Data, TransferSyntax)
    public void AddPixelData(
   object Data,
   string TransferSyntax
)

    Parameters

    Data

    The Byte Array to be added to the Pixel Attribute (7FE0, 0010) of the DataSet

    TransferSyntax

    Specifies the UID of the transfer syntax in which the data is coded. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / AddToDirectory Method

Image from which to extract demographics, and (optionally) create an icon

The path is relative to where the DICOMDIR is to be written, and must conform to ISO9660/DICOM rules, and therefore be composed to up to 8 elements, each no more than 8 characters, with no extensions, separated by backslashes.

The format with which the image is to be written to disk

In This Topic
    AddToDirectory Method
    In This Topic
    Simplified DICOMDIR creation with specified Image, Path, TransferSyntax
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function AddToDirectory( _
   ByVal Image As DicomDataSet, _
   ByVal Path As String, _
   ByVal TransferSyntax As String _
) As DicomDataSetCollection
    'Usage

Dim instance As DicomDataSet
Dim Image As DicomDataSet
Dim Path As String
Dim TransferSyntax As String
Dim value As DicomDataSetCollection

value = instance.AddToDirectory(Image, Path, TransferSyntax)
    public DicomDataSetCollection AddToDirectory(
   DicomDataSet Image,
   string Path,
   string TransferSyntax
)

    Parameters

    Image

    Image from which to extract demographics, and (optionally) create an icon

    Path

    The path is relative to where the DICOMDIR is to be written, and must conform to ISO9660/DICOM rules, and therefore be composed to up to 8 elements, each no more than 8 characters, with no extensions, separated by backslashes.

    TransferSyntax

    The format with which the image is to be written to disk

    Return Value

    DicomDataSetCollection
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Bitmap Method

    Bitmap Method
    Overload List
    Overload | Description
Bitmap() |
Bitmap(Int32) |
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Bitmap Method / Bitmap() Method

    Bitmap() Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function Bitmap() As Bitmap
    'Usage

Dim instance As DicomDataSet
Dim value As Bitmap

value = instance.Bitmap()
    public Bitmap Bitmap()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Bitmap Method / Bitmap(Int32) Method

    Bitmap(Int32) Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function Bitmap( _
   ByVal frame As Integer _
) As Bitmap
    'Usage

Dim instance As DicomDataSet
Dim frame As Integer
Dim value As Bitmap

value = instance.Bitmap(frame)
    public Bitmap Bitmap(
   int frame
)

    Parameters

    frame
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / ChangeCharacterSet Method
The new Specific Character Set value

    ChangeCharacterSet Method
    In This Topic
    Change the specific Character Set of a DICOM dataset. All applicable attributes will have its data re-encoded by the new character set
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub ChangeCharacterSet( _
   ByVal NewCharacterSet As String _
)
    'Usage

Dim instance As DicomDataSet
Dim NewCharacterSet As String

instance.ChangeCharacterSet(NewCharacterSet)
    public void ChangeCharacterSet(
   string NewCharacterSet
)

    Parameters

    NewCharacterSet
    The new Specific Character Set value
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / ChangeToDecompressed Method

    ChangeToDecompressed Method
    Simulate the effect of writing out as a Decompressed Image
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub ChangeToDecompressed()
    'Usage

Dim instance As DicomDataSet

instance.ChangeToDecompressed()
    public void ChangeToDecompressed()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Clear Method

    Clear Method
    Clear the DicomDataSet data
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub Clear()
    'Usage

Dim instance As DicomDataSet

instance.Clear()
    public void Clear()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Clone Method

    Clone Method (DicomDataSet)
    In This Topic
    Returns a copy of the DicomDataSet
    Overload List
    Overload | Description
Clone(Boolean) | Returns a copy of the DicomDataSet
Clone() | Returns a copy of the DicomDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Clone Method / Clone(Boolean) Method

If true then returns a Deep copy of the DicomDataSet.

If false, returns a Shallow copy.

In This Topic
    Clone(Boolean) Method
    In This Topic
    Returns a copy of the DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Overridable Function Clone( _
   ByVal Deep As Boolean _
) As Object
    'Usage

Dim instance As DicomDataSet
Dim Deep As Boolean
Dim value As Object

value = instance.Clone(Deep)
    public virtual object Clone(
   bool Deep
)

    Parameters

    Deep

    If true then returns a Deep copy of the DicomDataSet.

    If false, returns a Shallow copy.

    Return Value

    DicomDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Clone Method / Clone() Method

    Clone() Method
    Returns a copy of the DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Overridable Function Clone() As Object
    'Usage

Dim instance As DicomDataSet
Dim value As Object

value = instance.Clone()
    public virtual object Clone()

    Return Value

    DicomDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / DecompressAll Method

    DecompressAll Method
    Causes all the frames of an image to be decompressed.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub DecompressAll()
    'Usage

Dim instance As DicomDataSet

instance.DecompressAll()
    public void DecompressAll()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Dispose Method

    Dispose Method (DicomDataSet)
    In This Topic
    Release the resources used by the DicomDataSet object
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overridable Sub Dispose()
    'Usage

Dim instance As DicomDataSet

instance.Dispose()
    public virtual void Dispose()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / FindAttribute Method
The sequence in a functional group that this attribute is part of
The item to be found
The frame number. This is only relevant if the item is found within the PerFrame functional groups sequence

In This Topic
    FindAttribute Method
    In This Topic
    Locate an attribute within either a top level dataset, or within one of the functional group macros
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function FindAttribute( _
   ByVal Macro As Keyword, _
   ByVal Item As Keyword, _
   ByVal Frame As Integer _
) As DicomAttribute
    'Usage

Dim instance As DicomDataSet
Dim Macro As Keyword
Dim Item As Keyword
Dim Frame As Integer
Dim value As DicomAttribute

value = instance.FindAttribute(Macro, Item, Frame)
    public DicomAttribute FindAttribute(
   Keyword Macro,
   Keyword Item,
   int Frame
)

    Parameters

    Macro
    The sequence in a functional group that this attribute is part of
    Item
    The item to be found
    Frame
    The frame number. This is only relevant if the item is found within the PerFrame functional groups sequence

    Return Value

    The requested
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / ForEachAttribute Method
Delegate, which takes as a parameter, the path to each attribute.

In This Topic
    ForEachAttribute Method
    In This Topic
    Recursively perform an action on every attribute within the dataset
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub ForEachAttribute( _
   ByVal action As Action(Of SequencePath) _
)
    'Usage

Dim instance As DicomDataSet
Dim action As Action(Of SequencePath)

instance.ForEachAttribute(action)
    public void ForEachAttribute(
   Action<SequencePath> action
)

    Parameters

    action
    Delegate, which takes as a parameter, the path to each attribute.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / FrameSubSet Method
Requested frame numbers

    FrameSubSet Method
    In This Topic
    Generates a new DicomDataSet as a subset of the current instance as described in supplement 119
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function FrameSubSet( _
   ByVal Frames As IEnumerable(Of UInteger) _
) As DicomDataSet
    'Usage

Dim instance As DicomDataSet
Dim Frames As IEnumerable(Of UInteger)
Dim value As DicomDataSet

value = instance.FrameSubSet(Frames)
    public DicomDataSet FrameSubSet(
   IEnumerable<uint> Frames
)

    Parameters

    Frames
    Requested frame numbers

    Return Value

    Subset DicomDataSet that includes the requested frames
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / FunctionalGroupDataSet Method

    FunctionalGroupDataSet Method
    Locate the required functional group within a
    Overload List
    Overload | Description
FunctionalGroupDataSet(Int32,Int32,Int32) | Locate the required functional group within a
FunctionalGroupDataSet(Keyword,Int32) | Locate the required functional group within a
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / FunctionalGroupDataSet Method / FunctionalGroupDataSet(Int32,Int32,Int32) Method
The Group of the requested dataset
The Element of the requested dataset
The frame number to which the dataset should apply

In This Topic
    FunctionalGroupDataSet(Int32,Int32,Int32) Method
    In This Topic
    Locate the required functional group within a
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function FunctionalGroupDataSet( _
   ByVal FunctionalGroup As Integer, _
   ByVal FunctionalElement As Integer, _
   ByVal Frame As Integer _
) As DicomDataSet
    'Usage

Dim instance As DicomDataSet
Dim FunctionalGroup As Integer
Dim FunctionalElement As Integer
Dim Frame As Integer
Dim value As DicomDataSet

value = instance.FunctionalGroupDataSet(FunctionalGroup, FunctionalElement, Frame)
    public DicomDataSet FunctionalGroupDataSet(
   int FunctionalGroup,
   int FunctionalElement,
   int Frame
)

    Parameters

    FunctionalGroup
    The Group of the requested dataset
    FunctionalElement
    The Element of the requested dataset
    Frame
    The frame number to which the dataset should apply

    Return Value

    The requested dataset
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / FunctionalGroupDataSet Method / FunctionalGroupDataSet(Keyword,Int32) Method
The Keyword descriptor of the requested dataset
The frame number to which the dataset should apply

In This Topic
    FunctionalGroupDataSet(Keyword,Int32) Method
    In This Topic
    Locate the required functional group within a
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function FunctionalGroupDataSet( _
   ByVal Macro As Keyword, _
   ByVal Frame As Integer _
) As DicomDataSet
    'Usage

Dim instance As DicomDataSet
Dim Macro As Keyword
Dim Frame As Integer
Dim value As DicomDataSet

value = instance.FunctionalGroupDataSet(Macro, Frame)
    public DicomDataSet FunctionalGroupDataSet(
   Keyword Macro,
   int Frame
)

    Parameters

    Macro
    The Keyword descriptor of the requested dataset
    Frame
    The frame number to which the dataset should apply

    Return Value

    The requested dataset
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / FunctionalGroupOrRootLevelAttribute Method

    FunctionalGroupOrRootLevelAttribute Method
    Return the required within a specified functional group within a If DicomAttribute is not present in the specified DicomDataSet, it searches amongst the root level attributes
    Overload List
    Overload | Description
FunctionalGroupOrRootLevelAttribute(Keyword,Int32,Keyword) | Return the required within a specified functional group within a If DicomAttribute is not present in the specified DicomDataSet, it searches amongst the root level attributes
FunctionalGroupOrRootLevelAttribute(Int32,Int32,Int32,Int32,Int32) | Return the required within a specified functional group within a
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / FunctionalGroupOrRootLevelAttribute Method / FunctionalGroupOrRootLevelAttribute(Keyword,Int32,Keyword) Method
The keyword of the requested dataset
The frame number to which the dataset should apply
The keyword of the requested attribute within the dataset

In This Topic
    FunctionalGroupOrRootLevelAttribute(Keyword,Int32,Keyword) Method
    In This Topic
    Return the required within a specified functional group within a If DicomAttribute is not present in the specified DicomDataSet, it searches amongst the root level attributes
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function FunctionalGroupOrRootLevelAttribute( _
   ByVal FunctionalAttribute As Keyword, _
   ByVal Frame As Integer, _
   ByVal keyword As Keyword _
) As DicomAttribute
    'Usage

Dim instance As DicomDataSet
Dim FunctionalAttribute As Keyword
Dim Frame As Integer
Dim keyword As Keyword
Dim value As DicomAttribute

value = instance.FunctionalGroupOrRootLevelAttribute(FunctionalAttribute, Frame, keyword)
    public DicomAttribute FunctionalGroupOrRootLevelAttribute(
   Keyword FunctionalAttribute,
   int Frame,
   Keyword keyword
)

    Parameters

    FunctionalAttribute
    The keyword of the requested dataset
    Frame
    The frame number to which the dataset should apply
    keyword
    The keyword of the requested attribute within the dataset

    Return Value

    The requested
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / FunctionalGroupOrRootLevelAttribute Method / FunctionalGroupOrRootLevelAttribute(Int32,Int32,Int32,Int32,Int32) Method
The Group of the requested dataset
The Element of the requested dataset
The frame number to which the dataset should apply
The Group number of the requested attribute within the dataset
The Element number of the requested attribute within the dataset

In This Topic
    FunctionalGroupOrRootLevelAttribute(Int32,Int32,Int32,Int32,Int32) Method
    In This Topic
    Return the required within a specified functional group within a
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function FunctionalGroupOrRootLevelAttribute( _
   ByVal FunctionalGroup As Integer, _
   ByVal FunctionalElement As Integer, _
   ByVal Frame As Integer, _
   ByVal Group As Integer, _
   ByVal Element As Integer _
) As DicomAttribute
    'Usage

Dim instance As DicomDataSet
Dim FunctionalGroup As Integer
Dim FunctionalElement As Integer
Dim Frame As Integer
Dim Group As Integer
Dim Element As Integer
Dim value As DicomAttribute

value = instance.FunctionalGroupOrRootLevelAttribute(FunctionalGroup, FunctionalElement, Frame, Group, Element)
    public DicomAttribute FunctionalGroupOrRootLevelAttribute(
   int FunctionalGroup,
   int FunctionalElement,
   int Frame,
   int Group,
   int Element
)

    Parameters

    FunctionalGroup
    The Group of the requested dataset
    FunctionalElement
    The Element of the requested dataset
    Frame
    The frame number to which the dataset should apply
    Group
    The Group number of the requested attribute within the dataset
    Element
    The Element number of the requested attribute within the dataset

    Return Value

    The requested
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / GetAllBulkData Method

    GetAllBulkData Method
    Load All Bulk data for attributes
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub GetAllBulkData()
    'Usage

Dim instance As DicomDataSet

instance.GetAllBulkData()
    public void GetAllBulkData()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / GetAllURIBulkData Method

    GetAllURIBulkData Method
    Load Bulk data from URI, getting data from web calls
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub GetAllURIBulkData()
    'Usage

Dim instance As DicomDataSet

instance.GetAllURIBulkData()
    public void GetAllURIBulkData()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / GetMinAndMax Method

    GetMinAndMax Method
    Find the maximum and minimum pixel data values in the pixel data
    Overload List
    Overload | Description
GetMinAndMax(Single,Single,Single,Boolean) | Find the maximum and minimum pixel data values in the pixel data
GetMinAndMax(Single,Single,Single,Boolean,Boolean) | Find the maximum and minimum pixel data values in the pixel data
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / GetMinAndMax Method / GetMinAndMax(Single,Single,Single,Boolean) Method
The minimum value found
The maximum value found
Proportion of extreme values to ignore
Whether to apply scaling/modality lookup table transformation

In This Topic
    GetMinAndMax(Single,Single,Single,Boolean) Method
    In This Topic
    Find the maximum and minimum pixel data values in the pixel data
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub GetMinAndMax( _
   ByRef Min As Single, _
   ByRef Max As Single, _
   ByVal Centile As Single, _
   ByVal Scale As Boolean _
)
    'Usage

Dim instance As DicomDataSet
Dim Min As Single
Dim Max As Single
Dim Centile As Single
Dim Scale As Boolean

instance.GetMinAndMax(Min, Max, Centile, Scale)
    public void GetMinAndMax(
   out float Min,
   out float Max,
   float Centile,
   bool Scale
)

    Parameters

    Min
    The minimum value found
    Max
    The maximum value found
    Centile
    Proportion of extreme values to ignore
    Scale
    Whether to apply scaling/modality lookup table transformation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / GetMinAndMax Method / GetMinAndMax(Single,Single,Single,Boolean,Boolean) Method
The minimum value found
The maximum value found
Centile as Float
Whether to apply modality lookup table transformation
Whether to apply modality rescale slope and offset transformations

In This Topic
    GetMinAndMax(Single,Single,Single,Boolean,Boolean) Method
    In This Topic
    Find the maximum and minimum pixel data values in the pixel data
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub GetMinAndMax( _
   ByRef Min As Single, _
   ByRef Max As Single, _
   ByVal Centile As Single, _
   ByVal ScaleLUT As Boolean, _
   ByVal ScaleRescale As Boolean _
)
    'Usage

Dim instance As DicomDataSet
Dim Min As Single
Dim Max As Single
Dim Centile As Single
Dim ScaleLUT As Boolean
Dim ScaleRescale As Boolean

instance.GetMinAndMax(Min, Max, Centile, ScaleLUT, ScaleRescale)
    public void GetMinAndMax(
   out float Min,
   out float Max,
   float Centile,
   bool ScaleLUT,
   bool ScaleRescale
)

    Parameters

    Min
    The minimum value found
    Max
    The maximum value found
    Centile
    Centile as Float
    ScaleLUT
    Whether to apply modality lookup table transformation
    ScaleRescale
    Whether to apply modality rescale slope and offset transformations
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / GetPixelStream Method
Requested pixel data for the frame

    GetPixelStream Method
    In This Topic
    Returns the raw pixel data as a Stream object for a specific frame
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function GetPixelStream( _
   ByVal Frame As Integer _
) As Stream
    'Usage

Dim instance As DicomDataSet
Dim Frame As Integer
Dim value As Stream

value = instance.GetPixelStream(Frame)
    public Stream GetPixelStream(
   int Frame
)

    Parameters

    Frame
    Requested pixel data for the frame

    Return Value

    PixelData of the specified frame or null if it is uncompressed data or it encounters any failure during conversion
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Import Method

    Import Method (DicomDataSet)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub Import( _
   ByVal Stream As Stream, _
   ByVal Format As String _
)
    'Usage

Dim instance As DicomDataSet
Dim Stream As Stream
Dim Format As String

instance.Import(Stream, Format)
    public void Import(
   Stream Stream,
   string Format
)

    Parameters

    Stream
    Format
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / ImportPixelData Method
The data fragments
The transfer synatax corresponding to the data

In This Topic
    ImportPixelData Method
    In This Topic
    Direct import of compressed pixel data
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub ImportPixelData( _
   ByVal CompressedData As IEnumerable(Of Byte()), _
   ByVal TransferSyntax As String _
)
    'Usage

Dim instance As DicomDataSet
Dim CompressedData As IEnumerable(Of Byte())
Dim TransferSyntax As String

instance.ImportPixelData(CompressedData, TransferSyntax)
    public void ImportPixelData(
   IEnumerable<byte[]> CompressedData,
   string TransferSyntax
)

    Parameters

    CompressedData
    The data fragments
    TransferSyntax
    The transfer synatax corresponding to the data
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / MergeBulkData Method
A method which, when passed a URI, returns the associated byte array
If true, then an exception is thrown if any items cannot be found

In This Topic
    MergeBulkData Method
    In This Topic
    Load Bulk data for all attributes, getting data from a method, based on the URI
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub MergeBulkData( _
   ByVal GetData As Func(Of Uri,String,HttpContent), _
   ByVal RequireBulkData As Boolean _
)
    'Usage

Dim instance As DicomDataSet
Dim GetData As Func(Of Uri,String,HttpContent)
Dim RequireBulkData As Boolean

instance.MergeBulkData(GetData, RequireBulkData)
    public void MergeBulkData(
   Func<Uri,string,HttpContent> GetData,
   bool RequireBulkData
)

    Parameters

    GetData
    A method which, when passed a URI, returns the associated byte array
    RequireBulkData
    If true, then an exception is thrown if any items cannot be found
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / OriginalPixelData Method

    OriginalPixelData Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function OriginalPixelData( _
   ByVal Frame As Integer, _
   ByRef TransferSyntax As String _
) As Array
    'Usage

Dim instance As DicomDataSet
Dim Frame As Integer
Dim TransferSyntax As String
Dim value As Array

value = instance.OriginalPixelData(Frame, TransferSyntax)
    public Array OriginalPixelData(
   int Frame,
   out string TransferSyntax
)

    Parameters

    Frame
    TransferSyntax
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / PixelValuesByFrameGeneric Method

    PixelValuesByFrameGeneric Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function PixelValuesByFrameGeneric( _
   ByVal frame As Integer, _
   ByVal modalityTransform As Boolean _
) As Array
    'Usage

Dim instance As DicomDataSet
Dim frame As Integer
Dim modalityTransform As Boolean
Dim value As Array

value = instance.PixelValuesByFrameGeneric(frame, modalityTransform)
    public Array PixelValuesByFrameGeneric(
   int frame,
   bool modalityTransform
)

    Parameters

    frame
    modalityTransform
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Read Method

    Read Method (DicomDataSet)
    In This Topic
    Reads from a standard Stream, with specific reading behaviour
    Overload List
    Overload | Description
Read(Stream) |
Read(Stream,ReadBehaviours) | Reads from a standard Stream, with specific reading behaviour
Read(String) |
Read(String,ReadBehaviours) | Reads from a DICOM file, using specific read behaviours
Read(Byte[],ReadBehaviours) | Reads from a byte array
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Read Method / Read(Stream) Method

    Read(Stream) Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Read( _
   ByVal Stream As Stream _
)
    'Usage

Dim instance As DicomDataSet
Dim Stream As Stream

instance.Read(Stream)
    public void Read(
   Stream Stream
)

    Parameters

    Stream
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Read Method / Read(Stream,ReadBehaviours) Method

The Stream from which to read.

In This Topic
    Read(Stream,ReadBehaviours) Method
    In This Topic
    Reads from a standard Stream, with specific reading behaviour
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Read( _
   ByVal Stream As Stream, _
   ByVal Behaviour As ReadBehaviours _
)
    'Usage

Dim instance As DicomDataSet
Dim Stream As Stream
Dim Behaviour As ReadBehaviours

instance.Read(Stream, Behaviour)
    public void Read(
   Stream Stream,
   ReadBehaviours Behaviour
)

    Parameters

    Stream

    The Stream from which to read.

    Behaviour
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Read Method / Read(String) Method

    Read(String) Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Read( _
   ByVal FileName As String _
)
    'Usage

Dim instance As DicomDataSet
Dim FileName As String

instance.Read(FileName)
    public void Read(
   string FileName
)

    Parameters

    FileName
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Read Method / Read(String,ReadBehaviours) Method

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

In This Topic
    Read(String,ReadBehaviours) Method
    In This Topic
    Reads from a DICOM file, using specific read behaviours
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Read( _
   ByVal FileName As String, _
   ByVal Behaviour As ReadBehaviours _
)
    'Usage

Dim instance As DicomDataSet
Dim FileName As String
Dim Behaviour As ReadBehaviours

instance.Read(FileName, Behaviour)
    public void Read(
   string FileName,
   ReadBehaviours Behaviour
)

    Parameters

    FileName

    The name of the file to read.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

    Behaviour
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Read Method / Read(Byte[],ReadBehaviours) Method

The byte array to read

The behaviours to be used when reading this stream

In This Topic
    Read(Byte[],ReadBehaviours) Method
    In This Topic
    Reads from a byte array
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Read( _
   ByVal Array() As Byte, _
   Optional ByVal Behaviour As ReadBehaviours _
)
    'Usage

Dim instance As DicomDataSet
Dim Array() As Byte
Dim Behaviour As ReadBehaviours

instance.Read(Array, Behaviour)
    public void Read(
   byte[] Array,
   ReadBehaviours Behaviour
)

    Parameters

    Array

    The byte array to read

    Behaviour

    The behaviours to be used when reading this stream

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / ReadJson Method
The Stream to read from

    ReadJson Method (DicomDataSet)
    In This Topic
    Read DICOM data from a Json Stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub ReadJson( _
   ByVal Stream As Stream _
)
    'Usage

Dim instance As DicomDataSet
Dim Stream As Stream

instance.ReadJson(Stream)
    public void ReadJson(
   Stream Stream
)

    Parameters

    Stream
    The Stream to read from
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / ReadURL Method

The web address of the DataSet to read.

In This Topic
    ReadURL Method
    In This Topic
    Reads DataSet from Web Address
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub ReadURL( _
   ByVal URL As String _
)
    'Usage

Dim instance As DicomDataSet
Dim URL As String

instance.ReadURL(URL)
    public void ReadURL(
   string URL
)

    Parameters

    URL

    The web address of the DataSet to read.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / ReadXml Method
The Stream to read from
The transfer syntax to assign to the resulting instances - see remarks

In This Topic
    ReadXml Method
    In This Topic
    Read DICOM data from an XML Stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub ReadXml( _
   ByVal Stream As Stream, _
   Optional ByVal TransferSyntax As String _
)
    'Usage

Dim instance As DicomDataSet
Dim Stream As Stream
Dim TransferSyntax As String

instance.ReadXml(Stream, TransferSyntax)
    public void ReadXml(
   Stream Stream,
   string TransferSyntax
)

    Parameters

    Stream
    The Stream to read from
    TransferSyntax
    The transfer syntax to assign to the resulting instances - see remarks
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Remove Method

    Remove Method (DicomDataSet)
    In This Topic
    Removes an attribute from the DataSet
    Overload List
    Overload | Description
Remove(Int32,Int32) | Removes an attribute from the DataSet
Remove(Keyword) | Removes an attribute from the DataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Remove Method / Remove(Int32,Int32) Method

The group index of a data element

The element index of a data element

In This Topic
    Remove(Int32,Int32) Method
    In This Topic
    Removes an attribute from the DataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Remove( _
   ByVal Group As Integer, _
   ByVal Element As Integer _
)
    'Usage

Dim instance As DicomDataSet
Dim Group As Integer
Dim Element As Integer

instance.Remove(Group, Element)
    public void Remove(
   int Group,
   int Element
)

    Parameters

    Group

    The group index of a data element

    Element

    The element index of a data element

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Remove Method / Remove(Keyword) Method
The attribute to be removed, specified as a Keyword

    Remove(Keyword) Method
    In This Topic
    Removes an attribute from the DataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Remove( _
   ByVal Keyword As Keyword _
)
    'Usage

Dim instance As DicomDataSet
Dim Keyword As Keyword

instance.Remove(Keyword)
    public void Remove(
   Keyword Keyword
)

    Parameters

    Keyword
    The attribute to be removed, specified as a Keyword
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / RemovePrivateAttributes Method

    RemovePrivateAttributes Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub RemovePrivateAttributes()
    'Usage

Dim instance As DicomDataSet

instance.RemovePrivateAttributes()
    public void RemovePrivateAttributes()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Send Method

    Send Method (DicomDataSet)
    In This Topic
    Sends a DicomDataSet to a remote DICOM application
    Overload List
    Overload | Description
Send(String,Int32,String,String) | Sends a DicomDataSet to a remote DICOM application
Send(String,Int32,String,String,IEnumerable<String>) | Sends a DicomDataSet to a remote DICOM application, with control over the set of transfer synatxes offered.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Send Method / Send(String,Int32,String,String) Method

Network address (as dotted notation or resolvable name) to which the image is to be sent.

Port on which remote application is listening.

Name of remote Application Entity.

Name to quote for this Application Entity

In This Topic
    Send(String,Int32,String,String) Method
    In This Topic
    Sends a DicomDataSet to a remote DICOM application
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function Send( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAE As String, _
   ByVal CalledAE As String _
) As Integer
    'Usage

Dim instance As DicomDataSet
Dim Node As String
Dim Port As Integer
Dim CallingAE As String
Dim CalledAE As String
Dim value As Integer

value = instance.Send(Node, Port, CallingAE, CalledAE)
    public int Send(
   string Node,
   int Port,
   string CallingAE,
   string CalledAE
)

    Parameters

    Node

    Network address (as dotted notation or resolvable name) to which the image is to be sent.

    Port

    Port on which remote application is listening.

    CallingAE

    Name of remote Application Entity.

    CalledAE

    Name to quote for this Application Entity

    Return Value

    The status as returned by the remote application. Zero indicates success.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Send Method / Send(String,Int32,String,String,IEnumerable<String>) Method

Network address (as dotted notation or resolvable name) to which the image is to be sent.

Port on which remote application is listening.

Name of remote Application Entity.

Name to quote for this Application Entity

A list of offered Transfer Syntaxes

In This Topic
    Send(String,Int32,String,String,IEnumerable<String>) Method
    In This Topic
    Sends a DicomDataSet to a remote DICOM application, with control over the set of transfer synatxes offered.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function Send( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAE As String, _
   ByVal CalledAE As String, _
   ByVal OfferedTS As IEnumerable(Of String) _
) As Integer
    'Usage

Dim instance As DicomDataSet
Dim Node As String
Dim Port As Integer
Dim CallingAE As String
Dim CalledAE As String
Dim OfferedTS As IEnumerable(Of String)
Dim value As Integer

value = instance.Send(Node, Port, CallingAE, CalledAE, OfferedTS)
    public int Send(
   string Node,
   int Port,
   string CallingAE,
   string CalledAE,
   IEnumerable<string> OfferedTS
)

    Parameters

    Node

    Network address (as dotted notation or resolvable name) to which the image is to be sent.

    Port

    Port on which remote application is listening.

    CallingAE

    Name of remote Application Entity.

    CalledAE

    Name to quote for this Application Entity

    OfferedTS

    A list of offered Transfer Syntaxes

    Return Value

    The status as returned by the remote application. Zero indicates success.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / SetDicomCodec Method

    SetDicomCodec Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub SetDicomCodec( _
   ByVal TS As UID, _
   ByVal dec As IDecompressor, _
   ByVal Stream As Stream _
)
    'Usage

Dim instance As DicomDataSet
Dim TS As UID
Dim dec As IDecompressor
Dim Stream As Stream

instance.SetDicomCodec(TS, dec, Stream)
    public void SetDicomCodec(
   UID TS,
   IDecompressor dec,
   Stream Stream
)

    Parameters

    TS
    dec
    Stream
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / SetNonDicomCodec Method

    SetNonDicomCodec Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub SetNonDicomCodec( _
   ByVal source As IFrameSource _
)
    'Usage

Dim instance As DicomDataSet
Dim source As IFrameSource

instance.SetNonDicomCodec(source)
    public void SetNonDicomCodec(
   IFrameSource source
)

    Parameters

    source
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / SetPlanarConfiguration Method

The enumerated value to be set for planar configuration attribute (0028, 0006)

In This Topic
    SetPlanarConfiguration Method
    In This Topic
    Sets the planar configuration in DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub SetPlanarConfiguration( _
   ByVal Value As Integer _
)
    'Usage

Dim instance As DicomDataSet
Dim Value As Integer

instance.SetPlanarConfiguration(Value)
    public void SetPlanarConfiguration(
   int Value
)

    Parameters

    Value

    The enumerated value to be set for planar configuration attribute (0028, 0006)

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / SimplifyOverlays Method

    SimplifyOverlays Method
    Decompress the data, and move any overlays which are encoded with the pixel data (a method deprecated in DICOM many years ago) to stand-along overlay data in 60xx,3000.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub SimplifyOverlays()
    'Usage

Dim instance As DicomDataSet

instance.SimplifyOverlays()
    public void SimplifyOverlays()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / SKBitmap Method

    SKBitmap Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function SKBitmap( _
   ByVal Quality As SkiaSharp.SKFilterQuality, _
   ByVal WantedFrame As Integer, _
   Optional ByVal WindowWidth As Single, _
   Optional ByVal WindowCenter As Single, _
   Optional ByVal UseVOIIfPresent As Boolean _
) As SkiaSharp.SKBitmap
    'Usage

Dim instance As DicomDataSet
Dim Quality As SkiaSharp.SKFilterQuality
Dim WantedFrame As Integer
Dim WindowWidth As Single
Dim WindowCenter As Single
Dim UseVOIIfPresent As Boolean
Dim value As SkiaSharp.SKBitmap

value = instance.SKBitmap(Quality, WantedFrame, WindowWidth, WindowCenter, UseVOIIfPresent)
    public SkiaSharp.SKBitmap SKBitmap(
   SkiaSharp.SKFilterQuality Quality,
   int WantedFrame,
   float WindowWidth,
   float WindowCenter,
   bool UseVOIIfPresent
)

    Parameters

    Quality
    WantedFrame
    WindowWidth
    WindowCenter
    UseVOIIfPresent
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Validate Method

    Validate Method
    Validate all DicomAttributes within the DicomDataset
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub Validate()
    'Usage

Dim instance As DicomDataSet

instance.Validate()
    public void Validate()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / ValidateAll Method

    ValidateAll Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function ValidateAll() As List(Of ValidationException)
    'Usage

Dim instance As DicomDataSet
Dim value As List(Of ValidationException)

value = instance.ValidateAll()
    public List<ValidationException> ValidateAll()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Value Method

    Value Method
    Returns the value of the specified Data Element
    Overload List
    Overload | Description
Value(Int32,Int32) | Returns the value of the specified Data Element
Value(Keyword) | Returns the value of the specified Data Element
Value(String) | Returns the value of the specified Data Element
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Value Method / Value(Int32,Int32) Method

The group index of the specified Data Element

The element index of the specified Data Element

In This Topic
    Value(Int32,Int32) Method
    In This Topic
    Returns the value of the specified Data Element
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function Value( _
   ByVal group As Integer, _
   ByVal element As Integer _
) As Object
    'Usage

Dim instance As DicomDataSet
Dim group As Integer
Dim element As Integer
Dim value As Object

value = instance.Value(group, element)
    public object Value(
   int group,
   int element
)

    Parameters

    group

    The group index of the specified Data Element

    element

    The element index of the specified Data Element

    Return Value

    object
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Value Method / Value(Keyword) Method

The keyword of the DicomAttribute

    Value(Keyword) Method
    In This Topic
    Returns the value of the specified Data Element
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function Value( _
   ByVal Keyword As Keyword _
) As Object
    'Usage

Dim instance As DicomDataSet
Dim Keyword As Keyword
Dim value As Object

value = instance.Value(Keyword)
    public object Value(
   Keyword Keyword
)

    Parameters

    Keyword

    The keyword of the DicomAttribute

    Return Value

    object
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Value Method / Value(String) Method

The String Keyword of the

    Value(String) Method
    In This Topic
    Returns the value of the specified Data Element
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function Value( _
   ByVal Keyword As String _
) As Object
    'Usage

Dim instance As DicomDataSet
Dim Keyword As String
Dim value As Object

value = instance.Value(Keyword)
    public object Value(
   string Keyword
)

    Parameters

    Keyword

    The String Keyword of the

    Return Value

    object
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method

    Write Method
    Writes dataset to an external DICOM file with specified transfer syntax and quality factor
    Overload List
    Overload | Description
Write(String,String,Object) | Writes dataset to an external DICOM file with specified transfer syntax and quality factor
Write(String,String,Object,DicomDataSet) | Writes dataset to an external DICOM file with specified transfer syntax, quality factor and meta header
Write(String,String,Object,DicomDataSet,WriteBehaviours) | Writes dataset to an external DICOM file with specified transfer syntax, quality factor, meta header and behaviour overrides
Write(Stream,String,Object,DicomDataSet,WriteBehaviours) | Writes dataset to a stream with specified transfer syntax, quality factor, meta header and behaviour overrides
Write(String,Boolean) | Writes dataset to an external DICOM file
Write(String,String,DicomDataSet) | Writes dataset to an external DICOM file with specified transfer syntax and meta header
Write(String,String) | Writes dataset to an external DICOM file with specified transfer syntax
Write(String) | Writes dataset to an external DICOM file
Write(String,DicomDataSet) | Writes dataset to an external DICOM file with specified meta header
Write(Stream,String,Object) | Writes dataset to a system IO stream object with specified transfer syntax
Write(Stream,Boolean) | Writes dataset to a system IO stream object
Write(Stream,String) | Writes dataset to a system IO stream object with specified transfer syntax
Write(Stream,String,DicomDataSet) | Writes dataset to a system IO stream object with specified transfer syntax and meta header
Write(Stream) | Writes dataset to a system IO stream object
Write(Byte[],String,Object) | Writes dataset to a byte array with specified transfer syntax and quality factor
Write(Byte[],Boolean) | Writes dataset to a byte array
Write(Byte[],String) | Writes dataset to a byte array with specified transfer syntax
Write(Byte[]) | Writes the dataset to a byte array
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(String,String,Object) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The quality factor to be used.

In This Topic
    Write(String,String,Object) Method
    In This Topic
    Writes dataset to an external DICOM file with specified transfer syntax and quality factor
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object _
)
    'Usage

Dim instance As DicomDataSet
Dim FileName As String
Dim TransferSyntax As String
Dim Quality As Object

instance.Write(FileName, TransferSyntax, Quality)
    public void Write(
   string FileName,
   string TransferSyntax,
   object Quality
)

    Parameters

    FileName

    The name of the file to write.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    Quality

    The quality factor to be used.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(String,String,Object,DicomDataSet) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The quality factor to be used.

The customized MetaHeader (only Group 2 Elements)

In This Topic
    Write(String,String,Object,DicomDataSet) Method
    In This Topic
    Writes dataset to an external DICOM file with specified transfer syntax, quality factor and meta header
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object, _
   ByVal MetaHeader As DicomDataSet _
)
    'Usage

Dim instance As DicomDataSet
Dim FileName As String
Dim TransferSyntax As String
Dim Quality As Object
Dim MetaHeader As DicomDataSet

instance.Write(FileName, TransferSyntax, Quality, MetaHeader)
    public void Write(
   string FileName,
   string TransferSyntax,
   object Quality,
   DicomDataSet MetaHeader
)

    Parameters

    FileName

    The name of the file to write.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    Quality

    The quality factor to be used.

    MetaHeader

    The customized MetaHeader (only Group 2 Elements)

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(String,String,Object,DicomDataSet,WriteBehaviours) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The quality factor to be used.

The customized MetaHeader (only Group 2 Elements)

Specific options to use when writing the data

In This Topic
    Write(String,String,Object,DicomDataSet,WriteBehaviours) Method
    In This Topic
    Writes dataset to an external DICOM file with specified transfer syntax, quality factor, meta header and behaviour overrides
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object, _
   ByVal MetaHeader As DicomDataSet, _
   ByVal Behaviour As WriteBehaviours _
)
    'Usage

Dim instance As DicomDataSet
Dim FileName As String
Dim TransferSyntax As String
Dim Quality As Object
Dim MetaHeader As DicomDataSet
Dim Behaviour As WriteBehaviours

instance.Write(FileName, TransferSyntax, Quality, MetaHeader, Behaviour)
    public void Write(
   string FileName,
   string TransferSyntax,
   object Quality,
   DicomDataSet MetaHeader,
   WriteBehaviours Behaviour
)

    Parameters

    FileName

    The name of the file to write.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    Quality

    The quality factor to be used.

    MetaHeader

    The customized MetaHeader (only Group 2 Elements)

    Behaviour

    Specific options to use when writing the data

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(Stream,String,Object,DicomDataSet,WriteBehaviours) Method

The Stream to which to write.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The quality factor to be used.

The customized MetaHeader (only Group 2 Elements)

Specific options to use when writing the data

In This Topic
    Write(Stream,String,Object,DicomDataSet,WriteBehaviours) Method
    In This Topic
    Writes dataset to a stream with specified transfer syntax, quality factor, meta header and behaviour overrides
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Write( _
   ByVal Stream As Stream, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object, _
   ByVal MetaHeader As DicomDataSet, _
   ByVal Behaviour As WriteBehaviours _
)
    'Usage

Dim instance As DicomDataSet
Dim Stream As Stream
Dim TransferSyntax As String
Dim Quality As Object
Dim MetaHeader As DicomDataSet
Dim Behaviour As WriteBehaviours

instance.Write(Stream, TransferSyntax, Quality, MetaHeader, Behaviour)
    public void Write(
   Stream Stream,
   string TransferSyntax,
   object Quality,
   DicomDataSet MetaHeader,
   WriteBehaviours Behaviour
)

    Parameters

    Stream

    The Stream to which to write.

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    Quality

    The quality factor to be used.

    MetaHeader

    The customized MetaHeader (only Group 2 Elements)

    Behaviour

    Specific options to use when writing the data

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(String,Boolean) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the file, and an appropriate transfer syntax is used, as below.

If FALSE, the file is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

In This Topic
    Write(String,Boolean) Method
    In This Topic
    Writes dataset to an external DICOM file
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal isPart10 As Boolean _
)
    'Usage

Dim instance As DicomDataSet
Dim FileName As String
Dim isPart10 As Boolean

instance.Write(FileName, isPart10)
    public void Write(
   string FileName,
   bool isPart10
)

    Parameters

    FileName

    The name of the file to write.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

    isPart10

    If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the file, and an appropriate transfer syntax is used, as below.

    If FALSE, the file is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(String,String,DicomDataSet) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The customized MetaHeader (only Group 2 Elements)

In This Topic
    Write(String,String,DicomDataSet) Method
    In This Topic
    Writes dataset to an external DICOM file with specified transfer syntax and meta header
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal TransferSyntax As String, _
   ByVal MetaHeader As DicomDataSet _
)
    'Usage

Dim instance As DicomDataSet
Dim FileName As String
Dim TransferSyntax As String
Dim MetaHeader As DicomDataSet

instance.Write(FileName, TransferSyntax, MetaHeader)
    public void Write(
   string FileName,
   string TransferSyntax,
   DicomDataSet MetaHeader
)

    Parameters

    FileName

    The name of the file to write.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    MetaHeader

    The customized MetaHeader (only Group 2 Elements)

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(String,String) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

In This Topic
    Write(String,String) Method
    In This Topic
    Writes dataset to an external DICOM file with specified transfer syntax
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal TransferSyntax As String _
)
    'Usage

Dim instance As DicomDataSet
Dim FileName As String
Dim TransferSyntax As String

instance.Write(FileName, TransferSyntax)
    public void Write(
   string FileName,
   string TransferSyntax
)

    Parameters

    FileName

    The name of the file to write.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(String) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

In This Topic
    Write(String) Method
    In This Topic
    Writes dataset to an external DICOM file
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Write( _
   ByVal FileName As String _
)
    'Usage

Dim instance As DicomDataSet
Dim FileName As String

instance.Write(FileName)
    public void Write(
   string FileName
)

    Parameters

    FileName

    The name of the file to write.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(String,DicomDataSet) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

The customized MetaHeader (only Group 2 Elements)

In This Topic
    Write(String,DicomDataSet) Method
    In This Topic
    Writes dataset to an external DICOM file with specified meta header
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal MetaHeader As DicomDataSet _
)
    'Usage

Dim instance As DicomDataSet
Dim FileName As String
Dim MetaHeader As DicomDataSet

instance.Write(FileName, MetaHeader)
    public void Write(
   string FileName,
   DicomDataSet MetaHeader
)

    Parameters

    FileName

    The name of the file to write.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

    MetaHeader

    The customized MetaHeader (only Group 2 Elements)

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(Stream,String,Object) Method

The Stream from which to read.

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The quality factor to be used.

In This Topic
    Write(Stream,String,Object) Method
    In This Topic
    Writes dataset to a system IO stream object with specified transfer syntax
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Write( _
   ByVal Stream As Stream, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object _
)
    'Usage

Dim instance As DicomDataSet
Dim Stream As Stream
Dim TransferSyntax As String
Dim Quality As Object

instance.Write(Stream, TransferSyntax, Quality)
    public void Write(
   Stream Stream,
   string TransferSyntax,
   object Quality
)

    Parameters

    Stream

    The Stream from which to read.

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    Quality

    The quality factor to be used.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(Stream,Boolean) Method

The Stream from which to read.

If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the stream, and an appropriate transfer syntax is used, as below.

If FALSE, the stream is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

In This Topic
    Write(Stream,Boolean) Method
    In This Topic
    Writes dataset to a system IO stream object
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Write( _
   ByVal Stream As Stream, _
   ByVal isPart10 As Boolean _
)
    'Usage

Dim instance As DicomDataSet
Dim Stream As Stream
Dim isPart10 As Boolean

instance.Write(Stream, isPart10)
    public void Write(
   Stream Stream,
   bool isPart10
)

    Parameters

    Stream

    The Stream from which to read.

    isPart10

    If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the stream, and an appropriate transfer syntax is used, as below.

    If FALSE, the stream is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(Stream,String) Method

The Stream to which to write.

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

In This Topic
    Write(Stream,String) Method
    In This Topic
    Writes dataset to a system IO stream object with specified transfer syntax
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Write( _
   ByVal Stream As Stream, _
   ByVal TransferSyntax As String _
)
    'Usage

Dim instance As DicomDataSet
Dim Stream As Stream
Dim TransferSyntax As String

instance.Write(Stream, TransferSyntax)
    public void Write(
   Stream Stream,
   string TransferSyntax
)

    Parameters

    Stream

    The Stream to which to write.

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(Stream,String,DicomDataSet) Method

The Stream to which to write.

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The customized MetaHeader (only Group 2 Elements)

In This Topic
    Write(Stream,String,DicomDataSet) Method
    In This Topic
    Writes dataset to a system IO stream object with specified transfer syntax and meta header
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Write( _
   ByVal Stream As Stream, _
   ByVal TransferSyntax As String, _
   ByVal MetaHeader As DicomDataSet _
)
    'Usage

Dim instance As DicomDataSet
Dim Stream As Stream
Dim TransferSyntax As String
Dim MetaHeader As DicomDataSet

instance.Write(Stream, TransferSyntax, MetaHeader)
    public void Write(
   Stream Stream,
   string TransferSyntax,
   DicomDataSet MetaHeader
)

    Parameters

    Stream

    The Stream to which to write.

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    MetaHeader

    The customized MetaHeader (only Group 2 Elements)

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(Stream) Method

The Stream to which to write.

In This Topic
    Write(Stream) Method
    In This Topic
    Writes dataset to a system IO stream object
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Write( _
   ByVal Stream As Stream _
)
    'Usage

Dim instance As DicomDataSet
Dim Stream As Stream

instance.Write(Stream)
    public void Write(
   Stream Stream
)

    Parameters

    Stream

    The Stream to which to write.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(Byte[],String,Object) Method

The byte array to write dataset to

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The quality factor to be used

In This Topic
    Write(Byte[],String,Object) Method
    In This Topic
    Writes dataset to a byte array with specified transfer syntax and quality factor
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Write( _
   ByRef Array() As Byte, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object _
)
    'Usage

Dim instance As DicomDataSet
Dim Array() As Byte
Dim TransferSyntax As String
Dim Quality As Object

instance.Write(Array, TransferSyntax, Quality)
    public void Write(
   out byte[] Array,
   string TransferSyntax,
   object Quality
)

    Parameters

    Array

    The byte array to write dataset to

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    Quality

    The quality factor to be used

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(Byte[],Boolean) Method

The byte array to write dataset to

If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the file, and an appropriate transfer syntax is used, as below.

If FALSE, the file is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

In This Topic
    Write(Byte[],Boolean) Method
    In This Topic
    Writes dataset to a byte array
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Write( _
   ByRef Array() As Byte, _
   ByVal isPart10 As Boolean _
)
    'Usage

Dim instance As DicomDataSet
Dim Array() As Byte
Dim isPart10 As Boolean

instance.Write(Array, isPart10)
    public void Write(
   out byte[] Array,
   bool isPart10
)

    Parameters

    Array

    The byte array to write dataset to

    isPart10

    If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the file, and an appropriate transfer syntax is used, as below.

    If FALSE, the file is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(Byte[],String) Method

The byte array to write dataset to

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

In This Topic
    Write(Byte[],String) Method
    In This Topic
    Writes dataset to a byte array with specified transfer syntax
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Write( _
   ByRef Array() As Byte, _
   ByVal TransferSyntax As String _
)
    'Usage

Dim instance As DicomDataSet
Dim Array() As Byte
Dim TransferSyntax As String

instance.Write(Array, TransferSyntax)
    public void Write(
   out byte[] Array,
   string TransferSyntax
)

    Parameters

    Array

    The byte array to write dataset to

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(Byte[]) Method

The byte array to write dataset to

    Write(Byte[]) Method
    In This Topic
    Writes the dataset to a byte array
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Write( _
   ByRef Array() As Byte _
)
    'Usage

Dim instance As DicomDataSet
Dim Array() As Byte

instance.Write(Array)
    public void Write(
   out byte[] Array
)

    Parameters

    Array

    The byte array to write dataset to

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / WriteJson Method
The Stream to write to

    WriteJson Method (DicomDataSet)
    In This Topic
    Write the DICOM data into an Json Stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub WriteJson( _
   ByVal Stream As Stream _
)
    'Usage

Dim instance As DicomDataSet
Dim Stream As Stream

instance.WriteJson(Stream)
    public void WriteJson(
   Stream Stream
)

    Parameters

    Stream
    The Stream to write to
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / WriteXml Method
The Stream to write to

    WriteXml Method
    In This Topic
    Write the DICOM data into an XML Stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub WriteXml( _
   ByVal Stream As Stream _
)
    'Usage

Dim instance As DicomDataSet
Dim Stream As Stream

instance.WriteXml(Stream)
    public void WriteXml(
   Stream Stream
)

    Parameters

    Stream
    The Stream to write to
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomDataSet Class

    DicomDataSet Class Properties
    In This Topic

    For a list of all members of this type, see DicomDataSet members.

    Public Properties
     | Name | Description
Public Property | AccessionNumber | The Accession Number
Public Property | CacheMode | Controls how the pixel data is cached
Public Property | Children | Holds the hierarchical directory structure for DICOM directory files
Public Property | Command | The full command dataset received
Public Property | Count | Number of Attributes held in the DataSet
Public Property | DateOfBirth | Date of birth of the patient
Public Property | Identifer | Returns the underlying DataSet which contains the list of attributes to be matched, as specified in the DICOM standard.
Public Property | InstanceUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Item | Overloaded. Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Public Property | Name | The Name of the patient
Public Property | OriginalTS | Returns the Transfer syntax with which the object was originally received or read.
Public Property | Overrides | Image-specific list of unusual behaviours (e.g. to cope with faulty images)
Public Property | OverrideTS | A means to override an incorrect transfer syntax
Public Property | PatientID | The Patient ID
Public Property | PixelsPerFrame | The number of pixels per frame
Public Property | RawPixels | Accesses the raw pixel data as an array
Public Property | SamplesPerFrame | The number of samples per frame
Public Property | SeriesDescription | Descriptions for the series
Public Property | SeriesUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Sex | Sex of the patient
Public Property | Size |
Public Property | SOPClass | SOP class of the DicomDataSet.
Public Property | StudyDescription | Description for the study
Public Property | StudyUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Tag | A general purpose Tag for developer use
Public Property | UncompressedPI | Gets the Photometric Interpretation of the uncompressed Image data.
Public Property | ValidationDataSet | Assign a Validation DataSet to this property would override the DataSet's Validation scheme. This is mainly used for validation of CharacterSet.
Public Property | ValidationOptions |
    Top
    See Also

    Reference

    DicomDataSet Class
    DicomObjects Namespace


DicomObjects Namespace / DicomDataSet Class / AccessionNumber Property

    AccessionNumber Property
    The Accession Number
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property AccessionNumber As String
    'Usage

Dim instance As DicomDataSet
Dim value As String

instance.AccessionNumber = value

value = instance.AccessionNumber
    public string AccessionNumber {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / CacheMode Property

    CacheMode Property
    Controls how the pixel data is cached
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property CacheMode As CacheTypes
    'Usage

Dim instance As DicomDataSet
Dim value As CacheTypes

instance.CacheMode = value

value = instance.CacheMode
    public CacheTypes CacheMode {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Children Property

    Children Property
    Holds the hierarchical directory structure for DICOM directory files
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Children As DicomDataSetCollection
    'Usage

Dim instance As DicomDataSet
Dim value As DicomDataSetCollection

value = instance.Children
    public DicomDataSetCollection Children {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Command Property

    Command Property (DicomDataSet)
    In This Topic
    The full command dataset received
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Command As DicomDataSet
    'Usage

Dim instance As DicomDataSet
Dim value As DicomDataSet

value = instance.Command
    public DicomDataSet Command {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Count Property

    Count Property
    Number of Attributes held in the DataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Count As Integer
    'Usage

Dim instance As DicomDataSet
Dim value As Integer

value = instance.Count
    public int Count {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / DateOfBirth Property

    DateOfBirth Property (DicomDataSet)
    In This Topic
    Date of birth of the patient
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property DateOfBirth As Date
    'Usage

Dim instance As DicomDataSet
Dim value As Date

instance.DateOfBirth = value

value = instance.DateOfBirth
    public DateTime DateOfBirth {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Identifer Property

    Identifer Property
    Returns the underlying DataSet which contains the list of attributes to be matched, as specified in the DICOM standard.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Identifer As DicomDataSet
    'Usage

Dim instance As DicomDataSet
Dim value As DicomDataSet

value = instance.Identifer
    public DicomDataSet Identifer {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / InstanceUID Property

    InstanceUID Property (DicomDataSet)
    In This Topic
    Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property InstanceUID As String
    'Usage

Dim instance As DicomDataSet
Dim value As String

instance.InstanceUID = value

value = instance.InstanceUID
    public string InstanceUID {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Item Property

    Item Property (DicomDataSet)
    In This Topic
    Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
    Overload List
    Overload | Description
Item(Int32,Int32) | Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Item(Int32) | Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Item(Keyword) | Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Item(String) | Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Item Property / Item(Int32,Int32) Property

The group index of a data element.

The element index of a data element.

In This Topic
    Item(Int32,Int32) Property
    In This Topic
    Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Overridable ReadOnly Property Item( _
   ByVal group As Integer, _
   ByVal element As Integer _
) As DicomAttribute
    'Usage

Dim instance As DicomDataSet
Dim group As Integer
Dim element As Integer
Dim value As DicomAttribute

value = instance.Item(group, element)
    public virtual DicomAttribute Item(
   int group,
   int element
) {get;}

    Parameters

    group

    The group index of a data element.

    element

    The element index of a data element.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Item Property / Item(Int32) Property
The Index of the DicomAttribute

    Item(Int32) Property
    In This Topic
    Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As DicomAttribute
    'Usage

Dim instance As DicomDataSet
Dim index As Integer
Dim value As DicomAttribute

value = instance.Item(index)
    public DicomAttribute Item(
   int index
) {get;}

    Parameters

    index
    The Index of the DicomAttribute
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Item Property / Item(Keyword) Property
The Keyword of the DicomAttribute

    Item(Keyword) Property
    In This Topic
    Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal Keyword As Keyword _
) As DicomAttribute
    'Usage

Dim instance As DicomDataSet
Dim Keyword As Keyword
Dim value As DicomAttribute

value = instance.Item(Keyword)
    public DicomAttribute Item(
   Keyword Keyword
) {get;}

    Parameters

    Keyword
    The Keyword of the DicomAttribute
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Item Property / Item(String) Property
A String containing the of the DicomAttribute

    Item(String) Property
    In This Topic
    Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal Keyword As String _
) As DicomAttribute
    'Usage

Dim instance As DicomDataSet
Dim Keyword As String
Dim value As DicomAttribute

value = instance.Item(Keyword)
    public DicomAttribute Item(
   string Keyword
) {get;}

    Parameters

    Keyword
    A String containing the of the DicomAttribute
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Name Property

    Name Property (DicomDataSet)
    In This Topic
    The Name of the patient
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Name As String
    'Usage

Dim instance As DicomDataSet
Dim value As String

instance.Name = value

value = instance.Name
    public string Name {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / OriginalTS Property

    OriginalTS Property
    Returns the Transfer syntax with which the object was originally received or read.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property OriginalTS As String
    'Usage

Dim instance As DicomDataSet
Dim value As String

value = instance.OriginalTS
    public string OriginalTS {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Overrides Property

    Overrides Property
    Image-specific list of unusual behaviours (e.g. to cope with faulty images)
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Overrides As Dictionary(Of String,Object)
    'Usage

Dim instance As DicomDataSet
Dim value As Dictionary(Of String,Object)

instance.Overrides = value

value = instance.Overrides
    public Dictionary<string,object> Overrides {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / OverrideTS Property

    OverrideTS Property
    A means to override an incorrect transfer syntax
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property OverrideTS As String
    'Usage

Dim instance As DicomDataSet
Dim value As String

instance.OverrideTS = value

value = instance.OverrideTS
    public string OverrideTS {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / PatientID Property

    PatientID Property (DicomDataSet)
    In This Topic
    The Patient ID
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property PatientID As String
    'Usage

Dim instance As DicomDataSet
Dim value As String

instance.PatientID = value

value = instance.PatientID
    public string PatientID {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / PixelsPerFrame Property

    PixelsPerFrame Property
    The number of pixels per frame
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property PixelsPerFrame As Integer
    'Usage

Dim instance As DicomDataSet
Dim value As Integer

value = instance.PixelsPerFrame
    public int PixelsPerFrame {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / RawPixels Property

    RawPixels Property
    Accesses the raw pixel data as an array
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property RawPixels As Array
    'Usage

Dim instance As DicomDataSet
Dim value As Array

instance.RawPixels = value

value = instance.RawPixels
    public Array RawPixels {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / SamplesPerFrame Property

    SamplesPerFrame Property
    The number of samples per frame
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property SamplesPerFrame As Integer
    'Usage

Dim instance As DicomDataSet
Dim value As Integer

value = instance.SamplesPerFrame
    public int SamplesPerFrame {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / SeriesDescription Property

    SeriesDescription Property
    Descriptions for the series
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property SeriesDescription As String
    'Usage

Dim instance As DicomDataSet
Dim value As String

instance.SeriesDescription = value

value = instance.SeriesDescription
    public string SeriesDescription {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / SeriesUID Property

    SeriesUID Property (DicomDataSet)
    In This Topic
    Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property SeriesUID As String
    'Usage

Dim instance As DicomDataSet
Dim value As String

instance.SeriesUID = value

value = instance.SeriesUID
    public string SeriesUID {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Sex Property

    Sex Property (DicomDataSet)
    In This Topic
    Sex of the patient
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Sex As String
    'Usage

Dim instance As DicomDataSet
Dim value As String

instance.Sex = value

value = instance.Sex
    public string Sex {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Size Property

    Size Property (DicomDataSet)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Size As Size
    'Usage

Dim instance As DicomDataSet
Dim value As Size

value = instance.Size
    public Size Size {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / SOPClass Property

    SOPClass Property
    SOP class of the DicomDataSet.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property SOPClass As String
    'Usage

Dim instance As DicomDataSet
Dim value As String

instance.SOPClass = value

value = instance.SOPClass
    public string SOPClass {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / StudyDescription Property

    StudyDescription Property
    Description for the study
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property StudyDescription As String
    'Usage

Dim instance As DicomDataSet
Dim value As String

instance.StudyDescription = value

value = instance.StudyDescription
    public string StudyDescription {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / StudyUID Property

    StudyUID Property (DicomDataSet)
    In This Topic
    Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property StudyUID As String
    'Usage

Dim instance As DicomDataSet
Dim value As String

instance.StudyUID = value

value = instance.StudyUID
    public string StudyUID {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Tag Property

    Tag Property (DicomDataSet)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Tag As Object
    'Usage

Dim instance As DicomDataSet
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / UncompressedPI Property

    UncompressedPI Property
    Gets the Photometric Interpretation of the uncompressed Image data.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property UncompressedPI As String
    'Usage

Dim instance As DicomDataSet
Dim value As String

value = instance.UncompressedPI
    public string UncompressedPI {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / ValidationDataSet Property

    ValidationDataSet Property
    Assign a Validation DataSet to this property would override the DataSet's Validation scheme. This is mainly used for validation of CharacterSet.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property ValidationDataSet As DicomDataSet
    'Usage

Dim instance As DicomDataSet
Dim value As DicomDataSet

instance.ValidationDataSet = value

value = instance.ValidationDataSet
    public DicomDataSet ValidationDataSet {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / ValidationOptions Property

    ValidationOptions Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property ValidationOptions As ValidationOptions
    'Usage

Dim instance As DicomDataSet
Dim value As ValidationOptions

instance.ValidationOptions = value

value = instance.ValidationOptions
    public ValidationOptions ValidationOptions {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


%%PageItemTitle%% $$Fields$$

DicomObjects Namespace / DicomDataSet Class

    DicomDataSet Class Fields
    In This Topic

    For a list of all members of this type, see DicomDataSet members.

    Public Fields
     | Name | Description
Public Field | CompressedFrameStream | User-defined function to set output stream for compressed frame. This is suitable for writing out large compressed frames with Basic Offset Table.
    Top
    See Also

    Reference

    DicomDataSet Class
    DicomObjects Namespace


DicomObjects Namespace / DicomDataSet Class / CompressedFrameStream Field

    CompressedFrameStream Field
    User-defined function to set output stream for compressed frame. This is suitable for writing out large compressed frames with Basic Offset Table.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public CompressedFrameStream As Func(Of Integer,Stream)
    'Usage

Dim instance As DicomDataSet
Dim value As Func(Of Integer,Stream)

value = instance.CompressedFrameStream

instance.CompressedFrameStream = value
    public Func<int,Stream> CompressedFrameStream
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


%%PageItemTitle%%

DicomObjects Namespace / DicomDataSetCollection Class
Members

In This Topic
    DicomDataSetCollection Class
    In This Topic
    A collection of DicomDataSet objects
    Object Model
    DicomDataSetCollection ClassDicomDataSet Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

<DefaultMemberAttribute("Item")>
<DebuggerTypeProxyAttribute(System.Collections.Generic.ICollectionDebugView`1)>
<DebuggerDisplayAttribute("Count = {Count}")>
Public Class DicomDataSetCollection
   Inherits System.Collections.ObjectModel.Collection(Of DicomDataSet)
    'Usage

Dim instance As DicomDataSetCollection
    [DefaultMember("Item")]
[DebuggerTypeProxy(System.Collections.Generic.ICollectionDebugView`1)]
[DebuggerDisplay("Count = {Count}")]
public class DicomDataSetCollection : System.Collections.ObjectModel.Collection<DicomDataSet>
    Inheritance Hierarchy

    System.Object
    System.Collections.ObjectModel.Collection<T>
    DicomObjects.DicomDataSetCollection

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomDataSetCollection Class
Properties Methods

In This Topic
    DicomDataSetCollection Class Members
    In This Topic

    The following tables list the members exposed by DicomDataSetCollection.

    Public Constructors
     | Name | Description
Public Constructor | DicomDataSetCollection Constructor | Creates a DicomDataSetCollection object
    Top
    Public Properties
     | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Property | Item | Overloaded. Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Public Property | SopUIDList | Contains a list of SOP Class UIDs for all DataSet items contained in this Collection
Public Property | SyncRoot |
Public Property | Tag | A general purpose Tag for developer use
    Top
    Public Methods
     | Name | Description
Public Method | Add | Overloaded. Adds a DicomDataSetCollection to a DicomDataSetCollection
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Clone | Overloaded. Returns a copy of the DicomDataSetCollection
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Dispose | Release all resources used by DicomDataSetCollection
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | MakeKOS | Make DICOM Key Object Note object from a collection of DicomDataSets. The first DicomDataSet object in the collection will be used as the primary data for KOS content. If multiple Studies are present in the collection, each Study will be added as a new Current Requested Procedure Evidence Sequence item. All Referenced Instance(s) will be added to the Content Sequence.
Public Method | Read | Overloaded. Creates and adds a DicomDataSet from an external DICOM File, a byte array, or a file stream. Or Creates and adds a collection of DicomDataSet objects from an array of external DICOM files
Public Method | ReadJson | Read DICOM data from a JSON Stream
Public Method | Remove | Overloaded. Removes DicomDataSet from a DicomDataSetCollectionby matching its InstanceUID
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Send | Sends all DataSets within the collection in one association
Public Method | WriteJson | Write DICOM data to a JSON Stream
    Top
    See Also

    Reference

    DicomDataSetCollection Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / DicomDataSetCollection Class / DicomDataSetCollection Constructor

In This Topic
    DicomDataSetCollection Constructor
    In This Topic
    Creates a DicomDataSetCollection object
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New()
    'Usage

Dim instance As New DicomDataSetCollection()
    public DicomDataSetCollection()

    Return Value

    DicomDataSetCollection
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomDataSetCollection Class

    DicomDataSetCollection Class Methods
    In This Topic

    For a list of all members of this type, see DicomDataSetCollection members.

    Public Methods
     | Name | Description
Public Method | Add | Overloaded. Adds a DicomDataSetCollection to a DicomDataSetCollection
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Clone | Overloaded. Returns a copy of the DicomDataSetCollection
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Dispose | Release all resources used by DicomDataSetCollection
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | MakeKOS | Make DICOM Key Object Note object from a collection of DicomDataSets. The first DicomDataSet object in the collection will be used as the primary data for KOS content. If multiple Studies are present in the collection, each Study will be added as a new Current Requested Procedure Evidence Sequence item. All Referenced Instance(s) will be added to the Content Sequence.
Public Method | Read | Overloaded. Creates and adds a DicomDataSet from an external DICOM File, a byte array, or a file stream. Or Creates and adds a collection of DicomDataSet objects from an array of external DICOM files
Public Method | ReadJson | Read DICOM data from a JSON Stream
Public Method | Remove | Overloaded. Removes DicomDataSet from a DicomDataSetCollectionby matching its InstanceUID
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Send | Sends all DataSets within the collection in one association
Public Method | WriteJson | Write DICOM data to a JSON Stream
    Top
    See Also

    Reference

    DicomDataSetCollection Class
    DicomObjects Namespace


DicomObjects Namespace / DicomDataSetCollection Class / Add Method

    Add Method (DicomDataSetCollection)
    In This Topic
    Adds a DicomDataSetCollection to a DicomDataSetCollection
    Overload List
    Overload | Description
Add(IEnumerable<DicomDataSet>) | Adds a DicomDataSetCollection to a DicomDataSetCollection
Add(DicomDataSet) | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


DicomObjects Namespace / DicomDataSetCollection Class / Add Method / Add(IEnumerable<DicomDataSet>) Method

Collection of DicomDataSets to be added

    Add(IEnumerable<DicomDataSet>) Method
    In This Topic
    Adds a DicomDataSetCollection to a DicomDataSetCollection
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Add( _
   ByVal value As IEnumerable(Of DicomDataSet) _
)
    'Usage

Dim instance As DicomDataSetCollection
Dim value As IEnumerable(Of DicomDataSet)

instance.Add(value)
    public void Add(
   IEnumerable<DicomDataSet> value
)

    Parameters

    value

    Collection of DicomDataSets to be added

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members
    Overload List


DicomObjects Namespace / DicomDataSetCollection Class / Clone Method

    Clone Method (DicomDataSetCollection)
    In This Topic
    Returns a copy of the DicomDataSetCollection
    Overload List
    Overload | Description
Clone(Boolean) | Returns a copy of the DicomDataSetCollection
Clone() | Returns a copy of the DicomDataSetCollection
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


DicomObjects Namespace / DicomDataSetCollection Class / Clone Method / Clone(Boolean) Method

Boolean value, if true then returns a Deep copy of the DicomDataSetCollection.

If false, returns a Shallow copy.

In This Topic
    Clone(Boolean) Method
    In This Topic
    Returns a copy of the DicomDataSetCollection
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Overridable Function Clone( _
   ByVal Deep As Boolean _
) As Object
    'Usage

Dim instance As DicomDataSetCollection
Dim Deep As Boolean
Dim value As Object

value = instance.Clone(Deep)
    public virtual object Clone(
   bool Deep
)

    Parameters

    Deep

    Boolean value, if true then returns a Deep copy of the DicomDataSetCollection.

    If false, returns a Shallow copy.

    Return Value

    DicomDataSetCollection
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members
    Overload List


DicomObjects Namespace / DicomDataSetCollection Class / Clone Method / Clone() Method

    Clone() Method
    Returns a copy of the DicomDataSetCollection
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Overridable Function Clone() As Object
    'Usage

Dim instance As DicomDataSetCollection
Dim value As Object

value = instance.Clone()
    public virtual object Clone()

    Return Value

    DicomDataSetCollection
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members
    Overload List


DicomObjects Namespace / DicomDataSetCollection Class / Dispose Method

    Dispose Method (DicomDataSetCollection)
    In This Topic
    Release all resources used by DicomDataSetCollection
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub Dispose()
    'Usage

Dim instance As DicomDataSetCollection

instance.Dispose()
    public void Dispose()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


DicomObjects Namespace / DicomDataSetCollection Class / MakeKOS Method
The location UID of each referenced Series where Instances can be retreived
Name of the Application Entity Title of where the referenced Instances can be retrieved

In This Topic
    MakeKOS Method
    In This Topic
    Make DICOM Key Object Note object from a collection of DicomDataSets. The first DicomDataSet object in the collection will be used as the primary data for KOS content. If multiple Studies are present in the collection, each Study will be added as a new Current Requested Procedure Evidence Sequence item. All Referenced Instance(s) will be added to the Content Sequence.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function MakeKOS( _
   ByVal RetrieveLocationUID As String, _
   ByVal RetrieveAET As String _
) As DicomDataSet
    'Usage

Dim instance As DicomDataSetCollection
Dim RetrieveLocationUID As String
Dim RetrieveAET As String
Dim value As DicomDataSet

value = instance.MakeKOS(RetrieveLocationUID, RetrieveAET)
    public DicomDataSet MakeKOS(
   string RetrieveLocationUID,
   string RetrieveAET
)

    Parameters

    RetrieveLocationUID
    The location UID of each referenced Series where Instances can be retreived
    RetrieveAET
    Name of the Application Entity Title of where the referenced Instances can be retrieved
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


DicomObjects Namespace / DicomDataSetCollection Class / Read Method

    Read Method (DicomDataSetCollection)
    In This Topic
    Creates and adds a DicomDataSet from an external DICOM File, a byte array, or a file stream. Or Creates and adds a collection of DicomDataSet objects from an array of external DICOM files
    Overload List
    Overload | Description
Read(String) | Creates and adds a DicomDataSet from an external DICOM File, a byte array, or a file stream. Or Creates and adds a collection of DicomDataSet objects from an array of external DICOM files
Read(Byte[]) | Creates and adds a DicomDataSet from a byte array
Read(IEnumerable<String>) | Creates and adds a DicomDataSet from an external DICOM File, a byte array, or a file stream. Or Creates and adds a collection of DicomDataSet objects from an array of external DICOM files
Read(Stream) | Creates and adds a DicomDataSet from an external DICOM File, a byte array, or a file stream. Or Creates and adds a collection of DicomDataSet objects from an array of external DICOM files
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


DicomObjects Namespace / DicomDataSetCollection Class / Read Method / Read(String) Method

    Read(String) Method
    Creates and adds a DicomDataSet from an external DICOM File, a byte array, or a file stream. Or Creates and adds a collection of DicomDataSet objects from an array of external DICOM files
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function Read( _
   ByVal FileName As String _
) As DicomDataSet
    'Usage

Dim instance As DicomDataSetCollection
Dim FileName As String
Dim value As DicomDataSet

value = instance.Read(FileName)
    public DicomDataSet Read(
   string FileName
)

    Parameters

    FileName
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members
    Overload List


DicomObjects Namespace / DicomDataSetCollection Class / Read Method / Read(Byte[]) Method

Array as Byte Array:

The Byte Array to read

In This Topic
    Read(Byte[]) Method
    In This Topic
    Creates and adds a DicomDataSet from a byte array
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function Read( _
   ByVal Array() As Byte _
) As DicomDataSet
    'Usage

Dim instance As DicomDataSetCollection
Dim Array() As Byte
Dim value As DicomDataSet

value = instance.Read(Array)
    public DicomDataSet Read(
   byte[] Array
)

    Parameters

    Array

    Array as Byte Array:

    The Byte Array to read

    Return Value

    DicomDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members
    Overload List


DicomObjects Namespace / DicomDataSetCollection Class / Read Method / Read(IEnumerable<String>) Method

    Read(IEnumerable<String>) Method
    Creates and adds a DicomDataSet from an external DICOM File, a byte array, or a file stream. Or Creates and adds a collection of DicomDataSet objects from an array of external DICOM files
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function Read( _
   ByVal FileNames As IEnumerable(Of String) _
) As DicomDataSetCollection
    'Usage

Dim instance As DicomDataSetCollection
Dim FileNames As IEnumerable(Of String)
Dim value As DicomDataSetCollection

value = instance.Read(FileNames)
    public DicomDataSetCollection Read(
   IEnumerable<string> FileNames
)

    Parameters

    FileNames
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members
    Overload List


DicomObjects Namespace / DicomDataSetCollection Class / Read Method / Read(Stream) Method

    Read(Stream) Method
    Creates and adds a DicomDataSet from an external DICOM File, a byte array, or a file stream. Or Creates and adds a collection of DicomDataSet objects from an array of external DICOM files
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function Read( _
   ByVal Stream As Stream _
) As DicomDataSet
    'Usage

Dim instance As DicomDataSetCollection
Dim Stream As Stream
Dim value As DicomDataSet

value = instance.Read(Stream)
    public DicomDataSet Read(
   Stream Stream
)

    Parameters

    Stream
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members
    Overload List


DicomObjects Namespace / DicomDataSetCollection Class / ReadJson Method
The Stream to read from
The transfer syntax to assign to the resulting instances - see remarks

In This Topic
    ReadJson Method (DicomDataSetCollection)
    In This Topic
    Read DICOM data from a JSON Stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub ReadJson( _
   ByVal Stream As Stream, _
   Optional ByVal TransferSyntax As String _
)
    'Usage

Dim instance As DicomDataSetCollection
Dim Stream As Stream
Dim TransferSyntax As String

instance.ReadJson(Stream, TransferSyntax)
    public void ReadJson(
   Stream Stream,
   string TransferSyntax
)

    Parameters

    Stream
    The Stream to read from
    TransferSyntax
    The transfer syntax to assign to the resulting instances - see remarks
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


DicomObjects Namespace / DicomDataSetCollection Class / Remove Method

    Remove Method (DicomDataSetCollection)
    In This Topic
    Removes DicomDataSet from a DicomDataSetCollectionby matching its InstanceUID
    Overload List
    Overload | Description
Remove(String) | Removes DicomDataSet from a DicomDataSetCollectionby matching its InstanceUID
Remove(DicomDataSet) | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


DicomObjects Namespace / DicomDataSetCollection Class / Remove Method / Remove(String) Method

The InstanceUID of the DicomDataSet to be removed from the DicomDataSetCollection

In This Topic
    Remove(String) Method
    In This Topic
    Removes DicomDataSet from a DicomDataSetCollectionby matching its InstanceUID
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Remove( _
   ByVal InstanceUID As String _
)
    'Usage

Dim instance As DicomDataSetCollection
Dim InstanceUID As String

instance.Remove(InstanceUID)
    public void Remove(
   string InstanceUID
)

    Parameters

    InstanceUID

    The InstanceUID of the DicomDataSet to be removed from the DicomDataSetCollection

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members
    Overload List


DicomObjects Namespace / DicomDataSetCollection Class / Send Method
String value, the IP address
Integer value, the port number
String value, the calling application entity title
String value, the called application entity title

In This Topic
    Send Method (DicomDataSetCollection)
    In This Topic
    Sends all DataSets within the collection in one association
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function Send( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAE As String, _
   ByVal CalledAE As String _
) As Integer()
    'Usage

Dim instance As DicomDataSetCollection
Dim Node As String
Dim Port As Integer
Dim CallingAE As String
Dim CalledAE As String
Dim value() As Integer

value = instance.Send(Node, Port, CallingAE, CalledAE)
    public int[] Send(
   string Node,
   int Port,
   string CallingAE,
   string CalledAE
)

    Parameters

    Node
    String value, the IP address
    Port
    Integer value, the port number
    CallingAE
    String value, the calling application entity title
    CalledAE
    String value, the called application entity title

    Return Value

    int Array, as status of each image transfer
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


DicomObjects Namespace / DicomDataSetCollection Class / WriteJson Method
The Stream to write to

    WriteJson Method (DicomDataSetCollection)
    In This Topic
    Write DICOM data to a JSON Stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub WriteJson( _
   ByVal Stream As Stream _
)
    'Usage

Dim instance As DicomDataSetCollection
Dim Stream As Stream

instance.WriteJson(Stream)
    public void WriteJson(
   Stream Stream
)

    Parameters

    Stream
    The Stream to write to
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomDataSetCollection Class

    DicomDataSetCollection Class Properties
    In This Topic

    For a list of all members of this type, see DicomDataSetCollection members.

    Public Properties
     | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Property | Item | Overloaded. Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Public Property | SopUIDList | Contains a list of SOP Class UIDs for all DataSet items contained in this Collection
Public Property | SyncRoot |
Public Property | Tag | A general purpose Tag for developer use
    Top
    See Also

    Reference

    DicomDataSetCollection Class
    DicomObjects Namespace


DicomObjects Namespace / DicomDataSetCollection Class / Item Property

    Item Property (DicomDataSetCollection)
    In This Topic
    Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
    Overload List
    Overload | Description
Item(String) | Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
Item(Int32) | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


DicomObjects Namespace / DicomDataSetCollection Class / Item Property / Item(String) Property

String, the Instance UID of the DicomDataSet

    Item(String) Property
    In This Topic
    Note: C# syntax for the "Item" property is wrongly represented in a VB.NET syntax. This is a bug in the help file generator, and will be corrected in a later version of our help file.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal InstanceUID As String _
) As DicomDataSet
    'Usage

Dim instance As DicomDataSetCollection
Dim InstanceUID As String
Dim value As DicomDataSet

value = instance.Item(InstanceUID)
    public DicomDataSet Item(
   string InstanceUID
) {get;}

    Parameters

    InstanceUID

    String, the Instance UID of the DicomDataSet

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members
    Overload List


DicomObjects Namespace / DicomDataSetCollection Class / SopUIDList Property

    SopUIDList Property
    Contains a list of SOP Class UIDs for all DataSet items contained in this Collection
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property SopUIDList As String()
    'Usage

Dim instance As DicomDataSetCollection
Dim value() As String

value = instance.SopUIDList
    public string[] SopUIDList {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


DicomObjects Namespace / DicomDataSetCollection Class / SyncRoot Property

    SyncRoot Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property SyncRoot As Object
    'Usage

Dim instance As DicomDataSetCollection
Dim value As Object

value = instance.SyncRoot
    public object SyncRoot {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


DicomObjects Namespace / DicomDataSetCollection Class / Tag Property

    Tag Property (DicomDataSetCollection)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Tag As Object
    'Usage

Dim instance As DicomDataSetCollection
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


%%PageItemTitle%%

DicomObjects Namespace / DicomException Class
Members

In This Topic
    DicomException Class
    In This Topic
    Specific Exception for DICOM errors
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class DicomException
   Inherits System.Exception
    'Usage

Dim instance As DicomException
    public class DicomException : System.Exception
    Inheritance Hierarchy

    System.Object
    System.Exception
    DicomObjects.DicomException
    DicomObjects.Validation.ValidationException

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomException Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomException Class
Properties Methods

In This Topic
    DicomException Class Members
    In This Topic

    The following tables list the members exposed by DicomException.

    Public Constructors
     | Name | Description
Public Constructor | DicomException Constructor | Overloaded.
    Top
    Public Properties
     | Name | Description
Public Property | CausedAbort | True if this exception caused the related to association to issue an Abort (thereby no longer requiring to be closed)
Public Property | Code | The Error code
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | Tag | A general purpose Tag for developer use
Public Property | TargetSite | (Inherited from System.Exception)
    Top
    Public Methods
     | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
    Top
    See Also

    Reference

    DicomException Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / DicomException Class / DicomException Constructor

In This Topic
    DicomException Constructor
    In This Topic
    Overload List
    Overload | Description
DicomException Constructor(Int32) | Create a new DicomException
DicomException Constructor(Int32,String) | Create a new DicomException
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomException Class
    DicomException Members


%%PageItemTitle%%

DicomObjects Namespace / DicomException Class / DicomException Constructor / DicomException Constructor(Int32)
The DicomObjects error code

In This Topic
    DicomException Constructor(Int32)
    In This Topic
    Create a new DicomException
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New( _
   ByVal code As Integer _
)
    'Usage

Dim code As Integer

Dim instance As New DicomException(code)
    public DicomException(
   int code
)

    Parameters

    code
    The DicomObjects error code
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomException Class
    DicomException Members
    Overload List


%%PageItemTitle%%

DicomObjects Namespace / DicomException Class / DicomException Constructor / DicomException Constructor(Int32,String)
Error code
Associated string to be inserted

In This Topic
    DicomException Constructor(Int32,String)
    In This Topic
    Create a new DicomException
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New( _
   ByVal code As Integer, _
   ByVal val As String _
)
    'Usage

Dim code As Integer
Dim val As String

Dim instance As New DicomException(code, val)
    public DicomException(
   int code,
   string val
)

    Parameters

    code
    Error code
    val
    Associated string to be inserted
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomException Class
    DicomException Members
    Overload List


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomException Class

    DicomException Class Properties
    In This Topic

    For a list of all members of this type, see DicomException members.

    Public Properties
     | Name | Description
Public Property | CausedAbort | True if this exception caused the related to association to issue an Abort (thereby no longer requiring to be closed)
Public Property | Code | The Error code
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | Tag | A general purpose Tag for developer use
Public Property | TargetSite | (Inherited from System.Exception)
    Top
    See Also

    Reference

    DicomException Class
    DicomObjects Namespace


DicomObjects Namespace / DicomException Class / CausedAbort Property

    CausedAbort Property
    True if this exception caused the related to association to issue an Abort (thereby no longer requiring to be closed)
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property CausedAbort As Boolean
    'Usage

Dim instance As DicomException
Dim value As Boolean

value = instance.CausedAbort
    public bool CausedAbort {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomException Class
    DicomException Members


DicomObjects Namespace / DicomException Class / Code Property

    Code Property
    The Error code
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Code As Integer
    'Usage

Dim instance As DicomException
Dim value As Integer

value = instance.Code
    public int Code {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomException Class
    DicomException Members


DicomObjects Namespace / DicomException Class / Tag Property

    Tag Property (DicomException)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Tag As Object
    'Usage

Dim instance As DicomException
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomException Class
    DicomException Members


%%PageItemTitle%%

DicomObjects Namespace / DicomGlobal Class
Members

In This Topic
    DicomGlobal Class
    In This Topic
    Placeholder for various static methods and properties
    Object Model
    DicomGlobal ClassReadBehaviours ClassWriteBehaviours Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MustInherit NotInheritable Class DicomGlobal
    'Usage

Dim instance As DicomGlobal
    public static class DicomGlobal
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomGlobal

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomGlobal Class
Properties Methods Events

In This Topic
    DicomGlobal Class Members
    In This Topic

    The following tables list the members exposed by DicomGlobal.

    Public Properties
     | Name | Description
static (Shared in Visual Basic) | AssemblyDirectory | Returns the Assembly Directory information
static (Shared in Visual Basic) | AssemblyVersion | Gets the Assembly Version of DicomObjects.NET
static (Shared in Visual Basic) | Assume2022Escapes | Controls whether DicomObjects attempts to locate unannounced 2022 escape sequences
static (Shared in Visual Basic) | ChangeLossyUIDs | Controls whether DicomObjects changes the UID when doing lossy compression
static (Shared in Visual Basic) | CloseFilesAfterReading | Controls how pixel data is read from disk
static (Shared in Visual Basic) | ColourConverter | Interface to allow override of the default CIELab <=> RGB conversion
static (Shared in Visual Basic) | CombinePDVs | Controls whether to combine outgoing command and data PDVs into a single PDU
static (Shared in Visual Basic) | CurrentLogFileName | Returns the Current DicomObjects Log File Name in full.
static (Shared in Visual Basic) | DefaultCharacterSet | Default Character to set to use if 0008,0005 is absent
static (Shared in Visual Basic) | DefaultFFmpegFilter | Description of the Default filter to apply for FFmpeg processing
static (Shared in Visual Basic) | DefaultIpAddressFamily | The IP Address family to be used where not otherwise specified
static (Shared in Visual Basic) | DefaultReadBehaviour | Default behaviour when reading or receiving files
static (Shared in Visual Basic) | DefaultSOPClasses | Default list of SOP class UID's (Abstract syntaxes) to be used until specifically overridden by user settings
static (Shared in Visual Basic) | DefaultWriteBehaviour | Default behaviour when writing or sending files
static (Shared in Visual Basic) | DeidentifyInLog | A list of keywords fo attributes which should not be included in any standard log file.
static (Shared in Visual Basic) | DirectionStrings | Language specific indicators for anatomic labelling
static (Shared in Visual Basic) | DisplayCacheTime | Controls how long display cache copies of images are retained.
static (Shared in Visual Basic) | Enable10BitDisplay | To allows support for 10bit data.
static (Shared in Visual Basic) | EventLogLevel | Controls the logging of diagnostic message to the event.
static (Shared in Visual Basic) | FailOnSuspiciousPreamble | Detect any non-zero data in the preamble (the first 128 bytes) leading to 'DICM', and alert if any unwanted bytes or malicious code is present. A pre-defined list of file formats is used for checking against the non-zero preamble This mainly affects data with such preamble when reading it in. Writing to disk or sending using DICOM protocol would remove existing preamble (effectively cleaning any malicious preamble) and recreate it when written to disk on the receiving side
static (Shared in Visual Basic) | FileVersion | Gets the File Version of DicomObjects.NET
static (Shared in Visual Basic) | FlushLevel | A level to cause the log to be flushed to disk
static (Shared in Visual Basic) | FontScaling | The factor by which to increase the font size when using DirectX display mode. The default is 1.5, which gives appearance similar to those in GDI mode.
static (Shared in Visual Basic) | ImplementationName | The Implementation Name of this application
static (Shared in Visual Basic) | ImplementationUID | The Implementation UID of this application
static (Shared in Visual Basic) | IndentJson | Controls whether JSON generated is indented and formatted for easy human interpretation
static (Shared in Visual Basic) | JpipInitialSize |
static (Shared in Visual Basic) | LockGdiOperations | Controls whether to use an explicit lock to prevent recurrent GDI operations from happening
static (Shared in Visual Basic) | LogLicenceDetails |
static (Shared in Visual Basic) | MaximumDateTime | Control the global MaximumDateTime value used by DicomObjects. Default value is DateTime.MaxValue
static (Shared in Visual Basic) | MaximumPDUSize | The Maximum PDU size accepted and used by DicomObjects
static (Shared in Visual Basic) | MinFontSize | Contains the Minimum Font Size used when drawing Text Label.
static (Shared in Visual Basic) | MinimumDateTime | Control the global MinimumDateTime value used by DicomObjects. Default value is DateTime.MinValue
static (Shared in Visual Basic) | MoveTimesOut | Controls whether DicomObjects will time out during a C-MOVE operation
static (Shared in Visual Basic) | PreambleFileSignatures | A pre-defined modifiable list of file signatures to match against the preamble if is enabled
static (Shared in Visual Basic) | PreferredBitmapMode | Controls method of rendering used by "Bitmap"
static (Shared in Visual Basic) | PreserveDoublePrecision | Retain precision for double numbers
static (Shared in Visual Basic) | ProductName | The product name to be shown in licensing Dialogs etc. Default value is "DicomObjects".
static (Shared in Visual Basic) | QuadrupedDirectionStrings | The quadruped equivalent of DirectionStrings allowing localisation of these abbreviations
static (Shared in Visual Basic) | RenderException | Controls whether non-image objects throw an exception during rendering
static (Shared in Visual Basic) | ReUseArrays | Controls whether DicomObjcts re-uses arrays to hold pixel data
static (Shared in Visual Basic) | ReuseOnlyExactArraySize | Controls whether "Over-sized" arrays are used
static (Shared in Visual Basic) | RunningInDocker |
static (Shared in Visual Basic) | ShowTextBoxForPresentationStates | Controls whether bounding boxes are drawn around internally generated DicomLabel objects derived from text entries in Presentation States
static (Shared in Visual Basic) | SignedLicencePrefix |
static (Shared in Visual Basic) | ThreadCount | Controls how many threads may be used by DicomObjects when rendering etc.
static (Shared in Visual Basic) | Timeout | The period of time that a network operation will wait if there is no response from the peer
static (Shared in Visual Basic) | UIDRoot | UIDRoot used by the method
static (Shared in Visual Basic) | Use32BitTexture |
static (Shared in Visual Basic) | UsePerformanceCounters | Controls use of specific performance counters for DicomObjects
static (Shared in Visual Basic) | UsePixelCache | Controls whether to use an area of memory as a pixel cache to reduce demands on the memory allocator
static (Shared in Visual Basic) | ValidDateMax | Maximum allowed DateTime for validation purposes Default value is DateTime.MaxValue
static (Shared in Visual Basic) | ValidDateMin | Minimum allowed DateTime for validation purposes Default value is DateTime.MinValue
    Top
    Public Methods
     | Name | Description
static (Shared in Visual Basic) | AcceptedTransferSyntaxes | List of Transfer Syntaxes accepted by default for a group of SOP classes
static (Shared in Visual Basic) | AddDictionaryElement | Adds Data Element to the Dictionary.
static (Shared in Visual Basic) | AddPrivateDictionaryElement | Adds Private Data Element to the Dictionary.
static (Shared in Visual Basic) | AddToAcceptedTransferSyntaxes |
static (Shared in Visual Basic) | AddToOfferedTransferSyntaxes |
static (Shared in Visual Basic) | AddToSOPClassGroup |
static (Shared in Visual Basic) | ClearAcceptedTransferSyntaxes | Clear all accepted Transfer Syntaxes from a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | ClearOfferedTransferSyntaxes | Clear all offered Transfer Syntaxes from a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | ClearSOPClassGroup | Clear all SOP classes from a group used to help control use of associated transfer syntaxes
static (Shared in Visual Basic) | Echo | Sends a DICOM verify (C-ECHO), with IP address, port number, callingAET, calledAET to another application entity, and returns the result
static (Shared in Visual Basic) | FindGroup | Find to which group a particular SOP class is currently assigned
static (Shared in Visual Basic) | GetRegString | Overloaded. Returns the value of a cached key with default value
static (Shared in Visual Basic) | GetRegWord | Overloaded. Returns the value of a cached key with default value
static (Shared in Visual Basic) | GetStatusCodeType | Checks if status code is a defined error code
static (Shared in Visual Basic) | GuidToUID | Construct a DICOM UID from Universally Unique Identifier (GUID) based on the method defined in ISO/IEC 9834-8 / ITU-T X.667
static (Shared in Visual Basic) | IgnoreAttribute | Instruct DicomObjects to ignore particular attributes
static (Shared in Visual Basic) | IsDICOM | Overloaded. A very simple method to test whether a stream contains valid DICOM
static (Shared in Visual Basic) | IsEncrypted | Tests whether a DICOM file is encrypted according the CMS encoding defined in DICOM supplement 895
static (Shared in Visual Basic) | Keyword | Overloaded. Construct a keyword from arbitrary group and element values
static (Shared in Visual Basic) | KeywordElement |
static (Shared in Visual Basic) | KeywordGroup |
static (Shared in Visual Basic) | KeywordTag |
static (Shared in Visual Basic) | LoadConfigFile | Forces loading of the XML configuration file
static (Shared in Visual Basic) | Log | Add text to the log file.
static (Shared in Visual Basic) | LogToFile | Overloaded. Enables DicomObjects logging, specifies where DicomObjects log files appear, what the logging level is and the timer interval when new log file should be generated.
static (Shared in Visual Basic) | LogToFileStop | Stop logging to the currently active file
static (Shared in Visual Basic) | LogToLogger |
static (Shared in Visual Basic) | LogToStream | Enables DicomObjects logging to a user provided stream
static (Shared in Visual Basic) | MakeDictionary | Create a Dataset containing a null copy of all 'known' possible attributes
static (Shared in Visual Basic) | NewUID | Generates a guaranteed unique valid DICOM UID
static (Shared in Visual Basic) | OfferedTransferSyntaxes | List of Transfer Syntaxes offered by default for a group of SOP classes
static (Shared in Visual Basic) | RemoveFromAcceptedTransferSyntaxes |
static (Shared in Visual Basic) | RemoveFromOfferedTransferSyntaxes |
static (Shared in Visual Basic) | RemoveFromSOPClassGroup |
static (Shared in Visual Basic) | ResetPixelCache | Clear any existing pixel cache
static (Shared in Visual Basic) | SetRegString | Insert or replace values in the internal virtual registry
static (Shared in Visual Basic) | SetRegWord | Sets key values in the internal look up table
static (Shared in Visual Basic) | SOPClassGroup | Groups of SOP classes that use the same default Transfer Syntaxes
static (Shared in Visual Basic) | Zoom | The Zoom factor corresponding to a given object
    Top
    Public Events
     | Name | Description
Public Event | LogEvent | Event fires when loggable events occur
Public Event | OnChangeUid | Event fired when DicomObjects should change a UID for an object
Public Event | ValidateFragments | Routine to allow validation (and if necessary, correction) of fragments of compressed pixel data
    Top
    See Also

    Reference

    DicomGlobal Class
    DicomObjects Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomGlobal Class

    DicomGlobal Class Methods
    In This Topic

    For a list of all members of this type, see DicomGlobal members.

    Public Methods
     | Name | Description
static (Shared in Visual Basic) | AcceptedTransferSyntaxes | List of Transfer Syntaxes accepted by default for a group of SOP classes
static (Shared in Visual Basic) | AddDictionaryElement | Adds Data Element to the Dictionary.
static (Shared in Visual Basic) | AddPrivateDictionaryElement | Adds Private Data Element to the Dictionary.
static (Shared in Visual Basic) | AddToAcceptedTransferSyntaxes |
static (Shared in Visual Basic) | AddToOfferedTransferSyntaxes |
static (Shared in Visual Basic) | AddToSOPClassGroup |
static (Shared in Visual Basic) | ClearAcceptedTransferSyntaxes | Clear all accepted Transfer Syntaxes from a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | ClearOfferedTransferSyntaxes | Clear all offered Transfer Syntaxes from a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | ClearSOPClassGroup | Clear all SOP classes from a group used to help control use of associated transfer syntaxes
static (Shared in Visual Basic) | Echo | Sends a DICOM verify (C-ECHO), with IP address, port number, callingAET, calledAET to another application entity, and returns the result
static (Shared in Visual Basic) | FindGroup | Find to which group a particular SOP class is currently assigned
static (Shared in Visual Basic) | GetRegString | Overloaded. Returns the value of a cached key with default value
static (Shared in Visual Basic) | GetRegWord | Overloaded. Returns the value of a cached key with default value
static (Shared in Visual Basic) | GetStatusCodeType | Checks if status code is a defined error code
static (Shared in Visual Basic) | GuidToUID | Construct a DICOM UID from Universally Unique Identifier (GUID) based on the method defined in ISO/IEC 9834-8 / ITU-T X.667
static (Shared in Visual Basic) | IgnoreAttribute | Instruct DicomObjects to ignore particular attributes
static (Shared in Visual Basic) | IsDICOM | Overloaded. A very simple method to test whether a stream contains valid DICOM
static (Shared in Visual Basic) | IsEncrypted | Tests whether a DICOM file is encrypted according the CMS encoding defined in DICOM supplement 895
static (Shared in Visual Basic) | Keyword | Overloaded. Construct a keyword from arbitrary group and element values
static (Shared in Visual Basic) | KeywordElement |
static (Shared in Visual Basic) | KeywordGroup |
static (Shared in Visual Basic) | KeywordTag |
static (Shared in Visual Basic) | LoadConfigFile | Forces loading of the XML configuration file
static (Shared in Visual Basic) | Log | Add text to the log file.
static (Shared in Visual Basic) | LogToFile | Overloaded. Enables DicomObjects logging, specifies where DicomObjects log files appear, what the logging level is and the timer interval when new log file should be generated.
static (Shared in Visual Basic) | LogToFileStop | Stop logging to the currently active file
static (Shared in Visual Basic) | LogToLogger |
static (Shared in Visual Basic) | LogToStream | Enables DicomObjects logging to a user provided stream
static (Shared in Visual Basic) | MakeDictionary | Create a Dataset containing a null copy of all 'known' possible attributes
static (Shared in Visual Basic) | NewUID | Generates a guaranteed unique valid DICOM UID
static (Shared in Visual Basic) | OfferedTransferSyntaxes | List of Transfer Syntaxes offered by default for a group of SOP classes
static (Shared in Visual Basic) | RemoveFromAcceptedTransferSyntaxes |
static (Shared in Visual Basic) | RemoveFromOfferedTransferSyntaxes |
static (Shared in Visual Basic) | RemoveFromSOPClassGroup |
static (Shared in Visual Basic) | ResetPixelCache | Clear any existing pixel cache
static (Shared in Visual Basic) | SetRegString | Insert or replace values in the internal virtual registry
static (Shared in Visual Basic) | SetRegWord | Sets key values in the internal look up table
static (Shared in Visual Basic) | SOPClassGroup | Groups of SOP classes that use the same default Transfer Syntaxes
static (Shared in Visual Basic) | Zoom | The Zoom factor corresponding to a given object
    Top
    See Also

    Reference

    DicomGlobal Class
    DicomObjects Namespace


DicomObjects Namespace / DicomGlobal Class / AcceptedTransferSyntaxes Method
The SOPClassGroups

    AcceptedTransferSyntaxes Method
    In This Topic
    List of Transfer Syntaxes accepted by default for a group of SOP classes
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function AcceptedTransferSyntaxes( _
   ByVal Group As SOPClassGroups _
) As List(Of String)
    'Usage

Dim Group As SOPClassGroups
Dim value As List(Of String)

value = DicomGlobal.AcceptedTransferSyntaxes(Group)
    public static List<string> AcceptedTransferSyntaxes(
   SOPClassGroups Group
)

    Parameters

    Group
    The SOPClassGroups

    Return Value

    A list of Transfer Syntaxes to be accepted
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / AddDictionaryElement Method
Integer value, the group index of the data element.
Integer value, the element index of the data element.
String value, the value representation of the new data element.
String value, the value multiplicity of the data element.
String value, the description of the data element.

In This Topic
    AddDictionaryElement Method
    In This Topic
    Adds Data Element to the Dictionary.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Sub AddDictionaryElement( _
   ByVal Group As Integer, _
   ByVal Element As Integer, _
   ByVal VR As String, _
   ByVal VM As String, _
   ByVal Description As String _
)
    'Usage

Dim Group As Integer
Dim Element As Integer
Dim VR As String
Dim VM As String
Dim Description As String

DicomGlobal.AddDictionaryElement(Group, Element, VR, VM, Description)
    public static void AddDictionaryElement(
   int Group,
   int Element,
   string VR,
   string VM,
   string Description
)

    Parameters

    Group
    Integer value, the group index of the data element.
    Element
    Integer value, the element index of the data element.
    VR
    String value, the value representation of the new data element.
    VM
    String value, the value multiplicity of the data element.
    Description
    String value, the description of the data element.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / AddPrivateDictionaryElement Method
Integer value, the group index of the data element.
Byte value, the lower byte element index of the data element.
The name of the private creator
String value, the value representation of the new data element.
String value, the value multiplicity of the data element.
String value, the description of the data element.

In This Topic
    AddPrivateDictionaryElement Method
    In This Topic
    Adds Private Data Element to the Dictionary.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Sub AddPrivateDictionaryElement( _
   ByVal Group As Integer, _
   ByVal Element As Byte, _
   ByVal Creator As String, _
   ByVal VR As String, _
   ByVal VM As String, _
   ByVal Description As String _
)
    'Usage

Dim Group As Integer
Dim Element As Byte
Dim Creator As String
Dim VR As String
Dim VM As String
Dim Description As String

DicomGlobal.AddPrivateDictionaryElement(Group, Element, Creator, VR, VM, Description)
    public static void AddPrivateDictionaryElement(
   int Group,
   byte Element,
   string Creator,
   string VR,
   string VM,
   string Description
)

    Parameters

    Group
    Integer value, the group index of the data element.
    Element
    Byte value, the lower byte element index of the data element.
    Creator
    The name of the private creator
    VR
    String value, the value representation of the new data element.
    VM
    String value, the value multiplicity of the data element.
    Description
    String value, the description of the data element.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / AddToAcceptedTransferSyntaxes Method

    AddToAcceptedTransferSyntaxes Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Sub AddToAcceptedTransferSyntaxes( _
   ByVal Group As SOPClassGroups, _
   ByVal TransferSyntax As UID _
)
    'Usage

Dim Group As SOPClassGroups
Dim TransferSyntax As UID

DicomGlobal.AddToAcceptedTransferSyntaxes(Group, TransferSyntax)
    public static void AddToAcceptedTransferSyntaxes(
   SOPClassGroups Group,
   UID TransferSyntax
)

    Parameters

    Group
    TransferSyntax
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / AddToOfferedTransferSyntaxes Method

    AddToOfferedTransferSyntaxes Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Sub AddToOfferedTransferSyntaxes( _
   ByVal Group As SOPClassGroups, _
   ByVal TransferSyntax As UID _
)
    'Usage

Dim Group As SOPClassGroups
Dim TransferSyntax As UID

DicomGlobal.AddToOfferedTransferSyntaxes(Group, TransferSyntax)
    public static void AddToOfferedTransferSyntaxes(
   SOPClassGroups Group,
   UID TransferSyntax
)

    Parameters

    Group
    TransferSyntax
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / AddToSOPClassGroup Method

    AddToSOPClassGroup Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Sub AddToSOPClassGroup( _
   ByVal Group As SOPClassGroups, _
   ByVal SOPClass As UID _
)
    'Usage

Dim Group As SOPClassGroups
Dim SOPClass As UID

DicomGlobal.AddToSOPClassGroup(Group, SOPClass)
    public static void AddToSOPClassGroup(
   SOPClassGroups Group,
   UID SOPClass
)

    Parameters

    Group
    SOPClass
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ClearAcceptedTransferSyntaxes Method
The list of accepted Transfer Syntaxes to clear

    ClearAcceptedTransferSyntaxes Method
    In This Topic
    Clear all accepted Transfer Syntaxes from a group used to help control automatic acceptance of transfer syntaxes
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Sub ClearAcceptedTransferSyntaxes( _
   ByVal Group As SOPClassGroups _
)
    'Usage

Dim Group As SOPClassGroups

DicomGlobal.ClearAcceptedTransferSyntaxes(Group)
    public static void ClearAcceptedTransferSyntaxes(
   SOPClassGroups Group
)

    Parameters

    Group
    The list of accepted Transfer Syntaxes to clear
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ClearOfferedTransferSyntaxes Method
The list of offered Transfer Syntaxes to clear

    ClearOfferedTransferSyntaxes Method
    In This Topic
    Clear all offered Transfer Syntaxes from a group used to help control automatic acceptance of transfer syntaxes
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Sub ClearOfferedTransferSyntaxes( _
   ByVal Group As SOPClassGroups _
)
    'Usage

Dim Group As SOPClassGroups

DicomGlobal.ClearOfferedTransferSyntaxes(Group)
    public static void ClearOfferedTransferSyntaxes(
   SOPClassGroups Group
)

    Parameters

    Group
    The list of offered Transfer Syntaxes to clear
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ClearSOPClassGroup Method
The group to clear

    ClearSOPClassGroup Method
    In This Topic
    Clear all SOP classes from a group used to help control use of associated transfer syntaxes
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Sub ClearSOPClassGroup( _
   ByVal Group As SOPClassGroups _
)
    'Usage

Dim Group As SOPClassGroups

DicomGlobal.ClearSOPClassGroup(Group)
    public static void ClearSOPClassGroup(
   SOPClassGroups Group
)

    Parameters

    Group
    The group to clear
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / Echo Method

Remote entity name as IP address or resolvable name

Port to connect to

Calling Application Entity Titles (AETs)

Called Application Entity Titles (AETs)

In This Topic
    Echo Method (DicomGlobal)
    In This Topic
    Sends a DICOM verify (C-ECHO), with IP address, port number, callingAET, calledAET to another application entity, and returns the result
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function Echo( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAET As String, _
   ByVal CalledAET As String _
) As Integer
    'Usage

Dim Node As String
Dim Port As Integer
Dim CallingAET As String
Dim CalledAET As String
Dim value As Integer

value = DicomGlobal.Echo(Node, Port, CallingAET, CalledAET)
    public static int Echo(
   string Node,
   int Port,
   string CallingAET,
   string CalledAET
)

    Parameters

    Node

    Remote entity name as IP address or resolvable name

    Port

    Port to connect to

    CallingAET

    Calling Application Entity Titles (AETs)

    CalledAET

    Called Application Entity Titles (AETs)

    Return Value

    The status provided by the SCP. This should always be 0
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / FindGroup Method
The SOP class to be queried

    FindGroup Method
    In This Topic
    Find to which group a particular SOP class is currently assigned
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function FindGroup( _
   ByVal UID As String _
) As SOPClassGroups
    'Usage

Dim UID As String
Dim value As SOPClassGroups

value = DicomGlobal.FindGroup(UID)
    public static SOPClassGroups FindGroup(
   string UID
)

    Parameters

    UID
    The SOP class to be queried

    Return Value

    The associated group
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / GetRegString Method

    GetRegString Method
    Returns the value of a cached key with default value
    Overload List
    Overload | Description
GetRegString(String,String) | Returns the value of a cached key with default value
GetRegString(String) | Returns the value of a cached key
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / GetRegString Method / GetRegString(String,String) Method

The name of the registry key.

The default return value.

In This Topic
    GetRegString(String,String) Method
    In This Topic
    Returns the value of a cached key with default value
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Shared Function GetRegString( _
   ByVal Name As String, _
   ByVal Default As String _
) As String
    'Usage

Dim Name As String
Dim Default As String
Dim value As String

value = DicomGlobal.GetRegString(Name, Default)
    public static string GetRegString(
   string Name,
   string Default
)

    Parameters

    Name

    The name of the registry key.

    Default

    The default return value.

    Return Value

    string
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    Overload List


DicomObjects Namespace / DicomGlobal Class / GetRegString Method / GetRegString(String) Method

The name of the registry key.

In This Topic
    GetRegString(String) Method
    In This Topic
    Returns the value of a cached key
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Shared Function GetRegString( _
   ByVal Name As String _
) As String
    'Usage

Dim Name As String
Dim value As String

value = DicomGlobal.GetRegString(Name)
    public static string GetRegString(
   string Name
)

    Parameters

    Name

    The name of the registry key.

    Return Value

    string
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    Overload List


DicomObjects Namespace / DicomGlobal Class / GetRegWord Method

    GetRegWord Method
    Returns the value of a cached key with default value
    Overload List
    Overload | Description
GetRegWord(String,Int32) | Returns the value of a cached key with default value
GetRegWord(String) | Returns the value of a cached key
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / GetRegWord Method / GetRegWord(String,Int32) Method

The name of the registry key.

The default return value.

In This Topic
    GetRegWord(String,Int32) Method
    In This Topic
    Returns the value of a cached key with default value
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Shared Function GetRegWord( _
   ByVal Name As String, _
   ByVal Default As Integer _
) As Integer
    'Usage

Dim Name As String
Dim Default As Integer
Dim value As Integer

value = DicomGlobal.GetRegWord(Name, Default)
    public static int GetRegWord(
   string Name,
   int Default
)

    Parameters

    Name

    The name of the registry key.

    Default

    The default return value.

    Return Value

    int
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    Overload List


DicomObjects Namespace / DicomGlobal Class / GetRegWord Method / GetRegWord(String) Method

The name of the registry key.

In This Topic
    GetRegWord(String) Method
    In This Topic
    Returns the value of a cached key
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Shared Function GetRegWord( _
   ByVal Name As String _
) As Integer
    'Usage

Dim Name As String
Dim value As Integer

value = DicomGlobal.GetRegWord(Name)
    public static int GetRegWord(
   string Name
)

    Parameters

    Name

    The name of the registry key.

    Return Value

    int
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    Overload List


DicomObjects Namespace / DicomGlobal Class / GetStatusCodeType Method
Status code to check

    GetStatusCodeType Method
    In This Topic
    Checks if status code is a defined error code
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function GetStatusCodeType( _
   ByVal statusCode As StatusCode _
) As StatusType
    'Usage

Dim statusCode As StatusCode
Dim value As StatusType

value = DicomGlobal.GetStatusCodeType(statusCode)
    public static StatusType GetStatusCodeType(
   StatusCode statusCode
)

    Parameters

    statusCode
    Status code to check

    Return Value

    Type of the status code
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / GuidToUID Method
A System.Guid object to construct the DICOM UID from

    GuidToUID Method
    In This Topic
    Construct a DICOM UID from Universally Unique Identifier (GUID) based on the method defined in ISO/IEC 9834-8 / ITU-T X.667
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function GuidToUID( _
   ByVal guid As Guid _
) As String
    'Usage

Dim guid As Guid
Dim value As String

value = DicomGlobal.GuidToUID(guid)
    public static string GuidToUID(
   Guid guid
)

    Parameters

    guid
    A System.Guid object to construct the DICOM UID from

    Return Value

    A DICOM UID based on the Guid object
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / IgnoreAttribute Method
The Group to ignore
The Element to ignore

In This Topic
    IgnoreAttribute Method
    In This Topic
    Instruct DicomObjects to ignore particular attributes
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Sub IgnoreAttribute( _
   ByVal Group As Integer, _
   ByVal Element As Integer _
)
    'Usage

Dim Group As Integer
Dim Element As Integer

DicomGlobal.IgnoreAttribute(Group, Element)
    public static void IgnoreAttribute(
   int Group,
   int Element
)

    Parameters

    Group
    The Group to ignore
    Element
    The Element to ignore
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / IsDICOM Method

    IsDICOM Method
    A very simple method to test whether a stream contains valid DICOM
    Overload List
    Overload | Description
IsDICOM(Stream) | A very simple method to test whether a stream contains valid DICOM
IsDICOM(String) | A very simple method to decide if a File is DICOM
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / IsDICOM Method / IsDICOM(Stream) Method
The Stream which carries the data

    IsDICOM(Stream) Method
    In This Topic
    A very simple method to test whether a stream contains valid DICOM
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Shared Function IsDICOM( _
   ByVal stream As Stream _
) As Boolean
    'Usage

Dim stream As Stream
Dim value As Boolean

value = DicomGlobal.IsDICOM(stream)
    public static bool IsDICOM(
   Stream stream
)

    Parameters

    stream
    The Stream which carries the data

    Return Value

    True if the byte 129 - 132 is DICM and the next 8 bytes contains the group 0 header data 02 00 00 00 55 4C 04 00
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    Overload List


DicomObjects Namespace / DicomGlobal Class / IsDICOM Method / IsDICOM(String) Method
The full file path

    IsDICOM(String) Method
    In This Topic
    A very simple method to decide if a File is DICOM
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Shared Function IsDICOM( _
   ByVal Filename As String _
) As Boolean
    'Usage

Dim Filename As String
Dim value As Boolean

value = DicomGlobal.IsDICOM(Filename)
    public static bool IsDICOM(
   string Filename
)

    Parameters

    Filename
    The full file path

    Return Value

    True if bytes 129 - 132 are "DICM" and the next 8 bytes contains the group 0 header data 02 00 00 00 55 4C 04 00
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    Overload List


DicomObjects Namespace / DicomGlobal Class / IsEncrypted Method
File to test

    IsEncrypted Method
    In This Topic
    Tests whether a DICOM file is encrypted according the CMS encoding defined in DICOM supplement 895
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function IsEncrypted( _
   ByVal Filename As String _
) As Boolean
    'Usage

Dim Filename As String
Dim value As Boolean

value = DicomGlobal.IsEncrypted(Filename)
    public static bool IsEncrypted(
   string Filename
)

    Parameters

    Filename
    File to test

    Return Value

    True if file is encrypted
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / Keyword Method

    Keyword Method
    Construct a keyword from arbitrary group and element values
    Overload List
    Overload | Description
Keyword(String,String) |
Keyword(UInt16,UInt16) | Construct a keyword from arbitrary group and element values
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / Keyword Method / Keyword(String,String) Method

    Keyword(String,String) Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Shared Function Keyword( _
   ByVal group As String, _
   ByVal element As String _
) As Keyword
    'Usage

Dim group As String
Dim element As String
Dim value As Keyword

value = DicomGlobal.Keyword(group, element)
    public static Keyword Keyword(
   string group,
   string element
)

    Parameters

    group
    element
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    Overload List


DicomObjects Namespace / DicomGlobal Class / Keyword Method / Keyword(UInt16,UInt16) Method
The Group value
The Element value

In This Topic
    Keyword(UInt16,UInt16) Method
    In This Topic
    Construct a keyword from arbitrary group and element values
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Shared Function Keyword( _
   ByVal Group As UShort, _
   ByVal Element As UShort _
) As Keyword
    'Usage

Dim Group As UShort
Dim Element As UShort
Dim value As Keyword

value = DicomGlobal.Keyword(Group, Element)
    public static Keyword Keyword(
   ushort Group,
   ushort Element
)

    Parameters

    Group
    The Group value
    Element
    The Element value

    Return Value

    A keyword
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    Overload List


DicomObjects Namespace / DicomGlobal Class / KeywordElement Method

    KeywordElement Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function KeywordElement( _
   ByVal keyword As Keyword _
) As UShort
    'Usage

Dim keyword As Keyword
Dim value As UShort

value = DicomGlobal.KeywordElement(keyword)
    public static ushort KeywordElement(
   Keyword keyword
)

    Parameters

    keyword
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / KeywordGroup Method

    KeywordGroup Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function KeywordGroup( _
   ByVal keyword As Keyword _
) As UShort
    'Usage

Dim keyword As Keyword
Dim value As UShort

value = DicomGlobal.KeywordGroup(keyword)
    public static ushort KeywordGroup(
   Keyword keyword
)

    Parameters

    keyword
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / KeywordTag Method

    KeywordTag Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function KeywordTag( _
   ByVal keyword As Keyword, _
   Optional ByVal separator As String _
) As String
    'Usage

Dim keyword As Keyword
Dim separator As String
Dim value As String

value = DicomGlobal.KeywordTag(keyword, separator)
    public static string KeywordTag(
   Keyword keyword,
   string separator
)

    Parameters

    keyword
    separator
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / LoadConfigFile Method

    LoadConfigFile Method
    Forces loading of the XML configuration file
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Sub LoadConfigFile()
    'Usage

DicomGlobal.LoadConfigFile()
    public static void LoadConfigFile()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / Log Method
Text as string, which is to be added to the log file.

In This Topic
    Log Method
    In This Topic
    Add text to the log file.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Sub Log( _
   ByVal Text As String _
)
    'Usage

Dim Text As String

DicomGlobal.Log(Text)
    public static void Log(
   string Text
)

    Parameters

    Text
    Text as string, which is to be added to the log file.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / LogToFile Method

    LogToFile Method
    Enables DicomObjects logging, specifies where DicomObjects log files appear, what the logging level is and the timer interval when new log file should be generated.
    Overload List
    Overload | Description
LogToFile(String,Int32) | Enables DicomObjects logging, specifies where DicomObjects log files appear, what the logging level is and the timer interval when new log file should be generated.
LogToFile(String,Int32,Int32) | Enables DicomObjects logging, specifies where DicomObjects log files appear, what the logging level is and the timer interval when new log file should be generated.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / LogToFile Method / LogToFile(String,Int32) Method

The location of the log files.

If an empty string being passed, DicomObjects will use "C:\" as the default location.

But still it is the container's responsibility to ensure either that the path is valid and correct.

This value controls the level of details logged either to the display, or to a file.

The allowable values for log level are:

Decimal | Hex |
1 | 1 | Errors
2 | 2 | Warnings
4 | 4 | Informational Messages
8 | 8 | Detailed Logging
16 | 10 | All DICOM attributes received or read
32 | 20 | All DICOM attributes send or written
64 | 40 | Byte-Level data received, except contents of data PDUs
128 | 80 | Byte-level data sent, except contents of data PDUs
256 | 100 | All bytes received
512 | 200 | All bytes sent

In This Topic
    LogToFile(String,Int32) Method
    In This Topic
    Enables DicomObjects logging, specifies where DicomObjects log files appear, what the logging level is and the timer interval when new log file should be generated.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Shared Sub LogToFile( _
   ByVal Path As String, _
   ByVal LogLevel As Integer _
)
    'Usage

Dim Path As String
Dim LogLevel As Integer

DicomGlobal.LogToFile(Path, LogLevel)
    public static void LogToFile(
   string Path,
   int LogLevel
)

    Parameters

    Path

    The location of the log files.

    If an empty string being passed, DicomObjects will use "C:\" as the default location.

    But still it is the container's responsibility to ensure either that the path is valid and correct.

    LogLevel

    This value controls the level of details logged either to the display, or to a file.

    The allowable values for log level are:

    Decimal | Hex
    1 | 1 | Errors
    2 | 2 | Warnings
    4 | 4 | Informational Messages
    8 | 8 | Detailed Logging
    16 | 10 | All DICOM attributes received or read
    32 | 20 | All DICOM attributes send or written
    64 | 40 | Byte-Level data received, except contents of data PDUs
    128 | 80 | Byte-level data sent, except contents of data PDUs
    256 | 100 | All bytes received
    512 | 200 | All bytes sent

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    Overload List


DicomObjects Namespace / DicomGlobal Class / LogToFile Method / LogToFile(String,Int32,Int32) Method

The location of the log files.

If an empty string being passed, DicomObjects will use "C:\" as the default location.

But still it is the container's responsibility to ensure either that the path is valid and correct.

This value controls the level of details logged either to the display, or to a file.

The allowable values for log level are:

Decimal | Hex |
1 | 1 | Errors
2 | 2 | Warnings
4 | 4 | Informational Messages
8 | 8 | Detailed Logging
16 | 10 | All DICOM attributes received or read
32 | 20 | All DICOM attributes send or written
64 | 40 | Byte-Level data received, except contents of data PDUs
128 | 80 | Byte-level data sent, except contents of data PDUs
256 | 100 | All bytes received
512 | 200 | All bytes sent

RestartMinutes as int, the time interval when a new log file should be generated.

In This Topic
    LogToFile(String,Int32,Int32) Method
    In This Topic
    Enables DicomObjects logging, specifies where DicomObjects log files appear, what the logging level is and the timer interval when new log file should be generated.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Shared Sub LogToFile( _
   ByVal Path As String, _
   ByVal LogLevel As Integer, _
   ByVal RestartMinutes As Integer _
)
    'Usage

Dim Path As String
Dim LogLevel As Integer
Dim RestartMinutes As Integer

DicomGlobal.LogToFile(Path, LogLevel, RestartMinutes)
    public static void LogToFile(
   string Path,
   int LogLevel,
   int RestartMinutes
)

    Parameters

    Path

    The location of the log files.

    If an empty string being passed, DicomObjects will use "C:\" as the default location.

    But still it is the container's responsibility to ensure either that the path is valid and correct.

    LogLevel

    This value controls the level of details logged either to the display, or to a file.

    The allowable values for log level are:

    Decimal | Hex
    1 | 1 | Errors
    2 | 2 | Warnings
    4 | 4 | Informational Messages
    8 | 8 | Detailed Logging
    16 | 10 | All DICOM attributes received or read
    32 | 20 | All DICOM attributes send or written
    64 | 40 | Byte-Level data received, except contents of data PDUs
    128 | 80 | Byte-level data sent, except contents of data PDUs
    256 | 100 | All bytes received
    512 | 200 | All bytes sent
    RestartMinutes

    RestartMinutes as int, the time interval when a new log file should be generated.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    Overload List


DicomObjects Namespace / DicomGlobal Class / LogToFileStop Method

    LogToFileStop Method
    Stop logging to the currently active file
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Sub LogToFileStop()
    'Usage

DicomGlobal.LogToFileStop()
    public static void LogToFileStop()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / LogToLogger Method

    LogToLogger Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Sub LogToLogger( _
   ByVal Logger As ILogger, _
   ByVal LogLevel As Integer _
)
    'Usage

Dim Logger As ILogger
Dim LogLevel As Integer

DicomGlobal.LogToLogger(Logger, LogLevel)
    public static void LogToLogger(
   ILogger Logger,
   int LogLevel
)

    Parameters

    Logger
    LogLevel
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / LogToStream Method

The stream to send log data to

This value controls the level of details logged either to the display, or to a file.

The allowable values for log level are:

Decimal | Hex |
1 | 1 | Errors
2 | 2 | Warnings
4 | 4 | Informational Messages
8 | 8 | Detailed Logging
16 | 10 | All DICOM attributes received or read
32 | 20 | All DICOM attributes send or written
64 | 40 | Byte-Level data received, except contents of data PDUs
128 | 80 | Byte-level data sent, except contents of data PDUs
256 | 100 | All bytes received
512 | 200 | All bytes sent

In This Topic
    LogToStream Method
    In This Topic
    Enables DicomObjects logging to a user provided stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Sub LogToStream( _
   ByVal Stream As Stream, _
   ByVal LogLevel As Integer _
)
    'Usage

Dim Stream As Stream
Dim LogLevel As Integer

DicomGlobal.LogToStream(Stream, LogLevel)
    public static void LogToStream(
   Stream Stream,
   int LogLevel
)

    Parameters

    Stream

    The stream to send log data to

    LogLevel

    This value controls the level of details logged either to the display, or to a file.

    The allowable values for log level are:

    Decimal | Hex
    1 | 1 | Errors
    2 | 2 | Warnings
    4 | 4 | Informational Messages
    8 | 8 | Detailed Logging
    16 | 10 | All DICOM attributes received or read
    32 | 20 | All DICOM attributes send or written
    64 | 40 | Byte-Level data received, except contents of data PDUs
    128 | 80 | Byte-level data sent, except contents of data PDUs
    256 | 100 | All bytes received
    512 | 200 | All bytes sent
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / MakeDictionary Method

    MakeDictionary Method
    Create a Dataset containing a null copy of all 'known' possible attributes
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function MakeDictionary() As DicomDataSet
    'Usage

Dim value As DicomDataSet

value = DicomGlobal.MakeDictionary()
    public static DicomDataSet MakeDictionary()

    Return Value

    DicomDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / NewUID Method

    NewUID Method
    Generates a guaranteed unique valid DICOM UID
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function NewUID() As String
    'Usage

Dim value As String

value = DicomGlobal.NewUID()
    public static string NewUID()

    Return Value

    String
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / OfferedTransferSyntaxes Method

The SOPClassGroups

    OfferedTransferSyntaxes Method
    In This Topic
    List of Transfer Syntaxes offered by default for a group of SOP classes
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function OfferedTransferSyntaxes( _
   ByVal Group As SOPClassGroups _
) As List(Of String)
    'Usage

Dim Group As SOPClassGroups
Dim value As List(Of String)

value = DicomGlobal.OfferedTransferSyntaxes(Group)
    public static List<string> OfferedTransferSyntaxes(
   SOPClassGroups Group
)

    Parameters

    Group

    The SOPClassGroups

    Return Value

    The list of Transfer Syntaxes to be offered
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / RemoveFromAcceptedTransferSyntaxes Method

    RemoveFromAcceptedTransferSyntaxes Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Sub RemoveFromAcceptedTransferSyntaxes( _
   ByVal Group As SOPClassGroups, _
   ByVal TransferSyntax As UID _
)
    'Usage

Dim Group As SOPClassGroups
Dim TransferSyntax As UID

DicomGlobal.RemoveFromAcceptedTransferSyntaxes(Group, TransferSyntax)
    public static void RemoveFromAcceptedTransferSyntaxes(
   SOPClassGroups Group,
   UID TransferSyntax
)

    Parameters

    Group
    TransferSyntax
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / RemoveFromOfferedTransferSyntaxes Method

    RemoveFromOfferedTransferSyntaxes Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Sub RemoveFromOfferedTransferSyntaxes( _
   ByVal Group As SOPClassGroups, _
   ByVal TransferSyntax As UID _
)
    'Usage

Dim Group As SOPClassGroups
Dim TransferSyntax As UID

DicomGlobal.RemoveFromOfferedTransferSyntaxes(Group, TransferSyntax)
    public static void RemoveFromOfferedTransferSyntaxes(
   SOPClassGroups Group,
   UID TransferSyntax
)

    Parameters

    Group
    TransferSyntax
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / RemoveFromSOPClassGroup Method

    RemoveFromSOPClassGroup Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Sub RemoveFromSOPClassGroup( _
   ByVal Group As SOPClassGroups, _
   ByVal SOPClass As UID _
)
    'Usage

Dim Group As SOPClassGroups
Dim SOPClass As UID

DicomGlobal.RemoveFromSOPClassGroup(Group, SOPClass)
    public static void RemoveFromSOPClassGroup(
   SOPClassGroups Group,
   UID SOPClass
)

    Parameters

    Group
    SOPClass
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ResetPixelCache Method

    ResetPixelCache Method
    Clear any existing pixel cache
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Sub ResetPixelCache()
    'Usage

DicomGlobal.ResetPixelCache()
    public static void ResetPixelCache()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / SetRegString Method

The name of the registry key.

The value to set.

In This Topic
    SetRegString Method
    In This Topic
    Insert or replace values in the internal virtual registry
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Sub SetRegString( _
   ByVal Name As String, _
   ByVal Value As String _
)
    'Usage

Dim Name As String
Dim Value As String

DicomGlobal.SetRegString(Name, Value)
    public static void SetRegString(
   string Name,
   string Value
)

    Parameters

    Name

    The name of the registry key.

    Value

    The value to set.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / SetRegWord Method

The name of the registry key.

The value to set.

In This Topic
    SetRegWord Method
    In This Topic
    Sets key values in the internal look up table
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Sub SetRegWord( _
   ByVal Name As String, _
   ByVal Value As Integer _
)
    'Usage

Dim Name As String
Dim Value As Integer

DicomGlobal.SetRegWord(Name, Value)
    public static void SetRegWord(
   string Name,
   int Value
)

    Parameters

    Name

    The name of the registry key.

    Value

    The value to set.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / SOPClassGroup Method
The group requested

    SOPClassGroup Method
    In This Topic
    Groups of SOP classes that use the same default Transfer Syntaxes
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function SOPClassGroup( _
   ByVal Group As SOPClassGroups _
) As List(Of String)
    'Usage

Dim Group As SOPClassGroups
Dim value As List(Of String)

value = DicomGlobal.SOPClassGroup(Group)
    public static List<string> SOPClassGroup(
   SOPClassGroups Group
)

    Parameters

    Group
    The group requested

    Return Value

    The list of SOP classes to which the selected group applies
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / Zoom Method
The Matrix to use

    Zoom Method
    In This Topic
    The Zoom factor corresponding to a given object
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function Zoom( _
   ByVal m As Matrix _
) As Single
    'Usage

Dim m As Matrix
Dim value As Single

value = DicomGlobal.Zoom(m)
    public static float Zoom(
   Matrix m
)

    Parameters

    m
    The Matrix to use

    Return Value

    float/single
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomGlobal Class

    DicomGlobal Class Properties
    In This Topic

    For a list of all members of this type, see DicomGlobal members.

    Public Properties
     | Name | Description
static (Shared in Visual Basic) | AssemblyDirectory | Returns the Assembly Directory information
static (Shared in Visual Basic) | AssemblyVersion | Gets the Assembly Version of DicomObjects.NET
static (Shared in Visual Basic) | Assume2022Escapes | Controls whether DicomObjects attempts to locate unannounced 2022 escape sequences
static (Shared in Visual Basic) | ChangeLossyUIDs | Controls whether DicomObjects changes the UID when doing lossy compression
static (Shared in Visual Basic) | CloseFilesAfterReading | Controls how pixel data is read from disk
static (Shared in Visual Basic) | ColourConverter | Interface to allow override of the default CIELab <=> RGB conversion
static (Shared in Visual Basic) | CombinePDVs | Controls whether to combine outgoing command and data PDVs into a single PDU
static (Shared in Visual Basic) | CurrentLogFileName | Returns the Current DicomObjects Log File Name in full.
static (Shared in Visual Basic) | DefaultCharacterSet | Default Character to set to use if 0008,0005 is absent
static (Shared in Visual Basic) | DefaultFFmpegFilter | Description of the Default filter to apply for FFmpeg processing
static (Shared in Visual Basic) | DefaultIpAddressFamily | The IP Address family to be used where not otherwise specified
static (Shared in Visual Basic) | DefaultReadBehaviour | Default behaviour when reading or receiving files
static (Shared in Visual Basic) | DefaultSOPClasses | Default list of SOP class UID's (Abstract syntaxes) to be used until specifically overridden by user settings
static (Shared in Visual Basic) | DefaultWriteBehaviour | Default behaviour when writing or sending files
static (Shared in Visual Basic) | DeidentifyInLog | A list of keywords fo attributes which should not be included in any standard log file.
static (Shared in Visual Basic) | DirectionStrings | Language specific indicators for anatomic labelling
static (Shared in Visual Basic) | DisplayCacheTime | Controls how long display cache copies of images are retained.
static (Shared in Visual Basic) | Enable10BitDisplay | To allows support for 10bit data.
static (Shared in Visual Basic) | EventLogLevel | Controls the logging of diagnostic message to the event.
static (Shared in Visual Basic) | FailOnSuspiciousPreamble | Detect any non-zero data in the preamble (the first 128 bytes) leading to 'DICM', and alert if any unwanted bytes or malicious code is present. A pre-defined list of file formats is used for checking against the non-zero preamble This mainly affects data with such preamble when reading it in. Writing to disk or sending using DICOM protocol would remove existing preamble (effectively cleaning any malicious preamble) and recreate it when written to disk on the receiving side
static (Shared in Visual Basic) | FileVersion | Gets the File Version of DicomObjects.NET
static (Shared in Visual Basic) | FlushLevel | A level to cause the log to be flushed to disk
static (Shared in Visual Basic) | FontScaling | The factor by which to increase the font size when using DirectX display mode. The default is 1.5, which gives appearance similar to those in GDI mode.
static (Shared in Visual Basic) | ImplementationName | The Implementation Name of this application
static (Shared in Visual Basic) | ImplementationUID | The Implementation UID of this application
static (Shared in Visual Basic) | IndentJson | Controls whether JSON generated is indented and formatted for easy human interpretation
static (Shared in Visual Basic) | JpipInitialSize |
static (Shared in Visual Basic) | LockGdiOperations | Controls whether to use an explicit lock to prevent recurrent GDI operations from happening
static (Shared in Visual Basic) | LogLicenceDetails |
static (Shared in Visual Basic) | MaximumDateTime | Control the global MaximumDateTime value used by DicomObjects. Default value is DateTime.MaxValue
static (Shared in Visual Basic) | MaximumPDUSize | The Maximum PDU size accepted and used by DicomObjects
static (Shared in Visual Basic) | MinFontSize | Contains the Minimum Font Size used when drawing Text Label.
static (Shared in Visual Basic) | MinimumDateTime | Control the global MinimumDateTime value used by DicomObjects. Default value is DateTime.MinValue
static (Shared in Visual Basic) | MoveTimesOut | Controls whether DicomObjects will time out during a C-MOVE operation
static (Shared in Visual Basic) | PreambleFileSignatures | A pre-defined modifiable list of file signatures to match against the preamble if is enabled
static (Shared in Visual Basic) | PreferredBitmapMode | Controls method of rendering used by "Bitmap"
static (Shared in Visual Basic) | PreserveDoublePrecision | Retain precision for double numbers
static (Shared in Visual Basic) | ProductName | The product name to be shown in licensing Dialogs etc. Default value is "DicomObjects".
static (Shared in Visual Basic) | QuadrupedDirectionStrings | The quadruped equivalent of DirectionStrings allowing localisation of these abbreviations
static (Shared in Visual Basic) | RenderException | Controls whether non-image objects throw an exception during rendering
static (Shared in Visual Basic) | ReUseArrays | Controls whether DicomObjcts re-uses arrays to hold pixel data
static (Shared in Visual Basic) | ReuseOnlyExactArraySize | Controls whether "Over-sized" arrays are used
static (Shared in Visual Basic) | RunningInDocker |
static (Shared in Visual Basic) | ShowTextBoxForPresentationStates | Controls whether bounding boxes are drawn around internally generated DicomLabel objects derived from text entries in Presentation States
static (Shared in Visual Basic) | SignedLicencePrefix |
static (Shared in Visual Basic) | ThreadCount | Controls how many threads may be used by DicomObjects when rendering etc.
static (Shared in Visual Basic) | Timeout | The period of time that a network operation will wait if there is no response from the peer
static (Shared in Visual Basic) | UIDRoot | UIDRoot used by the method
static (Shared in Visual Basic) | Use32BitTexture |
static (Shared in Visual Basic) | UsePerformanceCounters | Controls use of specific performance counters for DicomObjects
static (Shared in Visual Basic) | UsePixelCache | Controls whether to use an area of memory as a pixel cache to reduce demands on the memory allocator
static (Shared in Visual Basic) | ValidDateMax | Maximum allowed DateTime for validation purposes Default value is DateTime.MaxValue
static (Shared in Visual Basic) | ValidDateMin | Minimum allowed DateTime for validation purposes Default value is DateTime.MinValue
    Top
    See Also

    Reference

    DicomGlobal Class
    DicomObjects Namespace


DicomObjects Namespace / DicomGlobal Class / AssemblyDirectory Property

    AssemblyDirectory Property
    Returns the Assembly Directory information
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly Property AssemblyDirectory As String
    'Usage

Dim value As String

value = DicomGlobal.AssemblyDirectory
    public static string AssemblyDirectory {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / AssemblyVersion Property

    AssemblyVersion Property
    Gets the Assembly Version of DicomObjects.NET
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly Property AssemblyVersion As String
    'Usage

Dim value As String

value = DicomGlobal.AssemblyVersion
    public static string AssemblyVersion {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / Assume2022Escapes Property

    Assume2022Escapes Property
    Controls whether DicomObjects attempts to locate unannounced 2022 escape sequences
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property Assume2022Escapes As Boolean
    'Usage

Dim value As Boolean

DicomGlobal.Assume2022Escapes = value

value = DicomGlobal.Assume2022Escapes
    public static bool Assume2022Escapes {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ChangeLossyUIDs Property

    ChangeLossyUIDs Property (DicomGlobal)
    In This Topic
    Controls whether DicomObjects changes the UID when doing lossy compression
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property ChangeLossyUIDs As Boolean
    'Usage

Dim value As Boolean

DicomGlobal.ChangeLossyUIDs = value

value = DicomGlobal.ChangeLossyUIDs
    public static bool ChangeLossyUIDs {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / CloseFilesAfterReading Property

    CloseFilesAfterReading Property (DicomGlobal)
    In This Topic
    Controls how pixel data is read from disk
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property CloseFilesAfterReading As Boolean
    'Usage

Dim value As Boolean

DicomGlobal.CloseFilesAfterReading = value

value = DicomGlobal.CloseFilesAfterReading
    public static bool CloseFilesAfterReading {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ColourConverter Property

    ColourConverter Property
    Interface to allow override of the default CIELab <=> RGB conversion
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property ColourConverter As IColourConverter
    'Usage

Dim value As IColourConverter

DicomGlobal.ColourConverter = value

value = DicomGlobal.ColourConverter
    public static IColourConverter ColourConverter {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / CombinePDVs Property

    CombinePDVs Property
    Controls whether to combine outgoing command and data PDVs into a single PDU
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property CombinePDVs As Boolean
    'Usage

Dim value As Boolean

DicomGlobal.CombinePDVs = value

value = DicomGlobal.CombinePDVs
    public static bool CombinePDVs {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / CurrentLogFileName Property

    CurrentLogFileName Property
    Returns the Current DicomObjects Log File Name in full.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly Property CurrentLogFileName As String
    'Usage

Dim value As String

value = DicomGlobal.CurrentLogFileName
    public static string CurrentLogFileName {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / DefaultCharacterSet Property

    DefaultCharacterSet Property
    Default Character to set to use if 0008,0005 is absent
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property DefaultCharacterSet As String
    'Usage

Dim value As String

DicomGlobal.DefaultCharacterSet = value

value = DicomGlobal.DefaultCharacterSet
    public static string DefaultCharacterSet {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / DefaultFFmpegFilter Property

    DefaultFFmpegFilter Property
    Description of the Default filter to apply for FFmpeg processing
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property DefaultFFmpegFilter As String
    'Usage

Dim value As String

DicomGlobal.DefaultFFmpegFilter = value

value = DicomGlobal.DefaultFFmpegFilter
    public static string DefaultFFmpegFilter {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / DefaultIpAddressFamily Property

    DefaultIpAddressFamily Property
    The IP Address family to be used where not otherwise specified
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property DefaultIpAddressFamily As AddressFamily
    'Usage

Dim value As AddressFamily

DicomGlobal.DefaultIpAddressFamily = value

value = DicomGlobal.DefaultIpAddressFamily
    public static AddressFamily DefaultIpAddressFamily {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / DefaultReadBehaviour Property

    DefaultReadBehaviour Property
    Default behaviour when reading or receiving files
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property DefaultReadBehaviour As ReadBehaviours
    'Usage

Dim value As ReadBehaviours

DicomGlobal.DefaultReadBehaviour = value

value = DicomGlobal.DefaultReadBehaviour
    public static ReadBehaviours DefaultReadBehaviour {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / DefaultSOPClasses Property

    DefaultSOPClasses Property
    Default list of SOP class UID's (Abstract syntaxes) to be used until specifically overridden by user settings
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly Property DefaultSOPClasses As ReadOnlyCollection(Of String)
    'Usage

Dim value As ReadOnlyCollection(Of String)

value = DicomGlobal.DefaultSOPClasses
    public static ReadOnlyCollection<string> DefaultSOPClasses {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / DefaultWriteBehaviour Property

    DefaultWriteBehaviour Property
    Default behaviour when writing or sending files
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property DefaultWriteBehaviour As WriteBehaviours
    'Usage

Dim value As WriteBehaviours

DicomGlobal.DefaultWriteBehaviour = value

value = DicomGlobal.DefaultWriteBehaviour
    public static WriteBehaviours DefaultWriteBehaviour {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / DeidentifyInLog Property

    DeidentifyInLog Property
    A list of keywords fo attributes which should not be included in any standard log file.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly Property DeidentifyInLog As List(Of Keyword)
    'Usage

Dim value As List(Of Keyword)

value = DicomGlobal.DeidentifyInLog
    public static List<Keyword> DeidentifyInLog {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / DirectionStrings Property

    DirectionStrings Property
    Language specific indicators for anatomic labelling
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property DirectionStrings As String()
    'Usage

Dim value() As String

DicomGlobal.DirectionStrings = value

value = DicomGlobal.DirectionStrings
    public static string[] DirectionStrings {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / DisplayCacheTime Property

    DisplayCacheTime Property
    Controls how long display cache copies of images are retained.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property DisplayCacheTime As TimeSpan
    'Usage

Dim value As TimeSpan

DicomGlobal.DisplayCacheTime = value

value = DicomGlobal.DisplayCacheTime
    public static TimeSpan DisplayCacheTime {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / Enable10BitDisplay Property

    Enable10BitDisplay Property
    To allows support for 10bit data.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property Enable10BitDisplay As Boolean
    'Usage

Dim value As Boolean

DicomGlobal.Enable10BitDisplay = value

value = DicomGlobal.Enable10BitDisplay
    public static bool Enable10BitDisplay {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / EventLogLevel Property

    EventLogLevel Property
    Controls the logging of diagnostic message to the event.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property EventLogLevel As LogLevel
    'Usage

Dim value As LogLevel

DicomGlobal.EventLogLevel = value

value = DicomGlobal.EventLogLevel
    public static LogLevel EventLogLevel {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / FailOnSuspiciousPreamble Property

    FailOnSuspiciousPreamble Property
    Detect any non-zero data in the preamble (the first 128 bytes) leading to 'DICM', and alert if any unwanted bytes or malicious code is present. A pre-defined list of file formats is used for checking against the non-zero preamble This mainly affects data with such preamble when reading it in. Writing to disk or sending using DICOM protocol would remove existing preamble (effectively cleaning any malicious preamble) and recreate it when written to disk on the receiving side
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property FailOnSuspiciousPreamble As Boolean
    'Usage

Dim value As Boolean

DicomGlobal.FailOnSuspiciousPreamble = value

value = DicomGlobal.FailOnSuspiciousPreamble
    public static bool FailOnSuspiciousPreamble {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / FileVersion Property

    FileVersion Property
    Gets the File Version of DicomObjects.NET
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly Property FileVersion As String
    'Usage

Dim value As String

value = DicomGlobal.FileVersion
    public static string FileVersion {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / FlushLevel Property

    FlushLevel Property
    A level to cause the log to be flushed to disk
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property FlushLevel As LogLevel
    'Usage

Dim value As LogLevel

DicomGlobal.FlushLevel = value

value = DicomGlobal.FlushLevel
    public static LogLevel FlushLevel {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / FontScaling Property

    FontScaling Property
    The factor by which to increase the font size when using DirectX display mode. The default is 1.5, which gives appearance similar to those in GDI mode.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property FontScaling As Single
    'Usage

Dim value As Single

DicomGlobal.FontScaling = value

value = DicomGlobal.FontScaling
    public static float FontScaling {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ImplementationName Property

    ImplementationName Property (DicomGlobal)
    In This Topic
    The Implementation Name of this application
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property ImplementationName As String
    'Usage

Dim value As String

DicomGlobal.ImplementationName = value

value = DicomGlobal.ImplementationName
    public static string ImplementationName {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ImplementationUID Property

    ImplementationUID Property (DicomGlobal)
    In This Topic
    The Implementation UID of this application
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property ImplementationUID As String
    'Usage

Dim value As String

DicomGlobal.ImplementationUID = value

value = DicomGlobal.ImplementationUID
    public static string ImplementationUID {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / IndentJson Property

    IndentJson Property
    Controls whether JSON generated is indented and formatted for easy human interpretation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property IndentJson As Boolean
    'Usage

Dim value As Boolean

DicomGlobal.IndentJson = value

value = DicomGlobal.IndentJson
    public static bool IndentJson {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / JpipInitialSize Property

    JpipInitialSize Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property JpipInitialSize As Integer
    'Usage

Dim value As Integer

DicomGlobal.JpipInitialSize = value

value = DicomGlobal.JpipInitialSize
    public static int JpipInitialSize {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / LockGdiOperations Property

    LockGdiOperations Property
    Controls whether to use an explicit lock to prevent recurrent GDI operations from happening
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property LockGdiOperations As Boolean
    'Usage

Dim value As Boolean

DicomGlobal.LockGdiOperations = value

value = DicomGlobal.LockGdiOperations
    public static bool LockGdiOperations {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / LogLicenceDetails Property

    LogLicenceDetails Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property LogLicenceDetails As Boolean
    'Usage

Dim value As Boolean

DicomGlobal.LogLicenceDetails = value

value = DicomGlobal.LogLicenceDetails
    public static bool LogLicenceDetails {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / MaximumDateTime Property

    MaximumDateTime Property
    Control the global MaximumDateTime value used by DicomObjects. Default value is DateTime.MaxValue
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property MaximumDateTime As Date
    'Usage

Dim value As Date

DicomGlobal.MaximumDateTime = value

value = DicomGlobal.MaximumDateTime
    public static DateTime MaximumDateTime {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / MaximumPDUSize Property

    MaximumPDUSize Property
    The Maximum PDU size accepted and used by DicomObjects
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property MaximumPDUSize As Integer
    'Usage

Dim value As Integer

DicomGlobal.MaximumPDUSize = value

value = DicomGlobal.MaximumPDUSize
    public static int MaximumPDUSize {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / MinFontSize Property

    MinFontSize Property
    Contains the Minimum Font Size used when drawing Text Label.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property MinFontSize As Single
    'Usage

Dim value As Single

DicomGlobal.MinFontSize = value

value = DicomGlobal.MinFontSize
    public static float MinFontSize {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / MinimumDateTime Property

    MinimumDateTime Property
    Control the global MinimumDateTime value used by DicomObjects. Default value is DateTime.MinValue
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property MinimumDateTime As Date
    'Usage

Dim value As Date

DicomGlobal.MinimumDateTime = value

value = DicomGlobal.MinimumDateTime
    public static DateTime MinimumDateTime {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / MoveTimesOut Property

    MoveTimesOut Property
    Controls whether DicomObjects will time out during a C-MOVE operation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property MoveTimesOut As Boolean
    'Usage

Dim value As Boolean

DicomGlobal.MoveTimesOut = value

value = DicomGlobal.MoveTimesOut
    public static bool MoveTimesOut {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / PreambleFileSignatures Property

    PreambleFileSignatures Property
    A pre-defined modifiable list of file signatures to match against the preamble if is enabled
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property PreambleFileSignatures As List(Of FileSignature)
    'Usage

Dim value As List(Of FileSignature)

DicomGlobal.PreambleFileSignatures = value

value = DicomGlobal.PreambleFileSignatures
    public static List<FileSignature> PreambleFileSignatures {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / PreferredBitmapMode Property

    PreferredBitmapMode Property
    Controls method of rendering used by "Bitmap"
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property PreferredBitmapMode As ViewerMode
    'Usage

Dim value As ViewerMode

DicomGlobal.PreferredBitmapMode = value

value = DicomGlobal.PreferredBitmapMode
    public static ViewerMode PreferredBitmapMode {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / PreserveDoublePrecision Property

    PreserveDoublePrecision Property
    Retain precision for double numbers
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property PreserveDoublePrecision As Boolean
    'Usage

Dim value As Boolean

DicomGlobal.PreserveDoublePrecision = value

value = DicomGlobal.PreserveDoublePrecision
    public static bool PreserveDoublePrecision {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ProductName Property

    ProductName Property
    The product name to be shown in licensing Dialogs etc. Default value is "DicomObjects".
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property ProductName As String
    'Usage

Dim value As String

DicomGlobal.ProductName = value

value = DicomGlobal.ProductName
    public static string ProductName {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / QuadrupedDirectionStrings Property

    QuadrupedDirectionStrings Property
    The quadruped equivalent of DirectionStrings allowing localisation of these abbreviations
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property QuadrupedDirectionStrings As String()
    'Usage

Dim value() As String

DicomGlobal.QuadrupedDirectionStrings = value

value = DicomGlobal.QuadrupedDirectionStrings
    public static string[] QuadrupedDirectionStrings {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / RenderException Property

    RenderException Property
    Controls whether non-image objects throw an exception during rendering
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property RenderException As Boolean
    'Usage

Dim value As Boolean

DicomGlobal.RenderException = value

value = DicomGlobal.RenderException
    public static bool RenderException {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ReUseArrays Property

    ReUseArrays Property
    Controls whether DicomObjcts re-uses arrays to hold pixel data
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property ReUseArrays As Boolean
    'Usage

Dim value As Boolean

DicomGlobal.ReUseArrays = value

value = DicomGlobal.ReUseArrays
    public static bool ReUseArrays {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ReuseOnlyExactArraySize Property

    ReuseOnlyExactArraySize Property
    Controls whether "Over-sized" arrays are used
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property ReuseOnlyExactArraySize As Boolean
    'Usage

Dim value As Boolean

DicomGlobal.ReuseOnlyExactArraySize = value

value = DicomGlobal.ReuseOnlyExactArraySize
    public static bool ReuseOnlyExactArraySize {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / RunningInDocker Property

    RunningInDocker Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly Property RunningInDocker As Boolean
    'Usage

Dim value As Boolean

value = DicomGlobal.RunningInDocker
    public static bool RunningInDocker {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ShowTextBoxForPresentationStates Property

    ShowTextBoxForPresentationStates Property
    Controls whether bounding boxes are drawn around internally generated DicomLabel objects derived from text entries in Presentation States
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property ShowTextBoxForPresentationStates As Boolean
    'Usage

Dim value As Boolean

DicomGlobal.ShowTextBoxForPresentationStates = value

value = DicomGlobal.ShowTextBoxForPresentationStates
    public static bool ShowTextBoxForPresentationStates {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / SignedLicencePrefix Property

    SignedLicencePrefix Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property SignedLicencePrefix As String
    'Usage

Dim value As String

DicomGlobal.SignedLicencePrefix = value

value = DicomGlobal.SignedLicencePrefix
    public static string SignedLicencePrefix {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ThreadCount Property

    ThreadCount Property
    Controls how many threads may be used by DicomObjects when rendering etc.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property ThreadCount As Integer
    'Usage

Dim value As Integer

DicomGlobal.ThreadCount = value

value = DicomGlobal.ThreadCount
    public static int ThreadCount {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / Timeout Property

    Timeout Property
    The period of time that a network operation will wait if there is no response from the peer
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property Timeout As Integer
    'Usage

Dim value As Integer

DicomGlobal.Timeout = value

value = DicomGlobal.Timeout
    public static int Timeout {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / UIDRoot Property

    UIDRoot Property
    UIDRoot used by the method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property UIDRoot As String
    'Usage

Dim value As String

DicomGlobal.UIDRoot = value

value = DicomGlobal.UIDRoot
    public static string UIDRoot {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / Use32BitTexture Property

    Use32BitTexture Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property Use32BitTexture As Boolean
    'Usage

Dim value As Boolean

DicomGlobal.Use32BitTexture = value

value = DicomGlobal.Use32BitTexture
    public static bool Use32BitTexture {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / UsePerformanceCounters Property

    UsePerformanceCounters Property
    Controls use of specific performance counters for DicomObjects
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property UsePerformanceCounters As Boolean
    'Usage

Dim value As Boolean

DicomGlobal.UsePerformanceCounters = value

value = DicomGlobal.UsePerformanceCounters
    public static bool UsePerformanceCounters {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / UsePixelCache Property

    UsePixelCache Property
    Controls whether to use an area of memory as a pixel cache to reduce demands on the memory allocator
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property UsePixelCache As Boolean
    'Usage

Dim value As Boolean

DicomGlobal.UsePixelCache = value

value = DicomGlobal.UsePixelCache
    public static bool UsePixelCache {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ValidDateMax Property

    ValidDateMax Property
    Maximum allowed DateTime for validation purposes Default value is DateTime.MaxValue
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property ValidDateMax As Date
    'Usage

Dim value As Date

DicomGlobal.ValidDateMax = value

value = DicomGlobal.ValidDateMax
    public static DateTime ValidDateMax {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ValidDateMin Property

    ValidDateMin Property
    Minimum allowed DateTime for validation purposes Default value is DateTime.MinValue
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property ValidDateMin As Date
    'Usage

Dim value As Date

DicomGlobal.ValidDateMin = value

value = DicomGlobal.ValidDateMin
    public static DateTime ValidDateMin {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


%%PageItemTitle%% $$Events$$

DicomObjects Namespace / DicomGlobal Class

    DicomGlobal Class Events
    In This Topic

    For a list of all members of this type, see DicomGlobal members.

    Public Events
     | Name | Description
Public Event | LogEvent | Event fires when loggable events occur
Public Event | OnChangeUid | Event fired when DicomObjects should change a UID for an object
Public Event | ValidateFragments | Routine to allow validation (and if necessary, correction) of fragments of compressed pixel data
    Top
    See Also

    Reference

    DicomGlobal Class
    DicomObjects Namespace


DicomObjects Namespace / DicomGlobal Class / LogEvent Event

    LogEvent Event
    Event fires when loggable events occur
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event LogEvent As LogHandler
    'Usage

Dim instance As DicomGlobal
Dim handler As LogHandler

AddHandler instance.LogEvent, handler
    public event LogHandler LogEvent
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / OnChangeUid Event

    OnChangeUid Event
    Event fired when DicomObjects should change a UID for an object
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event OnChangeUid As ChangeUidHandler
    'Usage

Dim instance As DicomGlobal
Dim handler As ChangeUidHandler

AddHandler instance.OnChangeUid, handler
    public event ChangeUidHandler OnChangeUid
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ValidateFragments Event

    ValidateFragments Event
    Routine to allow validation (and if necessary, correction) of fragments of compressed pixel data
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event ValidateFragments As Action(Of ValidateFragmentsArgs)
    'Usage

Dim instance As DicomGlobal
Dim handler As Action(Of ValidateFragmentsArgs)

AddHandler instance.ValidateFragments, handler
    public event Action<ValidateFragmentsArgs> ValidateFragments
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


%%PageItemTitle%%

DicomObjects Namespace / DicomLicence Class
Members

In This Topic
    DicomLicence Class
    In This Topic
    Object Model
    DicomLicence ClassDicomLicence ClassDicomLicence Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public NotInheritable Class DicomLicence
    'Usage

Dim instance As DicomLicence
    public sealed class DicomLicence
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomLicence

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomLicence Class
Properties Methods Events

In This Topic
    DicomLicence Class Members
    In This Topic

    The following tables list the members exposed by DicomLicence.

    Public Properties
     | Name | Description
static (Shared in Visual Basic) | BestLicence |
static (Shared in Visual Basic) | CurrentLicence |
Public Property | Expiry |
static (Shared in Visual Basic) | ExpiryWarningDays |
static (Shared in Visual Basic) | InstalledLicences |
static (Shared in Visual Basic) | LicenceServer |
static (Shared in Visual Basic) | LicenceServerCount |
static (Shared in Visual Basic) | MachineId |
static (Shared in Visual Basic) | ProxyDomain |
static (Shared in Visual Basic) | ProxyPassword |
static (Shared in Visual Basic) | ProxyUsername |
Public Property | Source |
Public Property | Token |
Public Property | Type |
    Top
    Public Methods
     | Name | Description
static (Shared in Visual Basic) | ActivateConcurrent |
static (Shared in Visual Basic) | ActivateOffLine |
static (Shared in Visual Basic) | ActivateOnLine |
static (Shared in Visual Basic) | ActivateSigned |
Public Method | Deactivate |
static (Shared in Visual Basic) | DeactivateAll |
Public Method | Equals |
Public Method | GetHashCode |
Public Method | ToString |
    Top
    Public Events
     | Name | Description
Public Event | LicenceExpired |
Public Event | LicenceRetrieve |
Public Event | LicenceStore |
    Top
    See Also

    Reference

    DicomLicence Class
    DicomObjects Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomLicence Class

    DicomLicence Class Methods
    In This Topic

    For a list of all members of this type, see DicomLicence members.

    Public Methods
     | Name | Description
static (Shared in Visual Basic) | ActivateConcurrent |
static (Shared in Visual Basic) | ActivateOffLine |
static (Shared in Visual Basic) | ActivateOnLine |
static (Shared in Visual Basic) | ActivateSigned |
Public Method | Deactivate |
static (Shared in Visual Basic) | DeactivateAll |
Public Method | Equals |
Public Method | GetHashCode |
Public Method | ToString |
    Top
    See Also

    Reference

    DicomLicence Class
    DicomObjects Namespace


DicomObjects Namespace / DicomLicence Class / ActivateConcurrent Method

    ActivateConcurrent Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function ActivateConcurrent( _
   ByVal licenceKey As String, _
   ByVal activationInfo1 As String, _
   ByVal activationInfo2 As String, _
   ByRef result As String _
) As DicomLicence
    'Usage

Dim licenceKey As String
Dim activationInfo1 As String
Dim activationInfo2 As String
Dim result As String
Dim value As DicomLicence

value = DicomLicence.ActivateConcurrent(licenceKey, activationInfo1, activationInfo2, result)
    public static DicomLicence ActivateConcurrent(
   string licenceKey,
   string activationInfo1,
   string activationInfo2,
   out string result
)

    Parameters

    licenceKey
    activationInfo1
    activationInfo2
    result
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / ActivateOffLine Method

    ActivateOffLine Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function ActivateOffLine( _
   ByVal licenceKey As String, _
   ByVal licenceToken As String, _
   ByRef result As String _
) As DicomLicence
    'Usage

Dim licenceKey As String
Dim licenceToken As String
Dim result As String
Dim value As DicomLicence

value = DicomLicence.ActivateOffLine(licenceKey, licenceToken, result)
    public static DicomLicence ActivateOffLine(
   string licenceKey,
   string licenceToken,
   out string result
)

    Parameters

    licenceKey
    licenceToken
    result
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / ActivateOnLine Method

    ActivateOnLine Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function ActivateOnLine( _
   ByVal licenceKey As String, _
   ByVal activationInfo1 As String, _
   ByVal activationInfo2 As String, _
   ByRef result As String _
) As DicomLicence
    'Usage

Dim licenceKey As String
Dim activationInfo1 As String
Dim activationInfo2 As String
Dim result As String
Dim value As DicomLicence

value = DicomLicence.ActivateOnLine(licenceKey, activationInfo1, activationInfo2, result)
    public static DicomLicence ActivateOnLine(
   string licenceKey,
   string activationInfo1,
   string activationInfo2,
   out string result
)

    Parameters

    licenceKey
    activationInfo1
    activationInfo2
    result
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / ActivateSigned Method

    ActivateSigned Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function ActivateSigned( _
   ByVal licenceKey As String, _
   ByVal activationInfo1 As String, _
   ByVal activationInfo2 As String, _
   ByRef result As String, _
   Optional ByVal expiryDate As Date _
) As DicomLicence
    'Usage

Dim licenceKey As String
Dim activationInfo1 As String
Dim activationInfo2 As String
Dim result As String
Dim expiryDate As Date
Dim value As DicomLicence

value = DicomLicence.ActivateSigned(licenceKey, activationInfo1, activationInfo2, result, expiryDate)
    public static DicomLicence ActivateSigned(
   string licenceKey,
   string activationInfo1,
   string activationInfo2,
   out string result,
   DateTime expiryDate
)

    Parameters

    licenceKey
    activationInfo1
    activationInfo2
    result
    expiryDate
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / Deactivate Method

    Deactivate Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub Deactivate( _
   ByVal deactivationInfo1 As String, _
   ByVal deactivationInfo2 As String _
)
    'Usage

Dim instance As DicomLicence
Dim deactivationInfo1 As String
Dim deactivationInfo2 As String

instance.Deactivate(deactivationInfo1, deactivationInfo2)
    public void Deactivate(
   string deactivationInfo1,
   string deactivationInfo2
)

    Parameters

    deactivationInfo1
    deactivationInfo2
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / DeactivateAll Method

    DeactivateAll Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Sub DeactivateAll( _
   ByVal deactivationInfo1 As String, _
   ByVal deactivationInfo2 As String _
)
    'Usage

Dim deactivationInfo1 As String
Dim deactivationInfo2 As String

DicomLicence.DeactivateAll(deactivationInfo1, deactivationInfo2)
    public static void DeactivateAll(
   string deactivationInfo1,
   string deactivationInfo2
)

    Parameters

    deactivationInfo1
    deactivationInfo2
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / Equals Method

    Equals Method (DicomLicence)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
    'Usage

Dim instance As DicomLicence
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
    public override bool Equals(
   object obj
)

    Parameters

    obj
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members
    Base Implementation in Equals


DicomObjects Namespace / DicomLicence Class / GetHashCode Method

    GetHashCode Method (DicomLicence)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overrides Function GetHashCode() As Integer
    'Usage

Dim instance As DicomLicence
Dim value As Integer

value = instance.GetHashCode()
    public override int GetHashCode()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members
    Base Implementation in GetHashCode


DicomObjects Namespace / DicomLicence Class / ToString Method

    ToString Method (DicomLicence)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overrides Function ToString() As String
    'Usage

Dim instance As DicomLicence
Dim value As String

value = instance.ToString()
    public override string ToString()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members
    Base Implementation in ToString


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomLicence Class

    DicomLicence Class Properties
    In This Topic

    For a list of all members of this type, see DicomLicence members.

    Public Properties
     | Name | Description
static (Shared in Visual Basic) | BestLicence |
static (Shared in Visual Basic) | CurrentLicence |
Public Property | Expiry |
static (Shared in Visual Basic) | ExpiryWarningDays |
static (Shared in Visual Basic) | InstalledLicences |
static (Shared in Visual Basic) | LicenceServer |
static (Shared in Visual Basic) | LicenceServerCount |
static (Shared in Visual Basic) | MachineId |
static (Shared in Visual Basic) | ProxyDomain |
static (Shared in Visual Basic) | ProxyPassword |
static (Shared in Visual Basic) | ProxyUsername |
Public Property | Source |
Public Property | Token |
Public Property | Type |
    Top
    See Also

    Reference

    DicomLicence Class
    DicomObjects Namespace


DicomObjects Namespace / DicomLicence Class / BestLicence Property

    BestLicence Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly Property BestLicence As DicomLicence
    'Usage

Dim value As DicomLicence

value = DicomLicence.BestLicence
    public static DicomLicence BestLicence {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / CurrentLicence Property

    CurrentLicence Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property CurrentLicence As DicomLicence
    'Usage

Dim value As DicomLicence

DicomLicence.CurrentLicence = value

value = DicomLicence.CurrentLicence
    public static DicomLicence CurrentLicence {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / Expiry Property

    Expiry Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Expiry As Date
    'Usage

Dim instance As DicomLicence
Dim value As Date

value = instance.Expiry
    public DateTime Expiry {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / ExpiryWarningDays Property

    ExpiryWarningDays Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property ExpiryWarningDays As Integer
    'Usage

Dim value As Integer

DicomLicence.ExpiryWarningDays = value

value = DicomLicence.ExpiryWarningDays
    public static int ExpiryWarningDays {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / InstalledLicences Property

    InstalledLicences Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly Property InstalledLicences As IEnumerable(Of DicomLicence)
    'Usage

Dim value As IEnumerable(Of DicomLicence)

value = DicomLicence.InstalledLicences
    public static IEnumerable<DicomLicence> InstalledLicences {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / LicenceServer Property

    LicenceServer Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property LicenceServer As String
    'Usage

Dim value As String

DicomLicence.LicenceServer = value

value = DicomLicence.LicenceServer
    public static string LicenceServer {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / LicenceServerCount Property

    LicenceServerCount Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property LicenceServerCount As Integer
    'Usage

Dim value As Integer

DicomLicence.LicenceServerCount = value

value = DicomLicence.LicenceServerCount
    public static int LicenceServerCount {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / MachineId Property

    MachineId Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly Property MachineId As String
    'Usage

Dim value As String

value = DicomLicence.MachineId
    public static string MachineId {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / ProxyDomain Property

    ProxyDomain Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property ProxyDomain As String
    'Usage

Dim value As String

DicomLicence.ProxyDomain = value

value = DicomLicence.ProxyDomain
    public static string ProxyDomain {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / ProxyPassword Property

    ProxyPassword Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property ProxyPassword As String
    'Usage

Dim value As String

DicomLicence.ProxyPassword = value

value = DicomLicence.ProxyPassword
    public static string ProxyPassword {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / ProxyUsername Property

    ProxyUsername Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property ProxyUsername As String
    'Usage

Dim value As String

DicomLicence.ProxyUsername = value

value = DicomLicence.ProxyUsername
    public static string ProxyUsername {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / Source Property

    Source Property (DicomLicence)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Source As String
    'Usage

Dim instance As DicomLicence
Dim value As String

value = instance.Source
    public string Source {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / Token Property

    Token Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Token As String
    'Usage

Dim instance As DicomLicence
Dim value As String

value = instance.Token
    public string Token {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / Type Property

    Type Property (DicomLicence)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Type As LicenceTypes
    'Usage

Dim instance As DicomLicence
Dim value As LicenceTypes

value = instance.Type
    public LicenceTypes Type {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


%%PageItemTitle%% $$Events$$

DicomObjects Namespace / DicomLicence Class

    DicomLicence Class Events
    In This Topic

    For a list of all members of this type, see DicomLicence members.

    Public Events
     | Name | Description
Public Event | LicenceExpired |
Public Event | LicenceRetrieve |
Public Event | LicenceStore |
    Top
    See Also

    Reference

    DicomLicence Class
    DicomObjects Namespace


DicomObjects Namespace / DicomLicence Class / LicenceExpired Event

    LicenceExpired Event
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event LicenceExpired As LicenceExpirationHandler
    'Usage

Dim instance As DicomLicence
Dim handler As LicenceExpirationHandler

AddHandler instance.LicenceExpired, handler
    public event LicenceExpirationHandler LicenceExpired
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / LicenceRetrieve Event

    LicenceRetrieve Event
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event LicenceRetrieve As LicenceRetrieveHandler
    'Usage

Dim instance As DicomLicence
Dim handler As LicenceRetrieveHandler

AddHandler instance.LicenceRetrieve, handler
    public event LicenceRetrieveHandler LicenceRetrieve
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / LicenceStore Event

    LicenceStore Event
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event LicenceStore As LicenceStoredHandler
    'Usage

Dim instance As DicomLicence
Dim handler As LicenceStoredHandler

AddHandler instance.LicenceStore, handler
    public event LicenceStoredHandler LicenceStore
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


%%PageItemTitle%%

DicomObjects Namespace / DicomMaskRange Class
Members

In This Topic
    DicomMaskRange Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class DicomMaskRange
    'Usage

Dim instance As DicomMaskRange
    public class DicomMaskRange
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomMaskRange

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomMaskRange Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomMaskRange Class
Properties

In This Topic
    DicomMaskRange Class Members
    In This Topic

    The following tables list the members exposed by DicomMaskRange.

    Public Constructors
     | Name | Description
Public Constructor | DicomMaskRange Constructor |
    Top
    Public Properties
     | Name | Description
Public Property | ApplicableFrames |
Public Property | MaskFraction |
Public Property | MaskFrames |
Public Property | MaskShift |
Public Property | Mode |
Public Property | NumberOfContrastFrames |
Public Property | TIDOffset |
    Top
    See Also

    Reference

    DicomMaskRange Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / DicomMaskRange Class / DicomMaskRange Constructor

In This Topic
    DicomMaskRange Constructor
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New()
    'Usage

Dim instance As New DicomMaskRange()
    public DicomMaskRange()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomMaskRange Class
    DicomMaskRange Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomMaskRange Class

    DicomMaskRange Class Properties
    In This Topic

    For a list of all members of this type, see DicomMaskRange members.

    Public Properties
     | Name | Description
Public Property | ApplicableFrames |
Public Property | MaskFraction |
Public Property | MaskFrames |
Public Property | MaskShift |
Public Property | Mode |
Public Property | NumberOfContrastFrames |
Public Property | TIDOffset |
    Top
    See Also

    Reference

    DicomMaskRange Class
    DicomObjects Namespace


DicomObjects Namespace / DicomMaskRange Class / ApplicableFrames Property

    ApplicableFrames Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property ApplicableFrames As Integer()
    'Usage

Dim instance As DicomMaskRange
Dim value() As Integer

instance.ApplicableFrames = value

value = instance.ApplicableFrames
    public int[] ApplicableFrames {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomMaskRange Class
    DicomMaskRange Members


DicomObjects Namespace / DicomMaskRange Class / MaskFraction Property

    MaskFraction Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property MaskFraction As Single
    'Usage

Dim instance As DicomMaskRange
Dim value As Single

instance.MaskFraction = value

value = instance.MaskFraction
    public float MaskFraction {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomMaskRange Class
    DicomMaskRange Members


DicomObjects Namespace / DicomMaskRange Class / MaskFrames Property

    MaskFrames Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property MaskFrames As Integer()
    'Usage

Dim instance As DicomMaskRange
Dim value() As Integer

instance.MaskFrames = value

value = instance.MaskFrames
    public int[] MaskFrames {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomMaskRange Class
    DicomMaskRange Members


DicomObjects Namespace / DicomMaskRange Class / MaskShift Property

    MaskShift Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property MaskShift As PointF
    'Usage

Dim instance As DicomMaskRange
Dim value As PointF

instance.MaskShift = value

value = instance.MaskShift
    public PointF MaskShift {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomMaskRange Class
    DicomMaskRange Members


DicomObjects Namespace / DicomMaskRange Class / Mode Property

    Mode Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Mode As MaskMode
    'Usage

Dim instance As DicomMaskRange
Dim value As MaskMode

instance.Mode = value

value = instance.Mode
    public MaskMode Mode {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomMaskRange Class
    DicomMaskRange Members


DicomObjects Namespace / DicomMaskRange Class / NumberOfContrastFrames Property

    NumberOfContrastFrames Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property NumberOfContrastFrames As Integer
    'Usage

Dim instance As DicomMaskRange
Dim value As Integer

instance.NumberOfContrastFrames = value

value = instance.NumberOfContrastFrames
    public int NumberOfContrastFrames {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomMaskRange Class
    DicomMaskRange Members


DicomObjects Namespace / DicomMaskRange Class / TIDOffset Property

    TIDOffset Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property TIDOffset As Integer
    'Usage

Dim instance As DicomMaskRange
Dim value As Integer

instance.TIDOffset = value

value = instance.TIDOffset
    public int TIDOffset {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomMaskRange Class
    DicomMaskRange Members


%%PageItemTitle%%

DicomObjects Namespace / DicomQuery Class
Members

In This Topic
    DicomQuery Class
    In This Topic
    Object used for DICOM Query/retrieve SCU operations
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class DicomQuery
    'Usage

Dim instance As DicomQuery
    public class DicomQuery
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomQuery

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomQuery Class
Properties Methods Events

In This Topic
    DicomQuery Class Members
    In This Topic

    The following tables list the members exposed by DicomQuery.

    Public Constructors
     | Name | Description
Public Constructor | DicomQuery Constructor | Create a new DicomQuery Object
    Top
    Public Properties
     | Name | Description
Public Property | CalculatedFrameList | Specify the list of frames (by triplets with the starting frame, ending frame and frame step) for Frame Level Retrival
Public Property | CalledAE | The Application Entity Title of the server providing the Query/Retrieve service to which the DicomQuery object is requesting a connection
Public Property | CallingAE | The Application Entity Title by which the DicomQuery object is to be known during its connection to the server providing the Query/Retrieve service
Public Property | DateOfBirth | Demographic details of the patient
Public Property | Destination | The Application Entity Name to which images should be sent by a C-MOVE request
Public Property | FrameTimes | Specify the range of frames by frame time, used for Frame Level Retrival
Public Property | InstanceUID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Level | Define the level of query or retrieve request within the DICOM search hierarchies.
Public Property | Name | Demographic details of the patient
Public Property | NoBulkData | Specify if bulk data is required in the FrameLevelRetrieve C-GET response
Public Property | Node | The IP address at which the Query/Retrieve service to which the DicomQuery object is requesting a connection may be found
Public Property | PatientID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Port | The TCP port at which the Query/Retrieve service to which the DicomQuery object is requesting a connection is listening
Public Property | Root | Define the type of query requested within the DICOM search hierarchies.
Public Property | SeriesUID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Sex | Demographic details of the patient
Public Property | SimpleFrameList | Specify the list of single frames (by frame number) for Frame Level Retrival
Public Property | StudyDate | The date or date range to be searched for suitable studies
Public Property | StudyUID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Tag | A general purpose Tag for developer use
Public Property | TransferSyntaxes | Controls the allowed transfer syntaxes for outgoing operations (C-FIND, C-MOVE & C-GET)
    Top
    Public Methods
     | Name | Description
Public Method | Find | Overloaded. Perform a C-FIND as SCU
Public Method | Get | Overloaded. Perform a C-GET as SCU
Public Method | Move | Overloaded. Perform a C-MOVE as SCU
Public Method | QueryDataSet | Returns the dataset which would have been used by Find method.
Public Method | RetrieveDataSet | Returns the DataSet which would have been used by Get or Move method
    Top
    Public Events
     | Name | Description
Public Event | InitiateTls | Routine to use to generate encrypted stream when TLS is to be used for outgoing associations.
Public Event | ResponseReceived | Event fires when a response is received on an out-going operation
    Top
    See Also

    Reference

    DicomQuery Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / DicomQuery Class / DicomQuery Constructor

In This Topic
    DicomQuery Constructor
    In This Topic
    Create a new DicomQuery Object
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New()
    'Usage

Dim instance As New DicomQuery()
    public DicomQuery()

    Return Value

    DicomQuery
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomQuery Class

    DicomQuery Class Methods
    In This Topic

    For a list of all members of this type, see DicomQuery members.

    Public Methods
     | Name | Description
Public Method | Find | Overloaded. Perform a C-FIND as SCU
Public Method | Get | Overloaded. Perform a C-GET as SCU
Public Method | Move | Overloaded. Perform a C-MOVE as SCU
Public Method | QueryDataSet | Returns the dataset which would have been used by Find method.
Public Method | RetrieveDataSet | Returns the DataSet which would have been used by Get or Move method
    Top
    See Also

    Reference

    DicomQuery Class
    DicomObjects Namespace


DicomObjects Namespace / DicomQuery Class / Find Method

    Find Method (DicomQuery)
    In This Topic
    Perform a C-FIND as SCU
    Overload List
    Overload | Description
Find() | Perform a C-FIND as SCU
Find(DicomDataSet) | Perform a C-FIND as SCU with search criteria.
Find(DicomAssociation,DicomDataSet) | Perform a C-FIND as SCU with search criteria.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / Find Method / Find() Method

    Find() Method
    Perform a C-FIND as SCU
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function Find() As DicomDataSetCollection
    'Usage

Dim instance As DicomQuery
Dim value As DicomDataSetCollection

value = instance.Find()
    public DicomDataSetCollection Find()

    Return Value

    DicomDataSetCollection
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members
    Overload List


DicomObjects Namespace / DicomQuery Class / Find Method / Find(DicomDataSet) Method

DicomDataSet containing the search criteria

    Find(DicomDataSet) Method
    In This Topic
    Perform a C-FIND as SCU with search criteria.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function Find( _
   ByVal Request As DicomDataSet _
) As DicomDataSetCollection
    'Usage

Dim instance As DicomQuery
Dim Request As DicomDataSet
Dim value As DicomDataSetCollection

value = instance.Find(Request)
    public DicomDataSetCollection Find(
   DicomDataSet Request
)

    Parameters

    Request

    DicomDataSet containing the search criteria

    Return Value

    DicomDataSetCollection
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members
    Overload List


DicomObjects Namespace / DicomQuery Class / Find Method / Find(DicomAssociation,DicomDataSet) Method

DicomAssociation Exposes the underlying DICOM association object

DicomDataSet containing the search criteria

In This Topic
    Find(DicomAssociation,DicomDataSet) Method
    In This Topic
    Perform a C-FIND as SCU with search criteria.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function Find( _
   ByVal Association As DicomAssociation, _
   ByVal Request As DicomDataSet _
) As DicomDataSetCollection
    'Usage

Dim instance As DicomQuery
Dim Association As DicomAssociation
Dim Request As DicomDataSet
Dim value As DicomDataSetCollection

value = instance.Find(Association, Request)
    public DicomDataSetCollection Find(
   DicomAssociation Association,
   DicomDataSet Request
)

    Parameters

    Association

    DicomAssociation Exposes the underlying DICOM association object

    Request

    DicomDataSet containing the search criteria

    Return Value

    DicomDataSetCollection
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members
    Overload List


DicomObjects Namespace / DicomQuery Class / Get Method

    Get Method (DicomQuery)
    In This Topic
    Perform a C-GET as SCU
    Overload List
    Overload | Description
Get() | Perform a C-GET as SCU
Get(DicomDataSet) | Perform a C-GET as SCU with matching criteria
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / Get Method / Get() Method

    Get() Method
    Perform a C-GET as SCU
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function Get() As DicomDataSetCollection
    'Usage

Dim instance As DicomQuery
Dim value As DicomDataSetCollection

value = instance.Get()
    public DicomDataSetCollection Get()

    Return Value

    DicomDataSetCollection
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members
    Overload List


DicomObjects Namespace / DicomQuery Class / Get Method / Get(DicomDataSet) Method

DicomDataSet containing the search criteria

    Get(DicomDataSet) Method
    In This Topic
    Perform a C-GET as SCU with matching criteria
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function Get( _
   ByVal Request As DicomDataSet _
) As DicomDataSetCollection
    'Usage

Dim instance As DicomQuery
Dim Request As DicomDataSet
Dim value As DicomDataSetCollection

value = instance.Get(Request)
    public DicomDataSetCollection Get(
   DicomDataSet Request
)

    Parameters

    Request

    DicomDataSet containing the search criteria

    Return Value

    DicomDataSetCollection

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members
    Overload List


DicomObjects Namespace / DicomQuery Class / Move Method

    Move Method (DicomQuery)
    In This Topic
    Perform a C-MOVE as SCU
    Overload List
    Overload | Description
Move() | Perform a C-MOVE as SCU
Move(DicomDataSet) | Perform a C-MOVE as SCU with matching criteria
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / Move Method / Move() Method

    Move() Method
    Perform a C-MOVE as SCU
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function Move() As DicomDataSet
    'Usage

Dim instance As DicomQuery
Dim value As DicomDataSet

value = instance.Move()
    public DicomDataSet Move()

    Return Value

    DicomDataSet, which contains the final response from SCP.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members
    Overload List


DicomObjects Namespace / DicomQuery Class / Move Method / Move(DicomDataSet) Method

DicomDataSet containing the search criteria

    Move(DicomDataSet) Method
    In This Topic
    Perform a C-MOVE as SCU with matching criteria
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function Move( _
   ByVal Request As DicomDataSet _
) As DicomDataSet
    'Usage

Dim instance As DicomQuery
Dim Request As DicomDataSet
Dim value As DicomDataSet

value = instance.Move(Request)
    public DicomDataSet Move(
   DicomDataSet Request
)

    Parameters

    Request

    DicomDataSet containing the search criteria

    Return Value

    DicomDataSet, which contains the final response from SCP.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members
    Overload List


DicomObjects Namespace / DicomQuery Class / QueryDataSet Method

    QueryDataSet Method (DicomQuery)
    In This Topic
    Returns the dataset which would have been used by Find method.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function QueryDataSet() As DicomDataSet
    'Usage

Dim instance As DicomQuery
Dim value As DicomDataSet

value = instance.QueryDataSet()
    public DicomDataSet QueryDataSet()

    Return Value

    DicomDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / RetrieveDataSet Method

    RetrieveDataSet Method
    Returns the DataSet which would have been used by Get or Move method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function RetrieveDataSet() As DicomDataSet
    'Usage

Dim instance As DicomQuery
Dim value As DicomDataSet

value = instance.RetrieveDataSet()
    public DicomDataSet RetrieveDataSet()

    Return Value

    DicomDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomQuery Class

    DicomQuery Class Properties
    In This Topic

    For a list of all members of this type, see DicomQuery members.

    Public Properties
     | Name | Description
Public Property | CalculatedFrameList | Specify the list of frames (by triplets with the starting frame, ending frame and frame step) for Frame Level Retrival
Public Property | CalledAE | The Application Entity Title of the server providing the Query/Retrieve service to which the DicomQuery object is requesting a connection
Public Property | CallingAE | The Application Entity Title by which the DicomQuery object is to be known during its connection to the server providing the Query/Retrieve service
Public Property | DateOfBirth | Demographic details of the patient
Public Property | Destination | The Application Entity Name to which images should be sent by a C-MOVE request
Public Property | FrameTimes | Specify the range of frames by frame time, used for Frame Level Retrival
Public Property | InstanceUID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Level | Define the level of query or retrieve request within the DICOM search hierarchies.
Public Property | Name | Demographic details of the patient
Public Property | NoBulkData | Specify if bulk data is required in the FrameLevelRetrieve C-GET response
Public Property | Node | The IP address at which the Query/Retrieve service to which the DicomQuery object is requesting a connection may be found
Public Property | PatientID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Port | The TCP port at which the Query/Retrieve service to which the DicomQuery object is requesting a connection is listening
Public Property | Root | Define the type of query requested within the DICOM search hierarchies.
Public Property | SeriesUID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Sex | Demographic details of the patient
Public Property | SimpleFrameList | Specify the list of single frames (by frame number) for Frame Level Retrival
Public Property | StudyDate | The date or date range to be searched for suitable studies
Public Property | StudyUID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Tag | A general purpose Tag for developer use
Public Property | TransferSyntaxes | Controls the allowed transfer syntaxes for outgoing operations (C-FIND, C-MOVE & C-GET)
    Top
    See Also

    Reference

    DicomQuery Class
    DicomObjects Namespace


DicomObjects Namespace / DicomQuery Class / CalculatedFrameList Property

    CalculatedFrameList Property
    Specify the list of frames (by triplets with the starting frame, ending frame and frame step) for Frame Level Retrival
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property CalculatedFrameList As Integer()
    'Usage

Dim instance As DicomQuery
Dim value() As Integer

instance.CalculatedFrameList = value

value = instance.CalculatedFrameList
    public int[] CalculatedFrameList {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / CalledAE Property

    CalledAE Property
    The Application Entity Title of the server providing the Query/Retrieve service to which the DicomQuery object is requesting a connection
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property CalledAE As String
    'Usage

Dim instance As DicomQuery
Dim value As String

instance.CalledAE = value

value = instance.CalledAE
    public string CalledAE {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / CallingAE Property

    CallingAE Property
    The Application Entity Title by which the DicomQuery object is to be known during its connection to the server providing the Query/Retrieve service
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property CallingAE As String
    'Usage

Dim instance As DicomQuery
Dim value As String

instance.CallingAE = value

value = instance.CallingAE
    public string CallingAE {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / DateOfBirth Property

    DateOfBirth Property (DicomQuery)
    In This Topic
    Demographic details of the patient
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property DateOfBirth As String
    'Usage

Dim instance As DicomQuery
Dim value As String

instance.DateOfBirth = value

value = instance.DateOfBirth
    public string DateOfBirth {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / Destination Property

    Destination Property (DicomQuery)
    In This Topic
    The Application Entity Name to which images should be sent by a C-MOVE request
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Destination As String
    'Usage

Dim instance As DicomQuery
Dim value As String

instance.Destination = value

value = instance.Destination
    public string Destination {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / FrameTimes Property

    FrameTimes Property
    Specify the range of frames by frame time, used for Frame Level Retrival
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property FrameTimes As Date()
    'Usage

Dim instance As DicomQuery
Dim value() As Date

instance.FrameTimes = value

value = instance.FrameTimes
    public DateTime[] FrameTimes {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / InstanceUID Property

    InstanceUID Property (DicomQuery)
    In This Topic
    Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property InstanceUID As String
    'Usage

Dim instance As DicomQuery
Dim value As String

instance.InstanceUID = value

value = instance.InstanceUID
    public string InstanceUID {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / Level Property

    Level Property (DicomQuery)
    In This Topic
    Define the level of query or retrieve request within the DICOM search hierarchies.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Level As QueryLevel
    'Usage

Dim instance As DicomQuery
Dim value As QueryLevel

instance.Level = value

value = instance.Level
    public QueryLevel Level {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / Name Property

    Name Property (DicomQuery)
    In This Topic
    Demographic details of the patient
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Name As String
    'Usage

Dim instance As DicomQuery
Dim value As String

instance.Name = value

value = instance.Name
    public string Name {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / NoBulkData Property

    NoBulkData Property
    Specify if bulk data is required in the FrameLevelRetrieve C-GET response
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property NoBulkData As Boolean
    'Usage

Dim instance As DicomQuery
Dim value As Boolean

instance.NoBulkData = value

value = instance.NoBulkData
    public bool NoBulkData {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / Node Property

    Node Property
    The IP address at which the Query/Retrieve service to which the DicomQuery object is requesting a connection may be found
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Node As String
    'Usage

Dim instance As DicomQuery
Dim value As String

instance.Node = value

value = instance.Node
    public string Node {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / PatientID Property

    PatientID Property (DicomQuery)
    In This Topic
    Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property PatientID As String
    'Usage

Dim instance As DicomQuery
Dim value As String

instance.PatientID = value

value = instance.PatientID
    public string PatientID {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / Port Property

    Port Property
    The TCP port at which the Query/Retrieve service to which the DicomQuery object is requesting a connection is listening
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Port As Integer
    'Usage

Dim instance As DicomQuery
Dim value As Integer

instance.Port = value

value = instance.Port
    public int Port {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / Root Property

    Root Property (DicomQuery)
    In This Topic
    Define the type of query requested within the DICOM search hierarchies.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Root As QueryRoot
    'Usage

Dim instance As DicomQuery
Dim value As QueryRoot

instance.Root = value

value = instance.Root
    public QueryRoot Root {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / SeriesUID Property

    SeriesUID Property (DicomQuery)
    In This Topic
    Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property SeriesUID As String
    'Usage

Dim instance As DicomQuery
Dim value As String

instance.SeriesUID = value

value = instance.SeriesUID
    public string SeriesUID {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / Sex Property

    Sex Property (DicomQuery)
    In This Topic
    Demographic details of the patient
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Sex As String
    'Usage

Dim instance As DicomQuery
Dim value As String

instance.Sex = value

value = instance.Sex
    public string Sex {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / SimpleFrameList Property

    SimpleFrameList Property
    Specify the list of single frames (by frame number) for Frame Level Retrival
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property SimpleFrameList As Integer()
    'Usage

Dim instance As DicomQuery
Dim value() As Integer

instance.SimpleFrameList = value

value = instance.SimpleFrameList
    public int[] SimpleFrameList {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / StudyDate Property

    StudyDate Property
    The date or date range to be searched for suitable studies
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property StudyDate As String
    'Usage

Dim instance As DicomQuery
Dim value As String

instance.StudyDate = value

value = instance.StudyDate
    public string StudyDate {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / StudyUID Property

    StudyUID Property (DicomQuery)
    In This Topic
    Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property StudyUID As String
    'Usage

Dim instance As DicomQuery
Dim value As String

instance.StudyUID = value

value = instance.StudyUID
    public string StudyUID {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / Tag Property

    Tag Property (DicomQuery)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Tag As Object
    'Usage

Dim instance As DicomQuery
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / TransferSyntaxes Property

    TransferSyntaxes Property (DicomQuery)
    In This Topic
    Controls the allowed transfer syntaxes for outgoing operations (C-FIND, C-MOVE & C-GET)
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property TransferSyntaxes As String
    'Usage

Dim instance As DicomQuery
Dim value As String

instance.TransferSyntaxes = value

value = instance.TransferSyntaxes
    public string TransferSyntaxes {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


%%PageItemTitle%% $$Events$$

DicomObjects Namespace / DicomQuery Class

    DicomQuery Class Events
    In This Topic

    For a list of all members of this type, see DicomQuery members.

    Public Events
     | Name | Description
Public Event | InitiateTls | Routine to use to generate encrypted stream when TLS is to be used for outgoing associations.
Public Event | ResponseReceived | Event fires when a response is received on an out-going operation
    Top
    See Also

    Reference

    DicomQuery Class
    DicomObjects Namespace


DicomObjects Namespace / DicomQuery Class / InitiateTls Event

    InitiateTls Event (DicomQuery)
    In This Topic
    Routine to use to generate encrypted stream when TLS is to be used for outgoing associations.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event InitiateTls As TlsInitiator
    'Usage

Dim instance As DicomQuery
Dim handler As TlsInitiator

AddHandler instance.InitiateTls, handler
    public event TlsInitiator InitiateTls
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / ResponseReceived Event

    ResponseReceived Event (DicomQuery)
    In This Topic
    Event fires when a response is received on an out-going operation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event ResponseReceived As ResponseReceivedHandler
    'Usage

Dim instance As DicomQuery
Dim handler As ResponseReceivedHandler

AddHandler instance.ResponseReceived, handler
    public event ResponseReceivedHandler ResponseReceived
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


%%PageItemTitle%%

DicomObjects Namespace / DicomServer Class
Members

In This Topic
    DicomServer Class
    In This Topic
    An object for handling advanced network communications, as both SCU & SCP
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class DicomServer
    'Usage

Dim instance As DicomServer
    public class DicomServer
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomServer

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomServer Class
Properties Methods Events

In This Topic
    DicomServer Class Members
    In This Topic

    The following tables list the members exposed by DicomServer.

    Public Constructors
     | Name | Description
Public Constructor | DicomServer Constructor | Creates a DicomServer object
    Top
    Public Properties
     | Name | Description
Public Property | AllowExtendedNegotiation | Controls whether extended negotation should be supported (as initiator or acceptor)
Public Property | AssociationCount | The number of associations currently open on this server
Public Property | DefaultStatus | The default status code to be returned in response to incoming requests
Public Property | NewAssociationType | This property is for user derived DicomAssociation
Public Property | Tag | A general purpose Tag for developer use
    Top
    Public Methods
     | Name | Description
Public Method | AbortAssociations | Aborts all related associations
Public Method | Accept | Means to allow DICOM negotiation on an existing socket
Public Method | Dispose | Release all system resources used by DicomServer object
Public Method | Listen | Overloaded. Open a TCP port to listen for incoming DICOM Connections
Public Method | Unlisten | Overloaded. Close a "Listening" TCP port, specified by the port number, for incoming DICOM Connections
Public Method | UnlistenAll | Close all "Listening" TCP ports for incoming DICOM Connections
    Top
    Public Events
     | Name | Description
Public Event | AssociationClosed | Event fired when an incoming DICOM association is closed
Public Event | AssociationRequest | Event fired when the object receives a DICOM connection request
Public Event | CStoreRequest |
Public Event | ErrorReceived | This event fires when an error is detected in received data
Public Event | InfoMessage | Passes information back to the container for error messages and notifications originating from the DICOM interface.
Public Event | InstanceReceived | This event is fired whenever a C-STORE operation completes, passing details of the instance received
Public Event | N_Event_Report | This event handler is fired on SCU when an N-EVENT-REPORT notification is received from the SCP.
Public Event | NormalisedReceived | This event fires when an incoming normalised request is received
Public Event | QueryReceived | Event fired when the object receives a DICOM C-FIND,C-GET or C-MOVE request
Public Event | ReceivingPixelData | Event called when pixel data is being received
Public Event | VerifyReceived | This event fires when a C-ECHO command (verification request) is received
    Top
    See Also

    Reference

    DicomServer Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / DicomServer Class / DicomServer Constructor

In This Topic
    DicomServer Constructor
    In This Topic
    Creates a DicomServer object
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New()
    'Usage

Dim instance As New DicomServer()
    public DicomServer()

    Return Value

    DicomServer
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomServer Class

    DicomServer Class Methods
    In This Topic

    For a list of all members of this type, see DicomServer members.

    Public Methods
     | Name | Description
Public Method | AbortAssociations | Aborts all related associations
Public Method | Accept | Means to allow DICOM negotiation on an existing socket
Public Method | Dispose | Release all system resources used by DicomServer object
Public Method | Listen | Overloaded. Open a TCP port to listen for incoming DICOM Connections
Public Method | Unlisten | Overloaded. Close a "Listening" TCP port, specified by the port number, for incoming DICOM Connections
Public Method | UnlistenAll | Close all "Listening" TCP ports for incoming DICOM Connections
    Top
    See Also

    Reference

    DicomServer Class
    DicomObjects Namespace


DicomObjects Namespace / DicomServer Class / AbortAssociations Method

    AbortAssociations Method
    Aborts all related associations
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub AbortAssociations()
    'Usage

Dim instance As DicomServer

instance.AbortAssociations()
    public void AbortAssociations()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / Accept Method
The underlying socket
A stream based on that socket

In This Topic
    Accept Method
    In This Topic
    Means to allow DICOM negotiation on an existing socket
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub Accept( _
   ByVal Socket As Socket, _
   ByVal Stream As Stream _
)
    'Usage

Dim instance As DicomServer
Dim Socket As Socket
Dim Stream As Stream

instance.Accept(Socket, Stream)
    public void Accept(
   Socket Socket,
   Stream Stream
)

    Parameters

    Socket
    The underlying socket
    Stream
    A stream based on that socket
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / Dispose Method

    Dispose Method (DicomServer)
    In This Topic
    Release all system resources used by DicomServer object
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overridable Sub Dispose()
    'Usage

Dim instance As DicomServer

instance.Dispose()
    public virtual void Dispose()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / Listen Method

    Listen Method
    Open a TCP port to listen for incoming DICOM Connections
    Overload List
    Overload | Description
Listen(Int32) | Open a TCP port to listen for incoming DICOM Connections
Listen(Int32,TlsAcceptor) | Open a TCP port to listen for secure incoming DICOM Connections
Listen(Int32,AddressFamily,TlsAcceptor) | Open a TCP port to listen for secure incoming DICOM Connections
Listen(Int32,String) | Open a TCP port to listen for incoming DICOM Connections, specified by port number and IP address
Listen(Int32,String,AddressFamily,TlsAcceptor) | Open a TCP port to listen for secure incoming DICOM Connections on a specific IP address
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / Listen Method / Listen(Int32) Method

The TCP port on which to receive connections

    Listen(Int32) Method
    In This Topic
    Open a TCP port to listen for incoming DICOM Connections
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Listen( _
   ByVal Port As Integer _
)
    'Usage

Dim instance As DicomServer
Dim Port As Integer

instance.Listen(Port)
    public void Listen(
   int Port
)

    Parameters

    Port

    The TCP port on which to receive connections

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members
    Overload List


DicomObjects Namespace / DicomServer Class / Listen Method / Listen(Int32,TlsAcceptor) Method

The TCP port on which to receive connections

The object used to accept secure connections

In This Topic
    Listen(Int32,TlsAcceptor) Method
    In This Topic
    Open a TCP port to listen for secure incoming DICOM Connections
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Listen( _
   ByVal Port As Integer, _
   ByVal AcceptTls As TlsAcceptor _
)
    'Usage

Dim instance As DicomServer
Dim Port As Integer
Dim AcceptTls As TlsAcceptor

instance.Listen(Port, AcceptTls)
    public void Listen(
   int Port,
   TlsAcceptor AcceptTls
)

    Parameters

    Port

    The TCP port on which to receive connections

    AcceptTls

    The object used to accept secure connections

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members
    Overload List


DicomObjects Namespace / DicomServer Class / Listen Method / Listen(Int32,AddressFamily,TlsAcceptor) Method

The TCP port on which to receive connections

The address family to use (IPv4 or IPv6)

The object used to accept secure connections

In This Topic
    Listen(Int32,AddressFamily,TlsAcceptor) Method
    In This Topic
    Open a TCP port to listen for secure incoming DICOM Connections
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Listen( _
   ByVal Port As Integer, _
   ByVal IpAddressFamily As AddressFamily, _
   ByVal AcceptTls As TlsAcceptor _
)
    'Usage

Dim instance As DicomServer
Dim Port As Integer
Dim IpAddressFamily As AddressFamily
Dim AcceptTls As TlsAcceptor

instance.Listen(Port, IpAddressFamily, AcceptTls)
    public void Listen(
   int Port,
   AddressFamily IpAddressFamily,
   TlsAcceptor AcceptTls
)

    Parameters

    Port

    The TCP port on which to receive connections

    IpAddressFamily

    The address family to use (IPv4 or IPv6)

    AcceptTls

    The object used to accept secure connections

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members
    Overload List


DicomObjects Namespace / DicomServer Class / Listen Method / Listen(Int32,String) Method

The TCP port on which to receive connections

IP address to listen on

In This Topic
    Listen(Int32,String) Method
    In This Topic
    Open a TCP port to listen for incoming DICOM Connections, specified by port number and IP address
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Listen( _
   ByVal Port As Integer, _
   ByVal Address As String _
)
    'Usage

Dim instance As DicomServer
Dim Port As Integer
Dim Address As String

instance.Listen(Port, Address)
    public void Listen(
   int Port,
   string Address
)

    Parameters

    Port

    The TCP port on which to receive connections

    Address

    IP address to listen on

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members
    Overload List


DicomObjects Namespace / DicomServer Class / Listen Method / Listen(Int32,String,AddressFamily,TlsAcceptor) Method

The TCP port on which to receive connections

The address to listen on

The address family to use (IPv4 or IPv6)

The object used to accept secure connections

In This Topic
    Listen(Int32,String,AddressFamily,TlsAcceptor) Method
    In This Topic
    Open a TCP port to listen for secure incoming DICOM Connections on a specific IP address
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Listen( _
   ByVal Port As Integer, _
   ByVal Address As String, _
   ByVal IpAddressFamily As AddressFamily, _
   ByVal AcceptTls As TlsAcceptor _
)
    'Usage

Dim instance As DicomServer
Dim Port As Integer
Dim Address As String
Dim IpAddressFamily As AddressFamily
Dim AcceptTls As TlsAcceptor

instance.Listen(Port, Address, IpAddressFamily, AcceptTls)
    public void Listen(
   int Port,
   string Address,
   AddressFamily IpAddressFamily,
   TlsAcceptor AcceptTls
)

    Parameters

    Port

    The TCP port on which to receive connections

    Address

    The address to listen on

    IpAddressFamily

    The address family to use (IPv4 or IPv6)

    AcceptTls

    The object used to accept secure connections

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members
    Overload List


DicomObjects Namespace / DicomServer Class / Unlisten Method

    Unlisten Method
    Close a "Listening" TCP port, specified by the port number, for incoming DICOM Connections
    Overload List
    Overload | Description
Unlisten(Int32) | Close a "Listening" TCP port, specified by the port number, for incoming DICOM Connections
Unlisten(Int32,String) | Close a "Listening" TCP port, specified by the port number and IP address, for incoming DICOM Connections
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / Unlisten Method / Unlisten(Int32) Method

The port number which is to be closed for incoming connection.

In This Topic
    Unlisten(Int32) Method
    In This Topic
    Close a "Listening" TCP port, specified by the port number, for incoming DICOM Connections
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Unlisten( _
   ByVal Port As Integer _
)
    'Usage

Dim instance As DicomServer
Dim Port As Integer

instance.Unlisten(Port)
    public void Unlisten(
   int Port
)

    Parameters

    Port

    The port number which is to be closed for incoming connection.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members
    Overload List


DicomObjects Namespace / DicomServer Class / Unlisten Method / Unlisten(Int32,String) Method

The port number which is to be closed for incoming connection

IP address to listen on

In This Topic
    Unlisten(Int32,String) Method
    In This Topic
    Close a "Listening" TCP port, specified by the port number and IP address, for incoming DICOM Connections
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Unlisten( _
   ByVal Port As Integer, _
   ByVal Address As String _
)
    'Usage

Dim instance As DicomServer
Dim Port As Integer
Dim Address As String

instance.Unlisten(Port, Address)
    public void Unlisten(
   int Port,
   string Address
)

    Parameters

    Port

    The port number which is to be closed for incoming connection

    Address

    IP address to listen on

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members
    Overload List


DicomObjects Namespace / DicomServer Class / UnlistenAll Method

    UnlistenAll Method
    Close all "Listening" TCP ports for incoming DICOM Connections
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub UnlistenAll()
    'Usage

Dim instance As DicomServer

instance.UnlistenAll()
    public void UnlistenAll()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomServer Class

    DicomServer Class Properties
    In This Topic

    For a list of all members of this type, see DicomServer members.

    Public Properties
     | Name | Description
Public Property | AllowExtendedNegotiation | Controls whether extended negotation should be supported (as initiator or acceptor)
Public Property | AssociationCount | The number of associations currently open on this server
Public Property | DefaultStatus | The default status code to be returned in response to incoming requests
Public Property | NewAssociationType | This property is for user derived DicomAssociation
Public Property | Tag | A general purpose Tag for developer use
    Top
    See Also

    Reference

    DicomServer Class
    DicomObjects Namespace


DicomObjects Namespace / DicomServer Class / AllowExtendedNegotiation Property

    AllowExtendedNegotiation Property
    Controls whether extended negotation should be supported (as initiator or acceptor)
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property AllowExtendedNegotiation As Boolean
    'Usage

Dim instance As DicomServer
Dim value As Boolean

instance.AllowExtendedNegotiation = value

value = instance.AllowExtendedNegotiation
    public bool AllowExtendedNegotiation {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / AssociationCount Property

    AssociationCount Property
    The number of associations currently open on this server
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property AssociationCount As Integer
    'Usage

Dim instance As DicomServer
Dim value As Integer

value = instance.AssociationCount
    public int AssociationCount {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / DefaultStatus Property

    DefaultStatus Property
    The default status code to be returned in response to incoming requests
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property DefaultStatus As Integer
    'Usage

Dim instance As DicomServer
Dim value As Integer

instance.DefaultStatus = value

value = instance.DefaultStatus
    public int DefaultStatus {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / NewAssociationType Property

    NewAssociationType Property
    This property is for user derived DicomAssociation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property NewAssociationType As Type
    'Usage

Dim instance As DicomServer
Dim value As Type

instance.NewAssociationType = value

value = instance.NewAssociationType
    public Type NewAssociationType {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / Tag Property

    Tag Property (DicomServer)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Tag As Object
    'Usage

Dim instance As DicomServer
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


%%PageItemTitle%% $$Events$$

DicomObjects Namespace / DicomServer Class

    DicomServer Class Events
    In This Topic

    For a list of all members of this type, see DicomServer members.

    Public Events
     | Name | Description
Public Event | AssociationClosed | Event fired when an incoming DICOM association is closed
Public Event | AssociationRequest | Event fired when the object receives a DICOM connection request
Public Event | CStoreRequest |
Public Event | ErrorReceived | This event fires when an error is detected in received data
Public Event | InfoMessage | Passes information back to the container for error messages and notifications originating from the DICOM interface.
Public Event | InstanceReceived | This event is fired whenever a C-STORE operation completes, passing details of the instance received
Public Event | N_Event_Report | This event handler is fired on SCU when an N-EVENT-REPORT notification is received from the SCP.
Public Event | NormalisedReceived | This event fires when an incoming normalised request is received
Public Event | QueryReceived | Event fired when the object receives a DICOM C-FIND,C-GET or C-MOVE request
Public Event | ReceivingPixelData | Event called when pixel data is being received
Public Event | VerifyReceived | This event fires when a C-ECHO command (verification request) is received
    Top
    See Also

    Reference

    DicomServer Class
    DicomObjects Namespace


DicomObjects Namespace / DicomServer Class / AssociationClosed Event

    AssociationClosed Event
    Event fired when an incoming DICOM association is closed
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event AssociationClosed As AssociationClosedHandler
    'Usage

Dim instance As DicomServer
Dim handler As AssociationClosedHandler

AddHandler instance.AssociationClosed, handler
    public event AssociationClosedHandler AssociationClosed
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / AssociationRequest Event

    AssociationRequest Event
    Event fired when the object receives a DICOM connection request
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event AssociationRequest As AssociationRequestHandler
    'Usage

Dim instance As DicomServer
Dim handler As AssociationRequestHandler

AddHandler instance.AssociationRequest, handler
    public event AssociationRequestHandler AssociationRequest
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / CStoreRequest Event

    CStoreRequest Event
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event CStoreRequest As CStoreRequestHandler
    'Usage

Dim instance As DicomServer
Dim handler As CStoreRequestHandler

AddHandler instance.CStoreRequest, handler
    public event CStoreRequestHandler CStoreRequest
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / ErrorReceived Event

    ErrorReceived Event
    This event fires when an error is detected in received data
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event ErrorReceived As ErrorReceivedHandler
    'Usage

Dim instance As DicomServer
Dim handler As ErrorReceivedHandler

AddHandler instance.ErrorReceived, handler
    public event ErrorReceivedHandler ErrorReceived
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / InfoMessage Event

    InfoMessage Event
    Passes information back to the container for error messages and notifications originating from the DICOM interface.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event InfoMessage As InfoMessageHandler
    'Usage

Dim instance As DicomServer
Dim handler As InfoMessageHandler

AddHandler instance.InfoMessage, handler
    public event InfoMessageHandler InfoMessage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / InstanceReceived Event

    InstanceReceived Event
    This event is fired whenever a C-STORE operation completes, passing details of the instance received
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event InstanceReceived As InstanceReceivedHandler
    'Usage

Dim instance As DicomServer
Dim handler As InstanceReceivedHandler

AddHandler instance.InstanceReceived, handler
    public event InstanceReceivedHandler InstanceReceived
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / N_Event_Report Event

    N_Event_Report Event (DicomServer)
    In This Topic
    This event handler is fired on SCU when an N-EVENT-REPORT notification is received from the SCP.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event N_Event_Report As N_Event_ReportHandler
    'Usage

Dim instance As DicomServer
Dim handler As N_Event_ReportHandler

AddHandler instance.N_Event_Report, handler
    public event N_Event_ReportHandler N_Event_Report
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / NormalisedReceived Event

    NormalisedReceived Event
    This event fires when an incoming normalised request is received
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event NormalisedReceived As NormalisedReceivedHandler
    'Usage

Dim instance As DicomServer
Dim handler As NormalisedReceivedHandler

AddHandler instance.NormalisedReceived, handler
    public event NormalisedReceivedHandler NormalisedReceived
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / QueryReceived Event

    QueryReceived Event
    Event fired when the object receives a DICOM C-FIND,C-GET or C-MOVE request
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event QueryReceived As QueryReceivedHandler
    'Usage

Dim instance As DicomServer
Dim handler As QueryReceivedHandler

AddHandler instance.QueryReceived, handler
    public event QueryReceivedHandler QueryReceived
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / ReceivingPixelData Event

    ReceivingPixelData Event
    Event called when pixel data is being received
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event ReceivingPixelData As ReceivingPixelDataHandler
    'Usage

Dim instance As DicomServer
Dim handler As ReceivingPixelDataHandler

AddHandler instance.ReceivingPixelData, handler
    public event ReceivingPixelDataHandler ReceivingPixelData
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / VerifyReceived Event

    VerifyReceived Event
    This event fires when a C-ECHO command (verification request) is received
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event VerifyReceived As VerifyReceivedHandler
    'Usage

Dim instance As DicomServer
Dim handler As VerifyReceivedHandler

AddHandler instance.VerifyReceived, handler
    public event VerifyReceivedHandler VerifyReceived
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


%%PageItemTitle%%

DicomObjects Namespace / ReadBehaviours Class
Members

In This Topic
    ReadBehaviours Class
    In This Topic
    Specific behaviour to use when reading/receiving a DICOM instance
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class ReadBehaviours
    'Usage

Dim instance As ReadBehaviours
    public class ReadBehaviours
    Inheritance Hierarchy

    System.Object
    DicomObjects.ReadBehaviours

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / ReadBehaviours Class
Properties

In This Topic
    ReadBehaviours Class Members
    In This Topic

    The following tables list the members exposed by ReadBehaviours.

    Public Constructors
     | Name | Description
Public Constructor | ReadBehaviours Constructor | Create a new ReadBehaviours object
    Top
    Public Properties
     | Name | Description
Public Property | BlankTransferSyntax | A default transfer syntax value for DicomObjects when reading DICOM image with missing transfer syntax value.
Public Property | CloseFilesAfterReading | Controls how pixel data is read from disk
Public Property | DiscardBadIcons | Controls how "bad icons" are handled.
Public Property | DontReadPixels | Can disable reading of pixel values
Public Property | IgnoreAfterPixels | Controls whether all data after the pixel data is to be ignored.
Public Property | IgnoreAfterTag | Controls whether all data after a specifc tag is to be ignored. Value shall be in ggggeeee hex format, such as 0x00100010 for patient name.
Public Property | IgnoreBOT | Ignore any Basic Offset Table which may be present in the received data
Public Property | IgnoreExceptions | Ignores a list of DicomObjects error codes accessible from during reading from disk/network and puts together what has been successfully read. This is particularly useful to skip exceptions and keep the association open to continue reading.
Public Property | IgnoreIconLengths | Ignore the lengths of the pixel data in icon sequences
Public Property | IgnorePrivateSequences | If set, private sequence items are skipped.
Public Property | SilentEndOfFileReached | Set to true to tell DicomObjects to not throw End Of File Reached exception and stop reading from file when an attribute with bad length is encountered. Default value is false
Public Property | ThrowNotDICOMDIRError | Controls whether to throw an exception if a file which is apparently a DICOM does not contain the expected DICOMDIR offset attributes.
Public Property | TolerateBadOffsets | Ignore bad "offset" data when reading a DICOMDIR
Public Property | ZeissBug | A workaround for old bad Zeiss Data, some of which had UT attributes with 2 Bytes length
    Top
    See Also

    Reference

    ReadBehaviours Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / ReadBehaviours Class / ReadBehaviours Constructor

In This Topic
    ReadBehaviours Constructor
    In This Topic
    Create a new ReadBehaviours object
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New()
    'Usage

Dim instance As New ReadBehaviours()
    public ReadBehaviours()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / ReadBehaviours Class

    ReadBehaviours Class Properties
    In This Topic

    For a list of all members of this type, see ReadBehaviours members.

    Public Properties
     | Name | Description
Public Property | BlankTransferSyntax | A default transfer syntax value for DicomObjects when reading DICOM image with missing transfer syntax value.
Public Property | CloseFilesAfterReading | Controls how pixel data is read from disk
Public Property | DiscardBadIcons | Controls how "bad icons" are handled.
Public Property | DontReadPixels | Can disable reading of pixel values
Public Property | IgnoreAfterPixels | Controls whether all data after the pixel data is to be ignored.
Public Property | IgnoreAfterTag | Controls whether all data after a specifc tag is to be ignored. Value shall be in ggggeeee hex format, such as 0x00100010 for patient name.
Public Property | IgnoreBOT | Ignore any Basic Offset Table which may be present in the received data
Public Property | IgnoreExceptions | Ignores a list of DicomObjects error codes accessible from during reading from disk/network and puts together what has been successfully read. This is particularly useful to skip exceptions and keep the association open to continue reading.
Public Property | IgnoreIconLengths | Ignore the lengths of the pixel data in icon sequences
Public Property | IgnorePrivateSequences | If set, private sequence items are skipped.
Public Property | SilentEndOfFileReached | Set to true to tell DicomObjects to not throw End Of File Reached exception and stop reading from file when an attribute with bad length is encountered. Default value is false
Public Property | ThrowNotDICOMDIRError | Controls whether to throw an exception if a file which is apparently a DICOM does not contain the expected DICOMDIR offset attributes.
Public Property | TolerateBadOffsets | Ignore bad "offset" data when reading a DICOMDIR
Public Property | ZeissBug | A workaround for old bad Zeiss Data, some of which had UT attributes with 2 Bytes length
    Top
    See Also

    Reference

    ReadBehaviours Class
    DicomObjects Namespace


DicomObjects Namespace / ReadBehaviours Class / BlankTransferSyntax Property

    BlankTransferSyntax Property
    A default transfer syntax value for DicomObjects when reading DICOM image with missing transfer syntax value.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property BlankTransferSyntax As String
    'Usage

Dim instance As ReadBehaviours
Dim value As String

instance.BlankTransferSyntax = value

value = instance.BlankTransferSyntax
    public string BlankTransferSyntax {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / CloseFilesAfterReading Property

    CloseFilesAfterReading Property (ReadBehaviours)
    In This Topic
    Controls how pixel data is read from disk
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property CloseFilesAfterReading As Boolean
    'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.CloseFilesAfterReading = value

value = instance.CloseFilesAfterReading
    public bool CloseFilesAfterReading {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / DiscardBadIcons Property

    DiscardBadIcons Property
    Controls how "bad icons" are handled.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property DiscardBadIcons As Boolean
    'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.DiscardBadIcons = value

value = instance.DiscardBadIcons
    public bool DiscardBadIcons {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / DontReadPixels Property

    DontReadPixels Property
    Can disable reading of pixel values
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property DontReadPixels As Boolean
    'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.DontReadPixels = value

value = instance.DontReadPixels
    public bool DontReadPixels {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / IgnoreAfterPixels Property

    IgnoreAfterPixels Property
    Controls whether all data after the pixel data is to be ignored.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property IgnoreAfterPixels As Boolean
    'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.IgnoreAfterPixels = value

value = instance.IgnoreAfterPixels
    public bool IgnoreAfterPixels {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / IgnoreAfterTag Property

    IgnoreAfterTag Property
    Controls whether all data after a specifc tag is to be ignored. Value shall be in ggggeeee hex format, such as 0x00100010 for patient name.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property IgnoreAfterTag As UInteger
    'Usage

Dim instance As ReadBehaviours
Dim value As UInteger

instance.IgnoreAfterTag = value

value = instance.IgnoreAfterTag
    public uint IgnoreAfterTag {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / IgnoreBOT Property

    IgnoreBOT Property
    Ignore any Basic Offset Table which may be present in the received data
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property IgnoreBOT As Boolean
    'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.IgnoreBOT = value

value = instance.IgnoreBOT
    public bool IgnoreBOT {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / IgnoreExceptions Property

    IgnoreExceptions Property
    Ignores a list of DicomObjects error codes accessible from during reading from disk/network and puts together what has been successfully read. This is particularly useful to skip exceptions and keep the association open to continue reading.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property IgnoreExceptions As Integer()
    'Usage

Dim instance As ReadBehaviours
Dim value() As Integer

instance.IgnoreExceptions = value

value = instance.IgnoreExceptions
    public int[] IgnoreExceptions {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / IgnoreIconLengths Property

    IgnoreIconLengths Property
    Ignore the lengths of the pixel data in icon sequences
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property IgnoreIconLengths As Boolean
    'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.IgnoreIconLengths = value

value = instance.IgnoreIconLengths
    public bool IgnoreIconLengths {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / IgnorePrivateSequences Property

    IgnorePrivateSequences Property
    If set, private sequence items are skipped.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property IgnorePrivateSequences As Boolean
    'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.IgnorePrivateSequences = value

value = instance.IgnorePrivateSequences
    public bool IgnorePrivateSequences {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / SilentEndOfFileReached Property

    SilentEndOfFileReached Property
    Set to true to tell DicomObjects to not throw End Of File Reached exception and stop reading from file when an attribute with bad length is encountered. Default value is false
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property SilentEndOfFileReached As Boolean
    'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.SilentEndOfFileReached = value

value = instance.SilentEndOfFileReached
    public bool SilentEndOfFileReached {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / ThrowNotDICOMDIRError Property

    ThrowNotDICOMDIRError Property
    Controls whether to throw an exception if a file which is apparently a DICOM does not contain the expected DICOMDIR offset attributes.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property ThrowNotDICOMDIRError As Boolean
    'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.ThrowNotDICOMDIRError = value

value = instance.ThrowNotDICOMDIRError
    public bool ThrowNotDICOMDIRError {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / TolerateBadOffsets Property

    TolerateBadOffsets Property
    Ignore bad "offset" data when reading a DICOMDIR
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property TolerateBadOffsets As Boolean
    'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.TolerateBadOffsets = value

value = instance.TolerateBadOffsets
    public bool TolerateBadOffsets {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / ZeissBug Property

    ZeissBug Property
    A workaround for old bad Zeiss Data, some of which had UT attributes with 2 Bytes length
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property ZeissBug As Boolean
    'Usage

Dim instance As ReadBehaviours
Dim value As Boolean

instance.ZeissBug = value

value = instance.ZeissBug
    public bool ZeissBug {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


%%PageItemTitle%%

DicomObjects Namespace / SequencePath Class
Members

In This Topic
    SequencePath Class
    In This Topic
    Object Model
    SequencePath ClassDicomDataSet ClassDicomAttribute ClassDicomAttribute Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class SequencePath
    'Usage

Dim instance As SequencePath
    public class SequencePath
    Inheritance Hierarchy

    System.Object
    DicomObjects.SequencePath

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SequencePath Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / SequencePath Class
Properties Methods

In This Topic
    SequencePath Class Members
    In This Topic

    The following tables list the members exposed by SequencePath.

    Public Properties
     | Name | Description
Public Property | DataSet |
Public Property | ParentAttributes |
Public Property | ParentSequenceItems |
Public Property | TargetAttribute |
    Top
    Public Methods
     | Name | Description
Public Method | Format |
    Top
    See Also

    Reference

    SequencePath Class
    DicomObjects Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / SequencePath Class

    SequencePath Class Methods
    In This Topic

    For a list of all members of this type, see SequencePath members.

    Public Methods
     | Name | Description
Public Method | Format |
    Top
    See Also

    Reference

    SequencePath Class
    DicomObjects Namespace


DicomObjects Namespace / SequencePath Class / Format Method

    Format Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function Format( _
   ByVal Basic As String, _
   ByVal Parents As String, _
   ByVal Bottom As String _
) As String
    'Usage

Dim instance As SequencePath
Dim Basic As String
Dim Parents As String
Dim Bottom As String
Dim value As String

value = instance.Format(Basic, Parents, Bottom)
    public string Format(
   string Basic,
   string Parents,
   string Bottom
)

    Parameters

    Basic
    Parents
    Bottom
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SequencePath Class
    SequencePath Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / SequencePath Class

    SequencePath Class Properties
    In This Topic

    For a list of all members of this type, see SequencePath members.

    Public Properties
     | Name | Description
Public Property | DataSet |
Public Property | ParentAttributes |
Public Property | ParentSequenceItems |
Public Property | TargetAttribute |
    Top
    See Also

    Reference

    SequencePath Class
    DicomObjects Namespace


DicomObjects Namespace / SequencePath Class / DataSet Property

    DataSet Property (SequencePath)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property DataSet As DicomDataSet
    'Usage

Dim instance As SequencePath
Dim value As DicomDataSet

value = instance.DataSet
    public DicomDataSet DataSet {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SequencePath Class
    SequencePath Members


DicomObjects Namespace / SequencePath Class / ParentAttributes Property

    ParentAttributes Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property ParentAttributes As List(Of DicomAttribute)
    'Usage

Dim instance As SequencePath
Dim value As List(Of DicomAttribute)

value = instance.ParentAttributes
    public List<DicomAttribute> ParentAttributes {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SequencePath Class
    SequencePath Members


DicomObjects Namespace / SequencePath Class / ParentSequenceItems Property

    ParentSequenceItems Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property ParentSequenceItems As List(Of Integer)
    'Usage

Dim instance As SequencePath
Dim value As List(Of Integer)

value = instance.ParentSequenceItems
    public List<int> ParentSequenceItems {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SequencePath Class
    SequencePath Members


DicomObjects Namespace / SequencePath Class / TargetAttribute Property

    TargetAttribute Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property TargetAttribute As DicomAttribute
    'Usage

Dim instance As SequencePath
Dim value As DicomAttribute

value = instance.TargetAttribute
    public DicomAttribute TargetAttribute {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SequencePath Class
    SequencePath Members


%%PageItemTitle%%

DicomObjects Namespace / WriteBehaviours Class
Members

In This Topic
    WriteBehaviours Class
    In This Topic
    Specific behaviour to use when writing/sending a DICOM instance
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class WriteBehaviours
    'Usage

Dim instance As WriteBehaviours
    public class WriteBehaviours
    Inheritance Hierarchy

    System.Object
    DicomObjects.WriteBehaviours

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / WriteBehaviours Class
Properties

In This Topic
    WriteBehaviours Class Members
    In This Topic

    The following tables list the members exposed by WriteBehaviours.

    Public Constructors
     | Name | Description
Public Constructor | WriteBehaviours Constructor | Create a new WriteBehaviours object
    Top
    Public Properties
     | Name | Description
Public Property | AllowOddLengths | Allows data to do be written with odd lengths
Public Property | ChangeLossyAttributes | Controls whether DicomObjects alters Lossy compression related attributes (for e.g. Instance UID, Source Image Sequence and Image Type) to reflect the change in data due to lossy compression. is a subset of this property where that only controls the UID changes but the other attributes are updated appropriately
Public Property | ChangeLossyUIDs | Controls whether DicomObjects changes the UID when doing lossy compression
Public Property | DontCompressIcons | Controls whether to compress icon pixcel data if using an encapsulated (compressed) transfer syntax.
Public Property | ImplicitSequenceItemLength | Controls whether sequence itemss are written out using Implicit or Explicit lengths for the sequence
Public Property | ImplicitSequenceLength | Controls whether sequences are written out using Implicit or Explicit lengths for the sequence
Public Property | NonSeekableBotHandling | Controls the creation of the Basic Offset Table (BOT) when writing data to non-seekable streams such as the network.
Public Property | OmitBOT |
Public Property | OmitJpegComments | Controls whether to include JPEG comments during compression
Public Property | RescaleCTs | Controls whether to make changes to the rescale slope and offset if compressing to a smaller range.
Public Property | SeekableBotHandling | Controls the creation of the Basic Offset Table (BOT) when writing data to seekable streams such as files.
    Top
    See Also

    Reference

    WriteBehaviours Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / WriteBehaviours Class / WriteBehaviours Constructor

In This Topic
    WriteBehaviours Constructor
    In This Topic
    Create a new WriteBehaviours object
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New()
    'Usage

Dim instance As New WriteBehaviours()
    public WriteBehaviours()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / WriteBehaviours Class

    WriteBehaviours Class Properties
    In This Topic

    For a list of all members of this type, see WriteBehaviours members.

    Public Properties
     | Name | Description
Public Property | AllowOddLengths | Allows data to do be written with odd lengths
Public Property | ChangeLossyAttributes | Controls whether DicomObjects alters Lossy compression related attributes (for e.g. Instance UID, Source Image Sequence and Image Type) to reflect the change in data due to lossy compression. is a subset of this property where that only controls the UID changes but the other attributes are updated appropriately
Public Property | ChangeLossyUIDs | Controls whether DicomObjects changes the UID when doing lossy compression
Public Property | DontCompressIcons | Controls whether to compress icon pixcel data if using an encapsulated (compressed) transfer syntax.
Public Property | ImplicitSequenceItemLength | Controls whether sequence itemss are written out using Implicit or Explicit lengths for the sequence
Public Property | ImplicitSequenceLength | Controls whether sequences are written out using Implicit or Explicit lengths for the sequence
Public Property | NonSeekableBotHandling | Controls the creation of the Basic Offset Table (BOT) when writing data to non-seekable streams such as the network.
Public Property | OmitBOT |
Public Property | OmitJpegComments | Controls whether to include JPEG comments during compression
Public Property | RescaleCTs | Controls whether to make changes to the rescale slope and offset if compressing to a smaller range.
Public Property | SeekableBotHandling | Controls the creation of the Basic Offset Table (BOT) when writing data to seekable streams such as files.
    Top
    See Also

    Reference

    WriteBehaviours Class
    DicomObjects Namespace


DicomObjects Namespace / WriteBehaviours Class / AllowOddLengths Property

    AllowOddLengths Property
    Allows data to do be written with odd lengths
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property AllowOddLengths As Boolean
    'Usage

Dim instance As WriteBehaviours
Dim value As Boolean

instance.AllowOddLengths = value

value = instance.AllowOddLengths
    public bool AllowOddLengths {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


DicomObjects Namespace / WriteBehaviours Class / ChangeLossyAttributes Property

    ChangeLossyAttributes Property
    Controls whether DicomObjects alters Lossy compression related attributes (for e.g. Instance UID, Source Image Sequence and Image Type) to reflect the change in data due to lossy compression. is a subset of this property where that only controls the UID changes but the other attributes are updated appropriately
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property ChangeLossyAttributes As Boolean
    'Usage

Dim instance As WriteBehaviours
Dim value As Boolean

instance.ChangeLossyAttributes = value

value = instance.ChangeLossyAttributes
    public bool ChangeLossyAttributes {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


DicomObjects Namespace / WriteBehaviours Class / ChangeLossyUIDs Property

    ChangeLossyUIDs Property (WriteBehaviours)
    In This Topic
    Controls whether DicomObjects changes the UID when doing lossy compression
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property ChangeLossyUIDs As Boolean
    'Usage

Dim instance As WriteBehaviours
Dim value As Boolean

instance.ChangeLossyUIDs = value

value = instance.ChangeLossyUIDs
    public bool ChangeLossyUIDs {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


DicomObjects Namespace / WriteBehaviours Class / DontCompressIcons Property

    DontCompressIcons Property
    Controls whether to compress icon pixcel data if using an encapsulated (compressed) transfer syntax.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property DontCompressIcons As Boolean
    'Usage

Dim instance As WriteBehaviours
Dim value As Boolean

instance.DontCompressIcons = value

value = instance.DontCompressIcons
    public bool DontCompressIcons {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


DicomObjects Namespace / WriteBehaviours Class / ImplicitSequenceItemLength Property

    ImplicitSequenceItemLength Property
    Controls whether sequence itemss are written out using Implicit or Explicit lengths for the sequence
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property ImplicitSequenceItemLength As Boolean
    'Usage

Dim instance As WriteBehaviours
Dim value As Boolean

instance.ImplicitSequenceItemLength = value

value = instance.ImplicitSequenceItemLength
    public bool ImplicitSequenceItemLength {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


DicomObjects Namespace / WriteBehaviours Class / ImplicitSequenceLength Property

    ImplicitSequenceLength Property
    Controls whether sequences are written out using Implicit or Explicit lengths for the sequence
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property ImplicitSequenceLength As Boolean
    'Usage

Dim instance As WriteBehaviours
Dim value As Boolean

instance.ImplicitSequenceLength = value

value = instance.ImplicitSequenceLength
    public bool ImplicitSequenceLength {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


DicomObjects Namespace / WriteBehaviours Class / NonSeekableBotHandling Property

    NonSeekableBotHandling Property
    Controls the creation of the Basic Offset Table (BOT) when writing data to non-seekable streams such as the network.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property NonSeekableBotHandling As BasicOffsetTableHandling
    'Usage

Dim instance As WriteBehaviours
Dim value As BasicOffsetTableHandling

instance.NonSeekableBotHandling = value

value = instance.NonSeekableBotHandling
    public BasicOffsetTableHandling NonSeekableBotHandling {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


DicomObjects Namespace / WriteBehaviours Class / OmitBOT Property

    OmitBOT Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Please use SeekableBotHandling & NonSeekableBotHandling for finer control")>
Public Property OmitBOT As Boolean
    'Usage

Dim instance As WriteBehaviours
Dim value As Boolean

instance.OmitBOT = value

value = instance.OmitBOT
    [Obsolete("Please use SeekableBotHandling & NonSeekableBotHandling for finer control")]
public bool OmitBOT {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


DicomObjects Namespace / WriteBehaviours Class / OmitJpegComments Property

    OmitJpegComments Property
    Controls whether to include JPEG comments during compression
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property OmitJpegComments As Boolean
    'Usage

Dim instance As WriteBehaviours
Dim value As Boolean

instance.OmitJpegComments = value

value = instance.OmitJpegComments
    public bool OmitJpegComments {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


DicomObjects Namespace / WriteBehaviours Class / RescaleCTs Property

    RescaleCTs Property
    Controls whether to make changes to the rescale slope and offset if compressing to a smaller range.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property RescaleCTs As Boolean
    'Usage

Dim instance As WriteBehaviours
Dim value As Boolean

instance.RescaleCTs = value

value = instance.RescaleCTs
    public bool RescaleCTs {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


DicomObjects Namespace / WriteBehaviours Class / SeekableBotHandling Property

    SeekableBotHandling Property
    Controls the creation of the Basic Offset Table (BOT) when writing data to seekable streams such as files.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property SeekableBotHandling As BasicOffsetTableHandling
    'Usage

Dim instance As WriteBehaviours
Dim value As BasicOffsetTableHandling

instance.SeekableBotHandling = value

value = instance.SeekableBotHandling
    public BasicOffsetTableHandling SeekableBotHandling {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


%%PageItemTitle%%

DicomObjects Namespace / DicomAttribute.DelayedDataRoutine Delegate

In This Topic
    DicomAttribute.DelayedDataRoutine Delegate
    In This Topic
    Delegate to fetch binary data for the bid
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Function DicomAttribute.DelayedDataRoutine( _
   ByVal ds As DicomDataSet _
) As Byte()
    'Usage

Dim instance As New DicomAttribute.DelayedDataRoutine(AddressOf HandlerMethod)
    public delegate byte[] DicomAttribute.DelayedDataRoutine(
   DicomDataSet ds
)

    Parameters

    ds

    Return Value

    Binary data as byte[]
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute.DelayedDataRoutine Members
    DicomObjects Namespace


Inheritance Hierarchy
    DicomObjects.Codecs Namespace
    Classes
     | Class | Description
Class | CodecFactory |
Class | CodecGlobal |
Class | CompressionArguments |
Class | DecompressionArguments |
Class | DicomCodecBaseArguments |
Class | ImportArguments |
Class | Jpeg2000CompressionOptions |
Class | JpegLossless |
Class | JpegLossy |
Class | JpegLSCompressionOptions |
Class | Jpip |
Class | ModificationArguments |
Class | SimpleCodec |
    Interfaces
     | Interface | Description
Interface | ICodecBase |
Interface | ICompressor |
Interface | IDecompressor |
Interface | IExporter |
Interface | IImporter |
    See Also

    Reference

    DicomObjects.Core Assembly


%%PageItemTitle%%

DicomObjects.Codecs Namespace / CodecFactory Class
Members

In This Topic
    CodecFactory Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MustInherit Class CodecFactory
    'Usage

Dim instance As CodecFactory
    public abstract class CodecFactory
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.CodecFactory

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CodecFactory Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / CodecFactory Class
Methods

In This Topic
    CodecFactory Class Members
    In This Topic

    The following tables list the members exposed by CodecFactory.

    Public Methods
     | Name | Description
Public Method | CheckStart |
Public Method | Compressor |
Public Method | Decompressor |
Public Method | Exporter |
Public Method | Importer |
Public Method | SupportedTransferSyntaxes |
    Top
    See Also

    Reference

    CodecFactory Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.Codecs Namespace / CodecFactory Class

    CodecFactory Class Methods
    In This Topic

    For a list of all members of this type, see CodecFactory members.

    Public Methods
     | Name | Description
Public Method | CheckStart |
Public Method | Compressor |
Public Method | Decompressor |
Public Method | Exporter |
Public Method | Importer |
Public Method | SupportedTransferSyntaxes |
    Top
    See Also

    Reference

    CodecFactory Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / CodecFactory Class / CheckStart Method

    CheckStart Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MustOverride Function CheckStart( _
   ByVal stream As Stream, _
   ByVal TransferSyntax As String _
) As Boolean
    'Usage

Dim instance As CodecFactory
Dim stream As Stream
Dim TransferSyntax As String
Dim value As Boolean

value = instance.CheckStart(stream, TransferSyntax)
    public abstract bool CheckStart(
   Stream stream,
   string TransferSyntax
)

    Parameters

    stream
    TransferSyntax
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CodecFactory Class
    CodecFactory Members


DicomObjects.Codecs Namespace / CodecFactory Class / Compressor Method

    Compressor Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MustOverride Function Compressor( _
   ByVal TransferSyntax As String _
) As ICompressor
    'Usage

Dim instance As CodecFactory
Dim TransferSyntax As String
Dim value As ICompressor

value = instance.Compressor(TransferSyntax)
    public abstract ICompressor Compressor(
   string TransferSyntax
)

    Parameters

    TransferSyntax
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CodecFactory Class
    CodecFactory Members


DicomObjects.Codecs Namespace / CodecFactory Class / Decompressor Method

    Decompressor Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MustOverride Function Decompressor( _
   ByVal TransferSyntax As String, _
   ByVal Data As Stream, _
   ByVal DataSet As DicomDataSet, _
   ByVal Frame As Integer _
) As IDecompressor
    'Usage

Dim instance As CodecFactory
Dim TransferSyntax As String
Dim Data As Stream
Dim DataSet As DicomDataSet
Dim Frame As Integer
Dim value As IDecompressor

value = instance.Decompressor(TransferSyntax, Data, DataSet, Frame)
    public abstract IDecompressor Decompressor(
   string TransferSyntax,
   Stream Data,
   DicomDataSet DataSet,
   int Frame
)

    Parameters

    TransferSyntax
    Data
    DataSet
    Frame
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CodecFactory Class
    CodecFactory Members


DicomObjects.Codecs Namespace / CodecFactory Class / Exporter Method

    Exporter Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MustOverride Function Exporter( _
   ByVal Format As String _
) As IExporter
    'Usage

Dim instance As CodecFactory
Dim Format As String
Dim value As IExporter

value = instance.Exporter(Format)
    public abstract IExporter Exporter(
   string Format
)

    Parameters

    Format
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CodecFactory Class
    CodecFactory Members


DicomObjects.Codecs Namespace / CodecFactory Class / Importer Method

    Importer Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MustOverride Function Importer( _
   ByVal Format As String _
) As IImporter
    'Usage

Dim instance As CodecFactory
Dim Format As String
Dim value As IImporter

value = instance.Importer(Format)
    public abstract IImporter Importer(
   string Format
)

    Parameters

    Format
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CodecFactory Class
    CodecFactory Members


DicomObjects.Codecs Namespace / CodecFactory Class / SupportedTransferSyntaxes Method

    SupportedTransferSyntaxes Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MustOverride Function SupportedTransferSyntaxes( _
   ByVal Operation As CodecOperation _
) As String()
    'Usage

Dim instance As CodecFactory
Dim Operation As CodecOperation
Dim value() As String

value = instance.SupportedTransferSyntaxes(Operation)
    public abstract string[] SupportedTransferSyntaxes(
   CodecOperation Operation
)

    Parameters

    Operation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CodecFactory Class
    CodecFactory Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / CodecGlobal Class
Members

In This Topic
    CodecGlobal Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MustInherit NotInheritable Class CodecGlobal
    'Usage

Dim instance As CodecGlobal
    public static class CodecGlobal
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.CodecGlobal

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CodecGlobal Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / CodecGlobal Class
Methods

In This Topic
    CodecGlobal Class Members
    In This Topic

    The following tables list the members exposed by CodecGlobal.

    Public Methods
     | Name | Description
static (Shared in Visual Basic) | AddCodec | Overloaded.
static (Shared in Visual Basic) | AvailableTransferSyntaxes |
static (Shared in Visual Basic) | Decompress |
static (Shared in Visual Basic) | RegisterCodec |
    Top
    See Also

    Reference

    CodecGlobal Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.Codecs Namespace / CodecGlobal Class

    CodecGlobal Class Methods
    In This Topic

    For a list of all members of this type, see CodecGlobal members.

    Public Methods
     | Name | Description
static (Shared in Visual Basic) | AddCodec | Overloaded.
static (Shared in Visual Basic) | AvailableTransferSyntaxes |
static (Shared in Visual Basic) | Decompress |
static (Shared in Visual Basic) | RegisterCodec |
    Top
    See Also

    Reference

    CodecGlobal Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / CodecGlobal Class / AddCodec Method

    AddCodec Method
    Overload List
    Overload | Description
AddCodec(Assembly) |
AddCodec(String) |
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CodecGlobal Class
    CodecGlobal Members


DicomObjects.Codecs Namespace / CodecGlobal Class / AddCodec Method / AddCodec(Assembly) Method

    AddCodec(Assembly) Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Shared Sub AddCodec( _
   ByVal Assembly As Assembly _
)
    'Usage

Dim Assembly As Assembly

CodecGlobal.AddCodec(Assembly)
    public static void AddCodec(
   Assembly Assembly
)

    Parameters

    Assembly
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CodecGlobal Class
    CodecGlobal Members
    Overload List


DicomObjects.Codecs Namespace / CodecGlobal Class / AddCodec Method / AddCodec(String) Method

    AddCodec(String) Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Shared Sub AddCodec( _
   ByVal AsemblyFilename As String _
)
    'Usage

Dim AsemblyFilename As String

CodecGlobal.AddCodec(AsemblyFilename)
    public static void AddCodec(
   string AsemblyFilename
)

    Parameters

    AsemblyFilename
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CodecGlobal Class
    CodecGlobal Members
    Overload List


DicomObjects.Codecs Namespace / CodecGlobal Class / AvailableTransferSyntaxes Method

    AvailableTransferSyntaxes Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function AvailableTransferSyntaxes( _
   ByVal IncludeOnlyCompress As Boolean, _
   ByVal IncludeOnlyDecompress As Boolean _
) As String()
    'Usage

Dim IncludeOnlyCompress As Boolean
Dim IncludeOnlyDecompress As Boolean
Dim value() As String

value = CodecGlobal.AvailableTransferSyntaxes(IncludeOnlyCompress, IncludeOnlyDecompress)
    public static string[] AvailableTransferSyntaxes(
   bool IncludeOnlyCompress,
   bool IncludeOnlyDecompress
)

    Parameters

    IncludeOnlyCompress
    IncludeOnlyDecompress
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CodecGlobal Class
    CodecGlobal Members


DicomObjects.Codecs Namespace / CodecGlobal Class / Decompress Method

    Decompress Method (CodecGlobal)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Sub Decompress( _
   ByVal CompressedData As Stream, _
   ByVal DestinationData As Array, _
   ByVal Size As Size, _
   ByVal Bits As Integer, _
   ByVal Planes As Integer, _
   ByVal TransferSyntax As String _
)
    'Usage

Dim CompressedData As Stream
Dim DestinationData As Array
Dim Size As Size
Dim Bits As Integer
Dim Planes As Integer
Dim TransferSyntax As String

CodecGlobal.Decompress(CompressedData, DestinationData, Size, Bits, Planes, TransferSyntax)
    public static void Decompress(
   Stream CompressedData,
   Array DestinationData,
   Size Size,
   int Bits,
   int Planes,
   string TransferSyntax
)

    Parameters

    CompressedData
    DestinationData
    Size
    Bits
    Planes
    TransferSyntax
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CodecGlobal Class
    CodecGlobal Members


DicomObjects.Codecs Namespace / CodecGlobal Class / RegisterCodec Method

    RegisterCodec Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Sub RegisterCodec( _
   ByVal codec As CodecFactory _
)
    'Usage

Dim codec As CodecFactory

CodecGlobal.RegisterCodec(codec)
    public static void RegisterCodec(
   CodecFactory codec
)

    Parameters

    codec
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CodecGlobal Class
    CodecGlobal Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / CompressionArguments Class
Members

In This Topic
    CompressionArguments Class
    In This Topic
    Object Model
    CompressionArguments ClassDicomDataSet ClassDicomAttribute ClassDicomDataSet ClassDicomAttribute ClassWriteBehaviours Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class CompressionArguments
   Inherits DicomCodecBaseArguments
    'Usage

Dim instance As CompressionArguments
    public class CompressionArguments : DicomCodecBaseArguments
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.DicomCodecBaseArguments
    DicomObjects.Codecs.CompressionArguments

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CompressionArguments Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / CompressionArguments Class
Properties

In This Topic
    CompressionArguments Class Members
    In This Topic

    The following tables list the members exposed by CompressionArguments.

    Public Properties
     | Name | Description
Public Property | BitsAllocated | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | BitsStored | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DataSet | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DestinationStream |
Public Property | Image |
Public Property | ImplementationUID | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | isSigned | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | OutputTransferSyntax |
Public Property | PhotometricInterpretation | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planarconfig | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planes | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Quality |
Public Property | Size | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | SourceArray |
Public Property | WriteBehaviour |
    Top
    See Also

    Reference

    CompressionArguments Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / CompressionArguments Class

    CompressionArguments Class Properties
    In This Topic

    For a list of all members of this type, see CompressionArguments members.

    Public Properties
     | Name | Description
Public Property | BitsAllocated | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | BitsStored | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DataSet | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DestinationStream |
Public Property | Image |
Public Property | ImplementationUID | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | isSigned | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | OutputTransferSyntax |
Public Property | PhotometricInterpretation | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planarconfig | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planes | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Quality |
Public Property | Size | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | SourceArray |
Public Property | WriteBehaviour |
    Top
    See Also

    Reference

    CompressionArguments Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / CompressionArguments Class / DestinationStream Property

    DestinationStream Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property DestinationStream As Stream
    'Usage

Dim instance As CompressionArguments
Dim value As Stream

value = instance.DestinationStream
    public Stream DestinationStream {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CompressionArguments Class
    CompressionArguments Members


DicomObjects.Codecs Namespace / CompressionArguments Class / Image Property

    Image Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Image As DicomDataSet
    'Usage

Dim instance As CompressionArguments
Dim value As DicomDataSet

instance.Image = value

value = instance.Image
    public DicomDataSet Image {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CompressionArguments Class
    CompressionArguments Members


DicomObjects.Codecs Namespace / CompressionArguments Class / OutputTransferSyntax Property

    OutputTransferSyntax Property (CompressionArguments)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property OutputTransferSyntax As String
    'Usage

Dim instance As CompressionArguments
Dim value As String

value = instance.OutputTransferSyntax
    public string OutputTransferSyntax {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CompressionArguments Class
    CompressionArguments Members


DicomObjects.Codecs Namespace / CompressionArguments Class / Quality Property

    Quality Property (CompressionArguments)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Quality As Object
    'Usage

Dim instance As CompressionArguments
Dim value As Object

instance.Quality = value

value = instance.Quality
    public object Quality {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CompressionArguments Class
    CompressionArguments Members


DicomObjects.Codecs Namespace / CompressionArguments Class / SourceArray Property

    SourceArray Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property SourceArray As Array
    'Usage

Dim instance As CompressionArguments
Dim value As Array

value = instance.SourceArray
    public Array SourceArray {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CompressionArguments Class
    CompressionArguments Members


DicomObjects.Codecs Namespace / CompressionArguments Class / WriteBehaviour Property

    WriteBehaviour Property (CompressionArguments)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property WriteBehaviour As WriteBehaviours
    'Usage

Dim instance As CompressionArguments
Dim value As WriteBehaviours

value = instance.WriteBehaviour
    public WriteBehaviours WriteBehaviour {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CompressionArguments Class
    CompressionArguments Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / DecompressionArguments Class
Members

In This Topic
    DecompressionArguments Class
    In This Topic
    Object Model
    DecompressionArguments ClassDicomDataSet ClassDicomAttribute Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class DecompressionArguments
   Inherits DicomCodecBaseArguments
    'Usage

Dim instance As DecompressionArguments
    public class DecompressionArguments : DicomCodecBaseArguments
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.DicomCodecBaseArguments
    DicomObjects.Codecs.DecompressionArguments

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DecompressionArguments Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / DecompressionArguments Class
Fields Properties

In This Topic
    DecompressionArguments Class Members
    In This Topic

    The following tables list the members exposed by DecompressionArguments.

    Public Fields
     | Name | Description
Public Field | ReadBehaviour |
    Top
    Public Properties
     | Name | Description
Public Property | BitsAllocated | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | BitsStored | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DataSet | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DestinationArray |
Public Property | Frame |
Public Property | ImplementationUID | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | InputTransferSyntax |
Public Property | isSigned | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | PhotometricInterpretation | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | PixelRequest |
Public Property | Planarconfig | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planes | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Size | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | SourceStream |
    Top
    See Also

    Reference

    DecompressionArguments Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / DecompressionArguments Class

    DecompressionArguments Class Properties
    In This Topic

    For a list of all members of this type, see DecompressionArguments members.

    Public Properties
     | Name | Description
Public Property | BitsAllocated | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | BitsStored | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DataSet | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DestinationArray |
Public Property | Frame |
Public Property | ImplementationUID | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | InputTransferSyntax |
Public Property | isSigned | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | PhotometricInterpretation | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | PixelRequest |
Public Property | Planarconfig | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planes | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Size | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | SourceStream |
    Top
    See Also

    Reference

    DecompressionArguments Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / DecompressionArguments Class / DestinationArray Property

    DestinationArray Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property DestinationArray As Array
    'Usage

Dim instance As DecompressionArguments
Dim value As Array

value = instance.DestinationArray
    public Array DestinationArray {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DecompressionArguments Class
    DecompressionArguments Members


DicomObjects.Codecs Namespace / DecompressionArguments Class / Frame Property

    Frame Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Frame As Integer
    'Usage

Dim instance As DecompressionArguments
Dim value As Integer

instance.Frame = value

value = instance.Frame
    public int Frame {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DecompressionArguments Class
    DecompressionArguments Members


DicomObjects.Codecs Namespace / DecompressionArguments Class / InputTransferSyntax Property

    InputTransferSyntax Property (DecompressionArguments)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property InputTransferSyntax As String
    'Usage

Dim instance As DecompressionArguments
Dim value As String

value = instance.InputTransferSyntax
    public string InputTransferSyntax {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DecompressionArguments Class
    DecompressionArguments Members


DicomObjects.Codecs Namespace / DecompressionArguments Class / PixelRequest Property

    PixelRequest Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property PixelRequest As PixelRequest
    'Usage

Dim instance As DecompressionArguments
Dim value As PixelRequest

instance.PixelRequest = value

value = instance.PixelRequest
    public PixelRequest PixelRequest {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DecompressionArguments Class
    DecompressionArguments Members


DicomObjects.Codecs Namespace / DecompressionArguments Class / SourceStream Property

    SourceStream Property (DecompressionArguments)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property SourceStream As Stream
    'Usage

Dim instance As DecompressionArguments
Dim value As Stream

value = instance.SourceStream
    public Stream SourceStream {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DecompressionArguments Class
    DecompressionArguments Members


%%PageItemTitle%% $$Fields$$

DicomObjects.Codecs Namespace / DecompressionArguments Class

    DecompressionArguments Class Fields
    In This Topic

    For a list of all members of this type, see DecompressionArguments members.

    Public Fields
     | Name | Description
Public Field | ReadBehaviour |
    Top
    See Also

    Reference

    DecompressionArguments Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / DecompressionArguments Class / ReadBehaviour Field

    ReadBehaviour Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadBehaviour As ReadBehaviours
    'Usage

Dim instance As DecompressionArguments
Dim value As ReadBehaviours

value = instance.ReadBehaviour

instance.ReadBehaviour = value
    public ReadBehaviours ReadBehaviour
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DecompressionArguments Class
    DecompressionArguments Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class
Members

In This Topic
    DicomCodecBaseArguments Class
    In This Topic
    Object Model
    DicomCodecBaseArguments ClassDicomDataSet ClassDicomAttribute Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class DicomCodecBaseArguments
    'Usage

Dim instance As DicomCodecBaseArguments
    public class DicomCodecBaseArguments
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.DicomCodecBaseArguments
    DicomObjects.Codecs.CompressionArguments
    DicomObjects.Codecs.DecompressionArguments
    DicomObjects.Codecs.ImportArguments
    DicomObjects.Codecs.ModificationArguments

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomCodecBaseArguments Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class
Properties

In This Topic
    DicomCodecBaseArguments Class Members
    In This Topic

    The following tables list the members exposed by DicomCodecBaseArguments.

    Public Properties
     | Name | Description
Public Property | BitsAllocated |
Public Property | BitsStored |
Public Property | DataSet |
Public Property | ImplementationUID |
Public Property | isSigned |
Public Property | PhotometricInterpretation |
Public Property | Planarconfig |
Public Property | Planes |
Public Property | Size |
    Top
    See Also

    Reference

    DicomCodecBaseArguments Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class

In This Topic
    DicomCodecBaseArguments Class Properties
    In This Topic

    For a list of all members of this type, see DicomCodecBaseArguments members.

    Public Properties
     | Name | Description
Public Property | BitsAllocated |
Public Property | BitsStored |
Public Property | DataSet |
Public Property | ImplementationUID |
Public Property | isSigned |
Public Property | PhotometricInterpretation |
Public Property | Planarconfig |
Public Property | Planes |
Public Property | Size |
    Top
    See Also

    Reference

    DicomCodecBaseArguments Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class / BitsAllocated Property

    BitsAllocated Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property BitsAllocated As Integer
    'Usage

Dim instance As DicomCodecBaseArguments
Dim value As Integer

value = instance.BitsAllocated
    public int BitsAllocated {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomCodecBaseArguments Class
    DicomCodecBaseArguments Members


DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class / BitsStored Property

    BitsStored Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property BitsStored As Integer
    'Usage

Dim instance As DicomCodecBaseArguments
Dim value As Integer

value = instance.BitsStored
    public int BitsStored {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomCodecBaseArguments Class
    DicomCodecBaseArguments Members


DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class / DataSet Property

    DataSet Property (DicomCodecBaseArguments)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property DataSet As DicomDataSet
    'Usage

Dim instance As DicomCodecBaseArguments
Dim value As DicomDataSet

value = instance.DataSet
    public DicomDataSet DataSet {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomCodecBaseArguments Class
    DicomCodecBaseArguments Members


DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class / ImplementationUID Property

    ImplementationUID Property (DicomCodecBaseArguments)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property ImplementationUID As String
    'Usage

Dim instance As DicomCodecBaseArguments
Dim value As String

value = instance.ImplementationUID
    public string ImplementationUID {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomCodecBaseArguments Class
    DicomCodecBaseArguments Members


DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class / isSigned Property

    isSigned Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property isSigned As Boolean
    'Usage

Dim instance As DicomCodecBaseArguments
Dim value As Boolean

value = instance.isSigned
    public bool isSigned {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomCodecBaseArguments Class
    DicomCodecBaseArguments Members


DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class / PhotometricInterpretation Property

    PhotometricInterpretation Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property PhotometricInterpretation As String
    'Usage

Dim instance As DicomCodecBaseArguments
Dim value As String

value = instance.PhotometricInterpretation
    public string PhotometricInterpretation {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomCodecBaseArguments Class
    DicomCodecBaseArguments Members


DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class / Planarconfig Property

    Planarconfig Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Planarconfig As Integer
    'Usage

Dim instance As DicomCodecBaseArguments
Dim value As Integer

value = instance.Planarconfig
    public int Planarconfig {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomCodecBaseArguments Class
    DicomCodecBaseArguments Members


DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class / Planes Property

    Planes Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Planes As Integer
    'Usage

Dim instance As DicomCodecBaseArguments
Dim value As Integer

value = instance.Planes
    public int Planes {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomCodecBaseArguments Class
    DicomCodecBaseArguments Members


DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class / Size Property

    Size Property (DicomCodecBaseArguments)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Size As Size
    'Usage

Dim instance As DicomCodecBaseArguments
Dim value As Size

value = instance.Size
    public Size Size {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomCodecBaseArguments Class
    DicomCodecBaseArguments Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / ImportArguments Class
Members

In This Topic
    ImportArguments Class
    In This Topic
    Object Model
    ImportArguments ClassDicomDataSet ClassDicomAttribute Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class ImportArguments
   Inherits DicomCodecBaseArguments
    'Usage

Dim instance As ImportArguments
    public class ImportArguments : DicomCodecBaseArguments
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.DicomCodecBaseArguments
    DicomObjects.Codecs.ImportArguments

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ImportArguments Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / ImportArguments Class
Properties

In This Topic
    ImportArguments Class Members
    In This Topic

    The following tables list the members exposed by ImportArguments.

    Public Properties
     | Name | Description
Public Property | BitsAllocated | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | BitsStored | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DataSet | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | ImplementationUID | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | ImportPixelData |
Public Property | InputTransferSyntax |
Public Property | isSigned | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | LossyType |
Public Property | PhotometricInterpretation | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planarconfig | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planes | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Size | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | SourceStream |
    Top
    See Also

    Reference

    ImportArguments Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / ImportArguments Class

    ImportArguments Class Properties
    In This Topic

    For a list of all members of this type, see ImportArguments members.

    Public Properties
     | Name | Description
Public Property | BitsAllocated | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | BitsStored | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DataSet | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | ImplementationUID | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | ImportPixelData |
Public Property | InputTransferSyntax |
Public Property | isSigned | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | LossyType |
Public Property | PhotometricInterpretation | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planarconfig | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planes | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Size | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | SourceStream |
    Top
    See Also

    Reference

    ImportArguments Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / ImportArguments Class / ImportPixelData Property

    ImportPixelData Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property ImportPixelData As Boolean
    'Usage

Dim instance As ImportArguments
Dim value As Boolean

instance.ImportPixelData = value

value = instance.ImportPixelData
    public bool ImportPixelData {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ImportArguments Class
    ImportArguments Members


DicomObjects.Codecs Namespace / ImportArguments Class / InputTransferSyntax Property

    InputTransferSyntax Property (ImportArguments)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property InputTransferSyntax As String
    'Usage

Dim instance As ImportArguments
Dim value As String

value = instance.InputTransferSyntax
    public string InputTransferSyntax {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ImportArguments Class
    ImportArguments Members


DicomObjects.Codecs Namespace / ImportArguments Class / LossyType Property

    LossyType Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property LossyType As String
    'Usage

Dim instance As ImportArguments
Dim value As String

instance.LossyType = value

value = instance.LossyType
    public string LossyType {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ImportArguments Class
    ImportArguments Members


DicomObjects.Codecs Namespace / ImportArguments Class / SourceStream Property

    SourceStream Property (ImportArguments)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property SourceStream As Stream
    'Usage

Dim instance As ImportArguments
Dim value As Stream

value = instance.SourceStream
    public Stream SourceStream {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ImportArguments Class
    ImportArguments Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class
Members

In This Topic
    Jpeg2000CompressionOptions Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class Jpeg2000CompressionOptions
    'Usage

Dim instance As Jpeg2000CompressionOptions
    public class Jpeg2000CompressionOptions
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.Jpeg2000CompressionOptions

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class
Properties Methods

In This Topic
    Jpeg2000CompressionOptions Class Members
    In This Topic

    The following tables list the members exposed by Jpeg2000CompressionOptions.

    Public Constructors
     | Name | Description
Public Constructor | Jpeg2000CompressionOptions Constructor |
    Top
    Public Properties
     | Name | Description
Public Property | ActualLevels |
Public Property | ForJpip |
Public Property | Layers |
Public Property | Levels |
Public Property | Lossy |
Public Property | PrecinctSize |
Public Property | Progression |
Public Property | Rate |
    Top
    Public Methods
     | Name | Description
Public Method | Clone |
static (Shared in Visual Basic) | OptionsFromImage |
    Top
    See Also

    Reference

    Jpeg2000CompressionOptions Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%%

DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class / Jpeg2000CompressionOptions Constructor

In This Topic
    Jpeg2000CompressionOptions Constructor
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New()
    'Usage

Dim instance As New Jpeg2000CompressionOptions()
    public Jpeg2000CompressionOptions()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Class
    Jpeg2000CompressionOptions Members


%%PageItemTitle%% $$Methods$$

DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class

In This Topic
    Jpeg2000CompressionOptions Class Methods
    In This Topic

    For a list of all members of this type, see Jpeg2000CompressionOptions members.

    Public Methods
     | Name | Description
Public Method | Clone |
static (Shared in Visual Basic) | OptionsFromImage |
    Top
    See Also

    Reference

    Jpeg2000CompressionOptions Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class / Clone Method

    Clone Method (Jpeg2000CompressionOptions)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function Clone() As Object
    'Usage

Dim instance As Jpeg2000CompressionOptions
Dim value As Object

value = instance.Clone()
    public object Clone()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Class
    Jpeg2000CompressionOptions Members


DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class / OptionsFromImage Method

    OptionsFromImage Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function OptionsFromImage( _
   ByVal DataSet As DicomDataSet, _
   ByVal Frame As Integer _
) As Jpeg2000CompressionOptions
    'Usage

Dim DataSet As DicomDataSet
Dim Frame As Integer
Dim value As Jpeg2000CompressionOptions

value = Jpeg2000CompressionOptions.OptionsFromImage(DataSet, Frame)
    public static Jpeg2000CompressionOptions OptionsFromImage(
   DicomDataSet DataSet,
   int Frame
)

    Parameters

    DataSet
    Frame
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Class
    Jpeg2000CompressionOptions Members


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class

In This Topic
    Jpeg2000CompressionOptions Class Properties
    In This Topic

    For a list of all members of this type, see Jpeg2000CompressionOptions members.

    Public Properties
     | Name | Description
Public Property | ActualLevels |
Public Property | ForJpip |
Public Property | Layers |
Public Property | Levels |
Public Property | Lossy |
Public Property | PrecinctSize |
Public Property | Progression |
Public Property | Rate |
    Top
    See Also

    Reference

    Jpeg2000CompressionOptions Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class / ActualLevels Property

    ActualLevels Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property ActualLevels As Integer
    'Usage

Dim instance As Jpeg2000CompressionOptions
Dim value As Integer

value = instance.ActualLevels
    public int ActualLevels {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Class
    Jpeg2000CompressionOptions Members


DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class / ForJpip Property

    ForJpip Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property ForJpip As Boolean
    'Usage

Dim instance As Jpeg2000CompressionOptions
Dim value As Boolean

instance.ForJpip = value

value = instance.ForJpip
    public bool ForJpip {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Class
    Jpeg2000CompressionOptions Members


DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class / Layers Property

    Layers Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Layers As Integer
    'Usage

Dim instance As Jpeg2000CompressionOptions
Dim value As Integer

instance.Layers = value

value = instance.Layers
    public int Layers {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Class
    Jpeg2000CompressionOptions Members


DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class / Levels Property

    Levels Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Levels As Integer
    'Usage

Dim instance As Jpeg2000CompressionOptions
Dim value As Integer

instance.Levels = value

value = instance.Levels
    public int Levels {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Class
    Jpeg2000CompressionOptions Members


DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class / Lossy Property

    Lossy Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Lossy As Boolean
    'Usage

Dim instance As Jpeg2000CompressionOptions
Dim value As Boolean

instance.Lossy = value

value = instance.Lossy
    public bool Lossy {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Class
    Jpeg2000CompressionOptions Members


DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class / PrecinctSize Property

    PrecinctSize Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property PrecinctSize As Integer
    'Usage

Dim instance As Jpeg2000CompressionOptions
Dim value As Integer

instance.PrecinctSize = value

value = instance.PrecinctSize
    public int PrecinctSize {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Class
    Jpeg2000CompressionOptions Members


DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class / Progression Property

    Progression Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Progression As Progression
    'Usage

Dim instance As Jpeg2000CompressionOptions
Dim value As Progression

instance.Progression = value

value = instance.Progression
    public Progression Progression {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Class
    Jpeg2000CompressionOptions Members


DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class / Rate Property

    Rate Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Rate As Double
    'Usage

Dim instance As Jpeg2000CompressionOptions
Dim value As Double

instance.Rate = value

value = instance.Rate
    public double Rate {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Class
    Jpeg2000CompressionOptions Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / JpegLossless Class
Members

In This Topic
    JpegLossless Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class JpegLossless
   Inherits SimpleCodec
   Implements ICodecBase, ICompressor, IDecompressor
    'Usage

Dim instance As JpegLossless
    public class JpegLossless : SimpleCodec, ICodecBase, ICompressor, IDecompressor
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.SimpleCodec
    DicomObjects.Codecs.JpegLossless

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLossless Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / JpegLossless Class
Fields Properties Methods

In This Topic
    JpegLossless Class Members
    In This Topic

    The following tables list the members exposed by JpegLossless.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | CheckForBadCompression |
    Top
    Public Properties
     | Name | Description
Public Property | MaximumBits | (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Property | NeedsPlanarConfigTransform | (Inherited from DicomObjects.Codecs.SimpleCodec)
    Top
    Public Methods
     | Name | Description
Public Method | BestRequest | (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | CalculatedFrameCount | (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | Compress | Overridden.
Public Method | Decompress | Overridden.
Public Method | DecompressedPhotmetricInterpretation | (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | DecompressState | (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | DownloadStatus | (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | LockObject | (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | PrepareFunction | (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | Quality | (Inherited from DicomObjects.Codecs.SimpleCodec)
    Top
    See Also

    Reference

    JpegLossless Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.Codecs Namespace / JpegLossless Class

    JpegLossless Class Methods
    In This Topic

    For a list of all members of this type, see JpegLossless members.

    Public Methods
     | Name | Description
Public Method | BestRequest | (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | CalculatedFrameCount | (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | Compress | Overridden.
Public Method | Decompress | Overridden.
Public Method | DecompressedPhotmetricInterpretation | (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | DecompressState | (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | DownloadStatus | (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | LockObject | (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | PrepareFunction | (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | Quality | (Inherited from DicomObjects.Codecs.SimpleCodec)
    Top
    See Also

    Reference

    JpegLossless Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / JpegLossless Class / Compress Method

    Compress Method (JpegLossless)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overrides Sub Compress( _
   ByVal args As CompressionArguments _
)
    'Usage

Dim instance As JpegLossless
Dim args As CompressionArguments

instance.Compress(args)
    public override void Compress(
   CompressionArguments args
)

    Parameters

    args
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLossless Class
    JpegLossless Members
    Base Implementation in Compress


DicomObjects.Codecs Namespace / JpegLossless Class / Decompress Method

    Decompress Method (JpegLossless)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overrides Sub Decompress( _
   ByVal args As DecompressionArguments _
)
    'Usage

Dim instance As JpegLossless
Dim args As DecompressionArguments

instance.Decompress(args)
    public override void Decompress(
   DecompressionArguments args
)

    Parameters

    args
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLossless Class
    JpegLossless Members
    Base Implementation in Decompress


%%PageItemTitle%% $$Fields$$

DicomObjects.Codecs Namespace / JpegLossless Class

    JpegLossless Class Fields
    In This Topic

    For a list of all members of this type, see JpegLossless members.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | CheckForBadCompression |
    Top
    See Also

    Reference

    JpegLossless Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / JpegLossless Class / CheckForBadCompression Field

    CheckForBadCompression Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared CheckForBadCompression As Boolean
    'Usage

Dim value As Boolean

value = JpegLossless.CheckForBadCompression

JpegLossless.CheckForBadCompression = value
    public static bool CheckForBadCompression
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLossless Class
    JpegLossless Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / JpegLossy Class
Members

In This Topic
    JpegLossy Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MustInherit NotInheritable Class JpegLossy
    'Usage

Dim instance As JpegLossy
    public static class JpegLossy
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.JpegLossy

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLossy Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / JpegLossy Class
Properties

In This Topic
    JpegLossy Class Members
    In This Topic

    The following tables list the members exposed by JpegLossy.

    Public Properties
     | Name | Description
static (Shared in Visual Basic) | DecompressionType |
    Top
    See Also

    Reference

    JpegLossy Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / JpegLossy Class

    JpegLossy Class Properties
    In This Topic

    For a list of all members of this type, see JpegLossy members.

    Public Properties
     | Name | Description
static (Shared in Visual Basic) | DecompressionType |
    Top
    See Also

    Reference

    JpegLossy Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / JpegLossy Class / DecompressionType Property

    DecompressionType Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property DecompressionType As CodecUsage
    'Usage

Dim value As CodecUsage

JpegLossy.DecompressionType = value

value = JpegLossy.DecompressionType
    public static CodecUsage DecompressionType {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLossy Class
    JpegLossy Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / JpegLSCompressionOptions Class
Members

In This Topic
    JpegLSCompressionOptions Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class JpegLSCompressionOptions
    'Usage

Dim instance As JpegLSCompressionOptions
    public class JpegLSCompressionOptions
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.JpegLSCompressionOptions

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLSCompressionOptions Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / JpegLSCompressionOptions Class
Properties Methods

In This Topic
    JpegLSCompressionOptions Class Members
    In This Topic

    The following tables list the members exposed by JpegLSCompressionOptions.

    Public Constructors
     | Name | Description
Public Constructor | JpegLSCompressionOptions Constructor |
    Top
    Public Properties
     | Name | Description
Public Property | Near |
Public Property | T1 |
Public Property | T2 |
Public Property | T3 |
    Top
    Public Methods
     | Name | Description
Public Method | Clone |
    Top
    See Also

    Reference

    JpegLSCompressionOptions Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%%

DicomObjects.Codecs Namespace / JpegLSCompressionOptions Class / JpegLSCompressionOptions Constructor

In This Topic
    JpegLSCompressionOptions Constructor
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New()
    'Usage

Dim instance As New JpegLSCompressionOptions()
    public JpegLSCompressionOptions()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLSCompressionOptions Class
    JpegLSCompressionOptions Members


%%PageItemTitle%% $$Methods$$

DicomObjects.Codecs Namespace / JpegLSCompressionOptions Class

In This Topic
    JpegLSCompressionOptions Class Methods
    In This Topic

    For a list of all members of this type, see JpegLSCompressionOptions members.

    Public Methods
     | Name | Description
Public Method | Clone |
    Top
    See Also

    Reference

    JpegLSCompressionOptions Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / JpegLSCompressionOptions Class / Clone Method

    Clone Method (JpegLSCompressionOptions)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function Clone() As Object
    'Usage

Dim instance As JpegLSCompressionOptions
Dim value As Object

value = instance.Clone()
    public object Clone()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLSCompressionOptions Class
    JpegLSCompressionOptions Members


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / JpegLSCompressionOptions Class

In This Topic
    JpegLSCompressionOptions Class Properties
    In This Topic

    For a list of all members of this type, see JpegLSCompressionOptions members.

    Public Properties
     | Name | Description
Public Property | Near |
Public Property | T1 |
Public Property | T2 |
Public Property | T3 |
    Top
    See Also

    Reference

    JpegLSCompressionOptions Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / JpegLSCompressionOptions Class / Near Property

    Near Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Near As Byte
    'Usage

Dim instance As JpegLSCompressionOptions
Dim value As Byte

instance.Near = value

value = instance.Near
    public byte Near {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLSCompressionOptions Class
    JpegLSCompressionOptions Members


DicomObjects.Codecs Namespace / JpegLSCompressionOptions Class / T1 Property

    T1 Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property T1 As Integer
    'Usage

Dim instance As JpegLSCompressionOptions
Dim value As Integer

instance.T1 = value

value = instance.T1
    public int T1 {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLSCompressionOptions Class
    JpegLSCompressionOptions Members


DicomObjects.Codecs Namespace / JpegLSCompressionOptions Class / T2 Property

    T2 Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property T2 As Integer
    'Usage

Dim instance As JpegLSCompressionOptions
Dim value As Integer

instance.T2 = value

value = instance.T2
    public int T2 {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLSCompressionOptions Class
    JpegLSCompressionOptions Members


DicomObjects.Codecs Namespace / JpegLSCompressionOptions Class / T3 Property

    T3 Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property T3 As Integer
    'Usage

Dim instance As JpegLSCompressionOptions
Dim value As Integer

instance.T3 = value

value = instance.T3
    public int T3 {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLSCompressionOptions Class
    JpegLSCompressionOptions Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / Jpip Class
Members

In This Topic
    Jpip Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MustInherit NotInheritable Class Jpip
    'Usage

Dim instance As Jpip
    public static class Jpip
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.Jpip

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpip Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / Jpip Class
Properties Events

In This Topic
    Jpip Class Members
    In This Topic

    The following tables list the members exposed by Jpip.

    Public Properties
     | Name | Description
static (Shared in Visual Basic) | ClientCertificate |
static (Shared in Visual Basic) | JpipThreads |
static (Shared in Visual Basic) | JpipUriBase |
static (Shared in Visual Basic) | LogLevel |
    Top
    Public Events
     | Name | Description
Public Event | GetUri |
Public Event | StatusUpdate |
    Top
    See Also

    Reference

    Jpip Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / Jpip Class

    Jpip Class Properties
    In This Topic

    For a list of all members of this type, see Jpip members.

    Public Properties
     | Name | Description
static (Shared in Visual Basic) | ClientCertificate |
static (Shared in Visual Basic) | JpipThreads |
static (Shared in Visual Basic) | JpipUriBase |
static (Shared in Visual Basic) | LogLevel |
    Top
    See Also

    Reference

    Jpip Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / Jpip Class / ClientCertificate Property

    ClientCertificate Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property ClientCertificate As X509Certificate2
    'Usage

Dim value As X509Certificate2

Jpip.ClientCertificate = value

value = Jpip.ClientCertificate
    public static X509Certificate2 ClientCertificate {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpip Class
    Jpip Members


DicomObjects.Codecs Namespace / Jpip Class / JpipThreads Property

    JpipThreads Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property JpipThreads As Integer
    'Usage

Dim value As Integer

Jpip.JpipThreads = value

value = Jpip.JpipThreads
    public static int JpipThreads {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpip Class
    Jpip Members


DicomObjects.Codecs Namespace / Jpip Class / JpipUriBase Property

    JpipUriBase Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property JpipUriBase As String
    'Usage

Dim value As String

Jpip.JpipUriBase = value

value = Jpip.JpipUriBase
    public static string JpipUriBase {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpip Class
    Jpip Members


DicomObjects.Codecs Namespace / Jpip Class / LogLevel Property

    LogLevel Property (Jpip)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Property LogLevel As LogLevel
    'Usage

Dim value As LogLevel

Jpip.LogLevel = value

value = Jpip.LogLevel
    public static LogLevel LogLevel {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpip Class
    Jpip Members


%%PageItemTitle%% $$Events$$

DicomObjects.Codecs Namespace / Jpip Class

    Jpip Class Events
    In This Topic

    For a list of all members of this type, see Jpip members.

    Public Events
     | Name | Description
Public Event | GetUri |
Public Event | StatusUpdate |
    Top
    See Also

    Reference

    Jpip Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / Jpip Class / GetUri Event

    GetUri Event
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event GetUri As GetUrlHandler
    'Usage

Dim instance As Jpip
Dim handler As GetUrlHandler

AddHandler instance.GetUri, handler
    public event GetUrlHandler GetUri
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpip Class
    Jpip Members


DicomObjects.Codecs Namespace / Jpip Class / StatusUpdate Event

    StatusUpdate Event
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Event StatusUpdate As StatusUpdateHandler
    'Usage

Dim instance As Jpip
Dim handler As StatusUpdateHandler

AddHandler instance.StatusUpdate, handler
    public event StatusUpdateHandler StatusUpdate
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpip Class
    Jpip Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / ModificationArguments Class
Members

In This Topic
    ModificationArguments Class
    In This Topic
    Object Model
    ModificationArguments ClassDicomDataSet ClassDicomAttribute Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class ModificationArguments
   Inherits DicomCodecBaseArguments
    'Usage

Dim instance As ModificationArguments
    public class ModificationArguments : DicomCodecBaseArguments
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.DicomCodecBaseArguments
    DicomObjects.Codecs.ModificationArguments

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ModificationArguments Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / ModificationArguments Class
Properties

In This Topic
    ModificationArguments Class Members
    In This Topic

    The following tables list the members exposed by ModificationArguments.

    Public Properties
     | Name | Description
Public Property | BitsAllocated | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | BitsStored | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DataSet | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | ImplementationUID | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | isSigned | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | LossyDescription |
Public Property | LossyMethod |
Public Property | offset |
Public Property | OutputTransferSyntax |
Public Property | PhotometricInterpretation | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planarconfig | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planes | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Quality |
Public Property | RequestedColourSpace |
Public Property | scale |
Public Property | Size | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
    Top
    See Also

    Reference

    ModificationArguments Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / ModificationArguments Class

    ModificationArguments Class Properties
    In This Topic

    For a list of all members of this type, see ModificationArguments members.

    Public Properties
     | Name | Description
Public Property | BitsAllocated | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | BitsStored | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DataSet | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | ImplementationUID | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | isSigned | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | LossyDescription |
Public Property | LossyMethod |
Public Property | offset |
Public Property | OutputTransferSyntax |
Public Property | PhotometricInterpretation | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planarconfig | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planes | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Quality |
Public Property | RequestedColourSpace |
Public Property | scale |
Public Property | Size | (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
    Top
    See Also

    Reference

    ModificationArguments Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / ModificationArguments Class / LossyDescription Property

    LossyDescription Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property LossyDescription As String
    'Usage

Dim instance As ModificationArguments
Dim value As String

instance.LossyDescription = value

value = instance.LossyDescription
    public string LossyDescription {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ModificationArguments Class
    ModificationArguments Members


DicomObjects.Codecs Namespace / ModificationArguments Class / LossyMethod Property

    LossyMethod Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property LossyMethod As String
    'Usage

Dim instance As ModificationArguments
Dim value As String

instance.LossyMethod = value

value = instance.LossyMethod
    public string LossyMethod {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ModificationArguments Class
    ModificationArguments Members


DicomObjects.Codecs Namespace / ModificationArguments Class / offset Property

    offset Property (ModificationArguments)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property offset As Single
    'Usage

Dim instance As ModificationArguments
Dim value As Single

instance.offset = value

value = instance.offset
    public float offset {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ModificationArguments Class
    ModificationArguments Members


DicomObjects.Codecs Namespace / ModificationArguments Class / OutputTransferSyntax Property

    OutputTransferSyntax Property (ModificationArguments)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property OutputTransferSyntax As String
    'Usage

Dim instance As ModificationArguments
Dim value As String

value = instance.OutputTransferSyntax
    public string OutputTransferSyntax {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ModificationArguments Class
    ModificationArguments Members


DicomObjects.Codecs Namespace / ModificationArguments Class / Quality Property

    Quality Property (ModificationArguments)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Quality As Object
    'Usage

Dim instance As ModificationArguments
Dim value As Object

value = instance.Quality
    public object Quality {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ModificationArguments Class
    ModificationArguments Members


DicomObjects.Codecs Namespace / ModificationArguments Class / RequestedColourSpace Property

    RequestedColourSpace Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property RequestedColourSpace As String
    'Usage

Dim instance As ModificationArguments
Dim value As String

instance.RequestedColourSpace = value

value = instance.RequestedColourSpace
    public string RequestedColourSpace {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ModificationArguments Class
    ModificationArguments Members


DicomObjects.Codecs Namespace / ModificationArguments Class / scale Property

    scale Property (ModificationArguments)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property scale As Single
    'Usage

Dim instance As ModificationArguments
Dim value As Single

instance.scale = value

value = instance.scale
    public float scale {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ModificationArguments Class
    ModificationArguments Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / SimpleCodec Class
Members

In This Topic
    SimpleCodec Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MustInherit Class SimpleCodec
   Implements ICodecBase, ICompressor, IDecompressor
    'Usage

Dim instance As SimpleCodec
    public abstract class SimpleCodec : ICodecBase, ICompressor, IDecompressor
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.SimpleCodec
    DicomObjects.Codecs.JpegLossless

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / SimpleCodec Class
Properties Methods

In This Topic
    SimpleCodec Class Members
    In This Topic

    The following tables list the members exposed by SimpleCodec.

    Public Properties
     | Name | Description
Public Property | MaximumBits |
Public Property | NeedsPlanarConfigTransform |
    Top
    Public Methods
     | Name | Description
Public Method | BestRequest |
Public Method | CalculatedFrameCount |
Public Method | Compress |
Public Method | Decompress |
Public Method | DecompressedPhotmetricInterpretation |
Public Method | DecompressState |
Public Method | DownloadStatus |
Public Method | LockObject |
Public Method | PrepareFunction |
Public Method | Quality |
    Top
    See Also

    Reference

    SimpleCodec Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.Codecs Namespace / SimpleCodec Class

    SimpleCodec Class Methods
    In This Topic

    For a list of all members of this type, see SimpleCodec members.

    Public Methods
     | Name | Description
Public Method | BestRequest |
Public Method | CalculatedFrameCount |
Public Method | Compress |
Public Method | Decompress |
Public Method | DecompressedPhotmetricInterpretation |
Public Method | DecompressState |
Public Method | DownloadStatus |
Public Method | LockObject |
Public Method | PrepareFunction |
Public Method | Quality |
    Top
    See Also

    Reference

    SimpleCodec Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / SimpleCodec Class / BestRequest Method

    BestRequest Method (SimpleCodec)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function BestRequest( _
   ByVal Zoom As Single, _
   ByVal Sync As RequestType, _
   ByVal parent As DicomDataSet, _
   ByVal Frame As Integer _
) As PixelRequest
    'Usage

Dim instance As SimpleCodec
Dim Zoom As Single
Dim Sync As RequestType
Dim parent As DicomDataSet
Dim Frame As Integer
Dim value As PixelRequest

value = instance.BestRequest(Zoom, Sync, parent, Frame)
    public PixelRequest BestRequest(
   float Zoom,
   RequestType Sync,
   DicomDataSet parent,
   int Frame
)

    Parameters

    Zoom
    Sync
    parent
    Frame
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


DicomObjects.Codecs Namespace / SimpleCodec Class / CalculatedFrameCount Method

    CalculatedFrameCount Method (SimpleCodec)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overridable Function CalculatedFrameCount() As Integer
    'Usage

Dim instance As SimpleCodec
Dim value As Integer

value = instance.CalculatedFrameCount()
    public virtual int CalculatedFrameCount()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


DicomObjects.Codecs Namespace / SimpleCodec Class / Compress Method

    Compress Method (SimpleCodec)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MustOverride Sub Compress( _
   ByVal args As CompressionArguments _
)
    'Usage

Dim instance As SimpleCodec
Dim args As CompressionArguments

instance.Compress(args)
    public abstract void Compress(
   CompressionArguments args
)

    Parameters

    args
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


DicomObjects.Codecs Namespace / SimpleCodec Class / Decompress Method

    Decompress Method (SimpleCodec)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MustOverride Sub Decompress( _
   ByVal args As DecompressionArguments _
)
    'Usage

Dim instance As SimpleCodec
Dim args As DecompressionArguments

instance.Decompress(args)
    public abstract void Decompress(
   DecompressionArguments args
)

    Parameters

    args
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


DicomObjects.Codecs Namespace / SimpleCodec Class / DecompressedPhotmetricInterpretation Method

    DecompressedPhotmetricInterpretation Method (SimpleCodec)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overridable Function DecompressedPhotmetricInterpretation( _
   ByVal parent As DicomDataSet _
) As String
    'Usage

Dim instance As SimpleCodec
Dim parent As DicomDataSet
Dim value As String

value = instance.DecompressedPhotmetricInterpretation(parent)
    public virtual string DecompressedPhotmetricInterpretation(
   DicomDataSet parent
)

    Parameters

    parent
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


DicomObjects.Codecs Namespace / SimpleCodec Class / DecompressState Method

    DecompressState Method (SimpleCodec)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function DecompressState( _
   ByVal Request As PixelRequest _
) As DecompressStatus
    'Usage

Dim instance As SimpleCodec
Dim Request As PixelRequest
Dim value As DecompressStatus

value = instance.DecompressState(Request)
    public DecompressStatus DecompressState(
   PixelRequest Request
)

    Parameters

    Request
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


DicomObjects.Codecs Namespace / SimpleCodec Class / DownloadStatus Method

    DownloadStatus Method (SimpleCodec)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function DownloadStatus( _
   ByVal Request As PixelRequest _
) As ProgressiveStatus
    'Usage

Dim instance As SimpleCodec
Dim Request As PixelRequest
Dim value As ProgressiveStatus

value = instance.DownloadStatus(Request)
    public ProgressiveStatus DownloadStatus(
   PixelRequest Request
)

    Parameters

    Request
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


DicomObjects.Codecs Namespace / SimpleCodec Class / LockObject Method

    LockObject Method (SimpleCodec)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function LockObject() As Object
    'Usage

Dim instance As SimpleCodec
Dim value As Object

value = instance.LockObject()
    public object LockObject()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


DicomObjects.Codecs Namespace / SimpleCodec Class / PrepareFunction Method

    PrepareFunction Method (SimpleCodec)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overridable Sub PrepareFunction( _
   ByVal args As ModificationArguments _
)
    'Usage

Dim instance As SimpleCodec
Dim args As ModificationArguments

instance.PrepareFunction(args)
    public virtual void PrepareFunction(
   ModificationArguments args
)

    Parameters

    args
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


DicomObjects.Codecs Namespace / SimpleCodec Class / Quality Method

    Quality Method (SimpleCodec)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function Quality( _
   ByVal TransferSyntax As String, _
   ByVal qmap As Dictionary(Of String,Object), _
   ByVal dataset As DicomDataSet _
) As Object
    'Usage

Dim instance As SimpleCodec
Dim TransferSyntax As String
Dim qmap As Dictionary(Of String,Object)
Dim dataset As DicomDataSet
Dim value As Object

value = instance.Quality(TransferSyntax, qmap, dataset)
    public object Quality(
   string TransferSyntax,
   Dictionary<string,object> qmap,
   DicomDataSet dataset
)

    Parameters

    TransferSyntax
    qmap
    dataset
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / SimpleCodec Class

    SimpleCodec Class Properties
    In This Topic

    For a list of all members of this type, see SimpleCodec members.

    Public Properties
     | Name | Description
Public Property | MaximumBits |
Public Property | NeedsPlanarConfigTransform |
    Top
    See Also

    Reference

    SimpleCodec Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / SimpleCodec Class / MaximumBits Property

    MaximumBits Property (SimpleCodec)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overridable ReadOnly Property MaximumBits As Integer
    'Usage

Dim instance As SimpleCodec
Dim value As Integer

value = instance.MaximumBits
    public virtual int MaximumBits {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


DicomObjects.Codecs Namespace / SimpleCodec Class / NeedsPlanarConfigTransform Property

    NeedsPlanarConfigTransform Property (SimpleCodec)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overridable ReadOnly Property NeedsPlanarConfigTransform As Boolean
    'Usage

Dim instance As SimpleCodec
Dim value As Boolean

value = instance.NeedsPlanarConfigTransform
    public virtual bool NeedsPlanarConfigTransform {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / ICodecBase Interface
Members

In This Topic
    ICodecBase Interface
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Interface ICodecBase
    'Usage

Dim instance As ICodecBase
    public interface ICodecBase
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ICodecBase Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / ICodecBase Interface
Methods

In This Topic
    ICodecBase Interface Members
    In This Topic

    The following tables list the members exposed by ICodecBase.

    Public Methods
     | Name | Description
Method | LockObject |
    Top
    See Also

    Reference

    ICodecBase Interface
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.Codecs Namespace / ICodecBase Interface

    ICodecBase Interface Methods
    In This Topic

    For a list of all members of this type, see ICodecBase members.

    Public Methods
     | Name | Description
Method | LockObject |
    Top
    See Also

    Reference

    ICodecBase Interface
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / ICodecBase Interface / LockObject Method

    LockObject Method (ICodecBase)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Function LockObject() As Object
    'Usage

Dim instance As ICodecBase
Dim value As Object

value = instance.LockObject()
    object LockObject()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ICodecBase Interface
    ICodecBase Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / ICompressor Interface
Members

In This Topic
    ICompressor Interface
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Interface ICompressor
   Inherits ICodecBase
    'Usage

Dim instance As ICompressor
    public interface ICompressor : ICodecBase
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ICompressor Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / ICompressor Interface
Properties Methods

In This Topic
    ICompressor Interface Members
    In This Topic

    The following tables list the members exposed by ICompressor.

    Public Properties
     | Name | Description
Property | MaximumBits |
Property | NeedsPlanarConfigTransform |
    Top
    Public Methods
     | Name | Description
Method | Compress |
Method | LockObject | (Inherited from DicomObjects.Codecs.ICodecBase)
Method | PrepareFunction |
Method | Quality |
    Top
    See Also

    Reference

    ICompressor Interface
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.Codecs Namespace / ICompressor Interface

    ICompressor Interface Methods
    In This Topic

    For a list of all members of this type, see ICompressor members.

    Public Methods
     | Name | Description
Method | Compress |
Method | LockObject | (Inherited from DicomObjects.Codecs.ICodecBase)
Method | PrepareFunction |
Method | Quality |
    Top
    See Also

    Reference

    ICompressor Interface
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / ICompressor Interface / Compress Method

    Compress Method (ICompressor)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Sub Compress( _
   ByVal args As CompressionArguments _
)
    'Usage

Dim instance As ICompressor
Dim args As CompressionArguments

instance.Compress(args)
    void Compress(
   CompressionArguments args
)

    Parameters

    args
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ICompressor Interface
    ICompressor Members


DicomObjects.Codecs Namespace / ICompressor Interface / PrepareFunction Method

    PrepareFunction Method (ICompressor)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Sub PrepareFunction( _
   ByVal ModificationArguments As ModificationArguments _
)
    'Usage

Dim instance As ICompressor
Dim ModificationArguments As ModificationArguments

instance.PrepareFunction(ModificationArguments)
    void PrepareFunction(
   ModificationArguments ModificationArguments
)

    Parameters

    ModificationArguments
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ICompressor Interface
    ICompressor Members


DicomObjects.Codecs Namespace / ICompressor Interface / Quality Method

    Quality Method (ICompressor)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Function Quality( _
   ByVal TransferSyntax As String, _
   ByVal qmap As Dictionary(Of String,Object), _
   ByVal dataset As DicomDataSet _
) As Object
    'Usage

Dim instance As ICompressor
Dim TransferSyntax As String
Dim qmap As Dictionary(Of String,Object)
Dim dataset As DicomDataSet
Dim value As Object

value = instance.Quality(TransferSyntax, qmap, dataset)
    object Quality(
   string TransferSyntax,
   Dictionary<string,object> qmap,
   DicomDataSet dataset
)

    Parameters

    TransferSyntax
    qmap
    dataset
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ICompressor Interface
    ICompressor Members


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / ICompressor Interface

    ICompressor Interface Properties
    In This Topic

    For a list of all members of this type, see ICompressor members.

    Public Properties
     | Name | Description
Property | MaximumBits |
Property | NeedsPlanarConfigTransform |
    Top
    See Also

    Reference

    ICompressor Interface
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / ICompressor Interface / MaximumBits Property

    MaximumBits Property (ICompressor)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

ReadOnly Property MaximumBits As Integer
    'Usage

Dim instance As ICompressor
Dim value As Integer

value = instance.MaximumBits
    int MaximumBits {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ICompressor Interface
    ICompressor Members


DicomObjects.Codecs Namespace / ICompressor Interface / NeedsPlanarConfigTransform Property

    NeedsPlanarConfigTransform Property (ICompressor)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

ReadOnly Property NeedsPlanarConfigTransform As Boolean
    'Usage

Dim instance As ICompressor
Dim value As Boolean

value = instance.NeedsPlanarConfigTransform
    bool NeedsPlanarConfigTransform {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ICompressor Interface
    ICompressor Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / IDecompressor Interface
Members

In This Topic
    IDecompressor Interface
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Interface IDecompressor
   Inherits ICodecBase
    'Usage

Dim instance As IDecompressor
    public interface IDecompressor : ICodecBase
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IDecompressor Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / IDecompressor Interface
Properties Methods

In This Topic
    IDecompressor Interface Members
    In This Topic

    The following tables list the members exposed by IDecompressor.

    Public Properties
     | Name | Description
Property | NeedsPlanarConfigTransform |
    Top
    Public Methods
     | Name | Description
Method | BestRequest |
Method | CalculatedFrameCount |
Method | Decompress |
Method | DecompressedPhotmetricInterpretation |
Method | DecompressState |
Method | DownloadStatus |
Method | LockObject | (Inherited from DicomObjects.Codecs.ICodecBase)
    Top
    See Also

    Reference

    IDecompressor Interface
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.Codecs Namespace / IDecompressor Interface

    IDecompressor Interface Methods
    In This Topic

    For a list of all members of this type, see IDecompressor members.

    Public Methods
     | Name | Description
Method | BestRequest |
Method | CalculatedFrameCount |
Method | Decompress |
Method | DecompressedPhotmetricInterpretation |
Method | DecompressState |
Method | DownloadStatus |
Method | LockObject | (Inherited from DicomObjects.Codecs.ICodecBase)
    Top
    See Also

    Reference

    IDecompressor Interface
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / IDecompressor Interface / BestRequest Method

    BestRequest Method (IDecompressor)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Function BestRequest( _
   ByVal Zoom As Single, _
   ByVal Sync As RequestType, _
   ByVal parent As DicomDataSet, _
   ByVal Frame As Integer _
) As PixelRequest
    'Usage

Dim instance As IDecompressor
Dim Zoom As Single
Dim Sync As RequestType
Dim parent As DicomDataSet
Dim Frame As Integer
Dim value As PixelRequest

value = instance.BestRequest(Zoom, Sync, parent, Frame)
    PixelRequest BestRequest(
   float Zoom,
   RequestType Sync,
   DicomDataSet parent,
   int Frame
)

    Parameters

    Zoom
    Sync
    parent
    Frame
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IDecompressor Interface
    IDecompressor Members


DicomObjects.Codecs Namespace / IDecompressor Interface / CalculatedFrameCount Method

    CalculatedFrameCount Method (IDecompressor)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Function CalculatedFrameCount() As Integer
    'Usage

Dim instance As IDecompressor
Dim value As Integer

value = instance.CalculatedFrameCount()
    int CalculatedFrameCount()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IDecompressor Interface
    IDecompressor Members


DicomObjects.Codecs Namespace / IDecompressor Interface / Decompress Method

    Decompress Method (IDecompressor)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Sub Decompress( _
   ByVal args As DecompressionArguments _
)
    'Usage

Dim instance As IDecompressor
Dim args As DecompressionArguments

instance.Decompress(args)
    void Decompress(
   DecompressionArguments args
)

    Parameters

    args
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IDecompressor Interface
    IDecompressor Members


DicomObjects.Codecs Namespace / IDecompressor Interface / DecompressedPhotmetricInterpretation Method

    DecompressedPhotmetricInterpretation Method (IDecompressor)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Function DecompressedPhotmetricInterpretation( _
   ByVal parent As DicomDataSet _
) As String
    'Usage

Dim instance As IDecompressor
Dim parent As DicomDataSet
Dim value As String

value = instance.DecompressedPhotmetricInterpretation(parent)
    string DecompressedPhotmetricInterpretation(
   DicomDataSet parent
)

    Parameters

    parent
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IDecompressor Interface
    IDecompressor Members


DicomObjects.Codecs Namespace / IDecompressor Interface / DecompressState Method

    DecompressState Method (IDecompressor)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Function DecompressState( _
   ByVal Request As PixelRequest _
) As DecompressStatus
    'Usage

Dim instance As IDecompressor
Dim Request As PixelRequest
Dim value As DecompressStatus

value = instance.DecompressState(Request)
    DecompressStatus DecompressState(
   PixelRequest Request
)

    Parameters

    Request
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IDecompressor Interface
    IDecompressor Members


DicomObjects.Codecs Namespace / IDecompressor Interface / DownloadStatus Method

    DownloadStatus Method (IDecompressor)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Function DownloadStatus( _
   ByVal Request As PixelRequest _
) As ProgressiveStatus
    'Usage

Dim instance As IDecompressor
Dim Request As PixelRequest
Dim value As ProgressiveStatus

value = instance.DownloadStatus(Request)
    ProgressiveStatus DownloadStatus(
   PixelRequest Request
)

    Parameters

    Request
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IDecompressor Interface
    IDecompressor Members


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / IDecompressor Interface

    IDecompressor Interface Properties
    In This Topic

    For a list of all members of this type, see IDecompressor members.

    Public Properties
     | Name | Description
Property | NeedsPlanarConfigTransform |
    Top
    See Also

    Reference

    IDecompressor Interface
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / IDecompressor Interface / NeedsPlanarConfigTransform Property

    NeedsPlanarConfigTransform Property (IDecompressor)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

ReadOnly Property NeedsPlanarConfigTransform As Boolean
    'Usage

Dim instance As IDecompressor
Dim value As Boolean

value = instance.NeedsPlanarConfigTransform
    bool NeedsPlanarConfigTransform {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IDecompressor Interface
    IDecompressor Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / IExporter Interface
Members

In This Topic
    IExporter Interface
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Interface IExporter
   Inherits ICodecBase
    'Usage

Dim instance As IExporter
    public interface IExporter : ICodecBase
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IExporter Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / IExporter Interface
Methods

In This Topic
    IExporter Interface Members
    In This Topic

    The following tables list the members exposed by IExporter.

    Public Methods
     | Name | Description
Method | Export |
Method | LockObject | (Inherited from DicomObjects.Codecs.ICodecBase)
    Top
    See Also

    Reference

    IExporter Interface
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.Codecs Namespace / IExporter Interface

    IExporter Interface Methods
    In This Topic

    For a list of all members of this type, see IExporter members.

    Public Methods
     | Name | Description
Method | Export |
Method | LockObject | (Inherited from DicomObjects.Codecs.ICodecBase)
    Top
    See Also

    Reference

    IExporter Interface
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / IExporter Interface / Export Method

    Export Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Sub Export( _
   ByVal args As CompressionArguments _
)
    'Usage

Dim instance As IExporter
Dim args As CompressionArguments

instance.Export(args)
    void Export(
   CompressionArguments args
)

    Parameters

    args
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IExporter Interface
    IExporter Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / IImporter Interface
Members

In This Topic
    IImporter Interface
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Interface IImporter
   Inherits ICodecBase
    'Usage

Dim instance As IImporter
    public interface IImporter : ICodecBase
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IImporter Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / IImporter Interface
Methods

In This Topic
    IImporter Interface Members
    In This Topic

    The following tables list the members exposed by IImporter.

    Public Methods
     | Name | Description
Method | Import |
Method | LockObject | (Inherited from DicomObjects.Codecs.ICodecBase)
    Top
    See Also

    Reference

    IImporter Interface
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.Codecs Namespace / IImporter Interface

    IImporter Interface Methods
    In This Topic

    For a list of all members of this type, see IImporter members.

    Public Methods
     | Name | Description
Method | Import |
Method | LockObject | (Inherited from DicomObjects.Codecs.ICodecBase)
    Top
    See Also

    Reference

    IImporter Interface
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / IImporter Interface / Import Method

    Import Method (IImporter)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Function Import( _
   ByVal args As ImportArguments _
) As Boolean
    'Usage

Dim instance As IImporter
Dim args As ImportArguments
Dim value As Boolean

value = instance.Import(args)
    bool Import(
   ImportArguments args
)

    Parameters

    args
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IImporter Interface
    IImporter Members


Inheritance Hierarchy
    DicomObjects.Delegates Namespace
    Delegates
     | Delegate | Description
Delegate | AssociationClosedHandler | Delegate for the event
Delegate | AssociationRequestHandler | Delegate for the event
Delegate | ChangeUidHandler | Delegate for the event
Delegate | CStoreRequestHandler |
Delegate | DataChangedHandler | Delegate for the event
Delegate | ErrorReceivedHandler | Delegate for the event
Delegate | GetUrlHandler | Delegate for the event
Delegate | InfoMessageHandler | Delegate for the event
Delegate | InstanceReceivedHandler | Delegate for the Event
Delegate | LicenceExpirationHandler |
Delegate | LicenceRetrieveHandler |
Delegate | LicenceStoredHandler |
Delegate | LogHandler | Delegate for the Event
Delegate | N_Event_ReportHandler | Delegate for the "N_Event_Report" events of a and
Delegate | NormalisedReceivedHandler | Delegate for the event
Delegate | QueryReceivedHandler | Delegate for the event
Delegate | ReceivingPixelDataHandler | Delegate used by the event
Delegate | ResponseReceivedHandler | Delegate for the and events
Delegate | StatusUpdateHandler | Delegate for the event
Delegate | TlsAcceptor | Delegate used to accept TLS communications
Delegate | TlsInitiator | Delegate used to initiate TLS communications
Delegate | VerifyReceivedHandler | Delegate for the event
    See Also

    Reference

    DicomObjects.Core Assembly


%%PageItemTitle%%

DicomObjects.Delegates Namespace / AssociationClosedHandler Delegate

In This Topic
    AssociationClosedHandler Delegate
    In This Topic
    Delegate for the event
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Sub AssociationClosedHandler( _
   ByVal Sender As Object, _
   ByVal e As AssociationClosedArgs _
)
    'Usage

Dim instance As New AssociationClosedHandler(AddressOf HandlerMethod)
    public delegate void AssociationClosedHandler(
   object Sender,
   AssociationClosedArgs e
)

    Parameters

    Sender
    e
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    AssociationClosedHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / AssociationRequestHandler Delegate

In This Topic
    AssociationRequestHandler Delegate
    In This Topic
    Delegate for the event
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Sub AssociationRequestHandler( _
   ByVal Sender As Object, _
   ByVal e As AssociationRequestArgs _
)
    'Usage

Dim instance As New AssociationRequestHandler(AddressOf HandlerMethod)
    public delegate void AssociationRequestHandler(
   object Sender,
   AssociationRequestArgs e
)

    Parameters

    Sender
    e
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    AssociationRequestHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / ChangeUidHandler Delegate

    ChangeUidHandler Delegate
    In This Topic
    Delegate for the event
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Sub ChangeUidHandler( _
   ByVal e As ChangeUidArgs _
)
    'Usage

Dim instance As New ChangeUidHandler(AddressOf HandlerMethod)
    public delegate void ChangeUidHandler(
   ChangeUidArgs e
)

    Parameters

    e
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ChangeUidHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / CStoreRequestHandler Delegate

In This Topic
    CStoreRequestHandler Delegate
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Sub CStoreRequestHandler( _
   ByVal Sender As Object, _
   ByVal e As CStoreRequestArgs _
)
    'Usage

Dim instance As New CStoreRequestHandler(AddressOf HandlerMethod)
    public delegate void CStoreRequestHandler(
   object Sender,
   CStoreRequestArgs e
)

    Parameters

    Sender
    e
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CStoreRequestHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / DataChangedHandler Delegate

In This Topic
    DataChangedHandler Delegate
    In This Topic
    Delegate for the event
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Sub DataChangedHandler( _
   ByVal Sender As Object _
)
    'Usage

Dim instance As New DataChangedHandler(AddressOf HandlerMethod)
    public delegate void DataChangedHandler(
   object Sender
)

    Parameters

    Sender
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DataChangedHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / ErrorReceivedHandler Delegate

In This Topic
    ErrorReceivedHandler Delegate
    In This Topic
    Delegate for the event
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Sub ErrorReceivedHandler( _
   ByVal Sender As Object, _
   ByVal e As ErrorReceivedArgs _
)
    'Usage

Dim instance As New ErrorReceivedHandler(AddressOf HandlerMethod)
    public delegate void ErrorReceivedHandler(
   object Sender,
   ErrorReceivedArgs e
)

    Parameters

    Sender
    e
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ErrorReceivedHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / GetUrlHandler Delegate

    GetUrlHandler Delegate
    In This Topic
    Delegate for the event
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Function GetUrlHandler( _
   ByVal DataSet As DicomDataSet _
) As String
    'Usage

Dim instance As New GetUrlHandler(AddressOf HandlerMethod)
    public delegate string GetUrlHandler(
   DicomDataSet DataSet
)

    Parameters

    DataSet

    Return Value

    The required Uri
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    GetUrlHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / InfoMessageHandler Delegate

In This Topic
    InfoMessageHandler Delegate
    In This Topic
    Delegate for the event
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Sub InfoMessageHandler( _
   ByVal Sender As Object, _
   ByVal e As InfoMessageArgs _
)
    'Usage

Dim instance As New InfoMessageHandler(AddressOf HandlerMethod)
    public delegate void InfoMessageHandler(
   object Sender,
   InfoMessageArgs e
)

    Parameters

    Sender
    e
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    InfoMessageHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / InstanceReceivedHandler Delegate

In This Topic
    InstanceReceivedHandler Delegate
    In This Topic
    Delegate for the Event
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Sub InstanceReceivedHandler( _
   ByVal Sender As Object, _
   ByVal e As InstanceReceivedArgs _
)
    'Usage

Dim instance As New InstanceReceivedHandler(AddressOf HandlerMethod)
    public delegate void InstanceReceivedHandler(
   object Sender,
   InstanceReceivedArgs e
)

    Parameters

    Sender
    e
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    InstanceReceivedHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / LicenceExpirationHandler Delegate

In This Topic
    LicenceExpirationHandler Delegate
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Sub LicenceExpirationHandler()
    'Usage

Dim instance As New LicenceExpirationHandler(AddressOf HandlerMethod)
    public delegate void LicenceExpirationHandler()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    LicenceExpirationHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / LicenceRetrieveHandler Delegate

In This Topic
    LicenceRetrieveHandler Delegate
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Function LicenceRetrieveHandler() As String
    'Usage

Dim instance As New LicenceRetrieveHandler(AddressOf HandlerMethod)
    public delegate string LicenceRetrieveHandler()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    LicenceRetrieveHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / LicenceStoredHandler Delegate

In This Topic
    LicenceStoredHandler Delegate
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Function LicenceStoredHandler( _
   ByVal licenceToken As String _
) As Boolean
    'Usage

Dim instance As New LicenceStoredHandler(AddressOf HandlerMethod)
    public delegate bool LicenceStoredHandler(
   string licenceToken
)

    Parameters

    licenceToken
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    LicenceStoredHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / LogHandler Delegate

    LogHandler Delegate
    In This Topic
    Delegate for the Event
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Sub LogHandler( _
   ByVal e As LogEventArgs _
)
    'Usage

Dim instance As New LogHandler(AddressOf HandlerMethod)
    public delegate void LogHandler(
   LogEventArgs e
)

    Parameters

    e
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    LogHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / N_Event_ReportHandler Delegate

In This Topic
    N_Event_ReportHandler Delegate
    In This Topic
    Delegate for the "N_Event_Report" events of a and
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Sub N_Event_ReportHandler( _
   ByVal Sender As Object, _
   ByVal e As N_Event_ReportArgs _
)
    'Usage

Dim instance As New N_Event_ReportHandler(AddressOf HandlerMethod)
    public delegate void N_Event_ReportHandler(
   object Sender,
   N_Event_ReportArgs e
)

    Parameters

    Sender
    e
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    N_Event_ReportHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / NormalisedReceivedHandler Delegate

In This Topic
    NormalisedReceivedHandler Delegate
    In This Topic
    Delegate for the event
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Sub NormalisedReceivedHandler( _
   ByVal Sender As Object, _
   ByVal e As NormalisedReceivedArgs _
)
    'Usage

Dim instance As New NormalisedReceivedHandler(AddressOf HandlerMethod)
    public delegate void NormalisedReceivedHandler(
   object Sender,
   NormalisedReceivedArgs e
)

    Parameters

    Sender
    e
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    NormalisedReceivedHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / QueryReceivedHandler Delegate

In This Topic
    QueryReceivedHandler Delegate
    In This Topic
    Delegate for the event
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Sub QueryReceivedHandler( _
   ByVal Sender As Object, _
   ByVal e As QueryReceivedArgs _
)
    'Usage

Dim instance As New QueryReceivedHandler(AddressOf HandlerMethod)
    public delegate void QueryReceivedHandler(
   object Sender,
   QueryReceivedArgs e
)

    Parameters

    Sender
    e
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / ReceivingPixelDataHandler Delegate

In This Topic
    ReceivingPixelDataHandler Delegate
    In This Topic
    Delegate used by the event
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Sub ReceivingPixelDataHandler( _
   ByVal Sender As Object, _
   ByVal e As ReceivingPixelDataArgs _
)
    'Usage

Dim instance As New ReceivingPixelDataHandler(AddressOf HandlerMethod)
    public delegate void ReceivingPixelDataHandler(
   object Sender,
   ReceivingPixelDataArgs e
)

    Parameters

    Sender
    e
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReceivingPixelDataHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / ResponseReceivedHandler Delegate

In This Topic
    ResponseReceivedHandler Delegate
    In This Topic
    Delegate for the and events
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Sub ResponseReceivedHandler( _
   ByVal Sender As Object, _
   ByVal e As ResponseReceivedArgs _
)
    'Usage

Dim instance As New ResponseReceivedHandler(AddressOf HandlerMethod)
    public delegate void ResponseReceivedHandler(
   object Sender,
   ResponseReceivedArgs e
)

    Parameters

    Sender
    e
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ResponseReceivedHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / StatusUpdateHandler Delegate

In This Topic
    StatusUpdateHandler Delegate
    In This Topic
    Delegate for the event
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Sub StatusUpdateHandler( _
   ByVal DataSet As DicomDataSet, _
   ByVal Request As PixelRequest, _
   ByVal Status As ProgressiveStatus _
)
    'Usage

Dim instance As New StatusUpdateHandler(AddressOf HandlerMethod)
    public delegate void StatusUpdateHandler(
   DicomDataSet DataSet,
   PixelRequest Request,
   ProgressiveStatus Status
)

    Parameters

    DataSet
    Request
    Status
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    StatusUpdateHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / TlsAcceptor Delegate

    TlsAcceptor Delegate
    In This Topic
    Delegate used to accept TLS communications
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Function TlsAcceptor( _
   ByVal EncryptedStream As Stream, _
   ByVal RemoteAddress As String, _
   ByVal LocalPort As Integer _
) As Stream
    'Usage

Dim instance As New TlsAcceptor(AddressOf HandlerMethod)
    public delegate Stream TlsAcceptor(
   Stream EncryptedStream,
   string RemoteAddress,
   int LocalPort
)

    Parameters

    EncryptedStream
    RemoteAddress
    LocalPort
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TlsAcceptor Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / TlsInitiator Delegate

    TlsInitiator Delegate
    In This Topic
    Delegate used to initiate TLS communications
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Function TlsInitiator( _
   ByVal ClearTextStream As Stream, _
   ByVal RemoteAddress As String, _
   ByVal RemotePort As Integer _
) As Stream
    'Usage

Dim instance As New TlsInitiator(AddressOf HandlerMethod)
    public delegate Stream TlsInitiator(
   Stream ClearTextStream,
   string RemoteAddress,
   int RemotePort
)

    Parameters

    ClearTextStream
    RemoteAddress
    RemotePort

    Return Value

    An encrypted stream following TLS negotiation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TlsInitiator Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / VerifyReceivedHandler Delegate

In This Topic
    VerifyReceivedHandler Delegate
    In This Topic
    Delegate for the event
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Sub VerifyReceivedHandler( _
   ByVal Sender As Object, _
   ByVal e As VerifyReceivedArgs _
)
    'Usage

Dim instance As New VerifyReceivedHandler(AddressOf HandlerMethod)
    public delegate void VerifyReceivedHandler(
   object Sender,
   VerifyReceivedArgs e
)

    Parameters

    Sender
    e
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VerifyReceivedHandler Members
    DicomObjects.Delegates Namespace


Inheritance Hierarchy
    DicomObjects.DicomWeb Namespace
    Classes
     | Class | Description
Class | ContentType |
Class | DicomWebClient |
Class | DicomWebServer |
Class | QidoEventArgs |
Class | QidoWebClient |
Class | RestfulController |
Class | RestfulRequest |
Class | RestfulResponse |
Class | StowEventArgs |
Class | StowWebClient |
Class | WadoEventArgs |
Class | WadoWebClient |
Class | WebContent |
    Interfaces
     | Interface | Description
Interface | IQidoWebClient |
Interface | IStowWebClient |
Interface | IWadoWebClient |
    Enumerations
     | Enumeration | Description
Enumeration | DicomDataEncoding | The ways that DICOM data can be encoded in DicomWeb
Enumeration | WADOOption |
    See Also

    Reference

    DicomObjects.Core Assembly


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / ContentType Class
Members

In This Topic
    ContentType Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class ContentType
    'Usage

Dim instance As ContentType
    public class ContentType
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomWeb.ContentType

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ContentType Members
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.DicomWeb Namespace / ContentType Class
Fields Properties Methods

In This Topic
    ContentType Class Members
    In This Topic

    The following tables list the members exposed by ContentType.

    Public Constructors
     | Name | Description
Public Constructor | ContentType Constructor | Overloaded.
    Top
    Public Fields
     | Name | Description
Public Field | MainType |
Public Field | SubType |
Public Field | TransferSyntax |
    Top
    Public Properties
     | Name | Description
Public Property | Multi |
Public Property | Type |
    Top
    Public Methods
     | Name | Description
Public Method | ToMediaType |
Public Method | ToMediaTypeWithQualityHeaderValue |
Public Method | ToString |
    Top
    See Also

    Reference

    ContentType Class
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / ContentType Class / ContentType Constructor

In This Topic
    ContentType Constructor
    In This Topic
    Overload List
    Overload | Description
ContentType Constructor(String,String) |
ContentType Constructor(String,String,String) |
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ContentType Class
    ContentType Members


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / ContentType Class / ContentType Constructor / ContentType Constructor(String,String)

In This Topic
    ContentType Constructor(String,String)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New( _
   ByVal MainType As String, _
   ByVal SubType As String _
)
    'Usage

Dim MainType As String
Dim SubType As String

Dim instance As New ContentType(MainType, SubType)
    public ContentType(
   string MainType,
   string SubType
)

    Parameters

    MainType
    SubType
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ContentType Class
    ContentType Members
    Overload List


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / ContentType Class / ContentType Constructor / ContentType Constructor(String,String,String)

In This Topic
    ContentType Constructor(String,String,String)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New( _
   ByVal MainType As String, _
   ByVal SubType As String, _
   ByVal TransferSyntax As String _
)
    'Usage

Dim MainType As String
Dim SubType As String
Dim TransferSyntax As String

Dim instance As New ContentType(MainType, SubType, TransferSyntax)
    public ContentType(
   string MainType,
   string SubType,
   string TransferSyntax
)

    Parameters

    MainType
    SubType
    TransferSyntax
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ContentType Class
    ContentType Members
    Overload List


%%PageItemTitle%% $$Methods$$

DicomObjects.DicomWeb Namespace / ContentType Class

    ContentType Class Methods
    In This Topic

    For a list of all members of this type, see ContentType members.

    Public Methods
     | Name | Description
Public Method | ToMediaType |
Public Method | ToMediaTypeWithQualityHeaderValue |
Public Method | ToString |
    Top
    See Also

    Reference

    ContentType Class
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / ContentType Class / ToMediaType Method

    ToMediaType Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function ToMediaType( _
   ByVal AllowMulti As Boolean, _
   ByVal WithQuality As Boolean _
) As MediaTypeHeaderValue
    'Usage

Dim instance As ContentType
Dim AllowMulti As Boolean
Dim WithQuality As Boolean
Dim value As MediaTypeHeaderValue

value = instance.ToMediaType(AllowMulti, WithQuality)
    public MediaTypeHeaderValue ToMediaType(
   bool AllowMulti,
   bool WithQuality
)

    Parameters

    AllowMulti
    WithQuality
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ContentType Class
    ContentType Members


DicomObjects.DicomWeb Namespace / ContentType Class / ToMediaTypeWithQualityHeaderValue Method

    ToMediaTypeWithQualityHeaderValue Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function ToMediaTypeWithQualityHeaderValue() As MediaTypeWithQualityHeaderValue
    'Usage

Dim instance As ContentType
Dim value As MediaTypeWithQualityHeaderValue

value = instance.ToMediaTypeWithQualityHeaderValue()
    public MediaTypeWithQualityHeaderValue ToMediaTypeWithQualityHeaderValue()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ContentType Class
    ContentType Members


DicomObjects.DicomWeb Namespace / ContentType Class / ToString Method

    ToString Method (ContentType)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overrides Function ToString() As String
    'Usage

Dim instance As ContentType
Dim value As String

value = instance.ToString()
    public override string ToString()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ContentType Class
    ContentType Members
    Base Implementation in ToString


%%PageItemTitle%% $$Properties$$

DicomObjects.DicomWeb Namespace / ContentType Class

    ContentType Class Properties
    In This Topic

    For a list of all members of this type, see ContentType members.

    Public Properties
     | Name | Description
Public Property | Multi |
Public Property | Type |
    Top
    See Also

    Reference

    ContentType Class
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / ContentType Class / Multi Property

    Multi Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Multi As Boolean
    'Usage

Dim instance As ContentType
Dim value As Boolean

value = instance.Multi
    public bool Multi {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ContentType Class
    ContentType Members


DicomObjects.DicomWeb Namespace / ContentType Class / Type Property

    Type Property (ContentType)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Type As String
    'Usage

Dim instance As ContentType
Dim value As String

value = instance.Type
    public string Type {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ContentType Class
    ContentType Members


%%PageItemTitle%% $$Fields$$

DicomObjects.DicomWeb Namespace / ContentType Class

    ContentType Class Fields
    In This Topic

    For a list of all members of this type, see ContentType members.

    Public Fields
     | Name | Description
Public Field | MainType |
Public Field | SubType |
Public Field | TransferSyntax |
    Top
    See Also

    Reference

    ContentType Class
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / ContentType Class / MainType Field

    MainType Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MainType As String
    'Usage

Dim instance As ContentType
Dim value As String

value = instance.MainType

instance.MainType = value
    public string MainType
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ContentType Class
    ContentType Members


DicomObjects.DicomWeb Namespace / ContentType Class / SubType Field

    SubType Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public SubType As String
    'Usage

Dim instance As ContentType
Dim value As String

value = instance.SubType

instance.SubType = value
    public string SubType
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ContentType Class
    ContentType Members


DicomObjects.DicomWeb Namespace / ContentType Class / TransferSyntax Field

    TransferSyntax Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public TransferSyntax As String
    'Usage

Dim instance As ContentType
Dim value As String

value = instance.TransferSyntax

instance.TransferSyntax = value
    public string TransferSyntax
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ContentType Class
    ContentType Members


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / DicomWebClient Class
Members

In This Topic
    DicomWebClient Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MustInherit Class DicomWebClient
    'Usage

Dim instance As DicomWebClient
    public abstract class DicomWebClient
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomWeb.DicomWebClient
    DicomObjects.DicomWeb.QidoWebClient
    DicomObjects.DicomWeb.StowWebClient
    DicomObjects.DicomWeb.WadoWebClient

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomWebClient Members
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.DicomWeb Namespace / DicomWebClient Class
Properties

In This Topic
    DicomWebClient Class Members
    In This Topic

    The following tables list the members exposed by DicomWebClient.

    Public Properties
     | Name | Description
Public Property | CertFile |
Public Property | CertPassword |
Public Property | JsonResponseWeight |
Public Property | Result |
Public Property | XmlResponseWeight |
    Top
    See Also

    Reference

    DicomWebClient Class
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.DicomWeb Namespace / DicomWebClient Class

    DicomWebClient Class Properties
    In This Topic

    For a list of all members of this type, see DicomWebClient members.

    Public Properties
     | Name | Description
Public Property | CertFile |
Public Property | CertPassword |
Public Property | JsonResponseWeight |
Public Property | Result |
Public Property | XmlResponseWeight |
    Top
    See Also

    Reference

    DicomWebClient Class
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / DicomWebClient Class / CertFile Property

    CertFile Property (DicomWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property CertFile As String
    'Usage

Dim instance As DicomWebClient
Dim value As String

instance.CertFile = value

value = instance.CertFile
    public string CertFile {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomWebClient Class
    DicomWebClient Members


DicomObjects.DicomWeb Namespace / DicomWebClient Class / CertPassword Property

    CertPassword Property (DicomWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property CertPassword As String
    'Usage

Dim instance As DicomWebClient
Dim value As String

instance.CertPassword = value

value = instance.CertPassword
    public string CertPassword {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomWebClient Class
    DicomWebClient Members


DicomObjects.DicomWeb Namespace / DicomWebClient Class / JsonResponseWeight Property

    JsonResponseWeight Property (DicomWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property JsonResponseWeight As Single
    'Usage

Dim instance As DicomWebClient
Dim value As Single

instance.JsonResponseWeight = value

value = instance.JsonResponseWeight
    public float JsonResponseWeight {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomWebClient Class
    DicomWebClient Members


DicomObjects.DicomWeb Namespace / DicomWebClient Class / Result Property

    Result Property (DicomWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Result As HttpResponseMessage
    'Usage

Dim instance As DicomWebClient
Dim value As HttpResponseMessage

value = instance.Result
    public HttpResponseMessage Result {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomWebClient Class
    DicomWebClient Members


DicomObjects.DicomWeb Namespace / DicomWebClient Class / XmlResponseWeight Property

    XmlResponseWeight Property (DicomWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property XmlResponseWeight As Single
    'Usage

Dim instance As DicomWebClient
Dim value As Single

instance.XmlResponseWeight = value

value = instance.XmlResponseWeight
    public float XmlResponseWeight {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomWebClient Class
    DicomWebClient Members


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / DicomWebServer Class
Members

In This Topic
    DicomWebServer Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class DicomWebServer
    'Usage

Dim instance As DicomWebServer
    public class DicomWebServer
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomWeb.DicomWebServer

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomWebServer Members
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.DicomWeb Namespace / DicomWebServer Class

    DicomWebServer Class Members
    In This Topic

    The following tables list the members exposed by DicomWebServer.

    Public Constructors
     | Name | Description
Public Constructor | DicomWebServer Constructor |
    Top
    See Also

    Reference

    DicomWebServer Class
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / DicomWebServer Class / DicomWebServer Constructor

In This Topic
    DicomWebServer Constructor
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New()
    'Usage

Dim instance As New DicomWebServer()
    public DicomWebServer()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomWebServer Class
    DicomWebServer Members


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / QidoEventArgs Class
Members

In This Topic
    QidoEventArgs Class
    In This Topic
    Object Model
    QidoEventArgs ClassDicomDataSetCollection ClassDicomDataSet Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class QidoEventArgs
    'Usage

Dim instance As QidoEventArgs
    public class QidoEventArgs
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomWeb.QidoEventArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QidoEventArgs Members
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.DicomWeb Namespace / QidoEventArgs Class
Properties Methods

In This Topic
    QidoEventArgs Class Members
    In This Topic

    The following tables list the members exposed by QidoEventArgs.

    Public Properties
     | Name | Description
Public Property | FuzzyMatching |
Public Property | Level |
Public Property | Limit |
Public Property | Offset |
Public Property | QueryStrings |
Public Property | Request |
Public Property | Results |
Public Property | Warnings |
    Top
    Public Methods
     | Name | Description
Public Method | QueryDataSet |
    Top
    See Also

    Reference

    QidoEventArgs Class
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.DicomWeb Namespace / QidoEventArgs Class

    QidoEventArgs Class Methods
    In This Topic

    For a list of all members of this type, see QidoEventArgs members.

    Public Methods
     | Name | Description
Public Method | QueryDataSet |
    Top
    See Also

    Reference

    QidoEventArgs Class
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / QidoEventArgs Class / QueryDataSet Method

    QueryDataSet Method (QidoEventArgs)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function QueryDataSet() As DicomDataSet
    'Usage

Dim instance As QidoEventArgs
Dim value As DicomDataSet

value = instance.QueryDataSet()
    public DicomDataSet QueryDataSet()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QidoEventArgs Class
    QidoEventArgs Members


%%PageItemTitle%% $$Properties$$

DicomObjects.DicomWeb Namespace / QidoEventArgs Class

    QidoEventArgs Class Properties
    In This Topic

    For a list of all members of this type, see QidoEventArgs members.

    Public Properties
     | Name | Description
Public Property | FuzzyMatching |
Public Property | Level |
Public Property | Limit |
Public Property | Offset |
Public Property | QueryStrings |
Public Property | Request |
Public Property | Results |
Public Property | Warnings |
    Top
    See Also

    Reference

    QidoEventArgs Class
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / QidoEventArgs Class / FuzzyMatching Property

    FuzzyMatching Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property FuzzyMatching As Boolean
    'Usage

Dim instance As QidoEventArgs
Dim value As Boolean

value = instance.FuzzyMatching
    public bool FuzzyMatching {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QidoEventArgs Class
    QidoEventArgs Members


DicomObjects.DicomWeb Namespace / QidoEventArgs Class / Level Property

    Level Property (QidoEventArgs)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Level As QueryLevel
    'Usage

Dim instance As QidoEventArgs
Dim value As QueryLevel

value = instance.Level
    public QueryLevel Level {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QidoEventArgs Class
    QidoEventArgs Members


DicomObjects.DicomWeb Namespace / QidoEventArgs Class / Limit Property

    Limit Property (QidoEventArgs)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Limit As Integer
    'Usage

Dim instance As QidoEventArgs
Dim value As Integer

instance.Limit = value

value = instance.Limit
    public int Limit {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QidoEventArgs Class
    QidoEventArgs Members


DicomObjects.DicomWeb Namespace / QidoEventArgs Class / Offset Property

    Offset Property (QidoEventArgs)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Offset As Integer
    'Usage

Dim instance As QidoEventArgs
Dim value As Integer

instance.Offset = value

value = instance.Offset
    public int Offset {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QidoEventArgs Class
    QidoEventArgs Members


DicomObjects.DicomWeb Namespace / QidoEventArgs Class / QueryStrings Property

    QueryStrings Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property QueryStrings As List(Of KeyValuePair(Of String,String))
    'Usage

Dim instance As QidoEventArgs
Dim value As List(Of KeyValuePair(Of String,String))

value = instance.QueryStrings
    public List<KeyValuePair<string,string>> QueryStrings {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QidoEventArgs Class
    QidoEventArgs Members


DicomObjects.DicomWeb Namespace / QidoEventArgs Class / Request Property

    Request Property (QidoEventArgs)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Request As HttpRequestMessage
    'Usage

Dim instance As QidoEventArgs
Dim value As HttpRequestMessage

value = instance.Request
    public HttpRequestMessage Request {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QidoEventArgs Class
    QidoEventArgs Members


DicomObjects.DicomWeb Namespace / QidoEventArgs Class / Results Property

    Results Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Results As DicomDataSetCollection
    'Usage

Dim instance As QidoEventArgs
Dim value As DicomDataSetCollection

instance.Results = value

value = instance.Results
    public DicomDataSetCollection Results {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QidoEventArgs Class
    QidoEventArgs Members


DicomObjects.DicomWeb Namespace / QidoEventArgs Class / Warnings Property

    Warnings Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Warnings As List(Of String)
    'Usage

Dim instance As QidoEventArgs
Dim value As List(Of String)

value = instance.Warnings
    public List<string> Warnings {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QidoEventArgs Class
    QidoEventArgs Members


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / QidoWebClient Class
Members

In This Topic
    QidoWebClient Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class QidoWebClient
   Inherits DicomWebClient
   Implements IQidoWebClient
    'Usage

Dim instance As QidoWebClient
    public class QidoWebClient : DicomWebClient, IQidoWebClient
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomWeb.DicomWebClient
    DicomObjects.DicomWeb.QidoWebClient

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QidoWebClient Members
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.DicomWeb Namespace / QidoWebClient Class
Properties Methods

In This Topic
    QidoWebClient Class Members
    In This Topic

    The following tables list the members exposed by QidoWebClient.

    Public Constructors
     | Name | Description
Public Constructor | QidoWebClient Constructor |
    Top
    Public Properties
     | Name | Description
Public Property | CertFile | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | CertPassword | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | IncludeAll |
Public Property | JsonResponseWeight | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | Limit |
Public Property | Offset |
Public Property | Result | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | UseFuzzyMatching |
Public Property | UseNamesInQuery |
Public Property | XmlResponseWeight | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
    Top
    Public Methods
     | Name | Description
Public Method | Query |
    Top
    See Also

    Reference

    QidoWebClient Class
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / QidoWebClient Class / QidoWebClient Constructor

In This Topic
    QidoWebClient Constructor
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New( _
   ByVal Destination As String, _
   Optional ByVal Certificate As String, _
   Optional ByVal Password As String, _
   Optional ByVal ServerCertValidationCallBack As Func(Of HttpRequestMessage,X509Certificate2,X509Chain,SslPolicyErrors,Boolean) _
)
    'Usage

Dim Destination As String
Dim Certificate As String
Dim Password As String
Dim ServerCertValidationCallBack As Func(Of HttpRequestMessage,X509Certificate2,X509Chain,SslPolicyErrors,Boolean)

Dim instance As New QidoWebClient(Destination, Certificate, Password, ServerCertValidationCallBack)
    public QidoWebClient(
   string Destination,
   string Certificate,
   string Password,
   Func<HttpRequestMessage,X509Certificate2,X509Chain,SslPolicyErrors,bool> ServerCertValidationCallBack
)

    Parameters

    Destination
    Certificate
    Password
    ServerCertValidationCallBack
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QidoWebClient Class
    QidoWebClient Members


%%PageItemTitle%% $$Methods$$

DicomObjects.DicomWeb Namespace / QidoWebClient Class

    QidoWebClient Class Methods
    In This Topic

    For a list of all members of this type, see QidoWebClient members.

    Public Methods
     | Name | Description
Public Method | Query |
    Top
    See Also

    Reference

    QidoWebClient Class
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / QidoWebClient Class / Query Method

    Query Method (QidoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function Query( _
   ByVal QueryDataSet As DicomDataSet, _
   Optional ByVal Root As QueryRoot, _
   Optional ByVal Level As QueryLevel _
) As DicomDataSetCollection
    'Usage

Dim instance As QidoWebClient
Dim QueryDataSet As DicomDataSet
Dim Root As QueryRoot
Dim Level As QueryLevel
Dim value As DicomDataSetCollection

value = instance.Query(QueryDataSet, Root, Level)
    public DicomDataSetCollection Query(
   DicomDataSet QueryDataSet,
   QueryRoot Root,
   QueryLevel Level
)

    Parameters

    QueryDataSet
    Root
    Level
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QidoWebClient Class
    QidoWebClient Members


%%PageItemTitle%% $$Properties$$

DicomObjects.DicomWeb Namespace / QidoWebClient Class

    QidoWebClient Class Properties
    In This Topic

    For a list of all members of this type, see QidoWebClient members.

    Public Properties
     | Name | Description
Public Property | CertFile | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | CertPassword | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | IncludeAll |
Public Property | JsonResponseWeight | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | Limit |
Public Property | Offset |
Public Property | Result | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | UseFuzzyMatching |
Public Property | UseNamesInQuery |
Public Property | XmlResponseWeight | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
    Top
    See Also

    Reference

    QidoWebClient Class
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / QidoWebClient Class / IncludeAll Property

    IncludeAll Property (QidoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property IncludeAll As Boolean
    'Usage

Dim instance As QidoWebClient
Dim value As Boolean

instance.IncludeAll = value

value = instance.IncludeAll
    public bool IncludeAll {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QidoWebClient Class
    QidoWebClient Members


DicomObjects.DicomWeb Namespace / QidoWebClient Class / Limit Property

    Limit Property (QidoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Limit As Integer
    'Usage

Dim instance As QidoWebClient
Dim value As Integer

instance.Limit = value

value = instance.Limit
    public int Limit {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QidoWebClient Class
    QidoWebClient Members


DicomObjects.DicomWeb Namespace / QidoWebClient Class / Offset Property

    Offset Property (QidoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Offset As Integer
    'Usage

Dim instance As QidoWebClient
Dim value As Integer

instance.Offset = value

value = instance.Offset
    public int Offset {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QidoWebClient Class
    QidoWebClient Members


DicomObjects.DicomWeb Namespace / QidoWebClient Class / UseFuzzyMatching Property

    UseFuzzyMatching Property (QidoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property UseFuzzyMatching As Boolean
    'Usage

Dim instance As QidoWebClient
Dim value As Boolean

instance.UseFuzzyMatching = value

value = instance.UseFuzzyMatching
    public bool UseFuzzyMatching {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QidoWebClient Class
    QidoWebClient Members


DicomObjects.DicomWeb Namespace / QidoWebClient Class / UseNamesInQuery Property

    UseNamesInQuery Property (QidoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property UseNamesInQuery As Boolean
    'Usage

Dim instance As QidoWebClient
Dim value As Boolean

instance.UseNamesInQuery = value

value = instance.UseNamesInQuery
    public bool UseNamesInQuery {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QidoWebClient Class
    QidoWebClient Members


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / RestfulController Class
Members

In This Topic
    RestfulController Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MustInherit Class RestfulController
    'Usage

Dim instance As RestfulController
    public abstract class RestfulController
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomWeb.RestfulController

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    RestfulController Members
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.DicomWeb Namespace / RestfulController Class

    RestfulController Class Members
    In This Topic

    The following tables list the members exposed by RestfulController.

    See Also

    Reference

    RestfulController Class
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / RestfulRequest Class
Members

In This Topic
    RestfulRequest Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MustInherit NotInheritable Class RestfulRequest
    'Usage

Dim instance As RestfulRequest
    public static class RestfulRequest
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomWeb.RestfulRequest

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    RestfulRequest Members
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.DicomWeb Namespace / RestfulRequest Class
Methods

In This Topic
    RestfulRequest Class Members
    In This Topic

    The following tables list the members exposed by RestfulRequest.

    Public Methods
     | Name | Description
static (Shared in Visual Basic) | PackDICOM |
    Top
    See Also

    Reference

    RestfulRequest Class
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.DicomWeb Namespace / RestfulRequest Class

    RestfulRequest Class Methods
    In This Topic

    For a list of all members of this type, see RestfulRequest members.

    Public Methods
     | Name | Description
static (Shared in Visual Basic) | PackDICOM |
    Top
    See Also

    Reference

    RestfulRequest Class
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / RestfulRequest Class / PackDICOM Method

    PackDICOM Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function PackDICOM( _
   ByVal data As WebContent _
) As HttpContent
    'Usage

Dim data As WebContent
Dim value As HttpContent

value = RestfulRequest.PackDICOM(data)
    public static HttpContent PackDICOM(
   WebContent data
)

    Parameters

    data
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    RestfulRequest Class
    RestfulRequest Members


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / RestfulResponse Class
Members

In This Topic
    RestfulResponse Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class RestfulResponse
    'Usage

Dim instance As RestfulResponse
    public class RestfulResponse
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomWeb.RestfulResponse

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    RestfulResponse Members
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.DicomWeb Namespace / RestfulResponse Class
Fields Methods

In This Topic
    RestfulResponse Class Members
    In This Topic

    The following tables list the members exposed by RestfulResponse.

    Public Constructors
     | Name | Description
Public Constructor | RestfulResponse Constructor |
    Top
    Public Fields
     | Name | Description
Public Field | BulkData |
Public Field | results |
static (Shared in Visual Basic) | XMLResponseMultiPart |
    Top
    Public Methods
     | Name | Description
Public Method | ResolveInternalUris |
    Top
    See Also

    Reference

    RestfulResponse Class
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / RestfulResponse Class / RestfulResponse Constructor

In This Topic
    RestfulResponse Constructor
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New( _
   ByVal content As HttpContent _
)
    'Usage

Dim content As HttpContent

Dim instance As New RestfulResponse(content)
    public RestfulResponse(
   HttpContent content
)

    Parameters

    content
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    RestfulResponse Class
    RestfulResponse Members


%%PageItemTitle%% $$Methods$$

DicomObjects.DicomWeb Namespace / RestfulResponse Class

    RestfulResponse Class Methods
    In This Topic

    For a list of all members of this type, see RestfulResponse members.

    Public Methods
     | Name | Description
Public Method | ResolveInternalUris |
    Top
    See Also

    Reference

    RestfulResponse Class
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / RestfulResponse Class / ResolveInternalUris Method

    ResolveInternalUris Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub ResolveInternalUris( _
   ByVal RequireAllData As Boolean _
)
    'Usage

Dim instance As RestfulResponse
Dim RequireAllData As Boolean

instance.ResolveInternalUris(RequireAllData)
    public void ResolveInternalUris(
   bool RequireAllData
)

    Parameters

    RequireAllData
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    RestfulResponse Class
    RestfulResponse Members


%%PageItemTitle%% $$Fields$$

DicomObjects.DicomWeb Namespace / RestfulResponse Class

    RestfulResponse Class Fields
    In This Topic

    For a list of all members of this type, see RestfulResponse members.

    Public Fields
     | Name | Description
Public Field | BulkData |
Public Field | results |
static (Shared in Visual Basic) | XMLResponseMultiPart |
    Top
    See Also

    Reference

    RestfulResponse Class
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / RestfulResponse Class / BulkData Field

    BulkData Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public BulkData As Dictionary(Of Uri,HttpContent)
    'Usage

Dim instance As RestfulResponse
Dim value As Dictionary(Of Uri,HttpContent)

value = instance.BulkData

instance.BulkData = value
    public Dictionary<Uri,HttpContent> BulkData
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    RestfulResponse Class
    RestfulResponse Members


DicomObjects.DicomWeb Namespace / RestfulResponse Class / results Field

    results Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public results As DicomDataSetCollection
    'Usage

Dim instance As RestfulResponse
Dim value As DicomDataSetCollection

value = instance.results

instance.results = value
    public DicomDataSetCollection results
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    RestfulResponse Class
    RestfulResponse Members


DicomObjects.DicomWeb Namespace / RestfulResponse Class / XMLResponseMultiPart Field

    XMLResponseMultiPart Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared XMLResponseMultiPart As Boolean
    'Usage

Dim value As Boolean

value = RestfulResponse.XMLResponseMultiPart

RestfulResponse.XMLResponseMultiPart = value
    public static bool XMLResponseMultiPart
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    RestfulResponse Class
    RestfulResponse Members


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / StowEventArgs Class
Members

In This Topic
    StowEventArgs Class
    In This Topic
    Object Model
    StowEventArgs ClassDicomDataSetCollection ClassDicomDataSet Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class StowEventArgs
    'Usage

Dim instance As StowEventArgs
    public class StowEventArgs
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomWeb.StowEventArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    StowEventArgs Members
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.DicomWeb Namespace / StowEventArgs Class
Properties Methods

In This Topic
    StowEventArgs Class Members
    In This Topic

    The following tables list the members exposed by StowEventArgs.

    Public Properties
     | Name | Description
Public Property | DataSets |
Public Property | Request |
    Top
    Public Methods
     | Name | Description
Public Method | SetFailed |
Public Method | SetSuccess |
    Top
    See Also

    Reference

    StowEventArgs Class
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.DicomWeb Namespace / StowEventArgs Class

    StowEventArgs Class Methods
    In This Topic

    For a list of all members of this type, see StowEventArgs members.

    Public Methods
     | Name | Description
Public Method | SetFailed |
Public Method | SetSuccess |
    Top
    See Also

    Reference

    StowEventArgs Class
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / StowEventArgs Class / SetFailed Method

    SetFailed Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub SetFailed( _
   ByVal DataSet As DicomDataSet, _
   ByVal Reason As Integer _
)
    'Usage

Dim instance As StowEventArgs
Dim DataSet As DicomDataSet
Dim Reason As Integer

instance.SetFailed(DataSet, Reason)
    public void SetFailed(
   DicomDataSet DataSet,
   int Reason
)

    Parameters

    DataSet
    Reason
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    StowEventArgs Class
    StowEventArgs Members


DicomObjects.DicomWeb Namespace / StowEventArgs Class / SetSuccess Method

    SetSuccess Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub SetSuccess( _
   ByVal DataSet As DicomDataSet _
)
    'Usage

Dim instance As StowEventArgs
Dim DataSet As DicomDataSet

instance.SetSuccess(DataSet)
    public void SetSuccess(
   DicomDataSet DataSet
)

    Parameters

    DataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    StowEventArgs Class
    StowEventArgs Members


%%PageItemTitle%% $$Properties$$

DicomObjects.DicomWeb Namespace / StowEventArgs Class

    StowEventArgs Class Properties
    In This Topic

    For a list of all members of this type, see StowEventArgs members.

    Public Properties
     | Name | Description
Public Property | DataSets |
Public Property | Request |
    Top
    See Also

    Reference

    StowEventArgs Class
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / StowEventArgs Class / DataSets Property

    DataSets Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property DataSets As DicomDataSetCollection
    'Usage

Dim instance As StowEventArgs
Dim value As DicomDataSetCollection

value = instance.DataSets
    public DicomDataSetCollection DataSets {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    StowEventArgs Class
    StowEventArgs Members


DicomObjects.DicomWeb Namespace / StowEventArgs Class / Request Property

    Request Property (StowEventArgs)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Request As HttpRequestMessage
    'Usage

Dim instance As StowEventArgs
Dim value As HttpRequestMessage

value = instance.Request
    public HttpRequestMessage Request {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    StowEventArgs Class
    StowEventArgs Members


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / StowWebClient Class
Members

In This Topic
    StowWebClient Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class StowWebClient
   Inherits DicomWebClient
   Implements IStowWebClient
    'Usage

Dim instance As StowWebClient
    public class StowWebClient : DicomWebClient, IStowWebClient
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomWeb.DicomWebClient
    DicomObjects.DicomWeb.StowWebClient

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    StowWebClient Members
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.DicomWeb Namespace / StowWebClient Class
Properties Methods

In This Topic
    StowWebClient Class Members
    In This Topic

    The following tables list the members exposed by StowWebClient.

    Public Constructors
     | Name | Description
Public Constructor | StowWebClient Constructor |
    Top
    Public Properties
     | Name | Description
Public Property | CertFile | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | CertPassword | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | JsonResponseWeight | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | Result | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | XmlResponseWeight | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
    Top
    Public Methods
     | Name | Description
Public Method | Store | Overloaded.
    Top
    See Also

    Reference

    StowWebClient Class
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / StowWebClient Class / StowWebClient Constructor

In This Topic
    StowWebClient Constructor
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New( _
   ByVal Destination As String, _
   Optional ByVal Certificate As String, _
   Optional ByVal Password As String, _
   Optional ByVal ServerCertValidationCallBack As Func(Of HttpRequestMessage,X509Certificate2,X509Chain,SslPolicyErrors,Boolean) _
)
    'Usage

Dim Destination As String
Dim Certificate As String
Dim Password As String
Dim ServerCertValidationCallBack As Func(Of HttpRequestMessage,X509Certificate2,X509Chain,SslPolicyErrors,Boolean)

Dim instance As New StowWebClient(Destination, Certificate, Password, ServerCertValidationCallBack)
    public StowWebClient(
   string Destination,
   string Certificate,
   string Password,
   Func<HttpRequestMessage,X509Certificate2,X509Chain,SslPolicyErrors,bool> ServerCertValidationCallBack
)

    Parameters

    Destination
    Certificate
    Password
    ServerCertValidationCallBack
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    StowWebClient Class
    StowWebClient Members


%%PageItemTitle%% $$Methods$$

DicomObjects.DicomWeb Namespace / StowWebClient Class

    StowWebClient Class Methods
    In This Topic

    For a list of all members of this type, see StowWebClient members.

    Public Methods
     | Name | Description
Public Method | Store | Overloaded.
    Top
    See Also

    Reference

    StowWebClient Class
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / StowWebClient Class / Store Method

    Store Method (StowWebClient)
    In This Topic
    Overload List
    Overload | Description
Store(DicomDataSetCollection,DicomDataEncoding,String) |
Store(DicomDataSetCollection,String) |
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    StowWebClient Class
    StowWebClient Members


DicomObjects.DicomWeb Namespace / StowWebClient Class / Store Method / Store(DicomDataSetCollection,DicomDataEncoding,String) Method

    Store(DicomDataSetCollection,DicomDataEncoding,String) Method
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function Store( _
   ByVal DataSets As DicomDataSetCollection, _
   ByVal Encoding As DicomDataEncoding, _
   ByVal TransferSyntax As String _
) As DicomDataSet
    'Usage

Dim instance As StowWebClient
Dim DataSets As DicomDataSetCollection
Dim Encoding As DicomDataEncoding
Dim TransferSyntax As String
Dim value As DicomDataSet

value = instance.Store(DataSets, Encoding, TransferSyntax)
    public DicomDataSet Store(
   DicomDataSetCollection DataSets,
   DicomDataEncoding Encoding,
   string TransferSyntax
)

    Parameters

    DataSets
    Encoding
    TransferSyntax
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    StowWebClient Class
    StowWebClient Members
    Overload List


DicomObjects.DicomWeb Namespace / StowWebClient Class / Store Method / Store(DicomDataSetCollection,String) Method

    Store(DicomDataSetCollection,String) Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function Store( _
   ByVal DataSets As DicomDataSetCollection, _
   ByVal TransferSyntax As String _
) As HttpResponseMessage
    'Usage

Dim instance As StowWebClient
Dim DataSets As DicomDataSetCollection
Dim TransferSyntax As String
Dim value As HttpResponseMessage

value = instance.Store(DataSets, TransferSyntax)
    public HttpResponseMessage Store(
   DicomDataSetCollection DataSets,
   string TransferSyntax
)

    Parameters

    DataSets
    TransferSyntax
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    StowWebClient Class
    StowWebClient Members
    Overload List


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / WadoEventArgs Class
Members

In This Topic
    WadoEventArgs Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class WadoEventArgs
    'Usage

Dim instance As WadoEventArgs
    public class WadoEventArgs
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomWeb.WadoEventArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WadoEventArgs Members
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.DicomWeb Namespace / WadoEventArgs Class
Properties Methods

In This Topic
    WadoEventArgs Class Members
    In This Topic

    The following tables list the members exposed by WadoEventArgs.

    Public Properties
     | Name | Description
Public Property | Frames |
Public Property | InstanceUID |
Public Property | Level |
Public Property | MetaDataOnly |
Public Property | Request |
Public Property | RequestedContentTypes |
Public Property | SeriesUID |
Public Property | StudyUID |
Public Property | TransferSyntax |
Public Property | WadoOperation |
    Top
    Public Methods
     | Name | Description
Public Method | MakeQuery |
Public Method | ReturnData |
    Top
    See Also

    Reference

    WadoEventArgs Class
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.DicomWeb Namespace / WadoEventArgs Class

    WadoEventArgs Class Methods
    In This Topic

    For a list of all members of this type, see WadoEventArgs members.

    Public Methods
     | Name | Description
Public Method | MakeQuery |
Public Method | ReturnData |
    Top
    See Also

    Reference

    WadoEventArgs Class
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / WadoEventArgs Class / MakeQuery Method

    MakeQuery Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function MakeQuery( _
   ByVal UseInstanceRoot As Boolean _
) As DicomQuery
    'Usage

Dim instance As WadoEventArgs
Dim UseInstanceRoot As Boolean
Dim value As DicomQuery

value = instance.MakeQuery(UseInstanceRoot)
    public DicomQuery MakeQuery(
   bool UseInstanceRoot
)

    Parameters

    UseInstanceRoot
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WadoEventArgs Class
    WadoEventArgs Members


DicomObjects.DicomWeb Namespace / WadoEventArgs Class / ReturnData Method

    ReturnData Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub ReturnData( _
   ByVal Results As IEnumerable(Of DicomDataSet), _
   ByVal FramesReduced As Boolean _
)
    'Usage

Dim instance As WadoEventArgs
Dim Results As IEnumerable(Of DicomDataSet)
Dim FramesReduced As Boolean

instance.ReturnData(Results, FramesReduced)
    public void ReturnData(
   IEnumerable<DicomDataSet> Results,
   bool FramesReduced
)

    Parameters

    Results
    FramesReduced
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WadoEventArgs Class
    WadoEventArgs Members


%%PageItemTitle%% $$Properties$$

DicomObjects.DicomWeb Namespace / WadoEventArgs Class

    WadoEventArgs Class Properties
    In This Topic

    For a list of all members of this type, see WadoEventArgs members.

    Public Properties
     | Name | Description
Public Property | Frames |
Public Property | InstanceUID |
Public Property | Level |
Public Property | MetaDataOnly |
Public Property | Request |
Public Property | RequestedContentTypes |
Public Property | SeriesUID |
Public Property | StudyUID |
Public Property | TransferSyntax |
Public Property | WadoOperation |
    Top
    See Also

    Reference

    WadoEventArgs Class
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / WadoEventArgs Class / Frames Property

    Frames Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Frames As Integer()
    'Usage

Dim instance As WadoEventArgs
Dim value() As Integer

value = instance.Frames
    public int[] Frames {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WadoEventArgs Class
    WadoEventArgs Members


DicomObjects.DicomWeb Namespace / WadoEventArgs Class / InstanceUID Property

    InstanceUID Property (WadoEventArgs)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property InstanceUID As String
    'Usage

Dim instance As WadoEventArgs
Dim value As String

value = instance.InstanceUID
    public string InstanceUID {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WadoEventArgs Class
    WadoEventArgs Members


DicomObjects.DicomWeb Namespace / WadoEventArgs Class / Level Property

    Level Property (WadoEventArgs)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Level As QueryLevel
    'Usage

Dim instance As WadoEventArgs
Dim value As QueryLevel

value = instance.Level
    public QueryLevel Level {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WadoEventArgs Class
    WadoEventArgs Members


DicomObjects.DicomWeb Namespace / WadoEventArgs Class / MetaDataOnly Property

    MetaDataOnly Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property MetaDataOnly As Boolean
    'Usage

Dim instance As WadoEventArgs
Dim value As Boolean

value = instance.MetaDataOnly
    public bool MetaDataOnly {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WadoEventArgs Class
    WadoEventArgs Members


DicomObjects.DicomWeb Namespace / WadoEventArgs Class / Request Property

    Request Property (WadoEventArgs)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Request As HttpRequestMessage
    'Usage

Dim instance As WadoEventArgs
Dim value As HttpRequestMessage

value = instance.Request
    public HttpRequestMessage Request {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WadoEventArgs Class
    WadoEventArgs Members


DicomObjects.DicomWeb Namespace / WadoEventArgs Class / RequestedContentTypes Property

    RequestedContentTypes Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property RequestedContentTypes As List(Of ContentType)
    'Usage

Dim instance As WadoEventArgs
Dim value As List(Of ContentType)

instance.RequestedContentTypes = value

value = instance.RequestedContentTypes
    public List<ContentType> RequestedContentTypes {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WadoEventArgs Class
    WadoEventArgs Members


DicomObjects.DicomWeb Namespace / WadoEventArgs Class / SeriesUID Property

    SeriesUID Property (WadoEventArgs)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property SeriesUID As String
    'Usage

Dim instance As WadoEventArgs
Dim value As String

value = instance.SeriesUID
    public string SeriesUID {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WadoEventArgs Class
    WadoEventArgs Members


DicomObjects.DicomWeb Namespace / WadoEventArgs Class / StudyUID Property

    StudyUID Property (WadoEventArgs)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property StudyUID As String
    'Usage

Dim instance As WadoEventArgs
Dim value As String

value = instance.StudyUID
    public string StudyUID {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WadoEventArgs Class
    WadoEventArgs Members


DicomObjects.DicomWeb Namespace / WadoEventArgs Class / TransferSyntax Property

    TransferSyntax Property (WadoEventArgs)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property TransferSyntax As String
    'Usage

Dim instance As WadoEventArgs
Dim value As String

instance.TransferSyntax = value

value = instance.TransferSyntax
    public string TransferSyntax {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WadoEventArgs Class
    WadoEventArgs Members


DicomObjects.DicomWeb Namespace / WadoEventArgs Class / WadoOperation Property

    WadoOperation Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property WadoOperation As WADOOption
    'Usage

Dim instance As WadoEventArgs
Dim value As WADOOption

value = instance.WadoOperation
    public WADOOption WadoOperation {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WadoEventArgs Class
    WadoEventArgs Members


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / WadoWebClient Class
Members

In This Topic
    WadoWebClient Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class WadoWebClient
   Inherits DicomWebClient
   Implements IWadoWebClient
    'Usage

Dim instance As WadoWebClient
    public class WadoWebClient : DicomWebClient, IWadoWebClient
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomWeb.DicomWebClient
    DicomObjects.DicomWeb.WadoWebClient

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WadoWebClient Members
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.DicomWeb Namespace / WadoWebClient Class
Properties Methods

In This Topic
    WadoWebClient Class Members
    In This Topic

    The following tables list the members exposed by WadoWebClient.

    Public Constructors
     | Name | Description
Public Constructor | WadoWebClient Constructor |
    Top
    Public Properties
     | Name | Description
Public Property | CertFile | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | CertPassword | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | JsonResponseWeight | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | Result | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | TransferSyntaxes |
Public Property | XmlResponseWeight | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
    Top
    Public Methods
     | Name | Description
Public Method | AppendBulkData |
Public Method | RetrieveMetaData |
Public Method | RetrieveNative | Overloaded.
Public Method | RetrieveRendered |
    Top
    See Also

    Reference

    WadoWebClient Class
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / WadoWebClient Class / WadoWebClient Constructor

In This Topic
    WadoWebClient Constructor
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New( _
   ByVal Destination As String, _
   Optional ByVal Certificate As String, _
   Optional ByVal Password As String, _
   Optional ByVal ServerCertValidationCallBack As Func(Of HttpRequestMessage,X509Certificate2,X509Chain,SslPolicyErrors,Boolean) _
)
    'Usage

Dim Destination As String
Dim Certificate As String
Dim Password As String
Dim ServerCertValidationCallBack As Func(Of HttpRequestMessage,X509Certificate2,X509Chain,SslPolicyErrors,Boolean)

Dim instance As New WadoWebClient(Destination, Certificate, Password, ServerCertValidationCallBack)
    public WadoWebClient(
   string Destination,
   string Certificate,
   string Password,
   Func<HttpRequestMessage,X509Certificate2,X509Chain,SslPolicyErrors,bool> ServerCertValidationCallBack
)

    Parameters

    Destination
    Certificate
    Password
    ServerCertValidationCallBack
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WadoWebClient Class
    WadoWebClient Members


%%PageItemTitle%% $$Methods$$

DicomObjects.DicomWeb Namespace / WadoWebClient Class

    WadoWebClient Class Methods
    In This Topic

    For a list of all members of this type, see WadoWebClient members.

    Public Methods
     | Name | Description
Public Method | AppendBulkData |
Public Method | RetrieveMetaData |
Public Method | RetrieveNative | Overloaded.
Public Method | RetrieveRendered |
    Top
    See Also

    Reference

    WadoWebClient Class
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / WadoWebClient Class / AppendBulkData Method

    AppendBulkData Method (WadoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub AppendBulkData( _
   ByVal DataSets As DicomDataSetCollection _
)
    'Usage

Dim instance As WadoWebClient
Dim DataSets As DicomDataSetCollection

instance.AppendBulkData(DataSets)
    public void AppendBulkData(
   DicomDataSetCollection DataSets
)

    Parameters

    DataSets
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WadoWebClient Class
    WadoWebClient Members


DicomObjects.DicomWeb Namespace / WadoWebClient Class / RetrieveMetaData Method

    RetrieveMetaData Method (WadoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function RetrieveMetaData( _
   ByVal StudyUID As String, _
   Optional ByVal SeriesUID As String, _
   Optional ByVal InstanceUID As String _
) As DicomDataSetCollection
    'Usage

Dim instance As WadoWebClient
Dim StudyUID As String
Dim SeriesUID As String
Dim InstanceUID As String
Dim value As DicomDataSetCollection

value = instance.RetrieveMetaData(StudyUID, SeriesUID, InstanceUID)
    public DicomDataSetCollection RetrieveMetaData(
   string StudyUID,
   string SeriesUID,
   string InstanceUID
)

    Parameters

    StudyUID
    SeriesUID
    InstanceUID
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WadoWebClient Class
    WadoWebClient Members


DicomObjects.DicomWeb Namespace / WadoWebClient Class / RetrieveNative Method

    RetrieveNative Method (WadoWebClient)
    In This Topic
    Overload List
    Overload | Description
RetrieveNative(DicomDataSet) |
RetrieveNative(String,String,String,Int32[],QueryRoot,String,Nullable<Int32>) |
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WadoWebClient Class
    WadoWebClient Members


DicomObjects.DicomWeb Namespace / WadoWebClient Class / RetrieveNative Method / RetrieveNative(DicomDataSet) Method

    RetrieveNative(DicomDataSet) Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function RetrieveNative( _
   ByVal RetrieveDataSet As DicomDataSet _
) As IEnumerable(Of DicomDataSet)
    'Usage

Dim instance As WadoWebClient
Dim RetrieveDataSet As DicomDataSet
Dim value As IEnumerable(Of DicomDataSet)

value = instance.RetrieveNative(RetrieveDataSet)
    public IEnumerable<DicomDataSet> RetrieveNative(
   DicomDataSet RetrieveDataSet
)

    Parameters

    RetrieveDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WadoWebClient Class
    WadoWebClient Members
    Overload List


DicomObjects.DicomWeb Namespace / WadoWebClient Class / RetrieveNative Method / RetrieveNative(String,String,String,Int32[],QueryRoot,String,Nullable<Int32>) Method

    RetrieveNative(String,String,String,Int32[],QueryRoot,String,Nullable<Int32>) Method
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Function RetrieveNative( _
   ByVal StudyUID As String, _
   Optional ByVal SeriesUID As String, _
   Optional ByVal InstanceUID As String, _
   Optional ByVal Frames() As Integer, _
   Optional ByVal Root As QueryRoot, _
   Optional ByVal SOPClassUID As String, _
   Optional ByVal BeamNumber As Nullable(Of Integer) _
) As IEnumerable(Of DicomDataSet)
    'Usage

Dim instance As WadoWebClient
Dim StudyUID As String
Dim SeriesUID As String
Dim InstanceUID As String
Dim Frames() As Integer
Dim Root As QueryRoot
Dim SOPClassUID As String
Dim BeamNumber As Nullable(Of Integer)
Dim value As IEnumerable(Of DicomDataSet)

value = instance.RetrieveNative(StudyUID, SeriesUID, InstanceUID, Frames, Root, SOPClassUID, BeamNumber)
    public IEnumerable<DicomDataSet> RetrieveNative(
   string StudyUID,
   string SeriesUID,
   string InstanceUID,
   int[] Frames,
   QueryRoot Root,
   string SOPClassUID,
   Nullable<int> BeamNumber
)

    Parameters

    StudyUID
    SeriesUID
    InstanceUID
    Frames
    Root
    SOPClassUID
    BeamNumber
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WadoWebClient Class
    WadoWebClient Members
    Overload List


DicomObjects.DicomWeb Namespace / WadoWebClient Class / RetrieveRendered Method

    RetrieveRendered Method (WadoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function RetrieveRendered( _
   ByVal StudyUID As String, _
   Optional ByVal SeriesUID As String, _
   Optional ByVal InstanceUID As String, _
   Optional ByVal Frames As IEnumerable(Of Integer) _
) As Dictionary(Of HttpContentHeaders,Byte())
    'Usage

Dim instance As WadoWebClient
Dim StudyUID As String
Dim SeriesUID As String
Dim InstanceUID As String
Dim Frames As IEnumerable(Of Integer)
Dim value As Dictionary(Of HttpContentHeaders,Byte())

value = instance.RetrieveRendered(StudyUID, SeriesUID, InstanceUID, Frames)
    public Dictionary<HttpContentHeaders,byte[]> RetrieveRendered(
   string StudyUID,
   string SeriesUID,
   string InstanceUID,
   IEnumerable<int> Frames
)

    Parameters

    StudyUID
    SeriesUID
    InstanceUID
    Frames
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WadoWebClient Class
    WadoWebClient Members


%%PageItemTitle%% $$Properties$$

DicomObjects.DicomWeb Namespace / WadoWebClient Class

    WadoWebClient Class Properties
    In This Topic

    For a list of all members of this type, see WadoWebClient members.

    Public Properties
     | Name | Description
Public Property | CertFile | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | CertPassword | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | JsonResponseWeight | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | Result | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | TransferSyntaxes |
Public Property | XmlResponseWeight | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
    Top
    See Also

    Reference

    WadoWebClient Class
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / WadoWebClient Class / TransferSyntaxes Property

    TransferSyntaxes Property (WadoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property TransferSyntaxes As List(Of String)
    'Usage

Dim instance As WadoWebClient
Dim value As List(Of String)

instance.TransferSyntaxes = value

value = instance.TransferSyntaxes
    public List<string> TransferSyntaxes {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WadoWebClient Class
    WadoWebClient Members


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / WebContent Class
Members

In This Topic
    WebContent Class
    In This Topic
    Object Model
    WebContent ClassContentType Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class WebContent
    'Usage

Dim instance As WebContent
    public class WebContent
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomWeb.WebContent

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WebContent Members
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.DicomWeb Namespace / WebContent Class
Properties

In This Topic
    WebContent Class Members
    In This Topic

    The following tables list the members exposed by WebContent.

    Public Constructors
     | Name | Description
Public Constructor | WebContent Constructor |
    Top
    Public Properties
     | Name | Description
Public Property | ContentLocation |
Public Property | ContentParameters |
Public Property | ContentType |
Public Property | IsBulkData |
Public Property | MultiPart |
Public Property | WriteData |
    Top
    See Also

    Reference

    WebContent Class
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / WebContent Class / WebContent Constructor

In This Topic
    WebContent Constructor
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New( _
   ByVal DataSets As DicomDataSetCollection, _
   ByVal Content As ContentType, _
   ByVal TransferSyntax As String, _
   ByVal MakeBulkData As Boolean, _
   ByVal GetBulkDataUri As Func(Of SequencePath,Uri) _
)
    'Usage

Dim DataSets As DicomDataSetCollection
Dim Content As ContentType
Dim TransferSyntax As String
Dim MakeBulkData As Boolean
Dim GetBulkDataUri As Func(Of SequencePath,Uri)

Dim instance As New WebContent(DataSets, Content, TransferSyntax, MakeBulkData, GetBulkDataUri)
    public WebContent(
   DicomDataSetCollection DataSets,
   ContentType Content,
   string TransferSyntax,
   bool MakeBulkData,
   Func<SequencePath,Uri> GetBulkDataUri
)

    Parameters

    DataSets
    Content
    TransferSyntax
    MakeBulkData
    GetBulkDataUri
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WebContent Class
    WebContent Members


%%PageItemTitle%% $$Properties$$

DicomObjects.DicomWeb Namespace / WebContent Class

    WebContent Class Properties
    In This Topic

    For a list of all members of this type, see WebContent members.

    Public Properties
     | Name | Description
Public Property | ContentLocation |
Public Property | ContentParameters |
Public Property | ContentType |
Public Property | IsBulkData |
Public Property | MultiPart |
Public Property | WriteData |
    Top
    See Also

    Reference

    WebContent Class
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / WebContent Class / ContentLocation Property

    ContentLocation Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property ContentLocation As Uri
    'Usage

Dim instance As WebContent
Dim value As Uri

instance.ContentLocation = value

value = instance.ContentLocation
    public Uri ContentLocation {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WebContent Class
    WebContent Members


DicomObjects.DicomWeb Namespace / WebContent Class / ContentParameters Property

    ContentParameters Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property ContentParameters As Dictionary(Of String,String)
    'Usage

Dim instance As WebContent
Dim value As Dictionary(Of String,String)

value = instance.ContentParameters
    public Dictionary<string,string> ContentParameters {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WebContent Class
    WebContent Members


DicomObjects.DicomWeb Namespace / WebContent Class / ContentType Property

    ContentType Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property ContentType As ContentType
    'Usage

Dim instance As WebContent
Dim value As ContentType

value = instance.ContentType
    public ContentType ContentType {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WebContent Class
    WebContent Members


DicomObjects.DicomWeb Namespace / WebContent Class / IsBulkData Property

    IsBulkData Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property IsBulkData As Boolean
    'Usage

Dim instance As WebContent
Dim value As Boolean

instance.IsBulkData = value

value = instance.IsBulkData
    public bool IsBulkData {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WebContent Class
    WebContent Members


DicomObjects.DicomWeb Namespace / WebContent Class / MultiPart Property

    MultiPart Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property MultiPart As Boolean
    'Usage

Dim instance As WebContent
Dim value As Boolean

value = instance.MultiPart
    public bool MultiPart {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WebContent Class
    WebContent Members


DicomObjects.DicomWeb Namespace / WebContent Class / WriteData Property

    WriteData Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property WriteData As Action(Of Stream)
    'Usage

Dim instance As WebContent
Dim value As Action(Of Stream)

value = instance.WriteData
    public Action<Stream> WriteData {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WebContent Class
    WebContent Members


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / DicomDataEncoding Enumeration

In This Topic
    DicomDataEncoding Enumeration
    In This Topic
    The ways that DICOM data can be encoded in DicomWeb
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum DicomDataEncoding
   Inherits System.Enum
    'Usage

Dim instance As DicomDataEncoding
    public enum DicomDataEncoding : System.Enum
    Members
    Member | Description
Json | JSON encoding
NativeDicom | Native DICOM as "part 10" files
Xml | XML encoding
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.DicomWeb.DicomDataEncoding

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.DicomWeb Namespace


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / WADOOption Enumeration

    WADOOption Enumeration
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum WADOOption
   Inherits System.Enum
    'Usage

Dim instance As WADOOption
    public enum WADOOption : System.Enum
    Members
    Member | Description
MetaDataOnly |
NativeDICOM |
Rendered |
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.DicomWeb.WADOOption

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.DicomWeb Namespace


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / IQidoWebClient Interface
Members

In This Topic
    IQidoWebClient Interface
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Interface IQidoWebClient
    'Usage

Dim instance As IQidoWebClient
    public interface IQidoWebClient
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IQidoWebClient Members
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.DicomWeb Namespace / IQidoWebClient Interface
Properties Methods

In This Topic
    IQidoWebClient Interface Members
    In This Topic

    The following tables list the members exposed by IQidoWebClient.

    Public Properties
     | Name | Description
Property | CertFile |
Property | CertPassword |
Property | IncludeAll |
Property | JsonResponseWeight |
Property | Limit |
Property | Offset |
Property | Result |
Property | UseFuzzyMatching |
Property | UseNamesInQuery |
Property | XmlResponseWeight |
    Top
    Public Methods
     | Name | Description
Method | Query |
    Top
    See Also

    Reference

    IQidoWebClient Interface
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.DicomWeb Namespace / IQidoWebClient Interface

    IQidoWebClient Interface Methods
    In This Topic

    For a list of all members of this type, see IQidoWebClient members.

    Public Methods
     | Name | Description
Method | Query |
    Top
    See Also

    Reference

    IQidoWebClient Interface
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / IQidoWebClient Interface / Query Method

    Query Method (IQidoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Function Query( _
   ByVal QueryDataSet As DicomDataSet, _
   Optional ByVal Root As QueryRoot, _
   Optional ByVal Level As QueryLevel _
) As DicomDataSetCollection
    'Usage

Dim instance As IQidoWebClient
Dim QueryDataSet As DicomDataSet
Dim Root As QueryRoot
Dim Level As QueryLevel
Dim value As DicomDataSetCollection

value = instance.Query(QueryDataSet, Root, Level)
    DicomDataSetCollection Query(
   DicomDataSet QueryDataSet,
   QueryRoot Root,
   QueryLevel Level
)

    Parameters

    QueryDataSet
    Root
    Level
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IQidoWebClient Interface
    IQidoWebClient Members


%%PageItemTitle%% $$Properties$$

DicomObjects.DicomWeb Namespace / IQidoWebClient Interface

    IQidoWebClient Interface Properties
    In This Topic

    For a list of all members of this type, see IQidoWebClient members.

    Public Properties
     | Name | Description
Property | CertFile |
Property | CertPassword |
Property | IncludeAll |
Property | JsonResponseWeight |
Property | Limit |
Property | Offset |
Property | Result |
Property | UseFuzzyMatching |
Property | UseNamesInQuery |
Property | XmlResponseWeight |
    Top
    See Also

    Reference

    IQidoWebClient Interface
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / IQidoWebClient Interface / CertFile Property

    CertFile Property (IQidoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Property CertFile As String
    'Usage

Dim instance As IQidoWebClient
Dim value As String

instance.CertFile = value

value = instance.CertFile
    string CertFile {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IQidoWebClient Interface
    IQidoWebClient Members


DicomObjects.DicomWeb Namespace / IQidoWebClient Interface / CertPassword Property

    CertPassword Property (IQidoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Property CertPassword As String
    'Usage

Dim instance As IQidoWebClient
Dim value As String

instance.CertPassword = value

value = instance.CertPassword
    string CertPassword {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IQidoWebClient Interface
    IQidoWebClient Members


DicomObjects.DicomWeb Namespace / IQidoWebClient Interface / IncludeAll Property

    IncludeAll Property (IQidoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Property IncludeAll As Boolean
    'Usage

Dim instance As IQidoWebClient
Dim value As Boolean

instance.IncludeAll = value

value = instance.IncludeAll
    bool IncludeAll {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IQidoWebClient Interface
    IQidoWebClient Members


DicomObjects.DicomWeb Namespace / IQidoWebClient Interface / JsonResponseWeight Property

    JsonResponseWeight Property (IQidoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Property JsonResponseWeight As Single
    'Usage

Dim instance As IQidoWebClient
Dim value As Single

instance.JsonResponseWeight = value

value = instance.JsonResponseWeight
    float JsonResponseWeight {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IQidoWebClient Interface
    IQidoWebClient Members


DicomObjects.DicomWeb Namespace / IQidoWebClient Interface / Limit Property

    Limit Property (IQidoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Property Limit As Integer
    'Usage

Dim instance As IQidoWebClient
Dim value As Integer

instance.Limit = value

value = instance.Limit
    int Limit {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IQidoWebClient Interface
    IQidoWebClient Members


DicomObjects.DicomWeb Namespace / IQidoWebClient Interface / Offset Property

    Offset Property (IQidoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Property Offset As Integer
    'Usage

Dim instance As IQidoWebClient
Dim value As Integer

instance.Offset = value

value = instance.Offset
    int Offset {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IQidoWebClient Interface
    IQidoWebClient Members


DicomObjects.DicomWeb Namespace / IQidoWebClient Interface / Result Property

    Result Property (IQidoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

ReadOnly Property Result As HttpResponseMessage
    'Usage

Dim instance As IQidoWebClient
Dim value As HttpResponseMessage

value = instance.Result
    HttpResponseMessage Result {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IQidoWebClient Interface
    IQidoWebClient Members


DicomObjects.DicomWeb Namespace / IQidoWebClient Interface / UseFuzzyMatching Property

    UseFuzzyMatching Property (IQidoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Property UseFuzzyMatching As Boolean
    'Usage

Dim instance As IQidoWebClient
Dim value As Boolean

instance.UseFuzzyMatching = value

value = instance.UseFuzzyMatching
    bool UseFuzzyMatching {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IQidoWebClient Interface
    IQidoWebClient Members


DicomObjects.DicomWeb Namespace / IQidoWebClient Interface / UseNamesInQuery Property

    UseNamesInQuery Property (IQidoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Property UseNamesInQuery As Boolean
    'Usage

Dim instance As IQidoWebClient
Dim value As Boolean

instance.UseNamesInQuery = value

value = instance.UseNamesInQuery
    bool UseNamesInQuery {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IQidoWebClient Interface
    IQidoWebClient Members


DicomObjects.DicomWeb Namespace / IQidoWebClient Interface / XmlResponseWeight Property

    XmlResponseWeight Property (IQidoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Property XmlResponseWeight As Single
    'Usage

Dim instance As IQidoWebClient
Dim value As Single

instance.XmlResponseWeight = value

value = instance.XmlResponseWeight
    float XmlResponseWeight {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IQidoWebClient Interface
    IQidoWebClient Members


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / IStowWebClient Interface
Members

In This Topic
    IStowWebClient Interface
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Interface IStowWebClient
    'Usage

Dim instance As IStowWebClient
    public interface IStowWebClient
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IStowWebClient Members
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.DicomWeb Namespace / IStowWebClient Interface
Properties Methods

In This Topic
    IStowWebClient Interface Members
    In This Topic

    The following tables list the members exposed by IStowWebClient.

    Public Properties
     | Name | Description
Property | CertFile |
Property | CertPassword |
Property | JsonResponseWeight |
Property | Result |
Property | XmlResponseWeight |
    Top
    Public Methods
     | Name | Description
Method | Store | Overloaded.
    Top
    See Also

    Reference

    IStowWebClient Interface
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.DicomWeb Namespace / IStowWebClient Interface

    IStowWebClient Interface Methods
    In This Topic

    For a list of all members of this type, see IStowWebClient members.

    Public Methods
     | Name | Description
Method | Store | Overloaded.
    Top
    See Also

    Reference

    IStowWebClient Interface
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / IStowWebClient Interface / Store Method

    Store Method (IStowWebClient)
    In This Topic
    Overload List
    Overload | Description
Store(DicomDataSetCollection,DicomDataEncoding,String) |
Store(DicomDataSetCollection,String) |
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IStowWebClient Interface
    IStowWebClient Members


DicomObjects.DicomWeb Namespace / IStowWebClient Interface / Store Method / Store(DicomDataSetCollection,DicomDataEncoding,String) Method

    Store(DicomDataSetCollection,DicomDataEncoding,String) Method
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Overloads Function Store( _
   ByVal DataSets As DicomDataSetCollection, _
   ByVal Encoding As DicomDataEncoding, _
   ByVal TransferSyntax As String _
) As DicomDataSet
    'Usage

Dim instance As IStowWebClient
Dim DataSets As DicomDataSetCollection
Dim Encoding As DicomDataEncoding
Dim TransferSyntax As String
Dim value As DicomDataSet

value = instance.Store(DataSets, Encoding, TransferSyntax)
    DicomDataSet Store(
   DicomDataSetCollection DataSets,
   DicomDataEncoding Encoding,
   string TransferSyntax
)

    Parameters

    DataSets
    Encoding
    TransferSyntax
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IStowWebClient Interface
    IStowWebClient Members
    Overload List


DicomObjects.DicomWeb Namespace / IStowWebClient Interface / Store Method / Store(DicomDataSetCollection,String) Method

    Store(DicomDataSetCollection,String) Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Overloads Function Store( _
   ByVal DataSets As DicomDataSetCollection, _
   ByVal TransferSyntax As String _
) As HttpResponseMessage
    'Usage

Dim instance As IStowWebClient
Dim DataSets As DicomDataSetCollection
Dim TransferSyntax As String
Dim value As HttpResponseMessage

value = instance.Store(DataSets, TransferSyntax)
    HttpResponseMessage Store(
   DicomDataSetCollection DataSets,
   string TransferSyntax
)

    Parameters

    DataSets
    TransferSyntax
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IStowWebClient Interface
    IStowWebClient Members
    Overload List


%%PageItemTitle%% $$Properties$$

DicomObjects.DicomWeb Namespace / IStowWebClient Interface

    IStowWebClient Interface Properties
    In This Topic

    For a list of all members of this type, see IStowWebClient members.

    Public Properties
     | Name | Description
Property | CertFile |
Property | CertPassword |
Property | JsonResponseWeight |
Property | Result |
Property | XmlResponseWeight |
    Top
    See Also

    Reference

    IStowWebClient Interface
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / IStowWebClient Interface / CertFile Property

    CertFile Property (IStowWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Property CertFile As String
    'Usage

Dim instance As IStowWebClient
Dim value As String

instance.CertFile = value

value = instance.CertFile
    string CertFile {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IStowWebClient Interface
    IStowWebClient Members


DicomObjects.DicomWeb Namespace / IStowWebClient Interface / CertPassword Property

    CertPassword Property (IStowWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Property CertPassword As String
    'Usage

Dim instance As IStowWebClient
Dim value As String

instance.CertPassword = value

value = instance.CertPassword
    string CertPassword {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IStowWebClient Interface
    IStowWebClient Members


DicomObjects.DicomWeb Namespace / IStowWebClient Interface / JsonResponseWeight Property

    JsonResponseWeight Property (IStowWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Property JsonResponseWeight As Single
    'Usage

Dim instance As IStowWebClient
Dim value As Single

instance.JsonResponseWeight = value

value = instance.JsonResponseWeight
    float JsonResponseWeight {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IStowWebClient Interface
    IStowWebClient Members


DicomObjects.DicomWeb Namespace / IStowWebClient Interface / Result Property

    Result Property (IStowWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

ReadOnly Property Result As HttpResponseMessage
    'Usage

Dim instance As IStowWebClient
Dim value As HttpResponseMessage

value = instance.Result
    HttpResponseMessage Result {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IStowWebClient Interface
    IStowWebClient Members


DicomObjects.DicomWeb Namespace / IStowWebClient Interface / XmlResponseWeight Property

    XmlResponseWeight Property (IStowWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Property XmlResponseWeight As Single
    'Usage

Dim instance As IStowWebClient
Dim value As Single

instance.XmlResponseWeight = value

value = instance.XmlResponseWeight
    float XmlResponseWeight {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IStowWebClient Interface
    IStowWebClient Members


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / IWadoWebClient Interface
Members

In This Topic
    IWadoWebClient Interface
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Interface IWadoWebClient
    'Usage

Dim instance As IWadoWebClient
    public interface IWadoWebClient
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IWadoWebClient Members
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.DicomWeb Namespace / IWadoWebClient Interface
Properties Methods

In This Topic
    IWadoWebClient Interface Members
    In This Topic

    The following tables list the members exposed by IWadoWebClient.

    Public Properties
     | Name | Description
Property | CertFile |
Property | CertPassword |
Property | JsonResponseWeight |
Property | Result |
Property | TransferSyntaxes |
Property | XmlResponseWeight |
    Top
    Public Methods
     | Name | Description
Method | AppendBulkData |
Method | RetrieveMetaData |
Method | RetrieveNative | Overloaded.
Method | RetrieveRendered |
    Top
    See Also

    Reference

    IWadoWebClient Interface
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.DicomWeb Namespace / IWadoWebClient Interface

    IWadoWebClient Interface Methods
    In This Topic

    For a list of all members of this type, see IWadoWebClient members.

    Public Methods
     | Name | Description
Method | AppendBulkData |
Method | RetrieveMetaData |
Method | RetrieveNative | Overloaded.
Method | RetrieveRendered |
    Top
    See Also

    Reference

    IWadoWebClient Interface
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / IWadoWebClient Interface / AppendBulkData Method

    AppendBulkData Method (IWadoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Sub AppendBulkData( _
   ByVal DataSets As DicomDataSetCollection _
)
    'Usage

Dim instance As IWadoWebClient
Dim DataSets As DicomDataSetCollection

instance.AppendBulkData(DataSets)
    void AppendBulkData(
   DicomDataSetCollection DataSets
)

    Parameters

    DataSets
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IWadoWebClient Interface
    IWadoWebClient Members


DicomObjects.DicomWeb Namespace / IWadoWebClient Interface / RetrieveMetaData Method

    RetrieveMetaData Method (IWadoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Function RetrieveMetaData( _
   ByVal StudyUID As String, _
   Optional ByVal SeriesUID As String, _
   Optional ByVal InstanceUID As String _
) As DicomDataSetCollection
    'Usage

Dim instance As IWadoWebClient
Dim StudyUID As String
Dim SeriesUID As String
Dim InstanceUID As String
Dim value As DicomDataSetCollection

value = instance.RetrieveMetaData(StudyUID, SeriesUID, InstanceUID)
    DicomDataSetCollection RetrieveMetaData(
   string StudyUID,
   string SeriesUID,
   string InstanceUID
)

    Parameters

    StudyUID
    SeriesUID
    InstanceUID
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IWadoWebClient Interface
    IWadoWebClient Members


DicomObjects.DicomWeb Namespace / IWadoWebClient Interface / RetrieveNative Method

    RetrieveNative Method (IWadoWebClient)
    In This Topic
    Overload List
    Overload | Description
RetrieveNative(DicomDataSet) |
RetrieveNative(String,String,String,Int32[],QueryRoot,String,Nullable<Int32>) |
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IWadoWebClient Interface
    IWadoWebClient Members


DicomObjects.DicomWeb Namespace / IWadoWebClient Interface / RetrieveNative Method / RetrieveNative(DicomDataSet) Method

    RetrieveNative(DicomDataSet) Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Overloads Function RetrieveNative( _
   ByVal RetrieveDataSet As DicomDataSet _
) As IEnumerable(Of DicomDataSet)
    'Usage

Dim instance As IWadoWebClient
Dim RetrieveDataSet As DicomDataSet
Dim value As IEnumerable(Of DicomDataSet)

value = instance.RetrieveNative(RetrieveDataSet)
    IEnumerable<DicomDataSet> RetrieveNative(
   DicomDataSet RetrieveDataSet
)

    Parameters

    RetrieveDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IWadoWebClient Interface
    IWadoWebClient Members
    Overload List


DicomObjects.DicomWeb Namespace / IWadoWebClient Interface / RetrieveNative Method / RetrieveNative(String,String,String,Int32[],QueryRoot,String,Nullable<Int32>) Method

    RetrieveNative(String,String,String,Int32[],QueryRoot,String,Nullable<Int32>) Method
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Overloads Function RetrieveNative( _
   ByVal StudyUID As String, _
   Optional ByVal SeriesUID As String, _
   Optional ByVal InstanceUID As String, _
   Optional ByVal Frames() As Integer, _
   Optional ByVal Root As QueryRoot, _
   Optional ByVal SOPClassUID As String, _
   Optional ByVal BeamNumber As Nullable(Of Integer) _
) As IEnumerable(Of DicomDataSet)
    'Usage

Dim instance As IWadoWebClient
Dim StudyUID As String
Dim SeriesUID As String
Dim InstanceUID As String
Dim Frames() As Integer
Dim Root As QueryRoot
Dim SOPClassUID As String
Dim BeamNumber As Nullable(Of Integer)
Dim value As IEnumerable(Of DicomDataSet)

value = instance.RetrieveNative(StudyUID, SeriesUID, InstanceUID, Frames, Root, SOPClassUID, BeamNumber)
    IEnumerable<DicomDataSet> RetrieveNative(
   string StudyUID,
   string SeriesUID,
   string InstanceUID,
   int[] Frames,
   QueryRoot Root,
   string SOPClassUID,
   Nullable<int> BeamNumber
)

    Parameters

    StudyUID
    SeriesUID
    InstanceUID
    Frames
    Root
    SOPClassUID
    BeamNumber
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IWadoWebClient Interface
    IWadoWebClient Members
    Overload List


DicomObjects.DicomWeb Namespace / IWadoWebClient Interface / RetrieveRendered Method

    RetrieveRendered Method (IWadoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Function RetrieveRendered( _
   ByVal StudyUID As String, _
   Optional ByVal SeriesUID As String, _
   Optional ByVal InstanceUID As String, _
   Optional ByVal Frames As IEnumerable(Of Integer) _
) As Dictionary(Of HttpContentHeaders,Byte())
    'Usage

Dim instance As IWadoWebClient
Dim StudyUID As String
Dim SeriesUID As String
Dim InstanceUID As String
Dim Frames As IEnumerable(Of Integer)
Dim value As Dictionary(Of HttpContentHeaders,Byte())

value = instance.RetrieveRendered(StudyUID, SeriesUID, InstanceUID, Frames)
    Dictionary<HttpContentHeaders,byte[]> RetrieveRendered(
   string StudyUID,
   string SeriesUID,
   string InstanceUID,
   IEnumerable<int> Frames
)

    Parameters

    StudyUID
    SeriesUID
    InstanceUID
    Frames
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IWadoWebClient Interface
    IWadoWebClient Members


%%PageItemTitle%% $$Properties$$

DicomObjects.DicomWeb Namespace / IWadoWebClient Interface

    IWadoWebClient Interface Properties
    In This Topic

    For a list of all members of this type, see IWadoWebClient members.

    Public Properties
     | Name | Description
Property | CertFile |
Property | CertPassword |
Property | JsonResponseWeight |
Property | Result |
Property | TransferSyntaxes |
Property | XmlResponseWeight |
    Top
    See Also

    Reference

    IWadoWebClient Interface
    DicomObjects.DicomWeb Namespace


DicomObjects.DicomWeb Namespace / IWadoWebClient Interface / CertFile Property

    CertFile Property (IWadoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Property CertFile As String
    'Usage

Dim instance As IWadoWebClient
Dim value As String

instance.CertFile = value

value = instance.CertFile
    string CertFile {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IWadoWebClient Interface
    IWadoWebClient Members


DicomObjects.DicomWeb Namespace / IWadoWebClient Interface / CertPassword Property

    CertPassword Property (IWadoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Property CertPassword As String
    'Usage

Dim instance As IWadoWebClient
Dim value As String

instance.CertPassword = value

value = instance.CertPassword
    string CertPassword {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IWadoWebClient Interface
    IWadoWebClient Members


DicomObjects.DicomWeb Namespace / IWadoWebClient Interface / JsonResponseWeight Property

    JsonResponseWeight Property (IWadoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Property JsonResponseWeight As Single
    'Usage

Dim instance As IWadoWebClient
Dim value As Single

instance.JsonResponseWeight = value

value = instance.JsonResponseWeight
    float JsonResponseWeight {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IWadoWebClient Interface
    IWadoWebClient Members


DicomObjects.DicomWeb Namespace / IWadoWebClient Interface / Result Property

    Result Property (IWadoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

ReadOnly Property Result As HttpResponseMessage
    'Usage

Dim instance As IWadoWebClient
Dim value As HttpResponseMessage

value = instance.Result
    HttpResponseMessage Result {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IWadoWebClient Interface
    IWadoWebClient Members


DicomObjects.DicomWeb Namespace / IWadoWebClient Interface / TransferSyntaxes Property

    TransferSyntaxes Property (IWadoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Property TransferSyntaxes As List(Of String)
    'Usage

Dim instance As IWadoWebClient
Dim value As List(Of String)

instance.TransferSyntaxes = value

value = instance.TransferSyntaxes
    List<string> TransferSyntaxes {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IWadoWebClient Interface
    IWadoWebClient Members


DicomObjects.DicomWeb Namespace / IWadoWebClient Interface / XmlResponseWeight Property

    XmlResponseWeight Property (IWadoWebClient)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Property XmlResponseWeight As Single
    'Usage

Dim instance As IWadoWebClient
Dim value As Single

instance.XmlResponseWeight = value

value = instance.XmlResponseWeight
    float XmlResponseWeight {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IWadoWebClient Interface
    IWadoWebClient Members


Inheritance Hierarchy
    DicomObjects.DicomWeb.Delegates Namespace
    Delegates
     | Delegate | Description
Delegate | QidoReceivedDelegate |
Delegate | StowReceivedDelegate |
Delegate | WadoReceivedDelegate |
    See Also

    Reference

    DicomObjects.Core Assembly


%%PageItemTitle%%

DicomObjects.DicomWeb.Delegates Namespace / QidoReceivedDelegate Delegate

In This Topic
    QidoReceivedDelegate Delegate
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Sub QidoReceivedDelegate( _
   ByVal args As QidoEventArgs _
)
    'Usage

Dim instance As New QidoReceivedDelegate(AddressOf HandlerMethod)
    public delegate void QidoReceivedDelegate(
   QidoEventArgs args
)

    Parameters

    args
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QidoReceivedDelegate Members
    DicomObjects.DicomWeb.Delegates Namespace


%%PageItemTitle%%

DicomObjects.DicomWeb.Delegates Namespace / StowReceivedDelegate Delegate

In This Topic
    StowReceivedDelegate Delegate
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Sub StowReceivedDelegate( _
   ByVal args As StowEventArgs _
)
    'Usage

Dim instance As New StowReceivedDelegate(AddressOf HandlerMethod)
    public delegate void StowReceivedDelegate(
   StowEventArgs args
)

    Parameters

    args
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    StowReceivedDelegate Members
    DicomObjects.DicomWeb.Delegates Namespace


%%PageItemTitle%%

DicomObjects.DicomWeb.Delegates Namespace / WadoReceivedDelegate Delegate

In This Topic
    WadoReceivedDelegate Delegate
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Delegate Sub WadoReceivedDelegate( _
   ByVal args As WadoEventArgs _
)
    'Usage

Dim instance As New WadoReceivedDelegate(AddressOf HandlerMethod)
    public delegate void WadoReceivedDelegate(
   WadoEventArgs args
)

    Parameters

    args
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WadoReceivedDelegate Members
    DicomObjects.DicomWeb.Delegates Namespace


Inheritance Hierarchy
    DicomObjects.Enums Namespace
    Enumerations
     | Enumeration | Description
Enumeration | BasicOffsetTableHandling | Allows control of Basic Offset Table (BOT) Handling when writing data
Enumeration | CacheTypes | Flags which are used to control caching.
Enumeration | ChangeUidReason | reason why a UID should be changed
Enumeration | CodecOperation | The basic types of codec operation requested by DicomObjects
Enumeration | CodecUsage | Enum to control whether a codec should use the Windows codec when available.
Enumeration | DecompressStatus | The state of decompression of an image
Enumeration | DicomOperation | The Full List of DICOM Primitive operations
Enumeration | DisplayMode | Controls how images are rendered
Enumeration | DrawCacheMode | Controls how images are drawn internally
Enumeration | FilterMode | Enumerated values for filter mode
Enumeration | FlipState | Enumerated values for flip mode
Enumeration | Keyword | The complete enumerated list of all DICOM data element. Enum representation can be used for adding and indexing data element in DicomDataSet object
Enumeration | LicencedFunctions |
Enumeration | LicenceTypes |
Enumeration | LogLevel | Log levels
Enumeration | MaskMode | Enumerated values for mask operations
Enumeration | PresentationStateFeatures | Flags to control which features of presentation states are used and/or converted
Enumeration | Progression | Ordering of packet used in JPEG 2000 & JPIP
Enumeration | ProgressiveStatus | The status of an image being viewed in a progressive manner
Enumeration | QueryLevel | Enumerated values for Query Level
Enumeration | QueryRoot | Enumerated values for Query Root
Enumeration | RequestType | Enum used in the class to pecify the required usage of the data requested
Enumeration | RetrieveType | The type of retrieval requested
Enumeration | RotateState | Enumerated values for rotate mode
Enumeration | RotationBehaviour | Rotation behaviour of the Image
Enumeration | RotationMode | Possible values for controlling the rotation behaviour of a label.
Enumeration | ScaleMode | How DicomLabel objects' dimensions should be interpreted - i.e. how they should be scaled
Enumeration | SOPClassGroups | The categories of SOP class used for negotiation
Enumeration | StatusCode | Common DICOM status codes
Enumeration | StatusType | DICOM status code type
Enumeration | StretchModes | Controls how an image is displayed
Enumeration | UIDType | Classification of DICOM UID types
Enumeration | UserIdentityResponseType | User Identity Response Type for User Identity Negotiation
Enumeration | UserIdentityType | User Identity Type for User Identity Negotiation
Enumeration | ViewerMode | The modes which can be used for displaying DICOM images in a
Enumeration | VoiLUTFunction | Controls which VOILUT function to be used
Enumeration | WaveletTransform | The types of wavelet transform used in JPEG 2000 & JPIP
    See Also

    Reference

    DicomObjects.Core Assembly


%%PageItemTitle%%

DicomObjects.Enums Namespace / BasicOffsetTableHandling Enumeration

In This Topic
    BasicOffsetTableHandling Enumeration
    In This Topic
    Allows control of Basic Offset Table (BOT) Handling when writing data
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum BasicOffsetTableHandling
   Inherits System.Enum
    'Usage

Dim instance As BasicOffsetTableHandling
    public enum BasicOffsetTableHandling : System.Enum
    Members
    Member | Description
CompressAndCache | Each frame is compressed and cached in memory, allowing the lengths to be calculated. The BOT is then written using those lengths, followed by the cached fragments themselves.
CompressTwice | Each frame is compressed allowing the lengths to be calculated, but the frames are discarded. The BOT is then written using those lengths, followed by the fragments themselves, which are generated by compressing the data a second time.
Omit | An empty (zero-length) BOT is written
Seek | The individual fragments are written, and the stream position is then moved back to the BOT to write the locations. This is the most efficient solution to producing a BOT, but is only applicable to seekable media and therefore cannot be used when performing C-STORE etc.
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.BasicOffsetTableHandling

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / CacheTypes Enumeration

    CacheTypes Enumeration
    In This Topic
    Flags which are used to control caching.
    Syntax
    • Visual Basic
    • C#
    'Declaration

<FlagsAttribute()>
Public Enum CacheTypes
   Inherits System.Enum
    'Usage

Dim instance As CacheTypes
    [Flags()]
public enum CacheTypes : System.Enum
    Members
    Member | Description
All | All caches
CompressedData | Specifies the raw compressed pixel data (where it needs to be read from disk)
Display |
LookupTables |
None | No caching at all
PixelData | Specifies the raw uncompressed pixel data (where it needs to be decompressed or read from disk)
Texture |
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.CacheTypes

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / ChangeUidReason Enumeration

    ChangeUidReason Enumeration
    In This Topic
    reason why a UID should be changed
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum ChangeUidReason
   Inherits System.Enum
    'Usage

Dim instance As ChangeUidReason
    public enum ChangeUidReason : System.Enum
    Members
    Member | Description
LossyCompression | Lossy image compression is being applied
SopClassCoersion | The SOP class is being coerced
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.ChangeUidReason

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / CodecOperation Enumeration

    CodecOperation Enumeration
    In This Topic
    The basic types of codec operation requested by DicomObjects
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum CodecOperation
   Inherits System.Enum
    'Usage

Dim instance As CodecOperation
    public enum CodecOperation : System.Enum
    Members
    Member | Description
Compress | Compression of DICOM images
Decompress | Decompression of DICOM compressed images
Export | Export of images to external files
Import | Import of images from external files
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.CodecOperation

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / CodecUsage Enumeration

    CodecUsage Enumeration
    In This Topic
    Enum to control whether a codec should use the Windows codec when available.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum CodecUsage
   Inherits System.Enum
    'Usage

Dim instance As CodecUsage
    public enum CodecUsage : System.Enum
    Members
    Member | Description
DicomObjects | Use the DicomObjects codec
Windows | Use the Windows codec
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.CodecUsage

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / DecompressStatus Enumeration

    DecompressStatus Enumeration
    In This Topic
    The state of decompression of an image
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum DecompressStatus
   Inherits System.Enum
    'Usage

Dim instance As DecompressStatus
    public enum DecompressStatus : System.Enum
    Members
    Member | Description
AllDownloaded | All data downloaded has been decompressed
Complete | The image has been fully decompressed at full resolution
InProgress | Data is waiting to be decompressed
None | Nothing decompressed yet
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.DecompressStatus

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / DicomOperation Enumeration

    DicomOperation Enumeration
    In This Topic
    The Full List of DICOM Primitive operations
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum DicomOperation
   Inherits System.Enum
    'Usage

Dim instance As DicomOperation
    public enum DicomOperation : System.Enum
    Members
    Member | Description
C_CANCEL | C-CANCEL : 0FFFH
C_ECHO | C-ECHO : 0030H
C_ECHO_RSP | C-ECHO Response : 8030H
C_FIND | C-FIND : 0020H
C_FIND_RSP | C-FIND Response : 8020H
C_GET | C-GET : 0010H
C_GET_RSP | C-GET Response : 8010H
C_MOVE | C-MOVE : 0021H
C_MOVE_RSP | C-MOVE Response : 8021H
C_STORE | C-STORE : 0001H
C_STORE_RSP | C-STORE Response : 8001H
N_ACTION | N-ACTION : 0130H
N_ACTION_RSP | N-ACTION Response : 8130H
N_CREATE | N-CREATE : 0140H
N_CREATE_RSP | N-CREATE Response : 8140H
N_DELETE | N-DELETE : 0150H
N_DELETE_RSP | N-DELETE Response : 8150H
N_EVENT_REPORT | N-EVENT_REPORT : 0100H
N_EVENT_REPORT_RSP | N-EVENT_REPORT Response : 8100H
N_GET | N-GET : 0110H
N_GET_RSP | N-GET Response : 8110H
N_SET | N-SET : 0120H
N_SET_RSP | N-SET Response : 8120H
NONE | No Operation
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.DicomOperation

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / DisplayMode Enumeration

    DisplayMode Enumeration
    In This Topic
    Controls how images are rendered
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum DisplayMode
   Inherits System.Enum
    'Usage

Dim instance As DisplayMode
    public enum DisplayMode : System.Enum
    Members
    Member | Description
Auto | Use Monochome if the image is monochrom and RGB is the image is colour
Monochrome | Force use of monochrome mode
RGB | Force use of RGB mode
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.DisplayMode

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / DrawCacheMode Enumeration

    DrawCacheMode Enumeration
    In This Topic
    Controls how images are drawn internally
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum DrawCacheMode
   Inherits System.Enum
    'Usage

Dim instance As DrawCacheMode
    public enum DrawCacheMode : System.Enum
    Members
    Member | Description
AfterLabels | Rendered copy has labelled added and is then cached. If this mode is used, then the cache is cleared when labels change. This mode is incompatible with DisplayMode.Monochrome as .NET des not permit use of a monochrome bitmap as a Graphics object. The mode will silently revert to BeforeLabels if DisplayMode is monochrome, or if it is Auto on a monochrome image.
BeforeLabels | Rendered copy is cached, and then drawn to the screen. Labels are drawn separately to the screen.
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.DrawCacheMode

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / FilterMode Enumeration

    FilterMode Enumeration
    In This Topic
    Enumerated values for filter mode
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum FilterMode
   Inherits System.Enum
    'Usage

Dim instance As FilterMode
    public enum FilterMode : System.Enum
    Members
    Member | Description
BiLinear | This mode is most applicable when zoom is >1, and uses bilinear interpolation. This is a simple and relatively fast means of magnification.
BSpline | This smoothing procedure interpolates using a Cubic B-Spline, which has the advantage of guaranteeing continuity in both the first and second differentials of the image, in both directions. No other parameters are used in this smoothing method, which produces good visual results, though some users find them a little too "smoothed"
BSpline2 | Custom format
CubicSpline | This is similar to the B-Spline described above, but uses an additional parameter (CubicSplineAlpha) to control the degree of smoothing or edge enhancement. The default value is –0.75, and normal values range fro –0.5 to –1.25, though higher negative values may be used to produce deliberate edge enhancement, though generally, UnsharpLength and UnsharpEnhancement should be used for this purpose, as they are independent of the smoothing method.
Default | For MagnificationMode, this acts identically to doFilterReplicate and for MinificationMode it acts as doFilterMovingAverage. This behaviour is the default, and is designed to minimise regulatory issues by doing the minimum necessary to display all pixel data, without adding extra "Image processing".
Gpu | This mode uses interpolation in the GPU to apply magnification or minification. It does not give as much flexibility as the other modes, but may be significant faster, whilst still avoiding a "blocky" effect for magnification and avoiding aliasing on grid-lines for minification.
MovingAverage | This mode is most applicable when zoom is <1, and calculates pixel values as a weighted average of the surrounding values. The number of values used for this calculation depends on the value of FilterLength. If this is 0 (the default), then a suitable values is determined internally, based on the zoom (approximately 2/ActualZoom), but if FilterLength is non-zero then 2*FilterLength values are used.
Replicate | If zooming up is necessary, then pixels are simply replicated, giving a possibly "blocky" but honest representation of the pixel data. For minification, rows and columns are simply omitted as necessary.
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.FilterMode

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / FlipState Enumeration

    FlipState Enumeration
    In This Topic
    Enumerated values for flip mode
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum FlipState
   Inherits System.Enum
    'Usage

Dim instance As FlipState
    public enum FlipState : System.Enum
    Members
    Member | Description
Both | Image is mirrored vertically and horizontally
Horizontal | Image is mirrored horizontally
Normal | No flipping specified
Vertical | Image is mirrored vertically
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.FlipState

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / Keyword Enumeration

    Keyword Enumeration
    In This Topic
    The complete enumerated list of all DICOM data element. Enum representation can be used for adding and indexing data element in DicomDataSet object
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum Keyword
   Inherits System.Enum
    'Usage

Dim instance As Keyword
    public enum Keyword : System.Enum
    Members
    Member | Description
AbortFlag | (4010,1024): Abort Flag
AbortReason | (4010,1021): Abort Reason
AbsoluteChannelDisplayScale | (003A,0248): Absolute Channel Display Scale
AbsoluteDosimetricObjectiveFlag | (3010,0073): Absolute Dosimetric Objective Flag
AbsorbedDoseToMetersetRatio |
AbstractPriorCodeSequence | (0072,003E): Abstract Prior Code Sequence
AbstractPriorValue | (0072,003C): Abstract Prior Value
Acceleration | (0016,0034): Acceleration
AccessionNumber | (0008,0050): Accession Number
AccessoryCode | (300A,00F9): Accessory Code
AcousticCouplingMediumCodeSequence |
AcousticCouplingMediumFlag |
AcousticCouplingMediumSoundSpeed |
AcousticCouplingMediumTemperature |
AcquiredImageAreaDoseProduct | (0018,9473): Acquired Image Area Dose Product
AcquiredSoundpathLength | (0014,4031): Acquired Soundpath Length
AcquiredSubtractionMaskFlag | (0018,11B2): Acquired Subtraction Mask Flag
AcquisitionComments | (0018,4000): Acquisition Comments()
AcquisitionCompressionType | (0014,4032): Acquisition Compression Type
AcquisitionContextDescription | (0040,0556): Acquisition Context Description
AcquisitionContextSequence | (0040,0555): Acquisition Context Sequence
AcquisitionContrast | (0008,9209): Acquisition Contrast
AcquisitionDate | (0008,0022): Acquisition Date
AcquisitionDateTime | (0008,002A): Acquisition DateTime
AcquisitionDeviceProcessingCode | (0018,1401): Acquisition Device Processing Code
AcquisitionDeviceProcessingDescription | (0018,1400): Acquisition Device Processing Description
AcquisitionDeviceSequence |
AcquisitionDeviceTypeCodeSequence | (0022,0015): Acquisition Device Type Code Sequence
AcquisitionDuration | (0018,9073): Acquisition Duration
AcquisitionEndLocationSequence | (0018,9932): Acquisition End Location Sequence
AcquisitionFieldOfViewLabel | (0018,11BB): Acquisition Field of View Label
AcquisitionIndex | (0020,9518): Acquisition Index
AcquisitionInitiationSequence |
AcquisitionMatrix | (0018,1310): Acquisition Matrix
AcquisitionMethod |
AcquisitionMethodAlgorithmSequence | (0022,1423): Acquisition Method Algorithm Sequence
AcquisitionMethodCodeSequence | (0022,1420): Acquisition Method Code Sequence
AcquisitionMode | (0018,11B0): Acquisition Mode
AcquisitionMotion | (0018,9930): Acquisition Motion
AcquisitionNumber | (0020,0012): Acquisition Number
AcquisitionProtocolDescription | (0018,9424): Acquisition Protocol Description
AcquisitionProtocolElementSequence | (0018,9920): Acquisition Protocol Element Sequence
AcquisitionProtocolElementSpecificationSequence | (0018,991F): Acquisition Protocol Element Specification Sequence
AcquisitionProtocolName | (0018,9423): Acquisition Protocol Name
AcquisitionSampleSize | (0014,4033): Acquisition Sample Size
AcquisitionSignalType |
AcquisitionsInSeries | (0020,1001): Acquisitions in Series()
AcquisitionsInStudy | (0020,1004): Acquisitions in Study
AcquisitionStartCondition | (0018,0073): Acquisition Start Condition
AcquisitionStartConditionData | (0018,0074): Acquisition Start Condition Data
AcquisitionStartLocationSequence | (0018,9931): Acquisition Start Location Sequence
AcquisitionStatus | (4010,1044): Acquisition Status
AcquisitionSubtaskIndex |
AcquisitionSubtaskSequence |
AcquisitionTaskApplicabilitySequence |
AcquisitionTaskIndex |
AcquisitionTaskSequence |
AcquisitionTaskWorkitemCodeSequence |
AcquisitionTerminationCondition | (0018,0071): Acquisition Termination Condition
AcquisitionTerminationConditionData | (0018,0075): Acquisition Termination Condition Data
AcquisitionTime | (0008,0032): Acquisition Time
AcquisitionTimeSynchronized | (0018,1800): Acquisition Time Synchronized
AcquisitionType | (0018,9302): Acquisition Type
AcquisitionUID |
AcrossScanSpatialResolution | (0022,0048): Across-scan Spatial Resolution
ActionTypeID | (0000,1008): Action Type ID
ActiveAperture | (0014,5100): Active Aperture
ActiveImageAreaOverlayGroup | (0018,6070): Active Image Area Overlay Group
ActiveSourceDiameter | (300A,0218): Active Source Diameter
ActiveSourceLength | (300A,021A): Active Source Length
ActualCardiacTriggerDelayTime | (0020,9252): Actual Cardiac Trigger Delay Time
ActualCardiacTriggerTimePriorToRPeak | (0020,9155): Actual Cardiac Trigger Time Prior To R-Peak
ActualEnvironmentalConditions | (0014,1010): Actual Environmental Conditions
ActualFrameDuration | (0018,1242): Actual Frame Duration
ActualHumanPerformersSequence | (0040,4035): Actual Human Performers Sequence
ActualRespiratoryTriggerDelayTime | (0020,9257): Actual Respiratory Trigger Delay Time
AdaptiveMapFormat | (0028,0730): Adaptive Map Format
AddGrayScale | (0000,5150): Add Gray Scale()
AddIntermediateSequence | (0046,0101): Add Intermediate Sequence
AdditionalDrugSequence | (0018,002A): Additional Drug Sequence
AdditionalInspectionMethodSequence | (4010,106F): Additional Inspection Method Sequence
AdditionalInspectionSelectionCriteria | (4010,106E): Additional Inspection Selection Criteria
AdditionalParameterRecordingInstanceSequence | (300A,0780): Additional Parameter Recording Instance Sequence
AdditionalPatientHistory | (0010,21B0): Additional Patient History
AdditionalRTAccessoryDeviceSequence |
AdditionalRTROIIdentificationCodeSequence | (3006,00B9): Additional RT ROI Identification Code Sequence
AdditionalScreeningPerformed | (4010,106D): Additional Screening Performed
AddNearSequence | (0046,0100): Add Near Sequence
AddOtherSequence | (0046,0102): Add Other Sequence
AddPower | (0046,0104): Add Power
AddressTrial | (0040,A353): Address (Trial)
AdministrationRouteCodeSequence | (0054,0302): Administration Route Code Sequence
AdmissionID | (0038,0010): Admission ID
AdmittingDate | (0038,0020): Admitting Date
AdmittingDiagnosesCodeSequence | (0008,1084): Admitting Diagnoses Code Sequence
AdmittingDiagnosesDescription | (0008,1080): Admitting Diagnoses Description
AdmittingTime | (0038,0021): Admitting Time
AdvancedBlendingSequence | (0070,1B01): Advanced Blending Sequence
AffectedSOPClassUID | (0000,0002): Affected SOP Class UID
AffectedSOPInstanceUID | (0000,1000): Affected SOP Instance UID
AfterloaderChannelID | (300A,0273): Afterloader Channel ID
AgeCorrectedSensitivityDeviationAlgorithmSequence | (0024,0065): Age Corrected Sensitivity Deviation Algorithm Sequence
AgeCorrectedSensitivityDeviationProbabilityValue | (0024,0100): Age Corrected Sensitivity Deviation Probability Value
AgeCorrectedSensitivityDeviationValue | (0024,0092): Age Corrected Sensitivity Deviation Value
AirCounts | (0014,3070): Air Counts
AITDeviceType | (4010,1070): AIT Device Type
AlarmDecision | (4010,1031): Alarm Decision
AlarmDecisionTime | (4010,102B): Alarm Decision Time
AlgorithmCodeSequenceTrial | (0040,A296): Algorithm Code Sequence (Trial)
AlgorithmDescription | (0018,9528): Algorithm Description
AlgorithmDescriptionTrial | (0040,A297): Algorithm Description (Trial)
AlgorithmFamilyCodeSequence | (0066,002F): Algorithm Family Code Sequence
AlgorithmName | (0066,0036): Algorithm Name
AlgorithmNameCodeSequence | (0066,0030): Algorithm Name Code Sequence
AlgorithmParameters | (0066,0032): Algorithm Parameters
AlgorithmRoutingCodeSequence | (4010,1064): Algorithm Routing Code Sequence
AlgorithmSource | (0024,0202): Algorithm Source
AlgorithmType | (0018,9527): Algorithm Type
AlgorithmVersion | (0066,0031): Algorithm Version
AliasedDataType | (0018,980B): Aliased Data Type
ALinePixelSpacing | (0052,0014): A-line Pixel Spacing
ALineRate | (0052,0011): A-line Rate
ALinesPerFrame | (0052,0012): A-lines Per Frame
Allergies | (0010,2110): Allergies
AllowLossyCompression | (2200,000F): Allow Lossy Compression
AllowMediaSplitting | (2200,0007): Allow Media Splitting
AlongScanSpatialResolution | (0022,0037): Along-scan Spatial Resolution
AlphaLUTTransferFunction | (0028,1410): Alpha LUT Transfer Function
AlphaPaletteColorLookupTableData | (0028,1204): Alpha Palette Color Lookup Table Data
AlphaPaletteColorLookupTableDescriptor | (0028,1104): Alpha Palette Color Lookup Table Descriptor
AlternateBeamDose | (300A,0091): Alternate Beam Dose
AlternateBeamDoseType | (300A,0092): Alternate Beam Dose Type
AlternateContainerIdentifierSequence | (0040,0515): Alternate Container Identifier Sequence
AlternateContentDescriptionSequence | (0070,0087): Alternate Content Description Sequence
AlternateRepresentationSequence | (0008,3001): Alternate Representation Sequence
AlternateValueSequence | (300A,073E): Alternate Value Sequence
AmbientLightValueSource | (0028,7025): Ambient Light Value Source
AmbientReflectionIntensity | (0070,1702): Ambient Reflection Intensity
AmplifierType | (0014,400A): Amplifier Type
AnalogFilterCharacteristicsSequence |
AnalogFilterRollOff |
AnalogFilterType |
AnalyzedArea | (0046,0227): Analyzed Area
AnatomicalOrientationType | (0010,2210): Anatomical Orientation Type
AnatomicApproachDirectionCodeSequenceTrial | (0008,2255): Anatomic Approach Direction Code Sequence (Trial)
AnatomicLocationOfExaminingInstrumentCodeSequenceTrial | (0008,2259): Anatomic Location Of Examining Instrument Code Sequence (Trial)
AnatomicLocationOfExaminingInstrumentDescriptionTrial | (0008,2258): Anatomic Location Of Examining Instrument Description (Trial)
AnatomicPerspectiveCodeSequenceTrial | (0008,2257): Anatomic Perspective Code Sequence (Trial)
AnatomicPerspectiveDescriptionTrial | (0008,2256): Anatomic Perspective Description (Trial)
AnatomicPortalOfEntranceCodeSequenceTrial | (0008,2253): Anatomic Portal Of Entrance Code Sequence (Trial)
AnatomicRegionModifierSequence | (0008,2220): Anatomic Region Modifier Sequence
AnatomicRegionSequence | (0008,2218): Anatomic Region Sequence
AnatomicRegionsInStudyCodeSequence | (0008,0063): Anatomic Regions in Study Code Sequence
AnatomicStructure | (0008,2208): Anatomic Structure
AnatomicStructureReferencePoint | (0022,1463): Anatomic Structure Reference Point
AnatomicStructureSpaceOrRegionCodeSequenceTrial | (0008,2251): Anatomic Structure Space Or Region Code Sequence (Trial)
AnatomicStructureSpaceOrRegionModifierCodeSequenceTrial | (0008,225A): Anatomic Structure Space Or Region Modifier Code Sequence (Trial)
AnatomicStructureSpaceOrRegionSequence | (0008,2229): Anatomic Structure, Space or Region Sequence
AnchorPoint | (0070,0014): Anchor Point
AnchorPointAnnotationUnits | (0070,0004): Anchor Point Annotation Units
AnchorPointVisibility | (0070,0015): Anchor Point Visibility
AngioFlag | (0018,0025): Angio Flag
AngleNumber | (0020,0018): Angle Number
AngularPosition | (0018,1141): Angular Position
AngularStep | (0018,1144): Angular Step
AngularViewVector | (0054,0090): Angular View Vector
AnimationCurveSequence | (0070,1A04): Animation Curve Sequence
AnimationStepSize | (0070,1A05): Animation Step Size
AnnotationAppliesToAllOpticalPaths | (006A,000D): Annotation Applies to All Optical Paths
AnnotationAppliesToAllZPlanes | (006A,000F): Annotation Applies to All Z Planes
AnnotationClipping | (0070,1907): Annotation Clipping
AnnotationContentSequence | (2130,0050): Annotation Content Sequence
AnnotationCoordinateType | (006A,0001): Annotation Coordinate Type
AnnotationDisplayFormatID | (2010,0030): Annotation Display Format ID
AnnotationFlag | (2000,0065): Annotation Flag
AnnotationGroupAlgorithmIdentificationSequence | (006A,0008): Annotation Group Algorithm Identification Sequence
AnnotationGroupDescription | (006A,0006): Annotation Group Description
AnnotationGroupGenerationType | (006A,0007): Annotation Group Generation Type
AnnotationGroupLabel | (006A,0005): Annotation Group Label
AnnotationGroupNumber | (0040,A180): Annotation Group Number
AnnotationGroupSequence | (006A,0002): Annotation Group Sequence
AnnotationGroupUID | (006A,0003): Annotation Group UID
AnnotationIndexList | (006A,0011): Annotation Index List
AnnotationPosition | (2030,0010): Annotation Position
AnnotationPropertyCategoryCodeSequence | (006A,0009): Annotation Property Category Code Sequence
AnnotationPropertyTypeCodeSequence | (006A,000A): Annotation Property Type Code Sequence
AnnotationPropertyTypeModifierCodeSequence | (006A,000B): Annotation Property Type Modifier Code Sequence
AnodeTargetMaterial | (0018,1191): Anode Target Material
AnomalyLocatorIndicator | (4010,107A): Anomaly Locator Indicator
AnomalyLocatorIndicatorSequence | (4010,1079): Anomaly Locator Indicator Sequence
AnteriorChamberDepth | (0022,1131): Anterior Chamber Depth
AnteriorChamberDepthDefinitionCodeSequence | (0022,1125): Anterior Chamber Depth Definition Code Sequence
AnteriorChamberDepthSequence | (0022,1128): Anterior Chamber Depth Sequence
ApertureElevation | (0014,5102): Aperture Elevation
ApertureValue | (0016,0022): Aperture Value
ApexPosition | (0020,9308): Apex Position
ApplicableFrameRange | (0028,6102): Applicable Frame Range
ApplicableSafetyStandardAgency | (0018,9174): Applicable Safety Standard Agency
ApplicableSafetyStandardDescription | (0018,9175): Applicable Safety Standard Description
ApplicationManufacturer | (0018,9526): Application Manufacturer
ApplicationMaximumRepaintTime | (0072,010E): Application Maximum Repaint Time
ApplicationName | (0018,9524): Application Name
ApplicationSetupCheck | (3008,0116): Application Setup Check
ApplicationSetupManufacturer | (300A,0238): Application Setup Manufacturer
ApplicationSetupName | (300A,0236): Application Setup Name
ApplicationSetupNumber | (300A,0234): Application Setup Number
ApplicationSetupSequence | (300A,0230): Application Setup Sequence
ApplicationSetupType | (300A,0232): Application Setup Type
ApplicationVersion | (0018,9525): Application Version
ApplicatorApertureShape | (300A,0432): Applicator Aperture Shape
ApplicatorDescription | (300A,010A): Applicator Description
ApplicatorGeometrySequence | (300A,0431): Applicator Geometry Sequence
ApplicatorID | (300A,0108): Applicator ID
ApplicatorOpening | (300A,0433): Applicator Opening
ApplicatorOpeningX | (300A,0434): Applicator Opening X
ApplicatorOpeningY | (300A,0435): Applicator Opening Y
ApplicatorSequence | (300A,0107): Applicator Sequence
ApplicatorShapeReferencedROINumber | (300A,02A1): Applicator Shape Referenced ROI Number
ApplicatorType | (300A,0109): Applicator Type
AppliedMaskSubtractionFlag | (0018,11C0): Applied Mask Subtraction Flag
ApprovalSequence | (0044,0100): Approval Sequence
ApprovalStatus | (300E,0002): Approval Status
ApprovalStatusDateTime | (0044,0004): Approval Status DateTime
ApprovalStatusFurtherDescription | (0044,0003): Approval Status Further Description
ApprovalSubjectSequence | (0044,0109): Approval Subject Sequence
Arbitrary | (4000,0010): Arbitrary()
ArchiveRequested | (0040,A494): Archive Requested
ArterialSpinLabelingContrast | (0018,9250): Arterial Spin Labeling Contrast
AscanRate | (0022,1649): A-scan Rate
ASLBolusCutoffDelayTime | (0018,925F): ASL Bolus Cut-off Delay Time
ASLBolusCutoffFlag | (0018,925C): ASL Bolus Cut-off Flag
ASLBolusCutoffTechnique | (0018,925E): ASL Bolus Cut-off Technique
ASLBolusCutoffTimingSequence | (0018,925D): ASL Bolus Cut-off Timing Sequence
ASLContext | (0018,9257): ASL Context
ASLCrusherDescription | (0018,925B): ASL Crusher Description
ASLCrusherFlag | (0018,9259): ASL Crusher Flag
ASLCrusherFlowLimit | (0018,925A): ASL Crusher Flow Limit
ASLMidSlabPosition | (0018,9256): ASL Mid Slab Position
ASLPulseTrainDuration | (0018,9258): ASL Pulse Train Duration
ASLSlabNumber | (0018,9253): ASL Slab Number
ASLSlabOrientation | (0018,9255): ASL Slab Orientation
ASLSlabSequence | (0018,9260): ASL Slab Sequence
ASLSlabThickness | (0018,9254): ASL Slab Thickness
ASLTechniqueDescription | (0018,9252): ASL Technique Description
AsserterIdentificationSequence | (0044,0103): Asserter Identification Sequence
AssertionCodeSequence | (0044,0101): Assertion Code Sequence
AssertionComments | (0044,0106): Assertion Comments
AssertionDateTime | (0044,0104): Assertion DateTime
AssertionExpirationDateTime | (0044,0105): Assertion Expiration DateTime
AssertionUID | (0044,0102): Assertion UID
AssessedAttributeValueSequence | (0082,0010): Assessed Attribute Value Sequence
AssessedSOPInstanceSequence | (0082,0004): Assessed SOP Instance Sequence
AssessmentLabel | (0082,0023): Assessment Label
AssessmentObservationsSequence | (0082,0007): Assessment Observations Sequence
AssessmentRequesterSequence | (0082,0017): Assessment Requester Sequence
AssessmentSetID | (0082,0016): Assessment Set ID
AssessmentSummary | (0082,0001): Assessment Summary
AssessmentSummaryDescription | (0082,0003): Assessment Summary Description
AssessmentTypeCodeSequence | (0082,0021): Assessment Type Code Sequence
AssignedLocation | (4010,102A): Assigned Location
AssigningAgencyOrDepartmentCodeSequence | (0040,003A): Assigning Agency or Department Code Sequence
AssigningFacilitySequence | (0040,0036): Assigning Facility Sequence
AssigningJurisdictionCodeSequence | (0040,0039): Assigning Jurisdiction Code Sequence
ATDAbilityAssessment | (4010,1014): ATD Ability Assessment
ATDAssessmentFlag | (4010,1015): ATD Assessment Flag
ATDAssessmentProbability | (4010,1016): ATD Assessment Probability
ATDAssessmentSequence | (4010,1038): ATD Assessment Sequence
AttachedContours | (3006,0049): Attached Contours
AttenuationCorrected | (0018,9759): Attenuation Corrected
AttenuationCorrectionMethod | (0054,1101): Attenuation Correction Method
AttenuationCorrectionSource | (0018,9738): Attenuation Correction Source
AttenuationCorrectionTemporalRelationship | (0018,9770): Attenuation Correction Temporal Relationship
AttributeIdentifierList | (0000,1005): Attribute Identifier List
AttributeItemSelector | (0074,1054): Attribute Item Selector
AttributeModificationDateTime | (0400,0562): Attribute Modification DateTime
AttributeOccurrencePointer | (0074,1052): Attribute Occurrence Pointer
AttributeOccurrencePrivateCreator | (0074,1056): Attribute Occurrence Private Creator
AttributeOccurrenceSequence | (0074,1050): Attribute Occurrence Sequence
AttributeToleranceValuesSequence | (300A,062B): Attribute Tolerance Values Sequence
AudioComments | (50xx,200E): Audio Comments
AudioSampleData | (50xx,200C): Audio Sample Data
AudioSampleFormat | (50xx,2002): Audio Sample Format
AudioType | (50xx,2000): Audio Type
AuthorIdentificationSequence | (3010,0019): Author Identification Sequence
AuthorizationEquipmentCertificationNumber | (0100,0426): Authorization Equipment Certification Number
AuthorObserverSequence | (0040,A078): Author Observer Sequence
AutoKVPLowerBound | (0018,9946): Auto KVP Lower Bound
AutoKVPSelectionType | (0018,9944): Auto KVP Selection Type
AutoKVPUpperBound | (0018,9945): Auto KVP Upper Bound
AutorefractionLeftEyeSequence | (0046,0052): Autorefraction Left Eye Sequence
AutorefractionRightEyeSequence | (0046,0050): Autorefraction Right Eye Sequence
AutosequenceFlag | (0074,1025): Autosequence Flag
AvailableTransferSyntaxUID | (0008,3002): Available Transfer Syntax UID
AverageBeamDosePointDepth | (300A,008D): Average Beam Dose Point Depth
AverageBeamDosePointEquivalentDepth | (300A,008E): Average Beam Dose Point Equivalent Depth
AverageBeamDosePointSourceToExternalContourDistance | (300A,0131): Average Beam Dose Point Source to External Contour Distance
AverageBeamDosePointSSD | (300A,008F): Average Beam Dose Point SSD
AverageCornealPower | (0046,0220): Average Corneal Power
AveragePulseWidth | (0018,1154): Average Pulse Width
AxialAcceptance | (0054,1200): Axial Acceptance
AxialDetectorDimension | (0018,9727): Axial Detector Dimension
AxialLengthOfTheEye | (0022,0030): Axial Length of the Eye
AxialMash | (0054,1201): Axial Mash
AxialPower | (0046,0249): Axial Power
AxialResolution | (0052,0008): Axial Resolution
AxisLabels | (50xx,0040): Axis Labels
AxisOfRotation | (0066,001B): Axis of Rotation
AxisUnits | (50xx,0030): Axis Units
B1rms | (0018,1320): B1rms
BackgroundColor | (0046,0092): Background Color
BackgroundIlluminationColorCodeSequence | (0024,0024): Background Illumination Color Code Sequence
BackgroundLuminance | (0024,0020): Background Luminance
BadPixelImage | (0014,3080): Bad Pixel Image
BarcodeSymbology | (2200,0006): Barcode Symbology
BarcodeValue | (2200,0005): Barcode Value
BaselineCorrection | (0018,9067): Baseline Correction
BasicColorImageSequence | (2020,0111): Basic Color Image Sequence
BasicGrayscaleImageSequence | (2020,0110): Basic Grayscale Image Sequence
BasisMaterialsCodeSequence | (4010,1045): Basis Materials Code Sequence
BasisRTTreatmentPhaseIndex | (3010,003E): Basis RT Treatment Phase Index
BatteryLevel | (0016,0003): Battery Level
BeamAngle | (0018,9449): Beam Angle
BeamAreaLimitSequence | (300A,0689): Beam Area Limit Sequence
BeamCurrentModulationID | (300A,034C): Beam Current Modulation ID
BeamDeliveryDurationLimit | (300A,00C5): Beam Delivery Duration Limit
BeamDescription | (300A,00C3): Beam Description
BeamDose | (300A,0084): Beam Dose
BeamDoseMeaning | (300A,008B): Beam Dose Meaning
BeamDosePointDepth | (300A,0088): Beam Dose Point Depth
BeamDosePointEquivalentDepth | (300A,0089): Beam Dose Point Equivalent Depth
BeamDosePointSourceToExternalContourDistance | (300A,0094): Beam Dose Point Source to External Contour Distance
BeamDosePointSSD | (300A,008A): Beam Dose Point SSD
BeamDoseSpecificationPoint | (300A,0082): Beam Dose Specification Point
BeamDoseType | (300A,0090): Beam Dose Type
BeamDoseVerificationControlPointSequence | (300A,008C): Beam Dose Verification Control Point Sequence
BeamHardeningCorrectionTechnique | (0014,3101): Beam Hardening Correction Technique
BeamHoldOriginatingDeviceSequence |
BeamHoldTransition |
BeamHoldTransitionDateTime |
BeamHoldTransitionTriggerSource |
BeamLimitingDeviceAngle | (300A,0120): Beam Limiting Device Angle
BeamLimitingDeviceAngleTolerance | (300A,0046): Beam Limiting Device Angle Tolerance
BeamLimitingDeviceLeafPairsSequence | (3008,00A0): Beam Limiting Device Leaf Pairs Sequence
BeamLimitingDevicePositionSequence | (300A,011A): Beam Limiting Device Position Sequence
BeamLimitingDevicePositionTolerance | (300A,004A): Beam Limiting Device Position Tolerance
BeamLimitingDeviceRotationDirection | (300A,0121): Beam Limiting Device Rotation Direction
BeamLimitingDeviceSequence | (300A,00B6): Beam Limiting Device Sequence
BeamLimitingDeviceToleranceSequence | (300A,0048): Beam Limiting Device Tolerance Sequence
BeamMeterset | (300A,0086): Beam Meterset
BeamModifierCoordinatesPresenceFlag |
BeamModifierOrientationAngle | (300A,0645): Beam Modifier Orientation Angle
BeamName | (300A,00C2): Beam Name
BeamNumber | (300A,00C0): Beam Number
BeamOrderIndex | (0074,1324): Beam Order Index
BeamOrderIndexTrial | (0074,1024): Beam Order Index (Trial)
BeamSequence | (300A,00B0): Beam Sequence
BeamSpotSize | (0052,0003): Beam Spot Size
BeamStopperPosition | (3008,0230): Beam Stopper Position
BeamTaskSequence | (0074,1020): Beam Task Sequence
BeamTaskType | (0074,1022): Beam Task Type
BeamType | (300A,00C4): Beam Type
BeatRejectionFlag | (0018,1080): Beat Rejection Flag
BeltHeight | (4010,1062): Belt Height
BibliographicCitationTrial | (0040,A16A): Bibliographic Citation (Trial)
BillingItemSequence | (0040,0296): Billing Item Sequence
BillingProcedureStepSequence | (0040,0320): Billing Procedure Step Sequence
BillingSuppliesAndDevicesSequence | (0040,0324): Billing Supplies and Devices Sequence
BiopsyTargetSequence | (0018,2041): Biopsy Target Sequence
BiPlaneAcquisitionSequence | (0028,5000): Bi-Plane Acquisition Sequence
BitsAllocated | (0028,0100): Bits Allocated
BitsForCodeWord | (0028,08x4): Bits For Code Word
BitsGrouped | (0028,0069): Bits Grouped
BitsMappedToColorLookupTable | (0028,1403): Bits Mapped to Color Lookup Table
BitsStored | (0028,0101): Bits Stored
BlendingDisplayInputSequence | (0070,1B03): Blending Display Input Sequence
BlendingDisplaySequence | (0070,1B04): Blending Display Sequence
BlendingInputNumber | (0070,1B02): Blending Input Number
BlendingLookupTableData | (0028,1408): Blending Lookup Table Data
BlendingLookupTableDescriptor | (0028,1407): Blending Lookup Table Descriptor
BlendingLUT1Sequence | (0028,1404): Blending LUT 1 Sequence
BlendingLUT1TransferFunction | (0028,1405): Blending LUT 1 Transfer Function
BlendingLUT2Sequence | (0028,140C): Blending LUT 2 Sequence
BlendingLUT2TransferFunction | (0028,140D): Blending LUT 2 Transfer Function
BlendingMode | (0070,1B06): Blending Mode
BlendingOperationType | (0072,0500): Blending Operation Type
BlendingPosition | (0070,0405): Blending Position
BlendingSequence | (0070,0402): Blending Sequence
BlendingWeightConstant | (0028,1406): Blending Weight Constant
BlindSpotLocalized | (0024,0106): Blind Spot Localized
BlindSpotXCoordinate | (0024,0107): Blind Spot X-Coordinate
BlindSpotYCoordinate | (0024,0108): Blind Spot Y-Coordinate
BlockColumns | (0028,0092): Block Columns
BlockData | (300A,0106): Block Data
BlockDefinitionSequence | (300A,066A): Block Definition Sequence
BlockDivergence | (300A,00FA): Block Divergence
BlockEdgeData | (300A,066B): Block Edge Data
BlockEdgeDataSequence | (300A,066F): Block Edge Data Sequence
BlockedPixels | (0028,0090): Blocked Pixels
BlockIdentifyingInformationStatus | (0008,0303): Block Identifying Information Status
BlockMountingPosition | (300A,00FB): Block Mounting Position
BlockName | (300A,00FE): Block Name
BlockNumber | (300A,00FC): Block Number
BlockNumberOfPoints | (300A,0104): Block Number of Points
BlockOrientation | (300A,066C): Block Orientation
BlockRows | (0028,0091): Block Rows
BlockSequence | (300A,00F4): Block Sequence
BlockSlabNumber | (300A,0443): Block Slab Number
BlockSlabSequence | (300A,0441): Block Slab Sequence
BlockSlabThickness | (300A,0442): Block Slab Thickness
BlockThickness | (300A,0100): Block Thickness
BlockTransmission | (300A,0102): Block Transmission
BlockTrayID | (300A,00F5): Block Tray ID
BlockType | (300A,00F8): Block Type
BloodSignalNulling | (0018,9022): Blood Signal Nulling
BluePaletteColorLookupTableData | (0028,1203): Blue Palette Color Lookup Table Data
BluePaletteColorLookupTableDescriptor | (0028,1103): Blue Palette Color Lookup Table Descriptor
BoardingPassID | (4010,101A): Boarding Pass ID
BodyPartExamined | (0018,0015): Body Part Examined
BodyPartThickness | (0018,11A0): Body Part Thickness
Bold | (0070,0249): Bold
BolusDefinitionSequence | (300A,0673): Bolus Definition Sequence
BolusDescription | (300A,00DD): Bolus Description
BolusID | (300A,00DC): Bolus ID
BoneThermalIndex | (0018,5024): Bone Thermal Index
BorderDensity | (2010,0100): Border Density
Borders | (0000,5160): Borders()
BottomRightHandCornerOfLocalizerArea | (0048,0202): Bottom Right Hand Corner of Localizer Area
BoundingBoxAnnotationUnits | (0070,0003): Bounding Box Annotation Units
BoundingBoxBottomRightHandCorner | (0070,0011): Bounding Box Bottom Right Hand Corner
BoundingBoxCrop | (0070,1303): Bounding Box Crop
BoundingBoxTextHorizontalJustification | (0070,0012): Bounding Box Text Horizontal Justification
BoundingBoxTopLeftHandCorner | (0070,0010): Bounding Box Top Left Hand Corner
BoundingPolygon | (4010,101D): Bounding Polygon
BoundingRectangle | (0068,6347): Bounding Rectangle
BrachyAccessoryDeviceID | (300A,0263): Brachy Accessory Device ID
BrachyAccessoryDeviceName | (300A,0266): Brachy Accessory Device Name
BrachyAccessoryDeviceNominalThickness | (300A,026A): Brachy Accessory Device Nominal Thickness
BrachyAccessoryDeviceNominalTransmission | (300A,026C): Brachy Accessory Device Nominal Transmission
BrachyAccessoryDeviceNumber | (300A,0262): Brachy Accessory Device Number
BrachyAccessoryDeviceSequence | (300A,0260): Brachy Accessory Device Sequence
BrachyAccessoryDeviceType | (300A,0264): Brachy Accessory Device Type
BrachyApplicationSetupDose | (300A,00A4): Brachy Application Setup Dose
BrachyApplicationSetupDoseSpecificationPoint | (300A,00A2): Brachy Application Setup Dose Specification Point
BrachyControlPointDeliveredSequence | (3008,0160): Brachy Control Point Delivered Sequence
BrachyControlPointSequence | (300A,02D0): Brachy Control Point Sequence
BrachyPulseControlPointDeliveredSequence | (3008,0173): Brachy Pulse Control Point Delivered Sequence
BrachyReferencedDoseReferenceSequence | (300C,0055): Brachy Referenced Dose Reference Sequence
BrachyTaskSequence | (0074,1401): Brachy Task Sequence
BrachytherapySourceType | (3010,0048): Brachytherapy Source Type
BrachyTreatmentTechnique | (300A,0200): Brachy Treatment Technique
BrachyTreatmentType | (300A,0202): Brachy Treatment Type
BranchOfService | (0010,1081): Branch of Service
BreastImplantPresent | (0028,1300): Breast Implant Present
BreastSupportIsocenterPrimaryAngle | (0018,9545): Breast Support Isocenter Primary Angle
BreastSupportIsocenterSecondaryAngle | (0018,9546): Breast Support Isocenter Secondary Angle
BreastSupportXPositionToIsocenter | (0018,9547): Breast Support X Position to Isocenter
BreastSupportYPositionToIsocenter | (0018,9548): Breast Support Y Position to Isocenter
BreastSupportZPositionToIsocenter | (0018,9549): Breast Support Z Position to Isocenter
BreedRegistrationNumber | (0010,2295): Breed Registration Number
BreedRegistrationSequence | (0010,2294): Breed Registration Sequence
BreedRegistryCodeSequence | (0010,2296): Breed Registry Code Sequence
BridgeResistors | (0014,4088): Bridge Resistors
BrightnessValue | (0016,0023): Brightness Value
BscanCycleTime | (0022,1645): B-scan Cycle Time
BscanCycleTimeVector | (0022,1646): B-scan Cycle Time Vector
BscanRate | (0022,1650): B-scan Rate
BscanSlabThickness | (0022,1643): B-scan Slab Thickness
BulkMotionCompensationTechnique | (0018,9172): Bulk Motion Compensation Technique
BulkMotionSignalSource | (0018,9173): Bulk Motion Signal Source
BulkMotionStatus | (0018,9166): Bulk Motion Status
BurnedInAnnotation | (0028,0301): Burned In Annotation
CADFileFormat | (0014,0023): CAD File Format
CalciumScoringMassFactorDevice | (0018,9352): Calcium Scoring Mass Factor Device
CalciumScoringMassFactorPatient | (0018,9351): Calcium Scoring Mass Factor Patient
CalculatedAnatomyThickness | (0018,9452): Calculated Anatomy Thickness
CalculatedDoseReferenceDescription | (3008,0074): Calculated Dose Reference Description
CalculatedDoseReferenceDoseValue | (3008,0076): Calculated Dose Reference Dose Value
CalculatedDoseReferenceNumber | (3008,0072): Calculated Dose Reference Number
CalculatedDoseReferenceSequence | (3008,0070): Calculated Dose Reference Sequence
CalculatedFrameList | (0008,1162): Calculated Frame List
CalculatedTargetPosition | (0018,2044): Calculated Target Position
CalculationComment | (0022,112C): Calculation Comment
CalculationCommentSequence | (0022,112A): Calculation Comment Sequence
CalculationCommentType | (0022,112B): Calculation Comment Type
CalibrationDataSequence | (0054,0306): Calibration Data Sequence
CalibrationDate | (0014,407E): Calibration Date
CalibrationDateTime |
CalibrationImage | (0050,0004): Calibration Image
CalibrationNotes | (0014,3099): Calibration Notes
CalibrationProcedure | (0014,4072): Calibration Procedure
CalibrationReferencePointDepth |
CalibrationSequence | (0018,9455): Calibration Sequence
CalibrationSettingsSequence | (0014,4070): Calibration Settings Sequence
CalibrationTime | (0014,407C): Calibration Time
CameraAngleOfView | (0022,001E): Camera Angle of View
CameraElevationAngle | (0016,0035): Camera Elevation Angle
CameraOwnerName | (0016,004D): Camera Owner Name
CameraPositionGroupSequence | (0034,000B): Camera Position Group Sequence
CardiacBeatRejectionTechnique | (0018,9169): Cardiac Beat Rejection Technique
CardiacCyclePosition | (0018,9236): Cardiac Cycle Position
CardiacFramingType | (0018,1064): Cardiac Framing Type
CardiacNumberOfImages | (0018,1090): Cardiac Number of Images
CardiacRRIntervalSpecified | (0018,9070): Cardiac R-R Interval Specified
CardiacSignalSource | (0018,9085): Cardiac Signal Source
CardiacSynchronizationSequence | (0018,9118): Cardiac Synchronization Sequence
CardiacSynchronizationTechnique | (0018,9037): Cardiac Synchronization Technique
CArmPhotonElectronControlPointSequence | (300A,062F): C-Arm Photon-Electron Control Point Sequence
CArmPositionerTabletopRelationship | (0018,9474): C-arm Positioner Tabletop Relationship
CarrierID | (4010,1058): Carrier ID
CarrierIDAssigningAuthority | (4010,1059): Carrier ID Assigning Authority
CassetteID | (0018,1007): Cassette ID
CassetteOrientation | (0018,1402): Cassette Orientation
CassetteSize | (0018,1403): Cassette Size
CatchTrialsDataFlag | (0024,0055): Catch Trials Data Flag
CatheterDirectionOfRotation | (0052,0031): Catheter Direction of Rotation
CatheterRotationalRate | (0052,0013): Catheter Rotational Rate
CellValuesSequence | (0040,A808): Cell Values Sequence
CenterFrequency |
CenterOfCircularCollimator | (0018,1710): Center of Circular Collimator
CenterOfCircularExposureControlSensingRegion | (0018,9440): Center of Circular Exposure Control Sensing Region
CenterOfCircularOutline | (0018,1635): Center of Circular Outline
CenterOfCircularShutter | (0018,1610): Center of Circular Shutter
CenterOfMass | (4010,101B): Center of Mass
CenterOfPTO | (4010,101C): Center of PTO
CenterOfRotation | (0066,001C): Center of Rotation
CenterOfRotationOffset | (0018,1145): Center of Rotation Offset
CertificateOfSigner | (0400,0115): Certificate of Signer
CertificateType | (0400,0110): Certificate Type
CertifiedTimestamp | (0400,0310): Certified Timestamp
CertifiedTimestampType | (0400,0305): Certified Timestamp Type
ChairHeadFramePosition | (300A,0151): Chair Head Frame Position
ChairHeadFramePositionTolerance | (300A,0153): Chair Head Frame Position Tolerance
ChannelBaseline | (003A,0213): Channel Baseline
ChannelDefinitionSequence | (003A,0200): Channel Definition Sequence
ChannelDeliveryContinuationSequence | (0074,140D): Channel Delivery Continuation Sequence
ChannelDeliveryOrderIndex | (0074,140C): Channel Delivery Order Index
ChannelDeliveryOrderSequence | (0074,1405): Channel Delivery Order Sequence
ChannelDerivationDescription | (003A,020C): Channel Derivation Description
ChannelDescriptionCodeSequence | (0022,001A): Channel Description Code Sequence
ChannelDisplaySequence | (003A,0242): Channel Display Sequence
ChannelEffectiveLength | (300A,0271): Channel Effective Length
ChannelIdentificationCode | (003A,0301): Channel Identification Code
ChannelImpedanceSequence | (003A,0312): Channel Impedance Sequence
ChannelInnerLength | (300A,0272): Channel Inner Length
ChannelLabel | (003A,0203): Channel Label
ChannelLength | (300A,0284): Channel Length
ChannelMaximumValue | (5400,0112): Channel Maximum Value
ChannelMinimumValue | (5400,0110): Channel Minimum Value
ChannelMode | (003A,0302): Channel Mode
ChannelNumber | (300A,0282): Channel Number
ChannelOffset | (003A,0218): Channel Offset
ChannelOverlap | (0014,409F): Channel Overlap
ChannelPosition | (003A,0245): Channel Position
ChannelRecommendedDisplayCIELabValue | (003A,0244): Channel Recommended Display CIELab Value
ChannelSampleSkew | (003A,0215): Channel Sample Skew
ChannelSensitivity | (003A,0210): Channel Sensitivity
ChannelSensitivityCorrectionFactor | (003A,0212): Channel Sensitivity Correction Factor
ChannelSensitivityUnitsSequence | (003A,0211): Channel Sensitivity Units Sequence
ChannelSequence | (300A,0280): Channel Sequence
ChannelSettingsSequence | (0014,4091): Channel Settings Sequence
ChannelShieldID | (300A,02B3): Channel Shield ID
ChannelShieldName | (300A,02B4): Channel Shield Name
ChannelShieldNominalThickness | (300A,02B8): Channel Shield Nominal Thickness
ChannelShieldNominalTransmission | (300A,02BA): Channel Shield Nominal Transmission
ChannelShieldNumber | (300A,02B2): Channel Shield Number
ChannelShieldSequence | (300A,02B0): Channel Shield Sequence
ChannelSourceModifiersSequence | (003A,0209): Channel Source Modifiers Sequence
ChannelSourceSequence | (003A,0208): Channel Source Sequence
ChannelStatus | (003A,0205): Channel Status
ChannelThreshold | (0014,4092): Channel Threshold
ChannelTimeSkew | (003A,0214): Channel Time Skew
ChannelTotalTime | (300A,0286): Channel Total Time
ChannelWidth | (0046,0042): Channel Width
ChemicalShiftMaximumIntegrationLimitInHz | (0018,9196): Chemical Shift Maximum Integration Limit in Hz
ChemicalShiftMaximumIntegrationLimitInppm | (0018,9296): Chemical Shift Maximum Integration Limit in ppm
ChemicalShiftMinimumIntegrationLimitInHz | (0018,9195): Chemical Shift Minimum Integration Limit in Hz
ChemicalShiftMinimumIntegrationLimitInppm | (0018,9295): Chemical Shift Minimum Integration Limit in ppm
ChemicalShiftReference | (0018,9053): Chemical Shift Reference
ChemicalShiftSequence | (0018,9084): Chemical Shift Sequence
CIExyWhitePoint | (0028,7018): CIExy White Point
CineRate | (0018,0040): Cine Rate
CineRelativeToRealTime | (0072,0330): Cine Relative to Real-Time
ClinicalFractionNumber | (300A,0705): Clinical Fraction Number
ClinicalTrialCoordinatingCenterName | (0012,0060): Clinical Trial Coordinating Center Name
ClinicalTrialProtocolEthicsCommitteeApprovalNumber | (0012,0082): Clinical Trial Protocol Ethics Committee Approval Number
ClinicalTrialProtocolEthicsCommitteeName | (0012,0081): Clinical Trial Protocol Ethics Committee Name
ClinicalTrialProtocolID | (0012,0020): Clinical Trial Protocol ID
ClinicalTrialProtocolName | (0012,0021): Clinical Trial Protocol Name
ClinicalTrialSeriesDescription | (0012,0072): Clinical Trial Series Description
ClinicalTrialSeriesID | (0012,0071): Clinical Trial Series ID
ClinicalTrialSiteID | (0012,0030): Clinical Trial Site ID
ClinicalTrialSiteName | (0012,0031): Clinical Trial Site Name
ClinicalTrialSponsorName | (0012,0010): Clinical Trial Sponsor Name
ClinicalTrialSubjectID | (0012,0040): Clinical Trial Subject ID
ClinicalTrialSubjectReadingID | (0012,0042): Clinical Trial Subject Reading ID
ClinicalTrialTimePointDescription | (0012,0051): Clinical Trial Time Point Description
ClinicalTrialTimePointID | (0012,0050): Clinical Trial Time Point ID
ClinicalTrialTimePointTypeCodeSequence |
CoatingMaterialsCodeSequence | (0068,63A4): Coating Materials Code Sequence
CodeLabel | (0028,08x0): Code Label
CodeMeaning | (0008,0104): Code Meaning
CodeNumberFormat | (0028,0740): Code Number Format
CodeTableLocation | (0028,08x3): Code Table Location
CodeValue | (0008,0100): Code Value
CodingSchemeDesignator | (0008,0102): Coding Scheme Designator
CodingSchemeExternalID | (0008,0114): Coding Scheme External ID
CodingSchemeIdentificationSequence | (0008,0110): Coding Scheme Identification Sequence
CodingSchemeName | (0008,0115): Coding Scheme Name
CodingSchemeRegistry | (0008,0112): Coding Scheme Registry
CodingSchemeResourcesSequence | (0008,0109): Coding Scheme Resources Sequence
CodingSchemeResponsibleOrganization | (0008,0116): Coding Scheme Responsible Organization
CodingSchemeUID | (0008,010C): Coding Scheme UID
CodingSchemeURL | (0008,010E): Coding Scheme URL
CodingSchemeURLType | (0008,010A): Coding Scheme URL Type
CodingSchemeVersion | (0008,0103): Coding Scheme Version
CoefficientsSDDN | (7FE0,0040): Coefficients SDDN
CoefficientsSDHN | (7FE0,0030): Coefficients SDHN
CoefficientsSDVN | (7FE0,0020): Coefficients SDVN
CoincidenceWindowWidth | (0054,1210): Coincidence Window Width
CollationFlag | (2000,0063): Collation Flag
CollimatorGridName | (0018,1180): Collimator/grid Name
CollimatorLeftVerticalEdge | (0018,1702): Collimator Left Vertical Edge
CollimatorLowerHorizontalEdge | (0018,1708): Collimator Lower Horizontal Edge
CollimatorRightVerticalEdge | (0018,1704): Collimator Right Vertical Edge
CollimatorShape | (0018,1700): Collimator Shape
CollimatorShapeSequence | (0018,9407): Collimator Shape Sequence
CollimatorType | (0018,1181): Collimator Type
CollimatorUpperHorizontalEdge | (0018,1706): Collimator Upper Horizontal Edge
ColorFilterArrayPatternColumns | (0016,000F): Color Filter Array Pattern Columns
ColorFilterArrayPatternRows | (0016,000E): Color Filter Array Pattern Rows
ColorFilterArrayPatternValues | (0016,0010): Color Filter Array Pattern Values
ColorImagePrintingFlag | (2000,0062): Color Image Printing Flag
ColorSpace | (0028,2002): Color Space
ColumnAngulation | (0018,1450): Column Angulation
ColumnAngulationPatient | (0018,9447): Column Angulation (Patient)
ColumnOverlap | (0028,0094): Column Overlap
ColumnPositionInTotalImagePixelMatrix | (0048,021E): Column Position In Total Image Pixel Matrix
Columns | (0028,0011): Columns
CombinationSegmentReferenceSequence | (3010,0024): Combination Segment Reference Sequence
CommandDataSetType | (0000,0800): Command Data Set Type
CommandField | (0000,0100): Command Field
CommandGroupLength | (0000,0000): Command Group Length
CommandLengthToEnd | (0000,0001): Command Length to End()
CommandMagnificationType | (0000,5180): Command Magnification Type()
CommandRecognitionCode | (0000,0010): Command Recognition Code()
CommentsOnPatientPerformanceOfVisualField | (0024,0044): Comments on Patient's Performance of Visual Field
CommentsOnRadiationDose | (0040,0310): Comments on Radiation Dose
CommentsOnThePerformedProcedureStep | (0040,0280): Comments on the Performed Procedure Step
CommentsOnTheScheduledProcedureStep | (0040,0400): Comments on the Scheduled Procedure Step
CommonZCoordinateValue | (006A,0010): Common Z Coordinate Value
CompensatorBasePlaneOffset | (300A,0666): Compensator Base Plane Offset
CompensatorColumnOffset | (300A,02E5): Compensator Column Offset
CompensatorColumns | (300A,00E8): Compensator Columns
CompensatorDefinitionSequence | (300A,0662): Compensator Definition Sequence
CompensatorDescription | (300A,02EB): Compensator Description
CompensatorDistalThicknessMap | (300A,0665): Compensator Distal Thickness Map
CompensatorDivergence | (300A,02E0): Compensator Divergence
CompensatorID | (300A,00E5): Compensator ID
CompensatorMapOrientation | (300A,0663): Compensator Map Orientation
CompensatorMillingToolDiameter | (300A,02E8): Compensator Milling Tool Diameter
CompensatorMountingPosition | (300A,02E1): Compensator Mounting Position
CompensatorNumber | (300A,00E4): Compensator Number
CompensatorPixelSpacing | (300A,00E9): Compensator Pixel Spacing
CompensatorPosition | (300A,00EA): Compensator Position
CompensatorProximalThicknessMap | (300A,0664): Compensator Proximal Thickness Map
CompensatorRelativeStoppingPowerRatio | (300A,02E7): Compensator Relative Stopping Power Ratio
CompensatorRows | (300A,00E7): Compensator Rows
CompensatorSequence | (300A,00E3): Compensator Sequence
CompensatorShapeFabricationCodeSequence | (300A,0667): Compensator Shape Fabrication Code Sequence
CompensatorShapeSequence | (300A,0668): Compensator Shape Sequence
CompensatorThicknessData | (300A,00EC): Compensator Thickness Data
CompensatorTransmissionData | (300A,00EB): Compensator Transmission Data
CompensatorTrayID | (300A,00EF): Compensator Tray ID
CompensatorType | (300A,00EE): Compensator Type
CompletionFlag | (0040,A491): Completion Flag
CompletionFlagDescription | (0040,A492): Completion Flag Description
ComplexImageComponent | (0008,9208): Complex Image Component
Component1ReferencedID | (0076,0070): Component 1 Referenced ID
Component1ReferencedMatingFeatureID | (0076,0090): Component 1 Referenced Mating Feature ID
Component1ReferencedMatingFeatureSetID | (0076,0080): Component 1 Referenced Mating Feature Set ID
Component2ReferencedID | (0076,00A0): Component 2 Referenced ID
Component2ReferencedMatingFeatureID | (0076,00C0): Component 2 Referenced Mating Feature ID
Component2ReferencedMatingFeatureSetID | (0076,00B0): Component 2 Referenced Mating Feature Set ID
ComponentAssemblySequence | (0076,0060): Component Assembly Sequence
ComponentID | (0076,0055): Component ID
ComponentInputSequence | (0070,1803): Component Input Sequence
ComponentManufacturer | (0014,0028): Component Manufacturer
ComponentManufacturingProcedure | (0014,0025): Component Manufacturing Procedure
ComponentReferenceSystem | (0014,0024): Component Reference System
ComponentSequence | (0076,0040): Component Sequence
ComponentShape | (0014,0050): Component Shape
ComponentType | (0070,1802): Component Type
ComponentTypeCodeSequence | (0076,0034): Component Type Code Sequence
ComponentTypesSequence | (0076,0032): Component Types Sequence
ComponentWelderIDs | (0014,0100): Component Welder IDs
CompositingMethod | (0070,1206): Compositing Method
CompoundGraphicInstanceID | (0070,0226): Compound Graphic Instance ID
CompoundGraphicSequence | (0070,0209): Compound Graphic Sequence
CompoundGraphicType | (0070,0294): Compound Graphic Type
CompoundGraphicUnits | (0070,0282): Compound Graphic Units
CompressionCode | (0028,0060): Compression Code()
CompressionContactArea | (0018,11A5): Compression Contact Area
CompressionDescription | (0028,0063): Compression Description
CompressionForce | (0018,11A2): Compression Force
CompressionLabel | (0028,0062): Compression Label
CompressionOriginator | (0028,0061): Compression Originator
CompressionPressure | (0018,11A3): Compression Pressure
CompressionRecognitionCode | (0028,005F): Compression Recognition Code
CompressionSequence | (0028,0065): Compression Sequence
CompressionStepPointers | (0028,0066): Compression Step Pointers
ConcatenationFrameOffsetNumber | (0020,9228): Concatenation Frame Offset Number
ConcatenationUID | (0020,9161): Concatenation UID
ConceptCodeSequence | (0040,A168): Concept Code Sequence
ConceptNameCodeSequence | (0040,A043): Concept Name Code Sequence
ConceptualVolumeBlockingConstraint | (3010,0068): Conceptual Volume Blocking Constraint
ConceptualVolumeCategoryCodeSequence | (3010,0067): Conceptual Volume Category Code Sequence
ConceptualVolumeCombinationDescription | (3010,000F): Conceptual Volume Combination Description
ConceptualVolumeCombinationExpression | (3010,000C): Conceptual Volume Combination Expression
ConceptualVolumeCombinationFlag | (3010,000E): Conceptual Volume Combination Flag
ConceptualVolumeConstituentIndex | (3010,000D): Conceptual Volume Constituent Index
ConceptualVolumeConstituentSegmentationReferenceSequence | (3010,0012): Conceptual Volume Constituent Segmentation Reference Sequence
ConceptualVolumeConstituentSequence | (3010,0008): Conceptual Volume Constituent Sequence
ConceptualVolumeDerivationAlgorithmSequence | (3010,0016): Conceptual Volume Derivation Algorithm Sequence
ConceptualVolumeDescription | (3010,0017): Conceptual Volume Description
ConceptualVolumeIdentificationSequence |
ConceptualVolumeOptimizationPrecedence | (3010,0066): Conceptual Volume Optimization Precedence
ConceptualVolumeSegmentationDefinedFlag | (3010,0010): Conceptual Volume Segmentation Defined Flag
ConceptualVolumeSegmentationReferenceSequence | (3010,0011): Conceptual Volume Segmentation Reference Sequence
ConceptualVolumeSequence | (3010,0025): Conceptual Volume Sequence
ConceptualVolumeTypeCodeSequence | (3010,0069): Conceptual Volume Type Code Sequence
ConceptualVolumeTypeModifierCodeSequence | (3010,006A): Conceptual Volume Type Modifier Code Sequence
ConceptualVolumeUID | (3010,0006): Conceptual Volume UID
CondenserLensPower | (0048,0111): Condenser Lens Power
ConfidentialityCode | (0040,1008): Confidentiality Code
ConfidentialityConstraintOnPatientDataDescription | (0040,3001): Confidentiality Constraint on Patient Data Description
ConfigurationDescription | (0028,700D): Configuration Description
ConfigurationID | (0028,700B): Configuration ID
ConfigurationInformation | (2010,0150): Configuration Information
ConfigurationInformationDescription | (2010,0152): Configuration Information Description
ConfigurationName | (0028,700C): Configuration Name
ConfigurationQAResultsSequence | (0028,7011): Configuration QA Results Sequence
ConfirmationSequence | (300A,073F): Confirmation Sequence
ConfocalMicroscopyImageFrameTypeSequence |
ConfocalMode |
ConnectorType | (0014,5105): Connector Type
ConsentForClinicalTrialUseSequence | (0012,0083): Consent for Clinical Trial Use Sequence
ConsentForDistributionFlag | (0012,0085): Consent for Distribution Flag
ConstantVolumeFlag | (0018,9333): Constant Volume Flag
ConstituentConceptualVolumeUID | (3010,0013): Constituent Conceptual Volume UID
ConstraintType | (0082,0032): Constraint Type
ConstraintValueSequence | (0082,0034): Constraint Value Sequence
ConstraintViolationCondition | (0082,0037): Constraint Violation Condition
ConstraintViolationSignificance | (0082,0036): Constraint Violation Significance
ConstraintWeight | (300A,0021): Constraint Weight
ConsultingPhysicianIdentificationSequence | (0008,009D): Consulting Physician Identification Sequence
ConsultingPhysicianName | (0008,009C): Consulting Physician's Name
ContactDisplayName | (0074,100C): Contact Display Name
ContactMethod | (0016,1003): Contact Method
ContactURI | (0074,100A): Contact URI
ContainerComponentDescription | (0050,001E): Container Component Description
ContainerComponentDiameter | (0050,001D): Container Component Diameter
ContainerComponentID | (0050,001B): Container Component ID
ContainerComponentLength | (0050,001C): Container Component Length
ContainerComponentMaterial | (0050,001A): Container Component Material
ContainerComponentSequence | (0040,0520): Container Component Sequence
ContainerComponentThickness | (0050,0013): Container Component Thickness
ContainerComponentTypeCodeSequence | (0050,0012): Container Component Type Code Sequence
ContainerComponentWidth | (0050,0015): Container Component Width
ContainerDescription | (0040,051A): Container Description
ContainerFileType |
ContainerIdentifier | (0040,0512): Container Identifier
ContainerTypeCodeSequence | (0040,0518): Container Type Code Sequence
ContentCreatorIdentificationCodeSequence | (0070,0086): Content Creator's Identification Code Sequence
ContentCreatorName | (0070,0084): Content Creator's Name
ContentDate | (0008,0023): Content Date
ContentDescription | (0070,0081): Content Description
ContentItemModifierSequence | (0040,0441): Content Item Modifier Sequence
ContentLabel | (0070,0080): Content Label
ContentQualification | (0018,9004): Content Qualification
ContentSequence | (0040,A730): Content Sequence
ContentTemplateSequence | (0040,A504): Content Template Sequence
ContentTime | (0008,0033): Content Time
ContextGroupExtensionCreatorUID | (0008,010D): Context Group Extension Creator UID
ContextGroupExtensionFlag | (0008,010B): Context Group Extension Flag
ContextGroupIdentificationSequence | (0008,0123): Context Group Identification Sequence
ContextGroupLocalVersion | (0008,0107): Context Group Local Version
ContextGroupVersion | (0008,0106): Context Group Version
ContextIdentifier | (0008,010F): Context Identifier
ContextUID | (0008,0117): Context UID
ContinuationEndMeterset | (0074,0121): Continuation End Meterset
ContinuationEndTotalReferenceAirKerma | (0074,1403): Continuation End Total Reference Air Kerma
ContinuationPulseNumber | (0074,1404): Continuation Pulse Number
ContinuationStartMeterset | (0074,0120): Continuation Start Meterset
ContinuationStartTotalReferenceAirKerma | (0074,1402): Continuation Start Total Reference Air Kerma
ContinuityOfContent | (0040,A050): Continuity Of Content
ContourData | (3006,0050): Contour Data
ContourGeometricType | (3006,0042): Contour Geometric Type
ContourImageSequence | (3006,0016): Contour Image Sequence
ContourNumber | (3006,0048): Contour Number
ContourOffsetVector | (3006,0045): Contour Offset Vector
ContourSequence | (3006,0040): Contour Sequence
ContourSlabThickness | (3006,0044): Contour Slab Thickness
ContourUncertaintyRadius | (0070,0312): Contour Uncertainty Radius
ContraindicationsCodeSequence | (0018,990B): Contraindications Code Sequence
Contrast | (0016,0048): Contrast
ContrastAdministrationProfileSequence | (0018,9340): Contrast Administration Profile Sequence
ContrastBolusAdministrationRouteSequence | (0018,0014): Contrast/Bolus Administration Route Sequence
ContrastBolusAgent | (0018,0010): Contrast/Bolus Agent
ContrastBolusAgentAdministered | (0018,9342): Contrast/Bolus Agent Administered
ContrastBolusAgentDetected | (0018,9343): Contrast/Bolus Agent Detected
ContrastBolusAgentNumber | (0018,9337): Contrast/Bolus Agent Number
ContrastBolusAgentPhase | (0018,9344): Contrast/Bolus Agent Phase
ContrastBolusAgentSequence | (0018,0012): Contrast/Bolus Agent Sequence
ContrastBolusAutoInjectionTriggerFlag | (0018,11B6): Contrast/Bolus Auto Injection Trigger Flag
ContrastBolusIngredient | (0018,1048): Contrast/Bolus Ingredient
ContrastBolusIngredientCodeSequence | (0018,9338): Contrast/Bolus Ingredient Code Sequence
ContrastBolusIngredientConcentration | (0018,1049): Contrast/Bolus Ingredient Concentration
ContrastBolusIngredientOpaque | (0018,9425): Contrast/Bolus Ingredient Opaque
ContrastBolusIngredientPercentByVolume | (0052,0001): Contrast/Bolus Ingredient Percent by Volume
ContrastBolusInjectionDelay | (0018,11B7): Contrast/Bolus Injection Delay
ContrastBolusRoute | (0018,1040): Contrast/Bolus Route
ContrastBolusStartTime | (0018,1042): Contrast/Bolus Start Time
ContrastBolusStopTime | (0018,1043): Contrast/Bolus Stop Time
ContrastBolusT1Relaxivity | (0018,0013): Contrast/Bolus T1 Relaxivity
ContrastBolusTotalDose | (0018,1044): Contrast/Bolus Total Dose
ContrastBolusUsageSequence | (0018,9341): Contrast/Bolus Usage Sequence
ContrastBolusVolume | (0018,1041): Contrast/Bolus Volume
ContrastFlowDuration | (0018,1047): Contrast Flow Duration
ContrastFlowRate | (0018,1046): Contrast Flow Rate
ContrastFrameAveraging | (0028,6112): Contrast Frame Averaging
ContributingEquipmentSequence | (0018,A001): Contributing Equipment Sequence
ContributingSOPInstancesReferenceSequence | (0020,9529): Contributing SOP Instances Reference Sequence
ContributingSourcesSequence | (0018,9506): Contributing Sources Sequence
ContributionDateTime | (0018,A002): Contribution DateTime
ContributionDescription | (0018,A003): Contribution Description
ControlPoint3DPosition | (300A,02D4): Control Point 3D Position
ControlPointDeliverySequence | (3008,0040): Control Point Delivery Sequence
ControlPointIndex | (300A,0112): Control Point Index
ControlPointOrientation | (300A,0412): Control Point Orientation
ControlPointRelativePosition | (300A,02D2): Control Point Relative Position
ControlPointSequence | (300A,0111): Control Point Sequence
ConventionalControlPointVerificationSequence | (0074,104C): Conventional Control Point Verification Sequence
ConventionalMachineVerificationSequence | (0074,1044): Conventional Machine Verification Sequence
ConversionSourceAttributesSequence | (0020,9172): Conversion Source Attributes Sequence
ConversionType | (0008,0064): Conversion Type
ConvolutionKernel | (0018,1210): Convolution Kernel
ConvolutionKernelGroup | (0018,9316): Convolution Kernel Group
CoordinatesSetGeometricTypeTrial | (0040,A290): Coordinates Set Geometric Type (Trial)
CoordinateStartValue | (50xx,0112): Coordinate Start Value
CoordinateStepValue | (50xx,0114): Coordinate Step Value
CoordinateSystemAxesSequence | (0014,2204): Coordinate System Axes Sequence
CoordinateSystemAxisCodeSequence | (0040,08DA): Coordinate System Axis Code Sequence
CoordinateSystemAxisDescription | (0014,2206): Coordinate System Axis Description
CoordinateSystemAxisNumber | (0014,220A): Coordinate System Axis Number
CoordinateSystemAxisType | (0014,220C): Coordinate System Axis Type
CoordinateSystemAxisUnits | (0014,220E): Coordinate System Axis Units
CoordinateSystemAxisValues | (0014,2210): Coordinate System Axis Values
CoordinateSystemDataSetMapping | (0014,2208): Coordinate System Data Set Mapping
CoordinateSystemNumberOfAxes | (0014,2202): Coordinate System Number of Axes
CoordinateSystemTransformRotationAndScaleMatrix | (0014,222A): Coordinate System Transform Rotation and Scale Matrix
CoordinateSystemTransformSequence | (0014,2220): Coordinate System Transform Sequence
CoordinateSystemTransformTranslationMatrix | (0014,222C): Coordinate System Transform Translation Matrix
Copies | (0000,5170): Copies()
CornealAxis | (0046,0115): Corneal Axis
CornealEccentricityIndex | (0046,0234): Corneal Eccentricity Index
CornealISValue | (0046,0224): Corneal I-S Value
CornealPointEstimated | (0046,0248): Corneal Point Estimated
CornealPointLocation | (0046,0247): Corneal Point Location
CornealPower | (0046,0114): Corneal Power
CornealSize | (0046,0046): Corneal Size
CornealSizeSequence | (0046,0047): Corneal Size Sequence
CornealTopographyMappingNormalsSequence | (0046,0210): Corneal Topography Mapping Normals Sequence
CornealTopographyMapQualityEvaluation | (0046,0242): Corneal Topography Map Quality Evaluation
CornealTopographyMapTypeCodeSequence | (0046,0207): Corneal Topography Map Type Code Sequence
CornealTopographySurface | (0046,0201): Corneal Topography Surface
CornealVertexLocation | (0046,0202): Corneal Vertex Location
CornealWavefront | (0046,0253): Corneal Wavefront
CorneaMeasurementMethodCodeSequence | (0046,0116): Cornea Measurement Method Code Sequence
CorneaMeasurementsSequence | (0046,0110): Cornea Measurements Sequence
CorrectedImage | (0028,0051): Corrected Image
CorrectedLocalizedDeviationFromNormal | (0024,0079): Corrected Localized Deviation From Normal
CorrectedLocalizedDeviationFromNormalCalculated | (0024,0078): Corrected Localized Deviation From Normal Calculated
CorrectedLocalizedDeviationFromNormalProbability | (0024,0081): Corrected Localized Deviation From Normal Probability
CorrectedLocalizedDeviationFromNormalProbabilityCalculated | (0024,0080): Corrected Localized Deviation From Normal Probability Calculated
CorrectedParameterSequence | (3008,0068): Corrected Parameter Sequence
CorrectionValue | (3008,006A): Correction Value
CountLossNormalizationCorrected | (0018,9764): Count Loss Normalization Corrected
CountRate | (0018,1243): Count Rate
CountryOfResidence | (0010,2150): Country of Residence
CountsAccumulated | (0018,0070): Counts Accumulated
CountsIncluded | (0054,1400): Counts Included
CountsSource | (0054,1002): Counts Source
CouplingMedium | (0014,4056): Coupling Medium
CouplingTechnique | (0014,4054): Coupling Technique
CouplingVelocity | (0014,4057): Coupling Velocity
CoverageOfKSpace | (0018,9094): Coverage of k-Space
CranialThermalIndex | (0018,5026): Cranial Thermal Index
CreationDate | (2100,0040): Creation Date
CreationTime | (2100,0050): Creation Time
CreatorVersionUID | (0008,9123): Creator-Version UID
Crop | (0070,1204): Crop
CroppingSpecificationIndex | (0070,1205): Cropping Specification Index
CroppingSpecificationNumber | (0070,1309): Cropping Specification Number
CSSFontName | (0070,0229): CSS Font Name
CTAcquisitionDetailsSequence | (0018,9304): CT Acquisition Details Sequence
CTAcquisitionTypeSequence | (0018,9301): CT Acquisition Type Sequence
CTAdditionalXRaySourceSequence | (0018,9360): CT Additional X-Ray Source Sequence
CTDIPhantomTypeCodeSequence | (0018,9346): CTDI Phantom Type Code Sequence
CTDIvol | (0018,9345): CTDIvol
CTDIvolNotificationTrigger | (0018,9942): CTDIvol Notification Trigger
CTExposureSequence | (0018,9321): CT Exposure Sequence
CTGeometrySequence | (0018,9312): CT Geometry Sequence
CTImageFrameTypeSequence | (0018,9329): CT Image Frame Type Sequence
CTImagingAcquisitionParameterSequence |
CTPositionSequence | (0018,9326): CT Position Sequence
CTReconstructionSequence | (0018,9314): CT Reconstruction Sequence
CTTableDynamicsSequence | (0018,9308): CT Table Dynamics Sequence
CTXRayDetailsSequence | (0018,9325): CT X-Ray Details Sequence
CumulativeDoseReferenceCoefficient | (300A,010C): Cumulative Dose Reference Coefficient
CumulativeDoseToDoseReference | (3008,0052): Cumulative Dose to Dose Reference
CumulativeMeterset | (300A,063C): Cumulative Meterset
CumulativeMetersetWeight | (300A,0134): Cumulative Meterset Weight
CumulativeTimeWeight | (300A,02D6): Cumulative Time Weight
CurrentConfigurationID | (0028,7002): Current Configuration ID
CurrentFractionNumber | (3008,0022): Current Fraction Number
CurrentObserverTrial | (0040,A307): Current Observer (Trial)
CurrentPatientLocation | (0038,0300): Current Patient Location
CurrentRequestedProcedureEvidenceSequence | (0040,A375): Current Requested Procedure Evidence Sequence
CurrentTreatmentStatus | (3008,0200): Current Treatment Status
CurvatureType | (0014,0052): Curvature Type
CurveActivationLayer | (50xx,1001): Curve Activation Layer
CurveData | (50xx,3000): Curve Data
CurveDataDescriptor | (50xx,0110): Curve Data Descriptor
CurveDate | (0008,0025): Curve Date
CurveDescription | (50xx,0022): Curve Description
CurveDimensions | (50xx,0005): Curve Dimensions
CurveLabel | (50xx,2500): Curve Label
CurveNumber | (0020,0024): Curve Number
CurveRange | (50xx,0106): Curve Range
CurveReferencedOverlayGroup | (50xx,2610): Curve Referenced Overlay Group
CurveReferencedOverlaySequence | (50xx,2600): Curve Referenced Overlay Sequence
CurveTime | (0008,0035): Curve Time()
CustodialOrganizationSequence | (0040,A07C): Custodial Organization Sequence
CustomRendered | (0016,0041): Custom Rendered
CylinderAxis | (0022,0009): Cylinder Axis
CylinderLensPower | (0022,0008): Cylinder Lens Power
CylinderPower | (0046,0147): Cylinder Power
CylinderSequence | (0046,0018): Cylinder Sequence
DACAmplitude | (0014,403C): DAC Amplitude
DACGainPoints | (0014,4038): DAC Gain Points
DACSequence | (0014,4035): DAC Sequence
DACTimePoints | (0014,403A): DAC Time Points
DACType | (0014,4036): DAC Type
Damping | (0014,4028): Damping
DarkCurrentCounts | (0014,3050): Dark Current Counts
DarkCurrentSequence | (0014,3040): Dark Current Sequence
DataBlock | (0028,0702): Data Block
DataBlockDescription | (0028,0701): Data Block Description
DataCollectionCenterPatient | (0018,9313): Data Collection Center (Patient)
DataCollectionDiameter | (0018,0090): Data Collection Diameter
DataElement |
DataElementConditionality |
DataElementDescription |
DataElementLabelItemSequence |
DataElementLabelSequence |
DataElementMaximumCharacters |
DataElementMinimumCharacters |
DataElementName |
DataElementsSigned | (0400,0020): Data Elements Signed
DataFrameAssignmentSequence | (0028,1401): Data Frame Assignment Sequence
DataInformationSequence | (0054,0063): Data Information Sequence
DataObservationSequence | (0024,0325): Data Observation Sequence
DataPathAssignment | (0028,1402): Data Path Assignment
DataPathID | (0028,140E): Data Path ID
DataPointColumns | (0028,9002): Data Point Columns
DataPointRows | (0028,9001): Data Point Rows
DataRepresentation | (0028,9108): Data Representation
DataSetDescription | (0024,0309): Data Set Description
DataSetName | (0024,0306): Data Set Name
DataSetSource | (0024,0308): Data Set Source
DataSetSubtype | (0008,0041): Data Set Subtype
DataSetTrailingPadding | (FFFC,FFFC): Data Set Trailing Padding
DataSetType | (0008,0040): Data Set Type
DataSetVersion | (0024,0307): Data Set Version
DataType | (0018,9808): Data Type
DataValueRepresentation | (50xx,0103): Data Value Representation
Date | (0040,A121): Date
DateOfDocumentOrVerbalTransactionTrial | (0040,A110): Date of Document or Verbal Transaction (Trial)
DateOfGainCalibration | (0014,3076): Date of Gain Calibration
DateOfInstallation |
DateOfLastCalibration | (0018,1200): Date of Last Calibration
DateOfLastDetectorCalibration | (0018,700C): Date of Last Detector Calibration
DateOfManufacture |
DateOfSecondaryCapture | (0018,1012): Date of Secondary Capture
DateTime | (0040,A120): DateTime
DateTimeOfLastCalibration | (0018,1202): DateTime of Last Calibration
dBdt | (0018,1318): dB/dt
DCTLabel | (0028,0700): DCT Label
DDLValue | (0028,7017): DDL Value
DeadTimeCorrected | (0018,9761): Dead Time Corrected
DeadTimeCorrectionFlag | (0054,1401): Dead Time Correction Flag
DeadTimeFactor | (0054,1324): Dead Time Factor
DecayCorrected | (0018,9758): Decay Corrected
DecayCorrection | (0054,1102): Decay Correction
DecayCorrectionDateTime | (0018,9701): Decay Correction DateTime
DecayFactor | (0054,1321): Decay Factor
DecimalPotentialVisualAcuity | (0046,0238): Decimal Potential Visual Acuity
DecimalVisualAcuity | (0046,0137): Decimal Visual Acuity
DecimateCropResult | (2020,00A2): Decimate/Crop Result
DecompositionAlgorithmIdentificationSequence | (0018,9380): Decomposition Algorithm Identification Sequence
DecompositionDescription | (0018,937F): Decomposition Description
DecompositionMaterialSequence | (0018,9381): Decomposition Material Sequence
DecompositionMethod | (0018,937E): Decomposition Method
DecoupledNucleus | (0018,9060): De-coupled Nucleus
Decoupling | (0018,9059): De-coupling
DecouplingChemicalShiftReference | (0018,9063): De-coupling Chemical Shift Reference
DecouplingFrequency | (0018,9061): De-coupling Frequency
DecouplingMethod | (0018,9062): De-coupling Method
DefaultMagnificationType | (2010,00A6): Default Magnification Type
DefaultPrinterResolutionID | (2010,0054): Default Printer Resolution ID
DefaultSmoothingType | (2010,00A8): Default Smoothing Type
DefinitionSourceSequence | (0008,1156): Definition Source Sequence
DeformableRegistrationGridSequence | (0064,0005): Deformable Registration Grid Sequence
DeformableRegistrationSequence | (0064,0002): Deformable Registration Sequence
DegreeOfDilation | (0022,000E): Degree of Dilation
DegreeOfFreedomID | (0068,6410): Degree of Freedom ID
DegreeOfFreedomType | (0068,6420): Degree of Freedom Type
DeidentificationAction | (0008,0307): Deidentification Action
DeidentificationActionSequence | (0008,0305): Deidentification Action Sequence
DeidentificationMethod | (0012,0063): De-identification Method
DeidentificationMethodCodeSequence | (0012,0064): De-identification Method Code Sequence
DelayLawIdentifier | (0014,405C): Delay Law Identifier
DeletionLock | (0074,1230): Deletion Lock
DelineatedRadiationFieldSize |
DeliveredChannelTotalTime | (3008,0134): Delivered Channel Total Time
DeliveredDepthDoseParametersSequence | (300A,0506): Delivered Depth Dose Parameters Sequence
DeliveredDistalDepth | (300A,0508): Delivered Distal Depth
DeliveredDistalDepthFraction | (300A,0507): Delivered Distal Depth Fraction
DeliveredMeterset | (3008,0044): Delivered Meterset
DeliveredNominalRangeModulatedRegionDepths | (300A,0510): Delivered Nominal Range Modulated Region Depths
DeliveredNominalRangeModulationFractions | (300A,0509): Delivered Nominal Range Modulation Fractions
DeliveredNumberOfPulses | (3008,0138): Delivered Number of Pulses
DeliveredPrimaryMeterset | (3008,0036): Delivered Primary Meterset
DeliveredPulseRepetitionInterval | (3008,013C): Delivered Pulse Repetition Interval
DeliveredReferenceDoseDefinition | (300A,0511): Delivered Reference Dose Definition
DeliveredSecondaryMeterset | (3008,0037): Delivered Secondary Meterset
DeliveredTreatmentTime | (3008,003B): Delivered Treatment Time
DeliveryMaximumDose | (300A,0023): Delivery Maximum Dose
DeliveryRate | (300A,063D): Delivery Rate
DeliveryRateUnitSequence | (300A,063E): Delivery Rate Unit Sequence
DeliveryTimeStructureCodeSequence | (3010,0088): Delivery Time Structure Code Sequence
DeliveryVerificationImageSequence | (0074,1030): Delivery Verification Image Sequence
DeliveryWarningDose | (300A,0022): Delivery Warning Dose
Density | (4010,1018): Density
DepthDoseParametersSequence | (300A,0505): Depth Dose Parameters Sequence
DepthOfScanField | (0018,5050): Depth of Scan Field
DepthOfTransverseImage | (0022,0041): Depth of Transverse Image
DepthsOfFocus | (0018,9801): Depth(s) of Focus
DepthSpatialResolution | (0022,0035): Depth Spatial Resolution
DepthValueAveragingFlag | (300A,0093): Depth Value Averaging Flag
DerivationAlgorithmSequence | (0022,1612): Derivation Algorithm Sequence
DerivationCodeSequence | (0008,9215): Derivation Code Sequence
DerivationConceptualVolumeSequence | (3010,0014): Derivation Conceptual Volume Sequence
DerivationDescription | (0008,2111): Derivation Description
DerivationImageSequence | (0008,9124): Derivation Image Sequence
DerivationImplantAssemblyTemplateSequence | (0076,000E): Derivation Implant Assembly Template Sequence
DerivationImplantTemplateSequence | (0068,6224): Derivation Implant Template Sequence
DestinationAE | (2100,0140): Destination AE
DetailsOfCoefficients | (0028,0404): Details of Coefficients
DetectorActivationOffsetFromExposure | (0018,7016): Detector Activation Offset From Exposure
DetectorActiveAreaOrientation | (0018,9558): Detector Active Area Orientation
DetectorActiveAreaTLHCPosition | (0018,9557): Detector Active Area TLHC Position
DetectorActiveDimensions | (0018,7026): Detector Active Dimension(s)
DetectorActiveOrigin | (0018,7028): Detector Active Origin
DetectorActiveShape | (0018,7024): Detector Active Shape
DetectorActiveTime | (0018,7014): Detector Active Time
DetectorBinning | (0018,701A): Detector Binning
DetectorCalibrationData | (4010,106C): Detector Calibration Data
DetectorConditionsNominalFlag | (0018,7000): Detector Conditions Nominal Flag
DetectorConfiguration | (0018,7005): Detector Configuration
DetectorDescription | (0018,7006): Detector Description
DetectorElementPhysicalSize | (0018,7020): Detector Element Physical Size
DetectorElementSize | (0054,1203): Detector Element Size
DetectorElementSpacing | (0018,7022): Detector Element Spacing
DetectorGeometry | (0018,9725): Detector Geometry
DetectorGeometrySequence | (4010,0004): Detector Geometry Sequence
DetectorID | (0018,700A): Detector ID
DetectorInformationSequence | (0054,0022): Detector Information Sequence
DetectorIsocenterPrimaryAngle | (0018,9550): Detector Isocenter Primary Angle
DetectorIsocenterSecondaryAngle | (0018,9551): Detector Isocenter Secondary Angle
DetectorLinesOfResponseUsed | (0054,1104): Detector Lines of Response Used
DetectorManufacturerModelName | (0018,702B): Detector Manufacturer's Model Name
DetectorManufacturerName | (0018,702A): Detector Manufacturer Name
DetectorMode | (0018,7008): Detector Mode
DetectorNormalizationCorrection | (0018,9768): Detector Normalization Correction
DetectorPositioningType |
DetectorPositionSequence | (0018,9541): Detector Position Sequence
DetectorPrimaryAngle | (0018,1530): Detector Primary Angle
DetectorSecondaryAngle | (0018,1531): Detector Secondary Angle
DetectorTemperature | (0018,7001): Detector Temperature
DetectorTemperatureSequence | (0014,3020): Detector Temperature Sequence
DetectorTimeSinceLastExposure | (0018,7012): Detector Time Since Last Exposure
DetectorType | (0018,7004): Detector Type
DetectorVector | (0054,0020): Detector Vector
DetectorXPositionToIsocenter | (0018,9552): Detector X Position to Isocenter
DetectorYPositionToIsocenter | (0018,9553): Detector Y Position to Isocenter
DetectorZPositionToIsocenter | (0018,9554): Detector Z Position to Isocenter
DeviationIndex | (0018,1413): Deviation Index
DeviceAlternateIdentifier | (3010,001B): Device Alternate Identifier
DeviceAlternateIdentifierFormat | (3010,001D): Device Alternate Identifier Format
DeviceAlternateIdentifierType | (3010,001C): Device Alternate Identifier Type
DeviceDescription | (0050,0020): Device Description
DeviceDiameter | (0050,0016): Device Diameter
DeviceDiameterUnits | (0050,0017): Device Diameter Units
DeviceID | (0018,1003): Device ID
DeviceIndex | (3010,0039): Device Index
DeviceLabel | (3010,002D): Device Label
DeviceLength | (0050,0014): Device Length
DeviceMotionControlSequence | (300A,0450): Device Motion Control Sequence
DeviceMotionExecutionMode | (300A,0451): Device Motion Execution Mode
DeviceMotionObservationMode | (300A,0452): Device Motion Observation Mode
DeviceMotionParameterCodeSequence | (300A,0453): Device Motion Parameter Code Sequence
DeviceOrderIndex | (300A,065E): Device Order Index
DevicePositionParameterSequence |
DevicePositionToEquipmentMappingMatrix |
DeviceSequence | (0050,0010): Device Sequence
DeviceSerialNumber | (0018,1000): Device Serial Number
DeviceSettingDescription | (0016,004B): Device Setting Description
DeviceSpecificAcquisitionParameterSequence |
DeviceTypeCodeSequence | (3010,002E): Device Type Code Sequence
DeviceUID | (0018,1002): Device UID
DeviceVolume | (0050,0018): Device Volume
DialogReceiver | (0000,4000): Dialog Receiver()
DiameterOfCircularOutline | (0018,1636): Diameter of Circular Outline
DiameterOfVisibility | (0070,0262): Diameter of Visibility
DiaphragmPosition | (3002,0034): Diaphragm Position
DICOMMediaRetrievalSequence | (0040,E022): DICOM Media Retrieval Sequence
DICOMRetrievalSequence | (0040,E021): DICOM Retrieval Sequence
DICOMStorageSequence | (0040,4071): DICOM Storage Sequence
DICOSVersion | (4010,103A): DICOS Version
DiffuseReflectionIntensity | (0070,1704): Diffuse Reflection Intensity
DiffusionAcquisitionCodeSequence | (0066,0133): Diffusion Acquisition Code Sequence
DiffusionAnisotropyType | (0018,9147): Diffusion Anisotropy Type
DiffusionBMatrixSequence | (0018,9601): Diffusion b-matrix Sequence
DiffusionBValue | (0018,9087): Diffusion b-value
DiffusionBValueXX | (0018,9602): Diffusion b-value XX
DiffusionBValueXY | (0018,9603): Diffusion b-value XY
DiffusionBValueXZ | (0018,9604): Diffusion b-value XZ
DiffusionBValueYY | (0018,9605): Diffusion b-value YY
DiffusionBValueYZ | (0018,9606): Diffusion b-value YZ
DiffusionBValueZZ | (0018,9607): Diffusion b-value ZZ
DiffusionDirectionality | (0018,9075): Diffusion Directionality
DiffusionGradientDirectionSequence | (0018,9076): Diffusion Gradient Direction Sequence
DiffusionGradientOrientation | (0018,9089): Diffusion Gradient Orientation
DiffusionModelCodeSequence | (0066,0134): Diffusion Model Code Sequence
DigitalFilterCharacteristicsSequence |
DigitalFilterOrder |
DigitalFilterTypeCodeSequence |
DigitalImageFormatAcquired | (0018,1023): Digital Image Format Acquired
DigitalSignatureDateTime | (0400,0105): Digital Signature DateTime
DigitalSignaturePurposeCodeSequence | (0400,0401): Digital Signature Purpose Code Sequence
DigitalSignaturesSequence | (FFFA,FFFA): Digital Signatures Sequence
DigitalSignatureUID | (0400,0100): Digital Signature UID
DigitalZoomRatio | (0016,0044): Digital Zoom Ratio
DigitizingDeviceTransportDirection | (0018,2020): Digitizing Device Transport Direction
DimensionDescriptionLabel | (0020,9421): Dimension Description Label
DimensionIndexPointer | (0020,9165): Dimension Index Pointer
DimensionIndexPrivateCreator | (0020,9213): Dimension Index Private Creator
DimensionIndexSequence | (0020,9222): Dimension Index Sequence
DimensionIndexValues | (0020,9157): Dimension Index Values
DimensionOrganizationSequence | (0020,9221): Dimension Organization Sequence
DimensionOrganizationType | (0020,9311): Dimension Organization Type
DimensionOrganizationUID | (0020,9164): Dimension Organization UID
DirectoryRecordSequence | (0004,1220): Directory Record Sequence
DirectoryRecordType | (0004,1430): Directory Record Type
DirectSegmentReferenceSequence | (3010,0023): Direct Segment Reference Sequence
DischargeDate | (0038,0030): Discharge Date
DischargeDiagnosisCodeSequence | (0038,0044): Discharge Diagnosis Code Sequence
DischargeDiagnosisDescription | (0038,0040): Discharge Diagnosis Description
DischargeTime | (0038,0032): Discharge Time
DisplacementMatrix | (300A,079B): Displacement Matrix
DisplacementReferenceLabel | (300A,079A): Displacement Reference Label
DisplacementReferenceLocationCodeSequence | (300A,079D): Displacement Reference Location Code Sequence
DisplayCalibrationResultSequence | (0028,7016): Display Calibration Result Sequence
DisplayDeviceTypeCodeSequence | (0028,7022): Display Device Type Code Sequence
DisplayedAreaBottomRightHandCorner | (0070,0053): Displayed Area Bottom Right Hand Corner
DisplayedAreaBottomRightHandCornerTrial | (0070,0051): Displayed Area Bottom Right Hand Corner (Trial)
DisplayedAreaSelectionSequence | (0070,005A): Displayed Area Selection Sequence
DisplayedAreaTopLeftHandCorner | (0070,0052): Displayed Area Top Left Hand Corner
DisplayedAreaTopLeftHandCornerTrial | (0070,0050): Displayed Area Top Left Hand Corner (Trial)
DisplayedZValue | (0018,2046): Displayed Z Value
DisplayEnvironmentSpatialPosition | (0072,0108): Display Environment Spatial Position
DisplayFilterPercentage | (0028,9411): Display Filter Percentage
DisplayFormat | (0000,5110): Display Format()
DisplayFunctionType | (0028,7019): Display Function Type
DisplaySetHorizontalJustification | (0072,0717): Display Set Horizontal Justification
DisplaySetLabel | (0072,0203): Display Set Label
DisplaySetNumber | (0072,0202): Display Set Number
DisplaySetPatientOrientation | (0072,0700): Display Set Patient Orientation
DisplaySetPresentationGroup | (0072,0204): Display Set Presentation Group
DisplaySetPresentationGroupDescription | (0072,0206): Display Set Presentation Group Description
DisplaySetScrollingGroup | (0072,0212): Display Set Scrolling Group
DisplaySetsSequence | (0072,0200): Display Sets Sequence
DisplaySetVerticalJustification | (0072,0718): Display Set Vertical Justification
DisplayShadingFlag | (003A,0246): Display Shading Flag
DisplaySubsystemConfigurationSequence | (0028,700A): Display Subsystem Configuration Sequence
DisplaySubsystemDescription | (0028,7005): Display Subsystem Description
DisplaySubsystemID | (0028,7003): Display Subsystem ID
DisplaySubsystemName | (0028,7004): Display Subsystem Name
DisplaySubsystemQAResultsSequence | (0028,7010): Display Subsystem QA Results Sequence
DisplaySubsystemSequence | (0028,7023): Display Subsystem Sequence
DisplayWindowLabelVector | (0018,2006): Display Window Label Vector
DistalDepth | (300A,0502): Distal Depth
DistalDepthFraction | (300A,0501): Distal Depth Fraction
DistanceBetweenBscanSlabs | (0022,1644): Distance Between B-scan Slabs
DistanceBetweenFocalPlanes | (0048,0014): Distance Between Focal Planes
DistanceObjectToTableTop | (0018,9403): Distance Object to Table Top
DistancePupillaryDistance | (0046,0060): Distance Pupillary Distance
DistanceReceptorPlaneToDetectorHousing | (0018,9426): Distance Receptor Plane to Detector Housing
DistanceSourceToDataCollectionCenter | (0018,9335): Distance Source to Data Collection Center
DistanceSourceToDetector | (0018,1110): Distance Source to Detector
DistanceSourceToEntrance | (0040,0306): Distance Source to Entrance
DistanceSourceToIsocenter | (0018,9402): Distance Source to Isocenter
DistanceSourceToPatient | (0018,1111): Distance Source to Patient
DistanceSourceToSupport | (0040,0307): Distance Source to Support
DistributionAddress | (4008,011A): Distribution Address
DistributionName | (4008,0119): Distribution Name
DistributionType | (0012,0084): Distribution Type
DLPNotificationTrigger | (0018,9943): DLP Notification Trigger
DocumentAuthorIdentifierCodeSequenceTrial | (0040,A068): Document Author Identifier Code Sequence (Trial)
DocumentAuthorTrial | (0040,A067): Document Author (Trial)
DocumentClassCodeSequence | (0040,E008): Document Class Code Sequence
DocumentIdentifierCodeSequenceTrial | (0040,A066): Document Identifier Code Sequence (Trial)
DocumentingObserverIdentifierCodeSequenceTrial | (0040,A076): Documenting Observer Identifier Code Sequence (Trial)
DocumentingOrganizationIdentifierCodeSequenceTrial | (0040,A028): Documenting Organization Identifier Code Sequence (Trial)
DocumentTitle | (0042,0010): Document Title
DopplerCorrectionAngle | (0018,6034): Doppler Correction Angle
DopplerSampleVolumeXPosition | (0018,6039): Doppler Sample Volume X Position
DopplerSampleVolumeXPositionRetired | (0018,6038): Doppler Sample Volume X Position (Retired)
DopplerSampleVolumeYPosition | (0018,603B): Doppler Sample Volume Y Position
DopplerSampleVolumeYPositionRetired | (0018,603A): Doppler Sample Volume Y Position (Retired)
DoseCalibrationConditionsSequence |
DoseCalibrationConditionsVerifiedFlag |
DoseCalibrationFactor | (0054,1322): Dose Calibration Factor
DoseComment | (3004,0006): Dose Comment
DoseGridScaling | (3004,000E): Dose Grid Scaling
DoseMeasurementDeviceCodeSequence | (300A,0774): Dose Measurement Device Code Sequence
DoseModeName | (0018,11B1): Dose Mode Name
DoseRateDelivered | (3008,0048): Dose Rate Delivered
DoseRateSet | (300A,0115): Dose Rate Set
DoseReferenceDescription | (300A,0016): Dose Reference Description
DoseReferenceNumber | (300A,0012): Dose Reference Number
DoseReferencePointCoordinates | (300A,0018): Dose Reference Point Coordinates
DoseReferenceSequence | (300A,0010): Dose Reference Sequence
DoseReferenceStructureType | (300A,0014): Dose Reference Structure Type
DoseReferenceType | (300A,0020): Dose Reference Type
DoseReferenceUID | (300A,0013): Dose Reference UID
DoseSummationType | (3004,000A): Dose Summation Type
DoseType | (3004,0004): Dose Type
DoseUnits | (3004,0002): Dose Units
DoseValue | (3004,0012): Dose Value
DoseValueInterpretation |
DoseValuePurpose | (300A,061D): Dose Value Purpose
DoseValuesSequence | (300A,061C): Dose Values Sequence
DosimetricObjectiveEvaluationScope | (3010,0063): Dosimetric Objective Evaluation Scope
DosimetricObjectiveParameterSequence | (3010,0070): Dosimetric Objective Parameter Sequence
DosimetricObjectivePurpose | (3010,0075): Dosimetric Objective Purpose
DosimetricObjectiveSequence | (3010,006C): Dosimetric Objective Sequence
DosimetricObjectiveTypeCodeSequence | (3010,006D): Dosimetric Objective Type Code Sequence
DosimetricObjectiveUID | (3010,006E): Dosimetric Objective UID
DosimetricObjectiveWeight | (3010,0074): Dosimetric Objective Weight
DoubleExposureFieldDelta | (0074,133A): Double Exposure Field Delta
DoubleExposureFieldDeltaTrial | (0074,103A): Double Exposure Field Delta (Trial)
DoubleExposureFlag | (0074,1034): Double Exposure Flag
DoubleExposureMeterset | (0074,1338): Double Exposure Meterset
DoubleExposureMetersetTrial | (0074,1038): Double Exposure Meterset (Trial)
DoubleExposureOrdering | (0074,1036): Double Exposure Ordering
DoubleFloatPixelData | (7FE0,0009): Double Float Pixel Data
DoubleFloatPixelPaddingRangeLimit | (0028,0125): Double Float Pixel Padding Range Limit
DoubleFloatPixelPaddingValue | (0028,0123): Double Float Pixel Padding Value
DoubleFloatRealWorldValueFirstValueMapped | (0040,9214): Double Float Real World Value First Value Mapped
DoubleFloatRealWorldValueLastValueMapped | (0040,9213): Double Float Real World Value Last Value Mapped
DoublePointCoordinatesData | (0066,0022): Double Point Coordinates Data
DriveProbeSequence | (0014,4083): Drive Probe Sequence
DriveType | (0014,4081): Drive Type
DVHData | (3004,0058): DVH Data
DVHDoseScaling | (3004,0052): DVH Dose Scaling
DVHMaximumDose | (3004,0072): DVH Maximum Dose
DVHMeanDose | (3004,0074): DVH Mean Dose
DVHMinimumDose | (3004,0070): DVH Minimum Dose
DVHNormalizationDoseValue | (3004,0042): DVH Normalization Dose Value
DVHNormalizationPoint | (3004,0040): DVH Normalization Point
DVHNumberOfBins | (3004,0056): DVH Number of Bins
DVHReferencedROISequence | (3004,0060): DVH Referenced ROI Sequence
DVHROIContributionType | (3004,0062): DVH ROI Contribution Type
DVHSequence | (3004,0050): DVH Sequence
DVHType | (3004,0001): DVH Type
DVHVolumeUnits | (3004,0054): DVH Volume Units
DynamicRange | (0018,5030): Dynamic Range()
EchoNumbers | (0018,0086): Echo Number(s)
EchoPeakPosition | (0018,9298): Echo Peak Position
EchoPlanarPulseSequence | (0018,9018): Echo Planar Pulse Sequence
EchoPulseSequence | (0018,9008): Echo Pulse Sequence
EchoTime | (0018,0081): Echo Time
EchoTrainLength | (0018,0091): Echo Train Length
EdgePointIndexList | (0066,0024): Edge Point Index List
EffectiveBinEnergy | (0018,936E): Effective Bin Energy
EffectiveDateTime | (0068,6226): Effective DateTime
EffectiveDoseCalculationMethodCategoryCodeSequence | (3010,0003): Effective Dose Calculation Method Category Code Sequence
EffectiveDoseCalculationMethodCodeSequence | (3010,0004): Effective Dose Calculation Method Code Sequence
EffectiveDoseCalculationMethodDescription | (3010,0005): Effective Dose Calculation Method Description
EffectiveDuration | (0018,0072): Effective Duration
EffectiveEchoTime | (0018,9082): Effective Echo Time
EffectiveRefractiveIndex | (0052,0004): Effective Refractive Index
EffectiveWedgeAngle | (300A,00DE): Effective Wedge Angle
ElementDimensionA | (0014,4014): Element Dimension A
ElementDimensionB | (0014,4015): Element Dimension B
ElementPitchA | (0014,4016): Element Pitch A
ElementPitchB | (0014,401D): Element Pitch B
ElementShape | (0014,4013): Element Shape
EmitterColorTemperature | (0016,1002): Emitter Color Temperature
EmmetropicMagnification | (0022,000A): Emmetropic Magnification
EmptyImageBoxCIELabValue | (0072,0421): Empty Image Box CIELab Value
EmptyImageDensity | (2010,0110): Empty Image Density
EmptyValueMatchingSequence |
EncapsulatedDocument | (0042,0011): Encapsulated Document
EncapsulatedDocumentLength | (0042,0015): Encapsulated Document Length
EncapsulatedPixelDataValueTotalLength |
EncryptedAttributesSequence | (0400,0500): Encrypted Attributes Sequence
EncryptedContent | (0400,0520): Encrypted Content
EncryptedContentTransferSyntaxUID | (0400,0510): Encrypted Content Transfer Syntax UID
EndAcquisitionDateTime | (0018,9517): End Acquisition DateTime
EndCumulativeMetersetWeight | (300C,0009): End Cumulative Meterset Weight
EndCumulativeTimeWeight | (0074,1408): End Cumulative Time Weight
EndingRespiratoryAmplitude | (0020,9248): Ending Respiratory Amplitude
EndingRespiratoryPhase | (0020,9249): Ending Respiratory Phase
EndMessageID | (0000,5020): End Message ID()
EndMeterset | (3008,007A): End Meterset
EnergyDerivationCodeSequence |
EnergyUnitCodeSequence | (300A,0684): Energy Unit Code Sequence
EnergyWeightingFactor | (0018,9353): Energy Weighting Factor
EnergyWindowCenterline | (0018,0032): Energy Window Centerline
EnergyWindowInformationSequence | (0054,0012): Energy Window Information Sequence
EnergyWindowLowerLimit | (0054,0014): Energy Window Lower Limit
EnergyWindowName | (0054,0018): Energy Window Name
EnergyWindowNumber | (0054,0308): Energy Window Number
EnergyWindowRangeSequence | (0054,0013): Energy Window Range Sequence
EnergyWindowTotalWidth | (0018,0033): Energy Window Total Width
EnergyWindowUpperLimit | (0054,0015): Energy Window Upper Limit
EnergyWindowVector | (0054,0010): Energy Window Vector
EnhancedPaletteColorLookupTableSequence | (0028,140B): Enhanced Palette Color Lookup Table Sequence
EnhancedRTBeamLimitingDeviceDefinitionFlag |
EnhancedRTBeamLimitingDeviceSequence |
EnhancedRTBeamLimitingOpeningSequence |
EntityDescription | (3010,0037): Entity Description
EntityLabel | (3010,0035): Entity Label
EntityLongLabel | (3010,0038): Entity Long Label
EntityName | (3010,0036): Entity Name
EntranceDose | (0040,0302): Entrance Dose
EntranceDoseDerivation | (0040,8303): Entrance Dose Derivation
EntranceDoseInmGy | (0040,8302): Entrance Dose in mGy
EnvironmentalConditions | (0014,1040): Environmental Conditions
EquipmentAdministratorSequence | (0028,7000): Equipment Administrator Sequence
EquipmentCoordinateSystemIdentification | (0028,9537): Equipment Coordinate System Identification
EquipmentFrameOfReferenceDescription | (300A,0676): Equipment Frame of Reference Description
EquipmentFrameOfReferenceUID | (300A,0675): Equipment Frame of Reference UID
EquipmentModality | (0008,0221): Equipment Modality
EquipmentReferencePointCodeSequence | (300A,0678): Equipment Reference Point Code Sequence
EquipmentReferencePointCoordinatesSequence | (300A,0677): Equipment Reference Point Coordinates Sequence
EquivalentCDADocumentSequence | (0040,A090): Equivalent CDA Document Sequence
EquivalentCodeSequence | (0008,0121): Equivalent Code Sequence
EquivalentConceptualVolumeInstanceReferenceSequence | (3010,0009): Equivalent Conceptual Volume Instance Reference Sequence
EquivalentConceptualVolumesSequence | (3010,000A): Equivalent Conceptual Volumes Sequence
EquivalentPupilRadius | (0046,0205): Equivalent Pupil Radius
Erase | (0000,5190): Erase()
ErrorComment | (0000,0902): Error Comment
ErrorID | (0000,0903): Error ID
EscapeTriplet | (1000,xxx0): Escape Triplet
EstimatedDoseSaving | (0018,9324): Estimated Dose Saving
EstimatedRadiographicMagnificationFactor | (0018,1114): Estimated Radiographic Magnification Factor
EthicsCommitteeApprovalEffectivenessEndDate | (0012,0087): Ethics Committee Approval Effectiveness End Date
EthicsCommitteeApprovalEffectivenessStartDate | (0012,0086): Ethics Committee Approval Effectiveness Start Date
EthnicGroup | (0010,2160): Ethnic Group
EvaluationAttempt | (0014,2008): Evaluation Attempt
EvaluatorName | (0014,2006): Evaluator Name
EvaluatorNumber | (0014,2004): Evaluator Number
EvaluatorSequence | (0014,2002): Evaluator Sequence
EventCodeSequence | (0008,2135): Event Code Sequence
EventElapsedTimes | (0008,2130): Event Elapsed Time(s)
EventTimeOffset | (0008,2134): Event Time Offset
EventTimerNames | (0008,2132): Event Timer Name(s)
EventTimerSequence | (0008,2133): Event Timer Sequence
EventTypeID | (0000,1002): Event Type ID
ExaminedBodyThickness | (0010,9431): Examined Body Thickness
ExcessiveFalseNegatives | (0024,0052): Excessive False Negatives
ExcessiveFalseNegativesDataFlag | (0024,0051): Excessive False Negatives Data Flag
ExcessiveFalsePositives | (0024,0062): Excessive False Positives
ExcessiveFalsePositivesDataFlag | (0024,0061): Excessive False Positives Data Flag
ExcessiveFixationLosses | (0024,0040): Excessive Fixation Losses
ExcessiveFixationLossesDataFlag | (0024,0039): Excessive Fixation Losses Data Flag
ExcitationEnergy |
ExcitationFrequency | (0014,4024): Excitation Frequency
ExcitationPulseDuration |
ExcitationSpectralWidth |
ExcitationWavelength |
ExcitationWavelengthSequence |
ExcludedIntervalsSequence | (0018,9803): Excluded Intervals Sequence
ExclusionDuration | (0018,9805): Exclusion Duration
ExclusionStartDateTime | (0018,9804): Exclusion Start DateTime
ExclusiveComponentType | (0076,0036): Exclusive Component Type
ExecutionStatus | (2100,0020): Execution Status
ExecutionStatusInfo | (2100,0030): Execution Status Info
EXIFVersion | (0016,0020): EXIF Version
ExpectedCompletionDateTime | (0040,4011): Expected Completion DateTime
ExpectedInVivoMeasurementValueIndex | (300A,0622): Expected In-Vivo Measurement Value Index
ExpectedInVivoMeasurementValuesSequence | (300A,0621): Expected In-Vivo Measurement Values Sequence
ExpirationDateTime |
ExpiryDate | (0014,1020): Expiry Date
ExposedArea | (0040,0303): Exposed Area
Exposure | (0018,1152): Exposure
ExposureBiasValue | (0016,0024): Exposure Bias Value
ExposureControlMode | (0018,7060): Exposure Control Mode
ExposureControlModeDescription | (0018,7062): Exposure Control Mode Description
ExposureControlSensingRegionLeftVerticalEdge | (0018,9436): Exposure Control Sensing Region Left Vertical Edge
ExposureControlSensingRegionLowerHorizontalEdge | (0018,9439): Exposure Control Sensing Region Lower Horizontal Edge
ExposureControlSensingRegionRightVerticalEdge | (0018,9437): Exposure Control Sensing Region Right Vertical Edge
ExposureControlSensingRegionShape | (0018,9435): Exposure Control Sensing Region Shape
ExposureControlSensingRegionsSequence | (0018,9434): Exposure Control Sensing Regions Sequence
ExposureControlSensingRegionUpperHorizontalEdge | (0018,9438): Exposure Control Sensing Region Upper Horizontal Edge
ExposureDoseSequence | (0040,030E): Exposure Dose Sequence
ExposureIndex | (0018,1411): Exposure Index
ExposureInmAs | (0018,9332): Exposure in mAs
ExposureInuAs | (0018,1153): Exposure in µAs
ExposureMode | (0016,0042): Exposure Mode
ExposureModulationType | (0018,9323): Exposure Modulation Type
ExposureProgram | (0016,0016): Exposure Program
ExposureSequence | (3002,0030): Exposure Sequence
ExposuresOnDetectorSinceLastCalibration | (0018,7010): Exposures on Detector Since Last Calibration
ExposuresOnDetectorSinceManufactured | (0018,7011): Exposures on Detector Since Manufactured
ExposuresOnPlate | (0018,1404): Exposures on Plate
ExposureStatus | (0018,7064): Exposure Status
ExposureTime | (0018,1150): Exposure Time
ExposureTimeInms | (0018,9328): Exposure Time in ms
ExposureTimeInSeconds | (0016,0004): Exposure Time in Seconds
ExposureTimeInuS | (0018,8150): Exposure Time in µS
ExtendedCodeMeaning | (0008,0108): Extended Code Meaning
ExtendedCodeValue | (0008,0101): Extended Code Value
ExtendedDepthOfField | (0048,0012): Extended Depth of Field
ExtendedMatchingMechanisms |
ExtendedOffsetTable | (7FE0,0001): Extended Offset Table
ExtendedOffsetTableLengths | (7FE0,0002): Extended Offset Table Lengths
ExternalContourEntryPoint | (300A,0133): External Contour Entry Point
FacetSequence | (0066,0034): Facet Sequence
FailedAttributesSequence | (0074,1048): Failed Attributes Sequence
FailedSOPInstanceUIDList | (0008,0058): Failed SOP Instance UID List
FailedSOPSequence | (0008,1198): Failed SOP Sequence
FailedStudySequence |
FailureAttributes | (2200,000E): Failure Attributes
FailureReason | (0008,1197): Failure Reason
FalseNegativesEstimate | (0024,0046): False Negatives Estimate
FalseNegativesEstimateFlag | (0024,0045): False Negatives Estimate Flag
FalseNegativesQuantity | (0024,0050): False Negatives Quantity
FalsePositivesEstimate | (0024,0054): False Positives Estimate
FalsePositivesEstimateFlag | (0024,0053): False Positives Estimate Flag
FalsePositivesQuantity | (0024,0060): False Positives Quantity
FiducialDescription | (0070,030F): Fiducial Description
FiducialIdentifier | (0070,0310): Fiducial Identifier
FiducialIdentifierCodeSequence | (0070,0311): Fiducial Identifier Code Sequence
FiducialSequence | (0070,031E): Fiducial Sequence
FiducialSetSequence | (0070,031C): Fiducial Set Sequence
FiducialsPropertyCategoryCodeSequence | (0070,031F): Fiducials Property Category Code Sequence
FiducialUID | (0070,031A): Fiducial UID
FieldOfViewDescription | (0018,9433): Field of View Description
FieldOfViewDimensions | (0018,1149): Field of View Dimension(s)
FieldOfViewDimensionsInFloat | (0018,9461): Field of View Dimension(s) in Float
FieldOfViewHorizontalFlip | (0018,7034): Field of View Horizontal Flip
FieldOfViewOrigin | (0018,7030): Field of View Origin
FieldOfViewRotation | (0018,7032): Field of View Rotation
FieldOfViewSequence | (0018,9432): Field of View Sequence
FieldOfViewShape | (0018,1147): Field of View Shape
FileAccessSequence |
FileAccessURI |
FileLengthInContainer |
FileMetaInformationGroupLength | (0002,0000): File Meta Information Group Length
FileMetaInformationVersion | (0002,0001): File Meta Information Version
FilenameInContainer |
FileOffsetInContainer |
FileSetAccessSequence |
FileSetConsistencyFlag | (0004,1212): File-set Consistency Flag
FileSetDescriptorFileID | (0004,1141): File-set Descriptor File ID
FileSetID | (0004,1130): File-set ID
FileSource | (0016,003A): File Source
FillerOrderNumberImagingServiceRequest | (0040,2017): Filler Order Number / Imaging Service Request
FillerOrderNumberImagingServiceRequestRetired | (0040,2007): Filler Order Number / Imaging Service Request (Retired)
FillerOrderNumberProcedure | (0040,1007): Filler Order Number / Procedure
FillMode | (0070,0257): Fill Mode
FillPattern | (0070,0256): Fill Pattern
FillStyleSequence | (0070,0233): Fill Style Sequence
FilmBoxContentSequence | (2130,0030): Film Box Content Sequence
FilmConsumptionSequence | (0040,0321): Film Consumption Sequence
FilmDestination | (2000,0040): Film Destination
FilmOrientation | (2010,0040): Film Orientation
FilmSessionLabel | (2000,0050): Film Session Label
FilmSizeID | (2010,0050): Film Size ID
FilterBeamPathLengthMaximum | (0018,7058): Filter Beam Path Length Maximum
FilterBeamPathLengthMinimum | (0018,7056): Filter Beam Path Length Minimum
FilterByAttributePresence | (0072,0404): Filter-by Attribute Presence
FilterByCategory | (0072,0402): Filter-by Category
FilterByOperator | (0072,0406): Filter-by Operator
FilterHighFrequency | (003A,0221): Filter High Frequency
FilterHighFrequencyCharacteristicsSequence |
FilterLookupTableData |
FilterLookupTableDescription |
FilterLookupTableSequence |
FilterLowFrequency | (003A,0220): Filter Low Frequency
FilterLowFrequencyCharacteristicsSequence |
FilterMaterial | (0018,7050): Filter Material
FilterMaterialUsedInGainCalibration | (0014,3074): Filter Material Used in Gain Calibration
FilterOperationsSequence | (0072,0400): Filter Operations Sequence
FilterThicknessMaximum | (0018,7054): Filter Thickness Maximum
FilterThicknessMinimum | (0018,7052): Filter Thickness Minimum
FilterThicknessUsedInGainCalibration | (0014,3075): Filter Thickness Used in Gain Calibration
FilterType | (0018,1160): Filter Type
FinalCumulativeMetersetWeight | (300A,010E): Final Cumulative Meterset Weight
FinalCumulativeTimeWeight | (300A,02C8): Final Cumulative Time Weight
FindingsFlagTrial | (0040,A007): Findings Flag (Trial)
FindingsGroupRecordingDateTrial | (0040,A023): Findings Group Recording Date (Trial)
FindingsGroupRecordingTimeTrial | (0040,A024): Findings Group Recording Time (Trial)
FindingsGroupUIDTrial | (0040,A021): Findings Group UID (Trial)
FindingsSequenceTrial | (0040,A020): Findings Sequence (Trial)
FindingsSourceCategoryCodeSequenceTrial | (0040,A026): Findings Source Category Code Sequence (Trial)
FindLocation | (0000,0400): Find Location()
FiniteVolume | (0066,000E): Finite Volume
FirstALineLocation | (0052,0034): First A-line Location
FirstOrderPhaseCorrection | (0018,9198): First Order Phase Correction
FirstOrderPhaseCorrectionAngle | (5600,0010): First Order Phase Correction Angle
FirstTreatmentDate | (3008,0054): First Treatment Date
FixationCheckedQuantity | (0024,0035): Fixation Checked Quantity
FixationDeviceDescription | (300A,0196): Fixation Device Description
FixationDeviceLabel | (300A,0194): Fixation Device Label
FixationDevicePitchAngle | (300A,0199): Fixation Device Pitch Angle
FixationDevicePosition | (300A,0198): Fixation Device Position
FixationDeviceRollAngle | (300A,019A): Fixation Device Roll Angle
FixationDeviceSequence | (300A,0190): Fixation Device Sequence
FixationDeviceType | (300A,0192): Fixation Device Type
FixationEye | (300A,0150): Fixation Eye
FixationLightAzimuthalAngle | (300A,0356): Fixation Light Azimuthal Angle
FixationLightAzimuthalAngleTolerance | (300A,0154): Fixation Light Azimuthal Angle Tolerance
FixationLightPolarAngle | (300A,0358): Fixation Light Polar Angle
FixationLightPolarAngleTolerance | (300A,0155): Fixation Light Polar Angle Tolerance
FixationMethodCodeSequence | (0068,63AC): Fixation Method Code Sequence
FixationMonitoringCodeSequence | (0024,0033): Fixation Monitoring Code Sequence
FixationSequence | (0024,0032): Fixation Sequence
FixedRTBeamDelimiterDeviceSequence | (300A,0646): Fixed RT Beam Delimiter Device Sequence
FlashEnergy | (0016,0036): Flash Energy
FlashFiringStatus | (0016,0011): Flash Firing Status
FlashFunctionPresent | (0016,0014): Flash Function Present
FlashMode | (0016,0013): Flash Mode
FlashRedEyeMode | (0016,0015): Flash Red Eye Mode
FlashReturnStatus | (0016,0012): Flash Return Status
FlatCornealAxisSequence | (0046,0113): Flat Corneal Axis Sequence
FlatKeratometricAxisSequence | (0046,0080): Flat Keratometric Axis Sequence
FlipAngle | (0018,1314): Flip Angle
FloatingPointValue | (0040,A161): Floating Point Value
FloatingPointValues | (0066,0125): Floating Point Values
FloatPixelData | (7FE0,0008): Float Pixel Data
FloatPixelPaddingRangeLimit | (0028,0124): Float Pixel Padding Range Limit
FloatPixelPaddingValue | (0028,0122): Float Pixel Padding Value
FlowCompensation | (0018,9010): Flow Compensation
FlowCompensationDirection | (0018,9183): Flow Compensation Direction
FlowIdentifier | (0034,0002): Flow Identifier
FlowIdentifierSequence | (0034,0001): Flow Identifier Sequence
FlowRTPSamplingRate | (0034,0004): Flow RTP Sampling Rate
FlowTransferSyntaxUID | (0034,0003): Flow Transfer Syntax UID
FluenceDataScale | (3002,0042): Fluence Data Scale
FluenceDataSource | (3002,0041): Fluence Data Source
FluenceMapSequence | (3002,0040): Fluence Map Sequence
FluenceMode | (3002,0051): Fluence Mode
FluenceModeID | (3002,0052): Fluence Mode ID
FluoroscopyFlag | (0018,9334): Fluoroscopy Flag
FluoroscopyLastImageHoldPersistenceFlag | (0018,11B4): Fluoroscopy Last Image Hold Persistence Flag
FluoroscopyPersistenceFlag | (0018,11B3): Fluoroscopy Persistence Flag
FNumber | (0016,0005): F-Number
FocalDistance | (0018,1182): Focal Distance
FocalLength | (0016,0029): Focal Length
FocalLengthIn35mmFilm | (0016,0045): Focal Length In 35mm Film
FocalSpots | (0018,1190): Focal Spot(s)
FocusDepth | (0018,5012): Focus Depth
FocusMethod | (0048,0011): Focus Method
FolderAccessURI |
FontName | (0070,0227): Font Name
FontNameType | (0070,0228): Font Name Type
FovealPointNormativeDataFlag | (0024,0117): Foveal Point Normative Data Flag
FovealPointProbabilityValue | (0024,0118): Foveal Point Probability Value
FovealSensitivity | (0024,0087): Foveal Sensitivity
FovealSensitivityMeasured | (0024,0086): Foveal Sensitivity Measured
FractionalBandwidth |
FractionalChannelDisplayScale | (003A,0247): Fractional Channel Display Scale
FractionationNotes | (3010,007F): Fractionation Notes
FractionBasedRelationshipIntervalAnchor | (3010,0083): Fraction-Based Relationship Interval Anchor
FractionBasedRelationshipSequence | (3010,0082): Fraction-Based Relationship Sequence
FractionGroupDescription | (300A,0072): Fraction Group Description
FractionGroupNumber | (300A,0071): Fraction Group Number
FractionGroupSequence | (300A,0070): Fraction Group Sequence
FractionGroupSummarySequence | (3008,0220): Fraction Group Summary Sequence
FractionGroupType | (3008,0224): Fraction Group Type
FractionNumber | (3002,0029): Fraction Number
FractionPattern | (300A,007B): Fraction Pattern
FractionPatternSequence | (3010,0079): Fraction Pattern Sequence
FractionStatusSummarySequence | (3008,0240): Fraction Status Summary Sequence
FrameAcquisitionDateTime | (0018,9074): Frame Acquisition DateTime
FrameAcquisitionDuration | (0018,9220): Frame Acquisition Duration
FrameAcquisitionNumber | (0020,9156): Frame Acquisition Number
FrameAcquisitionSequence | (0018,9417): Frame Acquisition Sequence
FrameAnatomySequence | (0020,9071): Frame Anatomy Sequence
FrameComments | (0020,9158): Frame Comments
FrameContentSequence | (0020,9111): Frame Content Sequence
FrameDelay | (0018,1066): Frame Delay
FrameDetectorParametersSequence | (0018,9451): Frame Detector Parameters Sequence
FrameDimensionPointer | (0028,000A): Frame Dimension Pointer
FrameDisplaySequence | (0008,9458): Frame Display Sequence
FrameDisplayShutterSequence | (0018,9472): Frame Display Shutter Sequence
FrameExtractionSequence | (0008,1164): Frame Extraction Sequence
FrameIncrementPointer | (0028,0009): Frame Increment Pointer
FrameLabel | (0020,9453): Frame Label
FrameLabelVector | (0018,2002): Frame Label Vector
FrameLaterality | (0020,9072): Frame Laterality
FrameNumbersOfInterest | (0028,6020): Frame Numbers of Interest (FOI)
FrameOfInterestDescription | (0028,6022): Frame of Interest Description
FrameOfInterestType | (0028,6023): Frame of Interest Type
FrameOfReferenceRelationshipSequence | (3006,00C0): Frame of Reference Relationship Sequence
FrameOfReferenceToDisplayedCoordinateSystemTransformationMatrix | (0070,030B): Frame of Reference to Displayed Coordinate System Transformation Matrix
FrameOfReferenceTransformationComment | (3006,00C8): Frame of Reference Transformation Comment
FrameOfReferenceTransformationMatrix | (3006,00C6): Frame of Reference Transformation Matrix
FrameOfReferenceTransformationMatrixType | (0070,030C): Frame of Reference Transformation Matrix Type
FrameOfReferenceTransformationType | (3006,00C4): Frame of Reference Transformation Type
FrameOfReferenceUID | (0020,0052): Frame of Reference UID
FrameOriginTimestamp | (0034,0007): Frame Origin Timestamp
FramePixelDataPropertiesSequence | (0028,9443): Frame Pixel Data Properties Sequence
FramePixelShiftSequence | (0028,9415): Frame Pixel Shift Sequence
FramePrimaryAngleVector | (0018,2003): Frame Primary Angle Vector
FrameReferenceDateTime | (0018,9151): Frame Reference DateTime
FrameReferenceTime | (0054,1300): Frame Reference Time
FrameSecondaryAngleVector | (0018,2004): Frame Secondary Angle Vector
FrameTime | (0018,1063): Frame Time
FrameTimeVector | (0018,1065): Frame Time Vector
FrameType | (0008,9007): Frame Type
FrameUsefulnessGroupSequence | (0034,0009): Frame Usefulness Group Sequence
FrameVOILUTSequence | (0028,9132): Frame VOI LUT Sequence
FrequencyCorrection | (0018,9101): Frequency Correction
FrequencyEncodingCodeSequence |
FunctionalGroupPointer | (0020,9167): Functional Group Pointer
FunctionalGroupPrivateCreator | (0020,9238): Functional Group Private Creator
FunctionalMRSequence | (0018,9621): Functional MR Sequence
FunctionalSettlingPhaseFramesPresent | (0018,9622): Functional Settling Phase Frames Present
FunctionalSyncPulse | (0018,9623): Functional Sync Pulse
GainControl | (0016,0047): Gain Control
GainCorrectionReferenceSequence | (0014,3060): Gain Correction Reference Sequence
GammaValue | (0028,701A): Gamma Value
GantryAngle | (300A,011E): Gantry Angle
GantryAngleTolerance | (300A,0044): Gantry Angle Tolerance
GantryDetectorSlew | (0018,1121): Gantry/Detector Slew
GantryDetectorTilt | (0018,1120): Gantry/Detector Tilt
GantryID | (0018,1008): Gantry ID
GantryMotionCorrected | (0018,9762): Gantry Motion Corrected
GantryPitchAngle | (300A,014A): Gantry Pitch Angle
GantryPitchAngleTolerance | (300A,014E): Gantry Pitch Angle Tolerance
GantryPitchRotationDirection | (300A,014C): Gantry Pitch Rotation Direction
GantryRotationDirection | (300A,011F): Gantry Rotation Direction
GantryType | (4010,1008): Gantry Type
GapLength | (0070,0261): Gap Length
GatedInformationSequence | (0054,0062): Gated Information Sequence
GateSettingsSequence | (0014,4060): Gate Settings Sequence
GateThreshold | (0014,4062): Gate Threshold
GatingBeamHoldTransitionSequence |
GeneralAccessoryDefinitionSequence | (300A,0671): General Accessory Definition Sequence
GeneralAccessoryDescription | (300A,0422): General Accessory Description
GeneralAccessoryID | (300A,0421): General Accessory ID
GeneralAccessoryNumber | (300A,0424): General Accessory Number
GeneralAccessorySequence | (300A,0420): General Accessory Sequence
GeneralAccessoryType | (300A,0423): General Accessory Type
GeneralizedDefectCorrectedSensitivityDeviationFlag | (0024,0102): Generalized Defect Corrected Sensitivity Deviation Flag
GeneralizedDefectCorrectedSensitivityDeviationProbabilityValue | (0024,0104): Generalized Defect Corrected Sensitivity Deviation Probability Value
GeneralizedDefectCorrectedSensitivityDeviationValue | (0024,0103): Generalized Defect Corrected Sensitivity Deviation Value
GeneralizedDefectSensitivityDeviationAlgorithmSequence | (0024,0067): Generalized Defect Sensitivity Deviation Algorithm Sequence
GeneralMachineVerificationSequence | (0074,1042): General Machine Verification Sequence
GeneralMatchingSequence |
GeneralPurposePerformedProcedureStepStatus | (0040,4002): General Purpose Performed Procedure Step Status
GeneralPurposeScheduledProcedureStepPriority | (0040,4003): General Purpose Scheduled Procedure Step Priority
GeneralPurposeScheduledProcedureStepStatus | (0040,4001): General Purpose Scheduled Procedure Step Status
GeneratorID | (0018,1005): Generator ID
GeneratorPower | (0018,1170): Generator Power
GeneticModificationsCodeSequence | (0010,0229): Genetic Modifications Code Sequence
GeneticModificationsDescription | (0010,0222): Genetic Modifications Description
GeneticModificationsNomenclature | (0010,0223): Genetic Modifications Nomenclature
GeneticModificationsSequence | (0010,0221): Genetic Modifications Sequence
GeometricalProperties | (0028,9444): Geometrical Properties
GeometricMaximumDistortion | (0028,9445): Geometric Maximum Distortion
GeometryForDisplay | (0070,1B08): Geometry for Display
GeometryOfKSpaceTraversal | (0018,9032): Geometry of k-Space Traversal
GlobalCrop | (0070,120B): Global Crop
GlobalCroppingSpecificationIndex | (0070,120C): Global Cropping Specification Index
GlobalDeviationFromNormal | (0024,0066): Global Deviation From Normal
GlobalDeviationProbability | (0024,0071): Global Deviation Probability
GlobalDeviationProbabilityNormalsFlag | (0024,0059): Global Deviation Probability Normals Flag
GlobalDeviationProbabilitySequence | (0024,0083): Global Deviation Probability Sequence
GPSAltitude | (0016,0076): GPS Altitude
GPSAltitudeRef | (0016,0075): GPS Altitude Ref
GPSAreaInformation | (0016,008C): GPS Area Information
GPSDateStamp | (0016,008D): GPS Date Stamp
GPSDestBearing | (0016,0088): GPS Dest Bearing
GPSDestBearingRef | (0016,0087): GPS Dest Bearing Ref
GPSDestDistance | (0016,008A): GPS Dest Distance
GPSDestDistanceRef | (0016,0089): GPS Dest Distance Ref
GPSDestLatitude | (0016,0084): GPS Dest Latitude
GPSDestLatitudeRef | (0016,0083): GPS Dest Latitude Ref
GPSDestLongitude | (0016,0086): GPS Dest Longitude
GPSDestLongitudeRef | (0016,0085): GPS Dest Longitude Ref
GPSDifferential | (0016,008E): GPS Differential
GPSDOP | (0016,007B): GPS DOP
GPSImgDirection | (0016,0081): GPS Img Direction
GPSImgDirectionRef | (0016,0080): GPS Img Direction Ref
GPSLatitude | (0016,0072): GPS Latitude
GPSLatitudeRef | (0016,0071): GPS Latitude Ref
GPSLongitude | (0016,0074): GPS Longitude
GPSLongitudeRef | (0016,0073): GPS Longitude Ref
GPSMapDatum | (0016,0082): GPS Map Datum
GPSMeasureMode | (0016,007A): GPS Measure Mode
GPSProcessingMethod | (0016,008B): GPS Processing Method
GPSSatellites | (0016,0078): GPS Satellites
GPSSpeed | (0016,007D): GPS Speed
GPSSpeedRef | (0016,007C): GPS Speed Ref
GPSStatus | (0016,0079): GPS Status
GPSTimeStamp | (0016,0077): GPS Time Stamp
GPSTrack | (0016,007F): GPS Track
GPSTrackRef | (0016,007E): GPS Track Ref
GPSVersionID | (0016,0070): GPS Version ID
GradientEchoTrainLength | (0018,9241): Gradient Echo Train Length
GradientOutput | (0018,9182): Gradient Output
GradientOutputType | (0018,9180): Gradient Output Type
GraphicAnnotationSequence | (0070,0001): Graphic Annotation Sequence
GraphicAnnotationUnits | (0070,0005): Graphic Annotation Units
GraphicCoordinatesDataSequence | (0070,0318): Graphic Coordinates Data Sequence
GraphicData | (0070,0022): Graphic Data
GraphicDimensions | (0070,0020): Graphic Dimensions
GraphicFilled | (0070,0024): Graphic Filled
GraphicGroupDescription | (0070,0208): Graphic Group Description
GraphicGroupID | (0070,0295): Graphic Group ID
GraphicGroupLabel | (0070,0207): Graphic Group Label
GraphicGroupSequence | (0070,0234): Graphic Group Sequence
GraphicLayer | (0070,0002): Graphic Layer
GraphicLayerDescription | (0070,0068): Graphic Layer Description
GraphicLayerOrder | (0070,0062): Graphic Layer Order
GraphicLayerRecommendedDisplayCIELabValue | (0070,0401): Graphic Layer Recommended Display CIELab Value
GraphicLayerRecommendedDisplayGrayscaleValue | (0070,0066): Graphic Layer Recommended Display Grayscale Value
GraphicLayerRecommendedDisplayRGBValue | (0070,0067): Graphic Layer Recommended Display RGB Value
GraphicLayerSequence | (0070,0060): Graphic Layer Sequence
GraphicObjectSequence | (0070,0009): Graphic Object Sequence
GraphicType | (0070,0023): Graphic Type
GrayLookupTableData | (0028,1200): Gray Lookup Table Data()
GrayLookupTableDescriptor | (0028,1100): Gray Lookup Table Descriptor()
GrayScale | (0028,1080): Gray Scale()
GreenPaletteColorLookupTableData | (0028,1202): Green Palette Color Lookup Table Data
GreenPaletteColorLookupTableDescriptor | (0028,1102): Green Palette Color Lookup Table Descriptor
Grid | (0018,1166): Grid
GridAbsorbingMaterial | (0018,7040): Grid Absorbing Material
GridAspectRatio | (0018,7046): Grid Aspect Ratio
GridDimensions | (0064,0007): Grid Dimensions
GridFocalDistance | (0018,704C): Grid Focal Distance
GridFrameOffsetVector | (3004,000C): Grid Frame Offset Vector
GridID | (0018,1006): Grid ID
GridPeriod | (0018,7048): Grid Period
GridPitch | (0018,7044): Grid Pitch
GridResolution | (0064,0008): Grid Resolution
GridSpacingMaterial | (0018,7041): Grid Spacing Material
GridThickness | (0018,7042): Grid Thickness
GroupOfPatientsIdentificationSequence | (0010,0027): Group of Patients Identification Sequence
HalfValueLayer | (0040,0314): Half Value Layer
HangingProtocolCreationDateTime | (0072,000A): Hanging Protocol Creation DateTime
HangingProtocolCreator | (0072,0008): Hanging Protocol Creator
HangingProtocolDefinitionSequence | (0072,000C): Hanging Protocol Definition Sequence
HangingProtocolDescription | (0072,0004): Hanging Protocol Description
HangingProtocolLevel | (0072,0006): Hanging Protocol Level
HangingProtocolName | (0072,0002): Hanging Protocol Name
HangingProtocolUserGroupName | (0072,0010): Hanging Protocol User Group Name
HangingProtocolUserIdentificationCodeSequence | (0072,000E): Hanging Protocol User Identification Code Sequence
HardcopyCreationDeviceID | (0018,1011): Hardcopy Creation Device ID
HardcopyDeviceManufacturer | (0018,1017): Hardcopy Device Manufacturer
HardcopyDeviceManufacturerModelName | (0018,101B): Hardcopy Device Manufacturer's Model Name
HardcopyDeviceSoftwareVersion | (0018,101A): Hardcopy Device Software Version
HeadFixationAngle | (300A,0148): Head Fixation Angle
HeadFixationAngleTolerance | (300A,0152): Head Fixation Angle Tolerance
HeartRate | (0018,1088): Heart Rate
HighBit | (0028,0102): High Bit
HighDoseTechniqueType | (300A,00C7): High-Dose Technique Type
HighEnergyDetectors | (4010,0002): High Energy Detectors
HighRRValue | (0018,1082): High R-R Value
HistogramBinWidth | (0060,3008): Histogram Bin Width
HistogramData | (0060,3020): Histogram Data
HistogramExplanation | (0060,3010): Histogram Explanation
HistogramFirstBinValue | (0060,3004): Histogram First Bin Value
HistogramLastBinValue | (0060,3006): Histogram Last Bin Value
HistogramNumberOfBins | (0060,3002): Histogram Number of Bins
HistogramSequence | (0060,3000): Histogram Sequence
HL7DocumentEffectiveTime | (0040,E004): HL7 Document Effective Time
HL7DocumentTypeCodeSequence | (0040,E006): HL7 Document Type Code Sequence
HL7InstanceIdentifier | (0040,E001): HL7 Instance Identifier
HL7StructuredDocumentReferenceSequence | (0040,A390): HL7 Structured Document Reference Sequence
HomeCommunityID | (0040,E031): Home Community ID
HorizontalAlignment | (0070,0242): Horizontal Alignment
HorizontalFieldOfView | (0022,000C): Horizontal Field of View
HorizontalOffsetOfSensor | (0014,3024): Horizontal Offset of Sensor
HorizontalPrismBase | (0046,0032): Horizontal Prism Base
HorizontalPrismPower | (0046,0030): Horizontal Prism Power
HPGLContourPenNumber | (0068,6310): HPGL Contour Pen Number
HPGLDocument | (0068,6300): HPGL Document
HPGLDocumentID | (0068,62D0): HPGL Document ID
HPGLDocumentLabel | (0068,62D5): HPGL Document Label
HPGLDocumentScaling | (0068,62F2): HPGL Document Scaling
HPGLDocumentSequence | (0068,62C0): HPGL Document Sequence
HPGLPenDescription | (0068,6345): HPGL Pen Description
HPGLPenLabel | (0068,6340): HPGL Pen Label
HPGLPenNumber | (0068,6330): HPGL Pen Number
HPGLPenSequence | (0068,6320): HPGL Pen Sequence
HuffmanTableSize | (1000,xxx2): Huffman Table Size
HuffmanTableTriplet | (1000,xxx3): Huffman Table Triplet
HumanPerformerCodeSequence | (0040,4009): Human Performer Code Sequence
HumanPerformerName | (0040,4037): Human Performer's Name
HumanPerformerOrganization | (0040,4036): Human Performer's Organization
Humidity | (0016,0031): Humidity
ICCProfile | (0028,2000): ICC Profile
IconImageSequence | (0088,0200): Icon Image Sequence
IdenticalDocumentsSequence | (0040,A525): Identical Documents Sequence
IdentificationDescriptionTrial | (0040,A224): Identification Description (Trial)
IdentifierCodeSequenceTrial | (0040,A070): Identifier Code Sequence (Trial)
IdentifierTypeCode | (0040,0035): Identifier Type Code
IdentifyingComments | (0008,4000): Identifying Comments()
IdentifyingPrivateElements | (0008,0306): Identifying Private Elements
Illumination | (2010,015E): Illumination
IlluminationBandwidth | (0022,0057): Illumination Bandwidth
IlluminationColorCodeSequence | (0048,0108): Illumination Color Code Sequence
IlluminationPower | (0022,0056): Illumination Power
IlluminationTranslationFlag |
IlluminationTypeCodeSequence | (0022,0016): Illumination Type Code Sequence
IlluminationWaveLength | (0022,0055): Illumination Wave Length
IlluminatorTypeCodeSequence | (0048,0100): Illuminator Type Code Sequence
ImageAcquisitionDepth |
ImageAndFluoroscopyAreaDoseProduct | (0018,115E): Image and Fluoroscopy Area Dose Product
ImageBoxContentSequence | (2130,0040): Image Box Content Sequence
ImageBoxesSequence | (0072,0300): Image Boxes Sequence
ImageBoxLargeScrollAmount | (0072,0318): Image Box Large Scroll Amount
ImageBoxLargeScrollType | (0072,0316): Image Box Large Scroll Type
ImageBoxLayoutType | (0072,0304): Image Box Layout Type
ImageBoxNumber | (0072,0302): Image Box Number
ImageBoxOverlapPriority | (0072,0320): Image Box Overlap Priority
ImageBoxPosition | (2020,0010): Image Box Position
ImageBoxPresentationLUTFlag | (2000,006A): Image Box Presentation LUT Flag
ImageBoxScrollDirection | (0072,0310): Image Box Scroll Direction
ImageBoxSmallScrollAmount | (0072,0314): Image Box Small Scroll Amount
ImageBoxSmallScrollType | (0072,0312): Image Box Small Scroll Type
ImageBoxSynchronizationSequence | (0072,0430): Image Box Synchronization Sequence
ImageBoxTileHorizontalDimension | (0072,0306): Image Box Tile Horizontal Dimension
ImageBoxTileVerticalDimension | (0072,0308): Image Box Tile Vertical Dimension
ImageCenterPointCoordinatesSequence | (0040,071A): Image Center Point Coordinates Sequence
ImageComments | (0020,4000): Image Comments
ImageDataLocation | (0028,08x8): Image Data Location
ImageDataTypeCodeSequence |
ImageDataTypeSequence | (0018,9807): Image Data Type Sequence
ImageDimensions | (0028,0005): Image Dimensions()
ImageDisplayFormat | (2010,0010): Image Display Format
ImagedNucleus | (0018,0085): Imaged Nucleus
ImagedVolumeDepth | (0048,0003): Imaged Volume Depth
ImagedVolumeHeight | (0048,0002): Imaged Volume Height
ImagedVolumeWidth | (0048,0001): Imaged Volume Width
ImageFilter | (0018,9320): Image Filter
ImageFilterDescription | (0018,9941): Image Filter Description
ImageFilterDetailsSequence | (0018,11BF): Image Filter Details Sequence
ImageFormat | (0028,0040): Image Format()
ImageFrameOrigin | (60xx,0051): Image Frame Origin
ImageGeometryType | (0020,0070): Image Geometry Type()
ImageHorizontalFlip | (0070,0041): Image Horizontal Flip
ImageID | (0054,0400): Image ID
ImageIndex | (0054,1330): Image Index
ImageLaterality | (0020,0062): Image Laterality
ImageLocation | (0028,0200): Image Location()
ImageOrientation | (0020,0035): Image Orientation()
ImageOrientationPatient | (0020,0037): Image Orientation (Patient)
ImageOrientationSlide | (0048,0102): Image Orientation (Slide)
ImageOrientationVolume | (0020,9302): Image Orientation (Volume)
ImageOverlayBoxContentSequence | (2130,0060): Image Overlay Box Content Sequence
ImageOverlayFlag | (2000,0067): Image Overlay Flag
ImagePathFilterPassBand | (0022,0004): Image Path Filter Pass Band
ImagePathFilterPassThroughWavelength | (0022,0003): Image Path Filter Pass-Through Wavelength
ImagePathFilterTypeStackCodeSequence | (0022,0018): Image Path Filter Type Stack Code Sequence
ImagePlanePixelSpacing | (3002,0011): Image Plane Pixel Spacing
ImagePosition | (0020,0030): Image Position()
ImagePositionPatient | (0020,0032): Image Position (Patient)
ImagePositionVolume | (0020,9301): Image Position (Volume)
ImagePresentationComments | (0028,4000): Image Presentation Comments()
ImageProcessingApplied | (0028,9446): Image Processing Applied
ImageQualityIndicatorMaterial | (0014,40A1): Image Quality Indicator Material
ImageQualityIndicatorSize | (0014,40A2): Image Quality Indicator Size
ImageQualityIndicatorType | (0014,40A0): Image Quality Indicator Type
ImageReceptorPositionSequence |
ImageRotation | (0070,0042): Image Rotation
ImageRotationRetired | (0070,0040): Image Rotation (Retired)
ImagerPixelSpacing | (0018,1164): Imager Pixel Spacing
ImageScaleRepresentation | (4010,1075): Image Scale Representation
ImageSetLabel | (0072,0040): Image Set Label
ImageSetNumber | (0072,0032): Image Set Number
ImageSetSelectorCategory | (0072,0034): Image Set Selector Category
ImageSetSelectorSequence | (0072,0022): Image Set Selector Sequence
ImageSetSelectorUsageFlag | (0072,0024): Image Set Selector Usage Flag
ImageSetsSequence | (0072,0020): Image Sets Sequence
ImagesInAcquisition | (0020,1002): Images in Acquisition
ImagesInSeries | (0020,1003): Images in Series
ImagesInStudy | (0020,1005): Images in Study
ImageToEquipmentMappingMatrix | (0028,9520): Image to Equipment Mapping Matrix
ImageTransformationMatrix | (0018,5210): Image Transformation Matrix
ImageTranslationVector | (0018,5212): Image Translation Vector
ImageTriggerDelay | (0018,1067): Image Trigger Delay
ImageType | (0008,0008): Image Type
ImageVolumeGeometry | (0070,1208): Image Volume Geometry
ImagingApertureSequence |
ImagingApertureSpecificationType |
ImagingDeviceLocationMatrixSequence |
ImagingDeviceLocationParameterSequence |
ImagingDeviceSpecificAcquisitionParameters | (300A,00CC): Imaging Device-Specific Acquisition Parameters
ImagingFrequency | (0018,0084): Imaging Frequency
ImagingServiceRequestComments | (0040,2400): Imaging Service Request Comments
ImagingSourceLocationSpecificationType |
ImagingSourcePositionSequence |
ImagingSourceToBeamModifierDefinitionPlaneDistance |
ImmersionMedia | (0016,1004): Immersion Media
ImpedanceMeasurementCurrentType | (003A,0316): Impedance Measurement Current Type
ImpedanceMeasurementDateTime | (003A,0314): Impedance Measurement DateTime
ImpedanceMeasurementFrequency | (003A,0315): Impedance Measurement Frequency
ImpedanceValue | (003A,0313): Impedance Value
ImplantAssemblyTemplateIssuer | (0076,0003): Implant Assembly Template Issuer
ImplantAssemblyTemplateName | (0076,0001): Implant Assembly Template Name
ImplantAssemblyTemplateTargetAnatomySequence | (0076,0010): Implant Assembly Template Target Anatomy Sequence
ImplantAssemblyTemplateType | (0076,000A): Implant Assembly Template Type
ImplantAssemblyTemplateVersion | (0076,0006): Implant Assembly Template Version
ImplantName | (0022,1095): Implant Name
ImplantPartNumber | (0022,1097): Implant Part Number
ImplantRegulatoryDisapprovalCodeSequence | (0068,62A0): Implant Regulatory Disapproval Code Sequence
ImplantSize | (0068,6210): Implant Size
ImplantTargetAnatomySequence | (0068,6230): Implant Target Anatomy Sequence
ImplantTemplate3DModelSurfaceNumber | (0068,6350): Implant Template 3D Model Surface Number
ImplantTemplateGroupDescription | (0078,0010): Implant Template Group Description
ImplantTemplateGroupIssuer | (0078,0020): Implant Template Group Issuer
ImplantTemplateGroupMemberID | (0078,002E): Implant Template Group Member ID
ImplantTemplateGroupMemberMatching2DCoordinatesSequence | (0078,0070): Implant Template Group Member Matching 2D Coordinates Sequence
ImplantTemplateGroupMembersSequence | (0078,002A): Implant Template Group Members Sequence
ImplantTemplateGroupName | (0078,0001): Implant Template Group Name
ImplantTemplateGroupTargetAnatomySequence | (0078,0028): Implant Template Group Target Anatomy Sequence
ImplantTemplateGroupVariationDimensionName | (0078,00B2): Implant Template Group Variation Dimension Name
ImplantTemplateGroupVariationDimensionRank | (0078,00B8): Implant Template Group Variation Dimension Rank
ImplantTemplateGroupVariationDimensionRankSequence | (0078,00B4): Implant Template Group Variation Dimension Rank Sequence
ImplantTemplateGroupVariationDimensionSequence | (0078,00B0): Implant Template Group Variation Dimension Sequence
ImplantTemplateGroupVersion | (0078,0024): Implant Template Group Version
ImplantTemplateVersion | (0068,6221): Implant Template Version
ImplantType | (0068,6223): Implant Type
ImplantTypeCodeSequence | (0068,63A8): Implant Type Code Sequence
ImplementationClassUID | (0002,0012): Implementation Class UID
ImplementationVersionName | (0002,0013): Implementation Version Name
Impressions | (4008,0300): Impressions
InboundArrivalType | (4010,1056): Inbound Arrival Type
IncidentAngle | (0014,4052): Incident Angle
IncludeDisplayApplication | (2200,0009): Include Display Application
IncludeNonDICOMObjects | (2200,0008): Include Non-DICOM Objects
IncludesImagingSubject | (0034,0008): Includes Imaging Subject
IncludesInformation | (0034,000C): Includes Information
InConcatenationNumber | (0020,9162): In-concatenation Number
InConcatenationTotalNumber | (0020,9163): In-concatenation Total Number
IncorporatedInventoryInstanceSequence |
IndexNormalsFlag | (0024,0338): Index Normals Flag
IndexProbability | (0024,0341): Index Probability
IndexProbabilitySequence | (0024,0344): Index Probability Sequence
IndicationDescription | (0014,2018): Indication Description
IndicationDisposition | (0014,201C): Indication Disposition
IndicationLabel | (0014,2016): Indication Label
IndicationNumber | (0014,2014): Indication Number
IndicationPhysicalPropertySequence | (0014,2030): Indication Physical Property Sequence
IndicationROISequence | (0014,201E): Indication ROI Sequence
IndicationSequence | (0014,2012): Indication Sequence
IndicationType | (0014,201A): Indication Type
InformationFromManufacturerSequence | (0068,6260): Information From Manufacturer Sequence
InformationIssueDateTime | (0068,6270): Information Issue DateTime
InformationSummary | (0068,6280): Information Summary
InitialCineRunState | (0018,0042): Initial Cine Run State
Initiator | (0000,0200): Initiator()
InnerDiameter | (0014,0056): Inner Diameter
InPlanePhaseEncodingDirection | (0018,1312): In-plane Phase Encoding Direction
InputAvailabilityFlag | (0040,4020): Input Availability Flag
InputInformationSequence | (0040,4021): Input Information Sequence
InputReadinessState | (0040,4041): Input Readiness State
InputSequencePositionIndex | (0070,1203): Input Sequence Position Index
InspectionSelectionCriteria | (4010,107C): Inspection Selection Criteria
InStackPositionNumber | (0020,9057): In-Stack Position Number
InstanceAvailability | (0008,0056): Instance Availability
InstanceCoercionDateTime | (0008,0015): Instance Coercion DateTime
InstanceCreationDate | (0008,0012): Instance Creation Date
InstanceCreationTime | (0008,0013): Instance Creation Time
InstanceCreatorUID | (0008,0014): Instance Creator UID
InstanceLevelReferencedPerformedProcedureStepSequence | (3010,0044): Instance-Level Referenced Performed Procedure Step Sequence
InstanceNumber | (0020,0013): Instance Number
InstanceOriginStatus | (0400,0600): Instance Origin Status
InstitutionAddress | (0008,0081): Institution Address
InstitutionalDepartmentName | (0008,1040): Institutional Department Name
InstitutionalDepartmentTypeCodeSequence | (0008,1041): Institutional Department Type Code Sequence
InstitutionCodeSequence | (0008,0082): Institution Code Sequence
InstitutionName | (0008,0080): Institution Name
InstructionDescription | (0018,9917): Instruction Description
InstructionIndex | (0018,9915): Instruction Index
InstructionPerformanceComment | (0018,991A): Instruction Performance Comment
InstructionPerformedDateTime | (0018,9919): Instruction Performed DateTime
InstructionPerformedFlag | (0018,9918): Instruction Performed Flag
InstructionSequence | (0018,9914): Instruction Sequence
InstructionText | (0018,9916): Instruction Text
InsurancePlanIdentification | (0010,1050): Insurance Plan Identification()
IntendedDeliveryDuration | (3010,007E): Intended Delivery Duration
IntendedFractionStartTime | (3010,0085): Intended Fraction Start Time
IntendedNumberOfFractions | (300A,0636): Intended Number of Fractions
IntendedPhaseEndDate | (3010,004D): Intended Phase End Date
IntendedPhaseStartDate | (3010,004C): Intended Phase Start Date
IntendedRecipientsOfResultsIdentificationSequence | (0040,1011): Intended Recipients of Results Identification Sequence
IntendedRTTreatmentPhaseSequence | (3010,004B): Intended RT Treatment Phase Sequence
IntendedStartDayOfWeek | (3010,0086): Intended Start Day of Week
IntensifierActiveDimensions | (0018,9428): Intensifier Active Dimension(s)
IntensifierActiveShape | (0018,9427): Intensifier Active Shape
IntensifierSize | (0018,1162): Intensifier Size
InterlockCodeSequence | (300A,0744): Interlock Code Sequence
InterlockDateTime | (300A,0741): Interlock DateTime
InterlockDescription | (300A,0742): Interlock Description
InterlockOriginatingDeviceSequence | (300A,0743): Interlock Originating Device Sequence
InterlockOriginDescription | (300A,0783): Interlock Origin Description
InterlockResolutionCodeSequence | (300A,0745): Interlock Resolution Code Sequence
InterlockResolutionUserSequence | (300A,0746): Interlock Resolution User Sequence
InterlockSequence | (300A,0740): Interlock Sequence
InterMarkerDistance | (0050,0019): Inter-Marker Distance
IntermediatePupillaryDistance | (0046,0063): Intermediate Pupillary Distance
InternalDetectorFrameTime | (0014,3011): Internal Detector Frame Time
InternationalRouteSegment | (4010,1028): International Route Segment
InteroperabilityIndex | (0016,0061): Interoperability Index
InteroperabilityVersion | (0016,0062): Interoperability Version
InterpolationType | (0052,0039): Interpolation Type
InterpretationApprovalDate | (4008,0112): Interpretation Approval Date
InterpretationApprovalTime | (4008,0113): Interpretation Approval Time
InterpretationApproverSequence | (4008,0111): Interpretation Approver Sequence
InterpretationAuthor | (4008,010C): Interpretation Author
InterpretationDiagnosisCodeSequence | (4008,0117): Interpretation Diagnosis Code Sequence
InterpretationDiagnosisDescription | (4008,0115): Interpretation Diagnosis Description
InterpretationID | (4008,0200): Interpretation ID
InterpretationIDIssuer | (4008,0202): Interpretation ID Issuer
InterpretationRecordedDate | (4008,0100): Interpretation Recorded Date
InterpretationRecordedTime | (4008,0101): Interpretation Recorded Time
InterpretationRecorder | (4008,0102): Interpretation Recorder
InterpretationStatusID | (4008,0212): Interpretation Status ID
InterpretationText | (4008,010B): Interpretation Text
InterpretationTranscriber | (4008,010A): Interpretation Transcriber
InterpretationTranscriptionDate | (4008,0108): Interpretation Transcription Date
InterpretationTranscriptionTime | (4008,0109): Interpretation Transcription Time
InterpretationTypeID | (4008,0210): Interpretation Type ID
IntervalNumber | (0020,0016): Interval Number
IntervalsAcquired | (0018,1083): Intervals Acquired
IntervalsRejected | (0018,1084): Intervals Rejected
InterventionDescription | (0018,003A): Intervention Description
InterventionDrugCodeSequence | (0018,0029): Intervention Drug Code Sequence
InterventionDrugDose | (0018,0028): Intervention Drug Dose
InterventionDrugInformationSequence | (0018,0026): Intervention Drug Information Sequence
InterventionDrugName | (0018,0034): Intervention Drug Name
InterventionDrugStartTime | (0018,0035): Intervention Drug Start Time
InterventionDrugStopTime | (0018,0027): Intervention Drug Stop Time
InterventionSequence | (0018,0036): Intervention Sequence
InterventionStatus | (0018,0038): Intervention Status
IntraocularLensCalculationsLeftEyeSequence | (0022,1310): Intraocular Lens Calculations Left Eye Sequence
IntraocularLensCalculationsRightEyeSequence | (0022,1300): Intraocular Lens Calculations Right Eye Sequence
IntraOcularPressure | (0022,000B): Intra Ocular Pressure
IntravascularFrameContentSequence | (0052,0027): Intravascular Frame Content Sequence
IntravascularLongitudinalDistance | (0052,0028): Intravascular Longitudinal Distance
IntravascularOCTFrameContentSequence | (0052,0029): Intravascular OCT Frame Content Sequence
IntravascularOCTFrameTypeSequence | (0052,0025): Intravascular OCT Frame Type Sequence
InventoriedInstancesSequence |
InventoriedSeriesSequence |
InventoriedStudiesSequence |
InventoryAccessEndPointsSequence |
InventoryCompletionStatus |
InventoryInstanceDescription |
InventoryLevel |
InventoryPurpose |
InversionRecovery | (0018,9009): Inversion Recovery
InversionTime | (0018,0082): Inversion Time
InversionTimes | (0018,9079): Inversion Times
IOLFormulaCodeSequence | (0022,1028): IOL Formula Code Sequence
IOLFormulaDetail | (0022,1029): IOL Formula Detail
IOLManufacturer | (0022,1093): IOL Manufacturer
IOLPower | (0022,1053): IOL Power
IOLPowerForExactEmmetropia | (0022,1121): IOL Power For Exact Emmetropia
IOLPowerForExactTargetRefraction | (0022,1122): IOL Power For Exact Target Refraction
IOLPowerSequence | (0022,1090): IOL Power Sequence
IonBeamLimitingDeviceSequence | (300A,03A4): Ion Beam Limiting Device Sequence
IonBeamSequence | (300A,03A2): Ion Beam Sequence
IonBlockSequence | (300A,03A6): Ion Block Sequence
IonControlPointDeliverySequence | (3008,0041): Ion Control Point Delivery Sequence
IonControlPointSequence | (300A,03A8): Ion Control Point Sequence
IonControlPointVerificationSequence | (0074,104E): Ion Control Point Verification Sequence
IonMachineVerificationSequence | (0074,1046): Ion Machine Verification Sequence
IonRangeCompensatorSequence | (300A,02EA): Ion Range Compensator Sequence
IonToleranceTableSequence | (300A,03A0): Ion Tolerance Table Sequence
IonWedgePositionSequence | (300A,03AC): Ion Wedge Position Sequence
IonWedgeSequence | (300A,03AA): Ion Wedge Sequence
IrradiationEventIdentificationSequence | (0018,9477): Irradiation Event Identification Sequence
IrradiationEventUID | (0008,3010): Irradiation Event UID
IsocenterPosition | (300A,012C): Isocenter Position
IsocenterReferenceSystemSequence | (0018,9462): Isocenter Reference System Sequence
IsocenterToBeamLimitingDeviceDistance | (300A,00BB): Isocenter to Beam Limiting Device Distance
IsocenterToBlockTrayDistance | (300A,00F7): Isocenter to Block Tray Distance
IsocenterToCompensatorDistances | (300A,02E6): Isocenter to Compensator Distances
IsocenterToCompensatorTrayDistance | (300A,02E4): Isocenter to Compensator Tray Distance
IsocenterToGeneralAccessoryDistance | (300A,0426): Isocenter to General Accessory Distance
IsocenterToLateralSpreadingDeviceDistance | (300A,0374): Isocenter to Lateral Spreading Device Distance
IsocenterToRangeModulatorDistance | (300A,038A): Isocenter to Range Modulator Distance
IsocenterToRangeShifterDistance | (300A,0364): Isocenter to Range Shifter Distance
IsocenterToWedgeTrayDistance | (300A,00D9): Isocenter to Wedge Tray Distance
ISOSpeed | (0016,001D): ISO Speed
ISOSpeedLatitudeyyy | (0016,001E): ISO Speed Latitude yyy
ISOSpeedLatitudezzz | (0016,001F): ISO Speed Latitude zzz
IsotopeNumber | (0020,0014): Isotope Number
IssueDateOfImagingServiceRequest | (0040,2004): Issue Date of Imaging Service Request
IssuerOfAccessionNumberSequence | (0008,0051): Issuer of Accession Number Sequence
IssuerOfAdmissionID | (0038,0011): Issuer of Admission ID
IssuerOfAdmissionIDSequence | (0038,0014): Issuer of Admission ID Sequence
IssuerOfClinicalTrialProtocolID |
IssuerOfClinicalTrialSeriesID |
IssuerOfClinicalTrialSiteID |
IssuerOfClinicalTrialSubjectID |
IssuerOfClinicalTrialSubjectReadingID |
IssuerOfClinicalTrialTimePointID |
IssuerOfPatientID | (0010,0021): Issuer of Patient ID
IssuerOfPatientIDQualifiersSequence | (0010,0024): Issuer of Patient ID Qualifiers Sequence
IssuerOfServiceEpisodeID | (0038,0061): Issuer of Service Episode ID
IssuerOfServiceEpisodeIDSequence | (0038,0064): Issuer of Service Episode ID Sequence
IssuerOfTheContainerIdentifierSequence | (0040,0513): Issuer of the Container Identifier Sequence
IssuerOfTheSpecimenIdentifierSequence | (0040,0562): Issuer of the Specimen Identifier Sequence
IssueTimeOfImagingServiceRequest | (0040,2005): Issue Time of Imaging Service Request
Italic | (0070,0250): Italic
Item | (FFFE,E000): Item
ItemDelimitationItem | (FFFE,E00D): Item Delimitation Item
ItemInventoryDateTime |
ItemNumber | (0020,0019): Item Number
IterativeReconstructionMethod | (0018,9769): Iterative Reconstruction Method
ItineraryID | (4010,1051): Itinerary ID
ItineraryIDAssigningAuthority | (4010,1053): Itinerary ID Assigning Authority
ItineraryIDType | (4010,1052): Itinerary ID Type
IVUSAcquisition | (0018,3100): IVUS Acquisition
IVUSGatedRate | (0018,3102): IVUS Gated Rate
IVUSPullbackRate | (0018,3101): IVUS Pullback Rate
IVUSPullbackStartFrameNumber | (0018,3103): IVUS Pullback Start Frame Number
IVUSPullbackStopFrameNumber | (0018,3104): IVUS Pullback Stop Frame Number
KeratoconusPredictionIndex | (0046,0236): Keratoconus Prediction Index
KeratometerIndex | (0022,1033): Keratometer Index
KeratometricAxis | (0046,0077): Keratometric Axis
KeratometricPower | (0046,0076): Keratometric Power
KeratometryLeftEyeSequence | (0046,0071): Keratometry Left Eye Sequence
KeratometryMeasurementTypeCodeSequence | (0022,1096): Keratometry Measurement Type Code Sequence
KeratometryRightEyeSequence | (0046,0070): Keratometry Right Eye Sequence
KSpaceFiltering | (0018,9064): k-space Filtering
KVImagingGenerationParametersSequence |
KVP | (0018,0060): KVP
KVUsedInGainCalibration | (0014,3071): KV Used in Gain Calibration
LabelStyleSelection | (2200,0003): Label Style Selection
LabelText | (2200,0002): Label Text
LabelUsingInformationExtractedFromInstances | (2200,0001): Label Using Information Extracted From Instances
LanguageCodeSequence | (0008,0006): Language Code Sequence
LanguageCodeSequenceTrial | (0040,A744): Language Code Sequence (Trial)
LargeBluePaletteColorLookupTableData | (0028,1213): Large Blue Palette Color Lookup Table Data
LargeBluePaletteColorLookupTableDescriptor | (0028,1113): Large Blue Palette Color Lookup Table Descriptor
LargeGreenPaletteColorLookupTableData | (0028,1212): Large Green Palette Color Lookup Table Data
LargeGreenPaletteColorLookupTableDescriptor | (0028,1112): Large Green Palette Color Lookup Table Descriptor
LargePaletteColorLookupTableUID | (0028,1214): Large Palette Color Lookup Table UID
LargeRedPaletteColorLookupTableData | (0028,1211): Large Red Palette Color Lookup Table Data
LargeRedPaletteColorLookupTableDescriptor | (0028,1111): Large Red Palette Color Lookup Table Descriptor
LargestImagePixelValue | (0028,0107): Largest Image Pixel Value
LargestImagePixelValueInPlane | (0028,0111): Largest Image Pixel Value in Plane
LargestMonochromePixelValue | (0028,9099): Largest Monochrome Pixel Value
LargestPixelValueInSeries | (0028,0109): Largest Pixel Value in Series
LargestValidPixelValue | (0028,0105): Largest Valid Pixel Value()
LastMenstrualDate | (0010,21D0): Last Menstrual Date
Laterality | (0020,0060): Laterality
LateralSpreadingDeviceDescription | (300A,033A): Lateral Spreading Device Description
LateralSpreadingDeviceID | (300A,0336): Lateral Spreading Device ID
LateralSpreadingDeviceNumber | (300A,0334): Lateral Spreading Device Number
LateralSpreadingDeviceSequence | (300A,0332): Lateral Spreading Device Sequence
LateralSpreadingDeviceSetting | (300A,0372): Lateral Spreading Device Setting
LateralSpreadingDeviceSettingsSequence | (300A,0370): Lateral Spreading Device Settings Sequence
LateralSpreadingDeviceType | (300A,0338): Lateral Spreading Device Type
LateralSpreadingDeviceWaterEquivalentThickness | (300A,033C): Lateral Spreading Device Water Equivalent Thickness
LeafJawPositions | (300A,011C): Leaf/Jaw Positions
LeafPositionBoundaries | (300A,00BE): Leaf Position Boundaries
LeftImageSequence | (0022,0021): Left Image Sequence
LeftLensSequence | (0046,0015): Left Lens Sequence
LengthToEnd | (0008,0001): Length to End()
LensConstantDescription | (0022,1094): Lens Constant Description
LensConstantSequence | (0022,1092): Lens Constant Sequence
LensDescription | (0046,0012): Lens Description
LensesCodeSequence | (0022,0019): Lenses Code Sequence
LensMake | (0016,004F): Lens Make
LensModel | (0016,0050): Lens Model
LensSegmentType | (0046,0038): Lens Segment Type
LensSerialNumber | (0016,0051): Lens Serial Number
LensSpecification | (0016,004E): Lens Specification
LensStatusCodeSequence | (0022,1024): Lens Status Code Sequence
LensStatusDescription | (0022,1065): Lens Status Description
LensThickness | (0022,1130): Lens Thickness
LensThicknessSequence | (0022,1127): Lens Thickness Sequence
LesionNumber | (0018,3105): Lesion Number
LightDirection | (0070,1703): Light Direction
LightPathFilterPassBand | (0022,0002): Light Path Filter Pass Band
LightPathFilterPassThroughWavelength | (0022,0001): Light Path Filter Pass-Through Wavelength
LightPathFilterTypeStackCodeSequence | (0022,0017): Light Path Filter Type Stack Code Sequence
LightSource | (0016,0028): Light Source
LightSourcePolarization | (0016,1001): Light Source Polarization
LINACEnergy | (0014,5002): LINAC Energy
LINACOutput | (0014,5004): LINAC Output
LinearityCorrectionTechnique | (0014,3100): Linearity Correction Technique
LineDashingStyle | (0070,0254): Line Dashing Style
LinePattern | (0070,0255): Line Pattern
LineSequence | (0066,0028): Line Sequence
LineStyleSequence | (0070,0232): Line Style Sequence
LineThickness | (0070,0253): Line Thickness
ListOfMIMETypes | (0042,0014): List of MIME Types
ListOfUIDMatchingSequence |
LocalDeviationProbabilityNormalsFlag | (0024,0072): Local Deviation Probability Normals Flag
LocalizedDeviationFromNormal | (0024,0068): Localized Deviation From Normal
LocalizedDeviationProbability | (0024,0073): Localized Deviation Probability
LocalizedDeviationProbabilitySequence | (0024,0085): Localized Deviation Probability Sequence
LocalizingCursorPosition | (0018,2043): Localizing Cursor Position
LocalNamespaceEntityID | (0040,0031): Local Namespace Entity ID
Location | (0020,0050): Location()
LocationOfMeasuredBeamDiameter | (0014,4019): Location of Measured Beam Diameter
LongCodeValue | (0008,0119): Long Code Value
LongDeviceDescription | (0050,0021): Long Device Description
LongEdgePointIndexList | (0066,0042): Long Edge Point Index List
LongitudinalTemporalEventType | (0012,0053): Longitudinal Temporal Event Type
LongitudinalTemporalInformationModified | (0028,0303): Longitudinal Temporal Information Modified
LongitudinalTemporalOffsetFromEvent | (0012,0052): Longitudinal Temporal Offset from Event
LongPrimitivePointIndexList | (0066,0040): Long Primitive Point Index List
LongTrianglePointIndexList | (0066,0041): Long Triangle Point Index List
LongVertexPointIndexList | (0066,0043): Long Vertex Point Index List
LossyImageCompression | (0028,2110): Lossy Image Compression
LossyImageCompressionMethod | (0028,2114): Lossy Image Compression Method
LossyImageCompressionRatio | (0028,2112): Lossy Image Compression Ratio
LossyImageCompressionRetired | (0008,2110): Lossy Image Compression (Retired)
LowEnergyDetectors | (4010,0001): Low Energy Detectors
LowerCutoffFrequency |
LowRRValue | (0018,1081): Low R-R Value
LuminanceCharacteristicsID | (0028,7009): Luminance Characteristics ID
LuminanceResponseDescription | (0028,7020): Luminance Response Description
LuminanceResponseSequence | (0028,701C): Luminance Response Sequence
LuminanceResultSequence | (0028,7024): Luminance Result Sequence
LuminanceUniformityResultSequence | (0028,7027): Luminance Uniformity Result Sequence
LuminanceValue | (0028,701F): Luminance Value
LUTData | (0028,3006): LUT Data
LUTDescriptor | (0028,3002): LUT Descriptor
LUTExplanation | (0028,3003): LUT Explanation
LUTFrameRange | (0028,9507): LUT Frame Range
LUTFunction | (0028,9474): LUT Function
LUTLabel | (0040,9210): LUT Label
LUTNumber | (0020,0026): LUT Number
MAC | (0400,0404): MAC
MACAlgorithm | (0400,0015): MAC Algorithm
MACCalculationTransferSyntaxUID | (0400,0010): MAC Calculation Transfer Syntax UID
MachineSpecificTreatmentTerminationCodeSequence | (300A,0716): Machine-Specific Treatment Termination Code Sequence
MACIDNumber | (0400,0005): MAC ID Number
MACParametersSequence | (4FFE,0001): MAC Parameters Sequence
MagneticFieldStrength | (0018,0087): Magnetic Field Strength
MagnetizationTransfer | (0018,9020): Magnetization Transfer
MagnificationType | (2010,0060): Magnification Type
MagnifyToNumberOfColumns | (2040,0074): Magnify to Number of Columns
MagnitudeEncodingCodeSequence |
MainLobeAngle | (0014,5103): Main Lobe Angle
MainRoofAngle | (0014,5104): Main Roof Angle
MajorTicksSequence | (0070,0287): Major Ticks Sequence
MakerNote | (0016,002B): Maker Note
MandatoryComponentType | (0076,0038): Mandatory Component Type
Manifold | (0066,0010): Manifold
ManipulatedImage | (0028,0050): Manipulated Image()
Manufacturer | (0008,0070): Manufacturer
ManufacturerDeviceClassUID | (0018,100B): Manufacturer's Device Class UID
ManufacturerDeviceIdentifier | (3010,0043): Manufacturer's Device Identifier
ManufacturerModelName | (0008,1090): Manufacturer's Model Name
ManufacturerModelVersion | (3010,001A): Manufacturer's Model Version
ManufacturerRelatedModelGroup | (0008,0222): Manufacturer's Related Model Group
MappedPixelValue | (0022,1452): Mapped Pixel Value
MappingResource | (0008,0105): Mapping Resource
MappingResourceIdentificationSequence | (0008,0124): Mapping Resource Identification Sequence
MappingResourceName | (0008,0122): Mapping Resource Name
MappingResourceUID | (0008,0118): Mapping Resource UID
MaskFrameNumbers | (0028,6110): Mask Frame Numbers
MaskingImage | (0020,0080): Masking Image()
MaskOperation | (0028,6101): Mask Operation
MaskOperationExplanation | (0028,6190): Mask Operation Explanation
MaskPointers | (0028,6030): Mask Pointer(s)
MaskSelectionMode | (0028,9454): Mask Selection Mode
MaskSubPixelShift | (0028,6114): Mask Sub-pixel Shift
MaskSubtractionSequence | (0028,6100): Mask Subtraction Sequence
MaskVisibilityPercentage | (0028,9478): Mask Visibility Percentage
Mass | (4010,1017): Mass
MaterialAttenuationSequence | (0018,9382): Material Attenuation Sequence
MaterialCodeSequence | (0018,937D): Material Code Sequence
MaterialGrade | (0014,0042): Material Grade
MaterialID | (300A,00E1): Material ID
MaterialIsolationDiameter | (0014,0034): Material Isolation Diameter
MaterialNotes | (0014,0046): Material Notes
MaterialPipeDiameter | (0014,0032): Material Pipe Diameter
MaterialPropertiesDescription | (0014,0044): Material Properties Description
MaterialPropertiesFileFormatRetired | (0014,0045): Material Properties File Format (Retired)
MaterialsCodeSequence | (0068,63A0): Materials Code Sequence
MaterialThickness | (0014,0030): Material Thickness
MatingFeatureDegreeOfFreedomSequence | (0068,6400): Mating Feature Degree of Freedom Sequence
MatingFeatureID | (0068,63F0): Mating Feature ID
MatingFeatureSequence | (0068,63E0): Mating Feature Sequence
MatingFeatureSetID | (0068,63C0): Mating Feature Set ID
MatingFeatureSetLabel | (0068,63D0): Mating Feature Set Label
MatingFeatureSetsSequence | (0068,63B0): Mating Feature Sets Sequence
MatrixRegistrationSequence | (0070,0309): Matrix Registration Sequence
MatrixSequence | (0070,030A): Matrix Sequence
MAUsedInGainCalibration | (0014,3072): MA Used in Gain Calibration
MaxApertureValue | (0016,0025): Max Aperture Value
MaxDensity | (2010,0130): Max Density
MaximumAcrossScanDistortion | (0022,0049): Maximum Across-scan Distortion
MaximumAlongScanDistortion | (0022,0038): Maximum Along-scan Distortion
MaximumCollatedFilms | (2010,0154): Maximum Collated Films
MaximumCoordinateValue | (50xx,0105): Maximum Coordinate Value
MaximumCornealCurvature | (0046,0212): Maximum Corneal Curvature
MaximumCornealCurvatureLocation | (0046,0213): Maximum Corneal Curvature Location
MaximumCornealCurvatureSequence | (0046,0211): Maximum Corneal Curvature Sequence
MaximumCumulativeMetersetExposure |
MaximumDepthDistortion | (0022,0036): Maximum Depth Distortion
MaximumFractionalValue | (0062,000E): Maximum Fractional Value
MaximumMemoryAllocation | (2000,0061): Maximum Memory Allocation
MaximumNominalEnergy | (300A,0682): Maximum Nominal Energy
MaximumNumberOfIntervalDays | (3010,0051): Maximum Number of Interval Days
MaximumNumberOfRecords |
MaximumPointDistance | (0066,0019): Maximum Point Distance
MaximumStimulusLuminance | (0024,0018): Maximum Stimulus Luminance
MaximumStoredValueMapped | (0028,1232): Maximum Stored Value Mapped
MeanPointDistance | (0066,0018): Mean Point Distance
MeasuredAPDimension | (0010,1023): Measured AP Dimension
MeasuredBandwidth | (0014,401C): Measured Bandwidth
MeasuredBeamDimensionA | (0014,4017): Measured Beam Dimension A
MeasuredBeamDimensionB | (0014,4018): Measured Beam Dimension B
MeasuredCenterFrequency | (0014,401B): Measured Center Frequency
MeasuredCharacteristics | (0028,7026): Measured Characteristics
MeasuredDoseDescription | (3008,0012): Measured Dose Description
MeasuredDoseReferenceNumber | (3008,0064): Measured Dose Reference Number
MeasuredDoseReferenceSequence | (3008,0010): Measured Dose Reference Sequence
MeasuredDoseType | (3008,0014): Measured Dose Type
MeasuredDoseValue | (3008,0016): Measured Dose Value
MeasuredLateralDimension | (0010,1024): Measured Lateral Dimension
MeasuredMetersetToDoseMappingSequence | (300A,0772): Measured Meterset to Dose Mapping Sequence
MeasuredValueSequence | (0040,A300): Measured Value Sequence
MeasurementAutomationTrial | (0040,A194): Measurement Automation (Trial)
MeasurementEquipmentSequence | (0028,7012): Measurement Equipment Sequence
MeasurementEquipmentType | (0028,7014): Measurement Equipment Type
MeasurementFunctions | (0028,7013): Measurement Functions
MeasurementLaterality | (0024,0113): Measurement Laterality
MeasurementPatternCodeSequence | (0028,702D): Measurement Pattern Code Sequence
MeasurementPrecisionDescriptionTrial | (0040,A047): Measurement Precision Description (Trial)
MeasurementsSequence | (0066,0121): Measurements Sequence
MeasurementUnitsCodeSequence | (0040,08EA): Measurement Units Code Sequence
MeasurementValuesSequence | (0066,0132): Measurement Values Sequence
MeasuringUnitsSequence | (0040,0295): Measuring Units Sequence
MechanicalIndex | (0018,5022): Mechanical Index
MediaDisposition | (2200,0004): Media Disposition
MediaInstalledSequence | (2000,00A2): Media Installed Sequence
MediaStorageSOPClassUID | (0002,0002): Media Storage SOP Class UID
MediaStorageSOPInstanceUID | (0002,0003): Media Storage SOP Instance UID
MedicalAlerts | (0010,2000): Medical Alerts
MedicalRecordLocator | (0010,1090): Medical Record Locator
MediumType | (2000,0030): Medium Type
MemoryAllocation | (2000,0060): Memory Allocation
MemoryBitDepth | (2000,00A0): Memory Bit Depth
MessageID | (0000,0110): Message ID
MessageIDBeingRespondedTo | (0000,0120): Message ID Being Responded To
MessageSetID | (0000,5010): Message Set ID()
MetaboliteMapCodeSequence | (0018,9083): Metabolite Map Code Sequence
MetaboliteMapDescription | (0018,9080): Metabolite Map Description
MetadataSequence |
MeteringMode | (0016,0027): Metering Mode
MetersetExposure | (3002,0032): Meterset Exposure
MetersetRate | (300A,035A): Meterset Rate
MetersetRateDelivered | (3008,0046): Meterset Rate Delivered
MetersetRateSet | (3008,0045): Meterset Rate Set
MetersetToDoseMappingSequence | (300A,0620): Meterset to Dose Mapping Sequence
MidSlabPosition | (0018,9106): Mid Slab Position
MilitaryRank | (0010,1080): Military Rank
MIMETypeOfEncapsulatedDocument | (0042,0012): MIME Type of Encapsulated Document
MinDensity | (2010,0120): Min Density
MinimumCoordinateValue | (50xx,0104): Minimum Coordinate Value
MinimumHoursBetweenFractions | (3010,0084): Minimum Hours between Fractions
MinimumKeratometricSequence | (0046,0215): Minimum Keratometric Sequence
MinimumNominalEnergy | (300A,0681): Minimum Nominal Energy
MinimumNumberOfIntervalDays | (3010,0050): Minimum Number of Interval Days
MinimumSensitivityValue | (0024,0105): Minimum Sensitivity Value
MinimumStoredValueMapped | (0028,1231): Minimum Stored Value Mapped
ModalitiesInStudy | (0008,0061): Modalities in Study
Modality | (0008,0060): Modality
ModalityLUTSequence | (0028,3000): Modality LUT Sequence
ModalityLUTType | (0028,3004): Modality LUT Type
ModelGroupUID | (0068,7004): Model Group UID
ModelMirroring | (0068,7002): Model Mirroring
ModelModification | (0068,7001): Model Modification
ModelSpecificationSequence | (0018,9912): Model Specification Sequence
ModelUsageCodeSequence | (0068,7003): Model Usage Code Sequence
ModeOfPercutaneousAccessSequence | (0052,0016): Mode of Percutaneous Access Sequence
ModifiableConstraintFlag | (0082,0038): Modifiable Constraint Flag
ModifiedAttributesSequence | (0400,0550): Modified Attributes Sequence
ModifiedImageDate | (0020,3403): Modified Image Date()
ModifiedImageDescription | (0020,3406): Modified Image Description()
ModifiedImageID | (0020,3402): Modified Image ID()
ModifiedImageTime | (0020,3405): Modified Image Time()
ModifierCodeSequence | (0040,A195): Modifier Code Sequence
ModifyingDeviceID | (0020,3401): Modifying Device ID()
ModifyingDeviceManufacturer | (0020,3404): Modifying Device Manufacturer()
ModifyingSystem | (0400,0563): Modifying System
ModulatedScanModeType | (300A,0309): Modulated Scan Mode Type
ModulationType | (0014,4026): Modulation Type
MonoenergeticEnergyEquivalent | (0018,937C): Monoenergetic Energy Equivalent
MostRecentTreatmentDate | (3008,0056): Most Recent Treatment Date
MotionSynchronizationSequence | (300A,0410): Motion Synchronization Sequence
MoveDestination | (0000,0600): Move Destination
MoveOriginatorApplicationEntityTitle | (0000,1030): Move Originator Application Entity Title
MoveOriginatorMessageID | (0000,1031): Move Originator Message ID
MPRSlabThickness | (0070,1503): MPR Slab Thickness
MPRThicknessType | (0070,1502): MPR Thickness Type
MPRTopLeftHandCorner | (0070,1505): MPR Top Left Hand Corner
MPRViewHeight | (0070,1512): MPR View Height
MPRViewHeightDirection | (0070,1511): MPR View Height Direction
MPRViewWidth | (0070,1508): MPR View Width
MPRViewWidthDirection | (0070,1507): MPR View Width Direction
MRAcquisitionFrequencyEncodingSteps | (0018,9058): MR Acquisition Frequency Encoding Steps
MRAcquisitionPhaseEncodingStepsInPlane | (0018,9231): MR Acquisition Phase Encoding Steps in-plane
MRAcquisitionPhaseEncodingStepsOutOfPlane | (0018,9232): MR Acquisition Phase Encoding Steps out-of-plane
MRAcquisitionType | (0018,0023): MR Acquisition Type
MRArterialSpinLabelingSequence | (0018,9251): MR Arterial Spin Labeling Sequence
MRAveragesSequence | (0018,9119): MR Averages Sequence
MRDiffusionSequence | (0018,9117): MR Diffusion Sequence
MRDRDirectoryRecordOffset | (0004,1504): MRDR Directory Record Offset
MREchoSequence | (0018,9114): MR Echo Sequence
MRFOVGeometrySequence | (0018,9125): MR FOV/Geometry Sequence
MRImageFrameTypeSequence | (0018,9226): MR Image Frame Type Sequence
MRImagingModifierSequence | (0018,9006): MR Imaging Modifier Sequence
MRMetaboliteMapSequence | (0018,9152): MR Metabolite Map Sequence
MRModifierSequence | (0018,9115): MR Modifier Sequence
MRReceiveCoilSequence | (0018,9042): MR Receive Coil Sequence
MRSpatialSaturationSequence | (0018,9107): MR Spatial Saturation Sequence
MRSpectroscopyAcquisitionType | (0018,9200): MR Spectroscopy Acquisition Type
MRSpectroscopyFOVGeometrySequence | (0018,9103): MR Spectroscopy FOV/Geometry Sequence
MRSpectroscopyFrameTypeSequence | (0018,9227): MR Spectroscopy Frame Type Sequence
MRTimingAndRelatedParametersSequence | (0018,9112): MR Timing and Related Parameters Sequence
MRTransmitCoilSequence | (0018,9049): MR Transmit Coil Sequence
MRVelocityEncodingSequence | (0018,9197): MR Velocity Encoding Sequence
MultiCoilConfiguration | (0018,9046): Multi-Coil Configuration
MultiCoilDefinitionSequence | (0018,9045): Multi-Coil Definition Sequence
MultiCoilElementName | (0018,9047): Multi-Coil Element Name
MultiCoilElementUsed | (0018,9048): Multi-Coil Element Used
MultienergyAcquisitionDescription | (0018,937B): Multi-energy Acquisition Description
MultienergyCTAcquisition | (0018,9361): Multi-energy CT Acquisition
MultienergyCTAcquisitionSequence | (0018,9362): Multi-energy CT Acquisition Sequence
MultienergyCTCharacteristicsSequence | (0018,9364): Multi-energy CT Characteristics Sequence
MultienergyCTPathIndex | (0018,937A): Multi-energy CT Path Index
MultienergyCTPathSequence | (0018,9379): Multi-energy CT Path Sequence
MultienergyCTProcessingSequence | (0018,9363): Multi-energy CT Processing Sequence
MultienergyCTXRayDetectorSequence | (0018,936F): Multi-energy CT X-Ray Detector Sequence
MultienergyCTXRaySourceSequence | (0018,9365): Multi-energy CT X-Ray Source Sequence
MultienergyDetectorType | (0018,9372): Multi-energy Detector Type
MultienergySourceTechnique | (0018,9368): Multi-energy Source Technique
MultiFramePresentationSequence | (0028,9505): Multi-frame Presentation Sequence
MultiFrameSourceSOPInstanceUID | (0008,1167): Multi-frame Source SOP Instance UID
MultiPlanarExcitation | (0018,9012): Multi-planar Excitation
MultiPlanarReconstructionStyle | (0070,1501): Multi-Planar Reconstruction Style
MultipleComponentApprovalSequence | (0014,0106): Multiple Component Approval Sequence
MultipleCopiesFlag | (0040,4006): Multiple Copies Flag
MultipleSpinEcho | (0018,9011): Multiple Spin Echo
MultiplexedAudioChannelsDescriptionCodeSequence | (003A,0300): Multiplexed Audio Channels Description Code Sequence
MultiplexGroupLabel | (003A,0020): Multiplex Group Label
MultiplexGroupTimeOffset | (0018,1068): Multiplex Group Time Offset
MultiplexGroupUID | (003A,0310): Multiplex Group UID
MVImagingGenerationParametersSequence |
MydriaticAgentCodeSequence | (0022,001C): Mydriatic Agent Code Sequence
MydriaticAgentConcentration | (0022,004E): Mydriatic Agent Concentration
MydriaticAgentConcentrationUnitsSequence | (0022,0042): Mydriatic Agent Concentration Units Sequence
MydriaticAgentSequence | (0022,0058): Mydriatic Agent Sequence
NameOfPhysiciansReadingStudy | (0008,1060): Name of Physician(s) Reading Study
NamesOfIntendedRecipientsOfResults | (0040,1010): Names of Intended Recipients of Results
NavigationDisplaySet | (0072,0216): Navigation Display Set
NavigationIndicatorSequence | (0072,0214): Navigation Indicator Sequence
NearPupillaryDistance | (0046,0062): Near Pupillary Distance
NegativeCatchTrialsQuantity | (0024,0048): Negative Catch Trials Quantity
NetworkID | (0008,1000): Network ID()
NominalBeamAngle | (0014,5112): Nominal Beam Angle
NominalBeamEnergy | (300A,0114): Nominal Beam Energy
NominalBeamEnergyUnit | (300A,0015): Nominal Beam Energy Unit
NominalCardiacTriggerDelayTime | (0020,9153): Nominal Cardiac Trigger Delay Time
NominalCardiacTriggerTimePriorToRPeak | (0020,9154): Nominal Cardiac Trigger Time Prior To R-Peak
NominalEnergy | (300A,0680): Nominal Energy
NominalFrequency | (0014,401A): Nominal Frequency
NominalInterval | (0018,1062): Nominal Interval
NominalMaxEnergy | (0018,9374): Nominal Max Energy
NominalMinEnergy | (0018,9375): Nominal Min Energy
NominalPercentageOfCardiacPhase | (0020,9241): Nominal Percentage of Cardiac Phase
NominalPercentageOfRespiratoryPhase | (0020,9245): Nominal Percentage of Respiratory Phase
NominalPriorDose | (300A,001A): Nominal Prior Dose
NominalRangeModulatedRegionDepths | (300A,0504): Nominal Range Modulated Region Depths
NominalRangeModulationFractions | (300A,0503): Nominal Range Modulation Fractions
NominalRespiratoryTriggerDelayTime | (0020,9255): Nominal Respiratory Trigger Delay Time
NominalScannedPixelSpacing | (0018,2010): Nominal Scanned Pixel Spacing
NominalScreenDefinitionSequence | (0072,0102): Nominal Screen Definition Sequence
NonconformingDataElementValue | (0400,0552): Nonconforming Data Element Value
NonconformingModifiedAttributesSequence | (0400,0551): Nonconforming Modified Attributes Sequence
NonDICOMOutputCodeSequence | (0040,4032): Non-DICOM Output Code Sequence
NonidentifyingPrivateElements | (0008,0304): Nonidentifying Private Elements
NonUniformRadialSamplingCorrected | (0018,9766): Non-uniform Radial Sampling Corrected
NormalizationFactorFormat | (0028,0710): Normalization Factor Format
NormalizationPoint | (3004,0008): Normalization Point
NormalReverse | (0000,5140): Normal/Reverse()
NotchFilterBandwidth | (003A,0223): Notch Filter Bandwidth
NotchFilterCharacteristicsSequence |
NotchFilterFrequency | (003A,0222): Notch Filter Frequency
NotificationFromManufacturerSequence | (0068,6265): Notification From Manufacturer Sequence
NTPSourceAddress | (0018,1803): NTP Source Address
NuclearMedicineSeriesType | (0008,0042): Nuclear Medicine Series Type
NumberOfAcquisitionDevices |
NumberOfAlarmObjects | (4010,1034): Number of Alarm Objects
NumberOfAnnotations | (006A,000C): Number of Annotations
NumberOfAssessmentObservations | (0082,0006): Number of Assessment Observations
NumberOfAverages | (0018,0083): Number of Averages
NumberOfBeams | (300A,0080): Number of Beams
NumberOfBlocks | (300A,00F0): Number of Blocks
NumberOfBlockSlabItems | (300A,0440): Number of Block Slab Items
NumberOfBoli | (300A,00ED): Number of Boli
NumberOfBoluses | (300A,0674): Number of Boluses
NumberOfBrachyApplicationSetups | (300A,00A0): Number of Brachy Application Setups
NumberOfBscansPerFrame | (0022,1642): Number of B-scans Per Frame
NumberOfChannels | (50xx,2004): Number of Channels
NumberOfCompensators | (300A,00E0): Number of Compensators
NumberOfCompletedSuboperations | (0000,1021): Number of Completed Sub-operations
NumberOfContourPoints | (3006,0046): Number of Contour Points
NumberOfControlPoints | (300A,0110): Number of Control Points
NumberOfCopies | (2000,0010): Number of Copies
NumberOfDetectors | (0054,0021): Number of Detectors
NumberOfDisplaySubsystems | (0028,7001): Number of Display Subsystems
NumberOfElements | (0014,4012): Number of Elements
NumberOfEnergyWindows | (0054,0011): Number of Energy Windows
NumberOfEventTimers | (0008,2129): Number of Event Timers
NumberOfFailedSuboperations | (0000,1022): Number of Failed Sub-operations
NumberOfFilms | (2100,0170): Number of Films
NumberOfFocalPlanes | (0048,0013): Number of Focal Planes
NumberOfFractionPatternDigitsPerDay | (300A,0079): Number of Fraction Pattern Digits Per Day
NumberOfFractions | (3010,007D): Number of Fractions
NumberOfFractionsDelivered | (3008,005A): Number of Fractions Delivered
NumberOfFractionsIncluded |
NumberOfFractionsPlanned | (300A,0078): Number of Fractions Planned
NumberOfFrames | (0028,0008): Number of Frames
NumberOfFramesInOverlay | (60xx,0015): Number of Frames in Overlay
NumberOfFramesInPhase | (0054,0033): Number of Frames in Phase
NumberOfFramesInRotation | (0054,0053): Number of Frames in Rotation
NumberOfFramesIntegrated | (0014,3012): Number of Frames Integrated
NumberOfFramesUsedForIntegration | (0014,3073): Number of Frames Used for Integration
NumberOfGeneralAccessories | (300A,0672): Number of General Accessories
NumberOfGraphicPoints | (0070,0021): Number of Graphic Points
NumberOfHorizontalPixels | (0072,0106): Number of Horizontal Pixels
NumberOfIntervalFractions | (3010,007C): Number of Interval Fractions
NumberOfIterations | (0018,9739): Number of Iterations
NumberOfKSpaceTrajectories | (0018,9093): Number of k-Space Trajectories
NumberOfLateralSpreadingDevices | (300A,0330): Number of Lateral Spreading Devices
NumberOfLeafJawPairs | (300A,00BC): Number of Leaf/Jaw Pairs
NumberOfLuminancePoints | (0028,701B): Number of Luminance Points
NumberOfMapPoints | (0022,1530): Number of Map Points
NumberOfMatches | (0000,0850): Number of Matches()
NumberOfOpticalPaths | (0048,0302): Number of Optical Paths
NumberOfPaddedALines | (0052,0038): Number of Padded A-lines
NumberOfPaintings | (300A,039A): Number of Paintings
NumberOfParallelRTBeamDelimiters | (300A,0648): Number of Parallel RT Beam Delimiters
NumberOfPatientRelatedInstances | (0020,1204): Number of Patient Related Instances
NumberOfPatientRelatedSeries | (0020,1202): Number of Patient Related Series
NumberOfPatientRelatedStudies | (0020,1200): Number of Patient Related Studies
NumberOfPatientSupportDevices | (300A,0687): Number of Patient Support Devices
NumberOfPhaseEncodingSteps | (0018,0089): Number of Phase Encoding Steps
NumberOfPhases | (0054,0031): Number of Phases
NumberOfPoints | (50xx,0010): Number of Points
NumberOfPolygonalVertices | (0018,1637): Number of Polygonal Vertices
NumberOfPriorsReferenced | (0072,0014): Number of Priors Referenced
NumberOfPulses | (300A,028A): Number of Pulses
NumberOfRadiationGenerationModes | (300A,0685): Number of Radiation GenerationModes
NumberOfRangeModulators | (300A,0340): Number of Range Modulators
NumberOfRangeShifters | (300A,0312): Number of Range Shifters
NumberOfReferences | (0004,1600): Number of References
NumberOfRemainingSuboperations | (0000,1020): Number of Remaining Sub-operations
NumberOfRotations | (0054,0051): Number of Rotations
NumberOfRRIntervals | (0054,0061): Number of R-R Intervals
NumberOfRTAccessoryHolders | (300A,0670): Number of RT Accessory Holders
NumberOfRTBeamLimitingDeviceOpenings | (300A,0657): Number of RT Beam Limiting Device Openings
NumberOfRTBeamLimitingDevices | (300A,0641): Number of RT Beam Limiting Devices
NumberOfRTControlPoints | (300A,0604): Number of RT Control Points
NumberOfSamples | (50xx,2006): Number of Samples
NumberOfScanSpotPositions | (300A,0392): Number of Scan Spot Positions
NumberOfScreens | (0072,0100): Number of Screens
NumberOfSeriesRelatedInstances | (0020,1209): Number of Series Related Instances
NumberOfSlices | (0054,0081): Number of Slices
NumberOfStages | (0008,2124): Number of Stages
NumberOfStudyRecordsInInstance |
NumberOfStudyRelatedInstances | (0020,1208): Number of Study Related Instances
NumberOfStudyRelatedSeries | (0020,1206): Number of Study Related Series
NumberOfSubsets | (0018,9740): Number of Subsets
NumberOfSurfacePoints | (0066,0015): Number of Surface Points
NumberOfSurfaces | (0066,0001): Number of Surfaces
NumberOfTableBreakPoints | (0018,6050): Number of Table Break Points
NumberOfTableColumns |
NumberOfTableEntries | (0018,6056): Number of Table Entries
NumberOfTableRows | (0040,A802): Number of Table Rows
NumberOfTables | (0028,08x2): Number of Tables
NumberOfTemporalPositions | (0020,0105): Number of Temporal Positions
NumberOfTimeSlices | (0054,0101): Number of Time Slices
NumberOfTimeSlots | (0054,0071): Number of Time Slots
NumberOfTomosynthesisSourceImages | (0018,1495): Number of Tomosynthesis Source Images
NumberOfTotalObjects | (4010,1033): Number of Total Objects
NumberOfTransformSteps | (0028,0402): Number of Transform Steps
NumberOfTriggersInPhase | (0054,0211): Number of Triggers in Phase
NumberOfVectors | (0066,001E): Number of Vectors
NumberOfVerticalPixels | (0072,0104): Number of Vertical Pixels
NumberOfViewsInStage | (0008,212A): Number of Views in Stage
NumberOfVisualStimuli | (0024,0038): Number of Visual Stimuli
NumberOfVolumetricCurvePoints | (0070,150C): Number of Volumetric Curve Points
NumberOfWarningSuboperations | (0000,1023): Number of Warning Sub-operations
NumberOfWaveformChannels | (003A,0005): Number of Waveform Channels
NumberOfWaveformSamples | (003A,0010): Number of Waveform Samples
NumberOfWedgePositions | (300A,0655): Number of Wedge Positions
NumberOfWedges | (300A,00D0): Number of Wedges
NumberOfZeroFills | (0018,9066): Number of Zero Fills
NumericValue | (0040,A30A): Numeric Value
NumericValueQualifierCodeSequence | (0040,A301): Numeric Value Qualifier Code Sequence
ObjectBinaryIdentifierTrial | (0040,A074): Object Binary Identifier (Trial)
ObjectDirectoryBinaryIdentifierTrial | (0040,A089): Object Directory Binary Identifier (Trial)
ObjectiveLensNumericalAperture | (0048,0113): Objective Lens Numerical Aperture
ObjectiveLensPower | (0048,0112): Objective Lens Power
ObjectPixelSpacingInCenterOfBeam | (0018,9404): Object Pixel Spacing in Center of Beam
ObjectSoundSpeed |
ObjectThicknessSequence | (0018,9456): Object Thickness Sequence
ObliqueCroppingPlaneSequence | (0070,1304): Oblique Cropping Plane Sequence
ObservationBasisCodeSequence | (0082,0022): Observation Basis Code Sequence
ObservationCategoryCodeSequenceTrial | (0040,A167): Observation Category Code Sequence (Trial)
ObservationDateTime | (0040,A032): Observation DateTime
ObservationDateTrial | (0040,A192): Observation Date (Trial)
ObservationDescription | (0082,000A): Observation Description
ObservationNumber | (3006,0082): Observation Number
ObservationSignificance | (0082,0008): Observation Significance
ObservationStartDateTime | (0040,A033): Observation Start DateTime
ObservationSubjectClassTrial | (0040,A403): Observation Subject Class (Trial)
ObservationSubjectContextFlagTrial | (0040,A600): Observation Subject Context Flag (Trial)
ObservationSubjectTypeCodeSequenceTrial | (0040,A404): Observation Subject Type Code Sequence (Trial)
ObservationSubjectUIDTrial | (0040,A402): Observation Subject UID (Trial)
ObservationTimeTrial | (0040,A193): Observation Time (Trial)
ObservationUID | (0040,A171): Observation UID
ObserverContextFlagTrial | (0040,A601): Observer Context Flag (Trial)
ObserverType | (0040,A084): Observer Type
Occupation | (0010,2180): Occupation
OCTAcquisitionDomain | (0052,0006): OCT Acquisition Domain
OCTBscanAnalysisAcquisitionParametersSequence | (0022,1640): OCT B-scan Analysis Acquisition Parameters Sequence
OCTFocalDistance | (0052,0002): OCT Focal Distance
OCTOpticalCenterWavelength | (0052,0007): OCT Optical Center Wavelength
OCTZOffsetApplied | (0052,0026): OCT Z Offset Applied
OCTZOffsetCorrection | (0052,0030): OCT Z Offset Correction
OECFColumnNames | (0016,0008): OECF Column Names
OECFColumns | (0016,0007): OECF Columns
OECFRows | (0016,0006): OECF Rows
OECFValues | (0016,0009): OECF Values
OffendingElement | (0000,0901): Offending Element
OffsetDirection | (0018,9905): Offset Direction
OffsetDistance | (0018,9904): Offset Distance
OffsetOfReferencedLowerLevelDirectoryEntity | (0004,1420): Offset of Referenced Lower-Level Directory Entity
OffsetOfTheFirstDirectoryRecordOfTheRootDirectoryEntity | (0004,1200): Offset of the First Directory Record of the Root Directory Entity
OffsetOfTheLastDirectoryRecordOfTheRootDirectoryEntity | (0004,1202): Offset of the Last Directory Record of the Root Directory Entity
OffsetOfTheNextDirectoryRecord | (0004,1400): Offset of the Next Directory Record
OmittedApplicationSetupSequence | (0074,140E): Omitted Application Setup Sequence
OmittedBeamTaskSequence | (300C,0111): Omitted Beam Task Sequence
OmittedChannelSequence | (0074,1409): Omitted Channel Sequence
OmittedRadiationSequence | (300A,0787): Omitted Radiation Sequence
OnAxisBackgroundAnatomicStructureCodeSequenceTrial | (0008,225C): On Axis Background Anatomic Structure Code Sequence (Trial)
OOIOwnerCreationTime | (4010,1041): OOI Owner Creation Time
OOIOwnerSequence | (4010,1047): OOI Owner Sequence
OOIOwnerType | (4010,1009): OOI Owner Type
OOISize | (4010,1043): OOI Size
OOIType | (4010,1042): OOI Type
OOITypeDescriptor | (4010,1068): OOI Type Descriptor
OperatingMode | (0018,9178): Operating Mode
OperatingModeSequence | (0018,9176): Operating Mode Sequence
OperatingModeType | (0018,9177): Operating Mode Type
OperatorIdentificationSequence | (0008,1072): Operator Identification Sequence
OperatorsName | (0008,1070): Operators' Name
OphthalmicAnatomicReferencePointXCoordinate | (0022,1624): Ophthalmic Anatomic Reference Point X-Coordinate
OphthalmicAnatomicReferencePointYCoordinate | (0022,1626): Ophthalmic Anatomic Reference Point Y-Coordinate
OphthalmicAxialLength | (0022,1019): Ophthalmic Axial Length
OphthalmicAxialLengthAcquisitionMethodCodeSequence | (0022,1153): Ophthalmic Axial Length Acquisition Method Code Sequence
OphthalmicAxialLengthDataSourceCodeSequence | (0022,1150): Ophthalmic Axial Length Data Source Code Sequence
OphthalmicAxialLengthDataSourceDescription | (0022,1159): Ophthalmic Axial Length Data Source Description
OphthalmicAxialLengthMeasurementModified | (0022,1140): Ophthalmic Axial Length Measurement Modified
OphthalmicAxialLengthMeasurementsLengthSummationSequence | (0022,1212): Ophthalmic Axial Length Measurements Length Summation Sequence
OphthalmicAxialLengthMeasurementsSegmentalLengthSequence | (0022,1211): Ophthalmic Axial Length Measurements Segmental Length Sequence
OphthalmicAxialLengthMeasurementsSegmentNameCodeSequence | (0022,1101): Ophthalmic Axial Length Measurements Segment Name Code Sequence
OphthalmicAxialLengthMeasurementsSequence | (0022,1050): Ophthalmic Axial Length Measurements Sequence
OphthalmicAxialLengthMeasurementsTotalLengthSequence | (0022,1210): Ophthalmic Axial Length Measurements Total Length Sequence
OphthalmicAxialLengthMeasurementsType | (0022,1010): Ophthalmic Axial Length Measurements Type
OphthalmicAxialLengthMethod | (0022,1515): Ophthalmic Axial Length Method
OphthalmicAxialLengthQualityMetricSequence | (0022,1262): Ophthalmic Axial Length Quality Metric Sequence
OphthalmicAxialLengthQualityMetricTypeCodeSequence | (0022,1265): Ophthalmic Axial Length Quality Metric Type Code Sequence()
OphthalmicAxialLengthQualityMetricTypeDescription | (0022,1273): Ophthalmic Axial Length Quality Metric Type Description
OphthalmicAxialLengthSelectionMethodCodeSequence | (0022,1250): Ophthalmic Axial Length Selection Method Code Sequence
OphthalmicAxialLengthSequence | (0022,1012): Ophthalmic Axial Length Sequence
OphthalmicAxialLengthVelocity | (0022,1059): Ophthalmic Axial Length Velocity
OphthalmicAxialMeasurementsDeviceType | (0022,1009): Ophthalmic Axial Measurements Device Type
OphthalmicAxialMeasurementsLeftEyeSequence | (0022,1008): Ophthalmic Axial Measurements Left Eye Sequence
OphthalmicAxialMeasurementsRightEyeSequence | (0022,1007): Ophthalmic Axial Measurements Right Eye Sequence
OphthalmicEnFaceImageQualityRatingSequence | (0022,1628): Ophthalmic En Face Image Quality Rating Sequence
OphthalmicFOV | (0022,1517): Ophthalmic FOV
OphthalmicFrameLocationSequence | (0022,0031): Ophthalmic Frame Location Sequence
OphthalmicImageOrientation | (0022,0039): Ophthalmic Image Orientation
OphthalmicImageTypeCodeSequence | (0022,1615): Ophthalmic Image Type Code Sequence
OphthalmicImageTypeDescription | (0022,1616): Ophthalmic Image Type Description
OphthalmicMappingDeviceType | (0022,1415): Ophthalmic Mapping Device Type
OphthalmicPatientClinicalInformationLeftEyeSequence | (0024,0114): Ophthalmic Patient Clinical Information Left Eye Sequence
OphthalmicPatientClinicalInformationRightEyeSequence | (0024,0115): Ophthalmic Patient Clinical Information Right Eye Sequence
OphthalmicThicknessMappingNormalsSequence | (0022,1443): Ophthalmic Thickness Mapping Normals Sequence
OphthalmicThicknessMapQualityRatingSequence | (0022,1470): Ophthalmic Thickness Map Quality Rating Sequence
OphthalmicThicknessMapQualityThresholdSequence | (0022,1458): Ophthalmic Thickness Map Quality Threshold Sequence
OphthalmicThicknessMapThresholdQualityRating | (0022,1460): Ophthalmic Thickness Map Threshold Quality Rating
OphthalmicThicknessMapTypeCodeSequence | (0022,1436): Ophthalmic Thickness Map Type Code Sequence
OphthalmicUltrasoundMethodCodeSequence | (0022,1044): Ophthalmic Ultrasound Method Code Sequence
OphthalmicVolumetricPropertiesFlag | (0022,1622): Ophthalmic Volumetric Properties Flag
OpticalMagnificationFactor | (0016,1005): Optical Magnification Factor
OpticalOphthalmicAxialLengthMeasurementsSequence | (0022,1225): Optical Ophthalmic Axial Length Measurements Sequence
OpticalPathDescription | (0048,0107): Optical Path Description
OpticalPathIdentificationSequence | (0048,0207): Optical Path Identification Sequence
OpticalPathIdentifier | (0048,0106): Optical Path Identifier
OpticalPathSequence | (0048,0105): Optical Path Sequence
OpticalSelectedOphthalmicAxialLengthSequence | (0022,1255): Optical Selected Ophthalmic Axial Length Sequence
OpticalTransmittance | (0046,0040): Optical Transmittance
Optotype | (0046,0094): Optotype
OptotypeDetailedDefinition | (0046,0139): Optotype Detailed Definition
OptotypePresentation | (0046,0095): Optotype Presentation
OrderCallbackPhoneNumber | (0040,2010): Order Callback Phone Number
OrderCallbackTelecomInformation | (0040,2011): Order Callback Telecom Information
OrderEnteredBy | (0040,2008): Order Entered By
OrderEntererLocation | (0040,2009): Order Enterer's Location
OrderFillerIdentifierSequence | (0040,0027): Order Filler Identifier Sequence
OrderPlacerIdentifierSequence | (0040,0026): Order Placer Identifier Sequence
OrganAtRiskFullVolumeDose | (300A,002A): Organ at Risk Full-volume Dose
OrganAtRiskLimitDose | (300A,002B): Organ at Risk Limit Dose
OrganAtRiskMaximumDose | (300A,002C): Organ at Risk Maximum Dose
OrganAtRiskOverdoseVolumeFraction | (300A,002D): Organ at Risk Overdose Volume Fraction
OrganDose | (0040,0316): Organ Dose
OrganExposed | (0040,0318): Organ Exposed
OrganizationalRoleCodeSequence | (0044,010A): Organizational Role Code Sequence
OriginalAttributesSequence | (0400,0561): Original Attributes Sequence
OriginalImageIdentification | (0020,5000): Original Image Identification()
OriginalImageIdentificationNomenclature | (0020,5002): Original Image Identification Nomenclature()
OriginalImageSequence | (2130,00C0): Original Image Sequence
OriginalImplantAssemblyTemplateSequence | (0076,000C): Original Implant Assembly Template Sequence
OriginalImplantTemplateSequence | (0068,6225): Original Implant Template Sequence
OriginalSpecializedSOPClassUID | (0008,001B): Original Specialized SOP Class UID
OriginatingSOPInstanceReferenceSequence | (3010,0007): Originating SOP Instance Reference Sequence
Originator | (2100,0070): Originator
OtherApprovalStatus | (0014,0107): Other Approval Status
OtherClinicalTrialProtocolIDsSequence |
OtherFailuresSequence | (0008,119A): Other Failures Sequence
OtherMagnificationTypesAvailable | (2010,00A7): Other Magnification Types Available
OtherMediaAvailableSequence | (2000,00A4): Other Media Available Sequence
OtherPatientIDs | (0010,1000): Other Patient IDs
OtherPatientIDsSequence | (0010,1002): Other Patient IDs Sequence
OtherPatientNames | (0010,1001): Other Patient Names
OtherPupillaryDistance | (0046,0064): Other Pupillary Distance
OtherSecondaryApprovalStatus | (0014,0108): Other Secondary Approval Status
OtherSmoothingTypesAvailable | (2010,00A9): Other Smoothing Types Available
OtherStudyNumbers | (0020,1070): Other Study Numbers
OuterDiameter | (0014,0054): Outer Diameter
OutlineLeftVerticalEdge | (0018,1631): Outline Left Vertical Edge
OutlineLowerHorizontalEdge | (0018,1634): Outline Lower Horizontal Edge
OutlineRightVerticalEdge | (0018,1632): Outline Right Vertical Edge
OutlineShapeType | (0018,1630): Outline Shape Type
OutlineUpperHorizontalEdge | (0018,1633): Outline Upper Horizontal Edge
OutputDestinationSequence | (0040,4070): Output Destination Sequence
OutputInformationSequence | (0040,4033): Output Information Sequence
OutputPower | (0018,5000): Output Power
OverallTemplateSpatialTolerance | (0068,62A5): Overall Template Spatial Tolerance
OverlayActivationLayer | (60xx,1001): Overlay Activation Layer
OverlayBackgroundDensity | (2040,0082): Overlay Background Density
OverlayBitPosition | (60xx,0102): Overlay Bit Position
OverlayBitsAllocated | (60xx,0100): Overlay Bits Allocated
OverlayBitsForCodeWord | (60xx,0804): Overlay Bits For Code Word
OverlayBitsGrouped | (60xx,0069): Overlay Bits Grouped
OverlayCodeLabel | (60xx,0800): Overlay Code Label
OverlayCodeTableLocation | (60xx,0803): Overlay Code Table Location
OverlayColumns | (60xx,0011): Overlay Columns
OverlayComments | (60xx,4000): Overlay Comments()
OverlayCompressionCode | (60xx,0060): Overlay Compression Code()
OverlayCompressionDescription | (60xx,0063): Overlay Compression Description
OverlayCompressionLabel | (60xx,0062): Overlay Compression Label
OverlayCompressionOriginator | (60xx,0061): Overlay Compression Originator
OverlayCompressionStepPointers | (60xx,0066): Overlay Compression Step Pointers
OverlayData | (60xx,3000): Overlay Data
OverlayDate | (0008,0024): Overlay Date
OverlayDescription | (60xx,0022): Overlay Description
OverlayDescriptorBlue | (60xx,1103): Overlay Descriptor - Blue
OverlayDescriptorGray | (60xx,1100): Overlay Descriptor - Gray
OverlayDescriptorGreen | (60xx,1102): Overlay Descriptor - Green
OverlayDescriptorRed | (60xx,1101): Overlay Descriptor - Red
OverlayForegroundDensity | (2040,0080): Overlay Foreground Density
OverlayFormat | (60xx,0110): Overlay Format()
OverlayLabel | (60xx,1500): Overlay Label
OverlayLocation | (60xx,0200): Overlay Location()
OverlayMagnificationType | (2040,0060): Overlay Magnification Type
OverlayMode | (2040,0090): Overlay Mode
OverlayNumber | (0020,0022): Overlay Number
OverlayNumberOfTables | (60xx,0802): Overlay Number of Tables
OverlayOrigin | (60xx,0050): Overlay Origin
OverlayOrImageMagnification | (2040,0072): Overlay or Image Magnification
OverlayPixelDataSequence | (2040,0020): Overlay Pixel Data Sequence
OverlayPlaneOrigin | (60xx,0052): Overlay Plane Origin
OverlayPlanes | (60xx,0012): Overlay Planes
OverlayRepeatInterval | (60xx,0068): Overlay Repeat Interval
OverlayRows | (60xx,0010): Overlay Rows
Overlays | (0000,51B0): Overlays()
OverlaysBlue | (60xx,1203): Overlays - Blue
OverlaysGray | (60xx,1200): Overlays - Gray
OverlaysGreen | (60xx,1202): Overlays - Green
OverlaySmoothingType | (2040,0070): Overlay Smoothing Type
OverlaysRed | (60xx,1201): Overlays - Red
OverlaySubtype | (60xx,0045): Overlay Subtype
OverlayTime | (0008,0034): Overlay Time
OverlayType | (60xx,0040): Overlay Type
OverriddenAttributesSequence | (0074,104A): Overridden Attributes Sequence
OverrideDateTime | (300A,0760): Override DateTime
OverrideParameterPointer | (3008,0062): Override Parameter Pointer
OverrideReason | (3008,0066): Override Reason
OverrideSequence | (3008,0060): Override Sequence
OversamplingPhase | (0018,9029): Oversampling Phase
OwnerID | (2100,0160): Owner ID
PaddleDescription | (0018,11A4): Paddle Description
PageNumberVector | (0018,2001): Page Number Vector
PagePositionID | (0000,5120): Page Position ID()
PaletteColorLookupTableSequence | (0048,0120): Palette Color Lookup Table Sequence
PaletteColorLookupTableUID | (0028,1199): Palette Color Lookup Table UID
ParallelAcquisition | (0018,9077): Parallel Acquisition
ParallelAcquisitionTechnique | (0018,9078): Parallel Acquisition Technique
ParallelReductionFactorInPlane | (0018,9069): Parallel Reduction Factor In-plane
ParallelReductionFactorInPlaneRetired | (0018,9096): Parallel Reduction Factor In-plane (Retired)
ParallelReductionFactorOutOfPlane | (0018,9155): Parallel Reduction Factor out-of-plane
ParallelReductionFactorSecondInPlane | (0018,9168): Parallel Reduction Factor Second In-plane
ParallelRTBeamDelimiterBoundaries | (300A,0649): Parallel RT Beam Delimiter Boundaries
ParallelRTBeamDelimiterDeviceOrientationLabelCodeSequence | (300A,0644): Parallel RT Beam Delimiter Device Orientation Label Code Sequence
ParallelRTBeamDelimiterDeviceSequence | (300A,0647): Parallel RT Beam Delimiter Device Sequence
ParallelRTBeamDelimiterLeafMountingSide | (300A,064F): Parallel RT Beam Delimiter Leaf Mounting Side
ParallelRTBeamDelimiterOpeningExtents |
ParallelRTBeamDelimiterOpeningMode | (300A,064E): Parallel RT Beam Delimiter Opening Mode
ParallelRTBeamDelimiterPositions | (300A,064A): Parallel RT Beam Delimiter Positions
ParameterItemIndex | (3008,0063): Parameter Item Index
ParameterPointer | (3008,0065): Parameter Pointer
ParameterSequencePointer | (3008,0061): Parameter Sequence Pointer
ParametersSpecificationSequence | (0018,9913): Parameters Specification Sequence
ParameterValueNumber | (3008,0067): Parameter Value Number
ParametricMapFrameTypeSequence | (0040,9092): Parametric Map Frame Type Sequence
PartialDataDisplayHandling | (0072,0208): Partial Data Display Handling
PartialFourier | (0018,9081): Partial Fourier
PartialFourierDirection | (0018,9036): Partial Fourier Direction
PartialView | (0028,1350): Partial View
PartialViewCodeSequence | (0028,1352): Partial View Code Sequence
PartialViewDescription | (0028,1351): Partial View Description
ParticipantSequence | (0040,A07A): Participant Sequence
ParticipationDateTime | (0040,A082): Participation DateTime
ParticipationType | (0040,A080): Participation Type
PatientAdditionalPosition | (300A,0184): Patient Additional Position
PatientAddress | (0010,1040): Patient's Address
PatientAge | (0010,1010): Patient's Age
PatientAlternativeCalendar | (0010,0035): Patient's Alternative Calendar
PatientBirthDate | (0010,0030): Patient's Birth Date
PatientBirthDateInAlternativeCalendar | (0010,0033): Patient's Birth Date in Alternative Calendar
PatientBirthName | (0010,1005): Patient's Birth Name
PatientBirthTime | (0010,0032): Patient's Birth Time
PatientBodyMassIndex | (0010,1022): Patient's Body Mass Index
PatientBreedCodeSequence | (0010,2293): Patient Breed Code Sequence
PatientBreedDescription | (0010,2292): Patient Breed Description
PatientClinicalTrialParticipationSequence | (0038,0502): Patient Clinical Trial Participation Sequence
PatientComments | (0010,4000): Patient Comments
PatientDeathDateInAlternativeCalendar | (0010,0034): Patient's Death Date in Alternative Calendar
PatientEquipmentRelationshipCodeSequence | (3010,0030): Patient Equipment Relationship Code Sequence
PatientEyeMovementCommandCodeSequence | (0022,0006): Patient Eye Movement Command Code Sequence
PatientEyeMovementCommanded | (0022,0005): Patient Eye Movement Commanded
PatientFrameOfReferenceSource | (0020,930C): Patient Frame of Reference Source
PatientGantryRelationshipCodeSequence | (0054,0414): Patient Gantry Relationship Code Sequence
PatientID | (0010,0020): Patient ID
PatientIdentityRemoved | (0012,0062): Patient Identity Removed
PatientInstitutionResidence | (0038,0400): Patient's Institution Residence
PatientInsurancePlanCodeSequence | (0010,0050): Patient's Insurance Plan Code Sequence
PatientLocationCoordinatesCodeSequence | (3006,00CA): Patient Location Coordinates Code Sequence
PatientLocationCoordinatesSequence | (3006,00C9): Patient Location Coordinates Sequence
PatientMotherBirthName | (0010,1060): Patient's Mother's Birth Name
PatientMotionCorrected | (0018,9763): Patient Motion Corrected
PatientName | (0010,0010): Patient's Name
PatientNotProperlyFixatedQuantity | (0024,0036): Patient Not Properly Fixated Quantity
PatientOrientation | (0020,0020): Patient Orientation
PatientOrientationCodeSequence | (0054,0410): Patient Orientation Code Sequence
PatientOrientationInFrameSequence | (0020,9450): Patient Orientation in Frame Sequence
PatientOrientationModifierCodeSequence | (0054,0412): Patient Orientation Modifier Code Sequence
PatientPhysiologicalStateCodeSequence | (0018,9772): Patient Physiological State Code Sequence
PatientPhysiologicalStateSequence | (0018,9771): Patient Physiological State Sequence
PatientPosition | (0018,5100): Patient Position
PatientPositioningInstructionSequence | (0018,991B): Patient Positioning Instruction Sequence
PatientPrimaryLanguageCodeSequence | (0010,0101): Patient's Primary Language Code Sequence
PatientPrimaryLanguageModifierCodeSequence | (0010,0102): Patient's Primary Language Modifier Code Sequence
PatientReliabilityIndicator | (0024,0069): Patient Reliability Indicator
PatientReligiousPreference | (0010,21F0): Patient's Religious Preference
PatientSetupLabel | (300A,0183): Patient Setup Label
PatientSetupNumber | (300A,0182): Patient Setup Number
PatientSetupPhotoDescription | (300A,0794): Patient Setup Photo Description
PatientSetupSequence | (300A,0180): Patient Setup Sequence
PatientSetupUID | (300A,0650): Patient Setup UID
PatientSex | (0010,0040): Patient's Sex
PatientSexNeutered | (0010,2203): Patient's Sex Neutered
PatientSize | (0010,1020): Patient's Size
PatientSizeCodeSequence | (0010,1021): Patient's Size Code Sequence
PatientSpeciesCodeSequence | (0010,2202): Patient Species Code Sequence
PatientSpeciesDescription | (0010,2201): Patient Species Description
PatientSpecificationSequence | (0018,9911): Patient Specification Sequence
PatientState | (0038,0500): Patient State
PatientSupportAccessoryCode | (300A,0354): Patient Support Accessory Code
PatientSupportAdjustedAngle | (0074,102A): Patient Support Adjusted Angle
PatientSupportAngle | (300A,0122): Patient Support Angle
PatientSupportAngleTolerance | (300A,004C): Patient Support Angle Tolerance
PatientSupportDevicesSequence | (300A,0686): Patient Support Devices Sequence
PatientSupportDisplacementSequence | (300A,079C): Patient Support Displacement Sequence
PatientSupportID | (300A,0352): Patient Support ID
PatientSupportPositionDeviceParameterSequence | (300A,065D): Patient Support Position Device Parameter Sequence
PatientSupportPositionDeviceToleranceSequence | (300A,0660): Patient Support Position Device Tolerance Sequence
PatientSupportPositionParameterOrderIndex | (300A,065F): Patient Support Position Parameter Order Index
PatientSupportPositionParameterSequence | (300A,065B): Patient Support Position Parameter Sequence
PatientSupportPositionSequence | (3006,00CB): Patient Support Position Sequence
PatientSupportPositionSpecificationMethod | (300A,065C): Patient Support Position Specification Method
PatientSupportPositionToleranceOrderIndex | (300A,0661): Patient Support Position Tolerance Order Index
PatientSupportPositionToleranceSequence | (300A,062D): Patient Support Position Tolerance Sequence
PatientSupportRotationDirection | (300A,0123): Patient Support Rotation Direction
PatientSupportType | (300A,0350): Patient Support Type
PatientTelecomInformation | (0010,2155): Patient's Telecom Information
PatientTelephoneNumbers | (0010,2154): Patient's Telephone Numbers
PatientTransportArrangements | (0040,1004): Patient Transport Arrangements
PatientTreatmentOrientationSequence | (3010,0032): Patient Treatment Orientation Sequence
PatientTreatmentPreparationDeviceSequence | (300A,078F): Patient Treatment Preparation Device Sequence
PatientTreatmentPreparationMethodCodeSequence | (300A,078D): Patient Treatment Preparation Method Code Sequence
PatientTreatmentPreparationMethodDescription | (300A,0792): Patient Treatment Preparation Method Description
PatientTreatmentPreparationProcedureCodeSequence | (300A,0791): Patient Treatment Preparation Procedure Code Sequence
PatientTreatmentPreparationProcedureIndex | (300A,0795): Patient Treatment Preparation Procedure Index
PatientTreatmentPreparationProcedureParameterDescription | (300A,078E): Patient Treatment Preparation Procedure Parameter Description
PatientTreatmentPreparationProcedureParameterSequence | (300A,0793): Patient Treatment Preparation Procedure Parameter Sequence
PatientTreatmentPreparationProcedureSequence | (300A,0790): Patient Treatment Preparation Procedure Sequence
PatientWeight | (0010,1030): Patient's Weight
PatternOffColorCIELabValue | (0070,0252): Pattern Off Color CIELab Value
PatternOffOpacity | (0070,0285): Pattern Off Opacity
PatternOnColorCIELabValue | (0070,0251): Pattern On Color CIELab Value
PatternOnOpacity | (0070,0284): Pattern On Opacity
PauseBetweenFrames | (0054,0038): Pause Between Frames
PercentPhaseFieldOfView | (0018,0094): Percent Phase Field of View
PercentSampling | (0018,0093): Percent Sampling
PerformedLocation | (0040,0243): Performed Location
PerformedProcedureCodeSequence | (0040,A372): Performed Procedure Code Sequence
PerformedProcedureStepDescription | (0040,0254): Performed Procedure Step Description
PerformedProcedureStepDiscontinuationReasonCodeSequence | (0040,0281): Performed Procedure Step Discontinuation Reason Code Sequence
PerformedProcedureStepEndDate | (0040,0250): Performed Procedure Step End Date
PerformedProcedureStepEndDateTime | (0040,4051): Performed Procedure Step End DateTime
PerformedProcedureStepEndTime | (0040,0251): Performed Procedure Step End Time
PerformedProcedureStepID | (0040,0253): Performed Procedure Step ID
PerformedProcedureStepStartDate | (0040,0244): Performed Procedure Step Start Date
PerformedProcedureStepStartDateTime | (0040,4050): Performed Procedure Step Start DateTime
PerformedProcedureStepStartTime | (0040,0245): Performed Procedure Step Start Time
PerformedProcedureStepStatus | (0040,0252): Performed Procedure Step Status
PerformedProcedureTypeDescription | (0040,0255): Performed Procedure Type Description
PerformedProcessingApplicationsCodeSequence | (0040,4007): Performed Processing Applications Code Sequence
PerformedProcessingParametersSequence | (0074,1212): Performed Processing Parameters Sequence
PerformedProtocolCodeSequence | (0040,0260): Performed Protocol Code Sequence
PerformedProtocolType | (0040,0261): Performed Protocol Type
PerformedSeriesSequence | (0040,0340): Performed Series Sequence
PerformedStationAETitle | (0040,0241): Performed Station AE Title
PerformedStationClassCodeSequence | (0040,4029): Performed Station Class Code Sequence
PerformedStationGeographicLocationCodeSequence | (0040,4030): Performed Station Geographic Location Code Sequence
PerformedStationName | (0040,0242): Performed Station Name
PerformedStationNameCodeSequence | (0040,4028): Performed Station Name Code Sequence
PerformedWorkitemCodeSequence | (0040,4019): Performed Workitem Code Sequence
PerformingPhysicianIdentificationSequence | (0008,1052): Performing Physician Identification Sequence
PerformingPhysicianName | (0008,1050): Performing Physician's Name
PerFrameFunctionalGroupsSequence | (5200,9230): Per-frame Functional Groups Sequence
PerimeterTable | (0028,0070): Perimeter Table
PerimeterValue | (0028,0071): Perimeter Value
PerProjectionAcquisitionSequence | (0018,9538): Per Projection Acquisition Sequence
PersonAddress | (0040,1102): Person's Address
PersonIdentificationCodeSequence | (0040,1101): Person Identification Code Sequence
PersonName | (0040,A123): Person Name
PersonTelecomInformation | (0040,1104): Person's Telecom Information
PersonTelephoneNumbers | (0040,1103): Person's Telephone Numbers
PertinentDocumentsSequence | (0038,0100): Pertinent Documents Sequence
PertinentOtherEvidenceSequence | (0040,A385): Pertinent Other Evidence Sequence
PertinentResourcesSequence | (0038,0101): Pertinent Resources Sequence
PertinentSOPClassesInSeries | (3010,0053): Pertinent SOP Classes in Series
PertinentSOPClassesInStudy | (3010,0052): Pertinent SOP Classes in Study
PETDetectorMotionDetailsSequence | (0018,9733): PET Detector Motion Details Sequence
PETFrameAcquisitionSequence | (0018,9732): PET Frame Acquisition Sequence
PETFrameCorrectionFactorsSequence | (0018,9736): PET Frame Correction Factors Sequence
PETFrameTypeSequence | (0018,9751): PET Frame Type Sequence
PETPositionSequence | (0018,9735): PET Position Sequence
PETReconstructionSequence | (0018,9749): PET Reconstruction Sequence
PETTableDynamicsSequence | (0018,9734): PET Table Dynamics Sequence
PhantomType | (4010,1046): Phantom Type
PhaseContrast | (0018,9014): Phase Contrast
PhaseDelay | (0054,0036): Phase Delay
PhaseDescription | (0054,0039): Phase Description
PhaseInformationSequence | (0054,0032): Phase Information Sequence
PhaseNumber | (0020,0015): Phase Number
PhaseVector | (0054,0030): Phase Vector
PhosphorType | (0018,1261): Phosphor Type
PhotoacousticExcitationCharacteristicsSequence |
PhotoacousticImageFrameTypeSequence |
PhotographicExposureIndex | (0016,0038): Photographic Exposure Index
PhotographicSensitivity | (0016,0018): Photographic Sensitivity
PhotometricInterpretation | (0028,0004): Photometric Interpretation
PhotonEnergy | (0018,9383): Photon Energy
PhototimerSetting | (0018,7065): Phototimer Setting
PhysicalDeltaX | (0018,602C): Physical Delta X
PhysicalDeltaY | (0018,602E): Physical Delta Y
PhysicalDetectorSize | (0018,9429): Physical Detector Size
PhysicalUnitsXDirection | (0018,6024): Physical Units X Direction
PhysicalUnitsYDirection | (0018,6026): Physical Units Y Direction
PhysicianApprovingInterpretation | (4008,0114): Physician Approving Interpretation
PhysiciansOfRecord | (0008,1048): Physician(s) of Record
PhysiciansOfRecordIdentificationSequence | (0008,1049): Physician(s) of Record Identification Sequence
PhysiciansReadingStudyIdentificationSequence | (0008,1062): Physician(s) Reading Study Identification Sequence
PixelAspectRatio | (0028,0034): Pixel Aspect Ratio
PixelBandwidth | (0018,0095): Pixel Bandwidth
PixelComponentDataType | (0018,604E): Pixel Component Data Type
PixelComponentMask | (0018,6046): Pixel Component Mask
PixelComponentOrganization | (0018,6044): Pixel Component Organization
PixelComponentPhysicalUnits | (0018,604C): Pixel Component Physical Units
PixelComponentRangeStart | (0018,6048): Pixel Component Range Start
PixelComponentRangeStop | (0018,604A): Pixel Component Range Stop
PixelCoordinatesSetTrial | (0040,A29A): Pixel Coordinates Set (Trial)
PixelData | (7FE0,0010): Pixel Data
PixelDataAreaOriginRelativeToFOV | (0018,7036): Pixel Data Area Origin Relative To FOV
PixelDataAreaRotationAngleRelativeToFOV | (0018,7038): Pixel Data Area Rotation Angle Relative To FOV
PixelDataProviderURL | (0028,7FE0): Pixel Data Provider URL
PixelIntensityRelationship | (0028,1040): Pixel Intensity Relationship
PixelIntensityRelationshipLUTSequence | (0028,9422): Pixel Intensity Relationship LUT Sequence
PixelIntensityRelationshipSign | (0028,1041): Pixel Intensity Relationship Sign
PixelMeasuresSequence | (0028,9110): Pixel Measures Sequence
PixelOriginInterpretation | (0048,0301): Pixel Origin Interpretation
PixelPaddingRangeLimit | (0028,0121): Pixel Padding Range Limit
PixelPaddingValue | (0028,0120): Pixel Padding Value
PixelPresentation | (0008,9205): Pixel Presentation
PixelRepresentation | (0028,0103): Pixel Representation
PixelShiftFrameRange | (0028,9506): Pixel Shift Frame Range
PixelShiftSequence | (0028,9501): Pixel Shift Sequence
PixelSpacing | (0028,0030): Pixel Spacing
PixelSpacingCalibrationDescription | (0028,0A04): Pixel Spacing Calibration Description
PixelSpacingCalibrationType | (0028,0A02): Pixel Spacing Calibration Type
PixelSpacingSequence | (0040,08D8): Pixel Spacing Sequence
PixelValueMappingCodeSequence | (0040,9098): Pixel Value Mapping Code Sequence
PixelValueMappingExplanation | (0022,1454): Pixel Value Mapping Explanation
PixelValueMappingToCodedConceptSequence | (0022,1450): Pixel Value Mapping to Coded Concept Sequence
PixelValueTransformationSequence | (0028,9145): Pixel Value Transformation Sequence
PlacerOrderNumberImagingServiceRequest | (0040,2016): Placer Order Number / Imaging Service Request
PlacerOrderNumberImagingServiceRequestRetired | (0040,2006): Placer Order Number / Imaging Service Request (Retired)
PlacerOrderNumberProcedure | (0040,1006): Placer Order Number / Procedure
PlanarConfiguration | (0028,0006): Planar Configuration
Plane | (0070,1305): Plane
PlaneIdentification | (0018,9457): Plane Identification
PlaneNormal | (0070,1306): Plane Normal
PlaneOrientationSequence | (0020,9116): Plane Orientation Sequence
PlaneOrientationVolumeSequence | (0020,930F): Plane Orientation (Volume) Sequence
PlanePositionSequence | (0020,9113): Plane Position Sequence
PlanePositionSlideSequence | (0048,021A): Plane Position (Slide) Sequence
PlanePositionVolumeSequence | (0020,930E): Plane Position (Volume) Sequence
Planes | (0028,0012): Planes
PlanesInAcquisition | (0018,9410): Planes in Acquisition
PlanIntent | (300A,000A): Plan Intent
PlannedVerificationImageSequence | (300A,00CA): Planned Verification Image Sequence
PlanningInputInformationSequence | (3010,0076): Planning Input Information Sequence
PlanningLandmarkDescription | (0068,6540): Planning Landmark Description
PlanningLandmarkID | (0068,6530): Planning Landmark ID
PlanningLandmarkIdentificationCodeSequence | (0068,6545): Planning Landmark Identification Code Sequence
PlanningLandmarkLineSequence | (0068,6510): Planning Landmark Line Sequence
PlanningLandmarkPlaneSequence | (0068,6520): Planning Landmark Plane Sequence
PlanningLandmarkPointSequence | (0068,6500): Planning Landmark Point Sequence
PlanOverviewIndex |
PlanOverviewSequence |
PlateID | (0018,1004): Plate ID
PlateType | (0018,1260): Plate Type
PointCoordinatesData | (0066,0016): Point Coordinates Data
PointPositionAccuracy | (0066,0017): Point Position Accuracy
PointsBoundingBoxCoordinates | (0066,001A): Points Bounding Box Coordinates
Polarity | (2020,0020): Polarity
PositionAcquisitionTemplateCodeSequence |
PositionAcquisitionTemplateDescription |
PositionAcquisitionTemplateID |
PositionAcquisitionTemplateIdentificationSequence |
PositionAcquisitionTemplateName |
PositionerIsocenterDetectorRotationAngle | (0018,9465): Positioner Isocenter Detector Rotation Angle
PositionerIsocenterPrimaryAngle | (0018,9463): Positioner Isocenter Primary Angle
PositionerIsocenterSecondaryAngle | (0018,9464): Positioner Isocenter Secondary Angle
PositionerMotion | (0018,1500): Positioner Motion
PositionerPositionSequence | (0018,9405): Positioner Position Sequence
PositionerPrimaryAngle | (0018,1510): Positioner Primary Angle
PositionerPrimaryAngleDirection | (0018,9559): Positioner Primary Angle Direction
PositionerPrimaryAngleIncrement | (0018,1520): Positioner Primary Angle Increment
PositionerSecondaryAngle | (0018,1511): Positioner Secondary Angle
PositionerSecondaryAngleIncrement | (0018,1521): Positioner Secondary Angle Increment
PositionerType | (0018,1508): Positioner Type
PositioningLandmarkSequence | (0018,991D): Positioning Landmark Sequence
PositioningMethodCodeSequence | (0018,991C): Positioning Method Code Sequence
PositionMeasuringDeviceUsed | (0018,980C): Position Measuring Device Used
PositionOfIsocenterProjection | (0018,9430): Position of Isocenter Projection
PositionReferenceIndicator | (0020,1040): Position Reference Indicator
PositiveCatchTrialsQuantity | (0024,0056): Positive Catch Trials Quantity
PostDeformationMatrixRegistrationSequence | (0064,0010): Post Deformation Matrix Registration Sequence
PostprocessingFunction | (0018,5021): Postprocessing Function
PotentialDiagnosticTasks | (0018,990A): Potential Diagnostic Tasks
PotentialReasonsForProcedure | (0018,9908): Potential Reasons for Procedure
PotentialReasonsForProcedureCodeSequence | (0018,9909): Potential Reasons for Procedure Code Sequence
PotentialRequestedProcedureCodeSequence | (0018,9907): Potential Requested Procedure Code Sequence
PotentialScheduledProtocolCodeSequence | (0018,9906): Potential Scheduled Protocol Code Sequence
PotentialThreatObjectID | (4010,1010): Potential Threat Object ID
PowerlineFrequency | (003A,0311): Powerline Frequency
PRCSToRCSOrientation | (4010,107E): PRCS to RCS Orientation
PreAmplifierEquipmentSequence | (0014,400E): Pre-Amplifier Equipment Sequence
PreAmplifierNotes | (0014,400F): Pre-Amplifier Notes
PreAmplifierSettingsSequence | (0014,4040): Pre-Amplifier Settings Sequence
PredecessorDocumentsSequence | (0040,A360): Predecessor Documents Sequence
PredecessorProtocolSequence | (0018,990E): Predecessor Protocol Sequence
PredecessorStructureSetSequence | (3006,0018): Predecessor Structure Set Sequence
PreDeformationMatrixRegistrationSequence | (0064,000F): Pre Deformation Matrix Registration Sequence
PredictedRefractiveError | (0022,1054): Predicted Refractive Error
PredictedToricErrorSequence | (0022,1048): Predicted Toric Error Sequence
PredictorColumns | (0028,0081): Predictor Columns
PredictorConstants | (0028,0082): Predictor Constants
PredictorRows | (0028,0080): Predictor Rows
PreferredPlaybackSequencing | (0018,1244): Preferred Playback Sequencing
PregnancyStatus | (0010,21C0): Pregnancy Status
PreliminaryFlag | (0040,A496): Preliminary Flag
PreMedication | (0040,0012): Pre-Medication
PrescriptionDescription | (300A,000E): Prescription Description
PrescriptionNotes | (3010,007B): Prescription Notes
PrescriptionNotesSequence | (3010,0081): Prescription Notes Sequence
PrescriptionOverviewSequence |
PreSelectedForImplantation | (0022,1049): Pre-Selected for Implantation
PresentationAnimationStyle | (0070,1A01): Presentation Animation Style
PresentationCreationDate | (0070,0082): Presentation Creation Date
PresentationCreationTime | (0070,0083): Presentation Creation Time
PresentationDisplayCollectionUID | (0070,1101): Presentation Display Collection UID
PresentationGroupNumber | (003A,0241): Presentation Group Number
PresentationInputType | (0070,1202): Presentation Input Type
PresentationIntentType | (0008,0068): Presentation Intent Type
PresentationLUTContentSequence | (2130,0080): Presentation LUT Content Sequence
PresentationLUTFlag | (2000,0069): Presentation LUT Flag
PresentationLUTSequence | (2050,0010): Presentation LUT Sequence
PresentationLUTShape | (2050,0020): Presentation LUT Shape
PresentationPixelAspectRatio | (0070,0102): Presentation Pixel Aspect Ratio
PresentationPixelMagnificationRatio | (0070,0103): Presentation Pixel Magnification Ratio
PresentationPixelSpacing | (0070,0101): Presentation Pixel Spacing
PresentationSequenceCollectionUID | (0070,1102): Presentation Sequence Collection UID
PresentationSequencePositionIndex | (0070,1103): Presentation Sequence Position Index
PresentationSizeMode | (0070,0100): Presentation Size Mode
PresentationStateClassificationComponentSequence | (0070,1801): Presentation State Classification Component Sequence
PresentationStateCompositorComponentSequence | (0070,1805): Presentation State Compositor Component Sequence
PresentedVisualStimuliDataFlag | (0024,0037): Presented Visual Stimuli Data Flag
PreserveCompositeInstancesAfterMediaCreation | (2200,000A): Preserve Composite Instances After Media Creation
Pressure | (0016,0032): Pressure
PrimaryAnatomicStructureModifierSequence | (0008,2230): Primary Anatomic Structure Modifier Sequence
PrimaryAnatomicStructureSequence | (0008,2228): Primary Anatomic Structure Sequence
PrimaryChromaticities | (0016,0002): Primary Chromaticities
PrimaryDoseValueIndicator | (300A,061B): Primary Dose Value Indicator
PrimaryDosimeterUnit | (300A,00B3): Primary Dosimeter Unit
PrimaryFluenceModeSequence | (3002,0050): Primary Fluence Mode Sequence
PrimaryPositionerIncrement | (0018,9514): Primary Positioner Increment
PrimaryPositionerIncrementSign | (0018,9518): Primary Positioner Increment Sign
PrimaryPositionerScanArc | (0018,9508): Primary Positioner Scan Arc
PrimaryPositionerScanStartAngle | (0018,9510): Primary Positioner Scan Start Angle
PrimaryPromptsCountsAccumulated | (0054,1310): Primary (Prompts) Counts Accumulated
PrimitivePointIndexList | (0066,0029): Primitive Point Index List
Print | (0000,51A0): Print()
PrinterCharacteristicsSequence | (2130,0015): Printer Characteristics Sequence
PrinterConfigurationSequence | (2000,001E): Printer Configuration Sequence
PrinterName | (2110,0030): Printer Name
PrinterPixelSpacing | (2010,0376): Printer Pixel Spacing
PrinterResolutionID | (2010,0052): Printer Resolution ID
PrinterStatus | (2110,0010): Printer Status
PrinterStatusInfo | (2110,0020): Printer Status Info
PrintingBitDepth | (2000,00A1): Printing Bit Depth
PrintJobDescriptionSequence | (2120,0050): Print Job Description Sequence
PrintJobID | (2100,0010): Print Job ID
PrintManagementCapabilitiesSequence | (2130,0010): Print Management Capabilities Sequence
PrintPriority | (2000,0020): Print Priority
PrintQueueID | (2110,0099): Print Queue ID
Priority | (0000,0700): Priority
PriorRecordKey |
PriorTreatmentDoseDescription | (3010,0061): Prior Treatment Dose Description
PriorTreatmentReferenceSequence | (3010,0062): Prior Treatment Reference Sequence
PrismSequence | (0046,0028): Prism Sequence
PrivateCreatorReference | (0008,0302): Private Creator Reference
PrivateDataElement | (0008,0308): Private Data Element
PrivateDataElementCharacteristicsSequence | (0008,0300): Private Data Element Characteristics Sequence
PrivateDataElementDefinitionSequence | (0008,0310): Private Data Element Definition Sequence
PrivateDataElementDescription | (0008,030E): Private Data Element Description
PrivateDataElementEncoding | (0008,030F): Private Data Element Encoding
PrivateDataElementKeyword | (0008,030D): Private Data Element Keyword
PrivateDataElementName | (0008,030C): Private Data Element Name
PrivateDataElementNumberOfItems | (0008,030B): Private Data Element Number of Items
PrivateDataElementValueMultiplicity | (0008,0309): Private Data Element Value Multiplicity
PrivateDataElementValueRepresentation | (0008,030A): Private Data Element Value Representation
PrivateGroupReference | (0008,0301): Private Group Reference
PrivateInformation | (0002,0102): Private Information
PrivateInformationCreatorUID | (0002,0100): Private Information Creator UID
PrivateRecordUID | (0004,1432): Private Record UID
ProbeCenterLocationX | (0014,4058): Probe Center Location X
ProbeCenterLocationZ | (0014,4059): Probe Center Location Z
ProbeDriveEquipmentSequence | (0014,4080): Probe Drive Equipment Sequence
ProbeDriveNotes | (0014,4082): Probe Drive Notes
ProbeDriveSettingsSequence | (0014,4087): Probe Drive Settings Sequence
ProbeInductance | (0014,4084): Probe Inductance
ProbeOrientationAngle | (0014,4089): Probe Orientation Angle
ProbeResistance | (0014,4085): Probe Resistance
ProcedureCodeSequence | (0008,1032): Procedure Code Sequence
ProcedureContextFlagTrial | (0040,A603): Procedure Context Flag (Trial)
ProcedureContextSequenceTrial | (0040,A340): Procedure Context Sequence (Trial)
ProcedureCreationDate | (0014,4076): Procedure Creation Date
ProcedureExpirationDate | (0014,4078): Procedure Expiration Date
ProcedureIdentifierCodeSequenceTrial | (0040,A085): Procedure Identifier Code Sequence (Trial)
ProcedureLastModifiedDate | (0014,407A): Procedure Last Modified Date
ProcedureStepCancellationDateTime | (0040,4052): Procedure Step Cancellation DateTime
ProcedureStepCommunicationsURISequence | (0074,1008): Procedure Step Communications URI Sequence
ProcedureStepDiscontinuationReasonCodeSequence | (0074,100E): Procedure Step Discontinuation Reason Code Sequence
ProcedureStepLabel | (0074,1204): Procedure Step Label
ProcedureStepProgress | (0074,1004): Procedure Step Progress
ProcedureStepProgressDescription | (0074,1006): Procedure Step Progress Description
ProcedureStepProgressInformationSequence | (0074,1002): Procedure Step Progress Information Sequence
ProcedureStepProgressParametersSequence | (0074,1007): Procedure Step Progress Parameters Sequence
ProcedureStepRelationshipType | (0074,1222): Procedure Step Relationship Type
ProcedureStepState | (0074,1000): Procedure Step State
ProcedureTypeCodeSequence | (0076,0020): Procedure Type Code Sequence
ProcedureVersion | (0014,4074): Procedure Version
ProcessingFunction | (0018,5020): Processing Function
ProductDescription | (0044,0009): Product Description
ProductExpirationDateTime | (0044,000B): Product Expiration DateTime
ProductLotIdentifier | (0044,000A): Product Lot Identifier
ProductName | (0044,0008): Product Name
ProductPackageIdentifier | (0044,0001): Product Package Identifier
ProductParameterSequence | (0044,0013): Product Parameter Sequence
ProductTypeCodeSequence | (0044,0007): Product Type Code Sequence
ProjectionEponymousNameCodeSequence | (0018,5104): Projection Eponymous Name Code Sequence
ProjectionImagingAcquisitionParameterSequence |
ProjectionPixelCalibrationSequence | (0018,9401): Projection Pixel Calibration Sequence
PropertyLabel | (0014,2032): Property Label
ProposedStudySequence | (2130,00A0): Proposed Study Sequence
ProtocolContextSequence | (0040,0440): Protocol Context Sequence
ProtocolDefinedPatientPosition | (0018,9947): Protocol Defined Patient Position
ProtocolDesignRationale | (0018,9910): Protocol Design Rationale
ProtocolElementCharacteristicsSummary | (0018,9923): Protocol Element Characteristics Summary
ProtocolElementName | (0018,9922): Protocol Element Name
ProtocolElementNumber | (0018,9921): Protocol Element Number
ProtocolElementPurpose | (0018,9924): Protocol Element Purpose
ProtocolName | (0018,1030): Protocol Name
ProtocolPlanningInformation | (0018,990F): Protocol Planning Information
PseudoColorPaletteInstanceReferenceSequence | (0072,0705): Pseudo-Color Palette Instance Reference Sequence
PseudoColorType | (0072,0704): Pseudo-Color Type
PTOLocationDescription | (4010,1078): PTO Location Description
PTORegionSequence | (4010,107B): PTO Region Sequence
PTORepresentationSequence | (4010,1037): PTO Representation Sequence
PulseNumber | (3008,0172): Pulse Number
PulseRepetitionFrequency | (0018,6032): Pulse Repetition Frequency
PulseRepetitionInterval | (300A,028C): Pulse Repetition Interval
PulserEquipmentSequence | (0014,4002): Pulser Equipment Sequence
PulserNotes | (0014,4006): Pulser Notes
PulserSettingsSequence | (0014,4020): Pulser Settings Sequence
PulserType | (0014,4004): Pulser Type
PulseSequenceName | (0018,9005): Pulse Sequence Name
PulseSpecificBrachyControlPointDeliveredSequence | (3008,0171): Pulse Specific Brachy Control Point Delivered Sequence
PulseWidth | (0014,4022): Pulse Width
PupilCentroidXCoordinate | (0046,0203): Pupil Centroid X-Coordinate
PupilCentroidYCoordinate | (0046,0204): Pupil Centroid Y-Coordinate
PupilDilated | (0022,000D): Pupil Dilated
PupilSize | (0046,0044): Pupil Size
PurposeOfReferenceCodeSequence | (0040,A170): Purpose of Reference Code Sequence
PVCRejection | (0018,1085): PVC Rejection
PyramidDescription |
PyramidLabel |
PyramidUID |
QAResultsSequence | (0028,700F): QA Results Sequence
QRMeasurementsSequence | (4010,1071): QR Measurements Sequence
QuadratureReceiveCoil | (0018,9044): Quadrature Receive Coil
QualityControlImage | (0028,0300): Quality Control Image
QualityControlSubject | (0010,0200): Quality Control Subject
QualityControlSubjectTypeCodeSequence | (0010,0201): Quality Control Subject Type Code Sequence
QualityThreshold | (0022,1630): Quality Threshold
QuantifiedDefect | (0024,0098): Quantified Defect
Quantity | (0040,0294): Quantity
QuantityDefinitionSequence | (0040,9220): Quantity Definition Sequence
QuantitySequence | (0040,0293): Quantity Sequence
QueryRetrieveLevel | (0008,0052): Query/Retrieve Level
QueryRetrieveView | (0008,0053): Query/Retrieve View
QueueStatus | (2120,0010): Queue Status
RadialPosition | (0018,1142): Radial Position
RadiationAtomicNumber | (300A,0304): Radiation Atomic Number
RadiationBeamBlockSlabThickness | (300A,066E): Radiation Beam Block Slab Thickness
RadiationBeamBlockThickness | (300A,066D): Radiation Beam Block Thickness
RadiationBeamCompensatorMillingToolDiameter | (300A,0669): Radiation Beam Compensator Milling Tool Diameter
RadiationBeamEffectiveWedgeAngle | (300A,0654): Radiation Beam Effective Wedge Angle
RadiationBeamWedgeAngle | (300A,0652): Radiation Beam Wedge Angle
RadiationBeamWedgeThinEdgeDistance | (300A,0653): Radiation Beam Wedge Thin Edge Distance
RadiationChargeState | (300A,0306): Radiation Charge State
RadiationDeviceConfigurationAndCommissioningKeySequence | (300A,065A): Radiation Device Configuration and Commissioning Key Sequence
RadiationDoseCentralAxisDisplacement | (300A,0624): Radiation Dose Central Axis Displacement
RadiationDoseIdentificationIndex | (300A,0603): Radiation Dose Identification Index
RadiationDoseIdentificationLabel | (300A,0619): Radiation Dose Identification Label
RadiationDoseIdentificationSequence | (300A,0618): Radiation Dose Identification Sequence
RadiationDoseInVivoMeasurementLabel | (300A,0623): Radiation Dose In-Vivo Measurement Label
RadiationDoseMeasurementPointCoordinates | (300A,0627): Radiation Dose Measurement Point Coordinates
RadiationDoseSequence | (300A,0617): Radiation Dose Sequence
RadiationDoseSourceToExternalContourDistance | (300A,0628): Radiation Dose Source to External Contour Distance
RadiationDoseSourceToSkinDistance | (300A,0626): Radiation Dose Source to Skin Distance
RadiationDoseValue | (300A,0625): Radiation Dose Value
RadiationDoseValuesParametersSequence | (300A,061F): Radiation Dose Values Parameters Sequence
RadiationDosimeterUnitSequence | (300A,0658): Radiation Dosimeter Unit Sequence
RadiationFluenceModifierCodeSequence | (300A,0683): Radiation Fluence Modifier Code Sequence
RadiationGenerationModeDescription | (300A,067D): Radiation GenerationMode Description
RadiationGenerationModeIndex | (300A,0601): Radiation Generation Mode Index
RadiationGenerationModeLabel | (300A,067C): Radiation GenerationMode Label
RadiationGenerationModeMachineCodeSequence | (300A,067E): Radiation GenerationMode Machine Code Sequence
RadiationGenerationModeSequence | (300A,067B): Radiation GenerationMode Sequence
RadiationMachineName | (3002,0020): Radiation Machine Name
RadiationMachineSAD | (3002,0022): Radiation Machine SAD
RadiationMachineSSD | (3002,0024): Radiation Machine SSD
RadiationMassNumber | (300A,0302): Radiation Mass Number
RadiationMode | (0018,115A): Radiation Mode
RadiationOrderIndex | (300A,0786): Radiation Order Index
RadiationSetting | (0018,1155): Radiation Setting
RadiationSourceAxisDistance | (300A,0640): Radiation Source-Axis Distance
RadiationSourceCoordinateSystemPitchAngle | (3010,0096): Radiation Source Coordinate System Pitch Angle
RadiationSourceCoordinateSystemRollAngle | (3010,0095): Radiation Source Coordinate SystemRoll Angle
RadiationSourceCoordinateSystemYawAngle | (3010,0094): Radiation Source Coordinate SystemYaw Angle
RadiationType | (300A,00C6): Radiation Type
RadiationTypeCodeSequence | (300A,067F): Radiation Type Code Sequence
RadiobiologicalDoseEffectFlag | (3010,0002): Radiobiological Dose Effect Flag
RadiobiologicalDoseEffectSequence | (3010,0001): Radiobiological Dose Effect Sequence
Radionuclide | (0018,0030): Radionuclide
RadionuclideCodeSequence | (0054,0300): Radionuclide Code Sequence
RadionuclideHalfLife | (0018,1075): Radionuclide Half Life
RadionuclidePositronFraction | (0018,1076): Radionuclide Positron Fraction
RadionuclideTotalDose | (0018,1074): Radionuclide Total Dose
Radiopharmaceutical | (0018,0031): Radiopharmaceutical
RadiopharmaceuticalAdministrationEventUID | (0008,3012): Radiopharmaceutical Administration Event UID
RadiopharmaceuticalAgentNumber | (0018,9729): Radiopharmaceutical Agent Number
RadiopharmaceuticalCodeSequence | (0054,0304): Radiopharmaceutical Code Sequence
RadiopharmaceuticalInformationSequence | (0054,0016): Radiopharmaceutical Information Sequence
RadiopharmaceuticalRoute | (0018,1070): Radiopharmaceutical Route
RadiopharmaceuticalSpecificActivity | (0018,1077): Radiopharmaceutical Specific Activity
RadiopharmaceuticalStartDateTime | (0018,1078): Radiopharmaceutical Start DateTime
RadiopharmaceuticalStartTime | (0018,1072): Radiopharmaceutical Start Time
RadiopharmaceuticalStopDateTime | (0018,1079): Radiopharmaceutical Stop DateTime
RadiopharmaceuticalStopTime | (0018,1073): Radiopharmaceutical Stop Time
RadiopharmaceuticalUsageSequence | (0018,9737): Radiopharmaceutical Usage Sequence
RadiopharmaceuticalVolume | (0018,1071): Radiopharmaceutical Volume
RadiotherapyTreatmentType | (3010,0046): Radiotherapy Treatment Type
RadiusAlongWedge | (0014,511F): Radius Along the Wedge
RadiusOfCircularCollimator | (0018,1712): Radius of Circular Collimator
RadiusOfCircularExposureControlSensingRegion | (0018,9441): Radius of Circular Exposure Control Sensing Region
RadiusOfCircularShutter | (0018,1612): Radius of Circular Shutter
RadiusOfCurvature | (0046,0075): Radius of Curvature
RandomsCorrected | (0018,9765): Randoms Corrected
RandomsCorrectionMethod | (0054,1100): Randoms Correction Method
RangeMatchingSequence |
RangeModulatorDescription | (300A,034A): Range Modulator Description
RangeModulatorGatingStartValue | (300A,0382): Range Modulator Gating Start Value
RangeModulatorGatingStartWaterEquivalentThickness | (300A,0386): Range Modulator Gating Start Water Equivalent Thickness
RangeModulatorGatingStopValue | (300A,0384): Range Modulator Gating Stop Value
RangeModulatorGatingStopWaterEquivalentThickness | (300A,0388): Range Modulator Gating Stop Water Equivalent Thickness
RangeModulatorID | (300A,0346): Range Modulator ID
RangeModulatorNumber | (300A,0344): Range Modulator Number
RangeModulatorSequence | (300A,0342): Range Modulator Sequence
RangeModulatorSettingsSequence | (300A,0380): Range Modulator Settings Sequence
RangeModulatorType | (300A,0348): Range Modulator Type
RangeOfFreedom | (0068,64A0): Range of Freedom
RangeShifterDescription | (300A,0322): Range Shifter Description
RangeShifterID | (300A,0318): Range Shifter ID
RangeShifterNumber | (300A,0316): Range Shifter Number
RangeShifterSequence | (300A,0314): Range Shifter Sequence
RangeShifterSetting | (300A,0362): Range Shifter Setting
RangeShifterSettingsSequence | (300A,0360): Range Shifter Settings Sequence
RangeShifterType | (300A,0320): Range Shifter Type
RangeShifterWaterEquivalentThickness | (300A,0366): Range Shifter Water Equivalent Thickness
RangingDepth | (0052,0009): Ranging Depth
RationalDenominatorValue | (0040,A163): Rational Denominator Value
RationalNumeratorValue | (0040,A162): Rational Numerator Value
RawDataHandling | (0040,4040): Raw Data Handling
RealTimeBulkDataFlowSequence | (0034,000A): Real-Time Bulk Data Flow Sequence
RealWorldValueFirstValueMapped | (0040,9216): Real World Value First Value Mapped
RealWorldValueIntercept | (0040,9224): Real World Value Intercept
RealWorldValueLastValueMapped | (0040,9211): Real World Value Last Value Mapped
RealWorldValueLUTData | (0040,9212): Real World Value LUT Data
RealWorldValueMappingSequence | (0040,9096): Real World Value Mapping Sequence
RealWorldValueSlope | (0040,9225): Real World Value Slope
ReasonForCancellation | (0074,1238): Reason for Cancellation
ReasonForChannelOmission | (0074,140A): Reason for Channel Omission
ReasonForChannelOmissionDescription | (0074,140B): Reason for Channel Omission Description
ReasonForOmission | (300C,0112): Reason for Omission
ReasonForOmissionCodeSequence |
ReasonForOmissionDescription | (300C,0113): Reason for Omission Description
ReasonForPerformedProcedureCodeSequence | (0040,1012): Reason For Performed Procedure Code Sequence
ReasonForRemovalCodeSequence |
ReasonForRequestedProcedureCodeSequence | (0040,100A): Reason for Requested Procedure Code Sequence
ReasonForStudy | (0032,1030): Reason for Study
ReasonForSuperseding | (3010,005C): Reason for Superseding
ReasonForTheAttributeModification | (0400,0565): Reason for the Attribute Modification
ReasonForTheImagingServiceRequest | (0040,2001): Reason for the Imaging Service Request
ReasonForTheRequestedProcedure | (0040,1002): Reason for the Requested Procedure
ReasonForVisit | (0032,1066): Reason for Visit
ReasonForVisitCodeSequence | (0032,1067): Reason for Visit Code Sequence
ReceiveCoilManufacturerName | (0018,9041): Receive Coil Manufacturer Name
ReceiveCoilName | (0018,1250): Receive Coil Name
ReceiveCoilType | (0018,9043): Receive Coil Type
ReceiveProbeSequence | (0014,4086): Receive Probe Sequence
Receiver | (0000,0300): Receiver()
ReceiverEquipmentSequence | (0014,4008): Receiver Equipment Sequence
ReceiverNotes | (0014,400C): Receiver Notes
ReceiverSettingsSequence | (0014,4030): Receiver Settings Sequence
ReceiveTransducerSequence | (0014,4011): Receive Transducer Sequence
ReceiveTransducerSettingsSequence | (0014,4051): Receive Transducer Settings Sequence
ReceivingAE | (0074,1234): Receiving AE
ReceivingApplicationEntityTitle | (0002,0018): Receiving Application Entity Title
ReceivingPresentationAddress | (0002,0028): Receiving Presentation Address
RecognitionCode | (0008,0010): Recognition Code()
RecognizableVisualFeatures | (0028,0302): Recognizable Visual Features
RecommendedAbsentPixelCIELabValue | (0048,0015): Recommended Absent Pixel CIELab Value
RecommendedAnimationRate | (0070,1A03): Recommended Animation Rate
RecommendedDefaultValueSequence | (0082,0035): Recommended Default Value Sequence
RecommendedDisplayCIELabValue | (0062,000D): Recommended Display CIELab Value
RecommendedDisplayCIELabValueList | (0066,0103): Recommended Display CIELab Value List
RecommendedDisplayFrameRate | (0008,2144): Recommended Display Frame Rate
RecommendedDisplayFrameRateInFloat | (0008,9459): Recommended Display Frame Rate in Float
RecommendedDisplayGrayscaleValue | (0062,000C): Recommended Display Grayscale Value
RecommendedExposureIndex | (0016,001C): Recommended Exposure Index
RecommendedLineThickness | (0066,0038): Recommended Line Thickness
RecommendedPointRadius | (0066,0037): Recommended Point Radius
RecommendedPresentationOpacity | (0066,000C): Recommended Presentation Opacity
RecommendedPresentationType | (0066,000D): Recommended Presentation Type
RecommendedRotationPoint | (0068,6346): Recommended Rotation Point
RecommendedViewingMode | (0028,1090): Recommended Viewing Mode
ReconstructionAlgorithm | (0018,9315): Reconstruction Algorithm
ReconstructionAlgorithmSequence | (0018,993D): Reconstruction Algorithm Sequence
ReconstructionAngle | (0018,9319): Reconstruction Angle
ReconstructionDescription | (0018,9531): Reconstruction Description
ReconstructionDiameter | (0018,1100): Reconstruction Diameter
ReconstructionEndLocationSequence | (0018,993C): Reconstruction End Location Sequence
ReconstructionFieldOfView | (0018,9317): Reconstruction Field of View
ReconstructionIndex | (0020,9536): Reconstruction Index
ReconstructionMethod | (0054,1103): Reconstruction Method
ReconstructionPipelineType | (0018,11BE): Reconstruction Pipeline Type
ReconstructionPixelSpacing | (0018,9322): Reconstruction Pixel Spacing
ReconstructionProtocolElementSequence | (0018,9934): Reconstruction Protocol Element Sequence
ReconstructionProtocolElementSpecificationSequence | (0018,9933): Reconstruction Protocol Element Specification Sequence
ReconstructionStartLocationSequence | (0018,993B): Reconstruction Start Location Sequence
ReconstructionTargetCenterLocationSequence | (0018,993E): Reconstruction Target Center Location Sequence
ReconstructionTargetCenterPatient | (0018,9318): Reconstruction Target Center (Patient)
ReconstructionType | (0018,9756): Reconstruction Type
RecordedBlockSequence | (3008,00D0): Recorded Block Sequence
RecordedBlockSlabSequence |
RecordedBrachyAccessoryDeviceSequence | (3008,0120): Recorded Brachy Accessory Device Sequence
RecordedChannelSequence | (3008,0130): Recorded Channel Sequence
RecordedChannelShieldSequence | (3008,0150): Recorded Channel Shield Sequence
RecordedCompensatorSequence | (3008,00C0): Recorded Compensator Sequence
RecordedLateralSpreadingDeviceSequence | (3008,00F4): Recorded Lateral Spreading Device Sequence
RecordedRangeModulatorSequence | (3008,00F6): Recorded Range Modulator Sequence
RecordedRangeShifterSequence | (3008,00F2): Recorded Range Shifter Sequence
RecordedRTControlPointDateTime | (300A,073A): Recorded RT Control Point DateTime
RecordedSnoutSequence | (3008,00F0): Recorded Snout Sequence
RecordedSourceApplicatorSequence | (3008,0140): Recorded Source Applicator Sequence
RecordedSourceSequence | (3008,0100): Recorded Source Sequence
RecordedWedgeSequence | (3008,00B0): Recorded Wedge Sequence
RecordInUseFlag | (0004,1410): Record In-use Flag
RecordKey |
RectificationType | (0018,1156): Rectification Type
RectifierSmoothing | (0014,4034): Rectifier Smoothing
RectilinearPhaseEncodeReordering | (0018,9034): Rectilinear Phase Encode Reordering
RedPaletteColorLookupTableData | (0028,1201): Red Palette Color Lookup Table Data
RedPaletteColorLookupTableDescriptor | (0028,1101): Red Palette Color Lookup Table Descriptor
Reference | (0020,1020): Reference()
ReferenceAirKermaRate | (300A,022A): Reference Air Kerma Rate
ReferenceBasisCodeSequence | (0018,9902): Reference Basis Code Sequence
ReferenceCoordinates | (0022,0032): Reference Coordinates
ReferencedAccessionSequenceTrial | (0040,A313): Referenced Accession Sequence (Trial)
ReferencedAssertionUID | (0044,0108): Referenced Assertion UID
ReferencedBaselineParametersRTRadiationInstanceSequence |
ReferencedBasicAnnotationBoxSequence | (2010,0520): Referenced Basic Annotation Box Sequence
ReferencedBeamNumber | (300C,0006): Referenced Beam Number
ReferencedBeamSequence | (300C,0004): Referenced Beam Sequence
ReferencedBlockNumber | (300C,00E0): Referenced Block Number
ReferencedBolusSequence | (300C,00B0): Referenced Bolus Sequence
ReferencedBrachyAccessoryDeviceNumber | (3008,0122): Referenced Brachy Accessory Device Number
ReferencedBrachyApplicationSetupNumber | (300C,000C): Referenced Brachy Application Setup Number
ReferencedBrachyApplicationSetupSequence | (300C,000A): Referenced Brachy Application Setup Sequence
ReferencedCalculatedDoseReferenceNumber | (3008,0092): Referenced Calculated Dose Reference Number
ReferencedCalculatedDoseReferenceSequence | (3008,0090): Referenced Calculated Dose Reference Sequence
ReferencedChannelNumber | (0074,1406): Referenced Channel Number
ReferencedChannelShieldNumber | (3008,0152): Referenced Channel Shield Number
ReferencedColorPaletteInstanceUID | (0028,0304): Referenced Color Palette Instance UID
ReferencedComparisonSOPInstanceSequence | (0082,0005): Referenced Comparison SOP Instance Sequence
ReferencedCompensatorNumber | (300C,00D0): Referenced Compensator Number
ReferencedConceptualVolumeUID | (3010,000B): Referenced Conceptual Volume UID
ReferencedContentItem | (0070,1904): Referenced Content Item
ReferencedContentItemIdentifier | (0040,DB73): Referenced Content Item Identifier
ReferencedControlPointIndex | (300C,00F0): Referenced Control Point Index
ReferencedControlPointSequence | (300C,00F2): Referenced Control Point Sequence
ReferencedCurveSequence | (0008,1145): Referenced Curve Sequence
ReferencedDateTime | (0040,A13A): Referenced DateTime
ReferencedDefinedDeviceIndex | (300A,0602): Referenced Defined Device Index
ReferencedDefinedProtocolSequence | (0018,990C): Referenced Defined Protocol Sequence
ReferencedDeviceIndex | (300A,0607): Referenced Device Index
ReferencedDigitalSignatureSequence | (0400,0402): Referenced Digital Signature Sequence
ReferencedDirectSegmentInstanceSequence | (3010,004A): Referenced Direct Segment Instance Sequence
ReferencedDoseReferenceNumber | (300C,0051): Referenced Dose Reference Number
ReferencedDoseReferenceSequence | (300C,0050): Referenced Dose Reference Sequence
ReferencedDoseReferenceUID | (300A,0083): Referenced Dose Reference UID
ReferencedDoseSequence | (300C,0080): Referenced Dose Sequence
ReferencedDosimetricObjectivesSequence | (3010,0071): Referenced Dosimetric Objectives Sequence
ReferencedDosimetricObjectiveUID | (3010,006F): Referenced Dosimetric Objective UID
ReferencedExpectedInVivoMeasurementValueIndex | (300A,0773): Referenced Expected In-Vivo Measurement Value Index
ReferencedFiducialsUID | (3010,0031): Referenced Fiducials UID
ReferencedFiducialUID | (0070,031B): Referenced Fiducial UID
ReferencedFileID | (0004,1500): Referenced File ID
ReferencedFilmBoxSequence | (2000,0500): Referenced Film Box Sequence
ReferencedFilmSessionSequence | (2010,0500): Referenced Film Session Sequence
ReferencedFindingsGroupUIDTrial | (0040,A022): Referenced Findings Group UID (Trial)
ReferencedFirstFrameSequence | (0072,0427): Referenced First Frame Sequence
ReferencedFractionGroupNumber | (300C,0022): Referenced Fraction Group Number
ReferencedFractionGroupSequence | (300C,0020): Referenced Fraction Group Sequence
ReferencedFractionNumber | (3008,0223): Referenced Fraction Number
ReferencedFrameNumber | (0008,1160): Referenced Frame Number
ReferencedFrameNumbers | (0040,A136): Referenced Frame Numbers
ReferencedFrameOfReferenceSequence | (3006,0010): Referenced Frame of Reference Sequence
ReferencedFrameOfReferenceUID | (3006,0024): Referenced Frame of Reference UID
ReferencedGeneralPurposeScheduledProcedureStepSequence | (0040,4016): Referenced General Purpose Scheduled Procedure Step Sequence
ReferencedGeneralPurposeScheduledProcedureStepTransactionUID | (0040,4023): Referenced General Purpose Scheduled Procedure Step Transaction UID
ReferencedHPGLDocumentID | (0068,6440): Referenced HPGL Document ID
ReferencedImageBoxSequence | (2010,0510): Referenced Image Box Sequence
ReferencedImageBoxSequenceRetired | (2040,0500): Referenced Image Box Sequence (Retired)
ReferencedImageEvidenceSequence | (0008,9092): Referenced Image Evidence Sequence
ReferencedImageNavigationSequence | (0048,0200): Referenced Image Navigation Sequence
ReferencedImageOverlayBoxSequence | (2020,0130): Referenced Image Overlay Box Sequence
ReferencedImageRealWorldValueMappingSequence | (0040,9094): Referenced Image Real World Value Mapping Sequence
ReferencedImageSequence | (0008,1140): Referenced Image Sequence
ReferencedImplantTemplateGroupMemberID | (0078,00B6): Referenced Implant Template Group Member ID
ReferencedInstancesBySOPClassSequence |
ReferencedInstanceSequence | (0008,114A): Referenced Instance Sequence
ReferencedInterpretationSequence | (4008,0050): Referenced Interpretation Sequence
ReferenceDisplaySets | (0072,0218): Reference Display Sets
ReferencedLateralSpreadingDeviceNumber | (300C,0102): Referenced Lateral Spreading Device Number
ReferencedMeasuredDoseReferenceNumber | (3008,0082): Referenced Measured Dose Reference Number
ReferencedMeasuredDoseReferenceSequence | (3008,0080): Referenced Measured Dose Reference Sequence
ReferencedNonImageCompositeSOPInstanceSequence | (0040,0220): Referenced Non-Image Composite SOP Instance Sequence
ReferencedObjectObservationClassTrial | (0040,A174): Referenced Object Observation Class (Trial)
ReferencedObservationClassTrial | (0040,A173): Referenced Observation Class (Trial)
ReferencedObservationUIDTrial | (0040,A172): Referenced Observation UID (Trial)
ReferencedOphthalmicAxialLengthMeasurementQCImageSequence | (0022,1330): Referenced Ophthalmic Axial Length Measurement QC Image Sequence
ReferencedOphthalmicAxialMeasurementsSequence | (0022,1100): Referenced Ophthalmic Axial Measurements Sequence
ReferencedOpticalPathIdentifier | (006A,000E): Referenced Optical Path Identifier
ReferenceDoseDefinition | (300A,0512): Reference Dose Definition
ReferenceDosePointCoordinates | (300A,061E): Reference Dose Point Coordinates
ReferenceDoseType | (300A,061A): Reference Dose Type
ReferencedOtherPlaneSequence | (0008,9410): Referenced Other Plane Sequence
ReferencedOverlayPlaneGroups | (2040,0011): Referenced Overlay Plane Groups
ReferencedOverlayPlaneSequence | (2040,0010): Referenced Overlay Plane Sequence
ReferencedOverlaySequence | (0008,1130): Referenced Overlay Sequence
ReferencedParentRTPrescriptionIndex | (3010,0042): Referenced Parent RT Prescription Index
ReferencedPathIndex | (0018,9378): Referenced Path Index
ReferencedPatientAliasSequence | (0038,0004): Referenced Patient Alias Sequence
ReferencedPatientPhotoSequence | (0010,1100): Referenced Patient Photo Sequence
ReferencedPatientSequence | (0008,1120): Referenced Patient Sequence
ReferencedPatientSetupNumber | (300C,006A): Referenced Patient Setup Number
ReferencedPatientSetupPhotoSequence | (300A,078C): Referenced Patient Setup Photo Sequence
ReferencedPatientSetupProcedureIndex | (300A,0796): Referenced Patient Setup Procedure Index
ReferencedPerformedProcedureStepSequence | (0008,1111): Referenced Performed Procedure Step Sequence
ReferencedPerformedProtocolSequence | (0018,990D): Referenced Performed Protocol Sequence
ReferencedPlanOverviewIndex |
ReferencedPositionReferenceInstanceSequence |
ReferencedPresentationLUTSequence | (2050,0500): Referenced Presentation LUT Sequence
ReferencedPresentationStateSequence | (0008,9237): Referenced Presentation State Sequence
ReferencedPrintJobSequence | (2120,0070): Referenced Print Job Sequence
ReferencedPrintJobSequencePullStoredPrint | (2100,0500): Referenced Print Job Sequence (Pull Stored Print)
ReferencedProcedureStepSequence | (0040,0330): Referenced Procedure Step Sequence
ReferencedPTOSequence | (4010,1076): Referenced PTO Sequence
ReferencedRadiationDoseIdentificationIndex | (300A,060C): Referenced Radiation Dose Identification Index
ReferencedRadiationGenerationModeIndex | (300A,0605): Referenced Radiation Generation Mode Index
ReferencedRadiationRTControlPointIndex | (300A,073B): Referenced Radiation RT Control Point Index
ReferencedRangeModulatorNumber | (300C,0104): Referenced Range Modulator Number
ReferencedRangeShifterNumber | (300C,0100): Referenced Range Shifter Number
ReferencedRawDataSequence | (0008,9121): Referenced Raw Data Sequence
ReferencedRealWorldValueMappingInstanceSequence | (0008,114B): Referenced Real World Value Mapping Instance Sequence
ReferencedReferenceImageNumber | (300C,0007): Referenced Reference Image Number
ReferencedReferenceImageSequence | (300C,0042): Referenced Reference Image Sequence
ReferencedRefractiveMeasurementsSequence | (0046,0145): Referenced Refractive Measurements Sequence
ReferencedRelatedGeneralSOPClassUIDInFile | (0004,151A): Referenced Related General SOP Class UID in File
ReferencedRequestSequence | (0040,A370): Referenced Request Sequence
ReferencedResultsSequence | (0008,1100): Referenced Results Sequence
ReferencedROINumber | (3006,0084): Referenced ROI Number
ReferencedRTAccessoryHolderDeviceIndex | (300A,060E): Referenced RT Accessory Holder Device Index
ReferencedRTInstanceSequence | (300A,0631): Referenced RT Instance Sequence
ReferencedRTPatientSetupSequence | (300A,0632): Referenced RT Patient Setup Sequence
ReferencedRTPhysicianIntentIndex | (3010,005E): Referenced RT Physician Intent Index
ReferencedRTPhysicianIntentSequence | (300A,063B): Referenced RT Physician Intent Sequence
ReferencedRTPlanSequence | (300C,0002): Referenced RT Plan Sequence
ReferencedRTPrescriptionIndex | (3010,0041): Referenced RT Prescription Index
ReferencedRTPrescriptionSequence | (300A,068A): Referenced RT Prescription Sequence
ReferencedRTRadiationRecordSequence | (300A,0703): Referenced RT Radiation Record Sequence
ReferencedRTRadiationSequence | (300A,0630): Referenced RT Radiation Sequence
ReferencedRTRadiationSetSequence | (300A,0702): Referenced RT Radiation Set Sequence
ReferencedRTTreatmentPhaseIndex | (3010,0040): Referenced RT Treatment Phase Index
ReferencedRTTreatmentPhaseSequence | (3010,0049): Referenced RT Treatment Phase Sequence
ReferencedRTTreatmentPreparationSequence | (300A,078B): Referenced RT Treatment Preparation Sequence
ReferencedSamplePositions | (0040,A132): Referenced Sample Positions
ReferencedSegmentNumber | (0062,000B): Referenced Segment Number
ReferencedSegmentReferenceIndex | (3010,0020): Referenced Segment Reference Index
ReferencedSeriesSequence | (0008,1115): Referenced Series Sequence
ReferencedSetupImageSequence | (300A,0401): Referenced Setup Image Sequence
ReferencedSOPClassUID | (0008,1150): Referenced SOP Class UID
ReferencedSOPClassUIDInFile | (0004,1510): Referenced SOP Class UID in File
ReferencedSOPInstanceMACSequence | (0400,0403): Referenced SOP Instance MAC Sequence
ReferencedSOPInstanceUID | (0008,1155): Referenced SOP Instance UID
ReferencedSOPInstanceUIDInFile | (0004,1511): Referenced SOP Instance UID in File
ReferencedSOPSequence | (0008,1199): Referenced SOP Sequence
ReferencedSourceApplicatorNumber | (3008,0142): Referenced Source Applicator Number
ReferencedSourceNumber | (300C,000E): Referenced Source Number
ReferencedSpatialRegistrationSequence | (0070,0404): Referenced Spatial Registration Sequence
ReferencedStartControlPointIndex | (300C,00F4): Referenced Start Control Point Index
ReferencedStereometricInstanceSequence | (0008,1134): Referenced Stereometric Instance Sequence
ReferencedStopControlPointIndex | (300C,00F6): Referenced Stop Control Point Index
ReferencedStorageMediaSequence | (2200,000D): Referenced Storage Media Sequence
ReferencedStoredPrintSequence | (2000,0510): Referenced Stored Print Sequence
ReferencedStructuredContextSequence | (0070,1903): Referenced Structured Context Sequence
ReferencedStructureSetSequence | (300C,0060): Referenced Structure Set Sequence
ReferencedStudySequence | (0008,1110): Referenced Study Sequence
ReferencedSurfaceDataSequence | (0080,0013): Referenced Surface Data Sequence
ReferencedSurfaceMeshIdentificationSequence | (0022,1620): Referenced Surface Mesh Identification Sequence
ReferencedSurfaceNumber | (0066,002C): Referenced Surface Number
ReferencedSurfaceSequence | (0066,002B): Referenced Surface Sequence
ReferencedTargetLuminanceCharacteristicsID | (0028,700E): Referenced Target Luminance Characteristics ID
ReferencedTDRInstanceSequence | (4010,1077): Referenced TDR Instance Sequence
ReferencedTextureSequence | (0080,0012): Referenced Texture Sequence
ReferencedTimeOffsets | (0040,A138): Referenced Time Offsets
ReferencedToleranceTableNumber | (300C,00A0): Referenced Tolerance Table Number
ReferencedTransferSyntaxUIDInFile | (0004,1512): Referenced Transfer Syntax UID in File
ReferencedTreatmentPositionGroupUID | (300A,0785): Referenced Treatment Position Group UID
ReferencedTreatmentPositionIndex | (300A,060B): Referenced Treatment Position Index
ReferencedTreatmentRecordSequence | (3008,0030): Referenced Treatment Record Sequence
ReferencedVerificationImageSequence | (300C,0040): Referenced Verification Image Sequence
ReferencedVisitSequence | (0008,1125): Referenced Visit Sequence
ReferencedVOILUTBoxSequence | (2020,0140): Referenced VOI LUT Box Sequence
ReferencedWaveformChannels | (0040,A0B0): Referenced Waveform Channels
ReferencedWaveformSequence | (0008,113A): Referenced Waveform Sequence
ReferencedWedgeNumber | (300C,00C0): Referenced Wedge Number
ReferencedXRayDetectorIndex | (0018,9376): Referenced X-Ray Detector Index
ReferencedXRaySourceIndex | (0018,9377): Referenced X-Ray Source Index
ReferenceGeometryCodeSequence | (0018,9903): Reference Geometry Code Sequence
ReferenceImageNumber | (300A,00C8): Reference Image Number
ReferenceLocationDescription | (0018,9901): Reference Location Description
ReferenceLocationLabel | (0018,9900): Reference Location Label
ReferencePixelPhysicalValueX | (0018,6028): Reference Pixel Physical Value X
ReferencePixelPhysicalValueY | (0018,602A): Reference Pixel Physical Value Y
ReferencePixelX0 | (0018,6020): Reference Pixel X0
ReferencePixelY0 | (0018,6022): Reference Pixel Y0
ReferenceToRecordedSound | (4008,0103): Reference to Recorded Sound
ReferringPhysicianAddress | (0008,0092): Referring Physician's Address
ReferringPhysicianIdentificationSequence | (0008,0096): Referring Physician Identification Sequence
ReferringPhysicianName | (0008,0090): Referring Physician's Name
ReferringPhysicianTelephoneNumbers | (0008,0094): Referring Physician's Telephone Numbers
ReflectedAmbientLight | (2010,0160): Reflected Ambient Light
ReformattingInterval | (0072,0514): Reformatting Interval
ReformattingOperationInitialViewDirection | (0072,0516): Reformatting Operation Initial View Direction
ReformattingOperationType | (0072,0510): Reformatting Operation Type
ReformattingThickness | (0072,0512): Reformatting Thickness
RefractiveErrorBeforeRefractiveSurgeryCodeSequence | (0022,1103): Refractive Error Before Refractive Surgery Code Sequence
RefractiveIndexApplied | (0052,003A): Refractive Index Applied
RefractiveIndexOfAqueousHumor | (0046,0118): Refractive Index of Aqueous Humor
RefractiveIndexOfCornea | (0046,0117): Refractive Index of Cornea
RefractiveParametersUsedOnPatientSequence | (0024,0112): Refractive Parameters Used on Patient Sequence
RefractivePower | (0046,0251): Refractive Power
RefractiveProcedureOccurred | (0022,1039): Refractive Procedure Occurred
RefractiveStateSequence | (0022,001B): Refractive State Sequence
RefractiveSurgeryTypeCodeSequence | (0022,1040): Refractive Surgery Type Code Sequence
RegionDataType | (0018,6014): Region Data Type
RegionFlags | (0018,6016): Region Flags
RegionLocationMaxX1 | (0018,601C): Region Location Max X1
RegionLocationMaxY1 | (0018,601E): Region Location Max Y1
RegionLocationMinX0 | (0018,6018): Region Location Min X0
RegionLocationMinY0 | (0018,601A): Region Location Min Y0
RegionOfResidence | (0010,2152): Region of Residence
RegionPixelShiftSequence | (0028,9502): Region Pixel Shift Sequence
RegionSpatialFormat | (0018,6012): Region Spatial Format
RegisteredLocalizerBottomRightHandCorner | (0022,1468): Registered Localizer Bottom Right Hand Corner
RegisteredLocalizerTopLeftHandCorner | (0022,1467): Registered Localizer Top Left Hand Corner
RegisteredLocalizerUnits | (0022,1466): Registered Localizer Units
RegistrationMethodCodeSequence | (0080,0003): Registration Method Code Sequence
RegistrationSequence | (0070,0308): Registration Sequence
RegistrationToLocalizerSequence | (0022,1465): Registration to Localizer Sequence
RegistrationTypeCodeSequence | (0070,030D): Registration Type Code Sequence
RelatedAssertionSequence | (0044,0107): Related Assertion Sequence
RelatedFrameOfReferenceUID | (3006,00C2): Related Frame of Reference UID
RelatedGeneralSOPClassUID | (0008,001A): Related General SOP Class UID
RelatedProcedureStepSequence | (0074,1220): Related Procedure Step Sequence
RelatedReferenceRTImageSequence | (0074,1040): Related Reference RT Image Sequence
RelatedRTROIObservationsSequence | (3006,00A0): Related RT ROI Observations Sequence
RelatedRTTreatmentPhaseIndex | (3010,003F): Related RT Treatment Phase Index
RelatedSegmentCharacteristicsSequence | (3010,0028): Related Segment Characteristics Sequence
RelatedSeriesSequence | (0008,1250): Related Series Sequence
RelationshipSequenceTrial | (0040,A731): Relationship Sequence (Trial)
RelationshipType | (0040,A010): Relationship Type
RelationshipTypeCodeSequenceTrial | (0040,A732): Relationship Type Code Sequence (Trial)
RelativeElevation | (0046,0252): Relative Elevation
RelativeImagePositionCodeSequence | (0022,001D): Relative Image Position Code Sequence
RelativeOpacity | (0070,0403): Relative Opacity
RelativeTime | (0072,0038): Relative Time
RelativeTimeUnits | (0072,003A): Relative Time Units
RelativeURIReferenceWithinEncapsulatedDocument | (0068,7005): Relative URI Reference Within Encapsulated Document
RelativeXRayExposure | (0018,1405): Relative X-Ray Exposure
RelevantInformationSequence | (0040,4022): Relevant Information Sequence
RelevantOPTAttributesSequence | (0022,1472): Relevant OPT Attributes Sequence
RemovedFromOperationalUse |
RenderedImageReferenceSequence | (0070,1104): Rendered Image Reference Sequence
RenderFieldOfView | (0070,1606): Render Field of View
RenderingMethod | (0070,120D): Rendering Method
RenderProjection | (0070,1602): Render Projection
RepairID | (0014,0105): Repair ID
RepeatFractionCycleLength | (300A,007A): Repeat Fraction Cycle Length
RepeatInterval | (0028,0068): Repeat Interval
RepetitionTime | (0018,0080): Repetition Time
ReplacedImplantAssemblyTemplateSequence | (0076,0008): Replaced Implant Assembly Template Sequence
ReplacedImplantTemplateGroupSequence | (0078,0026): Replaced Implant Template Group Sequence
ReplacedImplantTemplateSequence | (0068,6222): Replaced Implant Template Sequence
ReplacedProcedureStepSequence | (0074,1224): Replaced Procedure Step Sequence
ReportDetailSequenceTrial | (0040,A380): Report Detail Sequence (Trial)
ReportedValuesOrigin | (3002,000A): Reported Values Origin
ReportingPriority | (0040,1009): Reporting Priority
ReportNumber | (0020,00AA): Report Number
ReportProductionStatusTrial | (4008,00FF): Report Production Status (Trial)
ReportStatusCommentTrial | (0040,A33A): Report Status Comment (Trial)
ReportStatusIDTrial | (0040,A125): Report Status ID (Trial)
RepositoryUniqueID | (0040,E030): Repository Unique ID
RepresentativeFrameNumber | (0028,6010): Representative Frame Number
ReprojectionMethod | (0054,1004): Reprojection Method
RequestAttributesSequence | (0040,0275): Request Attributes Sequence
RequestedContrastAgent | (0032,1070): Requested Contrast Agent
RequestedDecimateCropBehavior | (2020,0040): Requested Decimate/Crop Behavior
RequestedImageSize | (2020,0030): Requested Image Size
RequestedImageSizeFlag | (2020,00A0): Requested Image Size Flag
RequestedLateralityCodeSequence |
RequestedMediaApplicationProfile | (2200,000C): Requested Media Application Profile
RequestedProcedureCodeSequence | (0032,1064): Requested Procedure Code Sequence
RequestedProcedureComments | (0040,1400): Requested Procedure Comments
RequestedProcedureDescription | (0032,1060): Requested Procedure Description
RequestedProcedureDescriptionTrial | (0040,1060): Requested Procedure Description (Trial)
RequestedProcedureID | (0040,1001): Requested Procedure ID
RequestedProcedureLocation | (0040,1005): Requested Procedure Location
RequestedProcedurePriority | (0040,1003): Requested Procedure Priority
RequestedResolutionID | (2020,0050): Requested Resolution ID
RequestedSeriesDescription | (0018,9937): Requested Series Description
RequestedSeriesDescriptionCodeSequence | (0018,11C1): Requested Series Description Code Sequence
RequestedSOPClassUID | (0000,0003): Requested SOP Class UID
RequestedSOPInstanceUID | (0000,1001): Requested SOP Instance UID
RequestedStatusInterval |
RequestedSubsequentWorkitemCodeSequence | (0040,4031): Requested Subsequent Workitem Code Sequence
RequestingAE | (0074,1236): Requesting AE
RequestingPhysician | (0032,1032): Requesting Physician
RequestingPhysicianIdentificationSequence | (0032,1031): Requesting Physician Identification Sequence
RequestingService | (0032,1033): Requesting Service
RequestingServiceCodeSequence | (0032,1034): Requesting Service Code Sequence
RequestPriority | (2200,0020): Request Priority
RescaleIntercept | (0028,1052): Rescale Intercept
RescaleSlope | (0028,1053): Rescale Slope
RescaleType | (0028,1054): Rescale Type
ResidualSyringeCounts | (0054,0017): Residual Syringe Counts
ResonantNucleus | (0018,9100): Resonant Nucleus
ResourceDescription | (0038,0102): Resource Description
RespiratoryCyclePosition | (0018,9214): Respiratory Cycle Position
RespiratoryIntervalTime | (0020,9254): Respiratory Interval Time
RespiratoryMotionCompensationTechnique | (0018,9170): Respiratory Motion Compensation Technique
RespiratoryMotionCompensationTechniqueDescription | (0018,9185): Respiratory Motion Compensation Technique Description
RespiratorySignalSource | (0018,9171): Respiratory Signal Source
RespiratorySignalSourceID | (0018,9186): Respiratory Signal Source ID
RespiratorySynchronizationSequence | (0020,9253): Respiratory Synchronization Sequence
RespiratoryTriggerDelayThreshold | (0020,9256): Respiratory Trigger Delay Threshold
RespiratoryTriggerType | (0020,9250): Respiratory Trigger Type
ResponseSequenceNumber | (0000,0860): Response Sequence Number()
ResponsibleGroupCodeSequence | (0008,0220): Responsible Group Code Sequence
ResponsibleOrganization | (0010,2299): Responsible Organization
ResponsiblePerson | (0010,2297): Responsible Person
ResponsiblePersonRole | (0010,2298): Responsible Person Role
ResultingGeneralPurposePerformedProcedureStepsSequence | (0040,4015): Resulting General Purpose Performed Procedure Steps Sequence
ResultsComments | (4008,4000): Results Comments
ResultsDistributionListSequence | (4008,0118): Results Distribution List Sequence
ResultsID | (4008,0040): Results ID
ResultsIDIssuer | (4008,0042): Results ID Issuer
ResultsNormalsSequence | (0024,0064): Results Normals Sequence
RetainInstances |
RetestSensitivityValue | (0024,0096): Retest Sensitivity Value
RetestStimulusSeen | (0024,0095): Retest Stimulus Seen
RetinalThicknessDefinitionCodeSequence | (0022,1445): Retinal Thickness Definition Code Sequence
RetrieveAETitle | (0008,0054): Retrieve AE Title
RetrieveLocationUID | (0040,E011): Retrieve Location UID
RetrieveURI | (0040,E010): Retrieve URI
RetrieveURL | (0008,1190): Retrieve URL
ReviewDate | (300E,0004): Review Date
ReviewerName | (300E,0008): Reviewer Name
ReviewTime | (300E,0005): Review Time
RevolutionTime | (0018,9305): Revolution Time
RFEchoTrainLength | (0018,9240): RF Echo Train Length
RGBATransferFunctionDescription | (0070,1A09): RGBA Transfer Function Description
RGBLUTTransferFunction | (0028,140F): RGB LUT Transfer Function
RightImageSequence | (0022,0022): Right Image Sequence
RightLensSequence | (0046,0014): Right Lens Sequence
RoboticBaseLocationIndicator | (3010,0090): Robotic Base Location Indicator
RoboticNodeIdentifier | (3010,0092): Robotic Node Identifier
RoboticPathControlPointSequence | (3010,0097): Robotic Path Control Point Sequence
RoboticPathNodeSetCodeSequence | (3010,0091): Robotic Path Node Set Code Sequence
ROIArea | (60xx,1301): ROI Area
ROIContourSequence | (3006,0039): ROI Contour Sequence
ROICreatorSequence |
ROIDateTime |
ROIDerivationAlgorithmIdentificationSequence | (3006,0037): ROI Derivation Algorithm Identification Sequence
ROIDescription | (3006,0028): ROI Description
ROIDisplayColor | (3006,002A): ROI Display Color
ROIElementalCompositionAtomicMassFraction | (3006,00B8): ROI Elemental Composition Atomic Mass Fraction
ROIElementalCompositionAtomicNumber | (3006,00B7): ROI Elemental Composition Atomic Number
ROIElementalCompositionSequence | (3006,00B6): ROI Elemental Composition Sequence
ROIGenerationAlgorithm | (3006,0036): ROI Generation Algorithm
ROIGenerationDescription | (3006,0038): ROI Generation Description
ROIInterpreter | (3006,00A6): ROI Interpreter
ROIInterpreterSequence |
ROIMean | (60xx,1302): ROI Mean
ROIName | (3006,0026): ROI Name
ROINumber | (3006,0022): ROI Number
ROIObservationContextCodeSequence |
ROIObservationDateTime |
ROIObservationDescription | (3006,0088): ROI Observation Description
ROIObservationLabel | (3006,0085): ROI Observation Label
ROIPhysicalPropertiesSequence | (3006,00B0): ROI Physical Properties Sequence
ROIPhysicalProperty | (3006,00B2): ROI Physical Property
ROIPhysicalPropertyValue | (3006,00B4): ROI Physical Property Value
ROIStandardDeviation | (60xx,1303): ROI Standard Deviation
ROIVolume | (3006,002C): ROI Volume
RotationAngle | (0070,0230): Rotation Angle
RotationDirection | (0018,1140): Rotation Direction
RotationInformationSequence | (0054,0052): Rotation Information Sequence
RotationOffset | (0018,1146): Rotation Offset
RotationOfScannedFilm | (0018,2030): Rotation of Scanned Film
RotationPoint | (0070,0273): Rotation Point
RotationVector | (0054,0050): Rotation Vector
RouteID | (4010,1054): Route ID
RouteIDAssigningAuthority | (4010,1055): Route ID Assigning Authority
RouteOfAdmissions | (0038,0016): Route of Admissions
RouteSegmentEndLocationID | (4010,101F): Route Segment End Location ID
RouteSegmentEndTime | (4010,1026): Route Segment End Time
RouteSegmentID | (4010,1007): Route Segment ID
RouteSegmentLocationIDType | (4010,1020): Route Segment Location ID Type
RouteSegmentSequence | (4010,100A): Route Segment Sequence
RouteSegmentStartLocationID | (4010,101E): Route Segment Start Location ID
RouteSegmentStartTime | (4010,1025): Route Segment Start Time
RowOverlap | (0028,0093): Row Overlap
RowPositionInTotalImagePixelMatrix | (0048,021F): Row Position In Total Image Pixel Matrix
Rows | (0028,0010): Rows
RRIntervalTimeNominal | (0020,9251): R-R Interval Time Nominal
RRIntervalVector | (0054,0060): R-R Interval Vector
RTAccessoryDeviceSlotID | (300A,0615): RT Accessory Device Slot ID
RTAccessoryHolderDefinitionSequence | (300A,0614): RT Accessory Holder Definition Sequence
RTAccessoryHolderSlotDistance | (300A,0612): RT Accessory Holder Slot Distance
RTAccessoryHolderSlotExistenceFlag | (300A,060F): RT Accessory Holder Slot Existence Flag
RTAccessoryHolderSlotID | (300A,0611): RT Accessory Holder Slot ID
RTAccessoryHolderSlotSequence | (300A,0610): RT Accessory Holder Slot Sequence
RTAccessoryHolderWaterEquivalentThickness | (300A,060D): RT Accessory Holder Water-Equivalent Thickness
RTAccessorySlotDistance | (300A,0613): RT Accessory Slot Distance
RTAcquisitionPatientPositionSequence |
RTAnatomicPrescriptionSequence | (3010,0060): RT Anatomic Prescription Sequence
RTBeamDelimiterGeometrySequence | (300A,064C): RT Beam Delimiter Geometry Sequence
RTBeamLimitingDeviceAngle | (300A,0679): RT Beam Limiting Device Angle
RTBeamLimitingDeviceDefinitionSequence | (300A,064D): RT Beam Limiting Device Definition Sequence
RTBeamLimitingDeviceDistalDistance | (300A,0643): RT Beam Limiting Device Distal Distance
RTBeamLimitingDeviceOffset | (300A,064B): RT Beam Limiting Device Offset
RTBeamLimitingDeviceOpeningSequence | (300A,0656): RT Beam Limiting Device Opening Sequence
RTBeamLimitingDeviceProximalDistance | (300A,0642): RT Beam Limiting Device Proximal Distance
RTBeamLimitingDeviceType | (300A,00B8): RT Beam Limiting Device Type
RTBeamModifierDefinitionDistance | (300A,0688): RT Beam Modifier Definition Distance
RTControlPointIndex | (300A,0600): RT Control Point Index
RTDeliveryStartPatientPositionSequence | (300A,0789): RT Delivery Start Patient Position Sequence
RTDeviceDistanceReferenceLocationCodeSequence | (300A,0659): RT Device Distance Reference Location Code Sequence
RTDiagnosisCodeSequence | (3010,005D): RT Diagnosis Code Sequence
RTDoseROISequence | (3004,0010): RT Dose ROI Sequence
RTImageDescription | (3002,0004): RT Image Description
RTImageFrameContextSequence |
RTImageFrameGeneralContentSequence |
RTImageFrameImagingDevicePositionSequence |
RTImageFramekVRadiationAcquisitionSequence |
RTImageFrameMVRadiationAcquisitionSequence |
RTImageFrameRadiationAcquisitionSequence |
RTImageLabel | (3002,0002): RT Image Label
RTImageName | (3002,0003): RT Image Name
RTImageOrientation | (3002,0010): RT Image Orientation
RTImagePlane | (3002,000C): RT Image Plane
RTImagePosition | (3002,0012): RT Image Position
RTImageScopeSequence |
RTImageSID | (3002,0026): RT Image SID
RTPatientPositionDisplacementSequence | (300A,0798): RT Patient Position Displacement Sequence
RTPatientPositionScopeSequence | (300A,0784): RT Patient Position Scope Sequence
RTPatientPositionSequence | (300A,0799): RT Patient Position Sequence
RTPhysicianIntentIndex | (3010,0058): RT Physician Intent Index
RTPhysicianIntentInputInstanceSequence | (3010,005F): RT Physician Intent Input Instance Sequence
RTPhysicianIntentNarrative | (3010,005A): RT Physician Intent Narrative
RTPhysicianIntentPredecessorSequence | (3010,0055): RT Physician Intent Predecessor Sequence
RTPhysicianIntentSequence | (3010,0057): RT Physician Intent Sequence
RTPlanDate | (300A,0006): RT Plan Date
RTPlanDescription | (300A,0004): RT Plan Description
RTPlanGeometry | (300A,000C): RT Plan Geometry
RTPlanLabel | (300A,0002): RT Plan Label
RTPlanName | (300A,0003): RT Plan Name
RTPlanRelationship | (300A,0055): RT Plan Relationship
RTPlanTime | (300A,0007): RT Plan Time
RTPrescriptionIndex | (3010,003C): RT Prescription Index
RTPrescriptionLabel | (3010,0054): RT Prescription Label
RTPrescriptionSequence | (3010,006B): RT Prescription Sequence
RTProtocolCodeSequence | (3010,005B): RT Protocol Code Sequence
RTRadiationPhysicalAndGeometricContentDetailFlag | (300A,0638): RT Radiation Physical and Geometric Content Detail Flag
RTRadiationSalvageRecordControlPointSequence | (300A,0722): RT Radiation Salvage Record Control Point Sequence
RTRadiationSequence | (300A,0616): RT Radiation Sequence
RTRadiationSetDeliveryNumber | (300A,0704): RT Radiation Set Delivery Number
RTRadiationSetDeliveryUsage | (300A,079E): RT Radiation Set Delivery Usage
RTRadiationSetIntent | (300A,0637): RT Radiation Set Intent
RTRadiationSetUsage | (300A,0707): RT Radiation Set Usage
RTRadiationTaskSequence | (300A,0797): RT Radiation Task Sequence
RTRadiationUsage | (300A,0701): RT Radiation Usage
RTRecordFlag | (300A,0639): RT Record Flag
RTReferencedSeriesSequence | (3006,0014): RT Referenced Series Sequence
RTReferencedStudySequence | (3006,0012): RT Referenced Study Sequence
RTRelatedROISequence | (3006,0030): RT Related ROI Sequence
RTROIIdentificationCodeSequence | (3006,0086): RT ROI Identification Code Sequence
RTROIInterpretedType | (3006,00A4): RT ROI Interpreted Type
RTROIObservationsSequence | (3006,0080): RT ROI Observations Sequence
RTROIRelationship | (3006,0033): RT ROI Relationship
RTSegmentAnnotationIndex | (3010,003D): RT Segment Annotation Index
RTSegmentAnnotationSequence | (3010,002A): RT Segment Annotation Sequence
RTToleranceSetLabel | (300A,062A): RT Tolerance Set Label
RTToleranceSetSequence | (300A,0629): RT Tolerance Set Sequence
RTTreatmentApproachLabel | (3010,0056): RT Treatment Approach Label
RTTreatmentFractionCompletionStatus | (300A,0706): RT Treatment Fraction Completion Status
RTTreatmentIntentType | (3010,0059): RT Treatment Intent Type
RTTreatmentPhaseIndex | (3010,003A): RT Treatment Phase Index
RTTreatmentPhaseIntentPresenceFlag | (3010,0045): RT Treatment Phase Intent Presence Flag
RTTreatmentPhaseIntervalSequence | (3010,004E): RT Treatment Phase Interval Sequence
RTTreatmentPhaseUID | (3010,003B): RT Treatment Phase UID
RTTreatmentPreparationPatientPositionSequence | (300A,078A): RT Treatment Preparation Patient Position Sequence
RTTreatmentSourceCoordinates | (3010,0093): RT Treatment Source Coordinates
RTTreatmentTechniqueCodeSequence | (3010,0080): RT Treatment Technique Code Sequence
RTTreatmentTerminationReasonCodeSequence | (300A,0715): RT Treatment Termination Reason Code Sequence
RTTreatmentTerminationStatus | (300A,0714): RT Treatment Termination Status
RTVCommunicationSOPClassUID | (0002,0032): RTV Communication SOP Class UID
RTVCommunicationSOPInstanceUID | (0002,0033): RTV Communication SOP Instance UID
RTVFlowActualFrameDuration | (0002,0038): RTV Flow Actual Frame Duration
RTVFlowIdentifier | (0002,0036): RTV Flow Identifier
RTVFlowRTPSamplingRate | (0002,0037): RTV Flow RTP Sampling Rate
RTVMetaInformationVersion | (0002,0031): RTV Meta Information Version
RTVSourceIdentifier | (0002,0035): RTV Source Identifier
RunLengthTriplet | (1000,xxx1): Run Length Triplet
RWavePointer | (0028,6040): R Wave Pointer
RWaveTimeVector | (0018,6060): R Wave Time Vector
SafePositionExitDate | (3008,0162): Safe Position Exit Date
SafePositionExitTime | (3008,0164): Safe Position Exit Time
SafePositionReturnDate | (3008,0166): Safe Position Return Date
SafePositionReturnTime | (3008,0168): Safe Position Return Time
SampleRate | (50xx,2008): Sample Rate
SamplesPerPixel | (0028,0002): Samples per Pixel
SamplesPerPixelUsed | (0028,0003): Samples per Pixel Used
SamplingFrequency | (003A,001A): Sampling Frequency
SamplingStepSize | (0070,1607): Sampling Step Size
SAR | (0018,1316): SAR
Saturation | (0016,0049): Saturation
SaturationRecovery | (0018,9024): Saturation Recovery
ScanArc | (0018,1143): Scan Arc
ScanArcType |
ScanLength | (0018,1302): Scan Length
ScanMode | (300A,0308): Scan Mode
ScannerSettingsSequence | (0014,409A): Scanner Settings Sequence
ScanningSequence | (0018,0020): Scanning Sequence
ScanningSpotSize | (300A,0398): Scanning Spot Size
ScanOptions | (0018,0022): Scan Options
ScanPatternTypeCodeSequence | (0022,1618): Scan Pattern Type Code Sequence
ScanProcedure | (0014,409B): Scan Procedure
ScanProgressionDirection | (0054,0501): Scan Progression Direction
ScanSpotMetersetsDelivered | (3008,0047): Scan Spot Metersets Delivered
ScanSpotMetersetWeights | (300A,0396): Scan Spot Meterset Weights
ScanSpotPositionMap | (300A,0394): Scan Spot Position Map
ScanSpotPrescribedIndices | (300A,0391): Scan Spot Prescribed Indices
ScanSpotReordered | (300A,0393): Scan Spot Reordered
ScanSpotReorderingAllowed | (300A,0395): Scan Spot Reordering Allowed
ScanSpotSizesDelivered | (300A,0399): Scan Spot Sizes Delivered
ScanSpotTimeOffset | (300A,038F): Scan Spot Time Offset
ScanSpotTuneID | (300A,0390): Scan Spot Tune ID
ScanStartPositionSequence |
ScanStopPositionSequence |
ScanType | (4010,1048): Scan Type
ScanVelocity | (0018,1300): Scan Velocity
ScatterCorrected | (0018,9760): Scatter Corrected
ScatterCorrectionMethod | (0054,1105): Scatter Correction Method
ScatterFractionFactor | (0054,1323): Scatter Fraction Factor
SceneCaptureType | (0016,0046): Scene Capture Type
SceneType | (0016,003B): Scene Type
ScheduledAdmissionDate | (0038,001A): Scheduled Admission Date
ScheduledAdmissionTime | (0038,001B): Scheduled Admission Time
ScheduledDischargeDate | (0038,001C): Scheduled Discharge Date
ScheduledDischargeTime | (0038,001D): Scheduled Discharge Time
ScheduledHumanPerformersSequence | (0040,4034): Scheduled Human Performers Sequence
ScheduledPatientInstitutionResidence | (0038,001E): Scheduled Patient Institution Residence
ScheduledPerformingPhysicianIdentificationSequence | (0040,000B): Scheduled Performing Physician Identification Sequence
ScheduledPerformingPhysicianName | (0040,0006): Scheduled Performing Physician's Name
ScheduledProcedureStepDescription | (0040,0007): Scheduled Procedure Step Description
ScheduledProcedureStepEndDate | (0040,0004): Scheduled Procedure Step End Date
ScheduledProcedureStepEndTime | (0040,0005): Scheduled Procedure Step End Time
ScheduledProcedureStepExpirationDateTime | (0040,4008): Scheduled Procedure Step Expiration DateTime
ScheduledProcedureStepID | (0040,0009): Scheduled Procedure Step ID
ScheduledProcedureStepLocation | (0040,0011): Scheduled Procedure Step Location
ScheduledProcedureStepModificationDateTime | (0040,4010): Scheduled Procedure Step Modification DateTime
ScheduledProcedureStepPriority | (0074,1200): Scheduled Procedure Step Priority
ScheduledProcedureStepSequence | (0040,0100): Scheduled Procedure Step Sequence
ScheduledProcedureStepStartDate | (0040,0002): Scheduled Procedure Step Start Date
ScheduledProcedureStepStartDateTime | (0040,4005): Scheduled Procedure Step Start DateTime
ScheduledProcedureStepStartTime | (0040,0003): Scheduled Procedure Step Start Time
ScheduledProcedureStepStatus | (0040,0020): Scheduled Procedure Step Status
ScheduledProcessingApplicationsCodeSequence | (0040,4004): Scheduled Processing Applications Code Sequence
ScheduledProcessingParametersSequence | (0074,1210): Scheduled Processing Parameters Sequence
ScheduledProtocolCodeSequence | (0040,0008): Scheduled Protocol Code Sequence
ScheduledSpecimenSequence | (0040,0500): Scheduled Specimen Sequence
ScheduledStationAETitle | (0040,0001): Scheduled Station AE Title
ScheduledStationClassCodeSequence | (0040,4026): Scheduled Station Class Code Sequence
ScheduledStationGeographicLocationCodeSequence | (0040,4027): Scheduled Station Geographic Location Code Sequence
ScheduledStationName | (0040,0010): Scheduled Station Name
ScheduledStationNameCodeSequence | (0040,4025): Scheduled Station Name Code Sequence
ScheduledStepAttributesSequence | (0040,0270): Scheduled Step Attributes Sequence
ScheduledStudyLocation | (0032,1020): Scheduled Study Location
ScheduledStudyLocationAETitle | (0032,1021): Scheduled Study Location AE Title
ScheduledStudyStartDate | (0032,1000): Scheduled Study Start Date
ScheduledStudyStartTime | (0032,1001): Scheduled Study Start Time
ScheduledStudyStopDate | (0032,1010): Scheduled Study Stop Date
ScheduledStudyStopTime | (0032,1011): Scheduled Study Stop Time
ScheduledWorkitemCodeSequence | (0040,4018): Scheduled Workitem Code Sequence
ScopeOfInventorySequence |
SCPStatus | (0074,1242): SCP Status
ScreeningBaselineMeasured | (0024,0120): Screening Baseline Measured
ScreeningBaselineMeasuredSequence | (0024,0122): Screening Baseline Measured Sequence
ScreeningBaselineType | (0024,0124): Screening Baseline Type
ScreeningBaselineValue | (0024,0126): Screening Baseline Value
ScreeningTestModeCodeSequence | (0024,0016): Screening Test Mode Code Sequence
ScreenMinimumColorBitDepth | (0072,010C): Screen Minimum Color Bit Depth
ScreenMinimumGrayscaleBitDepth | (0072,010A): Screen Minimum Grayscale Bit Depth
SeamLineIndex | (0052,0036): Seam Line Index
SeamLineLocation | (0052,0033): Seam Line Location
SecondaryApprovalStatus | (0014,0101): Secondary Approval Status
SecondaryCaptureDeviceID | (0018,1010): Secondary Capture Device ID
SecondaryCaptureDeviceManufacturer | (0018,1016): Secondary Capture Device Manufacturer
SecondaryCaptureDeviceManufacturerModelName | (0018,1018): Secondary Capture Device Manufacturer's Model Name
SecondaryCaptureDeviceSoftwareVersions | (0018,1019): Secondary Capture Device Software Versions
SecondaryCountsAccumulated | (0054,1311): Secondary Counts Accumulated
SecondaryCountsType | (0054,1220): Secondary Counts Type
SecondaryInspectionMethodSequence | (4010,107D): Secondary Inspection Method Sequence
SecondaryPositionerIncrement | (0018,9515): Secondary Positioner Increment
SecondaryPositionerIncrementSign | (0018,9519): Secondary Positioner Increment Sign
SecondaryPositionerScanArc | (0018,9509): Secondary Positioner Scan Arc
SecondaryPositionerScanStartAngle | (0018,9511): Secondary Positioner Scan Start Angle
SecondaryReviewDate | (0014,0102): Secondary Review Date
SecondaryReviewerName | (0014,0104): Secondary Reviewer Name
SecondaryReviewTime | (0014,0103): Secondary Review Time
SegmentAlgorithmName | (0062,0009): Segment Algorithm Name
SegmentAlgorithmType | (0062,0008): Segment Algorithm Type
SegmentAnnotationCategoryCodeSequence | (3010,002B): Segment Annotation Category Code Sequence
SegmentAnnotationTypeCodeSequence | (3010,002C): Segment Annotation Type Code Sequence
SegmentAnnotationTypeModifierCodeSequence | (3010,002F): Segment Annotation Type Modifier Code Sequence
SegmentationAlgorithmIdentificationSequence | (0062,0007): Segmentation Algorithm Identification Sequence
SegmentationCreationTemplateLabel | (3010,001E): Segmentation Creation Template Label
SegmentationFractionalType | (0062,0010): Segmentation Fractional Type
SegmentationTemplateUID | (3010,001F): Segmentation Template UID
SegmentationType | (0062,0001): Segmentation Type
SegmentCharacteristicsPrecedence | (3010,0029): Segment Characteristics Precedence
SegmentCharacteristicsSequence | (3010,0027): Segment Characteristics Sequence
SegmentDescription | (0062,0006): Segment Description
SegmentedAlphaPaletteColorLookupTableData | (0028,1224): Segmented Alpha Palette Color Lookup Table Data
SegmentedBluePaletteColorLookupTableData | (0028,1223): Segmented Blue Palette Color Lookup Table Data
SegmentedGreenPaletteColorLookupTableData | (0028,1222): Segmented Green Palette Color Lookup Table Data
SegmentedKSpaceTraversal | (0018,9033): Segmented k-Space Traversal
SegmentedPropertyCategoryCodeSequence | (0062,0003): Segmented Property Category Code Sequence
SegmentedPropertyTypeCodeSequence | (0062,000F): Segmented Property Type Code Sequence
SegmentedPropertyTypeModifierCodeSequence | (0062,0011): Segmented Property Type Modifier Code Sequence
SegmentedRedPaletteColorLookupTableData | (0028,1221): Segmented Red Palette Color Lookup Table Data
SegmentedRTAccessoryDeviceSequence | (3010,0026): Segmented RT Accessory Device Sequence
SegmentIdentificationSequence | (0062,000A): Segment Identification Sequence
SegmentLabel | (0062,0005): Segment Label
SegmentNumber | (0062,0004): Segment Number
SegmentReferenceIndex | (3010,0022): Segment Reference Index
SegmentReferenceSequence | (3010,0021): Segment Reference Sequence
SegmentSequence | (0062,0002): Segment Sequence
SegmentsOverlap | (0062,0013): Segments Overlap
SegmentSurfaceGenerationAlgorithmIdentificationSequence | (0066,002D): Segment Surface Generation Algorithm Identification Sequence
SegmentSurfaceSourceInstanceSequence | (0066,002E): Segment Surface Source Instance Sequence
SelectedFrameFunctionalGroupsSequence |
SelectedFrameNumber |
SelectedSegmentalOphthalmicAxialLengthSequence | (0022,1257): Selected Segmental Ophthalmic Axial Length Sequence
SelectedTotalOphthalmicAxialLengthSequence | (0022,1260): Selected Total Ophthalmic Axial Length Sequence
SelectorAEValue | (0072,005E): Selector AE Value
SelectorASValue | (0072,005F): Selector AS Value
SelectorAttribute | (0072,0026): Selector Attribute
SelectorAttributeKeyword | (0082,0019): Selector Attribute Keyword
SelectorAttributeName | (0082,0018): Selector Attribute Name
SelectorAttributePrivateCreator | (0072,0056): Selector Attribute Private Creator
SelectorAttributeVR | (0072,0050): Selector Attribute VR
SelectorATValue | (0072,0060): Selector AT Value
SelectorCodeSequenceValue | (0072,0080): Selector Code Sequence Value
SelectorCSValue | (0072,0062): Selector CS Value
SelectorDAValue | (0072,0061): Selector DA Value
SelectorDSValue | (0072,0072): Selector DS Value
SelectorDTValue | (0072,0063): Selector DT Value
SelectorFDValue | (0072,0074): Selector FD Value
SelectorFLValue | (0072,0076): Selector FL Value
SelectorISValue | (0072,0064): Selector IS Value
SelectorLOValue | (0072,0066): Selector LO Value
SelectorLTValue | (0072,0068): Selector LT Value
SelectorOBValue | (0072,0065): Selector OB Value
SelectorODValue | (0072,0073): Selector OD Value
SelectorOFValue | (0072,0067): Selector OF Value
SelectorOLValue | (0072,0075): Selector OL Value
SelectorOVValue | (0072,0081): Selector OV Value
SelectorOWValue | (0072,0069): Selector OW Value
SelectorPNValue | (0072,006A): Selector PN Value
SelectorSequencePointer | (0072,0052): Selector Sequence Pointer
SelectorSequencePointerItems | (0074,1057): Selector Sequence Pointer Items
SelectorSequencePointerPrivateCreator | (0072,0054): Selector Sequence Pointer Private Creator
SelectorSHValue | (0072,006C): Selector SH Value
SelectorSLValue | (0072,007C): Selector SL Value
SelectorSSValue | (0072,007E): Selector SS Value
SelectorSTValue | (0072,006E): Selector ST Value
SelectorSVValue | (0072,0082): Selector SV Value
SelectorTMValue | (0072,006B): Selector TM Value
SelectorUCValue | (0072,006F): Selector UC Value
SelectorUIValue | (0072,007F): Selector UI Value
SelectorULValue | (0072,0078): Selector UL Value
SelectorUNValue | (0072,006D): Selector UN Value
SelectorURValue | (0072,0071): Selector UR Value
SelectorUSValue | (0072,007A): Selector US Value
SelectorUTValue | (0072,0070): Selector UT Value
SelectorUVValue | (0072,0083): Selector UV Value
SelectorValueNumber | (0072,0028): Selector Value Number
SelfTimerMode | (0016,0019): Self Timer Mode
SendingApplicationEntityTitle | (0002,0017): Sending Application Entity Title
SendingPresentationAddress | (0002,0027): Sending Presentation Address
SensingMethod | (0016,0039): Sensing Method
Sensitivity | (0018,6000): Sensitivity
SensitivityCalibrated | (0018,9767): Sensitivity Calibrated
SensitivityType | (0016,001A): Sensitivity Type
SensitivityValue | (0024,0094): Sensitivity Value
SensorName | (0014,3022): Sensor Name
SensorTemperature | (0014,3028): Sensor Temperature
SequenceDelimitationItem | (FFFE,E0DD): Sequence Delimitation Item
SequenceName | (0018,0024): Sequence Name
SequenceOfCompressedData | (0028,0403): Sequence of Compressed Data
SequenceOfUltrasoundRegions | (0018,6011): Sequence of Ultrasound Regions
SequenceVariant | (0018,0021): Sequence Variant
SequencingIndicatorTrial | (0040,A060): Sequencing Indicator (Trial)
SeriesDate | (0008,0021): Series Date
SeriesDescription | (0008,103E): Series Description
SeriesDescriptionCodeSequence | (0008,103F): Series Description Code Sequence
SeriesInstanceUID | (0020,000E): Series Instance UID
SeriesInStudy | (0020,1000): Series in Study
SeriesNumber | (0020,0011): Series Number
SeriesTime | (0008,0031): Series Time
SeriesType | (0054,1000): Series Type
ServiceEpisodeDescription | (0038,0062): Service Episode Description
ServiceEpisodeID | (0038,0060): Service Episode ID
SettlingPhaseFrame | (0018,9624): Settling Phase Frame
SetupDeviceDescription | (300A,01BA): Setup Device Description
SetupDeviceLabel | (300A,01B8): Setup Device Label
SetupDeviceParameter | (300A,01BC): Setup Device Parameter
SetupDeviceSequence | (300A,01B4): Setup Device Sequence
SetupDeviceType | (300A,01B6): Setup Device Type
SetupImageComment | (300A,0402): Setup Image Comment
SetupReferenceDescription | (300A,01D0): Setup Reference Description
SetupTechnique | (300A,01B0): Setup Technique
SetupTechniqueDescription | (300A,01B2): Setup Technique Description
ShadingStyle | (0070,1701): Shading Style
ShadowColorCIELabValue | (0070,0247): Shadow Color CIELab Value
ShadowOffsetX | (0070,0245): Shadow Offset X
ShadowOffsetY | (0070,0246): Shadow Offset Y
ShadowOpacity | (0070,0258): Shadow Opacity
ShadowStyle | (0070,0244): Shadow Style
ShapeType | (0070,0306): Shape Type
SharedFunctionalGroupsSequence | (5200,9229): Shared Functional Groups Sequence
Sharpness | (0016,004A): Sharpness
ShieldingDeviceDescription | (300A,01A6): Shielding Device Description
ShieldingDeviceLabel | (300A,01A4): Shielding Device Label
ShieldingDevicePosition | (300A,01A8): Shielding Device Position
ShieldingDeviceSequence | (300A,01A0): Shielding Device Sequence
ShieldingDeviceType | (300A,01A2): Shielding Device Type
ShiftTableSize | (1000,xxx4): Shift Table Size
ShiftTableTriplet | (1000,xxx5): Shift Table Triplet
Shininess | (0070,1706): Shininess
ShortTermFluctuation | (0024,0075): Short Term Fluctuation
ShortTermFluctuationCalculated | (0024,0074): Short Term Fluctuation Calculated
ShortTermFluctuationProbability | (0024,0077): Short Term Fluctuation Probability
ShortTermFluctuationProbabilityCalculated | (0024,0076): Short Term Fluctuation Probability Calculated
ShotDurationTime | (0080,0004): Shot Duration Time
ShotOffsetTime | (0080,0005): Shot Offset Time
ShowAcquisitionTechniquesFlag | (0072,0716): Show Acquisition Techniques Flag
ShowGraphicAnnotationFlag | (0072,0712): Show Graphic Annotation Flag
ShowGrayscaleInverted | (0072,0706): Show Grayscale Inverted
ShowImageTrueSizeFlag | (0072,0710): Show Image True Size Flag
ShowPatientDemographicsFlag | (0072,0714): Show Patient Demographics Flag
ShowTickLabel | (0070,0278): Show Tick Label
ShutterLeftVerticalEdge | (0018,1602): Shutter Left Vertical Edge
ShutterLowerHorizontalEdge | (0018,1608): Shutter Lower Horizontal Edge
ShutterOverlayGroup | (0018,1623): Shutter Overlay Group
ShutterPresentationColorCIELabValue | (0018,1624): Shutter Presentation Color CIELab Value
ShutterPresentationValue | (0018,1622): Shutter Presentation Value
ShutterRightVerticalEdge | (0018,1604): Shutter Right Vertical Edge
ShutterShape | (0018,1600): Shutter Shape
ShutterSpeedValue | (0016,0021): Shutter Speed Value
ShutterUpperHorizontalEdge | (0018,1606): Shutter Upper Horizontal Edge
SignalDomainColumns | (0028,9003): Signal Domain Columns
SignalDomainRows | (0028,9235): Signal Domain Rows
SignalToNoiseRatio | (0022,1155): Signal to Noise Ratio
Signature | (0400,0120): Signature
SimpleFrameList | (0008,1161): Simple Frame List
SimulatedKeratometricCylinderSequence | (0046,0218): Simulated Keratometric Cylinder Sequence
SingleCollimationWidth | (0018,9306): Single Collimation Width
SkipBeats | (0018,1086): Skip Beats
SkipFrameRangeFlag | (0008,9460): Skip Frame Range Flag
SlabOrientation | (0018,9105): Slab Orientation
SlabThickness | (0018,9104): Slab Thickness
SliceLocation | (0020,1041): Slice Location
SliceLocationVector | (0018,2005): Slice Location Vector
SliceProgressionDirection | (0054,0500): Slice Progression Direction
SliceSensitivityFactor | (0054,1320): Slice Sensitivity Factor
SliceThickness | (0018,0050): Slice Thickness
SliceVector | (0054,0080): Slice Vector
SlideIdentifier | (0040,06FA): Slide Identifier
SmallestImagePixelValue | (0028,0106): Smallest Image Pixel Value
SmallestImagePixelValueInPlane | (0028,0110): Smallest Image Pixel Value in Plane
SmallestPixelValueInSeries | (0028,0108): Smallest Pixel Value in Series
SmallestValidPixelValue | (0028,0104): Smallest Valid Pixel Value()
SmokingStatus | (0010,21A0): Smoking Status
SmoothingType | (2010,0080): Smoothing Type
SnoutID | (300A,030F): Snout ID
SnoutPosition | (300A,030D): Snout Position
SnoutPositionTolerance | (300A,004B): Snout Position Tolerance
SnoutSequence | (300A,030C): Snout Sequence
SNRThreshold | (4010,1073): SNR Threshold
SoftcopyVOILUTSequence | (0028,3110): Softcopy VOI LUT Sequence
SoftTissueFocusThermalIndex | (0018,5028): Soft Tissue-focus Thermal Index
SoftTissueSurfaceThermalIndex | (0018,5029): Soft Tissue-surface Thermal Index
SoftTissueThermalIndex | (0018,5027): Soft Tissue Thermal Index
SoftwareVersions | (0018,1020): Software Versions
SOPAuthorizationComment | (0100,0424): SOP Authorization Comment
SOPAuthorizationDateTime | (0100,0420): SOP Authorization DateTime
SOPClassesInStudy | (0008,0062): SOP Classes in Study
SOPClassesSupported | (0008,115A): SOP Classes Supported
SOPClassUID | (0008,0016): SOP Class UID
SOPInstanceStatus | (0100,0410): SOP Instance Status
SOPInstanceUID | (0008,0018): SOP Instance UID
SOPInstanceUIDOfConcatenationSource | (0020,0242): SOP Instance UID of Concatenation Source
SortByCategory | (0072,0602): Sort-by Category
SortingDirection | (0072,0604): Sorting Direction
SortingOperationsSequence | (0072,0600): Sorting Operations Sequence
SoundPathLength | (0014,405A): Sound Path Length
SoundSpeedCorrectionMechanismCodeSequence |
SourceAcquisitionBeamNumber | (0018,9939): Source Acquisition Beam Number
SourceAcquisitionProtocolElementNumber | (0018,9938): Source Acquisition Protocol Element Number
SourceApplicationEntityTitle | (0002,0016): Source Application Entity Title
SourceApplicatorID | (300A,0291): Source Applicator ID
SourceApplicatorLength | (300A,0296): Source Applicator Length
SourceApplicatorManufacturer | (300A,0298): Source Applicator Manufacturer
SourceApplicatorName | (300A,0294): Source Applicator Name
SourceApplicatorNumber | (300A,0290): Source Applicator Number
SourceApplicatorStepSize | (300A,02A0): Source Applicator Step Size
SourceApplicatorTipLength | (300A,0274): Source Applicator Tip Length
SourceApplicatorType | (300A,0292): Source Applicator Type
SourceApplicatorWallNominalThickness | (300A,029C): Source Applicator Wall Nominal Thickness
SourceApplicatorWallNominalTransmission | (300A,029E): Source Applicator Wall Nominal Transmission
SourceAxisDistance | (300A,00B4): Source-Axis Distance
SourceConceptualVolumeSequence | (3010,0018): Source Conceptual Volume Sequence
SourceConceptualVolumeUID | (3010,0015): Source Conceptual Volume UID
SourceDescription | (300A,021C): Source Description
SourceEncapsulationNominalThickness | (300A,0222): Source Encapsulation Nominal Thickness
SourceEncapsulationNominalTransmission | (300A,0224): Source Encapsulation Nominal Transmission
SourceEndDateTime | (0018,936A): Source End DateTime
SourceFrameOfReferenceUID | (0064,0003): Source Frame of Reference UID
SourceHangingProtocolSequence | (0072,0012): Source Hanging Protocol Sequence
SourceIdentifier | (0034,0005): Source Identifier
SourceImageCornealProcessedDataSequence | (0046,0244): Source Image Corneal Processed Data Sequence
SourceImageEvidenceSequence | (0008,9154): Source Image Evidence Sequence
SourceImageIDs | (0020,31xx): Source Image IDs()
SourceImageSequence | (0008,2112): Source Image Sequence
SourceInstanceSequence | (0042,0013): Source Instance Sequence
SourceIrradiationEventSequence | (0008,3011): Source Irradiation Event Sequence
SourceIsotopeHalfLife | (300A,0228): Source Isotope Half Life
SourceIsotopeName | (300A,0226): Source Isotope Name
SourceManufacturer | (300A,0216): Source Manufacturer
SourceModelID | (300A,021B): Source Model ID
SourceMovementType | (300A,0288): Source Movement Type
SourceNumber | (300A,0212): Source Number
SourceOfAnteriorChamberDepthDataCodeSequence | (0022,1133): Source of Anterior Chamber Depth Data Code Sequence
SourceOfCornealSizeDataCodeSequence | (0022,1036): Source of Corneal Size Data Code Sequence
SourceOfCorneaMeasurementDataCodeSequence | (0046,0111): Source of Cornea Measurement Data Code Sequence
SourceOfLensThicknessDataCodeSequence | (0022,1132): Source of Lens Thickness Data Code Sequence
SourceOfOphthalmicAxialLengthCodeSequence | (0022,1035): Source of Ophthalmic Axial Length Code Sequence
SourceOfPreviousValues | (0400,0564): Source of Previous Values
SourceOfRefractiveMeasurementsCodeSequence | (0022,1135): Source of Refractive Measurements Code Sequence
SourceOfRefractiveMeasurementsSequence | (0022,1134): Source of Refractive Measurements Sequence
SourceOrientation | (4010,1060): Source Orientation
SourcePatientGroupIdentificationSequence | (0010,0026): Source Patient Group Identification Sequence
SourcePixelPlanesCharacteristicsSequence | (3006,004A): Source Pixel Planes Characteristics Sequence
SourcePosition | (4010,1061): Source Position
SourcePresentationAddress | (0002,0026): Source Presentation Address
SourceReconstructionProtocolElementNumber | (0018,993A): Source Reconstruction Protocol Element Number
SourceRollAngle | (300A,067A): Source Roll Angle
SourceSequence | (300A,0210): Source Sequence
SourceSerialNumber | (3008,0105): Source Serial Number
SourceSeriesInformationSequence |
SourceSeriesSequence |
SourceStartDateTime | (0018,9369): Source Start DateTime
SourceStrength | (300A,022B): Source Strength
SourceStrengthReferenceDate | (300A,022C): Source Strength Reference Date
SourceStrengthReferenceTime | (300A,022E): Source Strength Reference Time
SourceStrengthUnits | (300A,0229): Source Strength Units
SourceToApplicatorMountingPositionDistance | (300A,0436): Source to Applicator Mounting Position Distance
SourceToBeamLimitingDeviceDistance | (300A,00BA): Source to Beam Limiting Device Distance
SourceToBlockTrayDistance | (300A,00F6): Source to Block Tray Distance
SourceToCompensatorDistance | (300A,02E2): Source to Compensator Distance
SourceToCompensatorTrayDistance | (300A,00E6): Source to Compensator Tray Distance
SourceToExternalContourDistance | (300A,0132): Source to External Contour Distance
SourceToGeneralAccessoryDistance | (300A,0425): Source to General Accessory Distance
SourceToPatientSurfaceDistance | (300A,0634): Source to Patient Surface Distance
SourceToReferenceObjectDistance | (3002,0028): Source to Reference Object Distance
SourceToSurfaceDistance | (300A,0130): Source to Surface Distance
SourceToWedgeTrayDistance | (300A,00DA): Source to Wedge Tray Distance
SourceType | (300A,0214): Source Type
SourceWaveformSequence | (003A,020A): Source Waveform Sequence
SpacingBetweenSlices | (0018,0088): Spacing Between Slices
SpatialFrequencyResponseColumnNames | (0016,000C): Spatial Frequency Response Column Names
SpatialFrequencyResponseColumns | (0016,000B): Spatial Frequency Response Columns
SpatialFrequencyResponseRows | (0016,000A): Spatial Frequency Response Rows
SpatialFrequencyResponseValues | (0016,000D): Spatial Frequency Response Values
SpatialLocationsPreserved | (0028,135A): Spatial Locations Preserved
SpatialPresaturation | (0018,9027): Spatial Pre-saturation
SpatialResolution | (0018,1050): Spatial Resolution
SpatialTransformOfDose | (3004,0005): Spatial Transform of Dose
SpecialNeeds | (0038,0050): Special Needs
SpecificAbsorptionRateDefinition | (0018,9179): Specific Absorption Rate Definition
SpecificAbsorptionRateSequence | (0018,9239): Specific Absorption Rate Sequence
SpecificAbsorptionRateValue | (0018,9181): Specific Absorption Rate Value
SpecificationSelectionGuidance | (0082,0033): Specification Selection Guidance
SpecificCharacterSet | (0008,0005): Specific Character Set
SpecificCharacterSetOfFileSetDescriptorFile | (0004,1142): Specific Character Set of File-set Descriptor File
SpecifiedChannelTotalTime | (3008,0132): Specified Channel Total Time
SpecifiedMeterset | (3008,0042): Specified Meterset
SpecifiedNumberOfPulses | (3008,0136): Specified Number of Pulses
SpecifiedPrimaryMeterset | (3008,0032): Specified Primary Meterset
SpecifiedPulseRepetitionInterval | (3008,013A): Specified Pulse Repetition Interval
SpecifiedSecondaryMeterset | (3008,0033): Specified Secondary Meterset
SpecifiedTreatmentTime | (3008,003A): Specified Treatment Time
SpecimenAccessionNumber | (0040,050A): Specimen Accession Number
SpecimenDescriptionSequence | (0040,0560): Specimen Description Sequence
SpecimenDescriptionSequenceTrial | (0040,0552): Specimen Description Sequence (Trial)
SpecimenDescriptionTrial | (0040,0553): Specimen Description (Trial)
SpecimenDetailedDescription | (0040,0602): Specimen Detailed Description
SpecimenIdentifier | (0040,0551): Specimen Identifier
SpecimenLabelInImage | (0048,0010): Specimen Label in Image
SpecimenLocalizationContentItemSequence | (0040,0620): Specimen Localization Content Item Sequence
SpecimenPreparationSequence | (0040,0610): Specimen Preparation Sequence
SpecimenPreparationStepContentItemSequence | (0040,0612): Specimen Preparation Step Content Item Sequence
SpecimenReferenceSequence | (0048,0110): Specimen Reference Sequence
SpecimenSequence | (0040,0550): Specimen Sequence
SpecimenShortDescription | (0040,0600): Specimen Short Description
SpecimenTypeCodeSequence | (0040,059A): Specimen Type Code Sequence
SpecimenUID | (0040,0554): Specimen UID
SpectrallySelectedExcitation | (0018,9026): Spectrally Selected Excitation
SpectrallySelectedSuppression | (0018,9025): Spectrally Selected Suppression
SpectralSensitivity | (0016,0017): Spectral Sensitivity
SpectralWidth | (0018,9052): Spectral Width
SpectroscopyAcquisitionDataColumns | (0018,9127): Spectroscopy Acquisition Data Columns
SpectroscopyAcquisitionOutOfPlanePhaseSteps | (0018,9159): Spectroscopy Acquisition Out-of-plane Phase Steps
SpectroscopyAcquisitionPhaseColumns | (0018,9234): Spectroscopy Acquisition Phase Columns
SpectroscopyAcquisitionPhaseRows | (0018,9095): Spectroscopy Acquisition Phase Rows
SpectroscopyData | (5600,0020): Spectroscopy Data
SpecularReflectionIntensity | (0070,1705): Specular Reflection Intensity
SpherePower | (0046,0146): Sphere Power
SphericalLensPower | (0022,0007): Spherical Lens Power
SpiralPitchFactor | (0018,9311): Spiral Pitch Factor
Spoiling | (0018,9016): Spoiling
StackID | (0020,9056): Stack ID
StageCodeSequence | (0040,000A): Stage Code Sequence
StageName | (0008,2120): Stage Name
StageNumber | (0008,2122): Stage Number
StandardOutputSensitivity | (0016,001B): Standard Output Sensitivity
StartAcquisitionDateTime | (0018,9516): Start Acquisition DateTime
StartAngle | (0054,0200): Start Angle
StartCardiacTriggerCountThreshold | (0018,9717): Start Cardiac Trigger Count Threshold
StartCumulativeMeterset |
StartCumulativeMetersetWeight | (300C,0008): Start Cumulative Meterset Weight
StartCumulativeTimeWeight | (0074,1407): Start Cumulative Time Weight
StartDensityThreshold | (0018,9715): Start Density Threshold
StartingMetersetValueKnownFlag | (300A,0723): Starting Meterset Value Known Flag
StartingRespiratoryAmplitude | (0020,9246): Starting Respiratory Amplitude
StartingRespiratoryPhase | (0020,9247): Starting Respiratory Phase
StartMeterset | (3008,0078): Start Meterset
StartRelativeDensityDifferenceThreshold | (0018,9716): Start Relative Density Difference Threshold
StartRespiratoryTriggerCountThreshold | (0018,9718): Start Respiratory Trigger Count Threshold
StartTrim | (0008,2142): Start Trim
StationAETitle | (0008,0055): Station AE Title
StationName | (0008,1010): Station Name
Status | (0000,0900): Status
SteadyStatePulseSequence | (0018,9017): Steady State Pulse Sequence
SteepCornealAxisSequence | (0046,0112): Steep Corneal Axis Sequence
SteepKeratometricAxisSequence | (0046,0074): Steep Keratometric Axis Sequence
SteeringAngle | (0018,6036): Steering Angle
StereoBaselineAngle | (0022,0010): Stereo Baseline Angle
StereoBaselineDisplacement | (0022,0011): Stereo Baseline Displacement
StereoHorizontalPixelOffset | (0022,0012): Stereo Horizontal Pixel Offset
StereoPairsPresent | (0022,0028): Stereo Pairs Present
StereoPairsSequence | (0022,0020): Stereo Pairs Sequence
StereoRotation | (0022,0014): Stereo Rotation
StereoVerticalPixelOffset | (0022,0013): Stereo Vertical Pixel Offset
StimuliRetestingQuantity | (0024,0042): Stimuli Retesting Quantity
StimulusArea | (0024,0025): Stimulus Area
StimulusColorCodeSequence | (0024,0021): Stimulus Color Code Sequence
StimulusPresentationTime | (0024,0028): Stimulus Presentation Time
StimulusResults | (0024,0093): Stimulus Results
StopCumulativeMeterset |
StopTrim | (0008,2143): Stop Trim
StorageMediaFileSetID | (0088,0130): Storage Media File-set ID
StorageMediaFileSetUID | (0088,0140): Storage Media File-set UID
StorageProtocolElementSequence | (0018,9936): Storage Protocol Element Sequence
StorageProtocolElementSpecificationSequence | (0018,9935): Storage Protocol Element Specification Sequence
StorageURL | (0040,4073): Storage URL
StoredInstanceBaseURI |
StoredInstanceTransferSyntaxUID |
StoredValueColorRangeSequence | (0028,1230): Stored Value Color Range Sequence
STOWRSStorageSequence | (0040,4072): STOW-RS Storage Sequence
StrainAdditionalInformation | (0010,0218): Strain Additional Information
StrainCodeSequence | (0010,0219): Strain Code Sequence
StrainDescription | (0010,0212): Strain Description
StrainNomenclature | (0010,0213): Strain Nomenclature
StrainSource | (0010,0217): Strain Source
StrainSourceRegistryCodeSequence | (0010,0215): Strain Source Registry Code Sequence
StrainStockNumber | (0010,0214): Strain Stock Number
StrainStockSequence | (0010,0216): Strain Stock Sequence
StructuredConstraintObservationSequence | (0082,000C): Structured Constraint Observation Sequence
StructuredDisplayBackgroundCIELabValue | (0072,0420): Structured Display Background CIELab Value
StructuredDisplayImageBoxSequence | (0072,0422): Structured Display Image Box Sequence
StructuredDisplayTextBoxSequence | (0072,0424): Structured Display Text Box Sequence
StructureSetDate | (3006,0008): Structure Set Date
StructureSetDescription | (3006,0006): Structure Set Description
StructureSetLabel | (3006,0002): Structure Set Label
StructureSetName | (3006,0004): Structure Set Name
StructureSetROISequence | (3006,0020): Structure Set ROI Sequence
StructureSetTime | (3006,0009): Structure Set Time
StudiesContainingOtherReferencedInstancesSequence | (0008,1200): Studies Containing Other Referenced Instances Sequence
StudyAccessEndPointsSequence |
StudyArrivalDate | (0032,1040): Study Arrival Date
StudyArrivalTime | (0032,1041): Study Arrival Time
StudyComments | (0032,4000): Study Comments
StudyCompletionDate | (0032,1050): Study Completion Date
StudyCompletionTime | (0032,1051): Study Completion Time
StudyComponentStatusID | (0032,1055): Study Component Status ID
StudyDate | (0008,0020): Study Date
StudyDescription | (0008,1030): Study Description
StudyID | (0020,0010): Study ID
StudyIDIssuer | (0032,0012): Study ID Issuer
StudyInstanceUID | (0020,000D): Study Instance UID
StudyPriorityID | (0032,000C): Study Priority ID
StudyReadDate | (0032,0034): Study Read Date
StudyReadTime | (0032,0035): Study Read Time
StudyStatusID | (0032,000A): Study Status ID
StudyTime | (0008,0030): Study Time
StudyUpdateDateTime |
StudyVerifiedDate | (0032,0032): Study Verified Date
StudyVerifiedTime | (0032,0033): Study Verified Time
SubjectArea | (0016,002A): Subject Area
SubjectDistance | (0016,0026): Subject Distance
SubjectDistanceRange | (0016,004C): Subject Distance Range
SubjectiveRefractionLeftEyeSequence | (0046,0098): Subjective Refraction Left Eye Sequence
SubjectiveRefractionRightEyeSequence | (0046,0097): Subjective Refraction Right Eye Sequence
SubjectLocation | (0016,0037): Subject Location
SubjectRelativePositionInImage | (0010,0028): Subject Relative Position in Image
SubscriptionListStatus | (0074,1244): Subscription List Status
SubstanceAdministrationApproval | (0044,0002): Substance Administration Approval
SubstanceAdministrationDateTime | (0044,0010): Substance Administration DateTime
SubstanceAdministrationDeviceID | (0044,0012): Substance Administration Device ID
SubstanceAdministrationNotes | (0044,0011): Substance Administration Notes
SubstanceAdministrationParameterSequence | (0044,0019): Substance Administration Parameter Sequence
SubtaskWorkitemCodeSequence |
SubtractionItemID | (0028,9416): Subtraction Item ID
SummarizedFilterLookupTable |
SupportedImageDisplayFormatsSequence | (2000,00A8): Supported Image Display Formats Sequence
SurfaceAsymmetryIndex | (0046,0232): Surface Asymmetry Index
SurfaceComments | (0066,0004): Surface Comments
SurfaceCount | (0066,002A): Surface Count
SurfaceEntryPoint | (300A,012E): Surface Entry Point
SurfaceMeshPrimitivesSequence | (0066,0013): Surface Mesh Primitives Sequence
SurfaceMeshZPixelOffset | (0022,1658): Surface Mesh Z-Pixel Offset
SurfaceModelDescriptionSequence | (0068,6360): Surface Model Description Sequence
SurfaceModelLabel | (0068,6380): Surface Model Label
SurfaceModelScalingFactor | (0068,6390): Surface Model Scaling Factor
SurfaceNumber | (0066,0003): Surface Number
SurfacePointColorCIELabValueData | (0080,0007): Surface Point Color CIELab Value Data
SurfacePointPresentationValueData | (0080,0006): Surface Point Presentation Value Data
SurfacePointsNormalsSequence | (0066,0012): Surface Points Normals Sequence
SurfacePointsSequence | (0066,0011): Surface Points Sequence
SurfaceProcessing | (0066,0009): Surface Processing
SurfaceProcessingAlgorithmIdentificationSequence | (0066,0035): Surface Processing Algorithm Identification Sequence
SurfaceProcessingDescription | (0066,000B): Surface Processing Description
SurfaceProcessingRatio | (0066,000A): Surface Processing Ratio
SurfaceRegularityIndex | (0046,0230): Surface Regularity Index
SurfaceScanAcquisitionTypeCodeSequence | (0080,0001): Surface Scan Acquisition Type Code Sequence
SurfaceScanModeCodeSequence | (0080,0002): Surface Scan Mode Code Sequence
SurfaceSequence | (0066,0002): Surface Sequence
SurgicallyInducedAstigmatismSequence | (0022,1045): Surgically Induced Astigmatism Sequence
SurgicalTechnique | (0076,0030): Surgical Technique
SUVType | (0054,1006): SUV Type
SwitchingPhaseNominalDuration | (0018,936C): Switching Phase Nominal Duration
SwitchingPhaseNumber | (0018,936B): Switching Phase Number
SwitchingPhaseTransitionDuration | (0018,936D): Switching Phase Transition Duration
SwivelRange | (0070,1A06): Swivel Range
SynchronizationChannel | (0018,106C): Synchronization Channel
SynchronizationFrameOfReferenceUID | (0020,0200): Synchronization Frame of Reference UID
SynchronizationTrigger | (0018,106A): Synchronization Trigger
SynchronizedImageBoxList | (0072,0432): Synchronized Image Box List
SynchronizedScrollingSequence | (0072,0210): Synchronized Scrolling Sequence
SyntheticData |
SyringeCounts | (0018,1045): Syringe Counts
SystemStatus | (0028,7006): System Status
SystemStatusComment | (0028,7007): System Status Comment
T2Preparation | (0018,9021): T2 Preparation
TableAngle | (0018,1138): Table Angle
TableColumnDefinitionSequence | (0040,A807): Table Column Definition Sequence
TableColumnNumber | (0040,A805): Table Column Number
TableCradleTiltAngle | (0018,9471): Table Cradle Tilt Angle
TableFeedPerRotation | (0018,9310): Table Feed per Rotation
TableFrameOfReferenceUID | (0020,9313): Table Frame of Reference UID
TableHeadTiltAngle | (0018,9470): Table Head Tilt Angle
TableHeight | (0018,1130): Table Height
TableHorizontalRotationAngle | (0018,9469): Table Horizontal Rotation Angle
TableLateralIncrement | (0018,1136): Table Lateral Increment
TableLongitudinalIncrement | (0018,1137): Table Longitudinal Increment
TableMotion | (0018,1134): Table Motion
TableOfParameterValues | (0018,605A): Table of Parameter Values
TableOfPixelValues | (0018,6058): Table of Pixel Values
TableOfXBreakPoints | (0018,6052): Table of X Break Points
TableOfYBreakPoints | (0018,6054): Table of Y Break Points
TablePosition | (0018,9327): Table Position
TablePositionSequence | (0018,9406): Table Position Sequence
TableRowDefinitionSequence | (0040,A806): Table Row Definition Sequence
TableRowNumber | (0040,A804): Table Row Number
TableSpeed | (0018,9309): Table Speed
TableTopEccentricAdjustedAngle | (0074,102B): Table Top Eccentric Adjusted Angle
TableTopEccentricAngle | (300A,0125): Table Top Eccentric Angle
TableTopEccentricAngleTolerance | (300A,004E): Table Top Eccentric Angle Tolerance
TableTopEccentricAxisDistance | (300A,0124): Table Top Eccentric Axis Distance
TableTopEccentricRotationDirection | (300A,0126): Table Top Eccentric Rotation Direction
TableTopLateralAdjustedPosition | (0074,1028): Table Top Lateral Adjusted Position
TableTopLateralPosition | (300A,012A): Table Top Lateral Position
TableTopLateralPositionTolerance | (300A,0053): Table Top Lateral Position Tolerance
TableTopLateralSetupDisplacement | (300A,01D6): Table Top Lateral Setup Displacement
TableTopLongitudinalAdjustedPosition | (0074,1027): Table Top Longitudinal Adjusted Position
TableTopLongitudinalPosition | (300A,0129): Table Top Longitudinal Position
TableTopLongitudinalPositionTolerance | (300A,0052): Table Top Longitudinal Position Tolerance
TableTopLongitudinalSetupDisplacement | (300A,01D4): Table Top Longitudinal Setup Displacement
TableTopPitchAdjustedAngle | (0074,102C): Table Top Pitch Adjusted Angle
TableTopPitchAngle | (300A,0140): Table Top Pitch Angle
TableTopPitchAngleTolerance | (300A,004F): Table Top Pitch Angle Tolerance
TableTopPitchRotationDirection | (300A,0142): Table Top Pitch Rotation Direction
TableTopRollAdjustedAngle | (0074,102D): Table Top Roll Adjusted Angle
TableTopRollAngle | (300A,0144): Table Top Roll Angle
TableTopRollAngleTolerance | (300A,0050): Table Top Roll Angle Tolerance
TableTopRollRotationDirection | (300A,0146): Table Top Roll Rotation Direction
TableTopVerticalAdjustedPosition | (0074,1026): Table Top Vertical Adjusted Position
TableTopVerticalPosition | (300A,0128): Table Top Vertical Position
TableTopVerticalPositionTolerance | (300A,0051): Table Top Vertical Position Tolerance
TableTopVerticalSetupDisplacement | (300A,01D2): Table Top Vertical Setup Displacement
TableTraverse | (0018,1131): Table Traverse
TableType | (0018,113A): Table Type
TableVerticalIncrement | (0018,1135): Table Vertical Increment
TableXPositionToIsocenter | (0018,9466): Table X Position to Isocenter
TableYPositionToIsocenter | (0018,9467): Table Y Position to Isocenter
TableZPositionToIsocenter | (0018,9468): Table Z Position to Isocenter
TabulatedValuesSequence | (0040,A801): Tabulated Values Sequence
TagAngleFirstAxis | (0018,9019): Tag Angle First Axis
TagAngleSecondAxis | (0018,9219): Tag Angle Second Axis
Tagging | (0018,9028): Tagging
TaggingDelay | (0018,9184): Tagging Delay
TagSpacingFirstDimension | (0018,9030): Tag Spacing First Dimension
TagSpacingSecondDimension | (0018,9218): Tag Spacing Second Dimension
TagThickness | (0018,9035): Tag Thickness
TangentialPower | (0046,0250): Tangential Power
TargetExposureIndex | (0018,1412): Target Exposure Index
TargetFrameOfReferenceUID | (0018,991E): Target Frame of Reference UID
TargetLabel | (0018,2045): Target Label
TargetLuminanceCharacteristicsSequence | (0028,7008): Target Luminance Characteristics Sequence
TargetMaterialSequence | (4010,1072): Target Material Sequence
TargetMaximumDose | (300A,0027): Target Maximum Dose
TargetMaximumLuminance | (0028,701E): Target Maximum Luminance
TargetMinimumDose | (300A,0025): Target Minimum Dose
TargetMinimumLuminance | (0028,701D): Target Minimum Luminance
TargetPositionReferenceIndicator | (0020,103F): Target Position Reference Indicator
TargetPrescriptionDose | (300A,0026): Target Prescription Dose
TargetRefraction | (0022,1037): Target Refraction
TargetUID | (0018,2042): Target UID
TargetUnderdoseVolumeFraction | (300A,0028): Target Underdose Volume Fraction
TDRType | (4010,1027): TDR Type
TelephoneNumberTrial | (0040,A354): Telephone Number (Trial)
TeletherapyRadiationType | (3010,0047): Teletherapy Radiation Type
Temperature | (0016,0030): Temperature
TemplateExtensionCreatorUID | (0040,DB0D): Template Extension Creator UID
TemplateExtensionFlag | (0040,DB0B): Template Extension Flag
TemplateExtensionOrganizationUID | (0040,DB0C): Template Extension Organization UID
TemplateIdentifier | (0040,DB00): Template Identifier
TemplateLocalVersion | (0040,DB07): Template Local Version
TemplateName | (300A,0244): Template Name
TemplateNumber | (300A,0240): Template Number
TemplateType | (300A,0242): Template Type
TemplateVersion | (0040,DB06): Template Version
TemporalPositionIdentifier | (0020,0100): Temporal Position Identifier
TemporalPositionIndex | (0020,9128): Temporal Position Index
TemporalPositionSequence | (0020,9310): Temporal Position Sequence
TemporalPositionTimeOffset | (0020,930D): Temporal Position Time Offset
TemporalRangeType | (0040,A130): Temporal Range Type
TemporalRelationshipIntervalAnchor | (3010,004F): Temporal Relationship Interval Anchor
TemporalResolution | (0020,0110): Temporal Resolution
TerminalType | (0000,4010): Terminal Type()
TerminationCardiacTriggerCountThreshold | (0018,9723): Termination Cardiac Trigger Count Threshold
TerminationCountsThreshold | (0018,9719): Termination Counts Threshold
TerminationDensityThreshold | (0018,9720): Termination Density Threshold
TerminationRelativeDensityThreshold | (0018,9721): Termination Relative Density Threshold
TerminationRespiratoryTriggerCountThreshold | (0018,9724): Termination Respiratory Trigger Count Threshold
TerminationTimeThreshold | (0018,9722): Termination Time Threshold
TestImageValidation | (0028,702B): Test Image Validation
TestPatternCodeSequence | (0028,702C): Test Pattern Code Sequence
TestPointNormalsDataFlag | (0024,0057): Test Point Normals Data Flag
TestPointNormalsSequence | (0024,0058): Test Point Normals Sequence
TestResult | (0028,7029): Test Result
TestResultComment | (0028,702A): Test Result Comment
TextColorCIELabValue | (0070,0241): Text Color CIELab Value
TextComments | (4000,4000): Text Comments()
TextFormatID | (0000,5130): Text Format ID()
TextObjectSequence | (0070,0008): Text Object Sequence
TextString | (2030,0020): Text String
TextStyleSequence | (0070,0231): Text Style Sequence
TextureLabel | (0080,0009): Texture Label
TextValue | (0040,A160): Text Value
TherapeuticRoleCategoryCodeSequence | (3010,0064): Therapeutic Role Category Code Sequence
TherapeuticRoleTypeCodeSequence | (3010,0065): Therapeutic Role Type Code Sequence
TherapyDescription | (0018,0039): Therapy Description
TherapyType | (0018,0037): Therapy Type
ThreatCategory | (4010,1012): Threat Category
ThreatCategoryDescription | (4010,1013): Threat Category Description
ThreatDetectionAlgorithmAndVersion | (4010,1029): Threat Detection Algorithm and Version
ThreatROIBase | (4010,1004): Threat ROI Base
ThreatROIBitmap | (4010,1006): Threat ROI Bitmap
ThreatROIExtents | (4010,1005): Threat ROI Extents
ThreatROIVoxelSequence | (4010,1001): Threat ROI Voxel Sequence
ThreatSequence | (4010,1011): Threat Sequence
ThreeDDegreeOfFreedomAxis | (0068,6490): 3D Degree of Freedom Axis
ThreeDImplantTemplateGroupMemberMatchingAxes | (0078,0060): 3D Implant Template Group Member Matching Axes
ThreeDImplantTemplateGroupMemberMatchingPoint | (0078,0050): 3D Implant Template Group Member Matching Point
ThreeDLineCoordinates | (0068,65D0): 3D Line Coordinates
ThreeDMatingAxes | (0068,64D0): 3D Mating Axes
ThreeDMatingPoint | (0068,64C0): 3D Mating Point
ThreeDPlaneNormal | (0068,6620): 3D Plane Normal
ThreeDPlaneOrigin | (0068,6610): 3D Plane Origin
ThreeDPointCoordinates | (0068,6590): 3D Point Coordinates
ThreeDRenderingType | (0072,0520): 3D Rendering Type
ThresholdDensity | (2040,0100): Threshold Density
ThresholdSequence | (0070,1B11): Threshold Sequence
ThresholdType | (0070,1B13): Threshold Type
ThresholdValue | (0070,1B14): Threshold Value
ThresholdValueSequence | (0070,1B12): Threshold Value Sequence
TickAlignment | (0070,0274): Tick Alignment
TickLabel | (0070,0289): Tick Label
TickLabelAlignment | (0070,0279): Tick Label Alignment
TickPosition | (0070,0288): Tick Position
TIDOffset | (0028,6120): TID Offset
Time | (0040,A122): Time
TimeBasedImageSetsSequence | (0072,0030): Time Based Image Sets Sequence
TimeDistributionProtocol | (0018,1802): Time Distribution Protocol
TimeDomainFiltering | (0018,9065): Time Domain Filtering
TimeOfDocumentCreationOrVerbalTransactionTrial | (0040,A112): Time of Document Creation or Verbal Transaction (Trial)
TimeOfFlightContrast | (0018,9015): Time of Flight Contrast
TimeOfFlightInformationUsed | (0018,9755): Time of Flight Information Used
TimeOfFrameGroupSequence | (0034,000D): Time of Frame Group Sequence
TimeOfGainCalibration | (0014,3077): Time of Gain Calibration
TimeOfLastCalibration | (0018,1201): Time of Last Calibration
TimeOfLastDetectorCalibration | (0018,700E): Time of Last Detector Calibration
TimeOfSecondaryCapture | (0018,1014): Time of Secondary Capture
TimeRange | (0008,1163): Time Range
TimeSeriesBlending | (0070,1B07): Time Series Blending
TimeSliceVector | (0054,0100): Time Slice Vector
TimeSlotInformationSequence | (0054,0072): Time Slot Information Sequence
TimeSlotNumber | (0020,0017): Time Slot Number
TimeSlotTime | (0054,0073): Time Slot Time
TimeSlotVector | (0054,0070): Time Slot Vector
TimeSource | (0018,1801): Time Source
TimezoneOffsetFromUTC | (0008,0201): Timezone Offset From UTC
TIPType | (4010,1039): TIP Type
TissueHeterogeneityCorrection | (3004,0014): Tissue Heterogeneity Correction
TissueLocation |
TMLinePositionX0 | (0018,603D): TM-Line Position X0
TMLinePositionX0Retired | (0018,603C): TM-Line Position X0 (Retired)
TMLinePositionX1 | (0018,6041): TM-Line Position X1
TMLinePositionX1Retired | (0018,6040): TM-Line Position X1 (Retired)
TMLinePositionY0 | (0018,603F): TM-Line Position Y0
TMLinePositionY0Retired | (0018,603E): TM-Line Position Y0 (Retired)
TMLinePositionY1 | (0018,6043): TM-Line Position Y1
TMLinePositionY1Retired | (0018,6042): TM-Line Position Y1 (Retired)
ToleranceTableLabel | (300A,0043): Tolerance Table Label
ToleranceTableNumber | (300A,0042): Tolerance Table Number
ToleranceTableSequence | (300A,0040): Tolerance Table Sequence
ToleranceValue | (300A,062C): Tolerance Value
TomoAngle | (0018,1470): Tomo Angle
TomoClass | (0018,1491): Tomo Class
TomoLayerHeight | (0018,1460): Tomo Layer Height
TomotherapeuticControlPointSequence | (3010,0098): Tomotherapeutic Control Point Sequence
TomotherapeuticLeafInitialClosedDurations | (3010,009A): Tomotherapeutic Leaf Initial Closed Durations
TomotherapeuticLeafOpenDurations | (3010,0099): Tomotherapeutic Leaf Open Durations
TomoTime | (0018,1480): Tomo Time
TomoType | (0018,1490): Tomo Type
TopicAuthor | (0088,0910): Topic Author
TopicKeywords | (0088,0912): Topic Keywords
TopicSubject | (0088,0906): Topic Subject
TopicTitle | (0088,0904): Topic Title
TopLeftHandCornerOfLocalizerArea | (0048,0201): Top Left Hand Corner of Localizer Area
ToricIOLPowerForExactEmmetropiaSequence | (0022,104A): Toric IOL Power for Exact Emmetropia Sequence
ToricIOLPowerForExactTargetRefractionSequence | (0022,104B): Toric IOL Power for Exact Target Refraction Sequence
ToricIOLPowerSequence | (0022,1047): Toric IOL Power Sequence
TotalAperture | (0014,5101): Total Aperture
TotalBlockTrayFactor | (300A,00F2): Total Block Tray Factor
TotalBlockTrayWaterEquivalentThickness | (300A,00F3): Total Block Tray Water-Equivalent Thickness
TotalCollimationWidth | (0018,9307): Total Collimation Width
TotalCompensatorTrayFactor | (300A,00E2): Total Compensator Tray Factor
TotalCompensatorTrayWaterEquivalentThickness | (300A,02E3): Total Compensator Tray Water-Equivalent Thickness
TotalGain | (0018,5040): Total Gain()
TotalNumberOfExposures | (0040,0301): Total Number of Exposures
TotalNumberOfPiecesOfMediaCreated | (2200,000B): Total Number of Pieces of Media Created
TotalNumberOfStudyRecords |
TotalPixelMatrixColumns | (0048,0006): Total Pixel Matrix Columns
TotalPixelMatrixFocalPlanes | (0048,0303): Total Pixel Matrix Focal Planes
TotalPixelMatrixOriginSequence | (0048,0008): Total Pixel Matrix Origin Sequence
TotalPixelMatrixRows | (0048,0007): Total Pixel Matrix Rows
TotalPrescriptionDose |
TotalProcessingTime | (4010,1069): Total Processing Time
TotalReferenceAirKerma | (300A,0250): Total Reference Air Kerma
TotalTime | (50xx,200A): Total Time
TotalTimeOfFluoroscopy | (0040,0300): Total Time of Fluoroscopy
TotalWedgeTrayWaterEquivalentThickness | (300A,00D7): Total Wedge Tray Water-Equivalent Thickness
TrackingAlgorithmIdentificationSequence | (0066,0104): Tracking Algorithm Identification Sequence
TrackingID | (0062,0020): Tracking ID
TrackingUID | (0062,0021): Tracking UID
TrackPointIndexList | (0066,0129): Track Point Index List
TrackSequence | (0066,0102): Track Sequence
TrackSetAnatomicalTypeCodeSequence | (0066,0108): Track Set Anatomical Type Code Sequence
TrackSetDescription | (0066,0107): Track Set Description
TrackSetLabel | (0066,0106): Track Set Label
TrackSetNumber | (0066,0105): Track Set Number
TrackSetSequence | (0066,0101): Track Set Sequence
TrackSetStatisticsSequence | (0066,0124): Track Set Statistics Sequence
TrackStatisticsSequence | (0066,0130): Track Statistics Sequence
TransactionStatus |
TransactionStatusComment |
TransactionUID | (0008,1195): Transaction UID
TransducerApplicationCodeSequence | (0018,980F): Transducer Application Code Sequence
TransducerBeamSteeringCodeSequence | (0018,980E): Transducer Beam Steering Code Sequence
TransducerData | (0018,5010): Transducer Data
TransducerFrequency | (0018,6030): Transducer Frequency
TransducerGeometryCodeSequence | (0018,980D): Transducer Geometry Code Sequence
TransducerIdentificationSequence | (0018,5011): Transducer Identification Sequence
TransducerOrientation | (0008,2204): Transducer Orientation
TransducerOrientationModifierSequence | (0008,2246): Transducer Orientation Modifier Sequence
TransducerOrientationSequence | (0008,2244): Transducer Orientation Sequence
TransducerPosition | (0008,2200): Transducer Position
TransducerPositionModifierSequence | (0008,2242): Transducer Position Modifier Sequence
TransducerPositionSequence | (0008,2240): Transducer Position Sequence
TransducerResponseSequence |
TransducerScanPatternCodeSequence | (0018,9809): Transducer Scan Pattern Code Sequence
TransducerTechnologySequence |
TransducerType | (0018,6031): Transducer Type
TransferSyntaxUID | (0002,0010): Transfer Syntax UID
TransferTubeLength | (300A,02A4): Transfer Tube Length
TransferTubeNumber | (300A,02A2): Transfer Tube Number
TransformationAlgorithmSequence | (0022,1513): Transformation Algorithm Sequence
TransformationMethodCodeSequence | (0022,1512): Transformation Method Code Sequence
TransformDescription | (0014,2222): Transform Description
TransformedAxisUnits | (0014,2228): Transformed Axis Units
TransformLabel | (0028,0400): Transform Label
TransformNumberOfAxes | (0014,2224): Transform Number of Axes
TransformOrderOfAxes | (0014,2226): Transform Order of Axes
TransformVersionNumber | (0028,0401): Transform Version Number
TranslationRateX | (0014,409C): Translation Rate X
TranslationRateY | (0014,409D): Translation Rate Y
TransmitCoilManufacturerName | (0018,9050): Transmit Coil Manufacturer Name
TransmitCoilName | (0018,1251): Transmit Coil Name
TransmitCoilType | (0018,9051): Transmit Coil Type
TransmitterFrequency | (0018,9098): Transmitter Frequency
TransmitTransducerSequence | (0014,4010): Transmit Transducer Sequence
TransmitTransducerSettingsSequence | (0014,4050): Transmit Transducer Settings Sequence
TransportClassification | (4010,1067): Transport Classification
TransverseDetectorSeparation | (0018,9726): Transverse Detector Separation
TransverseMash | (0054,1202): Transverse Mash
TrayAccessoryCode | (300A,0355): Tray Accessory Code
TreatmentControlPointDate | (3008,0024): Treatment Control Point Date
TreatmentControlPointTime | (3008,0025): Treatment Control Point Time
TreatmentDate | (3008,0250): Treatment Date
TreatmentDeliveryContinuationFlag | (300A,0708): Treatment Delivery Continuation Flag
TreatmentDeliveryType | (300A,00CE): Treatment Delivery Type
TreatmentDeviceIdentificationSequence | (300A,063A): Treatment Device Identification Sequence
TreatmentMachineName | (300A,00B2): Treatment Machine Name
TreatmentMachineSequence | (300A,0206): Treatment Machine Sequence
TreatmentMachineSpecialModeCodeSequence | (300A,0635): Treatment Machine Special Mode Code Sequence
TreatmentPositionGroupLabel | (300A,0608): Treatment Position Group Label
TreatmentPositionGroupSequence | (300A,060A): Treatment Position Group Sequence
TreatmentPositionGroupUID | (300A,0609): Treatment Position Group UID
TreatmentPositionIndex | (300A,0606): Treatment Position Index
TreatmentPositionSequence | (300A,063F): Treatment Position Sequence
TreatmentProtocols | (300A,0009): Treatment Protocols
TreatmentRecordContentOrigin | (300A,0709): Treatment Record Content Origin
TreatmentSessionApplicationSetupSequence | (3008,0110): Treatment Session Application Setup Sequence
TreatmentSessionBeamSequence | (3008,0020): Treatment Session Beam Sequence
TreatmentSessionIonBeamSequence | (3008,0021): Treatment Session Ion Beam Sequence
TreatmentSessionUID | (300A,0700): Treatment Session UID
TreatmentSite | (3010,0077): Treatment Site
TreatmentSiteCodeSequence | (3010,0078): Treatment Site Code Sequence
TreatmentSiteModifierCodeSequence | (3010,0089): Treatment Site Modifier Code Sequence
TreatmentSites | (300A,000B): Treatment Sites
TreatmentStatusComment | (3008,0202): Treatment Status Comment
TreatmentSummaryCalculatedDoseReferenceSequence | (3008,0050): Treatment Summary Calculated Dose Reference Sequence
TreatmentSummaryMeasuredDoseReferenceSequence | (3008,00E0): Treatment Summary Measured Dose Reference Sequence
TreatmentTechniqueNotes | (3010,007A): Treatment Technique Notes
TreatmentTerminationCode | (3008,002B): Treatment Termination Code
TreatmentTerminationDescription | (300A,0730): Treatment Termination Description
TreatmentTerminationStatus | (3008,002A): Treatment Termination Status
TreatmentTime | (3008,0251): Treatment Time
TreatmentTimeLimit | (300A,062E): Treatment Time Limit
TreatmentToleranceViolationAttributeSequence | (300A,0733): Treatment Tolerance Violation Attribute Sequence
TreatmentToleranceViolationCategory | (300A,0732): Treatment Tolerance Violation Category
TreatmentToleranceViolationCauseCodeSequence | (300A,0762): Treatment Tolerance Violation Cause Code Sequence
TreatmentToleranceViolationDateTime | (300A,0736): Treatment Tolerance Violation DateTime
TreatmentToleranceViolationDescription | (300A,0734): Treatment Tolerance Violation Description
TreatmentToleranceViolationIdentification | (300A,0735): Treatment Tolerance Violation Identification
TreatmentToleranceViolationSequence | (300A,0731): Treatment Tolerance Violation Sequence
TreatmentToleranceViolationTypeCodeSequence | (300A,0761): Treatment Tolerance Violation Type Code Sequence
TreatmentVerificationStatus | (3008,002C): Treatment Verification Status
TriangleFanSequence | (0066,0027): Triangle Fan Sequence
TrianglePointIndexList | (0066,0023): Triangle Point Index List
TriangleStripSequence | (0066,0026): Triangle Strip Sequence
TriggerSamplePosition | (0018,106E): Trigger Sample Position
TriggerSourceOrType | (0018,1061): Trigger Source or Type
TriggerTime | (0018,1060): Trigger Time
TriggerTimeOffset | (0018,1069): Trigger Time Offset
TriggerVector | (0054,0210): Trigger Vector
TriggerWindow | (0018,1094): Trigger Window
Trim | (2010,0140): Trim
TubeAngle | (0018,9303): Tube Angle
TwoDDegreeOfFreedomAxis | (0068,64F0): 2D Degree of Freedom Axis
TwoDDegreeOfFreedomSequence | (0068,6470): 2D Degree of Freedom Sequence
TwoDimensionalToThreeDimensionalMapData | (0022,1531): Two Dimensional to Three Dimensional Map Data
TwoDimensionalToThreeDimensionalMapSequence | (0022,1518): Two Dimensional to Three Dimensional Map Sequence
TwoDImplantTemplateGroupMemberMatchingAxes | (0078,00A0): 2D Implant Template Group Member Matching Axes
TwoDImplantTemplateGroupMemberMatchingPoint | (0078,0090): 2D Implant Template Group Member Matching Point
TwoDLineCoordinates | (0068,65B0): 2D Line Coordinates
TwoDLineCoordinatesSequence | (0068,65A0): 2D Line Coordinates Sequence
TwoDMatingAxes | (0068,6460): 2D Mating Axes
TwoDMatingFeatureCoordinatesSequence | (0068,6430): 2D Mating Feature Coordinates Sequence
TwoDMatingPoint | (0068,6450): 2D Mating Point
TwoDPlaneCoordinatesSequence | (0068,65E0): 2D Plane Coordinates Sequence
TwoDPlaneIntersection | (0068,65F0): 2D Plane Intersection
TwoDPointCoordinates | (0068,6560): 2D Point Coordinates
TwoDPointCoordinatesSequence | (0068,6550): 2D Point Coordinates Sequence
TypeOfData | (50xx,0020): Type of Data
TypeOfDetectorMotion | (0054,0202): Type of Detector Motion
TypeOfFilters | (0018,1161): Type of Filters
TypeOfInstances | (0040,E020): Type of Instances
TypeOfOpticalCorrection | (0022,1046): Type of Optical Correction
TypeOfPatientID | (0010,0022): Type of Patient ID
TypeOfSynchronization | (0072,0434): Type of Synchronization
UDISequence | (0018,100A): UDI Sequence
UID | (0040,A124): UID
UltrasoundAcquisitionGeometry | (0020,9307): Ultrasound Acquisition Geometry
UltrasoundColorDataPresent | (0028,0014): Ultrasound Color Data Present
UltrasoundOphthalmicAxialLengthMeasurementsSequence | (0022,1220): Ultrasound Ophthalmic Axial Length Measurements Sequence
UltrasoundSelectedOphthalmicAxialLengthSequence | (0022,1230): Ultrasound Selected Ophthalmic Axial Length Sequence
UnassignedPerFrameConvertedAttributesSequence | (0020,9171): Unassigned Per-Frame Converted Attributes Sequence
UnassignedSharedConvertedAttributesSequence | (0020,9170): Unassigned Shared Converted Attributes Sequence
Underlined | (0070,0248): Underlined
UnformattedTextValue | (0070,0006): Unformatted Text Value
UnifiedProcedureStepListStatus | (0074,1246): Unified Procedure Step List Status
UnifiedProcedureStepPerformedProcedureSequence | (0074,1216): Unified Procedure Step Performed Procedure Sequence
UniformResourceLocatorTrial | (0040,A992): Uniform Resource Locator (Trial)
UniqueDeviceIdentifier | (0018,1009): Unique Device Identifier
Units | (0054,1001): Units
UniversalEntityID | (0040,0032): Universal Entity ID
UniversalEntityIDType | (0040,0033): Universal Entity ID Type
UnspecifiedLateralityLensSequence | (0046,0016): Unspecified Laterality Lens Sequence
UpdatedMetadataSequence |
UpperCutoffFrequency |
UpperLimitNumberOfPersistentFluoroscopyFrames | (0018,11B5): Upper Limit Number Of Persistent Fluoroscopy Frames
UpperLowerPixelValues | (0018,1240): Upper/Lower Pixel Values()
UrgencyOrPriorityAlertsTrial | (0040,A057): Urgency or Priority Alerts (Trial)
URNCodeValue | (0008,0120): URN Code Value
UsedFiducialsSequence | (0070,0314): Used Fiducials Sequence
UsedRTStructureSetROISequence |
UsedSegmentsSequence | (0062,0012): Used Segments Sequence
UserContentLabel | (3010,0033): User Content Label
UserContentLongLabel | (3010,0034): User Content Long Label
UserSelectedGainY | (0014,408B): User Selected Gain Y
UserSelectedOffsetX | (0014,408D): User Selected Offset X
UserSelectedOffsetY | (0014,408E): User Selected Offset Y
UserSelectedPhase | (0014,408C): User Selected Phase
USImageDescriptionSequence | (0018,9806): US Image Description Sequence
UValueData | (0080,0010): U Value Data
UVMappingSequence | (0080,0008): UV Mapping Sequence
ValueType | (0040,A040): Value Type
VariableCoefficientsSDDN | (7Fxx,0040): Variable Coefficients SDDN
VariableCoefficientsSDHN | (7Fxx,0030): Variable Coefficients SDHN
VariableCoefficientsSDVN | (7Fxx,0020): Variable Coefficients SDVN
VariableFlipAngleFlag | (0018,1315): Variable Flip Angle Flag
VariableModalityLUTSequence |
VariableNextDataGroup | (7Fxx,0011): Variable Next Data Group
VariablePixelData | (7Fxx,0010): Variable Pixel Data
VectorAccuracy | (0066,0020): Vector Accuracy
VectorCoordinateData | (0066,0021): Vector Coordinate Data
VectorDimensionality | (0066,001F): Vector Dimensionality
VectorGridData | (0064,0009): Vector Grid Data
VelocityEncodingAcquisitionSequence | (0018,9092): Velocity Encoding Acquisition Sequence
VelocityEncodingDirection | (0018,9090): Velocity Encoding Direction
VelocityEncodingMaximumValue | (0018,9217): Velocity Encoding Maximum Value
VelocityEncodingMinimumValue | (0018,9091): Velocity Encoding Minimum Value
VelocityOfSound | (0014,4064): Velocity of Sound
VerbalSourceIdentifierCodeSequenceTrial | (0040,A358): Verbal Source Identifier Code Sequence (Trial)
VerbalSourceTrial | (0040,A352): Verbal Source (Trial)
VerificationDateTime | (0040,A030): Verification DateTime
VerificationFlag | (0040,A493): Verification Flag
VerificationImageTiming | (0074,1032): Verification Image Timing
VerifyingObserverIdentificationCodeSequence | (0040,A088): Verifying Observer Identification Code Sequence
VerifyingObserverName | (0040,A075): Verifying Observer Name
VerifyingObserverSequence | (0040,A073): Verifying Observer Sequence
VerifyingOrganization | (0040,A027): Verifying Organization
VertexDistance |
VertexPointIndexList | (0066,0025): Vertex Point Index List
VerticalAlignment | (0070,0243): Vertical Alignment
VerticalOffsetOfSensor | (0014,3026): Vertical Offset of Sensor
VerticalPrismBase | (0046,0036): Vertical Prism Base
VerticalPrismPower | (0046,0034): Vertical Prism Power
VerticesOfTheOutlineOfPupil | (0046,0208): Vertices of the Outline of Pupil
VerticesOfThePolygonalCollimator | (0018,1720): Vertices of the Polygonal Collimator
VerticesOfThePolygonalExposureControlSensingRegion | (0018,9442): Vertices of the Polygonal Exposure Control Sensing Region
VerticesOfThePolygonalOutline | (0018,1638): Vertices of the Polygonal Outline
VerticesOfThePolygonalShutter | (0018,1620): Vertices of the Polygonal Shutter
VerticesOfTheRegion | (0028,9503): Vertices of the Region
VideoImageFormatAcquired | (0018,1022): Video Image Format Acquired
ViewCodeSequence | (0054,0220): View Code Sequence
ViewingDistance | (0046,0106): Viewing Distance
ViewingDistanceType | (0046,0125): Viewing Distance Type
ViewModifierCodeSequence | (0054,0222): View Modifier Code Sequence
ViewName | (0008,2127): View Name
ViewNumber | (0008,2128): View Number
ViewOrientationCodeSequence | (0068,62E0): View Orientation Code Sequence
ViewOrientationModifierCodeSequence | (0068,62F0): View Orientation Modifier Code Sequence
ViewpointLookAtPoint | (0070,1604): Viewpoint LookAt Point
ViewpointPosition | (0070,1603): Viewpoint Position
ViewpointUpDirection | (0070,1605): Viewpoint Up Direction
ViewPosition | (0018,5101): View Position
VirtualSourceAxisDistances | (300A,030A): Virtual Source-Axis Distances
VisitComments | (0038,4000): Visit Comments
VisitStatusID | (0038,0008): Visit Status ID
VisualAcuityBothEyesOpenSequence | (0046,0124): Visual Acuity Both Eyes Open Sequence
VisualAcuityLeftEyeSequence | (0046,0123): Visual Acuity Left Eye Sequence
VisualAcuityMeasurementSequence | (0024,0110): Visual Acuity Measurement Sequence
VisualAcuityModifiers | (0046,0135): Visual Acuity Modifiers
VisualAcuityRightEyeSequence | (0046,0122): Visual Acuity Right Eye Sequence
VisualAcuityTypeCodeSequence | (0046,0121): Visual Acuity Type Code Sequence
VisualEvaluationMethodCodeSequence | (0028,702E): Visual Evaluation Method Code Sequence
VisualEvaluationResultSequence | (0028,7015): Visual Evaluation Result Sequence
VisualEvaluationTestSequence | (0028,7028): Visual Evaluation Test Sequence
VisualFieldCatchTrialSequence | (0024,0034): Visual Field Catch Trial Sequence
VisualFieldGlobalResultsIndexSequence | (0024,0320): Visual Field Global Results Index Sequence
VisualFieldHorizontalExtent | (0024,0010): Visual Field Horizontal Extent
VisualFieldMeanSensitivity | (0024,0070): Visual Field Mean Sensitivity
VisualFieldShape | (0024,0012): Visual Field Shape
VisualFieldTestDuration | (0024,0088): Visual Field Test Duration
VisualFieldTestNormalsFlag | (0024,0063): Visual Field Test Normals Flag
VisualFieldTestPointNormalsSequence | (0024,0097): Visual Field Test Point Normals Sequence
VisualFieldTestPointSequence | (0024,0089): Visual Field Test Point Sequence
VisualFieldTestPointXCoordinate | (0024,0090): Visual Field Test Point X-Coordinate
VisualFieldTestPointYCoordinate | (0024,0091): Visual Field Test Point Y-Coordinate
VisualFieldTestReliabilityGlobalIndexSequence | (0024,0317): Visual Field Test Reliability Global Index Sequence
VisualFieldVerticalExtent | (0024,0011): Visual Field Vertical Extent
VitalStainCodeSequenceTrial | (0040,09F8): Vital Stain Code Sequence (Trial)
VitreousStatusCodeSequence | (0022,1025): Vitreous Status Code Sequence
VitreousStatusDescription | (0022,1066): Vitreous Status Description
VOILUTFunction | (0028,1056): VOI LUT Function
VOILUTSequence | (0028,3010): VOI LUT Sequence
VOIType | (0072,0702): VOI Type
VolumeBasedCalculationTechnique | (0008,9207): Volume Based Calculation Technique
VolumeCroppingMethod | (0070,1302): Volume Cropping Method
VolumeCroppingSequence | (0070,1301): Volume Cropping Sequence
VolumeFrameOfReferenceUID | (0020,9312): Volume Frame of Reference UID
VolumeLocalizationSequence | (0018,9126): Volume Localization Sequence
VolumeLocalizationTechnique | (0018,9054): Volume Localization Technique
VolumeOfPTO | (4010,1023): Volume of PTO
VolumeStreamSequence | (0070,1A08): Volume Stream Sequence
VolumeToTableMappingMatrix | (0020,930A): Volume to Table Mapping Matrix
VolumeToTransducerMappingMatrix | (0020,9309): Volume to Transducer Mapping Matrix
VolumeToTransducerRelationship | (0020,930B): Volume to Transducer Relationship
VolumetricAnnotationSequence | (0070,1901): Volumetric Annotation Sequence
VolumetricCurvePoints | (0070,150D): Volumetric Curve Points
VolumetricCurveUpDirections | (0070,1A07): Volumetric Curve Up Directions
VolumetricPresentationInputAnnotationSequence | (0070,1905): Volumetric Presentation Input Annotation Sequence
VolumetricPresentationInputIndex | (0070,1804): Volumetric Presentation Input Index
VolumetricPresentationInputNumber | (0070,1207): Volumetric Presentation Input Number
VolumetricPresentationInputSetSequence | (0070,120A): Volumetric Presentation Input Set Sequence
VolumetricPresentationInputSetUID | (0070,1209): Volumetric Presentation Input Set UID
VolumetricPresentationStateInputSequence | (0070,1201): Volumetric Presentation State Input Sequence
VolumetricProperties | (0008,9206): Volumetric Properties
VValueData | (0080,0011): V Value Data
WADORetrievalSequence | (0040,E023): WADO Retrieval Sequence
WADORSRetrievalSequence | (0040,E025): WADO-RS Retrieval Sequence
WarningReason | (0008,1196): Warning Reason
WaterDepth | (0016,0033): Water Depth
WaterEquivalentDiameter | (0018,1271): Water Equivalent Diameter
WaterEquivalentDiameterCalculationMethodCodeSequence | (0018,1272): Water Equivalent Diameter Calculation Method Code Sequence
WaterReferenceAcquisition | (0018,9297): Water Reference Acquisition
WaterReferencedPhaseCorrection | (0018,9199): Water Referenced Phase Correction
WaveformAmplifierType |
WaveformAnnotationSequence | (0040,B020): Waveform Annotation Sequence
WaveformBitsAllocated | (5400,1004): Waveform Bits Allocated
WaveformBitsStored | (003A,021A): Waveform Bits Stored
WaveformChannelNumber | (003A,0202): Waveform Channel Number
WaveformData | (5400,1010): Waveform Data
WaveformDataDisplayScale | (003A,0230): Waveform Data Display Scale
WaveformDisplayBackgroundCIELabValue | (003A,0231): Waveform Display Background CIELab Value
WaveformFilterDescription |
WaveformFilterType |
WaveformOriginality | (003A,0004): Waveform Originality
WaveformPaddingValue | (5400,100A): Waveform Padding Value
WaveformPresentationGroupSequence | (003A,0240): Waveform Presentation Group Sequence
WaveformSampleInterpretation | (5400,1006): Waveform Sample Interpretation
WaveformSequence | (5400,0100): Waveform Sequence
WedgeAngle | (300A,00D5): Wedge Angle
WedgeAngleFloat | (0014,5107): Wedge Angle Float
WedgeChamferHeight | (0014,511D): Wedge Chamfer Height
WedgeCurve | (0014,511E): Wedge Curve
WedgeDefinitionSequence | (300A,0651): Wedge Definition Sequence
WedgeDescription | (0014,5111): Wedge Description
WedgeElement1Position | (0014,5109): Wedge Element 1 Position
WedgeFactor | (300A,00D6): Wedge Factor
WedgeFrontGap | (0014,5117): Wedge Front Gap
WedgeFrontHeight | (0014,5119): Wedge Front Height
WedgeID | (300A,00D4): Wedge ID
WedgeInContactLength | (0014,5116): Wedge In Contact Length
WedgeInContactWidth | (0014,511C): Wedge In Contact Width
WedgeManufacturerName | (0014,5110): Wedge Manufacturer Name
WedgeMaterial | (0014,510B): Wedge Material
WedgeMaterialVelocity | (0014,510A): Wedge Material Velocity
WedgeModelNumber | (0014,5106): Wedge Model Number
WedgeName | (0014,510F): Wedge Name
WedgeNumber | (300A,00D2): Wedge Number
WedgeOffsetX | (0014,5113): Wedge Offset X
WedgeOffsetY | (0014,5114): Wedge Offset Y
WedgeOffsetZ | (0014,510C): Wedge Offset Z
WedgeOrientation | (300A,00D8): Wedge Orientation
WedgeOriginOffsetX | (0014,510D): Wedge Origin Offset X
WedgePosition | (300A,0118): Wedge Position
WedgePositionSequence | (300A,0116): Wedge Position Sequence
WedgeRearHeight | (0014,511A): Wedge Rear Height
WedgeRoofAngle | (0014,5108): Wedge Roof Angle
WedgeSequence | (300A,00D1): Wedge Sequence
WedgeThinEdgePosition | (300A,00DB): Wedge Thin Edge Position
WedgeTimeDelay | (0014,510E): Wedge Time Delay
WedgeTotalHeight | (0014,5118): Wedge Total Height
WedgeTotalLength | (0014,5115): Wedge Total Length
WedgeTotalWidth | (0014,511B): Wedge Total Width
WedgeType | (300A,00D3): Wedge Type
WeekdayFractionPatternSequence | (3010,0087): Weekday Fraction Pattern Sequence
WeightingLookupTableData | (0070,1808): Weighting Lookup Table Data
WeightingLookupTableDescriptor | (0070,1807): Weighting Lookup Table Descriptor
WeightingTransferFunctionSequence | (0070,1806): Weighting Transfer Function Sequence
WhiteBalance | (0016,0043): White Balance
WhitePoint | (0016,0001): White Point
WhitePointFlag | (0028,7021): White Point Flag
WholeBodyTechnique | (0018,1301): Whole Body Technique
WholeSlideMicroscopyImageFrameTypeSequence | (0040,0710): Whole Slide Microscopy Image Frame Type Sequence
WideFieldOphthalmicPhotographyQualityRatingSequence | (0022,1525): Wide Field Ophthalmic Photography Quality Rating Sequence
WideFieldOphthalmicPhotographyQualityThresholdSequence | (0022,1526): Wide Field Ophthalmic Photography Quality Threshold Sequence
WideFieldOphthalmicPhotographyThresholdQualityRating | (0022,1527): Wide Field Ophthalmic Photography Threshold Quality Rating
WindowCenter | (0028,1050): Window Center
WindowCenterWidthExplanation | (0028,1055): Window Center & Width Explanation
WindowWidth | (0028,1051): Window Width
WorklistLabel | (0074,1202): Worklist Label
XAAcquisitionDuration | (0018,11BD): XA Acquisition Duration
XAAcquisitionFrameRate | (0018,11B9): XA Acquisition Frame Rate
XAAcquisitionPhaseDetailsSequence | (0018,11B8): XA Acquisition Phase Details Sequence
XAPlaneDetailsSequence | (0018,11BA): XA Plane Details Sequence
XAXRFFrameCharacteristicsSequence | (0018,9412): XA/XRF Frame Characteristics Sequence
XCoordinatesCenterPixelViewAngle | (0022,1528): X Coordinates Center Pixel View Angle
XDSRetrievalSequence | (0040,E024): XDS Retrieval Sequence
XDSStorageSequence | (0040,4074): XDS Storage Sequence
XFocusCenter | (0018,1183): X Focus Center
XOffsetInSlideCoordinateSystem | (0040,072A): X Offset in Slide Coordinate System
XRay3DAcquisitionSequence | (0018,9507): X-Ray 3D Acquisition Sequence
XRay3DFrameTypeSequence | (0018,9504): X-Ray 3D Frame Type Sequence
XRay3DReconstructionSequence | (0018,9530): X-Ray 3D Reconstruction Sequence
XRayAcquisitionDoseSequence | (0018,9542): X-Ray Acquisition Dose Sequence
XRayDetectorID | (0018,9371): X-Ray Detector ID
XRayDetectorIndex | (0018,9370): X-Ray Detector Index
XRayDetectorLabel | (0018,9373): X-Ray Detector Label
XRayFilterDetailsSequence | (0018,11BC): X-Ray Filter Details Sequence
XRayFilterSequence | (0018,9556): X-Ray Filter Sequence
XRayGeometrySequence | (0018,9476): X-Ray Geometry Sequence
XRayGridSequence | (0018,9555): X-Ray Grid Sequence
XRayImageReceptorAngle | (3002,000E): X-Ray Image Receptor Angle
XRayImageReceptorTranslation | (3002,000D): X-Ray Image Receptor Translation
XRayMassAttenuationCoefficient | (0018,9384): X-Ray Mass Attenuation Coefficient
XRayOutput | (0040,0312): X-Ray Output
XRayReceptorType | (0018,9420): X-Ray Receptor Type
XRaySourceID | (0018,9367): X-Ray Source ID
XRaySourceIndex | (0018,9366): X-Ray Source Index
XRaySourceIsocenterPrimaryAngle | (0018,9543): X-Ray Source Isocenter Primary Angle
XRaySourceIsocenterSecondaryAngle | (0018,9544): X-Ray Source Isocenter Secondary Angle
XRayTubeCurrent | (0018,1151): X-Ray Tube Current
XRayTubeCurrentInmA | (0018,9330): X-Ray Tube Current in mA
XRayTubeCurrentInuA | (0018,8151): X-Ray Tube Current in µA
YCoordinatesCenterPixelViewAngle | (0022,1529): Y Coordinates Center Pixel View Angle
YFocusCenter | (0018,1184): Y Focus Center
YOffsetInSlideCoordinateSystem | (0040,073A): Y Offset in Slide Coordinate System
ZEffective | (4010,1019): Z Effective
ZeroVelocityPixelValue | (0018,9810): Zero Velocity Pixel Value
ZOffsetInSlideCoordinateSystem | (0040,074A): Z Offset in Slide Coordinate System
ZonalMap | (1010,xxxx): Zonal Map
ZonalMapFormat | (0028,0722): Zonal Map Format
ZonalMapLocation | (0028,0721): Zonal Map Location
ZonalMapNumberFormat | (0028,0720): Zonal Map Number Format
ZoomCenter | (0028,0032): Zoom Center
ZoomFactor | (0028,0031): Zoom Factor
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.Keyword

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / LicencedFunctions Enumeration

    LicencedFunctions Enumeration
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

<FlagsAttribute()>
Public Enum LicencedFunctions
   Inherits System.Enum
    'Usage

Dim instance As LicencedFunctions
    [Flags()]
public enum LicencedFunctions : System.Enum
    Members
    Member | Description
Acceptor |
CompositeSCP |
Initiator |
NormalisedSCP |
Read |
Write |
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.LicencedFunctions

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / LicenceTypes Enumeration

    LicenceTypes Enumeration
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum LicenceTypes
   Inherits System.Enum
    'Usage

Dim instance As LicenceTypes
    public enum LicenceTypes : System.Enum
    Members
    Member | Description
Demo |
Developer |
Full |
Trial |
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.LicenceTypes

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / LogLevel Enumeration

    LogLevel Enumeration
    In This Topic
    Log levels
    Syntax
    • Visual Basic
    • C#
    'Declaration

<FlagsAttribute()>
Public Enum LogLevel
   Inherits System.Enum
    'Usage

Dim instance As LogLevel
    [Flags()]
public enum LogLevel : System.Enum
    Members
    Member | Description
ALLBYTESIN |
ALLBYTESOUT |
CACHE |
CODEC |
DEBUG |
DETAILED |
ELEMENTSIN |
ELEMENTSOUT |
ERROR |
HIGH |
JPIP |
LIMITEDBYTESIN |
LIMITEDBYTESOUT |
LOG |
LOW |
MEDIUM |
PROFILE |
WARNING |
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.LogLevel

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / MaskMode Enumeration

    MaskMode Enumeration
    In This Topic
    Enumerated values for mask operations
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum MaskMode
   Inherits System.Enum
    'Usage

Dim instance As MaskMode
    public enum MaskMode : System.Enum
    Members
    Member | Description
AverageSubtraction | The frames specified by the MaskFrames property are averaged together, shifted by the amount specified in the MaskShift property, then subtracted from the contrast frames in the range specified in the ApplicableFrames property.
Maximum | In this mode, value of the frames specified by the MaskFrames property are compaired against the contrast frames specified in the ApplicableFrames property, the maximum value is then used for Rendering.
Minimum | In this mode, value of the frames specified by the MaskFrames property are compaired against the contrast frames specified in the ApplicableFrames property, the minimum value is then used for Rendering.
None | No mask subtraction operation is specified
ReverseTimeDifference | This is the reversed Time Interval Differencing mode, in which the number of the mask frame for each contrast frame is calculated by subtracting TID Offset from the first frame within the Applicable Frame Range, TID Offset+2 from the second frame within the Applicable Frame Range, TID Offset+4 from the third frame and so on.
TimeDifference | The mask for each frame within the Applicable Frames range, specified by the ApplicableFrames property, is selected by subtracting the value (specified by TIDOffset property) from the respective frame number.
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.MaskMode

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / PresentationStateFeatures Enumeration

In This Topic
    PresentationStateFeatures Enumeration
    In This Topic
    Flags to control which features of presentation states are used and/or converted
    Syntax
    • Visual Basic
    • C#
    'Declaration

<FlagsAttribute()>
Public Enum PresentationStateFeatures
   Inherits System.Enum
    'Usage

Dim instance As PresentationStateFeatures
    [Flags()]
public enum PresentationStateFeatures : System.Enum
    Members
    Member | Description
All | All features
DisplayArea | Selection of part of image for display
Gamma | Use of the property. Note that gamma is not part of the presentation state definition, but by default (if this bit is set), DicomObjects disables Gamma when a PS is applied to maintain consistency.
GraphicAnnotations | Graphical Annotations
Masking | Masking / Subtraction
ModalityTransform | Modality Transform - i.e. rescale slope and intercept or Modality LUT
Overlays | overlays activated or help by the presentation state
PresentationTransform | Presentation Transform - i.e. inversion or Presentation LUT
Shutters | Shutters defined
SpatialTransform | Rotate/flip etc.
TextAnnotations | Text Annotations
VoiTransform | VOI Transform - i.e. windowing or VOI LUT
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.PresentationStateFeatures

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / Progression Enumeration

    Progression Enumeration
    In This Topic
    Ordering of packet used in JPEG 2000 & JPIP
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum Progression
   Inherits System.Enum
    'Usage

Dim instance As Progression
    public enum Progression : System.Enum
    Members
    Member | Description
CPRL | Component Position Resolution Layer
LRCP | Layer Resolution Component Position
PCRL | Position Component Resolution Layer
RLCP | Resolution Layer Component Position
RPCL | Resolution Position Component Layer
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.Progression

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / ProgressiveStatus Enumeration

    ProgressiveStatus Enumeration
    In This Topic
    The status of an image being viewed in a progressive manner
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum ProgressiveStatus
   Inherits System.Enum
    'Usage

Dim instance As ProgressiveStatus
    public enum ProgressiveStatus : System.Enum
    Members
    Member | Description
Incomplete | The image is currently being retrieved, and will update asynchronously
NotStarted | The meta data and JPEG 2000 Header have not yet been retrieved/
RequiredResolution | All data available and needed for the current display area and resolution has been received, but more may be available if the area or magnification change.
WholeImage | All available data for the image has been retrieved.
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.ProgressiveStatus

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / QueryLevel Enumeration

    QueryLevel Enumeration
    In This Topic
    Enumerated values for Query Level
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum QueryLevel
   Inherits System.Enum
    'Usage

Dim instance As QueryLevel
    public enum QueryLevel : System.Enum
    Members
    Member | Description
FRAME | Frame level as per supplment 119
IMAGE | IMAGE level for query
INSTANCE | Equivalent to IMAGE level
NONE | No level specified
PATIENT | PATIENT level for query
SERIES | SERIES level for query
STUDY | STUDY level for query
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.QueryLevel

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / QueryRoot Enumeration

    QueryRoot Enumeration
    In This Topic
    Enumerated values for Query Root
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum QueryRoot
   Inherits System.Enum
    'Usage

Dim instance As QueryRoot
    public enum QueryRoot : System.Enum
    Members
    Member | Description
CompositeInstance | Composite Instance Root
GeneralPurposeWorklist | Root for General Purpose Worklist query
ModalityWorklist | Root for Modality Worklist query
None | No root specified
Patient | Patient Root
PatientStudyOnly | A combined root of Patient and Study
Study | Study Root
UnifiedProcedureStep | Root for DICOM Unified Procedure Step
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.QueryRoot

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / RequestType Enumeration

    RequestType Enumeration
    In This Topic
    Enum used in the class to pecify the required usage of the data requested
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum RequestType
   Inherits System.Enum
    'Usage

Dim instance As RequestType
    public enum RequestType : System.Enum
    Members
    Member | Description
Background | Low priority background request to satisfy a possible future requirement
Display | Data is for display - i.e. it will may be acquired asynchronously
Synchronous | Data must be acquired synchronously (e.g. for Writing out, or generating a bitmap etc.)
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.RequestType

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / RetrieveType Enumeration

    RetrieveType Enumeration
    In This Topic
    The type of retrieval requested
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum RetrieveType
   Inherits System.Enum
    'Usage

Dim instance As RetrieveType
    public enum RetrieveType : System.Enum
    Members
    Member | Description
Full | Full Data
NoBulkData | Remove all bulk data before sending
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.RetrieveType

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / RotateState Enumeration

    RotateState Enumeration
    In This Topic
    Enumerated values for rotate mode
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum RotateState
   Inherits System.Enum
    'Usage

Dim instance As RotateState
    public enum RotateState : System.Enum
    Members
    Member | Description
Full | Image is rotated 180°
Left | Image is rotated 90° counter-clockwise
Normal | No Rotate mode is specified
Right | Image is rotated 90° clockwise
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.RotateState

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / RotationBehaviour Enumeration

    RotationBehaviour Enumeration
    In This Topic
    Rotation behaviour of the Image
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum RotationBehaviour
   Inherits System.Enum
    'Usage

Dim instance As RotationBehaviour
    public enum RotationBehaviour : System.Enum
    Members
    Member | Description
BoundingBox | The top left position is defined as the top left corner of the bounding box which surrounds the rotated image.
FixedCentrePoint | The top left position is defined as being where the top left corner of the image would be if it were not rotated. If the image is rotated, it will rotate around the centre point of that non rotated position
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.RotationBehaviour

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / RotationMode Enumeration

    RotationMode Enumeration
    In This Topic
    Possible values for controlling the rotation behaviour of a label.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum RotationMode
   Inherits System.Enum
    'Usage

Dim instance As RotationMode
    public enum RotationMode : System.Enum
    Members
    Member | Description
CentreToRotationPoint | Move label position so that it remains centred on the rotation point as defined by
Default | Non-text labels rotate, but text labels do not.
NoRotate | The label does not rotate if the image is rotated
WithImage | The label rotates with the image (provided that the label's ScaleMode property is )
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.RotationMode

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / ScaleMode Enumeration

    ScaleMode Enumeration
    In This Topic
    How DicomLabel objects' dimensions should be interpreted - i.e. how they should be scaled
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum ScaleMode
   Inherits System.Enum
    'Usage

Dim instance As ScaleMode
    public enum ScaleMode : System.Enum
    Members
    Member | Description
Cell | Dimensions are in the coordinate system used by DICOM in presentation states, where (0.0,0.0) represents the top left corner of the display area, and (1.0,1.0) represents the bottom right
Cell1000 | Like Cell, but the corners are (0,0) and (1000,1000)
Image | Dimensions are in image pixels
Image3D | Used to specify points in 3D space using images' frame of reference
Output | Dimensions are in screen or other output device pixels and are unaffected by the zooming of the image
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.ScaleMode

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / SOPClassGroups Enumeration

    SOPClassGroups Enumeration
    In This Topic
    The categories of SOP class used for negotiation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum SOPClassGroups
   Inherits System.Enum
    'Usage

Dim instance As SOPClassGroups
    public enum SOPClassGroups : System.Enum
    Members
    Member | Description
Images16Bit | DICOM Images expected to contain up to 16 bit pixel data
Images1Bit | DICOM Images expected to contain only 1 bit pixel data
Images32Bit | DICOM Images expected to contain up to 32 bit pixel data
Images8Bit | DICOM Images expected to contain only 8 bit pixel data
ImplicitVrOnly | Special group for objects at risk of exceeding 64k for attributes with 2 byte lengths
NonImageObjects | Persistent DICOM objects without pixel data
Services | DICOM Services such as verification and C-GET etc.
User1 | User group for custom SOP class/transfer syntax definitions
User2 | User group for custom SOP class/transfer syntax definitions
User3 | User group for custom SOP class/transfer syntax definitions
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.SOPClassGroups

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / StatusCode Enumeration

    StatusCode Enumeration
    In This Topic
    Common DICOM status codes
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum StatusCode
   Inherits System.Enum
    'Usage

Dim instance As StatusCode
    public enum StatusCode : System.Enum
    Members
    Member | Description
AttributeListError | Attribute List Error
AttributeValueOutOfRange | Attribute Value Out of Range
Cancel | Operation cancelled
ClassInstanceConflict | Class-instance conflict
DuplicateInvocation | Duplicate invocation
DuplicateSOPInstance | Duplicate SOP instance
InvalidArgumentValue | Invalid argument value
InvalidAttributeValue | Invalid attribute value
InvalidObjectInstance | Invalid object instance
MissingAttribute | Missing attribute
MissingAttributeValue | Missing attribute value
MistypedArgument | Mistyped argument
NoSuchActionType | No such action type
NoSuchArgument | No such argument
NoSuchAttribute | No such attribute
NoSuchEventType | No such event type
NoSuchObjectInstance | No such object instance
NoSuchSOPClass | No such SOP class
ProcessingFailure | Processing failure
ResourceLimitation | Resource limitation
SOPClassNotSupported | SOP class not supported
Success | Operation successful
UnrecognizedOperation | Unrecognized operation
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.StatusCode

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / StatusType Enumeration

    StatusType Enumeration
    In This Topic
    DICOM status code type
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum StatusType
   Inherits System.Enum
    'Usage

Dim instance As StatusType
    public enum StatusType : System.Enum
    Members
    Member | Description
Cancel | Cancel status code
Failure | Failure status code
Pending | Pending status code
Success | Success status code
Unknown | Not a DICOM defined status code
Warning | Warning status code
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.StatusType

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / StretchModes Enumeration

    StretchModes Enumeration
    In This Topic
    Controls how an image is displayed
    Syntax
    • Visual Basic
    • C#
    'Declaration

<FlagsAttribute()>
Public Enum StretchModes
   Inherits System.Enum
    'Usage

Dim instance As StretchModes
    [Flags()]
public enum StretchModes : System.Enum
    Members
    Member | Description
NoStretch | Not stretched at all - display depends on and properties. If rotated, image position will be calculated as if non-rotated, the moved by DicomObjects.DicomImage.Scroll and then finally rotated around its centre point.
StretchCentred | Fitted to the available size, and centered within that
StretchTopLeft | Fitted to the available size, but placed in the top left corner
TrueSize | Similar to , but image will be zoomed and rotated and the top-left of its bounding box calculated to provide a reference position before the is applied.
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.StretchModes

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / UIDType Enumeration

    UIDType Enumeration
    In This Topic
    Classification of DICOM UID types
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum UIDType
   Inherits System.Enum
    'Usage

Dim instance As UIDType
    public enum UIDType : System.Enum
    Members
    Member | Description
ApplicationContext | The single DICOM Application Context
FrameOfReference | Well-known frames of reference
Image16Bit | DICOM Images expected to contain up to 16 bit pixel data
Image1Bit | DICOM Images containing only 1 bit pixel data
Image32Bit | DICOM Images expected to contain up to 32 bit pixel data
Image8Bit | DICOM Images expected to contain only 8 bit pixel data
MetaSOPClass | A DICOM Meta SOP class
NonImageObject | Persistent DICOM objects without pixel data
Service | DICOM Services such as verification and C-GET etc.
TransferSyntax | A DICOM Transfer Syntax
WellKnownInstance | Well-known fixed DICOM Instances
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.UIDType

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / UserIdentityResponseType Enumeration

In This Topic
    UserIdentityResponseType Enumeration
    In This Topic
    User Identity Response Type for User Identity Negotiation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum UserIdentityResponseType
   Inherits System.Enum
    'Usage

Dim instance As UserIdentityResponseType
    public enum UserIdentityResponseType : System.Enum
    Members
    Member | Description
NoResponseRequested | No response requested
PositiveResponseRequested | Positive response requested
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.UserIdentityResponseType

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / UserIdentityType Enumeration

    UserIdentityType Enumeration
    In This Topic
    User Identity Type for User Identity Negotiation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum UserIdentityType
   Inherits System.Enum
    'Usage

Dim instance As UserIdentityType
    public enum UserIdentityType : System.Enum
    Members
    Member | Description
JsonWebToken | JSON Web Token (JWT)
Kerberos | Kerberos Service ticket
SamlAssertion | SAML Assertion
UserName | Username as a string in UTF-8
UserNameAndPassword | Username as a string in UTF-8 and passcode
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.UserIdentityType

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / ViewerMode Enumeration

    ViewerMode Enumeration
    In This Topic
    The modes which can be used for displaying DICOM images in a
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum ViewerMode
   Inherits System.Enum
    'Usage

Dim instance As ViewerMode
    public enum ViewerMode : System.Enum
    Members
    Member | Description
Default |
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.ViewerMode

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / VoiLUTFunction Enumeration

    VoiLUTFunction Enumeration
    In This Topic
    Controls which VOILUT function to be used
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum VoiLUTFunction
   Inherits System.Enum
    'Usage

Dim instance As VoiLUTFunction
    public enum VoiLUTFunction : System.Enum
    Members
    Member | Description
Linear | Linear Windowing
Sigmoid | Sigmoide Window function
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.VoiLUTFunction

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / WaveletTransform Enumeration

    WaveletTransform Enumeration
    In This Topic
    The types of wavelet transform used in JPEG 2000 & JPIP
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum WaveletTransform
   Inherits System.Enum
    'Usage

Dim instance As WaveletTransform
    public enum WaveletTransform : System.Enum
    Members
    Member | Description
Irreversible | Irreversible 9/7
None | No transform
Reversible | Reversible 5/3
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.WaveletTransform

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


Inheritance Hierarchy
    DicomObjects.EventArguments Namespace
    Classes
     | Class | Description
Class | AssociationClosedArgs | Argument passed in the AssociationClosed event
Class | AssociationRequestArgs | Argument passed in the event
Class | ChangeUidArgs | Argument for the event, allowing visibility and control of UID changes
Class | CStoreRequestArgs |
Class | ErrorReceivedArgs | Argument passed in the ErrorReceived event
Class | InfoMessageArgs | Argument passed in the InfoMessage event
Class | InstanceReceivedArgs | Argument passed in the InstanceReceived event
Class | LogEventArgs | Arguments for the Event
Class | N_Event_ReportArgs | Event argument passed in the and events
Class | NormalisedReceivedArgs | Argument passed in the NormalisedReceived evetn
Class | OperationBaseArgs | A base class for other Arguments classes used for incoming operations It is not used directly on its own.
Class | QueryReceivedArgs | Argument passed in the QueryReceived event
Class | ReceivingPixelDataArgs | Class used by the event
Class | ResponseReceivedArgs | Event argument passed in the ResponseReceived
Class | ValidateFragmentsArgs | Argument for the event.
Class | VerifyReceivedArgs | Argument passed in the VerifyReceived Event
    See Also

    Reference

    DicomObjects.Core Assembly


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / AssociationClosedArgs Class
Members

In This Topic
    AssociationClosedArgs Class
    In This Topic
    Argument passed in the AssociationClosed event
    Object Model
    AssociationClosedArgs ClassDicomAssociation Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class AssociationClosedArgs
    'Usage

Dim instance As AssociationClosedArgs
    public class AssociationClosedArgs
    Inheritance Hierarchy

    System.Object
    DicomObjects.EventArguments.AssociationClosedArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    AssociationClosedArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / AssociationClosedArgs Class
Properties

In This Topic
    AssociationClosedArgs Class Members
    In This Topic

    The following tables list the members exposed by AssociationClosedArgs.

    Public Properties
     | Name | Description
Public Property | Association | The association that is to be closed
    Top
    See Also

    Reference

    AssociationClosedArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / AssociationClosedArgs Class

In This Topic
    AssociationClosedArgs Class Properties
    In This Topic

    For a list of all members of this type, see AssociationClosedArgs members.

    Public Properties
     | Name | Description
Public Property | Association | The association that is to be closed
    Top
    See Also

    Reference

    AssociationClosedArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / AssociationClosedArgs Class / Association Property

    Association Property (AssociationClosedArgs)
    In This Topic
    The association that is to be closed
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Association As DicomAssociation
    'Usage

Dim instance As AssociationClosedArgs
Dim value As DicomAssociation

value = instance.Association
    public DicomAssociation Association {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    AssociationClosedArgs Class
    AssociationClosedArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / AssociationRequestArgs Class
Members

In This Topic
    AssociationRequestArgs Class
    In This Topic
    Argument passed in the event
    Object Model
    AssociationRequestArgs ClassDicomAssociation ClassDicomContextCollection ClassDicomContext Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class AssociationRequestArgs
   Inherits System.EventArgs
    'Usage

Dim instance As AssociationRequestArgs
    public class AssociationRequestArgs : System.EventArgs
    Inheritance Hierarchy

    System.Object
    System.EventArgs
    DicomObjects.EventArguments.AssociationRequestArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    AssociationRequestArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / AssociationRequestArgs Class
Properties Methods

In This Topic
    AssociationRequestArgs Class Members
    In This Topic

    The following tables list the members exposed by AssociationRequestArgs.

    Public Properties
     | Name | Description
Public Property | Association | The association that contains the incoming request
Public Property | Contexts | The Contexts proposed by the remote application
    Top
    Public Methods
     | Name | Description
Public Method | Reject | Reject a whole association request
    Top
    See Also

    Reference

    AssociationRequestArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.EventArguments Namespace / AssociationRequestArgs Class

In This Topic
    AssociationRequestArgs Class Methods
    In This Topic

    For a list of all members of this type, see AssociationRequestArgs members.

    Public Methods
     | Name | Description
Public Method | Reject | Reject a whole association request
    Top
    See Also

    Reference

    AssociationRequestArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / AssociationRequestArgs Class / Reject Method / Reject(Byte,Byte,Byte) Method
Result as byte, indicating whether it's a permanent or transient rejection
Source as byte, indicating the source of the rejection
Reason as byte, indicating the reason of the rejection

In This Topic
    Reject(Byte,Byte,Byte) Method
    In This Topic
    Reject a whole association request
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub Reject( _
   ByVal Result As Byte, _
   ByVal Source As Byte, _
   ByVal Reason As Byte _
)
    'Usage

Dim instance As AssociationRequestArgs
Dim Result As Byte
Dim Source As Byte
Dim Reason As Byte

instance.Reject(Result, Source, Reason)
    public void Reject(
   byte Result,
   byte Source,
   byte Reason
)

    Parameters

    Result
    Result as byte, indicating whether it's a permanent or transient rejection
    Source
    Source as byte, indicating the source of the rejection
    Reason
    Reason as byte, indicating the reason of the rejection
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    AssociationRequestArgs Class
    AssociationRequestArgs Members
    Overload List


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / AssociationRequestArgs Class

In This Topic
    AssociationRequestArgs Class Properties
    In This Topic

    For a list of all members of this type, see AssociationRequestArgs members.

    Public Properties
     | Name | Description
Public Property | Association | The association that contains the incoming request
Public Property | Contexts | The Contexts proposed by the remote application
    Top
    See Also

    Reference

    AssociationRequestArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / AssociationRequestArgs Class / Association Property

    Association Property (AssociationRequestArgs)
    In This Topic
    The association that contains the incoming request
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Association As DicomAssociation
    'Usage

Dim instance As AssociationRequestArgs
Dim value As DicomAssociation

value = instance.Association
    public DicomAssociation Association {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    AssociationRequestArgs Class
    AssociationRequestArgs Members


DicomObjects.EventArguments Namespace / AssociationRequestArgs Class / Contexts Property

    Contexts Property
    The Contexts proposed by the remote application
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Contexts As DicomContextCollection
    'Usage

Dim instance As AssociationRequestArgs
Dim value As DicomContextCollection

value = instance.Contexts
    public DicomContextCollection Contexts {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    AssociationRequestArgs Class
    AssociationRequestArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / ChangeUidArgs Class
Members

In This Topic
    ChangeUidArgs Class
    In This Topic
    Argument for the event, allowing visibility and control of UID changes
    Object Model
    ChangeUidArgs ClassDicomDataSet ClassDicomAttribute Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class ChangeUidArgs
    'Usage

Dim instance As ChangeUidArgs
    public class ChangeUidArgs
    Inheritance Hierarchy

    System.Object
    DicomObjects.EventArguments.ChangeUidArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ChangeUidArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / ChangeUidArgs Class
Properties

In This Topic
    ChangeUidArgs Class Members
    In This Topic

    The following tables list the members exposed by ChangeUidArgs.

    Public Properties
     | Name | Description
Public Property | AllowChange | Controls whether to actually make the UID change
Public Property | DataSet | The dataset whose UID should be changed
Public Property | NewUID | The UID being proposed by DicomObjects.
Public Property | Quality | The quality being used for the image compression
Public Property | Reason | The reason that the UID should be changed
Public Property | TransferSyntax | The new transfer syntax being used
    Top
    See Also

    Reference

    ChangeUidArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / ChangeUidArgs Class

    ChangeUidArgs Class Properties
    In This Topic

    For a list of all members of this type, see ChangeUidArgs members.

    Public Properties
     | Name | Description
Public Property | AllowChange | Controls whether to actually make the UID change
Public Property | DataSet | The dataset whose UID should be changed
Public Property | NewUID | The UID being proposed by DicomObjects.
Public Property | Quality | The quality being used for the image compression
Public Property | Reason | The reason that the UID should be changed
Public Property | TransferSyntax | The new transfer syntax being used
    Top
    See Also

    Reference

    ChangeUidArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / ChangeUidArgs Class / AllowChange Property

    AllowChange Property
    Controls whether to actually make the UID change
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property AllowChange As Boolean
    'Usage

Dim instance As ChangeUidArgs
Dim value As Boolean

instance.AllowChange = value

value = instance.AllowChange
    public bool AllowChange {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ChangeUidArgs Class
    ChangeUidArgs Members


DicomObjects.EventArguments Namespace / ChangeUidArgs Class / DataSet Property

    DataSet Property (ChangeUidArgs)
    In This Topic
    The dataset whose UID should be changed
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property DataSet As DicomDataSet
    'Usage

Dim instance As ChangeUidArgs
Dim value As DicomDataSet

instance.DataSet = value

value = instance.DataSet
    public DicomDataSet DataSet {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ChangeUidArgs Class
    ChangeUidArgs Members


DicomObjects.EventArguments Namespace / ChangeUidArgs Class / NewUID Property

    NewUID Property
    The UID being proposed by DicomObjects.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property NewUID As String
    'Usage

Dim instance As ChangeUidArgs
Dim value As String

instance.NewUID = value

value = instance.NewUID
    public string NewUID {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ChangeUidArgs Class
    ChangeUidArgs Members


DicomObjects.EventArguments Namespace / ChangeUidArgs Class / Quality Property

    Quality Property (ChangeUidArgs)
    In This Topic
    The quality being used for the image compression
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Quality As Object
    'Usage

Dim instance As ChangeUidArgs
Dim value As Object

instance.Quality = value

value = instance.Quality
    public object Quality {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ChangeUidArgs Class
    ChangeUidArgs Members


DicomObjects.EventArguments Namespace / ChangeUidArgs Class / Reason Property

    Reason Property
    The reason that the UID should be changed
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Reason As ChangeUidReason
    'Usage

Dim instance As ChangeUidArgs
Dim value As ChangeUidReason

instance.Reason = value

value = instance.Reason
    public ChangeUidReason Reason {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ChangeUidArgs Class
    ChangeUidArgs Members


DicomObjects.EventArguments Namespace / ChangeUidArgs Class / TransferSyntax Property

    TransferSyntax Property (ChangeUidArgs)
    In This Topic
    The new transfer syntax being used
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property TransferSyntax As String
    'Usage

Dim instance As ChangeUidArgs
Dim value As String

instance.TransferSyntax = value

value = instance.TransferSyntax
    public string TransferSyntax {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ChangeUidArgs Class
    ChangeUidArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / CStoreRequestArgs Class
Members

In This Topic
    CStoreRequestArgs Class
    In This Topic
    Object Model
    CStoreRequestArgs ClassDicomAssociation Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class CStoreRequestArgs
   Inherits System.EventArgs
    'Usage

Dim instance As CStoreRequestArgs
    public class CStoreRequestArgs : System.EventArgs
    Inheritance Hierarchy

    System.Object
    System.EventArgs
    DicomObjects.EventArguments.CStoreRequestArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CStoreRequestArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / CStoreRequestArgs Class
Properties

In This Topic
    CStoreRequestArgs Class Members
    In This Topic

    The following tables list the members exposed by CStoreRequestArgs.

    Public Properties
     | Name | Description
Public Property | AffectedSOPClassUID |
Public Property | AffectedSOPInstanceUID |
Public Property | Association |
Public Property | Command |
Public Property | CommondDataSetType |
Public Property | MessageID |
Public Property | MoveOriginatorAET |
Public Property | MoveOriginatorMessageID |
Public Property | Priority |
    Top
    See Also

    Reference

    CStoreRequestArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / CStoreRequestArgs Class

In This Topic
    CStoreRequestArgs Class Properties
    In This Topic

    For a list of all members of this type, see CStoreRequestArgs members.

    Public Properties
     | Name | Description
Public Property | AffectedSOPClassUID |
Public Property | AffectedSOPInstanceUID |
Public Property | Association |
Public Property | Command |
Public Property | CommondDataSetType |
Public Property | MessageID |
Public Property | MoveOriginatorAET |
Public Property | MoveOriginatorMessageID |
Public Property | Priority |
    Top
    See Also

    Reference

    CStoreRequestArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / CStoreRequestArgs Class / AffectedSOPClassUID Property

    AffectedSOPClassUID Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property AffectedSOPClassUID As String
    'Usage

Dim instance As CStoreRequestArgs
Dim value As String

value = instance.AffectedSOPClassUID
    public string AffectedSOPClassUID {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CStoreRequestArgs Class
    CStoreRequestArgs Members


DicomObjects.EventArguments Namespace / CStoreRequestArgs Class / AffectedSOPInstanceUID Property

    AffectedSOPInstanceUID Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property AffectedSOPInstanceUID As String
    'Usage

Dim instance As CStoreRequestArgs
Dim value As String

value = instance.AffectedSOPInstanceUID
    public string AffectedSOPInstanceUID {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CStoreRequestArgs Class
    CStoreRequestArgs Members


DicomObjects.EventArguments Namespace / CStoreRequestArgs Class / Association Property

    Association Property (CStoreRequestArgs)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Association As DicomAssociation
    'Usage

Dim instance As CStoreRequestArgs
Dim value As DicomAssociation

value = instance.Association
    public DicomAssociation Association {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CStoreRequestArgs Class
    CStoreRequestArgs Members


DicomObjects.EventArguments Namespace / CStoreRequestArgs Class / Command Property

    Command Property (CStoreRequestArgs)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Command As UShort
    'Usage

Dim instance As CStoreRequestArgs
Dim value As UShort

value = instance.Command
    public ushort Command {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CStoreRequestArgs Class
    CStoreRequestArgs Members


DicomObjects.EventArguments Namespace / CStoreRequestArgs Class / CommondDataSetType Property

    CommondDataSetType Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property CommondDataSetType As UShort
    'Usage

Dim instance As CStoreRequestArgs
Dim value As UShort

value = instance.CommondDataSetType
    public ushort CommondDataSetType {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CStoreRequestArgs Class
    CStoreRequestArgs Members


DicomObjects.EventArguments Namespace / CStoreRequestArgs Class / MessageID Property

    MessageID Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property MessageID As UShort
    'Usage

Dim instance As CStoreRequestArgs
Dim value As UShort

value = instance.MessageID
    public ushort MessageID {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CStoreRequestArgs Class
    CStoreRequestArgs Members


DicomObjects.EventArguments Namespace / CStoreRequestArgs Class / MoveOriginatorAET Property

    MoveOriginatorAET Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property MoveOriginatorAET As String
    'Usage

Dim instance As CStoreRequestArgs
Dim value As String

value = instance.MoveOriginatorAET
    public string MoveOriginatorAET {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CStoreRequestArgs Class
    CStoreRequestArgs Members


DicomObjects.EventArguments Namespace / CStoreRequestArgs Class / MoveOriginatorMessageID Property

    MoveOriginatorMessageID Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property MoveOriginatorMessageID As UShort
    'Usage

Dim instance As CStoreRequestArgs
Dim value As UShort

value = instance.MoveOriginatorMessageID
    public ushort MoveOriginatorMessageID {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CStoreRequestArgs Class
    CStoreRequestArgs Members


DicomObjects.EventArguments Namespace / CStoreRequestArgs Class / Priority Property

    Priority Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Priority As UShort
    'Usage

Dim instance As CStoreRequestArgs
Dim value As UShort

value = instance.Priority
    public ushort Priority {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CStoreRequestArgs Class
    CStoreRequestArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / ErrorReceivedArgs Class
Members

In This Topic
    ErrorReceivedArgs Class
    In This Topic
    Argument passed in the ErrorReceived event
    Object Model
    ErrorReceivedArgs ClassDicomAssociation Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class ErrorReceivedArgs
    'Usage

Dim instance As ErrorReceivedArgs
    public class ErrorReceivedArgs
    Inheritance Hierarchy

    System.Object
    DicomObjects.EventArguments.ErrorReceivedArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ErrorReceivedArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / ErrorReceivedArgs Class
Properties

In This Topic
    ErrorReceivedArgs Class Members
    In This Topic

    The following tables list the members exposed by ErrorReceivedArgs.

    Public Properties
     | Name | Description
Public Property | Association | The association which contains the detected error
Public Property | Error | The Exception received
    Top
    See Also

    Reference

    ErrorReceivedArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / ErrorReceivedArgs Class

In This Topic
    ErrorReceivedArgs Class Properties
    In This Topic

    For a list of all members of this type, see ErrorReceivedArgs members.

    Public Properties
     | Name | Description
Public Property | Association | The association which contains the detected error
Public Property | Error | The Exception received
    Top
    See Also

    Reference

    ErrorReceivedArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / ErrorReceivedArgs Class / Association Property

    Association Property (ErrorReceivedArgs)
    In This Topic
    The association which contains the detected error
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Association As DicomAssociation
    'Usage

Dim instance As ErrorReceivedArgs
Dim value As DicomAssociation

value = instance.Association
    public DicomAssociation Association {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ErrorReceivedArgs Class
    ErrorReceivedArgs Members


DicomObjects.EventArguments Namespace / ErrorReceivedArgs Class / Error Property

    Error Property
    The Exception received
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Error As Exception
    'Usage

Dim instance As ErrorReceivedArgs
Dim value As Exception

value = instance.Error
    public Exception Error {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ErrorReceivedArgs Class
    ErrorReceivedArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / InfoMessageArgs Class
Members

In This Topic
    InfoMessageArgs Class
    In This Topic
    Argument passed in the InfoMessage event
    Object Model
    InfoMessageArgs ClassDicomAssociation Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class InfoMessageArgs
    'Usage

Dim instance As InfoMessageArgs
    public class InfoMessageArgs
    Inheritance Hierarchy

    System.Object
    DicomObjects.EventArguments.InfoMessageArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    InfoMessageArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / InfoMessageArgs Class
Properties

In This Topic
    InfoMessageArgs Class Members
    In This Topic

    The following tables list the members exposed by InfoMessageArgs.

    Public Properties
     | Name | Description
Public Property | Association | The current association
Public Property | Level | Level indicating the importance of the message
Public Property | Message | The message to be passed back
    Top
    See Also

    Reference

    InfoMessageArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / InfoMessageArgs Class

In This Topic
    InfoMessageArgs Class Properties
    In This Topic

    For a list of all members of this type, see InfoMessageArgs members.

    Public Properties
     | Name | Description
Public Property | Association | The current association
Public Property | Level | Level indicating the importance of the message
Public Property | Message | The message to be passed back
    Top
    See Also

    Reference

    InfoMessageArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / InfoMessageArgs Class / Association Property

    Association Property (InfoMessageArgs)
    In This Topic
    The current association
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Association As DicomAssociation
    'Usage

Dim instance As InfoMessageArgs
Dim value As DicomAssociation

value = instance.Association
    public DicomAssociation Association {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    InfoMessageArgs Class
    InfoMessageArgs Members


DicomObjects.EventArguments Namespace / InfoMessageArgs Class / Level Property

    Level Property (InfoMessageArgs)
    In This Topic
    Level indicating the importance of the message
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Level As Integer
    'Usage

Dim instance As InfoMessageArgs
Dim value As Integer

value = instance.Level
    public int Level {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    InfoMessageArgs Class
    InfoMessageArgs Members


DicomObjects.EventArguments Namespace / InfoMessageArgs Class / Message Property

    Message Property
    The message to be passed back
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Message As String
    'Usage

Dim instance As InfoMessageArgs
Dim value As String

value = instance.Message
    public string Message {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    InfoMessageArgs Class
    InfoMessageArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / InstanceReceivedArgs Class
Members

In This Topic
    InstanceReceivedArgs Class
    In This Topic
    Argument passed in the InstanceReceived event
    Object Model
    InstanceReceivedArgs ClassDicomDataSet ClassDicomAttribute ClassDicomDataSet ClassDicomAttribute ClassDicomDataSet ClassDicomAttribute ClassDicomDataSet ClassDicomAttribute ClassDicomAssociation ClassDicomDataSet ClassDicomAttribute Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class InstanceReceivedArgs
   Inherits OperationBaseArgs
    'Usage

Dim instance As InstanceReceivedArgs
    public class InstanceReceivedArgs : OperationBaseArgs
    Inheritance Hierarchy

    System.Object
    System.EventArgs
    DicomObjects.EventArguments.OperationBaseArgs
    DicomObjects.EventArguments.InstanceReceivedArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    InstanceReceivedArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / InstanceReceivedArgs Class
Properties

In This Topic
    InstanceReceivedArgs Class Members
    In This Topic

    The following tables list the members exposed by InstanceReceivedArgs.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Instance | The received composite DICOM instance
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ReceivedFilename | Filename to which the instance has already been saved
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
    Top
    See Also

    Reference

    InstanceReceivedArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / InstanceReceivedArgs Class

In This Topic
    InstanceReceivedArgs Class Properties
    In This Topic

    For a list of all members of this type, see InstanceReceivedArgs members.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Instance | The received composite DICOM instance
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ReceivedFilename | Filename to which the instance has already been saved
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
    Top
    See Also

    Reference

    InstanceReceivedArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / InstanceReceivedArgs Class / Instance Property

    Instance Property
    The received composite DICOM instance
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Instance As DicomDataSet
    'Usage

Dim instance As InstanceReceivedArgs
Dim value As DicomDataSet

value = instance.Instance
    public DicomDataSet Instance {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    InstanceReceivedArgs Class
    InstanceReceivedArgs Members


DicomObjects.EventArguments Namespace / InstanceReceivedArgs Class / ReceivedFilename Property

    ReceivedFilename Property
    Filename to which the instance has already been saved
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property ReceivedFilename As String
    'Usage

Dim instance As InstanceReceivedArgs
Dim value As String

value = instance.ReceivedFilename
    public string ReceivedFilename {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    InstanceReceivedArgs Class
    InstanceReceivedArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / LogEventArgs Class
Members

In This Topic
    LogEventArgs Class
    In This Topic
    Arguments for the Event
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class LogEventArgs
    'Usage

Dim instance As LogEventArgs
    public class LogEventArgs
    Inheritance Hierarchy

    System.Object
    DicomObjects.EventArguments.LogEventArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    LogEventArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / LogEventArgs Class
Properties

In This Topic
    LogEventArgs Class Members
    In This Topic

    The following tables list the members exposed by LogEventArgs.

    Public Properties
     | Name | Description
Public Property | Level | The level of the event being logged
Public Property | Source | The Log Event Source
Public Property | Text | The test of the association
    Top
    See Also

    Reference

    LogEventArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / LogEventArgs Class

    LogEventArgs Class Properties
    In This Topic

    For a list of all members of this type, see LogEventArgs members.

    Public Properties
     | Name | Description
Public Property | Level | The level of the event being logged
Public Property | Source | The Log Event Source
Public Property | Text | The test of the association
    Top
    See Also

    Reference

    LogEventArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / LogEventArgs Class / Level Property

    Level Property (LogEventArgs)
    In This Topic
    The level of the event being logged
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Level As Integer
    'Usage

Dim instance As LogEventArgs
Dim value As Integer

value = instance.Level
    public int Level {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    LogEventArgs Class
    LogEventArgs Members


DicomObjects.EventArguments Namespace / LogEventArgs Class / Source Property

    Source Property (LogEventArgs)
    In This Topic
    The Log Event Source
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Source As String
    'Usage

Dim instance As LogEventArgs
Dim value As String

value = instance.Source
    public string Source {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    LogEventArgs Class
    LogEventArgs Members


DicomObjects.EventArguments Namespace / LogEventArgs Class / Text Property

    Text Property
    The test of the association
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Text As String
    'Usage

Dim instance As LogEventArgs
Dim value As String

value = instance.Text
    public string Text {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    LogEventArgs Class
    LogEventArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / N_Event_ReportArgs Class
Members

In This Topic
    N_Event_ReportArgs Class
    In This Topic
    Event argument passed in the and events
    Object Model
    N_Event_ReportArgs ClassDicomDataSet ClassDicomAttribute ClassDicomDataSet ClassDicomAttribute ClassDicomDataSet ClassDicomAttribute ClassDicomAssociation ClassDicomDataSet ClassDicomAttribute Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class N_Event_ReportArgs
   Inherits OperationBaseArgs
    'Usage

Dim instance As N_Event_ReportArgs
    public class N_Event_ReportArgs : OperationBaseArgs
    Inheritance Hierarchy

    System.Object
    System.EventArgs
    DicomObjects.EventArguments.OperationBaseArgs
    DicomObjects.EventArguments.N_Event_ReportArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    N_Event_ReportArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / N_Event_ReportArgs Class
Properties

In This Topic
    N_Event_ReportArgs Class Members
    In This Topic

    The following tables list the members exposed by N_Event_ReportArgs.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | EventID | The ID of the notification
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
    Top
    See Also

    Reference

    N_Event_ReportArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / N_Event_ReportArgs Class

In This Topic
    N_Event_ReportArgs Class Properties
    In This Topic

    For a list of all members of this type, see N_Event_ReportArgs members.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | EventID | The ID of the notification
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
    Top
    See Also

    Reference

    N_Event_ReportArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / N_Event_ReportArgs Class / EventID Property

    EventID Property
    The ID of the notification
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property EventID As Integer
    'Usage

Dim instance As N_Event_ReportArgs
Dim value As Integer

value = instance.EventID
    public int EventID {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    N_Event_ReportArgs Class
    N_Event_ReportArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / NormalisedReceivedArgs Class
Members

In This Topic
    NormalisedReceivedArgs Class
    In This Topic
    Argument passed in the NormalisedReceived evetn
    Object Model
    NormalisedReceivedArgs ClassDicomDataSet ClassDicomAttribute ClassDicomDataSet ClassDicomAttribute ClassDicomDataSet ClassDicomAttribute ClassDicomAssociation ClassDicomDataSet ClassDicomAttribute Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class NormalisedReceivedArgs
   Inherits OperationBaseArgs
    'Usage

Dim instance As NormalisedReceivedArgs
    public class NormalisedReceivedArgs : OperationBaseArgs
    Inheritance Hierarchy

    System.Object
    System.EventArgs
    DicomObjects.EventArguments.OperationBaseArgs
    DicomObjects.EventArguments.NormalisedReceivedArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    NormalisedReceivedArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / NormalisedReceivedArgs Class
Properties

In This Topic
    NormalisedReceivedArgs Class Members
    In This Topic

    The following tables list the members exposed by NormalisedReceivedArgs.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
    Top
    See Also

    Reference

    NormalisedReceivedArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / OperationBaseArgs Class
Members

In This Topic
    OperationBaseArgs Class
    In This Topic
    A base class for other Arguments classes used for incoming operations It is not used directly on its own.
    Object Model
    OperationBaseArgs ClassDicomDataSet ClassDicomAttribute ClassDicomDataSet ClassDicomAttribute ClassDicomDataSet ClassDicomAttribute ClassDicomAssociation ClassDicomDataSet ClassDicomAttribute Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class OperationBaseArgs
   Inherits System.EventArgs
    'Usage

Dim instance As OperationBaseArgs
    public class OperationBaseArgs : System.EventArgs
    Inheritance Hierarchy

    System.Object
    System.EventArgs
    DicomObjects.EventArguments.OperationBaseArgs
    DicomObjects.EventArguments.InstanceReceivedArgs
    DicomObjects.EventArguments.N_Event_ReportArgs
    DicomObjects.EventArguments.NormalisedReceivedArgs
    DicomObjects.EventArguments.QueryReceivedArgs
    DicomObjects.EventArguments.VerifyReceivedArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    OperationBaseArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / OperationBaseArgs Class
Properties

In This Topic
    OperationBaseArgs Class Members
    In This Topic

    The following tables list the members exposed by OperationBaseArgs.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command
Public Property | Errors | List of errors found in an incoming request
Public Property | Operation | The normalised operation currently requested
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation
Public Property | Request | The incoming request
Public Property | RequestAssociation | The Association which contains the Query
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations
Public Property | Status | The status to be sent back as a C-Echo response
    Top
    See Also

    Reference

    OperationBaseArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / OperationBaseArgs Class

In This Topic
    OperationBaseArgs Class Properties
    In This Topic

    For a list of all members of this type, see OperationBaseArgs members.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command
Public Property | Errors | List of errors found in an incoming request
Public Property | Operation | The normalised operation currently requested
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation
Public Property | Request | The incoming request
Public Property | RequestAssociation | The Association which contains the Query
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations
Public Property | Status | The status to be sent back as a C-Echo response
    Top
    See Also

    Reference

    OperationBaseArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / OperationBaseArgs Class / Command Property

    Command Property (OperationBaseArgs)
    In This Topic
    The incoming command
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Command As DicomDataSet
    'Usage

Dim instance As OperationBaseArgs
Dim value As DicomDataSet

value = instance.Command
    public DicomDataSet Command {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    OperationBaseArgs Class
    OperationBaseArgs Members


DicomObjects.EventArguments Namespace / OperationBaseArgs Class / Errors Property

    Errors Property
    List of errors found in an incoming request
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Errors As DicomDataSet
    'Usage

Dim instance As OperationBaseArgs
Dim value As DicomDataSet

value = instance.Errors
    public DicomDataSet Errors {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    OperationBaseArgs Class
    OperationBaseArgs Members


DicomObjects.EventArguments Namespace / OperationBaseArgs Class / Operation Property

    Operation Property
    The normalised operation currently requested
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Operation As DicomOperation
    'Usage

Dim instance As OperationBaseArgs
Dim value As DicomOperation

value = instance.Operation
    public DicomOperation Operation {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    OperationBaseArgs Class
    OperationBaseArgs Members


DicomObjects.EventArguments Namespace / OperationBaseArgs Class / PresentationContextId Property

    PresentationContextId Property
    The Presentation Context ID used to transmit this operation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property PresentationContextId As Byte
    'Usage

Dim instance As OperationBaseArgs
Dim value As Byte

value = instance.PresentationContextId
    public byte PresentationContextId {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    OperationBaseArgs Class
    OperationBaseArgs Members


DicomObjects.EventArguments Namespace / OperationBaseArgs Class / Request Property

    Request Property (OperationBaseArgs)
    In This Topic
    The incoming request
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Request As DicomDataSet
    'Usage

Dim instance As OperationBaseArgs
Dim value As DicomDataSet

value = instance.Request
    public DicomDataSet Request {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    OperationBaseArgs Class
    OperationBaseArgs Members


DicomObjects.EventArguments Namespace / OperationBaseArgs Class / RequestAssociation Property

    RequestAssociation Property
    The Association which contains the Query
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property RequestAssociation As DicomAssociation
    'Usage

Dim instance As OperationBaseArgs
Dim value As DicomAssociation

value = instance.RequestAssociation
    public DicomAssociation RequestAssociation {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    OperationBaseArgs Class
    OperationBaseArgs Members


DicomObjects.EventArguments Namespace / OperationBaseArgs Class / ResultDataSet Property

    ResultDataSet Property
    Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property ResultDataSet As DicomDataSet
    'Usage

Dim instance As OperationBaseArgs
Dim value As DicomDataSet

instance.ResultDataSet = value

value = instance.ResultDataSet
    public DicomDataSet ResultDataSet {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    OperationBaseArgs Class
    OperationBaseArgs Members


DicomObjects.EventArguments Namespace / OperationBaseArgs Class / Status Property

    Status Property (OperationBaseArgs)
    In This Topic
    The status to be sent back as a C-Echo response
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Status As Integer
    'Usage

Dim instance As OperationBaseArgs
Dim value As Integer

instance.Status = value

value = instance.Status
    public int Status {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    OperationBaseArgs Class
    OperationBaseArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / QueryReceivedArgs Class
Members

In This Topic
    QueryReceivedArgs Class
    In This Topic
    Argument passed in the QueryReceived event
    Object Model
    QueryReceivedArgs ClassDicomDataSet ClassDicomAttribute ClassDicomDataSet ClassDicomAttribute ClassDicomAssociation ClassDicomDataSet ClassDicomAttribute ClassDicomAssociation ClassDicomDataSet ClassDicomAttribute Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class QueryReceivedArgs
   Inherits OperationBaseArgs
    'Usage

Dim instance As QueryReceivedArgs
    public class QueryReceivedArgs : OperationBaseArgs
    Inheritance Hierarchy

    System.Object
    System.EventArgs
    DicomObjects.EventArguments.OperationBaseArgs
    DicomObjects.EventArguments.QueryReceivedArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / QueryReceivedArgs Class
Properties Methods

In This Topic
    QueryReceivedArgs Class Members
    In This Topic

    The following tables list the members exposed by QueryReceivedArgs.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Destination | The Application Entity Name to which images should be sent by a C-MOVE request
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | InstanceAssociation | The Association to which to send instances using SendInstances
Public Property | Level | The Query Level
Public Property | ModificationsDone | Property to inform DicomObjects whether frame extraction (as per Supplement 119) has been performed
Public Property | NumberCompleted | Numbers of completed C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | NumberFailed | Numbers of failed C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | NumberRemaining | Numbers of remaining C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | NumberWarning | Numbers of warning C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RetrieveType | The type of retrieval requested
Public Property | Root | The Query Root
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
    Top
    Public Methods
     | Name | Description
Public Method | SendPending | Return a pending response
Public Method | SendResponse | Overloaded. Send response back as DicomDataSetCollection to the request association
    Top
    See Also

    Reference

    QueryReceivedArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.EventArguments Namespace / QueryReceivedArgs Class

In This Topic
    QueryReceivedArgs Class Methods
    In This Topic

    For a list of all members of this type, see QueryReceivedArgs members.

    Public Methods
     | Name | Description
Public Method | SendPending | Return a pending response
Public Method | SendResponse | Overloaded. Send response back as DicomDataSetCollection to the request association
    Top
    See Also

    Reference

    QueryReceivedArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / SendPending Method

    SendPending Method (QueryReceivedArgs)
    In This Topic
    Return a pending response
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub SendPending()
    'Usage

Dim instance As QueryReceivedArgs

instance.SendPending()
    public void SendPending()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / SendResponse Method

    SendResponse Method (QueryReceivedArgs)
    In This Topic
    Send response back as DicomDataSetCollection to the request association
    Overload List
    Overload | Description
SendResponse(IEnumerable<DicomDataSet>,Int32) | Send response back as DicomDataSetCollection to the request association
SendResponse(DicomDataSet,Int32) | Send response back as DicomDataSet to the request association
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / SendResponse Method / SendResponse(IEnumerable<DicomDataSet>,Int32) Method

    SendResponse(IEnumerable<DicomDataSet>,Int32) Method
    Send response back as DicomDataSetCollection to the request association
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub SendResponse( _
   ByVal Data As IEnumerable(Of DicomDataSet), _
   ByVal Status As Integer _
)
    'Usage

Dim instance As QueryReceivedArgs
Dim Data As IEnumerable(Of DicomDataSet)
Dim Status As Integer

instance.SendResponse(Data, Status)
    public void SendResponse(
   IEnumerable<DicomDataSet> Data,
   int Status
)

    Parameters

    Data
    Status
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members
    Overload List


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / SendResponse Method / SendResponse(DicomDataSet,Int32) Method

    SendResponse(DicomDataSet,Int32) Method
    Send response back as DicomDataSet to the request association
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overloads Sub SendResponse( _
   ByVal Data As DicomDataSet, _
   ByVal Status As Integer _
)
    'Usage

Dim instance As QueryReceivedArgs
Dim Data As DicomDataSet
Dim Status As Integer

instance.SendResponse(Data, Status)
    public void SendResponse(
   DicomDataSet Data,
   int Status
)

    Parameters

    Data
    Status
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members
    Overload List


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / QueryReceivedArgs Class

In This Topic
    QueryReceivedArgs Class Properties
    In This Topic

    For a list of all members of this type, see QueryReceivedArgs members.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Destination | The Application Entity Name to which images should be sent by a C-MOVE request
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | InstanceAssociation | The Association to which to send instances using SendInstances
Public Property | Level | The Query Level
Public Property | ModificationsDone | Property to inform DicomObjects whether frame extraction (as per Supplement 119) has been performed
Public Property | NumberCompleted | Numbers of completed C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | NumberFailed | Numbers of failed C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | NumberRemaining | Numbers of remaining C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | NumberWarning | Numbers of warning C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RetrieveType | The type of retrieval requested
Public Property | Root | The Query Root
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
    Top
    See Also

    Reference

    QueryReceivedArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / Destination Property

    Destination Property (QueryReceivedArgs)
    In This Topic
    The Application Entity Name to which images should be sent by a C-MOVE request
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Destination As String
    'Usage

Dim instance As QueryReceivedArgs
Dim value As String

value = instance.Destination
    public string Destination {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / InstanceAssociation Property

    InstanceAssociation Property
    The Association to which to send instances using SendInstances
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property InstanceAssociation As DicomAssociation
    'Usage

Dim instance As QueryReceivedArgs
Dim value As DicomAssociation

instance.InstanceAssociation = value

value = instance.InstanceAssociation
    public DicomAssociation InstanceAssociation {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / Level Property

    Level Property (QueryReceivedArgs)
    In This Topic
    The Query Level
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Level As QueryLevel
    'Usage

Dim instance As QueryReceivedArgs
Dim value As QueryLevel

value = instance.Level
    public QueryLevel Level {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / ModificationsDone Property

    ModificationsDone Property
    Property to inform DicomObjects whether frame extraction (as per Supplement 119) has been performed
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property ModificationsDone As Boolean
    'Usage

Dim instance As QueryReceivedArgs
Dim value As Boolean

instance.ModificationsDone = value

value = instance.ModificationsDone
    public bool ModificationsDone {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / NumberCompleted Property

    NumberCompleted Property
    Numbers of completed C-STORE sub-operations in a C-GET or C_MOVE operation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property NumberCompleted As Integer
    'Usage

Dim instance As QueryReceivedArgs
Dim value As Integer

instance.NumberCompleted = value

value = instance.NumberCompleted
    public int NumberCompleted {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / NumberFailed Property

    NumberFailed Property
    Numbers of failed C-STORE sub-operations in a C-GET or C_MOVE operation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property NumberFailed As Integer
    'Usage

Dim instance As QueryReceivedArgs
Dim value As Integer

instance.NumberFailed = value

value = instance.NumberFailed
    public int NumberFailed {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / NumberRemaining Property

    NumberRemaining Property
    Numbers of remaining C-STORE sub-operations in a C-GET or C_MOVE operation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property NumberRemaining As Integer
    'Usage

Dim instance As QueryReceivedArgs
Dim value As Integer

instance.NumberRemaining = value

value = instance.NumberRemaining
    public int NumberRemaining {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / NumberWarning Property

    NumberWarning Property
    Numbers of warning C-STORE sub-operations in a C-GET or C_MOVE operation
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property NumberWarning As Integer
    'Usage

Dim instance As QueryReceivedArgs
Dim value As Integer

instance.NumberWarning = value

value = instance.NumberWarning
    public int NumberWarning {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / RetrieveType Property

    RetrieveType Property
    The type of retrieval requested
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property RetrieveType As RetrieveType
    'Usage

Dim instance As QueryReceivedArgs
Dim value As RetrieveType

instance.RetrieveType = value

value = instance.RetrieveType
    public RetrieveType RetrieveType {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / Root Property

    Root Property (QueryReceivedArgs)
    In This Topic
    The Query Root
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Root As QueryRoot
    'Usage

Dim instance As QueryReceivedArgs
Dim value As QueryRoot

value = instance.Root
    public QueryRoot Root {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / ReceivingPixelDataArgs Class
Members

In This Topic
    ReceivingPixelDataArgs Class
    In This Topic
    Class used by the event
    Object Model
    ReceivingPixelDataArgs ClassDicomAssociation ClassDicomDataSet ClassDicomAttribute Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class ReceivingPixelDataArgs
    'Usage

Dim instance As ReceivingPixelDataArgs
    public class ReceivingPixelDataArgs
    Inheritance Hierarchy

    System.Object
    DicomObjects.EventArguments.ReceivingPixelDataArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReceivingPixelDataArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / ReceivingPixelDataArgs Class
Properties Methods

In This Topic
    ReceivingPixelDataArgs Class Members
    In This Topic

    The following tables list the members exposed by ReceivingPixelDataArgs.

    Public Properties
     | Name | Description
Public Property | Association | The association on which data is arriving
Public Property | Dataset | The dataset so far
    Top
    Public Methods
     | Name | Description
Public Method | ReceiveToDisk | Write the data received so far to the names file, and then pass received pixel data direct to that file, without holding it all in memory
Public Method | ReceiveToStream |
    Top
    See Also

    Reference

    ReceivingPixelDataArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.EventArguments Namespace / ReceivingPixelDataArgs Class

In This Topic
    ReceivingPixelDataArgs Class Methods
    In This Topic

    For a list of all members of this type, see ReceivingPixelDataArgs members.

    Public Methods
     | Name | Description
Public Method | ReceiveToDisk | Write the data received so far to the names file, and then pass received pixel data direct to that file, without holding it all in memory
Public Method | ReceiveToStream |
    Top
    See Also

    Reference

    ReceivingPixelDataArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / ReceivingPixelDataArgs Class / ReceiveToDisk Method

    ReceiveToDisk Method
    Write the data received so far to the names file, and then pass received pixel data direct to that file, without holding it all in memory
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub ReceiveToDisk( _
   ByVal FileName As String _
)
    'Usage

Dim instance As ReceivingPixelDataArgs
Dim FileName As String

instance.ReceiveToDisk(FileName)
    public void ReceiveToDisk(
   string FileName
)

    Parameters

    FileName
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReceivingPixelDataArgs Class
    ReceivingPixelDataArgs Members


DicomObjects.EventArguments Namespace / ReceivingPixelDataArgs Class / ReceiveToStream Method

    ReceiveToStream Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Sub ReceiveToStream( _
   ByVal stream As Stream _
)
    'Usage

Dim instance As ReceivingPixelDataArgs
Dim stream As Stream

instance.ReceiveToStream(stream)
    public void ReceiveToStream(
   Stream stream
)

    Parameters

    stream
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReceivingPixelDataArgs Class
    ReceivingPixelDataArgs Members


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / ReceivingPixelDataArgs Class

In This Topic
    ReceivingPixelDataArgs Class Properties
    In This Topic

    For a list of all members of this type, see ReceivingPixelDataArgs members.

    Public Properties
     | Name | Description
Public Property | Association | The association on which data is arriving
Public Property | Dataset | The dataset so far
    Top
    See Also

    Reference

    ReceivingPixelDataArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / ReceivingPixelDataArgs Class / Association Property

    Association Property (ReceivingPixelDataArgs)
    In This Topic
    The association on which data is arriving
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Association As DicomAssociation
    'Usage

Dim instance As ReceivingPixelDataArgs
Dim value As DicomAssociation

value = instance.Association
    public DicomAssociation Association {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReceivingPixelDataArgs Class
    ReceivingPixelDataArgs Members


DicomObjects.EventArguments Namespace / ReceivingPixelDataArgs Class / Dataset Property

    Dataset Property (ReceivingPixelDataArgs)
    In This Topic
    The dataset so far
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Dataset As DicomDataSet
    'Usage

Dim instance As ReceivingPixelDataArgs
Dim value As DicomDataSet

value = instance.Dataset
    public DicomDataSet Dataset {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReceivingPixelDataArgs Class
    ReceivingPixelDataArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / ResponseReceivedArgs Class
Members

In This Topic
    ResponseReceivedArgs Class
    In This Topic
    Event argument passed in the ResponseReceived
    Object Model
    ResponseReceivedArgs ClassDicomAssociation Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class ResponseReceivedArgs
   Inherits System.EventArgs
    'Usage

Dim instance As ResponseReceivedArgs
    public class ResponseReceivedArgs : System.EventArgs
    Inheritance Hierarchy

    System.Object
    System.EventArgs
    DicomObjects.EventArguments.ResponseReceivedArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ResponseReceivedArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / ResponseReceivedArgs Class
Properties

In This Topic
    ResponseReceivedArgs Class Members
    In This Topic

    The following tables list the members exposed by ResponseReceivedArgs.

    Public Properties
     | Name | Description
Public Property | Association | The incoming association that contains the received responses
Public Property | ReturnStatus | The Status to be returned for Instance received via C-GET
    Top
    See Also

    Reference

    ResponseReceivedArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / ResponseReceivedArgs Class

In This Topic
    ResponseReceivedArgs Class Properties
    In This Topic

    For a list of all members of this type, see ResponseReceivedArgs members.

    Public Properties
     | Name | Description
Public Property | Association | The incoming association that contains the received responses
Public Property | ReturnStatus | The Status to be returned for Instance received via C-GET
    Top
    See Also

    Reference

    ResponseReceivedArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / ResponseReceivedArgs Class / Association Property

    Association Property (ResponseReceivedArgs)
    In This Topic
    The incoming association that contains the received responses
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Association As DicomAssociation
    'Usage

Dim instance As ResponseReceivedArgs
Dim value As DicomAssociation

value = instance.Association
    public DicomAssociation Association {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ResponseReceivedArgs Class
    ResponseReceivedArgs Members


DicomObjects.EventArguments Namespace / ResponseReceivedArgs Class / ReturnStatus Property

    ReturnStatus Property
    The Status to be returned for Instance received via C-GET
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property ReturnStatus As Integer
    'Usage

Dim instance As ResponseReceivedArgs
Dim value As Integer

instance.ReturnStatus = value

value = instance.ReturnStatus
    public int ReturnStatus {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ResponseReceivedArgs Class
    ResponseReceivedArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / ValidateFragmentsArgs Class
Members

In This Topic
    ValidateFragmentsArgs Class
    In This Topic
    Argument for the event.
    Object Model
    ValidateFragmentsArgs ClassDicomDataSet ClassDicomAttribute Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class ValidateFragmentsArgs
    'Usage

Dim instance As ValidateFragmentsArgs
    public class ValidateFragmentsArgs
    Inheritance Hierarchy

    System.Object
    DicomObjects.EventArguments.ValidateFragmentsArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidateFragmentsArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / ValidateFragmentsArgs Class
Properties

In This Topic
    ValidateFragmentsArgs Class Members
    In This Topic

    The following tables list the members exposed by ValidateFragmentsArgs.

    Public Constructors
     | Name | Description
Public Constructor | ValidateFragmentsArgs Constructor |
    Top
    Public Properties
     | Name | Description
Public Property | BasicOffsetTable | The basic offset table as read from the received data.
Public Property | DataSet | The dataset to which this pixel data belongs
Public Property | Fragments | The fragments exactly as received. These may be replaced, but if you do (whether by replacing individual Stream, or even by replacing the whole list of Streams, you must set to true to force DicomObjects to use your modified data.
Public Property | Modified | Indication that data has been modified. Unless this is set to true, the return values in and will be ignored.
    Top
    See Also

    Reference

    ValidateFragmentsArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / ValidateFragmentsArgs Class / ValidateFragmentsArgs Constructor

In This Topic
    ValidateFragmentsArgs Constructor
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New()
    'Usage

Dim instance As New ValidateFragmentsArgs()
    public ValidateFragmentsArgs()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidateFragmentsArgs Class
    ValidateFragmentsArgs Members


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / ValidateFragmentsArgs Class

In This Topic
    ValidateFragmentsArgs Class Properties
    In This Topic

    For a list of all members of this type, see ValidateFragmentsArgs members.

    Public Properties
     | Name | Description
Public Property | BasicOffsetTable | The basic offset table as read from the received data.
Public Property | DataSet | The dataset to which this pixel data belongs
Public Property | Fragments | The fragments exactly as received. These may be replaced, but if you do (whether by replacing individual Stream, or even by replacing the whole list of Streams, you must set to true to force DicomObjects to use your modified data.
Public Property | Modified | Indication that data has been modified. Unless this is set to true, the return values in and will be ignored.
    Top
    See Also

    Reference

    ValidateFragmentsArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / ValidateFragmentsArgs Class / BasicOffsetTable Property

    BasicOffsetTable Property
    The basic offset table as read from the received data.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property BasicOffsetTable As UInteger()
    'Usage

Dim instance As ValidateFragmentsArgs
Dim value() As UInteger

instance.BasicOffsetTable = value

value = instance.BasicOffsetTable
    public uint[] BasicOffsetTable {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidateFragmentsArgs Class
    ValidateFragmentsArgs Members


DicomObjects.EventArguments Namespace / ValidateFragmentsArgs Class / DataSet Property

    DataSet Property (ValidateFragmentsArgs)
    In This Topic
    The dataset to which this pixel data belongs
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property DataSet As DicomDataSet
    'Usage

Dim instance As ValidateFragmentsArgs
Dim value As DicomDataSet

value = instance.DataSet
    public DicomDataSet DataSet {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidateFragmentsArgs Class
    ValidateFragmentsArgs Members


DicomObjects.EventArguments Namespace / ValidateFragmentsArgs Class / Fragments Property

    Fragments Property
    The fragments exactly as received. These may be replaced, but if you do (whether by replacing individual Stream, or even by replacing the whole list of Streams, you must set to true to force DicomObjects to use your modified data.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Fragments As List(Of List(Of Stream))
    'Usage

Dim instance As ValidateFragmentsArgs
Dim value As List(Of List(Of Stream))

instance.Fragments = value

value = instance.Fragments
    public List<List<Stream>> Fragments {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidateFragmentsArgs Class
    ValidateFragmentsArgs Members


DicomObjects.EventArguments Namespace / ValidateFragmentsArgs Class / Modified Property

    Modified Property
    Indication that data has been modified. Unless this is set to true, the return values in and will be ignored.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Modified As Boolean
    'Usage

Dim instance As ValidateFragmentsArgs
Dim value As Boolean

instance.Modified = value

value = instance.Modified
    public bool Modified {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidateFragmentsArgs Class
    ValidateFragmentsArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / VerifyReceivedArgs Class
Members

In This Topic
    VerifyReceivedArgs Class
    In This Topic
    Argument passed in the VerifyReceived Event
    Object Model
    VerifyReceivedArgs ClassDicomDataSet ClassDicomAttribute ClassDicomDataSet ClassDicomAttribute ClassDicomDataSet ClassDicomAttribute ClassDicomAssociation ClassDicomDataSet ClassDicomAttribute Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class VerifyReceivedArgs
   Inherits OperationBaseArgs
    'Usage

Dim instance As VerifyReceivedArgs
    public class VerifyReceivedArgs : OperationBaseArgs
    Inheritance Hierarchy

    System.Object
    System.EventArgs
    DicomObjects.EventArguments.OperationBaseArgs
    DicomObjects.EventArguments.VerifyReceivedArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VerifyReceivedArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / VerifyReceivedArgs Class
Properties

In This Topic
    VerifyReceivedArgs Class Members
    In This Topic

    The following tables list the members exposed by VerifyReceivedArgs.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
    Top
    See Also

    Reference

    VerifyReceivedArgs Class
    DicomObjects.EventArguments Namespace


Inheritance Hierarchy
    DicomObjects.UIDs Namespace
    Classes
     | Class | Description
Class | ApplicationContexts |
Class | FramesOfReference |
Class | MetaSOPClasses |
Class | SOPClasses |
Class | TransferSyntaxes |
Class | UID |
Class | WellKnownInstances |
    See Also

    Reference

    DicomObjects.Core Assembly


%%PageItemTitle%%

DicomObjects.UIDs Namespace / ApplicationContexts Class
Members

In This Topic
    ApplicationContexts Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MustInherit NotInheritable Class ApplicationContexts
    'Usage

Dim instance As ApplicationContexts
    public static class ApplicationContexts
    Inheritance Hierarchy

    System.Object
    DicomObjects.UIDs.ApplicationContexts

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ApplicationContexts Members
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.UIDs Namespace / ApplicationContexts Class
Fields

In This Topic
    ApplicationContexts Class Members
    In This Topic

    The following tables list the members exposed by ApplicationContexts.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | DICOM30 |
    Top
    See Also

    Reference

    ApplicationContexts Class
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Fields$$

DicomObjects.UIDs Namespace / ApplicationContexts Class

    ApplicationContexts Class Fields
    In This Topic

    For a list of all members of this type, see ApplicationContexts members.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | DICOM30 |
    Top
    See Also

    Reference

    ApplicationContexts Class
    DicomObjects.UIDs Namespace


DicomObjects.UIDs Namespace / ApplicationContexts Class / DICOM30 Field

    DICOM30 Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly DICOM30 As UID
    'Usage

Dim value As UID

value = ApplicationContexts.DICOM30
    public static readonly UID DICOM30
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ApplicationContexts Class
    ApplicationContexts Members


%%PageItemTitle%%

DicomObjects.UIDs Namespace / FramesOfReference Class
Members

In This Topic
    FramesOfReference Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MustInherit NotInheritable Class FramesOfReference
    'Usage

Dim instance As FramesOfReference
    public static class FramesOfReference
    Inheritance Hierarchy

    System.Object
    DicomObjects.UIDs.FramesOfReference

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Members
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.UIDs Namespace / FramesOfReference Class
Fields

In This Topic
    FramesOfReference Class Members
    In This Topic

    The following tables list the members exposed by FramesOfReference.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | ICBM452T1FrameofReference |
static (Shared in Visual Basic) | ICBMSingleSubjectMRIFrameofReference |
static (Shared in Visual Basic) | SPM2AVG152PDFrameofReference |
static (Shared in Visual Basic) | SPM2AVG152T1FrameofReference |
static (Shared in Visual Basic) | SPM2AVG152T2FrameofReference |
static (Shared in Visual Basic) | SPM2AVG305T1FrameofReference |
static (Shared in Visual Basic) | SPM2BRAINMASKFrameofReference |
static (Shared in Visual Basic) | SPM2CSFFrameofReference |
static (Shared in Visual Basic) | SPM2EPIFrameofReference |
static (Shared in Visual Basic) | SPM2FILT1FrameofReference |
static (Shared in Visual Basic) | SPM2GRAYFrameofReference |
static (Shared in Visual Basic) | SPM2PDFrameofReference |
static (Shared in Visual Basic) | SPM2PETFrameofReference |
static (Shared in Visual Basic) | SPM2SINGLESUBJT1FrameofReference |
static (Shared in Visual Basic) | SPM2SPECTFrameofReference |
static (Shared in Visual Basic) | SPM2T1FrameofReference |
static (Shared in Visual Basic) | SPM2T2FrameofReference |
static (Shared in Visual Basic) | SPM2TRANSMFrameofReference |
static (Shared in Visual Basic) | SPM2WHITEFrameofReference |
static (Shared in Visual Basic) | TalairachBrainAtlasFrameofReference |
    Top
    See Also

    Reference

    FramesOfReference Class
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Fields$$

DicomObjects.UIDs Namespace / FramesOfReference Class

    FramesOfReference Class Fields
    In This Topic

    For a list of all members of this type, see FramesOfReference members.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | ICBM452T1FrameofReference |
static (Shared in Visual Basic) | ICBMSingleSubjectMRIFrameofReference |
static (Shared in Visual Basic) | SPM2AVG152PDFrameofReference |
static (Shared in Visual Basic) | SPM2AVG152T1FrameofReference |
static (Shared in Visual Basic) | SPM2AVG152T2FrameofReference |
static (Shared in Visual Basic) | SPM2AVG305T1FrameofReference |
static (Shared in Visual Basic) | SPM2BRAINMASKFrameofReference |
static (Shared in Visual Basic) | SPM2CSFFrameofReference |
static (Shared in Visual Basic) | SPM2EPIFrameofReference |
static (Shared in Visual Basic) | SPM2FILT1FrameofReference |
static (Shared in Visual Basic) | SPM2GRAYFrameofReference |
static (Shared in Visual Basic) | SPM2PDFrameofReference |
static (Shared in Visual Basic) | SPM2PETFrameofReference |
static (Shared in Visual Basic) | SPM2SINGLESUBJT1FrameofReference |
static (Shared in Visual Basic) | SPM2SPECTFrameofReference |
static (Shared in Visual Basic) | SPM2T1FrameofReference |
static (Shared in Visual Basic) | SPM2T2FrameofReference |
static (Shared in Visual Basic) | SPM2TRANSMFrameofReference |
static (Shared in Visual Basic) | SPM2WHITEFrameofReference |
static (Shared in Visual Basic) | TalairachBrainAtlasFrameofReference |
    Top
    See Also

    Reference

    FramesOfReference Class
    DicomObjects.UIDs Namespace


DicomObjects.UIDs Namespace / FramesOfReference Class / ICBM452T1FrameofReference Field

    ICBM452T1FrameofReference Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ICBM452T1FrameofReference As UID
    'Usage

Dim value As UID

value = FramesOfReference.ICBM452T1FrameofReference
    public static readonly UID ICBM452T1FrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / ICBMSingleSubjectMRIFrameofReference Field

    ICBMSingleSubjectMRIFrameofReference Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ICBMSingleSubjectMRIFrameofReference As UID
    'Usage

Dim value As UID

value = FramesOfReference.ICBMSingleSubjectMRIFrameofReference
    public static readonly UID ICBMSingleSubjectMRIFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2AVG152PDFrameofReference Field

    SPM2AVG152PDFrameofReference Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SPM2AVG152PDFrameofReference As UID
    'Usage

Dim value As UID

value = FramesOfReference.SPM2AVG152PDFrameofReference
    public static readonly UID SPM2AVG152PDFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2AVG152T1FrameofReference Field

    SPM2AVG152T1FrameofReference Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SPM2AVG152T1FrameofReference As UID
    'Usage

Dim value As UID

value = FramesOfReference.SPM2AVG152T1FrameofReference
    public static readonly UID SPM2AVG152T1FrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2AVG152T2FrameofReference Field

    SPM2AVG152T2FrameofReference Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SPM2AVG152T2FrameofReference As UID
    'Usage

Dim value As UID

value = FramesOfReference.SPM2AVG152T2FrameofReference
    public static readonly UID SPM2AVG152T2FrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2AVG305T1FrameofReference Field

    SPM2AVG305T1FrameofReference Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SPM2AVG305T1FrameofReference As UID
    'Usage

Dim value As UID

value = FramesOfReference.SPM2AVG305T1FrameofReference
    public static readonly UID SPM2AVG305T1FrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2BRAINMASKFrameofReference Field

    SPM2BRAINMASKFrameofReference Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SPM2BRAINMASKFrameofReference As UID
    'Usage

Dim value As UID

value = FramesOfReference.SPM2BRAINMASKFrameofReference
    public static readonly UID SPM2BRAINMASKFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2CSFFrameofReference Field

    SPM2CSFFrameofReference Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SPM2CSFFrameofReference As UID
    'Usage

Dim value As UID

value = FramesOfReference.SPM2CSFFrameofReference
    public static readonly UID SPM2CSFFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2EPIFrameofReference Field

    SPM2EPIFrameofReference Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SPM2EPIFrameofReference As UID
    'Usage

Dim value As UID

value = FramesOfReference.SPM2EPIFrameofReference
    public static readonly UID SPM2EPIFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2FILT1FrameofReference Field

    SPM2FILT1FrameofReference Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SPM2FILT1FrameofReference As UID
    'Usage

Dim value As UID

value = FramesOfReference.SPM2FILT1FrameofReference
    public static readonly UID SPM2FILT1FrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2GRAYFrameofReference Field

    SPM2GRAYFrameofReference Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SPM2GRAYFrameofReference As UID
    'Usage

Dim value As UID

value = FramesOfReference.SPM2GRAYFrameofReference
    public static readonly UID SPM2GRAYFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2PDFrameofReference Field

    SPM2PDFrameofReference Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SPM2PDFrameofReference As UID
    'Usage

Dim value As UID

value = FramesOfReference.SPM2PDFrameofReference
    public static readonly UID SPM2PDFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2PETFrameofReference Field

    SPM2PETFrameofReference Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SPM2PETFrameofReference As UID
    'Usage

Dim value As UID

value = FramesOfReference.SPM2PETFrameofReference
    public static readonly UID SPM2PETFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2SINGLESUBJT1FrameofReference Field

    SPM2SINGLESUBJT1FrameofReference Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SPM2SINGLESUBJT1FrameofReference As UID
    'Usage

Dim value As UID

value = FramesOfReference.SPM2SINGLESUBJT1FrameofReference
    public static readonly UID SPM2SINGLESUBJT1FrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2SPECTFrameofReference Field

    SPM2SPECTFrameofReference Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SPM2SPECTFrameofReference As UID
    'Usage

Dim value As UID

value = FramesOfReference.SPM2SPECTFrameofReference
    public static readonly UID SPM2SPECTFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2T1FrameofReference Field

    SPM2T1FrameofReference Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SPM2T1FrameofReference As UID
    'Usage

Dim value As UID

value = FramesOfReference.SPM2T1FrameofReference
    public static readonly UID SPM2T1FrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2T2FrameofReference Field

    SPM2T2FrameofReference Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SPM2T2FrameofReference As UID
    'Usage

Dim value As UID

value = FramesOfReference.SPM2T2FrameofReference
    public static readonly UID SPM2T2FrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2TRANSMFrameofReference Field

    SPM2TRANSMFrameofReference Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SPM2TRANSMFrameofReference As UID
    'Usage

Dim value As UID

value = FramesOfReference.SPM2TRANSMFrameofReference
    public static readonly UID SPM2TRANSMFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2WHITEFrameofReference Field

    SPM2WHITEFrameofReference Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SPM2WHITEFrameofReference As UID
    'Usage

Dim value As UID

value = FramesOfReference.SPM2WHITEFrameofReference
    public static readonly UID SPM2WHITEFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / TalairachBrainAtlasFrameofReference Field

    TalairachBrainAtlasFrameofReference Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly TalairachBrainAtlasFrameofReference As UID
    'Usage

Dim value As UID

value = FramesOfReference.TalairachBrainAtlasFrameofReference
    public static readonly UID TalairachBrainAtlasFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


%%PageItemTitle%%

DicomObjects.UIDs Namespace / MetaSOPClasses Class
Members

In This Topic
    MetaSOPClasses Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MustInherit NotInheritable Class MetaSOPClasses
    'Usage

Dim instance As MetaSOPClasses
    public static class MetaSOPClasses
    Inheritance Hierarchy

    System.Object
    DicomObjects.UIDs.MetaSOPClasses

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    MetaSOPClasses Members
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.UIDs Namespace / MetaSOPClasses Class
Fields

In This Topic
    MetaSOPClasses Class Members
    In This Topic

    The following tables list the members exposed by MetaSOPClasses.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | BasicColorPrint |
static (Shared in Visual Basic) | BasicGrayscalePrint |
static (Shared in Visual Basic) | DetachedPatient |
static (Shared in Visual Basic) | DetachedResults |
static (Shared in Visual Basic) | DetachedStudy |
static (Shared in Visual Basic) | GeneralPurposeWorklist |
static (Shared in Visual Basic) | PullStoredPrint |
static (Shared in Visual Basic) | ReferencedColorPrint |
static (Shared in Visual Basic) | ReferencedGrayscalePrint |
    Top
    See Also

    Reference

    MetaSOPClasses Class
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Fields$$

DicomObjects.UIDs Namespace / MetaSOPClasses Class

    MetaSOPClasses Class Fields
    In This Topic

    For a list of all members of this type, see MetaSOPClasses members.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | BasicColorPrint |
static (Shared in Visual Basic) | BasicGrayscalePrint |
static (Shared in Visual Basic) | DetachedPatient |
static (Shared in Visual Basic) | DetachedResults |
static (Shared in Visual Basic) | DetachedStudy |
static (Shared in Visual Basic) | GeneralPurposeWorklist |
static (Shared in Visual Basic) | PullStoredPrint |
static (Shared in Visual Basic) | ReferencedColorPrint |
static (Shared in Visual Basic) | ReferencedGrayscalePrint |
    Top
    See Also

    Reference

    MetaSOPClasses Class
    DicomObjects.UIDs Namespace


DicomObjects.UIDs Namespace / MetaSOPClasses Class / BasicColorPrint Field

    BasicColorPrint Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly BasicColorPrint As UID
    'Usage

Dim value As UID

value = MetaSOPClasses.BasicColorPrint
    public static readonly UID BasicColorPrint
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    MetaSOPClasses Class
    MetaSOPClasses Members


DicomObjects.UIDs Namespace / MetaSOPClasses Class / BasicGrayscalePrint Field

    BasicGrayscalePrint Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly BasicGrayscalePrint As UID
    'Usage

Dim value As UID

value = MetaSOPClasses.BasicGrayscalePrint
    public static readonly UID BasicGrayscalePrint
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    MetaSOPClasses Class
    MetaSOPClasses Members


DicomObjects.UIDs Namespace / MetaSOPClasses Class / DetachedPatient Field

    DetachedPatient Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly DetachedPatient As UID
    'Usage

Dim value As UID

value = MetaSOPClasses.DetachedPatient
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID DetachedPatient
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    MetaSOPClasses Class
    MetaSOPClasses Members


DicomObjects.UIDs Namespace / MetaSOPClasses Class / DetachedResults Field

    DetachedResults Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly DetachedResults As UID
    'Usage

Dim value As UID

value = MetaSOPClasses.DetachedResults
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID DetachedResults
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    MetaSOPClasses Class
    MetaSOPClasses Members


DicomObjects.UIDs Namespace / MetaSOPClasses Class / DetachedStudy Field

    DetachedStudy Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly DetachedStudy As UID
    'Usage

Dim value As UID

value = MetaSOPClasses.DetachedStudy
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID DetachedStudy
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    MetaSOPClasses Class
    MetaSOPClasses Members


DicomObjects.UIDs Namespace / MetaSOPClasses Class / GeneralPurposeWorklist Field

    GeneralPurposeWorklist Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly GeneralPurposeWorklist As UID
    'Usage

Dim value As UID

value = MetaSOPClasses.GeneralPurposeWorklist
    public static readonly UID GeneralPurposeWorklist
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    MetaSOPClasses Class
    MetaSOPClasses Members


DicomObjects.UIDs Namespace / MetaSOPClasses Class / PullStoredPrint Field

    PullStoredPrint Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly PullStoredPrint As UID
    'Usage

Dim value As UID

value = MetaSOPClasses.PullStoredPrint
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID PullStoredPrint
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    MetaSOPClasses Class
    MetaSOPClasses Members


DicomObjects.UIDs Namespace / MetaSOPClasses Class / ReferencedColorPrint Field

    ReferencedColorPrint Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementions")>
Public Shared ReadOnly ReferencedColorPrint As UID
    'Usage

Dim value As UID

value = MetaSOPClasses.ReferencedColorPrint
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementions")]
public static readonly UID ReferencedColorPrint
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    MetaSOPClasses Class
    MetaSOPClasses Members


DicomObjects.UIDs Namespace / MetaSOPClasses Class / ReferencedGrayscalePrint Field

    ReferencedGrayscalePrint Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly ReferencedGrayscalePrint As UID
    'Usage

Dim value As UID

value = MetaSOPClasses.ReferencedGrayscalePrint
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID ReferencedGrayscalePrint
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    MetaSOPClasses Class
    MetaSOPClasses Members


%%PageItemTitle%%

DicomObjects.UIDs Namespace / SOPClasses Class
Members

In This Topic
    SOPClasses Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MustInherit NotInheritable Class SOPClasses
    'Usage

Dim instance As SOPClasses
    public static class SOPClasses
    Inheritance Hierarchy

    System.Object
    DicomObjects.UIDs.SOPClasses

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Members
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.UIDs Namespace / SOPClasses Class
Fields

In This Topic
    SOPClasses Class Members
    In This Topic

    The following tables list the members exposed by SOPClasses.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | AmbulatoryECGWaveform |
static (Shared in Visual Basic) | ArterialPulseWaveform |
static (Shared in Visual Basic) | AudioSRTrial |
static (Shared in Visual Basic) | AutorefractionMeasurements |
static (Shared in Visual Basic) | BasicAnnotationBox |
static (Shared in Visual Basic) | BasicColorImageBox |
static (Shared in Visual Basic) | BasicFilmBox |
static (Shared in Visual Basic) | BasicFilmSession |
static (Shared in Visual Basic) | BasicGrayscaleImageBox |
static (Shared in Visual Basic) | BasicPrintImageOverlayBox |
static (Shared in Visual Basic) | BasicStructuredDisplay |
static (Shared in Visual Basic) | BasicStudyContentNotification |
static (Shared in Visual Basic) | BasicTextSR |
static (Shared in Visual Basic) | BasicVoiceAudioWaveform |
static (Shared in Visual Basic) | BlendingSoftcopyPresentationState |
static (Shared in Visual Basic) | BreastImagingRelevantPatientInformationQuery |
static (Shared in Visual Basic) | BreastTomosynthesisImage |
static (Shared in Visual Basic) | CardiacElectrophysiologyWaveform |
static (Shared in Visual Basic) | CardiacRelevantPatientInformationQuery |
static (Shared in Visual Basic) | ChestCADSR |
static (Shared in Visual Basic) | ColonCADSR |
static (Shared in Visual Basic) | ColorPalette |
static (Shared in Visual Basic) | ColorPaletteQRFIND |
static (Shared in Visual Basic) | ColorPaletteQRGET |
static (Shared in Visual Basic) | ColorPaletteQRMOVE |
static (Shared in Visual Basic) | ColorSoftcopyPresentationState |
static (Shared in Visual Basic) | CompositeInstanceRootRetrieve_GET |
static (Shared in Visual Basic) | CompositeInstanceRootRetrieve_MOVE |
static (Shared in Visual Basic) | CompositeInstanceRootRetrieveWithoutBulkData_GET |
static (Shared in Visual Basic) | ComprehensiveSR |
static (Shared in Visual Basic) | ComprehensiveSRTrial |
static (Shared in Visual Basic) | ComputedRadiography |
static (Shared in Visual Basic) | CT |
static (Shared in Visual Basic) | DeformableSpatialRegistration |
static (Shared in Visual Basic) | DetachedInterpretationManagement |
static (Shared in Visual Basic) | DetachedPatientManagement |
static (Shared in Visual Basic) | DetachedResultsManagement |
static (Shared in Visual Basic) | DetachedStudyManagement |
static (Shared in Visual Basic) | DetachedVisitManagement |
static (Shared in Visual Basic) | DetailSRTrial |
static (Shared in Visual Basic) | DICOSCTImage |
static (Shared in Visual Basic) | DICOSDigitalXRayImageForPresentation |
static (Shared in Visual Basic) | DICOSDigitalXRayImageForProcessing |
static (Shared in Visual Basic) | DICOSThreatDetectionReport |
static (Shared in Visual Basic) | DigitalIntraoralXRay_Presentation |
static (Shared in Visual Basic) | DigitalIntraoralXRay_Processing |
static (Shared in Visual Basic) | DigitalMammographyXRay_Presentation |
static (Shared in Visual Basic) | DigitalMammographyXRay_Processing |
static (Shared in Visual Basic) | DigitalXRay_Presentation |
static (Shared in Visual Basic) | DigitalXRay_Processing |
static (Shared in Visual Basic) | EddyCurrentImage |
static (Shared in Visual Basic) | EddyCurrentMultiframeImage |
static (Shared in Visual Basic) | EncapsulatedCDA |
static (Shared in Visual Basic) | EncapsulatedPDF |
static (Shared in Visual Basic) | EncapsulatedSTL |
static (Shared in Visual Basic) | EnhancedCT |
static (Shared in Visual Basic) | EnhancedMR |
static (Shared in Visual Basic) | EnhancedMRColorImage |
static (Shared in Visual Basic) | EnhancedPETImage |
static (Shared in Visual Basic) | EnhancedSR |
static (Shared in Visual Basic) | EnhancedUSVolume |
static (Shared in Visual Basic) | EnhancedXAImage |
static (Shared in Visual Basic) | EnhancedXRFImage |
static (Shared in Visual Basic) | GeneralAudioWaveform |
static (Shared in Visual Basic) | GeneralECGWaveform |
static (Shared in Visual Basic) | GeneralPurposePerformedProcedureStep |
static (Shared in Visual Basic) | GeneralPurposeScheduledProcedureStep |
static (Shared in Visual Basic) | GeneralPurposeWorklistQRFIND |
static (Shared in Visual Basic) | GeneralRelevantPatientInformationQuery |
static (Shared in Visual Basic) | GenericImplantTemplate |
static (Shared in Visual Basic) | GenericImplantTemplateQRFIND |
static (Shared in Visual Basic) | GenericImplantTemplateQRGET |
static (Shared in Visual Basic) | GenericImplantTemplateQRMOVE |
static (Shared in Visual Basic) | GrayscaleSoftcopyPresentationState |
static (Shared in Visual Basic) | HangingProtocol |
static (Shared in Visual Basic) | HangingProtocolQRFIND |
static (Shared in Visual Basic) | HangingProtocolQRGET |
static (Shared in Visual Basic) | HangingProtocolQRMOVE |
static (Shared in Visual Basic) | HardcopyColor |
static (Shared in Visual Basic) | HardcopyGrayscale |
static (Shared in Visual Basic) | HemodynamicWaveform |
static (Shared in Visual Basic) | ImageOverlayBox |
static (Shared in Visual Basic) | ImplantAssemblyTemplate |
static (Shared in Visual Basic) | ImplantAssemblyTemplateQRFIND |
static (Shared in Visual Basic) | ImplantAssemblyTemplateQRGET |
static (Shared in Visual Basic) | ImplantAssemblyTemplateQRMOVE |
static (Shared in Visual Basic) | ImplantationPlanSR |
static (Shared in Visual Basic) | ImplantTemplateGroup |
static (Shared in Visual Basic) | ImplantTemplateGroupQRFIND |
static (Shared in Visual Basic) | ImplantTemplateGroupQRGET |
static (Shared in Visual Basic) | ImplantTemplateGroupQRMOVE |
static (Shared in Visual Basic) | InstanceAvailabilityNotification |
static (Shared in Visual Basic) | IntraocularLensCalculations |
static (Shared in Visual Basic) | IntravascularOpticalCoherenceTomographyImageForPresentation |
static (Shared in Visual Basic) | IntravascularOpticalCoherenceTomographyImageForProcessing |
static (Shared in Visual Basic) | KeratometryMeasurements |
static (Shared in Visual Basic) | KeyObjectSelectionDocument |
static (Shared in Visual Basic) | LensometryMeasurements |
static (Shared in Visual Basic) | MacularGridThicknessandVolumeReport |
static (Shared in Visual Basic) | MammographyCADSR |
static (Shared in Visual Basic) | MediaCreationManagementUID |
static (Shared in Visual Basic) | MediaStorageDirectory |
static (Shared in Visual Basic) | ModalityPerformedProcedureStep |
static (Shared in Visual Basic) | ModalityPerformedProcedureStepNotification |
static (Shared in Visual Basic) | ModalityPerformedProcedureStepRetrieve |
static (Shared in Visual Basic) | ModalityWorklistQRFIND |
static (Shared in Visual Basic) | MR |
static (Shared in Visual Basic) | MRSpectroscopy |
static (Shared in Visual Basic) | MultiFrameGrayscaleByteSC |
static (Shared in Visual Basic) | MultiFrameGrayscaleWordSC |
static (Shared in Visual Basic) | MultiFrameSingleBitSC |
static (Shared in Visual Basic) | MultiFrameTrueColorSC |
static (Shared in Visual Basic) | NuclearMedicine |
static (Shared in Visual Basic) | OldNuclearMedicine |
static (Shared in Visual Basic) | OldUltrasound |
static (Shared in Visual Basic) | OldUltrasoundMultiframe |
static (Shared in Visual Basic) | OphthalmicAxialMeasurements |
static (Shared in Visual Basic) | OphthalmicPhotography16Bit |
static (Shared in Visual Basic) | OphthalmicPhotography8Bit |
static (Shared in Visual Basic) | OphthalmicTomographyImage |
static (Shared in Visual Basic) | OphthalmicVisualFieldStaticPerimetryMeasurements |
static (Shared in Visual Basic) | PatientRootQR_FIND |
static (Shared in Visual Basic) | PatientRootQR_GET |
static (Shared in Visual Basic) | PatientRootQR_MOVE |
static (Shared in Visual Basic) | PatientStudyOnlyQR_FIND |
static (Shared in Visual Basic) | PatientStudyOnlyQR_GET |
static (Shared in Visual Basic) | PatientStudyOnlyQR_MOVE |
static (Shared in Visual Basic) | PositronEmissionTomography |
static (Shared in Visual Basic) | PresentationLUT |
static (Shared in Visual Basic) | Printer |
static (Shared in Visual Basic) | PrinterConfigurationRetrieval |
static (Shared in Visual Basic) | PrintJob |
static (Shared in Visual Basic) | PrintQueueManagement |
static (Shared in Visual Basic) | ProceduralEventLogging |
static (Shared in Visual Basic) | ProcedureLog |
static (Shared in Visual Basic) | ProductCharacteristicsQuery |
static (Shared in Visual Basic) | PseudoColorSoftcopyPresentationState |
static (Shared in Visual Basic) | PullPrintRequest |
static (Shared in Visual Basic) | RawData |
static (Shared in Visual Basic) | RealWorldValueMapping |
static (Shared in Visual Basic) | ReferencedImageBox |
static (Shared in Visual Basic) | RespiratoryWaveform |
static (Shared in Visual Basic) | RT |
static (Shared in Visual Basic) | RTBeamsDeliveryInstruction |
static (Shared in Visual Basic) | RTBeamsDeliveryInstructionTrial |
static (Shared in Visual Basic) | RTBeamsTreatmentRecord |
static (Shared in Visual Basic) | RTBrachyTreatmentRecord |
static (Shared in Visual Basic) | RTConventionalMachineVerification |
static (Shared in Visual Basic) | RTConventionalMachineVerificationTrial |
static (Shared in Visual Basic) | RTDose |
static (Shared in Visual Basic) | RTIonBeamsTreatmentRecord |
static (Shared in Visual Basic) | RTIonMachineVerification |
static (Shared in Visual Basic) | RTIonMachineVerificationTrial |
static (Shared in Visual Basic) | RTIonPlan |
static (Shared in Visual Basic) | RTPlan |
static (Shared in Visual Basic) | RTStructureSet |
static (Shared in Visual Basic) | RTTreatmentSummaryRecord |
static (Shared in Visual Basic) | SecondaryCapture |
static (Shared in Visual Basic) | Segmentation |
static (Shared in Visual Basic) | SpatialFiducials |
static (Shared in Visual Basic) | SpatialRegistration |
static (Shared in Visual Basic) | SpectaclePrescriptionReport |
static (Shared in Visual Basic) | StandaloneCurve |
static (Shared in Visual Basic) | StandaloneModalityLUT |
static (Shared in Visual Basic) | StandaloneOverlay |
static (Shared in Visual Basic) | StandalonePETCurve |
static (Shared in Visual Basic) | StandaloneVOILUT |
static (Shared in Visual Basic) | StereometricRelationship |
static (Shared in Visual Basic) | StorageCommitmentPull |
static (Shared in Visual Basic) | StorageCommitmentPush |
static (Shared in Visual Basic) | StorageServiceClass |
static (Shared in Visual Basic) | StoredPrint |
static (Shared in Visual Basic) | StudyComponentManagement |
static (Shared in Visual Basic) | StudyRootQR_FIND |
static (Shared in Visual Basic) | StudyRootQR_GET |
static (Shared in Visual Basic) | StudyRootQR_MOVE |
static (Shared in Visual Basic) | SubjectiveRefractionMeasurements |
static (Shared in Visual Basic) | SubstanceAdministrationLogging |
static (Shared in Visual Basic) | SubstanceApprovalQuery |
static (Shared in Visual Basic) | SurfaceSegmentation |
static (Shared in Visual Basic) | TextSRTrial |
static (Shared in Visual Basic) | TwelveLeadECGWaveform |
static (Shared in Visual Basic) | Ultrasound |
static (Shared in Visual Basic) | UltrasoundMultiframe |
static (Shared in Visual Basic) | UnifiedProcedureStepEvent |
static (Shared in Visual Basic) | UnifiedProcedureStepEventTrial |
static (Shared in Visual Basic) | UnifiedProcedureStepPull |
static (Shared in Visual Basic) | UnifiedProcedureStepPullTrial |
static (Shared in Visual Basic) | UnifiedProcedureStepPush |
static (Shared in Visual Basic) | UnifiedProcedureStepPushTrial |
static (Shared in Visual Basic) | UnifiedProcedureStepWatch |
static (Shared in Visual Basic) | UnifiedProcedureStepWatchTrial |
static (Shared in Visual Basic) | UnifiedWorklistandProcedureStepServiceClass |
static (Shared in Visual Basic) | UnifiedWorklistandProcedureStepServiceClassTrial |
static (Shared in Visual Basic) | Verification |
static (Shared in Visual Basic) | VideoEndoscopic |
static (Shared in Visual Basic) | VideoMicroscopic |
static (Shared in Visual Basic) | VideoPhotographic |
static (Shared in Visual Basic) | VisualAcuityMeasurements |
static (Shared in Visual Basic) | VLEndoscopic |
static (Shared in Visual Basic) | VLMicroscopic |
static (Shared in Visual Basic) | VLPhotographic |
static (Shared in Visual Basic) | VLSlideCoordinatesMicroscopic |
static (Shared in Visual Basic) | VLWholeSlideMicroscopyImage |
static (Shared in Visual Basic) | VOILUTBox |
static (Shared in Visual Basic) | WaveformTrial |
static (Shared in Visual Basic) | XA_XRFGrayscaleSoftcopyPresentationState |
static (Shared in Visual Basic) | XRay3DAngiographicImage |
static (Shared in Visual Basic) | XRay3DCraniofacialImage |
static (Shared in Visual Basic) | XRayAngiographic |
static (Shared in Visual Basic) | XRayAngiographicBiPlane |
static (Shared in Visual Basic) | XRayRadiationDoseSR |
static (Shared in Visual Basic) | XRayRadiofluoroscopic |
    Top
    See Also

    Reference

    SOPClasses Class
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Fields$$

DicomObjects.UIDs Namespace / SOPClasses Class

    SOPClasses Class Fields
    In This Topic

    For a list of all members of this type, see SOPClasses members.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | AmbulatoryECGWaveform |
static (Shared in Visual Basic) | ArterialPulseWaveform |
static (Shared in Visual Basic) | AudioSRTrial |
static (Shared in Visual Basic) | AutorefractionMeasurements |
static (Shared in Visual Basic) | BasicAnnotationBox |
static (Shared in Visual Basic) | BasicColorImageBox |
static (Shared in Visual Basic) | BasicFilmBox |
static (Shared in Visual Basic) | BasicFilmSession |
static (Shared in Visual Basic) | BasicGrayscaleImageBox |
static (Shared in Visual Basic) | BasicPrintImageOverlayBox |
static (Shared in Visual Basic) | BasicStructuredDisplay |
static (Shared in Visual Basic) | BasicStudyContentNotification |
static (Shared in Visual Basic) | BasicTextSR |
static (Shared in Visual Basic) | BasicVoiceAudioWaveform |
static (Shared in Visual Basic) | BlendingSoftcopyPresentationState |
static (Shared in Visual Basic) | BreastImagingRelevantPatientInformationQuery |
static (Shared in Visual Basic) | BreastTomosynthesisImage |
static (Shared in Visual Basic) | CardiacElectrophysiologyWaveform |
static (Shared in Visual Basic) | CardiacRelevantPatientInformationQuery |
static (Shared in Visual Basic) | ChestCADSR |
static (Shared in Visual Basic) | ColonCADSR |
static (Shared in Visual Basic) | ColorPalette |
static (Shared in Visual Basic) | ColorPaletteQRFIND |
static (Shared in Visual Basic) | ColorPaletteQRGET |
static (Shared in Visual Basic) | ColorPaletteQRMOVE |
static (Shared in Visual Basic) | ColorSoftcopyPresentationState |
static (Shared in Visual Basic) | CompositeInstanceRootRetrieve_GET |
static (Shared in Visual Basic) | CompositeInstanceRootRetrieve_MOVE |
static (Shared in Visual Basic) | CompositeInstanceRootRetrieveWithoutBulkData_GET |
static (Shared in Visual Basic) | ComprehensiveSR |
static (Shared in Visual Basic) | ComprehensiveSRTrial |
static (Shared in Visual Basic) | ComputedRadiography |
static (Shared in Visual Basic) | CT |
static (Shared in Visual Basic) | DeformableSpatialRegistration |
static (Shared in Visual Basic) | DetachedInterpretationManagement |
static (Shared in Visual Basic) | DetachedPatientManagement |
static (Shared in Visual Basic) | DetachedResultsManagement |
static (Shared in Visual Basic) | DetachedStudyManagement |
static (Shared in Visual Basic) | DetachedVisitManagement |
static (Shared in Visual Basic) | DetailSRTrial |
static (Shared in Visual Basic) | DICOSCTImage |
static (Shared in Visual Basic) | DICOSDigitalXRayImageForPresentation |
static (Shared in Visual Basic) | DICOSDigitalXRayImageForProcessing |
static (Shared in Visual Basic) | DICOSThreatDetectionReport |
static (Shared in Visual Basic) | DigitalIntraoralXRay_Presentation |
static (Shared in Visual Basic) | DigitalIntraoralXRay_Processing |
static (Shared in Visual Basic) | DigitalMammographyXRay_Presentation |
static (Shared in Visual Basic) | DigitalMammographyXRay_Processing |
static (Shared in Visual Basic) | DigitalXRay_Presentation |
static (Shared in Visual Basic) | DigitalXRay_Processing |
static (Shared in Visual Basic) | EddyCurrentImage |
static (Shared in Visual Basic) | EddyCurrentMultiframeImage |
static (Shared in Visual Basic) | EncapsulatedCDA |
static (Shared in Visual Basic) | EncapsulatedPDF |
static (Shared in Visual Basic) | EncapsulatedSTL |
static (Shared in Visual Basic) | EnhancedCT |
static (Shared in Visual Basic) | EnhancedMR |
static (Shared in Visual Basic) | EnhancedMRColorImage |
static (Shared in Visual Basic) | EnhancedPETImage |
static (Shared in Visual Basic) | EnhancedSR |
static (Shared in Visual Basic) | EnhancedUSVolume |
static (Shared in Visual Basic) | EnhancedXAImage |
static (Shared in Visual Basic) | EnhancedXRFImage |
static (Shared in Visual Basic) | GeneralAudioWaveform |
static (Shared in Visual Basic) | GeneralECGWaveform |
static (Shared in Visual Basic) | GeneralPurposePerformedProcedureStep |
static (Shared in Visual Basic) | GeneralPurposeScheduledProcedureStep |
static (Shared in Visual Basic) | GeneralPurposeWorklistQRFIND |
static (Shared in Visual Basic) | GeneralRelevantPatientInformationQuery |
static (Shared in Visual Basic) | GenericImplantTemplate |
static (Shared in Visual Basic) | GenericImplantTemplateQRFIND |
static (Shared in Visual Basic) | GenericImplantTemplateQRGET |
static (Shared in Visual Basic) | GenericImplantTemplateQRMOVE |
static (Shared in Visual Basic) | GrayscaleSoftcopyPresentationState |
static (Shared in Visual Basic) | HangingProtocol |
static (Shared in Visual Basic) | HangingProtocolQRFIND |
static (Shared in Visual Basic) | HangingProtocolQRGET |
static (Shared in Visual Basic) | HangingProtocolQRMOVE |
static (Shared in Visual Basic) | HardcopyColor |
static (Shared in Visual Basic) | HardcopyGrayscale |
static (Shared in Visual Basic) | HemodynamicWaveform |
static (Shared in Visual Basic) | ImageOverlayBox |
static (Shared in Visual Basic) | ImplantAssemblyTemplate |
static (Shared in Visual Basic) | ImplantAssemblyTemplateQRFIND |
static (Shared in Visual Basic) | ImplantAssemblyTemplateQRGET |
static (Shared in Visual Basic) | ImplantAssemblyTemplateQRMOVE |
static (Shared in Visual Basic) | ImplantationPlanSR |
static (Shared in Visual Basic) | ImplantTemplateGroup |
static (Shared in Visual Basic) | ImplantTemplateGroupQRFIND |
static (Shared in Visual Basic) | ImplantTemplateGroupQRGET |
static (Shared in Visual Basic) | ImplantTemplateGroupQRMOVE |
static (Shared in Visual Basic) | InstanceAvailabilityNotification |
static (Shared in Visual Basic) | IntraocularLensCalculations |
static (Shared in Visual Basic) | IntravascularOpticalCoherenceTomographyImageForPresentation |
static (Shared in Visual Basic) | IntravascularOpticalCoherenceTomographyImageForProcessing |
static (Shared in Visual Basic) | KeratometryMeasurements |
static (Shared in Visual Basic) | KeyObjectSelectionDocument |
static (Shared in Visual Basic) | LensometryMeasurements |
static (Shared in Visual Basic) | MacularGridThicknessandVolumeReport |
static (Shared in Visual Basic) | MammographyCADSR |
static (Shared in Visual Basic) | MediaCreationManagementUID |
static (Shared in Visual Basic) | MediaStorageDirectory |
static (Shared in Visual Basic) | ModalityPerformedProcedureStep |
static (Shared in Visual Basic) | ModalityPerformedProcedureStepNotification |
static (Shared in Visual Basic) | ModalityPerformedProcedureStepRetrieve |
static (Shared in Visual Basic) | ModalityWorklistQRFIND |
static (Shared in Visual Basic) | MR |
static (Shared in Visual Basic) | MRSpectroscopy |
static (Shared in Visual Basic) | MultiFrameGrayscaleByteSC |
static (Shared in Visual Basic) | MultiFrameGrayscaleWordSC |
static (Shared in Visual Basic) | MultiFrameSingleBitSC |
static (Shared in Visual Basic) | MultiFrameTrueColorSC |
static (Shared in Visual Basic) | NuclearMedicine |
static (Shared in Visual Basic) | OldNuclearMedicine |
static (Shared in Visual Basic) | OldUltrasound |
static (Shared in Visual Basic) | OldUltrasoundMultiframe |
static (Shared in Visual Basic) | OphthalmicAxialMeasurements |
static (Shared in Visual Basic) | OphthalmicPhotography16Bit |
static (Shared in Visual Basic) | OphthalmicPhotography8Bit |
static (Shared in Visual Basic) | OphthalmicTomographyImage |
static (Shared in Visual Basic) | OphthalmicVisualFieldStaticPerimetryMeasurements |
static (Shared in Visual Basic) | PatientRootQR_FIND |
static (Shared in Visual Basic) | PatientRootQR_GET |
static (Shared in Visual Basic) | PatientRootQR_MOVE |
static (Shared in Visual Basic) | PatientStudyOnlyQR_FIND |
static (Shared in Visual Basic) | PatientStudyOnlyQR_GET |
static (Shared in Visual Basic) | PatientStudyOnlyQR_MOVE |
static (Shared in Visual Basic) | PositronEmissionTomography |
static (Shared in Visual Basic) | PresentationLUT |
static (Shared in Visual Basic) | Printer |
static (Shared in Visual Basic) | PrinterConfigurationRetrieval |
static (Shared in Visual Basic) | PrintJob |
static (Shared in Visual Basic) | PrintQueueManagement |
static (Shared in Visual Basic) | ProceduralEventLogging |
static (Shared in Visual Basic) | ProcedureLog |
static (Shared in Visual Basic) | ProductCharacteristicsQuery |
static (Shared in Visual Basic) | PseudoColorSoftcopyPresentationState |
static (Shared in Visual Basic) | PullPrintRequest |
static (Shared in Visual Basic) | RawData |
static (Shared in Visual Basic) | RealWorldValueMapping |
static (Shared in Visual Basic) | ReferencedImageBox |
static (Shared in Visual Basic) | RespiratoryWaveform |
static (Shared in Visual Basic) | RT |
static (Shared in Visual Basic) | RTBeamsDeliveryInstruction |
static (Shared in Visual Basic) | RTBeamsDeliveryInstructionTrial |
static (Shared in Visual Basic) | RTBeamsTreatmentRecord |
static (Shared in Visual Basic) | RTBrachyTreatmentRecord |
static (Shared in Visual Basic) | RTConventionalMachineVerification |
static (Shared in Visual Basic) | RTConventionalMachineVerificationTrial |
static (Shared in Visual Basic) | RTDose |
static (Shared in Visual Basic) | RTIonBeamsTreatmentRecord |
static (Shared in Visual Basic) | RTIonMachineVerification |
static (Shared in Visual Basic) | RTIonMachineVerificationTrial |
static (Shared in Visual Basic) | RTIonPlan |
static (Shared in Visual Basic) | RTPlan |
static (Shared in Visual Basic) | RTStructureSet |
static (Shared in Visual Basic) | RTTreatmentSummaryRecord |
static (Shared in Visual Basic) | SecondaryCapture |
static (Shared in Visual Basic) | Segmentation |
static (Shared in Visual Basic) | SpatialFiducials |
static (Shared in Visual Basic) | SpatialRegistration |
static (Shared in Visual Basic) | SpectaclePrescriptionReport |
static (Shared in Visual Basic) | StandaloneCurve |
static (Shared in Visual Basic) | StandaloneModalityLUT |
static (Shared in Visual Basic) | StandaloneOverlay |
static (Shared in Visual Basic) | StandalonePETCurve |
static (Shared in Visual Basic) | StandaloneVOILUT |
static (Shared in Visual Basic) | StereometricRelationship |
static (Shared in Visual Basic) | StorageCommitmentPull |
static (Shared in Visual Basic) | StorageCommitmentPush |
static (Shared in Visual Basic) | StorageServiceClass |
static (Shared in Visual Basic) | StoredPrint |
static (Shared in Visual Basic) | StudyComponentManagement |
static (Shared in Visual Basic) | StudyRootQR_FIND |
static (Shared in Visual Basic) | StudyRootQR_GET |
static (Shared in Visual Basic) | StudyRootQR_MOVE |
static (Shared in Visual Basic) | SubjectiveRefractionMeasurements |
static (Shared in Visual Basic) | SubstanceAdministrationLogging |
static (Shared in Visual Basic) | SubstanceApprovalQuery |
static (Shared in Visual Basic) | SurfaceSegmentation |
static (Shared in Visual Basic) | TextSRTrial |
static (Shared in Visual Basic) | TwelveLeadECGWaveform |
static (Shared in Visual Basic) | Ultrasound |
static (Shared in Visual Basic) | UltrasoundMultiframe |
static (Shared in Visual Basic) | UnifiedProcedureStepEvent |
static (Shared in Visual Basic) | UnifiedProcedureStepEventTrial |
static (Shared in Visual Basic) | UnifiedProcedureStepPull |
static (Shared in Visual Basic) | UnifiedProcedureStepPullTrial |
static (Shared in Visual Basic) | UnifiedProcedureStepPush |
static (Shared in Visual Basic) | UnifiedProcedureStepPushTrial |
static (Shared in Visual Basic) | UnifiedProcedureStepWatch |
static (Shared in Visual Basic) | UnifiedProcedureStepWatchTrial |
static (Shared in Visual Basic) | UnifiedWorklistandProcedureStepServiceClass |
static (Shared in Visual Basic) | UnifiedWorklistandProcedureStepServiceClassTrial |
static (Shared in Visual Basic) | Verification |
static (Shared in Visual Basic) | VideoEndoscopic |
static (Shared in Visual Basic) | VideoMicroscopic |
static (Shared in Visual Basic) | VideoPhotographic |
static (Shared in Visual Basic) | VisualAcuityMeasurements |
static (Shared in Visual Basic) | VLEndoscopic |
static (Shared in Visual Basic) | VLMicroscopic |
static (Shared in Visual Basic) | VLPhotographic |
static (Shared in Visual Basic) | VLSlideCoordinatesMicroscopic |
static (Shared in Visual Basic) | VLWholeSlideMicroscopyImage |
static (Shared in Visual Basic) | VOILUTBox |
static (Shared in Visual Basic) | WaveformTrial |
static (Shared in Visual Basic) | XA_XRFGrayscaleSoftcopyPresentationState |
static (Shared in Visual Basic) | XRay3DAngiographicImage |
static (Shared in Visual Basic) | XRay3DCraniofacialImage |
static (Shared in Visual Basic) | XRayAngiographic |
static (Shared in Visual Basic) | XRayAngiographicBiPlane |
static (Shared in Visual Basic) | XRayRadiationDoseSR |
static (Shared in Visual Basic) | XRayRadiofluoroscopic |
    Top
    See Also

    Reference

    SOPClasses Class
    DicomObjects.UIDs Namespace


DicomObjects.UIDs Namespace / SOPClasses Class / AmbulatoryECGWaveform Field

    AmbulatoryECGWaveform Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly AmbulatoryECGWaveform As UID
    'Usage

Dim value As UID

value = SOPClasses.AmbulatoryECGWaveform
    public static readonly UID AmbulatoryECGWaveform
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ArterialPulseWaveform Field

    ArterialPulseWaveform Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ArterialPulseWaveform As UID
    'Usage

Dim value As UID

value = SOPClasses.ArterialPulseWaveform
    public static readonly UID ArterialPulseWaveform
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / AudioSRTrial Field

    AudioSRTrial Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly AudioSRTrial As UID
    'Usage

Dim value As UID

value = SOPClasses.AudioSRTrial
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID AudioSRTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / AutorefractionMeasurements Field

    AutorefractionMeasurements Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly AutorefractionMeasurements As UID
    'Usage

Dim value As UID

value = SOPClasses.AutorefractionMeasurements
    public static readonly UID AutorefractionMeasurements
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BasicAnnotationBox Field

    BasicAnnotationBox Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly BasicAnnotationBox As UID
    'Usage

Dim value As UID

value = SOPClasses.BasicAnnotationBox
    public static readonly UID BasicAnnotationBox
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BasicColorImageBox Field

    BasicColorImageBox Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly BasicColorImageBox As UID
    'Usage

Dim value As UID

value = SOPClasses.BasicColorImageBox
    public static readonly UID BasicColorImageBox
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BasicFilmBox Field

    BasicFilmBox Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly BasicFilmBox As UID
    'Usage

Dim value As UID

value = SOPClasses.BasicFilmBox
    public static readonly UID BasicFilmBox
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BasicFilmSession Field

    BasicFilmSession Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly BasicFilmSession As UID
    'Usage

Dim value As UID

value = SOPClasses.BasicFilmSession
    public static readonly UID BasicFilmSession
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BasicGrayscaleImageBox Field

    BasicGrayscaleImageBox Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly BasicGrayscaleImageBox As UID
    'Usage

Dim value As UID

value = SOPClasses.BasicGrayscaleImageBox
    public static readonly UID BasicGrayscaleImageBox
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BasicPrintImageOverlayBox Field

    BasicPrintImageOverlayBox Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly BasicPrintImageOverlayBox As UID
    'Usage

Dim value As UID

value = SOPClasses.BasicPrintImageOverlayBox
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID BasicPrintImageOverlayBox
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BasicStructuredDisplay Field

    BasicStructuredDisplay Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly BasicStructuredDisplay As UID
    'Usage

Dim value As UID

value = SOPClasses.BasicStructuredDisplay
    public static readonly UID BasicStructuredDisplay
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BasicStudyContentNotification Field

    BasicStudyContentNotification Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly BasicStudyContentNotification As UID
    'Usage

Dim value As UID

value = SOPClasses.BasicStudyContentNotification
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID BasicStudyContentNotification
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BasicTextSR Field

    BasicTextSR Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly BasicTextSR As UID
    'Usage

Dim value As UID

value = SOPClasses.BasicTextSR
    public static readonly UID BasicTextSR
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BasicVoiceAudioWaveform Field

    BasicVoiceAudioWaveform Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly BasicVoiceAudioWaveform As UID
    'Usage

Dim value As UID

value = SOPClasses.BasicVoiceAudioWaveform
    public static readonly UID BasicVoiceAudioWaveform
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BlendingSoftcopyPresentationState Field

    BlendingSoftcopyPresentationState Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly BlendingSoftcopyPresentationState As UID
    'Usage

Dim value As UID

value = SOPClasses.BlendingSoftcopyPresentationState
    public static readonly UID BlendingSoftcopyPresentationState
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BreastImagingRelevantPatientInformationQuery Field

    BreastImagingRelevantPatientInformationQuery Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly BreastImagingRelevantPatientInformationQuery As UID
    'Usage

Dim value As UID

value = SOPClasses.BreastImagingRelevantPatientInformationQuery
    public static readonly UID BreastImagingRelevantPatientInformationQuery
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BreastTomosynthesisImage Field

    BreastTomosynthesisImage Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly BreastTomosynthesisImage As UID
    'Usage

Dim value As UID

value = SOPClasses.BreastTomosynthesisImage
    public static readonly UID BreastTomosynthesisImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / CardiacElectrophysiologyWaveform Field

    CardiacElectrophysiologyWaveform Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly CardiacElectrophysiologyWaveform As UID
    'Usage

Dim value As UID

value = SOPClasses.CardiacElectrophysiologyWaveform
    public static readonly UID CardiacElectrophysiologyWaveform
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / CardiacRelevantPatientInformationQuery Field

    CardiacRelevantPatientInformationQuery Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly CardiacRelevantPatientInformationQuery As UID
    'Usage

Dim value As UID

value = SOPClasses.CardiacRelevantPatientInformationQuery
    public static readonly UID CardiacRelevantPatientInformationQuery
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ChestCADSR Field

    ChestCADSR Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ChestCADSR As UID
    'Usage

Dim value As UID

value = SOPClasses.ChestCADSR
    public static readonly UID ChestCADSR
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ColonCADSR Field

    ColonCADSR Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ColonCADSR As UID
    'Usage

Dim value As UID

value = SOPClasses.ColonCADSR
    public static readonly UID ColonCADSR
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ColorPalette Field

    ColorPalette Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ColorPalette As UID
    'Usage

Dim value As UID

value = SOPClasses.ColorPalette
    public static readonly UID ColorPalette
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ColorPaletteQRFIND Field

    ColorPaletteQRFIND Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ColorPaletteQRFIND As UID
    'Usage

Dim value As UID

value = SOPClasses.ColorPaletteQRFIND
    public static readonly UID ColorPaletteQRFIND
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ColorPaletteQRGET Field

    ColorPaletteQRGET Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ColorPaletteQRGET As UID
    'Usage

Dim value As UID

value = SOPClasses.ColorPaletteQRGET
    public static readonly UID ColorPaletteQRGET
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ColorPaletteQRMOVE Field

    ColorPaletteQRMOVE Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ColorPaletteQRMOVE As UID
    'Usage

Dim value As UID

value = SOPClasses.ColorPaletteQRMOVE
    public static readonly UID ColorPaletteQRMOVE
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ColorSoftcopyPresentationState Field

    ColorSoftcopyPresentationState Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ColorSoftcopyPresentationState As UID
    'Usage

Dim value As UID

value = SOPClasses.ColorSoftcopyPresentationState
    public static readonly UID ColorSoftcopyPresentationState
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / CompositeInstanceRootRetrieve_GET Field

    CompositeInstanceRootRetrieve_GET Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly CompositeInstanceRootRetrieve_GET As UID
    'Usage

Dim value As UID

value = SOPClasses.CompositeInstanceRootRetrieve_GET
    public static readonly UID CompositeInstanceRootRetrieve_GET
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / CompositeInstanceRootRetrieve_MOVE Field

    CompositeInstanceRootRetrieve_MOVE Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly CompositeInstanceRootRetrieve_MOVE As UID
    'Usage

Dim value As UID

value = SOPClasses.CompositeInstanceRootRetrieve_MOVE
    public static readonly UID CompositeInstanceRootRetrieve_MOVE
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / CompositeInstanceRootRetrieveWithoutBulkData_GET Field

    CompositeInstanceRootRetrieveWithoutBulkData_GET Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly CompositeInstanceRootRetrieveWithoutBulkData_GET As UID
    'Usage

Dim value As UID

value = SOPClasses.CompositeInstanceRootRetrieveWithoutBulkData_GET
    public static readonly UID CompositeInstanceRootRetrieveWithoutBulkData_GET
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ComprehensiveSR Field

    ComprehensiveSR Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ComprehensiveSR As UID
    'Usage

Dim value As UID

value = SOPClasses.ComprehensiveSR
    public static readonly UID ComprehensiveSR
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ComprehensiveSRTrial Field

    ComprehensiveSRTrial Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly ComprehensiveSRTrial As UID
    'Usage

Dim value As UID

value = SOPClasses.ComprehensiveSRTrial
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID ComprehensiveSRTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ComputedRadiography Field

    ComputedRadiography Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ComputedRadiography As UID
    'Usage

Dim value As UID

value = SOPClasses.ComputedRadiography
    public static readonly UID ComputedRadiography
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / CT Field

    CT Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly CT As UID
    'Usage

Dim value As UID

value = SOPClasses.CT
    public static readonly UID CT
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DeformableSpatialRegistration Field

    DeformableSpatialRegistration Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly DeformableSpatialRegistration As UID
    'Usage

Dim value As UID

value = SOPClasses.DeformableSpatialRegistration
    public static readonly UID DeformableSpatialRegistration
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DetachedInterpretationManagement Field

    DetachedInterpretationManagement Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly DetachedInterpretationManagement As UID
    'Usage

Dim value As UID

value = SOPClasses.DetachedInterpretationManagement
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID DetachedInterpretationManagement
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DetachedPatientManagement Field

    DetachedPatientManagement Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly DetachedPatientManagement As UID
    'Usage

Dim value As UID

value = SOPClasses.DetachedPatientManagement
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID DetachedPatientManagement
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DetachedResultsManagement Field

    DetachedResultsManagement Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly DetachedResultsManagement As UID
    'Usage

Dim value As UID

value = SOPClasses.DetachedResultsManagement
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID DetachedResultsManagement
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DetachedStudyManagement Field

    DetachedStudyManagement Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly DetachedStudyManagement As UID
    'Usage

Dim value As UID

value = SOPClasses.DetachedStudyManagement
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID DetachedStudyManagement
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DetachedVisitManagement Field

    DetachedVisitManagement Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly DetachedVisitManagement As UID
    'Usage

Dim value As UID

value = SOPClasses.DetachedVisitManagement
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID DetachedVisitManagement
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DetailSRTrial Field

    DetailSRTrial Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly DetailSRTrial As UID
    'Usage

Dim value As UID

value = SOPClasses.DetailSRTrial
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID DetailSRTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DICOSCTImage Field

    DICOSCTImage Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly DICOSCTImage As UID
    'Usage

Dim value As UID

value = SOPClasses.DICOSCTImage
    public static readonly UID DICOSCTImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DICOSDigitalXRayImageForPresentation Field

    DICOSDigitalXRayImageForPresentation Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly DICOSDigitalXRayImageForPresentation As UID
    'Usage

Dim value As UID

value = SOPClasses.DICOSDigitalXRayImageForPresentation
    public static readonly UID DICOSDigitalXRayImageForPresentation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DICOSDigitalXRayImageForProcessing Field

    DICOSDigitalXRayImageForProcessing Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly DICOSDigitalXRayImageForProcessing As UID
    'Usage

Dim value As UID

value = SOPClasses.DICOSDigitalXRayImageForProcessing
    public static readonly UID DICOSDigitalXRayImageForProcessing
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DICOSThreatDetectionReport Field

    DICOSThreatDetectionReport Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly DICOSThreatDetectionReport As UID
    'Usage

Dim value As UID

value = SOPClasses.DICOSThreatDetectionReport
    public static readonly UID DICOSThreatDetectionReport
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DigitalIntraoralXRay_Presentation Field

    DigitalIntraoralXRay_Presentation Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly DigitalIntraoralXRay_Presentation As UID
    'Usage

Dim value As UID

value = SOPClasses.DigitalIntraoralXRay_Presentation
    public static readonly UID DigitalIntraoralXRay_Presentation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DigitalIntraoralXRay_Processing Field

    DigitalIntraoralXRay_Processing Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly DigitalIntraoralXRay_Processing As UID
    'Usage

Dim value As UID

value = SOPClasses.DigitalIntraoralXRay_Processing
    public static readonly UID DigitalIntraoralXRay_Processing
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DigitalMammographyXRay_Presentation Field

    DigitalMammographyXRay_Presentation Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly DigitalMammographyXRay_Presentation As UID
    'Usage

Dim value As UID

value = SOPClasses.DigitalMammographyXRay_Presentation
    public static readonly UID DigitalMammographyXRay_Presentation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DigitalMammographyXRay_Processing Field

    DigitalMammographyXRay_Processing Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly DigitalMammographyXRay_Processing As UID
    'Usage

Dim value As UID

value = SOPClasses.DigitalMammographyXRay_Processing
    public static readonly UID DigitalMammographyXRay_Processing
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DigitalXRay_Presentation Field

    DigitalXRay_Presentation Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly DigitalXRay_Presentation As UID
    'Usage

Dim value As UID

value = SOPClasses.DigitalXRay_Presentation
    public static readonly UID DigitalXRay_Presentation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DigitalXRay_Processing Field

    DigitalXRay_Processing Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly DigitalXRay_Processing As UID
    'Usage

Dim value As UID

value = SOPClasses.DigitalXRay_Processing
    public static readonly UID DigitalXRay_Processing
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EddyCurrentImage Field

    EddyCurrentImage Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly EddyCurrentImage As UID
    'Usage

Dim value As UID

value = SOPClasses.EddyCurrentImage
    public static readonly UID EddyCurrentImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EddyCurrentMultiframeImage Field

    EddyCurrentMultiframeImage Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly EddyCurrentMultiframeImage As UID
    'Usage

Dim value As UID

value = SOPClasses.EddyCurrentMultiframeImage
    public static readonly UID EddyCurrentMultiframeImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EncapsulatedCDA Field

    EncapsulatedCDA Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly EncapsulatedCDA As UID
    'Usage

Dim value As UID

value = SOPClasses.EncapsulatedCDA
    public static readonly UID EncapsulatedCDA
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EncapsulatedPDF Field

    EncapsulatedPDF Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly EncapsulatedPDF As UID
    'Usage

Dim value As UID

value = SOPClasses.EncapsulatedPDF
    public static readonly UID EncapsulatedPDF
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EncapsulatedSTL Field

    EncapsulatedSTL Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly EncapsulatedSTL As UID
    'Usage

Dim value As UID

value = SOPClasses.EncapsulatedSTL
    public static readonly UID EncapsulatedSTL
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EnhancedCT Field

    EnhancedCT Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly EnhancedCT As UID
    'Usage

Dim value As UID

value = SOPClasses.EnhancedCT
    public static readonly UID EnhancedCT
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EnhancedMR Field

    EnhancedMR Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly EnhancedMR As UID
    'Usage

Dim value As UID

value = SOPClasses.EnhancedMR
    public static readonly UID EnhancedMR
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EnhancedMRColorImage Field

    EnhancedMRColorImage Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly EnhancedMRColorImage As UID
    'Usage

Dim value As UID

value = SOPClasses.EnhancedMRColorImage
    public static readonly UID EnhancedMRColorImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EnhancedPETImage Field

    EnhancedPETImage Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly EnhancedPETImage As UID
    'Usage

Dim value As UID

value = SOPClasses.EnhancedPETImage
    public static readonly UID EnhancedPETImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EnhancedSR Field

    EnhancedSR Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly EnhancedSR As UID
    'Usage

Dim value As UID

value = SOPClasses.EnhancedSR
    public static readonly UID EnhancedSR
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EnhancedUSVolume Field

    EnhancedUSVolume Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly EnhancedUSVolume As UID
    'Usage

Dim value As UID

value = SOPClasses.EnhancedUSVolume
    public static readonly UID EnhancedUSVolume
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EnhancedXAImage Field

    EnhancedXAImage Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly EnhancedXAImage As UID
    'Usage

Dim value As UID

value = SOPClasses.EnhancedXAImage
    public static readonly UID EnhancedXAImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EnhancedXRFImage Field

    EnhancedXRFImage Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly EnhancedXRFImage As UID
    'Usage

Dim value As UID

value = SOPClasses.EnhancedXRFImage
    public static readonly UID EnhancedXRFImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / GeneralAudioWaveform Field

    GeneralAudioWaveform Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly GeneralAudioWaveform As UID
    'Usage

Dim value As UID

value = SOPClasses.GeneralAudioWaveform
    public static readonly UID GeneralAudioWaveform
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / GeneralECGWaveform Field

    GeneralECGWaveform Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly GeneralECGWaveform As UID
    'Usage

Dim value As UID

value = SOPClasses.GeneralECGWaveform
    public static readonly UID GeneralECGWaveform
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / GeneralPurposePerformedProcedureStep Field

    GeneralPurposePerformedProcedureStep Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly GeneralPurposePerformedProcedureStep As UID
    'Usage

Dim value As UID

value = SOPClasses.GeneralPurposePerformedProcedureStep
    public static readonly UID GeneralPurposePerformedProcedureStep
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / GeneralPurposeScheduledProcedureStep Field

    GeneralPurposeScheduledProcedureStep Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly GeneralPurposeScheduledProcedureStep As UID
    'Usage

Dim value As UID

value = SOPClasses.GeneralPurposeScheduledProcedureStep
    public static readonly UID GeneralPurposeScheduledProcedureStep
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / GeneralPurposeWorklistQRFIND Field

    GeneralPurposeWorklistQRFIND Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly GeneralPurposeWorklistQRFIND As UID
    'Usage

Dim value As UID

value = SOPClasses.GeneralPurposeWorklistQRFIND
    public static readonly UID GeneralPurposeWorklistQRFIND
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / GeneralRelevantPatientInformationQuery Field

    GeneralRelevantPatientInformationQuery Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly GeneralRelevantPatientInformationQuery As UID
    'Usage

Dim value As UID

value = SOPClasses.GeneralRelevantPatientInformationQuery
    public static readonly UID GeneralRelevantPatientInformationQuery
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / GenericImplantTemplate Field

    GenericImplantTemplate Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly GenericImplantTemplate As UID
    'Usage

Dim value As UID

value = SOPClasses.GenericImplantTemplate
    public static readonly UID GenericImplantTemplate
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / GenericImplantTemplateQRFIND Field

    GenericImplantTemplateQRFIND Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly GenericImplantTemplateQRFIND As UID
    'Usage

Dim value As UID

value = SOPClasses.GenericImplantTemplateQRFIND
    public static readonly UID GenericImplantTemplateQRFIND
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / GenericImplantTemplateQRGET Field

    GenericImplantTemplateQRGET Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly GenericImplantTemplateQRGET As UID
    'Usage

Dim value As UID

value = SOPClasses.GenericImplantTemplateQRGET
    public static readonly UID GenericImplantTemplateQRGET
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / GenericImplantTemplateQRMOVE Field

    GenericImplantTemplateQRMOVE Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly GenericImplantTemplateQRMOVE As UID
    'Usage

Dim value As UID

value = SOPClasses.GenericImplantTemplateQRMOVE
    public static readonly UID GenericImplantTemplateQRMOVE
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / GrayscaleSoftcopyPresentationState Field

    GrayscaleSoftcopyPresentationState Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly GrayscaleSoftcopyPresentationState As UID
    'Usage

Dim value As UID

value = SOPClasses.GrayscaleSoftcopyPresentationState
    public static readonly UID GrayscaleSoftcopyPresentationState
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / HangingProtocol Field

    HangingProtocol Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly HangingProtocol As UID
    'Usage

Dim value As UID

value = SOPClasses.HangingProtocol
    public static readonly UID HangingProtocol
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / HangingProtocolQRFIND Field

    HangingProtocolQRFIND Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly HangingProtocolQRFIND As UID
    'Usage

Dim value As UID

value = SOPClasses.HangingProtocolQRFIND
    public static readonly UID HangingProtocolQRFIND
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / HangingProtocolQRGET Field

    HangingProtocolQRGET Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly HangingProtocolQRGET As UID
    'Usage

Dim value As UID

value = SOPClasses.HangingProtocolQRGET
    public static readonly UID HangingProtocolQRGET
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / HangingProtocolQRMOVE Field

    HangingProtocolQRMOVE Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly HangingProtocolQRMOVE As UID
    'Usage

Dim value As UID

value = SOPClasses.HangingProtocolQRMOVE
    public static readonly UID HangingProtocolQRMOVE
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / HardcopyColor Field

    HardcopyColor Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly HardcopyColor As UID
    'Usage

Dim value As UID

value = SOPClasses.HardcopyColor
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID HardcopyColor
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / HardcopyGrayscale Field

    HardcopyGrayscale Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly HardcopyGrayscale As UID
    'Usage

Dim value As UID

value = SOPClasses.HardcopyGrayscale
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID HardcopyGrayscale
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / HemodynamicWaveform Field

    HemodynamicWaveform Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly HemodynamicWaveform As UID
    'Usage

Dim value As UID

value = SOPClasses.HemodynamicWaveform
    public static readonly UID HemodynamicWaveform
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ImageOverlayBox Field

    ImageOverlayBox Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly ImageOverlayBox As UID
    'Usage

Dim value As UID

value = SOPClasses.ImageOverlayBox
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID ImageOverlayBox
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ImplantAssemblyTemplate Field

    ImplantAssemblyTemplate Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ImplantAssemblyTemplate As UID
    'Usage

Dim value As UID

value = SOPClasses.ImplantAssemblyTemplate
    public static readonly UID ImplantAssemblyTemplate
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ImplantAssemblyTemplateQRFIND Field

    ImplantAssemblyTemplateQRFIND Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ImplantAssemblyTemplateQRFIND As UID
    'Usage

Dim value As UID

value = SOPClasses.ImplantAssemblyTemplateQRFIND
    public static readonly UID ImplantAssemblyTemplateQRFIND
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ImplantAssemblyTemplateQRGET Field

    ImplantAssemblyTemplateQRGET Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ImplantAssemblyTemplateQRGET As UID
    'Usage

Dim value As UID

value = SOPClasses.ImplantAssemblyTemplateQRGET
    public static readonly UID ImplantAssemblyTemplateQRGET
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ImplantAssemblyTemplateQRMOVE Field

    ImplantAssemblyTemplateQRMOVE Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ImplantAssemblyTemplateQRMOVE As UID
    'Usage

Dim value As UID

value = SOPClasses.ImplantAssemblyTemplateQRMOVE
    public static readonly UID ImplantAssemblyTemplateQRMOVE
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ImplantationPlanSR Field

    ImplantationPlanSR Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ImplantationPlanSR As UID
    'Usage

Dim value As UID

value = SOPClasses.ImplantationPlanSR
    public static readonly UID ImplantationPlanSR
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ImplantTemplateGroup Field

    ImplantTemplateGroup Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ImplantTemplateGroup As UID
    'Usage

Dim value As UID

value = SOPClasses.ImplantTemplateGroup
    public static readonly UID ImplantTemplateGroup
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ImplantTemplateGroupQRFIND Field

    ImplantTemplateGroupQRFIND Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ImplantTemplateGroupQRFIND As UID
    'Usage

Dim value As UID

value = SOPClasses.ImplantTemplateGroupQRFIND
    public static readonly UID ImplantTemplateGroupQRFIND
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ImplantTemplateGroupQRGET Field

    ImplantTemplateGroupQRGET Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ImplantTemplateGroupQRGET As UID
    'Usage

Dim value As UID

value = SOPClasses.ImplantTemplateGroupQRGET
    public static readonly UID ImplantTemplateGroupQRGET
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ImplantTemplateGroupQRMOVE Field

    ImplantTemplateGroupQRMOVE Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ImplantTemplateGroupQRMOVE As UID
    'Usage

Dim value As UID

value = SOPClasses.ImplantTemplateGroupQRMOVE
    public static readonly UID ImplantTemplateGroupQRMOVE
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / InstanceAvailabilityNotification Field

    InstanceAvailabilityNotification Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly InstanceAvailabilityNotification As UID
    'Usage

Dim value As UID

value = SOPClasses.InstanceAvailabilityNotification
    public static readonly UID InstanceAvailabilityNotification
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / IntraocularLensCalculations Field

    IntraocularLensCalculations Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly IntraocularLensCalculations As UID
    'Usage

Dim value As UID

value = SOPClasses.IntraocularLensCalculations
    public static readonly UID IntraocularLensCalculations
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / IntravascularOpticalCoherenceTomographyImageForPresentation Field

    IntravascularOpticalCoherenceTomographyImageForPresentation Field
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly IntravascularOpticalCoherenceTomographyImageForPresentation As UID
    'Usage

Dim value As UID

value = SOPClasses.IntravascularOpticalCoherenceTomographyImageForPresentation
    public static readonly UID IntravascularOpticalCoherenceTomographyImageForPresentation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / IntravascularOpticalCoherenceTomographyImageForProcessing Field

    IntravascularOpticalCoherenceTomographyImageForProcessing Field
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly IntravascularOpticalCoherenceTomographyImageForProcessing As UID
    'Usage

Dim value As UID

value = SOPClasses.IntravascularOpticalCoherenceTomographyImageForProcessing
    public static readonly UID IntravascularOpticalCoherenceTomographyImageForProcessing
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / KeratometryMeasurements Field

    KeratometryMeasurements Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly KeratometryMeasurements As UID
    'Usage

Dim value As UID

value = SOPClasses.KeratometryMeasurements
    public static readonly UID KeratometryMeasurements
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / KeyObjectSelectionDocument Field

    KeyObjectSelectionDocument Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly KeyObjectSelectionDocument As UID
    'Usage

Dim value As UID

value = SOPClasses.KeyObjectSelectionDocument
    public static readonly UID KeyObjectSelectionDocument
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / LensometryMeasurements Field

    LensometryMeasurements Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly LensometryMeasurements As UID
    'Usage

Dim value As UID

value = SOPClasses.LensometryMeasurements
    public static readonly UID LensometryMeasurements
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / MacularGridThicknessandVolumeReport Field

    MacularGridThicknessandVolumeReport Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly MacularGridThicknessandVolumeReport As UID
    'Usage

Dim value As UID

value = SOPClasses.MacularGridThicknessandVolumeReport
    public static readonly UID MacularGridThicknessandVolumeReport
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / MammographyCADSR Field

    MammographyCADSR Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly MammographyCADSR As UID
    'Usage

Dim value As UID

value = SOPClasses.MammographyCADSR
    public static readonly UID MammographyCADSR
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / MediaCreationManagementUID Field

    MediaCreationManagementUID Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly MediaCreationManagementUID As UID
    'Usage

Dim value As UID

value = SOPClasses.MediaCreationManagementUID
    public static readonly UID MediaCreationManagementUID
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / MediaStorageDirectory Field

    MediaStorageDirectory Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly MediaStorageDirectory As UID
    'Usage

Dim value As UID

value = SOPClasses.MediaStorageDirectory
    public static readonly UID MediaStorageDirectory
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ModalityPerformedProcedureStep Field

    ModalityPerformedProcedureStep Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ModalityPerformedProcedureStep As UID
    'Usage

Dim value As UID

value = SOPClasses.ModalityPerformedProcedureStep
    public static readonly UID ModalityPerformedProcedureStep
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ModalityPerformedProcedureStepNotification Field

    ModalityPerformedProcedureStepNotification Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ModalityPerformedProcedureStepNotification As UID
    'Usage

Dim value As UID

value = SOPClasses.ModalityPerformedProcedureStepNotification
    public static readonly UID ModalityPerformedProcedureStepNotification
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ModalityPerformedProcedureStepRetrieve Field

    ModalityPerformedProcedureStepRetrieve Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ModalityPerformedProcedureStepRetrieve As UID
    'Usage

Dim value As UID

value = SOPClasses.ModalityPerformedProcedureStepRetrieve
    public static readonly UID ModalityPerformedProcedureStepRetrieve
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ModalityWorklistQRFIND Field

    ModalityWorklistQRFIND Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ModalityWorklistQRFIND As UID
    'Usage

Dim value As UID

value = SOPClasses.ModalityWorklistQRFIND
    public static readonly UID ModalityWorklistQRFIND
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / MR Field

    MR Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly MR As UID
    'Usage

Dim value As UID

value = SOPClasses.MR
    public static readonly UID MR
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / MRSpectroscopy Field

    MRSpectroscopy Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly MRSpectroscopy As UID
    'Usage

Dim value As UID

value = SOPClasses.MRSpectroscopy
    public static readonly UID MRSpectroscopy
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / MultiFrameGrayscaleByteSC Field

    MultiFrameGrayscaleByteSC Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly MultiFrameGrayscaleByteSC As UID
    'Usage

Dim value As UID

value = SOPClasses.MultiFrameGrayscaleByteSC
    public static readonly UID MultiFrameGrayscaleByteSC
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / MultiFrameGrayscaleWordSC Field

    MultiFrameGrayscaleWordSC Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly MultiFrameGrayscaleWordSC As UID
    'Usage

Dim value As UID

value = SOPClasses.MultiFrameGrayscaleWordSC
    public static readonly UID MultiFrameGrayscaleWordSC
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / MultiFrameSingleBitSC Field

    MultiFrameSingleBitSC Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly MultiFrameSingleBitSC As UID
    'Usage

Dim value As UID

value = SOPClasses.MultiFrameSingleBitSC
    public static readonly UID MultiFrameSingleBitSC
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / MultiFrameTrueColorSC Field

    MultiFrameTrueColorSC Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly MultiFrameTrueColorSC As UID
    'Usage

Dim value As UID

value = SOPClasses.MultiFrameTrueColorSC
    public static readonly UID MultiFrameTrueColorSC
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / NuclearMedicine Field

    NuclearMedicine Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly NuclearMedicine As UID
    'Usage

Dim value As UID

value = SOPClasses.NuclearMedicine
    public static readonly UID NuclearMedicine
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / OldNuclearMedicine Field

    OldNuclearMedicine Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly OldNuclearMedicine As UID
    'Usage

Dim value As UID

value = SOPClasses.OldNuclearMedicine
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID OldNuclearMedicine
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / OldUltrasound Field

    OldUltrasound Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly OldUltrasound As UID
    'Usage

Dim value As UID

value = SOPClasses.OldUltrasound
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID OldUltrasound
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / OldUltrasoundMultiframe Field

    OldUltrasoundMultiframe Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly OldUltrasoundMultiframe As UID
    'Usage

Dim value As UID

value = SOPClasses.OldUltrasoundMultiframe
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID OldUltrasoundMultiframe
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / OphthalmicAxialMeasurements Field

    OphthalmicAxialMeasurements Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly OphthalmicAxialMeasurements As UID
    'Usage

Dim value As UID

value = SOPClasses.OphthalmicAxialMeasurements
    public static readonly UID OphthalmicAxialMeasurements
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / OphthalmicPhotography16Bit Field

    OphthalmicPhotography16Bit Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly OphthalmicPhotography16Bit As UID
    'Usage

Dim value As UID

value = SOPClasses.OphthalmicPhotography16Bit
    public static readonly UID OphthalmicPhotography16Bit
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / OphthalmicPhotography8Bit Field

    OphthalmicPhotography8Bit Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly OphthalmicPhotography8Bit As UID
    'Usage

Dim value As UID

value = SOPClasses.OphthalmicPhotography8Bit
    public static readonly UID OphthalmicPhotography8Bit
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / OphthalmicTomographyImage Field

    OphthalmicTomographyImage Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly OphthalmicTomographyImage As UID
    'Usage

Dim value As UID

value = SOPClasses.OphthalmicTomographyImage
    public static readonly UID OphthalmicTomographyImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / OphthalmicVisualFieldStaticPerimetryMeasurements Field

    OphthalmicVisualFieldStaticPerimetryMeasurements Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly OphthalmicVisualFieldStaticPerimetryMeasurements As UID
    'Usage

Dim value As UID

value = SOPClasses.OphthalmicVisualFieldStaticPerimetryMeasurements
    public static readonly UID OphthalmicVisualFieldStaticPerimetryMeasurements
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PatientRootQR_FIND Field

    PatientRootQR_FIND Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly PatientRootQR_FIND As UID
    'Usage

Dim value As UID

value = SOPClasses.PatientRootQR_FIND
    public static readonly UID PatientRootQR_FIND
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PatientRootQR_GET Field

    PatientRootQR_GET Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly PatientRootQR_GET As UID
    'Usage

Dim value As UID

value = SOPClasses.PatientRootQR_GET
    public static readonly UID PatientRootQR_GET
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PatientRootQR_MOVE Field

    PatientRootQR_MOVE Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly PatientRootQR_MOVE As UID
    'Usage

Dim value As UID

value = SOPClasses.PatientRootQR_MOVE
    public static readonly UID PatientRootQR_MOVE
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PatientStudyOnlyQR_FIND Field

    PatientStudyOnlyQR_FIND Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly PatientStudyOnlyQR_FIND As UID
    'Usage

Dim value As UID

value = SOPClasses.PatientStudyOnlyQR_FIND
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID PatientStudyOnlyQR_FIND
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PatientStudyOnlyQR_GET Field

    PatientStudyOnlyQR_GET Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly PatientStudyOnlyQR_GET As UID
    'Usage

Dim value As UID

value = SOPClasses.PatientStudyOnlyQR_GET
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID PatientStudyOnlyQR_GET
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PatientStudyOnlyQR_MOVE Field

    PatientStudyOnlyQR_MOVE Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly PatientStudyOnlyQR_MOVE As UID
    'Usage

Dim value As UID

value = SOPClasses.PatientStudyOnlyQR_MOVE
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID PatientStudyOnlyQR_MOVE
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PositronEmissionTomography Field

    PositronEmissionTomography Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly PositronEmissionTomography As UID
    'Usage

Dim value As UID

value = SOPClasses.PositronEmissionTomography
    public static readonly UID PositronEmissionTomography
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PresentationLUT Field

    PresentationLUT Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly PresentationLUT As UID
    'Usage

Dim value As UID

value = SOPClasses.PresentationLUT
    public static readonly UID PresentationLUT
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / Printer Field

    Printer Field (SOPClasses)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly Printer As UID
    'Usage

Dim value As UID

value = SOPClasses.Printer
    public static readonly UID Printer
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PrinterConfigurationRetrieval Field

    PrinterConfigurationRetrieval Field (SOPClasses)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly PrinterConfigurationRetrieval As UID
    'Usage

Dim value As UID

value = SOPClasses.PrinterConfigurationRetrieval
    public static readonly UID PrinterConfigurationRetrieval
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PrintJob Field

    PrintJob Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly PrintJob As UID
    'Usage

Dim value As UID

value = SOPClasses.PrintJob
    public static readonly UID PrintJob
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PrintQueueManagement Field

    PrintQueueManagement Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly PrintQueueManagement As UID
    'Usage

Dim value As UID

value = SOPClasses.PrintQueueManagement
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID PrintQueueManagement
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ProceduralEventLogging Field

    ProceduralEventLogging Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ProceduralEventLogging As UID
    'Usage

Dim value As UID

value = SOPClasses.ProceduralEventLogging
    public static readonly UID ProceduralEventLogging
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ProcedureLog Field

    ProcedureLog Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ProcedureLog As UID
    'Usage

Dim value As UID

value = SOPClasses.ProcedureLog
    public static readonly UID ProcedureLog
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ProductCharacteristicsQuery Field

    ProductCharacteristicsQuery Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ProductCharacteristicsQuery As UID
    'Usage

Dim value As UID

value = SOPClasses.ProductCharacteristicsQuery
    public static readonly UID ProductCharacteristicsQuery
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PseudoColorSoftcopyPresentationState Field

    PseudoColorSoftcopyPresentationState Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly PseudoColorSoftcopyPresentationState As UID
    'Usage

Dim value As UID

value = SOPClasses.PseudoColorSoftcopyPresentationState
    public static readonly UID PseudoColorSoftcopyPresentationState
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PullPrintRequest Field

    PullPrintRequest Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly PullPrintRequest As UID
    'Usage

Dim value As UID

value = SOPClasses.PullPrintRequest
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID PullPrintRequest
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RawData Field

    RawData Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly RawData As UID
    'Usage

Dim value As UID

value = SOPClasses.RawData
    public static readonly UID RawData
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RealWorldValueMapping Field

    RealWorldValueMapping Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly RealWorldValueMapping As UID
    'Usage

Dim value As UID

value = SOPClasses.RealWorldValueMapping
    public static readonly UID RealWorldValueMapping
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ReferencedImageBox Field

    ReferencedImageBox Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly ReferencedImageBox As UID
    'Usage

Dim value As UID

value = SOPClasses.ReferencedImageBox
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID ReferencedImageBox
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RespiratoryWaveform Field

    RespiratoryWaveform Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly RespiratoryWaveform As UID
    'Usage

Dim value As UID

value = SOPClasses.RespiratoryWaveform
    public static readonly UID RespiratoryWaveform
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RT Field

    RT Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly RT As UID
    'Usage

Dim value As UID

value = SOPClasses.RT
    public static readonly UID RT
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTBeamsDeliveryInstruction Field

    RTBeamsDeliveryInstruction Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly RTBeamsDeliveryInstruction As UID
    'Usage

Dim value As UID

value = SOPClasses.RTBeamsDeliveryInstruction
    public static readonly UID RTBeamsDeliveryInstruction
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTBeamsDeliveryInstructionTrial Field

    RTBeamsDeliveryInstructionTrial Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly RTBeamsDeliveryInstructionTrial As UID
    'Usage

Dim value As UID

value = SOPClasses.RTBeamsDeliveryInstructionTrial
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID RTBeamsDeliveryInstructionTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTBeamsTreatmentRecord Field

    RTBeamsTreatmentRecord Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly RTBeamsTreatmentRecord As UID
    'Usage

Dim value As UID

value = SOPClasses.RTBeamsTreatmentRecord
    public static readonly UID RTBeamsTreatmentRecord
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTBrachyTreatmentRecord Field

    RTBrachyTreatmentRecord Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly RTBrachyTreatmentRecord As UID
    'Usage

Dim value As UID

value = SOPClasses.RTBrachyTreatmentRecord
    public static readonly UID RTBrachyTreatmentRecord
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTConventionalMachineVerification Field

    RTConventionalMachineVerification Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly RTConventionalMachineVerification As UID
    'Usage

Dim value As UID

value = SOPClasses.RTConventionalMachineVerification
    public static readonly UID RTConventionalMachineVerification
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTConventionalMachineVerificationTrial Field

    RTConventionalMachineVerificationTrial Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly RTConventionalMachineVerificationTrial As UID
    'Usage

Dim value As UID

value = SOPClasses.RTConventionalMachineVerificationTrial
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID RTConventionalMachineVerificationTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTDose Field

    RTDose Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly RTDose As UID
    'Usage

Dim value As UID

value = SOPClasses.RTDose
    public static readonly UID RTDose
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTIonBeamsTreatmentRecord Field

    RTIonBeamsTreatmentRecord Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly RTIonBeamsTreatmentRecord As UID
    'Usage

Dim value As UID

value = SOPClasses.RTIonBeamsTreatmentRecord
    public static readonly UID RTIonBeamsTreatmentRecord
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTIonMachineVerification Field

    RTIonMachineVerification Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly RTIonMachineVerification As UID
    'Usage

Dim value As UID

value = SOPClasses.RTIonMachineVerification
    public static readonly UID RTIonMachineVerification
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTIonMachineVerificationTrial Field

    RTIonMachineVerificationTrial Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly RTIonMachineVerificationTrial As UID
    'Usage

Dim value As UID

value = SOPClasses.RTIonMachineVerificationTrial
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID RTIonMachineVerificationTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTIonPlan Field

    RTIonPlan Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly RTIonPlan As UID
    'Usage

Dim value As UID

value = SOPClasses.RTIonPlan
    public static readonly UID RTIonPlan
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTPlan Field

    RTPlan Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly RTPlan As UID
    'Usage

Dim value As UID

value = SOPClasses.RTPlan
    public static readonly UID RTPlan
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTStructureSet Field

    RTStructureSet Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly RTStructureSet As UID
    'Usage

Dim value As UID

value = SOPClasses.RTStructureSet
    public static readonly UID RTStructureSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTTreatmentSummaryRecord Field

    RTTreatmentSummaryRecord Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly RTTreatmentSummaryRecord As UID
    'Usage

Dim value As UID

value = SOPClasses.RTTreatmentSummaryRecord
    public static readonly UID RTTreatmentSummaryRecord
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / SecondaryCapture Field

    SecondaryCapture Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SecondaryCapture As UID
    'Usage

Dim value As UID

value = SOPClasses.SecondaryCapture
    public static readonly UID SecondaryCapture
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / Segmentation Field

    Segmentation Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly Segmentation As UID
    'Usage

Dim value As UID

value = SOPClasses.Segmentation
    public static readonly UID Segmentation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / SpatialFiducials Field

    SpatialFiducials Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SpatialFiducials As UID
    'Usage

Dim value As UID

value = SOPClasses.SpatialFiducials
    public static readonly UID SpatialFiducials
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / SpatialRegistration Field

    SpatialRegistration Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SpatialRegistration As UID
    'Usage

Dim value As UID

value = SOPClasses.SpatialRegistration
    public static readonly UID SpatialRegistration
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / SpectaclePrescriptionReport Field

    SpectaclePrescriptionReport Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SpectaclePrescriptionReport As UID
    'Usage

Dim value As UID

value = SOPClasses.SpectaclePrescriptionReport
    public static readonly UID SpectaclePrescriptionReport
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StandaloneCurve Field

    StandaloneCurve Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly StandaloneCurve As UID
    'Usage

Dim value As UID

value = SOPClasses.StandaloneCurve
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID StandaloneCurve
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StandaloneModalityLUT Field

    StandaloneModalityLUT Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly StandaloneModalityLUT As UID
    'Usage

Dim value As UID

value = SOPClasses.StandaloneModalityLUT
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID StandaloneModalityLUT
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StandaloneOverlay Field

    StandaloneOverlay Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly StandaloneOverlay As UID
    'Usage

Dim value As UID

value = SOPClasses.StandaloneOverlay
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID StandaloneOverlay
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StandalonePETCurve Field

    StandalonePETCurve Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly StandalonePETCurve As UID
    'Usage

Dim value As UID

value = SOPClasses.StandalonePETCurve
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID StandalonePETCurve
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StandaloneVOILUT Field

    StandaloneVOILUT Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly StandaloneVOILUT As UID
    'Usage

Dim value As UID

value = SOPClasses.StandaloneVOILUT
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID StandaloneVOILUT
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StereometricRelationship Field

    StereometricRelationship Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly StereometricRelationship As UID
    'Usage

Dim value As UID

value = SOPClasses.StereometricRelationship
    public static readonly UID StereometricRelationship
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StorageCommitmentPull Field

    StorageCommitmentPull Field (SOPClasses)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly StorageCommitmentPull As UID
    'Usage

Dim value As UID

value = SOPClasses.StorageCommitmentPull
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID StorageCommitmentPull
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StorageCommitmentPush Field

    StorageCommitmentPush Field (SOPClasses)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly StorageCommitmentPush As UID
    'Usage

Dim value As UID

value = SOPClasses.StorageCommitmentPush
    public static readonly UID StorageCommitmentPush
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StorageServiceClass Field

    StorageServiceClass Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly StorageServiceClass As UID
    'Usage

Dim value As UID

value = SOPClasses.StorageServiceClass
    public static readonly UID StorageServiceClass
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StoredPrint Field

    StoredPrint Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly StoredPrint As UID
    'Usage

Dim value As UID

value = SOPClasses.StoredPrint
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID StoredPrint
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StudyComponentManagement Field

    StudyComponentManagement Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly StudyComponentManagement As UID
    'Usage

Dim value As UID

value = SOPClasses.StudyComponentManagement
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID StudyComponentManagement
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StudyRootQR_FIND Field

    StudyRootQR_FIND Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly StudyRootQR_FIND As UID
    'Usage

Dim value As UID

value = SOPClasses.StudyRootQR_FIND
    public static readonly UID StudyRootQR_FIND
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StudyRootQR_GET Field

    StudyRootQR_GET Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly StudyRootQR_GET As UID
    'Usage

Dim value As UID

value = SOPClasses.StudyRootQR_GET
    public static readonly UID StudyRootQR_GET
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StudyRootQR_MOVE Field

    StudyRootQR_MOVE Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly StudyRootQR_MOVE As UID
    'Usage

Dim value As UID

value = SOPClasses.StudyRootQR_MOVE
    public static readonly UID StudyRootQR_MOVE
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / SubjectiveRefractionMeasurements Field

    SubjectiveRefractionMeasurements Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SubjectiveRefractionMeasurements As UID
    'Usage

Dim value As UID

value = SOPClasses.SubjectiveRefractionMeasurements
    public static readonly UID SubjectiveRefractionMeasurements
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / SubstanceAdministrationLogging Field

    SubstanceAdministrationLogging Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SubstanceAdministrationLogging As UID
    'Usage

Dim value As UID

value = SOPClasses.SubstanceAdministrationLogging
    public static readonly UID SubstanceAdministrationLogging
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / SubstanceApprovalQuery Field

    SubstanceApprovalQuery Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SubstanceApprovalQuery As UID
    'Usage

Dim value As UID

value = SOPClasses.SubstanceApprovalQuery
    public static readonly UID SubstanceApprovalQuery
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / SurfaceSegmentation Field

    SurfaceSegmentation Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SurfaceSegmentation As UID
    'Usage

Dim value As UID

value = SOPClasses.SurfaceSegmentation
    public static readonly UID SurfaceSegmentation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / TextSRTrial Field

    TextSRTrial Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly TextSRTrial As UID
    'Usage

Dim value As UID

value = SOPClasses.TextSRTrial
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID TextSRTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / TwelveLeadECGWaveform Field

    TwelveLeadECGWaveform Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly TwelveLeadECGWaveform As UID
    'Usage

Dim value As UID

value = SOPClasses.TwelveLeadECGWaveform
    public static readonly UID TwelveLeadECGWaveform
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / Ultrasound Field

    Ultrasound Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly Ultrasound As UID
    'Usage

Dim value As UID

value = SOPClasses.Ultrasound
    public static readonly UID Ultrasound
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / UltrasoundMultiframe Field

    UltrasoundMultiframe Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly UltrasoundMultiframe As UID
    'Usage

Dim value As UID

value = SOPClasses.UltrasoundMultiframe
    public static readonly UID UltrasoundMultiframe
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / UnifiedProcedureStepEvent Field

    UnifiedProcedureStepEvent Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly UnifiedProcedureStepEvent As UID
    'Usage

Dim value As UID

value = SOPClasses.UnifiedProcedureStepEvent
    public static readonly UID UnifiedProcedureStepEvent
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / UnifiedProcedureStepEventTrial Field

    UnifiedProcedureStepEventTrial Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly UnifiedProcedureStepEventTrial As UID
    'Usage

Dim value As UID

value = SOPClasses.UnifiedProcedureStepEventTrial
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID UnifiedProcedureStepEventTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / UnifiedProcedureStepPull Field

    UnifiedProcedureStepPull Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly UnifiedProcedureStepPull As UID
    'Usage

Dim value As UID

value = SOPClasses.UnifiedProcedureStepPull
    public static readonly UID UnifiedProcedureStepPull
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / UnifiedProcedureStepPullTrial Field

    UnifiedProcedureStepPullTrial Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly UnifiedProcedureStepPullTrial As UID
    'Usage

Dim value As UID

value = SOPClasses.UnifiedProcedureStepPullTrial
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID UnifiedProcedureStepPullTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / UnifiedProcedureStepPush Field

    UnifiedProcedureStepPush Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly UnifiedProcedureStepPush As UID
    'Usage

Dim value As UID

value = SOPClasses.UnifiedProcedureStepPush
    public static readonly UID UnifiedProcedureStepPush
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / UnifiedProcedureStepPushTrial Field

    UnifiedProcedureStepPushTrial Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly UnifiedProcedureStepPushTrial As UID
    'Usage

Dim value As UID

value = SOPClasses.UnifiedProcedureStepPushTrial
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID UnifiedProcedureStepPushTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / UnifiedProcedureStepWatch Field

    UnifiedProcedureStepWatch Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly UnifiedProcedureStepWatch As UID
    'Usage

Dim value As UID

value = SOPClasses.UnifiedProcedureStepWatch
    public static readonly UID UnifiedProcedureStepWatch
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / UnifiedProcedureStepWatchTrial Field

    UnifiedProcedureStepWatchTrial Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly UnifiedProcedureStepWatchTrial As UID
    'Usage

Dim value As UID

value = SOPClasses.UnifiedProcedureStepWatchTrial
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID UnifiedProcedureStepWatchTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / UnifiedWorklistandProcedureStepServiceClass Field

    UnifiedWorklistandProcedureStepServiceClass Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly UnifiedWorklistandProcedureStepServiceClass As UID
    'Usage

Dim value As UID

value = SOPClasses.UnifiedWorklistandProcedureStepServiceClass
    public static readonly UID UnifiedWorklistandProcedureStepServiceClass
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / UnifiedWorklistandProcedureStepServiceClassTrial Field

    UnifiedWorklistandProcedureStepServiceClassTrial Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly UnifiedWorklistandProcedureStepServiceClassTrial As UID
    'Usage

Dim value As UID

value = SOPClasses.UnifiedWorklistandProcedureStepServiceClassTrial
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID UnifiedWorklistandProcedureStepServiceClassTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / Verification Field

    Verification Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly Verification As UID
    'Usage

Dim value As UID

value = SOPClasses.Verification
    public static readonly UID Verification
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / VideoEndoscopic Field

    VideoEndoscopic Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly VideoEndoscopic As UID
    'Usage

Dim value As UID

value = SOPClasses.VideoEndoscopic
    public static readonly UID VideoEndoscopic
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / VideoMicroscopic Field

    VideoMicroscopic Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly VideoMicroscopic As UID
    'Usage

Dim value As UID

value = SOPClasses.VideoMicroscopic
    public static readonly UID VideoMicroscopic
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / VideoPhotographic Field

    VideoPhotographic Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly VideoPhotographic As UID
    'Usage

Dim value As UID

value = SOPClasses.VideoPhotographic
    public static readonly UID VideoPhotographic
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / VisualAcuityMeasurements Field

    VisualAcuityMeasurements Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly VisualAcuityMeasurements As UID
    'Usage

Dim value As UID

value = SOPClasses.VisualAcuityMeasurements
    public static readonly UID VisualAcuityMeasurements
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / VLEndoscopic Field

    VLEndoscopic Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly VLEndoscopic As UID
    'Usage

Dim value As UID

value = SOPClasses.VLEndoscopic
    public static readonly UID VLEndoscopic
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / VLMicroscopic Field

    VLMicroscopic Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly VLMicroscopic As UID
    'Usage

Dim value As UID

value = SOPClasses.VLMicroscopic
    public static readonly UID VLMicroscopic
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / VLPhotographic Field

    VLPhotographic Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly VLPhotographic As UID
    'Usage

Dim value As UID

value = SOPClasses.VLPhotographic
    public static readonly UID VLPhotographic
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / VLSlideCoordinatesMicroscopic Field

    VLSlideCoordinatesMicroscopic Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly VLSlideCoordinatesMicroscopic As UID
    'Usage

Dim value As UID

value = SOPClasses.VLSlideCoordinatesMicroscopic
    public static readonly UID VLSlideCoordinatesMicroscopic
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / VLWholeSlideMicroscopyImage Field

    VLWholeSlideMicroscopyImage Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly VLWholeSlideMicroscopyImage As UID
    'Usage

Dim value As UID

value = SOPClasses.VLWholeSlideMicroscopyImage
    public static readonly UID VLWholeSlideMicroscopyImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / VOILUTBox Field

    VOILUTBox Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly VOILUTBox As UID
    'Usage

Dim value As UID

value = SOPClasses.VOILUTBox
    public static readonly UID VOILUTBox
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / WaveformTrial Field

    WaveformTrial Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
Public Shared ReadOnly WaveformTrial As UID
    'Usage

Dim value As UID

value = SOPClasses.WaveformTrial
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementations")]
public static readonly UID WaveformTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / XA_XRFGrayscaleSoftcopyPresentationState Field

    XA_XRFGrayscaleSoftcopyPresentationState Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly XA_XRFGrayscaleSoftcopyPresentationState As UID
    'Usage

Dim value As UID

value = SOPClasses.XA_XRFGrayscaleSoftcopyPresentationState
    public static readonly UID XA_XRFGrayscaleSoftcopyPresentationState
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / XRay3DAngiographicImage Field

    XRay3DAngiographicImage Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly XRay3DAngiographicImage As UID
    'Usage

Dim value As UID

value = SOPClasses.XRay3DAngiographicImage
    public static readonly UID XRay3DAngiographicImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / XRay3DCraniofacialImage Field

    XRay3DCraniofacialImage Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly XRay3DCraniofacialImage As UID
    'Usage

Dim value As UID

value = SOPClasses.XRay3DCraniofacialImage
    public static readonly UID XRay3DCraniofacialImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / XRayAngiographic Field

    XRayAngiographic Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly XRayAngiographic As UID
    'Usage

Dim value As UID

value = SOPClasses.XRayAngiographic
    public static readonly UID XRayAngiographic
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / XRayAngiographicBiPlane Field

    XRayAngiographicBiPlane Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly XRayAngiographicBiPlane As UID
    'Usage

Dim value As UID

value = SOPClasses.XRayAngiographicBiPlane
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID XRayAngiographicBiPlane
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / XRayRadiationDoseSR Field

    XRayRadiationDoseSR Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly XRayRadiationDoseSR As UID
    'Usage

Dim value As UID

value = SOPClasses.XRayRadiationDoseSR
    public static readonly UID XRayRadiationDoseSR
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / XRayRadiofluoroscopic Field

    XRayRadiofluoroscopic Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly XRayRadiofluoroscopic As UID
    'Usage

Dim value As UID

value = SOPClasses.XRayRadiofluoroscopic
    public static readonly UID XRayRadiofluoroscopic
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


%%PageItemTitle%%

DicomObjects.UIDs Namespace / TransferSyntaxes Class
Members

In This Topic
    TransferSyntaxes Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MustInherit NotInheritable Class TransferSyntaxes
    'Usage

Dim instance As TransferSyntaxes
    public static class TransferSyntaxes
    Inheritance Hierarchy

    System.Object
    DicomObjects.UIDs.TransferSyntaxes

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Members
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.UIDs Namespace / TransferSyntaxes Class
Fields

In This Topic
    TransferSyntaxes Class Members
    In This Topic

    The following tables list the members exposed by TransferSyntaxes.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | DeflatedExplicitVRLittleEndian |
static (Shared in Visual Basic) | ExplicitVRBigEndian |
static (Shared in Visual Basic) | ExplicitVRLittleEndian |
static (Shared in Visual Basic) | ImplicitVRLittleEndian |
static (Shared in Visual Basic) | JPEG2000Lossless |
static (Shared in Visual Basic) | JPEG2000Lossy |
static (Shared in Visual Basic) | JPEG2000Part2MulticomponentImageCompression |
static (Shared in Visual Basic) | JPEG2000Part2MulticomponentImageCompressionLosslessOnly |
static (Shared in Visual Basic) | JPEGBaseline |
static (Shared in Visual Basic) | JPEGExtended |
static (Shared in Visual Basic) | JPEGExtendedHierarchicalProcess16and18 |
static (Shared in Visual Basic) | JPEGExtendedHierarchicalProcess17and19 |
static (Shared in Visual Basic) | JPEGExtendedProcess3and5 |
static (Shared in Visual Basic) | JPEGFullProgressionHierarchicalProcess24and26 |
static (Shared in Visual Basic) | JPEGFullProgressionHierarchicalProcess25and27 |
static (Shared in Visual Basic) | JPEGFullProgressionNonHierarchicalProcess10and12 |
static (Shared in Visual Basic) | JPEGFullProgressionNonHierarchicalProcess11and13 |
static (Shared in Visual Basic) | JPEGLossless |
static (Shared in Visual Basic) | JPEGLosslessFirstOrder |
static (Shared in Visual Basic) | JPEGLosslessHierarchicalProcess28 |
static (Shared in Visual Basic) | JPEGLosslessHierarchicalProcess29 |
static (Shared in Visual Basic) | JPEGLosslessNonHierarchicalProcess15 |
static (Shared in Visual Basic) | JPEGLSLossless |
static (Shared in Visual Basic) | JPEGLSLossy |
static (Shared in Visual Basic) | JPEGSpectralSelectionHierarchicalProcess20and22 |
static (Shared in Visual Basic) | JPEGSpectralSelectionHierarchicalProcess21and23 |
static (Shared in Visual Basic) | JPEGSpectralSelectionNonHierarchicalProcess6and8 |
static (Shared in Visual Basic) | JPEGSpectralSelectionNonHierarchicalProcess7and9 |
static (Shared in Visual Basic) | JPIPReferenced |
static (Shared in Visual Basic) | JPIPReferencedDeflate |
static (Shared in Visual Basic) | MPEG2 |
static (Shared in Visual Basic) | MPEG2_HL |
static (Shared in Visual Basic) | MPEG4 |
static (Shared in Visual Basic) | MPEG4_BD |
static (Shared in Visual Basic) | RFC2557MIMEencapsulation |
static (Shared in Visual Basic) | RLELossless |
static (Shared in Visual Basic) | XMLEncoding |
    Top
    See Also

    Reference

    TransferSyntaxes Class
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Fields$$

DicomObjects.UIDs Namespace / TransferSyntaxes Class

    TransferSyntaxes Class Fields
    In This Topic

    For a list of all members of this type, see TransferSyntaxes members.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | DeflatedExplicitVRLittleEndian |
static (Shared in Visual Basic) | ExplicitVRBigEndian |
static (Shared in Visual Basic) | ExplicitVRLittleEndian |
static (Shared in Visual Basic) | ImplicitVRLittleEndian |
static (Shared in Visual Basic) | JPEG2000Lossless |
static (Shared in Visual Basic) | JPEG2000Lossy |
static (Shared in Visual Basic) | JPEG2000Part2MulticomponentImageCompression |
static (Shared in Visual Basic) | JPEG2000Part2MulticomponentImageCompressionLosslessOnly |
static (Shared in Visual Basic) | JPEGBaseline |
static (Shared in Visual Basic) | JPEGExtended |
static (Shared in Visual Basic) | JPEGExtendedHierarchicalProcess16and18 |
static (Shared in Visual Basic) | JPEGExtendedHierarchicalProcess17and19 |
static (Shared in Visual Basic) | JPEGExtendedProcess3and5 |
static (Shared in Visual Basic) | JPEGFullProgressionHierarchicalProcess24and26 |
static (Shared in Visual Basic) | JPEGFullProgressionHierarchicalProcess25and27 |
static (Shared in Visual Basic) | JPEGFullProgressionNonHierarchicalProcess10and12 |
static (Shared in Visual Basic) | JPEGFullProgressionNonHierarchicalProcess11and13 |
static (Shared in Visual Basic) | JPEGLossless |
static (Shared in Visual Basic) | JPEGLosslessFirstOrder |
static (Shared in Visual Basic) | JPEGLosslessHierarchicalProcess28 |
static (Shared in Visual Basic) | JPEGLosslessHierarchicalProcess29 |
static (Shared in Visual Basic) | JPEGLosslessNonHierarchicalProcess15 |
static (Shared in Visual Basic) | JPEGLSLossless |
static (Shared in Visual Basic) | JPEGLSLossy |
static (Shared in Visual Basic) | JPEGSpectralSelectionHierarchicalProcess20and22 |
static (Shared in Visual Basic) | JPEGSpectralSelectionHierarchicalProcess21and23 |
static (Shared in Visual Basic) | JPEGSpectralSelectionNonHierarchicalProcess6and8 |
static (Shared in Visual Basic) | JPEGSpectralSelectionNonHierarchicalProcess7and9 |
static (Shared in Visual Basic) | JPIPReferenced |
static (Shared in Visual Basic) | JPIPReferencedDeflate |
static (Shared in Visual Basic) | MPEG2 |
static (Shared in Visual Basic) | MPEG2_HL |
static (Shared in Visual Basic) | MPEG4 |
static (Shared in Visual Basic) | MPEG4_BD |
static (Shared in Visual Basic) | RFC2557MIMEencapsulation |
static (Shared in Visual Basic) | RLELossless |
static (Shared in Visual Basic) | XMLEncoding |
    Top
    See Also

    Reference

    TransferSyntaxes Class
    DicomObjects.UIDs Namespace


DicomObjects.UIDs Namespace / TransferSyntaxes Class / DeflatedExplicitVRLittleEndian Field

    DeflatedExplicitVRLittleEndian Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly DeflatedExplicitVRLittleEndian As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.DeflatedExplicitVRLittleEndian
    public static readonly UID DeflatedExplicitVRLittleEndian
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / ExplicitVRBigEndian Field

    ExplicitVRBigEndian Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ExplicitVRBigEndian As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.ExplicitVRBigEndian
    public static readonly UID ExplicitVRBigEndian
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / ExplicitVRLittleEndian Field

    ExplicitVRLittleEndian Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ExplicitVRLittleEndian As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.ExplicitVRLittleEndian
    public static readonly UID ExplicitVRLittleEndian
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / ImplicitVRLittleEndian Field

    ImplicitVRLittleEndian Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ImplicitVRLittleEndian As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.ImplicitVRLittleEndian
    public static readonly UID ImplicitVRLittleEndian
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEG2000Lossless Field

    JPEG2000Lossless Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly JPEG2000Lossless As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEG2000Lossless
    public static readonly UID JPEG2000Lossless
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEG2000Lossy Field

    JPEG2000Lossy Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly JPEG2000Lossy As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEG2000Lossy
    public static readonly UID JPEG2000Lossy
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEG2000Part2MulticomponentImageCompression Field

    JPEG2000Part2MulticomponentImageCompression Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly JPEG2000Part2MulticomponentImageCompression As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEG2000Part2MulticomponentImageCompression
    public static readonly UID JPEG2000Part2MulticomponentImageCompression
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEG2000Part2MulticomponentImageCompressionLosslessOnly Field

    JPEG2000Part2MulticomponentImageCompressionLosslessOnly Field
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly JPEG2000Part2MulticomponentImageCompressionLosslessOnly As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEG2000Part2MulticomponentImageCompressionLosslessOnly
    public static readonly UID JPEG2000Part2MulticomponentImageCompressionLosslessOnly
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGBaseline Field

    JPEGBaseline Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly JPEGBaseline As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEGBaseline
    public static readonly UID JPEGBaseline
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGExtended Field

    JPEGExtended Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly JPEGExtended As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEGExtended
    public static readonly UID JPEGExtended
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGExtendedHierarchicalProcess16and18 Field

    JPEGExtendedHierarchicalProcess16and18 Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementions")>
Public Shared ReadOnly JPEGExtendedHierarchicalProcess16and18 As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEGExtendedHierarchicalProcess16and18
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementions")]
public static readonly UID JPEGExtendedHierarchicalProcess16and18
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGExtendedHierarchicalProcess17and19 Field

    JPEGExtendedHierarchicalProcess17and19 Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly JPEGExtendedHierarchicalProcess17and19 As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEGExtendedHierarchicalProcess17and19
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID JPEGExtendedHierarchicalProcess17and19
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGExtendedProcess3and5 Field

    JPEGExtendedProcess3and5 Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly JPEGExtendedProcess3and5 As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEGExtendedProcess3and5
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID JPEGExtendedProcess3and5
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGFullProgressionHierarchicalProcess24and26 Field

    JPEGFullProgressionHierarchicalProcess24and26 Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly JPEGFullProgressionHierarchicalProcess24and26 As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEGFullProgressionHierarchicalProcess24and26
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID JPEGFullProgressionHierarchicalProcess24and26
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGFullProgressionHierarchicalProcess25and27 Field

    JPEGFullProgressionHierarchicalProcess25and27 Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementions")>
Public Shared ReadOnly JPEGFullProgressionHierarchicalProcess25and27 As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEGFullProgressionHierarchicalProcess25and27
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementions")]
public static readonly UID JPEGFullProgressionHierarchicalProcess25and27
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGFullProgressionNonHierarchicalProcess10and12 Field

    JPEGFullProgressionNonHierarchicalProcess10and12 Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementions")>
Public Shared ReadOnly JPEGFullProgressionNonHierarchicalProcess10and12 As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEGFullProgressionNonHierarchicalProcess10and12
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementions")]
public static readonly UID JPEGFullProgressionNonHierarchicalProcess10and12
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGFullProgressionNonHierarchicalProcess11and13 Field

    JPEGFullProgressionNonHierarchicalProcess11and13 Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementions")>
Public Shared ReadOnly JPEGFullProgressionNonHierarchicalProcess11and13 As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEGFullProgressionNonHierarchicalProcess11and13
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementions")]
public static readonly UID JPEGFullProgressionNonHierarchicalProcess11and13
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGLossless Field

    JPEGLossless Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly JPEGLossless As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEGLossless
    public static readonly UID JPEGLossless
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGLosslessFirstOrder Field

    JPEGLosslessFirstOrder Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly JPEGLosslessFirstOrder As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEGLosslessFirstOrder
    public static readonly UID JPEGLosslessFirstOrder
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGLosslessHierarchicalProcess28 Field

    JPEGLosslessHierarchicalProcess28 Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly JPEGLosslessHierarchicalProcess28 As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEGLosslessHierarchicalProcess28
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID JPEGLosslessHierarchicalProcess28
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGLosslessHierarchicalProcess29 Field

    JPEGLosslessHierarchicalProcess29 Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementions")>
Public Shared ReadOnly JPEGLosslessHierarchicalProcess29 As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEGLosslessHierarchicalProcess29
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementions")]
public static readonly UID JPEGLosslessHierarchicalProcess29
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGLosslessNonHierarchicalProcess15 Field

    JPEGLosslessNonHierarchicalProcess15 Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly JPEGLosslessNonHierarchicalProcess15 As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEGLosslessNonHierarchicalProcess15
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID JPEGLosslessNonHierarchicalProcess15
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGLSLossless Field

    JPEGLSLossless Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly JPEGLSLossless As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEGLSLossless
    public static readonly UID JPEGLSLossless
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGLSLossy Field

    JPEGLSLossy Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly JPEGLSLossy As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEGLSLossy
    public static readonly UID JPEGLSLossy
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGSpectralSelectionHierarchicalProcess20and22 Field

    JPEGSpectralSelectionHierarchicalProcess20and22 Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly JPEGSpectralSelectionHierarchicalProcess20and22 As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEGSpectralSelectionHierarchicalProcess20and22
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID JPEGSpectralSelectionHierarchicalProcess20and22
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGSpectralSelectionHierarchicalProcess21and23 Field

    JPEGSpectralSelectionHierarchicalProcess21and23 Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementions")>
Public Shared ReadOnly JPEGSpectralSelectionHierarchicalProcess21and23 As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEGSpectralSelectionHierarchicalProcess21and23
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementions")]
public static readonly UID JPEGSpectralSelectionHierarchicalProcess21and23
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGSpectralSelectionNonHierarchicalProcess6and8 Field

    JPEGSpectralSelectionNonHierarchicalProcess6and8 Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly JPEGSpectralSelectionNonHierarchicalProcess6and8 As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEGSpectralSelectionNonHierarchicalProcess6and8
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID JPEGSpectralSelectionNonHierarchicalProcess6and8
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGSpectralSelectionNonHierarchicalProcess7and9 Field

    JPEGSpectralSelectionNonHierarchicalProcess7and9 Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly JPEGSpectralSelectionNonHierarchicalProcess7and9 As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPEGSpectralSelectionNonHierarchicalProcess7and9
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID JPEGSpectralSelectionNonHierarchicalProcess7and9
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPIPReferenced Field

    JPIPReferenced Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly JPIPReferenced As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPIPReferenced
    public static readonly UID JPIPReferenced
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPIPReferencedDeflate Field

    JPIPReferencedDeflate Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly JPIPReferencedDeflate As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.JPIPReferencedDeflate
    public static readonly UID JPIPReferencedDeflate
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / MPEG2 Field

    MPEG2 Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly MPEG2 As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.MPEG2
    public static readonly UID MPEG2
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / MPEG2_HL Field

    MPEG2_HL Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly MPEG2_HL As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.MPEG2_HL
    public static readonly UID MPEG2_HL
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / MPEG4 Field

    MPEG4 Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly MPEG4 As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.MPEG4
    public static readonly UID MPEG4
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / MPEG4_BD Field

    MPEG4_BD Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly MPEG4_BD As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.MPEG4_BD
    public static readonly UID MPEG4_BD
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / RFC2557MIMEencapsulation Field

    RFC2557MIMEencapsulation Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly RFC2557MIMEencapsulation As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.RFC2557MIMEencapsulation
    public static readonly UID RFC2557MIMEencapsulation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / RLELossless Field

    RLELossless Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly RLELossless As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.RLELossless
    public static readonly UID RLELossless
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / XMLEncoding Field

    XMLEncoding Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly XMLEncoding As UID
    'Usage

Dim value As UID

value = TransferSyntaxes.XMLEncoding
    public static readonly UID XMLEncoding
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


%%PageItemTitle%%

DicomObjects.UIDs Namespace / UID Class
Members

In This Topic
    UID Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class UID
    'Usage

Dim instance As UID
    public class UID
    Inheritance Hierarchy

    System.Object
    DicomObjects.UIDs.UID

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    UID Members
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.UIDs Namespace / UID Class
Properties Methods

In This Topic
    UID Class Members
    In This Topic

    The following tables list the members exposed by UID.

    Public Properties
     | Name | Description
Public Property | Description |
Public Property | Name |
Public Property | Retired |
Public Property | Type |
Public Property | Value |
    Top
    Public Methods
     | Name | Description
static (Shared in Visual Basic) | Parse |
Public Method | ToString |
    Top
    Public Operators
    public Operator Implicit Type Conversion Overloaded.
    Top
    See Also

    Reference

    UID Class
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.UIDs Namespace / UID Class

    UID Class Methods
    In This Topic

    For a list of all members of this type, see UID members.

    Public Methods
     | Name | Description
static (Shared in Visual Basic) | Parse |
Public Method | ToString |
    Top
    See Also

    Reference

    UID Class
    DicomObjects.UIDs Namespace


DicomObjects.UIDs Namespace / UID Class / Parse Method

    Parse Method
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared Function Parse( _
   ByVal Value As String, _
   ByRef Name As String _
) As UID
    'Usage

Dim Value As String
Dim Name As String
Dim value As UID

value = UID.Parse(Value, Name)
    public static UID Parse(
   string Value,
   out string Name
)

    Parameters

    Value
    Name
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    UID Class
    UID Members


DicomObjects.UIDs Namespace / UID Class / ToString Method

    ToString Method (UID)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overrides Function ToString() As String
    'Usage

Dim instance As UID
Dim value As String

value = instance.ToString()
    public override string ToString()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    UID Class
    UID Members
    Base Implementation in ToString


%%PageItemTitle%% $$Properties$$

DicomObjects.UIDs Namespace / UID Class

    UID Class Properties
    In This Topic

    For a list of all members of this type, see UID members.

    Public Properties
     | Name | Description
Public Property | Description |
Public Property | Name |
Public Property | Retired |
Public Property | Type |
Public Property | Value |
    Top
    See Also

    Reference

    UID Class
    DicomObjects.UIDs Namespace


DicomObjects.UIDs Namespace / UID Class / Description Property

    Description Property (UID)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Description As String
    'Usage

Dim instance As UID
Dim value As String

value = instance.Description
    public string Description {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    UID Class
    UID Members


DicomObjects.UIDs Namespace / UID Class / Name Property

    Name Property (UID)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Name As String
    'Usage

Dim instance As UID
Dim value As String

value = instance.Name
    public string Name {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    UID Class
    UID Members


DicomObjects.UIDs Namespace / UID Class / Retired Property

    Retired Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Retired As Boolean
    'Usage

Dim instance As UID
Dim value As Boolean

value = instance.Retired
    public bool Retired {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    UID Class
    UID Members


DicomObjects.UIDs Namespace / UID Class / Type Property

    Type Property (UID)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Type As UIDType
    'Usage

Dim instance As UID
Dim value As UIDType

value = instance.Type
    public UIDType Type {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    UID Class
    UID Members


DicomObjects.UIDs Namespace / UID Class / Value Property

    Value Property (UID)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Value As String
    'Usage

Dim instance As UID
Dim value As String

value = instance.Value
    public string Value {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    UID Class
    UID Members


DicomObjects.UIDs Namespace / UID Class / Implicit Type Conversion Operator

    Implicit Type Conversion Operator
    Overload List
    Overload | Description
Implicit Type Conversion(UID,String) |
Implicit Type Conversion(String,UID) |
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    UID Class
    UID Members


%%PageItemTitle%%

DicomObjects.UIDs Namespace / WellKnownInstances Class
Members

In This Topic
    WellKnownInstances Class
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public MustInherit NotInheritable Class WellKnownInstances
    'Usage

Dim instance As WellKnownInstances
    public static class WellKnownInstances
    Inheritance Hierarchy

    System.Object
    DicomObjects.UIDs.WellKnownInstances

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Members
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.UIDs Namespace / WellKnownInstances Class
Fields

In This Topic
    WellKnownInstances Class Members
    In This Topic

    The following tables list the members exposed by WellKnownInstances.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | HotIronColorPaletteSOPInstance |
static (Shared in Visual Basic) | HotMetalBlueColorPaletteSOPInstance |
static (Shared in Visual Basic) | PET20StepColorPaletteSOPInstance |
static (Shared in Visual Basic) | PETColorPaletteSOPInstance |
static (Shared in Visual Basic) | Printer |
static (Shared in Visual Basic) | PrinterConfigurationRetrieval |
static (Shared in Visual Basic) | PrintQueue |
static (Shared in Visual Basic) | ProceduralEventLoggingSOPInstance |
static (Shared in Visual Basic) | StorageCommitmentPull |
static (Shared in Visual Basic) | StorageCommitmentPush |
static (Shared in Visual Basic) | SubstanceAdministrationLoggingSOPInstance |
static (Shared in Visual Basic) | UnifiedWorklistandProcedureStepSOPInstance |
    Top
    See Also

    Reference

    WellKnownInstances Class
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Fields$$

DicomObjects.UIDs Namespace / WellKnownInstances Class

    WellKnownInstances Class Fields
    In This Topic

    For a list of all members of this type, see WellKnownInstances members.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | HotIronColorPaletteSOPInstance |
static (Shared in Visual Basic) | HotMetalBlueColorPaletteSOPInstance |
static (Shared in Visual Basic) | PET20StepColorPaletteSOPInstance |
static (Shared in Visual Basic) | PETColorPaletteSOPInstance |
static (Shared in Visual Basic) | Printer |
static (Shared in Visual Basic) | PrinterConfigurationRetrieval |
static (Shared in Visual Basic) | PrintQueue |
static (Shared in Visual Basic) | ProceduralEventLoggingSOPInstance |
static (Shared in Visual Basic) | StorageCommitmentPull |
static (Shared in Visual Basic) | StorageCommitmentPush |
static (Shared in Visual Basic) | SubstanceAdministrationLoggingSOPInstance |
static (Shared in Visual Basic) | UnifiedWorklistandProcedureStepSOPInstance |
    Top
    See Also

    Reference

    WellKnownInstances Class
    DicomObjects.UIDs Namespace


DicomObjects.UIDs Namespace / WellKnownInstances Class / HotIronColorPaletteSOPInstance Field

    HotIronColorPaletteSOPInstance Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly HotIronColorPaletteSOPInstance As UID
    'Usage

Dim value As UID

value = WellKnownInstances.HotIronColorPaletteSOPInstance
    public static readonly UID HotIronColorPaletteSOPInstance
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


DicomObjects.UIDs Namespace / WellKnownInstances Class / HotMetalBlueColorPaletteSOPInstance Field

    HotMetalBlueColorPaletteSOPInstance Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly HotMetalBlueColorPaletteSOPInstance As UID
    'Usage

Dim value As UID

value = WellKnownInstances.HotMetalBlueColorPaletteSOPInstance
    public static readonly UID HotMetalBlueColorPaletteSOPInstance
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


DicomObjects.UIDs Namespace / WellKnownInstances Class / PET20StepColorPaletteSOPInstance Field

    PET20StepColorPaletteSOPInstance Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly PET20StepColorPaletteSOPInstance As UID
    'Usage

Dim value As UID

value = WellKnownInstances.PET20StepColorPaletteSOPInstance
    public static readonly UID PET20StepColorPaletteSOPInstance
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


DicomObjects.UIDs Namespace / WellKnownInstances Class / PETColorPaletteSOPInstance Field

    PETColorPaletteSOPInstance Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly PETColorPaletteSOPInstance As UID
    'Usage

Dim value As UID

value = WellKnownInstances.PETColorPaletteSOPInstance
    public static readonly UID PETColorPaletteSOPInstance
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


DicomObjects.UIDs Namespace / WellKnownInstances Class / Printer Field

    Printer Field (WellKnownInstances)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly Printer As UID
    'Usage

Dim value As UID

value = WellKnownInstances.Printer
    public static readonly UID Printer
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


DicomObjects.UIDs Namespace / WellKnownInstances Class / PrinterConfigurationRetrieval Field

    PrinterConfigurationRetrieval Field (WellKnownInstances)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly PrinterConfigurationRetrieval As UID
    'Usage

Dim value As UID

value = WellKnownInstances.PrinterConfigurationRetrieval
    public static readonly UID PrinterConfigurationRetrieval
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


DicomObjects.UIDs Namespace / WellKnownInstances Class / PrintQueue Field

    PrintQueue Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

<ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly PrintQueue As UID
    'Usage

Dim value As UID

value = WellKnownInstances.PrintQueue
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID PrintQueue
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


DicomObjects.UIDs Namespace / WellKnownInstances Class / ProceduralEventLoggingSOPInstance Field

    ProceduralEventLoggingSOPInstance Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly ProceduralEventLoggingSOPInstance As UID
    'Usage

Dim value As UID

value = WellKnownInstances.ProceduralEventLoggingSOPInstance
    public static readonly UID ProceduralEventLoggingSOPInstance
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


DicomObjects.UIDs Namespace / WellKnownInstances Class / StorageCommitmentPull Field

    StorageCommitmentPull Field (WellKnownInstances)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Retired UID - should not be used in new implementions")>
Public Shared ReadOnly StorageCommitmentPull As UID
    'Usage

Dim value As UID

value = WellKnownInstances.StorageCommitmentPull
    [EditorBrowsable(EditorBrowsableState.Advanced)]
[Obsolete("Retired UID - should not be used in new implementions")]
public static readonly UID StorageCommitmentPull
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


DicomObjects.UIDs Namespace / WellKnownInstances Class / StorageCommitmentPush Field

    StorageCommitmentPush Field (WellKnownInstances)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly StorageCommitmentPush As UID
    'Usage

Dim value As UID

value = WellKnownInstances.StorageCommitmentPush
    public static readonly UID StorageCommitmentPush
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


DicomObjects.UIDs Namespace / WellKnownInstances Class / SubstanceAdministrationLoggingSOPInstance Field

    SubstanceAdministrationLoggingSOPInstance Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly SubstanceAdministrationLoggingSOPInstance As UID
    'Usage

Dim value As UID

value = WellKnownInstances.SubstanceAdministrationLoggingSOPInstance
    public static readonly UID SubstanceAdministrationLoggingSOPInstance
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


DicomObjects.UIDs Namespace / WellKnownInstances Class / UnifiedWorklistandProcedureStepSOPInstance Field

    UnifiedWorklistandProcedureStepSOPInstance Field
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly UnifiedWorklistandProcedureStepSOPInstance As UID
    'Usage

Dim value As UID

value = WellKnownInstances.UnifiedWorklistandProcedureStepSOPInstance
    public static readonly UID UnifiedWorklistandProcedureStepSOPInstance
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


Inheritance Hierarchy
    DicomObjects.Validation Namespace
    Classes
     | Class | Description
Class | ValidationException |
Class | ValidationOptions |
    See Also

    Reference

    DicomObjects.Core Assembly


%%PageItemTitle%%

DicomObjects.Validation Namespace / ValidationException Class
Members

In This Topic
    ValidationException Class
    In This Topic
    Object Model
    ValidationException ClassDicomAttribute ClassDicomDataSet ClassDicomAttribute Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class ValidationException
   Inherits DicomObjects.DicomException
    'Usage

Dim instance As ValidationException
    public class ValidationException : DicomObjects.DicomException
    Inheritance Hierarchy

    System.Object
    System.Exception
    DicomObjects.DicomException
    DicomObjects.Validation.ValidationException

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationException Members
    DicomObjects.Validation Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Validation Namespace / ValidationException Class
Properties Methods

In This Topic
    ValidationException Class Members
    In This Topic

    The following tables list the members exposed by ValidationException.

    Public Properties
     | Name | Description
Public Property | Attribute |
Public Property | CausedAbort | True if this exception caused the related to association to issue an Abort (thereby no longer requiring to be closed) (Inherited from DicomObjects.DicomException)
Public Property | Code | The Error code (Inherited from DicomObjects.DicomException)
Public Property | Data | (Inherited from System.Exception)
Public Property | DataSet |
Public Property | Element |
Public Property | Group |
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Path |
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | Tag | A general purpose Tag for developer use (Inherited from DicomObjects.DicomException)
Public Property | TargetSite | (Inherited from System.Exception)
    Top
    Public Methods
     | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
    Top
    See Also

    Reference

    ValidationException Class
    DicomObjects.Validation Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.Validation Namespace / ValidationException Class

In This Topic
    ValidationException Class Properties
    In This Topic

    For a list of all members of this type, see ValidationException members.

    Public Properties
     | Name | Description
Public Property | Attribute |
Public Property | CausedAbort | True if this exception caused the related to association to issue an Abort (thereby no longer requiring to be closed) (Inherited from DicomObjects.DicomException)
Public Property | Code | The Error code (Inherited from DicomObjects.DicomException)
Public Property | Data | (Inherited from System.Exception)
Public Property | DataSet |
Public Property | Element |
Public Property | Group |
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Path |
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | Tag | A general purpose Tag for developer use (Inherited from DicomObjects.DicomException)
Public Property | TargetSite | (Inherited from System.Exception)
    Top
    See Also

    Reference

    ValidationException Class
    DicomObjects.Validation Namespace


DicomObjects.Validation Namespace / ValidationException Class / Attribute Property

    Attribute Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Attribute As DicomAttribute
    'Usage

Dim instance As ValidationException
Dim value As DicomAttribute

value = instance.Attribute
    public DicomAttribute Attribute {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationException Class
    ValidationException Members


DicomObjects.Validation Namespace / ValidationException Class / DataSet Property

    DataSet Property (ValidationException)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property DataSet As DicomDataSet
    'Usage

Dim instance As ValidationException
Dim value As DicomDataSet

value = instance.DataSet
    public DicomDataSet DataSet {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationException Class
    ValidationException Members


DicomObjects.Validation Namespace / ValidationException Class / Element Property

    Element Property (ValidationException)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Element As Integer
    'Usage

Dim instance As ValidationException
Dim value As Integer

value = instance.Element
    public int Element {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationException Class
    ValidationException Members


DicomObjects.Validation Namespace / ValidationException Class / Group Property

    Group Property (ValidationException)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Group As Integer
    'Usage

Dim instance As ValidationException
Dim value As Integer

value = instance.Group
    public int Group {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationException Class
    ValidationException Members


DicomObjects.Validation Namespace / ValidationException Class / Path Property

    Path Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public ReadOnly Property Path As List(Of ItemLocation)
    'Usage

Dim instance As ValidationException
Dim value As List(Of ItemLocation)

value = instance.Path
    public List<ItemLocation> Path {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationException Class
    ValidationException Members


%%PageItemTitle%%

DicomObjects.Validation Namespace / ValidationOptions Class
Members

In This Topic
    ValidationOptions Class
    In This Topic
    Object Model
    ValidationOptions ClassValidationOptions ClassValidationOptions ClassValidationOptions Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class ValidationOptions
    'Usage

Dim instance As ValidationOptions
    public class ValidationOptions
    Inheritance Hierarchy

    System.Object
    DicomObjects.Validation.ValidationOptions

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Members
    DicomObjects.Validation Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Validation Namespace / ValidationOptions Class
Properties Methods

In This Topic
    ValidationOptions Class Members
    In This Topic

    The following tables list the members exposed by ValidationOptions.

    Public Constructors
     | Name | Description
Public Constructor | ValidationOptions Constructor |
    Top
    Public Properties
     | Name | Description
static (Shared in Visual Basic) | All |
Public Property | CharacterSet |
Public Property | DataLength |
Public Property | Detailed |
Public Property | ForQuery |
static (Shared in Visual Basic) | None |
Public Property | PrivateAttributes |
Public Property | PrivateSequences |
static (Shared in Visual Basic) | Query |
    Top
    Public Methods
     | Name | Description
Public Method | Equals |
Public Method | GetHashCode |
    Top
    See Also

    Reference

    ValidationOptions Class
    DicomObjects.Validation Namespace


%%PageItemTitle%%

DicomObjects.Validation Namespace / ValidationOptions Class / ValidationOptions Constructor

In This Topic
    ValidationOptions Constructor
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New()
    'Usage

Dim instance As New ValidationOptions()
    public ValidationOptions()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members


%%PageItemTitle%% $$Methods$$

DicomObjects.Validation Namespace / ValidationOptions Class

    ValidationOptions Class Methods
    In This Topic

    For a list of all members of this type, see ValidationOptions members.

    Public Methods
     | Name | Description
Public Method | Equals |
Public Method | GetHashCode |
    Top
    See Also

    Reference

    ValidationOptions Class
    DicomObjects.Validation Namespace


DicomObjects.Validation Namespace / ValidationOptions Class / Equals Method

    Equals Method (ValidationOptions)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overrides Function Equals( _
   ByVal other As Object _
) As Boolean
    'Usage

Dim instance As ValidationOptions
Dim other As Object
Dim value As Boolean

value = instance.Equals(other)
    public override bool Equals(
   object other
)

    Parameters

    other
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members
    Base Implementation in Equals


DicomObjects.Validation Namespace / ValidationOptions Class / GetHashCode Method

    GetHashCode Method (ValidationOptions)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Overrides Function GetHashCode() As Integer
    'Usage

Dim instance As ValidationOptions
Dim value As Integer

value = instance.GetHashCode()
    public override int GetHashCode()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members
    Base Implementation in GetHashCode


%%PageItemTitle%% $$Properties$$

DicomObjects.Validation Namespace / ValidationOptions Class

    ValidationOptions Class Properties
    In This Topic

    For a list of all members of this type, see ValidationOptions members.

    Public Properties
     | Name | Description
static (Shared in Visual Basic) | All |
Public Property | CharacterSet |
Public Property | DataLength |
Public Property | Detailed |
Public Property | ForQuery |
static (Shared in Visual Basic) | None |
Public Property | PrivateAttributes |
Public Property | PrivateSequences |
static (Shared in Visual Basic) | Query |
    Top
    See Also

    Reference

    ValidationOptions Class
    DicomObjects.Validation Namespace


DicomObjects.Validation Namespace / ValidationOptions Class / All Property

    All Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly Property All As ValidationOptions
    'Usage

Dim value As ValidationOptions

value = ValidationOptions.All
    public static ValidationOptions All {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members


DicomObjects.Validation Namespace / ValidationOptions Class / CharacterSet Property

    CharacterSet Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property CharacterSet As Boolean
    'Usage

Dim instance As ValidationOptions
Dim value As Boolean

instance.CharacterSet = value

value = instance.CharacterSet
    public bool CharacterSet {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members


DicomObjects.Validation Namespace / ValidationOptions Class / DataLength Property

    DataLength Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property DataLength As Boolean
    'Usage

Dim instance As ValidationOptions
Dim value As Boolean

instance.DataLength = value

value = instance.DataLength
    public bool DataLength {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members


DicomObjects.Validation Namespace / ValidationOptions Class / Detailed Property

    Detailed Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Detailed As Boolean
    'Usage

Dim instance As ValidationOptions
Dim value As Boolean

instance.Detailed = value

value = instance.Detailed
    public bool Detailed {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members


DicomObjects.Validation Namespace / ValidationOptions Class / ForQuery Property

    ForQuery Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property ForQuery As Boolean
    'Usage

Dim instance As ValidationOptions
Dim value As Boolean

instance.ForQuery = value

value = instance.ForQuery
    public bool ForQuery {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members


DicomObjects.Validation Namespace / ValidationOptions Class / None Property

    None Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly Property None As ValidationOptions
    'Usage

Dim value As ValidationOptions

value = ValidationOptions.None
    public static ValidationOptions None {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members


DicomObjects.Validation Namespace / ValidationOptions Class / PrivateAttributes Property

    PrivateAttributes Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property PrivateAttributes As Boolean
    'Usage

Dim instance As ValidationOptions
Dim value As Boolean

instance.PrivateAttributes = value

value = instance.PrivateAttributes
    public bool PrivateAttributes {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members


DicomObjects.Validation Namespace / ValidationOptions Class / PrivateSequences Property

    PrivateSequences Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property PrivateSequences As Boolean
    'Usage

Dim instance As ValidationOptions
Dim value As Boolean

instance.PrivateSequences = value

value = instance.PrivateSequences
    public bool PrivateSequences {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members


DicomObjects.Validation Namespace / ValidationOptions Class / Query Property

    Query Property
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Shared ReadOnly Property Query As ValidationOptions
    'Usage

Dim value As ValidationOptions

value = ValidationOptions.Query
    public static ValidationOptions Query {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members


Inheritance Hierarchy
    DicomObjects.Video Namespace
    Classes
     | Class | Description
Class | VideoCompressionOptions | Control the encoding of video for either export, or for encoding into one of the DICOM video transfer syntaxes
    Enumerations
     | Enumeration | Description
Enumeration | Level | Video level enumerations
Enumeration | Profile | Video profile enumerations
    See Also

    Reference

    DicomObjects.Core Assembly


%%PageItemTitle%%

DicomObjects.Video Namespace / VideoCompressionOptions Class
Members

In This Topic
    VideoCompressionOptions Class
    In This Topic
    Control the encoding of video for either export, or for encoding into one of the DICOM video transfer syntaxes
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Class VideoCompressionOptions
    'Usage

Dim instance As VideoCompressionOptions
    public class VideoCompressionOptions
    Inheritance Hierarchy

    System.Object
    DicomObjects.Video.VideoCompressionOptions

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Members
    DicomObjects.Video Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Video Namespace / VideoCompressionOptions Class
Properties

In This Topic
    VideoCompressionOptions Class Members
    In This Topic

    The following tables list the members exposed by VideoCompressionOptions.

    Public Constructors
     | Name | Description
Public Constructor | VideoCompressionOptions Constructor | Construct a default set of compression options for a given image and output format
    Top
    Public Properties
     | Name | Description
Public Property | BitsPerSecond | The defined output rate in Bits per second
Public Property | Container | The name of the container ("format") to use when encoding.
Public Property | ExplicitCodec | The name of the video compression codec to use
Public Property | FirstFrame | The first frame of the video to export
Public Property | InputFilter | Filter to apply to raw frames before scaling etc.
Public Property | InputFrameRate | The rate at which the source frames are to be used.
Public Property | LastFrame | The last frame of the video to export
Public Property | Level | Video level to use
Public Property | OutputFilter | Filter to apply to scaled frames before passing to the codec
Public Property | OutputFrameRate | The rate at which frame are fed to the codec
Public Property | OutputSize | The size of the output frames to be encoded
Public Property | PaddingColour | Colour to use for any padding required if is not the same as the original DICOM image size
Public Property | Profile | The Video profile to use
Public Property | Scale | Controls whether to scale video if is not the same as the original DICOM image size
Public Property | UseWindowing | Controls whether data is put into the MPEG "raw" or via the presentaiton chain, including windowing
    Top
    See Also

    Reference

    VideoCompressionOptions Class
    DicomObjects.Video Namespace


%%PageItemTitle%%

DicomObjects.Video Namespace / VideoCompressionOptions Class / VideoCompressionOptions Constructor
The Image to be compressed to video
The output format - see remarks
If specified (may be null), then the specific codec is used - otherwise this can be selected internally based on the container
If set to a value convertable to an integer, then this is used to initialise the BitsPerSecond property

In This Topic
    VideoCompressionOptions Constructor
    In This Topic
    Construct a default set of compression options for a given image and output format
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Function New( _
   ByVal Image As DicomDataSet, _
   ByVal Format As String, _
   ByVal Codec As String, _
   ByVal Quality As Object _
)
    'Usage

Dim Image As DicomDataSet
Dim Format As String
Dim Codec As String
Dim Quality As Object

Dim instance As New VideoCompressionOptions(Image, Format, Codec, Quality)
    public VideoCompressionOptions(
   DicomDataSet Image,
   string Format,
   string Codec,
   object Quality
)

    Parameters

    Image
    The Image to be compressed to video
    Format
    The output format - see remarks
    Codec
    If specified (may be null), then the specific codec is used - otherwise this can be selected internally based on the container
    Quality
    If set to a value convertable to an integer, then this is used to initialise the BitsPerSecond property
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


%%PageItemTitle%% $$Properties$$

DicomObjects.Video Namespace / VideoCompressionOptions Class

    VideoCompressionOptions Class Properties
    In This Topic

    For a list of all members of this type, see VideoCompressionOptions members.

    Public Properties
     | Name | Description
Public Property | BitsPerSecond | The defined output rate in Bits per second
Public Property | Container | The name of the container ("format") to use when encoding.
Public Property | ExplicitCodec | The name of the video compression codec to use
Public Property | FirstFrame | The first frame of the video to export
Public Property | InputFilter | Filter to apply to raw frames before scaling etc.
Public Property | InputFrameRate | The rate at which the source frames are to be used.
Public Property | LastFrame | The last frame of the video to export
Public Property | Level | Video level to use
Public Property | OutputFilter | Filter to apply to scaled frames before passing to the codec
Public Property | OutputFrameRate | The rate at which frame are fed to the codec
Public Property | OutputSize | The size of the output frames to be encoded
Public Property | PaddingColour | Colour to use for any padding required if is not the same as the original DICOM image size
Public Property | Profile | The Video profile to use
Public Property | Scale | Controls whether to scale video if is not the same as the original DICOM image size
Public Property | UseWindowing | Controls whether data is put into the MPEG "raw" or via the presentaiton chain, including windowing
    Top
    See Also

    Reference

    VideoCompressionOptions Class
    DicomObjects.Video Namespace


DicomObjects.Video Namespace / VideoCompressionOptions Class / BitsPerSecond Property

    BitsPerSecond Property
    The defined output rate in Bits per second
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property BitsPerSecond As Integer
    'Usage

Dim instance As VideoCompressionOptions
Dim value As Integer

instance.BitsPerSecond = value

value = instance.BitsPerSecond
    public int BitsPerSecond {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / Container Property

    Container Property
    The name of the container ("format") to use when encoding.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Container As String
    'Usage

Dim instance As VideoCompressionOptions
Dim value As String

instance.Container = value

value = instance.Container
    public string Container {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / ExplicitCodec Property

    ExplicitCodec Property
    The name of the video compression codec to use
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property ExplicitCodec As String
    'Usage

Dim instance As VideoCompressionOptions
Dim value As String

instance.ExplicitCodec = value

value = instance.ExplicitCodec
    public string ExplicitCodec {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / FirstFrame Property

    FirstFrame Property
    The first frame of the video to export
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property FirstFrame As Integer
    'Usage

Dim instance As VideoCompressionOptions
Dim value As Integer

instance.FirstFrame = value

value = instance.FirstFrame
    public int FirstFrame {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / InputFilter Property

    InputFilter Property
    Filter to apply to raw frames before scaling etc.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property InputFilter As String
    'Usage

Dim instance As VideoCompressionOptions
Dim value As String

instance.InputFilter = value

value = instance.InputFilter
    public string InputFilter {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / InputFrameRate Property

    InputFrameRate Property
    The rate at which the source frames are to be used.
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property InputFrameRate As Integer
    'Usage

Dim instance As VideoCompressionOptions
Dim value As Integer

instance.InputFrameRate = value

value = instance.InputFrameRate
    public int InputFrameRate {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / LastFrame Property

    LastFrame Property
    The last frame of the video to export
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property LastFrame As Integer
    'Usage

Dim instance As VideoCompressionOptions
Dim value As Integer

instance.LastFrame = value

value = instance.LastFrame
    public int LastFrame {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / Level Property

    Level Property (VideoCompressionOptions)
    In This Topic
    Video level to use
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Level As Level
    'Usage

Dim instance As VideoCompressionOptions
Dim value As Level

instance.Level = value

value = instance.Level
    public Level Level {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / OutputFilter Property

    OutputFilter Property
    Filter to apply to scaled frames before passing to the codec
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property OutputFilter As String
    'Usage

Dim instance As VideoCompressionOptions
Dim value As String

instance.OutputFilter = value

value = instance.OutputFilter
    public string OutputFilter {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / OutputFrameRate Property

    OutputFrameRate Property
    The rate at which frame are fed to the codec
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property OutputFrameRate As Integer
    'Usage

Dim instance As VideoCompressionOptions
Dim value As Integer

instance.OutputFrameRate = value

value = instance.OutputFrameRate
    public int OutputFrameRate {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / OutputSize Property

    OutputSize Property
    The size of the output frames to be encoded
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property OutputSize As Size
    'Usage

Dim instance As VideoCompressionOptions
Dim value As Size

instance.OutputSize = value

value = instance.OutputSize
    public Size OutputSize {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / PaddingColour Property

    PaddingColour Property
    Colour to use for any padding required if is not the same as the original DICOM image size
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property PaddingColour As Color
    'Usage

Dim instance As VideoCompressionOptions
Dim value As Color

instance.PaddingColour = value

value = instance.PaddingColour
    public Color PaddingColour {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / Profile Property

    Profile Property
    The Video profile to use
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Profile As Profile
    'Usage

Dim instance As VideoCompressionOptions
Dim value As Profile

instance.Profile = value

value = instance.Profile
    public Profile Profile {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / Scale Property

    Scale Property (VideoCompressionOptions)
    In This Topic
    Controls whether to scale video if is not the same as the original DICOM image size
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property Scale As Boolean
    'Usage

Dim instance As VideoCompressionOptions
Dim value As Boolean

instance.Scale = value

value = instance.Scale
    public bool Scale {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / UseWindowing Property

    UseWindowing Property
    Controls whether data is put into the MPEG "raw" or via the presentaiton chain, including windowing
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Property UseWindowing As Boolean
    'Usage

Dim instance As VideoCompressionOptions
Dim value As Boolean

instance.UseWindowing = value

value = instance.UseWindowing
    public bool UseWindowing {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


%%PageItemTitle%%

DicomObjects.Video Namespace / Level Enumeration

    Level Enumeration
    In This Topic
    Video level enumerations
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum Level
   Inherits System.Enum
    'Usage

Dim instance As Level
    public enum Level : System.Enum
    Members
    Member | Description
MPEG2_High | MPEG 2 High level - as used in the MPEG-2 DICOM MP@HLtransfer syntax
MPEG2_High1440 | MPEG 2 High 1440 level (not generally used in DICOM)
MPEG2_Low | MPEG 2 Simple level (not generally used in DICOM)
MPEG2_Main | MPEG 2 Main level - as used in the MPEG-2 DICOM MP@MLtransfer syntax
MPEG4_41 | MPEG-4 AVC/H.264 Level 4.1 as used in the MPEG-4 AVC/H.264 HiP@Level4.1 transfer syntaxes
MPEG4_42 | MPEG-4 AVC/H.264 Level 4.2 as used in the MPEG-4 AVC/H.264 HiP@Level4.1 transfer syntaxes
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Video.Level

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Video Namespace


%%PageItemTitle%%

DicomObjects.Video Namespace / Profile Enumeration

    Profile Enumeration
    In This Topic
    Video profile enumerations
    Syntax
    • Visual Basic
    • C#
    'Declaration

Public Enum Profile
   Inherits System.Enum
    'Usage

Dim instance As Profile
    public enum Profile : System.Enum
    Members
    Member | Description
MPEG2_High | MPEG 2 High profile. This is not generally used in DICOM. Not to be confused with the High Level ( which is used in the DICOM MPEG2 MP@HL transfer syntax)
MPEG2_Main | MPEG 2 Main profile - as used in the MPEG-2 DICOM transfer syntaxes
MPEG2_Simple | MPEG 2 Simple profile. This is not generally used in DICOM.
MPEG4_High | MPEG-4 AVC/H.264 High profile as used in the MPEG-4 AVC/H.264 HiP@Level4.1 transfer syntaxes
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Video.Profile

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Video Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / JpegLossless Class

    JpegLossless Class Properties
    In This Topic

    For a list of all members of this type, see JpegLossless members.

    Public Properties
     | Name | Description
Public Property | MaximumBits | (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Property | NeedsPlanarConfigTransform | (Inherited from DicomObjects.Codecs.SimpleCodec)
    Top
    See Also

    Reference

    JpegLossless Class
    DicomObjects.Codecs Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

    DicomObjects.Codecs Namespace Inheritance Hierarchy
    Inheritance Hierarchy
    System.Object
    DicomObjects.Codecs.CodecFactory
    DicomObjects.Codecs.CodecGlobal
    DicomObjects.Codecs.DicomCodecBaseArguments
    DicomObjects.Codecs.CompressionArguments
    DicomObjects.Codecs.DecompressionArguments
    DicomObjects.Codecs.ImportArguments
    DicomObjects.Codecs.ModificationArguments
    DicomObjects.Codecs.Jpeg2000CompressionOptions
    DicomObjects.Codecs.JpegLossy
    DicomObjects.Codecs.JpegLSCompressionOptions
    DicomObjects.Codecs.Jpip
    DicomObjects.Codecs.SimpleCodec
    DicomObjects.Codecs.JpegLossless
    See Also

    Reference

    DicomObjects.Core Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

    DicomObjects.Delegates Namespace Inheritance Hierarchy
    Inheritance Hierarchy
    System.Object
    See Also

    Reference

    DicomObjects.Core Assembly


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomException Class

    DicomException Class Methods
    In This Topic

    For a list of all members of this type, see DicomException members.

    Public Methods
     | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
    Top
    See Also

    Reference

    DicomException Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / DicomPrint Class
Members

In This Topic
    DicomPrint Class
    In This Topic
    An object to simply printing to a DICOM printer
    Object Model
    DicomPrint ClassDicomDataSetCollection ClassDicomDataSet ClassDicomAssociation ClassDicomDataSet ClassDicomAttribute ClassDicomDataSet ClassDicomAttribute ClassDicomDataSet ClassDicomAttribute ClassDicomDataSet ClassDicomAttribute Class
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public Class DicomPrint
    'Usage

    Dim instance As DicomPrint
    public class DicomPrint
    public ref class DicomPrint
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomPrint

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomPrint Class
Properties Methods

In This Topic
    DicomPrint Class Members
    In This Topic

    The following tables list the members exposed by DicomPrint.

    Public Constructors
     | Name | Description
Public Constructor | DicomPrint Constructor | Creates a DicomPrint object
    Top
    Public Properties
     | Name | Description
Public Property | AnnotationFormat | Common printing variable, the annotation format
Public Property | Annotations | DataSets containing annotations to add to a film
Public Property | BitDepth | The bit depth to send to the printer
Public Property | Colour | Controls whether monochrome of colour printing is attempted
Public Property | Connection | Reference to the underlying DicomAssociation object used by a DicomPrint object
Public Property | Copies | Common printing variable, number of copies to print
Public Property | FilmBox | Over-rides of default values for Film Box Object
Public Property | FilmSize | Common printing variable, the size of the film
Public Property | Format | Common printing variable, the printing format
Public Property | ImageBox | Over-rides of default values for Image Box Object
Public Property | MetaSOPClass | Returns the Meta SOP Class used during the printing session
Public Property | NextPosition | Indicates/Controls the next image box to be used by PrintImage
Public Property | Orientation | Common printing variable, the printing orientation
Public Property | Printer | The well known Printer Instance (as a DicomDataSet)
Public Property | Session | Over-rides of default values for Film Session Object
Public Property | Tag | A general purpose Tag for developer use
    Top
    Public Methods
     | Name | Description
Public Method | AddAnnotation | Adds an Annotation to the Annotations collection
Public Method | CheckStatus | Check Print Status and return success or error message
Public Method | Close | Closes an association to a DICOM printer, completing any pending print operations
Public Method | Open | Opens an association to a DICOM printer for printing
Public Method | PrintFilm | Print current film
Public Method | PrintImage |
    Top
    See Also

    Reference

    DicomPrint Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / DicomPrint Class / DicomPrint Constructor

In This Topic
    DicomPrint Constructor
    In This Topic
    Creates a DicomPrint object
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public Function New()
    'Usage

    Dim instance As New DicomPrint()
    public DicomPrint()
    public:
DicomPrint();

    Return Value

    DicomPrint
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / AddAnnotation Method

ID of Annotation to be added

Text value of the annotation to be added

In This Topic
    AddAnnotation Method
    In This Topic
    Adds an Annotation to the Annotations collection
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public Sub AddAnnotation( _
   ByVal AnnotationID As Integer, _
   ByVal AnnotationString As String _
)
    'Usage

    Dim instance As DicomPrint
Dim AnnotationID As Integer
Dim AnnotationString As String

instance.AddAnnotation(AnnotationID, AnnotationString)
    public void AddAnnotation(
   int AnnotationID,
   string AnnotationString
)
    public:
void AddAnnotation(
   int AnnotationID,
   String^ AnnotationString
)

    Parameters

    AnnotationID

    ID of Annotation to be added

    AnnotationString

    Text value of the annotation to be added

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / AnnotationFormat Property

    AnnotationFormat Property
    Common printing variable, the annotation format
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public Property AnnotationFormat As String
    'Usage

    Dim instance As DicomPrint
Dim value As String

instance.AnnotationFormat = value

value = instance.AnnotationFormat
    public string AnnotationFormat {get; set;}
    public:
property String^ AnnotationFormat {
   String^ get();
   void set (    String^ value);
}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / Annotations Property

    Annotations Property
    DataSets containing annotations to add to a film
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public ReadOnly Property Annotations As DicomDataSetCollection
    'Usage

    Dim instance As DicomPrint
Dim value As DicomDataSetCollection

value = instance.Annotations
    public DicomDataSetCollection Annotations {get;}
    public:
property DicomDataSetCollection^ Annotations {
   DicomDataSetCollection^ get();
}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / BitDepth Property

    BitDepth Property
    The bit depth to send to the printer
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public Property BitDepth As Integer
    'Usage

    Dim instance As DicomPrint
Dim value As Integer

instance.BitDepth = value

value = instance.BitDepth
    public int BitDepth {get; set;}
    public:
property int BitDepth {
   int get();
   void set (    int value);
}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / CheckStatus Method
String

    CheckStatus Method
    In This Topic
    Check Print Status and return success or error message
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public Sub CheckStatus( _
   ByVal Message As String _
)
    'Usage

    Dim instance As DicomPrint
Dim Message As String

instance.CheckStatus(Message)
    public void CheckStatus(
   string Message
)
    public:
void CheckStatus(
   String^ Message
)

    Parameters

    Message
    String
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / Close Method

    Close Method (DicomPrint)
    In This Topic
    Closes an association to a DICOM printer, completing any pending print operations
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public Sub Close()
    'Usage

    Dim instance As DicomPrint

instance.Close()
    public void Close()
    public:
void Close();
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / Colour Property

    Colour Property
    Controls whether monochrome of colour printing is attempted
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public Property Colour As Boolean
    'Usage

    Dim instance As DicomPrint
Dim value As Boolean

instance.Colour = value

value = instance.Colour
    public bool Colour {get; set;}
    public:
property bool Colour {
   bool get();
   void set (    bool value);
}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / Connection Property

    Connection Property
    Reference to the underlying DicomAssociation object used by a DicomPrint object
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public ReadOnly Property Connection As DicomAssociation
    'Usage

    Dim instance As DicomPrint
Dim value As DicomAssociation

value = instance.Connection
    public DicomAssociation Connection {get;}
    public:
property DicomAssociation^ Connection {
   DicomAssociation^ get();
}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / Copies Property

    Copies Property
    Common printing variable, number of copies to print
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public Property Copies As Short
    'Usage

    Dim instance As DicomPrint
Dim value As Short

instance.Copies = value

value = instance.Copies
    public short Copies {get; set;}
    public:
property short Copies {
   short get();
   void set (    short value);
}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / FilmBox Property

    FilmBox Property
    Over-rides of default values for Film Box Object
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public ReadOnly Property FilmBox As DicomDataSet
    'Usage

    Dim instance As DicomPrint
Dim value As DicomDataSet

value = instance.FilmBox
    public DicomDataSet FilmBox {get;}
    public:
property DicomDataSet^ FilmBox {
   DicomDataSet^ get();
}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / FilmSize Property

    FilmSize Property
    Common printing variable, the size of the film
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public Property FilmSize As String
    'Usage

    Dim instance As DicomPrint
Dim value As String

instance.FilmSize = value

value = instance.FilmSize
    public string FilmSize {get; set;}
    public:
property String^ FilmSize {
   String^ get();
   void set (    String^ value);
}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / Format Property

    Format Property
    Common printing variable, the printing format
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public Property Format As String
    'Usage

    Dim instance As DicomPrint
Dim value As String

instance.Format = value

value = instance.Format
    public string Format {get; set;}
    public:
property String^ Format {
   String^ get();
   void set (    String^ value);
}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / ImageBox Property

    ImageBox Property
    Over-rides of default values for Image Box Object
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public ReadOnly Property ImageBox As DicomDataSet
    'Usage

    Dim instance As DicomPrint
Dim value As DicomDataSet

value = instance.ImageBox
    public DicomDataSet ImageBox {get;}
    public:
property DicomDataSet^ ImageBox {
   DicomDataSet^ get();
}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / MetaSOPClass Property

    MetaSOPClass Property (DicomPrint)
    In This Topic
    Returns the Meta SOP Class used during the printing session
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public ReadOnly Property MetaSOPClass As String
    'Usage

    Dim instance As DicomPrint
Dim value As String

value = instance.MetaSOPClass
    public string MetaSOPClass {get;}
    public:
property String^ MetaSOPClass {
   String^ get();
}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / NextPosition Property

    NextPosition Property
    Indicates/Controls the next image box to be used by PrintImage
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public Property NextPosition As Integer
    'Usage

    Dim instance As DicomPrint
Dim value As Integer

instance.NextPosition = value

value = instance.NextPosition
    public int NextPosition {get; set;}
    public:
property int NextPosition {
   int get();
   void set (    int value);
}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / Open Method

Network address (as dotted notation or resolvable name) to which the association is to be made

Port on which remote application is listening

Name to quote for this Application Entity

Name of remote Application Entity

In This Topic
    Open Method (DicomPrint)
    In This Topic
    Opens an association to a DICOM printer for printing
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public Sub Open( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAE As String, _
   ByVal CalledAE As String _
)
    'Usage

    Dim instance As DicomPrint
Dim Node As String
Dim Port As Integer
Dim CallingAE As String
Dim CalledAE As String

instance.Open(Node, Port, CallingAE, CalledAE)
    public void Open(
   string Node,
   int Port,
   string CallingAE,
   string CalledAE
)
    public:
void Open(
   String^ Node,
   int Port,
   String^ CallingAE,
   String^ CalledAE
)

    Parameters

    Node

    Network address (as dotted notation or resolvable name) to which the association is to be made

    Port

    Port on which remote application is listening

    CallingAE

    Name to quote for this Application Entity

    CalledAE

    Name of remote Application Entity

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / Orientation Property

    Orientation Property
    Common printing variable, the printing orientation
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public Property Orientation As String
    'Usage

    Dim instance As DicomPrint
Dim value As String

instance.Orientation = value

value = instance.Orientation
    public string Orientation {get; set;}
    public:
property String^ Orientation {
   String^ get();
   void set (    String^ value);
}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / Printer Property

    Printer Property
    The well known Printer Instance (as a DicomDataSet)
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public ReadOnly Property Printer As DicomDataSet
    'Usage

    Dim instance As DicomPrint
Dim value As DicomDataSet

value = instance.Printer
    public DicomDataSet Printer {get;}
    public:
property DicomDataSet^ Printer {
   DicomDataSet^ get();
}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / PrintFilm Method

    PrintFilm Method
    Print current film
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public Sub PrintFilm()
    'Usage

    Dim instance As DicomPrint

instance.PrintFilm()
    public void PrintFilm()
    public:
void PrintFilm();
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / PrintImage Method

    PrintImage Method
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public Sub PrintImage( _
   ByVal Image As DicomDataSet, _
   ByVal Raw As Boolean _
)
    'Usage

    Dim instance As DicomPrint
Dim Image As DicomDataSet
Dim Raw As Boolean

instance.PrintImage(Image, Raw)
    public void PrintImage(
   DicomDataSet Image,
   bool Raw
)
    public:
void PrintImage(
   DicomDataSet^ Image,
   bool Raw
)

    Parameters

    Image
    Raw
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / Session Property

    Session Property
    Over-rides of default values for Film Session Object
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public ReadOnly Property Session As DicomDataSet
    'Usage

    Dim instance As DicomPrint
Dim value As DicomDataSet

value = instance.Session
    public DicomDataSet Session {get;}
    public:
property DicomDataSet^ Session {
   DicomDataSet^ get();
}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / Tag Property

    Tag Property (DicomPrint)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    • C++/CLI
    'Declaration

    Public Property Tag As Object
    'Usage

    Dim instance As DicomPrint
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    public:
property Object^ Tag {
   Object^ get();
   void set (    Object^ value);
}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

    DicomObjects.DicomWeb.Delegates Namespace Inheritance Hierarchy
    In This Topic
    Inheritance Hierarchy
    System.Object
    See Also

    Reference

    DicomObjects.Core Assembly


%%PageItemTitle%% $$Properties$$

DicomObjects.DicomWeb Namespace / StowWebClient Class

    StowWebClient Class Properties
    In This Topic

    For a list of all members of this type, see StowWebClient members.

    Public Properties
     | Name | Description
Public Property | CertFile | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | CertPassword | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | JsonResponseWeight | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | Result | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
Public Property | XmlResponseWeight | (Inherited from DicomObjects.DicomWeb.DicomWebClient)
    Top
    See Also

    Reference

    StowWebClient Class
    DicomObjects.DicomWeb Namespace


%%PageItemTitle%%

DicomObjects.DicomWeb Namespace / WebContent Class / WebContent Constructor

In This Topic
    WebContent Constructor
    In This Topic
    Overload List
    Overload | Description
WebContent Constructor |
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WebContent Class
    WebContent Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

    DicomObjects.DicomWeb Namespace Inheritance Hierarchy
    Inheritance Hierarchy
    System.Object
    DicomObjects.DicomWeb.ContentType
    DicomObjects.DicomWeb.DicomWebClient
    DicomObjects.DicomWeb.QidoWebClient
    DicomObjects.DicomWeb.StowWebClient
    DicomObjects.DicomWeb.WadoWebClient
    DicomObjects.DicomWeb.DicomWebServer
    DicomObjects.DicomWeb.QidoEventArgs
    DicomObjects.DicomWeb.RestfulController
    DicomObjects.DicomWeb.RestfulRequest
    DicomObjects.DicomWeb.RestfulResponse
    DicomObjects.DicomWeb.StowEventArgs
    DicomObjects.DicomWeb.WadoEventArgs
    DicomObjects.DicomWeb.WebContent
    See Also

    Reference

    DicomObjects.Core Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

    DicomObjects.Enums Namespace Inheritance Hierarchy
    Inheritance Hierarchy
    System.Object
    See Also

    Reference

    DicomObjects.Core Assembly


DicomObjects.EventArguments Namespace / AssociationRequestArgs Class / Reject Method

    Reject Method (AssociationRequestArgs)
    In This Topic
    Reject a whole association request
    Overload List
    Overload | Description
Reject | Reject a whole association request
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    AssociationRequestArgs Class
    AssociationRequestArgs Members


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / NormalisedReceivedArgs Class

In This Topic
    NormalisedReceivedArgs Class Properties
    In This Topic

    For a list of all members of this type, see NormalisedReceivedArgs members.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
    Top
    See Also

    Reference

    NormalisedReceivedArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / VerifyReceivedArgs Class

In This Topic
    VerifyReceivedArgs Class Properties
    In This Topic

    For a list of all members of this type, see VerifyReceivedArgs members.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
    Top
    See Also

    Reference

    VerifyReceivedArgs Class
    DicomObjects.EventArguments Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

    DicomObjects.EventArguments Namespace Inheritance Hierarchy
    Inheritance Hierarchy
    System.Object
    DicomObjects.EventArguments.AssociationClosedArgs
    DicomObjects.EventArguments.ChangeUidArgs
    DicomObjects.EventArguments.ErrorReceivedArgs
    DicomObjects.EventArguments.InfoMessageArgs
    DicomObjects.EventArguments.LogEventArgs
    DicomObjects.EventArguments.ReceivingPixelDataArgs
    DicomObjects.EventArguments.ValidateFragmentsArgs
    System.EventArgs
    DicomObjects.EventArguments.AssociationRequestArgs
    DicomObjects.EventArguments.CStoreRequestArgs
    DicomObjects.EventArguments.OperationBaseArgs
    DicomObjects.EventArguments.InstanceReceivedArgs
    DicomObjects.EventArguments.N_Event_ReportArgs
    DicomObjects.EventArguments.NormalisedReceivedArgs
    DicomObjects.EventArguments.QueryReceivedArgs
    DicomObjects.EventArguments.VerifyReceivedArgs
    DicomObjects.EventArguments.ResponseReceivedArgs
    See Also

    Reference

    DicomObjects.Core Assembly


DicomObjects.UIDs Namespace / UID Class / Implicit Type Conversion Operator / Implicit Type Conversion(String,UID) Operator

    Implicit Type Conversion(String,UID) Operator
    Syntax
    • Visual Basic
    • C#
    'Declaration

Overloads Public Operator Widening CType( _
   ByVal uid As UID _
) As String
    'Usage

    public string operator implicit(
   UID uid
)

    Parameters

    uid
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    UID Class
    UID Members
    Overload List


DicomObjects.UIDs Namespace / UID Class / Implicit Type Conversion Operator / Implicit Type Conversion(UID,String) Operator

    Implicit Type Conversion(UID,String) Operator
    Syntax
    • Visual Basic
    • C#
    'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As String _
) As UID
    'Usage

    public UID operator implicit(
   string value
)

    Parameters

    value
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    UID Class
    UID Members
    Overload List


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

    DicomObjects.UIDs Namespace Inheritance Hierarchy
    Inheritance Hierarchy
    System.Object
    DicomObjects.UIDs.ApplicationContexts
    DicomObjects.UIDs.FramesOfReference
    DicomObjects.UIDs.MetaSOPClasses
    DicomObjects.UIDs.SOPClasses
    DicomObjects.UIDs.TransferSyntaxes
    DicomObjects.UIDs.UID
    DicomObjects.UIDs.WellKnownInstances
    See Also

    Reference

    DicomObjects.Core Assembly


%%PageItemTitle%% $$Methods$$

DicomObjects.Validation Namespace / ValidationException Class

In This Topic
    ValidationException Class Methods
    In This Topic

    For a list of all members of this type, see ValidationException members.

    Public Methods
     | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
    Top
    See Also

    Reference

    ValidationException Class
    DicomObjects.Validation Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

    DicomObjects.Validation Namespace Inheritance Hierarchy
    Inheritance Hierarchy
    System.Object
    DicomObjects.Validation.ValidationOptions
    System.Exception
    DicomObjects.DicomException
    DicomObjects.Validation.ValidationException
    See Also

    Reference

    DicomObjects.Core Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

    DicomObjects.Video Namespace Inheritance Hierarchy
    Inheritance Hierarchy
    System.Object
    DicomObjects.Video.VideoCompressionOptions
    See Also

    Reference

    DicomObjects.Core Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

    DicomObjects Namespace Inheritance Hierarchy
    Inheritance Hierarchy
    System.Object
    DicomObjects.DicomAssociation
    DicomObjects.DicomAttribute
    DicomObjects.DicomContext
    DicomObjects.DicomDataSet
    DicomObjects.DicomGlobal
    DicomObjects.DicomLicence
    DicomObjects.DicomMaskRange
    DicomObjects.DicomQuery
    DicomObjects.DicomServer
    DicomObjects.ReadBehaviours
    DicomObjects.SequencePath
    DicomObjects.WriteBehaviours
    System.Collections.ObjectModel.Collection<T>
    DicomObjects.DicomDataSetCollection
    System.Collections.ObjectModel.KeyedCollection<TKey,TItem>
    DicomObjects.DicomContextCollection
    System.Exception
    DicomObjects.DicomException
    DicomObjects.Validation.ValidationException
    See Also

    Reference

    DicomObjects.Core Assembly